Gallio

Gallio API Documentation
Gallio Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ActionChain | An action chain captures a sequence of actions to be performed as part of a complex multi-part process.
Public class | ActionChain | An action chain captures a sequence of actions to be performed as part of a complex multi-part process.
Public class | FuncChain | A function chain captures a sequence of actions to be performed as part of a complex multi-part process.

Interfaces

 | Interface | Description
Public interface | ICloneable | Provides a typed clone operation.

Structures

 | Structure | Description
Public structure | Pair | An immutable record that holds two values.
Public structure | Triple | An immutable record that holds three values.

Delegates

 | Delegate | Description
Public delegate | Action | An action with no arguments.
Public delegate | Action | An action with two arguments.
Public delegate | Action | An action with three arguments.
Public delegate | Action | An action with four arguments.
Public delegate | ActionDecorator | Represents a delegate that decorates an action.
Public delegate | ActionDecorator | Represents a delegate that decorates an action.
Public delegate | Func | A function with zero arguments.
Public delegate | Func | A function with one argument.
Public delegate | Func | A function with two arguments.
Public delegate | Func | A function with three arguments.
Public delegate | Func | A function with four arguments.
Public delegate | FuncDecorator | Represents a delegate that decorates a function.

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/


Action Delegate

Action Delegate
See Also Example
[image]

An action with no arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Action()
C#
public delegate void Action()
C++
public delegate void Action()
J#
/** delegate */
public delegate void Action()
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Gallio Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio [3.0.6.0]


Action Generic Delegate

Action Generic Delegate
[image]

An action with two arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Action(Of T1, T2)( _
ByVal arg1 As T1, _
ByVal arg2 As T2 _
)
C#
public delegate void Action<T1, T2>(
T1 arg1,
T2 arg2
)
C++
public delegate void Action<T1, T2>(
T1 arg1,
T2 arg2
)
J#
/** delegate */
public delegate void Action<T1, T2>(
T1 arg1,
T2 arg2
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type

Parameters

arg1
The first argument
arg2
The second argument

See Also

Gallio Namespace


Action Generic Delegate

Action Generic Delegate
[image]

An action with three arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Action(Of T1, T2, T3)( _
ByVal arg1 As T1, _
ByVal arg2 As T2, _
ByVal arg3 As T3 _
)
C#
public delegate void Action<T1, T2, T3>(
T1 arg1,
T2 arg2,
T3 arg3
)
C++
public delegate void Action<T1, T2, T3>(
T1 arg1,
T2 arg2,
T3 arg3
)
J#
/** delegate */
public delegate void Action<T1, T2, T3>(
T1 arg1,
T2 arg2,
T3 arg3
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type
T3
The third argument type

Parameters

arg1
The first argument
arg2
The second argument
arg3
The third argument

See Also

Gallio Namespace


Action Generic Delegate

Action Generic Delegate
[image]

An action with four arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Action(Of T1, T2, T3, T4)( _
ByVal arg1 As T1, _
ByVal arg2 As T2, _
ByVal arg3 As T3, _
ByVal arg4 As T4 _
)
C#
public delegate void Action<T1, T2, T3, T4>(
T1 arg1,
T2 arg2,
T3 arg3,
T4 arg4
)
C++
public delegate void Action<T1, T2, T3, T4>(
T1 arg1,
T2 arg2,
T3 arg3,
T4 arg4
)
J#
/** delegate */
public delegate void Action<T1, T2, T3, T4>(
T1 arg1,
T2 arg2,
T3 arg3,
T4 arg4
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type
T3
The third argument type
T4
The fourth argument type

Parameters

arg1
The first argument
arg2
The second argument
arg3
The third argument
arg4
The fourth argument

See Also

Gallio Namespace


ActionChain Generic Class

ActionChain Generic Class
See Also Example Members
[image]

An action chain captures a sequence of actions to be performed as part of a complex multi-part process.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ActionChain(Of T)
C#
public class ActionChain<T>
C++
ref class ActionChain<T>
J#
public class ActionChain<T>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The action argument type

Remarks

Later actions in a chain will not run if prior ones throw an exception. To catch and handle exceptions, use Around to register a decorator that runs around the current action whose execution is then under your control.

Inheritance Hierarchy

System.Object
Gallio.ActionChain<T>

See Also

ActionChain<T> Members
Gallio Namespace


ActionChain<T> Members

ActionChain Members
See Also Example Constructors Fields Properties Methods
[image]

An action chain captures a sequence of actions to be performed as part of a complex multi-part process.

The following tables list the members exposed by ActionChain<T>.

Public Constructors

 | Name | Description
Public method | ActionChain | Initializes a new instance of the ActionChain class.
Top

Public Fields

Name | Description
NoOp | Gets a singleton action that does nothing when invoked. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | Action | Gets or sets a representation of the chain as a single action. The action is progressively augmented as new contributions are registered using Before, After and Around. By default the action is NoOp.
Top

Public Methods

 | Name | Description
Public method | After | Registers an action to perform after all other actions currently in the chain.
Public method | Around | Registers an action to perform around all other actions currently in the chain. The contained part of the chain is passed in as an action to the decorator that the decorator can choose to run (or not) as needed.
Public method | Before | Registers an action to perform before all other actions currently in the chain.
Public method | Clear | Clears the chain and sets it action to NoOp.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ActionChain<T> Class
Gallio Namespace


ActionChain Constructor

ActionChain Constructor
[image]

Initializes a new instance of the ActionChain class.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ActionChain()
C++
public:
ActionChain() sealed
J#
public ActionChain()
JScript
JScript does not support generic types and methods.

See Also

ActionChain<T> Class
Gallio Namespace


Fields

ActionChain Fields
[image]

Public Fields

Name | Description
NoOp | Gets a singleton action that does nothing when invoked. This field is read-only.
Top

See Also

ActionChain<T> Class
Gallio Namespace


NoOp Field

ActionChain.NoOp Field
[image]

Gets a singleton action that does nothing when invoked. This field is read-only.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NoOp As Action(Of T)
C#
public static readonly Action<T> NoOp;
C++
public:
static const Action<T> NoOp;
J#
public static final Action<T> NoOp
JScript
JScript does not support generic types and methods.

See Also

ActionChain<T> Class
Gallio Namespace


Properties

ActionChain Properties
[image]

Public Properties

 | Name | Description
Public property | Action | Gets or sets a representation of the chain as a single action. The action is progressively augmented as new contributions are registered using Before, After and Around. By default the action is NoOp.
Top

See Also

ActionChain<T> Class
Gallio Namespace


Action Property

ActionChain.Action Property
[image]

Gets or sets a representation of the chain as a single action.

The action is progressively augmented as new contributions are registered using Before, After and Around. By default the action is NoOp.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Action As Action(Of T)
C#
public Action<T> Action { get; set; }
C++
public property Action<T> Action sealed {
Action<T> get();
void set(Action<T> value);
}
J#
/** property */
public Action<T> get_Action();

/** property */
public void set_Action(Action<T> value);
JScript
JScript does not support generic types and methods.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ActionChain<T> Class
Gallio Namespace


Methods

ActionChain Methods
[image]

Public Methods

 | Name | Description
Public method | After | Registers an action to perform after all other actions currently in the chain.
Public method | Around | Registers an action to perform around all other actions currently in the chain. The contained part of the chain is passed in as an action to the decorator that the decorator can choose to run (or not) as needed.
Public method | Before | Registers an action to perform before all other actions currently in the chain.
Public method | Clear | Clears the chain and sets it action to NoOp.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ActionChain<T> Class
Gallio Namespace


After Method

ActionChain.After Method
[image]

Registers an action to perform after all other actions currently in the chain.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub After( _
ByVal action As Action(Of T) _
)
C#
public void After(
Action<T> action
)
C++
public:
void After(
Action<T> action
) sealed
J#
public void After(
Action<T> action
)
JScript
JScript does not support generic types and methods.

Parameters

action
The action to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

The value of Action will be set to a new instance that performs the specified action after the current Action.

See Also

ActionChain<T> Class
Gallio Namespace


Around Method

ActionChain.Around Method
[image]

Registers an action to perform around all other actions currently in the chain. The contained part of the chain is passed in as an action to the decorator that the decorator can choose to run (or not) as needed.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Around( _
ByVal decorator As ActionDecorator(Of T) _
)
C#
public void Around(
ActionDecorator<T> decorator
)
C++
public:
void Around(
ActionDecorator<T> decorator
) sealed
J#
public void Around(
ActionDecorator<T> decorator
)
JScript
JScript does not support generic types and methods.

Parameters

decorator
The decorator to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if decorator is null

Remarks

The value of Action will be set to a new instance that performs the specified decorator around the current Action.

See Also

ActionChain<T> Class
Gallio Namespace


Before Method

ActionChain.Before Method
[image]

Registers an action to perform before all other actions currently in the chain.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Before( _
ByVal action As Action(Of T) _
)
C#
public void Before(
Action<T> action
)
C++
public:
void Before(
Action<T> action
) sealed
J#
public void Before(
Action<T> action
)
JScript
JScript does not support generic types and methods.

Parameters

action
The action to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

The value of Action will be set to a new instance that performs the specified action before the current Action.

See Also

ActionChain<T> Class
Gallio Namespace


Clear Method

ActionChain.Clear Method
[image]

Clears the chain and sets it action to NoOp.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
JScript does not support generic types and methods.

See Also

ActionChain<T> Class
Gallio Namespace


ActionChain Generic Class

ActionChain Generic Class
See Also Example Members
[image]

An action chain captures a sequence of actions to be performed as part of a complex multi-part process.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ActionChain(Of T1, T2)
C#
public class ActionChain<T1, T2>
C++
ref class ActionChain<T1, T2>
J#
public class ActionChain<T1, T2>
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type

Remarks

Later actions in a chain will not run if prior ones throw an exception. To catch and handle exceptions, use Around to register a decorator that runs around the current action whose execution is then under your control.

Inheritance Hierarchy

System.Object
Gallio.ActionChain<T1,T2>

See Also

ActionChain<T1,T2> Members
Gallio Namespace


ActionChain<T1,T2> Members

ActionChain Members
See Also Example Constructors Fields Properties Methods
[image]

An action chain captures a sequence of actions to be performed as part of a complex multi-part process.

The following tables list the members exposed by ActionChain<T1,T2>.

Public Constructors

 | Name | Description
Public method | ActionChain | Initializes a new instance of the ActionChain class.
Top

Public Fields

Name | Description
NoOp | Gets a singleton action that does nothing when invoked. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | Action | Gets or sets a representation of the chain as a single action. The action is progressively augmented as new contributions are registered using Before, After and Around. By default the action is NoOp.
Top

Public Methods

 | Name | Description
Public method | After | Registers an action to perform after all other actions currently in the chain.
Public method | Around | Registers an action to perform around all other actions currently in the chain. The contained part of the chain is passed in as an action to the decorator that the decorator can choose to run (or not) as needed.
Public method | Before | Registers an action to perform before all other actions currently in the chain.
Public method | Clear | Clears the chain and sets it action to NoOp.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ActionChain<T1,T2> Class
Gallio Namespace


ActionChain Constructor

ActionChain Constructor
[image]

Initializes a new instance of the ActionChain class.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ActionChain()
C++
public:
ActionChain() sealed
J#
public ActionChain()
JScript
JScript does not support generic types and methods.

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Fields

ActionChain Fields
[image]

Public Fields

Name | Description
NoOp | Gets a singleton action that does nothing when invoked. This field is read-only.
Top

See Also

ActionChain<T1,T2> Class
Gallio Namespace


NoOp Field

ActionChain.NoOp Field
[image]

Gets a singleton action that does nothing when invoked. This field is read-only.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NoOp As Action(Of T1, T2)
C#
public static readonly Action<T1, T2> NoOp;
C++
public:
static const Action<T1, T2> NoOp;
J#
public static final Action<T1, T2> NoOp
JScript
JScript does not support generic types and methods.

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Properties

ActionChain Properties
[image]

Public Properties

 | Name | Description
Public property | Action | Gets or sets a representation of the chain as a single action. The action is progressively augmented as new contributions are registered using Before, After and Around. By default the action is NoOp.
Top

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Action Property

ActionChain.Action Property
[image]

Gets or sets a representation of the chain as a single action.

The action is progressively augmented as new contributions are registered using Before, After and Around. By default the action is NoOp.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Action As Action(Of T1, T2)
C#
public Action<T1, T2> Action { get; set; }
C++
public property Action<T1, T2> Action sealed {
Action<T1, T2> get();
void set(Action<T1, T2> value);
}
J#
/** property */
public Action<T1, T2> get_Action();

/** property */
public void set_Action(Action<T1, T2> value);
JScript
JScript does not support generic types and methods.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Methods

ActionChain Methods
[image]

Public Methods

 | Name | Description
Public method | After | Registers an action to perform after all other actions currently in the chain.
Public method | Around | Registers an action to perform around all other actions currently in the chain. The contained part of the chain is passed in as an action to the decorator that the decorator can choose to run (or not) as needed.
Public method | Before | Registers an action to perform before all other actions currently in the chain.
Public method | Clear | Clears the chain and sets it action to NoOp.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ActionChain<T1,T2> Class
Gallio Namespace


After Method

ActionChain.After Method
[image]

Registers an action to perform after all other actions currently in the chain.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub After( _
ByVal action As Action(Of T1, T2) _
)
C#
public void After(
Action<T1, T2> action
)
C++
public:
void After(
Action<T1, T2> action
) sealed
J#
public void After(
Action<T1, T2> action
)
JScript
JScript does not support generic types and methods.

Parameters

action
The action to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

The value of Action will be set to a new instance that performs the specified action after the current Action.

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Around Method

ActionChain.Around Method
[image]

Registers an action to perform around all other actions currently in the chain. The contained part of the chain is passed in as an action to the decorator that the decorator can choose to run (or not) as needed.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Around( _
ByVal decorator As ActionDecorator(Of T1, T2) _
)
C#
public void Around(
ActionDecorator<T1, T2> decorator
)
C++
public:
void Around(
ActionDecorator<T1, T2> decorator
) sealed
J#
public void Around(
ActionDecorator<T1, T2> decorator
)
JScript
JScript does not support generic types and methods.

Parameters

decorator
The decorator to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if decorator is null

Remarks

The value of Action will be set to a new instance that performs the specified decorator around the current Action.

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Before Method

ActionChain.Before Method
[image]

Registers an action to perform before all other actions currently in the chain.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Before( _
ByVal action As Action(Of T1, T2) _
)
C#
public void Before(
Action<T1, T2> action
)
C++
public:
void Before(
Action<T1, T2> action
) sealed
J#
public void Before(
Action<T1, T2> action
)
JScript
JScript does not support generic types and methods.

Parameters

action
The action to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

The value of Action will be set to a new instance that performs the specified action before the current Action.

See Also

ActionChain<T1,T2> Class
Gallio Namespace


Clear Method

ActionChain.Clear Method
[image]

Clears the chain and sets it action to NoOp.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
JScript does not support generic types and methods.

See Also

ActionChain<T1,T2> Class
Gallio Namespace


ActionDecorator Generic Delegate

ActionDecorator Generic Delegate
[image]

Represents a delegate that decorates an action.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ActionDecorator(Of T)( _
ByVal obj As T, _
ByVal action As Action(Of T) _
)
C#
public delegate void ActionDecorator<T>(
T obj,
Action<T> action
)
C++
public delegate void ActionDecorator<T>(
T obj,
Action<T> action
)
J#
/** delegate */
public delegate void ActionDecorator<T>(
T obj,
Action<T> action
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of object the action is performed upon

Parameters

obj
The object to act upon
action
The action to decorate which should be called in the middle of applying the decoration

See Also

Gallio Namespace


ActionDecorator Generic Delegate

ActionDecorator Generic Delegate
[image]

Represents a delegate that decorates an action.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ActionDecorator(Of T1, T2)( _
ByVal arg1 As T1, _
ByVal arg2 As T2, _
ByVal action As Action(Of T1, T2) _
)
C#
public delegate void ActionDecorator<T1, T2>(
T1 arg1,
T2 arg2,
Action<T1, T2> action
)
C++
public delegate void ActionDecorator<T1, T2>(
T1 arg1,
T2 arg2,
Action<T1, T2> action
)
J#
/** delegate */
public delegate void ActionDecorator<T1, T2>(
T1 arg1,
T2 arg2,
Action<T1, T2> action
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type

Parameters

arg1
The first argument
arg2
The second argument
action
The action to decorate which should be called in the middle of applying the decoration

See Also

Gallio Namespace


Func Generic Delegate

Func Generic Delegate
[image]

A function with zero arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function Func(Of TResult)()
C#
public delegate TResult Func<TResult>()
C++
public delegate TResult Func<TResult>()
J#
/** delegate */
public delegate TResult Func<TResult>()
JScript
JScript does not support generic types and methods.

Type Parameters

TResult
The result type

See Also

Gallio Namespace


Func Generic Delegate

Func Generic Delegate
[image]

A function with one argument.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function Func(Of T1, TResult)( _
ByVal arg1 As T1 _
)
C#
public delegate TResult Func<T1, TResult>(
T1 arg1
)
C++
public delegate TResult Func<T1, TResult>(
T1 arg1
)
J#
/** delegate */
public delegate TResult Func<T1, TResult>(
T1 arg1
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
TResult
The result type

Parameters

arg1
The first argument

See Also

Gallio Namespace


Func Generic Delegate

Func Generic Delegate
[image]

A function with two arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function Func(Of T1, T2, TResult)( _
ByVal arg1 As T1, _
ByVal arg2 As T2 _
)
C#
public delegate TResult Func<T1, T2, TResult>(
T1 arg1,
T2 arg2
)
C++
public delegate TResult Func<T1, T2, TResult>(
T1 arg1,
T2 arg2
)
J#
/** delegate */
public delegate TResult Func<T1, T2, TResult>(
T1 arg1,
T2 arg2
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type
TResult
The result type

Parameters

arg1
The first argument
arg2
The second argument

See Also

Gallio Namespace


Func Generic Delegate

Func Generic Delegate
[image]

A function with three arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function Func(Of T1, T2, T3, TResult)( _
ByVal arg1 As T1, _
ByVal arg2 As T2, _
ByVal arg3 As T3 _
)
C#
public delegate TResult Func<T1, T2, T3, TResult>(
T1 arg1,
T2 arg2,
T3 arg3
)
C++
public delegate TResult Func<T1, T2, T3, TResult>(
T1 arg1,
T2 arg2,
T3 arg3
)
J#
/** delegate */
public delegate TResult Func<T1, T2, T3, TResult>(
T1 arg1,
T2 arg2,
T3 arg3
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type
T3
The third argument type
TResult
The result type

Parameters

arg1
The first argument
arg2
The second argument
arg3
The third argument

See Also

Gallio Namespace


Func Generic Delegate

Func Generic Delegate
[image]

A function with four arguments.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function Func(Of T1, T2, T3, T4, TResult)( _
ByVal arg1 As T1, _
ByVal arg2 As T2, _
ByVal arg3 As T3, _
ByVal arg4 As T4 _
)
C#
public delegate TResult Func<T1, T2, T3, T4, TResult>(
T1 arg1,
T2 arg2,
T3 arg3,
T4 arg4
)
C++
public delegate TResult Func<T1, T2, T3, T4, TResult>(
T1 arg1,
T2 arg2,
T3 arg3,
T4 arg4
)
J#
/** delegate */
public delegate TResult Func<T1, T2, T3, T4, TResult>(
T1 arg1,
T2 arg2,
T3 arg3,
T4 arg4
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first argument type
T2
The second argument type
T3
The third argument type
T4
The fourth argument type
TResult
The result type

Parameters

arg1
The first argument
arg2
The second argument
arg3
The third argument
arg4
The fourth argument

See Also

Gallio Namespace


FuncChain Generic Class

FuncChain Generic Class
See Also Example Members
[image]

A function chain captures a sequence of actions to be performed as part of a complex multi-part process.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FuncChain(Of T, TResult)
C#
public class FuncChain<T, TResult>
C++
ref class FuncChain<T, TResult>
J#
public class FuncChain<T, TResult>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The function argument type
TResult
The function result type

Inheritance Hierarchy

System.Object
Gallio.FuncChain<T,TResult>

See Also

FuncChain<T,TResult> Members
Gallio Namespace


FuncChain<T,TResult> Members

FuncChain Members
See Also Example Constructors Properties Methods
[image]

A function chain captures a sequence of actions to be performed as part of a complex multi-part process.

The following tables list the members exposed by FuncChain<T,TResult>.

Public Constructors

 | Name | Description
Public method | FuncChain | Creates a function chain.
Top

Public Properties

 | Name | Description
Public property | Func | Gets or sets a representation of the chain as a single function. The function is progressively augmented as new contributions are registered Around. By default the action is whatever was passed into the constructor.
Top

Public Methods

 | Name | Description
Public method | Around | Registers a function decorator to perform around all other actions currently in the chain. The contained part of the chain is passed in as a function to the decorator that the decorator can choose to run (or not) as needed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FuncChain<T,TResult> Class
Gallio Namespace


FuncChain Constructor

FuncChain Constructor
[image]

Creates a function chain.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal func As Func(Of T, TResult) _
)
C#
public FuncChain(
Func<T, TResult> func
)
C++
public:
FuncChain(
Func<T, TResult> func
) sealed
J#
public FuncChain(
Func<T, TResult> func
)
JScript
JScript does not support generic types and methods.

Parameters

func
The initial function

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if func is null

See Also

FuncChain<T,TResult> Class
Gallio Namespace


Properties

FuncChain Properties
[image]

Public Properties

 | Name | Description
Public property | Func | Gets or sets a representation of the chain as a single function. The function is progressively augmented as new contributions are registered Around. By default the action is whatever was passed into the constructor.
Top

See Also

FuncChain<T,TResult> Class
Gallio Namespace


Func Property

FuncChain.Func Property
[image]

Gets or sets a representation of the chain as a single function.

The function is progressively augmented as new contributions are registered Around. By default the action is whatever was passed into the constructor.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Func As Func(Of T, TResult)
C#
public Func<T, TResult> Func { get; set; }
C++
public property Func<T, TResult> Func sealed {
Func<T, TResult> get();
void set(Func<T, TResult> value);
}
J#
/** property */
public Func<T, TResult> get_Func();

/** property */
public void set_Func(Func<T, TResult> value);
JScript
JScript does not support generic types and methods.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

FuncChain<T,TResult> Class
Gallio Namespace


Methods

FuncChain Methods
[image]

Public Methods

 | Name | Description
Public method | Around | Registers a function decorator to perform around all other actions currently in the chain. The contained part of the chain is passed in as a function to the decorator that the decorator can choose to run (or not) as needed.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FuncChain<T,TResult> Class
Gallio Namespace


Around Method

FuncChain.Around Method
[image]

Registers a function decorator to perform around all other actions currently in the chain. The contained part of the chain is passed in as a function to the decorator that the decorator can choose to run (or not) as needed.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Around( _
ByVal decorator As FuncDecorator(Of T, TResult) _
)
C#
public void Around(
FuncDecorator<T, TResult> decorator
)
C++
public:
void Around(
FuncDecorator<T, TResult> decorator
) sealed
J#
public void Around(
FuncDecorator<T, TResult> decorator
)
JScript
JScript does not support generic types and methods.

Parameters

decorator
The decorator to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if decorator is null

Remarks

The value of Func will be set to a new instance that performs the specified decorator around the current Func.

See Also

FuncChain<T,TResult> Class
Gallio Namespace


FuncDecorator Generic Delegate

FuncDecorator Generic Delegate
[image]

Represents a delegate that decorates a function.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function FuncDecorator(Of T, TResult)( _
ByVal obj As T, _
ByVal func As Func(Of T, TResult) _
)
C#
public delegate TResult FuncDecorator<T, TResult>(
T obj,
Func<T, TResult> func
)
C++
public delegate TResult FuncDecorator<T, TResult>(
T obj,
Func<T, TResult> func
)
J#
/** delegate */
public delegate TResult FuncDecorator<T, TResult>(
T obj,
Func<T, TResult> func
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of object the function is performed upon
TResult
The type of the function result

Parameters

obj
The object to act upon
func
The function to decorate which should be called in the middle of applying the decoration

See Also

Gallio Namespace


ICloneable Generic Interface

ICloneable Generic Interface
See Also Example Members
[image]

Provides a typed clone operation.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICloneable(Of T As ICloneable(Of T))
Implements ICloneable
C#
public interface ICloneable<T> : ICloneable where T : ICloneable<T>
C++
interface class ICloneable<T> : ICloneable where T : ICloneable<T>
J#
public interface ICloneable<T> implements ICloneable
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type produced when the object is cloned

Types that implement ICloneable<T>

Type | Description
Gallio.Model.Logging.Tags.BodyTag | The top-level container tag of structured text. This class cannot be inherited.
Gallio.Model.Logging.Tags.ContainerTag | An abstract container tag for representing tags that can contain other tags. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Model.Logging.Tags.EmbedTag | An embedded attachment tag. This class cannot be inherited.
Gallio.Model.Logging.Tags.MarkerTag | A marker tag. This class cannot be inherited.
Gallio.Model.Logging.Tags.SectionTag | A section tag. This class cannot be inherited.
Gallio.Model.Logging.Tags.Tag | An tag represents a portion of the contents of a structured test log stream. Each one can be thought of as a command that will regenerate the structured test log stream when written back out. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Model.Logging.Tags.TextTag | A text tag, containing text. This class cannot be inherited.

See Also

ICloneable<T> Members
Gallio Namespace


ICloneable<T> Members

ICloneable Members
See Also Example Methods
[image]

Provides a typed clone operation.

The following tables list the members exposed by ICloneable<T>.

Public Methods

 | Name | Description
Public method | Clone | Clones the object.
Top

See Also

ICloneable<T> Interface
Gallio Namespace


Methods

ICloneable Methods
[image]

Public Methods

 | Name | Description
Public method | Clone | Clones the object.
Top

See Also

ICloneable<T> Interface
Gallio Namespace


Clone Method

ICloneable.Clone Method
[image]

Clones the object.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Clone()
C#
T Clone()
C++
T Clone() abstract
J#
T Clone()
JScript
JScript does not support generic types and methods.

Return Value

The cloned object

See Also

ICloneable<T> Interface
Gallio Namespace


Pair Generic Structure

Pair Generic Structure
See Also Example Members
[image]

An immutable record that holds two values.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure Pair(Of TFirst, TSecond)
C#
public struct Pair<TFirst, TSecond>
C++
value class Pair<TFirst, TSecond>
J#
public final class Pair<TFirst, TSecond> extends ValueType
JScript
JScript does not support generic types and methods.

Type Parameters

TFirst
The type of the first value
TSecond
The type of the second value

Inheritance Hierarchy

System.Object
Gallio.Pair<TFirst,TSecond>

See Also

Pair<TFirst,TSecond> Members
Gallio Namespace


Pair<TFirst,TSecond> Members

Pair Members
See Also Example Constructors Properties Methods
[image]

An immutable record that holds two values.

The following tables list the members exposed by Pair<TFirst,TSecond>.

Public Constructors

 | Name | Description
Public method | Pair | Creates a pair.
Top

Public Properties

 | Name | Description
Public property | First | Gets the first value.
Public property | Second | Gets the second value.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

Pair<TFirst,TSecond> Structure
Gallio Namespace


Pair Constructor

Pair Constructor
[image]

Creates a pair.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal first As TFirst, _
ByVal second As TSecond _
)
C#
public Pair(
TFirst first,
TSecond second
)
C++
public:
Pair(
TFirst first,
TSecond second
) sealed
J#
public Pair(
TFirst first,
TSecond second
)
JScript
JScript does not support generic types and methods.

Parameters

first
The first value
second
The second value

See Also

Pair<TFirst,TSecond> Structure
Gallio Namespace


Properties

Pair Properties
[image]

Public Properties

 | Name | Description
Public property | First | Gets the first value.
Public property | Second | Gets the second value.
Top

See Also

Pair<TFirst,TSecond> Structure
Gallio Namespace


First Property

Pair.First Property
[image]

Gets the first value.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property First
C#
public TFirst First { get; }
C++
public property TFirst First sealed {
TFirst get();
}
J#
/** property */
public TFirst get_First();
JScript
JScript does not support generic types and methods.

See Also

Pair<TFirst,TSecond> Structure
Gallio Namespace


Second Property

Pair.Second Property
[image]

Gets the second value.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Second
C#
public TSecond Second { get; }
C++
public property TSecond Second sealed {
TSecond get();
}
J#
/** property */
public TSecond get_Second();
JScript
JScript does not support generic types and methods.

See Also

Pair<TFirst,TSecond> Structure
Gallio Namespace


Triple Generic Structure

Triple Generic Structure
See Also Example Members
[image]

An immutable record that holds three values.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure Triple(Of TFirst, TSecond, TThird)
C#
public struct Triple<TFirst, TSecond, TThird>
C++
value class Triple<TFirst, TSecond, TThird>
J#
public final class Triple<TFirst, TSecond, TThird> extends ValueType
JScript
JScript does not support generic types and methods.

Type Parameters

TFirst
The type of the first value
TSecond
The type of the second value
TThird
The type of the third value

Inheritance Hierarchy

System.Object
Gallio.Triple<TFirst,TSecond,TThird>

See Also

Triple<TFirst,TSecond,TThird> Members
Gallio Namespace


Triple<TFirst,TSecond,TThird> Members

Triple Members
See Also Example Constructors Properties Methods
[image]

An immutable record that holds three values.

The following tables list the members exposed by Triple<TFirst,TSecond,TThird>.

Public Constructors

 | Name | Description
Public method | Triple | Creates a triple.
Top

Public Properties

 | Name | Description
Public property | First | Gets the first value.
Public property | Second | Gets the second value.
Public property | Third | Gets the third value.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

Triple<TFirst,TSecond,TThird> Structure
Gallio Namespace


Triple Constructor

Triple Constructor
[image]

Creates a triple.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal first As TFirst, _
ByVal second As TSecond, _
ByVal third As TThird _
)
C#
public Triple(
TFirst first,
TSecond second,
TThird third
)
C++
public:
Triple(
TFirst first,
TSecond second,
TThird third
) sealed
J#
public Triple(
TFirst first,
TSecond second,
TThird third
)
JScript
JScript does not support generic types and methods.

Parameters

first
The first value
second
The second value
third
The third value

See Also

Triple<TFirst,TSecond,TThird> Structure
Gallio Namespace


Properties

Triple Properties
[image]

Public Properties

 | Name | Description
Public property | First | Gets the first value.
Public property | Second | Gets the second value.
Public property | Third | Gets the third value.
Top

See Also

Triple<TFirst,TSecond,TThird> Structure
Gallio Namespace


First Property

Triple.First Property
[image]

Gets the first value.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property First
C#
public TFirst First { get; }
C++
public property TFirst First sealed {
TFirst get();
}
J#
/** property */
public TFirst get_First();
JScript
JScript does not support generic types and methods.

See Also

Triple<TFirst,TSecond,TThird> Structure
Gallio Namespace


Second Property

Triple.Second Property
[image]

Gets the second value.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Second
C#
public TSecond Second { get; }
C++
public property TSecond Second sealed {
TSecond get();
}
J#
/** property */
public TSecond get_Second();
JScript
JScript does not support generic types and methods.

See Also

Triple<TFirst,TSecond,TThird> Structure
Gallio Namespace


Third Property

Triple.Third Property
[image]

Gets the third value.

Namespace: Gallio
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Third
C#
public TThird Third { get; }
C++
public property TThird Third sealed {
TThird get();
}
J#
/** property */
public TThird get_Third();
JScript
JScript does not support generic types and methods.

See Also

Triple<TFirst,TSecond,TThird> Structure
Gallio Namespace


Gallio.Ambience

Gallio.Ambience Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AmbienceClient | The Ambience client accesses shared data provided by a remote AmbienceServer. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AmbienceClientConfiguration | Provides configuration data for AmbienceClient.
Public class | AmbienceException | Describes a problem accessing Gallio Ambience.
Public class | AmbienceSectionHandler | Recognizes and processes the <ambience> configuration section.
Public class | AmbienceServer | The Ambience server provides shared data to remote AmbienceClients.
Public class | AmbienceServerConfiguration | Provides configuration data for AmbienceServer.
Public class Ambient

The Ambient object store is a shared lightweight repository for intermediate test data. It is like a persistent whiteboard used to pass information from one test to another or to store it for subsequent analysis.

The Ambient object store may be used to model the persistent state of the testing environment for end-to-end black-box integration testing. It is particularly useful for decoupling tests that incorporate stateful components such as databases (that are not wiped and restored each time) or time-sensitive processes such as asynchronous jobs.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AmbientDataContainerExtensions | Extension methods for LINQ syntax over Ambient data containers. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AmbientDataQueryExtensions | Extension methods for LINQ syntax over Ambient data queries. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

 | Interface | Description
Public interface | IAmbientDataContainer | Represents a container of Ambient data and providers operations to query, store and update its contents.
Public interface | IAmbientDataQuery | Represents a lazily evaluated query over Ambient data for use with the LINQ query syntax.
Public interface | IAmbientDataSet | A data set containing Ambient objects.


AmbienceClient Class

AmbienceClient Class
See Also Example Members
[image]

The Ambience client accesses shared data provided by a remote AmbienceServer. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AmbienceClient
Implements IDisposable
C#
public sealed class AmbienceClient : IDisposable
C++
ref class AmbienceClient sealed : IDisposable
J#
public final class AmbienceClient implements IDisposable
JScript
public final class AmbienceClient extends IDisposable

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbienceClient

See Also

AmbienceClient Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceClient Members

AmbienceClient Members
See Also Example Properties Methods
[image]

The Ambience client accesses shared data provided by a remote AmbienceServer. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AmbienceClient.

Public Properties

 | Name | Description
Public property | Container | Gets the client's data container.
Top

Public Methods

 | Name | Description
 | Connect | Connects the client to the remote server.
Public method | Dispose | Determines whether the specified Object is equal to the current Object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AmbienceClient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Properties

AmbienceClient Properties
[image]

Public Properties

 | Name | Description
Public property | Container | Gets the client's data container.
Top

See Also

AmbienceClient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Container Property

AmbienceClient.Container Property
[image]

Gets the client's data container.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IAmbientDataContainer
C#
public IAmbientDataContainer Container { get; }
C++
public property IAmbientDataContainer Container sealed {
IAmbientDataContainer get();
}
J#
/** property */
public IAmbientDataContainer get_Container();
JScript
public function get Container() : IAmbientDataContainer

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the client has been disposed

See Also

AmbienceClient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Methods

AmbienceClient Methods
[image]

Public Methods

 | Name | Description
 | Connect | Connects the client to the remote server.
Public method | Dispose | Determines whether the specified Object is equal to the current Object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AmbienceClient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Connect Method

AmbienceClient.Connect Method
[image]

Connects the client to the remote server.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Connect( _
ByVal configuration As AmbienceClientConfiguration _
) As AmbienceClient
C#
public static AmbienceClient Connect(
AmbienceClientConfiguration configuration
)
C++
public:
static AmbienceClient Connect(
AmbienceClientConfiguration configuration
)
J#
public static AmbienceClient Connect(
AmbienceClientConfiguration configuration
)
JScript
public static function Connect(
configuration : AmbienceClientConfiguration
) : AmbienceClient

Parameters

configuration
The client configuration

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if configuration is null
AmbienceException | Thrown if the operation failed

See Also

AmbienceClient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Dispose Method

AmbienceClient.Dispose Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IDisposable.Dispose

See Also

AmbienceClient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceClientConfiguration Class

AmbienceClientConfiguration Class
See Also Example Members
[image]

Provides configuration data for AmbienceClient.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Class AmbienceClientConfiguration
C#
public class AmbienceClientConfiguration
C++
ref class AmbienceClientConfiguration
J#
public class AmbienceClientConfiguration
JScript
public class AmbienceClientConfiguration

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbienceClientConfiguration

See Also

AmbienceClientConfiguration Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceClientConfiguration Members

AmbienceClientConfiguration Members
See Also Example Constructors Properties Methods
[image]

Provides configuration data for AmbienceClient.

The following tables list the members exposed by AmbienceClientConfiguration.

Public Constructors

 | Name | Description
Public method | AmbienceClientConfiguration | Initializes a new instance of the AmbienceClientConfiguration class.
Top

Public Properties

 | Name | Description
Public property | Credential | Gets or sets the Ambient server username and password.
Public property | HostName | Gets or sets the Ambient server hostname.
Public property | Port | Gets or sets the Ambient server port number.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AmbienceClientConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceClientConfiguration Constructor

AmbienceClientConfiguration Constructor
[image]

Initializes a new instance of the AmbienceClientConfiguration class.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AmbienceClientConfiguration()
C++
public:
AmbienceClientConfiguration() sealed
J#
public AmbienceClientConfiguration()
JScript
public function AmbienceClientConfiguration()

See Also

AmbienceClientConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Properties

AmbienceClientConfiguration Properties
[image]

Public Properties

 | Name | Description
Public property | Credential | Gets or sets the Ambient server username and password.
Public property | HostName | Gets or sets the Ambient server hostname.
Public property | Port | Gets or sets the Ambient server port number.
Top

See Also

AmbienceClientConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Credential Property

AmbienceClientConfiguration.Credential Property
[image]

Gets or sets the Ambient server username and password.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Property Credential As NetworkCredential
C#
public NetworkCredential Credential { get; set; }
C++
public property NetworkCredential Credential sealed {
NetworkCredential get();
void set(NetworkCredential value);
}
J#
/** property */
public NetworkCredential get_Credential();

/** property */
public void set_Credential(NetworkCredential value);
JScript
public function get Credential() : NetworkCredential

public function set Credential(value : NetworkCredential);

Property Value

The username and password, defaults to an anonymous credential.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

AmbienceClientConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


HostName Property

AmbienceClientConfiguration.HostName Property
[image]

Gets or sets the Ambient server hostname.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Property HostName As String
C#
public string HostName { get; set; }
C++
public property string HostName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_HostName();

/** property */
public void set_HostName(string value);
JScript
public function get HostName() : String

public function set HostName(value : String);

Property Value

The hostname, defaults to "localhost".

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null
ArgumentException | Thrown if value is empty

See Also

AmbienceClientConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Port Property

AmbienceClientConfiguration.Port Property
[image]

Gets or sets the Ambient server port number.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port { get; set; }
C++
public property int Port sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Port();

/** property */
public void set_Port(int value);
JScript
public function get Port() : int

public function set Port(value : int);

Property Value

The port number, defaults to 7822.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if the port number is not in the range 1..65535

See Also

AmbienceClientConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Class

AmbienceException Class
See Also Example Members
[image]

Describes a problem accessing Gallio Ambience.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AmbienceException
Inherits Exception
C#
[SerializableAttribute]
public class AmbienceException : Exception
C++
[SerializableAttribute]
ref class AmbienceException : Exception
J#
/** @attribute SerializableAttribute() */
public class AmbienceException extends Exception
JScript
public
SerializableAttribute
class AmbienceException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Ambience.AmbienceException

See Also

AmbienceException Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Members

AmbienceException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes a problem accessing Gallio Ambience.

The following tables list the members exposed by AmbienceException.

Public Constructors

Name | Description
AmbienceException | Overloaded. Initializes a new instance of the AmbienceException class.
Top

Protected Constructors

Name | Description
AmbienceException | Overloaded. Initializes a new instance of the AmbienceException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AmbienceException | Overloaded. Initializes a new instance of the AmbienceException class.
Top

See Also

AmbienceException Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Constructor

AmbienceException Constructor

Initializes a new instance of the AmbienceException class.

Overload List

 | Name | Description
Public method | AmbienceException | Creates an exception.
Family method | AmbienceException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | AmbienceException (String) | Creates an exception.
Public method | AmbienceException (String, Exception) | Creates an exception.

See Also

AmbienceException Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Constructor ()

AmbienceException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AmbienceException()
C++
public:
AmbienceException() sealed
J#
public AmbienceException()
JScript
public function AmbienceException()

See Also

AmbienceException Class
Gallio.Ambience Namespace
AmbienceException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Constructor (SerializationInfo, StreamingContext)

AmbienceException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected AmbienceException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
AmbienceException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected AmbienceException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function AmbienceException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

AmbienceException Class
Gallio.Ambience Namespace
AmbienceException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Constructor (String)

AmbienceException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public AmbienceException(
string message
)
C++
public:
AmbienceException(
String message
) sealed
J#
public AmbienceException(
string message
)
JScript
public function AmbienceException(
message : String
)

Parameters

message
The message

See Also

AmbienceException Class
Gallio.Ambience Namespace
AmbienceException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceException Constructor (String, Exception)

AmbienceException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public AmbienceException(
string message,
Exception innerException
)
C++
public:
AmbienceException(
String message,
Exception innerException
) sealed
J#
public AmbienceException(
string message,
Exception innerException
)
JScript
public function AmbienceException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

AmbienceException Class
Gallio.Ambience Namespace
AmbienceException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceSectionHandler Class

AmbienceSectionHandler Class
See Also Example Members
[image]

Recognizes and processes the <ambience> configuration section.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Class AmbienceSectionHandler
Implements IConfigurationSectionHandler
C#
public class AmbienceSectionHandler : IConfigurationSectionHandler
C++
ref class AmbienceSectionHandler : IConfigurationSectionHandler
J#
public class AmbienceSectionHandler implements IConfigurationSectionHandler
JScript
public class AmbienceSectionHandler extends IConfigurationSectionHandler

Example

Example configuration: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="ambience" type="Gallio.Ambience.AmbienceSectionHandler, Gallio.Ambience" /> </configSections> <ambience> <defaultClient hostName="localhost" port="65436" userName="Test" password="Password" /> </ambience> </configuration>

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbienceSectionHandler

See Also

AmbienceSectionHandler Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceSectionHandler Members

AmbienceSectionHandler Members
See Also Example Constructors Fields Methods
[image]

Recognizes and processes the <ambience> configuration section.

The following tables list the members exposed by AmbienceSectionHandler.

Public Constructors

 | Name | Description
Public method | AmbienceSectionHandler | Initializes a new instance of the AmbienceSectionHandler class.
Top

Public Fields

Name | Description
SectionName | The name of the Ambience section: "ambience". This field is constant and read-only.
Top

Public Methods

 | Name | Description
Public method | Create | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AmbienceSectionHandler Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceSectionHandler Constructor

AmbienceSectionHandler Constructor
[image]

Initializes a new instance of the AmbienceSectionHandler class.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AmbienceSectionHandler()
C++
public:
AmbienceSectionHandler() sealed
J#
public AmbienceSectionHandler()
JScript
public function AmbienceSectionHandler()

See Also

AmbienceSectionHandler Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Fields

AmbienceSectionHandler Fields
[image]

Public Fields

Name | Description
SectionName | The name of the Ambience section: "ambience". This field is constant and read-only.
Top

See Also

AmbienceSectionHandler Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


SectionName Field

AmbienceSectionHandler.SectionName Field
[image]

The name of the Ambience section: "ambience". This field is constant and read-only.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public const SectionName As String = "ambience"
C#
public const string SectionName = "ambience";
C++
public:
const String SectionName = L"ambience";
J#
public const string SectionName = "ambience"
JScript
public const SectionName : String = "ambience";

See Also

AmbienceSectionHandler Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Methods

AmbienceSectionHandler Methods
[image]

Public Methods

 | Name | Description
Public method | Create | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AmbienceSectionHandler Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Create Method

AmbienceSectionHandler.Create Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Function Create( _
ByVal parent As Object, _
ByVal configContext As Object, _
ByVal section As XmlNode _
) As Object _
Implements IConfigurationSectionHandler.Create
C#
public object Create(
object parent,
object configContext,
XmlNode section
)
C++
public:
Object Create(
Object parent,
Object configContext,
XmlNode section
) sealed
J#
public object Create(
object parent,
object configContext,
XmlNode section
)
JScript
public function Create(
parent : Object,
configContext : Object,
section : XmlNode
) : Object

Return Value

A hash code for the current Object.

Implements

IConfigurationSectionHandler.Create

See Also

AmbienceSectionHandler Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceServer Class

AmbienceServer Class
See Also Example Members
[image]

The Ambience server provides shared data to remote AmbienceClients.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Class AmbienceServer
Implements IDisposable
C#
public class AmbienceServer : IDisposable
C++
ref class AmbienceServer : IDisposable
J#
public class AmbienceServer implements IDisposable
JScript
public class AmbienceServer extends IDisposable

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbienceServer

See Also

AmbienceServer Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceServer Members

AmbienceServer Members
See Also Example Constructors Methods
[image]

The Ambience server provides shared data to remote AmbienceClients.

The following tables list the members exposed by AmbienceServer.

Public Constructors

 | Name | Description
Public method | AmbienceServer | Creates an ambient server with parameters initialized to defaults.
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Stops and disposes the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Start | Starts the server.
Public method | Stop | Stops the server. Does nothing if the server has already been stopped.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Stops and disposes the server.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AmbienceServer Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceServer Constructor

AmbienceServer Constructor
[image]

Creates an ambient server with parameters initialized to defaults.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal configuration As AmbienceServerConfiguration _
)
C#
public AmbienceServer(
AmbienceServerConfiguration configuration
)
C++
public:
AmbienceServer(
AmbienceServerConfiguration configuration
) sealed
J#
public AmbienceServer(
AmbienceServerConfiguration configuration
)
JScript
public function AmbienceServer(
configuration : AmbienceServerConfiguration
)

Parameters

configuration
The server configuration

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if configuration is null

See Also

AmbienceServer Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Methods

AmbienceServer Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Stops and disposes the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Start | Starts the server.
Public method | Stop | Stops the server. Does nothing if the server has already been stopped.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Stops and disposes the server.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AmbienceServer Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Dispose Method

AmbienceServer.Dispose Method

Stops and disposes the server.

Overload List

 | Name | Description
Public method | Dispose | Stops and disposes the server.
Family method | Dispose (Boolean) | Stops and disposes the server.

See Also

AmbienceServer Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Dispose Method ()

AmbienceServer.Dispose Method ()
See Also Example
[image]

Stops and disposes the server.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

AmbienceServer Class
Gallio.Ambience Namespace
AmbienceServer.Dispose Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Dispose Method (Boolean)

AmbienceServer.Dispose Method (Boolean)
See Also Example
[image]

Stops and disposes the server.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

AmbienceServer Class
Gallio.Ambience Namespace
AmbienceServer.Dispose Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Start Method

AmbienceServer.Start Method
[image]

Starts the server.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub Start()
C#
public void Start()
C++
public:
void Start() sealed
J#
public void Start()
JScript
public function Start()

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the server has already been started
ObjectDisposedException | Thrown if the server has been disposed
AmbienceException | Thrown if the operation failed

See Also

AmbienceServer Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Stop Method

AmbienceServer.Stop Method
[image]

Stops the server. Does nothing if the server has already been stopped.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub Stop()
C#
public void Stop()
C++
public:
void Stop() sealed
J#
public void Stop()
JScript
public function Stop()

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the server has been disposed

See Also

AmbienceServer Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceServerConfiguration Class

AmbienceServerConfiguration Class
See Also Example Members
[image]

Provides configuration data for AmbienceServer.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Class AmbienceServerConfiguration
C#
public class AmbienceServerConfiguration
C++
ref class AmbienceServerConfiguration
J#
public class AmbienceServerConfiguration
JScript
public class AmbienceServerConfiguration

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbienceServerConfiguration

See Also

AmbienceServerConfiguration Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceServerConfiguration Members

AmbienceServerConfiguration Members
See Also Example Constructors Properties Methods
[image]

Provides configuration data for AmbienceServer.

The following tables list the members exposed by AmbienceServerConfiguration.

Public Constructors

 | Name | Description
Public method | AmbienceServerConfiguration | Initializes a new instance of the AmbienceServerConfiguration class.
Top

Public Properties

 | Name | Description
Public property | Credential | Gets or sets the Ambient server username and password.
Public property | DatabasePath | Gets or sets the database file path.
Public property | Port | Gets or sets the Ambient server port number.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AmbienceServerConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbienceServerConfiguration Constructor

AmbienceServerConfiguration Constructor
[image]

Initializes a new instance of the AmbienceServerConfiguration class.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AmbienceServerConfiguration()
C++
public:
AmbienceServerConfiguration() sealed
J#
public AmbienceServerConfiguration()
JScript
public function AmbienceServerConfiguration()

See Also

AmbienceServerConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Properties

AmbienceServerConfiguration Properties
[image]

Public Properties

 | Name | Description
Public property | Credential | Gets or sets the Ambient server username and password.
Public property | DatabasePath | Gets or sets the database file path.
Public property | Port | Gets or sets the Ambient server port number.
Top

See Also

AmbienceServerConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Credential Property

AmbienceServerConfiguration.Credential Property
[image]

Gets or sets the Ambient server username and password.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Property Credential As NetworkCredential
C#
public NetworkCredential Credential { get; set; }
C++
public property NetworkCredential Credential sealed {
NetworkCredential get();
void set(NetworkCredential value);
}
J#
/** property */
public NetworkCredential get_Credential();

/** property */
public void set_Credential(NetworkCredential value);
JScript
public function get Credential() : NetworkCredential

public function set Credential(value : NetworkCredential);

Property Value

The username and password, defaults to an anonymous credential.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

AmbienceServerConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


DatabasePath Property

AmbienceServerConfiguration.DatabasePath Property
[image]

Gets or sets the database file path.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Property DatabasePath As String
C#
public string DatabasePath { get; set; }
C++
public property string DatabasePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DatabasePath();

/** property */
public void set_DatabasePath(string value);
JScript
public function get DatabasePath() : String

public function set DatabasePath(value : String);

Property Value

The database file path, the default is a file called Default.db in the Gallio.Ambient subdirectory of the Common Application Data folder.

See Also

AmbienceServerConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Port Property

AmbienceServerConfiguration.Port Property
[image]

Gets or sets the Ambient server port number.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port { get; set; }
C++
public property int Port sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Port();

/** property */
public void set_Port(int value);
JScript
public function get Port() : int

public function set Port(value : int);

Property Value

The port number, defaults to 7822.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if the port number is not in the range 1..65535

See Also

AmbienceServerConfiguration Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Ambient Class

Ambient Class
See Also Example Members
[image]

The Ambient object store is a shared lightweight repository for intermediate test data. It is like a persistent whiteboard used to pass information from one test to another or to store it for subsequent analysis.

The Ambient object store may be used to model the persistent state of the testing environment for end-to-end black-box integration testing. It is particularly useful for decoupling tests that incorporate stateful components such as databases (that are not wiped and restored each time) or time-sensitive processes such as asynchronous jobs.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Module Ambient
C#
public static class Ambient
C++
ref class Ambient abstract sealed
J#
public final class Ambient
JScript
public class Ambient

Example

Suppose we are testing a periodic invoicing process. The business requirement dictates that on the last day of each month, an invoice must be generated and delivered electronically to all customers with an outstanding balance in their account.

To verify this requirement, we might choose to adopt a combination of unit testing and integration testing methodologies.

First, we will write unit tests for each component involved in the invoicing process including the invoice generator, data access code, electronic delivery apparatus, and the periodic job scheduler. During unit testing, we will probably replace the periodic job scheduler with a mock or stub implementation that simulates the end-of-month trigger mechanism. This is fast and quite effective.

Next, for additional confidence we will want to verify that the system works completely as an integrated whole. Perhaps the job scheduling mechanism is built on 3rd party tools that must be correctly configured for the environment. In this situation, we might consider implementing an end-to-end system test with nothing mocked out.

We can implement an end-to-end test like this:

  • Write a few test scripts that are scheduled to run on a regular basis and that generate transactions that will be reflected in the invoices.
  • For each transaction, such as creating a new account or purchasing a service, the scripts should make a record in the Ambient object store.
  • Write a few more test scripts that are scheduled to run after the invoicing process occurs. They should verify the contents of the invoices based on previously stored records in the Ambient object store.

Of course, in this example it can take up to a month to obtain confirmation that the invoicing process functioned as expected. Consequently, we should not rely on this approach exclusively for our testing purposes. Nevertheless, it may be useful as part of an on-going Quality Assurance audit.

Inheritance Hierarchy

System.Object
Gallio.Ambience.Ambient

See Also

Ambient Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Ambient Members

Ambient Members
See Also Example Properties
[image]

The Ambient object store is a shared lightweight repository for intermediate test data. It is like a persistent whiteboard used to pass information from one test to another or to store it for subsequent analysis.

The Ambient object store may be used to model the persistent state of the testing environment for end-to-end black-box integration testing. It is particularly useful for decoupling tests that incorporate stateful components such as databases (that are not wiped and restored each time) or time-sensitive processes such as asynchronous jobs.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Ambient.

Public Properties

Name | Description
Data | Gets the default ambient data container.
DefaultClientConfiguration | Gets or sets the default client configuration.
Top

See Also

Ambient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Properties

Ambient Properties
[image]

Public Properties

Name | Description
Data | Gets the default ambient data container.
DefaultClientConfiguration | Gets or sets the default client configuration.
Top

See Also

Ambient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Data Property

Ambient.Data Property
[image]

Gets the default ambient data container.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Data As IAmbientDataContainer
C#
public static IAmbientDataContainer Data { get; }
C++
public static property IAmbientDataContainer Data {
IAmbientDataContainer get();
}
J#
/** property */
public IAmbientDataContainer get_Data();
JScript
public function get Data() : IAmbientDataContainer

Exceptions

Exception Type | Condition
AmbienceException | Thrown if the operation failed

See Also

Ambient Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


DefaultClientConfiguration Property

Ambient.DefaultClientConfiguration Property
[image]

Gets or sets the default client configuration.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property DefaultClientConfiguration As AmbienceClientConfiguration
C#
public static AmbienceClientConfiguration DefaultClientConfiguration { get; set; }
C++
public static property AmbienceClientConfiguration DefaultClientConfiguration {
AmbienceClientConfiguration get();
void set(AmbienceClientConfiguration value);
}
J#
/** property */
public AmbienceClientConfiguration get_DefaultClientConfiguration();

/** property */
public void set_DefaultClientConfiguration(AmbienceClientConfiguration value);
JScript
public function get DefaultClientConfiguration() : AmbienceClientConfiguration

public function set DefaultClientConfiguration(value : AmbienceClientConfiguration);

Property Value

The default client configuration. The initial value is populated from the contents of the Ambience configuration section in the application's or test's configuration file. See also .

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

Ambient Class
Gallio.Ambience Namespace
AmbienceSectionHandler

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbientDataContainerExtensions Class

AmbientDataContainerExtensions Class
See Also Example Members
[image]

Extension methods for LINQ syntax over Ambient data containers. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Module AmbientDataContainerExtensions
C#
[ExtensionAttribute]
public static class AmbientDataContainerExtensions
C++
[ExtensionAttribute]
ref class AmbientDataContainerExtensions abstract sealed
J#
/** @attribute ExtensionAttribute() */
public final class AmbientDataContainerExtensions
JScript
public
ExtensionAttribute
class AmbientDataContainerExtensions

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbientDataContainerExtensions

See Also

AmbientDataContainerExtensions Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbientDataContainerExtensions Members

AmbientDataContainerExtensions Members
See Also Example Methods
[image]

Extension methods for LINQ syntax over Ambient data containers. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AmbientDataContainerExtensions.

Public Methods

Name | Description
Cast | Obtains a query over a data container.
Top

See Also

AmbientDataContainerExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Methods

AmbientDataContainerExtensions Methods
[image]

Public Methods

Name | Description
Cast | Obtains a query over a data container.
Top

See Also

AmbientDataContainerExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Cast Generic Method

AmbientDataContainerExtensions.Cast Generic Method
[image]

Obtains a query over a data container.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Cast(Of T)( _
ByVal container As IAmbientDataContainer _
) As IAmbientDataQuery(Of T)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<T> Cast<T>(
IAmbientDataContainer container
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<T> Cast<T>(
IAmbientDataContainer container
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<T> Cast<T>(
IAmbientDataContainer container
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The result type

Parameters

container
The container

Return Value

The query object

Remarks

Client code will not call this method directly. However, it turns out that the C# compiler will add an implicit call to this method when it attempts to select a value from the container using LINQ syntax.

See Also

AmbientDataContainerExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbientDataQueryExtensions Class

AmbientDataQueryExtensions Class
See Also Example Members
[image]

Extension methods for LINQ syntax over Ambient data queries. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Module AmbientDataQueryExtensions
C#
[ExtensionAttribute]
public static class AmbientDataQueryExtensions
C++
[ExtensionAttribute]
ref class AmbientDataQueryExtensions abstract sealed
J#
/** @attribute ExtensionAttribute() */
public final class AmbientDataQueryExtensions
JScript
public
ExtensionAttribute
class AmbientDataQueryExtensions

Inheritance Hierarchy

System.Object
Gallio.Ambience.AmbientDataQueryExtensions

See Also

AmbientDataQueryExtensions Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


AmbientDataQueryExtensions Members

AmbientDataQueryExtensions Members
See Also Example Methods
[image]

Extension methods for LINQ syntax over Ambient data queries. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AmbientDataQueryExtensions.

Public Methods

Name | Description
Count | Counts the number of objects produced by the query.
OrderBy | Produces a new query ordered by a comparison expression in ascending order.
OrderByDescending | Produces a new query ordered by a comparison expression in descending order.
Select | Produces a new query to select a projection of a component of another query.
ThenBy | Produces a new query ordered by an additional comparison expression in ascending order.
ThenByDescending | Produces a new query ordered by an additional comparison expression in descending order.
Where | Produces a new query to filter another query by a criteria.
Top

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Methods

AmbientDataQueryExtensions Methods
[image]

Public Methods

Name | Description
Count | Counts the number of objects produced by the query.
OrderBy | Produces a new query ordered by a comparison expression in ascending order.
OrderByDescending | Produces a new query ordered by a comparison expression in descending order.
Select | Produces a new query to select a projection of a component of another query.
ThenBy | Produces a new query ordered by an additional comparison expression in ascending order.
ThenByDescending | Produces a new query ordered by an additional comparison expression in descending order.
Where | Produces a new query to filter another query by a criteria.
Top

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Count Generic Method

AmbientDataQueryExtensions.Count Generic Method
[image]

Counts the number of objects produced by the query.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Count(Of TSource)( _
ByVal self As IAmbientDataQuery(Of TSource) _
) As Integer
C#
[ExtensionAttribute]
public static int Count<TSource>(
IAmbientDataQuery<TSource> self
)
C++
[ExtensionAttribute]
public:
static int Count<TSource>(
IAmbientDataQuery<TSource> self
)
J#
/** @attribute ExtensionAttribute() */
public static int Count<TSource>(
IAmbientDataQuery<TSource> self
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried

Parameters

self
The query

Return Value

The number of objects

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


OrderBy Generic Method

AmbientDataQueryExtensions.OrderBy Generic Method
[image]

Produces a new query ordered by a comparison expression in ascending order.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function OrderBy(Of TSource, TKey)( _
ByVal self As IAmbientDataQuery(Of TSource), _
ByVal expression As Expression(Of Func(Of TSource, TKey)) _
) As IAmbientDataQuery(Of TSource)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<TSource> OrderBy<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<TSource> OrderBy<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<TSource> OrderBy<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried
TKey
The sort key type

Parameters

self
The query
expression
The sort comparison expression

Return Value

The ordered query

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


OrderByDescending Generic Method

AmbientDataQueryExtensions.OrderByDescending Generic Method
[image]

Produces a new query ordered by a comparison expression in descending order.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function OrderByDescending(Of TSource, TKey)( _
ByVal self As IAmbientDataQuery(Of TSource), _
ByVal expression As Expression(Of Func(Of TSource, TKey)) _
) As IAmbientDataQuery(Of TSource)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<TSource> OrderByDescending<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<TSource> OrderByDescending<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<TSource> OrderByDescending<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried
TKey
The sort key type

Parameters

self
The query
expression
The sort comparison expression

Return Value

The ordered query

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Select Generic Method

AmbientDataQueryExtensions.Select Generic Method
[image]

Produces a new query to select a projection of a component of another query.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Select(Of TSource, TRet)( _
ByVal self As IAmbientDataQuery(Of TSource), _
ByVal selector As Func(Of TSource, TRet) _
) As IAmbientDataQuery(Of TRet)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<TRet> Select<TSource, TRet>(
IAmbientDataQuery<TSource> self,
Func<TSource, TRet> selector
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<TRet> Select<TSource, TRet>(
IAmbientDataQuery<TSource> self,
Func<TSource, TRet> selector
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<TRet> Select<TSource, TRet>(
IAmbientDataQuery<TSource> self,
Func<TSource, TRet> selector
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried
TRet
The projection result type

Parameters

self
The query
selector
The selection expression

Return Value

The projected query

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


ThenBy Generic Method

AmbientDataQueryExtensions.ThenBy Generic Method
[image]

Produces a new query ordered by an additional comparison expression in ascending order.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function ThenBy(Of TSource, TKey)( _
ByVal self As IAmbientDataQuery(Of TSource), _
ByVal expression As Expression(Of Func(Of TSource, TKey)) _
) As IAmbientDataQuery(Of TSource)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<TSource> ThenBy<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<TSource> ThenBy<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<TSource> ThenBy<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried
TKey
The sort key type

Parameters

self
The query
expression
The sort comparison expression

Return Value

The ordered query

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


ThenByDescending Generic Method

AmbientDataQueryExtensions.ThenByDescending Generic Method
[image]

Produces a new query ordered by an additional comparison expression in descending order.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function ThenByDescending(Of TSource, TKey)( _
ByVal self As IAmbientDataQuery(Of TSource), _
ByVal expression As Expression(Of Func(Of TSource, TKey)) _
) As IAmbientDataQuery(Of TSource)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<TSource> ThenByDescending<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<TSource> ThenByDescending<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<TSource> ThenByDescending<TSource, TKey>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, TKey>> expression
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried
TKey
The sort key type

Parameters

self
The query
expression
The sort comparison expression

Return Value

The ordered query

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Where Generic Method

AmbientDataQueryExtensions.Where Generic Method
[image]

Produces a new query to filter another query by a criteria.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Where(Of TSource)( _
ByVal self As IAmbientDataQuery(Of TSource), _
ByVal expression As Expression(Of Func(Of TSource, Boolean)) _
) As IAmbientDataQuery(Of TSource)
C#
[ExtensionAttribute]
public static IAmbientDataQuery<TSource> Where<TSource>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, bool>> expression
)
C++
[ExtensionAttribute]
public:
static IAmbientDataQuery<TSource> Where<TSource>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, bool>> expression
)
J#
/** @attribute ExtensionAttribute() */
public static IAmbientDataQuery<TSource> Where<TSource>(
IAmbientDataQuery<TSource> self,
Expression<Func<TSource, bool>> expression
)
JScript
JScript does not support generic types and methods.

Type Parameters

TSource
The type of object being queried

Parameters

self
The query
expression
The filter expression

Return Value

The filtered query

See Also

AmbientDataQueryExtensions Class
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


IAmbientDataContainer Interface

IAmbientDataContainer Interface
See Also Example Members
[image]

Represents a container of Ambient data and providers operations to query, store and update its contents.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAmbientDataContainer
C#
public interface IAmbientDataContainer
C++
interface class IAmbientDataContainer
J#
public interface IAmbientDataContainer
JScript
public interface IAmbientDataContainer

See Also

IAmbientDataContainer Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


IAmbientDataContainer Members

IAmbientDataContainer Members
See Also Example Methods
[image]

Represents a container of Ambient data and providers operations to query, store and update its contents.

The following tables list the members exposed by IAmbientDataContainer.

Public Methods

 | Name | Description
Public method | Delete | Deletes the object from the container.
Public method | DeleteAll | Deletes all objects in the container. (Use with caution!)
Public method | Query | Overloaded. Gets all objects of a particular type in the container.
Public method | Store | Stores or updates an object in the container.
Top

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Methods

IAmbientDataContainer Methods
[image]

Public Methods

 | Name | Description
Public method | Delete | Deletes the object from the container.
Public method | DeleteAll | Deletes all objects in the container. (Use with caution!)
Public method | Query | Overloaded. Gets all objects of a particular type in the container.
Public method | Store | Stores or updates an object in the container.
Top

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Delete Method

IAmbientDataContainer.Delete Method
[image]

Deletes the object from the container.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Sub Delete( _
ByVal obj As Object _
)
C#
void Delete(
object obj
)
C++
void Delete(
Object obj
) abstract
J#
void Delete(
object obj
)
JScript
function Delete(
obj : Object
)

Parameters

obj
The object to delete

Exceptions

Exception Type | Condition
AmbienceException | Thrown if the operation failed

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


DeleteAll Method

IAmbientDataContainer.DeleteAll Method
[image]

Deletes all objects in the container. (Use with caution!)

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteAll()
C#
void DeleteAll()
C++
void DeleteAll() abstract
J#
void DeleteAll()
JScript
function DeleteAll()

Exceptions

Exception Type | Condition
AmbienceException | Thrown if the operation failed

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Query Generic Method

IAmbientDataContainer.Query Generic Method

Gets all objects of a particular type in the container.

Overload List

 | Name | Description
Public method | Query | Gets all objects of a particular type in the container.
Public method | Query (Predicate<T>) | Gets all objects of a particular type in the container that match a particular filtering criteria.

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Query Generic Method ()

IAmbientDataContainer.Query Generic Method ()
See Also Example
[image]

Gets all objects of a particular type in the container.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Query(Of T)() As IAmbientDataSet(Of T)
C#
public abstract IAmbientDataSet<T> Query<T>()
C++
public:
IAmbientDataSet<T> Query<T>() abstract
J#
public abstract IAmbientDataSet<T> Query<T>()
JScript
JScript does not support generic types and methods.

Type Parameters

T
The object type

Return Value

The data set

Exceptions

Exception Type | Condition
AmbienceException | Thrown if the operation failed

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace
IAmbientDataContainer.Query Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Query Generic Method (Generic Predicate)

IAmbientDataContainer.Query Generic Method (Generic Predicate)
See Also Example
[image]

Gets all objects of a particular type in the container that match a particular filtering criteria.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Query(Of T)( _
ByVal predicate As Predicate(Of T) _
) As IAmbientDataSet(Of T)
C#
public abstract IAmbientDataSet<T> Query<T>(
Predicate<T> predicate
)
C++
public:
IAmbientDataSet<T> Query<T>(
Predicate<T> predicate
) abstract
J#
public abstract IAmbientDataSet<T> Query<T>(
Predicate<T> predicate
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The object type

Parameters

predicate
The filtering criteria

Return Value

The data set

Exceptions

Exception Type | Condition
AmbienceException | Thrown if the operation failed

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace
IAmbientDataContainer.Query Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Store Method

IAmbientDataContainer.Store Method
[image]

Stores or updates an object in the container.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Sub Store( _
ByVal obj As Object _
)
C#
void Store(
object obj
)
C++
void Store(
Object obj
) abstract
J#
void Store(
object obj
)
JScript
function Store(
obj : Object
)

Parameters

obj
The object to store

Exceptions

Exception Type | Condition
AmbienceException | Thrown if the operation failed

See Also

IAmbientDataContainer Interface
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


IAmbientDataQuery Generic Interface

IAmbientDataQuery Generic Interface
[image]

Represents a lazily evaluated query over Ambient data for use with the LINQ query syntax.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAmbientDataQuery(Of T)
Implements IEnumerable(Of T), IEnumerable
C#
public interface IAmbientDataQuery<T> : IEnumerable<T>, IEnumerable
C++
interface class IAmbientDataQuery<T> : IEnumerable<T>, IEnumerable
J#
public interface IAmbientDataQuery<T> implements IEnumerable<T>, IEnumerable
JScript
JScript does not support generic types and methods.

See Also

IAmbientDataQuery<T> Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


IAmbientDataSet Generic Interface

IAmbientDataSet Generic Interface
[image]

A data set containing Ambient objects.

Namespace: Gallio.Ambience
Assembly: Gallio.Ambience (in Gallio.Ambience.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAmbientDataSet(Of T)
Implements IList(Of T), ICollection(Of T), IEnumerable(Of T), IEnumerable
C#
public interface IAmbientDataSet<T> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
C++
interface class IAmbientDataSet<T> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
J#
public interface IAmbientDataSet<T> implements IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
JScript
JScript does not support generic types and methods.

See Also

IAmbientDataSet<T> Members
Gallio.Ambience Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Ambience [3.0.6.0]


Gallio.Collections

Gallio.Collections Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | ArrayEqualityComparer | Compares arrays for equality by element.
Public class | CollectionUtils | Utility functions for manipulating collections. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | CovariantList | A covariant list converts a list of the input type to a read-only list of the more generic output type. The wrapped list can be used to mimic covariance in method return types.
Public class | EmptyArray | Provides a singleton empty array instance. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | EmptyDictionary | A read-only empty dictionary.
Public class | GenericUtils | Utility functions for manipulating generic collections. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | HashSet | A hashtable-based set implementation.
Public class | LazyCache | Lazily populates and caches values associated with a particular key.
Public class | MultiMap | A multi-map allows a list of values to be associated with a single key.
Public class | PropertyBag | A property bag associates keys with values where each key may have one or more associated value. All keys and values must be non-null strings. This class cannot be inherited.
Public class | PropertySet | A property set associates keys with values where each key may have exactly one associated value. All keys and values must be non-null strings. This class cannot be inherited.
Public class | ReadOnlyDictionary | A read-only dictionary wrapper.
Public class | ReferentialEqualityComparer | An equality comparer that compares values by reference. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | TreeUtils | Provides functions for manipulating ad-hoc trees. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class UserDataCollection

A user data collection stores arbitrary key/value pairs that may be associated with other objects in the system.

Accesses to the collection are synchronized during access. To safely manupulate multiple keys at one time, simply lock the UserDataCollection for the duration of the operation.

Interfaces

 | Interface | Description
Public interface | IMultiMap | A multi-map allows a list of values to be associated with a single key.

Structures

 | Structure | Description
Public structure | Key | A strongly-typed key to be used together with an associative array to help the compiler perform better type checking of the value associated with the key.

Delegates

 | Delegate | Description
NestedPublic delegate | TreeUtils.ChildEnumerator | Enumerates child nodes in a tree.


ArrayEqualityComparer Generic Class

ArrayEqualityComparer Generic Class
See Also Example Members
[image]

Compares arrays for equality by element.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ArrayEqualityComparer(Of T)
Implements IEqualityComparer(Of T[])
C#
public class ArrayEqualityComparer<T> : IEqualityComparer<T[]>
C++
ref class ArrayEqualityComparer<T> : IEqualityComparer<T[]>
J#
public class ArrayEqualityComparer<T> implements IEqualityComparer<T[]>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Collections.ArrayEqualityComparer<T>

See Also

ArrayEqualityComparer<T> Members
Gallio.Collections Namespace


ArrayEqualityComparer<T> Members

ArrayEqualityComparer Members
See Also Example Fields Methods Explicit Inteface Implementations
[image]

Compares arrays for equality by element.

The following tables list the members exposed by ArrayEqualityComparer<T>.

Public Constructors

Name | Description
ArrayEqualityComparer | Overloaded. Initializes a new instance of the ArrayEqualityComparer class.
Top

Public Fields

Name | Description
Default | Gets a default instance of the array equality comparer. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ArrayEqualityComparer | Overloaded. Initializes a new instance of the ArrayEqualityComparer class.
Top

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


ArrayEqualityComparer Constructor

ArrayEqualityComparer Constructor

Initializes a new instance of the ArrayEqualityComparer class.

Overload List

 | Name | Description
Public method | ArrayEqualityComparer | Creates a default array equality comparer.
Public method | ArrayEqualityComparer (IEqualityComparer<T>) | Creates an array equality comparer using the specified element comparer.

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


ArrayEqualityComparer Constructor ()

ArrayEqualityComparer Constructor ()
See Also Example
[image]

Creates a default array equality comparer.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ArrayEqualityComparer()
C++
public:
ArrayEqualityComparer() sealed
J#
public ArrayEqualityComparer()
JScript
JScript does not support generic types and methods.

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace
ArrayEqualityComparer<T> Constructor Overload List


ArrayEqualityComparer Constructor (Generic IEqualityComparer)

ArrayEqualityComparer Constructor (Generic IEqualityComparer)
See Also Example
[image]

Creates an array equality comparer using the specified element comparer.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal elementComparer As IEqualityComparer(Of T) _
)
C#
public ArrayEqualityComparer(
IEqualityComparer<T> elementComparer
)
C++
public:
ArrayEqualityComparer(
IEqualityComparer<T> elementComparer
) sealed
J#
public ArrayEqualityComparer(
IEqualityComparer<T> elementComparer
)
JScript
JScript does not support generic types and methods.

Parameters

elementComparer
The comparer to use to compare individual elements, or null to use Default

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace
ArrayEqualityComparer<T> Constructor Overload List


Fields

ArrayEqualityComparer Fields
[image]

Public Fields

Name | Description
Default | Gets a default instance of the array equality comparer. This field is read-only.
Top

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


Default Field

ArrayEqualityComparer.Default Field
[image]

Gets a default instance of the array equality comparer. This field is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As ArrayEqualityComparer(Of T)
C#
public static readonly ArrayEqualityComparer<T> Default;
C++
public:
static const ArrayEqualityComparer<T> Default;
J#
public static final ArrayEqualityComparer<T> Default
JScript
JScript does not support generic types and methods.

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


Methods

ArrayEqualityComparer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


Equals Method

ArrayEqualityComparer<T>.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (T, T) |
Public method | Equals (Object) | Determines whether the specified Object is equal to the current Object. (inherited from Object)

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


Equals Method (T[], T[])

ArrayEqualityComparer.Equals Method (T[], T[])
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal x As T(), _
ByVal y As T() _
) As Boolean _
Implements IEqualityComparer<T[]>.Equals
C#
public bool Equals(
T[] x,
T[] y
)
C++
public:
bool Equals(
array<T>^ x,
array<T>^ y
) sealed
J#
public bool Equals(
T[] x,
T[] y
)
JScript
JScript does not support generic types and methods.

Implements

IEqualityComparer<T[]>.Equals

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace
ArrayEqualityComparer<T>.Equals Overload List


GetHashCode Method

ArrayEqualityComparer<T>.GetHashCode Method

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Overload List

 | Name | Description
Public method | GetHashCode (T) |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace


GetHashCode Method (T[])

ArrayEqualityComparer.GetHashCode Method (T[])
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHashCode( _
ByVal obj As T() _
) As Integer _
Implements IEqualityComparer<T[]>.GetHashCode
C#
public int GetHashCode(
T[] obj
)
C++
public:
int GetHashCode(
array<T>^ obj
) sealed
J#
public int GetHashCode(
T[] obj
)
JScript
JScript does not support generic types and methods.

Implements

IEqualityComparer<T[]>.GetHashCode

See Also

ArrayEqualityComparer<T> Class
Gallio.Collections Namespace
ArrayEqualityComparer<T>.GetHashCode Overload List


CollectionUtils Class

CollectionUtils Class
See Also Example Members
[image]

Utility functions for manipulating collections. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module CollectionUtils
C#
public static class CollectionUtils
C++
ref class CollectionUtils abstract sealed
J#
public final class CollectionUtils
JScript
public class CollectionUtils

Inheritance Hierarchy

System.Object
Gallio.Collections.CollectionUtils

See Also

CollectionUtils Members
Gallio.Collections Namespace


CollectionUtils Members

CollectionUtils Members
See Also Example Methods
[image]

Utility functions for manipulating collections. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by CollectionUtils.

Public Methods

Name | Description
ConvertAllToArray | Converts all elements of the input collection and returns the collected results as an array of the same size.
Find | Returns the first element of the input enumeration for which the specified predicate returns true.
ToArray | Copies all of the elements of the input collection to an array.
Top

See Also

CollectionUtils Class
Gallio.Collections Namespace


Methods

CollectionUtils Methods
[image]

Public Methods

Name | Description
ConvertAllToArray | Converts all elements of the input collection and returns the collected results as an array of the same size.
Find | Returns the first element of the input enumeration for which the specified predicate returns true.
ToArray | Copies all of the elements of the input collection to an array.
Top

See Also

CollectionUtils Class
Gallio.Collections Namespace


ConvertAllToArray Generic Method

CollectionUtils.ConvertAllToArray Generic Method
[image]

Converts all elements of the input collection and returns the collected results as an array of the same size.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertAllToArray(Of TInput, TOutput)( _
ByVal input As ICollection, _
ByVal converter As Converter(Of TInput, TOutput) _
)
C#
public static TOutput[] ConvertAllToArray<TInput, TOutput>(
ICollection input,
Converter<TInput, TOutput> converter
)
C++
public:
static array<TOutput>^ ConvertAllToArray<TInput, TOutput>(
ICollection input,
Converter<TInput, TOutput> converter
)
J#
public static TOutput[] ConvertAllToArray<TInput, TOutput>(
ICollection input,
Converter<TInput, TOutput> converter
)
JScript
JScript does not support generic types and methods.

Type Parameters

TInput
The input type
TOutput
The output type

Parameters

input
The input collection
converter
The conversion function to apply to each element

Return Value

The output array

See Also

CollectionUtils Class
Gallio.Collections Namespace


Find Generic Method

CollectionUtils.Find Generic Method
[image]

Returns the first element of the input enumeration for which the specified predicate returns true.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Find(Of T)( _
ByVal enumeration As IEnumerable, _
ByVal predicate As Predicate(Of T) _
)
C#
public static T Find<T>(
IEnumerable enumeration,
Predicate<T> predicate
)
C++
public:
static T Find<T>(
IEnumerable enumeration,
Predicate<T> predicate
)
J#
public static T Find<T>(
IEnumerable enumeration,
Predicate<T> predicate
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The element type

Parameters

enumeration
The input enumeration
predicate
The predicate

Return Value

The first matching value or the default for the type if not found

See Also

CollectionUtils Class
Gallio.Collections Namespace


ToArray Generic Method

CollectionUtils.ToArray Generic Method
[image]

Copies all of the elements of the input collection to an array.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToArray(Of T)( _
ByVal collection As ICollection _
)
C#
public static T[] ToArray<T>(
ICollection collection
)
C++
public:
static array<T>^ ToArray<T>(
ICollection collection
)
J#
public static T[] ToArray<T>(
ICollection collection
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The element type

Parameters

collection
The input collection

Return Value

The output array

See Also

CollectionUtils Class
Gallio.Collections Namespace


CovariantList Generic Class

CovariantList Generic Class
See Also Example Members
[image]

A covariant list converts a list of the input type to a read-only list of the more generic output type. The wrapped list can be used to mimic covariance in method return types.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CovariantList(Of TInput As TOutput, TOutput)
Implements IList(Of TOutput), ICollection(Of TOutput), IEnumerable(Of TOutput), IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class CovariantList<TInput, TOutput> : IList<TOutput>, ICollection<TOutput>, IEnumerable<TOutput>, IEnumerable where TInput : TOutput
C++
[DefaultMemberAttribute(L"Item")]
ref class CovariantList<TInput, TOutput> : IList<TOutput>, ICollection<TOutput>, IEnumerable<TOutput>, IEnumerable where TInput : TOutput
J#
/** @attribute DefaultMemberAttribute("Item") */
public class CovariantList<TInput, TOutput> implements IList<TOutput>, ICollection<TOutput>, IEnumerable<TOutput>, IEnumerable
JScript
JScript does not support generic types and methods.

Type Parameters

TInput
The input list type
TOutput
The output list type

Inheritance Hierarchy

System.Object
Gallio.Collections.CovariantList<TInput,TOutput>

See Also

CovariantList<TInput,TOutput> Members
Gallio.Collections Namespace


CovariantList<TInput,TOutput> Members

CovariantList Members
See Also Example Constructors Properties Methods
[image]

A covariant list converts a list of the input type to a read-only list of the more generic output type. The wrapped list can be used to mimic covariance in method return types.

The following tables list the members exposed by CovariantList<TInput,TOutput>.

Public Constructors

 | Name | Description
Public method | CovariantList | Creates a wrapper for the specified list.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


CovariantList Constructor

CovariantList Constructor
[image]

Creates a wrapper for the specified list.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal inputList As IList(Of TInput) _
)
C#
public CovariantList(
IList<TInput> inputList
)
C++
public:
CovariantList(
IList<TInput> inputList
) sealed
J#
public CovariantList(
IList<TInput> inputList
)
JScript
JScript does not support generic types and methods.

Parameters

inputList
The input list

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if inputList is null

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


Properties

CovariantList Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Top

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


Count Property

CovariantList.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<TOutput>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
JScript does not support generic types and methods.

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<TOutput>.Count

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


IsReadOnly Property

CovariantList.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<TOutput>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
JScript does not support generic types and methods.

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<TOutput>.IsReadOnly

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


Item Property

CovariantList.Item Property
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal index As Integer _
)
C#
public TOutput this[
int index
] { get; }
C++
public property TOutput default[int index] sealed {
TOutput get(int index);
}
J#
/** property */
public TOutput get_Item(int index);
JScript
JScript does not support generic types and methods.

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


Methods

CovariantList Methods
[image]

Public Methods

 | Name | Description
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


Contains Method

CovariantList.Contains Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As TOutput _
) As Boolean _
Implements ICollection<TOutput>.Contains
C#
public bool Contains(
TOutput item
)
C++
public:
bool Contains(
TOutput item
) sealed
J#
public bool Contains(
TOutput item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<TOutput>.Contains

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


CopyTo Method

CovariantList.CopyTo Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As TOutput(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<TOutput>.CopyTo
C#
public void CopyTo(
TOutput[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<TOutput>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
TOutput[] array,
int arrayIndex
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<TOutput>.CopyTo

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


GetEnumerator Method

CovariantList.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of TOutput) _
Implements IEnumerable<TOutput>.GetEnumerator
C#
public IEnumerator<TOutput> GetEnumerator()
C++
public:
IEnumerator<TOutput> GetEnumerator() sealed
J#
public IEnumerator<TOutput> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<TOutput>.GetEnumerator

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


IndexOf Method

CovariantList.IndexOf Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal item As TOutput _
) As Integer _
Implements IList<TOutput>.IndexOf
C#
public int IndexOf(
TOutput item
)
C++
public:
int IndexOf(
TOutput item
) sealed
J#
public int IndexOf(
TOutput item
)
JScript
JScript does not support generic types and methods.

Implements

IList<TOutput>.IndexOf

See Also

CovariantList<TInput,TOutput> Class
Gallio.Collections Namespace


EmptyArray Generic Class

EmptyArray Generic Class
See Also Example Members
[image]

Provides a singleton empty array instance. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module EmptyArray(Of T)
C#
public static class EmptyArray<T>
C++
ref class EmptyArray<T> abstract sealed
J#
public final class EmptyArray<T>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of array to provide

Inheritance Hierarchy

System.Object
Gallio.Collections.EmptyArray<T>

See Also

EmptyArray<T> Members
Gallio.Collections Namespace


EmptyArray<T> Members

EmptyArray Members
See Also Example Fields
[image]

Provides a singleton empty array instance. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by EmptyArray<T>.

Public Fields

Name | Description
Instance | An empty array of type T. This field is read-only.
Top

See Also

EmptyArray<T> Class
Gallio.Collections Namespace


Fields

EmptyArray Fields
[image]

Public Fields

Name | Description
Instance | An empty array of type T. This field is read-only.
Top

See Also

EmptyArray<T> Class
Gallio.Collections Namespace


Instance Field

EmptyArray.Instance Field
[image]

An empty array of type T. This field is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As T()
C#
public static readonly T[] Instance;
C++
public:
static const array<T>^ Instance;
J#
public static final T[] Instance
JScript
JScript does not support generic types and methods.

See Also

EmptyArray<T> Class
Gallio.Collections Namespace


EmptyDictionary Generic Class

EmptyDictionary Generic Class
See Also Example Members
[image]

A read-only empty dictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
DefaultMemberAttribute("Item")>
Public Class EmptyDictionary(Of TKey, TValue)
Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)), IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
public class EmptyDictionary<TKey, TValue> : IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
C++
[SerializableAttribute]
[DefaultMemberAttribute(L"Item")]
ref class EmptyDictionary<TKey, TValue> : IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
J#
/** @attribute SerializableAttribute() */
/** @attribute DefaultMemberAttribute("Item") */
public class EmptyDictionary<TKey, TValue> implements IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The dictionary key type
TValue
The dictionary value type

Inheritance Hierarchy

System.Object
Gallio.Collections.EmptyDictionary<TKey,TValue>

See Also

EmptyDictionary<TKey,TValue> Members
Gallio.Collections Namespace


EmptyDictionary<TKey,TValue> Members

EmptyDictionary Members
See Also Example Constructors Fields Properties Methods
[image]

A read-only empty dictionary.

The following tables list the members exposed by EmptyDictionary<TKey,TValue>.

Public Constructors

 | Name | Description
Public method | EmptyDictionary | Initializes a new instance of the EmptyDictionary class.
Top

Public Fields

Name | Description
Instance | A read-only empty dictionary instance. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

Public Methods

 | Name | Description
Public method | Add | Overloaded. Adds an element with the provided key and value to the IDictionary.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains |
Public method | ContainsKey | Determines whether the IDictionary contains an element with the specified key.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove | Overloaded. Removes the element with the specified key from the IDictionary.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


EmptyDictionary Constructor

EmptyDictionary Constructor
[image]

Initializes a new instance of the EmptyDictionary class.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EmptyDictionary()
C++
public:
EmptyDictionary() sealed
J#
public EmptyDictionary()
JScript
JScript does not support generic types and methods.

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Fields

EmptyDictionary Fields
[image]

Public Fields

Name | Description
Instance | A read-only empty dictionary instance. This field is read-only.
Top

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Instance Field

EmptyDictionary.Instance Field
[image]

A read-only empty dictionary instance. This field is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As IDictionary(Of TKey, TValue)
C#
public static readonly IDictionary<TKey, TValue> Instance;
C++
public:
static const IDictionary<TKey, TValue> Instance;
J#
public static final IDictionary<TKey, TValue> Instance
JScript
JScript does not support generic types and methods.

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Properties

EmptyDictionary Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Count Property

EmptyDictionary.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<KeyValuePair`2>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
JScript does not support generic types and methods.

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<KeyValuePair`2>.Count

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


IsReadOnly Property

EmptyDictionary.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<KeyValuePair`2>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
JScript does not support generic types and methods.

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<KeyValuePair`2>.IsReadOnly

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Item Property

EmptyDictionary.Item Property
[image]

Gets or sets the element with the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal key As TKey _
) _
Implements IDictionary<TKey,TValue>.Item
C#
public TValue this[
TKey key
] { get; set; }
C++
public property TValue default[TKey key] sealed {
TValue get(TKey key);
void set(TKey key, TValue value);
}
J#
/** property */
public TValue get_Item(TKey key);

/** property */
public void set_Item(TKey key, TValue value);
JScript
JScript does not support generic types and methods.

Parameters

key
The key of the element to get or set.

Property Value

The element with the specified key.

Implements

IDictionary<TKey,TValue>.Item

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Keys Property

EmptyDictionary.Keys Property
[image]

Gets an ICollection containing the keys of the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of TKey) _
Implements IDictionary<TKey,TValue>.Keys
C#
public ICollection<TKey> Keys { get; }
C++
public property ICollection<TKey> Keys sealed {
ICollection<TKey> get();
}
J#
/** property */
public ICollection<TKey> get_Keys();
JScript
JScript does not support generic types and methods.

Property Value

An ICollection containing the keys of the object that implements IDictionary.

Implements

IDictionary<TKey,TValue>.Keys

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Values Property

EmptyDictionary.Values Property
[image]

Gets an ICollection containing the values in the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of TValue) _
Implements IDictionary<TKey,TValue>.Values
C#
public ICollection<TValue> Values { get; }
C++
public property ICollection<TValue> Values sealed {
ICollection<TValue> get();
}
J#
/** property */
public ICollection<TValue> get_Values();
JScript
JScript does not support generic types and methods.

Property Value

An ICollection containing the values in the object that implements IDictionary.

Implements

IDictionary<TKey,TValue>.Values

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Methods

EmptyDictionary Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Overloaded. Adds an element with the provided key and value to the IDictionary.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains |
Public method | ContainsKey | Determines whether the IDictionary contains an element with the specified key.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove | Overloaded. Removes the element with the specified key from the IDictionary.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Add Method

EmptyDictionary<TKey,TValue>.Add Method

Adds an element with the provided key and value to the IDictionary.

Overload List

 | Name | Description
Public method | Add (TKey, TValue) | Adds an element with the provided key and value to the IDictionary.
Public method | Add (KeyValuePair<TKey, TValue>) |

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Add Method (TKey, TValue)

EmptyDictionary.Add Method (TKey, TValue)
See Also Example
[image]

Adds an element with the provided key and value to the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As TKey, _
ByVal value As TValue _
) _
Implements IDictionary<TKey,TValue>.Add
C#
public void Add(
TKey key,
TValue value
)
C++
public:
void Add(
TKey key,
TValue value
) sealed
J#
public void Add(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The object to use as the key of the element to add.
value
The object to use as the value of the element to add.

Implements

IDictionary<TKey,TValue>.Add

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
EmptyDictionary<TKey,TValue>.Add Overload List


Add Method (Generic KeyValuePair)

EmptyDictionary.Add Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As KeyValuePair(Of TKey, TValue) _
) _
Implements ICollection<KeyValuePair`2>.Add
C#
public void Add(
KeyValuePair<TKey, TValue> item
)
C++
public:
void Add(
KeyValuePair<TKey, TValue> item
) sealed
J#
public void Add(
KeyValuePair<TKey, TValue> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Add

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
EmptyDictionary<TKey,TValue>.Add Overload List


Clear Method

EmptyDictionary.Clear Method
[image]

Removes all items from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<KeyValuePair`2>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Clear

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Contains Method

EmptyDictionary.Contains Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As KeyValuePair(Of TKey, TValue) _
) As Boolean _
Implements ICollection<KeyValuePair`2>.Contains
C#
public bool Contains(
KeyValuePair<TKey, TValue> item
)
C++
public:
bool Contains(
KeyValuePair<TKey, TValue> item
) sealed
J#
public bool Contains(
KeyValuePair<TKey, TValue> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Contains

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


ContainsKey Method

EmptyDictionary.ContainsKey Method
[image]

Determines whether the IDictionary contains an element with the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
ByVal key As TKey _
) As Boolean _
Implements IDictionary<TKey,TValue>.ContainsKey
C#
public bool ContainsKey(
TKey key
)
C++
public:
bool ContainsKey(
TKey key
) sealed
J#
public bool ContainsKey(
TKey key
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key to locate in the IDictionary.

Return Value

true if the IDictionary contains an element with the key; otherwise, false.

Implements

IDictionary<TKey,TValue>.ContainsKey

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


CopyTo Method

EmptyDictionary.CopyTo Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As KeyValuePair(Of TKey, TValue)(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<KeyValuePair`2>.CopyTo
C#
public void CopyTo(
KeyValuePair<TKey, TValue>[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<KeyValuePair<TKey, TValue>>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
KeyValuePair<TKey, TValue>[] array,
int arrayIndex
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.CopyTo

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


GetEnumerator Method

EmptyDictionary.GetEnumerator Method
[image]

Returns an enumerator that iterates through a collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
C#
public IEnumerator GetEnumerator()
C++
public:
IEnumerator GetEnumerator() sealed
J#
public IEnumerator GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable.GetEnumerator

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Remove Method

EmptyDictionary<TKey,TValue>.Remove Method

Removes the element with the specified key from the IDictionary.

Overload List

 | Name | Description
Public method | Remove (TKey) | Removes the element with the specified key from the IDictionary.
Public method | Remove (KeyValuePair<TKey, TValue>) |

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Remove Method (TKey)

EmptyDictionary.Remove Method (TKey)
See Also Example
[image]

Removes the element with the specified key from the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As TKey _
) As Boolean _
Implements IDictionary<TKey,TValue>.Remove
C#
public bool Remove(
TKey key
)
C++
public:
bool Remove(
TKey key
) sealed
J#
public bool Remove(
TKey key
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key of the element to remove.

Return Value

true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original IDictionary.

Implements

IDictionary<TKey,TValue>.Remove

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
EmptyDictionary<TKey,TValue>.Remove Overload List


Remove Method (Generic KeyValuePair)

EmptyDictionary.Remove Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As KeyValuePair(Of TKey, TValue) _
) As Boolean _
Implements ICollection<KeyValuePair`2>.Remove
C#
public bool Remove(
KeyValuePair<TKey, TValue> item
)
C++
public:
bool Remove(
KeyValuePair<TKey, TValue> item
) sealed
J#
public bool Remove(
KeyValuePair<TKey, TValue> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Remove

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
EmptyDictionary<TKey,TValue>.Remove Overload List


TryGetValue Method

EmptyDictionary.TryGetValue Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
ByVal key As TKey, _
<OutAttribute> ByRef value As TValue _
) As Boolean _
Implements IDictionary<TKey,TValue>.TryGetValue
C#
public bool TryGetValue(
TKey key,
out TValue value
)
C++
public:
bool TryGetValue(
TKey key,
[OutAttribute] TValue% value
) sealed
J#
public bool TryGetValue(
TKey key,
/** @attribute OutAttribute() */ /** @ref */ TValue value
)
JScript
JScript does not support generic types and methods.

Implements

IDictionary<TKey,TValue>.TryGetValue

See Also

EmptyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


GenericUtils Class

GenericUtils Class
See Also Example Members
[image]

Utility functions for manipulating generic collections. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module GenericUtils
C#
public static class GenericUtils
C++
ref class GenericUtils abstract sealed
J#
public final class GenericUtils
JScript
public class GenericUtils

Inheritance Hierarchy

System.Object
Gallio.Collections.GenericUtils

See Also

GenericUtils Members
Gallio.Collections Namespace


GenericUtils Members

GenericUtils Members
See Also Example Methods
[image]

Utility functions for manipulating generic collections. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by GenericUtils.

Public Methods

Name | Description
AddAll | Adds all elements of the input enumeration to the output collection.
ConvertAllToArray | Converts each element of the input collection and returns the collected results as an array of the same size.
ConvertAndAddAll | Converts each element of the input collection and adds the result to the output collection succession in the same order.
ConvertAndCopyAll | Converts each element of the input collection and stores the result in the output list using the same index. The output list must be at least as large as the input list.
ElementsEqual | Overloaded. Returns true if the elements of both lists are equal.
ElementsEqualOrderIndependent | Returns true if the elements of both lists are equal but possibly appear in a different order. Handles elements that appear multiple times and ensures that they appear the same number of times in each list.
Find | Returns the first element of the input enumeration for which the specified predicate returns true.
KeyValuePairsEqual | Returns true if both dictionaries have equal key/value pairs.
ToArray | Overloaded. Copies all of the elements of the input collection to an array.
Top

See Also

GenericUtils Class
Gallio.Collections Namespace


Methods

GenericUtils Methods
[image]

Public Methods

Name | Description
AddAll | Adds all elements of the input enumeration to the output collection.
ConvertAllToArray | Converts each element of the input collection and returns the collected results as an array of the same size.
ConvertAndAddAll | Converts each element of the input collection and adds the result to the output collection succession in the same order.
ConvertAndCopyAll | Converts each element of the input collection and stores the result in the output list using the same index. The output list must be at least as large as the input list.
ElementsEqual | Overloaded. Returns true if the elements of both lists are equal.
ElementsEqualOrderIndependent | Returns true if the elements of both lists are equal but possibly appear in a different order. Handles elements that appear multiple times and ensures that they appear the same number of times in each list.
Find | Returns the first element of the input enumeration for which the specified predicate returns true.
KeyValuePairsEqual | Returns true if both dictionaries have equal key/value pairs.
ToArray | Overloaded. Copies all of the elements of the input collection to an array.
Top

See Also

GenericUtils Class
Gallio.Collections Namespace


AddAll Generic Method

GenericUtils.AddAll Generic Method
[image]

Adds all elements of the input enumeration to the output collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddAll(Of T)( _
ByVal input As IEnumerable(Of T), _
ByVal output As ICollection(Of T) _
)
C#
public static void AddAll<T>(
IEnumerable<T> input,
ICollection<T> output
)
C++
public:
static void AddAll<T>(
IEnumerable<T> input,
ICollection<T> output
)
J#
public static void AddAll<T>(
IEnumerable<T> input,
ICollection<T> output
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The element type

Parameters

input
The input enumeration
output
The output collection

See Also

GenericUtils Class
Gallio.Collections Namespace


ConvertAllToArray Generic Method

GenericUtils.ConvertAllToArray Generic Method
[image]

Converts each element of the input collection and returns the collected results as an array of the same size.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertAllToArray(Of TInput, TOutput)( _
ByVal input As ICollection(Of TInput), _
ByVal converter As Converter(Of TInput, TOutput) _
)
C#
public static TOutput[] ConvertAllToArray<TInput, TOutput>(
ICollection<TInput> input,
Converter<TInput, TOutput> converter
)
C++
public:
static array<TOutput>^ ConvertAllToArray<TInput, TOutput>(
ICollection<TInput> input,
Converter<TInput, TOutput> converter
)
J#
public static TOutput[] ConvertAllToArray<TInput, TOutput>(
ICollection<TInput> input,
Converter<TInput, TOutput> converter
)
JScript
JScript does not support generic types and methods.

Type Parameters

TInput
The input type
TOutput
The output type

Parameters

input
The input collection
converter
The conversion function to apply to each element

Return Value

The output array

See Also

GenericUtils Class
Gallio.Collections Namespace


ConvertAndAddAll Generic Method

GenericUtils.ConvertAndAddAll Generic Method
[image]

Converts each element of the input collection and adds the result to the output collection succession in the same order.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConvertAndAddAll(Of TInput, TOutput)( _
ByVal input As ICollection(Of TInput), _
ByVal output As ICollection(Of TOutput), _
ByVal converter As Converter(Of TInput, TOutput) _
)
C#
public static void ConvertAndAddAll<TInput, TOutput>(
ICollection<TInput> input,
ICollection<TOutput> output,
Converter<TInput, TOutput> converter
)
C++
public:
static void ConvertAndAddAll<TInput, TOutput>(
ICollection<TInput> input,
ICollection<TOutput> output,
Converter<TInput, TOutput> converter
)
J#
public static void ConvertAndAddAll<TInput, TOutput>(
ICollection<TInput> input,
ICollection<TOutput> output,
Converter<TInput, TOutput> converter
)
JScript
JScript does not support generic types and methods.

Type Parameters

TInput
The input type
TOutput
The output type

Parameters

input
The input list
output
The output list
converter
The conversion function to apply to each element

See Also

GenericUtils Class
Gallio.Collections Namespace


ConvertAndCopyAll Generic Method

GenericUtils.ConvertAndCopyAll Generic Method
[image]

Converts each element of the input collection and stores the result in the output list using the same index. The output list must be at least as large as the input list.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ConvertAndCopyAll(Of TInput, TOutput)( _
ByVal input As ICollection(Of TInput), _
ByVal output As IList(Of TOutput), _
ByVal converter As Converter(Of TInput, TOutput) _
)
C#
public static void ConvertAndCopyAll<TInput, TOutput>(
ICollection<TInput> input,
IList<TOutput> output,
Converter<TInput, TOutput> converter
)
C++
public:
static void ConvertAndCopyAll<TInput, TOutput>(
ICollection<TInput> input,
IList<TOutput> output,
Converter<TInput, TOutput> converter
)
J#
public static void ConvertAndCopyAll<TInput, TOutput>(
ICollection<TInput> input,
IList<TOutput> output,
Converter<TInput, TOutput> converter
)
JScript
JScript does not support generic types and methods.

Type Parameters

TInput
The input type
TOutput
The output type

Parameters

input
The input list
output
The output list
converter
The conversion function to apply to each element

See Also

GenericUtils Class
Gallio.Collections Namespace


ElementsEqual Generic Method

GenericUtils.ElementsEqual Generic Method

Returns true if the elements of both lists are equal.

Overload List

Name | Description
ElementsEqual (IList<T>, IList<T>) | Returns true if the elements of both lists are equal.
ElementsEqual (IList<T>, IList<T>, Func<T, T, bool>) | Returns true if the elements of both lists are equal.

See Also

GenericUtils Class
Gallio.Collections Namespace


ElementsEqual Generic Method (Generic IList, Generic IList)

GenericUtils.ElementsEqual Generic Method (Generic IList, Generic IList)
See Also Example
[image]

Returns true if the elements of both lists are equal.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ElementsEqual(Of T)( _
ByVal a As IList(Of T), _
ByVal b As IList(Of T) _
) As Boolean
C#
public static bool ElementsEqual<T>(
IList<T> a,
IList<T> b
)
C++
public:
static bool ElementsEqual<T>(
IList<T> a,
IList<T> b
)
J#
public static bool ElementsEqual<T>(
IList<T> a,
IList<T> b
)
JScript
JScript does not support generic types and methods.

Parameters

a
The first collection
b
The second collection

Return Value

True if the elements are equal

See Also

GenericUtils Class
Gallio.Collections Namespace
GenericUtils.ElementsEqual Overload List


ElementsEqual Generic Method (Generic IList, Generic IList, Generic Func)

GenericUtils.ElementsEqual Generic Method (Generic IList, Generic IList, Generic Func)
See Also Example
[image]

Returns true if the elements of both lists are equal.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ElementsEqual(Of T)( _
ByVal a As IList(Of T), _
ByVal b As IList(Of T), _
ByVal comparer As Func(Of T, T, Boolean) _
) As Boolean
C#
public static bool ElementsEqual<T>(
IList<T> a,
IList<T> b,
Func<T, T, bool> comparer
)
C++
public:
static bool ElementsEqual<T>(
IList<T> a,
IList<T> b,
Func<T, T, bool> comparer
)
J#
public static bool ElementsEqual<T>(
IList<T> a,
IList<T> b,
Func<T, T, bool> comparer
)
JScript
JScript does not support generic types and methods.

Parameters

a
The first collection
b
The second collection
comparer
The comparison strategy to use

Return Value

True if the elements are equal

See Also

GenericUtils Class
Gallio.Collections Namespace
GenericUtils.ElementsEqual Overload List


ElementsEqualOrderIndependent Generic Method

GenericUtils.ElementsEqualOrderIndependent Generic Method
[image]

Returns true if the elements of both lists are equal but possibly appear in a different order. Handles elements that appear multiple times and ensures that they appear the same number of times in each list.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ElementsEqualOrderIndependent(Of T)( _
ByVal a As IList(Of T), _
ByVal b As IList(Of T) _
) As Boolean
C#
public static bool ElementsEqualOrderIndependent<T>(
IList<T> a,
IList<T> b
)
C++
public:
static bool ElementsEqualOrderIndependent<T>(
IList<T> a,
IList<T> b
)
J#
public static bool ElementsEqualOrderIndependent<T>(
IList<T> a,
IList<T> b
)
JScript
JScript does not support generic types and methods.

Parameters

a
The first collection
b
The second collection

Return Value

True if the elements are equal

See Also

GenericUtils Class
Gallio.Collections Namespace


Find Generic Method

GenericUtils.Find Generic Method
[image]

Returns the first element of the input enumeration for which the specified predicate returns true.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Find(Of T)( _
ByVal enumeration As IEnumerable(Of T), _
ByVal predicate As Predicate(Of T) _
)
C#
public static T Find<T>(
IEnumerable<T> enumeration,
Predicate<T> predicate
)
C++
public:
static T Find<T>(
IEnumerable<T> enumeration,
Predicate<T> predicate
)
J#
public static T Find<T>(
IEnumerable<T> enumeration,
Predicate<T> predicate
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The element type

Parameters

enumeration
The input enumeration
predicate
The predicate

Return Value

The first matching value or the default for the type if not found

See Also

GenericUtils Class
Gallio.Collections Namespace


KeyValuePairsEqual Generic Method

GenericUtils.KeyValuePairsEqual Generic Method
[image]

Returns true if both dictionaries have equal key/value pairs.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function KeyValuePairsEqual(Of TKey, TValue)( _
ByVal a As IDictionary(Of TKey, TValue), _
ByVal b As IDictionary(Of TKey, TValue) _
) As Boolean
C#
public static bool KeyValuePairsEqual<TKey, TValue>(
IDictionary<TKey, TValue> a,
IDictionary<TKey, TValue> b
)
C++
public:
static bool KeyValuePairsEqual<TKey, TValue>(
IDictionary<TKey, TValue> a,
IDictionary<TKey, TValue> b
)
J#
public static bool KeyValuePairsEqual<TKey, TValue>(
IDictionary<TKey, TValue> a,
IDictionary<TKey, TValue> b
)
JScript
JScript does not support generic types and methods.

Parameters

a
The first collection
b
The second collection

Return Value

True if the elements are equal

See Also

GenericUtils Class
Gallio.Collections Namespace


ToArray Generic Method

GenericUtils.ToArray Generic Method

Copies all of the elements of the input collection to an array.

Overload List

Name | Description
ToArray (ICollection<T>) | Copies all of the elements of the input collection to an array.
ToArray (IEnumerable<T>) | Copies all of the elements of the input enumerable to an array.

See Also

GenericUtils Class
Gallio.Collections Namespace


ToArray Generic Method (Generic ICollection)

GenericUtils.ToArray Generic Method (Generic ICollection)
See Also Example
[image]

Copies all of the elements of the input collection to an array.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToArray(Of T)( _
ByVal collection As ICollection(Of T) _
)
C#
public static T[] ToArray<T>(
ICollection<T> collection
)
C++
public:
static array<T>^ ToArray<T>(
ICollection<T> collection
)
J#
public static T[] ToArray<T>(
ICollection<T> collection
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The element type

Parameters

collection
The input collection

Return Value

The output array

See Also

GenericUtils Class
Gallio.Collections Namespace
GenericUtils.ToArray Overload List


ToArray Generic Method (Generic IEnumerable)

GenericUtils.ToArray Generic Method (Generic IEnumerable)
See Also Example
[image]

Copies all of the elements of the input enumerable to an array.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToArray(Of T)( _
ByVal enumerable As IEnumerable(Of T) _
)
C#
public static T[] ToArray<T>(
IEnumerable<T> enumerable
)
C++
public:
static array<T>^ ToArray<T>(
IEnumerable<T> enumerable
)
J#
public static T[] ToArray<T>(
IEnumerable<T> enumerable
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The element type

Parameters

enumerable
The input enumerable

Return Value

The output array

See Also

GenericUtils Class
Gallio.Collections Namespace
GenericUtils.ToArray Overload List


HashSet Generic Class

HashSet Generic Class
See Also Example Members
[image]

A hashtable-based set implementation.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class HashSet(Of T)
Implements ICollection(Of T), IEnumerable(Of T), IEnumerable
C#
public class HashSet<T> : ICollection<T>, IEnumerable<T>, IEnumerable
C++
ref class HashSet<T> : ICollection<T>, IEnumerable<T>, IEnumerable
J#
public class HashSet<T> implements ICollection<T>, IEnumerable<T>, IEnumerable
JScript
JScript does not support generic types and methods.

Remarks

This will probably be replaced by the new HashSet{T} class in the new System.Core of .Net 3.5.

Inheritance Hierarchy

System.Object
Gallio.Collections.HashSet<T>

See Also

HashSet<T> Members
Gallio.Collections Namespace


HashSet<T> Members

HashSet Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A hashtable-based set implementation.

The following tables list the members exposed by HashSet<T>.

Public Constructors

Name | Description
HashSet | Overloaded. Initializes a new instance of the HashSet class.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Top

Public Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains | Determines whether the ICollection contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
HashSet | Overloaded. Initializes a new instance of the HashSet class.
Top

See Also

HashSet<T> Class
Gallio.Collections Namespace


HashSet Constructor

HashSet Constructor

Initializes a new instance of the HashSet class.

Overload List

 | Name | Description
Public method | HashSet | Creates an empty set.
Public method | HashSet (IEqualityComparer<T>) | Creates an empty set using the specified comparer.

See Also

HashSet<T> Class
Gallio.Collections Namespace


HashSet Constructor ()

HashSet Constructor ()
See Also Example
[image]

Creates an empty set.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HashSet()
C++
public:
HashSet() sealed
J#
public HashSet()
JScript
JScript does not support generic types and methods.

See Also

HashSet<T> Class
Gallio.Collections Namespace
HashSet<T> Constructor Overload List


HashSet Constructor (Generic IEqualityComparer)

HashSet Constructor (Generic IEqualityComparer)
See Also Example
[image]

Creates an empty set using the specified comparer.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal comparer As IEqualityComparer(Of T) _
)
C#
public HashSet(
IEqualityComparer<T> comparer
)
C++
public:
HashSet(
IEqualityComparer<T> comparer
) sealed
J#
public HashSet(
IEqualityComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Parameters

comparer
The comparer, or null to use the default comparer

See Also

HashSet<T> Class
Gallio.Collections Namespace
HashSet<T> Constructor Overload List


Properties

HashSet Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Top

See Also

HashSet<T> Class
Gallio.Collections Namespace


Count Property

HashSet.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<T>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
JScript does not support generic types and methods.

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<T>.Count

See Also

HashSet<T> Class
Gallio.Collections Namespace


IsReadOnly Property

HashSet.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<T>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
JScript does not support generic types and methods.

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<T>.IsReadOnly

See Also

HashSet<T> Class
Gallio.Collections Namespace


Methods

HashSet Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds an item to the ICollection.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains | Determines whether the ICollection contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove | Removes the first occurrence of a specific object from the ICollection.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

HashSet<T> Class
Gallio.Collections Namespace


Add Method

HashSet.Add Method
[image]

Adds an item to the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As T _
) _
Implements ICollection<T>.Add
C#
public void Add(
T item
)
C++
public:
void Add(
T item
) sealed
J#
public void Add(
T item
)
JScript
JScript does not support generic types and methods.

Parameters

item
The object to add to the ICollection.

Implements

ICollection<T>.Add

See Also

HashSet<T> Class
Gallio.Collections Namespace


Clear Method

HashSet.Clear Method
[image]

Removes all items from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<T>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
JScript does not support generic types and methods.

Implements

ICollection<T>.Clear

See Also

HashSet<T> Class
Gallio.Collections Namespace


Contains Method

HashSet.Contains Method
[image]

Determines whether the ICollection contains a specific value.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As T _
) As Boolean _
Implements ICollection<T>.Contains
C#
public bool Contains(
T item
)
C++
public:
bool Contains(
T item
) sealed
J#
public bool Contains(
T item
)
JScript
JScript does not support generic types and methods.

Parameters

item
The object to locate in the ICollection.

Return Value

true if item is found in the ICollection; otherwise, false.

Implements

ICollection<T>.Contains

See Also

HashSet<T> Class
Gallio.Collections Namespace


CopyTo Method

HashSet.CopyTo Method
[image]

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As T(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<T>.CopyTo
C#
public void CopyTo(
T[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<T>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
T[] array,
int arrayIndex
)
JScript
JScript does not support generic types and methods.

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.

Implements

ICollection<T>.CopyTo

See Also

HashSet<T> Class
Gallio.Collections Namespace


GetEnumerator Method

HashSet.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of T) _
Implements IEnumerable<T>.GetEnumerator
C#
public IEnumerator<T> GetEnumerator()
C++
public:
IEnumerator<T> GetEnumerator() sealed
J#
public IEnumerator<T> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<T>.GetEnumerator

See Also

HashSet<T> Class
Gallio.Collections Namespace


Remove Method

HashSet.Remove Method
[image]

Removes the first occurrence of a specific object from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As T _
) As Boolean _
Implements ICollection<T>.Remove
C#
public bool Remove(
T item
)
C++
public:
bool Remove(
T item
) sealed
J#
public bool Remove(
T item
)
JScript
JScript does not support generic types and methods.

Parameters

item
The object to remove from the ICollection.

Return Value

true if item was successfully removed from the ICollection; otherwise, false. This method also returns false if item is not found in the original ICollection.

Implements

ICollection<T>.Remove

See Also

HashSet<T> Class
Gallio.Collections Namespace


IMultiMap Generic Interface

IMultiMap Generic Interface
See Also Example Members
[image]

A multi-map allows a list of values to be associated with a single key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMultiMap(Of TKey, TValue)
Implements IDictionary(Of TKey, IList(Of TValue)), ICollection(Of KeyValuePair(Of TKey, IList(Of TValue))), IEnumerable(Of KeyValuePair(Of TKey, IList(Of TValue))), IEnumerable
C#
public interface IMultiMap<TKey, TValue> : IDictionary<TKey, IList<TValue>>, ICollection<KeyValuePair<TKey, IList<TValue>>>, IEnumerable<KeyValuePair<TKey, IList<TValue>>>, IEnumerable
C++
interface class IMultiMap<TKey, TValue> : IDictionary<TKey, IList<TValue>>, ICollection<KeyValuePair<TKey, IList<TValue>>>, IEnumerable<KeyValuePair<TKey, IList<TValue>>>, IEnumerable
J#
public interface IMultiMap<TKey, TValue> implements IDictionary<TKey, IList<TValue>>, ICollection<KeyValuePair<TKey, IList<TValue>>>, IEnumerable<KeyValuePair<TKey, IList<TValue>>>, IEnumerable
JScript
JScript does not support generic types and methods.

Types that implement IMultiMap<TKey,TValue>

Type | Description
Gallio.Collections.MultiMap<TKey,TValue> | A multi-map allows a list of values to be associated with a single key.
Gallio.Collections.PropertyBag | A property bag associates keys with values where each key may have one or more associated value. All keys and values must be non-null strings. This class cannot be inherited.

Remarks

The value collections provided by the multi-map are always read-only. They can only be modified by calling the appropriate methods of the multi-map to add or remove items. This behavior helps multi-map implementations better maintain their invariants.

See Also

IMultiMap<TKey,TValue> Members
Gallio.Collections Namespace


IMultiMap<TKey,TValue> Members

IMultiMap Members
See Also Example Properties Methods
[image]

A multi-map allows a list of values to be associated with a single key.

The following tables list the members exposed by IMultiMap<TKey,TValue>.

Public Properties

 | Name | Description
Public property | Pairs | Gets the contents of the multi-map as an enumeration of pairs.
Top

Public Methods

 | Name | Description
Public method | Add | Adds a value to the list of those associated with a key.
Public method | AddAll | Overloaded. Adds all of the values from the specified enumeration of key-value pairs.
Public method | Contains | Returns true if the map contains an entry with the specified key and value.
Public method | Remove | Removes a value from the list of those associated with a key.
Top

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


Properties

IMultiMap Properties
[image]

Public Properties

 | Name | Description
Public property | Pairs | Gets the contents of the multi-map as an enumeration of pairs.
Top

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


Pairs Property

IMultiMap.Pairs Property
[image]

Gets the contents of the multi-map as an enumeration of pairs.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Pairs As IEnumerable(Of KeyValuePair(Of TKey, TValue))
C#
IEnumerable<KeyValuePair<TKey, TValue>> Pairs { get; }
C++
property IEnumerable<KeyValuePair<TKey, TValue>> Pairs abstract {
IEnumerable<KeyValuePair<TKey, TValue>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<TKey, TValue>> get_Pairs();
JScript
JScript does not support generic types and methods.

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


Methods

IMultiMap Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds a value to the list of those associated with a key.
Public method | AddAll | Overloaded. Adds all of the values from the specified enumeration of key-value pairs.
Public method | Contains | Returns true if the map contains an entry with the specified key and value.
Public method | Remove | Removes a value from the list of those associated with a key.
Top

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


Add Method

IMultiMap.Add Method
[image]

Adds a value to the list of those associated with a key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Add( _
ByVal key As TKey, _
ByVal value As TValue _
)
C#
void Add(
TKey key,
TValue value
)
C++
void Add(
TKey key,
TValue value
) abstract
J#
void Add(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
value
The value to associate

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


AddAll Method

IMultiMap<TKey,TValue>.AddAll Method

Adds all of the values from the specified enumeration of key-value pairs.

Overload List

 | Name | Description
Public method | AddAll (IEnumerable<KeyValuePair<TKey, TValue>>) | Adds all of the values from the specified enumeration of key-value pairs.
Public method | AddAll (IEnumerable<KeyValuePair<TKey, IList<TValue>>>) | Adds all of the values from the specified map.

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


AddAll Method (Generic IEnumerable)

IMultiMap.AddAll Method (Generic IEnumerable)
See Also Example
[image]

Adds all of the values from the specified enumeration of key-value pairs.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddAll( _
ByVal pairs As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
)
C#
public abstract void AddAll(
IEnumerable<KeyValuePair<TKey, TValue>> pairs
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<TKey, TValue>> pairs
) abstract
J#
public abstract void AddAll(
IEnumerable<KeyValuePair<TKey, TValue>> pairs
)
JScript
JScript does not support generic types and methods.

Parameters

pairs
The key-value pairs

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if pairs is null

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace
IMultiMap<TKey,TValue>.AddAll Overload List


AddAll Method (Generic IEnumerable)

IMultiMap.AddAll Method (Generic IEnumerable)
See Also Example
[image]

Adds all of the values from the specified map.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddAll( _
ByVal map As IEnumerable(Of KeyValuePair(Of TKey, IList(Of TValue))) _
)
C#
public abstract void AddAll(
IEnumerable<KeyValuePair<TKey, IList<TValue>>> map
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<TKey, IList<TValue>>> map
) abstract
J#
public abstract void AddAll(
IEnumerable<KeyValuePair<TKey, IList<TValue>>> map
)
JScript
JScript does not support generic types and methods.

Parameters

map
The map

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if map is null

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace
IMultiMap<TKey,TValue>.AddAll Overload List


Contains Method

IMultiMap.Contains Method
[image]

Returns true if the map contains an entry with the specified key and value.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Contains( _
ByVal key As TKey, _
ByVal value As TValue _
) As Boolean
C#
bool Contains(
TKey key,
TValue value
)
C++
bool Contains(
TKey key,
TValue value
) abstract
J#
bool Contains(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
value
The value to find

Return Value

True if the map contains an entry with the specified key and value

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


Remove Method

IMultiMap.Remove Method
[image]

Removes a value from the list of those associated with a key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Remove( _
ByVal key As TKey, _
ByVal value As TValue _
) As Boolean
C#
bool Remove(
TKey key,
TValue value
)
C++
bool Remove(
TKey key,
TValue value
) abstract
J#
bool Remove(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
value
The value to remove from the key

Return Value

True if the value was removed

See Also

IMultiMap<TKey,TValue> Interface
Gallio.Collections Namespace


Key Generic Structure

Key Generic Structure
See Also Example Members
[image]

A strongly-typed key to be used together with an associative array to help the compiler perform better type checking of the value associated with the key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure Key(Of TValue)
C#
public struct Key<TValue>
C++
value class Key<TValue>
J#
public final class Key<TValue> extends ValueType
JScript
JScript does not support generic types and methods.

Type Parameters

TValue
The type of value associated with the key

Inheritance Hierarchy

System.Object
Gallio.Collections.Key<TValue>

See Also

Key<TValue> Members
Gallio.Collections Namespace


Key<TValue> Members

Key Members
See Also Example Constructors Properties Methods
[image]

A strongly-typed key to be used together with an associative array to help the compiler perform better type checking of the value associated with the key.

The following tables list the members exposed by Key<TValue>.

Public Constructors

 | Name | Description
Public method | Key | Creates a new key.
Top

Public Properties

 | Name | Description
Public property | Name | Gets the unique name of the key.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

Key<TValue> Structure
Gallio.Collections Namespace


Key Constructor

Key Constructor
[image]

Creates a new key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public Key(
string name
)
C++
public:
Key(
String name
) sealed
J#
public Key(
string name
)
JScript
JScript does not support generic types and methods.

Parameters

name
The unique name of the key

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

Key<TValue> Structure
Gallio.Collections Namespace


Properties

Key Properties
[image]

Public Properties

 | Name | Description
Public property | Name | Gets the unique name of the key.
Top

See Also

Key<TValue> Structure
Gallio.Collections Namespace


Name Property

Key.Name Property
[image]

Gets the unique name of the key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
JScript does not support generic types and methods.

See Also

Key<TValue> Structure
Gallio.Collections Namespace


LazyCache Generic Class

LazyCache Generic Class
See Also Example Members
[image]

Lazily populates and caches values associated with a particular key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class LazyCache(Of TKey, TValue)
C#
[DefaultMemberAttribute("Item")]
public class LazyCache<TKey, TValue>
C++
[DefaultMemberAttribute(L"Item")]
ref class LazyCache<TKey, TValue>
J#
/** @attribute DefaultMemberAttribute("Item") */
public class LazyCache<TKey, TValue>
JScript
JScript does not support generic types and methods.

Remarks

Instances of this type are safe for use by multiple concurrent threads. In the case of a race occurs between two threads that result in the population of the same key, the populator function may be called concurrently with two requests for the same key. The winner of the race gets to store its value in the cache for later use. However, the loser of the race will discard its value and use the newly cached instead.

Inheritance Hierarchy

System.Object
Gallio.Collections.LazyCache<TKey,TValue>

See Also

LazyCache<TKey,TValue> Members
Gallio.Collections Namespace


LazyCache<TKey,TValue> Members

LazyCache Members
See Also Example Constructors Properties Methods
[image]

Lazily populates and caches values associated with a particular key.

The following tables list the members exposed by LazyCache<TKey,TValue>.

Public Constructors

 | Name | Description
Public method | LazyCache | Creates a cache with the specified populator function.
Top

Public Properties

 | Name | Description
Public property | Item | Gets the value associated with the specified key. Populates it on demand if not already cached.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LazyCache<TKey,TValue> Class
Gallio.Collections Namespace


LazyCache Constructor

LazyCache Constructor
[image]

Creates a cache with the specified populator function.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal populator As Func(Of TKey, TValue) _
)
C#
public LazyCache(
Func<TKey, TValue> populator
)
C++
public:
LazyCache(
Func<TKey, TValue> populator
) sealed
J#
public LazyCache(
Func<TKey, TValue> populator
)
JScript
JScript does not support generic types and methods.

Parameters

populator
A function that provides a value given a key

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if populator is null

See Also

LazyCache<TKey,TValue> Class
Gallio.Collections Namespace


Properties

LazyCache Properties
[image]

Public Properties

 | Name | Description
Public property | Item | Gets the value associated with the specified key. Populates it on demand if not already cached.
Top

See Also

LazyCache<TKey,TValue> Class
Gallio.Collections Namespace


Item Property

LazyCache.Item Property
[image]

Gets the value associated with the specified key. Populates it on demand if not already cached.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal key As TKey _
)
C#
public TValue this[
TKey key
] { get; }
C++
public property TValue default[TKey key] sealed {
TValue get(TKey key);
}
J#
/** property */
public TValue get_Item(TKey key);
JScript
JScript does not support generic types and methods.

Parameters

key
The key

Property Value

The associated value

See Also

LazyCache<TKey,TValue> Class
Gallio.Collections Namespace


MultiMap Generic Class

MultiMap Generic Class
See Also Example Members
[image]

A multi-map allows a list of values to be associated with a single key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
DefaultMemberAttribute("Item")>
Public Class MultiMap(Of TKey, TValue)
Implements IMultiMap(Of TKey, TValue), IDictionary(Of TKey, IList(Of TValue)), ICollection(Of KeyValuePair(Of TKey, IList(Of TValue))), IEnumerable(Of KeyValuePair(Of TKey, IList(Of TValue))), IEnumerable
C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
public class MultiMap<TKey, TValue> : IMultiMap<TKey, TValue>, IDictionary<TKey, IList<TValue>>, ICollection<KeyValuePair<TKey, IList<TValue>>>, IEnumerable<KeyValuePair<TKey, IList<TValue>>>, IEnumerable
C++
[SerializableAttribute]
[DefaultMemberAttribute(L"Item")]
ref class MultiMap<TKey, TValue> : IMultiMap<TKey, TValue>, IDictionary<TKey, IList<TValue>>, ICollection<KeyValuePair<TKey, IList<TValue>>>, IEnumerable<KeyValuePair<TKey, IList<TValue>>>, IEnumerable
J#
/** @attribute SerializableAttribute() */
/** @attribute DefaultMemberAttribute("Item") */
public class MultiMap<TKey, TValue> implements IMultiMap<TKey, TValue>, IDictionary<TKey, IList<TValue>>, ICollection<KeyValuePair<TKey, IList<TValue>>>, IEnumerable<KeyValuePair<TKey, IList<TValue>>>, IEnumerable
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Collections.MultiMap<TKey,TValue>

See Also

MultiMap<TKey,TValue> Members
Gallio.Collections Namespace


MultiMap<TKey,TValue> Members

MultiMap Members
See Also Example Constructors Properties Methods
[image]

A multi-map allows a list of values to be associated with a single key.

The following tables list the members exposed by MultiMap<TKey,TValue>.

Public Constructors

 | Name | Description
Public method | MultiMap | Creates an empty multi-map.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of distinct keys in the map.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item | Gets or sets the list of values associated with the specified key. Returns an empty list if there are none.
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Pairs | Gets the contents of the multi-map as an enumeration of pairs.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

Public Methods

 | Name | Description
Public method | Add | Overloaded. Adds a value to the list of those associated with a key.
Public method | AddAll | Overloaded. Adds all of the values from the specified enumeration of key-value pairs.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains | Overloaded. Returns true if the map contains an entry with the specified key and value.
Public method | ContainsKey | Returns true if the map contains at least one value associated with the specified key.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | ReadOnly | Obtains a read-only view of another multi-map.
Public method | Remove | Overloaded. Removes all values associated with the specified key.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


MultiMap Constructor

MultiMap Constructor
[image]

Creates an empty multi-map.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MultiMap()
C++
public:
MultiMap() sealed
J#
public MultiMap()
JScript
JScript does not support generic types and methods.

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Properties

MultiMap Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of distinct keys in the map.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item | Gets or sets the list of values associated with the specified key. Returns an empty list if there are none.
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Pairs | Gets the contents of the multi-map as an enumeration of pairs.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Count Property

MultiMap.Count Property
[image]

Gets the number of distinct keys in the map.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<KeyValuePair`2>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Count

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


IsReadOnly Property

MultiMap.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<KeyValuePair`2>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
JScript does not support generic types and methods.

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<KeyValuePair`2>.IsReadOnly

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Item Property

MultiMap.Item Property
[image]

Gets or sets the list of values associated with the specified key. Returns an empty list if there are none.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal key As TKey _
) As IList(Of TValue) _
Implements IDictionary<TKey,IList`1>.Item
C#
public IList<TValue> this[
TKey key
] { get; set; }
C++
public property IList<TValue> default[TKey key] sealed {
IList<TValue> get(TKey key);
void set(TKey key, IList<TValue> value);
}
J#
/** property */
public IList<TValue> get_Item(TKey key);

/** property */
public void set_Item(TKey key, IList<TValue> value);
JScript
JScript does not support generic types and methods.

Parameters

key
The key

Property Value

The list of values

Implements

IDictionary<TKey,IList`1>.Item

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Keys Property

MultiMap.Keys Property
[image]

Gets an ICollection containing the keys of the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of TKey) _
Implements IDictionary<TKey,IList`1>.Keys
C#
public ICollection<TKey> Keys { get; }
C++
public property ICollection<TKey> Keys sealed {
ICollection<TKey> get();
}
J#
/** property */
public ICollection<TKey> get_Keys();
JScript
JScript does not support generic types and methods.

Property Value

An ICollection containing the keys of the object that implements IDictionary.

Implements

IDictionary<TKey,IList`1>.Keys

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Pairs Property

MultiMap.Pairs Property
[image]

Gets the contents of the multi-map as an enumeration of pairs.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pairs As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
Implements IMultiMap<TKey,TValue>.Pairs
C#
public IEnumerable<KeyValuePair<TKey, TValue>> Pairs { get; }
C++
public property IEnumerable<KeyValuePair<TKey, TValue>> Pairs sealed {
IEnumerable<KeyValuePair<TKey, TValue>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<TKey, TValue>> get_Pairs();
JScript
JScript does not support generic types and methods.

Implements

IMultiMap<TKey,TValue>.Pairs

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Values Property

MultiMap.Values Property
[image]

Gets an ICollection containing the values in the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of IList(Of TValue)) _
Implements IDictionary<TKey,IList`1>.Values
C#
public ICollection<IList<TValue>> Values { get; }
C++
public property ICollection<IList<TValue>> Values sealed {
ICollection<IList<TValue>> get();
}
J#
/** property */
public ICollection<IList<TValue>> get_Values();
JScript
JScript does not support generic types and methods.

Property Value

An ICollection containing the values in the object that implements IDictionary.

Implements

IDictionary<TKey,IList`1>.Values

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Methods

MultiMap Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Overloaded. Adds a value to the list of those associated with a key.
Public method | AddAll | Overloaded. Adds all of the values from the specified enumeration of key-value pairs.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains | Overloaded. Returns true if the map contains an entry with the specified key and value.
Public method | ContainsKey | Returns true if the map contains at least one value associated with the specified key.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | ReadOnly | Obtains a read-only view of another multi-map.
Public method | Remove | Overloaded. Removes all values associated with the specified key.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Add Method

MultiMap<TKey,TValue>.Add Method

Adds a value to the list of those associated with a key.

Overload List

 | Name | Description
Public method | Add (TKey, TValue) | Adds a value to the list of those associated with a key.
Public method | Add (TKey, IList<TValue>) | Adds all values in the pair to the specified key.
Public method | Add (KeyValuePair<TKey, IList<TValue>>) | Adds all values in the pair to the specified key.

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Add Method (TKey, TValue)

MultiMap.Add Method (TKey, TValue)
See Also Example
[image]

Adds a value to the list of those associated with a key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As TKey, _
ByVal value As TValue _
) _
Implements IMultiMap<TKey,TValue>.Add
C#
public void Add(
TKey key,
TValue value
)
C++
public:
void Add(
TKey key,
TValue value
) sealed
J#
public void Add(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
value
The value to associate

Implements

IMultiMap<TKey,TValue>.Add

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Add Overload List


Add Method (TKey, Generic IList)

MultiMap.Add Method (TKey, Generic IList)
See Also Example
[image]

Adds all values in the pair to the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As TKey, _
ByVal values As IList(Of TValue) _
) _
Implements IDictionary<TKey,IList`1>.Add
C#
public void Add(
TKey key,
IList<TValue> values
)
C++
public:
void Add(
TKey key,
IList<TValue> values
) sealed
J#
public void Add(
TKey key,
IList<TValue> values
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
values
The values

Implements

IDictionary<TKey,IList`1>.Add

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Add Overload List


Add Method (Generic KeyValuePair)

MultiMap.Add Method (Generic KeyValuePair)
See Also Example
[image]

Adds all values in the pair to the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As KeyValuePair(Of TKey, IList(Of TValue)) _
) _
Implements ICollection<KeyValuePair`2>.Add
C#
public void Add(
KeyValuePair<TKey, IList<TValue>> item
)
C++
public:
void Add(
KeyValuePair<TKey, IList<TValue>> item
) sealed
J#
public void Add(
KeyValuePair<TKey, IList<TValue>> item
)
JScript
JScript does not support generic types and methods.

Parameters

item
The key and values pair

Implements

ICollection<KeyValuePair`2>.Add

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Add Overload List


AddAll Method

MultiMap<TKey,TValue>.AddAll Method

Adds all of the values from the specified enumeration of key-value pairs.

Overload List

 | Name | Description
Public method | AddAll (IEnumerable<KeyValuePair<TKey, TValue>>) | Adds all of the values from the specified enumeration of key-value pairs.
Public method | AddAll (IEnumerable<KeyValuePair<TKey, IList<TValue>>>) | Adds all of the values from the specified map.

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


AddAll Method (Generic IEnumerable)

MultiMap.AddAll Method (Generic IEnumerable)
See Also Example
[image]

Adds all of the values from the specified enumeration of key-value pairs.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAll( _
ByVal pairs As IEnumerable(Of KeyValuePair(Of TKey, TValue)) _
) _
Implements IMultiMap<TKey,TValue>.AddAll
C#
public void AddAll(
IEnumerable<KeyValuePair<TKey, TValue>> pairs
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<TKey, TValue>> pairs
) sealed
J#
public void AddAll(
IEnumerable<KeyValuePair<TKey, TValue>> pairs
)
JScript
JScript does not support generic types and methods.

Parameters

pairs
The key-value pairs

Implements

IMultiMap<TKey,TValue>.AddAll

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.AddAll Overload List


AddAll Method (Generic IEnumerable)

MultiMap.AddAll Method (Generic IEnumerable)
See Also Example
[image]

Adds all of the values from the specified map.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAll( _
ByVal map As IEnumerable(Of KeyValuePair(Of TKey, IList(Of TValue))) _
) _
Implements IMultiMap<TKey,TValue>.AddAll
C#
public void AddAll(
IEnumerable<KeyValuePair<TKey, IList<TValue>>> map
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<TKey, IList<TValue>>> map
) sealed
J#
public void AddAll(
IEnumerable<KeyValuePair<TKey, IList<TValue>>> map
)
JScript
JScript does not support generic types and methods.

Parameters

map
The map

Implements

IMultiMap<TKey,TValue>.AddAll

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.AddAll Overload List


Clear Method

MultiMap.Clear Method
[image]

Removes all items from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<KeyValuePair`2>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Clear

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Contains Method

MultiMap<TKey,TValue>.Contains Method

Returns true if the map contains an entry with the specified key and value.

Overload List

 | Name | Description
Public method | Contains (TKey, TValue) | Returns true if the map contains an entry with the specified key and value.
Public method | Contains (KeyValuePair<TKey, IList<TValue>>) |

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Contains Method (TKey, TValue)

MultiMap.Contains Method (TKey, TValue)
See Also Example
[image]

Returns true if the map contains an entry with the specified key and value.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal key As TKey, _
ByVal value As TValue _
) As Boolean _
Implements IMultiMap<TKey,TValue>.Contains
C#
public bool Contains(
TKey key,
TValue value
)
C++
public:
bool Contains(
TKey key,
TValue value
) sealed
J#
public bool Contains(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
value
The value to find

Return Value

True if the map contains an entry with the specified key and value

Implements

IMultiMap<TKey,TValue>.Contains

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Contains Overload List


Contains Method (Generic KeyValuePair)

MultiMap.Contains Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As KeyValuePair(Of TKey, IList(Of TValue)) _
) As Boolean _
Implements ICollection<KeyValuePair`2>.Contains
C#
public bool Contains(
KeyValuePair<TKey, IList<TValue>> item
)
C++
public:
bool Contains(
KeyValuePair<TKey, IList<TValue>> item
) sealed
J#
public bool Contains(
KeyValuePair<TKey, IList<TValue>> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Contains

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Contains Overload List


ContainsKey Method

MultiMap.ContainsKey Method
[image]

Returns true if the map contains at least one value associated with the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
ByVal key As TKey _
) As Boolean _
Implements IDictionary<TKey,IList`1>.ContainsKey
C#
public bool ContainsKey(
TKey key
)
C++
public:
bool ContainsKey(
TKey key
) sealed
J#
public bool ContainsKey(
TKey key
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key

Return Value

True if there is at least one value associated with the key

Implements

IDictionary<TKey,IList`1>.ContainsKey

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


CopyTo Method

MultiMap.CopyTo Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As KeyValuePair(Of TKey, IList(Of TValue))(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<KeyValuePair`2>.CopyTo
C#
public void CopyTo(
KeyValuePair<TKey, IList<TValue>>[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<KeyValuePair<TKey, IList<TValue>>>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
KeyValuePair<TKey, IList<TValue>>[] array,
int arrayIndex
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.CopyTo

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


GetEnumerator Method

MultiMap.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of KeyValuePair(Of TKey, IList(Of TValue))) _
Implements IEnumerable<KeyValuePair`2>.GetEnumerator
C#
public IEnumerator<KeyValuePair<TKey, IList<TValue>>> GetEnumerator()
C++
public:
IEnumerator<KeyValuePair<TKey, IList<TValue>>> GetEnumerator() sealed
J#
public IEnumerator<KeyValuePair<TKey, IList<TValue>>> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<KeyValuePair`2>.GetEnumerator

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


ReadOnly Method

MultiMap.ReadOnly Method
[image]

Obtains a read-only view of another multi-map.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadOnly( _
ByVal map As IMultiMap(Of TKey, TValue) _
) As IMultiMap(Of TKey, TValue)
C#
public static IMultiMap<TKey, TValue> ReadOnly(
IMultiMap<TKey, TValue> map
)
C++
public:
static IMultiMap<TKey, TValue> ReadOnly(
IMultiMap<TKey, TValue> map
)
J#
public static IMultiMap<TKey, TValue> ReadOnly(
IMultiMap<TKey, TValue> map
)
JScript
JScript does not support generic types and methods.

Parameters

map
The multi-map

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if map is null

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Remove Method

MultiMap<TKey,TValue>.Remove Method

Removes all values associated with the specified key.

Overload List

 | Name | Description
Public method | Remove (TKey) | Removes all values associated with the specified key.
Public method | Remove (TKey, TValue) | Removes a value from the list of those associated with a key.
Public method | Remove (KeyValuePair<TKey, IList<TValue>>) | Removes all values in the pair from the specified key.

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


Remove Method (TKey)

MultiMap.Remove Method (TKey)
See Also Example
[image]

Removes all values associated with the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As TKey _
) As Boolean _
Implements IDictionary<TKey,IList`1>.Remove
C#
public bool Remove(
TKey key
)
C++
public:
bool Remove(
TKey key
) sealed
J#
public bool Remove(
TKey key
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key

Return Value

True if the key existed and was removed

Implements

IDictionary<TKey,IList`1>.Remove

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Remove Overload List


Remove Method (TKey, TValue)

MultiMap.Remove Method (TKey, TValue)
See Also Example
[image]

Removes a value from the list of those associated with a key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As TKey, _
ByVal value As TValue _
) As Boolean _
Implements IMultiMap<TKey,TValue>.Remove
C#
public bool Remove(
TKey key,
TValue value
)
C++
public:
bool Remove(
TKey key,
TValue value
) sealed
J#
public bool Remove(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key
value
The value to remove from the key

Return Value

True if the value was removed

Implements

IMultiMap<TKey,TValue>.Remove

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Remove Overload List


Remove Method (Generic KeyValuePair)

MultiMap.Remove Method (Generic KeyValuePair)
See Also Example
[image]

Removes all values in the pair from the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As KeyValuePair(Of TKey, IList(Of TValue)) _
) As Boolean _
Implements ICollection<KeyValuePair`2>.Remove
C#
public bool Remove(
KeyValuePair<TKey, IList<TValue>> item
)
C++
public:
bool Remove(
KeyValuePair<TKey, IList<TValue>> item
) sealed
J#
public bool Remove(
KeyValuePair<TKey, IList<TValue>> item
)
JScript
JScript does not support generic types and methods.

Parameters

item
The key and values pair

Return Value

True if at least one value was removed

Implements

ICollection<KeyValuePair`2>.Remove

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace
MultiMap<TKey,TValue>.Remove Overload List


TryGetValue Method

MultiMap.TryGetValue Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
ByVal key As TKey, _
<OutAttribute> ByRef value As IList(Of TValue) _
) As Boolean _
Implements IDictionary<TKey,IList`1>.TryGetValue
C#
public bool TryGetValue(
TKey key,
out IList<TValue> value
)
C++
public:
bool TryGetValue(
TKey key,
[OutAttribute] IList<TValue>% value
) sealed
J#
public bool TryGetValue(
TKey key,
/** @attribute OutAttribute() */ /** @ref */ IList<TValue> value
)
JScript
JScript does not support generic types and methods.

Implements

IDictionary<TKey,IList`1>.TryGetValue

See Also

MultiMap<TKey,TValue> Class
Gallio.Collections Namespace


PropertyBag Class

PropertyBag Class
See Also Example Members
[image]

A property bag associates keys with values where each key may have one or more associated value. All keys and values must be non-null strings. This class cannot be inherited.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("propertyBag", Namespace := "http://www.gallio.org/"), _
XmlSchemaProviderAttribute("ProvideXmlSchema"), _
DefaultMemberAttribute("Item")>
Public NotInheritable Class PropertyBag
Implements IMultiMap(Of String, String), IDictionary(Of String, IList(Of String)), ICollection(Of KeyValuePair(Of String, IList(Of String))), IEnumerable(Of KeyValuePair(Of String, IList(Of String))), IEnumerable, IXmlSerializable, IEquatable(Of PropertyBag)
C#
[SerializableAttribute]
[XmlRootAttribute("propertyBag", Namespace = "http://www.gallio.org/")]
[XmlSchemaProviderAttribute("ProvideXmlSchema")]
[DefaultMemberAttribute("Item")]
public sealed class PropertyBag : IMultiMap<string, string>, IDictionary<string, IList<string>>, ICollection<KeyValuePair<string, IList<string>>>, IEnumerable<KeyValuePair<string, IList<string>>>, IEnumerable, IXmlSerializable, IEquatable<PropertyBag>
C++
[SerializableAttribute]
[XmlRootAttribute(L"propertyBag", Namespace = L"http://www.gallio.org/")]
[XmlSchemaProviderAttribute(L"ProvideXmlSchema")]
[DefaultMemberAttribute(L"Item")]
ref class PropertyBag sealed : IMultiMap<string, string>, IDictionary<string, IList<string>>, ICollection<KeyValuePair<string, IList<string>>>, IEnumerable<KeyValuePair<string, IList<string>>>, IEnumerable, IXmlSerializable, IEquatable<PropertyBag>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("propertyBag", Namespace = "http://www.gallio.org/") */
/** @attribute XmlSchemaProviderAttribute("ProvideXmlSchema") */
/** @attribute DefaultMemberAttribute("Item") */
public final class PropertyBag implements IMultiMap<string, string>, IDictionary<string, IList<string>>, ICollection<KeyValuePair<string, IList<string>>>, IEnumerable<KeyValuePair<string, IList<string>>>, IEnumerable, IXmlSerializable, IEquatable<PropertyBag>
JScript
public
SerializableAttribute
XmlRootAttribute("propertyBag", Namespace = "http://www.gallio.org/")
XmlSchemaProviderAttribute("ProvideXmlSchema")
DefaultMemberAttribute("Item")
final class PropertyBag extends IMultiMap<string, string>, IDictionary<string, IList<string>>, ICollection<KeyValuePair<string, IList<string>>>, IEnumerable<KeyValuePair<string, IList<string>>>, IEnumerable, IXmlSerializable, IEquatable<PropertyBag>

Remarks

This collection supports Xml-serialization and content-based equality comparison.

Inheritance Hierarchy

System.Object
Gallio.Collections.PropertyBag

See Also

PropertyBag Members
Gallio.Collections Namespace


PropertyBag Members

PropertyBag Members
See Also Example Constructors Properties Methods
[image]

A property bag associates keys with values where each key may have one or more associated value. All keys and values must be non-null strings. This class cannot be inherited.

The following tables list the members exposed by PropertyBag.

Public Constructors

 | Name | Description
Public method | PropertyBag | Creates an empty property bag.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Pairs | Gets the contents of the multi-map as an enumeration of pairs.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

Public Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddAll | Overloaded.
Public method | AsReadOnly | Gets a read-only view of this property set.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains | Overloaded.
Public method | ContainsKey |
Public method | Copy | Creates a copy of this property bag.
Public method | CopyTo |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the first value associated with a key.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | Remove | Overloaded.
Public method | SetValue | Sets the value associated with a key.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

See Also

PropertyBag Class
Gallio.Collections Namespace


PropertyBag Constructor

PropertyBag Constructor
[image]

Creates an empty property bag.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyBag()
C++
public:
PropertyBag() sealed
J#
public PropertyBag()
JScript
public function PropertyBag()

See Also

PropertyBag Class
Gallio.Collections Namespace


Properties

PropertyBag Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Pairs | Gets the contents of the multi-map as an enumeration of pairs.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

See Also

PropertyBag Class
Gallio.Collections Namespace


Count Property

PropertyBag.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<KeyValuePair<String,IList<String>>>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
public function get Count() : int

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<KeyValuePair<String,IList<String>>>.Count

See Also

PropertyBag Class
Gallio.Collections Namespace


IsReadOnly Property

PropertyBag.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<KeyValuePair<String,IList<String>>>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
public function get IsReadOnly() : bool

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<KeyValuePair<String,IList<String>>>.IsReadOnly

See Also

PropertyBag Class
Gallio.Collections Namespace


Item Property

PropertyBag.Item Property
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal key As String _
) As IList(Of String) _
Implements IDictionary<String,IList<String>>.Item
C#
public IList<string> this[
string key
] { get; set; }
C++
public property IList<string> default[String key] sealed {
IList<string> get(String key);
void set(String key, IList<string> value);
}
J#
/** property */
public IList<string> get_Item(string key);

/** property */
public void set_Item(string key, IList<string> value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

Implements

IDictionary<String,IList<String>>.Item

See Also

PropertyBag Class
Gallio.Collections Namespace


Keys Property

PropertyBag.Keys Property
[image]

Gets an ICollection containing the keys of the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of String) _
Implements IDictionary<String,IList<String>>.Keys
C#
public ICollection<string> Keys { get; }
C++
public property ICollection<string> Keys sealed {
ICollection<string> get();
}
J#
/** property */
public ICollection<string> get_Keys();
JScript
public function get Keys() : ICollection<string>

Property Value

An ICollection containing the keys of the object that implements IDictionary.

Implements

IDictionary<String,IList<String>>.Keys

See Also

PropertyBag Class
Gallio.Collections Namespace


Pairs Property

PropertyBag.Pairs Property
[image]

Gets the contents of the multi-map as an enumeration of pairs.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pairs As IEnumerable(Of KeyValuePair(Of String, String)) _
Implements IMultiMap<String,String>.Pairs
C#
public IEnumerable<KeyValuePair<string, string>> Pairs { get; }
C++
public property IEnumerable<KeyValuePair<string, string>> Pairs sealed {
IEnumerable<KeyValuePair<string, string>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<string, string>> get_Pairs();
JScript
public function get Pairs() : IEnumerable<KeyValuePair<string, string>>

Implements

IMultiMap<String,String>.Pairs

See Also

PropertyBag Class
Gallio.Collections Namespace


Values Property

PropertyBag.Values Property
[image]

Gets an ICollection containing the values in the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of IList(Of String)) _
Implements IDictionary<String,IList<String>>.Values
C#
public ICollection<IList<string>> Values { get; }
C++
public property ICollection<IList<string>> Values sealed {
ICollection<IList<string>> get();
}
J#
/** property */
public ICollection<IList<string>> get_Values();
JScript
public function get Values() : ICollection<IList<string>>

Property Value

An ICollection containing the values in the object that implements IDictionary.

Implements

IDictionary<String,IList<String>>.Values

See Also

PropertyBag Class
Gallio.Collections Namespace


Methods

PropertyBag Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddAll | Overloaded.
Public method | AsReadOnly | Gets a read-only view of this property set.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains | Overloaded.
Public method | ContainsKey |
Public method | Copy | Creates a copy of this property bag.
Public method | CopyTo |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the first value associated with a key.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | Remove | Overloaded.
Public method | SetValue | Sets the value associated with a key.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

See Also

PropertyBag Class
Gallio.Collections Namespace


Add Method

PropertyBag.Add Method

Overload List

 | Name | Description
Public method | Add (KeyValuePair<string, IList<string>>) |
Public method | Add (String, IList<string>) |
Public method | Add (String, String) |

See Also

PropertyBag Class
Gallio.Collections Namespace


Add Method (Generic KeyValuePair)

PropertyBag.Add Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As KeyValuePair(Of String, IList(Of String)) _
) _
Implements ICollection<KeyValuePair<String,IList<String>>>.Add
C#
public void Add(
KeyValuePair<string, IList<string>> item
)
C++
public:
void Add(
KeyValuePair<string, IList<string>> item
) sealed
J#
public void Add(
KeyValuePair<string, IList<string>> item
)
JScript
public function Add(
item : KeyValuePair<string, IList<string>>
)

Implements

ICollection<KeyValuePair<String,IList<String>>>.Add

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Add Overload List


Add Method (String, Generic IList)

PropertyBag.Add Method (String, Generic IList)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As String, _
ByVal values As IList(Of String) _
) _
Implements IDictionary<String,IList<String>>.Add
C#
public void Add(
string key,
IList<string> values
)
C++
public:
void Add(
String key,
IList<string> values
) sealed
J#
public void Add(
string key,
IList<string> values
)
JScript
public function Add(
key : String,
values : IList<string>
)

Implements

IDictionary<String,IList<String>>.Add

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Add Overload List


Add Method (String, String)

PropertyBag.Add Method (String, String)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As String, _
ByVal value As String _
) _
Implements IMultiMap<String,String>.Add
C#
public void Add(
string key,
string value
)
C++
public:
void Add(
String key,
String value
) sealed
J#
public void Add(
string key,
string value
)
JScript
public function Add(
key : String,
value : String
)

Implements

IMultiMap<String,String>.Add

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Add Overload List


AddAll Method

PropertyBag.AddAll Method

Overload List

 | Name | Description
Public method | AddAll (IEnumerable<KeyValuePair<string, IList<string>>>) |
Public method | AddAll (IEnumerable<KeyValuePair<string, string>>) |

See Also

PropertyBag Class
Gallio.Collections Namespace


AddAll Method (Generic IEnumerable)

PropertyBag.AddAll Method (Generic IEnumerable)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAll( _
ByVal map As IEnumerable(Of KeyValuePair(Of String, IList(Of String))) _
) _
Implements IMultiMap<String,String>.AddAll
C#
public void AddAll(
IEnumerable<KeyValuePair<string, IList<string>>> map
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<string, IList<string>>> map
) sealed
J#
public void AddAll(
IEnumerable<KeyValuePair<string, IList<string>>> map
)
JScript
public function AddAll(
map : IEnumerable<KeyValuePair<string, IList<string>>>
)

Implements

IMultiMap<String,String>.AddAll

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.AddAll Overload List


AddAll Method (Generic IEnumerable)

PropertyBag.AddAll Method (Generic IEnumerable)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAll( _
ByVal pairs As IEnumerable(Of KeyValuePair(Of String, String)) _
) _
Implements IMultiMap<String,String>.AddAll
C#
public void AddAll(
IEnumerable<KeyValuePair<string, string>> pairs
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<string, string>> pairs
) sealed
J#
public void AddAll(
IEnumerable<KeyValuePair<string, string>> pairs
)
JScript
public function AddAll(
pairs : IEnumerable<KeyValuePair<string, string>>
)

Implements

IMultiMap<String,String>.AddAll

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.AddAll Overload List


AsReadOnly Method

PropertyBag.AsReadOnly Method
[image]

Gets a read-only view of this property set.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As PropertyBag
C#
public PropertyBag AsReadOnly()
C++
public:
PropertyBag AsReadOnly() sealed
J#
public PropertyBag AsReadOnly()
JScript
public function AsReadOnly() : PropertyBag

Return Value

A read-only view

See Also

PropertyBag Class
Gallio.Collections Namespace


Clear Method

PropertyBag.Clear Method
[image]

Removes all items from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<KeyValuePair<String,IList<String>>>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

Implements

ICollection<KeyValuePair<String,IList<String>>>.Clear

See Also

PropertyBag Class
Gallio.Collections Namespace


Contains Method

PropertyBag.Contains Method

Overload List

 | Name | Description
Public method | Contains (KeyValuePair<string, IList<string>>) |
Public method | Contains (String, String) |

See Also

PropertyBag Class
Gallio.Collections Namespace


Contains Method (Generic KeyValuePair)

PropertyBag.Contains Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As KeyValuePair(Of String, IList(Of String)) _
) As Boolean _
Implements ICollection<KeyValuePair<String,IList<String>>>.Contains
C#
public bool Contains(
KeyValuePair<string, IList<string>> item
)
C++
public:
bool Contains(
KeyValuePair<string, IList<string>> item
) sealed
J#
public bool Contains(
KeyValuePair<string, IList<string>> item
)
JScript
public function Contains(
item : KeyValuePair<string, IList<string>>
) : bool

Implements

ICollection<KeyValuePair<String,IList<String>>>.Contains

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Contains Overload List


Contains Method (String, String)

PropertyBag.Contains Method (String, String)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal key As String, _
ByVal value As String _
) As Boolean _
Implements IMultiMap<String,String>.Contains
C#
public bool Contains(
string key,
string value
)
C++
public:
bool Contains(
String key,
String value
) sealed
J#
public bool Contains(
string key,
string value
)
JScript
public function Contains(
key : String,
value : String
) : bool

Implements

IMultiMap<String,String>.Contains

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Contains Overload List


ContainsKey Method

PropertyBag.ContainsKey Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
ByVal key As String _
) As Boolean _
Implements IDictionary<String,IList<String>>.ContainsKey
C#
public bool ContainsKey(
string key
)
C++
public:
bool ContainsKey(
String key
) sealed
J#
public bool ContainsKey(
string key
)
JScript
public function ContainsKey(
key : String
) : bool

Implements

IDictionary<String,IList<String>>.ContainsKey

See Also

PropertyBag Class
Gallio.Collections Namespace


Copy Method

PropertyBag.Copy Method
[image]

Creates a copy of this property bag.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As PropertyBag
C#
public PropertyBag Copy()
C++
public:
PropertyBag Copy() sealed
J#
public PropertyBag Copy()
JScript
public function Copy() : PropertyBag

Return Value

The copy

See Also

PropertyBag Class
Gallio.Collections Namespace


CopyTo Method

PropertyBag.CopyTo Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As KeyValuePair(Of String, IList(Of String))(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<KeyValuePair<String,IList<String>>>.CopyTo
C#
public void CopyTo(
KeyValuePair<string, IList<string>>[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<KeyValuePair<string, IList<string>>>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
KeyValuePair<string, IList<string>>[] array,
int arrayIndex
)
JScript
public function CopyTo(
array : KeyValuePair<string, IList<string>>[],
arrayIndex : int
)

Implements

ICollection<KeyValuePair<String,IList<String>>>.CopyTo

See Also

PropertyBag Class
Gallio.Collections Namespace


Equals Method

PropertyBag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (PropertyBag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

PropertyBag Class
Gallio.Collections Namespace


Equals Method (PropertyBag)

PropertyBag.Equals Method (PropertyBag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As PropertyBag _
) As Boolean _
Implements IEquatable<PropertyBag>.Equals
C#
public bool Equals(
PropertyBag other
)
C++
public:
bool Equals(
PropertyBag other
) sealed
J#
public bool Equals(
PropertyBag other
)
JScript
public function Equals(
other : PropertyBag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<PropertyBag>.Equals

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Equals Overload List


Equals Method (Object)

PropertyBag.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Equals Overload List


GetEnumerator Method

PropertyBag.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of KeyValuePair(Of String, IList(Of String))) _
Implements IEnumerable<KeyValuePair<String,IList<String>>>.GetEnumerator
C#
public IEnumerator<KeyValuePair<string, IList<string>>> GetEnumerator()
C++
public:
IEnumerator<KeyValuePair<string, IList<string>>> GetEnumerator() sealed
J#
public IEnumerator<KeyValuePair<string, IList<string>>> GetEnumerator()
JScript
public function GetEnumerator() : IEnumerator<KeyValuePair<string, IList<string>>>

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<KeyValuePair<String,IList<String>>>.GetEnumerator

See Also

PropertyBag Class
Gallio.Collections Namespace


GetHashCode Method

PropertyBag.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

PropertyBag Class
Gallio.Collections Namespace


GetValue Method

PropertyBag.GetValue Method
[image]

Gets the first value associated with a key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal key As String _
) As String
C#
public string GetValue(
string key
)
C++
public:
String GetValue(
String key
) sealed
J#
public string GetValue(
string key
)
JScript
public function GetValue(
key : String
) : String

Parameters

key
The key

Return Value

The first associated value, or null if none

Remarks

If there are multiple values, returns only the first one.

See Also

PropertyBag Class
Gallio.Collections Namespace


ProvideXmlSchema Method

PropertyBag.ProvideXmlSchema Method
[image]

Provides the Xml schema for this element.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ProvideXmlSchema( _
ByVal schemas As XmlSchemaSet _
) As XmlQualifiedName
C#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
C++
public:
static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
J#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
JScript
public static function ProvideXmlSchema(
schemas : XmlSchemaSet
) : XmlQualifiedName

Parameters

schemas
The schema set

Return Value

The schema type of the element

See Also

PropertyBag Class
Gallio.Collections Namespace


Remove Method

PropertyBag.Remove Method

Overload List

 | Name | Description
Public method | Remove (KeyValuePair<string, IList<string>>) |
Public method | Remove (String) |
Public method | Remove (String, String) |

See Also

PropertyBag Class
Gallio.Collections Namespace


Remove Method (Generic KeyValuePair)

PropertyBag.Remove Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As KeyValuePair(Of String, IList(Of String)) _
) As Boolean _
Implements ICollection<KeyValuePair<String,IList<String>>>.Remove
C#
public bool Remove(
KeyValuePair<string, IList<string>> item
)
C++
public:
bool Remove(
KeyValuePair<string, IList<string>> item
) sealed
J#
public bool Remove(
KeyValuePair<string, IList<string>> item
)
JScript
public function Remove(
item : KeyValuePair<string, IList<string>>
) : bool

Implements

ICollection<KeyValuePair<String,IList<String>>>.Remove

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Remove Overload List


Remove Method (String)

PropertyBag.Remove Method (String)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As String _
) As Boolean _
Implements IDictionary<String,IList<String>>.Remove
C#
public bool Remove(
string key
)
C++
public:
bool Remove(
String key
) sealed
J#
public bool Remove(
string key
)
JScript
public function Remove(
key : String
) : bool

Implements

IDictionary<String,IList<String>>.Remove

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Remove Overload List


Remove Method (String, String)

PropertyBag.Remove Method (String, String)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As String, _
ByVal value As String _
) As Boolean _
Implements IMultiMap<String,String>.Remove
C#
public bool Remove(
string key,
string value
)
C++
public:
bool Remove(
String key,
String value
) sealed
J#
public bool Remove(
string key,
string value
)
JScript
public function Remove(
key : String,
value : String
) : bool

Implements

IMultiMap<String,String>.Remove

See Also

PropertyBag Class
Gallio.Collections Namespace
PropertyBag.Remove Overload List


SetValue Method

PropertyBag.SetValue Method
[image]

Sets the value associated with a key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValue( _
ByVal key As String, _
ByVal value As String _
)
C#
public void SetValue(
string key,
string value
)
C++
public:
void SetValue(
String key,
String value
) sealed
J#
public void SetValue(
string key,
string value
)
JScript
public function SetValue(
key : String,
value : String
)

Parameters

key
The key
value
The new value, or null to remove the existing values

Remarks

Removes all values previously associated with that key.

See Also

PropertyBag Class
Gallio.Collections Namespace


TryGetValue Method

PropertyBag.TryGetValue Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
ByVal key As String, _
<OutAttribute> ByRef value As IList(Of String) _
) As Boolean _
Implements IDictionary<String,IList<String>>.TryGetValue
C#
public bool TryGetValue(
string key,
out IList<string> value
)
C++
public:
bool TryGetValue(
String key,
[OutAttribute] IList<string>% value
) sealed
J#
public bool TryGetValue(
string key,
/** @attribute OutAttribute() */ /** @ref */ IList<string> value
)
JScript
public function TryGetValue(
key : String,
OutAttribute value : IList<string>
) : bool

Implements

IDictionary<String,IList<String>>.TryGetValue

See Also

PropertyBag Class
Gallio.Collections Namespace


PropertySet Class

PropertySet Class
See Also Example Members
[image]

A property set associates keys with values where each key may have exactly one associated value. All keys and values must be non-null strings. This class cannot be inherited.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
DefaultMemberAttribute("Item"), _
XmlRootAttribute("propertySet", Namespace := "http://www.gallio.org/"), _
XmlSchemaProviderAttribute("ProvideXmlSchema")>
Public NotInheritable Class PropertySet
Implements IDictionary(Of String, String), ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)), IEnumerable, IEquatable(Of PropertySet), IXmlSerializable
C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
[XmlRootAttribute("propertySet", Namespace = "http://www.gallio.org/")]
[XmlSchemaProviderAttribute("ProvideXmlSchema")]
public sealed class PropertySet : IDictionary<string, string>, ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>, IEnumerable, IEquatable<PropertySet>, IXmlSerializable
C++
[SerializableAttribute]
[DefaultMemberAttribute(L"Item")]
[XmlRootAttribute(L"propertySet", Namespace = L"http://www.gallio.org/")]
[XmlSchemaProviderAttribute(L"ProvideXmlSchema")]
ref class PropertySet sealed : IDictionary<string, string>, ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>, IEnumerable, IEquatable<PropertySet>, IXmlSerializable
J#
/** @attribute SerializableAttribute() */
/** @attribute DefaultMemberAttribute("Item") */
/** @attribute XmlRootAttribute("propertySet", Namespace = "http://www.gallio.org/") */
/** @attribute XmlSchemaProviderAttribute("ProvideXmlSchema") */
public final class PropertySet implements IDictionary<string, string>, ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>, IEnumerable, IEquatable<PropertySet>, IXmlSerializable
JScript
public
SerializableAttribute
DefaultMemberAttribute("Item")
XmlRootAttribute("propertySet", Namespace = "http://www.gallio.org/")
XmlSchemaProviderAttribute("ProvideXmlSchema")
final class PropertySet extends IDictionary<string, string>, ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>, IEnumerable, IEquatable<PropertySet>, IXmlSerializable

Remarks

This collection supports Xml-serialization and content-based equality comparison.

Inheritance Hierarchy

System.Object
Gallio.Collections.PropertySet

See Also

PropertySet Members
Gallio.Collections Namespace


PropertySet Members

PropertySet Members
See Also Example Constructors Properties Methods
[image]

A property set associates keys with values where each key may have exactly one associated value. All keys and values must be non-null strings. This class cannot be inherited.

The following tables list the members exposed by PropertySet.

Public Constructors

 | Name | Description
Public method | PropertySet | Creates an empty property set.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

Public Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddAll | Adds all elements of another collection to this dictionary.
Public method | AsReadOnly | Gets a read-only view of this property set.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains |
Public method | ContainsKey |
Public method | Copy | Creates a full copy of this property set.
Public method | CopyTo |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value associated with a key, or null if absent.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | Remove | Overloaded.
Public method | SetValue | Sets the value associated with a key, removes an existing value if null.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

See Also

PropertySet Class
Gallio.Collections Namespace


PropertySet Constructor

PropertySet Constructor
[image]

Creates an empty property set.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertySet()
C++
public:
PropertySet() sealed
J#
public PropertySet()
JScript
public function PropertySet()

See Also

PropertySet Class
Gallio.Collections Namespace


Properties

PropertySet Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

See Also

PropertySet Class
Gallio.Collections Namespace


Count Property

PropertySet.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<KeyValuePair<String,String>>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
public function get Count() : int

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<KeyValuePair<String,String>>.Count

See Also

PropertySet Class
Gallio.Collections Namespace


IsReadOnly Property

PropertySet.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<KeyValuePair<String,String>>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
public function get IsReadOnly() : bool

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<KeyValuePair<String,String>>.IsReadOnly

See Also

PropertySet Class
Gallio.Collections Namespace


Item Property

PropertySet.Item Property
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal key As String _
) As String _
Implements IDictionary<String,String>.Item
C#
public string this[
string key
] { get; set; }
C++
public property string default[String key] sealed {
String get(String key);
void set(String key, String value);
}
J#
/** property */
public string get_Item(string key);

/** property */
public void set_Item(string key, string value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

Implements

IDictionary<String,String>.Item

See Also

PropertySet Class
Gallio.Collections Namespace


Keys Property

PropertySet.Keys Property
[image]

Gets an ICollection containing the keys of the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of String) _
Implements IDictionary<String,String>.Keys
C#
public ICollection<string> Keys { get; }
C++
public property ICollection<string> Keys sealed {
ICollection<string> get();
}
J#
/** property */
public ICollection<string> get_Keys();
JScript
public function get Keys() : ICollection<string>

Property Value

An ICollection containing the keys of the object that implements IDictionary.

Implements

IDictionary<String,String>.Keys

See Also

PropertySet Class
Gallio.Collections Namespace


Values Property

PropertySet.Values Property
[image]

Gets an ICollection containing the values in the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of String) _
Implements IDictionary<String,String>.Values
C#
public ICollection<string> Values { get; }
C++
public property ICollection<string> Values sealed {
ICollection<string> get();
}
J#
/** property */
public ICollection<string> get_Values();
JScript
public function get Values() : ICollection<string>

Property Value

An ICollection containing the values in the object that implements IDictionary.

Implements

IDictionary<String,String>.Values

See Also

PropertySet Class
Gallio.Collections Namespace


Methods

PropertySet Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | AddAll | Adds all elements of another collection to this dictionary.
Public method | AsReadOnly | Gets a read-only view of this property set.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains |
Public method | ContainsKey |
Public method | Copy | Creates a full copy of this property set.
Public method | CopyTo |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value associated with a key, or null if absent.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | Remove | Overloaded.
Public method | SetValue | Sets the value associated with a key, removes an existing value if null.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

See Also

PropertySet Class
Gallio.Collections Namespace


Add Method

PropertySet.Add Method

Overload List

 | Name | Description
Public method | Add (KeyValuePair<string, string>) |
Public method | Add (String, String) |

See Also

PropertySet Class
Gallio.Collections Namespace


Add Method (Generic KeyValuePair)

PropertySet.Add Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As KeyValuePair(Of String, String) _
) _
Implements ICollection<KeyValuePair<String,String>>.Add
C#
public void Add(
KeyValuePair<string, string> item
)
C++
public:
void Add(
KeyValuePair<string, string> item
) sealed
J#
public void Add(
KeyValuePair<string, string> item
)
JScript
public function Add(
item : KeyValuePair<string, string>
)

Implements

ICollection<KeyValuePair<String,String>>.Add

See Also

PropertySet Class
Gallio.Collections Namespace
PropertySet.Add Overload List


Add Method (String, String)

PropertySet.Add Method (String, String)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As String, _
ByVal value As String _
) _
Implements IDictionary<String,String>.Add
C#
public void Add(
string key,
string value
)
C++
public:
void Add(
String key,
String value
) sealed
J#
public void Add(
string key,
string value
)
JScript
public function Add(
key : String,
value : String
)

Implements

IDictionary<String,String>.Add

See Also

PropertySet Class
Gallio.Collections Namespace
PropertySet.Add Overload List


AddAll Method

PropertySet.AddAll Method
[image]

Adds all elements of another collection to this dictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAll( _
ByVal collection As IEnumerable(Of KeyValuePair(Of String, String)) _
)
C#
public void AddAll(
IEnumerable<KeyValuePair<string, string>> collection
)
C++
public:
void AddAll(
IEnumerable<KeyValuePair<string, string>> collection
) sealed
J#
public void AddAll(
IEnumerable<KeyValuePair<string, string>> collection
)
JScript
public function AddAll(
collection : IEnumerable<KeyValuePair<string, string>>
)

Parameters

collection
The collection to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if collection is null

See Also

PropertySet Class
Gallio.Collections Namespace


AsReadOnly Method

PropertySet.AsReadOnly Method
[image]

Gets a read-only view of this property set.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As PropertySet
C#
public PropertySet AsReadOnly()
C++
public:
PropertySet AsReadOnly() sealed
J#
public PropertySet AsReadOnly()
JScript
public function AsReadOnly() : PropertySet

Return Value

A read-only view

See Also

PropertySet Class
Gallio.Collections Namespace


Clear Method

PropertySet.Clear Method
[image]

Removes all items from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<KeyValuePair<String,String>>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

Implements

ICollection<KeyValuePair<String,String>>.Clear

See Also

PropertySet Class
Gallio.Collections Namespace


Contains Method

PropertySet.Contains Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As KeyValuePair(Of String, String) _
) As Boolean _
Implements ICollection<KeyValuePair<String,String>>.Contains
C#
public bool Contains(
KeyValuePair<string, string> item
)
C++
public:
bool Contains(
KeyValuePair<string, string> item
) sealed
J#
public bool Contains(
KeyValuePair<string, string> item
)
JScript
public function Contains(
item : KeyValuePair<string, string>
) : bool

Implements

ICollection<KeyValuePair<String,String>>.Contains

See Also

PropertySet Class
Gallio.Collections Namespace


ContainsKey Method

PropertySet.ContainsKey Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
ByVal key As String _
) As Boolean _
Implements IDictionary<String,String>.ContainsKey
C#
public bool ContainsKey(
string key
)
C++
public:
bool ContainsKey(
String key
) sealed
J#
public bool ContainsKey(
string key
)
JScript
public function ContainsKey(
key : String
) : bool

Implements

IDictionary<String,String>.ContainsKey

See Also

PropertySet Class
Gallio.Collections Namespace


Copy Method

PropertySet.Copy Method
[image]

Creates a full copy of this property set.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As PropertySet
C#
public PropertySet Copy()
C++
public:
PropertySet Copy() sealed
J#
public PropertySet Copy()
JScript
public function Copy() : PropertySet

Return Value

The copy

See Also

PropertySet Class
Gallio.Collections Namespace


CopyTo Method

PropertySet.CopyTo Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As KeyValuePair(Of String, String)(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<KeyValuePair<String,String>>.CopyTo
C#
public void CopyTo(
KeyValuePair<string, string>[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<KeyValuePair<string, string>>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
KeyValuePair<string, string>[] array,
int arrayIndex
)
JScript
public function CopyTo(
array : KeyValuePair<string, string>[],
arrayIndex : int
)

Implements

ICollection<KeyValuePair<String,String>>.CopyTo

See Also

PropertySet Class
Gallio.Collections Namespace


Equals Method

PropertySet.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (PropertySet) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

PropertySet Class
Gallio.Collections Namespace


Equals Method (PropertySet)

PropertySet.Equals Method (PropertySet)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As PropertySet _
) As Boolean _
Implements IEquatable<PropertySet>.Equals
C#
public bool Equals(
PropertySet other
)
C++
public:
bool Equals(
PropertySet other
) sealed
J#
public bool Equals(
PropertySet other
)
JScript
public function Equals(
other : PropertySet
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<PropertySet>.Equals

See Also

PropertySet Class
Gallio.Collections Namespace
PropertySet.Equals Overload List


Equals Method (Object)

PropertySet.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

PropertySet Class
Gallio.Collections Namespace
PropertySet.Equals Overload List


GetEnumerator Method

PropertySet.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of KeyValuePair(Of String, String)) _
Implements IEnumerable<KeyValuePair<String,String>>.GetEnumerator
C#
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
C++
public:
IEnumerator<KeyValuePair<string, string>> GetEnumerator() sealed
J#
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
JScript
public function GetEnumerator() : IEnumerator<KeyValuePair<string, string>>

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<KeyValuePair<String,String>>.GetEnumerator

See Also

PropertySet Class
Gallio.Collections Namespace


GetHashCode Method

PropertySet.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

PropertySet Class
Gallio.Collections Namespace


GetValue Method

PropertySet.GetValue Method
[image]

Gets the value associated with a key, or null if absent.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal key As String _
) As String
C#
public string GetValue(
string key
)
C++
public:
String GetValue(
String key
) sealed
J#
public string GetValue(
string key
)
JScript
public function GetValue(
key : String
) : String

Parameters

key
The key

Return Value

The associated value, or null if none

See Also

PropertySet Class
Gallio.Collections Namespace


ProvideXmlSchema Method

PropertySet.ProvideXmlSchema Method
[image]

Provides the Xml schema for this element.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ProvideXmlSchema( _
ByVal schemas As XmlSchemaSet _
) As XmlQualifiedName
C#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
C++
public:
static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
J#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
JScript
public static function ProvideXmlSchema(
schemas : XmlSchemaSet
) : XmlQualifiedName

Parameters

schemas
The schema set

Return Value

The schema type of the element

See Also

PropertySet Class
Gallio.Collections Namespace


Remove Method

PropertySet.Remove Method

Overload List

 | Name | Description
Public method | Remove (KeyValuePair<string, string>) |
Public method | Remove (String) |

See Also

PropertySet Class
Gallio.Collections Namespace


Remove Method (Generic KeyValuePair)

PropertySet.Remove Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As KeyValuePair(Of String, String) _
) As Boolean _
Implements ICollection<KeyValuePair<String,String>>.Remove
C#
public bool Remove(
KeyValuePair<string, string> item
)
C++
public:
bool Remove(
KeyValuePair<string, string> item
) sealed
J#
public bool Remove(
KeyValuePair<string, string> item
)
JScript
public function Remove(
item : KeyValuePair<string, string>
) : bool

Implements

ICollection<KeyValuePair<String,String>>.Remove

See Also

PropertySet Class
Gallio.Collections Namespace
PropertySet.Remove Overload List


Remove Method (String)

PropertySet.Remove Method (String)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As String _
) As Boolean _
Implements IDictionary<String,String>.Remove
C#
public bool Remove(
string key
)
C++
public:
bool Remove(
String key
) sealed
J#
public bool Remove(
string key
)
JScript
public function Remove(
key : String
) : bool

Implements

IDictionary<String,String>.Remove

See Also

PropertySet Class
Gallio.Collections Namespace
PropertySet.Remove Overload List


SetValue Method

PropertySet.SetValue Method
[image]

Sets the value associated with a key, removes an existing value if null.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValue( _
ByVal key As String, _
ByVal value As String _
)
C#
public void SetValue(
string key,
string value
)
C++
public:
void SetValue(
String key,
String value
) sealed
J#
public void SetValue(
string key,
string value
)
JScript
public function SetValue(
key : String,
value : String
)

Parameters

key
The key
value
The new value, or null to remove the existing value

See Also

PropertySet Class
Gallio.Collections Namespace


TryGetValue Method

PropertySet.TryGetValue Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
ByVal key As String, _
<OutAttribute> ByRef value As String _
) As Boolean _
Implements IDictionary<String,String>.TryGetValue
C#
public bool TryGetValue(
string key,
out string value
)
C++
public:
bool TryGetValue(
String key,
[OutAttribute] String% value
) sealed
J#
public bool TryGetValue(
string key,
/** @attribute OutAttribute() */ /** @ref */ string value
)
JScript
public function TryGetValue(
key : String,
OutAttribute value : String
) : bool

Implements

IDictionary<String,String>.TryGetValue

See Also

PropertySet Class
Gallio.Collections Namespace


ReadOnlyDictionary Generic Class

ReadOnlyDictionary Generic Class
See Also Example Members
[image]

A read-only dictionary wrapper.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
DefaultMemberAttribute("Item")>
Public Class ReadOnlyDictionary(Of TKey, TValue)
Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)), IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
public class ReadOnlyDictionary<TKey, TValue> : IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
C++
[SerializableAttribute]
[DefaultMemberAttribute(L"Item")]
ref class ReadOnlyDictionary<TKey, TValue> : IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
J#
/** @attribute SerializableAttribute() */
/** @attribute DefaultMemberAttribute("Item") */
public class ReadOnlyDictionary<TKey, TValue> implements IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Collections.ReadOnlyDictionary<TKey,TValue>

See Also

ReadOnlyDictionary<TKey,TValue> Members
Gallio.Collections Namespace


ReadOnlyDictionary<TKey,TValue> Members

ReadOnlyDictionary Members
See Also Example Constructors Properties Methods
[image]

A read-only dictionary wrapper.

The following tables list the members exposed by ReadOnlyDictionary<TKey,TValue>.

Public Constructors

 | Name | Description
Public method | ReadOnlyDictionary | Creates a read-only dictionary wrapper for another dictionary.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

Public Methods

 | Name | Description
Public method | Add | Overloaded. Adds an element with the provided key and value to the IDictionary.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains |
Public method | ContainsKey | Determines whether the IDictionary contains an element with the specified key.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove | Overloaded. Removes the element with the specified key from the IDictionary.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


ReadOnlyDictionary Constructor

ReadOnlyDictionary Constructor
[image]

Creates a read-only dictionary wrapper for another dictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal inner As IDictionary(Of TKey, TValue) _
)
C#
public ReadOnlyDictionary(
IDictionary<TKey, TValue> inner
)
C++
public:
ReadOnlyDictionary(
IDictionary<TKey, TValue> inner
) sealed
J#
public ReadOnlyDictionary(
IDictionary<TKey, TValue> inner
)
JScript
JScript does not support generic types and methods.

Parameters

inner
The dictionary to wrap

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if inner is null

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Properties

ReadOnlyDictionary Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollection containing the keys of the IDictionary.
Public property | Values | Gets an ICollection containing the values in the IDictionary.
Top

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Count Property

ReadOnlyDictionary.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<KeyValuePair`2>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
JScript does not support generic types and methods.

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<KeyValuePair`2>.Count

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


IsReadOnly Property

ReadOnlyDictionary.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<KeyValuePair`2>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
JScript does not support generic types and methods.

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<KeyValuePair`2>.IsReadOnly

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Item Property

ReadOnlyDictionary.Item Property
[image]

Gets or sets the element with the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal key As TKey _
) _
Implements IDictionary<TKey,TValue>.Item
C#
public TValue this[
TKey key
] { get; set; }
C++
public property TValue default[TKey key] sealed {
TValue get(TKey key);
void set(TKey key, TValue value);
}
J#
/** property */
public TValue get_Item(TKey key);

/** property */
public void set_Item(TKey key, TValue value);
JScript
JScript does not support generic types and methods.

Parameters

key
The key of the element to get or set.

Property Value

The element with the specified key.

Implements

IDictionary<TKey,TValue>.Item

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Keys Property

ReadOnlyDictionary.Keys Property
[image]

Gets an ICollection containing the keys of the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of TKey) _
Implements IDictionary<TKey,TValue>.Keys
C#
public ICollection<TKey> Keys { get; }
C++
public property ICollection<TKey> Keys sealed {
ICollection<TKey> get();
}
J#
/** property */
public ICollection<TKey> get_Keys();
JScript
JScript does not support generic types and methods.

Property Value

An ICollection containing the keys of the object that implements IDictionary.

Implements

IDictionary<TKey,TValue>.Keys

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Values Property

ReadOnlyDictionary.Values Property
[image]

Gets an ICollection containing the values in the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of TValue) _
Implements IDictionary<TKey,TValue>.Values
C#
public ICollection<TValue> Values { get; }
C++
public property ICollection<TValue> Values sealed {
ICollection<TValue> get();
}
J#
/** property */
public ICollection<TValue> get_Values();
JScript
JScript does not support generic types and methods.

Property Value

An ICollection containing the values in the object that implements IDictionary.

Implements

IDictionary<TKey,TValue>.Values

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Methods

ReadOnlyDictionary Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Overloaded. Adds an element with the provided key and value to the IDictionary.
Public method | Clear | Removes all items from the ICollection.
Public method | Contains |
Public method | ContainsKey | Determines whether the IDictionary contains an element with the specified key.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove | Overloaded. Removes the element with the specified key from the IDictionary.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Add Method

ReadOnlyDictionary<TKey,TValue>.Add Method

Adds an element with the provided key and value to the IDictionary.

Overload List

 | Name | Description
Public method | Add (TKey, TValue) | Adds an element with the provided key and value to the IDictionary.
Public method | Add (KeyValuePair<TKey, TValue>) |

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Add Method (TKey, TValue)

ReadOnlyDictionary.Add Method (TKey, TValue)
See Also Example
[image]

Adds an element with the provided key and value to the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal key As TKey, _
ByVal value As TValue _
) _
Implements IDictionary<TKey,TValue>.Add
C#
public void Add(
TKey key,
TValue value
)
C++
public:
void Add(
TKey key,
TValue value
) sealed
J#
public void Add(
TKey key,
TValue value
)
JScript
JScript does not support generic types and methods.

Parameters

key
The object to use as the key of the element to add.
value
The object to use as the value of the element to add.

Implements

IDictionary<TKey,TValue>.Add

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
ReadOnlyDictionary<TKey,TValue>.Add Overload List


Add Method (Generic KeyValuePair)

ReadOnlyDictionary.Add Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As KeyValuePair(Of TKey, TValue) _
) _
Implements ICollection<KeyValuePair`2>.Add
C#
public void Add(
KeyValuePair<TKey, TValue> item
)
C++
public:
void Add(
KeyValuePair<TKey, TValue> item
) sealed
J#
public void Add(
KeyValuePair<TKey, TValue> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Add

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
ReadOnlyDictionary<TKey,TValue>.Add Overload List


Clear Method

ReadOnlyDictionary.Clear Method
[image]

Removes all items from the ICollection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<KeyValuePair`2>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Clear

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Contains Method

ReadOnlyDictionary.Contains Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As KeyValuePair(Of TKey, TValue) _
) As Boolean _
Implements ICollection<KeyValuePair`2>.Contains
C#
public bool Contains(
KeyValuePair<TKey, TValue> item
)
C++
public:
bool Contains(
KeyValuePair<TKey, TValue> item
) sealed
J#
public bool Contains(
KeyValuePair<TKey, TValue> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Contains

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


ContainsKey Method

ReadOnlyDictionary.ContainsKey Method
[image]

Determines whether the IDictionary contains an element with the specified key.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
ByVal key As TKey _
) As Boolean _
Implements IDictionary<TKey,TValue>.ContainsKey
C#
public bool ContainsKey(
TKey key
)
C++
public:
bool ContainsKey(
TKey key
) sealed
J#
public bool ContainsKey(
TKey key
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key to locate in the IDictionary.

Return Value

true if the IDictionary contains an element with the key; otherwise, false.

Implements

IDictionary<TKey,TValue>.ContainsKey

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


CopyTo Method

ReadOnlyDictionary.CopyTo Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As KeyValuePair(Of TKey, TValue)(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<KeyValuePair`2>.CopyTo
C#
public void CopyTo(
KeyValuePair<TKey, TValue>[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<KeyValuePair<TKey, TValue>>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
KeyValuePair<TKey, TValue>[] array,
int arrayIndex
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.CopyTo

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


GetEnumerator Method

ReadOnlyDictionary.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of KeyValuePair(Of TKey, TValue)) _
Implements IEnumerable<KeyValuePair`2>.GetEnumerator
C#
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
C++
public:
IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator() sealed
J#
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<KeyValuePair`2>.GetEnumerator

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Remove Method

ReadOnlyDictionary<TKey,TValue>.Remove Method

Removes the element with the specified key from the IDictionary.

Overload List

 | Name | Description
Public method | Remove (TKey) | Removes the element with the specified key from the IDictionary.
Public method | Remove (KeyValuePair<TKey, TValue>) |

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


Remove Method (TKey)

ReadOnlyDictionary.Remove Method (TKey)
See Also Example
[image]

Removes the element with the specified key from the IDictionary.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal key As TKey _
) As Boolean _
Implements IDictionary<TKey,TValue>.Remove
C#
public bool Remove(
TKey key
)
C++
public:
bool Remove(
TKey key
) sealed
J#
public bool Remove(
TKey key
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key of the element to remove.

Return Value

true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original IDictionary.

Implements

IDictionary<TKey,TValue>.Remove

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
ReadOnlyDictionary<TKey,TValue>.Remove Overload List


Remove Method (Generic KeyValuePair)

ReadOnlyDictionary.Remove Method (Generic KeyValuePair)
See Also Example
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As KeyValuePair(Of TKey, TValue) _
) As Boolean _
Implements ICollection<KeyValuePair`2>.Remove
C#
public bool Remove(
KeyValuePair<TKey, TValue> item
)
C++
public:
bool Remove(
KeyValuePair<TKey, TValue> item
) sealed
J#
public bool Remove(
KeyValuePair<TKey, TValue> item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<KeyValuePair`2>.Remove

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace
ReadOnlyDictionary<TKey,TValue>.Remove Overload List


TryGetValue Method

ReadOnlyDictionary.TryGetValue Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
ByVal key As TKey, _
<OutAttribute> ByRef value As TValue _
) As Boolean _
Implements IDictionary<TKey,TValue>.TryGetValue
C#
public bool TryGetValue(
TKey key,
out TValue value
)
C++
public:
bool TryGetValue(
TKey key,
[OutAttribute] TValue% value
) sealed
J#
public bool TryGetValue(
TKey key,
/** @attribute OutAttribute() */ /** @ref */ TValue value
)
JScript
JScript does not support generic types and methods.

Implements

IDictionary<TKey,TValue>.TryGetValue

See Also

ReadOnlyDictionary<TKey,TValue> Class
Gallio.Collections Namespace


ReferentialEqualityComparer Generic Class

ReferentialEqualityComparer Generic Class
See Also Example Members
[image]

An equality comparer that compares values by reference. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ReferentialEqualityComparer(Of T As Class)
Implements IEqualityComparer(Of T)
C#
public sealed class ReferentialEqualityComparer<T> : IEqualityComparer<T> where T : class
C++
ref class ReferentialEqualityComparer<T> sealed : IEqualityComparer<T> where T : class
J#
public final class ReferentialEqualityComparer<T> implements IEqualityComparer<T>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of values to compare, must be reference types

Inheritance Hierarchy

System.Object
Gallio.Collections.ReferentialEqualityComparer<T>

See Also

ReferentialEqualityComparer<T> Members
Gallio.Collections Namespace


ReferentialEqualityComparer<T> Members

ReferentialEqualityComparer Members
See Also Example Properties Methods
[image]

An equality comparer that compares values by reference. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ReferentialEqualityComparer<T>.

Public Properties

Name | Description
Instance | Gets the singleton instance of the comparer.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace


Properties

ReferentialEqualityComparer Properties
[image]

Public Properties

Name | Description
Instance | Gets the singleton instance of the comparer.
Top

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace


Instance Property

ReferentialEqualityComparer.Instance Property
[image]

Gets the singleton instance of the comparer.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As ReferentialEqualityComparer(Of T)
C#
public static ReferentialEqualityComparer<T> Instance { get; }
C++
public static property ReferentialEqualityComparer<T> Instance {
ReferentialEqualityComparer<T> get();
}
J#
/** property */
public ReferentialEqualityComparer<T> get_Instance();
JScript
JScript does not support generic types and methods.

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace


Methods

ReferentialEqualityComparer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace


Equals Method

ReferentialEqualityComparer<T>.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (T, T) | Determines whether the specified objects are equal.
Public method | Equals (Object) | Determines whether the specified Object is equal to the current Object. (inherited from Object)

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace


Equals Method (T, T)

ReferentialEqualityComparer.Equals Method (T, T)
See Also Example
[image]

Determines whether the specified objects are equal.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal x As T, _
ByVal y As T _
) As Boolean _
Implements IEqualityComparer<T>.Equals
C#
public bool Equals(
T x,
T y
)
C++
public:
bool Equals(
T x,
T y
) sealed
J#
public bool Equals(
T x,
T y
)
JScript
JScript does not support generic types and methods.

Parameters

x
The first object of type T to compare.
y
The second object of type T to compare.

Return Value

true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparer<T>.Equals

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace
ReferentialEqualityComparer<T>.Equals Overload List


GetHashCode Method

ReferentialEqualityComparer<T>.GetHashCode Method

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Overload List

 | Name | Description
Public method | GetHashCode (T) | Returns a hash code for the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace


GetHashCode Method (T)

ReferentialEqualityComparer.GetHashCode Method (T)
See Also Example
[image]

Returns a hash code for the specified object.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHashCode( _
ByVal obj As T _
) As Integer _
Implements IEqualityComparer<T>.GetHashCode
C#
public int GetHashCode(
T obj
)
C++
public:
int GetHashCode(
T obj
) sealed
J#
public int GetHashCode(
T obj
)
JScript
JScript does not support generic types and methods.

Parameters

obj
The Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.

Implements

IEqualityComparer<T>.GetHashCode

See Also

ReferentialEqualityComparer<T> Class
Gallio.Collections Namespace
ReferentialEqualityComparer<T>.GetHashCode Overload List


TreeUtils Class

TreeUtils Class
See Also Example Members
[image]

Provides functions for manipulating ad-hoc trees. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TreeUtils
C#
public static class TreeUtils
C++
ref class TreeUtils abstract sealed
J#
public final class TreeUtils
JScript
public class TreeUtils

Inheritance Hierarchy

System.Object
Gallio.Collections.TreeUtils

See Also

TreeUtils Members
Gallio.Collections Namespace


TreeUtils Members

TreeUtils Members
See Also Example Methods
[image]

Provides functions for manipulating ad-hoc trees. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TreeUtils.

Public Methods

Name | Description
GetPreOrderTraversal |
Top

See Also

TreeUtils Class
Gallio.Collections Namespace


Methods

TreeUtils Methods
[image]

Public Methods

Name | Description
GetPreOrderTraversal |
Top

See Also

TreeUtils Class
Gallio.Collections Namespace


GetPreOrderTraversal Generic Method

TreeUtils.GetPreOrderTraversal Generic Method
[image]

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPreOrderTraversal(Of T)( _
ByVal rootNode As T, _
ByVal enumerator As TreeUtils.ChildEnumerator(Of T) _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> GetPreOrderTraversal<T>(
T rootNode,
TreeUtils.ChildEnumerator<T> enumerator
)
C++
public:
static IEnumerable<T> GetPreOrderTraversal<T>(
T rootNode,
TreeUtils.ChildEnumerator<T> enumerator
)
J#
public static IEnumerable<T> GetPreOrderTraversal<T>(
T rootNode,
TreeUtils.ChildEnumerator<T> enumerator
)
JScript
JScript does not support generic types and methods.

See Also

TreeUtils Class
Gallio.Collections Namespace


TreeUtils.ChildEnumerator Generic Delegate

TreeUtils.ChildEnumerator Generic Delegate
[image]

Enumerates child nodes in a tree.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function TreeUtils.ChildEnumerator(Of T)( _
ByVal node As T _
) As IEnumerable(Of T)
C#
public delegate IEnumerable<T> TreeUtils.ChildEnumerator<T>(
T node
)
C++
public delegate IEnumerable<T> TreeUtils.ChildEnumerator<T>(
T node
)
J#
/** delegate */
public delegate IEnumerable<T> TreeUtils.ChildEnumerator<T>(
T node
)
JScript
JScript does not support generic types and methods.

Parameters

node
The node

See Also

Gallio.Collections Namespace


UserDataCollection Class

UserDataCollection Class
See Also Example Members
[image]

A user data collection stores arbitrary key/value pairs that may be associated with other objects in the system.

Accesses to the collection are synchronized during access. To safely manupulate multiple keys at one time, simply lock the UserDataCollection for the duration of the operation.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class UserDataCollection
C#
public class UserDataCollection
C++
ref class UserDataCollection
J#
public class UserDataCollection
JScript
public class UserDataCollection

Inheritance Hierarchy

System.Object
Gallio.Collections.UserDataCollection

See Also

UserDataCollection Members
Gallio.Collections Namespace


UserDataCollection Members

UserDataCollection Members
See Also Example Constructors Methods
[image]

A user data collection stores arbitrary key/value pairs that may be associated with other objects in the system.

Accesses to the collection are synchronized during access. To safely manupulate multiple keys at one time, simply lock the UserDataCollection for the duration of the operation.

The following tables list the members exposed by UserDataCollection.

Public Constructors

 | Name | Description
Public method | UserDataCollection | Creates an empty collection.
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets a value from the collection.
Public method | GetValueOrDefault | Gets a value from the collection or a default value if none found.
Public method | HasValue | Determines whether a key has an associated value in the collection.
Public method | RemoveValue | Removes a value from the collection.
Public method | SetValue | Sets a value in the collection.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue | Tries to get a value from the collection.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UserDataCollection Class
Gallio.Collections Namespace


UserDataCollection Constructor

UserDataCollection Constructor
[image]

Creates an empty collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UserDataCollection()
C++
public:
UserDataCollection() sealed
J#
public UserDataCollection()
JScript
public function UserDataCollection()

See Also

UserDataCollection Class
Gallio.Collections Namespace


Methods

UserDataCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets a value from the collection.
Public method | GetValueOrDefault | Gets a value from the collection or a default value if none found.
Public method | HasValue | Determines whether a key has an associated value in the collection.
Public method | RemoveValue | Removes a value from the collection.
Public method | SetValue | Sets a value in the collection.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue | Tries to get a value from the collection.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UserDataCollection Class
Gallio.Collections Namespace


Copy Method

UserDataCollection.Copy Method
[image]

Creates a copy of the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As UserDataCollection
C#
public UserDataCollection Copy()
C++
public:
UserDataCollection Copy() sealed
J#
public UserDataCollection Copy()
JScript
public function Copy() : UserDataCollection

Return Value

The copy

See Also

UserDataCollection Class
Gallio.Collections Namespace


GetValue Generic Method

UserDataCollection.GetValue Generic Method
[image]

Gets a value from the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue(Of T)( _
ByVal key As Key(Of T) _
)
C#
public T GetValue<T>(
Key<T> key
)
C++
public:
T GetValue<T>(
Key<T> key
) sealed
J#
public T GetValue<T>(
Key<T> key
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Parameters

key
The key

Return Value

The associated value

Exceptions

Exception Type | Condition
KeyNotFoundException | Thrown if key was not found.

See Also

UserDataCollection Class
Gallio.Collections Namespace


GetValueOrDefault Generic Method

UserDataCollection.GetValueOrDefault Generic Method
[image]

Gets a value from the collection or a default value if none found.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValueOrDefault(Of T)( _
ByVal key As Key(Of T), _
ByVal defaultValue As T _
)
C#
public T GetValueOrDefault<T>(
Key<T> key,
T defaultValue
)
C++
public:
T GetValueOrDefault<T>(
Key<T> key,
T defaultValue
) sealed
J#
public T GetValueOrDefault<T>(
Key<T> key,
T defaultValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Parameters

key
The key
defaultValue
The default value

Return Value

The associated value, or the default value

See Also

UserDataCollection Class
Gallio.Collections Namespace


HasValue Generic Method

UserDataCollection.HasValue Generic Method
[image]

Determines whether a key has an associated value in the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function HasValue(Of T)( _
ByVal key As Key(Of T) _
) As Boolean
C#
public bool HasValue<T>(
Key<T> key
)
C++
public:
bool HasValue<T>(
Key<T> key
) sealed
J#
public bool HasValue<T>(
Key<T> key
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Parameters

key
The key

Return Value

True if the key has an associated value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if key is null

See Also

UserDataCollection Class
Gallio.Collections Namespace


RemoveValue Generic Method

UserDataCollection.RemoveValue Generic Method
[image]

Removes a value from the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveValue(Of T)( _
ByVal key As Key(Of T) _
)
C#
public void RemoveValue<T>(
Key<T> key
)
C++
public:
void RemoveValue<T>(
Key<T> key
) sealed
J#
public void RemoveValue<T>(
Key<T> key
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Parameters

key
The key

See Also

UserDataCollection Class
Gallio.Collections Namespace


SetValue Generic Method

UserDataCollection.SetValue Generic Method
[image]

Sets a value in the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetValue(Of T)( _
ByVal key As Key(Of T), _
ByVal value As T _
)
C#
public void SetValue<T>(
Key<T> key,
T value
)
C++
public:
void SetValue<T>(
Key<T> key,
T value
) sealed
J#
public void SetValue<T>(
Key<T> key,
T value
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Parameters

key
The key
value
The value to set

See Also

UserDataCollection Class
Gallio.Collections Namespace


TryGetValue Generic Method

UserDataCollection.TryGetValue Generic Method
[image]

Tries to get a value from the collection.

Namespace: Gallio.Collections
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue(Of T)( _
ByVal key As Key(Of T), _
<OutAttribute> ByRef value As T _
) As Boolean
C#
public bool TryGetValue<T>(
Key<T> key,
out T value
)
C++
public:
bool TryGetValue<T>(
Key<T> key,
[OutAttribute] T% value
) sealed
J#
public bool TryGetValue<T>(
Key<T> key,
/** @attribute OutAttribute() */ /** @ref */ T value
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Parameters

key
The key
value
Set to the value, or default(T) if none present

Return Value

True if a value was obtained

See Also

UserDataCollection Class
Gallio.Collections Namespace


Gallio.Concurrency

Gallio.Concurrency Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class ProcessTask

A process task provides support for launching external processes and collecting their output.

The process task provides a guarnatee that when you call Join all redirected output from the console output and error streams will already have been captured and delivered to the event handlers, as appropriate.

Public class Task

A task represents a concurrently executing operation.

A Task might not necessarily represent an operation that is executing in a local Thread. It can represent other processes that execute remotely or that are represented by some other mechanism.

A Task is guaranteed to send events in the following order: Started, Aborted (if applicable), Terminated. The events are dispatched synchronously such that the next event in the sequence will not be fired until the previous event is completely processed.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class TaskContainer

A TaskContainer manages the lifecycle of any number of Tasks and monitors their run-time behavior.

For example, when a Task terminates abruptly due to an exception, its container will send out a notification that may cause all of the other tasks to be aborted and for the currently executing test case to fail.

Public class | TaskEventArgs | A task-related event.
Public class | TaskResult | Holds the result of executing a task. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class ThreadAbortScope

A ThreadAbortScope executes a block of code inside a special scope that is designed to issue and safely handle Abort on demand.

This class may be used as a primitive for implementing higher-level protected scopes for the purpose of asynchronous cancelation and time-limited execution.

Public class | ThreadTask | An implementation of Task based on a locally running thread.

Structures

Structure Description
Public structure LockBox

A lock box object provides protected read / write access to a shared object that may be accessed concurrently by multiple threads.

Clients are expected to use the Read and Write methods to acquire and release a lock of the appropriate type prior to manipulating the contents.

Delegates

 | Delegate | Description
Public delegate | ReadAction | An action that reads the contents of an object. It should not modify the object in any way.
Public delegate | WriteAction | An action that reads or writes the contents of an object.


LockBox Generic Structure

LockBox Generic Structure
See Also Example Members
[image]

A lock box object provides protected read / write access to a shared object that may be accessed concurrently by multiple threads.

Clients are expected to use the Read and Write methods to acquire and release a lock of the appropriate type prior to manipulating the contents.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure LockBox(Of T)
C#
public struct LockBox<T>
C++
value class LockBox<T>
J#
public final class LockBox<T> extends ValueType
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of object inside the lock box

Inheritance Hierarchy

System.Object
Gallio.Concurrency.LockBox<T>

See Also

LockBox<T> Members
Gallio.Concurrency Namespace


LockBox<T> Members

LockBox Members
See Also Example Constructors Methods
[image]

A lock box object provides protected read / write access to a shared object that may be accessed concurrently by multiple threads.

Clients are expected to use the Read and Write methods to acquire and release a lock of the appropriate type prior to manipulating the contents.

The following tables list the members exposed by LockBox<T>.

Public Constructors

 | Name | Description
Public method | LockBox | Creates a lock box for the specified object.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Read | Acquires a read lock and invokes the action with the object inside the lock box.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Public method | Write | Acquires a write lock and invokes the action with the object inside the lock box.
Top

See Also

LockBox<T> Structure
Gallio.Concurrency Namespace


LockBox Constructor

LockBox Constructor
[image]

Creates a lock box for the specified object.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal obj As T _
)
C#
public LockBox(
T obj
)
C++
public:
LockBox(
T obj
) sealed
J#
public LockBox(
T obj
)
JScript
JScript does not support generic types and methods.

Parameters

obj
The object to protect

See Also

LockBox<T> Structure
Gallio.Concurrency Namespace


Methods

LockBox Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Read | Acquires a read lock and invokes the action with the object inside the lock box.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Public method | Write | Acquires a write lock and invokes the action with the object inside the lock box.
Top

See Also

LockBox<T> Structure
Gallio.Concurrency Namespace


Read Method

LockBox.Read Method
[image]

Acquires a read lock and invokes the action with the object inside the lock box.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Read( _
ByVal action As ReadAction(Of T) _
)
C#
public void Read(
ReadAction<T> action
)
C++
public:
void Read(
ReadAction<T> action
) sealed
J#
public void Read(
ReadAction<T> action
)
JScript
JScript does not support generic types and methods.

Parameters

action
The action to invoke

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

See Also

LockBox<T> Structure
Gallio.Concurrency Namespace


Write Method

LockBox.Write Method
[image]

Acquires a write lock and invokes the action with the object inside the lock box.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal action As WriteAction(Of T) _
)
C#
public void Write(
WriteAction<T> action
)
C++
public:
void Write(
WriteAction<T> action
) sealed
J#
public void Write(
WriteAction<T> action
)
JScript
JScript does not support generic types and methods.

Parameters

action
The action to invoke

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

See Also

LockBox<T> Structure
Gallio.Concurrency Namespace


ProcessTask Class

ProcessTask Class
See Also Example Members
[image]

A process task provides support for launching external processes and collecting their output.

The process task provides a guarnatee that when you call Join all redirected output from the console output and error streams will already have been captured and delivered to the event handlers, as appropriate.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ProcessTask
Inherits Task
C#
public class ProcessTask : Task
C++
ref class ProcessTask : Task
J#
public class ProcessTask extends Task
JScript
public class ProcessTask extends Task

Inheritance Hierarchy

System.Object
Gallio.Concurrency.Task
Gallio.Concurrency.ProcessTask

See Also

ProcessTask Members
Gallio.Concurrency Namespace


ProcessTask Members

ProcessTask Members
See Also Example Constructors Properties Methods Events
[image]

A process task provides support for launching external processes and collecting their output.

The process task provides a guarnatee that when you call Join all redirected output from the console output and error streams will already have been captured and delivered to the event handlers, as appropriate.

The following tables list the members exposed by ProcessTask.

Public Constructors

 | Name | Description
Public method | ProcessTask | Creates a process task.
Top

Public Properties

 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | CaptureConsoleError | Gets or sets whether console error stream of the process should be captured and made available via the ConsoleError property. The default value is false.
Public property | CaptureConsoleOutput | Gets or sets whether console output stream of the process should be captured and made available via the ConsoleOutput property. The default value is false.
Public property | ConsoleError | Gets the captured contents of the console error stream written by the process.
Public property | ConsoleOutput | Gets the captured contents of the console output stream written by the process.
Public property | CreateWindow | Gets or sets whether to create a window for the command prompt. The default value is false.
Public property | ExecutablePath | Gets the executable path.
Public property | ExitCode | Gets the exit code of the process, or -1 if the process did not run or has not exited.
Public property | ExitCodeDescription | Gets a description of the exit code, if available, or null otherwise.
Public property | IsAborted | Returns true if the task has been aborted. (inherited from Task)
Public property | IsPending | Returns true if the task has not been started or aborted yet. (inherited from Task)
Public property | IsRunning | Returns true if the task is running. (inherited from Task)
Public property | IsTerminated | Returns true if the task ran and was terminated. (inherited from Task)
Public property | Name | Gets the name of the task. (inherited from Task)
Public property | Process | Gets the Process that was started or null if the process has not been started yet.
Public property | Result | Gets the task result, or null if the task has not terminated or was aborted before starting. (inherited from Task)
Public property | UseShellExecute | Gets or sets whether to execute the command with the Windows shell. The default value is false.
Public property | WorkingDirectory | Gets the working directory path.
Top

Public Methods

 | Name | Description
Public method | Abort | Asynchronously aborts the task. If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing. (inherited from Task)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Waits for the task to terminate. Does nothing if the task has not been started or is not running. (inherited from Task)
Public method | Run | Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false. (inherited from Task)
Public method | Start | Starts running the task. Does nothing if the task has already been started or has been aborted. (inherited from Task)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AbortImpl | Overridden. Aborts the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | JoinImpl | Overridden. Waits for the task to terminate.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyTerminated | Dispatches notification that the task has terminated and provides its result. (inherited from Task)
Family method | OnAborted | Notifies the Aborted event handlers. (inherited from Task)
Family method | OnStarted | Notifies the Started event handlers. (inherited from Task)
Family method | OnTerminated | Notifies the Terminated event handlers. (inherited from Task)
Family method | StartImpl | Overridden. Starts the task.
Family method | StartProcess | Starts a Process.
Top

Public Events

 | Name | Description
Public event | Aborted | Adds or removes an event handler that is signaled when the task is aborted. If a handler is being added and the task has already aborted, it is immediately invoked. (inherited from Task)
Public event | ConsoleErrorDataReceived | The event fired when each line of new output is received on the console error stream.
Public event | ConsoleOutputDataReceived | The event fired when each line of new output is received on the console output stream.
Public event | Started | Adds or removes an event handler that is signaled when the task is started. If a handler is being added and the task has already started, it is immediately invoked. (inherited from Task)
Public event | Terminated | Adds or removes an event handler that is signaled when the task is terminated. If a handler is being added and the task has already terminated, it is immediately invoked. (inherited from Task)
Top

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ProcessTask Constructor

ProcessTask Constructor
[image]

Creates a process task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal executablePath As String, _
ByVal arguments As String, _
ByVal workingDirectory As String _
)
C#
public ProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
C++
public:
ProcessTask(
String executablePath,
String arguments,
String workingDirectory
) sealed
J#
public ProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
JScript
public function ProcessTask(
executablePath : String,
arguments : String,
workingDirectory : String
)

Parameters

executablePath
The path of the executable executable
arguments
The arguments for the executable
workingDirectory
The working directory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if executablePath, arguments or workingDirectory is null

See Also

ProcessTask Class
Gallio.Concurrency Namespace


Properties

ProcessTask Properties
[image]

Public Properties

 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | CaptureConsoleError | Gets or sets whether console error stream of the process should be captured and made available via the ConsoleError property. The default value is false.
Public property | CaptureConsoleOutput | Gets or sets whether console output stream of the process should be captured and made available via the ConsoleOutput property. The default value is false.
Public property | ConsoleError | Gets the captured contents of the console error stream written by the process.
Public property | ConsoleOutput | Gets the captured contents of the console output stream written by the process.
Public property | CreateWindow | Gets or sets whether to create a window for the command prompt. The default value is false.
Public property | ExecutablePath | Gets the executable path.
Public property | ExitCode | Gets the exit code of the process, or -1 if the process did not run or has not exited.
Public property | ExitCodeDescription | Gets a description of the exit code, if available, or null otherwise.
Public property | IsAborted | Returns true if the task has been aborted. (inherited from Task)
Public property | IsPending | Returns true if the task has not been started or aborted yet. (inherited from Task)
Public property | IsRunning | Returns true if the task is running. (inherited from Task)
Public property | IsTerminated | Returns true if the task ran and was terminated. (inherited from Task)
Public property | Name | Gets the name of the task. (inherited from Task)
Public property | Process | Gets the Process that was started or null if the process has not been started yet.
Public property | Result | Gets the task result, or null if the task has not terminated or was aborted before starting. (inherited from Task)
Public property | UseShellExecute | Gets or sets whether to execute the command with the Windows shell. The default value is false.
Public property | WorkingDirectory | Gets the working directory path.
Top

See Also

ProcessTask Class
Gallio.Concurrency Namespace


Arguments Property

ProcessTask.Arguments Property
[image]

Gets the arguments.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As String
C#
public string Arguments { get; }
C++
public property string Arguments sealed {
String get();
}
J#
/** property */
public string get_Arguments();
JScript
public function get Arguments() : String

See Also

ProcessTask Class
Gallio.Concurrency Namespace


CaptureConsoleError Property

ProcessTask.CaptureConsoleError Property
[image]

Gets or sets whether console error stream of the process should be captured and made available via the ConsoleError property.

The default value is false.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CaptureConsoleError As Boolean
C#
public bool CaptureConsoleError { get; set; }
C++
public property bool CaptureConsoleError sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CaptureConsoleError();

/** property */
public void set_CaptureConsoleError(bool value);
JScript
public function get CaptureConsoleError() : bool

public function set CaptureConsoleError(value : bool);

See Also

ProcessTask Class
Gallio.Concurrency Namespace


CaptureConsoleOutput Property

ProcessTask.CaptureConsoleOutput Property
[image]

Gets or sets whether console output stream of the process should be captured and made available via the ConsoleOutput property.

The default value is false.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CaptureConsoleOutput As Boolean
C#
public bool CaptureConsoleOutput { get; set; }
C++
public property bool CaptureConsoleOutput sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CaptureConsoleOutput();

/** property */
public void set_CaptureConsoleOutput(bool value);
JScript
public function get CaptureConsoleOutput() : bool

public function set CaptureConsoleOutput(value : bool);

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ConsoleError Property

ProcessTask.ConsoleError Property
[image]

Gets the captured contents of the console error stream written by the process.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConsoleError As String
C#
public string ConsoleError { get; }
C++
public property string ConsoleError sealed {
String get();
}
J#
/** property */
public string get_ConsoleError();
JScript
public function get ConsoleError() : String

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the process has not been started or if CaptureConsoleError is null

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ConsoleOutput Property

ProcessTask.ConsoleOutput Property
[image]

Gets the captured contents of the console output stream written by the process.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConsoleOutput As String
C#
public string ConsoleOutput { get; }
C++
public property string ConsoleOutput sealed {
String get();
}
J#
/** property */
public string get_ConsoleOutput();
JScript
public function get ConsoleOutput() : String

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the process has not been started or if CaptureConsoleOutput is null

See Also

ProcessTask Class
Gallio.Concurrency Namespace


CreateWindow Property

ProcessTask.CreateWindow Property
[image]

Gets or sets whether to create a window for the command prompt.

The default value is false.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateWindow As Boolean
C#
public bool CreateWindow { get; set; }
C++
public property bool CreateWindow sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CreateWindow();

/** property */
public void set_CreateWindow(bool value);
JScript
public function get CreateWindow() : bool

public function set CreateWindow(value : bool);

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ExecutablePath Property

ProcessTask.ExecutablePath Property
[image]

Gets the executable path.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutablePath As String
C#
public string ExecutablePath { get; }
C++
public property string ExecutablePath sealed {
String get();
}
J#
/** property */
public string get_ExecutablePath();
JScript
public function get ExecutablePath() : String

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ExitCode Property

ProcessTask.ExitCode Property
[image]

Gets the exit code of the process, or -1 if the process did not run or has not exited.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExitCode As Integer
C#
public int ExitCode { get; }
C++
public property int ExitCode sealed {
int get();
}
J#
/** property */
public int get_ExitCode();
JScript
public function get ExitCode() : int

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ExitCodeDescription Property

ProcessTask.ExitCodeDescription Property
[image]

Gets a description of the exit code, if available, or null otherwise.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExitCodeDescription As String
C#
public string ExitCodeDescription { get; }
C++
public property string ExitCodeDescription sealed {
String get();
}
J#
/** property */
public string get_ExitCodeDescription();
JScript
public function get ExitCodeDescription() : String

See Also

ProcessTask Class
Gallio.Concurrency Namespace


Process Property

ProcessTask.Process Property
[image]

Gets the Process that was started or null if the process has not been started yet.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Process As Process
C#
public Process Process { get; }
C++
public property Process Process sealed {
Process get();
}
J#
/** property */
public Process get_Process();
JScript
public function get Process() : Process

See Also

ProcessTask Class
Gallio.Concurrency Namespace


UseShellExecute Property

ProcessTask.UseShellExecute Property
[image]

Gets or sets whether to execute the command with the Windows shell.

The default value is false.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property UseShellExecute As Boolean
C#
public bool UseShellExecute { get; set; }
C++
public property bool UseShellExecute sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_UseShellExecute();

/** property */
public void set_UseShellExecute(bool value);
JScript
public function get UseShellExecute() : bool

public function set UseShellExecute(value : bool);

See Also

ProcessTask Class
Gallio.Concurrency Namespace


WorkingDirectory Property

ProcessTask.WorkingDirectory Property
[image]

Gets the working directory path.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WorkingDirectory As String
C#
public string WorkingDirectory { get; }
C++
public property string WorkingDirectory sealed {
String get();
}
J#
/** property */
public string get_WorkingDirectory();
JScript
public function get WorkingDirectory() : String

See Also

ProcessTask Class
Gallio.Concurrency Namespace


Methods

ProcessTask Methods
[image]

Public Methods

 | Name | Description
Public method | Abort | Asynchronously aborts the task. If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing. (inherited from Task)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Waits for the task to terminate. Does nothing if the task has not been started or is not running. (inherited from Task)
Public method | Run | Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false. (inherited from Task)
Public method | Start | Starts running the task. Does nothing if the task has already been started or has been aborted. (inherited from Task)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AbortImpl | Overridden. Aborts the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | JoinImpl | Overridden. Waits for the task to terminate.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyTerminated | Dispatches notification that the task has terminated and provides its result. (inherited from Task)
Family method | OnAborted | Notifies the Aborted event handlers. (inherited from Task)
Family method | OnStarted | Notifies the Started event handlers. (inherited from Task)
Family method | OnTerminated | Notifies the Terminated event handlers. (inherited from Task)
Family method | StartImpl | Overridden. Starts the task.
Family method | StartProcess | Starts a Process.
Top

See Also

ProcessTask Class
Gallio.Concurrency Namespace


AbortImpl Method

ProcessTask.AbortImpl Method
[image]

Aborts the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AbortImpl()
C#
protected override void AbortImpl()
C++
protected:
virtual void AbortImpl() override
J#
protected override void AbortImpl()
JScript
protected override function AbortImpl()

See Also

ProcessTask Class
Gallio.Concurrency Namespace


JoinImpl Method

ProcessTask.JoinImpl Method
[image]

Waits for the task to terminate.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function JoinImpl( _
ByVal timeout As Nullable(Of TimeSpan) _
) As Boolean
C#
protected override bool JoinImpl(
Nullable<TimeSpan> timeout
)
C++
protected:
virtual bool JoinImpl(
Nullable<TimeSpan> timeout
) override
J#
protected override bool JoinImpl(
Nullable<TimeSpan> timeout
)
JScript
protected override function JoinImpl(
timeout : Nullable<TimeSpan>
) : bool

Parameters

timeout
The timeout, or null to wait indefinitely

Return Value

True if the task is not running as of the time this method exits, false if a timeout occurred while waiting

See Also

ProcessTask Class
Gallio.Concurrency Namespace


StartImpl Method

ProcessTask.StartImpl Method
[image]

Starts the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StartImpl()
C#
protected override void StartImpl()
C++
protected:
virtual void StartImpl() override
J#
protected override void StartImpl()
JScript
protected override function StartImpl()

See Also

ProcessTask Class
Gallio.Concurrency Namespace


StartProcess Method

ProcessTask.StartProcess Method
[image]

Starts a Process.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function StartProcess( _
ByVal startInfo As ProcessStartInfo _
) As Process
C#
protected virtual Process StartProcess(
ProcessStartInfo startInfo
)
C++
protected:
virtual Process StartProcess(
ProcessStartInfo startInfo
)
J#
protected virtual Process StartProcess(
ProcessStartInfo startInfo
)
JScript
protected virtual function StartProcess(
startInfo : ProcessStartInfo
) : Process

Parameters

startInfo
The ProcessStartInfo that has been started

Return Value

The process

Remarks

This method may be override to change how the process is created and started.

See Also

ProcessTask Class
Gallio.Concurrency Namespace


Events

ProcessTask Events
[image]

Public Events

 | Name | Description
Public event | Aborted | Adds or removes an event handler that is signaled when the task is aborted. If a handler is being added and the task has already aborted, it is immediately invoked. (inherited from Task)
Public event | ConsoleErrorDataReceived | The event fired when each line of new output is received on the console error stream.
Public event | ConsoleOutputDataReceived | The event fired when each line of new output is received on the console output stream.
Public event | Started | Adds or removes an event handler that is signaled when the task is started. If a handler is being added and the task has already started, it is immediately invoked. (inherited from Task)
Public event | Terminated | Adds or removes an event handler that is signaled when the task is terminated. If a handler is being added and the task has already terminated, it is immediately invoked. (inherited from Task)
Top

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ConsoleErrorDataReceived Event

ProcessTask.ConsoleErrorDataReceived Event
[image]

The event fired when each line of new output is received on the console error stream.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event ConsoleErrorDataReceived As EventHandler(Of DataReceivedEventArgs)
C#
public event EventHandler<DataReceivedEventArgs> ConsoleErrorDataReceived
C++
public:
virtual event EventHandler<DataReceivedEventArgs> ConsoleErrorDataReceived {
void add(EventHandler<DataReceivedEventArgs> value) sealed ;
void remove(EventHandler<DataReceivedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ConsoleErrorDataReceived(EventHandler<DataReceivedEventArgs> value);

/** event */
public final void remove_ConsoleErrorDataReceived(EventHandler<DataReceivedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

This event should be wired up before starting the task to ensure that no data is lost.

Please note that the Data property will be null when the redirected stream is closed after the process exits.

Event Data

The event handler receives an argument of type DataReceivedEventArgs containing data related to this event. The following DataReceivedEventArgs property provides information specific to this event.

Property | Description
Data |

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ConsoleOutputDataReceived Event

ProcessTask.ConsoleOutputDataReceived Event
[image]

The event fired when each line of new output is received on the console output stream.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event ConsoleOutputDataReceived As EventHandler(Of DataReceivedEventArgs)
C#
public event EventHandler<DataReceivedEventArgs> ConsoleOutputDataReceived
C++
public:
virtual event EventHandler<DataReceivedEventArgs> ConsoleOutputDataReceived {
void add(EventHandler<DataReceivedEventArgs> value) sealed ;
void remove(EventHandler<DataReceivedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ConsoleOutputDataReceived(EventHandler<DataReceivedEventArgs> value);

/** event */
public final void remove_ConsoleOutputDataReceived(EventHandler<DataReceivedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

This event should be wired up before starting the task to ensure that no data is lost.

Please note that the Data property will be null when the redirected stream is closed after the process exits.

Event Data

The event handler receives an argument of type DataReceivedEventArgs containing data related to this event. The following DataReceivedEventArgs property provides information specific to this event.

Property | Description
Data |

See Also

ProcessTask Class
Gallio.Concurrency Namespace


ReadAction Generic Delegate

ReadAction Generic Delegate
[image]

An action that reads the contents of an object. It should not modify the object in any way.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ReadAction(Of T)( _
ByVal obj As T _
)
C#
public delegate void ReadAction<T>(
T obj
)
C++
public delegate void ReadAction<T>(
T obj
)
J#
/** delegate */
public delegate void ReadAction<T>(
T obj
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of object

Parameters

obj
The object

See Also

Gallio.Concurrency Namespace


Task Class

Task Class
See Also Example Members
[image]

A task represents a concurrently executing operation.

A Task might not necessarily represent an operation that is executing in a local Thread. It can represent other processes that execute remotely or that are represented by some other mechanism.

A Task is guaranteed to send events in the following order: Started, Aborted (if applicable), Terminated. The events are dispatched synchronously such that the next event in the sequence will not be fired until the previous event is completely processed.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Task
C#
public abstract class Task
C++
ref class Task abstract
J#
public class Task
JScript
public class Task

Inheritance Hierarchy

System.Object
Gallio.Concurrency.Task
Gallio.Concurrency.ProcessTask
Gallio.Concurrency.ThreadTask

See Also

Task Members
Gallio.Concurrency Namespace
TaskContainer


Task Members

Task Members
See Also Example Constructors Properties Methods Events
[image]

A task represents a concurrently executing operation.

A Task might not necessarily represent an operation that is executing in a local Thread. It can represent other processes that execute remotely or that are represented by some other mechanism.

A Task is guaranteed to send events in the following order: Started, Aborted (if applicable), Terminated. The events are dispatched synchronously such that the next event in the sequence will not be fired until the previous event is completely processed.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Task.

Public Constructors

 | Name | Description
Public method | Task | Creates a task.
Top

Public Properties

 | Name | Description
Public property | IsAborted | Returns true if the task has been aborted.
Public property | IsPending | Returns true if the task has not been started or aborted yet.
Public property | IsRunning | Returns true if the task is running.
Public property | IsTerminated | Returns true if the task ran and was terminated.
Public property | Name | Gets the name of the task.
Public property | Result | Gets the task result, or null if the task has not terminated or was aborted before starting.
Top

Public Methods

 | Name | Description
Public method | Abort | Asynchronously aborts the task. If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Waits for the task to terminate. Does nothing if the task has not been started or is not running.
Public method | Run | Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false.
Public method | Start | Starts running the task. Does nothing if the task has already been started or has been aborted.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AbortImpl | Aborts the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | JoinImpl | Waits for the task to terminate.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyTerminated | Dispatches notification that the task has terminated and provides its result.
Family method | OnAborted | Notifies the Aborted event handlers.
Family method | OnStarted | Notifies the Started event handlers.
Family method | OnTerminated | Notifies the Terminated event handlers.
Family method | StartImpl | Starts the task.
Top

Public Events

 | Name | Description
Public event | Aborted | Adds or removes an event handler that is signaled when the task is aborted. If a handler is being added and the task has already aborted, it is immediately invoked.
Public event | Started | Adds or removes an event handler that is signaled when the task is started. If a handler is being added and the task has already started, it is immediately invoked.
Public event | Terminated | Adds or removes an event handler that is signaled when the task is terminated. If a handler is being added and the task has already terminated, it is immediately invoked.
Top

See Also

Task Class
Gallio.Concurrency Namespace
TaskContainer


Task Constructor

Task Constructor
[image]

Creates a task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public Task(
string name
)
C++
public:
Task(
String name
) sealed
J#
public Task(
string name
)
JScript
public function Task(
name : String
)

Parameters

name
The name of the task

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

Task Class
Gallio.Concurrency Namespace


Properties

Task Properties
[image]

Public Properties

 | Name | Description
Public property | IsAborted | Returns true if the task has been aborted.
Public property | IsPending | Returns true if the task has not been started or aborted yet.
Public property | IsRunning | Returns true if the task is running.
Public property | IsTerminated | Returns true if the task ran and was terminated.
Public property | Name | Gets the name of the task.
Public property | Result | Gets the task result, or null if the task has not terminated or was aborted before starting.
Top

See Also

Task Class
Gallio.Concurrency Namespace
TaskContainer


IsAborted Property

Task.IsAborted Property
[image]

Returns true if the task has been aborted.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAborted As Boolean
C#
public bool IsAborted { get; }
C++
public property bool IsAborted sealed {
bool get();
}
J#
/** property */
public bool get_IsAborted();
JScript
public function get IsAborted() : bool

See Also

Task Class
Gallio.Concurrency Namespace


IsPending Property

Task.IsPending Property
[image]

Returns true if the task has not been started or aborted yet.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPending As Boolean
C#
public bool IsPending { get; }
C++
public property bool IsPending sealed {
bool get();
}
J#
/** property */
public bool get_IsPending();
JScript
public function get IsPending() : bool

See Also

Task Class
Gallio.Concurrency Namespace


IsRunning Property

Task.IsRunning Property
[image]

Returns true if the task is running.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRunning As Boolean
C#
public bool IsRunning { get; }
C++
public property bool IsRunning sealed {
bool get();
}
J#
/** property */
public bool get_IsRunning();
JScript
public function get IsRunning() : bool

See Also

Task Class
Gallio.Concurrency Namespace


IsTerminated Property

Task.IsTerminated Property
[image]

Returns true if the task ran and was terminated.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTerminated As Boolean
C#
public bool IsTerminated { get; }
C++
public property bool IsTerminated sealed {
bool get();
}
J#
/** property */
public bool get_IsTerminated();
JScript
public function get IsTerminated() : bool

See Also

Task Class
Gallio.Concurrency Namespace


Name Property

Task.Name Property
[image]

Gets the name of the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

Task Class
Gallio.Concurrency Namespace


Result Property

Task.Result Property
[image]

Gets the task result, or null if the task has not terminated or was aborted before starting.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As TaskResult
C#
public TaskResult Result { get; }
C++
public property TaskResult Result sealed {
TaskResult get();
}
J#
/** property */
public TaskResult get_Result();
JScript
public function get Result() : TaskResult

See Also

Task Class
Gallio.Concurrency Namespace


Methods

Task Methods
[image]

Public Methods

 | Name | Description
Public method | Abort | Asynchronously aborts the task. If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Waits for the task to terminate. Does nothing if the task has not been started or is not running.
Public method | Run | Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false.
Public method | Start | Starts running the task. Does nothing if the task has already been started or has been aborted.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AbortImpl | Aborts the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | JoinImpl | Waits for the task to terminate.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyTerminated | Dispatches notification that the task has terminated and provides its result.
Family method | OnAborted | Notifies the Aborted event handlers.
Family method | OnStarted | Notifies the Started event handlers.
Family method | OnTerminated | Notifies the Terminated event handlers.
Family method | StartImpl | Starts the task.
Top

See Also

Task Class
Gallio.Concurrency Namespace
TaskContainer


Abort Method

Task.Abort Method
[image]

Asynchronously aborts the task.

If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Abort()
C#
public void Abort()
C++
public:
void Abort() sealed
J#
public void Abort()
JScript
public function Abort()

Remarks

A typical implementation of this method may cause a ThreadAbortException to be thrown non-deterministically within the task's thread. Normally such an exception should cause the thread to abort abruptly but it may have no effect in certain conditions. Also, aborting a task in this manner may cause the application to enter an invalid state because exception handlers are often not designed to recover from ThreadAbortException correctly.

See Also

Task Class
Gallio.Concurrency Namespace
Abort
IsAborted


AbortImpl Method

Task.AbortImpl Method
[image]

Aborts the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub AbortImpl()
C#
protected abstract void AbortImpl()
C++
protected:
void AbortImpl() abstract
J#
protected abstract void AbortImpl()
JScript
protected abstract function AbortImpl()

See Also

Task Class
Gallio.Concurrency Namespace
Abort


Join Method

Task.Join Method
[image]

Waits for the task to terminate.

Does nothing if the task has not been started or is not running.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Join( _
ByVal timeout As Nullable(Of TimeSpan) _
) As Boolean
C#
public bool Join(
Nullable<TimeSpan> timeout
)
C++
public:
bool Join(
Nullable<TimeSpan> timeout
) sealed
J#
public bool Join(
Nullable<TimeSpan> timeout
)
JScript
public function Join(
timeout : Nullable<TimeSpan>
) : bool

Parameters

timeout
The maximum amount of time to wait for completion, or null to wait indefinitely

Return Value

True if the task is not running as of the time this method exits, false if a timeout occurred while waiting

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if timeout represents a negative time span

See Also

Task Class
Gallio.Concurrency Namespace
Join
IsRunning


JoinImpl Method

Task.JoinImpl Method
[image]

Waits for the task to terminate.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function JoinImpl( _
ByVal timeout As Nullable(Of TimeSpan) _
) As Boolean
C#
protected abstract bool JoinImpl(
Nullable<TimeSpan> timeout
)
C++
protected:
bool JoinImpl(
Nullable<TimeSpan> timeout
) abstract
J#
protected abstract bool JoinImpl(
Nullable<TimeSpan> timeout
)
JScript
protected abstract function JoinImpl(
timeout : Nullable<TimeSpan>
) : bool

Parameters

timeout
The timeout, or null to wait indefinitely

Return Value

True if the task is not running as of the time this method exits, false if a timeout occurred while waiting

See Also

Task Class
Gallio.Concurrency Namespace


NotifyTerminated Method

Task.NotifyTerminated Method
[image]

Dispatches notification that the task has terminated and provides its result.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub NotifyTerminated( _
ByVal result As TaskResult _
)
C#
protected void NotifyTerminated(
TaskResult result
)
C++
protected:
void NotifyTerminated(
TaskResult result
) sealed
J#
protected void NotifyTerminated(
TaskResult result
)
JScript
protected function NotifyTerminated(
result : TaskResult
)

Parameters

result
The task result

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if result is null
InvalidOperationException | Thrown if the task is not currently running

See Also

Task Class
Gallio.Concurrency Namespace


OnAborted Method

Task.OnAborted Method
[image]

Notifies the Aborted event handlers.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAborted()
C#
protected virtual void OnAborted()
C++
protected:
virtual void OnAborted()
J#
protected virtual void OnAborted()
JScript
protected virtual function OnAborted()

Remarks

This method may be overridden by a subclass to perform any necessary actions just prior to calling the event handlers.

See Also

Task Class
Gallio.Concurrency Namespace


OnStarted Method

Task.OnStarted Method
[image]

Notifies the Started event handlers.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnStarted()
C#
protected virtual void OnStarted()
C++
protected:
virtual void OnStarted()
J#
protected virtual void OnStarted()
JScript
protected virtual function OnStarted()

Remarks

This method may be overridden by a subclass to perform any necessary actions just prior to calling the event handlers.

See Also

Task Class
Gallio.Concurrency Namespace


OnTerminated Method

Task.OnTerminated Method
[image]

Notifies the Terminated event handlers.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTerminated()
C#
protected virtual void OnTerminated()
C++
protected:
virtual void OnTerminated()
J#
protected virtual void OnTerminated()
JScript
protected virtual function OnTerminated()

Remarks

This method may be overridden by a subclass to perform any necessary actions just prior to calling the event handlers.

See Also

Task Class
Gallio.Concurrency Namespace


Run Method

Task.Run Method
[image]

Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Run( _
ByVal timeout As Nullable(Of TimeSpan) _
) As Boolean
C#
public bool Run(
Nullable<TimeSpan> timeout
)
C++
public:
bool Run(
Nullable<TimeSpan> timeout
) sealed
J#
public bool Run(
Nullable<TimeSpan> timeout
)
JScript
public function Run(
timeout : Nullable<TimeSpan>
) : bool

Parameters

timeout
The maximum amount of time to wait for completion, or null to wait indefinitely

Return Value

True if the task ran to completion within the specified time span, false if the task was aborted

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if timeout represents a negative time span

See Also

Task Class
Gallio.Concurrency Namespace


Start Method

Task.Start Method
[image]

Starts running the task.

Does nothing if the task has already been started or has been aborted.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Start()
C#
public void Start()
C++
public:
void Start() sealed
J#
public void Start()
JScript
public function Start()

See Also

Task Class
Gallio.Concurrency Namespace
IsPending


StartImpl Method

Task.StartImpl Method
[image]

Starts the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub StartImpl()
C#
protected abstract void StartImpl()
C++
protected:
void StartImpl() abstract
J#
protected abstract void StartImpl()
JScript
protected abstract function StartImpl()

See Also

Task Class
Gallio.Concurrency Namespace
Start


Events

Task Events
[image]

Public Events

 | Name | Description
Public event | Aborted | Adds or removes an event handler that is signaled when the task is aborted. If a handler is being added and the task has already aborted, it is immediately invoked.
Public event | Started | Adds or removes an event handler that is signaled when the task is started. If a handler is being added and the task has already started, it is immediately invoked.
Public event | Terminated | Adds or removes an event handler that is signaled when the task is terminated. If a handler is being added and the task has already terminated, it is immediately invoked.
Top

See Also

Task Class
Gallio.Concurrency Namespace
TaskContainer


Aborted Event

Task.Aborted Event
[image]

Adds or removes an event handler that is signaled when the task is aborted. If a handler is being added and the task has already aborted, it is immediately invoked.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Aborted As EventHandler(Of TaskEventArgs)
C#
public event EventHandler<TaskEventArgs> Aborted
C++
public:
virtual event EventHandler<TaskEventArgs> Aborted {
void add(EventHandler<TaskEventArgs> value) sealed ;
void remove(EventHandler<TaskEventArgs> value) sealed ;
}
J#
/** event */
public final void add_Aborted(EventHandler<TaskEventArgs> value);

/** event */
public final void remove_Aborted(EventHandler<TaskEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TaskEventArgs containing data related to this event. The following TaskEventArgs property provides information specific to this event.

Property | Description
Task | Gets the task that the event is about.

See Also

Task Class
Gallio.Concurrency Namespace


Started Event

Task.Started Event
[image]

Adds or removes an event handler that is signaled when the task is started. If a handler is being added and the task has already started, it is immediately invoked.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Started As EventHandler(Of TaskEventArgs)
C#
public event EventHandler<TaskEventArgs> Started
C++
public:
virtual event EventHandler<TaskEventArgs> Started {
void add(EventHandler<TaskEventArgs> value) sealed ;
void remove(EventHandler<TaskEventArgs> value) sealed ;
}
J#
/** event */
public final void add_Started(EventHandler<TaskEventArgs> value);

/** event */
public final void remove_Started(EventHandler<TaskEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TaskEventArgs containing data related to this event. The following TaskEventArgs property provides information specific to this event.

Property | Description
Task | Gets the task that the event is about.

See Also

Task Class
Gallio.Concurrency Namespace


Terminated Event

Task.Terminated Event
[image]

Adds or removes an event handler that is signaled when the task is terminated. If a handler is being added and the task has already terminated, it is immediately invoked.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Terminated As EventHandler(Of TaskEventArgs)
C#
public event EventHandler<TaskEventArgs> Terminated
C++
public:
virtual event EventHandler<TaskEventArgs> Terminated {
void add(EventHandler<TaskEventArgs> value) sealed ;
void remove(EventHandler<TaskEventArgs> value) sealed ;
}
J#
/** event */
public final void add_Terminated(EventHandler<TaskEventArgs> value);

/** event */
public final void remove_Terminated(EventHandler<TaskEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TaskEventArgs containing data related to this event. The following TaskEventArgs property provides information specific to this event.

Property | Description
Task | Gets the task that the event is about.

See Also

Task Class
Gallio.Concurrency Namespace


TaskContainer Class

TaskContainer Class
See Also Example Members
[image]

A TaskContainer manages the lifecycle of any number of Tasks and monitors their run-time behavior.

For example, when a Task terminates abruptly due to an exception, its container will send out a notification that may cause all of the other tasks to be aborted and for the currently executing test case to fail.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskContainer
C#
public class TaskContainer
C++
ref class TaskContainer
J#
public class TaskContainer
JScript
public class TaskContainer

Inheritance Hierarchy

System.Object
Gallio.Concurrency.TaskContainer

See Also

TaskContainer Members
Gallio.Concurrency Namespace


TaskContainer Members

TaskContainer Members
See Also Example Constructors Methods Events
[image]

A TaskContainer manages the lifecycle of any number of Tasks and monitors their run-time behavior.

For example, when a Task terminates abruptly due to an exception, its container will send out a notification that may cause all of the other tasks to be aborted and for the currently executing test case to fail.

The following tables list the members exposed by TaskContainer.

Public Constructors

 | Name | Description
Public method | TaskContainer | Creates an empty task container.
Top

Public Methods

 | Name | Description
Public method | AbortAll | Asynchronously aborts all of the tasks currently running within the container.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetActiveTasks | Gets the list of all tasks that are currently running.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | JoinAll | Waits for all of currently running tasks to terminate.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Watch | Adds a new task for this container to watch.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | TaskAborted | Adds or removes an event handler that is signaled when any watched task is aborted.
Public event | TaskStarted | Adds or removes an event handler that is signaled when any watched task is started.
Public event | TaskTerminated | Adds or removes an event handler that is signaled when any watched task is terminated.
Top

See Also

TaskContainer Class
Gallio.Concurrency Namespace


TaskContainer Constructor

TaskContainer Constructor
[image]

Creates an empty task container.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TaskContainer()
C++
public:
TaskContainer() sealed
J#
public TaskContainer()
JScript
public function TaskContainer()

See Also

TaskContainer Class
Gallio.Concurrency Namespace


Methods

TaskContainer Methods
[image]

Public Methods

 | Name | Description
Public method | AbortAll | Asynchronously aborts all of the tasks currently running within the container.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetActiveTasks | Gets the list of all tasks that are currently running.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | JoinAll | Waits for all of currently running tasks to terminate.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Watch | Adds a new task for this container to watch.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TaskContainer Class
Gallio.Concurrency Namespace


AbortAll Method

TaskContainer.AbortAll Method
[image]

Asynchronously aborts all of the tasks currently running within the container.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AbortAll()
C#
public void AbortAll()
C++
public:
void AbortAll() sealed
J#
public void AbortAll()
JScript
public function AbortAll()

See Also

TaskContainer Class
Gallio.Concurrency Namespace
Abort


GetActiveTasks Method

TaskContainer.GetActiveTasks Method
[image]

Gets the list of all tasks that are currently running.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetActiveTasks() As IList(Of Task)
C#
public IList<Task> GetActiveTasks()
C++
public:
IList<Task> GetActiveTasks() sealed
J#
public IList<Task> GetActiveTasks()
JScript
public function GetActiveTasks() : IList<Task>

Return Value

The list of running tasks

See Also

TaskContainer Class
Gallio.Concurrency Namespace


JoinAll Method

TaskContainer.JoinAll Method
[image]

Waits for all of currently running tasks to terminate.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function JoinAll( _
ByVal timeout As Nullable(Of TimeSpan) _
) As Boolean
C#
public bool JoinAll(
Nullable<TimeSpan> timeout
)
C++
public:
bool JoinAll(
Nullable<TimeSpan> timeout
) sealed
J#
public bool JoinAll(
Nullable<TimeSpan> timeout
)
JScript
public function JoinAll(
timeout : Nullable<TimeSpan>
) : bool

Parameters

timeout
The maximum amount of time to wait for completion, or null to wait indefinitely

Return Value

True if no tasks are running as of the time this method exits, false if a timeout occurred while waiting

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if timeout represents a negative time span

See Also

TaskContainer Class
Gallio.Concurrency Namespace
Join


Watch Method

TaskContainer.Watch Method
[image]

Adds a new task for this container to watch.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Watch( _
ByVal task As Task _
)
C#
public void Watch(
Task task
)
C++
public:
void Watch(
Task task
) sealed
J#
public void Watch(
Task task
)
JScript
public function Watch(
task : Task
)

Parameters

task
The task to monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if task is null

See Also

TaskContainer Class
Gallio.Concurrency Namespace


Events

TaskContainer Events
[image]

Public Events

 | Name | Description
Public event | TaskAborted | Adds or removes an event handler that is signaled when any watched task is aborted.
Public event | TaskStarted | Adds or removes an event handler that is signaled when any watched task is started.
Public event | TaskTerminated | Adds or removes an event handler that is signaled when any watched task is terminated.
Top

See Also

TaskContainer Class
Gallio.Concurrency Namespace


TaskAborted Event

TaskContainer.TaskAborted Event
[image]

Adds or removes an event handler that is signaled when any watched task is aborted.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TaskAborted As EventHandler(Of TaskEventArgs)
C#
public event EventHandler<TaskEventArgs> TaskAborted
C++
public:
virtual event EventHandler<TaskEventArgs> TaskAborted {
void add(EventHandler<TaskEventArgs> value) sealed ;
void remove(EventHandler<TaskEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TaskAborted(EventHandler<TaskEventArgs> value);

/** event */
public final void remove_TaskAborted(EventHandler<TaskEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TaskEventArgs containing data related to this event. The following TaskEventArgs property provides information specific to this event.

Property | Description
Task | Gets the task that the event is about.

See Also

TaskContainer Class
Gallio.Concurrency Namespace


TaskStarted Event

TaskContainer.TaskStarted Event
[image]

Adds or removes an event handler that is signaled when any watched task is started.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TaskStarted As EventHandler(Of TaskEventArgs)
C#
public event EventHandler<TaskEventArgs> TaskStarted
C++
public:
virtual event EventHandler<TaskEventArgs> TaskStarted {
void add(EventHandler<TaskEventArgs> value) sealed ;
void remove(EventHandler<TaskEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TaskStarted(EventHandler<TaskEventArgs> value);

/** event */
public final void remove_TaskStarted(EventHandler<TaskEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TaskEventArgs containing data related to this event. The following TaskEventArgs property provides information specific to this event.

Property | Description
Task | Gets the task that the event is about.

See Also

TaskContainer Class
Gallio.Concurrency Namespace


TaskTerminated Event

TaskContainer.TaskTerminated Event
[image]

Adds or removes an event handler that is signaled when any watched task is terminated.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TaskTerminated As EventHandler(Of TaskEventArgs)
C#
public event EventHandler<TaskEventArgs> TaskTerminated
C++
public:
virtual event EventHandler<TaskEventArgs> TaskTerminated {
void add(EventHandler<TaskEventArgs> value) sealed ;
void remove(EventHandler<TaskEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TaskTerminated(EventHandler<TaskEventArgs> value);

/** event */
public final void remove_TaskTerminated(EventHandler<TaskEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TaskEventArgs containing data related to this event. The following TaskEventArgs property provides information specific to this event.

Property | Description
Task | Gets the task that the event is about.

See Also

TaskContainer Class
Gallio.Concurrency Namespace


TaskEventArgs Class

TaskEventArgs Class
See Also Example Members
[image]

A task-related event.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskEventArgs
Inherits EventArgs
C#
public class TaskEventArgs : EventArgs
C++
ref class TaskEventArgs : EventArgs
J#
public class TaskEventArgs extends EventArgs
JScript
public class TaskEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Concurrency.TaskEventArgs

See Also

TaskEventArgs Members
Gallio.Concurrency Namespace


TaskEventArgs Members

TaskEventArgs Members
See Also Example Constructors Properties Methods
[image]

A task-related event.

The following tables list the members exposed by TaskEventArgs.

Public Constructors

 | Name | Description
Public method | TaskEventArgs | Creates event arguments for a task-related event.
Top

Public Properties

 | Name | Description
Public property | Task | Gets the task that the event is about.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TaskEventArgs Class
Gallio.Concurrency Namespace


TaskEventArgs Constructor

TaskEventArgs Constructor
[image]

Creates event arguments for a task-related event.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal task As Task _
)
C#
public TaskEventArgs(
Task task
)
C++
public:
TaskEventArgs(
Task task
) sealed
J#
public TaskEventArgs(
Task task
)
JScript
public function TaskEventArgs(
task : Task
)

Parameters

task
The task that the event is about

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if task is null

See Also

TaskEventArgs Class
Gallio.Concurrency Namespace


Properties

TaskEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Task | Gets the task that the event is about.
Top

See Also

TaskEventArgs Class
Gallio.Concurrency Namespace


Task Property

TaskEventArgs.Task Property
[image]

Gets the task that the event is about.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Task As Task
C#
public Task Task { get; }
C++
public property Task Task sealed {
Task get();
}
J#
/** property */
public Task get_Task();
JScript
public function get Task() : Task

See Also

TaskEventArgs Class
Gallio.Concurrency Namespace


TaskResult Class

TaskResult Class
See Also Example Members
[image]

Holds the result of executing a task. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class TaskResult
C#
[SerializableAttribute]
public sealed class TaskResult
C++
[SerializableAttribute]
ref class TaskResult sealed
J#
/** @attribute SerializableAttribute() */
public final class TaskResult
JScript
public
SerializableAttribute
final class TaskResult

Inheritance Hierarchy

System.Object
Gallio.Concurrency.TaskResult

See Also

TaskResult Members
Gallio.Concurrency Namespace


TaskResult Members

TaskResult Members
See Also Example Properties Methods
[image]

Holds the result of executing a task. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TaskResult.

Public Properties

 | Name | Description
Public property | Exception | Gets the exception that was encountered by the task and caused it to terminated, or null if no exception was thrown.
Public property | Value | Gets the value yielded by the task when it terminated, or null if an exception was thrown.
Top

Public Methods

 | Name | Description
 | CreateFromException | Creates a task result that contains the specified exception that was encountered by the task and caused it to terminate.
 | CreateFromValue | Creates a task result that contains the specified value yielded by the task when it terminated.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

TaskResult Class
Gallio.Concurrency Namespace


Properties

TaskResult Properties
[image]

Public Properties

 | Name | Description
Public property | Exception | Gets the exception that was encountered by the task and caused it to terminated, or null if no exception was thrown.
Public property | Value | Gets the value yielded by the task when it terminated, or null if an exception was thrown.
Top

See Also

TaskResult Class
Gallio.Concurrency Namespace


Exception Property

TaskResult.Exception Property
[image]

Gets the exception that was encountered by the task and caused it to terminated, or null if no exception was thrown.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception { get; }
C++
public property Exception Exception sealed {
Exception get();
}
J#
/** property */
public Exception get_Exception();
JScript
public function get Exception() : Exception

See Also

TaskResult Class
Gallio.Concurrency Namespace


Value Property

TaskResult.Value Property
[image]

Gets the value yielded by the task when it terminated, or null if an exception was thrown.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value { get; }
C++
public property object Value sealed {
Object get();
}
J#
/** property */
public object get_Value();
JScript
public function get Value() : Object

See Also

TaskResult Class
Gallio.Concurrency Namespace


Methods

TaskResult Methods
[image]

Public Methods

 | Name | Description
 | CreateFromException | Creates a task result that contains the specified exception that was encountered by the task and caused it to terminate.
 | CreateFromValue | Creates a task result that contains the specified value yielded by the task when it terminated.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

TaskResult Class
Gallio.Concurrency Namespace


CreateFromException Method

TaskResult.CreateFromException Method
[image]

Creates a task result that contains the specified exception that was encountered by the task and caused it to terminate.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromException( _
ByVal exception As Exception _
) As TaskResult
C#
public static TaskResult CreateFromException(
Exception exception
)
C++
public:
static TaskResult CreateFromException(
Exception exception
)
J#
public static TaskResult CreateFromException(
Exception exception
)
JScript
public static function CreateFromException(
exception : Exception
) : TaskResult

Parameters

exception
The exception

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

See Also

TaskResult Class
Gallio.Concurrency Namespace


CreateFromValue Method

TaskResult.CreateFromValue Method
[image]

Creates a task result that contains the specified value yielded by the task when it terminated.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromValue( _
ByVal value As Object _
) As TaskResult
C#
public static TaskResult CreateFromValue(
object value
)
C++
public:
static TaskResult CreateFromValue(
Object value
)
J#
public static TaskResult CreateFromValue(
object value
)
JScript
public static function CreateFromValue(
value : Object
) : TaskResult

Parameters

value
The value

See Also

TaskResult Class
Gallio.Concurrency Namespace


ToString Method

TaskResult.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

TaskResult Class
Gallio.Concurrency Namespace


ThreadAbortScope Class

ThreadAbortScope Class
See Also Example Members
[image]

A ThreadAbortScope executes a block of code inside a special scope that is designed to issue and safely handle Abort on demand.

This class may be used as a primitive for implementing higher-level protected scopes for the purpose of asynchronous cancelation and time-limited execution.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ThreadAbortScope
C#
public class ThreadAbortScope
C++
ref class ThreadAbortScope
J#
public class ThreadAbortScope
JScript
public class ThreadAbortScope

Remarks

The implementation distinguishes between Aborts that are initated using the Abort method and those that may be initiated by other system components. Foreign aborts are not handled so they are allowed to continue to propagate. This is to ensure that critical aborts such as those that are initiated by Unload can unwind the stack without interference.

Inheritance Hierarchy

System.Object
Gallio.Concurrency.ThreadAbortScope

See Also

ThreadAbortScope Members
Gallio.Concurrency Namespace


ThreadAbortScope Members

ThreadAbortScope Members
See Also Example Constructors Methods
[image]

A ThreadAbortScope executes a block of code inside a special scope that is designed to issue and safely handle Abort on demand.

This class may be used as a primitive for implementing higher-level protected scopes for the purpose of asynchronous cancelation and time-limited execution.

The following tables list the members exposed by ThreadAbortScope.

Public Constructors

 | Name | Description
Public method | ThreadAbortScope | Initializes a new instance of the ThreadAbortScope class.
Top

Public Methods

 | Name | Description
Public method | Abort | Aborts the currently running action and prevents any further actions from running inside of this scope.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Protect | Runs an action inside of a protected context wherein it cannot receive a thread abort from this ThreadAbortScope.
Public method | Run | Runs an action inside of the scope.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ThreadAbortScope Class
Gallio.Concurrency Namespace


ThreadAbortScope Constructor

ThreadAbortScope Constructor
[image]

Initializes a new instance of the ThreadAbortScope class.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ThreadAbortScope()
C++
public:
ThreadAbortScope() sealed
J#
public ThreadAbortScope()
JScript
public function ThreadAbortScope()

See Also

ThreadAbortScope Class
Gallio.Concurrency Namespace


Methods

ThreadAbortScope Methods
[image]

Public Methods

 | Name | Description
Public method | Abort | Aborts the currently running action and prevents any further actions from running inside of this scope.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Protect | Runs an action inside of a protected context wherein it cannot receive a thread abort from this ThreadAbortScope.
Public method | Run | Runs an action inside of the scope.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ThreadAbortScope Class
Gallio.Concurrency Namespace


Abort Method

ThreadAbortScope.Abort Method
[image]

Aborts the currently running action and prevents any further actions from running inside of this scope.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Abort()
C#
public void Abort()
C++
public:
void Abort() sealed
J#
public void Abort()
JScript
public function Abort()

See Also

ThreadAbortScope Class
Gallio.Concurrency Namespace


Protect Method

ThreadAbortScope.Protect Method
[image]

Runs an action inside of a protected context wherein it cannot receive a thread abort from this ThreadAbortScope.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerHiddenAttribute>
Public Sub Protect( _
ByVal action As Action _
)
C#
[DebuggerHiddenAttribute]
public void Protect(
Action action
)
C++
[DebuggerHiddenAttribute]
public:
void Protect(
Action action
) sealed
J#
/** @attribute DebuggerHiddenAttribute() */
public void Protect(
Action action
)
JScript
public

DebuggerHiddenAttribute
function Protect(
action : Action
)

Parameters

action
The action to run

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

This method enables critical system code to be protected from aborts that may affect the scope. This call cannot be nested.

See Also

ThreadAbortScope Class
Gallio.Concurrency Namespace


Run Method

ThreadAbortScope.Run Method
[image]

Runs an action inside of the scope.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerHiddenAttribute>
Public Function Run( _
ByVal action As Action _
) As ThreadAbortException
C#
[DebuggerHiddenAttribute]
public ThreadAbortException Run(
Action action
)
C++
[DebuggerHiddenAttribute]
public:
ThreadAbortException Run(
Action action
) sealed
J#
/** @attribute DebuggerHiddenAttribute() */
public ThreadAbortException Run(
Action action
)
JScript
public

DebuggerHiddenAttribute
function Run(
action : Action
) : ThreadAbortException

Parameters

action
The action to run

Return Value

The ThreadAbortException that was caught if the action was aborted, or null if the action completed normally

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null
InvalidOperationException | Thrown if an action is already running in this scope
Exception | Any other exception thrown by action itself

Remarks

At most one action may be in progress at any time. This method is not reentrant and cannot be called concurrently from multiple threads.

See Also

ThreadAbortScope Class
Gallio.Concurrency Namespace


ThreadTask Class

ThreadTask Class
See Also Example Members
[image]

An implementation of Task based on a locally running thread.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ThreadTask
Inherits Task
C#
public class ThreadTask : Task
C++
ref class ThreadTask : Task
J#
public class ThreadTask extends Task
JScript
public class ThreadTask extends Task

Inheritance Hierarchy

System.Object
Gallio.Concurrency.Task
Gallio.Concurrency.ThreadTask

See Also

ThreadTask Members
Gallio.Concurrency Namespace


ThreadTask Members

ThreadTask Members
See Also Example Properties Methods Events Explicit Inteface Implementations
[image]

An implementation of Task based on a locally running thread.

The following tables list the members exposed by ThreadTask.

Public Constructors

Name | Description
ThreadTask | Overloaded.
Top

Public Properties

 | Name | Description
Public property | ApartmentState | Gets or sets the desired ApartmentState to use for the thread when it is started.
Public property | IsAborted | Returns true if the task has been aborted. (inherited from Task)
Public property | IsPending | Returns true if the task has not been started or aborted yet. (inherited from Task)
Public property | IsRunning | Returns true if the task is running. (inherited from Task)
Public property | IsTerminated | Returns true if the task ran and was terminated. (inherited from Task)
Public property | Name | Gets the name of the task. (inherited from Task)
Public property | Result | Gets the task result, or null if the task has not terminated or was aborted before starting. (inherited from Task)
Public property | Thread | Gets the thread on which the task is running, or null if the task is not running.
Top

Public Methods

 | Name | Description
Public method | Abort | Asynchronously aborts the task. If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing. (inherited from Task)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Waits for the task to terminate. Does nothing if the task has not been started or is not running. (inherited from Task)
Public method | Run | Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false. (inherited from Task)
Public method | Start | Starts running the task. Does nothing if the task has already been started or has been aborted. (inherited from Task)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AbortImpl | Overridden. Aborts the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | JoinImpl | Overridden. Waits for the task to terminate.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyTerminated | Dispatches notification that the task has terminated and provides its result. (inherited from Task)
Family method | OnAborted | Notifies the Aborted event handlers. (inherited from Task)
Family method | OnStarted | Notifies the Started event handlers. (inherited from Task)
Family method | OnTerminated | Notifies the Terminated event handlers. (inherited from Task)
Family method | StartImpl | Overridden. Starts the task.
Top

Public Events

 | Name | Description
Public event | Aborted | Adds or removes an event handler that is signaled when the task is aborted. If a handler is being added and the task has already aborted, it is immediately invoked. (inherited from Task)
Public event | Started | Adds or removes an event handler that is signaled when the task is started. If a handler is being added and the task has already started, it is immediately invoked. (inherited from Task)
Public event | Terminated | Adds or removes an event handler that is signaled when the task is terminated. If a handler is being added and the task has already terminated, it is immediately invoked. (inherited from Task)
Top

Explicit Interface Implementations

Name | Description
ThreadTask | Overloaded.
Top

See Also

ThreadTask Class
Gallio.Concurrency Namespace


ThreadTask Constructor

ThreadTask Constructor

Overload List

 | Name | Description
Public method | ThreadTask (String, Action) | Creates a task that will execute code within a new locally running thread. When the task terminates successfully, its result will contain the value null.
Public method | ThreadTask (String, Func<object>) | Creates a task that will execute code within a new locally running thread. When the task terminates successfully, its result will contain the value returned by action.

See Also

ThreadTask Class
Gallio.Concurrency Namespace


ThreadTask Constructor (String, Action)

ThreadTask Constructor (String, Action)
See Also Example
[image]

Creates a task that will execute code within a new locally running thread. When the task terminates successfully, its result will contain the value null.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal action As Action _
)
C#
public ThreadTask(
string name,
Action action
)
C++
public:
ThreadTask(
String name,
Action action
) sealed
J#
public ThreadTask(
string name,
Action action
)
JScript
public function ThreadTask(
name : String,
action : Action
)

Parameters

name
The name of the task
action
The action to perform within the thread

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null

See Also

ThreadTask Class
Gallio.Concurrency Namespace
ThreadTask Constructor Overload List


ThreadTask Constructor (String, Generic Func)

ThreadTask Constructor (String, Generic Func)
See Also Example
[image]

Creates a task that will execute code within a new locally running thread. When the task terminates successfully, its result will contain the value returned by action.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal action As Func(Of Object) _
)
C#
public ThreadTask(
string name,
Func<object> action
)
C++
public:
ThreadTask(
String name,
Func<object> action
) sealed
J#
public ThreadTask(
string name,
Func<object> action
)
JScript
public function ThreadTask(
name : String,
action : Func<object>
)

Parameters

name
The name of the task
action
The action to perform within the thread

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null

See Also

ThreadTask Class
Gallio.Concurrency Namespace
ThreadTask Constructor Overload List


Properties

ThreadTask Properties
[image]

Public Properties

 | Name | Description
Public property | ApartmentState | Gets or sets the desired ApartmentState to use for the thread when it is started.
Public property | IsAborted | Returns true if the task has been aborted. (inherited from Task)
Public property | IsPending | Returns true if the task has not been started or aborted yet. (inherited from Task)
Public property | IsRunning | Returns true if the task is running. (inherited from Task)
Public property | IsTerminated | Returns true if the task ran and was terminated. (inherited from Task)
Public property | Name | Gets the name of the task. (inherited from Task)
Public property | Result | Gets the task result, or null if the task has not terminated or was aborted before starting. (inherited from Task)
Public property | Thread | Gets the thread on which the task is running, or null if the task is not running.
Top

See Also

ThreadTask Class
Gallio.Concurrency Namespace


ApartmentState Property

ThreadTask.ApartmentState Property
[image]

Gets or sets the desired ApartmentState to use for the thread when it is started.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ApartmentState As ApartmentState
C#
public ApartmentState ApartmentState { get; set; }
C++
public property ApartmentState ApartmentState sealed {
ApartmentState get();
void set(ApartmentState value);
}
J#
/** property */
public ApartmentState get_ApartmentState();

/** property */
public void set_ApartmentState(ApartmentState value);
JScript
public function get ApartmentState() : ApartmentState

public function set ApartmentState(value : ApartmentState);

Property Value

The default value is Unknown which causes the new thread to use the runtime's default apartment state.

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if this method is called after the thread has started

See Also

ThreadTask Class
Gallio.Concurrency Namespace


Thread Property

ThreadTask.Thread Property
[image]

Gets the thread on which the task is running, or null if the task is not running.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Thread As Thread
C#
public Thread Thread { get; }
C++
public property Thread Thread sealed {
Thread get();
}
J#
/** property */
public Thread get_Thread();
JScript
public function get Thread() : Thread

See Also

ThreadTask Class
Gallio.Concurrency Namespace


Methods

ThreadTask Methods
[image]

Public Methods

 | Name | Description
Public method | Abort | Asynchronously aborts the task. If the task has not been started, then the task will be forbidden from starting later and its IsAborted property will be set. If the task has already terminated, then does nothing. (inherited from Task)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Waits for the task to terminate. Does nothing if the task has not been started or is not running. (inherited from Task)
Public method | Run | Starts the task and waits for it to complete until the timeout expires. If the timeout expires, aborts the task and returns false. (inherited from Task)
Public method | Start | Starts running the task. Does nothing if the task has already been started or has been aborted. (inherited from Task)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AbortImpl | Overridden. Aborts the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | JoinImpl | Overridden. Waits for the task to terminate.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyTerminated | Dispatches notification that the task has terminated and provides its result. (inherited from Task)
Family method | OnAborted | Notifies the Aborted event handlers. (inherited from Task)
Family method | OnStarted | Notifies the Started event handlers. (inherited from Task)
Family method | OnTerminated | Notifies the Terminated event handlers. (inherited from Task)
Family method | StartImpl | Overridden. Starts the task.
Top

See Also

ThreadTask Class
Gallio.Concurrency Namespace


AbortImpl Method

ThreadTask.AbortImpl Method
[image]

Aborts the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AbortImpl()
C#
protected override void AbortImpl()
C++
protected:
virtual void AbortImpl() override
J#
protected override void AbortImpl()
JScript
protected override function AbortImpl()

See Also

ThreadTask Class
Gallio.Concurrency Namespace


JoinImpl Method

ThreadTask.JoinImpl Method
[image]

Waits for the task to terminate.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function JoinImpl( _
ByVal timeout As Nullable(Of TimeSpan) _
) As Boolean
C#
protected override bool JoinImpl(
Nullable<TimeSpan> timeout
)
C++
protected:
virtual bool JoinImpl(
Nullable<TimeSpan> timeout
) override
J#
protected override bool JoinImpl(
Nullable<TimeSpan> timeout
)
JScript
protected override function JoinImpl(
timeout : Nullable<TimeSpan>
) : bool

Parameters

timeout
The timeout, or null to wait indefinitely

Return Value

True if the task is not running as of the time this method exits, false if a timeout occurred while waiting

See Also

ThreadTask Class
Gallio.Concurrency Namespace


StartImpl Method

ThreadTask.StartImpl Method
[image]

Starts the task.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StartImpl()
C#
protected override void StartImpl()
C++
protected:
virtual void StartImpl() override
J#
protected override void StartImpl()
JScript
protected override function StartImpl()

See Also

ThreadTask Class
Gallio.Concurrency Namespace


WriteAction Generic Delegate

WriteAction Generic Delegate
[image]

An action that reads or writes the contents of an object.

Namespace: Gallio.Concurrency
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub WriteAction(Of T)( _
ByVal obj As T _
)
C#
public delegate void WriteAction<T>(
T obj
)
C++
public delegate void WriteAction<T>(
T obj
)
J#
/** delegate */
public delegate void WriteAction<T>(
T obj
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of object

Parameters

obj
The object

See Also

Gallio.Concurrency Namespace


Gallio.Framework

Gallio.Framework Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class ComparisonSemantics

Describes the semantics of how objects should be compared.

This class encapsulates a default set of rules for comparing objects. These rules may be used as the foundation of a suite of standard assertion functions for comparing identity, equality and relations.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | DiagnosticLog | The diagnostic log provides services for writing diagnostic messages to the console or runtime log during a test run. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class Sandbox

A sandbox is an isolated environments for executing test actions. It provides the ability to abort actions in progress so that the test runner can proceed to run other actions.

Sandboxes are hierarchically structured. When an outer sandbox is aborted, all of its inner sandboxes are likewise aborted. A sandbox also provides the ability to create new child sandboxes at will so that test actions can be isolated with fine granularity.

This class cannot be inherited.
Public class | SilentTestException | This exception type is used to signal a test outcome silently without logging the exception.
Public class Tasks

The tasks class provides a mechanism for coordinating the actions of multiple tasks within a test case.

Each task started by a test case is monitored. When the test exits, any remaining tasks are automatically aborted and disposed.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class TestContext

The test context provides information about the environment in which a test is executing. A new context is created each time a test or test step begins execution.

Test contexts are arranged in a hierarchy that corresponds to the order in which the contexts were entered. Thus the context for a test likely has as its parent the context for its containing test fixture.

Arbitrary user data can be associated with a test context. Furthermore, client code may attach Finishing event handlers to perform resource reclamation just prior to marking the test step as finished.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class TestException

This exception type is an abstract base class for exceptions that are used to explicitly signal the outcome of a test.

The test framework uses the value of the Outcome property to set the test result instead of applying the standard behavior for unexpected exceptions.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class TestFailedException

This exception type is used to signal that a test has failed to satisfy some predetermined condition established by the test author.

For example, an assertion failure may be signaled using a TestFailedException to distinguish it from other application or runtime errors that a test might encounter at runtime.

Public class | TestInconclusiveException | This exception type is used to signal that a test has not produced a conclusive pass or fail result. The exception message, if present, should explain the reason no conclusive result was obtained.
Public class | TestLog | The test log class provides services for writing information to the execution log associated with a test. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class TestStep

Provides functions for manipulating test steps.

A step is a delimited region of a test. Each step appears in the report as if it were a dynamically generated test nested within the body of the test (or some other step) that spawned it. The step has its own execution log, pass/fail/inconclusive result and in all other respects behaves much like an ordinary test would.

The number of steps within a test does not need to be known ahead of time. This can be useful in situations where insufficient information is known about the internal structure of a test to be able to fully populate the test tree will all of its details. Because steps are dynamically generated at runtime, they appear in test reports but they are invisible to test runners. that traverse the test tree.

There are many interesting uses for steps. For example:

  • A single test consisting of a long sequence of actions can be subdivided into steps to simplify analysis.
  • A test might depend on environmental configuration that cannot be known a priori.
  • A performance test might be scheduled to run for a certain duration but the total number of iterations is unknown. By running each iteration as a step within a single test, the test report can display the execution log and pass/fail result of each iteration independently of the others.
  • A script-driven test driver could execute a scripted sequence of verification commands as a distinct step. If the script is written in a general purpose programming language, the total number of commands and the order in which they will be performed might not be known ahead of time. Using steps enables the integration of tests written in forms that cannot be directly adapted to the framework's native testing primitives.
  • When testing non-deterministic algorithms, it is sometimes useful to repeat a test multiple times under slightly different conditions until a certain level of confidence is reached. The variety of conditions tested might be determined adaptively based on an error estimation metric. Using steps each condition verified can be reported independently.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | TestTerminatedException | This exception type is used to signal that a test has been terminated with a particular outcome. The exception message, if present, should explain the reason that the test was terminated.

Structures

 | Structure | Description
Public structure | TestContextCookie | A context cookie is used to unwind the context stack of the current thread to its previous state prior to a context having been entered.


ComparisonSemantics Class

ComparisonSemantics Class
See Also Example Members
[image]

Describes the semantics of how objects should be compared.

This class encapsulates a default set of rules for comparing objects. These rules may be used as the foundation of a suite of standard assertion functions for comparing identity, equality and relations.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public Module ComparisonSemantics
C#
[TestFrameworkInternalAttribute]
public static class ComparisonSemantics
C++
[TestFrameworkInternalAttribute]
ref class ComparisonSemantics abstract sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public final class ComparisonSemantics
JScript
public
TestFrameworkInternalAttribute
class ComparisonSemantics

Remarks

At this time, there is no extensiblity mechanism provided for comparison semantics but it would be nice to have one. Feel free to add your comments to the issue: http://code.google.com/p/mb-unit/issues/detail?id=304

Inheritance Hierarchy

System.Object
Gallio.Framework.ComparisonSemantics

See Also

ComparisonSemantics Members
Gallio.Framework Namespace


ComparisonSemantics Members

ComparisonSemantics Members
See Also Example Methods
[image]

Describes the semantics of how objects should be compared.

This class encapsulates a default set of rules for comparing objects. These rules may be used as the foundation of a suite of standard assertion functions for comparing identity, equality and relations.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ComparisonSemantics.

Public Methods

Name | Description
ApproximatelyEqual | Returns true if two values are equal to within a specified delta.
Compare | Compares two objects.
Equals | Overloaded. Determines whether two Object instances are equal.
IsSimpleEnumerableType | Returns true if the specified type is a simple enumerable type. A simple enumerable type is one that that does not override Equals.
Same | Returns true if two objects are the same.
Top

See Also

ComparisonSemantics Class
Gallio.Framework Namespace


Methods

ComparisonSemantics Methods
[image]

Public Methods

Name | Description
ApproximatelyEqual | Returns true if two values are equal to within a specified delta.
Compare | Compares two objects.
Equals | Overloaded. Determines whether two Object instances are equal.
IsSimpleEnumerableType | Returns true if the specified type is a simple enumerable type. A simple enumerable type is one that that does not override Equals.
Same | Returns true if two objects are the same.
Top

See Also

ComparisonSemantics Class
Gallio.Framework Namespace


ApproximatelyEqual Generic Method

ComparisonSemantics.ApproximatelyEqual Generic Method
[image]

Returns true if two values are equal to within a specified delta.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ApproximatelyEqual(Of TValue, TDifference)( _
ByVal left As TValue, _
ByVal right As TValue, _
ByVal delta As TDifference _
) As Boolean
C#
public static bool ApproximatelyEqual<TValue, TDifference>(
TValue left,
TValue right,
TDifference delta
)
C++
public:
static bool ApproximatelyEqual<TValue, TDifference>(
TValue left,
TValue right,
TDifference delta
)
J#
public static bool ApproximatelyEqual<TValue, TDifference>(
TValue left,
TValue right,
TDifference delta
)
JScript
JScript does not support generic types and methods.

Type Parameters

TValue
The type of values to be compared
TDifference
The type of the difference produced when the values are subtracted, for numeric types this is the same as TValue but it may differ for other types

Parameters

left
The expected value
right
The actual value
delta
The inclusive delta between the values

Return Value

True if the values are approximately equal

Remarks

The values are considered approximately equal if the absolute value of their difference is less than or equal to the delta.

This method works with any comparable type that also supports a subtraction operator including Single, Double, Decimal, Int32, DateTime (using a TimeSpan delta), and many others.

See Also

ComparisonSemantics Class
Gallio.Framework Namespace


Compare Generic Method

ComparisonSemantics.Compare Generic Method
[image]

Compares two objects.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Compare(Of T)( _
ByVal left As T, _
ByVal right As T _
) As Integer
C#
public static int Compare<T>(
T left,
T right
)
C++
public:
static int Compare<T>(
T left,
T right
)
J#
public static int Compare<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The object type

Parameters

left
The left object, may be null
right
The right object, may be null

Return Value

A value less than zero if the left object if less than the right object, zero if the left and right objects are equal, or greater than zero if the left object is greater than the right object

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the values cannot be ordered.

Remarks

Rules applied:

  • If both objects are null, returns 0.
  • If both objects are referentially equal, returns true.
  • If the objects are both instances of the same simple enumerable type (), then compares each pair of values until a non-equal pair is found at which point the result of that comparison is returned. If one enumeration runs out of values than the other, then it is considered to be less than the other.
  • If the objects implement IComparable, uses it to determine order.
  • If the objects implement IComparable, uses it to determine order.
  • Otherwise no deterministic comparison is possible so throws an exception.

The ordering of nulls is determined by CompareTo except when comparing collections. If one collection happens to be null but not the other then it is considered less than the other.

See Also

ComparisonSemantics Class
Gallio.Framework Namespace
IsSimpleEnumerableType


Equals Method

ComparisonSemantics.Equals Method

Determines whether two Object instances are equal.

Overload List

Name | Description
Equals (Object, Object) | Returns true if two objects are equal.
Equals (T, T) | Returns true if two objects are equal.

See Also

ComparisonSemantics Class
Gallio.Framework Namespace


Equals Method (Object, Object)

ComparisonSemantics.Equals Method (Object, Object)
See Also Example
[image]

Returns true if two objects are equal.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Equals( _
ByVal left As Object, _
ByVal right As Object _
) As Boolean
C#
public static bool Equals(
object left,
object right
)
C++
public:
static bool Equals(
Object left,
Object right
)
J#
public static bool Equals(
object left,
object right
)
JScript
public static function Equals(
left : Object,
right : Object
) : bool

Parameters

left
The left object, may be null
right
The right object, may be null

Return Value

True if the objects are equal

See Also

ComparisonSemantics Class
Gallio.Framework Namespace
ComparisonSemantics.Equals Overload List
Equals


Equals Generic Method (T, T)

ComparisonSemantics.Equals Generic Method (T, T)
See Also Example
[image]

Returns true if two objects are equal.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Equals(Of T)( _
ByVal left As T, _
ByVal right As T _
) As Boolean
C#
public static bool Equals<T>(
T left,
T right
)
C++
public:
static bool Equals<T>(
T left,
T right
)
J#
public static bool Equals<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The object type

Parameters

left
The left object, may be null
right
The right object, may be null

Return Value

True if the objects are equal

Remarks

Rules applied:

  • If both objects are null, returns true.
  • If one object is null but not the other, returns false.
  • If both objects are referentially equal, returns true.
  • If the objects are both instances of the same simple enumerable type (), returns true if the collections have equal length and contents.
  • Otherwise uses Equals to determine equality.

See Also

ComparisonSemantics Class
Gallio.Framework Namespace
ComparisonSemantics.Equals Overload List
IsSimpleEnumerableType


IsSimpleEnumerableType Method

ComparisonSemantics.IsSimpleEnumerableType Method
[image]

Returns true if the specified type is a simple enumerable type. A simple enumerable type is one that that does not override Equals.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsSimpleEnumerableType( _
ByVal type As Type _
) As Boolean
C#
public static bool IsSimpleEnumerableType(
Type type
)
C++
public:
static bool IsSimpleEnumerableType(
Type type
)
J#
public static bool IsSimpleEnumerableType(
Type type
)
JScript
public static function IsSimpleEnumerableType(
type : Type
) : bool

Parameters

type
The object type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

Remarks

The set of simple enumerable types includes arrays, lists, dictionaries and other standard collection types in the .Net framework.

See Also

ComparisonSemantics Class
Gallio.Framework Namespace


Same Generic Method

ComparisonSemantics.Same Generic Method
[image]

Returns true if two objects are the same.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Same(Of T As Class)( _
ByVal left As T, _
ByVal right As T _
) As Boolean
C#
public static bool Same<T>(
T left,
T right
) where T : class
C++
public:
static bool Same<T>(
T left,
T right
)
J#
public static bool Same<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The object type, which must be a reference type (class) since a value type (struct) has no concept of referential identity.

Parameters

left
The left object, may be null
right
The right object, may be null

Return Value

True if both objects are the same

Remarks

Rules applied:

  • Objects are the same if they are referentially equal according to ReferenceEquals.

See Also

ComparisonSemantics Class
Gallio.Framework Namespace


DiagnosticLog Class

DiagnosticLog Class
[image]

The diagnostic log provides services for writing diagnostic messages to the console or runtime log during a test run. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module DiagnosticLog
C#
public static class DiagnosticLog
C++
ref class DiagnosticLog abstract sealed
J#
public final class DiagnosticLog
JScript
public class DiagnosticLog

Remarks

Diagnostic messages will appear in the test report but they are not associated with any particular tests. Unlike TestLog the messages may not include rich content such as attachments or embedded images.

If you use the diagnostic log to report progress messages, keep in mind that they will all be preserved in the report, making the report larger.

Inheritance Hierarchy

System.Object
Gallio.Framework.DiagnosticLog

See Also

DiagnosticLog Members
Gallio.Framework Namespace
TestLog


DiagnosticLog Members

DiagnosticLog Members
[image]

The diagnostic log provides services for writing diagnostic messages to the console or runtime log during a test run. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by DiagnosticLog.

Public Methods

Name | Description
WriteLine | Overloaded. Writes a message to the diagnostic log.
Top

See Also

DiagnosticLog Class
Gallio.Framework Namespace
TestLog


Methods

DiagnosticLog Methods
[image]

Public Methods

Name | Description
WriteLine | Overloaded. Writes a message to the diagnostic log.
Top

See Also

DiagnosticLog Class
Gallio.Framework Namespace
TestLog


WriteLine Method

DiagnosticLog.WriteLine Method

Writes a message to the diagnostic log.

Overload List

Name | Description
WriteLine (String) | Writes a message to the diagnostic log.
WriteLine (String, Object) | Writes a formatted message to the diagnostic log.

See Also

DiagnosticLog Class
Gallio.Framework Namespace


WriteLine Method (String)

DiagnosticLog.WriteLine Method (String)
See Also Example
[image]

Writes a message to the diagnostic log.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal message As String _
)
C#
public static void WriteLine(
string message
)
C++
public:
static void WriteLine(
String message
)
J#
public static void WriteLine(
string message
)
JScript
public static function WriteLine(
message : String
)

Parameters

message
The message to write, may be null

See Also

DiagnosticLog Class
Gallio.Framework Namespace
DiagnosticLog.WriteLine Overload List


WriteLine Method (String, Object[])

DiagnosticLog.WriteLine Method (String, Object[])
See Also Example
[image]

Writes a formatted message to the diagnostic log.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void WriteLine(
string messageFormat,
params object[] messageArgs
)
C++
public:
static void WriteLine(
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void WriteLine(
string messageFormat,
object[] messageArgs
)
JScript
public static function WriteLine(
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

messageFormat
The message format string, may be null
messageArgs
The message arguments

See Also

DiagnosticLog Class
Gallio.Framework Namespace
DiagnosticLog.WriteLine Overload List
Format


Sandbox Class

Sandbox Class
See Also Example Members
[image]

A sandbox is an isolated environments for executing test actions. It provides the ability to abort actions in progress so that the test runner can proceed to run other actions.

Sandboxes are hierarchically structured. When an outer sandbox is aborted, all of its inner sandboxes are likewise aborted. A sandbox also provides the ability to create new child sandboxes at will so that test actions can be isolated with fine granularity.

This class cannot be inherited.
Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public NotInheritable Class Sandbox
Implements IDisposable
C#
[TestFrameworkInternalAttribute]
public sealed class Sandbox : IDisposable
C++
[TestFrameworkInternalAttribute]
ref class Sandbox sealed : IDisposable
J#
/** @attribute TestFrameworkInternalAttribute() */
public final class Sandbox implements IDisposable
JScript
public
TestFrameworkInternalAttribute
final class Sandbox extends IDisposable

Remarks

This class is safe for use from multiple concurrent threads.

Inheritance Hierarchy

System.Object
Gallio.Framework.Sandbox

See Also

Sandbox Members
Gallio.Framework Namespace


Sandbox Members

Sandbox Members
See Also Example Constructors Properties Methods Events
[image]

A sandbox is an isolated environments for executing test actions. It provides the ability to abort actions in progress so that the test runner can proceed to run other actions.

Sandboxes are hierarchically structured. When an outer sandbox is aborted, all of its inner sandboxes are likewise aborted. A sandbox also provides the ability to create new child sandboxes at will so that test actions can be isolated with fine granularity.

This class cannot be inherited.

The following tables list the members exposed by Sandbox.

Public Constructors

 | Name | Description
Public method | Sandbox | Creates a root sandbox.
Top

Public Properties

 | Name | Description
Public property | AbortMessage | Gets a message that will be logged when the sandbox is aborted, or null if none.
Public property | AbortOutcome | Returns the TestOutcome passed to Abort, or null if Abort has not been called.
Public property | WasAborted | Returns true if Abort was called.
Top

Public Methods

 | Name | Description
Public method | Abort | Aborts all actions in progress within this context. The abort is persistent and cannot be reverted. Therefore once aborted, no further test actions will be permitted to run. Subsequent calls to Abort will have no effect.
Public method | CreateChild | Creates a child sandbox. When the parent sandbox is aborted, the child will likewise be aborted. This policy offers a mechanism to scope actions recursively.
Public method | Dispose | Disposes the sandbox. All currently executing actions are aborted with Error if Abort has not already been called.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Protect | Runs an action inside of a protected context wherein it cannot receive a thread abort from this Sandbox.
Public method | Run | Runs a test action.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | UseTimeout | Uses a specified timeout for all actions run within a block of code.
Top

Public Events

 | Name | Description
Public event | Aborted | An event that is dispatched when Abort is called. If the sandbox has already been aborted then the event handler is immediately invoked.
Top

See Also

Sandbox Class
Gallio.Framework Namespace


Sandbox Constructor

Sandbox Constructor
[image]

Creates a root sandbox.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Sandbox()
C++
public:
Sandbox() sealed
J#
public Sandbox()
JScript
public function Sandbox()

See Also

Sandbox Class
Gallio.Framework Namespace


Properties

Sandbox Properties
[image]

Public Properties

 | Name | Description
Public property | AbortMessage | Gets a message that will be logged when the sandbox is aborted, or null if none.
Public property | AbortOutcome | Returns the TestOutcome passed to Abort, or null if Abort has not been called.
Public property | WasAborted | Returns true if Abort was called.
Top

See Also

Sandbox Class
Gallio.Framework Namespace


AbortMessage Property

Sandbox.AbortMessage Property
[image]

Gets a message that will be logged when the sandbox is aborted, or null if none.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbortMessage As String
C#
public string AbortMessage { get; }
C++
public property string AbortMessage sealed {
String get();
}
J#
/** property */
public string get_AbortMessage();
JScript
public function get AbortMessage() : String

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed

See Also

Sandbox Class
Gallio.Framework Namespace


AbortOutcome Property

Sandbox.AbortOutcome Property
[image]

Returns the TestOutcome passed to Abort, or null if Abort has not been called.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AbortOutcome As Nullable(Of TestOutcome)
C#
public Nullable<TestOutcome> AbortOutcome { get; }
C++
public property Nullable<TestOutcome> AbortOutcome sealed {
Nullable<TestOutcome> get();
}
J#
/** property */
public Nullable<TestOutcome> get_AbortOutcome();
JScript
public function get AbortOutcome() : Nullable<TestOutcome>

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed

See Also

Sandbox Class
Gallio.Framework Namespace


WasAborted Property

Sandbox.WasAborted Property
[image]

Returns true if Abort was called.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WasAborted As Boolean
C#
public bool WasAborted { get; }
C++
public property bool WasAborted sealed {
bool get();
}
J#
/** property */
public bool get_WasAborted();
JScript
public function get WasAborted() : bool

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed

See Also

Sandbox Class
Gallio.Framework Namespace


Methods

Sandbox Methods
[image]

Public Methods

 | Name | Description
Public method | Abort | Aborts all actions in progress within this context. The abort is persistent and cannot be reverted. Therefore once aborted, no further test actions will be permitted to run. Subsequent calls to Abort will have no effect.
Public method | CreateChild | Creates a child sandbox. When the parent sandbox is aborted, the child will likewise be aborted. This policy offers a mechanism to scope actions recursively.
Public method | Dispose | Disposes the sandbox. All currently executing actions are aborted with Error if Abort has not already been called.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Protect | Runs an action inside of a protected context wherein it cannot receive a thread abort from this Sandbox.
Public method | Run | Runs a test action.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | UseTimeout | Uses a specified timeout for all actions run within a block of code.
Top

See Also

Sandbox Class
Gallio.Framework Namespace


Abort Method

Sandbox.Abort Method
[image]

Aborts all actions in progress within this context.

The abort is persistent and cannot be reverted. Therefore once aborted, no further test actions will be permitted to run. Subsequent calls to Abort will have no effect.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Abort( _
ByVal outcome As TestOutcome, _
ByVal message As String _
)
C#
public void Abort(
TestOutcome outcome,
string message
)
C++
public:
void Abort(
TestOutcome outcome,
String message
) sealed
J#
public void Abort(
TestOutcome outcome,
string message
)
JScript
public function Abort(
outcome : TestOutcome,
message : String
)

Parameters

outcome
The outcome to be returned from aborted actions
message
A message to be logged when the action is aborted, or null if none

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed

See Also

Sandbox Class
Gallio.Framework Namespace


CreateChild Method

Sandbox.CreateChild Method
[image]

Creates a child sandbox.

When the parent sandbox is aborted, the child will likewise be aborted. This policy offers a mechanism to scope actions recursively.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChild() As Sandbox
C#
public Sandbox CreateChild()
C++
public:
Sandbox CreateChild() sealed
J#
public Sandbox CreateChild()
JScript
public function CreateChild() : Sandbox

Return Value

The child sandbox

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed

See Also

Sandbox Class
Gallio.Framework Namespace


Dispose Method

Sandbox.Dispose Method
[image]

Disposes the sandbox.

All currently executing actions are aborted with Error if Abort has not already been called.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

Sandbox Class
Gallio.Framework Namespace


Protect Method

Sandbox.Protect Method
[image]

Runs an action inside of a protected context wherein it cannot receive a thread abort from this Sandbox.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerHiddenAttribute>
Public Sub Protect( _
ByVal action As Action _
)
C#
[DebuggerHiddenAttribute]
public void Protect(
Action action
)
C++
[DebuggerHiddenAttribute]
public:
void Protect(
Action action
) sealed
J#
/** @attribute DebuggerHiddenAttribute() */
public void Protect(
Action action
)
JScript
public

DebuggerHiddenAttribute
function Protect(
action : Action
)

Parameters

action
The action to run

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

This method enables critical system code to be protected from aborts that may affect the sandbox. This call cannot be nested.

See Also

Sandbox Class
Gallio.Framework Namespace


Run Method

Sandbox.Run Method
[image]

Runs a test action.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Run( _
ByVal testLogWriter As TestLogWriter, _
ByVal action As Action, _
ByVal description As String _
) As TestOutcome
C#
public TestOutcome Run(
TestLogWriter testLogWriter,
Action action,
string description
)
C++
public:
TestOutcome Run(
TestLogWriter testLogWriter,
Action action,
String description
) sealed
J#
public TestOutcome Run(
TestLogWriter testLogWriter,
Action action,
string description
)
JScript
public function Run(
testLogWriter : TestLogWriter,
action : Action,
description : String
) : TestOutcome

Parameters

testLogWriter
The log writer for reporting failures
action
The action to run
description
A description of the action being performed, to be used as a log section name when reporting failures, or null if none

Return Value

The outcome of the action

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testLogWriter or action is null
ObjectDisposedException | Thrown if the sandbox was disposed

Remarks

If the action throws an exception or if the test action is aborted, then logs a message to the testLogWriter. Exceptions of type TestException are handled specially since they may modify the effective outcome of the run. If ExcludeStackTrace is true and HasNonDefaultMessage is false then the exception is effectively silent. Therefore the action can modify its outcome and cause messages to be logged by throwing a suitable exception such as TestException or SilentTestException.

If the Abort method is called or has already been called, the action is aborted and the appropriate outcome is returned. The abort is manifested as an asynchronous ThreadAbortException which should cause the action to terminate. It may not terminate immediately, however.

Produces an outcome in the following manner:

  • If the action completed without throwing an exception returns Passed.
  • If the action threw a TestException, returns the value of the Outcome property.
  • If the action threw an different kind of exception, logs the exception and returns Failed.
  • If the action was aborted, returns AbortOutcome.
  • If the action timed out, returns Timeout.

See Also

Sandbox Class
Gallio.Framework Namespace


UseTimeout Method

Sandbox.UseTimeout Method
[image]

Uses a specified timeout for all actions run within a block of code.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub UseTimeout( _
ByVal timeout As Nullable(Of TimeSpan), _
ByVal action As Action _
)
C#
public void UseTimeout(
Nullable<TimeSpan> timeout,
Action action
)
C++
public:
void UseTimeout(
Nullable<TimeSpan> timeout,
Action action
) sealed
J#
public void UseTimeout(
Nullable<TimeSpan> timeout,
Action action
)
JScript
public function UseTimeout(
timeout : Nullable<TimeSpan>,
action : Action
)

Parameters

timeout
The execution timeout or null if none
action
The action to perform, protected by the timeout

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed
ArgumentOutOfRangeException | Thrown if timeout is negative
ArgumentNullException | Thrown if action is null

See Also

Sandbox Class
Gallio.Framework Namespace


Events

Sandbox Events
[image]

Public Events

 | Name | Description
Public event | Aborted | An event that is dispatched when Abort is called. If the sandbox has already been aborted then the event handler is immediately invoked.
Top

See Also

Sandbox Class
Gallio.Framework Namespace


Aborted Event

Sandbox.Aborted Event
[image]

An event that is dispatched when Abort is called.

If the sandbox has already been aborted then the event handler is immediately invoked.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Aborted As EventHandler
C#
public event EventHandler Aborted
C++
public:
virtual event EventHandler Aborted {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Aborted(EventHandler value);

/** event */
public final void remove_Aborted(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the sandbox was disposed

See Also

Sandbox Class
Gallio.Framework Namespace


SilentTestException Class

SilentTestException Class
See Also Example Members
[image]

This exception type is used to signal a test outcome silently without logging the exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class SilentTestException
Inherits TestTerminatedException
C#
[SerializableAttribute]
public class SilentTestException : TestTerminatedException
C++
[SerializableAttribute]
ref class SilentTestException : TestTerminatedException
J#
/** @attribute SerializableAttribute() */
public class SilentTestException extends TestTerminatedException
JScript
public
SerializableAttribute
class SilentTestException extends TestTerminatedException

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestTerminatedException
Gallio.Framework.SilentTestException

See Also

SilentTestException Members
Gallio.Framework Namespace


SilentTestException Members

SilentTestException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

This exception type is used to signal a test outcome silently without logging the exception.

The following tables list the members exposed by SilentTestException.

Public Constructors

Name | Description
SilentTestException | Overloaded.
Top

Protected Constructors

Name | Description
SilentTestException | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Overridden. Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Gets the outcome of the test. (inherited from TestTerminatedException)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from TestTerminatedException)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SilentTestException | Overloaded.
Top

See Also

SilentTestException Class
Gallio.Framework Namespace


SilentTestException Constructor

SilentTestException Constructor

Overload List

 | Name | Description
Public method | SilentTestException (TestOutcome) | Creates a silent test exception with the specified outcome.
Public method | SilentTestException (TestOutcome, String) | Creates a silent test exception with the specified outcome.
Family method | SilentTestException (SerializationInfo, StreamingContext) | Creates a exception from serialization info.

See Also

SilentTestException Class
Gallio.Framework Namespace


SilentTestException Constructor (TestOutcome)

SilentTestException Constructor (TestOutcome)
See Also Example
[image]

Creates a silent test exception with the specified outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal outcome As TestOutcome _
)
C#
public SilentTestException(
TestOutcome outcome
)
C++
public:
SilentTestException(
TestOutcome outcome
) sealed
J#
public SilentTestException(
TestOutcome outcome
)
JScript
public function SilentTestException(
outcome : TestOutcome
)

Parameters

outcome
The test outcome

See Also

SilentTestException Class
Gallio.Framework Namespace
SilentTestException Constructor Overload List


SilentTestException Constructor (TestOutcome, String)

SilentTestException Constructor (TestOutcome, String)
See Also Example
[image]

Creates a silent test exception with the specified outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal outcome As TestOutcome, _
ByVal message As String _
)
C#
public SilentTestException(
TestOutcome outcome,
string message
)
C++
public:
SilentTestException(
TestOutcome outcome,
String message
) sealed
J#
public SilentTestException(
TestOutcome outcome,
string message
)
JScript
public function SilentTestException(
outcome : TestOutcome,
message : String
)

Parameters

outcome
The test outcome
message
The message, or null if none

See Also

SilentTestException Class
Gallio.Framework Namespace
SilentTestException Constructor Overload List


SilentTestException Constructor (SerializationInfo, StreamingContext)

SilentTestException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates a exception from serialization info.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected SilentTestException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
SilentTestException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected SilentTestException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function SilentTestException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

SilentTestException Class
Gallio.Framework Namespace
SilentTestException Constructor Overload List


Properties

SilentTestException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Overridden. Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Gets the outcome of the test. (inherited from TestTerminatedException)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

SilentTestException Class
Gallio.Framework Namespace


ExcludeStackTrace Property

SilentTestException.ExcludeStackTrace Property
[image]

Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ExcludeStackTrace As Boolean
C#
public override bool ExcludeStackTrace { get; }
C++
public override property bool ExcludeStackTrace override {
bool get();
}
J#
/** property */
public bool get_ExcludeStackTrace();
JScript
public function get ExcludeStackTrace() : bool

See Also

SilentTestException Class
Gallio.Framework Namespace


Tasks Class

Tasks Class
See Also Example Members
[image]

The tasks class provides a mechanism for coordinating the actions of multiple tasks within a test case.

Each task started by a test case is monitored. When the test exits, any remaining tasks are automatically aborted and disposed.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module Tasks
C#
public static class Tasks
C++
ref class Tasks abstract sealed
J#
public final class Tasks
JScript
public class Tasks

Inheritance Hierarchy

System.Object
Gallio.Framework.Tasks

See Also

Tasks Members
Gallio.Framework Namespace


Tasks Members

Tasks Members
See Also Example Properties Methods
[image]

The tasks class provides a mechanism for coordinating the actions of multiple tasks within a test case.

Each task started by a test case is monitored. When the test exits, any remaining tasks are automatically aborted and disposed.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Tasks.

Public Properties

Name | Description
TaskContainer | Gets the task container for the current TestContext.
Top

Public Methods

Name | Description
CreateProcessTask | Creates a new process task but does not start it. The output of the process will be logged and included as part of the test results. It may also be examined using the ConsoleOutput and ConsoleError properties while the process executes and after it terminates.
CreateThreadTask | Creates a new thread task but does not start it.
JoinAndVerify | Waits for all tasks to complete or for timeout to occur. Then verifies that no failures have occurred in any of the tasks.
StartProcessTask | Starts a new process and begins watching it. The output of the process will be logged and included as part of the test results. It may also be examined using the ConsoleOutput and ConsoleError properties while the process executes and after it terminates.
StartThreadTask | Starts a new thread task.
Verify | Verifies that no failures have occurred in any of the tasks.
WatchTask | Adds a new task for the task manager to watch.
Top

See Also

Tasks Class
Gallio.Framework Namespace


Properties

Tasks Properties
[image]

Public Properties

Name | Description
TaskContainer | Gets the task container for the current TestContext.
Top

See Also

Tasks Class
Gallio.Framework Namespace


TaskContainer Property

Tasks.TaskContainer Property
[image]

Gets the task container for the current TestContext.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TaskContainer As TaskContainer
C#
public static TaskContainer TaskContainer { get; }
C++
public static property TaskContainer TaskContainer {
TaskContainer get();
}
J#
/** property */
public TaskContainer get_TaskContainer();
JScript
public function get TaskContainer() : TaskContainer

See Also

Tasks Class
Gallio.Framework Namespace


Methods

Tasks Methods
[image]

Public Methods

Name | Description
CreateProcessTask | Creates a new process task but does not start it. The output of the process will be logged and included as part of the test results. It may also be examined using the ConsoleOutput and ConsoleError properties while the process executes and after it terminates.
CreateThreadTask | Creates a new thread task but does not start it.
JoinAndVerify | Waits for all tasks to complete or for timeout to occur. Then verifies that no failures have occurred in any of the tasks.
StartProcessTask | Starts a new process and begins watching it. The output of the process will be logged and included as part of the test results. It may also be examined using the ConsoleOutput and ConsoleError properties while the process executes and after it terminates.
StartThreadTask | Starts a new thread task.
Verify | Verifies that no failures have occurred in any of the tasks.
WatchTask | Adds a new task for the task manager to watch.
Top

See Also

Tasks Class
Gallio.Framework Namespace


CreateProcessTask Method

Tasks.CreateProcessTask Method
[image]

Creates a new process task but does not start it.

The output of the process will be logged and included as part of the test results. It may also be examined using the ConsoleOutput and ConsoleError properties while the process executes and after it terminates.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateProcessTask( _
ByVal executablePath As String, _
ByVal arguments As String, _
ByVal workingDirectory As String _
) As ProcessTask
C#
public static ProcessTask CreateProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
C++
public:
static ProcessTask CreateProcessTask(
String executablePath,
String arguments,
String workingDirectory
)
J#
public static ProcessTask CreateProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
JScript
public static function CreateProcessTask(
executablePath : String,
arguments : String,
workingDirectory : String
) : ProcessTask

Parameters

executablePath
The path of the executable executable
arguments
The arguments for the executable
workingDirectory
The working directory

Return Value

The new thread task

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if executablePath, arguments or workingDirectory is null

Remarks

There is no need to call WatchTask on the returned task.

See Also

Tasks Class
Gallio.Framework Namespace


CreateThreadTask Method

Tasks.CreateThreadTask Method
[image]

Creates a new thread task but does not start it.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateThreadTask( _
ByVal name As String, _
ByVal action As Action _
) As ThreadTask
C#
public static ThreadTask CreateThreadTask(
string name,
Action action
)
C++
public:
static ThreadTask CreateThreadTask(
String name,
Action action
)
J#
public static ThreadTask CreateThreadTask(
string name,
Action action
)
JScript
public static function CreateThreadTask(
name : String,
action : Action
) : ThreadTask

Parameters

name
The name of the task, or null to create a new name based on the method associated with the action
action
The action to perform

Return Value

The new thread task

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

There is no need to call WatchTask on the returned task.

See Also

Tasks Class
Gallio.Framework Namespace


JoinAndVerify Method

Tasks.JoinAndVerify Method
[image]

Waits for all tasks to complete or for timeout to occur. Then verifies that no failures have occurred in any of the tasks.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub JoinAndVerify( _
ByVal timeout As TimeSpan _
)
C#
public static void JoinAndVerify(
TimeSpan timeout
)
C++
public:
static void JoinAndVerify(
TimeSpan timeout
)
J#
public static void JoinAndVerify(
TimeSpan timeout
)
JScript
public static function JoinAndVerify(
timeout : TimeSpan
)

Parameters

timeout
The timeout

Exceptions

Exception Type | Condition
TestException | Thrown if some of the tasks did not complete or if any of the tasks failed

See Also

Tasks Class
Gallio.Framework Namespace


StartProcessTask Method

Tasks.StartProcessTask Method
[image]

Starts a new process and begins watching it.

The output of the process will be logged and included as part of the test results. It may also be examined using the ConsoleOutput and ConsoleError properties while the process executes and after it terminates.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function StartProcessTask( _
ByVal executablePath As String, _
ByVal arguments As String, _
ByVal workingDirectory As String _
) As ProcessTask
C#
public static ProcessTask StartProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
C++
public:
static ProcessTask StartProcessTask(
String executablePath,
String arguments,
String workingDirectory
)
J#
public static ProcessTask StartProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
JScript
public static function StartProcessTask(
executablePath : String,
arguments : String,
workingDirectory : String
) : ProcessTask

Parameters

executablePath
The path of the executable executable
arguments
The arguments for the executable
workingDirectory
The working directory

Return Value

The new thread task

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if executablePath, arguments or workingDirectory is null

Remarks

There is no need to call WatchTask on the returned task.

See Also

Tasks Class
Gallio.Framework Namespace


StartThreadTask Method

Tasks.StartThreadTask Method
[image]

Starts a new thread task.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function StartThreadTask( _
ByVal name As String, _
ByVal action As Action _
) As ThreadTask
C#
public static ThreadTask StartThreadTask(
string name,
Action action
)
C++
public:
static ThreadTask StartThreadTask(
String name,
Action action
)
J#
public static ThreadTask StartThreadTask(
string name,
Action action
)
JScript
public static function StartThreadTask(
name : String,
action : Action
) : ThreadTask

Parameters

name
The name of the task, or null to create a new name based on the method associated with the action
action
The action to perform

Return Value

The new thread task

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

There is no need to call WatchTask on the returned task.

See Also

Tasks Class
Gallio.Framework Namespace


Verify Method

Tasks.Verify Method
[image]

Verifies that no failures have occurred in any of the tasks.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Verify()
C#
public static void Verify()
C++
public:
static void Verify()
J#
public static void Verify()
JScript
public static function Verify()

Exceptions

Exception Type | Condition
TestException | Thrown if any of the tasks failed

See Also

Tasks Class
Gallio.Framework Namespace


WatchTask Method

Tasks.WatchTask Method
[image]

Adds a new task for the task manager to watch.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WatchTask( _
ByVal task As Task _
)
C#
public static void WatchTask(
Task task
)
C++
public:
static void WatchTask(
Task task
)
J#
public static void WatchTask(
Task task
)
JScript
public static function WatchTask(
task : Task
)

Parameters

task
The task to watch

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if task is null

See Also

Tasks Class
Gallio.Framework Namespace


TestContext Class

TestContext Class
See Also Example Members
[image]

The test context provides information about the environment in which a test is executing. A new context is created each time a test or test step begins execution.

Test contexts are arranged in a hierarchy that corresponds to the order in which the contexts were entered. Thus the context for a test likely has as its parent the context for its containing test fixture.

Arbitrary user data can be associated with a test context. Furthermore, client code may attach Finishing event handlers to perform resource reclamation just prior to marking the test step as finished.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public NotInheritable Class TestContext
C#
[TestFrameworkInternalAttribute]
public sealed class TestContext
C++
[TestFrameworkInternalAttribute]
ref class TestContext sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public final class TestContext
JScript
public
TestFrameworkInternalAttribute
final class TestContext

Inheritance Hierarchy

System.Object
Gallio.Framework.TestContext

See Also

TestContext Members
Gallio.Framework Namespace
TestStep


TestContext Members

TestContext Members
See Also Example Properties Methods Events
[image]

The test context provides information about the environment in which a test is executing. A new context is created each time a test or test step begins execution.

Test contexts are arranged in a hierarchy that corresponds to the order in which the contexts were entered. Thus the context for a test likely has as its parent the context for its containing test fixture.

Arbitrary user data can be associated with a test context. Furthermore, client code may attach Finishing event handlers to perform resource reclamation just prior to marking the test step as finished.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestContext.

Public Properties

 | Name | Description
Public property | AssertCount | Gets the current assertion count.
 | CurrentContext | Gets the context of the current thread, or null if there is no current context.
Public property | Data | Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.
 | GlobalContext | Gets the global context of the environment, or null if there is no such context.
Public property | IsFinished | Returns true if the step associated with the context has finished execution and completed all Finishing actions.
Public property | LifecyclePhase | Gets or sets the lifecycle phase the context is in.
Public property | LogWriter | Gets the log writer for this context. Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.
Public property | Outcome | Gets the step's outcome or its interim outcome if the test is still running. The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.
Public property | Parent | Gets the parent context or null if this context has no parent.
Public property | Sandbox | Gets the sandbox of the test step, or null if none.
Public property | Test | Gets the test associated with the context.
Public property | TestStep | Gets the test step associated with the context.
Top

Public Methods

 | Name | Description
Public method | AddAssertCount | Adds the specified amount to the assert count atomically.
Public method | AddMetadata | Adds metadata to the step that is running in the context.
Public method | Enter | Enters this context with the current thread.
 | EnterContext | Enters the specified context with the current thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetThreadDefaultContext | Gets the default context for the specified thread.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IncrementAssertCount | Increments the assert count atomically.
Public method | RunStep | Performs an action as a new step within the current context and associates it with the specified code reference. Does not verify the outcome of the step.
Public method | RunStepAndVerifyOutcome | Performs an action as a new step within the current context and associates it with the specified code reference. Verifies that the step produced the expected outcome.
Public method | SetInterimOutcome | Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.
 | SetThreadDefaultContext | Sets the default context for the specified thread.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | Finishing | The Finishing event is raised when the test is finishing to provide clients with an opportunity to perform additional clean up tasks after all ordinary test processing is finished.
Top

See Also

TestContext Class
Gallio.Framework Namespace
TestStep


Properties

TestContext Properties
[image]

Public Properties

 | Name | Description
Public property | AssertCount | Gets the current assertion count.
 | CurrentContext | Gets the context of the current thread, or null if there is no current context.
Public property | Data | Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.
 | GlobalContext | Gets the global context of the environment, or null if there is no such context.
Public property | IsFinished | Returns true if the step associated with the context has finished execution and completed all Finishing actions.
Public property | LifecyclePhase | Gets or sets the lifecycle phase the context is in.
Public property | LogWriter | Gets the log writer for this context. Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.
Public property | Outcome | Gets the step's outcome or its interim outcome if the test is still running. The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.
Public property | Parent | Gets the parent context or null if this context has no parent.
Public property | Sandbox | Gets the sandbox of the test step, or null if none.
Public property | Test | Gets the test associated with the context.
Public property | TestStep | Gets the test step associated with the context.
Top

See Also

TestContext Class
Gallio.Framework Namespace
TestStep


AssertCount Property

TestContext.AssertCount Property
[image]

Gets the current assertion count.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssertCount As Integer
C#
public int AssertCount { get; }
C++
public property int AssertCount sealed {
int get();
}
J#
/** property */
public int get_AssertCount();
JScript
public function get AssertCount() : int

See Also

TestContext Class
Gallio.Framework Namespace


CurrentContext Property

TestContext.CurrentContext Property
[image]

Gets the context of the current thread, or null if there is no current context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CurrentContext As TestContext
C#
public static TestContext CurrentContext { get; }
C++
public static property TestContext CurrentContext {
TestContext get();
}
J#
/** property */
public TestContext get_CurrentContext();
JScript
public function get CurrentContext() : TestContext

See Also

TestContext Class
Gallio.Framework Namespace


Data Property

TestContext.Data Property
[image]

Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As UserDataCollection
C#
public UserDataCollection Data { get; }
C++
public property UserDataCollection Data sealed {
UserDataCollection get();
}
J#
/** property */
public UserDataCollection get_Data();
JScript
public function get Data() : UserDataCollection

Remarks

Each context has its own distinct user data collection.

See Also

TestContext Class
Gallio.Framework Namespace


GlobalContext Property

TestContext.GlobalContext Property
[image]

Gets the global context of the environment, or null if there is no such context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property GlobalContext As TestContext
C#
public static TestContext GlobalContext { get; }
C++
public static property TestContext GlobalContext {
TestContext get();
}
J#
/** property */
public TestContext get_GlobalContext();
JScript
public function get GlobalContext() : TestContext

See Also

TestContext Class
Gallio.Framework Namespace


IsFinished Property

TestContext.IsFinished Property
[image]

Returns true if the step associated with the context has finished execution and completed all Finishing actions.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFinished As Boolean
C#
public bool IsFinished { get; }
C++
public property bool IsFinished sealed {
bool get();
}
J#
/** property */
public bool get_IsFinished();
JScript
public function get IsFinished() : bool

See Also

TestContext Class
Gallio.Framework Namespace


LifecyclePhase Property

TestContext.LifecyclePhase Property
[image]

Gets or sets the lifecycle phase the context is in.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property LifecyclePhase As String
C#
public string LifecyclePhase { get; set; }
C++
public property string LifecyclePhase sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LifecyclePhase();

/** property */
public void set_LifecyclePhase(string value);
JScript
public function get LifecyclePhase() : String

public function set LifecyclePhase(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestContext Class
Gallio.Framework Namespace
LifecyclePhases


LogWriter Property

TestContext.LogWriter Property
[image]

Gets the log writer for this context.

Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LogWriter As TestLogWriter
C#
public TestLogWriter LogWriter { get; }
C++
public property TestLogWriter LogWriter sealed {
TestLogWriter get();
}
J#
/** property */
public TestLogWriter get_LogWriter();
JScript
public function get LogWriter() : TestLogWriter

See Also

TestContext Class
Gallio.Framework Namespace


Outcome Property

TestContext.Outcome Property
[image]

Gets the step's outcome or its interim outcome if the test is still running.

The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outcome As TestOutcome
C#
public TestOutcome Outcome { get; }
C++
public property TestOutcome Outcome sealed {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

Remarks

For example, this property enables code running as part of the tear down phase to determine whether the test is failing and to perform different actions in that case.

See Also

TestContext Class
Gallio.Framework Namespace
SetInterimOutcome


Parent Property

TestContext.Parent Property
[image]

Gets the parent context or null if this context has no parent.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As TestContext
C#
public TestContext Parent { get; }
C++
public property TestContext Parent sealed {
TestContext get();
}
J#
/** property */
public TestContext get_Parent();
JScript
public function get Parent() : TestContext

See Also

TestContext Class
Gallio.Framework Namespace


Sandbox Property

TestContext.Sandbox Property
[image]

Gets the sandbox of the test step, or null if none.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sandbox As Sandbox
C#
public Sandbox Sandbox { get; }
C++
public property Sandbox Sandbox sealed {
Sandbox get();
}
J#
/** property */
public Sandbox get_Sandbox();
JScript
public function get Sandbox() : Sandbox

Remarks

The value will typically only be null in the case where the test step belongs to a different test framework that does not use sandboxes.

See Also

TestContext Class
Gallio.Framework Namespace


Test Property

TestContext.Test Property
[image]

Gets the test associated with the context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As TestInfo
C#
public TestInfo Test { get; }
C++
public property TestInfo Test sealed {
TestInfo get();
}
J#
/** property */
public TestInfo get_Test();
JScript
public function get Test() : TestInfo

See Also

TestContext Class
Gallio.Framework Namespace


TestStep Property

TestContext.TestStep Property
[image]

Gets the test step associated with the context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestStep As TestStepInfo
C#
public TestStepInfo TestStep { get; }
C++
public property TestStepInfo TestStep sealed {
TestStepInfo get();
}
J#
/** property */
public TestStepInfo get_TestStep();
JScript
public function get TestStep() : TestStepInfo

See Also

TestContext Class
Gallio.Framework Namespace


Methods

TestContext Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssertCount | Adds the specified amount to the assert count atomically.
Public method | AddMetadata | Adds metadata to the step that is running in the context.
Public method | Enter | Enters this context with the current thread.
 | EnterContext | Enters the specified context with the current thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetThreadDefaultContext | Gets the default context for the specified thread.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IncrementAssertCount | Increments the assert count atomically.
Public method | RunStep | Performs an action as a new step within the current context and associates it with the specified code reference. Does not verify the outcome of the step.
Public method | RunStepAndVerifyOutcome | Performs an action as a new step within the current context and associates it with the specified code reference. Verifies that the step produced the expected outcome.
Public method | SetInterimOutcome | Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.
 | SetThreadDefaultContext | Sets the default context for the specified thread.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestContext Class
Gallio.Framework Namespace
TestStep


AddAssertCount Method

TestContext.AddAssertCount Method
[image]

Adds the specified amount to the assert count atomically.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssertCount( _
ByVal value As Integer _
)
C#
public void AddAssertCount(
int value
)
C++
public:
void AddAssertCount(
int value
) sealed
J#
public void AddAssertCount(
int value
)
JScript
public function AddAssertCount(
value : int
)

Parameters

value
The amount to add to the assert count

See Also

TestContext Class
Gallio.Framework Namespace


AddMetadata Method

TestContext.AddMetadata Method
[image]

Adds metadata to the step that is running in the context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMetadata( _
ByVal metadataKey As String, _
ByVal metadataValue As String _
)
C#
public void AddMetadata(
string metadataKey,
string metadataValue
)
C++
public:
void AddMetadata(
String metadataKey,
String metadataValue
) sealed
J#
public void AddMetadata(
string metadataKey,
string metadataValue
)
JScript
public function AddMetadata(
metadataKey : String,
metadataValue : String
)

Parameters

metadataKey
The metadata key
metadataValue
The metadata value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if metadataKey or metadataValue is null

See Also

TestContext Class
Gallio.Framework Namespace


Enter Method

TestContext.Enter Method
[image]

Enters this context with the current thread.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Enter() As TestContextCookie
C#
public TestContextCookie Enter()
C++
public:
TestContextCookie Enter() sealed
J#
public TestContextCookie Enter()
JScript
public function Enter() : TestContextCookie

Return Value

A cookie that can be used to restore the current thread's context to its previous value

Remarks

Conceptually this method pushes this context onto the context stack for the current thread. It then returns a cookie that can be used to restore the current thread's context to its previous value.

See Also

TestContext Class
Gallio.Framework Namespace
TestContextCookie


EnterContext Method

TestContext.EnterContext Method
[image]

Enters the specified context with the current thread.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EnterContext( _
ByVal context As TestContext _
) As TestContextCookie
C#
public static TestContextCookie EnterContext(
TestContext context
)
C++
public:
static TestContextCookie EnterContext(
TestContext context
)
J#
public static TestContextCookie EnterContext(
TestContext context
)
JScript
public static function EnterContext(
context : TestContext
) : TestContextCookie

Parameters

context
The context to enter, or null to enter a scope without a context

Return Value

A cookie that can be used to restore the current thread's context to its previous value

Remarks

Conceptually this method pushes the specified context onto the context stack for the current thread. It then returns a cookie that can be used to restore the current thread's context to its previous value.

See Also

TestContext Class
Gallio.Framework Namespace
TestContextCookie


GetThreadDefaultContext Method

TestContext.GetThreadDefaultContext Method
[image]

Gets the default context for the specified thread.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetThreadDefaultContext( _
ByVal thread As Thread _
) As TestContext
C#
public static TestContext GetThreadDefaultContext(
Thread thread
)
C++
public:
static TestContext GetThreadDefaultContext(
Thread thread
)
J#
public static TestContext GetThreadDefaultContext(
Thread thread
)
JScript
public static function GetThreadDefaultContext(
thread : Thread
) : TestContext

Parameters

thread
The thread

Return Value

The default context

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if thread is null

Remarks

The default context for a thread is GlobalContext unless the thread's default context has been overridden with SetThreadDefaultContext.

Changing the default context of a thread is useful for capturing existing threads created outside of a test into a particular context. Among other things, this ensures that side-effects of the thread, such as writing text to the console, are recorded as part of the step represented by the specified context.

See Also

TestContext Class
Gallio.Framework Namespace


IncrementAssertCount Method

TestContext.IncrementAssertCount Method
[image]

Increments the assert count atomically.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub IncrementAssertCount()
C#
public void IncrementAssertCount()
C++
public:
void IncrementAssertCount() sealed
J#
public void IncrementAssertCount()
JScript
public function IncrementAssertCount()

See Also

TestContext Class
Gallio.Framework Namespace


RunStep Method

TestContext.RunStep Method
[image]

Performs an action as a new step within the current context and associates it with the specified code reference. Does not verify the outcome of the step.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function RunStep( _
ByVal name As String, _
ByVal action As Action, _
ByVal timeout As Nullable(Of TimeSpan), _
ByVal isTestCase As Boolean, _
ByVal codeElement As ICodeElementInfo _
) As TestContext
C#
public TestContext RunStep(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement
)
C++
public:
TestContext RunStep(
String name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement
) sealed
J#
public TestContext RunStep(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement
)
JScript
public function RunStep(
name : String,
action : Action,
timeout : Nullable<TimeSpan>,
isTestCase : bool,
codeElement : ICodeElementInfo
) : TestContext

Parameters

name
The name of the step
action
The action to perform
timeout
The step execution timeout, or null if none
isTestCase
True if the step represents an independent test case
codeElement
The associated code element, or null if none

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
ArgumentOutOfRangeException | Thrown if timeout is negative

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method does not verify that the test step completed successfully. Check the Outcome of the test step or call RunStepAndVerifyOutcome to ensure that the expected outcome was obtained.

See Also

TestContext Class
Gallio.Framework Namespace


RunStepAndVerifyOutcome Method

TestContext.RunStepAndVerifyOutcome Method
[image]

Performs an action as a new step within the current context and associates it with the specified code reference. Verifies that the step produced the expected outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function RunStepAndVerifyOutcome( _
ByVal name As String, _
ByVal action As Action, _
ByVal timeout As Nullable(Of TimeSpan), _
ByVal isTestCase As Boolean, _
ByVal codeElement As ICodeElementInfo, _
ByVal expectedOutcome As TestOutcome _
) As TestContext
C#
public TestContext RunStepAndVerifyOutcome(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement,
TestOutcome expectedOutcome
)
C++
public:
TestContext RunStepAndVerifyOutcome(
String name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement,
TestOutcome expectedOutcome
) sealed
J#
public TestContext RunStepAndVerifyOutcome(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement,
TestOutcome expectedOutcome
)
JScript
public function RunStepAndVerifyOutcome(
name : String,
action : Action,
timeout : Nullable<TimeSpan>,
isTestCase : bool,
codeElement : ICodeElementInfo,
expectedOutcome : TestOutcome
) : TestContext

Parameters

name
The name of the step
action
The action to perform
timeout
The step execution timeout, or null if none
isTestCase
True if the step represents an independent test case
codeElement
The associated code element, or null if none
expectedOutcome
The expected outcome of the step

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
ArgumentOutOfRangeException | Thrown if timeout is negative
AssertionFailureException | Thrown if the expected outcome was not obtained

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method verifies that the step produced the expected outcome. If a different outcome was obtained, then raises an assertion failure.

See Also

TestContext Class
Gallio.Framework Namespace


SetInterimOutcome Method

TestContext.SetInterimOutcome Method
[image]

Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetInterimOutcome( _
ByVal outcome As TestOutcome _
)
C#
public void SetInterimOutcome(
TestOutcome outcome
)
C++
public:
void SetInterimOutcome(
TestOutcome outcome
) sealed
J#
public void SetInterimOutcome(
TestOutcome outcome
)
JScript
public function SetInterimOutcome(
outcome : TestOutcome
)

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if attempting to set the outcome while the test is not running

Remarks

The value set here will be overridden by whatever final outcome the step returns. Consequently the actual outcome may still differ from the anticipated outcome that was set using this method.

See Also

TestContext Class
Gallio.Framework Namespace
Outcome


SetThreadDefaultContext Method

TestContext.SetThreadDefaultContext Method
[image]

Sets the default context for the specified thread.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetThreadDefaultContext( _
ByVal thread As Thread, _
ByVal context As TestContext _
)
C#
public static void SetThreadDefaultContext(
Thread thread,
TestContext context
)
C++
public:
static void SetThreadDefaultContext(
Thread thread,
TestContext context
)
J#
public static void SetThreadDefaultContext(
Thread thread,
TestContext context
)
JScript
public static function SetThreadDefaultContext(
thread : Thread,
context : TestContext
)

Parameters

thread
The thread
context
The context to associate with the thread, or null to reset the thread's default context to inherit the GlobalContext once again

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if thread is null

Remarks

The default context for a thread is GlobalContext unless the thread's default context has been overridden with SetThreadDefaultContext.

Changing the default context of a thread is useful for capturing existing threads created outside of a test into a particular context. Among other things, this ensures that side-effects of the thread, such as writing text to the console, are recorded as part of the step represented by the specified context.

See Also

TestContext Class
Gallio.Framework Namespace


Events

TestContext Events
[image]

Public Events

 | Name | Description
Public event | Finishing | The Finishing event is raised when the test is finishing to provide clients with an opportunity to perform additional clean up tasks after all ordinary test processing is finished.
Top

See Also

TestContext Class
Gallio.Framework Namespace
TestStep


Finishing Event

TestContext.Finishing Event
[image]

The Finishing event is raised when the test is finishing to provide clients with an opportunity to perform additional clean up tasks after all ordinary test processing is finished.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Finishing As EventHandler
C#
public event EventHandler Finishing
C++
public:
virtual event EventHandler Finishing {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Finishing(EventHandler value);

/** event */
public final void remove_Finishing(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

TestContext Class
Gallio.Framework Namespace


TestContextCookie Structure

TestContextCookie Structure
See Also Example Members
[image]

A context cookie is used to unwind the context stack of the current thread to its previous state prior to a context having been entered.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure TestContextCookie
Implements IDisposable
C#
public struct TestContextCookie : IDisposable
C++
value class TestContextCookie : IDisposable
J#
public final class TestContextCookie extends ValueType implements IDisposable
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Framework.TestContextCookie

See Also

TestContextCookie Members
Gallio.Framework Namespace


TestContextCookie Members

TestContextCookie Members
See Also Example Methods
[image]

A context cookie is used to unwind the context stack of the current thread to its previous state prior to a context having been entered.

The following tables list the members exposed by TestContextCookie.

Public Methods

 | Name | Description
Public method | Dispose | Exits the context that was entered when the cookie was granted. Equivalent to calling ExitContext. This method is provded as a convenience for use with the C# using statement.
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | ExitContext | Exits the context that was entered when the cookie was granted.
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

TestContextCookie Structure
Gallio.Framework Namespace


Methods

TestContextCookie Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Exits the context that was entered when the cookie was granted. Equivalent to calling ExitContext. This method is provded as a convenience for use with the C# using statement.
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | ExitContext | Exits the context that was entered when the cookie was granted.
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

TestContextCookie Structure
Gallio.Framework Namespace


Dispose Method

TestContextCookie.Dispose Method
[image]

Exits the context that was entered when the cookie was granted.

Equivalent to calling ExitContext. This method is provded as a convenience for use with the C# using statement.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the cookie belongs to a different Thread or if the context was already exited
ObjectDisposedException | Thrown if the context manager has been disposed

Remarks

This method will also exit nested contexts on the current thread that were entered after the context for which this cookie was produced but have not yet been exited.

See Also

TestContextCookie Structure
Gallio.Framework Namespace


ExitContext Method

TestContextCookie.ExitContext Method
[image]

Exits the context that was entered when the cookie was granted.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExitContext()
C#
public void ExitContext()
C++
public:
void ExitContext() sealed
J#
public void ExitContext()
JScript
public function ExitContext()

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the cookie belongs to a different Thread or if the context was already exited
ObjectDisposedException | Thrown if the context manager has been disposed

Remarks

This method will also exit nested contexts on the current thread that were entered after the context for which this cookie was produced but have not yet been exited.

See Also

TestContextCookie Structure
Gallio.Framework Namespace


TestException Class

TestException Class
See Also Example Members
[image]

This exception type is an abstract base class for exceptions that are used to explicitly signal the outcome of a test.

The test framework uses the value of the Outcome property to set the test result instead of applying the standard behavior for unexpected exceptions.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class TestException
Inherits Exception
C#
[SerializableAttribute]
public abstract class TestException : Exception
C++
[SerializableAttribute]
ref class TestException abstract : Exception
J#
/** @attribute SerializableAttribute() */
public class TestException extends Exception
JScript
public
SerializableAttribute
class TestException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestFailedException
Gallio.Framework.TestInconclusiveException
Gallio.Framework.TestTerminatedException

See Also

TestException Members
Gallio.Framework Namespace


TestException Members

TestException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

This exception type is an abstract base class for exceptions that are used to explicitly signal the outcome of a test.

The test framework uses the value of the Outcome property to set the test result instead of applying the standard behavior for unexpected exceptions.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestException.

Protected Constructors

Name | Description
TestException | Overloaded. Initializes a new instance of the TestException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Gets the outcome of the test.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestException | Overloaded. Initializes a new instance of the TestException class.
Top

See Also

TestException Class
Gallio.Framework Namespace


TestException Constructor

TestException Constructor

Initializes a new instance of the TestException class.

Overload List

 | Name | Description
Family method | TestException | Creates an exception.
Family method | TestException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Family method | TestException (String) | Creates an exception.
Family method | TestException (String, Exception) | Creates an exception.

See Also

TestException Class
Gallio.Framework Namespace


TestException Constructor ()

TestException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestException()
C++
protected:
TestException() sealed
J#
protected TestException()
JScript
protected function TestException()

See Also

TestException Class
Gallio.Framework Namespace
TestException Constructor Overload List


TestException Constructor (SerializationInfo, StreamingContext)

TestException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected TestException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
TestException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected TestException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function TestException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

TestException Class
Gallio.Framework Namespace
TestException Constructor Overload List


TestException Constructor (String)

TestException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal message As String _
)
C#
protected TestException(
string message
)
C++
protected:
TestException(
String message
) sealed
J#
protected TestException(
string message
)
JScript
protected function TestException(
message : String
)

Parameters

message
The message

See Also

TestException Class
Gallio.Framework Namespace
TestException Constructor Overload List


TestException Constructor (String, Exception)

TestException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
protected TestException(
string message,
Exception innerException
)
C++
protected:
TestException(
String message,
Exception innerException
) sealed
J#
protected TestException(
string message,
Exception innerException
)
JScript
protected function TestException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

TestException Class
Gallio.Framework Namespace
TestException Constructor Overload List


Properties

TestException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments).
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Gets the outcome of the test.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

TestException Class
Gallio.Framework Namespace


ExcludeStackTrace Property

TestException.ExcludeStackTrace Property
[image]

Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ExcludeStackTrace As Boolean
C#
public virtual bool ExcludeStackTrace { get; }
C++
public virtual property bool ExcludeStackTrace {
bool get();
}
J#
/** property */
public bool get_ExcludeStackTrace();
JScript
public function get ExcludeStackTrace() : bool

See Also

TestException Class
Gallio.Framework Namespace


HasNonDefaultMessage Property

TestException.HasNonDefaultMessage Property
[image]

Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments).

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property HasNonDefaultMessage As Boolean
Get
Protected Set
End Property
C#
public bool HasNonDefaultMessage { get; protected set; }
C++
public property bool HasNonDefaultMessage sealed {
public:
bool get();
protected:
void set(bool value);
}
J#
/** property */
public bool get_HasNonDefaultMessage();

/** property */
protected void set_HasNonDefaultMessage(bool value);
JScript
public function get HasNonDefaultMessage() : bool

protected function set HasNonDefaultMessage(value : bool);

See Also

TestException Class
Gallio.Framework Namespace


Outcome Property

TestException.Outcome Property
[image]

Gets the outcome of the test.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Outcome As TestOutcome
C#
public abstract TestOutcome Outcome { get; }
C++
public abstract property TestOutcome Outcome abstract {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

See Also

TestException Class
Gallio.Framework Namespace


Methods

TestException Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestException Class
Gallio.Framework Namespace


GetObjectData Method

TestException.GetObjectData Method
[image]

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
C++
public:
virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
) override
J#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
JScript
public override function GetObjectData(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable.GetObjectData

See Also

TestException Class
Gallio.Framework Namespace


TestFailedException Class

TestFailedException Class
See Also Example Members
[image]

This exception type is used to signal that a test has failed to satisfy some predetermined condition established by the test author.

For example, an assertion failure may be signaled using a TestFailedException to distinguish it from other application or runtime errors that a test might encounter at runtime.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class TestFailedException
Inherits TestException
C#
[SerializableAttribute]
public class TestFailedException : TestException
C++
[SerializableAttribute]
ref class TestFailedException : TestException
J#
/** @attribute SerializableAttribute() */
public class TestFailedException extends TestException
JScript
public
SerializableAttribute
class TestFailedException extends TestException

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestFailedException
Gallio.Framework.Assertions.AssertionException

See Also

TestFailedException Members
Gallio.Framework Namespace


TestFailedException Members

TestFailedException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

This exception type is used to signal that a test has failed to satisfy some predetermined condition established by the test author.

For example, an assertion failure may be signaled using a TestFailedException to distinguish it from other application or runtime errors that a test might encounter at runtime.

The following tables list the members exposed by TestFailedException.

Public Constructors

Name | Description
TestFailedException | Overloaded. Initializes a new instance of the TestFailedException class.
Top

Protected Constructors

Name | Description
TestFailedException | Overloaded. Initializes a new instance of the TestFailedException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Returns Failed.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from TestException)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestFailedException | Overloaded. Initializes a new instance of the TestFailedException class.
Top

See Also

TestFailedException Class
Gallio.Framework Namespace


TestFailedException Constructor

TestFailedException Constructor

Initializes a new instance of the TestFailedException class.

Overload List

 | Name | Description
Public method | TestFailedException | Creates an exception.
Family method | TestFailedException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | TestFailedException (String) | Creates an exception.
Public method | TestFailedException (String, Exception) | Creates an exception.

See Also

TestFailedException Class
Gallio.Framework Namespace


TestFailedException Constructor ()

TestFailedException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestFailedException()
C++
public:
TestFailedException() sealed
J#
public TestFailedException()
JScript
public function TestFailedException()

See Also

TestFailedException Class
Gallio.Framework Namespace
TestFailedException Constructor Overload List


TestFailedException Constructor (SerializationInfo, StreamingContext)

TestFailedException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected TestFailedException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
TestFailedException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected TestFailedException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function TestFailedException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

TestFailedException Class
Gallio.Framework Namespace
TestFailedException Constructor Overload List


TestFailedException Constructor (String)

TestFailedException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public TestFailedException(
string message
)
C++
public:
TestFailedException(
String message
) sealed
J#
public TestFailedException(
string message
)
JScript
public function TestFailedException(
message : String
)

Parameters

message
The message

See Also

TestFailedException Class
Gallio.Framework Namespace
TestFailedException Constructor Overload List


TestFailedException Constructor (String, Exception)

TestFailedException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public TestFailedException(
string message,
Exception innerException
)
C++
public:
TestFailedException(
String message,
Exception innerException
) sealed
J#
public TestFailedException(
string message,
Exception innerException
)
JScript
public function TestFailedException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

TestFailedException Class
Gallio.Framework Namespace
TestFailedException Constructor Overload List


Properties

TestFailedException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Returns Failed.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

TestFailedException Class
Gallio.Framework Namespace


Outcome Property

TestFailedException.Outcome Property
[image]

Returns Failed.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outcome As TestOutcome
C#
public TestOutcome Outcome { get; }
C++
public property TestOutcome Outcome sealed {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

See Also

TestFailedException Class
Gallio.Framework Namespace


TestInconclusiveException Class

TestInconclusiveException Class
See Also Example Members
[image]

This exception type is used to signal that a test has not produced a conclusive pass or fail result. The exception message, if present, should explain the reason no conclusive result was obtained.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class TestInconclusiveException
Inherits TestException
C#
[SerializableAttribute]
public class TestInconclusiveException : TestException
C++
[SerializableAttribute]
ref class TestInconclusiveException : TestException
J#
/** @attribute SerializableAttribute() */
public class TestInconclusiveException extends TestException
JScript
public
SerializableAttribute
class TestInconclusiveException extends TestException

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestInconclusiveException

See Also

TestInconclusiveException Members
Gallio.Framework Namespace


TestInconclusiveException Members

TestInconclusiveException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

This exception type is used to signal that a test has not produced a conclusive pass or fail result. The exception message, if present, should explain the reason no conclusive result was obtained.

The following tables list the members exposed by TestInconclusiveException.

Public Constructors

Name | Description
TestInconclusiveException | Overloaded. Initializes a new instance of the TestInconclusiveException class.
Top

Protected Constructors

Name | Description
TestInconclusiveException | Overloaded. Initializes a new instance of the TestInconclusiveException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Returns Inconclusive.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from TestException)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestInconclusiveException | Overloaded. Initializes a new instance of the TestInconclusiveException class.
Top

See Also

TestInconclusiveException Class
Gallio.Framework Namespace


TestInconclusiveException Constructor

TestInconclusiveException Constructor

Initializes a new instance of the TestInconclusiveException class.

Overload List

 | Name | Description
Public method | TestInconclusiveException | Creates an exception.
Family method | TestInconclusiveException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | TestInconclusiveException (String) | Creates an exception.
Public method | TestInconclusiveException (String, Exception) | Creates an exception.

See Also

TestInconclusiveException Class
Gallio.Framework Namespace


TestInconclusiveException Constructor ()

TestInconclusiveException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestInconclusiveException()
C++
public:
TestInconclusiveException() sealed
J#
public TestInconclusiveException()
JScript
public function TestInconclusiveException()

See Also

TestInconclusiveException Class
Gallio.Framework Namespace
TestInconclusiveException Constructor Overload List


TestInconclusiveException Constructor (SerializationInfo, StreamingContext)

TestInconclusiveException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected TestInconclusiveException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
TestInconclusiveException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected TestInconclusiveException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function TestInconclusiveException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

TestInconclusiveException Class
Gallio.Framework Namespace
TestInconclusiveException Constructor Overload List


TestInconclusiveException Constructor (String)

TestInconclusiveException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public TestInconclusiveException(
string message
)
C++
public:
TestInconclusiveException(
String message
) sealed
J#
public TestInconclusiveException(
string message
)
JScript
public function TestInconclusiveException(
message : String
)

Parameters

message
The message

See Also

TestInconclusiveException Class
Gallio.Framework Namespace
TestInconclusiveException Constructor Overload List


TestInconclusiveException Constructor (String, Exception)

TestInconclusiveException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public TestInconclusiveException(
string message,
Exception innerException
)
C++
public:
TestInconclusiveException(
String message,
Exception innerException
) sealed
J#
public TestInconclusiveException(
string message,
Exception innerException
)
JScript
public function TestInconclusiveException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

TestInconclusiveException Class
Gallio.Framework Namespace
TestInconclusiveException Constructor Overload List


Properties

TestInconclusiveException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Returns Inconclusive.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

TestInconclusiveException Class
Gallio.Framework Namespace


Outcome Property

TestInconclusiveException.Outcome Property
[image]

Returns Inconclusive.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outcome As TestOutcome
C#
public TestOutcome Outcome { get; }
C++
public property TestOutcome Outcome sealed {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

See Also

TestInconclusiveException Class
Gallio.Framework Namespace


TestLog Class

TestLog Class
See Also Example Members
[image]

The test log class provides services for writing information to the execution log associated with a test. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestLog
C#
public static class TestLog
C++
ref class TestLog abstract sealed
J#
public final class TestLog
JScript
public class TestLog

Remarks

A test log records the output of a test during its execution including any text that was written to console output streams, exceptions that occurred, and anything else the test writer might want to save.

A log consists of zero or more log streams that are opened automatically on demand to capture independent sequences of log output. Each stream can further be broken down into possibly nested sections to classify output during different phases of test execution (useful for drilling into complex tests). In addition to text, a log can contain attachments that are either attached at the top level of the log or embedded into log streams. Attachments are typed by mime-type and can contain Text, Xml, Images, Blobs, or any other content. Certain test frameworks may automatically create attachments to gather all manner of diagnostic information over the course of the test.

Test log messages are not echoed to the console or runtime log during test execution, they are incorporated into the test report. Use DiagnosticLog instead if you wish to write messages immediately where the operator can see them.

Inheritance Hierarchy

System.Object
Gallio.Framework.TestLog

See Also

TestLog Members
Gallio.Framework Namespace
DiagnosticLog


TestLog Members

TestLog Members
See Also Example Properties Methods
[image]

The test log class provides services for writing information to the execution log associated with a test. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestLog.

Public Properties

Name | Description
ConsoleError | Gets the current stream writer for the built-in log stream where the Error stream for the test is recorded.
ConsoleInput | Gets the current stream writer for the built-in log stream where the In stream for the test is recorded.
ConsoleOutput | Gets the current stream writer for the built-in log stream where the Out stream for the test is recorded.
DebugTrace | Gets the current stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded.
Default | Gets the current stream writer for the built-in log stream where the output from the convenience methods of the TestLog class is recorded.
Failures | Gets the current stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded.
Warnings | Gets the current stream writer for the built-in log stream where warnings are recorded.
Writer | Gets the current log writer.
Top

Public Methods

Name Description
Attach Attaches an attachment to the execution log.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachHtml Attaches an HTML attachment with mime-type Html.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachImage Attaches an image attachment with a mime-type compatible with its internal representation.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachObjectAsXml Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachPlainText Attaches an plain text attachment with mime-type PlainText.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachXHtml Attaches an XHTML attachment with mime-type XHtml.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachXml Attaches an XML attachment with mime-type Xml.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

BeginMarker

Begins a marked region. Maybe be nested.

A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

BeginSection

Begins a section with the specified name. Maybe be nested.

A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Embed Embeds an attachment.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedExisting Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedHtml Embeds an HTML attachment with mime-type Html.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedImage Embeds an image attachment with a mime-type compatible with its internal representation.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedObjectAsXml Overloaded. Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedPlainText Embeds an plain text attachment with mime-type PlainText.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedXHtml Embeds an XHTML attachment with mime-type XHtml.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedXml Embeds an XML attachment with mime-type Xml.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

End

Ends the region most recently started with one of the Begin* methods.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Flush

Flushes the log writer.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Write Overloaded.

Writes a test log stream writable object to the stream.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteEllipsis

Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteException Overloaded.

Writes an exception.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteHighlighted

Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteLine Overloaded. Writes a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Top

See Also

TestLog Class
Gallio.Framework Namespace
DiagnosticLog


Properties

TestLog Properties
[image]

Public Properties

Name | Description
ConsoleError | Gets the current stream writer for the built-in log stream where the Error stream for the test is recorded.
ConsoleInput | Gets the current stream writer for the built-in log stream where the In stream for the test is recorded.
ConsoleOutput | Gets the current stream writer for the built-in log stream where the Out stream for the test is recorded.
DebugTrace | Gets the current stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded.
Default | Gets the current stream writer for the built-in log stream where the output from the convenience methods of the TestLog class is recorded.
Failures | Gets the current stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded.
Warnings | Gets the current stream writer for the built-in log stream where warnings are recorded.
Writer | Gets the current log writer.
Top

See Also

TestLog Class
Gallio.Framework Namespace
DiagnosticLog


ConsoleError Property

TestLog.ConsoleError Property
[image]

Gets the current stream writer for the built-in log stream where the Error stream for the test is recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ConsoleError As TestLogStreamWriter
C#
public static TestLogStreamWriter ConsoleError { get; }
C++
public static property TestLogStreamWriter ConsoleError {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_ConsoleError();
JScript
public function get ConsoleError() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


ConsoleInput Property

TestLog.ConsoleInput Property
[image]

Gets the current stream writer for the built-in log stream where the In stream for the test is recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ConsoleInput As TestLogStreamWriter
C#
public static TestLogStreamWriter ConsoleInput { get; }
C++
public static property TestLogStreamWriter ConsoleInput {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_ConsoleInput();
JScript
public function get ConsoleInput() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


ConsoleOutput Property

TestLog.ConsoleOutput Property
[image]

Gets the current stream writer for the built-in log stream where the Out stream for the test is recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ConsoleOutput As TestLogStreamWriter
C#
public static TestLogStreamWriter ConsoleOutput { get; }
C++
public static property TestLogStreamWriter ConsoleOutput {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_ConsoleOutput();
JScript
public function get ConsoleOutput() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


DebugTrace Property

TestLog.DebugTrace Property
[image]

Gets the current stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DebugTrace As TestLogStreamWriter
C#
public static TestLogStreamWriter DebugTrace { get; }
C++
public static property TestLogStreamWriter DebugTrace {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_DebugTrace();
JScript
public function get DebugTrace() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


Default Property

TestLog.Default Property
[image]

Gets the current stream writer for the built-in log stream where the output from the convenience methods of the TestLog class is recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Default As TestLogStreamWriter
C#
public static TestLogStreamWriter Default { get; }
C++
public static property TestLogStreamWriter Default {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_Default();
JScript
public function get Default() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


Failures Property

TestLog.Failures Property
[image]

Gets the current stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Failures As TestLogStreamWriter
C#
public static TestLogStreamWriter Failures { get; }
C++
public static property TestLogStreamWriter Failures {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_Failures();
JScript
public function get Failures() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


Warnings Property

TestLog.Warnings Property
[image]

Gets the current stream writer for the built-in log stream where warnings are recorded.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Warnings As TestLogStreamWriter
C#
public static TestLogStreamWriter Warnings { get; }
C++
public static property TestLogStreamWriter Warnings {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_Warnings();
JScript
public function get Warnings() : TestLogStreamWriter

See Also

TestLog Class
Gallio.Framework Namespace


Writer Property

TestLog.Writer Property
[image]

Gets the current log writer.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Writer As TestLogWriter
C#
public static TestLogWriter Writer { get; }
C++
public static property TestLogWriter Writer {
TestLogWriter get();
}
J#
/** property */
public TestLogWriter get_Writer();
JScript
public function get Writer() : TestLogWriter

Property Value

The execution log, never null

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if there is no current log writer

See Also

TestLog Class
Gallio.Framework Namespace


Methods

TestLog Methods
[image]

Public Methods

Name Description
Attach Attaches an attachment to the execution log.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachHtml Attaches an HTML attachment with mime-type Html.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachImage Attaches an image attachment with a mime-type compatible with its internal representation.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachObjectAsXml Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachPlainText Attaches an plain text attachment with mime-type PlainText.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachXHtml Attaches an XHTML attachment with mime-type XHtml.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

AttachXml Attaches an XML attachment with mime-type Xml.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

BeginMarker

Begins a marked region. Maybe be nested.

A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

BeginSection

Begins a section with the specified name. Maybe be nested.

A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Embed Embeds an attachment.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedExisting Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedHtml Embeds an HTML attachment with mime-type Html.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedImage Embeds an image attachment with a mime-type compatible with its internal representation.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedObjectAsXml Overloaded. Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedPlainText Embeds an plain text attachment with mime-type PlainText.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedXHtml Embeds an XHTML attachment with mime-type XHtml.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

EmbedXml Embeds an XML attachment with mime-type Xml.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

End

Ends the region most recently started with one of the Begin* methods.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Flush

Flushes the log writer.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Write Overloaded.

Writes a test log stream writable object to the stream.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteEllipsis

Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteException Overloaded.

Writes an exception.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteHighlighted

Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

WriteLine Overloaded. Writes a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Top

See Also

TestLog Class
Gallio.Framework Namespace
DiagnosticLog


Attach Method

TestLog.Attach Method
[image]

Attaches an attachment to the execution log.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Attach( _
ByVal attachment As Attachment _
) As Attachment
C#
public static Attachment Attach(
Attachment attachment
)
C++
public:
static Attachment Attach(
Attachment attachment
)
J#
public static Attachment Attach(
Attachment attachment
)
JScript
public static function Attach(
attachment : Attachment
) : Attachment

Parameters

attachment
The attachment to include

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachment is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
Embed


AttachHtml Method

TestLog.AttachHtml Method
[image]

Attaches an HTML attachment with mime-type Html.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachHtml( _
ByVal attachmentName As String, _
ByVal html As String _
) As TextAttachment
C#
public static TextAttachment AttachHtml(
string attachmentName,
string html
)
C++
public:
static TextAttachment AttachHtml(
String attachmentName,
String html
)
J#
public static TextAttachment AttachHtml(
string attachmentName,
string html
)
JScript
public static function AttachHtml(
attachmentName : String,
html : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
html
The HTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if html is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
EmbedHtml


AttachImage Method

TestLog.AttachImage Method
[image]

Attaches an image attachment with a mime-type compatible with its internal representation.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachImage( _
ByVal attachmentName As String, _
ByVal image As Image _
) As BinaryAttachment
C#
public static BinaryAttachment AttachImage(
string attachmentName,
Image image
)
C++
public:
static BinaryAttachment AttachImage(
String attachmentName,
Image image
)
J#
public static BinaryAttachment AttachImage(
string attachmentName,
Image image
)
JScript
public static function AttachImage(
attachmentName : String,
image : Image
) : BinaryAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
image
The image to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if image is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
EmbedImage


AttachObjectAsXml Method

TestLog.AttachObjectAsXml Method

Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Overload List

Name | Description
AttachObjectAsXml (String, Object) | Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. This is a convenience method that forwards the request to the current log writer as returned by the Writer property.
AttachObjectAsXml (String, Object, XmlSerializer) | Attaches an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer. This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

See Also

TestLog Class
Gallio.Framework Namespace


AttachObjectAsXml Method (String, Object)

TestLog.AttachObjectAsXml Method (String, Object)
See Also Example
[image]

Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object _
) As TextAttachment
C#
public static TextAttachment AttachObjectAsXml(
string attachmentName,
object obj
)
C++
public:
static TextAttachment AttachObjectAsXml(
String attachmentName,
Object obj
)
J#
public static TextAttachment AttachObjectAsXml(
string attachmentName,
object obj
)
JScript
public static function AttachObjectAsXml(
attachmentName : String,
obj : Object
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.AttachObjectAsXml Overload List
EmbedObjectAsXml


AttachObjectAsXml Method (String, Object, XmlSerializer)

TestLog.AttachObjectAsXml Method (String, Object, XmlSerializer)
See Also Example
[image]

Attaches an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object, _
ByVal xmlSerializer As XmlSerializer _
) As TextAttachment
C#
public static TextAttachment AttachObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
C++
public:
static TextAttachment AttachObjectAsXml(
String attachmentName,
Object obj,
XmlSerializer xmlSerializer
)
J#
public static TextAttachment AttachObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
JScript
public static function AttachObjectAsXml(
attachmentName : String,
obj : Object,
xmlSerializer : XmlSerializer
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null
xmlSerializer
The XmlSerializer to use, or null to use the default XmlSerializer for the object's type

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.AttachObjectAsXml Overload List
EmbedObjectAsXml


AttachPlainText Method

TestLog.AttachPlainText Method
[image]

Attaches an plain text attachment with mime-type PlainText.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachPlainText( _
ByVal attachmentName As String, _
ByVal text As String _
) As TextAttachment
C#
public static TextAttachment AttachPlainText(
string attachmentName,
string text
)
C++
public:
static TextAttachment AttachPlainText(
String attachmentName,
String text
)
J#
public static TextAttachment AttachPlainText(
string attachmentName,
string text
)
JScript
public static function AttachPlainText(
attachmentName : String,
text : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
text
The text to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
EmbedPlainText


AttachXHtml Method

TestLog.AttachXHtml Method
[image]

Attaches an XHTML attachment with mime-type XHtml.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachXHtml( _
ByVal attachmentName As String, _
ByVal xhtml As String _
) As TextAttachment
C#
public static TextAttachment AttachXHtml(
string attachmentName,
string xhtml
)
C++
public:
static TextAttachment AttachXHtml(
String attachmentName,
String xhtml
)
J#
public static TextAttachment AttachXHtml(
string attachmentName,
string xhtml
)
JScript
public static function AttachXHtml(
attachmentName : String,
xhtml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xhtml
The XHTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xhtml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
EmbedXHtml


AttachXml Method

TestLog.AttachXml Method
[image]

Attaches an XML attachment with mime-type Xml.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function AttachXml( _
ByVal attachmentName As String, _
ByVal xml As String _
) As TextAttachment
C#
public static TextAttachment AttachXml(
string attachmentName,
string xml
)
C++
public:
static TextAttachment AttachXml(
String attachmentName,
String xml
)
J#
public static TextAttachment AttachXml(
string attachmentName,
string xml
)
JScript
public static function AttachXml(
attachmentName : String,
xml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xml
The XML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
EmbedXml


BeginMarker Method

TestLog.BeginMarker Method
[image]

Begins a marked region. Maybe be nested.

A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BeginMarker( _
ByVal marker As Marker _
) As IDisposable
C#
public static IDisposable BeginMarker(
Marker marker
)
C++
public:
static IDisposable BeginMarker(
Marker marker
)
J#
public static IDisposable BeginMarker(
Marker marker
)
JScript
public static function BeginMarker(
marker : Marker
) : IDisposable

Parameters

marker
The marker

Return Value

A Disposable object that calls End when disposed. This is a convenience for use with the C# "using" statement.

Example

Copy Code
            using (Log.BeginMarker(Marker.Monospace))
            {
                Log.WriteLine(contents);
            }

See Also

TestLog Class
Gallio.Framework Namespace


BeginSection Method

TestLog.BeginSection Method
[image]

Begins a section with the specified name. Maybe be nested.

A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BeginSection( _
ByVal sectionName As String _
) As IDisposable
C#
public static IDisposable BeginSection(
string sectionName
)
C++
public:
static IDisposable BeginSection(
String sectionName
)
J#
public static IDisposable BeginSection(
string sectionName
)
JScript
public static function BeginSection(
sectionName : String
) : IDisposable

Parameters

sectionName
The name of the section

Return Value

A Disposable object that calls End when disposed. This is a convenience for use with the C# "using" statement.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sectionName is null

Example

Copy Code
            using (Log.BeginSection("Doing something interesting"))
            {
                Log.WriteLine("Ah ha!");
            }

See Also

TestLog Class
Gallio.Framework Namespace


Embed Method

TestLog.Embed Method
[image]

Embeds an attachment.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Embed( _
ByVal attachment As Attachment _
) As Attachment
C#
public static Attachment Embed(
Attachment attachment
)
C++
public:
static Attachment Embed(
Attachment attachment
)
J#
public static Attachment Embed(
Attachment attachment
)
JScript
public static function Embed(
attachment : Attachment
) : Attachment

Parameters

attachment
The attachment to embed

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachment is null
InvalidOperationException | Thrown if there is already an attachment with the same name

Remarks

An attachment instance can be embedded multiple times efficiently since each embedded copy is typically represented as a link to the same common attachment instance.

See Also

TestLog Class
Gallio.Framework Namespace
Attach


EmbedExisting Method

TestLog.EmbedExisting Method
[image]

Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EmbedExisting( _
ByVal attachmentName As String _
)
C#
public static void EmbedExisting(
string attachmentName
)
C++
public:
static void EmbedExisting(
String attachmentName
)
J#
public static void EmbedExisting(
string attachmentName
)
JScript
public static function EmbedExisting(
attachmentName : String
)

Parameters

attachmentName
The name of the existing attachment to embed

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachmentName is null
InvalidOperationException | Thrown if no attachment with the specified name has been previously attached

Remarks

An attachment instance can be embedded multiple times efficiently since each embedded copy is typically represented as a link to the same common attachment instance.

See Also

TestLog Class
Gallio.Framework Namespace
Attach
Embed


EmbedHtml Method

TestLog.EmbedHtml Method
[image]

Embeds an HTML attachment with mime-type Html.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedHtml( _
ByVal attachmentName As String, _
ByVal html As String _
) As TextAttachment
C#
public static TextAttachment EmbedHtml(
string attachmentName,
string html
)
C++
public:
static TextAttachment EmbedHtml(
String attachmentName,
String html
)
J#
public static TextAttachment EmbedHtml(
string attachmentName,
string html
)
JScript
public static function EmbedHtml(
attachmentName : String,
html : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
html
The HTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if html is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
AttachHtml


EmbedImage Method

TestLog.EmbedImage Method
[image]

Embeds an image attachment with a mime-type compatible with its internal representation.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedImage( _
ByVal attachmentName As String, _
ByVal image As Image _
) As BinaryAttachment
C#
public static BinaryAttachment EmbedImage(
string attachmentName,
Image image
)
C++
public:
static BinaryAttachment EmbedImage(
String attachmentName,
Image image
)
J#
public static BinaryAttachment EmbedImage(
string attachmentName,
Image image
)
JScript
public static function EmbedImage(
attachmentName : String,
image : Image
) : BinaryAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
image
The image to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if image is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
AttachImage


EmbedObjectAsXml Method

TestLog.EmbedObjectAsXml Method

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Overload List

Name | Description
EmbedObjectAsXml (String, Object) | Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
EmbedObjectAsXml (String, Object, XmlSerializer) | Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

See Also

TestLog Class
Gallio.Framework Namespace


EmbedObjectAsXml Method (String, Object)

TestLog.EmbedObjectAsXml Method (String, Object)
See Also Example
[image]

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object _
) As TextAttachment
C#
public static TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj
)
C++
public:
static TextAttachment EmbedObjectAsXml(
String attachmentName,
Object obj
)
J#
public static TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj
)
JScript
public static function EmbedObjectAsXml(
attachmentName : String,
obj : Object
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.EmbedObjectAsXml Overload List
AttachObjectAsXml


EmbedObjectAsXml Method (String, Object, XmlSerializer)

TestLog.EmbedObjectAsXml Method (String, Object, XmlSerializer)
See Also Example
[image]

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object, _
ByVal xmlSerializer As XmlSerializer _
) As TextAttachment
C#
public static TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
C++
public:
static TextAttachment EmbedObjectAsXml(
String attachmentName,
Object obj,
XmlSerializer xmlSerializer
)
J#
public static TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
JScript
public static function EmbedObjectAsXml(
attachmentName : String,
obj : Object,
xmlSerializer : XmlSerializer
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null
xmlSerializer
The XmlSerializer to use, or null to use the default XmlSerializer for the object's type

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.EmbedObjectAsXml Overload List
AttachObjectAsXml


EmbedPlainText Method

TestLog.EmbedPlainText Method
[image]

Embeds an plain text attachment with mime-type PlainText.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedPlainText( _
ByVal attachmentName As String, _
ByVal text As String _
) As TextAttachment
C#
public static TextAttachment EmbedPlainText(
string attachmentName,
string text
)
C++
public:
static TextAttachment EmbedPlainText(
String attachmentName,
String text
)
J#
public static TextAttachment EmbedPlainText(
string attachmentName,
string text
)
JScript
public static function EmbedPlainText(
attachmentName : String,
text : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
text
The text to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
AttachPlainText


EmbedXHtml Method

TestLog.EmbedXHtml Method
[image]

Embeds an XHTML attachment with mime-type XHtml.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedXHtml( _
ByVal attachmentName As String, _
ByVal xhtml As String _
) As TextAttachment
C#
public static TextAttachment EmbedXHtml(
string attachmentName,
string xhtml
)
C++
public:
static TextAttachment EmbedXHtml(
String attachmentName,
String xhtml
)
J#
public static TextAttachment EmbedXHtml(
string attachmentName,
string xhtml
)
JScript
public static function EmbedXHtml(
attachmentName : String,
xhtml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xhtml
The XHTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xhtml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
AttachXHtml


EmbedXml Method

TestLog.EmbedXml Method
[image]

Embeds an XML attachment with mime-type Xml.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EmbedXml( _
ByVal attachmentName As String, _
ByVal xml As String _
) As TextAttachment
C#
public static TextAttachment EmbedXml(
string attachmentName,
string xml
)
C++
public:
static TextAttachment EmbedXml(
String attachmentName,
String xml
)
J#
public static TextAttachment EmbedXml(
string attachmentName,
string xml
)
JScript
public static function EmbedXml(
attachmentName : String,
xml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xml
The XML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLog Class
Gallio.Framework Namespace
AttachXml


End Method

TestLog.End Method
[image]

Ends the region most recently started with one of the Begin* methods.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub End()
C#
public static void End()
C++
public:
static void End()
J#
public static void End()
JScript
public static function End()

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if there is no current nested region

See Also

TestLog Class
Gallio.Framework Namespace


Flush Method

TestLog.Flush Method
[image]

Flushes the log writer.

This is a convenience method that forwards the request to the current log writer as returned by the Writer property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Flush()
C#
public static void Flush()
C++
public:
static void Flush()
J#
public static void Flush()
JScript
public static function Flush()

See Also

TestLog Class
Gallio.Framework Namespace


Write Method

TestLog.Write Method

Writes a test log stream writable object to the stream.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Overload List

Name | Description
Write (ITestLogStreamWritable) | Writes a test log stream writable object to the stream. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
Write (Char) | Writes a character. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
Write (Char) | Writes an array of characters. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
Write (Char, Int32, Int32) | Writes an array of characters. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
Write (Object) | Writes a formatted object. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
Write (String) | Writes a string. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
Write (String, Object) | Writes a formatted string. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

See Also

TestLog Class
Gallio.Framework Namespace


Write Method (ITestLogStreamWritable)

TestLog.Write Method (ITestLogStreamWritable)
See Also Example
[image]

Writes a test log stream writable object to the stream.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal obj As ITestLogStreamWritable _
)
C#
public static void Write(
ITestLogStreamWritable obj
)
C++
public:
static void Write(
ITestLogStreamWritable obj
)
J#
public static void Write(
ITestLogStreamWritable obj
)
JScript
public static function Write(
obj : ITestLogStreamWritable
)

Parameters

obj
The object to write, or null if none

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List


Write Method (Char)

TestLog.Write Method (Char)
See Also Example
[image]

Writes a character.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal value As Char _
)
C#
public static void Write(
char value
)
C++
public:
static void Write(
wchar_t value
)
J#
public static void Write(
char value
)
JScript
public static function Write(
value : char
)

Parameters

value
The character value

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List


Write Method (Char[])

TestLog.Write Method (Char[])
See Also Example
[image]

Writes an array of characters.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal value As Char() _
)
C#
public static void Write(
char[] value
)
C++
public:
static void Write(
array<wchar_t>^ value
)
J#
public static void Write(
char[] value
)
JScript
public static function Write(
value : char[]
)

Parameters

value
The array of characters

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List


Write Method (Char[], Int32, Int32)

TestLog.Write Method (Char[], Int32, Int32)
See Also Example
[image]

Writes an array of characters.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal buffer As Char(), _
ByVal index As Integer, _
ByVal count As Integer _
)
C#
public static void Write(
char[] buffer,
int index,
int count
)
C++
public:
static void Write(
array<wchar_t>^ buffer,
int index,
int count
)
J#
public static void Write(
char[] buffer,
int index,
int count
)
JScript
public static function Write(
buffer : char[],
index : int,
count : int
)

Parameters

buffer
The character buffer
index
The index of the first character in the buffer to write
count
The number of characters from the buffer to write

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if buffer is null
ArgumentOutOfRangeException | Thrown if index or count are out of range

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List


Write Method (Object)

TestLog.Write Method (Object)
See Also Example
[image]

Writes a formatted object.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal value As Object _
)
C#
public static void Write(
object value
)
C++
public:
static void Write(
Object value
)
J#
public static void Write(
object value
)
JScript
public static function Write(
value : Object
)

Parameters

value
The object value

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List


Write Method (String)

TestLog.Write Method (String)
See Also Example
[image]

Writes a string.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal value As String _
)
C#
public static void Write(
string value
)
C++
public:
static void Write(
String value
)
J#
public static void Write(
string value
)
JScript
public static function Write(
value : String
)

Parameters

value
The string value

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List


Write Method (String, Object[])

TestLog.Write Method (String, Object[])
See Also Example
[image]

Writes a formatted string.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Write(
string format,
params object[] args
)
C++
public:
static void Write(
String format,
... array<Object>^ args
)
J#
public static void Write(
string format,
object[] args
)
JScript
public static function Write(
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

format
The format string
args
The format string arguments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if format is null

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.Write Overload List
Format


WriteEllipsis Method

TestLog.WriteEllipsis Method
[image]

Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteEllipsis()
C#
public static void WriteEllipsis()
C++
public:
static void WriteEllipsis()
J#
public static void WriteEllipsis()
JScript
public static function WriteEllipsis()

Remarks

This is a convenience method that simply encapsulates "..." within a marked region of type Ellipsis. However, tools may reinterpret the special marker to make the "..." less ambiguous.

See Also

TestLog Class
Gallio.Framework Namespace


WriteException Method

TestLog.WriteException Method

Writes an exception.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Overload List

Name | Description
WriteException (ExceptionData) | Writes an exception. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteException (ExceptionData, String) | Writes an exception within its own section which provides additional cues for interpretation. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteException (Exception) | Writes an exception. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteException (Exception, String) | Writes an exception within its own section. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

See Also

TestLog Class
Gallio.Framework Namespace


WriteException Method (ExceptionData)

TestLog.WriteException Method (ExceptionData)
See Also Example
[image]

Writes an exception.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteException( _
ByVal exception As ExceptionData _
)
C#
public static void WriteException(
ExceptionData exception
)
C++
public:
static void WriteException(
ExceptionData exception
)
J#
public static void WriteException(
ExceptionData exception
)
JScript
public static function WriteException(
exception : ExceptionData
)

Parameters

exception
The exception data to write

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteException Overload List


WriteException Method (ExceptionData, String)

TestLog.WriteException Method (ExceptionData, String)
See Also Example
[image]

Writes an exception within its own section which provides additional cues for interpretation.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteException( _
ByVal exception As ExceptionData, _
ByVal sectionName As String _
)
C#
public static void WriteException(
ExceptionData exception,
string sectionName
)
C++
public:
static void WriteException(
ExceptionData exception,
String sectionName
)
J#
public static void WriteException(
ExceptionData exception,
string sectionName
)
JScript
public static function WriteException(
exception : ExceptionData,
sectionName : String
)

Parameters

exception
The exception data to write
sectionName
The section name, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteException Overload List


WriteException Method (Exception)

TestLog.WriteException Method (Exception)
See Also Example
[image]

Writes an exception.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteException( _
ByVal exception As Exception _
)
C#
public static void WriteException(
Exception exception
)
C++
public:
static void WriteException(
Exception exception
)
J#
public static void WriteException(
Exception exception
)
JScript
public static function WriteException(
exception : Exception
)

Parameters

exception
The exception to write

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteException Overload List


WriteException Method (Exception, String)

TestLog.WriteException Method (Exception, String)
See Also Example
[image]

Writes an exception within its own section.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteException( _
ByVal exception As Exception, _
ByVal sectionName As String _
)
C#
public static void WriteException(
Exception exception,
string sectionName
)
C++
public:
static void WriteException(
Exception exception,
String sectionName
)
J#
public static void WriteException(
Exception exception,
string sectionName
)
JScript
public static function WriteException(
exception : Exception,
sectionName : String
)

Parameters

exception
The exception to write
sectionName
The section name, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception, or sectionName is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteException Overload List


WriteHighlighted Method

TestLog.WriteHighlighted Method
[image]

Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteHighlighted( _
ByVal text As String _
)
C#
public static void WriteHighlighted(
string text
)
C++
public:
static void WriteHighlighted(
String text
)
J#
public static void WriteHighlighted(
string text
)
JScript
public static function WriteHighlighted(
text : String
)

Parameters

text
The text to write, or null if none

Remarks

This is a convenience method that simply encapsulates the highlighted text within a marker region of type Highlight.

See Also

TestLog Class
Gallio.Framework Namespace


WriteLine Method

TestLog.WriteLine Method

Writes a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Overload List

Name | Description
WriteLine | Writes a line delimiter. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteLine (Char) | Writes a character followed by a line delimiter. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteLine (Char) | Writes an array of characters followed by a line delimiter. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteLine (Object) | Writes a formatted object followed by a line delimiter. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteLine (String) | Writes a string followed by a line delimiter. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.
WriteLine (String, Object) | Writes a formatted string followed by a line delimiter. This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

See Also

TestLog Class
Gallio.Framework Namespace


WriteLine Method ()

TestLog.WriteLine Method ()
See Also Example
[image]

Writes a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine()
C#
public static void WriteLine()
C++
public:
static void WriteLine()
J#
public static void WriteLine()
JScript
public static function WriteLine()

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteLine Overload List


WriteLine Method (Char)

TestLog.WriteLine Method (Char)
See Also Example
[image]

Writes a character followed by a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal value As Char _
)
C#
public static void WriteLine(
char value
)
C++
public:
static void WriteLine(
wchar_t value
)
J#
public static void WriteLine(
char value
)
JScript
public static function WriteLine(
value : char
)

Parameters

value
The character value

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteLine Overload List


WriteLine Method (Char[])

TestLog.WriteLine Method (Char[])
See Also Example
[image]

Writes an array of characters followed by a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal value As Char() _
)
C#
public static void WriteLine(
char[] value
)
C++
public:
static void WriteLine(
array<wchar_t>^ value
)
J#
public static void WriteLine(
char[] value
)
JScript
public static function WriteLine(
value : char[]
)

Parameters

value
The array of characters

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteLine Overload List


WriteLine Method (Object)

TestLog.WriteLine Method (Object)
See Also Example
[image]

Writes a formatted object followed by a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal value As Object _
)
C#
public static void WriteLine(
object value
)
C++
public:
static void WriteLine(
Object value
)
J#
public static void WriteLine(
object value
)
JScript
public static function WriteLine(
value : Object
)

Parameters

value
The object value

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteLine Overload List


WriteLine Method (String)

TestLog.WriteLine Method (String)
See Also Example
[image]

Writes a string followed by a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal value As String _
)
C#
public static void WriteLine(
string value
)
C++
public:
static void WriteLine(
String value
)
J#
public static void WriteLine(
string value
)
JScript
public static function WriteLine(
value : String
)

Parameters

value
The string value

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteLine Overload List


WriteLine Method (String, Object[])

TestLog.WriteLine Method (String, Object[])
See Also Example
[image]

Writes a formatted string followed by a line delimiter.

This is a convenience method that forwards the request to the current default log stream writer as returned by the Default property.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteLine( _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void WriteLine(
string format,
params object[] args
)
C++
public:
static void WriteLine(
String format,
... array<Object>^ args
)
J#
public static void WriteLine(
string format,
object[] args
)
JScript
public static function WriteLine(
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

format
The format string
args
The format string arguments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if format is null

See Also

TestLog Class
Gallio.Framework Namespace
TestLog.WriteLine Overload List
Format


TestStep Class

TestStep Class
See Also Example Members
[image]

Provides functions for manipulating test steps.

A step is a delimited region of a test. Each step appears in the report as if it were a dynamically generated test nested within the body of the test (or some other step) that spawned it. The step has its own execution log, pass/fail/inconclusive result and in all other respects behaves much like an ordinary test would.

The number of steps within a test does not need to be known ahead of time. This can be useful in situations where insufficient information is known about the internal structure of a test to be able to fully populate the test tree will all of its details. Because steps are dynamically generated at runtime, they appear in test reports but they are invisible to test runners. that traverse the test tree.

There are many interesting uses for steps. For example:

  • A single test consisting of a long sequence of actions can be subdivided into steps to simplify analysis.
  • A test might depend on environmental configuration that cannot be known a priori.
  • A performance test might be scheduled to run for a certain duration but the total number of iterations is unknown. By running each iteration as a step within a single test, the test report can display the execution log and pass/fail result of each iteration independently of the others.
  • A script-driven test driver could execute a scripted sequence of verification commands as a distinct step. If the script is written in a general purpose programming language, the total number of commands and the order in which they will be performed might not be known ahead of time. Using steps enables the integration of tests written in forms that cannot be directly adapted to the framework's native testing primitives.
  • When testing non-deterministic algorithms, it is sometimes useful to repeat a test multiple times under slightly different conditions until a certain level of confidence is reached. The variety of conditions tested might be determined adaptively based on an error estimation metric. Using steps each condition verified can be reported independently.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public Module TestStep
C#
[TestFrameworkInternalAttribute]
public static class TestStep
C++
[TestFrameworkInternalAttribute]
ref class TestStep abstract sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public final class TestStep
JScript
public
TestFrameworkInternalAttribute
class TestStep

Example

Running as many iterations of a test as possible for a set maximum duration. Each iteration will run as a separate test step so that it has its own test execution log and test outcome included in the test report.

Copy Code
            [Test]
            public void MeasurePerformance()
            {
                // Warm up.
                TestStep.RunStepAndVerify("Warm Up", DoSomething, TestOutcome.Passed);

                // Run as many iterations as possible for 10 seconds.
                int iterations = 0;
                Stopwatch stopwatch = Stopwatch.StartNew();
                while (stopwatch.ElapsedMilliseconds < 10*1000)
                {
                    iterations += 1;
                    TestStep.RunStepAndVerify("Iteration #" + i, DoSomething, TestOutcome.Passed);
                }

                double iterationsPerSecond = iterations * 1000.0 / stopwatch.ElapsedMilliseconds;
                Assert.GreaterEqualThan(iterationsPerSecond, 5, "Unacceptable performance.");
            }

            private void DoSomething()
            {
                objectUnderTest.Wibble();
            }

Inheritance Hierarchy

System.Object
Gallio.Framework.TestStep

See Also

TestStep Members
Gallio.Framework Namespace


TestStep Members

TestStep Members
See Also Example Properties Methods
[image]

Provides functions for manipulating test steps.

A step is a delimited region of a test. Each step appears in the report as if it were a dynamically generated test nested within the body of the test (or some other step) that spawned it. The step has its own execution log, pass/fail/inconclusive result and in all other respects behaves much like an ordinary test would.

The number of steps within a test does not need to be known ahead of time. This can be useful in situations where insufficient information is known about the internal structure of a test to be able to fully populate the test tree will all of its details. Because steps are dynamically generated at runtime, they appear in test reports but they are invisible to test runners. that traverse the test tree.

There are many interesting uses for steps. For example:

  • A single test consisting of a long sequence of actions can be subdivided into steps to simplify analysis.
  • A test might depend on environmental configuration that cannot be known a priori.
  • A performance test might be scheduled to run for a certain duration but the total number of iterations is unknown. By running each iteration as a step within a single test, the test report can display the execution log and pass/fail result of each iteration independently of the others.
  • A script-driven test driver could execute a scripted sequence of verification commands as a distinct step. If the script is written in a general purpose programming language, the total number of commands and the order in which they will be performed might not be known ahead of time. Using steps enables the integration of tests written in forms that cannot be directly adapted to the framework's native testing primitives.
  • When testing non-deterministic algorithms, it is sometimes useful to repeat a test multiple times under slightly different conditions until a certain level of confidence is reached. The variety of conditions tested might be determined adaptively based on an error estimation metric. Using steps each condition verified can be reported independently.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestStep.

Public Properties

Name | Description
CurrentStep | Gets reflection information about the current step.
Top

Public Methods

Name | Description
AddMetadata | Adds metadata to the step that is running in the context.
RunStep | Overloaded. Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.
RunStepAndVerifyOutcome | Overloaded. Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.
Top

See Also

TestStep Class
Gallio.Framework Namespace


Properties

TestStep Properties
[image]

Public Properties

Name | Description
CurrentStep | Gets reflection information about the current step.
Top

See Also

TestStep Class
Gallio.Framework Namespace


CurrentStep Property

TestStep.CurrentStep Property
[image]

Gets reflection information about the current step.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CurrentStep As TestStepInfo
C#
public static TestStepInfo CurrentStep { get; }
C++
public static property TestStepInfo CurrentStep {
TestStepInfo get();
}
J#
/** property */
public TestStepInfo get_CurrentStep();
JScript
public function get CurrentStep() : TestStepInfo

See Also

TestStep Class
Gallio.Framework Namespace


Methods

TestStep Methods
[image]

Public Methods

Name | Description
AddMetadata | Adds metadata to the step that is running in the context.
RunStep | Overloaded. Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.
RunStepAndVerifyOutcome | Overloaded. Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.
Top

See Also

TestStep Class
Gallio.Framework Namespace


AddMetadata Method

TestStep.AddMetadata Method
[image]

Adds metadata to the step that is running in the context.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddMetadata( _
ByVal metadataKey As String, _
ByVal metadataValue As String _
)
C#
public static void AddMetadata(
string metadataKey,
string metadataValue
)
C++
public:
static void AddMetadata(
String metadataKey,
String metadataValue
)
J#
public static void AddMetadata(
string metadataKey,
string metadataValue
)
JScript
public static function AddMetadata(
metadataKey : String,
metadataValue : String
)

Parameters

metadataKey
The metadata key
metadataValue
The metadata value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if metadataKey or metadataValue is null

See Also

TestStep Class
Gallio.Framework Namespace


RunStep Method

TestStep.RunStep Method

Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.

Overload List

Name | Description
RunStep (String, Action) | Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.
RunStep (String, Action, Nullable<TimeSpan>) | Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.
RunStep (String, Action, Nullable<TimeSpan>, Boolean, ICodeElementInfo) | Performs an action as a new step within the current context and associates it with the specified code reference. Does not verify the outcome of the step.

See Also

TestStep Class
Gallio.Framework Namespace


RunStep Method (String, Action)

TestStep.RunStep Method (String, Action)
See Also Example
[image]

Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RunStep( _
ByVal name As String, _
ByVal action As Action _
) As TestContext
C#
public static TestContext RunStep(
string name,
Action action
)
C++
public:
static TestContext RunStep(
String name,
Action action
)
J#
public static TestContext RunStep(
string name,
Action action
)
JScript
public static function RunStep(
name : String,
action : Action
) : TestContext

Parameters

name
The name of the step
action
The action to perform

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method does not verify that the test step completed successfully. Check the Outcome of the test step or call RunStepAndVerifyOutcome to ensure that the expected outcome was obtained.

See Also

TestStep Class
Gallio.Framework Namespace
TestStep.RunStep Overload List


RunStep Method (String, Action, Generic Nullable)

TestStep.RunStep Method (String, Action, Generic Nullable)
See Also Example
[image]

Performs an action as a new step within the current context and associates it with the calling function. Does not verify the outcome of the step.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RunStep( _
ByVal name As String, _
ByVal action As Action, _
ByVal timeout As Nullable(Of TimeSpan) _
) As TestContext
C#
public static TestContext RunStep(
string name,
Action action,
Nullable<TimeSpan> timeout
)
C++
public:
static TestContext RunStep(
String name,
Action action,
Nullable<TimeSpan> timeout
)
J#
public static TestContext RunStep(
string name,
Action action,
Nullable<TimeSpan> timeout
)
JScript
public static function RunStep(
name : String,
action : Action,
timeout : Nullable<TimeSpan>
) : TestContext

Parameters

name
The name of the step
action
The action to perform
timeout
The step execution timeout, or null if none

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
ArgumentOutOfRangeException | Thrown if timeout is negative

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method does not verify that the test step completed successfully. Check the Outcome of the test step or call RunStepAndVerifyOutcome to ensure that the expected outcome was obtained.

See Also

TestStep Class
Gallio.Framework Namespace
TestStep.RunStep Overload List


RunStep Method (String, Action, Generic Nullable, Boolean, ICodeElementInfo)

TestStep.RunStep Method (String, Action, Generic Nullable, Boolean, ICodeElementInfo)
See Also Example
[image]

Performs an action as a new step within the current context and associates it with the specified code reference. Does not verify the outcome of the step.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RunStep( _
ByVal name As String, _
ByVal action As Action, _
ByVal timeout As Nullable(Of TimeSpan), _
ByVal isTestCase As Boolean, _
ByVal codeElement As ICodeElementInfo _
) As TestContext
C#
public static TestContext RunStep(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement
)
C++
public:
static TestContext RunStep(
String name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement
)
J#
public static TestContext RunStep(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement
)
JScript
public static function RunStep(
name : String,
action : Action,
timeout : Nullable<TimeSpan>,
isTestCase : bool,
codeElement : ICodeElementInfo
) : TestContext

Parameters

name
The name of the step
action
The action to perform
timeout
The step execution timeout, or null if none
isTestCase
True if the step represents an independent test case
codeElement
The associated code element, or null if none

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
ArgumentOutOfRangeException | Thrown if timeout is negative

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method does not verify that the test step completed successfully. Check the Outcome of the test step or call RunStepAndVerifyOutcome to ensure that the expected outcome was obtained.

See Also

TestStep Class
Gallio.Framework Namespace
TestStep.RunStep Overload List


RunStepAndVerifyOutcome Method

TestStep.RunStepAndVerifyOutcome Method

Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.

Overload List

Name | Description
RunStepAndVerifyOutcome (String, Action, TestOutcome) | Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.
RunStepAndVerifyOutcome (String, Action, Nullable<TimeSpan>, TestOutcome) | Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.
RunStepAndVerifyOutcome (String, Action, Nullable<TimeSpan>, Boolean, ICodeElementInfo, TestOutcome) | Performs an action as a new step within the current context and associates it with the specified code reference. Verifies that the step produced the expected outcome.

See Also

TestStep Class
Gallio.Framework Namespace


RunStepAndVerifyOutcome Method (String, Action, TestOutcome)

TestStep.RunStepAndVerifyOutcome Method (String, Action, TestOutcome)
See Also Example
[image]

Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RunStepAndVerifyOutcome( _
ByVal name As String, _
ByVal action As Action, _
ByVal expectedOutcome As TestOutcome _
) As TestContext
C#
public static TestContext RunStepAndVerifyOutcome(
string name,
Action action,
TestOutcome expectedOutcome
)
C++
public:
static TestContext RunStepAndVerifyOutcome(
String name,
Action action,
TestOutcome expectedOutcome
)
J#
public static TestContext RunStepAndVerifyOutcome(
string name,
Action action,
TestOutcome expectedOutcome
)
JScript
public static function RunStepAndVerifyOutcome(
name : String,
action : Action,
expectedOutcome : TestOutcome
) : TestContext

Parameters

name
The name of the step
action
The action to perform
expectedOutcome
The expected outcome of the step

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
AssertionFailureException | Thrown if the expected outcome was not obtained

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method verifies that the step produced the expected outcome. If a different outcome was obtained, then raises an assertion failure.

See Also

TestStep Class
Gallio.Framework Namespace
TestStep.RunStepAndVerifyOutcome Overload List


RunStepAndVerifyOutcome Method (String, Action, Generic Nullable, TestOutcome)

TestStep.RunStepAndVerifyOutcome Method (String, Action, Generic Nullable, TestOutcome)
See Also Example
[image]

Performs an action as a new step within the current context and associates it with the calling function. Verifies that the step produced the expected outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RunStepAndVerifyOutcome( _
ByVal name As String, _
ByVal action As Action, _
ByVal timeout As Nullable(Of TimeSpan), _
ByVal expectedOutcome As TestOutcome _
) As TestContext
C#
public static TestContext RunStepAndVerifyOutcome(
string name,
Action action,
Nullable<TimeSpan> timeout,
TestOutcome expectedOutcome
)
C++
public:
static TestContext RunStepAndVerifyOutcome(
String name,
Action action,
Nullable<TimeSpan> timeout,
TestOutcome expectedOutcome
)
J#
public static TestContext RunStepAndVerifyOutcome(
string name,
Action action,
Nullable<TimeSpan> timeout,
TestOutcome expectedOutcome
)
JScript
public static function RunStepAndVerifyOutcome(
name : String,
action : Action,
timeout : Nullable<TimeSpan>,
expectedOutcome : TestOutcome
) : TestContext

Parameters

name
The name of the step
action
The action to perform
timeout
The step execution timeout, or null if none
expectedOutcome
The expected outcome of the step

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
ArgumentOutOfRangeException | Thrown if timeout is negative
AssertionFailureException | Thrown if the expected outcome was not obtained

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method verifies that the step produced the expected outcome. If a different outcome was obtained, then raises an assertion failure.

See Also

TestStep Class
Gallio.Framework Namespace
TestStep.RunStepAndVerifyOutcome Overload List


RunStepAndVerifyOutcome Method (String, Action, Generic Nullable, Boolean, ICodeElementInfo, TestOutcome)

TestStep.RunStepAndVerifyOutcome Method (String, Action, Generic Nullable, Boolean, ICodeElementInfo, TestOutcome)
See Also Example
[image]

Performs an action as a new step within the current context and associates it with the specified code reference. Verifies that the step produced the expected outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RunStepAndVerifyOutcome( _
ByVal name As String, _
ByVal action As Action, _
ByVal timeout As Nullable(Of TimeSpan), _
ByVal isTestCase As Boolean, _
ByVal codeElement As ICodeElementInfo, _
ByVal expectedOutcome As TestOutcome _
) As TestContext
C#
public static TestContext RunStepAndVerifyOutcome(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement,
TestOutcome expectedOutcome
)
C++
public:
static TestContext RunStepAndVerifyOutcome(
String name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement,
TestOutcome expectedOutcome
)
J#
public static TestContext RunStepAndVerifyOutcome(
string name,
Action action,
Nullable<TimeSpan> timeout,
bool isTestCase,
ICodeElementInfo codeElement,
TestOutcome expectedOutcome
)
JScript
public static function RunStepAndVerifyOutcome(
name : String,
action : Action,
timeout : Nullable<TimeSpan>,
isTestCase : bool,
codeElement : ICodeElementInfo,
expectedOutcome : TestOutcome
) : TestContext

Parameters

name
The name of the step
action
The action to perform
timeout
The step execution timeout, or null if none
isTestCase
True if the step represents an independent test case
codeElement
The associated code element, or null if none
expectedOutcome
The expected outcome of the step

Return Value

The context of the step that ran

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or action is null
ArgumentException | Thrown if name is the empty string
ArgumentOutOfRangeException | Thrown if timeout is negative
AssertionFailureException | Thrown if the expected outcome was not obtained

Remarks

This method creates a new child context with a new nested ITestStep, enters the child context, performs the action, then exits the child context.

This method may be called recursively to create nested steps or concurrently to create parallel steps.

This method verifies that the step produced the expected outcome. If a different outcome was obtained, then raises an assertion failure.

See Also

TestStep Class
Gallio.Framework Namespace
TestStep.RunStepAndVerifyOutcome Overload List


TestTerminatedException Class

TestTerminatedException Class
See Also Example Members
[image]

This exception type is used to signal that a test has been terminated with a particular outcome. The exception message, if present, should explain the reason that the test was terminated.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class TestTerminatedException
Inherits TestException
C#
[SerializableAttribute]
public class TestTerminatedException : TestException
C++
[SerializableAttribute]
ref class TestTerminatedException : TestException
J#
/** @attribute SerializableAttribute() */
public class TestTerminatedException extends TestException
JScript
public
SerializableAttribute
class TestTerminatedException extends TestException

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestTerminatedException
Gallio.Framework.SilentTestException

See Also

TestTerminatedException Members
Gallio.Framework Namespace


TestTerminatedException Members

TestTerminatedException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

This exception type is used to signal that a test has been terminated with a particular outcome. The exception message, if present, should explain the reason that the test was terminated.

The following tables list the members exposed by TestTerminatedException.

Public Constructors

Name | Description
TestTerminatedException | Overloaded.
Top

Protected Constructors

Name | Description
TestTerminatedException | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Overridden. Gets the outcome of the test.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestTerminatedException | Overloaded.
Top

See Also

TestTerminatedException Class
Gallio.Framework Namespace


TestTerminatedException Constructor

TestTerminatedException Constructor

Overload List

 | Name | Description
Public method | TestTerminatedException (TestOutcome) | Creates a silent test exception with the specified outcome.
Public method | TestTerminatedException (TestOutcome, String) | Creates a silent test exception with the specified outcome.
Public method | TestTerminatedException (TestOutcome, String, Exception) | Creates an exception.
Family method | TestTerminatedException (SerializationInfo, StreamingContext) | Creates a exception from serialization info.

See Also

TestTerminatedException Class
Gallio.Framework Namespace


TestTerminatedException Constructor (TestOutcome)

TestTerminatedException Constructor (TestOutcome)
See Also Example
[image]

Creates a silent test exception with the specified outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal outcome As TestOutcome _
)
C#
public TestTerminatedException(
TestOutcome outcome
)
C++
public:
TestTerminatedException(
TestOutcome outcome
) sealed
J#
public TestTerminatedException(
TestOutcome outcome
)
JScript
public function TestTerminatedException(
outcome : TestOutcome
)

Parameters

outcome
The test outcome

See Also

TestTerminatedException Class
Gallio.Framework Namespace
TestTerminatedException Constructor Overload List


TestTerminatedException Constructor (TestOutcome, String)

TestTerminatedException Constructor (TestOutcome, String)
See Also Example
[image]

Creates a silent test exception with the specified outcome.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal outcome As TestOutcome, _
ByVal message As String _
)
C#
public TestTerminatedException(
TestOutcome outcome,
string message
)
C++
public:
TestTerminatedException(
TestOutcome outcome,
String message
) sealed
J#
public TestTerminatedException(
TestOutcome outcome,
string message
)
JScript
public function TestTerminatedException(
outcome : TestOutcome,
message : String
)

Parameters

outcome
The test outcome
message
The message, or null if none

See Also

TestTerminatedException Class
Gallio.Framework Namespace
TestTerminatedException Constructor Overload List


TestTerminatedException Constructor (TestOutcome, String, Exception)

TestTerminatedException Constructor (TestOutcome, String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal outcome As TestOutcome, _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public TestTerminatedException(
TestOutcome outcome,
string message,
Exception innerException
)
C++
public:
TestTerminatedException(
TestOutcome outcome,
String message,
Exception innerException
) sealed
J#
public TestTerminatedException(
TestOutcome outcome,
string message,
Exception innerException
)
JScript
public function TestTerminatedException(
outcome : TestOutcome,
message : String,
innerException : Exception
)

Parameters

outcome
The test outcome
message
The message, or null if none
innerException
The inner exception, or null if none

See Also

TestTerminatedException Class
Gallio.Framework Namespace
TestTerminatedException Constructor Overload List


TestTerminatedException Constructor (SerializationInfo, StreamingContext)

TestTerminatedException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates a exception from serialization info.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected TestTerminatedException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
TestTerminatedException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected TestTerminatedException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function TestTerminatedException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

TestTerminatedException Class
Gallio.Framework Namespace
TestTerminatedException Constructor Overload List


Properties

TestTerminatedException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Overridden. Gets the outcome of the test.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

TestTerminatedException Class
Gallio.Framework Namespace


Outcome Property

TestTerminatedException.Outcome Property
[image]

Gets the outcome of the test.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Outcome As TestOutcome
C#
public override TestOutcome Outcome { get; }
C++
public override property TestOutcome Outcome override {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

See Also

TestTerminatedException Class
Gallio.Framework Namespace


Methods

TestTerminatedException Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestTerminatedException Class
Gallio.Framework Namespace


GetObjectData Method

TestTerminatedException.GetObjectData Method
[image]

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Gallio.Framework
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
C++
public:
virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
) override
J#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
JScript
public override function GetObjectData(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable.GetObjectData

See Also

TestTerminatedException Class
Gallio.Framework Namespace


Gallio.Framework.Assertions

Gallio.Framework.Assertions Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AssertionConditionEvaluator | Evaluates a conditional expression. If the condition evaluates differently than expected, returns a detailed AssertionFailure that describes the formatted values of relevant sub-expressions within the condtion. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AssertionContext | Describes the context in which an assertion is being evaluated. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AssertionException | The exception type used by the Gallio assertion framework to signal assertion failures.
Public class AssertionFailure

An assertion failure is an immutable description of a failed assertion and its cause. It takes into account information about labeled values such as the expected and actual value.

Use an AssertionFailureBuilder to generate an instance of this type.

Public class | AssertionFailureBuilder | An assertion failure builder is used to construct a complete description of an assertion failure that has occurred. It takes into account information about the expected and actual value, as well as additional labeled values and exceptions.
Public class AssertionFailureException

An exception type that wraps a AssertionFailure.

This exception is used in two ways:

  • The exception may be "silent" when it is used to cause a test to terminate due to an assertion failure that has already been logged or otherwise conveyed to the user.
  • Otherwise the exception will be reported the user in the typical manner.
Public class | AssertionHelper | Provides utilities to assist with the implementation of new asserts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Structures

Structure Description
NestedPublic structure AssertionFailure.LabeledValue

A labeled value describes a named assertion parameter.

The label indicates the purpose of the value, such as "Expected Value". The value itself should be formatted to emphasize structural characteristics.

For additional emphasis, such as for comparison purposes (ie. diffs), the value may be formatted as structured text to include highlights and other markup.

Enumerations

Enumeration Description
Public enumeration AssertionFailureBehavior

Specifies the behavior that should take place when a AssertionFailure is submitted to the AssertionContext.

There are three orthogonal dimensions to the assertion failure behavior:

  • Log / No-Log: Log the failure when reported, or do not log it.
  • Throw / No-Throw: Throw an exception to abort computation, or allow it to continue
  • Discard / No-Discard (aka. CaptureAndContinue): Discard the failure when finished reporting it, or capture it in a list for further processing


AssertionConditionEvaluator Class

AssertionConditionEvaluator Class
See Also Example Members
[image]

Evaluates a conditional expression. If the condition evaluates differently than expected, returns a detailed AssertionFailure that describes the formatted values of relevant sub-expressions within the condtion. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public Module AssertionConditionEvaluator
C#
[TestFrameworkInternalAttribute]
public static class AssertionConditionEvaluator
C++
[TestFrameworkInternalAttribute]
ref class AssertionConditionEvaluator abstract sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public final class AssertionConditionEvaluator
JScript
public
TestFrameworkInternalAttribute
class AssertionConditionEvaluator

Inheritance Hierarchy

System.Object
Gallio.Framework.Assertions.AssertionConditionEvaluator

See Also

AssertionConditionEvaluator Members
Gallio.Framework.Assertions Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


AssertionConditionEvaluator Members

AssertionConditionEvaluator Members
See Also Example Methods
[image]

Evaluates a conditional expression. If the condition evaluates differently than expected, returns a detailed AssertionFailure that describes the formatted values of relevant sub-expressions within the condtion. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AssertionConditionEvaluator.

Public Methods

Name | Description
Eval | Evaluates a conditional expression.
Top

See Also

AssertionConditionEvaluator Class
Gallio.Framework.Assertions Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

AssertionConditionEvaluator Methods
[image]

Public Methods

Name | Description
Eval | Evaluates a conditional expression.
Top

See Also

AssertionConditionEvaluator Class
Gallio.Framework.Assertions Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Eval Method

AssertionConditionEvaluator.Eval Method
[image]

Evaluates a conditional expression.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Eval( _
ByVal condition As Expression(Of Func(Of Boolean)), _
ByVal expectedResult As Boolean, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
) As AssertionFailure
C#
public static AssertionFailure Eval(
Expression<Func<bool>> condition,
bool expectedResult,
string messageFormat,
params object[] messageArgs
)
C++
public:
static AssertionFailure Eval(
Expression<Func<bool>> condition,
bool expectedResult,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static AssertionFailure Eval(
Expression<Func<bool>> condition,
bool expectedResult,
string messageFormat,
object[] messageArgs
)
JScript
public static function Eval(
condition : Expression<Func<bool>>,
expectedResult : bool,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
) : AssertionFailure

Parameters

condition
The conditional expression
expectedResult
The expected result
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The assertion failure if the conditional expression evaluated to a different result than was expected or threw an exception, otherwise null

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if condition is null

See Also

AssertionConditionEvaluator Class
Gallio.Framework.Assertions Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


AssertionContext Class

AssertionContext Class
See Also Example Members
[image]

Describes the context in which an assertion is being evaluated. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class AssertionContext
C#
public sealed class AssertionContext
C++
ref class AssertionContext sealed
J#
public final class AssertionContext
JScript
public final class AssertionContext

Inheritance Hierarchy

System.Object
Gallio.Framework.Assertions.AssertionContext

See Also

AssertionContext Members
Gallio.Framework.Assertions Namespace


AssertionContext Members

AssertionContext Members
See Also Example Properties Methods
[image]

Describes the context in which an assertion is being evaluated. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AssertionContext.

Public Properties

 | Name | Description
Public property | AssertionFailureBehavior | Gets the current assertion failure behavior.
 | CurrentContext | Gets the current assertion context.
Public property | TestContext | Gets the associated test context.
Top

Public Methods

 | Name | Description
Public method | CaptureFailures | Performs an action and returns an array containing the assertion failures that were observed within the block.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPendingFailures | Gets the pending failures within the current assertion scope.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SubmitFailure | Submits an assertion failure.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


Properties

AssertionContext Properties
[image]

Public Properties

 | Name | Description
Public property | AssertionFailureBehavior | Gets the current assertion failure behavior.
 | CurrentContext | Gets the current assertion context.
Public property | TestContext | Gets the associated test context.
Top

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


AssertionFailureBehavior Property

AssertionContext.AssertionFailureBehavior Property
[image]

Gets the current assertion failure behavior.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssertionFailureBehavior As AssertionFailureBehavior
C#
public AssertionFailureBehavior AssertionFailureBehavior { get; }
C++
public property AssertionFailureBehavior AssertionFailureBehavior sealed {
AssertionFailureBehavior get();
}
J#
/** property */
public AssertionFailureBehavior get_AssertionFailureBehavior();
JScript
public function get AssertionFailureBehavior() : AssertionFailureBehavior

Remarks

The value of this property may change during invocations of CaptureFailures.

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


CurrentContext Property

AssertionContext.CurrentContext Property
[image]

Gets the current assertion context.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CurrentContext As AssertionContext
C#
public static AssertionContext CurrentContext { get; }
C++
public static property AssertionContext CurrentContext {
AssertionContext get();
}
J#
/** property */
public AssertionContext get_CurrentContext();
JScript
public function get CurrentContext() : AssertionContext

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


TestContext Property

AssertionContext.TestContext Property
[image]

Gets the associated test context.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestContext As TestContext
C#
public TestContext TestContext { get; }
C++
public property TestContext TestContext sealed {
TestContext get();
}
J#
/** property */
public TestContext get_TestContext();
JScript
public function get TestContext() : TestContext

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


Methods

AssertionContext Methods
[image]

Public Methods

 | Name | Description
Public method | CaptureFailures | Performs an action and returns an array containing the assertion failures that were observed within the block.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPendingFailures | Gets the pending failures within the current assertion scope.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SubmitFailure | Submits an assertion failure.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


CaptureFailures Method

AssertionContext.CaptureFailures Method
[image]

Performs an action and returns an array containing the assertion failures that were observed within the block.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public Function CaptureFailures( _
ByVal action As Action, _
ByVal assertionFailureBehavior As AssertionFailureBehavior, _
ByVal captureExceptionAsAssertionFailure As Boolean _
) As AssertionFailure()
C#
[TestFrameworkInternalAttribute]
public AssertionFailure[] CaptureFailures(
Action action,
AssertionFailureBehavior assertionFailureBehavior,
bool captureExceptionAsAssertionFailure
)
C++
[TestFrameworkInternalAttribute]
public:
array<AssertionFailure>^ CaptureFailures(
Action action,
AssertionFailureBehavior assertionFailureBehavior,
bool captureExceptionAsAssertionFailure
) sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public AssertionFailure[] CaptureFailures(
Action action,
AssertionFailureBehavior assertionFailureBehavior,
bool captureExceptionAsAssertionFailure
)
JScript
public

TestFrameworkInternalAttribute
function CaptureFailures(
action : Action,
assertionFailureBehavior : AssertionFailureBehavior,
captureExceptionAsAssertionFailure : bool
) : AssertionFailure[]

Parameters

action
The action to invoke
assertionFailureBehavior
The assertion failure behavior to use while executing the block
captureExceptionAsAssertionFailure
Specifies whether to represent an exception as an assertion failure, otherwise it is rethrown

Return Value

The array of failures, may be empty if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

The set of failures captured will depend on the setting of assertionFailureBehavior.

  • If set to LogAndThrow or Throw, then only the first failure will be captured since execution will be immediately aborted when it happens.
  • If set to Log or CaptureAndContinue, then all failures will be captured until the block terminates or throws an exception for some other reason.
  • If set to Discard, then no failures will be captured since they will all be ignored!

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


GetPendingFailures Method

AssertionContext.GetPendingFailures Method
[image]

Gets the pending failures within the current assertion scope.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPendingFailures() As AssertionFailure()
C#
public AssertionFailure[] GetPendingFailures()
C++
public:
array<AssertionFailure>^ GetPendingFailures() sealed
J#
public AssertionFailure[] GetPendingFailures()
JScript
public function GetPendingFailures() : AssertionFailure[]

Return Value

The pending failures, or an empty array if none

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


SubmitFailure Method

AssertionContext.SubmitFailure Method
[image]

Submits an assertion failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitFailure( _
ByVal failure As AssertionFailure _
)
C#
public void SubmitFailure(
AssertionFailure failure
)
C++
public:
void SubmitFailure(
AssertionFailure failure
) sealed
J#
public void SubmitFailure(
AssertionFailure failure
)
JScript
public function SubmitFailure(
failure : AssertionFailure
)

Parameters

failure
The assertion failure

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if failure is null

Remarks

The behavior of this method depends upon the current setting of AssertionFailureBehavior. Typically this method will throw an AssertionFailureException but it might do other things. Do not assume that it will throw an exception!

See Also

AssertionContext Class
Gallio.Framework.Assertions Namespace


AssertionException Class

AssertionException Class
See Also Example Members
[image]

The exception type used by the Gallio assertion framework to signal assertion failures.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AssertionException
Inherits TestFailedException
C#
[SerializableAttribute]
public class AssertionException : TestFailedException
C++
[SerializableAttribute]
ref class AssertionException : TestFailedException
J#
/** @attribute SerializableAttribute() */
public class AssertionException extends TestFailedException
JScript
public
SerializableAttribute
class AssertionException extends TestFailedException

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestFailedException
Gallio.Framework.Assertions.AssertionException
Gallio.Framework.Assertions.AssertionFailureException

See Also

AssertionException Members
Gallio.Framework.Assertions Namespace


AssertionException Members

AssertionException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The exception type used by the Gallio assertion framework to signal assertion failures.

The following tables list the members exposed by AssertionException.

Public Constructors

Name | Description
AssertionException | Overloaded. Initializes a new instance of the AssertionException class.
Top

Protected Constructors

Name | Description
AssertionException | Overloaded. Initializes a new instance of the AssertionException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged. (inherited from TestException)
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Outcome | Returns Failed. (inherited from TestFailedException)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from TestException)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AssertionException | Overloaded. Initializes a new instance of the AssertionException class.
Top

See Also

AssertionException Class
Gallio.Framework.Assertions Namespace


AssertionException Constructor

AssertionException Constructor

Initializes a new instance of the AssertionException class.

Overload List

 | Name | Description
Public method | AssertionException | Creates an exception.
Family method | AssertionException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | AssertionException (String) | Creates an exception.
Public method | AssertionException (String, Exception) | Creates an exception.

See Also

AssertionException Class
Gallio.Framework.Assertions Namespace


AssertionException Constructor ()

AssertionException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AssertionException()
C++
public:
AssertionException() sealed
J#
public AssertionException()
JScript
public function AssertionException()

See Also

AssertionException Class
Gallio.Framework.Assertions Namespace
AssertionException Constructor Overload List


AssertionException Constructor (SerializationInfo, StreamingContext)

AssertionException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected AssertionException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
AssertionException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected AssertionException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function AssertionException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

AssertionException Class
Gallio.Framework.Assertions Namespace
AssertionException Constructor Overload List


AssertionException Constructor (String)

AssertionException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public AssertionException(
string message
)
C++
public:
AssertionException(
String message
) sealed
J#
public AssertionException(
string message
)
JScript
public function AssertionException(
message : String
)

Parameters

message
The message

See Also

AssertionException Class
Gallio.Framework.Assertions Namespace
AssertionException Constructor Overload List


AssertionException Constructor (String, Exception)

AssertionException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public AssertionException(
string message,
Exception innerException
)
C++
public:
AssertionException(
String message,
Exception innerException
) sealed
J#
public AssertionException(
string message,
Exception innerException
)
JScript
public function AssertionException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

AssertionException Class
Gallio.Framework.Assertions Namespace
AssertionException Constructor Overload List


AssertionFailure Class

AssertionFailure Class
See Also Example Members
[image]

An assertion failure is an immutable description of a failed assertion and its cause. It takes into account information about labeled values such as the expected and actual value.

Use an AssertionFailureBuilder to generate an instance of this type.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AssertionFailure
Implements ITestLogStreamWritable
C#
[SerializableAttribute]
public class AssertionFailure : ITestLogStreamWritable
C++
[SerializableAttribute]
ref class AssertionFailure : ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
public class AssertionFailure implements ITestLogStreamWritable
JScript
public
SerializableAttribute
class AssertionFailure extends ITestLogStreamWritable

Inheritance Hierarchy

System.Object
Gallio.Framework.Assertions.AssertionFailure

See Also

AssertionFailure Members
Gallio.Framework.Assertions Namespace


AssertionFailure Members

AssertionFailure Members
See Also Example Constructors Fields Properties Methods
[image]

An assertion failure is an immutable description of a failed assertion and its cause. It takes into account information about labeled values such as the expected and actual value.

Use an AssertionFailureBuilder to generate an instance of this type.

The following tables list the members exposed by AssertionFailure.

Protected Constructors

 | Name | Description
Family method | AssertionFailure | Creates an assertion failure object.
Top

Public Fields

Name | Description
MaxFormattedValueLength | Gets the maximum length of formatted value that can be presented before truncation occurs. This field is read-only.
MaxLabelLengthBeforeTruncation | Gets the maximum length of label that can be presented before truncation occurs. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | Description | Gets the description of the assertion failure.
Public property | Exceptions | Gets information about the exceptions.
Public property | InnerFailures | Gets the nested assertion failures that contributed to the composite assertion failure described by this instance.
Public property | LabeledValues | Gets formatted representations of labeled values as key/value pairs.
Public property | Message | Gets the user-supplied message about the assertion failure, or null if none.
Public property | StackTrace | Get the stack track of the failure, or null if none.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the failure as a string.
Public method | WriteTo | Writes the assertion failure to a test log stream.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | WriteDetails | Writes the details about the assertion failure to the structured text writer.
Top

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


AssertionFailure Constructor

AssertionFailure Constructor
[image]

Creates an assertion failure object.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal description As String, _
ByVal message As String, _
ByVal stackTrace As StackTraceData, _
ByVal labeledValues As IList(Of LabeledValue), _
ByVal exceptions As IList(Of ExceptionData), _
ByVal innerFailures As IList(Of AssertionFailure) _
)
C#
protected AssertionFailure(
string description,
string message,
StackTraceData stackTrace,
IList<LabeledValue> labeledValues,
IList<ExceptionData> exceptions,
IList<AssertionFailure> innerFailures
)
C++
protected:
AssertionFailure(
String description,
String message,
StackTraceData stackTrace,
IList<LabeledValue> labeledValues,
IList<ExceptionData> exceptions,
IList<AssertionFailure> innerFailures
) sealed
J#
protected AssertionFailure(
string description,
string message,
StackTraceData stackTrace,
IList<LabeledValue> labeledValues,
IList<ExceptionData> exceptions,
IList<AssertionFailure> innerFailures
)
JScript
protected function AssertionFailure(
description : String,
message : String,
stackTrace : StackTraceData,
labeledValues : IList<LabeledValue>,
exceptions : IList<ExceptionData>,
innerFailures : IList<AssertionFailure>
)

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


Fields

AssertionFailure Fields
[image]

Public Fields

Name | Description
MaxFormattedValueLength | Gets the maximum length of formatted value that can be presented before truncation occurs. This field is read-only.
MaxLabelLengthBeforeTruncation | Gets the maximum length of label that can be presented before truncation occurs. This field is read-only.
Top

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


MaxFormattedValueLength Field

AssertionFailure.MaxFormattedValueLength Field
[image]

Gets the maximum length of formatted value that can be presented before truncation occurs. This field is read-only.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxFormattedValueLength As Integer
C#
public static readonly int MaxFormattedValueLength;
C++
public:
static const int MaxFormattedValueLength;
J#
public static final int MaxFormattedValueLength
JScript
public static const var MaxFormattedValueLength : int;

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


MaxLabelLengthBeforeTruncation Field

AssertionFailure.MaxLabelLengthBeforeTruncation Field
[image]

Gets the maximum length of label that can be presented before truncation occurs. This field is read-only.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxLabelLengthBeforeTruncation As Integer
C#
public static readonly int MaxLabelLengthBeforeTruncation;
C++
public:
static const int MaxLabelLengthBeforeTruncation;
J#
public static final int MaxLabelLengthBeforeTruncation
JScript
public static const var MaxLabelLengthBeforeTruncation : int;

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


Properties

AssertionFailure Properties
[image]

Public Properties

 | Name | Description
Public property | Description | Gets the description of the assertion failure.
Public property | Exceptions | Gets information about the exceptions.
Public property | InnerFailures | Gets the nested assertion failures that contributed to the composite assertion failure described by this instance.
Public property | LabeledValues | Gets formatted representations of labeled values as key/value pairs.
Public property | Message | Gets the user-supplied message about the assertion failure, or null if none.
Public property | StackTrace | Get the stack track of the failure, or null if none.
Top

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


Description Property

AssertionFailure.Description Property
[image]

Gets the description of the assertion failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
C#
public string Description { get; }
C++
public property string Description sealed {
String get();
}
J#
/** property */
public string get_Description();
JScript
public function get Description() : String

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


Exceptions Property

AssertionFailure.Exceptions Property
[image]

Gets information about the exceptions.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exceptions As IList(Of ExceptionData)
C#
public IList<ExceptionData> Exceptions { get; }
C++
public property IList<ExceptionData> Exceptions sealed {
IList<ExceptionData> get();
}
J#
/** property */
public IList<ExceptionData> get_Exceptions();
JScript
public function get Exceptions() : IList<ExceptionData>

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


InnerFailures Property

AssertionFailure.InnerFailures Property
[image]

Gets the nested assertion failures that contributed to the composite assertion failure described by this instance.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerFailures As IList(Of AssertionFailure)
C#
public IList<AssertionFailure> InnerFailures { get; }
C++
public property IList<AssertionFailure> InnerFailures sealed {
IList<AssertionFailure> get();
}
J#
/** property */
public IList<AssertionFailure> get_InnerFailures();
JScript
public function get InnerFailures() : IList<AssertionFailure>

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


LabeledValues Property

AssertionFailure.LabeledValues Property
[image]

Gets formatted representations of labeled values as key/value pairs.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LabeledValues As IList(Of LabeledValue)
C#
public IList<LabeledValue> LabeledValues { get; }
C++
public property IList<LabeledValue> LabeledValues sealed {
IList<LabeledValue> get();
}
J#
/** property */
public IList<LabeledValue> get_LabeledValues();
JScript
public function get LabeledValues() : IList<LabeledValue>

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


Message Property

AssertionFailure.Message Property
[image]

Gets the user-supplied message about the assertion failure, or null if none.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
C++
public property string Message sealed {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


StackTrace Property

AssertionFailure.StackTrace Property
[image]

Get the stack track of the failure, or null if none.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StackTrace As StackTraceData
C#
public StackTraceData StackTrace { get; }
C++
public property StackTraceData StackTrace sealed {
StackTraceData get();
}
J#
/** property */
public StackTraceData get_StackTrace();
JScript
public function get StackTrace() : StackTraceData

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


Methods

AssertionFailure Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the failure as a string.
Public method | WriteTo | Writes the assertion failure to a test log stream.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | WriteDetails | Writes the details about the assertion failure to the structured text writer.
Top

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


ToString Method

AssertionFailure.ToString Method
[image]

Formats the failure as a string.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted string

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


WriteDetails Method

AssertionFailure.WriteDetails Method
[image]

Writes the details about the assertion failure to the structured text writer.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteDetails( _
ByVal writer As TestLogStreamWriter _
)
C#
protected virtual void WriteDetails(
TestLogStreamWriter writer
)
C++
protected:
virtual void WriteDetails(
TestLogStreamWriter writer
)
J#
protected virtual void WriteDetails(
TestLogStreamWriter writer
)
JScript
protected virtual function WriteDetails(
writer : TestLogStreamWriter
)

Parameters

writer
The structured text writer, not null

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


WriteTo Method

AssertionFailure.WriteTo Method
[image]

Writes the assertion failure to a test log stream.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public virtual void WriteTo(
TestLogStreamWriter writer
)
C++
public:
virtual void WriteTo(
TestLogStreamWriter writer
)
J#
public virtual void WriteTo(
TestLogStreamWriter writer
)
JScript
public virtual function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The test log stream

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

AssertionFailure Class
Gallio.Framework.Assertions Namespace


AssertionFailure.LabeledValue Structure

AssertionFailure.LabeledValue Structure
See Also Example Members
[image]

A labeled value describes a named assertion parameter.

The label indicates the purpose of the value, such as "Expected Value". The value itself should be formatted to emphasize structural characteristics.

For additional emphasis, such as for comparison purposes (ie. diffs), the value may be formatted as structured text to include highlights and other markup.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Structure AssertionFailure.LabeledValue
C#
[SerializableAttribute]
public struct AssertionFailure.LabeledValue
C++
[SerializableAttribute]
value class AssertionFailure.LabeledValue
J#
/** @attribute SerializableAttribute() */
public final class AssertionFailure.LabeledValue extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Framework.Assertions.AssertionFailure.LabeledValue

See Also

AssertionFailure.LabeledValue Members
Gallio.Framework.Assertions Namespace


AssertionFailure.LabeledValue Members

AssertionFailure.LabeledValue Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A labeled value describes a named assertion parameter.

The label indicates the purpose of the value, such as "Expected Value". The value itself should be formatted to emphasize structural characteristics.

For additional emphasis, such as for comparison purposes (ie. diffs), the value may be formatted as structured text to include highlights and other markup.

The following tables list the members exposed by AssertionFailure.LabeledValue.

Public Constructors

Name | Description
AssertionFailure.LabeledValue | Overloaded.
Top

Public Properties

 | Name | Description
Public property | FormattedValue | Gets the formatted value as structured text.
Public property | Label | Gets the label.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

Explicit Interface Implementations

Name | Description
AssertionFailure.LabeledValue | Overloaded.
Top

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


AssertionFailure.LabeledValue Constructor

AssertionFailure.LabeledValue Constructor

Overload List

 | Name | Description
Public method | AssertionFailure.LabeledValue (String, StructuredText) | Creates a labeled value with structured text.
Public method | AssertionFailure.LabeledValue (String, String) | Creates a labeled value with plain text.

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


AssertionFailure.LabeledValue Constructor (String, StructuredText)

AssertionFailure.LabeledValue Constructor (String, StructuredText)
See Also Example
[image]

Creates a labeled value with structured text.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal label As String, _
ByVal formattedValue As StructuredText _
)
C#
public AssertionFailure.LabeledValue(
string label,
StructuredText formattedValue
)
C++
public:
AssertionFailure.LabeledValue(
String label,
StructuredText formattedValue
) sealed
J#
public AssertionFailure.LabeledValue(
string label,
StructuredText formattedValue
)
JScript
public function AssertionFailure.LabeledValue(
label : String,
formattedValue : StructuredText
)

Parameters

label
The label
formattedValue
The formatted value as structured text

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if label or formattedValue is null
ArgumentException | Thrown if label is empty

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace
AssertionFailure.LabeledValue Constructor Overload List


AssertionFailure.LabeledValue Constructor (String, String)

AssertionFailure.LabeledValue Constructor (String, String)
See Also Example
[image]

Creates a labeled value with plain text.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal label As String, _
ByVal formattedValue As String _
)
C#
public AssertionFailure.LabeledValue(
string label,
string formattedValue
)
C++
public:
AssertionFailure.LabeledValue(
String label,
String formattedValue
) sealed
J#
public AssertionFailure.LabeledValue(
string label,
string formattedValue
)
JScript
public function AssertionFailure.LabeledValue(
label : String,
formattedValue : String
)

Parameters

label
The label
formattedValue
The formatted value as plain text

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if label or formattedValue is null
ArgumentException | Thrown if label is empty

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace
AssertionFailure.LabeledValue Constructor Overload List


Properties

AssertionFailure.LabeledValue Properties
[image]

Public Properties

 | Name | Description
Public property | FormattedValue | Gets the formatted value as structured text.
Public property | Label | Gets the label.
Top

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


FormattedValue Property

AssertionFailure.LabeledValue.FormattedValue Property
[image]

Gets the formatted value as structured text.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FormattedValue As StructuredText
C#
public StructuredText FormattedValue { get; }
C++
public property StructuredText FormattedValue sealed {
StructuredText get();
}
J#
/** property */
public StructuredText get_FormattedValue();
JScript
public function get FormattedValue() : StructuredText

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


Label Property

AssertionFailure.LabeledValue.Label Property
[image]

Gets the label.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As String
C#
public string Label { get; }
C++
public property string Label sealed {
String get();
}
J#
/** property */
public string get_Label();
JScript
public function get Label() : String

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


Methods

AssertionFailure.LabeledValue Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


ToString Method

AssertionFailure.LabeledValue.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

AssertionFailure.LabeledValue Structure
Gallio.Framework.Assertions Namespace


AssertionFailureBehavior Enumeration

AssertionFailureBehavior Enumeration
[image]

Specifies the behavior that should take place when a AssertionFailure is submitted to the AssertionContext.

There are three orthogonal dimensions to the assertion failure behavior:

  • Log / No-Log: Log the failure when reported, or do not log it.
  • Throw / No-Throw: Throw an exception to abort computation, or allow it to continue
  • Discard / No-Discard (aka. CaptureAndContinue): Discard the failure when finished reporting it, or capture it in a list for further processing

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum AssertionFailureBehavior
C#
[FlagsAttribute]
public enum AssertionFailureBehavior
C++
[FlagsAttribute]
public enum class AssertionFailureBehavior
J#
/** @attribute FlagsAttribute() */
public enum AssertionFailureBehavior
JScript
public enum AssertionFailureBehavior

Members

Member Name | Description | Value
Log | When an assertion failure is reported, capture it in a list, log it, and allow the computation to continue. | 1
Throw | When an assertion failure is reported, capture it in a list, then throw an AssertionFailureException to immediately abort the current computation. | 2
LogAndThrow

When an assertion failure is reported, capture it in a list, log it, then throw an AssertionFailureException to immediately abort the current computation.

This is the default behavior for assertion contexts.

3
Discard | When an assertion failure is reported, discard it (instead of capturing it in a list) and allow the current computation to continue. | 4
CaptureAndContinue

When an assertion failure is reported, capture it in a list and allow the current computation to continue.

This is the opposite of Discard, and is an alias for the case where none of the other flags are specified.

0

See Also

Gallio.Framework.Assertions Namespace


AssertionFailureBuilder Class

AssertionFailureBuilder Class
See Also Example Members
[image]

An assertion failure builder is used to construct a complete description of an assertion failure that has occurred. It takes into account information about the expected and actual value, as well as additional labeled values and exceptions.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class AssertionFailureBuilder
C#
public class AssertionFailureBuilder
C++
ref class AssertionFailureBuilder
J#
public class AssertionFailureBuilder
JScript
public class AssertionFailureBuilder

Inheritance Hierarchy

System.Object
Gallio.Framework.Assertions.AssertionFailureBuilder

See Also

AssertionFailureBuilder Members
Gallio.Framework.Assertions Namespace


AssertionFailureBuilder Members

AssertionFailureBuilder Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

An assertion failure builder is used to construct a complete description of an assertion failure that has occurred. It takes into account information about the expected and actual value, as well as additional labeled values and exceptions.

The following tables list the members exposed by AssertionFailureBuilder.

Public Constructors

Name | Description
AssertionFailureBuilder | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Formatter | Gets the formatted used by the builder.
Top

Public Methods

Name | Description
Public method | AddException | Overloaded. Adds an exception to the assertion failure.
Public method | AddInnerFailure | Adds a nested assertion failure that contributed to the composite assertion failure described by this instance.
Public method | AddInnerFailures | Adds an enumeration of nested assertion failures that contributed to the composite assertion failure described by this instance.
Public method AddLabeledValue Overloaded.

Adds a labeled value.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Public method AddRawActualValue

Adds the raw actual value to be formatted using Formatter.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Public method AddRawExpectedAndActualValuesWithDiffs

Adds the raw expected and actual values to be formatted using Formatter and includes formatting of their differences.

The order in which this method is called determines the order in which the values will appear relative to other labeled values.

Public method AddRawExpectedValue

Adds the raw expected value to be formatted using Formatter.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Public method AddRawLabeledValue

Adds a raw labeled value to be formatted using Formatter.

The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.

Public method AddRawLabeledValuesWithDiffs

Adds two raw labeled values formatted using Formatter and includes formatting of their differences.

The order in which this method is called determines the order in which the values will appear relative to other labeled values.

Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetMessage | Overloaded. Sets the user-supplied assertion failure message.
Public method | SetStackTrace | Sets the stack trace.
Public method | ToAssertionFailure | Generates an immutable object that describes the failure.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateAssertionFailure | Creates an assertion failure object.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AssertionFailureBuilder | Overloaded.
Top

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AssertionFailureBuilder Constructor

AssertionFailureBuilder Constructor

Overload List

 | Name | Description
Public method | AssertionFailureBuilder (String) | Creates an assertion failure builder with the default formatter.
Public method | AssertionFailureBuilder (String, IFormatter) | Creates an assertion failure builder with the specified formatter.

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AssertionFailureBuilder Constructor (String)

AssertionFailureBuilder Constructor (String)
See Also Example
[image]

Creates an assertion failure builder with the default formatter.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal description As String _
)
C#
public AssertionFailureBuilder(
string description
)
C++
public:
AssertionFailureBuilder(
String description
) sealed
J#
public AssertionFailureBuilder(
string description
)
JScript
public function AssertionFailureBuilder(
description : String
)

Parameters

description
The description of the failure

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if description is null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder Constructor Overload List


AssertionFailureBuilder Constructor (String, IFormatter)

AssertionFailureBuilder Constructor (String, IFormatter)
See Also Example
[image]

Creates an assertion failure builder with the specified formatter.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal description As String, _
ByVal formatter As IFormatter _
)
C#
public AssertionFailureBuilder(
string description,
IFormatter formatter
)
C++
public:
AssertionFailureBuilder(
String description,
IFormatter formatter
) sealed
J#
public AssertionFailureBuilder(
string description,
IFormatter formatter
)
JScript
public function AssertionFailureBuilder(
description : String,
formatter : IFormatter
)

Parameters

description
The description of the failure
formatter
The formatter to use

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if description or formatter is null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder Constructor Overload List


Properties

AssertionFailureBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | Formatter | Gets the formatted used by the builder.
Top

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


Formatter Property

AssertionFailureBuilder.Formatter Property
[image]

Gets the formatted used by the builder.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Formatter As IFormatter
C#
public IFormatter Formatter { get; }
C++
public property IFormatter Formatter sealed {
IFormatter get();
}
J#
/** property */
public IFormatter get_Formatter();
JScript
public function get Formatter() : IFormatter

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


Methods

AssertionFailureBuilder Methods
[image]

Public Methods

Name | Description
Public method | AddException | Overloaded. Adds an exception to the assertion failure.
Public method | AddInnerFailure | Adds a nested assertion failure that contributed to the composite assertion failure described by this instance.
Public method | AddInnerFailures | Adds an enumeration of nested assertion failures that contributed to the composite assertion failure described by this instance.
Public method AddLabeledValue Overloaded.

Adds a labeled value.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Public method AddRawActualValue

Adds the raw actual value to be formatted using Formatter.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Public method AddRawExpectedAndActualValuesWithDiffs

Adds the raw expected and actual values to be formatted using Formatter and includes formatting of their differences.

The order in which this method is called determines the order in which the values will appear relative to other labeled values.

Public method AddRawExpectedValue

Adds the raw expected value to be formatted using Formatter.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Public method AddRawLabeledValue

Adds a raw labeled value to be formatted using Formatter.

The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.

Public method AddRawLabeledValuesWithDiffs

Adds two raw labeled values formatted using Formatter and includes formatting of their differences.

The order in which this method is called determines the order in which the values will appear relative to other labeled values.

Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetMessage | Overloaded. Sets the user-supplied assertion failure message.
Public method | SetStackTrace | Sets the stack trace.
Public method | ToAssertionFailure | Generates an immutable object that describes the failure.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateAssertionFailure | Creates an assertion failure object.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddException Method

AssertionFailureBuilder.AddException Method

Adds an exception to the assertion failure.

Overload List

 | Name | Description
Public method | AddException (ExceptionData) | Adds an exception to the assertion failure.
Public method | AddException (Exception) | Adds an exception to the assertion failure.

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddException Method (ExceptionData)

AssertionFailureBuilder.AddException Method (ExceptionData)
See Also Example
[image]

Adds an exception to the assertion failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddException( _
ByVal ex As ExceptionData _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddException(
ExceptionData ex
)
C++
public:
AssertionFailureBuilder AddException(
ExceptionData ex
) sealed
J#
public AssertionFailureBuilder AddException(
ExceptionData ex
)
JScript
public function AddException(
ex : ExceptionData
) : AssertionFailureBuilder

Parameters

ex
The exception data to add

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if ex is null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.AddException Overload List


AddException Method (Exception)

AssertionFailureBuilder.AddException Method (Exception)
See Also Example
[image]

Adds an exception to the assertion failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddException( _
ByVal ex As Exception _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddException(
Exception ex
)
C++
public:
AssertionFailureBuilder AddException(
Exception ex
) sealed
J#
public AssertionFailureBuilder AddException(
Exception ex
)
JScript
public function AddException(
ex : Exception
) : AssertionFailureBuilder

Parameters

ex
The exception to add

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if ex is null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.AddException Overload List


AddInnerFailure Method

AssertionFailureBuilder.AddInnerFailure Method
[image]

Adds a nested assertion failure that contributed to the composite assertion failure described by this instance.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddInnerFailure( _
ByVal innerFailure As AssertionFailure _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddInnerFailure(
AssertionFailure innerFailure
)
C++
public:
AssertionFailureBuilder AddInnerFailure(
AssertionFailure innerFailure
) sealed
J#
public AssertionFailureBuilder AddInnerFailure(
AssertionFailure innerFailure
)
JScript
public function AddInnerFailure(
innerFailure : AssertionFailure
) : AssertionFailureBuilder

Parameters

innerFailure
The inner assertion failure to add

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if innerFailure is null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddInnerFailures Method

AssertionFailureBuilder.AddInnerFailures Method
[image]

Adds an enumeration of nested assertion failures that contributed to the composite assertion failure described by this instance.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddInnerFailures( _
ByVal innerFailures As IEnumerable(Of AssertionFailure) _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddInnerFailures(
IEnumerable<AssertionFailure> innerFailures
)
C++
public:
AssertionFailureBuilder AddInnerFailures(
IEnumerable<AssertionFailure> innerFailures
) sealed
J#
public AssertionFailureBuilder AddInnerFailures(
IEnumerable<AssertionFailure> innerFailures
)
JScript
public function AddInnerFailures(
innerFailures : IEnumerable<AssertionFailure>
) : AssertionFailureBuilder

Parameters

innerFailures
The enumeration of inner assertion failures to add

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if innerFailures is null or contains a null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddLabeledValue Method

AssertionFailureBuilder.AddLabeledValue Method

Adds a labeled value.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Overload List

 | Name | Description
Public method | AddLabeledValue (AssertionFailure.LabeledValue) | Adds a labeled value. The order in which this method is called determines the order in which this value will appear relative to other labeled values.
Public method | AddLabeledValue (String, StructuredText) | Adds a labeled value as structured text. The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.
Public method | AddLabeledValue (String, String) | Adds a labeled value as plain text. The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddLabeledValue Method (AssertionFailure.LabeledValue)

AssertionFailureBuilder.AddLabeledValue Method (AssertionFailure.LabeledValue)
See Also Example
[image]

Adds a labeled value.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddLabeledValue( _
ByVal labeledValue As AssertionFailure.LabeledValue _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddLabeledValue(
AssertionFailure.LabeledValue labeledValue
)
C++
public:
AssertionFailureBuilder AddLabeledValue(
AssertionFailure.LabeledValue labeledValue
) sealed
J#
public AssertionFailureBuilder AddLabeledValue(
AssertionFailure.LabeledValue labeledValue
)
JScript
public function AddLabeledValue(
labeledValue : AssertionFailure.LabeledValue
) : AssertionFailureBuilder

Parameters

labeledValue
The labeled value

Return Value

The builder, to allow for fluent method chaining

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.AddLabeledValue Overload List


AddLabeledValue Method (String, StructuredText)

AssertionFailureBuilder.AddLabeledValue Method (String, StructuredText)
See Also Example
[image]

Adds a labeled value as structured text.

The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddLabeledValue( _
ByVal label As String, _
ByVal formattedValue As StructuredText _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddLabeledValue(
string label,
StructuredText formattedValue
)
C++
public:
AssertionFailureBuilder AddLabeledValue(
String label,
StructuredText formattedValue
) sealed
J#
public AssertionFailureBuilder AddLabeledValue(
string label,
StructuredText formattedValue
)
JScript
public function AddLabeledValue(
label : String,
formattedValue : StructuredText
) : AssertionFailureBuilder

Parameters

label
The label
formattedValue
The formatted value as structured text

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if label or formattedValue is null
ArgumentException | Thrown if label is empty

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.AddLabeledValue Overload List


AddLabeledValue Method (String, String)

AssertionFailureBuilder.AddLabeledValue Method (String, String)
See Also Example
[image]

Adds a labeled value as plain text.

The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddLabeledValue( _
ByVal label As String, _
ByVal formattedValue As String _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddLabeledValue(
string label,
string formattedValue
)
C++
public:
AssertionFailureBuilder AddLabeledValue(
String label,
String formattedValue
) sealed
J#
public AssertionFailureBuilder AddLabeledValue(
string label,
string formattedValue
)
JScript
public function AddLabeledValue(
label : String,
formattedValue : String
) : AssertionFailureBuilder

Parameters

label
The label
formattedValue
The formatted value

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if label or formattedValue is null
ArgumentException | Thrown if label is empty

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.AddLabeledValue Overload List


AddRawActualValue Method

AssertionFailureBuilder.AddRawActualValue Method
[image]

Adds the raw actual value to be formatted using Formatter.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddRawActualValue( _
ByVal actualValue As Object _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddRawActualValue(
object actualValue
)
C++
public:
AssertionFailureBuilder AddRawActualValue(
Object actualValue
) sealed
J#
public AssertionFailureBuilder AddRawActualValue(
object actualValue
)
JScript
public function AddRawActualValue(
actualValue : Object
) : AssertionFailureBuilder

Parameters

actualValue
The actual value

Return Value

The builder, to allow for fluent method chaining

Remarks

This is a convenience method for setting a labeled value called "Actual Value".

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddRawExpectedAndActualValuesWithDiffs Method

AssertionFailureBuilder.AddRawExpectedAndActualValuesWithDiffs Method
See Also Example
[image]

Adds the raw expected and actual values to be formatted using Formatter and includes formatting of their differences.

The order in which this method is called determines the order in which the values will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddRawExpectedAndActualValuesWithDiffs( _
ByVal expectedValue As Object, _
ByVal actualValue As Object _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddRawExpectedAndActualValuesWithDiffs(
object expectedValue,
object actualValue
)
C++
public:
AssertionFailureBuilder AddRawExpectedAndActualValuesWithDiffs(
Object expectedValue,
Object actualValue
) sealed
J#
public AssertionFailureBuilder AddRawExpectedAndActualValuesWithDiffs(
object expectedValue,
object actualValue
)
JScript
public function AddRawExpectedAndActualValuesWithDiffs(
expectedValue : Object,
actualValue : Object
) : AssertionFailureBuilder

Parameters

expectedValue
The expected value
actualValue
The actual value

Return Value

The builder, to allow for fluent method chaining

Remarks

This is a convenience method for setting a pair of labeled values called "Expected Value" and "Actual Value" with diffs.

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddRawExpectedValue Method

AssertionFailureBuilder.AddRawExpectedValue Method
[image]

Adds the raw expected value to be formatted using Formatter.

The order in which this method is called determines the order in which this value will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddRawExpectedValue( _
ByVal expectedValue As Object _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddRawExpectedValue(
object expectedValue
)
C++
public:
AssertionFailureBuilder AddRawExpectedValue(
Object expectedValue
) sealed
J#
public AssertionFailureBuilder AddRawExpectedValue(
object expectedValue
)
JScript
public function AddRawExpectedValue(
expectedValue : Object
) : AssertionFailureBuilder

Parameters

expectedValue
The expected value

Return Value

The builder, to allow for fluent method chaining

Remarks

This is a convenience method for setting a labeled value called "Expected Value".

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddRawLabeledValue Method

AssertionFailureBuilder.AddRawLabeledValue Method
[image]

Adds a raw labeled value to be formatted using Formatter.

The order in which this method is called determines the order in which this labeled value will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddRawLabeledValue( _
ByVal label As String, _
ByVal value As Object _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddRawLabeledValue(
string label,
object value
)
C++
public:
AssertionFailureBuilder AddRawLabeledValue(
String label,
Object value
) sealed
J#
public AssertionFailureBuilder AddRawLabeledValue(
string label,
object value
)
JScript
public function AddRawLabeledValue(
label : String,
value : Object
) : AssertionFailureBuilder

Parameters

label
The label
value
The raw unformatted value

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if label is null
ArgumentException | Thrown if label is empty

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AddRawLabeledValuesWithDiffs Method

AssertionFailureBuilder.AddRawLabeledValuesWithDiffs Method
[image]

Adds two raw labeled values formatted using Formatter and includes formatting of their differences.

The order in which this method is called determines the order in which the values will appear relative to other labeled values.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddRawLabeledValuesWithDiffs( _
ByVal leftLabel As String, _
ByVal leftValue As Object, _
ByVal rightLabel As String, _
ByVal rightValue As Object _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder AddRawLabeledValuesWithDiffs(
string leftLabel,
object leftValue,
string rightLabel,
object rightValue
)
C++
public:
AssertionFailureBuilder AddRawLabeledValuesWithDiffs(
String leftLabel,
Object leftValue,
String rightLabel,
Object rightValue
) sealed
J#
public AssertionFailureBuilder AddRawLabeledValuesWithDiffs(
string leftLabel,
object leftValue,
string rightLabel,
object rightValue
)
JScript
public function AddRawLabeledValuesWithDiffs(
leftLabel : String,
leftValue : Object,
rightLabel : String,
rightValue : Object
) : AssertionFailureBuilder

Parameters

leftLabel
The left label
leftValue
The left value
rightLabel
The right label
rightValue
The right value

Return Value

The builder, to allow for fluent method chaining

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if leftLabel or rightLabel is null

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


CreateAssertionFailure Method

AssertionFailureBuilder.CreateAssertionFailure Method
[image]

Creates an assertion failure object.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateAssertionFailure( _
ByVal description As String, _
ByVal message As String, _
ByVal stackTrace As StackTraceData, _
ByVal labeledValues As IList(Of LabeledValue), _
ByVal exceptions As IList(Of ExceptionData), _
ByVal innerFailures As IList(Of AssertionFailure) _
) As AssertionFailure
C#
protected virtual AssertionFailure CreateAssertionFailure(
string description,
string message,
StackTraceData stackTrace,
IList<LabeledValue> labeledValues,
IList<ExceptionData> exceptions,
IList<AssertionFailure> innerFailures
)
C++
protected:
virtual AssertionFailure CreateAssertionFailure(
String description,
String message,
StackTraceData stackTrace,
IList<LabeledValue> labeledValues,
IList<ExceptionData> exceptions,
IList<AssertionFailure> innerFailures
)
J#
protected virtual AssertionFailure CreateAssertionFailure(
string description,
string message,
StackTraceData stackTrace,
IList<LabeledValue> labeledValues,
IList<ExceptionData> exceptions,
IList<AssertionFailure> innerFailures
)
JScript
protected virtual function CreateAssertionFailure(
description : String,
message : String,
stackTrace : StackTraceData,
labeledValues : IList<LabeledValue>,
exceptions : IList<ExceptionData>,
innerFailures : IList<AssertionFailure>
) : AssertionFailure

Remarks

Subclasses may override this method to define custom extended assertion failure objects.

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


SetMessage Method

AssertionFailureBuilder.SetMessage Method

Sets the user-supplied assertion failure message.

Overload List

 | Name | Description
Public method | SetMessage (String) | Sets the user-supplied assertion failure message.
Public method | SetMessage (String, Object) | Sets the user-supplied assertion failure message to a formatted value.

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


SetMessage Method (String)

AssertionFailureBuilder.SetMessage Method (String)
See Also Example
[image]

Sets the user-supplied assertion failure message.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMessage( _
ByVal message As String _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder SetMessage(
string message
)
C++
public:
AssertionFailureBuilder SetMessage(
String message
) sealed
J#
public AssertionFailureBuilder SetMessage(
string message
)
JScript
public function SetMessage(
message : String
) : AssertionFailureBuilder

Parameters

message
The user-supplied assertion failure message, or null if none

Return Value

The builder, to allow for fluent method chaining

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.SetMessage Overload List


SetMessage Method (String, Object[])

AssertionFailureBuilder.SetMessage Method (String, Object[])
See Also Example
[image]

Sets the user-supplied assertion failure message to a formatted value.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SetMessage( _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder SetMessage(
string messageFormat,
params object[] messageArgs
)
C++
public:
AssertionFailureBuilder SetMessage(
String messageFormat,
... array<Object>^ messageArgs
) sealed
J#
public AssertionFailureBuilder SetMessage(
string messageFormat,
object[] messageArgs
)
JScript
public function SetMessage(
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
) : AssertionFailureBuilder

Parameters

messageFormat
The user-supplied assertion failure message format string, or null if none
messageArgs
The format arguments, or null or empty if none

Return Value

The builder, to allow for fluent method chaining

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace
AssertionFailureBuilder.SetMessage Overload List


SetStackTrace Method

AssertionFailureBuilder.SetStackTrace Method
[image]

Sets the stack trace.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SetStackTrace( _
ByVal stackTrace As StackTraceData _
) As AssertionFailureBuilder
C#
public AssertionFailureBuilder SetStackTrace(
StackTraceData stackTrace
)
C++
public:
AssertionFailureBuilder SetStackTrace(
StackTraceData stackTrace
) sealed
J#
public AssertionFailureBuilder SetStackTrace(
StackTraceData stackTrace
)
JScript
public function SetStackTrace(
stackTrace : StackTraceData
) : AssertionFailureBuilder

Parameters

stackTrace
The stack trace, or null if none

Return Value

The builder, to allow for fluent method chaining

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


ToAssertionFailure Method

AssertionFailureBuilder.ToAssertionFailure Method
[image]

Generates an immutable object that describes the failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public Function ToAssertionFailure() As AssertionFailure
C#
[TestFrameworkInternalAttribute]
public AssertionFailure ToAssertionFailure()
C++
[TestFrameworkInternalAttribute]
public:
AssertionFailure ToAssertionFailure() sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public AssertionFailure ToAssertionFailure()
JScript
public

TestFrameworkInternalAttribute
function ToAssertionFailure() : AssertionFailure

Return Value

The assertion failure

See Also

AssertionFailureBuilder Class
Gallio.Framework.Assertions Namespace


AssertionFailureException Class

AssertionFailureException Class
See Also Example Members
[image]

An exception type that wraps a AssertionFailure.

This exception is used in two ways:

  • The exception may be "silent" when it is used to cause a test to terminate due to an assertion failure that has already been logged or otherwise conveyed to the user.
  • Otherwise the exception will be reported the user in the typical manner.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AssertionFailureException
Inherits AssertionException
C#
[SerializableAttribute]
public class AssertionFailureException : AssertionException
C++
[SerializableAttribute]
ref class AssertionFailureException : AssertionException
J#
/** @attribute SerializableAttribute() */
public class AssertionFailureException extends AssertionException
JScript
public
SerializableAttribute
class AssertionFailureException extends AssertionException

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.TestException
Gallio.Framework.TestFailedException
Gallio.Framework.Assertions.AssertionException
Gallio.Framework.Assertions.AssertionFailureException

See Also

AssertionFailureException Members
Gallio.Framework.Assertions Namespace


AssertionFailureException Members

AssertionFailureException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

An exception type that wraps a AssertionFailure.

This exception is used in two ways:

  • The exception may be "silent" when it is used to cause a test to terminate due to an assertion failure that has already been logged or otherwise conveyed to the user.
  • Otherwise the exception will be reported the user in the typical manner.

The following tables list the members exposed by AssertionFailureException.

Public Constructors

Name | Description
AssertionFailureException | Overloaded.
Top

Protected Constructors

Name | Description
AssertionFailureException | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Overridden. Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.
Public property | Failure | Gets the associated assertion failure, never null.
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | IsSilent | Returns true if the assertion failure exception should not be logged because the information it contains has already been conveyed to the user.
Public property | Message | Overridden. Gets a message that describes the current exception.
Public property | Outcome | Returns Failed. (inherited from TestFailedException)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AssertionFailureException | Overloaded.
Top

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


AssertionFailureException Constructor

AssertionFailureException Constructor

Overload List

 | Name | Description
Public method | AssertionFailureException (AssertionFailure, Boolean) | Creates an exception for a given assertion failure.
Family method | AssertionFailureException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


AssertionFailureException Constructor (AssertionFailure, Boolean)

AssertionFailureException Constructor (AssertionFailure, Boolean)
See Also Example
[image]

Creates an exception for a given assertion failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal failure As AssertionFailure, _
ByVal silent As Boolean _
)
C#
public AssertionFailureException(
AssertionFailure failure,
bool silent
)
C++
public:
AssertionFailureException(
AssertionFailure failure,
bool silent
) sealed
J#
public AssertionFailureException(
AssertionFailure failure,
bool silent
)
JScript
public function AssertionFailureException(
failure : AssertionFailure,
silent : bool
)

Parameters

failure
The assertion failure
silent
True if the assertion failure exception should not be logged because the information it contains has already been conveyed to the user

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if failure is null

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace
AssertionFailureException Constructor Overload List


AssertionFailureException Constructor (SerializationInfo, StreamingContext)

AssertionFailureException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected AssertionFailureException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
AssertionFailureException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected AssertionFailureException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function AssertionFailureException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace
AssertionFailureException Constructor Overload List


Properties

AssertionFailureException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExcludeStackTrace | Overridden. Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.
Public property | Failure | Gets the associated assertion failure, never null.
Public property | HasNonDefaultMessage | Returns true if the test exception has a non-default message (the message parameter was not null in the constructor arguments). (inherited from TestException)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | IsSilent | Returns true if the assertion failure exception should not be logged because the information it contains has already been conveyed to the user.
Public property | Message | Overridden. Gets a message that describes the current exception.
Public property | Outcome | Returns Failed. (inherited from TestFailedException)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


ExcludeStackTrace Property

AssertionFailureException.ExcludeStackTrace Property
[image]

Returns true if the outcome and message (if any) should be used but the exception stack trace should not be logged.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ExcludeStackTrace As Boolean
C#
public override bool ExcludeStackTrace { get; }
C++
public override property bool ExcludeStackTrace override {
bool get();
}
J#
/** property */
public bool get_ExcludeStackTrace();
JScript
public function get ExcludeStackTrace() : bool

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


Failure Property

AssertionFailureException.Failure Property
[image]

Gets the associated assertion failure, never null.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Failure As AssertionFailure
C#
public AssertionFailure Failure { get; }
C++
public property AssertionFailure Failure sealed {
AssertionFailure get();
}
J#
/** property */
public AssertionFailure get_Failure();
JScript
public function get Failure() : AssertionFailure

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


IsSilent Property

AssertionFailureException.IsSilent Property
[image]

Returns true if the assertion failure exception should not be logged because the information it contains has already been conveyed to the user.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSilent As Boolean
C#
public bool IsSilent { get; }
C++
public property bool IsSilent sealed {
bool get();
}
J#
/** property */
public bool get_IsSilent();
JScript
public function get IsSilent() : bool

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


Message Property

AssertionFailureException.Message Property
[image]

Gets a message that describes the current exception.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message { get; }
C++
public override property string Message override {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

Property Value

The error message that explains the reason for the exception, or an empty string("").

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


Methods

AssertionFailureException Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden. When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


GetObjectData Method

AssertionFailureException.GetObjectData Method
[image]

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
C++
public:
virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
) override
J#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
JScript
public override function GetObjectData(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable.GetObjectData

See Also

AssertionFailureException Class
Gallio.Framework.Assertions Namespace


AssertionHelper Class

AssertionHelper Class
See Also Example Members
[image]

Provides utilities to assist with the implementation of new asserts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public MustInherit Class AssertionHelper
C#
[TestFrameworkInternalAttribute]
public abstract class AssertionHelper
C++
[TestFrameworkInternalAttribute]
ref class AssertionHelper abstract
J#
/** @attribute TestFrameworkInternalAttribute() */
public class AssertionHelper
JScript
public
TestFrameworkInternalAttribute
class AssertionHelper

Inheritance Hierarchy

System.Object
Gallio.Framework.Assertions.AssertionHelper

See Also

AssertionHelper Members
Gallio.Framework.Assertions Namespace


AssertionHelper Members

AssertionHelper Members
See Also Example Constructors Methods
[image]

Provides utilities to assist with the implementation of new asserts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AssertionHelper.

Protected Constructors

 | Name | Description
Family method | AssertionHelper | Initializes a new instance of the AssertionHelper class.
Top

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Eval Overloaded.

Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

The assertion failure behavior while the action runs is Throw so the action terminates on the first failure. The assertion failure itself is returned but it is not logged.

This method is very useful for composing assertions because it enables assertions to be evaluated, and, when they fail, the failure can be recorded as an inner assertion failure of some larger composite assertion. For example, this makes it possible to create an assertion over a collection of items by composing an assertion over a single item.

Fail | Submits a failure if the assertion failure object is non-null.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Verify

Verifies that an assertion succeeded.

If the assertion function returns null then the assertion is deemed to have passed. If it returns an AssertionFailure or throws an exception, then is is deemed to have failed.

When an assertion failure is detected, it is submitted to SubmitFailure which may choose to throw a AssertionFailureException or do something else.

Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace


AssertionHelper Constructor

AssertionHelper Constructor
[image]

Initializes a new instance of the AssertionHelper class.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected AssertionHelper()
C++
protected:
AssertionHelper() sealed
J#
protected AssertionHelper()
JScript
protected function AssertionHelper()

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace


Methods

AssertionHelper Methods
[image]

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Eval Overloaded.

Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

The assertion failure behavior while the action runs is Throw so the action terminates on the first failure. The assertion failure itself is returned but it is not logged.

This method is very useful for composing assertions because it enables assertions to be evaluated, and, when they fail, the failure can be recorded as an inner assertion failure of some larger composite assertion. For example, this makes it possible to create an assertion over a collection of items by composing an assertion over a single item.

Fail | Submits a failure if the assertion failure object is non-null.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Verify

Verifies that an assertion succeeded.

If the assertion function returns null then the assertion is deemed to have passed. If it returns an AssertionFailure or throws an exception, then is is deemed to have failed.

When an assertion failure is detected, it is submitted to SubmitFailure which may choose to throw a AssertionFailureException or do something else.

Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace


Eval Method

AssertionHelper.Eval Method

Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

The assertion failure behavior while the action runs is Throw so the action terminates on the first failure. The assertion failure itself is returned but it is not logged.

This method is very useful for composing assertions because it enables assertions to be evaluated, and, when they fail, the failure can be recorded as an inner assertion failure of some larger composite assertion. For example, this makes it possible to create an assertion over a collection of items by composing an assertion over a single item.

Overload List

Name | Description
Eval (Action)

Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

The assertion failure behavior while the action runs is Throw so the action terminates on the first failure. The assertion failure itself is returned but it is not logged.

This method is very useful for composing assertions because it enables assertions to be evaluated, and, when they fail, the failure can be recorded as an inner assertion failure of some larger composite assertion. For example, this makes it possible to create an assertion over a collection of items by composing an assertion over a single item.

Eval (Action, AssertionFailureBehavior) | Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace


Eval Method (Action)

AssertionHelper.Eval Method (Action)
See Also Example
[image]

Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

The assertion failure behavior while the action runs is Throw so the action terminates on the first failure. The assertion failure itself is returned but it is not logged.

This method is very useful for composing assertions because it enables assertions to be evaluated, and, when they fail, the failure can be recorded as an inner assertion failure of some larger composite assertion. For example, this makes it possible to create an assertion over a collection of items by composing an assertion over a single item.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Eval( _
ByVal action As Action _
) As AssertionFailure()
C#
public static AssertionFailure[] Eval(
Action action
)
C++
public:
static array<AssertionFailure>^ Eval(
Action action
)
J#
public static AssertionFailure[] Eval(
Action action
)
JScript
public static function Eval(
action : Action
) : AssertionFailure[]

Parameters

action
The action to invoke

Return Value

The array of failures, may be empty if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace
AssertionHelper.Eval Overload List


Eval Method (Action, AssertionFailureBehavior)

AssertionHelper.Eval Method (Action, AssertionFailureBehavior)
See Also Example
[image]

Performs an action and returns an array containing the assertion failures that were observed within the block. If the block throws an exception, it is reified as an assertion failure.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Eval( _
ByVal action As Action, _
ByVal assertionFailureBehavior As AssertionFailureBehavior _
) As AssertionFailure()
C#
public static AssertionFailure[] Eval(
Action action,
AssertionFailureBehavior assertionFailureBehavior
)
C++
public:
static array<AssertionFailure>^ Eval(
Action action,
AssertionFailureBehavior assertionFailureBehavior
)
J#
public static AssertionFailure[] Eval(
Action action,
AssertionFailureBehavior assertionFailureBehavior
)
JScript
public static function Eval(
action : Action,
assertionFailureBehavior : AssertionFailureBehavior
) : AssertionFailure[]

Parameters

action
The action to invoke
assertionFailureBehavior
The assertion failure behavior to use while the action runs

Return Value

The array of failures, may be empty if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace
AssertionHelper.Eval Overload List


Fail Method

AssertionHelper.Fail Method
[image]

Submits a failure if the assertion failure object is non-null.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Fail( _
ByVal failure As AssertionFailure _
)
C#
public static void Fail(
AssertionFailure failure
)
C++
public:
static void Fail(
AssertionFailure failure
)
J#
public static void Fail(
AssertionFailure failure
)
JScript
public static function Fail(
failure : AssertionFailure
)

Parameters

failure
Failure to be submited, or null if none

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace


Verify Method

AssertionHelper.Verify Method
[image]

Verifies that an assertion succeeded.

If the assertion function returns null then the assertion is deemed to have passed. If it returns an AssertionFailure or throws an exception, then is is deemed to have failed.

When an assertion failure is detected, it is submitted to SubmitFailure which may choose to throw a AssertionFailureException or do something else.

Namespace: Gallio.Framework.Assertions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Verify( _
ByVal assertionFunc As Func(Of AssertionFailure) _
)
C#
public static void Verify(
Func<AssertionFailure> assertionFunc
)
C++
public:
static void Verify(
Func<AssertionFailure> assertionFunc
)
J#
public static void Verify(
Func<AssertionFailure> assertionFunc
)
JScript
public static function Verify(
assertionFunc : Func<AssertionFailure>
)

Parameters

assertionFunc
The assertion function to evaluate

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assertionFunc is null

Remarks

Using this method enables the system to track statistics about assertions and to ensure that assertion failures are reported uniformly.

It is important to note that not all failures will result in a AssertionFailureException being thrown. Refer to SubmitFailure for details.

See Also

AssertionHelper Class
Gallio.Framework.Assertions Namespace


Gallio.Framework.Conversions

Gallio.Framework.Conversions Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ArrayToArrayConversionRule | Converts arrays from one-dimensional arrays of one element type to another. This class cannot be inherited.
Public class | BaseConverter | An abstract base class implementation of IConverter that mostly validates arguments and provides a default implement for CanConvert based on GetConversionCost. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | Converter | Service locator for IConverter. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ConvertibleToConvertibleConversionRule | Converts values among IConvertible types. This class cannot be inherited.
Public class | NullConverter | A null implementation of a converter that does not actually support converting values. Consequently CanConvert returns false whenever a conversion would be required.
Public class | ObjectToStringConversionRule | Converts an Object into a String using ToString. This class cannot be inherited.
Public class | RuleBasedConverter | A rule-based converter uses a set of IConversionRules to perform conversions. It caches the best path it determines for each conversion so that it only needs to compute the conversion cost once.
Public class | StringToXmlDocumentConversionRule | Converts a String into an XmlDocument assuming the string is valid xml. This class cannot be inherited.
Public class | XPathNavigableToXPathNavigatorConversionRule | Converts IXPathNavigable objects to XPathNavigator objects. This class cannot be inherited.
Public class | XPathNavigatorToStringConversionRule | Converts an XPathNavigator into a String by value or outer xml. This class cannot be inherited.
Public class | XPathNavigatorToXmlSerializableTypeConversionRule | Converts XPathNavigator objects to XML serializable objects that have the XmlTypeAttribute. This class cannot be inherited.

Interfaces

 | Interface | Description
Public interface | IConversionRule | A conversion rule encapsulates an algorithm for converting a value from a source type to a target type.
Public interface | IConverter | A converter converts a value from a source type to a target type.

Structures

 | Structure | Description
Public structure | ConversionCost | Describes the relative cost of performing a conversion so that different conversions can be ranked by cost. A typical direct conversion should have a cost of one. Lossy conversions should be more costly.


ArrayToArrayConversionRule Class

ArrayToArrayConversionRule Class
See Also Example Members
[image]

Converts arrays from one-dimensional arrays of one element type to another. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ArrayToArrayConversionRule
Implements IConversionRule
C#
public sealed class ArrayToArrayConversionRule : IConversionRule
C++
ref class ArrayToArrayConversionRule sealed : IConversionRule
J#
public final class ArrayToArrayConversionRule implements IConversionRule
JScript
public final class ArrayToArrayConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.ArrayToArrayConversionRule

See Also

ArrayToArrayConversionRule Members
Gallio.Framework.Conversions Namespace


ArrayToArrayConversionRule Members

ArrayToArrayConversionRule Members
See Also Example Constructors Methods
[image]

Converts arrays from one-dimensional arrays of one element type to another. This class cannot be inherited.

The following tables list the members exposed by ArrayToArrayConversionRule.

Public Constructors

 | Name | Description
Public method | ArrayToArrayConversionRule | Initializes a new instance of the ArrayToArrayConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ArrayToArrayConversionRule Class
Gallio.Framework.Conversions Namespace


ArrayToArrayConversionRule Constructor

ArrayToArrayConversionRule Constructor
[image]

Initializes a new instance of the ArrayToArrayConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ArrayToArrayConversionRule()
C++
public:
ArrayToArrayConversionRule() sealed
J#
public ArrayToArrayConversionRule()
JScript
public function ArrayToArrayConversionRule()

See Also

ArrayToArrayConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

ArrayToArrayConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ArrayToArrayConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

ArrayToArrayConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

ArrayToArrayConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

ArrayToArrayConversionRule.GetConversionCost Method
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

ArrayToArrayConversionRule Class
Gallio.Framework.Conversions Namespace


BaseConverter Class

BaseConverter Class
See Also Example Members
[image]

An abstract base class implementation of IConverter that mostly validates arguments and provides a default implement for CanConvert based on GetConversionCost. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseConverter
Implements IConverter
C#
public abstract class BaseConverter : IConverter
C++
ref class BaseConverter abstract : IConverter
J#
public class BaseConverter implements IConverter
JScript
public class BaseConverter extends IConverter

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.BaseConverter
Gallio.Framework.Conversions.NullConverter
Gallio.Framework.Conversions.RuleBasedConverter

See Also

BaseConverter Members
Gallio.Framework.Conversions Namespace


BaseConverter Members

BaseConverter Members
See Also Example Constructors Methods
[image]

An abstract base class implementation of IConverter that mostly validates arguments and provides a default implement for CanConvert based on GetConversionCost. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseConverter.

Protected Constructors

 | Name | Description
Family method | BaseConverter | Initializes a new instance of the BaseConverter class.
Top

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType.
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanConvertImpl | Implements CanConvert.
Family method | ConvertImpl | Implements Convert
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetConversionCostImpl | Implements GetConversionCost.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


BaseConverter Constructor

BaseConverter Constructor
[image]

Initializes a new instance of the BaseConverter class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseConverter()
C++
protected:
BaseConverter() sealed
J#
protected BaseConverter()
JScript
protected function BaseConverter()

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


Methods

BaseConverter Methods
[image]

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType.
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanConvertImpl | Implements CanConvert.
Family method | ConvertImpl | Implements Convert
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetConversionCostImpl | Implements GetConversionCost.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


CanConvert Method

BaseConverter.CanConvert Method
[image]

Determines whether the converter can convert a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CanConvert( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As Boolean _
Implements IConverter.CanConvert
C#
public bool CanConvert(
Type sourceType,
Type targetType
)
C++
public:
bool CanConvert(
Type sourceType,
Type targetType
) sealed
J#
public bool CanConvert(
Type sourceType,
Type targetType
)
JScript
public function CanConvert(
sourceType : Type,
targetType : Type
) : bool

Parameters

sourceType
The source type
targetType
The target type

Return Value

True if the converter supports this conversion

Implements

IConverter.CanConvert

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


CanConvertImpl Method

BaseConverter.CanConvertImpl Method
[image]

Implements CanConvert.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CanConvertImpl( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As Boolean
C#
protected virtual bool CanConvertImpl(
Type sourceType,
Type targetType
)
C++
protected:
virtual bool CanConvertImpl(
Type sourceType,
Type targetType
)
J#
protected virtual bool CanConvertImpl(
Type sourceType,
Type targetType
)
JScript
protected virtual function CanConvertImpl(
sourceType : Type,
targetType : Type
) : bool

Parameters

sourceType
The source type, never null
targetType
The target type, never null

Return Value

True if the conversion is supported

Remarks

The default implementation returns true if GetConversionCostImpl returns a valid conversion cost.

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


Convert Method

BaseConverter.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type _
) As Object _
Implements IConverter.Convert
C#
public object Convert(
object sourceValue,
Type targetType
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType
) sealed
J#
public object Convert(
object sourceValue,
Type targetType
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type
) : Object

Parameters

sourceValue
The value to convert
targetType
The target type

Return Value

The converted value

Implements

IConverter.Convert

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


ConvertImpl Method

BaseConverter.ConvertImpl Method
[image]

Implements Convert

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function ConvertImpl( _
ByVal sourceValue As Object, _
ByVal targetType As Type _
) As Object
C#
protected abstract object ConvertImpl(
object sourceValue,
Type targetType
)
C++
protected:
Object ConvertImpl(
Object sourceValue,
Type targetType
) abstract
J#
protected abstract object ConvertImpl(
object sourceValue,
Type targetType
)
JScript
protected abstract function ConvertImpl(
sourceValue : Object,
targetType : Type
) : Object

Parameters

sourceValue
The source value
targetType
The target type, never null

Return Value

The converted value

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

BaseConverter.GetConversionCost Method
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As ConversionCost _
Implements IConverter.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type
) : ConversionCost

Parameters

sourceType
The source type
targetType
The target type

Return Value

The conversion cost

Implements

IConverter.GetConversionCost

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


GetConversionCostImpl Method

BaseConverter.GetConversionCostImpl Method
[image]

Implements GetConversionCost.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetConversionCostImpl( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As ConversionCost
C#
protected abstract ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
)
C++
protected:
ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
) abstract
J#
protected abstract ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
)
JScript
protected abstract function GetConversionCostImpl(
sourceType : Type,
targetType : Type
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null

Return Value

The conversion cost

See Also

BaseConverter Class
Gallio.Framework.Conversions Namespace


ConversionCost Structure

ConversionCost Structure
See Also Example Members
[image]

Describes the relative cost of performing a conversion so that different conversions can be ranked by cost. A typical direct conversion should have a cost of one. Lossy conversions should be more costly.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure ConversionCost
Implements IComparable(Of ConversionCost)
C#
public struct ConversionCost : IComparable<ConversionCost>
C++
value class ConversionCost : IComparable<ConversionCost>
J#
public final class ConversionCost extends ValueType implements IComparable<ConversionCost>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.ConversionCost

See Also

ConversionCost Members
Gallio.Framework.Conversions Namespace


ConversionCost Members

ConversionCost Members
See Also Example Constructors Fields Properties Methods
[image]

Describes the relative cost of performing a conversion so that different conversions can be ranked by cost. A typical direct conversion should have a cost of one. Lossy conversions should be more costly.

The following tables list the members exposed by ConversionCost.

Public Constructors

 | Name | Description
Public method | ConversionCost | Creates a conversion cost.
Top

Public Fields

Name | Description
Best | The conversion is the best possible conversion available. Built-in conversions should not use this value. It should be reserved for user-created conversions that are intended to override the built-in conversions. This field is read-only.
Default | The conversion is a poor default choice. It costs a sufficient number of units of work to perform to ensure that a non-default conversion will be chosen if possible. This field is read-only.
Invalid | The conversion is not supported. This field is read-only.
Maximum | The conversion costs the maximum possible amount of work to perform. This field is read-only.
Typical | The conversion costs a typical amount of work to perform. It may yet be trumped by a conversion that costs less. This field is read-only.
Zero | The conversion has zero cost because no work is required. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | IsInvalid | Returns true if the conversion is not supported.
Public property | Value | Gets the cost value.
Top

Public Methods

 | Name | Description
Public method | Add | Adds this conversion cost with the other and returns the sum.
Public method | CompareTo |
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


ConversionCost Constructor

ConversionCost Constructor
[image]

Creates a conversion cost.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal value As Integer _
)
C#
public ConversionCost(
int value
)
C++
public:
ConversionCost(
int value
) sealed
J#
public ConversionCost(
int value
)
JScript
public function ConversionCost(
value : int
)

Parameters

value
The number of units of work required by the conversion

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if value is negative

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Fields

ConversionCost Fields
[image]

Public Fields

Name | Description
Best | The conversion is the best possible conversion available. Built-in conversions should not use this value. It should be reserved for user-created conversions that are intended to override the built-in conversions. This field is read-only.
Default | The conversion is a poor default choice. It costs a sufficient number of units of work to perform to ensure that a non-default conversion will be chosen if possible. This field is read-only.
Invalid | The conversion is not supported. This field is read-only.
Maximum | The conversion costs the maximum possible amount of work to perform. This field is read-only.
Typical | The conversion costs a typical amount of work to perform. It may yet be trumped by a conversion that costs less. This field is read-only.
Zero | The conversion has zero cost because no work is required. This field is read-only.
Top

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Best Field

ConversionCost.Best Field
[image]

The conversion is the best possible conversion available. Built-in conversions should not use this value. It should be reserved for user-created conversions that are intended to override the built-in conversions. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Best As ConversionCost
C#
public static readonly ConversionCost Best;
C++
public:
static const ConversionCost Best;
J#
public static final ConversionCost Best
JScript
public static const var Best : ConversionCost;

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Default Field

ConversionCost.Default Field
[image]

The conversion is a poor default choice. It costs a sufficient number of units of work to perform to ensure that a non-default conversion will be chosen if possible. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As ConversionCost
C#
public static readonly ConversionCost Default;
C++
public:
static const ConversionCost Default;
J#
public static final ConversionCost Default
JScript
public static const var Default : ConversionCost;

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Invalid Field

ConversionCost.Invalid Field
[image]

The conversion is not supported. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Invalid As ConversionCost
C#
public static readonly ConversionCost Invalid;
C++
public:
static const ConversionCost Invalid;
J#
public static final ConversionCost Invalid
JScript
public static const var Invalid : ConversionCost;

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Maximum Field

ConversionCost.Maximum Field
[image]

The conversion costs the maximum possible amount of work to perform. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Maximum As ConversionCost
C#
public static readonly ConversionCost Maximum;
C++
public:
static const ConversionCost Maximum;
J#
public static final ConversionCost Maximum
JScript
public static const var Maximum : ConversionCost;

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Typical Field

ConversionCost.Typical Field
[image]

The conversion costs a typical amount of work to perform. It may yet be trumped by a conversion that costs less. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Typical As ConversionCost
C#
public static readonly ConversionCost Typical;
C++
public:
static const ConversionCost Typical;
J#
public static final ConversionCost Typical
JScript
public static const var Typical : ConversionCost;

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Zero Field

ConversionCost.Zero Field
[image]

The conversion has zero cost because no work is required. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As ConversionCost
C#
public static readonly ConversionCost Zero;
C++
public:
static const ConversionCost Zero;
J#
public static final ConversionCost Zero
JScript
public static const var Zero : ConversionCost;

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Properties

ConversionCost Properties
[image]

Public Properties

 | Name | Description
Public property | IsInvalid | Returns true if the conversion is not supported.
Public property | Value | Gets the cost value.
Top

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


IsInvalid Property

ConversionCost.IsInvalid Property
[image]

Returns true if the conversion is not supported.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInvalid As Boolean
C#
public bool IsInvalid { get; }
C++
public property bool IsInvalid sealed {
bool get();
}
J#
/** property */
public bool get_IsInvalid();
JScript
public function get IsInvalid() : bool

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Value Property

ConversionCost.Value Property
[image]

Gets the cost value.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Integer
C#
public int Value { get; }
C++
public property int Value sealed {
int get();
}
J#
/** property */
public int get_Value();
JScript
public function get Value() : int

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Methods

ConversionCost Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds this conversion cost with the other and returns the sum.
Public method | CompareTo |
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Add Method

ConversionCost.Add Method
[image]

Adds this conversion cost with the other and returns the sum.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal other As ConversionCost _
) As ConversionCost
C#
public ConversionCost Add(
ConversionCost other
)
C++
public:
ConversionCost Add(
ConversionCost other
) sealed
J#
public ConversionCost Add(
ConversionCost other
)
JScript
public function Add(
other : ConversionCost
) : ConversionCost

Parameters

other
The other conversion cost

Return Value

The summed conversion cost

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


CompareTo Method

ConversionCost.CompareTo Method
[image]

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
ByVal other As ConversionCost _
) As Integer _
Implements IComparable<ConversionCost>.CompareTo
C#
public int CompareTo(
ConversionCost other
)
C++
public:
int CompareTo(
ConversionCost other
) sealed
J#
public int CompareTo(
ConversionCost other
)
JScript
public function CompareTo(
other : ConversionCost
) : int

Implements

IComparable<ConversionCost>.CompareTo

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


ToString Method

ConversionCost.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

ConversionCost Structure
Gallio.Framework.Conversions Namespace


Converter Class

Converter Class
See Also Example Members
[image]

Service locator for IConverter. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module Converter
C#
public static class Converter
C++
ref class Converter abstract sealed
J#
public final class Converter
JScript
public class Converter

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.Converter

See Also

Converter Members
Gallio.Framework.Conversions Namespace


Converter Members

Converter Members
See Also Example Properties
[image]

Service locator for IConverter. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Converter.

Public Properties

Name | Description
Instance | Gets the global conveter singleton.
Top

See Also

Converter Class
Gallio.Framework.Conversions Namespace


Properties

Converter Properties
[image]

Public Properties

Name | Description
Instance | Gets the global conveter singleton.
Top

See Also

Converter Class
Gallio.Framework.Conversions Namespace


Instance Property

Converter.Instance Property
[image]

Gets the global conveter singleton.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As IConverter
C#
public static IConverter Instance { get; }
C++
public static property IConverter Instance {
IConverter get();
}
J#
/** property */
public IConverter get_Instance();
JScript
public function get Instance() : IConverter

See Also

Converter Class
Gallio.Framework.Conversions Namespace


ConvertibleToConvertibleConversionRule Class

ConvertibleToConvertibleConversionRule Class
See Also Example Members
[image]

Converts values among IConvertible types. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConvertibleToConvertibleConversionRule
Implements IConversionRule
C#
public sealed class ConvertibleToConvertibleConversionRule : IConversionRule
C++
ref class ConvertibleToConvertibleConversionRule sealed : IConversionRule
J#
public final class ConvertibleToConvertibleConversionRule implements IConversionRule
JScript
public final class ConvertibleToConvertibleConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.ConvertibleToConvertibleConversionRule

See Also

ConvertibleToConvertibleConversionRule Members
Gallio.Framework.Conversions Namespace


ConvertibleToConvertibleConversionRule Members

ConvertibleToConvertibleConversionRule Members
See Also Example Constructors Methods
[image]

Converts values among IConvertible types. This class cannot be inherited.

The following tables list the members exposed by ConvertibleToConvertibleConversionRule.

Public Constructors

 | Name | Description
Public method | ConvertibleToConvertibleConversionRule | Initializes a new instance of the ConvertibleToConvertibleConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConvertibleToConvertibleConversionRule Class
Gallio.Framework.Conversions Namespace


ConvertibleToConvertibleConversionRule Constructor

ConvertibleToConvertibleConversionRule Constructor
[image]

Initializes a new instance of the ConvertibleToConvertibleConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ConvertibleToConvertibleConversionRule()
C++
public:
ConvertibleToConvertibleConversionRule() sealed
J#
public ConvertibleToConvertibleConversionRule()
JScript
public function ConvertibleToConvertibleConversionRule()

See Also

ConvertibleToConvertibleConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

ConvertibleToConvertibleConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConvertibleToConvertibleConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

ConvertibleToConvertibleConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

ConvertibleToConvertibleConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

ConvertibleToConvertibleConversionRule.GetConversionCost Method
See Also Example
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

ConvertibleToConvertibleConversionRule Class
Gallio.Framework.Conversions Namespace


IConversionRule Interface

IConversionRule Interface
See Also Example Members
[image]

A conversion rule encapsulates an algorithm for converting a value from a source type to a target type.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IConversionRule
C#
public interface IConversionRule
C++
interface class IConversionRule
J#
public interface IConversionRule
JScript
public interface IConversionRule

Types that implement IConversionRule

Type | Description
Gallio.Framework.Conversions.ArrayToArrayConversionRule | Converts arrays from one-dimensional arrays of one element type to another. This class cannot be inherited.
Gallio.Framework.Conversions.ConvertibleToConvertibleConversionRule | Converts values among IConvertible types. This class cannot be inherited.
Gallio.Framework.Conversions.ObjectToStringConversionRule | Converts an Object into a String using ToString. This class cannot be inherited.
Gallio.Framework.Conversions.StringToXmlDocumentConversionRule | Converts a String into an XmlDocument assuming the string is valid xml. This class cannot be inherited.
Gallio.Framework.Conversions.XPathNavigableToXPathNavigatorConversionRule | Converts IXPathNavigable objects to XPathNavigator objects. This class cannot be inherited.
Gallio.Framework.Conversions.XPathNavigatorToStringConversionRule | Converts an XPathNavigator into a String by value or outer xml. This class cannot be inherited.
Gallio.Framework.Conversions.XPathNavigatorToXmlSerializableTypeConversionRule | Converts XPathNavigator objects to XML serializable objects that have the XmlTypeAttribute. This class cannot be inherited.

Remarks

This type is not intended to be used directly by clients. Instead refer to IConverter for a simpler abstraction that wraps IConversionRule.

See Also

IConversionRule Members
Gallio.Framework.Conversions Namespace


IConversionRule Members

IConversionRule Members
See Also Example Methods
[image]

A conversion rule encapsulates an algorithm for converting a value from a source type to a target type.

The following tables list the members exposed by IConversionRule.

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Top

See Also

IConversionRule Interface
Gallio.Framework.Conversions Namespace


Methods

IConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Top

See Also

IConversionRule Interface
Gallio.Framework.Conversions Namespace


Convert Method

IConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object
C#
object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) abstract
J#
object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Remarks

This method must not be called if GetConversionCost returned Invalid when asked about the sourceValue type and targetType. It must also not be called if sourceValue is null or if it is already an instance of targetType.

See Also

IConversionRule Interface
Gallio.Framework.Conversions Namespace


GetConversionCost Method

IConversionRule.GetConversionCost Method
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost
C#
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) abstract
J#
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

See Also

IConversionRule Interface
Gallio.Framework.Conversions Namespace


IConverter Interface

IConverter Interface
See Also Example Members
[image]

A converter converts a value from a source type to a target type.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IConverter
C#
public interface IConverter
C++
interface class IConverter
J#
public interface IConverter
JScript
public interface IConverter

Types that implement IConverter

Type | Description
Gallio.Framework.Conversions.BaseConverter | An abstract base class implementation of IConverter that mostly validates arguments and provides a default implement for CanConvert based on GetConversionCost. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IConverter Members
Gallio.Framework.Conversions Namespace


IConverter Members

IConverter Members
See Also Example Methods
[image]

A converter converts a value from a source type to a target type.

The following tables list the members exposed by IConverter.

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType.
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Top

See Also

IConverter Interface
Gallio.Framework.Conversions Namespace


Methods

IConverter Methods
[image]

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType.
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Top

See Also

IConverter Interface
Gallio.Framework.Conversions Namespace


CanConvert Method

IConverter.CanConvert Method
[image]

Determines whether the converter can convert a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CanConvert( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As Boolean
C#
bool CanConvert(
Type sourceType,
Type targetType
)
C++
bool CanConvert(
Type sourceType,
Type targetType
) abstract
J#
bool CanConvert(
Type sourceType,
Type targetType
)
JScript
function CanConvert(
sourceType : Type,
targetType : Type
) : bool

Parameters

sourceType
The source type
targetType
The target type

Return Value

True if the converter supports this conversion

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sourceType or targetType is null

See Also

IConverter Interface
Gallio.Framework.Conversions Namespace


Convert Method

IConverter.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type _
) As Object
C#
object Convert(
object sourceValue,
Type targetType
)
C++
Object Convert(
Object sourceValue,
Type targetType
) abstract
J#
object Convert(
object sourceValue,
Type targetType
)
JScript
function Convert(
sourceValue : Object,
targetType : Type
) : Object

Parameters

sourceValue
The value to convert
targetType
The target type

Return Value

The converted value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if targetType is null
InvalidOperationException | Thrown the requested conversion was not supported

See Also

IConverter Interface
Gallio.Framework.Conversions Namespace


GetConversionCost Method

IConverter.GetConversionCost Method
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As ConversionCost
C#
ConversionCost GetConversionCost(
Type sourceType,
Type targetType
)
C++
ConversionCost GetConversionCost(
Type sourceType,
Type targetType
) abstract
J#
ConversionCost GetConversionCost(
Type sourceType,
Type targetType
)
JScript
function GetConversionCost(
sourceType : Type,
targetType : Type
) : ConversionCost

Parameters

sourceType
The source type
targetType
The target type

Return Value

The conversion cost

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sourceType or targetType is null

See Also

IConverter Interface
Gallio.Framework.Conversions Namespace


NullConverter Class

NullConverter Class
See Also Example Members
[image]

A null implementation of a converter that does not actually support converting values. Consequently CanConvert returns false whenever a conversion would be required.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class NullConverter
Inherits BaseConverter
C#
public class NullConverter : BaseConverter
C++
ref class NullConverter : BaseConverter
J#
public class NullConverter extends BaseConverter
JScript
public class NullConverter extends BaseConverter

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.BaseConverter
Gallio.Framework.Conversions.NullConverter

See Also

NullConverter Members
Gallio.Framework.Conversions Namespace


NullConverter Members

NullConverter Members
See Also Example Constructors Fields Methods
[image]

A null implementation of a converter that does not actually support converting values. Consequently CanConvert returns false whenever a conversion would be required.

The following tables list the members exposed by NullConverter.

Public Constructors

 | Name | Description
Public method | NullConverter | Initializes a new instance of the NullConverter class.
Top

Public Fields

Name | Description
Instance | Gets a singleton instance of the null converter. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | Convert | Converts the value sourceValue to type targetType. (inherited from BaseConverter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanConvertImpl | Implements CanConvert. (inherited from BaseConverter)
Family method | ConvertImpl | Overridden. Implements Convert
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetConversionCostImpl | Overridden. Implements GetConversionCost.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


NullConverter Constructor

NullConverter Constructor
[image]

Initializes a new instance of the NullConverter class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NullConverter()
C++
public:
NullConverter() sealed
J#
public NullConverter()
JScript
public function NullConverter()

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


Fields

NullConverter Fields
[image]

Public Fields

Name | Description
Instance | Gets a singleton instance of the null converter. This field is read-only.
Top

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


Instance Field

NullConverter.Instance Field
[image]

Gets a singleton instance of the null converter. This field is read-only.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As NullConverter
C#
public static readonly NullConverter Instance;
C++
public:
static const NullConverter Instance;
J#
public static final NullConverter Instance
JScript
public static const var Instance : NullConverter;

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


Methods

NullConverter Methods
[image]

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | Convert | Converts the value sourceValue to type targetType. (inherited from BaseConverter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanConvertImpl | Implements CanConvert. (inherited from BaseConverter)
Family method | ConvertImpl | Overridden. Implements Convert
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetConversionCostImpl | Overridden. Implements GetConversionCost.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


ConvertImpl Method

NullConverter.ConvertImpl Method
[image]

Implements Convert

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ConvertImpl( _
ByVal sourceValue As Object, _
ByVal targetType As Type _
) As Object
C#
protected override object ConvertImpl(
object sourceValue,
Type targetType
)
C++
protected:
virtual Object ConvertImpl(
Object sourceValue,
Type targetType
) override
J#
protected override object ConvertImpl(
object sourceValue,
Type targetType
)
JScript
protected override function ConvertImpl(
sourceValue : Object,
targetType : Type
) : Object

Parameters

sourceValue
The source value
targetType
The target type, never null

Return Value

The converted value

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


GetConversionCostImpl Method

NullConverter.GetConversionCostImpl Method
[image]

Implements GetConversionCost.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetConversionCostImpl( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As ConversionCost
C#
protected override ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
)
C++
protected:
virtual ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
) override
J#
protected override ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
)
JScript
protected override function GetConversionCostImpl(
sourceType : Type,
targetType : Type
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null

Return Value

The conversion cost

See Also

NullConverter Class
Gallio.Framework.Conversions Namespace


ObjectToStringConversionRule Class

ObjectToStringConversionRule Class
See Also Example Members
[image]

Converts an Object into a String using ToString. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectToStringConversionRule
Implements IConversionRule
C#
public sealed class ObjectToStringConversionRule : IConversionRule
C++
ref class ObjectToStringConversionRule sealed : IConversionRule
J#
public final class ObjectToStringConversionRule implements IConversionRule
JScript
public final class ObjectToStringConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.ObjectToStringConversionRule

See Also

ObjectToStringConversionRule Members
Gallio.Framework.Conversions Namespace


ObjectToStringConversionRule Members

ObjectToStringConversionRule Members
See Also Example Constructors Methods
[image]

Converts an Object into a String using ToString. This class cannot be inherited.

The following tables list the members exposed by ObjectToStringConversionRule.

Public Constructors

 | Name | Description
Public method | ObjectToStringConversionRule | Initializes a new instance of the ObjectToStringConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ObjectToStringConversionRule Class
Gallio.Framework.Conversions Namespace


ObjectToStringConversionRule Constructor

ObjectToStringConversionRule Constructor
[image]

Initializes a new instance of the ObjectToStringConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ObjectToStringConversionRule()
C++
public:
ObjectToStringConversionRule() sealed
J#
public ObjectToStringConversionRule()
JScript
public function ObjectToStringConversionRule()

See Also

ObjectToStringConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

ObjectToStringConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ObjectToStringConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

ObjectToStringConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

ObjectToStringConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

ObjectToStringConversionRule.GetConversionCost Method
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

ObjectToStringConversionRule Class
Gallio.Framework.Conversions Namespace


RuleBasedConverter Class

RuleBasedConverter Class
See Also Example Members
[image]

A rule-based converter uses a set of IConversionRules to perform conversions. It caches the best path it determines for each conversion so that it only needs to compute the conversion cost once.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RuleBasedConverter
Inherits BaseConverter
C#
public class RuleBasedConverter : BaseConverter
C++
ref class RuleBasedConverter : BaseConverter
J#
public class RuleBasedConverter extends BaseConverter
JScript
public class RuleBasedConverter extends BaseConverter

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.BaseConverter
Gallio.Framework.Conversions.RuleBasedConverter

See Also

RuleBasedConverter Members
Gallio.Framework.Conversions Namespace


RuleBasedConverter Members

RuleBasedConverter Members
See Also Example Constructors Methods
[image]

A rule-based converter uses a set of IConversionRules to perform conversions. It caches the best path it determines for each conversion so that it only needs to compute the conversion cost once.

The following tables list the members exposed by RuleBasedConverter.

Public Constructors

 | Name | Description
Public method | RuleBasedConverter | Creates a rule-based converter.
Top

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | Convert | Converts the value sourceValue to type targetType. (inherited from BaseConverter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanConvertImpl | Implements CanConvert. (inherited from BaseConverter)
Family method | ConvertImpl | Overridden. Implements Convert
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetConversionCostImpl | Overridden. Implements GetConversionCost.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuleBasedConverter Class
Gallio.Framework.Conversions Namespace


RuleBasedConverter Constructor

RuleBasedConverter Constructor
[image]

Creates a rule-based converter.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal rules As IConversionRule() _
)
C#
public RuleBasedConverter(
IConversionRule[] rules
)
C++
public:
RuleBasedConverter(
array<IConversionRule>^ rules
) sealed
J#
public RuleBasedConverter(
IConversionRule[] rules
)
JScript
public function RuleBasedConverter(
rules : IConversionRule[]
)

Parameters

rules
The rules to use

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if rules is null

See Also

RuleBasedConverter Class
Gallio.Framework.Conversions Namespace


Methods

RuleBasedConverter Methods
[image]

Public Methods

 | Name | Description
Public method | CanConvert | Determines whether the converter can convert a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | Convert | Converts the value sourceValue to type targetType. (inherited from BaseConverter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType. (inherited from BaseConverter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanConvertImpl | Implements CanConvert. (inherited from BaseConverter)
Family method | ConvertImpl | Overridden. Implements Convert
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetConversionCostImpl | Overridden. Implements GetConversionCost.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuleBasedConverter Class
Gallio.Framework.Conversions Namespace


ConvertImpl Method

RuleBasedConverter.ConvertImpl Method
[image]

Implements Convert

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ConvertImpl( _
ByVal sourceValue As Object, _
ByVal targetType As Type _
) As Object
C#
protected override object ConvertImpl(
object sourceValue,
Type targetType
)
C++
protected:
virtual Object ConvertImpl(
Object sourceValue,
Type targetType
) override
J#
protected override object ConvertImpl(
object sourceValue,
Type targetType
)
JScript
protected override function ConvertImpl(
sourceValue : Object,
targetType : Type
) : Object

Parameters

sourceValue
The source value
targetType
The target type, never null

Return Value

The converted value

See Also

RuleBasedConverter Class
Gallio.Framework.Conversions Namespace


GetConversionCostImpl Method

RuleBasedConverter.GetConversionCostImpl Method
[image]

Implements GetConversionCost.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetConversionCostImpl( _
ByVal sourceType As Type, _
ByVal targetType As Type _
) As ConversionCost
C#
protected override ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
)
C++
protected:
virtual ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
) override
J#
protected override ConversionCost GetConversionCostImpl(
Type sourceType,
Type targetType
)
JScript
protected override function GetConversionCostImpl(
sourceType : Type,
targetType : Type
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null

Return Value

The conversion cost

See Also

RuleBasedConverter Class
Gallio.Framework.Conversions Namespace


StringToXmlDocumentConversionRule Class

StringToXmlDocumentConversionRule Class
See Also Example Members
[image]

Converts a String into an XmlDocument assuming the string is valid xml. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StringToXmlDocumentConversionRule
Implements IConversionRule
C#
public sealed class StringToXmlDocumentConversionRule : IConversionRule
C++
ref class StringToXmlDocumentConversionRule sealed : IConversionRule
J#
public final class StringToXmlDocumentConversionRule implements IConversionRule
JScript
public final class StringToXmlDocumentConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.StringToXmlDocumentConversionRule

See Also

StringToXmlDocumentConversionRule Members
Gallio.Framework.Conversions Namespace


StringToXmlDocumentConversionRule Members

StringToXmlDocumentConversionRule Members
See Also Example Constructors Methods
[image]

Converts a String into an XmlDocument assuming the string is valid xml. This class cannot be inherited.

The following tables list the members exposed by StringToXmlDocumentConversionRule.

Public Constructors

 | Name | Description
Public method | StringToXmlDocumentConversionRule | Initializes a new instance of the StringToXmlDocumentConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StringToXmlDocumentConversionRule Class
Gallio.Framework.Conversions Namespace


StringToXmlDocumentConversionRule Constructor

StringToXmlDocumentConversionRule Constructor
[image]

Initializes a new instance of the StringToXmlDocumentConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StringToXmlDocumentConversionRule()
C++
public:
StringToXmlDocumentConversionRule() sealed
J#
public StringToXmlDocumentConversionRule()
JScript
public function StringToXmlDocumentConversionRule()

See Also

StringToXmlDocumentConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

StringToXmlDocumentConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StringToXmlDocumentConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

StringToXmlDocumentConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

StringToXmlDocumentConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

StringToXmlDocumentConversionRule.GetConversionCost Method
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

StringToXmlDocumentConversionRule Class
Gallio.Framework.Conversions Namespace


XPathNavigableToXPathNavigatorConversionRule Class

XPathNavigableToXPathNavigatorConversionRule Class
See Also Example Members
[image]

Converts IXPathNavigable objects to XPathNavigator objects. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XPathNavigableToXPathNavigatorConversionRule
Implements IConversionRule
C#
public sealed class XPathNavigableToXPathNavigatorConversionRule : IConversionRule
C++
ref class XPathNavigableToXPathNavigatorConversionRule sealed : IConversionRule
J#
public final class XPathNavigableToXPathNavigatorConversionRule implements IConversionRule
JScript
public final class XPathNavigableToXPathNavigatorConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.XPathNavigableToXPathNavigatorConversionRule

See Also

XPathNavigableToXPathNavigatorConversionRule Members
Gallio.Framework.Conversions Namespace


XPathNavigableToXPathNavigatorConversionRule Members

XPathNavigableToXPathNavigatorConversionRule Members
See Also Example Constructors Methods
[image]

Converts IXPathNavigable objects to XPathNavigator objects. This class cannot be inherited.

The following tables list the members exposed by XPathNavigableToXPathNavigatorConversionRule.

Public Constructors

 | Name | Description
Public method | XPathNavigableToXPathNavigatorConversionRule | Initializes a new instance of the XPathNavigableToXPathNavigatorConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigableToXPathNavigatorConversionRule Class
Gallio.Framework.Conversions Namespace


XPathNavigableToXPathNavigatorConversionRule Constructor

XPathNavigableToXPathNavigatorConversionRule Constructor
[image]

Initializes a new instance of the XPathNavigableToXPathNavigatorConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XPathNavigableToXPathNavigatorConversionRule()
C++
public:
XPathNavigableToXPathNavigatorConversionRule() sealed
J#
public XPathNavigableToXPathNavigatorConversionRule()
JScript
public function XPathNavigableToXPathNavigatorConversionRule()

See Also

XPathNavigableToXPathNavigatorConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

XPathNavigableToXPathNavigatorConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigableToXPathNavigatorConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

XPathNavigableToXPathNavigatorConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

XPathNavigableToXPathNavigatorConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

XPathNavigableToXPathNavigatorConversionRule.GetConversionCost Method
See Also Example
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

XPathNavigableToXPathNavigatorConversionRule Class
Gallio.Framework.Conversions Namespace


XPathNavigatorToStringConversionRule Class

XPathNavigatorToStringConversionRule Class
See Also Example Members
[image]

Converts an XPathNavigator into a String by value or outer xml. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XPathNavigatorToStringConversionRule
Implements IConversionRule
C#
public sealed class XPathNavigatorToStringConversionRule : IConversionRule
C++
ref class XPathNavigatorToStringConversionRule sealed : IConversionRule
J#
public final class XPathNavigatorToStringConversionRule implements IConversionRule
JScript
public final class XPathNavigatorToStringConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.XPathNavigatorToStringConversionRule

See Also

XPathNavigatorToStringConversionRule Members
Gallio.Framework.Conversions Namespace


XPathNavigatorToStringConversionRule Members

XPathNavigatorToStringConversionRule Members
See Also Example Constructors Methods
[image]

Converts an XPathNavigator into a String by value or outer xml. This class cannot be inherited.

The following tables list the members exposed by XPathNavigatorToStringConversionRule.

Public Constructors

 | Name | Description
Public method | XPathNavigatorToStringConversionRule | Initializes a new instance of the XPathNavigatorToStringConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigatorToStringConversionRule Class
Gallio.Framework.Conversions Namespace


XPathNavigatorToStringConversionRule Constructor

XPathNavigatorToStringConversionRule Constructor
[image]

Initializes a new instance of the XPathNavigatorToStringConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XPathNavigatorToStringConversionRule()
C++
public:
XPathNavigatorToStringConversionRule() sealed
J#
public XPathNavigatorToStringConversionRule()
JScript
public function XPathNavigatorToStringConversionRule()

See Also

XPathNavigatorToStringConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

XPathNavigatorToStringConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigatorToStringConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

XPathNavigatorToStringConversionRule.Convert Method
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

XPathNavigatorToStringConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

XPathNavigatorToStringConversionRule.GetConversionCost Method
See Also Example
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

XPathNavigatorToStringConversionRule Class
Gallio.Framework.Conversions Namespace


XPathNavigatorToXmlSerializableTypeConversionRule Class

XPathNavigatorToXmlSerializableTypeConversionRule Class
See Also Example Members
[image]

Converts XPathNavigator objects to XML serializable objects that have the XmlTypeAttribute. This class cannot be inherited.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XPathNavigatorToXmlSerializableTypeConversionRule
Implements IConversionRule
C#
public sealed class XPathNavigatorToXmlSerializableTypeConversionRule : IConversionRule
C++
ref class XPathNavigatorToXmlSerializableTypeConversionRule sealed : IConversionRule
J#
public final class XPathNavigatorToXmlSerializableTypeConversionRule implements IConversionRule
JScript
public final class XPathNavigatorToXmlSerializableTypeConversionRule extends IConversionRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Conversions.XPathNavigatorToXmlSerializableTypeConversionRule

See Also

XPathNavigatorToXmlSerializableTypeConversionRule Members
Gallio.Framework.Conversions Namespace


XPathNavigatorToXmlSerializableTypeConversionRule Members

XPathNavigatorToXmlSerializableTypeConversionRule Members
See Also Example Constructors Methods
[image]

Converts XPathNavigator objects to XML serializable objects that have the XmlTypeAttribute. This class cannot be inherited.

The following tables list the members exposed by XPathNavigatorToXmlSerializableTypeConversionRule.

Public Constructors

 | Name | Description
Public method | XPathNavigatorToXmlSerializableTypeConversionRule | Initializes a new instance of the XPathNavigatorToXmlSerializableTypeConversionRule class.
Top

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigatorToXmlSerializableTypeConversionRule Class
Gallio.Framework.Conversions Namespace


XPathNavigatorToXmlSerializableTypeConversionRule Constructor

XPathNavigatorToXmlSerializableTypeConversionRule Constructor
See Also Example
[image]

Initializes a new instance of the XPathNavigatorToXmlSerializableTypeConversionRule class.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XPathNavigatorToXmlSerializableTypeConversionRule()
C++
public:
XPathNavigatorToXmlSerializableTypeConversionRule() sealed
J#
public XPathNavigatorToXmlSerializableTypeConversionRule()
JScript
public function XPathNavigatorToXmlSerializableTypeConversionRule()

See Also

XPathNavigatorToXmlSerializableTypeConversionRule Class
Gallio.Framework.Conversions Namespace


Methods

XPathNavigatorToXmlSerializableTypeConversionRule Methods
[image]

Public Methods

 | Name | Description
Public method | Convert | Converts the value sourceValue to type targetType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetConversionCost | Gets the cost of converting a value of type sourceType to type targetType.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigatorToXmlSerializableTypeConversionRule Class
Gallio.Framework.Conversions Namespace


Convert Method

XPathNavigatorToXmlSerializableTypeConversionRule.Convert Method
See Also Example
[image]

Converts the value sourceValue to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Convert( _
ByVal sourceValue As Object, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As Object _
Implements IConversionRule.Convert
C#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
C++
public:
Object Convert(
Object sourceValue,
Type targetType,
IConverter elementConverter
) sealed
J#
public object Convert(
object sourceValue,
Type targetType,
IConverter elementConverter
)
JScript
public function Convert(
sourceValue : Object,
targetType : Type,
elementConverter : IConverter
) : Object

Parameters

sourceValue
The value to convert, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The converted value

Implements

IConversionRule.Convert

See Also

XPathNavigatorToXmlSerializableTypeConversionRule Class
Gallio.Framework.Conversions Namespace


GetConversionCost Method

XPathNavigatorToXmlSerializableTypeConversionRule.GetConversionCost Method
See Also Example
[image]

Gets the cost of converting a value of type sourceType to type targetType.

Namespace: Gallio.Framework.Conversions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConversionCost( _
ByVal sourceType As Type, _
ByVal targetType As Type, _
ByVal elementConverter As IConverter _
) As ConversionCost _
Implements IConversionRule.GetConversionCost
C#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
C++
public:
ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
) sealed
J#
public ConversionCost GetConversionCost(
Type sourceType,
Type targetType,
IConverter elementConverter
)
JScript
public function GetConversionCost(
sourceType : Type,
targetType : Type,
elementConverter : IConverter
) : ConversionCost

Parameters

sourceType
The source type, never null
targetType
The target type, never null
elementConverter
A converter that may be used to recursively convert the contents of a composite object from one type to another, never null

Return Value

The conversion cost

Implements

IConversionRule.GetConversionCost

See Also

XPathNavigatorToXmlSerializableTypeConversionRule Class
Gallio.Framework.Conversions Namespace


Gallio.Framework.Data

Gallio.Framework.Data Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AggregateDataSet | Abstract base class for an aggregate data set that combines a list of data sets according to some algorithm. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseDataAccessor | A base implementation of IDataAccessor that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseDataBinder | Abstract base class for IDataBinder that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseDataItem | Abstract base class for data items. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseDataSet | Abstract base class for IDataSet that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BoundDataAccessor | A IDataAccessor that simply accesses a value contained by a data item using a particular DataBinding. This class cannot be inherited.
Public class | CombinatorialJoinStrategy | The combinatorial join strategy combines items by constructing the cartesian product of the items of each provider. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ConcatenationMergeStrategy | The concatenation merge strategy combines the items from multiple providers by simply concatenating the items in the order in which they appear and proceeding from one provider to the next until all providers have been fully processed. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ConstantDataAccessor | An implementation of IDataAccessor that returns a constant value, ignoring the data item it is passed. This class cannot be inherited.
Public class CsvDataSet

A CSV data set retrieves fields from a CSV document as strings.

If the CSV document has a header, then it is interpreted as the names of the columns. Columns with names in brackets, such as "[ExpectedException]", are interpreted as containing metadata values associated with the named key.

Public class CsvReader

Reads data from a Comma Separated Values document.

The document format simply consists of sequential lines of delimited field values.

  • The standard delimiter is ',' (comma) but it may be overridden using FieldDelimiter.
  • Empty lines are considered to be records with one empty field.
  • Lines that begin with a special CommentPrefix are excluded from the record set.
  • Field values may be quoted using '"' (quote) characters. The quotes will be omitted from the record set. Quotes may be escaped by doubling them within a quoted field.
  • Unbalanced quotes are tolerated but may produce unexpected results.
  • Excess whitespace is trimmed unless quoted.
  • The document may contain a header consiting of field names but the reader does not interpret it in any special way. It will simply be returned to the client as an ordinary record.
Public class DataBinding

A data binding object describes how a data binding is to take place.

This class provides support for optional path-based and index-based lookup. Subclasses may provide additional properties that are recognized by special kinds of data sets to modify how a bound value is resolved.

Public class | DataBindingContext | A DataBindingContext tracks a list of IDataSets and DataBindings that are used to produce IDataItems. This class cannot be inherited.
Public class | DataBindingException | The type of exception thrown when data binding operations fail.
Public class DataBindingSpec

A data binding specification describes how values are bound to slots (ISlotInfo) of a type or method. The specification can then be used to create new objects or invoke methods.

A specification automatically converts values to the correct types for data binding using a IConverter. It can also format the specification to a string using a IFormatter.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | DataItemUtils | Utilities for IDataItem. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class DataRow

A data row is a simple immutable value type that encpasulates an array of values along with associated metadata for use in data binding expressions. It presents a fluent interface that users may find more convenient than other IDataItem implementations.

The data in a DataRow is always considered dynamic.

Public class | DataSource | An data source object provides a simple way of aggregating data sets together. It also provides a simple translation mechanism for mapping binding paths to binding indexes which is useful for providing named aliases for columns in indexed data sets.
Public class | DataSourceTable | A data source table manages a collection of named data sources.
Public class FactoryDataSet

A factory data set generates data items by invoking a factory delegate and interpreting its output in accordance with the factory kind.

Multiple different interpretations are supported. Refer to the documentation of the FactoryKind enumeration for more details about each kind.

Public class | Generators | This class provides a set of factory methods for creating enumerable objects that generate values according to a specified rule. The generated values may be used for a variety of purposes including data-driven testing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class IntersectionMergeStrategy

The intersection merge strategy combines the items from multiple providers by discarding items whose values do not appear in the items of all other providers. If the same item appears more than once within any given provider, when it will be enumerated only as often as the least number of repetitions of that item that appear in other providers.

Uniqueness is determined by the natural equality of each bound value in the item.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ItemSequenceDataSet | A data set constructed from a sequence of data items. This class cannot be inherited.
Public class JoinedDataSet

A joined data set is an aggregate data set that joins items from each of zero or more other data sets according to a IJoinStrategy.

A joined data set supports queries with two kinds of DataBinding:

  • A translated binding produced by TranslateBinding is scoped to a particular IDataSet. When a query occurs using a translated binding, only that IDataSet and its IDataItem components are consulted.
  • Any other binding is treated as if it referred to the joined IDataItem including all of the contributions of all data sets. The joined IDataItem is conceptually laid out such that the columns of first IDataSet appear first followed by those of successive IDataSets in order. To maintain this illustion, the Index component of the binding is adjusted internally before passing any queries on to the IDataSets. Thereafter a binding will be consumed by the first IDataSet that returns true from its CanBind method after index-adjustment.

Public class | ListDataItem | A list data item contains a list of static data values combined with optional metadata for the item. Data binding occurs based on the binding index alone. This class cannot be inherited.
Public class | MergedDataSet | A merged data set is an aggregate data set that selects items from each of zero or more other data sets according to a IMergeStrategy.
Public class | MethodInvocationSpec | Encapsulates a specification for invoking a method given values for its generic parameters and formal parameters. This class cannot be inherited.
Public class | NullDataItem | A null data item simply returns a null value on each request. It has no metadata. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ObjectCreationSpec | Encapsulates a specification for creating objects given values for a type's generic parameters, constructor parameters, fields and properties. This class cannot be inherited.
Public class | ObjectDataBinder | An object data binder creates objects and binds values to its slots such as generic type parameters, constructor parameters, fields and properties.
Public class PairwiseJoinStrategy

The pairwise strategy constructs a limited number of combinations of the items within the data providers such that they cover all possible pairs of values from each data source.

This strategy can be more efficient than one based on exhaustively testing all combinations since many test failures result from the interaction of a relatively small number of factors: often just two of them.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ScalarDataBinder | A scalar data binder queries a specified data source with a data binding and converts the resulting value to the requested type. It does nothing during unbinding.
Public class | ScalarDataItem | A scalar data item represents a single static data value combined with optional metadata for the item. Data binding occurs whenever the binding index is 0. This class cannot be inherited.
Public class | SequentialJoinStrategy | The sequential join strategy combines items from each data provider sequentially. If one provider contains fewer items than the others, the sequential join strategy will insert a NullDataItem in its place until all other providers have been exhausted. This is similar to performing an "outer join" of multiple sources by ordinal index. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | SimpleDataItem | An implementation of IDataItem that stores the dynamic flag and metadata. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class UnionMergeStrategy

The union merge strategy combines the items from multiple providers by discarding all items whose values duplicate those of other items that have already been enumerated.

Uniqueness is determined by the natural equality of each bound value in the item.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ValueSequenceDataSet | A data set constructed from an enumerated sequence of values. This class cannot be inherited.
Public class | XmlDataSet | An XML data set selects nodes from an XML document using XPath expressions. The selected nodes are returned as XPathNavigator objects.

Interfaces

Interface | Description
Public interface | IDataAccessor | A data accessor extracts a value from a IDataItem.
Public interface IDataBinder

A data binder specifies how to produce values that are suitable for data binding in some context.

The typical IDataBinder lifecycle is as follows:

  • First, a DataBindingContext is created.
  • Next the client calls Register for each IDataBinder, supplying the DataBindingContext and a IDataSourceResolver for resolving data sources.
  • Then the client calls GetItems and begins enumerating over the items.
  • For each item, the client calls GetValue using the IDataAccessor produced by the IDataBinders to obtain the bound values.
  • When finished with an item, the client disposes it.

The lifecycle may also be explained in terms of three phases from the perspective of a IDataBinder.

  • Prebinding - The Register method is called to register interest in particular IDataSets with the DataBindingContext.
  • Binding - The GetValue method is called to obtain bound values from a IDataItem.
  • Unbinding - The IDataItem's Dispose method is called to release resources used by the bound values.
Public interface IDataItem

A data item is an opaque representation of a collection of values and metadata that may be retrieved using data bindings that encode the appropriate lookup rules into the item.

Data items may have very different forms:

  • Scalar-like items: Items that always yield a single value, possibly a constant
  • Row-like items: Items that yield several values in response to index-based data bindings or named column paths
  • Structured items: Items that yield values by binding to paths within the item or by resolving custom data binding expressions
Public interface | IDataProvider | A data provider generates an enumeration of IDataItems given a collection of DataBindings to satisfy.
Public interface | IDataSet | A data set provides data items for data binding and describes whether is supports particular bindings.
Public interface | IDataSourceResolver | Resolves data sources by name.
Public interface | IJoinStrategy | A join strategy combines items from multiple providers into products according to some algorithm.
Public interface | IMergeStrategy | A merge strategy combines items from multiple providers into a sequence according to some algorithm.

Enumerations

Enumeration Description
Public enumeration FactoryKind

Specifies the kind of factory member referenced by FactoryDataSet.

Each kind of factory expresses its contents by returning enumerations of data sets, data items, object arrays and single objects.

The kind of a factory may be automatically determined or it may be explicitly specified in cases where it may be ambiguous.


AggregateDataSet Class

AggregateDataSet Class
See Also Example Members
[image]

Abstract base class for an aggregate data set that combines a list of data sets according to some algorithm. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class AggregateDataSet
Inherits BaseDataSet
C#
public abstract class AggregateDataSet : BaseDataSet
C++
ref class AggregateDataSet abstract : BaseDataSet
J#
public class AggregateDataSet extends BaseDataSet
JScript
public class AggregateDataSet extends BaseDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.AggregateDataSet
Gallio.Framework.Data.JoinedDataSet
Gallio.Framework.Data.MergedDataSet

See Also

AggregateDataSet Members
Gallio.Framework.Data Namespace


AggregateDataSet Members

AggregateDataSet Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for an aggregate data set that combines a list of data sets according to some algorithm. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AggregateDataSet.

Protected Constructors

 | Name | Description
Family method | AggregateDataSet | Initializes a new instance of the AggregateDataSet class.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set. (inherited from BaseDataSet)
Public property | DataSets | Gets the immutable list of combined data sets.
Top

Public Methods

 | Name | Description
Public method | AddDataSet | Adds a data set to the aggregate.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Determines whether a binding can be satisfied by the data set. (inherited from BaseDataSet)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Enumerates the data items in the data set. (inherited from BaseDataSet)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AggregateDataSet Class
Gallio.Framework.Data Namespace


AggregateDataSet Constructor

AggregateDataSet Constructor
[image]

Initializes a new instance of the AggregateDataSet class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected AggregateDataSet()
C++
protected:
AggregateDataSet() sealed
J#
protected AggregateDataSet()
JScript
protected function AggregateDataSet()

See Also

AggregateDataSet Class
Gallio.Framework.Data Namespace


Properties

AggregateDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set. (inherited from BaseDataSet)
Public property | DataSets | Gets the immutable list of combined data sets.
Top

See Also

AggregateDataSet Class
Gallio.Framework.Data Namespace


DataSets Property

AggregateDataSet.DataSets Property
[image]

Gets the immutable list of combined data sets.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSets As IList(Of IDataSet)
C#
public IList<IDataSet> DataSets { get; }
C++
public property IList<IDataSet> DataSets sealed {
IList<IDataSet> get();
}
J#
/** property */
public IList<IDataSet> get_DataSets();
JScript
public function get DataSets() : IList<IDataSet>

See Also

AggregateDataSet Class
Gallio.Framework.Data Namespace


Methods

AggregateDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | AddDataSet | Adds a data set to the aggregate.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Determines whether a binding can be satisfied by the data set. (inherited from BaseDataSet)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Enumerates the data items in the data set. (inherited from BaseDataSet)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AggregateDataSet Class
Gallio.Framework.Data Namespace


AddDataSet Method

AggregateDataSet.AddDataSet Method
[image]

Adds a data set to the aggregate.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDataSet( _
ByVal dataSet As IDataSet _
)
C#
public virtual void AddDataSet(
IDataSet dataSet
)
C++
public:
virtual void AddDataSet(
IDataSet dataSet
)
J#
public virtual void AddDataSet(
IDataSet dataSet
)
JScript
public virtual function AddDataSet(
dataSet : IDataSet
)

Parameters

dataSet
The data set to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if dataSet is null
ArgumentException | Thrown if dataSet is already a member of this aggregate

See Also

AggregateDataSet Class
Gallio.Framework.Data Namespace


BaseDataAccessor Class

BaseDataAccessor Class
See Also Example Members
[image]

A base implementation of IDataAccessor that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseDataAccessor
Implements IDataAccessor
C#
public abstract class BaseDataAccessor : IDataAccessor
C++
ref class BaseDataAccessor abstract : IDataAccessor
J#
public class BaseDataAccessor implements IDataAccessor
JScript
public class BaseDataAccessor extends IDataAccessor

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataAccessor
Gallio.Framework.Data.BoundDataAccessor
Gallio.Framework.Data.ConstantDataAccessor

See Also

BaseDataAccessor Members
Gallio.Framework.Data Namespace


BaseDataAccessor Members

BaseDataAccessor Members
See Also Example Constructors Methods
[image]

A base implementation of IDataAccessor that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseDataAccessor.

Protected Constructors

 | Name | Description
Family method | BaseDataAccessor | Initializes a new instance of the BaseDataAccessor class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets a value derived from the IDataItem.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Internal implementation of GetValue after argument validation has been performed.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseDataAccessor Class
Gallio.Framework.Data Namespace


BaseDataAccessor Constructor

BaseDataAccessor Constructor
[image]

Initializes a new instance of the BaseDataAccessor class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseDataAccessor()
C++
protected:
BaseDataAccessor() sealed
J#
protected BaseDataAccessor()
JScript
protected function BaseDataAccessor()

See Also

BaseDataAccessor Class
Gallio.Framework.Data Namespace


Methods

BaseDataAccessor Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets a value derived from the IDataItem.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Internal implementation of GetValue after argument validation has been performed.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseDataAccessor Class
Gallio.Framework.Data Namespace


GetValue Method

BaseDataAccessor.GetValue Method
[image]

Gets a value derived from the IDataItem.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal item As IDataItem _
) As Object _
Implements IDataAccessor.GetValue
C#
public object GetValue(
IDataItem item
)
C++
public:
Object GetValue(
IDataItem item
) sealed
J#
public object GetValue(
IDataItem item
)
JScript
public function GetValue(
item : IDataItem
) : Object

Parameters

item
The data item

Return Value

The value

Implements

IDataAccessor.GetValue

See Also

BaseDataAccessor Class
Gallio.Framework.Data Namespace


GetValueImpl Method

BaseDataAccessor.GetValueImpl Method
[image]

Internal implementation of GetValue after argument validation has been performed.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetValueImpl( _
ByVal item As IDataItem _
) As Object
C#
protected abstract object GetValueImpl(
IDataItem item
)
C++
protected:
Object GetValueImpl(
IDataItem item
) abstract
J#
protected abstract object GetValueImpl(
IDataItem item
)
JScript
protected abstract function GetValueImpl(
item : IDataItem
) : Object

Parameters

item
The data item, not null

Return Value

The value

Exceptions

Exception Type | Condition
DataBindingException | Thrown if the data binding fails

See Also

BaseDataAccessor Class
Gallio.Framework.Data Namespace


BaseDataBinder Class

BaseDataBinder Class
See Also Example Members
[image]

Abstract base class for IDataBinder that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseDataBinder
Implements IDataBinder
C#
public abstract class BaseDataBinder : IDataBinder
C++
ref class BaseDataBinder abstract : IDataBinder
J#
public class BaseDataBinder implements IDataBinder
JScript
public class BaseDataBinder extends IDataBinder

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataBinder
Gallio.Framework.Data.ObjectDataBinder
Gallio.Framework.Data.ScalarDataBinder

See Also

BaseDataBinder Members
Gallio.Framework.Data Namespace


BaseDataBinder Members

BaseDataBinder Members
See Also Example Constructors Methods
[image]

Abstract base class for IDataBinder that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseDataBinder.

Protected Constructors

 | Name | Description
Family method | BaseDataBinder | Initializes a new instance of the BaseDataBinder class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RegisterImpl | Implementation of Register.
Top

See Also

BaseDataBinder Class
Gallio.Framework.Data Namespace


BaseDataBinder Constructor

BaseDataBinder Constructor
[image]

Initializes a new instance of the BaseDataBinder class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseDataBinder()
C++
protected:
BaseDataBinder() sealed
J#
protected BaseDataBinder()
JScript
protected function BaseDataBinder()

See Also

BaseDataBinder Class
Gallio.Framework.Data Namespace


Methods

BaseDataBinder Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RegisterImpl | Implementation of Register.
Top

See Also

BaseDataBinder Class
Gallio.Framework.Data Namespace


Register Method

BaseDataBinder.Register Method
[image]

Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Register( _
ByVal context As DataBindingContext, _
ByVal resolver As IDataSourceResolver _
) As IDataAccessor _
Implements IDataBinder.Register
C#
public IDataAccessor Register(
DataBindingContext context,
IDataSourceResolver resolver
)
C++
public:
IDataAccessor Register(
DataBindingContext context,
IDataSourceResolver resolver
) sealed
J#
public IDataAccessor Register(
DataBindingContext context,
IDataSourceResolver resolver
)
JScript
public function Register(
context : DataBindingContext,
resolver : IDataSourceResolver
) : IDataAccessor

Parameters

context
The data binding context
resolver
The data source resolver

Return Value

The data binding accessor to use for obtaining bound values from IDataItems produced by the DataBindingContext.

Implements

IDataBinder.Register

See Also

BaseDataBinder Class
Gallio.Framework.Data Namespace


RegisterImpl Method

BaseDataBinder.RegisterImpl Method
[image]

Implementation of Register.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function RegisterImpl( _
ByVal context As DataBindingContext, _
ByVal resolver As IDataSourceResolver _
) As IDataAccessor
C#
protected abstract IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
)
C++
protected:
IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
) abstract
J#
protected abstract IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
)
JScript
protected abstract function RegisterImpl(
context : DataBindingContext,
resolver : IDataSourceResolver
) : IDataAccessor

Parameters

context
The data binding context, not null
resolver
The data source resolver, not null

Return Value

The data binding accessor

See Also

BaseDataBinder Class
Gallio.Framework.Data Namespace


BaseDataItem Class

BaseDataItem Class
See Also Example Members
[image]

Abstract base class for data items. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseDataItem
Implements IDataItem
C#
public abstract class BaseDataItem : IDataItem
C++
ref class BaseDataItem abstract : IDataItem
J#
public class BaseDataItem implements IDataItem
JScript
public class BaseDataItem extends IDataItem

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataItem
Gallio.Framework.Data.DataRow
Gallio.Framework.Data.NullDataItem
Gallio.Framework.Data.SimpleDataItem

See Also

BaseDataItem Members
Gallio.Framework.Data Namespace


BaseDataItem Members

BaseDataItem Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for data items. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseDataItem.

Protected Constructors

 | Name | Description
Family method | BaseDataItem | Initializes a new instance of the BaseDataItem class.
Top

Public Properties

Name Description
Public property IsDynamic

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding.
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Implements GetValue.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateMetadataImpl | Implements PopulateMetadata.
Top

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


BaseDataItem Constructor

BaseDataItem Constructor
[image]

Initializes a new instance of the BaseDataItem class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseDataItem()
C++
protected:
BaseDataItem() sealed
J#
protected BaseDataItem()
JScript
protected function BaseDataItem()

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


Properties

BaseDataItem Properties
[image]

Public Properties

Name Description
Public property IsDynamic

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


IsDynamic Property

BaseDataItem.IsDynamic Property
[image]

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsDynamic As Boolean _
Implements IDataItem.IsDynamic
C#
public abstract bool IsDynamic { get; }
C++
public abstract property bool IsDynamic abstract {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

Implements

IDataItem.IsDynamic

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


Methods

BaseDataItem Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding.
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Implements GetValue.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateMetadataImpl | Implements PopulateMetadata.
Top

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


GetBindingsForInformalDescription Method

BaseDataItem.GetBindingsForInformalDescription Method
[image]

Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetBindingsForInformalDescription() As IEnumerable(Of DataBinding) _
Implements IDataItem.GetBindingsForInformalDescription
C#
public abstract IEnumerable<DataBinding> GetBindingsForInformalDescription()
C++
public:
IEnumerable<DataBinding> GetBindingsForInformalDescription() abstract
J#
public abstract IEnumerable<DataBinding> GetBindingsForInformalDescription()
JScript
public abstract function GetBindingsForInformalDescription() : IEnumerable<DataBinding>

Return Value

The enumeration of bindings

Implements

IDataItem.GetBindingsForInformalDescription

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


GetValue Method

BaseDataItem.GetValue Method
[image]

Gets the value of the specified binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
ByVal binding As DataBinding _
) As Object _
Implements IDataItem.GetValue
C#
public object GetValue(
DataBinding binding
)
C++
public:
Object GetValue(
DataBinding binding
) sealed
J#
public object GetValue(
DataBinding binding
)
JScript
public function GetValue(
binding : DataBinding
) : Object

Parameters

binding
The data binding, never null

Return Value

The value

Implements

IDataItem.GetValue

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


GetValueImpl Method

BaseDataItem.GetValueImpl Method
[image]

Implements GetValue.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetValueImpl( _
ByVal binding As DataBinding _
) As Object
C#
protected abstract object GetValueImpl(
DataBinding binding
)
C++
protected:
Object GetValueImpl(
DataBinding binding
) abstract
J#
protected abstract object GetValueImpl(
DataBinding binding
)
JScript
protected abstract function GetValueImpl(
binding : DataBinding
) : Object

Parameters

binding
The binding, never null

Return Value

The associated value

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


PopulateMetadata Method

BaseDataItem.PopulateMetadata Method
[image]

Populates the specified metadata map with key/value pairs associated with the data item, if any.

For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateMetadata( _
ByVal map As PropertyBag _
) _
Implements IDataItem.PopulateMetadata
C#
public void PopulateMetadata(
PropertyBag map
)
C++
public:
void PopulateMetadata(
PropertyBag map
) sealed
J#
public void PopulateMetadata(
PropertyBag map
)
JScript
public function PopulateMetadata(
map : PropertyBag
)

Parameters

map
The metadata map

Implements

IDataItem.PopulateMetadata

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


PopulateMetadataImpl Method

BaseDataItem.PopulateMetadataImpl Method
[image]

Implements PopulateMetadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub PopulateMetadataImpl( _
ByVal map As PropertyBag _
)
C#
protected abstract void PopulateMetadataImpl(
PropertyBag map
)
C++
protected:
void PopulateMetadataImpl(
PropertyBag map
) abstract
J#
protected abstract void PopulateMetadataImpl(
PropertyBag map
)
JScript
protected abstract function PopulateMetadataImpl(
map : PropertyBag
)

Parameters

map
The metadata map to populate, never null

See Also

BaseDataItem Class
Gallio.Framework.Data Namespace


BaseDataSet Class

BaseDataSet Class
See Also Example Members
[image]

Abstract base class for IDataSet that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseDataSet
Implements IDataSet, IDataProvider
C#
public abstract class BaseDataSet : IDataSet, IDataProvider
C++
ref class BaseDataSet abstract : IDataSet, IDataProvider
J#
public class BaseDataSet implements IDataSet, IDataProvider
JScript
public class BaseDataSet extends IDataSet, IDataProvider

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Derived types

See Also

BaseDataSet Members
Gallio.Framework.Data Namespace


BaseDataSet Members

BaseDataSet Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for IDataSet that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseDataSet.

Protected Constructors

 | Name | Description
Family method | BaseDataSet | Initializes a new instance of the BaseDataSet class.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


BaseDataSet Constructor

BaseDataSet Constructor
[image]

Initializes a new instance of the BaseDataSet class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseDataSet()
C++
protected:
BaseDataSet() sealed
J#
protected BaseDataSet()
JScript
protected function BaseDataSet()

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


Properties

BaseDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set.
Top

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

BaseDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public abstract int ColumnCount { get; }
C++
public abstract property int ColumnCount abstract {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


Methods

BaseDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


CanBind Method

BaseDataSet.CanBind Method
[image]

Returns true if the data set can provide a value for the specified binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CanBind( _
ByVal binding As DataBinding _
) As Boolean _
Implements IDataSet.CanBind
C#
public bool CanBind(
DataBinding binding
)
C++
public:
bool CanBind(
DataBinding binding
) sealed
J#
public bool CanBind(
DataBinding binding
)
JScript
public function CanBind(
binding : DataBinding
) : bool

Parameters

binding
The binding

Return Value

True if the data set can provide a value for the binding

Implements

IDataSet.CanBind

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


CanBindImpl Method

BaseDataSet.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected abstract bool CanBindImpl(
DataBinding binding
)
C++
protected:
bool CanBindImpl(
DataBinding binding
) abstract
J#
protected abstract bool CanBindImpl(
DataBinding binding
)
JScript
protected abstract function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


GetItems Method

BaseDataSet.GetItems Method
[image]

Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetItems( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem) _
Implements IDataProvider.GetItems
C#
public IEnumerable<IDataItem> GetItems(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
public:
IEnumerable<IDataItem> GetItems(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IDataItem> GetItems(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
public function GetItems(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The bindings that are requested
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The enumeration of data items

Implements

IDataProvider.GetItems

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

BaseDataSet.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected abstract IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) abstract
J#
protected abstract IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected abstract function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


BoundDataAccessor Class

BoundDataAccessor Class
See Also Example Members
[image]

A IDataAccessor that simply accesses a value contained by a data item using a particular DataBinding. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BoundDataAccessor
Inherits BaseDataAccessor
C#
public sealed class BoundDataAccessor : BaseDataAccessor
C++
ref class BoundDataAccessor sealed : BaseDataAccessor
J#
public final class BoundDataAccessor extends BaseDataAccessor
JScript
public final class BoundDataAccessor extends BaseDataAccessor

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataAccessor
Gallio.Framework.Data.BoundDataAccessor

See Also

BoundDataAccessor Members
Gallio.Framework.Data Namespace


BoundDataAccessor Members

BoundDataAccessor Members
See Also Example Constructors Methods
[image]

A IDataAccessor that simply accesses a value contained by a data item using a particular DataBinding. This class cannot be inherited.

The following tables list the members exposed by BoundDataAccessor.

Public Constructors

 | Name | Description
Public method | BoundDataAccessor | Creates a bound data accessor.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets a value derived from the IDataItem. (inherited from BaseDataAccessor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BoundDataAccessor Class
Gallio.Framework.Data Namespace


BoundDataAccessor Constructor

BoundDataAccessor Constructor
[image]

Creates a bound data accessor.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal binding As DataBinding _
)
C#
public BoundDataAccessor(
DataBinding binding
)
C++
public:
BoundDataAccessor(
DataBinding binding
) sealed
J#
public BoundDataAccessor(
DataBinding binding
)
JScript
public function BoundDataAccessor(
binding : DataBinding
)

Parameters

binding
The binding to query

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if binding is null

See Also

BoundDataAccessor Class
Gallio.Framework.Data Namespace


CombinatorialJoinStrategy Class

CombinatorialJoinStrategy Class
See Also Example Members
[image]

The combinatorial join strategy combines items by constructing the cartesian product of the items of each provider. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CombinatorialJoinStrategy
Implements IJoinStrategy
C#
public sealed class CombinatorialJoinStrategy : IJoinStrategy
C++
ref class CombinatorialJoinStrategy sealed : IJoinStrategy
J#
public final class CombinatorialJoinStrategy implements IJoinStrategy
JScript
public final class CombinatorialJoinStrategy extends IJoinStrategy

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.CombinatorialJoinStrategy

See Also

CombinatorialJoinStrategy Members
Gallio.Framework.Data Namespace
PairwiseJoinStrategy


CombinatorialJoinStrategy Members

CombinatorialJoinStrategy Members
See Also Example Fields Methods
[image]

The combinatorial join strategy combines items by constructing the cartesian product of the items of each provider. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by CombinatorialJoinStrategy.

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CombinatorialJoinStrategy Class
Gallio.Framework.Data Namespace
PairwiseJoinStrategy


Fields

CombinatorialJoinStrategy Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

See Also

CombinatorialJoinStrategy Class
Gallio.Framework.Data Namespace
PairwiseJoinStrategy


Instance Field

CombinatorialJoinStrategy.Instance Field
[image]

Gets the singleton instance of the strategy. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As CombinatorialJoinStrategy
C#
public static readonly CombinatorialJoinStrategy Instance;
C++
public:
static const CombinatorialJoinStrategy Instance;
J#
public static final CombinatorialJoinStrategy Instance
JScript
public static const var Instance : CombinatorialJoinStrategy;

See Also

CombinatorialJoinStrategy Class
Gallio.Framework.Data Namespace


Methods

CombinatorialJoinStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CombinatorialJoinStrategy Class
Gallio.Framework.Data Namespace
PairwiseJoinStrategy


Join Method

CombinatorialJoinStrategy.Join Method
[image]

Joins the items from each provider into a sequence of aggregate items.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Join( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindingsPerProvider As IList(Of ICollection(Of DataBinding)), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IList(Of IDataItem)) _
Implements IJoinStrategy.Join
C#
public IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
C++
public:
IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
JScript
public function Join(
providers : IList<IDataProvider>,
bindingsPerProvider : IList<ICollection<DataBinding>>,
includeDynamicItems : bool
) : IEnumerable<IList<IDataItem>>

Parameters

providers
The list of providers
bindingsPerProvider
The list of bindings per provider
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

An enumeration of item-lists consisting of exactly one item from each provider and indexed in the same order as the providers collection

Implements

IJoinStrategy.Join

See Also

CombinatorialJoinStrategy Class
Gallio.Framework.Data Namespace


ConcatenationMergeStrategy Class

ConcatenationMergeStrategy Class
See Also Example Members
[image]

The concatenation merge strategy combines the items from multiple providers by simply concatenating the items in the order in which they appear and proceeding from one provider to the next until all providers have been fully processed. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConcatenationMergeStrategy
Implements IMergeStrategy
C#
public sealed class ConcatenationMergeStrategy : IMergeStrategy
C++
ref class ConcatenationMergeStrategy sealed : IMergeStrategy
J#
public final class ConcatenationMergeStrategy implements IMergeStrategy
JScript
public final class ConcatenationMergeStrategy extends IMergeStrategy

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.ConcatenationMergeStrategy

See Also

ConcatenationMergeStrategy Members
Gallio.Framework.Data Namespace


ConcatenationMergeStrategy Members

ConcatenationMergeStrategy Members
See Also Example Fields Methods
[image]

The concatenation merge strategy combines the items from multiple providers by simply concatenating the items in the order in which they appear and proceeding from one provider to the next until all providers have been fully processed. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ConcatenationMergeStrategy.

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Merge | Merges the items from each provider into a new sequence.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConcatenationMergeStrategy Class
Gallio.Framework.Data Namespace


Fields

ConcatenationMergeStrategy Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

See Also

ConcatenationMergeStrategy Class
Gallio.Framework.Data Namespace


Instance Field

ConcatenationMergeStrategy.Instance Field
[image]

Gets the singleton instance of the strategy. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As ConcatenationMergeStrategy
C#
public static readonly ConcatenationMergeStrategy Instance;
C++
public:
static const ConcatenationMergeStrategy Instance;
J#
public static final ConcatenationMergeStrategy Instance
JScript
public static const var Instance : ConcatenationMergeStrategy;

See Also

ConcatenationMergeStrategy Class
Gallio.Framework.Data Namespace


Methods

ConcatenationMergeStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Merge | Merges the items from each provider into a new sequence.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConcatenationMergeStrategy Class
Gallio.Framework.Data Namespace


Merge Method

ConcatenationMergeStrategy.Merge Method
[image]

Merges the items from each provider into a new sequence.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Merge( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem) _
Implements IMergeStrategy.Merge
C#
public IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
public:
IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
public function Merge(
providers : IList<IDataProvider>,
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

providers
The list of providers
bindings
The bindings
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The merged sequence of items

Implements

IMergeStrategy.Merge

See Also

ConcatenationMergeStrategy Class
Gallio.Framework.Data Namespace


ConstantDataAccessor Class

ConstantDataAccessor Class
See Also Example Members
[image]

An implementation of IDataAccessor that returns a constant value, ignoring the data item it is passed. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConstantDataAccessor
Inherits BaseDataAccessor
C#
public sealed class ConstantDataAccessor : BaseDataAccessor
C++
ref class ConstantDataAccessor sealed : BaseDataAccessor
J#
public final class ConstantDataAccessor extends BaseDataAccessor
JScript
public final class ConstantDataAccessor extends BaseDataAccessor

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataAccessor
Gallio.Framework.Data.ConstantDataAccessor

See Also

ConstantDataAccessor Members
Gallio.Framework.Data Namespace


ConstantDataAccessor Members

ConstantDataAccessor Members
See Also Example Constructors Methods
[image]

An implementation of IDataAccessor that returns a constant value, ignoring the data item it is passed. This class cannot be inherited.

The following tables list the members exposed by ConstantDataAccessor.

Public Constructors

 | Name | Description
Public method | ConstantDataAccessor | Creates a data accessor that returns a specified constant value.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets a value derived from the IDataItem. (inherited from BaseDataAccessor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConstantDataAccessor Class
Gallio.Framework.Data Namespace


ConstantDataAccessor Constructor

ConstantDataAccessor Constructor
[image]

Creates a data accessor that returns a specified constant value.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal value As Object _
)
C#
public ConstantDataAccessor(
object value
)
C++
public:
ConstantDataAccessor(
Object value
) sealed
J#
public ConstantDataAccessor(
object value
)
JScript
public function ConstantDataAccessor(
value : Object
)

Parameters

value
The constant value to be returned by GetValue

See Also

ConstantDataAccessor Class
Gallio.Framework.Data Namespace


CsvDataSet Class

CsvDataSet Class
See Also Example Members
[image]

A CSV data set retrieves fields from a CSV document as strings.

If the CSV document has a header, then it is interpreted as the names of the columns. Columns with names in brackets, such as "[ExpectedException]", are interpreted as containing metadata values associated with the named key.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class CsvDataSet
Inherits BaseDataSet
C#
public class CsvDataSet : BaseDataSet
C++
ref class CsvDataSet : BaseDataSet
J#
public class CsvDataSet extends BaseDataSet
JScript
public class CsvDataSet extends BaseDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.CsvDataSet

See Also

CsvDataSet Members
Gallio.Framework.Data Namespace


CsvDataSet Members

CsvDataSet Members
See Also Example Constructors Properties Methods
[image]

A CSV data set retrieves fields from a CSV document as strings.

If the CSV document has a header, then it is interpreted as the names of the columns. Columns with names in brackets, such as "[ExpectedException]", are interpreted as containing metadata values associated with the named key.

The following tables list the members exposed by CsvDataSet.

Public Constructors

 | Name | Description
Public method | CsvDataSet | Creates a CSV data set.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | CommentPrefix | Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling. Comment lines are excluded from the record set.
Public property | DataLocationName | Gets the name of the location that is providing the data, or null if none. The data location name and line number are exposed as DataLocation metadata when provided.
Public property | FieldDelimiter | Gets or sets the field delimiter character.
Public property | HasHeader | Gets or sets whether the CSV document has a header that should be used to provide aliases for indexed columns.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


CsvDataSet Constructor

CsvDataSet Constructor
[image]

Creates a CSV data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal documentReaderProvider As Func(Of TextReader), _
ByVal isDynamic As Boolean _
)
C#
public CsvDataSet(
Func<TextReader> documentReaderProvider,
bool isDynamic
)
C++
public:
CsvDataSet(
Func<TextReader> documentReaderProvider,
bool isDynamic
) sealed
J#
public CsvDataSet(
Func<TextReader> documentReaderProvider,
bool isDynamic
)
JScript
public function CsvDataSet(
documentReaderProvider : Func<TextReader>,
isDynamic : bool
)

Parameters

documentReaderProvider
A delegate that provides the text reader for reading the CSV document on demand
isDynamic
True if the data set should be considered dynamic

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if documentReaderProvider is null

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


Properties

CsvDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | CommentPrefix | Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling. Comment lines are excluded from the record set.
Public property | DataLocationName | Gets the name of the location that is providing the data, or null if none. The data location name and line number are exposed as DataLocation metadata when provided.
Public property | FieldDelimiter | Gets or sets the field delimiter character.
Public property | HasHeader | Gets or sets whether the CSV document has a header that should be used to provide aliases for indexed columns.
Top

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

CsvDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


CommentPrefix Property

CsvDataSet.CommentPrefix Property
[image]

Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling.

Comment lines are excluded from the record set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CommentPrefix As Char
C#
public char CommentPrefix { get; set; }
C++
public property char CommentPrefix sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_CommentPrefix();

/** property */
public void set_CommentPrefix(char value);
JScript
public function get CommentPrefix() : char

public function set CommentPrefix(value : char);

Property Value

The default value is '#' (pound).

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


DataLocationName Property

CsvDataSet.DataLocationName Property
[image]

Gets the name of the location that is providing the data, or null if none.

The data location name and line number are exposed as DataLocation metadata when provided.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property DataLocationName As String
C#
public string DataLocationName { get; set; }
C++
public property string DataLocationName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DataLocationName();

/** property */
public void set_DataLocationName(string value);
JScript
public function get DataLocationName() : String

public function set DataLocationName(value : String);

Property Value

The default value is null.

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


FieldDelimiter Property

CsvDataSet.FieldDelimiter Property
[image]

Gets or sets the field delimiter character.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldDelimiter As Char
C#
public char FieldDelimiter { get; set; }
C++
public property char FieldDelimiter sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_FieldDelimiter();

/** property */
public void set_FieldDelimiter(char value);
JScript
public function get FieldDelimiter() : char

public function set FieldDelimiter(value : char);

Property Value

The default value is ',' (comma).

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


HasHeader Property

CsvDataSet.HasHeader Property
[image]

Gets or sets whether the CSV document has a header that should be used to provide aliases for indexed columns.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property HasHeader As Boolean
C#
public bool HasHeader { get; set; }
C++
public property bool HasHeader sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_HasHeader();

/** property */
public void set_HasHeader(bool value);
JScript
public function get HasHeader() : bool

public function set HasHeader(value : bool);

Property Value

The default value is 'false' which indicates that the file does not have a header.

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


Methods

CsvDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


CanBindImpl Method

CsvDataSet.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected override bool CanBindImpl(
DataBinding binding
)
C++
protected:
virtual bool CanBindImpl(
DataBinding binding
) override
J#
protected override bool CanBindImpl(
DataBinding binding
)
JScript
protected override function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

CsvDataSet.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
virtual IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) override
J#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected override function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

CsvDataSet Class
Gallio.Framework.Data Namespace


CsvReader Class

CsvReader Class
See Also Example Members
[image]

Reads data from a Comma Separated Values document.

The document format simply consists of sequential lines of delimited field values.

  • The standard delimiter is ',' (comma) but it may be overridden using FieldDelimiter.
  • Empty lines are considered to be records with one empty field.
  • Lines that begin with a special CommentPrefix are excluded from the record set.
  • Field values may be quoted using '"' (quote) characters. The quotes will be omitted from the record set. Quotes may be escaped by doubling them within a quoted field.
  • Unbalanced quotes are tolerated but may produce unexpected results.
  • Excess whitespace is trimmed unless quoted.
  • The document may contain a header consiting of field names but the reader does not interpret it in any special way. It will simply be returned to the client as an ordinary record.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class CsvReader
Implements IDisposable
C#
public class CsvReader : IDisposable
C++
ref class CsvReader : IDisposable
J#
public class CsvReader implements IDisposable
JScript
public class CsvReader extends IDisposable

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.CsvReader

See Also

CsvReader Members
Gallio.Framework.Data Namespace


CsvReader Members

CsvReader Members
See Also Example Constructors Properties Methods
[image]

Reads data from a Comma Separated Values document.

The document format simply consists of sequential lines of delimited field values.

  • The standard delimiter is ',' (comma) but it may be overridden using FieldDelimiter.
  • Empty lines are considered to be records with one empty field.
  • Lines that begin with a special CommentPrefix are excluded from the record set.
  • Field values may be quoted using '"' (quote) characters. The quotes will be omitted from the record set. Quotes may be escaped by doubling them within a quoted field.
  • Unbalanced quotes are tolerated but may produce unexpected results.
  • Excess whitespace is trimmed unless quoted.
  • The document may contain a header consiting of field names but the reader does not interpret it in any special way. It will simply be returned to the client as an ordinary record.

The following tables list the members exposed by CsvReader.

Public Constructors

 | Name | Description
Public method | CsvReader | Creates a CSV reader.
Top

Public Properties

 | Name | Description
Public property | CommentPrefix | Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling. Comment lines are excluded from the record set.
Public property | FieldDelimiter | Gets or sets the field delimiter character.
Public property | PreviousRecordLineNumber | Gets the 1-based line number of the previously returned record, or 0 if no lines have been read yet.
Top

Public Methods

 | Name | Description
Public method | Close | Closes the reader.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ReadRecord | Reads the list of fields that belong to the next record in the document. Returns null at the end of the document.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CsvReader Class
Gallio.Framework.Data Namespace


CsvReader Constructor

CsvReader Constructor
[image]

Creates a CSV reader.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal documentReader As TextReader _
)
C#
public CsvReader(
TextReader documentReader
)
C++
public:
CsvReader(
TextReader documentReader
) sealed
J#
public CsvReader(
TextReader documentReader
)
JScript
public function CsvReader(
documentReader : TextReader
)

Parameters

documentReader
The text reader from which to read the contents of the document

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if documentReader is null

See Also

CsvReader Class
Gallio.Framework.Data Namespace


Properties

CsvReader Properties
[image]

Public Properties

 | Name | Description
Public property | CommentPrefix | Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling. Comment lines are excluded from the record set.
Public property | FieldDelimiter | Gets or sets the field delimiter character.
Public property | PreviousRecordLineNumber | Gets the 1-based line number of the previously returned record, or 0 if no lines have been read yet.
Top

See Also

CsvReader Class
Gallio.Framework.Data Namespace


CommentPrefix Property

CsvReader.CommentPrefix Property
[image]

Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling.

Comment lines are excluded from the record set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CommentPrefix As Char
C#
public char CommentPrefix { get; set; }
C++
public property char CommentPrefix sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_CommentPrefix();

/** property */
public void set_CommentPrefix(char value);
JScript
public function get CommentPrefix() : char

public function set CommentPrefix(value : char);

Property Value

The default value is '#' (pound).

See Also

CsvReader Class
Gallio.Framework.Data Namespace


FieldDelimiter Property

CsvReader.FieldDelimiter Property
[image]

Gets or sets the field delimiter character.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldDelimiter As Char
C#
public char FieldDelimiter { get; set; }
C++
public property char FieldDelimiter sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_FieldDelimiter();

/** property */
public void set_FieldDelimiter(char value);
JScript
public function get FieldDelimiter() : char

public function set FieldDelimiter(value : char);

Property Value

The default value is ',' (comma).

See Also

CsvReader Class
Gallio.Framework.Data Namespace


PreviousRecordLineNumber Property

CsvReader.PreviousRecordLineNumber Property
[image]

Gets the 1-based line number of the previously returned record, or 0 if no lines have been read yet.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviousRecordLineNumber As Integer
C#
public int PreviousRecordLineNumber { get; }
C++
public property int PreviousRecordLineNumber sealed {
int get();
}
J#
/** property */
public int get_PreviousRecordLineNumber();
JScript
public function get PreviousRecordLineNumber() : int

See Also

CsvReader Class
Gallio.Framework.Data Namespace


Methods

CsvReader Methods
[image]

Public Methods

 | Name | Description
Public method | Close | Closes the reader.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ReadRecord | Reads the list of fields that belong to the next record in the document. Returns null at the end of the document.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CsvReader Class
Gallio.Framework.Data Namespace


Close Method

CsvReader.Close Method
[image]

Closes the reader.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()
C++
public:
void Close() sealed
J#
public void Close()
JScript
public function Close()

See Also

CsvReader Class
Gallio.Framework.Data Namespace


ReadRecord Method

CsvReader.ReadRecord Method
[image]

Reads the list of fields that belong to the next record in the document. Returns null at the end of the document.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadRecord() As String()
C#
public string[] ReadRecord()
C++
public:
array<String>^ ReadRecord() sealed
J#
public string[] ReadRecord()
JScript
public function ReadRecord() : String[]

Return Value

The record contents as an array of field values, or null if at the end of the document

Exceptions

Exception Type | Condition
IOException | Thrown if an I/O error occurs

See Also

CsvReader Class
Gallio.Framework.Data Namespace


DataBinding Class

DataBinding Class
See Also Example Members
[image]

A data binding object describes how a data binding is to take place.

This class provides support for optional path-based and index-based lookup. Subclasses may provide additional properties that are recognized by special kinds of data sets to modify how a bound value is resolved.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DataBinding
Implements IEquatable(Of DataBinding)
C#
public class DataBinding : IEquatable<DataBinding>
C++
ref class DataBinding : IEquatable<DataBinding>
J#
public class DataBinding implements IEquatable<DataBinding>
JScript
public class DataBinding extends IEquatable<DataBinding>

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataBinding

See Also

DataBinding Members
Gallio.Framework.Data Namespace


DataBinding Members

DataBinding Members
See Also Example Constructors Properties Methods
[image]

A data binding object describes how a data binding is to take place.

This class provides support for optional path-based and index-based lookup. Subclasses may provide additional properties that are recognized by special kinds of data sets to modify how a bound value is resolved.

The following tables list the members exposed by DataBinding.

Public Constructors

 | Name | Description
Public method | DataBinding | Creates a new data binding with an optional index and path.
Top

Public Properties

 | Name | Description
Public property | Index | Gets an optional binding index that describes how to locate the bound value in a data set that is structured as an ordered tuple, such as the ordinal index of a cell in an array. Null if none.
Public property | Path | Gets an optional binding path that describes how to locate the bound value in the data set, such as a column name or an XPath expression. Null if none.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ReplaceIndex | Creates a clone of the data binding with a different index.
Public method | ToString | Overridden. Returns a debug representation of the binding as a string.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DataBinding Class
Gallio.Framework.Data Namespace


DataBinding Constructor

DataBinding Constructor
[image]

Creates a new data binding with an optional index and path.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal index As Nullable(Of Integer), _
ByVal path As String _
)
C#
public DataBinding(
Nullable<int> index,
string path
)
C++
public:
DataBinding(
Nullable<int> index,
String path
) sealed
J#
public DataBinding(
Nullable<int> index,
string path
)
JScript
public function DataBinding(
index : Nullable<int>,
path : String
)

Parameters

index
The binding index or null if none.
path
The binding path or null if none.

See Also

DataBinding Class
Gallio.Framework.Data Namespace
Index
Path


Properties

DataBinding Properties
[image]

Public Properties

 | Name | Description
Public property | Index | Gets an optional binding index that describes how to locate the bound value in a data set that is structured as an ordered tuple, such as the ordinal index of a cell in an array. Null if none.
Public property | Path | Gets an optional binding path that describes how to locate the bound value in the data set, such as a column name or an XPath expression. Null if none.
Top

See Also

DataBinding Class
Gallio.Framework.Data Namespace


Index Property

DataBinding.Index Property
[image]

Gets an optional binding index that describes how to locate the bound value in a data set that is structured as an ordered tuple, such as the ordinal index of a cell in an array. Null if none.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Index As Nullable(Of Integer)
C#
public virtual Nullable<int> Index { get; }
C++
public virtual property Nullable<int> Index {
Nullable<int> get();
}
J#
/** property */
public Nullable<int> get_Index();
JScript
public function get Index() : Nullable<int>

Remarks

The default binding index for a test parameter may be its ordinal index in the parameter array. A data set can take advantage of this convention by treating the binding index

See Also

DataBinding Class
Gallio.Framework.Data Namespace


Path Property

DataBinding.Path Property
[image]

Gets an optional binding path that describes how to locate the bound value in the data set, such as a column name or an XPath expression. Null if none.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Path As String
C#
public virtual string Path { get; }
C++
public virtual property string Path {
String get();
}
J#
/** property */
public string get_Path();
JScript
public function get Path() : String

Remarks

The default binding path for a test parameter may be the name of the test parameter. A data set can take advantage of this convention by treating the binding path as a case-insensitive name where appropriate.

See Also

DataBinding Class
Gallio.Framework.Data Namespace


Methods

DataBinding Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ReplaceIndex | Creates a clone of the data binding with a different index.
Public method | ToString | Overridden. Returns a debug representation of the binding as a string.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DataBinding Class
Gallio.Framework.Data Namespace


Equals Method

DataBinding.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (DataBinding) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

DataBinding Class
Gallio.Framework.Data Namespace


Equals Method (DataBinding)

DataBinding.Equals Method (DataBinding)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Equals( _
ByVal other As DataBinding _
) As Boolean _
Implements IEquatable<DataBinding>.Equals
C#
public virtual bool Equals(
DataBinding other
)
C++
public:
virtual bool Equals(
DataBinding other
)
J#
public virtual bool Equals(
DataBinding other
)
JScript
public virtual function Equals(
other : DataBinding
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<DataBinding>.Equals

See Also

DataBinding Class
Gallio.Framework.Data Namespace
DataBinding.Equals Overload List


Equals Method (Object)

DataBinding.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

DataBinding Class
Gallio.Framework.Data Namespace
DataBinding.Equals Overload List


GetHashCode Method

DataBinding.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

DataBinding Class
Gallio.Framework.Data Namespace


ReplaceIndex Method

DataBinding.ReplaceIndex Method
[image]

Creates a clone of the data binding with a different index.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ReplaceIndex( _
ByVal index As Nullable(Of Integer) _
) As DataBinding
C#
public virtual DataBinding ReplaceIndex(
Nullable<int> index
)
C++
public:
virtual DataBinding ReplaceIndex(
Nullable<int> index
)
J#
public virtual DataBinding ReplaceIndex(
Nullable<int> index
)
JScript
public virtual function ReplaceIndex(
index : Nullable<int>
) : DataBinding

Parameters

index
The new index

Return Value

The cloned binding

See Also

DataBinding Class
Gallio.Framework.Data Namespace


ToString Method

DataBinding.ToString Method
[image]

Returns a debug representation of the binding as a string.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The string representation

See Also

DataBinding Class
Gallio.Framework.Data Namespace


DataBindingContext Class

DataBindingContext Class
See Also Example Members
[image]

A DataBindingContext tracks a list of IDataSets and DataBindings that are used to produce IDataItems. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataBindingContext
C#
public sealed class DataBindingContext
C++
ref class DataBindingContext sealed
J#
public final class DataBindingContext
JScript
public final class DataBindingContext

Remarks

In typical usage, a IDataBinder registers interest in obtaining data from a particular IDataSet by providing a corresponding DataBinding. The DataBindingContext then adds the requested IDataSet to its DataSets list and returns a IDataAccessor. When GetItems is called, the DataBindingContext produces an enumeration of IDataItem. Data-bound values can then be obtained from the IDataItem via the GetValue method of each accessor.

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataBindingContext

See Also

DataBindingContext Members
Gallio.Framework.Data Namespace
IDataBinder


DataBindingContext Members

DataBindingContext Members
See Also Example Constructors Properties Methods
[image]

A DataBindingContext tracks a list of IDataSets and DataBindings that are used to produce IDataItems. This class cannot be inherited.

The following tables list the members exposed by DataBindingContext.

Public Constructors

 | Name | Description
Public method | DataBindingContext | Creates a data binding context.
Top

Public Properties

 | Name | Description
Public property | Converter | Gets the converter service.
Public property | DataSets | Gets the immutable list of data sets to be enumerated during data binding.
Public property | HasBindings | Returns true if the data binding context contains registered data bindings.
Public property | Strategy | Gets or sets the IJoinStrategy to use for combining the DataSets together. By default the strategy is CombinatorialJoinStrategy.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of IDataItems. The contents of each item may be inspected using a IDataAccessor as returned by RegisterBinding. When the client is finished with an item, it should dispose it by calling the Dispose method of the IDataItem.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RegisterBinding | Registers a data binding for a given data set and adds the data set to the list of data sets to be enumerated during data binding. Returns a IDataAccessor that may be used to retrieve the values associated with the binding.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace
IDataBinder


DataBindingContext Constructor

DataBindingContext Constructor
[image]

Creates a data binding context.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal converter As IConverter _
)
C#
public DataBindingContext(
IConverter converter
)
C++
public:
DataBindingContext(
IConverter converter
) sealed
J#
public DataBindingContext(
IConverter converter
)
JScript
public function DataBindingContext(
converter : IConverter
)

Parameters

converter
The converter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if converter is null

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


Properties

DataBindingContext Properties
[image]

Public Properties

 | Name | Description
Public property | Converter | Gets the converter service.
Public property | DataSets | Gets the immutable list of data sets to be enumerated during data binding.
Public property | HasBindings | Returns true if the data binding context contains registered data bindings.
Public property | Strategy | Gets or sets the IJoinStrategy to use for combining the DataSets together. By default the strategy is CombinatorialJoinStrategy.
Top

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace
IDataBinder


Converter Property

DataBindingContext.Converter Property
[image]

Gets the converter service.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Converter As IConverter
C#
public IConverter Converter { get; }
C++
public property IConverter Converter sealed {
IConverter get();
}
J#
/** property */
public IConverter get_Converter();
JScript
public function get Converter() : IConverter

Remarks

The data binding context does not use the converter itself, but it may be used by data binders to perform any required internal conversions.

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


DataSets Property

DataBindingContext.DataSets Property
[image]

Gets the immutable list of data sets to be enumerated during data binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSets As IList(Of IDataSet)
C#
public IList<IDataSet> DataSets { get; }
C++
public property IList<IDataSet> DataSets sealed {
IList<IDataSet> get();
}
J#
/** property */
public IList<IDataSet> get_DataSets();
JScript
public function get DataSets() : IList<IDataSet>

Remarks

These are the IDataSets from which the raw data for binding will be retrieved.

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


HasBindings Property

DataBindingContext.HasBindings Property
[image]

Returns true if the data binding context contains registered data bindings.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasBindings As Boolean
C#
public bool HasBindings { get; }
C++
public property bool HasBindings sealed {
bool get();
}
J#
/** property */
public bool get_HasBindings();
JScript
public function get HasBindings() : bool

Remarks

If the context contains no data bindings then by definition it also contains no data sets. In the absence of bindings, GetItems will produce exactly one IDataItem (a NullDataItem) and no data binding work will actually need to be performed by the client. Consequently a client may choose to treat this situation as a special case and may adopt a different (possibly simpler) algorithm in response.

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


Strategy Property

DataBindingContext.Strategy Property
[image]

Gets or sets the IJoinStrategy to use for combining the DataSets together. By default the strategy is CombinatorialJoinStrategy.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Strategy As IJoinStrategy
C#
public IJoinStrategy Strategy { get; set; }
C++
public property IJoinStrategy Strategy sealed {
IJoinStrategy get();
void set(IJoinStrategy value);
}
J#
/** property */
public IJoinStrategy get_Strategy();

/** property */
public void set_Strategy(IJoinStrategy value);
JScript
public function get Strategy() : IJoinStrategy

public function set Strategy(value : IJoinStrategy);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


Methods

DataBindingContext Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of IDataItems. The contents of each item may be inspected using a IDataAccessor as returned by RegisterBinding. When the client is finished with an item, it should dispose it by calling the Dispose method of the IDataItem.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RegisterBinding | Registers a data binding for a given data set and adds the data set to the list of data sets to be enumerated during data binding. Returns a IDataAccessor that may be used to retrieve the values associated with the binding.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace
IDataBinder


GetItems Method

DataBindingContext.GetItems Method
[image]

Gets an enumeration of IDataItems.

The contents of each item may be inspected using a IDataAccessor as returned by RegisterBinding. When the client is finished with an item, it should dispose it by calling the Dispose method of the IDataItem.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetItems( _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
public IEnumerable<IDataItem> GetItems(
bool includeDynamicItems
)
C++
public:
IEnumerable<IDataItem> GetItems(
bool includeDynamicItems
) sealed
J#
public IEnumerable<IDataItem> GetItems(
bool includeDynamicItems
)
JScript
public function GetItems(
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The enumeration of data items

Remarks

A client typically registers its IDataBinders with the DataBindingContext then enters a loop to enumerate the items. For each item, the client will call GetValue to retrieve the values of interest. When it is finished with an item, it disposes it and proceeds on to the next one or stops. In this manner, a client may apply multiple IDataBinders within the same DataBindingContext.

If no data bindings have been registered (HasBindings is false), this method returns exactly one data item consisting of a NullDataItem.

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


RegisterBinding Method

DataBindingContext.RegisterBinding Method
[image]

Registers a data binding for a given data set and adds the data set to the list of data sets to be enumerated during data binding. Returns a IDataAccessor that may be used to retrieve the values associated with the binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function RegisterBinding( _
ByVal dataSet As IDataSet, _
ByVal binding As DataBinding _
) As IDataAccessor
C#
public IDataAccessor RegisterBinding(
IDataSet dataSet,
DataBinding binding
)
C++
public:
IDataAccessor RegisterBinding(
IDataSet dataSet,
DataBinding binding
) sealed
J#
public IDataAccessor RegisterBinding(
IDataSet dataSet,
DataBinding binding
)
JScript
public function RegisterBinding(
dataSet : IDataSet,
binding : DataBinding
) : IDataAccessor

Parameters

dataSet
The data set
binding
The data binding

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if dataSet or binding is null

Remarks

A IDataBinder uses this method to register interest in querying a particular IDataSet. It must do so before GetItems is called to ensure that the IDataSet is included in the enumeration.

See Also

DataBindingContext Class
Gallio.Framework.Data Namespace


DataBindingException Class

DataBindingException Class
See Also Example Members
[image]

The type of exception thrown when data binding operations fail.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class DataBindingException
Inherits Exception
C#
[SerializableAttribute]
public class DataBindingException : Exception
C++
[SerializableAttribute]
ref class DataBindingException : Exception
J#
/** @attribute SerializableAttribute() */
public class DataBindingException extends Exception
JScript
public
SerializableAttribute
class DataBindingException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.Data.DataBindingException

See Also

DataBindingException Members
Gallio.Framework.Data Namespace


DataBindingException Members

DataBindingException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when data binding operations fail.

The following tables list the members exposed by DataBindingException.

Public Constructors

Name | Description
DataBindingException | Overloaded. Initializes a new instance of the DataBindingException class.
Top

Protected Constructors

Name | Description
DataBindingException | Overloaded. Initializes a new instance of the DataBindingException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DataBindingException | Overloaded. Initializes a new instance of the DataBindingException class.
Top

See Also

DataBindingException Class
Gallio.Framework.Data Namespace


DataBindingException Constructor

DataBindingException Constructor

Initializes a new instance of the DataBindingException class.

Overload List

 | Name | Description
Public method | DataBindingException | Creates an exception.
Family method | DataBindingException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | DataBindingException (String) | Creates an exception.
Public method | DataBindingException (String, DataBinding) | Creates an exception with an associated data binding.
Public method | DataBindingException (String, DataBinding, Exception) | Creates an exception with an associated data binding.
Public method | DataBindingException (String, Exception) | Creates an exception.

See Also

DataBindingException Class
Gallio.Framework.Data Namespace


DataBindingException Constructor ()

DataBindingException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DataBindingException()
C++
public:
DataBindingException() sealed
J#
public DataBindingException()
JScript
public function DataBindingException()

See Also

DataBindingException Class
Gallio.Framework.Data Namespace
DataBindingException Constructor Overload List


DataBindingException Constructor (SerializationInfo, StreamingContext)

DataBindingException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected DataBindingException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
DataBindingException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected DataBindingException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function DataBindingException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

DataBindingException Class
Gallio.Framework.Data Namespace
DataBindingException Constructor Overload List


DataBindingException Constructor (String)

DataBindingException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public DataBindingException(
string message
)
C++
public:
DataBindingException(
String message
) sealed
J#
public DataBindingException(
string message
)
JScript
public function DataBindingException(
message : String
)

Parameters

message
The message

See Also

DataBindingException Class
Gallio.Framework.Data Namespace
DataBindingException Constructor Overload List


DataBindingException Constructor (String, DataBinding)

DataBindingException Constructor (String, DataBinding)
See Also Example
[image]

Creates an exception with an associated data binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal binding As DataBinding _
)
C#
public DataBindingException(
string message,
DataBinding binding
)
C++
public:
DataBindingException(
String message,
DataBinding binding
) sealed
J#
public DataBindingException(
string message,
DataBinding binding
)
JScript
public function DataBindingException(
message : String,
binding : DataBinding
)

Parameters

message
The message
binding
The associated data binding, or null if none

See Also

DataBindingException Class
Gallio.Framework.Data Namespace
DataBindingException Constructor Overload List


DataBindingException Constructor (String, DataBinding, Exception)

DataBindingException Constructor (String, DataBinding, Exception)
See Also Example
[image]

Creates an exception with an associated data binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal binding As DataBinding, _
ByVal innerException As Exception _
)
C#
public DataBindingException(
string message,
DataBinding binding,
Exception innerException
)
C++
public:
DataBindingException(
String message,
DataBinding binding,
Exception innerException
) sealed
J#
public DataBindingException(
string message,
DataBinding binding,
Exception innerException
)
JScript
public function DataBindingException(
message : String,
binding : DataBinding,
innerException : Exception
)

Parameters

message
The message
binding
The associated data binding, or null if none
innerException
The inner exception

See Also

DataBindingException Class
Gallio.Framework.Data Namespace
DataBindingException Constructor Overload List


DataBindingException Constructor (String, Exception)

DataBindingException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public DataBindingException(
string message,
Exception innerException
)
C++
public:
DataBindingException(
String message,
Exception innerException
) sealed
J#
public DataBindingException(
string message,
Exception innerException
)
JScript
public function DataBindingException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

DataBindingException Class
Gallio.Framework.Data Namespace
DataBindingException Constructor Overload List


DataBindingSpec Class

DataBindingSpec Class
See Also Example Members
[image]

A data binding specification describes how values are bound to slots (ISlotInfo) of a type or method. The specification can then be used to create new objects or invoke methods.

A specification automatically converts values to the correct types for data binding using a IConverter. It can also format the specification to a string using a IFormatter.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DataBindingSpec
C#
public abstract class DataBindingSpec
C++
ref class DataBindingSpec abstract
J#
public class DataBindingSpec
JScript
public class DataBindingSpec

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataBindingSpec
Gallio.Framework.Data.MethodInvocationSpec
Gallio.Framework.Data.ObjectCreationSpec

See Also

DataBindingSpec Members
Gallio.Framework.Data Namespace
ObjectCreationSpec


DataBindingSpec Members

DataBindingSpec Members
See Also Example Constructors Properties Methods
[image]

A data binding specification describes how values are bound to slots (ISlotInfo) of a type or method. The specification can then be used to create new objects or invoke methods.

A specification automatically converts values to the correct types for data binding using a IConverter. It can also format the specification to a string using a IFormatter.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by DataBindingSpec.

Protected Constructors

 | Name | Description
Family method | DataBindingSpec | Creates a data binding spec.
Top

Public Properties

 | Name | Description
Public property | Converter | Gets the converter.
Public property | SlotValues | Gets the slot values.
Top

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method Format

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

Name | Description
AppendFormattedGenericArguments | Appends formatted generic arguments within angle brackets, if any.
AppendFormattedMethodArguments | Appends formatted generic arguments within parentheses, if any.
AppendFormattedNamedValues | Appends formatted values keyed and sorted by name, if any. This method is used with fields and properties.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FormatImpl | Internal implementation of Format after argument validation.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
ResolveMember

Resolves a member that may be declared by a generic type using the resolved type or one of its subtypes.

For example, if member was declared by type Foo<T> and resolvedType is a subtype of Foo<int>, returns a reflection object for the member as declared by Foo<int>.

Top

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace
ObjectCreationSpec


DataBindingSpec Constructor

DataBindingSpec Constructor
[image]

Creates a data binding spec.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal slotValues As IEnumerable(Of KeyValuePair(Of ISlotInfo, Object)), _
ByVal converter As IConverter _
)
C#
protected DataBindingSpec(
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
)
C++
protected:
DataBindingSpec(
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
) sealed
J#
protected DataBindingSpec(
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
)
JScript
protected function DataBindingSpec(
slotValues : IEnumerable<KeyValuePair<ISlotInfo, object>>,
converter : IConverter
)

Parameters

slotValues
The slot values
converter
The converter to use for converting slot values to the required types

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if slotValues or converter is null or if slotValues contains a null slot

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


Properties

DataBindingSpec Properties
[image]

Public Properties

 | Name | Description
Public property | Converter | Gets the converter.
Public property | SlotValues | Gets the slot values.
Top

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace
ObjectCreationSpec


Converter Property

DataBindingSpec.Converter Property
[image]

Gets the converter.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Converter As IConverter
C#
public IConverter Converter { get; }
C++
public property IConverter Converter sealed {
IConverter get();
}
J#
/** property */
public IConverter get_Converter();
JScript
public function get Converter() : IConverter

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


SlotValues Property

DataBindingSpec.SlotValues Property
[image]

Gets the slot values.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SlotValues As IEnumerable(Of KeyValuePair(Of ISlotInfo, Object))
C#
public IEnumerable<KeyValuePair<ISlotInfo, object>> SlotValues { get; }
C++
public property IEnumerable<KeyValuePair<ISlotInfo, object>> SlotValues sealed {
IEnumerable<KeyValuePair<ISlotInfo, object>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<ISlotInfo, object>> get_SlotValues();
JScript
public function get SlotValues() : IEnumerable<KeyValuePair<ISlotInfo, object>>

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


Methods

DataBindingSpec Methods
[image]

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method Format

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

Name | Description
AppendFormattedGenericArguments | Appends formatted generic arguments within angle brackets, if any.
AppendFormattedMethodArguments | Appends formatted generic arguments within parentheses, if any.
AppendFormattedNamedValues | Appends formatted values keyed and sorted by name, if any. This method is used with fields and properties.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FormatImpl | Internal implementation of Format after argument validation.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
ResolveMember

Resolves a member that may be declared by a generic type using the resolved type or one of its subtypes.

For example, if member was declared by type Foo<T> and resolvedType is a subtype of Foo<int>, returns a reflection object for the member as declared by Foo<int>.

Top

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace
ObjectCreationSpec


AppendFormattedGenericArguments Method

DataBindingSpec.AppendFormattedGenericArguments Method
[image]

Appends formatted generic arguments within angle brackets, if any.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AppendFormattedGenericArguments( _
ByVal str As StringBuilder, _
ByVal arguments As Type(), _
ByVal formatter As IFormatter _
)
C#
protected static void AppendFormattedGenericArguments(
StringBuilder str,
Type[] arguments,
IFormatter formatter
)
C++
protected:
static void AppendFormattedGenericArguments(
StringBuilder str,
array<Type>^ arguments,
IFormatter formatter
)
J#
protected static void AppendFormattedGenericArguments(
StringBuilder str,
Type[] arguments,
IFormatter formatter
)
JScript
protected static function AppendFormattedGenericArguments(
str : StringBuilder,
arguments : Type[],
formatter : IFormatter
)

Parameters

str
The string builder, not null
arguments
The arguments, not null
formatter
The formatter, not null

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


AppendFormattedMethodArguments Method

DataBindingSpec.AppendFormattedMethodArguments Method
[image]

Appends formatted generic arguments within parentheses, if any.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AppendFormattedMethodArguments( _
ByVal str As StringBuilder, _
ByVal arguments As Object(), _
ByVal formatter As IFormatter _
)
C#
protected static void AppendFormattedMethodArguments(
StringBuilder str,
object[] arguments,
IFormatter formatter
)
C++
protected:
static void AppendFormattedMethodArguments(
StringBuilder str,
array<Object>^ arguments,
IFormatter formatter
)
J#
protected static void AppendFormattedMethodArguments(
StringBuilder str,
object[] arguments,
IFormatter formatter
)
JScript
protected static function AppendFormattedMethodArguments(
str : StringBuilder,
arguments : Object[],
formatter : IFormatter
)

Parameters

str
The string builder, not null
arguments
The arguments, not null
formatter
The formatter, not null

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


AppendFormattedNamedValues Method

DataBindingSpec.AppendFormattedNamedValues Method
[image]

Appends formatted values keyed and sorted by name, if any. This method is used with fields and properties.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AppendFormattedNamedValues( _
ByVal str As StringBuilder, _
ByVal namedValues As IEnumerable(Of KeyValuePair(Of String, Object)), _
ByVal formatter As IFormatter _
)
C#
protected static void AppendFormattedNamedValues(
StringBuilder str,
IEnumerable<KeyValuePair<string, object>> namedValues,
IFormatter formatter
)
C++
protected:
static void AppendFormattedNamedValues(
StringBuilder str,
IEnumerable<KeyValuePair<string, object>> namedValues,
IFormatter formatter
)
J#
protected static void AppendFormattedNamedValues(
StringBuilder str,
IEnumerable<KeyValuePair<string, object>> namedValues,
IFormatter formatter
)
JScript
protected static function AppendFormattedNamedValues(
str : StringBuilder,
namedValues : IEnumerable<KeyValuePair<string, object>>,
formatter : IFormatter
)

Parameters

str
The string builder, not null
namedValues
The named values, not null
formatter
The formatter, not null

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


Format Method

DataBindingSpec.Format Method
[image]

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal entity As String, _
ByVal formatter As IFormatter _
) As String
C#
public string Format(
string entity,
IFormatter formatter
)
C++
public:
String Format(
String entity,
IFormatter formatter
) sealed
J#
public string Format(
string entity,
IFormatter formatter
)
JScript
public function Format(
entity : String,
formatter : IFormatter
) : String

Parameters

entity
The entity that is qualified by the specification such as the name of a type or method
formatter
The formatter

Return Value

The formatted specification

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if entity or formatter is null

Remarks

This method assumes that the slots all belong to the same declaring type or method which is always the case for ObjectCreationSpec and MethodInvocationSpec.

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


FormatImpl Method

DataBindingSpec.FormatImpl Method
[image]

Internal implementation of Format after argument validation.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function FormatImpl( _
ByVal entity As String, _
ByVal formatter As IFormatter _
) As String
C#
protected abstract string FormatImpl(
string entity,
IFormatter formatter
)
C++
protected:
String FormatImpl(
String entity,
IFormatter formatter
) abstract
J#
protected abstract string FormatImpl(
string entity,
IFormatter formatter
)
JScript
protected abstract function FormatImpl(
entity : String,
formatter : IFormatter
) : String

Parameters

entity
The entity that is qualified by the specification such as the name of a type or method
formatter
The formatter, not null

Return Value

The formatted specification

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


ResolveMember Generic Method

DataBindingSpec.ResolveMember Generic Method
[image]

Resolves a member that may be declared by a generic type using the resolved type or one of its subtypes.

For example, if member was declared by type Foo<T> and resolvedType is a subtype of Foo<int>, returns a reflection object for the member as declared by Foo<int>.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function ResolveMember(Of T As MemberInfo)( _
ByVal resolvedType As Type, _
ByVal member As T _
)
C#
protected static T ResolveMember<T>(
Type resolvedType,
T member
) where T : MemberInfo
C++
protected:
static T ResolveMember<T>(
Type resolvedType,
T member
)
J#
protected static T ResolveMember<T>(
Type resolvedType,
T member
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of member

Parameters

resolvedType
The resolved type, not null
member
The member, not null

Return Value

The resolved member

See Also

DataBindingSpec Class
Gallio.Framework.Data Namespace


DataItemUtils Class

DataItemUtils Class
See Also Example Members
[image]

Utilities for IDataItem. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module DataItemUtils
C#
public static class DataItemUtils
C++
ref class DataItemUtils abstract sealed
J#
public final class DataItemUtils
JScript
public class DataItemUtils

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataItemUtils

See Also

DataItemUtils Members
Gallio.Framework.Data Namespace


DataItemUtils Members

DataItemUtils Members
See Also Example Methods
[image]

Utilities for IDataItem. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by DataItemUtils.

Public Methods

Name | Description
GetMetadata | Gets the metadata associated with a data item.
Top

See Also

DataItemUtils Class
Gallio.Framework.Data Namespace


Methods

DataItemUtils Methods
[image]

Public Methods

Name | Description
GetMetadata | Gets the metadata associated with a data item.
Top

See Also

DataItemUtils Class
Gallio.Framework.Data Namespace


GetMetadata Method

DataItemUtils.GetMetadata Method
[image]

Gets the metadata associated with a data item.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetMetadata( _
ByVal dataItem As IDataItem _
) As PropertyBag
C#
public static PropertyBag GetMetadata(
IDataItem dataItem
)
C++
public:
static PropertyBag GetMetadata(
IDataItem dataItem
)
J#
public static PropertyBag GetMetadata(
IDataItem dataItem
)
JScript
public static function GetMetadata(
dataItem : IDataItem
) : PropertyBag

Parameters

dataItem
The data item

Return Value

The associated metadata

See Also

DataItemUtils Class
Gallio.Framework.Data Namespace


DataRow Class

DataRow Class
See Also Example Members
[image]

A data row is a simple immutable value type that encpasulates an array of values along with associated metadata for use in data binding expressions. It presents a fluent interface that users may find more convenient than other IDataItem implementations.

The data in a DataRow is always considered dynamic.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DataRow
Inherits BaseDataItem
C#
public class DataRow : BaseDataItem
C++
ref class DataRow : BaseDataItem
J#
public class DataRow extends BaseDataItem
JScript
public class DataRow extends BaseDataItem

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataItem
Gallio.Framework.Data.DataRow

See Also

DataRow Members
Gallio.Framework.Data Namespace


DataRow Members

DataRow Members
See Also Example Constructors Properties Methods
[image]

A data row is a simple immutable value type that encpasulates an array of values along with associated metadata for use in data binding expressions. It presents a fluent interface that users may find more convenient than other IDataItem implementations.

The data in a DataRow is always considered dynamic.

The following tables list the members exposed by DataRow.

Public Constructors

 | Name | Description
Public method | DataRow | Creates a data row with the specified array of values.
Top

Public Properties

Name Description
Public property IsDynamic Overridden.

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WithMetadata | Overloaded. Returns an augmented data row with added metadata from the specified metadata map.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Overridden. Implements GetValue.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateMetadataImpl | Overridden. Implements PopulateMetadata.
Top

See Also

DataRow Class
Gallio.Framework.Data Namespace


DataRow Constructor

DataRow Constructor
[image]

Creates a data row with the specified array of values.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal ParamArray values As Object() _
)
C#
public DataRow(
params object[] values
)
C++
public:
DataRow(
... array<Object>^ values
) sealed
J#
public DataRow(
object[] values
)
JScript
public function DataRow(
ParamArrayAttribute values : Object[]
)

Parameters

values
The array of values

See Also

DataRow Class
Gallio.Framework.Data Namespace


Properties

DataRow Properties
[image]

Public Properties

Name Description
Public property IsDynamic Overridden.

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

See Also

DataRow Class
Gallio.Framework.Data Namespace


IsDynamic Property

DataRow.IsDynamic Property
[image]

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDynamic As Boolean _
Implements IDataItem.IsDynamic
C#
public override bool IsDynamic { get; }
C++
public override property bool IsDynamic override {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

Implements

IDataItem.IsDynamic

See Also

DataRow Class
Gallio.Framework.Data Namespace


Methods

DataRow Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WithMetadata | Overloaded. Returns an augmented data row with added metadata from the specified metadata map.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Overridden. Implements GetValue.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateMetadataImpl | Overridden. Implements PopulateMetadata.
Top

See Also

DataRow Class
Gallio.Framework.Data Namespace


GetBindingsForInformalDescription Method

DataRow.GetBindingsForInformalDescription Method
[image]

Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetBindingsForInformalDescription() As IEnumerable(Of DataBinding) _
Implements IDataItem.GetBindingsForInformalDescription
C#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
C++
public:
virtual IEnumerable<DataBinding> GetBindingsForInformalDescription() override
J#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
JScript
public override function GetBindingsForInformalDescription() : IEnumerable<DataBinding>

Return Value

The enumeration of bindings

Implements

IDataItem.GetBindingsForInformalDescription

See Also

DataRow Class
Gallio.Framework.Data Namespace


GetValueImpl Method

DataRow.GetValueImpl Method
[image]

Implements GetValue.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValueImpl( _
ByVal binding As DataBinding _
) As Object
C#
protected override object GetValueImpl(
DataBinding binding
)
C++
protected:
virtual Object GetValueImpl(
DataBinding binding
) override
J#
protected override object GetValueImpl(
DataBinding binding
)
JScript
protected override function GetValueImpl(
binding : DataBinding
) : Object

Parameters

binding
The binding, never null

Return Value

The associated value

See Also

DataRow Class
Gallio.Framework.Data Namespace


PopulateMetadataImpl Method

DataRow.PopulateMetadataImpl Method
[image]

Implements PopulateMetadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateMetadataImpl( _
ByVal map As PropertyBag _
)
C#
protected override void PopulateMetadataImpl(
PropertyBag map
)
C++
protected:
virtual void PopulateMetadataImpl(
PropertyBag map
) override
J#
protected override void PopulateMetadataImpl(
PropertyBag map
)
JScript
protected override function PopulateMetadataImpl(
map : PropertyBag
)

Parameters

map
The metadata map to populate, never null

See Also

DataRow Class
Gallio.Framework.Data Namespace


WithMetadata Method

DataRow.WithMetadata Method

Returns an augmented data row with added metadata from the specified metadata map.

Overload List

 | Name | Description
Public method | WithMetadata (PropertyBag) | Returns an augmented data row with added metadata from the specified metadata map.
Public method | WithMetadata (String, String) | Returns an augmented data row with added metadata.

See Also

DataRow Class
Gallio.Framework.Data Namespace


WithMetadata Method (PropertyBag)

DataRow.WithMetadata Method (PropertyBag)
See Also Example
[image]

Returns an augmented data row with added metadata from the specified metadata map.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function WithMetadata( _
ByVal map As PropertyBag _
) As DataRow
C#
public DataRow WithMetadata(
PropertyBag map
)
C++
public:
DataRow WithMetadata(
PropertyBag map
) sealed
J#
public DataRow WithMetadata(
PropertyBag map
)
JScript
public function WithMetadata(
map : PropertyBag
) : DataRow

Parameters

map
The metadata map

Return Value

The augmented data row

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if map is null

Remarks

The original data row is not modified!

See Also

DataRow Class
Gallio.Framework.Data Namespace
DataRow.WithMetadata Overload List


WithMetadata Method (String, String)

DataRow.WithMetadata Method (String, String)
See Also Example
[image]

Returns an augmented data row with added metadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function WithMetadata( _
ByVal key As String, _
ByVal value As String _
) As DataRow
C#
public DataRow WithMetadata(
string key,
string value
)
C++
public:
DataRow WithMetadata(
String key,
String value
) sealed
J#
public DataRow WithMetadata(
string key,
string value
)
JScript
public function WithMetadata(
key : String,
value : String
) : DataRow

Parameters

key
The metadata key
value
The metadata value

Return Value

The augmented data row

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if key or value is null

Remarks

The original data row is not modified!

See Also

DataRow Class
Gallio.Framework.Data Namespace
DataRow.WithMetadata Overload List


DataSource Class

DataSource Class
See Also Example Members
[image]

An data source object provides a simple way of aggregating data sets together. It also provides a simple translation mechanism for mapping binding paths to binding indexes which is useful for providing named aliases for columns in indexed data sets.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DataSource
Inherits MergedDataSet
C#
public class DataSource : MergedDataSet
C++
ref class DataSource : MergedDataSet
J#
public class DataSource extends MergedDataSet
JScript
public class DataSource extends MergedDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.AggregateDataSet
Gallio.Framework.Data.MergedDataSet
Gallio.Framework.Data.DataSource

See Also

DataSource Members
Gallio.Framework.Data Namespace


DataSource Members

DataSource Members
See Also Example Constructors Properties Methods
[image]

An data source object provides a simple way of aggregating data sets together. It also provides a simple translation mechanism for mapping binding paths to binding indexes which is useful for providing named aliases for columns in indexed data sets.

The following tables list the members exposed by DataSource.

Public Constructors

 | Name | Description
Public method | DataSource | Creates a data source with a given name.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set. (inherited from MergedDataSet)
Public property | DataSets | Gets the immutable list of combined data sets. (inherited from AggregateDataSet)
Public property | Name | Gets the name of the data source, or an empty string if it is anonymous.
Public property | Strategy | Gets or sets the IMergeStrategy. By default the strategy is ConcatenationMergeStrategy. (inherited from MergedDataSet)
Top

Public Methods

 | Name | Description
Public method | AddDataSet | Adds a data set to the aggregate. (inherited from MergedDataSet)
Public method | AddIndexAlias | Adds an alias for a binding path to map it to the specified index.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DataSource Class
Gallio.Framework.Data Namespace


DataSource Constructor

DataSource Constructor
[image]

Creates a data source with a given name.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public DataSource(
string name
)
C++
public:
DataSource(
String name
) sealed
J#
public DataSource(
string name
)
JScript
public function DataSource(
name : String
)

Parameters

name
The name of the data source, or an empty string if it is anonymous

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

DataSource Class
Gallio.Framework.Data Namespace


Properties

DataSource Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set. (inherited from MergedDataSet)
Public property | DataSets | Gets the immutable list of combined data sets. (inherited from AggregateDataSet)
Public property | Name | Gets the name of the data source, or an empty string if it is anonymous.
Public property | Strategy | Gets or sets the IMergeStrategy. By default the strategy is ConcatenationMergeStrategy. (inherited from MergedDataSet)
Top

See Also

DataSource Class
Gallio.Framework.Data Namespace


Name Property

DataSource.Name Property
[image]

Gets the name of the data source, or an empty string if it is anonymous.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

DataSource Class
Gallio.Framework.Data Namespace


Methods

DataSource Methods
[image]

Public Methods

 | Name | Description
Public method | AddDataSet | Adds a data set to the aggregate. (inherited from MergedDataSet)
Public method | AddIndexAlias | Adds an alias for a binding path to map it to the specified index.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DataSource Class
Gallio.Framework.Data Namespace


AddIndexAlias Method

DataSource.AddIndexAlias Method
[image]

Adds an alias for a binding path to map it to the specified index.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndexAlias( _
ByVal path As String, _
ByVal index As Nullable(Of Integer) _
)
C#
public void AddIndexAlias(
string path,
Nullable<int> index
)
C++
public:
void AddIndexAlias(
String path,
Nullable<int> index
) sealed
J#
public void AddIndexAlias(
string path,
Nullable<int> index
)
JScript
public function AddIndexAlias(
path : String,
index : Nullable<int>
)

Parameters

path
The binding path to match in a case-insensitive manner
index
The associated index to use instead

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null

See Also

DataSource Class
Gallio.Framework.Data Namespace


CanBindImpl Method

DataSource.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected override bool CanBindImpl(
DataBinding binding
)
C++
protected:
virtual bool CanBindImpl(
DataBinding binding
) override
J#
protected override bool CanBindImpl(
DataBinding binding
)
JScript
protected override function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

DataSource Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

DataSource.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
virtual IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) override
J#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected override function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

DataSource Class
Gallio.Framework.Data Namespace


DataSourceTable Class

DataSourceTable Class
See Also Example Members
[image]

A data source table manages a collection of named data sources.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DataSourceTable
Implements IDataSourceResolver
C#
public class DataSourceTable : IDataSourceResolver
C++
ref class DataSourceTable : IDataSourceResolver
J#
public class DataSourceTable implements IDataSourceResolver
JScript
public class DataSourceTable extends IDataSourceResolver

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataSourceTable

See Also

DataSourceTable Members
Gallio.Framework.Data Namespace


DataSourceTable Members

DataSourceTable Members
See Also Example Constructors Methods
[image]

A data source table manages a collection of named data sources.

The following tables list the members exposed by DataSourceTable.

Public Constructors

 | Name | Description
Public method | DataSourceTable | Initializes a new instance of the DataSourceTable class.
Top

Public Methods

 | Name | Description
Public method | DefineDataSource |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ResolveDataSource | Resolves the data source with the specified name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DataSourceTable Class
Gallio.Framework.Data Namespace


DataSourceTable Constructor

DataSourceTable Constructor
[image]

Initializes a new instance of the DataSourceTable class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DataSourceTable()
C++
public:
DataSourceTable() sealed
J#
public DataSourceTable()
JScript
public function DataSourceTable()

See Also

DataSourceTable Class
Gallio.Framework.Data Namespace


Methods

DataSourceTable Methods
[image]

Public Methods

 | Name | Description
Public method | DefineDataSource |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ResolveDataSource | Resolves the data source with the specified name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DataSourceTable Class
Gallio.Framework.Data Namespace


DefineDataSource Method

DataSourceTable.DefineDataSource Method
[image]

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function DefineDataSource( _
ByVal name As String _
) As DataSource
C#
public DataSource DefineDataSource(
string name
)
C++
public:
DataSource DefineDataSource(
String name
) sealed
J#
public DataSource DefineDataSource(
string name
)
JScript
public function DefineDataSource(
name : String
) : DataSource

See Also

DataSourceTable Class
Gallio.Framework.Data Namespace


ResolveDataSource Method

DataSourceTable.ResolveDataSource Method
[image]

Resolves the data source with the specified name.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ResolveDataSource( _
ByVal name As String _
) As DataSource _
Implements IDataSourceResolver.ResolveDataSource
C#
public DataSource ResolveDataSource(
string name
)
C++
public:
DataSource ResolveDataSource(
String name
) sealed
J#
public DataSource ResolveDataSource(
string name
)
JScript
public function ResolveDataSource(
name : String
) : DataSource

Parameters

name
The data source name

Return Value

The resolved data source, or null if none found

Implements

IDataSourceResolver.ResolveDataSource

See Also

DataSourceTable Class
Gallio.Framework.Data Namespace


FactoryDataSet Class

FactoryDataSet Class
See Also Example Members
[image]

A factory data set generates data items by invoking a factory delegate and interpreting its output in accordance with the factory kind.

Multiple different interpretations are supported. Refer to the documentation of the FactoryKind enumeration for more details about each kind.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FactoryDataSet
Inherits BaseDataSet
C#
public class FactoryDataSet : BaseDataSet
C++
ref class FactoryDataSet : BaseDataSet
J#
public class FactoryDataSet extends BaseDataSet
JScript
public class FactoryDataSet extends BaseDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.FactoryDataSet

See Also

FactoryDataSet Members
Gallio.Framework.Data Namespace


FactoryDataSet Members

FactoryDataSet Members
See Also Example Constructors Properties Methods
[image]

A factory data set generates data items by invoking a factory delegate and interpreting its output in accordance with the factory kind.

Multiple different interpretations are supported. Refer to the documentation of the FactoryKind enumeration for more details about each kind.

The following tables list the members exposed by FactoryDataSet.

Public Constructors

 | Name | Description
Public method | FactoryDataSet | Creates a factory data set.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


FactoryDataSet Constructor

FactoryDataSet Constructor
[image]

Creates a factory data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal factory As Func(Of IEnumerable), _
ByVal factoryKind As FactoryKind, _
ByVal columnCount As Integer _
)
C#
public FactoryDataSet(
Func<IEnumerable> factory,
FactoryKind factoryKind,
int columnCount
)
C++
public:
FactoryDataSet(
Func<IEnumerable> factory,
FactoryKind factoryKind,
int columnCount
) sealed
J#
public FactoryDataSet(
Func<IEnumerable> factory,
FactoryKind factoryKind,
int columnCount
)
JScript
public function FactoryDataSet(
factory : Func<IEnumerable>,
factoryKind : FactoryKind,
columnCount : int
)

Parameters

factory
The factory delegate
factoryKind
The kind of factory
columnCount
The number of columns in the data items produced by the factory or 0 if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if factory is null
ArgumentOutOfRangeException | Thrown if factoryKind is invalid or if columnCount is less than 0

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


Properties

FactoryDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Top

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

FactoryDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


Methods

FactoryDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


CanBindImpl Method

FactoryDataSet.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected override bool CanBindImpl(
DataBinding binding
)
C++
protected:
virtual bool CanBindImpl(
DataBinding binding
) override
J#
protected override bool CanBindImpl(
DataBinding binding
)
JScript
protected override function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

FactoryDataSet.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
virtual IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) override
J#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected override function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

FactoryDataSet Class
Gallio.Framework.Data Namespace


FactoryKind Enumeration

FactoryKind Enumeration
[image]

Specifies the kind of factory member referenced by FactoryDataSet.

Each kind of factory expresses its contents by returning enumerations of data sets, data items, object arrays and single objects.

The kind of a factory may be automatically determined or it may be explicitly specified in cases where it may be ambiguous.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum FactoryKind
C#
public enum FactoryKind
C++
public enum class FactoryKind
J#
public enum FactoryKind
JScript
public enum FactoryKind

Members

Member Name | Description
Auto

Automatically determines the type of factory based on the type of element returned by the enumeration.

  • If the element is a IDataSet then it is processed in the same manner as DataSet.
  • If the element is a IDataItem (such as DataItem, ScalarDataItem or ListDataItem) then it is processed in the same manner as DataItem.
  • If the element is an array then it is processed in the same manner as ObjectArray.
  • Otherwise the element is process in the same manner as Object.

Refer to the other factory kinds for usage examples.

DataSet | Specifies that the factory returns an enumeration IDataSets whose items are to be consumed.
DataItem | Specifies that the factory returns an enumeration of IDataItems (such as DataRow, ScalarDataItem, or ListDataItem).
ObjectArray | Specifies that the factory returns an enumeration of object arrays that describe successive items.
Object | Specifies that the factory returns an enumeration of single object values.

See Also

Gallio.Framework.Data Namespace


Generators Class

Generators Class
See Also Example Members
[image]

This class provides a set of factory methods for creating enumerable objects that generate values according to a specified rule. The generated values may be used for a variety of purposes including data-driven testing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module Generators
C#
public static class Generators
C++
ref class Generators abstract sealed
J#
public final class Generators
JScript
public class Generators

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.Generators

See Also

Generators Members
Gallio.Framework.Data Namespace


Generators Members

Generators Members
See Also Example Methods
[image]

This class provides a set of factory methods for creating enumerable objects that generate values according to a specified rule. The generated values may be used for a variety of purposes including data-driven testing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Generators.

Public Methods

Name | Description
EnumValues | Creates an enumeration that yields all values of an Enum type.
Linear | Overloaded. Creates an enumeration that yields a linear sequence of Double values forming an arithmetic progression.
Top

See Also

Generators Class
Gallio.Framework.Data Namespace


Methods

Generators Methods
[image]

Public Methods

Name | Description
EnumValues | Creates an enumeration that yields all values of an Enum type.
Linear | Overloaded. Creates an enumeration that yields a linear sequence of Double values forming an arithmetic progression.
Top

See Also

Generators Class
Gallio.Framework.Data Namespace


EnumValues Method

Generators.EnumValues Method
[image]

Creates an enumeration that yields all values of an Enum type.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EnumValues( _
ByVal enumType As Type _
) As IEnumerable
C#
public static IEnumerable EnumValues(
Type enumType
)
C++
public:
static IEnumerable EnumValues(
Type enumType
)
J#
public static IEnumerable EnumValues(
Type enumType
)
JScript
public static function EnumValues(
enumType : Type
) : IEnumerable

Parameters

enumType
The Enum type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if enumType is null
ArgumentException | Thrown if enumType is not an Enum type

See Also

Generators Class
Gallio.Framework.Data Namespace


Linear Method

Generators.Linear Method

Creates an enumeration that yields a linear sequence of Double values forming an arithmetic progression.

Overload List

Name | Description
Linear (Double, Int32, Double) | Creates an enumeration that yields a linear sequence of Double values forming an arithmetic progression.
Linear (Int32, Int32, Int32) | Creates an enumeration that yields a linear sequence of Int32 values forming an arithmetic progression.

See Also

Generators Class
Gallio.Framework.Data Namespace


Linear Method (Double, Int32, Double)

Generators.Linear Method (Double, Int32, Double)
See Also Example
[image]

Creates an enumeration that yields a linear sequence of Double values forming an arithmetic progression.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Linear( _
ByVal firstValue As Double, _
ByVal count As Integer, _
ByVal step As Double _
) As IEnumerable(Of Double)
C#
public static IEnumerable<double> Linear(
double firstValue,
int count,
double step
)
C++
public:
static IEnumerable<double> Linear(
double firstValue,
int count,
double step
)
J#
public static IEnumerable<double> Linear(
double firstValue,
int count,
double step
)
JScript
public static function Linear(
firstValue : double,
count : int,
step : double
) : IEnumerable<double>

Parameters

firstValue
The first value to generate
count
The number of values to generate
step
The increment for each successive value

Return Value

The enumeration

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if count is less than 0

See Also

Generators Class
Gallio.Framework.Data Namespace
Generators.Linear Overload List


Linear Method (Int32, Int32, Int32)

Generators.Linear Method (Int32, Int32, Int32)
See Also Example
[image]

Creates an enumeration that yields a linear sequence of Int32 values forming an arithmetic progression.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Linear( _
ByVal firstValue As Integer, _
ByVal count As Integer, _
ByVal step As Integer _
) As IEnumerable(Of Integer)
C#
public static IEnumerable<int> Linear(
int firstValue,
int count,
int step
)
C++
public:
static IEnumerable<int> Linear(
int firstValue,
int count,
int step
)
J#
public static IEnumerable<int> Linear(
int firstValue,
int count,
int step
)
JScript
public static function Linear(
firstValue : int,
count : int,
step : int
) : IEnumerable<int>

Parameters

firstValue
The first value to generate
count
The number of values to generate
step
The increment for each successive value

Return Value

The enumeration

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if count is less than 0

See Also

Generators Class
Gallio.Framework.Data Namespace
Generators.Linear Overload List


IDataAccessor Interface

IDataAccessor Interface
See Also Example Members
[image]

A data accessor extracts a value from a IDataItem.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataAccessor
C#
public interface IDataAccessor
C++
interface class IDataAccessor
J#
public interface IDataAccessor
JScript
public interface IDataAccessor

Types that implement IDataAccessor

Type | Description
Gallio.Framework.Data.BaseDataAccessor | A base implementation of IDataAccessor that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IDataAccessor Members
Gallio.Framework.Data Namespace


IDataAccessor Members

IDataAccessor Members
See Also Example Methods
[image]

A data accessor extracts a value from a IDataItem.

The following tables list the members exposed by IDataAccessor.

Public Methods

 | Name | Description
Public method | GetValue | Gets a value derived from the IDataItem.
Top

See Also

IDataAccessor Interface
Gallio.Framework.Data Namespace


Methods

IDataAccessor Methods
[image]

Public Methods

 | Name | Description
Public method | GetValue | Gets a value derived from the IDataItem.
Top

See Also

IDataAccessor Interface
Gallio.Framework.Data Namespace


GetValue Method

IDataAccessor.GetValue Method
[image]

Gets a value derived from the IDataItem.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetValue( _
ByVal item As IDataItem _
) As Object
C#
object GetValue(
IDataItem item
)
C++
Object GetValue(
IDataItem item
) abstract
J#
object GetValue(
IDataItem item
)
JScript
function GetValue(
item : IDataItem
) : Object

Parameters

item
The data item

Return Value

The value

Exceptions

Exception Type | Condition
DataBindingException | Thrown if the data binding fails
ArgumentNullException | Thrown if item is null

See Also

IDataAccessor Interface
Gallio.Framework.Data Namespace


IDataBinder Interface

IDataBinder Interface
See Also Example Members
[image]

A data binder specifies how to produce values that are suitable for data binding in some context.

The typical IDataBinder lifecycle is as follows:

  • First, a DataBindingContext is created.
  • Next the client calls Register for each IDataBinder, supplying the DataBindingContext and a IDataSourceResolver for resolving data sources.
  • Then the client calls GetItems and begins enumerating over the items.
  • For each item, the client calls GetValue using the IDataAccessor produced by the IDataBinders to obtain the bound values.
  • When finished with an item, the client disposes it.

The lifecycle may also be explained in terms of three phases from the perspective of a IDataBinder.

  • Prebinding - The Register method is called to register interest in particular IDataSets with the DataBindingContext.
  • Binding - The GetValue method is called to obtain bound values from a IDataItem.
  • Unbinding - The IDataItem's Dispose method is called to release resources used by the bound values.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataBinder
C#
public interface IDataBinder
C++
interface class IDataBinder
J#
public interface IDataBinder
JScript
public interface IDataBinder

Types that implement IDataBinder

Type | Description
Gallio.Framework.Data.BaseDataBinder | Abstract base class for IDataBinder that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Remarks

Several data binders may be composed to generate complex values that are produced using contributions from other data binders. For example, a simple data binder might select a single value from a data source and convert it to the right time. A composite data binder may then use the values produced by several of these simple data binders to initialize the fields of a composite object. Thus a composite data binder facilitates the production of relatively complex object graphs that are generated from primitive data binding units.

See Also

IDataBinder Members
Gallio.Framework.Data Namespace


IDataBinder Members

IDataBinder Members
See Also Example Methods
[image]

A data binder specifies how to produce values that are suitable for data binding in some context.

The typical IDataBinder lifecycle is as follows:

  • First, a DataBindingContext is created.
  • Next the client calls Register for each IDataBinder, supplying the DataBindingContext and a IDataSourceResolver for resolving data sources.
  • Then the client calls GetItems and begins enumerating over the items.
  • For each item, the client calls GetValue using the IDataAccessor produced by the IDataBinders to obtain the bound values.
  • When finished with an item, the client disposes it.

The lifecycle may also be explained in terms of three phases from the perspective of a IDataBinder.

  • Prebinding - The Register method is called to register interest in particular IDataSets with the DataBindingContext.
  • Binding - The GetValue method is called to obtain bound values from a IDataItem.
  • Unbinding - The IDataItem's Dispose method is called to release resources used by the bound values.

The following tables list the members exposed by IDataBinder.

Public Methods

 | Name | Description
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext.
Top

See Also

IDataBinder Interface
Gallio.Framework.Data Namespace


Methods

IDataBinder Methods
[image]

Public Methods

 | Name | Description
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext.
Top

See Also

IDataBinder Interface
Gallio.Framework.Data Namespace


Register Method

IDataBinder.Register Method
[image]

Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Register( _
ByVal context As DataBindingContext, _
ByVal resolver As IDataSourceResolver _
) As IDataAccessor
C#
IDataAccessor Register(
DataBindingContext context,
IDataSourceResolver resolver
)
C++
IDataAccessor Register(
DataBindingContext context,
IDataSourceResolver resolver
) abstract
J#
IDataAccessor Register(
DataBindingContext context,
IDataSourceResolver resolver
)
JScript
function Register(
context : DataBindingContext,
resolver : IDataSourceResolver
) : IDataAccessor

Parameters

context
The data binding context
resolver
The data source resolver

Return Value

The data binding accessor to use for obtaining bound values from IDataItems produced by the DataBindingContext.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if context or resolver is null

See Also

IDataBinder Interface
Gallio.Framework.Data Namespace


IDataItem Interface

IDataItem Interface
See Also Example Members
[image]

A data item is an opaque representation of a collection of values and metadata that may be retrieved using data bindings that encode the appropriate lookup rules into the item.

Data items may have very different forms:

  • Scalar-like items: Items that always yield a single value, possibly a constant
  • Row-like items: Items that yield several values in response to index-based data bindings or named column paths
  • Structured items: Items that yield values by binding to paths within the item or by resolving custom data binding expressions

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataItem
C#
public interface IDataItem
C++
interface class IDataItem
J#
public interface IDataItem
JScript
public interface IDataItem

Types that implement IDataItem

Type | Description
Gallio.Framework.Data.BaseDataItem | Abstract base class for data items. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IDataItem Members
Gallio.Framework.Data Namespace
IDataAccessor


IDataItem Members

IDataItem Members
See Also Example Properties Methods
[image]

A data item is an opaque representation of a collection of values and metadata that may be retrieved using data bindings that encode the appropriate lookup rules into the item.

Data items may have very different forms:

  • Scalar-like items: Items that always yield a single value, possibly a constant
  • Row-like items: Items that yield several values in response to index-based data bindings or named column paths
  • Structured items: Items that yield values by binding to paths within the item or by resolving custom data binding expressions

The following tables list the members exposed by IDataItem.

Public Properties

Name Description
Public property IsDynamic

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

Public Methods

 | Name | Description
Public method | GetBindingsForInformalDescription | Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetValue | Gets the value of the specified binding.
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item.
Top

See Also

IDataItem Interface
Gallio.Framework.Data Namespace
IDataAccessor


Properties

IDataItem Properties
[image]

Public Properties

Name Description
Public property IsDynamic

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

See Also

IDataItem Interface
Gallio.Framework.Data Namespace
IDataAccessor


IsDynamic Property

IDataItem.IsDynamic Property
[image]

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDynamic As Boolean
C#
bool IsDynamic { get; }
C++
property bool IsDynamic abstract {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

See Also

IDataItem Interface
Gallio.Framework.Data Namespace


Methods

IDataItem Methods
[image]

Public Methods

 | Name | Description
Public method | GetBindingsForInformalDescription | Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetValue | Gets the value of the specified binding.
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item.
Top

See Also

IDataItem Interface
Gallio.Framework.Data Namespace
IDataAccessor


GetBindingsForInformalDescription Method

IDataItem.GetBindingsForInformalDescription Method
[image]

Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetBindingsForInformalDescription() As IEnumerable(Of DataBinding)
C#
IEnumerable<DataBinding> GetBindingsForInformalDescription()
C++
IEnumerable<DataBinding> GetBindingsForInformalDescription() abstract
J#
IEnumerable<DataBinding> GetBindingsForInformalDescription()
JScript
function GetBindingsForInformalDescription() : IEnumerable<DataBinding>

Return Value

The enumeration of bindings

See Also

IDataItem Interface
Gallio.Framework.Data Namespace


GetValue Method

IDataItem.GetValue Method
[image]

Gets the value of the specified binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetValue( _
ByVal binding As DataBinding _
) As Object
C#
object GetValue(
DataBinding binding
)
C++
Object GetValue(
DataBinding binding
) abstract
J#
object GetValue(
DataBinding binding
)
JScript
function GetValue(
binding : DataBinding
) : Object

Parameters

binding
The data binding, never null

Return Value

The value

Exceptions

Exception Type | Condition
DataBindingException | Thrown if the binding cannot be resolved or if its value cannot be obtained

See Also

IDataItem Interface
Gallio.Framework.Data Namespace


PopulateMetadata Method

IDataItem.PopulateMetadata Method
[image]

Populates the specified metadata map with key/value pairs associated with the data item, if any.

For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateMetadata( _
ByVal map As PropertyBag _
)
C#
void PopulateMetadata(
PropertyBag map
)
C++
void PopulateMetadata(
PropertyBag map
) abstract
J#
void PopulateMetadata(
PropertyBag map
)
JScript
function PopulateMetadata(
map : PropertyBag
)

Parameters

map
The metadata map

See Also

IDataItem Interface
Gallio.Framework.Data Namespace


IDataProvider Interface

IDataProvider Interface
See Also Example Members
[image]

A data provider generates an enumeration of IDataItems given a collection of DataBindings to satisfy.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataProvider
C#
public interface IDataProvider
C++
interface class IDataProvider
J#
public interface IDataProvider
JScript
public interface IDataProvider

Types that implement IDataProvider

Type | Description
Gallio.Framework.Data.BaseDataSet | Abstract base class for IDataSet that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IDataProvider Members
Gallio.Framework.Data Namespace


IDataProvider Members

IDataProvider Members
See Also Example Methods
[image]

A data provider generates an enumeration of IDataItems given a collection of DataBindings to satisfy.

The following tables list the members exposed by IDataProvider.

Public Methods

 | Name | Description
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled.
Top

See Also

IDataProvider Interface
Gallio.Framework.Data Namespace


Methods

IDataProvider Methods
[image]

Public Methods

 | Name | Description
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled.
Top

See Also

IDataProvider Interface
Gallio.Framework.Data Namespace


GetItems Method

IDataProvider.GetItems Method
[image]

Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetItems( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
IEnumerable<IDataItem> GetItems(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
IEnumerable<IDataItem> GetItems(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) abstract
J#
IEnumerable<IDataItem> GetItems(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
function GetItems(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The bindings that are requested
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The enumeration of data items

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if bindings is null

See Also

IDataProvider Interface
Gallio.Framework.Data Namespace


IDataSet Interface

IDataSet Interface
See Also Example Members
[image]

A data set provides data items for data binding and describes whether is supports particular bindings.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataSet
Implements IDataProvider
C#
public interface IDataSet : IDataProvider
C++
interface class IDataSet : IDataProvider
J#
public interface IDataSet implements IDataProvider
JScript
public interface IDataSet extends IDataProvider

Types that implement IDataSet

Type | Description
Gallio.Framework.Data.BaseDataSet | Abstract base class for IDataSet that validates input arguments before passing them on to the implementation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IDataSet Members
Gallio.Framework.Data Namespace


IDataSet Members

IDataSet Members
See Also Example Properties Methods
[image]

A data set provides data items for data binding and describes whether is supports particular bindings.

The following tables list the members exposed by IDataSet.

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding.
Top

See Also

IDataSet Interface
Gallio.Framework.Data Namespace


Properties

IDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Gets the number of columns in an indexed data set.
Top

See Also

IDataSet Interface
Gallio.Framework.Data Namespace


ColumnCount Property

IDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ColumnCount As Integer
C#
int ColumnCount { get; }
C++
property int ColumnCount abstract {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

See Also

IDataSet Interface
Gallio.Framework.Data Namespace


Methods

IDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding.
Top

See Also

IDataSet Interface
Gallio.Framework.Data Namespace


CanBind Method

IDataSet.CanBind Method
[image]

Returns true if the data set can provide a value for the specified binding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CanBind( _
ByVal binding As DataBinding _
) As Boolean
C#
bool CanBind(
DataBinding binding
)
C++
bool CanBind(
DataBinding binding
) abstract
J#
bool CanBind(
DataBinding binding
)
JScript
function CanBind(
binding : DataBinding
) : bool

Parameters

binding
The binding

Return Value

True if the data set can provide a value for the binding

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if binding is null

See Also

IDataSet Interface
Gallio.Framework.Data Namespace


IDataSourceResolver Interface

IDataSourceResolver Interface
See Also Example Members
[image]

Resolves data sources by name.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataSourceResolver
C#
public interface IDataSourceResolver
C++
interface class IDataSourceResolver
J#
public interface IDataSourceResolver
JScript
public interface IDataSourceResolver

Types that implement IDataSourceResolver

Type | Description
Gallio.Framework.Data.DataSourceTable | A data source table manages a collection of named data sources.
Gallio.Framework.Pattern.PatternTestDataContext

A pattern test data context introduces a scope for data source declarations.

Each PatternTest or PatternTestParameter has a PatternTestDataContext. However, data contexts may also be nested.

For example, the constructor of a test class typically augments its containing test with additional test parameters that represent its own constructor parameters. If data binding attributes are applied to the constructor, they should operate within the scope of that constructor only. To achieve this effect, the constructor declares a new PatternTestDataContext within which its test parameters will be created.

See Also

IDataSourceResolver Members
Gallio.Framework.Data Namespace


IDataSourceResolver Members

IDataSourceResolver Members
See Also Example Methods
[image]

Resolves data sources by name.

The following tables list the members exposed by IDataSourceResolver.

Public Methods

 | Name | Description
Public method | ResolveDataSource | Resolves the data source with the specified name.
Top

See Also

IDataSourceResolver Interface
Gallio.Framework.Data Namespace


Methods

IDataSourceResolver Methods
[image]

Public Methods

 | Name | Description
Public method | ResolveDataSource | Resolves the data source with the specified name.
Top

See Also

IDataSourceResolver Interface
Gallio.Framework.Data Namespace


ResolveDataSource Method

IDataSourceResolver.ResolveDataSource Method
[image]

Resolves the data source with the specified name.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ResolveDataSource( _
ByVal name As String _
) As DataSource
C#
DataSource ResolveDataSource(
string name
)
C++
DataSource ResolveDataSource(
String name
) abstract
J#
DataSource ResolveDataSource(
string name
)
JScript
function ResolveDataSource(
name : String
) : DataSource

Parameters

name
The data source name

Return Value

The resolved data source, or null if none found

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

IDataSourceResolver Interface
Gallio.Framework.Data Namespace


IJoinStrategy Interface

IJoinStrategy Interface
See Also Example Members
[image]

A join strategy combines items from multiple providers into products according to some algorithm.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IJoinStrategy
C#
public interface IJoinStrategy
C++
interface class IJoinStrategy
J#
public interface IJoinStrategy
JScript
public interface IJoinStrategy

Types that implement IJoinStrategy

Type | Description
Gallio.Framework.Data.CombinatorialJoinStrategy | The combinatorial join strategy combines items by constructing the cartesian product of the items of each provider. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Gallio.Framework.Data.PairwiseJoinStrategy

The pairwise strategy constructs a limited number of combinations of the items within the data providers such that they cover all possible pairs of values from each data source.

This strategy can be more efficient than one based on exhaustively testing all combinations since many test failures result from the interaction of a relatively small number of factors: often just two of them.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Gallio.Framework.Data.SequentialJoinStrategy | The sequential join strategy combines items from each data provider sequentially. If one provider contains fewer items than the others, the sequential join strategy will insert a NullDataItem in its place until all other providers have been exhausted. This is similar to performing an "outer join" of multiple sources by ordinal index. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Remarks

A join strategy performs much the same purpose as a "JOIN" in query languages. It specifies how items from multiple providers are to be correlated to create a sequence of aggregate items.

See Also

IJoinStrategy Members
Gallio.Framework.Data Namespace
JoinedDataSet


IJoinStrategy Members

IJoinStrategy Members
See Also Example Methods
[image]

A join strategy combines items from multiple providers into products according to some algorithm.

The following tables list the members exposed by IJoinStrategy.

Public Methods

 | Name | Description
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Top

See Also

IJoinStrategy Interface
Gallio.Framework.Data Namespace
JoinedDataSet


Methods

IJoinStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Top

See Also

IJoinStrategy Interface
Gallio.Framework.Data Namespace
JoinedDataSet


Join Method

IJoinStrategy.Join Method
[image]

Joins the items from each provider into a sequence of aggregate items.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Join( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindingsPerProvider As IList(Of ICollection(Of DataBinding)), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IList(Of IDataItem))
C#
IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
C++
IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
) abstract
J#
IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
JScript
function Join(
providers : IList<IDataProvider>,
bindingsPerProvider : IList<ICollection<DataBinding>>,
includeDynamicItems : bool
) : IEnumerable<IList<IDataItem>>

Parameters

providers
The list of providers
bindingsPerProvider
The list of bindings per provider
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

An enumeration of item-lists consisting of exactly one item from each provider and indexed in the same order as the providers collection

Remarks

The number of elements in each item-list must equal the number of providers in the providers list because each item-list should contain exactly one item taken from each provider.

See Also

IJoinStrategy Interface
Gallio.Framework.Data Namespace


IMergeStrategy Interface

IMergeStrategy Interface
See Also Example Members
[image]

A merge strategy combines items from multiple providers into a sequence according to some algorithm.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMergeStrategy
C#
public interface IMergeStrategy
C++
interface class IMergeStrategy
J#
public interface IMergeStrategy
JScript
public interface IMergeStrategy

Types that implement IMergeStrategy

Type | Description
Gallio.Framework.Data.ConcatenationMergeStrategy | The concatenation merge strategy combines the items from multiple providers by simply concatenating the items in the order in which they appear and proceeding from one provider to the next until all providers have been fully processed. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Gallio.Framework.Data.IntersectionMergeStrategy | The intersection merge strategy combines the items from multiple providers by discarding items whose values do not appear in the items of all other providers. If the same item appears more than once within any given provider, when it will be enumerated only as often as the least number of repetitions of that item that appear in other providers. Uniqueness is determined by the natural equality of each bound value in the item. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Gallio.Framework.Data.UnionMergeStrategy | The union merge strategy combines the items from multiple providers by discarding all items whose values duplicate those of other items that have already been enumerated. Uniqueness is determined by the natural equality of each bound value in the item. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Remarks

A merge strategy performs much the same purpose as a "UNION" or other combinator in query languages. It specifies how to select items among multiple providers to create an aggregate sequence of items.

See Also

IMergeStrategy Members
Gallio.Framework.Data Namespace
MergedDataSet


IMergeStrategy Members

IMergeStrategy Members
See Also Example Methods
[image]

A merge strategy combines items from multiple providers into a sequence according to some algorithm.

The following tables list the members exposed by IMergeStrategy.

Public Methods

 | Name | Description
Public method | Merge | Merges the items from each provider into a new sequence.
Top

See Also

IMergeStrategy Interface
Gallio.Framework.Data Namespace
MergedDataSet


Methods

IMergeStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Merge | Merges the items from each provider into a new sequence.
Top

See Also

IMergeStrategy Interface
Gallio.Framework.Data Namespace
MergedDataSet


Merge Method

IMergeStrategy.Merge Method
[image]

Merges the items from each provider into a new sequence.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Merge( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
) abstract
J#
IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
function Merge(
providers : IList<IDataProvider>,
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

providers
The list of providers
bindings
The bindings
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The merged sequence of items

See Also

IMergeStrategy Interface
Gallio.Framework.Data Namespace


IntersectionMergeStrategy Class

IntersectionMergeStrategy Class
See Also Example Members
[image]

The intersection merge strategy combines the items from multiple providers by discarding items whose values do not appear in the items of all other providers. If the same item appears more than once within any given provider, when it will be enumerated only as often as the least number of repetitions of that item that appear in other providers.

Uniqueness is determined by the natural equality of each bound value in the item.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IntersectionMergeStrategy
Implements IMergeStrategy
C#
public sealed class IntersectionMergeStrategy : IMergeStrategy
C++
ref class IntersectionMergeStrategy sealed : IMergeStrategy
J#
public final class IntersectionMergeStrategy implements IMergeStrategy
JScript
public final class IntersectionMergeStrategy extends IMergeStrategy

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.IntersectionMergeStrategy

See Also

IntersectionMergeStrategy Members
Gallio.Framework.Data Namespace


IntersectionMergeStrategy Members

IntersectionMergeStrategy Members
See Also Example Fields Methods
[image]

The intersection merge strategy combines the items from multiple providers by discarding items whose values do not appear in the items of all other providers. If the same item appears more than once within any given provider, when it will be enumerated only as often as the least number of repetitions of that item that appear in other providers.

Uniqueness is determined by the natural equality of each bound value in the item.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by IntersectionMergeStrategy.

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Merge | Merges the items from each provider into a new sequence.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

IntersectionMergeStrategy Class
Gallio.Framework.Data Namespace


Fields

IntersectionMergeStrategy Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

See Also

IntersectionMergeStrategy Class
Gallio.Framework.Data Namespace


Instance Field

IntersectionMergeStrategy.Instance Field
[image]

Gets the singleton instance of the strategy. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As IntersectionMergeStrategy
C#
public static readonly IntersectionMergeStrategy Instance;
C++
public:
static const IntersectionMergeStrategy Instance;
J#
public static final IntersectionMergeStrategy Instance
JScript
public static const var Instance : IntersectionMergeStrategy;

See Also

IntersectionMergeStrategy Class
Gallio.Framework.Data Namespace


Methods

IntersectionMergeStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Merge | Merges the items from each provider into a new sequence.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

IntersectionMergeStrategy Class
Gallio.Framework.Data Namespace


Merge Method

IntersectionMergeStrategy.Merge Method
[image]

Merges the items from each provider into a new sequence.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Merge( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem) _
Implements IMergeStrategy.Merge
C#
public IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
public:
IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
public function Merge(
providers : IList<IDataProvider>,
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

providers
The list of providers
bindings
The bindings
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The merged sequence of items

Implements

IMergeStrategy.Merge

See Also

IntersectionMergeStrategy Class
Gallio.Framework.Data Namespace


ItemSequenceDataSet Class

ItemSequenceDataSet Class
See Also Example Members
[image]

A data set constructed from a sequence of data items. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ItemSequenceDataSet
Inherits BaseDataSet
C#
public sealed class ItemSequenceDataSet : BaseDataSet
C++
ref class ItemSequenceDataSet sealed : BaseDataSet
J#
public final class ItemSequenceDataSet extends BaseDataSet
JScript
public final class ItemSequenceDataSet extends BaseDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.ItemSequenceDataSet

See Also

ItemSequenceDataSet Members
Gallio.Framework.Data Namespace


ItemSequenceDataSet Members

ItemSequenceDataSet Members
See Also Example Constructors Properties Methods
[image]

A data set constructed from a sequence of data items. This class cannot be inherited.

The following tables list the members exposed by ItemSequenceDataSet.

Public Constructors

 | Name | Description
Public method | ItemSequenceDataSet | Creates a row data set.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ItemSequenceDataSet Class
Gallio.Framework.Data Namespace


ItemSequenceDataSet Constructor

ItemSequenceDataSet Constructor
[image]

Creates a row data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal items As IEnumerable(Of IDataItem), _
ByVal columnCount As Integer _
)
C#
public ItemSequenceDataSet(
IEnumerable<IDataItem> items,
int columnCount
)
C++
public:
ItemSequenceDataSet(
IEnumerable<IDataItem> items,
int columnCount
) sealed
J#
public ItemSequenceDataSet(
IEnumerable<IDataItem> items,
int columnCount
)
JScript
public function ItemSequenceDataSet(
items : IEnumerable<IDataItem>,
columnCount : int
)

Parameters

items
The sequence of items
columnCount
The column count

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if items is null
ArgumentOutOfRangeException | Thrown if columnCount is negative

See Also

ItemSequenceDataSet Class
Gallio.Framework.Data Namespace


Properties

ItemSequenceDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Top

See Also

ItemSequenceDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

ItemSequenceDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

ItemSequenceDataSet Class
Gallio.Framework.Data Namespace


JoinedDataSet Class

JoinedDataSet Class
See Also Example Members
[image]

A joined data set is an aggregate data set that joins items from each of zero or more other data sets according to a IJoinStrategy.

A joined data set supports queries with two kinds of DataBinding:

  • A translated binding produced by TranslateBinding is scoped to a particular IDataSet. When a query occurs using a translated binding, only that IDataSet and its IDataItem components are consulted.
  • Any other binding is treated as if it referred to the joined IDataItem including all of the contributions of all data sets. The joined IDataItem is conceptually laid out such that the columns of first IDataSet appear first followed by those of successive IDataSets in order. To maintain this illustion, the Index component of the binding is adjusted internally before passing any queries on to the IDataSets. Thereafter a binding will be consumed by the first IDataSet that returns true from its CanBind method after index-adjustment.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class JoinedDataSet
Inherits AggregateDataSet
C#
public class JoinedDataSet : AggregateDataSet
C++
ref class JoinedDataSet : AggregateDataSet
J#
public class JoinedDataSet extends AggregateDataSet
JScript
public class JoinedDataSet extends AggregateDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.AggregateDataSet
Gallio.Framework.Data.JoinedDataSet

See Also

JoinedDataSet Members
Gallio.Framework.Data Namespace


JoinedDataSet Members

JoinedDataSet Members
See Also Example Constructors Properties Methods
[image]

A joined data set is an aggregate data set that joins items from each of zero or more other data sets according to a IJoinStrategy.

A joined data set supports queries with two kinds of DataBinding:

  • A translated binding produced by TranslateBinding is scoped to a particular IDataSet. When a query occurs using a translated binding, only that IDataSet and its IDataItem components are consulted.
  • Any other binding is treated as if it referred to the joined IDataItem including all of the contributions of all data sets. The joined IDataItem is conceptually laid out such that the columns of first IDataSet appear first followed by those of successive IDataSets in order. To maintain this illustion, the Index component of the binding is adjusted internally before passing any queries on to the IDataSets. Thereafter a binding will be consumed by the first IDataSet that returns true from its CanBind method after index-adjustment.

The following tables list the members exposed by JoinedDataSet.

Public Constructors

 | Name | Description
Public method | JoinedDataSet | Initializes a new instance of the JoinedDataSet class.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | DataSets | Gets the immutable list of combined data sets. (inherited from AggregateDataSet)
Public property | Strategy | Gets or sets the IJoinStrategy. By default the strategy is CombinatorialJoinStrategy.
Top

Public Methods

Name | Description
Public method | AddDataSet | Overridden. Adds a data set to the aggregate.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method TranslateBinding

Translates a binding into one that expresses a query that is scoped over a particular data set that is associated with this interface.

If the binding contains an index parameter, the translated binding will contain an index that is offset based on the position of the contents of the data set within the items of the joined aggregate.

Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


JoinedDataSet Constructor

JoinedDataSet Constructor
[image]

Initializes a new instance of the JoinedDataSet class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public JoinedDataSet()
C++
public:
JoinedDataSet() sealed
J#
public JoinedDataSet()
JScript
public function JoinedDataSet()

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


Properties

JoinedDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | DataSets | Gets the immutable list of combined data sets. (inherited from AggregateDataSet)
Public property | Strategy | Gets or sets the IJoinStrategy. By default the strategy is CombinatorialJoinStrategy.
Top

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

JoinedDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


Strategy Property

JoinedDataSet.Strategy Property
[image]

Gets or sets the IJoinStrategy. By default the strategy is CombinatorialJoinStrategy.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Strategy As IJoinStrategy
C#
public IJoinStrategy Strategy { get; set; }
C++
public property IJoinStrategy Strategy sealed {
IJoinStrategy get();
void set(IJoinStrategy value);
}
J#
/** property */
public IJoinStrategy get_Strategy();

/** property */
public void set_Strategy(IJoinStrategy value);
JScript
public function get Strategy() : IJoinStrategy

public function set Strategy(value : IJoinStrategy);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


Methods

JoinedDataSet Methods
[image]

Public Methods

Name | Description
Public method | AddDataSet | Overridden. Adds a data set to the aggregate.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method TranslateBinding

Translates a binding into one that expresses a query that is scoped over a particular data set that is associated with this interface.

If the binding contains an index parameter, the translated binding will contain an index that is offset based on the position of the contents of the data set within the items of the joined aggregate.

Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


AddDataSet Method

JoinedDataSet.AddDataSet Method
[image]

Adds a data set to the aggregate.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddDataSet( _
ByVal dataSet As IDataSet _
)
C#
public override void AddDataSet(
IDataSet dataSet
)
C++
public:
virtual void AddDataSet(
IDataSet dataSet
) override
J#
public override void AddDataSet(
IDataSet dataSet
)
JScript
public override function AddDataSet(
dataSet : IDataSet
)

Parameters

dataSet
The data set to add

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


CanBindImpl Method

JoinedDataSet.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected override bool CanBindImpl(
DataBinding binding
)
C++
protected:
virtual bool CanBindImpl(
DataBinding binding
) override
J#
protected override bool CanBindImpl(
DataBinding binding
)
JScript
protected override function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

JoinedDataSet.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
virtual IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) override
J#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected override function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


TranslateBinding Method

JoinedDataSet.TranslateBinding Method
[image]

Translates a binding into one that expresses a query that is scoped over a particular data set that is associated with this interface.

If the binding contains an index parameter, the translated binding will contain an index that is offset based on the position of the contents of the data set within the items of the joined aggregate.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TranslateBinding( _
ByVal dataSet As IDataSet, _
ByVal binding As DataBinding _
) As DataBinding
C#
public DataBinding TranslateBinding(
IDataSet dataSet,
DataBinding binding
)
C++
public:
DataBinding TranslateBinding(
IDataSet dataSet,
DataBinding binding
) sealed
J#
public DataBinding TranslateBinding(
IDataSet dataSet,
DataBinding binding
)
JScript
public function TranslateBinding(
dataSet : IDataSet,
binding : DataBinding
) : DataBinding

Parameters

dataSet
The data set
binding
The binding

Return Value

The translated binding

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if dataSet or binding is null
ArgumentException | Thrown if dataSet is not a member of this instance

See Also

JoinedDataSet Class
Gallio.Framework.Data Namespace


ListDataItem Generic Class

ListDataItem Generic Class
See Also Example Members
[image]

A list data item contains a list of static data values combined with optional metadata for the item. Data binding occurs based on the binding index alone. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ListDataItem(Of T)
Inherits SimpleDataItem
C#
public sealed class ListDataItem<T> : SimpleDataItem
C++
ref class ListDataItem<T> sealed : SimpleDataItem
J#
public final class ListDataItem<T> extends SimpleDataItem
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataItem
Gallio.Framework.Data.SimpleDataItem
Gallio.Framework.Data.ListDataItem<T>

See Also

ListDataItem<T> Members
Gallio.Framework.Data Namespace


ListDataItem<T> Members

ListDataItem Members
See Also Example Constructors Properties Methods
[image]

A list data item contains a list of static data values combined with optional metadata for the item. Data binding occurs based on the binding index alone. This class cannot be inherited.

The following tables list the members exposed by ListDataItem<T>.

Public Constructors

 | Name | Description
Public method | ListDataItem | Creates a list data item with optional metadata.
Top

Public Properties

Name Description
Public property IsDynamic

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

(inherited from SimpleDataItem)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ListDataItem<T> Class
Gallio.Framework.Data Namespace


ListDataItem Constructor

ListDataItem Constructor
[image]

Creates a list data item with optional metadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal values As IList(Of T), _
ByVal metadataPairs As IEnumerable(Of KeyValuePair(Of String, String)), _
ByVal isDynamic As Boolean _
)
C#
public ListDataItem(
IList<T> values,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
C++
public:
ListDataItem(
IList<T> values,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
) sealed
J#
public ListDataItem(
IList<T> values,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
JScript
JScript does not support generic types and methods.

Parameters

values
The list of values
metadataPairs
The metadata key/value pairs, or null if none
isDynamic
True if the item contains dynamic data

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if values is null

See Also

ListDataItem<T> Class
Gallio.Framework.Data Namespace


Methods

ListDataItem Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ListDataItem<T> Class
Gallio.Framework.Data Namespace


GetBindingsForInformalDescription Method

ListDataItem.GetBindingsForInformalDescription Method
[image]

Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetBindingsForInformalDescription() As IEnumerable(Of DataBinding) _
Implements IDataItem.GetBindingsForInformalDescription
C#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
C++
public:
virtual IEnumerable<DataBinding> GetBindingsForInformalDescription() override
J#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
JScript
JScript does not support generic types and methods.

Return Value

The enumeration of bindings

Implements

IDataItem.GetBindingsForInformalDescription

See Also

ListDataItem<T> Class
Gallio.Framework.Data Namespace


MergedDataSet Class

MergedDataSet Class
See Also Example Members
[image]

A merged data set is an aggregate data set that selects items from each of zero or more other data sets according to a IMergeStrategy.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class MergedDataSet
Inherits AggregateDataSet
C#
public class MergedDataSet : AggregateDataSet
C++
ref class MergedDataSet : AggregateDataSet
J#
public class MergedDataSet extends AggregateDataSet
JScript
public class MergedDataSet extends AggregateDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.AggregateDataSet
Gallio.Framework.Data.MergedDataSet
Gallio.Framework.Data.DataSource

See Also

MergedDataSet Members
Gallio.Framework.Data Namespace


MergedDataSet Members

MergedDataSet Members
See Also Example Constructors Properties Methods
[image]

A merged data set is an aggregate data set that selects items from each of zero or more other data sets according to a IMergeStrategy.

The following tables list the members exposed by MergedDataSet.

Public Constructors

 | Name | Description
Public method | MergedDataSet | Initializes a new instance of the MergedDataSet class.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | DataSets | Gets the immutable list of combined data sets. (inherited from AggregateDataSet)
Public property | Strategy | Gets or sets the IMergeStrategy. By default the strategy is ConcatenationMergeStrategy.
Top

Public Methods

 | Name | Description
Public method | AddDataSet | Overridden. Adds a data set to the aggregate.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


MergedDataSet Constructor

MergedDataSet Constructor
[image]

Initializes a new instance of the MergedDataSet class.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MergedDataSet()
C++
public:
MergedDataSet() sealed
J#
public MergedDataSet()
JScript
public function MergedDataSet()

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


Properties

MergedDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | DataSets | Gets the immutable list of combined data sets. (inherited from AggregateDataSet)
Public property | Strategy | Gets or sets the IMergeStrategy. By default the strategy is ConcatenationMergeStrategy.
Top

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

MergedDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


Strategy Property

MergedDataSet.Strategy Property
[image]

Gets or sets the IMergeStrategy. By default the strategy is ConcatenationMergeStrategy.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Strategy As IMergeStrategy
C#
public IMergeStrategy Strategy { get; set; }
C++
public property IMergeStrategy Strategy sealed {
IMergeStrategy get();
void set(IMergeStrategy value);
}
J#
/** property */
public IMergeStrategy get_Strategy();

/** property */
public void set_Strategy(IMergeStrategy value);
JScript
public function get Strategy() : IMergeStrategy

public function set Strategy(value : IMergeStrategy);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


Methods

MergedDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | AddDataSet | Overridden. Adds a data set to the aggregate.
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


AddDataSet Method

MergedDataSet.AddDataSet Method
[image]

Adds a data set to the aggregate.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddDataSet( _
ByVal dataSet As IDataSet _
)
C#
public override void AddDataSet(
IDataSet dataSet
)
C++
public:
virtual void AddDataSet(
IDataSet dataSet
) override
J#
public override void AddDataSet(
IDataSet dataSet
)
JScript
public override function AddDataSet(
dataSet : IDataSet
)

Parameters

dataSet
The data set to add

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


CanBindImpl Method

MergedDataSet.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected override bool CanBindImpl(
DataBinding binding
)
C++
protected:
virtual bool CanBindImpl(
DataBinding binding
) override
J#
protected override bool CanBindImpl(
DataBinding binding
)
JScript
protected override function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

MergedDataSet.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
virtual IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) override
J#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected override function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

MergedDataSet Class
Gallio.Framework.Data Namespace


MethodInvocationSpec Class

MethodInvocationSpec Class
See Also Example Members
[image]

Encapsulates a specification for invoking a method given values for its generic parameters and formal parameters. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MethodInvocationSpec
Inherits DataBindingSpec
C#
public sealed class MethodInvocationSpec : DataBindingSpec
C++
ref class MethodInvocationSpec sealed : DataBindingSpec
J#
public final class MethodInvocationSpec extends DataBindingSpec
JScript
public final class MethodInvocationSpec extends DataBindingSpec

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataBindingSpec
Gallio.Framework.Data.MethodInvocationSpec

See Also

MethodInvocationSpec Members
Gallio.Framework.Data Namespace


MethodInvocationSpec Members

MethodInvocationSpec Members
See Also Example Constructors Properties Methods
[image]

Encapsulates a specification for invoking a method given values for its generic parameters and formal parameters. This class cannot be inherited.

The following tables list the members exposed by MethodInvocationSpec.

Public Constructors

 | Name | Description
Public method | MethodInvocationSpec | Creates a new method specification.
Top

Public Properties

 | Name | Description
Public property | Converter | Gets the converter. (inherited from DataBindingSpec)
Public property | Method | Gets the method or generic method definition to be invoked.
Public property | ResolvedArguments | Gets the resolved method arguments. The values have already been converted to appropriate types for invoking the method.
Public property | ResolvedMethod | Gets the resolved method given any generic method arguments that may have been provided as slot values.
Public property | ResolvedType | Gets the resolved type that declares the method.
Public property | SlotValues | Gets the slot values. (inherited from DataBindingSpec)
Top

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method Format

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

(inherited from DataBindingSpec)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Invoke | Invokes the method.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


MethodInvocationSpec Constructor

MethodInvocationSpec Constructor
[image]

Creates a new method specification.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal resolvedType As Type, _
ByVal method As IMethodInfo, _
ByVal slotValues As IEnumerable(Of KeyValuePair(Of ISlotInfo, Object)), _
ByVal converter As IConverter _
)
C#
public MethodInvocationSpec(
Type resolvedType,
IMethodInfo method,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
)
C++
public:
MethodInvocationSpec(
Type resolvedType,
IMethodInfo method,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
) sealed
J#
public MethodInvocationSpec(
Type resolvedType,
IMethodInfo method,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
)
JScript
public function MethodInvocationSpec(
resolvedType : Type,
method : IMethodInfo,
slotValues : IEnumerable<KeyValuePair<ISlotInfo, object>>,
converter : IConverter
)

Parameters

resolvedType
The non-generic type or generic type instantiation that declares the method to be invoked or is a subtype of the declaring type. This parameter is used to resolve the method to its declaring type.
method
The method or generic method definition to be instantiated
slotValues
The slot values
converter
The converter to use for converting slot values to the required types

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if resolvedType, method, slotValues or converter is null
ArgumentException | Thrown if slotValues contains slots that are declared by different methods or have incompatible values

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


Properties

MethodInvocationSpec Properties
[image]

Public Properties

 | Name | Description
Public property | Converter | Gets the converter. (inherited from DataBindingSpec)
Public property | Method | Gets the method or generic method definition to be invoked.
Public property | ResolvedArguments | Gets the resolved method arguments. The values have already been converted to appropriate types for invoking the method.
Public property | ResolvedMethod | Gets the resolved method given any generic method arguments that may have been provided as slot values.
Public property | ResolvedType | Gets the resolved type that declares the method.
Public property | SlotValues | Gets the slot values. (inherited from DataBindingSpec)
Top

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


Method Property

MethodInvocationSpec.Method Property
[image]

Gets the method or generic method definition to be invoked.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Method As IMethodInfo
C#
public IMethodInfo Method { get; }
C++
public property IMethodInfo Method sealed {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_Method();
JScript
public function get Method() : IMethodInfo

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


ResolvedArguments Property

MethodInvocationSpec.ResolvedArguments Property
[image]

Gets the resolved method arguments.

The values have already been converted to appropriate types for invoking the method.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedArguments As Object()
C#
public object[] ResolvedArguments { get; }
C++
public property object[] ResolvedArguments sealed {
array<Object>^ get();
}
J#
/** property */
public object[] get_ResolvedArguments();
JScript
public function get ResolvedArguments() : Object[]

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


ResolvedMethod Property

MethodInvocationSpec.ResolvedMethod Property
[image]

Gets the resolved method given any generic method arguments that may have been provided as slot values.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedMethod As MethodInfo
C#
public MethodInfo ResolvedMethod { get; }
C++
public property MethodInfo ResolvedMethod sealed {
MethodInfo get();
}
J#
/** property */
public MethodInfo get_ResolvedMethod();
JScript
public function get ResolvedMethod() : MethodInfo

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


ResolvedType Property

MethodInvocationSpec.ResolvedType Property
[image]

Gets the resolved type that declares the method.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedType As Type
C#
public Type ResolvedType { get; }
C++
public property Type ResolvedType sealed {
Type get();
}
J#
/** property */
public Type get_ResolvedType();
JScript
public function get ResolvedType() : Type

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


Methods

MethodInvocationSpec Methods
[image]

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method Format

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

(inherited from DataBindingSpec)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Invoke | Invokes the method.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


Invoke Method

MethodInvocationSpec.Invoke Method
[image]

Invokes the method.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerHiddenAttribute, _
DebuggerStepThroughAttribute>
Public Function Invoke( _
ByVal obj As Object _
) As Object
C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
public object Invoke(
object obj
)
C++
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
public:
Object Invoke(
Object obj
) sealed
J#
/** @attribute DebuggerHiddenAttribute() */
/** @attribute DebuggerStepThroughAttribute() */
public object Invoke(
object obj
)
JScript
public

DebuggerHiddenAttribute
DebuggerStepThroughAttribute
function Invoke(
obj : Object
) : Object

Parameters

obj
The object on which to invoke the method. This value is ignored if the method is static.

Return Value

The method result value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null but the method is non-static
Exception | Any exception thrown by the invoked method

See Also

MethodInvocationSpec Class
Gallio.Framework.Data Namespace


NullDataItem Class

NullDataItem Class
See Also Example Members
[image]

A null data item simply returns a null value on each request. It has no metadata. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullDataItem
Inherits BaseDataItem
C#
public sealed class NullDataItem : BaseDataItem
C++
ref class NullDataItem sealed : BaseDataItem
J#
public final class NullDataItem extends BaseDataItem
JScript
public final class NullDataItem extends BaseDataItem

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataItem
Gallio.Framework.Data.NullDataItem

See Also

NullDataItem Members
Gallio.Framework.Data Namespace


NullDataItem Members

NullDataItem Members
See Also Example Fields Properties Methods
[image]

A null data item simply returns a null value on each request. It has no metadata. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by NullDataItem.

Public Fields

Name | Description
Instance | Gets the singleton null data item instance. This field is read-only.
Top

Public Properties

Name Description
Public property IsDynamic Overridden.

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


Fields

NullDataItem Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton null data item instance. This field is read-only.
Top

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


Instance Field

NullDataItem.Instance Field
[image]

Gets the singleton null data item instance. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As NullDataItem
C#
public static readonly NullDataItem Instance;
C++
public:
static const NullDataItem Instance;
J#
public static final NullDataItem Instance
JScript
public static const var Instance : NullDataItem;

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


Properties

NullDataItem Properties
[image]

Public Properties

Name Description
Public property IsDynamic Overridden.

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


IsDynamic Property

NullDataItem.IsDynamic Property
[image]

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDynamic As Boolean _
Implements IDataItem.IsDynamic
C#
public override bool IsDynamic { get; }
C++
public override property bool IsDynamic override {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

Implements

IDataItem.IsDynamic

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


Methods

NullDataItem Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


GetBindingsForInformalDescription Method

NullDataItem.GetBindingsForInformalDescription Method
[image]

Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetBindingsForInformalDescription() As IEnumerable(Of DataBinding) _
Implements IDataItem.GetBindingsForInformalDescription
C#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
C++
public:
virtual IEnumerable<DataBinding> GetBindingsForInformalDescription() override
J#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
JScript
public override function GetBindingsForInformalDescription() : IEnumerable<DataBinding>

Return Value

The enumeration of bindings

Implements

IDataItem.GetBindingsForInformalDescription

See Also

NullDataItem Class
Gallio.Framework.Data Namespace


ObjectCreationSpec Class

ObjectCreationSpec Class
See Also Example Members
[image]

Encapsulates a specification for creating objects given values for a type's generic parameters, constructor parameters, fields and properties. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectCreationSpec
Inherits DataBindingSpec
C#
public sealed class ObjectCreationSpec : DataBindingSpec
C++
ref class ObjectCreationSpec sealed : DataBindingSpec
J#
public final class ObjectCreationSpec extends DataBindingSpec
JScript
public final class ObjectCreationSpec extends DataBindingSpec

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.DataBindingSpec
Gallio.Framework.Data.ObjectCreationSpec

See Also

ObjectCreationSpec Members
Gallio.Framework.Data Namespace


ObjectCreationSpec Members

ObjectCreationSpec Members
See Also Example Constructors Properties Methods
[image]

Encapsulates a specification for creating objects given values for a type's generic parameters, constructor parameters, fields and properties. This class cannot be inherited.

The following tables list the members exposed by ObjectCreationSpec.

Public Constructors

 | Name | Description
Public method | ObjectCreationSpec | Creates a new object specification.
Top

Public Properties

 | Name | Description
Public property | Converter | Gets the converter. (inherited from DataBindingSpec)
Public property | ResolvedConstructor | Gets the resolved constructor, or null if the type was abstract or if it was a struct and the default struct constructor is being use.
Public property | ResolvedConstructorArguments | Gets the resolved constructor arguments. The values have already been converted to appropriate types for invoking the constructor.
Public property | ResolvedFieldValues | Gets the resolved fields and their values. The values have already been converted to appropriate types for setting the fields.
Public property | ResolvedPropertyValues | Gets the resolved properties and their values. The values have already been converted to appropriate types for setting the properties.
Public property | ResolvedType | Gets the resolved type given any generic type arguments that may have been provided as slot values.
Public property | SlotValues | Gets the slot values. (inherited from DataBindingSpec)
Public property | Type | Gets the type or generic type definition to be instantiated.
Top

Public Methods

Name | Description
Public method | CreateInstance | Creates an instance of the resolved type and initializes it using constructor parameter, field and property slot values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method Format

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

(inherited from DataBindingSpec)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ObjectCreationSpec Constructor

ObjectCreationSpec Constructor
[image]

Creates a new object specification.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As ITypeInfo, _
ByVal slotValues As IEnumerable(Of KeyValuePair(Of ISlotInfo, Object)), _
ByVal converter As IConverter _
)
C#
public ObjectCreationSpec(
ITypeInfo type,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
)
C++
public:
ObjectCreationSpec(
ITypeInfo type,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
) sealed
J#
public ObjectCreationSpec(
ITypeInfo type,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues,
IConverter converter
)
JScript
public function ObjectCreationSpec(
type : ITypeInfo,
slotValues : IEnumerable<KeyValuePair<ISlotInfo, object>>,
converter : IConverter
)

Parameters

type
The type or generic type definition to be instantiated
slotValues
The slot values
converter
The converter to use for converting slot values to the required types

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type, slotValues or converter is null
ArgumentException | Thrown if type has an element type or if slotValues contains slots that are declared by different types or have incompatible values

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


Properties

ObjectCreationSpec Properties
[image]

Public Properties

 | Name | Description
Public property | Converter | Gets the converter. (inherited from DataBindingSpec)
Public property | ResolvedConstructor | Gets the resolved constructor, or null if the type was abstract or if it was a struct and the default struct constructor is being use.
Public property | ResolvedConstructorArguments | Gets the resolved constructor arguments. The values have already been converted to appropriate types for invoking the constructor.
Public property | ResolvedFieldValues | Gets the resolved fields and their values. The values have already been converted to appropriate types for setting the fields.
Public property | ResolvedPropertyValues | Gets the resolved properties and their values. The values have already been converted to appropriate types for setting the properties.
Public property | ResolvedType | Gets the resolved type given any generic type arguments that may have been provided as slot values.
Public property | SlotValues | Gets the slot values. (inherited from DataBindingSpec)
Public property | Type | Gets the type or generic type definition to be instantiated.
Top

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ResolvedConstructor Property

ObjectCreationSpec.ResolvedConstructor Property
[image]

Gets the resolved constructor, or null if the type was abstract or if it was a struct and the default struct constructor is being use.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedConstructor As ConstructorInfo
C#
public ConstructorInfo ResolvedConstructor { get; }
C++
public property ConstructorInfo ResolvedConstructor sealed {
ConstructorInfo get();
}
J#
/** property */
public ConstructorInfo get_ResolvedConstructor();
JScript
public function get ResolvedConstructor() : ConstructorInfo

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ResolvedConstructorArguments Property

ObjectCreationSpec.ResolvedConstructorArguments Property
[image]

Gets the resolved constructor arguments.

The values have already been converted to appropriate types for invoking the constructor.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedConstructorArguments As Object()
C#
public object[] ResolvedConstructorArguments { get; }
C++
public property object[] ResolvedConstructorArguments sealed {
array<Object>^ get();
}
J#
/** property */
public object[] get_ResolvedConstructorArguments();
JScript
public function get ResolvedConstructorArguments() : Object[]

Remarks

If ResolvedConstructor is null, then this value will be an empty array.

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ResolvedFieldValues Property

ObjectCreationSpec.ResolvedFieldValues Property
[image]

Gets the resolved fields and their values.

The values have already been converted to appropriate types for setting the fields.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedFieldValues As IEnumerable(Of KeyValuePair(Of FieldInfo, Object))
C#
public IEnumerable<KeyValuePair<FieldInfo, object>> ResolvedFieldValues { get; }
C++
public property IEnumerable<KeyValuePair<FieldInfo, object>> ResolvedFieldValues sealed {
IEnumerable<KeyValuePair<FieldInfo, object>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<FieldInfo, object>> get_ResolvedFieldValues();
JScript
public function get ResolvedFieldValues() : IEnumerable<KeyValuePair<FieldInfo, object>>

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ResolvedPropertyValues Property

ObjectCreationSpec.ResolvedPropertyValues Property
[image]

Gets the resolved properties and their values.

The values have already been converted to appropriate types for setting the properties.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedPropertyValues As IEnumerable(Of KeyValuePair(Of PropertyInfo, Object))
C#
public IEnumerable<KeyValuePair<PropertyInfo, object>> ResolvedPropertyValues { get; }
C++
public property IEnumerable<KeyValuePair<PropertyInfo, object>> ResolvedPropertyValues sealed {
IEnumerable<KeyValuePair<PropertyInfo, object>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<PropertyInfo, object>> get_ResolvedPropertyValues();
JScript
public function get ResolvedPropertyValues() : IEnumerable<KeyValuePair<PropertyInfo, object>>

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ResolvedType Property

ObjectCreationSpec.ResolvedType Property
[image]

Gets the resolved type given any generic type arguments that may have been provided as slot values.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResolvedType As Type
C#
public Type ResolvedType { get; }
C++
public property Type ResolvedType sealed {
Type get();
}
J#
/** property */
public Type get_ResolvedType();
JScript
public function get ResolvedType() : Type

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


Type Property

ObjectCreationSpec.Type Property
[image]

Gets the type or generic type definition to be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ITypeInfo
C#
public ITypeInfo Type { get; }
C++
public property ITypeInfo Type sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_Type();
JScript
public function get Type() : ITypeInfo

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


Methods

ObjectCreationSpec Methods
[image]

Public Methods

Name | Description
Public method | CreateInstance | Creates an instance of the resolved type and initializes it using constructor parameter, field and property slot values.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method Format

Formats the specification to a string for presentation.

The values are listed sequentially as follows:

  • The entity.
  • The IGenericParameterInfo slot values, if any, are ordered by index and enclosed within angle bracket.
  • The IParameterInfo slot values, if any, are ordered by index and enclosed within parentheses.
  • All other slot values, if any, are sorted by name and formatted as name-value pair assignments following a colon and delimited by a comma
Example: 'SomeType<int, string>(42, "deep thought"): Author="Douglas Adams", Book="HGTTG"'.

If there are no slots of a given kind, then the enclosing angle brackets or parentheses are ignored. Therefore if SlotValues is empty then entity will be returned unmodified.

(inherited from DataBindingSpec)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


CreateInstance Method

ObjectCreationSpec.CreateInstance Method
[image]

Creates an instance of the resolved type and initializes it using constructor parameter, field and property slot values.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateInstance() As Object
C#
public object CreateInstance()
C++
public:
Object CreateInstance() sealed
J#
public object CreateInstance()
JScript
public function CreateInstance() : Object

Return Value

The new instance, never null

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the type is not instantiable

See Also

ObjectCreationSpec Class
Gallio.Framework.Data Namespace


ObjectDataBinder Class

ObjectDataBinder Class
See Also Example Members
[image]

An object data binder creates objects and binds values to its slots such as generic type parameters, constructor parameters, fields and properties.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectDataBinder
Inherits BaseDataBinder
C#
public class ObjectDataBinder : BaseDataBinder
C++
ref class ObjectDataBinder : BaseDataBinder
J#
public class ObjectDataBinder extends BaseDataBinder
JScript
public class ObjectDataBinder extends BaseDataBinder

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataBinder
Gallio.Framework.Data.ObjectDataBinder

See Also

ObjectDataBinder Members
Gallio.Framework.Data Namespace


ObjectDataBinder Members

ObjectDataBinder Members
See Also Example Constructors Methods
[image]

An object data binder creates objects and binds values to its slots such as generic type parameters, constructor parameters, fields and properties.

The following tables list the members exposed by ObjectDataBinder.

Public Constructors

 | Name | Description
Public method | ObjectDataBinder | Creates an object data binder initially without slot binders.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext. (inherited from BaseDataBinder)
Public method | SetSlotBinder | Sets the binder for a slot.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RegisterImpl | Overridden. Implementation of Register.
Top

See Also

ObjectDataBinder Class
Gallio.Framework.Data Namespace


ObjectDataBinder Constructor

ObjectDataBinder Constructor
[image]

Creates an object data binder initially without slot binders.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As ITypeInfo _
)
C#
public ObjectDataBinder(
ITypeInfo type
)
C++
public:
ObjectDataBinder(
ITypeInfo type
) sealed
J#
public ObjectDataBinder(
ITypeInfo type
)
JScript
public function ObjectDataBinder(
type : ITypeInfo
)

Parameters

type
The type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

ObjectDataBinder Class
Gallio.Framework.Data Namespace


Methods

ObjectDataBinder Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext. (inherited from BaseDataBinder)
Public method | SetSlotBinder | Sets the binder for a slot.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RegisterImpl | Overridden. Implementation of Register.
Top

See Also

ObjectDataBinder Class
Gallio.Framework.Data Namespace


RegisterImpl Method

ObjectDataBinder.RegisterImpl Method
[image]

Implementation of Register.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function RegisterImpl( _
ByVal context As DataBindingContext, _
ByVal resolver As IDataSourceResolver _
) As IDataAccessor
C#
protected override IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
)
C++
protected:
virtual IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
) override
J#
protected override IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
)
JScript
protected override function RegisterImpl(
context : DataBindingContext,
resolver : IDataSourceResolver
) : IDataAccessor

Parameters

context
The data binding context, not null
resolver
The data source resolver, not null

Return Value

The data binding accessor

See Also

ObjectDataBinder Class
Gallio.Framework.Data Namespace


SetSlotBinder Method

ObjectDataBinder.SetSlotBinder Method
[image]

Sets the binder for a slot.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSlotBinder( _
ByVal slot As ISlotInfo, _
ByVal binder As IDataBinder _
)
C#
public void SetSlotBinder(
ISlotInfo slot,
IDataBinder binder
)
C++
public:
void SetSlotBinder(
ISlotInfo slot,
IDataBinder binder
) sealed
J#
public void SetSlotBinder(
ISlotInfo slot,
IDataBinder binder
)
JScript
public function SetSlotBinder(
slot : ISlotInfo,
binder : IDataBinder
)

Parameters

slot
The slot
binder
The binder

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if slot or binder is null

See Also

ObjectDataBinder Class
Gallio.Framework.Data Namespace


PairwiseJoinStrategy Class

PairwiseJoinStrategy Class
See Also Example Members
[image]

The pairwise strategy constructs a limited number of combinations of the items within the data providers such that they cover all possible pairs of values from each data source.

This strategy can be more efficient than one based on exhaustively testing all combinations since many test failures result from the interaction of a relatively small number of factors: often just two of them.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class PairwiseJoinStrategy
Implements IJoinStrategy
C#
public sealed class PairwiseJoinStrategy : IJoinStrategy
C++
ref class PairwiseJoinStrategy sealed : IJoinStrategy
J#
public final class PairwiseJoinStrategy implements IJoinStrategy
JScript
public final class PairwiseJoinStrategy extends IJoinStrategy

Remarks

Computing orthogonal arrays for pairwise joins for large domains can be very expensive computationally. Therefore most practical algorithms use approximations.

The algorithm used here makes a list of all pairs that must be covered. Then it constructs combinations greedily by trying to include as many uncovered pairs in each one as possible, preferring pairs used less often over other ones. The combinations produced may not be optimal but empirically it covers all pairs using a sufficiently small number of cases for most practical purposes.

Many thanks to James Bach at Satisfice (www.satisfice.com) for his AllPairs program from which the algorithm used here was adapted.

The choice of considering only 2 factors was made for the sake of implementation convenience. It turns out that an N-wise combination strategy is much more complex to implement efficiently because the general problem is NP-Complete. However, if you should choose to implement such a join strategy on your own, please consider contributing it back to the Gallio project for others to use. Thanks!

See also: http://www.pairwise.org/.

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.PairwiseJoinStrategy

See Also

PairwiseJoinStrategy Members
Gallio.Framework.Data Namespace
CombinatorialJoinStrategy


PairwiseJoinStrategy Members

PairwiseJoinStrategy Members
See Also Example Fields Methods
[image]

The pairwise strategy constructs a limited number of combinations of the items within the data providers such that they cover all possible pairs of values from each data source.

This strategy can be more efficient than one based on exhaustively testing all combinations since many test failures result from the interaction of a relatively small number of factors: often just two of them.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by PairwiseJoinStrategy.

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PairwiseJoinStrategy Class
Gallio.Framework.Data Namespace
CombinatorialJoinStrategy


Fields

PairwiseJoinStrategy Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

See Also

PairwiseJoinStrategy Class
Gallio.Framework.Data Namespace
CombinatorialJoinStrategy


Instance Field

PairwiseJoinStrategy.Instance Field
[image]

Gets the singleton instance of the strategy. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As PairwiseJoinStrategy
C#
public static readonly PairwiseJoinStrategy Instance;
C++
public:
static const PairwiseJoinStrategy Instance;
J#
public static final PairwiseJoinStrategy Instance
JScript
public static const var Instance : PairwiseJoinStrategy;

See Also

PairwiseJoinStrategy Class
Gallio.Framework.Data Namespace


Methods

PairwiseJoinStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PairwiseJoinStrategy Class
Gallio.Framework.Data Namespace
CombinatorialJoinStrategy


Join Method

PairwiseJoinStrategy.Join Method
[image]

Joins the items from each provider into a sequence of aggregate items.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Join( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindingsPerProvider As IList(Of ICollection(Of DataBinding)), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IList(Of IDataItem)) _
Implements IJoinStrategy.Join
C#
public IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
C++
public:
IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
JScript
public function Join(
providers : IList<IDataProvider>,
bindingsPerProvider : IList<ICollection<DataBinding>>,
includeDynamicItems : bool
) : IEnumerable<IList<IDataItem>>

Parameters

providers
The list of providers
bindingsPerProvider
The list of bindings per provider
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

An enumeration of item-lists consisting of exactly one item from each provider and indexed in the same order as the providers collection

Implements

IJoinStrategy.Join

See Also

PairwiseJoinStrategy Class
Gallio.Framework.Data Namespace


ScalarDataBinder Class

ScalarDataBinder Class
See Also Example Members
[image]

A scalar data binder queries a specified data source with a data binding and converts the resulting value to the requested type. It does nothing during unbinding.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ScalarDataBinder
Inherits BaseDataBinder
C#
public class ScalarDataBinder : BaseDataBinder
C++
ref class ScalarDataBinder : BaseDataBinder
J#
public class ScalarDataBinder extends BaseDataBinder
JScript
public class ScalarDataBinder extends BaseDataBinder

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataBinder
Gallio.Framework.Data.ScalarDataBinder

See Also

ScalarDataBinder Members
Gallio.Framework.Data Namespace


ScalarDataBinder Members

ScalarDataBinder Members
See Also Example Constructors Methods
[image]

A scalar data binder queries a specified data source with a data binding and converts the resulting value to the requested type. It does nothing during unbinding.

The following tables list the members exposed by ScalarDataBinder.

Public Constructors

 | Name | Description
Public method | ScalarDataBinder | Creates a scalar data binder.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext. (inherited from BaseDataBinder)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RegisterImpl | Overridden. Implementation of Register.
Top

See Also

ScalarDataBinder Class
Gallio.Framework.Data Namespace


ScalarDataBinder Constructor

ScalarDataBinder Constructor
[image]

Creates a scalar data binder.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal binding As DataBinding, _
ByVal sourceName As String _
)
C#
public ScalarDataBinder(
DataBinding binding,
string sourceName
)
C++
public:
ScalarDataBinder(
DataBinding binding,
String sourceName
) sealed
J#
public ScalarDataBinder(
DataBinding binding,
string sourceName
)
JScript
public function ScalarDataBinder(
binding : DataBinding,
sourceName : String
)

Parameters

binding
The data binding
sourceName
The data source name to query, or an empty string if it is anonymous

See Also

ScalarDataBinder Class
Gallio.Framework.Data Namespace


Methods

ScalarDataBinder Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Register | Registers the IDataBinder's requests to query particular IDataSets with the DataBindingContext. (inherited from BaseDataBinder)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RegisterImpl | Overridden. Implementation of Register.
Top

See Also

ScalarDataBinder Class
Gallio.Framework.Data Namespace


RegisterImpl Method

ScalarDataBinder.RegisterImpl Method
[image]

Implementation of Register.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function RegisterImpl( _
ByVal context As DataBindingContext, _
ByVal resolver As IDataSourceResolver _
) As IDataAccessor
C#
protected override IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
)
C++
protected:
virtual IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
) override
J#
protected override IDataAccessor RegisterImpl(
DataBindingContext context,
IDataSourceResolver resolver
)
JScript
protected override function RegisterImpl(
context : DataBindingContext,
resolver : IDataSourceResolver
) : IDataAccessor

Parameters

context
The data binding context, not null
resolver
The data source resolver, not null

Return Value

The data binding accessor

See Also

ScalarDataBinder Class
Gallio.Framework.Data Namespace


ScalarDataItem Generic Class

ScalarDataItem Generic Class
See Also Example Members
[image]

A scalar data item represents a single static data value combined with optional metadata for the item. Data binding occurs whenever the binding index is 0. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScalarDataItem(Of T)
Inherits SimpleDataItem
C#
public sealed class ScalarDataItem<T> : SimpleDataItem
C++
ref class ScalarDataItem<T> sealed : SimpleDataItem
J#
public final class ScalarDataItem<T> extends SimpleDataItem
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataItem
Gallio.Framework.Data.SimpleDataItem
Gallio.Framework.Data.ScalarDataItem<T>

See Also

ScalarDataItem<T> Members
Gallio.Framework.Data Namespace


ScalarDataItem<T> Members

ScalarDataItem Members
See Also Example Constructors Properties Methods
[image]

A scalar data item represents a single static data value combined with optional metadata for the item. Data binding occurs whenever the binding index is 0. This class cannot be inherited.

The following tables list the members exposed by ScalarDataItem<T>.

Public Constructors

 | Name | Description
Public method | ScalarDataItem | Creates a scalar data item with optional metadata.
Top

Public Properties

Name Description
Public property IsDynamic

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

(inherited from SimpleDataItem)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ScalarDataItem<T> Class
Gallio.Framework.Data Namespace


ScalarDataItem Constructor

ScalarDataItem Constructor
[image]

Creates a scalar data item with optional metadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal value As T, _
ByVal metadataPairs As IEnumerable(Of KeyValuePair(Of String, String)), _
ByVal isDynamic As Boolean _
)
C#
public ScalarDataItem(
T value,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
C++
public:
ScalarDataItem(
T value,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
) sealed
J#
public ScalarDataItem(
T value,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value to hold
metadataPairs
The metadata key/value pairs, or null if none
isDynamic
True if the item contains dynamic data

See Also

ScalarDataItem<T> Class
Gallio.Framework.Data Namespace


Methods

ScalarDataItem Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Overridden. Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ScalarDataItem<T> Class
Gallio.Framework.Data Namespace


GetBindingsForInformalDescription Method

ScalarDataItem.GetBindingsForInformalDescription Method
[image]

Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetBindingsForInformalDescription() As IEnumerable(Of DataBinding) _
Implements IDataItem.GetBindingsForInformalDescription
C#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
C++
public:
virtual IEnumerable<DataBinding> GetBindingsForInformalDescription() override
J#
public override IEnumerable<DataBinding> GetBindingsForInformalDescription()
JScript
JScript does not support generic types and methods.

Return Value

The enumeration of bindings

Implements

IDataItem.GetBindingsForInformalDescription

See Also

ScalarDataItem<T> Class
Gallio.Framework.Data Namespace


SequentialJoinStrategy Class

SequentialJoinStrategy Class
See Also Example Members
[image]

The sequential join strategy combines items from each data provider sequentially. If one provider contains fewer items than the others, the sequential join strategy will insert a NullDataItem in its place until all other providers have been exhausted. This is similar to performing an "outer join" of multiple sources by ordinal index. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SequentialJoinStrategy
Implements IJoinStrategy
C#
public sealed class SequentialJoinStrategy : IJoinStrategy
C++
ref class SequentialJoinStrategy sealed : IJoinStrategy
J#
public final class SequentialJoinStrategy implements IJoinStrategy
JScript
public final class SequentialJoinStrategy extends IJoinStrategy

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.SequentialJoinStrategy

See Also

SequentialJoinStrategy Members
Gallio.Framework.Data Namespace


SequentialJoinStrategy Members

SequentialJoinStrategy Members
See Also Example Fields Methods
[image]

The sequential join strategy combines items from each data provider sequentially. If one provider contains fewer items than the others, the sequential join strategy will insert a NullDataItem in its place until all other providers have been exhausted. This is similar to performing an "outer join" of multiple sources by ordinal index. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by SequentialJoinStrategy.

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SequentialJoinStrategy Class
Gallio.Framework.Data Namespace


Fields

SequentialJoinStrategy Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

See Also

SequentialJoinStrategy Class
Gallio.Framework.Data Namespace


Instance Field

SequentialJoinStrategy.Instance Field
[image]

Gets the singleton instance of the strategy. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As SequentialJoinStrategy
C#
public static readonly SequentialJoinStrategy Instance;
C++
public:
static const SequentialJoinStrategy Instance;
J#
public static final SequentialJoinStrategy Instance
JScript
public static const var Instance : SequentialJoinStrategy;

See Also

SequentialJoinStrategy Class
Gallio.Framework.Data Namespace


Methods

SequentialJoinStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Join | Joins the items from each provider into a sequence of aggregate items.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SequentialJoinStrategy Class
Gallio.Framework.Data Namespace


Join Method

SequentialJoinStrategy.Join Method
[image]

Joins the items from each provider into a sequence of aggregate items.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Join( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindingsPerProvider As IList(Of ICollection(Of DataBinding)), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IList(Of IDataItem)) _
Implements IJoinStrategy.Join
C#
public IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
C++
public:
IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IList<IDataItem>> Join(
IList<IDataProvider> providers,
IList<ICollection<DataBinding>> bindingsPerProvider,
bool includeDynamicItems
)
JScript
public function Join(
providers : IList<IDataProvider>,
bindingsPerProvider : IList<ICollection<DataBinding>>,
includeDynamicItems : bool
) : IEnumerable<IList<IDataItem>>

Parameters

providers
The list of providers
bindingsPerProvider
The list of bindings per provider
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

An enumeration of item-lists consisting of exactly one item from each provider and indexed in the same order as the providers collection

Implements

IJoinStrategy.Join

See Also

SequentialJoinStrategy Class
Gallio.Framework.Data Namespace


SimpleDataItem Class

SimpleDataItem Class
See Also Example Members
[image]

An implementation of IDataItem that stores the dynamic flag and metadata. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SimpleDataItem
Inherits BaseDataItem
C#
public abstract class SimpleDataItem : BaseDataItem
C++
ref class SimpleDataItem abstract : BaseDataItem
J#
public class SimpleDataItem extends BaseDataItem
JScript
public class SimpleDataItem extends BaseDataItem

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataItem
Gallio.Framework.Data.SimpleDataItem
Gallio.Framework.Data.ListDataItem<T>
Gallio.Framework.Data.ScalarDataItem<T>

See Also

SimpleDataItem Members
Gallio.Framework.Data Namespace


SimpleDataItem Members

SimpleDataItem Members
See Also Example Constructors Properties Methods
[image]

An implementation of IDataItem that stores the dynamic flag and metadata. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by SimpleDataItem.

Public Constructors

 | Name | Description
Public method | SimpleDataItem | Creates a data item.
Top

Public Properties

Name Description
Public property IsDynamic Overridden.

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete. (inherited from BaseDataItem)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Implements GetValue. (inherited from BaseDataItem)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateMetadataImpl | Overridden. Implements PopulateMetadata.
Top

See Also

SimpleDataItem Class
Gallio.Framework.Data Namespace


SimpleDataItem Constructor

SimpleDataItem Constructor
[image]

Creates a data item.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal metadataPairs As IEnumerable(Of KeyValuePair(Of String, String)), _
ByVal isDynamic As Boolean _
)
C#
public SimpleDataItem(
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
C++
public:
SimpleDataItem(
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
) sealed
J#
public SimpleDataItem(
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
JScript
public function SimpleDataItem(
metadataPairs : IEnumerable<KeyValuePair<string, string>>,
isDynamic : bool
)

Parameters

metadataPairs
The metadata key/value pairs for the item, or null if none
isDynamic
True if the item is dynamic

See Also

SimpleDataItem Class
Gallio.Framework.Data Namespace


Properties

SimpleDataItem Properties
[image]

Public Properties

Name Description
Public property IsDynamic Overridden.

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Top

See Also

SimpleDataItem Class
Gallio.Framework.Data Namespace


IsDynamic Property

SimpleDataItem.IsDynamic Property
[image]

Returns true if the item contains data that is obtained dynamically from sources whose content may change over time or may be expensive to query ahead of time.

For example, data obtained from a database should be considered dynamic. On the other hand, data obtained from declarative metadata defined as part of the test should be considered static.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDynamic As Boolean _
Implements IDataItem.IsDynamic
C#
public override bool IsDynamic { get; }
C++
public override property bool IsDynamic override {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

Implements

IDataItem.IsDynamic

See Also

SimpleDataItem Class
Gallio.Framework.Data Namespace


Methods

SimpleDataItem Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBindingsForInformalDescription | Gets an enumeration of the data bindings that may be queried to informally describe its contents. The enumeration of bindings may not be complete. (inherited from BaseDataItem)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Gets the value of the specified binding. (inherited from BaseDataItem)
Public method | PopulateMetadata | Populates the specified metadata map with key/value pairs associated with the data item, if any. For example, the metadata may contain a description that serves as documentation of the contents of the data item or of the test scenario that is exercised by the contents of the data item. This metadata may be injected into test instances created with the contents of this data item. (inherited from BaseDataItem)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetValueImpl | Implements GetValue. (inherited from BaseDataItem)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateMetadataImpl | Overridden. Implements PopulateMetadata.
Top

See Also

SimpleDataItem Class
Gallio.Framework.Data Namespace


PopulateMetadataImpl Method

SimpleDataItem.PopulateMetadataImpl Method
[image]

Implements PopulateMetadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateMetadataImpl( _
ByVal map As PropertyBag _
)
C#
protected override void PopulateMetadataImpl(
PropertyBag map
)
C++
protected:
virtual void PopulateMetadataImpl(
PropertyBag map
) override
J#
protected override void PopulateMetadataImpl(
PropertyBag map
)
JScript
protected override function PopulateMetadataImpl(
map : PropertyBag
)

Parameters

map
The metadata map to populate, never null

See Also

SimpleDataItem Class
Gallio.Framework.Data Namespace


UnionMergeStrategy Class

UnionMergeStrategy Class
See Also Example Members
[image]

The union merge strategy combines the items from multiple providers by discarding all items whose values duplicate those of other items that have already been enumerated.

Uniqueness is determined by the natural equality of each bound value in the item.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnionMergeStrategy
Implements IMergeStrategy
C#
public sealed class UnionMergeStrategy : IMergeStrategy
C++
ref class UnionMergeStrategy sealed : IMergeStrategy
J#
public final class UnionMergeStrategy implements IMergeStrategy
JScript
public final class UnionMergeStrategy extends IMergeStrategy

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.UnionMergeStrategy

See Also

UnionMergeStrategy Members
Gallio.Framework.Data Namespace


UnionMergeStrategy Members

UnionMergeStrategy Members
See Also Example Fields Methods
[image]

The union merge strategy combines the items from multiple providers by discarding all items whose values duplicate those of other items that have already been enumerated.

Uniqueness is determined by the natural equality of each bound value in the item.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by UnionMergeStrategy.

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Merge | Merges the items from each provider into a new sequence.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UnionMergeStrategy Class
Gallio.Framework.Data Namespace


Fields

UnionMergeStrategy Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the strategy. This field is read-only.
Top

See Also

UnionMergeStrategy Class
Gallio.Framework.Data Namespace


Instance Field

UnionMergeStrategy.Instance Field
[image]

Gets the singleton instance of the strategy. This field is read-only.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As UnionMergeStrategy
C#
public static readonly UnionMergeStrategy Instance;
C++
public:
static const UnionMergeStrategy Instance;
J#
public static final UnionMergeStrategy Instance
JScript
public static const var Instance : UnionMergeStrategy;

See Also

UnionMergeStrategy Class
Gallio.Framework.Data Namespace


Methods

UnionMergeStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Merge | Merges the items from each provider into a new sequence.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UnionMergeStrategy Class
Gallio.Framework.Data Namespace


Merge Method

UnionMergeStrategy.Merge Method
[image]

Merges the items from each provider into a new sequence.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Merge( _
ByVal providers As IList(Of IDataProvider), _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem) _
Implements IMergeStrategy.Merge
C#
public IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
public:
IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
) sealed
J#
public IEnumerable<IDataItem> Merge(
IList<IDataProvider> providers,
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
public function Merge(
providers : IList<IDataProvider>,
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

providers
The list of providers
bindings
The bindings
includeDynamicItems
If true, includes items that may be dynamically generated in the result set. Otherwise excludes such items and only returns those that are statically known a priori.

Return Value

The merged sequence of items

Implements

IMergeStrategy.Merge

See Also

UnionMergeStrategy Class
Gallio.Framework.Data Namespace


ValueSequenceDataSet Class

ValueSequenceDataSet Class
See Also Example Members
[image]

A data set constructed from an enumerated sequence of values. This class cannot be inherited.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ValueSequenceDataSet
Inherits BaseDataSet
C#
public sealed class ValueSequenceDataSet : BaseDataSet
C++
ref class ValueSequenceDataSet sealed : BaseDataSet
J#
public final class ValueSequenceDataSet extends BaseDataSet
JScript
public final class ValueSequenceDataSet extends BaseDataSet

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.ValueSequenceDataSet

See Also

ValueSequenceDataSet Members
Gallio.Framework.Data Namespace


ValueSequenceDataSet Members

ValueSequenceDataSet Members
See Also Example Constructors Properties Methods
[image]

A data set constructed from an enumerated sequence of values. This class cannot be inherited.

The following tables list the members exposed by ValueSequenceDataSet.

Public Constructors

 | Name | Description
Public method | ValueSequenceDataSet | Creates a column sequence data set with optional metadata.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ValueSequenceDataSet Class
Gallio.Framework.Data Namespace


ValueSequenceDataSet Constructor

ValueSequenceDataSet Constructor
[image]

Creates a column sequence data set with optional metadata.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal values As IEnumerable, _
ByVal metadataPairs As IEnumerable(Of KeyValuePair(Of String, String)), _
ByVal isDynamic As Boolean _
)
C#
public ValueSequenceDataSet(
IEnumerable values,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
C++
public:
ValueSequenceDataSet(
IEnumerable values,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
) sealed
J#
public ValueSequenceDataSet(
IEnumerable values,
IEnumerable<KeyValuePair<string, string>> metadataPairs,
bool isDynamic
)
JScript
public function ValueSequenceDataSet(
values : IEnumerable,
metadataPairs : IEnumerable<KeyValuePair<string, string>>,
isDynamic : bool
)

Parameters

values
The sequence of column values, each generating an item
metadataPairs
The metadata key/value pair enumeration, or null if none
isDynamic
True if the sequence is dynamic

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if values is null

See Also

ValueSequenceDataSet Class
Gallio.Framework.Data Namespace


Properties

ValueSequenceDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Top

See Also

ValueSequenceDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

ValueSequenceDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

ValueSequenceDataSet Class
Gallio.Framework.Data Namespace


XmlDataSet Class

XmlDataSet Class
See Also Example Members
[image]

An XML data set selects nodes from an XML document using XPath expressions. The selected nodes are returned as XPathNavigator objects.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlDataSet
Inherits BaseDataSet
C#
public class XmlDataSet : BaseDataSet
C++
ref class XmlDataSet : BaseDataSet
J#
public class XmlDataSet extends BaseDataSet
JScript
public class XmlDataSet extends BaseDataSet

Remarks

Two XPath expressions are used.

  • Item Path - An XPath expression that selects a set of nodes that are used to uniquely identify records. For example, the item path might be used to select the containing element of each Book element in an XML document of Books. The item path is specified in the constructor.
  • Binding Path - An XPath expression that selects a node relative to the item path that contains a particular data value of interest. For example, the binding path might be used to select the Author attribute of a Book element in an XML document of Books. The binding path is specified by the DataBinding.

The XML may contain metadata at the row level by adding metadata elements in the http://www.gallio.org/ namespace containing metadata entries. In the following example, the row values would be selected using an Item Path of "//row" and a Binding Path of "@value". Additionally, some rows would have metadata as specified.

Copy Code
            <data>
              <row value="somevalue">
                <metadata xmlns="http://www.gallio.org/">
                  <entry key="Description" value="A row..." />
                  <entry key="Author" value="Me" />
                </metadata>
              </row>
              <row value="anothervalue" />
            </data>

Inheritance Hierarchy

System.Object
Gallio.Framework.Data.BaseDataSet
Gallio.Framework.Data.XmlDataSet

See Also

XmlDataSet Members
Gallio.Framework.Data Namespace


XmlDataSet Members

XmlDataSet Members
See Also Example Constructors Properties Methods
[image]

An XML data set selects nodes from an XML document using XPath expressions. The selected nodes are returned as XPathNavigator objects.

The following tables list the members exposed by XmlDataSet.

Public Constructors

 | Name | Description
Public method | XmlDataSet | Creates an XML data set.
Top

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | DataLocationName | Gets the name of the location that is providing the data, or null if none. The data location name and line number are exposed as DataLocation metadata when provided.
Top

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


XmlDataSet Constructor

XmlDataSet Constructor
[image]

Creates an XML data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal documentProvider As Func(Of IXPathNavigable), _
ByVal itemPath As String, _
ByVal isDynamic As Boolean _
)
C#
public XmlDataSet(
Func<IXPathNavigable> documentProvider,
string itemPath,
bool isDynamic
)
C++
public:
XmlDataSet(
Func<IXPathNavigable> documentProvider,
String itemPath,
bool isDynamic
) sealed
J#
public XmlDataSet(
Func<IXPathNavigable> documentProvider,
string itemPath,
bool isDynamic
)
JScript
public function XmlDataSet(
documentProvider : Func<IXPathNavigable>,
itemPath : String,
isDynamic : bool
)

Parameters

documentProvider
A delegate that produces the XML document on demand
itemPath
The XPath expression used to select items within the document
isDynamic
True if the data set should be considered dynamic

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if documentProvider or itemPath is null

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


Properties

XmlDataSet Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnCount | Overridden. Gets the number of columns in an indexed data set.
Public property | DataLocationName | Gets the name of the location that is providing the data, or null if none. The data location name and line number are exposed as DataLocation metadata when provided.
Top

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


ColumnCount Property

XmlDataSet.ColumnCount Property
[image]

Gets the number of columns in an indexed data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ColumnCount As Integer _
Implements IDataSet.ColumnCount
C#
public override int ColumnCount { get; }
C++
public override property int ColumnCount override {
int get();
}
J#
/** property */
public int get_ColumnCount();
JScript
public function get ColumnCount() : int

Implements

IDataSet.ColumnCount

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


DataLocationName Property

XmlDataSet.DataLocationName Property
[image]

Gets the name of the location that is providing the data, or null if none.

The data location name and line number are exposed as DataLocation metadata when provided.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property DataLocationName As String
C#
public string DataLocationName { get; set; }
C++
public property string DataLocationName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DataLocationName();

/** property */
public void set_DataLocationName(string value);
JScript
public function get DataLocationName() : String

public function set DataLocationName(value : String);

Property Value

The default value is null.

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


Methods

XmlDataSet Methods
[image]

Public Methods

 | Name | Description
Public method | CanBind | Returns true if the data set can provide a value for the specified binding. (inherited from BaseDataSet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetItems | Gets an enumeration of data items that can supply values for a given collection of bindings. It should produce items even if some of the requested bindings cannot be fulfilled. (inherited from BaseDataSet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CanBindImpl | Overridden. Determines whether a binding can be satisfied by the data set.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetItemsImpl | Overridden. Enumerates the data items in the data set.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


CanBindImpl Method

XmlDataSet.CanBindImpl Method
[image]

Determines whether a binding can be satisfied by the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CanBindImpl( _
ByVal binding As DataBinding _
) As Boolean
C#
protected override bool CanBindImpl(
DataBinding binding
)
C++
protected:
virtual bool CanBindImpl(
DataBinding binding
) override
J#
protected override bool CanBindImpl(
DataBinding binding
)
JScript
protected override function CanBindImpl(
binding : DataBinding
) : bool

Parameters

binding
The data binding, not null

Return Value

True if the binding can be satisfied

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


GetItemsImpl Method

XmlDataSet.GetItemsImpl Method
[image]

Enumerates the data items in the data set.

Namespace: Gallio.Framework.Data
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemsImpl( _
ByVal bindings As ICollection(Of DataBinding), _
ByVal includeDynamicItems As Boolean _
) As IEnumerable(Of IDataItem)
C#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
C++
protected:
virtual IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
) override
J#
protected override IEnumerable<IDataItem> GetItemsImpl(
ICollection<DataBinding> bindings,
bool includeDynamicItems
)
JScript
protected override function GetItemsImpl(
bindings : ICollection<DataBinding>,
includeDynamicItems : bool
) : IEnumerable<IDataItem>

Parameters

bindings
The data bindings, not null
includeDynamicItems
If true, includes dynamic items

Return Value

The enumeration of data items in the combined data set

See Also

XmlDataSet Class
Gallio.Framework.Data Namespace


Gallio.Framework.Formatting

Gallio.Framework.Formatting Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class BooleanFormattingRule

A formatting rule for Boolean.

Formats values as "true" or "false".

This class cannot be inherited.
Public class ByteFormattingRule

A formatting rule for Byte.

Formats values as two digit hex values like "0xa5".

This class cannot be inherited.
Public class CharFormattingRule

A formatting rule for Char.

Formats values as literals like: "'x'" or "'\n'".

This class cannot be inherited.
Public class | ConvertToStringFormattingRule | A default formatting rule for objects based on using the IConverter to convert the value to a string. This rule has minimum priority so that all other formatting rules should override it in principle. This class cannot be inherited.
Public class DateTimeFormattingRule

A formatting rule for DateTime.

Formats values in the invariant round-trip format like: "yyyy'-'MM'-'dd'T'HH':'mm':'ss'.'fffffffzz".

This class cannot be inherited.
Public class DBNullFormattingRule

A formatting rule for DBNull.

Formats values as "dbnull".

This class cannot be inherited.
Public class DecimalFormattingRule

A formatting rule for Decimal.

Formats values like: "5.6m".

This class cannot be inherited.
Public class DictionaryEntryFormattingRule

A formatting rule for DictionaryEntry.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.
Public class DoubleFormattingRule

A formatting rule for Double.

Formats values like: "5.6".

This class cannot be inherited.
Public class EnumerableFormattingRule

A formatting rule for IEnumerable.

Formats values as "[1, 2, 3]".

This class cannot be inherited.
Public class ExpressionFormattingRule

A formatting rule for Expression.

Formats expression trees using a more familiar C#-like syntax than the default. Also recognizes captured variables and displays them naturally to conceal the implied field access to an anonymous class.

Made-up syntax for nodes that cannot be directly represented in C#.

  • Power operator: **, as in a ** b
  • Quote expression: `...`, as in `a + b`
  • Constants: formatted recursively using other formatters, which may yield unusual syntax

This class cannot be inherited.
Public class | Formatter | Service locator for IFormatter. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | FormatterExtensions | Extensions methods for formatting. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | FormattingRulePriority | Typical IFormattingRule priority values to use as guidelines. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class IntegerFormattingRule

A formatting rule for Int16, Int32, Int64, UInt16, UInt32, and UInt64.

Formats values like: "5", "123", "-12".

This class cannot be inherited.
Public class KeyValuePairFormattingRule

A formatting rule for KeyValuePair.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.
Public class | RuleBasedFormatter | A rule-based formatter uses a set of IFormattingRules to format values appropriately.
Public class SByteFormattingRule

A formatting rule for SByte.

Formats values as two digit signed hex values like "0x55" and "-0x55".

This class cannot be inherited.
Public class SingleFormattingRule

A formatting rule for Single.

Formats values like: "5.6f".

This class cannot be inherited.
Public class StringFormattingRule

A formatting rule for String.

Formats values as literals like: ""abc\ndef"".

This class cannot be inherited.
Public class | StructuralFormattingRule | A formatting rule that describes the structure of objects in terms of their constituent properties and fields.
Public class | StubFormatter | A formatter that is used when the runtime is not initialized.
Public class TypeFormattingRule

A formatting rule for Type.

Formats values like: string, MyType.Nested, int[], byte*, similar to C#.

This class cannot be inherited.
Public class XPathNavigableFormattingRule

A formatting rule for IXPathNavigable.

Formats values as "<root />".

This class cannot be inherited.

Interfaces

 | Interface | Description
Public interface | IFormatter | Provides services for formatting objects for display.
Public interface | IFormattingRule | A formatting rule encapsulates an algorithm for formatting values of particular types to strings for presentation.


BooleanFormattingRule Class

BooleanFormattingRule Class
See Also Example Members
[image]

A formatting rule for Boolean.

Formats values as "true" or "false".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BooleanFormattingRule
Implements IFormattingRule
C#
public sealed class BooleanFormattingRule : IFormattingRule
C++
ref class BooleanFormattingRule sealed : IFormattingRule
J#
public final class BooleanFormattingRule implements IFormattingRule
JScript
public final class BooleanFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.BooleanFormattingRule

See Also

BooleanFormattingRule Members
Gallio.Framework.Formatting Namespace


BooleanFormattingRule Members

BooleanFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Boolean.

Formats values as "true" or "false".

This class cannot be inherited.

The following tables list the members exposed by BooleanFormattingRule.

Public Constructors

 | Name | Description
Public method | BooleanFormattingRule | Initializes a new instance of the BooleanFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BooleanFormattingRule Class
Gallio.Framework.Formatting Namespace


BooleanFormattingRule Constructor

BooleanFormattingRule Constructor
[image]

Initializes a new instance of the BooleanFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BooleanFormattingRule()
C++
public:
BooleanFormattingRule() sealed
J#
public BooleanFormattingRule()
JScript
public function BooleanFormattingRule()

See Also

BooleanFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

BooleanFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BooleanFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

BooleanFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

BooleanFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

BooleanFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

BooleanFormattingRule Class
Gallio.Framework.Formatting Namespace


ByteFormattingRule Class

ByteFormattingRule Class
See Also Example Members
[image]

A formatting rule for Byte.

Formats values as two digit hex values like "0xa5".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ByteFormattingRule
Implements IFormattingRule
C#
public sealed class ByteFormattingRule : IFormattingRule
C++
ref class ByteFormattingRule sealed : IFormattingRule
J#
public final class ByteFormattingRule implements IFormattingRule
JScript
public final class ByteFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.ByteFormattingRule

See Also

ByteFormattingRule Members
Gallio.Framework.Formatting Namespace


ByteFormattingRule Members

ByteFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Byte.

Formats values as two digit hex values like "0xa5".

This class cannot be inherited.

The following tables list the members exposed by ByteFormattingRule.

Public Constructors

 | Name | Description
Public method | ByteFormattingRule | Initializes a new instance of the ByteFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ByteFormattingRule Class
Gallio.Framework.Formatting Namespace


ByteFormattingRule Constructor

ByteFormattingRule Constructor
[image]

Initializes a new instance of the ByteFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ByteFormattingRule()
C++
public:
ByteFormattingRule() sealed
J#
public ByteFormattingRule()
JScript
public function ByteFormattingRule()

See Also

ByteFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

ByteFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ByteFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

ByteFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

ByteFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

ByteFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

ByteFormattingRule Class
Gallio.Framework.Formatting Namespace


CharFormattingRule Class

CharFormattingRule Class
See Also Example Members
[image]

A formatting rule for Char.

Formats values as literals like: "'x'" or "'\n'".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CharFormattingRule
Implements IFormattingRule
C#
public sealed class CharFormattingRule : IFormattingRule
C++
ref class CharFormattingRule sealed : IFormattingRule
J#
public final class CharFormattingRule implements IFormattingRule
JScript
public final class CharFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.CharFormattingRule

See Also

CharFormattingRule Members
Gallio.Framework.Formatting Namespace


CharFormattingRule Members

CharFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Char.

Formats values as literals like: "'x'" or "'\n'".

This class cannot be inherited.

The following tables list the members exposed by CharFormattingRule.

Public Constructors

 | Name | Description
Public method | CharFormattingRule | Initializes a new instance of the CharFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CharFormattingRule Class
Gallio.Framework.Formatting Namespace


CharFormattingRule Constructor

CharFormattingRule Constructor
[image]

Initializes a new instance of the CharFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CharFormattingRule()
C++
public:
CharFormattingRule() sealed
J#
public CharFormattingRule()
JScript
public function CharFormattingRule()

See Also

CharFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

CharFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CharFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

CharFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

CharFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

CharFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

CharFormattingRule Class
Gallio.Framework.Formatting Namespace


ConvertToStringFormattingRule Class

ConvertToStringFormattingRule Class
See Also Example Members
[image]

A default formatting rule for objects based on using the IConverter to convert the value to a string. This rule has minimum priority so that all other formatting rules should override it in principle. This class cannot be inherited.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ConvertToStringFormattingRule
Implements IFormattingRule
C#
public sealed class ConvertToStringFormattingRule : IFormattingRule
C++
ref class ConvertToStringFormattingRule sealed : IFormattingRule
J#
public final class ConvertToStringFormattingRule implements IFormattingRule
JScript
public final class ConvertToStringFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.ConvertToStringFormattingRule

See Also

ConvertToStringFormattingRule Members
Gallio.Framework.Formatting Namespace


ConvertToStringFormattingRule Members

ConvertToStringFormattingRule Members
See Also Example Constructors Methods
[image]

A default formatting rule for objects based on using the IConverter to convert the value to a string. This rule has minimum priority so that all other formatting rules should override it in principle. This class cannot be inherited.

The following tables list the members exposed by ConvertToStringFormattingRule.

Public Constructors

 | Name | Description
Public method | ConvertToStringFormattingRule | Creates a conversion to string formatting rule.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConvertToStringFormattingRule Class
Gallio.Framework.Formatting Namespace


ConvertToStringFormattingRule Constructor

ConvertToStringFormattingRule Constructor
[image]

Creates a conversion to string formatting rule.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal converter As IConverter _
)
C#
public ConvertToStringFormattingRule(
IConverter converter
)
C++
public:
ConvertToStringFormattingRule(
IConverter converter
) sealed
J#
public ConvertToStringFormattingRule(
IConverter converter
)
JScript
public function ConvertToStringFormattingRule(
converter : IConverter
)

Parameters

converter
The converter to use

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if converter is null

See Also

ConvertToStringFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

ConvertToStringFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ConvertToStringFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

ConvertToStringFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

ConvertToStringFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

ConvertToStringFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

ConvertToStringFormattingRule Class
Gallio.Framework.Formatting Namespace


DateTimeFormattingRule Class

DateTimeFormattingRule Class
See Also Example Members
[image]

A formatting rule for DateTime.

Formats values in the invariant round-trip format like: "yyyy'-'MM'-'dd'T'HH':'mm':'ss'.'fffffffzz".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DateTimeFormattingRule
Implements IFormattingRule
C#
public sealed class DateTimeFormattingRule : IFormattingRule
C++
ref class DateTimeFormattingRule sealed : IFormattingRule
J#
public final class DateTimeFormattingRule implements IFormattingRule
JScript
public final class DateTimeFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.DateTimeFormattingRule

See Also

DateTimeFormattingRule Members
Gallio.Framework.Formatting Namespace


DateTimeFormattingRule Members

DateTimeFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for DateTime.

Formats values in the invariant round-trip format like: "yyyy'-'MM'-'dd'T'HH':'mm':'ss'.'fffffffzz".

This class cannot be inherited.

The following tables list the members exposed by DateTimeFormattingRule.

Public Constructors

 | Name | Description
Public method | DateTimeFormattingRule | Initializes a new instance of the DateTimeFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DateTimeFormattingRule Class
Gallio.Framework.Formatting Namespace


DateTimeFormattingRule Constructor

DateTimeFormattingRule Constructor
[image]

Initializes a new instance of the DateTimeFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DateTimeFormattingRule()
C++
public:
DateTimeFormattingRule() sealed
J#
public DateTimeFormattingRule()
JScript
public function DateTimeFormattingRule()

See Also

DateTimeFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

DateTimeFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DateTimeFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

DateTimeFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

DateTimeFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

DateTimeFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

DateTimeFormattingRule Class
Gallio.Framework.Formatting Namespace


DBNullFormattingRule Class

DBNullFormattingRule Class
See Also Example Members
[image]

A formatting rule for DBNull.

Formats values as "dbnull".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DBNullFormattingRule
Implements IFormattingRule
C#
public sealed class DBNullFormattingRule : IFormattingRule
C++
ref class DBNullFormattingRule sealed : IFormattingRule
J#
public final class DBNullFormattingRule implements IFormattingRule
JScript
public final class DBNullFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.DBNullFormattingRule

See Also

DBNullFormattingRule Members
Gallio.Framework.Formatting Namespace


DBNullFormattingRule Members

DBNullFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for DBNull.

Formats values as "dbnull".

This class cannot be inherited.

The following tables list the members exposed by DBNullFormattingRule.

Public Constructors

 | Name | Description
Public method | DBNullFormattingRule | Initializes a new instance of the DBNullFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DBNullFormattingRule Class
Gallio.Framework.Formatting Namespace


DBNullFormattingRule Constructor

DBNullFormattingRule Constructor
[image]

Initializes a new instance of the DBNullFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DBNullFormattingRule()
C++
public:
DBNullFormattingRule() sealed
J#
public DBNullFormattingRule()
JScript
public function DBNullFormattingRule()

See Also

DBNullFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

DBNullFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DBNullFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

DBNullFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

DBNullFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

DBNullFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

DBNullFormattingRule Class
Gallio.Framework.Formatting Namespace


DecimalFormattingRule Class

DecimalFormattingRule Class
See Also Example Members
[image]

A formatting rule for Decimal.

Formats values like: "5.6m".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DecimalFormattingRule
Implements IFormattingRule
C#
public sealed class DecimalFormattingRule : IFormattingRule
C++
ref class DecimalFormattingRule sealed : IFormattingRule
J#
public final class DecimalFormattingRule implements IFormattingRule
JScript
public final class DecimalFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.DecimalFormattingRule

See Also

DecimalFormattingRule Members
Gallio.Framework.Formatting Namespace


DecimalFormattingRule Members

DecimalFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Decimal.

Formats values like: "5.6m".

This class cannot be inherited.

The following tables list the members exposed by DecimalFormattingRule.

Public Constructors

 | Name | Description
Public method | DecimalFormattingRule | Initializes a new instance of the DecimalFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DecimalFormattingRule Class
Gallio.Framework.Formatting Namespace


DecimalFormattingRule Constructor

DecimalFormattingRule Constructor
[image]

Initializes a new instance of the DecimalFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DecimalFormattingRule()
C++
public:
DecimalFormattingRule() sealed
J#
public DecimalFormattingRule()
JScript
public function DecimalFormattingRule()

See Also

DecimalFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

DecimalFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DecimalFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

DecimalFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

DecimalFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

DecimalFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

DecimalFormattingRule Class
Gallio.Framework.Formatting Namespace


DictionaryEntryFormattingRule Class

DictionaryEntryFormattingRule Class
See Also Example Members
[image]

A formatting rule for DictionaryEntry.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DictionaryEntryFormattingRule
Implements IFormattingRule
C#
public sealed class DictionaryEntryFormattingRule : IFormattingRule
C++
ref class DictionaryEntryFormattingRule sealed : IFormattingRule
J#
public final class DictionaryEntryFormattingRule implements IFormattingRule
JScript
public final class DictionaryEntryFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.DictionaryEntryFormattingRule

See Also

DictionaryEntryFormattingRule Members
Gallio.Framework.Formatting Namespace


DictionaryEntryFormattingRule Members

DictionaryEntryFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for DictionaryEntry.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.

The following tables list the members exposed by DictionaryEntryFormattingRule.

Public Constructors

 | Name | Description
Public method | DictionaryEntryFormattingRule | Initializes a new instance of the DictionaryEntryFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DictionaryEntryFormattingRule Class
Gallio.Framework.Formatting Namespace


DictionaryEntryFormattingRule Constructor

DictionaryEntryFormattingRule Constructor
[image]

Initializes a new instance of the DictionaryEntryFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DictionaryEntryFormattingRule()
C++
public:
DictionaryEntryFormattingRule() sealed
J#
public DictionaryEntryFormattingRule()
JScript
public function DictionaryEntryFormattingRule()

See Also

DictionaryEntryFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

DictionaryEntryFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DictionaryEntryFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

DictionaryEntryFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

DictionaryEntryFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

DictionaryEntryFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

DictionaryEntryFormattingRule Class
Gallio.Framework.Formatting Namespace


DoubleFormattingRule Class

DoubleFormattingRule Class
See Also Example Members
[image]

A formatting rule for Double.

Formats values like: "5.6".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DoubleFormattingRule
Implements IFormattingRule
C#
public sealed class DoubleFormattingRule : IFormattingRule
C++
ref class DoubleFormattingRule sealed : IFormattingRule
J#
public final class DoubleFormattingRule implements IFormattingRule
JScript
public final class DoubleFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.DoubleFormattingRule

See Also

DoubleFormattingRule Members
Gallio.Framework.Formatting Namespace


DoubleFormattingRule Members

DoubleFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Double.

Formats values like: "5.6".

This class cannot be inherited.

The following tables list the members exposed by DoubleFormattingRule.

Public Constructors

 | Name | Description
Public method | DoubleFormattingRule | Initializes a new instance of the DoubleFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DoubleFormattingRule Class
Gallio.Framework.Formatting Namespace


DoubleFormattingRule Constructor

DoubleFormattingRule Constructor
[image]

Initializes a new instance of the DoubleFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DoubleFormattingRule()
C++
public:
DoubleFormattingRule() sealed
J#
public DoubleFormattingRule()
JScript
public function DoubleFormattingRule()

See Also

DoubleFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

DoubleFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DoubleFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

DoubleFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

DoubleFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

DoubleFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

DoubleFormattingRule Class
Gallio.Framework.Formatting Namespace


EnumerableFormattingRule Class

EnumerableFormattingRule Class
See Also Example Members
[image]

A formatting rule for IEnumerable.

Formats values as "[1, 2, 3]".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EnumerableFormattingRule
Implements IFormattingRule
C#
public sealed class EnumerableFormattingRule : IFormattingRule
C++
ref class EnumerableFormattingRule sealed : IFormattingRule
J#
public final class EnumerableFormattingRule implements IFormattingRule
JScript
public final class EnumerableFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.EnumerableFormattingRule

See Also

EnumerableFormattingRule Members
Gallio.Framework.Formatting Namespace


EnumerableFormattingRule Members

EnumerableFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for IEnumerable.

Formats values as "[1, 2, 3]".

This class cannot be inherited.

The following tables list the members exposed by EnumerableFormattingRule.

Public Constructors

 | Name | Description
Public method | EnumerableFormattingRule | Initializes a new instance of the EnumerableFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

EnumerableFormattingRule Class
Gallio.Framework.Formatting Namespace


EnumerableFormattingRule Constructor

EnumerableFormattingRule Constructor
[image]

Initializes a new instance of the EnumerableFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EnumerableFormattingRule()
C++
public:
EnumerableFormattingRule() sealed
J#
public EnumerableFormattingRule()
JScript
public function EnumerableFormattingRule()

See Also

EnumerableFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

EnumerableFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

EnumerableFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

EnumerableFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

EnumerableFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

EnumerableFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

EnumerableFormattingRule Class
Gallio.Framework.Formatting Namespace


ExpressionFormattingRule Class

ExpressionFormattingRule Class
See Also Example Members
[image]

A formatting rule for Expression.

Formats expression trees using a more familiar C#-like syntax than the default. Also recognizes captured variables and displays them naturally to conceal the implied field access to an anonymous class.

Made-up syntax for nodes that cannot be directly represented in C#.

  • Power operator: **, as in a ** b
  • Quote expression: `...`, as in `a + b`
  • Constants: formatted recursively using other formatters, which may yield unusual syntax

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionFormattingRule
Implements IFormattingRule
C#
public sealed class ExpressionFormattingRule : IFormattingRule
C++
ref class ExpressionFormattingRule sealed : IFormattingRule
J#
public final class ExpressionFormattingRule implements IFormattingRule
JScript
public final class ExpressionFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.ExpressionFormattingRule

See Also

ExpressionFormattingRule Members
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionFormattingRule Members

ExpressionFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Expression.

Formats expression trees using a more familiar C#-like syntax than the default. Also recognizes captured variables and displays them naturally to conceal the implied field access to an anonymous class.

Made-up syntax for nodes that cannot be directly represented in C#.

  • Power operator: **, as in a ** b
  • Quote expression: `...`, as in `a + b`
  • Constants: formatted recursively using other formatters, which may yield unusual syntax

This class cannot be inherited.

The following tables list the members exposed by ExpressionFormattingRule.

Public Constructors

 | Name | Description
Public method | ExpressionFormattingRule | Initializes a new instance of the ExpressionFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionFormattingRule Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionFormattingRule Constructor

ExpressionFormattingRule Constructor
[image]

Initializes a new instance of the ExpressionFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExpressionFormattingRule()
C++
public:
ExpressionFormattingRule() sealed
J#
public ExpressionFormattingRule()
JScript
public function ExpressionFormattingRule()

See Also

ExpressionFormattingRule Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

ExpressionFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionFormattingRule Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Format Method

ExpressionFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

ExpressionFormattingRule Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


GetPriority Method

ExpressionFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

ExpressionFormattingRule Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Formatter Class

Formatter Class
See Also Example Members
[image]

Service locator for IFormatter. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module Formatter
C#
public static class Formatter
C++
ref class Formatter abstract sealed
J#
public final class Formatter
JScript
public class Formatter

Remarks

Handles the case where the runtime is not initialized by returning a StubFormatter.

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.Formatter

See Also

Formatter Members
Gallio.Framework.Formatting Namespace


Formatter Members

Formatter Members
See Also Example Properties
[image]

Service locator for IFormatter. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Formatter.

Public Properties

Name | Description
Instance | Gets the global formatter singleton.
Top

See Also

Formatter Class
Gallio.Framework.Formatting Namespace


Properties

Formatter Properties
[image]

Public Properties

Name | Description
Instance | Gets the global formatter singleton.
Top

See Also

Formatter Class
Gallio.Framework.Formatting Namespace


Instance Property

Formatter.Instance Property
[image]

Gets the global formatter singleton.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As IFormatter
C#
public static IFormatter Instance { get; }
C++
public static property IFormatter Instance {
IFormatter get();
}
J#
/** property */
public IFormatter get_Instance();
JScript
public function get Instance() : IFormatter

See Also

Formatter Class
Gallio.Framework.Formatting Namespace


FormatterExtensions Class

FormatterExtensions Class
[image]

Extensions methods for formatting. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Module FormatterExtensions
C#
[ExtensionAttribute]
public static class FormatterExtensions
C++
[ExtensionAttribute]
ref class FormatterExtensions abstract sealed
J#
/** @attribute ExtensionAttribute() */
public final class FormatterExtensions
JScript
public
ExtensionAttribute
class FormatterExtensions

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.FormatterExtensions

See Also

FormatterExtensions Members
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


FormatterExtensions Members

FormatterExtensions Members
[image]

Extensions methods for formatting. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by FormatterExtensions.

Public Methods

Name | Description
Format | Overloaded. Formats an object using the default IFormatter.
Top

See Also

FormatterExtensions Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

FormatterExtensions Methods
[image]

Public Methods

Name | Description
Format | Overloaded. Formats an object using the default IFormatter.
Top

See Also

FormatterExtensions Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Format Method

FormatterExtensions.Format Method

Formats an object using the default IFormatter.

Overload List

Name | Description
Format (Object) | Formats an object using the default IFormatter.
Format (Object, IFormatter) | Formats an object using the specified IFormatter.

See Also

FormatterExtensions Class
Gallio.Framework.Formatting Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Format Method (Object)

FormatterExtensions.Format Method (Object)
See Also Example
[image]

Formats an object using the default IFormatter.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Format( _
ByVal obj As Object _
) As String
C#
[ExtensionAttribute]
public static string Format(
object obj
)
C++
[ExtensionAttribute]
public:
static String Format(
Object obj
)
J#
/** @attribute ExtensionAttribute() */
public static string Format(
object obj
)
JScript
public static

ExtensionAttribute
function Format(
obj : Object
) : String

Parameters

obj
The object to format

Return Value

The formatted object

See Also

FormatterExtensions Class
Gallio.Framework.Formatting Namespace
FormatterExtensions.Format Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Format Method (Object, IFormatter)

FormatterExtensions.Format Method (Object, IFormatter)
See Also Example
[image]

Formats an object using the specified IFormatter.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String
C#
[ExtensionAttribute]
public static string Format(
object obj,
IFormatter formatter
)
C++
[ExtensionAttribute]
public:
static String Format(
Object obj,
IFormatter formatter
)
J#
/** @attribute ExtensionAttribute() */
public static string Format(
object obj,
IFormatter formatter
)
JScript
public static

ExtensionAttribute
function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format
formatter
The formatter to use, or null for the default

Return Value

The formatted object

See Also

FormatterExtensions Class
Gallio.Framework.Formatting Namespace
FormatterExtensions.Format Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


FormattingRulePriority Class

FormattingRulePriority Class
See Also Example Members
[image]

Typical IFormattingRule priority values to use as guidelines. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module FormattingRulePriority
C#
public static class FormattingRulePriority
C++
ref class FormattingRulePriority abstract sealed
J#
public final class FormattingRulePriority
JScript
public class FormattingRulePriority

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.FormattingRulePriority

See Also

FormattingRulePriority Members
Gallio.Framework.Formatting Namespace


FormattingRulePriority Members

FormattingRulePriority Members
See Also Example Fields
[image]

Typical IFormattingRule priority values to use as guidelines. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by FormattingRulePriority.

Public Fields

Name | Description
Best | The best possible formatting rule priority. A rule with this priority will override all other matching rules. This field is constant and read-only.
Better | A better than typical rule. This value should be used for cases where the typical rule is not quite precise enough. This field is constant and read-only.
Default | The default formatting rule priority. A rule with this priority will be overridden by all other matching rules. This field is constant and read-only.
Fallback | Fallback rule priority. Represents a rule to be applied if the typical case fails. This field is constant and read-only.
Generic | Generic rule priority. Represents a generic rule that can represent objects of any type structurally. This field is constant and read-only.
Typical | Typical rule priority. This is a good starting point for rule priorities. This field is constant and read-only.
Top

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Fields

FormattingRulePriority Fields
[image]

Public Fields

Name | Description
Best | The best possible formatting rule priority. A rule with this priority will override all other matching rules. This field is constant and read-only.
Better | A better than typical rule. This value should be used for cases where the typical rule is not quite precise enough. This field is constant and read-only.
Default | The default formatting rule priority. A rule with this priority will be overridden by all other matching rules. This field is constant and read-only.
Fallback | Fallback rule priority. Represents a rule to be applied if the typical case fails. This field is constant and read-only.
Generic | Generic rule priority. Represents a generic rule that can represent objects of any type structurally. This field is constant and read-only.
Typical | Typical rule priority. This is a good starting point for rule priorities. This field is constant and read-only.
Top

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Best Field

FormattingRulePriority.Best Field
[image]

The best possible formatting rule priority. A rule with this priority will override all other matching rules. This field is constant and read-only.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Best As Integer = 2147483647
C#
public const int Best = 2147483647;
C++
public:
const int Best = 2147483647;
J#
public const int Best = 2147483647
JScript
public const Best : int = 2147483647;

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Better Field

FormattingRulePriority.Better Field
[image]

A better than typical rule. This value should be used for cases where the typical rule is not quite precise enough. This field is constant and read-only.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Better As Integer = 10
C#
public const int Better = 10;
C++
public:
const int Better = 10;
J#
public const int Better = 10
JScript
public const Better : int = 10;

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Default Field

FormattingRulePriority.Default Field
[image]

The default formatting rule priority. A rule with this priority will be overridden by all other matching rules. This field is constant and read-only.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Default As Integer = -2147483648
C#
public const int Default = -2147483648;
C++
public:
const int Default = -2147483648;
J#
public const int Default = -2147483648
JScript
public const Default : int = -2147483648;

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Fallback Field

FormattingRulePriority.Fallback Field
[image]

Fallback rule priority. Represents a rule to be applied if the typical case fails. This field is constant and read-only.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Fallback As Integer = -10
C#
public const int Fallback = -10;
C++
public:
const int Fallback = -10;
J#
public const int Fallback = -10
JScript
public const Fallback : int = -10;

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Generic Field

FormattingRulePriority.Generic Field
[image]

Generic rule priority. Represents a generic rule that can represent objects of any type structurally. This field is constant and read-only.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Generic As Integer = -20
C#
public const int Generic = -20;
C++
public:
const int Generic = -20;
J#
public const int Generic = -20
JScript
public const Generic : int = -20;

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


Typical Field

FormattingRulePriority.Typical Field
[image]

Typical rule priority. This is a good starting point for rule priorities. This field is constant and read-only.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Typical As Integer = 0
C#
public const int Typical = 0;
C++
public:
const int Typical = 0;
J#
public const int Typical = 0
JScript
public const Typical : int = 0;

See Also

FormattingRulePriority Class
Gallio.Framework.Formatting Namespace


IFormatter Interface

IFormatter Interface
See Also Example Members
[image]

Provides services for formatting objects for display.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFormatter
C#
public interface IFormatter
C++
interface class IFormatter
J#
public interface IFormatter
JScript
public interface IFormatter

Types that implement IFormatter

Type | Description
Gallio.Framework.Formatting.RuleBasedFormatter | A rule-based formatter uses a set of IFormattingRules to format values appropriately.

See Also

IFormatter Members
Gallio.Framework.Formatting Namespace


IFormatter Members

IFormatter Members
See Also Example Methods
[image]

Provides services for formatting objects for display.

The following tables list the members exposed by IFormatter.

Public Methods

 | Name | Description
Public method | Format | Formats an object to a string for display.
Top

See Also

IFormatter Interface
Gallio.Framework.Formatting Namespace


Methods

IFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Format | Formats an object to a string for display.
Top

See Also

IFormatter Interface
Gallio.Framework.Formatting Namespace


Format Method

IFormatter.Format Method
[image]

Formats an object to a string for display.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Format( _
ByVal obj As Object _
) As String
C#
string Format(
object obj
)
C++
String Format(
Object obj
) abstract
J#
string Format(
object obj
)
JScript
function Format(
obj : Object
) : String

Parameters

obj
The object to format, may be null

Return Value

The formatted string, never null and never an empty string

Remarks

The formatted string may incorporate a variety of presentation techniques intended to clearly identify formatted values of different types. For example, strings might appear quoted, objects might be described using ToString or in terms of their properties, collections might be listed as sequences of formatted elements.

The resulting string should not be expected to be machine-readable.

This method should never return an empty string or throw an exception. If the value cannot be formatted property then a placeholder should be used instead, such as the value's type.

Likewise this method should never throw an exception. If the object cannot be formatted cleanly, then an error message should be produced instead.

These constraints are intended to ensure that the formatter provides a robust service to all clients.

See Also

IFormatter Interface
Gallio.Framework.Formatting Namespace


IFormattingRule Interface

IFormattingRule Interface
See Also Example Members
[image]

A formatting rule encapsulates an algorithm for formatting values of particular types to strings for presentation.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFormattingRule
C#
public interface IFormattingRule
C++
interface class IFormattingRule
J#
public interface IFormattingRule
JScript
public interface IFormattingRule

Types that implement IFormattingRule

Type | Description
Gallio.Framework.Formatting.BooleanFormattingRule

A formatting rule for Boolean.

Formats values as "true" or "false".

This class cannot be inherited.
Gallio.Framework.Formatting.ByteFormattingRule

A formatting rule for Byte.

Formats values as two digit hex values like "0xa5".

This class cannot be inherited.
Gallio.Framework.Formatting.CharFormattingRule

A formatting rule for Char.

Formats values as literals like: "'x'" or "'\n'".

This class cannot be inherited.
Gallio.Framework.Formatting.ConvertToStringFormattingRule | A default formatting rule for objects based on using the IConverter to convert the value to a string. This rule has minimum priority so that all other formatting rules should override it in principle. This class cannot be inherited.
Gallio.Framework.Formatting.DateTimeFormattingRule

A formatting rule for DateTime.

Formats values in the invariant round-trip format like: "yyyy'-'MM'-'dd'T'HH':'mm':'ss'.'fffffffzz".

This class cannot be inherited.
Gallio.Framework.Formatting.DBNullFormattingRule

A formatting rule for DBNull.

Formats values as "dbnull".

This class cannot be inherited.
Gallio.Framework.Formatting.DecimalFormattingRule

A formatting rule for Decimal.

Formats values like: "5.6m".

This class cannot be inherited.
Gallio.Framework.Formatting.DictionaryEntryFormattingRule

A formatting rule for DictionaryEntry.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.
Gallio.Framework.Formatting.DoubleFormattingRule

A formatting rule for Double.

Formats values like: "5.6".

This class cannot be inherited.
Gallio.Framework.Formatting.EnumerableFormattingRule

A formatting rule for IEnumerable.

Formats values as "[1, 2, 3]".

This class cannot be inherited.
Gallio.Framework.Formatting.ExpressionFormattingRule

A formatting rule for Expression.

Formats expression trees using a more familiar C#-like syntax than the default. Also recognizes captured variables and displays them naturally to conceal the implied field access to an anonymous class.

Made-up syntax for nodes that cannot be directly represented in C#.

  • Power operator: **, as in a ** b
  • Quote expression: `...`, as in `a + b`
  • Constants: formatted recursively using other formatters, which may yield unusual syntax

This class cannot be inherited.
Gallio.Framework.Formatting.IntegerFormattingRule

A formatting rule for Int16, Int32, Int64, UInt16, UInt32, and UInt64.

Formats values like: "5", "123", "-12".

This class cannot be inherited.
Gallio.Framework.Formatting.KeyValuePairFormattingRule

A formatting rule for KeyValuePair.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.
Gallio.Framework.Formatting.SByteFormattingRule

A formatting rule for SByte.

Formats values as two digit signed hex values like "0x55" and "-0x55".

This class cannot be inherited.
Gallio.Framework.Formatting.SingleFormattingRule

A formatting rule for Single.

Formats values like: "5.6f".

This class cannot be inherited.
Gallio.Framework.Formatting.StringFormattingRule

A formatting rule for String.

Formats values as literals like: ""abc\ndef"".

This class cannot be inherited.
Gallio.Framework.Formatting.StructuralFormattingRule | A formatting rule that describes the structure of objects in terms of their constituent properties and fields.
Gallio.Framework.Formatting.TypeFormattingRule

A formatting rule for Type.

Formats values like: string, MyType.Nested, int[], byte*, similar to C#.

This class cannot be inherited.
Gallio.Framework.Formatting.XPathNavigableFormattingRule

A formatting rule for IXPathNavigable.

Formats values as "<root />".

This class cannot be inherited.

Remarks

This type is not intended to be used directly by clients. Instead refer to IFormatter for a simpler abstraction that wraps IFormattingRule.

See Also

IFormattingRule Members
Gallio.Framework.Formatting Namespace


IFormattingRule Members

IFormattingRule Members
See Also Example Methods
[image]

A formatting rule encapsulates an algorithm for formatting values of particular types to strings for presentation.

The following tables list the members exposed by IFormattingRule.

Public Methods

 | Name | Description
Public method | Format | Formats the specified object.
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Top

See Also

IFormattingRule Interface
Gallio.Framework.Formatting Namespace


Methods

IFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Format | Formats the specified object.
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Top

See Also

IFormattingRule Interface
Gallio.Framework.Formatting Namespace


Format Method

IFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String
C#
string Format(
object obj,
IFormatter formatter
)
C++
String Format(
Object obj,
IFormatter formatter
) abstract
J#
string Format(
object obj,
IFormatter formatter
)
JScript
function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Remarks

Exceptions thrown by this method will not be reported to clients. Instead the formatter will substitute an appropriate placeholder string instead.

See Also

IFormattingRule Interface
Gallio.Framework.Formatting Namespace


GetPriority Method

IFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer)
C#
Nullable<int> GetPriority(
Type type
)
C++
Nullable<int> GetPriority(
Type type
) abstract
J#
Nullable<int> GetPriority(
Type type
)
JScript
function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Remarks

A typical

See Also

IFormattingRule Interface
Gallio.Framework.Formatting Namespace
FormattingRulePriority


IntegerFormattingRule Class

IntegerFormattingRule Class
See Also Example Members
[image]

A formatting rule for Int16, Int32, Int64, UInt16, UInt32, and UInt64.

Formats values like: "5", "123", "-12".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IntegerFormattingRule
Implements IFormattingRule
C#
public sealed class IntegerFormattingRule : IFormattingRule
C++
ref class IntegerFormattingRule sealed : IFormattingRule
J#
public final class IntegerFormattingRule implements IFormattingRule
JScript
public final class IntegerFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.IntegerFormattingRule

See Also

IntegerFormattingRule Members
Gallio.Framework.Formatting Namespace


IntegerFormattingRule Members

IntegerFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Int16, Int32, Int64, UInt16, UInt32, and UInt64.

Formats values like: "5", "123", "-12".

This class cannot be inherited.

The following tables list the members exposed by IntegerFormattingRule.

Public Constructors

 | Name | Description
Public method | IntegerFormattingRule | Initializes a new instance of the IntegerFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

IntegerFormattingRule Class
Gallio.Framework.Formatting Namespace


IntegerFormattingRule Constructor

IntegerFormattingRule Constructor
[image]

Initializes a new instance of the IntegerFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public IntegerFormattingRule()
C++
public:
IntegerFormattingRule() sealed
J#
public IntegerFormattingRule()
JScript
public function IntegerFormattingRule()

See Also

IntegerFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

IntegerFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

IntegerFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

IntegerFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

IntegerFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

IntegerFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

IntegerFormattingRule Class
Gallio.Framework.Formatting Namespace


KeyValuePairFormattingRule Class

KeyValuePairFormattingRule Class
See Also Example Members
[image]

A formatting rule for KeyValuePair.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class KeyValuePairFormattingRule
Implements IFormattingRule
C#
public sealed class KeyValuePairFormattingRule : IFormattingRule
C++
ref class KeyValuePairFormattingRule sealed : IFormattingRule
J#
public final class KeyValuePairFormattingRule implements IFormattingRule
JScript
public final class KeyValuePairFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.KeyValuePairFormattingRule

See Also

KeyValuePairFormattingRule Members
Gallio.Framework.Formatting Namespace


KeyValuePairFormattingRule Members

KeyValuePairFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for KeyValuePair.

Formats values as "\"key\": \"value\"".

This class cannot be inherited.

The following tables list the members exposed by KeyValuePairFormattingRule.

Public Constructors

 | Name | Description
Public method | KeyValuePairFormattingRule | Initializes a new instance of the KeyValuePairFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

KeyValuePairFormattingRule Class
Gallio.Framework.Formatting Namespace


KeyValuePairFormattingRule Constructor

KeyValuePairFormattingRule Constructor
[image]

Initializes a new instance of the KeyValuePairFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public KeyValuePairFormattingRule()
C++
public:
KeyValuePairFormattingRule() sealed
J#
public KeyValuePairFormattingRule()
JScript
public function KeyValuePairFormattingRule()

See Also

KeyValuePairFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

KeyValuePairFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

KeyValuePairFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

KeyValuePairFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

KeyValuePairFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

KeyValuePairFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

KeyValuePairFormattingRule Class
Gallio.Framework.Formatting Namespace


RuleBasedFormatter Class

RuleBasedFormatter Class
See Also Example Members
[image]

A rule-based formatter uses a set of IFormattingRules to format values appropriately.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RuleBasedFormatter
Implements IFormatter
C#
public class RuleBasedFormatter : IFormatter
C++
ref class RuleBasedFormatter : IFormatter
J#
public class RuleBasedFormatter implements IFormatter
JScript
public class RuleBasedFormatter extends IFormatter

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.RuleBasedFormatter
Gallio.Framework.Formatting.StubFormatter

See Also

RuleBasedFormatter Members
Gallio.Framework.Formatting Namespace


RuleBasedFormatter Members

RuleBasedFormatter Members
See Also Example Constructors Methods
[image]

A rule-based formatter uses a set of IFormattingRules to format values appropriately.

The following tables list the members exposed by RuleBasedFormatter.

Public Constructors

 | Name | Description
Public method | RuleBasedFormatter | Creates a rule-based formatter.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats an object to a string for display.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuleBasedFormatter Class
Gallio.Framework.Formatting Namespace


RuleBasedFormatter Constructor

RuleBasedFormatter Constructor
[image]

Creates a rule-based formatter.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal rules As IFormattingRule() _
)
C#
public RuleBasedFormatter(
IFormattingRule[] rules
)
C++
public:
RuleBasedFormatter(
array<IFormattingRule>^ rules
) sealed
J#
public RuleBasedFormatter(
IFormattingRule[] rules
)
JScript
public function RuleBasedFormatter(
rules : IFormattingRule[]
)

Parameters

rules
The rules to use

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if rules is null

See Also

RuleBasedFormatter Class
Gallio.Framework.Formatting Namespace


Methods

RuleBasedFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats an object to a string for display.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuleBasedFormatter Class
Gallio.Framework.Formatting Namespace


Format Method

RuleBasedFormatter.Format Method
[image]

Formats an object to a string for display.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object _
) As String _
Implements IFormatter.Format
C#
public string Format(
object obj
)
C++
public:
String Format(
Object obj
) sealed
J#
public string Format(
object obj
)
JScript
public function Format(
obj : Object
) : String

Parameters

obj
The object to format, may be null

Return Value

The formatted string, never null and never an empty string

Implements

IFormatter.Format

See Also

RuleBasedFormatter Class
Gallio.Framework.Formatting Namespace


SByteFormattingRule Class

SByteFormattingRule Class
See Also Example Members
[image]

A formatting rule for SByte.

Formats values as two digit signed hex values like "0x55" and "-0x55".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SByteFormattingRule
Implements IFormattingRule
C#
public sealed class SByteFormattingRule : IFormattingRule
C++
ref class SByteFormattingRule sealed : IFormattingRule
J#
public final class SByteFormattingRule implements IFormattingRule
JScript
public final class SByteFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.SByteFormattingRule

See Also

SByteFormattingRule Members
Gallio.Framework.Formatting Namespace


SByteFormattingRule Members

SByteFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for SByte.

Formats values as two digit signed hex values like "0x55" and "-0x55".

This class cannot be inherited.

The following tables list the members exposed by SByteFormattingRule.

Public Constructors

 | Name | Description
Public method | SByteFormattingRule | Initializes a new instance of the SByteFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SByteFormattingRule Class
Gallio.Framework.Formatting Namespace


SByteFormattingRule Constructor

SByteFormattingRule Constructor
[image]

Initializes a new instance of the SByteFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SByteFormattingRule()
C++
public:
SByteFormattingRule() sealed
J#
public SByteFormattingRule()
JScript
public function SByteFormattingRule()

See Also

SByteFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

SByteFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SByteFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

SByteFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

SByteFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

SByteFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

SByteFormattingRule Class
Gallio.Framework.Formatting Namespace


SingleFormattingRule Class

SingleFormattingRule Class
See Also Example Members
[image]

A formatting rule for Single.

Formats values like: "5.6f".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SingleFormattingRule
Implements IFormattingRule
C#
public sealed class SingleFormattingRule : IFormattingRule
C++
ref class SingleFormattingRule sealed : IFormattingRule
J#
public final class SingleFormattingRule implements IFormattingRule
JScript
public final class SingleFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.SingleFormattingRule

See Also

SingleFormattingRule Members
Gallio.Framework.Formatting Namespace


SingleFormattingRule Members

SingleFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Single.

Formats values like: "5.6f".

This class cannot be inherited.

The following tables list the members exposed by SingleFormattingRule.

Public Constructors

 | Name | Description
Public method | SingleFormattingRule | Initializes a new instance of the SingleFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SingleFormattingRule Class
Gallio.Framework.Formatting Namespace


SingleFormattingRule Constructor

SingleFormattingRule Constructor
[image]

Initializes a new instance of the SingleFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SingleFormattingRule()
C++
public:
SingleFormattingRule() sealed
J#
public SingleFormattingRule()
JScript
public function SingleFormattingRule()

See Also

SingleFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

SingleFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SingleFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

SingleFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

SingleFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

SingleFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

SingleFormattingRule Class
Gallio.Framework.Formatting Namespace


StringFormattingRule Class

StringFormattingRule Class
See Also Example Members
[image]

A formatting rule for String.

Formats values as literals like: ""abc\ndef"".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StringFormattingRule
Implements IFormattingRule
C#
public sealed class StringFormattingRule : IFormattingRule
C++
ref class StringFormattingRule sealed : IFormattingRule
J#
public final class StringFormattingRule implements IFormattingRule
JScript
public final class StringFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.StringFormattingRule

See Also

StringFormattingRule Members
Gallio.Framework.Formatting Namespace


StringFormattingRule Members

StringFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for String.

Formats values as literals like: ""abc\ndef"".

This class cannot be inherited.

The following tables list the members exposed by StringFormattingRule.

Public Constructors

 | Name | Description
Public method | StringFormattingRule | Initializes a new instance of the StringFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StringFormattingRule Class
Gallio.Framework.Formatting Namespace


StringFormattingRule Constructor

StringFormattingRule Constructor
[image]

Initializes a new instance of the StringFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StringFormattingRule()
C++
public:
StringFormattingRule() sealed
J#
public StringFormattingRule()
JScript
public function StringFormattingRule()

See Also

StringFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

StringFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StringFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

StringFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

StringFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

StringFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

StringFormattingRule Class
Gallio.Framework.Formatting Namespace


StructuralFormattingRule Class

StructuralFormattingRule Class
See Also Example Members
[image]

A formatting rule that describes the structure of objects in terms of their constituent properties and fields.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class StructuralFormattingRule
Implements IFormattingRule
C#
public class StructuralFormattingRule : IFormattingRule
C++
ref class StructuralFormattingRule : IFormattingRule
J#
public class StructuralFormattingRule implements IFormattingRule
JScript
public class StructuralFormattingRule extends IFormattingRule

Remarks

Describes the object using a format similar to a C# property initializer syntax.

{Foo.SomeType: Property = "Value", Field = "Other value"}

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.StructuralFormattingRule

See Also

StructuralFormattingRule Members
Gallio.Framework.Formatting Namespace


StructuralFormattingRule Members

StructuralFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule that describes the structure of objects in terms of their constituent properties and fields.

The following tables list the members exposed by StructuralFormattingRule.

Public Constructors

 | Name | Description
Public method | StructuralFormattingRule | Initializes a new instance of the StructuralFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StructuralFormattingRule Class
Gallio.Framework.Formatting Namespace


StructuralFormattingRule Constructor

StructuralFormattingRule Constructor
[image]

Initializes a new instance of the StructuralFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StructuralFormattingRule()
C++
public:
StructuralFormattingRule() sealed
J#
public StructuralFormattingRule()
JScript
public function StructuralFormattingRule()

See Also

StructuralFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

StructuralFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StructuralFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

StructuralFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

StructuralFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

StructuralFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

StructuralFormattingRule Class
Gallio.Framework.Formatting Namespace


StubFormatter Class

StubFormatter Class
See Also Example Members
[image]

A formatter that is used when the runtime is not initialized.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class StubFormatter
Inherits RuleBasedFormatter
C#
public class StubFormatter : RuleBasedFormatter
C++
ref class StubFormatter : RuleBasedFormatter
J#
public class StubFormatter extends RuleBasedFormatter
JScript
public class StubFormatter extends RuleBasedFormatter

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.RuleBasedFormatter
Gallio.Framework.Formatting.StubFormatter

See Also

StubFormatter Members
Gallio.Framework.Formatting Namespace


StubFormatter Members

StubFormatter Members
See Also Example Constructors Methods
[image]

A formatter that is used when the runtime is not initialized.

The following tables list the members exposed by StubFormatter.

Public Constructors

 | Name | Description
Public method | StubFormatter | Creates a stub formatter using only a few built-in formatting rules.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats an object to a string for display. (inherited from RuleBasedFormatter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StubFormatter Class
Gallio.Framework.Formatting Namespace


StubFormatter Constructor

StubFormatter Constructor
[image]

Creates a stub formatter using only a few built-in formatting rules.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StubFormatter()
C++
public:
StubFormatter() sealed
J#
public StubFormatter()
JScript
public function StubFormatter()

See Also

StubFormatter Class
Gallio.Framework.Formatting Namespace


TypeFormattingRule Class

TypeFormattingRule Class
See Also Example Members
[image]

A formatting rule for Type.

Formats values like: string, MyType.Nested, int[], byte*, similar to C#.

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TypeFormattingRule
Implements IFormattingRule
C#
public sealed class TypeFormattingRule : IFormattingRule
C++
ref class TypeFormattingRule sealed : IFormattingRule
J#
public final class TypeFormattingRule implements IFormattingRule
JScript
public final class TypeFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.TypeFormattingRule

See Also

TypeFormattingRule Members
Gallio.Framework.Formatting Namespace


TypeFormattingRule Members

TypeFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for Type.

Formats values like: string, MyType.Nested, int[], byte*, similar to C#.

This class cannot be inherited.

The following tables list the members exposed by TypeFormattingRule.

Public Constructors

 | Name | Description
Public method | TypeFormattingRule | Initializes a new instance of the TypeFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TypeFormattingRule Class
Gallio.Framework.Formatting Namespace


TypeFormattingRule Constructor

TypeFormattingRule Constructor
[image]

Initializes a new instance of the TypeFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TypeFormattingRule()
C++
public:
TypeFormattingRule() sealed
J#
public TypeFormattingRule()
JScript
public function TypeFormattingRule()

See Also

TypeFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

TypeFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TypeFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

TypeFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

TypeFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

TypeFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

TypeFormattingRule Class
Gallio.Framework.Formatting Namespace


XPathNavigableFormattingRule Class

XPathNavigableFormattingRule Class
See Also Example Members
[image]

A formatting rule for IXPathNavigable.

Formats values as "<root />".

This class cannot be inherited.
Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XPathNavigableFormattingRule
Implements IFormattingRule
C#
public sealed class XPathNavigableFormattingRule : IFormattingRule
C++
ref class XPathNavigableFormattingRule sealed : IFormattingRule
J#
public final class XPathNavigableFormattingRule implements IFormattingRule
JScript
public final class XPathNavigableFormattingRule extends IFormattingRule

Inheritance Hierarchy

System.Object
Gallio.Framework.Formatting.XPathNavigableFormattingRule

See Also

XPathNavigableFormattingRule Members
Gallio.Framework.Formatting Namespace


XPathNavigableFormattingRule Members

XPathNavigableFormattingRule Members
See Also Example Constructors Methods
[image]

A formatting rule for IXPathNavigable.

Formats values as "<root />".

This class cannot be inherited.

The following tables list the members exposed by XPathNavigableFormattingRule.

Public Constructors

 | Name | Description
Public method | XPathNavigableFormattingRule | Initializes a new instance of the XPathNavigableFormattingRule class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigableFormattingRule Class
Gallio.Framework.Formatting Namespace


XPathNavigableFormattingRule Constructor

XPathNavigableFormattingRule Constructor
[image]

Initializes a new instance of the XPathNavigableFormattingRule class.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XPathNavigableFormattingRule()
C++
public:
XPathNavigableFormattingRule() sealed
J#
public XPathNavigableFormattingRule()
JScript
public function XPathNavigableFormattingRule()

See Also

XPathNavigableFormattingRule Class
Gallio.Framework.Formatting Namespace


Methods

XPathNavigableFormattingRule Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPriority | Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XPathNavigableFormattingRule Class
Gallio.Framework.Formatting Namespace


Format Method

XPathNavigableFormattingRule.Format Method
[image]

Formats the specified object.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Format( _
ByVal obj As Object, _
ByVal formatter As IFormatter _
) As String _
Implements IFormattingRule.Format
C#
public string Format(
object obj,
IFormatter formatter
)
C++
public:
String Format(
Object obj,
IFormatter formatter
) sealed
J#
public string Format(
object obj,
IFormatter formatter
)
JScript
public function Format(
obj : Object,
formatter : IFormatter
) : String

Parameters

obj
The object to format, never null
formatter
The formatter to use for recursive formatting, never null

Return Value

The formatted string representation of the object or null if the object could not be formatted to produce a non-empty string

Implements

IFormattingRule.Format

See Also

XPathNavigableFormattingRule Class
Gallio.Framework.Formatting Namespace


GetPriority Method

XPathNavigableFormattingRule.GetPriority Method
[image]

Gets the formatting rule's priority for object of the specified type. Rules with higher priority values take precedence over rules with lower priority values.

Namespace: Gallio.Framework.Formatting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPriority( _
ByVal type As Type _
) As Nullable(Of Integer) _
Implements IFormattingRule.GetPriority
C#
public Nullable<int> GetPriority(
Type type
)
C++
public:
Nullable<int> GetPriority(
Type type
) sealed
J#
public Nullable<int> GetPriority(
Type type
)
JScript
public function GetPriority(
type : Type
) : Nullable<int>

Parameters

type
The type of object, never null

Return Value

The priority of this rule, or null if the rule does not support formatting the specified object type

Implements

IFormattingRule.GetPriority

See Also

XPathNavigableFormattingRule Class
Gallio.Framework.Formatting Namespace


Gallio.Framework.Pattern

Gallio.Framework.Pattern Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class AnnotationPatternAttribute

Associates an annotation message with a code element. When the code element is processed as part of building some other test, the annotation message will be emitted. This may be used to signal error, warning, and informational messages associated with the code element in question.

Many annotations are automatically generated by the framework. For example, improperly used attributes generally cause error annotations to be emitted. This attribute provides an easy way for test authors to leverage the annotation mechanism for other discretionary purposes where it is desirable to draw attention to a particular code element.

Note that the annotation will only be emitted if it is encountered during the process of building a test. If for some reason the annotated code element is not processed, then the attribute will have no effect.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseBuilder | Abstract base class for typical builder implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BasePattern | Abstract base implementation of IPattern with do-nothing implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BasePatternTestFrameworkExtension | A base implementation of IPatternTestFrameworkExtension that does nothing.
Public class | BaseTestComponentBuilder | Abstract base class for test component builders. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | ContributionMethodPatternAttribute | A contribution method pattern attribute applies decorations to a containing scope such as by introducing a new setup or teardown action to a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class DataPatternAttribute

The data pattern attribute applies a data source to a fixture or test parameter declaratively. It can be attached to a fixture class, a public property or field of a fixture, a test method or a test method parameter. When attached to a property or field of a fixture, implies that the property or field is a fixture parameter (so the TestParameterPatternAttribute may be omitted).

The order in which items contributed by a data pattern attribute are use can be controlled via the Order property. The contents of data sets with lower order indices are processed before those with higher indices.

Copy Code
            // Ensures that the rows are processed in exactly the order they appear.
            [Test]
            [Row(1, "a"), Order=1)]
            [Row(2, "b"), Order=2)]
            [Row(3, "c"), Order=3)]
            public void Test(int x, string y) { ... }
This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | DeclarativePatternResolver | A declarative pattern resolver based on PatternAttribute. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class DecoratorPatternAttribute

A decorator attribute applies contributions to a test component in scope such as a test or test parameter generated by some other pattern attribute.

Occasionally the order in which decorators are applied is significant so this type provides a Order property to specify an explicit ordering when required. All decorators that apply to a given test component declaration are applied in increasing Order.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | DefaultPatternEvaluator | Default implementation of a pattern evaluator.
Public class | DefaultPatternScope | Default implementation of a pattern scope.
Public class | DefaultTestBuilder | Default implementation of a test model builder.
Public class | DefaultTestDataContextBuilder | Default implementation of a test data context builder.
Public class | DefaultTestModelBuilder | Default implementation of a test model builder.
Public class | DefaultTestParameterBuilder | Default implementation of a test parameter builder.
Public class MetadataPatternAttribute

Applies declarative metadata to a test component.

A metadata attribute is similar to a decorator but more restrictive. Metadata does not modify the structure of a test directly. Instead it introduces additional metadata key / value pairs for classification, filtering, reporting, documentation or other purposes.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class PatternAttribute

The PatternAttribute class is the base class for all pattern test framework attributes. It associates a code element with a IPattern for building up parts of the test model using reflection.

Subclasses of IPattern define simpler interfaces for implementing the semantics of common types of attributes such as test factories, decorators, and data providers. Refer to the documentation of each subclass for details on its use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | PatternAttributeTargets | Standard AttributeTargets flag combinations for PatternAttribute declarations. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | PatternTest | A test case that has been defined by the PatternTestFramework.
Public class PatternTestActions

An implementation of IPatternTestHandler based on actions that can be sequenced and composed as chains.

This class is the backbone of the PatternTestFramework extensibility model. Because new behaviors can be defined and added to action chains at will by any component that participates in the test construction process (typically an IPattern), the framework itself does not need to hardcode the mechanism by which the behaviors are selected.

Public class | PatternTestController | Controls the execution of PatternTest instances.
Public class PatternTestDataContext

A pattern test data context introduces a scope for data source declarations.

Each PatternTest or PatternTestParameter has a PatternTestDataContext. However, data contexts may also be nested.

For example, the constructor of a test class typically augments its containing test with additional test parameters that represent its own constructor parameters. If data binding attributes are applied to the constructor, they should operate within the scope of that constructor only. To achieve this effect, the constructor declares a new PatternTestDataContext within which its test parameters will be created.

Public class | PatternTestExplorer | A test explorer for PatternTestFramework.
Public class PatternTestFramework

The pattern test framework is a built-in framework that Gallio provides based on reflection over attributes that implement IPattern.

The pattern test framework does not provide many attributes that end-users would use to write tests. The framework is intended to be extended by IPatternTestFrameworkExtension components and libraries that define the test syntax and other facilities.

For example, a Test-Driven framework would augment the base framework with a syntax based around test fixtures, test methods and assertions. A Behavior-Driven framework would instead use a syntax based around contexts and specifications. Both frameworks would share the common attribute-based model provided by the pattern test framework. They may even interoperate to a large extent.

Other add-on libraries and tools may further contribute functionality to the pattern test framework by registering components with the runtime or by subclassing pattern attributes.

Public class | PatternTestInstanceActions | An implementation of IPatternTestInstanceHandler based on actions that can be sequenced and composed as chains.
Public class PatternTestInstanceState

Represents the run-time state of a single instance of a PatternTest that is to be executed.

Typical lifecycle of PatternTestInstanceState:

  • The PatternTestController creates a PatternTestInstanceState for the instance of the PatternTest to be executed using particular data bindings.
  • The controller populates the instance state with slot values for each slot with an associated IDataAccessor in the PatternTestState.
  • The controller calls BeforeTestInstance to give test extensions the opportunity to modify the instance state.
  • The controller initializes, sets up, executes, tears down and disposes the test instance.
  • The controller calls AfterTestInstance to give test extensions the opportunity to clean up the instance state.
Public class | PatternTestParameter | Represents an parameter of a PatternTest derived from a field, property or method parameter.
Public class | PatternTestParameterActions | An implementation of IPatternTestParameterHandler based on actions that can be sequenced and composed as chains.
Public class PatternTestState

Represents the run-time state of a PatternTest that is to be executed.

Typical lifecycle of PatternTestState:

  • The PatternTestController creates a PatternTestState for the PatternTest to be executed.
  • The controller populates the test state with slot binding accessors for each PatternTestParameter associated with the test.
  • The controller calls BeforeTest to give test extensions the opportunity to modify the test state.
  • The controller begins iterating over the IDataItems produced by the state's BindingContext. For each item it constructs a PatternTestInstanceState and executes the test instance.
  • The controller calls AfterTest to give test extensions the opportunity to clean up the test state.
Public class | PatternTestStep | A step that belongs to a PatternTest.
Public class PatternUsageErrorException

The type of exception thrown when a test declaration is malformed or contains an error. Implementations of IPattern may use this exception to report that a pattern is malformed or not valid in the context in which it appears.

The exception effectively halts the processing of the pattern. The message text is then manifested as an error annotation that may be displayed to the user.

When you see this error, check to make sure that the syntax of the test is correct, all required parameters have been provided and they contain valid values.

Public class ProcessIsolation

The process isolation object saves global process-level context information when it is created and restores it when it is disposed.

The following context information is saved and restored:

  • The current working directory

This class cannot be inherited.
Public class | TestAssemblyDecoratorPatternAttribute | A test assembly decorator pattern attribute applies decorations to an existing test declared at the assembly-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestAssemblyExecutionParameters | Configures runtime parameters while executing tests within a test assembly. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class TestAssemblyInitializationAttribute

An assembly initialization attribute gets a chance to perform early initialization of the system before enumerating the tests within the assembly.

For examples, a subclass of this attribute may be used to register an assembly resolver before test enumeration occurs to ensure that all referenced assemblies can be loaded.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class TestAssemblyPatternAttribute

Declares that an assembly generates an assembly-level test. Subclasses of this attribute can customize how test enumeration takes place within the assembly.

At most one attribute of this type may appear on any given assembly.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class TestConstructorPatternAttribute

Declares that a constructor is used to provide test fixture parameters. Subclasses of this attribute can control what happens with the constructor.

At most one attribute of this type may appear on any given constructor.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestDecoratorPatternAttribute | A test decorator pattern attribute applies decorations to a test defined by an assembly, type, or method. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestDependencyPatternAttribute | A dependency pattern attribute creates a dependency on the tests defined by some other code element. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestMethodDecoratorPatternAttribute | A test decorator pattern attribute applies decorations to an existing test declared at the method-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestMethodPatternAttribute | Declares that a method represents a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestParameterDecoratorPatternAttribute | A test parameter decorator pattern attribute applies decorations to an existing PatternTestParameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class TestParameterPatternAttribute

Declares that a field, property, method parameter or generic parameter represents a PatternTestParameter. Subclasses of this attribute can control what happens with the parameter.

At most one attribute of this type may appear on any given property, field or parameter declaration.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestTypeDecoratorPatternAttribute | A test type decorator pattern attribute applies decorations to an existing test declared at the type-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestTypePatternAttribute | Declares that a type represents an test.
Public class | ToolInfo | Provides information about a tool that extends the PatternTestFramework. This class cannot be inherited.

Interfaces

Interface | Description
Public interface IPattern

A IPattern defines a composable rule for building up a test model using reflection.

The general idea is that a pattern applies contributions to a IPatternScope that represents the state of the pattern interpretation process. A primary pattern adds contributions to its containing scope with the Consume method. All patterns (primary and non-primary) add further contributions to the pattern's own scope with the Process method.

A pattern can also defer some of its processing by registering a decorator on the scope. Once all of the decorators have been gathered, they can be applied in sorted order as required.

Pattern processing is performed recursively. First the primary pattern for the assembly is found. If none is registered then the default assembly pattern is used instead. The assembly pattern then performs reflection over the types within the assembly and hands off control (via Consume) to any primary patterns it finds each type. Likewise the types scan their members and call into their primary patterns. And so on. Each primary pattern is responsible for invoking (via Process) any additional non-primary patterns associated with their code element after they have established the appropriate evaluation scope.

Typically a pattern is associated with a code element by means of a PatternAttribute but other associations are possible. Some patterns might define default rules for recursively processing code elements that do not have primary patterns of their own. Others might use means other than standard reflection to discover the patterns to be applied. The process is intended to be open and extensible.

Public interface | IPatternEvaluator | A pattern evaluator maintains state that is needed to interpret patterns. It is used by the PatternTestExplorer to populate a TestModel during test enumeration.
Public interface | IPatternResolver | The pattern resolver provides a means for obtaining the IPattern objects associated with an ICodeElementInfo.
Public interface | IPatternScope | A pattern scope describes the environment in which the pattern is being evaluated.
Public interface | IPatternTestComponent | An interface shared by PatternTest and PatternTestParameter.
Public interface | IPatternTestFrameworkExtension | A pattern test framework extension provides the opportunity to extend the standard pattern test framework with additional behaviors.
Public interface | IPatternTestHandler | A pattern test handler provides the logic that implements the various phases of the test execution lifecycle.
Public interface | IPatternTestInstanceHandler | A pattern test instance handler provides the logic that implements the various phases of the test instance execution lifecycle.
Public interface | IPatternTestParameterHandler | A pattern test parameter handler provides the logic that implements the various phases of the test parameter binding lifecycle.
Public interface | ISupportDeferredActions | Provides support for performing deferred build actions.
Public interface | ITestBuilder | A test builder applies contributions to a test under construction.
Public interface | ITestComponentBuilder | A test component builder applies contributions to a test or test parameter under construction.
Public interface | ITestDataContextBuilder | A test data context builder applies contributions to a test data context under construction.
Public interface | ITestModelBuilder | A test model builder applies contributions to a test model under construction.
Public interface | ITestParameterBuilder | A test builder applies contributions to a test under construction.

Delegates

 | Delegate | Description
Public delegate | DeferredComponentPopulator | Populates components lazily.
Public delegate | PatternTestPopulator | A delegate used to lazily populate the children of an PatternTest.
Public delegate | TestAction | Performs one primitive action of a test and returns its outcome.


AnnotationPatternAttribute Class

AnnotationPatternAttribute Class
See Also Example Members
[image]

Associates an annotation message with a code element. When the code element is processed as part of building some other test, the annotation message will be emitted. This may be used to signal error, warning, and informational messages associated with the code element in question.

Many annotations are automatically generated by the framework. For example, improperly used attributes generally cause error annotations to be emitted. This attribute provides an easy way for test authors to leverage the annotation mechanism for other discretionary purposes where it is desirable to draw attention to a particular code element.

Note that the annotation will only be emitted if it is encountered during the process of building a test. If for some reason the annotated code element is not processed, then the attribute will have no effect.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.All, AllowMultiple := True, Inherited := True)>
Public MustInherit Class AnnotationPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = True, Inherited = True)]
public abstract class AnnotationPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::All, AllowMultiple = True, Inherited = True)]
ref class AnnotationPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = True, Inherited = True) */
public class AnnotationPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = True, Inherited = True)
class AnnotationPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.AnnotationPatternAttribute
MbUnit.Framework.AnnotationAttribute

See Also

AnnotationPatternAttribute Members
Gallio.Framework.Pattern Namespace


AnnotationPatternAttribute Members

AnnotationPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

Associates an annotation message with a code element. When the code element is processed as part of building some other test, the annotation message will be emitted. This may be used to signal error, warning, and informational messages associated with the code element in question.

Many annotations are automatically generated by the framework. For example, improperly used attributes generally cause error annotations to be emitted. This attribute provides an easy way for test authors to leverage the annotation mechanism for other discretionary purposes where it is desirable to draw attention to a particular code element.

Note that the annotation will only be emitted if it is encountered during the process of building a test. If for some reason the annotated code element is not processed, then the attribute will have no effect.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AnnotationPatternAttribute.

Public Constructors

 | Name | Description
Public method | AnnotationPatternAttribute | Associates an annotation message of the specified type with the code element.
Top

Public Properties

Name | Description
Public property | Details | Gets or sets optional detail text of the annotation, or null if none.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets the annotation message.
Public property | Type | Gets the annotation type.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Top

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


AnnotationPatternAttribute Constructor

AnnotationPatternAttribute Constructor
[image]

Associates an annotation message of the specified type with the code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As AnnotationType, _
ByVal message As String _
)
C#
public AnnotationPatternAttribute(
AnnotationType type,
string message
)
C++
public:
AnnotationPatternAttribute(
AnnotationType type,
String message
) sealed
J#
public AnnotationPatternAttribute(
AnnotationType type,
string message
)
JScript
public function AnnotationPatternAttribute(
type : AnnotationType,
message : String
)

Parameters

type
The annotation type
message
The annotation message

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

AnnotationPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property | Details | Gets or sets optional detail text of the annotation, or null if none.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets the annotation message.
Public property | Type | Gets the annotation type.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


Details Property

AnnotationPatternAttribute.Details Property
[image]

Gets or sets optional detail text of the annotation, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Details As String
C#
public string Details { get; set; }
C++
public property string Details sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Details();

/** property */
public void set_Details(string value);
JScript
public function get Details() : String

public function set Details(value : String);

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


Message Property

AnnotationPatternAttribute.Message Property
[image]

Gets the annotation message.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
C++
public property string Message sealed {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


Type Property

AnnotationPatternAttribute.Type Property
[image]

Gets the annotation type.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As AnnotationType
C#
public AnnotationType Type { get; }
C++
public property AnnotationType Type sealed {
AnnotationType get();
}
J#
/** property */
public AnnotationType get_Type();
JScript
public function get Type() : AnnotationType

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

AnnotationPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Top

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

AnnotationPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

AnnotationPatternAttribute Class
Gallio.Framework.Pattern Namespace


BaseBuilder Class

BaseBuilder Class
See Also Example Members
[image]

Abstract base class for typical builder implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseBuilder
Implements ISupportDeferredActions
C#
public abstract class BaseBuilder : ISupportDeferredActions
C++
ref class BaseBuilder abstract : ISupportDeferredActions
J#
public class BaseBuilder implements ISupportDeferredActions
JScript
public class BaseBuilder extends ISupportDeferredActions

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BaseBuilder
Gallio.Framework.Pattern.BaseTestComponentBuilder
Gallio.Framework.Pattern.DefaultTestDataContextBuilder
Gallio.Framework.Pattern.DefaultTestModelBuilder

See Also

BaseBuilder Members
Gallio.Framework.Pattern Namespace


BaseBuilder Members

BaseBuilder Members
See Also Example Constructors Methods
[image]

Abstract base class for typical builder implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseBuilder.

Protected Constructors

 | Name | Description
Family method | BaseBuilder | Initializes a new instance of the BaseBuilder class.
Top

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called.
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseBuilder Class
Gallio.Framework.Pattern Namespace


BaseBuilder Constructor

BaseBuilder Constructor
[image]

Initializes a new instance of the BaseBuilder class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseBuilder()
C++
protected:
BaseBuilder() sealed
J#
protected BaseBuilder()
JScript
protected function BaseBuilder()

See Also

BaseBuilder Class
Gallio.Framework.Pattern Namespace


Methods

BaseBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called.
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseBuilder Class
Gallio.Framework.Pattern Namespace


AddDeferredAction Method

BaseBuilder.AddDeferredAction Method
[image]

Registers a deferred action to be performed when ApplyDeferredActions is called.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDeferredAction( _
ByVal codeElement As ICodeElementInfo, _
ByVal order As Integer, _
ByVal deferredAction As Action _
) _
Implements ISupportDeferredActions.AddDeferredAction
C#
public void AddDeferredAction(
ICodeElementInfo codeElement,
int order,
Action deferredAction
)
C++
public:
void AddDeferredAction(
ICodeElementInfo codeElement,
int order,
Action deferredAction
) sealed
J#
public void AddDeferredAction(
ICodeElementInfo codeElement,
int order,
Action deferredAction
)
JScript
public function AddDeferredAction(
codeElement : ICodeElementInfo,
order : int,
deferredAction : Action
)

Parameters

codeElement
The associated code element, used to report errors if the deferred action throws an exception
order
The order in which the action should be applied, from least order to greatest
deferredAction
The action to perform

Implements

ISupportDeferredActions.AddDeferredAction

See Also

BaseBuilder Class
Gallio.Framework.Pattern Namespace


ApplyDeferredActions Method

BaseBuilder.ApplyDeferredActions Method
[image]

Applies all pending deferred in order and clears the list.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ApplyDeferredActions() _
Implements ISupportDeferredActions.ApplyDeferredActions
C#
public void ApplyDeferredActions()
C++
public:
void ApplyDeferredActions() sealed
J#
public void ApplyDeferredActions()
JScript
public function ApplyDeferredActions()

Implements

ISupportDeferredActions.ApplyDeferredActions

See Also

BaseBuilder Class
Gallio.Framework.Pattern Namespace


GetTestModelBuilder Method

BaseBuilder.GetTestModelBuilder Method
[image]

Gets the test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTestModelBuilder() As ITestModelBuilder
C#
protected abstract ITestModelBuilder GetTestModelBuilder()
C++
protected:
ITestModelBuilder GetTestModelBuilder() abstract
J#
protected abstract ITestModelBuilder GetTestModelBuilder()
JScript
protected abstract function GetTestModelBuilder() : ITestModelBuilder

Return Value

The test model builder

See Also

BaseBuilder Class
Gallio.Framework.Pattern Namespace


BasePattern Class

BasePattern Class
See Also Example Members
[image]

Abstract base implementation of IPattern with do-nothing implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public MustInherit Class BasePattern
Implements IPattern
C#
[TestFrameworkInternalAttribute]
public abstract class BasePattern : IPattern
C++
[TestFrameworkInternalAttribute]
ref class BasePattern abstract : IPattern
J#
/** @attribute TestFrameworkInternalAttribute() */
public class BasePattern implements IPattern
JScript
public
TestFrameworkInternalAttribute
class BasePattern extends IPattern

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BasePattern

See Also

BasePattern Members
Gallio.Framework.Pattern Namespace


BasePattern Members

BasePattern Members
See Also Example Constructors Properties Methods
[image]

Abstract base implementation of IPattern with do-nothing implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BasePattern.

Protected Constructors

 | Name | Description
Family method | BasePattern | Initializes a new instance of the BasePattern class.
Top

Public Properties

Name Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


BasePattern Constructor

BasePattern Constructor
[image]

Initializes a new instance of the BasePattern class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BasePattern()
C++
protected:
BasePattern() sealed
J#
protected BasePattern()
JScript
protected function BasePattern()

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


Properties

BasePattern Properties
[image]

Public Properties

Name Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Top

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

BasePattern.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public virtual bool IsPrimary { get; }
C++
public virtual property bool IsPrimary {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


Methods

BasePattern Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


Consume Method

BasePattern.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
J#
public virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public virtual function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


IsTest Method

BasePattern.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTest
C#
public virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
J#
public virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public virtual function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTest

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


IsTestPart Method

BasePattern.IsTestPart Method
[image]

Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsTestPart( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTestPart
C#
public virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
J#
public virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public virtual function IsTestPart(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTestPart

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


Process Method

BasePattern.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
public virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public virtual function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

BasePattern Class
Gallio.Framework.Pattern Namespace


BasePatternTestFrameworkExtension Class

BasePatternTestFrameworkExtension Class
See Also Example Members
[image]

A base implementation of IPatternTestFrameworkExtension that does nothing.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BasePatternTestFrameworkExtension
Implements IPatternTestFrameworkExtension
C#
public class BasePatternTestFrameworkExtension : IPatternTestFrameworkExtension
C++
ref class BasePatternTestFrameworkExtension : IPatternTestFrameworkExtension
J#
public class BasePatternTestFrameworkExtension implements IPatternTestFrameworkExtension
JScript
public class BasePatternTestFrameworkExtension extends IPatternTestFrameworkExtension

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BasePatternTestFrameworkExtension
MbUnit.Core.MbUnitTestFrameworkExtension

See Also

BasePatternTestFrameworkExtension Members
Gallio.Framework.Pattern Namespace


BasePatternTestFrameworkExtension Members

BasePatternTestFrameworkExtension Members
See Also Example Constructors Methods
[image]

A base implementation of IPatternTestFrameworkExtension that does nothing.

The following tables list the members exposed by BasePatternTestFrameworkExtension.

Public Constructors

 | Name | Description
Public method | BasePatternTestFrameworkExtension | Initializes a new instance of the BasePatternTestFrameworkExtension class.
Top

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method GetReferencedTools

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BasePatternTestFrameworkExtension Class
Gallio.Framework.Pattern Namespace


BasePatternTestFrameworkExtension Constructor

BasePatternTestFrameworkExtension Constructor
[image]

Initializes a new instance of the BasePatternTestFrameworkExtension class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BasePatternTestFrameworkExtension()
C++
public:
BasePatternTestFrameworkExtension() sealed
J#
public BasePatternTestFrameworkExtension()
JScript
public function BasePatternTestFrameworkExtension()

See Also

BasePatternTestFrameworkExtension Class
Gallio.Framework.Pattern Namespace


Methods

BasePatternTestFrameworkExtension Methods
[image]

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method GetReferencedTools

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BasePatternTestFrameworkExtension Class
Gallio.Framework.Pattern Namespace


GetReferencedTools Method

BasePatternTestFrameworkExtension.GetReferencedTools Method
[image]

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetReferencedTools( _
ByVal assembly As IAssemblyInfo _
) As IEnumerable(Of ToolInfo) _
Implements IPatternTestFrameworkExtension.GetReferencedTools
C#
public virtual IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
C++
public:
virtual IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
J#
public virtual IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
JScript
public virtual function GetReferencedTools(
assembly : IAssemblyInfo
) : IEnumerable<ToolInfo>

Parameters

assembly
The test assembly

Return Value

The tool information

Implements

IPatternTestFrameworkExtension.GetReferencedTools

See Also

BasePatternTestFrameworkExtension Class
Gallio.Framework.Pattern Namespace


BaseTestComponentBuilder Class

BaseTestComponentBuilder Class
See Also Example Members
[image]

Abstract base class for test component builders. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTestComponentBuilder
Inherits BaseBuilder
Implements ITestComponentBuilder
C#
public abstract class BaseTestComponentBuilder : BaseBuilder, ITestComponentBuilder
C++
ref class BaseTestComponentBuilder abstract : BaseBuilder, ITestComponentBuilder
J#
public class BaseTestComponentBuilder extends BaseBuilder implements ITestComponentBuilder
JScript
public class BaseTestComponentBuilder extends BaseBuilder, ITestComponentBuilder

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BaseBuilder
Gallio.Framework.Pattern.BaseTestComponentBuilder
Gallio.Framework.Pattern.DefaultTestBuilder
Gallio.Framework.Pattern.DefaultTestParameterBuilder

See Also

BaseTestComponentBuilder Members
Gallio.Framework.Pattern Namespace


BaseTestComponentBuilder Members

BaseTestComponentBuilder Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for test component builders. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTestComponentBuilder.

Protected Constructors

 | Name | Description
Family method | BaseTestComponentBuilder | Creates a test component builder.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Name | Gets or sets the name of the component.
Top

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | AddMetadata | Adds a metadata key value pair.
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTestComponent | Gets the underlying test component.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestComponent | Gets the underlying test component.
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


BaseTestComponentBuilder Constructor

BaseTestComponentBuilder Constructor
[image]

Creates a test component builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal testModelBuilder As ITestModelBuilder _
)
C#
protected BaseTestComponentBuilder(
ITestModelBuilder testModelBuilder
)
C++
protected:
BaseTestComponentBuilder(
ITestModelBuilder testModelBuilder
) sealed
J#
protected BaseTestComponentBuilder(
ITestModelBuilder testModelBuilder
)
JScript
protected function BaseTestComponentBuilder(
testModelBuilder : ITestModelBuilder
)

Parameters

testModelBuilder
The associated test model builder

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModelBuilder is null

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


Properties

BaseTestComponentBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Name | Gets or sets the name of the component.
Top

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


CodeElement Property

BaseTestComponentBuilder.CodeElement Property
[image]

Gets a reference to the point of definition of this test component in the code, or null if unknown.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CodeElement As ICodeElementInfo _
Implements ITestComponentBuilder.CodeElement
C#
public ICodeElementInfo CodeElement { get; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

Implements

ITestComponentBuilder.CodeElement

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


Id Property

BaseTestComponentBuilder.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As String _
Implements ITestComponentBuilder.Id
C#
public string Id { get; }
C++
public property string Id sealed {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Implements

ITestComponentBuilder.Id

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


Name Property

BaseTestComponentBuilder.Name Property
[image]

Gets or sets the name of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String _
Implements ITestComponentBuilder.Name
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Implements

ITestComponentBuilder.Name

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


Methods

BaseTestComponentBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | AddMetadata | Adds a metadata key value pair.
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTestComponent | Gets the underlying test component.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestComponent | Gets the underlying test component.
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


AddMetadata Method

BaseTestComponentBuilder.AddMetadata Method
[image]

Adds a metadata key value pair.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMetadata( _
ByVal key As String, _
ByVal value As String _
) _
Implements ITestComponentBuilder.AddMetadata
C#
public void AddMetadata(
string key,
string value
)
C++
public:
void AddMetadata(
String key,
String value
) sealed
J#
public void AddMetadata(
string key,
string value
)
JScript
public function AddMetadata(
key : String,
value : String
)

Parameters

key
The metadata key
value
The value to add

Implements

ITestComponentBuilder.AddMetadata

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


GetTestComponent Method

BaseTestComponentBuilder.GetTestComponent Method
[image]

Gets the underlying test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTestComponent() As IPatternTestComponent
C#
protected abstract IPatternTestComponent GetTestComponent()
C++
protected:
IPatternTestComponent GetTestComponent() abstract
J#
protected abstract IPatternTestComponent GetTestComponent()
JScript
protected abstract function GetTestComponent() : IPatternTestComponent

Return Value

The test component

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


GetTestModelBuilder Method

BaseTestComponentBuilder.GetTestModelBuilder Method
[image]

Gets the test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetTestModelBuilder() As ITestModelBuilder
C#
protected ITestModelBuilder GetTestModelBuilder()
C++
protected:
ITestModelBuilder GetTestModelBuilder() sealed
J#
protected ITestModelBuilder GetTestModelBuilder()
JScript
protected function GetTestModelBuilder() : ITestModelBuilder

Return Value

The test model builder

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


ToTestComponent Method

BaseTestComponentBuilder.ToTestComponent Method
[image]

Gets the underlying test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToTestComponent() As IPatternTestComponent _
Implements ITestComponentBuilder.ToTestComponent
C#
public IPatternTestComponent ToTestComponent()
C++
public:
IPatternTestComponent ToTestComponent() sealed
J#
public IPatternTestComponent ToTestComponent()
JScript
public function ToTestComponent() : IPatternTestComponent

Return Value

The underlying test component

Implements

ITestComponentBuilder.ToTestComponent

See Also

BaseTestComponentBuilder Class
Gallio.Framework.Pattern Namespace


ContributionMethodPatternAttribute Class

ContributionMethodPatternAttribute Class
See Also Example Members
[image]

A contribution method pattern attribute applies decorations to a containing scope such as by introducing a new setup or teardown action to a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public MustInherit Class ContributionMethodPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public abstract class ContributionMethodPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class ContributionMethodPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class ContributionMethodPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class ContributionMethodPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
Derived types

See Also

ContributionMethodPatternAttribute Members
Gallio.Framework.Pattern Namespace


ContributionMethodPatternAttribute Members

ContributionMethodPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A contribution method pattern attribute applies decorations to a containing scope such as by introducing a new setup or teardown action to a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ContributionMethodPatternAttribute.

Protected Constructors

 | Name | Description
Family method | ContributionMethodPatternAttribute | Initializes a new instance of the ContributionMethodPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Overridden. Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


ContributionMethodPatternAttribute Constructor

ContributionMethodPatternAttribute Constructor
[image]

Initializes a new instance of the ContributionMethodPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected ContributionMethodPatternAttribute()
C++
protected:
ContributionMethodPatternAttribute() sealed
J#
protected ContributionMethodPatternAttribute()
JScript
protected function ContributionMethodPatternAttribute()

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

ContributionMethodPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

ContributionMethodPatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

ContributionMethodPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Overridden. Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Consume Method

ContributionMethodPatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


DecorateContainingScope Method

ContributionMethodPatternAttribute.DecorateContainingScope Method
See Also Example
[image]

Applies decorations to the containing test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DecorateContainingScope( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
J#
protected virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected virtual function DecorateContainingScope(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method to process

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTestPart Method

ContributionMethodPatternAttribute.IsTestPart Method
[image]

Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTestPart( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTestPart
C#
public override bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTestPart(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTestPart

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

ContributionMethodPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
)
J#
protected virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


DataPatternAttribute Class

DataPatternAttribute Class
See Also Example Members
[image]

The data pattern attribute applies a data source to a fixture or test parameter declaratively. It can be attached to a fixture class, a public property or field of a fixture, a test method or a test method parameter. When attached to a property or field of a fixture, implies that the property or field is a fixture parameter (so the TestParameterPatternAttribute may be omitted).

The order in which items contributed by a data pattern attribute are use can be controlled via the Order property. The contents of data sets with lower order indices are processed before those with higher indices.

Copy Code
            // Ensures that the rows are processed in exactly the order they appear.
            [Test]
            [Row(1, "a"), Order=1)]
            [Row(2, "b"), Order=2)]
            [Row(3, "c"), Order=3)]
            public void Test(int x, string y) { ... }
This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public MustInherit Class DataPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public abstract class DataPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class DataPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class DataPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class DataPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.ContentAttribute
MbUnit.Framework.DataAttribute
MbUnit.Framework.FactoryAttribute
MbUnit.Framework.HeaderAttribute

See Also

DataPatternAttribute Members
Gallio.Framework.Pattern Namespace


DataPatternAttribute Members

DataPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

The data pattern attribute applies a data source to a fixture or test parameter declaratively. It can be attached to a fixture class, a public property or field of a fixture, a test method or a test method parameter. When attached to a property or field of a fixture, implies that the property or field is a fixture parameter (so the TestParameterPatternAttribute may be omitted).

The order in which items contributed by a data pattern attribute are use can be controlled via the Order property. The contents of data sets with lower order indices are processed before those with higher indices.

Copy Code
            // Ensures that the rows are processed in exactly the order they appear.
            [Test]
            [Row(1, "a"), Order=1)]
            [Row(2, "b"), Order=2)]
            [Row(3, "c"), Order=3)]
            public void Test(int x, string y) { ... }
This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by DataPatternAttribute.

Protected Constructors

 | Name | Description
Family method | DataPatternAttribute | Initializes a new instance of the DataPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


DataPatternAttribute Constructor

DataPatternAttribute Constructor
[image]

Initializes a new instance of the DataPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected DataPatternAttribute()
C++
protected:
DataPatternAttribute() sealed
J#
protected DataPatternAttribute()
JScript
protected function DataPatternAttribute()

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

DataPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


SourceName Property

DataPatternAttribute.SourceName Property
[image]

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceName As String
C#
public string SourceName { get; set; }
C++
public property string SourceName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SourceName();

/** property */
public void set_SourceName(string value);
JScript
public function get SourceName() : String

public function set SourceName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

DataPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


PopulateDataSource Method

DataPatternAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
J#
protected virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected virtual function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

DataPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

DataPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

DataPatternAttribute Class
Gallio.Framework.Pattern Namespace


DeclarativePatternResolver Class

DeclarativePatternResolver Class
See Also Example Members
[image]

A declarative pattern resolver based on PatternAttribute. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DeclarativePatternResolver
Implements IPatternResolver
C#
public sealed class DeclarativePatternResolver : IPatternResolver
C++
ref class DeclarativePatternResolver sealed : IPatternResolver
J#
public final class DeclarativePatternResolver implements IPatternResolver
JScript
public final class DeclarativePatternResolver extends IPatternResolver

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.DeclarativePatternResolver

See Also

DeclarativePatternResolver Members
Gallio.Framework.Pattern Namespace


DeclarativePatternResolver Members

DeclarativePatternResolver Members
See Also Example Fields Methods
[image]

A declarative pattern resolver based on PatternAttribute. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by DeclarativePatternResolver.

Public Fields

Name | Description
Instance | Gets the singleton instance of the declarative pattern resolver. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPatterns | Gets the patterns associated with the specified code element.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DeclarativePatternResolver Class
Gallio.Framework.Pattern Namespace


Fields

DeclarativePatternResolver Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the declarative pattern resolver. This field is read-only.
Top

See Also

DeclarativePatternResolver Class
Gallio.Framework.Pattern Namespace


Instance Field

DeclarativePatternResolver.Instance Field
[image]

Gets the singleton instance of the declarative pattern resolver. This field is read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As DeclarativePatternResolver
C#
public static readonly DeclarativePatternResolver Instance;
C++
public:
static const DeclarativePatternResolver Instance;
J#
public static final DeclarativePatternResolver Instance
JScript
public static const var Instance : DeclarativePatternResolver;

See Also

DeclarativePatternResolver Class
Gallio.Framework.Pattern Namespace


Methods

DeclarativePatternResolver Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPatterns | Gets the patterns associated with the specified code element.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DeclarativePatternResolver Class
Gallio.Framework.Pattern Namespace


GetPatterns Method

DeclarativePatternResolver.GetPatterns Method
[image]

Gets the patterns associated with the specified code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPatterns( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of IPattern) _
Implements IPatternResolver.GetPatterns
C#
public IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
C++
public:
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
) sealed
J#
public IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
JScript
public function GetPatterns(
codeElement : ICodeElementInfo
) : IEnumerable<IPattern>

Parameters

codeElement
The code element

Return Value

The enumeration of patterns

Implements

IPatternResolver.GetPatterns

See Also

DeclarativePatternResolver Class
Gallio.Framework.Pattern Namespace


DecoratorPatternAttribute Class

DecoratorPatternAttribute Class
See Also Example Members
[image]

A decorator attribute applies contributions to a test component in scope such as a test or test parameter generated by some other pattern attribute.

Occasionally the order in which decorators are applied is significant so this type provides a Order property to specify an explicit ordering when required. All decorators that apply to a given test component declaration are applied in increasing Order.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class DecoratorPatternAttribute
Inherits PatternAttribute
C#
public abstract class DecoratorPatternAttribute : PatternAttribute
C++
ref class DecoratorPatternAttribute abstract : PatternAttribute
J#
public class DecoratorPatternAttribute extends PatternAttribute
JScript
public class DecoratorPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Derived types

See Also

DecoratorPatternAttribute Members
Gallio.Framework.Pattern Namespace


DecoratorPatternAttribute Members

DecoratorPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A decorator attribute applies contributions to a test component in scope such as a test or test parameter generated by some other pattern attribute.

Occasionally the order in which decorators are applied is significant so this type provides a Order property to specify an explicit ordering when required. All decorators that apply to a given test component declaration are applied in increasing Order.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by DecoratorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | DecoratorPatternAttribute | Initializes a new instance of the DecoratorPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Top

See Also

DecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


DecoratorPatternAttribute Constructor

DecoratorPatternAttribute Constructor
[image]

Initializes a new instance of the DecoratorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected DecoratorPatternAttribute()
C++
protected:
DecoratorPatternAttribute() sealed
J#
protected DecoratorPatternAttribute()
JScript
protected function DecoratorPatternAttribute()

See Also

DecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

DecoratorPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Order Property

DecoratorPatternAttribute.Order Property
[image]

Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Order As Integer
C#
public int Order { get; set; }
C++
public property int Order sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public function get Order() : int

public function set Order(value : int);

Property Value

The default order index is 0.

See Also

DecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultPatternEvaluator Class

DefaultPatternEvaluator Class
See Also Example Members
[image]

Default implementation of a pattern evaluator.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultPatternEvaluator
Implements IPatternEvaluator
C#
public class DefaultPatternEvaluator : IPatternEvaluator
C++
ref class DefaultPatternEvaluator : IPatternEvaluator
J#
public class DefaultPatternEvaluator implements IPatternEvaluator
JScript
public class DefaultPatternEvaluator extends IPatternEvaluator

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.DefaultPatternEvaluator

See Also

DefaultPatternEvaluator Members
Gallio.Framework.Pattern Namespace


DefaultPatternEvaluator Members

DefaultPatternEvaluator Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a pattern evaluator.

The following tables list the members exposed by DefaultPatternEvaluator.

Public Constructors

 | Name | Description
Public method | DefaultPatternEvaluator | Creates a pattern evaluator.
Top

Public Properties

 | Name | Description
Public property | TestModelBuilder | Gets the builder for the test model under construction.
Top

Public Methods

 | Name | Description
Public method | Consume | Consumes the specified code element.
Public method | CreateTopLevelTestScope | Creates a top-level test as a child of the root test. Returns the scope of the newly created top-level test.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDeclaredTests | Finds tests that are declared by the specified ICodeElementInfo.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPatterns | Gets all patterns associated with a code element.
Public method | GetPrimaryPattern | Gets the primary pattern associated with a code element, or null if none.
Public method | GetScopes | Finds scopes that are associated with the specified ICodeElementInfo and returns an enumeration of their IPatternScope objects.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | HasPatterns | Returns true if a code element has one or more associated patterns.
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test.
Public method | Process | Processes the specified code element.
Public method | RegisterScope | Registers the scope so that it can be resolved later by GetScopes.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


DefaultPatternEvaluator Constructor

DefaultPatternEvaluator Constructor
[image]

Creates a pattern evaluator.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModelBuilder As ITestModelBuilder, _
ByVal patternResolver As IPatternResolver _
)
C#
public DefaultPatternEvaluator(
ITestModelBuilder testModelBuilder,
IPatternResolver patternResolver
)
C++
public:
DefaultPatternEvaluator(
ITestModelBuilder testModelBuilder,
IPatternResolver patternResolver
) sealed
J#
public DefaultPatternEvaluator(
ITestModelBuilder testModelBuilder,
IPatternResolver patternResolver
)
JScript
public function DefaultPatternEvaluator(
testModelBuilder : ITestModelBuilder,
patternResolver : IPatternResolver
)

Parameters

testModelBuilder
The test model builder
patternResolver
The pattern resolver

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModelBuilder or patternResolver is null

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


Properties

DefaultPatternEvaluator Properties
[image]

Public Properties

 | Name | Description
Public property | TestModelBuilder | Gets the builder for the test model under construction.
Top

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


TestModelBuilder Property

DefaultPatternEvaluator.TestModelBuilder Property
[image]

Gets the builder for the test model under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestModelBuilder As ITestModelBuilder _
Implements IPatternEvaluator.TestModelBuilder
C#
public ITestModelBuilder TestModelBuilder { get; }
C++
public property ITestModelBuilder TestModelBuilder sealed {
ITestModelBuilder get();
}
J#
/** property */
public ITestModelBuilder get_TestModelBuilder();
JScript
public function get TestModelBuilder() : ITestModelBuilder

Implements

IPatternEvaluator.TestModelBuilder

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


Methods

DefaultPatternEvaluator Methods
[image]

Public Methods

 | Name | Description
Public method | Consume | Consumes the specified code element.
Public method | CreateTopLevelTestScope | Creates a top-level test as a child of the root test. Returns the scope of the newly created top-level test.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDeclaredTests | Finds tests that are declared by the specified ICodeElementInfo.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPatterns | Gets all patterns associated with a code element.
Public method | GetPrimaryPattern | Gets the primary pattern associated with a code element, or null if none.
Public method | GetScopes | Finds scopes that are associated with the specified ICodeElementInfo and returns an enumeration of their IPatternScope objects.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | HasPatterns | Returns true if a code element has one or more associated patterns.
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test.
Public method | Process | Processes the specified code element.
Public method | RegisterScope | Registers the scope so that it can be resolved later by GetScopes.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


Consume Method

DefaultPatternEvaluator.Consume Method
[image]

Consumes the specified code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean, _
ByVal defaultPrimaryPattern As IPattern _
) _
Implements IPatternEvaluator.Consume
C#
public void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
C++
public:
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
) sealed
J#
public void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
JScript
public function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool,
defaultPrimaryPattern : IPattern
)

Parameters

containingScope
The containing scope
codeElement
The code element to consume
skipChildren
If true, instructs the primary pattern to defer populating child tests
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Implements

IPatternEvaluator.Consume

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


CreateTopLevelTestScope Method

DefaultPatternEvaluator.CreateTopLevelTestScope Method
[image]

Creates a top-level test as a child of the root test. Returns the scope of the newly created top-level test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTopLevelTestScope( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope _
Implements IPatternEvaluator.CreateTopLevelTestScope
C#
public IPatternScope CreateTopLevelTestScope(
string name,
ICodeElementInfo codeElement
)
C++
public:
IPatternScope CreateTopLevelTestScope(
String name,
ICodeElementInfo codeElement
) sealed
J#
public IPatternScope CreateTopLevelTestScope(
string name,
ICodeElementInfo codeElement
)
JScript
public function CreateTopLevelTestScope(
name : String,
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

name
The test name
codeElement
The associated code element, or null if none

Return Value

The builder for the top-level test

Implements

IPatternEvaluator.CreateTopLevelTestScope

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


GetDeclaredTests Method

DefaultPatternEvaluator.GetDeclaredTests Method
[image]

Finds tests that are declared by the specified ICodeElementInfo.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDeclaredTests( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of PatternTest) _
Implements IPatternEvaluator.GetDeclaredTests
C#
public IEnumerable<PatternTest> GetDeclaredTests(
ICodeElementInfo codeElement
)
C++
public:
IEnumerable<PatternTest> GetDeclaredTests(
ICodeElementInfo codeElement
) sealed
J#
public IEnumerable<PatternTest> GetDeclaredTests(
ICodeElementInfo codeElement
)
JScript
public function GetDeclaredTests(
codeElement : ICodeElementInfo
) : IEnumerable<PatternTest>

Parameters

codeElement
The code element

Return Value

The enumeration of tests

Implements

IPatternEvaluator.GetDeclaredTests

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


GetPatterns Method

DefaultPatternEvaluator.GetPatterns Method
[image]

Gets all patterns associated with a code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPatterns( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of IPattern) _
Implements IPatternEvaluator.GetPatterns
C#
public IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
C++
public:
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
) sealed
J#
public IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
JScript
public function GetPatterns(
codeElement : ICodeElementInfo
) : IEnumerable<IPattern>

Parameters

codeElement
The code element

Return Value

The enumeration of patterns, or null if none

Implements

IPatternEvaluator.GetPatterns

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


GetPrimaryPattern Method

DefaultPatternEvaluator.GetPrimaryPattern Method
[image]

Gets the primary pattern associated with a code element, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPrimaryPattern( _
ByVal codeElement As ICodeElementInfo _
) As IPattern _
Implements IPatternEvaluator.GetPrimaryPattern
C#
public IPattern GetPrimaryPattern(
ICodeElementInfo codeElement
)
C++
public:
IPattern GetPrimaryPattern(
ICodeElementInfo codeElement
) sealed
J#
public IPattern GetPrimaryPattern(
ICodeElementInfo codeElement
)
JScript
public function GetPrimaryPattern(
codeElement : ICodeElementInfo
) : IPattern

Parameters

codeElement
The code element

Return Value

The primary pattern, or null if none

Implements

IPatternEvaluator.GetPrimaryPattern

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


GetScopes Method

DefaultPatternEvaluator.GetScopes Method
[image]

Finds scopes that are associated with the specified ICodeElementInfo and returns an enumeration of their IPatternScope objects.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetScopes( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of IPatternScope) _
Implements IPatternEvaluator.GetScopes
C#
public IEnumerable<IPatternScope> GetScopes(
ICodeElementInfo codeElement
)
C++
public:
IEnumerable<IPatternScope> GetScopes(
ICodeElementInfo codeElement
) sealed
J#
public IEnumerable<IPatternScope> GetScopes(
ICodeElementInfo codeElement
)
JScript
public function GetScopes(
codeElement : ICodeElementInfo
) : IEnumerable<IPatternScope>

Parameters

codeElement
The code element

Return Value

The enumeration of scopes

Implements

IPatternEvaluator.GetScopes

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


HasPatterns Method

DefaultPatternEvaluator.HasPatterns Method
[image]

Returns true if a code element has one or more associated patterns.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function HasPatterns( _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPatternEvaluator.HasPatterns
C#
public bool HasPatterns(
ICodeElementInfo codeElement
)
C++
public:
bool HasPatterns(
ICodeElementInfo codeElement
) sealed
J#
public bool HasPatterns(
ICodeElementInfo codeElement
)
JScript
public function HasPatterns(
codeElement : ICodeElementInfo
) : bool

Parameters

codeElement
The code element

Return Value

True if the code element has an associated pattern

Implements

IPatternEvaluator.HasPatterns

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


IsTest Method

DefaultPatternEvaluator.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsTest( _
ByVal codeElement As ICodeElementInfo, _
ByVal defaultPrimaryPattern As IPattern _
) As Boolean _
Implements IPatternEvaluator.IsTest
C#
public bool IsTest(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
C++
public:
bool IsTest(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
) sealed
J#
public bool IsTest(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
JScript
public function IsTest(
codeElement : ICodeElementInfo,
defaultPrimaryPattern : IPattern
) : bool

Parameters

codeElement
The code element
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Return Value

True if the code element represents a test

Implements

IPatternEvaluator.IsTest

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


IsTestPart Method

DefaultPatternEvaluator.IsTestPart Method
[image]

Returns true if the code element represents a part of a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsTestPart( _
ByVal codeElement As ICodeElementInfo, _
ByVal defaultPrimaryPattern As IPattern _
) As Boolean _
Implements IPatternEvaluator.IsTestPart
C#
public bool IsTestPart(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
C++
public:
bool IsTestPart(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
) sealed
J#
public bool IsTestPart(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
JScript
public function IsTestPart(
codeElement : ICodeElementInfo,
defaultPrimaryPattern : IPattern
) : bool

Parameters

codeElement
The code element
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Return Value

True if the code element represents a test

Implements

IPatternEvaluator.IsTestPart

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


Process Method

DefaultPatternEvaluator.Process Method
[image]

Processes the specified code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPatternEvaluator.Process
C#
public void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) sealed
J#
public void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPatternEvaluator.Process

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


RegisterScope Method

DefaultPatternEvaluator.RegisterScope Method
[image]

Registers the scope so that it can be resolved later by GetScopes.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterScope( _
ByVal scope As IPatternScope _
) _
Implements IPatternEvaluator.RegisterScope
C#
public void RegisterScope(
IPatternScope scope
)
C++
public:
void RegisterScope(
IPatternScope scope
) sealed
J#
public void RegisterScope(
IPatternScope scope
)
JScript
public function RegisterScope(
scope : IPatternScope
)

Parameters

scope
The scope

Implements

IPatternEvaluator.RegisterScope

See Also

DefaultPatternEvaluator Class
Gallio.Framework.Pattern Namespace


DefaultPatternScope Class

DefaultPatternScope Class
See Also Example Members
[image]

Default implementation of a pattern scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultPatternScope
Implements IPatternScope
C#
public class DefaultPatternScope : IPatternScope
C++
ref class DefaultPatternScope : IPatternScope
J#
public class DefaultPatternScope implements IPatternScope
JScript
public class DefaultPatternScope extends IPatternScope

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.DefaultPatternScope

See Also

DefaultPatternScope Members
Gallio.Framework.Pattern Namespace


DefaultPatternScope Members

DefaultPatternScope Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a pattern scope.

The following tables list the members exposed by DefaultPatternScope.

Public Constructors

 | Name | Description
Public method | DefaultPatternScope | Creates a new scope.
Top

Public Properties

 | Name | Description
Public property | CanAddChildTest | Returns true if a child test can be added to the test within scope.
Public property | CanAddTestParameter | Returns true if a test parameter can be added to the test within scope.
Public property | CodeElement | Gets the code element associated with the scope, or null if none.
Public property | Evaluator | Gets the pattern evaluator.
Public property | IsTestDeclaration | Returns true if the scope represents a test declaration. An arbitrary scope nested within a test declaration scope is not itself considered a test declaration scope unless it also represents a test declaration.
Public property | IsTestParameterDeclaration | Returns true if the scope represents a test parameter declaration. An arbitrary scope nested within a test parameter declaration scope is not itself considered a test parameter declaration scope unless it also represents a test parameter declaration.
Public property | TestBuilder | Gets a builder for applying contributions to the test currently being constructed within this scope. Never null.
Public property | TestComponentBuilder | Gets a builder for applying contributions to the test component currently being constructed within this scope.
Public property | TestDataContextBuilder | Gets a builder for applying contributions to the current test data context within the scope.
Public property | TestModelBuilder | Gets a builder for applying contributions to the test model.
Public property | TestParameterBuilder | Gets a builder for applying contributions to the test parameter currently being constructed within this scope, if there is one, or null if there is no test parameter in scope.
Top

Public Methods

 | Name | Description
Public method | AddDeferredComponentPopulator | Adds an action to the scope that enables a pattern to lazily populate the test model with components generated in nested scopes. This is used when Consume is called with the option to skip children.
Public method | Consume | Consumes the specified code element using this scope as the containing scope.
Public method | CreateChildTestDataContextScope | Creates a child test data context derived from the builders of this scope. Returns the scope of the newly created child test data context.
Public method | CreateChildTestScope | Creates a child test with its own child data context derived from the builders of this scope. Returns the scope of the newly created child test.
Public method | CreateScope | Creates and registers a scope for a test component.
Public method | CreateTestParameterScope | Creates a test parameter for the test in scope with its own child data context derived from the builders of this scope. Returns the scope of the newly created test parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | PopulateDeferredComponents | Asks all registered deferred component populators to build components whose construction had previously been deferred.
Public method | Process | Processes the specified code element using this scope as the current scope.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


DefaultPatternScope Constructor

DefaultPatternScope Constructor
[image]

Creates a new scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo, _
ByVal testBuilder As ITestBuilder, _
ByVal testParameterBuilder As ITestParameterBuilder, _
ByVal testDataContextBuilder As ITestDataContextBuilder, _
ByVal isDeclaration As Boolean _
)
C#
public DefaultPatternScope(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
)
C++
public:
DefaultPatternScope(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
) sealed
J#
public DefaultPatternScope(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
)
JScript
public function DefaultPatternScope(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo,
testBuilder : ITestBuilder,
testParameterBuilder : ITestParameterBuilder,
testDataContextBuilder : ITestDataContextBuilder,
isDeclaration : bool
)

Parameters

evaluator
The pattern evaluator
codeElement
The code element associated with the scope, or null if none
testBuilder
The test builder in scope
testParameterBuilder
The test parameter builder in scope, or null if none
testDataContextBuilder
The test data context builder
isDeclaration
True if the scope represents the initial point of declaration of a given test component

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if evaluator, testBuilder or testDataContextBuilder is null

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


Properties

DefaultPatternScope Properties
[image]

Public Properties

 | Name | Description
Public property | CanAddChildTest | Returns true if a child test can be added to the test within scope.
Public property | CanAddTestParameter | Returns true if a test parameter can be added to the test within scope.
Public property | CodeElement | Gets the code element associated with the scope, or null if none.
Public property | Evaluator | Gets the pattern evaluator.
Public property | IsTestDeclaration | Returns true if the scope represents a test declaration. An arbitrary scope nested within a test declaration scope is not itself considered a test declaration scope unless it also represents a test declaration.
Public property | IsTestParameterDeclaration | Returns true if the scope represents a test parameter declaration. An arbitrary scope nested within a test parameter declaration scope is not itself considered a test parameter declaration scope unless it also represents a test parameter declaration.
Public property | TestBuilder | Gets a builder for applying contributions to the test currently being constructed within this scope. Never null.
Public property | TestComponentBuilder | Gets a builder for applying contributions to the test component currently being constructed within this scope.
Public property | TestDataContextBuilder | Gets a builder for applying contributions to the current test data context within the scope.
Public property | TestModelBuilder | Gets a builder for applying contributions to the test model.
Public property | TestParameterBuilder | Gets a builder for applying contributions to the test parameter currently being constructed within this scope, if there is one, or null if there is no test parameter in scope.
Top

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CanAddChildTest Property

DefaultPatternScope.CanAddChildTest Property
[image]

Returns true if a child test can be added to the test within scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanAddChildTest As Boolean _
Implements IPatternScope.CanAddChildTest
C#
public bool CanAddChildTest { get; }
C++
public property bool CanAddChildTest sealed {
bool get();
}
J#
/** property */
public bool get_CanAddChildTest();
JScript
public function get CanAddChildTest() : bool

Implements

IPatternScope.CanAddChildTest

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CanAddTestParameter Property

DefaultPatternScope.CanAddTestParameter Property
[image]

Returns true if a test parameter can be added to the test within scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanAddTestParameter As Boolean _
Implements IPatternScope.CanAddTestParameter
C#
public bool CanAddTestParameter { get; }
C++
public property bool CanAddTestParameter sealed {
bool get();
}
J#
/** property */
public bool get_CanAddTestParameter();
JScript
public function get CanAddTestParameter() : bool

Implements

IPatternScope.CanAddTestParameter

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CodeElement Property

DefaultPatternScope.CodeElement Property
[image]

Gets the code element associated with the scope, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CodeElement As ICodeElementInfo _
Implements IPatternScope.CodeElement
C#
public ICodeElementInfo CodeElement { get; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

Implements

IPatternScope.CodeElement

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


Evaluator Property

DefaultPatternScope.Evaluator Property
[image]

Gets the pattern evaluator.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Evaluator As IPatternEvaluator _
Implements IPatternScope.Evaluator
C#
public IPatternEvaluator Evaluator { get; }
C++
public property IPatternEvaluator Evaluator sealed {
IPatternEvaluator get();
}
J#
/** property */
public IPatternEvaluator get_Evaluator();
JScript
public function get Evaluator() : IPatternEvaluator

Implements

IPatternScope.Evaluator

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


IsTestDeclaration Property

DefaultPatternScope.IsTestDeclaration Property
[image]

Returns true if the scope represents a test declaration.

An arbitrary scope nested within a test declaration scope is not itself considered a test declaration scope unless it also represents a test declaration.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTestDeclaration As Boolean _
Implements IPatternScope.IsTestDeclaration
C#
public bool IsTestDeclaration { get; }
C++
public property bool IsTestDeclaration sealed {
bool get();
}
J#
/** property */
public bool get_IsTestDeclaration();
JScript
public function get IsTestDeclaration() : bool

Implements

IPatternScope.IsTestDeclaration

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


IsTestParameterDeclaration Property

DefaultPatternScope.IsTestParameterDeclaration Property
[image]

Returns true if the scope represents a test parameter declaration.

An arbitrary scope nested within a test parameter declaration scope is not itself considered a test parameter declaration scope unless it also represents a test parameter declaration.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTestParameterDeclaration As Boolean _
Implements IPatternScope.IsTestParameterDeclaration
C#
public bool IsTestParameterDeclaration { get; }
C++
public property bool IsTestParameterDeclaration sealed {
bool get();
}
J#
/** property */
public bool get_IsTestParameterDeclaration();
JScript
public function get IsTestParameterDeclaration() : bool

Implements

IPatternScope.IsTestParameterDeclaration

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


TestBuilder Property

DefaultPatternScope.TestBuilder Property
[image]

Gets a builder for applying contributions to the test currently being constructed within this scope. Never null.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestBuilder As ITestBuilder _
Implements IPatternScope.TestBuilder
C#
public ITestBuilder TestBuilder { get; }
C++
public property ITestBuilder TestBuilder sealed {
ITestBuilder get();
}
J#
/** property */
public ITestBuilder get_TestBuilder();
JScript
public function get TestBuilder() : ITestBuilder

Implements

IPatternScope.TestBuilder

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


TestComponentBuilder Property

DefaultPatternScope.TestComponentBuilder Property
[image]

Gets a builder for applying contributions to the test component currently being constructed within this scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestComponentBuilder As ITestComponentBuilder _
Implements IPatternScope.TestComponentBuilder
C#
public ITestComponentBuilder TestComponentBuilder { get; }
C++
public property ITestComponentBuilder TestComponentBuilder sealed {
ITestComponentBuilder get();
}
J#
/** property */
public ITestComponentBuilder get_TestComponentBuilder();
JScript
public function get TestComponentBuilder() : ITestComponentBuilder

Implements

IPatternScope.TestComponentBuilder

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


TestDataContextBuilder Property

DefaultPatternScope.TestDataContextBuilder Property
[image]

Gets a builder for applying contributions to the current test data context within the scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestDataContextBuilder As ITestDataContextBuilder _
Implements IPatternScope.TestDataContextBuilder
C#
public ITestDataContextBuilder TestDataContextBuilder { get; }
C++
public property ITestDataContextBuilder TestDataContextBuilder sealed {
ITestDataContextBuilder get();
}
J#
/** property */
public ITestDataContextBuilder get_TestDataContextBuilder();
JScript
public function get TestDataContextBuilder() : ITestDataContextBuilder

Implements

IPatternScope.TestDataContextBuilder

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


TestModelBuilder Property

DefaultPatternScope.TestModelBuilder Property
[image]

Gets a builder for applying contributions to the test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestModelBuilder As ITestModelBuilder _
Implements IPatternScope.TestModelBuilder
C#
public ITestModelBuilder TestModelBuilder { get; }
C++
public property ITestModelBuilder TestModelBuilder sealed {
ITestModelBuilder get();
}
J#
/** property */
public ITestModelBuilder get_TestModelBuilder();
JScript
public function get TestModelBuilder() : ITestModelBuilder

Implements

IPatternScope.TestModelBuilder

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


TestParameterBuilder Property

DefaultPatternScope.TestParameterBuilder Property
[image]

Gets a builder for applying contributions to the test parameter currently being constructed within this scope, if there is one, or null if there is no test parameter in scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestParameterBuilder As ITestParameterBuilder _
Implements IPatternScope.TestParameterBuilder
C#
public ITestParameterBuilder TestParameterBuilder { get; }
C++
public property ITestParameterBuilder TestParameterBuilder sealed {
ITestParameterBuilder get();
}
J#
/** property */
public ITestParameterBuilder get_TestParameterBuilder();
JScript
public function get TestParameterBuilder() : ITestParameterBuilder

Implements

IPatternScope.TestParameterBuilder

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


Methods

DefaultPatternScope Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredComponentPopulator | Adds an action to the scope that enables a pattern to lazily populate the test model with components generated in nested scopes. This is used when Consume is called with the option to skip children.
Public method | Consume | Consumes the specified code element using this scope as the containing scope.
Public method | CreateChildTestDataContextScope | Creates a child test data context derived from the builders of this scope. Returns the scope of the newly created child test data context.
Public method | CreateChildTestScope | Creates a child test with its own child data context derived from the builders of this scope. Returns the scope of the newly created child test.
Public method | CreateScope | Creates and registers a scope for a test component.
Public method | CreateTestParameterScope | Creates a test parameter for the test in scope with its own child data context derived from the builders of this scope. Returns the scope of the newly created test parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | PopulateDeferredComponents | Asks all registered deferred component populators to build components whose construction had previously been deferred.
Public method | Process | Processes the specified code element using this scope as the current scope.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


AddDeferredComponentPopulator Method

DefaultPatternScope.AddDeferredComponentPopulator Method
[image]

Adds an action to the scope that enables a pattern to lazily populate the test model with components generated in nested scopes. This is used when Consume is called with the option to skip children.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDeferredComponentPopulator( _
ByVal populator As DeferredComponentPopulator _
) _
Implements IPatternScope.AddDeferredComponentPopulator
C#
public void AddDeferredComponentPopulator(
DeferredComponentPopulator populator
)
C++
public:
void AddDeferredComponentPopulator(
DeferredComponentPopulator populator
) sealed
J#
public void AddDeferredComponentPopulator(
DeferredComponentPopulator populator
)
JScript
public function AddDeferredComponentPopulator(
populator : DeferredComponentPopulator
)

Parameters

populator
A DeferredComponentPopulator supplied by the pattern to populate its components lazily

Implements

IPatternScope.AddDeferredComponentPopulator

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


Consume Method

DefaultPatternScope.Consume Method
[image]

Consumes the specified code element using this scope as the containing scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Consume( _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean, _
ByVal defaultPrimaryPattern As IPattern _
) _
Implements IPatternScope.Consume
C#
public void Consume(
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
C++
public:
void Consume(
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
) sealed
J#
public void Consume(
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
JScript
public function Consume(
codeElement : ICodeElementInfo,
skipChildren : bool,
defaultPrimaryPattern : IPattern
)

Parameters

codeElement
The code element to consume
skipChildren
If true, instructs the primary pattern to defer populating child tests
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Implements

IPatternScope.Consume

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CreateChildTestDataContextScope Method

DefaultPatternScope.CreateChildTestDataContextScope Method
[image]

Creates a child test data context derived from the builders of this scope. Returns the scope of the newly created child test data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChildTestDataContextScope( _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope _
Implements IPatternScope.CreateChildTestDataContextScope
C#
public IPatternScope CreateChildTestDataContextScope(
ICodeElementInfo codeElement
)
C++
public:
IPatternScope CreateChildTestDataContextScope(
ICodeElementInfo codeElement
) sealed
J#
public IPatternScope CreateChildTestDataContextScope(
ICodeElementInfo codeElement
)
JScript
public function CreateChildTestDataContextScope(
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

codeElement
The associated code element, or null if none

Return Value

The scope of the newly created child test data context

Implements

IPatternScope.CreateChildTestDataContextScope

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CreateChildTestScope Method

DefaultPatternScope.CreateChildTestScope Method
[image]

Creates a child test with its own child data context derived from the builders of this scope. Returns the scope of the newly created child test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChildTestScope( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope _
Implements IPatternScope.CreateChildTestScope
C#
public IPatternScope CreateChildTestScope(
string name,
ICodeElementInfo codeElement
)
C++
public:
IPatternScope CreateChildTestScope(
String name,
ICodeElementInfo codeElement
) sealed
J#
public IPatternScope CreateChildTestScope(
string name,
ICodeElementInfo codeElement
)
JScript
public function CreateChildTestScope(
name : String,
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

name
The test name
codeElement
The associated code element, or null if none

Return Value

The scope of the newly created child test

Implements

IPatternScope.CreateChildTestScope

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CreateScope Method

DefaultPatternScope.CreateScope Method
[image]

Creates and registers a scope for a test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateScope( _
ByVal codeElement As ICodeElementInfo, _
ByVal testBuilder As ITestBuilder, _
ByVal testParameterBuilder As ITestParameterBuilder, _
ByVal testDataContextBuilder As ITestDataContextBuilder, _
ByVal isDeclaration As Boolean _
) As IPatternScope _
Implements IPatternScope.CreateScope
C#
public IPatternScope CreateScope(
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
)
C++
public:
IPatternScope CreateScope(
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
) sealed
J#
public IPatternScope CreateScope(
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
)
JScript
public function CreateScope(
codeElement : ICodeElementInfo,
testBuilder : ITestBuilder,
testParameterBuilder : ITestParameterBuilder,
testDataContextBuilder : ITestDataContextBuilder,
isDeclaration : bool
) : IPatternScope

Parameters

codeElement
The code element to associate with the scope
testBuilder
The test builder
testParameterBuilder
The test parameter builder, or null if the scope is to be associated to the test only
testDataContextBuilder
The test data context builder
isDeclaration
If true, the scope represents the point of declaration of the test component with which it is associated

Return Value

The new scope

Implements

IPatternScope.CreateScope

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


CreateTestParameterScope Method

DefaultPatternScope.CreateTestParameterScope Method
[image]

Creates a test parameter for the test in scope with its own child data context derived from the builders of this scope. Returns the scope of the newly created test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTestParameterScope( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope _
Implements IPatternScope.CreateTestParameterScope
C#
public IPatternScope CreateTestParameterScope(
string name,
ICodeElementInfo codeElement
)
C++
public:
IPatternScope CreateTestParameterScope(
String name,
ICodeElementInfo codeElement
) sealed
J#
public IPatternScope CreateTestParameterScope(
string name,
ICodeElementInfo codeElement
)
JScript
public function CreateTestParameterScope(
name : String,
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

name
The test parameter name
codeElement
The associated code element, or null if none

Return Value

The scope of the newly created test parameter

Implements

IPatternScope.CreateTestParameterScope

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


PopulateDeferredComponents Method

DefaultPatternScope.PopulateDeferredComponents Method
[image]

Asks all registered deferred component populators to build components whose construction had previously been deferred.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub PopulateDeferredComponents( _
ByVal codeElementHint As ICodeElementInfo _
) _
Implements IPatternScope.PopulateDeferredComponents
C#
public void PopulateDeferredComponents(
ICodeElementInfo codeElementHint
)
C++
public:
void PopulateDeferredComponents(
ICodeElementInfo codeElementHint
) sealed
J#
public void PopulateDeferredComponents(
ICodeElementInfo codeElementHint
)
JScript
public function PopulateDeferredComponents(
codeElementHint : ICodeElementInfo
)

Parameters

codeElementHint
The code element hint to identify the location of the particular components to populate, or null to populate them all

Implements

IPatternScope.PopulateDeferredComponents

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


Process Method

DefaultPatternScope.Process Method
[image]

Processes the specified code element using this scope as the current scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Process( _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPatternScope.Process
C#
public void Process(
ICodeElementInfo codeElement
)
C++
public:
void Process(
ICodeElementInfo codeElement
) sealed
J#
public void Process(
ICodeElementInfo codeElement
)
JScript
public function Process(
codeElement : ICodeElementInfo
)

Parameters

codeElement
The code element to process

Implements

IPatternScope.Process

See Also

DefaultPatternScope Class
Gallio.Framework.Pattern Namespace


DefaultTestBuilder Class

DefaultTestBuilder Class
See Also Example Members
[image]

Default implementation of a test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestBuilder
Inherits BaseTestComponentBuilder
Implements ITestBuilder
C#
public class DefaultTestBuilder : BaseTestComponentBuilder, ITestBuilder
C++
ref class DefaultTestBuilder : BaseTestComponentBuilder, ITestBuilder
J#
public class DefaultTestBuilder extends BaseTestComponentBuilder implements ITestBuilder
JScript
public class DefaultTestBuilder extends BaseTestComponentBuilder, ITestBuilder

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BaseBuilder
Gallio.Framework.Pattern.BaseTestComponentBuilder
Gallio.Framework.Pattern.DefaultTestBuilder

See Also

DefaultTestBuilder Members
Gallio.Framework.Pattern Namespace


DefaultTestBuilder Members

DefaultTestBuilder Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a test model builder.

The following tables list the members exposed by DefaultTestBuilder.

Public Constructors

 | Name | Description
Public method | DefaultTestBuilder | Creates a test builder.
Top

Public Properties

Name | Description
Public property | ApartmentState | Gets or sets the apartment state to be used to run the test.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponentBuilder)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestComponentBuilder)
Public property | IsParallelizable | Gets or sets whether the test is parallelizable.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.
Public property | Name | Gets or sets the name of the component. (inherited from BaseTestComponentBuilder)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TestActions | Gets the set of actions that describe the behavior of the test.
Public property | TestInstanceActions | Gets the set of actions that describe the behavior of the test's instances.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | AddDependency | Adds a test dependency.
Public method | AddMetadata | Adds a metadata key value pair. (inherited from BaseTestComponentBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | CreateChild | Creates a child test and returns its builder.
Public method | CreateParameter | Creates a test parameter and returns its builder.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetExpectedExceptionType | Sets the name of the expected exception type.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTest | Gets the underlying test.
Public method | ToTestComponent | Gets the underlying test component. (inherited from BaseTestComponentBuilder)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestComponent | Gets the underlying test component.
Family method | GetTestModelBuilder | Gets the test model builder. (inherited from BaseTestComponentBuilder)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestBuilder Constructor

DefaultTestBuilder Constructor
[image]

Creates a test builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModelBuilder As ITestModelBuilder, _
ByVal test As PatternTest _
)
C#
public DefaultTestBuilder(
ITestModelBuilder testModelBuilder,
PatternTest test
)
C++
public:
DefaultTestBuilder(
ITestModelBuilder testModelBuilder,
PatternTest test
) sealed
J#
public DefaultTestBuilder(
ITestModelBuilder testModelBuilder,
PatternTest test
)
JScript
public function DefaultTestBuilder(
testModelBuilder : ITestModelBuilder,
test : PatternTest
)

Parameters

testModelBuilder
The test model builder
test
The underlying test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModelBuilder or test is null

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


Properties

DefaultTestBuilder Properties
[image]

Public Properties

Name | Description
Public property | ApartmentState | Gets or sets the apartment state to be used to run the test.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponentBuilder)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestComponentBuilder)
Public property | IsParallelizable | Gets or sets whether the test is parallelizable.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.
Public property | Name | Gets or sets the name of the component. (inherited from BaseTestComponentBuilder)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TestActions | Gets the set of actions that describe the behavior of the test.
Public property | TestInstanceActions | Gets the set of actions that describe the behavior of the test's instances.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


ApartmentState Property

DefaultTestBuilder.ApartmentState Property
[image]

Gets or sets the apartment state to be used to run the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ApartmentState As ApartmentState _
Implements ITestBuilder.ApartmentState
C#
public ApartmentState ApartmentState { get; set; }
C++
public property ApartmentState ApartmentState sealed {
ApartmentState get();
void set(ApartmentState value);
}
J#
/** property */
public ApartmentState get_ApartmentState();

/** property */
public void set_ApartmentState(ApartmentState value);
JScript
public function get ApartmentState() : ApartmentState

public function set ApartmentState(value : ApartmentState);

Property Value

The default value of this property is Unknown.

Implements

ITestBuilder.ApartmentState

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


IsParallelizable Property

DefaultTestBuilder.IsParallelizable Property
[image]

Gets or sets whether the test is parallelizable.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsParallelizable As Boolean _
Implements ITestBuilder.IsParallelizable
C#
public bool IsParallelizable { get; set; }
C++
public property bool IsParallelizable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsParallelizable();

/** property */
public void set_IsParallelizable(bool value);
JScript
public function get IsParallelizable() : bool

public function set IsParallelizable(value : bool);

Property Value

True if the test is parallelizable. The default value of this property is false.

Implements

ITestBuilder.IsParallelizable

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


IsTestCase Property

DefaultTestBuilder.IsTestCase Property
[image]

Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTestCase As Boolean _
Implements ITestBuilder.IsTestCase
C#
public bool IsTestCase { get; set; }
C++
public property bool IsTestCase sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsTestCase();

/** property */
public void set_IsTestCase(bool value);
JScript
public function get IsTestCase() : bool

public function set IsTestCase(value : bool);

Implements

ITestBuilder.IsTestCase

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


Kind Property

DefaultTestBuilder.Kind Property
[image]

Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Kind As String _
Implements ITestBuilder.Kind
C#
public string Kind { get; set; }
C++
public property string Kind sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Kind();

/** property */
public void set_Kind(string value);
JScript
public function get Kind() : String

public function set Kind(value : String);

Property Value

One of the TestKinds constants.

Implements

ITestBuilder.Kind

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


LocalId Property

DefaultTestBuilder.LocalId Property
[image]

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocalId As String _
Implements ITestBuilder.LocalId
C#
public string LocalId { get; }
C++
public property string LocalId sealed {
String get();
}
J#
/** property */
public string get_LocalId();
JScript
public function get LocalId() : String

Property Value

The locally unique identifier

Implements

ITestBuilder.LocalId

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


LocalIdHint Property

DefaultTestBuilder.LocalIdHint Property
[image]

Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalIdHint As String _
Implements ITestBuilder.LocalIdHint
C#
public string LocalIdHint { get; set; }
C++
public property string LocalIdHint sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalIdHint();

/** property */
public void set_LocalIdHint(string value);
JScript
public function get LocalIdHint() : String

public function set LocalIdHint(value : String);

Property Value

The local id hint

Implements

ITestBuilder.LocalIdHint

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


Order Property

DefaultTestBuilder.Order Property
[image]

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Order As Integer _
Implements ITestBuilder.Order
C#
public int Order { get; set; }
C++
public property int Order sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public function get Order() : int

public function set Order(value : int);

Property Value

The test execution order with respect to siblings, initially zero.

Implements

ITestBuilder.Order

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


TestActions Property

DefaultTestBuilder.TestActions Property
[image]

Gets the set of actions that describe the behavior of the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestActions As PatternTestActions _
Implements ITestBuilder.TestActions
C#
public PatternTestActions TestActions { get; }
C++
public property PatternTestActions TestActions sealed {
PatternTestActions get();
}
J#
/** property */
public PatternTestActions get_TestActions();
JScript
public function get TestActions() : PatternTestActions

Implements

ITestBuilder.TestActions

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


TestInstanceActions Property

DefaultTestBuilder.TestInstanceActions Property
[image]

Gets the set of actions that describe the behavior of the test's instances.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestInstanceActions As PatternTestInstanceActions _
Implements ITestBuilder.TestInstanceActions
C#
public PatternTestInstanceActions TestInstanceActions { get; }
C++
public property PatternTestInstanceActions TestInstanceActions sealed {
PatternTestInstanceActions get();
}
J#
/** property */
public PatternTestInstanceActions get_TestInstanceActions();
JScript
public function get TestInstanceActions() : PatternTestInstanceActions

Implements

ITestBuilder.TestInstanceActions

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


Timeout Property

DefaultTestBuilder.Timeout Property
[image]

Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Timeout As Nullable(Of TimeSpan) _
Implements ITestBuilder.Timeout
C#
public Nullable<TimeSpan> Timeout { get; set; }
C++
public property Nullable<TimeSpan> Timeout sealed {
Nullable<TimeSpan> get();
void set(Nullable<TimeSpan> value);
}
J#
/** property */
public Nullable<TimeSpan> get_Timeout();

/** property */
public void set_Timeout(Nullable<TimeSpan> value);
JScript
public function get Timeout() : Nullable<TimeSpan>

public function set Timeout(value : Nullable<TimeSpan>);

Property Value

The timeout. Default value is null.

Implements

ITestBuilder.Timeout

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


Methods

DefaultTestBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | AddDependency | Adds a test dependency.
Public method | AddMetadata | Adds a metadata key value pair. (inherited from BaseTestComponentBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | CreateChild | Creates a child test and returns its builder.
Public method | CreateParameter | Creates a test parameter and returns its builder.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetExpectedExceptionType | Sets the name of the expected exception type.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTest | Gets the underlying test.
Public method | ToTestComponent | Gets the underlying test component. (inherited from BaseTestComponentBuilder)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestComponent | Gets the underlying test component.
Family method | GetTestModelBuilder | Gets the test model builder. (inherited from BaseTestComponentBuilder)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


AddDependency Method

DefaultTestBuilder.AddDependency Method
[image]

Adds a test dependency.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDependency( _
ByVal testDependency As ITest _
) _
Implements ITestBuilder.AddDependency
C#
public void AddDependency(
ITest testDependency
)
C++
public:
void AddDependency(
ITest testDependency
) sealed
J#
public void AddDependency(
ITest testDependency
)
JScript
public function AddDependency(
testDependency : ITest
)

Parameters

testDependency
The test to add as a dependency

Implements

ITestBuilder.AddDependency

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


CreateChild Method

DefaultTestBuilder.CreateChild Method
[image]

Creates a child test and returns its builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChild( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContextBuilder As ITestDataContextBuilder _
) As ITestBuilder _
Implements ITestBuilder.CreateChild
C#
public ITestBuilder CreateChild(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
C++
public:
ITestBuilder CreateChild(
String name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
) sealed
J#
public ITestBuilder CreateChild(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
JScript
public function CreateChild(
name : String,
codeElement : ICodeElementInfo,
dataContextBuilder : ITestDataContextBuilder
) : ITestBuilder

Parameters

name
The test name
codeElement
The associated code element, or null if none
dataContextBuilder
The data context builder for the new test

Return Value

The builder for the child test

Implements

ITestBuilder.CreateChild

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


CreateParameter Method

DefaultTestBuilder.CreateParameter Method
[image]

Creates a test parameter and returns its builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateParameter( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContextBuilder As ITestDataContextBuilder _
) As ITestParameterBuilder _
Implements ITestBuilder.CreateParameter
C#
public ITestParameterBuilder CreateParameter(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
C++
public:
ITestParameterBuilder CreateParameter(
String name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
) sealed
J#
public ITestParameterBuilder CreateParameter(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
JScript
public function CreateParameter(
name : String,
codeElement : ICodeElementInfo,
dataContextBuilder : ITestDataContextBuilder
) : ITestParameterBuilder

Parameters

name
The test parameter name
codeElement
The associated code element, or null if none
dataContextBuilder
The data context builder for the new test parameter

Return Value

The builder for the test parameter

Implements

ITestBuilder.CreateParameter

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


GetTestComponent Method

DefaultTestBuilder.GetTestComponent Method
[image]

Gets the underlying test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetTestComponent() As IPatternTestComponent
C#
protected IPatternTestComponent GetTestComponent()
C++
protected:
IPatternTestComponent GetTestComponent() sealed
J#
protected IPatternTestComponent GetTestComponent()
JScript
protected function GetTestComponent() : IPatternTestComponent

Return Value

The test component

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


SetExpectedExceptionType Method

DefaultTestBuilder.SetExpectedExceptionType Method
[image]

Sets the name of the expected exception type.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetExpectedExceptionType( _
ByVal typeName As String _
) _
Implements ITestBuilder.SetExpectedExceptionType
C#
public void SetExpectedExceptionType(
string typeName
)
C++
public:
void SetExpectedExceptionType(
String typeName
) sealed
J#
public void SetExpectedExceptionType(
string typeName
)
JScript
public function SetExpectedExceptionType(
typeName : String
)

Parameters

typeName
The expected exception type name

Implements

ITestBuilder.SetExpectedExceptionType

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


ToTest Method

DefaultTestBuilder.ToTest Method
[image]

Gets the underlying test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToTest() As PatternTest _
Implements ITestBuilder.ToTest
C#
public PatternTest ToTest()
C++
public:
PatternTest ToTest() sealed
J#
public PatternTest ToTest()
JScript
public function ToTest() : PatternTest

Return Value

The underlying test

Implements

ITestBuilder.ToTest

See Also

DefaultTestBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestDataContextBuilder Class

DefaultTestDataContextBuilder Class
See Also Example Members
[image]

Default implementation of a test data context builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestDataContextBuilder
Inherits BaseBuilder
Implements ITestDataContextBuilder
C#
public class DefaultTestDataContextBuilder : BaseBuilder, ITestDataContextBuilder
C++
ref class DefaultTestDataContextBuilder : BaseBuilder, ITestDataContextBuilder
J#
public class DefaultTestDataContextBuilder extends BaseBuilder implements ITestDataContextBuilder
JScript
public class DefaultTestDataContextBuilder extends BaseBuilder, ITestDataContextBuilder

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BaseBuilder
Gallio.Framework.Pattern.DefaultTestDataContextBuilder

See Also

DefaultTestDataContextBuilder Members
Gallio.Framework.Pattern Namespace


DefaultTestDataContextBuilder Members

DefaultTestDataContextBuilder Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a test data context builder.

The following tables list the members exposed by DefaultTestDataContextBuilder.

Public Constructors

 | Name | Description
Public method | DefaultTestDataContextBuilder | Creates a test data context builder.
Top

Public Properties

Name Description
Public property ImplicitDataBindingIndexOffset

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.
Top

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | CreateChild | Creates a child data context.
Public method | DefineDataSource | Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToPatternTestDataContext | Gets the underlying pattern test data context.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestDataContextBuilder Constructor

DefaultTestDataContextBuilder Constructor
[image]

Creates a test data context builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModelBuilder As ITestModelBuilder, _
ByVal testDataContext As PatternTestDataContext _
)
C#
public DefaultTestDataContextBuilder(
ITestModelBuilder testModelBuilder,
PatternTestDataContext testDataContext
)
C++
public:
DefaultTestDataContextBuilder(
ITestModelBuilder testModelBuilder,
PatternTestDataContext testDataContext
) sealed
J#
public DefaultTestDataContextBuilder(
ITestModelBuilder testModelBuilder,
PatternTestDataContext testDataContext
)
JScript
public function DefaultTestDataContextBuilder(
testModelBuilder : ITestModelBuilder,
testDataContext : PatternTestDataContext
)

Parameters

testModelBuilder
The associated test model builder
testDataContext
The underlying test data context

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModelBuilder or testDataContext is null

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


Properties

DefaultTestDataContextBuilder Properties
[image]

Public Properties

Name Description
Public property ImplicitDataBindingIndexOffset

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.
Top

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


ImplicitDataBindingIndexOffset Property

DefaultTestDataContextBuilder.ImplicitDataBindingIndexOffset Property
See Also Example
[image]

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplicitDataBindingIndexOffset As Integer _
Implements ITestDataContextBuilder.ImplicitDataBindingIndexOffset
C#
public int ImplicitDataBindingIndexOffset { get; set; }
C++
public property int ImplicitDataBindingIndexOffset sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ImplicitDataBindingIndexOffset();

/** property */
public void set_ImplicitDataBindingIndexOffset(int value);
JScript
public function get ImplicitDataBindingIndexOffset() : int

public function set ImplicitDataBindingIndexOffset(value : int);

Implements

ITestDataContextBuilder.ImplicitDataBindingIndexOffset

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


Methods

DefaultTestDataContextBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | CreateChild | Creates a child data context.
Public method | DefineDataSource | Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToPatternTestDataContext | Gets the underlying pattern test data context.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


CreateChild Method

DefaultTestDataContextBuilder.CreateChild Method
[image]

Creates a child data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChild() As ITestDataContextBuilder _
Implements ITestDataContextBuilder.CreateChild
C#
public ITestDataContextBuilder CreateChild()
C++
public:
ITestDataContextBuilder CreateChild() sealed
J#
public ITestDataContextBuilder CreateChild()
JScript
public function CreateChild() : ITestDataContextBuilder

Return Value

The builder for the child context

Implements

ITestDataContextBuilder.CreateChild

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


DefineDataSource Method

DefaultTestDataContextBuilder.DefineDataSource Method
[image]

Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function DefineDataSource( _
ByVal name As String _
) As DataSource _
Implements ITestDataContextBuilder.DefineDataSource
C#
public DataSource DefineDataSource(
string name
)
C++
public:
DataSource DefineDataSource(
String name
) sealed
J#
public DataSource DefineDataSource(
string name
)
JScript
public function DefineDataSource(
name : String
) : DataSource

Parameters

name
The data source name

Return Value

The defined data source

Implements

ITestDataContextBuilder.DefineDataSource

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


GetTestModelBuilder Method

DefaultTestDataContextBuilder.GetTestModelBuilder Method
[image]

Gets the test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetTestModelBuilder() As ITestModelBuilder
C#
protected ITestModelBuilder GetTestModelBuilder()
C++
protected:
ITestModelBuilder GetTestModelBuilder() sealed
J#
protected ITestModelBuilder GetTestModelBuilder()
JScript
protected function GetTestModelBuilder() : ITestModelBuilder

Return Value

The test model builder

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


ToPatternTestDataContext Method

DefaultTestDataContextBuilder.ToPatternTestDataContext Method
See Also Example
[image]

Gets the underlying pattern test data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToPatternTestDataContext() As PatternTestDataContext _
Implements ITestDataContextBuilder.ToPatternTestDataContext
C#
public PatternTestDataContext ToPatternTestDataContext()
C++
public:
PatternTestDataContext ToPatternTestDataContext() sealed
J#
public PatternTestDataContext ToPatternTestDataContext()
JScript
public function ToPatternTestDataContext() : PatternTestDataContext

Return Value

The underlying pattern test data context

Implements

ITestDataContextBuilder.ToPatternTestDataContext

See Also

DefaultTestDataContextBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestModelBuilder Class

DefaultTestModelBuilder Class
See Also Example Members
[image]

Default implementation of a test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestModelBuilder
Inherits BaseBuilder
Implements ITestModelBuilder
C#
public class DefaultTestModelBuilder : BaseBuilder, ITestModelBuilder
C++
ref class DefaultTestModelBuilder : BaseBuilder, ITestModelBuilder
J#
public class DefaultTestModelBuilder extends BaseBuilder implements ITestModelBuilder
JScript
public class DefaultTestModelBuilder extends BaseBuilder, ITestModelBuilder

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BaseBuilder
Gallio.Framework.Pattern.DefaultTestModelBuilder

See Also

DefaultTestModelBuilder Members
Gallio.Framework.Pattern Namespace


DefaultTestModelBuilder Members

DefaultTestModelBuilder Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a test model builder.

The following tables list the members exposed by DefaultTestModelBuilder.

Public Constructors

 | Name | Description
Public method | DefaultTestModelBuilder | Creates a test model builder.
Top

Public Properties

 | Name | Description
Public property | ReflectionPolicy | Gets the reflection policy for the model.
Top

Public Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation to the test model.
Public method | AddAssemblyResolver | Adds an assembly resolver to the test model's assembly loading policy.
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | CreateTopLevelTest | Creates a top-level test as a child of the root test and returns its builder.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | PublishExceptionAsAnnotation | Publishes an exception as an annotation about a particular code element.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTestModel | Gets the underlying test model.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestModelBuilder Constructor

DefaultTestModelBuilder Constructor
[image]

Creates a test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModel As TestModel _
)
C#
public DefaultTestModelBuilder(
TestModel testModel
)
C++
public:
DefaultTestModelBuilder(
TestModel testModel
) sealed
J#
public DefaultTestModelBuilder(
TestModel testModel
)
JScript
public function DefaultTestModelBuilder(
testModel : TestModel
)

Parameters

testModel
The underlying test model

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModel is null

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


Properties

DefaultTestModelBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | ReflectionPolicy | Gets the reflection policy for the model.
Top

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


ReflectionPolicy Property

DefaultTestModelBuilder.ReflectionPolicy Property
[image]

Gets the reflection policy for the model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReflectionPolicy As IReflectionPolicy _
Implements ITestModelBuilder.ReflectionPolicy
C#
public IReflectionPolicy ReflectionPolicy { get; }
C++
public property IReflectionPolicy ReflectionPolicy sealed {
IReflectionPolicy get();
}
J#
/** property */
public IReflectionPolicy get_ReflectionPolicy();
JScript
public function get ReflectionPolicy() : IReflectionPolicy

Implements

ITestModelBuilder.ReflectionPolicy

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


Methods

DefaultTestModelBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation to the test model.
Public method | AddAssemblyResolver | Adds an assembly resolver to the test model's assembly loading policy.
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | CreateTopLevelTest | Creates a top-level test as a child of the root test and returns its builder.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | PublishExceptionAsAnnotation | Publishes an exception as an annotation about a particular code element.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTestModel | Gets the underlying test model.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestModelBuilder | Gets the test model builder.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


AddAnnotation Method

DefaultTestModelBuilder.AddAnnotation Method
[image]

Adds an annotation to the test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAnnotation( _
ByVal annotation As Annotation _
) _
Implements ITestModelBuilder.AddAnnotation
C#
public void AddAnnotation(
Annotation annotation
)
C++
public:
void AddAnnotation(
Annotation annotation
) sealed
J#
public void AddAnnotation(
Annotation annotation
)
JScript
public function AddAnnotation(
annotation : Annotation
)

Parameters

annotation
The annotation to add

Implements

ITestModelBuilder.AddAnnotation

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


AddAssemblyResolver Method

DefaultTestModelBuilder.AddAssemblyResolver Method
[image]

Adds an assembly resolver to the test model's assembly loading policy.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssemblyResolver( _
ByVal resolver As IAssemblyResolver _
) _
Implements ITestModelBuilder.AddAssemblyResolver
C#
public void AddAssemblyResolver(
IAssemblyResolver resolver
)
C++
public:
void AddAssemblyResolver(
IAssemblyResolver resolver
) sealed
J#
public void AddAssemblyResolver(
IAssemblyResolver resolver
)
JScript
public function AddAssemblyResolver(
resolver : IAssemblyResolver
)

Parameters

resolver
The resolver to add

Implements

ITestModelBuilder.AddAssemblyResolver

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


CreateTopLevelTest Method

DefaultTestModelBuilder.CreateTopLevelTest Method
[image]

Creates a top-level test as a child of the root test and returns its builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTopLevelTest( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContextBuilder As ITestDataContextBuilder _
) As ITestBuilder _
Implements ITestModelBuilder.CreateTopLevelTest
C#
public ITestBuilder CreateTopLevelTest(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
C++
public:
ITestBuilder CreateTopLevelTest(
String name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
) sealed
J#
public ITestBuilder CreateTopLevelTest(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
JScript
public function CreateTopLevelTest(
name : String,
codeElement : ICodeElementInfo,
dataContextBuilder : ITestDataContextBuilder
) : ITestBuilder

Parameters

name
The test name
codeElement
The associated code element, or null if none
dataContextBuilder
The data context builder for the new test

Return Value

The builder for the top-level test

Implements

ITestModelBuilder.CreateTopLevelTest

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


GetTestModelBuilder Method

DefaultTestModelBuilder.GetTestModelBuilder Method
[image]

Gets the test model builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetTestModelBuilder() As ITestModelBuilder
C#
protected ITestModelBuilder GetTestModelBuilder()
C++
protected:
ITestModelBuilder GetTestModelBuilder() sealed
J#
protected ITestModelBuilder GetTestModelBuilder()
JScript
protected function GetTestModelBuilder() : ITestModelBuilder

Return Value

The test model builder

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


PublishExceptionAsAnnotation Method

DefaultTestModelBuilder.PublishExceptionAsAnnotation Method
[image]

Publishes an exception as an annotation about a particular code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub PublishExceptionAsAnnotation( _
ByVal codeElement As ICodeElementInfo, _
ByVal ex As Exception _
) _
Implements ITestModelBuilder.PublishExceptionAsAnnotation
C#
public void PublishExceptionAsAnnotation(
ICodeElementInfo codeElement,
Exception ex
)
C++
public:
void PublishExceptionAsAnnotation(
ICodeElementInfo codeElement,
Exception ex
) sealed
J#
public void PublishExceptionAsAnnotation(
ICodeElementInfo codeElement,
Exception ex
)
JScript
public function PublishExceptionAsAnnotation(
codeElement : ICodeElementInfo,
ex : Exception
)

Parameters

codeElement
The code element, or null if none
ex
The exception to publish

Implements

ITestModelBuilder.PublishExceptionAsAnnotation

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


ToTestModel Method

DefaultTestModelBuilder.ToTestModel Method
[image]

Gets the underlying test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToTestModel() As TestModel _
Implements ITestModelBuilder.ToTestModel
C#
public TestModel ToTestModel()
C++
public:
TestModel ToTestModel() sealed
J#
public TestModel ToTestModel()
JScript
public function ToTestModel() : TestModel

Return Value

The underlying test model

Implements

ITestModelBuilder.ToTestModel

See Also

DefaultTestModelBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestParameterBuilder Class

DefaultTestParameterBuilder Class
See Also Example Members
[image]

Default implementation of a test parameter builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestParameterBuilder
Inherits BaseTestComponentBuilder
Implements ITestParameterBuilder
C#
public class DefaultTestParameterBuilder : BaseTestComponentBuilder, ITestParameterBuilder
C++
ref class DefaultTestParameterBuilder : BaseTestComponentBuilder, ITestParameterBuilder
J#
public class DefaultTestParameterBuilder extends BaseTestComponentBuilder implements ITestParameterBuilder
JScript
public class DefaultTestParameterBuilder extends BaseTestComponentBuilder, ITestParameterBuilder

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BaseBuilder
Gallio.Framework.Pattern.BaseTestComponentBuilder
Gallio.Framework.Pattern.DefaultTestParameterBuilder

See Also

DefaultTestParameterBuilder Members
Gallio.Framework.Pattern Namespace


DefaultTestParameterBuilder Members

DefaultTestParameterBuilder Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a test parameter builder.

The following tables list the members exposed by DefaultTestParameterBuilder.

Public Constructors

 | Name | Description
Public method | DefaultTestParameterBuilder | Creates a test parameter builder.
Top

Public Properties

 | Name | Description
Public property | Binder | Gets or sets the data binder for the parameter.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponentBuilder)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestComponentBuilder)
Public property | Name | Gets or sets the name of the component. (inherited from BaseTestComponentBuilder)
Public property | TestParameterActions | Gets the set of actions that describe the behavior of the test parameter.
Top

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | AddMetadata | Adds a metadata key value pair. (inherited from BaseTestComponentBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTestComponent | Gets the underlying test component. (inherited from BaseTestComponentBuilder)
Public method | ToTestParameter | Gets the underlying test parameter.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestComponent | Gets the underlying test component.
Family method | GetTestModelBuilder | Gets the test model builder. (inherited from BaseTestComponentBuilder)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


DefaultTestParameterBuilder Constructor

DefaultTestParameterBuilder Constructor
[image]

Creates a test parameter builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModelBuilder As ITestModelBuilder, _
ByVal testParameter As PatternTestParameter _
)
C#
public DefaultTestParameterBuilder(
ITestModelBuilder testModelBuilder,
PatternTestParameter testParameter
)
C++
public:
DefaultTestParameterBuilder(
ITestModelBuilder testModelBuilder,
PatternTestParameter testParameter
) sealed
J#
public DefaultTestParameterBuilder(
ITestModelBuilder testModelBuilder,
PatternTestParameter testParameter
)
JScript
public function DefaultTestParameterBuilder(
testModelBuilder : ITestModelBuilder,
testParameter : PatternTestParameter
)

Parameters

testModelBuilder
The test model builder
testParameter
The underlying test parameter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModelBuilder or testParameter is null

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


Properties

DefaultTestParameterBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | Binder | Gets or sets the data binder for the parameter.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponentBuilder)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestComponentBuilder)
Public property | Name | Gets or sets the name of the component. (inherited from BaseTestComponentBuilder)
Public property | TestParameterActions | Gets the set of actions that describe the behavior of the test parameter.
Top

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


Binder Property

DefaultTestParameterBuilder.Binder Property
[image]

Gets or sets the data binder for the parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Binder As IDataBinder _
Implements ITestParameterBuilder.Binder
C#
public IDataBinder Binder { get; set; }
C++
public property IDataBinder Binder sealed {
IDataBinder get();
void set(IDataBinder value);
}
J#
/** property */
public IDataBinder get_Binder();

/** property */
public void set_Binder(IDataBinder value);
JScript
public function get Binder() : IDataBinder

public function set Binder(value : IDataBinder);

Implements

ITestParameterBuilder.Binder

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


TestParameterActions Property

DefaultTestParameterBuilder.TestParameterActions Property
[image]

Gets the set of actions that describe the behavior of the test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestParameterActions As PatternTestParameterActions _
Implements ITestParameterBuilder.TestParameterActions
C#
public PatternTestParameterActions TestParameterActions { get; }
C++
public property PatternTestParameterActions TestParameterActions sealed {
PatternTestParameterActions get();
}
J#
/** property */
public PatternTestParameterActions get_TestParameterActions();
JScript
public function get TestParameterActions() : PatternTestParameterActions

Implements

ITestParameterBuilder.TestParameterActions

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


Methods

DefaultTestParameterBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called. (inherited from BaseBuilder)
Public method | AddMetadata | Adds a metadata key value pair. (inherited from BaseTestComponentBuilder)
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list. (inherited from BaseBuilder)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ToTestComponent | Gets the underlying test component. (inherited from BaseTestComponentBuilder)
Public method | ToTestParameter | Gets the underlying test parameter.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetTestComponent | Gets the underlying test component.
Family method | GetTestModelBuilder | Gets the test model builder. (inherited from BaseTestComponentBuilder)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


GetTestComponent Method

DefaultTestParameterBuilder.GetTestComponent Method
[image]

Gets the underlying test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetTestComponent() As IPatternTestComponent
C#
protected IPatternTestComponent GetTestComponent()
C++
protected:
IPatternTestComponent GetTestComponent() sealed
J#
protected IPatternTestComponent GetTestComponent()
JScript
protected function GetTestComponent() : IPatternTestComponent

Return Value

The test component

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


ToTestParameter Method

DefaultTestParameterBuilder.ToTestParameter Method
[image]

Gets the underlying test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToTestParameter() As PatternTestParameter _
Implements ITestParameterBuilder.ToTestParameter
C#
public PatternTestParameter ToTestParameter()
C++
public:
PatternTestParameter ToTestParameter() sealed
J#
public PatternTestParameter ToTestParameter()
JScript
public function ToTestParameter() : PatternTestParameter

Return Value

The underlying test parameter

Implements

ITestParameterBuilder.ToTestParameter

See Also

DefaultTestParameterBuilder Class
Gallio.Framework.Pattern Namespace


DeferredComponentPopulator Delegate

DeferredComponentPopulator Delegate
[image]

Populates components lazily.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub DeferredComponentPopulator( _
ByVal codeElementHint As ICodeElementInfo _
)
C#
public delegate void DeferredComponentPopulator(
ICodeElementInfo codeElementHint
)
C++
public delegate void DeferredComponentPopulator(
ICodeElementInfo codeElementHint
)
J#
/** delegate */
public delegate void DeferredComponentPopulator(
ICodeElementInfo codeElementHint
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

codeElementHint
The code element hint to identify the location of the particular components to populate, or null to populate them all

Remarks

A populator function takes one parameter to specify a hint for the particular code element whose patterns should be processed to generate components. If the hint is null or unrecognized then the populator should proceed to generate all remaining components.

See Also

Gallio.Framework.Pattern Namespace


IPattern Interface

IPattern Interface
See Also Example Members
[image]

A IPattern defines a composable rule for building up a test model using reflection.

The general idea is that a pattern applies contributions to a IPatternScope that represents the state of the pattern interpretation process. A primary pattern adds contributions to its containing scope with the Consume method. All patterns (primary and non-primary) add further contributions to the pattern's own scope with the Process method.

A pattern can also defer some of its processing by registering a decorator on the scope. Once all of the decorators have been gathered, they can be applied in sorted order as required.

Pattern processing is performed recursively. First the primary pattern for the assembly is found. If none is registered then the default assembly pattern is used instead. The assembly pattern then performs reflection over the types within the assembly and hands off control (via Consume) to any primary patterns it finds each type. Likewise the types scan their members and call into their primary patterns. And so on. Each primary pattern is responsible for invoking (via Process) any additional non-primary patterns associated with their code element after they have established the appropriate evaluation scope.

Typically a pattern is associated with a code element by means of a PatternAttribute but other associations are possible. Some patterns might define default rules for recursively processing code elements that do not have primary patterns of their own. Others might use means other than standard reflection to discover the patterns to be applied. The process is intended to be open and extensible.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPattern
C#
public interface IPattern
C++
interface class IPattern
J#
public interface IPattern
JScript
public interface IPattern

Types that implement IPattern

Type | Description
Gallio.Framework.Pattern.BasePattern | Abstract base implementation of IPattern with do-nothing implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Framework.Pattern.PatternAttribute

The PatternAttribute class is the base class for all pattern test framework attributes. It associates a code element with a IPattern for building up parts of the test model using reflection.

Subclasses of IPattern define simpler interfaces for implementing the semantics of common types of attributes such as test factories, decorators, and data providers. Refer to the documentation of each subclass for details on its use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IPattern Members
Gallio.Framework.Pattern Namespace
PatternAttribute
PatternTestFramework


IPattern Members

IPattern Members
See Also Example Properties Methods
[image]

A IPattern defines a composable rule for building up a test model using reflection.

The general idea is that a pattern applies contributions to a IPatternScope that represents the state of the pattern interpretation process. A primary pattern adds contributions to its containing scope with the Consume method. All patterns (primary and non-primary) add further contributions to the pattern's own scope with the Process method.

A pattern can also defer some of its processing by registering a decorator on the scope. Once all of the decorators have been gathered, they can be applied in sorted order as required.

Pattern processing is performed recursively. First the primary pattern for the assembly is found. If none is registered then the default assembly pattern is used instead. The assembly pattern then performs reflection over the types within the assembly and hands off control (via Consume) to any primary patterns it finds each type. Likewise the types scan their members and call into their primary patterns. And so on. Each primary pattern is responsible for invoking (via Process) any additional non-primary patterns associated with their code element after they have established the appropriate evaluation scope.

Typically a pattern is associated with a code element by means of a PatternAttribute but other associations are possible. Some patterns might define default rules for recursively processing code elements that do not have primary patterns of their own. Others might use means other than standard reflection to discover the patterns to be applied. The process is intended to be open and extensible.

The following tables list the members exposed by IPattern.

Public Properties

Name Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Top

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace
PatternAttribute
PatternTestFramework


Properties

IPattern Properties
[image]

Public Properties

Name Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Top

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace
PatternAttribute
PatternTestFramework


IsPrimary Property

IPattern.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPrimary As Boolean
C#
bool IsPrimary { get; }
C++
property bool IsPrimary abstract {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace


Methods

IPattern Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Top

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace
PatternAttribute
PatternTestFramework


Consume Method

IPattern.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
)
C#
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) abstract
J#
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Exceptions

Exception Type | Condition
PatternUsageErrorException | May be thrown to halt processing of the pattern and report an error message to the user as an annotation that describes how the pattern was misapplied.

Remarks

This method is only called for primary patterns.

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace
IsPrimary


IsTest Method

IPattern.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean
C#
bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) abstract
J#
bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Exceptions

Exception Type | Condition
PatternUsageErrorException | May be thrown to halt processing of the pattern and report an error message to the user as an annotation that describes how the pattern was misapplied.

Remarks

This method is only called for primary patterns.

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace


IsTestPart Method

IPattern.IsTestPart Method
[image]

Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsTestPart( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean
C#
bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) abstract
J#
bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
function IsTestPart(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Exceptions

Exception Type | Condition
PatternUsageErrorException | May be thrown to halt processing of the pattern and report an error message to the user as an annotation that describes how the pattern was misapplied.

Remarks

This method is only called for primary patterns.

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace


Process Method

IPattern.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) abstract
J#
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Exceptions

Exception Type | Condition
PatternUsageErrorException | May be thrown to halt processing of the pattern and report an error message to the user as an annotation that describes how the pattern was misapplied.

See Also

IPattern Interface
Gallio.Framework.Pattern Namespace


IPatternEvaluator Interface

IPatternEvaluator Interface
See Also Example Members
[image]

A pattern evaluator maintains state that is needed to interpret patterns. It is used by the PatternTestExplorer to populate a TestModel during test enumeration.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternEvaluator
C#
public interface IPatternEvaluator
C++
interface class IPatternEvaluator
J#
public interface IPatternEvaluator
JScript
public interface IPatternEvaluator

Types that implement IPatternEvaluator

Type | Description
Gallio.Framework.Pattern.DefaultPatternEvaluator | Default implementation of a pattern evaluator.

See Also

IPatternEvaluator Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


IPatternEvaluator Members

IPatternEvaluator Members
See Also Example Properties Methods
[image]

A pattern evaluator maintains state that is needed to interpret patterns. It is used by the PatternTestExplorer to populate a TestModel during test enumeration.

The following tables list the members exposed by IPatternEvaluator.

Public Properties

 | Name | Description
Public property | TestModelBuilder | Gets the builder for the test model under construction.
Top

Public Methods

 | Name | Description
Public method | Consume | Consumes the specified code element.
Public method | CreateTopLevelTestScope | Creates a top-level test as a child of the root test. Returns the scope of the newly created top-level test.
Public method | GetDeclaredTests | Finds tests that are declared by the specified ICodeElementInfo.
Public method | GetPatterns | Gets all patterns associated with a code element.
Public method | GetPrimaryPattern | Gets the primary pattern associated with a code element, or null if none.
Public method | GetScopes | Finds scopes that are associated with the specified ICodeElementInfo and returns an enumeration of their IPatternScope objects.
Public method | HasPatterns | Returns true if a code element has one or more associated patterns.
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test.
Public method | Process | Processes the specified code element.
Public method | RegisterScope | Registers the scope so that it can be resolved later by GetScopes.
Top

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
PatternTestFramework


Properties

IPatternEvaluator Properties
[image]

Public Properties

 | Name | Description
Public property | TestModelBuilder | Gets the builder for the test model under construction.
Top

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
PatternTestFramework


TestModelBuilder Property

IPatternEvaluator.TestModelBuilder Property
[image]

Gets the builder for the test model under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestModelBuilder As ITestModelBuilder
C#
ITestModelBuilder TestModelBuilder { get; }
C++
property ITestModelBuilder TestModelBuilder abstract {
ITestModelBuilder get();
}
J#
/** property */
public ITestModelBuilder get_TestModelBuilder();
JScript
public function get TestModelBuilder() : ITestModelBuilder

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternEvaluator Methods
[image]

Public Methods

 | Name | Description
Public method | Consume | Consumes the specified code element.
Public method | CreateTopLevelTestScope | Creates a top-level test as a child of the root test. Returns the scope of the newly created top-level test.
Public method | GetDeclaredTests | Finds tests that are declared by the specified ICodeElementInfo.
Public method | GetPatterns | Gets all patterns associated with a code element.
Public method | GetPrimaryPattern | Gets the primary pattern associated with a code element, or null if none.
Public method | GetScopes | Finds scopes that are associated with the specified ICodeElementInfo and returns an enumeration of their IPatternScope objects.
Public method | HasPatterns | Returns true if a code element has one or more associated patterns.
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test.
Public method | Process | Processes the specified code element.
Public method | RegisterScope | Registers the scope so that it can be resolved later by GetScopes.
Top

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
PatternTestFramework


Consume Method

IPatternEvaluator.Consume Method
[image]

Consumes the specified code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean, _
ByVal defaultPrimaryPattern As IPattern _
)
C#
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
C++
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
) abstract
J#
void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
JScript
function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool,
defaultPrimaryPattern : IPattern
)

Parameters

containingScope
The containing scope
codeElement
The code element to consume
skipChildren
If true, instructs the primary pattern to defer populating child tests
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if containingScope or codeElement is null

Remarks

Any exceptions thrown by a pattern are caught and manifested as annotations associated with the code element.

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
PatternUsageErrorException
Consume


CreateTopLevelTestScope Method

IPatternEvaluator.CreateTopLevelTestScope Method
[image]

Creates a top-level test as a child of the root test. Returns the scope of the newly created top-level test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTopLevelTestScope( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope
C#
IPatternScope CreateTopLevelTestScope(
string name,
ICodeElementInfo codeElement
)
C++
IPatternScope CreateTopLevelTestScope(
String name,
ICodeElementInfo codeElement
) abstract
J#
IPatternScope CreateTopLevelTestScope(
string name,
ICodeElementInfo codeElement
)
JScript
function CreateTopLevelTestScope(
name : String,
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

name
The test name
codeElement
The associated code element, or null if none

Return Value

The builder for the top-level test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


GetDeclaredTests Method

IPatternEvaluator.GetDeclaredTests Method
[image]

Finds tests that are declared by the specified ICodeElementInfo.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetDeclaredTests( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of PatternTest)
C#
IEnumerable<PatternTest> GetDeclaredTests(
ICodeElementInfo codeElement
)
C++
IEnumerable<PatternTest> GetDeclaredTests(
ICodeElementInfo codeElement
) abstract
J#
IEnumerable<PatternTest> GetDeclaredTests(
ICodeElementInfo codeElement
)
JScript
function GetDeclaredTests(
codeElement : ICodeElementInfo
) : IEnumerable<PatternTest>

Parameters

codeElement
The code element

Return Value

The enumeration of tests

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


GetPatterns Method

IPatternEvaluator.GetPatterns Method
[image]

Gets all patterns associated with a code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetPatterns( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of IPattern)
C#
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
C++
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
) abstract
J#
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
JScript
function GetPatterns(
codeElement : ICodeElementInfo
) : IEnumerable<IPattern>

Parameters

codeElement
The code element

Return Value

The enumeration of patterns, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


GetPrimaryPattern Method

IPatternEvaluator.GetPrimaryPattern Method
[image]

Gets the primary pattern associated with a code element, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetPrimaryPattern( _
ByVal codeElement As ICodeElementInfo _
) As IPattern
C#
IPattern GetPrimaryPattern(
ICodeElementInfo codeElement
)
C++
IPattern GetPrimaryPattern(
ICodeElementInfo codeElement
) abstract
J#
IPattern GetPrimaryPattern(
ICodeElementInfo codeElement
)
JScript
function GetPrimaryPattern(
codeElement : ICodeElementInfo
) : IPattern

Parameters

codeElement
The code element

Return Value

The primary pattern, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null
PatternUsageErrorException | Thrown if there are multiple primary patterns associated with the code element

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


GetScopes Method

IPatternEvaluator.GetScopes Method
[image]

Finds scopes that are associated with the specified ICodeElementInfo and returns an enumeration of their IPatternScope objects.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetScopes( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of IPatternScope)
C#
IEnumerable<IPatternScope> GetScopes(
ICodeElementInfo codeElement
)
C++
IEnumerable<IPatternScope> GetScopes(
ICodeElementInfo codeElement
) abstract
J#
IEnumerable<IPatternScope> GetScopes(
ICodeElementInfo codeElement
)
JScript
function GetScopes(
codeElement : ICodeElementInfo
) : IEnumerable<IPatternScope>

Parameters

codeElement
The code element

Return Value

The enumeration of scopes

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


HasPatterns Method

IPatternEvaluator.HasPatterns Method
[image]

Returns true if a code element has one or more associated patterns.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function HasPatterns( _
ByVal codeElement As ICodeElementInfo _
) As Boolean
C#
bool HasPatterns(
ICodeElementInfo codeElement
)
C++
bool HasPatterns(
ICodeElementInfo codeElement
) abstract
J#
bool HasPatterns(
ICodeElementInfo codeElement
)
JScript
function HasPatterns(
codeElement : ICodeElementInfo
) : bool

Parameters

codeElement
The code element

Return Value

True if the code element has an associated pattern

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


IsTest Method

IPatternEvaluator.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsTest( _
ByVal codeElement As ICodeElementInfo, _
ByVal defaultPrimaryPattern As IPattern _
) As Boolean
C#
bool IsTest(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
C++
bool IsTest(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
) abstract
J#
bool IsTest(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
JScript
function IsTest(
codeElement : ICodeElementInfo,
defaultPrimaryPattern : IPattern
) : bool

Parameters

codeElement
The code element
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Return Value

True if the code element represents a test

Remarks

If an exception occurs, this method returns false.

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
IsTest


IsTestPart Method

IPatternEvaluator.IsTestPart Method
[image]

Returns true if the code element represents a part of a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsTestPart( _
ByVal codeElement As ICodeElementInfo, _
ByVal defaultPrimaryPattern As IPattern _
) As Boolean
C#
bool IsTestPart(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
C++
bool IsTestPart(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
) abstract
J#
bool IsTestPart(
ICodeElementInfo codeElement,
IPattern defaultPrimaryPattern
)
JScript
function IsTestPart(
codeElement : ICodeElementInfo,
defaultPrimaryPattern : IPattern
) : bool

Parameters

codeElement
The code element
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Return Value

True if the code element represents a test

Remarks

If an exception occurs, this method returns false.

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
IsTest


Process Method

IPatternEvaluator.Process Method
[image]

Processes the specified code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) abstract
J#
void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

Remarks

Any exceptions thrown by a pattern are caught and manifested as annotations associated with the code element.

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace
PatternUsageErrorException
Process


RegisterScope Method

IPatternEvaluator.RegisterScope Method
[image]

Registers the scope so that it can be resolved later by GetScopes.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterScope( _
ByVal scope As IPatternScope _
)
C#
void RegisterScope(
IPatternScope scope
)
C++
void RegisterScope(
IPatternScope scope
) abstract
J#
void RegisterScope(
IPatternScope scope
)
JScript
function RegisterScope(
scope : IPatternScope
)

Parameters

scope
The scope

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if scope is null

See Also

IPatternEvaluator Interface
Gallio.Framework.Pattern Namespace


IPatternResolver Interface

IPatternResolver Interface
See Also Example Members
[image]

The pattern resolver provides a means for obtaining the IPattern objects associated with an ICodeElementInfo.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternResolver
C#
public interface IPatternResolver
C++
interface class IPatternResolver
J#
public interface IPatternResolver
JScript
public interface IPatternResolver

Types that implement IPatternResolver

Type | Description
Gallio.Framework.Pattern.DeclarativePatternResolver | A declarative pattern resolver based on PatternAttribute. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

See Also

IPatternResolver Members
Gallio.Framework.Pattern Namespace


IPatternResolver Members

IPatternResolver Members
See Also Example Methods
[image]

The pattern resolver provides a means for obtaining the IPattern objects associated with an ICodeElementInfo.

The following tables list the members exposed by IPatternResolver.

Public Methods

 | Name | Description
Public method | GetPatterns | Gets the patterns associated with the specified code element.
Top

See Also

IPatternResolver Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternResolver Methods
[image]

Public Methods

 | Name | Description
Public method | GetPatterns | Gets the patterns associated with the specified code element.
Top

See Also

IPatternResolver Interface
Gallio.Framework.Pattern Namespace


GetPatterns Method

IPatternResolver.GetPatterns Method
[image]

Gets the patterns associated with the specified code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetPatterns( _
ByVal codeElement As ICodeElementInfo _
) As IEnumerable(Of IPattern)
C#
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
C++
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
) abstract
J#
IEnumerable<IPattern> GetPatterns(
ICodeElementInfo codeElement
)
JScript
function GetPatterns(
codeElement : ICodeElementInfo
) : IEnumerable<IPattern>

Parameters

codeElement
The code element

Return Value

The enumeration of patterns

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

IPatternResolver Interface
Gallio.Framework.Pattern Namespace


IPatternScope Interface

IPatternScope Interface
See Also Example Members
[image]

A pattern scope describes the environment in which the pattern is being evaluated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternScope
C#
public interface IPatternScope
C++
interface class IPatternScope
J#
public interface IPatternScope
JScript
public interface IPatternScope

Types that implement IPatternScope

Type | Description
Gallio.Framework.Pattern.DefaultPatternScope | Default implementation of a pattern scope.

Remarks

A pattern is always evaluated in some scope which determines its ultimate effect on declarations of tests, test parameters and test data contexts.

See Also

IPatternScope Members
Gallio.Framework.Pattern Namespace


IPatternScope Members

IPatternScope Members
See Also Example Properties Methods
[image]

A pattern scope describes the environment in which the pattern is being evaluated.

The following tables list the members exposed by IPatternScope.

Public Properties

 | Name | Description
Public property | CanAddChildTest | Returns true if a child test can be added to the test within scope.
Public property | CanAddTestParameter | Returns true if a test parameter can be added to the test within scope.
Public property | CodeElement | Gets the code element associated with the scope, or null if none.
Public property | Evaluator | Gets the pattern evaluator.
Public property | IsTestDeclaration | Returns true if the scope represents a test declaration. An arbitrary scope nested within a test declaration scope is not itself considered a test declaration scope unless it also represents a test declaration.
Public property | IsTestParameterDeclaration | Returns true if the scope represents a test parameter declaration. An arbitrary scope nested within a test parameter declaration scope is not itself considered a test parameter declaration scope unless it also represents a test parameter declaration.
Public property | TestBuilder | Gets a builder for applying contributions to the test currently being constructed within this scope. Never null.
Public property | TestComponentBuilder | Gets a builder for applying contributions to the test component currently being constructed within this scope.
Public property | TestDataContextBuilder | Gets a builder for applying contributions to the current test data context within the scope.
Public property | TestModelBuilder | Gets a builder for applying contributions to the test model.
Public property | TestParameterBuilder | Gets a builder for applying contributions to the test parameter currently being constructed within this scope, if there is one, or null if there is no test parameter in scope.
Top

Public Methods

 | Name | Description
Public method | AddDeferredComponentPopulator | Adds an action to the scope that enables a pattern to lazily populate the test model with components generated in nested scopes. This is used when Consume is called with the option to skip children.
Public method | Consume | Consumes the specified code element using this scope as the containing scope.
Public method | CreateChildTestDataContextScope | Creates a child test data context derived from the builders of this scope. Returns the scope of the newly created child test data context.
Public method | CreateChildTestScope | Creates a child test with its own child data context derived from the builders of this scope. Returns the scope of the newly created child test.
Public method | CreateScope | Creates and registers a scope for a test component.
Public method | CreateTestParameterScope | Creates a test parameter for the test in scope with its own child data context derived from the builders of this scope. Returns the scope of the newly created test parameter.
Public method | PopulateDeferredComponents | Asks all registered deferred component populators to build components whose construction had previously been deferred.
Public method | Process | Processes the specified code element using this scope as the current scope.
Top

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


Properties

IPatternScope Properties
[image]

Public Properties

 | Name | Description
Public property | CanAddChildTest | Returns true if a child test can be added to the test within scope.
Public property | CanAddTestParameter | Returns true if a test parameter can be added to the test within scope.
Public property | CodeElement | Gets the code element associated with the scope, or null if none.
Public property | Evaluator | Gets the pattern evaluator.
Public property | IsTestDeclaration | Returns true if the scope represents a test declaration. An arbitrary scope nested within a test declaration scope is not itself considered a test declaration scope unless it also represents a test declaration.
Public property | IsTestParameterDeclaration | Returns true if the scope represents a test parameter declaration. An arbitrary scope nested within a test parameter declaration scope is not itself considered a test parameter declaration scope unless it also represents a test parameter declaration.
Public property | TestBuilder | Gets a builder for applying contributions to the test currently being constructed within this scope. Never null.
Public property | TestComponentBuilder | Gets a builder for applying contributions to the test component currently being constructed within this scope.
Public property | TestDataContextBuilder | Gets a builder for applying contributions to the current test data context within the scope.
Public property | TestModelBuilder | Gets a builder for applying contributions to the test model.
Public property | TestParameterBuilder | Gets a builder for applying contributions to the test parameter currently being constructed within this scope, if there is one, or null if there is no test parameter in scope.
Top

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CanAddChildTest Property

IPatternScope.CanAddChildTest Property
[image]

Returns true if a child test can be added to the test within scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanAddChildTest As Boolean
C#
bool CanAddChildTest { get; }
C++
property bool CanAddChildTest abstract {
bool get();
}
J#
/** property */
public bool get_CanAddChildTest();
JScript
public function get CanAddChildTest() : bool

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CanAddTestParameter Property

IPatternScope.CanAddTestParameter Property
[image]

Returns true if a test parameter can be added to the test within scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanAddTestParameter As Boolean
C#
bool CanAddTestParameter { get; }
C++
property bool CanAddTestParameter abstract {
bool get();
}
J#
/** property */
public bool get_CanAddTestParameter();
JScript
public function get CanAddTestParameter() : bool

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CodeElement Property

IPatternScope.CodeElement Property
[image]

Gets the code element associated with the scope, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CodeElement As ICodeElementInfo
C#
ICodeElementInfo CodeElement { get; }
C++
property ICodeElementInfo CodeElement abstract {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


Evaluator Property

IPatternScope.Evaluator Property
[image]

Gets the pattern evaluator.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Evaluator As IPatternEvaluator
C#
IPatternEvaluator Evaluator { get; }
C++
property IPatternEvaluator Evaluator abstract {
IPatternEvaluator get();
}
J#
/** property */
public IPatternEvaluator get_Evaluator();
JScript
public function get Evaluator() : IPatternEvaluator

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


IsTestDeclaration Property

IPatternScope.IsTestDeclaration Property
[image]

Returns true if the scope represents a test declaration.

An arbitrary scope nested within a test declaration scope is not itself considered a test declaration scope unless it also represents a test declaration.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsTestDeclaration As Boolean
C#
bool IsTestDeclaration { get; }
C++
property bool IsTestDeclaration abstract {
bool get();
}
J#
/** property */
public bool get_IsTestDeclaration();
JScript
public function get IsTestDeclaration() : bool

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


IsTestParameterDeclaration Property

IPatternScope.IsTestParameterDeclaration Property
[image]

Returns true if the scope represents a test parameter declaration.

An arbitrary scope nested within a test parameter declaration scope is not itself considered a test parameter declaration scope unless it also represents a test parameter declaration.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsTestParameterDeclaration As Boolean
C#
bool IsTestParameterDeclaration { get; }
C++
property bool IsTestParameterDeclaration abstract {
bool get();
}
J#
/** property */
public bool get_IsTestParameterDeclaration();
JScript
public function get IsTestParameterDeclaration() : bool

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


TestBuilder Property

IPatternScope.TestBuilder Property
[image]

Gets a builder for applying contributions to the test currently being constructed within this scope. Never null.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestBuilder As ITestBuilder
C#
ITestBuilder TestBuilder { get; }
C++
property ITestBuilder TestBuilder abstract {
ITestBuilder get();
}
J#
/** property */
public ITestBuilder get_TestBuilder();
JScript
public function get TestBuilder() : ITestBuilder

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


TestComponentBuilder Property

IPatternScope.TestComponentBuilder Property
[image]

Gets a builder for applying contributions to the test component currently being constructed within this scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestComponentBuilder As ITestComponentBuilder
C#
ITestComponentBuilder TestComponentBuilder { get; }
C++
property ITestComponentBuilder TestComponentBuilder abstract {
ITestComponentBuilder get();
}
J#
/** property */
public ITestComponentBuilder get_TestComponentBuilder();
JScript
public function get TestComponentBuilder() : ITestComponentBuilder

Remarks

The component may be a test or a test parameter. It will never be null.

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


TestDataContextBuilder Property

IPatternScope.TestDataContextBuilder Property
[image]

Gets a builder for applying contributions to the current test data context within the scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestDataContextBuilder As ITestDataContextBuilder
C#
ITestDataContextBuilder TestDataContextBuilder { get; }
C++
property ITestDataContextBuilder TestDataContextBuilder abstract {
ITestDataContextBuilder get();
}
J#
/** property */
public ITestDataContextBuilder get_TestDataContextBuilder();
JScript
public function get TestDataContextBuilder() : ITestDataContextBuilder

Remarks

A test data context is essentially a lexically scoped environment for the declaration of data sources used by parameterized tests.

Typically a new data context will be introduced at the point of declaration of a test or test parameter, but it may also be introduced by other lexical scopes. For example, a test fixture constructor may declare a new test data context which provides data sources that can be used for data binding by the constructor's parameters (but are not visible to any other part of the fixture).

Since there is always a test component in scope, the test data context builder can never be null.

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


TestModelBuilder Property

IPatternScope.TestModelBuilder Property
[image]

Gets a builder for applying contributions to the test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestModelBuilder As ITestModelBuilder
C#
ITestModelBuilder TestModelBuilder { get; }
C++
property ITestModelBuilder TestModelBuilder abstract {
ITestModelBuilder get();
}
J#
/** property */
public ITestModelBuilder get_TestModelBuilder();
JScript
public function get TestModelBuilder() : ITestModelBuilder

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


TestParameterBuilder Property

IPatternScope.TestParameterBuilder Property
[image]

Gets a builder for applying contributions to the test parameter currently being constructed within this scope, if there is one, or null if there is no test parameter in scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestParameterBuilder As ITestParameterBuilder
C#
ITestParameterBuilder TestParameterBuilder { get; }
C++
property ITestParameterBuilder TestParameterBuilder abstract {
ITestParameterBuilder get();
}
J#
/** property */
public ITestParameterBuilder get_TestParameterBuilder();
JScript
public function get TestParameterBuilder() : ITestParameterBuilder

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternScope Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredComponentPopulator | Adds an action to the scope that enables a pattern to lazily populate the test model with components generated in nested scopes. This is used when Consume is called with the option to skip children.
Public method | Consume | Consumes the specified code element using this scope as the containing scope.
Public method | CreateChildTestDataContextScope | Creates a child test data context derived from the builders of this scope. Returns the scope of the newly created child test data context.
Public method | CreateChildTestScope | Creates a child test with its own child data context derived from the builders of this scope. Returns the scope of the newly created child test.
Public method | CreateScope | Creates and registers a scope for a test component.
Public method | CreateTestParameterScope | Creates a test parameter for the test in scope with its own child data context derived from the builders of this scope. Returns the scope of the newly created test parameter.
Public method | PopulateDeferredComponents | Asks all registered deferred component populators to build components whose construction had previously been deferred.
Public method | Process | Processes the specified code element using this scope as the current scope.
Top

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


AddDeferredComponentPopulator Method

IPatternScope.AddDeferredComponentPopulator Method
[image]

Adds an action to the scope that enables a pattern to lazily populate the test model with components generated in nested scopes. This is used when Consume is called with the option to skip children.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddDeferredComponentPopulator( _
ByVal populator As DeferredComponentPopulator _
)
C#
void AddDeferredComponentPopulator(
DeferredComponentPopulator populator
)
C++
void AddDeferredComponentPopulator(
DeferredComponentPopulator populator
) abstract
J#
void AddDeferredComponentPopulator(
DeferredComponentPopulator populator
)
JScript
function AddDeferredComponentPopulator(
populator : DeferredComponentPopulator
)

Parameters

populator
A DeferredComponentPopulator supplied by the pattern to populate its components lazily

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if populator is null

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace
PopulateDeferredComponents


Consume Method

IPatternScope.Consume Method
[image]

Consumes the specified code element using this scope as the containing scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Consume( _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean, _
ByVal defaultPrimaryPattern As IPattern _
)
C#
void Consume(
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
C++
void Consume(
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
) abstract
J#
void Consume(
ICodeElementInfo codeElement,
bool skipChildren,
IPattern defaultPrimaryPattern
)
JScript
function Consume(
codeElement : ICodeElementInfo,
skipChildren : bool,
defaultPrimaryPattern : IPattern
)

Parameters

codeElement
The code element to consume
skipChildren
If true, instructs the primary pattern to defer populating child tests
defaultPrimaryPattern
The default primary pattern to use, if none can be resolved for the code element. May be null if none.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

Remarks

This is a convenience method that calls Consume.

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CreateChildTestDataContextScope Method

IPatternScope.CreateChildTestDataContextScope Method
[image]

Creates a child test data context derived from the builders of this scope. Returns the scope of the newly created child test data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateChildTestDataContextScope( _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope
C#
IPatternScope CreateChildTestDataContextScope(
ICodeElementInfo codeElement
)
C++
IPatternScope CreateChildTestDataContextScope(
ICodeElementInfo codeElement
) abstract
J#
IPatternScope CreateChildTestDataContextScope(
ICodeElementInfo codeElement
)
JScript
function CreateChildTestDataContextScope(
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

codeElement
The associated code element, or null if none

Return Value

The scope of the newly created child test data context

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CreateChildTestScope Method

IPatternScope.CreateChildTestScope Method
[image]

Creates a child test with its own child data context derived from the builders of this scope. Returns the scope of the newly created child test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateChildTestScope( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope
C#
IPatternScope CreateChildTestScope(
string name,
ICodeElementInfo codeElement
)
C++
IPatternScope CreateChildTestScope(
String name,
ICodeElementInfo codeElement
) abstract
J#
IPatternScope CreateChildTestScope(
string name,
ICodeElementInfo codeElement
)
JScript
function CreateChildTestScope(
name : String,
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

name
The test name
codeElement
The associated code element, or null if none

Return Value

The scope of the newly created child test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null
PatternUsageErrorException | Thrown if CanAddChildTest is null

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CreateScope Method

IPatternScope.CreateScope Method
[image]

Creates and registers a scope for a test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateScope( _
ByVal codeElement As ICodeElementInfo, _
ByVal testBuilder As ITestBuilder, _
ByVal testParameterBuilder As ITestParameterBuilder, _
ByVal testDataContextBuilder As ITestDataContextBuilder, _
ByVal isDeclaration As Boolean _
) As IPatternScope
C#
IPatternScope CreateScope(
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
)
C++
IPatternScope CreateScope(
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
) abstract
J#
IPatternScope CreateScope(
ICodeElementInfo codeElement,
ITestBuilder testBuilder,
ITestParameterBuilder testParameterBuilder,
ITestDataContextBuilder testDataContextBuilder,
bool isDeclaration
)
JScript
function CreateScope(
codeElement : ICodeElementInfo,
testBuilder : ITestBuilder,
testParameterBuilder : ITestParameterBuilder,
testDataContextBuilder : ITestDataContextBuilder,
isDeclaration : bool
) : IPatternScope

Parameters

codeElement
The code element to associate with the scope
testBuilder
The test builder
testParameterBuilder
The test parameter builder, or null if the scope is to be associated to the test only
testDataContextBuilder
The test data context builder
isDeclaration
If true, the scope represents the point of declaration of the test component with which it is associated

Return Value

The new scope

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement, testBuilder, testParameterBuilder or testDataContextBuilder is null

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


CreateTestParameterScope Method

IPatternScope.CreateTestParameterScope Method
[image]

Creates a test parameter for the test in scope with its own child data context derived from the builders of this scope. Returns the scope of the newly created test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTestParameterScope( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As IPatternScope
C#
IPatternScope CreateTestParameterScope(
string name,
ICodeElementInfo codeElement
)
C++
IPatternScope CreateTestParameterScope(
String name,
ICodeElementInfo codeElement
) abstract
J#
IPatternScope CreateTestParameterScope(
string name,
ICodeElementInfo codeElement
)
JScript
function CreateTestParameterScope(
name : String,
codeElement : ICodeElementInfo
) : IPatternScope

Parameters

name
The test parameter name
codeElement
The associated code element, or null if none

Return Value

The scope of the newly created test parameter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null
PatternUsageErrorException | Thrown if CanAddTestParameter is null

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


PopulateDeferredComponents Method

IPatternScope.PopulateDeferredComponents Method
[image]

Asks all registered deferred component populators to build components whose construction had previously been deferred.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub PopulateDeferredComponents( _
ByVal codeElementHint As ICodeElementInfo _
)
C#
void PopulateDeferredComponents(
ICodeElementInfo codeElementHint
)
C++
void PopulateDeferredComponents(
ICodeElementInfo codeElementHint
) abstract
J#
void PopulateDeferredComponents(
ICodeElementInfo codeElementHint
)
JScript
function PopulateDeferredComponents(
codeElementHint : ICodeElementInfo
)

Parameters

codeElementHint
The code element hint to identify the location of the particular components to populate, or null to populate them all

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace
AddDeferredComponentPopulator


Process Method

IPatternScope.Process Method
[image]

Processes the specified code element using this scope as the current scope.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Process( _
ByVal codeElement As ICodeElementInfo _
)
C#
void Process(
ICodeElementInfo codeElement
)
C++
void Process(
ICodeElementInfo codeElement
) abstract
J#
void Process(
ICodeElementInfo codeElement
)
JScript
function Process(
codeElement : ICodeElementInfo
)

Parameters

codeElement
The code element to process

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

Remarks

This is a convenience method that calls Process.

See Also

IPatternScope Interface
Gallio.Framework.Pattern Namespace


IPatternTestComponent Interface

IPatternTestComponent Interface
See Also Example Members
[image]

An interface shared by PatternTest and PatternTestParameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternTestComponent
Implements ITestComponent
C#
public interface IPatternTestComponent : ITestComponent
C++
interface class IPatternTestComponent : ITestComponent
J#
public interface IPatternTestComponent implements ITestComponent
JScript
public interface IPatternTestComponent extends ITestComponent

Types that implement IPatternTestComponent

Type | Description
Gallio.Framework.Pattern.PatternTest | A test case that has been defined by the PatternTestFramework.
Gallio.Framework.Pattern.PatternTestParameter | Represents an parameter of a PatternTest derived from a field, property or method parameter.

See Also

IPatternTestComponent Members
Gallio.Framework.Pattern Namespace


IPatternTestComponent Members

IPatternTestComponent Members
See Also Example Properties Methods
[image]

An interface shared by PatternTest and PatternTestParameter.

The following tables list the members exposed by IPatternTestComponent.

Public Properties

 | Name | Description
Public property | DataContext | Gets the data context of the component.
Top

Public Methods

 | Name | Description
Public method | SetName | Sets the name of the component.
Top

See Also

IPatternTestComponent Interface
Gallio.Framework.Pattern Namespace


Properties

IPatternTestComponent Properties
[image]

Public Properties

 | Name | Description
Public property | DataContext | Gets the data context of the component.
Top

See Also

IPatternTestComponent Interface
Gallio.Framework.Pattern Namespace


DataContext Property

IPatternTestComponent.DataContext Property
[image]

Gets the data context of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DataContext As PatternTestDataContext
C#
PatternTestDataContext DataContext { get; }
C++
property PatternTestDataContext DataContext abstract {
PatternTestDataContext get();
}
J#
/** property */
public PatternTestDataContext get_DataContext();
JScript
public function get DataContext() : PatternTestDataContext

See Also

IPatternTestComponent Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternTestComponent Methods
[image]

Public Methods

 | Name | Description
Public method | SetName | Sets the name of the component.
Top

See Also

IPatternTestComponent Interface
Gallio.Framework.Pattern Namespace


SetName Method

IPatternTestComponent.SetName Method
[image]

Sets the name of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetName( _
ByVal value As String _
)
C#
void SetName(
string value
)
C++
void SetName(
String value
) abstract
J#
void SetName(
string value
)
JScript
function SetName(
value : String
)

See Also

IPatternTestComponent Interface
Gallio.Framework.Pattern Namespace


IPatternTestFrameworkExtension Interface

IPatternTestFrameworkExtension Interface
See Also Example Members
[image]

A pattern test framework extension provides the opportunity to extend the standard pattern test framework with additional behaviors.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternTestFrameworkExtension
C#
public interface IPatternTestFrameworkExtension
C++
interface class IPatternTestFrameworkExtension
J#
public interface IPatternTestFrameworkExtension
JScript
public interface IPatternTestFrameworkExtension

Types that implement IPatternTestFrameworkExtension

Type | Description
Gallio.Framework.Pattern.BasePatternTestFrameworkExtension | A base implementation of IPatternTestFrameworkExtension that does nothing.

See Also

IPatternTestFrameworkExtension Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


IPatternTestFrameworkExtension Members

IPatternTestFrameworkExtension Members
See Also Example Methods
[image]

A pattern test framework extension provides the opportunity to extend the standard pattern test framework with additional behaviors.

The following tables list the members exposed by IPatternTestFrameworkExtension.

Public Methods

Name Description
Public method GetReferencedTools

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Top

See Also

IPatternTestFrameworkExtension Interface
Gallio.Framework.Pattern Namespace
PatternTestFramework


Methods

IPatternTestFrameworkExtension Methods
[image]

Public Methods

Name Description
Public method GetReferencedTools

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Top

See Also

IPatternTestFrameworkExtension Interface
Gallio.Framework.Pattern Namespace
PatternTestFramework


GetReferencedTools Method

IPatternTestFrameworkExtension.GetReferencedTools Method
[image]

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetReferencedTools( _
ByVal assembly As IAssemblyInfo _
) As IEnumerable(Of ToolInfo)
C#
IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
C++
IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
) abstract
J#
IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
JScript
function GetReferencedTools(
assembly : IAssemblyInfo
) : IEnumerable<ToolInfo>

Parameters

assembly
The test assembly

Return Value

The tool information

See Also

IPatternTestFrameworkExtension Interface
Gallio.Framework.Pattern Namespace


IPatternTestHandler Interface

IPatternTestHandler Interface
See Also Example Members
[image]

A pattern test handler provides the logic that implements the various phases of the test execution lifecycle.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternTestHandler
C#
public interface IPatternTestHandler
C++
interface class IPatternTestHandler
J#
public interface IPatternTestHandler
JScript
public interface IPatternTestHandler

Types that implement IPatternTestHandler

Type Description
Gallio.Framework.Pattern.PatternTestActions

An implementation of IPatternTestHandler based on actions that can be sequenced and composed as chains.

This class is the backbone of the PatternTestFramework extensibility model. Because new behaviors can be defined and added to action chains at will by any component that participates in the test construction process (typically an IPattern), the framework itself does not need to hardcode the mechanism by which the behaviors are selected.

Remarks

Each method represents the behavior to be performed during a particular phase. Different actions are permitted during each phase. Consult the documentation the appropriate method of this interface for restrictions.

The phases generally run in the following order. Some phases may be skipped due to exceptions or if there is no work to be done.

  • BeforeTest
  • InitializeTest
  • -- for each test instance --
  • DecorateTestInstance
  • Run the actions in the decorated IPatternTestInstanceHandler
  • -- end --
  • DisposeTest
  • AfterTest

See Also

IPatternTestHandler Members
Gallio.Framework.Pattern Namespace


IPatternTestHandler Members

IPatternTestHandler Members
See Also Example Properties Methods
[image]

A pattern test handler provides the logic that implements the various phases of the test execution lifecycle.

The following tables list the members exposed by IPatternTestHandler.

Public Properties

 | Name | Description
Public property | TestInstanceHandler | Gets the test instance handler that describes the lifecycle of a test instance.
Top

Public Methods

Name Description
Public method AfterTest

Cleans up a completed test state after its use.

This method runs in the TestContext of its containing test step because the test has terminated.

The following actions are typically performed during this phase:

  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTest

Prepares a newly created test state before its use.

This method runs in the TestContext of its containing test step because the test has not yet been started.

The following actions are typically performed during this phase:

  • Configuring the PrimaryTestStep in anticipation of test execution.
  • Accessing user data via Data.
  • Skipping the test by throwing an appropriate SilentTestException.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
Public method DecorateTestInstance

Decorates the IPatternTestHandler of a test instance before its BeforeTestInstance actions have a chance to run.

This method runs in the TestContext of its containing test instance because the test has not yet been started.

This method may apply any number of decorations to the test instance's handler by adding actions to the supplied decoratedTestInstanceActions object. The test instance's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

The following actions are typically performed during this phase:

  • Adding additional actions for the test instance to the decoratedTestInstanceActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
  • Modifying the PatternTestState object in any way.
Public method DisposeTest

Cleans up a test following the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method InitializeTest

Initializes a test prior to the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Aborting the test run if any preconditions have not been satisfied or if the test is to be skipped.
  • Configuring the test environment in advance of the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Top

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


Properties

IPatternTestHandler Properties
[image]

Public Properties

 | Name | Description
Public property | TestInstanceHandler | Gets the test instance handler that describes the lifecycle of a test instance.
Top

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


TestInstanceHandler Property

IPatternTestHandler.TestInstanceHandler Property
[image]

Gets the test instance handler that describes the lifecycle of a test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestInstanceHandler As IPatternTestInstanceHandler
C#
IPatternTestInstanceHandler TestInstanceHandler { get; }
C++
property IPatternTestInstanceHandler TestInstanceHandler abstract {
IPatternTestInstanceHandler get();
}
J#
/** property */
public IPatternTestInstanceHandler get_TestInstanceHandler();
JScript
public function get TestInstanceHandler() : IPatternTestInstanceHandler

Remarks

These actions may be further decorated on a per-instance basis using DecorateTestInstance.

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternTestHandler Methods
[image]

Public Methods

Name Description
Public method AfterTest

Cleans up a completed test state after its use.

This method runs in the TestContext of its containing test step because the test has terminated.

The following actions are typically performed during this phase:

  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTest

Prepares a newly created test state before its use.

This method runs in the TestContext of its containing test step because the test has not yet been started.

The following actions are typically performed during this phase:

  • Configuring the PrimaryTestStep in anticipation of test execution.
  • Accessing user data via Data.
  • Skipping the test by throwing an appropriate SilentTestException.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
Public method DecorateTestInstance

Decorates the IPatternTestHandler of a test instance before its BeforeTestInstance actions have a chance to run.

This method runs in the TestContext of its containing test instance because the test has not yet been started.

This method may apply any number of decorations to the test instance's handler by adding actions to the supplied decoratedTestInstanceActions object. The test instance's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

The following actions are typically performed during this phase:

  • Adding additional actions for the test instance to the decoratedTestInstanceActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
  • Modifying the PatternTestState object in any way.
Public method DisposeTest

Cleans up a test following the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method InitializeTest

Initializes a test prior to the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Aborting the test run if any preconditions have not been satisfied or if the test is to be skipped.
  • Configuring the test environment in advance of the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Top

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


AfterTest Method

IPatternTestHandler.AfterTest Method
[image]

Cleans up a completed test state after its use.

This method runs in the TestContext of its containing test step because the test has terminated.

The following actions are typically performed during this phase:

  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AfterTest( _
ByVal testState As PatternTestState _
)
C#
void AfterTest(
PatternTestState testState
)
C++
void AfterTest(
PatternTestState testState
) abstract
J#
void AfterTest(
PatternTestState testState
)
JScript
function AfterTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


BeforeTest Method

IPatternTestHandler.BeforeTest Method
[image]

Prepares a newly created test state before its use.

This method runs in the TestContext of its containing test step because the test has not yet been started.

The following actions are typically performed during this phase:

  • Configuring the PrimaryTestStep in anticipation of test execution.
  • Accessing user data via Data.
  • Skipping the test by throwing an appropriate SilentTestException.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub BeforeTest( _
ByVal testState As PatternTestState _
)
C#
void BeforeTest(
PatternTestState testState
)
C++
void BeforeTest(
PatternTestState testState
) abstract
J#
void BeforeTest(
PatternTestState testState
)
JScript
function BeforeTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


DecorateTestInstance Method

IPatternTestHandler.DecorateTestInstance Method
[image]

Decorates the IPatternTestHandler of a test instance before its BeforeTestInstance actions have a chance to run.

This method runs in the TestContext of its containing test instance because the test has not yet been started.

This method may apply any number of decorations to the test instance's handler by adding actions to the supplied decoratedTestInstanceActions object. The test instance's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

The following actions are typically performed during this phase:

  • Adding additional actions for the test instance to the decoratedTestInstanceActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
  • Modifying the PatternTestState object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub DecorateTestInstance( _
ByVal testState As PatternTestState, _
ByVal decoratedTestInstanceActions As PatternTestInstanceActions _
)
C#
void DecorateTestInstance(
PatternTestState testState,
PatternTestInstanceActions decoratedTestInstanceActions
)
C++
void DecorateTestInstance(
PatternTestState testState,
PatternTestInstanceActions decoratedTestInstanceActions
) abstract
J#
void DecorateTestInstance(
PatternTestState testState,
PatternTestInstanceActions decoratedTestInstanceActions
)
JScript
function DecorateTestInstance(
testState : PatternTestState,
decoratedTestInstanceActions : PatternTestInstanceActions
)

Parameters

testState
The test state, never null
decoratedTestInstanceActions
The test instance's actions to decorate, never null

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


DisposeTest Method

IPatternTestHandler.DisposeTest Method
[image]

Cleans up a test following the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub DisposeTest( _
ByVal testState As PatternTestState _
)
C#
void DisposeTest(
PatternTestState testState
)
C++
void DisposeTest(
PatternTestState testState
) abstract
J#
void DisposeTest(
PatternTestState testState
)
JScript
function DisposeTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


InitializeTest Method

IPatternTestHandler.InitializeTest Method
[image]

Initializes a test prior to the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Aborting the test run if any preconditions have not been satisfied or if the test is to be skipped.
  • Configuring the test environment in advance of the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub InitializeTest( _
ByVal testState As PatternTestState _
)
C#
void InitializeTest(
PatternTestState testState
)
C++
void InitializeTest(
PatternTestState testState
) abstract
J#
void InitializeTest(
PatternTestState testState
)
JScript
function InitializeTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

See Also

IPatternTestHandler Interface
Gallio.Framework.Pattern Namespace


IPatternTestInstanceHandler Interface

IPatternTestInstanceHandler Interface
See Also Example Members
[image]

A pattern test instance handler provides the logic that implements the various phases of the test instance execution lifecycle.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternTestInstanceHandler
C#
public interface IPatternTestInstanceHandler
C++
interface class IPatternTestInstanceHandler
J#
public interface IPatternTestInstanceHandler
JScript
public interface IPatternTestInstanceHandler

Types that implement IPatternTestInstanceHandler

Type | Description
Gallio.Framework.Pattern.PatternTestInstanceActions | An implementation of IPatternTestInstanceHandler based on actions that can be sequenced and composed as chains.

Remarks

Each method represents the behavior to be performed during a particular phase. Different actions are permitted during each phase. Consult the documentation the appropriate method of this interface for restrictions.

The phases generally run in the following order. Some phases may be skipped due to exceptions or if there is no work to be done.

  • BeforeTestInstance
  • --- begin RunTestInstanceBody ---
  • InitializeTestInstance
  • SetUpTestInstance
  • ExecuteTestInstance
  • DecorateChildTest before each child test
  • TearDownTestInstance
  • DisposeTestInstance
  • --- end RunTestInstanceBody ---
  • AfterTestInstance

See Also

IPatternTestInstanceHandler Members
Gallio.Framework.Pattern Namespace


IPatternTestInstanceHandler Members

IPatternTestInstanceHandler Members
See Also Example Methods
[image]

A pattern test instance handler provides the logic that implements the various phases of the test instance execution lifecycle.

The following tables list the members exposed by IPatternTestInstanceHandler.

Public Methods

Name | Description
Public method AfterTestInstance

Cleans up a completed test instance after its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has terminated.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the test disposal.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTestInstance

Prepares a newly created test instance state before its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has not yet started.

If IsReusingPrimaryTestStep is false then this method has the opportunity to modify the name or add metadata to the brand new PatternTestStep that was created for just this test instance.

The following actions are typically performed during this phase:

  • Adding or changing slot values.
  • Configuring the test environment in advance of test initialization.
  • Modifying the name or metadata of the PatternTestStep, if IsReusingPrimaryTestStep is false (since the primary test step has already started execution).
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way UNLESS IsReusingPrimaryTestStep is false.
  • Skipping the test instance by throwing an appropriate SilentTestException.
Public method DecorateChildTest

Decorates the IPatternTestInstanceHandler of a child test before its BeforeTest actions have a chance to run.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

This method may apply any number of decorations to the child test's handler by adding actions to the supplied decoratedChildTestActions object. The child test's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

A typical use of this method is to augment the SetUpTestInstance and TearDownTestInstance behaviors of the child test with additional contributions provided by the parent.

It is also possible to decorate descendants besides direct children. To do so, decorate the child's DecorateChildTest behavior to perpetuate the decoration down to more deeply nested descendants. This process of recursive decoration may be carried along to whatever depth is required.

The following actions are typically performed during this phase:

  • Adding additional actions for the child test to the decoratedChildTestActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method DisposeTestInstance

Disposes a test instance that is about to terminate.

This method runs in the TestContext of the test instance in the Dispose lifecycle phase.

The following actions are typically performed during this phase:

  • Deconfiguring the test fixture following test execution.
  • Disposing the test fixture instance.
  • Disposing other resources.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method ExecuteTestInstance

Executes the test instance.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method InitializeTestInstance

Initializes a test instance that has just started running.

This method runs in the TestContext of the test instance in the Initialize lifecycle phase.

The following actions are typically performed during this phase:

  • Creating the test fixture instance and setting FixtureType and FixtureInstance.
  • Configuring the test fixture in advance of test execution.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | RunTestInstanceBody | Runs the body of the test from the Initialize phase through the Dispose phase.
Public method SetUpTestInstance

Sets up a test instance prior to execution.

This method runs in the TestContext of the test instance in the SetUp lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test setup methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method TearDownTestInstance

Tears down a test instance following execution.

This method runs in the TestContext of the test instance in the TearDown lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test teardown methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Top

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternTestInstanceHandler Methods
[image]

Public Methods

Name | Description
Public method AfterTestInstance

Cleans up a completed test instance after its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has terminated.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the test disposal.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTestInstance

Prepares a newly created test instance state before its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has not yet started.

If IsReusingPrimaryTestStep is false then this method has the opportunity to modify the name or add metadata to the brand new PatternTestStep that was created for just this test instance.

The following actions are typically performed during this phase:

  • Adding or changing slot values.
  • Configuring the test environment in advance of test initialization.
  • Modifying the name or metadata of the PatternTestStep, if IsReusingPrimaryTestStep is false (since the primary test step has already started execution).
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way UNLESS IsReusingPrimaryTestStep is false.
  • Skipping the test instance by throwing an appropriate SilentTestException.
Public method DecorateChildTest

Decorates the IPatternTestInstanceHandler of a child test before its BeforeTest actions have a chance to run.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

This method may apply any number of decorations to the child test's handler by adding actions to the supplied decoratedChildTestActions object. The child test's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

A typical use of this method is to augment the SetUpTestInstance and TearDownTestInstance behaviors of the child test with additional contributions provided by the parent.

It is also possible to decorate descendants besides direct children. To do so, decorate the child's DecorateChildTest behavior to perpetuate the decoration down to more deeply nested descendants. This process of recursive decoration may be carried along to whatever depth is required.

The following actions are typically performed during this phase:

  • Adding additional actions for the child test to the decoratedChildTestActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method DisposeTestInstance

Disposes a test instance that is about to terminate.

This method runs in the TestContext of the test instance in the Dispose lifecycle phase.

The following actions are typically performed during this phase:

  • Deconfiguring the test fixture following test execution.
  • Disposing the test fixture instance.
  • Disposing other resources.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method ExecuteTestInstance

Executes the test instance.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method InitializeTestInstance

Initializes a test instance that has just started running.

This method runs in the TestContext of the test instance in the Initialize lifecycle phase.

The following actions are typically performed during this phase:

  • Creating the test fixture instance and setting FixtureType and FixtureInstance.
  • Configuring the test fixture in advance of test execution.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | RunTestInstanceBody | Runs the body of the test from the Initialize phase through the Dispose phase.
Public method SetUpTestInstance

Sets up a test instance prior to execution.

This method runs in the TestContext of the test instance in the SetUp lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test setup methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method TearDownTestInstance

Tears down a test instance following execution.

This method runs in the TestContext of the test instance in the TearDown lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test teardown methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Top

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


AfterTestInstance Method

IPatternTestInstanceHandler.AfterTestInstance Method
[image]

Cleans up a completed test instance after its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has terminated.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the test disposal.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AfterTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void AfterTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void AfterTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void AfterTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function AfterTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


BeforeTestInstance Method

IPatternTestInstanceHandler.BeforeTestInstance Method
[image]

Prepares a newly created test instance state before its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has not yet started.

If IsReusingPrimaryTestStep is false then this method has the opportunity to modify the name or add metadata to the brand new PatternTestStep that was created for just this test instance.

The following actions are typically performed during this phase:

  • Adding or changing slot values.
  • Configuring the test environment in advance of test initialization.
  • Modifying the name or metadata of the PatternTestStep, if IsReusingPrimaryTestStep is false (since the primary test step has already started execution).
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way UNLESS IsReusingPrimaryTestStep is false.
  • Skipping the test instance by throwing an appropriate SilentTestException.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub BeforeTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void BeforeTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void BeforeTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void BeforeTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function BeforeTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


DecorateChildTest Method

IPatternTestInstanceHandler.DecorateChildTest Method
[image]

Decorates the IPatternTestInstanceHandler of a child test before its BeforeTest actions have a chance to run.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

This method may apply any number of decorations to the child test's handler by adding actions to the supplied decoratedChildTestActions object. The child test's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

A typical use of this method is to augment the SetUpTestInstance and TearDownTestInstance behaviors of the child test with additional contributions provided by the parent.

It is also possible to decorate descendants besides direct children. To do so, decorate the child's DecorateChildTest behavior to perpetuate the decoration down to more deeply nested descendants. This process of recursive decoration may be carried along to whatever depth is required.

The following actions are typically performed during this phase:

  • Adding additional actions for the child test to the decoratedChildTestActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub DecorateChildTest( _
ByVal testInstanceState As PatternTestInstanceState, _
ByVal decoratedChildTestActions As PatternTestActions _
)
C#
void DecorateChildTest(
PatternTestInstanceState testInstanceState,
PatternTestActions decoratedChildTestActions
)
C++
void DecorateChildTest(
PatternTestInstanceState testInstanceState,
PatternTestActions decoratedChildTestActions
) abstract
J#
void DecorateChildTest(
PatternTestInstanceState testInstanceState,
PatternTestActions decoratedChildTestActions
)
JScript
function DecorateChildTest(
testInstanceState : PatternTestInstanceState,
decoratedChildTestActions : PatternTestActions
)

Parameters

testInstanceState
The test instance state, never null
decoratedChildTestActions
The child test's actions to decorate, never null

Remarks

The testInstanceState represents the state of the currently executing instance of this test; not the child. The child has not started running yet. When the child runs, the decorator actions installed in decoratedChildTestActions will be invoked with references to the child's state as usual.

For some purposes it may be useful to save the testInstanceState for later use in the decorated action. For example, if the decorated action needs to invoke a method on the parent test fixture, then it will need to have the parent's testInstanceState. This is very easy using anonymous delegates (due to variable capture) but can also be accomplished with other means as required.

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


DisposeTestInstance Method

IPatternTestInstanceHandler.DisposeTestInstance Method
[image]

Disposes a test instance that is about to terminate.

This method runs in the TestContext of the test instance in the Dispose lifecycle phase.

The following actions are typically performed during this phase:

  • Deconfiguring the test fixture following test execution.
  • Disposing the test fixture instance.
  • Disposing other resources.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub DisposeTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void DisposeTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void DisposeTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void DisposeTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function DisposeTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


ExecuteTestInstance Method

IPatternTestInstanceHandler.ExecuteTestInstance Method
[image]

Executes the test instance.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ExecuteTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void ExecuteTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void ExecuteTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void ExecuteTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function ExecuteTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


InitializeTestInstance Method

IPatternTestInstanceHandler.InitializeTestInstance Method
[image]

Initializes a test instance that has just started running.

This method runs in the TestContext of the test instance in the Initialize lifecycle phase.

The following actions are typically performed during this phase:

  • Creating the test fixture instance and setting FixtureType and FixtureInstance.
  • Configuring the test fixture in advance of test execution.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub InitializeTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void InitializeTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void InitializeTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void InitializeTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function InitializeTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


RunTestInstanceBody Method

IPatternTestInstanceHandler.RunTestInstanceBody Method
[image]

Runs the body of the test from the Initialize phase through the Dispose phase.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function RunTestInstanceBody( _
ByVal testInstanceState As PatternTestInstanceState _
) As TestOutcome
C#
TestOutcome RunTestInstanceBody(
PatternTestInstanceState testInstanceState
)
C++
TestOutcome RunTestInstanceBody(
PatternTestInstanceState testInstanceState
) abstract
J#
TestOutcome RunTestInstanceBody(
PatternTestInstanceState testInstanceState
)
JScript
function RunTestInstanceBody(
testInstanceState : PatternTestInstanceState
) : TestOutcome

Parameters

testInstanceState
The test instance state, never null

Return Value

The test outcome

Remarks

This method is somewhat special in that it gives the test instance handler a chance to encapsulate the context in which the test runs. It can cause the test to run repeatedly, or in another thread, or with some special execution context. Of course, if it does any of these things then it is responsible for properly cleaning up the test and responding in a timely manner to abort events from the current test context's Sandbox.

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


SetUpTestInstance Method

IPatternTestInstanceHandler.SetUpTestInstance Method
[image]

Sets up a test instance prior to execution.

This method runs in the TestContext of the test instance in the SetUp lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test setup methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetUpTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void SetUpTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void SetUpTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void SetUpTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function SetUpTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


TearDownTestInstance Method

IPatternTestInstanceHandler.TearDownTestInstance Method
[image]

Tears down a test instance following execution.

This method runs in the TestContext of the test instance in the TearDown lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test teardown methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub TearDownTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
void TearDownTestInstance(
PatternTestInstanceState testInstanceState
)
C++
void TearDownTestInstance(
PatternTestInstanceState testInstanceState
) abstract
J#
void TearDownTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
function TearDownTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

See Also

IPatternTestInstanceHandler Interface
Gallio.Framework.Pattern Namespace


IPatternTestParameterHandler Interface

IPatternTestParameterHandler Interface
See Also Example Members
[image]

A pattern test parameter handler provides the logic that implements the various phases of the test parameter binding lifecycle.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPatternTestParameterHandler
C#
public interface IPatternTestParameterHandler
C++
interface class IPatternTestParameterHandler
J#
public interface IPatternTestParameterHandler
JScript
public interface IPatternTestParameterHandler

Types that implement IPatternTestParameterHandler

Type | Description
Gallio.Framework.Pattern.PatternTestParameterActions | An implementation of IPatternTestParameterHandler based on actions that can be sequenced and composed as chains.

Remarks

Each method represents the behavior to be performed during a particular phase. Different actions are permitted during each phase. Consult the documentation the appropriate method of this interface for restrictions.

The phases generally run in the following order. Some phases may be skipped due to exceptions or if there is no work to be done.

  • -- for each test instance --
  • BindTestParameter
  • UnbindTestParameter
  • -- end --

See Also

IPatternTestParameterHandler Members
Gallio.Framework.Pattern Namespace


IPatternTestParameterHandler Members

IPatternTestParameterHandler Members
See Also Example Methods
[image]

A pattern test parameter handler provides the logic that implements the various phases of the test parameter binding lifecycle.

The following tables list the members exposed by IPatternTestParameterHandler.

Public Methods

Name Description
Public method BindTestParameter

Binds a value to a test parameter.

The following actions are typically performed during this phase:

  • Associated a value with a slot on the test fixture or test method.
  • Storing the object for later use during the test run.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Public method UnbindTestParameter

Unbinds a test parameter.

The following actions are typically performed during this phase:

  • Releasing any resources used by the test parameter.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Top

See Also

IPatternTestParameterHandler Interface
Gallio.Framework.Pattern Namespace


Methods

IPatternTestParameterHandler Methods
[image]

Public Methods

Name Description
Public method BindTestParameter

Binds a value to a test parameter.

The following actions are typically performed during this phase:

  • Associated a value with a slot on the test fixture or test method.
  • Storing the object for later use during the test run.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Public method UnbindTestParameter

Unbinds a test parameter.

The following actions are typically performed during this phase:

  • Releasing any resources used by the test parameter.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Top

See Also

IPatternTestParameterHandler Interface
Gallio.Framework.Pattern Namespace


BindTestParameter Method

IPatternTestParameterHandler.BindTestParameter Method
[image]

Binds a value to a test parameter.

The following actions are typically performed during this phase:

  • Associated a value with a slot on the test fixture or test method.
  • Storing the object for later use during the test run.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub BindTestParameter( _
ByVal testInstanceState As PatternTestInstanceState, _
ByVal value As Object _
)
C#
void BindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
C++
void BindTestParameter(
PatternTestInstanceState testInstanceState,
Object value
) abstract
J#
void BindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
JScript
function BindTestParameter(
testInstanceState : PatternTestInstanceState,
value : Object
)

Parameters

testInstanceState
The test instance state, never null
value
The value to bind to the parameter

See Also

IPatternTestParameterHandler Interface
Gallio.Framework.Pattern Namespace


UnbindTestParameter Method

IPatternTestParameterHandler.UnbindTestParameter Method
[image]

Unbinds a test parameter.

The following actions are typically performed during this phase:

  • Releasing any resources used by the test parameter.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub UnbindTestParameter( _
ByVal testInstanceState As PatternTestInstanceState, _
ByVal value As Object _
)
C#
void UnbindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
C++
void UnbindTestParameter(
PatternTestInstanceState testInstanceState,
Object value
) abstract
J#
void UnbindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
JScript
function UnbindTestParameter(
testInstanceState : PatternTestInstanceState,
value : Object
)

Parameters

testInstanceState
The test instance state, never null
value
The value that was bound to the test parameter

See Also

IPatternTestParameterHandler Interface
Gallio.Framework.Pattern Namespace


ISupportDeferredActions Interface

ISupportDeferredActions Interface
See Also Example Members
[image]

Provides support for performing deferred build actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISupportDeferredActions
C#
public interface ISupportDeferredActions
C++
interface class ISupportDeferredActions
J#
public interface ISupportDeferredActions
JScript
public interface ISupportDeferredActions

Types that implement ISupportDeferredActions

Type | Description
Gallio.Framework.Pattern.BaseBuilder | Abstract base class for typical builder implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ISupportDeferredActions Members
Gallio.Framework.Pattern Namespace


ISupportDeferredActions Members

ISupportDeferredActions Members
See Also Example Methods
[image]

Provides support for performing deferred build actions.

The following tables list the members exposed by ISupportDeferredActions.

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called.
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list.
Top

See Also

ISupportDeferredActions Interface
Gallio.Framework.Pattern Namespace


Methods

ISupportDeferredActions Methods
[image]

Public Methods

 | Name | Description
Public method | AddDeferredAction | Registers a deferred action to be performed when ApplyDeferredActions is called.
Public method | ApplyDeferredActions | Applies all pending deferred in order and clears the list.
Top

See Also

ISupportDeferredActions Interface
Gallio.Framework.Pattern Namespace


AddDeferredAction Method

ISupportDeferredActions.AddDeferredAction Method
[image]

Registers a deferred action to be performed when ApplyDeferredActions is called.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddDeferredAction( _
ByVal codeElement As ICodeElementInfo, _
ByVal order As Integer, _
ByVal deferredAction As Action _
)
C#
void AddDeferredAction(
ICodeElementInfo codeElement,
int order,
Action deferredAction
)
C++
void AddDeferredAction(
ICodeElementInfo codeElement,
int order,
Action deferredAction
) abstract
J#
void AddDeferredAction(
ICodeElementInfo codeElement,
int order,
Action deferredAction
)
JScript
function AddDeferredAction(
codeElement : ICodeElementInfo,
order : int,
deferredAction : Action
)

Parameters

codeElement
The associated code element, used to report errors if the deferred action throws an exception
order
The order in which the action should be applied, from least order to greatest
deferredAction
The action to perform

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement or deferredAction is null

Remarks

Typically used to enable decorations to be applied in a particular order.

See Also

ISupportDeferredActions Interface
Gallio.Framework.Pattern Namespace
ApplyDeferredActions


ApplyDeferredActions Method

ISupportDeferredActions.ApplyDeferredActions Method
[image]

Applies all pending deferred in order and clears the list.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ApplyDeferredActions()
C#
void ApplyDeferredActions()
C++
void ApplyDeferredActions() abstract
J#
void ApplyDeferredActions()
JScript
function ApplyDeferredActions()

See Also

ISupportDeferredActions Interface
Gallio.Framework.Pattern Namespace


ITestBuilder Interface

ITestBuilder Interface
See Also Example Members
[image]

A test builder applies contributions to a test under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestBuilder
Implements ITestComponentBuilder, ISupportDeferredActions
C#
public interface ITestBuilder : ITestComponentBuilder, ISupportDeferredActions
C++
interface class ITestBuilder : ITestComponentBuilder, ISupportDeferredActions
J#
public interface ITestBuilder implements ITestComponentBuilder, ISupportDeferredActions
JScript
public interface ITestBuilder extends ITestComponentBuilder, ISupportDeferredActions

Types that implement ITestBuilder

Type | Description
Gallio.Framework.Pattern.DefaultTestBuilder | Default implementation of a test model builder.

See Also

ITestBuilder Members
Gallio.Framework.Pattern Namespace


ITestBuilder Members

ITestBuilder Members
See Also Example Properties Methods
[image]

A test builder applies contributions to a test under construction.

The following tables list the members exposed by ITestBuilder.

Public Properties

Name | Description
Public property | ApartmentState | Gets or sets the apartment state to be used to run the test.
Public property | IsParallelizable | Gets or sets whether the test is parallelizable.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TestActions | Gets the set of actions that describe the behavior of the test.
Public property | TestInstanceActions | Gets the set of actions that describe the behavior of the test's instances.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

Public Methods

 | Name | Description
Public method | AddDependency | Adds a test dependency.
Public method | CreateChild | Creates a child test and returns its builder.
Public method | CreateParameter | Creates a test parameter and returns its builder.
Public method | SetExpectedExceptionType | Sets the name of the expected exception type.
Public method | ToTest | Gets the underlying test.
Top

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


Properties

ITestBuilder Properties
[image]

Public Properties

Name | Description
Public property | ApartmentState | Gets or sets the apartment state to be used to run the test.
Public property | IsParallelizable | Gets or sets whether the test is parallelizable.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TestActions | Gets the set of actions that describe the behavior of the test.
Public property | TestInstanceActions | Gets the set of actions that describe the behavior of the test's instances.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


ApartmentState Property

ITestBuilder.ApartmentState Property
[image]

Gets or sets the apartment state to be used to run the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property ApartmentState As ApartmentState
C#
ApartmentState ApartmentState { get; set; }
C++
property ApartmentState ApartmentState abstract {
ApartmentState get();
void set(ApartmentState value);
}
J#
/** property */
public ApartmentState get_ApartmentState();

/** property */
public void set_ApartmentState(ApartmentState value);
JScript
public function get ApartmentState() : ApartmentState

public function set ApartmentState(value : ApartmentState);

Property Value

The default value of this property is Unknown.

Remarks

If the apartment state is Unknown the test will inherit the apartment state of its parent. Otherwise it will run in a thread with the specified apartment state.

The test runner guarantees that the root test runs with the STA apartment state. Consequently the apartment state only needs to be overridden to run a test in some mode that may differ from that which it would ordinarily inherit.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


IsParallelizable Property

ITestBuilder.IsParallelizable Property
[image]

Gets or sets whether the test is parallelizable.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property IsParallelizable As Boolean
C#
bool IsParallelizable { get; set; }
C++
property bool IsParallelizable abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsParallelizable();

/** property */
public void set_IsParallelizable(bool value);
JScript
public function get IsParallelizable() : bool

public function set IsParallelizable(value : bool);

Property Value

True if the test is parallelizable. The default value of this property is false.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


IsTestCase Property

ITestBuilder.IsTestCase Property
[image]

Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property IsTestCase As Boolean
C#
bool IsTestCase { get; set; }
C++
property bool IsTestCase abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsTestCase();

/** property */
public void set_IsTestCase(bool value);
JScript
public function get IsTestCase() : bool

public function set IsTestCase(value : bool);

Remarks

Not all test cases are leaf nodes in the test tree and vice-versa.

This value is defined as a property rather than as a metadata key because it significantly changes the semantics of test execution.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


Kind Property

ITestBuilder.Kind Property
[image]

Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Kind As String
C#
string Kind { get; set; }
C++
property string Kind abstract {
String get();
void set(String value);
}
J#
/** property */
public string get_Kind();

/** property */
public void set_Kind(string value);
JScript
public function get Kind() : String

public function set Kind(value : String);

Property Value

One of the TestKinds constants.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


LocalId Property

ITestBuilder.LocalId Property
[image]

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LocalId As String
C#
string LocalId { get; }
C++
property string LocalId abstract {
String get();
}
J#
/** property */
public string get_LocalId();
JScript
public function get LocalId() : String

Property Value

The locally unique identifier

Remarks

The locally unique LocalId property may be used to generate the globally unique Id property of a test by combining it with the locally unique identifiers of its parents.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


LocalIdHint Property

ITestBuilder.LocalIdHint Property
[image]

Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property LocalIdHint As String
C#
string LocalIdHint { get; set; }
C++
property string LocalIdHint abstract {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalIdHint();

/** property */
public void set_LocalIdHint(string value);
JScript
public function get LocalIdHint() : String

public function set LocalIdHint(value : String);

Property Value

The local id hint

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


Order Property

ITestBuilder.Order Property
[image]

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Order As Integer
C#
int Order { get; set; }
C++
property int Order abstract {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public function get Order() : int

public function set Order(value : int);

Property Value

The test execution order with respect to siblings, initially zero.

Remarks

Some test frameworks may choose to ignore test order or may impose their own ordering schemes.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


TestActions Property

ITestBuilder.TestActions Property
[image]

Gets the set of actions that describe the behavior of the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestActions As PatternTestActions
C#
PatternTestActions TestActions { get; }
C++
property PatternTestActions TestActions abstract {
PatternTestActions get();
}
J#
/** property */
public PatternTestActions get_TestActions();
JScript
public function get TestActions() : PatternTestActions

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


TestInstanceActions Property

ITestBuilder.TestInstanceActions Property
[image]

Gets the set of actions that describe the behavior of the test's instances.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestInstanceActions As PatternTestInstanceActions
C#
PatternTestInstanceActions TestInstanceActions { get; }
C++
property PatternTestInstanceActions TestInstanceActions abstract {
PatternTestInstanceActions get();
}
J#
/** property */
public PatternTestInstanceActions get_TestInstanceActions();
JScript
public function get TestInstanceActions() : PatternTestInstanceActions

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


Timeout Property

ITestBuilder.Timeout Property
[image]

Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Timeout As Nullable(Of TimeSpan)
C#
Nullable<TimeSpan> Timeout { get; set; }
C++
property Nullable<TimeSpan> Timeout abstract {
Nullable<TimeSpan> get();
void set(Nullable<TimeSpan> value);
}
J#
/** property */
public Nullable<TimeSpan> get_Timeout();

/** property */
public void set_Timeout(Nullable<TimeSpan> value);
JScript
public function get Timeout() : Nullable<TimeSpan>

public function set Timeout(value : Nullable<TimeSpan>);

Property Value

The timeout. Default value is null.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if value represents a negative time span

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


Methods

ITestBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddDependency | Adds a test dependency.
Public method | CreateChild | Creates a child test and returns its builder.
Public method | CreateParameter | Creates a test parameter and returns its builder.
Public method | SetExpectedExceptionType | Sets the name of the expected exception type.
Public method | ToTest | Gets the underlying test.
Top

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


AddDependency Method

ITestBuilder.AddDependency Method
[image]

Adds a test dependency.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddDependency( _
ByVal testDependency As ITest _
)
C#
void AddDependency(
ITest testDependency
)
C++
void AddDependency(
ITest testDependency
) abstract
J#
void AddDependency(
ITest testDependency
)
JScript
function AddDependency(
testDependency : ITest
)

Parameters

testDependency
The test to add as a dependency

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testDependency is null

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


CreateChild Method

ITestBuilder.CreateChild Method
[image]

Creates a child test and returns its builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateChild( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContextBuilder As ITestDataContextBuilder _
) As ITestBuilder
C#
ITestBuilder CreateChild(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
C++
ITestBuilder CreateChild(
String name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
) abstract
J#
ITestBuilder CreateChild(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
JScript
function CreateChild(
name : String,
codeElement : ICodeElementInfo,
dataContextBuilder : ITestDataContextBuilder
) : ITestBuilder

Parameters

name
The test name
codeElement
The associated code element, or null if none
dataContextBuilder
The data context builder for the new test

Return Value

The builder for the child test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or dataContextBuilder is null

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


CreateParameter Method

ITestBuilder.CreateParameter Method
[image]

Creates a test parameter and returns its builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateParameter( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContextBuilder As ITestDataContextBuilder _
) As ITestParameterBuilder
C#
ITestParameterBuilder CreateParameter(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
C++
ITestParameterBuilder CreateParameter(
String name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
) abstract
J#
ITestParameterBuilder CreateParameter(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
JScript
function CreateParameter(
name : String,
codeElement : ICodeElementInfo,
dataContextBuilder : ITestDataContextBuilder
) : ITestParameterBuilder

Parameters

name
The test parameter name
codeElement
The associated code element, or null if none
dataContextBuilder
The data context builder for the new test parameter

Return Value

The builder for the test parameter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or dataContextBuilder is null

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


SetExpectedExceptionType Method

ITestBuilder.SetExpectedExceptionType Method
[image]

Sets the name of the expected exception type.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetExpectedExceptionType( _
ByVal typeName As String _
)
C#
void SetExpectedExceptionType(
string typeName
)
C++
void SetExpectedExceptionType(
String typeName
) abstract
J#
void SetExpectedExceptionType(
string typeName
)
JScript
function SetExpectedExceptionType(
typeName : String
)

Parameters

typeName
The expected exception type name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if typeName is null

Remarks

This method works by adding ExpectedException metadata containing the type name as value.

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


ToTest Method

ITestBuilder.ToTest Method
[image]

Gets the underlying test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ToTest() As PatternTest
C#
PatternTest ToTest()
C++
PatternTest ToTest() abstract
J#
PatternTest ToTest()
JScript
function ToTest() : PatternTest

Return Value

The underlying test

See Also

ITestBuilder Interface
Gallio.Framework.Pattern Namespace


ITestComponentBuilder Interface

ITestComponentBuilder Interface
See Also Example Members
[image]

A test component builder applies contributions to a test or test parameter under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestComponentBuilder
Implements ISupportDeferredActions
C#
public interface ITestComponentBuilder : ISupportDeferredActions
C++
interface class ITestComponentBuilder : ISupportDeferredActions
J#
public interface ITestComponentBuilder implements ISupportDeferredActions
JScript
public interface ITestComponentBuilder extends ISupportDeferredActions

Types that implement ITestComponentBuilder

Type | Description
Gallio.Framework.Pattern.BaseTestComponentBuilder | Abstract base class for test component builders. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestComponentBuilder Members
Gallio.Framework.Pattern Namespace


ITestComponentBuilder Members

ITestComponentBuilder Members
See Also Example Properties Methods
[image]

A test component builder applies contributions to a test or test parameter under construction.

The following tables list the members exposed by ITestComponentBuilder.

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Name | Gets or sets the name of the component.
Top

Public Methods

 | Name | Description
Public method | AddMetadata | Adds a metadata key value pair.
Public method | ToTestComponent | Gets the underlying test component.
Top

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace


Properties

ITestComponentBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Name | Gets or sets the name of the component.
Top

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace


CodeElement Property

ITestComponentBuilder.CodeElement Property
[image]

Gets a reference to the point of definition of this test component in the code, or null if unknown.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CodeElement As ICodeElementInfo
C#
ICodeElementInfo CodeElement { get; }
C++
property ICodeElementInfo CodeElement abstract {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace


Id Property

ITestComponentBuilder.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Id As String
C#
string Id { get; }
C++
property string Id abstract {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Remarks

The identifier must be unique across all components within a given test project. It should also be stable so that the identifier remains valid across recompilations and code changes that do not alter the underlying declarations (insofar as is possible).

The identifier does not refer to a specific instance of ITestComponent, but rather incorporates enough information so that we can unambiguously find a corresponding instance in a model that has been populated. When we rebuild the model, assuming the code hasn't changed too much, the objects in the model will have the same identifier as before. This allows the identifier to be saved in project files to construct lists of components. We can also use it to refer to components remotely.

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace


Name Property

ITestComponentBuilder.Name Property
[image]

Gets or sets the name of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Name As String
C#
string Name { get; set; }
C++
property string Name abstract {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace
Name


Methods

ITestComponentBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddMetadata | Adds a metadata key value pair.
Public method | ToTestComponent | Gets the underlying test component.
Top

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace


AddMetadata Method

ITestComponentBuilder.AddMetadata Method
[image]

Adds a metadata key value pair.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddMetadata( _
ByVal key As String, _
ByVal value As String _
)
C#
void AddMetadata(
string key,
string value
)
C++
void AddMetadata(
String key,
String value
) abstract
J#
void AddMetadata(
string key,
string value
)
JScript
function AddMetadata(
key : String,
value : String
)

Parameters

key
The metadata key
value
The value to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if key or value is null

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace
Metadata
MetadataKeys


ToTestComponent Method

ITestComponentBuilder.ToTestComponent Method
[image]

Gets the underlying test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ToTestComponent() As IPatternTestComponent
C#
IPatternTestComponent ToTestComponent()
C++
IPatternTestComponent ToTestComponent() abstract
J#
IPatternTestComponent ToTestComponent()
JScript
function ToTestComponent() : IPatternTestComponent

Return Value

The underlying test component

See Also

ITestComponentBuilder Interface
Gallio.Framework.Pattern Namespace


ITestDataContextBuilder Interface

ITestDataContextBuilder Interface
See Also Example Members
[image]

A test data context builder applies contributions to a test data context under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestDataContextBuilder
C#
public interface ITestDataContextBuilder
C++
interface class ITestDataContextBuilder
J#
public interface ITestDataContextBuilder
JScript
public interface ITestDataContextBuilder

Types that implement ITestDataContextBuilder

Type | Description
Gallio.Framework.Pattern.DefaultTestDataContextBuilder | Default implementation of a test data context builder.

See Also

ITestDataContextBuilder Members
Gallio.Framework.Pattern Namespace


ITestDataContextBuilder Members

ITestDataContextBuilder Members
See Also Example Properties Methods
[image]

A test data context builder applies contributions to a test data context under construction.

The following tables list the members exposed by ITestDataContextBuilder.

Public Properties

Name Description
Public property ImplicitDataBindingIndexOffset

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.
Top

Public Methods

 | Name | Description
Public method | CreateChild | Creates a child data context.
Public method | DefineDataSource | Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.
Public method | ToPatternTestDataContext | Gets the underlying pattern test data context.
Top

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


Properties

ITestDataContextBuilder Properties
[image]

Public Properties

Name Description
Public property ImplicitDataBindingIndexOffset

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.
Top

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


ImplicitDataBindingIndexOffset Property

ITestDataContextBuilder.ImplicitDataBindingIndexOffset Property
See Also Example
[image]

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property ImplicitDataBindingIndexOffset As Integer
C#
int ImplicitDataBindingIndexOffset { get; set; }
C++
property int ImplicitDataBindingIndexOffset abstract {
int get();
void set(int value);
}
J#
/** property */
public int get_ImplicitDataBindingIndexOffset();

/** property */
public void set_ImplicitDataBindingIndexOffset(int value);
JScript
public function get ImplicitDataBindingIndexOffset() : int

public function set ImplicitDataBindingIndexOffset(value : int);

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


Methods

ITestDataContextBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | CreateChild | Creates a child data context.
Public method | DefineDataSource | Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.
Public method | ToPatternTestDataContext | Gets the underlying pattern test data context.
Top

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


CreateChild Method

ITestDataContextBuilder.CreateChild Method
[image]

Creates a child data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateChild() As ITestDataContextBuilder
C#
ITestDataContextBuilder CreateChild()
C++
ITestDataContextBuilder CreateChild() abstract
J#
ITestDataContextBuilder CreateChild()
JScript
function CreateChild() : ITestDataContextBuilder

Return Value

The builder for the child context

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


DefineDataSource Method

ITestDataContextBuilder.DefineDataSource Method
[image]

Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function DefineDataSource( _
ByVal name As String _
) As DataSource
C#
DataSource DefineDataSource(
string name
)
C++
DataSource DefineDataSource(
String name
) abstract
J#
DataSource DefineDataSource(
string name
)
JScript
function DefineDataSource(
name : String
) : DataSource

Parameters

name
The data source name

Return Value

The defined data source

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


ToPatternTestDataContext Method

ITestDataContextBuilder.ToPatternTestDataContext Method
[image]

Gets the underlying pattern test data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ToPatternTestDataContext() As PatternTestDataContext
C#
PatternTestDataContext ToPatternTestDataContext()
C++
PatternTestDataContext ToPatternTestDataContext() abstract
J#
PatternTestDataContext ToPatternTestDataContext()
JScript
function ToPatternTestDataContext() : PatternTestDataContext

Return Value

The underlying pattern test data context

See Also

ITestDataContextBuilder Interface
Gallio.Framework.Pattern Namespace


ITestModelBuilder Interface

ITestModelBuilder Interface
See Also Example Members
[image]

A test model builder applies contributions to a test model under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestModelBuilder
Implements ISupportDeferredActions
C#
public interface ITestModelBuilder : ISupportDeferredActions
C++
interface class ITestModelBuilder : ISupportDeferredActions
J#
public interface ITestModelBuilder implements ISupportDeferredActions
JScript
public interface ITestModelBuilder extends ISupportDeferredActions

Types that implement ITestModelBuilder

Type | Description
Gallio.Framework.Pattern.DefaultTestModelBuilder | Default implementation of a test model builder.

See Also

ITestModelBuilder Members
Gallio.Framework.Pattern Namespace


ITestModelBuilder Members

ITestModelBuilder Members
See Also Example Properties Methods
[image]

A test model builder applies contributions to a test model under construction.

The following tables list the members exposed by ITestModelBuilder.

Public Properties

 | Name | Description
Public property | ReflectionPolicy | Gets the reflection policy for the model.
Top

Public Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation to the test model.
Public method | AddAssemblyResolver | Adds an assembly resolver to the test model's assembly loading policy.
Public method | CreateTopLevelTest | Creates a top-level test as a child of the root test and returns its builder.
Public method | PublishExceptionAsAnnotation | Publishes an exception as an annotation about a particular code element.
Public method | ToTestModel | Gets the underlying test model.
Top

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


Properties

ITestModelBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | ReflectionPolicy | Gets the reflection policy for the model.
Top

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


ReflectionPolicy Property

ITestModelBuilder.ReflectionPolicy Property
[image]

Gets the reflection policy for the model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReflectionPolicy As IReflectionPolicy
C#
IReflectionPolicy ReflectionPolicy { get; }
C++
property IReflectionPolicy ReflectionPolicy abstract {
IReflectionPolicy get();
}
J#
/** property */
public IReflectionPolicy get_ReflectionPolicy();
JScript
public function get ReflectionPolicy() : IReflectionPolicy

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


Methods

ITestModelBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation to the test model.
Public method | AddAssemblyResolver | Adds an assembly resolver to the test model's assembly loading policy.
Public method | CreateTopLevelTest | Creates a top-level test as a child of the root test and returns its builder.
Public method | PublishExceptionAsAnnotation | Publishes an exception as an annotation about a particular code element.
Public method | ToTestModel | Gets the underlying test model.
Top

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


AddAnnotation Method

ITestModelBuilder.AddAnnotation Method
[image]

Adds an annotation to the test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddAnnotation( _
ByVal annotation As Annotation _
)
C#
void AddAnnotation(
Annotation annotation
)
C++
void AddAnnotation(
Annotation annotation
) abstract
J#
void AddAnnotation(
Annotation annotation
)
JScript
function AddAnnotation(
annotation : Annotation
)

Parameters

annotation
The annotation to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if annotation is null

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


AddAssemblyResolver Method

ITestModelBuilder.AddAssemblyResolver Method
[image]

Adds an assembly resolver to the test model's assembly loading policy.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddAssemblyResolver( _
ByVal resolver As IAssemblyResolver _
)
C#
void AddAssemblyResolver(
IAssemblyResolver resolver
)
C++
void AddAssemblyResolver(
IAssemblyResolver resolver
) abstract
J#
void AddAssemblyResolver(
IAssemblyResolver resolver
)
JScript
function AddAssemblyResolver(
resolver : IAssemblyResolver
)

Parameters

resolver
The resolver to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if resolver is null

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


CreateTopLevelTest Method

ITestModelBuilder.CreateTopLevelTest Method
[image]

Creates a top-level test as a child of the root test and returns its builder.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTopLevelTest( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContextBuilder As ITestDataContextBuilder _
) As ITestBuilder
C#
ITestBuilder CreateTopLevelTest(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
C++
ITestBuilder CreateTopLevelTest(
String name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
) abstract
J#
ITestBuilder CreateTopLevelTest(
string name,
ICodeElementInfo codeElement,
ITestDataContextBuilder dataContextBuilder
)
JScript
function CreateTopLevelTest(
name : String,
codeElement : ICodeElementInfo,
dataContextBuilder : ITestDataContextBuilder
) : ITestBuilder

Parameters

name
The test name
codeElement
The associated code element, or null if none
dataContextBuilder
The data context builder for the new test

Return Value

The builder for the top-level test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or dataContextBuilder is null

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


PublishExceptionAsAnnotation Method

ITestModelBuilder.PublishExceptionAsAnnotation Method
[image]

Publishes an exception as an annotation about a particular code element.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub PublishExceptionAsAnnotation( _
ByVal codeElement As ICodeElementInfo, _
ByVal ex As Exception _
)
C#
void PublishExceptionAsAnnotation(
ICodeElementInfo codeElement,
Exception ex
)
C++
void PublishExceptionAsAnnotation(
ICodeElementInfo codeElement,
Exception ex
) abstract
J#
void PublishExceptionAsAnnotation(
ICodeElementInfo codeElement,
Exception ex
)
JScript
function PublishExceptionAsAnnotation(
codeElement : ICodeElementInfo,
ex : Exception
)

Parameters

codeElement
The code element, or null if none
ex
The exception to publish

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


ToTestModel Method

ITestModelBuilder.ToTestModel Method
[image]

Gets the underlying test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ToTestModel() As TestModel
C#
TestModel ToTestModel()
C++
TestModel ToTestModel() abstract
J#
TestModel ToTestModel()
JScript
function ToTestModel() : TestModel

Return Value

The underlying test model

See Also

ITestModelBuilder Interface
Gallio.Framework.Pattern Namespace


ITestParameterBuilder Interface

ITestParameterBuilder Interface
See Also Example Members
[image]

A test builder applies contributions to a test under construction.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestParameterBuilder
Implements ITestComponentBuilder, ISupportDeferredActions
C#
public interface ITestParameterBuilder : ITestComponentBuilder, ISupportDeferredActions
C++
interface class ITestParameterBuilder : ITestComponentBuilder, ISupportDeferredActions
J#
public interface ITestParameterBuilder implements ITestComponentBuilder, ISupportDeferredActions
JScript
public interface ITestParameterBuilder extends ITestComponentBuilder, ISupportDeferredActions

Types that implement ITestParameterBuilder

Type | Description
Gallio.Framework.Pattern.DefaultTestParameterBuilder | Default implementation of a test parameter builder.

See Also

ITestParameterBuilder Members
Gallio.Framework.Pattern Namespace


ITestParameterBuilder Members

ITestParameterBuilder Members
See Also Example Properties Methods
[image]

A test builder applies contributions to a test under construction.

The following tables list the members exposed by ITestParameterBuilder.

Public Properties

 | Name | Description
Public property | Binder | Gets or sets the data binder for the parameter.
Public property | TestParameterActions | Gets the set of actions that describe the behavior of the test parameter.
Top

Public Methods

 | Name | Description
Public method | ToTestParameter | Gets the underlying test parameter.
Top

See Also

ITestParameterBuilder Interface
Gallio.Framework.Pattern Namespace


Properties

ITestParameterBuilder Properties
[image]

Public Properties

 | Name | Description
Public property | Binder | Gets or sets the data binder for the parameter.
Public property | TestParameterActions | Gets the set of actions that describe the behavior of the test parameter.
Top

See Also

ITestParameterBuilder Interface
Gallio.Framework.Pattern Namespace


Binder Property

ITestParameterBuilder.Binder Property
[image]

Gets or sets the data binder for the parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Binder As IDataBinder
C#
IDataBinder Binder { get; set; }
C++
property IDataBinder Binder abstract {
IDataBinder get();
void set(IDataBinder value);
}
J#
/** property */
public IDataBinder get_Binder();

/** property */
public void set_Binder(IDataBinder value);
JScript
public function get Binder() : IDataBinder

public function set Binder(value : IDataBinder);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

Remarks

The default value is a ScalarDataBinder bound to the anonymous data source using a DataBinding whose path is the name of this parameter and whose index is the implicit index computed by the pararameter's data context.

See Also

ITestParameterBuilder Interface
Gallio.Framework.Pattern Namespace


TestParameterActions Property

ITestParameterBuilder.TestParameterActions Property
[image]

Gets the set of actions that describe the behavior of the test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestParameterActions As PatternTestParameterActions
C#
PatternTestParameterActions TestParameterActions { get; }
C++
property PatternTestParameterActions TestParameterActions abstract {
PatternTestParameterActions get();
}
J#
/** property */
public PatternTestParameterActions get_TestParameterActions();
JScript
public function get TestParameterActions() : PatternTestParameterActions

See Also

ITestParameterBuilder Interface
Gallio.Framework.Pattern Namespace


Methods

ITestParameterBuilder Methods
[image]

Public Methods

 | Name | Description
Public method | ToTestParameter | Gets the underlying test parameter.
Top

See Also

ITestParameterBuilder Interface
Gallio.Framework.Pattern Namespace


ToTestParameter Method

ITestParameterBuilder.ToTestParameter Method
[image]

Gets the underlying test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ToTestParameter() As PatternTestParameter
C#
PatternTestParameter ToTestParameter()
C++
PatternTestParameter ToTestParameter() abstract
J#
PatternTestParameter ToTestParameter()
JScript
function ToTestParameter() : PatternTestParameter

Return Value

The underlying test parameter

See Also

ITestParameterBuilder Interface
Gallio.Framework.Pattern Namespace


MetadataPatternAttribute Class

MetadataPatternAttribute Class
See Also Example Members
[image]

Applies declarative metadata to a test component.

A metadata attribute is similar to a decorator but more restrictive. Metadata does not modify the structure of a test directly. Instead it introduces additional metadata key / value pairs for classification, filtering, reporting, documentation or other purposes.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public MustInherit Class MetadataPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public abstract class MetadataPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class MetadataPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class MetadataPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class MetadataPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
Derived types

See Also

MetadataPatternAttribute Members
Gallio.Framework.Pattern Namespace


MetadataPatternAttribute Members

MetadataPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

Applies declarative metadata to a test component.

A metadata attribute is similar to a decorator but more restrictive. Metadata does not modify the structure of a test directly. Instead it introduces additional metadata key / value pairs for classification, filtering, reporting, documentation or other purposes.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by MetadataPatternAttribute.

Protected Constructors

 | Name | Description
Family method | MetadataPatternAttribute | Initializes a new instance of the MetadataPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


MetadataPatternAttribute Constructor

MetadataPatternAttribute Constructor
[image]

Initializes a new instance of the MetadataPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected MetadataPatternAttribute()
C++
protected:
MetadataPatternAttribute() sealed
J#
protected MetadataPatternAttribute()
JScript
protected function MetadataPatternAttribute()

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

MetadataPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


GetMetadata Method

MetadataPatternAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected abstract IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
IEnumerable<KeyValuePair<string, string>> GetMetadata() abstract
J#
protected abstract IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected abstract function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

MetadataPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

MetadataPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


PatternAttribute Class

PatternAttribute Class
See Also Example Members
[image]

The PatternAttribute class is the base class for all pattern test framework attributes. It associates a code element with a IPattern for building up parts of the test model using reflection.

Subclasses of IPattern define simpler interfaces for implementing the semantics of common types of attributes such as test factories, decorators, and data providers. Refer to the documentation of each subclass for details on its use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public MustInherit Class PatternAttribute
Inherits Attribute
Implements IPattern
C#
[TestFrameworkInternalAttribute]
public abstract class PatternAttribute : Attribute, IPattern
C++
[TestFrameworkInternalAttribute]
ref class PatternAttribute abstract : Attribute, IPattern
J#
/** @attribute TestFrameworkInternalAttribute() */
public class PatternAttribute extends Attribute implements IPattern
JScript
public
TestFrameworkInternalAttribute
class PatternAttribute extends Attribute, IPattern

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Derived types

See Also

PatternAttribute Members
Gallio.Framework.Pattern Namespace
IPattern
PatternTestFramework


PatternAttribute Members

PatternAttribute Members
See Also Example Constructors Properties Methods
[image]

The PatternAttribute class is the base class for all pattern test framework attributes. It associates a code element with a IPattern for building up parts of the test model using reflection.

Subclasses of IPattern define simpler interfaces for implementing the semantics of common types of attributes such as test factories, decorators, and data providers. Refer to the documentation of each subclass for details on its use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by PatternAttribute.

Protected Constructors

 | Name | Description
Family method | PatternAttribute | Initializes a new instance of the PatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.
Top

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace
IPattern
PatternTestFramework


PatternAttribute Constructor

PatternAttribute Constructor
[image]

Initializes a new instance of the PatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected PatternAttribute()
C++
protected:
PatternAttribute() sealed
J#
protected PatternAttribute()
JScript
protected function PatternAttribute()

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

PatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace
IPattern
PatternTestFramework


IsPrimary Property

PatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public virtual bool IsPrimary { get; }
C++
public virtual property bool IsPrimary {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

PatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.
Top

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace
IPattern
PatternTestFramework


Consume Method

PatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
J#
public virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public virtual function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTest Method

PatternAttribute.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTest
C#
public virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
J#
public virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public virtual function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTest

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTestPart Method

PatternAttribute.IsTestPart Method
[image]

Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsTestPart( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTestPart
C#
public virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
J#
public virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public virtual function IsTestPart(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTestPart

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

PatternAttribute.Process Method
[image]

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
public virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public virtual function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Implements

IPattern.Process

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


ThrowUsageErrorException Method

PatternAttribute.ThrowUsageErrorException Method

Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.

Overload List

 | Name | Description
Family method | ThrowUsageErrorException (String) | Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.
Family method | ThrowUsageErrorException (String, Exception) | Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace


ThrowUsageErrorException Method (String)

PatternAttribute.ThrowUsageErrorException Method (String)
See Also Example
[image]

Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ThrowUsageErrorException( _
ByVal message As String _
)
C#
protected void ThrowUsageErrorException(
string message
)
C++
protected:
void ThrowUsageErrorException(
String message
) sealed
J#
protected void ThrowUsageErrorException(
string message
)
JScript
protected function ThrowUsageErrorException(
message : String
)

Parameters

message
The message, not null

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace
PatternAttribute.ThrowUsageErrorException Overload List


ThrowUsageErrorException Method (String, Exception)

PatternAttribute.ThrowUsageErrorException Method (String, Exception)
See Also Example
[image]

Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ThrowUsageErrorException( _
ByVal message As String, _
ByVal ex As Exception _
)
C#
protected void ThrowUsageErrorException(
string message,
Exception ex
)
C++
protected:
void ThrowUsageErrorException(
String message,
Exception ex
) sealed
J#
protected void ThrowUsageErrorException(
string message,
Exception ex
)
JScript
protected function ThrowUsageErrorException(
message : String,
ex : Exception
)

Parameters

message
The message, not null
ex
The associated exception, or null if none

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace
PatternAttribute.ThrowUsageErrorException Overload List


PatternAttributeTargets Class

PatternAttributeTargets Class
See Also Example Members
[image]

Standard AttributeTargets flag combinations for PatternAttribute declarations. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module PatternAttributeTargets
C#
public static class PatternAttributeTargets
C++
ref class PatternAttributeTargets abstract sealed
J#
public final class PatternAttributeTargets
JScript
public class PatternAttributeTargets

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternAttributeTargets

See Also

PatternAttributeTargets Members
Gallio.Framework.Pattern Namespace


PatternAttributeTargets Members

PatternAttributeTargets Members
See Also Example Fields
[image]

Standard AttributeTargets flag combinations for PatternAttribute declarations. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by PatternAttributeTargets.

Public Fields

Name | Description
ContributionMethod | Valid attribute targets for contribution methods. This field is constant and read-only.
DataContext | Valid attribute targets for data contexts. This field is constant and read-only.
Test | Valid attribute targets for tests. This field is constant and read-only.
TestAssembly | Valid attribute targets for test assemblies. This field is constant and read-only.
TestComponent | Valid attribute targets for tests or test parameters. This field is constant and read-only.
TestConstructor | Valid attribute targets for test constructors. This field is constant and read-only.
TestContract | Valid attribute targets for test contracts. This field is constant and read-only.
TestMethod | Valid attribute targets for test methods. This field is constant and read-only.
TestParameter | Valid attribute targets for test parameters. This field is constant and read-only.
TestType | Valid attribute targets for test types. This field is constant and read-only.
Top

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


Fields

PatternAttributeTargets Fields
[image]

Public Fields

Name | Description
ContributionMethod | Valid attribute targets for contribution methods. This field is constant and read-only.
DataContext | Valid attribute targets for data contexts. This field is constant and read-only.
Test | Valid attribute targets for tests. This field is constant and read-only.
TestAssembly | Valid attribute targets for test assemblies. This field is constant and read-only.
TestComponent | Valid attribute targets for tests or test parameters. This field is constant and read-only.
TestConstructor | Valid attribute targets for test constructors. This field is constant and read-only.
TestContract | Valid attribute targets for test contracts. This field is constant and read-only.
TestMethod | Valid attribute targets for test methods. This field is constant and read-only.
TestParameter | Valid attribute targets for test parameters. This field is constant and read-only.
TestType | Valid attribute targets for test types. This field is constant and read-only.
Top

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


ContributionMethod Field

PatternAttributeTargets.ContributionMethod Field
[image]

Valid attribute targets for contribution methods. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ContributionMethod As AttributeTargets = AttributeTargets.Method
C#
public const AttributeTargets ContributionMethod = AttributeTargets.Method;
C++
public:
const AttributeTargets ContributionMethod = AttributeTargets::Method;
J#
public const AttributeTargets ContributionMethod = AttributeTargets.Method
JScript
public const ContributionMethod : AttributeTargets = AttributeTargets.Method;

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


DataContext Field

PatternAttributeTargets.DataContext Field
[image]

Valid attribute targets for data contexts. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const DataContext As AttributeTargets = (AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter)
C#
public const AttributeTargets DataContext = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter);
C++
public:
const AttributeTargets DataContext = (AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter);
J#
public const AttributeTargets DataContext = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter)
JScript
public const DataContext : AttributeTargets = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter);

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


Test Field

PatternAttributeTargets.Test Field
[image]

Valid attribute targets for tests. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Test As AttributeTargets = (AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field)
C#
public const AttributeTargets Test = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field);
C++
public:
const AttributeTargets Test = (AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field);
J#
public const AttributeTargets Test = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field)
JScript
public const Test : AttributeTargets = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field);

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestAssembly Field

PatternAttributeTargets.TestAssembly Field
[image]

Valid attribute targets for test assemblies. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestAssembly As AttributeTargets = AttributeTargets.Assembly
C#
public const AttributeTargets TestAssembly = AttributeTargets.Assembly;
C++
public:
const AttributeTargets TestAssembly = AttributeTargets::Assembly;
J#
public const AttributeTargets TestAssembly = AttributeTargets.Assembly
JScript
public const TestAssembly : AttributeTargets = AttributeTargets.Assembly;

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestComponent Field

PatternAttributeTargets.TestComponent Field
[image]

Valid attribute targets for tests or test parameters. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestComponent As AttributeTargets = (AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter)
C#
public const AttributeTargets TestComponent = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter);
C++
public:
const AttributeTargets TestComponent = (AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter);
J#
public const AttributeTargets TestComponent = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter)
JScript
public const TestComponent : AttributeTargets = (AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter);

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestConstructor Field

PatternAttributeTargets.TestConstructor Field
[image]

Valid attribute targets for test constructors. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestConstructor As AttributeTargets = AttributeTargets.Constructor
C#
public const AttributeTargets TestConstructor = AttributeTargets.Constructor;
C++
public:
const AttributeTargets TestConstructor = AttributeTargets::Constructor;
J#
public const AttributeTargets TestConstructor = AttributeTargets.Constructor
JScript
public const TestConstructor : AttributeTargets = AttributeTargets.Constructor;

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestContract Field

PatternAttributeTargets.TestContract Field
[image]

Valid attribute targets for test contracts. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestContract As AttributeTargets = AttributeTargets.Field
C#
public const AttributeTargets TestContract = AttributeTargets.Field;
C++
public:
const AttributeTargets TestContract = AttributeTargets::Field;
J#
public const AttributeTargets TestContract = AttributeTargets.Field
JScript
public const TestContract : AttributeTargets = AttributeTargets.Field;

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestMethod Field

PatternAttributeTargets.TestMethod Field
[image]

Valid attribute targets for test methods. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestMethod As AttributeTargets = AttributeTargets.Method
C#
public const AttributeTargets TestMethod = AttributeTargets.Method;
C++
public:
const AttributeTargets TestMethod = AttributeTargets::Method;
J#
public const AttributeTargets TestMethod = AttributeTargets.Method
JScript
public const TestMethod : AttributeTargets = AttributeTargets.Method;

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestParameter Field

PatternAttributeTargets.TestParameter Field
[image]

Valid attribute targets for test parameters. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestParameter As AttributeTargets = (AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter)
C#
public const AttributeTargets TestParameter = (AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter);
C++
public:
const AttributeTargets TestParameter = (AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter);
J#
public const AttributeTargets TestParameter = (AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter)
JScript
public const TestParameter : AttributeTargets = (AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter);

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


TestType Field

PatternAttributeTargets.TestType Field
[image]

Valid attribute targets for test types. This field is constant and read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestType As AttributeTargets = AttributeTargets.Class
C#
public const AttributeTargets TestType = AttributeTargets.Class;
C++
public:
const AttributeTargets TestType = AttributeTargets::Class;
J#
public const AttributeTargets TestType = AttributeTargets.Class
JScript
public const TestType : AttributeTargets = AttributeTargets.Class;

See Also

PatternAttributeTargets Class
Gallio.Framework.Pattern Namespace


PatternTest Class

PatternTest Class
See Also Example Members
[image]

A test case that has been defined by the PatternTestFramework.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTest
Inherits BaseTest
Implements IPatternTestComponent
C#
public class PatternTest : BaseTest, IPatternTestComponent
C++
ref class PatternTest : BaseTest, IPatternTestComponent
J#
public class PatternTest extends BaseTest implements IPatternTestComponent
JScript
public class PatternTest extends BaseTest, IPatternTestComponent

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTest
Gallio.Framework.Pattern.PatternTest

See Also

PatternTest Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTest Members

PatternTest Members
See Also Example Constructors Properties Methods
[image]

A test case that has been defined by the PatternTestFramework.

The following tables list the members exposed by PatternTest.

Public Constructors

 | Name | Description
Public method | PatternTest | Initializes a test initially without a parent.
Top

Public Properties

Name | Description
Public property | ApartmentState | Gets or sets the apartment state to be used to run the test.
Public property | Children | Gets a read-only list of the children of this test. (inherited from BaseTest)
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | DataContext | Gets the data context of the component.
Public property | Dependencies | Gets a read-only list of the dependencies of this test. (inherited from BaseTest)
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

(inherited from BaseTest)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTest)
Public property | IsParallelizable | Gets or sets whether the test is parallelizable.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only. (inherited from BaseTest)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

(inherited from BaseTest)
Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId. (inherited from BaseTest)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from BaseTest)
Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant. (inherited from BaseTest)
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test. (inherited from BaseTest)
Public property | TestActions | Gets the set of actions that describe the behavior of the test.
Public property | TestControllerFactory | Overridden. Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.
Public property | TestInstanceActions | Gets the set of actions that describe the behavior of the test's instances.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property. (inherited from BaseTest)
Public method | AddDependency | Adds a test dependency. (inherited from BaseTest)
Public method | AddParameter | Adds a test parameter and sets its Owner property. (inherited from BaseTest)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test. (inherited from BaseTest)
Public method | SetName | Sets the name of the component.
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTest)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTest Constructor

PatternTest Constructor
[image]

Initializes a test initially without a parent.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContext As PatternTestDataContext _
)
C#
public PatternTest(
string name,
ICodeElementInfo codeElement,
PatternTestDataContext dataContext
)
C++
public:
PatternTest(
String name,
ICodeElementInfo codeElement,
PatternTestDataContext dataContext
) sealed
J#
public PatternTest(
string name,
ICodeElementInfo codeElement,
PatternTestDataContext dataContext
)
JScript
public function PatternTest(
name : String,
codeElement : ICodeElementInfo,
dataContext : PatternTestDataContext
)

Parameters

name
The name of the test
codeElement
The point of definition of the test, or null if unknown
dataContext
The data context

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or dataContext is null

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


Properties

PatternTest Properties
[image]

Public Properties

Name | Description
Public property | ApartmentState | Gets or sets the apartment state to be used to run the test.
Public property | Children | Gets a read-only list of the children of this test. (inherited from BaseTest)
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | DataContext | Gets the data context of the component.
Public property | Dependencies | Gets a read-only list of the dependencies of this test. (inherited from BaseTest)
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

(inherited from BaseTest)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTest)
Public property | IsParallelizable | Gets or sets whether the test is parallelizable.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only. (inherited from BaseTest)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

(inherited from BaseTest)
Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId. (inherited from BaseTest)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from BaseTest)
Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant. (inherited from BaseTest)
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test. (inherited from BaseTest)
Public property | TestActions | Gets the set of actions that describe the behavior of the test.
Public property | TestControllerFactory | Overridden. Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.
Public property | TestInstanceActions | Gets the set of actions that describe the behavior of the test's instances.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


ApartmentState Property

PatternTest.ApartmentState Property
[image]

Gets or sets the apartment state to be used to run the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ApartmentState As ApartmentState
C#
public ApartmentState ApartmentState { get; set; }
C++
public property ApartmentState ApartmentState sealed {
ApartmentState get();
void set(ApartmentState value);
}
J#
/** property */
public ApartmentState get_ApartmentState();

/** property */
public void set_ApartmentState(ApartmentState value);
JScript
public function get ApartmentState() : ApartmentState

public function set ApartmentState(value : ApartmentState);

Property Value

The default value of this property is Unknown.

Remarks

If the apartment state is Unknown the test will inherit the apartment state of its parent. Otherwise it will run in a thread with the specified apartment state.

The test runner guarantees that the root test runs with the STA apartment state. Consequently the apartment state only needs to be overridden to run a test in some mode that may differ from that which it would ordinarily inherit.

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


DataContext Property

PatternTest.DataContext Property
[image]

Gets the data context of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataContext As PatternTestDataContext _
Implements IPatternTestComponent.DataContext
C#
public PatternTestDataContext DataContext { get; }
C++
public property PatternTestDataContext DataContext sealed {
PatternTestDataContext get();
}
J#
/** property */
public PatternTestDataContext get_DataContext();
JScript
public function get DataContext() : PatternTestDataContext

Implements

IPatternTestComponent.DataContext

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


IsParallelizable Property

PatternTest.IsParallelizable Property
[image]

Gets or sets whether the test is parallelizable.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsParallelizable As Boolean
C#
public bool IsParallelizable { get; set; }
C++
public property bool IsParallelizable sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsParallelizable();

/** property */
public void set_IsParallelizable(bool value);
JScript
public function get IsParallelizable() : bool

public function set IsParallelizable(value : bool);

Property Value

True if the test is parallelizable. The default value of this property is false.

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


TestActions Property

PatternTest.TestActions Property
[image]

Gets the set of actions that describe the behavior of the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestActions As PatternTestActions
C#
public PatternTestActions TestActions { get; }
C++
public property PatternTestActions TestActions sealed {
PatternTestActions get();
}
J#
/** property */
public PatternTestActions get_TestActions();
JScript
public function get TestActions() : PatternTestActions

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


TestControllerFactory Property

PatternTest.TestControllerFactory Property
[image]

Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TestControllerFactory As Func(Of ITestController) _
Implements ITest.TestControllerFactory
C#
public override Func<ITestController> TestControllerFactory { get; }
C++
public override property Func<ITestController> TestControllerFactory override {
Func<ITestController> get();
}
J#
/** property */
public Func<ITestController> get_TestControllerFactory();
JScript
public function get TestControllerFactory() : Func<ITestController>

Property Value

The test controller factory, or null if this test cannot produce a controller (and consequently is not a master test according to the definition above)

Implements

ITest.TestControllerFactory

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


TestInstanceActions Property

PatternTest.TestInstanceActions Property
[image]

Gets the set of actions that describe the behavior of the test's instances.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestInstanceActions As PatternTestInstanceActions
C#
public PatternTestInstanceActions TestInstanceActions { get; }
C++
public property PatternTestInstanceActions TestInstanceActions sealed {
PatternTestInstanceActions get();
}
J#
/** property */
public PatternTestInstanceActions get_TestInstanceActions();
JScript
public function get TestInstanceActions() : PatternTestInstanceActions

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


Timeout Property

PatternTest.Timeout Property
[image]

Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Timeout As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> Timeout { get; set; }
C++
public property Nullable<TimeSpan> Timeout sealed {
Nullable<TimeSpan> get();
void set(Nullable<TimeSpan> value);
}
J#
/** property */
public Nullable<TimeSpan> get_Timeout();

/** property */
public void set_Timeout(Nullable<TimeSpan> value);
JScript
public function get Timeout() : Nullable<TimeSpan>

public function set Timeout(value : Nullable<TimeSpan>);

Property Value

The timeout. Default value is null.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if value represents a negative time span

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


Methods

PatternTest Methods
[image]

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property. (inherited from BaseTest)
Public method | AddDependency | Adds a test dependency. (inherited from BaseTest)
Public method | AddParameter | Adds a test parameter and sets its Owner property. (inherited from BaseTest)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test. (inherited from BaseTest)
Public method | SetName | Sets the name of the component.
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTest)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


SetName Method

PatternTest.SetName Method
[image]

Sets the name of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetName( _
ByVal value As String _
) _
Implements IPatternTestComponent.SetName
C#
public void SetName(
string value
)
C++
public:
void SetName(
String value
) sealed
J#
public void SetName(
string value
)
JScript
public function SetName(
value : String
)

Implements

IPatternTestComponent.SetName

See Also

PatternTest Class
Gallio.Framework.Pattern Namespace


PatternTestActions Class

PatternTestActions Class
See Also Example Members
[image]

An implementation of IPatternTestHandler based on actions that can be sequenced and composed as chains.

This class is the backbone of the PatternTestFramework extensibility model. Because new behaviors can be defined and added to action chains at will by any component that participates in the test construction process (typically an IPattern), the framework itself does not need to hardcode the mechanism by which the behaviors are selected.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestActions
Implements IPatternTestHandler
C#
public class PatternTestActions : IPatternTestHandler
C++
ref class PatternTestActions : IPatternTestHandler
J#
public class PatternTestActions implements IPatternTestHandler
JScript
public class PatternTestActions extends IPatternTestHandler

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternTestActions

See Also

PatternTestActions Members
Gallio.Framework.Pattern Namespace
IPatternTestHandler


PatternTestActions Members

PatternTestActions Members
See Also Example Constructors Properties Methods
[image]

An implementation of IPatternTestHandler based on actions that can be sequenced and composed as chains.

This class is the backbone of the PatternTestFramework extensibility model. Because new behaviors can be defined and added to action chains at will by any component that participates in the test construction process (typically an IPattern), the framework itself does not need to hardcode the mechanism by which the behaviors are selected.

The following tables list the members exposed by PatternTestActions.

Public Constructors

 | Name | Description
Public method | PatternTestActions | Creates a test actions object initially configured with empty action chains that do nothing.
Top

Public Properties

 | Name | Description
Public property | AfterTestChain | Gets the chain of AfterTest actions.
Public property | BeforeTestChain | Gets the chain of BeforeTest actions.
Public property | DecorateTestInstanceChain | Gets the chain of DecorateTestInstance actions.
Public property | DisposeTestChain | Gets the chain of DisposeTest actions.
Public property | InitializeTestChain | Gets the chain of InitializeTest actions.
Public property | TestInstanceActions | Gets the test instance actions that describes the lifecycle of a test instance.
Public property | TestInstanceHandler | Gets the test instance handler that describes the lifecycle of a test instance.
Top

Public Methods

Name | Description
Public method AfterTest

Cleans up a completed test state after its use.

This method runs in the TestContext of its containing test step because the test has terminated.

The following actions are typically performed during this phase:

  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTest

Prepares a newly created test state before its use.

This method runs in the TestContext of its containing test step because the test has not yet been started.

The following actions are typically performed during this phase:

  • Configuring the PrimaryTestStep in anticipation of test execution.
  • Accessing user data via Data.
  • Skipping the test by throwing an appropriate SilentTestException.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
CreateDecorator

Creates a new PatternTestActions object initially configured to forward calls to the specified handler without change. The result is that any behaviors added to the action chains of the returned PatternTestActions will be invoked before, after or around those of the specified handler.

A pattern test decorator applies additional actions around those of another IPatternTestHandler for a PatternTest.

Public method DecorateTestInstance

Decorates the IPatternTestHandler of a test instance before its BeforeTestInstance actions have a chance to run.

This method runs in the TestContext of its containing test instance because the test has not yet been started.

This method may apply any number of decorations to the test instance's handler by adding actions to the supplied decoratedTestInstanceActions object. The test instance's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

The following actions are typically performed during this phase:

  • Adding additional actions for the test instance to the decoratedTestInstanceActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
  • Modifying the PatternTestState object in any way.
Public method DisposeTest

Cleans up a test following the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method InitializeTest

Initializes a test prior to the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Aborting the test run if any preconditions have not been satisfied or if the test is to be skipped.
  • Configuring the test environment in advance of the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
IPatternTestHandler


PatternTestActions Constructor

PatternTestActions Constructor
[image]

Creates a test actions object initially configured with empty action chains that do nothing.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PatternTestActions()
C++
public:
PatternTestActions() sealed
J#
public PatternTestActions()
JScript
public function PatternTestActions()

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestActions Properties
[image]

Public Properties

 | Name | Description
Public property | AfterTestChain | Gets the chain of AfterTest actions.
Public property | BeforeTestChain | Gets the chain of BeforeTest actions.
Public property | DecorateTestInstanceChain | Gets the chain of DecorateTestInstance actions.
Public property | DisposeTestChain | Gets the chain of DisposeTest actions.
Public property | InitializeTestChain | Gets the chain of InitializeTest actions.
Public property | TestInstanceActions | Gets the test instance actions that describes the lifecycle of a test instance.
Public property | TestInstanceHandler | Gets the test instance handler that describes the lifecycle of a test instance.
Top

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
IPatternTestHandler


AfterTestChain Property

PatternTestActions.AfterTestChain Property
[image]

Gets the chain of AfterTest actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AfterTestChain As ActionChain(Of PatternTestState)
C#
public ActionChain<PatternTestState> AfterTestChain { get; }
C++
public property ActionChain<PatternTestState> AfterTestChain sealed {
ActionChain<PatternTestState> get();
}
J#
/** property */
public ActionChain<PatternTestState> get_AfterTestChain();
JScript
public function get AfterTestChain() : ActionChain<PatternTestState>

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
AfterTest


BeforeTestChain Property

PatternTestActions.BeforeTestChain Property
[image]

Gets the chain of BeforeTest actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BeforeTestChain As ActionChain(Of PatternTestState)
C#
public ActionChain<PatternTestState> BeforeTestChain { get; }
C++
public property ActionChain<PatternTestState> BeforeTestChain sealed {
ActionChain<PatternTestState> get();
}
J#
/** property */
public ActionChain<PatternTestState> get_BeforeTestChain();
JScript
public function get BeforeTestChain() : ActionChain<PatternTestState>

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
BeforeTest


DecorateTestInstanceChain Property

PatternTestActions.DecorateTestInstanceChain Property
[image]

Gets the chain of DecorateTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DecorateTestInstanceChain As ActionChain(Of PatternTestState, PatternTestInstanceActions)
C#
public ActionChain<PatternTestState, PatternTestInstanceActions> DecorateTestInstanceChain { get; }
C++
public property ActionChain<PatternTestState, PatternTestInstanceActions> DecorateTestInstanceChain sealed {
ActionChain<PatternTestState, PatternTestInstanceActions> get();
}
J#
/** property */
public ActionChain<PatternTestState, PatternTestInstanceActions> get_DecorateTestInstanceChain();
JScript
public function get DecorateTestInstanceChain() : ActionChain<PatternTestState, PatternTestInstanceActions>

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
DecorateTestInstance


DisposeTestChain Property

PatternTestActions.DisposeTestChain Property
[image]

Gets the chain of DisposeTest actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisposeTestChain As ActionChain(Of PatternTestState)
C#
public ActionChain<PatternTestState> DisposeTestChain { get; }
C++
public property ActionChain<PatternTestState> DisposeTestChain sealed {
ActionChain<PatternTestState> get();
}
J#
/** property */
public ActionChain<PatternTestState> get_DisposeTestChain();
JScript
public function get DisposeTestChain() : ActionChain<PatternTestState>

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
DisposeTest


InitializeTestChain Property

PatternTestActions.InitializeTestChain Property
[image]

Gets the chain of InitializeTest actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InitializeTestChain As ActionChain(Of PatternTestState)
C#
public ActionChain<PatternTestState> InitializeTestChain { get; }
C++
public property ActionChain<PatternTestState> InitializeTestChain sealed {
ActionChain<PatternTestState> get();
}
J#
/** property */
public ActionChain<PatternTestState> get_InitializeTestChain();
JScript
public function get InitializeTestChain() : ActionChain<PatternTestState>

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
InitializeTest


TestInstanceActions Property

PatternTestActions.TestInstanceActions Property
[image]

Gets the test instance actions that describes the lifecycle of a test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestInstanceActions As PatternTestInstanceActions
C#
public PatternTestInstanceActions TestInstanceActions { get; }
C++
public property PatternTestInstanceActions TestInstanceActions sealed {
PatternTestInstanceActions get();
}
J#
/** property */
public PatternTestInstanceActions get_TestInstanceActions();
JScript
public function get TestInstanceActions() : PatternTestInstanceActions

Remarks

These actions may be further decorated on a per-instance basis using DecorateTestInstanceChain.

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


TestInstanceHandler Property

PatternTestActions.TestInstanceHandler Property
[image]

Gets the test instance handler that describes the lifecycle of a test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestInstanceHandler As IPatternTestInstanceHandler _
Implements IPatternTestHandler.TestInstanceHandler
C#
public IPatternTestInstanceHandler TestInstanceHandler { get; }
C++
public property IPatternTestInstanceHandler TestInstanceHandler sealed {
IPatternTestInstanceHandler get();
}
J#
/** property */
public IPatternTestInstanceHandler get_TestInstanceHandler();
JScript
public function get TestInstanceHandler() : IPatternTestInstanceHandler

Implements

IPatternTestHandler.TestInstanceHandler

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestActions Methods
[image]

Public Methods

Name | Description
Public method AfterTest

Cleans up a completed test state after its use.

This method runs in the TestContext of its containing test step because the test has terminated.

The following actions are typically performed during this phase:

  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTest

Prepares a newly created test state before its use.

This method runs in the TestContext of its containing test step because the test has not yet been started.

The following actions are typically performed during this phase:

  • Configuring the PrimaryTestStep in anticipation of test execution.
  • Accessing user data via Data.
  • Skipping the test by throwing an appropriate SilentTestException.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
CreateDecorator

Creates a new PatternTestActions object initially configured to forward calls to the specified handler without change. The result is that any behaviors added to the action chains of the returned PatternTestActions will be invoked before, after or around those of the specified handler.

A pattern test decorator applies additional actions around those of another IPatternTestHandler for a PatternTest.

Public method DecorateTestInstance

Decorates the IPatternTestHandler of a test instance before its BeforeTestInstance actions have a chance to run.

This method runs in the TestContext of its containing test instance because the test has not yet been started.

This method may apply any number of decorations to the test instance's handler by adding actions to the supplied decoratedTestInstanceActions object. The test instance's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

The following actions are typically performed during this phase:

  • Adding additional actions for the test instance to the decoratedTestInstanceActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
  • Modifying the PatternTestState object in any way.
Public method DisposeTest

Cleans up a test following the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method InitializeTest

Initializes a test prior to the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Aborting the test run if any preconditions have not been satisfied or if the test is to be skipped.
  • Configuring the test environment in advance of the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace
IPatternTestHandler


AfterTest Method

PatternTestActions.AfterTest Method
[image]

Cleans up a completed test state after its use.

This method runs in the TestContext of its containing test step because the test has terminated.

The following actions are typically performed during this phase:

  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub AfterTest( _
ByVal testState As PatternTestState _
) _
Implements IPatternTestHandler.AfterTest
C#
[TestEntryPointAttribute]
public void AfterTest(
PatternTestState testState
)
C++
[TestEntryPointAttribute]
public:
void AfterTest(
PatternTestState testState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void AfterTest(
PatternTestState testState
)
JScript
public

TestEntryPointAttribute
function AfterTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

Implements

IPatternTestHandler.AfterTest

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


BeforeTest Method

PatternTestActions.BeforeTest Method
[image]

Prepares a newly created test state before its use.

This method runs in the TestContext of its containing test step because the test has not yet been started.

The following actions are typically performed during this phase:

  • Configuring the PrimaryTestStep in anticipation of test execution.
  • Accessing user data via Data.
  • Skipping the test by throwing an appropriate SilentTestException.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub BeforeTest( _
ByVal testState As PatternTestState _
) _
Implements IPatternTestHandler.BeforeTest
C#
[TestEntryPointAttribute]
public void BeforeTest(
PatternTestState testState
)
C++
[TestEntryPointAttribute]
public:
void BeforeTest(
PatternTestState testState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void BeforeTest(
PatternTestState testState
)
JScript
public

TestEntryPointAttribute
function BeforeTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

Implements

IPatternTestHandler.BeforeTest

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


CreateDecorator Method

PatternTestActions.CreateDecorator Method
[image]

Creates a new PatternTestActions object initially configured to forward calls to the specified handler without change. The result is that any behaviors added to the action chains of the returned PatternTestActions will be invoked before, after or around those of the specified handler.

A pattern test decorator applies additional actions around those of another IPatternTestHandler for a PatternTest.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDecorator( _
ByVal handler As IPatternTestHandler _
) As PatternTestActions
C#
public static PatternTestActions CreateDecorator(
IPatternTestHandler handler
)
C++
public:
static PatternTestActions CreateDecorator(
IPatternTestHandler handler
)
J#
public static PatternTestActions CreateDecorator(
IPatternTestHandler handler
)
JScript
public static function CreateDecorator(
handler : IPatternTestHandler
) : PatternTestActions

Parameters

handler
The handler to decorate

Return Value

The decorated handler actions

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if handler is null

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


DecorateTestInstance Method

PatternTestActions.DecorateTestInstance Method
[image]

Decorates the IPatternTestHandler of a test instance before its BeforeTestInstance actions have a chance to run.

This method runs in the TestContext of its containing test instance because the test has not yet been started.

This method may apply any number of decorations to the test instance's handler by adding actions to the supplied decoratedTestInstanceActions object. The test instance's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

The following actions are typically performed during this phase:

  • Adding additional actions for the test instance to the decoratedTestInstanceActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.
  • Modifying the PatternTestState object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub DecorateTestInstance( _
ByVal testState As PatternTestState, _
ByVal decoratedTestInstanceActions As PatternTestInstanceActions _
) _
Implements IPatternTestHandler.DecorateTestInstance
C#
[TestEntryPointAttribute]
public void DecorateTestInstance(
PatternTestState testState,
PatternTestInstanceActions decoratedTestInstanceActions
)
C++
[TestEntryPointAttribute]
public:
void DecorateTestInstance(
PatternTestState testState,
PatternTestInstanceActions decoratedTestInstanceActions
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void DecorateTestInstance(
PatternTestState testState,
PatternTestInstanceActions decoratedTestInstanceActions
)
JScript
public

TestEntryPointAttribute
function DecorateTestInstance(
testState : PatternTestState,
decoratedTestInstanceActions : PatternTestInstanceActions
)

Parameters

testState
The test state, never null
decoratedTestInstanceActions
The test instance's actions to decorate, never null

Implements

IPatternTestHandler.DecorateTestInstance

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


DisposeTest Method

PatternTestActions.DisposeTest Method
[image]

Cleans up a test following the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub DisposeTest( _
ByVal testState As PatternTestState _
) _
Implements IPatternTestHandler.DisposeTest
C#
[TestEntryPointAttribute]
public void DisposeTest(
PatternTestState testState
)
C++
[TestEntryPointAttribute]
public:
void DisposeTest(
PatternTestState testState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void DisposeTest(
PatternTestState testState
)
JScript
public

TestEntryPointAttribute
function DisposeTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

Implements

IPatternTestHandler.DisposeTest

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


InitializeTest Method

PatternTestActions.InitializeTest Method
[image]

Initializes a test prior to the execution of its instances.

This method runs in the TestContext of the PrimaryTestStep.

The following actions are typically performed during this phase:

  • Aborting the test run if any preconditions have not been satisfied or if the test is to be skipped.
  • Configuring the test environment in advance of the enumeration and execution of all test instances.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub InitializeTest( _
ByVal testState As PatternTestState _
) _
Implements IPatternTestHandler.InitializeTest
C#
[TestEntryPointAttribute]
public void InitializeTest(
PatternTestState testState
)
C++
[TestEntryPointAttribute]
public:
void InitializeTest(
PatternTestState testState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void InitializeTest(
PatternTestState testState
)
JScript
public

TestEntryPointAttribute
function InitializeTest(
testState : PatternTestState
)

Parameters

testState
The test state, never null

Implements

IPatternTestHandler.InitializeTest

See Also

PatternTestActions Class
Gallio.Framework.Pattern Namespace


PatternTestController Class

PatternTestController Class
See Also Example Members
[image]

Controls the execution of PatternTest instances.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestController
Inherits BaseTestController
C#
public class PatternTestController : BaseTestController
C++
ref class PatternTestController : BaseTestController
J#
public class PatternTestController extends BaseTestController
JScript
public class PatternTestController extends BaseTestController

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.BaseTestController
Gallio.Framework.Pattern.PatternTestController

See Also

PatternTestController Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestController Members

PatternTestController Members
See Also Example Constructors Methods
[image]

Controls the execution of PatternTest instances.

The following tables list the members exposed by PatternTestController.

Public Constructors

 | Name | Description
Public method | PatternTestController | Creates a pattern test controller.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestController)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RunTests | Runs the tests. (inherited from BaseTestController)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunTestsImpl | Overridden. Implementation of RunTests called after argument validation has taken place.
Top

See Also

PatternTestController Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestController Constructor

PatternTestController Constructor
[image]

Creates a pattern test controller.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal formatter As IFormatter, _
ByVal converter As IConverter _
)
C#
public PatternTestController(
IFormatter formatter,
IConverter converter
)
C++
public:
PatternTestController(
IFormatter formatter,
IConverter converter
) sealed
J#
public PatternTestController(
IFormatter formatter,
IConverter converter
)
JScript
public function PatternTestController(
formatter : IFormatter,
converter : IConverter
)

Parameters

formatter
The formatter for data binding
converter
The converter for data binding

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter or converter is null

See Also

PatternTestController Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestController Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestController)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RunTests | Runs the tests. (inherited from BaseTestController)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunTestsImpl | Overridden. Implementation of RunTests called after argument validation has taken place.
Top

See Also

PatternTestController Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


RunTestsImpl Method

PatternTestController.RunTestsImpl Method
[image]

Implementation of RunTests called after argument validation has taken place.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function RunTestsImpl( _
ByVal rootTestCommand As ITestCommand, _
ByVal parentTestStep As ITestStep, _
ByVal options As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As TestOutcome
C#
protected override TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
C++
protected:
virtual TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
) override
J#
protected override TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
JScript
protected override function RunTestsImpl(
rootTestCommand : ITestCommand,
parentTestStep : ITestStep,
options : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : TestOutcome

Parameters

rootTestCommand
The root test command, not null
parentTestStep
The parent test step, or null if none
options
The test execution options, not null
progressMonitor
The progress monitor, not null

Return Value

The combined outcome of the root test command

See Also

PatternTestController Class
Gallio.Framework.Pattern Namespace


PatternTestDataContext Class

PatternTestDataContext Class
See Also Example Members
[image]

A pattern test data context introduces a scope for data source declarations.

Each PatternTest or PatternTestParameter has a PatternTestDataContext. However, data contexts may also be nested.

For example, the constructor of a test class typically augments its containing test with additional test parameters that represent its own constructor parameters. If data binding attributes are applied to the constructor, they should operate within the scope of that constructor only. To achieve this effect, the constructor declares a new PatternTestDataContext within which its test parameters will be created.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestDataContext
Implements IDataSourceResolver
C#
public class PatternTestDataContext : IDataSourceResolver
C++
ref class PatternTestDataContext : IDataSourceResolver
J#
public class PatternTestDataContext implements IDataSourceResolver
JScript
public class PatternTestDataContext extends IDataSourceResolver

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternTestDataContext

See Also

PatternTestDataContext Members
Gallio.Framework.Pattern Namespace


PatternTestDataContext Members

PatternTestDataContext Members
See Also Example Constructors Properties Methods
[image]

A pattern test data context introduces a scope for data source declarations.

Each PatternTest or PatternTestParameter has a PatternTestDataContext. However, data contexts may also be nested.

For example, the constructor of a test class typically augments its containing test with additional test parameters that represent its own constructor parameters. If data binding attributes are applied to the constructor, they should operate within the scope of that constructor only. To achieve this effect, the constructor declares a new PatternTestDataContext within which its test parameters will be created.

The following tables list the members exposed by PatternTestDataContext.

Public Constructors

 | Name | Description
Public method | PatternTestDataContext | Creates a new data context.
Top

Public Properties

Name | Description
Public property ImplicitDataBindingIndexOffset

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.
Public property | Parent | Gets the containing data context, or null if none.
Top

Public Methods

 | Name | Description
Public method | CreateChild | Creates a child data context.
Public method | DefineDataSource | Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ResolveDataSource | Resolves the data source with the specified name.
Public method | ResolveImplicitDataBindingIndex | Returns the index that should be used to implicitly bind to the nearest anonymous data source that can be found. The index is computed as the sum of the ImplicitDataBindingIndexOffset of each data context traversed to find the data source excluding the data context that actually has the data source.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


PatternTestDataContext Constructor

PatternTestDataContext Constructor
[image]

Creates a new data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal parent As PatternTestDataContext _
)
C#
public PatternTestDataContext(
PatternTestDataContext parent
)
C++
public:
PatternTestDataContext(
PatternTestDataContext parent
) sealed
J#
public PatternTestDataContext(
PatternTestDataContext parent
)
JScript
public function PatternTestDataContext(
parent : PatternTestDataContext
)

Parameters

parent
The containing data context, or null if none

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestDataContext Properties
[image]

Public Properties

Name | Description
Public property ImplicitDataBindingIndexOffset

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.
Public property | Parent | Gets the containing data context, or null if none.
Top

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


ImplicitDataBindingIndexOffset Property

PatternTestDataContext.ImplicitDataBindingIndexOffset Property
See Also Example
[image]

Gets or sets the offset to add to a test parameter's implicit data binding index to map it into the containing data context.

This property is used to determine the data binding index of a test parameter that has not been explicitly bound. The offsets are summed cumulatively to produce an implicit data binding index while traversing the chain of containing data contexts while locating the first anonymous data source.

For example, suppose Y is the second parameter of a test method. If Y does not have an explicit data binding, we will apply implicit data binding rules as follows.

  • If Y's data context contains an anonymous data source, then the implicit data binding index will be 0.
  • Otherwise, if Y's containing data context contains an anonymous data source, then the implicit data binding index will equal the offset specified in Y's data context: 1 (since it is the second parameter).
  • Otherwise, we continue searching containing data contexts and summing their offsets until we find an anonymous data source. If none is found, then data binding will fail.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplicitDataBindingIndexOffset As Integer
C#
public int ImplicitDataBindingIndexOffset { get; set; }
C++
public property int ImplicitDataBindingIndexOffset sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ImplicitDataBindingIndexOffset();

/** property */
public void set_ImplicitDataBindingIndexOffset(int value);
JScript
public function get ImplicitDataBindingIndexOffset() : int

public function set ImplicitDataBindingIndexOffset(value : int);

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


Parent Property

PatternTestDataContext.Parent Property
[image]

Gets the containing data context, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As PatternTestDataContext
C#
public PatternTestDataContext Parent { get; }
C++
public property PatternTestDataContext Parent sealed {
PatternTestDataContext get();
}
J#
/** property */
public PatternTestDataContext get_Parent();
JScript
public function get Parent() : PatternTestDataContext

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestDataContext Methods
[image]

Public Methods

 | Name | Description
Public method | CreateChild | Creates a child data context.
Public method | DefineDataSource | Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ResolveDataSource | Resolves the data source with the specified name.
Public method | ResolveImplicitDataBindingIndex | Returns the index that should be used to implicitly bind to the nearest anonymous data source that can be found. The index is computed as the sum of the ImplicitDataBindingIndexOffset of each data context traversed to find the data source excluding the data context that actually has the data source.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


CreateChild Method

PatternTestDataContext.CreateChild Method
[image]

Creates a child data context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateChild() As PatternTestDataContext
C#
public virtual PatternTestDataContext CreateChild()
C++
public:
virtual PatternTestDataContext CreateChild()
J#
public virtual PatternTestDataContext CreateChild()
JScript
public virtual function CreateChild() : PatternTestDataContext

Return Value

A handle for the child context

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


DefineDataSource Method

PatternTestDataContext.DefineDataSource Method
[image]

Defines a new data source within this data context if one does not exist. Otherwise returns the existing one.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function DefineDataSource( _
ByVal name As String _
) As DataSource
C#
public DataSource DefineDataSource(
string name
)
C++
public:
DataSource DefineDataSource(
String name
) sealed
J#
public DataSource DefineDataSource(
string name
)
JScript
public function DefineDataSource(
name : String
) : DataSource

Parameters

name
The data source name

Return Value

The defined data source

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


ResolveDataSource Method

PatternTestDataContext.ResolveDataSource Method
[image]

Resolves the data source with the specified name.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ResolveDataSource( _
ByVal name As String _
) As DataSource _
Implements IDataSourceResolver.ResolveDataSource
C#
public DataSource ResolveDataSource(
string name
)
C++
public:
DataSource ResolveDataSource(
String name
) sealed
J#
public DataSource ResolveDataSource(
string name
)
JScript
public function ResolveDataSource(
name : String
) : DataSource

Parameters

name
The data source name

Return Value

The resolved data source, or null if none found

Implements

IDataSourceResolver.ResolveDataSource

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace


ResolveImplicitDataBindingIndex Method

PatternTestDataContext.ResolveImplicitDataBindingIndex Method
See Also Example
[image]

Returns the index that should be used to implicitly bind to the nearest anonymous data source that can be found. The index is computed as the sum of the ImplicitDataBindingIndexOffset of each data context traversed to find the data source excluding the data context that actually has the data source.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ResolveImplicitDataBindingIndex() As Nullable(Of Integer)
C#
public Nullable<int> ResolveImplicitDataBindingIndex()
C++
public:
Nullable<int> ResolveImplicitDataBindingIndex() sealed
J#
public Nullable<int> ResolveImplicitDataBindingIndex()
JScript
public function ResolveImplicitDataBindingIndex() : Nullable<int>

Return Value

The implicit data binding index, or null if no anonymous data sources were found

See Also

PatternTestDataContext Class
Gallio.Framework.Pattern Namespace
ImplicitDataBindingIndexOffset


PatternTestExplorer Class

PatternTestExplorer Class
See Also Example Members
[image]

A test explorer for PatternTestFramework.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestExplorer
Inherits BaseTestExplorer
C#
public class PatternTestExplorer : BaseTestExplorer
C++
ref class PatternTestExplorer : BaseTestExplorer
J#
public class PatternTestExplorer extends BaseTestExplorer
JScript
public class PatternTestExplorer extends BaseTestExplorer

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestExplorer
Gallio.Framework.Pattern.PatternTestExplorer

See Also

PatternTestExplorer Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestExplorer Members

PatternTestExplorer Members
See Also Example Constructors Properties Methods
[image]

A test explorer for PatternTestFramework.

The following tables list the members exposed by PatternTestExplorer.

Public Constructors

 | Name | Description
Public method | PatternTestExplorer | Creates a test explorer.
Top

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests. (inherited from BaseTestExplorer)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly | Overridden. Explores the tests defined by an assembly and links them into the TestModel.
Public method | ExploreType | Overridden. Explores the tests defined by a type and links them into the TestModel.
Public method | FinishModel | Overridden. Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestExplorer Constructor

PatternTestExplorer Constructor
[image]

Creates a test explorer.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModel As TestModel, _
ByVal extensions As IPatternTestFrameworkExtension() _
)
C#
public PatternTestExplorer(
TestModel testModel,
IPatternTestFrameworkExtension[] extensions
)
C++
public:
PatternTestExplorer(
TestModel testModel,
array<IPatternTestFrameworkExtension>^ extensions
) sealed
J#
public PatternTestExplorer(
TestModel testModel,
IPatternTestFrameworkExtension[] extensions
)
JScript
public function PatternTestExplorer(
testModel : TestModel,
extensions : IPatternTestFrameworkExtension[]
)

Parameters

testModel
The test model
extensions
The test framework extensions

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModel or extensions is null

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestExplorer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly | Overridden. Explores the tests defined by an assembly and links them into the TestModel.
Public method | ExploreType | Overridden. Explores the tests defined by a type and links them into the TestModel.
Public method | FinishModel | Overridden. Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


ExploreAssembly Method

PatternTestExplorer.ExploreAssembly Method
[image]

Explores the tests defined by an assembly and links them into the TestModel.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub ExploreAssembly( _
ByVal assembly As IAssemblyInfo, _
ByVal consumer As Action(Of ITest) _
) _
Implements ITestExplorer.ExploreAssembly
C#
public override void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
C++
public:
virtual void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
) override
J#
public override void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
JScript
public override function ExploreAssembly(
assembly : IAssemblyInfo,
consumer : Action<ITest>
)

Parameters

assembly
The assembly
consumer
An action to perform on each assembly-level test explored, or null if no action is required

Implements

ITestExplorer.ExploreAssembly

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace


ExploreType Method

PatternTestExplorer.ExploreType Method
[image]

Explores the tests defined by a type and links them into the TestModel.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub ExploreType( _
ByVal type As ITypeInfo, _
ByVal consumer As Action(Of ITest) _
) _
Implements ITestExplorer.ExploreType
C#
public override void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
C++
public:
virtual void ExploreType(
ITypeInfo type,
Action<ITest> consumer
) override
J#
public override void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
JScript
public override function ExploreType(
type : ITypeInfo,
consumer : Action<ITest>
)

Parameters

type
The type
consumer
An action to perform on each type-level test explored, or null if no action is required

Implements

ITestExplorer.ExploreType

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace


FinishModel Method

PatternTestExplorer.FinishModel Method
[image]

Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub FinishModel() _
Implements ITestExplorer.FinishModel
C#
public override void FinishModel()
C++
public:
virtual void FinishModel() override
J#
public override void FinishModel()
JScript
public override function FinishModel()

Implements

ITestExplorer.FinishModel

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace


IsTest Method

PatternTestExplorer.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTest( _
ByVal element As ICodeElementInfo _
) As Boolean _
Implements ITestExplorer.IsTest
C#
public override bool IsTest(
ICodeElementInfo element
)
C++
public:
virtual bool IsTest(
ICodeElementInfo element
) override
J#
public override bool IsTest(
ICodeElementInfo element
)
JScript
public override function IsTest(
element : ICodeElementInfo
) : bool

Parameters

element
The element

Return Value

True if the element represents a test

Implements

ITestExplorer.IsTest

See Also

PatternTestExplorer Class
Gallio.Framework.Pattern Namespace


PatternTestFramework Class

PatternTestFramework Class
See Also Example Members
[image]

The pattern test framework is a built-in framework that Gallio provides based on reflection over attributes that implement IPattern.

The pattern test framework does not provide many attributes that end-users would use to write tests. The framework is intended to be extended by IPatternTestFrameworkExtension components and libraries that define the test syntax and other facilities.

For example, a Test-Driven framework would augment the base framework with a syntax based around test fixtures, test methods and assertions. A Behavior-Driven framework would instead use a syntax based around contexts and specifications. Both frameworks would share the common attribute-based model provided by the pattern test framework. They may even interoperate to a large extent.

Other add-on libraries and tools may further contribute functionality to the pattern test framework by registering components with the runtime or by subclassing pattern attributes.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestFramework
Inherits BaseTestFramework
C#
public class PatternTestFramework : BaseTestFramework
C++
ref class PatternTestFramework : BaseTestFramework
J#
public class PatternTestFramework extends BaseTestFramework
JScript
public class PatternTestFramework extends BaseTestFramework

Remarks

Gallio supports the use of multiple test frameworks. The pattern test framework model defined here may not be appropriate for all purposes. Therefore you may consider creating a new test framework from scratch by implementing ITestFramework and ITestExplorer appropriately to obtain the desired semantics.

The name of the Pattern Test Framework derives from the similarity between the recursive construction process performed by IPattern and the kind of pattern matching that is performed by a recursive descent parser. Each primary IPattern can be thought of as a grammar rule that matches a given code element and describes how further matching of nested code elements is intended to occur. The actual matching performed is somewhat simplistic (largely based on attribute lookup) but on the whole the framework provides a quite flexible implementation pattern for a wide variety of testing features.

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestFramework
Gallio.Framework.Pattern.PatternTestFramework

See Also

PatternTestFramework Members
Gallio.Framework.Pattern Namespace


PatternTestFramework Members

PatternTestFramework Members
See Also Example Constructors Properties Methods
[image]

The pattern test framework is a built-in framework that Gallio provides based on reflection over attributes that implement IPattern.

The pattern test framework does not provide many attributes that end-users would use to write tests. The framework is intended to be extended by IPatternTestFrameworkExtension components and libraries that define the test syntax and other facilities.

For example, a Test-Driven framework would augment the base framework with a syntax based around test fixtures, test methods and assertions. A Behavior-Driven framework would instead use a syntax based around contexts and specifications. Both frameworks would share the common attribute-based model provided by the pattern test framework. They may even interoperate to a large extent.

Other add-on libraries and tools may further contribute functionality to the pattern test framework by registering components with the runtime or by subclassing pattern attributes.

The following tables list the members exposed by PatternTestFramework.

Public Constructors

 | Name | Description
Public method | PatternTestFramework | Creates an instance of the pattern test framework.
Top

Public Properties

 | Name | Description
Public property | Id | Overridden. Gets the unique id of the test framework.
Public property | Name | Overridden. Gets the name of the test framework.
Top

Public Methods

 | Name | Description
Public method | ConfigureTestDomain | Applies additional contributions to a test domain, if desired. (inherited from BaseTestFramework)
Public method | CreateTestExplorer | Overridden. Creates a test explorer for this test framework.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


PatternTestFramework Constructor

PatternTestFramework Constructor
[image]

Creates an instance of the pattern test framework.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal extensions As IPatternTestFrameworkExtension() _
)
C#
public PatternTestFramework(
IPatternTestFrameworkExtension[] extensions
)
C++
public:
PatternTestFramework(
array<IPatternTestFrameworkExtension>^ extensions
) sealed
J#
public PatternTestFramework(
IPatternTestFrameworkExtension[] extensions
)
JScript
public function PatternTestFramework(
extensions : IPatternTestFrameworkExtension[]
)

Parameters

extensions
The framework extensions

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if extensions is null

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestFramework Properties
[image]

Public Properties

 | Name | Description
Public property | Id | Overridden. Gets the unique id of the test framework.
Public property | Name | Overridden. Gets the name of the test framework.
Top

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


Id Property

PatternTestFramework.Id Property
[image]

Gets the unique id of the test framework.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Id As Guid _
Implements ITestFramework.Id
C#
public override Guid Id { get; }
C++
public override property Guid Id override {
Guid get();
}
J#
/** property */
public Guid get_Id();
JScript
public function get Id() : Guid

Implements

ITestFramework.Id

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


Name Property

PatternTestFramework.Name Property
[image]

Gets the name of the test framework.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String _
Implements ITestFramework.Name
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ITestFramework.Name

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestFramework Methods
[image]

Public Methods

 | Name | Description
Public method | ConfigureTestDomain | Applies additional contributions to a test domain, if desired. (inherited from BaseTestFramework)
Public method | CreateTestExplorer | Overridden. Creates a test explorer for this test framework.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


CreateTestExplorer Method

PatternTestFramework.CreateTestExplorer Method
[image]

Creates a test explorer for this test framework.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateTestExplorer( _
ByVal testModel As TestModel _
) As ITestExplorer _
Implements ITestFramework.CreateTestExplorer
C#
public override ITestExplorer CreateTestExplorer(
TestModel testModel
)
C++
public:
virtual ITestExplorer CreateTestExplorer(
TestModel testModel
) override
J#
public override ITestExplorer CreateTestExplorer(
TestModel testModel
)
JScript
public override function CreateTestExplorer(
testModel : TestModel
) : ITestExplorer

Parameters

testModel
The test model to populate incrementally as tests are discovered

Return Value

The test explorer

Implements

ITestFramework.CreateTestExplorer

See Also

PatternTestFramework Class
Gallio.Framework.Pattern Namespace


PatternTestInstanceActions Class

PatternTestInstanceActions Class
See Also Example Members
[image]

An implementation of IPatternTestInstanceHandler based on actions that can be sequenced and composed as chains.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestInstanceActions
Implements IPatternTestInstanceHandler
C#
public class PatternTestInstanceActions : IPatternTestInstanceHandler
C++
ref class PatternTestInstanceActions : IPatternTestInstanceHandler
J#
public class PatternTestInstanceActions implements IPatternTestInstanceHandler
JScript
public class PatternTestInstanceActions extends IPatternTestInstanceHandler

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternTestInstanceActions

See Also

PatternTestInstanceActions Members
Gallio.Framework.Pattern Namespace
IPatternTestInstanceHandler
PatternTestActions


PatternTestInstanceActions Members

PatternTestInstanceActions Members
See Also Example Constructors Properties Methods
[image]

An implementation of IPatternTestInstanceHandler based on actions that can be sequenced and composed as chains.

The following tables list the members exposed by PatternTestInstanceActions.

Public Constructors

 | Name | Description
Public method | PatternTestInstanceActions | Creates a test instance actions object initially configured with empty action chains that do nothing.
Top

Public Properties

 | Name | Description
Public property | AfterTestInstanceChain | Gets the chain of AfterTestInstance actions.
Public property | BeforeTestInstanceChain | Gets the chain of BeforeTestInstance actions.
Public property | DecorateChildTestChain | Gets the chain of DecorateChildTest actions.
Public property | DisposeTestInstanceChain | Gets the chain of DisposeTestInstance actions.
Public property | ExecuteTestInstanceChain | Gets the chain of ExecuteTestInstance actions.
Public property | InitializeTestInstanceChain | Gets the chain of InitializeTestInstance actions.
Public property | RunTestInstanceBodyChain | Gets the chain of RunTestInstanceBody functions.
Public property | SetUpTestInstanceChain | Gets the chain of SetUpTestInstance actions.
Public property | TearDownTestInstanceChain | Gets the chain of TearDownTestInstance actions.
Top

Public Methods

Name | Description
Public method AfterTestInstance

Cleans up a completed test instance after its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has terminated.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the test disposal.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTestInstance

Prepares a newly created test instance state before its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has not yet started.

If IsReusingPrimaryTestStep is false then this method has the opportunity to modify the name or add metadata to the brand new PatternTestStep that was created for just this test instance.

The following actions are typically performed during this phase:

  • Adding or changing slot values.
  • Configuring the test environment in advance of test initialization.
  • Modifying the name or metadata of the PatternTestStep, if IsReusingPrimaryTestStep is false (since the primary test step has already started execution).
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way UNLESS IsReusingPrimaryTestStep is false.
  • Skipping the test instance by throwing an appropriate SilentTestException.
CreateDecorator

Creates a new PatternTestInstanceActions object initially configured to forward calls to the specified handler without change. The result is that any behaviors added to the action chains of the returned PatternTestInstanceActions will be invoked before, after or around those of the specified handler.

A pattern test decorator applies additional actions around those of another IPatternTestInstanceHandler for a PatternTestStep.

Public method DecorateChildTest

Decorates the IPatternTestInstanceHandler of a child test before its BeforeTest actions have a chance to run.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

This method may apply any number of decorations to the child test's handler by adding actions to the supplied decoratedChildTestActions object. The child test's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

A typical use of this method is to augment the SetUpTestInstance and TearDownTestInstance behaviors of the child test with additional contributions provided by the parent.

It is also possible to decorate descendants besides direct children. To do so, decorate the child's DecorateChildTest behavior to perpetuate the decoration down to more deeply nested descendants. This process of recursive decoration may be carried along to whatever depth is required.

The following actions are typically performed during this phase:

  • Adding additional actions for the child test to the decoratedChildTestActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method DisposeTestInstance

Disposes a test instance that is about to terminate.

This method runs in the TestContext of the test instance in the Dispose lifecycle phase.

The following actions are typically performed during this phase:

  • Deconfiguring the test fixture following test execution.
  • Disposing the test fixture instance.
  • Disposing other resources.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method ExecuteTestInstance

Executes the test instance.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method InitializeTestInstance

Initializes a test instance that has just started running.

This method runs in the TestContext of the test instance in the Initialize lifecycle phase.

The following actions are typically performed during this phase:

  • Creating the test fixture instance and setting FixtureType and FixtureInstance.
  • Configuring the test fixture in advance of test execution.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | RunTestInstanceBody | Runs the body of the test from the Initialize phase through the Dispose phase.
Public method SetUpTestInstance

Sets up a test instance prior to execution.

This method runs in the TestContext of the test instance in the SetUp lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test setup methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method TearDownTestInstance

Tears down a test instance following execution.

This method runs in the TestContext of the test instance in the TearDown lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test teardown methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
IPatternTestInstanceHandler
PatternTestActions


PatternTestInstanceActions Constructor

PatternTestInstanceActions Constructor
[image]

Creates a test instance actions object initially configured with empty action chains that do nothing.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PatternTestInstanceActions()
C++
public:
PatternTestInstanceActions() sealed
J#
public PatternTestInstanceActions()
JScript
public function PatternTestInstanceActions()

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestInstanceActions Properties
[image]

Public Properties

 | Name | Description
Public property | AfterTestInstanceChain | Gets the chain of AfterTestInstance actions.
Public property | BeforeTestInstanceChain | Gets the chain of BeforeTestInstance actions.
Public property | DecorateChildTestChain | Gets the chain of DecorateChildTest actions.
Public property | DisposeTestInstanceChain | Gets the chain of DisposeTestInstance actions.
Public property | ExecuteTestInstanceChain | Gets the chain of ExecuteTestInstance actions.
Public property | InitializeTestInstanceChain | Gets the chain of InitializeTestInstance actions.
Public property | RunTestInstanceBodyChain | Gets the chain of RunTestInstanceBody functions.
Public property | SetUpTestInstanceChain | Gets the chain of SetUpTestInstance actions.
Public property | TearDownTestInstanceChain | Gets the chain of TearDownTestInstance actions.
Top

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
IPatternTestInstanceHandler
PatternTestActions


AfterTestInstanceChain Property

PatternTestInstanceActions.AfterTestInstanceChain Property
[image]

Gets the chain of AfterTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AfterTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> AfterTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> AfterTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_AfterTestInstanceChain();
JScript
public function get AfterTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
AfterTestInstance


BeforeTestInstanceChain Property

PatternTestInstanceActions.BeforeTestInstanceChain Property
[image]

Gets the chain of BeforeTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BeforeTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> BeforeTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> BeforeTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_BeforeTestInstanceChain();
JScript
public function get BeforeTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
BeforeTestInstance


DecorateChildTestChain Property

PatternTestInstanceActions.DecorateChildTestChain Property
[image]

Gets the chain of DecorateChildTest actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DecorateChildTestChain As ActionChain(Of PatternTestInstanceState, PatternTestActions)
C#
public ActionChain<PatternTestInstanceState, PatternTestActions> DecorateChildTestChain { get; }
C++
public property ActionChain<PatternTestInstanceState, PatternTestActions> DecorateChildTestChain sealed {
ActionChain<PatternTestInstanceState, PatternTestActions> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState, PatternTestActions> get_DecorateChildTestChain();
JScript
public function get DecorateChildTestChain() : ActionChain<PatternTestInstanceState, PatternTestActions>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
DecorateChildTest


DisposeTestInstanceChain Property

PatternTestInstanceActions.DisposeTestInstanceChain Property
[image]

Gets the chain of DisposeTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisposeTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> DisposeTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> DisposeTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_DisposeTestInstanceChain();
JScript
public function get DisposeTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
DisposeTestInstance


ExecuteTestInstanceChain Property

PatternTestInstanceActions.ExecuteTestInstanceChain Property
[image]

Gets the chain of ExecuteTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecuteTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> ExecuteTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> ExecuteTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_ExecuteTestInstanceChain();
JScript
public function get ExecuteTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
ExecuteTestInstance


InitializeTestInstanceChain Property

PatternTestInstanceActions.InitializeTestInstanceChain Property
See Also Example
[image]

Gets the chain of InitializeTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InitializeTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> InitializeTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> InitializeTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_InitializeTestInstanceChain();
JScript
public function get InitializeTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
InitializeTestInstance


RunTestInstanceBodyChain Property

PatternTestInstanceActions.RunTestInstanceBodyChain Property
[image]

Gets the chain of RunTestInstanceBody functions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RunTestInstanceBodyChain As FuncChain(Of PatternTestInstanceState, TestOutcome)
C#
public FuncChain<PatternTestInstanceState, TestOutcome> RunTestInstanceBodyChain { get; }
C++
public property FuncChain<PatternTestInstanceState, TestOutcome> RunTestInstanceBodyChain sealed {
FuncChain<PatternTestInstanceState, TestOutcome> get();
}
J#
/** property */
public FuncChain<PatternTestInstanceState, TestOutcome> get_RunTestInstanceBodyChain();
JScript
public function get RunTestInstanceBodyChain() : FuncChain<PatternTestInstanceState, TestOutcome>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
RunTestInstanceBody


SetUpTestInstanceChain Property

PatternTestInstanceActions.SetUpTestInstanceChain Property
[image]

Gets the chain of SetUpTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SetUpTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> SetUpTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> SetUpTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_SetUpTestInstanceChain();
JScript
public function get SetUpTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
SetUpTestInstance


TearDownTestInstanceChain Property

PatternTestInstanceActions.TearDownTestInstanceChain Property
See Also Example
[image]

Gets the chain of TearDownTestInstance actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TearDownTestInstanceChain As ActionChain(Of PatternTestInstanceState)
C#
public ActionChain<PatternTestInstanceState> TearDownTestInstanceChain { get; }
C++
public property ActionChain<PatternTestInstanceState> TearDownTestInstanceChain sealed {
ActionChain<PatternTestInstanceState> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState> get_TearDownTestInstanceChain();
JScript
public function get TearDownTestInstanceChain() : ActionChain<PatternTestInstanceState>

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
TearDownTestInstance


Methods

PatternTestInstanceActions Methods
[image]

Public Methods

Name | Description
Public method AfterTestInstance

Cleans up a completed test instance after its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has terminated.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the test disposal.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method BeforeTestInstance

Prepares a newly created test instance state before its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has not yet started.

If IsReusingPrimaryTestStep is false then this method has the opportunity to modify the name or add metadata to the brand new PatternTestStep that was created for just this test instance.

The following actions are typically performed during this phase:

  • Adding or changing slot values.
  • Configuring the test environment in advance of test initialization.
  • Modifying the name or metadata of the PatternTestStep, if IsReusingPrimaryTestStep is false (since the primary test step has already started execution).
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way UNLESS IsReusingPrimaryTestStep is false.
  • Skipping the test instance by throwing an appropriate SilentTestException.
CreateDecorator

Creates a new PatternTestInstanceActions object initially configured to forward calls to the specified handler without change. The result is that any behaviors added to the action chains of the returned PatternTestInstanceActions will be invoked before, after or around those of the specified handler.

A pattern test decorator applies additional actions around those of another IPatternTestInstanceHandler for a PatternTestStep.

Public method DecorateChildTest

Decorates the IPatternTestInstanceHandler of a child test before its BeforeTest actions have a chance to run.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

This method may apply any number of decorations to the child test's handler by adding actions to the supplied decoratedChildTestActions object. The child test's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

A typical use of this method is to augment the SetUpTestInstance and TearDownTestInstance behaviors of the child test with additional contributions provided by the parent.

It is also possible to decorate descendants besides direct children. To do so, decorate the child's DecorateChildTest behavior to perpetuate the decoration down to more deeply nested descendants. This process of recursive decoration may be carried along to whatever depth is required.

The following actions are typically performed during this phase:

  • Adding additional actions for the child test to the decoratedChildTestActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method DisposeTestInstance

Disposes a test instance that is about to terminate.

This method runs in the TestContext of the test instance in the Dispose lifecycle phase.

The following actions are typically performed during this phase:

  • Deconfiguring the test fixture following test execution.
  • Disposing the test fixture instance.
  • Disposing other resources.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method ExecuteTestInstance

Executes the test instance.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method InitializeTestInstance

Initializes a test instance that has just started running.

This method runs in the TestContext of the test instance in the Initialize lifecycle phase.

The following actions are typically performed during this phase:

  • Creating the test fixture instance and setting FixtureType and FixtureInstance.
  • Configuring the test fixture in advance of test execution.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | RunTestInstanceBody | Runs the body of the test from the Initialize phase through the Dispose phase.
Public method SetUpTestInstance

Sets up a test instance prior to execution.

This method runs in the TestContext of the test instance in the SetUp lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test setup methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method TearDownTestInstance

Tears down a test instance following execution.

This method runs in the TestContext of the test instance in the TearDown lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test teardown methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace
IPatternTestInstanceHandler
PatternTestActions


AfterTestInstance Method

PatternTestInstanceActions.AfterTestInstance Method
[image]

Cleans up a completed test instance after its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has terminated.

The following actions are typically performed during this phase:

  • Deconfiguring the test environment following the test disposal.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub AfterTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.AfterTestInstance
C#
[TestEntryPointAttribute]
public void AfterTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void AfterTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void AfterTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function AfterTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.AfterTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


BeforeTestInstance Method

PatternTestInstanceActions.BeforeTestInstance Method
[image]

Prepares a newly created test instance state before its use.

This method runs in the TestContext of the PrimaryTestStep because the test step for this instance (if different from the primary step) has not yet started.

If IsReusingPrimaryTestStep is false then this method has the opportunity to modify the name or add metadata to the brand new PatternTestStep that was created for just this test instance.

The following actions are typically performed during this phase:

  • Adding or changing slot values.
  • Configuring the test environment in advance of test initialization.
  • Modifying the name or metadata of the PatternTestStep, if IsReusingPrimaryTestStep is false (since the primary test step has already started execution).
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way UNLESS IsReusingPrimaryTestStep is false.
  • Skipping the test instance by throwing an appropriate SilentTestException.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub BeforeTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.BeforeTestInstance
C#
[TestEntryPointAttribute]
public void BeforeTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void BeforeTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void BeforeTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function BeforeTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.BeforeTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


CreateDecorator Method

PatternTestInstanceActions.CreateDecorator Method
[image]

Creates a new PatternTestInstanceActions object initially configured to forward calls to the specified handler without change. The result is that any behaviors added to the action chains of the returned PatternTestInstanceActions will be invoked before, after or around those of the specified handler.

A pattern test decorator applies additional actions around those of another IPatternTestInstanceHandler for a PatternTestStep.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDecorator( _
ByVal handler As IPatternTestInstanceHandler _
) As PatternTestInstanceActions
C#
public static PatternTestInstanceActions CreateDecorator(
IPatternTestInstanceHandler handler
)
C++
public:
static PatternTestInstanceActions CreateDecorator(
IPatternTestInstanceHandler handler
)
J#
public static PatternTestInstanceActions CreateDecorator(
IPatternTestInstanceHandler handler
)
JScript
public static function CreateDecorator(
handler : IPatternTestInstanceHandler
) : PatternTestInstanceActions

Parameters

handler
The handler to decorate

Return Value

The decorated handler actions

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if handler is null

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


DecorateChildTest Method

PatternTestInstanceActions.DecorateChildTest Method
[image]

Decorates the IPatternTestInstanceHandler of a child test before its BeforeTest actions have a chance to run.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

This method may apply any number of decorations to the child test's handler by adding actions to the supplied decoratedChildTestActions object. The child test's original handler is unmodified by this operation and the decorated actions are discarded once the child test is finished.

A typical use of this method is to augment the SetUpTestInstance and TearDownTestInstance behaviors of the child test with additional contributions provided by the parent.

It is also possible to decorate descendants besides direct children. To do so, decorate the child's DecorateChildTest behavior to perpetuate the decoration down to more deeply nested descendants. This process of recursive decoration may be carried along to whatever depth is required.

The following actions are typically performed during this phase:

  • Adding additional actions for the child test to the decoratedChildTestActions.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub DecorateChildTest( _
ByVal testInstanceState As PatternTestInstanceState, _
ByVal decoratedChildTestActions As PatternTestActions _
) _
Implements IPatternTestInstanceHandler.DecorateChildTest
C#
[TestEntryPointAttribute]
public void DecorateChildTest(
PatternTestInstanceState testInstanceState,
PatternTestActions decoratedChildTestActions
)
C++
[TestEntryPointAttribute]
public:
void DecorateChildTest(
PatternTestInstanceState testInstanceState,
PatternTestActions decoratedChildTestActions
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void DecorateChildTest(
PatternTestInstanceState testInstanceState,
PatternTestActions decoratedChildTestActions
)
JScript
public

TestEntryPointAttribute
function DecorateChildTest(
testInstanceState : PatternTestInstanceState,
decoratedChildTestActions : PatternTestActions
)

Parameters

testInstanceState
The test instance state, never null
decoratedChildTestActions
The child test's actions to decorate, never null

Implements

IPatternTestInstanceHandler.DecorateChildTest

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


DisposeTestInstance Method

PatternTestInstanceActions.DisposeTestInstance Method
[image]

Disposes a test instance that is about to terminate.

This method runs in the TestContext of the test instance in the Dispose lifecycle phase.

The following actions are typically performed during this phase:

  • Deconfiguring the test fixture following test execution.
  • Disposing the test fixture instance.
  • Disposing other resources.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub DisposeTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.DisposeTestInstance
C#
[TestEntryPointAttribute]
public void DisposeTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void DisposeTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void DisposeTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function DisposeTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.DisposeTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


ExecuteTestInstance Method

PatternTestInstanceActions.ExecuteTestInstance Method
[image]

Executes the test instance.

This method runs in the TestContext of the test instance in the Execute lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub ExecuteTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.ExecuteTestInstance
C#
[TestEntryPointAttribute]
public void ExecuteTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void ExecuteTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void ExecuteTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function ExecuteTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.ExecuteTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


InitializeTestInstance Method

PatternTestInstanceActions.InitializeTestInstance Method
[image]

Initializes a test instance that has just started running.

This method runs in the TestContext of the test instance in the Initialize lifecycle phase.

The following actions are typically performed during this phase:

  • Creating the test fixture instance and setting FixtureType and FixtureInstance.
  • Configuring the test fixture in advance of test execution.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub InitializeTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.InitializeTestInstance
C#
[TestEntryPointAttribute]
public void InitializeTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void InitializeTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void InitializeTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function InitializeTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.InitializeTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


RunTestInstanceBody Method

PatternTestInstanceActions.RunTestInstanceBody Method
[image]

Runs the body of the test from the Initialize phase through the Dispose phase.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Function RunTestInstanceBody( _
ByVal testInstanceState As PatternTestInstanceState _
) As TestOutcome _
Implements IPatternTestInstanceHandler.RunTestInstanceBody
C#
[TestEntryPointAttribute]
public TestOutcome RunTestInstanceBody(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
TestOutcome RunTestInstanceBody(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public TestOutcome RunTestInstanceBody(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function RunTestInstanceBody(
testInstanceState : PatternTestInstanceState
) : TestOutcome

Parameters

testInstanceState
The test instance state, never null

Return Value

The test outcome

Implements

IPatternTestInstanceHandler.RunTestInstanceBody

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


SetUpTestInstance Method

PatternTestInstanceActions.SetUpTestInstance Method
[image]

Sets up a test instance prior to execution.

This method runs in the TestContext of the test instance in the SetUp lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test setup methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub SetUpTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.SetUpTestInstance
C#
[TestEntryPointAttribute]
public void SetUpTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void SetUpTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void SetUpTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function SetUpTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.SetUpTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


TearDownTestInstance Method

PatternTestInstanceActions.TearDownTestInstance Method
[image]

Tears down a test instance following execution.

This method runs in the TestContext of the test instance in the TearDown lifecycle phase.

The following actions are typically performed during this phase:

  • Invoking test teardown methods.
  • Accessing user data via Data.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
  • Modifying the PatternTestStep object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub TearDownTestInstance( _
ByVal testInstanceState As PatternTestInstanceState _
) _
Implements IPatternTestInstanceHandler.TearDownTestInstance
C#
[TestEntryPointAttribute]
public void TearDownTestInstance(
PatternTestInstanceState testInstanceState
)
C++
[TestEntryPointAttribute]
public:
void TearDownTestInstance(
PatternTestInstanceState testInstanceState
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void TearDownTestInstance(
PatternTestInstanceState testInstanceState
)
JScript
public

TestEntryPointAttribute
function TearDownTestInstance(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, never null

Implements

IPatternTestInstanceHandler.TearDownTestInstance

See Also

PatternTestInstanceActions Class
Gallio.Framework.Pattern Namespace


PatternTestInstanceState Class

PatternTestInstanceState Class
See Also Example Members
[image]

Represents the run-time state of a single instance of a PatternTest that is to be executed.

Typical lifecycle of PatternTestInstanceState:

  • The PatternTestController creates a PatternTestInstanceState for the instance of the PatternTest to be executed using particular data bindings.
  • The controller populates the instance state with slot values for each slot with an associated IDataAccessor in the PatternTestState.
  • The controller calls BeforeTestInstance to give test extensions the opportunity to modify the instance state.
  • The controller initializes, sets up, executes, tears down and disposes the test instance.
  • The controller calls AfterTestInstance to give test extensions the opportunity to clean up the instance state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestInstanceState
C#
public class PatternTestInstanceState
C++
ref class PatternTestInstanceState
J#
public class PatternTestInstanceState
JScript
public class PatternTestInstanceState

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternTestInstanceState

See Also

PatternTestInstanceState Members
Gallio.Framework.Pattern Namespace


PatternTestInstanceState Members

PatternTestInstanceState Members
See Also Example Properties Methods
[image]

Represents the run-time state of a single instance of a PatternTest that is to be executed.

Typical lifecycle of PatternTestInstanceState:

  • The PatternTestController creates a PatternTestInstanceState for the instance of the PatternTest to be executed using particular data bindings.
  • The controller populates the instance state with slot values for each slot with an associated IDataAccessor in the PatternTestState.
  • The controller calls BeforeTestInstance to give test extensions the opportunity to modify the instance state.
  • The controller initializes, sets up, executes, tears down and disposes the test instance.
  • The controller calls AfterTestInstance to give test extensions the opportunity to clean up the instance state.

The following tables list the members exposed by PatternTestInstanceState.

Public Properties

 | Name | Description
Public property | BindingItem | Gets the data item obtained from the test's DataBindingContext to create this state.
Public property | Converter | Gets the converter for data binding.
Public property | Data | Gets the user data collection associated with the test instance state. It may be used to associate arbitrary key/value pairs with the execution of the test instance.
Public property | FixtureInstance | Gets or sets the test fixture instance or null if none.
Public property | FixtureType | Gets or sets the test fixture type or null if none.
Public property | Formatter | Gets the formatter for data binding.
Public property | IsReusingPrimaryTestStep | Returns true if the TestStep is the PrimaryTestStep that was created for the test. False if a new PatternTestStep was created as a child of the primary test step just for this test instance.
Public property | SlotValues | Gets a mutable dictionary of slots and their bound values. The dictionary maps slots to the values that will be stored in them during test execution.
Public property | Test | Gets the test associated with this test instance state.
Public property | TestArguments | Gets or sets the test method arguments or null if none.
Public property | TestInstanceHandler | Gets the handler for the test instance.
Public property | TestMethod | Gets or sets the test method or null if none.
Public property | TestParameterValues | Gets a mutable dictionary of values assigned to test parameters.
Public property | TestState | Gets the test state associated with this test instance state.
Public property | TestStep | Gets the test step used to execute the test instance.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FromContext | Gets the pattern test instance state from the specified context.
Public method | GetFixtureObjectCreationSpec | Gets a fixture object creation specification using the state's bound SlotValues.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetTestMethodInvocationSpec | Gets a test method invocation specification using the state's bound SlotValues.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InvokeFixtureMethod | Invokes a fixture method using the specified slotValues.
Public method | InvokeTestMethod | Invokes the test method specified by TestMethod, FixtureInstance and TestArguments. If there is no test method or no arguments, does nothing.
Public method | RunBody | Runs the body of the test.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestInstanceState Properties
[image]

Public Properties

 | Name | Description
Public property | BindingItem | Gets the data item obtained from the test's DataBindingContext to create this state.
Public property | Converter | Gets the converter for data binding.
Public property | Data | Gets the user data collection associated with the test instance state. It may be used to associate arbitrary key/value pairs with the execution of the test instance.
Public property | FixtureInstance | Gets or sets the test fixture instance or null if none.
Public property | FixtureType | Gets or sets the test fixture type or null if none.
Public property | Formatter | Gets the formatter for data binding.
Public property | IsReusingPrimaryTestStep | Returns true if the TestStep is the PrimaryTestStep that was created for the test. False if a new PatternTestStep was created as a child of the primary test step just for this test instance.
Public property | SlotValues | Gets a mutable dictionary of slots and their bound values. The dictionary maps slots to the values that will be stored in them during test execution.
Public property | Test | Gets the test associated with this test instance state.
Public property | TestArguments | Gets or sets the test method arguments or null if none.
Public property | TestInstanceHandler | Gets the handler for the test instance.
Public property | TestMethod | Gets or sets the test method or null if none.
Public property | TestParameterValues | Gets a mutable dictionary of values assigned to test parameters.
Public property | TestState | Gets the test state associated with this test instance state.
Public property | TestStep | Gets the test step used to execute the test instance.
Top

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


BindingItem Property

PatternTestInstanceState.BindingItem Property
[image]

Gets the data item obtained from the test's DataBindingContext to create this state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingItem As IDataItem
C#
public IDataItem BindingItem { get; }
C++
public property IDataItem BindingItem sealed {
IDataItem get();
}
J#
/** property */
public IDataItem get_BindingItem();
JScript
public function get BindingItem() : IDataItem

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


Converter Property

PatternTestInstanceState.Converter Property
[image]

Gets the converter for data binding.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Converter As IConverter
C#
public IConverter Converter { get; }
C++
public property IConverter Converter sealed {
IConverter get();
}
J#
/** property */
public IConverter get_Converter();
JScript
public function get Converter() : IConverter

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


Data Property

PatternTestInstanceState.Data Property
[image]

Gets the user data collection associated with the test instance state. It may be used to associate arbitrary key/value pairs with the execution of the test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As UserDataCollection
C#
public UserDataCollection Data { get; }
C++
public property UserDataCollection Data sealed {
UserDataCollection get();
}
J#
/** property */
public UserDataCollection get_Data();
JScript
public function get Data() : UserDataCollection

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


FixtureInstance Property

PatternTestInstanceState.FixtureInstance Property
[image]

Gets or sets the test fixture instance or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property FixtureInstance As Object
C#
public object FixtureInstance { get; set; }
C++
public property object FixtureInstance sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_FixtureInstance();

/** property */
public void set_FixtureInstance(object value);
JScript
public function get FixtureInstance() : Object

public function set FixtureInstance(value : Object);

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


FixtureType Property

PatternTestInstanceState.FixtureType Property
[image]

Gets or sets the test fixture type or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property FixtureType As Type
C#
public Type FixtureType { get; set; }
C++
public property Type FixtureType sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_FixtureType();

/** property */
public void set_FixtureType(Type value);
JScript
public function get FixtureType() : Type

public function set FixtureType(value : Type);

Exceptions

Exception Type | Condition
ArgumentException | Thrown if value contains unbound generic parameters, is a generic parameter, has an element type

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


Formatter Property

PatternTestInstanceState.Formatter Property
[image]

Gets the formatter for data binding.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Formatter As IFormatter
C#
public IFormatter Formatter { get; }
C++
public property IFormatter Formatter sealed {
IFormatter get();
}
J#
/** property */
public IFormatter get_Formatter();
JScript
public function get Formatter() : IFormatter

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


IsReusingPrimaryTestStep Property

PatternTestInstanceState.IsReusingPrimaryTestStep Property
[image]

Returns true if the TestStep is the PrimaryTestStep that was created for the test. False if a new PatternTestStep was created as a child of the primary test step just for this test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusingPrimaryTestStep As Boolean
C#
public bool IsReusingPrimaryTestStep { get; }
C++
public property bool IsReusingPrimaryTestStep sealed {
bool get();
}
J#
/** property */
public bool get_IsReusingPrimaryTestStep();
JScript
public function get IsReusingPrimaryTestStep() : bool

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


SlotValues Property

PatternTestInstanceState.SlotValues Property
[image]

Gets a mutable dictionary of slots and their bound values.

The dictionary maps slots to the values that will be stored in them during test execution.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SlotValues As IDictionary(Of ISlotInfo, Object)
C#
public IDictionary<ISlotInfo, object> SlotValues { get; }
C++
public property IDictionary<ISlotInfo, object> SlotValues sealed {
IDictionary<ISlotInfo, object> get();
}
J#
/** property */
public IDictionary<ISlotInfo, object> get_SlotValues();
JScript
public function get SlotValues() : IDictionary<ISlotInfo, object>

Remarks

The slots should be valid for the type of test in question. For example, a test fixture supports constructor parameters, generic type parameters, fields and properies declared by the test fixture type. Likewise a test method supports method parameters and generic method parameters declared by the test method. Other novel kinds of tests might additional capabilities.

A value should be of a type that is compatible with the slot's ValueType. If any type conversion is required, it should already have taken place prior to adding the value to this dictionary.

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


Test Property

PatternTestInstanceState.Test Property
[image]

Gets the test associated with this test instance state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As PatternTest
C#
public PatternTest Test { get; }
C++
public property PatternTest Test sealed {
PatternTest get();
}
J#
/** property */
public PatternTest get_Test();
JScript
public function get Test() : PatternTest

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


TestArguments Property

PatternTestInstanceState.TestArguments Property
[image]

Gets or sets the test method arguments or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestArguments As Object()
C#
public object[] TestArguments { get; set; }
C++
public property object[] TestArguments sealed {
array<Object>^ get();
void set(array<Object>^ value);
}
J#
/** property */
public object[] get_TestArguments();

/** property */
public void set_TestArguments(object[] value);
JScript
public function get TestArguments() : Object[]

public function set TestArguments(value : Object[]);

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


TestInstanceHandler Property

PatternTestInstanceState.TestInstanceHandler Property
[image]

Gets the handler for the test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestInstanceHandler As IPatternTestInstanceHandler
C#
public IPatternTestInstanceHandler TestInstanceHandler { get; }
C++
public property IPatternTestInstanceHandler TestInstanceHandler sealed {
IPatternTestInstanceHandler get();
}
J#
/** property */
public IPatternTestInstanceHandler get_TestInstanceHandler();
JScript
public function get TestInstanceHandler() : IPatternTestInstanceHandler

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


TestMethod Property

PatternTestInstanceState.TestMethod Property
[image]

Gets or sets the test method or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestMethod As MethodInfo
C#
public MethodInfo TestMethod { get; set; }
C++
public property MethodInfo TestMethod sealed {
MethodInfo get();
void set(MethodInfo value);
}
J#
/** property */
public MethodInfo get_TestMethod();

/** property */
public void set_TestMethod(MethodInfo value);
JScript
public function get TestMethod() : MethodInfo

public function set TestMethod(value : MethodInfo);

Exceptions

Exception Type | Condition
ArgumentException | Thrown if value is contains unbound generic parameters

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


TestParameterValues Property

PatternTestInstanceState.TestParameterValues Property
[image]

Gets a mutable dictionary of values assigned to test parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestParameterValues As IDictionary(Of PatternTestParameter, Object)
C#
public IDictionary<PatternTestParameter, object> TestParameterValues { get; }
C++
public property IDictionary<PatternTestParameter, object> TestParameterValues sealed {
IDictionary<PatternTestParameter, object> get();
}
J#
/** property */
public IDictionary<PatternTestParameter, object> get_TestParameterValues();
JScript
public function get TestParameterValues() : IDictionary<PatternTestParameter, object>

Remarks

The contents of the dictionary are initialized by the framework as part of the test parameter binding phase for the test instance, just before the "before test instance" actions run.

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


TestState Property

PatternTestInstanceState.TestState Property
[image]

Gets the test state associated with this test instance state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestState As PatternTestState
C#
public PatternTestState TestState { get; }
C++
public property PatternTestState TestState sealed {
PatternTestState get();
}
J#
/** property */
public PatternTestState get_TestState();
JScript
public function get TestState() : PatternTestState

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


TestStep Property

PatternTestInstanceState.TestStep Property
[image]

Gets the test step used to execute the test instance.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestStep As PatternTestStep
C#
public PatternTestStep TestStep { get; }
C++
public property PatternTestStep TestStep sealed {
PatternTestStep get();
}
J#
/** property */
public PatternTestStep get_TestStep();
JScript
public function get TestStep() : PatternTestStep

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestInstanceState Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FromContext | Gets the pattern test instance state from the specified context.
Public method | GetFixtureObjectCreationSpec | Gets a fixture object creation specification using the state's bound SlotValues.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetTestMethodInvocationSpec | Gets a test method invocation specification using the state's bound SlotValues.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InvokeFixtureMethod | Invokes a fixture method using the specified slotValues.
Public method | InvokeTestMethod | Invokes the test method specified by TestMethod, FixtureInstance and TestArguments. If there is no test method or no arguments, does nothing.
Public method | RunBody | Runs the body of the test.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


FromContext Method

PatternTestInstanceState.FromContext Method
[image]

Gets the pattern test instance state from the specified context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromContext( _
ByVal context As TestContext _
) As PatternTestInstanceState
C#
public static PatternTestInstanceState FromContext(
TestContext context
)
C++
public:
static PatternTestInstanceState FromContext(
TestContext context
)
J#
public static PatternTestInstanceState FromContext(
TestContext context
)
JScript
public static function FromContext(
context : TestContext
) : PatternTestInstanceState

Parameters

context
The context

Return Value

The pattern test instance state, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if context is null

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


GetFixtureObjectCreationSpec Method

PatternTestInstanceState.GetFixtureObjectCreationSpec Method
[image]

Gets a fixture object creation specification using the state's bound SlotValues.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFixtureObjectCreationSpec( _
ByVal type As ITypeInfo _
) As ObjectCreationSpec
C#
public ObjectCreationSpec GetFixtureObjectCreationSpec(
ITypeInfo type
)
C++
public:
ObjectCreationSpec GetFixtureObjectCreationSpec(
ITypeInfo type
) sealed
J#
public ObjectCreationSpec GetFixtureObjectCreationSpec(
ITypeInfo type
)
JScript
public function GetFixtureObjectCreationSpec(
type : ITypeInfo
) : ObjectCreationSpec

Parameters

type
The fixture type or generic type definition

Return Value

The fixture instance

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null
ArgumentException | Thrown if the slots or values in SlotValues are not appropriate for instantiating type

Remarks

The values of FixtureType and FixtureInstance are not used.

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace
ObjectCreationSpec


GetTestMethodInvocationSpec Method

PatternTestInstanceState.GetTestMethodInvocationSpec Method
[image]

Gets a test method invocation specification using the state's bound SlotValues.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTestMethodInvocationSpec( _
ByVal method As IMethodInfo _
) As MethodInvocationSpec
C#
public MethodInvocationSpec GetTestMethodInvocationSpec(
IMethodInfo method
)
C++
public:
MethodInvocationSpec GetTestMethodInvocationSpec(
IMethodInfo method
) sealed
J#
public MethodInvocationSpec GetTestMethodInvocationSpec(
IMethodInfo method
)
JScript
public function GetTestMethodInvocationSpec(
method : IMethodInfo
) : MethodInvocationSpec

Parameters

method
The test method or generic method definition, possibly declared by a generic type or generic type defintion

Return Value

The method return value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if method is null
ArgumentException | Thrown if the slots or values in SlotValues or FixtureType are not appropriate for invoking method
InvalidOperationException | Thrown if FixtureType is null

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace
MethodInvocationSpec


InvokeFixtureMethod Method

PatternTestInstanceState.InvokeFixtureMethod Method
[image]

Invokes a fixture method using the specified slotValues.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Function InvokeFixtureMethod( _
ByVal method As IMethodInfo, _
ByVal slotValues As IEnumerable(Of KeyValuePair(Of ISlotInfo, Object)) _
) As Object
C#
[TestEntryPointAttribute]
public object InvokeFixtureMethod(
IMethodInfo method,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues
)
C++
[TestEntryPointAttribute]
public:
Object InvokeFixtureMethod(
IMethodInfo method,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public object InvokeFixtureMethod(
IMethodInfo method,
IEnumerable<KeyValuePair<ISlotInfo, object>> slotValues
)
JScript
public

TestEntryPointAttribute
function InvokeFixtureMethod(
method : IMethodInfo,
slotValues : IEnumerable<KeyValuePair<ISlotInfo, object>>
) : Object

Parameters

method
The fixture method or generic method definition, possibly declared by a generic type or generic type defintion
slotValues
The slot values to use for invoking the method

Return Value

The method return value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if method or slotValues is null
ArgumentException | Thrown if the slots or values in SlotValues or FixtureType or FixtureInstance are not appropriate for invoking method
InvalidOperationException | Thrown if FixtureType is null
Exception | Any exception thrown by the invoked method

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace
MethodInvocationSpec


InvokeTestMethod Method

PatternTestInstanceState.InvokeTestMethod Method
[image]

Invokes the test method specified by TestMethod, FixtureInstance and TestArguments. If there is no test method or no arguments, does nothing.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Function InvokeTestMethod() As Object
C#
[TestEntryPointAttribute]
public object InvokeTestMethod()
C++
[TestEntryPointAttribute]
public:
Object InvokeTestMethod() sealed
J#
/** @attribute TestEntryPointAttribute() */
public object InvokeTestMethod()
JScript
public

TestEntryPointAttribute
function InvokeTestMethod() : Object

Return Value

The method return value, or null if there was none

Exceptions

Exception Type | Condition
Exception | Any exception thrown by the invoked method

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


RunBody Method

PatternTestInstanceState.RunBody Method
[image]

Runs the body of the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Function RunBody() As TestOutcome
C#
[TestEntryPointAttribute]
public TestOutcome RunBody()
C++
[TestEntryPointAttribute]
public:
TestOutcome RunBody() sealed
J#
/** @attribute TestEntryPointAttribute() */
public TestOutcome RunBody()
JScript
public

TestEntryPointAttribute
function RunBody() : TestOutcome

Return Value

The test outcome

See Also

PatternTestInstanceState Class
Gallio.Framework.Pattern Namespace


PatternTestParameter Class

PatternTestParameter Class
See Also Example Members
[image]

Represents an parameter of a PatternTest derived from a field, property or method parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestParameter
Inherits BaseTestParameter
Implements IPatternTestComponent
C#
public class PatternTestParameter : BaseTestParameter, IPatternTestComponent
C++
ref class PatternTestParameter : BaseTestParameter, IPatternTestComponent
J#
public class PatternTestParameter extends BaseTestParameter implements IPatternTestComponent
JScript
public class PatternTestParameter extends BaseTestParameter, IPatternTestComponent

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTestParameter
Gallio.Framework.Pattern.PatternTestParameter

See Also

PatternTestParameter Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestParameter Members

PatternTestParameter Members
See Also Example Constructors Properties Methods
[image]

Represents an parameter of a PatternTest derived from a field, property or method parameter.

The following tables list the members exposed by PatternTestParameter.

Public Constructors

 | Name | Description
Public method | PatternTestParameter | Creates a test pattern parameter.
Top

Public Properties

 | Name | Description
Public property | Binder | Gets or sets the IDataBinder for this test parameter.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | DataContext | Gets the data context of the component.
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestParameter)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Owner | Gets the test that owns this parameter.
Public property | TestParameterActions | Gets the set of actions that describe the behavior of the test parameter.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetName | Sets the name of the component.
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTestComponent)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestParameter Constructor

PatternTestParameter Constructor
[image]

Creates a test pattern parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal dataContext As PatternTestDataContext _
)
C#
public PatternTestParameter(
string name,
ICodeElementInfo codeElement,
PatternTestDataContext dataContext
)
C++
public:
PatternTestParameter(
String name,
ICodeElementInfo codeElement,
PatternTestDataContext dataContext
) sealed
J#
public PatternTestParameter(
string name,
ICodeElementInfo codeElement,
PatternTestDataContext dataContext
)
JScript
public function PatternTestParameter(
name : String,
codeElement : ICodeElementInfo,
dataContext : PatternTestDataContext
)

Parameters

name
The name of the test parameter
codeElement
The code element (usually a slot) represented by the parameter, or null if none
dataContext
The data context of the test parameter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name, codeElement or dataContext is null

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestParameter Properties
[image]

Public Properties

 | Name | Description
Public property | Binder | Gets or sets the IDataBinder for this test parameter.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | DataContext | Gets the data context of the component.
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestParameter)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Owner | Gets the test that owns this parameter.
Public property | TestParameterActions | Gets the set of actions that describe the behavior of the test parameter.
Top

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


Binder Property

PatternTestParameter.Binder Property
[image]

Gets or sets the IDataBinder for this test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Binder As IDataBinder
C#
public IDataBinder Binder { get; set; }
C++
public property IDataBinder Binder sealed {
IDataBinder get();
void set(IDataBinder value);
}
J#
/** property */
public IDataBinder get_Binder();

/** property */
public void set_Binder(IDataBinder value);
JScript
public function get Binder() : IDataBinder

public function set Binder(value : IDataBinder);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

Remarks

The default value is a ScalarDataBinder bound to the anonymous data source using a DataBinding whose path is the name of this parameter and whose index is the implicit index computed by the pararameter's data context.

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace


DataContext Property

PatternTestParameter.DataContext Property
[image]

Gets the data context of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataContext As PatternTestDataContext _
Implements IPatternTestComponent.DataContext
C#
public PatternTestDataContext DataContext { get; }
C++
public property PatternTestDataContext DataContext sealed {
PatternTestDataContext get();
}
J#
/** property */
public PatternTestDataContext get_DataContext();
JScript
public function get DataContext() : PatternTestDataContext

Implements

IPatternTestComponent.DataContext

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace


Owner Property

PatternTestParameter.Owner Property
[image]

Gets the test that owns this parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Owner As PatternTest
C#
public new PatternTest Owner { get; }
C++
public new property PatternTest Owner sealed {
PatternTest get();
}
J#
/** property */
public PatternTest get_Owner();
JScript
public function get Owner() : PatternTest

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace


TestParameterActions Property

PatternTestParameter.TestParameterActions Property
[image]

Gets the set of actions that describe the behavior of the test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestParameterActions As PatternTestParameterActions
C#
public PatternTestParameterActions TestParameterActions { get; }
C++
public property PatternTestParameterActions TestParameterActions sealed {
PatternTestParameterActions get();
}
J#
/** property */
public PatternTestParameterActions get_TestParameterActions();
JScript
public function get TestParameterActions() : PatternTestParameterActions

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestParameter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetName | Sets the name of the component.
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTestComponent)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


SetName Method

PatternTestParameter.SetName Method
[image]

Sets the name of the component.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetName( _
ByVal value As String _
) _
Implements IPatternTestComponent.SetName
C#
public void SetName(
string value
)
C++
public:
void SetName(
String value
) sealed
J#
public void SetName(
string value
)
JScript
public function SetName(
value : String
)

Implements

IPatternTestComponent.SetName

See Also

PatternTestParameter Class
Gallio.Framework.Pattern Namespace


PatternTestParameterActions Class

PatternTestParameterActions Class
See Also Example Members
[image]

An implementation of IPatternTestParameterHandler based on actions that can be sequenced and composed as chains.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestParameterActions
Implements IPatternTestParameterHandler
C#
public class PatternTestParameterActions : IPatternTestParameterHandler
C++
ref class PatternTestParameterActions : IPatternTestParameterHandler
J#
public class PatternTestParameterActions implements IPatternTestParameterHandler
JScript
public class PatternTestParameterActions extends IPatternTestParameterHandler

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternTestParameterActions

See Also

PatternTestParameterActions Members
Gallio.Framework.Pattern Namespace
IPatternTestParameterHandler


PatternTestParameterActions Members

PatternTestParameterActions Members
See Also Example Constructors Properties Methods
[image]

An implementation of IPatternTestParameterHandler based on actions that can be sequenced and composed as chains.

The following tables list the members exposed by PatternTestParameterActions.

Public Constructors

 | Name | Description
Public method | PatternTestParameterActions | Creates a test parameter actions object initially configured with empty action chains that do nothing.
Top

Public Properties

 | Name | Description
Public property | BindTestParameterChain | Gets the chain of BindTestParameter actions.
Public property | UnbindTestParameterChain | Gets the chain of UnbindTestParameter actions.
Top

Public Methods

Name | Description
Public method BindTestParameter

Binds a value to a test parameter.

The following actions are typically performed during this phase:

  • Associated a value with a slot on the test fixture or test method.
  • Storing the object for later use during the test run.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method UnbindTestParameter

Unbinds a test parameter.

The following actions are typically performed during this phase:

  • Releasing any resources used by the test parameter.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace
IPatternTestParameterHandler


PatternTestParameterActions Constructor

PatternTestParameterActions Constructor
[image]

Creates a test parameter actions object initially configured with empty action chains that do nothing.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PatternTestParameterActions()
C++
public:
PatternTestParameterActions() sealed
J#
public PatternTestParameterActions()
JScript
public function PatternTestParameterActions()

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestParameterActions Properties
[image]

Public Properties

 | Name | Description
Public property | BindTestParameterChain | Gets the chain of BindTestParameter actions.
Public property | UnbindTestParameterChain | Gets the chain of UnbindTestParameter actions.
Top

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace
IPatternTestParameterHandler


BindTestParameterChain Property

PatternTestParameterActions.BindTestParameterChain Property
[image]

Gets the chain of BindTestParameter actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindTestParameterChain As ActionChain(Of PatternTestInstanceState, Object)
C#
public ActionChain<PatternTestInstanceState, object> BindTestParameterChain { get; }
C++
public property ActionChain<PatternTestInstanceState, object> BindTestParameterChain sealed {
ActionChain<PatternTestInstanceState, object> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState, object> get_BindTestParameterChain();
JScript
public function get BindTestParameterChain() : ActionChain<PatternTestInstanceState, object>

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace
BindTestParameter


UnbindTestParameterChain Property

PatternTestParameterActions.UnbindTestParameterChain Property
See Also Example
[image]

Gets the chain of UnbindTestParameter actions.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UnbindTestParameterChain As ActionChain(Of PatternTestInstanceState, Object)
C#
public ActionChain<PatternTestInstanceState, object> UnbindTestParameterChain { get; }
C++
public property ActionChain<PatternTestInstanceState, object> UnbindTestParameterChain sealed {
ActionChain<PatternTestInstanceState, object> get();
}
J#
/** property */
public ActionChain<PatternTestInstanceState, object> get_UnbindTestParameterChain();
JScript
public function get UnbindTestParameterChain() : ActionChain<PatternTestInstanceState, object>

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace
UnbindTestParameter


Methods

PatternTestParameterActions Methods
[image]

Public Methods

Name | Description
Public method BindTestParameter

Binds a value to a test parameter.

The following actions are typically performed during this phase:

  • Associated a value with a slot on the test fixture or test method.
  • Storing the object for later use during the test run.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method UnbindTestParameter

Unbinds a test parameter.

The following actions are typically performed during this phase:

  • Releasing any resources used by the test parameter.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace
IPatternTestParameterHandler


BindTestParameter Method

PatternTestParameterActions.BindTestParameter Method
[image]

Binds a value to a test parameter.

The following actions are typically performed during this phase:

  • Associated a value with a slot on the test fixture or test method.
  • Storing the object for later use during the test run.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub BindTestParameter( _
ByVal testInstanceState As PatternTestInstanceState, _
ByVal value As Object _
) _
Implements IPatternTestParameterHandler.BindTestParameter
C#
[TestEntryPointAttribute]
public void BindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
C++
[TestEntryPointAttribute]
public:
void BindTestParameter(
PatternTestInstanceState testInstanceState,
Object value
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void BindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
JScript
public

TestEntryPointAttribute
function BindTestParameter(
testInstanceState : PatternTestInstanceState,
value : Object
)

Parameters

testInstanceState
The test instance state, never null
value
The value to bind to the parameter

Implements

IPatternTestParameterHandler.BindTestParameter

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace


UnbindTestParameter Method

PatternTestParameterActions.UnbindTestParameter Method
[image]

Unbinds a test parameter.

The following actions are typically performed during this phase:

  • Releasing any resources used by the test parameter.

The following actions are forbidden during this phase because they would either go unnoticed or have undesirable side-effects upon test execution:

  • Modifying the PatternTest object in any way.
  • Modifying the PatternTestState object in any way.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Public Sub UnbindTestParameter( _
ByVal testInstanceState As PatternTestInstanceState, _
ByVal value As Object _
) _
Implements IPatternTestParameterHandler.UnbindTestParameter
C#
[TestEntryPointAttribute]
public void UnbindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
C++
[TestEntryPointAttribute]
public:
void UnbindTestParameter(
PatternTestInstanceState testInstanceState,
Object value
) sealed
J#
/** @attribute TestEntryPointAttribute() */
public void UnbindTestParameter(
PatternTestInstanceState testInstanceState,
object value
)
JScript
public

TestEntryPointAttribute
function UnbindTestParameter(
testInstanceState : PatternTestInstanceState,
value : Object
)

Parameters

testInstanceState
The test instance state, never null
value
The value that was bound to the test parameter

Implements

IPatternTestParameterHandler.UnbindTestParameter

See Also

PatternTestParameterActions Class
Gallio.Framework.Pattern Namespace


PatternTestPopulator Delegate

PatternTestPopulator Delegate
[image]

A delegate used to lazily populate the children of an PatternTest.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub PatternTestPopulator( _
ByVal recurse As Boolean _
)
C#
public delegate void PatternTestPopulator(
bool recurse
)
C++
public delegate void PatternTestPopulator(
bool recurse
)
J#
/** delegate */
public delegate void PatternTestPopulator(
bool recurse
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

recurse
If true, the populator should recursively populate all of its newly populated test elements in addition to itself

See Also

Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestState Class

PatternTestState Class
See Also Example Members
[image]

Represents the run-time state of a PatternTest that is to be executed.

Typical lifecycle of PatternTestState:

  • The PatternTestController creates a PatternTestState for the PatternTest to be executed.
  • The controller populates the test state with slot binding accessors for each PatternTestParameter associated with the test.
  • The controller calls BeforeTest to give test extensions the opportunity to modify the test state.
  • The controller begins iterating over the IDataItems produced by the state's BindingContext. For each item it constructs a PatternTestInstanceState and executes the test instance.
  • The controller calls AfterTest to give test extensions the opportunity to clean up the test state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestState
C#
public class PatternTestState
C++
ref class PatternTestState
J#
public class PatternTestState
JScript
public class PatternTestState

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.PatternTestState

See Also

PatternTestState Members
Gallio.Framework.Pattern Namespace


PatternTestState Members

PatternTestState Members
See Also Example Properties Methods
[image]

Represents the run-time state of a PatternTest that is to be executed.

Typical lifecycle of PatternTestState:

  • The PatternTestController creates a PatternTestState for the PatternTest to be executed.
  • The controller populates the test state with slot binding accessors for each PatternTestParameter associated with the test.
  • The controller calls BeforeTest to give test extensions the opportunity to modify the test state.
  • The controller begins iterating over the IDataItems produced by the state's BindingContext. For each item it constructs a PatternTestInstanceState and executes the test instance.
  • The controller calls AfterTest to give test extensions the opportunity to clean up the test state.

The following tables list the members exposed by PatternTestState.

Public Properties

 | Name | Description
Public property | BindingContext | Gets the data binding context of the test. The context is used to produce data items for test instances.
Public property | Converter | Gets the converter for data binding.
Public property | Data | Gets the user data collection associated with the test state. It may be used to associate arbitrary key/value pairs with the execution of the test.
Public property | Formatter | Gets the formatter for data binding.
Public property | IsExplicit | Returns true if the test was selected explicitly.
Public property | PrimaryTestStep | Gets the primary test step associated with this test state. If the test has data bindings, the test instance for each data item will be executed as children of the primary test step. Otherwise, the primary test step will be used for the entire test run.
Public property | Test | Gets the test associated with this test state.
Public property | TestHandler | Gets the handler for the test.
Public property | TestParameterDataAccessors | Gets a mutable dictionary of data accessors that will provide values assigned to test parameters given a data binding item.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FromContext | Gets the pattern test state from the specified context.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


Properties

PatternTestState Properties
[image]

Public Properties

 | Name | Description
Public property | BindingContext | Gets the data binding context of the test. The context is used to produce data items for test instances.
Public property | Converter | Gets the converter for data binding.
Public property | Data | Gets the user data collection associated with the test state. It may be used to associate arbitrary key/value pairs with the execution of the test.
Public property | Formatter | Gets the formatter for data binding.
Public property | IsExplicit | Returns true if the test was selected explicitly.
Public property | PrimaryTestStep | Gets the primary test step associated with this test state. If the test has data bindings, the test instance for each data item will be executed as children of the primary test step. Otherwise, the primary test step will be used for the entire test run.
Public property | Test | Gets the test associated with this test state.
Public property | TestHandler | Gets the handler for the test.
Public property | TestParameterDataAccessors | Gets a mutable dictionary of data accessors that will provide values assigned to test parameters given a data binding item.
Top

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


BindingContext Property

PatternTestState.BindingContext Property
[image]

Gets the data binding context of the test. The context is used to produce data items for test instances.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingContext As DataBindingContext
C#
public DataBindingContext BindingContext { get; }
C++
public property DataBindingContext BindingContext sealed {
DataBindingContext get();
}
J#
/** property */
public DataBindingContext get_BindingContext();
JScript
public function get BindingContext() : DataBindingContext

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


Converter Property

PatternTestState.Converter Property
[image]

Gets the converter for data binding.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Converter As IConverter
C#
public IConverter Converter { get; }
C++
public property IConverter Converter sealed {
IConverter get();
}
J#
/** property */
public IConverter get_Converter();
JScript
public function get Converter() : IConverter

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


Data Property

PatternTestState.Data Property
[image]

Gets the user data collection associated with the test state. It may be used to associate arbitrary key/value pairs with the execution of the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As UserDataCollection
C#
public UserDataCollection Data { get; }
C++
public property UserDataCollection Data sealed {
UserDataCollection get();
}
J#
/** property */
public UserDataCollection get_Data();
JScript
public function get Data() : UserDataCollection

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


Formatter Property

PatternTestState.Formatter Property
[image]

Gets the formatter for data binding.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Formatter As IFormatter
C#
public IFormatter Formatter { get; }
C++
public property IFormatter Formatter sealed {
IFormatter get();
}
J#
/** property */
public IFormatter get_Formatter();
JScript
public function get Formatter() : IFormatter

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


IsExplicit Property

PatternTestState.IsExplicit Property
[image]

Returns true if the test was selected explicitly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsExplicit As Boolean
C#
public bool IsExplicit { get; }
C++
public property bool IsExplicit sealed {
bool get();
}
J#
/** property */
public bool get_IsExplicit();
JScript
public function get IsExplicit() : bool

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


PrimaryTestStep Property

PatternTestState.PrimaryTestStep Property
[image]

Gets the primary test step associated with this test state.

If the test has data bindings, the test instance for each data item will be executed as children of the primary test step. Otherwise, the primary test step will be used for the entire test run.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrimaryTestStep As PatternTestStep
C#
public PatternTestStep PrimaryTestStep { get; }
C++
public property PatternTestStep PrimaryTestStep sealed {
PatternTestStep get();
}
J#
/** property */
public PatternTestStep get_PrimaryTestStep();
JScript
public function get PrimaryTestStep() : PatternTestStep

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


Test Property

PatternTestState.Test Property
[image]

Gets the test associated with this test state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As PatternTest
C#
public PatternTest Test { get; }
C++
public property PatternTest Test sealed {
PatternTest get();
}
J#
/** property */
public PatternTest get_Test();
JScript
public function get Test() : PatternTest

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


TestHandler Property

PatternTestState.TestHandler Property
[image]

Gets the handler for the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestHandler As IPatternTestHandler
C#
public IPatternTestHandler TestHandler { get; }
C++
public property IPatternTestHandler TestHandler sealed {
IPatternTestHandler get();
}
J#
/** property */
public IPatternTestHandler get_TestHandler();
JScript
public function get TestHandler() : IPatternTestHandler

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


TestParameterDataAccessors Property

PatternTestState.TestParameterDataAccessors Property
[image]

Gets a mutable dictionary of data accessors that will provide values assigned to test parameters given a data binding item.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestParameterDataAccessors As IDictionary(Of PatternTestParameter, IDataAccessor)
C#
public IDictionary<PatternTestParameter, IDataAccessor> TestParameterDataAccessors { get; }
C++
public property IDictionary<PatternTestParameter, IDataAccessor> TestParameterDataAccessors sealed {
IDictionary<PatternTestParameter, IDataAccessor> get();
}
J#
/** property */
public IDictionary<PatternTestParameter, IDataAccessor> get_TestParameterDataAccessors();
JScript
public function get TestParameterDataAccessors() : IDictionary<PatternTestParameter, IDataAccessor>

Remarks

The contents of the dictionary are initialized by the framework as part of the test parameter binding phase for the test instance, just before the "before test" actions run.

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


Methods

PatternTestState Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FromContext | Gets the pattern test state from the specified context.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


FromContext Method

PatternTestState.FromContext Method
[image]

Gets the pattern test state from the specified context.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromContext( _
ByVal context As TestContext _
) As PatternTestState
C#
public static PatternTestState FromContext(
TestContext context
)
C++
public:
static PatternTestState FromContext(
TestContext context
)
J#
public static PatternTestState FromContext(
TestContext context
)
JScript
public static function FromContext(
context : TestContext
) : PatternTestState

Parameters

context
The context

Return Value

The pattern test state, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if context is null

See Also

PatternTestState Class
Gallio.Framework.Pattern Namespace


PatternTestStep Class

PatternTestStep Class
See Also Example Members
[image]

A step that belongs to a PatternTest.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class PatternTestStep
Inherits BaseTestStep
C#
public class PatternTestStep : BaseTestStep
C++
ref class PatternTestStep : BaseTestStep
J#
public class PatternTestStep extends BaseTestStep
JScript
public class PatternTestStep extends BaseTestStep

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTestStep
Gallio.Framework.Pattern.PatternTestStep

See Also

PatternTestStep Members
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestStep Members

PatternTestStep Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A step that belongs to a PatternTest.

The following tables list the members exposed by PatternTestStep.

Public Constructors

Name | Description
PatternTestStep | Overloaded.
Top

Public Properties

Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest

(inherited from BaseTestStep)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestStep)
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

(inherited from BaseTestStep)
Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

(inherited from BaseTestStep)
Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy. (inherited from BaseTestStep)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Parent | Gets the step that contains this one, or null if this instance represents the root step of the test step tree. (inherited from BaseTestStep)
Public property | Test | Gets the associated test.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTestStep)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
PatternTestStep | Overloaded.
Top

See Also

PatternTestStep Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


PatternTestStep Constructor

PatternTestStep Constructor

Overload List

 | Name | Description
Public method | PatternTestStep (PatternTest, ITestStep) | Creates a primary step using the same name, code element and metadata as the test to which it belongs.
Public method | PatternTestStep (PatternTest, ITestStep, String, ICodeElementInfo, Boolean) | Creates a step.

See Also

PatternTestStep Class
Gallio.Framework.Pattern Namespace


PatternTestStep Constructor (PatternTest, ITestStep)

PatternTestStep Constructor (PatternTest, ITestStep)
See Also Example
[image]

Creates a primary step using the same name, code element and metadata as the test to which it belongs.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal test As PatternTest, _
ByVal parent As ITestStep _
)
C#
public PatternTestStep(
PatternTest test,
ITestStep parent
)
C++
public:
PatternTestStep(
PatternTest test,
ITestStep parent
) sealed
J#
public PatternTestStep(
PatternTest test,
ITestStep parent
)
JScript
public function PatternTestStep(
test : PatternTest,
parent : ITestStep
)

Parameters

test
The test to which the step belongs
parent
The parent test step, or null if creating the root step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if test is null

See Also

PatternTestStep Class
Gallio.Framework.Pattern Namespace
PatternTestStep Constructor Overload List


PatternTestStep Constructor (PatternTest, ITestStep, String, ICodeElementInfo, Boolean)

PatternTestStep Constructor (PatternTest, ITestStep, String, ICodeElementInfo, Boolean)
See Also Example
[image]

Creates a step.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal test As PatternTest, _
ByVal parent As ITestStep, _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal isPrimary As Boolean _
)
C#
public PatternTestStep(
PatternTest test,
ITestStep parent,
string name,
ICodeElementInfo codeElement,
bool isPrimary
)
C++
public:
PatternTestStep(
PatternTest test,
ITestStep parent,
String name,
ICodeElementInfo codeElement,
bool isPrimary
) sealed
J#
public PatternTestStep(
PatternTest test,
ITestStep parent,
string name,
ICodeElementInfo codeElement,
bool isPrimary
)
JScript
public function PatternTestStep(
test : PatternTest,
parent : ITestStep,
name : String,
codeElement : ICodeElementInfo,
isPrimary : bool
)

Parameters

test
The test to which the step belongs
parent
The parent step, or null if creating a root step
name
The step name
codeElement
The point of definition of the step, or null if unknown
isPrimary
True if the test step is primary

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or test is null

Remarks

If isPrimary is true, then all metadata from the test is copied to the step. Otherwise the new step will have no metadata initially.

See Also

PatternTestStep Class
Gallio.Framework.Pattern Namespace
PatternTestStep Constructor Overload List


Properties

PatternTestStep Properties
[image]

Public Properties

Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest

(inherited from BaseTestStep)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTestStep)
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

(inherited from BaseTestStep)
Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

(inherited from BaseTestStep)
Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy. (inherited from BaseTestStep)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Parent | Gets the step that contains this one, or null if this instance represents the root step of the test step tree. (inherited from BaseTestStep)
Public property | Test | Gets the associated test.
Top

See Also

PatternTestStep Class
Gallio.Framework.Pattern Namespace
PatternTestFramework


Test Property

PatternTestStep.Test Property
[image]

Gets the associated test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Test As PatternTest
C#
public new PatternTest Test { get; }
C++
public new property PatternTest Test sealed {
PatternTest get();
}
J#
/** property */
public PatternTest get_Test();
JScript
public function get Test() : PatternTest

See Also

PatternTestStep Class
Gallio.Framework.Pattern Namespace


PatternUsageErrorException Class

PatternUsageErrorException Class
See Also Example Members
[image]

The type of exception thrown when a test declaration is malformed or contains an error. Implementations of IPattern may use this exception to report that a pattern is malformed or not valid in the context in which it appears.

The exception effectively halts the processing of the pattern. The message text is then manifested as an error annotation that may be displayed to the user.

When you see this error, check to make sure that the syntax of the test is correct, all required parameters have been provided and they contain valid values.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class PatternUsageErrorException
Inherits Exception
C#
[SerializableAttribute]
public class PatternUsageErrorException : Exception
C++
[SerializableAttribute]
ref class PatternUsageErrorException : Exception
J#
/** @attribute SerializableAttribute() */
public class PatternUsageErrorException extends Exception
JScript
public
SerializableAttribute
class PatternUsageErrorException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Framework.Pattern.PatternUsageErrorException

See Also

PatternUsageErrorException Members
Gallio.Framework.Pattern Namespace


PatternUsageErrorException Members

PatternUsageErrorException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when a test declaration is malformed or contains an error. Implementations of IPattern may use this exception to report that a pattern is malformed or not valid in the context in which it appears.

The exception effectively halts the processing of the pattern. The message text is then manifested as an error annotation that may be displayed to the user.

When you see this error, check to make sure that the syntax of the test is correct, all required parameters have been provided and they contain valid values.

The following tables list the members exposed by PatternUsageErrorException.

Public Constructors

Name | Description
PatternUsageErrorException | Overloaded.
Top

Protected Constructors

Name | Description
PatternUsageErrorException | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
PatternUsageErrorException | Overloaded.
Top

See Also

PatternUsageErrorException Class
Gallio.Framework.Pattern Namespace


PatternUsageErrorException Constructor

PatternUsageErrorException Constructor

Overload List

 | Name | Description
Family method | PatternUsageErrorException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | PatternUsageErrorException (String) | Creates a usage error exception.
Public method | PatternUsageErrorException (String, Exception) | Creates a usage error exception.

See Also

PatternUsageErrorException Class
Gallio.Framework.Pattern Namespace


PatternUsageErrorException Constructor (SerializationInfo, StreamingContext)

PatternUsageErrorException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected PatternUsageErrorException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
PatternUsageErrorException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected PatternUsageErrorException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function PatternUsageErrorException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

PatternUsageErrorException Class
Gallio.Framework.Pattern Namespace
PatternUsageErrorException Constructor Overload List


PatternUsageErrorException Constructor (String)

PatternUsageErrorException Constructor (String)
See Also Example
[image]

Creates a usage error exception.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public PatternUsageErrorException(
string message
)
C++
public:
PatternUsageErrorException(
String message
) sealed
J#
public PatternUsageErrorException(
string message
)
JScript
public function PatternUsageErrorException(
message : String
)

Parameters

message
A message that describes how the pattern was misused and possibly what should be done to correct it.

See Also

PatternUsageErrorException Class
Gallio.Framework.Pattern Namespace
PatternUsageErrorException Constructor Overload List


PatternUsageErrorException Constructor (String, Exception)

PatternUsageErrorException Constructor (String, Exception)
See Also Example
[image]

Creates a usage error exception.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public PatternUsageErrorException(
string message,
Exception innerException
)
C++
public:
PatternUsageErrorException(
String message,
Exception innerException
) sealed
J#
public PatternUsageErrorException(
string message,
Exception innerException
)
JScript
public function PatternUsageErrorException(
message : String,
innerException : Exception
)

Parameters

message
A message that describes how the pattern was misused and possibly what should be done to correct it.
innerException
An optional exception that will be used to provide aditional details about the usage error

See Also

PatternUsageErrorException Class
Gallio.Framework.Pattern Namespace
PatternUsageErrorException Constructor Overload List


ProcessIsolation Class

ProcessIsolation Class
See Also Example Members
[image]

The process isolation object saves global process-level context information when it is created and restores it when it is disposed.

The following context information is saved and restored:

  • The current working directory

This class cannot be inherited.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ProcessIsolation
Implements IDisposable
C#
public sealed class ProcessIsolation : IDisposable
C++
ref class ProcessIsolation sealed : IDisposable
J#
public final class ProcessIsolation implements IDisposable
JScript
public final class ProcessIsolation extends IDisposable

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.ProcessIsolation

See Also

ProcessIsolation Members
Gallio.Framework.Pattern Namespace


ProcessIsolation Members

ProcessIsolation Members
See Also Example Constructors Methods
[image]

The process isolation object saves global process-level context information when it is created and restores it when it is disposed.

The following context information is saved and restored:

  • The current working directory

This class cannot be inherited.

The following tables list the members exposed by ProcessIsolation.

Public Constructors

 | Name | Description
Public method | ProcessIsolation | Saves global process state to be subsequently restored when disposed.
Top

Public Methods

 | Name | Description
Public method | Dispose | Restores the saved process state.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ProcessIsolation Class
Gallio.Framework.Pattern Namespace


ProcessIsolation Constructor

ProcessIsolation Constructor
[image]

Saves global process state to be subsequently restored when disposed.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ProcessIsolation()
C++
public:
ProcessIsolation() sealed
J#
public ProcessIsolation()
JScript
public function ProcessIsolation()

See Also

ProcessIsolation Class
Gallio.Framework.Pattern Namespace


Methods

ProcessIsolation Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Restores the saved process state.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ProcessIsolation Class
Gallio.Framework.Pattern Namespace


Dispose Method

ProcessIsolation.Dispose Method
[image]

Restores the saved process state.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

ProcessIsolation Class
Gallio.Framework.Pattern Namespace


TestAction Delegate

TestAction Delegate
[image]

Performs one primitive action of a test and returns its outcome.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function TestAction() As TestOutcome
C#
public delegate TestOutcome TestAction()
C++
public delegate TestOutcome TestAction()
J#
/** delegate */
public delegate TestOutcome TestAction()
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

Gallio.Framework.Pattern Namespace


TestAssemblyDecoratorPatternAttribute Class

TestAssemblyDecoratorPatternAttribute Class
See Also Example Members
[image]

A test assembly decorator pattern attribute applies decorations to an existing test declared at the assembly-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestAssemblyDecoratorPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)]
public abstract class TestAssemblyDecoratorPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = True, Inherited = True)]
ref class TestAssemblyDecoratorPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True) */
public class TestAssemblyDecoratorPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)
class TestAssemblyDecoratorPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestAssemblyDecoratorPatternAttribute
MbUnit.Framework.DefaultTestCaseTimeoutAttribute
MbUnit.Framework.DegreeOfParallelismAttribute

See Also

TestAssemblyDecoratorPatternAttribute Members
Gallio.Framework.Pattern Namespace
TestAssemblyPatternAttribute


TestAssemblyDecoratorPatternAttribute Members

TestAssemblyDecoratorPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A test assembly decorator pattern attribute applies decorations to an existing test declared at the assembly-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestAssemblyDecoratorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestAssemblyDecoratorPatternAttribute | Initializes a new instance of the TestAssemblyDecoratorPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateAssemblyTest | Applies decorations to an assembly-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestAssemblyDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestAssemblyPatternAttribute


TestAssemblyDecoratorPatternAttribute Constructor

TestAssemblyDecoratorPatternAttribute Constructor
[image]

Initializes a new instance of the TestAssemblyDecoratorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestAssemblyDecoratorPatternAttribute()
C++
protected:
TestAssemblyDecoratorPatternAttribute() sealed
J#
protected TestAssemblyDecoratorPatternAttribute()
JScript
protected function TestAssemblyDecoratorPatternAttribute()

See Also

TestAssemblyDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestAssemblyDecoratorPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateAssemblyTest | Applies decorations to an assembly-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestAssemblyDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestAssemblyPatternAttribute


DecorateAssemblyTest Method

TestAssemblyDecoratorPatternAttribute.DecorateAssemblyTest Method
See Also Example
[image]

Applies decorations to an assembly-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DecorateAssemblyTest( _
ByVal assemblyScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
J#
protected virtual void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
JScript
protected virtual function DecorateAssemblyTest(
assemblyScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

assemblyScope
The assembly scope
assembly
The assembly

See Also

TestAssemblyDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

TestAssemblyDecoratorPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

TestAssemblyDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestAssemblyDecoratorPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
IAssemblyInfo assembly
)
C++
protected:
virtual void Validate(
IPatternScope scope,
IAssemblyInfo assembly
)
J#
protected virtual void Validate(
IPatternScope scope,
IAssemblyInfo assembly
)
JScript
protected virtual function Validate(
scope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

scope
The scope
assembly
The assembly

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestAssemblyDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestAssemblyExecutionParameters Class

TestAssemblyExecutionParameters Class
See Also Example Members
[image]

Configures runtime parameters while executing tests within a test assembly. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestAssemblyExecutionParameters
C#
public static class TestAssemblyExecutionParameters
C++
ref class TestAssemblyExecutionParameters abstract sealed
J#
public final class TestAssemblyExecutionParameters
JScript
public class TestAssemblyExecutionParameters

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.TestAssemblyExecutionParameters

See Also

TestAssemblyExecutionParameters Members
Gallio.Framework.Pattern Namespace


TestAssemblyExecutionParameters Members

TestAssemblyExecutionParameters Members
See Also Example Properties Methods
[image]

Configures runtime parameters while executing tests within a test assembly. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestAssemblyExecutionParameters.

Public Properties

Name | Description
DefaultTestCaseTimeout | Specifies the default test case timeout or null if none.
DegreeOfParallelism | Specifies the maximum number of concurrent threads to use when tests are run in parallel.
Top

Public Methods

Name | Description
Reset | Resets the globals to default values.
Top

See Also

TestAssemblyExecutionParameters Class
Gallio.Framework.Pattern Namespace


Properties

TestAssemblyExecutionParameters Properties
[image]

Public Properties

Name | Description
DefaultTestCaseTimeout | Specifies the default test case timeout or null if none.
DegreeOfParallelism | Specifies the maximum number of concurrent threads to use when tests are run in parallel.
Top

See Also

TestAssemblyExecutionParameters Class
Gallio.Framework.Pattern Namespace


DefaultTestCaseTimeout Property

TestAssemblyExecutionParameters.DefaultTestCaseTimeout Property
See Also Example
[image]

Specifies the default test case timeout or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property DefaultTestCaseTimeout As Nullable(Of TimeSpan)
C#
public static Nullable<TimeSpan> DefaultTestCaseTimeout { get; set; }
C++
public static property Nullable<TimeSpan> DefaultTestCaseTimeout {
Nullable<TimeSpan> get();
void set(Nullable<TimeSpan> value);
}
J#
/** property */
public Nullable<TimeSpan> get_DefaultTestCaseTimeout();

/** property */
public void set_DefaultTestCaseTimeout(Nullable<TimeSpan> value);
JScript
public function get DefaultTestCaseTimeout() : Nullable<TimeSpan>

public function set DefaultTestCaseTimeout(value : Nullable<TimeSpan>);

Property Value

The default timeout for test cases or null if none. Defaults to 10 minutes.

See Also

TestAssemblyExecutionParameters Class
Gallio.Framework.Pattern Namespace


DegreeOfParallelism Property

TestAssemblyExecutionParameters.DegreeOfParallelism Property
[image]

Specifies the maximum number of concurrent threads to use when tests are run in parallel.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property DegreeOfParallelism As Integer
C#
public static int DegreeOfParallelism { get; set; }
C++
public static property int DegreeOfParallelism {
int get();
void set(int value);
}
J#
/** property */
public int get_DegreeOfParallelism();

/** property */
public void set_DegreeOfParallelism(int value);
JScript
public function get DegreeOfParallelism() : int

public function set DegreeOfParallelism(value : int);

Property Value

The degree of parallelism. Defaults to ProcessorCount or 2, whichever is greater.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if value is less than 1

See Also

TestAssemblyExecutionParameters Class
Gallio.Framework.Pattern Namespace


Methods

TestAssemblyExecutionParameters Methods
[image]

Public Methods

Name | Description
Reset | Resets the globals to default values.
Top

See Also

TestAssemblyExecutionParameters Class
Gallio.Framework.Pattern Namespace


Reset Method

TestAssemblyExecutionParameters.Reset Method
[image]

Resets the globals to default values.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Reset()
C#
public static void Reset()
C++
public:
static void Reset()
J#
public static void Reset()
JScript
public static function Reset()

See Also

TestAssemblyExecutionParameters Class
Gallio.Framework.Pattern Namespace


TestAssemblyInitializationAttribute Class

TestAssemblyInitializationAttribute Class
See Also Example Members
[image]

An assembly initialization attribute gets a chance to perform early initialization of the system before enumerating the tests within the assembly.

For examples, a subclass of this attribute may be used to register an assembly resolver before test enumeration occurs to ensure that all referenced assemblies can be loaded.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestAssemblyInitializationAttribute
Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)]
public abstract class TestAssemblyInitializationAttribute : Attribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = True, Inherited = True)]
ref class TestAssemblyInitializationAttribute abstract : Attribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True) */
public class TestAssemblyInitializationAttribute extends Attribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)
class TestAssemblyInitializationAttribute extends Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.TestAssemblyInitializationAttribute
MbUnit.Framework.AssemblyResolverAttribute

See Also

TestAssemblyInitializationAttribute Members
Gallio.Framework.Pattern Namespace


TestAssemblyInitializationAttribute Members

TestAssemblyInitializationAttribute Members
See Also Example Constructors Properties Methods
[image]

An assembly initialization attribute gets a chance to perform early initialization of the system before enumerating the tests within the assembly.

For examples, a subclass of this attribute may be used to register an assembly resolver before test enumeration occurs to ensure that all referenced assemblies can be loaded.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestAssemblyInitializationAttribute.

Protected Constructors

 | Name | Description
Family method | TestAssemblyInitializationAttribute | Initializes a new instance of the TestAssemblyInitializationAttribute class.
Top

Public Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Performs early initialization for the specified assembly.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestAssemblyInitializationAttribute Class
Gallio.Framework.Pattern Namespace


TestAssemblyInitializationAttribute Constructor

TestAssemblyInitializationAttribute Constructor
[image]

Initializes a new instance of the TestAssemblyInitializationAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestAssemblyInitializationAttribute()
C++
protected:
TestAssemblyInitializationAttribute() sealed
J#
protected TestAssemblyInitializationAttribute()
JScript
protected function TestAssemblyInitializationAttribute()

See Also

TestAssemblyInitializationAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestAssemblyInitializationAttribute Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Performs early initialization for the specified assembly.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestAssemblyInitializationAttribute Class
Gallio.Framework.Pattern Namespace


Initialize Method

TestAssemblyInitializationAttribute.Initialize Method
[image]

Performs early initialization for the specified assembly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Initialize( _
ByVal frameworkScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
public abstract void Initialize(
IPatternScope frameworkScope,
IAssemblyInfo assembly
)
C++
public:
void Initialize(
IPatternScope frameworkScope,
IAssemblyInfo assembly
) abstract
J#
public abstract void Initialize(
IPatternScope frameworkScope,
IAssemblyInfo assembly
)
JScript
public abstract function Initialize(
frameworkScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

frameworkScope
The framework-level scope that will eventually contain the assembly-level test
assembly
The assembly to process

See Also

TestAssemblyInitializationAttribute Class
Gallio.Framework.Pattern Namespace


TestAssemblyPatternAttribute Class

TestAssemblyPatternAttribute Class
See Also Example Members
[image]

Declares that an assembly generates an assembly-level test. Subclasses of this attribute can customize how test enumeration takes place within the assembly.

At most one attribute of this type may appear on any given assembly.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := False, Inherited := True)>
Public MustInherit Class TestAssemblyPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = False, Inherited = True)]
public abstract class TestAssemblyPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = False, Inherited = True)]
ref class TestAssemblyPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = False, Inherited = True) */
public class TestAssemblyPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = False, Inherited = True)
class TestAssemblyPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestAssemblyPatternAttribute

See Also

TestAssemblyPatternAttribute Members
Gallio.Framework.Pattern Namespace
TestAssemblyDecoratorPatternAttribute


TestAssemblyPatternAttribute Members

TestAssemblyPatternAttribute Members
See Also Example Constructors Fields Properties Methods
[image]

Declares that an assembly generates an assembly-level test. Subclasses of this attribute can customize how test enumeration takes place within the assembly.

At most one attribute of this type may appear on any given assembly.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestAssemblyPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestAssemblyPatternAttribute | Initializes a new instance of the TestAssemblyPatternAttribute class.
Top

Public Fields

Name | Description
DefaultInstance | Gets a default instance of the assembly pattern attribute to use when no other pattern consumes an assembly. This field is read-only.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultTypePattern | Gets the default pattern to apply to types that do not have a primary pattern, or null if none.
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeAssemblyTest | Initializes a test for an assembly after it has been added to the test model.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateChildrenImmediately | Populates the children of the assembly test all at once.
Family method | PrepareToPopulateChildrenOnDemand | Prepares to populate the children of the assembly test on demand by adding a deferred populator with AddDeferredComponentPopulator.
Family method | SetTestSemantics | Applies semantic actions to the assembly-level test to estalish its runtime behavior. This method is called after InitializeAssemblyTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestAssemblyDecoratorPatternAttribute


TestAssemblyPatternAttribute Constructor

TestAssemblyPatternAttribute Constructor
[image]

Initializes a new instance of the TestAssemblyPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestAssemblyPatternAttribute()
C++
protected:
TestAssemblyPatternAttribute() sealed
J#
protected TestAssemblyPatternAttribute()
JScript
protected function TestAssemblyPatternAttribute()

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Fields

TestAssemblyPatternAttribute Fields
[image]

Public Fields

Name | Description
DefaultInstance | Gets a default instance of the assembly pattern attribute to use when no other pattern consumes an assembly. This field is read-only.
Top

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestAssemblyDecoratorPatternAttribute


DefaultInstance Field

TestAssemblyPatternAttribute.DefaultInstance Field
[image]

Gets a default instance of the assembly pattern attribute to use when no other pattern consumes an assembly. This field is read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultInstance As TestAssemblyPatternAttribute
C#
public static readonly TestAssemblyPatternAttribute DefaultInstance;
C++
public:
static const TestAssemblyPatternAttribute DefaultInstance;
J#
public static final TestAssemblyPatternAttribute DefaultInstance
JScript
public static const var DefaultInstance : TestAssemblyPatternAttribute;

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

TestAssemblyPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultTypePattern | Gets the default pattern to apply to types that do not have a primary pattern, or null if none.
Top

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestAssemblyDecoratorPatternAttribute


DefaultTypePattern Property

TestAssemblyPatternAttribute.DefaultTypePattern Property
[image]

Gets the default pattern to apply to types that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultTypePattern As IPattern
C#
protected virtual IPattern DefaultTypePattern { get; }
C++
protected virtual property IPattern DefaultTypePattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultTypePattern();
JScript
protected function get DefaultTypePattern() : IPattern

Remarks

The default implementation returns AutomaticInstance.

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

TestAssemblyPatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestAssemblyPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeAssemblyTest | Initializes a test for an assembly after it has been added to the test model.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateChildrenImmediately | Populates the children of the assembly test all at once.
Family method | PrepareToPopulateChildrenOnDemand | Prepares to populate the children of the assembly test on demand by adding a deferred populator with AddDeferredComponentPopulator.
Family method | SetTestSemantics | Applies semantic actions to the assembly-level test to estalish its runtime behavior. This method is called after InitializeAssemblyTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestAssemblyDecoratorPatternAttribute


Consume Method

TestAssemblyPatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


InitializeAssemblyTest Method

TestAssemblyPatternAttribute.InitializeAssemblyTest Method
[image]

Initializes a test for an assembly after it has been added to the test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeAssemblyTest( _
ByVal assemblyScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void InitializeAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void InitializeAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
J#
protected virtual void InitializeAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
JScript
protected virtual function InitializeAssemblyTest(
assemblyScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

assemblyScope
The assembly scope
assembly
The assembly

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTest Method

TestAssemblyPatternAttribute.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTest
C#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTest

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


PopulateChildrenImmediately Method

TestAssemblyPatternAttribute.PopulateChildrenImmediately Method
See Also Example
[image]

Populates the children of the assembly test all at once.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PopulateChildrenImmediately( _
ByVal assemblyScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void PopulateChildrenImmediately(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void PopulateChildrenImmediately(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
J#
protected virtual void PopulateChildrenImmediately(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
JScript
protected virtual function PopulateChildrenImmediately(
assemblyScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

assemblyScope
The assembly scope
assembly
The assembly

Remarks

The default implementation processes all public and non-public types within the assembly.

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


PrepareToPopulateChildrenOnDemand Method

TestAssemblyPatternAttribute.PrepareToPopulateChildrenOnDemand Method
See Also Example
[image]

Prepares to populate the children of the assembly test on demand by adding a deferred populator with AddDeferredComponentPopulator.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PrepareToPopulateChildrenOnDemand( _
ByVal assemblyScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void PrepareToPopulateChildrenOnDemand(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void PrepareToPopulateChildrenOnDemand(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
J#
protected virtual void PrepareToPopulateChildrenOnDemand(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
JScript
protected virtual function PrepareToPopulateChildrenOnDemand(
assemblyScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

assemblyScope
The assembly scope
assembly
The assembly

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


SetTestSemantics Method

TestAssemblyPatternAttribute.SetTestSemantics Method
[image]

Applies semantic actions to the assembly-level test to estalish its runtime behavior.

This method is called after InitializeAssemblyTest.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTestSemantics( _
ByVal testBuilder As ITestBuilder, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
IAssemblyInfo assembly
)
C++
protected:
virtual void SetTestSemantics(
ITestBuilder testBuilder,
IAssemblyInfo assembly
)
J#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
IAssemblyInfo assembly
)
JScript
protected virtual function SetTestSemantics(
testBuilder : ITestBuilder,
assembly : IAssemblyInfo
)

Parameters

testBuilder
The test builder
assembly
The assembly

Remarks

The default behavior for a TestAssemblyPatternAttribute is to configure the test actions as follows:

  • InitializeTest: Reset the TestAssemblyExecutionParameters to defaults.

You can override this method to change the semantics as required.

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestAssemblyPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IAssemblyInfo assembly
)
J#
protected virtual void Validate(
IPatternScope containingScope,
IAssemblyInfo assembly
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

containingScope
The containing scope
assembly
The assembly

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestAssemblyPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestConstructorPatternAttribute Class

TestConstructorPatternAttribute Class
See Also Example Members
[image]

Declares that a constructor is used to provide test fixture parameters. Subclasses of this attribute can control what happens with the constructor.

At most one attribute of this type may appear on any given constructor.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple := False, Inherited := True)>
Public MustInherit Class TestConstructorPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = False, Inherited = True)]
public abstract class TestConstructorPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Constructor, AllowMultiple = False, Inherited = True)]
ref class TestConstructorPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = False, Inherited = True) */
public class TestConstructorPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Constructor, AllowMultiple = False, Inherited = True)
class TestConstructorPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestConstructorPatternAttribute

See Also

TestConstructorPatternAttribute Members
Gallio.Framework.Pattern Namespace


TestConstructorPatternAttribute Members

TestConstructorPatternAttribute Members
See Also Example Constructors Fields Properties Methods
[image]

Declares that a constructor is used to provide test fixture parameters. Subclasses of this attribute can control what happens with the constructor.

At most one attribute of this type may appear on any given constructor.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestConstructorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestConstructorPatternAttribute | Initializes a new instance of the TestConstructorPatternAttribute class.
Top

Public Fields

Name | Description
DefaultInstance | Gets a default instance of the constructor pattern attribute to use when no other pattern consumes a contructor. This field is read-only.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultConstructorParameterPattern | Gets the default pattern to apply to constructor parameters that do not have a primary pattern, or null if none.
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Overridden. Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeDataContext | Initializes the PatternTestDataContext.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestConstructorPatternAttribute Constructor

TestConstructorPatternAttribute Constructor
[image]

Initializes a new instance of the TestConstructorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestConstructorPatternAttribute()
C++
protected:
TestConstructorPatternAttribute() sealed
J#
protected TestConstructorPatternAttribute()
JScript
protected function TestConstructorPatternAttribute()

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Fields

TestConstructorPatternAttribute Fields
[image]

Public Fields

Name | Description
DefaultInstance | Gets a default instance of the constructor pattern attribute to use when no other pattern consumes a contructor. This field is read-only.
Top

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultInstance Field

TestConstructorPatternAttribute.DefaultInstance Field
[image]

Gets a default instance of the constructor pattern attribute to use when no other pattern consumes a contructor. This field is read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultInstance As TestConstructorPatternAttribute
C#
public static readonly TestConstructorPatternAttribute DefaultInstance;
C++
public:
static const TestConstructorPatternAttribute DefaultInstance;
J#
public static final TestConstructorPatternAttribute DefaultInstance
JScript
public static const var DefaultInstance : TestConstructorPatternAttribute;

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

TestConstructorPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultConstructorParameterPattern | Gets the default pattern to apply to constructor parameters that do not have a primary pattern, or null if none.
Top

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultConstructorParameterPattern Property

TestConstructorPatternAttribute.DefaultConstructorParameterPattern Property
See Also Example
[image]

Gets the default pattern to apply to constructor parameters that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultConstructorParameterPattern As IPattern
C#
protected virtual IPattern DefaultConstructorParameterPattern { get; }
C++
protected virtual property IPattern DefaultConstructorParameterPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultConstructorParameterPattern();
JScript
protected function get DefaultConstructorParameterPattern() : IPattern

Remarks

The default implementation returns DefaultInstance.

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

TestConstructorPatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestConstructorPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Overridden. Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeDataContext | Initializes the PatternTestDataContext.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Consume Method

TestConstructorPatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


InitializeDataContext Method

TestConstructorPatternAttribute.InitializeDataContext Method
[image]

Initializes the PatternTestDataContext.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeDataContext( _
ByVal dataContextScope As IPatternScope, _
ByVal constructor As IConstructorInfo _
)
C#
protected virtual void InitializeDataContext(
IPatternScope dataContextScope,
IConstructorInfo constructor
)
C++
protected:
virtual void InitializeDataContext(
IPatternScope dataContextScope,
IConstructorInfo constructor
)
J#
protected virtual void InitializeDataContext(
IPatternScope dataContextScope,
IConstructorInfo constructor
)
JScript
protected virtual function InitializeDataContext(
dataContextScope : IPatternScope,
constructor : IConstructorInfo
)

Parameters

dataContextScope
The data context scope
constructor
The constructor

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTestPart Method

TestConstructorPatternAttribute.IsTestPart Method
[image]

Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTestPart( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTestPart
C#
public override bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTestPart(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTestPart

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestConstructorPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal constructor As IConstructorInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
IConstructorInfo constructor
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IConstructorInfo constructor
)
J#
protected virtual void Validate(
IPatternScope containingScope,
IConstructorInfo constructor
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
constructor : IConstructorInfo
)

Parameters

containingScope
The containing scope
constructor
The constructor

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestConstructorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestDecoratorPatternAttribute Class

TestDecoratorPatternAttribute Class
See Also Example Members
[image]

A test decorator pattern attribute applies decorations to a test defined by an assembly, type, or method. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestDecoratorPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public abstract class TestDecoratorPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class TestDecoratorPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class TestDecoratorPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class TestDecoratorPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
Derived types

See Also

TestDecoratorPatternAttribute Members
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


TestDecoratorPatternAttribute Members

TestDecoratorPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A test decorator pattern attribute applies decorations to a test defined by an assembly, type, or method. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestDecoratorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestDecoratorPatternAttribute | Initializes a new instance of the TestDecoratorPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


TestDecoratorPatternAttribute Constructor

TestDecoratorPatternAttribute Constructor
[image]

Initializes a new instance of the TestDecoratorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestDecoratorPatternAttribute()
C++
protected:
TestDecoratorPatternAttribute() sealed
J#
protected TestDecoratorPatternAttribute()
JScript
protected function TestDecoratorPatternAttribute()

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestDecoratorPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


DecorateTest Method

TestDecoratorPatternAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

TestDecoratorPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestDecoratorPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestDependencyPatternAttribute Class

TestDependencyPatternAttribute Class
See Also Example Members
[image]

A dependency pattern attribute creates a dependency on the tests defined by some other code element. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestDependencyPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public abstract class TestDependencyPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class TestDependencyPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class TestDependencyPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class TestDependencyPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestDependencyPatternAttribute
MbUnit.Framework.DependsOnAttribute

See Also

TestDependencyPatternAttribute Members
Gallio.Framework.Pattern Namespace


TestDependencyPatternAttribute Members

TestDependencyPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A dependency pattern attribute creates a dependency on the tests defined by some other code element. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestDependencyPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestDependencyPatternAttribute | Initializes a new instance of the TestDependencyPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDependency | Gets the code element that declares the tests on which this test should depend.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestDependencyPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestDependencyPatternAttribute Constructor

TestDependencyPatternAttribute Constructor
[image]

Initializes a new instance of the TestDependencyPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestDependencyPatternAttribute()
C++
protected:
TestDependencyPatternAttribute() sealed
J#
protected TestDependencyPatternAttribute()
JScript
protected function TestDependencyPatternAttribute()

See Also

TestDependencyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestDependencyPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDependency | Gets the code element that declares the tests on which this test should depend.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestDependencyPatternAttribute Class
Gallio.Framework.Pattern Namespace


GetDependency Method

TestDependencyPatternAttribute.GetDependency Method
[image]

Gets the code element that declares the tests on which this test should depend.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetDependency( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) As ICodeElementInfo
C#
protected abstract ICodeElementInfo GetDependency(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
ICodeElementInfo GetDependency(
IPatternScope scope,
ICodeElementInfo codeElement
) abstract
J#
protected abstract ICodeElementInfo GetDependency(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected abstract function GetDependency(
scope : IPatternScope,
codeElement : ICodeElementInfo
) : ICodeElementInfo

Parameters

scope
The scope
codeElement
The code element

Return Value

The code element representing the dependency

See Also

TestDependencyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

TestDependencyPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

TestDependencyPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestDependencyPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestDependencyPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestMethodDecoratorPatternAttribute Class

TestMethodDecoratorPatternAttribute Class
See Also Example Members
[image]

A test decorator pattern attribute applies decorations to an existing test declared at the method-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestMethodDecoratorPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = True, Inherited = True)]
public abstract class TestMethodDecoratorPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = True, Inherited = True)]
ref class TestMethodDecoratorPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = True, Inherited = True) */
public class TestMethodDecoratorPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = True, Inherited = True)
class TestMethodDecoratorPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.ExpectedExceptionAttribute
MbUnit.Framework.MultipleAssertsAttribute

See Also

TestMethodDecoratorPatternAttribute Members
Gallio.Framework.Pattern Namespace


TestMethodDecoratorPatternAttribute Members

TestMethodDecoratorPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A test decorator pattern attribute applies decorations to an existing test declared at the method-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestMethodDecoratorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestMethodDecoratorPatternAttribute | Initializes a new instance of the TestMethodDecoratorPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestMethodDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestMethodDecoratorPatternAttribute Constructor

TestMethodDecoratorPatternAttribute Constructor
[image]

Initializes a new instance of the TestMethodDecoratorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestMethodDecoratorPatternAttribute()
C++
protected:
TestMethodDecoratorPatternAttribute() sealed
J#
protected TestMethodDecoratorPatternAttribute()
JScript
protected function TestMethodDecoratorPatternAttribute()

See Also

TestMethodDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestMethodDecoratorPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestMethodDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


DecorateMethodTest Method

TestMethodDecoratorPatternAttribute.DecorateMethodTest Method
See Also Example
[image]

Applies decorations to a method-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DecorateMethodTest( _
ByVal methodScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected virtual void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
J#
protected virtual void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
JScript
protected virtual function DecorateMethodTest(
methodScope : IPatternScope,
method : IMethodInfo
)

Parameters

methodScope
The method scope
method
The method

See Also

TestMethodDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

TestMethodDecoratorPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

TestMethodDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestMethodDecoratorPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope scope,
IMethodInfo method
)
J#
protected virtual void Validate(
IPatternScope scope,
IMethodInfo method
)
JScript
protected virtual function Validate(
scope : IPatternScope,
method : IMethodInfo
)

Parameters

scope
The scope
method
The method

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestMethodDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestMethodPatternAttribute Class

TestMethodPatternAttribute Class
See Also Example Members
[image]

Declares that a method represents a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public MustInherit Class TestMethodPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public abstract class TestMethodPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TestMethodPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class TestMethodPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class TestMethodPatternAttribute extends PatternAttribute

Remarks

Subclasses of this attribute can control what happens with the method.

At most one attribute of this type may appear on any given method.

A test method has a timeout of 10 minutes by default.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestMethodPatternAttribute
MbUnit.Framework.DynamicTestFactoryAttribute
MbUnit.Framework.TestAttribute

See Also

TestMethodPatternAttribute Members
Gallio.Framework.Pattern Namespace
TestMethodDecoratorPatternAttribute


TestMethodPatternAttribute Members

TestMethodPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

Declares that a method represents a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestMethodPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestMethodPatternAttribute | Initializes a new instance of the TestMethodPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none.
Family property | DefaultMethodParameterPattern | Gets the default pattern to apply to method parameters that do not have a primary pattern, or null if none.
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Executes the test method.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestMethodDecoratorPatternAttribute


TestMethodPatternAttribute Constructor

TestMethodPatternAttribute Constructor
[image]

Initializes a new instance of the TestMethodPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestMethodPatternAttribute()
C++
protected:
TestMethodPatternAttribute() sealed
J#
protected TestMethodPatternAttribute()
JScript
protected function TestMethodPatternAttribute()

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

TestMethodPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none.
Family property | DefaultMethodParameterPattern | Gets the default pattern to apply to method parameters that do not have a primary pattern, or null if none.
Top

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestMethodDecoratorPatternAttribute


DefaultGenericParameterPattern Property

TestMethodPatternAttribute.DefaultGenericParameterPattern Property
See Also Example
[image]

Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultGenericParameterPattern As IPattern
C#
protected virtual IPattern DefaultGenericParameterPattern { get; }
C++
protected virtual property IPattern DefaultGenericParameterPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultGenericParameterPattern();
JScript
protected function get DefaultGenericParameterPattern() : IPattern

Remarks

The default implementation returns DefaultInstance.

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultMethodParameterPattern Property

TestMethodPatternAttribute.DefaultMethodParameterPattern Property
See Also Example
[image]

Gets the default pattern to apply to method parameters that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMethodParameterPattern As IPattern
C#
protected virtual IPattern DefaultMethodParameterPattern { get; }
C++
protected virtual property IPattern DefaultMethodParameterPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultMethodParameterPattern();
JScript
protected function get DefaultMethodParameterPattern() : IPattern

Remarks

The default implementation returns DefaultInstance.

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

TestMethodPatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Order Property

TestMethodPatternAttribute.Order Property
[image]

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Order As Integer
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public int Order { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property int Order sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public CompilerGeneratedAttribute function get Order() : int

public CompilerGeneratedAttribute function set Order(value : int);

Property Value

The test execution order with respect to siblings, initially zero.

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestMethodPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Executes the test method.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestMethodDecoratorPatternAttribute


Consume Method

TestMethodPatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Execute Method

TestMethodPatternAttribute.Execute Method
[image]

Executes the test method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function Execute( _
ByVal state As PatternTestInstanceState _
) As Object
C#
protected virtual object Execute(
PatternTestInstanceState state
)
C++
protected:
virtual Object Execute(
PatternTestInstanceState state
)
J#
protected virtual object Execute(
PatternTestInstanceState state
)
JScript
protected virtual function Execute(
state : PatternTestInstanceState
) : Object

Parameters

state
The test instance state, not null

Return Value

The test method result

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


InitializeTest Method

TestMethodPatternAttribute.InitializeTest Method
[image]

Initializes a test for a method after it has been added to the test model.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeTest( _
ByVal methodScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected virtual void InitializeTest(
IPatternScope methodScope,
IMethodInfo method
)
C++
protected:
virtual void InitializeTest(
IPatternScope methodScope,
IMethodInfo method
)
J#
protected virtual void InitializeTest(
IPatternScope methodScope,
IMethodInfo method
)
JScript
protected virtual function InitializeTest(
methodScope : IPatternScope,
method : IMethodInfo
)

Parameters

methodScope
The method scope
method
The method

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTest Method

TestMethodPatternAttribute.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTest
C#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTest

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


SetTestSemantics Method

TestMethodPatternAttribute.SetTestSemantics Method
[image]

Applies semantic actions to a test to estalish its runtime behavior.

This method is called after InitializeTest.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTestSemantics( _
ByVal testBuilder As ITestBuilder, _
ByVal method As IMethodInfo _
)
C#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
IMethodInfo method
)
C++
protected:
virtual void SetTestSemantics(
ITestBuilder testBuilder,
IMethodInfo method
)
J#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
IMethodInfo method
)
JScript
protected virtual function SetTestSemantics(
testBuilder : ITestBuilder,
method : IMethodInfo
)

Parameters

testBuilder
The test builder
method
The test method

Remarks

The default behavior for a TestMethodPatternAttribute is to configure the test actions as follows:

  • BeforeTestInstance: Set the test step name, TestMethod and TestArguments based on any values bound to the test method's generic parameter and method parameter slots.
  • ExecuteTestInstance: Invoke the method.

You can override this method to change the semantics as required.

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestMethodPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
)
J#
protected virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestParameterDecoratorPatternAttribute Class

TestParameterDecoratorPatternAttribute Class
See Also Example Members
[image]

A test parameter decorator pattern attribute applies decorations to an existing PatternTestParameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestParameterDecoratorPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public abstract class TestParameterDecoratorPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class TestParameterDecoratorPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class TestParameterDecoratorPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class TestParameterDecoratorPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestParameterDecoratorPatternAttribute
MbUnit.Framework.BindAttribute

See Also

TestParameterDecoratorPatternAttribute Members
Gallio.Framework.Pattern Namespace


TestParameterDecoratorPatternAttribute Members

TestParameterDecoratorPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A test parameter decorator pattern attribute applies decorations to an existing PatternTestParameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestParameterDecoratorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestParameterDecoratorPatternAttribute | Initializes a new instance of the TestParameterDecoratorPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTestParameter | Applies decorations to a PatternTestParameter. A typical use of this method is to augment the test parameter with additional metadata or to add additional behaviors to the test parameter.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestParameterDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestParameterDecoratorPatternAttribute Constructor

TestParameterDecoratorPatternAttribute Constructor
[image]

Initializes a new instance of the TestParameterDecoratorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestParameterDecoratorPatternAttribute()
C++
protected:
TestParameterDecoratorPatternAttribute() sealed
J#
protected TestParameterDecoratorPatternAttribute()
JScript
protected function TestParameterDecoratorPatternAttribute()

See Also

TestParameterDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestParameterDecoratorPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTestParameter | Applies decorations to a PatternTestParameter. A typical use of this method is to augment the test parameter with additional metadata or to add additional behaviors to the test parameter.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestParameterDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


DecorateTestParameter Method

TestParameterDecoratorPatternAttribute.DecorateTestParameter Method
See Also Example
[image]

Applies decorations to a PatternTestParameter.

A typical use of this method is to augment the test parameter with additional metadata or to add additional behaviors to the test parameter.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DecorateTestParameter( _
ByVal slotScope As IPatternScope, _
ByVal slot As ISlotInfo _
)
C#
protected virtual void DecorateTestParameter(
IPatternScope slotScope,
ISlotInfo slot
)
C++
protected:
virtual void DecorateTestParameter(
IPatternScope slotScope,
ISlotInfo slot
)
J#
protected virtual void DecorateTestParameter(
IPatternScope slotScope,
ISlotInfo slot
)
JScript
protected virtual function DecorateTestParameter(
slotScope : IPatternScope,
slot : ISlotInfo
)

Parameters

slotScope
The slot scope
slot
The slot

See Also

TestParameterDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

TestParameterDecoratorPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

TestParameterDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestParameterDecoratorPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal slot As ISlotInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ISlotInfo slot
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ISlotInfo slot
)
J#
protected virtual void Validate(
IPatternScope scope,
ISlotInfo slot
)
JScript
protected virtual function Validate(
scope : IPatternScope,
slot : ISlotInfo
)

Parameters

scope
The scope
slot
The slot

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestParameterDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestParameterPatternAttribute Class

TestParameterPatternAttribute Class
See Also Example Members
[image]

Declares that a field, property, method parameter or generic parameter represents a PatternTestParameter. Subclasses of this attribute can control what happens with the parameter.

At most one attribute of this type may appear on any given property, field or parameter declaration.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := False, Inherited := True)>
Public MustInherit Class TestParameterPatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True)]
public abstract class TestParameterPatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = False, Inherited = True)]
ref class TestParameterPatternAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True) */
public class TestParameterPatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True)
class TestParameterPatternAttribute extends PatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestParameterPatternAttribute
MbUnit.Framework.ParameterAttribute

See Also

TestParameterPatternAttribute Members
Gallio.Framework.Pattern Namespace


TestParameterPatternAttribute Members

TestParameterPatternAttribute Members
See Also Example Constructors Fields Properties Methods
[image]

Declares that a field, property, method parameter or generic parameter represents a PatternTestParameter. Subclasses of this attribute can control what happens with the parameter.

At most one attribute of this type may appear on any given property, field or parameter declaration.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestParameterPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestParameterPatternAttribute | Initializes a new instance of the TestParameterPatternAttribute class.
Top

Public Fields

Name | Description
AutomaticInstance | Gets an instance of the parameter pattern attribute to use when no other pattern consumes the parameter but when the parameter appears to have other contributing pattern attributes associated with it. So a test parameter is created automatically if we try to apply contributions to it, such as data items, but otherwise it is silent. This is particularly useful with fields and properties. This field is read-only.
DefaultInstance | Gets a default instance of the parameter pattern attribute to use when no other pattern consumes the parameter. This field is read-only.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Overridden. Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTestParameter | Initializes a test parameter after it has been added to the containing test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestParameterPatternAttribute Constructor

TestParameterPatternAttribute Constructor
[image]

Initializes a new instance of the TestParameterPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestParameterPatternAttribute()
C++
protected:
TestParameterPatternAttribute() sealed
J#
protected TestParameterPatternAttribute()
JScript
protected function TestParameterPatternAttribute()

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


Fields

TestParameterPatternAttribute Fields
[image]

Public Fields

Name | Description
AutomaticInstance | Gets an instance of the parameter pattern attribute to use when no other pattern consumes the parameter but when the parameter appears to have other contributing pattern attributes associated with it. So a test parameter is created automatically if we try to apply contributions to it, such as data items, but otherwise it is silent. This is particularly useful with fields and properties. This field is read-only.
DefaultInstance | Gets a default instance of the parameter pattern attribute to use when no other pattern consumes the parameter. This field is read-only.
Top

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


AutomaticInstance Field

TestParameterPatternAttribute.AutomaticInstance Field
[image]

Gets an instance of the parameter pattern attribute to use when no other pattern consumes the parameter but when the parameter appears to have other contributing pattern attributes associated with it. So a test parameter is created automatically if we try to apply contributions to it, such as data items, but otherwise it is silent. This is particularly useful with fields and properties. This field is read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AutomaticInstance As TestParameterPatternAttribute
C#
public static readonly TestParameterPatternAttribute AutomaticInstance;
C++
public:
static const TestParameterPatternAttribute AutomaticInstance;
J#
public static final TestParameterPatternAttribute AutomaticInstance
JScript
public static const var AutomaticInstance : TestParameterPatternAttribute;

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultInstance Field

TestParameterPatternAttribute.DefaultInstance Field
[image]

Gets a default instance of the parameter pattern attribute to use when no other pattern consumes the parameter. This field is read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultInstance As TestParameterPatternAttribute
C#
public static readonly TestParameterPatternAttribute DefaultInstance;
C++
public:
static const TestParameterPatternAttribute DefaultInstance;
J#
public static final TestParameterPatternAttribute DefaultInstance
JScript
public static const var DefaultInstance : TestParameterPatternAttribute;

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


Properties

TestParameterPatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

TestParameterPatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestParameterPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Overridden. Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTestParameter | Initializes a test parameter after it has been added to the containing test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


Consume Method

TestParameterPatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


InitializeTestParameter Method

TestParameterPatternAttribute.InitializeTestParameter Method
[image]

Initializes a test parameter after it has been added to the containing test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeTestParameter( _
ByVal testParameterScope As IPatternScope, _
ByVal slot As ISlotInfo _
)
C#
protected virtual void InitializeTestParameter(
IPatternScope testParameterScope,
ISlotInfo slot
)
C++
protected:
virtual void InitializeTestParameter(
IPatternScope testParameterScope,
ISlotInfo slot
)
J#
protected virtual void InitializeTestParameter(
IPatternScope testParameterScope,
ISlotInfo slot
)
JScript
protected virtual function InitializeTestParameter(
testParameterScope : IPatternScope,
slot : ISlotInfo
)

Parameters

testParameterScope
The test parameter scope
slot
The slot

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTestPart Method

TestParameterPatternAttribute.IsTestPart Method
[image]

Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTestPart( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTestPart
C#
public override bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTestPart(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTestPart(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTestPart

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestParameterPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal slot As ISlotInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
ISlotInfo slot
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
ISlotInfo slot
)
J#
protected virtual void Validate(
IPatternScope containingScope,
ISlotInfo slot
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
slot : ISlotInfo
)

Parameters

containingScope
The containing scope
slot
The slot

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestParameterPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestTypeDecoratorPatternAttribute Class

TestTypeDecoratorPatternAttribute Class
See Also Example Members
[image]

A test type decorator pattern attribute applies decorations to an existing test declared at the type-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestTypeDecoratorPatternAttribute
Inherits DecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = True, Inherited = True)]
public abstract class TestTypeDecoratorPatternAttribute : DecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = True, Inherited = True)]
ref class TestTypeDecoratorPatternAttribute abstract : DecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = True, Inherited = True) */
public class TestTypeDecoratorPatternAttribute extends DecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = True, Inherited = True)
class TestTypeDecoratorPatternAttribute extends DecoratorPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestTypeDecoratorPatternAttribute

See Also

TestTypeDecoratorPatternAttribute Members
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


TestTypeDecoratorPatternAttribute Members

TestTypeDecoratorPatternAttribute Members
See Also Example Constructors Properties Methods
[image]

A test type decorator pattern attribute applies decorations to an existing test declared at the type-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestTypeDecoratorPatternAttribute.

Protected Constructors

 | Name | Description
Family method | TestTypeDecoratorPatternAttribute | Initializes a new instance of the TestTypeDecoratorPatternAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Applies decorations to a type-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestTypeDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


TestTypeDecoratorPatternAttribute Constructor

TestTypeDecoratorPatternAttribute Constructor
[image]

Initializes a new instance of the TestTypeDecoratorPatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestTypeDecoratorPatternAttribute()
C++
protected:
TestTypeDecoratorPatternAttribute() sealed
J#
protected TestTypeDecoratorPatternAttribute()
JScript
protected function TestTypeDecoratorPatternAttribute()

See Also

TestTypeDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestTypeDecoratorPatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Applies decorations to a type-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestTypeDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


DecorateTest Method

TestTypeDecoratorPatternAttribute.DecorateTest Method
[image]

Applies decorations to a type-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DecorateTest( _
ByVal typeScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected virtual void DecorateTest(
IPatternScope typeScope,
ITypeInfo type
)
C++
protected:
virtual void DecorateTest(
IPatternScope typeScope,
ITypeInfo type
)
J#
protected virtual void DecorateTest(
IPatternScope typeScope,
ITypeInfo type
)
JScript
protected virtual function DecorateTest(
typeScope : IPatternScope,
type : ITypeInfo
)

Parameters

typeScope
The type scope
type
The type

See Also

TestTypeDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Process Method

TestTypeDecoratorPatternAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

TestTypeDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestTypeDecoratorPatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ITypeInfo type
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ITypeInfo type
)
J#
protected virtual void Validate(
IPatternScope scope,
ITypeInfo type
)
JScript
protected virtual function Validate(
scope : IPatternScope,
type : ITypeInfo
)

Parameters

scope
The scope
type
The type

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestTypeDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


TestTypePatternAttribute Class

TestTypePatternAttribute Class
See Also Example Members
[image]

Declares that a type represents an test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := False, Inherited := True)>
Public Class TestTypePatternAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True)]
public class TestTypePatternAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = False, Inherited = True)]
ref class TestTypePatternAttribute : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True) */
public class TestTypePatternAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True)
class TestTypePatternAttribute extends PatternAttribute

Remarks

Subclasses of this attribute can control what happens with the type.

At most one attribute of this type may appear on any given class.

A test type has no timeout by default.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestTypePatternAttribute
MbUnit.Framework.AssemblyFixtureAttribute
MbUnit.Framework.TestFixtureAttribute

See Also

TestTypePatternAttribute Members
Gallio.Framework.Pattern Namespace
TestTypeDecoratorPatternAttribute


TestTypePatternAttribute Members

TestTypePatternAttribute Members
See Also Example Constructors Fields Properties Methods
[image]

Declares that a type represents an test.

The following tables list the members exposed by TestTypePatternAttribute.

Public Constructors

 | Name | Description
Public method | TestTypePatternAttribute | Initializes a new instance of the TestTypePatternAttribute class.
Top

Public Fields

Name | Description
AutomaticInstance | Gets an instance of the test type pattern attribute to use when no other pattern consumes the type. If the type can be inferred to be a test type then the pattern will behave as if the type has a test type pattern attribute applied to it. Otherwise it will simply recurse into nested types. This field is read-only.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultConstructorPattern | Gets the default pattern to apply to constructors that do not have a primary pattern, or null if none.
Family property | DefaultEventPattern | Gets the default pattern to apply to events that do not have a primary pattern, or null if none.
Family property | DefaultFieldPattern | Gets the default pattern to apply to fields that do not have a primary pattern, or null if none.
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none.
Family property | DefaultMethodPattern | Gets the default pattern to apply to methods that do not have a primary pattern, or null if none.
Family property | DefaultNestedTypePattern | Gets the default pattern to apply to nested types that do not have a primary pattern, or null if none.
Family property | DefaultPropertyPattern | Gets the default pattern to apply to properties that do not have a primary pattern, or null if none.
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConsumeConstructors | Consumes type constructors.
Family method | ConsumeMembers | Consumes type members including fields, properties, methods and events.
Family method | ConsumeNestedTypes | Consumes nested types.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMemberBindingFlags | Gets the binding flags that should be used to enumerate non-nested type members of the type for determining their contribution to the test fixture. Instance members are only included if the type is not abstract.
Family method | InferTestType | Infers whether the type is a test type based on its structure. Returns true if the type any associated patterns, if it has non-nested type members (subject to GetMemberBindingFlags) with patterns, if it has generic parameters with patterns, or if any of its nested types satisfy the preceding rules.
Family method | InitializeTest | Initializes a test for a type after it has been added to the test model. The members of base types are processed before those of subtypes.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypeDecoratorPatternAttribute


TestTypePatternAttribute Constructor

TestTypePatternAttribute Constructor
[image]

Initializes a new instance of the TestTypePatternAttribute class.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestTypePatternAttribute()
C++
public:
TestTypePatternAttribute() sealed
J#
public TestTypePatternAttribute()
JScript
public function TestTypePatternAttribute()

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


Fields

TestTypePatternAttribute Fields
[image]

Public Fields

Name | Description
AutomaticInstance | Gets an instance of the test type pattern attribute to use when no other pattern consumes the type. If the type can be inferred to be a test type then the pattern will behave as if the type has a test type pattern attribute applied to it. Otherwise it will simply recurse into nested types. This field is read-only.
Top

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypeDecoratorPatternAttribute


AutomaticInstance Field

TestTypePatternAttribute.AutomaticInstance Field
[image]

Gets an instance of the test type pattern attribute to use when no other pattern consumes the type. If the type can be inferred to be a test type then the pattern will behave as if the type has a test type pattern attribute applied to it. Otherwise it will simply recurse into nested types. This field is read-only.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly AutomaticInstance As TestTypePatternAttribute
C#
public static readonly TestTypePatternAttribute AutomaticInstance;
C++
public:
static const TestTypePatternAttribute AutomaticInstance;
J#
public static final TestTypePatternAttribute AutomaticInstance
JScript
public static const var AutomaticInstance : TestTypePatternAttribute;

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace
InferTestType


Properties

TestTypePatternAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultConstructorPattern | Gets the default pattern to apply to constructors that do not have a primary pattern, or null if none.
Family property | DefaultEventPattern | Gets the default pattern to apply to events that do not have a primary pattern, or null if none.
Family property | DefaultFieldPattern | Gets the default pattern to apply to fields that do not have a primary pattern, or null if none.
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none.
Family property | DefaultMethodPattern | Gets the default pattern to apply to methods that do not have a primary pattern, or null if none.
Family property | DefaultNestedTypePattern | Gets the default pattern to apply to nested types that do not have a primary pattern, or null if none.
Family property | DefaultPropertyPattern | Gets the default pattern to apply to properties that do not have a primary pattern, or null if none.
Top

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypeDecoratorPatternAttribute


DefaultConstructorPattern Property

TestTypePatternAttribute.DefaultConstructorPattern Property
[image]

Gets the default pattern to apply to constructors that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultConstructorPattern As IPattern
C#
protected virtual IPattern DefaultConstructorPattern { get; }
C++
protected virtual property IPattern DefaultConstructorPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultConstructorPattern();
JScript
protected function get DefaultConstructorPattern() : IPattern

Remarks

The default implementation returns DefaultInstance.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultEventPattern Property

TestTypePatternAttribute.DefaultEventPattern Property
[image]

Gets the default pattern to apply to events that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultEventPattern As IPattern
C#
protected virtual IPattern DefaultEventPattern { get; }
C++
protected virtual property IPattern DefaultEventPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultEventPattern();
JScript
protected function get DefaultEventPattern() : IPattern

Remarks

The default implementation returns null.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultFieldPattern Property

TestTypePatternAttribute.DefaultFieldPattern Property
[image]

Gets the default pattern to apply to fields that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultFieldPattern As IPattern
C#
protected virtual IPattern DefaultFieldPattern { get; }
C++
protected virtual property IPattern DefaultFieldPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultFieldPattern();
JScript
protected function get DefaultFieldPattern() : IPattern

Remarks

The default implementation returns AutomaticInstance.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultGenericParameterPattern Property

TestTypePatternAttribute.DefaultGenericParameterPattern Property
See Also Example
[image]

Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultGenericParameterPattern As IPattern
C#
protected virtual IPattern DefaultGenericParameterPattern { get; }
C++
protected virtual property IPattern DefaultGenericParameterPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultGenericParameterPattern();
JScript
protected function get DefaultGenericParameterPattern() : IPattern

Remarks

The default implementation returns DefaultInstance.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultMethodPattern Property

TestTypePatternAttribute.DefaultMethodPattern Property
[image]

Gets the default pattern to apply to methods that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMethodPattern As IPattern
C#
protected virtual IPattern DefaultMethodPattern { get; }
C++
protected virtual property IPattern DefaultMethodPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultMethodPattern();
JScript
protected function get DefaultMethodPattern() : IPattern

Remarks

The default implementation returns null.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultNestedTypePattern Property

TestTypePatternAttribute.DefaultNestedTypePattern Property
[image]

Gets the default pattern to apply to nested types that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultNestedTypePattern As IPattern
C#
protected virtual IPattern DefaultNestedTypePattern { get; }
C++
protected virtual property IPattern DefaultNestedTypePattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultNestedTypePattern();
JScript
protected function get DefaultNestedTypePattern() : IPattern

Remarks

The default implementation returns AutomaticInstance.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


DefaultPropertyPattern Property

TestTypePatternAttribute.DefaultPropertyPattern Property
[image]

Gets the default pattern to apply to properties that do not have a primary pattern, or null if none.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultPropertyPattern As IPattern
C#
protected virtual IPattern DefaultPropertyPattern { get; }
C++
protected virtual property IPattern DefaultPropertyPattern {
IPattern get();
}
J#
/** property */
protected IPattern get_DefaultPropertyPattern();
JScript
protected function get DefaultPropertyPattern() : IPattern

Remarks

The default implementation returns AutomaticInstance.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


IsPrimary Property

TestTypePatternAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


Order Property

TestTypePatternAttribute.Order Property
[image]

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Order As Integer
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public int Order { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property int Order sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public CompilerGeneratedAttribute function get Order() : int

public CompilerGeneratedAttribute function set Order(value : int);

Property Value

The test execution order with respect to siblings, initially zero.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


Methods

TestTypePatternAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConsumeConstructors | Consumes type constructors.
Family method | ConsumeMembers | Consumes type members including fields, properties, methods and events.
Family method | ConsumeNestedTypes | Consumes nested types.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMemberBindingFlags | Gets the binding flags that should be used to enumerate non-nested type members of the type for determining their contribution to the test fixture. Instance members are only included if the type is not abstract.
Family method | InferTestType | Infers whether the type is a test type based on its structure. Returns true if the type any associated patterns, if it has non-nested type members (subject to GetMemberBindingFlags) with patterns, if it has generic parameters with patterns, or if any of its nested types satisfy the preceding rules.
Family method | InitializeTest | Initializes a test for a type after it has been added to the test model. The members of base types are processed before those of subtypes.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypeDecoratorPatternAttribute


Consume Method

TestTypePatternAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


ConsumeConstructors Method

TestTypePatternAttribute.ConsumeConstructors Method
[image]

Consumes type constructors.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ConsumeConstructors( _
ByVal typeScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected void ConsumeConstructors(
IPatternScope typeScope,
ITypeInfo type
)
C++
protected:
void ConsumeConstructors(
IPatternScope typeScope,
ITypeInfo type
) sealed
J#
protected void ConsumeConstructors(
IPatternScope typeScope,
ITypeInfo type
)
JScript
protected function ConsumeConstructors(
typeScope : IPatternScope,
type : ITypeInfo
)

Parameters

typeScope
The scope to be used as the containing scope
type
The type whose constructors are to be consumed

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


ConsumeMembers Method

TestTypePatternAttribute.ConsumeMembers Method
[image]

Consumes type members including fields, properties, methods and events.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ConsumeMembers( _
ByVal typeScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected void ConsumeMembers(
IPatternScope typeScope,
ITypeInfo type
)
C++
protected:
void ConsumeMembers(
IPatternScope typeScope,
ITypeInfo type
) sealed
J#
protected void ConsumeMembers(
IPatternScope typeScope,
ITypeInfo type
)
JScript
protected function ConsumeMembers(
typeScope : IPatternScope,
type : ITypeInfo
)

Parameters

typeScope
The scope to be used as the containing scope
type
The type whose members are to be consumed

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


ConsumeNestedTypes Method

TestTypePatternAttribute.ConsumeNestedTypes Method
[image]

Consumes nested types.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ConsumeNestedTypes( _
ByVal typeScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected void ConsumeNestedTypes(
IPatternScope typeScope,
ITypeInfo type
)
C++
protected:
void ConsumeNestedTypes(
IPatternScope typeScope,
ITypeInfo type
) sealed
J#
protected void ConsumeNestedTypes(
IPatternScope typeScope,
ITypeInfo type
)
JScript
protected function ConsumeNestedTypes(
typeScope : IPatternScope,
type : ITypeInfo
)

Parameters

typeScope
The scope to be used as the containing scope
type
The type whose nested types are to be consumed

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


GetMemberBindingFlags Method

TestTypePatternAttribute.GetMemberBindingFlags Method
[image]

Gets the binding flags that should be used to enumerate non-nested type members of the type for determining their contribution to the test fixture. Instance members are only included if the type is not abstract.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetMemberBindingFlags( _
ByVal type As ITypeInfo _
) As BindingFlags
C#
protected virtual BindingFlags GetMemberBindingFlags(
ITypeInfo type
)
C++
protected:
virtual BindingFlags GetMemberBindingFlags(
ITypeInfo type
)
J#
protected virtual BindingFlags GetMemberBindingFlags(
ITypeInfo type
)
JScript
protected virtual function GetMemberBindingFlags(
type : ITypeInfo
) : BindingFlags

Parameters

type
The type

Return Value

The binding flags for enumerating members

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


InferTestType Method

TestTypePatternAttribute.InferTestType Method
[image]

Infers whether the type is a test type based on its structure. Returns true if the type any associated patterns, if it has non-nested type members (subject to GetMemberBindingFlags) with patterns, if it has generic parameters with patterns, or if any of its nested types satisfy the preceding rules.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function InferTestType( _
ByVal evaluator As IPatternEvaluator, _
ByVal type As ITypeInfo _
) As Boolean
C#
protected virtual bool InferTestType(
IPatternEvaluator evaluator,
ITypeInfo type
)
C++
protected:
virtual bool InferTestType(
IPatternEvaluator evaluator,
ITypeInfo type
)
J#
protected virtual bool InferTestType(
IPatternEvaluator evaluator,
ITypeInfo type
)
JScript
protected virtual function InferTestType(
evaluator : IPatternEvaluator,
type : ITypeInfo
) : bool

Parameters

evaluator
The pattern evaluator
type
The type

Return Value

True if the type is likely a test type

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


InitializeTest Method

TestTypePatternAttribute.InitializeTest Method
[image]

Initializes a test for a type after it has been added to the test model.

The members of base types are processed before those of subtypes.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeTest( _
ByVal typeScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected virtual void InitializeTest(
IPatternScope typeScope,
ITypeInfo type
)
C++
protected:
virtual void InitializeTest(
IPatternScope typeScope,
ITypeInfo type
)
J#
protected virtual void InitializeTest(
IPatternScope typeScope,
ITypeInfo type
)
JScript
protected virtual function InitializeTest(
typeScope : IPatternScope,
type : ITypeInfo
)

Parameters

typeScope
The type scope
type
The type

Remarks

The default implementation processes all public members of the type including the first constructor found, then recurses to process all public and non-public nested types. Non-public members other than nested types are ignored.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


IsTest Method

TestTypePatternAttribute.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTest
C#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTest

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


SetTestSemantics Method

TestTypePatternAttribute.SetTestSemantics Method
[image]

Applies semantic actions to a test to estalish its runtime behavior.

This method is called after InitializeTest.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTestSemantics( _
ByVal testBuilder As ITestBuilder, _
ByVal type As ITypeInfo _
)
C#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
ITypeInfo type
)
C++
protected:
virtual void SetTestSemantics(
ITestBuilder testBuilder,
ITypeInfo type
)
J#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
ITypeInfo type
)
JScript
protected virtual function SetTestSemantics(
testBuilder : ITestBuilder,
type : ITypeInfo
)

Parameters

testBuilder
The test builder
type
The test type

Remarks

The default behavior for a TestTypePatternAttribute is to configure the test actions as follows:

  • BeforeTestInstance: Set the fixture instance name and FixtureType.
  • InitializeTestInstance: Create the fixture instance and set the FixtureInstance property accordingly.
  • DisposeTestInstance: If the fixture type implements IDisposable, disposes the fixture instance.
  • DecorateChildTest: Decorates the child's BeforeTestInstance to set its FixtureInstance and FixtureType properties to those of the fixture. The child test may override these values later on but this is a reasonable default setting for test methods within a fixture.

You can override this method to change the semantics as required.

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


Validate Method

TestTypePatternAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
ITypeInfo type
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
ITypeInfo type
)
J#
protected virtual void Validate(
IPatternScope containingScope,
ITypeInfo type
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
type : ITypeInfo
)

Parameters

containingScope
The containing scope
type
The type

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

TestTypePatternAttribute Class
Gallio.Framework.Pattern Namespace


ToolInfo Class

ToolInfo Class
See Also Example Members
[image]

Provides information about a tool that extends the PatternTestFramework. This class cannot be inherited.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ToolInfo
C#
public sealed class ToolInfo
C++
ref class ToolInfo sealed
J#
public final class ToolInfo
JScript
public final class ToolInfo

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.ToolInfo

See Also

ToolInfo Members
Gallio.Framework.Pattern Namespace
IPatternTestFrameworkExtension


ToolInfo Members

ToolInfo Members
See Also Example Constructors Properties Methods
[image]

Provides information about a tool that extends the PatternTestFramework. This class cannot be inherited.

The following tables list the members exposed by ToolInfo.

Public Constructors

 | Name | Description
Public method | ToolInfo | Creates a tool information object.
Top

Public Properties

 | Name | Description
Public property | Id | Gets the unique id of the tool.
Public property | Name | Gets the display name of the tool.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ToolInfo Class
Gallio.Framework.Pattern Namespace
IPatternTestFrameworkExtension


ToolInfo Constructor

ToolInfo Constructor
[image]

Creates a tool information object.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
C#
public ToolInfo(
string id,
string name
)
C++
public:
ToolInfo(
String id,
String name
) sealed
J#
public ToolInfo(
string id,
string name
)
JScript
public function ToolInfo(
id : String,
name : String
)

Parameters

id
The unique id of the tool
name
The display name of the tool

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if id or name is null

See Also

ToolInfo Class
Gallio.Framework.Pattern Namespace


Properties

ToolInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Id | Gets the unique id of the tool.
Public property | Name | Gets the display name of the tool.
Top

See Also

ToolInfo Class
Gallio.Framework.Pattern Namespace
IPatternTestFrameworkExtension


Id Property

ToolInfo.Id Property
[image]

Gets the unique id of the tool.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As String
C#
public string Id { get; }
C++
public property string Id sealed {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

See Also

ToolInfo Class
Gallio.Framework.Pattern Namespace


Name Property

ToolInfo.Name Property
[image]

Gets the display name of the tool.

Namespace: Gallio.Framework.Pattern
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

ToolInfo Class
Gallio.Framework.Pattern Namespace


Gallio.Framework.Text

Gallio.Framework.Text Namespace
See Also Example Hierarchy

Classes

Class Description
Public class DiffSet

A diff set consists of a sequence of differences between a left document and a right document that indicate changed and unchanged regions.

If the changes are applied in order to the left document, the right document will be reproduced. If the inverse changes are applied in order to the right document, the left document will be reproduced.

This class cannot be inherited.

Structures

 | Structure | Description
Public structure | Diff | Describes the difference between a range of the left document and a range of the right document. Each diff is accompanied by a DiffKind that indicates whether it represents an identical region or one with changes.
Public structure | Range | A range denotes a segment of a string or other indexed data structure.
Public structure | Substring | A substring provides a convenient representation for a range within a larger string.

Enumerations

 | Enumeration | Description
Public enumeration | DiffKind | Describes whether a difference represents a changed or unchanged region.
Public enumeration | DiffStyle | Specifies the presentation style for a DiffSet.


Diff Structure

Diff Structure
See Also Example Members
[image]

Describes the difference between a range of the left document and a range of the right document. Each diff is accompanied by a DiffKind that indicates whether it represents an identical region or one with changes.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Structure Diff
Implements IEquatable(Of Diff)
C#
[SerializableAttribute]
public struct Diff : IEquatable<Diff>
C++
[SerializableAttribute]
value class Diff : IEquatable<Diff>
J#
/** @attribute SerializableAttribute() */
public final class Diff extends ValueType implements IEquatable<Diff>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Framework.Text.Diff

See Also

Diff Members
Gallio.Framework.Text Namespace


Diff Members

Diff Members
See Also Example Constructors Properties Methods
[image]

Describes the difference between a range of the left document and a range of the right document. Each diff is accompanied by a DiffKind that indicates whether it represents an identical region or one with changes.

The following tables list the members exposed by Diff.

Public Constructors

 | Name | Description
Public method | Diff | Create a diff.
Top

Public Properties

 | Name | Description
Public property | Kind | Gets the diff kind which indicateds whether there is a change over the range covered by the diff.
Public property | LeftRange | Gets the range of the left document that is affected.
Public property | RightRange | Gets the range of the right document that is affected.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Diff Structure
Gallio.Framework.Text Namespace


Diff Constructor

Diff Constructor
[image]

Create a diff.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal kind As DiffKind, _
ByVal leftRange As Range, _
ByVal rightRange As Range _
)
C#
public Diff(
DiffKind kind,
Range leftRange,
Range rightRange
)
C++
public:
Diff(
DiffKind kind,
Range leftRange,
Range rightRange
) sealed
J#
public Diff(
DiffKind kind,
Range leftRange,
Range rightRange
)
JScript
public function Diff(
kind : DiffKind,
leftRange : Range,
rightRange : Range
)

Parameters

kind
The diff kind which indicates whether there is a change over the range covered by the diff
leftRange
The range of the left document that is affected
rightRange
The range of the right document that is affected

See Also

Diff Structure
Gallio.Framework.Text Namespace


Properties

Diff Properties
[image]

Public Properties

 | Name | Description
Public property | Kind | Gets the diff kind which indicateds whether there is a change over the range covered by the diff.
Public property | LeftRange | Gets the range of the left document that is affected.
Public property | RightRange | Gets the range of the right document that is affected.
Top

See Also

Diff Structure
Gallio.Framework.Text Namespace


Kind Property

Diff.Kind Property
[image]

Gets the diff kind which indicateds whether there is a change over the range covered by the diff.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Kind As DiffKind
C#
public DiffKind Kind { get; }
C++
public property DiffKind Kind sealed {
DiffKind get();
}
J#
/** property */
public DiffKind get_Kind();
JScript
public function get Kind() : DiffKind

See Also

Diff Structure
Gallio.Framework.Text Namespace


LeftRange Property

Diff.LeftRange Property
[image]

Gets the range of the left document that is affected.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeftRange As Range
C#
public Range LeftRange { get; }
C++
public property Range LeftRange sealed {
Range get();
}
J#
/** property */
public Range get_LeftRange();
JScript
public function get LeftRange() : Range

See Also

Diff Structure
Gallio.Framework.Text Namespace


RightRange Property

Diff.RightRange Property
[image]

Gets the range of the right document that is affected.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RightRange As Range
C#
public Range RightRange { get; }
C++
public property Range RightRange sealed {
Range get();
}
J#
/** property */
public Range get_RightRange();
JScript
public function get RightRange() : Range

See Also

Diff Structure
Gallio.Framework.Text Namespace


Methods

Diff Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Diff Structure
Gallio.Framework.Text Namespace


Equals Method

Diff.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (Diff) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

Diff Structure
Gallio.Framework.Text Namespace


Equals Method (Diff)

Diff.Equals Method (Diff)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As Diff _
) As Boolean _
Implements IEquatable<Diff>.Equals
C#
public bool Equals(
Diff other
)
C++
public:
bool Equals(
Diff other
) sealed
J#
public bool Equals(
Diff other
)
JScript
public function Equals(
other : Diff
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<Diff>.Equals

See Also

Diff Structure
Gallio.Framework.Text Namespace
Diff.Equals Overload List


Equals Method (Object)

Diff.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Diff Structure
Gallio.Framework.Text Namespace
Diff.Equals Overload List


GetHashCode Method

Diff.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Diff Structure
Gallio.Framework.Text Namespace


op_Equality Operator

Diff.op_Equality Operator
[image]

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As Diff, _
ByVal b As Diff _
) As Boolean
C#
public static bool operator ==(
Diff a,
Diff b
)
C++
public:
static bool operator ==(
Diff a,
Diff b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Diff Structure
Gallio.Framework.Text Namespace


op_Inequality Operator

Diff.op_Inequality Operator
[image]

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As Diff, _
ByVal b As Diff _
) As Boolean
C#
public static bool operator !=(
Diff a,
Diff b
)
C++
public:
static bool operator !=(
Diff a,
Diff b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Diff Structure
Gallio.Framework.Text Namespace


ToString Method

Diff.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

Diff Structure
Gallio.Framework.Text Namespace


DiffKind Enumeration

DiffKind Enumeration
[image]

Describes whether a difference represents a changed or unchanged region.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum DiffKind
C#
public enum DiffKind
C++
public enum class DiffKind
J#
public enum DiffKind
JScript
public enum DiffKind

Members

Member Name | Description
NoChange | Indicates there is no change between the left and right documents over the ranges described by the diff.
Change | Indicates there is a change between the left and right documents over the ranges described by the diff. Text may have been added, removed, or edited.

See Also

Gallio.Framework.Text Namespace


DiffSet Class

DiffSet Class
See Also Example Members
[image]

A diff set consists of a sequence of differences between a left document and a right document that indicate changed and unchanged regions.

If the changes are applied in order to the left document, the right document will be reproduced. If the inverse changes are applied in order to the right document, the left document will be reproduced.

This class cannot be inherited.
Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class DiffSet
Implements ITestLogStreamWritable
C#
[SerializableAttribute]
public sealed class DiffSet : ITestLogStreamWritable
C++
[SerializableAttribute]
ref class DiffSet sealed : ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
public final class DiffSet implements ITestLogStreamWritable
JScript
public
SerializableAttribute
final class DiffSet extends ITestLogStreamWritable

Remarks

This implementation is based on Myers' O((M + N) * D) time and O(M + N) space algorithm for computing the longest common subsequence from his paper "An O(ND) Difference Algorithm and Its Variations." (http://citeseer.ist.psu.edu/myers86ond.html)

There were two other sources for inspiration although this implementation is not a direct port of either of them.

  • The org.eclipse.compare.internal.LCS class in Eclipse (http://www.eclipse.org) from which we borrow the concept of limiting the number of differences to produce an approximate result with a reduced time bound for large data sets. Since the Eclipse implementation of the LCS follows Myers' algorithm pretty closely, it was also very useful as a point of comparison for finding bugs.
  • Neil Fraser's "Diff Match and Patch" algorithm (http://code.google.com/p/google-diff-match-patch/). We borrow some ideas about semantic cleanup from here.

Inheritance Hierarchy

System.Object
Gallio.Framework.Text.DiffSet

See Also

DiffSet Members
Gallio.Framework.Text Namespace


DiffSet Members

DiffSet Members
See Also Example Constructors Properties Methods
[image]

A diff set consists of a sequence of differences between a left document and a right document that indicate changed and unchanged regions.

If the changes are applied in order to the left document, the right document will be reproduced. If the inverse changes are applied in order to the right document, the left document will be reproduced.

This class cannot be inherited.

The following tables list the members exposed by DiffSet.

Public Constructors

 | Name | Description
Public method | DiffSet | Constructs a diff set.
Top

Public Properties

 | Name | Description
Public property | ContainsChanges | Returns true if the list of differences contains changed regions.
Public property | Diffs | Gets the list of differences that indicate the changed and unchanged regions between the left and right documents. The diffs span the entire range of the left and right documents and are listed in document order.
Public property | IsEmpty | Returns true if the list of differences is empty which can only occur when both document being compared are empty.
Public property | LeftDocument | Gets the left document.
Public property | RightDocument | Gets the right document.
Top

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
GetDiffSet | Gets the set of differences between a left document and a right document.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method Simplify

Simplifies the diff for presentation.

This method applies a series of heuristics to make the diff easier to read but perhaps less optimal, including the following:

  • Adjacent diffs of the same kind are combined.
  • Small unchanged regions sandwiched between larger changed regions are converted to larger changed regions. This improves the case when only a few scattered characters coincidentally match between the two documents.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method WriteTo Overloaded.

Writes the diffs using the Interleaved presentation style and no limits on the context length.

For the purposes of determining additions and deletions, the left document is considered the original and the right document is the considered to be the one that was modified. Changes are annotated by markers: by DiffAddition, DiffDeletion and DiffChange.

Top

See Also

DiffSet Class
Gallio.Framework.Text Namespace


DiffSet Constructor

DiffSet Constructor
[image]

Constructs a diff set.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal diffs As IList(Of Diff), _
ByVal leftDocument As String, _
ByVal rightDocument As String _
)
C#
public DiffSet(
IList<Diff> diffs,
string leftDocument,
string rightDocument
)
C++
public:
DiffSet(
IList<Diff> diffs,
String leftDocument,
String rightDocument
) sealed
J#
public DiffSet(
IList<Diff> diffs,
string leftDocument,
string rightDocument
)
JScript
public function DiffSet(
diffs : IList<Diff>,
leftDocument : String,
rightDocument : String
)

Parameters

diffs
The list of differences that indicate the changed and unchanged regions between the left and right documents. The diffs span the entire range of the left and right documents and are listed in document order.
leftDocument
The left document
rightDocument
The right document

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if leftDocument, rightDocument or diffs is null
ArgumentException | Thrown if diffs does not completely cover the left and right documents or are not listed in the correct order

See Also

DiffSet Class
Gallio.Framework.Text Namespace


Properties

DiffSet Properties
[image]

Public Properties

 | Name | Description
Public property | ContainsChanges | Returns true if the list of differences contains changed regions.
Public property | Diffs | Gets the list of differences that indicate the changed and unchanged regions between the left and right documents. The diffs span the entire range of the left and right documents and are listed in document order.
Public property | IsEmpty | Returns true if the list of differences is empty which can only occur when both document being compared are empty.
Public property | LeftDocument | Gets the left document.
Public property | RightDocument | Gets the right document.
Top

See Also

DiffSet Class
Gallio.Framework.Text Namespace


ContainsChanges Property

DiffSet.ContainsChanges Property
[image]

Returns true if the list of differences contains changed regions.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsChanges As Boolean
C#
public bool ContainsChanges { get; }
C++
public property bool ContainsChanges sealed {
bool get();
}
J#
/** property */
public bool get_ContainsChanges();
JScript
public function get ContainsChanges() : bool

See Also

DiffSet Class
Gallio.Framework.Text Namespace


Diffs Property

DiffSet.Diffs Property
[image]

Gets the list of differences that indicate the changed and unchanged regions between the left and right documents. The diffs span the entire range of the left and right documents and are listed in document order.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Diffs As IList(Of Diff)
C#
public IList<Diff> Diffs { get; }
C++
public property IList<Diff> Diffs sealed {
IList<Diff> get();
}
J#
/** property */
public IList<Diff> get_Diffs();
JScript
public function get Diffs() : IList<Diff>

See Also

DiffSet Class
Gallio.Framework.Text Namespace


IsEmpty Property

DiffSet.IsEmpty Property
[image]

Returns true if the list of differences is empty which can only occur when both document being compared are empty.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty { get; }
C++
public property bool IsEmpty sealed {
bool get();
}
J#
/** property */
public bool get_IsEmpty();
JScript
public function get IsEmpty() : bool

See Also

DiffSet Class
Gallio.Framework.Text Namespace


LeftDocument Property

DiffSet.LeftDocument Property
[image]

Gets the left document.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeftDocument As String
C#
public string LeftDocument { get; }
C++
public property string LeftDocument sealed {
String get();
}
J#
/** property */
public string get_LeftDocument();
JScript
public function get LeftDocument() : String

See Also

DiffSet Class
Gallio.Framework.Text Namespace


RightDocument Property

DiffSet.RightDocument Property
[image]

Gets the right document.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RightDocument As String
C#
public string RightDocument { get; }
C++
public property string RightDocument sealed {
String get();
}
J#
/** property */
public string get_RightDocument();
JScript
public function get RightDocument() : String

See Also

DiffSet Class
Gallio.Framework.Text Namespace


Methods

DiffSet Methods
[image]

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
GetDiffSet | Gets the set of differences between a left document and a right document.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method Simplify

Simplifies the diff for presentation.

This method applies a series of heuristics to make the diff easier to read but perhaps less optimal, including the following:

  • Adjacent diffs of the same kind are combined.
  • Small unchanged regions sandwiched between larger changed regions are converted to larger changed regions. This improves the case when only a few scattered characters coincidentally match between the two documents.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method WriteTo Overloaded.

Writes the diffs using the Interleaved presentation style and no limits on the context length.

For the purposes of determining additions and deletions, the left document is considered the original and the right document is the considered to be the one that was modified. Changes are annotated by markers: by DiffAddition, DiffDeletion and DiffChange.

Top

See Also

DiffSet Class
Gallio.Framework.Text Namespace


GetDiffSet Method

DiffSet.GetDiffSet Method
[image]

Gets the set of differences between a left document and a right document.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDiffSet( _
ByVal leftDocument As String, _
ByVal rightDocument As String _
) As DiffSet
C#
public static DiffSet GetDiffSet(
string leftDocument,
string rightDocument
)
C++
public:
static DiffSet GetDiffSet(
String leftDocument,
String rightDocument
)
J#
public static DiffSet GetDiffSet(
string leftDocument,
string rightDocument
)
JScript
public static function GetDiffSet(
leftDocument : String,
rightDocument : String
) : DiffSet

Parameters

leftDocument
The left document
rightDocument
The right document

Return Value

The set of differences

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if leftDocument or rightDocument is null

See Also

DiffSet Class
Gallio.Framework.Text Namespace


Simplify Method

DiffSet.Simplify Method
[image]

Simplifies the diff for presentation.

This method applies a series of heuristics to make the diff easier to read but perhaps less optimal, including the following:

  • Adjacent diffs of the same kind are combined.
  • Small unchanged regions sandwiched between larger changed regions are converted to larger changed regions. This improves the case when only a few scattered characters coincidentally match between the two documents.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Simplify() As DiffSet
C#
public DiffSet Simplify()
C++
public:
DiffSet Simplify() sealed
J#
public DiffSet Simplify()
JScript
public function Simplify() : DiffSet

Return Value

Returns a simplified diff

See Also

DiffSet Class
Gallio.Framework.Text Namespace


WriteTo Method

DiffSet.WriteTo Method

Writes the diffs using the Interleaved presentation style and no limits on the context length.

For the purposes of determining additions and deletions, the left document is considered the original and the right document is the considered to be the one that was modified. Changes are annotated by markers: by DiffAddition, DiffDeletion and DiffChange.

Overload List

 | Name | Description
Public method | WriteTo (TestLogStreamWriter) | Writes the diffs using the Interleaved presentation style and no limits on the context length. For the purposes of determining additions and deletions, the left document is considered the original and the right document is the considered to be the one that was modified. Changes are annotated by markers: by DiffAddition, DiffDeletion and DiffChange.
Public method | WriteTo (TestLogStreamWriter, DiffStyle) | Writes the diffs using the specified presentation style and no limits on the context length. Changes are annotated by markers: DiffAddition, DiffDeletion and DiffChange. If the style is Interleaved then the left document is considered the original and the right document is the considered to be the one that was modified so deletions appear within the left and additions within the right. If the style is LeftOnly or RightOnly then only the deletion and changed markers are used.
Public method | WriteTo (TestLogStreamWriter, DiffStyle, Int32) | Writes the diffs using the specified presentation style and max context length. Changes are annotated by markers: DiffAddition, DiffDeletion and DiffChange. If the style is Interleaved then the left document is considered the original and the right document is the considered to be the one that was modified so deletions appear within the left and additions within the right. If the style is LeftOnly or RightOnly then only the deletion and changed markers are used.

See Also

DiffSet Class
Gallio.Framework.Text Namespace


WriteTo Method (TestLogStreamWriter)

DiffSet.WriteTo Method (TestLogStreamWriter)
See Also Example
[image]

Writes the diffs using the Interleaved presentation style and no limits on the context length.

For the purposes of determining additions and deletions, the left document is considered the original and the right document is the considered to be the one that was modified. Changes are annotated by markers: by DiffAddition, DiffDeletion and DiffChange.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The test log stream writer to receive the highlighted document

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if if null

See Also

DiffSet Class
Gallio.Framework.Text Namespace
DiffSet.WriteTo Overload List


WriteTo Method (TestLogStreamWriter, DiffStyle)

DiffSet.WriteTo Method (TestLogStreamWriter, DiffStyle)
See Also Example
[image]

Writes the diffs using the specified presentation style and no limits on the context length.

Changes are annotated by markers: DiffAddition, DiffDeletion and DiffChange.

If the style is Interleaved then the left document is considered the original and the right document is the considered to be the one that was modified so deletions appear within the left and additions within the right.

If the style is LeftOnly or RightOnly then only the deletion and changed markers are used.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter, _
ByVal style As DiffStyle _
)
C#
public void WriteTo(
TestLogStreamWriter writer,
DiffStyle style
)
C++
public:
void WriteTo(
TestLogStreamWriter writer,
DiffStyle style
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer,
DiffStyle style
)
JScript
public function WriteTo(
writer : TestLogStreamWriter,
style : DiffStyle
)

Parameters

writer
The test log stream writer to receive the highlighted document
style
The presentation style

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if if null

See Also

DiffSet Class
Gallio.Framework.Text Namespace
DiffSet.WriteTo Overload List


WriteTo Method (TestLogStreamWriter, DiffStyle, Int32)

DiffSet.WriteTo Method (TestLogStreamWriter, DiffStyle, Int32)
See Also Example
[image]

Writes the diffs using the specified presentation style and max context length.

Changes are annotated by markers: DiffAddition, DiffDeletion and DiffChange.

If the style is Interleaved then the left document is considered the original and the right document is the considered to be the one that was modified so deletions appear within the left and additions within the right.

If the style is LeftOnly or RightOnly then only the deletion and changed markers are used.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter, _
ByVal style As DiffStyle, _
ByVal maxContextLength As Integer _
)
C#
public void WriteTo(
TestLogStreamWriter writer,
DiffStyle style,
int maxContextLength
)
C++
public:
void WriteTo(
TestLogStreamWriter writer,
DiffStyle style,
int maxContextLength
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer,
DiffStyle style,
int maxContextLength
)
JScript
public function WriteTo(
writer : TestLogStreamWriter,
style : DiffStyle,
maxContextLength : int
)

Parameters

writer
The test log stream writer to receive the highlighted document
style
The presentation style
maxContextLength
The maximum number of characters of unchanged regions to display for context, or MaxValue for no limit. Extraneous context is split in two with an ellipsis inserted in between both halves

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if if null
ArgumentOutOfRangeException | Thrown if maxContextLength is negative

See Also

DiffSet Class
Gallio.Framework.Text Namespace
DiffSet.WriteTo Overload List


DiffStyle Enumeration

DiffStyle Enumeration
[image]

Specifies the presentation style for a DiffSet.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum DiffStyle
C#
public enum DiffStyle
C++
public enum class DiffStyle
J#
public enum DiffStyle
JScript
public enum DiffStyle

Members

Member Name | Description
Interleaved | Display the left and right document contents and diffs fully interleaved.
LeftOnly | Display only the left document contents.
RightOnly | Display only the right document contents.

See Also

Gallio.Framework.Text Namespace


Range Structure

Range Structure
See Also Example Members
[image]

A range denotes a segment of a string or other indexed data structure.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Structure Range
Implements IEquatable(Of Range)
C#
[SerializableAttribute]
public struct Range : IEquatable<Range>
C++
[SerializableAttribute]
value class Range : IEquatable<Range>
J#
/** @attribute SerializableAttribute() */
public final class Range extends ValueType implements IEquatable<Range>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Framework.Text.Range

See Also

Range Members
Gallio.Framework.Text Namespace


Range Members

Range Members
See Also Example Constructors Properties Methods
[image]

A range denotes a segment of a string or other indexed data structure.

The following tables list the members exposed by Range.

Public Constructors

 | Name | Description
Public method | Range | Creates a range of indices.
Top

Public Properties

 | Name | Description
Public property | EndIndex | Gets the ending index of the range, which is the start index plus the length. The ending index is one past the last character within the range.
Public property | Length | Gets the length of the range.
Public property | StartIndex | Gets the starting index of the range.
Top

Public Methods

 | Name | Description
 | Between | Creates a new range between the start index (inclusively) and end index (exclusively).
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | ExtendWith | Extends a range into an adjacent range and returns the combined range.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | SubstringOf | Gets a substring of the specified text using this range.
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Range Structure
Gallio.Framework.Text Namespace


Range Constructor

Range Constructor
[image]

Creates a range of indices.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal startIndex As Integer, _
ByVal length As Integer _
)
C#
public Range(
int startIndex,
int length
)
C++
public:
Range(
int startIndex,
int length
) sealed
J#
public Range(
int startIndex,
int length
)
JScript
public function Range(
startIndex : int,
length : int
)

Parameters

startIndex
The starting index of the range
length
The number of characters within the range, may be 0

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if startIndex or length is negative

See Also

Range Structure
Gallio.Framework.Text Namespace


Properties

Range Properties
[image]

Public Properties

 | Name | Description
Public property | EndIndex | Gets the ending index of the range, which is the start index plus the length. The ending index is one past the last character within the range.
Public property | Length | Gets the length of the range.
Public property | StartIndex | Gets the starting index of the range.
Top

See Also

Range Structure
Gallio.Framework.Text Namespace


EndIndex Property

Range.EndIndex Property
[image]

Gets the ending index of the range, which is the start index plus the length. The ending index is one past the last character within the range.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EndIndex As Integer
C#
public int EndIndex { get; }
C++
public property int EndIndex sealed {
int get();
}
J#
/** property */
public int get_EndIndex();
JScript
public function get EndIndex() : int

See Also

Range Structure
Gallio.Framework.Text Namespace


Length Property

Range.Length Property
[image]

Gets the length of the range.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
C++
public property int Length sealed {
int get();
}
J#
/** property */
public int get_Length();
JScript
public function get Length() : int

See Also

Range Structure
Gallio.Framework.Text Namespace


StartIndex Property

Range.StartIndex Property
[image]

Gets the starting index of the range.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartIndex As Integer
C#
public int StartIndex { get; }
C++
public property int StartIndex sealed {
int get();
}
J#
/** property */
public int get_StartIndex();
JScript
public function get StartIndex() : int

See Also

Range Structure
Gallio.Framework.Text Namespace


Methods

Range Methods
[image]

Public Methods

 | Name | Description
 | Between | Creates a new range between the start index (inclusively) and end index (exclusively).
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | ExtendWith | Extends a range into an adjacent range and returns the combined range.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | SubstringOf | Gets a substring of the specified text using this range.
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Range Structure
Gallio.Framework.Text Namespace


Between Method

Range.Between Method
[image]

Creates a new range between the start index (inclusively) and end index (exclusively).

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Between( _
ByVal startIndex As Integer, _
ByVal endIndex As Integer _
) As Range
C#
public static Range Between(
int startIndex,
int endIndex
)
C++
public:
static Range Between(
int startIndex,
int endIndex
)
J#
public static Range Between(
int startIndex,
int endIndex
)
JScript
public static function Between(
startIndex : int,
endIndex : int
) : Range

Parameters

startIndex
The start index
endIndex
The end index

Return Value

The new range

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if startIndex is negative or greater than endIndex

See Also

Range Structure
Gallio.Framework.Text Namespace


Equals Method

Range.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (Range) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

Range Structure
Gallio.Framework.Text Namespace


Equals Method (Range)

Range.Equals Method (Range)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As Range _
) As Boolean _
Implements IEquatable<Range>.Equals
C#
public bool Equals(
Range other
)
C++
public:
bool Equals(
Range other
) sealed
J#
public bool Equals(
Range other
)
JScript
public function Equals(
other : Range
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<Range>.Equals

See Also

Range Structure
Gallio.Framework.Text Namespace
Range.Equals Overload List


Equals Method (Object)

Range.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Range Structure
Gallio.Framework.Text Namespace
Range.Equals Overload List


ExtendWith Method

Range.ExtendWith Method
[image]

Extends a range into an adjacent range and returns the combined range.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ExtendWith( _
ByVal range As Range _
) As Range
C#
public Range ExtendWith(
Range range
)
C++
public:
Range ExtendWith(
Range range
) sealed
J#
public Range ExtendWith(
Range range
)
JScript
public function ExtendWith(
range : Range
) : Range

Parameters

range
The adjacent range

Return Value

The extended range

Exceptions

Exception Type | Condition
ArgumentException | Thrown if range is not an adjacent range

See Also

Range Structure
Gallio.Framework.Text Namespace


GetHashCode Method

Range.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Range Structure
Gallio.Framework.Text Namespace


op_Equality Operator

Range.op_Equality Operator
[image]

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As Range, _
ByVal b As Range _
) As Boolean
C#
public static bool operator ==(
Range a,
Range b
)
C++
public:
static bool operator ==(
Range a,
Range b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Range Structure
Gallio.Framework.Text Namespace


op_Inequality Operator

Range.op_Inequality Operator
[image]

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As Range, _
ByVal b As Range _
) As Boolean
C#
public static bool operator !=(
Range a,
Range b
)
C++
public:
static bool operator !=(
Range a,
Range b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Range Structure
Gallio.Framework.Text Namespace


SubstringOf Method

Range.SubstringOf Method
[image]

Gets a substring of the specified text using this range.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SubstringOf( _
ByVal text As String _
) As String
C#
public string SubstringOf(
string text
)
C++
public:
String SubstringOf(
String text
) sealed
J#
public string SubstringOf(
string text
)
JScript
public function SubstringOf(
text : String
) : String

Parameters

text
The source text

Return Value

The substring of the source text that represents this range

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null

See Also

Range Structure
Gallio.Framework.Text Namespace


ToString Method

Range.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

Range Structure
Gallio.Framework.Text Namespace


Substring Structure

Substring Structure
See Also Example Members
[image]

A substring provides a convenient representation for a range within a larger string.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Structure Substring
Implements IEquatable(Of Substring)
C#
[DefaultMemberAttribute("Item")]
public struct Substring : IEquatable<Substring>
C++
[DefaultMemberAttribute(L"Item")]
value class Substring : IEquatable<Substring>
J#
/** @attribute DefaultMemberAttribute("Item") */
public final class Substring extends ValueType implements IEquatable<Substring>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Framework.Text.Substring

See Also

Substring Members
Gallio.Framework.Text Namespace


Substring Members

Substring Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A substring provides a convenient representation for a range within a larger string.

The following tables list the members exposed by Substring.

Public Constructors

Name | Description
Substring | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Content | Returns the whole string.
Public property | Item | Gets the character with a particular index.
Public property | Length | Gets the length of the substring.
Public property | Range | Returns the range of the underlying string represented by the substring.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | Extract | Overloaded. Returns a substring of the substring.
Public method | FindCommonPrefixLength | Finds the length of the common prefix of this substring and another one.
Public method | FindCommonSuffixLength | Finds the length of the common suffix of this substring and another one.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

Explicit Interface Implementations

Name | Description
Substring | Overloaded.
Top

See Also

Substring Structure
Gallio.Framework.Text Namespace


Substring Constructor

Substring Constructor

Overload List

 | Name | Description
Public method | Substring (String) | Creates a substring object defined over the entire range of a string.
Public method | Substring (String, Range) | Creates a substring object.

See Also

Substring Structure
Gallio.Framework.Text Namespace


Substring Constructor (String)

Substring Constructor (String)
See Also Example
[image]

Creates a substring object defined over the entire range of a string.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal content As String _
)
C#
public Substring(
string content
)
C++
public:
Substring(
String content
) sealed
J#
public Substring(
string content
)
JScript
public function Substring(
content : String
)

Parameters

content
The string

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if content is null

See Also

Substring Structure
Gallio.Framework.Text Namespace
Substring Constructor Overload List


Substring Constructor (String, Range)

Substring Constructor (String, Range)
See Also Example
[image]

Creates a substring object.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal content As String, _
ByVal range As Range _
)
C#
public Substring(
string content,
Range range
)
C++
public:
Substring(
String content,
Range range
) sealed
J#
public Substring(
string content,
Range range
)
JScript
public function Substring(
content : String,
range : Range
)

Parameters

content
The string
range
The range within the string

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if content is null
ArgumentException | Thrown if range is outside the bounds of the content string

See Also

Substring Structure
Gallio.Framework.Text Namespace
Substring Constructor Overload List


Properties

Substring Properties
[image]

Public Properties

 | Name | Description
Public property | Content | Returns the whole string.
Public property | Item | Gets the character with a particular index.
Public property | Length | Gets the length of the substring.
Public property | Range | Returns the range of the underlying string represented by the substring.
Top

See Also

Substring Structure
Gallio.Framework.Text Namespace


Content Property

Substring.Content Property
[image]

Returns the whole string.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Content As String
C#
public string Content { get; }
C++
public property string Content sealed {
String get();
}
J#
/** property */
public string get_Content();
JScript
public function get Content() : String

See Also

Substring Structure
Gallio.Framework.Text Namespace


Item Property

Substring.Item Property
[image]

Gets the character with a particular index.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Char
C#
public char this[
int index
] { get; }
C++
public property char default[int index] sealed {
wchar_t get(int index);
}
J#
/** property */
public char get_Item(int index);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

Parameters

index
The index

Property Value

The character

Exceptions

Exception Type | Condition
IndexOutOfRangeException | Thrown if the index is out of range

See Also

Substring Structure
Gallio.Framework.Text Namespace


Length Property

Substring.Length Property
[image]

Gets the length of the substring.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
C++
public property int Length sealed {
int get();
}
J#
/** property */
public int get_Length();
JScript
public function get Length() : int

See Also

Substring Structure
Gallio.Framework.Text Namespace


Range Property

Substring.Range Property
[image]

Returns the range of the underlying string represented by the substring.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Range As Range
C#
public Range Range { get; }
C++
public property Range Range sealed {
Range get();
}
J#
/** property */
public Range get_Range();
JScript
public function get Range() : Range

See Also

Substring Structure
Gallio.Framework.Text Namespace


Methods

Substring Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | Extract | Overloaded. Returns a substring of the substring.
Public method | FindCommonPrefixLength | Finds the length of the common prefix of this substring and another one.
Public method | FindCommonSuffixLength | Finds the length of the common suffix of this substring and another one.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Substring Structure
Gallio.Framework.Text Namespace


Equals Method

Substring.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (Substring) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

Substring Structure
Gallio.Framework.Text Namespace


Equals Method (Substring)

Substring.Equals Method (Substring)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As Substring _
) As Boolean _
Implements IEquatable<Substring>.Equals
C#
public bool Equals(
Substring other
)
C++
public:
bool Equals(
Substring other
) sealed
J#
public bool Equals(
Substring other
)
JScript
public function Equals(
other : Substring
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<Substring>.Equals

See Also

Substring Structure
Gallio.Framework.Text Namespace
Substring.Equals Overload List


Equals Method (Object)

Substring.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Substring Structure
Gallio.Framework.Text Namespace
Substring.Equals Overload List


Extract Method

Substring.Extract Method

Returns a substring of the substring.

Overload List

 | Name | Description
Public method | Extract (Int32) | Returns a substring of the substring.
Public method | Extract (Int32, Int32) | Returns a substring of the substring.

See Also

Substring Structure
Gallio.Framework.Text Namespace


Extract Method (Int32)

Substring.Extract Method (Int32)
See Also Example
[image]

Returns a substring of the substring.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Extract( _
ByVal index As Integer _
) As Substring
C#
public Substring Extract(
int index
)
C++
public:
Substring Extract(
int index
) sealed
J#
public Substring Extract(
int index
)
JScript
public function Extract(
index : int
) : Substring

Parameters

index
The index at which to start

Return Value

The substring

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if index is negative or if is greater than Length

See Also

Substring Structure
Gallio.Framework.Text Namespace
Substring.Extract Overload List


Extract Method (Int32, Int32)

Substring.Extract Method (Int32, Int32)
See Also Example
[image]

Returns a substring of the substring.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Extract( _
ByVal index As Integer, _
ByVal length As Integer _
) As Substring
C#
public Substring Extract(
int index,
int length
)
C++
public:
Substring Extract(
int index,
int length
) sealed
J#
public Substring Extract(
int index,
int length
)
JScript
public function Extract(
index : int,
length : int
) : Substring

Parameters

index
The index at which to start
length
The length of the substring to produce

Return Value

The substring

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if index or length are negative or if their sum is greater than Length

See Also

Substring Structure
Gallio.Framework.Text Namespace
Substring.Extract Overload List


FindCommonPrefixLength Method

Substring.FindCommonPrefixLength Method
[image]

Finds the length of the common prefix of this substring and another one.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function FindCommonPrefixLength( _
ByVal other As Substring _
) As Integer
C#
public int FindCommonPrefixLength(
Substring other
)
C++
public:
int FindCommonPrefixLength(
Substring other
) sealed
J#
public int FindCommonPrefixLength(
Substring other
)
JScript
public function FindCommonPrefixLength(
other : Substring
) : int

Parameters

other
The other substring

Return Value

The common prefix length, or 0 if the substrings have no prefix in common

See Also

Substring Structure
Gallio.Framework.Text Namespace


FindCommonSuffixLength Method

Substring.FindCommonSuffixLength Method
[image]

Finds the length of the common suffix of this substring and another one.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function FindCommonSuffixLength( _
ByVal other As Substring _
) As Integer
C#
public int FindCommonSuffixLength(
Substring other
)
C++
public:
int FindCommonSuffixLength(
Substring other
) sealed
J#
public int FindCommonSuffixLength(
Substring other
)
JScript
public function FindCommonSuffixLength(
other : Substring
) : int

Parameters

other
The other substring

Return Value

The common suffix length, or 0 if the substrings have no suffix in common

See Also

Substring Structure
Gallio.Framework.Text Namespace


GetHashCode Method

Substring.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Substring Structure
Gallio.Framework.Text Namespace


op_Equality Operator

Substring.op_Equality Operator
[image]

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As Substring, _
ByVal b As Substring _
) As Boolean
C#
public static bool operator ==(
Substring a,
Substring b
)
C++
public:
static bool operator ==(
Substring a,
Substring b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Substring Structure
Gallio.Framework.Text Namespace


op_Inequality Operator

Substring.op_Inequality Operator
[image]

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As Substring, _
ByVal b As Substring _
) As Boolean
C#
public static bool operator !=(
Substring a,
Substring b
)
C++
public:
static bool operator !=(
Substring a,
Substring b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Substring Structure
Gallio.Framework.Text Namespace


ToString Method

Substring.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Framework.Text
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

Substring Structure
Gallio.Framework.Text Namespace


Gallio.Framework.Utilities

Gallio.Framework.Utilities Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | SampleRunner | Runs sample test cases within an embedded copy of the test runner and provides access to the resulting test report. Logs debug output from the embedded test runner while the sample tests run. This utility class is intended to help write integration tests for test framework features.


SampleRunner Class

SampleRunner Class
See Also Example Members
[image]

Runs sample test cases within an embedded copy of the test runner and provides access to the resulting test report. Logs debug output from the embedded test runner while the sample tests run.

This utility class is intended to help write integration tests for test framework features.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class SampleRunner
C#
public class SampleRunner
C++
ref class SampleRunner
J#
public class SampleRunner
JScript
public class SampleRunner

Remarks

This class is NOT intended to be used for instructional purposes as a template for creating a new test runner. Do NOT copy this code and try to make a new test runner out of it. Instead, please examine the code for the Gallio Echo test runner and pay attention to how it uses the TestLauncher.

Inheritance Hierarchy

System.Object
Gallio.Framework.Utilities.SampleRunner

See Also

SampleRunner Members
Gallio.Framework.Utilities Namespace


SampleRunner Members

SampleRunner Members
See Also Example Constructors Properties Methods
[image]

Runs sample test cases within an embedded copy of the test runner and provides access to the resulting test report. Logs debug output from the embedded test runner while the sample tests run.

This utility class is intended to help write integration tests for test framework features.

The following tables list the members exposed by SampleRunner.

Public Constructors

 | Name | Description
Public method | SampleRunner | Creates a sample runner.
Top

Public Properties

 | Name | Description
Public property | PackageConfig | Gets the package configuration object for the test run. The returned object may be modified prior to running the tests to configure various parameters of the test run.
Public property | Report | Gets the test report that was produced by the test run.
Public property | Result | Gets the result of the test run.
Public property | TestRunnerFactoryName | Gets or sets the name of the test runner factory to use.
Top

Public Methods

 | Name | Description
Public method | AddAssembly | Adds a test assembly to the package configuration, if not already added.
Public method | AddFilter | Adds a test filter to the combined list of filters that select which tests to include in the run, if not already added.
Public method | AddFixture | Adds a test fixture type to the list of filters, and automatically adds its containing test assembly to the package configuration, if not already added.
Public method | AddMethod | Adds a test method to the list of filters, and automatically adds its containing test assembly to the package configuration, if not already added.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores the tests but does not run them.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPrimaryTestStepRun | Gets the primary test step run of a test with the given code reference. If there are multiple primary steps, returns the first one found.
Public method | GetTestCaseRunsWithin | Gets all test step runs that represent test cases within a test with the specified code reference.
Public method | GetTestData | Gets information about the test with the given code reference.
Public method | GetTestStepRuns | Gets all test step runs with the given code reference.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs the tests.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


SampleRunner Constructor

SampleRunner Constructor
[image]

Creates a sample runner.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SampleRunner()
C++
public:
SampleRunner() sealed
J#
public SampleRunner()
JScript
public function SampleRunner()

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Properties

SampleRunner Properties
[image]

Public Properties

 | Name | Description
Public property | PackageConfig | Gets the package configuration object for the test run. The returned object may be modified prior to running the tests to configure various parameters of the test run.
Public property | Report | Gets the test report that was produced by the test run.
Public property | Result | Gets the result of the test run.
Public property | TestRunnerFactoryName | Gets or sets the name of the test runner factory to use.
Top

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


PackageConfig Property

SampleRunner.PackageConfig Property
[image]

Gets the package configuration object for the test run.

The returned object may be modified prior to running the tests to configure various parameters of the test run.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PackageConfig As TestPackageConfig
C#
public TestPackageConfig PackageConfig { get; }
C++
public property TestPackageConfig PackageConfig sealed {
TestPackageConfig get();
}
J#
/** property */
public TestPackageConfig get_PackageConfig();
JScript
public function get PackageConfig() : TestPackageConfig

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Report Property

SampleRunner.Report Property
[image]

Gets the test report that was produced by the test run.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Result Property

SampleRunner.Result Property
[image]

Gets the result of the test run.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As TestLauncherResult
C#
public TestLauncherResult Result { get; }
C++
public property TestLauncherResult Result sealed {
TestLauncherResult get();
}
J#
/** property */
public TestLauncherResult get_Result();
JScript
public function get Result() : TestLauncherResult

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


TestRunnerFactoryName Property

SampleRunner.TestRunnerFactoryName Property
[image]

Gets or sets the name of the test runner factory to use.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestRunnerFactoryName As String
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public string TestRunnerFactoryName { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property string TestRunnerFactoryName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TestRunnerFactoryName();

/** property */
public void set_TestRunnerFactoryName(string value);
JScript
public CompilerGeneratedAttribute function get TestRunnerFactoryName() : String

public CompilerGeneratedAttribute function set TestRunnerFactoryName(value : String);

Property Value

The test runner factory name, defaults to Local

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Methods

SampleRunner Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssembly | Adds a test assembly to the package configuration, if not already added.
Public method | AddFilter | Adds a test filter to the combined list of filters that select which tests to include in the run, if not already added.
Public method | AddFixture | Adds a test fixture type to the list of filters, and automatically adds its containing test assembly to the package configuration, if not already added.
Public method | AddMethod | Adds a test method to the list of filters, and automatically adds its containing test assembly to the package configuration, if not already added.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores the tests but does not run them.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPrimaryTestStepRun | Gets the primary test step run of a test with the given code reference. If there are multiple primary steps, returns the first one found.
Public method | GetTestCaseRunsWithin | Gets all test step runs that represent test cases within a test with the specified code reference.
Public method | GetTestData | Gets information about the test with the given code reference.
Public method | GetTestStepRuns | Gets all test step runs with the given code reference.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs the tests.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


AddAssembly Method

SampleRunner.AddAssembly Method
[image]

Adds a test assembly to the package configuration, if not already added.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssembly( _
ByVal assembly As Assembly _
)
C#
public void AddAssembly(
Assembly assembly
)
C++
public:
void AddAssembly(
Assembly assembly
) sealed
J#
public void AddAssembly(
Assembly assembly
)
JScript
public function AddAssembly(
assembly : Assembly
)

Parameters

assembly
The assembly to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


AddFilter Method

SampleRunner.AddFilter Method
[image]

Adds a test filter to the combined list of filters that select which tests to include in the run, if not already added.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFilter( _
ByVal filter As Filter(Of ITest) _
)
C#
public void AddFilter(
Filter<ITest> filter
)
C++
public:
void AddFilter(
Filter<ITest> filter
) sealed
J#
public void AddFilter(
Filter<ITest> filter
)
JScript
public function AddFilter(
filter : Filter<ITest>
)

Parameters

filter
The filter to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if filter is null

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


AddFixture Method

SampleRunner.AddFixture Method
[image]

Adds a test fixture type to the list of filters, and automatically adds its containing test assembly to the package configuration, if not already added.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddFixture( _
ByVal fixtureType As Type _
)
C#
public void AddFixture(
Type fixtureType
)
C++
public:
void AddFixture(
Type fixtureType
) sealed
J#
public void AddFixture(
Type fixtureType
)
JScript
public function AddFixture(
fixtureType : Type
)

Parameters

fixtureType
The test fixture type to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if fixtureType is null

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


AddMethod Method

SampleRunner.AddMethod Method
[image]

Adds a test method to the list of filters, and automatically adds its containing test assembly to the package configuration, if not already added.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMethod( _
ByVal fixtureType As Type, _
ByVal methodName As String _
)
C#
public void AddMethod(
Type fixtureType,
string methodName
)
C++
public:
void AddMethod(
Type fixtureType,
String methodName
) sealed
J#
public void AddMethod(
Type fixtureType,
string methodName
)
JScript
public function AddMethod(
fixtureType : Type,
methodName : String
)

Parameters

fixtureType
The test fixture type
methodName
The test method name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if fixtureType or methodName is null

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Explore Method

SampleRunner.Explore Method
[image]

Explores the tests but does not run them.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Explore()
C#
public void Explore()
C++
public:
void Explore() sealed
J#
public void Explore()
JScript
public function Explore()

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


GetPrimaryTestStepRun Method

SampleRunner.GetPrimaryTestStepRun Method
[image]

Gets the primary test step run of a test with the given code reference. If there are multiple primary steps, returns the first one found.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPrimaryTestStepRun( _
ByVal codeReference As CodeReference _
) As TestStepRun
C#
public TestStepRun GetPrimaryTestStepRun(
CodeReference codeReference
)
C++
public:
TestStepRun GetPrimaryTestStepRun(
CodeReference codeReference
) sealed
J#
public TestStepRun GetPrimaryTestStepRun(
CodeReference codeReference
)
JScript
public function GetPrimaryTestStepRun(
codeReference : CodeReference
) : TestStepRun

Parameters

codeReference
The code reference of the test

Return Value

The first test step run, or null if not found

Remarks

Can only be called after the tests have run.

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


GetTestCaseRunsWithin Method

SampleRunner.GetTestCaseRunsWithin Method
[image]

Gets all test step runs that represent test cases within a test with the specified code reference.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTestCaseRunsWithin( _
ByVal codeReference As CodeReference _
) As IList(Of TestStepRun)
C#
public IList<TestStepRun> GetTestCaseRunsWithin(
CodeReference codeReference
)
C++
public:
IList<TestStepRun> GetTestCaseRunsWithin(
CodeReference codeReference
) sealed
J#
public IList<TestStepRun> GetTestCaseRunsWithin(
CodeReference codeReference
)
JScript
public function GetTestCaseRunsWithin(
codeReference : CodeReference
) : IList<TestStepRun>

Parameters

codeReference
The code reference of the test

Return Value

The first test step run, or null if not found

Remarks

Can only be called after the tests have run.

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


GetTestData Method

SampleRunner.GetTestData Method
[image]

Gets information about the test with the given code reference.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTestData( _
ByVal codeReference As CodeReference _
) As TestData
C#
public TestData GetTestData(
CodeReference codeReference
)
C++
public:
TestData GetTestData(
CodeReference codeReference
) sealed
J#
public TestData GetTestData(
CodeReference codeReference
)
JScript
public function GetTestData(
codeReference : CodeReference
) : TestData

Parameters

codeReference
The code reference of the test

Return Value

The test data, or null if not found

Remarks

Can only be called after the tests have run.

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


GetTestStepRuns Method

SampleRunner.GetTestStepRuns Method
[image]

Gets all test step runs with the given code reference.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTestStepRuns( _
ByVal codeReference As CodeReference _
) As IEnumerable(Of TestStepRun)
C#
public IEnumerable<TestStepRun> GetTestStepRuns(
CodeReference codeReference
)
C++
public:
IEnumerable<TestStepRun> GetTestStepRuns(
CodeReference codeReference
) sealed
J#
public IEnumerable<TestStepRun> GetTestStepRuns(
CodeReference codeReference
)
JScript
public function GetTestStepRuns(
codeReference : CodeReference
) : IEnumerable<TestStepRun>

Parameters

codeReference
The code reference of the test

Return Value

The enumeration of test step runs, or null if not found

Remarks

Can only be called after the tests have run.

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Run Method

SampleRunner.Run Method
[image]

Runs the tests.

Namespace: Gallio.Framework.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Run()
C#
public void Run()
C++
public:
void Run() sealed
J#
public void Run()
JScript
public function Run()

See Also

SampleRunner Class
Gallio.Framework.Utilities Namespace


Gallio.Linq

Gallio.Linq Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ActionExtensions | Extension methods for Action delegates. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ExpressionExtensions | Extension methods for Expression. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ExpressionInstrumentor | Instuments an Expression to intercept intermediate results from each sub-expression. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | ExpressionVisitor | Performs different actions depending on the type of Expression visited. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Structures

 | Structure | Description
Public structure | Unit | A value type that represents the result of evaluating an expression of type Void.


ActionExtensions Class

ActionExtensions Class
See Also Example Members
[image]

Extension methods for Action delegates. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Module ActionExtensions
C#
[ExtensionAttribute]
public static class ActionExtensions
C++
[ExtensionAttribute]
ref class ActionExtensions abstract sealed
J#
/** @attribute ExtensionAttribute() */
public final class ActionExtensions
JScript
public
ExtensionAttribute
class ActionExtensions

Inheritance Hierarchy

System.Object
Gallio.Linq.ActionExtensions

See Also

ActionExtensions Members
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ActionExtensions Members

ActionExtensions Members
See Also Example Methods
[image]

Extension methods for Action delegates. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ActionExtensions.

Public Methods

Name | Description
AsUnitFunc | Wraps an action as a function that returns a dummy Unit value.
Top

See Also

ActionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

ActionExtensions Methods
[image]

Public Methods

Name | Description
AsUnitFunc | Wraps an action as a function that returns a dummy Unit value.
Top

See Also

ActionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


AsUnitFunc Method

ActionExtensions.AsUnitFunc Method
[image]

Wraps an action as a function that returns a dummy Unit value.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function AsUnitFunc( _
ByVal action As Action _
) As Func(Of Unit)
C#
[ExtensionAttribute]
public static Func<Unit> AsUnitFunc(
Action action
)
C++
[ExtensionAttribute]
public:
static Func<Unit> AsUnitFunc(
Action action
)
J#
/** @attribute ExtensionAttribute() */
public static Func<Unit> AsUnitFunc(
Action action
)
JScript
public static

ExtensionAttribute
function AsUnitFunc(
action : Action
) : Func<Unit>

Return Value

The function

See Also

ActionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionExtensions Class

ExpressionExtensions Class
See Also Example Members
[image]

Extension methods for Expression. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Module ExpressionExtensions
C#
[ExtensionAttribute]
public static class ExpressionExtensions
C++
[ExtensionAttribute]
ref class ExpressionExtensions abstract sealed
J#
/** @attribute ExtensionAttribute() */
public final class ExpressionExtensions
JScript
public
ExtensionAttribute
class ExpressionExtensions

Inheritance Hierarchy

System.Object
Gallio.Linq.ExpressionExtensions

See Also

ExpressionExtensions Members
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionExtensions Members

ExpressionExtensions Members
See Also Example Methods
[image]

Extension methods for Expression. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ExpressionExtensions.

Public Methods

Name | Description
Bind | Overloaded. Binds the arguments of a function expression.
IsCapturedVariable | Overloaded. Returns true if the expression represents a captured variable within a closure.
IsCapturedVariableOrParameter | Returns true if the expression represents a captured variable or a parameter.
Top

See Also

ExpressionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

ExpressionExtensions Methods
[image]

Public Methods

Name | Description
Bind | Overloaded. Binds the arguments of a function expression.
IsCapturedVariable | Overloaded. Returns true if the expression represents a captured variable within a closure.
IsCapturedVariableOrParameter | Returns true if the expression represents a captured variable or a parameter.
Top

See Also

ExpressionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Bind Generic Method

ExpressionExtensions.Bind Generic Method

Binds the arguments of a function expression.

Overload List

Name | Description
Bind (Expression<Func<T, TResult>>, T) | Binds the arguments of a function expression.
Bind (Expression<Func<T1, TResult>>, T1, T2) | Binds the arguments of a function expression.

See Also

ExpressionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Bind Generic Method (Generic Expression, T)

ExpressionExtensions.Bind Generic Method (Generic Expression, T)
See Also Example
[image]

Binds the arguments of a function expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Bind(Of T, TResult)( _
ByVal expr As Expression(Of Func(Of T, TResult)), _
ByVal arg As T _
) As Expression(Of Func(Of TResult))
C#
[ExtensionAttribute]
public static Expression<Func<TResult>> Bind<T, TResult>(
Expression<Func<T, TResult>> expr,
T arg
)
C++
[ExtensionAttribute]
public:
static Expression<Func<TResult>> Bind<T, TResult>(
Expression<Func<T, TResult>> expr,
T arg
)
J#
/** @attribute ExtensionAttribute() */
public static Expression<Func<TResult>> Bind<T, TResult>(
Expression<Func<T, TResult>> expr,
T arg
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The parameter type
TResult
The result type

Parameters

expr
The expression
arg
The argument value

Return Value

The bound function

See Also

ExpressionExtensions Class
Gallio.Linq Namespace
ExpressionExtensions.Bind Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Bind Generic Method (Generic Expression, T1, T2)

ExpressionExtensions.Bind Generic Method (Generic Expression, T1, T2)
See Also Example
[image]

Binds the arguments of a function expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function Bind(Of T1, T2, TResult)( _
ByVal expr As Expression(Of Func(Of T1, TResult)), _
ByVal arg1 As T1, _
ByVal arg2 As T2 _
) As Expression(Of Func(Of TResult))
C#
[ExtensionAttribute]
public static Expression<Func<TResult>> Bind<T1, T2, TResult>(
Expression<Func<T1, TResult>> expr,
T1 arg1,
T2 arg2
)
C++
[ExtensionAttribute]
public:
static Expression<Func<TResult>> Bind<T1, T2, TResult>(
Expression<Func<T1, TResult>> expr,
T1 arg1,
T2 arg2
)
J#
/** @attribute ExtensionAttribute() */
public static Expression<Func<TResult>> Bind<T1, T2, TResult>(
Expression<Func<T1, TResult>> expr,
T1 arg1,
T2 arg2
)
JScript
JScript does not support generic types and methods.

Type Parameters

T1
The first parameter type
T2
The second parameter type
TResult
The result type

Parameters

expr
The expression
arg1
The first argument value
arg2
The second argument value

Return Value

The bound function

See Also

ExpressionExtensions Class
Gallio.Linq Namespace
ExpressionExtensions.Bind Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


IsCapturedVariable Method

ExpressionExtensions.IsCapturedVariable Method

Returns true if the expression represents a captured variable within a closure.

Overload List

Name | Description
IsCapturedVariable (Expression) | Returns true if the expression represents a captured variable within a closure.
IsCapturedVariable (MemberExpression) | Returns true if the expression represents a captured variable within a closure.

See Also

ExpressionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


IsCapturedVariable Method (Expression)

ExpressionExtensions.IsCapturedVariable Method (Expression)
See Also Example
[image]

Returns true if the expression represents a captured variable within a closure.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function IsCapturedVariable( _
ByVal expr As Expression _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsCapturedVariable(
Expression expr
)
C++
[ExtensionAttribute]
public:
static bool IsCapturedVariable(
Expression expr
)
J#
/** @attribute ExtensionAttribute() */
public static bool IsCapturedVariable(
Expression expr
)
JScript
public static

ExtensionAttribute
function IsCapturedVariable(
expr : Expression
) : bool

Parameters

expr
The expression

Return Value

True if the expression represents a captured variable

See Also

ExpressionExtensions Class
Gallio.Linq Namespace
ExpressionExtensions.IsCapturedVariable Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


IsCapturedVariable Method (MemberExpression)

ExpressionExtensions.IsCapturedVariable Method (MemberExpression)
See Also Example
[image]

Returns true if the expression represents a captured variable within a closure.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function IsCapturedVariable( _
ByVal expr As MemberExpression _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsCapturedVariable(
MemberExpression expr
)
C++
[ExtensionAttribute]
public:
static bool IsCapturedVariable(
MemberExpression expr
)
J#
/** @attribute ExtensionAttribute() */
public static bool IsCapturedVariable(
MemberExpression expr
)
JScript
public static

ExtensionAttribute
function IsCapturedVariable(
expr : MemberExpression
) : bool

Parameters

expr
The expression

Return Value

True if the expression represents a captured variable

See Also

ExpressionExtensions Class
Gallio.Linq Namespace
ExpressionExtensions.IsCapturedVariable Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


IsCapturedVariableOrParameter Method

ExpressionExtensions.IsCapturedVariableOrParameter Method
[image]

Returns true if the expression represents a captured variable or a parameter.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<ExtensionAttribute>
Public Shared Function IsCapturedVariableOrParameter( _
ByVal expr As Expression _
) As Boolean
C#
[ExtensionAttribute]
public static bool IsCapturedVariableOrParameter(
Expression expr
)
C++
[ExtensionAttribute]
public:
static bool IsCapturedVariableOrParameter(
Expression expr
)
J#
/** @attribute ExtensionAttribute() */
public static bool IsCapturedVariableOrParameter(
Expression expr
)
JScript
public static

ExtensionAttribute
function IsCapturedVariableOrParameter(
expr : Expression
) : bool

Parameters

expr
The expression

Return Value

True if the expression represents a captured variable or a parameter

See Also

ExpressionExtensions Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionInstrumentor Class

ExpressionInstrumentor Class
See Also Example Members
[image]

Instuments an Expression to intercept intermediate results from each sub-expression. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ExpressionInstrumentor
C#
public abstract class ExpressionInstrumentor
C++
ref class ExpressionInstrumentor abstract
J#
public class ExpressionInstrumentor
JScript
public class ExpressionInstrumentor

Inheritance Hierarchy

System.Object
Gallio.Linq.ExpressionInstrumentor

See Also

ExpressionInstrumentor Members
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionInstrumentor Members

ExpressionInstrumentor Members
See Also Example Constructors Methods
[image]

Instuments an Expression to intercept intermediate results from each sub-expression. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ExpressionInstrumentor.

Protected Constructors

 | Name | Description
Family method | ExpressionInstrumentor | Initializes a new instance of the ExpressionInstrumentor class.
Top

Public Methods

 | Name | Description
Public method | Compile | Compiles an expression to introduce trace points.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Rewrite | Rewrites an expression tree to introduce trace points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Intercept | Evaluates a sub-expression and collects trace information.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ExpressionInstrumentor Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionInstrumentor Constructor

ExpressionInstrumentor Constructor
[image]

Initializes a new instance of the ExpressionInstrumentor class.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected ExpressionInstrumentor()
C++
protected:
ExpressionInstrumentor() sealed
J#
protected ExpressionInstrumentor()
JScript
protected function ExpressionInstrumentor()

See Also

ExpressionInstrumentor Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

ExpressionInstrumentor Methods
[image]

Public Methods

 | Name | Description
Public method | Compile | Compiles an expression to introduce trace points.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Rewrite | Rewrites an expression tree to introduce trace points.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Intercept | Evaluates a sub-expression and collects trace information.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ExpressionInstrumentor Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Compile Generic Method

ExpressionInstrumentor.Compile Generic Method
[image]

Compiles an expression to introduce trace points.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Function Compile(Of T)( _
ByVal expr As Expression(Of T) _
)
C#
public T Compile<T>(
Expression<T> expr
)
C++
public:
T Compile<T>(
Expression<T> expr
) sealed
J#
public T Compile<T>(
Expression<T> expr
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The expression type

Parameters

expr
The expression tree

Return Value

The compiled delegate representing expression

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if expr is null

See Also

ExpressionInstrumentor Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Intercept Generic Method

ExpressionInstrumentor.Intercept Generic Method
[image]

Evaluates a sub-expression and collects trace information.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
<DebuggerHiddenAttribute, _
DebuggerStepThroughAttribute>
Protected Overridable Function Intercept(Of T)( _
ByVal expr As Expression, _
ByVal continuation As Func(Of T) _
)
C#
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
protected virtual T Intercept<T>(
Expression expr,
Func<T> continuation
)
C++
[DebuggerHiddenAttribute]
[DebuggerStepThroughAttribute]
protected:
virtual T Intercept<T>(
Expression expr,
Func<T> continuation
)
J#
/** @attribute DebuggerHiddenAttribute() */
/** @attribute DebuggerStepThroughAttribute() */
protected virtual T Intercept<T>(
Expression expr,
Func<T> continuation
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The return type of the sub-expression

Parameters

expr
The sub-expression to evaluate
continuation
The continuation that evaluates the sub-expression

Return Value

The result of the evaluation

See Also

ExpressionInstrumentor Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Rewrite Generic Method

ExpressionInstrumentor.Rewrite Generic Method
[image]

Rewrites an expression tree to introduce trace points.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Function Rewrite(Of T)( _
ByVal expr As Expression(Of T) _
) As Expression(Of T)
C#
public Expression<T> Rewrite<T>(
Expression<T> expr
)
C++
public:
Expression<T> Rewrite<T>(
Expression<T> expr
) sealed
J#
public Expression<T> Rewrite<T>(
Expression<T> expr
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The expression type

Parameters

expr
The expression tree

Return Value

The compiled delegate representing expression

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if expr is null

See Also

ExpressionInstrumentor Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionVisitor Generic Class

ExpressionVisitor Generic Class
See Also Example Members
[image]

Performs different actions depending on the type of Expression visited. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ExpressionVisitor(Of T)
C#
public abstract class ExpressionVisitor<T>
C++
ref class ExpressionVisitor<T> abstract
J#
public class ExpressionVisitor<T>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The visitor result type

Inheritance Hierarchy

System.Object
Gallio.Linq.ExpressionVisitor<T>

See Also

ExpressionVisitor<T> Members
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionVisitor<T> Members

ExpressionVisitor Members
See Also Example Constructors Methods
[image]

Performs different actions depending on the type of Expression visited. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ExpressionVisitor<T>.

Protected Constructors

 | Name | Description
Family method | ExpressionVisitor | Initializes a new instance of the ExpressionVisitor class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Visit | Visits the expression.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | VisitAny | Visits an expression of any type that does not have other special behavior. The default implementation throws NotSupportedException.
Family method | VisitBinary | Visits a binary expression.
Family method | VisitConditional | Visits a conditional expression.
Family method | VisitConstant | Visits a constant expression.
Family method | VisitInvocation | Visits an invocation expression.
Family method | VisitLambda | Visits a lambda expression.
Family method | VisitListInit | Visits an list init expression.
Family method | VisitMember | Visits a member access expression.
Family method | VisitMemberInit | Visits a member init expression.
Family method | VisitMethodCall | Visits a call expression.
Family method | VisitNew | Visits a new expression.
Family method | VisitNewArray | Visits a new array expression.
Family method | VisitParameter | Visits a parameter expression.
Family method | VisitTypeBinary | Visits a type binary expression.
Family method | VisitUnary | Visits a unary expression.
Top

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ExpressionVisitor Constructor

ExpressionVisitor Constructor
[image]

Initializes a new instance of the ExpressionVisitor class.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected ExpressionVisitor()
C++
protected:
ExpressionVisitor() sealed
J#
protected ExpressionVisitor()
JScript
JScript does not support generic types and methods.

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

ExpressionVisitor Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Visit | Visits the expression.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | VisitAny | Visits an expression of any type that does not have other special behavior. The default implementation throws NotSupportedException.
Family method | VisitBinary | Visits a binary expression.
Family method | VisitConditional | Visits a conditional expression.
Family method | VisitConstant | Visits a constant expression.
Family method | VisitInvocation | Visits an invocation expression.
Family method | VisitLambda | Visits a lambda expression.
Family method | VisitListInit | Visits an list init expression.
Family method | VisitMember | Visits a member access expression.
Family method | VisitMemberInit | Visits a member init expression.
Family method | VisitMethodCall | Visits a call expression.
Family method | VisitNew | Visits a new expression.
Family method | VisitNewArray | Visits a new array expression.
Family method | VisitParameter | Visits a parameter expression.
Family method | VisitTypeBinary | Visits a type binary expression.
Family method | VisitUnary | Visits a unary expression.
Top

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Visit Method

ExpressionVisitor.Visit Method
[image]

Visits the expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Function Visit( _
ByVal expr As Expression _
)
C#
public T Visit(
Expression expr
)
C++
public:
T Visit(
Expression expr
) sealed
J#
public T Visit(
Expression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitAny Method

ExpressionVisitor.VisitAny Method
[image]

Visits an expression of any type that does not have other special behavior.

The default implementation throws NotSupportedException.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitAny( _
ByVal expr As Expression _
)
C#
protected virtual T VisitAny(
Expression expr
)
C++
protected:
virtual T VisitAny(
Expression expr
)
J#
protected virtual T VisitAny(
Expression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitBinary Method

ExpressionVisitor.VisitBinary Method
[image]

Visits a binary expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitBinary( _
ByVal expr As BinaryExpression _
)
C#
protected virtual T VisitBinary(
BinaryExpression expr
)
C++
protected:
virtual T VisitBinary(
BinaryExpression expr
)
J#
protected virtual T VisitBinary(
BinaryExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitConditional Method

ExpressionVisitor.VisitConditional Method
[image]

Visits a conditional expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitConditional( _
ByVal expr As ConditionalExpression _
)
C#
protected virtual T VisitConditional(
ConditionalExpression expr
)
C++
protected:
virtual T VisitConditional(
ConditionalExpression expr
)
J#
protected virtual T VisitConditional(
ConditionalExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitConstant Method

ExpressionVisitor.VisitConstant Method
[image]

Visits a constant expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitConstant( _
ByVal expr As ConstantExpression _
)
C#
protected virtual T VisitConstant(
ConstantExpression expr
)
C++
protected:
virtual T VisitConstant(
ConstantExpression expr
)
J#
protected virtual T VisitConstant(
ConstantExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitInvocation Method

ExpressionVisitor.VisitInvocation Method
[image]

Visits an invocation expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitInvocation( _
ByVal expr As InvocationExpression _
)
C#
protected virtual T VisitInvocation(
InvocationExpression expr
)
C++
protected:
virtual T VisitInvocation(
InvocationExpression expr
)
J#
protected virtual T VisitInvocation(
InvocationExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitLambda Method

ExpressionVisitor.VisitLambda Method
[image]

Visits a lambda expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitLambda( _
ByVal expr As LambdaExpression _
)
C#
protected virtual T VisitLambda(
LambdaExpression expr
)
C++
protected:
virtual T VisitLambda(
LambdaExpression expr
)
J#
protected virtual T VisitLambda(
LambdaExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitListInit Method

ExpressionVisitor.VisitListInit Method
[image]

Visits an list init expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitListInit( _
ByVal expr As ListInitExpression _
)
C#
protected virtual T VisitListInit(
ListInitExpression expr
)
C++
protected:
virtual T VisitListInit(
ListInitExpression expr
)
J#
protected virtual T VisitListInit(
ListInitExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitMember Method

ExpressionVisitor.VisitMember Method
[image]

Visits a member access expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitMember( _
ByVal expr As MemberExpression _
)
C#
protected virtual T VisitMember(
MemberExpression expr
)
C++
protected:
virtual T VisitMember(
MemberExpression expr
)
J#
protected virtual T VisitMember(
MemberExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitMemberInit Method

ExpressionVisitor.VisitMemberInit Method
[image]

Visits a member init expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitMemberInit( _
ByVal expr As MemberInitExpression _
)
C#
protected virtual T VisitMemberInit(
MemberInitExpression expr
)
C++
protected:
virtual T VisitMemberInit(
MemberInitExpression expr
)
J#
protected virtual T VisitMemberInit(
MemberInitExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitMethodCall Method

ExpressionVisitor.VisitMethodCall Method
[image]

Visits a call expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitMethodCall( _
ByVal expr As MethodCallExpression _
)
C#
protected virtual T VisitMethodCall(
MethodCallExpression expr
)
C++
protected:
virtual T VisitMethodCall(
MethodCallExpression expr
)
J#
protected virtual T VisitMethodCall(
MethodCallExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitNew Method

ExpressionVisitor.VisitNew Method
[image]

Visits a new expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitNew( _
ByVal expr As NewExpression _
)
C#
protected virtual T VisitNew(
NewExpression expr
)
C++
protected:
virtual T VisitNew(
NewExpression expr
)
J#
protected virtual T VisitNew(
NewExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitNewArray Method

ExpressionVisitor.VisitNewArray Method
[image]

Visits a new array expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitNewArray( _
ByVal expr As NewArrayExpression _
)
C#
protected virtual T VisitNewArray(
NewArrayExpression expr
)
C++
protected:
virtual T VisitNewArray(
NewArrayExpression expr
)
J#
protected virtual T VisitNewArray(
NewArrayExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitParameter Method

ExpressionVisitor.VisitParameter Method
[image]

Visits a parameter expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitParameter( _
ByVal expr As ParameterExpression _
)
C#
protected virtual T VisitParameter(
ParameterExpression expr
)
C++
protected:
virtual T VisitParameter(
ParameterExpression expr
)
J#
protected virtual T VisitParameter(
ParameterExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitTypeBinary Method

ExpressionVisitor.VisitTypeBinary Method
[image]

Visits a type binary expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitTypeBinary( _
ByVal expr As TypeBinaryExpression _
)
C#
protected virtual T VisitTypeBinary(
TypeBinaryExpression expr
)
C++
protected:
virtual T VisitTypeBinary(
TypeBinaryExpression expr
)
J#
protected virtual T VisitTypeBinary(
TypeBinaryExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


VisitUnary Method

ExpressionVisitor.VisitUnary Method
[image]

Visits a unary expression.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function VisitUnary( _
ByVal expr As UnaryExpression _
)
C#
protected virtual T VisitUnary(
UnaryExpression expr
)
C++
protected:
virtual T VisitUnary(
UnaryExpression expr
)
J#
protected virtual T VisitUnary(
UnaryExpression expr
)
JScript
JScript does not support generic types and methods.

Parameters

expr
The expression

Return Value

The result

See Also

ExpressionVisitor<T> Class
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Unit Structure

Unit Structure
See Also Example Members
[image]

A value type that represents the result of evaluating an expression of type Void.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Structure Unit
C#
public struct Unit
C++
value class Unit
J#
public final class Unit extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Linq.Unit

See Also

Unit Members
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Unit Members

Unit Members
See Also Example Fields Methods
[image]

A value type that represents the result of evaluating an expression of type Void.

The following tables list the members exposed by Unit.

Public Fields

Name | Description
Value | Gets the singular value of the Unit type. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Unit Structure
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Fields

Unit Fields
[image]

Public Fields

Name | Description
Value | Gets the singular value of the Unit type. This field is read-only.
Top

See Also

Unit Structure
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Value Field

Unit.Value Field
[image]

Gets the singular value of the Unit type. This field is read-only.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Value As Unit
C#
public static readonly Unit Value;
C++
public:
static const Unit Value;
J#
public static final Unit Value
JScript
public static const var Value : Unit;

See Also

Unit Structure
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Methods

Unit Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Unit Structure
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


ToString Method

Unit.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Linq
Assembly: Gallio35 (in Gallio35.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

Unit Structure
Gallio.Linq Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio35 [3.0.6.0]


Gallio.Loader

Gallio.Loader Namespace
See Also Example Hierarchy

Classes

Class Description
Public class GallioLoader

The Gallio loader provides access to installed Gallio assemblies so that we can reference them even if they are not copied locally.

We must avoid copying these assemblies because it is possible for multiple copies to be loaded in the same process simultaneously in different load context (Load / LoadFrom / LoadFile). When multiple copies of the same assembly are loaded their types are considered distinct and they cannot reliably exchange information with other components (like plugins). This problem was actually observed when two different Visual Studio add-ins installed in different locations were loaded at the same time.

The Gallio loader may be used in situations where 3rd party integration mandates the installation of a Gallio-dependent assembly outside of the Gallio installation path. It is fairly typical for application plugin models.

The loader itself will typically be loaded from the GAC or copy-local as usual. It will then springboard into the locally installed copy of Gallio which is found by searching the registry. It is also possible to specify the location of the Gallio installation explicitly instead.

Once the loader has been initialized, all Gallio types should become accessible. In particular, the runtime can then be initialized.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class SafeException

An exception that expresses a problem in a manner that may be safely communicated across a remote context to a client that may not be able to load the original exception type.

Using this type prevents spurious SerializationException exceptions from being thrown due to the server exposing an internal exception type that is not accessible to the client.

Interfaces

 | Interface | Description
Public interface | IGallioLoader | Provides an interface for interacting with the Gallio Loader.
Public interface | IGallioRemoteEnvironment | Provides access to an instance of the Gallio runtime that is running in a foreign AppDomain.


GallioLoader Class

GallioLoader Class
See Also Example Members
[image]

The Gallio loader provides access to installed Gallio assemblies so that we can reference them even if they are not copied locally.

We must avoid copying these assemblies because it is possible for multiple copies to be loaded in the same process simultaneously in different load context (Load / LoadFrom / LoadFile). When multiple copies of the same assembly are loaded their types are considered distinct and they cannot reliably exchange information with other components (like plugins). This problem was actually observed when two different Visual Studio add-ins installed in different locations were loaded at the same time.

The Gallio loader may be used in situations where 3rd party integration mandates the installation of a Gallio-dependent assembly outside of the Gallio installation path. It is fairly typical for application plugin models.

The loader itself will typically be loaded from the GAC or copy-local as usual. It will then springboard into the locally installed copy of Gallio which is found by searching the registry. It is also possible to specify the location of the Gallio installation explicitly instead.

Once the loader has been initialized, all Gallio types should become accessible. In particular, the runtime can then be initialized.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class GallioLoader
Inherits MarshalByRefObject
Implements IGallioLoader
C#
public sealed class GallioLoader : MarshalByRefObject, IGallioLoader
C++
ref class GallioLoader sealed : MarshalByRefObject, IGallioLoader
J#
public final class GallioLoader extends MarshalByRefObject implements IGallioLoader
JScript
public final class GallioLoader extends MarshalByRefObject, IGallioLoader

Remarks

Then install the assembly resolver in your program BEFORE referencing any Gallio types. Beware that types are referenced implicitly by field and method declarations. When external code calls directly into your assembly, you must ensure that all entry points are guarded with appropriate calls to the loader. This may be facilitated somewhat by calling the loader from static initializers declared on the appropriate externally visible classes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Loader.GallioLoader

See Also

GallioLoader Members
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


GallioLoader Members

GallioLoader Members
See Also Example Properties Methods
[image]

The Gallio loader provides access to installed Gallio assemblies so that we can reference them even if they are not copied locally.

We must avoid copying these assemblies because it is possible for multiple copies to be loaded in the same process simultaneously in different load context (Load / LoadFrom / LoadFile). When multiple copies of the same assembly are loaded their types are considered distinct and they cannot reliably exchange information with other components (like plugins). This problem was actually observed when two different Visual Studio add-ins installed in different locations were loaded at the same time.

The Gallio loader may be used in situations where 3rd party integration mandates the installation of a Gallio-dependent assembly outside of the Gallio installation path. It is fairly typical for application plugin models.

The loader itself will typically be loaded from the GAC or copy-local as usual. It will then springboard into the locally installed copy of Gallio which is found by searching the registry. It is also possible to specify the location of the Gallio installation explicitly instead.

Once the loader has been initialized, all Gallio types should become accessible. In particular, the runtime can then be initialized.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by GallioLoader.

Public Properties

 | Name | Description
 | Instance | Gets the Gallio loader instance, or null if not initialized.
Public property | RuntimePath | Gets the Gallio runtime path.
Top

Public Methods

 | Name | Description
Public method | AddHintDirectory | Adds a hint directory to the assembly resolver.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
 | CreateRemoteEnvironment | Creates a private AppDomain that Gallio can reside in.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetApplicationVersion | Gets the application version given its primary assembly. Uses the assembly file version if available.
 | GetDefaultRuntimePath | Gets the runtime path that will be used by default by the loader. The path is determined by looking up the location of the Gallio installation in the registry. It may be overridden by setting the development runtime path key.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | Initialize | Overloaded. Initializes the Gallio loader (if not already initialized) and returns its singleton reference.
Public method | InitializeLifetimeService | Overridden. Obtains a lifetime service object to control the lifetime policy for this instance.
 | InitializeRemote | Overloaded. Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.
Public method | Resolve | Overloaded. Resolves a runtime service.
Public method | SetupRuntime | Sets up the runtime with a default runtime setup using the loader's runtime path and a null logger. Does nothing if the runtime has already been initialized. If you need more control over this behavior, call RuntimeBootstrap yourself.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Properties

GallioLoader Properties
[image]

Public Properties

 | Name | Description
 | Instance | Gets the Gallio loader instance, or null if not initialized.
Public property | RuntimePath | Gets the Gallio runtime path.
Top

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Instance Property

GallioLoader.Instance Property
[image]

Gets the Gallio loader instance, or null if not initialized.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As IGallioLoader
C#
public static IGallioLoader Instance { get; }
C++
public static property IGallioLoader Instance {
IGallioLoader get();
}
J#
/** property */
public IGallioLoader get_Instance();
JScript
public function get Instance() : IGallioLoader

Remarks

A null result does not mean that Gallio is not loaded or that its assemblies cannot be resolved. It may simply means that this particular loading mechanism has not been used.

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


RuntimePath Property

GallioLoader.RuntimePath Property
[image]

Gets the Gallio runtime path.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RuntimePath As String _
Implements IGallioLoader.RuntimePath
C#
public string RuntimePath { get; }
C++
public property string RuntimePath sealed {
String get();
}
J#
/** property */
public string get_RuntimePath();
JScript
public function get RuntimePath() : String

Implements

IGallioLoader.RuntimePath

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Methods

GallioLoader Methods
[image]

Public Methods

 | Name | Description
Public method | AddHintDirectory | Adds a hint directory to the assembly resolver.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
 | CreateRemoteEnvironment | Creates a private AppDomain that Gallio can reside in.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetApplicationVersion | Gets the application version given its primary assembly. Uses the assembly file version if available.
 | GetDefaultRuntimePath | Gets the runtime path that will be used by default by the loader. The path is determined by looking up the location of the Gallio installation in the registry. It may be overridden by setting the development runtime path key.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | Initialize | Overloaded. Initializes the Gallio loader (if not already initialized) and returns its singleton reference.
Public method | InitializeLifetimeService | Overridden. Obtains a lifetime service object to control the lifetime policy for this instance.
 | InitializeRemote | Overloaded. Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.
Public method | Resolve | Overloaded. Resolves a runtime service.
Public method | SetupRuntime | Sets up the runtime with a default runtime setup using the loader's runtime path and a null logger. Does nothing if the runtime has already been initialized. If you need more control over this behavior, call RuntimeBootstrap yourself.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


AddHintDirectory Method

GallioLoader.AddHintDirectory Method
[image]

Adds a hint directory to the assembly resolver.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddHintDirectory( _
ByVal path As String _
) _
Implements IGallioLoader.AddHintDirectory
C#
public void AddHintDirectory(
string path
)
C++
public:
void AddHintDirectory(
String path
) sealed
J#
public void AddHintDirectory(
string path
)
JScript
public function AddHintDirectory(
path : String
)

Parameters

path
The path of the hint directory to add

Implements

IGallioLoader.AddHintDirectory

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


CreateRemoteEnvironment Method

GallioLoader.CreateRemoteEnvironment Method
[image]

Creates a private AppDomain that Gallio can reside in.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRemoteEnvironment() As IGallioRemoteEnvironment
C#
public static IGallioRemoteEnvironment CreateRemoteEnvironment()
C++
public:
static IGallioRemoteEnvironment CreateRemoteEnvironment()
J#
public static IGallioRemoteEnvironment CreateRemoteEnvironment()
JScript
public static function CreateRemoteEnvironment() : IGallioRemoteEnvironment

Return Value

The remote environment

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if Gallio does not appear to be installed
SafeException | Thrown if the operation could not be performed

Remarks

If you need the Gallio runtime, then you should also call SetupRuntime on the environment's loader.

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


GetApplicationVersion Method

GallioLoader.GetApplicationVersion Method
[image]

Gets the application version given its primary assembly. Uses the assembly file version if available.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetApplicationVersion( _
ByVal assembly As Assembly _
) As Version
C#
public static Version GetApplicationVersion(
Assembly assembly
)
C++
public:
static Version GetApplicationVersion(
Assembly assembly
)
J#
public static Version GetApplicationVersion(
Assembly assembly
)
JScript
public static function GetApplicationVersion(
assembly : Assembly
) : Version

Parameters

assembly
The assembly

Return Value

The assembly's file version

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


GetDefaultRuntimePath Method

GallioLoader.GetDefaultRuntimePath Method
[image]

Gets the runtime path that will be used by default by the loader. The path is determined by looking up the location of the Gallio installation in the registry. It may be overridden by setting the development runtime path key.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultRuntimePath() As String
C#
public static string GetDefaultRuntimePath()
C++
public:
static String GetDefaultRuntimePath()
J#
public static string GetDefaultRuntimePath()
JScript
public static function GetDefaultRuntimePath() : String

Return Value

The installed runtime path

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if Gallio does not appear to be installed

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Initialize Method

GallioLoader.Initialize Method

Initializes the Gallio loader (if not already initialized) and returns its singleton reference.

Overload List

Name | Description
Initialize | Initializes the Gallio loader (if not already initialized) and returns its singleton reference.
Initialize (String) | Initializes the Gallio loader (if not already initialized) and returns its singleton reference.

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Initialize Method ()

GallioLoader.Initialize Method ()
See Also Example
[image]

Initializes the Gallio loader (if not already initialized) and returns its singleton reference.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Initialize() As IGallioLoader
C#
public static IGallioLoader Initialize()
C++
public:
static IGallioLoader Initialize()
J#
public static IGallioLoader Initialize()
JScript
public static function Initialize() : IGallioLoader

Return Value

The loader

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if Gallio does not appear to be installed
SafeException | Thrown if the operation could not be performed

See Also

GallioLoader Class
Gallio.Loader Namespace
GallioLoader.Initialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Initialize Method (String)

GallioLoader.Initialize Method (String)
See Also Example
[image]

Initializes the Gallio loader (if not already initialized) and returns its singleton reference.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Initialize( _
ByVal runtimePath As String _
) As IGallioLoader
C#
public static IGallioLoader Initialize(
string runtimePath
)
C++
public:
static IGallioLoader Initialize(
String runtimePath
)
J#
public static IGallioLoader Initialize(
string runtimePath
)
JScript
public static function Initialize(
runtimePath : String
) : IGallioLoader

Parameters

runtimePath
The runtime path from which to load Gallio, or null to determine it automatically

Return Value

The loader

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if Gallio does not appear to be installed
SafeException | Thrown if the operation could not be performed

See Also

GallioLoader Class
Gallio.Loader Namespace
GallioLoader.Initialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


InitializeLifetimeService Method

GallioLoader.InitializeLifetimeService Method
[image]

Obtains a lifetime service object to control the lifetime policy for this instance.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function InitializeLifetimeService() As Object
C#
public override object InitializeLifetimeService()
C++
public:
virtual Object InitializeLifetimeService() override
J#
public override object InitializeLifetimeService()
JScript
public override function InitializeLifetimeService() : Object

Return Value

An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the LeaseManagerPollTime property.

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


InitializeRemote Method

GallioLoader.InitializeRemote Method

Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.

Overload List

Name | Description
InitializeRemote (AppDomain) | Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.
InitializeRemote (AppDomain, String) | Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


InitializeRemote Method (AppDomain)

GallioLoader.InitializeRemote Method (AppDomain)
See Also Example
[image]

Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function InitializeRemote( _
ByVal appDomain As AppDomain _
) As IGallioLoader
C#
public static IGallioLoader InitializeRemote(
AppDomain appDomain
)
C++
public:
static IGallioLoader InitializeRemote(
AppDomain appDomain
)
J#
public static IGallioLoader InitializeRemote(
AppDomain appDomain
)
JScript
public static function InitializeRemote(
appDomain : AppDomain
) : IGallioLoader

Parameters

appDomain
The AppDomain in which to initialize the loader

Return Value

The loader

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if appDomain is null
InvalidOperationException | Thrown if Gallio does not appear to be installed
SafeException | Thrown if the operation could not be performed

See Also

GallioLoader Class
Gallio.Loader Namespace
GallioLoader.InitializeRemote Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


InitializeRemote Method (AppDomain, String)

GallioLoader.InitializeRemote Method (AppDomain, String)
See Also Example
[image]

Remotely initializes the Gallio loader (if not already initialized) and returns its singleton reference within a foreign AppDomain.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function InitializeRemote( _
ByVal appDomain As AppDomain, _
ByVal runtimePath As String _
) As IGallioLoader
C#
public static IGallioLoader InitializeRemote(
AppDomain appDomain,
string runtimePath
)
C++
public:
static IGallioLoader InitializeRemote(
AppDomain appDomain,
String runtimePath
)
J#
public static IGallioLoader InitializeRemote(
AppDomain appDomain,
string runtimePath
)
JScript
public static function InitializeRemote(
appDomain : AppDomain,
runtimePath : String
) : IGallioLoader

Parameters

appDomain
The AppDomain in which to initialize the loader
runtimePath
The runtime path from which to load Gallio, or null to determine it automatically

Return Value

The loader

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if appDomain is null
InvalidOperationException | Thrown if Gallio does not appear to be installed
SafeException | Thrown if the operation could not be performed

See Also

GallioLoader Class
Gallio.Loader Namespace
GallioLoader.InitializeRemote Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Resolve Generic Method

GallioLoader.Resolve Generic Method

Resolves a runtime service.

Overload List

 | Name | Description
Public method | Resolve (Type) | Resolves a runtime service.
Public method | Resolve | Resolves a runtime service.

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Resolve Method (Type)

GallioLoader.Resolve Method (Type)
See Also Example
[image]

Resolves a runtime service.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal serviceType As Type _
) As Object _
Implements IGallioLoader.Resolve
C#
public object Resolve(
Type serviceType
)
C++
public:
Object Resolve(
Type serviceType
) sealed
J#
public object Resolve(
Type serviceType
)
JScript
public function Resolve(
serviceType : Type
) : Object

Parameters

serviceType
The type of service to resolve

Return Value

The resolved service

Implements

IGallioLoader.Resolve

See Also

GallioLoader Class
Gallio.Loader Namespace
GallioLoader.Resolve Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Resolve Generic Method ()

GallioLoader.Resolve Generic Method ()
See Also Example
[image]

Resolves a runtime service.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve(Of T)() _
Implements IGallioLoader.Resolve
C#
public T Resolve<T>()
C++
public:
T Resolve<T>() sealed
J#
public T Resolve<T>()
JScript
JScript does not support generic types and methods.

Return Value

The resolved service

Implements

IGallioLoader.Resolve

See Also

GallioLoader Class
Gallio.Loader Namespace
GallioLoader.Resolve Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SetupRuntime Method

GallioLoader.SetupRuntime Method
[image]

Sets up the runtime with a default runtime setup using the loader's runtime path and a null logger. Does nothing if the runtime has already been initialized.

If you need more control over this behavior, call RuntimeBootstrap yourself.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetupRuntime() _
Implements IGallioLoader.SetupRuntime
C#
public void SetupRuntime()
C++
public:
void SetupRuntime() sealed
J#
public void SetupRuntime()
JScript
public function SetupRuntime()

Implements

IGallioLoader.SetupRuntime

See Also

GallioLoader Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


IGallioLoader Interface

IGallioLoader Interface
See Also Example Members
[image]

Provides an interface for interacting with the Gallio Loader.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Interface IGallioLoader
C#
public interface IGallioLoader
C++
interface class IGallioLoader
J#
public interface IGallioLoader
JScript
public interface IGallioLoader

Types that implement IGallioLoader

Type Description
Gallio.Loader.GallioLoader

The Gallio loader provides access to installed Gallio assemblies so that we can reference them even if they are not copied locally.

We must avoid copying these assemblies because it is possible for multiple copies to be loaded in the same process simultaneously in different load context (Load / LoadFrom / LoadFile). When multiple copies of the same assembly are loaded their types are considered distinct and they cannot reliably exchange information with other components (like plugins). This problem was actually observed when two different Visual Studio add-ins installed in different locations were loaded at the same time.

The Gallio loader may be used in situations where 3rd party integration mandates the installation of a Gallio-dependent assembly outside of the Gallio installation path. It is fairly typical for application plugin models.

The loader itself will typically be loaded from the GAC or copy-local as usual. It will then springboard into the locally installed copy of Gallio which is found by searching the registry. It is also possible to specify the location of the Gallio installation explicitly instead.

Once the loader has been initialized, all Gallio types should become accessible. In particular, the runtime can then be initialized.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

See Also

IGallioLoader Members
Gallio.Loader Namespace
GallioLoader

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


IGallioLoader Members

IGallioLoader Members
See Also Example Properties Methods
[image]

Provides an interface for interacting with the Gallio Loader.

The following tables list the members exposed by IGallioLoader.

Public Properties

 | Name | Description
Public property | RuntimePath | Gets the Gallio runtime path.
Top

Public Methods

 | Name | Description
Public method | AddHintDirectory | Adds a hint directory to the assembly resolver.
Public method | Resolve | Overloaded. Resolves a runtime service.
Public method | SetupRuntime | Sets up the runtime with a default runtime setup using the loader's runtime path and a null logger. Does nothing if the runtime has already been initialized. If you need more control over this behavior, call RuntimeBootstrap yourself.
Top

See Also

IGallioLoader Interface
Gallio.Loader Namespace
GallioLoader

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Properties

IGallioLoader Properties
[image]

Public Properties

 | Name | Description
Public property | RuntimePath | Gets the Gallio runtime path.
Top

See Also

IGallioLoader Interface
Gallio.Loader Namespace
GallioLoader

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


RuntimePath Property

IGallioLoader.RuntimePath Property
[image]

Gets the Gallio runtime path.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RuntimePath As String
C#
string RuntimePath { get; }
C++
property string RuntimePath abstract {
String get();
}
J#
/** property */
public string get_RuntimePath();
JScript
public function get RuntimePath() : String

Exceptions

Exception Type | Condition
SafeException | Thrown if the operation could not be performed

See Also

IGallioLoader Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Methods

IGallioLoader Methods
[image]

Public Methods

 | Name | Description
Public method | AddHintDirectory | Adds a hint directory to the assembly resolver.
Public method | Resolve | Overloaded. Resolves a runtime service.
Public method | SetupRuntime | Sets up the runtime with a default runtime setup using the loader's runtime path and a null logger. Does nothing if the runtime has already been initialized. If you need more control over this behavior, call RuntimeBootstrap yourself.
Top

See Also

IGallioLoader Interface
Gallio.Loader Namespace
GallioLoader

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


AddHintDirectory Method

IGallioLoader.AddHintDirectory Method
[image]

Adds a hint directory to the assembly resolver.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Sub AddHintDirectory( _
ByVal path As String _
)
C#
void AddHintDirectory(
string path
)
C++
void AddHintDirectory(
String path
) abstract
J#
void AddHintDirectory(
string path
)
JScript
function AddHintDirectory(
path : String
)

Parameters

path
The path of the hint directory to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null
SafeException | Thrown if the operation could not be performed

See Also

IGallioLoader Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Resolve Generic Method

IGallioLoader.Resolve Generic Method

Resolves a runtime service.

Overload List

 | Name | Description
Public method | Resolve (Type) | Resolves a runtime service.
Public method | Resolve | Resolves a runtime service.

See Also

IGallioLoader Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Resolve Method (Type)

IGallioLoader.Resolve Method (Type)
See Also Example
[image]

Resolves a runtime service.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Resolve( _
ByVal serviceType As Type _
) As Object
C#
public abstract object Resolve(
Type serviceType
)
C++
public:
Object Resolve(
Type serviceType
) abstract
J#
public abstract object Resolve(
Type serviceType
)
JScript
public abstract function Resolve(
serviceType : Type
) : Object

Parameters

serviceType
The type of service to resolve

Return Value

The resolved service

Exceptions

Exception Type | Condition
SafeException | Thrown if the operation could not be performed

See Also

IGallioLoader Interface
Gallio.Loader Namespace
IGallioLoader.Resolve Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Resolve Generic Method ()

IGallioLoader.Resolve Generic Method ()
See Also Example
[image]

Resolves a runtime service.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Resolve(Of T)()
C#
public abstract T Resolve<T>()
C++
public:
T Resolve<T>() abstract
J#
public abstract T Resolve<T>()
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of service to resolve

Return Value

The resolved service

Exceptions

Exception Type | Condition
SafeException | Thrown if the operation could not be performed

See Also

IGallioLoader Interface
Gallio.Loader Namespace
IGallioLoader.Resolve Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SetupRuntime Method

IGallioLoader.SetupRuntime Method
[image]

Sets up the runtime with a default runtime setup using the loader's runtime path and a null logger. Does nothing if the runtime has already been initialized.

If you need more control over this behavior, call RuntimeBootstrap yourself.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Sub SetupRuntime()
C#
void SetupRuntime()
C++
void SetupRuntime() abstract
J#
void SetupRuntime()
JScript
function SetupRuntime()

Exceptions

Exception Type | Condition
SafeException | Thrown if the operation could not be performed

See Also

IGallioLoader Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


IGallioRemoteEnvironment Interface

IGallioRemoteEnvironment Interface
See Also Example Members
[image]

Provides access to an instance of the Gallio runtime that is running in a foreign AppDomain.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Interface IGallioRemoteEnvironment
Implements IDisposable
C#
public interface IGallioRemoteEnvironment : IDisposable
C++
interface class IGallioRemoteEnvironment : IDisposable
J#
public interface IGallioRemoteEnvironment implements IDisposable
JScript
public interface IGallioRemoteEnvironment extends IDisposable

See Also

IGallioRemoteEnvironment Members
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


IGallioRemoteEnvironment Members

IGallioRemoteEnvironment Members
See Also Example Properties
[image]

Provides access to an instance of the Gallio runtime that is running in a foreign AppDomain.

The following tables list the members exposed by IGallioRemoteEnvironment.

Public Properties

 | Name | Description
Public property | AppDomain | Gets the remote AppDomain.
Public property | Loader | Gets the remote loader.
Top

See Also

IGallioRemoteEnvironment Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Properties

IGallioRemoteEnvironment Properties
[image]

Public Properties

 | Name | Description
Public property | AppDomain | Gets the remote AppDomain.
Public property | Loader | Gets the remote loader.
Top

See Also

IGallioRemoteEnvironment Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


AppDomain Property

IGallioRemoteEnvironment.AppDomain Property
[image]

Gets the remote AppDomain.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AppDomain As AppDomain
C#
AppDomain AppDomain { get; }
C++
property AppDomain AppDomain abstract {
AppDomain get();
}
J#
/** property */
public AppDomain get_AppDomain();
JScript
public function get AppDomain() : AppDomain

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the remote environment has been disposed

See Also

IGallioRemoteEnvironment Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Loader Property

IGallioRemoteEnvironment.Loader Property
[image]

Gets the remote loader.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Loader As IGallioLoader
C#
IGallioLoader Loader { get; }
C++
property IGallioLoader Loader abstract {
IGallioLoader get();
}
J#
/** property */
public IGallioLoader get_Loader();
JScript
public function get Loader() : IGallioLoader

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the remote environment has been disposed

See Also

IGallioRemoteEnvironment Interface
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Class

SafeException Class
See Also Example Members
[image]

An exception that expresses a problem in a manner that may be safely communicated across a remote context to a client that may not be able to load the original exception type.

Using this type prevents spurious SerializationException exceptions from being thrown due to the server exposing an internal exception type that is not accessible to the client.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class SafeException
Inherits Exception
C#
[SerializableAttribute]
public class SafeException : Exception
C++
[SerializableAttribute]
ref class SafeException : Exception
J#
/** @attribute SerializableAttribute() */
public class SafeException extends Exception
JScript
public
SerializableAttribute
class SafeException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Loader.SafeException

See Also

SafeException Members
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Members

SafeException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

An exception that expresses a problem in a manner that may be safely communicated across a remote context to a client that may not be able to load the original exception type.

Using this type prevents spurious SerializationException exceptions from being thrown due to the server exposing an internal exception type that is not accessible to the client.

The following tables list the members exposed by SafeException.

Public Constructors

Name | Description
SafeException | Overloaded. Initializes a new instance of the SafeException class.
Top

Protected Constructors

Name | Description
SafeException | Overloaded. Initializes a new instance of the SafeException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
 | Wrap | Wraps an exception as a SafeException.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
SafeException | Overloaded. Initializes a new instance of the SafeException class.
Top

See Also

SafeException Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Constructor

SafeException Constructor

Initializes a new instance of the SafeException class.

Overload List

 | Name | Description
Public method | SafeException | Creates an exception.
Family method | SafeException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | SafeException (String) | Creates an exception.
Public method | SafeException (String, Exception) | Creates an exception.

See Also

SafeException Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Constructor ()

SafeException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SafeException()
C++
public:
SafeException() sealed
J#
public SafeException()
JScript
public function SafeException()

See Also

SafeException Class
Gallio.Loader Namespace
SafeException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Constructor (SerializationInfo, StreamingContext)

SafeException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected SafeException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
SafeException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected SafeException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function SafeException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

SafeException Class
Gallio.Loader Namespace
SafeException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Constructor (String)

SafeException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public SafeException(
string message
)
C++
public:
SafeException(
String message
) sealed
J#
public SafeException(
string message
)
JScript
public function SafeException(
message : String
)

Parameters

message
The message

See Also

SafeException Class
Gallio.Loader Namespace
SafeException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


SafeException Constructor (String, Exception)

SafeException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public SafeException(
string message,
Exception innerException
)
C++
public:
SafeException(
String message,
Exception innerException
) sealed
J#
public SafeException(
string message,
Exception innerException
)
JScript
public function SafeException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

SafeException Class
Gallio.Loader Namespace
SafeException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Methods

SafeException Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
 | Wrap | Wraps an exception as a SafeException.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SafeException Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Wrap Method

SafeException.Wrap Method
[image]

Wraps an exception as a SafeException.

Namespace: Gallio.Loader
Assembly: Gallio.Loader (in Gallio.Loader.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal ex As Exception _
) As SafeException
C#
public static SafeException Wrap(
Exception ex
)
C++
public:
static SafeException Wrap(
Exception ex
)
J#
public static SafeException Wrap(
Exception ex
)
JScript
public static function Wrap(
ex : Exception
) : SafeException

Parameters

ex
The exception type

Return Value

The wrapped exception

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if ex is null

See Also

SafeException Class
Gallio.Loader Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Loader [3.0.6.0]


Gallio.Model

Gallio.Model Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AggregateTestExplorer | An aggregate test explorer combines multiple test explorers from different sources to incorporate all of their contributions.
Public class | Annotation | An annotation associates a message with a source code location to inform the user about a problem.
Public class | BaseInfo | Abstract base class for read-only reflection model objects. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseInfoList | The abstract base class of a list that wraps model objects with their corresponding reflection types derived from BaseInfo. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseTest | Base implementation of ITest.
Public class | BaseTestComponent | Base implementation of ITestComponent. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseTestExplorer | A base test explorer that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseTestFramework | Abstract base class for test framework implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseTestParameter | Base implementation of ITestParameter.
Public class | BaseTestStep | Base implementation of ITestStep.
Public class | DefaultTestPackageExplorerFactory | Default implementation of a test package explorer factory that aggregates over all registered frameworks.
Public class | LifecyclePhases | Defines the names of common test step lifecycle phases. Custom phases may also be defined. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | MetadataKeys | Provides common metadata keys. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ModelException | The type of exception thrown when test model and test framework operations fail.
Public class | ModelUtils | Provides utility functions for manipulating the object model. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | NullTestExplorer | A null test explorer. This class cannot be inherited.
Public class | RootTest | The root test in the test tree.
Public class | TestComponentInfo | A read-only implementation of ITestComponent for reflection. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestDomainSetup | Specifies setup options for a test domain. A test domain represents an isolated host environment within which a subset of a test package will be loaded, explored and run.
Public class | TestExplorationOptions | Provides options that control how test exploration occurs. This class cannot be inherited.
Public class | TestInfo | A read-only implementation of ITest for reflection. This class cannot be inherited.
Public class | TestInfoList | Wraps a list of ITest for reflection. This class cannot be inherited.
Public class | TestKinds | Specifies the kind of a test component. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | TestModel | The test model provides access to the contents of the test tree generated from a test package by the test enumeration process. This class cannot be inherited.
Public class | TestPackage | A test package describes the resources that have been loaded in in preparation for enumerating and running the tests they contain. This class cannot be inherited.
Public class | TestPackageConfig | A test package configuration specifies the options used by a test runner to load tests into memory for execution. The package may contain multiple test assemblies that are to be loaded together for test execution. It can also be serialized as XML or using .Net remoting for persistence and remote operation. This class cannot be inherited.
Public class | TestParameterInfo | A read-only implementation of ITestParameter for reflection. This class cannot be inherited.
Public class | TestParameterInfoList | Wraps a list of ITestParameter for reflection. This class cannot be inherited.
Public class | TestResult | A test result describes the final result of having executed a test. This class cannot be inherited.
Public class | TestStepInfo | A read-only implementation of ITestStep for reflection. This class cannot be inherited.

Interfaces

Interface | Description
Public interface ITest

A test object represents a parameterized test case or test container. The test parameters are used as placeholders for data-binding during test execution. A single test can produce multiple steps () at runtime.

A ITest can be thought of as a declarative artifact that describes about what a test "looks like" from the outside based on available reflective metadata. A ITestStep is then the runtime counterpart of a ITest that is created to describe different parameter bindigns or other characteristics of a test's structure that become manifest only at runtime.

A test may depend on one or more other tests. When a test fails, the tests that depend on it are also automatically considered failures. Moreover, the test harness ensures that a test will only run once all of its dependencies have completed execution successfully. A run-time error will occur when the system detects the presence of circular test dependencies or attempts to execute a test concurrently with its dependencies.

A test contain child tests. The children of a test are executed in dependency order within the scope of the parent test. Thus the parent test may setup/teardown the execution environment used to execute its children. Tests that belong to different subtrees are executed in relative isolation within the common environment established by their common parent.

The object model distinguishes between tests that represent individual test cases and other test containers. Test containers are skipped if they do not contain any test cases or if none of their test cases have been selected for execution.

Public interface | ITestComponent | Common interface for elements in the test object model. All components have a name for presentation, metadata for annotations, and a code reference to its point of definition.
Public interface ITestExplorer

A test explorer scans a volume of code using reflection to build a partial test tree. The tests constructed in this manner may not be complete or executable but they provide useful insight into the layout of the test suite that can subsequently be used to drive the test runner.

As a test explorer explores test assemblies and types, it incrementally populates a TestModel with its discoveries. The TestModel is guaranteed to contain all of the tests explicitly explored, but it may also contain other tests that were discovered by the explorer along the way. For example, a valid implementation of ITestExplorer could implement ExploreType by exploring the entire assembly as performed by ExploreAssembly.

Public interface | ITestFramework | The test framework service provides support for enumerating and executing tests that belong to some test framework. A new third party test framework may be supported by defining and registering a suitable implementation of this interface.
Public interface | ITestPackageExplorerFactory | Creates test explorers for packages.
Public interface ITestParameter

A test parameter describes a formal parameter of a ITest to which a value may be bound and used during test execution.

The Name property of a test parameter should be unique among the set parameters belonging to its Owner to ensure that it can be differentiated from others. However, this constraint is not enforced.

Public interface ITestStep

A test step is a delimited region of a test defined at run-time. Each test that is executed consists of at least one step: the "primary" step. During execution, each test may spawn additional nested steps that may run in parallel or in series with one another as required.

A test step may be used to describe a particular instance of a data driven test. It can also be used to generate a completely dynamic hierarchy at runtime that mirrors and extends the static test hierarchy with new information derived from the actual execution of the test.

Each step has its own execution log and test result (pass/fail/inconclusive). Therefore a multi-step test may possess multiple execution logs and test results. This is deliberate. Think of a ITest as being the declarative component of a test that specifies which test method to invoke and its arguments. An ITestStep is the runtime counterpart of the ITest that captures output and control flow information about part or all of the test.

A test step also has metadata that can be update at run-time to carry additional declarative information about the step.

Structures

 | Structure | Description
Public structure | TestOutcome | Describes the outcome of a test. An outcome consists of two parts. First, a required Status that describes whether test passed, failed or was inconclusive. Second, an optional Category that enables different outcomes with the same status to be distinguished. The category also provides an opportunity to extend the definition of a test outcome to include custom semantic details.

Enumerations

 | Enumeration | Description
Public enumeration | AnnotationType | Specifies the type of an annotation.
Public enumeration | TestStatus | Describes whether a test passed, failed, was skipped or was inconclusive. The status codes are ranked in order of severity from least to greatest as follows: Passed, Skipped, Inconclusive, Failed.


AggregateTestExplorer Class

AggregateTestExplorer Class
See Also Example Members
[image]

An aggregate test explorer combines multiple test explorers from different sources to incorporate all of their contributions.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class AggregateTestExplorer
Inherits BaseTestExplorer
C#
public class AggregateTestExplorer : BaseTestExplorer
C++
ref class AggregateTestExplorer : BaseTestExplorer
J#
public class AggregateTestExplorer extends BaseTestExplorer
JScript
public class AggregateTestExplorer extends BaseTestExplorer

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestExplorer
Gallio.Model.AggregateTestExplorer

See Also

AggregateTestExplorer Members
Gallio.Model Namespace


AggregateTestExplorer Members

AggregateTestExplorer Members
See Also Example Constructors Properties Methods
[image]

An aggregate test explorer combines multiple test explorers from different sources to incorporate all of their contributions.

The following tables list the members exposed by AggregateTestExplorer.

Public Constructors

 | Name | Description
Public method | AggregateTestExplorer | Creates an empty aggregate test explorer.
Top

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests. (inherited from BaseTestExplorer)
Top

Public Methods

 | Name | Description
Public method | AddExplorersForRequestedFrameworks | Adds test explorers for the frameworks requested by the test model's test package.
Public method | AddTestExplorer | Adds a test explorer to the aggregate.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly | Overridden. Explores the tests defined by an assembly and links them into the TestModel.
Public method | ExploreType | Overridden. Explores the tests defined by a type and links them into the TestModel.
Public method | FinishModel | Overridden. Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


AggregateTestExplorer Constructor

AggregateTestExplorer Constructor
[image]

Creates an empty aggregate test explorer.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModel As TestModel _
)
C#
public AggregateTestExplorer(
TestModel testModel
)
C++
public:
AggregateTestExplorer(
TestModel testModel
) sealed
J#
public AggregateTestExplorer(
TestModel testModel
)
JScript
public function AggregateTestExplorer(
testModel : TestModel
)

Parameters

testModel
The test model that is incrementally populated by the test explorer as it explores tests.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModel is null

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


Methods

AggregateTestExplorer Methods
[image]

Public Methods

 | Name | Description
Public method | AddExplorersForRequestedFrameworks | Adds test explorers for the frameworks requested by the test model's test package.
Public method | AddTestExplorer | Adds a test explorer to the aggregate.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly | Overridden. Explores the tests defined by an assembly and links them into the TestModel.
Public method | ExploreType | Overridden. Explores the tests defined by a type and links them into the TestModel.
Public method | FinishModel | Overridden. Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


AddExplorersForRequestedFrameworks Method

AggregateTestExplorer.AddExplorersForRequestedFrameworks Method
See Also Example
[image]

Adds test explorers for the frameworks requested by the test model's test package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddExplorersForRequestedFrameworks( _
ByVal frameworks As IEnumerable(Of ITestFramework) _
)
C#
public void AddExplorersForRequestedFrameworks(
IEnumerable<ITestFramework> frameworks
)
C++
public:
void AddExplorersForRequestedFrameworks(
IEnumerable<ITestFramework> frameworks
) sealed
J#
public void AddExplorersForRequestedFrameworks(
IEnumerable<ITestFramework> frameworks
)
JScript
public function AddExplorersForRequestedFrameworks(
frameworks : IEnumerable<ITestFramework>
)

Parameters

frameworks
The frameworks

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if frameworks is null

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


AddTestExplorer Method

AggregateTestExplorer.AddTestExplorer Method
[image]

Adds a test explorer to the aggregate.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddTestExplorer( _
ByVal explorer As ITestExplorer _
)
C#
public void AddTestExplorer(
ITestExplorer explorer
)
C++
public:
void AddTestExplorer(
ITestExplorer explorer
) sealed
J#
public void AddTestExplorer(
ITestExplorer explorer
)
JScript
public function AddTestExplorer(
explorer : ITestExplorer
)

Parameters

explorer
The explorer to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if explorer is null
ArgumentException | Thrown if explorer has a different TestModel

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


ExploreAssembly Method

AggregateTestExplorer.ExploreAssembly Method
[image]

Explores the tests defined by an assembly and links them into the TestModel.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub ExploreAssembly( _
ByVal assembly As IAssemblyInfo, _
ByVal consumer As Action(Of ITest) _
) _
Implements ITestExplorer.ExploreAssembly
C#
public override void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
C++
public:
virtual void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
) override
J#
public override void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
JScript
public override function ExploreAssembly(
assembly : IAssemblyInfo,
consumer : Action<ITest>
)

Parameters

assembly
The assembly
consumer
An action to perform on each assembly-level test explored, or null if no action is required

Implements

ITestExplorer.ExploreAssembly

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


ExploreType Method

AggregateTestExplorer.ExploreType Method
[image]

Explores the tests defined by a type and links them into the TestModel.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub ExploreType( _
ByVal type As ITypeInfo, _
ByVal consumer As Action(Of ITest) _
) _
Implements ITestExplorer.ExploreType
C#
public override void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
C++
public:
virtual void ExploreType(
ITypeInfo type,
Action<ITest> consumer
) override
J#
public override void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
JScript
public override function ExploreType(
type : ITypeInfo,
consumer : Action<ITest>
)

Parameters

type
The type
consumer
An action to perform on each type-level test explored, or null if no action is required

Implements

ITestExplorer.ExploreType

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


FinishModel Method

AggregateTestExplorer.FinishModel Method
[image]

Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub FinishModel() _
Implements ITestExplorer.FinishModel
C#
public override void FinishModel()
C++
public:
virtual void FinishModel() override
J#
public override void FinishModel()
JScript
public override function FinishModel()

Implements

ITestExplorer.FinishModel

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


IsTest Method

AggregateTestExplorer.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTest( _
ByVal element As ICodeElementInfo _
) As Boolean _
Implements ITestExplorer.IsTest
C#
public override bool IsTest(
ICodeElementInfo element
)
C++
public:
virtual bool IsTest(
ICodeElementInfo element
) override
J#
public override bool IsTest(
ICodeElementInfo element
)
JScript
public override function IsTest(
element : ICodeElementInfo
) : bool

Parameters

element
The element

Return Value

True if the element represents a test

Implements

ITestExplorer.IsTest

See Also

AggregateTestExplorer Class
Gallio.Model Namespace


Annotation Class

Annotation Class
See Also Example Members
[image]

An annotation associates a message with a source code location to inform the user about a problem.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class Annotation
C#
[SerializableAttribute]
public class Annotation
C++
[SerializableAttribute]
ref class Annotation
J#
/** @attribute SerializableAttribute() */
public class Annotation
JScript
public
SerializableAttribute
class Annotation

Inheritance Hierarchy

System.Object
Gallio.Model.Annotation

See Also

Annotation Members
Gallio.Model Namespace


Annotation Members

Annotation Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

An annotation associates a message with a source code location to inform the user about a problem.

The following tables list the members exposed by Annotation.

Public Constructors

Name | Description
Annotation | Overloaded.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets the code element associated with the annotation.
Public property | Details | Gets additional details such as exception text, or null if none.
Public property | Message | Gets the annotation message.
Public property | Type | Gets the annotation type.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Annotation | Overloaded.
Top

See Also

Annotation Class
Gallio.Model Namespace


Annotation Constructor

Annotation Constructor

Overload List

 | Name | Description
Public method | Annotation (AnnotationType, ICodeElementInfo, String) | Creates an annotation with no details.
Public method | Annotation (AnnotationType, ICodeElementInfo, String, Exception) | Creates an annotation with a detail exception.
Public method | Annotation (AnnotationType, ICodeElementInfo, String, String) | Creates an annotation with a detail message string.

See Also

Annotation Class
Gallio.Model Namespace


Annotation Constructor (AnnotationType, ICodeElementInfo, String)

Annotation Constructor (AnnotationType, ICodeElementInfo, String)
See Also Example
[image]

Creates an annotation with no details.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As AnnotationType, _
ByVal codeElement As ICodeElementInfo, _
ByVal message As String _
)
C#
public Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
string message
)
C++
public:
Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
String message
) sealed
J#
public Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
string message
)
JScript
public function Annotation(
type : AnnotationType,
codeElement : ICodeElementInfo,
message : String
)

Parameters

type
The annotation type
codeElement
The associated code element, or null if none
message
The annotation message

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

Annotation Class
Gallio.Model Namespace
Annotation Constructor Overload List


Annotation Constructor (AnnotationType, ICodeElementInfo, String, Exception)

Annotation Constructor (AnnotationType, ICodeElementInfo, String, Exception)
See Also Example
[image]

Creates an annotation with a detail exception.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As AnnotationType, _
ByVal codeElement As ICodeElementInfo, _
ByVal message As String, _
ByVal ex As Exception _
)
C#
public Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
string message,
Exception ex
)
C++
public:
Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
String message,
Exception ex
) sealed
J#
public Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
string message,
Exception ex
)
JScript
public function Annotation(
type : AnnotationType,
codeElement : ICodeElementInfo,
message : String,
ex : Exception
)

Parameters

type
The annotation type
codeElement
The associated code element, or null if none
message
The annotation message
ex
The exception to use as additional details or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

Annotation Class
Gallio.Model Namespace
Annotation Constructor Overload List


Annotation Constructor (AnnotationType, ICodeElementInfo, String, String)

Annotation Constructor (AnnotationType, ICodeElementInfo, String, String)
See Also Example
[image]

Creates an annotation with a detail message string.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As AnnotationType, _
ByVal codeElement As ICodeElementInfo, _
ByVal message As String, _
ByVal details As String _
)
C#
public Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
string message,
string details
)
C++
public:
Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
String message,
String details
) sealed
J#
public Annotation(
AnnotationType type,
ICodeElementInfo codeElement,
string message,
string details
)
JScript
public function Annotation(
type : AnnotationType,
codeElement : ICodeElementInfo,
message : String,
details : String
)

Parameters

type
The annotation type
codeElement
The associated code element, or null if none
message
The annotation message
details
Additional details such as exception text or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

Annotation Class
Gallio.Model Namespace
Annotation Constructor Overload List


Properties

Annotation Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets the code element associated with the annotation.
Public property | Details | Gets additional details such as exception text, or null if none.
Public property | Message | Gets the annotation message.
Public property | Type | Gets the annotation type.
Top

See Also

Annotation Class
Gallio.Model Namespace


CodeElement Property

Annotation.CodeElement Property
[image]

Gets the code element associated with the annotation.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CodeElement As ICodeElementInfo
C#
public ICodeElementInfo CodeElement { get; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

See Also

Annotation Class
Gallio.Model Namespace


Details Property

Annotation.Details Property
[image]

Gets additional details such as exception text, or null if none.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Details As String
C#
public string Details { get; }
C++
public property string Details sealed {
String get();
}
J#
/** property */
public string get_Details();
JScript
public function get Details() : String

See Also

Annotation Class
Gallio.Model Namespace


Message Property

Annotation.Message Property
[image]

Gets the annotation message.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
C++
public property string Message sealed {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

Annotation Class
Gallio.Model Namespace


Type Property

Annotation.Type Property
[image]

Gets the annotation type.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As AnnotationType
C#
public AnnotationType Type { get; }
C++
public property AnnotationType Type sealed {
AnnotationType get();
}
J#
/** property */
public AnnotationType get_Type();
JScript
public function get Type() : AnnotationType

See Also

Annotation Class
Gallio.Model Namespace


AnnotationType Enumeration

AnnotationType Enumeration
[image]

Specifies the type of an annotation.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum AnnotationType
C#
public enum AnnotationType
C++
public enum class AnnotationType
J#
public enum AnnotationType
JScript
public enum AnnotationType

Members

Member Name | Description
Info | An informational annotation.
Warning | A warning annotation.
Error | An error annotation.

See Also

Gallio.Model Namespace


BaseInfo Class

BaseInfo Class
See Also Example Members
[image]

Abstract base class for read-only reflection model objects. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseInfo
C#
public abstract class BaseInfo
C++
ref class BaseInfo abstract
J#
public class BaseInfo
JScript
public class BaseInfo

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfo
Gallio.Model.TestComponentInfo

See Also

BaseInfo Members
Gallio.Model Namespace


BaseInfo Members

BaseInfo Members
See Also Example Methods
[image]

Abstract base class for read-only reflection model objects. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseInfo.

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two objects for equality.
 | op_Inequality | Compares two objects for inequality.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseInfo Class
Gallio.Model Namespace


Methods

BaseInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two objects for equality.
 | op_Inequality | Compares two objects for inequality.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseInfo Class
Gallio.Model Namespace


Equals Method

BaseInfo.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (BaseInfo) | Compares this object's source for equality with the other's source.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

BaseInfo Class
Gallio.Model Namespace


Equals Method (BaseInfo)

BaseInfo.Equals Method (BaseInfo)
See Also Example
[image]

Compares this object's source for equality with the other's source.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As BaseInfo _
) As Boolean
C#
public bool Equals(
BaseInfo other
)
C++
public:
bool Equals(
BaseInfo other
) sealed
J#
public bool Equals(
BaseInfo other
)
JScript
public function Equals(
other : BaseInfo
) : bool

Parameters

other
The other object

Return Value

True if the objects are equal

See Also

BaseInfo Class
Gallio.Model Namespace
BaseInfo.Equals Overload List


Equals Method (Object)

BaseInfo.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

BaseInfo Class
Gallio.Model Namespace
BaseInfo.Equals Overload List


GetHashCode Method

BaseInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

BaseInfo Class
Gallio.Model Namespace


op_Equality Operator

BaseInfo.op_Equality Operator
[image]

Compares two objects for equality.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As BaseInfo, _
ByVal b As BaseInfo _
) As Boolean
C#
public static bool operator ==(
BaseInfo a,
BaseInfo b
)
C++
public:
static bool operator ==(
BaseInfo a,
BaseInfo b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Return Value

True if they are equal

See Also

BaseInfo Class
Gallio.Model Namespace


op_Inequality Operator

BaseInfo.op_Inequality Operator
[image]

Compares two objects for inequality.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As BaseInfo, _
ByVal b As BaseInfo _
) As Boolean
C#
public static bool operator !=(
BaseInfo a,
BaseInfo b
)
C++
public:
static bool operator !=(
BaseInfo a,
BaseInfo b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Return Value

True if they are not equal

See Also

BaseInfo Class
Gallio.Model Namespace


ToString Method

BaseInfo.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

BaseInfo Class
Gallio.Model Namespace


BaseInfoList Generic Class

BaseInfoList Generic Class
See Also Example Members
[image]

The abstract base class of a list that wraps model objects with their corresponding reflection types derived from BaseInfo. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public MustInherit Class BaseInfoList(Of TModel As Class, TInfo As {BaseInfo, TModel})
Implements IList(Of TInfo), ICollection(Of TInfo), IEnumerable(Of TInfo), IEnumerable
C#
[DefaultMemberAttribute("Item")]
public abstract class BaseInfoList<TModel, TInfo> : IList<TInfo>, ICollection<TInfo>, IEnumerable<TInfo>, IEnumerable where TModel : class where TInfo : BaseInfo, TModel
C++
[DefaultMemberAttribute(L"Item")]
ref class BaseInfoList<TModel, TInfo> abstract : IList<TInfo>, ICollection<TInfo>, IEnumerable<TInfo>, IEnumerable where TModel : class where TInfo : BaseInfo, TModel
J#
/** @attribute DefaultMemberAttribute("Item") */
public class BaseInfoList<TModel, TInfo> implements IList<TInfo>, ICollection<TInfo>, IEnumerable<TInfo>, IEnumerable
JScript
JScript does not support generic types and methods.

Type Parameters

TModel
The model object type
TInfo
The reflection type

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfoList<TModel,TInfo>
Gallio.Model.TestInfoList
Gallio.Model.TestParameterInfoList

See Also

BaseInfoList<TModel,TInfo> Members
Gallio.Model Namespace


BaseInfoList<TModel,TInfo> Members

BaseInfoList Members
See Also Example Properties Methods
[image]

The abstract base class of a list that wraps model objects with their corresponding reflection types derived from BaseInfo. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseInfoList<TModel,TInfo>.

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | AsModelList | Returns a wrapper for the list of elements using the model object's type instead of the reflection object's type.
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
 | Unwrap | Unwraps the specified output item.
Family method | Wrap | Wraps the specified input item.
Top

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Properties

BaseInfoList Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection.
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only.
Public property | Item |
Top

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Count Property

BaseInfoList.Count Property
[image]

Gets the number of elements contained in the ICollection.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<TInfo>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
JScript does not support generic types and methods.

Property Value

The number of elements contained in the ICollection.

Implements

ICollection<TInfo>.Count

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


IsReadOnly Property

BaseInfoList.IsReadOnly Property
[image]

Gets a value indicating whether the ICollection is read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean _
Implements ICollection<TInfo>.IsReadOnly
C#
public bool IsReadOnly { get; }
C++
public property bool IsReadOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsReadOnly();
JScript
JScript does not support generic types and methods.

Property Value

true if the ICollection is read-only; otherwise, false.

Implements

ICollection<TInfo>.IsReadOnly

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Item Property

BaseInfoList.Item Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal index As Integer _
)
C#
public TInfo this[
int index
] { get; }
C++
public property TInfo default[int index] sealed {
TInfo get(int index);
}
J#
/** property */
public TInfo get_Item(int index);
JScript
JScript does not support generic types and methods.

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Methods

BaseInfoList Methods
[image]

Public Methods

 | Name | Description
Public method | AsModelList | Returns a wrapper for the list of elements using the model object's type instead of the reflection object's type.
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
 | Unwrap | Unwraps the specified output item.
Family method | Wrap | Wraps the specified input item.
Top

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


AsModelList Method

BaseInfoList.AsModelList Method
[image]

Returns a wrapper for the list of elements using the model object's type instead of the reflection object's type.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AsModelList() As IList(Of TModel)
C#
public IList<TModel> AsModelList()
C++
public:
IList<TModel> AsModelList() sealed
J#
public IList<TModel> AsModelList()
JScript
JScript does not support generic types and methods.

Return Value

The model list

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Contains Method

BaseInfoList.Contains Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As TInfo _
) As Boolean _
Implements ICollection<TInfo>.Contains
C#
public bool Contains(
TInfo item
)
C++
public:
bool Contains(
TInfo item
) sealed
J#
public bool Contains(
TInfo item
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<TInfo>.Contains

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


CopyTo Method

BaseInfoList.CopyTo Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As TInfo(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<TInfo>.CopyTo
C#
public void CopyTo(
TInfo[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<TInfo>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
TInfo[] array,
int arrayIndex
)
JScript
JScript does not support generic types and methods.

Implements

ICollection<TInfo>.CopyTo

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


GetEnumerator Method

BaseInfoList.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of TInfo) _
Implements IEnumerable<TInfo>.GetEnumerator
C#
public IEnumerator<TInfo> GetEnumerator()
C++
public:
IEnumerator<TInfo> GetEnumerator() sealed
J#
public IEnumerator<TInfo> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable<TInfo>.GetEnumerator

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


IndexOf Method

BaseInfoList.IndexOf Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal item As TInfo _
) As Integer _
Implements IList<TInfo>.IndexOf
C#
public int IndexOf(
TInfo item
)
C++
public:
int IndexOf(
TInfo item
) sealed
J#
public int IndexOf(
TInfo item
)
JScript
JScript does not support generic types and methods.

Implements

IList<TInfo>.IndexOf

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Unwrap Method

BaseInfoList.Unwrap Method
[image]

Unwraps the specified output item.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function Unwrap( _
ByVal infoItem As TInfo _
)
C#
protected static TModel Unwrap(
TInfo infoItem
)
C++
protected:
static TModel Unwrap(
TInfo infoItem
)
J#
protected static TModel Unwrap(
TInfo infoItem
)
JScript
JScript does not support generic types and methods.

Parameters

infoItem
The output item

Return Value

The corresponding input item or null if the output item is a valid wrapper

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


Wrap Method

BaseInfoList.Wrap Method
[image]

Wraps the specified input item.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function Wrap( _
ByVal inputItem As TModel _
)
C#
protected abstract TInfo Wrap(
TModel inputItem
)
C++
protected:
TInfo Wrap(
TModel inputItem
) abstract
J#
protected abstract TInfo Wrap(
TModel inputItem
)
JScript
JScript does not support generic types and methods.

Parameters

inputItem
The input item

Return Value

The output item

See Also

BaseInfoList<TModel,TInfo> Class
Gallio.Model Namespace


BaseTest Class

BaseTest Class
See Also Example Members
[image]

Base implementation of ITest.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BaseTest
Inherits BaseTestComponent
Implements ITest
C#
public class BaseTest : BaseTestComponent, ITest
C++
ref class BaseTest : BaseTestComponent, ITest
J#
public class BaseTest extends BaseTestComponent implements ITest
JScript
public class BaseTest extends BaseTestComponent, ITest

Remarks

The base test implementation acts as a simple container for tests. Accordingly its kind is set to Group by default.

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTest
Gallio.Framework.Pattern.PatternTest
Gallio.Model.RootTest

See Also

BaseTest Members
Gallio.Model Namespace


BaseTest Members

BaseTest Members
See Also Example Constructors Properties Methods
[image]

Base implementation of ITest.

The following tables list the members exposed by BaseTest.

Public Constructors

 | Name | Description
Public method | BaseTest | Initializes a test initially without a parent.
Top

Public Properties

Name | Description
Public property | Children | Gets a read-only list of the children of this test.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | Dependencies | Gets a read-only list of the dependencies of this test.
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Public property | Id | Overridden. Gets the stable unique identifier of the component.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant.
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test.
Public property | TestControllerFactory
Top

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property.
Public method | AddDependency | Adds a test dependency.
Public method | AddParameter | Adds a test parameter and sets its Owner property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTest Class
Gallio.Model Namespace


BaseTest Constructor

BaseTest Constructor
[image]

Initializes a test initially without a parent.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
)
C#
public BaseTest(
string name,
ICodeElementInfo codeElement
)
C++
public:
BaseTest(
String name,
ICodeElementInfo codeElement
) sealed
J#
public BaseTest(
string name,
ICodeElementInfo codeElement
)
JScript
public function BaseTest(
name : String,
codeElement : ICodeElementInfo
)

Parameters

name
The name of the test
codeElement
The point of definition of the test, or null if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

BaseTest Class
Gallio.Model Namespace


Properties

BaseTest Properties
[image]

Public Properties

Name | Description
Public property | Children | Gets a read-only list of the children of this test.
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | Dependencies | Gets a read-only list of the dependencies of this test.
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Public property | Id | Overridden. Gets the stable unique identifier of the component.
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant.
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test.
Public property | TestControllerFactory
Top

See Also

BaseTest Class
Gallio.Model Namespace


Children Property

BaseTest.Children Property
[image]

Gets a read-only list of the children of this test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Children As IList(Of ITest) _
Implements ITest.Children
C#
public IList<ITest> Children { get; }
C++
public property IList<ITest> Children sealed {
IList<ITest> get();
}
J#
/** property */
public IList<ITest> get_Children();
JScript
public function get Children() : IList<ITest>

Implements

ITest.Children

See Also

BaseTest Class
Gallio.Model Namespace


Dependencies Property

BaseTest.Dependencies Property
[image]

Gets a read-only list of the dependencies of this test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dependencies As IList(Of ITest) _
Implements ITest.Dependencies
C#
public IList<ITest> Dependencies { get; }
C++
public property IList<ITest> Dependencies sealed {
IList<ITest> get();
}
J#
/** property */
public IList<ITest> get_Dependencies();
JScript
public function get Dependencies() : IList<ITest>

Implements

ITest.Dependencies

See Also

BaseTest Class
Gallio.Model Namespace


FullName Property

BaseTest.FullName Property
[image]

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String _
Implements ITest.FullName
C#
public string FullName { get; }
C++
public property string FullName sealed {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITest.FullName

See Also

BaseTest Class
Gallio.Model Namespace


Id Property

BaseTest.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Id As String _
Implements ITestComponent.Id
C#
public override string Id { get; }
C++
public override property string Id override {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Implements

ITestComponent.Id

See Also

BaseTest Class
Gallio.Model Namespace


IsTestCase Property

BaseTest.IsTestCase Property
[image]

Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTestCase As Boolean _
Implements ITest.IsTestCase
C#
public bool IsTestCase { get; set; }
C++
public property bool IsTestCase sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsTestCase();

/** property */
public void set_IsTestCase(bool value);
JScript
public function get IsTestCase() : bool

public function set IsTestCase(value : bool);

Implements

ITest.IsTestCase

See Also

BaseTest Class
Gallio.Model Namespace


LocalId Property

BaseTest.LocalId Property
[image]

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocalId As String _
Implements ITest.LocalId
C#
public string LocalId { get; }
C++
public property string LocalId sealed {
String get();
}
J#
/** property */
public string get_LocalId();
JScript
public function get LocalId() : String

Property Value

The locally unique identifier

Implements

ITest.LocalId

See Also

BaseTest Class
Gallio.Model Namespace


LocalIdHint Property

BaseTest.LocalIdHint Property
[image]

Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalIdHint As String
C#
public string LocalIdHint { get; set; }
C++
public property string LocalIdHint sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalIdHint();

/** property */
public void set_LocalIdHint(string value);
JScript
public function get LocalIdHint() : String

public function set LocalIdHint(value : String);

Property Value

The local id hint

See Also

BaseTest Class
Gallio.Model Namespace


Order Property

BaseTest.Order Property
[image]

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Order As Integer _
Implements ITest.Order
C#
public int Order { get; set; }
C++
public property int Order sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public function get Order() : int

public function set Order(value : int);

Property Value

The test execution order with respect to siblings, initially zero.

Implements

ITest.Order

See Also

BaseTest Class
Gallio.Model Namespace


Parameters Property

BaseTest.Parameters Property
[image]

Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IList(Of ITestParameter) _
Implements ITest.Parameters
C#
public IList<ITestParameter> Parameters { get; }
C++
public property IList<ITestParameter> Parameters sealed {
IList<ITestParameter> get();
}
J#
/** property */
public IList<ITestParameter> get_Parameters();
JScript
public function get Parameters() : IList<ITestParameter>

Implements

ITest.Parameters

See Also

BaseTest Class
Gallio.Model Namespace


Parent Property

BaseTest.Parent Property
[image]

Gets or sets the parent of this test, or null if this is the root test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Parent As ITest _
Implements ITest.Parent
C#
public ITest Parent { get; set; }
C++
public property ITest Parent sealed {
ITest get();
void set(ITest value);
}
J#
/** property */
public ITest get_Parent();

/** property */
public void set_Parent(ITest value);
JScript
public function get Parent() : ITest

public function set Parent(value : ITest);

Implements

ITest.Parent

See Also

BaseTest Class
Gallio.Model Namespace


TestControllerFactory Property

BaseTest.TestControllerFactory Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TestControllerFactory As Func(Of ITestController) _
Implements ITest.TestControllerFactory
C#
public virtual Func<ITestController> TestControllerFactory { get; }
C++
public virtual property Func<ITestController> TestControllerFactory {
Func<ITestController> get();
}
J#
/** property */
public Func<ITestController> get_TestControllerFactory();
JScript
public function get TestControllerFactory() : Func<ITestController>

Implements

ITest.TestControllerFactory

See Also

BaseTest Class
Gallio.Model Namespace


Methods

BaseTest Methods
[image]

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property.
Public method | AddDependency | Adds a test dependency.
Public method | AddParameter | Adds a test parameter and sets its Owner property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTest Class
Gallio.Model Namespace


AddChild Method

BaseTest.AddChild Method
[image]

Adds a child test and sets its Parent property.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddChild( _
ByVal test As ITest _
) _
Implements ITest.AddChild
C#
public void AddChild(
ITest test
)
C++
public:
void AddChild(
ITest test
) sealed
J#
public void AddChild(
ITest test
)
JScript
public function AddChild(
test : ITest
)

Parameters

test
The test to add as a child

Implements

ITest.AddChild

See Also

BaseTest Class
Gallio.Model Namespace


AddDependency Method

BaseTest.AddDependency Method
[image]

Adds a test dependency.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDependency( _
ByVal test As ITest _
) _
Implements ITest.AddDependency
C#
public void AddDependency(
ITest test
)
C++
public:
void AddDependency(
ITest test
) sealed
J#
public void AddDependency(
ITest test
)
JScript
public function AddDependency(
test : ITest
)

Parameters

test
The test to add as a dependency

Implements

ITest.AddDependency

See Also

BaseTest Class
Gallio.Model Namespace


AddParameter Method

BaseTest.AddParameter Method
[image]

Adds a test parameter and sets its Owner property.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddParameter( _
ByVal parameter As ITestParameter _
) _
Implements ITest.AddParameter
C#
public void AddParameter(
ITestParameter parameter
)
C++
public:
void AddParameter(
ITestParameter parameter
) sealed
J#
public void AddParameter(
ITestParameter parameter
)
JScript
public function AddParameter(
parameter : ITestParameter
)

Parameters

parameter
The test parameter to add

Implements

ITest.AddParameter

See Also

BaseTest Class
Gallio.Model Namespace


GetUniqueLocalIdForChild Method

BaseTest.GetUniqueLocalIdForChild Method
[image]

Obtains a unique local id for a child of this test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetUniqueLocalIdForChild( _
ByVal localIdHint As String _
) As String _
Implements ITest.GetUniqueLocalIdForChild
C#
public string GetUniqueLocalIdForChild(
string localIdHint
)
C++
public:
String GetUniqueLocalIdForChild(
String localIdHint
) sealed
J#
public string GetUniqueLocalIdForChild(
string localIdHint
)
JScript
public function GetUniqueLocalIdForChild(
localIdHint : String
) : String

Parameters

localIdHint
A suggested id which will be used if no conflicts occur

Return Value

The unique local id to use

Implements

ITest.GetUniqueLocalIdForChild

See Also

BaseTest Class
Gallio.Model Namespace


ToString Method

BaseTest.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

BaseTest Class
Gallio.Model Namespace


BaseTestComponent Class

BaseTestComponent Class
See Also Example Members
[image]

Base implementation of ITestComponent. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTestComponent
Implements ITestComponent
C#
public abstract class BaseTestComponent : ITestComponent
C++
ref class BaseTestComponent abstract : ITestComponent
J#
public class BaseTestComponent implements ITestComponent
JScript
public class BaseTestComponent extends ITestComponent

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTest
Gallio.Model.BaseTestParameter
Gallio.Model.BaseTestStep

See Also

BaseTestComponent Members
Gallio.Model Namespace


BaseTestComponent Members

BaseTestComponent Members
See Also Example Constructors Properties Methods
[image]

Base implementation of ITestComponent. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTestComponent.

Public Constructors

 | Name | Description
Public method | BaseTestComponent | Initializes a test component.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id |
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)
Public property | Metadata | Gets the metadata of the component.
Public property | Name | Gets the name of the component.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestComponent Class
Gallio.Model Namespace


BaseTestComponent Constructor

BaseTestComponent Constructor
[image]

Initializes a test component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
)
C#
public BaseTestComponent(
string name,
ICodeElementInfo codeElement
)
C++
public:
BaseTestComponent(
String name,
ICodeElementInfo codeElement
) sealed
J#
public BaseTestComponent(
string name,
ICodeElementInfo codeElement
)
JScript
public function BaseTestComponent(
name : String,
codeElement : ICodeElementInfo
)

Parameters

name
The name of the component
codeElement
The point of definition of the component, or null if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

BaseTestComponent Class
Gallio.Model Namespace


Properties

BaseTestComponent Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id |
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)
Public property | Metadata | Gets the metadata of the component.
Public property | Name | Gets the name of the component.
Top

See Also

BaseTestComponent Class
Gallio.Model Namespace


CodeElement Property

BaseTestComponent.CodeElement Property
[image]

Gets a reference to the point of definition of this test component in the code, or null if unknown.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CodeElement As ICodeElementInfo _
Implements ITestComponent.CodeElement
C#
public ICodeElementInfo CodeElement { get; set; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
void set(ICodeElementInfo value);
}
J#
/** property */
public ICodeElementInfo get_CodeElement();

/** property */
public void set_CodeElement(ICodeElementInfo value);
JScript
public function get CodeElement() : ICodeElementInfo

public function set CodeElement(value : ICodeElementInfo);

Implements

ITestComponent.CodeElement

See Also

BaseTestComponent Class
Gallio.Model Namespace


Id Property

BaseTestComponent.Id Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Id As String _
Implements ITestComponent.Id
C#
public abstract string Id { get; }
C++
public abstract property string Id abstract {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Implements

ITestComponent.Id

See Also

BaseTestComponent Class
Gallio.Model Namespace


Kind Property

BaseTestComponent.Kind Property
[image]

Gets or sets the value of the TestKind metadata entry. (This is a convenience method.)

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Kind As String
C#
public string Kind { get; set; }
C++
public property string Kind sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Kind();

/** property */
public void set_Kind(string value);
JScript
public function get Kind() : String

public function set Kind(value : String);

Property Value

One of the TestKinds constants.

See Also

BaseTestComponent Class
Gallio.Model Namespace


Metadata Property

BaseTestComponent.Metadata Property
[image]

Gets the metadata of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metadata As PropertyBag _
Implements ITestComponent.Metadata
C#
public PropertyBag Metadata { get; }
C++
public property PropertyBag Metadata sealed {
PropertyBag get();
}
J#
/** property */
public PropertyBag get_Metadata();
JScript
public function get Metadata() : PropertyBag

Implements

ITestComponent.Metadata

See Also

BaseTestComponent Class
Gallio.Model Namespace


Name Property

BaseTestComponent.Name Property
[image]

Gets the name of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String _
Implements ITestComponent.Name
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Implements

ITestComponent.Name

See Also

BaseTestComponent Class
Gallio.Model Namespace


Methods

BaseTestComponent Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestComponent Class
Gallio.Model Namespace


ToString Method

BaseTestComponent.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

BaseTestComponent Class
Gallio.Model Namespace


BaseTestExplorer Class

BaseTestExplorer Class
See Also Example Members
[image]

A base test explorer that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTestExplorer
Implements ITestExplorer
C#
public abstract class BaseTestExplorer : ITestExplorer
C++
ref class BaseTestExplorer abstract : ITestExplorer
J#
public class BaseTestExplorer implements ITestExplorer
JScript
public class BaseTestExplorer extends ITestExplorer

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestExplorer
Gallio.Framework.Pattern.PatternTestExplorer
Gallio.Model.AggregateTestExplorer
Gallio.Model.NullTestExplorer

See Also

BaseTestExplorer Members
Gallio.Model Namespace


BaseTestExplorer Members

BaseTestExplorer Members
See Also Example Constructors Properties Methods
[image]

A base test explorer that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTestExplorer.

Public Constructors

 | Name | Description
Public method | BaseTestExplorer | Creates a test explorer.
Top

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly |
Public method | ExploreType |
Public method | FinishModel |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestExplorer Class
Gallio.Model Namespace


BaseTestExplorer Constructor

BaseTestExplorer Constructor
[image]

Creates a test explorer.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModel As TestModel _
)
C#
public BaseTestExplorer(
TestModel testModel
)
C++
public:
BaseTestExplorer(
TestModel testModel
) sealed
J#
public BaseTestExplorer(
TestModel testModel
)
JScript
public function BaseTestExplorer(
testModel : TestModel
)

Parameters

testModel
The test model that is incrementally populated by the test explorer as it explores tests.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModel is null

See Also

BaseTestExplorer Class
Gallio.Model Namespace


Properties

BaseTestExplorer Properties
[image]

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests.
Top

See Also

BaseTestExplorer Class
Gallio.Model Namespace


TestModel Property

BaseTestExplorer.TestModel Property
[image]

Gets the test model that is incrementally populated by the test explorer as it explores tests.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestModel As TestModel _
Implements ITestExplorer.TestModel
C#
public TestModel TestModel { get; }
C++
public property TestModel TestModel sealed {
TestModel get();
}
J#
/** property */
public TestModel get_TestModel();
JScript
public function get TestModel() : TestModel

Implements

ITestExplorer.TestModel

See Also

BaseTestExplorer Class
Gallio.Model Namespace


Methods

BaseTestExplorer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly |
Public method | ExploreType |
Public method | FinishModel |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestExplorer Class
Gallio.Model Namespace


ExploreAssembly Method

BaseTestExplorer.ExploreAssembly Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ExploreAssembly( _
ByVal assembly As IAssemblyInfo, _
ByVal consumer As Action(Of ITest) _
) _
Implements ITestExplorer.ExploreAssembly
C#
public virtual void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
C++
public:
virtual void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
J#
public virtual void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
JScript
public virtual function ExploreAssembly(
assembly : IAssemblyInfo,
consumer : Action<ITest>
)

Implements

ITestExplorer.ExploreAssembly

See Also

BaseTestExplorer Class
Gallio.Model Namespace


ExploreType Method

BaseTestExplorer.ExploreType Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ExploreType( _
ByVal type As ITypeInfo, _
ByVal consumer As Action(Of ITest) _
) _
Implements ITestExplorer.ExploreType
C#
public virtual void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
C++
public:
virtual void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
J#
public virtual void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
JScript
public virtual function ExploreType(
type : ITypeInfo,
consumer : Action<ITest>
)

Implements

ITestExplorer.ExploreType

See Also

BaseTestExplorer Class
Gallio.Model Namespace


FinishModel Method

BaseTestExplorer.FinishModel Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub FinishModel() _
Implements ITestExplorer.FinishModel
C#
public virtual void FinishModel()
C++
public:
virtual void FinishModel()
J#
public virtual void FinishModel()
JScript
public virtual function FinishModel()

Implements

ITestExplorer.FinishModel

See Also

BaseTestExplorer Class
Gallio.Model Namespace


IsTest Method

BaseTestExplorer.IsTest Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsTest( _
ByVal element As ICodeElementInfo _
) As Boolean _
Implements ITestExplorer.IsTest
C#
public virtual bool IsTest(
ICodeElementInfo element
)
C++
public:
virtual bool IsTest(
ICodeElementInfo element
)
J#
public virtual bool IsTest(
ICodeElementInfo element
)
JScript
public virtual function IsTest(
element : ICodeElementInfo
) : bool

Implements

ITestExplorer.IsTest

See Also

BaseTestExplorer Class
Gallio.Model Namespace


BaseTestFramework Class

BaseTestFramework Class
See Also Example Members
[image]

Abstract base class for test framework implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTestFramework
Implements ITestFramework
C#
public abstract class BaseTestFramework : ITestFramework
C++
ref class BaseTestFramework abstract : ITestFramework
J#
public class BaseTestFramework implements ITestFramework
JScript
public class BaseTestFramework extends ITestFramework

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestFramework
Gallio.Framework.Pattern.PatternTestFramework

See Also

BaseTestFramework Members
Gallio.Model Namespace


BaseTestFramework Members

BaseTestFramework Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for test framework implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTestFramework.

Protected Constructors

 | Name | Description
Family method | BaseTestFramework | Initializes a new instance of the BaseTestFramework class.
Top

Public Properties

 | Name | Description
Public property | Id |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | ConfigureTestDomain | Applies additional contributions to a test domain, if desired.
Public method | CreateTestExplorer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestFramework Class
Gallio.Model Namespace


BaseTestFramework Constructor

BaseTestFramework Constructor
[image]

Initializes a new instance of the BaseTestFramework class.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseTestFramework()
C++
protected:
BaseTestFramework() sealed
J#
protected BaseTestFramework()
JScript
protected function BaseTestFramework()

See Also

BaseTestFramework Class
Gallio.Model Namespace


Properties

BaseTestFramework Properties
[image]

Public Properties

 | Name | Description
Public property | Id |
Public property | Name |
Top

See Also

BaseTestFramework Class
Gallio.Model Namespace


Id Property

BaseTestFramework.Id Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Id As Guid _
Implements ITestFramework.Id
C#
public abstract Guid Id { get; }
C++
public abstract property Guid Id abstract {
Guid get();
}
J#
/** property */
public Guid get_Id();
JScript
public function get Id() : Guid

Implements

ITestFramework.Id

See Also

BaseTestFramework Class
Gallio.Model Namespace


Name Property

BaseTestFramework.Name Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String _
Implements ITestFramework.Name
C#
public abstract string Name { get; }
C++
public abstract property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ITestFramework.Name

See Also

BaseTestFramework Class
Gallio.Model Namespace


Methods

BaseTestFramework Methods
[image]

Public Methods

 | Name | Description
Public method | ConfigureTestDomain | Applies additional contributions to a test domain, if desired.
Public method | CreateTestExplorer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestFramework Class
Gallio.Model Namespace


ConfigureTestDomain Method

BaseTestFramework.ConfigureTestDomain Method
[image]

Applies additional contributions to a test domain, if desired.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ConfigureTestDomain( _
ByVal testDomainSetup As TestDomainSetup _
) _
Implements ITestFramework.ConfigureTestDomain
C#
public virtual void ConfigureTestDomain(
TestDomainSetup testDomainSetup
)
C++
public:
virtual void ConfigureTestDomain(
TestDomainSetup testDomainSetup
)
J#
public virtual void ConfigureTestDomain(
TestDomainSetup testDomainSetup
)
JScript
public virtual function ConfigureTestDomain(
testDomainSetup : TestDomainSetup
)

Parameters

testDomainSetup
The test domain setup to modify

Implements

ITestFramework.ConfigureTestDomain

See Also

BaseTestFramework Class
Gallio.Model Namespace


CreateTestExplorer Method

BaseTestFramework.CreateTestExplorer Method
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateTestExplorer( _
ByVal testModel As TestModel _
) As ITestExplorer _
Implements ITestFramework.CreateTestExplorer
C#
public virtual ITestExplorer CreateTestExplorer(
TestModel testModel
)
C++
public:
virtual ITestExplorer CreateTestExplorer(
TestModel testModel
)
J#
public virtual ITestExplorer CreateTestExplorer(
TestModel testModel
)
JScript
public virtual function CreateTestExplorer(
testModel : TestModel
) : ITestExplorer

Implements

ITestFramework.CreateTestExplorer

See Also

BaseTestFramework Class
Gallio.Model Namespace


BaseTestParameter Class

BaseTestParameter Class
See Also Example Members
[image]

Base implementation of ITestParameter.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BaseTestParameter
Inherits BaseTestComponent
Implements ITestParameter
C#
public class BaseTestParameter : BaseTestComponent, ITestParameter
C++
ref class BaseTestParameter : BaseTestComponent, ITestParameter
J#
public class BaseTestParameter extends BaseTestComponent implements ITestParameter
JScript
public class BaseTestParameter extends BaseTestComponent, ITestParameter

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTestParameter
Gallio.Framework.Pattern.PatternTestParameter

See Also

BaseTestParameter Members
Gallio.Model Namespace


BaseTestParameter Members

BaseTestParameter Members
See Also Example Constructors Properties Methods
[image]

Base implementation of ITestParameter.

The following tables list the members exposed by BaseTestParameter.

Public Constructors

 | Name | Description
Public method | BaseTestParameter | Initializes a test parameter.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | Id | Overridden. Gets the stable unique identifier of the component.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Owner | Gets or sets the test that owns this parameter, or null if this parameter does not yet have an owner.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTestComponent)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestParameter Class
Gallio.Model Namespace


BaseTestParameter Constructor

BaseTestParameter Constructor
[image]

Initializes a test parameter.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
)
C#
public BaseTestParameter(
string name,
ICodeElementInfo codeElement
)
C++
public:
BaseTestParameter(
String name,
ICodeElementInfo codeElement
) sealed
J#
public BaseTestParameter(
string name,
ICodeElementInfo codeElement
)
JScript
public function BaseTestParameter(
name : String,
codeElement : ICodeElementInfo
)

Parameters

name
The name of the test parameter
codeElement
The point of definition of the parameter, or null if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

BaseTestParameter Class
Gallio.Model Namespace


Properties

BaseTestParameter Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | Id | Overridden. Gets the stable unique identifier of the component.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Owner | Gets or sets the test that owns this parameter, or null if this parameter does not yet have an owner.
Top

See Also

BaseTestParameter Class
Gallio.Model Namespace


Id Property

BaseTestParameter.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Id As String _
Implements ITestComponent.Id
C#
public override string Id { get; }
C++
public override property string Id override {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Implements

ITestComponent.Id

See Also

BaseTestParameter Class
Gallio.Model Namespace


Owner Property

BaseTestParameter.Owner Property
[image]

Gets or sets the test that owns this parameter, or null if this parameter does not yet have an owner.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As ITest _
Implements ITestParameter.Owner
C#
public ITest Owner { get; set; }
C++
public property ITest Owner sealed {
ITest get();
void set(ITest value);
}
J#
/** property */
public ITest get_Owner();

/** property */
public void set_Owner(ITest value);
JScript
public function get Owner() : ITest

public function set Owner(value : ITest);

Implements

ITestParameter.Owner

See Also

BaseTestParameter Class
Gallio.Model Namespace


BaseTestStep Class

BaseTestStep Class
See Also Example Members
[image]

Base implementation of ITestStep.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BaseTestStep
Inherits BaseTestComponent
Implements ITestStep
C#
public class BaseTestStep : BaseTestComponent, ITestStep
C++
ref class BaseTestStep : BaseTestComponent, ITestStep
J#
public class BaseTestStep extends BaseTestComponent implements ITestStep
JScript
public class BaseTestStep extends BaseTestComponent, ITestStep

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTestStep
Gallio.Framework.Pattern.PatternTestStep

See Also

BaseTestStep Members
Gallio.Model Namespace


BaseTestStep Members

BaseTestStep Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Base implementation of ITestStep.

The following tables list the members exposed by BaseTestStep.

Public Constructors

Name | Description
BaseTestStep | Overloaded.
Top

Public Properties

Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest
Public property | Id | Overridden. Gets the stable unique identifier of the component.
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Parent | Gets the step that contains this one, or null if this instance represents the root step of the test step tree.
Public property | Test | Gets the test to which this step belongs.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
BaseTestStep | Overloaded.
Top

See Also

BaseTestStep Class
Gallio.Model Namespace


BaseTestStep Constructor

BaseTestStep Constructor

Overload List

 | Name | Description
Public method | BaseTestStep (ITest, ITestStep) | Creates a primary step using the same name, code element and metadata as the test to which it belongs.
Public method | BaseTestStep (ITest, ITestStep, String, ICodeElementInfo, Boolean) | Creates a step.

See Also

BaseTestStep Class
Gallio.Model Namespace


BaseTestStep Constructor (ITest, ITestStep)

BaseTestStep Constructor (ITest, ITestStep)
See Also Example
[image]

Creates a primary step using the same name, code element and metadata as the test to which it belongs.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal test As ITest, _
ByVal parent As ITestStep _
)
C#
public BaseTestStep(
ITest test,
ITestStep parent
)
C++
public:
BaseTestStep(
ITest test,
ITestStep parent
) sealed
J#
public BaseTestStep(
ITest test,
ITestStep parent
)
JScript
public function BaseTestStep(
test : ITest,
parent : ITestStep
)

Parameters

test
The test to which the step belongs
parent
The parent test step, or null if creating the root step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if test is null

See Also

BaseTestStep Class
Gallio.Model Namespace
BaseTestStep Constructor Overload List


BaseTestStep Constructor (ITest, ITestStep, String, ICodeElementInfo, Boolean)

BaseTestStep Constructor (ITest, ITestStep, String, ICodeElementInfo, Boolean)
See Also Example
[image]

Creates a step.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal test As ITest, _
ByVal parent As ITestStep, _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo, _
ByVal isPrimary As Boolean _
)
C#
public BaseTestStep(
ITest test,
ITestStep parent,
string name,
ICodeElementInfo codeElement,
bool isPrimary
)
C++
public:
BaseTestStep(
ITest test,
ITestStep parent,
String name,
ICodeElementInfo codeElement,
bool isPrimary
) sealed
J#
public BaseTestStep(
ITest test,
ITestStep parent,
string name,
ICodeElementInfo codeElement,
bool isPrimary
)
JScript
public function BaseTestStep(
test : ITest,
parent : ITestStep,
name : String,
codeElement : ICodeElementInfo,
isPrimary : bool
)

Parameters

test
The test to which the step belongs
parent
The parent step, or null if creating a root step
name
The step name
codeElement
The point of definition of the step, or null if unknown
isPrimary
True if the test step is primary

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or test is null

Remarks

If isPrimary is true, then all metadata from the test is copied to the step. Otherwise the new step will have no metadata initially.

See Also

BaseTestStep Class
Gallio.Model Namespace
BaseTestStep Constructor Overload List


Properties

BaseTestStep Properties
[image]

Public Properties

Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest
Public property | Id | Overridden. Gets the stable unique identifier of the component.
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property | Parent | Gets the step that contains this one, or null if this instance represents the root step of the test step tree.
Public property | Test | Gets the test to which this step belongs.
Top

See Also

BaseTestStep Class
Gallio.Model Namespace


FullName Property

BaseTestStep.FullName Property
[image]

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String _
Implements ITestStep.FullName
C#
public string FullName { get; }
C++
public property string FullName sealed {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITestStep.FullName

See Also

BaseTestStep Class
Gallio.Model Namespace


Id Property

BaseTestStep.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Id As String _
Implements ITestComponent.Id
C#
public override string Id { get; }
C++
public override property string Id override {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Implements

ITestComponent.Id

See Also

BaseTestStep Class
Gallio.Model Namespace


IsDynamic Property

BaseTestStep.IsDynamic Property
[image]

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDynamic As Boolean _
Implements ITestStep.IsDynamic
C#
public bool IsDynamic { get; set; }
C++
public property bool IsDynamic sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsDynamic();

/** property */
public void set_IsDynamic(bool value);
JScript
public function get IsDynamic() : bool

public function set IsDynamic(value : bool);

Implements

ITestStep.IsDynamic

See Also

BaseTestStep Class
Gallio.Model Namespace


IsPrimary Property

BaseTestStep.IsPrimary Property
[image]

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean _
Implements ITestStep.IsPrimary
C#
public bool IsPrimary { get; }
C++
public property bool IsPrimary sealed {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

ITestStep.IsPrimary

See Also

BaseTestStep Class
Gallio.Model Namespace


IsTestCase Property

BaseTestStep.IsTestCase Property
[image]

Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsTestCase As Boolean _
Implements ITestStep.IsTestCase
C#
public bool IsTestCase { get; set; }
C++
public property bool IsTestCase sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsTestCase();

/** property */
public void set_IsTestCase(bool value);
JScript
public function get IsTestCase() : bool

public function set IsTestCase(value : bool);

Implements

ITestStep.IsTestCase

See Also

BaseTestStep Class
Gallio.Model Namespace


Parent Property

BaseTestStep.Parent Property
[image]

Gets the step that contains this one, or null if this instance represents the root step of the test step tree.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ITestStep _
Implements ITestStep.Parent
C#
public ITestStep Parent { get; }
C++
public property ITestStep Parent sealed {
ITestStep get();
}
J#
/** property */
public ITestStep get_Parent();
JScript
public function get Parent() : ITestStep

Implements

ITestStep.Parent

See Also

BaseTestStep Class
Gallio.Model Namespace


Test Property

BaseTestStep.Test Property
[image]

Gets the test to which this step belongs.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As ITest _
Implements ITestStep.Test
C#
public ITest Test { get; }
C++
public property ITest Test sealed {
ITest get();
}
J#
/** property */
public ITest get_Test();
JScript
public function get Test() : ITest

Implements

ITestStep.Test

See Also

BaseTestStep Class
Gallio.Model Namespace


Methods

BaseTestStep Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTestStep Class
Gallio.Model Namespace


ToString Method

BaseTestStep.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

BaseTestStep Class
Gallio.Model Namespace


DefaultTestPackageExplorerFactory Class

DefaultTestPackageExplorerFactory Class
See Also Example Members
[image]

Default implementation of a test package explorer factory that aggregates over all registered frameworks.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestPackageExplorerFactory
Implements ITestPackageExplorerFactory
C#
public class DefaultTestPackageExplorerFactory : ITestPackageExplorerFactory
C++
ref class DefaultTestPackageExplorerFactory : ITestPackageExplorerFactory
J#
public class DefaultTestPackageExplorerFactory implements ITestPackageExplorerFactory
JScript
public class DefaultTestPackageExplorerFactory extends ITestPackageExplorerFactory

Inheritance Hierarchy

System.Object
Gallio.Model.DefaultTestPackageExplorerFactory

See Also

DefaultTestPackageExplorerFactory Members
Gallio.Model Namespace


DefaultTestPackageExplorerFactory Members

DefaultTestPackageExplorerFactory Members
See Also Example Constructors Methods
[image]

Default implementation of a test package explorer factory that aggregates over all registered frameworks.

The following tables list the members exposed by DefaultTestPackageExplorerFactory.

Public Constructors

 | Name | Description
Public method | DefaultTestPackageExplorerFactory | Creates a factory.
Top

Public Methods

 | Name | Description
Public method | CreateTestExplorer | Creates a test explorer with the specified reflection policy.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestPackageExplorerFactory Class
Gallio.Model Namespace


DefaultTestPackageExplorerFactory Constructor

DefaultTestPackageExplorerFactory Constructor
[image]

Creates a factory.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal loader As ILoader, _
ByVal frameworks As ITestFramework() _
)
C#
public DefaultTestPackageExplorerFactory(
ILoader loader,
ITestFramework[] frameworks
)
C++
public:
DefaultTestPackageExplorerFactory(
ILoader loader,
array<ITestFramework>^ frameworks
) sealed
J#
public DefaultTestPackageExplorerFactory(
ILoader loader,
ITestFramework[] frameworks
)
JScript
public function DefaultTestPackageExplorerFactory(
loader : ILoader,
frameworks : ITestFramework[]
)

Parameters

loader
The loader
frameworks
The frameworks to explore

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if loader or frameworks is null

See Also

DefaultTestPackageExplorerFactory Class
Gallio.Model Namespace


Methods

DefaultTestPackageExplorerFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestExplorer | Creates a test explorer with the specified reflection policy.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestPackageExplorerFactory Class
Gallio.Model Namespace


CreateTestExplorer Method

DefaultTestPackageExplorerFactory.CreateTestExplorer Method
[image]

Creates a test explorer with the specified reflection policy.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTestExplorer( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal reflectionPolicy As IReflectionPolicy _
) As ITestExplorer _
Implements ITestPackageExplorerFactory.CreateTestExplorer
C#
public ITestExplorer CreateTestExplorer(
TestPackageConfig testPackageConfig,
IReflectionPolicy reflectionPolicy
)
C++
public:
ITestExplorer CreateTestExplorer(
TestPackageConfig testPackageConfig,
IReflectionPolicy reflectionPolicy
) sealed
J#
public ITestExplorer CreateTestExplorer(
TestPackageConfig testPackageConfig,
IReflectionPolicy reflectionPolicy
)
JScript
public function CreateTestExplorer(
testPackageConfig : TestPackageConfig,
reflectionPolicy : IReflectionPolicy
) : ITestExplorer

Parameters

testPackageConfig
The test package configuration
reflectionPolicy
The reflection policy

Return Value

The test explorer

Implements

ITestPackageExplorerFactory.CreateTestExplorer

See Also

DefaultTestPackageExplorerFactory Class
Gallio.Model Namespace


ITest Interface

ITest Interface
See Also Example Members
[image]

A test object represents a parameterized test case or test container. The test parameters are used as placeholders for data-binding during test execution. A single test can produce multiple steps () at runtime.

A ITest can be thought of as a declarative artifact that describes about what a test "looks like" from the outside based on available reflective metadata. A ITestStep is then the runtime counterpart of a ITest that is created to describe different parameter bindigns or other characteristics of a test's structure that become manifest only at runtime.

A test may depend on one or more other tests. When a test fails, the tests that depend on it are also automatically considered failures. Moreover, the test harness ensures that a test will only run once all of its dependencies have completed execution successfully. A run-time error will occur when the system detects the presence of circular test dependencies or attempts to execute a test concurrently with its dependencies.

A test contain child tests. The children of a test are executed in dependency order within the scope of the parent test. Thus the parent test may setup/teardown the execution environment used to execute its children. Tests that belong to different subtrees are executed in relative isolation within the common environment established by their common parent.

The object model distinguishes between tests that represent individual test cases and other test containers. Test containers are skipped if they do not contain any test cases or if none of their test cases have been selected for execution.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITest
Implements ITestComponent
C#
public interface ITest : ITestComponent
C++
interface class ITest : ITestComponent
J#
public interface ITest implements ITestComponent
JScript
public interface ITest extends ITestComponent

Types that implement ITest

Type | Description
Gallio.Model.BaseTest | Base implementation of ITest.
Gallio.Model.TestInfo | A read-only implementation of ITest for reflection. This class cannot be inherited.

See Also

ITest Members
Gallio.Model Namespace
ITestStep


ITest Members

ITest Members
See Also Example Properties Methods
[image]

A test object represents a parameterized test case or test container. The test parameters are used as placeholders for data-binding during test execution. A single test can produce multiple steps () at runtime.

A ITest can be thought of as a declarative artifact that describes about what a test "looks like" from the outside based on available reflective metadata. A ITestStep is then the runtime counterpart of a ITest that is created to describe different parameter bindigns or other characteristics of a test's structure that become manifest only at runtime.

A test may depend on one or more other tests. When a test fails, the tests that depend on it are also automatically considered failures. Moreover, the test harness ensures that a test will only run once all of its dependencies have completed execution successfully. A run-time error will occur when the system detects the presence of circular test dependencies or attempts to execute a test concurrently with its dependencies.

A test contain child tests. The children of a test are executed in dependency order within the scope of the parent test. Thus the parent test may setup/teardown the execution environment used to execute its children. Tests that belong to different subtrees are executed in relative isolation within the common environment established by their common parent.

The object model distinguishes between tests that represent individual test cases and other test containers. Test containers are skipped if they do not contain any test cases or if none of their test cases have been selected for execution.

The following tables list the members exposed by ITest.

Public Properties

Name | Description
Public property | Children | Gets a read-only list of the children of this test.
Public property | Dependencies | Gets a read-only list of the dependencies of this test.
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant.
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test.
Public property | TestControllerFactory | Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.
Top

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property.
Public method | AddDependency | Adds a test dependency.
Public method | AddParameter | Adds a test parameter and sets its Owner property.
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test.
Top

See Also

ITest Interface
Gallio.Model Namespace
ITestStep


Properties

ITest Properties
[image]

Public Properties

Name | Description
Public property | Children | Gets a read-only list of the children of this test.
Public property | Dependencies | Gets a read-only list of the dependencies of this test.
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant.
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test.
Public property | TestControllerFactory | Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.
Top

See Also

ITest Interface
Gallio.Model Namespace
ITestStep


Children Property

ITest.Children Property
[image]

Gets a read-only list of the children of this test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As IList(Of ITest)
C#
IList<ITest> Children { get; }
C++
property IList<ITest> Children abstract {
IList<ITest> get();
}
J#
/** property */
public IList<ITest> get_Children();
JScript
public function get Children() : IList<ITest>

See Also

ITest Interface
Gallio.Model Namespace


Dependencies Property

ITest.Dependencies Property
[image]

Gets a read-only list of the dependencies of this test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Dependencies As IList(Of ITest)
C#
IList<ITest> Dependencies { get; }
C++
property IList<ITest> Dependencies abstract {
IList<ITest> get();
}
J#
/** property */
public IList<ITest> get_Dependencies();
JScript
public function get Dependencies() : IList<ITest>

Remarks

Some test frameworks may choose to ignore test dependencies or may impose their own dependency schemes.

See Also

ITest Interface
Gallio.Model Namespace


FullName Property

ITest.FullName Property
[image]

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullName As String
C#
string FullName { get; }
C++
property string FullName abstract {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

See Also

ITest Interface
Gallio.Model Namespace


IsTestCase Property

ITest.IsTestCase Property
[image]

Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsTestCase As Boolean
C#
bool IsTestCase { get; }
C++
property bool IsTestCase abstract {
bool get();
}
J#
/** property */
public bool get_IsTestCase();
JScript
public function get IsTestCase() : bool

Remarks

Not all test cases are leaf nodes in the test tree and vice-versa.

This value is defined as a property rather than as a metadata key because it significantly changes the semantics of test execution.

See Also

ITest Interface
Gallio.Model Namespace


LocalId Property

ITest.LocalId Property
[image]

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LocalId As String
C#
string LocalId { get; }
C++
property string LocalId abstract {
String get();
}
J#
/** property */
public string get_LocalId();
JScript
public function get LocalId() : String

Property Value

The locally unique identifier

Remarks

The locally unique LocalId property may be used to generate the globally unique Id property of a test by combining it with the locally unique identifiers of its parents.

See Also

ITest Interface
Gallio.Model Namespace


Order Property

ITest.Order Property
[image]

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Order As Integer
C#
int Order { get; set; }
C++
property int Order abstract {
int get();
void set(int value);
}
J#
/** property */
public int get_Order();

/** property */
public void set_Order(int value);
JScript
public function get Order() : int

public function set Order(value : int);

Property Value

The test execution order with respect to siblings, initially zero.

Remarks

Some test frameworks may choose to ignore test order or may impose their own ordering schemes.

See Also

ITest Interface
Gallio.Model Namespace


Parameters Property

ITest.Parameters Property
[image]

Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Parameters As IList(Of ITestParameter)
C#
IList<ITestParameter> Parameters { get; }
C++
property IList<ITestParameter> Parameters abstract {
IList<ITestParameter> get();
}
J#
/** property */
public IList<ITestParameter> get_Parameters();
JScript
public function get Parameters() : IList<ITestParameter>

See Also

ITest Interface
Gallio.Model Namespace


Parent Property

ITest.Parent Property
[image]

Gets or sets the parent of this test, or null if this is the root test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Parent As ITest
C#
ITest Parent { get; set; }
C++
property ITest Parent abstract {
ITest get();
void set(ITest value);
}
J#
/** property */
public ITest get_Parent();

/** property */
public void set_Parent(ITest value);
JScript
public function get Parent() : ITest

public function set Parent(value : ITest);

See Also

ITest Interface
Gallio.Model Namespace


TestControllerFactory Property

ITest.TestControllerFactory Property
[image]

Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestControllerFactory As Func(Of ITestController)
C#
Func<ITestController> TestControllerFactory { get; }
C++
property Func<ITestController> TestControllerFactory abstract {
Func<ITestController> get();
}
J#
/** property */
public Func<ITestController> get_TestControllerFactory();
JScript
public function get TestControllerFactory() : Func<ITestController>

Property Value

The test controller factory, or null if this test cannot produce a controller (and consequently is not a master test according to the definition above)

Remarks

The top-most test that returns a non-null Func is referred to as the master test. It may contain other tests that also have non-null factories but there is no built-in mechanism provided to delegate control from one controller to another in the middle of its execution. Thus the nested controller will only be executed if the master controller chooses to implement a suitable delegation policy of this sort.

During test execution, the test plan scans the list of tests to be executed in depth-first order to locate the master tests for each subtree. The test plan instantiates and invokes a test controller for each master test.

For example, the top-level test created by a ITestFramework is usually a master test. The ITestController created by the framework's master test will then take care of setting up the environment for the entire subtree beneath it and then actually running the tests. Thus the interaction between the test harness and test controllers (as mediated by master tests) represents a division of labor among multiple possible test execution strategies.

See Also

ITest Interface
Gallio.Model Namespace


Methods

ITest Methods
[image]

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property.
Public method | AddDependency | Adds a test dependency.
Public method | AddParameter | Adds a test parameter and sets its Owner property.
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test.
Top

See Also

ITest Interface
Gallio.Model Namespace
ITestStep


AddChild Method

ITest.AddChild Method
[image]

Adds a child test and sets its Parent property.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddChild( _
ByVal test As ITest _
)
C#
void AddChild(
ITest test
)
C++
void AddChild(
ITest test
) abstract
J#
void AddChild(
ITest test
)
JScript
function AddChild(
test : ITest
)

Parameters

test
The test to add as a child

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if test is null
InvalidOperationException | Thrown if test is already the child of some other test

See Also

ITest Interface
Gallio.Model Namespace


AddDependency Method

ITest.AddDependency Method
[image]

Adds a test dependency.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddDependency( _
ByVal test As ITest _
)
C#
void AddDependency(
ITest test
)
C++
void AddDependency(
ITest test
) abstract
J#
void AddDependency(
ITest test
)
JScript
function AddDependency(
test : ITest
)

Parameters

test
The test to add as a dependency

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if test is null

See Also

ITest Interface
Gallio.Model Namespace


AddParameter Method

ITest.AddParameter Method
[image]

Adds a test parameter and sets its Owner property.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddParameter( _
ByVal parameter As ITestParameter _
)
C#
void AddParameter(
ITestParameter parameter
)
C++
void AddParameter(
ITestParameter parameter
) abstract
J#
void AddParameter(
ITestParameter parameter
)
JScript
function AddParameter(
parameter : ITestParameter
)

Parameters

parameter
The test parameter to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if parameter is null
InvalidOperationException | Thrown if parameter is already owned by some other test

See Also

ITest Interface
Gallio.Model Namespace


GetUniqueLocalIdForChild Method

ITest.GetUniqueLocalIdForChild Method
[image]

Obtains a unique local id for a child of this test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetUniqueLocalIdForChild( _
ByVal localIdHint As String _
) As String
C#
string GetUniqueLocalIdForChild(
string localIdHint
)
C++
String GetUniqueLocalIdForChild(
String localIdHint
) abstract
J#
string GetUniqueLocalIdForChild(
string localIdHint
)
JScript
function GetUniqueLocalIdForChild(
localIdHint : String
) : String

Parameters

localIdHint
A suggested id which will be used if no conflicts occur

Return Value

The unique local id to use

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if localIdHint is null

See Also

ITest Interface
Gallio.Model Namespace


ITestComponent Interface

ITestComponent Interface
See Also Example Members
[image]

Common interface for elements in the test object model. All components have a name for presentation, metadata for annotations, and a code reference to its point of definition.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestComponent
C#
public interface ITestComponent
C++
interface class ITestComponent
J#
public interface ITestComponent
JScript
public interface ITestComponent

Types that implement ITestComponent

Type | Description
Gallio.Model.BaseTestComponent | Base implementation of ITestComponent. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Model.TestComponentInfo | A read-only implementation of ITestComponent for reflection. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestComponent Members
Gallio.Model Namespace


ITestComponent Members

ITestComponent Members
See Also Example Properties
[image]

Common interface for elements in the test object model. All components have a name for presentation, metadata for annotations, and a code reference to its point of definition.

The following tables list the members exposed by ITestComponent.

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Metadata | Gets the metadata of the component.
Public property | Name | Gets the name of the component.
Top

See Also

ITestComponent Interface
Gallio.Model Namespace


Properties

ITestComponent Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Metadata | Gets the metadata of the component.
Public property | Name | Gets the name of the component.
Top

See Also

ITestComponent Interface
Gallio.Model Namespace


CodeElement Property

ITestComponent.CodeElement Property
[image]

Gets a reference to the point of definition of this test component in the code, or null if unknown.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CodeElement As ICodeElementInfo
C#
ICodeElementInfo CodeElement { get; }
C++
property ICodeElementInfo CodeElement abstract {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

See Also

ITestComponent Interface
Gallio.Model Namespace


Id Property

ITestComponent.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Id As String
C#
string Id { get; }
C++
property string Id abstract {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Remarks

The identifier must be unique across all components within a given test project. It should also be stable so that the identifier remains valid across recompilations and code changes that do not alter the underlying declarations (insofar as is possible).

The identifier does not refer to a specific instance of ITestComponent, but rather incorporates enough information so that we can unambiguously find a corresponding instance in a model that has been populated. When we rebuild the model, assuming the code hasn't changed too much, the objects in the model will have the same identifier as before. This allows the identifier to be saved in project files to construct lists of components. We can also use it to refer to components remotely.

See Also

ITestComponent Interface
Gallio.Model Namespace


Metadata Property

ITestComponent.Metadata Property
[image]

Gets the metadata of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Metadata As PropertyBag
C#
PropertyBag Metadata { get; }
C++
property PropertyBag Metadata abstract {
PropertyBag get();
}
J#
/** property */
public PropertyBag get_Metadata();
JScript
public function get Metadata() : PropertyBag

See Also

ITestComponent Interface
Gallio.Model Namespace


Name Property

ITestComponent.Name Property
[image]

Gets the name of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
C++
property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Remarks

The name does not need to be globally unique.

See Also

ITestComponent Interface
Gallio.Model Namespace


ITestExplorer Interface

ITestExplorer Interface
See Also Example Members
[image]

A test explorer scans a volume of code using reflection to build a partial test tree. The tests constructed in this manner may not be complete or executable but they provide useful insight into the layout of the test suite that can subsequently be used to drive the test runner.

As a test explorer explores test assemblies and types, it incrementally populates a TestModel with its discoveries. The TestModel is guaranteed to contain all of the tests explicitly explored, but it may also contain other tests that were discovered by the explorer along the way. For example, a valid implementation of ITestExplorer could implement ExploreType by exploring the entire assembly as performed by ExploreAssembly.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestExplorer
C#
public interface ITestExplorer
C++
interface class ITestExplorer
J#
public interface ITestExplorer
JScript
public interface ITestExplorer

Types that implement ITestExplorer

Type | Description
Gallio.Model.BaseTestExplorer | A base test explorer that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestExplorer Members
Gallio.Model Namespace


ITestExplorer Members

ITestExplorer Members
See Also Example Properties Methods
[image]

A test explorer scans a volume of code using reflection to build a partial test tree. The tests constructed in this manner may not be complete or executable but they provide useful insight into the layout of the test suite that can subsequently be used to drive the test runner.

As a test explorer explores test assemblies and types, it incrementally populates a TestModel with its discoveries. The TestModel is guaranteed to contain all of the tests explicitly explored, but it may also contain other tests that were discovered by the explorer along the way. For example, a valid implementation of ITestExplorer could implement ExploreType by exploring the entire assembly as performed by ExploreAssembly.

The following tables list the members exposed by ITestExplorer.

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests.
Top

Public Methods

 | Name | Description
Public method | ExploreAssembly | Explores the tests defined by an assembly and links them into the TestModel.
Public method | ExploreType | Explores the tests defined by a type and links them into the TestModel.
Public method | FinishModel | Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.
Public method | IsTest | Returns true if the code element represents a test.
Top

See Also

ITestExplorer Interface
Gallio.Model Namespace


Properties

ITestExplorer Properties
[image]

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests.
Top

See Also

ITestExplorer Interface
Gallio.Model Namespace


TestModel Property

ITestExplorer.TestModel Property
[image]

Gets the test model that is incrementally populated by the test explorer as it explores tests.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestModel As TestModel
C#
TestModel TestModel { get; }
C++
property TestModel TestModel abstract {
TestModel get();
}
J#
/** property */
public TestModel get_TestModel();
JScript
public function get TestModel() : TestModel

See Also

ITestExplorer Interface
Gallio.Model Namespace


Methods

ITestExplorer Methods
[image]

Public Methods

 | Name | Description
Public method | ExploreAssembly | Explores the tests defined by an assembly and links them into the TestModel.
Public method | ExploreType | Explores the tests defined by a type and links them into the TestModel.
Public method | FinishModel | Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.
Public method | IsTest | Returns true if the code element represents a test.
Top

See Also

ITestExplorer Interface
Gallio.Model Namespace


ExploreAssembly Method

ITestExplorer.ExploreAssembly Method
[image]

Explores the tests defined by an assembly and links them into the TestModel.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ExploreAssembly( _
ByVal assembly As IAssemblyInfo, _
ByVal consumer As Action(Of ITest) _
)
C#
void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
C++
void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
) abstract
J#
void ExploreAssembly(
IAssemblyInfo assembly,
Action<ITest> consumer
)
JScript
function ExploreAssembly(
assembly : IAssemblyInfo,
consumer : Action<ITest>
)

Parameters

assembly
The assembly
consumer
An action to perform on each assembly-level test explored, or null if no action is required

See Also

ITestExplorer Interface
Gallio.Model Namespace


ExploreType Method

ITestExplorer.ExploreType Method
[image]

Explores the tests defined by a type and links them into the TestModel.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ExploreType( _
ByVal type As ITypeInfo, _
ByVal consumer As Action(Of ITest) _
)
C#
void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
C++
void ExploreType(
ITypeInfo type,
Action<ITest> consumer
) abstract
J#
void ExploreType(
ITypeInfo type,
Action<ITest> consumer
)
JScript
function ExploreType(
type : ITypeInfo,
consumer : Action<ITest>
)

Parameters

type
The type
consumer
An action to perform on each type-level test explored, or null if no action is required

See Also

ITestExplorer Interface
Gallio.Model Namespace


FinishModel Method

ITestExplorer.FinishModel Method
[image]

Performs any final actions after exploration has taken place to ensure that we have a complete and internally consistent model.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub FinishModel()
C#
void FinishModel()
C++
void FinishModel() abstract
J#
void FinishModel()
JScript
function FinishModel()

Remarks

A test explorer may elect to defer some processing until the test model has been fully populated. For example, it may not be possible to resolve test dependencies as soon as they are encountered, so this processing may be deferred until all assemblies and types have been explored.

See Also

ITestExplorer Interface
Gallio.Model Namespace


IsTest Method

ITestExplorer.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsTest( _
ByVal element As ICodeElementInfo _
) As Boolean
C#
bool IsTest(
ICodeElementInfo element
)
C++
bool IsTest(
ICodeElementInfo element
) abstract
J#
bool IsTest(
ICodeElementInfo element
)
JScript
function IsTest(
element : ICodeElementInfo
) : bool

Parameters

element
The element

Return Value

True if the element represents a test

See Also

ITestExplorer Interface
Gallio.Model Namespace


ITestFramework Interface

ITestFramework Interface
See Also Example Members
[image]

The test framework service provides support for enumerating and executing tests that belong to some test framework. A new third party test framework may be supported by defining and registering a suitable implementation of this interface.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestFramework
C#
public interface ITestFramework
C++
interface class ITestFramework
J#
public interface ITestFramework
JScript
public interface ITestFramework

Types that implement ITestFramework

Type | Description
Gallio.Model.BaseTestFramework | Abstract base class for test framework implementations. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestFramework Members
Gallio.Model Namespace


ITestFramework Members

ITestFramework Members
See Also Example Properties Methods
[image]

The test framework service provides support for enumerating and executing tests that belong to some test framework. A new third party test framework may be supported by defining and registering a suitable implementation of this interface.

The following tables list the members exposed by ITestFramework.

Public Properties

 | Name | Description
Public property | Id | Gets the unique id of the test framework.
Public property | Name | Gets the name of the test framework.
Top

Public Methods

 | Name | Description
Public method | ConfigureTestDomain | Applies additional contributions to a test domain, if desired.
Public method | CreateTestExplorer | Creates a test explorer for this test framework.
Top

See Also

ITestFramework Interface
Gallio.Model Namespace


Properties

ITestFramework Properties
[image]

Public Properties

 | Name | Description
Public property | Id | Gets the unique id of the test framework.
Public property | Name | Gets the name of the test framework.
Top

See Also

ITestFramework Interface
Gallio.Model Namespace


Id Property

ITestFramework.Id Property
[image]

Gets the unique id of the test framework.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Id As Guid
C#
Guid Id { get; }
C++
property Guid Id abstract {
Guid get();
}
J#
/** property */
public Guid get_Id();
JScript
public function get Id() : Guid

See Also

ITestFramework Interface
Gallio.Model Namespace


Name Property

ITestFramework.Name Property
[image]

Gets the name of the test framework.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
C++
property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

ITestFramework Interface
Gallio.Model Namespace


Methods

ITestFramework Methods
[image]

Public Methods

 | Name | Description
Public method | ConfigureTestDomain | Applies additional contributions to a test domain, if desired.
Public method | CreateTestExplorer | Creates a test explorer for this test framework.
Top

See Also

ITestFramework Interface
Gallio.Model Namespace


ConfigureTestDomain Method

ITestFramework.ConfigureTestDomain Method
[image]

Applies additional contributions to a test domain, if desired.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ConfigureTestDomain( _
ByVal testDomainSetup As TestDomainSetup _
)
C#
void ConfigureTestDomain(
TestDomainSetup testDomainSetup
)
C++
void ConfigureTestDomain(
TestDomainSetup testDomainSetup
) abstract
J#
void ConfigureTestDomain(
TestDomainSetup testDomainSetup
)
JScript
function ConfigureTestDomain(
testDomainSetup : TestDomainSetup
)

Parameters

testDomainSetup
The test domain setup to modify

Remarks

This method may be used by a test framework to set additional binding redirects or hint directories prior to loading a test package in a test domain.

See Also

ITestFramework Interface
Gallio.Model Namespace


CreateTestExplorer Method

ITestFramework.CreateTestExplorer Method
[image]

Creates a test explorer for this test framework.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTestExplorer( _
ByVal testModel As TestModel _
) As ITestExplorer
C#
ITestExplorer CreateTestExplorer(
TestModel testModel
)
C++
ITestExplorer CreateTestExplorer(
TestModel testModel
) abstract
J#
ITestExplorer CreateTestExplorer(
TestModel testModel
)
JScript
function CreateTestExplorer(
testModel : TestModel
) : ITestExplorer

Parameters

testModel
The test model to populate incrementally as tests are discovered

Return Value

The test explorer

See Also

ITestFramework Interface
Gallio.Model Namespace


ITestPackageExplorerFactory Interface

ITestPackageExplorerFactory Interface
See Also Example Members
[image]

Creates test explorers for packages.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestPackageExplorerFactory
C#
public interface ITestPackageExplorerFactory
C++
interface class ITestPackageExplorerFactory
J#
public interface ITestPackageExplorerFactory
JScript
public interface ITestPackageExplorerFactory

Types that implement ITestPackageExplorerFactory

Type | Description
Gallio.Model.DefaultTestPackageExplorerFactory | Default implementation of a test package explorer factory that aggregates over all registered frameworks.

See Also

ITestPackageExplorerFactory Members
Gallio.Model Namespace


ITestPackageExplorerFactory Members

ITestPackageExplorerFactory Members
See Also Example Methods
[image]

Creates test explorers for packages.

The following tables list the members exposed by ITestPackageExplorerFactory.

Public Methods

 | Name | Description
Public method | CreateTestExplorer | Creates a test explorer with the specified reflection policy.
Top

See Also

ITestPackageExplorerFactory Interface
Gallio.Model Namespace


Methods

ITestPackageExplorerFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestExplorer | Creates a test explorer with the specified reflection policy.
Top

See Also

ITestPackageExplorerFactory Interface
Gallio.Model Namespace


CreateTestExplorer Method

ITestPackageExplorerFactory.CreateTestExplorer Method
[image]

Creates a test explorer with the specified reflection policy.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTestExplorer( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal reflectionPolicy As IReflectionPolicy _
) As ITestExplorer
C#
ITestExplorer CreateTestExplorer(
TestPackageConfig testPackageConfig,
IReflectionPolicy reflectionPolicy
)
C++
ITestExplorer CreateTestExplorer(
TestPackageConfig testPackageConfig,
IReflectionPolicy reflectionPolicy
) abstract
J#
ITestExplorer CreateTestExplorer(
TestPackageConfig testPackageConfig,
IReflectionPolicy reflectionPolicy
)
JScript
function CreateTestExplorer(
testPackageConfig : TestPackageConfig,
reflectionPolicy : IReflectionPolicy
) : ITestExplorer

Parameters

testPackageConfig
The test package configuration
reflectionPolicy
The reflection policy

Return Value

The test explorer

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackageConfig or reflectionPolicy is null

See Also

ITestPackageExplorerFactory Interface
Gallio.Model Namespace


ITestParameter Interface

ITestParameter Interface
See Also Example Members
[image]

A test parameter describes a formal parameter of a ITest to which a value may be bound and used during test execution.

The Name property of a test parameter should be unique among the set parameters belonging to its Owner to ensure that it can be differentiated from others. However, this constraint is not enforced.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestParameter
Implements ITestComponent
C#
public interface ITestParameter : ITestComponent
C++
interface class ITestParameter : ITestComponent
J#
public interface ITestParameter implements ITestComponent
JScript
public interface ITestParameter extends ITestComponent

Types that implement ITestParameter

Type | Description
Gallio.Model.BaseTestParameter | Base implementation of ITestParameter.
Gallio.Model.TestParameterInfo | A read-only implementation of ITestParameter for reflection. This class cannot be inherited.

See Also

ITestParameter Members
Gallio.Model Namespace


ITestParameter Members

ITestParameter Members
See Also Example Properties
[image]

A test parameter describes a formal parameter of a ITest to which a value may be bound and used during test execution.

The Name property of a test parameter should be unique among the set parameters belonging to its Owner to ensure that it can be differentiated from others. However, this constraint is not enforced.

The following tables list the members exposed by ITestParameter.

Public Properties

 | Name | Description
Public property | Owner | Gets or sets the test that owns this parameter, or null if this parameter does not yet have an owner.
Top

See Also

ITestParameter Interface
Gallio.Model Namespace


Properties

ITestParameter Properties
[image]

Public Properties

 | Name | Description
Public property | Owner | Gets or sets the test that owns this parameter, or null if this parameter does not yet have an owner.
Top

See Also

ITestParameter Interface
Gallio.Model Namespace


Owner Property

ITestParameter.Owner Property
[image]

Gets or sets the test that owns this parameter, or null if this parameter does not yet have an owner.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Owner As ITest
C#
ITest Owner { get; set; }
C++
property ITest Owner abstract {
ITest get();
void set(ITest value);
}
J#
/** property */
public ITest get_Owner();

/** property */
public void set_Owner(ITest value);
JScript
public function get Owner() : ITest

public function set Owner(value : ITest);

See Also

ITestParameter Interface
Gallio.Model Namespace


ITestStep Interface

ITestStep Interface
See Also Example Members
[image]

A test step is a delimited region of a test defined at run-time. Each test that is executed consists of at least one step: the "primary" step. During execution, each test may spawn additional nested steps that may run in parallel or in series with one another as required.

A test step may be used to describe a particular instance of a data driven test. It can also be used to generate a completely dynamic hierarchy at runtime that mirrors and extends the static test hierarchy with new information derived from the actual execution of the test.

Each step has its own execution log and test result (pass/fail/inconclusive). Therefore a multi-step test may possess multiple execution logs and test results. This is deliberate. Think of a ITest as being the declarative component of a test that specifies which test method to invoke and its arguments. An ITestStep is the runtime counterpart of the ITest that captures output and control flow information about part or all of the test.

A test step also has metadata that can be update at run-time to carry additional declarative information about the step.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestStep
Implements ITestComponent
C#
public interface ITestStep : ITestComponent
C++
interface class ITestStep : ITestComponent
J#
public interface ITestStep implements ITestComponent
JScript
public interface ITestStep extends ITestComponent

Types that implement ITestStep

Type | Description
Gallio.Model.BaseTestStep | Base implementation of ITestStep.
Gallio.Model.TestStepInfo | A read-only implementation of ITestStep for reflection. This class cannot be inherited.

See Also

ITestStep Members
Gallio.Model Namespace


ITestStep Members

ITestStep Members
See Also Example Properties
[image]

A test step is a delimited region of a test defined at run-time. Each test that is executed consists of at least one step: the "primary" step. During execution, each test may spawn additional nested steps that may run in parallel or in series with one another as required.

A test step may be used to describe a particular instance of a data driven test. It can also be used to generate a completely dynamic hierarchy at runtime that mirrors and extends the static test hierarchy with new information derived from the actual execution of the test.

Each step has its own execution log and test result (pass/fail/inconclusive). Therefore a multi-step test may possess multiple execution logs and test results. This is deliberate. Think of a ITest as being the declarative component of a test that specifies which test method to invoke and its arguments. An ITestStep is the runtime counterpart of the ITest that captures output and control flow information about part or all of the test.

A test step also has metadata that can be update at run-time to carry additional declarative information about the step.

The following tables list the members exposed by ITestStep.

Public Properties

Name | Description
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.
Public property | Parent | Gets the step that contains this one, or null if this instance represents the root step of the test step tree.
Public property | Test | Gets the test to which this step belongs.
Top

See Also

ITestStep Interface
Gallio.Model Namespace


Properties

ITestStep Properties
[image]

Public Properties

Name | Description
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.
Public property | Parent | Gets the step that contains this one, or null if this instance represents the root step of the test step tree.
Public property | Test | Gets the test to which this step belongs.
Top

See Also

ITestStep Interface
Gallio.Model Namespace


FullName Property

ITestStep.FullName Property
[image]

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullName As String
C#
string FullName { get; }
C++
property string FullName abstract {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

See Also

ITestStep Interface
Gallio.Model Namespace


IsDynamic Property

ITestStep.IsDynamic Property
[image]

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsDynamic As Boolean
C#
bool IsDynamic { get; }
C++
property bool IsDynamic abstract {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

See Also

ITestStep Interface
Gallio.Model Namespace


IsPrimary Property

ITestStep.IsPrimary Property
[image]

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPrimary As Boolean
C#
bool IsPrimary { get; }
C++
property bool IsPrimary abstract {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Remarks

For example, suppose we have a data-driven test fixture F which contains a data-driven test T. There will be a primary test step of F that represents the undifferentiated fixture with no data bound to it. Its immediate children will be derived test steps of F with particular data bindings. Similarly, each of these derived test steps of F will contain a primary test step of T which then contains derived test steps of T.

This case is illustrated like this where periods delimit path segments in the test step hierarchy.

  • F - Primary test step of F
  • F.F1 - Non-primary test step of F with data bindings
  • F.F1.T - Primary test step of T
  • F.F1.T.T1 - Non-primary test step of T with data bindings
  • F.F1.T.T2 - Non-primary test step of T with data bindings
  • F.F2 - Non-primary test step of F with data bindings
  • F.F2.T - Primary test step of T
  • F.F2.T.T1 - Non-primary test step of T with data bindings
  • F.F2.T.T2 - Non-primary test step of T with data bindings

See Also

ITestStep Interface
Gallio.Model Namespace


IsTestCase Property

ITestStep.IsTestCase Property
[image]

Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsTestCase As Boolean
C#
bool IsTestCase { get; }
C++
property bool IsTestCase abstract {
bool get();
}
J#
/** property */
public bool get_IsTestCase();
JScript
public function get IsTestCase() : bool

Remarks

A test step can only be a test case if its associated ITest is a test case. However, not all test steps of tests that are test cases will themselves be test cases. For example, a data-driven test might have one primary test step with multiple derived test steps as children. The primary test step will generally not be considered a test case but its children will.

See Also

ITestStep Interface
Gallio.Model Namespace
IsTestCase


Parent Property

ITestStep.Parent Property
[image]

Gets the step that contains this one, or null if this instance represents the root step of the test step tree.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As ITestStep
C#
ITestStep Parent { get; }
C++
property ITestStep Parent abstract {
ITestStep get();
}
J#
/** property */
public ITestStep get_Parent();
JScript
public function get Parent() : ITestStep

See Also

ITestStep Interface
Gallio.Model Namespace


Test Property

ITestStep.Test Property
[image]

Gets the test to which this step belongs.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Test As ITest
C#
ITest Test { get; }
C++
property ITest Test abstract {
ITest get();
}
J#
/** property */
public ITest get_Test();
JScript
public function get Test() : ITest

See Also

ITestStep Interface
Gallio.Model Namespace


LifecyclePhases Class

LifecyclePhases Class
See Also Example Members
[image]

Defines the names of common test step lifecycle phases. Custom phases may also be defined. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module LifecyclePhases
C#
public static class LifecyclePhases
C++
ref class LifecyclePhases abstract sealed
J#
public final class LifecyclePhases
JScript
public class LifecyclePhases

Inheritance Hierarchy

System.Object
Gallio.Model.LifecyclePhases

See Also

LifecyclePhases Members
Gallio.Model Namespace


LifecyclePhases Members

LifecyclePhases Members
See Also Example Fields
[image]

Defines the names of common test step lifecycle phases. Custom phases may also be defined. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by LifecyclePhases.

Public Fields

Name | Description
Dispose | The test step's context is being disposed. This field is constant and read-only.
Execute | The test step is executing its main body. This field is constant and read-only.
Finishing | The test step is finishing. This field is constant and read-only.
Initialize | The test is being initialize. (Fixture construction, etc.) This field is constant and read-only.
SetUp | The test step is being set up. This field is constant and read-only.
Starting | The test step is starting. This field is constant and read-only.
TearDown | The test step is being torn down. This field is constant and read-only.
Top

See Also

LifecyclePhases Class
Gallio.Model Namespace


Fields

LifecyclePhases Fields
[image]

Public Fields

Name | Description
Dispose | The test step's context is being disposed. This field is constant and read-only.
Execute | The test step is executing its main body. This field is constant and read-only.
Finishing | The test step is finishing. This field is constant and read-only.
Initialize | The test is being initialize. (Fixture construction, etc.) This field is constant and read-only.
SetUp | The test step is being set up. This field is constant and read-only.
Starting | The test step is starting. This field is constant and read-only.
TearDown | The test step is being torn down. This field is constant and read-only.
Top

See Also

LifecyclePhases Class
Gallio.Model Namespace


Dispose Field

LifecyclePhases.Dispose Field
[image]

The test step's context is being disposed. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Dispose As String = "Dispose"
C#
public const string Dispose = "Dispose";
C++
public:
const String Dispose = L"Dispose";
J#
public const string Dispose = "Dispose"
JScript
public const Dispose : String = "Dispose";

See Also

LifecyclePhases Class
Gallio.Model Namespace


Execute Field

LifecyclePhases.Execute Field
[image]

The test step is executing its main body. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Execute As String = "Execute"
C#
public const string Execute = "Execute";
C++
public:
const String Execute = L"Execute";
J#
public const string Execute = "Execute"
JScript
public const Execute : String = "Execute";

See Also

LifecyclePhases Class
Gallio.Model Namespace


Finishing Field

LifecyclePhases.Finishing Field
[image]

The test step is finishing. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Finishing As String = "Finishing"
C#
public const string Finishing = "Finishing";
C++
public:
const String Finishing = L"Finishing";
J#
public const string Finishing = "Finishing"
JScript
public const Finishing : String = "Finishing";

See Also

LifecyclePhases Class
Gallio.Model Namespace


Initialize Field

LifecyclePhases.Initialize Field
[image]

The test is being initialize. (Fixture construction, etc.) This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Initialize As String = "Initialize"
C#
public const string Initialize = "Initialize";
C++
public:
const String Initialize = L"Initialize";
J#
public const string Initialize = "Initialize"
JScript
public const Initialize : String = "Initialize";

See Also

LifecyclePhases Class
Gallio.Model Namespace


SetUp Field

LifecyclePhases.SetUp Field
[image]

The test step is being set up. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const SetUp As String = "SetUp"
C#
public const string SetUp = "SetUp";
C++
public:
const String SetUp = L"SetUp";
J#
public const string SetUp = "SetUp"
JScript
public const SetUp : String = "SetUp";

See Also

LifecyclePhases Class
Gallio.Model Namespace


Starting Field

LifecyclePhases.Starting Field
[image]

The test step is starting. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Starting As String = "Starting"
C#
public const string Starting = "Starting";
C++
public:
const String Starting = L"Starting";
J#
public const string Starting = "Starting"
JScript
public const Starting : String = "Starting";

See Also

LifecyclePhases Class
Gallio.Model Namespace


TearDown Field

LifecyclePhases.TearDown Field
[image]

The test step is being torn down. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TearDown As String = "TearDown"
C#
public const string TearDown = "TearDown";
C++
public:
const String TearDown = L"TearDown";
J#
public const string TearDown = "TearDown"
JScript
public const TearDown : String = "TearDown";

See Also

LifecyclePhases Class
Gallio.Model Namespace


MetadataKeys Class

MetadataKeys Class
See Also Example Members
[image]

Provides common metadata keys. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module MetadataKeys
C#
public static class MetadataKeys
C++
ref class MetadataKeys abstract sealed
J#
public final class MetadataKeys
JScript
public class MetadataKeys

Inheritance Hierarchy

System.Object
Gallio.Model.MetadataKeys

See Also

MetadataKeys Members
Gallio.Model Namespace


MetadataKeys Members

MetadataKeys Members
See Also Example Fields
[image]

Provides common metadata keys. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by MetadataKeys.

Public Fields

Name | Description
AuthorEmail | The metadata key for the author's email. This field is constant and read-only.
AuthorHomepage | The metadata key for the author's homepage. This field is constant and read-only.
AuthorName | The metadata key for the author's name. This field is constant and read-only.
Category | The metadata key for the name of a category to which a test belongs. This field is constant and read-only.
CodeBase | The matadata key for the location of an assembly as a local file path or as a Uri. This field is constant and read-only.
Company | The metadata key for the name of the company associated with a test. This field is constant and read-only.
Configuration | The metadata key for build/release configuration information associated with a test. It describes the target environment or usage for the test. This field is constant and read-only.
Copyright | The metadata key for a copyright associated with a test. This field is constant and read-only.
DataLocation | The metadata key for specifying the origin of data used by a test. This field is constant and read-only.
Description | The metadata key for the description of a test component. This field is constant and read-only.
ExpectedException | The metadata key for the expected exception type which should be the name, full name or assembly-qualified name of the expected exception type. This field is constant and read-only.
ExplicitReason | The metadata key that describes the reason that a test should be run explicitly. (Tests may of course be marked explicit without a declared reason.) This field is constant and read-only.
FileVersion | The metadata key for a file version number associated with a test. This field is constant and read-only.
IgnoreReason | The metadata key that describes the reason that a test is being ignored. (Tests may of course be ignored without a declared reason.) This field is constant and read-only.
Importance | The metadata key for the importance of a test component as the string representation of one of the TestImportance constants in MbUnit or its equivalent. This field is constant and read-only.
InformationalVersion | The metadata key for an informational version number associated with a test. This field is constant and read-only.
PendingReason | The metadata key that describes the reason that a test is pending. (Tests may of course be marked pending without a declared reason.) This field is constant and read-only.
Product | The metadata key for a product associated with a test. This field is constant and read-only.
TestKind | The metadata key used to describe the kind of a test as the string representation of one of the TestKinds constants. This field is constant and read-only.
TestsOn | The metadata key for the name of the type being tested. The associated value should be the full name of the type from FullName or the assembly qualified name of the type from AssemblyQualifiedName. This field is constant and read-only.
Title | The metadata key for a title associated with a test. This field is constant and read-only.
Trademark | The metadata key for a trademark associated with a test. This field is constant and read-only.
Version | The metadata key for a version number associated with a test. This field is constant and read-only.
XmlDocumentation | The metadata key for the XML documentation of the test derived from XML code documentation comments. This field is constant and read-only.
Top

See Also

MetadataKeys Class
Gallio.Model Namespace


Fields

MetadataKeys Fields
[image]

Public Fields

Name | Description
AuthorEmail | The metadata key for the author's email. This field is constant and read-only.
AuthorHomepage | The metadata key for the author's homepage. This field is constant and read-only.
AuthorName | The metadata key for the author's name. This field is constant and read-only.
Category | The metadata key for the name of a category to which a test belongs. This field is constant and read-only.
CodeBase | The matadata key for the location of an assembly as a local file path or as a Uri. This field is constant and read-only.
Company | The metadata key for the name of the company associated with a test. This field is constant and read-only.
Configuration | The metadata key for build/release configuration information associated with a test. It describes the target environment or usage for the test. This field is constant and read-only.
Copyright | The metadata key for a copyright associated with a test. This field is constant and read-only.
DataLocation | The metadata key for specifying the origin of data used by a test. This field is constant and read-only.
Description | The metadata key for the description of a test component. This field is constant and read-only.
ExpectedException | The metadata key for the expected exception type which should be the name, full name or assembly-qualified name of the expected exception type. This field is constant and read-only.
ExplicitReason | The metadata key that describes the reason that a test should be run explicitly. (Tests may of course be marked explicit without a declared reason.) This field is constant and read-only.
FileVersion | The metadata key for a file version number associated with a test. This field is constant and read-only.
IgnoreReason | The metadata key that describes the reason that a test is being ignored. (Tests may of course be ignored without a declared reason.) This field is constant and read-only.
Importance | The metadata key for the importance of a test component as the string representation of one of the TestImportance constants in MbUnit or its equivalent. This field is constant and read-only.
InformationalVersion | The metadata key for an informational version number associated with a test. This field is constant and read-only.
PendingReason | The metadata key that describes the reason that a test is pending. (Tests may of course be marked pending without a declared reason.) This field is constant and read-only.
Product | The metadata key for a product associated with a test. This field is constant and read-only.
TestKind | The metadata key used to describe the kind of a test as the string representation of one of the TestKinds constants. This field is constant and read-only.
TestsOn | The metadata key for the name of the type being tested. The associated value should be the full name of the type from FullName or the assembly qualified name of the type from AssemblyQualifiedName. This field is constant and read-only.
Title | The metadata key for a title associated with a test. This field is constant and read-only.
Trademark | The metadata key for a trademark associated with a test. This field is constant and read-only.
Version | The metadata key for a version number associated with a test. This field is constant and read-only.
XmlDocumentation | The metadata key for the XML documentation of the test derived from XML code documentation comments. This field is constant and read-only.
Top

See Also

MetadataKeys Class
Gallio.Model Namespace


AuthorEmail Field

MetadataKeys.AuthorEmail Field
[image]

The metadata key for the author's email. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const AuthorEmail As String = "AuthorEmail"
C#
public const string AuthorEmail = "AuthorEmail";
C++
public:
const String AuthorEmail = L"AuthorEmail";
J#
public const string AuthorEmail = "AuthorEmail"
JScript
public const AuthorEmail : String = "AuthorEmail";

Remarks

May be derived from AuthorAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


AuthorHomepage Field

MetadataKeys.AuthorHomepage Field
[image]

The metadata key for the author's homepage. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const AuthorHomepage As String = "AuthorHomepage"
C#
public const string AuthorHomepage = "AuthorHomepage";
C++
public:
const String AuthorHomepage = L"AuthorHomepage";
J#
public const string AuthorHomepage = "AuthorHomepage"
JScript
public const AuthorHomepage : String = "AuthorHomepage";

Remarks

May be derived from AuthorAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


AuthorName Field

MetadataKeys.AuthorName Field
[image]

The metadata key for the author's name. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const AuthorName As String = "AuthorName"
C#
public const string AuthorName = "AuthorName";
C++
public:
const String AuthorName = L"AuthorName";
J#
public const string AuthorName = "AuthorName"
JScript
public const AuthorName : String = "AuthorName";

Remarks

May be derived from AuthorAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


Category Field

MetadataKeys.Category Field
[image]

The metadata key for the name of a category to which a test belongs. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Category As String = "Category"
C#
public const string Category = "Category";
C++
public:
const String Category = L"Category";
J#
public const string Category = "Category"
JScript
public const Category : String = "Category";

Remarks

May be derived from CategoryAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


CodeBase Field

MetadataKeys.CodeBase Field
[image]

The matadata key for the location of an assembly as a local file path or as a Uri. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const CodeBase As String = "CodeBase"
C#
public const string CodeBase = "CodeBase";
C++
public:
const String CodeBase = L"CodeBase";
J#
public const string CodeBase = "CodeBase"
JScript
public const CodeBase : String = "CodeBase";

Remarks

May be derived from the assembly's CodeBase property.

See Also

MetadataKeys Class
Gallio.Model Namespace


Company Field

MetadataKeys.Company Field
[image]

The metadata key for the name of the company associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Company As String = "Company"
C#
public const string Company = "Company";
C++
public:
const String Company = L"Company";
J#
public const string Company = "Company"
JScript
public const Company : String = "Company";

Remarks

May be derived from AssemblyCompanyAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


Configuration Field

MetadataKeys.Configuration Field
[image]

The metadata key for build/release configuration information associated with a test. It describes the target environment or usage for the test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Configuration As String = "Configuration"
C#
public const string Configuration = "Configuration";
C++
public:
const String Configuration = L"Configuration";
J#
public const string Configuration = "Configuration"
JScript
public const Configuration : String = "Configuration";

Remarks

May be derived from AssemblyConfigurationAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


Copyright Field

MetadataKeys.Copyright Field
[image]

The metadata key for a copyright associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Copyright As String = "Copyright"
C#
public const string Copyright = "Copyright";
C++
public:
const String Copyright = L"Copyright";
J#
public const string Copyright = "Copyright"
JScript
public const Copyright : String = "Copyright";

Remarks

May be derived from AssemblyCopyrightAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


DataLocation Field

MetadataKeys.DataLocation Field
[image]

The metadata key for specifying the origin of data used by a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const DataLocation As String = "DataLocation"
C#
public const string DataLocation = "DataLocation";
C++
public:
const String DataLocation = L"DataLocation";
J#
public const string DataLocation = "DataLocation"
JScript
public const DataLocation : String = "DataLocation";

Remarks

May be the file name and line number of a record in a file, the ID of a database record or some other identifying characteristic.

See Also

MetadataKeys Class
Gallio.Model Namespace


Description Field

MetadataKeys.Description Field
[image]

The metadata key for the description of a test component. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Description As String = "Description"
C#
public const string Description = "Description";
C++
public:
const String Description = L"Description";
J#
public const string Description = "Description"
JScript
public const Description : String = "Description";

Remarks

May be derived from AssemblyDescriptionAttribute or DescriptionAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


ExpectedException Field

MetadataKeys.ExpectedException Field
[image]

The metadata key for the expected exception type which should be the name, full name or assembly-qualified name of the expected exception type. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ExpectedException As String = "ExpectedException"
C#
public const string ExpectedException = "ExpectedException";
C++
public:
const String ExpectedException = L"ExpectedException";
J#
public const string ExpectedException = "ExpectedException"
JScript
public const ExpectedException : String = "ExpectedException";

Remarks

May be derived from ExpectedExceptionAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


ExplicitReason Field

MetadataKeys.ExplicitReason Field
[image]

The metadata key that describes the reason that a test should be run explicitly. (Tests may of course be marked explicit without a declared reason.) This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ExplicitReason As String = "ExplicitReason"
C#
public const string ExplicitReason = "ExplicitReason";
C++
public:
const String ExplicitReason = L"ExplicitReason";
J#
public const string ExplicitReason = "ExplicitReason"
JScript
public const ExplicitReason : String = "ExplicitReason";

Remarks

May be derived from ExplicitAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


FileVersion Field

MetadataKeys.FileVersion Field
[image]

The metadata key for a file version number associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const FileVersion As String = "FileVersion"
C#
public const string FileVersion = "FileVersion";
C++
public:
const String FileVersion = L"FileVersion";
J#
public const string FileVersion = "FileVersion"
JScript
public const FileVersion : String = "FileVersion";

Remarks

May be derived from AssemblyFileVersionAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


IgnoreReason Field

MetadataKeys.IgnoreReason Field
[image]

The metadata key that describes the reason that a test is being ignored. (Tests may of course be ignored without a declared reason.) This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const IgnoreReason As String = "IgnoreReason"
C#
public const string IgnoreReason = "IgnoreReason";
C++
public:
const String IgnoreReason = L"IgnoreReason";
J#
public const string IgnoreReason = "IgnoreReason"
JScript
public const IgnoreReason : String = "IgnoreReason";

Remarks

May be derived from IgnoreAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


Importance Field

MetadataKeys.Importance Field
[image]

The metadata key for the importance of a test component as the string representation of one of the TestImportance constants in MbUnit or its equivalent. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Importance As String = "Importance"
C#
public const string Importance = "Importance";
C++
public:
const String Importance = L"Importance";
J#
public const string Importance = "Importance"
JScript
public const Importance : String = "Importance";

Remarks

May be derived from ImportantAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


InformationalVersion Field

MetadataKeys.InformationalVersion Field
[image]

The metadata key for an informational version number associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const InformationalVersion As String = "InformationalVersion"
C#
public const string InformationalVersion = "InformationalVersion";
C++
public:
const String InformationalVersion = L"InformationalVersion";
J#
public const string InformationalVersion = "InformationalVersion"
JScript
public const InformationalVersion : String = "InformationalVersion";

Remarks

May be derived from AssemblyInformationalVersionAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


PendingReason Field

MetadataKeys.PendingReason Field
[image]

The metadata key that describes the reason that a test is pending. (Tests may of course be marked pending without a declared reason.) This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const PendingReason As String = "PendingReason"
C#
public const string PendingReason = "PendingReason";
C++
public:
const String PendingReason = L"PendingReason";
J#
public const string PendingReason = "PendingReason"
JScript
public const PendingReason : String = "PendingReason";

Remarks

May be derived from PendingAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


Product Field

MetadataKeys.Product Field
[image]

The metadata key for a product associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Product As String = "Product"
C#
public const string Product = "Product";
C++
public:
const String Product = L"Product";
J#
public const string Product = "Product"
JScript
public const Product : String = "Product";

Remarks

May be derived from AssemblyProductAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


TestKind Field

MetadataKeys.TestKind Field
[image]

The metadata key used to describe the kind of a test as the string representation of one of the TestKinds constants. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestKind As String = "TestKind"
C#
public const string TestKind = "TestKind";
C++
public:
const String TestKind = L"TestKind";
J#
public const string TestKind = "TestKind"
JScript
public const TestKind : String = "TestKind";

See Also

MetadataKeys Class
Gallio.Model Namespace


TestsOn Field

MetadataKeys.TestsOn Field
[image]

The metadata key for the name of the type being tested. The associated value should be the full name of the type from FullName or the assembly qualified name of the type from AssemblyQualifiedName. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const TestsOn As String = "TestsOn"
C#
public const string TestsOn = "TestsOn";
C++
public:
const String TestsOn = L"TestsOn";
J#
public const string TestsOn = "TestsOn"
JScript
public const TestsOn : String = "TestsOn";

Remarks

May be derived from TestsOnAttribute in MbUnit or its equivalent.

See Also

MetadataKeys Class
Gallio.Model Namespace


Title Field

MetadataKeys.Title Field
[image]

The metadata key for a title associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Title As String = "Title"
C#
public const string Title = "Title";
C++
public:
const String Title = L"Title";
J#
public const string Title = "Title"
JScript
public const Title : String = "Title";

Remarks

May be derived from AssemblyTitleAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


Trademark Field

MetadataKeys.Trademark Field
[image]

The metadata key for a trademark associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Trademark As String = "Trademark"
C#
public const string Trademark = "Trademark";
C++
public:
const String Trademark = L"Trademark";
J#
public const string Trademark = "Trademark"
JScript
public const Trademark : String = "Trademark";

Remarks

May be derived from AssemblyTrademarkAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


Version Field

MetadataKeys.Version Field
[image]

The metadata key for a version number associated with a test. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Version As String = "Version"
C#
public const string Version = "Version";
C++
public:
const String Version = L"Version";
J#
public const string Version = "Version"
JScript
public const Version : String = "Version";

Remarks

May be derived from AssemblyVersionAttribute.

See Also

MetadataKeys Class
Gallio.Model Namespace


XmlDocumentation Field

MetadataKeys.XmlDocumentation Field
[image]

The metadata key for the XML documentation of the test derived from XML code documentation comments. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const XmlDocumentation As String = "XmlDocumentation"
C#
public const string XmlDocumentation = "XmlDocumentation";
C++
public:
const String XmlDocumentation = L"XmlDocumentation";
J#
public const string XmlDocumentation = "XmlDocumentation"
JScript
public const XmlDocumentation : String = "XmlDocumentation";

See Also

MetadataKeys Class
Gallio.Model Namespace


ModelException Class

ModelException Class
See Also Example Members
[image]

The type of exception thrown when test model and test framework operations fail.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class ModelException
Inherits Exception
C#
[SerializableAttribute]
public class ModelException : Exception
C++
[SerializableAttribute]
ref class ModelException : Exception
J#
/** @attribute SerializableAttribute() */
public class ModelException extends Exception
JScript
public
SerializableAttribute
class ModelException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Model.ModelException

See Also

ModelException Members
Gallio.Model Namespace


ModelException Members

ModelException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when test model and test framework operations fail.

The following tables list the members exposed by ModelException.

Public Constructors

Name | Description
ModelException | Overloaded. Initializes a new instance of the ModelException class.
Top

Protected Constructors

Name | Description
ModelException | Overloaded. Initializes a new instance of the ModelException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ModelException | Overloaded. Initializes a new instance of the ModelException class.
Top

See Also

ModelException Class
Gallio.Model Namespace


ModelException Constructor

ModelException Constructor

Initializes a new instance of the ModelException class.

Overload List

 | Name | Description
Public method | ModelException | Creates an exception.
Family method | ModelException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | ModelException (String) | Creates an exception.
Public method | ModelException (String, Exception) | Creates an exception.

See Also

ModelException Class
Gallio.Model Namespace


ModelException Constructor ()

ModelException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModelException()
C++
public:
ModelException() sealed
J#
public ModelException()
JScript
public function ModelException()

See Also

ModelException Class
Gallio.Model Namespace
ModelException Constructor Overload List


ModelException Constructor (SerializationInfo, StreamingContext)

ModelException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected ModelException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
ModelException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected ModelException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function ModelException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

ModelException Class
Gallio.Model Namespace
ModelException Constructor Overload List


ModelException Constructor (String)

ModelException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public ModelException(
string message
)
C++
public:
ModelException(
String message
) sealed
J#
public ModelException(
string message
)
JScript
public function ModelException(
message : String
)

Parameters

message
The message

See Also

ModelException Class
Gallio.Model Namespace
ModelException Constructor Overload List


ModelException Constructor (String, Exception)

ModelException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public ModelException(
string message,
Exception innerException
)
C++
public:
ModelException(
String message,
Exception innerException
) sealed
J#
public ModelException(
string message,
Exception innerException
)
JScript
public function ModelException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

ModelException Class
Gallio.Model Namespace
ModelException Constructor Overload List


ModelUtils Class

ModelUtils Class
See Also Example Members
[image]

Provides utility functions for manipulating the object model. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ModelUtils
C#
public static class ModelUtils
C++
ref class ModelUtils abstract sealed
J#
public final class ModelUtils
JScript
public class ModelUtils

Inheritance Hierarchy

System.Object
Gallio.Model.ModelUtils

See Also

ModelUtils Members
Gallio.Model Namespace


ModelUtils Members

ModelUtils Members
See Also Example Methods
[image]

Provides utility functions for manipulating the object model. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ModelUtils.

Public Methods

Name Description
PopulateMetadataFromAssembly

Populates the provided metadata map with asembly-level metadata derived from custom attributes.

Currently recognized attributes:

  • AssemblyCompanyAttribute
  • AssemblyConfigurationAttribute
  • AssemblyCopyrightAttribute
  • AssemblyDescriptionAttribute
  • AssemblyFileVersionAttribute
  • AssemblyInformationalVersionAttribute
  • AssemblyProductAttribute
  • AssemblyTitleAttribute
  • AssemblyTrademarkAttribute
  • AssemblyVersionAttribute
Top

See Also

ModelUtils Class
Gallio.Model Namespace


Methods

ModelUtils Methods
[image]

Public Methods

Name Description
PopulateMetadataFromAssembly

Populates the provided metadata map with asembly-level metadata derived from custom attributes.

Currently recognized attributes:

  • AssemblyCompanyAttribute
  • AssemblyConfigurationAttribute
  • AssemblyCopyrightAttribute
  • AssemblyDescriptionAttribute
  • AssemblyFileVersionAttribute
  • AssemblyInformationalVersionAttribute
  • AssemblyProductAttribute
  • AssemblyTitleAttribute
  • AssemblyTrademarkAttribute
  • AssemblyVersionAttribute
Top

See Also

ModelUtils Class
Gallio.Model Namespace


PopulateMetadataFromAssembly Method

ModelUtils.PopulateMetadataFromAssembly Method
[image]

Populates the provided metadata map with asembly-level metadata derived from custom attributes.

Currently recognized attributes:

  • AssemblyCompanyAttribute
  • AssemblyConfigurationAttribute
  • AssemblyCopyrightAttribute
  • AssemblyDescriptionAttribute
  • AssemblyFileVersionAttribute
  • AssemblyInformationalVersionAttribute
  • AssemblyProductAttribute
  • AssemblyTitleAttribute
  • AssemblyTrademarkAttribute
  • AssemblyVersionAttribute

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub PopulateMetadataFromAssembly( _
ByVal assembly As IAssemblyInfo, _
ByVal metadataMap As PropertyBag _
)
C#
public static void PopulateMetadataFromAssembly(
IAssemblyInfo assembly,
PropertyBag metadataMap
)
C++
public:
static void PopulateMetadataFromAssembly(
IAssemblyInfo assembly,
PropertyBag metadataMap
)
J#
public static void PopulateMetadataFromAssembly(
IAssemblyInfo assembly,
PropertyBag metadataMap
)
JScript
public static function PopulateMetadataFromAssembly(
assembly : IAssemblyInfo,
metadataMap : PropertyBag
)

Parameters

assembly
The assembly
metadataMap
The metadata map

See Also

ModelUtils Class
Gallio.Model Namespace


NullTestExplorer Class

NullTestExplorer Class
See Also Example Members
[image]

A null test explorer. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullTestExplorer
Inherits BaseTestExplorer
C#
public sealed class NullTestExplorer : BaseTestExplorer
C++
ref class NullTestExplorer sealed : BaseTestExplorer
J#
public final class NullTestExplorer extends BaseTestExplorer
JScript
public final class NullTestExplorer extends BaseTestExplorer

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestExplorer
Gallio.Model.NullTestExplorer

See Also

NullTestExplorer Members
Gallio.Model Namespace


NullTestExplorer Members

NullTestExplorer Members
See Also Example Constructors Properties Methods
[image]

A null test explorer. This class cannot be inherited.

The following tables list the members exposed by NullTestExplorer.

Public Constructors

 | Name | Description
Public method | NullTestExplorer | Create a null test explorer.
Top

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model that is incrementally populated by the test explorer as it explores tests. (inherited from BaseTestExplorer)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExploreAssembly | (inherited from BaseTestExplorer)
Public method | ExploreType | (inherited from BaseTestExplorer)
Public method | FinishModel | (inherited from BaseTestExplorer)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsTest | (inherited from BaseTestExplorer)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullTestExplorer Class
Gallio.Model Namespace


NullTestExplorer Constructor

NullTestExplorer Constructor
[image]

Create a null test explorer.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testModel As TestModel _
)
C#
public NullTestExplorer(
TestModel testModel
)
C++
public:
NullTestExplorer(
TestModel testModel
) sealed
J#
public NullTestExplorer(
TestModel testModel
)
JScript
public function NullTestExplorer(
testModel : TestModel
)

Parameters

testModel
The test model

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModel is null

See Also

NullTestExplorer Class
Gallio.Model Namespace


RootTest Class

RootTest Class
See Also Example Members
[image]

The root test in the test tree.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RootTest
Inherits BaseTest
C#
public class RootTest : BaseTest
C++
ref class RootTest : BaseTest
J#
public class RootTest extends BaseTest
JScript
public class RootTest extends BaseTest

Inheritance Hierarchy

System.Object
Gallio.Model.BaseTestComponent
Gallio.Model.BaseTest
Gallio.Model.RootTest

See Also

RootTest Members
Gallio.Model Namespace


RootTest Members

RootTest Members
See Also Example Constructors Properties Methods
[image]

The root test in the test tree.

The following tables list the members exposed by RootTest.

Public Constructors

 | Name | Description
Public method | RootTest | Creates the root test.
Top

Public Properties

Name | Description
Public property | Children | Gets a read-only list of the children of this test. (inherited from BaseTest)
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | Dependencies | Gets a read-only list of the dependencies of this test. (inherited from BaseTest)
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

(inherited from BaseTest)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTest)
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only. (inherited from BaseTest)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

(inherited from BaseTest)
Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId. (inherited from BaseTest)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from BaseTest)
Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant. (inherited from BaseTest)
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test. (inherited from BaseTest)
Public property | TestControllerFactory | Overridden. Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.
Top

Public Methods

 | Name | Description
Public method | AddChild | Adds a child test and sets its Parent property. (inherited from BaseTest)
Public method | AddDependency | Adds a test dependency. (inherited from BaseTest)
Public method | AddParameter | Adds a test parameter and sets its Owner property. (inherited from BaseTest)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetUniqueLocalIdForChild | Obtains a unique local id for a child of this test. (inherited from BaseTest)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseTest)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RootTest Class
Gallio.Model Namespace


RootTest Constructor

RootTest Constructor
[image]

Creates the root test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RootTest()
C++
public:
RootTest() sealed
J#
public RootTest()
JScript
public function RootTest()

See Also

RootTest Class
Gallio.Model Namespace


Properties

RootTest Properties
[image]

Public Properties

Name | Description
Public property | Children | Gets a read-only list of the children of this test. (inherited from BaseTest)
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from BaseTestComponent)
Public property | Dependencies | Gets a read-only list of the dependencies of this test. (inherited from BaseTest)
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

(inherited from BaseTest)
Public property | Id | Gets the stable unique identifier of the component. (inherited from BaseTest)
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only. (inherited from BaseTest)
Public property | Kind | Gets or sets the value of the TestKind metadata entry. (This is a convenience method.) (inherited from BaseTestComponent)
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

(inherited from BaseTest)
Public property | LocalIdHint | Gets or sets a suggested LocalId hint, or null if none. The value returned by this method will be checked for uniqueness and amended as necessary to produce a truly unique LocalId. (inherited from BaseTest)
Public property | Metadata | Gets the metadata of the component. (inherited from BaseTestComponent)
Public property | Name | Gets the name of the component. (inherited from BaseTestComponent)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from BaseTest)
Public property | Parameters | Gets a read-only list of the parameters of this test. Each parameter must have a unique name. The order in which the parameters appear is not significant. (inherited from BaseTest)
Public property | Parent | Gets or sets the parent of this test, or null if this is the root test. (inherited from BaseTest)
Public property | TestControllerFactory | Overridden. Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.
Top

See Also

RootTest Class
Gallio.Model Namespace


TestControllerFactory Property

RootTest.TestControllerFactory Property
[image]

Gets a ITestControllerFunc to run this tes and all of its children. Returns null if this test is merely a container for other tests or if it otherwise does not require or provide its own controller.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TestControllerFactory As Func(Of ITestController) _
Implements ITest.TestControllerFactory
C#
public override Func<ITestController> TestControllerFactory { get; }
C++
public override property Func<ITestController> TestControllerFactory override {
Func<ITestController> get();
}
J#
/** property */
public Func<ITestController> get_TestControllerFactory();
JScript
public function get TestControllerFactory() : Func<ITestController>

Property Value

The test controller factory, or null if this test cannot produce a controller (and consequently is not a master test according to the definition above)

Implements

ITest.TestControllerFactory

See Also

RootTest Class
Gallio.Model Namespace


TestComponentInfo Class

TestComponentInfo Class
See Also Example Members
[image]

A read-only implementation of ITestComponent for reflection. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TestComponentInfo
Inherits BaseInfo
Implements ITestComponent
C#
public abstract class TestComponentInfo : BaseInfo, ITestComponent
C++
ref class TestComponentInfo abstract : BaseInfo, ITestComponent
J#
public class TestComponentInfo extends BaseInfo implements ITestComponent
JScript
public class TestComponentInfo extends BaseInfo, ITestComponent

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfo
Gallio.Model.TestComponentInfo
Gallio.Model.TestInfo
Gallio.Model.TestParameterInfo
Gallio.Model.TestStepInfo

See Also

TestComponentInfo Members
Gallio.Model Namespace


TestComponentInfo Members

TestComponentInfo Members
See Also Example Properties Methods
[image]

A read-only implementation of ITestComponent for reflection. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestComponentInfo.

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Metadata | Gets the metadata of the component.
Public property | Name | Gets the name of the component.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from BaseInfo)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from BaseInfo)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseInfo)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestComponentInfo Class
Gallio.Model Namespace


Properties

TestComponentInfo Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown.
Public property | Id | Gets the stable unique identifier of the component.
Public property | Metadata | Gets the metadata of the component.
Public property | Name | Gets the name of the component.
Top

See Also

TestComponentInfo Class
Gallio.Model Namespace


CodeElement Property

TestComponentInfo.CodeElement Property
[image]

Gets a reference to the point of definition of this test component in the code, or null if unknown.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CodeElement As ICodeElementInfo _
Implements ITestComponent.CodeElement
C#
public ICodeElementInfo CodeElement { get; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

Implements

ITestComponent.CodeElement

See Also

TestComponentInfo Class
Gallio.Model Namespace


Id Property

TestComponentInfo.Id Property
[image]

Gets the stable unique identifier of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As String _
Implements ITestComponent.Id
C#
public string Id { get; }
C++
public property string Id sealed {
String get();
}
J#
/** property */
public string get_Id();
JScript
public function get Id() : String

Implements

ITestComponent.Id

See Also

TestComponentInfo Class
Gallio.Model Namespace


Metadata Property

TestComponentInfo.Metadata Property
[image]

Gets the metadata of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metadata As PropertyBag _
Implements ITestComponent.Metadata
C#
public PropertyBag Metadata { get; }
C++
public property PropertyBag Metadata sealed {
PropertyBag get();
}
J#
/** property */
public PropertyBag get_Metadata();
JScript
public function get Metadata() : PropertyBag

Implements

ITestComponent.Metadata

See Also

TestComponentInfo Class
Gallio.Model Namespace


Name Property

TestComponentInfo.Name Property
[image]

Gets the name of the component.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String _
Implements ITestComponent.Name
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ITestComponent.Name

See Also

TestComponentInfo Class
Gallio.Model Namespace


TestDomainSetup Class

TestDomainSetup Class
See Also Example Members
[image]

Specifies setup options for a test domain. A test domain represents an isolated host environment within which a subset of a test package will be loaded, explored and run.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class TestDomainSetup
C#
[SerializableAttribute]
public class TestDomainSetup
C++
[SerializableAttribute]
ref class TestDomainSetup
J#
/** @attribute SerializableAttribute() */
public class TestDomainSetup
JScript
public
SerializableAttribute
class TestDomainSetup

Inheritance Hierarchy

System.Object
Gallio.Model.TestDomainSetup

See Also

TestDomainSetup Members
Gallio.Model Namespace


TestDomainSetup Members

TestDomainSetup Members
See Also Example Constructors Properties Methods
[image]

Specifies setup options for a test domain. A test domain represents an isolated host environment within which a subset of a test package will be loaded, explored and run.

The following tables list the members exposed by TestDomainSetup.

Public Constructors

 | Name | Description
Public method | TestDomainSetup | Creates setup options a test domain.
Top

Public Properties

 | Name | Description
Public property | TestPackageConfig | Gets or sets the test package configuration to load in the test domain.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | MergeFrom | Merges the contents of another test domain setup into this one.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestDomainSetup Class
Gallio.Model Namespace


TestDomainSetup Constructor

TestDomainSetup Constructor
[image]

Creates setup options a test domain.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testPackageConfig As TestPackageConfig _
)
C#
public TestDomainSetup(
TestPackageConfig testPackageConfig
)
C++
public:
TestDomainSetup(
TestPackageConfig testPackageConfig
) sealed
J#
public TestDomainSetup(
TestPackageConfig testPackageConfig
)
JScript
public function TestDomainSetup(
testPackageConfig : TestPackageConfig
)

Parameters

testPackageConfig
The test package configuration to load in the test domain

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackageConfig is null

See Also

TestDomainSetup Class
Gallio.Model Namespace


Properties

TestDomainSetup Properties
[image]

Public Properties

 | Name | Description
Public property | TestPackageConfig | Gets or sets the test package configuration to load in the test domain.
Top

See Also

TestDomainSetup Class
Gallio.Model Namespace


TestPackageConfig Property

TestDomainSetup.TestPackageConfig Property
[image]

Gets or sets the test package configuration to load in the test domain.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestPackageConfig As TestPackageConfig
C#
public TestPackageConfig TestPackageConfig { get; set; }
C++
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
void set(TestPackageConfig value);
}
J#
/** property */
public TestPackageConfig get_TestPackageConfig();

/** property */
public void set_TestPackageConfig(TestPackageConfig value);
JScript
public function get TestPackageConfig() : TestPackageConfig

public function set TestPackageConfig(value : TestPackageConfig);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestDomainSetup Class
Gallio.Model Namespace


Methods

TestDomainSetup Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | MergeFrom | Merges the contents of another test domain setup into this one.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestDomainSetup Class
Gallio.Model Namespace


MergeFrom Method

TestDomainSetup.MergeFrom Method
[image]

Merges the contents of another test domain setup into this one.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub MergeFrom( _
ByVal source As TestDomainSetup _
)
C#
public void MergeFrom(
TestDomainSetup source
)
C++
public:
void MergeFrom(
TestDomainSetup source
) sealed
J#
public void MergeFrom(
TestDomainSetup source
)
JScript
public function MergeFrom(
source : TestDomainSetup
)

Parameters

source
The source setup

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestDomainSetup Class
Gallio.Model Namespace


TestExplorationOptions Class

TestExplorationOptions Class
See Also Example Members
[image]

Provides options that control how test exploration occurs. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class TestExplorationOptions
C#
[SerializableAttribute]
public sealed class TestExplorationOptions
C++
[SerializableAttribute]
ref class TestExplorationOptions sealed
J#
/** @attribute SerializableAttribute() */
public final class TestExplorationOptions
JScript
public
SerializableAttribute
final class TestExplorationOptions

Inheritance Hierarchy

System.Object
Gallio.Model.TestExplorationOptions

See Also

TestExplorationOptions Members
Gallio.Model Namespace


TestExplorationOptions Members

TestExplorationOptions Members
See Also Example Constructors Methods
[image]

Provides options that control how test exploration occurs. This class cannot be inherited.

The following tables list the members exposed by TestExplorationOptions.

Public Constructors

 | Name | Description
Public method | TestExplorationOptions | Initializes a new instance of the TestExplorationOptions class.
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestExplorationOptions Class
Gallio.Model Namespace


TestExplorationOptions Constructor

TestExplorationOptions Constructor
[image]

Initializes a new instance of the TestExplorationOptions class.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestExplorationOptions()
C++
public:
TestExplorationOptions() sealed
J#
public TestExplorationOptions()
JScript
public function TestExplorationOptions()

See Also

TestExplorationOptions Class
Gallio.Model Namespace


Methods

TestExplorationOptions Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestExplorationOptions Class
Gallio.Model Namespace


Copy Method

TestExplorationOptions.Copy Method
[image]

Creates a copy of the options.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As TestExplorationOptions
C#
public TestExplorationOptions Copy()
C++
public:
TestExplorationOptions Copy() sealed
J#
public TestExplorationOptions Copy()
JScript
public function Copy() : TestExplorationOptions

Return Value

The copy

See Also

TestExplorationOptions Class
Gallio.Model Namespace


TestInfo Class

TestInfo Class
See Also Example Members
[image]

A read-only implementation of ITest for reflection. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestInfo
Inherits TestComponentInfo
Implements ITest
C#
public sealed class TestInfo : TestComponentInfo, ITest
C++
ref class TestInfo sealed : TestComponentInfo, ITest
J#
public final class TestInfo extends TestComponentInfo implements ITest
JScript
public final class TestInfo extends TestComponentInfo, ITest

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfo
Gallio.Model.TestComponentInfo
Gallio.Model.TestInfo

See Also

TestInfo Members
Gallio.Model Namespace


TestInfo Members

TestInfo Members
See Also Example Constructors Properties Methods
[image]

A read-only implementation of ITest for reflection. This class cannot be inherited.

The following tables list the members exposed by TestInfo.

Public Constructors

 | Name | Description
Public method | TestInfo | Creates a read-only wrapper of a test.
Top

Public Properties

Name | Description
Public property | Children
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from TestComponentInfo)
Public property | Dependencies
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Public property | Id | Gets the stable unique identifier of the component. (inherited from TestComponentInfo)
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | Metadata | Gets the metadata of the component. (inherited from TestComponentInfo)
Public property | Name | Gets the name of the component. (inherited from TestComponentInfo)
Public property | Order
Public property | Parameters
Public property | Parent
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from BaseInfo)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from BaseInfo)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseInfo)
Top

See Also

TestInfo Class
Gallio.Model Namespace


TestInfo Constructor

TestInfo Constructor
[image]

Creates a read-only wrapper of a test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITest _
)
C#
public TestInfo(
ITest source
)
C++
public:
TestInfo(
ITest source
) sealed
J#
public TestInfo(
ITest source
)
JScript
public function TestInfo(
source : ITest
)

Parameters

source
The source test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestInfo Class
Gallio.Model Namespace


Properties

TestInfo Properties
[image]

Public Properties

Name | Description
Public property | Children
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from TestComponentInfo)
Public property | Dependencies
Public property FullName

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Public property | Id | Gets the stable unique identifier of the component. (inherited from TestComponentInfo)
Public property | IsTestCase | Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.
Public property LocalId

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Public property | Metadata | Gets the metadata of the component. (inherited from TestComponentInfo)
Public property | Name | Gets the name of the component. (inherited from TestComponentInfo)
Public property | Order
Public property | Parameters
Public property | Parent
Top

See Also

TestInfo Class
Gallio.Model Namespace


Children Property

TestInfo.Children Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Children As TestInfoList
C#
public TestInfoList Children { get; }
C++
public property TestInfoList Children sealed {
TestInfoList get();
}
J#
/** property */
public TestInfoList get_Children();
JScript
public function get Children() : TestInfoList

See Also

TestInfo Class
Gallio.Model Namespace


Dependencies Property

TestInfo.Dependencies Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dependencies As TestInfoList
C#
public TestInfoList Dependencies { get; }
C++
public property TestInfoList Dependencies sealed {
TestInfoList get();
}
J#
/** property */
public TestInfoList get_Dependencies();
JScript
public function get Dependencies() : TestInfoList

See Also

TestInfo Class
Gallio.Model Namespace


FullName Property

TestInfo.FullName Property
[image]

Gets the full name of the test. The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test.

The full name of the root test is empty.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String _
Implements ITest.FullName
C#
public string FullName { get; }
C++
public property string FullName sealed {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITest.FullName

See Also

TestInfo Class
Gallio.Model Namespace


IsTestCase Property

TestInfo.IsTestCase Property
[image]

Gets whether this test represents an individual test case as opposed to a test container such as a fixture or suite. The value of this property can be used by the test harness to avoid processing containers that have no test cases. It can also be used by the reporting infrastructure to constrain output statistics to test cases only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTestCase As Boolean _
Implements ITest.IsTestCase
C#
public bool IsTestCase { get; }
C++
public property bool IsTestCase sealed {
bool get();
}
J#
/** property */
public bool get_IsTestCase();
JScript
public function get IsTestCase() : bool

Implements

ITest.IsTestCase

See Also

TestInfo Class
Gallio.Model Namespace


LocalId Property

TestInfo.LocalId Property
[image]

Gets a locally unique identifier for this test that satisfies the following conditions:

  • The identifier is unique among all siblings of this test belonging to the same parent.
  • The identifier is likely to be stable across multiple sessions including changes and recompilations of the test projects.
  • The identifier is non-null.

The local identifier may be the same as the test's name. However since the name is intended for display to end-users, it may contain irrelevant details (such as version numbers) that would reduce its long-term stability. In that case, a different local identifier should be selected such as one based on the test's CodeElement and an ordering condition among siblings to guarantee uniqueness.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LocalId As String _
Implements ITest.LocalId
C#
public string LocalId { get; }
C++
public property string LocalId sealed {
String get();
}
J#
/** property */
public string get_LocalId();
JScript
public function get LocalId() : String

Property Value

The locally unique identifier

Implements

ITest.LocalId

See Also

TestInfo Class
Gallio.Model Namespace


Order Property

TestInfo.Order Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Order As Integer
C#
public int Order { get; }
C++
public property int Order sealed {
int get();
}
J#
/** property */
public int get_Order();
JScript
public function get Order() : int

See Also

TestInfo Class
Gallio.Model Namespace


Parameters Property

TestInfo.Parameters Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As TestParameterInfoList
C#
public TestParameterInfoList Parameters { get; }
C++
public property TestParameterInfoList Parameters sealed {
TestParameterInfoList get();
}
J#
/** property */
public TestParameterInfoList get_Parameters();
JScript
public function get Parameters() : TestParameterInfoList

See Also

TestInfo Class
Gallio.Model Namespace


Parent Property

TestInfo.Parent Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ITest
C#
public ITest Parent { get; }
C++
public property ITest Parent sealed {
ITest get();
}
J#
/** property */
public ITest get_Parent();
JScript
public function get Parent() : ITest

See Also

TestInfo Class
Gallio.Model Namespace


TestInfoList Class

TestInfoList Class
See Also Example Members
[image]

Wraps a list of ITest for reflection. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestInfoList
Inherits BaseInfoList(Of ITest, TestInfo)
C#
public sealed class TestInfoList : BaseInfoList<ITest, TestInfo>
C++
ref class TestInfoList sealed : BaseInfoList<ITest, TestInfo>
J#
public final class TestInfoList extends BaseInfoList<ITest, TestInfo>
JScript
public final class TestInfoList extends BaseInfoList<ITest, TestInfo>

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfoList<TModel,TInfo>
Gallio.Model.TestInfoList

See Also

TestInfoList Members
Gallio.Model Namespace


TestInfoList Members

TestInfoList Members
See Also Example Constructors Properties Methods
[image]

Wraps a list of ITest for reflection. This class cannot be inherited.

The following tables list the members exposed by TestInfoList.

Public Constructors

 | Name | Description
Public method | TestInfoList | Creates a wrapper for the specified list of tests.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection. (inherited from BaseInfoList)
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only. (inherited from BaseInfoList)
Public property | Item | (inherited from BaseInfoList)
Top

Public Methods

 | Name | Description
Public method | AsModelList | Returns a wrapper for the list of elements using the model object's type instead of the reflection object's type. (inherited from BaseInfoList)
Public method | Contains | (inherited from BaseInfoList)
Public method | CopyTo | (inherited from BaseInfoList)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from BaseInfoList)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | (inherited from BaseInfoList)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestInfoList Class
Gallio.Model Namespace


TestInfoList Constructor

TestInfoList Constructor
[image]

Creates a wrapper for the specified list of tests.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal inputList As IList(Of ITest) _
)
C#
public TestInfoList(
IList<ITest> inputList
)
C++
public:
TestInfoList(
IList<ITest> inputList
) sealed
J#
public TestInfoList(
IList<ITest> inputList
)
JScript
public function TestInfoList(
inputList : IList<ITest>
)

Parameters

inputList
The source test list

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if inputList is null

See Also

TestInfoList Class
Gallio.Model Namespace


TestKinds Class

TestKinds Class
See Also Example Members
[image]

Specifies the kind of a test component. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestKinds
C#
public static class TestKinds
C++
ref class TestKinds abstract sealed
J#
public final class TestKinds
JScript
public class TestKinds

Remarks

The test kind is ignored by the test runner but it allows tests to be classified so that a user interface can provide appropriate decorations and other affordances for any test kinds that it recognizes.

If none of the built-in kinds are appropriate, you may use the Custom kind or invent your own kind as you wish.

Inheritance Hierarchy

System.Object
Gallio.Model.TestKinds

See Also

TestKinds Members
Gallio.Model Namespace
TestKind


TestKinds Members

TestKinds Members
See Also Example Fields
[image]

Specifies the kind of a test component. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestKinds.

Public Fields

Name | Description
Assembly | The test represents the tests contained in a single test assembly. This field is constant and read-only.
Custom | The test is of some other unspecified kind. This field is constant and read-only.
Error | The test is an error placeholder used in place of a test when an error occurs during test enumeration. This field is constant and read-only.
Fixture | The test represents a test fixture. This field is constant and read-only.
Framework | The test represents a grouping of all contributions offered by a given test framework. This field is constant and read-only.
Group | The test represents a grouping of tests for descriptive purposes. This field is constant and read-only.
Namespace | The test represents the tests contained in a single test namespace. This field is constant and read-only.
Root | The test represents the root of the test tree. This field is constant and read-only.
Suite | The test represents a test suite. This field is constant and read-only.
Test | The test represents a test case. This field is constant and read-only.
Top

See Also

TestKinds Class
Gallio.Model Namespace
TestKind


Fields

TestKinds Fields
[image]

Public Fields

Name | Description
Assembly | The test represents the tests contained in a single test assembly. This field is constant and read-only.
Custom | The test is of some other unspecified kind. This field is constant and read-only.
Error | The test is an error placeholder used in place of a test when an error occurs during test enumeration. This field is constant and read-only.
Fixture | The test represents a test fixture. This field is constant and read-only.
Framework | The test represents a grouping of all contributions offered by a given test framework. This field is constant and read-only.
Group | The test represents a grouping of tests for descriptive purposes. This field is constant and read-only.
Namespace | The test represents the tests contained in a single test namespace. This field is constant and read-only.
Root | The test represents the root of the test tree. This field is constant and read-only.
Suite | The test represents a test suite. This field is constant and read-only.
Test | The test represents a test case. This field is constant and read-only.
Top

See Also

TestKinds Class
Gallio.Model Namespace
TestKind


Assembly Field

TestKinds.Assembly Field
[image]

The test represents the tests contained in a single test assembly. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Assembly As String = "Assembly"
C#
public const string Assembly = "Assembly";
C++
public:
const String Assembly = L"Assembly";
J#
public const string Assembly = "Assembly"
JScript
public const Assembly : String = "Assembly";

See Also

TestKinds Class
Gallio.Model Namespace


Custom Field

TestKinds.Custom Field
[image]

The test is of some other unspecified kind. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Custom As String = "Custom"
C#
public const string Custom = "Custom";
C++
public:
const String Custom = L"Custom";
J#
public const string Custom = "Custom"
JScript
public const Custom : String = "Custom";

Remarks

If none of the built-in kinds are appropriate, you may use the Custom kind or invent one of your own to present in the user interface (albeit perhaps without special affordances.)

See Also

TestKinds Class
Gallio.Model Namespace


Error Field

TestKinds.Error Field
[image]

The test is an error placeholder used in place of a test when an error occurs during test enumeration. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Error As String = "Error"
C#
public const string Error = "Error";
C++
public:
const String Error = L"Error";
J#
public const string Error = "Error"
JScript
public const Error : String = "Error";

See Also

TestKinds Class
Gallio.Model Namespace


Fixture Field

TestKinds.Fixture Field
[image]

The test represents a test fixture. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Fixture As String = "Fixture"
C#
public const string Fixture = "Fixture";
C++
public:
const String Fixture = L"Fixture";
J#
public const string Fixture = "Fixture"
JScript
public const Fixture : String = "Fixture";

See Also

TestKinds Class
Gallio.Model Namespace


Framework Field

TestKinds.Framework Field
[image]

The test represents a grouping of all contributions offered by a given test framework. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Framework As String = "Framework"
C#
public const string Framework = "Framework";
C++
public:
const String Framework = L"Framework";
J#
public const string Framework = "Framework"
JScript
public const Framework : String = "Framework";

See Also

TestKinds Class
Gallio.Model Namespace


Group Field

TestKinds.Group Field
[image]

The test represents a grouping of tests for descriptive purposes. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Group As String = "Group"
C#
public const string Group = "Group";
C++
public:
const String Group = L"Group";
J#
public const string Group = "Group"
JScript
public const Group : String = "Group";

See Also

TestKinds Class
Gallio.Model Namespace


Namespace Field

TestKinds.Namespace Field
[image]

The test represents the tests contained in a single test namespace. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Namespace As String = "Namespace"
C#
public const string Namespace = "Namespace";
C++
public:
const String Namespace = L"Namespace";
J#
public const string Namespace = "Namespace"
JScript
public const Namespace : String = "Namespace";

See Also

TestKinds Class
Gallio.Model Namespace


Root Field

TestKinds.Root Field
[image]

The test represents the root of the test tree. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Root As String = "Root"
C#
public const string Root = "Root";
C++
public:
const String Root = L"Root";
J#
public const string Root = "Root"
JScript
public const Root : String = "Root";

See Also

TestKinds Class
Gallio.Model Namespace


Suite Field

TestKinds.Suite Field
[image]

The test represents a test suite. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Suite As String = "Suite"
C#
public const string Suite = "Suite";
C++
public:
const String Suite = L"Suite";
J#
public const string Suite = "Suite"
JScript
public const Suite : String = "Suite";

See Also

TestKinds Class
Gallio.Model Namespace


Test Field

TestKinds.Test Field
[image]

The test represents a test case. This field is constant and read-only.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Test As String = "Test"
C#
public const string Test = "Test";
C++
public:
const String Test = L"Test";
J#
public const string Test = "Test"
JScript
public const Test : String = "Test";

See Also

TestKinds Class
Gallio.Model Namespace


TestModel Class

TestModel Class
See Also Example Members
[image]

The test model provides access to the contents of the test tree generated from a test package by the test enumeration process. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestModel
C#
public sealed class TestModel
C++
ref class TestModel sealed
J#
public final class TestModel
JScript
public final class TestModel

Inheritance Hierarchy

System.Object
Gallio.Model.TestModel

See Also

TestModel Members
Gallio.Model Namespace


TestModel Members

TestModel Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The test model provides access to the contents of the test tree generated from a test package by the test enumeration process. This class cannot be inherited.

The following tables list the members exposed by TestModel.

Public Constructors

Name | Description
TestModel | Overloaded.
Top

Public Properties

Name | Description
Public property | AllTests | Recursively enumerates all tests including the root test.
Public property Annotations

Gets the read-only list of annotations.

An annotation is an informational, warning or error message associated with a code element in the test model.

Test frameworks publish annotations on the test model that describe usage errors or warnings about problems that may prevent tests from running, such as using a custom attribute incorrectly. They may also emit informational annotations to draw the user's attention, such as by flagging ignored or pending tests.

The presentation of annotations is undefined. A command-line test runner might simply log them whereas an IDE plugin could generate new task items to incorporate them into the UI.

Public property | RootTest | Gets the root test in the model.
Public property | TestPackage | Gets the test package.
Top

Public Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestModel | Overloaded.
Top

See Also

TestModel Class
Gallio.Model Namespace


TestModel Constructor

TestModel Constructor

Overload List

 | Name | Description
Public method | TestModel (TestPackage) | Creates a test model with a new empty root test.
Public method | TestModel (TestPackage, RootTest) | Creates a test model.

See Also

TestModel Class
Gallio.Model Namespace


TestModel Constructor (TestPackage)

TestModel Constructor (TestPackage)
See Also Example
[image]

Creates a test model with a new empty root test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testPackage As TestPackage _
)
C#
public TestModel(
TestPackage testPackage
)
C++
public:
TestModel(
TestPackage testPackage
) sealed
J#
public TestModel(
TestPackage testPackage
)
JScript
public function TestModel(
testPackage : TestPackage
)

Parameters

testPackage
The test package from which the model was created

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackage is null

See Also

TestModel Class
Gallio.Model Namespace
TestModel Constructor Overload List


TestModel Constructor (TestPackage, RootTest)

TestModel Constructor (TestPackage, RootTest)
See Also Example
[image]

Creates a test model.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testPackage As TestPackage, _
ByVal rootTest As RootTest _
)
C#
public TestModel(
TestPackage testPackage,
RootTest rootTest
)
C++
public:
TestModel(
TestPackage testPackage,
RootTest rootTest
) sealed
J#
public TestModel(
TestPackage testPackage,
RootTest rootTest
)
JScript
public function TestModel(
testPackage : TestPackage,
rootTest : RootTest
)

Parameters

testPackage
The test package from which the model was created
rootTest
The root test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackage or rootTest is null

See Also

TestModel Class
Gallio.Model Namespace
TestModel Constructor Overload List


Properties

TestModel Properties
[image]

Public Properties

Name | Description
Public property | AllTests | Recursively enumerates all tests including the root test.
Public property Annotations

Gets the read-only list of annotations.

An annotation is an informational, warning or error message associated with a code element in the test model.

Test frameworks publish annotations on the test model that describe usage errors or warnings about problems that may prevent tests from running, such as using a custom attribute incorrectly. They may also emit informational annotations to draw the user's attention, such as by flagging ignored or pending tests.

The presentation of annotations is undefined. A command-line test runner might simply log them whereas an IDE plugin could generate new task items to incorporate them into the UI.

Public property | RootTest | Gets the root test in the model.
Public property | TestPackage | Gets the test package.
Top

See Also

TestModel Class
Gallio.Model Namespace


AllTests Property

TestModel.AllTests Property
[image]

Recursively enumerates all tests including the root test.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllTests As IEnumerable(Of ITest)
C#
public IEnumerable<ITest> AllTests { get; }
C++
public property IEnumerable<ITest> AllTests sealed {
IEnumerable<ITest> get();
}
J#
/** property */
public IEnumerable<ITest> get_AllTests();
JScript
public function get AllTests() : IEnumerable<ITest>

See Also

TestModel Class
Gallio.Model Namespace


Annotations Property

TestModel.Annotations Property
[image]

Gets the read-only list of annotations.

An annotation is an informational, warning or error message associated with a code element in the test model.

Test frameworks publish annotations on the test model that describe usage errors or warnings about problems that may prevent tests from running, such as using a custom attribute incorrectly. They may also emit informational annotations to draw the user's attention, such as by flagging ignored or pending tests.

The presentation of annotations is undefined. A command-line test runner might simply log them whereas an IDE plugin could generate new task items to incorporate them into the UI.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Annotations As IList(Of Annotation)
C#
public IList<Annotation> Annotations { get; }
C++
public property IList<Annotation> Annotations sealed {
IList<Annotation> get();
}
J#
/** property */
public IList<Annotation> get_Annotations();
JScript
public function get Annotations() : IList<Annotation>

See Also

TestModel Class
Gallio.Model Namespace


RootTest Property

TestModel.RootTest Property
[image]

Gets the root test in the model.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootTest As RootTest
C#
public RootTest RootTest { get; }
C++
public property RootTest RootTest sealed {
RootTest get();
}
J#
/** property */
public RootTest get_RootTest();
JScript
public function get RootTest() : RootTest

See Also

TestModel Class
Gallio.Model Namespace


TestPackage Property

TestModel.TestPackage Property
[image]

Gets the test package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestPackage As TestPackage
C#
public TestPackage TestPackage { get; }
C++
public property TestPackage TestPackage sealed {
TestPackage get();
}
J#
/** property */
public TestPackage get_TestPackage();
JScript
public function get TestPackage() : TestPackage

See Also

TestModel Class
Gallio.Model Namespace


Methods

TestModel Methods
[image]

Public Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestModel Class
Gallio.Model Namespace


AddAnnotation Method

TestModel.AddAnnotation Method
[image]

Adds an annotation.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAnnotation( _
ByVal annotation As Annotation _
)
C#
public void AddAnnotation(
Annotation annotation
)
C++
public:
void AddAnnotation(
Annotation annotation
) sealed
J#
public void AddAnnotation(
Annotation annotation
)
JScript
public function AddAnnotation(
annotation : Annotation
)

Parameters

annotation
The annotation to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if annotation is null

See Also

TestModel Class
Gallio.Model Namespace
Annotations


TestOutcome Structure

TestOutcome Structure
See Also Example Members
[image]

Describes the outcome of a test.

An outcome consists of two parts. First, a required Status that describes whether test passed, failed or was inconclusive. Second, an optional Category that enables different outcomes with the same status to be distinguished. The category also provides an opportunity to extend the definition of a test outcome to include custom semantic details.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("outcome", Namespace := "http://www.gallio.org/"), _
XmlSchemaProviderAttribute("ProvideXmlSchema")>
Public Structure TestOutcome
Implements IXmlSerializable, IEquatable(Of TestOutcome)
C#
[SerializableAttribute]
[XmlRootAttribute("outcome", Namespace = "http://www.gallio.org/")]
[XmlSchemaProviderAttribute("ProvideXmlSchema")]
public struct TestOutcome : IXmlSerializable, IEquatable<TestOutcome>
C++
[SerializableAttribute]
[XmlRootAttribute(L"outcome", Namespace = L"http://www.gallio.org/")]
[XmlSchemaProviderAttribute(L"ProvideXmlSchema")]
value class TestOutcome : IXmlSerializable, IEquatable<TestOutcome>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("outcome", Namespace = "http://www.gallio.org/") */
/** @attribute XmlSchemaProviderAttribute("ProvideXmlSchema") */
public final class TestOutcome extends ValueType implements IXmlSerializable, IEquatable<TestOutcome>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Model.TestOutcome

See Also

TestOutcome Members
Gallio.Model Namespace


TestOutcome Members

TestOutcome Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes the outcome of a test.

An outcome consists of two parts. First, a required Status that describes whether test passed, failed or was inconclusive. Second, an optional Category that enables different outcomes with the same status to be distinguished. The category also provides an opportunity to extend the definition of a test outcome to include custom semantic details.

The following tables list the members exposed by TestOutcome.

Public Constructors

Name | Description
TestOutcome | Overloaded.
Top

Public Properties

Name | Description
Canceled | Gets a standard outcome for a test that has an inconclusive outcome because it was canceled.
Public property Category

Gets the test outcome category, or null if none. Never an empty string.

The category, when provided, provides additional information to describe what happened to result in this particular outcome.

Examples: "ignored", "skipped", "pending", "canceled", "aborted", "timeout".

Naming guidelines:

  • A category should be a single lower-case word.
  • It should be a word that can appear on its own or following a number. Consequently, nouns are poor choices because they may need to be pluralized.
  • It should not repeat the information already provided by the Status. Consequently, "passed", "failed" and "inconclusive" are poor choices.
  • It should be a standard category, if possible.
  • It should not be too granular. If too many categories are in common usage, test result summaries by category may become unwieldly.
Public property DisplayName

Gets the name of the outcome as it should be displayed.

The display name is the outcome's Category, if available. Otherwise it is a lowercase rendition of the outcome's Status.

Error | Gets a standard outcome for a test that failed due to an error.
Explicit | Gets a standard outcome for a test that did not run because it must be selected explicitly. The test may be particularly expensive or require manual supervision by an operator.
Failed | Gets a standard outcome for a test that failed.
Ignored | Gets a standard outcome for a test that did not run because the user is choosing to ignore it. Perhaps the test is broken or non-functional.
Inconclusive | Gets a standard outcome for a test that was inconclusive.
Passed | Gets a standard outcome for a test that passed.
Pending | Gets a standard outcome for a test that did not run because it has unsatisfied prerequisites. The test may depend on functionality that has not yet been implemented or perhaps the test itself has yet to be implemented.
Skipped | Gets a standard outcome for a test that did not run.
Public property Status

Gets the test status.

The test status describes whether a test passed, failed or produced an inconclusive result. This information may be reported to the user with icons and textual labels to explain the overall significance of the outcome.

Timeout | Gets a standard outcome for a test that failed because it ran out of time.
Top

Public Methods

 | Name | Description
Public method | CombineWith | If the other outcome is more severe than this one, returns it. Otherwise returns this outcome.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | Generalize | Produces an outcome with the same status but omitting the category information.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two outcomes for equality.
 | op_Inequality | Compares two outcomes for inequality.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Overridden. Returns the DisplayName of the outcome.
Top

Explicit Interface Implementations

Name | Description
TestOutcome | Overloaded.
Top

See Also

TestOutcome Structure
Gallio.Model Namespace


TestOutcome Constructor

TestOutcome Constructor

Overload List

 | Name | Description
Public method | TestOutcome (TestStatus) | Creates a test outcome with no category.
Public method | TestOutcome (TestStatus, String) | Creates a test outcome with an optional category.

See Also

TestOutcome Structure
Gallio.Model Namespace


TestOutcome Constructor (TestStatus)

TestOutcome Constructor (TestStatus)
See Also Example
[image]

Creates a test outcome with no category.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal status As TestStatus _
)
C#
public TestOutcome(
TestStatus status
)
C++
public:
TestOutcome(
TestStatus status
) sealed
J#
public TestOutcome(
TestStatus status
)
JScript
public function TestOutcome(
status : TestStatus
)

Parameters

status
The test Status

See Also

TestOutcome Structure
Gallio.Model Namespace
TestOutcome Constructor Overload List


TestOutcome Constructor (TestStatus, String)

TestOutcome Constructor (TestStatus, String)
See Also Example
[image]

Creates a test outcome with an optional category.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal status As TestStatus, _
ByVal category As String _
)
C#
public TestOutcome(
TestStatus status,
string category
)
C++
public:
TestOutcome(
TestStatus status,
String category
) sealed
J#
public TestOutcome(
TestStatus status,
string category
)
JScript
public function TestOutcome(
status : TestStatus,
category : String
)

Parameters

status
The test Status
category
The test Category, or null or an empty string if none

See Also

TestOutcome Structure
Gallio.Model Namespace
TestOutcome Constructor Overload List


Properties

TestOutcome Properties
[image]

Public Properties

Name | Description
Canceled | Gets a standard outcome for a test that has an inconclusive outcome because it was canceled.
Public property Category

Gets the test outcome category, or null if none. Never an empty string.

The category, when provided, provides additional information to describe what happened to result in this particular outcome.

Examples: "ignored", "skipped", "pending", "canceled", "aborted", "timeout".

Naming guidelines:

  • A category should be a single lower-case word.
  • It should be a word that can appear on its own or following a number. Consequently, nouns are poor choices because they may need to be pluralized.
  • It should not repeat the information already provided by the Status. Consequently, "passed", "failed" and "inconclusive" are poor choices.
  • It should be a standard category, if possible.
  • It should not be too granular. If too many categories are in common usage, test result summaries by category may become unwieldly.
Public property DisplayName

Gets the name of the outcome as it should be displayed.

The display name is the outcome's Category, if available. Otherwise it is a lowercase rendition of the outcome's Status.

Error | Gets a standard outcome for a test that failed due to an error.
Explicit | Gets a standard outcome for a test that did not run because it must be selected explicitly. The test may be particularly expensive or require manual supervision by an operator.
Failed | Gets a standard outcome for a test that failed.
Ignored | Gets a standard outcome for a test that did not run because the user is choosing to ignore it. Perhaps the test is broken or non-functional.
Inconclusive | Gets a standard outcome for a test that was inconclusive.
Passed | Gets a standard outcome for a test that passed.
Pending | Gets a standard outcome for a test that did not run because it has unsatisfied prerequisites. The test may depend on functionality that has not yet been implemented or perhaps the test itself has yet to be implemented.
Skipped | Gets a standard outcome for a test that did not run.
Public property Status

Gets the test status.

The test status describes whether a test passed, failed or produced an inconclusive result. This information may be reported to the user with icons and textual labels to explain the overall significance of the outcome.

Timeout | Gets a standard outcome for a test that failed because it ran out of time.
Top

See Also

TestOutcome Structure
Gallio.Model Namespace


Canceled Property

TestOutcome.Canceled Property
[image]

Gets a standard outcome for a test that has an inconclusive outcome because it was canceled.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Canceled As TestOutcome
C#
public static TestOutcome Canceled { get; }
C++
public static property TestOutcome Canceled {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Canceled();
JScript
public function get Canceled() : TestOutcome

Property Value

The outcome

Remarks

Status: Inconclusive. Category: "canceled".

See Also

TestOutcome Structure
Gallio.Model Namespace


Category Property

TestOutcome.Category Property
[image]

Gets the test outcome category, or null if none. Never an empty string.

The category, when provided, provides additional information to describe what happened to result in this particular outcome.

Examples: "ignored", "skipped", "pending", "canceled", "aborted", "timeout".

Naming guidelines:

  • A category should be a single lower-case word.
  • It should be a word that can appear on its own or following a number. Consequently, nouns are poor choices because they may need to be pluralized.
  • It should not repeat the information already provided by the Status. Consequently, "passed", "failed" and "inconclusive" are poor choices.
  • It should be a standard category, if possible.
  • It should not be too granular. If too many categories are in common usage, test result summaries by category may become unwieldly.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Category As String
C#
public string Category { get; }
C++
public property string Category sealed {
String get();
}
J#
/** property */
public string get_Category();
JScript
public function get Category() : String

See Also

TestOutcome Structure
Gallio.Model Namespace


DisplayName Property

TestOutcome.DisplayName Property
[image]

Gets the name of the outcome as it should be displayed.

The display name is the outcome's Category, if available. Otherwise it is a lowercase rendition of the outcome's Status.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String
C#
public string DisplayName { get; }
C++
public property string DisplayName sealed {
String get();
}
J#
/** property */
public string get_DisplayName();
JScript
public function get DisplayName() : String

See Also

TestOutcome Structure
Gallio.Model Namespace


Error Property

TestOutcome.Error Property
[image]

Gets a standard outcome for a test that failed due to an error.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Error As TestOutcome
C#
public static TestOutcome Error { get; }
C++
public static property TestOutcome Error {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Error();
JScript
public function get Error() : TestOutcome

Property Value

The outcome

Remarks

Status: Failed. Category: "error".

See Also

TestOutcome Structure
Gallio.Model Namespace


Explicit Property

TestOutcome.Explicit Property
[image]

Gets a standard outcome for a test that did not run because it must be selected explicitly. The test may be particularly expensive or require manual supervision by an operator.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Explicit As TestOutcome
C#
public static TestOutcome Explicit { get; }
C++
public static property TestOutcome Explicit {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Explicit();
JScript
public function get Explicit() : TestOutcome

Property Value

The outcome

Remarks

Status: Skipped. Category: "explicit".

See Also

TestOutcome Structure
Gallio.Model Namespace


Failed Property

TestOutcome.Failed Property
[image]

Gets a standard outcome for a test that failed.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Failed As TestOutcome
C#
public static TestOutcome Failed { get; }
C++
public static property TestOutcome Failed {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Failed();
JScript
public function get Failed() : TestOutcome

Property Value

The outcome

Remarks

Status: Failed. Category: null.

See Also

TestOutcome Structure
Gallio.Model Namespace


Ignored Property

TestOutcome.Ignored Property
[image]

Gets a standard outcome for a test that did not run because the user is choosing to ignore it. Perhaps the test is broken or non-functional.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Ignored As TestOutcome
C#
public static TestOutcome Ignored { get; }
C++
public static property TestOutcome Ignored {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Ignored();
JScript
public function get Ignored() : TestOutcome

Property Value

The outcome

Remarks

Status: Skipped. Category: "ignored".

See Also

TestOutcome Structure
Gallio.Model Namespace


Inconclusive Property

TestOutcome.Inconclusive Property
[image]

Gets a standard outcome for a test that was inconclusive.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Inconclusive As TestOutcome
C#
public static TestOutcome Inconclusive { get; }
C++
public static property TestOutcome Inconclusive {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Inconclusive();
JScript
public function get Inconclusive() : TestOutcome

Property Value

The outcome

Remarks

Status: Inconclusive. Category: null.

See Also

TestOutcome Structure
Gallio.Model Namespace


Passed Property

TestOutcome.Passed Property
[image]

Gets a standard outcome for a test that passed.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Passed As TestOutcome
C#
public static TestOutcome Passed { get; }
C++
public static property TestOutcome Passed {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Passed();
JScript
public function get Passed() : TestOutcome

Property Value

The outcome

Remarks

Status: Passed. Category: null.

See Also

TestOutcome Structure
Gallio.Model Namespace


Pending Property

TestOutcome.Pending Property
[image]

Gets a standard outcome for a test that did not run because it has unsatisfied prerequisites. The test may depend on functionality that has not yet been implemented or perhaps the test itself has yet to be implemented.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Pending As TestOutcome
C#
public static TestOutcome Pending { get; }
C++
public static property TestOutcome Pending {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Pending();
JScript
public function get Pending() : TestOutcome

Property Value

The outcome

Remarks

Status: Skipped. Category: "pending".

See Also

TestOutcome Structure
Gallio.Model Namespace


Skipped Property

TestOutcome.Skipped Property
[image]

Gets a standard outcome for a test that did not run.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Skipped As TestOutcome
C#
public static TestOutcome Skipped { get; }
C++
public static property TestOutcome Skipped {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Skipped();
JScript
public function get Skipped() : TestOutcome

Property Value

The outcome

Remarks

Status: Skipped. Category: null.

See Also

TestOutcome Structure
Gallio.Model Namespace


Status Property

TestOutcome.Status Property
[image]

Gets the test status.

The test status describes whether a test passed, failed or produced an inconclusive result. This information may be reported to the user with icons and textual labels to explain the overall significance of the outcome.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As TestStatus
C#
public TestStatus Status { get; }
C++
public property TestStatus Status sealed {
TestStatus get();
}
J#
/** property */
public TestStatus get_Status();
JScript
public function get Status() : TestStatus

See Also

TestOutcome Structure
Gallio.Model Namespace


Timeout Property

TestOutcome.Timeout Property
[image]

Gets a standard outcome for a test that failed because it ran out of time.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Timeout As TestOutcome
C#
public static TestOutcome Timeout { get; }
C++
public static property TestOutcome Timeout {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Timeout();
JScript
public function get Timeout() : TestOutcome

Property Value

The outcome

Remarks

Status: Failed. Category: "timeout".

See Also

TestOutcome Structure
Gallio.Model Namespace


Methods

TestOutcome Methods
[image]

Public Methods

 | Name | Description
Public method | CombineWith | If the other outcome is more severe than this one, returns it. Otherwise returns this outcome.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | Generalize | Produces an outcome with the same status but omitting the category information.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two outcomes for equality.
 | op_Inequality | Compares two outcomes for inequality.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Overridden. Returns the DisplayName of the outcome.
Top

See Also

TestOutcome Structure
Gallio.Model Namespace


CombineWith Method

TestOutcome.CombineWith Method
[image]

If the other outcome is more severe than this one, returns it. Otherwise returns this outcome.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CombineWith( _
ByVal other As TestOutcome _
) As TestOutcome
C#
public TestOutcome CombineWith(
TestOutcome other
)
C++
public:
TestOutcome CombineWith(
TestOutcome other
) sealed
J#
public TestOutcome CombineWith(
TestOutcome other
)
JScript
public function CombineWith(
other : TestOutcome
) : TestOutcome

Parameters

other
The other outcome

Return Value

The combined outcome

Remarks

This combination rule has the nice property of preserving the first failure encountered even if subsequent failures occur and are combined.

See Also

TestOutcome Structure
Gallio.Model Namespace
TestStatus


Equals Method

TestOutcome.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (TestOutcome) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

TestOutcome Structure
Gallio.Model Namespace


Equals Method (TestOutcome)

TestOutcome.Equals Method (TestOutcome)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As TestOutcome _
) As Boolean _
Implements IEquatable<TestOutcome>.Equals
C#
public bool Equals(
TestOutcome other
)
C++
public:
bool Equals(
TestOutcome other
) sealed
J#
public bool Equals(
TestOutcome other
)
JScript
public function Equals(
other : TestOutcome
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<TestOutcome>.Equals

See Also

TestOutcome Structure
Gallio.Model Namespace
TestOutcome.Equals Overload List


Equals Method (Object)

TestOutcome.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

TestOutcome Structure
Gallio.Model Namespace
TestOutcome.Equals Overload List


Generalize Method

TestOutcome.Generalize Method
[image]

Produces an outcome with the same status but omitting the category information.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Generalize() As TestOutcome
C#
public TestOutcome Generalize()
C++
public:
TestOutcome Generalize() sealed
J#
public TestOutcome Generalize()
JScript
public function Generalize() : TestOutcome

Return Value

The generalized outcome

See Also

TestOutcome Structure
Gallio.Model Namespace


GetHashCode Method

TestOutcome.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

TestOutcome Structure
Gallio.Model Namespace


op_Equality Operator

TestOutcome.op_Equality Operator
[image]

Compares two outcomes for equality.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As TestOutcome, _
ByVal b As TestOutcome _
) As Boolean
C#
public static bool operator ==(
TestOutcome a,
TestOutcome b
)
C++
public:
static bool operator ==(
TestOutcome a,
TestOutcome b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first outcome
b
The second outcome

Return Value

True if the outcomes are equal

See Also

TestOutcome Structure
Gallio.Model Namespace


op_Inequality Operator

TestOutcome.op_Inequality Operator
[image]

Compares two outcomes for inequality.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As TestOutcome, _
ByVal b As TestOutcome _
) As Boolean
C#
public static bool operator !=(
TestOutcome a,
TestOutcome b
)
C++
public:
static bool operator !=(
TestOutcome a,
TestOutcome b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first outcome
b
The second outcome

Return Value

True if the outcomes are not equal

See Also

TestOutcome Structure
Gallio.Model Namespace


ProvideXmlSchema Method

TestOutcome.ProvideXmlSchema Method
[image]

Provides the Xml schema for this element.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ProvideXmlSchema( _
ByVal schemas As XmlSchemaSet _
) As XmlQualifiedName
C#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
C++
public:
static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
J#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
JScript
public static function ProvideXmlSchema(
schemas : XmlSchemaSet
) : XmlQualifiedName

Parameters

schemas
The schema set

Return Value

The schema type of the element

See Also

TestOutcome Structure
Gallio.Model Namespace


ToString Method

TestOutcome.ToString Method
[image]

Returns the DisplayName of the outcome.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The display name

See Also

TestOutcome Structure
Gallio.Model Namespace


TestPackage Class

TestPackage Class
See Also Example Members
[image]

A test package describes the resources that have been loaded in in preparation for enumerating and running the tests they contain. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestPackage
C#
public sealed class TestPackage
C++
ref class TestPackage sealed
J#
public final class TestPackage
JScript
public final class TestPackage

Inheritance Hierarchy

System.Object
Gallio.Model.TestPackage

See Also

TestPackage Members
Gallio.Model Namespace


TestPackage Members

TestPackage Members
See Also Example Constructors Properties Methods
[image]

A test package describes the resources that have been loaded in in preparation for enumerating and running the tests they contain. This class cannot be inherited.

The following tables list the members exposed by TestPackage.

Public Constructors

 | Name | Description
Public method | TestPackage | Creates a test package with the specified configuration.
Top

Public Properties

 | Name | Description
Public property | Assemblies | Gets the assemblies that belong to the test package.
Public property | Config | Gets the test package configuration.
Public property | Loader | Gets the loader for the package.
Public property | ReflectionPolicy | Gets the reflection policy.
Top

Public Methods

 | Name | Description
Public method | AddAssembly | Adds an assembly to the test package.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestPackage Class
Gallio.Model Namespace


TestPackage Constructor

TestPackage Constructor
[image]

Creates a test package with the specified configuration.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal config As TestPackageConfig, _
ByVal reflectionPolicy As IReflectionPolicy, _
ByVal loader As ILoader _
)
C#
public TestPackage(
TestPackageConfig config,
IReflectionPolicy reflectionPolicy,
ILoader loader
)
C++
public:
TestPackage(
TestPackageConfig config,
IReflectionPolicy reflectionPolicy,
ILoader loader
) sealed
J#
public TestPackage(
TestPackageConfig config,
IReflectionPolicy reflectionPolicy,
ILoader loader
)
JScript
public function TestPackage(
config : TestPackageConfig,
reflectionPolicy : IReflectionPolicy,
loader : ILoader
)

Parameters

config
The package configuration
reflectionPolicy
The reflection policy for the package
loader
The loader for the package

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if config, reflectionPolicy or loader is null

See Also

TestPackage Class
Gallio.Model Namespace


Properties

TestPackage Properties
[image]

Public Properties

 | Name | Description
Public property | Assemblies | Gets the assemblies that belong to the test package.
Public property | Config | Gets the test package configuration.
Public property | Loader | Gets the loader for the package.
Public property | ReflectionPolicy | Gets the reflection policy.
Top

See Also

TestPackage Class
Gallio.Model Namespace


Assemblies Property

TestPackage.Assemblies Property
[image]

Gets the assemblies that belong to the test package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assemblies As IList(Of IAssemblyInfo)
C#
public IList<IAssemblyInfo> Assemblies { get; }
C++
public property IList<IAssemblyInfo> Assemblies sealed {
IList<IAssemblyInfo> get();
}
J#
/** property */
public IList<IAssemblyInfo> get_Assemblies();
JScript
public function get Assemblies() : IList<IAssemblyInfo>

See Also

TestPackage Class
Gallio.Model Namespace


Config Property

TestPackage.Config Property
[image]

Gets the test package configuration.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Config As TestPackageConfig
C#
public TestPackageConfig Config { get; }
C++
public property TestPackageConfig Config sealed {
TestPackageConfig get();
}
J#
/** property */
public TestPackageConfig get_Config();
JScript
public function get Config() : TestPackageConfig

See Also

TestPackage Class
Gallio.Model Namespace


Loader Property

TestPackage.Loader Property
[image]

Gets the loader for the package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Loader As ILoader
C#
public ILoader Loader { get; }
C++
public property ILoader Loader sealed {
ILoader get();
}
J#
/** property */
public ILoader get_Loader();
JScript
public function get Loader() : ILoader

See Also

TestPackage Class
Gallio.Model Namespace


ReflectionPolicy Property

TestPackage.ReflectionPolicy Property
[image]

Gets the reflection policy.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReflectionPolicy As IReflectionPolicy
C#
public IReflectionPolicy ReflectionPolicy { get; }
C++
public property IReflectionPolicy ReflectionPolicy sealed {
IReflectionPolicy get();
}
J#
/** property */
public IReflectionPolicy get_ReflectionPolicy();
JScript
public function get ReflectionPolicy() : IReflectionPolicy

See Also

TestPackage Class
Gallio.Model Namespace


Methods

TestPackage Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssembly | Adds an assembly to the test package.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestPackage Class
Gallio.Model Namespace


AddAssembly Method

TestPackage.AddAssembly Method
[image]

Adds an assembly to the test package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssembly( _
ByVal assembly As IAssemblyInfo _
)
C#
public void AddAssembly(
IAssemblyInfo assembly
)
C++
public:
void AddAssembly(
IAssemblyInfo assembly
) sealed
J#
public void AddAssembly(
IAssemblyInfo assembly
)
JScript
public function AddAssembly(
assembly : IAssemblyInfo
)

Parameters

assembly
The assembly to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

TestPackage Class
Gallio.Model Namespace


TestPackageConfig Class

TestPackageConfig Class
See Also Example Members
[image]

A test package configuration specifies the options used by a test runner to load tests into memory for execution. The package may contain multiple test assemblies that are to be loaded together for test execution. It can also be serialized as XML or using .Net remoting for persistence and remote operation. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("testPackageConfig", Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestPackageConfig
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("testPackageConfig", Namespace = "http://www.gallio.org/")]
public sealed class TestPackageConfig
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"testPackageConfig", Namespace = L"http://www.gallio.org/")]
ref class TestPackageConfig sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("testPackageConfig", Namespace = "http://www.gallio.org/") */
public final class TestPackageConfig
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("testPackageConfig", Namespace = "http://www.gallio.org/")
final class TestPackageConfig

Remarks

Someday a test package might allow other kinds of resources to be specified such as individual test scripts, archives, dependent files, environmental additional configuration settings, etc...

Inheritance Hierarchy

System.Object
Gallio.Model.TestPackageConfig

See Also

TestPackageConfig Members
Gallio.Model Namespace


TestPackageConfig Members

TestPackageConfig Members
See Also Example Constructors Properties Methods
[image]

A test package configuration specifies the options used by a test runner to load tests into memory for execution. The package may contain multiple test assemblies that are to be loaded together for test execution. It can also be serialized as XML or using .Net remoting for persistence and remote operation. This class cannot be inherited.

The following tables list the members exposed by TestPackageConfig.

Public Constructors

 | Name | Description
Public method | TestPackageConfig | Creates an empty package.
Top

Public Properties

 | Name | Description
Public property | AssemblyFiles | Gets the list of relative or absolute paths of test assembly files.
Public property | ExcludedFrameworkIds | Gets the list of test framework IDs that are to be excluded from the test exploration process.
Public property | HintDirectories | Gets the list of hint directories used to resolve test assemblies and other files.
Public property | HostSetup | Gets or sets the host setup parameters.
Top

Public Methods

 | Name | Description
Public method | Canonicalize | Makes all paths in this instance absolute.
Public method | Copy | Creates a copy of the test package.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsFrameworkRequested | Returns true if the framework with the specified id should be used to explore the contents of the test package.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestPackageConfig Class
Gallio.Model Namespace


TestPackageConfig Constructor

TestPackageConfig Constructor
[image]

Creates an empty package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestPackageConfig()
C++
public:
TestPackageConfig() sealed
J#
public TestPackageConfig()
JScript
public function TestPackageConfig()

See Also

TestPackageConfig Class
Gallio.Model Namespace


Properties

TestPackageConfig Properties
[image]

Public Properties

 | Name | Description
Public property | AssemblyFiles | Gets the list of relative or absolute paths of test assembly files.
Public property | ExcludedFrameworkIds | Gets the list of test framework IDs that are to be excluded from the test exploration process.
Public property | HintDirectories | Gets the list of hint directories used to resolve test assemblies and other files.
Public property | HostSetup | Gets or sets the host setup parameters.
Top

See Also

TestPackageConfig Class
Gallio.Model Namespace


AssemblyFiles Property

TestPackageConfig.AssemblyFiles Property
[image]

Gets the list of relative or absolute paths of test assembly files.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("assemblyFiles", IsNullable := False), _
XmlArrayItemAttribute("assemblyFile", GetType(String), IsNullable := False)>
Public ReadOnly Property AssemblyFiles As List(Of String)
C#
[XmlArrayAttribute("assemblyFiles", IsNullable = False)]
[XmlArrayItemAttribute("assemblyFile", typeof(String), IsNullable = False)]
public List<string> AssemblyFiles { get; }
C++
[XmlArrayAttribute(L"assemblyFiles", IsNullable = False)]
[XmlArrayItemAttribute(L"assemblyFile", typeof(String), IsNullable = False)]
public property List<string> AssemblyFiles sealed {
List<string> get();
}
J#
/** @attribute XmlArrayAttribute("assemblyFiles", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("assemblyFile", typeof(String), IsNullable = False) */
/** property */
public List<string> get_AssemblyFiles();
JScript
public function get AssemblyFiles() : List<string>

See Also

TestPackageConfig Class
Gallio.Model Namespace


ExcludedFrameworkIds Property

TestPackageConfig.ExcludedFrameworkIds Property
[image]

Gets the list of test framework IDs that are to be excluded from the test exploration process.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("excludedFrameworkIds", IsNullable := False), _
XmlArrayItemAttribute("excludedFrameworkId", GetType(String), IsNullable := False)>
Public ReadOnly Property ExcludedFrameworkIds As List(Of String)
C#
[XmlArrayAttribute("excludedFrameworkIds", IsNullable = False)]
[XmlArrayItemAttribute("excludedFrameworkId", typeof(String), IsNullable = False)]
public List<string> ExcludedFrameworkIds { get; }
C++
[XmlArrayAttribute(L"excludedFrameworkIds", IsNullable = False)]
[XmlArrayItemAttribute(L"excludedFrameworkId", typeof(String), IsNullable = False)]
public property List<string> ExcludedFrameworkIds sealed {
List<string> get();
}
J#
/** @attribute XmlArrayAttribute("excludedFrameworkIds", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("excludedFrameworkId", typeof(String), IsNullable = False) */
/** property */
public List<string> get_ExcludedFrameworkIds();
JScript
public function get ExcludedFrameworkIds() : List<string>

See Also

TestPackageConfig Class
Gallio.Model Namespace


HintDirectories Property

TestPackageConfig.HintDirectories Property
[image]

Gets the list of hint directories used to resolve test assemblies and other files.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("hintDirectory", GetType(String), IsNullable := False), _
XmlArrayAttribute("hintDirectories", IsNullable := False)>
Public ReadOnly Property HintDirectories As List(Of String)
C#
[XmlArrayItemAttribute("hintDirectory", typeof(String), IsNullable = False)]
[XmlArrayAttribute("hintDirectories", IsNullable = False)]
public List<string> HintDirectories { get; }
C++
[XmlArrayItemAttribute(L"hintDirectory", typeof(String), IsNullable = False)]
[XmlArrayAttribute(L"hintDirectories", IsNullable = False)]
public property List<string> HintDirectories sealed {
List<string> get();
}
J#
/** @attribute XmlArrayItemAttribute("hintDirectory", typeof(String), IsNullable = False) */
/** @attribute XmlArrayAttribute("hintDirectories", IsNullable = False) */
/** property */
public List<string> get_HintDirectories();
JScript
public function get HintDirectories() : List<string>

See Also

TestPackageConfig Class
Gallio.Model Namespace


HostSetup Property

TestPackageConfig.HostSetup Property
[image]

Gets or sets the host setup parameters.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("hostSetup", IsNullable := False)>
Public Property HostSetup As HostSetup
C#
[XmlElementAttribute("hostSetup", IsNullable = False)]
public HostSetup HostSetup { get; set; }
C++
[XmlElementAttribute(L"hostSetup", IsNullable = False)]
public property HostSetup HostSetup sealed {
HostSetup get();
void set(HostSetup value);
}
J#
/** @attribute XmlElementAttribute("hostSetup", IsNullable = False) */
/** property */
public HostSetup get_HostSetup();

/** property */
public void set_HostSetup(HostSetup value);
JScript
public function get HostSetup() : HostSetup

public function set HostSetup(value : HostSetup);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

Remarks

The defaults are as follows:

  • Use the test assembly directory as the application base directory and working directory. (signaled by specifying null values in the host setup).
  • No shadow copying.
  • Store test assembly configuration files in the application base directory.
  • Use auto-detected processor architecture (signaled by specifying None in the host setup).

See Also

TestPackageConfig Class
Gallio.Model Namespace


Methods

TestPackageConfig Methods
[image]

Public Methods

 | Name | Description
Public method | Canonicalize | Makes all paths in this instance absolute.
Public method | Copy | Creates a copy of the test package.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsFrameworkRequested | Returns true if the framework with the specified id should be used to explore the contents of the test package.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestPackageConfig Class
Gallio.Model Namespace


Canonicalize Method

TestPackageConfig.Canonicalize Method
[image]

Makes all paths in this instance absolute.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Canonicalize( _
ByVal baseDirectory As String _
)
C#
public void Canonicalize(
string baseDirectory
)
C++
public:
void Canonicalize(
String baseDirectory
) sealed
J#
public void Canonicalize(
string baseDirectory
)
JScript
public function Canonicalize(
baseDirectory : String
)

Parameters

baseDirectory
The base directory for resolving relative paths, or null to use the current directory

See Also

TestPackageConfig Class
Gallio.Model Namespace


Copy Method

TestPackageConfig.Copy Method
[image]

Creates a copy of the test package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As TestPackageConfig
C#
public TestPackageConfig Copy()
C++
public:
TestPackageConfig Copy() sealed
J#
public TestPackageConfig Copy()
JScript
public function Copy() : TestPackageConfig

Return Value

The copy

See Also

TestPackageConfig Class
Gallio.Model Namespace


IsFrameworkRequested Method

TestPackageConfig.IsFrameworkRequested Method
[image]

Returns true if the framework with the specified id should be used to explore the contents of the test package.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsFrameworkRequested( _
ByVal frameworkId As Guid _
) As Boolean
C#
public bool IsFrameworkRequested(
Guid frameworkId
)
C++
public:
bool IsFrameworkRequested(
Guid frameworkId
) sealed
J#
public bool IsFrameworkRequested(
Guid frameworkId
)
JScript
public function IsFrameworkRequested(
frameworkId : Guid
) : bool

Parameters

frameworkId
The framework id

Return Value

True if the framework is requested

See Also

TestPackageConfig Class
Gallio.Model Namespace


TestParameterInfo Class

TestParameterInfo Class
See Also Example Members
[image]

A read-only implementation of ITestParameter for reflection. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestParameterInfo
Inherits TestComponentInfo
Implements ITestParameter
C#
public sealed class TestParameterInfo : TestComponentInfo, ITestParameter
C++
ref class TestParameterInfo sealed : TestComponentInfo, ITestParameter
J#
public final class TestParameterInfo extends TestComponentInfo implements ITestParameter
JScript
public final class TestParameterInfo extends TestComponentInfo, ITestParameter

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfo
Gallio.Model.TestComponentInfo
Gallio.Model.TestParameterInfo

See Also

TestParameterInfo Members
Gallio.Model Namespace


TestParameterInfo Members

TestParameterInfo Members
See Also Example Constructors Properties Methods
[image]

A read-only implementation of ITestParameter for reflection. This class cannot be inherited.

The following tables list the members exposed by TestParameterInfo.

Public Constructors

 | Name | Description
Public method | TestParameterInfo | Creates a read-only wrapper of the specified test parameter.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from TestComponentInfo)
Public property | Id | Gets the stable unique identifier of the component. (inherited from TestComponentInfo)
Public property | Metadata | Gets the metadata of the component. (inherited from TestComponentInfo)
Public property | Name | Gets the name of the component. (inherited from TestComponentInfo)
Public property | Owner |
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from BaseInfo)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from BaseInfo)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseInfo)
Top

See Also

TestParameterInfo Class
Gallio.Model Namespace


TestParameterInfo Constructor

TestParameterInfo Constructor
[image]

Creates a read-only wrapper of the specified test parameter.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITestParameter _
)
C#
public TestParameterInfo(
ITestParameter source
)
C++
public:
TestParameterInfo(
ITestParameter source
) sealed
J#
public TestParameterInfo(
ITestParameter source
)
JScript
public function TestParameterInfo(
source : ITestParameter
)

Parameters

source
The source test parameter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestParameterInfo Class
Gallio.Model Namespace


Properties

TestParameterInfo Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from TestComponentInfo)
Public property | Id | Gets the stable unique identifier of the component. (inherited from TestComponentInfo)
Public property | Metadata | Gets the metadata of the component. (inherited from TestComponentInfo)
Public property | Name | Gets the name of the component. (inherited from TestComponentInfo)
Public property | Owner |
Top

See Also

TestParameterInfo Class
Gallio.Model Namespace


Owner Property

TestParameterInfo.Owner Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As TestInfo
C#
public TestInfo Owner { get; }
C++
public property TestInfo Owner sealed {
TestInfo get();
}
J#
/** property */
public TestInfo get_Owner();
JScript
public function get Owner() : TestInfo

See Also

TestParameterInfo Class
Gallio.Model Namespace


TestParameterInfoList Class

TestParameterInfoList Class
See Also Example Members
[image]

Wraps a list of ITestParameter for reflection. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestParameterInfoList
Inherits BaseInfoList(Of ITestParameter, TestParameterInfo)
C#
public sealed class TestParameterInfoList : BaseInfoList<ITestParameter, TestParameterInfo>
C++
ref class TestParameterInfoList sealed : BaseInfoList<ITestParameter, TestParameterInfo>
J#
public final class TestParameterInfoList extends BaseInfoList<ITestParameter, TestParameterInfo>
JScript
public final class TestParameterInfoList extends BaseInfoList<ITestParameter, TestParameterInfo>

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfoList<TModel,TInfo>
Gallio.Model.TestParameterInfoList

See Also

TestParameterInfoList Members
Gallio.Model Namespace


TestParameterInfoList Members

TestParameterInfoList Members
See Also Example Constructors Properties Methods
[image]

Wraps a list of ITestParameter for reflection. This class cannot be inherited.

The following tables list the members exposed by TestParameterInfoList.

Public Constructors

 | Name | Description
Public method | TestParameterInfoList | Creates a wrapper for the specified input list of test parameters.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollection. (inherited from BaseInfoList)
Public property | IsReadOnly | Gets a value indicating whether the ICollection is read-only. (inherited from BaseInfoList)
Public property | Item | (inherited from BaseInfoList)
Top

Public Methods

 | Name | Description
Public method | AsModelList | Returns a wrapper for the list of elements using the model object's type instead of the reflection object's type. (inherited from BaseInfoList)
Public method | Contains | (inherited from BaseInfoList)
Public method | CopyTo | (inherited from BaseInfoList)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (inherited from BaseInfoList)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | (inherited from BaseInfoList)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestParameterInfoList Class
Gallio.Model Namespace


TestParameterInfoList Constructor

TestParameterInfoList Constructor
[image]

Creates a wrapper for the specified input list of test parameters.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal inputList As IList(Of ITestParameter) _
)
C#
public TestParameterInfoList(
IList<ITestParameter> inputList
)
C++
public:
TestParameterInfoList(
IList<ITestParameter> inputList
) sealed
J#
public TestParameterInfoList(
IList<ITestParameter> inputList
)
JScript
public function TestParameterInfoList(
inputList : IList<ITestParameter>
)

Parameters

inputList
The source test parameter list

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if inputList is null

See Also

TestParameterInfoList Class
Gallio.Model Namespace


TestResult Class

TestResult Class
See Also Example Members
[image]

A test result describes the final result of having executed a test. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestResult
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestResult
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestResult sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestResult
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestResult

Inheritance Hierarchy

System.Object
Gallio.Model.TestResult

See Also

TestResult Members
Gallio.Model Namespace


TestResult Members

TestResult Members
See Also Example Constructors Properties Methods
[image]

A test result describes the final result of having executed a test. This class cannot be inherited.

The following tables list the members exposed by TestResult.

Public Constructors

 | Name | Description
Public method | TestResult | Initializes a new instance of the TestResult class.
Top

Public Properties

 | Name | Description
Public property | AssertCount | Gets or sets the number of assertions evaluated by the test, including its children.
Public property | Duration | Gets or sets the test duration in seconds, including its children.
Public property | Outcome | Gets or sets the test outcome, including its children (unless they were skipped or are otherwise irrelevant to the outcome of their parent).
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestResult Class
Gallio.Model Namespace


TestResult Constructor

TestResult Constructor
[image]

Initializes a new instance of the TestResult class.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestResult()
C++
public:
TestResult() sealed
J#
public TestResult()
JScript
public function TestResult()

See Also

TestResult Class
Gallio.Model Namespace


Properties

TestResult Properties
[image]

Public Properties

 | Name | Description
Public property | AssertCount | Gets or sets the number of assertions evaluated by the test, including its children.
Public property | Duration | Gets or sets the test duration in seconds, including its children.
Public property | Outcome | Gets or sets the test outcome, including its children (unless they were skipped or are otherwise irrelevant to the outcome of their parent).
Top

See Also

TestResult Class
Gallio.Model Namespace


AssertCount Property

TestResult.AssertCount Property
[image]

Gets or sets the number of assertions evaluated by the test, including its children.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assertCount")>
Public Property AssertCount As Integer
C#
[XmlAttributeAttribute("assertCount")]
public int AssertCount { get; set; }
C++
[XmlAttributeAttribute(L"assertCount")]
public property int AssertCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("assertCount") */
/** property */
public int get_AssertCount();

/** property */
public void set_AssertCount(int value);
JScript
public function get AssertCount() : int

public function set AssertCount(value : int);

See Also

TestResult Class
Gallio.Model Namespace


Duration Property

TestResult.Duration Property
[image]

Gets or sets the test duration in seconds, including its children.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("duration")>
Public Property Duration As Double
C#
[XmlAttributeAttribute("duration")]
public double Duration { get; set; }
C++
[XmlAttributeAttribute(L"duration")]
public property double Duration sealed {
double get();
void set(double value);
}
J#
/** @attribute XmlAttributeAttribute("duration") */
/** property */
public double get_Duration();

/** property */
public void set_Duration(double value);
JScript
public function get Duration() : double

public function set Duration(value : double);

See Also

TestResult Class
Gallio.Model Namespace


Outcome Property

TestResult.Outcome Property
[image]

Gets or sets the test outcome, including its children (unless they were skipped or are otherwise irrelevant to the outcome of their parent).

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("outcome")>
Public Property Outcome As TestOutcome
C#
[XmlElementAttribute("outcome")]
public TestOutcome Outcome { get; set; }
C++
[XmlElementAttribute(L"outcome")]
public property TestOutcome Outcome sealed {
TestOutcome get();
void set(TestOutcome value);
}
J#
/** @attribute XmlElementAttribute("outcome") */
/** property */
public TestOutcome get_Outcome();

/** property */
public void set_Outcome(TestOutcome value);
JScript
public function get Outcome() : TestOutcome

public function set Outcome(value : TestOutcome);

Property Value

Defaults to Inconclusive.

See Also

TestResult Class
Gallio.Model Namespace


TestStatus Enumeration

TestStatus Enumeration
[image]

Describes whether a test passed, failed, was skipped or was inconclusive.

The status codes are ranked in order of severity from least to greatest as follows: Passed, Skipped, Inconclusive, Failed.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum TestStatus
C#
public enum TestStatus
C++
public enum class TestStatus
J#
public enum TestStatus
JScript
public enum TestStatus

Members

Member Name | Description
Passed | The test passed.
Skipped | The test did not run so nothing is known about its status.
Inconclusive | The test did not run or its result was inconclusive.
Failed | The test failed or encountered an error during execution.

See Also

Gallio.Model Namespace


TestStepInfo Class

TestStepInfo Class
See Also Example Members
[image]

A read-only implementation of ITestStep for reflection. This class cannot be inherited.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepInfo
Inherits TestComponentInfo
Implements ITestStep
C#
public sealed class TestStepInfo : TestComponentInfo, ITestStep
C++
ref class TestStepInfo sealed : TestComponentInfo, ITestStep
J#
public final class TestStepInfo extends TestComponentInfo implements ITestStep
JScript
public final class TestStepInfo extends TestComponentInfo, ITestStep

Inheritance Hierarchy

System.Object
Gallio.Model.BaseInfo
Gallio.Model.TestComponentInfo
Gallio.Model.TestStepInfo

See Also

TestStepInfo Members
Gallio.Model Namespace


TestStepInfo Members

TestStepInfo Members
See Also Example Constructors Properties Methods
[image]

A read-only implementation of ITestStep for reflection. This class cannot be inherited.

The following tables list the members exposed by TestStepInfo.

Public Constructors

 | Name | Description
Public method | TestStepInfo | Creates a read-only wrapper of the specified test step.
Top

Public Properties

Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from TestComponentInfo)
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest
Public property | Id | Gets the stable unique identifier of the component. (inherited from TestComponentInfo)
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.
Public property | Metadata | Gets the metadata of the component. (inherited from TestComponentInfo)
Public property | Name | Gets the name of the component. (inherited from TestComponentInfo)
Public property | Parent
Public property | Test
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from BaseInfo)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from BaseInfo)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from BaseInfo)
Top

See Also

TestStepInfo Class
Gallio.Model Namespace


TestStepInfo Constructor

TestStepInfo Constructor
[image]

Creates a read-only wrapper of the specified test step.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITestStep _
)
C#
public TestStepInfo(
ITestStep source
)
C++
public:
TestStepInfo(
ITestStep source
) sealed
J#
public TestStepInfo(
ITestStep source
)
JScript
public function TestStepInfo(
source : ITestStep
)

Parameters

source
The source test step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestStepInfo Class
Gallio.Model Namespace


Properties

TestStepInfo Properties
[image]

Public Properties

Name | Description
Public property | CodeElement | Gets a reference to the point of definition of this test component in the code, or null if unknown. (inherited from TestComponentInfo)
Public property FullName

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest
Public property | Id | Gets the stable unique identifier of the component. (inherited from TestComponentInfo)
Public property IsDynamic

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Public property IsPrimary

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Public property | IsTestCase | Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.
Public property | Metadata | Gets the metadata of the component. (inherited from TestComponentInfo)
Public property | Name | Gets the name of the component. (inherited from TestComponentInfo)
Public property | Parent
Public property | Test
Top

See Also

TestStepInfo Class
Gallio.Model Namespace


FullName Property

TestStepInfo.FullName Property
[image]

Gets the full name of the step.

The full name is derived by concatenating the FullName of the Parent followed by a slash ('/') followed by the Name of this test step.

The full name of the root test step is empty.

Examples:

  • "" - The root step
  • "SomeAssembly/SomeFixture/SomeTest" - The step corresponding to SomeTest
  • "SomeAssembly/SomeFixture/SomeTest/ChildStep" - A child step of SomeTest

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String _
Implements ITestStep.FullName
C#
public string FullName { get; }
C++
public property string FullName sealed {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITestStep.FullName

See Also

TestStepInfo Class
Gallio.Model Namespace


IsDynamic Property

TestStepInfo.IsDynamic Property
[image]

Returns true if the test step is dynamic. A dynamic test step is one whose execution is governed by parameters that are not known a priori.

For example, a primary test step is generally not dynamic because its existence usually only depends on statically known information derived from the test model. However, a child test step created at runtime by a data binding process might be considered dynamic if the data items that were used may change between test runs even when the static structure of the test code remains the same. So a test step that uses random data items or that owes its existence to processes that are not entirely under the control of the test framework should be flagged as dynamic.

It can be useful to distinguish between static and dynamic test steps when correlating results across test runs. Dynamic test steps are more likely to change in dramatic ways between test runs than static test steps.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDynamic As Boolean _
Implements ITestStep.IsDynamic
C#
public bool IsDynamic { get; }
C++
public property bool IsDynamic sealed {
bool get();
}
J#
/** property */
public bool get_IsDynamic();
JScript
public function get IsDynamic() : bool

Implements

ITestStep.IsDynamic

See Also

TestStepInfo Class
Gallio.Model Namespace


IsPrimary Property

TestStepInfo.IsPrimary Property
[image]

Returns true if the test step is the top node of a hierarchy of test steps that are all associated with the same test. In the case where a single test step is associated with a test, then it is the primary test step. There may be multiple primary test steps of the same test if they are not directly related by ancestry (ie. one does not contain the other).

A non-primary test step is known as a derived test step.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPrimary As Boolean _
Implements ITestStep.IsPrimary
C#
public bool IsPrimary { get; }
C++
public property bool IsPrimary sealed {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

ITestStep.IsPrimary

See Also

TestStepInfo Class
Gallio.Model Namespace


IsTestCase Property

TestStepInfo.IsTestCase Property
[image]

Returns true if the test step represents a distinct test case. A test case is typically a leaf of the test step hierarchy.

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTestCase As Boolean _
Implements ITestStep.IsTestCase
C#
public bool IsTestCase { get; }
C++
public property bool IsTestCase sealed {
bool get();
}
J#
/** property */
public bool get_IsTestCase();
JScript
public function get IsTestCase() : bool

Implements

ITestStep.IsTestCase

See Also

TestStepInfo Class
Gallio.Model Namespace


Parent Property

TestStepInfo.Parent Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As TestStepInfo
C#
public TestStepInfo Parent { get; }
C++
public property TestStepInfo Parent sealed {
TestStepInfo get();
}
J#
/** property */
public TestStepInfo get_Parent();
JScript
public function get Parent() : TestStepInfo

See Also

TestStepInfo Class
Gallio.Model Namespace


Test Property

TestStepInfo.Test Property
[image]

Namespace: Gallio.Model
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As TestInfo
C#
public TestInfo Test { get; }
C++
public property TestInfo Test sealed {
TestInfo get();
}
J#
/** property */
public TestInfo get_Test();
JScript
public function get Test() : TestInfo

See Also

TestStepInfo Class
Gallio.Model Namespace


Gallio.Model.Diagnostics

Gallio.Model.Diagnostics Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | ExceptionData | Describes an exception in a serializable form. This class cannot be inherited.
Public class | StackTraceData | Describes a stack trace in a serializable form. This class cannot be inherited.
Public class StackTraceFilter

Provides methods for filtering the stack trace for tests.

The objective of this filtering is to omit frames that are not relevant to the user when reporting test failures.

Stack trace filtering proceeds as follows:

  • Stack frames that have an associated DebuggerHiddenAttribute or TestFrameworkInternalAttribute are omitted.
  • The stack trace is chopped just above the top-most stack frame with an associated TestEntryPointAttribute.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class TestEntryPointAttribute

This attribute is used to mark methods that call into test code.

The StackTraceFilter uses this attribute to determine at what point control flow initially transitioned from the test framework into the test. It can then filter out irrelevant frames that lie above the entry point.

If two entry points are nested within one another in the call stack, then the effect is the same as if the outermost entry point did not appear. This enables test frameworks to support recursion into themselves.

This class cannot be inherited.
Public class TestFrameworkInternalAttribute

This attribute is used to mark methods and types that are internal to the implementation of the test framework.

The StackTraceFilter uses this attribute to identify stack frames that may safely be filtered out when describing failures to users. If the stack frame refers to a method with this attribute or declared by a type with this attribute then it is omitted. The attribute also applies to nested types to help cover anonymous delegates as well.

This class cannot be inherited.


ExceptionData Class

ExceptionData Class
See Also Example Members
[image]

Describes an exception in a serializable form. This class cannot be inherited.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class ExceptionData
Implements ITestLogStreamWritable
C#
[SerializableAttribute]
public sealed class ExceptionData : ITestLogStreamWritable
C++
[SerializableAttribute]
ref class ExceptionData sealed : ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
public final class ExceptionData implements ITestLogStreamWritable
JScript
public
SerializableAttribute
final class ExceptionData extends ITestLogStreamWritable

Inheritance Hierarchy

System.Object
Gallio.Model.Diagnostics.ExceptionData

See Also

ExceptionData Members
Gallio.Model.Diagnostics Namespace


ExceptionData Members

ExceptionData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes an exception in a serializable form. This class cannot be inherited.

The following tables list the members exposed by ExceptionData.

Public Constructors

Name | Description
ExceptionData | Overloaded.
Top

Public Properties

 | Name | Description
Public property | InnerException | Gets the inner exception data, or null if none.
Public property | Message | Gets the exception message text.
Public property | StackTrace | Gets the exception stack trace.
Public property | Type | Gets the exception type full name.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the exception to a string similar to the one that the .Net framework would ordinarily construct.
Public method | WriteTo | Writes the exception in a structured format with markers to distinguish its component elements.
Top

Explicit Interface Implementations

Name | Description
ExceptionData | Overloaded.
Top

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


ExceptionData Constructor

ExceptionData Constructor

Overload List

 | Name | Description
Public method | ExceptionData (Exception) | Creates an exception data object from an exception.
Public method | ExceptionData (String, String, StackTraceData, ExceptionData) | Creates an exception data object.
Public method | ExceptionData (String, String, String, ExceptionData) | Creates an exception data object.

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


ExceptionData Constructor (Exception)

ExceptionData Constructor (Exception)
See Also Example
[image]

Creates an exception data object from an exception.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal exception As Exception _
)
C#
public ExceptionData(
Exception exception
)
C++
public:
ExceptionData(
Exception exception
) sealed
J#
public ExceptionData(
Exception exception
)
JScript
public function ExceptionData(
exception : Exception
)

Parameters

exception
The exception

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace
ExceptionData Constructor Overload List


ExceptionData Constructor (String, String, StackTraceData, ExceptionData)

ExceptionData Constructor (String, String, StackTraceData, ExceptionData)
See Also Example
[image]

Creates an exception data object.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As String, _
ByVal message As String, _
ByVal stackTrace As StackTraceData, _
ByVal innerException As ExceptionData _
)
C#
public ExceptionData(
string type,
string message,
StackTraceData stackTrace,
ExceptionData innerException
)
C++
public:
ExceptionData(
String type,
String message,
StackTraceData stackTrace,
ExceptionData innerException
) sealed
J#
public ExceptionData(
string type,
string message,
StackTraceData stackTrace,
ExceptionData innerException
)
JScript
public function ExceptionData(
type : String,
message : String,
stackTrace : StackTraceData,
innerException : ExceptionData
)

Parameters

type
The exception type full name
message
The exception message text
stackTrace
The exception stack trace
innerException
The inner exception data, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type, message or stackTrace is null

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace
ExceptionData Constructor Overload List


ExceptionData Constructor (String, String, String, ExceptionData)

ExceptionData Constructor (String, String, String, ExceptionData)
See Also Example
[image]

Creates an exception data object.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As String, _
ByVal message As String, _
ByVal stackTrace As String, _
ByVal innerException As ExceptionData _
)
C#
public ExceptionData(
string type,
string message,
string stackTrace,
ExceptionData innerException
)
C++
public:
ExceptionData(
String type,
String message,
String stackTrace,
ExceptionData innerException
) sealed
J#
public ExceptionData(
string type,
string message,
string stackTrace,
ExceptionData innerException
)
JScript
public function ExceptionData(
type : String,
message : String,
stackTrace : String,
innerException : ExceptionData
)

Parameters

type
The exception type full name
message
The exception message text
stackTrace
The exception stack trace
innerException
The inner exception data, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type, message or stackTrace is null

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace
ExceptionData Constructor Overload List


Properties

ExceptionData Properties
[image]

Public Properties

 | Name | Description
Public property | InnerException | Gets the inner exception data, or null if none.
Public property | Message | Gets the exception message text.
Public property | StackTrace | Gets the exception stack trace.
Public property | Type | Gets the exception type full name.
Top

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


InnerException Property

ExceptionData.InnerException Property
[image]

Gets the inner exception data, or null if none.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As ExceptionData
C#
public ExceptionData InnerException { get; }
C++
public property ExceptionData InnerException sealed {
ExceptionData get();
}
J#
/** property */
public ExceptionData get_InnerException();
JScript
public function get InnerException() : ExceptionData

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


Message Property

ExceptionData.Message Property
[image]

Gets the exception message text.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
C++
public property string Message sealed {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


StackTrace Property

ExceptionData.StackTrace Property
[image]

Gets the exception stack trace.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StackTrace As StackTraceData
C#
public StackTraceData StackTrace { get; }
C++
public property StackTraceData StackTrace sealed {
StackTraceData get();
}
J#
/** property */
public StackTraceData get_StackTrace();
JScript
public function get StackTrace() : StackTraceData

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


Type Property

ExceptionData.Type Property
[image]

Gets the exception type full name.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
C#
public string Type { get; }
C++
public property string Type sealed {
String get();
}
J#
/** property */
public string get_Type();
JScript
public function get Type() : String

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


Methods

ExceptionData Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the exception to a string similar to the one that the .Net framework would ordinarily construct.
Public method | WriteTo | Writes the exception in a structured format with markers to distinguish its component elements.
Top

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


ToString Method

ExceptionData.ToString Method
[image]

Formats the exception to a string similar to the one that the .Net framework would ordinarily construct.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted exception

Remarks

The exception will not be terminated by a new line.

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


WriteTo Method

ExceptionData.WriteTo Method
[image]

Writes the exception in a structured format with markers to distinguish its component elements.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The log stream writer

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

Remarks

The exception will not be terminated by a new line.

See Also

ExceptionData Class
Gallio.Model.Diagnostics Namespace


StackTraceData Class

StackTraceData Class
See Also Example Members
[image]

Describes a stack trace in a serializable form. This class cannot be inherited.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class StackTraceData
Implements ITestLogStreamWritable
C#
[SerializableAttribute]
public sealed class StackTraceData : ITestLogStreamWritable
C++
[SerializableAttribute]
ref class StackTraceData sealed : ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
public final class StackTraceData implements ITestLogStreamWritable
JScript
public
SerializableAttribute
final class StackTraceData extends ITestLogStreamWritable

Inheritance Hierarchy

System.Object
Gallio.Model.Diagnostics.StackTraceData

See Also

StackTraceData Members
Gallio.Model.Diagnostics Namespace


StackTraceData Members

StackTraceData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes a stack trace in a serializable form. This class cannot be inherited.

The following tables list the members exposed by StackTraceData.

Public Constructors

Name | Description
StackTraceData | Overloaded.
Top

Public Properties

 | Name | Description
Public property | IsEmpty | Returns true if the stack trace data is empty.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the stack trace to a string similar to the one that the .Net framework would ordinarily construct.
Public method | WriteTo | Writes the stack trace in a structured format with markers to distinguish its component elements.
Top

Explicit Interface Implementations

Name | Description
StackTraceData | Overloaded.
Top

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


StackTraceData Constructor

StackTraceData Constructor

Overload List

 | Name | Description
Public method | StackTraceData (ICodeElementInfo) | Creates a stack trace data object that points to the specified code element.
Public method | StackTraceData (String) | Creates a stack trace data object from a string.

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


StackTraceData Constructor (ICodeElementInfo)

StackTraceData Constructor (ICodeElementInfo)
See Also Example
[image]

Creates a stack trace data object that points to the specified code element.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal codeElement As ICodeElementInfo _
)
C#
public StackTraceData(
ICodeElementInfo codeElement
)
C++
public:
StackTraceData(
ICodeElementInfo codeElement
) sealed
J#
public StackTraceData(
ICodeElementInfo codeElement
)
JScript
public function StackTraceData(
codeElement : ICodeElementInfo
)

Parameters

codeElement
The code element

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace
StackTraceData Constructor Overload List


StackTraceData Constructor (String)

StackTraceData Constructor (String)
See Also Example
[image]

Creates a stack trace data object from a string.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal stackTrace As String _
)
C#
public StackTraceData(
string stackTrace
)
C++
public:
StackTraceData(
String stackTrace
) sealed
J#
public StackTraceData(
string stackTrace
)
JScript
public function StackTraceData(
stackTrace : String
)

Parameters

stackTrace
The stack trace

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if stackTrace is null

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace
StackTraceData Constructor Overload List


Properties

StackTraceData Properties
[image]

Public Properties

 | Name | Description
Public property | IsEmpty | Returns true if the stack trace data is empty.
Top

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


IsEmpty Property

StackTraceData.IsEmpty Property
[image]

Returns true if the stack trace data is empty.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty { get; }
C++
public property bool IsEmpty sealed {
bool get();
}
J#
/** property */
public bool get_IsEmpty();
JScript
public function get IsEmpty() : bool

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


Methods

StackTraceData Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the stack trace to a string similar to the one that the .Net framework would ordinarily construct.
Public method | WriteTo | Writes the stack trace in a structured format with markers to distinguish its component elements.
Top

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


ToString Method

StackTraceData.ToString Method
[image]

Formats the stack trace to a string similar to the one that the .Net framework would ordinarily construct.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted stack trace

Remarks

The exception will not be terminated by a new line.

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


WriteTo Method

StackTraceData.WriteTo Method
[image]

Writes the stack trace in a structured format with markers to distinguish its component elements.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The log stream writer

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

Remarks

The stack trace will not be terminated by a new line.

See Also

StackTraceData Class
Gallio.Model.Diagnostics Namespace


StackTraceFilter Class

StackTraceFilter Class
See Also Example Members
[image]

Provides methods for filtering the stack trace for tests.

The objective of this filtering is to omit frames that are not relevant to the user when reporting test failures.

Stack trace filtering proceeds as follows:

  • Stack frames that have an associated DebuggerHiddenAttribute or TestFrameworkInternalAttribute are omitted.
  • The stack trace is chopped just above the top-most stack frame with an associated TestEntryPointAttribute.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module StackTraceFilter
C#
public static class StackTraceFilter
C++
ref class StackTraceFilter abstract sealed
J#
public final class StackTraceFilter
JScript
public class StackTraceFilter

Inheritance Hierarchy

System.Object
Gallio.Model.Diagnostics.StackTraceFilter

See Also

StackTraceFilter Members
Gallio.Model.Diagnostics Namespace


StackTraceFilter Members

StackTraceFilter Members
See Also Example Methods
[image]

Provides methods for filtering the stack trace for tests.

The objective of this filtering is to omit frames that are not relevant to the user when reporting test failures.

Stack trace filtering proceeds as follows:

  • Stack frames that have an associated DebuggerHiddenAttribute or TestFrameworkInternalAttribute are omitted.
  • The stack trace is chopped just above the top-most stack frame with an associated TestEntryPointAttribute.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by StackTraceFilter.

Public Methods

Name | Description
CaptureFilteredStackTrace | Captures a filtered stack trace from the currently executing thread.
FilterException | Overloaded. Filters the stack trace information about an exception.
FilterStackTrace | Filters a stack trace.
FilterStackTraceToString | Filters a stack trace.
Top

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace


Methods

StackTraceFilter Methods
[image]

Public Methods

Name | Description
CaptureFilteredStackTrace | Captures a filtered stack trace from the currently executing thread.
FilterException | Overloaded. Filters the stack trace information about an exception.
FilterStackTrace | Filters a stack trace.
FilterStackTraceToString | Filters a stack trace.
Top

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace


CaptureFilteredStackTrace Method

StackTraceFilter.CaptureFilteredStackTrace Method
[image]

Captures a filtered stack trace from the currently executing thread.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerHiddenAttribute>
Public Shared Function CaptureFilteredStackTrace() As String
C#
[DebuggerHiddenAttribute]
public static string CaptureFilteredStackTrace()
C++
[DebuggerHiddenAttribute]
public:
static String CaptureFilteredStackTrace()
J#
/** @attribute DebuggerHiddenAttribute() */
public static string CaptureFilteredStackTrace()
JScript
public static

DebuggerHiddenAttribute
function CaptureFilteredStackTrace() : String

Return Value

The filtered stack trace

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace


FilterException Method

StackTraceFilter.FilterException Method

Filters the stack trace information about an exception.

Overload List

Name | Description
FilterException (ExceptionData) | Filters the stack trace information about an exception.
FilterException (Exception) | Filters the stack trace information in an exception.

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace


FilterException Method (ExceptionData)

StackTraceFilter.FilterException Method (ExceptionData)
See Also Example
[image]

Filters the stack trace information about an exception.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FilterException( _
ByVal exception As ExceptionData _
) As ExceptionData
C#
public static ExceptionData FilterException(
ExceptionData exception
)
C++
public:
static ExceptionData FilterException(
ExceptionData exception
)
J#
public static ExceptionData FilterException(
ExceptionData exception
)
JScript
public static function FilterException(
exception : ExceptionData
) : ExceptionData

Parameters

exception
The exception data

Return Value

The filtered exception data

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace
StackTraceFilter.FilterException Overload List


FilterException Method (Exception)

StackTraceFilter.FilterException Method (Exception)
See Also Example
[image]

Filters the stack trace information in an exception.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FilterException( _
ByVal exception As Exception _
) As ExceptionData
C#
public static ExceptionData FilterException(
Exception exception
)
C++
public:
static ExceptionData FilterException(
Exception exception
)
J#
public static ExceptionData FilterException(
Exception exception
)
JScript
public static function FilterException(
exception : Exception
) : ExceptionData

Parameters

exception
The exception

Return Value

The filtered exception data

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace
StackTraceFilter.FilterException Overload List


FilterStackTrace Method

StackTraceFilter.FilterStackTrace Method
[image]

Filters a stack trace.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FilterStackTrace( _
ByVal stackTrace As String _
) As String
C#
public static string FilterStackTrace(
string stackTrace
)
C++
public:
static String FilterStackTrace(
String stackTrace
)
J#
public static string FilterStackTrace(
string stackTrace
)
JScript
public static function FilterStackTrace(
stackTrace : String
) : String

Parameters

stackTrace
The stack trace

Return Value

The filtered stack trace

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if stackTrace is null

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace


FilterStackTraceToString Method

StackTraceFilter.FilterStackTraceToString Method
[image]

Filters a stack trace.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FilterStackTraceToString( _
ByVal stackTrace As StackTrace _
) As String
C#
public static string FilterStackTraceToString(
StackTrace stackTrace
)
C++
public:
static String FilterStackTraceToString(
StackTrace stackTrace
)
J#
public static string FilterStackTraceToString(
StackTrace stackTrace
)
JScript
public static function FilterStackTraceToString(
stackTrace : StackTrace
) : String

Parameters

stackTrace
The stack trace

Return Value

The filtered stack trace string

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if stackTrace is null

See Also

StackTraceFilter Class
Gallio.Model.Diagnostics Namespace


TestEntryPointAttribute Class

TestEntryPointAttribute Class
See Also Example Members
[image]

This attribute is used to mark methods that call into test code.

The StackTraceFilter uses this attribute to determine at what point control flow initially transitioned from the test framework into the test. It can then filter out irrelevant frames that lie above the entry point.

If two entry points are nested within one another in the call stack, then the effect is the same as if the outermost entry point did not appear. This enables test frameworks to support recursion into themselves.

This class cannot be inherited.
Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Constructor Or AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public NotInheritable Class TestEntryPointAttribute
Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Constructor | AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public sealed class TestEntryPointAttribute : Attribute
C++
[AttributeUsageAttribute(AttributeTargets::Constructor | AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TestEntryPointAttribute sealed : Attribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Constructor | AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public final class TestEntryPointAttribute extends Attribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Constructor | AttributeTargets.Method, AllowMultiple = False, Inherited = True)
final class TestEntryPointAttribute extends Attribute

Remarks

Other attributes may also contribute to stack trace filtering. Refer to StackTraceFilter for details.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Model.Diagnostics.TestEntryPointAttribute

See Also

TestEntryPointAttribute Members
Gallio.Model.Diagnostics Namespace


TestEntryPointAttribute Members

TestEntryPointAttribute Members
See Also Example Constructors Properties Methods
[image]

This attribute is used to mark methods that call into test code.

The StackTraceFilter uses this attribute to determine at what point control flow initially transitioned from the test framework into the test. It can then filter out irrelevant frames that lie above the entry point.

If two entry points are nested within one another in the call stack, then the effect is the same as if the outermost entry point did not appear. This enables test frameworks to support recursion into themselves.

This class cannot be inherited.

The following tables list the members exposed by TestEntryPointAttribute.

Public Constructors

 | Name | Description
Public method | TestEntryPointAttribute | Initializes a new instance of the TestEntryPointAttribute class.
Top

Public Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestEntryPointAttribute Class
Gallio.Model.Diagnostics Namespace


TestEntryPointAttribute Constructor

TestEntryPointAttribute Constructor
[image]

Initializes a new instance of the TestEntryPointAttribute class.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestEntryPointAttribute()
C++
public:
TestEntryPointAttribute() sealed
J#
public TestEntryPointAttribute()
JScript
public function TestEntryPointAttribute()

See Also

TestEntryPointAttribute Class
Gallio.Model.Diagnostics Namespace


TestFrameworkInternalAttribute Class

TestFrameworkInternalAttribute Class
See Also Example Members
[image]

This attribute is used to mark methods and types that are internal to the implementation of the test framework.

The StackTraceFilter uses this attribute to identify stack frames that may safely be filtered out when describing failures to users. If the stack frame refers to a method with this attribute or declared by a type with this attribute then it is omitted. The attribute also applies to nested types to help cover anonymous delegates as well.

This class cannot be inherited.
Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public NotInheritable Class TestFrameworkInternalAttribute
Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public sealed class TestFrameworkInternalAttribute : Attribute
C++
[AttributeUsageAttribute(AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TestFrameworkInternalAttribute sealed : Attribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public final class TestFrameworkInternalAttribute extends Attribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method, AllowMultiple = False, Inherited = True)
final class TestFrameworkInternalAttribute extends Attribute

Remarks

Other attributes may also contribute to stack trace filtering. Refer to StackTraceFilter for details.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Model.Diagnostics.TestFrameworkInternalAttribute

See Also

TestFrameworkInternalAttribute Members
Gallio.Model.Diagnostics Namespace


TestFrameworkInternalAttribute Members

TestFrameworkInternalAttribute Members
See Also Example Constructors Properties Methods
[image]

This attribute is used to mark methods and types that are internal to the implementation of the test framework.

The StackTraceFilter uses this attribute to identify stack frames that may safely be filtered out when describing failures to users. If the stack frame refers to a method with this attribute or declared by a type with this attribute then it is omitted. The attribute also applies to nested types to help cover anonymous delegates as well.

This class cannot be inherited.

The following tables list the members exposed by TestFrameworkInternalAttribute.

Public Constructors

 | Name | Description
Public method | TestFrameworkInternalAttribute | Initializes a new instance of the TestFrameworkInternalAttribute class.
Top

Public Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestFrameworkInternalAttribute Class
Gallio.Model.Diagnostics Namespace


TestFrameworkInternalAttribute Constructor

TestFrameworkInternalAttribute Constructor
[image]

Initializes a new instance of the TestFrameworkInternalAttribute class.

Namespace: Gallio.Model.Diagnostics
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestFrameworkInternalAttribute()
C++
public:
TestFrameworkInternalAttribute() sealed
J#
public TestFrameworkInternalAttribute()
JScript
public function TestFrameworkInternalAttribute()

See Also

TestFrameworkInternalAttribute Class
Gallio.Model.Diagnostics Namespace


Gallio.Model.Execution

Gallio.Model.Execution Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | BaseTestController | Base implementation of ITestController that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | DefaultTestContextTracker | The default context tracker tracks the current context by way of the thread's ExecutionContext and CallContext. The .Net framework ensures that this context information flows across threads during asynchronous callbacks, timer events and thread pool work item execution.
Public class DefaultTestOrderStrategy

Defines the test ordering strategy.

This default strategy first compares test by explicit ordering (using Order) then defines an implicit ordering by name (using Name).

This class cannot be inherited.
Public class | ManagedTestCommand | A ITestCommand implementation based on a ITestContextManager.
Public class | ObservableTestContextManager | An observable test context manager creates and tracks test contexts that are associated with a ITestExecutionListener for reporting test events back to the test runner.
Public class | ObservableTestLogWriter | A log writer that sends messages to a ITestExecutionListener.
Public class | RecursiveTestController | A test controller that recursively enters the context of each non master-test found. When a master test is found, instantiates the ITestController for it and hands control over to it for the subtree of tests rooted at the master test.
Public class | StubTestContext | A stub implementation of ITestContext using a TextualTestLogWriter. Does not fully support nested test steps or other dynamic features.
Public class StubTestContextTracker

The stub context tracker is a dummy implementation of ITestContextTracker that is used in situations where the runtime environment has not been initialized.

A typical use of this stub is to support the use of certain framework methods from clients that are not being executed inside of the Gallio test harness such as when test code is run by third party tools.

This class cannot be inherited.
Public class | TestCommandFactory | Creates test commands. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | TestContextTrackerAccessor | Static service locator for ITestContextTracker. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | TestExecutionOptions | Provides options that control how test execution occurs. This class cannot be inherited.

Interfaces

Interface | Description
Public interface | ITestCommand | A test command requests the execution of a tree of ITests. The test command hierarchy mirrors a filtered subset of the test hierarchy.
Public interface ITestContext

The context provides information about the environment in which a test is executing. A new context is created each time a test or test step begins execution.

Contexts are arranged in a hierarchy that corresponds to the order in which the contexts were entered. Thus the context for a test likely has as its parent the context for its containing test fixture.

Arbitrary user data can be associated with a context. Furthermore, client code may attach Finishing event handlers to perform resource reclamation or other updates when the test step is finished.

When the context is disposed, its associated test step is automatically marked as being finished unless FinishStep was previously called. When this occurs the test step is finished with an outcome of Error.

Public interface | ITestContextManager | A test context manager functions as a factory for ITestContext objects and tracks them with an ITestContextTracker.
Public interface | ITestContextTracker | The context tracker tracks the ITestContext associated with threads.
Public interface | ITestController | A test controller runs a batch of tests.


BaseTestController Class

BaseTestController Class
See Also Example Members
[image]

Base implementation of ITestController that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTestController
Implements ITestController, IDisposable
C#
public abstract class BaseTestController : ITestController, IDisposable
C++
ref class BaseTestController abstract : ITestController, IDisposable
J#
public class BaseTestController implements ITestController, IDisposable
JScript
public class BaseTestController extends ITestController, IDisposable

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.BaseTestController
Gallio.Framework.Pattern.PatternTestController
Gallio.Model.Execution.RecursiveTestController

See Also

BaseTestController Members
Gallio.Model.Execution Namespace


BaseTestController Members

BaseTestController Members
See Also Example Constructors Methods
[image]

Base implementation of ITestController that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTestController.

Protected Constructors

 | Name | Description
Family method | BaseTestController | Initializes a new instance of the BaseTestController class.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RunTests | Runs the tests.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunTestsImpl | Implementation of RunTests called after argument validation has taken place.
 | SkipAll | Recursively generates single test steps for each ITestCommand and sets the final outcome to Skipped.
Top

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


BaseTestController Constructor

BaseTestController Constructor
[image]

Initializes a new instance of the BaseTestController class.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseTestController()
C++
protected:
BaseTestController() sealed
J#
protected BaseTestController()
JScript
protected function BaseTestController()

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


Methods

BaseTestController Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RunTests | Runs the tests.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunTestsImpl | Implementation of RunTests called after argument validation has taken place.
 | SkipAll | Recursively generates single test steps for each ITestCommand and sets the final outcome to Skipped.
Top

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


Dispose Method

BaseTestController.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose() _
Implements IDisposable.Dispose
C#
public virtual void Dispose()
C++
public:
virtual void Dispose()
J#
public virtual void Dispose()
JScript
public virtual function Dispose()

Implements

IDisposable.Dispose

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


RunTests Method

BaseTestController.RunTests Method
[image]

Runs the tests.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function RunTests( _
ByVal rootTestCommand As ITestCommand, _
ByVal parentTestStep As ITestStep, _
ByVal options As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As TestOutcome _
Implements ITestController.RunTests
C#
public TestOutcome RunTests(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
C++
public:
TestOutcome RunTests(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
) sealed
J#
public TestOutcome RunTests(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
JScript
public function RunTests(
rootTestCommand : ITestCommand,
parentTestStep : ITestStep,
options : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : TestOutcome

Parameters

rootTestCommand
The root test monitor
parentTestStep
The parent test step, or null if starting a root step
options
The test execution options
progressMonitor
The progress monitor

Return Value

The combined outcome of the root test command

Implements

ITestController.RunTests

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


RunTestsImpl Method

BaseTestController.RunTestsImpl Method
[image]

Implementation of RunTests called after argument validation has taken place.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function RunTestsImpl( _
ByVal rootTestCommand As ITestCommand, _
ByVal parentTestStep As ITestStep, _
ByVal options As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As TestOutcome
C#
protected abstract TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
C++
protected:
TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
) abstract
J#
protected abstract TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
JScript
protected abstract function RunTestsImpl(
rootTestCommand : ITestCommand,
parentTestStep : ITestStep,
options : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : TestOutcome

Parameters

rootTestCommand
The root test command, not null
parentTestStep
The parent test step, or null if none
options
The test execution options, not null
progressMonitor
The progress monitor, not null

Return Value

The combined outcome of the root test command

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


SkipAll Method

BaseTestController.SkipAll Method
[image]

Recursively generates single test steps for each ITestCommand and sets the final outcome to Skipped.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub SkipAll( _
ByVal rootTestCommand As ITestCommand, _
ByVal parentTestStep As ITestStep _
)
C#
protected static void SkipAll(
ITestCommand rootTestCommand,
ITestStep parentTestStep
)
C++
protected:
static void SkipAll(
ITestCommand rootTestCommand,
ITestStep parentTestStep
)
J#
protected static void SkipAll(
ITestCommand rootTestCommand,
ITestStep parentTestStep
)
JScript
protected static function SkipAll(
rootTestCommand : ITestCommand,
parentTestStep : ITestStep
)

Parameters

rootTestCommand
The root test command
parentTestStep
The parent test step

Remarks

This is useful for implementing fallback behavior when SkipTestExecution is true.

See Also

BaseTestController Class
Gallio.Model.Execution Namespace


DefaultTestContextTracker Class

DefaultTestContextTracker Class
See Also Example Members
[image]

The default context tracker tracks the current context by way of the thread's ExecutionContext and CallContext. The .Net framework ensures that this context information flows across threads during asynchronous callbacks, timer events and thread pool work item execution.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestContextTracker
Implements ITestContextTracker
C#
public class DefaultTestContextTracker : ITestContextTracker
C++
ref class DefaultTestContextTracker : ITestContextTracker
J#
public class DefaultTestContextTracker implements ITestContextTracker
JScript
public class DefaultTestContextTracker extends ITestContextTracker

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.DefaultTestContextTracker
Gallio.Model.Execution.StubTestContextTracker

See Also

DefaultTestContextTracker Members
Gallio.Model.Execution Namespace


DefaultTestContextTracker Members

DefaultTestContextTracker Members
See Also Example Constructors Properties Methods
[image]

The default context tracker tracks the current context by way of the thread's ExecutionContext and CallContext. The .Net framework ensures that this context information flows across threads during asynchronous callbacks, timer events and thread pool work item execution.

The following tables list the members exposed by DefaultTestContextTracker.

Public Constructors

 | Name | Description
Public method | DefaultTestContextTracker | Initializes the context tracker.
Top

Public Properties

Name | Description
Public property CurrentContext

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

Public property | GlobalContext | Gets or the global context of the environment, or null if there is no such context.
Top

Public Methods

 | Name | Description
Public method | EnterContext | Enters a context.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetThreadDefaultContext | Gets the default context for the specified thread.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetThreadDefaultContext | Sets the default context for the specified thread.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


DefaultTestContextTracker Constructor

DefaultTestContextTracker Constructor
[image]

Initializes the context tracker.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DefaultTestContextTracker()
C++
public:
DefaultTestContextTracker() sealed
J#
public DefaultTestContextTracker()
JScript
public function DefaultTestContextTracker()

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


Properties

DefaultTestContextTracker Properties
[image]

Public Properties

Name | Description
Public property CurrentContext

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

Public property | GlobalContext | Gets or the global context of the environment, or null if there is no such context.
Top

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


CurrentContext Property

DefaultTestContextTracker.CurrentContext Property
[image]

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentContext As ITestContext _
Implements ITestContextTracker.CurrentContext
C#
public ITestContext CurrentContext { get; }
C++
public property ITestContext CurrentContext sealed {
ITestContext get();
}
J#
/** property */
public ITestContext get_CurrentContext();
JScript
public function get CurrentContext() : ITestContext

Implements

ITestContextTracker.CurrentContext

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


GlobalContext Property

DefaultTestContextTracker.GlobalContext Property
[image]

Gets or the global context of the environment, or null if there is no such context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property GlobalContext As ITestContext _
Implements ITestContextTracker.GlobalContext
C#
public ITestContext GlobalContext { get; set; }
C++
public property ITestContext GlobalContext sealed {
ITestContext get();
void set(ITestContext value);
}
J#
/** property */
public ITestContext get_GlobalContext();

/** property */
public void set_GlobalContext(ITestContext value);
JScript
public function get GlobalContext() : ITestContext

public function set GlobalContext(value : ITestContext);

Implements

ITestContextTracker.GlobalContext

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


Methods

DefaultTestContextTracker Methods
[image]

Public Methods

 | Name | Description
Public method | EnterContext | Enters a context.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetThreadDefaultContext | Gets the default context for the specified thread.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetThreadDefaultContext | Sets the default context for the specified thread.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


EnterContext Method

DefaultTestContextTracker.EnterContext Method
[image]

Enters a context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EnterContext( _
ByVal context As ITestContext _
) As IDisposable _
Implements ITestContextTracker.EnterContext
C#
public IDisposable EnterContext(
ITestContext context
)
C++
public:
IDisposable EnterContext(
ITestContext context
) sealed
J#
public IDisposable EnterContext(
ITestContext context
)
JScript
public function EnterContext(
context : ITestContext
) : IDisposable

Parameters

context
The context to enter, or null to enter a scope without a context

Return Value

A cookie that can be used to restore the current thread's context to its previous value when disposed

Implements

ITestContextTracker.EnterContext

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


GetThreadDefaultContext Method

DefaultTestContextTracker.GetThreadDefaultContext Method
[image]

Gets the default context for the specified thread.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetThreadDefaultContext( _
ByVal thread As Thread _
) As ITestContext _
Implements ITestContextTracker.GetThreadDefaultContext
C#
public ITestContext GetThreadDefaultContext(
Thread thread
)
C++
public:
ITestContext GetThreadDefaultContext(
Thread thread
) sealed
J#
public ITestContext GetThreadDefaultContext(
Thread thread
)
JScript
public function GetThreadDefaultContext(
thread : Thread
) : ITestContext

Parameters

thread
The thread

Return Value

The default context of the thread

Implements

ITestContextTracker.GetThreadDefaultContext

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


SetThreadDefaultContext Method

DefaultTestContextTracker.SetThreadDefaultContext Method
[image]

Sets the default context for the specified thread.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetThreadDefaultContext( _
ByVal thread As Thread, _
ByVal context As ITestContext _
) _
Implements ITestContextTracker.SetThreadDefaultContext
C#
public void SetThreadDefaultContext(
Thread thread,
ITestContext context
)
C++
public:
void SetThreadDefaultContext(
Thread thread,
ITestContext context
) sealed
J#
public void SetThreadDefaultContext(
Thread thread,
ITestContext context
)
JScript
public function SetThreadDefaultContext(
thread : Thread,
context : ITestContext
)

Parameters

thread
The thread
context
The context to associate with the thread, or null to reset the thread's default context to inherit the GlobalContext once again

Implements

ITestContextTracker.SetThreadDefaultContext

See Also

DefaultTestContextTracker Class
Gallio.Model.Execution Namespace


DefaultTestOrderStrategy Class

DefaultTestOrderStrategy Class
See Also Example Members
[image]

Defines the test ordering strategy.

This default strategy first compares test by explicit ordering (using Order) then defines an implicit ordering by name (using Name).

This class cannot be inherited.
Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DefaultTestOrderStrategy
Implements IComparer(Of ITest)
C#
public sealed class DefaultTestOrderStrategy : IComparer<ITest>
C++
ref class DefaultTestOrderStrategy sealed : IComparer<ITest>
J#
public final class DefaultTestOrderStrategy implements IComparer<ITest>
JScript
public final class DefaultTestOrderStrategy extends IComparer<ITest>

Remarks

Why implicitly order tests by name instead of randomly?

It is my belief that ordering tests by name significantly eases test result interpretation because the test results are produced in a meaningful and predictable order. If the implicit order is known, then it's easier for a tester to guage test progress by inspecting the name of the currently executing test (in addition to using cues provided by progress monitors, of course). Related tests also tend to have similar names or share a common prefix so sorting by name can effectively cluster these tests together thereby providing feedback about related topics around the same time.

A tester may of course take advantage of this known ordering to produce tests that are dependent upon one another without making that clear in the code by specifying explicit test dependencies or ordering. When a test is renamed, the implicit ordering will change, possibly causing other tests to fail. However, it is not Gallio's objective to police testers, who may well adopt any number of inadvisable practices to meet their ends.

Nevertheless, any test framework is still free to produce a random ordering of independent tests. It suffices for the framework to initialize the Order property of each of its testsw to a distinct random number. Problem solved.

Perhaps someday we can also offer the user a global choice among alternative test ordering strategies.

-- Jeff.

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.DefaultTestOrderStrategy

See Also

DefaultTestOrderStrategy Members
Gallio.Model.Execution Namespace


DefaultTestOrderStrategy Members

DefaultTestOrderStrategy Members
See Also Example Constructors Methods
[image]

Defines the test ordering strategy.

This default strategy first compares test by explicit ordering (using Order) then defines an implicit ordering by name (using Name).

This class cannot be inherited.

The following tables list the members exposed by DefaultTestOrderStrategy.

Public Constructors

 | Name | Description
Public method | DefaultTestOrderStrategy | Initializes a new instance of the DefaultTestOrderStrategy class.
Top

Public Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DefaultTestOrderStrategy Class
Gallio.Model.Execution Namespace


DefaultTestOrderStrategy Constructor

DefaultTestOrderStrategy Constructor
[image]

Initializes a new instance of the DefaultTestOrderStrategy class.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DefaultTestOrderStrategy()
C++
public:
DefaultTestOrderStrategy() sealed
J#
public DefaultTestOrderStrategy()
JScript
public function DefaultTestOrderStrategy()

See Also

DefaultTestOrderStrategy Class
Gallio.Model.Execution Namespace


Methods

DefaultTestOrderStrategy Methods
[image]

Public Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DefaultTestOrderStrategy Class
Gallio.Model.Execution Namespace


Compare Method

DefaultTestOrderStrategy.Compare Method
[image]

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Compare( _
ByVal a As ITest, _
ByVal b As ITest _
) As Integer _
Implements IComparer<ITest>.Compare
C#
public int Compare(
ITest a,
ITest b
)
C++
public:
int Compare(
ITest a,
ITest b
) sealed
J#
public int Compare(
ITest a,
ITest b
)
JScript
public function Compare(
a : ITest,
b : ITest
) : int

Implements

IComparer<ITest>.Compare

See Also

DefaultTestOrderStrategy Class
Gallio.Model.Execution Namespace


ITestCommand Interface

ITestCommand Interface
See Also Example Members
[image]

A test command requests the execution of a tree of ITests. The test command hierarchy mirrors a filtered subset of the test hierarchy.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestCommand
C#
public interface ITestCommand
C++
interface class ITestCommand
J#
public interface ITestCommand
JScript
public interface ITestCommand

Types that implement ITestCommand

Type | Description
Gallio.Model.Execution.ManagedTestCommand | A ITestCommand implementation based on a ITestContextManager.

Remarks

The order in which commands appear in the command tree is significant. Commands should be sorted such that if command A depends on command B, then B will appear before A in a pre-order traversal of the tree.

The ordering constraint is intended to simplify the implementation of ITestControllers. Test controllers may assume that executing ITestCommands in pre-order traversal sequence will be sufficient to ensure that all dependencies can be evaluated in time.

However, a ITestController is NOT required to run the tests in the specified order. Moreover, it is NOT required to run them serially at all. A smart ITestController might run tests in parallel or take into account additional sequencing constraints governing execution order.

In order to achieve correct behavior, a ITestController should satisfy the following guarantees with respect to test commands:

  • A test command runs within the scope of its parent test command.
  • A test command runs only after all of the test commands it depends on have passed.
  • A test command with a failed dependency or that is not run for internal reasons reports a test outcome of Skipped.

See Also

ITestCommand Members
Gallio.Model.Execution Namespace


ITestCommand Members

ITestCommand Members
See Also Example Properties Methods
[image]

A test command requests the execution of a tree of ITests. The test command hierarchy mirrors a filtered subset of the test hierarchy.

The following tables list the members exposed by ITestCommand.

Public Properties

 | Name | Description
Public property | Children | Gets the list of child commands to run within the scope of this command. Each child command represents a test that is a child of the test managed by this command. The children are listed in an order that is consistent with their dependencies. See class commends for details.
Public property | Dependencies | Gets the list of other commands that this command depends upon. The dependent commands are guaranteed to have appeared before this command in a pre-order traversal of the command tree. A test command cannot depend on one of its direct ancestors.
Public property | IsExplicit | Returns true if the test was explicitly selected by a filter.
Public property | PreOrderTraversal | Enumerates this command and all of its descendants in pre-order tree traversal.
Public property | RootStepFailureCount | Gets the number of times that a root step of this test has failed.
Public property | Test | Gets the test that is to be executed.
Public property | TestCount | Gets the total number of tests in the command subtree, including itself.
Top

Public Methods

Name | Description
Public method | AreDependenciesSatisfied | Returns true if all of the dependencies of this test command have been satisfied.
Public method | GetAllCommands | Gets a list consisting of this command and all of its descendants as enumerated by pre-order tree traversal.
Public method StartPrimaryChildStep

Starts the primary step of the test associated with this command as a child of the specified test step and returns its test context.

This method is equivalent to calling StartStep using a default implementation of ITestStep that is initialized using parentTestStep and the metadata from the

Public method | StartStep | Starts a new step of the test using the specified test step object.
Top

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


Properties

ITestCommand Properties
[image]

Public Properties

 | Name | Description
Public property | Children | Gets the list of child commands to run within the scope of this command. Each child command represents a test that is a child of the test managed by this command. The children are listed in an order that is consistent with their dependencies. See class commends for details.
Public property | Dependencies | Gets the list of other commands that this command depends upon. The dependent commands are guaranteed to have appeared before this command in a pre-order traversal of the command tree. A test command cannot depend on one of its direct ancestors.
Public property | IsExplicit | Returns true if the test was explicitly selected by a filter.
Public property | PreOrderTraversal | Enumerates this command and all of its descendants in pre-order tree traversal.
Public property | RootStepFailureCount | Gets the number of times that a root step of this test has failed.
Public property | Test | Gets the test that is to be executed.
Public property | TestCount | Gets the total number of tests in the command subtree, including itself.
Top

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


Children Property

ITestCommand.Children Property
[image]

Gets the list of child commands to run within the scope of this command.

Each child command represents a test that is a child of the test managed by this command.

The children are listed in an order that is consistent with their dependencies. See class commends for details.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As IList(Of ITestCommand)
C#
IList<ITestCommand> Children { get; }
C++
property IList<ITestCommand> Children abstract {
IList<ITestCommand> get();
}
J#
/** property */
public IList<ITestCommand> get_Children();
JScript
public function get Children() : IList<ITestCommand>

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


Dependencies Property

ITestCommand.Dependencies Property
[image]

Gets the list of other commands that this command depends upon.

The dependent commands are guaranteed to have appeared before this command in a pre-order traversal of the command tree. A test command cannot depend on one of its direct ancestors.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Dependencies As IList(Of ITestCommand)
C#
IList<ITestCommand> Dependencies { get; }
C++
property IList<ITestCommand> Dependencies abstract {
IList<ITestCommand> get();
}
J#
/** property */
public IList<ITestCommand> get_Dependencies();
JScript
public function get Dependencies() : IList<ITestCommand>

Remarks

There must be no circular dependencies.

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


IsExplicit Property

ITestCommand.IsExplicit Property
[image]

Returns true if the test was explicitly selected by a filter.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsExplicit As Boolean
C#
bool IsExplicit { get; }
C++
property bool IsExplicit abstract {
bool get();
}
J#
/** property */
public bool get_IsExplicit();
JScript
public function get IsExplicit() : bool

Remarks

This flag enables test controllers to distinguish the case when a particular test was explicitly selected by a user-specified filter rather than by virtue of one of its parents having been selected.

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


PreOrderTraversal Property

ITestCommand.PreOrderTraversal Property
[image]

Enumerates this command and all of its descendants in pre-order tree traversal.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PreOrderTraversal As IEnumerable(Of ITestCommand)
C#
IEnumerable<ITestCommand> PreOrderTraversal { get; }
C++
property IEnumerable<ITestCommand> PreOrderTraversal abstract {
IEnumerable<ITestCommand> get();
}
J#
/** property */
public IEnumerable<ITestCommand> get_PreOrderTraversal();
JScript
public function get PreOrderTraversal() : IEnumerable<ITestCommand>

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


RootStepFailureCount Property

ITestCommand.RootStepFailureCount Property
[image]

Gets the number of times that a root step of this test has failed.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RootStepFailureCount As Integer
C#
int RootStepFailureCount { get; }
C++
property int RootStepFailureCount abstract {
int get();
}
J#
/** property */
public int get_RootStepFailureCount();
JScript
public function get RootStepFailureCount() : int

Remarks

The value of this field is automatically updated as each root step created by StartPrimaryChildStep finishes.

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


Test Property

ITestCommand.Test Property
[image]

Gets the test that is to be executed.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Test As ITest
C#
ITest Test { get; }
C++
property ITest Test abstract {
ITest get();
}
J#
/** property */
public ITest get_Test();
JScript
public function get Test() : ITest

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


TestCount Property

ITestCommand.TestCount Property
[image]

Gets the total number of tests in the command subtree, including itself.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestCount As Integer
C#
int TestCount { get; }
C++
property int TestCount abstract {
int get();
}
J#
/** property */
public int get_TestCount();
JScript
public function get TestCount() : int

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


Methods

ITestCommand Methods
[image]

Public Methods

Name | Description
Public method | AreDependenciesSatisfied | Returns true if all of the dependencies of this test command have been satisfied.
Public method | GetAllCommands | Gets a list consisting of this command and all of its descendants as enumerated by pre-order tree traversal.
Public method StartPrimaryChildStep

Starts the primary step of the test associated with this command as a child of the specified test step and returns its test context.

This method is equivalent to calling StartStep using a default implementation of ITestStep that is initialized using parentTestStep and the metadata from the

Public method | StartStep | Starts a new step of the test using the specified test step object.
Top

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


AreDependenciesSatisfied Method

ITestCommand.AreDependenciesSatisfied Method
[image]

Returns true if all of the dependencies of this test command have been satisfied.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function AreDependenciesSatisfied() As Boolean
C#
bool AreDependenciesSatisfied()
C++
bool AreDependenciesSatisfied() abstract
J#
bool AreDependenciesSatisfied()
JScript
function AreDependenciesSatisfied() : bool

Return Value

True if the dependencies of this test command have been satisfied

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


GetAllCommands Method

ITestCommand.GetAllCommands Method
[image]

Gets a list consisting of this command and all of its descendants as enumerated by pre-order tree traversal.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetAllCommands() As IList(Of ITestCommand)
C#
IList<ITestCommand> GetAllCommands()
C++
IList<ITestCommand> GetAllCommands() abstract
J#
IList<ITestCommand> GetAllCommands()
JScript
function GetAllCommands() : IList<ITestCommand>

Return Value

The list of all command

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


StartPrimaryChildStep Method

ITestCommand.StartPrimaryChildStep Method
[image]

Starts the primary step of the test associated with this command as a child of the specified test step and returns its test context.

This method is equivalent to calling StartStep using a default implementation of ITestStep that is initialized using parentTestStep and the metadata from the

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function StartPrimaryChildStep( _
ByVal parentTestStep As ITestStep _
) As ITestContext
C#
ITestContext StartPrimaryChildStep(
ITestStep parentTestStep
)
C++
ITestContext StartPrimaryChildStep(
ITestStep parentTestStep
) abstract
J#
ITestContext StartPrimaryChildStep(
ITestStep parentTestStep
)
JScript
function StartPrimaryChildStep(
parentTestStep : ITestStep
) : ITestContext

Parameters

parentTestStep
The parent test step, or null if none

Return Value

The test context for the new primary test step

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace
StartStep


StartStep Method

ITestCommand.StartStep Method
[image]

Starts a new step of the test using the specified test step object.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function StartStep( _
ByVal testStep As ITestStep _
) As ITestContext
C#
ITestContext StartStep(
ITestStep testStep
)
C++
ITestContext StartStep(
ITestStep testStep
) abstract
J#
ITestContext StartStep(
ITestStep testStep
)
JScript
function StartStep(
testStep : ITestStep
) : ITestContext

Parameters

testStep
The test step to start

Return Value

The test context for the test step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testStep is null
ArgumentException | Thrown if testStep does not belong to the test associated with this test command

Remarks

The current thread's test context is set to a new context for the test step that is starting. The new context will be a child of the current thread's context.

See Also

ITestCommand Interface
Gallio.Model.Execution Namespace


ITestContext Interface

ITestContext Interface
See Also Example Members
[image]

The context provides information about the environment in which a test is executing. A new context is created each time a test or test step begins execution.

Contexts are arranged in a hierarchy that corresponds to the order in which the contexts were entered. Thus the context for a test likely has as its parent the context for its containing test fixture.

Arbitrary user data can be associated with a context. Furthermore, client code may attach Finishing event handlers to perform resource reclamation or other updates when the test step is finished.

When the context is disposed, its associated test step is automatically marked as being finished unless FinishStep was previously called. When this occurs the test step is finished with an outcome of Error.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestContext
Implements IDisposable
C#
public interface ITestContext : IDisposable
C++
interface class ITestContext : IDisposable
J#
public interface ITestContext implements IDisposable
JScript
public interface ITestContext extends IDisposable

Types that implement ITestContext

Type | Description
Gallio.Model.Execution.StubTestContext | A stub implementation of ITestContext using a TextualTestLogWriter. Does not fully support nested test steps or other dynamic features.

See Also

ITestContext Members
Gallio.Model.Execution Namespace


ITestContext Members

ITestContext Members
See Also Example Properties Methods Events
[image]

The context provides information about the environment in which a test is executing. A new context is created each time a test or test step begins execution.

Contexts are arranged in a hierarchy that corresponds to the order in which the contexts were entered. Thus the context for a test likely has as its parent the context for its containing test fixture.

Arbitrary user data can be associated with a context. Furthermore, client code may attach Finishing event handlers to perform resource reclamation or other updates when the test step is finished.

When the context is disposed, its associated test step is automatically marked as being finished unless FinishStep was previously called. When this occurs the test step is finished with an outcome of Error.

The following tables list the members exposed by ITestContext.

Public Properties

 | Name | Description
Public property | AssertCount | Gets the current assertion count.
Public property | Data | Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.
Public property | IsFinished | Returns true if the step associated with the context has finished execution and completed all Finishing actions.
Public property | LifecyclePhase | Gets or sets the lifecycle phase the context is in.
Public property | LogWriter | Gets the log writer for the test executing in this context. Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.
Public property | Outcome | Gets the step's outcome or its interim outcome if the test is still running. The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.
Public property | Parent | Gets the parent context or null if this context has no parent.
Public property | TestStep | Gets the test step associated with the context.
Top

Public Methods

 | Name | Description
Public method | AddAssertCount | Adds the specified amount to the assert count atomically.
Public method | AddMetadata | Adds metadata to the step that is running in the context.
Public method | FinishStep | Finishes a step and submits its final result.
Public method | SetInterimOutcome | Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.
Public method | StartChildStep | Starts a child step of the test and returns its context.
Top

Public Events

Name Description
Public event Finishing

The Finishing event is raised when the test step is finishing to perform resource reclamation or other updates.

Clients may attach handlers to this event to perform cleanup activities and other tasks as needed. If a new event handler is added and the step has already finished, the handler is immediately invoked.

Top

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


Properties

ITestContext Properties
[image]

Public Properties

 | Name | Description
Public property | AssertCount | Gets the current assertion count.
Public property | Data | Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.
Public property | IsFinished | Returns true if the step associated with the context has finished execution and completed all Finishing actions.
Public property | LifecyclePhase | Gets or sets the lifecycle phase the context is in.
Public property | LogWriter | Gets the log writer for the test executing in this context. Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.
Public property | Outcome | Gets the step's outcome or its interim outcome if the test is still running. The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.
Public property | Parent | Gets the parent context or null if this context has no parent.
Public property | TestStep | Gets the test step associated with the context.
Top

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


AssertCount Property

ITestContext.AssertCount Property
[image]

Gets the current assertion count.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AssertCount As Integer
C#
int AssertCount { get; }
C++
property int AssertCount abstract {
int get();
}
J#
/** property */
public int get_AssertCount();
JScript
public function get AssertCount() : int

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


Data Property

ITestContext.Data Property
[image]

Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Data As UserDataCollection
C#
UserDataCollection Data { get; }
C++
property UserDataCollection Data abstract {
UserDataCollection get();
}
J#
/** property */
public UserDataCollection get_Data();
JScript
public function get Data() : UserDataCollection

Remarks

Each context has its own distinct user data collection.

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


IsFinished Property

ITestContext.IsFinished Property
[image]

Returns true if the step associated with the context has finished execution and completed all Finishing actions.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFinished As Boolean
C#
bool IsFinished { get; }
C++
property bool IsFinished abstract {
bool get();
}
J#
/** property */
public bool get_IsFinished();
JScript
public function get IsFinished() : bool

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


LifecyclePhase Property

ITestContext.LifecyclePhase Property
[image]

Gets or sets the lifecycle phase the context is in.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property LifecyclePhase As String
C#
string LifecyclePhase { get; set; }
C++
property string LifecyclePhase abstract {
String get();
void set(String value);
}
J#
/** property */
public string get_LifecyclePhase();

/** property */
public void set_LifecyclePhase(string value);
JScript
public function get LifecyclePhase() : String

public function set LifecyclePhase(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null
InvalidOperationException | Thrown if attempting to set the phase while the test is not running

See Also

ITestContext Interface
Gallio.Model.Execution Namespace
LifecyclePhases


LogWriter Property

ITestContext.LogWriter Property
[image]

Gets the log writer for the test executing in this context.

Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property LogWriter As TestLogWriter
C#
TestLogWriter LogWriter { get; }
C++
property TestLogWriter LogWriter abstract {
TestLogWriter get();
}
J#
/** property */
public TestLogWriter get_LogWriter();
JScript
public function get LogWriter() : TestLogWriter

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


Outcome Property

ITestContext.Outcome Property
[image]

Gets the step's outcome or its interim outcome if the test is still running.

The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Outcome As TestOutcome
C#
TestOutcome Outcome { get; }
C++
property TestOutcome Outcome abstract {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

Remarks

For example, this property enables code running as part of the tear down phase to determine whether the test is failing and to perform different actions in that case.

See Also

ITestContext Interface
Gallio.Model.Execution Namespace
SetInterimOutcome


Parent Property

ITestContext.Parent Property
[image]

Gets the parent context or null if this context has no parent.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As ITestContext
C#
ITestContext Parent { get; }
C++
property ITestContext Parent abstract {
ITestContext get();
}
J#
/** property */
public ITestContext get_Parent();
JScript
public function get Parent() : ITestContext

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


TestStep Property

ITestContext.TestStep Property
[image]

Gets the test step associated with the context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestStep As ITestStep
C#
ITestStep TestStep { get; }
C++
property ITestStep TestStep abstract {
ITestStep get();
}
J#
/** property */
public ITestStep get_TestStep();
JScript
public function get TestStep() : ITestStep

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


Methods

ITestContext Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssertCount | Adds the specified amount to the assert count atomically.
Public method | AddMetadata | Adds metadata to the step that is running in the context.
Public method | FinishStep | Finishes a step and submits its final result.
Public method | SetInterimOutcome | Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.
Public method | StartChildStep | Starts a child step of the test and returns its context.
Top

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


AddAssertCount Method

ITestContext.AddAssertCount Method
[image]

Adds the specified amount to the assert count atomically.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddAssertCount( _
ByVal value As Integer _
)
C#
void AddAssertCount(
int value
)
C++
void AddAssertCount(
int value
) abstract
J#
void AddAssertCount(
int value
)
JScript
function AddAssertCount(
value : int
)

Parameters

value
The amount to add to the assert count

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the test is not running

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


AddMetadata Method

ITestContext.AddMetadata Method
[image]

Adds metadata to the step that is running in the context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddMetadata( _
ByVal metadataKey As String, _
ByVal metadataValue As String _
)
C#
void AddMetadata(
string metadataKey,
string metadataValue
)
C++
void AddMetadata(
String metadataKey,
String metadataValue
) abstract
J#
void AddMetadata(
string metadataKey,
string metadataValue
)
JScript
function AddMetadata(
metadataKey : String,
metadataValue : String
)

Parameters

metadataKey
The metadata key
metadataValue
The metadata value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if metadataKey or metadataValue is null
InvalidOperationException | Thrown if the test is not running

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


FinishStep Method

ITestContext.FinishStep Method
[image]

Finishes a step and submits its final result.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub FinishStep( _
ByVal outcome As TestOutcome, _
ByVal actualDuration As Nullable(Of TimeSpan) _
)
C#
void FinishStep(
TestOutcome outcome,
Nullable<TimeSpan> actualDuration
)
C++
void FinishStep(
TestOutcome outcome,
Nullable<TimeSpan> actualDuration
) abstract
J#
void FinishStep(
TestOutcome outcome,
Nullable<TimeSpan> actualDuration
)
JScript
function FinishStep(
outcome : TestOutcome,
actualDuration : Nullable<TimeSpan>
)

Parameters

outcome
The final test outcome
actualDuration
The actual duration of the step, if null the step monitor will record the duration as the total amount of time since the step monitor was started

Remarks

If any children of the step are still executing their contexts are automatically disposed. Then Finishing actions are executed. Finally, the current thread's test context is exited.

See Also

ITestContext Interface
Gallio.Model.Execution Namespace
Finishing


SetInterimOutcome Method

ITestContext.SetInterimOutcome Method
[image]

Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetInterimOutcome( _
ByVal outcome As TestOutcome _
)
C#
void SetInterimOutcome(
TestOutcome outcome
)
C++
void SetInterimOutcome(
TestOutcome outcome
) abstract
J#
void SetInterimOutcome(
TestOutcome outcome
)
JScript
function SetInterimOutcome(
outcome : TestOutcome
)

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if attempting to set the outcome while the test is not running

Remarks

The value set here will be overridden by whatever final outcome the step returns. Consequently the actual outcome may still differ from the anticipated outcome that was set using this method.

See Also

ITestContext Interface
Gallio.Model.Execution Namespace
Outcome


StartChildStep Method

ITestContext.StartChildStep Method
[image]

Starts a child step of the test and returns its context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function StartChildStep( _
ByVal childStep As ITestStep _
) As ITestContext
C#
ITestContext StartChildStep(
ITestStep childStep
)
C++
ITestContext StartChildStep(
ITestStep childStep
) abstract
J#
ITestContext StartChildStep(
ITestStep childStep
)
JScript
function StartChildStep(
childStep : ITestStep
) : ITestContext

Parameters

childStep
The step to start

Return Value

The context of the child step

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the step has finished
ArgumentNullException | Thrown if childStep is null
ArgumentException | Thrown if childStep is not a child of the this step

Remarks

The current thread's test context is set to the context of the test step that is starting.

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


Events

ITestContext Events
[image]

Public Events

Name Description
Public event Finishing

The Finishing event is raised when the test step is finishing to perform resource reclamation or other updates.

Clients may attach handlers to this event to perform cleanup activities and other tasks as needed. If a new event handler is added and the step has already finished, the handler is immediately invoked.

Top

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


Finishing Event

ITestContext.Finishing Event
[image]

The Finishing event is raised when the test step is finishing to perform resource reclamation or other updates.

Clients may attach handlers to this event to perform cleanup activities and other tasks as needed. If a new event handler is added and the step has already finished, the handler is immediately invoked.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event Finishing As EventHandler
C#
abstract event EventHandler Finishing
C++
event EventHandler Finishing {
void add(EventHandler value) abstract ;
void remove(EventHandler value) abstract ;
}
J#
/** event */
void add_Finishing(EventHandler value);

/** event */
abstract void remove_Finishing(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ITestContext Interface
Gallio.Model.Execution Namespace


ITestContextManager Interface

ITestContextManager Interface
See Also Example Members
[image]

A test context manager functions as a factory for ITestContext objects and tracks them with an ITestContextTracker.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestContextManager
C#
public interface ITestContextManager
C++
interface class ITestContextManager
J#
public interface ITestContextManager
JScript
public interface ITestContextManager

Types that implement ITestContextManager

Type | Description
Gallio.Model.Execution.ObservableTestContextManager | An observable test context manager creates and tracks test contexts that are associated with a ITestExecutionListener for reporting test events back to the test runner.

See Also

ITestContextManager Members
Gallio.Model.Execution Namespace


ITestContextManager Members

ITestContextManager Members
See Also Example Properties Methods
[image]

A test context manager functions as a factory for ITestContext objects and tracks them with an ITestContextTracker.

The following tables list the members exposed by ITestContextManager.

Public Properties

 | Name | Description
Public property | ContextTracker | Gets the test context tracker.
Top

Public Methods

 | Name | Description
Public method | StartStep | Starts a test step and returns its associated test context.
Top

See Also

ITestContextManager Interface
Gallio.Model.Execution Namespace


Properties

ITestContextManager Properties
[image]

Public Properties

 | Name | Description
Public property | ContextTracker | Gets the test context tracker.
Top

See Also

ITestContextManager Interface
Gallio.Model.Execution Namespace


ContextTracker Property

ITestContextManager.ContextTracker Property
[image]

Gets the test context tracker.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ContextTracker As ITestContextTracker
C#
ITestContextTracker ContextTracker { get; }
C++
property ITestContextTracker ContextTracker abstract {
ITestContextTracker get();
}
J#
/** property */
public ITestContextTracker get_ContextTracker();
JScript
public function get ContextTracker() : ITestContextTracker

See Also

ITestContextManager Interface
Gallio.Model.Execution Namespace


Methods

ITestContextManager Methods
[image]

Public Methods

 | Name | Description
Public method | StartStep | Starts a test step and returns its associated test context.
Top

See Also

ITestContextManager Interface
Gallio.Model.Execution Namespace


StartStep Method

ITestContextManager.StartStep Method
[image]

Starts a test step and returns its associated test context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function StartStep( _
ByVal testStep As ITestStep _
) As ITestContext
C#
ITestContext StartStep(
ITestStep testStep
)
C++
ITestContext StartStep(
ITestStep testStep
) abstract
J#
ITestContext StartStep(
ITestStep testStep
)
JScript
function StartStep(
testStep : ITestStep
) : ITestContext

Parameters

testStep
The test step

Return Value

The test context associated with the test step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testStep is null

Remarks

The current thread's test context is set to a new context for the test step that is starting. The new context will be a child of the current thread's context.

See Also

ITestContextManager Interface
Gallio.Model.Execution Namespace


ITestContextTracker Interface

ITestContextTracker Interface
See Also Example Members
[image]

The context tracker tracks the ITestContext associated with threads.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestContextTracker
C#
public interface ITestContextTracker
C++
interface class ITestContextTracker
J#
public interface ITestContextTracker
JScript
public interface ITestContextTracker

Types that implement ITestContextTracker

Type | Description
Gallio.Model.Execution.DefaultTestContextTracker | The default context tracker tracks the current context by way of the thread's ExecutionContext and CallContext. The .Net framework ensures that this context information flows across threads during asynchronous callbacks, timer events and thread pool work item execution.

Remarks

All context tracker operations are thread safe.

See Also

ITestContextTracker Members
Gallio.Model.Execution Namespace


ITestContextTracker Members

ITestContextTracker Members
See Also Example Properties Methods
[image]

The context tracker tracks the ITestContext associated with threads.

The following tables list the members exposed by ITestContextTracker.

Public Properties

Name | Description
Public property CurrentContext

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

Public property | GlobalContext | Gets or the global context of the environment, or null if there is no such context.
Top

Public Methods

 | Name | Description
Public method | EnterContext | Enters a context.
Public method | GetThreadDefaultContext | Gets the default context for the specified thread.
Public method | SetThreadDefaultContext | Sets the default context for the specified thread.
Top

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


Properties

ITestContextTracker Properties
[image]

Public Properties

Name | Description
Public property CurrentContext

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

Public property | GlobalContext | Gets or the global context of the environment, or null if there is no such context.
Top

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


CurrentContext Property

ITestContextTracker.CurrentContext Property
[image]

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrentContext As ITestContext
C#
ITestContext CurrentContext { get; }
C++
property ITestContext CurrentContext abstract {
ITestContext get();
}
J#
/** property */
public ITestContext get_CurrentContext();
JScript
public function get CurrentContext() : ITestContext

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


GlobalContext Property

ITestContextTracker.GlobalContext Property
[image]

Gets or the global context of the environment, or null if there is no such context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property GlobalContext As ITestContext
C#
ITestContext GlobalContext { get; set; }
C++
property ITestContext GlobalContext abstract {
ITestContext get();
void set(ITestContext value);
}
J#
/** property */
public ITestContext get_GlobalContext();

/** property */
public void set_GlobalContext(ITestContext value);
JScript
public function get GlobalContext() : ITestContext

public function set GlobalContext(value : ITestContext);

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


Methods

ITestContextTracker Methods
[image]

Public Methods

 | Name | Description
Public method | EnterContext | Enters a context.
Public method | GetThreadDefaultContext | Gets the default context for the specified thread.
Public method | SetThreadDefaultContext | Sets the default context for the specified thread.
Top

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


EnterContext Method

ITestContextTracker.EnterContext Method
[image]

Enters a context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function EnterContext( _
ByVal context As ITestContext _
) As IDisposable
C#
IDisposable EnterContext(
ITestContext context
)
C++
IDisposable EnterContext(
ITestContext context
) abstract
J#
IDisposable EnterContext(
ITestContext context
)
JScript
function EnterContext(
context : ITestContext
) : IDisposable

Parameters

context
The context to enter, or null to enter a scope without a context

Return Value

A cookie that can be used to restore the current thread's context to its previous value when disposed

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


GetThreadDefaultContext Method

ITestContextTracker.GetThreadDefaultContext Method
[image]

Gets the default context for the specified thread.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetThreadDefaultContext( _
ByVal thread As Thread _
) As ITestContext
C#
ITestContext GetThreadDefaultContext(
Thread thread
)
C++
ITestContext GetThreadDefaultContext(
Thread thread
) abstract
J#
ITestContext GetThreadDefaultContext(
Thread thread
)
JScript
function GetThreadDefaultContext(
thread : Thread
) : ITestContext

Parameters

thread
The thread

Return Value

The default context of the thread

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if thread is null

Remarks

The default context for a thread is GlobalContext unless the thread's default context has been overridden with SetThreadDefaultContext.

Changing the default context of a thread is useful for capturing existing threads created outside of a test into a particular context. Among other things, this ensures that side-effects of the thread, such as writing text to the console, are recorded as part of the step represented by the specified context.

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


SetThreadDefaultContext Method

ITestContextTracker.SetThreadDefaultContext Method
[image]

Sets the default context for the specified thread.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetThreadDefaultContext( _
ByVal thread As Thread, _
ByVal context As ITestContext _
)
C#
void SetThreadDefaultContext(
Thread thread,
ITestContext context
)
C++
void SetThreadDefaultContext(
Thread thread,
ITestContext context
) abstract
J#
void SetThreadDefaultContext(
Thread thread,
ITestContext context
)
JScript
function SetThreadDefaultContext(
thread : Thread,
context : ITestContext
)

Parameters

thread
The thread
context
The context to associate with the thread, or null to reset the thread's default context to inherit the GlobalContext once again

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if thread is null

Remarks

The default context for a thread is GlobalContext unless the thread's default context has been overridden with SetThreadDefaultContext.

Changing the default context of a thread is useful for capturing existing threads created outside of a test into a particular context. Among other things, this ensures that side-effects of the thread, such as writing text to the console, are recorded as part of the step represented by the specified context.

See Also

ITestContextTracker Interface
Gallio.Model.Execution Namespace


ITestController Interface

ITestController Interface
See Also Example Members
[image]

A test controller runs a batch of tests.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestController
Implements IDisposable
C#
public interface ITestController : IDisposable
C++
interface class ITestController : IDisposable
J#
public interface ITestController implements IDisposable
JScript
public interface ITestController extends IDisposable

Types that implement ITestController

Type | Description
Gallio.Model.Execution.BaseTestController | Base implementation of ITestController that does nothing. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestController Members
Gallio.Model.Execution Namespace


ITestController Members

ITestController Members
See Also Example Methods
[image]

A test controller runs a batch of tests.

The following tables list the members exposed by ITestController.

Public Methods

 | Name | Description
Public method | RunTests | Runs the tests.
Top

See Also

ITestController Interface
Gallio.Model.Execution Namespace


Methods

ITestController Methods
[image]

Public Methods

 | Name | Description
Public method | RunTests | Runs the tests.
Top

See Also

ITestController Interface
Gallio.Model.Execution Namespace


RunTests Method

ITestController.RunTests Method
[image]

Runs the tests.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function RunTests( _
ByVal rootTestCommand As ITestCommand, _
ByVal parentTestStep As ITestStep, _
ByVal options As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As TestOutcome
C#
TestOutcome RunTests(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
C++
TestOutcome RunTests(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
) abstract
J#
TestOutcome RunTests(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
JScript
function RunTests(
rootTestCommand : ITestCommand,
parentTestStep : ITestStep,
options : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : TestOutcome

Parameters

rootTestCommand
The root test monitor
parentTestStep
The parent test step, or null if starting a root step
options
The test execution options
progressMonitor
The progress monitor

Return Value

The combined outcome of the root test command

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if rootTestCommandprogressMonitor, or options is null

Remarks

This method can be called at most once during the lifetime of a test controller.

See Also

ITestController Interface
Gallio.Model.Execution Namespace


ManagedTestCommand Class

ManagedTestCommand Class
See Also Example Members
[image]

A ITestCommand implementation based on a ITestContextManager.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ManagedTestCommand
Implements ITestCommand
C#
public class ManagedTestCommand : ITestCommand
C++
ref class ManagedTestCommand : ITestCommand
J#
public class ManagedTestCommand implements ITestCommand
JScript
public class ManagedTestCommand extends ITestCommand

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.ManagedTestCommand

See Also

ManagedTestCommand Members
Gallio.Model.Execution Namespace


ManagedTestCommand Members

ManagedTestCommand Members
See Also Example Constructors Properties Methods
[image]

A ITestCommand implementation based on a ITestContextManager.

The following tables list the members exposed by ManagedTestCommand.

Public Constructors

 | Name | Description
Public method | ManagedTestCommand | Creates a test command.
Top

Public Properties

 | Name | Description
Public property | Children | Gets the list of child commands to run within the scope of this command. Each child command represents a test that is a child of the test managed by this command. The children are listed in an order that is consistent with their dependencies. See class commends for details.
Public property | Dependencies | Gets the list of other commands that this command depends upon. The dependent commands are guaranteed to have appeared before this command in a pre-order traversal of the command tree. A test command cannot depend on one of its direct ancestors.
Public property | IsExplicit | Returns true if the test was explicitly selected by a filter.
Public property | PreOrderTraversal | Enumerates this command and all of its descendants in pre-order tree traversal.
Public property | RootStepFailureCount | Gets the number of times that a root step of this test has failed.
Public property | Test | Gets the test that is to be executed.
Public property | TestCount | Gets the total number of tests in the command subtree, including itself.
Top

Public Methods

Name | Description
Public method | AddChild | Adds a child test command.
Public method | AddDependency | Adds a test command dependency.
Public method | AreDependenciesSatisfied | Returns true if all of the dependencies of this test command have been satisfied.
Public method | ChildrenToArray | Gets the list of children as an array.
Public method | ClearChildren | Clears the children of the command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetAllCommands | Gets a list consisting of this command and all of its descendants as enumerated by pre-order tree traversal.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method StartPrimaryChildStep

Starts the primary step of the test associated with this command as a child of the specified test step and returns its test context.

This method is equivalent to calling StartStep using a default implementation of ITestStep that is initialized using parentTestStep and the metadata from the

Public method | StartStep | Starts a new step of the test using the specified test step object.
Public method | ToString | Overridden. Returns a description of the test command for debugging purposes.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


ManagedTestCommand Constructor

ManagedTestCommand Constructor
[image]

Creates a test command.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal contextManager As ITestContextManager, _
ByVal test As ITest, _
ByVal isExplicit As Boolean _
)
C#
public ManagedTestCommand(
ITestContextManager contextManager,
ITest test,
bool isExplicit
)
C++
public:
ManagedTestCommand(
ITestContextManager contextManager,
ITest test,
bool isExplicit
) sealed
J#
public ManagedTestCommand(
ITestContextManager contextManager,
ITest test,
bool isExplicit
)
JScript
public function ManagedTestCommand(
contextManager : ITestContextManager,
test : ITest,
isExplicit : bool
)

Parameters

contextManager
The test context manager
test
The test
isExplicit
True if the test is being executed explicitly

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


Properties

ManagedTestCommand Properties
[image]

Public Properties

 | Name | Description
Public property | Children | Gets the list of child commands to run within the scope of this command. Each child command represents a test that is a child of the test managed by this command. The children are listed in an order that is consistent with their dependencies. See class commends for details.
Public property | Dependencies | Gets the list of other commands that this command depends upon. The dependent commands are guaranteed to have appeared before this command in a pre-order traversal of the command tree. A test command cannot depend on one of its direct ancestors.
Public property | IsExplicit | Returns true if the test was explicitly selected by a filter.
Public property | PreOrderTraversal | Enumerates this command and all of its descendants in pre-order tree traversal.
Public property | RootStepFailureCount | Gets the number of times that a root step of this test has failed.
Public property | Test | Gets the test that is to be executed.
Public property | TestCount | Gets the total number of tests in the command subtree, including itself.
Top

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


Children Property

ManagedTestCommand.Children Property
[image]

Gets the list of child commands to run within the scope of this command.

Each child command represents a test that is a child of the test managed by this command.

The children are listed in an order that is consistent with their dependencies. See class commends for details.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Children As IList(Of ITestCommand) _
Implements ITestCommand.Children
C#
public IList<ITestCommand> Children { get; }
C++
public property IList<ITestCommand> Children sealed {
IList<ITestCommand> get();
}
J#
/** property */
public IList<ITestCommand> get_Children();
JScript
public function get Children() : IList<ITestCommand>

Implements

ITestCommand.Children

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


Dependencies Property

ManagedTestCommand.Dependencies Property
[image]

Gets the list of other commands that this command depends upon.

The dependent commands are guaranteed to have appeared before this command in a pre-order traversal of the command tree. A test command cannot depend on one of its direct ancestors.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dependencies As IList(Of ITestCommand) _
Implements ITestCommand.Dependencies
C#
public IList<ITestCommand> Dependencies { get; }
C++
public property IList<ITestCommand> Dependencies sealed {
IList<ITestCommand> get();
}
J#
/** property */
public IList<ITestCommand> get_Dependencies();
JScript
public function get Dependencies() : IList<ITestCommand>

Implements

ITestCommand.Dependencies

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


IsExplicit Property

ManagedTestCommand.IsExplicit Property
[image]

Returns true if the test was explicitly selected by a filter.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsExplicit As Boolean _
Implements ITestCommand.IsExplicit
C#
public bool IsExplicit { get; }
C++
public property bool IsExplicit sealed {
bool get();
}
J#
/** property */
public bool get_IsExplicit();
JScript
public function get IsExplicit() : bool

Implements

ITestCommand.IsExplicit

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


PreOrderTraversal Property

ManagedTestCommand.PreOrderTraversal Property
[image]

Enumerates this command and all of its descendants in pre-order tree traversal.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreOrderTraversal As IEnumerable(Of ITestCommand) _
Implements ITestCommand.PreOrderTraversal
C#
public IEnumerable<ITestCommand> PreOrderTraversal { get; }
C++
public property IEnumerable<ITestCommand> PreOrderTraversal sealed {
IEnumerable<ITestCommand> get();
}
J#
/** property */
public IEnumerable<ITestCommand> get_PreOrderTraversal();
JScript
public function get PreOrderTraversal() : IEnumerable<ITestCommand>

Implements

ITestCommand.PreOrderTraversal

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


RootStepFailureCount Property

ManagedTestCommand.RootStepFailureCount Property
[image]

Gets the number of times that a root step of this test has failed.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootStepFailureCount As Integer _
Implements ITestCommand.RootStepFailureCount
C#
public int RootStepFailureCount { get; }
C++
public property int RootStepFailureCount sealed {
int get();
}
J#
/** property */
public int get_RootStepFailureCount();
JScript
public function get RootStepFailureCount() : int

Implements

ITestCommand.RootStepFailureCount

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


Test Property

ManagedTestCommand.Test Property
[image]

Gets the test that is to be executed.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As ITest _
Implements ITestCommand.Test
C#
public ITest Test { get; }
C++
public property ITest Test sealed {
ITest get();
}
J#
/** property */
public ITest get_Test();
JScript
public function get Test() : ITest

Implements

ITestCommand.Test

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


TestCount Property

ManagedTestCommand.TestCount Property
[image]

Gets the total number of tests in the command subtree, including itself.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestCount As Integer _
Implements ITestCommand.TestCount
C#
public int TestCount { get; }
C++
public property int TestCount sealed {
int get();
}
J#
/** property */
public int get_TestCount();
JScript
public function get TestCount() : int

Implements

ITestCommand.TestCount

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


Methods

ManagedTestCommand Methods
[image]

Public Methods

Name | Description
Public method | AddChild | Adds a child test command.
Public method | AddDependency | Adds a test command dependency.
Public method | AreDependenciesSatisfied | Returns true if all of the dependencies of this test command have been satisfied.
Public method | ChildrenToArray | Gets the list of children as an array.
Public method | ClearChildren | Clears the children of the command.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetAllCommands | Gets a list consisting of this command and all of its descendants as enumerated by pre-order tree traversal.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method StartPrimaryChildStep

Starts the primary step of the test associated with this command as a child of the specified test step and returns its test context.

This method is equivalent to calling StartStep using a default implementation of ITestStep that is initialized using parentTestStep and the metadata from the

Public method | StartStep | Starts a new step of the test using the specified test step object.
Public method | ToString | Overridden. Returns a description of the test command for debugging purposes.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


AddChild Method

ManagedTestCommand.AddChild Method
[image]

Adds a child test command.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddChild( _
ByVal child As ManagedTestCommand _
)
C#
public void AddChild(
ManagedTestCommand child
)
C++
public:
void AddChild(
ManagedTestCommand child
) sealed
J#
public void AddChild(
ManagedTestCommand child
)
JScript
public function AddChild(
child : ManagedTestCommand
)

Parameters

child
The child to add

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


AddDependency Method

ManagedTestCommand.AddDependency Method
[image]

Adds a test command dependency.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDependency( _
ByVal dependency As ManagedTestCommand _
)
C#
public void AddDependency(
ManagedTestCommand dependency
)
C++
public:
void AddDependency(
ManagedTestCommand dependency
) sealed
J#
public void AddDependency(
ManagedTestCommand dependency
)
JScript
public function AddDependency(
dependency : ManagedTestCommand
)

Parameters

dependency
The dependency to add

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


AreDependenciesSatisfied Method

ManagedTestCommand.AreDependenciesSatisfied Method
[image]

Returns true if all of the dependencies of this test command have been satisfied.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AreDependenciesSatisfied() As Boolean _
Implements ITestCommand.AreDependenciesSatisfied
C#
public bool AreDependenciesSatisfied()
C++
public:
bool AreDependenciesSatisfied() sealed
J#
public bool AreDependenciesSatisfied()
JScript
public function AreDependenciesSatisfied() : bool

Return Value

True if the dependencies of this test command have been satisfied

Implements

ITestCommand.AreDependenciesSatisfied

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


ChildrenToArray Method

ManagedTestCommand.ChildrenToArray Method
[image]

Gets the list of children as an array.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ChildrenToArray() As ManagedTestCommand()
C#
public ManagedTestCommand[] ChildrenToArray()
C++
public:
array<ManagedTestCommand>^ ChildrenToArray() sealed
J#
public ManagedTestCommand[] ChildrenToArray()
JScript
public function ChildrenToArray() : ManagedTestCommand[]

Return Value

The array of children

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


ClearChildren Method

ManagedTestCommand.ClearChildren Method
[image]

Clears the children of the command.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearChildren()
C#
public void ClearChildren()
C++
public:
void ClearChildren() sealed
J#
public void ClearChildren()
JScript
public function ClearChildren()

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


GetAllCommands Method

ManagedTestCommand.GetAllCommands Method
[image]

Gets a list consisting of this command and all of its descendants as enumerated by pre-order tree traversal.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllCommands() As IList(Of ITestCommand) _
Implements ITestCommand.GetAllCommands
C#
public IList<ITestCommand> GetAllCommands()
C++
public:
IList<ITestCommand> GetAllCommands() sealed
J#
public IList<ITestCommand> GetAllCommands()
JScript
public function GetAllCommands() : IList<ITestCommand>

Return Value

The list of all command

Implements

ITestCommand.GetAllCommands

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


StartPrimaryChildStep Method

ManagedTestCommand.StartPrimaryChildStep Method
[image]

Starts the primary step of the test associated with this command as a child of the specified test step and returns its test context.

This method is equivalent to calling StartStep using a default implementation of ITestStep that is initialized using parentTestStep and the metadata from the

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function StartPrimaryChildStep( _
ByVal parentTestStep As ITestStep _
) As ITestContext _
Implements ITestCommand.StartPrimaryChildStep
C#
public ITestContext StartPrimaryChildStep(
ITestStep parentTestStep
)
C++
public:
ITestContext StartPrimaryChildStep(
ITestStep parentTestStep
) sealed
J#
public ITestContext StartPrimaryChildStep(
ITestStep parentTestStep
)
JScript
public function StartPrimaryChildStep(
parentTestStep : ITestStep
) : ITestContext

Parameters

parentTestStep
The parent test step, or null if none

Return Value

The test context for the new primary test step

Implements

ITestCommand.StartPrimaryChildStep

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


StartStep Method

ManagedTestCommand.StartStep Method
[image]

Starts a new step of the test using the specified test step object.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function StartStep( _
ByVal testStep As ITestStep _
) As ITestContext _
Implements ITestCommand.StartStep
C#
public ITestContext StartStep(
ITestStep testStep
)
C++
public:
ITestContext StartStep(
ITestStep testStep
) sealed
J#
public ITestContext StartStep(
ITestStep testStep
)
JScript
public function StartStep(
testStep : ITestStep
) : ITestContext

Parameters

testStep
The test step to start

Return Value

The test context for the test step

Implements

ITestCommand.StartStep

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


ToString Method

ManagedTestCommand.ToString Method
[image]

Returns a description of the test command for debugging purposes.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A description of the test command

See Also

ManagedTestCommand Class
Gallio.Model.Execution Namespace


ObservableTestContextManager Class

ObservableTestContextManager Class
See Also Example Members
[image]

An observable test context manager creates and tracks test contexts that are associated with a ITestExecutionListener for reporting test events back to the test runner.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ObservableTestContextManager
Implements ITestContextManager
C#
public class ObservableTestContextManager : ITestContextManager
C++
ref class ObservableTestContextManager : ITestContextManager
J#
public class ObservableTestContextManager implements ITestContextManager
JScript
public class ObservableTestContextManager extends ITestContextManager

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.ObservableTestContextManager

See Also

ObservableTestContextManager Members
Gallio.Model.Execution Namespace


ObservableTestContextManager Members

ObservableTestContextManager Members
See Also Example Constructors Properties Methods
[image]

An observable test context manager creates and tracks test contexts that are associated with a ITestExecutionListener for reporting test events back to the test runner.

The following tables list the members exposed by ObservableTestContextManager.

Public Constructors

 | Name | Description
Public method | ObservableTestContextManager | Creates a test context manager.
Top

Public Properties

 | Name | Description
Public property | ContextTracker | Gets the test context tracker.
Public property | TestExecutionListener | Gets the test listener to which test events are dispatched.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | StartStep | Starts a test step and returns its associated test context.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


ObservableTestContextManager Constructor

ObservableTestContextManager Constructor
[image]

Creates a test context manager.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal contextTracker As ITestContextTracker, _
ByVal testExecutionListener As ITestExecutionListener _
)
C#
public ObservableTestContextManager(
ITestContextTracker contextTracker,
ITestExecutionListener testExecutionListener
)
C++
public:
ObservableTestContextManager(
ITestContextTracker contextTracker,
ITestExecutionListener testExecutionListener
) sealed
J#
public ObservableTestContextManager(
ITestContextTracker contextTracker,
ITestExecutionListener testExecutionListener
)
JScript
public function ObservableTestContextManager(
contextTracker : ITestContextTracker,
testExecutionListener : ITestExecutionListener
)

Parameters

contextTracker
The test context tracker
testExecutionListener
The test listener to which notifications are dispatched

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if contextTracker or testExecutionListener is null

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


Properties

ObservableTestContextManager Properties
[image]

Public Properties

 | Name | Description
Public property | ContextTracker | Gets the test context tracker.
Public property | TestExecutionListener | Gets the test listener to which test events are dispatched.
Top

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


ContextTracker Property

ObservableTestContextManager.ContextTracker Property
[image]

Gets the test context tracker.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContextTracker As ITestContextTracker _
Implements ITestContextManager.ContextTracker
C#
public ITestContextTracker ContextTracker { get; }
C++
public property ITestContextTracker ContextTracker sealed {
ITestContextTracker get();
}
J#
/** property */
public ITestContextTracker get_ContextTracker();
JScript
public function get ContextTracker() : ITestContextTracker

Implements

ITestContextManager.ContextTracker

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


TestExecutionListener Property

ObservableTestContextManager.TestExecutionListener Property
[image]

Gets the test listener to which test events are dispatched.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestExecutionListener As ITestExecutionListener
C#
public ITestExecutionListener TestExecutionListener { get; }
C++
public property ITestExecutionListener TestExecutionListener sealed {
ITestExecutionListener get();
}
J#
/** property */
public ITestExecutionListener get_TestExecutionListener();
JScript
public function get TestExecutionListener() : ITestExecutionListener

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


Methods

ObservableTestContextManager Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | StartStep | Starts a test step and returns its associated test context.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


StartStep Method

ObservableTestContextManager.StartStep Method
[image]

Starts a test step and returns its associated test context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function StartStep( _
ByVal testStep As ITestStep _
) As ITestContext _
Implements ITestContextManager.StartStep
C#
public ITestContext StartStep(
ITestStep testStep
)
C++
public:
ITestContext StartStep(
ITestStep testStep
) sealed
J#
public ITestContext StartStep(
ITestStep testStep
)
JScript
public function StartStep(
testStep : ITestStep
) : ITestContext

Parameters

testStep
The test step

Return Value

The test context associated with the test step

Implements

ITestContextManager.StartStep

See Also

ObservableTestContextManager Class
Gallio.Model.Execution Namespace


ObservableTestLogWriter Class

ObservableTestLogWriter Class
See Also Example Members
[image]

A log writer that sends messages to a ITestExecutionListener.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ObservableTestLogWriter
Inherits TestLogWriter
C#
public class ObservableTestLogWriter : TestLogWriter
C++
ref class ObservableTestLogWriter : TestLogWriter
J#
public class ObservableTestLogWriter extends TestLogWriter
JScript
public class ObservableTestLogWriter extends TestLogWriter

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Execution.ObservableTestLogWriter

See Also

ObservableTestLogWriter Members
Gallio.Model.Execution Namespace


ObservableTestLogWriter Members

ObservableTestLogWriter Members
See Also Example Constructors Properties Methods
[image]

A log writer that sends messages to a ITestExecutionListener.

The following tables list the members exposed by ObservableTestLogWriter.

Public Constructors

 | Name | Description
Public method | ObservableTestLogWriter | Creates a log writer.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Overridden. Closes the log.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


ObservableTestLogWriter Constructor

ObservableTestLogWriter Constructor
[image]

Creates a log writer.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal stepId As String _
)
C#
public ObservableTestLogWriter(
ITestExecutionListener testExecutionListener,
string stepId
)
C++
public:
ObservableTestLogWriter(
ITestExecutionListener testExecutionListener,
String stepId
) sealed
J#
public ObservableTestLogWriter(
ITestExecutionListener testExecutionListener,
string stepId
)
JScript
public function ObservableTestLogWriter(
testExecutionListener : ITestExecutionListener,
stepId : String
)

Parameters

testExecutionListener
The test listener to which notifications are dispatched
stepId
The step id

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testExecutionListener or stepId is null

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


Methods

ObservableTestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Overridden. Closes the log.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


AttachImpl Method

ObservableTestLogWriter.AttachImpl Method
[image]

Adds an attachment to the log.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AttachImpl( _
ByVal attachment As Attachment _
)
C#
protected override void AttachImpl(
Attachment attachment
)
C++
protected:
virtual void AttachImpl(
Attachment attachment
) override
J#
protected override void AttachImpl(
Attachment attachment
)
JScript
protected override function AttachImpl(
attachment : Attachment
)

Parameters

attachment
The attachment to write, never null

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


CloseImpl Method

ObservableTestLogWriter.CloseImpl Method
[image]

Closes the log.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub CloseImpl()
C#
protected override void CloseImpl()
C++
protected:
virtual void CloseImpl() override
J#
protected override void CloseImpl()
JScript
protected override function CloseImpl()

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


StreamBeginMarkerImpl Method

ObservableTestLogWriter.StreamBeginMarkerImpl Method
[image]

Begins a marked region in a log stream.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginMarkerImpl( _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
C++
protected:
virtual void StreamBeginMarkerImpl(
String streamName,
Marker marker
) override
J#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
JScript
protected override function StreamBeginMarkerImpl(
streamName : String,
marker : Marker
)

Parameters

streamName
The log stream name
marker
The marker

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


StreamBeginSectionImpl Method

ObservableTestLogWriter.StreamBeginSectionImpl Method
[image]

Begins a section in a log stream.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginSectionImpl( _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
C++
protected:
virtual void StreamBeginSectionImpl(
String streamName,
String sectionName
) override
J#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
JScript
protected override function StreamBeginSectionImpl(
streamName : String,
sectionName : String
)

Parameters

streamName
The log stream name
sectionName
The name of the section to begin, never null

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


StreamEmbedImpl Method

ObservableTestLogWriter.StreamEmbedImpl Method
[image]

Embeds an attachment into a log stream.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEmbedImpl( _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
C++
protected:
virtual void StreamEmbedImpl(
String streamName,
String attachmentName
) override
J#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
JScript
protected override function StreamEmbedImpl(
streamName : String,
attachmentName : String
)

Parameters

streamName
The log stream name
attachmentName
The name of the attachment to write, never null

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


StreamEndImpl Method

ObservableTestLogWriter.StreamEndImpl Method
[image]

Ends the current region started with one of the Begin* methods in a log stream.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEndImpl( _
ByVal streamName As String _
)
C#
protected override void StreamEndImpl(
string streamName
)
C++
protected:
virtual void StreamEndImpl(
String streamName
) override
J#
protected override void StreamEndImpl(
string streamName
)
JScript
protected override function StreamEndImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


StreamWriteImpl Method

ObservableTestLogWriter.StreamWriteImpl Method
[image]

Writes a text string to a log stream.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamWriteImpl( _
ByVal streamName As String, _
ByVal text As String _
)
C#
protected override void StreamWriteImpl(
string streamName,
string text
)
C++
protected:
virtual void StreamWriteImpl(
String streamName,
String text
) override
J#
protected override void StreamWriteImpl(
string streamName,
string text
)
JScript
protected override function StreamWriteImpl(
streamName : String,
text : String
)

Parameters

streamName
The log stream name
text
The text to write, never null

See Also

ObservableTestLogWriter Class
Gallio.Model.Execution Namespace


RecursiveTestController Class

RecursiveTestController Class
See Also Example Members
[image]

A test controller that recursively enters the context of each non master-test found. When a master test is found, instantiates the ITestController for it and hands control over to it for the subtree of tests rooted at the master test.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RecursiveTestController
Inherits BaseTestController
C#
public class RecursiveTestController : BaseTestController
C++
ref class RecursiveTestController : BaseTestController
J#
public class RecursiveTestController extends BaseTestController
JScript
public class RecursiveTestController extends BaseTestController

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.BaseTestController
Gallio.Model.Execution.RecursiveTestController

See Also

RecursiveTestController Members
Gallio.Model.Execution Namespace


RecursiveTestController Members

RecursiveTestController Members
See Also Example Constructors Methods
[image]

A test controller that recursively enters the context of each non master-test found. When a master test is found, instantiates the ITestController for it and hands control over to it for the subtree of tests rooted at the master test.

The following tables list the members exposed by RecursiveTestController.

Public Constructors

 | Name | Description
Public method | RecursiveTestController | Initializes a new instance of the RecursiveTestController class.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestController)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RunTests | Runs the tests. (inherited from BaseTestController)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunTestsImpl | Overridden. Implementation of RunTests called after argument validation has taken place.
Top

See Also

RecursiveTestController Class
Gallio.Model.Execution Namespace


RecursiveTestController Constructor

RecursiveTestController Constructor
[image]

Initializes a new instance of the RecursiveTestController class.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RecursiveTestController()
C++
public:
RecursiveTestController() sealed
J#
public RecursiveTestController()
JScript
public function RecursiveTestController()

See Also

RecursiveTestController Class
Gallio.Model.Execution Namespace


Methods

RecursiveTestController Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestController)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RunTests | Runs the tests. (inherited from BaseTestController)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunTestsImpl | Overridden. Implementation of RunTests called after argument validation has taken place.
Top

See Also

RecursiveTestController Class
Gallio.Model.Execution Namespace


RunTestsImpl Method

RecursiveTestController.RunTestsImpl Method
[image]

Implementation of RunTests called after argument validation has taken place.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function RunTestsImpl( _
ByVal rootTestCommand As ITestCommand, _
ByVal parentTestStep As ITestStep, _
ByVal options As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As TestOutcome
C#
protected override TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
C++
protected:
virtual TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
) override
J#
protected override TestOutcome RunTestsImpl(
ITestCommand rootTestCommand,
ITestStep parentTestStep,
TestExecutionOptions options,
IProgressMonitor progressMonitor
)
JScript
protected override function RunTestsImpl(
rootTestCommand : ITestCommand,
parentTestStep : ITestStep,
options : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : TestOutcome

Parameters

rootTestCommand
The root test command, not null
parentTestStep
The parent test step, or null if none
options
The test execution options, not null
progressMonitor
The progress monitor, not null

Return Value

The combined outcome of the root test command

See Also

RecursiveTestController Class
Gallio.Model.Execution Namespace


StubTestContext Class

StubTestContext Class
See Also Example Members
[image]

A stub implementation of ITestContext using a TextualTestLogWriter. Does not fully support nested test steps or other dynamic features.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class StubTestContext
Implements ITestContext, IDisposable
C#
public class StubTestContext : ITestContext, IDisposable
C++
ref class StubTestContext : ITestContext, IDisposable
J#
public class StubTestContext implements ITestContext, IDisposable
JScript
public class StubTestContext extends ITestContext, IDisposable

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.StubTestContext

See Also

StubTestContext Members
Gallio.Model.Execution Namespace
StubTestContextTracker
TextualTestLogWriter


StubTestContext Members

StubTestContext Members
See Also Example Constructors Properties Methods Events
[image]

A stub implementation of ITestContext using a TextualTestLogWriter. Does not fully support nested test steps or other dynamic features.

The following tables list the members exposed by StubTestContext.

Public Constructors

 | Name | Description
Public method | StubTestContext | Creates a stub context.
Top

Public Properties

 | Name | Description
Public property | AssertCount | Gets the current assertion count.
Public property | Data | Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.
Public property | IsFinished | Returns true if the step associated with the context has finished execution and completed all Finishing actions.
Public property | LifecyclePhase | Gets or sets the lifecycle phase the context is in.
Public property | LogWriter | Gets the log writer for the test executing in this context. Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.
Public property | Outcome | Gets the step's outcome or its interim outcome if the test is still running. The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.
Public property | Parent | Gets the parent context or null if this context has no parent.
Public property | TestStep | Gets the test step associated with the context.
Top

Public Methods

 | Name | Description
Public method | AddAssertCount | Adds the specified amount to the assert count atomically.
Public method | AddMetadata | Adds metadata to the step that is running in the context.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FinishStep | Finishes a step and submits its final result.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetInterimOutcome | Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.
Public method | StartChildStep | Overloaded. Starts a child step of the test and returns its context.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

Name Description
Public event Finishing

The Finishing event is raised when the test step is finishing to perform resource reclamation or other updates.

Clients may attach handlers to this event to perform cleanup activities and other tasks as needed. If a new event handler is added and the step has already finished, the handler is immediately invoked.

Top

See Also

StubTestContext Class
Gallio.Model.Execution Namespace
StubTestContextTracker
TextualTestLogWriter


StubTestContext Constructor

StubTestContext Constructor
[image]

Creates a stub context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StubTestContext()
C++
public:
StubTestContext() sealed
J#
public StubTestContext()
JScript
public function StubTestContext()

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


Properties

StubTestContext Properties
[image]

Public Properties

 | Name | Description
Public property | AssertCount | Gets the current assertion count.
Public property | Data | Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.
Public property | IsFinished | Returns true if the step associated with the context has finished execution and completed all Finishing actions.
Public property | LifecyclePhase | Gets or sets the lifecycle phase the context is in.
Public property | LogWriter | Gets the log writer for the test executing in this context. Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.
Public property | Outcome | Gets the step's outcome or its interim outcome if the test is still running. The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.
Public property | Parent | Gets the parent context or null if this context has no parent.
Public property | TestStep | Gets the test step associated with the context.
Top

See Also

StubTestContext Class
Gallio.Model.Execution Namespace
StubTestContextTracker
TextualTestLogWriter


AssertCount Property

StubTestContext.AssertCount Property
[image]

Gets the current assertion count.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssertCount As Integer _
Implements ITestContext.AssertCount
C#
public int AssertCount { get; }
C++
public property int AssertCount sealed {
int get();
}
J#
/** property */
public int get_AssertCount();
JScript
public function get AssertCount() : int

Implements

ITestContext.AssertCount

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


Data Property

StubTestContext.Data Property
[image]

Gets the user data collection associated with the context. It may be used to associate arbitrary key/value pairs with the context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As UserDataCollection _
Implements ITestContext.Data
C#
public UserDataCollection Data { get; }
C++
public property UserDataCollection Data sealed {
UserDataCollection get();
}
J#
/** property */
public UserDataCollection get_Data();
JScript
public function get Data() : UserDataCollection

Implements

ITestContext.Data

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


IsFinished Property

StubTestContext.IsFinished Property
[image]

Returns true if the step associated with the context has finished execution and completed all Finishing actions.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFinished As Boolean _
Implements ITestContext.IsFinished
C#
public bool IsFinished { get; }
C++
public property bool IsFinished sealed {
bool get();
}
J#
/** property */
public bool get_IsFinished();
JScript
public function get IsFinished() : bool

Implements

ITestContext.IsFinished

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


LifecyclePhase Property

StubTestContext.LifecyclePhase Property
[image]

Gets or sets the lifecycle phase the context is in.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property LifecyclePhase As String _
Implements ITestContext.LifecyclePhase
C#
public string LifecyclePhase { get; set; }
C++
public property string LifecyclePhase sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LifecyclePhase();

/** property */
public void set_LifecyclePhase(string value);
JScript
public function get LifecyclePhase() : String

public function set LifecyclePhase(value : String);

Implements

ITestContext.LifecyclePhase

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


LogWriter Property

StubTestContext.LogWriter Property
[image]

Gets the log writer for the test executing in this context.

Each test step gets its own log writer that is distinct from those of other steps. So the log writer returned by this property is particular to the step represented by this test context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LogWriter As TestLogWriter _
Implements ITestContext.LogWriter
C#
public TestLogWriter LogWriter { get; }
C++
public property TestLogWriter LogWriter sealed {
TestLogWriter get();
}
J#
/** property */
public TestLogWriter get_LogWriter();
JScript
public function get LogWriter() : TestLogWriter

Implements

ITestContext.LogWriter

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


Outcome Property

StubTestContext.Outcome Property
[image]

Gets the step's outcome or its interim outcome if the test is still running.

The value of this property is initially Passed but may change over the course of execution to reflect the anticipated outcome of the test. When the test finishes, its outcome is frozen.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outcome As TestOutcome _
Implements ITestContext.Outcome
C#
public TestOutcome Outcome { get; }
C++
public property TestOutcome Outcome sealed {
TestOutcome get();
}
J#
/** property */
public TestOutcome get_Outcome();
JScript
public function get Outcome() : TestOutcome

Implements

ITestContext.Outcome

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


Parent Property

StubTestContext.Parent Property
[image]

Gets the parent context or null if this context has no parent.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As ITestContext _
Implements ITestContext.Parent
C#
public ITestContext Parent { get; }
C++
public property ITestContext Parent sealed {
ITestContext get();
}
J#
/** property */
public ITestContext get_Parent();
JScript
public function get Parent() : ITestContext

Implements

ITestContext.Parent

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


TestStep Property

StubTestContext.TestStep Property
[image]

Gets the test step associated with the context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestStep As ITestStep _
Implements ITestContext.TestStep
C#
public ITestStep TestStep { get; }
C++
public property ITestStep TestStep sealed {
ITestStep get();
}
J#
/** property */
public ITestStep get_TestStep();
JScript
public function get TestStep() : ITestStep

Implements

ITestContext.TestStep

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


Methods

StubTestContext Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssertCount | Adds the specified amount to the assert count atomically.
Public method | AddMetadata | Adds metadata to the step that is running in the context.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FinishStep | Finishes a step and submits its final result.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetInterimOutcome | Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.
Public method | StartChildStep | Overloaded. Starts a child step of the test and returns its context.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StubTestContext Class
Gallio.Model.Execution Namespace
StubTestContextTracker
TextualTestLogWriter


AddAssertCount Method

StubTestContext.AddAssertCount Method
[image]

Adds the specified amount to the assert count atomically.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssertCount( _
ByVal value As Integer _
) _
Implements ITestContext.AddAssertCount
C#
public void AddAssertCount(
int value
)
C++
public:
void AddAssertCount(
int value
) sealed
J#
public void AddAssertCount(
int value
)
JScript
public function AddAssertCount(
value : int
)

Parameters

value
The amount to add to the assert count

Implements

ITestContext.AddAssertCount

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


AddMetadata Method

StubTestContext.AddMetadata Method
[image]

Adds metadata to the step that is running in the context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMetadata( _
ByVal metadataKey As String, _
ByVal metadataValue As String _
) _
Implements ITestContext.AddMetadata
C#
public void AddMetadata(
string metadataKey,
string metadataValue
)
C++
public:
void AddMetadata(
String metadataKey,
String metadataValue
) sealed
J#
public void AddMetadata(
string metadataKey,
string metadataValue
)
JScript
public function AddMetadata(
metadataKey : String,
metadataValue : String
)

Parameters

metadataKey
The metadata key
metadataValue
The metadata value

Implements

ITestContext.AddMetadata

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


Dispose Method

StubTestContext.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


FinishStep Method

StubTestContext.FinishStep Method
[image]

Finishes a step and submits its final result.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub FinishStep( _
ByVal outcome As TestOutcome, _
ByVal actualDuration As Nullable(Of TimeSpan) _
) _
Implements ITestContext.FinishStep
C#
public void FinishStep(
TestOutcome outcome,
Nullable<TimeSpan> actualDuration
)
C++
public:
void FinishStep(
TestOutcome outcome,
Nullable<TimeSpan> actualDuration
) sealed
J#
public void FinishStep(
TestOutcome outcome,
Nullable<TimeSpan> actualDuration
)
JScript
public function FinishStep(
outcome : TestOutcome,
actualDuration : Nullable<TimeSpan>
)

Parameters

outcome
The final test outcome
actualDuration
The actual duration of the step, if null the step monitor will record the duration as the total amount of time since the step monitor was started

Implements

ITestContext.FinishStep

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


SetInterimOutcome Method

StubTestContext.SetInterimOutcome Method
[image]

Sets the step's interim Outcome. The interim outcome is used to communicate the anticipated outcome of the step to later phases of execution.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetInterimOutcome( _
ByVal outcome As TestOutcome _
) _
Implements ITestContext.SetInterimOutcome
C#
public void SetInterimOutcome(
TestOutcome outcome
)
C++
public:
void SetInterimOutcome(
TestOutcome outcome
) sealed
J#
public void SetInterimOutcome(
TestOutcome outcome
)
JScript
public function SetInterimOutcome(
outcome : TestOutcome
)

Implements

ITestContext.SetInterimOutcome

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


StartChildStep Method

StubTestContext.StartChildStep Method

Starts a child step of the test and returns its context.

Overload List

 | Name | Description
Public method | StartChildStep (ITestStep) | Starts a child step of the test and returns its context.
Public method | StartChildStep (String, ICodeElementInfo) |

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


StartChildStep Method (ITestStep)

StubTestContext.StartChildStep Method (ITestStep)
See Also Example
[image]

Starts a child step of the test and returns its context.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function StartChildStep( _
ByVal childStep As ITestStep _
) As ITestContext _
Implements ITestContext.StartChildStep
C#
public ITestContext StartChildStep(
ITestStep childStep
)
C++
public:
ITestContext StartChildStep(
ITestStep childStep
) sealed
J#
public ITestContext StartChildStep(
ITestStep childStep
)
JScript
public function StartChildStep(
childStep : ITestStep
) : ITestContext

Parameters

childStep
The step to start

Return Value

The context of the child step

Implements

ITestContext.StartChildStep

See Also

StubTestContext Class
Gallio.Model.Execution Namespace
StubTestContext.StartChildStep Overload List


StartChildStep Method (String, ICodeElementInfo)

StubTestContext.StartChildStep Method (String, ICodeElementInfo)
See Also Example
[image]

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function StartChildStep( _
ByVal name As String, _
ByVal codeElement As ICodeElementInfo _
) As ITestContext
C#
public ITestContext StartChildStep(
string name,
ICodeElementInfo codeElement
)
C++
public:
ITestContext StartChildStep(
String name,
ICodeElementInfo codeElement
) sealed
J#
public ITestContext StartChildStep(
string name,
ICodeElementInfo codeElement
)
JScript
public function StartChildStep(
name : String,
codeElement : ICodeElementInfo
) : ITestContext

See Also

StubTestContext Class
Gallio.Model.Execution Namespace
StubTestContext.StartChildStep Overload List


Events

StubTestContext Events
[image]

Public Events

Name Description
Public event Finishing

The Finishing event is raised when the test step is finishing to perform resource reclamation or other updates.

Clients may attach handlers to this event to perform cleanup activities and other tasks as needed. If a new event handler is added and the step has already finished, the handler is immediately invoked.

Top

See Also

StubTestContext Class
Gallio.Model.Execution Namespace
StubTestContextTracker
TextualTestLogWriter


Finishing Event

StubTestContext.Finishing Event
[image]

The Finishing event is raised when the test step is finishing to perform resource reclamation or other updates.

Clients may attach handlers to this event to perform cleanup activities and other tasks as needed. If a new event handler is added and the step has already finished, the handler is immediately invoked.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Finishing As EventHandler
C#
public event EventHandler Finishing
C++
public:
virtual event EventHandler Finishing {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Finishing(EventHandler value);

/** event */
public final void remove_Finishing(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestContext.Finishing

See Also

StubTestContext Class
Gallio.Model.Execution Namespace


StubTestContextTracker Class

StubTestContextTracker Class
See Also Example Members
[image]

The stub context tracker is a dummy implementation of ITestContextTracker that is used in situations where the runtime environment has not been initialized.

A typical use of this stub is to support the use of certain framework methods from clients that are not being executed inside of the Gallio test harness such as when test code is run by third party tools.

This class cannot be inherited.
Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StubTestContextTracker
Inherits DefaultTestContextTracker
C#
public sealed class StubTestContextTracker : DefaultTestContextTracker
C++
ref class StubTestContextTracker sealed : DefaultTestContextTracker
J#
public final class StubTestContextTracker extends DefaultTestContextTracker
JScript
public final class StubTestContextTracker extends DefaultTestContextTracker

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.DefaultTestContextTracker
Gallio.Model.Execution.StubTestContextTracker

See Also

StubTestContextTracker Members
Gallio.Model.Execution Namespace


StubTestContextTracker Members

StubTestContextTracker Members
See Also Example Constructors Properties Methods
[image]

The stub context tracker is a dummy implementation of ITestContextTracker that is used in situations where the runtime environment has not been initialized.

A typical use of this stub is to support the use of certain framework methods from clients that are not being executed inside of the Gallio test harness such as when test code is run by third party tools.

This class cannot be inherited.

The following tables list the members exposed by StubTestContextTracker.

Public Constructors

 | Name | Description
Public method | StubTestContextTracker | Creates a stub context tracker.
Top

Public Properties

Name | Description
Public property CurrentContext

Gets the context of the current thread, or null if there is no current context.

A thread's current context is determined in the following manner:

  • If the thread's context stack is not empty then the top-most item of the stack is used. EnterContext pushed a new item on this stack.
  • Otherwise, if the thread has an default context, then it is used. SetThreadDefaultContext sets the default context for a thread.
  • Otherwise, the GlobalContext is used.

Context information may flow across threads by inheritance such that a child thread acquires the context of its parent. However, each thread has its own context stack distinct from that of any other.

(inherited from DefaultTestContextTracker)
Public property | GlobalContext | Gets or the global context of the environment, or null if there is no such context. (inherited from DefaultTestContextTracker)
Top

Public Methods

 | Name | Description
Public method | EnterContext | Enters a context. (inherited from DefaultTestContextTracker)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetThreadDefaultContext | Gets the default context for the specified thread. (inherited from DefaultTestContextTracker)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetThreadDefaultContext | Sets the default context for the specified thread. (inherited from DefaultTestContextTracker)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StubTestContextTracker Class
Gallio.Model.Execution Namespace


StubTestContextTracker Constructor

StubTestContextTracker Constructor
[image]

Creates a stub context tracker.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StubTestContextTracker()
C++
public:
StubTestContextTracker() sealed
J#
public StubTestContextTracker()
JScript
public function StubTestContextTracker()

See Also

StubTestContextTracker Class
Gallio.Model.Execution Namespace


TestCommandFactory Class

TestCommandFactory Class
See Also Example Members
[image]

Creates test commands. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestCommandFactory
C#
public static class TestCommandFactory
C++
ref class TestCommandFactory abstract sealed
J#
public final class TestCommandFactory
JScript
public class TestCommandFactory

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.TestCommandFactory

See Also

TestCommandFactory Members
Gallio.Model.Execution Namespace


TestCommandFactory Members

TestCommandFactory Members
See Also Example Methods
[image]

Creates test commands. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestCommandFactory.

Public Methods

Name | Description
BuildCommands | Recursively builds a tree of test commands.
Top

See Also

TestCommandFactory Class
Gallio.Model.Execution Namespace


Methods

TestCommandFactory Methods
[image]

Public Methods

Name | Description
BuildCommands | Recursively builds a tree of test commands.
Top

See Also

TestCommandFactory Class
Gallio.Model.Execution Namespace


BuildCommands Method

TestCommandFactory.BuildCommands Method
[image]

Recursively builds a tree of test commands.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BuildCommands( _
ByVal testModel As TestModel, _
ByVal filterSet As FilterSet(Of ITest), _
ByVal exactFilter As Boolean, _
ByVal contextManager As ITestContextManager _
) As ITestCommand
C#
public static ITestCommand BuildCommands(
TestModel testModel,
FilterSet<ITest> filterSet,
bool exactFilter,
ITestContextManager contextManager
)
C++
public:
static ITestCommand BuildCommands(
TestModel testModel,
FilterSet<ITest> filterSet,
bool exactFilter,
ITestContextManager contextManager
)
J#
public static ITestCommand BuildCommands(
TestModel testModel,
FilterSet<ITest> filterSet,
bool exactFilter,
ITestContextManager contextManager
)
JScript
public static function BuildCommands(
testModel : TestModel,
filterSet : FilterSet<ITest>,
exactFilter : bool,
contextManager : ITestContextManager
) : ITestCommand

Parameters

testModel
The test model
filterSet
The filter set for the test model
exactFilter
If true, only the specified tests are included, otherwise children of the selected tests are automatically included
contextManager
The test context manager

Return Value

The root test command or null if none of the tests in the subtree including testModel matched the filter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testModel, filterSet or contextManager is null
ModelException | Thrown if an invalid test dependency is found

See Also

TestCommandFactory Class
Gallio.Model.Execution Namespace


TestContextTrackerAccessor Class

TestContextTrackerAccessor Class
See Also Example Members
[image]

Static service locator for ITestContextTracker. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestContextTrackerAccessor
C#
public static class TestContextTrackerAccessor
C++
ref class TestContextTrackerAccessor abstract sealed
J#
public final class TestContextTrackerAccessor
JScript
public class TestContextTrackerAccessor

Remarks

Handles the case where the runtime is not initialized by returning a StubTestContextTracker.

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.TestContextTrackerAccessor

See Also

TestContextTrackerAccessor Members
Gallio.Model.Execution Namespace


TestContextTrackerAccessor Members

TestContextTrackerAccessor Members
See Also Example Properties
[image]

Static service locator for ITestContextTracker. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestContextTrackerAccessor.

Public Properties

Name | Description
Instance | Gets the global test context tracker singleton.
Top

See Also

TestContextTrackerAccessor Class
Gallio.Model.Execution Namespace


Properties

TestContextTrackerAccessor Properties
[image]

Public Properties

Name | Description
Instance | Gets the global test context tracker singleton.
Top

See Also

TestContextTrackerAccessor Class
Gallio.Model.Execution Namespace


Instance Property

TestContextTrackerAccessor.Instance Property
[image]

Gets the global test context tracker singleton.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As ITestContextTracker
C#
public static ITestContextTracker Instance { get; }
C++
public static property ITestContextTracker Instance {
ITestContextTracker get();
}
J#
/** property */
public ITestContextTracker get_Instance();
JScript
public function get Instance() : ITestContextTracker

See Also

TestContextTrackerAccessor Class
Gallio.Model.Execution Namespace


TestExecutionOptions Class

TestExecutionOptions Class
See Also Example Members
[image]

Provides options that control how test execution occurs. This class cannot be inherited.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class TestExecutionOptions
C#
[SerializableAttribute]
public sealed class TestExecutionOptions
C++
[SerializableAttribute]
ref class TestExecutionOptions sealed
J#
/** @attribute SerializableAttribute() */
public final class TestExecutionOptions
JScript
public
SerializableAttribute
final class TestExecutionOptions

Inheritance Hierarchy

System.Object
Gallio.Model.Execution.TestExecutionOptions

See Also

TestExecutionOptions Members
Gallio.Model.Execution Namespace


TestExecutionOptions Members

TestExecutionOptions Members
See Also Example Constructors Properties Methods
[image]

Provides options that control how test execution occurs. This class cannot be inherited.

The following tables list the members exposed by TestExecutionOptions.

Public Constructors

 | Name | Description
Public method | TestExecutionOptions | Initializes a new instance of the TestExecutionOptions class.
Top

Public Properties

 | Name | Description
Public property | ExactFilter | Gets or sets whether the filter exactly specifies all tests to select. If false, then children of the selected tests are also included.
Public property | FilterSet | Gets or sets the filter set.
Public property | SingleThreaded | Gets or sets whether to run tests within a single thread. This ensures that the tests will run on the same thread as the initial call to the test harness (unless the test framework itself spawns any new threads).
Public property | SkipDynamicTests | Gets or sets whether to skip running tests that use dynamic data items. This flag can be useful in combination with SkipTestExecution to enumerate non-dynamic tests only.
Public property | SkipTestExecution | Gets or sets whether to skip the execution of tests. The test runner will go through most of the motions of running tests but will skip the actual execution phase. This option can be used to enumerate data-driven test steps without running them. It can also be used to verify that the execution environment is sane without doing most of the work of running the tests.
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


TestExecutionOptions Constructor

TestExecutionOptions Constructor
[image]

Initializes a new instance of the TestExecutionOptions class.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestExecutionOptions()
C++
public:
TestExecutionOptions() sealed
J#
public TestExecutionOptions()
JScript
public function TestExecutionOptions()

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


Properties

TestExecutionOptions Properties
[image]

Public Properties

 | Name | Description
Public property | ExactFilter | Gets or sets whether the filter exactly specifies all tests to select. If false, then children of the selected tests are also included.
Public property | FilterSet | Gets or sets the filter set.
Public property | SingleThreaded | Gets or sets whether to run tests within a single thread. This ensures that the tests will run on the same thread as the initial call to the test harness (unless the test framework itself spawns any new threads).
Public property | SkipDynamicTests | Gets or sets whether to skip running tests that use dynamic data items. This flag can be useful in combination with SkipTestExecution to enumerate non-dynamic tests only.
Public property | SkipTestExecution | Gets or sets whether to skip the execution of tests. The test runner will go through most of the motions of running tests but will skip the actual execution phase. This option can be used to enumerate data-driven test steps without running them. It can also be used to verify that the execution environment is sane without doing most of the work of running the tests.
Top

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


ExactFilter Property

TestExecutionOptions.ExactFilter Property
[image]

Gets or sets whether the filter exactly specifies all tests to select. If false, then children of the selected tests are also included.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ExactFilter As Boolean
C#
public bool ExactFilter { get; set; }
C++
public property bool ExactFilter sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ExactFilter();

/** property */
public void set_ExactFilter(bool value);
JScript
public function get ExactFilter() : bool

public function set ExactFilter(value : bool);

Property Value

Defaults to false.

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


FilterSet Property

TestExecutionOptions.FilterSet Property
[image]

Gets or sets the filter set.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property FilterSet As FilterSet(Of ITest)
C#
public FilterSet<ITest> FilterSet { get; set; }
C++
public property FilterSet<ITest> FilterSet sealed {
FilterSet<ITest> get();
void set(FilterSet<ITest> value);
}
J#
/** property */
public FilterSet<ITest> get_FilterSet();

/** property */
public void set_FilterSet(FilterSet<ITest> value);
JScript
public function get FilterSet() : FilterSet<ITest>

public function set FilterSet(value : FilterSet<ITest>);

Property Value

Defaults to an empty filter set.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


SingleThreaded Property

TestExecutionOptions.SingleThreaded Property
[image]

Gets or sets whether to run tests within a single thread. This ensures that the tests will run on the same thread as the initial call to the test harness (unless the test framework itself spawns any new threads).

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property SingleThreaded As Boolean
C#
public bool SingleThreaded { get; set; }
C++
public property bool SingleThreaded sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SingleThreaded();

/** property */
public void set_SingleThreaded(bool value);
JScript
public function get SingleThreaded() : bool

public function set SingleThreaded(value : bool);

Property Value

Defaults to false.

Remarks

When tests are run single-threaded, the test harness will no longer be able to guarantee that the default apartment state is STA.

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


SkipDynamicTests Property

TestExecutionOptions.SkipDynamicTests Property
[image]

Gets or sets whether to skip running tests that use dynamic data items.

This flag can be useful in combination with SkipTestExecution to enumerate non-dynamic tests only.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property SkipDynamicTests As Boolean
C#
public bool SkipDynamicTests { get; set; }
C++
public property bool SkipDynamicTests sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SkipDynamicTests();

/** property */
public void set_SkipDynamicTests(bool value);
JScript
public function get SkipDynamicTests() : bool

public function set SkipDynamicTests(value : bool);

Property Value

Defaults to false

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


SkipTestExecution Property

TestExecutionOptions.SkipTestExecution Property
[image]

Gets or sets whether to skip the execution of tests.

The test runner will go through most of the motions of running tests but will skip the actual execution phase. This option can be used to enumerate data-driven test steps without running them. It can also be used to verify that the execution environment is sane without doing most of the work of running the tests.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property SkipTestExecution As Boolean
C#
public bool SkipTestExecution { get; set; }
C++
public property bool SkipTestExecution sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SkipTestExecution();

/** property */
public void set_SkipTestExecution(bool value);
JScript
public function get SkipTestExecution() : bool

public function set SkipTestExecution(value : bool);

Property Value

Defaults to false

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


Methods

TestExecutionOptions Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


Copy Method

TestExecutionOptions.Copy Method
[image]

Creates a copy of the options.

Namespace: Gallio.Model.Execution
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As TestExecutionOptions
C#
public TestExecutionOptions Copy()
C++
public:
TestExecutionOptions Copy() sealed
J#
public TestExecutionOptions Copy()
JScript
public function Copy() : TestExecutionOptions

Return Value

The copy

See Also

TestExecutionOptions Class
Gallio.Model.Execution Namespace


Gallio.Model.Filters

Gallio.Model.Filters Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AndFilter | A filter combinator that matches a value when all of its constituent filters match the value.
Public class | AnyFilter | A filter that matches anything and always returns true.
Public class | AssemblyFilter | A filter that matches objects whose CodeElement matches the specified assembly name filter.
Public class | EqualityFilter | An equality filter compares values for strict equality. This class cannot be inherited.
Public class | Filter | A filter is a serializable predicate. The framework uses filters to select among tests discovered through the process of test enumeration. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | FilterFormatter | Formats filters in such manner that they can be reparsed using the FilterParser.
Public class | FilterParseException | The type of exception thrown when a filter cannot be parsed.
Public class | FilterParser | A filter parser constructs filters from its textual representation as a filter expression.
Public class | FilterRule | Specifies an inclusion or exclusion filter rule. This class cannot be inherited.
Public class | FilterSet | A filterset combines zero or more filters as a sequence of inclusion and exclusion rules. This class cannot be inherited.
Public class | FilterUtils | Provides utilities for manipulating filters. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | IdFilter | A filter that matches objects whose Id matches the specified id filter.
Public class | MemberFilter | A filter that matches objects whose CodeElement matches the specified member name filter. This filter should normally be used together with a TypeFilter to ensure the accuracy of the member match.
Public class | MetadataFilter | A filter that matches objects whose Metadata has a key with a value that matches the value filter.
Public class | ModelComponentFilterFactory | Builds filters for ITestComponent objects.
Public class | NameFilter | A filter that matches objects whose Name matches the specified name filter.
Public class | NamespaceFilter | A filter that matches objects whose CodeElement matches the specified namespace name.
Public class | NoneFilter | A filter that matches nothing and always returns false.
Public class | NotFilter | A filter combinator that is the negation of another filter.
Public class | OrFilter | A filter combinator that matches a value when at least one of its constituent filters matches the value.
Public class | PropertyFilter | Abstract base class for filters that encapsulate a rule for selecting some property of an object to be compared against a string value filter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | RegexFilter | A regex filter matches strings against a given Regex. Null string values are converted to empty strings for regex evaluation purposes. This class cannot be inherited.
Public class | TypeFilter | A filter that matches objects whose CodeElement matches the specified type name.

Interfaces

 | Interface | Description
Public interface | IFilterFactory | Creates filters of a given type based on a specification that consists of a filter key and a rule for matching values.
Public interface | IFilterVisitor | Visits the structure of filters.

Enumerations

 | Enumeration | Description
Public enumeration | FilterRuleType | Specifies whether a filter rule is an inclusion or exclusion rule.
Public enumeration | FilterSetResult | Specifies whether a filter set includes, excludes or does not match a particular item.


AndFilter Generic Class

AndFilter Generic Class
See Also Example Members
[image]

A filter combinator that matches a value when all of its constituent filters match the value.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AndFilter(Of T)
Inherits Filter(Of T)
C#
[SerializableAttribute]
public class AndFilter<T> : Filter<T>
C++
[SerializableAttribute]
ref class AndFilter<T> : Filter<T>
J#
/** @attribute SerializableAttribute() */
public class AndFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.AndFilter<T>

See Also

AndFilter<T> Members
Gallio.Model.Filters Namespace


AndFilter<T> Members

AndFilter Members
See Also Example Constructors Properties Methods
[image]

A filter combinator that matches a value when all of its constituent filters match the value.

The following tables list the members exposed by AndFilter<T>.

Public Constructors

 | Name | Description
Public method | AndFilter | Creates an AND-filter.
Top

Public Properties

 | Name | Description
Public property | Filters | Gets the filters that must jointly be matched. If the list is empty, the filter matches everything.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


AndFilter Constructor

AndFilter Constructor
[image]

Creates an AND-filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal filters As ICollection(Of Filter(Of T)) _
)
C#
public AndFilter(
ICollection<Filter<T>> filters
)
C++
public:
AndFilter(
ICollection<Filter<T>> filters
) sealed
J#
public AndFilter(
ICollection<Filter<T>> filters
)
JScript
JScript does not support generic types and methods.

Parameters

filters
The filters that must all jointly be matched. If the list is empty, the filter matches everything.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if filters is null

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


Properties

AndFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Filters | Gets the filters that must jointly be matched. If the list is empty, the filter matches everything.
Top

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


Filters Property

AndFilter.Filters Property
[image]

Gets the filters that must jointly be matched. If the list is empty, the filter matches everything.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter(Of T))
C#
public IList<Filter<T>> Filters { get; }
C++
public property IList<Filter<T>> Filters sealed {
IList<Filter<T>> get();
}
J#
/** property */
public IList<Filter<T>> get_Filters();
JScript
JScript does not support generic types and methods.

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


Methods

AndFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

AndFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

AndFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

AndFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

AndFilter<T> Class
Gallio.Model.Filters Namespace


AnyFilter Generic Class

AnyFilter Generic Class
See Also Example Members
[image]

A filter that matches anything and always returns true.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AnyFilter(Of T)
Inherits Filter(Of T)
C#
[SerializableAttribute]
public class AnyFilter<T> : Filter<T>
C++
[SerializableAttribute]
ref class AnyFilter<T> : Filter<T>
J#
/** @attribute SerializableAttribute() */
public class AnyFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.AnyFilter<T>

See Also

AnyFilter<T> Members
Gallio.Model.Filters Namespace


AnyFilter<T> Members

AnyFilter Members
See Also Example Constructors Methods
[image]

A filter that matches anything and always returns true.

The following tables list the members exposed by AnyFilter<T>.

Public Constructors

 | Name | Description
Public method | AnyFilter | Initializes a new instance of the AnyFilter class.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AnyFilter<T> Class
Gallio.Model.Filters Namespace


AnyFilter Constructor

AnyFilter Constructor
[image]

Initializes a new instance of the AnyFilter class.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AnyFilter()
C++
public:
AnyFilter() sealed
J#
public AnyFilter()
JScript
JScript does not support generic types and methods.

See Also

AnyFilter<T> Class
Gallio.Model.Filters Namespace


Methods

AnyFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AnyFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

AnyFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

AnyFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

AnyFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

AnyFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

AnyFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

AnyFilter<T> Class
Gallio.Model.Filters Namespace


AssemblyFilter Generic Class

AssemblyFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose CodeElement matches the specified assembly name filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class AssemblyFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class AssemblyFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class AssemblyFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class AssemblyFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.AssemblyFilter<T>

See Also

AssemblyFilter<T> Members
Gallio.Model.Filters Namespace


AssemblyFilter<T> Members

AssemblyFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose CodeElement matches the specified assembly name filter.

The following tables list the members exposed by AssemblyFilter<T>.

Public Constructors

 | Name | Description
Public method | AssemblyFilter | Creates an assembly filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


AssemblyFilter Constructor

AssemblyFilter Constructor
[image]

Creates an assembly filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyNameFilter As Filter(Of String) _
)
C#
public AssemblyFilter(
Filter<string> assemblyNameFilter
)
C++
public:
AssemblyFilter(
Filter<string> assemblyNameFilter
) sealed
J#
public AssemblyFilter(
Filter<string> assemblyNameFilter
)
JScript
JScript does not support generic types and methods.

Parameters

assemblyNameFilter
A filter for the assembly name that is used to match one of the following values:
  • Full name as returned by FullName
  • Simple name (aka. partial name) as returned by Name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyNameFilter is null

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


Properties

AssemblyFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

AssemblyFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


Methods

AssemblyFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

AssemblyFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

AssemblyFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

AssemblyFilter<T> Class
Gallio.Model.Filters Namespace


EqualityFilter Generic Class

EqualityFilter Generic Class
See Also Example Members
[image]

An equality filter compares values for strict equality. This class cannot be inherited.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class EqualityFilter(Of T As {IEquatable(Of T), Class})
Inherits Filter(Of T)
C#
[SerializableAttribute]
public sealed class EqualityFilter<T> : Filter<T> where T : IEquatable<T>, class
C++
[SerializableAttribute]
ref class EqualityFilter<T> sealed : Filter<T> where T : IEquatable<T>, class
J#
/** @attribute SerializableAttribute() */
public final class EqualityFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.EqualityFilter<T>

See Also

EqualityFilter<T> Members
Gallio.Model.Filters Namespace


EqualityFilter<T> Members

EqualityFilter Members
See Also Example Constructors Properties Methods
[image]

An equality filter compares values for strict equality. This class cannot be inherited.

The following tables list the members exposed by EqualityFilter<T>.

Public Constructors

 | Name | Description
Public method | EqualityFilter | Creates an equality filter.
Top

Public Properties

 | Name | Description
Public property | Comparand | Gets the value to compare for equality.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


EqualityFilter Constructor

EqualityFilter Constructor
[image]

Creates an equality filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal comparand As T _
)
C#
public EqualityFilter(
T comparand
)
C++
public:
EqualityFilter(
T comparand
) sealed
J#
public EqualityFilter(
T comparand
)
JScript
JScript does not support generic types and methods.

Parameters

comparand
The value to compare for equality

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


Properties

EqualityFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Comparand | Gets the value to compare for equality.
Top

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


Comparand Property

EqualityFilter.Comparand Property
[image]

Gets the value to compare for equality.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Comparand
C#
public T Comparand { get; }
C++
public property T Comparand sealed {
T get();
}
J#
/** property */
public T get_Comparand();
JScript
JScript does not support generic types and methods.

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


Methods

EqualityFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

EqualityFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

EqualityFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

EqualityFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

EqualityFilter<T> Class
Gallio.Model.Filters Namespace


Filter Generic Class

Filter Generic Class
See Also Example Members
[image]

A filter is a serializable predicate. The framework uses filters to select among tests discovered through the process of test enumeration. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class Filter(Of T)
C#
[SerializableAttribute]
public abstract class Filter<T>
C++
[SerializableAttribute]
ref class Filter<T> abstract
J#
/** @attribute SerializableAttribute() */
public class Filter<T>
JScript
JScript does not support generic types and methods.

Remarks

Filters must be serializable objects defined in the framework assembly or in plugins. The reason is that filter definitions may need to be transferred across AppDomains so the filter's concrete type must be known to the recipient. Filters do not implement MarshalByRefObject because there is no guarantee that a valid remoting context will exist in which to carry out the operation. So, if you need a new filter type put it in a plugin.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Derived types

See Also

Filter<T> Members
Gallio.Model.Filters Namespace


Filter<T> Members

Filter Members
See Also Example Constructors Methods
[image]

A filter is a serializable predicate. The framework uses filters to select among tests discovered through the process of test enumeration. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Filter<T>.

Protected Constructors

 | Name | Description
Family method | Filter | Initializes a new instance of the Filter class.
Top

Public Methods

 | Name | Description
Public method | Accept | Accepts a visitor and performs double-dispatch.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Determines whether the filter matches the value.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


Filter Constructor

Filter Constructor
[image]

Initializes a new instance of the Filter class.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected Filter()
C++
protected:
Filter() sealed
J#
protected Filter()
JScript
JScript does not support generic types and methods.

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


Methods

Filter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Accepts a visitor and performs double-dispatch.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Determines whether the filter matches the value.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


Accept Method

Filter.Accept Method
[image]

Accepts a visitor and performs double-dispatch.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public abstract void Accept(
IFilterVisitor visitor
)
C++
public:
void Accept(
IFilterVisitor visitor
) abstract
J#
public abstract void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

Parameters

visitor
The visitor, never null

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

Filter.IsMatch Method
[image]

Determines whether the filter matches the value.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public abstract bool IsMatch(
T value
)
C++
public:
bool IsMatch(
T value
) abstract
J#
public abstract bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value to consider, never null

Return Value

True if the filter matches the value

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


ToFilterExpr Method

Filter.ToFilterExpr Method
[image]

Formats the filter to a string suitable for parsing by FilterParser.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToFilterExpr() As String
C#
public string ToFilterExpr()
C++
public:
String ToFilterExpr() sealed
J#
public string ToFilterExpr()
JScript
JScript does not support generic types and methods.

Return Value

The formatted filter expression

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


FilterFormatter Class

FilterFormatter Class
See Also Example Members
[image]

Formats filters in such manner that they can be reparsed using the FilterParser.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FilterFormatter
Implements IFilterVisitor
C#
public class FilterFormatter : IFilterVisitor
C++
ref class FilterFormatter : IFilterVisitor
J#
public class FilterFormatter implements IFilterVisitor
JScript
public class FilterFormatter extends IFilterVisitor

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.FilterFormatter

See Also

FilterFormatter Members
Gallio.Model.Filters Namespace
FilterParser


FilterFormatter Members

FilterFormatter Members
See Also Example Constructors Methods
[image]

Formats filters in such manner that they can be reparsed using the FilterParser.

The following tables list the members exposed by FilterFormatter.

Public Constructors

 | Name | Description
Public method | FilterFormatter | Initializes a new instance of the FilterFormatter class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Gets the formatted filter contents.
Public method | VisitAndFilter | Visits a AndFilter.
Public method | VisitAnyFilter | Visits a AnyFilter.
Public method | VisitEqualityFilter | Visits a EqualityFilter.
Public method | VisitNoneFilter | Visits a NoneFilter.
Public method | VisitNotFilter | Visits a NotFilter.
Public method | VisitOrFilter | Visits a OrFilter.
Public method | VisitPropertyFilter | Visits a PropertyFilter.
Public method | VisitRegexFilter | Visits a RegexFilter.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace
FilterParser


FilterFormatter Constructor

FilterFormatter Constructor
[image]

Initializes a new instance of the FilterFormatter class.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FilterFormatter()
C++
public:
FilterFormatter() sealed
J#
public FilterFormatter()
JScript
public function FilterFormatter()

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


Methods

FilterFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Gets the formatted filter contents.
Public method | VisitAndFilter | Visits a AndFilter.
Public method | VisitAnyFilter | Visits a AnyFilter.
Public method | VisitEqualityFilter | Visits a EqualityFilter.
Public method | VisitNoneFilter | Visits a NoneFilter.
Public method | VisitNotFilter | Visits a NotFilter.
Public method | VisitOrFilter | Visits a OrFilter.
Public method | VisitPropertyFilter | Visits a PropertyFilter.
Public method | VisitRegexFilter | Visits a RegexFilter.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace
FilterParser


ToString Method

FilterFormatter.ToString Method
[image]

Gets the formatted filter contents.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted filter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitAndFilter Generic Method

FilterFormatter.VisitAndFilter Generic Method
[image]

Visits a AndFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitAndFilter(Of T)( _
ByVal filter As AndFilter(Of T) _
) _
Implements IFilterVisitor.VisitAndFilter
C#
public void VisitAndFilter<T>(
AndFilter<T> filter
)
C++
public:
void VisitAndFilter<T>(
AndFilter<T> filter
) sealed
J#
public void VisitAndFilter<T>(
AndFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitAndFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitAnyFilter Generic Method

FilterFormatter.VisitAnyFilter Generic Method
[image]

Visits a AnyFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitAnyFilter(Of T)( _
ByVal filter As AnyFilter(Of T) _
) _
Implements IFilterVisitor.VisitAnyFilter
C#
public void VisitAnyFilter<T>(
AnyFilter<T> filter
)
C++
public:
void VisitAnyFilter<T>(
AnyFilter<T> filter
) sealed
J#
public void VisitAnyFilter<T>(
AnyFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitAnyFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitEqualityFilter Generic Method

FilterFormatter.VisitEqualityFilter Generic Method
[image]

Visits a EqualityFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitEqualityFilter(Of T As {IEquatable(Of T), Class})( _
ByVal filter As EqualityFilter(Of T) _
) _
Implements IFilterVisitor.VisitEqualityFilter
C#
public void VisitEqualityFilter<T>(
EqualityFilter<T> filter
) where T : IEquatable<T>, class
C++
public:
void VisitEqualityFilter<T>(
EqualityFilter<T> filter
) sealed
J#
public void VisitEqualityFilter<T>(
EqualityFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitEqualityFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitNoneFilter Generic Method

FilterFormatter.VisitNoneFilter Generic Method
[image]

Visits a NoneFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitNoneFilter(Of T)( _
ByVal filter As NoneFilter(Of T) _
) _
Implements IFilterVisitor.VisitNoneFilter
C#
public void VisitNoneFilter<T>(
NoneFilter<T> filter
)
C++
public:
void VisitNoneFilter<T>(
NoneFilter<T> filter
) sealed
J#
public void VisitNoneFilter<T>(
NoneFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitNoneFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitNotFilter Generic Method

FilterFormatter.VisitNotFilter Generic Method
[image]

Visits a NotFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitNotFilter(Of T)( _
ByVal filter As NotFilter(Of T) _
) _
Implements IFilterVisitor.VisitNotFilter
C#
public void VisitNotFilter<T>(
NotFilter<T> filter
)
C++
public:
void VisitNotFilter<T>(
NotFilter<T> filter
) sealed
J#
public void VisitNotFilter<T>(
NotFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitNotFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitOrFilter Generic Method

FilterFormatter.VisitOrFilter Generic Method
[image]

Visits a OrFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitOrFilter(Of T)( _
ByVal filter As OrFilter(Of T) _
) _
Implements IFilterVisitor.VisitOrFilter
C#
public void VisitOrFilter<T>(
OrFilter<T> filter
)
C++
public:
void VisitOrFilter<T>(
OrFilter<T> filter
) sealed
J#
public void VisitOrFilter<T>(
OrFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitOrFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitPropertyFilter Generic Method

FilterFormatter.VisitPropertyFilter Generic Method
[image]

Visits a PropertyFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitPropertyFilter(Of T)( _
ByVal filter As PropertyFilter(Of T) _
) _
Implements IFilterVisitor.VisitPropertyFilter
C#
public void VisitPropertyFilter<T>(
PropertyFilter<T> filter
)
C++
public:
void VisitPropertyFilter<T>(
PropertyFilter<T> filter
) sealed
J#
public void VisitPropertyFilter<T>(
PropertyFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

Implements

IFilterVisitor.VisitPropertyFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


VisitRegexFilter Method

FilterFormatter.VisitRegexFilter Method
[image]

Visits a RegexFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub VisitRegexFilter( _
ByVal filter As RegexFilter _
) _
Implements IFilterVisitor.VisitRegexFilter
C#
public void VisitRegexFilter(
RegexFilter filter
)
C++
public:
void VisitRegexFilter(
RegexFilter filter
) sealed
J#
public void VisitRegexFilter(
RegexFilter filter
)
JScript
public function VisitRegexFilter(
filter : RegexFilter
)

Parameters

filter
The filter

Implements

IFilterVisitor.VisitRegexFilter

See Also

FilterFormatter Class
Gallio.Model.Filters Namespace


FilterParseException Class

FilterParseException Class
See Also Example Members
[image]

The type of exception thrown when a filter cannot be parsed.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class FilterParseException
Inherits Exception
C#
[SerializableAttribute]
public class FilterParseException : Exception
C++
[SerializableAttribute]
ref class FilterParseException : Exception
J#
/** @attribute SerializableAttribute() */
public class FilterParseException extends Exception
JScript
public
SerializableAttribute
class FilterParseException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Model.Filters.FilterParseException

See Also

FilterParseException Members
Gallio.Model.Filters Namespace


FilterParseException Members

FilterParseException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when a filter cannot be parsed.

The following tables list the members exposed by FilterParseException.

Public Constructors

Name | Description
FilterParseException | Overloaded. Initializes a new instance of the FilterParseException class.
Top

Protected Constructors

Name | Description
FilterParseException | Overloaded. Initializes a new instance of the FilterParseException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
FilterParseException | Overloaded. Initializes a new instance of the FilterParseException class.
Top

See Also

FilterParseException Class
Gallio.Model.Filters Namespace


FilterParseException Constructor

FilterParseException Constructor

Initializes a new instance of the FilterParseException class.

Overload List

 | Name | Description
Public method | FilterParseException | Creates an exception.
Family method | FilterParseException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | FilterParseException (String) | Creates an exception.
Public method | FilterParseException (String, Exception) | Creates an exception.

See Also

FilterParseException Class
Gallio.Model.Filters Namespace


FilterParseException Constructor ()

FilterParseException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FilterParseException()
C++
public:
FilterParseException() sealed
J#
public FilterParseException()
JScript
public function FilterParseException()

See Also

FilterParseException Class
Gallio.Model.Filters Namespace
FilterParseException Constructor Overload List


FilterParseException Constructor (SerializationInfo, StreamingContext)

FilterParseException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected FilterParseException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
FilterParseException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected FilterParseException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function FilterParseException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

FilterParseException Class
Gallio.Model.Filters Namespace
FilterParseException Constructor Overload List


FilterParseException Constructor (String)

FilterParseException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public FilterParseException(
string message
)
C++
public:
FilterParseException(
String message
) sealed
J#
public FilterParseException(
string message
)
JScript
public function FilterParseException(
message : String
)

Parameters

message
The message

See Also

FilterParseException Class
Gallio.Model.Filters Namespace
FilterParseException Constructor Overload List


FilterParseException Constructor (String, Exception)

FilterParseException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public FilterParseException(
string message,
Exception innerException
)
C++
public:
FilterParseException(
String message,
Exception innerException
) sealed
J#
public FilterParseException(
string message,
Exception innerException
)
JScript
public function FilterParseException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

FilterParseException Class
Gallio.Model.Filters Namespace
FilterParseException Constructor Overload List


FilterParser Generic Class

FilterParser Generic Class
See Also Example Members
[image]

A filter parser constructs filters from its textual representation as a filter expression.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FilterParser(Of T)
C#
public class FilterParser<T>
C++
ref class FilterParser<T>
J#
public class FilterParser<T>
JScript
JScript does not support generic types and methods.

Example

Assuming the following fixtures have been defined:

Copy Code
      [TestFixture]
      [Category("UnitTest")]
      [Author("AlbertEinstein")]
      public class Fixture1
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

      [TestFixture]
      [Category("IntegrationTest")]
      public class Fixture2
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

The following filters could be applied:

  • Type: Fixture1 - All the tests within Fixture1 will be run.
  • Member: Test1 - Only Fixture1.Test1 and Fixture2.Test1 will be run.
  • Type: Fixture1, Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1 or Type:Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1, Fixture2 and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • Type:/Fixture*/ and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • AuthorName:AlbertEinstein - All the tests within Fixture1 will be run because its author attribute is set to "AlbertEinstein".
  • Category: IntegrationTest - All the tests within Fixture2 will be run because its category attribute is set to "IntegrationTest".
  • ("Type": 'Fixture1' and "Member":/Test*/) or (Type : Fixture2 and Member: /Test*/) - All the tests will be run. This example also shows that you can enclose key and values with quotation marks, and group expressions with parentheses.
  • exclude AuthorName: AlbertEinstein - All the tests within Fixture2 will be run because its author attribute is not set to "AlbertEinstein".
  • exclude Type: Fixture2 include Member: Test2 - Only Fixture1.Test2 will be run because Fixture2 was excluded from consideration before the inclusion rule was applied.

Remarks

The filter grammar is defined as follows:

Copy Code
     INCLUDE          ::= "include"              # Not case-sensitive
     EXCLUDE          ::= "exclude"              # Not case-sensitive

     OR               ::= "or"                   # Not case-sensitive
     AND              ::= "and"                  # Not case-sensitive
     NOT              ::= "not"                  # Not case-sensitive

     <unquotedWord>   ::= [^:,*()/\"']+

     <quotedWord>     ::= '"' .* '"'             # String delimited by double quotation marks
                      | "'" .* "'"               # String delimited by single quotation marks

     <word>           ::= <unquotedWord>
                      | <quotedWord>

     <regexWord>      ::= "/" .* "/"             # Regular expression
                      | "/" .* "/i"              # Case-insensitive regular expression

     <key>            ::= <word>

     <value>          ::= <word>                 # Value specified by exact string
                      | <regexWord>              # Value specified by regular expression

     <matchSequence>  ::= <value> (',' <value>)* # One or more comma-separated values

     <filterExpr>     ::= "*"                    # "Any"
                      | <key> ":" matchSeq>
                      | <filterExpr> OR filterExpr>   # Combine filter expressions with OR
                      | <filterExpr> AND filterExpr>  # Combine filter expressions with AND
                      | NOT <filterExpr>         # Negate filter expression
                      | "(" <filterExpr> ")"     # Grouping filter expression

     <filterRule>     ::= <filterExpr>           # Inclusion rule (default case)
                      | INCLUDE <filterExpr>     # Inclusion rule
                      | EXCLUDE <filterExpr>     # Exclusion rule

     <filterSet>      ::= <filterRule>           # Filter set consists of at least one filter rule.
                      | <filterRule> <filterSet> # But may be a sequence of rules.

  • By default this property takes the value "*", which means the "Any" filter will be applied.
  • The operator precedence is, from highest to lowest: NOT, AND, and OR. All these operators are left-associative.
  • The commas used to separate the values are interpreted as OR operators, so "Type:Fixture1,Fixture2" is equivalent to "Type:Fixture1 or Type:Fixture2".
  • White-space is ignored outside quoted strings, so "Type:Fixture1|Type:Fixture2" is equivalent to "Type : Fixture1 | Type : Fixture2".
  • Commas, colons, slashes, backslashes and quotation marks can be escaped with a backslash. For example, \' will be interpreted as '. Using a single backslash in front of any other character is invalid.
  • Currently the following filter keys are recognized:
    • Id: Filter by id.
    • Name: Filter by name.
    • Assembly: Filter by assembly name.
    • Namespace: Filter by namespace name.
    • Type: Filter by type name, including inherited types.
    • ExactType: Filter by type name, excluding inherited types.
    • Member: Filter by member name.
    • *: All other names are assumed to correspond to metadata keys. See MetadataKeys for standard metadata keys. Common keys are: AuthorName, Category, Description, Importance, TestsOn.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.FilterParser<T>

See Also

FilterParser<T> Members
Gallio.Model.Filters Namespace
MetadataKeys
FilterFormatter


FilterParser<T> Members

FilterParser Members
See Also Example Constructors Methods
[image]

A filter parser constructs filters from its textual representation as a filter expression.

The following tables list the members exposed by FilterParser<T>.

Public Constructors

 | Name | Description
Public method | FilterParser | Creates a filter parser.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ParseFilter | Creates a filter from its textual representation as a filter expression.
Public method | ParseFilterSet | Creates a filter set from its textual representation as a filter set expression consisting of inclusion and exclusion rules.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FilterParser<T> Class
Gallio.Model.Filters Namespace
MetadataKeys
FilterFormatter


FilterParser Constructor

FilterParser Constructor
[image]

Creates a filter parser.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal factory As IFilterFactory(Of T) _
)
C#
public FilterParser(
IFilterFactory<T> factory
)
C++
public:
FilterParser(
IFilterFactory<T> factory
) sealed
J#
public FilterParser(
IFilterFactory<T> factory
)
JScript
JScript does not support generic types and methods.

Parameters

factory
The factory to use for constructing filters based on filter keys and a filter rule for matching string values

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if factory is null

See Also

FilterParser<T> Class
Gallio.Model.Filters Namespace


Methods

FilterParser Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ParseFilter | Creates a filter from its textual representation as a filter expression.
Public method | ParseFilterSet | Creates a filter set from its textual representation as a filter set expression consisting of inclusion and exclusion rules.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FilterParser<T> Class
Gallio.Model.Filters Namespace
MetadataKeys
FilterFormatter


ParseFilter Method

FilterParser.ParseFilter Method
[image]

Creates a filter from its textual representation as a filter expression.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ParseFilter( _
ByVal filterExpr As String _
) As Filter(Of T)
C#
public Filter<T> ParseFilter(
string filterExpr
)
C++
public:
Filter<T> ParseFilter(
String filterExpr
) sealed
J#
public Filter<T> ParseFilter(
string filterExpr
)
JScript
JScript does not support generic types and methods.

Parameters

filterExpr
The filter expression

Return Value

The parsed filter

See Also

FilterParser<T> Class
Gallio.Model.Filters Namespace


ParseFilterSet Method

FilterParser.ParseFilterSet Method
[image]

Creates a filter set from its textual representation as a filter set expression consisting of inclusion and exclusion rules.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ParseFilterSet( _
ByVal filterSetExpr As String _
) As FilterSet(Of T)
C#
public FilterSet<T> ParseFilterSet(
string filterSetExpr
)
C++
public:
FilterSet<T> ParseFilterSet(
String filterSetExpr
) sealed
J#
public FilterSet<T> ParseFilterSet(
string filterSetExpr
)
JScript
JScript does not support generic types and methods.

Parameters

filterSetExpr
The filter set expression

Return Value

The parsed filter set

Remarks

If the filter set expression is empty or contains only whitespace then the resulting filter set will be empty.

See Also

FilterParser<T> Class
Gallio.Model.Filters Namespace


FilterRule Generic Class

FilterRule Generic Class
See Also Example Members
[image]

Specifies an inclusion or exclusion filter rule. This class cannot be inherited.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class FilterRule(Of T)
C#
[SerializableAttribute]
public sealed class FilterRule<T>
C++
[SerializableAttribute]
ref class FilterRule<T> sealed
J#
/** @attribute SerializableAttribute() */
public final class FilterRule<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.FilterRule<T>

See Also

FilterRule<T> Members
Gallio.Model.Filters Namespace


FilterRule<T> Members

FilterRule Members
See Also Example Constructors Properties Methods
[image]

Specifies an inclusion or exclusion filter rule. This class cannot be inherited.

The following tables list the members exposed by FilterRule<T>.

Public Constructors

 | Name | Description
Public method | FilterRule | Creates a filter rule.
Top

Public Properties

 | Name | Description
Public property | Filter | Gets the filter.
Public property | RuleType | Gets the filter rule type: inclusion or exclusion.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FilterRule<T> Class
Gallio.Model.Filters Namespace


FilterRule Constructor

FilterRule Constructor
[image]

Creates a filter rule.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal ruleType As FilterRuleType, _
ByVal filter As Filter(Of T) _
)
C#
public FilterRule(
FilterRuleType ruleType,
Filter<T> filter
)
C++
public:
FilterRule(
FilterRuleType ruleType,
Filter<T> filter
) sealed
J#
public FilterRule(
FilterRuleType ruleType,
Filter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

ruleType
The rule type: inclusion or exclusion
filter
The filter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if filter is null

See Also

FilterRule<T> Class
Gallio.Model.Filters Namespace


Properties

FilterRule Properties
[image]

Public Properties

 | Name | Description
Public property | Filter | Gets the filter.
Public property | RuleType | Gets the filter rule type: inclusion or exclusion.
Top

See Also

FilterRule<T> Class
Gallio.Model.Filters Namespace


Filter Property

FilterRule.Filter Property
[image]

Gets the filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filter As Filter(Of T)
C#
public Filter<T> Filter { get; }
C++
public property Filter<T> Filter sealed {
Filter<T> get();
}
J#
/** property */
public Filter<T> get_Filter();
JScript
JScript does not support generic types and methods.

See Also

FilterRule<T> Class
Gallio.Model.Filters Namespace


RuleType Property

FilterRule.RuleType Property
[image]

Gets the filter rule type: inclusion or exclusion.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RuleType As FilterRuleType
C#
public FilterRuleType RuleType { get; }
C++
public property FilterRuleType RuleType sealed {
FilterRuleType get();
}
J#
/** property */
public FilterRuleType get_RuleType();
JScript
JScript does not support generic types and methods.

See Also

FilterRule<T> Class
Gallio.Model.Filters Namespace


FilterRuleType Enumeration

FilterRuleType Enumeration
[image]

Specifies whether a filter rule is an inclusion or exclusion rule.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum FilterRuleType
C#
public enum FilterRuleType
C++
public enum class FilterRuleType
J#
public enum FilterRuleType
JScript
public enum FilterRuleType

Members

Member Name | Description
Inclusion | The filter rule is an inclusion rule.
Exclusion | The filter rule is an exclusion rule.

See Also

Gallio.Model.Filters Namespace
FilterRule


FilterSet Generic Class

FilterSet Generic Class
See Also Example Members
[image]

A filterset combines zero or more filters as a sequence of inclusion and exclusion rules. This class cannot be inherited.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class FilterSet(Of T)
C#
[SerializableAttribute]
public sealed class FilterSet<T>
C++
[SerializableAttribute]
ref class FilterSet<T> sealed
J#
/** @attribute SerializableAttribute() */
public final class FilterSet<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.FilterSet<T>

See Also

FilterSet<T> Members
Gallio.Model.Filters Namespace


FilterSet<T> Members

FilterSet Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A filterset combines zero or more filters as a sequence of inclusion and exclusion rules. This class cannot be inherited.

The following tables list the members exposed by FilterSet<T>.

Public Constructors

Name | Description
FilterSet | Overloaded.
Top

Public Properties

 | Name | Description
 | Empty | Returns an empty filter set.
Public property | HasInclusionRules | Returns true if the filter set has at least one inclusion rule.
Public property | IsEmpty | Returns true if the filter set is empty.
Public property | Rules | Gets the read-only list of filter rules.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Evaluate | Evaluates the rules of this filter set and indicates whether the item is included, excluded or not matched by the list of rules.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToFilterSetExpr | Formats the filter set to a string suitable for parsing by FilterParser.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Explicit Interface Implementations

Name | Description
FilterSet | Overloaded.
Top

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


FilterSet Constructor

FilterSet Constructor

Overload List

 | Name | Description
Public method | FilterSet (Filter<T>) | Creates a filter set consisting of a single inclusion filter.
Public method | FilterSet (ICollection<FilterRule<T>>) | Creates a filter set consisting of a collection of rules.

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


FilterSet Constructor (Generic Filter)

FilterSet Constructor (Generic Filter)
See Also Example
[image]

Creates a filter set consisting of a single inclusion filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal inclusionFilter As Filter(Of T) _
)
C#
public FilterSet(
Filter<T> inclusionFilter
)
C++
public:
FilterSet(
Filter<T> inclusionFilter
) sealed
J#
public FilterSet(
Filter<T> inclusionFilter
)
JScript
JScript does not support generic types and methods.

Parameters

inclusionFilter
The inclusion filter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if inclusionFilter is null

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace
FilterSet<T> Constructor Overload List


FilterSet Constructor (Generic ICollection)

FilterSet Constructor (Generic ICollection)
See Also Example
[image]

Creates a filter set consisting of a collection of rules.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal rules As ICollection(Of FilterRule(Of T)) _
)
C#
public FilterSet(
ICollection<FilterRule<T>> rules
)
C++
public:
FilterSet(
ICollection<FilterRule<T>> rules
) sealed
J#
public FilterSet(
ICollection<FilterRule<T>> rules
)
JScript
JScript does not support generic types and methods.

Parameters

rules
The filter rules

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if rules is null

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace
FilterSet<T> Constructor Overload List


Properties

FilterSet Properties
[image]

Public Properties

 | Name | Description
 | Empty | Returns an empty filter set.
Public property | HasInclusionRules | Returns true if the filter set has at least one inclusion rule.
Public property | IsEmpty | Returns true if the filter set is empty.
Public property | Rules | Gets the read-only list of filter rules.
Top

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


Empty Property

FilterSet.Empty Property
[image]

Returns an empty filter set.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Empty As FilterSet(Of T)
C#
public static FilterSet<T> Empty { get; }
C++
public static property FilterSet<T> Empty {
FilterSet<T> get();
}
J#
/** property */
public FilterSet<T> get_Empty();
JScript
JScript does not support generic types and methods.

Remarks

An empty filter set neither includes nor excludes any values on its own. However when filtering tests, Gallio applies an implicit inclusion rule when none is otherwise specified so the net effect if that all tests will be included (although "explicit" tests will not be selected explicitly so they will not run).

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


HasInclusionRules Property

FilterSet.HasInclusionRules Property
[image]

Returns true if the filter set has at least one inclusion rule.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasInclusionRules As Boolean
C#
public bool HasInclusionRules { get; }
C++
public property bool HasInclusionRules sealed {
bool get();
}
J#
/** property */
public bool get_HasInclusionRules();
JScript
JScript does not support generic types and methods.

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


IsEmpty Property

FilterSet.IsEmpty Property
[image]

Returns true if the filter set is empty.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty { get; }
C++
public property bool IsEmpty sealed {
bool get();
}
J#
/** property */
public bool get_IsEmpty();
JScript
JScript does not support generic types and methods.

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


Rules Property

FilterSet.Rules Property
[image]

Gets the read-only list of filter rules.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Rules As IList(Of FilterRule(Of T))
C#
public IList<FilterRule<T>> Rules { get; }
C++
public property IList<FilterRule<T>> Rules sealed {
IList<FilterRule<T>> get();
}
J#
/** property */
public IList<FilterRule<T>> get_Rules();
JScript
JScript does not support generic types and methods.

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


Methods

FilterSet Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Evaluate | Evaluates the rules of this filter set and indicates whether the item is included, excluded or not matched by the list of rules.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToFilterSetExpr | Formats the filter set to a string suitable for parsing by FilterParser.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


Evaluate Method

FilterSet.Evaluate Method
[image]

Evaluates the rules of this filter set and indicates whether the item is included, excluded or not matched by the list of rules.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Evaluate( _
ByVal item As T _
) As FilterSetResult
C#
public FilterSetResult Evaluate(
T item
)
C++
public:
FilterSetResult Evaluate(
T item
) sealed
J#
public FilterSetResult Evaluate(
T item
)
JScript
JScript does not support generic types and methods.

Parameters

item
The item

Return Value

The result

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


ToFilterSetExpr Method

FilterSet.ToFilterSetExpr Method
[image]

Formats the filter set to a string suitable for parsing by FilterParser.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToFilterSetExpr() As String
C#
public string ToFilterSetExpr()
C++
public:
String ToFilterSetExpr() sealed
J#
public string ToFilterSetExpr()
JScript
JScript does not support generic types and methods.

Return Value

The formatted filter set expression

Remarks

The empty filter is represented by an empty string.

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


ToString Method

FilterSet.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

Return Value

A String that represents the current Object.

See Also

FilterSet<T> Class
Gallio.Model.Filters Namespace


FilterSetResult Enumeration

FilterSetResult Enumeration
[image]

Specifies whether a filter set includes, excludes or does not match a particular item.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum FilterSetResult
C#
public enum FilterSetResult
C++
public enum class FilterSetResult
J#
public enum FilterSetResult
JScript
public enum FilterSetResult

Members

Member Name | Description
Unmatched | The filter set neither includes nor excludes the item.
Include | The filter set includes the item.
Exclude | The filter set excludes the item.

See Also

Gallio.Model.Filters Namespace


FilterUtils Class

FilterUtils Class
See Also Example Members
[image]

Provides utilities for manipulating filters. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module FilterUtils
C#
public static class FilterUtils
C++
ref class FilterUtils abstract sealed
J#
public final class FilterUtils
JScript
public class FilterUtils

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.FilterUtils

See Also

FilterUtils Members
Gallio.Model.Filters Namespace


FilterUtils Members

FilterUtils Members
See Also Example Methods
[image]

Provides utilities for manipulating filters. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by FilterUtils.

Public Methods

Name | Description
ParseTestFilter | Parses a test filter.
ParseTestFilterSet | Parses a test filter set.
Top

See Also

FilterUtils Class
Gallio.Model.Filters Namespace


Methods

FilterUtils Methods
[image]

Public Methods

Name | Description
ParseTestFilter | Parses a test filter.
ParseTestFilterSet | Parses a test filter set.
Top

See Also

FilterUtils Class
Gallio.Model.Filters Namespace


ParseTestFilter Method

FilterUtils.ParseTestFilter Method
[image]

Parses a test filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseTestFilter( _
ByVal filterExpr As String _
) As Filter(Of ITest)
C#
public static Filter<ITest> ParseTestFilter(
string filterExpr
)
C++
public:
static Filter<ITest> ParseTestFilter(
String filterExpr
)
J#
public static Filter<ITest> ParseTestFilter(
string filterExpr
)
JScript
public static function ParseTestFilter(
filterExpr : String
) : Filter<ITest>

Parameters

filterExpr
The filter expression

Return Value

The parsed filter

See Also

FilterUtils Class
Gallio.Model.Filters Namespace


ParseTestFilterSet Method

FilterUtils.ParseTestFilterSet Method
[image]

Parses a test filter set.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseTestFilterSet( _
ByVal filterExpr As String _
) As FilterSet(Of ITest)
C#
public static FilterSet<ITest> ParseTestFilterSet(
string filterExpr
)
C++
public:
static FilterSet<ITest> ParseTestFilterSet(
String filterExpr
)
J#
public static FilterSet<ITest> ParseTestFilterSet(
string filterExpr
)
JScript
public static function ParseTestFilterSet(
filterExpr : String
) : FilterSet<ITest>

Parameters

filterExpr
The filter expression

Return Value

The parsed filter set

See Also

FilterUtils Class
Gallio.Model.Filters Namespace


IdFilter Generic Class

IdFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose Id matches the specified id filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class IdFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class IdFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class IdFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class IdFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.IdFilter<T>

See Also

IdFilter<T> Members
Gallio.Model.Filters Namespace


IdFilter<T> Members

IdFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose Id matches the specified id filter.

The following tables list the members exposed by IdFilter<T>.

Public Constructors

 | Name | Description
Public method | IdFilter | Creates an identity filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


IdFilter Constructor

IdFilter Constructor
[image]

Creates an identity filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal idFilter As Filter(Of String) _
)
C#
public IdFilter(
Filter<string> idFilter
)
C++
public:
IdFilter(
Filter<string> idFilter
) sealed
J#
public IdFilter(
Filter<string> idFilter
)
JScript
JScript does not support generic types and methods.

Parameters

idFilter
A filter for the id

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if idFilter is null

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


Properties

IdFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

IdFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


Methods

IdFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

IdFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

IdFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

IdFilter<T> Class
Gallio.Model.Filters Namespace


IFilterFactory Generic Interface

IFilterFactory Generic Interface
See Also Example Members
[image]

Creates filters of a given type based on a specification that consists of a filter key and a rule for matching values.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFilterFactory(Of T)
C#
public interface IFilterFactory<T>
C++
interface class IFilterFactory<T>
J#
public interface IFilterFactory<T>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The filter type

Types that implement IFilterFactory<T>

Type | Description
Gallio.Model.Filters.ModelComponentFilterFactory<T> | Builds filters for ITestComponent objects.

See Also

IFilterFactory<T> Members
Gallio.Model.Filters Namespace


IFilterFactory<T> Members

IFilterFactory Members
See Also Example Methods
[image]

Creates filters of a given type based on a specification that consists of a filter key and a rule for matching values.

The following tables list the members exposed by IFilterFactory<T>.

Public Methods

 | Name | Description
Public method | CreateFilter | Creates a filter from a specification
Top

See Also

IFilterFactory<T> Interface
Gallio.Model.Filters Namespace


Methods

IFilterFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateFilter | Creates a filter from a specification
Top

See Also

IFilterFactory<T> Interface
Gallio.Model.Filters Namespace


CreateFilter Method

IFilterFactory.CreateFilter Method
[image]

Creates a filter from a specification

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateFilter( _
ByVal key As String, _
ByVal valueFilter As Filter(Of String) _
) As Filter(Of T)
C#
Filter<T> CreateFilter(
string key,
Filter<string> valueFilter
)
C++
Filter<T> CreateFilter(
String key,
Filter<string> valueFilter
) abstract
J#
Filter<T> CreateFilter(
string key,
Filter<string> valueFilter
)
JScript
JScript does not support generic types and methods.

Parameters

key
The filter key that identifies the kind of filter to create
valueFilter
The filter to use as a rule for matching values

Return Value

The filter

See Also

IFilterFactory<T> Interface
Gallio.Model.Filters Namespace


IFilterVisitor Interface

IFilterVisitor Interface
See Also Example Members
[image]

Visits the structure of filters.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFilterVisitor
C#
public interface IFilterVisitor
C++
interface class IFilterVisitor
J#
public interface IFilterVisitor
JScript
public interface IFilterVisitor

Types that implement IFilterVisitor

Type | Description
Gallio.Model.Filters.FilterFormatter | Formats filters in such manner that they can be reparsed using the FilterParser.

See Also

IFilterVisitor Members
Gallio.Model.Filters Namespace


IFilterVisitor Members

IFilterVisitor Members
See Also Example Methods
[image]

Visits the structure of filters.

The following tables list the members exposed by IFilterVisitor.

Public Methods

 | Name | Description
Public method | VisitAndFilter | Visits a AndFilter.
Public method | VisitAnyFilter | Visits a AnyFilter.
Public method | VisitEqualityFilter | Visits a EqualityFilter.
Public method | VisitNoneFilter | Visits a NoneFilter.
Public method | VisitNotFilter | Visits a NotFilter.
Public method | VisitOrFilter | Visits a OrFilter.
Public method | VisitPropertyFilter | Visits a PropertyFilter.
Public method | VisitRegexFilter | Visits a RegexFilter.
Top

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


Methods

IFilterVisitor Methods
[image]

Public Methods

 | Name | Description
Public method | VisitAndFilter | Visits a AndFilter.
Public method | VisitAnyFilter | Visits a AnyFilter.
Public method | VisitEqualityFilter | Visits a EqualityFilter.
Public method | VisitNoneFilter | Visits a NoneFilter.
Public method | VisitNotFilter | Visits a NotFilter.
Public method | VisitOrFilter | Visits a OrFilter.
Public method | VisitPropertyFilter | Visits a PropertyFilter.
Public method | VisitRegexFilter | Visits a RegexFilter.
Top

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitAndFilter Generic Method

IFilterVisitor.VisitAndFilter Generic Method
[image]

Visits a AndFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitAndFilter(Of T)( _
ByVal filter As AndFilter(Of T) _
)
C#
void VisitAndFilter<T>(
AndFilter<T> filter
)
C++
void VisitAndFilter<T>(
AndFilter<T> filter
) abstract
J#
void VisitAndFilter<T>(
AndFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitAnyFilter Generic Method

IFilterVisitor.VisitAnyFilter Generic Method
[image]

Visits a AnyFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitAnyFilter(Of T)( _
ByVal filter As AnyFilter(Of T) _
)
C#
void VisitAnyFilter<T>(
AnyFilter<T> filter
)
C++
void VisitAnyFilter<T>(
AnyFilter<T> filter
) abstract
J#
void VisitAnyFilter<T>(
AnyFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitEqualityFilter Generic Method

IFilterVisitor.VisitEqualityFilter Generic Method
[image]

Visits a EqualityFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitEqualityFilter(Of T As {IEquatable(Of T), Class})( _
ByVal filter As EqualityFilter(Of T) _
)
C#
void VisitEqualityFilter<T>(
EqualityFilter<T> filter
) where T : IEquatable<T>, class
C++
void VisitEqualityFilter<T>(
EqualityFilter<T> filter
) abstract
J#
void VisitEqualityFilter<T>(
EqualityFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitNoneFilter Generic Method

IFilterVisitor.VisitNoneFilter Generic Method
[image]

Visits a NoneFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitNoneFilter(Of T)( _
ByVal filter As NoneFilter(Of T) _
)
C#
void VisitNoneFilter<T>(
NoneFilter<T> filter
)
C++
void VisitNoneFilter<T>(
NoneFilter<T> filter
) abstract
J#
void VisitNoneFilter<T>(
NoneFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitNotFilter Generic Method

IFilterVisitor.VisitNotFilter Generic Method
[image]

Visits a NotFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitNotFilter(Of T)( _
ByVal filter As NotFilter(Of T) _
)
C#
void VisitNotFilter<T>(
NotFilter<T> filter
)
C++
void VisitNotFilter<T>(
NotFilter<T> filter
) abstract
J#
void VisitNotFilter<T>(
NotFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitOrFilter Generic Method

IFilterVisitor.VisitOrFilter Generic Method
[image]

Visits a OrFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitOrFilter(Of T)( _
ByVal filter As OrFilter(Of T) _
)
C#
void VisitOrFilter<T>(
OrFilter<T> filter
)
C++
void VisitOrFilter<T>(
OrFilter<T> filter
) abstract
J#
void VisitOrFilter<T>(
OrFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitPropertyFilter Generic Method

IFilterVisitor.VisitPropertyFilter Generic Method
[image]

Visits a PropertyFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitPropertyFilter(Of T)( _
ByVal filter As PropertyFilter(Of T) _
)
C#
void VisitPropertyFilter<T>(
PropertyFilter<T> filter
)
C++
void VisitPropertyFilter<T>(
PropertyFilter<T> filter
) abstract
J#
void VisitPropertyFilter<T>(
PropertyFilter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


VisitRegexFilter Method

IFilterVisitor.VisitRegexFilter Method
[image]

Visits a RegexFilter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitRegexFilter( _
ByVal filter As RegexFilter _
)
C#
void VisitRegexFilter(
RegexFilter filter
)
C++
void VisitRegexFilter(
RegexFilter filter
) abstract
J#
void VisitRegexFilter(
RegexFilter filter
)
JScript
function VisitRegexFilter(
filter : RegexFilter
)

Parameters

filter
The filter

See Also

IFilterVisitor Interface
Gallio.Model.Filters Namespace


MemberFilter Generic Class

MemberFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose CodeElement matches the specified member name filter. This filter should normally be used together with a TypeFilter to ensure the accuracy of the member match.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class MemberFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class MemberFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class MemberFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class MemberFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.MemberFilter<T>

See Also

MemberFilter<T> Members
Gallio.Model.Filters Namespace


MemberFilter<T> Members

MemberFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose CodeElement matches the specified member name filter. This filter should normally be used together with a TypeFilter to ensure the accuracy of the member match.

The following tables list the members exposed by MemberFilter<T>.

Public Constructors

 | Name | Description
Public method | MemberFilter | Creates a member filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


MemberFilter Constructor

MemberFilter Constructor
[image]

Creates a member filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal memberNameFilter As Filter(Of String) _
)
C#
public MemberFilter(
Filter<string> memberNameFilter
)
C++
public:
MemberFilter(
Filter<string> memberNameFilter
) sealed
J#
public MemberFilter(
Filter<string> memberNameFilter
)
JScript
JScript does not support generic types and methods.

Parameters

memberNameFilter
A filter for the member name as returned by Name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if memberNameFilter is null

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


Properties

MemberFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

MemberFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


Methods

MemberFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

MemberFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

MemberFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

MemberFilter<T> Class
Gallio.Model.Filters Namespace


MetadataFilter Generic Class

MetadataFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose Metadata has a key with a value that matches the value filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class MetadataFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class MetadataFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class MetadataFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class MetadataFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.MetadataFilter<T>

See Also

MetadataFilter<T> Members
Gallio.Model.Filters Namespace


MetadataFilter<T> Members

MetadataFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose Metadata has a key with a value that matches the value filter.

The following tables list the members exposed by MetadataFilter<T>.

Public Constructors

 | Name | Description
Public method | MetadataFilter | Creates a metadata filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


MetadataFilter Constructor

MetadataFilter Constructor
[image]

Creates a metadata filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal key As String, _
ByVal valueFilter As Filter(Of String) _
)
C#
public MetadataFilter(
string key,
Filter<string> valueFilter
)
C++
public:
MetadataFilter(
String key,
Filter<string> valueFilter
) sealed
J#
public MetadataFilter(
string key,
Filter<string> valueFilter
)
JScript
JScript does not support generic types and methods.

Parameters

key
The metadata key to look for
valueFilter
A filter for the metadata value to match

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if key or valueFilter is null

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


Properties

MetadataFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

MetadataFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


Methods

MetadataFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

MetadataFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

MetadataFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

MetadataFilter<T> Class
Gallio.Model.Filters Namespace


ModelComponentFilterFactory Generic Class

ModelComponentFilterFactory Generic Class
See Also Example Members
[image]

Builds filters for ITestComponent objects.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ModelComponentFilterFactory(Of T As ITestComponent)
Implements IFilterFactory(Of T)
C#
public class ModelComponentFilterFactory<T> : IFilterFactory<T> where T : ITestComponent
C++
ref class ModelComponentFilterFactory<T> : IFilterFactory<T> where T : ITestComponent
J#
public class ModelComponentFilterFactory<T> implements IFilterFactory<T>
JScript
JScript does not support generic types and methods.

Type Parameters

T
The ITestComponent subtype

Remarks

Recognizes the following filter keys:

  • Id: Filter by id
  • Name: Filter by name
  • Assembly: Filter by assembly name
  • Namespace: Filter by namespace name
  • Type: Filter by type name, including inherited types
  • ExactType: Filter by exact type name, excluding inherited types
  • Member: Filter by member name
  • *: All other names are assumed to correspond to metadata keys

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.ModelComponentFilterFactory<T>

See Also

ModelComponentFilterFactory<T> Members
Gallio.Model.Filters Namespace


ModelComponentFilterFactory<T> Members

ModelComponentFilterFactory Members
See Also Example Constructors Methods
[image]

Builds filters for ITestComponent objects.

The following tables list the members exposed by ModelComponentFilterFactory<T>.

Public Constructors

 | Name | Description
Public method | ModelComponentFilterFactory | Initializes a new instance of the ModelComponentFilterFactory class.
Top

Public Methods

 | Name | Description
Public method | CreateFilter | Creates a filter from a specification
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ModelComponentFilterFactory<T> Class
Gallio.Model.Filters Namespace


ModelComponentFilterFactory Constructor

ModelComponentFilterFactory Constructor
[image]

Initializes a new instance of the ModelComponentFilterFactory class.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ModelComponentFilterFactory()
C++
public:
ModelComponentFilterFactory() sealed
J#
public ModelComponentFilterFactory()
JScript
JScript does not support generic types and methods.

See Also

ModelComponentFilterFactory<T> Class
Gallio.Model.Filters Namespace


Methods

ModelComponentFilterFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateFilter | Creates a filter from a specification
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ModelComponentFilterFactory<T> Class
Gallio.Model.Filters Namespace


CreateFilter Method

ModelComponentFilterFactory.CreateFilter Method
[image]

Creates a filter from a specification

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateFilter( _
ByVal key As String, _
ByVal valueFilter As Filter(Of String) _
) As Filter(Of T) _
Implements IFilterFactory<T>.CreateFilter
C#
public Filter<T> CreateFilter(
string key,
Filter<string> valueFilter
)
C++
public:
Filter<T> CreateFilter(
String key,
Filter<string> valueFilter
) sealed
J#
public Filter<T> CreateFilter(
string key,
Filter<string> valueFilter
)
JScript
JScript does not support generic types and methods.

Parameters

key
The filter key that identifies the kind of filter to create
valueFilter
The filter to use as a rule for matching values

Return Value

The filter

Implements

IFilterFactory<T>.CreateFilter

See Also

ModelComponentFilterFactory<T> Class
Gallio.Model.Filters Namespace


NameFilter Generic Class

NameFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose Name matches the specified name filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class NameFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class NameFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class NameFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class NameFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.NameFilter<T>

See Also

NameFilter<T> Members
Gallio.Model.Filters Namespace


NameFilter<T> Members

NameFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose Name matches the specified name filter.

The following tables list the members exposed by NameFilter<T>.

Public Constructors

 | Name | Description
Public method | NameFilter | Creates a name filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


NameFilter Constructor

NameFilter Constructor
[image]

Creates a name filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal nameFilter As Filter(Of String) _
)
C#
public NameFilter(
Filter<string> nameFilter
)
C++
public:
NameFilter(
Filter<string> nameFilter
) sealed
J#
public NameFilter(
Filter<string> nameFilter
)
JScript
JScript does not support generic types and methods.

Parameters

nameFilter
A filter for the name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if nameFilter is null

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


Properties

NameFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

NameFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


Methods

NameFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

NameFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

NameFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

NameFilter<T> Class
Gallio.Model.Filters Namespace


NamespaceFilter Generic Class

NamespaceFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose CodeElement matches the specified namespace name.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class NamespaceFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class NamespaceFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class NamespaceFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class NamespaceFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.NamespaceFilter<T>

See Also

NamespaceFilter<T> Members
Gallio.Model.Filters Namespace


NamespaceFilter<T> Members

NamespaceFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose CodeElement matches the specified namespace name.

The following tables list the members exposed by NamespaceFilter<T>.

Public Constructors

 | Name | Description
Public method | NamespaceFilter | Creates a namespace filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


NamespaceFilter Constructor

NamespaceFilter Constructor
[image]

Creates a namespace filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal namespaceNameFilter As Filter(Of String) _
)
C#
public NamespaceFilter(
Filter<string> namespaceNameFilter
)
C++
public:
NamespaceFilter(
Filter<string> namespaceNameFilter
) sealed
J#
public NamespaceFilter(
Filter<string> namespaceNameFilter
)
JScript
JScript does not support generic types and methods.

Parameters

namespaceNameFilter
A filter for the namespace name obtained via reflection on types

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if namespaceNameFilter is null

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


Properties

NamespaceFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

NamespaceFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


Methods

NamespaceFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

NamespaceFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

NamespaceFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

NamespaceFilter<T> Class
Gallio.Model.Filters Namespace


NoneFilter Generic Class

NoneFilter Generic Class
See Also Example Members
[image]

A filter that matches nothing and always returns false.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class NoneFilter(Of T)
Inherits Filter(Of T)
C#
[SerializableAttribute]
public class NoneFilter<T> : Filter<T>
C++
[SerializableAttribute]
ref class NoneFilter<T> : Filter<T>
J#
/** @attribute SerializableAttribute() */
public class NoneFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.NoneFilter<T>

See Also

NoneFilter<T> Members
Gallio.Model.Filters Namespace


NoneFilter<T> Members

NoneFilter Members
See Also Example Constructors Methods
[image]

A filter that matches nothing and always returns false.

The following tables list the members exposed by NoneFilter<T>.

Public Constructors

 | Name | Description
Public method | NoneFilter | Initializes a new instance of the NoneFilter class.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NoneFilter<T> Class
Gallio.Model.Filters Namespace


NoneFilter Constructor

NoneFilter Constructor
[image]

Initializes a new instance of the NoneFilter class.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NoneFilter()
C++
public:
NoneFilter() sealed
J#
public NoneFilter()
JScript
JScript does not support generic types and methods.

See Also

NoneFilter<T> Class
Gallio.Model.Filters Namespace


Methods

NoneFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NoneFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

NoneFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

NoneFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

NoneFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

NoneFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

NoneFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

NoneFilter<T> Class
Gallio.Model.Filters Namespace


NotFilter Generic Class

NotFilter Generic Class
See Also Example Members
[image]

A filter combinator that is the negation of another filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class NotFilter(Of T)
Inherits Filter(Of T)
C#
[SerializableAttribute]
public class NotFilter<T> : Filter<T>
C++
[SerializableAttribute]
ref class NotFilter<T> : Filter<T>
J#
/** @attribute SerializableAttribute() */
public class NotFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.NotFilter<T>

See Also

NotFilter<T> Members
Gallio.Model.Filters Namespace


NotFilter<T> Members

NotFilter Members
See Also Example Constructors Properties Methods
[image]

A filter combinator that is the negation of another filter.

The following tables list the members exposed by NotFilter<T>.

Public Constructors

 | Name | Description
Public method | NotFilter | Creates a NOT-filter.
Top

Public Properties

 | Name | Description
Public property | Filter | Gets the filter to be negated.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


NotFilter Constructor

NotFilter Constructor
[image]

Creates a NOT-filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal filter As Filter(Of T) _
)
C#
public NotFilter(
Filter<T> filter
)
C++
public:
NotFilter(
Filter<T> filter
) sealed
J#
public NotFilter(
Filter<T> filter
)
JScript
JScript does not support generic types and methods.

Parameters

filter
The filter to be negated

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if filter is null

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


Properties

NotFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Filter | Gets the filter to be negated.
Top

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


Filter Property

NotFilter.Filter Property
[image]

Gets the filter to be negated.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filter As Filter(Of T)
C#
public Filter<T> Filter { get; }
C++
public property Filter<T> Filter sealed {
Filter<T> get();
}
J#
/** property */
public Filter<T> get_Filter();
JScript
JScript does not support generic types and methods.

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


Methods

NotFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

NotFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

NotFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

NotFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

NotFilter<T> Class
Gallio.Model.Filters Namespace


OrFilter Generic Class

OrFilter Generic Class
See Also Example Members
[image]

A filter combinator that matches a value when at least one of its constituent filters matches the value.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class OrFilter(Of T)
Inherits Filter(Of T)
C#
[SerializableAttribute]
public class OrFilter<T> : Filter<T>
C++
[SerializableAttribute]
ref class OrFilter<T> : Filter<T>
J#
/** @attribute SerializableAttribute() */
public class OrFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.OrFilter<T>

See Also

OrFilter<T> Members
Gallio.Model.Filters Namespace


OrFilter<T> Members

OrFilter Members
See Also Example Constructors Properties Methods
[image]

A filter combinator that matches a value when at least one of its constituent filters matches the value.

The following tables list the members exposed by OrFilter<T>.

Public Constructors

 | Name | Description
Public method | OrFilter | Creates an OR-filter.
Top

Public Properties

 | Name | Description
Public property | Filters | Gets the filters from which at least one match must be found. If the list is empty, the filter matches everything.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


OrFilter Constructor

OrFilter Constructor
[image]

Creates an OR-filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal filters As ICollection(Of Filter(Of T)) _
)
C#
public OrFilter(
ICollection<Filter<T>> filters
)
C++
public:
OrFilter(
ICollection<Filter<T>> filters
) sealed
J#
public OrFilter(
ICollection<Filter<T>> filters
)
JScript
JScript does not support generic types and methods.

Parameters

filters
The filters from which at least one match must be found. If the list is empty, the filter matches everything.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if filters is null

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


Properties

OrFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Filters | Gets the filters from which at least one match must be found. If the list is empty, the filter matches everything.
Top

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


Filters Property

OrFilter.Filters Property
[image]

Gets the filters from which at least one match must be found. If the list is empty, the filter matches everything.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filters As IList(Of Filter(Of T))
C#
public IList<Filter<T>> Filters { get; }
C++
public property IList<Filter<T>> Filters sealed {
IList<Filter<T>> get();
}
J#
/** property */
public IList<Filter<T>> get_Filters();
JScript
JScript does not support generic types and methods.

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


Methods

OrFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

OrFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

OrFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

OrFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

OrFilter<T> Class
Gallio.Model.Filters Namespace


PropertyFilter Generic Class

PropertyFilter Generic Class
See Also Example Members
[image]

Abstract base class for filters that encapsulate a rule for selecting some property of an object to be compared against a string value filter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class PropertyFilter(Of T)
Inherits Filter(Of T)
C#
[SerializableAttribute]
public abstract class PropertyFilter<T> : Filter<T>
C++
[SerializableAttribute]
ref class PropertyFilter<T> abstract : Filter<T>
J#
/** @attribute SerializableAttribute() */
public class PropertyFilter<T> extends Filter<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Derived types

See Also

PropertyFilter<T> Members
Gallio.Model.Filters Namespace


PropertyFilter<T> Members

PropertyFilter Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for filters that encapsulate a rule for selecting some property of an object to be compared against a string value filter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by PropertyFilter<T>.

Public Constructors

 | Name | Description
Public method | PropertyFilter | Creates a filter for some property by string value.
Top

Public Properties

 | Name | Description
Public property | Key | Gets the key that represents the filtered property.
Public property | ValueFilter | Gets the string value filter.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Determines whether the filter matches the value. (inherited from Filter)
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


PropertyFilter Constructor

PropertyFilter Constructor
[image]

Creates a filter for some property by string value.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal valueFilter As Filter(Of String) _
)
C#
public PropertyFilter(
Filter<string> valueFilter
)
C++
public:
PropertyFilter(
Filter<string> valueFilter
) sealed
J#
public PropertyFilter(
Filter<string> valueFilter
)
JScript
JScript does not support generic types and methods.

Parameters

valueFilter
The string value filter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if valueFilter is null

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


Properties

PropertyFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Gets the key that represents the filtered property.
Public property | ValueFilter | Gets the string value filter.
Top

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

PropertyFilter.Key Property
[image]

Gets the key that represents the filtered property.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Key As String
C#
public abstract string Key { get; }
C++
public abstract property string Key abstract {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


ValueFilter Property

PropertyFilter.ValueFilter Property
[image]

Gets the string value filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueFilter As Filter(Of String)
C#
public Filter<string> ValueFilter { get; }
C++
public property Filter<string> ValueFilter sealed {
Filter<string> get();
}
J#
/** property */
public Filter<string> get_ValueFilter();
JScript
JScript does not support generic types and methods.

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


Methods

PropertyFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Determines whether the filter matches the value. (inherited from Filter)
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


Accept Method

PropertyFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
JScript does not support generic types and methods.

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


RegexFilter Class

RegexFilter Class
See Also Example Members
[image]

A regex filter matches strings against a given Regex. Null string values are converted to empty strings for regex evaluation purposes. This class cannot be inherited.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class RegexFilter
Inherits Filter(Of String)
C#
[SerializableAttribute]
public sealed class RegexFilter : Filter<string>
C++
[SerializableAttribute]
ref class RegexFilter sealed : Filter<string>
J#
/** @attribute SerializableAttribute() */
public final class RegexFilter extends Filter<string>
JScript
public
SerializableAttribute
final class RegexFilter extends Filter<string>

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.RegexFilter

See Also

RegexFilter Members
Gallio.Model.Filters Namespace


RegexFilter Members

RegexFilter Members
See Also Example Constructors Properties Methods
[image]

A regex filter matches strings against a given Regex. Null string values are converted to empty strings for regex evaluation purposes. This class cannot be inherited.

The following tables list the members exposed by RegexFilter.

Public Constructors

 | Name | Description
Public method | RegexFilter | Creates an regex filter.
Top

Public Properties

 | Name | Description
Public property | Regex | Gets the regular expression for matching strings.
Top

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


RegexFilter Constructor

RegexFilter Constructor
[image]

Creates an regex filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal regex As Regex _
)
C#
public RegexFilter(
Regex regex
)
C++
public:
RegexFilter(
Regex regex
) sealed
J#
public RegexFilter(
Regex regex
)
JScript
public function RegexFilter(
regex : Regex
)

Parameters

regex
The regular expression for matching strings

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if regex is null

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


Properties

RegexFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Regex | Gets the regular expression for matching strings.
Top

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


Regex Property

RegexFilter.Regex Property
[image]

Gets the regular expression for matching strings.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Regex As Regex
C#
public Regex Regex { get; }
C++
public property Regex Regex sealed {
Regex get();
}
J#
/** property */
public Regex get_Regex();
JScript
public function get Regex() : Regex

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


Methods

RegexFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Overridden.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


Accept Method

RegexFilter.Accept Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Accept( _
ByVal visitor As IFilterVisitor _
)
C#
public override void Accept(
IFilterVisitor visitor
)
C++
public:
virtual void Accept(
IFilterVisitor visitor
) override
J#
public override void Accept(
IFilterVisitor visitor
)
JScript
public override function Accept(
visitor : IFilterVisitor
)

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


IsMatch Method

RegexFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As String _
) As Boolean
C#
public override bool IsMatch(
string value
)
C++
public:
virtual bool IsMatch(
String value
) override
J#
public override bool IsMatch(
string value
)
JScript
public override function IsMatch(
value : String
) : bool

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


ToString Method

RegexFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

RegexFilter Class
Gallio.Model.Filters Namespace


TypeFilter Generic Class

TypeFilter Generic Class
See Also Example Members
[image]

A filter that matches objects whose CodeElement matches the specified type name.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class TypeFilter(Of T As ITestComponent)
Inherits PropertyFilter(Of T)
C#
[SerializableAttribute]
public class TypeFilter<T> : PropertyFilter<T> where T : ITestComponent
C++
[SerializableAttribute]
ref class TypeFilter<T> : PropertyFilter<T> where T : ITestComponent
J#
/** @attribute SerializableAttribute() */
public class TypeFilter<T> extends PropertyFilter<T>
JScript
JScript does not support generic types and methods.

Remarks

Generic types should be specified by the name of their generic type definition. eg. Foo`1.

Inheritance Hierarchy

System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.TypeFilter<T>

See Also

TypeFilter<T> Members
Gallio.Model.Filters Namespace


TypeFilter<T> Members

TypeFilter Members
See Also Example Constructors Properties Methods
[image]

A filter that matches objects whose CodeElement matches the specified type name.

The following tables list the members exposed by TypeFilter<T>.

Public Constructors

 | Name | Description
Public method | TypeFilter | Creates a type filter.
Top

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


TypeFilter Constructor

TypeFilter Constructor
[image]

Creates a type filter.

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal typeNameFilter As Filter(Of String), _
ByVal includeDerivedTypes As Boolean _
)
C#
public TypeFilter(
Filter<string> typeNameFilter,
bool includeDerivedTypes
)
C++
public:
TypeFilter(
Filter<string> typeNameFilter,
bool includeDerivedTypes
) sealed
J#
public TypeFilter(
Filter<string> typeNameFilter,
bool includeDerivedTypes
)
JScript
JScript does not support generic types and methods.

Parameters

typeNameFilter
A filter to match the type name obtained via reflection on the type in one of the following ways:
  • Fully qualified by namespace and assembly as returned by AssemblyQualifiedName
  • Qualified by namespace as returned by FullName
  • Unqualified as returned by the type's Name
includeDerivedTypes
If true, subclasses and interface implementations of the specified type are also matched by the filter if they can be located

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if typeNameFilter is null

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


Properties

TypeFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Key | Overridden.
Public property | ValueFilter | Gets the string value filter. (inherited from PropertyFilter)
Top

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


Key Property

TypeFilter.Key Property
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Key As String
C#
public override string Key { get; }
C++
public override property string Key override {
String get();
}
J#
/** property */
public string get_Key();
JScript
JScript does not support generic types and methods.

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


Methods

TypeFilter Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | (inherited from PropertyFilter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsMatch | Overridden.
Public method | ToFilterExpr | Formats the filter to a string suitable for parsing by FilterParser. (inherited from Filter)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


IsMatch Method

TypeFilter.IsMatch Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsMatch( _
ByVal value As T _
) As Boolean
C#
public override bool IsMatch(
T value
)
C++
public:
virtual bool IsMatch(
T value
) override
J#
public override bool IsMatch(
T value
)
JScript
JScript does not support generic types and methods.

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


ToString Method

TypeFilter.ToString Method
[image]

Namespace: Gallio.Model.Filters
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
JScript does not support generic types and methods.

See Also

TypeFilter<T> Class
Gallio.Model.Filters Namespace


Gallio.Model.Logging

Gallio.Model.Logging Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | Attachment | An attachment is an embedded object in an execution log. An attachment must specify a content type (a MIME type), and some contents. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class AttachmentData

An Xml-serializable structure that describes the contents, encoding and disposition of an attachment.

The contents of the attachment are embedded in the execution log according to their encoding. Text is directly embedded into the Xml whereas binary attachments are base 64 encoded.

This class cannot be inherited.
Public class | BinaryAttachment | Represents a binary-encoded attachments. This class cannot be inherited.
Public class | FallbackTestLogWriter | A test log writer that falls back to a different test log writer for certain operations when its primary test log writer is closed.
Public class | MimeTypes | Defines constants for commonly used mime types. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | NullTestLogWriter | A test log writer that does nothing.
Public class | StringTestLogWriter | An implementation of TestLogStreamWriter that writes its output to a string.
Public class | StructuredTestLog | A structured test log is an Xml-serializable in-memory representation of a test log written by a TestLogWriter. This class cannot be inherited.
Public class StructuredTestLogStream

A structured log stream object represents a recursively structured stream of rich text that supports embedded attachments, nested sections and marked regions. Each part of the text is captured by a tag, some of which are composable and may therefore contain other tags.

It is effectively an xml-serializable representation of a test log stream written by a TestLogStreamWriter.

This class cannot be inherited.
Public class | StructuredTestLogWriter | Writes a StructuredTestLog in memory.
Public class StructuredText

A structured text object contains attachments and formatted text with rich presentation elements.

Structured text is emitted by a StructuredTextWriter.

This class cannot be inherited.
Public class | StructuredTextWriter | Writes log information in a structured manner so as to produce a StructuredText or String.
Public class | TestLogStreamLogger | A ILogger implementation that logs messages to the specified TestLogStreamWriter. This can be used to write log messages to the test execution log. This class cannot be inherited.
Public class | TestLogStreamNames | Common test log stream names. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | TestLogStreamWriter | A log stream writer provides methods for writing rich structured text with embedded attachments, nested sections and hidden semantic markers to a particular stream within a log writer.
Public class TestLogWriter

A log records the output of a test during its execution including any text that was written to console output streams, exceptions that occurred, and anything else the test writer might want to save.

A log consists of zero or more log streams that are opened automatically on demand to capture independent sequences of log output. Each stream can further be broken down into possibly nested sections to classify output during different phases of test execution (useful for drilling into complex tests). In addition to text, a log can contain attachments that are either attached at the top level of the log or embedded into log streams. Attachments are typed by mime-type and can contain Text, Xml, Images, Blobs, or any other content. Certain test frameworks may automatically create attachments to gather all manner of diagnostic information over the course of the test.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TextAttachment | Represents a text-encoded attachment. This class cannot be inherited.
Public class | TextualTestLogWriter | An implementation of TestLogWriter that represents the test log as text written to a TextWriter.

Interfaces

 | Interface | Description
Public interface | ITestLogStreamWritable | Interface implemented by objects that can write themselves to a TestLogStreamWriter

Structures

 | Structure | Description
Public structure | Marker | A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly. Several standard marker classes are provided but you may also define your own.

Enumerations

 | Enumeration | Description
Public enumeration | AttachmentContentDisposition | Specifies how attachments are stored in Xml.
Public enumeration | AttachmentEncoding | Specifies the Xml-encoding of an embedded execution log attachment.


Attachment Class

Attachment Class
See Also Example Members
[image]

An attachment is an embedded object in an execution log. An attachment must specify a content type (a MIME type), and some contents. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class Attachment
C#
[SerializableAttribute]
public abstract class Attachment
C++
[SerializableAttribute]
ref class Attachment abstract
J#
/** @attribute SerializableAttribute() */
public class Attachment
JScript
public
SerializableAttribute
class Attachment

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Attachment
Gallio.Model.Logging.BinaryAttachment
Gallio.Model.Logging.TextAttachment

See Also

Attachment Members
Gallio.Model.Logging Namespace


Attachment Members

Attachment Members
See Also Example Properties Methods
[image]

An attachment is an embedded object in an execution log. An attachment must specify a content type (a MIME type), and some contents. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Attachment.

Public Properties

 | Name | Description
Public property | ContentType | Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types.
Public property | Name | Gets the name of the attachment, not null.
Top

Public Methods

 | Name | Description
 | CreateHtmlAttachment | Creates an HTML attachment.
 | CreateImageAttachment | Embeds an image attachment with a mime-type compatible with its internal representation.
 | CreateObjectAsXmlAttachment | Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified serializer.
 | CreatePlainTextAttachment | Creates a plain text attachment.
 | CreateXHtmlAttachment | Creates an XHTML attachment.
 | CreateXmlAttachment | Creates an XML attachment.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FromAttachmentData | Recovers the attachment information from serializable attachment data.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToAttachmentData | Generates serializable attachment data from an attachment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Attachment Class
Gallio.Model.Logging Namespace


Properties

Attachment Properties
[image]

Public Properties

 | Name | Description
Public property | ContentType | Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types.
Public property | Name | Gets the name of the attachment, not null.
Top

See Also

Attachment Class
Gallio.Model.Logging Namespace


ContentType Property

Attachment.ContentType Property
[image]

Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentType As String
C#
public string ContentType { get; }
C++
public property string ContentType sealed {
String get();
}
J#
/** property */
public string get_ContentType();
JScript
public function get ContentType() : String

See Also

Attachment Class
Gallio.Model.Logging Namespace
MimeTypes


Name Property

Attachment.Name Property
[image]

Gets the name of the attachment, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

Attachment Class
Gallio.Model.Logging Namespace


Methods

Attachment Methods
[image]

Public Methods

 | Name | Description
 | CreateHtmlAttachment | Creates an HTML attachment.
 | CreateImageAttachment | Embeds an image attachment with a mime-type compatible with its internal representation.
 | CreateObjectAsXmlAttachment | Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified serializer.
 | CreatePlainTextAttachment | Creates a plain text attachment.
 | CreateXHtmlAttachment | Creates an XHTML attachment.
 | CreateXmlAttachment | Creates an XML attachment.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FromAttachmentData | Recovers the attachment information from serializable attachment data.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToAttachmentData | Generates serializable attachment data from an attachment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Attachment Class
Gallio.Model.Logging Namespace


CreateHtmlAttachment Method

Attachment.CreateHtmlAttachment Method
[image]

Creates an HTML attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateHtmlAttachment( _
ByVal name As String, _
ByVal html As String _
) As TextAttachment
C#
public static TextAttachment CreateHtmlAttachment(
string name,
string html
)
C++
public:
static TextAttachment CreateHtmlAttachment(
String name,
String html
)
J#
public static TextAttachment CreateHtmlAttachment(
string name,
string html
)
JScript
public static function CreateHtmlAttachment(
name : String,
html : String
) : TextAttachment

Parameters

name
The attachment name, or null to automatically assign one
html
The html string, not null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if html is null

See Also

Attachment Class
Gallio.Model.Logging Namespace


CreateImageAttachment Method

Attachment.CreateImageAttachment Method
[image]

Embeds an image attachment with a mime-type compatible with its internal representation.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateImageAttachment( _
ByVal name As String, _
ByVal image As Image _
) As BinaryAttachment
C#
public static BinaryAttachment CreateImageAttachment(
string name,
Image image
)
C++
public:
static BinaryAttachment CreateImageAttachment(
String name,
Image image
)
J#
public static BinaryAttachment CreateImageAttachment(
string name,
Image image
)
JScript
public static function CreateImageAttachment(
name : String,
image : Image
) : BinaryAttachment

Parameters

name
The attachment name, or null to automatically assign one
image
The image to attach

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if image is null

See Also

Attachment Class
Gallio.Model.Logging Namespace


CreateObjectAsXmlAttachment Method

Attachment.CreateObjectAsXmlAttachment Method
[image]

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified serializer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateObjectAsXmlAttachment( _
ByVal name As String, _
ByVal obj As Object, _
ByVal xmlSerializer As XmlSerializer _
) As TextAttachment
C#
public static TextAttachment CreateObjectAsXmlAttachment(
string name,
object obj,
XmlSerializer xmlSerializer
)
C++
public:
static TextAttachment CreateObjectAsXmlAttachment(
String name,
Object obj,
XmlSerializer xmlSerializer
)
J#
public static TextAttachment CreateObjectAsXmlAttachment(
string name,
object obj,
XmlSerializer xmlSerializer
)
JScript
public static function CreateObjectAsXmlAttachment(
name : String,
obj : Object,
xmlSerializer : XmlSerializer
) : TextAttachment

Parameters

name
The attachment name, or null to automatically assign one
obj
The object to serialize and embed, must not be null
xmlSerializer
The xml serializer to use, or null to use the default based on the object's type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null

See Also

Attachment Class
Gallio.Model.Logging Namespace
XmlSerializer


CreatePlainTextAttachment Method

Attachment.CreatePlainTextAttachment Method
[image]

Creates a plain text attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreatePlainTextAttachment( _
ByVal name As String, _
ByVal text As String _
) As TextAttachment
C#
public static TextAttachment CreatePlainTextAttachment(
string name,
string text
)
C++
public:
static TextAttachment CreatePlainTextAttachment(
String name,
String text
)
J#
public static TextAttachment CreatePlainTextAttachment(
string name,
string text
)
JScript
public static function CreatePlainTextAttachment(
name : String,
text : String
) : TextAttachment

Parameters

name
The attachment name, or null to automatically assign one
text
The text string, not null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null

See Also

Attachment Class
Gallio.Model.Logging Namespace


CreateXHtmlAttachment Method

Attachment.CreateXHtmlAttachment Method
[image]

Creates an XHTML attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateXHtmlAttachment( _
ByVal name As String, _
ByVal xhtml As String _
) As TextAttachment
C#
public static TextAttachment CreateXHtmlAttachment(
string name,
string xhtml
)
C++
public:
static TextAttachment CreateXHtmlAttachment(
String name,
String xhtml
)
J#
public static TextAttachment CreateXHtmlAttachment(
string name,
string xhtml
)
JScript
public static function CreateXHtmlAttachment(
name : String,
xhtml : String
) : TextAttachment

Parameters

name
The attachment name, or null to automatically assign one
xhtml
The xhtml string, not null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xhtml is null

See Also

Attachment Class
Gallio.Model.Logging Namespace


CreateXmlAttachment Method

Attachment.CreateXmlAttachment Method
[image]

Creates an XML attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateXmlAttachment( _
ByVal name As String, _
ByVal xml As String _
) As TextAttachment
C#
public static TextAttachment CreateXmlAttachment(
string name,
string xml
)
C++
public:
static TextAttachment CreateXmlAttachment(
String name,
String xml
)
J#
public static TextAttachment CreateXmlAttachment(
string name,
string xml
)
JScript
public static function CreateXmlAttachment(
name : String,
xml : String
) : TextAttachment

Parameters

name
The attachment name, or null to automatically assign one
xml
The XML string, not null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xml is null

See Also

Attachment Class
Gallio.Model.Logging Namespace


FromAttachmentData Method

Attachment.FromAttachmentData Method
[image]

Recovers the attachment information from serializable attachment data.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromAttachmentData( _
ByVal data As AttachmentData _
) As Attachment
C#
public static Attachment FromAttachmentData(
AttachmentData data
)
C++
public:
static Attachment FromAttachmentData(
AttachmentData data
)
J#
public static Attachment FromAttachmentData(
AttachmentData data
)
JScript
public static function FromAttachmentData(
data : AttachmentData
) : Attachment

Parameters

data
The attachment data

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if data is null

See Also

Attachment Class
Gallio.Model.Logging Namespace


ToAttachmentData Method

Attachment.ToAttachmentData Method
[image]

Generates serializable attachment data from an attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function ToAttachmentData() As AttachmentData
C#
public abstract AttachmentData ToAttachmentData()
C++
public:
AttachmentData ToAttachmentData() abstract
J#
public abstract AttachmentData ToAttachmentData()
JScript
public abstract function ToAttachmentData() : AttachmentData

Return Value

The attachment data

See Also

Attachment Class
Gallio.Model.Logging Namespace


AttachmentContentDisposition Enumeration

AttachmentContentDisposition Enumeration
[image]

Specifies how attachments are stored in Xml.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum AttachmentContentDisposition
C#
public enum AttachmentContentDisposition
C++
public enum class AttachmentContentDisposition
J#
public enum AttachmentContentDisposition
JScript
public enum AttachmentContentDisposition

Members

Member Name | Description
Absent | The attachment content is not present.
Link | The attachment content is saved to a linked file indicated by ContentPath.
Inline | The attachment content is included inline as SerializedContents with a given Encoding.

See Also

Gallio.Model.Logging Namespace


AttachmentData Class

AttachmentData Class
See Also Example Members
[image]

An Xml-serializable structure that describes the contents, encoding and disposition of an attachment.

The contents of the attachment are embedded in the execution log according to their encoding. Text is directly embedded into the Xml whereas binary attachments are base 64 encoded.

This class cannot be inherited.
Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class AttachmentData
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class AttachmentData
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class AttachmentData sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class AttachmentData
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class AttachmentData

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.AttachmentData

See Also

AttachmentData Members
Gallio.Model.Logging Namespace


AttachmentData Members

AttachmentData Members
See Also Example Properties Methods
[image]

An Xml-serializable structure that describes the contents, encoding and disposition of an attachment.

The contents of the attachment are embedded in the execution log according to their encoding. Text is directly embedded into the Xml whereas binary attachments are base 64 encoded.

This class cannot be inherited.

The following tables list the members exposed by AttachmentData.

Public Properties

 | Name | Description
Public property | ContentDisposition | Gets or sets the content disposition of the attachment which indicates how the attachment has been stored.
Public property | ContentPath | Gets or sets the path of the attachment contents relative to the directory that contains the Xml serialized report, or null if the content is embedded.
Public property | ContentType | Gets or sets the content type of the attachment as a MIME type, not null.
Public property | Encoding | Gets or sets the encoding of the attachment. This value specifies how the attachment is represented in Xml.
Public property | IsText | Returns true if the attachment is textual, false if it is binary.
Public property | Name | Gets or sets the name of the attachment, not null.
Public property | SerializedContents | Gets or sets the attachment content serialized as text (including Base64 attachments), possibly null if none.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBytes | Gets the binary contents of a binary attachment.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetText | Gets the text contents of a text attachment.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadContents | Loads the attachment contents from a stream.
Public method | SaveContents | Saves the attachment contents to a stream.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


Properties

AttachmentData Properties
[image]

Public Properties

 | Name | Description
Public property | ContentDisposition | Gets or sets the content disposition of the attachment which indicates how the attachment has been stored.
Public property | ContentPath | Gets or sets the path of the attachment contents relative to the directory that contains the Xml serialized report, or null if the content is embedded.
Public property | ContentType | Gets or sets the content type of the attachment as a MIME type, not null.
Public property | Encoding | Gets or sets the encoding of the attachment. This value specifies how the attachment is represented in Xml.
Public property | IsText | Returns true if the attachment is textual, false if it is binary.
Public property | Name | Gets or sets the name of the attachment, not null.
Public property | SerializedContents | Gets or sets the attachment content serialized as text (including Base64 attachments), possibly null if none.
Top

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


ContentDisposition Property

AttachmentData.ContentDisposition Property
[image]

Gets or sets the content disposition of the attachment which indicates how the attachment has been stored.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("contentDisposition")>
Public Property ContentDisposition As AttachmentContentDisposition
C#
[XmlAttributeAttribute("contentDisposition")]
public AttachmentContentDisposition ContentDisposition { get; set; }
C++
[XmlAttributeAttribute(L"contentDisposition")]
public property AttachmentContentDisposition ContentDisposition sealed {
AttachmentContentDisposition get();
void set(AttachmentContentDisposition value);
}
J#
/** @attribute XmlAttributeAttribute("contentDisposition") */
/** property */
public AttachmentContentDisposition get_ContentDisposition();

/** property */
public void set_ContentDisposition(AttachmentContentDisposition value);
JScript
public function get ContentDisposition() : AttachmentContentDisposition

public function set ContentDisposition(value : AttachmentContentDisposition);

Property Value

The content disposition, initially Inline

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


ContentPath Property

AttachmentData.ContentPath Property
[image]

Gets or sets the path of the attachment contents relative to the directory that contains the Xml serialized report, or null if the content is embedded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("contentPath")>
Public Property ContentPath As String
C#
[XmlAttributeAttribute("contentPath")]
public string ContentPath { get; set; }
C++
[XmlAttributeAttribute(L"contentPath")]
public property string ContentPath sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("contentPath") */
/** property */
public string get_ContentPath();

/** property */
public void set_ContentPath(string value);
JScript
public function get ContentPath() : String

public function set ContentPath(value : String);

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


ContentType Property

AttachmentData.ContentType Property
[image]

Gets or sets the content type of the attachment as a MIME type, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("contentType")>
Public Property ContentType As String
C#
[XmlAttributeAttribute("contentType")]
public string ContentType { get; set; }
C++
[XmlAttributeAttribute(L"contentType")]
public property string ContentType sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("contentType") */
/** property */
public string get_ContentType();

/** property */
public void set_ContentType(string value);
JScript
public function get ContentType() : String

public function set ContentType(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


Encoding Property

AttachmentData.Encoding Property
[image]

Gets or sets the encoding of the attachment. This value specifies how the attachment is represented in Xml.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("encoding")>
Public Property Encoding As AttachmentEncoding
C#
[XmlAttributeAttribute("encoding")]
public AttachmentEncoding Encoding { get; set; }
C++
[XmlAttributeAttribute(L"encoding")]
public property AttachmentEncoding Encoding sealed {
AttachmentEncoding get();
void set(AttachmentEncoding value);
}
J#
/** @attribute XmlAttributeAttribute("encoding") */
/** property */
public AttachmentEncoding get_Encoding();

/** property */
public void set_Encoding(AttachmentEncoding value);
JScript
public function get Encoding() : AttachmentEncoding

public function set Encoding(value : AttachmentEncoding);

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


IsText Property

AttachmentData.IsText Property
[image]

Returns true if the attachment is textual, false if it is binary.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsText As Boolean
C#
public bool IsText { get; }
C++
public property bool IsText sealed {
bool get();
}
J#
/** property */
public bool get_IsText();
JScript
public function get IsText() : bool

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


Name Property

AttachmentData.Name Property
[image]

Gets or sets the name of the attachment, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("name")>
Public Property Name As String
C#
[XmlAttributeAttribute("name")]
public string Name { get; set; }
C++
[XmlAttributeAttribute(L"name")]
public property string Name sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("name") */
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


SerializedContents Property

AttachmentData.SerializedContents Property
[image]

Gets or sets the attachment content serialized as text (including Base64 attachments), possibly null if none.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlTextAttribute>
Public Property SerializedContents As String
C#
[XmlTextAttribute]
public string SerializedContents { get; set; }
C++
[XmlTextAttribute]
public property string SerializedContents sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlTextAttribute() */
/** property */
public string get_SerializedContents();

/** property */
public void set_SerializedContents(string value);
JScript
public function get SerializedContents() : String

public function set SerializedContents(value : String);

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


Methods

AttachmentData Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBytes | Gets the binary contents of a binary attachment.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetText | Gets the text contents of a text attachment.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadContents | Loads the attachment contents from a stream.
Public method | SaveContents | Saves the attachment contents to a stream.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


GetBytes Method

AttachmentData.GetBytes Method
[image]

Gets the binary contents of a binary attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetBytes() As Byte()
C#
public byte[] GetBytes()
C++
public:
array<char>^ GetBytes() sealed
J#
public byte[] GetBytes()
JScript
public function GetBytes() : Byte[]

Return Value

The bytes, or null if not available

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the attachment is not binary

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


GetText Method

AttachmentData.GetText Method
[image]

Gets the text contents of a text attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetText() As String
C#
public string GetText()
C++
public:
String GetText() sealed
J#
public string GetText()
JScript
public function GetText() : String

Return Value

The text, or null if not available

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the attachment is not textual

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


LoadContents Method

AttachmentData.LoadContents Method
[image]

Loads the attachment contents from a stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadContents( _
ByVal stream As Stream _
)
C#
public void LoadContents(
Stream stream
)
C++
public:
void LoadContents(
Stream stream
) sealed
J#
public void LoadContents(
Stream stream
)
JScript
public function LoadContents(
stream : Stream
)

Parameters

stream
The stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if stream is null
IOException | If the attachment could not be loaded

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


SaveContents Method

AttachmentData.SaveContents Method
[image]

Saves the attachment contents to a stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveContents( _
ByVal stream As Stream, _
ByVal encoding As Encoding _
)
C#
public void SaveContents(
Stream stream,
Encoding encoding
)
C++
public:
void SaveContents(
Stream stream,
Encoding encoding
) sealed
J#
public void SaveContents(
Stream stream,
Encoding encoding
)
JScript
public function SaveContents(
stream : Stream,
encoding : Encoding
)

Parameters

stream
The stream
encoding
The preferred encoding to use if writing text, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if stream is null
IOException | If the attachment could not be saved
InvalidOperationException | Thrown if the attachment contents are not available

See Also

AttachmentData Class
Gallio.Model.Logging Namespace


AttachmentEncoding Enumeration

AttachmentEncoding Enumeration
[image]

Specifies the Xml-encoding of an embedded execution log attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum AttachmentEncoding
C#
public enum AttachmentEncoding
C++
public enum class AttachmentEncoding
J#
public enum AttachmentEncoding
JScript
public enum AttachmentEncoding

Members

Member Name | Description
Text | The attachment is encoded as a text string.
Base64 | The attachment is encoded as base 64 text string.

See Also

Gallio.Model.Logging Namespace


BinaryAttachment Class

BinaryAttachment Class
See Also Example Members
[image]

Represents a binary-encoded attachments. This class cannot be inherited.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class BinaryAttachment
Inherits Attachment
Implements IEquatable(Of BinaryAttachment)
C#
[SerializableAttribute]
public sealed class BinaryAttachment : Attachment, IEquatable<BinaryAttachment>
C++
[SerializableAttribute]
ref class BinaryAttachment sealed : Attachment, IEquatable<BinaryAttachment>
J#
/** @attribute SerializableAttribute() */
public final class BinaryAttachment extends Attachment implements IEquatable<BinaryAttachment>
JScript
public
SerializableAttribute
final class BinaryAttachment extends Attachment, IEquatable<BinaryAttachment>

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Attachment
Gallio.Model.Logging.BinaryAttachment

See Also

BinaryAttachment Members
Gallio.Model.Logging Namespace


BinaryAttachment Members

BinaryAttachment Members
See Also Example Constructors Properties Methods
[image]

Represents a binary-encoded attachments. This class cannot be inherited.

The following tables list the members exposed by BinaryAttachment.

Public Constructors

 | Name | Description
Public method | BinaryAttachment | Creates an attachment.
Top

Public Properties

 | Name | Description
Public property | Bytes | Gets the binary content of the attachment, not null.
Public property | ContentType | Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types. (inherited from Attachment)
Public property | Name | Gets the name of the attachment, not null. (inherited from Attachment)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToAttachmentData | Overridden. Generates serializable attachment data from an attachment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


BinaryAttachment Constructor

BinaryAttachment Constructor
[image]

Creates an attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal contentType As String, _
ByVal bytes As Byte() _
)
C#
public BinaryAttachment(
string name,
string contentType,
byte[] bytes
)
C++
public:
BinaryAttachment(
String name,
String contentType,
array<char>^ bytes
) sealed
J#
public BinaryAttachment(
string name,
string contentType,
byte[] bytes
)
JScript
public function BinaryAttachment(
name : String,
contentType : String,
bytes : Byte[]
)

Parameters

name
The attachment name, not null
contentType
The content type, not null
bytes
The binary data, not null

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if contentType or bytes is null

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


Properties

BinaryAttachment Properties
[image]

Public Properties

 | Name | Description
Public property | Bytes | Gets the binary content of the attachment, not null.
Public property | ContentType | Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types. (inherited from Attachment)
Public property | Name | Gets the name of the attachment, not null. (inherited from Attachment)
Top

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


Bytes Property

BinaryAttachment.Bytes Property
[image]

Gets the binary content of the attachment, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bytes As Byte()
C#
public byte[] Bytes { get; }
C++
public property byte[] Bytes sealed {
array<char>^ get();
}
J#
/** property */
public byte[] get_Bytes();
JScript
public function get Bytes() : Byte[]

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


Methods

BinaryAttachment Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToAttachmentData | Overridden. Generates serializable attachment data from an attachment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


Equals Method

BinaryAttachment.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (BinaryAttachment) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


Equals Method (BinaryAttachment)

BinaryAttachment.Equals Method (BinaryAttachment)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As BinaryAttachment _
) As Boolean _
Implements IEquatable<BinaryAttachment>.Equals
C#
public bool Equals(
BinaryAttachment other
)
C++
public:
bool Equals(
BinaryAttachment other
) sealed
J#
public bool Equals(
BinaryAttachment other
)
JScript
public function Equals(
other : BinaryAttachment
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<BinaryAttachment>.Equals

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace
BinaryAttachment.Equals Overload List


Equals Method (Object)

BinaryAttachment.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace
BinaryAttachment.Equals Overload List


GetHashCode Method

BinaryAttachment.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


ToAttachmentData Method

BinaryAttachment.ToAttachmentData Method
[image]

Generates serializable attachment data from an attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToAttachmentData() As AttachmentData
C#
public override AttachmentData ToAttachmentData()
C++
public:
virtual AttachmentData ToAttachmentData() override
J#
public override AttachmentData ToAttachmentData()
JScript
public override function ToAttachmentData() : AttachmentData

Return Value

The attachment data

See Also

BinaryAttachment Class
Gallio.Model.Logging Namespace


FallbackTestLogWriter Class

FallbackTestLogWriter Class
See Also Example Members
[image]

A test log writer that falls back to a different test log writer for certain operations when its primary test log writer is closed.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FallbackTestLogWriter
Inherits TestLogWriter
C#
public class FallbackTestLogWriter : TestLogWriter
C++
ref class FallbackTestLogWriter : TestLogWriter
J#
public class FallbackTestLogWriter extends TestLogWriter
JScript
public class FallbackTestLogWriter extends TestLogWriter

Remarks

Not all operations are delegated to the fallback log writer. Some, such as embedding attachments and entering or exiting nested scopes, are excluded due to potential errors that may occur because the fallback test writer may not have seen the previous operation to add the attachment or enter the scope.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Logging.FallbackTestLogWriter

See Also

FallbackTestLogWriter Members
Gallio.Model.Logging Namespace


FallbackTestLogWriter Members

FallbackTestLogWriter Members
See Also Example Constructors Properties Methods
[image]

A test log writer that falls back to a different test log writer for certain operations when its primary test log writer is closed.

The following tables list the members exposed by FallbackTestLogWriter.

Public Constructors

 | Name | Description
Public method | FallbackTestLogWriter | Creates a fallback test log writer with the specified provider.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


FallbackTestLogWriter Constructor

FallbackTestLogWriter Constructor
[image]

Creates a fallback test log writer with the specified provider.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal primary As TestLogWriter, _
ByVal fallback As TestLogWriter _
)
C#
public FallbackTestLogWriter(
TestLogWriter primary,
TestLogWriter fallback
)
C++
public:
FallbackTestLogWriter(
TestLogWriter primary,
TestLogWriter fallback
) sealed
J#
public FallbackTestLogWriter(
TestLogWriter primary,
TestLogWriter fallback
)
JScript
public function FallbackTestLogWriter(
primary : TestLogWriter,
fallback : TestLogWriter
)

Parameters

primary
The test log writer to call by default
fallback
The test log writer to call as a fallback

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if primary or fallback is null

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


Methods

FallbackTestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


AttachImpl Method

FallbackTestLogWriter.AttachImpl Method
[image]

Adds an attachment to the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AttachImpl( _
ByVal attachment As Attachment _
)
C#
protected override void AttachImpl(
Attachment attachment
)
C++
protected:
virtual void AttachImpl(
Attachment attachment
) override
J#
protected override void AttachImpl(
Attachment attachment
)
JScript
protected override function AttachImpl(
attachment : Attachment
)

Parameters

attachment
The attachment to write, never null

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginMarkerImpl Method

FallbackTestLogWriter.StreamBeginMarkerImpl Method
[image]

Begins a marked region in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginMarkerImpl( _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
C++
protected:
virtual void StreamBeginMarkerImpl(
String streamName,
Marker marker
) override
J#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
JScript
protected override function StreamBeginMarkerImpl(
streamName : String,
marker : Marker
)

Parameters

streamName
The log stream name
marker
The marker

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginSectionImpl Method

FallbackTestLogWriter.StreamBeginSectionImpl Method
[image]

Begins a section in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginSectionImpl( _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
C++
protected:
virtual void StreamBeginSectionImpl(
String streamName,
String sectionName
) override
J#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
JScript
protected override function StreamBeginSectionImpl(
streamName : String,
sectionName : String
)

Parameters

streamName
The log stream name
sectionName
The name of the section to begin, never null

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEmbedImpl Method

FallbackTestLogWriter.StreamEmbedImpl Method
[image]

Embeds an attachment into a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEmbedImpl( _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
C++
protected:
virtual void StreamEmbedImpl(
String streamName,
String attachmentName
) override
J#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
JScript
protected override function StreamEmbedImpl(
streamName : String,
attachmentName : String
)

Parameters

streamName
The log stream name
attachmentName
The name of the attachment to write, never null

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEndImpl Method

FallbackTestLogWriter.StreamEndImpl Method
[image]

Ends the current region started with one of the Begin* methods in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEndImpl( _
ByVal streamName As String _
)
C#
protected override void StreamEndImpl(
string streamName
)
C++
protected:
virtual void StreamEndImpl(
String streamName
) override
J#
protected override void StreamEndImpl(
string streamName
)
JScript
protected override function StreamEndImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


StreamWriteImpl Method

FallbackTestLogWriter.StreamWriteImpl Method
[image]

Writes a text string to a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamWriteImpl( _
ByVal streamName As String, _
ByVal text As String _
)
C#
protected override void StreamWriteImpl(
string streamName,
string text
)
C++
protected:
virtual void StreamWriteImpl(
String streamName,
String text
) override
J#
protected override void StreamWriteImpl(
string streamName,
string text
)
JScript
protected override function StreamWriteImpl(
streamName : String,
text : String
)

Parameters

streamName
The log stream name
text
The text to write, never null

See Also

FallbackTestLogWriter Class
Gallio.Model.Logging Namespace


ITestLogStreamWritable Interface

ITestLogStreamWritable Interface
See Also Example Members
[image]

Interface implemented by objects that can write themselves to a TestLogStreamWriter

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestLogStreamWritable
C#
public interface ITestLogStreamWritable
C++
interface class ITestLogStreamWritable
J#
public interface ITestLogStreamWritable
JScript
public interface ITestLogStreamWritable

Types that implement ITestLogStreamWritable

Type | Description
Gallio.Framework.Assertions.AssertionFailure

An assertion failure is an immutable description of a failed assertion and its cause. It takes into account information about labeled values such as the expected and actual value.

Use an AssertionFailureBuilder to generate an instance of this type.

Gallio.Framework.Text.DiffSet

A diff set consists of a sequence of differences between a left document and a right document that indicate changed and unchanged regions.

If the changes are applied in order to the left document, the right document will be reproduced. If the inverse changes are applied in order to the right document, the left document will be reproduced.

This class cannot be inherited.
Gallio.Model.Diagnostics.ExceptionData | Describes an exception in a serializable form. This class cannot be inherited.
Gallio.Model.Diagnostics.StackTraceData | Describes a stack trace in a serializable form. This class cannot be inherited.
Gallio.Model.Logging.StructuredTestLogStream

A structured log stream object represents a recursively structured stream of rich text that supports embedded attachments, nested sections and marked regions. Each part of the text is captured by a tag, some of which are composable and may therefore contain other tags.

It is effectively an xml-serializable representation of a test log stream written by a TestLogStreamWriter.

This class cannot be inherited.
Gallio.Model.Logging.StructuredText

A structured text object contains attachments and formatted text with rich presentation elements.

Structured text is emitted by a StructuredTextWriter.

This class cannot be inherited.
Gallio.Model.Logging.StructuredTextWriter | Writes log information in a structured manner so as to produce a StructuredText or String.
Gallio.Model.Logging.Tags.Tag | An tag represents a portion of the contents of a structured test log stream. Each one can be thought of as a command that will regenerate the structured test log stream when written back out. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestLogStreamWritable Members
Gallio.Model.Logging Namespace


ITestLogStreamWritable Members

ITestLogStreamWritable Members
See Also Example Methods
[image]

Interface implemented by objects that can write themselves to a TestLogStreamWriter

The following tables list the members exposed by ITestLogStreamWritable.

Public Methods

 | Name | Description
Public method | WriteTo | Writes the object to a test log stream.
Top

See Also

ITestLogStreamWritable Interface
Gallio.Model.Logging Namespace


Methods

ITestLogStreamWritable Methods
[image]

Public Methods

 | Name | Description
Public method | WriteTo | Writes the object to a test log stream.
Top

See Also

ITestLogStreamWritable Interface
Gallio.Model.Logging Namespace


WriteTo Method

ITestLogStreamWritable.WriteTo Method
[image]

Writes the object to a test log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
)
C#
void WriteTo(
TestLogStreamWriter writer
)
C++
void WriteTo(
TestLogStreamWriter writer
) abstract
J#
void WriteTo(
TestLogStreamWriter writer
)
JScript
function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The test log stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

ITestLogStreamWritable Interface
Gallio.Model.Logging Namespace


Marker Structure

Marker Structure
See Also Example Members
[image]

A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.

Several standard marker classes are provided but you may also define your own.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Structure Marker
Implements IEquatable(Of Marker)
C#
[SerializableAttribute]
public struct Marker : IEquatable<Marker>
C++
[SerializableAttribute]
value class Marker : IEquatable<Marker>
J#
/** @attribute SerializableAttribute() */
public final class Marker extends ValueType implements IEquatable<Marker>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Marker

See Also

Marker Members
Gallio.Model.Logging Namespace


Marker Members

Marker Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.

Several standard marker classes are provided but you may also define your own.

The following tables list the members exposed by Marker.

Public Constructors

Name | Description
Marker | Overloaded.
Top

Public Fields

Name | Description
AssertionFailureClass | Standard marker class for assertion failures. This field is constant and read-only.
CodeLocationClass | Standard marker class for code location references. This field is constant and read-only.
CodeLocationColumnNumberAttrib | Column attribute for code location references. This field is constant and read-only.
CodeLocationLineNumberAttrib | Line attribute for code location references. This field is constant and read-only.
CodeLocationPathAttrib | Path attribute for code location references. This field is constant and read-only.
DiffAdditionClass | Standard marker class for content that represents added content in a diff. This field is constant and read-only.
DiffChangeClass | Standard marker class for content that represents changed content in a diff. This field is constant and read-only.
DiffDeletionClass | Standard marker class for content that represents deleted content in a diff. This field is constant and read-only.
EllipsisClass | Standard marker class for content that has been elided and may be made available instead as an attribute. This field is constant and read-only.
ExceptionClass | Standard marker class for exceptions including their details. This field is constant and read-only.
ExceptionMessageClass | Standard marker class for exception messages reported as part of exception details. This field is constant and read-only.
ExceptionTypeClass | Standard marker class for exception types reported as part of exception details. This field is constant and read-only.
HighlightClass | Standard marker class for content that should be displayed with a highlight. This field is constant and read-only.
LabelClass | Standard marker class for labels and headings. This field is constant and read-only.
LinkClass | Standard marker class for link to a url. This field is constant and read-only.
LinkUrlAttrib | Url attribute for links. This field is constant and read-only.
MonospaceClass | Standard marker class for fixed width output such as that from a console or structured table. This field is constant and read-only.
StackTraceClass | Standard marker class for stack traces. This field is constant and read-only.
Top

Public Properties

 | Name | Description
 | AssertionFailure | Standard marker for assertion failures.
Public property | Attributes | Gets the marker's attributes which are optional name/value pairs associated with a marker to carry additional semantic content.
Public property | Class | Gets the marker class.
 | DiffAddition | Standard marker for content that represents added content in a diff.
 | DiffChange | Standard marker for content that represents changed content in a diff.
 | DiffDeletion | Standard marker for content that represents deleted content in a diff.
 | Ellipsis | Standard marker for text that is elided and replaced by an ellipsis.
 | Exception | Standard marker for exceptions including their details.
 | ExceptionMessage | Standard marker for exception messages reported as part of exception details.
 | ExceptionType | Standard marker for exception types reported as part of exception details.
 | Highlight | Standard marker for content that should be displayed with a highlight.
 | Label | Standard marker for labels and headings.
 | Monospace | Standard marker for fixed width output such as that from a console or structured table.
 | StackTrace | Standard marker for stack traces.
Top

Public Methods

 | Name | Description
 | CodeLocation | Creates a standard marker for a code location.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | Link | Creates a standard marker for a link to a Url.
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
 | ValidateIdentifier | Verifies that the parameter is a valid marker class or attribute identifier.
Public method | WithAttribute | Creates a copy of the marker with the specified attribute added.
Top

Explicit Interface Implementations

Name | Description
Marker | Overloaded.
Top

See Also

Marker Structure
Gallio.Model.Logging Namespace


Marker Constructor

Marker Constructor

Overload List

 | Name | Description
Public method | Marker (String) | Creates a marker.
Public method | Marker (String, IDictionary<string, string>) | Creates a marker with attributes.

See Also

Marker Structure
Gallio.Model.Logging Namespace


Marker Constructor (String)

Marker Constructor (String)
See Also Example
[image]

Creates a marker.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal class As String _
)
C#
public Marker(
string class
)
C++
public:
Marker(
String class
) sealed
J#
public Marker(
string class
)
JScript
public function Marker(
class : String
)

Parameters

class
The marker class

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if class is null
ArgumentException | Thrown if the class is not a valid identifier.

See Also

Marker Structure
Gallio.Model.Logging Namespace
Marker Constructor Overload List
ValidateIdentifier


Marker Constructor (String, Generic IDictionary)

Marker Constructor (String, Generic IDictionary)
See Also Example
[image]

Creates a marker with attributes.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal class As String, _
ByVal attributes As IDictionary(Of String, String) _
)
C#
public Marker(
string class,
IDictionary<string, string> attributes
)
C++
public:
Marker(
String class,
IDictionary<string, string> attributes
) sealed
J#
public Marker(
string class,
IDictionary<string, string> attributes
)
JScript
public function Marker(
class : String,
attributes : IDictionary<string, string>
)

Parameters

class
The marker class
attributes
The attributes

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if class or attributes is null
ArgumentException | Thrown if the class is not a valid identifier.

See Also

Marker Structure
Gallio.Model.Logging Namespace
Marker Constructor Overload List
ValidateIdentifier


Fields

Marker Fields
[image]

Public Fields

Name | Description
AssertionFailureClass | Standard marker class for assertion failures. This field is constant and read-only.
CodeLocationClass | Standard marker class for code location references. This field is constant and read-only.
CodeLocationColumnNumberAttrib | Column attribute for code location references. This field is constant and read-only.
CodeLocationLineNumberAttrib | Line attribute for code location references. This field is constant and read-only.
CodeLocationPathAttrib | Path attribute for code location references. This field is constant and read-only.
DiffAdditionClass | Standard marker class for content that represents added content in a diff. This field is constant and read-only.
DiffChangeClass | Standard marker class for content that represents changed content in a diff. This field is constant and read-only.
DiffDeletionClass | Standard marker class for content that represents deleted content in a diff. This field is constant and read-only.
EllipsisClass | Standard marker class for content that has been elided and may be made available instead as an attribute. This field is constant and read-only.
ExceptionClass | Standard marker class for exceptions including their details. This field is constant and read-only.
ExceptionMessageClass | Standard marker class for exception messages reported as part of exception details. This field is constant and read-only.
ExceptionTypeClass | Standard marker class for exception types reported as part of exception details. This field is constant and read-only.
HighlightClass | Standard marker class for content that should be displayed with a highlight. This field is constant and read-only.
LabelClass | Standard marker class for labels and headings. This field is constant and read-only.
LinkClass | Standard marker class for link to a url. This field is constant and read-only.
LinkUrlAttrib | Url attribute for links. This field is constant and read-only.
MonospaceClass | Standard marker class for fixed width output such as that from a console or structured table. This field is constant and read-only.
StackTraceClass | Standard marker class for stack traces. This field is constant and read-only.
Top

See Also

Marker Structure
Gallio.Model.Logging Namespace


AssertionFailureClass Field

Marker.AssertionFailureClass Field
[image]

Standard marker class for assertion failures. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const AssertionFailureClass As String = "AssertionFailure"
C#
public const string AssertionFailureClass = "AssertionFailure";
C++
public:
const String AssertionFailureClass = L"AssertionFailure";
J#
public const string AssertionFailureClass = "AssertionFailure"
JScript
public const AssertionFailureClass : String = "AssertionFailure";

See Also

Marker Structure
Gallio.Model.Logging Namespace


CodeLocationClass Field

Marker.CodeLocationClass Field
[image]

Standard marker class for code location references. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const CodeLocationClass As String = "CodeLocation"
C#
public const string CodeLocationClass = "CodeLocation";
C++
public:
const String CodeLocationClass = L"CodeLocation";
J#
public const string CodeLocationClass = "CodeLocation"
JScript
public const CodeLocationClass : String = "CodeLocation";

See Also

Marker Structure
Gallio.Model.Logging Namespace


CodeLocationColumnNumberAttrib Field

Marker.CodeLocationColumnNumberAttrib Field
[image]

Column attribute for code location references. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const CodeLocationColumnNumberAttrib As String = "column"
C#
public const string CodeLocationColumnNumberAttrib = "column";
C++
public:
const String CodeLocationColumnNumberAttrib = L"column";
J#
public const string CodeLocationColumnNumberAttrib = "column"
JScript
public const CodeLocationColumnNumberAttrib : String = "column";

See Also

Marker Structure
Gallio.Model.Logging Namespace


CodeLocationLineNumberAttrib Field

Marker.CodeLocationLineNumberAttrib Field
[image]

Line attribute for code location references. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const CodeLocationLineNumberAttrib As String = "line"
C#
public const string CodeLocationLineNumberAttrib = "line";
C++
public:
const String CodeLocationLineNumberAttrib = L"line";
J#
public const string CodeLocationLineNumberAttrib = "line"
JScript
public const CodeLocationLineNumberAttrib : String = "line";

See Also

Marker Structure
Gallio.Model.Logging Namespace


CodeLocationPathAttrib Field

Marker.CodeLocationPathAttrib Field
[image]

Path attribute for code location references. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const CodeLocationPathAttrib As String = "path"
C#
public const string CodeLocationPathAttrib = "path";
C++
public:
const String CodeLocationPathAttrib = L"path";
J#
public const string CodeLocationPathAttrib = "path"
JScript
public const CodeLocationPathAttrib : String = "path";

See Also

Marker Structure
Gallio.Model.Logging Namespace


DiffAdditionClass Field

Marker.DiffAdditionClass Field
[image]

Standard marker class for content that represents added content in a diff. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const DiffAdditionClass As String = "DiffAddition"
C#
public const string DiffAdditionClass = "DiffAddition";
C++
public:
const String DiffAdditionClass = L"DiffAddition";
J#
public const string DiffAdditionClass = "DiffAddition"
JScript
public const DiffAdditionClass : String = "DiffAddition";

See Also

Marker Structure
Gallio.Model.Logging Namespace


DiffChangeClass Field

Marker.DiffChangeClass Field
[image]

Standard marker class for content that represents changed content in a diff. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const DiffChangeClass As String = "DiffChange"
C#
public const string DiffChangeClass = "DiffChange";
C++
public:
const String DiffChangeClass = L"DiffChange";
J#
public const string DiffChangeClass = "DiffChange"
JScript
public const DiffChangeClass : String = "DiffChange";

See Also

Marker Structure
Gallio.Model.Logging Namespace


DiffDeletionClass Field

Marker.DiffDeletionClass Field
[image]

Standard marker class for content that represents deleted content in a diff. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const DiffDeletionClass As String = "DiffDeletion"
C#
public const string DiffDeletionClass = "DiffDeletion";
C++
public:
const String DiffDeletionClass = L"DiffDeletion";
J#
public const string DiffDeletionClass = "DiffDeletion"
JScript
public const DiffDeletionClass : String = "DiffDeletion";

See Also

Marker Structure
Gallio.Model.Logging Namespace


EllipsisClass Field

Marker.EllipsisClass Field
[image]

Standard marker class for content that has been elided and may be made available instead as an attribute. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const EllipsisClass As String = "Ellipsis"
C#
public const string EllipsisClass = "Ellipsis";
C++
public:
const String EllipsisClass = L"Ellipsis";
J#
public const string EllipsisClass = "Ellipsis"
JScript
public const EllipsisClass : String = "Ellipsis";

See Also

Marker Structure
Gallio.Model.Logging Namespace


ExceptionClass Field

Marker.ExceptionClass Field
[image]

Standard marker class for exceptions including their details. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ExceptionClass As String = "Exception"
C#
public const string ExceptionClass = "Exception";
C++
public:
const String ExceptionClass = L"Exception";
J#
public const string ExceptionClass = "Exception"
JScript
public const ExceptionClass : String = "Exception";

See Also

Marker Structure
Gallio.Model.Logging Namespace


ExceptionMessageClass Field

Marker.ExceptionMessageClass Field
[image]

Standard marker class for exception messages reported as part of exception details. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ExceptionMessageClass As String = "ExceptionMessage"
C#
public const string ExceptionMessageClass = "ExceptionMessage";
C++
public:
const String ExceptionMessageClass = L"ExceptionMessage";
J#
public const string ExceptionMessageClass = "ExceptionMessage"
JScript
public const ExceptionMessageClass : String = "ExceptionMessage";

See Also

Marker Structure
Gallio.Model.Logging Namespace


ExceptionTypeClass Field

Marker.ExceptionTypeClass Field
[image]

Standard marker class for exception types reported as part of exception details. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ExceptionTypeClass As String = "ExceptionType"
C#
public const string ExceptionTypeClass = "ExceptionType";
C++
public:
const String ExceptionTypeClass = L"ExceptionType";
J#
public const string ExceptionTypeClass = "ExceptionType"
JScript
public const ExceptionTypeClass : String = "ExceptionType";

See Also

Marker Structure
Gallio.Model.Logging Namespace


HighlightClass Field

Marker.HighlightClass Field
[image]

Standard marker class for content that should be displayed with a highlight. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const HighlightClass As String = "Highlight"
C#
public const string HighlightClass = "Highlight";
C++
public:
const String HighlightClass = L"Highlight";
J#
public const string HighlightClass = "Highlight"
JScript
public const HighlightClass : String = "Highlight";

See Also

Marker Structure
Gallio.Model.Logging Namespace


LabelClass Field

Marker.LabelClass Field
[image]

Standard marker class for labels and headings. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const LabelClass As String = "Label"
C#
public const string LabelClass = "Label";
C++
public:
const String LabelClass = L"Label";
J#
public const string LabelClass = "Label"
JScript
public const LabelClass : String = "Label";

See Also

Marker Structure
Gallio.Model.Logging Namespace


LinkClass Field

Marker.LinkClass Field
[image]

Standard marker class for link to a url. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const LinkClass As String = "Link"
C#
public const string LinkClass = "Link";
C++
public:
const String LinkClass = L"Link";
J#
public const string LinkClass = "Link"
JScript
public const LinkClass : String = "Link";

See Also

Marker Structure
Gallio.Model.Logging Namespace


LinkUrlAttrib Field

Marker.LinkUrlAttrib Field
[image]

Url attribute for links. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const LinkUrlAttrib As String = "url"
C#
public const string LinkUrlAttrib = "url";
C++
public:
const String LinkUrlAttrib = L"url";
J#
public const string LinkUrlAttrib = "url"
JScript
public const LinkUrlAttrib : String = "url";

See Also

Marker Structure
Gallio.Model.Logging Namespace


MonospaceClass Field

Marker.MonospaceClass Field
[image]

Standard marker class for fixed width output such as that from a console or structured table. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const MonospaceClass As String = "Monospace"
C#
public const string MonospaceClass = "Monospace";
C++
public:
const String MonospaceClass = L"Monospace";
J#
public const string MonospaceClass = "Monospace"
JScript
public const MonospaceClass : String = "Monospace";

See Also

Marker Structure
Gallio.Model.Logging Namespace


StackTraceClass Field

Marker.StackTraceClass Field
[image]

Standard marker class for stack traces. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const StackTraceClass As String = "StackTrace"
C#
public const string StackTraceClass = "StackTrace";
C++
public:
const String StackTraceClass = L"StackTrace";
J#
public const string StackTraceClass = "StackTrace"
JScript
public const StackTraceClass : String = "StackTrace";

See Also

Marker Structure
Gallio.Model.Logging Namespace


Properties

Marker Properties
[image]

Public Properties

 | Name | Description
 | AssertionFailure | Standard marker for assertion failures.
Public property | Attributes | Gets the marker's attributes which are optional name/value pairs associated with a marker to carry additional semantic content.
Public property | Class | Gets the marker class.
 | DiffAddition | Standard marker for content that represents added content in a diff.
 | DiffChange | Standard marker for content that represents changed content in a diff.
 | DiffDeletion | Standard marker for content that represents deleted content in a diff.
 | Ellipsis | Standard marker for text that is elided and replaced by an ellipsis.
 | Exception | Standard marker for exceptions including their details.
 | ExceptionMessage | Standard marker for exception messages reported as part of exception details.
 | ExceptionType | Standard marker for exception types reported as part of exception details.
 | Highlight | Standard marker for content that should be displayed with a highlight.
 | Label | Standard marker for labels and headings.
 | Monospace | Standard marker for fixed width output such as that from a console or structured table.
 | StackTrace | Standard marker for stack traces.
Top

See Also

Marker Structure
Gallio.Model.Logging Namespace


AssertionFailure Property

Marker.AssertionFailure Property
[image]

Standard marker for assertion failures.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AssertionFailure As Marker
C#
public static Marker AssertionFailure { get; }
C++
public static property Marker AssertionFailure {
Marker get();
}
J#
/** property */
public Marker get_AssertionFailure();
JScript
public function get AssertionFailure() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Attributes Property

Marker.Attributes Property
[image]

Gets the marker's attributes which are optional name/value pairs associated with a marker to carry additional semantic content.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attributes As IDictionary(Of String, String)
C#
public IDictionary<string, string> Attributes { get; }
C++
public property IDictionary<string, string> Attributes sealed {
IDictionary<string, string> get();
}
J#
/** property */
public IDictionary<string, string> get_Attributes();
JScript
public function get Attributes() : IDictionary<string, string>

See Also

Marker Structure
Gallio.Model.Logging Namespace


Class Property

Marker.Class Property
[image]

Gets the marker class.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Class As String
C#
public string Class { get; }
C++
public property string Class sealed {
String get();
}
J#
/** property */
public string get_Class();
JScript
public function get Class() : String

See Also

Marker Structure
Gallio.Model.Logging Namespace


DiffAddition Property

Marker.DiffAddition Property
[image]

Standard marker for content that represents added content in a diff.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DiffAddition As Marker
C#
public static Marker DiffAddition { get; }
C++
public static property Marker DiffAddition {
Marker get();
}
J#
/** property */
public Marker get_DiffAddition();
JScript
public function get DiffAddition() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


DiffChange Property

Marker.DiffChange Property
[image]

Standard marker for content that represents changed content in a diff.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DiffChange As Marker
C#
public static Marker DiffChange { get; }
C++
public static property Marker DiffChange {
Marker get();
}
J#
/** property */
public Marker get_DiffChange();
JScript
public function get DiffChange() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


DiffDeletion Property

Marker.DiffDeletion Property
[image]

Standard marker for content that represents deleted content in a diff.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DiffDeletion As Marker
C#
public static Marker DiffDeletion { get; }
C++
public static property Marker DiffDeletion {
Marker get();
}
J#
/** property */
public Marker get_DiffDeletion();
JScript
public function get DiffDeletion() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Ellipsis Property

Marker.Ellipsis Property
[image]

Standard marker for text that is elided and replaced by an ellipsis.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Ellipsis As Marker
C#
public static Marker Ellipsis { get; }
C++
public static property Marker Ellipsis {
Marker get();
}
J#
/** property */
public Marker get_Ellipsis();
JScript
public function get Ellipsis() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Exception Property

Marker.Exception Property
[image]

Standard marker for exceptions including their details.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Exception As Marker
C#
public static Marker Exception { get; }
C++
public static property Marker Exception {
Marker get();
}
J#
/** property */
public Marker get_Exception();
JScript
public function get Exception() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


ExceptionMessage Property

Marker.ExceptionMessage Property
[image]

Standard marker for exception messages reported as part of exception details.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ExceptionMessage As Marker
C#
public static Marker ExceptionMessage { get; }
C++
public static property Marker ExceptionMessage {
Marker get();
}
J#
/** property */
public Marker get_ExceptionMessage();
JScript
public function get ExceptionMessage() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


ExceptionType Property

Marker.ExceptionType Property
[image]

Standard marker for exception types reported as part of exception details.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ExceptionType As Marker
C#
public static Marker ExceptionType { get; }
C++
public static property Marker ExceptionType {
Marker get();
}
J#
/** property */
public Marker get_ExceptionType();
JScript
public function get ExceptionType() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Highlight Property

Marker.Highlight Property
[image]

Standard marker for content that should be displayed with a highlight.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Highlight As Marker
C#
public static Marker Highlight { get; }
C++
public static property Marker Highlight {
Marker get();
}
J#
/** property */
public Marker get_Highlight();
JScript
public function get Highlight() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Label Property

Marker.Label Property
[image]

Standard marker for labels and headings.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Label As Marker
C#
public static Marker Label { get; }
C++
public static property Marker Label {
Marker get();
}
J#
/** property */
public Marker get_Label();
JScript
public function get Label() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Monospace Property

Marker.Monospace Property
[image]

Standard marker for fixed width output such as that from a console or structured table.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Monospace As Marker
C#
public static Marker Monospace { get; }
C++
public static property Marker Monospace {
Marker get();
}
J#
/** property */
public Marker get_Monospace();
JScript
public function get Monospace() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


StackTrace Property

Marker.StackTrace Property
[image]

Standard marker for stack traces.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property StackTrace As Marker
C#
public static Marker StackTrace { get; }
C++
public static property Marker StackTrace {
Marker get();
}
J#
/** property */
public Marker get_StackTrace();
JScript
public function get StackTrace() : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Methods

Marker Methods
[image]

Public Methods

 | Name | Description
 | CodeLocation | Creates a standard marker for a code location.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | Link | Creates a standard marker for a link to a Url.
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
 | ValidateIdentifier | Verifies that the parameter is a valid marker class or attribute identifier.
Public method | WithAttribute | Creates a copy of the marker with the specified attribute added.
Top

See Also

Marker Structure
Gallio.Model.Logging Namespace


CodeLocation Method

Marker.CodeLocation Method
[image]

Creates a standard marker for a code location.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CodeLocation( _
ByVal location As CodeLocation _
) As Marker
C#
public static Marker CodeLocation(
CodeLocation location
)
C++
public:
static Marker CodeLocation(
CodeLocation location
)
J#
public static Marker CodeLocation(
CodeLocation location
)
JScript
public static function CodeLocation(
location : CodeLocation
) : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


Equals Method

Marker.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (Marker) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

Marker Structure
Gallio.Model.Logging Namespace


Equals Method (Marker)

Marker.Equals Method (Marker)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As Marker _
) As Boolean _
Implements IEquatable<Marker>.Equals
C#
public bool Equals(
Marker other
)
C++
public:
bool Equals(
Marker other
) sealed
J#
public bool Equals(
Marker other
)
JScript
public function Equals(
other : Marker
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<Marker>.Equals

See Also

Marker Structure
Gallio.Model.Logging Namespace
Marker.Equals Overload List


Equals Method (Object)

Marker.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Marker Structure
Gallio.Model.Logging Namespace
Marker.Equals Overload List


GetHashCode Method

Marker.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Marker Structure
Gallio.Model.Logging Namespace


Link Method

Marker.Link Method
[image]

Creates a standard marker for a link to a Url.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Link( _
ByVal url As String _
) As Marker
C#
public static Marker Link(
string url
)
C++
public:
static Marker Link(
String url
)
J#
public static Marker Link(
string url
)
JScript
public static function Link(
url : String
) : Marker

See Also

Marker Structure
Gallio.Model.Logging Namespace


op_Equality Operator

Marker.op_Equality Operator
[image]

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As Marker, _
ByVal b As Marker _
) As Boolean
C#
public static bool operator ==(
Marker a,
Marker b
)
C++
public:
static bool operator ==(
Marker a,
Marker b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Marker Structure
Gallio.Model.Logging Namespace


op_Inequality Operator

Marker.op_Inequality Operator
[image]

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As Marker, _
ByVal b As Marker _
) As Boolean
C#
public static bool operator !=(
Marker a,
Marker b
)
C++
public:
static bool operator !=(
Marker a,
Marker b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

Marker Structure
Gallio.Model.Logging Namespace


ToString Method

Marker.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

Marker Structure
Gallio.Model.Logging Namespace


ValidateIdentifier Method

Marker.ValidateIdentifier Method
[image]

Verifies that the parameter is a valid marker class or attribute identifier.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ValidateIdentifier( _
ByVal identifier As String _
)
C#
public static void ValidateIdentifier(
string identifier
)
C++
public:
static void ValidateIdentifier(
String identifier
)
J#
public static void ValidateIdentifier(
string identifier
)
JScript
public static function ValidateIdentifier(
identifier : String
)

Parameters

identifier
The identifier

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if identifier is null
ArgumentException | Thrown if identifier is empty or contains characters other than letters, digits and underscores

See Also

Marker Structure
Gallio.Model.Logging Namespace


WithAttribute Method

Marker.WithAttribute Method
[image]

Creates a copy of the marker with the specified attribute added.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function WithAttribute( _
ByVal name As String, _
ByVal value As String _
) As Marker
C#
public Marker WithAttribute(
string name,
string value
)
C++
public:
Marker WithAttribute(
String name,
String value
) sealed
J#
public Marker WithAttribute(
string name,
string value
)
JScript
public function WithAttribute(
name : String,
value : String
) : Marker

Parameters

name
The attribute name
value
The attribute value

Return Value

The marker copy with the attribute

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or value is null
ArgumentException | Thrown if the name is not a valid identifier.

See Also

Marker Structure
Gallio.Model.Logging Namespace
ValidateIdentifier


MimeTypes Class

MimeTypes Class
See Also Example Members
[image]

Defines constants for commonly used mime types. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module MimeTypes
C#
public static class MimeTypes
C++
ref class MimeTypes abstract sealed
J#
public final class MimeTypes
JScript
public class MimeTypes

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.MimeTypes

See Also

MimeTypes Members
Gallio.Model.Logging Namespace


MimeTypes Members

MimeTypes Members
See Also Example Fields Methods
[image]

Defines constants for commonly used mime types. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by MimeTypes.

Public Fields

Name | Description
Binary | Binary data. This field is constant and read-only.
Css | Cascading Style Sheet. This field is constant and read-only.
Gif | GIF image. This field is constant and read-only.
Html | HTML. This field is constant and read-only.
JavaScript | JavaScript This field is constant and read-only.
MHtml | MHTML web archive. This field is constant and read-only.
PlainText | Plain text data. This field is constant and read-only.
Png | PNG image. This field is constant and read-only.
XHtml | Well-formed XHTML. This field is constant and read-only.
Xml | Xml data. This field is constant and read-only.
Top

Public Methods

Name | Description
GetMimeTypeByExtension | Guesses the mime type given a well-known extension.
Top

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Fields

MimeTypes Fields
[image]

Public Fields

Name | Description
Binary | Binary data. This field is constant and read-only.
Css | Cascading Style Sheet. This field is constant and read-only.
Gif | GIF image. This field is constant and read-only.
Html | HTML. This field is constant and read-only.
JavaScript | JavaScript This field is constant and read-only.
MHtml | MHTML web archive. This field is constant and read-only.
PlainText | Plain text data. This field is constant and read-only.
Png | PNG image. This field is constant and read-only.
XHtml | Well-formed XHTML. This field is constant and read-only.
Xml | Xml data. This field is constant and read-only.
Top

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Binary Field

MimeTypes.Binary Field
[image]

Binary data. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Binary As String = "application/octet-stream"
C#
public const string Binary = "application/octet-stream";
C++
public:
const String Binary = L"application/octet-stream";
J#
public const string Binary = "application/octet-stream"
JScript
public const Binary : String = "application/octet-stream";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Css Field

MimeTypes.Css Field
[image]

Cascading Style Sheet. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Css As String = "text/css"
C#
public const string Css = "text/css";
C++
public:
const String Css = L"text/css";
J#
public const string Css = "text/css"
JScript
public const Css : String = "text/css";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Gif Field

MimeTypes.Gif Field
[image]

GIF image. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Gif As String = "image/gif"
C#
public const string Gif = "image/gif";
C++
public:
const String Gif = L"image/gif";
J#
public const string Gif = "image/gif"
JScript
public const Gif : String = "image/gif";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Html Field

MimeTypes.Html Field
[image]

HTML. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Html As String = "text/html"
C#
public const string Html = "text/html";
C++
public:
const String Html = L"text/html";
J#
public const string Html = "text/html"
JScript
public const Html : String = "text/html";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


JavaScript Field

MimeTypes.JavaScript Field
[image]

JavaScript This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const JavaScript As String = "text/javascript"
C#
public const string JavaScript = "text/javascript";
C++
public:
const String JavaScript = L"text/javascript";
J#
public const string JavaScript = "text/javascript"
JScript
public const JavaScript : String = "text/javascript";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


MHtml Field

MimeTypes.MHtml Field
[image]

MHTML web archive. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const MHtml As String = "multipart/related"
C#
public const string MHtml = "multipart/related";
C++
public:
const String MHtml = L"multipart/related";
J#
public const string MHtml = "multipart/related"
JScript
public const MHtml : String = "multipart/related";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


PlainText Field

MimeTypes.PlainText Field
[image]

Plain text data. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const PlainText As String = "text/plain"
C#
public const string PlainText = "text/plain";
C++
public:
const String PlainText = L"text/plain";
J#
public const string PlainText = "text/plain"
JScript
public const PlainText : String = "text/plain";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Png Field

MimeTypes.Png Field
[image]

PNG image. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Png As String = "image/png"
C#
public const string Png = "image/png";
C++
public:
const String Png = L"image/png";
J#
public const string Png = "image/png"
JScript
public const Png : String = "image/png";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


XHtml Field

MimeTypes.XHtml Field
[image]

Well-formed XHTML. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const XHtml As String = "text/xhtml+xml"
C#
public const string XHtml = "text/xhtml+xml";
C++
public:
const String XHtml = L"text/xhtml+xml";
J#
public const string XHtml = "text/xhtml+xml"
JScript
public const XHtml : String = "text/xhtml+xml";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Xml Field

MimeTypes.Xml Field
[image]

Xml data. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Xml As String = "text/xml"
C#
public const string Xml = "text/xml";
C++
public:
const String Xml = L"text/xml";
J#
public const string Xml = "text/xml"
JScript
public const Xml : String = "text/xml";

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


Methods

MimeTypes Methods
[image]

Public Methods

Name | Description
GetMimeTypeByExtension | Guesses the mime type given a well-known extension.
Top

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


GetMimeTypeByExtension Method

MimeTypes.GetMimeTypeByExtension Method
[image]

Guesses the mime type given a well-known extension.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetMimeTypeByExtension( _
ByVal extension As String _
) As String
C#
public static string GetMimeTypeByExtension(
string extension
)
C++
public:
static String GetMimeTypeByExtension(
String extension
)
J#
public static string GetMimeTypeByExtension(
string extension
)
JScript
public static function GetMimeTypeByExtension(
extension : String
) : String

Parameters

extension
The extension

Return Value

The mime type, or null if not known

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if extension is null

See Also

MimeTypes Class
Gallio.Model.Logging Namespace


NullTestLogWriter Class

NullTestLogWriter Class
See Also Example Members
[image]

A test log writer that does nothing.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class NullTestLogWriter
Inherits TestLogWriter
C#
public class NullTestLogWriter : TestLogWriter
C++
ref class NullTestLogWriter : TestLogWriter
J#
public class NullTestLogWriter extends TestLogWriter
JScript
public class NullTestLogWriter extends TestLogWriter

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Logging.NullTestLogWriter

See Also

NullTestLogWriter Members
Gallio.Model.Logging Namespace


NullTestLogWriter Members

NullTestLogWriter Members
See Also Example Constructors Properties Methods
[image]

A test log writer that does nothing.

The following tables list the members exposed by NullTestLogWriter.

Public Constructors

 | Name | Description
Public method | NullTestLogWriter | Initializes a new instance of the NullTestLogWriter class.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


NullTestLogWriter Constructor

NullTestLogWriter Constructor
[image]

Initializes a new instance of the NullTestLogWriter class.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NullTestLogWriter()
C++
public:
NullTestLogWriter() sealed
J#
public NullTestLogWriter()
JScript
public function NullTestLogWriter()

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


Methods

NullTestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


AttachImpl Method

NullTestLogWriter.AttachImpl Method
[image]

Adds an attachment to the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AttachImpl( _
ByVal attachment As Attachment _
)
C#
protected override void AttachImpl(
Attachment attachment
)
C++
protected:
virtual void AttachImpl(
Attachment attachment
) override
J#
protected override void AttachImpl(
Attachment attachment
)
JScript
protected override function AttachImpl(
attachment : Attachment
)

Parameters

attachment
The attachment to write, never null

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginMarkerImpl Method

NullTestLogWriter.StreamBeginMarkerImpl Method
[image]

Begins a marked region in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginMarkerImpl( _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
C++
protected:
virtual void StreamBeginMarkerImpl(
String streamName,
Marker marker
) override
J#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
JScript
protected override function StreamBeginMarkerImpl(
streamName : String,
marker : Marker
)

Parameters

streamName
The log stream name
marker
The marker

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginSectionImpl Method

NullTestLogWriter.StreamBeginSectionImpl Method
[image]

Begins a section in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginSectionImpl( _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
C++
protected:
virtual void StreamBeginSectionImpl(
String streamName,
String sectionName
) override
J#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
JScript
protected override function StreamBeginSectionImpl(
streamName : String,
sectionName : String
)

Parameters

streamName
The log stream name
sectionName
The name of the section to begin, never null

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEmbedImpl Method

NullTestLogWriter.StreamEmbedImpl Method
[image]

Embeds an attachment into a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEmbedImpl( _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
C++
protected:
virtual void StreamEmbedImpl(
String streamName,
String attachmentName
) override
J#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
JScript
protected override function StreamEmbedImpl(
streamName : String,
attachmentName : String
)

Parameters

streamName
The log stream name
attachmentName
The name of the attachment to write, never null

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEndImpl Method

NullTestLogWriter.StreamEndImpl Method
[image]

Ends the current region started with one of the Begin* methods in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEndImpl( _
ByVal streamName As String _
)
C#
protected override void StreamEndImpl(
string streamName
)
C++
protected:
virtual void StreamEndImpl(
String streamName
) override
J#
protected override void StreamEndImpl(
string streamName
)
JScript
protected override function StreamEndImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


StreamWriteImpl Method

NullTestLogWriter.StreamWriteImpl Method
[image]

Writes a text string to a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamWriteImpl( _
ByVal streamName As String, _
ByVal text As String _
)
C#
protected override void StreamWriteImpl(
string streamName,
string text
)
C++
protected:
virtual void StreamWriteImpl(
String streamName,
String text
) override
J#
protected override void StreamWriteImpl(
string streamName,
string text
)
JScript
protected override function StreamWriteImpl(
streamName : String,
text : String
)

Parameters

streamName
The log stream name
text
The text to write, never null

See Also

NullTestLogWriter Class
Gallio.Model.Logging Namespace


StringTestLogWriter Class

StringTestLogWriter Class
See Also Example Members
[image]

An implementation of TestLogStreamWriter that writes its output to a string.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class StringTestLogWriter
Inherits TextualTestLogWriter
C#
public class StringTestLogWriter : TextualTestLogWriter
C++
ref class StringTestLogWriter : TextualTestLogWriter
J#
public class StringTestLogWriter extends TextualTestLogWriter
JScript
public class StringTestLogWriter extends TextualTestLogWriter

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Logging.TextualTestLogWriter
Gallio.Model.Logging.StringTestLogWriter

See Also

StringTestLogWriter Members
Gallio.Model.Logging Namespace


StringTestLogWriter Members

StringTestLogWriter Members
See Also Example Constructors Properties Methods
[image]

An implementation of TestLogStreamWriter that writes its output to a string.

The following tables list the members exposed by StringTestLogWriter.

Public Constructors

 | Name | Description
Public method | StringTestLogWriter | Creates a log stream writer for the Default stream.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Protected Properties

 | Name | Description
Family property | Verbose | Returns true if the verbose print mode is enabled. (inherited from TextualTestLogWriter)
Family property | Writer | Gets the underlying text writer. (inherited from TextualTestLogWriter)
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Overridden. Gets the formatted log contents as a string.
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Adds an attachment to the log. (inherited from TextualTestLogWriter)
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Begins a marked region in a log stream. (inherited from TextualTestLogWriter)
Family method | StreamBeginSectionImpl | Begins a section in a log stream. (inherited from TextualTestLogWriter)
Family method | StreamEmbedImpl | Embeds an attachment into a log stream. (inherited from TextualTestLogWriter)
Family method | StreamEndImpl | Ends the current region started with one of the Begin* methods in a log stream. (inherited from TextualTestLogWriter)
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Writes a text string to a log stream. (inherited from TextualTestLogWriter)
Top

See Also

StringTestLogWriter Class
Gallio.Model.Logging Namespace


StringTestLogWriter Constructor

StringTestLogWriter Constructor
[image]

Creates a log stream writer for the Default stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal verbose As Boolean _
)
C#
public StringTestLogWriter(
bool verbose
)
C++
public:
StringTestLogWriter(
bool verbose
) sealed
J#
public StringTestLogWriter(
bool verbose
)
JScript
public function StringTestLogWriter(
verbose : bool
)

Parameters

verbose
If true, prints detailed information about the location of attachments, sections, and markers, otherwise discards these formatting details and prints section headers as text on their own line

See Also

StringTestLogWriter Class
Gallio.Model.Logging Namespace


Methods

StringTestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Overridden. Gets the formatted log contents as a string.
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Adds an attachment to the log. (inherited from TextualTestLogWriter)
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Begins a marked region in a log stream. (inherited from TextualTestLogWriter)
Family method | StreamBeginSectionImpl | Begins a section in a log stream. (inherited from TextualTestLogWriter)
Family method | StreamEmbedImpl | Embeds an attachment into a log stream. (inherited from TextualTestLogWriter)
Family method | StreamEndImpl | Ends the current region started with one of the Begin* methods in a log stream. (inherited from TextualTestLogWriter)
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Writes a text string to a log stream. (inherited from TextualTestLogWriter)
Top

See Also

StringTestLogWriter Class
Gallio.Model.Logging Namespace


ToString Method

StringTestLogWriter.ToString Method
[image]

Gets the formatted log contents as a string.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The contents as a string

See Also

StringTestLogWriter Class
Gallio.Model.Logging Namespace


StructuredTestLog Class

StructuredTestLog Class
See Also Example Members
[image]

A structured test log is an Xml-serializable in-memory representation of a test log written by a TestLogWriter. This class cannot be inherited.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("testLog", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class StructuredTestLog
C#
[SerializableAttribute]
[XmlRootAttribute("testLog", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class StructuredTestLog
C++
[SerializableAttribute]
[XmlRootAttribute(L"testLog", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class StructuredTestLog sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("testLog", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class StructuredTestLog
JScript
public
SerializableAttribute
XmlRootAttribute("testLog", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class StructuredTestLog

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.StructuredTestLog

See Also

StructuredTestLog Members
Gallio.Model.Logging Namespace
StructuredTestLogWriter


StructuredTestLog Members

StructuredTestLog Members
See Also Example Constructors Properties Methods
[image]

A structured test log is an Xml-serializable in-memory representation of a test log written by a TestLogWriter. This class cannot be inherited.

The following tables list the members exposed by StructuredTestLog.

Public Constructors

 | Name | Description
Public method | StructuredTestLog | Creates an empty log.
Top

Public Properties

 | Name | Description
Public property | Attachments | Gets the list of attachments, not null.
Public property | Streams | Gets the list of streams, not null. Used for Xml-serialization.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetAttachment | Gets an attachment by name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStream | Gets a stream by name.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the log to a string by concatenating all formatted streams and displaying a "*** Stream Name ***" header for each stream name.
Public method | WriteTo | Writes the contents of the log to a test log writer.
Top

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace
StructuredTestLogWriter


StructuredTestLog Constructor

StructuredTestLog Constructor
[image]

Creates an empty log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StructuredTestLog()
C++
public:
StructuredTestLog() sealed
J#
public StructuredTestLog()
JScript
public function StructuredTestLog()

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


Properties

StructuredTestLog Properties
[image]

Public Properties

 | Name | Description
Public property | Attachments | Gets the list of attachments, not null.
Public property | Streams | Gets the list of streams, not null. Used for Xml-serialization.
Top

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace
StructuredTestLogWriter


Attachments Property

StructuredTestLog.Attachments Property
[image]

Gets the list of attachments, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("attachment", GetType(AttachmentData), Namespace := "http://www.gallio.org/", IsNullable := False), _
XmlArrayAttribute("attachments", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public ReadOnly Property Attachments As List(Of AttachmentData)
C#
[XmlArrayItemAttribute("attachment", typeof(AttachmentData), Namespace = "http://www.gallio.org/", IsNullable = False)]
[XmlArrayAttribute("attachments", Namespace = "http://www.gallio.org/", IsNullable = False)]
public List<AttachmentData> Attachments { get; }
C++
[XmlArrayItemAttribute(L"attachment", typeof(AttachmentData), Namespace = L"http://www.gallio.org/", IsNullable = False)]
[XmlArrayAttribute(L"attachments", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property List<AttachmentData> Attachments sealed {
List<AttachmentData> get();
}
J#
/** @attribute XmlArrayItemAttribute("attachment", typeof(AttachmentData), Namespace = "http://www.gallio.org/", IsNullable = False) */
/** @attribute XmlArrayAttribute("attachments", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public List<AttachmentData> get_Attachments();
JScript
public function get Attachments() : List<AttachmentData>

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


Streams Property

StructuredTestLog.Streams Property
[image]

Gets the list of streams, not null. Used for Xml-serialization.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("streams", Namespace := "http://www.gallio.org/", IsNullable := False), _
XmlArrayItemAttribute("stream", GetType(StructuredTestLogStream), Namespace := "http://www.gallio.org/", IsNullable := False)>
Public ReadOnly Property Streams As List(Of StructuredTestLogStream)
C#
[XmlArrayAttribute("streams", Namespace = "http://www.gallio.org/", IsNullable = False)]
[XmlArrayItemAttribute("stream", typeof(StructuredTestLogStream), Namespace = "http://www.gallio.org/", IsNullable = False)]
public List<StructuredTestLogStream> Streams { get; }
C++
[XmlArrayAttribute(L"streams", Namespace = L"http://www.gallio.org/", IsNullable = False)]
[XmlArrayItemAttribute(L"stream", typeof(StructuredTestLogStream), Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property List<StructuredTestLogStream> Streams sealed {
List<StructuredTestLogStream> get();
}
J#
/** @attribute XmlArrayAttribute("streams", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("stream", typeof(StructuredTestLogStream), Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public List<StructuredTestLogStream> get_Streams();
JScript
public function get Streams() : List<StructuredTestLogStream>

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


Methods

StructuredTestLog Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetAttachment | Gets an attachment by name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStream | Gets a stream by name.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the log to a string by concatenating all formatted streams and displaying a "*** Stream Name ***" header for each stream name.
Public method | WriteTo | Writes the contents of the log to a test log writer.
Top

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace
StructuredTestLogWriter


GetAttachment Method

StructuredTestLog.GetAttachment Method
[image]

Gets an attachment by name.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAttachment( _
ByVal name As String _
) As AttachmentData
C#
public AttachmentData GetAttachment(
string name
)
C++
public:
AttachmentData GetAttachment(
String name
) sealed
J#
public AttachmentData GetAttachment(
string name
)
JScript
public function GetAttachment(
name : String
) : AttachmentData

Parameters

name
The attachment name

Return Value

The attachment or null if not found

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


GetStream Method

StructuredTestLog.GetStream Method
[image]

Gets a stream by name.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStream( _
ByVal name As String _
) As StructuredTestLogStream
C#
public StructuredTestLogStream GetStream(
string name
)
C++
public:
StructuredTestLogStream GetStream(
String name
) sealed
J#
public StructuredTestLogStream GetStream(
string name
)
JScript
public function GetStream(
name : String
) : StructuredTestLogStream

Parameters

name
The stream name

Return Value

The stream or null if not found

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


ToString Method

StructuredTestLog.ToString Method
[image]

Formats the log to a string by concatenating all formatted streams and displaying a "*** Stream Name ***" header for each stream name.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted text

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


WriteTo Method

StructuredTestLog.WriteTo Method
[image]

Writes the contents of the log to a test log writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogWriter _
)
C#
public void WriteTo(
TestLogWriter writer
)
C++
public:
void WriteTo(
TestLogWriter writer
) sealed
J#
public void WriteTo(
TestLogWriter writer
)
JScript
public function WriteTo(
writer : TestLogWriter
)

Parameters

writer
The writer

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

StructuredTestLog Class
Gallio.Model.Logging Namespace


StructuredTestLogStream Class

StructuredTestLogStream Class
See Also Example Members
[image]

A structured log stream object represents a recursively structured stream of rich text that supports embedded attachments, nested sections and marked regions. Each part of the text is captured by a tag, some of which are composable and may therefore contain other tags.

It is effectively an xml-serializable representation of a test log stream written by a TestLogStreamWriter.

This class cannot be inherited.
Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class StructuredTestLogStream
Implements ITestLogStreamWritable
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class StructuredTestLogStream : ITestLogStreamWritable
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class StructuredTestLogStream sealed : ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class StructuredTestLogStream implements ITestLogStreamWritable
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class StructuredTestLogStream extends ITestLogStreamWritable

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.StructuredTestLogStream

See Also

StructuredTestLogStream Members
Gallio.Model.Logging Namespace


StructuredTestLogStream Members

StructuredTestLogStream Members
See Also Example Constructors Properties Methods
[image]

A structured log stream object represents a recursively structured stream of rich text that supports embedded attachments, nested sections and marked regions. Each part of the text is captured by a tag, some of which are composable and may therefore contain other tags.

It is effectively an xml-serializable representation of a test log stream written by a TestLogStreamWriter.

This class cannot be inherited.

The following tables list the members exposed by StructuredTestLogStream.

Public Constructors

 | Name | Description
Public method | StructuredTestLogStream | Creates an initialized stream.
Top

Public Properties

 | Name | Description
Public property | Body | Gets or sets the body of the log stream, not null.
Public property | Name | Gets or sets the name of the log stream, not null.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the stream using a TagFormatter.
Public method | WriteTo | Writes the contents of the stream to a test log stream writer.
Top

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


StructuredTestLogStream Constructor

StructuredTestLogStream Constructor
[image]

Creates an initialized stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public StructuredTestLogStream(
string name
)
C++
public:
StructuredTestLogStream(
String name
) sealed
J#
public StructuredTestLogStream(
string name
)
JScript
public function StructuredTestLogStream(
name : String
)

Parameters

name
The stream name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


Properties

StructuredTestLogStream Properties
[image]

Public Properties

 | Name | Description
Public property | Body | Gets or sets the body of the log stream, not null.
Public property | Name | Gets or sets the name of the log stream, not null.
Top

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


Body Property

StructuredTestLogStream.Body Property
[image]

Gets or sets the body of the log stream, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("body", IsNullable := False)>
Public Property Body As BodyTag
C#
[XmlElementAttribute("body", IsNullable = False)]
public BodyTag Body { get; set; }
C++
[XmlElementAttribute(L"body", IsNullable = False)]
public property BodyTag Body sealed {
BodyTag get();
void set(BodyTag value);
}
J#
/** @attribute XmlElementAttribute("body", IsNullable = False) */
/** property */
public BodyTag get_Body();

/** property */
public void set_Body(BodyTag value);
JScript
public function get Body() : BodyTag

public function set Body(value : BodyTag);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


Name Property

StructuredTestLogStream.Name Property
[image]

Gets or sets the name of the log stream, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("name")>
Public Property Name As String
C#
[XmlAttributeAttribute("name")]
public string Name { get; set; }
C++
[XmlAttributeAttribute(L"name")]
public property string Name sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("name") */
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


Methods

StructuredTestLogStream Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the stream using a TagFormatter.
Public method | WriteTo | Writes the contents of the stream to a test log stream writer.
Top

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


ToString Method

StructuredTestLogStream.ToString Method
[image]

Formats the stream using a TagFormatter.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted text

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


WriteTo Method

StructuredTestLogStream.WriteTo Method
[image]

Writes the contents of the stream to a test log stream writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The writer

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

StructuredTestLogStream Class
Gallio.Model.Logging Namespace


StructuredTestLogWriter Class

StructuredTestLogWriter Class
See Also Example Members
[image]

Writes a StructuredTestLog in memory.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class StructuredTestLogWriter
Inherits TestLogWriter
C#
public class StructuredTestLogWriter : TestLogWriter
C++
ref class StructuredTestLogWriter : TestLogWriter
J#
public class StructuredTestLogWriter extends TestLogWriter
JScript
public class StructuredTestLogWriter extends TestLogWriter

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Logging.StructuredTestLogWriter

See Also

StructuredTestLogWriter Members
Gallio.Model.Logging Namespace


StructuredTestLogWriter Members

StructuredTestLogWriter Members
See Also Example Constructors Properties Methods
[image]

Writes a StructuredTestLog in memory.

The following tables list the members exposed by StructuredTestLogWriter.

Public Constructors

 | Name | Description
Public method | StructuredTestLogWriter | Creates an log writer that builds a new StructuredTestLog.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | TestLog | Gets the test log under construction.
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Overridden. Flushes the writer and formats it as a string.
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Overridden. Closes the log.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Overridden. Flushes the log.
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Overridden. Flushes a log stream.
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StructuredTestLogWriter Constructor

StructuredTestLogWriter Constructor
[image]

Creates an log writer that builds a new StructuredTestLog.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StructuredTestLogWriter()
C++
public:
StructuredTestLogWriter() sealed
J#
public StructuredTestLogWriter()
JScript
public function StructuredTestLogWriter()

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


Properties

StructuredTestLogWriter Properties
[image]

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | TestLog | Gets the test log under construction.
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


TestLog Property

StructuredTestLogWriter.TestLog Property
[image]

Gets the test log under construction.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestLog As StructuredTestLog
C#
public StructuredTestLog TestLog { get; }
C++
public property StructuredTestLog TestLog sealed {
StructuredTestLog get();
}
J#
/** property */
public StructuredTestLog get_TestLog();
JScript
public function get TestLog() : StructuredTestLog

Remarks

The contents of the test log will change as more text is written. However, it may be necessary to Flush or Close the writer for these changes to be observed.

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


Methods

StructuredTestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Overridden. Flushes the writer and formats it as a string.
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Overridden. Closes the log.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Overridden. Flushes the log.
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Overridden. Flushes a log stream.
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


AttachImpl Method

StructuredTestLogWriter.AttachImpl Method
[image]

Adds an attachment to the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AttachImpl( _
ByVal attachment As Attachment _
)
C#
protected override void AttachImpl(
Attachment attachment
)
C++
protected:
virtual void AttachImpl(
Attachment attachment
) override
J#
protected override void AttachImpl(
Attachment attachment
)
JScript
protected override function AttachImpl(
attachment : Attachment
)

Parameters

attachment
The attachment to write, never null

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


CloseImpl Method

StructuredTestLogWriter.CloseImpl Method
[image]

Closes the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub CloseImpl()
C#
protected override void CloseImpl()
C++
protected:
virtual void CloseImpl() override
J#
protected override void CloseImpl()
JScript
protected override function CloseImpl()

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


FlushImpl Method

StructuredTestLogWriter.FlushImpl Method
[image]

Flushes the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FlushImpl()
C#
protected override void FlushImpl()
C++
protected:
virtual void FlushImpl() override
J#
protected override void FlushImpl()
JScript
protected override function FlushImpl()

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginMarkerImpl Method

StructuredTestLogWriter.StreamBeginMarkerImpl Method
[image]

Begins a marked region in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginMarkerImpl( _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
C++
protected:
virtual void StreamBeginMarkerImpl(
String streamName,
Marker marker
) override
J#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
JScript
protected override function StreamBeginMarkerImpl(
streamName : String,
marker : Marker
)

Parameters

streamName
The log stream name
marker
The marker

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginSectionImpl Method

StructuredTestLogWriter.StreamBeginSectionImpl Method
[image]

Begins a section in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginSectionImpl( _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
C++
protected:
virtual void StreamBeginSectionImpl(
String streamName,
String sectionName
) override
J#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
JScript
protected override function StreamBeginSectionImpl(
streamName : String,
sectionName : String
)

Parameters

streamName
The log stream name
sectionName
The name of the section to begin, never null

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEmbedImpl Method

StructuredTestLogWriter.StreamEmbedImpl Method
[image]

Embeds an attachment into a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEmbedImpl( _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
C++
protected:
virtual void StreamEmbedImpl(
String streamName,
String attachmentName
) override
J#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
JScript
protected override function StreamEmbedImpl(
streamName : String,
attachmentName : String
)

Parameters

streamName
The log stream name
attachmentName
The name of the attachment to write, never null

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEndImpl Method

StructuredTestLogWriter.StreamEndImpl Method
[image]

Ends the current region started with one of the Begin* methods in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEndImpl( _
ByVal streamName As String _
)
C#
protected override void StreamEndImpl(
string streamName
)
C++
protected:
virtual void StreamEndImpl(
String streamName
) override
J#
protected override void StreamEndImpl(
string streamName
)
JScript
protected override function StreamEndImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StreamFlushImpl Method

StructuredTestLogWriter.StreamFlushImpl Method
[image]

Flushes a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamFlushImpl( _
ByVal streamName As String _
)
C#
protected override void StreamFlushImpl(
string streamName
)
C++
protected:
virtual void StreamFlushImpl(
String streamName
) override
J#
protected override void StreamFlushImpl(
string streamName
)
JScript
protected override function StreamFlushImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StreamWriteImpl Method

StructuredTestLogWriter.StreamWriteImpl Method
[image]

Writes a text string to a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamWriteImpl( _
ByVal streamName As String, _
ByVal text As String _
)
C#
protected override void StreamWriteImpl(
string streamName,
string text
)
C++
protected:
virtual void StreamWriteImpl(
String streamName,
String text
) override
J#
protected override void StreamWriteImpl(
string streamName,
string text
)
JScript
protected override function StreamWriteImpl(
streamName : String,
text : String
)

Parameters

streamName
The log stream name
text
The text to write, never null

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


ToString Method

StructuredTestLogWriter.ToString Method
[image]

Flushes the writer and formats it as a string.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted log as a string

See Also

StructuredTestLogWriter Class
Gallio.Model.Logging Namespace


StructuredText Class

StructuredText Class
See Also Example Members
[image]

A structured text object contains attachments and formatted text with rich presentation elements.

Structured text is emitted by a StructuredTextWriter.

This class cannot be inherited.
Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class StructuredText
Implements IEquatable(Of StructuredText), ITestLogStreamWritable
C#
[SerializableAttribute]
public sealed class StructuredText : IEquatable<StructuredText>, ITestLogStreamWritable
C++
[SerializableAttribute]
ref class StructuredText sealed : IEquatable<StructuredText>, ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
public final class StructuredText implements IEquatable<StructuredText>, ITestLogStreamWritable
JScript
public
SerializableAttribute
final class StructuredText extends IEquatable<StructuredText>, ITestLogStreamWritable

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.StructuredText

See Also

StructuredText Members
Gallio.Model.Logging Namespace
StructuredTextWriter


StructuredText Members

StructuredText Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A structured text object contains attachments and formatted text with rich presentation elements.

Structured text is emitted by a StructuredTextWriter.

This class cannot be inherited.

The following tables list the members exposed by StructuredText.

Public Constructors

Name | Description
StructuredText | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Attachments | Gets the immutable list of attachments.
Public property | BodyTag | Gets a copy of the body tag that described the structured text.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetTextLength | Returns the total length of all TextTags that appear within the structured text body.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Formats the structured text to a string, discarding unrepresentable formatting details.
Public method | TruncatedWriteTo | Writes the structured text to a test log stream writer and truncates its text to a particular maximum length, omitting all subsequent contents.
Public method | WriteTo | Writes the structured text to a test log stream writer.
Top

Explicit Interface Implementations

Name | Description
StructuredText | Overloaded.
Top

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredTextWriter


StructuredText Constructor

StructuredText Constructor

Overload List

 | Name | Description
Public method | StructuredText (BodyTag) | Creates a structured text object that wraps the body tag of a structured test log stream and no attachments.
Public method | StructuredText (BodyTag, IList<Attachment>) | Creates a structured text object that wraps the body tag of a structured test log stream and a list of attachments.
Public method | StructuredText (String) | Creates a simple structured text object over a plain text string.

See Also

StructuredText Class
Gallio.Model.Logging Namespace


StructuredText Constructor (BodyTag)

StructuredText Constructor (BodyTag)
See Also Example
[image]

Creates a structured text object that wraps the body tag of a structured test log stream and no attachments.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal bodyTag As BodyTag _
)
C#
public StructuredText(
BodyTag bodyTag
)
C++
public:
StructuredText(
BodyTag bodyTag
) sealed
J#
public StructuredText(
BodyTag bodyTag
)
JScript
public function StructuredText(
bodyTag : BodyTag
)

Parameters

bodyTag
The body tag to wrap

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if bodyTag is null

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredText Constructor Overload List


StructuredText Constructor (BodyTag, Generic IList)

StructuredText Constructor (BodyTag, Generic IList)
See Also Example
[image]

Creates a structured text object that wraps the body tag of a structured test log stream and a list of attachments.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal bodyTag As BodyTag, _
ByVal attachments As IList(Of Attachment) _
)
C#
public StructuredText(
BodyTag bodyTag,
IList<Attachment> attachments
)
C++
public:
StructuredText(
BodyTag bodyTag,
IList<Attachment> attachments
) sealed
J#
public StructuredText(
BodyTag bodyTag,
IList<Attachment> attachments
)
JScript
public function StructuredText(
bodyTag : BodyTag,
attachments : IList<Attachment>
)

Parameters

bodyTag
The body tag to wrap
attachments
The list of attachments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if bodyTag, or attachments is null

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredText Constructor Overload List


StructuredText Constructor (String)

StructuredText Constructor (String)
See Also Example
[image]

Creates a simple structured text object over a plain text string.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal text As String _
)
C#
public StructuredText(
string text
)
C++
public:
StructuredText(
String text
) sealed
J#
public StructuredText(
string text
)
JScript
public function StructuredText(
text : String
)

Parameters

text
The text string

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredText Constructor Overload List


Properties

StructuredText Properties
[image]

Public Properties

 | Name | Description
Public property | Attachments | Gets the immutable list of attachments.
Public property | BodyTag | Gets a copy of the body tag that described the structured text.
Top

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredTextWriter


Attachments Property

StructuredText.Attachments Property
[image]

Gets the immutable list of attachments.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attachments As IList(Of Attachment)
C#
public IList<Attachment> Attachments { get; }
C++
public property IList<Attachment> Attachments sealed {
IList<Attachment> get();
}
J#
/** property */
public IList<Attachment> get_Attachments();
JScript
public function get Attachments() : IList<Attachment>

See Also

StructuredText Class
Gallio.Model.Logging Namespace


BodyTag Property

StructuredText.BodyTag Property
[image]

Gets a copy of the body tag that described the structured text.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BodyTag As BodyTag
C#
public BodyTag BodyTag { get; }
C++
public property BodyTag BodyTag sealed {
BodyTag get();
}
J#
/** property */
public BodyTag get_BodyTag();
JScript
public function get BodyTag() : BodyTag

See Also

StructuredText Class
Gallio.Model.Logging Namespace


Methods

StructuredText Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetTextLength | Returns the total length of all TextTags that appear within the structured text body.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality |
 | op_Inequality |
Public method | ToString | Overridden. Formats the structured text to a string, discarding unrepresentable formatting details.
Public method | TruncatedWriteTo | Writes the structured text to a test log stream writer and truncates its text to a particular maximum length, omitting all subsequent contents.
Public method | WriteTo | Writes the structured text to a test log stream writer.
Top

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredTextWriter


Equals Method

StructuredText.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (StructuredText) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

StructuredText Class
Gallio.Model.Logging Namespace


Equals Method (StructuredText)

StructuredText.Equals Method (StructuredText)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As StructuredText _
) As Boolean _
Implements IEquatable<StructuredText>.Equals
C#
public bool Equals(
StructuredText other
)
C++
public:
bool Equals(
StructuredText other
) sealed
J#
public bool Equals(
StructuredText other
)
JScript
public function Equals(
other : StructuredText
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<StructuredText>.Equals

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredText.Equals Overload List


Equals Method (Object)

StructuredText.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

StructuredText Class
Gallio.Model.Logging Namespace
StructuredText.Equals Overload List


GetHashCode Method

StructuredText.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

StructuredText Class
Gallio.Model.Logging Namespace


GetTextLength Method

StructuredText.GetTextLength Method
[image]

Returns the total length of all TextTags that appear within the structured text body.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTextLength() As Integer
C#
public int GetTextLength()
C++
public:
int GetTextLength() sealed
J#
public int GetTextLength()
JScript
public function GetTextLength() : int

Return Value

The total text length

See Also

StructuredText Class
Gallio.Model.Logging Namespace


op_Equality Operator

StructuredText.op_Equality Operator
[image]

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As StructuredText, _
ByVal b As StructuredText _
) As Boolean
C#
public static bool operator ==(
StructuredText a,
StructuredText b
)
C++
public:
static bool operator ==(
StructuredText a,
StructuredText b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

StructuredText Class
Gallio.Model.Logging Namespace


op_Inequality Operator

StructuredText.op_Inequality Operator
[image]

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As StructuredText, _
ByVal b As StructuredText _
) As Boolean
C#
public static bool operator !=(
StructuredText a,
StructuredText b
)
C++
public:
static bool operator !=(
StructuredText a,
StructuredText b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

See Also

StructuredText Class
Gallio.Model.Logging Namespace


ToString Method

StructuredText.ToString Method
[image]

Formats the structured text to a string, discarding unrepresentable formatting details.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The structured text as a string

See Also

StructuredText Class
Gallio.Model.Logging Namespace


TruncatedWriteTo Method

StructuredText.TruncatedWriteTo Method
[image]

Writes the structured text to a test log stream writer and truncates its text to a particular maximum length, omitting all subsequent contents.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function TruncatedWriteTo( _
ByVal writer As TestLogStreamWriter, _
ByVal maxLength As Integer _
) As Boolean
C#
public bool TruncatedWriteTo(
TestLogStreamWriter writer,
int maxLength
)
C++
public:
bool TruncatedWriteTo(
TestLogStreamWriter writer,
int maxLength
) sealed
J#
public bool TruncatedWriteTo(
TestLogStreamWriter writer,
int maxLength
)
JScript
public function TruncatedWriteTo(
writer : TestLogStreamWriter,
maxLength : int
) : bool

Parameters

writer
The writer
maxLength
The maximum length of text to write

Return Value

True if truncation occurred

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null
ArgumentOutOfRangeException | Thrown if maxLength is negative

See Also

StructuredText Class
Gallio.Model.Logging Namespace


WriteTo Method

StructuredText.WriteTo Method
[image]

Writes the structured text to a test log stream writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The writer

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

StructuredText Class
Gallio.Model.Logging Namespace


StructuredTextWriter Class

StructuredTextWriter Class
See Also Example Members
[image]

Writes log information in a structured manner so as to produce a StructuredText or String.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class StructuredTextWriter
Inherits TestLogStreamWriter
Implements ITestLogStreamWritable
C#
public class StructuredTextWriter : TestLogStreamWriter, ITestLogStreamWritable
C++
ref class StructuredTextWriter : TestLogStreamWriter, ITestLogStreamWritable
J#
public class StructuredTextWriter extends TestLogStreamWriter implements ITestLogStreamWritable
JScript
public class StructuredTextWriter extends TestLogStreamWriter, ITestLogStreamWritable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.TextWriter
Gallio.Model.Logging.TestLogStreamWriter
Gallio.Model.Logging.StructuredTextWriter

See Also

StructuredTextWriter Members
Gallio.Model.Logging Namespace


StructuredTextWriter Members

StructuredTextWriter Members
See Also Example Constructors Fields Properties Methods
[image]

Writes log information in a structured manner so as to produce a StructuredText or String.

The following tables list the members exposed by StructuredTextWriter.

Public Constructors

 | Name | Description
Public method | StructuredTextWriter | Creates a structured text writer.
Top

Protected Fields

 | Name | Description
Family field | CoreNewLine | Stores the new line characters used for this TextWriter. (inherited from TextWriter)
Top

Public Properties

 | Name | Description
Public property | Container | Gets the containing log writer. (inherited from TestLogStreamWriter)
Public property | Encoding | When overridden in a derived class, returns the Encoding in which the output is written. (inherited from TestLogStreamWriter)
Public property | FormatProvider | Gets an object that controls formatting. (inherited from TextWriter)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter. (inherited from TestLogStreamWriter)
Top

Public Methods

 | Name | Description
Public method | BeginMarker | Begins a marked region. Maybe be nested. A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly. (inherited from TestLogStreamWriter)
Public method | BeginSection | Begins a section with the specified name. Maybe be nested. A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading. (inherited from TestLogStreamWriter)
Public method | Close | Closes the current writer and releases any system resources associated with the writer. (inherited from TextWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases all resources used by the TextWriter object. (inherited from TestLogStreamWriter)
Public method | Embed | Embeds an attachment. (inherited from TestLogStreamWriter)
Public method | EmbedExisting | Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached. (inherited from TestLogStreamWriter)
Public method | EmbedHtml | Embeds an HTML attachment with mime-type Html. (inherited from TestLogStreamWriter)
Public method | EmbedImage | Embeds an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogStreamWriter)
Public method | EmbedObjectAsXml | Overloaded. Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogStreamWriter)
Public method | EmbedPlainText | Embeds an plain text attachment with mime-type PlainText. (inherited from TestLogStreamWriter)
Public method | EmbedXHtml | Embeds an XHTML attachment with mime-type XHtml. (inherited from TestLogStreamWriter)
Public method | EmbedXml | Embeds an XML attachment with mime-type Xml. (inherited from TestLogStreamWriter)
Public method | End | Ends the region most recently started with one of the Begin* methods. (inherited from TestLogStreamWriter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (inherited from TestLogStreamWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Overridden. Returns the structured text formatted as a string.
Public method | ToStructuredText | Gets the structured text produced so far.
Public method | Write | Overloaded. Writes the given data type to a text stream. (inherited from TestLogStreamWriter)
Public method | WriteEllipsis | Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated. (inherited from TestLogStreamWriter)
Public method | WriteException | Overloaded. Writes an exception. (inherited from TestLogStreamWriter)
Public method | WriteHighlighted | Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values. (inherited from TestLogStreamWriter)
Public method | WriteLine | Overloaded. Writes some data as specified by the overloaded parameters, followed by a line terminator. (inherited from TestLogStreamWriter)
Public method | WriteTo | Writes the object to a test log stream.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases all resources used by the TextWriter object. (inherited from TestLogStreamWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

StructuredTextWriter Class
Gallio.Model.Logging Namespace


StructuredTextWriter Constructor

StructuredTextWriter Constructor
[image]

Creates a structured text writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StructuredTextWriter()
C++
public:
StructuredTextWriter() sealed
J#
public StructuredTextWriter()
JScript
public function StructuredTextWriter()

See Also

StructuredTextWriter Class
Gallio.Model.Logging Namespace


Methods

StructuredTextWriter Methods
[image]

Public Methods

 | Name | Description
Public method | BeginMarker | Begins a marked region. Maybe be nested. A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly. (inherited from TestLogStreamWriter)
Public method | BeginSection | Begins a section with the specified name. Maybe be nested. A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading. (inherited from TestLogStreamWriter)
Public method | Close | Closes the current writer and releases any system resources associated with the writer. (inherited from TextWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases all resources used by the TextWriter object. (inherited from TestLogStreamWriter)
Public method | Embed | Embeds an attachment. (inherited from TestLogStreamWriter)
Public method | EmbedExisting | Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached. (inherited from TestLogStreamWriter)
Public method | EmbedHtml | Embeds an HTML attachment with mime-type Html. (inherited from TestLogStreamWriter)
Public method | EmbedImage | Embeds an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogStreamWriter)
Public method | EmbedObjectAsXml | Overloaded. Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogStreamWriter)
Public method | EmbedPlainText | Embeds an plain text attachment with mime-type PlainText. (inherited from TestLogStreamWriter)
Public method | EmbedXHtml | Embeds an XHTML attachment with mime-type XHtml. (inherited from TestLogStreamWriter)
Public method | EmbedXml | Embeds an XML attachment with mime-type Xml. (inherited from TestLogStreamWriter)
Public method | End | Ends the region most recently started with one of the Begin* methods. (inherited from TestLogStreamWriter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (inherited from TestLogStreamWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Overridden. Returns the structured text formatted as a string.
Public method | ToStructuredText | Gets the structured text produced so far.
Public method | Write | Overloaded. Writes the given data type to a text stream. (inherited from TestLogStreamWriter)
Public method | WriteEllipsis | Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated. (inherited from TestLogStreamWriter)
Public method | WriteException | Overloaded. Writes an exception. (inherited from TestLogStreamWriter)
Public method | WriteHighlighted | Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values. (inherited from TestLogStreamWriter)
Public method | WriteLine | Overloaded. Writes some data as specified by the overloaded parameters, followed by a line terminator. (inherited from TestLogStreamWriter)
Public method | WriteTo | Writes the object to a test log stream.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases all resources used by the TextWriter object. (inherited from TestLogStreamWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

StructuredTextWriter Class
Gallio.Model.Logging Namespace


ToString Method

StructuredTextWriter.ToString Method
[image]

Returns the structured text formatted as a string.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The structured text

See Also

StructuredTextWriter Class
Gallio.Model.Logging Namespace


ToStructuredText Method

StructuredTextWriter.ToStructuredText Method
[image]

Gets the structured text produced so far.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ToStructuredText() As StructuredText
C#
public StructuredText ToStructuredText()
C++
public:
StructuredText ToStructuredText() sealed
J#
public StructuredText ToStructuredText()
JScript
public function ToStructuredText() : StructuredText

Return Value

The structured text

See Also

StructuredTextWriter Class
Gallio.Model.Logging Namespace


WriteTo Method

StructuredTextWriter.WriteTo Method
[image]

Writes the object to a test log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The test log stream

Implements

ITestLogStreamWritable.WriteTo

See Also

StructuredTextWriter Class
Gallio.Model.Logging Namespace


TestLogStreamLogger Class

TestLogStreamLogger Class
See Also Example Members
[image]

A ILogger implementation that logs messages to the specified TestLogStreamWriter. This can be used to write log messages to the test execution log. This class cannot be inherited.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestLogStreamLogger
Inherits BaseLogger
C#
public sealed class TestLogStreamLogger : BaseLogger
C++
ref class TestLogStreamLogger sealed : BaseLogger
J#
public final class TestLogStreamLogger extends BaseLogger
JScript
public final class TestLogStreamLogger extends BaseLogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Model.Logging.TestLogStreamLogger

See Also

TestLogStreamLogger Members
Gallio.Model.Logging Namespace


TestLogStreamLogger Members

TestLogStreamLogger Members
See Also Example Constructors Methods
[image]

A ILogger implementation that logs messages to the specified TestLogStreamWriter. This can be used to write log messages to the test execution log. This class cannot be inherited.

The following tables list the members exposed by TestLogStreamLogger.

Public Constructors

 | Name | Description
Public method | TestLogStreamLogger | Creates a logger for the log stream writer.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestLogStreamLogger Class
Gallio.Model.Logging Namespace


TestLogStreamLogger Constructor

TestLogStreamLogger Constructor
[image]

Creates a logger for the log stream writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal writer As TestLogStreamWriter _
)
C#
public TestLogStreamLogger(
TestLogStreamWriter writer
)
C++
public:
TestLogStreamLogger(
TestLogStreamWriter writer
) sealed
J#
public TestLogStreamLogger(
TestLogStreamWriter writer
)
JScript
public function TestLogStreamLogger(
writer : TestLogStreamWriter
)

Parameters

writer
The log stream writer

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

TestLogStreamLogger Class
Gallio.Model.Logging Namespace


TestLogStreamNames Class

TestLogStreamNames Class
See Also Example Members
[image]

Common test log stream names. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestLogStreamNames
C#
public static class TestLogStreamNames
C++
ref class TestLogStreamNames abstract sealed
J#
public final class TestLogStreamNames
JScript
public class TestLogStreamNames

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.TestLogStreamNames

See Also

TestLogStreamNames Members
Gallio.Model.Logging Namespace


TestLogStreamNames Members

TestLogStreamNames Members
See Also Example Fields
[image]

Common test log stream names. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestLogStreamNames.

Public Fields

Name | Description
ConsoleError | The name of the built-in log stream where the Error stream from the test is recorded. This field is constant and read-only.
ConsoleInput | The name of the built-in log stream where the In stream for the test is recorded. This field is constant and read-only.
ConsoleOutput | The name of the built-in log stream where the Out stream from the test is recorded. This field is constant and read-only.
DebugTrace | The name of the built-in log stream log stream where diagnostic Debug and Trace information is recorded. This field is constant and read-only.
Default | The name of the built-in log stream where additional log output is recorded. In new test frameworks, this stream should be used instead of the console output and error streams for logging test output. This field is constant and read-only.
Failures | The name of the built-in log stream where assertion failures, exceptions and other failure data are recorded. This field is constant and read-only.
Warnings | The name of the built-in log stream where warnings are recorded. This field is constant and read-only.
Top

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


Fields

TestLogStreamNames Fields
[image]

Public Fields

Name | Description
ConsoleError | The name of the built-in log stream where the Error stream from the test is recorded. This field is constant and read-only.
ConsoleInput | The name of the built-in log stream where the In stream for the test is recorded. This field is constant and read-only.
ConsoleOutput | The name of the built-in log stream where the Out stream from the test is recorded. This field is constant and read-only.
DebugTrace | The name of the built-in log stream log stream where diagnostic Debug and Trace information is recorded. This field is constant and read-only.
Default | The name of the built-in log stream where additional log output is recorded. In new test frameworks, this stream should be used instead of the console output and error streams for logging test output. This field is constant and read-only.
Failures | The name of the built-in log stream where assertion failures, exceptions and other failure data are recorded. This field is constant and read-only.
Warnings | The name of the built-in log stream where warnings are recorded. This field is constant and read-only.
Top

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


ConsoleError Field

TestLogStreamNames.ConsoleError Field
[image]

The name of the built-in log stream where the Error stream from the test is recorded. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ConsoleError As String = "ConsoleError"
C#
public const string ConsoleError = "ConsoleError";
C++
public:
const String ConsoleError = L"ConsoleError";
J#
public const string ConsoleError = "ConsoleError"
JScript
public const ConsoleError : String = "ConsoleError";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


ConsoleInput Field

TestLogStreamNames.ConsoleInput Field
[image]

The name of the built-in log stream where the In stream for the test is recorded. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ConsoleInput As String = "ConsoleInput"
C#
public const string ConsoleInput = "ConsoleInput";
C++
public:
const String ConsoleInput = L"ConsoleInput";
J#
public const string ConsoleInput = "ConsoleInput"
JScript
public const ConsoleInput : String = "ConsoleInput";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


ConsoleOutput Field

TestLogStreamNames.ConsoleOutput Field
[image]

The name of the built-in log stream where the Out stream from the test is recorded. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ConsoleOutput As String = "ConsoleOutput"
C#
public const string ConsoleOutput = "ConsoleOutput";
C++
public:
const String ConsoleOutput = L"ConsoleOutput";
J#
public const string ConsoleOutput = "ConsoleOutput"
JScript
public const ConsoleOutput : String = "ConsoleOutput";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


DebugTrace Field

TestLogStreamNames.DebugTrace Field
[image]

The name of the built-in log stream log stream where diagnostic Debug and Trace information is recorded. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const DebugTrace As String = "DebugTrace"
C#
public const string DebugTrace = "DebugTrace";
C++
public:
const String DebugTrace = L"DebugTrace";
J#
public const string DebugTrace = "DebugTrace"
JScript
public const DebugTrace : String = "DebugTrace";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


Default Field

TestLogStreamNames.Default Field
[image]

The name of the built-in log stream where additional log output is recorded. In new test frameworks, this stream should be used instead of the console output and error streams for logging test output. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Default As String = "Log"
C#
public const string Default = "Log";
C++
public:
const String Default = L"Log";
J#
public const string Default = "Log"
JScript
public const Default : String = "Log";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


Failures Field

TestLogStreamNames.Failures Field
[image]

The name of the built-in log stream where assertion failures, exceptions and other failure data are recorded. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Failures As String = "Failures"
C#
public const string Failures = "Failures";
C++
public:
const String Failures = L"Failures";
J#
public const string Failures = "Failures"
JScript
public const Failures : String = "Failures";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


Warnings Field

TestLogStreamNames.Warnings Field
[image]

The name of the built-in log stream where warnings are recorded. This field is constant and read-only.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Warnings As String = "Warnings"
C#
public const string Warnings = "Warnings";
C++
public:
const String Warnings = L"Warnings";
J#
public const string Warnings = "Warnings"
JScript
public const Warnings : String = "Warnings";

See Also

TestLogStreamNames Class
Gallio.Model.Logging Namespace


TestLogStreamWriter Class

TestLogStreamWriter Class
See Also Example Members
[image]

A log stream writer provides methods for writing rich structured text with embedded attachments, nested sections and hidden semantic markers to a particular stream within a log writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TestLogStreamWriter
Inherits TextWriter
C#
public class TestLogStreamWriter : TextWriter
C++
ref class TestLogStreamWriter : TextWriter
J#
public class TestLogStreamWriter extends TextWriter
JScript
public class TestLogStreamWriter extends TextWriter

Remarks

The operations on this interface are thread-safe.

The object extends MarshalByRefObject so instances may be accessed by remote clients if required.

Newlines are always normalized to LFs ('\n') only. Any CRs ('\r') that are written are automatically stripped.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.TextWriter
Gallio.Model.Logging.TestLogStreamWriter
Gallio.Model.Logging.StructuredTextWriter

See Also

TestLogStreamWriter Members
Gallio.Model.Logging Namespace
TestLogWriter


TestLogStreamWriter Members

TestLogStreamWriter Members
See Also Example Constructors Fields Properties Methods
[image]

A log stream writer provides methods for writing rich structured text with embedded attachments, nested sections and hidden semantic markers to a particular stream within a log writer.

The following tables list the members exposed by TestLogStreamWriter.

Public Constructors

 | Name | Description
Public method | TestLogStreamWriter | Creates a log stream writer.
Top

Protected Fields

 | Name | Description
Family field | CoreNewLine | Stores the new line characters used for this TextWriter. (inherited from TextWriter)
Top

Public Properties

 | Name | Description
Public property | Container | Gets the containing log writer.
Public property | Encoding | Overridden. When overridden in a derived class, returns the Encoding in which the output is written.
Public property | FormatProvider | Gets an object that controls formatting. (inherited from TextWriter)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter.
Public property | StreamName | Gets the name of the log stream being written.
Top

Public Methods

 | Name | Description
Public method | BeginMarker | Begins a marked region. Maybe be nested. A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.
Public method | BeginSection | Begins a section with the specified name. Maybe be nested. A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading.
Public method | Close | Closes the current writer and releases any system resources associated with the writer. (inherited from TextWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases all resources used by the TextWriter object.
Public method | Embed | Embeds an attachment.
Public method | EmbedExisting | Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached.
Public method | EmbedHtml | Embeds an HTML attachment with mime-type Html.
Public method | EmbedImage | Embeds an image attachment with a mime-type compatible with its internal representation.
Public method | EmbedObjectAsXml | Overloaded. Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.
Public method | EmbedPlainText | Embeds an plain text attachment with mime-type PlainText.
Public method | EmbedXHtml | Embeds an XHTML attachment with mime-type XHtml.
Public method | EmbedXml | Embeds an XML attachment with mime-type Xml.
Public method | End | Ends the region most recently started with one of the Begin* methods.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded. Writes the given data type to a text stream.
Public method | WriteEllipsis | Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated.
Public method | WriteException | Overloaded. Writes an exception.
Public method | WriteHighlighted | Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values.
Public method | WriteLine | Overloaded. Writes some data as specified by the overloaded parameters, followed by a line terminator.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases all resources used by the TextWriter object.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogWriter


TestLogStreamWriter Constructor

TestLogStreamWriter Constructor
[image]

Creates a log stream writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal container As TestLogWriter, _
ByVal streamName As String _
)
C#
public TestLogStreamWriter(
TestLogWriter container,
string streamName
)
C++
public:
TestLogStreamWriter(
TestLogWriter container,
String streamName
) sealed
J#
public TestLogStreamWriter(
TestLogWriter container,
string streamName
)
JScript
public function TestLogStreamWriter(
container : TestLogWriter,
streamName : String
)

Parameters

container
The containing log writer
streamName
The stream name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if container or streamName is null

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Properties

TestLogStreamWriter Properties
[image]

Public Properties

 | Name | Description
Public property | Container | Gets the containing log writer.
Public property | Encoding | Overridden. When overridden in a derived class, returns the Encoding in which the output is written.
Public property | FormatProvider | Gets an object that controls formatting. (inherited from TextWriter)
Public property | NewLine | Gets or sets the line terminator string used by the current TextWriter.
Public property | StreamName | Gets the name of the log stream being written.
Top

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogWriter


Container Property

TestLogStreamWriter.Container Property
[image]

Gets the containing log writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As TestLogWriter
C#
public TestLogWriter Container { get; }
C++
public property TestLogWriter Container sealed {
TestLogWriter get();
}
J#
/** property */
public TestLogWriter get_Container();
JScript
public function get Container() : TestLogWriter

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Encoding Property

TestLogStreamWriter.Encoding Property
[image]

When overridden in a derived class, returns the Encoding in which the output is written.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Encoding As Encoding
C#
public override Encoding Encoding { get; }
C++
public override property Encoding Encoding override {
Encoding get();
}
J#
/** property */
public Encoding get_Encoding();
JScript
public function get Encoding() : Encoding

Property Value

The Encoding in which the output is written.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


NewLine Property

TestLogStreamWriter.NewLine Property
[image]

Gets or sets the line terminator string used by the current TextWriter.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewLine As String
C#
public string NewLine { get; }
C++
public property string NewLine sealed {
String get();
}
J#
/** property */
public string get_NewLine();
JScript
public function get NewLine() : String

Property Value

The line terminator string for the current TextWriter.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


StreamName Property

TestLogStreamWriter.StreamName Property
[image]

Gets the name of the log stream being written.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StreamName As String
C#
public string StreamName { get; }
C++
public property string StreamName sealed {
String get();
}
J#
/** property */
public string get_StreamName();
JScript
public function get StreamName() : String

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Methods

TestLogStreamWriter Methods
[image]

Public Methods

 | Name | Description
Public method | BeginMarker | Begins a marked region. Maybe be nested. A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.
Public method | BeginSection | Begins a section with the specified name. Maybe be nested. A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading.
Public method | Close | Closes the current writer and releases any system resources associated with the writer. (inherited from TextWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases all resources used by the TextWriter object.
Public method | Embed | Embeds an attachment.
Public method | EmbedExisting | Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached.
Public method | EmbedHtml | Embeds an HTML attachment with mime-type Html.
Public method | EmbedImage | Embeds an image attachment with a mime-type compatible with its internal representation.
Public method | EmbedObjectAsXml | Overloaded. Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.
Public method | EmbedPlainText | Embeds an plain text attachment with mime-type PlainText.
Public method | EmbedXHtml | Embeds an XHTML attachment with mime-type XHtml.
Public method | EmbedXml | Embeds an XML attachment with mime-type Xml.
Public method | End | Ends the region most recently started with one of the Begin* methods.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded. Writes the given data type to a text stream.
Public method | WriteEllipsis | Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated.
Public method | WriteException | Overloaded. Writes an exception.
Public method | WriteHighlighted | Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values.
Public method | WriteLine | Overloaded. Writes some data as specified by the overloaded parameters, followed by a line terminator.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Releases all resources used by the TextWriter object.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogWriter


BeginMarker Method

TestLogStreamWriter.BeginMarker Method
[image]

Begins a marked region. Maybe be nested.

A marker is a hidden tag that labels its contents with a semantic class. It is roughly equivalent in operation to an HTML "span" tag. Various tools may inspect the markers and modify the presentation accordingly.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginMarker( _
ByVal marker As Marker _
) As IDisposable
C#
public IDisposable BeginMarker(
Marker marker
)
C++
public:
IDisposable BeginMarker(
Marker marker
) sealed
J#
public IDisposable BeginMarker(
Marker marker
)
JScript
public function BeginMarker(
marker : Marker
) : IDisposable

Parameters

marker
The marker

Return Value

A Disposable object that calls End when disposed. This is a convenience for use with the C# "using" statement.

Example

Copy Code
            using (Log.BeginMarker(Marker.Monospace))
            {
                Log.WriteLine(contents);
            }

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


BeginSection Method

TestLogStreamWriter.BeginSection Method
[image]

Begins a section with the specified name. Maybe be nested.

A section groups together related content in the test log to make it easier to distinguish. The section name is used as a heading.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function BeginSection( _
ByVal sectionName As String _
) As IDisposable
C#
public IDisposable BeginSection(
string sectionName
)
C++
public:
IDisposable BeginSection(
String sectionName
) sealed
J#
public IDisposable BeginSection(
string sectionName
)
JScript
public function BeginSection(
sectionName : String
) : IDisposable

Parameters

sectionName
The name of the section

Return Value

A Disposable object that calls End when disposed. This is a convenience for use with the C# "using" statement.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sectionName is null

Example

Copy Code
            using (Log.Default.BeginSection("Doing something interesting"))
            {
                Log.Default.WriteLine("Ah ha!");
            }

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Dispose Method

TestLogStreamWriter.Dispose Method

Releases all resources used by the TextWriter object.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | This method does not make sense for a log stream writer because a stream cannot be closed independently of its containing log.
Public method | Dispose | Releases all resources used by the TextWriter object. (inherited from TextWriter)

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Dispose Method (Boolean)

TestLogStreamWriter.Dispose Method (Boolean)
See Also Example
[image]

This method does not make sense for a log stream writer because a stream cannot be closed independently of its containing log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected void Dispose(
bool disposing
)
C++
protected:
void Dispose(
bool disposing
) sealed
J#
protected void Dispose(
bool disposing
)
JScript
protected function Dispose(
disposing : bool
)

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.Dispose Overload List


Embed Method

TestLogStreamWriter.Embed Method
[image]

Embeds an attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Embed( _
ByVal attachment As Attachment _
) As Attachment
C#
public Attachment Embed(
Attachment attachment
)
C++
public:
Attachment Embed(
Attachment attachment
) sealed
J#
public Attachment Embed(
Attachment attachment
)
JScript
public function Embed(
attachment : Attachment
) : Attachment

Parameters

attachment
The attachment to embed

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachment is null
InvalidOperationException | Thrown if there is already an attachment with the same name

Remarks

An attachment instance can be embedded multiple times efficiently since each embedded copy is typically represented as a link to the same common attachment instance.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
Attach


EmbedExisting Method

TestLogStreamWriter.EmbedExisting Method
[image]

Embeds another copy of an existing attachment. This method can be used to repeatedly embed an existing attachment at multiple points in multiple streams without needing to keep the Attachment instance itself around. This can help to reduce memory footprint since the original Attachment instance can be garbage collected shortly after it is first attached.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub EmbedExisting( _
ByVal attachmentName As String _
)
C#
public void EmbedExisting(
string attachmentName
)
C++
public:
void EmbedExisting(
String attachmentName
) sealed
J#
public void EmbedExisting(
string attachmentName
)
JScript
public function EmbedExisting(
attachmentName : String
)

Parameters

attachmentName
The name of the existing attachment to embed

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachmentName is null
InvalidOperationException | Thrown if no attachment with the specified name has been previously attached

Remarks

An attachment instance can be embedded multiple times efficiently since each embedded copy is typically represented as a link to the same common attachment instance.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
Attach
Embed


EmbedHtml Method

TestLogStreamWriter.EmbedHtml Method
[image]

Embeds an HTML attachment with mime-type Html.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedHtml( _
ByVal attachmentName As String, _
ByVal html As String _
) As TextAttachment
C#
public TextAttachment EmbedHtml(
string attachmentName,
string html
)
C++
public:
TextAttachment EmbedHtml(
String attachmentName,
String html
) sealed
J#
public TextAttachment EmbedHtml(
string attachmentName,
string html
)
JScript
public function EmbedHtml(
attachmentName : String,
html : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
html
The HTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if html is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
AttachHtml


EmbedImage Method

TestLogStreamWriter.EmbedImage Method
[image]

Embeds an image attachment with a mime-type compatible with its internal representation.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedImage( _
ByVal attachmentName As String, _
ByVal image As Image _
) As BinaryAttachment
C#
public BinaryAttachment EmbedImage(
string attachmentName,
Image image
)
C++
public:
BinaryAttachment EmbedImage(
String attachmentName,
Image image
) sealed
J#
public BinaryAttachment EmbedImage(
string attachmentName,
Image image
)
JScript
public function EmbedImage(
attachmentName : String,
image : Image
) : BinaryAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
image
The image to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if image is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
AttachImage


EmbedObjectAsXml Method

TestLogStreamWriter.EmbedObjectAsXml Method

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

Overload List

 | Name | Description
Public method | EmbedObjectAsXml (String, Object) | Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.
Public method | EmbedObjectAsXml (String, Object, XmlSerializer) | Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


EmbedObjectAsXml Method (String, Object)

TestLogStreamWriter.EmbedObjectAsXml Method (String, Object)
See Also Example
[image]

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object _
) As TextAttachment
C#
public TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj
)
C++
public:
TextAttachment EmbedObjectAsXml(
String attachmentName,
Object obj
) sealed
J#
public TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj
)
JScript
public function EmbedObjectAsXml(
attachmentName : String,
obj : Object
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.EmbedObjectAsXml Overload List
AttachObjectAsXml


EmbedObjectAsXml Method (String, Object, XmlSerializer)

TestLogStreamWriter.EmbedObjectAsXml Method (String, Object, XmlSerializer)
See Also Example
[image]

Embeds an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object, _
ByVal xmlSerializer As XmlSerializer _
) As TextAttachment
C#
public TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
C++
public:
TextAttachment EmbedObjectAsXml(
String attachmentName,
Object obj,
XmlSerializer xmlSerializer
) sealed
J#
public TextAttachment EmbedObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
JScript
public function EmbedObjectAsXml(
attachmentName : String,
obj : Object,
xmlSerializer : XmlSerializer
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null
xmlSerializer
The XmlSerializer to use, or null to use the default XmlSerializer for the object's type

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.EmbedObjectAsXml Overload List
AttachObjectAsXml


EmbedPlainText Method

TestLogStreamWriter.EmbedPlainText Method
[image]

Embeds an plain text attachment with mime-type PlainText.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedPlainText( _
ByVal attachmentName As String, _
ByVal text As String _
) As TextAttachment
C#
public TextAttachment EmbedPlainText(
string attachmentName,
string text
)
C++
public:
TextAttachment EmbedPlainText(
String attachmentName,
String text
) sealed
J#
public TextAttachment EmbedPlainText(
string attachmentName,
string text
)
JScript
public function EmbedPlainText(
attachmentName : String,
text : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
text
The text to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
AttachPlainText


EmbedXHtml Method

TestLogStreamWriter.EmbedXHtml Method
[image]

Embeds an XHTML attachment with mime-type XHtml.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedXHtml( _
ByVal attachmentName As String, _
ByVal xhtml As String _
) As TextAttachment
C#
public TextAttachment EmbedXHtml(
string attachmentName,
string xhtml
)
C++
public:
TextAttachment EmbedXHtml(
String attachmentName,
String xhtml
) sealed
J#
public TextAttachment EmbedXHtml(
string attachmentName,
string xhtml
)
JScript
public function EmbedXHtml(
attachmentName : String,
xhtml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xhtml
The XHTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xhtml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
AttachXHtml


EmbedXml Method

TestLogStreamWriter.EmbedXml Method
[image]

Embeds an XML attachment with mime-type Xml.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EmbedXml( _
ByVal attachmentName As String, _
ByVal xml As String _
) As TextAttachment
C#
public TextAttachment EmbedXml(
string attachmentName,
string xml
)
C++
public:
TextAttachment EmbedXml(
String attachmentName,
String xml
) sealed
J#
public TextAttachment EmbedXml(
string attachmentName,
string xml
)
JScript
public function EmbedXml(
attachmentName : String,
xml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xml
The XML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
AttachXml


End Method

TestLogStreamWriter.End Method
[image]

Ends the region most recently started with one of the Begin* methods.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub End()
C#
public void End()
C++
public:
void End() sealed
J#
public void End()
JScript
public function End()

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if there is no current nested region

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Flush Method

TestLogStreamWriter.Flush Method
[image]

Clears all buffers for the current writer and causes any buffered data to be written to the underlying device.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Flush()
C#
public void Flush()
C++
public:
void Flush() sealed
J#
public void Flush()
JScript
public function Flush()

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Write Method

TestLogStreamWriter.Write Method

Writes the given data type to a text stream.

Overload List

 | Name | Description
Public method | Write (ITestLogStreamWritable) | Writes a test log stream writable object to the stream.
Public method | Write (Char) | Overridden. Writes a character to the text stream.
Public method | Write (Char, Int32, Int32) | Writes a subarray of characters to the text stream.
Public method | Write (Object) | Overridden. Writes the text representation of an object to the text stream by calling ToString on that object.
Public method | Write (String) | Writes a string to the text stream.
Public method | Write (Boolean) | Writes the text representation of a Boolean value to the text stream. (inherited from TextWriter)
Public method | Write (Char) | Writes a character array to the text stream. (inherited from TextWriter)
Public method | Write (Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | Write (Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (inherited from TextWriter)
Public method | Write (Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (inherited from TextWriter)
Public method | Write (Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (inherited from TextWriter)
Public method | Write (Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (inherited from TextWriter)
Public method | Write (String, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (String, Object, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (String, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (inherited from TextWriter)
Public method | Write (UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (inherited from TextWriter)

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


Write Method (ITestLogStreamWritable)

TestLogStreamWriter.Write Method (ITestLogStreamWritable)
See Also Example
[image]

Writes a test log stream writable object to the stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal obj As ITestLogStreamWritable _
)
C#
public void Write(
ITestLogStreamWritable obj
)
C++
public:
void Write(
ITestLogStreamWritable obj
) sealed
J#
public void Write(
ITestLogStreamWritable obj
)
JScript
public function Write(
obj : ITestLogStreamWritable
)

Parameters

obj
The object to write, or null if none

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.Write Overload List


Write Method (Char)

TestLogStreamWriter.Write Method (Char)
See Also Example
[image]

Writes a character to the text stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal value As Char _
)
C#
public override void Write(
char value
)
C++
public:
virtual void Write(
wchar_t value
) override
J#
public override void Write(
char value
)
JScript
public override function Write(
value : char
)

Parameters

value
The character to write to the text stream.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.Write Overload List


Write Method (Char[], Int32, Int32)

TestLogStreamWriter.Write Method (Char[], Int32, Int32)
See Also Example
[image]

Writes a subarray of characters to the text stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal buffer As Char(), _
ByVal index As Integer, _
ByVal count As Integer _
)
C#
public void Write(
char[] buffer,
int index,
int count
)
C++
public:
void Write(
array<wchar_t>^ buffer,
int index,
int count
) sealed
J#
public void Write(
char[] buffer,
int index,
int count
)
JScript
public function Write(
buffer : char[],
index : int,
count : int
)

Parameters

buffer
The character array to write data from.
index
Starting index in the buffer.
count
The number of characters to write.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.Write Overload List


Write Method (Object)

TestLogStreamWriter.Write Method (Object)
See Also Example
[image]

Writes the text representation of an object to the text stream by calling ToString on that object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal value As Object _
)
C#
public override void Write(
object value
)
C++
public:
virtual void Write(
Object value
) override
J#
public override void Write(
object value
)
JScript
public override function Write(
value : Object
)

Parameters

value
The object to write.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.Write Overload List


Write Method (String)

TestLogStreamWriter.Write Method (String)
See Also Example
[image]

Writes a string to the text stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As String _
)
C#
public void Write(
string value
)
C++
public:
void Write(
String value
) sealed
J#
public void Write(
string value
)
JScript
public function Write(
value : String
)

Parameters

value
The string to write.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.Write Overload List


WriteEllipsis Method

TestLogStreamWriter.WriteEllipsis Method
[image]

Writes an ellipsis to indicate where content has been elided for brevity. An ellipsis may be used, for example, when printing assertion failures to clearly identify sections where the user is not being presented all of the information because it was too long and had to be truncated.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteEllipsis()
C#
public void WriteEllipsis()
C++
public:
void WriteEllipsis() sealed
J#
public void WriteEllipsis()
JScript
public function WriteEllipsis()

Remarks

This is a convenience method that simply encapsulates "..." within a marked region of type Ellipsis. However, tools may reinterpret the special marker to make the "..." less ambiguous.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


WriteException Method

TestLogStreamWriter.WriteException Method

Writes an exception.

Overload List

 | Name | Description
Public method | WriteException (ExceptionData) | Writes an exception.
Public method | WriteException (ExceptionData, String) | Writes an exception within its own section which provides additional cues for interpretation.
Public method | WriteException (Exception) | Writes an exception.
Public method | WriteException (Exception, String) | Writes an exception within its own section.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


WriteException Method (ExceptionData)

TestLogStreamWriter.WriteException Method (ExceptionData)
See Also Example
[image]

Writes an exception.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteException( _
ByVal exception As ExceptionData _
)
C#
public void WriteException(
ExceptionData exception
)
C++
public:
void WriteException(
ExceptionData exception
) sealed
J#
public void WriteException(
ExceptionData exception
)
JScript
public function WriteException(
exception : ExceptionData
)

Parameters

exception
The exception data to write

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.WriteException Overload List


WriteException Method (ExceptionData, String)

TestLogStreamWriter.WriteException Method (ExceptionData, String)
See Also Example
[image]

Writes an exception within its own section which provides additional cues for interpretation.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteException( _
ByVal exception As ExceptionData, _
ByVal sectionName As String _
)
C#
public void WriteException(
ExceptionData exception,
string sectionName
)
C++
public:
void WriteException(
ExceptionData exception,
String sectionName
) sealed
J#
public void WriteException(
ExceptionData exception,
string sectionName
)
JScript
public function WriteException(
exception : ExceptionData,
sectionName : String
)

Parameters

exception
The exception data to write
sectionName
The section name, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.WriteException Overload List


WriteException Method (Exception)

TestLogStreamWriter.WriteException Method (Exception)
See Also Example
[image]

Writes an exception.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteException( _
ByVal exception As Exception _
)
C#
public void WriteException(
Exception exception
)
C++
public:
void WriteException(
Exception exception
) sealed
J#
public void WriteException(
Exception exception
)
JScript
public function WriteException(
exception : Exception
)

Parameters

exception
The exception to write

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.WriteException Overload List


WriteException Method (Exception, String)

TestLogStreamWriter.WriteException Method (Exception, String)
See Also Example
[image]

Writes an exception within its own section.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteException( _
ByVal exception As Exception, _
ByVal sectionName As String _
)
C#
public void WriteException(
Exception exception,
string sectionName
)
C++
public:
void WriteException(
Exception exception,
String sectionName
) sealed
J#
public void WriteException(
Exception exception,
string sectionName
)
JScript
public function WriteException(
exception : Exception,
sectionName : String
)

Parameters

exception
The exception to write
sectionName
The section name, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exception is null

Remarks

The exception will not be terminated by a new line.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.WriteException Overload List


WriteHighlighted Method

TestLogStreamWriter.WriteHighlighted Method
[image]

Writes highlighted text. Highlights can be used to emphasize important information such differences between similar expected and actual values.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteHighlighted( _
ByVal text As String _
)
C#
public void WriteHighlighted(
string text
)
C++
public:
void WriteHighlighted(
String text
) sealed
J#
public void WriteHighlighted(
string text
)
JScript
public function WriteHighlighted(
text : String
)

Parameters

text
The text to write, or null if none

Remarks

This is a convenience method that simply encapsulates the highlighted text within a marked region of type Highlight.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


WriteLine Method

TestLogStreamWriter.WriteLine Method

Writes some data as specified by the overloaded parameters, followed by a line terminator.

Overload List

 | Name | Description
Public method | WriteLine (Object) | Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream.
Public method | WriteLine | Writes a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Boolean) | Writes the text representation of a Boolean followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Char) | Writes a character followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Char) | Writes an array of characters followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Char, Int32, Int32) | Writes a subarray of characters followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Double) | Writes the text representation of a 8-byte floating-point value followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Int32) | Writes the text representation of a 4-byte signed integer followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Int64) | Writes the text representation of an 8-byte signed integer followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (Single) | Writes the text representation of a 4-byte floating-point value followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (String) | Writes a string followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (String, Object) | Writes out a formatted string and a new line, using the same semantics as Format. (inherited from TextWriter)
Public method | WriteLine (String, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format. (inherited from TextWriter)
Public method | WriteLine (String, Object, Object, Object) | Writes out a formatted string and a new line, using the same semantics as Format. (inherited from TextWriter)
Public method | WriteLine (String, Object) | Writes out a formatted string and a new line, using the same semantics as Format. (inherited from TextWriter)
Public method | WriteLine (UInt32) | Writes the text representation of a 4-byte unsigned integer followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | WriteLine (UInt64) | Writes the text representation of an 8-byte unsigned integer followed by a line terminator to the text stream. (inherited from TextWriter)

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace


WriteLine Method (Object)

TestLogStreamWriter.WriteLine Method (Object)
See Also Example
[image]

Writes the text representation of an object by calling ToString on this object, followed by a line terminator to the text stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteLine( _
ByVal value As Object _
)
C#
public void WriteLine(
object value
)
C++
public:
void WriteLine(
Object value
) sealed
J#
public void WriteLine(
object value
)
JScript
public function WriteLine(
value : Object
)

Parameters

value
The object to write. If value is null, only the line termination characters are written.

See Also

TestLogStreamWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter.WriteLine Overload List


TestLogWriter Class

TestLogWriter Class
See Also Example Members
[image]

A log records the output of a test during its execution including any text that was written to console output streams, exceptions that occurred, and anything else the test writer might want to save.

A log consists of zero or more log streams that are opened automatically on demand to capture independent sequences of log output. Each stream can further be broken down into possibly nested sections to classify output during different phases of test execution (useful for drilling into complex tests). In addition to text, a log can contain attachments that are either attached at the top level of the log or embedded into log streams. Attachments are typed by mime-type and can contain Text, Xml, Images, Blobs, or any other content. Certain test frameworks may automatically create attachments to gather all manner of diagnostic information over the course of the test.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
DefaultMemberAttribute("Item")>
Public MustInherit Class TestLogWriter
Inherits MarshalByRefObject
C#
[SerializableAttribute]
[DefaultMemberAttribute("Item")]
public abstract class TestLogWriter : MarshalByRefObject
C++
[SerializableAttribute]
[DefaultMemberAttribute(L"Item")]
ref class TestLogWriter abstract : MarshalByRefObject
J#
/** @attribute SerializableAttribute() */
/** @attribute DefaultMemberAttribute("Item") */
public class TestLogWriter extends MarshalByRefObject
JScript
public
SerializableAttribute
DefaultMemberAttribute("Item")
class TestLogWriter extends MarshalByRefObject

Remarks

All operations on this interface are thread-safe.

Subclasses may assume that the following validation steps have been performed before the implementation methods are called:

  • Checking arguments for null and invalid values
  • Ensuring that the writer has not been closed
  • Ensuring that no attachment with the same name exists when adding an attachment
  • Ensuring that there is an attachment with the specified name exists when embedding an attachment
  • Ensuring that the nesting level of sections and markers is correct and balanced when End is called

The object extends MarshalByRefObject so instances may be accessed by remote clients if required.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Execution.ObservableTestLogWriter
Gallio.Model.Logging.FallbackTestLogWriter
Gallio.Model.Logging.NullTestLogWriter
Gallio.Model.Logging.StructuredTestLogWriter
Gallio.Model.Logging.TextualTestLogWriter

See Also

TestLogWriter Members
Gallio.Model.Logging Namespace
TestLogStreamWriter


TestLogWriter Members

TestLogWriter Members
See Also Example Constructors Properties Methods
[image]

A log records the output of a test during its execution including any text that was written to console output streams, exceptions that occurred, and anything else the test writer might want to save.

A log consists of zero or more log streams that are opened automatically on demand to capture independent sequences of log output. Each stream can further be broken down into possibly nested sections to classify output during different phases of test execution (useful for drilling into complex tests). In addition to text, a log can contain attachments that are either attached at the top level of the log or embedded into log streams. Attachments are typed by mime-type and can contain Text, Xml, Images, Blobs, or any other content. Certain test frameworks may automatically create attachments to gather all manner of diagnostic information over the course of the test.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestLogWriter.

Protected Constructors

 | Name | Description
Family method | TestLogWriter | Initializes a new instance of the TestLogWriter class.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded.
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded.
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded.
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded.
Public property | Default | Gets the stream writer for the built-in log stream.
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded.
Public property | IsClosed | Returns true if the log writer is closed.
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand.
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded.
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log.
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html.
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation.
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText.
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml.
Public method | AttachXml | Attaches an XML attachment with mime-type Xml.
Public method | Close | Closes the log writer.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Adds an attachment to the log.
Family method | CloseImpl | Closes the log.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log.
Family method | GetStreamImpl | Gets a writer for the stream with the specified name.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Begins a section in a log stream.
Family method | StreamEmbedImpl | Embeds an attachment into a log stream.
Family method | StreamEndImpl | Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream.
Family method | StreamWriteImpl | Writes a text string to a log stream.
Top

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter


TestLogWriter Constructor

TestLogWriter Constructor
[image]

Initializes a new instance of the TestLogWriter class.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestLogWriter()
C++
protected:
TestLogWriter() sealed
J#
protected TestLogWriter()
JScript
protected function TestLogWriter()

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Properties

TestLogWriter Properties
[image]

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded.
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded.
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded.
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded.
Public property | Default | Gets the stream writer for the built-in log stream.
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded.
Public property | IsClosed | Returns true if the log writer is closed.
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand.
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded.
Top

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter


ConsoleError Property

TestLogWriter.ConsoleError Property
[image]

Gets the stream writer for the built-in log stream where the Error stream for the test is recorded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConsoleError As TestLogStreamWriter
C#
public TestLogStreamWriter ConsoleError { get; }
C++
public property TestLogStreamWriter ConsoleError sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_ConsoleError();
JScript
public function get ConsoleError() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


ConsoleInput Property

TestLogWriter.ConsoleInput Property
[image]

Gets the stream writer for the built-in log stream where the In stream for the test is recorded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConsoleInput As TestLogStreamWriter
C#
public TestLogStreamWriter ConsoleInput { get; }
C++
public property TestLogStreamWriter ConsoleInput sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_ConsoleInput();
JScript
public function get ConsoleInput() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


ConsoleOutput Property

TestLogWriter.ConsoleOutput Property
[image]

Gets the stream writer for the built-in log stream where the Out stream for the test is recorded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConsoleOutput As TestLogStreamWriter
C#
public TestLogStreamWriter ConsoleOutput { get; }
C++
public property TestLogStreamWriter ConsoleOutput sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_ConsoleOutput();
JScript
public function get ConsoleOutput() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


DebugTrace Property

TestLogWriter.DebugTrace Property
[image]

Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DebugTrace As TestLogStreamWriter
C#
public TestLogStreamWriter DebugTrace { get; }
C++
public property TestLogStreamWriter DebugTrace sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_DebugTrace();
JScript
public function get DebugTrace() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Default Property

TestLogWriter.Default Property
[image]

Gets the stream writer for the built-in log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Default As TestLogStreamWriter
C#
public TestLogStreamWriter Default { get; }
C++
public property TestLogStreamWriter Default sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_Default();
JScript
public function get Default() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Failures Property

TestLogWriter.Failures Property
[image]

Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Failures As TestLogStreamWriter
C#
public TestLogStreamWriter Failures { get; }
C++
public property TestLogStreamWriter Failures sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_Failures();
JScript
public function get Failures() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


IsClosed Property

TestLogWriter.IsClosed Property
[image]

Returns true if the log writer is closed.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed As Boolean
C#
public bool IsClosed { get; }
C++
public property bool IsClosed sealed {
bool get();
}
J#
/** property */
public bool get_IsClosed();
JScript
public function get IsClosed() : bool

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Item Property

TestLogWriter.Item Property
[image]

Gets the log stream with the specified name. If the stream does not exist, it is created on demand.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal streamName As String _
) As TestLogStreamWriter
C#
public TestLogStreamWriter this[
string streamName
] { get; }
C++
public property TestLogStreamWriter default[String streamName] sealed {
TestLogStreamWriter get(String streamName);
}
J#
/** property */
public TestLogStreamWriter get_Item(string streamName);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

Parameters

streamName
The name of the log stream

Property Value

The log stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if streamName is null

Remarks

This property may return different instances of TestLogStreamWriter each time it is called but they always represent the same stream just the same.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Warnings Property

TestLogWriter.Warnings Property
[image]

Gets the stream writer for the built-in log stream where warnings are recorded.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warnings As TestLogStreamWriter
C#
public TestLogStreamWriter Warnings { get; }
C++
public property TestLogStreamWriter Warnings sealed {
TestLogStreamWriter get();
}
J#
/** property */
public TestLogStreamWriter get_Warnings();
JScript
public function get Warnings() : TestLogStreamWriter

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Methods

TestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log.
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html.
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation.
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText.
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml.
Public method | AttachXml | Attaches an XML attachment with mime-type Xml.
Public method | Close | Closes the log writer.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Adds an attachment to the log.
Family method | CloseImpl | Closes the log.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log.
Family method | GetStreamImpl | Gets a writer for the stream with the specified name.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Begins a section in a log stream.
Family method | StreamEmbedImpl | Embeds an attachment into a log stream.
Family method | StreamEndImpl | Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream.
Family method | StreamWriteImpl | Writes a text string to a log stream.
Top

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
TestLogStreamWriter


Attach Method

TestLogWriter.Attach Method
[image]

Attaches an attachment to the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Attach( _
ByVal attachment As Attachment _
) As Attachment
C#
public Attachment Attach(
Attachment attachment
)
C++
public:
Attachment Attach(
Attachment attachment
) sealed
J#
public Attachment Attach(
Attachment attachment
)
JScript
public function Attach(
attachment : Attachment
) : Attachment

Parameters

attachment
The attachment to include

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachment is null
InvalidOperationException | Thrown if there is already an attachment with the same name

Remarks

An attachment instance can be embedded multiple times efficiently since each embedded copy is typically represented as a link to the same common attachment instance.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
Embed


AttachHtml Method

TestLogWriter.AttachHtml Method
[image]

Attaches an HTML attachment with mime-type Html.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachHtml( _
ByVal attachmentName As String, _
ByVal html As String _
) As TextAttachment
C#
public TextAttachment AttachHtml(
string attachmentName,
string html
)
C++
public:
TextAttachment AttachHtml(
String attachmentName,
String html
) sealed
J#
public TextAttachment AttachHtml(
string attachmentName,
string html
)
JScript
public function AttachHtml(
attachmentName : String,
html : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
html
The HTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if html is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
EmbedHtml


AttachImage Method

TestLogWriter.AttachImage Method
[image]

Attaches an image attachment with a mime-type compatible with its internal representation.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachImage( _
ByVal attachmentName As String, _
ByVal image As Image _
) As BinaryAttachment
C#
public BinaryAttachment AttachImage(
string attachmentName,
Image image
)
C++
public:
BinaryAttachment AttachImage(
String attachmentName,
Image image
) sealed
J#
public BinaryAttachment AttachImage(
string attachmentName,
Image image
)
JScript
public function AttachImage(
attachmentName : String,
image : Image
) : BinaryAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
image
The image to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if image is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
EmbedImage


AttachImpl Method

TestLogWriter.AttachImpl Method
[image]

Adds an attachment to the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub AttachImpl( _
ByVal attachment As Attachment _
)
C#
protected abstract void AttachImpl(
Attachment attachment
)
C++
protected:
void AttachImpl(
Attachment attachment
) abstract
J#
protected abstract void AttachImpl(
Attachment attachment
)
JScript
protected abstract function AttachImpl(
attachment : Attachment
)

Parameters

attachment
The attachment to write, never null

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if there is already an attachment with the same name

Remarks

The implementation should allow the same attachment instance to be attached multiple times and optimize this case by representing embedded attachments as links.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


AttachObjectAsXml Method

TestLogWriter.AttachObjectAsXml Method

Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

Overload List

 | Name | Description
Public method | AttachObjectAsXml (String, Object) | Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.
Public method | AttachObjectAsXml (String, Object, XmlSerializer) | Attaches an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


AttachObjectAsXml Method (String, Object)

TestLogWriter.AttachObjectAsXml Method (String, Object)
See Also Example
[image]

Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object _
) As TextAttachment
C#
public TextAttachment AttachObjectAsXml(
string attachmentName,
object obj
)
C++
public:
TextAttachment AttachObjectAsXml(
String attachmentName,
Object obj
) sealed
J#
public TextAttachment AttachObjectAsXml(
string attachmentName,
object obj
)
JScript
public function AttachObjectAsXml(
attachmentName : String,
obj : Object
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
TestLogWriter.AttachObjectAsXml Overload List
EmbedObjectAsXml


AttachObjectAsXml Method (String, Object, XmlSerializer)

TestLogWriter.AttachObjectAsXml Method (String, Object, XmlSerializer)
See Also Example
[image]

Attaches an XML-serialized object as an XML attachment with mime-type Xml using the specified XmlSerializer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachObjectAsXml( _
ByVal attachmentName As String, _
ByVal obj As Object, _
ByVal xmlSerializer As XmlSerializer _
) As TextAttachment
C#
public TextAttachment AttachObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
C++
public:
TextAttachment AttachObjectAsXml(
String attachmentName,
Object obj,
XmlSerializer xmlSerializer
) sealed
J#
public TextAttachment AttachObjectAsXml(
string attachmentName,
object obj,
XmlSerializer xmlSerializer
)
JScript
public function AttachObjectAsXml(
attachmentName : String,
obj : Object,
xmlSerializer : XmlSerializer
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
obj
The object to serialize and embed, must not be null
xmlSerializer
The XmlSerializer to use, or null to use the default XmlSerializer for the object's type

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if obj is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
TestLogWriter.AttachObjectAsXml Overload List
EmbedObjectAsXml


AttachPlainText Method

TestLogWriter.AttachPlainText Method
[image]

Attaches an plain text attachment with mime-type PlainText.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachPlainText( _
ByVal attachmentName As String, _
ByVal text As String _
) As TextAttachment
C#
public TextAttachment AttachPlainText(
string attachmentName,
string text
)
C++
public:
TextAttachment AttachPlainText(
String attachmentName,
String text
) sealed
J#
public TextAttachment AttachPlainText(
string attachmentName,
string text
)
JScript
public function AttachPlainText(
attachmentName : String,
text : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
text
The text to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
EmbedPlainText


AttachXHtml Method

TestLogWriter.AttachXHtml Method
[image]

Attaches an XHTML attachment with mime-type XHtml.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachXHtml( _
ByVal attachmentName As String, _
ByVal xhtml As String _
) As TextAttachment
C#
public TextAttachment AttachXHtml(
string attachmentName,
string xhtml
)
C++
public:
TextAttachment AttachXHtml(
String attachmentName,
String xhtml
) sealed
J#
public TextAttachment AttachXHtml(
string attachmentName,
string xhtml
)
JScript
public function AttachXHtml(
attachmentName : String,
xhtml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xhtml
The XHTML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xhtml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
EmbedXHtml


AttachXml Method

TestLogWriter.AttachXml Method
[image]

Attaches an XML attachment with mime-type Xml.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachXml( _
ByVal attachmentName As String, _
ByVal xml As String _
) As TextAttachment
C#
public TextAttachment AttachXml(
string attachmentName,
string xml
)
C++
public:
TextAttachment AttachXml(
String attachmentName,
String xml
) sealed
J#
public TextAttachment AttachXml(
string attachmentName,
string xml
)
JScript
public function AttachXml(
attachmentName : String,
xml : String
) : TextAttachment

Parameters

attachmentName
The name of the attachment to create or null to automatically assign one. The attachment name must be unique within the scope of the currently executing test step.
xml
The XML to attach

Return Value

The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xml is null
InvalidOperationException | Thrown if there is already an attachment with the same name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace
EmbedXml


Close Method

TestLogWriter.Close Method
[image]

Closes the log writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()
C++
public:
void Close() sealed
J#
public void Close()
JScript
public function Close()

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


CloseImpl Method

TestLogWriter.CloseImpl Method
[image]

Closes the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CloseImpl()
C#
protected virtual void CloseImpl()
C++
protected:
virtual void CloseImpl()
J#
protected virtual void CloseImpl()
JScript
protected virtual function CloseImpl()

Remarks

The implementation may prevent the log from being closed by throwing an exception. When this happens, the log's IsClosed property will remain false.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


Flush Method

TestLogWriter.Flush Method
[image]

Flushes the log writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Flush()
C#
public void Flush()
C++
public:
void Flush() sealed
J#
public void Flush()
JScript
public function Flush()

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


FlushImpl Method

TestLogWriter.FlushImpl Method
[image]

Flushes the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub FlushImpl()
C#
protected virtual void FlushImpl()
C++
protected:
virtual void FlushImpl()
J#
protected virtual void FlushImpl()
JScript
protected virtual function FlushImpl()

Remarks

The implementation should flush all of the individual log streams.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


GetStreamImpl Method

TestLogWriter.GetStreamImpl Method
[image]

Gets a writer for the stream with the specified name.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetStreamImpl( _
ByVal streamName As String _
) As TestLogStreamWriter
C#
protected virtual TestLogStreamWriter GetStreamImpl(
string streamName
)
C++
protected:
virtual TestLogStreamWriter GetStreamImpl(
String streamName
)
J#
protected virtual TestLogStreamWriter GetStreamImpl(
string streamName
)
JScript
protected virtual function GetStreamImpl(
streamName : String
) : TestLogStreamWriter

Parameters

streamName
The stream name, never null

Return Value

The log stream writer

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginMarkerImpl Method

TestLogWriter.StreamBeginMarkerImpl Method
[image]

Begins a marked region in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub StreamBeginMarkerImpl( _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
protected abstract void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
C++
protected:
void StreamBeginMarkerImpl(
String streamName,
Marker marker
) abstract
J#
protected abstract void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
JScript
protected abstract function StreamBeginMarkerImpl(
streamName : String,
marker : Marker
)

Parameters

streamName
The log stream name
marker
The marker

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginSectionImpl Method

TestLogWriter.StreamBeginSectionImpl Method
[image]

Begins a section in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub StreamBeginSectionImpl( _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
protected abstract void StreamBeginSectionImpl(
string streamName,
string sectionName
)
C++
protected:
void StreamBeginSectionImpl(
String streamName,
String sectionName
) abstract
J#
protected abstract void StreamBeginSectionImpl(
string streamName,
string sectionName
)
JScript
protected abstract function StreamBeginSectionImpl(
streamName : String,
sectionName : String
)

Parameters

streamName
The log stream name
sectionName
The name of the section to begin, never null

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


StreamEmbedImpl Method

TestLogWriter.StreamEmbedImpl Method
[image]

Embeds an attachment into a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub StreamEmbedImpl( _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
protected abstract void StreamEmbedImpl(
string streamName,
string attachmentName
)
C++
protected:
void StreamEmbedImpl(
String streamName,
String attachmentName
) abstract
J#
protected abstract void StreamEmbedImpl(
string streamName,
string attachmentName
)
JScript
protected abstract function StreamEmbedImpl(
streamName : String,
attachmentName : String
)

Parameters

streamName
The log stream name
attachmentName
The name of the attachment to write, never null

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if no attachment with the specified name has been previously attached

Remarks

The implementation should allow the same attachment instance to be attached multiple times and optimize this case by representing embedded attachments as links.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


StreamEndImpl Method

TestLogWriter.StreamEndImpl Method
[image]

Ends the current region started with one of the Begin* methods in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub StreamEndImpl( _
ByVal streamName As String _
)
C#
protected abstract void StreamEndImpl(
string streamName
)
C++
protected:
void StreamEndImpl(
String streamName
) abstract
J#
protected abstract void StreamEndImpl(
string streamName
)
JScript
protected abstract function StreamEndImpl(
streamName : String
)

Parameters

streamName
The log stream name

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if there is no current nested region

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


StreamFlushImpl Method

TestLogWriter.StreamFlushImpl Method
[image]

Flushes a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub StreamFlushImpl( _
ByVal streamName As String _
)
C#
protected virtual void StreamFlushImpl(
string streamName
)
C++
protected:
virtual void StreamFlushImpl(
String streamName
)
J#
protected virtual void StreamFlushImpl(
string streamName
)
JScript
protected virtual function StreamFlushImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


StreamWriteImpl Method

TestLogWriter.StreamWriteImpl Method
[image]

Writes a text string to a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub StreamWriteImpl( _
ByVal streamName As String, _
ByVal text As String _
)
C#
protected abstract void StreamWriteImpl(
string streamName,
string text
)
C++
protected:
void StreamWriteImpl(
String streamName,
String text
) abstract
J#
protected abstract void StreamWriteImpl(
string streamName,
string text
)
JScript
protected abstract function StreamWriteImpl(
streamName : String,
text : String
)

Parameters

streamName
The log stream name
text
The text to write, never null

Remarks

The implementation can assume that newlines are normalized to LFs ('\n') only and that CRs ('\r') have been stripped.

See Also

TestLogWriter Class
Gallio.Model.Logging Namespace


TextAttachment Class

TextAttachment Class
See Also Example Members
[image]

Represents a text-encoded attachment. This class cannot be inherited.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class TextAttachment
Inherits Attachment
Implements IEquatable(Of TextAttachment)
C#
[SerializableAttribute]
public sealed class TextAttachment : Attachment, IEquatable<TextAttachment>
C++
[SerializableAttribute]
ref class TextAttachment sealed : Attachment, IEquatable<TextAttachment>
J#
/** @attribute SerializableAttribute() */
public final class TextAttachment extends Attachment implements IEquatable<TextAttachment>
JScript
public
SerializableAttribute
final class TextAttachment extends Attachment, IEquatable<TextAttachment>

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Attachment
Gallio.Model.Logging.TextAttachment

See Also

TextAttachment Members
Gallio.Model.Logging Namespace


TextAttachment Members

TextAttachment Members
See Also Example Constructors Properties Methods
[image]

Represents a text-encoded attachment. This class cannot be inherited.

The following tables list the members exposed by TextAttachment.

Public Constructors

 | Name | Description
Public method | TextAttachment | Creates an attachment.
Top

Public Properties

 | Name | Description
Public property | ContentType | Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types. (inherited from Attachment)
Public property | Name | Gets the name of the attachment, not null. (inherited from Attachment)
Public property | Text | Gets the text of the attachment, not null.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToAttachmentData | Overridden. Generates serializable attachment data from an attachment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


TextAttachment Constructor

TextAttachment Constructor
[image]

Creates an attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal contentType As String, _
ByVal text As String _
)
C#
public TextAttachment(
string name,
string contentType,
string text
)
C++
public:
TextAttachment(
String name,
String contentType,
String text
) sealed
J#
public TextAttachment(
string name,
string contentType,
string text
)
JScript
public function TextAttachment(
name : String,
contentType : String,
text : String
)

Parameters

name
The attachment name, or null to automatically assign one
contentType
The content type, not null
text
The text string, not null

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if contentType or text is null

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


Properties

TextAttachment Properties
[image]

Public Properties

 | Name | Description
Public property | ContentType | Gets the content type of the attachment specified as a MIME type, not null. for definitions of common supported MIME types. (inherited from Attachment)
Public property | Name | Gets the name of the attachment, not null. (inherited from Attachment)
Public property | Text | Gets the text of the attachment, not null.
Top

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


Text Property

TextAttachment.Text Property
[image]

Gets the text of the attachment, not null.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
C++
public property string Text sealed {
String get();
}
J#
/** property */
public string get_Text();
JScript
public function get Text() : String

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


Methods

TextAttachment Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToAttachmentData | Overridden. Generates serializable attachment data from an attachment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


Equals Method

TextAttachment.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (TextAttachment) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


Equals Method (TextAttachment)

TextAttachment.Equals Method (TextAttachment)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As TextAttachment _
) As Boolean _
Implements IEquatable<TextAttachment>.Equals
C#
public bool Equals(
TextAttachment other
)
C++
public:
bool Equals(
TextAttachment other
) sealed
J#
public bool Equals(
TextAttachment other
)
JScript
public function Equals(
other : TextAttachment
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<TextAttachment>.Equals

See Also

TextAttachment Class
Gallio.Model.Logging Namespace
TextAttachment.Equals Overload List


Equals Method (Object)

TextAttachment.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

TextAttachment Class
Gallio.Model.Logging Namespace
TextAttachment.Equals Overload List


GetHashCode Method

TextAttachment.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


ToAttachmentData Method

TextAttachment.ToAttachmentData Method
[image]

Generates serializable attachment data from an attachment.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToAttachmentData() As AttachmentData
C#
public override AttachmentData ToAttachmentData()
C++
public:
virtual AttachmentData ToAttachmentData() override
J#
public override AttachmentData ToAttachmentData()
JScript
public override function ToAttachmentData() : AttachmentData

Return Value

The attachment data

See Also

TextAttachment Class
Gallio.Model.Logging Namespace


TextualTestLogWriter Class

TextualTestLogWriter Class
See Also Example Members
[image]

An implementation of TestLogWriter that represents the test log as text written to a TextWriter.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TextualTestLogWriter
Inherits TestLogWriter
C#
public class TextualTestLogWriter : TestLogWriter
C++
ref class TextualTestLogWriter : TestLogWriter
J#
public class TextualTestLogWriter extends TestLogWriter
JScript
public class TextualTestLogWriter extends TestLogWriter

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Logging.TextualTestLogWriter
Gallio.Model.Logging.StringTestLogWriter

See Also

TextualTestLogWriter Members
Gallio.Model.Logging Namespace
StubTestContextTracker


TextualTestLogWriter Members

TextualTestLogWriter Members
See Also Example Constructors Properties Methods
[image]

An implementation of TestLogWriter that represents the test log as text written to a TextWriter.

The following tables list the members exposed by TextualTestLogWriter.

Public Constructors

 | Name | Description
Public method | TextualTestLogWriter | Creates a stub test log writer.
Top

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Protected Properties

 | Name | Description
Family property | Verbose | Returns true if the verbose print mode is enabled.
Family property | Writer | Gets the underlying text writer.
Top

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace
StubTestContextTracker


TextualTestLogWriter Constructor

TextualTestLogWriter Constructor
[image]

Creates a stub test log writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal writer As TextWriter, _
ByVal verbose As Boolean _
)
C#
public TextualTestLogWriter(
TextWriter writer,
bool verbose
)
C++
public:
TextualTestLogWriter(
TextWriter writer,
bool verbose
) sealed
J#
public TextualTestLogWriter(
TextWriter writer,
bool verbose
)
JScript
public function TextualTestLogWriter(
writer : TextWriter,
verbose : bool
)

Parameters

writer
The text writer to write to
verbose
If true, prints detailed information about the location of attachments, sections, and markers, otherwise discards these formatting details and prints section headers as text on their own line

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writer is null

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


Properties

TextualTestLogWriter Properties
[image]

Public Properties

 | Name | Description
Public property | ConsoleError | Gets the stream writer for the built-in log stream where the Error stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleInput | Gets the stream writer for the built-in log stream where the In stream for the test is recorded. (inherited from TestLogWriter)
Public property | ConsoleOutput | Gets the stream writer for the built-in log stream where the Out stream for the test is recorded. (inherited from TestLogWriter)
Public property | DebugTrace | Gets the stream writer for the built-in log stream where diagnostic Debug and Trace information is recorded. (inherited from TestLogWriter)
Public property | Default | Gets the stream writer for the built-in log stream. (inherited from TestLogWriter)
Public property | Failures | Gets the stream writer for the built-in log stream where assertion failures, exceptions and other failure data are recorded. (inherited from TestLogWriter)
Public property | IsClosed | Returns true if the log writer is closed. (inherited from TestLogWriter)
Public property | Item | Gets the log stream with the specified name. If the stream does not exist, it is created on demand. (inherited from TestLogWriter)
Public property | Warnings | Gets the stream writer for the built-in log stream where warnings are recorded. (inherited from TestLogWriter)
Top

Protected Properties

 | Name | Description
Family property | Verbose | Returns true if the verbose print mode is enabled.
Family property | Writer | Gets the underlying text writer.
Top

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace
StubTestContextTracker


Verbose Property

TextualTestLogWriter.Verbose Property
[image]

Returns true if the verbose print mode is enabled.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Verbose As Boolean
C#
protected bool Verbose { get; }
C++
protected property bool Verbose sealed {
bool get();
}
J#
/** property */
protected bool get_Verbose();
JScript
protected function get Verbose() : bool

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


Writer Property

TextualTestLogWriter.Writer Property
[image]

Gets the underlying text writer.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Writer As TextWriter
C#
protected TextWriter Writer { get; }
C++
protected property TextWriter Writer sealed {
TextWriter get();
}
J#
/** property */
protected TextWriter get_Writer();
JScript
protected function get Writer() : TextWriter

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


Methods

TextualTestLogWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Attach | Attaches an attachment to the log. (inherited from TestLogWriter)
Public method | AttachHtml | Attaches an HTML attachment with mime-type Html. (inherited from TestLogWriter)
Public method | AttachImage | Attaches an image attachment with a mime-type compatible with its internal representation. (inherited from TestLogWriter)
Public method | AttachObjectAsXml | Overloaded. Attaches an XML-serialized object as an XML attachment with mime-type Xml using the default XmlSerializer for the object's type. (inherited from TestLogWriter)
Public method | AttachPlainText | Attaches an plain text attachment with mime-type PlainText. (inherited from TestLogWriter)
Public method | AttachXHtml | Attaches an XHTML attachment with mime-type XHtml. (inherited from TestLogWriter)
Public method | AttachXml | Attaches an XML attachment with mime-type Xml. (inherited from TestLogWriter)
Public method | Close | Closes the log writer. (inherited from TestLogWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes the log writer. (inherited from TestLogWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AttachImpl | Overridden. Adds an attachment to the log.
Family method | CloseImpl | Closes the log. (inherited from TestLogWriter)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | FlushImpl | Flushes the log. (inherited from TestLogWriter)
Family method | GetStreamImpl | Gets a writer for the stream with the specified name. (inherited from TestLogWriter)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | StreamBeginMarkerImpl | Overridden. Begins a marked region in a log stream.
Family method | StreamBeginSectionImpl | Overridden. Begins a section in a log stream.
Family method | StreamEmbedImpl | Overridden. Embeds an attachment into a log stream.
Family method | StreamEndImpl | Overridden. Ends the current region started with one of the Begin* methods in a log stream.
Family method | StreamFlushImpl | Flushes a log stream. (inherited from TestLogWriter)
Family method | StreamWriteImpl | Overridden. Writes a text string to a log stream.
Top

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace
StubTestContextTracker


AttachImpl Method

TextualTestLogWriter.AttachImpl Method
[image]

Adds an attachment to the log.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AttachImpl( _
ByVal attachment As Attachment _
)
C#
protected override void AttachImpl(
Attachment attachment
)
C++
protected:
virtual void AttachImpl(
Attachment attachment
) override
J#
protected override void AttachImpl(
Attachment attachment
)
JScript
protected override function AttachImpl(
attachment : Attachment
)

Parameters

attachment
The attachment to write, never null

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginMarkerImpl Method

TextualTestLogWriter.StreamBeginMarkerImpl Method
[image]

Begins a marked region in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginMarkerImpl( _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
C++
protected:
virtual void StreamBeginMarkerImpl(
String streamName,
Marker marker
) override
J#
protected override void StreamBeginMarkerImpl(
string streamName,
Marker marker
)
JScript
protected override function StreamBeginMarkerImpl(
streamName : String,
marker : Marker
)

Parameters

streamName
The log stream name
marker
The marker

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


StreamBeginSectionImpl Method

TextualTestLogWriter.StreamBeginSectionImpl Method
[image]

Begins a section in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamBeginSectionImpl( _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
C++
protected:
virtual void StreamBeginSectionImpl(
String streamName,
String sectionName
) override
J#
protected override void StreamBeginSectionImpl(
string streamName,
string sectionName
)
JScript
protected override function StreamBeginSectionImpl(
streamName : String,
sectionName : String
)

Parameters

streamName
The log stream name
sectionName
The name of the section to begin, never null

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEmbedImpl Method

TextualTestLogWriter.StreamEmbedImpl Method
[image]

Embeds an attachment into a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEmbedImpl( _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
C++
protected:
virtual void StreamEmbedImpl(
String streamName,
String attachmentName
) override
J#
protected override void StreamEmbedImpl(
string streamName,
string attachmentName
)
JScript
protected override function StreamEmbedImpl(
streamName : String,
attachmentName : String
)

Parameters

streamName
The log stream name
attachmentName
The name of the attachment to write, never null

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


StreamEndImpl Method

TextualTestLogWriter.StreamEndImpl Method
[image]

Ends the current region started with one of the Begin* methods in a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamEndImpl( _
ByVal streamName As String _
)
C#
protected override void StreamEndImpl(
string streamName
)
C++
protected:
virtual void StreamEndImpl(
String streamName
) override
J#
protected override void StreamEndImpl(
string streamName
)
JScript
protected override function StreamEndImpl(
streamName : String
)

Parameters

streamName
The log stream name

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


StreamWriteImpl Method

TextualTestLogWriter.StreamWriteImpl Method
[image]

Writes a text string to a log stream.

Namespace: Gallio.Model.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub StreamWriteImpl( _
ByVal streamName As String, _
ByVal text As String _
)
C#
protected override void StreamWriteImpl(
string streamName,
string text
)
C++
protected:
virtual void StreamWriteImpl(
String streamName,
String text
) override
J#
protected override void StreamWriteImpl(
string streamName,
string text
)
JScript
protected override function StreamWriteImpl(
streamName : String,
text : String
)

Parameters

streamName
The log stream name
text
The text to write, never null

See Also

TextualTestLogWriter Class
Gallio.Model.Logging Namespace


Gallio.Model.Logging.Tags

Gallio.Model.Logging.Tags Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | BaseTagVisitor | An abstract base class for tag visitors that recursively traverses all tags and does nothing else by default. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BodyTag | The top-level container tag of structured text. This class cannot be inherited.
Public class | ContainerTag | An abstract container tag for representing tags that can contain other tags. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | EmbedTag | An embedded attachment tag. This class cannot be inherited.
Public class | MarkerTag | A marker tag. This class cannot be inherited.
NestedPublic class | MarkerTag.Attribute | Represents a marker attribute. This class cannot be inherited.
Public class | SectionTag | A section tag. This class cannot be inherited.
Public class | Tag | An tag represents a portion of the contents of a structured test log stream. Each one can be thought of as a command that will regenerate the structured test log stream when written back out. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TagFormatter | Formats Tag instances to plain text. Text tags are written as-is. Sections introduce paragraph breaks with the header written out as the first line. Embedded attachments are described by name.
Public class | TextTag | A text tag, containing text. This class cannot be inherited.

Interfaces

 | Interface | Description
Public interface | ITagVisitor | Visits a Tag.


BaseTagVisitor Class

BaseTagVisitor Class
See Also Example Members
[image]

An abstract base class for tag visitors that recursively traverses all tags and does nothing else by default. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTagVisitor
Implements ITagVisitor
C#
public abstract class BaseTagVisitor : ITagVisitor
C++
ref class BaseTagVisitor abstract : ITagVisitor
J#
public class BaseTagVisitor implements ITagVisitor
JScript
public class BaseTagVisitor extends ITagVisitor

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.BaseTagVisitor

See Also

BaseTagVisitor Members
Gallio.Model.Logging.Tags Namespace


BaseTagVisitor Members

BaseTagVisitor Members
See Also Example Constructors Methods
[image]

An abstract base class for tag visitors that recursively traverses all tags and does nothing else by default. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTagVisitor.

Protected Constructors

 | Name | Description
Family method | BaseTagVisitor | Initializes a new instance of the BaseTagVisitor class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | VisitBodyTag | Visits a body tag.
Public method | VisitEmbedTag | Visits an embedded attachment tag.
Public method | VisitMarkerTag | Visits a marker tag.
Public method | VisitSectionTag | Visits a section tag.
Public method | VisitTextTag | Visits a text tag.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


BaseTagVisitor Constructor

BaseTagVisitor Constructor
[image]

Initializes a new instance of the BaseTagVisitor class.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseTagVisitor()
C++
protected:
BaseTagVisitor() sealed
J#
protected BaseTagVisitor()
JScript
protected function BaseTagVisitor()

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


Methods

BaseTagVisitor Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | VisitBodyTag | Visits a body tag.
Public method | VisitEmbedTag | Visits an embedded attachment tag.
Public method | VisitMarkerTag | Visits a marker tag.
Public method | VisitSectionTag | Visits a section tag.
Public method | VisitTextTag | Visits a text tag.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


VisitBodyTag Method

BaseTagVisitor.VisitBodyTag Method
[image]

Visits a body tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitBodyTag( _
ByVal tag As BodyTag _
) _
Implements ITagVisitor.VisitBodyTag
C#
public virtual void VisitBodyTag(
BodyTag tag
)
C++
public:
virtual void VisitBodyTag(
BodyTag tag
)
J#
public virtual void VisitBodyTag(
BodyTag tag
)
JScript
public virtual function VisitBodyTag(
tag : BodyTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitBodyTag

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


VisitEmbedTag Method

BaseTagVisitor.VisitEmbedTag Method
[image]

Visits an embedded attachment tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitEmbedTag( _
ByVal tag As EmbedTag _
) _
Implements ITagVisitor.VisitEmbedTag
C#
public virtual void VisitEmbedTag(
EmbedTag tag
)
C++
public:
virtual void VisitEmbedTag(
EmbedTag tag
)
J#
public virtual void VisitEmbedTag(
EmbedTag tag
)
JScript
public virtual function VisitEmbedTag(
tag : EmbedTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitEmbedTag

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


VisitMarkerTag Method

BaseTagVisitor.VisitMarkerTag Method
[image]

Visits a marker tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitMarkerTag( _
ByVal tag As MarkerTag _
) _
Implements ITagVisitor.VisitMarkerTag
C#
public virtual void VisitMarkerTag(
MarkerTag tag
)
C++
public:
virtual void VisitMarkerTag(
MarkerTag tag
)
J#
public virtual void VisitMarkerTag(
MarkerTag tag
)
JScript
public virtual function VisitMarkerTag(
tag : MarkerTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitMarkerTag

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


VisitSectionTag Method

BaseTagVisitor.VisitSectionTag Method
[image]

Visits a section tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitSectionTag( _
ByVal tag As SectionTag _
) _
Implements ITagVisitor.VisitSectionTag
C#
public virtual void VisitSectionTag(
SectionTag tag
)
C++
public:
virtual void VisitSectionTag(
SectionTag tag
)
J#
public virtual void VisitSectionTag(
SectionTag tag
)
JScript
public virtual function VisitSectionTag(
tag : SectionTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitSectionTag

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


VisitTextTag Method

BaseTagVisitor.VisitTextTag Method
[image]

Visits a text tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitTextTag( _
ByVal tag As TextTag _
) _
Implements ITagVisitor.VisitTextTag
C#
public virtual void VisitTextTag(
TextTag tag
)
C++
public:
virtual void VisitTextTag(
TextTag tag
)
J#
public virtual void VisitTextTag(
TextTag tag
)
JScript
public virtual function VisitTextTag(
tag : TextTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitTextTag

See Also

BaseTagVisitor Class
Gallio.Model.Logging.Tags Namespace


BodyTag Class

BodyTag Class
See Also Example Members
[image]

The top-level container tag of structured text. This class cannot be inherited.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("body", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class BodyTag
Inherits ContainerTag
C#
[SerializableAttribute]
[XmlRootAttribute("body", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class BodyTag : ContainerTag
C++
[SerializableAttribute]
[XmlRootAttribute(L"body", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class BodyTag sealed : ContainerTag
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("body", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class BodyTag extends ContainerTag
JScript
public
SerializableAttribute
XmlRootAttribute("body", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class BodyTag extends ContainerTag

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.ContainerTag
Gallio.Model.Logging.Tags.BodyTag

See Also

BodyTag Members
Gallio.Model.Logging.Tags Namespace


BodyTag Members

BodyTag Members
See Also Example Constructors Properties Methods
[image]

The top-level container tag of structured text. This class cannot be inherited.

The following tables list the members exposed by BodyTag.

Public Constructors

 | Name | Description
Public method | BodyTag | Initializes a new instance of the BodyTag class.
Top

Public Properties

 | Name | Description
Public property | Contents | Gets the list of nested contents of this tag. (inherited from ContainerTag)
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag. (inherited from ContainerTag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace


BodyTag Constructor

BodyTag Constructor
[image]

Initializes a new instance of the BodyTag class.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BodyTag()
C++
public:
BodyTag() sealed
J#
public BodyTag()
JScript
public function BodyTag()

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace


Methods

BodyTag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag. (inherited from ContainerTag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

BodyTag.Clone Method
[image]

Clones the object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function Clone() As BodyTag _
Implements ICloneable<BodyTag>.Clone
C#
public new BodyTag Clone()
C++
public:
BodyTag Clone() sealed
J#
public new BodyTag Clone()
JScript
public function Clone() : BodyTag

Return Value

The cloned object

Implements

ICloneable<BodyTag>.Clone

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

BodyTag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (BodyTag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | Equals (ContainerTag) | Determines whether the specified Object is equal to the current Object. (inherited from ContainerTag)
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object. (inherited from Tag)

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (BodyTag)

BodyTag.Equals Method (BodyTag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As BodyTag _
) As Boolean _
Implements IEquatable<BodyTag>.Equals
C#
public bool Equals(
BodyTag other
)
C++
public:
bool Equals(
BodyTag other
) sealed
J#
public bool Equals(
BodyTag other
)
JScript
public function Equals(
other : BodyTag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<BodyTag>.Equals

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace
BodyTag.Equals Overload List


Equals Method (Object)

BodyTag.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace
BodyTag.Equals Overload List


GetHashCode Method

BodyTag.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

BodyTag Class
Gallio.Model.Logging.Tags Namespace


ContainerTag Class

ContainerTag Class
See Also Example Members
[image]

An abstract container tag for representing tags that can contain other tags. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class ContainerTag
Inherits Tag
C#
[SerializableAttribute]
public abstract class ContainerTag : Tag
C++
[SerializableAttribute]
ref class ContainerTag abstract : Tag
J#
/** @attribute SerializableAttribute() */
public class ContainerTag extends Tag
JScript
public
SerializableAttribute
class ContainerTag extends Tag

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.ContainerTag
Gallio.Model.Logging.Tags.BodyTag
Gallio.Model.Logging.Tags.MarkerTag
Gallio.Model.Logging.Tags.SectionTag

See Also

ContainerTag Members
Gallio.Model.Logging.Tags Namespace


ContainerTag Members

ContainerTag Members
See Also Example Constructors Properties Methods
[image]

An abstract container tag for representing tags that can contain other tags. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ContainerTag.

Protected Constructors

 | Name | Description
Family method | ContainerTag | Creates an empty container tag.
Top

Public Properties

 | Name | Description
Public property | Contents | Gets the list of nested contents of this tag.
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag.
Public method | Clone |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


ContainerTag Constructor

ContainerTag Constructor
[image]

Creates an empty container tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected ContainerTag()
C++
protected:
ContainerTag() sealed
J#
protected ContainerTag()
JScript
protected function ContainerTag()

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


Properties

ContainerTag Properties
[image]

Public Properties

 | Name | Description
Public property | Contents | Gets the list of nested contents of this tag.
Top

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


Contents Property

ContainerTag.Contents Property
[image]

Gets the list of nested contents of this tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("marker", GetType(MarkerTag), IsNullable := False), _
XmlArrayItemAttribute("text", GetType(TextTag), IsNullable := False), _
XmlArrayItemAttribute("embed", GetType(EmbedTag), IsNullable := False), _
XmlArrayAttribute("contents", IsNullable := False), _
XmlArrayItemAttribute("section", GetType(SectionTag), IsNullable := False)>
Public ReadOnly Property Contents As List(Of Tag)
C#
[XmlArrayItemAttribute("marker", typeof(MarkerTag), IsNullable = False)]
[XmlArrayItemAttribute("text", typeof(TextTag), IsNullable = False)]
[XmlArrayItemAttribute("embed", typeof(EmbedTag), IsNullable = False)]
[XmlArrayAttribute("contents", IsNullable = False)]
[XmlArrayItemAttribute("section", typeof(SectionTag), IsNullable = False)]
public List<Tag> Contents { get; }
C++
[XmlArrayItemAttribute(L"marker", typeof(MarkerTag), IsNullable = False)]
[XmlArrayItemAttribute(L"text", typeof(TextTag), IsNullable = False)]
[XmlArrayItemAttribute(L"embed", typeof(EmbedTag), IsNullable = False)]
[XmlArrayAttribute(L"contents", IsNullable = False)]
[XmlArrayItemAttribute(L"section", typeof(SectionTag), IsNullable = False)]
public property List<Tag> Contents sealed {
List<Tag> get();
}
J#
/** @attribute XmlArrayItemAttribute("marker", typeof(MarkerTag), IsNullable = False) */
/** @attribute XmlArrayItemAttribute("text", typeof(TextTag), IsNullable = False) */
/** @attribute XmlArrayItemAttribute("embed", typeof(EmbedTag), IsNullable = False) */
/** @attribute XmlArrayAttribute("contents", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("section", typeof(SectionTag), IsNullable = False) */
/** property */
public List<Tag> get_Contents();
JScript
public function get Contents() : List<Tag>

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


Methods

ContainerTag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag.
Public method | Clone |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


AcceptContents Method

ContainerTag.AcceptContents Method
[image]

Invokes the appropriate visitor method each element contained within this tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AcceptContents( _
ByVal visitor As ITagVisitor _
)
C#
public void AcceptContents(
ITagVisitor visitor
)
C++
public:
void AcceptContents(
ITagVisitor visitor
) sealed
J#
public void AcceptContents(
ITagVisitor visitor
)
JScript
public function AcceptContents(
visitor : ITagVisitor
)

Parameters

visitor
The visitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if visitor is null

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

ContainerTag.Clone Method
[image]

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function Clone() As ContainerTag _
Implements ICloneable<ContainerTag>.Clone
C#
public new ContainerTag Clone()
C++
public:
ContainerTag Clone() sealed
J#
public new ContainerTag Clone()
JScript
public function Clone() : ContainerTag

Implements

ICloneable<ContainerTag>.Clone

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

ContainerTag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ContainerTag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object. (inherited from Tag)
Public method | Equals (Object) | Determines whether the specified Object is equal to the current Object. (inherited from Object)

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (ContainerTag)

ContainerTag.Equals Method (ContainerTag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ContainerTag _
) As Boolean _
Implements IEquatable<ContainerTag>.Equals
C#
public bool Equals(
ContainerTag other
)
C++
public:
bool Equals(
ContainerTag other
) sealed
J#
public bool Equals(
ContainerTag other
)
JScript
public function Equals(
other : ContainerTag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<ContainerTag>.Equals

See Also

ContainerTag Class
Gallio.Model.Logging.Tags Namespace
ContainerTag.Equals Overload List


EmbedTag Class

EmbedTag Class
See Also Example Members
[image]

An embedded attachment tag. This class cannot be inherited.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("embed", Namespace := "http://www.gallio.org/")>
Public NotInheritable Class EmbedTag
Inherits Tag
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("embed", Namespace = "http://www.gallio.org/")]
public sealed class EmbedTag : Tag
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"embed", Namespace = L"http://www.gallio.org/")]
ref class EmbedTag sealed : Tag
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("embed", Namespace = "http://www.gallio.org/") */
public final class EmbedTag extends Tag
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("embed", Namespace = "http://www.gallio.org/")
final class EmbedTag extends Tag

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.EmbedTag

See Also

EmbedTag Members
Gallio.Model.Logging.Tags Namespace


EmbedTag Members

EmbedTag Members
See Also Example Constructors Properties Methods
[image]

An embedded attachment tag. This class cannot be inherited.

The following tables list the members exposed by EmbedTag.

Public Constructors

 | Name | Description
Public method | EmbedTag | Creates an initialized tag.
Top

Public Properties

 | Name | Description
Public property | AttachmentName | Gets or sets the name of the referenced attachment to embed, not null.
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


EmbedTag Constructor

EmbedTag Constructor
[image]

Creates an initialized tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal attachmentName As String _
)
C#
public EmbedTag(
string attachmentName
)
C++
public:
EmbedTag(
String attachmentName
) sealed
J#
public EmbedTag(
string attachmentName
)
JScript
public function EmbedTag(
attachmentName : String
)

Parameters

attachmentName
The name of the attachment to embed

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attachmentName is null

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


Properties

EmbedTag Properties
[image]

Public Properties

 | Name | Description
Public property | AttachmentName | Gets or sets the name of the referenced attachment to embed, not null.
Top

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


AttachmentName Property

EmbedTag.AttachmentName Property
[image]

Gets or sets the name of the referenced attachment to embed, not null.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("attachmentName")>
Public Property AttachmentName As String
C#
[XmlAttributeAttribute("attachmentName")]
public string AttachmentName { get; set; }
C++
[XmlAttributeAttribute(L"attachmentName")]
public property string AttachmentName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("attachmentName") */
/** property */
public string get_AttachmentName();

/** property */
public void set_AttachmentName(string value);
JScript
public function get AttachmentName() : String

public function set AttachmentName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


Methods

EmbedTag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

EmbedTag.Clone Method
[image]

Clones the object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function Clone() As EmbedTag _
Implements ICloneable<EmbedTag>.Clone
C#
public new EmbedTag Clone()
C++
public:
EmbedTag Clone() sealed
J#
public new EmbedTag Clone()
JScript
public function Clone() : EmbedTag

Return Value

The cloned object

Implements

ICloneable<EmbedTag>.Clone

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

EmbedTag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (EmbedTag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object. (inherited from Tag)

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (EmbedTag)

EmbedTag.Equals Method (EmbedTag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As EmbedTag _
) As Boolean _
Implements IEquatable<EmbedTag>.Equals
C#
public bool Equals(
EmbedTag other
)
C++
public:
bool Equals(
EmbedTag other
) sealed
J#
public bool Equals(
EmbedTag other
)
JScript
public function Equals(
other : EmbedTag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<EmbedTag>.Equals

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace
EmbedTag.Equals Overload List


Equals Method (Object)

EmbedTag.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace
EmbedTag.Equals Overload List


GetHashCode Method

EmbedTag.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

EmbedTag Class
Gallio.Model.Logging.Tags Namespace


ITagVisitor Interface

ITagVisitor Interface
See Also Example Members
[image]

Visits a Tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITagVisitor
C#
public interface ITagVisitor
C++
interface class ITagVisitor
J#
public interface ITagVisitor
JScript
public interface ITagVisitor

Types that implement ITagVisitor

Type | Description
Gallio.Model.Logging.Tags.BaseTagVisitor | An abstract base class for tag visitors that recursively traverses all tags and does nothing else by default. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Model.Logging.Tags.TagFormatter | Formats Tag instances to plain text. Text tags are written as-is. Sections introduce paragraph breaks with the header written out as the first line. Embedded attachments are described by name.

See Also

ITagVisitor Members
Gallio.Model.Logging.Tags Namespace


ITagVisitor Members

ITagVisitor Members
See Also Example Methods
[image]

Visits a Tag.

The following tables list the members exposed by ITagVisitor.

Public Methods

 | Name | Description
Public method | VisitBodyTag | Visits a body tag.
Public method | VisitEmbedTag | Visits an embedded attachment tag.
Public method | VisitMarkerTag | Visits a marker tag.
Public method | VisitSectionTag | Visits a section tag.
Public method | VisitTextTag | Visits a text tag.
Top

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


Methods

ITagVisitor Methods
[image]

Public Methods

 | Name | Description
Public method | VisitBodyTag | Visits a body tag.
Public method | VisitEmbedTag | Visits an embedded attachment tag.
Public method | VisitMarkerTag | Visits a marker tag.
Public method | VisitSectionTag | Visits a section tag.
Public method | VisitTextTag | Visits a text tag.
Top

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


VisitBodyTag Method

ITagVisitor.VisitBodyTag Method
[image]

Visits a body tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitBodyTag( _
ByVal tag As BodyTag _
)
C#
void VisitBodyTag(
BodyTag tag
)
C++
void VisitBodyTag(
BodyTag tag
) abstract
J#
void VisitBodyTag(
BodyTag tag
)
JScript
function VisitBodyTag(
tag : BodyTag
)

Parameters

tag
The tag to visit

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


VisitEmbedTag Method

ITagVisitor.VisitEmbedTag Method
[image]

Visits an embedded attachment tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitEmbedTag( _
ByVal tag As EmbedTag _
)
C#
void VisitEmbedTag(
EmbedTag tag
)
C++
void VisitEmbedTag(
EmbedTag tag
) abstract
J#
void VisitEmbedTag(
EmbedTag tag
)
JScript
function VisitEmbedTag(
tag : EmbedTag
)

Parameters

tag
The tag to visit

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


VisitMarkerTag Method

ITagVisitor.VisitMarkerTag Method
[image]

Visits a marker tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitMarkerTag( _
ByVal tag As MarkerTag _
)
C#
void VisitMarkerTag(
MarkerTag tag
)
C++
void VisitMarkerTag(
MarkerTag tag
) abstract
J#
void VisitMarkerTag(
MarkerTag tag
)
JScript
function VisitMarkerTag(
tag : MarkerTag
)

Parameters

tag
The tag to visit

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


VisitSectionTag Method

ITagVisitor.VisitSectionTag Method
[image]

Visits a section tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitSectionTag( _
ByVal tag As SectionTag _
)
C#
void VisitSectionTag(
SectionTag tag
)
C++
void VisitSectionTag(
SectionTag tag
) abstract
J#
void VisitSectionTag(
SectionTag tag
)
JScript
function VisitSectionTag(
tag : SectionTag
)

Parameters

tag
The tag to visit

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


VisitTextTag Method

ITagVisitor.VisitTextTag Method
[image]

Visits a text tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub VisitTextTag( _
ByVal tag As TextTag _
)
C#
void VisitTextTag(
TextTag tag
)
C++
void VisitTextTag(
TextTag tag
) abstract
J#
void VisitTextTag(
TextTag tag
)
JScript
function VisitTextTag(
tag : TextTag
)

Parameters

tag
The tag to visit

See Also

ITagVisitor Interface
Gallio.Model.Logging.Tags Namespace


MarkerTag Class

MarkerTag Class
See Also Example Members
[image]

A marker tag. This class cannot be inherited.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("marker", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class MarkerTag
Inherits ContainerTag
C#
[SerializableAttribute]
[XmlRootAttribute("marker", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class MarkerTag : ContainerTag
C++
[SerializableAttribute]
[XmlRootAttribute(L"marker", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class MarkerTag sealed : ContainerTag
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("marker", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class MarkerTag extends ContainerTag
JScript
public
SerializableAttribute
XmlRootAttribute("marker", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class MarkerTag extends ContainerTag

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.ContainerTag
Gallio.Model.Logging.Tags.MarkerTag

See Also

MarkerTag Members
Gallio.Model.Logging.Tags Namespace


MarkerTag Members

MarkerTag Members
See Also Example Constructors Properties Methods
[image]

A marker tag. This class cannot be inherited.

The following tables list the members exposed by MarkerTag.

Public Constructors

 | Name | Description
Public method | MarkerTag | Creates an initialized tag.
Top

Public Properties

 | Name | Description
Public property | Attributes | Gets the list of marker attributes.
Public property | Class | Gets or sets the marker class, not null.
Public property | Contents | Gets the list of nested contents of this tag. (inherited from ContainerTag)
Public property | Marker | Gets the marker.
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag. (inherited from ContainerTag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


MarkerTag Constructor

MarkerTag Constructor
[image]

Creates an initialized tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal marker As Marker _
)
C#
public MarkerTag(
Marker marker
)
C++
public:
MarkerTag(
Marker marker
) sealed
J#
public MarkerTag(
Marker marker
)
JScript
public function MarkerTag(
marker : Marker
)

Parameters

marker
The marker

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Properties

MarkerTag Properties
[image]

Public Properties

 | Name | Description
Public property | Attributes | Gets the list of marker attributes.
Public property | Class | Gets or sets the marker class, not null.
Public property | Contents | Gets the list of nested contents of this tag. (inherited from ContainerTag)
Public property | Marker | Gets the marker.
Top

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Attributes Property

MarkerTag.Attributes Property
[image]

Gets the list of marker attributes.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("attributes", IsNullable := False), _
XmlArrayItemAttribute("attribute", GetType(MarkerTag_x002B_Attribute), IsNullable := False)>
Public ReadOnly Property Attributes As List(Of Attribute)
C#
[XmlArrayAttribute("attributes", IsNullable = False)]
[XmlArrayItemAttribute("attribute", typeof(MarkerTag_x002B_Attribute), IsNullable = False)]
public List<Attribute> Attributes { get; }
C++
[XmlArrayAttribute(L"attributes", IsNullable = False)]
[XmlArrayItemAttribute(L"attribute", typeof(MarkerTag_x002B_Attribute), IsNullable = False)]
public property List<Attribute> Attributes sealed {
List<Attribute> get();
}
J#
/** @attribute XmlArrayAttribute("attributes", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("attribute", typeof(MarkerTag_x002B_Attribute), IsNullable = False) */
/** property */
public List<Attribute> get_Attributes();
JScript
public function get Attributes() : List<Attribute>

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Class Property

MarkerTag.Class Property
[image]

Gets or sets the marker class, not null.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("class")>
Public Property Class As String
C#
[XmlAttributeAttribute("class")]
public string Class { get; set; }
C++
[XmlAttributeAttribute(L"class")]
public property string Class sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("class") */
/** property */
public string get_Class();

/** property */
public void set_Class(string value);
JScript
public function get Class() : String

public function set Class(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null
ArgumentException | Thrown if the value is not a valid identifier.

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace
ValidateIdentifier


Marker Property

MarkerTag.Marker Property
[image]

Gets the marker.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property Marker As Marker
C#
[XmlIgnoreAttribute]
public Marker Marker { get; }
C++
[XmlIgnoreAttribute]
public property Marker Marker sealed {
Marker get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Marker get_Marker();
JScript
public function get Marker() : Marker

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Methods

MarkerTag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag. (inherited from ContainerTag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

MarkerTag.Clone Method
[image]

Clones the object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function Clone() As MarkerTag _
Implements ICloneable<MarkerTag>.Clone
C#
public new MarkerTag Clone()
C++
public:
MarkerTag Clone() sealed
J#
public new MarkerTag Clone()
JScript
public function Clone() : MarkerTag

Return Value

The cloned object

Implements

ICloneable<MarkerTag>.Clone

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

MarkerTag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ContainerTag) | Determines whether the specified Object is equal to the current Object. (inherited from ContainerTag)
Public method | Equals (MarkerTag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object. (inherited from Tag)

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (MarkerTag)

MarkerTag.Equals Method (MarkerTag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As MarkerTag _
) As Boolean _
Implements IEquatable<MarkerTag>.Equals
C#
public bool Equals(
MarkerTag other
)
C++
public:
bool Equals(
MarkerTag other
) sealed
J#
public bool Equals(
MarkerTag other
)
JScript
public function Equals(
other : MarkerTag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<MarkerTag>.Equals

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace
MarkerTag.Equals Overload List


Equals Method (Object)

MarkerTag.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace
MarkerTag.Equals Overload List


GetHashCode Method

MarkerTag.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

MarkerTag Class
Gallio.Model.Logging.Tags Namespace


MarkerTag.Attribute Class

MarkerTag.Attribute Class
See Also Example Members
[image]

Represents a marker attribute. This class cannot be inherited.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("marker", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class MarkerTag.Attribute
C#
[SerializableAttribute]
[XmlRootAttribute("marker", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class MarkerTag.Attribute
C++
[SerializableAttribute]
[XmlRootAttribute(L"marker", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class MarkerTag.Attribute sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("marker", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class MarkerTag.Attribute
JScript
public
SerializableAttribute
XmlRootAttribute("marker", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class MarkerTag.Attribute

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.MarkerTag.Attribute

See Also

MarkerTag.Attribute Members
Gallio.Model.Logging.Tags Namespace


MarkerTag.Attribute Members

MarkerTag.Attribute Members
See Also Example Constructors Properties Methods
[image]

Represents a marker attribute. This class cannot be inherited.

The following tables list the members exposed by MarkerTag.Attribute.

Public Constructors

 | Name | Description
Public method | MarkerTag.Attribute | Creates an initialized attribute.
Top

Public Properties

 | Name | Description
Public property | Name | Gets or sets the attribute name, not null.
Public property | Value | Gets or sets the attribute value, not null.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MarkerTag.Attribute Class
Gallio.Model.Logging.Tags Namespace


MarkerTag.Attribute Constructor

MarkerTag.Attribute Constructor
[image]

Creates an initialized attribute.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal value As String _
)
C#
public MarkerTag.Attribute(
string name,
string value
)
C++
public:
MarkerTag.Attribute(
String name,
String value
) sealed
J#
public MarkerTag.Attribute(
string name,
string value
)
JScript
public function MarkerTag.Attribute(
name : String,
value : String
)

Parameters

name
The attribute name
value
The attribute value

Exceptions

Exception Type | Condition
ArgumentException | Thrown if name is invalid
ArgumentNullException | Thrown if name or value is null

See Also

MarkerTag.Attribute Class
Gallio.Model.Logging.Tags Namespace


Properties

MarkerTag.Attribute Properties
[image]

Public Properties

 | Name | Description
Public property | Name | Gets or sets the attribute name, not null.
Public property | Value | Gets or sets the attribute value, not null.
Top

See Also

MarkerTag.Attribute Class
Gallio.Model.Logging.Tags Namespace


Name Property

MarkerTag.Attribute.Name Property
[image]

Gets or sets the attribute name, not null.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("name")>
Public Property Name As String
C#
[XmlAttributeAttribute("name")]
public string Name { get; set; }
C++
[XmlAttributeAttribute(L"name")]
public property string Name sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("name") */
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null
ArgumentException | Thrown if the value is not a valid identifier.

See Also

MarkerTag.Attribute Class
Gallio.Model.Logging.Tags Namespace
ValidateIdentifier


Value Property

MarkerTag.Attribute.Value Property
[image]

Gets or sets the attribute value, not null.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("value")>
Public Property Value As String
C#
[XmlAttributeAttribute("value")]
public string Value { get; set; }
C++
[XmlAttributeAttribute(L"value")]
public property string Value sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("value") */
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

MarkerTag.Attribute Class
Gallio.Model.Logging.Tags Namespace


SectionTag Class

SectionTag Class
See Also Example Members
[image]

A section tag. This class cannot be inherited.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("section", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class SectionTag
Inherits ContainerTag
C#
[SerializableAttribute]
[XmlRootAttribute("section", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class SectionTag : ContainerTag
C++
[SerializableAttribute]
[XmlRootAttribute(L"section", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class SectionTag sealed : ContainerTag
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("section", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class SectionTag extends ContainerTag
JScript
public
SerializableAttribute
XmlRootAttribute("section", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class SectionTag extends ContainerTag

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.ContainerTag
Gallio.Model.Logging.Tags.SectionTag

See Also

SectionTag Members
Gallio.Model.Logging.Tags Namespace


SectionTag Members

SectionTag Members
See Also Example Constructors Properties Methods
[image]

A section tag. This class cannot be inherited.

The following tables list the members exposed by SectionTag.

Public Constructors

 | Name | Description
Public method | SectionTag | Creates an initialized tag.
Top

Public Properties

 | Name | Description
Public property | Contents | Gets the list of nested contents of this tag. (inherited from ContainerTag)
Public property | Name | Gets or sets the section name, not null.
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag. (inherited from ContainerTag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


SectionTag Constructor

SectionTag Constructor
[image]

Creates an initialized tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public SectionTag(
string name
)
C++
public:
SectionTag(
String name
) sealed
J#
public SectionTag(
string name
)
JScript
public function SectionTag(
name : String
)

Parameters

name
The section name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Properties

SectionTag Properties
[image]

Public Properties

 | Name | Description
Public property | Contents | Gets the list of nested contents of this tag. (inherited from ContainerTag)
Public property | Name | Gets or sets the section name, not null.
Top

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Name Property

SectionTag.Name Property
[image]

Gets or sets the section name, not null.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("name")>
Public Property Name As String
C#
[XmlAttributeAttribute("name")]
public string Name { get; set; }
C++
[XmlAttributeAttribute(L"name")]
public property string Name sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("name") */
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Methods

SectionTag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | AcceptContents | Invokes the appropriate visitor method each element contained within this tag. (inherited from ContainerTag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

SectionTag.Clone Method
[image]

Clones the object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function Clone() As SectionTag _
Implements ICloneable<SectionTag>.Clone
C#
public new SectionTag Clone()
C++
public:
SectionTag Clone() sealed
J#
public new SectionTag Clone()
JScript
public function Clone() : SectionTag

Return Value

The cloned object

Implements

ICloneable<SectionTag>.Clone

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

SectionTag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ContainerTag) | Determines whether the specified Object is equal to the current Object. (inherited from ContainerTag)
Public method | Equals (SectionTag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object. (inherited from Tag)

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (SectionTag)

SectionTag.Equals Method (SectionTag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As SectionTag _
) As Boolean _
Implements IEquatable<SectionTag>.Equals
C#
public bool Equals(
SectionTag other
)
C++
public:
bool Equals(
SectionTag other
) sealed
J#
public bool Equals(
SectionTag other
)
JScript
public function Equals(
other : SectionTag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<SectionTag>.Equals

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace
SectionTag.Equals Overload List


Equals Method (Object)

SectionTag.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace
SectionTag.Equals Overload List


GetHashCode Method

SectionTag.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

SectionTag Class
Gallio.Model.Logging.Tags Namespace


Tag Class

Tag Class
See Also Example Members
[image]

An tag represents a portion of the contents of a structured test log stream. Each one can be thought of as a command that will regenerate the structured test log stream when written back out. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class Tag
Implements ICloneable(Of Tag), ICloneable, IEquatable(Of Tag), ITestLogStreamWritable
C#
[SerializableAttribute]
public abstract class Tag : ICloneable<Tag>, ICloneable, IEquatable<Tag>, ITestLogStreamWritable
C++
[SerializableAttribute]
ref class Tag abstract : ICloneable<Tag>, ICloneable, IEquatable<Tag>, ITestLogStreamWritable
J#
/** @attribute SerializableAttribute() */
public class Tag implements ICloneable<Tag>, ICloneable, IEquatable<Tag>, ITestLogStreamWritable
JScript
public
SerializableAttribute
class Tag extends ICloneable<Tag>, ICloneable, IEquatable<Tag>, ITestLogStreamWritable

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.ContainerTag
Gallio.Model.Logging.Tags.EmbedTag
Gallio.Model.Logging.Tags.TextTag

See Also

Tag Members
Gallio.Model.Logging.Tags Namespace


Tag Members

Tag Members
See Also Example Constructors Methods
[image]

An tag represents a portion of the contents of a structured test log stream. Each one can be thought of as a command that will regenerate the structured test log stream when written back out. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Tag.

Protected Constructors

 | Name | Description
Family method | Tag | Initializes a new instance of the Tag class.
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type.
Public method | Clone |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the tag using a TagFormatter.
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


Tag Constructor

Tag Constructor
[image]

Initializes a new instance of the Tag class.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected Tag()
C++
protected:
Tag() sealed
J#
protected Tag()
JScript
protected function Tag()

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


Methods

Tag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type.
Public method | Clone |
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Formats the tag using a TagFormatter.
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


Accept Method

Tag.Accept Method
[image]

Invokes the appropriate visitor method for this tag type.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Accept( _
ByVal visitor As ITagVisitor _
)
C#
public void Accept(
ITagVisitor visitor
)
C++
public:
void Accept(
ITagVisitor visitor
) sealed
J#
public void Accept(
ITagVisitor visitor
)
JScript
public function Accept(
visitor : ITagVisitor
)

Parameters

visitor
The visitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if visitor is null

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

Tag.Clone Method
[image]

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As Tag _
Implements ICloneable<Tag>.Clone
C#
public Tag Clone()
C++
public:
Tag Clone() sealed
J#
public Tag Clone()
JScript
public function Clone() : Tag

Implements

ICloneable<Tag>.Clone

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

Tag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Determines whether the specified Object is equal to the current Object. (inherited from Object)

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (Tag)

Tag.Equals Method (Tag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As Tag _
) As Boolean _
Implements IEquatable<Tag>.Equals
C#
public bool Equals(
Tag other
)
C++
public:
bool Equals(
Tag other
) sealed
J#
public bool Equals(
Tag other
)
JScript
public function Equals(
other : Tag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<Tag>.Equals

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace
Tag.Equals Overload List


ToString Method

Tag.ToString Method
[image]

Formats the tag using a TagFormatter.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The formatted text

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


WriteTo Method

Tag.WriteTo Method
[image]

Writes the structured text tag to a TestLogStreamWriter.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal writer As TestLogStreamWriter _
) _
Implements ITestLogStreamWritable.WriteTo
C#
public void WriteTo(
TestLogStreamWriter writer
)
C++
public:
void WriteTo(
TestLogStreamWriter writer
) sealed
J#
public void WriteTo(
TestLogStreamWriter writer
)
JScript
public function WriteTo(
writer : TestLogStreamWriter
)

Parameters

writer
The structured text writer

Implements

ITestLogStreamWritable.WriteTo

Exceptions

Exception Type | Condition
ArgumentNullException | Throw if writer is null

See Also

Tag Class
Gallio.Model.Logging.Tags Namespace


TagFormatter Class

TagFormatter Class
See Also Example Members
[image]

Formats Tag instances to plain text.

Text tags are written as-is. Sections introduce paragraph breaks with the header written out as the first line. Embedded attachments are described by name.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TagFormatter
Implements ITagVisitor
C#
public class TagFormatter : ITagVisitor
C++
ref class TagFormatter : ITagVisitor
J#
public class TagFormatter implements ITagVisitor
JScript
public class TagFormatter extends ITagVisitor

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.TagFormatter

See Also

TagFormatter Members
Gallio.Model.Logging.Tags Namespace


TagFormatter Members

TagFormatter Members
See Also Example Constructors Methods
[image]

Formats Tag instances to plain text.

Text tags are written as-is. Sections introduce paragraph breaks with the header written out as the first line. Embedded attachments are described by name.

The following tables list the members exposed by TagFormatter.

Public Constructors

 | Name | Description
Public method | TagFormatter | Initializes a new instance of the TagFormatter class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Gets the formatted text that has been built.
Public method | VisitBodyTag | Visits a body tag.
Public method | VisitEmbedTag | Visits an embedded attachment tag.
Public method | VisitMarkerTag | Visits a marker tag.
Public method | VisitSectionTag | Visits a section tag.
Public method | VisitTextTag | Visits a text tag.
Top

Protected Methods

 | Name | Description
Family method | Append | Appends text to the buffer including any requested spacing.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RequestMinimumSpacing | Ensures that the next chunk of text appended is separated by at least the specified number of line breaks.
Top

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


TagFormatter Constructor

TagFormatter Constructor
[image]

Initializes a new instance of the TagFormatter class.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TagFormatter()
C++
public:
TagFormatter() sealed
J#
public TagFormatter()
JScript
public function TagFormatter()

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


Methods

TagFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Gets the formatted text that has been built.
Public method | VisitBodyTag | Visits a body tag.
Public method | VisitEmbedTag | Visits an embedded attachment tag.
Public method | VisitMarkerTag | Visits a marker tag.
Public method | VisitSectionTag | Visits a section tag.
Public method | VisitTextTag | Visits a text tag.
Top

Protected Methods

 | Name | Description
Family method | Append | Appends text to the buffer including any requested spacing.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RequestMinimumSpacing | Ensures that the next chunk of text appended is separated by at least the specified number of line breaks.
Top

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


Append Method

TagFormatter.Append Method
[image]

Appends text to the buffer including any requested spacing.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub Append( _
ByVal text As String _
)
C#
protected void Append(
string text
)
C++
protected:
void Append(
String text
) sealed
J#
protected void Append(
string text
)
JScript
protected function Append(
text : String
)

Parameters

text
The text to append

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


RequestMinimumSpacing Method

TagFormatter.RequestMinimumSpacing Method
[image]

Ensures that the next chunk of text appended is separated by at least the specified number of line breaks.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RequestMinimumSpacing( _
ByVal spacing As Integer _
)
C#
protected void RequestMinimumSpacing(
int spacing
)
C++
protected:
void RequestMinimumSpacing(
int spacing
) sealed
J#
protected void RequestMinimumSpacing(
int spacing
)
JScript
protected function RequestMinimumSpacing(
spacing : int
)

Parameters

spacing
The minimum number of line breaks to insert

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


ToString Method

TagFormatter.ToString Method
[image]

Gets the formatted text that has been built.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


VisitBodyTag Method

TagFormatter.VisitBodyTag Method
[image]

Visits a body tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitBodyTag( _
ByVal tag As BodyTag _
) _
Implements ITagVisitor.VisitBodyTag
C#
public virtual void VisitBodyTag(
BodyTag tag
)
C++
public:
virtual void VisitBodyTag(
BodyTag tag
)
J#
public virtual void VisitBodyTag(
BodyTag tag
)
JScript
public virtual function VisitBodyTag(
tag : BodyTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitBodyTag

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


VisitEmbedTag Method

TagFormatter.VisitEmbedTag Method
[image]

Visits an embedded attachment tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitEmbedTag( _
ByVal tag As EmbedTag _
) _
Implements ITagVisitor.VisitEmbedTag
C#
public virtual void VisitEmbedTag(
EmbedTag tag
)
C++
public:
virtual void VisitEmbedTag(
EmbedTag tag
)
J#
public virtual void VisitEmbedTag(
EmbedTag tag
)
JScript
public virtual function VisitEmbedTag(
tag : EmbedTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitEmbedTag

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


VisitMarkerTag Method

TagFormatter.VisitMarkerTag Method
[image]

Visits a marker tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitMarkerTag( _
ByVal tag As MarkerTag _
) _
Implements ITagVisitor.VisitMarkerTag
C#
public virtual void VisitMarkerTag(
MarkerTag tag
)
C++
public:
virtual void VisitMarkerTag(
MarkerTag tag
)
J#
public virtual void VisitMarkerTag(
MarkerTag tag
)
JScript
public virtual function VisitMarkerTag(
tag : MarkerTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitMarkerTag

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


VisitSectionTag Method

TagFormatter.VisitSectionTag Method
[image]

Visits a section tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitSectionTag( _
ByVal tag As SectionTag _
) _
Implements ITagVisitor.VisitSectionTag
C#
public virtual void VisitSectionTag(
SectionTag tag
)
C++
public:
virtual void VisitSectionTag(
SectionTag tag
)
J#
public virtual void VisitSectionTag(
SectionTag tag
)
JScript
public virtual function VisitSectionTag(
tag : SectionTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitSectionTag

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


VisitTextTag Method

TagFormatter.VisitTextTag Method
[image]

Visits a text tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub VisitTextTag( _
ByVal tag As TextTag _
) _
Implements ITagVisitor.VisitTextTag
C#
public virtual void VisitTextTag(
TextTag tag
)
C++
public:
virtual void VisitTextTag(
TextTag tag
)
J#
public virtual void VisitTextTag(
TextTag tag
)
JScript
public virtual function VisitTextTag(
tag : TextTag
)

Parameters

tag
The tag to visit

Implements

ITagVisitor.VisitTextTag

See Also

TagFormatter Class
Gallio.Model.Logging.Tags Namespace


TextTag Class

TextTag Class
See Also Example Members
[image]

A text tag, containing text. This class cannot be inherited.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("text", Namespace := "http://www.gallio.org/"), _
XmlSchemaProviderAttribute("ProvideXmlSchema")>
Public NotInheritable Class TextTag
Inherits Tag
Implements IXmlSerializable
C#
[SerializableAttribute]
[XmlRootAttribute("text", Namespace = "http://www.gallio.org/")]
[XmlSchemaProviderAttribute("ProvideXmlSchema")]
public sealed class TextTag : Tag, IXmlSerializable
C++
[SerializableAttribute]
[XmlRootAttribute(L"text", Namespace = L"http://www.gallio.org/")]
[XmlSchemaProviderAttribute(L"ProvideXmlSchema")]
ref class TextTag sealed : Tag, IXmlSerializable
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("text", Namespace = "http://www.gallio.org/") */
/** @attribute XmlSchemaProviderAttribute("ProvideXmlSchema") */
public final class TextTag extends Tag implements IXmlSerializable
JScript
public
SerializableAttribute
XmlRootAttribute("text", Namespace = "http://www.gallio.org/")
XmlSchemaProviderAttribute("ProvideXmlSchema")
final class TextTag extends Tag, IXmlSerializable

Inheritance Hierarchy

System.Object
Gallio.Model.Logging.Tags.Tag
Gallio.Model.Logging.Tags.TextTag

See Also

TextTag Members
Gallio.Model.Logging.Tags Namespace


TextTag Members

TextTag Members
See Also Example Constructors Properties Methods
[image]

A text tag, containing text. This class cannot be inherited.

The following tables list the members exposed by TextTag.

Public Constructors

 | Name | Description
Public method | TextTag | Creates an initialized text tag.
Top

Public Properties

 | Name | Description
Public property | Text | Gets or sets the text within the tag, not null.
Top

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


TextTag Constructor

TextTag Constructor
[image]

Creates an initialized text tag.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal text As String _
)
C#
public TextTag(
string text
)
C++
public:
TextTag(
String text
) sealed
J#
public TextTag(
string text
)
JScript
public function TextTag(
text : String
)

Parameters

text
The text within the tag

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if text is null

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Properties

TextTag Properties
[image]

Public Properties

 | Name | Description
Public property | Text | Gets or sets the text within the tag, not null.
Top

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Text Property

TextTag.Text Property
[image]

Gets or sets the text within the tag, not null.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
C++
public property string Text sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Text();

/** property */
public void set_Text(string value);
JScript
public function get Text() : String

public function set Text(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Methods

TextTag Methods
[image]

Public Methods

 | Name | Description
Public method | Accept | Invokes the appropriate visitor method for this tag type. (inherited from Tag)
Public method | Clone | Clones the object.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Formats the tag using a TagFormatter. (inherited from Tag)
Public method | WriteTo | Writes the structured text tag to a TestLogStreamWriter. (inherited from Tag)
Top

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Clone Method

TextTag.Clone Method
[image]

Clones the object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function Clone() As TextTag _
Implements ICloneable<TextTag>.Clone
C#
public new TextTag Clone()
C++
public:
TextTag Clone() sealed
J#
public new TextTag Clone()
JScript
public function Clone() : TextTag

Return Value

The cloned object

Implements

ICloneable<TextTag>.Clone

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method

TextTag.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (Tag) | Determines whether the specified Object is equal to the current Object. (inherited from Tag)
Public method | Equals (TextTag) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Equals Method (TextTag)

TextTag.Equals Method (TextTag)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As TextTag _
) As Boolean _
Implements IEquatable<TextTag>.Equals
C#
public bool Equals(
TextTag other
)
C++
public:
bool Equals(
TextTag other
) sealed
J#
public bool Equals(
TextTag other
)
JScript
public function Equals(
other : TextTag
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<TextTag>.Equals

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace
TextTag.Equals Overload List


Equals Method (Object)

TextTag.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace
TextTag.Equals Overload List


GetHashCode Method

TextTag.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


ProvideXmlSchema Method

TextTag.ProvideXmlSchema Method
[image]

Provides the Xml schema for this element.

Namespace: Gallio.Model.Logging.Tags
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ProvideXmlSchema( _
ByVal schemas As XmlSchemaSet _
) As XmlQualifiedName
C#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
C++
public:
static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
J#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
JScript
public static function ProvideXmlSchema(
schemas : XmlSchemaSet
) : XmlQualifiedName

Parameters

schemas
The schema set

Return Value

The schema type of the element

See Also

TextTag Class
Gallio.Model.Logging.Tags Namespace


Gallio.Model.Messages

Gallio.Model.Messages Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | RemoteTestExecutionListener | Wraps a test execution listener so that it can be accessed remotely.
Public class | RemoteTestExplorationListener | Wraps a test exploration listener so that it can be accessed remotely.

Interfaces

 | Interface | Description
Public interface | ITestExecutionListener | A test execution listener observes the progress of test execution as a series of events.
Public interface | ITestExplorationListener | A test exploration listener observes the progress of test exploration as a series of events.


ITestExecutionListener Interface

ITestExecutionListener Interface
See Also Example Members
[image]

A test execution listener observes the progress of test execution as a series of events.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestExecutionListener
C#
public interface ITestExecutionListener
C++
interface class ITestExecutionListener
J#
public interface ITestExecutionListener
JScript
public interface ITestExecutionListener

Types that implement ITestExecutionListener

Type | Description
Gallio.Model.Messages.RemoteTestExecutionListener | Wraps a test execution listener so that it can be accessed remotely.

See Also

ITestExecutionListener Members
Gallio.Model.Messages Namespace


ITestExecutionListener Members

ITestExecutionListener Members
See Also Example Methods
[image]

A test execution listener observes the progress of test execution as a series of events.

The following tables list the members exposed by ITestExecutionListener.

Public Methods

 | Name | Description
Public method | NotifyTestStepFinished | Notifies the listener that a test step has finished execution.
Public method | NotifyTestStepLifecyclePhaseChanged | Notifies the listener that a test step has changed lifecycle phase.
Public method | NotifyTestStepLogAttach | Notifies the listener that an attachment has been added to a test step log.
Public method | NotifyTestStepLogStreamBeginMarker | Notifies the listener that a marker region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamBeginSection | Notifies the listener that a section region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamEmbed | Notifies the listener that an attachment has been embedded into a test step log stream.
Public method | NotifyTestStepLogStreamEnd | Notifies the listener that a region started with Begin* has finished within a test step log stream.
Public method | NotifyTestStepLogStreamWrite | Notifies the listener that text has been written to a test step log stream.
Public method | NotifyTestStepMetadataAdded | Notifies the listener that a test step has dynamically added metadata to itself.
Public method | NotifyTestStepStarted | Notifies the listener that a test step has started execution.
Top

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


Methods

ITestExecutionListener Methods
[image]

Public Methods

 | Name | Description
Public method | NotifyTestStepFinished | Notifies the listener that a test step has finished execution.
Public method | NotifyTestStepLifecyclePhaseChanged | Notifies the listener that a test step has changed lifecycle phase.
Public method | NotifyTestStepLogAttach | Notifies the listener that an attachment has been added to a test step log.
Public method | NotifyTestStepLogStreamBeginMarker | Notifies the listener that a marker region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamBeginSection | Notifies the listener that a section region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamEmbed | Notifies the listener that an attachment has been embedded into a test step log stream.
Public method | NotifyTestStepLogStreamEnd | Notifies the listener that a region started with Begin* has finished within a test step log stream.
Public method | NotifyTestStepLogStreamWrite | Notifies the listener that text has been written to a test step log stream.
Public method | NotifyTestStepMetadataAdded | Notifies the listener that a test step has dynamically added metadata to itself.
Public method | NotifyTestStepStarted | Notifies the listener that a test step has started execution.
Top

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepFinished Method

ITestExecutionListener.NotifyTestStepFinished Method
[image]

Notifies the listener that a test step has finished execution.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepFinished( _
ByVal stepId As String, _
ByVal result As TestResult _
)
C#
void NotifyTestStepFinished(
string stepId,
TestResult result
)
C++
void NotifyTestStepFinished(
String stepId,
TestResult result
) abstract
J#
void NotifyTestStepFinished(
string stepId,
TestResult result
)
JScript
function NotifyTestStepFinished(
stepId : String,
result : TestResult
)

Parameters

stepId
The id of the test step, not null
result
The test result, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLifecyclePhaseChanged Method

ITestExecutionListener.NotifyTestStepLifecyclePhaseChanged Method
See Also Example
[image]

Notifies the listener that a test step has changed lifecycle phase.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLifecyclePhaseChanged( _
ByVal stepId As String, _
ByVal lifecyclePhase As String _
)
C#
void NotifyTestStepLifecyclePhaseChanged(
string stepId,
string lifecyclePhase
)
C++
void NotifyTestStepLifecyclePhaseChanged(
String stepId,
String lifecyclePhase
) abstract
J#
void NotifyTestStepLifecyclePhaseChanged(
string stepId,
string lifecyclePhase
)
JScript
function NotifyTestStepLifecyclePhaseChanged(
stepId : String,
lifecyclePhase : String
)

Parameters

stepId
The id of the test step, not null
lifecyclePhase
The lifecycle phase name, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLogAttach Method

ITestExecutionListener.NotifyTestStepLogAttach Method
[image]

Notifies the listener that an attachment has been added to a test step log.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLogAttach( _
ByVal stepId As String, _
ByVal attachment As Attachment _
)
C#
void NotifyTestStepLogAttach(
string stepId,
Attachment attachment
)
C++
void NotifyTestStepLogAttach(
String stepId,
Attachment attachment
) abstract
J#
void NotifyTestStepLogAttach(
string stepId,
Attachment attachment
)
JScript
function NotifyTestStepLogAttach(
stepId : String,
attachment : Attachment
)

Parameters

stepId
The id of the test step, not null
attachment
The attachment, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamBeginMarker Method

ITestExecutionListener.NotifyTestStepLogStreamBeginMarker Method
See Also Example
[image]

Notifies the listener that a marker region has been started within a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLogStreamBeginMarker( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal marker As Marker _
)
C#
void NotifyTestStepLogStreamBeginMarker(
string stepId,
string streamName,
Marker marker
)
C++
void NotifyTestStepLogStreamBeginMarker(
String stepId,
String streamName,
Marker marker
) abstract
J#
void NotifyTestStepLogStreamBeginMarker(
string stepId,
string streamName,
Marker marker
)
JScript
function NotifyTestStepLogStreamBeginMarker(
stepId : String,
streamName : String,
marker : Marker
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
marker
The marker

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamBeginSection Method

ITestExecutionListener.NotifyTestStepLogStreamBeginSection Method
See Also Example
[image]

Notifies the listener that a section region has been started within a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLogStreamBeginSection( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal sectionName As String _
)
C#
void NotifyTestStepLogStreamBeginSection(
string stepId,
string streamName,
string sectionName
)
C++
void NotifyTestStepLogStreamBeginSection(
String stepId,
String streamName,
String sectionName
) abstract
J#
void NotifyTestStepLogStreamBeginSection(
string stepId,
string streamName,
string sectionName
)
JScript
function NotifyTestStepLogStreamBeginSection(
stepId : String,
streamName : String,
sectionName : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
sectionName
The section name, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamEmbed Method

ITestExecutionListener.NotifyTestStepLogStreamEmbed Method
[image]

Notifies the listener that an attachment has been embedded into a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLogStreamEmbed( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal attachmentName As String _
)
C#
void NotifyTestStepLogStreamEmbed(
string stepId,
string streamName,
string attachmentName
)
C++
void NotifyTestStepLogStreamEmbed(
String stepId,
String streamName,
String attachmentName
) abstract
J#
void NotifyTestStepLogStreamEmbed(
string stepId,
string streamName,
string attachmentName
)
JScript
function NotifyTestStepLogStreamEmbed(
stepId : String,
streamName : String,
attachmentName : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
attachmentName
The attachment name, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamEnd Method

ITestExecutionListener.NotifyTestStepLogStreamEnd Method
[image]

Notifies the listener that a region started with Begin* has finished within a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLogStreamEnd( _
ByVal stepId As String, _
ByVal streamName As String _
)
C#
void NotifyTestStepLogStreamEnd(
string stepId,
string streamName
)
C++
void NotifyTestStepLogStreamEnd(
String stepId,
String streamName
) abstract
J#
void NotifyTestStepLogStreamEnd(
string stepId,
string streamName
)
JScript
function NotifyTestStepLogStreamEnd(
stepId : String,
streamName : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamWrite Method

ITestExecutionListener.NotifyTestStepLogStreamWrite Method
[image]

Notifies the listener that text has been written to a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepLogStreamWrite( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal text As String _
)
C#
void NotifyTestStepLogStreamWrite(
string stepId,
string streamName,
string text
)
C++
void NotifyTestStepLogStreamWrite(
String stepId,
String streamName,
String text
) abstract
J#
void NotifyTestStepLogStreamWrite(
string stepId,
string streamName,
string text
)
JScript
function NotifyTestStepLogStreamWrite(
stepId : String,
streamName : String,
text : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
text
The text, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepMetadataAdded Method

ITestExecutionListener.NotifyTestStepMetadataAdded Method
[image]

Notifies the listener that a test step has dynamically added metadata to itself.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepMetadataAdded( _
ByVal stepId As String, _
ByVal metadataKey As String, _
ByVal metadataValue As String _
)
C#
void NotifyTestStepMetadataAdded(
string stepId,
string metadataKey,
string metadataValue
)
C++
void NotifyTestStepMetadataAdded(
String stepId,
String metadataKey,
String metadataValue
) abstract
J#
void NotifyTestStepMetadataAdded(
string stepId,
string metadataKey,
string metadataValue
)
JScript
function NotifyTestStepMetadataAdded(
stepId : String,
metadataKey : String,
metadataValue : String
)

Parameters

stepId
The id of the test step, not null
metadataKey
The metadata key, not null
metadataValue
The metadata value, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


NotifyTestStepStarted Method

ITestExecutionListener.NotifyTestStepStarted Method
[image]

Notifies the listener that a test step has started execution.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyTestStepStarted( _
ByVal step As TestStepData _
)
C#
void NotifyTestStepStarted(
TestStepData step
)
C++
void NotifyTestStepStarted(
TestStepData step
) abstract
J#
void NotifyTestStepStarted(
TestStepData step
)
JScript
function NotifyTestStepStarted(
step : TestStepData
)

Parameters

step
Information about the test step that is about to start, not null

See Also

ITestExecutionListener Interface
Gallio.Model.Messages Namespace


ITestExplorationListener Interface

ITestExplorationListener Interface
See Also Example Members
[image]

A test exploration listener observes the progress of test exploration as a series of events.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestExplorationListener
C#
public interface ITestExplorationListener
C++
interface class ITestExplorationListener
J#
public interface ITestExplorationListener
JScript
public interface ITestExplorationListener

Types that implement ITestExplorationListener

Type | Description
Gallio.Model.Messages.RemoteTestExplorationListener | Wraps a test exploration listener so that it can be accessed remotely.

See Also

ITestExplorationListener Members
Gallio.Model.Messages Namespace


ITestExplorationListener Members

ITestExplorationListener Members
See Also Example Methods
[image]

A test exploration listener observes the progress of test exploration as a series of events.

The following tables list the members exposed by ITestExplorationListener.

Public Methods

 | Name | Description
Public method | NotifyAnnotationAdded | Notifies the listener that an annotation has been added to the test model.
Public method | NotifySubtreeMerged | Notifies the listener that a subtree of tests has been merged into the test model.
Top

See Also

ITestExplorationListener Interface
Gallio.Model.Messages Namespace


Methods

ITestExplorationListener Methods
[image]

Public Methods

 | Name | Description
Public method | NotifyAnnotationAdded | Notifies the listener that an annotation has been added to the test model.
Public method | NotifySubtreeMerged | Notifies the listener that a subtree of tests has been merged into the test model.
Top

See Also

ITestExplorationListener Interface
Gallio.Model.Messages Namespace


NotifyAnnotationAdded Method

ITestExplorationListener.NotifyAnnotationAdded Method
[image]

Notifies the listener that an annotation has been added to the test model.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifyAnnotationAdded( _
ByVal annotation As AnnotationData _
)
C#
void NotifyAnnotationAdded(
AnnotationData annotation
)
C++
void NotifyAnnotationAdded(
AnnotationData annotation
) abstract
J#
void NotifyAnnotationAdded(
AnnotationData annotation
)
JScript
function NotifyAnnotationAdded(
annotation : AnnotationData
)

Parameters

annotation
The annotation that was added

See Also

ITestExplorationListener Interface
Gallio.Model.Messages Namespace


NotifySubtreeMerged Method

ITestExplorationListener.NotifySubtreeMerged Method
[image]

Notifies the listener that a subtree of tests has been merged into the test model.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub NotifySubtreeMerged( _
ByVal parentTestId As String, _
ByVal test As TestData _
)
C#
void NotifySubtreeMerged(
string parentTestId,
TestData test
)
C++
void NotifySubtreeMerged(
String parentTestId,
TestData test
) abstract
J#
void NotifySubtreeMerged(
string parentTestId,
TestData test
)
JScript
function NotifySubtreeMerged(
parentTestId : String,
test : TestData
)

Parameters

parentTestId
The id of the parent test, or null if adding the root
test
The test at the top of the subtree was merged

See Also

ITestExplorationListener Interface
Gallio.Model.Messages Namespace


RemoteTestExecutionListener Class

RemoteTestExecutionListener Class
See Also Example Members
[image]

Wraps a test execution listener so that it can be accessed remotely.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RemoteTestExecutionListener
Inherits LongLivedMarshalByRefObject
Implements ITestExecutionListener
C#
public class RemoteTestExecutionListener : LongLivedMarshalByRefObject, ITestExecutionListener
C++
ref class RemoteTestExecutionListener : LongLivedMarshalByRefObject, ITestExecutionListener
J#
public class RemoteTestExecutionListener extends LongLivedMarshalByRefObject implements ITestExecutionListener
JScript
public class RemoteTestExecutionListener extends LongLivedMarshalByRefObject, ITestExecutionListener

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Model.Messages.RemoteTestExecutionListener

See Also

RemoteTestExecutionListener Members
Gallio.Model.Messages Namespace


RemoteTestExecutionListener Members

RemoteTestExecutionListener Members
See Also Example Constructors Methods
[image]

Wraps a test execution listener so that it can be accessed remotely.

The following tables list the members exposed by RemoteTestExecutionListener.

Public Constructors

 | Name | Description
Public method | RemoteTestExecutionListener | Creates a wrapper for the specified listener.
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | NotifyTestStepFinished | Notifies the listener that a test step has finished execution.
Public method | NotifyTestStepLifecyclePhaseChanged | Notifies the listener that a test step has changed lifecycle phase.
Public method | NotifyTestStepLogAttach | Notifies the listener that an attachment has been added to a test step log.
Public method | NotifyTestStepLogStreamBeginMarker | Notifies the listener that a marker region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamBeginSection | Notifies the listener that a section region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamEmbed | Notifies the listener that an attachment has been embedded into a test step log stream.
Public method | NotifyTestStepLogStreamEnd | Notifies the listener that a region started with Begin* has finished within a test step log stream.
Public method | NotifyTestStepLogStreamWrite | Notifies the listener that text has been written to a test step log stream.
Public method | NotifyTestStepMetadataAdded | Notifies the listener that a test step has dynamically added metadata to itself.
Public method | NotifyTestStepStarted | Notifies the listener that a test step has started execution.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


RemoteTestExecutionListener Constructor

RemoteTestExecutionListener Constructor
[image]

Creates a wrapper for the specified listener.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testExecutionListener As ITestExecutionListener _
)
C#
public RemoteTestExecutionListener(
ITestExecutionListener testExecutionListener
)
C++
public:
RemoteTestExecutionListener(
ITestExecutionListener testExecutionListener
) sealed
J#
public RemoteTestExecutionListener(
ITestExecutionListener testExecutionListener
)
JScript
public function RemoteTestExecutionListener(
testExecutionListener : ITestExecutionListener
)

Parameters

testExecutionListener
The listener to wrap

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testExecutionListener is null

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


Methods

RemoteTestExecutionListener Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | NotifyTestStepFinished | Notifies the listener that a test step has finished execution.
Public method | NotifyTestStepLifecyclePhaseChanged | Notifies the listener that a test step has changed lifecycle phase.
Public method | NotifyTestStepLogAttach | Notifies the listener that an attachment has been added to a test step log.
Public method | NotifyTestStepLogStreamBeginMarker | Notifies the listener that a marker region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamBeginSection | Notifies the listener that a section region has been started within a test step log stream.
Public method | NotifyTestStepLogStreamEmbed | Notifies the listener that an attachment has been embedded into a test step log stream.
Public method | NotifyTestStepLogStreamEnd | Notifies the listener that a region started with Begin* has finished within a test step log stream.
Public method | NotifyTestStepLogStreamWrite | Notifies the listener that text has been written to a test step log stream.
Public method | NotifyTestStepMetadataAdded | Notifies the listener that a test step has dynamically added metadata to itself.
Public method | NotifyTestStepStarted | Notifies the listener that a test step has started execution.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepFinished Method

RemoteTestExecutionListener.NotifyTestStepFinished Method
[image]

Notifies the listener that a test step has finished execution.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepFinished( _
ByVal stepId As String, _
ByVal result As TestResult _
) _
Implements ITestExecutionListener.NotifyTestStepFinished
C#
public void NotifyTestStepFinished(
string stepId,
TestResult result
)
C++
public:
void NotifyTestStepFinished(
String stepId,
TestResult result
) sealed
J#
public void NotifyTestStepFinished(
string stepId,
TestResult result
)
JScript
public function NotifyTestStepFinished(
stepId : String,
result : TestResult
)

Parameters

stepId
The id of the test step, not null
result
The test result, not null

Implements

ITestExecutionListener.NotifyTestStepFinished

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLifecyclePhaseChanged Method

RemoteTestExecutionListener.NotifyTestStepLifecyclePhaseChanged Method
See Also Example
[image]

Notifies the listener that a test step has changed lifecycle phase.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLifecyclePhaseChanged( _
ByVal stepId As String, _
ByVal lifecyclePhase As String _
) _
Implements ITestExecutionListener.NotifyTestStepLifecyclePhaseChanged
C#
public void NotifyTestStepLifecyclePhaseChanged(
string stepId,
string lifecyclePhase
)
C++
public:
void NotifyTestStepLifecyclePhaseChanged(
String stepId,
String lifecyclePhase
) sealed
J#
public void NotifyTestStepLifecyclePhaseChanged(
string stepId,
string lifecyclePhase
)
JScript
public function NotifyTestStepLifecyclePhaseChanged(
stepId : String,
lifecyclePhase : String
)

Parameters

stepId
The id of the test step, not null
lifecyclePhase
The lifecycle phase name, not null

Implements

ITestExecutionListener.NotifyTestStepLifecyclePhaseChanged

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLogAttach Method

RemoteTestExecutionListener.NotifyTestStepLogAttach Method
[image]

Notifies the listener that an attachment has been added to a test step log.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogAttach( _
ByVal stepId As String, _
ByVal attachment As Attachment _
) _
Implements ITestExecutionListener.NotifyTestStepLogAttach
C#
public void NotifyTestStepLogAttach(
string stepId,
Attachment attachment
)
C++
public:
void NotifyTestStepLogAttach(
String stepId,
Attachment attachment
) sealed
J#
public void NotifyTestStepLogAttach(
string stepId,
Attachment attachment
)
JScript
public function NotifyTestStepLogAttach(
stepId : String,
attachment : Attachment
)

Parameters

stepId
The id of the test step, not null
attachment
The attachment, not null

Implements

ITestExecutionListener.NotifyTestStepLogAttach

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamBeginMarker Method

RemoteTestExecutionListener.NotifyTestStepLogStreamBeginMarker Method
See Also Example
[image]

Notifies the listener that a marker region has been started within a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamBeginMarker( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal marker As Marker _
) _
Implements ITestExecutionListener.NotifyTestStepLogStreamBeginMarker
C#
public void NotifyTestStepLogStreamBeginMarker(
string stepId,
string streamName,
Marker marker
)
C++
public:
void NotifyTestStepLogStreamBeginMarker(
String stepId,
String streamName,
Marker marker
) sealed
J#
public void NotifyTestStepLogStreamBeginMarker(
string stepId,
string streamName,
Marker marker
)
JScript
public function NotifyTestStepLogStreamBeginMarker(
stepId : String,
streamName : String,
marker : Marker
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
marker
The marker

Implements

ITestExecutionListener.NotifyTestStepLogStreamBeginMarker

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamBeginSection Method

RemoteTestExecutionListener.NotifyTestStepLogStreamBeginSection Method
See Also Example
[image]

Notifies the listener that a section region has been started within a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamBeginSection( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal sectionName As String _
) _
Implements ITestExecutionListener.NotifyTestStepLogStreamBeginSection
C#
public void NotifyTestStepLogStreamBeginSection(
string stepId,
string streamName,
string sectionName
)
C++
public:
void NotifyTestStepLogStreamBeginSection(
String stepId,
String streamName,
String sectionName
) sealed
J#
public void NotifyTestStepLogStreamBeginSection(
string stepId,
string streamName,
string sectionName
)
JScript
public function NotifyTestStepLogStreamBeginSection(
stepId : String,
streamName : String,
sectionName : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
sectionName
The section name, not null

Implements

ITestExecutionListener.NotifyTestStepLogStreamBeginSection

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamEmbed Method

RemoteTestExecutionListener.NotifyTestStepLogStreamEmbed Method
See Also Example
[image]

Notifies the listener that an attachment has been embedded into a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamEmbed( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal attachmentName As String _
) _
Implements ITestExecutionListener.NotifyTestStepLogStreamEmbed
C#
public void NotifyTestStepLogStreamEmbed(
string stepId,
string streamName,
string attachmentName
)
C++
public:
void NotifyTestStepLogStreamEmbed(
String stepId,
String streamName,
String attachmentName
) sealed
J#
public void NotifyTestStepLogStreamEmbed(
string stepId,
string streamName,
string attachmentName
)
JScript
public function NotifyTestStepLogStreamEmbed(
stepId : String,
streamName : String,
attachmentName : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
attachmentName
The attachment name, not null

Implements

ITestExecutionListener.NotifyTestStepLogStreamEmbed

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamEnd Method

RemoteTestExecutionListener.NotifyTestStepLogStreamEnd Method
See Also Example
[image]

Notifies the listener that a region started with Begin* has finished within a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamEnd( _
ByVal stepId As String, _
ByVal streamName As String _
) _
Implements ITestExecutionListener.NotifyTestStepLogStreamEnd
C#
public void NotifyTestStepLogStreamEnd(
string stepId,
string streamName
)
C++
public:
void NotifyTestStepLogStreamEnd(
String stepId,
String streamName
) sealed
J#
public void NotifyTestStepLogStreamEnd(
string stepId,
string streamName
)
JScript
public function NotifyTestStepLogStreamEnd(
stepId : String,
streamName : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null

Implements

ITestExecutionListener.NotifyTestStepLogStreamEnd

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepLogStreamWrite Method

RemoteTestExecutionListener.NotifyTestStepLogStreamWrite Method
See Also Example
[image]

Notifies the listener that text has been written to a test step log stream.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamWrite( _
ByVal stepId As String, _
ByVal streamName As String, _
ByVal text As String _
) _
Implements ITestExecutionListener.NotifyTestStepLogStreamWrite
C#
public void NotifyTestStepLogStreamWrite(
string stepId,
string streamName,
string text
)
C++
public:
void NotifyTestStepLogStreamWrite(
String stepId,
String streamName,
String text
) sealed
J#
public void NotifyTestStepLogStreamWrite(
string stepId,
string streamName,
string text
)
JScript
public function NotifyTestStepLogStreamWrite(
stepId : String,
streamName : String,
text : String
)

Parameters

stepId
The id of the test step, not null
streamName
The stream name, not null
text
The text, not null

Implements

ITestExecutionListener.NotifyTestStepLogStreamWrite

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepMetadataAdded Method

RemoteTestExecutionListener.NotifyTestStepMetadataAdded Method
See Also Example
[image]

Notifies the listener that a test step has dynamically added metadata to itself.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepMetadataAdded( _
ByVal stepId As String, _
ByVal metadataKey As String, _
ByVal metadataValue As String _
) _
Implements ITestExecutionListener.NotifyTestStepMetadataAdded
C#
public void NotifyTestStepMetadataAdded(
string stepId,
string metadataKey,
string metadataValue
)
C++
public:
void NotifyTestStepMetadataAdded(
String stepId,
String metadataKey,
String metadataValue
) sealed
J#
public void NotifyTestStepMetadataAdded(
string stepId,
string metadataKey,
string metadataValue
)
JScript
public function NotifyTestStepMetadataAdded(
stepId : String,
metadataKey : String,
metadataValue : String
)

Parameters

stepId
The id of the test step, not null
metadataKey
The metadata key, not null
metadataValue
The metadata value, not null

Implements

ITestExecutionListener.NotifyTestStepMetadataAdded

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


NotifyTestStepStarted Method

RemoteTestExecutionListener.NotifyTestStepStarted Method
[image]

Notifies the listener that a test step has started execution.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepStarted( _
ByVal step As TestStepData _
) _
Implements ITestExecutionListener.NotifyTestStepStarted
C#
public void NotifyTestStepStarted(
TestStepData step
)
C++
public:
void NotifyTestStepStarted(
TestStepData step
) sealed
J#
public void NotifyTestStepStarted(
TestStepData step
)
JScript
public function NotifyTestStepStarted(
step : TestStepData
)

Parameters

step
Information about the test step that is about to start, not null

Implements

ITestExecutionListener.NotifyTestStepStarted

See Also

RemoteTestExecutionListener Class
Gallio.Model.Messages Namespace


RemoteTestExplorationListener Class

RemoteTestExplorationListener Class
See Also Example Members
[image]

Wraps a test exploration listener so that it can be accessed remotely.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RemoteTestExplorationListener
Inherits LongLivedMarshalByRefObject
Implements ITestExplorationListener
C#
public class RemoteTestExplorationListener : LongLivedMarshalByRefObject, ITestExplorationListener
C++
ref class RemoteTestExplorationListener : LongLivedMarshalByRefObject, ITestExplorationListener
J#
public class RemoteTestExplorationListener extends LongLivedMarshalByRefObject implements ITestExplorationListener
JScript
public class RemoteTestExplorationListener extends LongLivedMarshalByRefObject, ITestExplorationListener

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Model.Messages.RemoteTestExplorationListener

See Also

RemoteTestExplorationListener Members
Gallio.Model.Messages Namespace


RemoteTestExplorationListener Members

RemoteTestExplorationListener Members
See Also Example Constructors Methods
[image]

Wraps a test exploration listener so that it can be accessed remotely.

The following tables list the members exposed by RemoteTestExplorationListener.

Public Constructors

 | Name | Description
Public method | RemoteTestExplorationListener | Creates a wrapper for the specified listener.
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | NotifyAnnotationAdded | Notifies the listener that an annotation has been added to the test model.
Public method | NotifySubtreeMerged | Notifies the listener that a subtree of tests has been merged into the test model.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

RemoteTestExplorationListener Class
Gallio.Model.Messages Namespace


RemoteTestExplorationListener Constructor

RemoteTestExplorationListener Constructor
[image]

Creates a wrapper for the specified listener.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testExplorationListener As ITestExplorationListener _
)
C#
public RemoteTestExplorationListener(
ITestExplorationListener testExplorationListener
)
C++
public:
RemoteTestExplorationListener(
ITestExplorationListener testExplorationListener
) sealed
J#
public RemoteTestExplorationListener(
ITestExplorationListener testExplorationListener
)
JScript
public function RemoteTestExplorationListener(
testExplorationListener : ITestExplorationListener
)

Parameters

testExplorationListener
The listener to wrap

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testExplorationListener is null

See Also

RemoteTestExplorationListener Class
Gallio.Model.Messages Namespace


Methods

RemoteTestExplorationListener Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | NotifyAnnotationAdded | Notifies the listener that an annotation has been added to the test model.
Public method | NotifySubtreeMerged | Notifies the listener that a subtree of tests has been merged into the test model.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

RemoteTestExplorationListener Class
Gallio.Model.Messages Namespace


NotifyAnnotationAdded Method

RemoteTestExplorationListener.NotifyAnnotationAdded Method
[image]

Notifies the listener that an annotation has been added to the test model.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyAnnotationAdded( _
ByVal annotation As AnnotationData _
) _
Implements ITestExplorationListener.NotifyAnnotationAdded
C#
public void NotifyAnnotationAdded(
AnnotationData annotation
)
C++
public:
void NotifyAnnotationAdded(
AnnotationData annotation
) sealed
J#
public void NotifyAnnotationAdded(
AnnotationData annotation
)
JScript
public function NotifyAnnotationAdded(
annotation : AnnotationData
)

Parameters

annotation
The annotation that was added

Implements

ITestExplorationListener.NotifyAnnotationAdded

See Also

RemoteTestExplorationListener Class
Gallio.Model.Messages Namespace


NotifySubtreeMerged Method

RemoteTestExplorationListener.NotifySubtreeMerged Method
[image]

Notifies the listener that a subtree of tests has been merged into the test model.

Namespace: Gallio.Model.Messages
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifySubtreeMerged( _
ByVal parentTestId As String, _
ByVal test As TestData _
) _
Implements ITestExplorationListener.NotifySubtreeMerged
C#
public void NotifySubtreeMerged(
string parentTestId,
TestData test
)
C++
public:
void NotifySubtreeMerged(
String parentTestId,
TestData test
) sealed
J#
public void NotifySubtreeMerged(
string parentTestId,
TestData test
)
JScript
public function NotifySubtreeMerged(
parentTestId : String,
test : TestData
)

Parameters

parentTestId
The id of the parent test, or null if adding the root
test
The test at the top of the subtree was merged

Implements

ITestExplorationListener.NotifySubtreeMerged

See Also

RemoteTestExplorationListener Class
Gallio.Model.Messages Namespace


Gallio.Model.Serialization

Gallio.Model.Serialization Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AnnotationData | Describes an annotation in a portable manner for serialization.
Public class | TestComponentData | Describes a test model component in a portable manner for serialization. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestData | Describes a test in a portable manner for serialization. This class cannot be inherited.
Public class | TestModelData | The test model captures the root of the test data tree along with an index by id. This class cannot be inherited.
Public class | TestPackageData | Describes a test package in a portable manner for serialization. This class cannot be inherited.
Public class | TestParameterData | Describes a test parameter in a portable manner for serialization. This class cannot be inherited.
Public class | TestStepData | Describes a test step in a portable manner for serialization. This class cannot be inherited.


AnnotationData Class

AnnotationData Class
See Also Example Members
[image]

Describes an annotation in a portable manner for serialization.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("annotation", Namespace := "http://www.gallio.org/")>
Public Class AnnotationData
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("annotation", Namespace = "http://www.gallio.org/")]
public class AnnotationData
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"annotation", Namespace = L"http://www.gallio.org/")]
ref class AnnotationData
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("annotation", Namespace = "http://www.gallio.org/") */
public class AnnotationData
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("annotation", Namespace = "http://www.gallio.org/")
class AnnotationData

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.AnnotationData

See Also

AnnotationData Members
Gallio.Model.Serialization Namespace
Annotation


AnnotationData Members

AnnotationData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes an annotation in a portable manner for serialization.

The following tables list the members exposed by AnnotationData.

Public Constructors

Name | Description
AnnotationData | Overloaded.
Top

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location associated with the annotation.
Public property | CodeReference | Gets or sets the code reference associated with the annotation.
Public property | Details | Gets or sets additional details such as exception text, or null if none.
Public property | Message | Gets or sets the annotation message.
Public property | Type | Gets or sets the annotation type.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Writes the annotation to a logger for presentation.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
AnnotationData | Overloaded.
Top

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace
Annotation


AnnotationData Constructor

AnnotationData Constructor

Overload List

 | Name | Description
Public method | AnnotationData (Annotation) | Copies the contents of an annotation.
Public method | AnnotationData (AnnotationType, CodeLocation, CodeReference, String, String) | Creates an annotation.

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


AnnotationData Constructor (Annotation)

AnnotationData Constructor (Annotation)
See Also Example
[image]

Copies the contents of an annotation.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As Annotation _
)
C#
public AnnotationData(
Annotation source
)
C++
public:
AnnotationData(
Annotation source
) sealed
J#
public AnnotationData(
Annotation source
)
JScript
public function AnnotationData(
source : Annotation
)

Parameters

source
The source annotation

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace
AnnotationData Constructor Overload List


AnnotationData Constructor (AnnotationType, CodeLocation, CodeReference, String, String)

AnnotationData Constructor (AnnotationType, CodeLocation, CodeReference, String, String)
See Also Example
[image]

Creates an annotation.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As AnnotationType, _
ByVal codeLocation As CodeLocation, _
ByVal codeReference As CodeReference, _
ByVal message As String, _
ByVal details As String _
)
C#
public AnnotationData(
AnnotationType type,
CodeLocation codeLocation,
CodeReference codeReference,
string message,
string details
)
C++
public:
AnnotationData(
AnnotationType type,
CodeLocation codeLocation,
CodeReference codeReference,
String message,
String details
) sealed
J#
public AnnotationData(
AnnotationType type,
CodeLocation codeLocation,
CodeReference codeReference,
string message,
string details
)
JScript
public function AnnotationData(
type : AnnotationType,
codeLocation : CodeLocation,
codeReference : CodeReference,
message : String,
details : String
)

Parameters

type
The annotation type
codeLocation
The code location
codeReference
The code reference
message
The annotation message
details
Additional details such as exception text or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace
AnnotationData Constructor Overload List


Properties

AnnotationData Properties
[image]

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location associated with the annotation.
Public property | CodeReference | Gets or sets the code reference associated with the annotation.
Public property | Details | Gets or sets additional details such as exception text, or null if none.
Public property | Message | Gets or sets the annotation message.
Public property | Type | Gets or sets the annotation type.
Top

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace
Annotation


CodeLocation Property

AnnotationData.CodeLocation Property
[image]

Gets or sets the code location associated with the annotation.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("codeLocation")>
Public Property CodeLocation As CodeLocation
C#
[XmlElementAttribute("codeLocation")]
public CodeLocation CodeLocation { get; set; }
C++
[XmlElementAttribute(L"codeLocation")]
public property CodeLocation CodeLocation sealed {
CodeLocation get();
void set(CodeLocation value);
}
J#
/** @attribute XmlElementAttribute("codeLocation") */
/** property */
public CodeLocation get_CodeLocation();

/** property */
public void set_CodeLocation(CodeLocation value);
JScript
public function get CodeLocation() : CodeLocation

public function set CodeLocation(value : CodeLocation);

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


CodeReference Property

AnnotationData.CodeReference Property
[image]

Gets or sets the code reference associated with the annotation.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("codeReference")>
Public Property CodeReference As CodeReference
C#
[XmlElementAttribute("codeReference")]
public CodeReference CodeReference { get; set; }
C++
[XmlElementAttribute(L"codeReference")]
public property CodeReference CodeReference sealed {
CodeReference get();
void set(CodeReference value);
}
J#
/** @attribute XmlElementAttribute("codeReference") */
/** property */
public CodeReference get_CodeReference();

/** property */
public void set_CodeReference(CodeReference value);
JScript
public function get CodeReference() : CodeReference

public function set CodeReference(value : CodeReference);

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


Details Property

AnnotationData.Details Property
[image]

Gets or sets additional details such as exception text, or null if none.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("details")>
Public Property Details As String
C#
[XmlAttributeAttribute("details")]
public string Details { get; set; }
C++
[XmlAttributeAttribute(L"details")]
public property string Details sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("details") */
/** property */
public string get_Details();

/** property */
public void set_Details(string value);
JScript
public function get Details() : String

public function set Details(value : String);

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


Message Property

AnnotationData.Message Property
[image]

Gets or sets the annotation message.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("message")>
Public Property Message As String
C#
[XmlAttributeAttribute("message")]
public string Message { get; set; }
C++
[XmlAttributeAttribute(L"message")]
public property string Message sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("message") */
/** property */
public string get_Message();

/** property */
public void set_Message(string value);
JScript
public function get Message() : String

public function set Message(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


Type Property

AnnotationData.Type Property
[image]

Gets or sets the annotation type.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("type")>
Public Property Type As AnnotationType
C#
[XmlAttributeAttribute("type")]
public AnnotationType Type { get; set; }
C++
[XmlAttributeAttribute(L"type")]
public property AnnotationType Type sealed {
AnnotationType get();
void set(AnnotationType value);
}
J#
/** @attribute XmlAttributeAttribute("type") */
/** property */
public AnnotationType get_Type();

/** property */
public void set_Type(AnnotationType value);
JScript
public function get Type() : AnnotationType

public function set Type(value : AnnotationType);

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


Methods

AnnotationData Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Writes the annotation to a logger for presentation.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace
Annotation


Log Method

AnnotationData.Log Method
[image]

Writes the annotation to a logger for presentation.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Log( _
ByVal logger As ILogger, _
ByVal includePrefix As Boolean _
)
C#
public void Log(
ILogger logger,
bool includePrefix
)
C++
public:
void Log(
ILogger logger,
bool includePrefix
) sealed
J#
public void Log(
ILogger logger,
bool includePrefix
)
JScript
public function Log(
logger : ILogger,
includePrefix : bool
)

Parameters

logger
The logger
includePrefix
If true, includes an identifying prefix to describe the annotation type, otherwise we assume that the logger will do its own thing based on the log severity

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logger is null

See Also

AnnotationData Class
Gallio.Model.Serialization Namespace


TestComponentData Class

TestComponentData Class
See Also Example Members
[image]

Describes a test model component in a portable manner for serialization. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public MustInherit Class TestComponentData
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public abstract class TestComponentData
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestComponentData abstract
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public class TestComponentData
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
class TestComponentData

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.TestComponentData
Gallio.Model.Serialization.TestData
Gallio.Model.Serialization.TestPackageData
Gallio.Model.Serialization.TestParameterData
Gallio.Model.Serialization.TestStepData

See Also

TestComponentData Members
Gallio.Model.Serialization Namespace
ITestComponent


TestComponentData Members

TestComponentData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes a test model component in a portable manner for serialization. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestComponentData.

Public Constructors

Name | Description
TestComponentData | Overloaded. Initializes a new instance of the TestComponentData class.
Top

Protected Constructors

Name | Description
TestComponentData | Overloaded. Initializes a new instance of the TestComponentData class.
Top

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available.
Public property | CodeReference | Gets or sets the code reference or Unknown if not available.
Public property | Id | Gets or sets the test component id. (non-null)
Public property | Metadata | Gets or sets the metadata map. (non-null)
Public property | Name | Gets or sets the test component name. (non-null)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestComponentData | Overloaded. Initializes a new instance of the TestComponentData class.
Top

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
ITestComponent


TestComponentData Constructor

TestComponentData Constructor

Initializes a new instance of the TestComponentData class.

Overload List

 | Name | Description
Family method | TestComponentData | Creates an uninitialized instance for Xml deserialization.
Public method | TestComponentData (ITestComponent) | Copies the contents of a test component.
Public method | TestComponentData (String, String) | Creates a test component.

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace


TestComponentData Constructor ()

TestComponentData Constructor ()
See Also Example
[image]

Creates an uninitialized instance for Xml deserialization.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestComponentData()
C++
protected:
TestComponentData() sealed
J#
protected TestComponentData()
JScript
protected function TestComponentData()

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
TestComponentData Constructor Overload List


TestComponentData Constructor (ITestComponent)

TestComponentData Constructor (ITestComponent)
See Also Example
[image]

Copies the contents of a test component.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITestComponent _
)
C#
public TestComponentData(
ITestComponent source
)
C++
public:
TestComponentData(
ITestComponent source
) sealed
J#
public TestComponentData(
ITestComponent source
)
JScript
public function TestComponentData(
source : ITestComponent
)

Parameters

source
The source object

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
TestComponentData Constructor Overload List


TestComponentData Constructor (String, String)

TestComponentData Constructor (String, String)
See Also Example
[image]

Creates a test component.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
C#
public TestComponentData(
string id,
string name
)
C++
public:
TestComponentData(
String id,
String name
) sealed
J#
public TestComponentData(
string id,
string name
)
JScript
public function TestComponentData(
id : String,
name : String
)

Parameters

id
The component id
name
The component name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if id or name is null

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
TestComponentData Constructor Overload List


Properties

TestComponentData Properties
[image]

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available.
Public property | CodeReference | Gets or sets the code reference or Unknown if not available.
Public property | Id | Gets or sets the test component id. (non-null)
Public property | Metadata | Gets or sets the metadata map. (non-null)
Public property | Name | Gets or sets the test component name. (non-null)
Top

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
ITestComponent


CodeLocation Property

TestComponentData.CodeLocation Property
[image]

Gets or sets the code location or Unknown if not available.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("codeLocation", IsNullable := False)>
Public Property CodeLocation As CodeLocation
C#
[XmlElementAttribute("codeLocation", IsNullable = False)]
public CodeLocation CodeLocation { get; set; }
C++
[XmlElementAttribute(L"codeLocation", IsNullable = False)]
public property CodeLocation CodeLocation sealed {
CodeLocation get();
void set(CodeLocation value);
}
J#
/** @attribute XmlElementAttribute("codeLocation", IsNullable = False) */
/** property */
public CodeLocation get_CodeLocation();

/** property */
public void set_CodeLocation(CodeLocation value);
JScript
public function get CodeLocation() : CodeLocation

public function set CodeLocation(value : CodeLocation);

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
CodeElement


CodeReference Property

TestComponentData.CodeReference Property
[image]

Gets or sets the code reference or Unknown if not available.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("codeReference", IsNullable := False)>
Public Property CodeReference As CodeReference
C#
[XmlElementAttribute("codeReference", IsNullable = False)]
public CodeReference CodeReference { get; set; }
C++
[XmlElementAttribute(L"codeReference", IsNullable = False)]
public property CodeReference CodeReference sealed {
CodeReference get();
void set(CodeReference value);
}
J#
/** @attribute XmlElementAttribute("codeReference", IsNullable = False) */
/** property */
public CodeReference get_CodeReference();

/** property */
public void set_CodeReference(CodeReference value);
JScript
public function get CodeReference() : CodeReference

public function set CodeReference(value : CodeReference);

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
CodeElement


Id Property

TestComponentData.Id Property
[image]

Gets or sets the test component id. (non-null)

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("id")>
Public Property Id As String
C#
[XmlAttributeAttribute("id")]
public string Id { get; set; }
C++
[XmlAttributeAttribute(L"id")]
public property string Id sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("id") */
/** property */
public string get_Id();

/** property */
public void set_Id(string value);
JScript
public function get Id() : String

public function set Id(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
Id


Metadata Property

TestComponentData.Metadata Property
[image]

Gets or sets the metadata map. (non-null)

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("metadata", IsNullable := False)>
Public Property Metadata As PropertyBag
C#
[XmlElementAttribute("metadata", IsNullable = False)]
public PropertyBag Metadata { get; set; }
C++
[XmlElementAttribute(L"metadata", IsNullable = False)]
public property PropertyBag Metadata sealed {
PropertyBag get();
void set(PropertyBag value);
}
J#
/** @attribute XmlElementAttribute("metadata", IsNullable = False) */
/** property */
public PropertyBag get_Metadata();

/** property */
public void set_Metadata(PropertyBag value);
JScript
public function get Metadata() : PropertyBag

public function set Metadata(value : PropertyBag);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
Metadata


Name Property

TestComponentData.Name Property
[image]

Gets or sets the test component name. (non-null)

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("name")>
Public Property Name As String
C#
[XmlAttributeAttribute("name")]
public string Name { get; set; }
C++
[XmlAttributeAttribute(L"name")]
public property string Name sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("name") */
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestComponentData Class
Gallio.Model.Serialization Namespace
Name


TestData Class

TestData Class
See Also Example Members
[image]

Describes a test in a portable manner for serialization. This class cannot be inherited.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("test", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestData
Inherits TestComponentData
C#
[SerializableAttribute]
[XmlRootAttribute("test", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestData : TestComponentData
C++
[SerializableAttribute]
[XmlRootAttribute(L"test", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestData sealed : TestComponentData
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("test", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestData extends TestComponentData
JScript
public
SerializableAttribute
XmlRootAttribute("test", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestData extends TestComponentData

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.TestComponentData
Gallio.Model.Serialization.TestData

See Also

TestData Members
Gallio.Model.Serialization Namespace
ITest


TestData Members

TestData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes a test in a portable manner for serialization. This class cannot be inherited.

The following tables list the members exposed by TestData.

Public Constructors

Name | Description
TestData | Overloaded.
Top

Public Properties

 | Name | Description
Public property | AllTests | Recursively enumerates this test and all of its descendants.
Public property | Children | Gets the mutable list of children.
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | FullName | Gets or sets the full name of the test.
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | IsTestCase | Gets or sets whether this node is a test case.
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Public property | Parameters | Gets the mutable list of parameters.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestData | Overloaded.
Top

See Also

TestData Class
Gallio.Model.Serialization Namespace
ITest


TestData Constructor

TestData Constructor

Overload List

 | Name | Description
Public method | TestData (ITest) | Copies the contents of a test.
Public method | TestData (String, String, String) | Creates a test info.

See Also

TestData Class
Gallio.Model.Serialization Namespace


TestData Constructor (ITest)

TestData Constructor (ITest)
See Also Example
[image]

Copies the contents of a test.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITest _
)
C#
public TestData(
ITest source
)
C++
public:
TestData(
ITest source
) sealed
J#
public TestData(
ITest source
)
JScript
public function TestData(
source : ITest
)

Parameters

source
The source test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestData Class
Gallio.Model.Serialization Namespace
TestData Constructor Overload List


TestData Constructor (String, String, String)

TestData Constructor (String, String, String)
See Also Example
[image]

Creates a test info.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal fullName As String _
)
C#
public TestData(
string id,
string name,
string fullName
)
C++
public:
TestData(
String id,
String name,
String fullName
) sealed
J#
public TestData(
string id,
string name,
string fullName
)
JScript
public function TestData(
id : String,
name : String,
fullName : String
)

Parameters

id
The component id
name
The component name
fullName
The full name of the test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if id, name, or fullName is null

See Also

TestData Class
Gallio.Model.Serialization Namespace
TestData Constructor Overload List


Properties

TestData Properties
[image]

Public Properties

 | Name | Description
Public property | AllTests | Recursively enumerates this test and all of its descendants.
Public property | Children | Gets the mutable list of children.
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | FullName | Gets or sets the full name of the test.
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | IsTestCase | Gets or sets whether this node is a test case.
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Public property | Parameters | Gets the mutable list of parameters.
Top

See Also

TestData Class
Gallio.Model.Serialization Namespace
ITest


AllTests Property

TestData.AllTests Property
[image]

Recursively enumerates this test and all of its descendants.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property AllTests As IEnumerable(Of TestData)
C#
[XmlIgnoreAttribute]
public IEnumerable<TestData> AllTests { get; }
C++
[XmlIgnoreAttribute]
public property IEnumerable<TestData> AllTests sealed {
IEnumerable<TestData> get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public IEnumerable<TestData> get_AllTests();
JScript
public function get AllTests() : IEnumerable<TestData>

See Also

TestData Class
Gallio.Model.Serialization Namespace


Children Property

TestData.Children Property
[image]

Gets the mutable list of children.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("test", GetType(TestData), IsNullable := False), _
XmlArrayAttribute("children", IsNullable := False)>
Public ReadOnly Property Children As List(Of TestData)
C#
[XmlArrayItemAttribute("test", typeof(TestData), IsNullable = False)]
[XmlArrayAttribute("children", IsNullable = False)]
public List<TestData> Children { get; }
C++
[XmlArrayItemAttribute(L"test", typeof(TestData), IsNullable = False)]
[XmlArrayAttribute(L"children", IsNullable = False)]
public property List<TestData> Children sealed {
List<TestData> get();
}
J#
/** @attribute XmlArrayItemAttribute("test", typeof(TestData), IsNullable = False) */
/** @attribute XmlArrayAttribute("children", IsNullable = False) */
/** property */
public List<TestData> get_Children();
JScript
public function get Children() : List<TestData>

See Also

TestData Class
Gallio.Model.Serialization Namespace
Children


FullName Property

TestData.FullName Property
[image]

Gets or sets the full name of the test.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("fullName")>
Public Property FullName As String
C#
[XmlAttributeAttribute("fullName")]
public string FullName { get; set; }
C++
[XmlAttributeAttribute(L"fullName")]
public property string FullName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("fullName") */
/** property */
public string get_FullName();

/** property */
public void set_FullName(string value);
JScript
public function get FullName() : String

public function set FullName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestData Class
Gallio.Model.Serialization Namespace


IsTestCase Property

TestData.IsTestCase Property
[image]

Gets or sets whether this node is a test case.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("isTestCase")>
Public Property IsTestCase As Boolean
C#
[XmlAttributeAttribute("isTestCase")]
public bool IsTestCase { get; set; }
C++
[XmlAttributeAttribute(L"isTestCase")]
public property bool IsTestCase sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("isTestCase") */
/** property */
public bool get_IsTestCase();

/** property */
public void set_IsTestCase(bool value);
JScript
public function get IsTestCase() : bool

public function set IsTestCase(value : bool);

See Also

TestData Class
Gallio.Model.Serialization Namespace
IsTestCase


Parameters Property

TestData.Parameters Property
[image]

Gets the mutable list of parameters.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("parameter", GetType(TestParameterData), IsNullable := False), _
XmlArrayAttribute("parameters", IsNullable := False)>
Public ReadOnly Property Parameters As List(Of TestParameterData)
C#
[XmlArrayItemAttribute("parameter", typeof(TestParameterData), IsNullable = False)]
[XmlArrayAttribute("parameters", IsNullable = False)]
public List<TestParameterData> Parameters { get; }
C++
[XmlArrayItemAttribute(L"parameter", typeof(TestParameterData), IsNullable = False)]
[XmlArrayAttribute(L"parameters", IsNullable = False)]
public property List<TestParameterData> Parameters sealed {
List<TestParameterData> get();
}
J#
/** @attribute XmlArrayItemAttribute("parameter", typeof(TestParameterData), IsNullable = False) */
/** @attribute XmlArrayAttribute("parameters", IsNullable = False) */
/** property */
public List<TestParameterData> get_Parameters();
JScript
public function get Parameters() : List<TestParameterData>

See Also

TestData Class
Gallio.Model.Serialization Namespace
Parameters


TestModelData Class

TestModelData Class
See Also Example Members
[image]

The test model captures the root of the test data tree along with an index by id. This class cannot be inherited.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("testModel", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestModelData
C#
[SerializableAttribute]
[XmlRootAttribute("testModel", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestModelData
C++
[SerializableAttribute]
[XmlRootAttribute(L"testModel", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestModelData sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("testModel", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestModelData
JScript
public
SerializableAttribute
XmlRootAttribute("testModel", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestModelData

Remarks

This class is safe for used by multiple threads.

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.TestModelData

See Also

TestModelData Members
Gallio.Model.Serialization Namespace


TestModelData Members

TestModelData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The test model captures the root of the test data tree along with an index by id. This class cannot be inherited.

The following tables list the members exposed by TestModelData.

Public Constructors

Name | Description
TestModelData | Overloaded. Initializes a new instance of the TestModelData class.
Top

Public Properties

 | Name | Description
Public property | AllTests | Recursively enumerates all tests including the root test.
Public property | Annotations | Gets the mutable list of annotations.
Public property | RootTest | Gets or sets the root test in the model.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetErrorAnnotationCount | Gets the number of error annotations on the model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetTestById | Gets a test by its id.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | MergeSubtree | Merged a subtree of tests into the model.
Public method | ResetIndex | Resets the test index by id in case the test model has been modified.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestModelData | Overloaded. Initializes a new instance of the TestModelData class.
Top

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


TestModelData Constructor

TestModelData Constructor

Initializes a new instance of the TestModelData class.

Overload List

 | Name | Description
Public method | TestModelData | Creates an empty test model with just a root test.
Public method | TestModelData (TestData) | Creates a test model.
Public method | TestModelData (TestModel) | Copies the contents of a test model.

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


TestModelData Constructor ()

TestModelData Constructor ()
See Also Example
[image]

Creates an empty test model with just a root test.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestModelData()
C++
public:
TestModelData() sealed
J#
public TestModelData()
JScript
public function TestModelData()

See Also

TestModelData Class
Gallio.Model.Serialization Namespace
TestModelData Constructor Overload List


TestModelData Constructor (TestData)

TestModelData Constructor (TestData)
See Also Example
[image]

Creates a test model.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal rootTest As TestData _
)
C#
public TestModelData(
TestData rootTest
)
C++
public:
TestModelData(
TestData rootTest
) sealed
J#
public TestModelData(
TestData rootTest
)
JScript
public function TestModelData(
rootTest : TestData
)

Parameters

rootTest
The root test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if rootTest is null

See Also

TestModelData Class
Gallio.Model.Serialization Namespace
TestModelData Constructor Overload List


TestModelData Constructor (TestModel)

TestModelData Constructor (TestModel)
See Also Example
[image]

Copies the contents of a test model.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As TestModel _
)
C#
public TestModelData(
TestModel source
)
C++
public:
TestModelData(
TestModel source
) sealed
J#
public TestModelData(
TestModel source
)
JScript
public function TestModelData(
source : TestModel
)

Parameters

source
The source test model

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestModelData Class
Gallio.Model.Serialization Namespace
TestModelData Constructor Overload List


Properties

TestModelData Properties
[image]

Public Properties

 | Name | Description
Public property | AllTests | Recursively enumerates all tests including the root test.
Public property | Annotations | Gets the mutable list of annotations.
Public property | RootTest | Gets or sets the root test in the model.
Top

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


AllTests Property

TestModelData.AllTests Property
[image]

Recursively enumerates all tests including the root test.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property AllTests As IEnumerable(Of TestData)
C#
[XmlIgnoreAttribute]
public IEnumerable<TestData> AllTests { get; }
C++
[XmlIgnoreAttribute]
public property IEnumerable<TestData> AllTests sealed {
IEnumerable<TestData> get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public IEnumerable<TestData> get_AllTests();
JScript
public function get AllTests() : IEnumerable<TestData>

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


Annotations Property

TestModelData.Annotations Property
[image]

Gets the mutable list of annotations.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("annotations", IsNullable := False), _
XmlArrayItemAttribute("annotation", GetType(AnnotationData), IsNullable := False)>
Public ReadOnly Property Annotations As List(Of AnnotationData)
C#
[XmlArrayAttribute("annotations", IsNullable = False)]
[XmlArrayItemAttribute("annotation", typeof(AnnotationData), IsNullable = False)]
public List<AnnotationData> Annotations { get; }
C++
[XmlArrayAttribute(L"annotations", IsNullable = False)]
[XmlArrayItemAttribute(L"annotation", typeof(AnnotationData), IsNullable = False)]
public property List<AnnotationData> Annotations sealed {
List<AnnotationData> get();
}
J#
/** @attribute XmlArrayAttribute("annotations", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("annotation", typeof(AnnotationData), IsNullable = False) */
/** property */
public List<AnnotationData> get_Annotations();
JScript
public function get Annotations() : List<AnnotationData>

See Also

TestModelData Class
Gallio.Model.Serialization Namespace
Annotations


RootTest Property

TestModelData.RootTest Property
[image]

Gets or sets the root test in the model.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("test", IsNullable := False)>
Public Property RootTest As TestData
C#
[XmlElementAttribute("test", IsNullable = False)]
public TestData RootTest { get; set; }
C++
[XmlElementAttribute(L"test", IsNullable = False)]
public property TestData RootTest sealed {
TestData get();
void set(TestData value);
}
J#
/** @attribute XmlElementAttribute("test", IsNullable = False) */
/** property */
public TestData get_RootTest();

/** property */
public void set_RootTest(TestData value);
JScript
public function get RootTest() : TestData

public function set RootTest(value : TestData);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


Methods

TestModelData Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetErrorAnnotationCount | Gets the number of error annotations on the model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetTestById | Gets a test by its id.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | MergeSubtree | Merged a subtree of tests into the model.
Public method | ResetIndex | Resets the test index by id in case the test model has been modified.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


GetErrorAnnotationCount Method

TestModelData.GetErrorAnnotationCount Method
[image]

Gets the number of error annotations on the model.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetErrorAnnotationCount() As Integer
C#
public int GetErrorAnnotationCount()
C++
public:
int GetErrorAnnotationCount() sealed
J#
public int GetErrorAnnotationCount()
JScript
public function GetErrorAnnotationCount() : int

Return Value

The numer of error annotations present

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


GetTestById Method

TestModelData.GetTestById Method
[image]

Gets a test by its id.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTestById( _
ByVal testId As String _
) As TestData
C#
public TestData GetTestById(
string testId
)
C++
public:
TestData GetTestById(
String testId
) sealed
J#
public TestData GetTestById(
string testId
)
JScript
public function GetTestById(
testId : String
) : TestData

Parameters

testId
The test id

Return Value

The test, or null if not found

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testId is null

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


MergeSubtree Method

TestModelData.MergeSubtree Method
[image]

Merged a subtree of tests into the model.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function MergeSubtree( _
ByVal parentTestId As String, _
ByVal test As TestData _
) As TestData
C#
public TestData MergeSubtree(
string parentTestId,
TestData test
)
C++
public:
TestData MergeSubtree(
String parentTestId,
TestData test
) sealed
J#
public TestData MergeSubtree(
string parentTestId,
TestData test
)
JScript
public function MergeSubtree(
parentTestId : String,
test : TestData
) : TestData

Parameters

parentTestId
The id of the parent test, or null if adding the root
test
The top test of the subtree to add

Return Value

The merged test, if the test was already present in the tree

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if test is null

Remarks

Merges tests with duplicate ids. Adds new tests in place.

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


ResetIndex Method

TestModelData.ResetIndex Method
[image]

Resets the test index by id in case the test model has been modified.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ResetIndex()
C#
public void ResetIndex()
C++
public:
void ResetIndex() sealed
J#
public void ResetIndex()
JScript
public function ResetIndex()

See Also

TestModelData Class
Gallio.Model.Serialization Namespace


TestPackageData Class

TestPackageData Class
See Also Example Members
[image]

Describes a test package in a portable manner for serialization. This class cannot be inherited.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("testPackage", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestPackageData
Inherits TestComponentData
C#
[SerializableAttribute]
[XmlRootAttribute("testPackage", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestPackageData : TestComponentData
C++
[SerializableAttribute]
[XmlRootAttribute(L"testPackage", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestPackageData sealed : TestComponentData
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("testPackage", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestPackageData extends TestComponentData
JScript
public
SerializableAttribute
XmlRootAttribute("testPackage", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestPackageData extends TestComponentData

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.TestComponentData
Gallio.Model.Serialization.TestPackageData

See Also

TestPackageData Members
Gallio.Model.Serialization Namespace
TestPackage


TestPackageData Members

TestPackageData Members
See Also Example Constructors Properties Methods
[image]

Describes a test package in a portable manner for serialization. This class cannot be inherited.

The following tables list the members exposed by TestPackageData.

Public Constructors

 | Name | Description
Public method | TestPackageData | Copies the contents of a test package.
Top

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | Config | Gets or sets the test package configuration.
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestPackageData Class
Gallio.Model.Serialization Namespace
TestPackage


TestPackageData Constructor

TestPackageData Constructor
[image]

Copies the contents of a test package.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As TestPackage _
)
C#
public TestPackageData(
TestPackage source
)
C++
public:
TestPackageData(
TestPackage source
) sealed
J#
public TestPackageData(
TestPackage source
)
JScript
public function TestPackageData(
source : TestPackage
)

Parameters

source
The source test package

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestPackageData Class
Gallio.Model.Serialization Namespace


Properties

TestPackageData Properties
[image]

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | Config | Gets or sets the test package configuration.
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Top

See Also

TestPackageData Class
Gallio.Model.Serialization Namespace
TestPackage


Config Property

TestPackageData.Config Property
[image]

Gets or sets the test package configuration.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testPackageConfig", IsNullable := False)>
Public Property Config As TestPackageConfig
C#
[XmlElementAttribute("testPackageConfig", IsNullable = False)]
public TestPackageConfig Config { get; set; }
C++
[XmlElementAttribute(L"testPackageConfig", IsNullable = False)]
public property TestPackageConfig Config sealed {
TestPackageConfig get();
void set(TestPackageConfig value);
}
J#
/** @attribute XmlElementAttribute("testPackageConfig", IsNullable = False) */
/** property */
public TestPackageConfig get_Config();

/** property */
public void set_Config(TestPackageConfig value);
JScript
public function get Config() : TestPackageConfig

public function set Config(value : TestPackageConfig);

See Also

TestPackageData Class
Gallio.Model.Serialization Namespace


TestParameterData Class

TestParameterData Class
See Also Example Members
[image]

Describes a test parameter in a portable manner for serialization. This class cannot be inherited.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestParameterData
Inherits TestComponentData
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestParameterData : TestComponentData
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestParameterData sealed : TestComponentData
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestParameterData extends TestComponentData
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestParameterData extends TestComponentData

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.TestComponentData
Gallio.Model.Serialization.TestParameterData

See Also

TestParameterData Members
Gallio.Model.Serialization Namespace
ITestParameter


TestParameterData Members

TestParameterData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes a test parameter in a portable manner for serialization. This class cannot be inherited.

The following tables list the members exposed by TestParameterData.

Public Constructors

Name | Description
TestParameterData | Overloaded.
Top

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestParameterData | Overloaded.
Top

See Also

TestParameterData Class
Gallio.Model.Serialization Namespace
ITestParameter


TestParameterData Constructor

TestParameterData Constructor

Overload List

 | Name | Description
Public method | TestParameterData (ITestParameter) | Copies the contents of a test parameter.
Public method | TestParameterData (String, String) | Creates a parameter data object.

See Also

TestParameterData Class
Gallio.Model.Serialization Namespace


TestParameterData Constructor (ITestParameter)

TestParameterData Constructor (ITestParameter)
See Also Example
[image]

Copies the contents of a test parameter.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITestParameter _
)
C#
public TestParameterData(
ITestParameter source
)
C++
public:
TestParameterData(
ITestParameter source
) sealed
J#
public TestParameterData(
ITestParameter source
)
JScript
public function TestParameterData(
source : ITestParameter
)

Parameters

source
The source test parameter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestParameterData Class
Gallio.Model.Serialization Namespace
TestParameterData Constructor Overload List


TestParameterData Constructor (String, String)

TestParameterData Constructor (String, String)
See Also Example
[image]

Creates a parameter data object.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As String, _
ByVal name As String _
)
C#
public TestParameterData(
string id,
string name
)
C++
public:
TestParameterData(
String id,
String name
) sealed
J#
public TestParameterData(
string id,
string name
)
JScript
public function TestParameterData(
id : String,
name : String
)

Parameters

id
The component id
name
The component name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if id or name is null

See Also

TestParameterData Class
Gallio.Model.Serialization Namespace
TestParameterData Constructor Overload List


TestStepData Class

TestStepData Class
See Also Example Members
[image]

Describes a test step in a portable manner for serialization. This class cannot be inherited.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("testStep", Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestStepData
Inherits TestComponentData
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("testStep", Namespace = "http://www.gallio.org/")]
public sealed class TestStepData : TestComponentData
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"testStep", Namespace = L"http://www.gallio.org/")]
ref class TestStepData sealed : TestComponentData
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("testStep", Namespace = "http://www.gallio.org/") */
public final class TestStepData extends TestComponentData
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("testStep", Namespace = "http://www.gallio.org/")
final class TestStepData extends TestComponentData

Inheritance Hierarchy

System.Object
Gallio.Model.Serialization.TestComponentData
Gallio.Model.Serialization.TestStepData

See Also

TestStepData Members
Gallio.Model.Serialization Namespace
ITestStep


TestStepData Members

TestStepData Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Describes a test step in a portable manner for serialization. This class cannot be inherited.

The following tables list the members exposed by TestStepData.

Public Constructors

Name | Description
TestStepData | Overloaded.
Top

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | FullName | Gets or sets the full name of the step.
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | IsDynamic | Gets or sets whether the test step is dynamic.
Public property | IsPrimary | Gets or sets whether the test step is primary.
Public property | IsTestCase | Gets or sets whether the test step represents a test case.
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Public property | ParentId | Gets or sets the id of the parent step.
Public property | TestId | Gets or sets the id of the test to which the step belongs.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TestStepData | Overloaded.
Top

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
ITestStep


TestStepData Constructor

TestStepData Constructor

Overload List

 | Name | Description
Public method | TestStepData (ITestStep) | Copies the contents of a test step.
Public method | TestStepData (String, String, String, String) | Creates a step.

See Also

TestStepData Class
Gallio.Model.Serialization Namespace


TestStepData Constructor (ITestStep)

TestStepData Constructor (ITestStep)
See Also Example
[image]

Copies the contents of a test step.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As ITestStep _
)
C#
public TestStepData(
ITestStep source
)
C++
public:
TestStepData(
ITestStep source
) sealed
J#
public TestStepData(
ITestStep source
)
JScript
public function TestStepData(
source : ITestStep
)

Parameters

source
The source test step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if source is null

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
TestStepData Constructor Overload List


TestStepData Constructor (String, String, String, String)

TestStepData Constructor (String, String, String, String)
See Also Example
[image]

Creates a step.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As String, _
ByVal name As String, _
ByVal fullName As String, _
ByVal testId As String _
)
C#
public TestStepData(
string id,
string name,
string fullName,
string testId
)
C++
public:
TestStepData(
String id,
String name,
String fullName,
String testId
) sealed
J#
public TestStepData(
string id,
string name,
string fullName,
string testId
)
JScript
public function TestStepData(
id : String,
name : String,
fullName : String,
testId : String
)

Parameters

id
The step id
name
The step name
fullName
The full name of the step
testId
The test id

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if id, name, fullName or testId is null

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
TestStepData Constructor Overload List


Properties

TestStepData Properties
[image]

Public Properties

 | Name | Description
Public property | CodeLocation | Gets or sets the code location or Unknown if not available. (inherited from TestComponentData)
Public property | CodeReference | Gets or sets the code reference or Unknown if not available. (inherited from TestComponentData)
Public property | FullName | Gets or sets the full name of the step.
Public property | Id | Gets or sets the test component id. (non-null) (inherited from TestComponentData)
Public property | IsDynamic | Gets or sets whether the test step is dynamic.
Public property | IsPrimary | Gets or sets whether the test step is primary.
Public property | IsTestCase | Gets or sets whether the test step represents a test case.
Public property | Metadata | Gets or sets the metadata map. (non-null) (inherited from TestComponentData)
Public property | Name | Gets or sets the test component name. (non-null) (inherited from TestComponentData)
Public property | ParentId | Gets or sets the id of the parent step.
Public property | TestId | Gets or sets the id of the test to which the step belongs.
Top

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
ITestStep


FullName Property

TestStepData.FullName Property
[image]

Gets or sets the full name of the step.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("fullName")>
Public Property FullName As String
C#
[XmlAttributeAttribute("fullName")]
public string FullName { get; set; }
C++
[XmlAttributeAttribute(L"fullName")]
public property string FullName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("fullName") */
/** property */
public string get_FullName();

/** property */
public void set_FullName(string value);
JScript
public function get FullName() : String

public function set FullName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestStepData Class
Gallio.Model.Serialization Namespace


IsDynamic Property

TestStepData.IsDynamic Property
[image]

Gets or sets whether the test step is dynamic.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("isDynamic")>
Public Property IsDynamic As Boolean
C#
[XmlAttributeAttribute("isDynamic")]
public bool IsDynamic { get; set; }
C++
[XmlAttributeAttribute(L"isDynamic")]
public property bool IsDynamic sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("isDynamic") */
/** property */
public bool get_IsDynamic();

/** property */
public void set_IsDynamic(bool value);
JScript
public function get IsDynamic() : bool

public function set IsDynamic(value : bool);

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
IsDynamic


IsPrimary Property

TestStepData.IsPrimary Property
[image]

Gets or sets whether the test step is primary.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("isPrimary")>
Public Property IsPrimary As Boolean
C#
[XmlAttributeAttribute("isPrimary")]
public bool IsPrimary { get; set; }
C++
[XmlAttributeAttribute(L"isPrimary")]
public property bool IsPrimary sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("isPrimary") */
/** property */
public bool get_IsPrimary();

/** property */
public void set_IsPrimary(bool value);
JScript
public function get IsPrimary() : bool

public function set IsPrimary(value : bool);

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
IsPrimary


IsTestCase Property

TestStepData.IsTestCase Property
[image]

Gets or sets whether the test step represents a test case.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("isTestCase")>
Public Property IsTestCase As Boolean
C#
[XmlAttributeAttribute("isTestCase")]
public bool IsTestCase { get; set; }
C++
[XmlAttributeAttribute(L"isTestCase")]
public property bool IsTestCase sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("isTestCase") */
/** property */
public bool get_IsTestCase();

/** property */
public void set_IsTestCase(bool value);
JScript
public function get IsTestCase() : bool

public function set IsTestCase(value : bool);

See Also

TestStepData Class
Gallio.Model.Serialization Namespace
IsTestCase


ParentId Property

TestStepData.ParentId Property
[image]

Gets or sets the id of the parent step.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("parentId")>
Public Property ParentId As String
C#
[XmlAttributeAttribute("parentId")]
public string ParentId { get; set; }
C++
[XmlAttributeAttribute(L"parentId")]
public property string ParentId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("parentId") */
/** property */
public string get_ParentId();

/** property */
public void set_ParentId(string value);
JScript
public function get ParentId() : String

public function set ParentId(value : String);

See Also

TestStepData Class
Gallio.Model.Serialization Namespace


TestId Property

TestStepData.TestId Property
[image]

Gets or sets the id of the test to which the step belongs.

Namespace: Gallio.Model.Serialization
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("testId")>
Public Property TestId As String
C#
[XmlAttributeAttribute("testId")]
public string TestId { get; set; }
C++
[XmlAttributeAttribute(L"testId")]
public property string TestId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("testId") */
/** property */
public string get_TestId();

/** property */
public void set_TestId(string value);
JScript
public function get TestId() : String

public function set TestId(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestStepData Class
Gallio.Model.Serialization Namespace


Gallio.MSBuildTasks

Gallio.MSBuildTasks Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | Gallio | An MSBuild task that provides support for running Gallio tests.


Gallio Class

Gallio Class
See Also Example Members
[image]

An MSBuild task that provides support for running Gallio tests.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Gallio
Inherits Task
C#
public class Gallio : Task
C++
ref class Gallio : Task
J#
public class Gallio extends Task
JScript
public class Gallio extends Task

Example

The following code is an example build file that shows how to load the task, specify the test assemblies and set some of the task's properties:

Copy Code
            <Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
                <!-- This is needed by MSBuild to locate the Gallio task -->
                <UsingTask AssemblyFile="[Path-to-assembly]\Gallio.MSBuildTasks.dll" TaskName="Gallio" />
                <!-- Specify the tests assemblies -->
                <ItemGroup>
                    <TestAssemblies Include="[Path-to-test-assembly1]/TestAssembly1.dll" />
                    <TestAssemblies Include="[Path-to-test-assembly2]/TestAssembly2.dll" />
                </ItemGroup>
                <Target Name="RunTests">
                    <Gallio IgnoreFailures="true" Filter="Type=SomeFixture" Assemblies="@(TestAssemblies)">
                        <!-- This tells MSBuild to store the output value of the task's ExitCode property
                             into the project's ExitCode property -->
                        <Output TaskParameter="ExitCode" PropertyName="ExitCode"/>
                    </Gallio>
                    <Error Text="Tests execution failed" Condition="'$(ExitCode)' != 0" />
                </Target>
            </Project>

Remarks

In order for MSBuild to find this task, the Gallio.MSBuildTasks.dll has to be loaded with the UsingTask directive:

Copy Code
            <UsingTask AssemblyFile="[Path-to-assembly]\Gallio.MSBuildTasks.dll" TaskName="Gallio" />
The AssemblyFile attribute must be set to the path where the Gallio.MSBuildTasks.dll assembly resides, and the TaskName attribute must be set to "Gallio", otherwise MSBuild won't load the task.

Inheritance Hierarchy

System.Object
Microsoft.Build.Utilities.Task
Gallio.MSBuildTasks.Gallio

See Also

Gallio Members
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Gallio Members

Gallio Members
See Also Example Constructors Properties Methods
[image]

An MSBuild task that provides support for running Gallio tests.

The following tables list the members exposed by Gallio.

Public Constructors

 | Name | Description
Public method | Gallio | Initializes a new instance of the Gallio class.
Top

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Public property | Assemblies | The list of relative or absolute paths of test assembly files to execute. This is required.
Public property | AssertCount | Gets the number of assertions evaluated.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property Debug

Attaches the debugger to the test process when set to true.

The default is false.

Public property | DoNotRun | Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.
Public property | Duration | Gets the duration of the tests execution in seconds.
Public property | EchoResults | Sets whether to echo results to the screen as tests finish. If this option is set to true, the default, test results are echoed to the console in varying detail depending on the current verbosity level. Otherwise only final summary statistics are displayed.
Public property | ExitCode | Gets the exit code of the tests execution.
Public property | FailedCount | Gets the total number of test cases that were run and failed.
Public property | Filter | Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.
Public property | HintDirectories | The list of directories used for loading assemblies and other dependent resources.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IgnoreAnnotations | Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.
Public property | IgnoreFailures | Sets whether test failures will be ignored and allow the build to proceed. When set to false, test failures will cause the build to fail.
Public property | InconclusiveCount | Gets the total number of test cases that ran and were inconclusive.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | PassedCount | Gets the total number of test cases that were run and passed.
Public property | PluginDirectories | Additional Gallio plugin directories to search recursively.
Public property | ReportDirectory | Sets the name of the directory where the reports will be put.
Public property | ReportFormatterProperties | Specifies option property key/value pairs for the report formatter.
Public property | ReportNameFormat | Sets the format string to use to generate the reports filenames.
Public property | ReportTypes | A list of the types of reports to generate, separated by semicolons.
Public property | RunCount | Gets the total number of test cases that were run.
Public property RunnerExtensions

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Public property | RunnerProperties | Specifies option property key/value pairs for the test runner.
Public property | RunnerType | Sets the type of test runner to use.
Public property | RunTimeLimit | Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.
Public property ShadowCopy

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Public property | ShowReports | Sets whether to show generated reports in a window using the default system application registered to the report file type.
Public property | SkippedCount | Gets the total number of test cases that did not run because they were skipped.
Public property | StepCount | Gets the total number of test steps run.
Public property | TestCount | Gets the total number of test cases run.
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overridden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Gallio Constructor

Gallio Constructor
[image]

Initializes a new instance of the Gallio class.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Gallio()
C++
public:
Gallio() sealed
J#
public Gallio()
JScript
public function Gallio()

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Properties

Gallio Properties
[image]

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Public property | Assemblies | The list of relative or absolute paths of test assembly files to execute. This is required.
Public property | AssertCount | Gets the number of assertions evaluated.
Public property | BuildEngine | Gets or sets the instance of the IBuildEngine object used by the task. (inherited from Task)
Public property Debug

Attaches the debugger to the test process when set to true.

The default is false.

Public property | DoNotRun | Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.
Public property | Duration | Gets the duration of the tests execution in seconds.
Public property | EchoResults | Sets whether to echo results to the screen as tests finish. If this option is set to true, the default, test results are echoed to the console in varying detail depending on the current verbosity level. Otherwise only final summary statistics are displayed.
Public property | ExitCode | Gets the exit code of the tests execution.
Public property | FailedCount | Gets the total number of test cases that were run and failed.
Public property | Filter | Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.
Public property | HintDirectories | The list of directories used for loading assemblies and other dependent resources.
Public property | HostObject | Gets or sets the host object associated with the task. (inherited from Task)
Public property | IgnoreAnnotations | Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.
Public property | IgnoreFailures | Sets whether test failures will be ignored and allow the build to proceed. When set to false, test failures will cause the build to fail.
Public property | InconclusiveCount | Gets the total number of test cases that ran and were inconclusive.
Public property | Log | Gets an instance of a TaskLoggingHelper class containing task logging methods. (inherited from Task)
Public property | PassedCount | Gets the total number of test cases that were run and passed.
Public property | PluginDirectories | Additional Gallio plugin directories to search recursively.
Public property | ReportDirectory | Sets the name of the directory where the reports will be put.
Public property | ReportFormatterProperties | Specifies option property key/value pairs for the report formatter.
Public property | ReportNameFormat | Sets the format string to use to generate the reports filenames.
Public property | ReportTypes | A list of the types of reports to generate, separated by semicolons.
Public property | RunCount | Gets the total number of test cases that were run.
Public property RunnerExtensions

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Public property | RunnerProperties | Specifies option property key/value pairs for the test runner.
Public property | RunnerType | Sets the type of test runner to use.
Public property | RunTimeLimit | Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.
Public property ShadowCopy

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Public property | ShowReports | Sets whether to show generated reports in a window using the default system application registered to the report file type.
Public property | SkippedCount | Gets the total number of test cases that did not run because they were skipped.
Public property | StepCount | Gets the total number of test steps run.
Public property | TestCount | Gets the total number of test cases run.
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Top

Protected Properties

 | Name | Description
Family property | HelpKeywordPrefix | Gets or sets the prefix used to compose Help keywords from resource names. (inherited from Task)
Family property | TaskResources | Gets or sets the culture-specific resources associated with the task. (inherited from Task)
Top

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ApplicationBaseDirectory Property

Gallio.ApplicationBaseDirectory Property
[image]

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ApplicationBaseDirectory As ITaskItem
C#
public ITaskItem ApplicationBaseDirectory { set; }
C++
public property ITaskItem ApplicationBaseDirectory sealed {
void set(ITaskItem value);
}
J#
/** property */
public void set_ApplicationBaseDirectory(ITaskItem value);
JScript
public function set ApplicationBaseDirectory(value : ITaskItem);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Assemblies Property

Gallio.Assemblies Property
[image]

The list of relative or absolute paths of test assembly files to execute. This is required.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute>
Public WriteOnly Property Assemblies As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Assemblies { set; }
C++
[RequiredAttribute]
public property ITaskItem[] Assemblies sealed {
void set(array<ITaskItem>^ value);
}
J#
/** @attribute RequiredAttribute() */
/** property */
public void set_Assemblies(ITaskItem[] value);
JScript
public function set Assemblies(value : ITaskItem[]);

Example

The following example shows how to specify the test assemblies (for a more complete example please see the Gallio task documentation):

Copy Code
            <ItemGroup>
                <TestAssemblies Include="[Path-to-test-assembly1]/TestAssembly1.dll" />
                <TestAssemblies Include="[Path-to-test-assembly2]/TestAssembly2.dll" />
            </ItemGroup>
            <Target Name="MyTarget">
                <Gallio Assemblies="@(TestAssemblies)" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


AssertCount Property

Gallio.AssertCount Property
[image]

Gets the number of assertions evaluated.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property AssertCount As Integer
C#
[OutputAttribute]
public int AssertCount { get; }
C++
[OutputAttribute]
public property int AssertCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_AssertCount();
JScript
public function get AssertCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's AssertionCount output property will
                      be made available as a property called AssertionCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="AssertionCount" PropertyName="AssertionCount" />
            </Gallio>
            <!-- After execution the number of assertions can be retrieved like this: -->
            <Message Text="$(AssertionCount) assertions were evaluated." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Debug Property

Gallio.Debug Property
[image]

Attaches the debugger to the test process when set to true.

The default is false.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Debug As Boolean
C#
public bool Debug { set; }
C++
public property bool Debug sealed {
void set(bool value);
}
J#
/** property */
public void set_Debug(bool value);
JScript
public function set Debug(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


DoNotRun Property

Gallio.DoNotRun Property
[image]

Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DoNotRun As Boolean
C#
public bool DoNotRun { set; }
C++
public property bool DoNotRun sealed {
void set(bool value);
}
J#
/** property */
public void set_DoNotRun(bool value);
JScript
public function set DoNotRun(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Duration Property

Gallio.Duration Property
[image]

Gets the duration of the tests execution in seconds.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property Duration As Double
C#
[OutputAttribute]
public double Duration { get; }
C++
[OutputAttribute]
public property double Duration sealed {
double get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public double get_Duration();
JScript
public function get Duration() : double

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's Duration output property will
                      be made available as a property called Duration in the project
                      after the tests have been run: -->
                <Output TaskParameter="Duration" PropertyName="Duration" />
            </Gallio>
            <!-- After execution the duration can be retrieved like this: -->
            <Message Text="The tests took $(Duration)s to execute." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


EchoResults Property

Gallio.EchoResults Property
[image]

Sets whether to echo results to the screen as tests finish. If this option is set to true, the default, test results are echoed to the console in varying detail depending on the current verbosity level. Otherwise only final summary statistics are displayed.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property EchoResults As Boolean
C#
public bool EchoResults { set; }
C++
public property bool EchoResults sealed {
void set(bool value);
}
J#
/** property */
public void set_EchoResults(bool value);
JScript
public function set EchoResults(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ExitCode Property

Gallio.ExitCode Property
[image]

Gets the exit code of the tests execution.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property ExitCode As Integer
C#
[OutputAttribute]
public int ExitCode { get; }
C++
[OutputAttribute]
public property int ExitCode sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_ExitCode();
JScript
public function get ExitCode() : int

Remarks

This property is only meaningful when the IgnoreFailures property is set to true.

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's ExitCode output property will
                      be made available as a property called ExitCode in the project
                      after the tests have been run: -->
                <Output TaskParameter="ExitCode" PropertyName="ExitCode"/>
            </Gallio>
            <!-- After the exit code be retrieved and used like this: -->
            <Error Text="The tests execution failed" Condition="'$(ExitCode)' != 0" />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


FailedCount Property

Gallio.FailedCount Property
[image]

Gets the total number of test cases that were run and failed.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property FailedCount As Integer
C#
[OutputAttribute]
public int FailedCount { get; }
C++
[OutputAttribute]
public property int FailedCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_FailedCount();
JScript
public function get FailedCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's FailedCount output property will
                      be made available as a property called FailedCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="FailedCount" PropertyName="FailedCount" />
            </Gallio>
            <!-- After execution the number of failed tests can be retrieved like this: -->
            <Message Text="$(FailedCount) tests passed." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Filter Property

Gallio.Filter Property
[image]

Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Filter As String
C#
public string Filter { set; }
C++
public property string Filter sealed {
void set(String value);
}
J#
/** property */
public void set_Filter(string value);
JScript
public function set Filter(value : String);

Remarks

The filter grammar is defined as follows:

Copy Code
     INCLUDE          ::= "include"              # Not case-sensitive
     EXCLUDE          ::= "exclude"              # Not case-sensitive

     OR               ::= "or"                   # Not case-sensitive
     AND              ::= "and"                  # Not case-sensitive
     NOT              ::= "not"                  # Not case-sensitive

     <unquotedWord>   ::= [^:,*()/\"']+

     <quotedWord>     ::= '"' .* '"'             # String delimited by double quotation marks
                      | "'" .* "'"               # String delimited by single quotation marks

     <word>           ::= <unquotedWord>
                      | <quotedWord>

     <regexWord>      ::= "/" .* "/"             # Regular expression
                      | "/" .* "/i"              # Case-insensitive regular expression

     <key>            ::= <word>

     <value>          ::= <word>                 # Value specified by exact string
                      | <regexWord>              # Value specified by regular expression

     <matchSequence>  ::= <value> (',' <value>)* # One or more comma-separated values

     <filterExpr>     ::= "*"                    # "Any"
                      | <key> ":" matchSeq>
                      | <filterExpr> OR filterExpr>   # Combine filter expressions with OR
                      | <filterExpr> AND filterExpr>  # Combine filter expressions with AND
                      | NOT <filterExpr>         # Negate filter expression
                      | "(" <filterExpr> ")"     # Grouping filter expression

     <filterRule>     ::= <filterExpr>           # Inclusion rule (default case)
                      | INCLUDE <filterExpr>     # Inclusion rule
                      | EXCLUDE <filterExpr>     # Exclusion rule

     <filterSet>      ::= <filterRule>           # Filter set consists of at least one filter rule.
                      | <filterRule> <filterSet> # But may be a sequence of rules.

  • By default this property takes the value "*", which means the "Any" filter will be applied.
  • The operator precedence is, from highest to lowest: NOT, AND, and OR. All these operators are left-associative.
  • The commas used to separate the values are interpreted as OR operators, so "Type:Fixture1,Fixture2" is equivalent to "Type:Fixture1 or Type:Fixture2".
  • White-space is ignored outside quoted strings, so "Type:Fixture1|Type:Fixture2" is equivalent to "Type : Fixture1 | Type : Fixture2".
  • Commas, colons, slashes, backslashes and quotation marks can be escaped with a backslash. For example, \' will be interpreted as '. Using a single backslash in front of any other character is invalid.
  • Currently the following filter keys are recognized:
    • Id: Filter by id.
    • Name: Filter by name.
    • Assembly: Filter by assembly name.
    • Namespace: Filter by namespace name.
    • Type: Filter by type name, including inherited types.
    • ExactType: Filter by type name, excluding inherited types.
    • Member: Filter by member name.
    • *: All other names are assumed to correspond to metadata keys. See MetadataKeys for standard metadata keys. Common keys are: AuthorName, Category, Description, Importance, TestsOn.

Example

Assuming the following fixtures have been defined:

Copy Code
      [TestFixture]
      [Category("UnitTest")]
      [Author("AlbertEinstein")]
      public class Fixture1
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

      [TestFixture]
      [Category("IntegrationTest")]
      public class Fixture2
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

The following filters could be applied:

  • Type: Fixture1 - All the tests within Fixture1 will be run.
  • Member: Test1 - Only Fixture1.Test1 and Fixture2.Test1 will be run.
  • Type: Fixture1, Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1 or Type:Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1, Fixture2 and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • Type:/Fixture*/ and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • AuthorName:AlbertEinstein - All the tests within Fixture1 will be run because its author attribute is set to "AlbertEinstein".
  • Category: IntegrationTest - All the tests within Fixture2 will be run because its category attribute is set to "IntegrationTest".
  • ("Type": 'Fixture1' and "Member":/Test*/) or (Type : Fixture2 and Member: /Test*/) - All the tests will be run. This example also shows that you can enclose key and values with quotation marks, and group expressions with parentheses.
  • exclude AuthorName: AlbertEinstein - All the tests within Fixture2 will be run because its author attribute is not set to "AlbertEinstein".
  • exclude Type: Fixture2 include Member: Test2 - Only Fixture1.Test2 will be run because Fixture2 was excluded from consideration before the inclusion rule was applied.

See Also

Gallio Class
Gallio.MSBuildTasks Namespace
MetadataKeys

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


HintDirectories Property

Gallio.HintDirectories Property
[image]

The list of directories used for loading assemblies and other dependent resources.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property HintDirectories As ITaskItem()
C#
public ITaskItem[] HintDirectories { set; }
C++
public property ITaskItem[] HintDirectories sealed {
void set(array<ITaskItem>^ value);
}
J#
/** property */
public void set_HintDirectories(ITaskItem[] value);
JScript
public function set HintDirectories(value : ITaskItem[]);

Example

The following example shows how to specify the hint directories:

Copy Code
            <ItemGroup>
                <HintDirectories Include="[Path-to-test-hint-directory-1]/" />
                <HintDirectories Include="[Path-to-test-hint-directory-2]/" />
            </ItemGroup>
            <Target Name="MyTarget">
                <Gallio HintDirectories="@(HintDirectories)" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


IgnoreAnnotations Property

Gallio.IgnoreAnnotations Property
[image]

Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property IgnoreAnnotations As Boolean
C#
public bool IgnoreAnnotations { set; }
C++
public property bool IgnoreAnnotations sealed {
void set(bool value);
}
J#
/** property */
public void set_IgnoreAnnotations(bool value);
JScript
public function set IgnoreAnnotations(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


IgnoreFailures Property

Gallio.IgnoreFailures Property
[image]

Sets whether test failures will be ignored and allow the build to proceed. When set to false, test failures will cause the build to fail.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property IgnoreFailures As Boolean
C#
public bool IgnoreFailures { set; }
C++
public property bool IgnoreFailures sealed {
void set(bool value);
}
J#
/** property */
public void set_IgnoreFailures(bool value);
JScript
public function set IgnoreFailures(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


InconclusiveCount Property

Gallio.InconclusiveCount Property
[image]

Gets the total number of test cases that ran and were inconclusive.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property InconclusiveCount As Integer
C#
[OutputAttribute]
public int InconclusiveCount { get; }
C++
[OutputAttribute]
public property int InconclusiveCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_InconclusiveCount();
JScript
public function get InconclusiveCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's InconclusiveCount output property will
                      be made available as a property called InconclusiveCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="InconclusiveCount" PropertyName="InconclusiveCount" />
            </Gallio>
            <!-- After execution the number of inconclusive tests can be retrieved like this: -->
            <Message Text="$(InconclusiveCount) tests were inconclusive." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


PassedCount Property

Gallio.PassedCount Property
[image]

Gets the total number of test cases that were run and passed.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property PassedCount As Integer
C#
[OutputAttribute]
public int PassedCount { get; }
C++
[OutputAttribute]
public property int PassedCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_PassedCount();
JScript
public function get PassedCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's PassedCount output property will
                      be made available as a property called PassedCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="PassedCount" PropertyName="PassedCount" />
            </Gallio>
            <!-- After execution the number of passed tests can be retrieved like this: -->
            <Message Text="$(PassedCount) tests passed." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


PluginDirectories Property

Gallio.PluginDirectories Property
[image]

Additional Gallio plugin directories to search recursively.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property PluginDirectories As ITaskItem()
C#
public ITaskItem[] PluginDirectories { set; }
C++
public property ITaskItem[] PluginDirectories sealed {
void set(array<ITaskItem>^ value);
}
J#
/** property */
public void set_PluginDirectories(ITaskItem[] value);
JScript
public function set PluginDirectories(value : ITaskItem[]);

Example

The following example shows how to specify the plugins directories:

Copy Code
            <ItemGroup>
                <PluginDirectories Include="[Path-to-test-plugin-directory-1]/" />
                <PluginDirectories Include="[Path-to-test-plugin-directory-2]/" />
            </ItemGroup>
            <Target Name="MyTarget">
                <Gallio PluginDirectories="@(PluginDirectories)" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ReportDirectory Property

Gallio.ReportDirectory Property
[image]

Sets the name of the directory where the reports will be put.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ReportDirectory As ITaskItem
C#
public ITaskItem ReportDirectory { set; }
C++
public property ITaskItem ReportDirectory sealed {
void set(ITaskItem value);
}
J#
/** property */
public void set_ReportDirectory(ITaskItem value);
JScript
public function set ReportDirectory(value : ITaskItem);

Remarks

The directory will be created if it doesn't exist. Existing files will be overwrited.

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ReportFormatterProperties Property

Gallio.ReportFormatterProperties Property
[image]

Specifies option property key/value pairs for the report formatter.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ReportFormatterProperties As String()
C#
public string[] ReportFormatterProperties { set; }
C++
public property string[] ReportFormatterProperties sealed {
void set(array<String>^ value);
}
J#
/** property */
public void set_ReportFormatterProperties(string[] value);
JScript
public function set ReportFormatterProperties(value : String[]);

Example

The following example changes the default attachment content disposition for the reports.

Copy Code
            <Target Name="MyTarget">
                <Gallio Assemblies="MyAssembly" RunnerExtensions="AttachmentContentDisposition=Absent" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ReportNameFormat Property

Gallio.ReportNameFormat Property
[image]

Sets the format string to use to generate the reports filenames.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ReportNameFormat As String
C#
public string ReportNameFormat { set; }
C++
public property string ReportNameFormat sealed {
void set(String value);
}
J#
/** property */
public void set_ReportNameFormat(string value);
JScript
public function set ReportNameFormat(value : String);

Remarks

Any occurence of {0} will be replaced by the date, and any occurrence of {1} by the time. The default format string is test-report-{0}-{1}.

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ReportTypes Property

Gallio.ReportTypes Property
[image]

A list of the types of reports to generate, separated by semicolons.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ReportTypes As String()
C#
public string[] ReportTypes { set; }
C++
public property string[] ReportTypes sealed {
void set(array<String>^ value);
}
J#
/** property */
public void set_ReportTypes(string[] value);
JScript
public function set ReportTypes(value : String[]);

Remarks

  • The types supported "out of the box" are: Html, Html-Inline, Text, XHtml, XHtml-Inline, Xml, and Xml-Inline, but more types could be available as plugins.
  • The report types are not case sensitive.

Example

In the following example reports will be generated in both HTML and XML format:

Copy Code
            <Target Name="MyTarget">
                <Gallio ReportTypes="html;xml" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


RunCount Property

Gallio.RunCount Property
[image]

Gets the total number of test cases that were run.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property RunCount As Integer
C#
[OutputAttribute]
public int RunCount { get; }
C++
[OutputAttribute]
public property int RunCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_RunCount();
JScript
public function get RunCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's RunCount output property will
                      be made available as a property called RunCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="RunCount" PropertyName="RunCount" />
            </Gallio>
            <!-- After execution the number of tests run can be retrieved like this: -->
            <Message Text="$(RunCount) tests were run." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


RunnerExtensions Property

Gallio.RunnerExtensions Property
[image]

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property RunnerExtensions As String()
C#
public string[] RunnerExtensions { set; }
C++
public property string[] RunnerExtensions sealed {
void set(array<String>^ value);
}
J#
/** property */
public void set_RunnerExtensions(string[] value);
JScript
public function set RunnerExtensions(value : String[]);

Remarks

Since semicolons are used to delimit multiple property values in MSBuild, it may be necessary to escape semicolons that appear as part of test runner extension specifications to ensure MSBuild does not misinterpret them. An escaped semicolon may be written as "%3B" in the build file.

Example

The following example runs tests using a custom logger extension:

Copy Code
            <Target Name="MyTarget">
                <Gallio Assemblies="MyAssembly" RunnerExtensions="FancyLogger,MyExtensions.dll%3BColorOutput,FancyIndenting" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


RunnerProperties Property

Gallio.RunnerProperties Property
[image]

Specifies option property key/value pairs for the test runner.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property RunnerProperties As String()
C#
public string[] RunnerProperties { set; }
C++
public property string[] RunnerProperties sealed {
void set(array<String>^ value);
}
J#
/** property */
public void set_RunnerProperties(string[] value);
JScript
public function set RunnerProperties(value : String[]);

Example

The following example specifies some extra NCover arguments.

Copy Code
            <gallio>
            <Target Name="MyTarget">
                <Gallio Assemblies="MyAssembly" RunnerExtensions="NCoverArguments='//eas Gallio'" />
            </Target>

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


RunnerType Property

Gallio.RunnerType Property
[image]

Sets the type of test runner to use.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property RunnerType As String
C#
public string RunnerType { set; }
C++
public property string RunnerType sealed {
void set(String value);
}
J#
/** property */
public void set_RunnerType(string value);
JScript
public function set RunnerType(value : String);

Remarks

  • The types supported "out of the box" are: Local, IsolatedAppDomain and IsolatedProcess (default), but more types could be available as plugins.
  • The runner types are not case sensitive.

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


RunTimeLimit Property

Gallio.RunTimeLimit Property
[image]

Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property RunTimeLimit As Double
C#
public double RunTimeLimit { set; }
C++
public property double RunTimeLimit sealed {
void set(double value);
}
J#
/** property */
public void set_RunTimeLimit(double value);
JScript
public function set RunTimeLimit(value : double);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ShadowCopy Property

Gallio.ShadowCopy Property
[image]

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ShadowCopy As Boolean
C#
public bool ShadowCopy { set; }
C++
public property bool ShadowCopy sealed {
void set(bool value);
}
J#
/** property */
public void set_ShadowCopy(bool value);
JScript
public function set ShadowCopy(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


ShowReports Property

Gallio.ShowReports Property
[image]

Sets whether to show generated reports in a window using the default system application registered to the report file type.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property ShowReports As Boolean
C#
public bool ShowReports { set; }
C++
public property bool ShowReports sealed {
void set(bool value);
}
J#
/** property */
public void set_ShowReports(bool value);
JScript
public function set ShowReports(value : bool);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


SkippedCount Property

Gallio.SkippedCount Property
[image]

Gets the total number of test cases that did not run because they were skipped.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property SkippedCount As Integer
C#
[OutputAttribute]
public int SkippedCount { get; }
C++
[OutputAttribute]
public property int SkippedCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_SkippedCount();
JScript
public function get SkippedCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's SkippedCount output property will
                      be made available as a property called SkippedCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="SkippedCount" PropertyName="SkippedCount" />
            </Gallio>
            <!-- After execution the number of skipped tests can be retrieved like this: -->
            <Message Text="$(SkippedCount) tests were skipped." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


StepCount Property

Gallio.StepCount Property
[image]

Gets the total number of test steps run.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property StepCount As Integer
C#
[OutputAttribute]
public int StepCount { get; }
C++
[OutputAttribute]
public property int StepCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_StepCount();
JScript
public function get StepCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's StepCount output property will
                      be made available as a property called StepCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="StepCount" PropertyName="StepCount" />
            </Gallio>
            <!-- After execution the number of test steps run can be retrieved like this: -->
            <Message Text="$(StepCount) test steps were run." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


TestCount Property

Gallio.TestCount Property
[image]

Gets the total number of test cases run.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute>
Public ReadOnly Property TestCount As Integer
C#
[OutputAttribute]
public int TestCount { get; }
C++
[OutputAttribute]
public property int TestCount sealed {
int get();
}
J#
/** @attribute OutputAttribute() */
/** property */
public int get_TestCount();
JScript
public function get TestCount() : int

Example

To use this property, you need to include an Output tag within the Gallio tag to specify a name to reference it:

Copy Code
            <Gallio>
                 <!-- This tells MSBuild that the task's TestCount output property will
                      be made available as a property called TestCount in the project
                      after the tests have been run: -->
                <Output TaskParameter="TestCount" PropertyName="TestCount" />
            </Gallio>
            <!-- After execution the number of test cases run can be retrieved like this: -->
            <Message Text="$(TestCount) test cases were run." />

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


WorkingDirectory Property

Gallio.WorkingDirectory Property
[image]

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property WorkingDirectory As ITaskItem
C#
public ITaskItem WorkingDirectory { set; }
C++
public property ITaskItem WorkingDirectory sealed {
void set(ITaskItem value);
}
J#
/** property */
public void set_WorkingDirectory(ITaskItem value);
JScript
public function set WorkingDirectory(value : ITaskItem);

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Methods

Gallio Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Overridden. When overridden in a derived class, executes the task.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Execute Method

Gallio.Execute Method
[image]

When overridden in a derived class, executes the task.

Namespace: Gallio.MSBuildTasks
Assembly: Gallio.MSBuildTasks (in Gallio.MSBuildTasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute() As Boolean _
Implements ITask.Execute
C#
public override bool Execute()
C++
public:
virtual bool Execute() override
J#
public override bool Execute()
JScript
public override function Execute() : bool

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask.Execute

See Also

Gallio Class
Gallio.MSBuildTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.MSBuildTasks [3.0.6.0]


Gallio.NAntTasks

Gallio.NAntTasks Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | GallioTask | A NAnt task that provides support for running Gallio tests.


GallioTask Class

GallioTask Class
See Also Example Members
[image]

A NAnt task that provides support for running Gallio tests.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskNameAttribute("gallio")>
Public Class GallioTask
Inherits Task
C#
[TaskNameAttribute("gallio")]
public class GallioTask : Task
C++
[TaskNameAttribute(L"gallio")]
ref class GallioTask : Task
J#
/** @attribute TaskNameAttribute("gallio") */
public class GallioTask extends Task
JScript
public
TaskNameAttribute("gallio")
class GallioTask extends Task

Example

The following code is an example build file that shows how to load the task, specify the test assemblies and set some of the task's properties:

Copy Code
                <?xml version="1.0" ?>
                <project name="TestProject" default="RunTests">
                <!-- This is needed by NAnt to locate the Gallio task -->
                <loadtasks assembly="[pathtoassembly]\Gallio.NAntTasks.dll" />
                <target name="RunTests">
                 <gallio result-property="ExitCode" failonerror="false" filter="Type=SomeFixture" >
                  <assemblies>
                    <!-- Specify the tests assemblies -->
                    <include name="[Path-to-test-assembly1]/TestAssembly1.dll" />
                    <include name="[Path-to-test-assembly2]/TestAssembly2.dll" />
                  </assemblies>
                 </gallio>
                 <fail if="${ExitCode != '0'}" >The return code should have been 0!</fail>
                </target>

                </project>

Remarks

In order for NAnt to find this task, either the Gallio.NAntTasks.dll assembly needs to be put in NAnt's bin folder, or it must be loaded with the loadtasks directive:

Copy Code
                <loadtasks assembly="[pathtoassembly]\Gallio.NAntTasks.dll" />

Inheritance Hierarchy

System.Object
NAnt.Core.Element
NAnt.Core.Task
Gallio.NAntTasks.GallioTask

See Also

GallioTask Members
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


GallioTask Members

GallioTask Members
See Also Example Constructors Properties Methods
[image]

A NAnt task that provides support for running Gallio tests.

The following tables list the members exposed by GallioTask.

Public Constructors

 | Name | Description
Public method | GallioTask | Initializes a new instance of the GallioTask class.
Top

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Public property | Assemblies | The list of test assemblies to execute. This is required.
Public property Debug

Attaches the debugger to the test process when set to true.

The default is false.

Public property | DoNotRun | Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.
Public property | EchoResults | Sets whether to echo results to the screen as tests finish. If this option is set to true, the default, test results are echoed to the console in varying detail depending on the current verbosity level. Otherwise only the final summary statistics are displayed.
Public property | FailOnError | Determines if task failure stops the build, or is just reported. The default is true. (inherited from Task)
Public property | Filter | Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.
Public property | HintDirectories | The list of directories used for loading assemblies and other dependent resources.
Public property | IfDefined | If true then the task will be executed; otherwise, skipped. The default is true. (inherited from Task)
Public property | IgnoreAnnotations | Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.
Public property | LogPrefix | The prefix used when sending messages to the log. (inherited from Task)
Public property | Name | The name of the task. (inherited from Task)
Public property | NamespaceManager | Gets or sets the XmlNamespaceManager. (inherited from Element)
Public property | Parent | Gets or sets the parent of the element. (inherited from Element)
Public property | PluginDirectories | Additional Gallio plugin directories to search recursively.
Public property | Project | Gets or sets the Project to which this element belongs. (inherited from Element)
Public property | Properties | Gets the properties local to this Element and the Project. (inherited from Element)
Public property | ReportDirectory | Sets the name of the directory where the reports will be put.
Public property | ReportFormatterProperties | Specifies option property key/value pairs for the report formatter.
Public property | ReportNameFormat | Sets the format string to use to generate the reports filenames.
Public property | ReportTypes | A list of the types of reports to generate, separated by semicolons.
Public property | ResultProperty | Sets the name of a NAnt property in which the exit code of the tests execution should be stored.
Public property RunnerExtensions

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Public property | RunnerProperties | Specifies option property key/value pairs for the test runner.
Public property | RunnerType | Sets the type of test runner to use.
Public property | RunTimeLimit | Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.
Public property ShadowCopy

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Public property | ShowReports | Sets whether to show generated reports in a window using the default system application registered to the report file type.
Public property | StatisticsPropertiesPrefix | Sets the prefix that will be used for the statistics result properties.
Public property | Threshold | Gets or sets the log threshold for this Task. By default the threshold of a task matches the threshold of the project. (inherited from Task)
Public property | UnlessDefined | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false. (inherited from Task)
Public property | Verbose | Determines whether the task should report detailed build log messages. The default is false. (inherited from Task)
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Top

Protected Properties

 | Name | Description
Family property | CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element. (inherited from Element)
Family property | Location | Gets or sets the location in the build file where the element is defined. (inherited from Element)
Family property | XmlNode | Gets or sets the XML node of the element. (inherited from Element)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Executes the task unless it is skipped. (inherited from Task)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Performs default initialization. (inherited from Element)
Public method | InitializeTaskConfiguration | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file. (inherited from Task)
Public method | IsLogEnabledFor | Determines whether build output is enabled for the given Level. (inherited from Task)
Public method | Log | Overloaded. Logs a message with the given priority. (inherited from Task)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

Name | Description
Family method | CopyTo | Copies all instance data of the Element to a given Element. (inherited from Element)
Family method | ExecuteTask | Overridden. Executes the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttributeConfigurationNode | Locates the XML node for the specified attribute in the project configuration node. (inherited from Element)
Family method InitializeElement
Note
Deprecated (to be deleted).
(inherited from Task)
Family method | InitializeTask | Initializes the task. (inherited from Task)
Family method | InitializeXml | Initializes all build attributes and child elements. (inherited from Element)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


GallioTask Constructor

GallioTask Constructor
[image]

Initializes a new instance of the GallioTask class.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GallioTask()
C++
public:
GallioTask() sealed
J#
public GallioTask()
JScript
public function GallioTask()

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


Properties

GallioTask Properties
[image]

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Public property | Assemblies | The list of test assemblies to execute. This is required.
Public property Debug

Attaches the debugger to the test process when set to true.

The default is false.

Public property | DoNotRun | Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.
Public property | EchoResults | Sets whether to echo results to the screen as tests finish. If this option is set to true, the default, test results are echoed to the console in varying detail depending on the current verbosity level. Otherwise only the final summary statistics are displayed.
Public property | FailOnError | Determines if task failure stops the build, or is just reported. The default is true. (inherited from Task)
Public property | Filter | Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.
Public property | HintDirectories | The list of directories used for loading assemblies and other dependent resources.
Public property | IfDefined | If true then the task will be executed; otherwise, skipped. The default is true. (inherited from Task)
Public property | IgnoreAnnotations | Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.
Public property | LogPrefix | The prefix used when sending messages to the log. (inherited from Task)
Public property | Name | The name of the task. (inherited from Task)
Public property | NamespaceManager | Gets or sets the XmlNamespaceManager. (inherited from Element)
Public property | Parent | Gets or sets the parent of the element. (inherited from Element)
Public property | PluginDirectories | Additional Gallio plugin directories to search recursively.
Public property | Project | Gets or sets the Project to which this element belongs. (inherited from Element)
Public property | Properties | Gets the properties local to this Element and the Project. (inherited from Element)
Public property | ReportDirectory | Sets the name of the directory where the reports will be put.
Public property | ReportFormatterProperties | Specifies option property key/value pairs for the report formatter.
Public property | ReportNameFormat | Sets the format string to use to generate the reports filenames.
Public property | ReportTypes | A list of the types of reports to generate, separated by semicolons.
Public property | ResultProperty | Sets the name of a NAnt property in which the exit code of the tests execution should be stored.
Public property RunnerExtensions

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Public property | RunnerProperties | Specifies option property key/value pairs for the test runner.
Public property | RunnerType | Sets the type of test runner to use.
Public property | RunTimeLimit | Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.
Public property ShadowCopy

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Public property | ShowReports | Sets whether to show generated reports in a window using the default system application registered to the report file type.
Public property | StatisticsPropertiesPrefix | Sets the prefix that will be used for the statistics result properties.
Public property | Threshold | Gets or sets the log threshold for this Task. By default the threshold of a task matches the threshold of the project. (inherited from Task)
Public property | UnlessDefined | Opposite of IfDefined. If false then the task will be executed; otherwise, skipped. The default is false. (inherited from Task)
Public property | Verbose | Determines whether the task should report detailed build log messages. The default is false. (inherited from Task)
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Top

Protected Properties

 | Name | Description
Family property | CustomXmlProcessing | Gets a value indicating whether the element is performing additional processing using the XmlNode that was used to initialize the element. (inherited from Element)
Family property | Location | Gets or sets the location in the build file where the element is defined. (inherited from Element)
Family property | XmlNode | Gets or sets the XML node of the element. (inherited from Element)
Top

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ApplicationBaseDirectory Property

GallioTask.ApplicationBaseDirectory Property
[image]

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("application-base-directory")>
Public WriteOnly Property ApplicationBaseDirectory As String
C#
[TaskAttributeAttribute("application-base-directory")]
public string ApplicationBaseDirectory { set; }
C++
[TaskAttributeAttribute(L"application-base-directory")]
public property string ApplicationBaseDirectory sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("application-base-directory") */
/** property */
public void set_ApplicationBaseDirectory(string value);
JScript
public function set ApplicationBaseDirectory(value : String);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


Assemblies Property

GallioTask.Assemblies Property
[image]

The list of test assemblies to execute. This is required.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<BuildElementArrayAttribute("assemblies", ElementType := GetType(FileSet), Required := True)>
Public WriteOnly Property Assemblies As FileSet()
C#
[BuildElementArrayAttribute("assemblies", ElementType = typeof(FileSet), Required = True)]
public FileSet[] Assemblies { set; }
C++
[BuildElementArrayAttribute(L"assemblies", ElementType = typeof(FileSet), Required = True)]
public property FileSet[] Assemblies sealed {
void set(array<FileSet>^ value);
}
J#
/** @attribute BuildElementArrayAttribute("assemblies", ElementType = typeof(FileSet), Required = True) */
/** property */
public void set_Assemblies(FileSet[] value);
JScript
public function set Assemblies(value : FileSet[]);

Example

The following example shows how to specify the test assemblies (for a more complete example please see the GallioTask task documentation):

Copy Code
             <gallio>
                 <assemblies>
                     <!-- Specify the tests assemblies -->
                     <include name="[Path-to-test-assembly1]/TestAssembly1.dll" />
                     <include name="[Path-to-test-assembly2]/TestAssembly2.dll" />
                 </assemblies>
             </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


Debug Property

GallioTask.Debug Property
[image]

Attaches the debugger to the test process when set to true.

The default is false.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("debug")>
Public WriteOnly Property Debug As Boolean
C#
[TaskAttributeAttribute("debug")]
public bool Debug { set; }
C++
[TaskAttributeAttribute(L"debug")]
public property bool Debug sealed {
void set(bool value);
}
J#
/** @attribute TaskAttributeAttribute("debug") */
/** property */
public void set_Debug(bool value);
JScript
public function set Debug(value : bool);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


DoNotRun Property

GallioTask.DoNotRun Property
[image]

Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("do-not-run", Required := False)>
Public WriteOnly Property DoNotRun As Boolean
C#
[TaskAttributeAttribute("do-not-run", Required = False)]
public bool DoNotRun { set; }
C++
[TaskAttributeAttribute(L"do-not-run", Required = False)]
public property bool DoNotRun sealed {
void set(bool value);
}
J#
/** @attribute TaskAttributeAttribute("do-not-run", Required = False) */
/** property */
public void set_DoNotRun(bool value);
JScript
public function set DoNotRun(value : bool);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


EchoResults Property

GallioTask.EchoResults Property
[image]

Sets whether to echo results to the screen as tests finish. If this option is set to true, the default, test results are echoed to the console in varying detail depending on the current verbosity level. Otherwise only the final summary statistics are displayed.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("echo-results", Required := False)>
Public WriteOnly Property EchoResults As Boolean
C#
[TaskAttributeAttribute("echo-results", Required = False)]
public bool EchoResults { set; }
C++
[TaskAttributeAttribute(L"echo-results", Required = False)]
public property bool EchoResults sealed {
void set(bool value);
}
J#
/** @attribute TaskAttributeAttribute("echo-results", Required = False) */
/** property */
public void set_EchoResults(bool value);
JScript
public function set EchoResults(value : bool);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


Filter Property

GallioTask.Filter Property
[image]

Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("filter")>
Public WriteOnly Property Filter As String
C#
[TaskAttributeAttribute("filter")]
public string Filter { set; }
C++
[TaskAttributeAttribute(L"filter")]
public property string Filter sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("filter") */
/** property */
public void set_Filter(string value);
JScript
public function set Filter(value : String);

Remarks

The filter grammar is defined as follows:

Copy Code
     INCLUDE          ::= "include"              # Not case-sensitive
     EXCLUDE          ::= "exclude"              # Not case-sensitive

     OR               ::= "or"                   # Not case-sensitive
     AND              ::= "and"                  # Not case-sensitive
     NOT              ::= "not"                  # Not case-sensitive

     <unquotedWord>   ::= [^:,*()/\"']+

     <quotedWord>     ::= '"' .* '"'             # String delimited by double quotation marks
                      | "'" .* "'"               # String delimited by single quotation marks

     <word>           ::= <unquotedWord>
                      | <quotedWord>

     <regexWord>      ::= "/" .* "/"             # Regular expression
                      | "/" .* "/i"              # Case-insensitive regular expression

     <key>            ::= <word>

     <value>          ::= <word>                 # Value specified by exact string
                      | <regexWord>              # Value specified by regular expression

     <matchSequence>  ::= <value> (',' <value>)* # One or more comma-separated values

     <filterExpr>     ::= "*"                    # "Any"
                      | <key> ":" matchSeq>
                      | <filterExpr> OR filterExpr>   # Combine filter expressions with OR
                      | <filterExpr> AND filterExpr>  # Combine filter expressions with AND
                      | NOT <filterExpr>         # Negate filter expression
                      | "(" <filterExpr> ")"     # Grouping filter expression

     <filterRule>     ::= <filterExpr>           # Inclusion rule (default case)
                      | INCLUDE <filterExpr>     # Inclusion rule
                      | EXCLUDE <filterExpr>     # Exclusion rule

     <filterSet>      ::= <filterRule>           # Filter set consists of at least one filter rule.
                      | <filterRule> <filterSet> # But may be a sequence of rules.

  • By default this property takes the value "*", which means the "Any" filter will be applied.
  • The operator precedence is, from highest to lowest: NOT, AND, and OR. All these operators are left-associative.
  • The commas used to separate the values are interpreted as OR operators, so "Type:Fixture1,Fixture2" is equivalent to "Type:Fixture1 or Type:Fixture2".
  • White-space is ignored outside quoted strings, so "Type:Fixture1|Type:Fixture2" is equivalent to "Type : Fixture1 | Type : Fixture2".
  • Commas, colons, slashes, backslashes and quotation marks can be escaped with a backslash. For example, \' will be interpreted as '. Using a single backslash in front of any other character is invalid.
  • Currently the following filter keys are recognized:
    • Id: Filter by id.
    • Name: Filter by name.
    • Assembly: Filter by assembly name.
    • Namespace: Filter by namespace name.
    • Type: Filter by type name, including inherited types.
    • ExactType: Filter by type name, excluding inherited types.
    • Member: Filter by member name.
    • *: All other names are assumed to correspond to metadata keys. See MetadataKeys for standard metadata keys. Common keys are: AuthorName, Category, Description, Importance, TestsOn.

Example

Assuming the following fixtures have been defined:

Copy Code
      [TestFixture]
      [Category("UnitTest")]
      [Author("AlbertEinstein")]
      public class Fixture1
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

      [TestFixture]
      [Category("IntegrationTest")]
      public class Fixture2
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

The following filters could be applied:

  • Type: Fixture1 - All the tests within Fixture1 will be run.
  • Member: Test1 - Only Fixture1.Test1 and Fixture2.Test1 will be run.
  • Type: Fixture1, Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1 or Type:Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1, Fixture2 and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • Type:/Fixture*/ and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • AuthorName:AlbertEinstein - All the tests within Fixture1 will be run because its author attribute is set to "AlbertEinstein".
  • Category: IntegrationTest - All the tests within Fixture2 will be run because its category attribute is set to "IntegrationTest".
  • ("Type": 'Fixture1' and "Member":/Test*/) or (Type : Fixture2 and Member: /Test*/) - All the tests will be run. This example also shows that you can enclose key and values with quotation marks, and group expressions with parentheses.
  • exclude AuthorName: AlbertEinstein - All the tests within Fixture2 will be run because its author attribute is not set to "AlbertEinstein".
  • exclude Type: Fixture2 include Member: Test2 - Only Fixture1.Test2 will be run because Fixture2 was excluded from consideration before the inclusion rule was applied.

See Also

GallioTask Class
Gallio.NAntTasks Namespace
MetadataKeys

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


HintDirectories Property

GallioTask.HintDirectories Property
[image]

The list of directories used for loading assemblies and other dependent resources.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<BuildElementArrayAttribute("hint-directories", ElementType := GetType(DirSet))>
Public WriteOnly Property HintDirectories As DirSet()
C#
[BuildElementArrayAttribute("hint-directories", ElementType = typeof(DirSet))]
public DirSet[] HintDirectories { set; }
C++
[BuildElementArrayAttribute(L"hint-directories", ElementType = typeof(DirSet))]
public property DirSet[] HintDirectories sealed {
void set(array<DirSet>^ value);
}
J#
/** @attribute BuildElementArrayAttribute("hint-directories", ElementType = typeof(DirSet)) */
/** property */
public void set_HintDirectories(DirSet[] value);
JScript
public function set HintDirectories(value : DirSet[]);

Example

The following example shows how to specify the hint directories:

Copy Code
            <gallio>
                <hint-directories>
                    <include name="C:\SomeFolder\AnotherFolder" />
                    <include name="../somefolder" />
                </hint-directories>
            </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


IgnoreAnnotations Property

GallioTask.IgnoreAnnotations Property
[image]

Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("ignore-annotations", Required := False)>
Public WriteOnly Property IgnoreAnnotations As Boolean
C#
[TaskAttributeAttribute("ignore-annotations", Required = False)]
public bool IgnoreAnnotations { set; }
C++
[TaskAttributeAttribute(L"ignore-annotations", Required = False)]
public property bool IgnoreAnnotations sealed {
void set(bool value);
}
J#
/** @attribute TaskAttributeAttribute("ignore-annotations", Required = False) */
/** property */
public void set_IgnoreAnnotations(bool value);
JScript
public function set IgnoreAnnotations(value : bool);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


PluginDirectories Property

GallioTask.PluginDirectories Property
[image]

Additional Gallio plugin directories to search recursively.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<BuildElementArrayAttribute("plugin-directories", ElementType := GetType(DirSet))>
Public WriteOnly Property PluginDirectories As DirSet()
C#
[BuildElementArrayAttribute("plugin-directories", ElementType = typeof(DirSet))]
public DirSet[] PluginDirectories { set; }
C++
[BuildElementArrayAttribute(L"plugin-directories", ElementType = typeof(DirSet))]
public property DirSet[] PluginDirectories sealed {
void set(array<DirSet>^ value);
}
J#
/** @attribute BuildElementArrayAttribute("plugin-directories", ElementType = typeof(DirSet)) */
/** property */
public void set_PluginDirectories(DirSet[] value);
JScript
public function set PluginDirectories(value : DirSet[]);

Example

The following example shows how to specify the plugins directories:

Copy Code
            <gallio>
                <plugin-directories>
                    <include name="C:\SomeFolder\AnotherFolder" />
                    <include name="../somefolder" />
                </plugin-directories>
            </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ReportDirectory Property

GallioTask.ReportDirectory Property
[image]

Sets the name of the directory where the reports will be put.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("report-directory", Required := False)>
Public WriteOnly Property ReportDirectory As String
C#
[TaskAttributeAttribute("report-directory", Required = False)]
public string ReportDirectory { set; }
C++
[TaskAttributeAttribute(L"report-directory", Required = False)]
public property string ReportDirectory sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("report-directory", Required = False) */
/** property */
public void set_ReportDirectory(string value);
JScript
public function set ReportDirectory(value : String);

Remarks

The directory will be created if it doesn't exist. Existing files will be overwrited.

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ReportFormatterProperties Property

GallioTask.ReportFormatterProperties Property
[image]

Specifies option property key/value pairs for the report formatter.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<BuildElementArrayAttribute("report-formatter-property")>
Public ReadOnly Property ReportFormatterProperties As ArgumentCollection
C#
[BuildElementArrayAttribute("report-formatter-property")]
public ArgumentCollection ReportFormatterProperties { get; }
C++
[BuildElementArrayAttribute(L"report-formatter-property")]
public property ArgumentCollection ReportFormatterProperties sealed {
ArgumentCollection get();
}
J#
/** @attribute BuildElementArrayAttribute("report-formatter-property") */
/** property */
public ArgumentCollection get_ReportFormatterProperties();
JScript
public function get ReportFormatterProperties() : ArgumentCollection

Example

The following example changes the default attachment content disposition for the reports.

Copy Code
            <gallio>
                <report-formatter-property value="AttachmentContentDisposition=Absent" />
                <!-- More options -->
            </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ReportNameFormat Property

GallioTask.ReportNameFormat Property
[image]

Sets the format string to use to generate the reports filenames.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("report-name-format", Required := False)>
Public WriteOnly Property ReportNameFormat As String
C#
[TaskAttributeAttribute("report-name-format", Required = False)]
public string ReportNameFormat { set; }
C++
[TaskAttributeAttribute(L"report-name-format", Required = False)]
public property string ReportNameFormat sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("report-name-format", Required = False) */
/** property */
public void set_ReportNameFormat(string value);
JScript
public function set ReportNameFormat(value : String);

Remarks

Any occurence of {0} will be replaced by the date, and any occurrence of {1} by the time. The default format string is test-report-{0}-{1}.

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ReportTypes Property

GallioTask.ReportTypes Property
[image]

A list of the types of reports to generate, separated by semicolons.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("report-types")>
Public WriteOnly Property ReportTypes As String
C#
[TaskAttributeAttribute("report-types")]
public string ReportTypes { set; }
C++
[TaskAttributeAttribute(L"report-types")]
public property string ReportTypes sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("report-types") */
/** property */
public void set_ReportTypes(string value);
JScript
public function set ReportTypes(value : String);

Remarks

  • The types supported "out of the box" are: Html, Html-Inline, Text, XHtml, XHtml-Inline, Xml, and Xml-Inline, but more types could be available as plugins.
  • The report types are not case sensitives.

Example

In the following example reports will be generated in both HTML and XML format.

Copy Code
            <gallio report-types="html;xml">
                <!-- More options -->
            </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ResultProperty Property

GallioTask.ResultProperty Property
[image]

Sets the name of a NAnt property in which the exit code of the tests execution should be stored.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("result-property"), _
StringValidatorAttribute(AllowEmpty := False)>
Public WriteOnly Property ResultProperty As String
C#
[TaskAttributeAttribute("result-property")]
[StringValidatorAttribute(AllowEmpty = False)]
public string ResultProperty { set; }
C++
[TaskAttributeAttribute(L"result-property")]
[StringValidatorAttribute(AllowEmpty = False)]
public property string ResultProperty sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("result-property") */
/** @attribute StringValidatorAttribute(AllowEmpty = False) */
/** property */
public void set_ResultProperty(string value);
JScript
public function set ResultProperty(value : String);

Remarks

Only of interest if FailOnError is set to false.

Example

Copy Code
            <target name="RunTests">
                <gallio result-property="ExitCode" failonerror="false">
                    <!-- Include test assemblies -->
                </gallio>
                <fail if="${ExitCode != 0}" >The return code should have been 0!</fail>
            </target>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


RunnerExtensions Property

GallioTask.RunnerExtensions Property
[image]

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<BuildElementArrayAttribute("runner-extension")>
Public ReadOnly Property RunnerExtensions As ArgumentCollection
C#
[BuildElementArrayAttribute("runner-extension")]
public ArgumentCollection RunnerExtensions { get; }
C++
[BuildElementArrayAttribute(L"runner-extension")]
public property ArgumentCollection RunnerExtensions sealed {
ArgumentCollection get();
}
J#
/** @attribute BuildElementArrayAttribute("runner-extension") */
/** property */
public ArgumentCollection get_RunnerExtensions();
JScript
public function get RunnerExtensions() : ArgumentCollection

Example

The following example runs tests using a custom logger extension:

Copy Code
            <gallio>
                <runner-extension value="FancyLogger,MyExtensions.dll;ColorOutput,FancyIndenting" />
                <!-- More options -->
            </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


RunnerProperties Property

GallioTask.RunnerProperties Property
[image]

Specifies option property key/value pairs for the test runner.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<BuildElementArrayAttribute("runner-property")>
Public ReadOnly Property RunnerProperties As ArgumentCollection
C#
[BuildElementArrayAttribute("runner-property")]
public ArgumentCollection RunnerProperties { get; }
C++
[BuildElementArrayAttribute(L"runner-property")]
public property ArgumentCollection RunnerProperties sealed {
ArgumentCollection get();
}
J#
/** @attribute BuildElementArrayAttribute("runner-property") */
/** property */
public ArgumentCollection get_RunnerProperties();
JScript
public function get RunnerProperties() : ArgumentCollection

Example

The following example specifies some extra NCover arguments.

Copy Code
            <gallio>
                <runner-property value="NCoverArguments='//eas Gallio'" />
                <!-- More options -->
            </gallio>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


RunnerType Property

GallioTask.RunnerType Property
[image]

Sets the type of test runner to use.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("runner-type", Required := False)>
Public WriteOnly Property RunnerType As String
C#
[TaskAttributeAttribute("runner-type", Required = False)]
public string RunnerType { set; }
C++
[TaskAttributeAttribute(L"runner-type", Required = False)]
public property string RunnerType sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("runner-type", Required = False) */
/** property */
public void set_RunnerType(string value);
JScript
public function set RunnerType(value : String);

Remarks

  • The types supported "out of the box" are: Local, IsolatedAppDomain and IsolatedProcess (default), but more types could be available as plugins.
  • The runner types are not case sensitive.

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


RunTimeLimit Property

GallioTask.RunTimeLimit Property
[image]

Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("run-time-limit", Required := False)>
Public WriteOnly Property RunTimeLimit As Double
C#
[TaskAttributeAttribute("run-time-limit", Required = False)]
public double RunTimeLimit { set; }
C++
[TaskAttributeAttribute(L"run-time-limit", Required = False)]
public property double RunTimeLimit sealed {
void set(double value);
}
J#
/** @attribute TaskAttributeAttribute("run-time-limit", Required = False) */
/** property */
public void set_RunTimeLimit(double value);
JScript
public function set RunTimeLimit(value : double);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ShadowCopy Property

GallioTask.ShadowCopy Property
[image]

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("shadow-copy")>
Public WriteOnly Property ShadowCopy As Boolean
C#
[TaskAttributeAttribute("shadow-copy")]
public bool ShadowCopy { set; }
C++
[TaskAttributeAttribute(L"shadow-copy")]
public property bool ShadowCopy sealed {
void set(bool value);
}
J#
/** @attribute TaskAttributeAttribute("shadow-copy") */
/** property */
public void set_ShadowCopy(bool value);
JScript
public function set ShadowCopy(value : bool);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ShowReports Property

GallioTask.ShowReports Property
[image]

Sets whether to show generated reports in a window using the default system application registered to the report file type.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("show-reports", Required := False)>
Public WriteOnly Property ShowReports As Boolean
C#
[TaskAttributeAttribute("show-reports", Required = False)]
public bool ShowReports { set; }
C++
[TaskAttributeAttribute(L"show-reports", Required = False)]
public property bool ShowReports sealed {
void set(bool value);
}
J#
/** @attribute TaskAttributeAttribute("show-reports", Required = False) */
/** property */
public void set_ShowReports(bool value);
JScript
public function set ShowReports(value : bool);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


StatisticsPropertiesPrefix Property

GallioTask.StatisticsPropertiesPrefix Property
[image]

Sets the prefix that will be used for the statistics result properties.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("statistics-properties-prefix"), _
StringValidatorAttribute(AllowEmpty := False)>
Public WriteOnly Property StatisticsPropertiesPrefix As String
C#
[TaskAttributeAttribute("statistics-properties-prefix")]
[StringValidatorAttribute(AllowEmpty = False)]
public string StatisticsPropertiesPrefix { set; }
C++
[TaskAttributeAttribute(L"statistics-properties-prefix")]
[StringValidatorAttribute(AllowEmpty = False)]
public property string StatisticsPropertiesPrefix sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("statistics-properties-prefix") */
/** @attribute StringValidatorAttribute(AllowEmpty = False) */
/** property */
public void set_StatisticsPropertiesPrefix(string value);
JScript
public function set StatisticsPropertiesPrefix(value : String);

Remarks

The following properties are available:

  • AssertCount - Gets the number of assertions evaluated.
  • FailedCount - Gets the total number of test cases that were run and failed.
  • InconclusiveCount - Gets the total number of test cases that ran and were inconclusive.
  • PassedCount - Gets the total number of test cases that were run and passed.
  • SkippedCount - Gets the total number of test cases that did not run because they were skipped.
  • RunCount - Gets the total number of test cases that were run.
  • TestCount - Gets the total number of test cases.
  • StepCount - Gets the total number of test steps.

Example

The following example shows how to use the result-properties-prefix property :

Copy Code
            <target name="RunTests">
                <gallio statistics-properties-prefix="gallio.">
                    <assemblies>
                        <include name="SomeAssembly.dll" />
                    </assemblies>
                </gallio>
                <echo message="AssertCount = ${gallio.AssertCount}" />
                <echo message="FailedCount = ${gallio.FailedCount}" />
                <echo message="InconclusiveCount = ${gallio.InconclusiveCount}" />
                <echo message="PassedCount = ${gallio.PassedCount}" />
                <echo message="SkippedCount = ${gallio.SkippedCount}" />
                <echo message="RunCount = ${gallio.RunCount}" />
                <echo message="TestCount = ${gallio.TestCount}" />
                <echo message="StepCount = ${gallio.StepCount}" />
            </target>

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


WorkingDirectory Property

GallioTask.WorkingDirectory Property
[image]

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
<TaskAttributeAttribute("working-directory")>
Public WriteOnly Property WorkingDirectory As String
C#
[TaskAttributeAttribute("working-directory")]
public string WorkingDirectory { set; }
C++
[TaskAttributeAttribute(L"working-directory")]
public property string WorkingDirectory sealed {
void set(String value);
}
J#
/** @attribute TaskAttributeAttribute("working-directory") */
/** property */
public void set_WorkingDirectory(string value);
JScript
public function set WorkingDirectory(value : String);

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


Methods

GallioTask Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Execute | Executes the task unless it is skipped. (inherited from Task)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Performs default initialization. (inherited from Element)
Public method | InitializeTaskConfiguration | Initializes the configuration of the task using configuration settings retrieved from the NAnt configuration file. (inherited from Task)
Public method | IsLogEnabledFor | Determines whether build output is enabled for the given Level. (inherited from Task)
Public method | Log | Overloaded. Logs a message with the given priority. (inherited from Task)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

Name | Description
Family method | CopyTo | Copies all instance data of the Element to a given Element. (inherited from Element)
Family method | ExecuteTask | Overridden. Executes the task.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttributeConfigurationNode | Locates the XML node for the specified attribute in the project configuration node. (inherited from Element)
Family method InitializeElement
Note
Deprecated (to be deleted).
(inherited from Task)
Family method | InitializeTask | Initializes the task. (inherited from Task)
Family method | InitializeXml | Initializes all build attributes and child elements. (inherited from Element)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


ExecuteTask Method

GallioTask.ExecuteTask Method
[image]

Executes the task.

Namespace: Gallio.NAntTasks
Assembly: Gallio.NAntTasks (in Gallio.NAntTasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ExecuteTask()
C#
protected override void ExecuteTask()
C++
protected:
virtual void ExecuteTask() override
J#
protected override void ExecuteTask()
JScript
protected override function ExecuteTask()

See Also

GallioTask Class
Gallio.NAntTasks Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.NAntTasks [3.0.6.0]


Gallio.PowerShellCommands

Gallio.PowerShellCommands Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | RunGallioCommand | A PowerShell Cmdlet for running Gallio.


RunGallioCommand Class

RunGallioCommand Class
See Also Example Members
[image]

A PowerShell Cmdlet for running Gallio.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<CmdletAttribute("Run", "Gallio")>
Public Class RunGallioCommand
Inherits BaseCommand
C#
[CmdletAttribute("Run", "Gallio")]
public class RunGallioCommand : BaseCommand
C++
[CmdletAttribute(L"Run", L"Gallio")]
ref class RunGallioCommand : BaseCommand
J#
/** @attribute CmdletAttribute("Run", "Gallio") */
public class RunGallioCommand extends BaseCommand
JScript
public
CmdletAttribute("Run", "Gallio")
class RunGallioCommand extends BaseCommand

Example

There are severals ways to run this cmdlet:

Copy Code
            # Makes the Gallio commands available
            Add-PSSnapIn Gallio
            # Runs TestAssembly1.dll
            Run-Gallio "[Path-to-assembly1]\TestAssembly1.dll" -f Category:UnitTests -rd C:\build\reports -rf html

Remarks

Only the Assemblies parameter is required.

Inheritance Hierarchy

System.Object
System.Management.Automation.Internal.InternalCommand
System.Management.Automation.Cmdlet
System.Management.Automation.PSCmdlet
Gallio.PowerShellCommands.BaseCommand
Gallio.PowerShellCommands.RunGallioCommand

See Also

RunGallioCommand Members
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


RunGallioCommand Members

RunGallioCommand Members
See Also Example Constructors Properties Methods Events
[image]

A PowerShell Cmdlet for running Gallio.

The following tables list the members exposed by RunGallioCommand.

Public Constructors

 | Name | Description
Public method | RunGallioCommand | Initializes a new instance of the RunGallioCommand class.
Top

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Public property | Assemblies | The list of relative or absolute paths of test assembly files to execute. This is required.
Public property | CommandRuntime | (inherited from Cmdlet)
Public property DebugTests

Attaches the debugger to the test process when set to true.

The default is false.

Public property | DoNotRun | Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.
Public property | Filter | Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.
Public property | HintDirectories | The list of directories used for loading assemblies and other dependent resources.
Public property | Host | (inherited from PSCmdlet)
Public property | IgnoreAnnotations | Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.
Public property | InvokeCommand | (inherited from PSCmdlet)
Public property | InvokeProvider | (inherited from PSCmdlet)
Public property | Logger | Gets the logger for the cmdlet. (inherited from BaseCommand)
Public property | MyInvocation | (inherited from PSCmdlet)
Public property | NoEchoResults | Sets whether to echo results to the screen as tests finish. If this option is specified only the final summary statistics are displayed. Otherwise test results are echoed to the console in varying detail depending on the current verbosity level.
Public property | NoProgress | Sets whether progress information is shown during the execution. If this option is specified, the execution is silent and no progress information is displayed. (inherited from BaseCommand)
Public property | ParameterSetName | (inherited from PSCmdlet)
Public property | PluginDirectories | Additional Gallio plugin directories to search recursively.
Public property | ProgressMonitorProvider | Gets the progress monitor provider for the cmdlet. (inherited from BaseCommand)
Public property | ReportDirectory | Sets the name of the directory where the reports will be put.
Public property | ReportFormatterProperties | Specifies option property key/value pairs for the report formatter.
Public property | ReportNameFormat | Sets the format string to use to generate the reports filenames.
Public property | ReportTypes | A list of the types of reports to generate, separated by semicolons.
Public property RunnerExtensions

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Public property | RunnerProperties | Specifies option property key/value pairs for the test runner.
Public property | RunnerType | Sets the type of test runner to use.
Public property | RunTimeLimit | Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.
Public property | SessionState | (inherited from PSCmdlet)
Public property ShadowCopy

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Public property | ShowReports | Sets whether to open the generated reports once execution has finished.
Public property | Stopping | (inherited from Cmdlet)
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Top

Public Methods

 | Name | Description
Public method | CurrentProviderLocation | (inherited from PSCmdlet)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetResolvedProviderPathFromPSPath | (inherited from PSCmdlet)
Public method | GetResourceString | (inherited from Cmdlet)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetUnresolvedProviderPathFromPSPath | (inherited from PSCmdlet)
Public method | GetVariableValue | Overloaded. (inherited from PSCmdlet)
Public method | Invoke | (inherited from Cmdlet)
Public method | PostMessage | Posts an action to perform later within the message loop. (inherited from BaseCommand)
Public method | RunWithMessagePump | Starts a message pump running on the current thread and performs the specified action in another thread. The action can asynchronously communicate back to the cmdlet using PostMessage on the current thread. (inherited from BaseCommand)
Public method | ShouldContinue | Overloaded. (inherited from Cmdlet)
Public method | ShouldProcess | Overloaded. (inherited from Cmdlet)
Public method | ThrowTerminatingError | (inherited from Cmdlet)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteCommandDetail | (inherited from Cmdlet)
Public method | WriteDebug | (inherited from Cmdlet)
Public method | WriteError | (inherited from Cmdlet)
Public method | WriteObject | Overloaded. (inherited from Cmdlet)
Public method | WriteProgress | (inherited from Cmdlet)
Public method | WriteVerbose | (inherited from Cmdlet)
Public method | WriteWarning | (inherited from Cmdlet)
Top

Protected Methods

 | Name | Description
Family method | BeginProcessing | (inherited from Cmdlet)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ProcessRecord | (inherited from Cmdlet)
Family method | StopProcessing | Aborts the processing of the command. (inherited from BaseCommand)
Top

Public Events

 | Name | Description
Public event | StopRequested | The event dispatches when the command is asynchronously being stopped via StopProcessing. (inherited from BaseCommand)
Top

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


RunGallioCommand Constructor

RunGallioCommand Constructor
[image]

Initializes a new instance of the RunGallioCommand class.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RunGallioCommand()
C++
public:
RunGallioCommand() sealed
J#
public RunGallioCommand()
JScript
public function RunGallioCommand()

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


Properties

RunGallioCommand Properties
[image]

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Public property | Assemblies | The list of relative or absolute paths of test assembly files to execute. This is required.
Public property | CommandRuntime | (inherited from Cmdlet)
Public property DebugTests

Attaches the debugger to the test process when set to true.

The default is false.

Public property | DoNotRun | Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.
Public property | Filter | Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.
Public property | HintDirectories | The list of directories used for loading assemblies and other dependent resources.
Public property | Host | (inherited from PSCmdlet)
Public property | IgnoreAnnotations | Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.
Public property | InvokeCommand | (inherited from PSCmdlet)
Public property | InvokeProvider | (inherited from PSCmdlet)
Public property | Logger | Gets the logger for the cmdlet. (inherited from BaseCommand)
Public property | MyInvocation | (inherited from PSCmdlet)
Public property | NoEchoResults | Sets whether to echo results to the screen as tests finish. If this option is specified only the final summary statistics are displayed. Otherwise test results are echoed to the console in varying detail depending on the current verbosity level.
Public property | NoProgress | Sets whether progress information is shown during the execution. If this option is specified, the execution is silent and no progress information is displayed. (inherited from BaseCommand)
Public property | ParameterSetName | (inherited from PSCmdlet)
Public property | PluginDirectories | Additional Gallio plugin directories to search recursively.
Public property | ProgressMonitorProvider | Gets the progress monitor provider for the cmdlet. (inherited from BaseCommand)
Public property | ReportDirectory | Sets the name of the directory where the reports will be put.
Public property | ReportFormatterProperties | Specifies option property key/value pairs for the report formatter.
Public property | ReportNameFormat | Sets the format string to use to generate the reports filenames.
Public property | ReportTypes | A list of the types of reports to generate, separated by semicolons.
Public property RunnerExtensions

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Public property | RunnerProperties | Specifies option property key/value pairs for the test runner.
Public property | RunnerType | Sets the type of test runner to use.
Public property | RunTimeLimit | Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.
Public property | SessionState | (inherited from PSCmdlet)
Public property ShadowCopy

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Public property | ShowReports | Sets whether to open the generated reports once execution has finished.
Public property | Stopping | (inherited from Cmdlet)
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Top

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ApplicationBaseDirectory Property

RunGallioCommand.ApplicationBaseDirectory Property
[image]

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property ApplicationBaseDirectory As String
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string ApplicationBaseDirectory { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string ApplicationBaseDirectory sealed {
void set(String value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_ApplicationBaseDirectory(string value);
JScript
public function set ApplicationBaseDirectory(value : String);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


Assemblies Property

RunGallioCommand.Assemblies Property
[image]

The list of relative or absolute paths of test assembly files to execute. This is required.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ValidateNotNullOrEmptyAttribute, _
ParameterAttribute(Position := 0, Mandatory := True, ValueFromPipelineByPropertyName := True), _
ValidateCountAttribute(1, 99999)>
Public WriteOnly Property Assemblies As String()
C#
[ValidateNotNullOrEmptyAttribute]
[ParameterAttribute(Position = 0, Mandatory = True, ValueFromPipelineByPropertyName = True)]
[ValidateCountAttribute(1, 99999)]
public string[] Assemblies { set; }
C++
[ValidateNotNullOrEmptyAttribute]
[ParameterAttribute(Position = 0, Mandatory = True, ValueFromPipelineByPropertyName = True)]
[ValidateCountAttribute(1, 99999)]
public property string[] Assemblies sealed {
void set(array<String>^ value);
}
J#
/** @attribute ValidateNotNullOrEmptyAttribute() */
/** @attribute ParameterAttribute(Position = 0, Mandatory = True, ValueFromPipelineByPropertyName = True) */
/** @attribute ValidateCountAttribute(1, 99999) */
/** property */
public void set_Assemblies(string[] value);
JScript
public function set Assemblies(value : String[]);

Example

There are severals ways to pass the test assemblies names to the cmdlet:

Copy Code
             # Runs TestAssembly1.dll
             Run-Gallio "[Path-to-assembly1]\TestAssembly1.dll"

             # Runs TestAssembly1.dll and TestAssembly2.dll
             Run-Gallio "[Path-to-assembly1]\TestAssembly1.dll","[Path-to-assembly2]\TestAssembly2.dll"

             # Runs TestAssembly1.dll and TestAssembly2.dll
             $assemblies = "[Path-to-assembly1]\TestAssembly1.dll","[Path-to-assembly2]\TestAssembly2.dll"
             Run-Gallio $assemblies

             # Runs TestAssembly1.dll and TestAssembly2.dll
             $assembly1 = "[Path-to-assembly1]\TestAssembly1.dll"
             $assembly2 = "[Path-to-assembly2]\TestAssembly2.dll"
             $assemblies = $assembly1,$assembly2
             Run-Gallio $assemblies

             # If you don't specify the test assemblies, PowerShell will prompt you for the names:
             PS C:\Documents and Settings\jhi> Run-Gallio

             cmdlet Run-Gallio at command pipeline position
             Supply values for the following parameters:
             Assemblies[0]:

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


DebugTests Property

RunGallioCommand.DebugTests Property
[image]

Attaches the debugger to the test process when set to true.

The default is false.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property DebugTests As Boolean
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public bool DebugTests { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property bool DebugTests sealed {
void set(bool value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_DebugTests(bool value);
JScript
public function set DebugTests(value : bool);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


DoNotRun Property

RunGallioCommand.DoNotRun Property
[image]

Sets whether to load the tests but not run them. This option may be used to produce a report that contains test metadata for consumption by other tools.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property DoNotRun As SwitchParameter
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public SwitchParameter DoNotRun { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property SwitchParameter DoNotRun sealed {
void set(SwitchParameter value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_DoNotRun(SwitchParameter value);
JScript
public function set DoNotRun(value : SwitchParameter);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


Filter Property

RunGallioCommand.Filter Property
[image]

Sets the filter set to apply, which consists of a sequence of one or more inclusion or exclusion filter rules prefixed using 'include' (optional) or 'exclude'. A filter rule consists of zero or more filter expressions that may be combined using 'and', 'or', and 'not' and grouped with parentheses. A filter expression consists of a filter key followed by one or more comma-delimited matching values in the form 'key: value, "quoted value", /regular expression/'.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property Filter As String
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public string Filter { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property string Filter sealed {
void set(String value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_Filter(string value);
JScript
public function set Filter(value : String);

Remarks

The filter grammar is defined as follows:

Copy Code
     INCLUDE          ::= "include"              # Not case-sensitive
     EXCLUDE          ::= "exclude"              # Not case-sensitive

     OR               ::= "or"                   # Not case-sensitive
     AND              ::= "and"                  # Not case-sensitive
     NOT              ::= "not"                  # Not case-sensitive

     <unquotedWord>   ::= [^:,*()/\"']+

     <quotedWord>     ::= '"' .* '"'             # String delimited by double quotation marks
                      | "'" .* "'"               # String delimited by single quotation marks

     <word>           ::= <unquotedWord>
                      | <quotedWord>

     <regexWord>      ::= "/" .* "/"             # Regular expression
                      | "/" .* "/i"              # Case-insensitive regular expression

     <key>            ::= <word>

     <value>          ::= <word>                 # Value specified by exact string
                      | <regexWord>              # Value specified by regular expression

     <matchSequence>  ::= <value> (',' <value>)* # One or more comma-separated values

     <filterExpr>     ::= "*"                    # "Any"
                      | <key> ":" matchSeq>
                      | <filterExpr> OR filterExpr>   # Combine filter expressions with OR
                      | <filterExpr> AND filterExpr>  # Combine filter expressions with AND
                      | NOT <filterExpr>         # Negate filter expression
                      | "(" <filterExpr> ")"     # Grouping filter expression

     <filterRule>     ::= <filterExpr>           # Inclusion rule (default case)
                      | INCLUDE <filterExpr>     # Inclusion rule
                      | EXCLUDE <filterExpr>     # Exclusion rule

     <filterSet>      ::= <filterRule>           # Filter set consists of at least one filter rule.
                      | <filterRule> <filterSet> # But may be a sequence of rules.

  • By default this property takes the value "*", which means the "Any" filter will be applied.
  • The operator precedence is, from highest to lowest: NOT, AND, and OR. All these operators are left-associative.
  • The commas used to separate the values are interpreted as OR operators, so "Type:Fixture1,Fixture2" is equivalent to "Type:Fixture1 or Type:Fixture2".
  • White-space is ignored outside quoted strings, so "Type:Fixture1|Type:Fixture2" is equivalent to "Type : Fixture1 | Type : Fixture2".
  • Commas, colons, slashes, backslashes and quotation marks can be escaped with a backslash. For example, \' will be interpreted as '. Using a single backslash in front of any other character is invalid.
  • Currently the following filter keys are recognized:
    • Id: Filter by id.
    • Name: Filter by name.
    • Assembly: Filter by assembly name.
    • Namespace: Filter by namespace name.
    • Type: Filter by type name, including inherited types.
    • ExactType: Filter by type name, excluding inherited types.
    • Member: Filter by member name.
    • *: All other names are assumed to correspond to metadata keys. See MetadataKeys for standard metadata keys. Common keys are: AuthorName, Category, Description, Importance, TestsOn.

Example

Assuming the following fixtures have been defined:

Copy Code
      [TestFixture]
      [Category("UnitTest")]
      [Author("AlbertEinstein")]
      public class Fixture1
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

      [TestFixture]
      [Category("IntegrationTest")]
      public class Fixture2
      {
        [Test]
        public void Test1()
        {
        }
        [Test]
        public void Test2()
        {
        }
      }

The following filters could be applied:

  • Type: Fixture1 - All the tests within Fixture1 will be run.
  • Member: Test1 - Only Fixture1.Test1 and Fixture2.Test1 will be run.
  • Type: Fixture1, Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1 or Type:Fixture2 - All the tests within Fixture1 or Fixture2 will be run.
  • Type:Fixture1, Fixture2 and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • Type:/Fixture*/ and Member:Test2 - Only Fixture1.Test2 and Fixture2.Test2 will be run.
  • AuthorName:AlbertEinstein - All the tests within Fixture1 will be run because its author attribute is set to "AlbertEinstein".
  • Category: IntegrationTest - All the tests within Fixture2 will be run because its category attribute is set to "IntegrationTest".
  • ("Type": 'Fixture1' and "Member":/Test*/) or (Type : Fixture2 and Member: /Test*/) - All the tests will be run. This example also shows that you can enclose key and values with quotation marks, and group expressions with parentheses.
  • exclude AuthorName: AlbertEinstein - All the tests within Fixture2 will be run because its author attribute is not set to "AlbertEinstein".
  • exclude Type: Fixture2 include Member: Test2 - Only Fixture1.Test2 will be run because Fixture2 was excluded from consideration before the inclusion rule was applied.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace
MetadataKeys

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


HintDirectories Property

RunGallioCommand.HintDirectories Property
[image]

The list of directories used for loading assemblies and other dependent resources.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property HintDirectories As String()
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string[] HintDirectories { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string[] HintDirectories sealed {
void set(array<String>^ value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_HintDirectories(string[] value);
JScript
public function set HintDirectories(value : String[]);

Example

The following example shows how to specify the hint directories:

Copy Code
            Run-Gallio SomeAssembly.dll -hd C:\SomeFolder

See the Assemblies property for more ways of passing list of parameters to the cmdlet.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


IgnoreAnnotations Property

RunGallioCommand.IgnoreAnnotations Property
[image]

Sets whether to ignore annotations when determining the result code. If false (default), then error annotations, usually indicative of broken tests, will cause a failure result to be generated.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property IgnoreAnnotations As SwitchParameter
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public SwitchParameter IgnoreAnnotations { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property SwitchParameter IgnoreAnnotations sealed {
void set(SwitchParameter value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_IgnoreAnnotations(SwitchParameter value);
JScript
public function set IgnoreAnnotations(value : SwitchParameter);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


NoEchoResults Property

RunGallioCommand.NoEchoResults Property
[image]

Sets whether to echo results to the screen as tests finish. If this option is specified only the final summary statistics are displayed. Otherwise test results are echoed to the console in varying detail depending on the current verbosity level.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property NoEchoResults As SwitchParameter
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public SwitchParameter NoEchoResults { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property SwitchParameter NoEchoResults sealed {
void set(SwitchParameter value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_NoEchoResults(SwitchParameter value);
JScript
public function set NoEchoResults(value : SwitchParameter);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


PluginDirectories Property

RunGallioCommand.PluginDirectories Property
[image]

Additional Gallio plugin directories to search recursively.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property PluginDirectories As String()
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public string[] PluginDirectories { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property string[] PluginDirectories sealed {
void set(array<String>^ value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_PluginDirectories(string[] value);
JScript
public function set PluginDirectories(value : String[]);

Example

The following example shows how to specify the plugin directories:

Copy Code
            Run-Gallio SomeAssembly.dll -pd C:\SomeFolder

See the Assemblies property for more ways of passing list of parameters to the cmdlet.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ReportDirectory Property

RunGallioCommand.ReportDirectory Property
[image]

Sets the name of the directory where the reports will be put.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property ReportDirectory As String
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string ReportDirectory { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string ReportDirectory sealed {
void set(String value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_ReportDirectory(string value);
JScript
public function set ReportDirectory(value : String);

Remarks

The directory will be created if it doesn't exist. Existing files will be overwrited.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ReportFormatterProperties Property

RunGallioCommand.ReportFormatterProperties Property
[image]

Specifies option property key/value pairs for the report formatter.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property ReportFormatterProperties As String()
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string[] ReportFormatterProperties { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string[] ReportFormatterProperties sealed {
void set(array<String>^ value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_ReportFormatterProperties(string[] value);
JScript
public function set ReportFormatterProperties(value : String[]);

Example

The following example changes the default attachment content disposition for the reports.

Copy Code
            Run-Gallio SomeAssembly.dll -report-formatter-property "AttachmentContentDisposition=Absent"

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ReportNameFormat Property

RunGallioCommand.ReportNameFormat Property
[image]

Sets the format string to use to generate the reports filenames.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property ReportNameFormat As String
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public string ReportNameFormat { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property string ReportNameFormat sealed {
void set(String value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_ReportNameFormat(string value);
JScript
public function set ReportNameFormat(value : String);

Remarks

Any occurence of {0} will be replaced by the date, and any occurrence of {1} by the time. The default format string is test-report-{0}-{1}.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ReportTypes Property

RunGallioCommand.ReportTypes Property
[image]

A list of the types of reports to generate, separated by semicolons.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property ReportTypes As String()
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string[] ReportTypes { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string[] ReportTypes sealed {
void set(array<String>^ value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_ReportTypes(string[] value);
JScript
public function set ReportTypes(value : String[]);

Remarks

  • The types supported "out of the box" are: Html, Html-Inline, Text, XHtml, XHtml-Inline, Xml, and Xml-Inline, but more types could be available as plugins.
  • The report types are not case sensitives.

Example

In the following example reports will be generated in both HTML and XML format:

Copy Code
            Run-Gallio SomeAssembly.dll -rt "html","text"

See the Assemblies property for more ways of passing list of parameters to the cmdlet.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


RunnerExtensions Property

RunGallioCommand.RunnerExtensions Property
[image]

Specifies the type, assembly, and parameters of custom test runner extensions to use during the test run in the form: '[Namespace.]Type,Assembly[;Parameters]'.

eg. 'FancyLogger,MyCustomExtensions.dll;SomeParameters'

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property RunnerExtensions As String()
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string[] RunnerExtensions { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string[] RunnerExtensions sealed {
void set(array<String>^ value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_RunnerExtensions(string[] value);
JScript
public function set RunnerExtensions(value : String[]);

Example

The following example runs tests using a custom logger extension:

Copy Code
            Run-Gallio SomeAssembly.dll -runner-extension 'FancyLogger,MyExtensions.dll;ColorOutput,FancyIndenting'

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


RunnerProperties Property

RunGallioCommand.RunnerProperties Property
[image]

Specifies option property key/value pairs for the test runner.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property RunnerProperties As String()
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public string[] RunnerProperties { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property string[] RunnerProperties sealed {
void set(array<String>^ value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_RunnerProperties(string[] value);
JScript
public function set RunnerProperties(value : String[]);

Example

The following example specifies some extra NCover arguments.

Copy Code
            Run-Gallio SomeAssembly.dll -runner-property "NCoverArguments='//eas Gallio'"

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


RunnerType Property

RunGallioCommand.RunnerType Property
[image]

Sets the type of test runner to use.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property RunnerType As String
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public string RunnerType { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property string RunnerType sealed {
void set(String value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_RunnerType(string value);
JScript
public function set RunnerType(value : String);

Remarks

  • The types supported "out of the box" are: Local, IsolatedAppDomain and IsolatedProcess (default), but more types could be available as plugins.
  • The runner types are not case sensitive.

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


RunTimeLimit Property

RunGallioCommand.RunTimeLimit Property
[image]

Sets the maximum amount of time (in seconds) the tests can run before they are canceled. The default is an infinite time to run.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property RunTimeLimit As Double
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public double RunTimeLimit { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property double RunTimeLimit sealed {
void set(double value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_RunTimeLimit(double value);
JScript
public function set RunTimeLimit(value : double);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ShadowCopy Property

RunGallioCommand.ShadowCopy Property
[image]

Enables shadow copying when set to true.

Shadow copying allows the original assemblies to be modified while the tests are running. However, shadow copying may occasionally cause some tests to fail if they depend on their original location.

The default is false.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property ShadowCopy As SwitchParameter
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public SwitchParameter ShadowCopy { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property SwitchParameter ShadowCopy sealed {
void set(SwitchParameter value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_ShadowCopy(SwitchParameter value);
JScript
public function set ShadowCopy(value : SwitchParameter);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


ShowReports Property

RunGallioCommand.ShowReports Property
[image]

Sets whether to open the generated reports once execution has finished.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<ParameterAttribute(ValueFromPipelineByPropertyName := True), _
AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])>
Public WriteOnly Property ShowReports As SwitchParameter
C#
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
public SwitchParameter ShowReports { set; }
C++
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
public property SwitchParameter ShowReports sealed {
void set(SwitchParameter value);
}
J#
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** property */
public void set_ShowReports(SwitchParameter value);
JScript
public function set ShowReports(value : SwitchParameter);

Remarks

  • This parameter takes the value true if present and false if not. No value has to be specified.
  • The reports are opened in a window using the default system application registered to the report file type.

Example

Copy Code
            # Doesn't show the reports once execution has finished
            Run-Gallio SomeAssembly.dll
            # Shows the reports once execution has finished
            Run-Gallio SomeAssembly.dll -sr

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


WorkingDirectory Property

RunGallioCommand.WorkingDirectory Property
[image]

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

The default is null.

Namespace: Gallio.PowerShellCommands
Assembly: Gallio.PowerShellCommands (in Gallio.PowerShellCommands.dll)

Syntax

Visual Basic (Declaration)
<AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]), _
ParameterAttribute(ValueFromPipelineByPropertyName := True)>
Public WriteOnly Property WorkingDirectory As String
C#
[AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public string WorkingDirectory { set; }
C++
[AliasAttribute(System::Collections::ObjectModel::ReadOnlyCollection`1[System::Reflection::CustomAttributeTypedArgument])]
[ParameterAttribute(ValueFromPipelineByPropertyName = True)]
public property string WorkingDirectory sealed {
void set(String value);
}
J#
/** @attribute AliasAttribute(System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeTypedArgument]) */
/** @attribute ParameterAttribute(ValueFromPipelineByPropertyName = True) */
/** property */
public void set_WorkingDirectory(string value);
JScript
public function set WorkingDirectory(value : String);

See Also

RunGallioCommand Class
Gallio.PowerShellCommands Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.PowerShellCommands [3.0.6.0]


Gallio.Reflection

Gallio.Reflection Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AssemblyUtils | Provides helpers for working with assemblies. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AttributeUtils | Manipulates attributes described by their metadata. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | CodeElementSorter | Sorts code elements in various ways. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | DeclaringTypeComparer | Sorts an members that all belong to the same type such that the members declared by supertypes appear before those declared by subtypes. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class ReflectionOnlyAssemblyLoader

This assembly loader loads assemblies externally for reflection only.

This implementation ensures that the assembly files do not remain locked on disk and are not cached in memory outside of the scope of the loader. Consequently the Garbage Collector will automatically reclaim the loader and its contents when they become unreferenced.

In contrast, that of the standard .Net reflection-only load context () does not allow assemblies to be reclaimed until the AppDomain is unloaded.

The loader considers all assemblies in the specified search path as well as any that can be located using the current AppDomain's assembly resolvers.

Public class | ReflectionUtils | Provides functions for working with reflection. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ReflectionWrapperResolveException | The type of exception thrown when a reflection wrapper could not be resolved to a native reflection target.
Public class | Reflector | Wraps reflection types using the reflection adapter interfaces. Also resolves code references. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

Interface | Description
Public interface IAssemblyInfo

A Assembly reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface | IAttributeInfo | Provides information about the contents of a custom attribute.
Public interface ICodeElementInfo

Represents a structural element of some code base.

This interface is the base of a hierarchy of abstract reflection objects. Different implementations of these objects may be used to perform reflection over different sources.

Public interface IConstructorInfo

A ConstructorInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IEventInfo

A EventInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IFieldInfo

A FieldInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IFunctionInfo

A MethodBase reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IGenericParameterInfo

A Type reflection wrapper for generic parameters. The parameter is presented as if it were a slot the accepted a value of type Type.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IMemberInfo

A MemberInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IMethodInfo

A MethodInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface INamespaceInfo

A namespace reflection wrapper identified by its name.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IParameterInfo

A ParameterInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface IPropertyInfo

A PropertyInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Public interface | IReflectionPolicy | A reflection policy provides access to top-level reflection resources such as assemblies.
Public interface | ISlotInfo | A slot represents a field, property or parameter. It is used to simplify the handling of data binding since all three of these types are similar in that they can hold values of some type.
Public interface ITypeInfo

A Type reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Structures

 | Structure | Description
Public structure | CodeLocation | Specifies the location of a code element as a position within a file.
Public structure | CodeReference | A code reference is a pointer into the structure of a .Net program for use in describing the location of a certain code construct to the user. It is typically used to identify the point of definition of a test component.
Public structure | ConstantValue | Specifies a typed constant value.

Enumerations

 | Enumeration | Description
Public enumeration | CodeElementKind | Describes the kind of code element represented by a ICodeElementInfo.
Public enumeration | CodeReferenceKind | Describes the kind of code element specified by a CodeReference.


AssemblyUtils Class

AssemblyUtils Class
See Also Example Members
[image]

Provides helpers for working with assemblies. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module AssemblyUtils
C#
public static class AssemblyUtils
C++
ref class AssemblyUtils abstract sealed
J#
public final class AssemblyUtils
JScript
public class AssemblyUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.AssemblyUtils

See Also

AssemblyUtils Members
Gallio.Reflection Namespace


AssemblyUtils Members

AssemblyUtils Members
See Also Example Methods
[image]

Provides helpers for working with assemblies. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AssemblyUtils.

Public Methods

Name | Description
GetApplicationVersion | Gets the application version given its primary assembly. Uses the assembly file version if available.
GetAssemblyLocalPath | Gets the local path of the assembly prior to shadow copying. Returns null if the original location of the assembly is not local.
GetAssemblyLocation | Gets the location of the assembly, or null if it is dynamic.
GetAssemblyNameCulture | Gets the culture component of an assembly name.
GetFriendlyAssemblyCodeBase | If the assembly codebase is a local file, returns it as a local path. Otherwise, returns the assembly codebase Uri.
GetFriendlyAssemblyLocation | Gets the original local path of the assembly prior to shadow copying, if it is local. Otherwise, returns the shadow-copied assembly location.
Top

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


Methods

AssemblyUtils Methods
[image]

Public Methods

Name | Description
GetApplicationVersion | Gets the application version given its primary assembly. Uses the assembly file version if available.
GetAssemblyLocalPath | Gets the local path of the assembly prior to shadow copying. Returns null if the original location of the assembly is not local.
GetAssemblyLocation | Gets the location of the assembly, or null if it is dynamic.
GetAssemblyNameCulture | Gets the culture component of an assembly name.
GetFriendlyAssemblyCodeBase | If the assembly codebase is a local file, returns it as a local path. Otherwise, returns the assembly codebase Uri.
GetFriendlyAssemblyLocation | Gets the original local path of the assembly prior to shadow copying, if it is local. Otherwise, returns the shadow-copied assembly location.
Top

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


GetApplicationVersion Method

AssemblyUtils.GetApplicationVersion Method
[image]

Gets the application version given its primary assembly. Uses the assembly file version if available.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetApplicationVersion( _
ByVal assembly As Assembly _
) As Version
C#
public static Version GetApplicationVersion(
Assembly assembly
)
C++
public:
static Version GetApplicationVersion(
Assembly assembly
)
J#
public static Version GetApplicationVersion(
Assembly assembly
)
JScript
public static function GetApplicationVersion(
assembly : Assembly
) : Version

Parameters

assembly
The assembly

Return Value

The assembly's file version

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


GetAssemblyLocalPath Method

AssemblyUtils.GetAssemblyLocalPath Method
[image]

Gets the local path of the assembly prior to shadow copying. Returns null if the original location of the assembly is not local.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAssemblyLocalPath( _
ByVal assembly As Assembly _
) As String
C#
public static string GetAssemblyLocalPath(
Assembly assembly
)
C++
public:
static String GetAssemblyLocalPath(
Assembly assembly
)
J#
public static string GetAssemblyLocalPath(
Assembly assembly
)
JScript
public static function GetAssemblyLocalPath(
assembly : Assembly
) : String

Parameters

assembly
The assembly

Return Value

The original non-shadow copied local path of the assembly, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


GetAssemblyLocation Method

AssemblyUtils.GetAssemblyLocation Method
[image]

Gets the location of the assembly, or null if it is dynamic.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAssemblyLocation( _
ByVal assembly As Assembly _
) As String
C#
public static string GetAssemblyLocation(
Assembly assembly
)
C++
public:
static String GetAssemblyLocation(
Assembly assembly
)
J#
public static string GetAssemblyLocation(
Assembly assembly
)
JScript
public static function GetAssemblyLocation(
assembly : Assembly
) : String

Parameters

assembly
The assembly

Return Value

The assembly location as returned by Location or null if the assembly is dynamic and does not have a location

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


GetAssemblyNameCulture Method

AssemblyUtils.GetAssemblyNameCulture Method
[image]

Gets the culture component of an assembly name.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAssemblyNameCulture( _
ByVal assemblyName As AssemblyName _
) As String
C#
public static string GetAssemblyNameCulture(
AssemblyName assemblyName
)
C++
public:
static String GetAssemblyNameCulture(
AssemblyName assemblyName
)
J#
public static string GetAssemblyNameCulture(
AssemblyName assemblyName
)
JScript
public static function GetAssemblyNameCulture(
assemblyName : AssemblyName
) : String

Parameters

assemblyName
The assembly name

Return Value

The culture name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyName is null

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


GetFriendlyAssemblyCodeBase Method

AssemblyUtils.GetFriendlyAssemblyCodeBase Method
[image]

If the assembly codebase is a local file, returns it as a local path. Otherwise, returns the assembly codebase Uri.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFriendlyAssemblyCodeBase( _
ByVal assembly As Assembly _
) As String
C#
public static string GetFriendlyAssemblyCodeBase(
Assembly assembly
)
C++
public:
static String GetFriendlyAssemblyCodeBase(
Assembly assembly
)
J#
public static string GetFriendlyAssemblyCodeBase(
Assembly assembly
)
JScript
public static function GetFriendlyAssemblyCodeBase(
assembly : Assembly
) : String

Parameters

assembly
The assembly

Return Value

The assembly's path

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


GetFriendlyAssemblyLocation Method

AssemblyUtils.GetFriendlyAssemblyLocation Method
[image]

Gets the original local path of the assembly prior to shadow copying, if it is local. Otherwise, returns the shadow-copied assembly location.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFriendlyAssemblyLocation( _
ByVal assembly As Assembly _
) As String
C#
public static string GetFriendlyAssemblyLocation(
Assembly assembly
)
C++
public:
static String GetFriendlyAssemblyLocation(
Assembly assembly
)
J#
public static string GetFriendlyAssemblyLocation(
Assembly assembly
)
JScript
public static function GetFriendlyAssemblyLocation(
assembly : Assembly
) : String

Parameters

assembly
The assembly

Return Value

The local path of the assembly, preferably its original non-shadow copied location, or null if the assembly is dynamic and does not have a location

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

AssemblyUtils Class
Gallio.Reflection Namespace


AttributeUtils Class

AttributeUtils Class
See Also Example Members
[image]

Manipulates attributes described by their metadata. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module AttributeUtils
C#
public static class AttributeUtils
C++
ref class AttributeUtils abstract sealed
J#
public final class AttributeUtils
JScript
public class AttributeUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.AttributeUtils

See Also

AttributeUtils Members
Gallio.Reflection Namespace


AttributeUtils Members

AttributeUtils Members
See Also Example Methods
[image]

Manipulates attributes described by their metadata. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AttributeUtils.

Public Methods

Name | Description
GetAttribute | Overloaded. Gets the attribute of the specified type, or null if none.
GetAttributes | Overloaded. Gets the attributes of the specified type.
HasAttribute | Overloaded. Returns true if the code element has an attribute of the specified type.
ResolveAttributes | Resolves all the attributes.
Top

See Also

AttributeUtils Class
Gallio.Reflection Namespace


Methods

AttributeUtils Methods
[image]

Public Methods

Name | Description
GetAttribute | Overloaded. Gets the attribute of the specified type, or null if none.
GetAttributes | Overloaded. Gets the attributes of the specified type.
HasAttribute | Overloaded. Returns true if the code element has an attribute of the specified type.
ResolveAttributes | Resolves all the attributes.
Top

See Also

AttributeUtils Class
Gallio.Reflection Namespace


GetAttribute Generic Method

AttributeUtils.GetAttribute Generic Method

Gets the attribute of the specified type, or null if none.

Overload List

Name | Description
GetAttribute (ICodeElementInfo, Type, Boolean) | Gets the attribute of the specified type, or null if none.
GetAttribute (ICodeElementInfo, Boolean) | Gets the attribute of the specified type, or null if none.

See Also

AttributeUtils Class
Gallio.Reflection Namespace


GetAttribute Method (ICodeElementInfo, Type, Boolean)

AttributeUtils.GetAttribute Method (ICodeElementInfo, Type, Boolean)
See Also Example
[image]

Gets the attribute of the specified type, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAttribute( _
ByVal element As ICodeElementInfo, _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object
C#
public static object GetAttribute(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
C++
public:
static Object GetAttribute(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
J#
public static object GetAttribute(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
JScript
public static function GetAttribute(
element : ICodeElementInfo,
attributeType : Type,
inherit : bool
) : Object

Parameters

element
The code element
attributeType
The attribute type
inherit
If true, includes inherited attributes

Return Value

The attribute, or null if none

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the code element has multiple attributes of the specified type

See Also

AttributeUtils Class
Gallio.Reflection Namespace
AttributeUtils.GetAttribute Overload List


GetAttribute Generic Method (ICodeElementInfo, Boolean)

AttributeUtils.GetAttribute Generic Method (ICodeElementInfo, Boolean)
See Also Example
[image]

Gets the attribute of the specified type, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAttribute(Of T As Class)( _
ByVal element As ICodeElementInfo, _
ByVal inherit As Boolean _
)
C#
public static T GetAttribute<T>(
ICodeElementInfo element,
bool inherit
) where T : class
C++
public:
static T GetAttribute<T>(
ICodeElementInfo element,
bool inherit
)
J#
public static T GetAttribute<T>(
ICodeElementInfo element,
bool inherit
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The attribute type

Parameters

element
The code element
inherit
If true, includes inherited attributes

Return Value

The attribute, or null if none

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the code element has multiple attributes of the specified type

See Also

AttributeUtils Class
Gallio.Reflection Namespace
AttributeUtils.GetAttribute Overload List


GetAttributes Generic Method

AttributeUtils.GetAttributes Generic Method

Gets the attributes of the specified type.

Overload List

Name | Description
GetAttributes (ICodeElementInfo, Type, Boolean) | Gets the attributes of the specified type.
GetAttributes (ICodeElementInfo, Boolean) | Gets the attributes of the specified type.

See Also

AttributeUtils Class
Gallio.Reflection Namespace


GetAttributes Method (ICodeElementInfo, Type, Boolean)

AttributeUtils.GetAttributes Method (ICodeElementInfo, Type, Boolean)
See Also Example
[image]

Gets the attributes of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAttributes( _
ByVal element As ICodeElementInfo, _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As IEnumerable(Of Object)
C#
public static IEnumerable<object> GetAttributes(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
C++
public:
static IEnumerable<object> GetAttributes(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
J#
public static IEnumerable<object> GetAttributes(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
JScript
public static function GetAttributes(
element : ICodeElementInfo,
attributeType : Type,
inherit : bool
) : IEnumerable<object>

Parameters

element
The code element
attributeType
The attribute type
inherit
If true, includes inherited attributes

Return Value

The attributes

See Also

AttributeUtils Class
Gallio.Reflection Namespace
AttributeUtils.GetAttributes Overload List


GetAttributes Generic Method (ICodeElementInfo, Boolean)

AttributeUtils.GetAttributes Generic Method (ICodeElementInfo, Boolean)
See Also Example
[image]

Gets the attributes of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAttributes(Of T As Class)( _
ByVal element As ICodeElementInfo, _
ByVal inherit As Boolean _
) As IEnumerable(Of T)
C#
public static IEnumerable<T> GetAttributes<T>(
ICodeElementInfo element,
bool inherit
) where T : class
C++
public:
static IEnumerable<T> GetAttributes<T>(
ICodeElementInfo element,
bool inherit
)
J#
public static IEnumerable<T> GetAttributes<T>(
ICodeElementInfo element,
bool inherit
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The attribute type

Parameters

element
The code element
inherit
If true, includes inherited attributes

Return Value

The attributes

See Also

AttributeUtils Class
Gallio.Reflection Namespace
AttributeUtils.GetAttributes Overload List


HasAttribute Generic Method

AttributeUtils.HasAttribute Generic Method

Returns true if the code element has an attribute of the specified type.

Overload List

Name | Description
HasAttribute (ICodeElementInfo, Type, Boolean) | Returns true if the code element has an attribute of the specified type.
HasAttribute (ICodeElementInfo, Boolean) | Returns true if the code element has an attribute of the specified type.

See Also

AttributeUtils Class
Gallio.Reflection Namespace


HasAttribute Method (ICodeElementInfo, Type, Boolean)

AttributeUtils.HasAttribute Method (ICodeElementInfo, Type, Boolean)
See Also Example
[image]

Returns true if the code element has an attribute of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HasAttribute( _
ByVal element As ICodeElementInfo, _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean
C#
public static bool HasAttribute(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
C++
public:
static bool HasAttribute(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
J#
public static bool HasAttribute(
ICodeElementInfo element,
Type attributeType,
bool inherit
)
JScript
public static function HasAttribute(
element : ICodeElementInfo,
attributeType : Type,
inherit : bool
) : bool

Parameters

element
The code element
attributeType
The attribute type
inherit
If true, includes inherited attributes

Return Value

True if the code element has at least one attribute of the specified type

See Also

AttributeUtils Class
Gallio.Reflection Namespace
AttributeUtils.HasAttribute Overload List


HasAttribute Generic Method (ICodeElementInfo, Boolean)

AttributeUtils.HasAttribute Generic Method (ICodeElementInfo, Boolean)
See Also Example
[image]

Returns true if the code element has an attribute of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HasAttribute(Of T)( _
ByVal element As ICodeElementInfo, _
ByVal inherit As Boolean _
) As Boolean
C#
public static bool HasAttribute<T>(
ICodeElementInfo element,
bool inherit
)
C++
public:
static bool HasAttribute<T>(
ICodeElementInfo element,
bool inherit
)
J#
public static bool HasAttribute<T>(
ICodeElementInfo element,
bool inherit
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The attribute type

Parameters

element
The code element
inherit
If true, includes inherited attributes

Return Value

True if the code element has at least one attribute of the specified type

See Also

AttributeUtils Class
Gallio.Reflection Namespace
AttributeUtils.HasAttribute Overload List


ResolveAttributes Method

AttributeUtils.ResolveAttributes Method
[image]

Resolves all the attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveAttributes( _
ByVal attributes As IEnumerable(Of IAttributeInfo) _
) As IEnumerable(Of Object)
C#
public static IEnumerable<object> ResolveAttributes(
IEnumerable<IAttributeInfo> attributes
)
C++
public:
static IEnumerable<object> ResolveAttributes(
IEnumerable<IAttributeInfo> attributes
)
J#
public static IEnumerable<object> ResolveAttributes(
IEnumerable<IAttributeInfo> attributes
)
JScript
public static function ResolveAttributes(
attributes : IEnumerable<IAttributeInfo>
) : IEnumerable<object>

Parameters

attributes
The attribute descriptions

Return Value

The resolved attribute instances

Remarks

Omits attributes that cannot be resolved.

See Also

AttributeUtils Class
Gallio.Reflection Namespace


CodeElementKind Enumeration

CodeElementKind Enumeration
[image]

Describes the kind of code element represented by a ICodeElementInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum CodeElementKind
C#
public enum CodeElementKind
C++
public enum class CodeElementKind
J#
public enum CodeElementKind
JScript
public enum CodeElementKind

Members

Member Name | Description
Assembly | The element is an IAssemblyInfo.
Namespace | The element is an INamespaceInfo.
Type | The element is an ITypeInfo.
Field | The element is an IFieldInfo.
Property | The element is an IPropertyInfo.
Event | The element is an IEventInfo.
Constructor | The element is an Constructor.
Method | The element is an IMethodInfo.
Parameter | The element is an IParameterInfo.
GenericParameter | The element is an IGenericParameterInfo.

See Also

Gallio.Reflection Namespace


CodeElementSorter Class

CodeElementSorter Class
See Also Example Members
[image]

Sorts code elements in various ways. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module CodeElementSorter
C#
public static class CodeElementSorter
C++
ref class CodeElementSorter abstract sealed
J#
public final class CodeElementSorter
JScript
public class CodeElementSorter

Inheritance Hierarchy

System.Object
Gallio.Reflection.CodeElementSorter

See Also

CodeElementSorter Members
Gallio.Reflection Namespace


CodeElementSorter Members

CodeElementSorter Members
See Also Example Methods
[image]

Sorts code elements in various ways. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by CodeElementSorter.

Public Methods

Name | Description
SortMembersByDeclaringType | Sorts members such that those declared by supertypes appear before those declared by subtypes.
Top

See Also

CodeElementSorter Class
Gallio.Reflection Namespace


Methods

CodeElementSorter Methods
[image]

Public Methods

Name | Description
SortMembersByDeclaringType | Sorts members such that those declared by supertypes appear before those declared by subtypes.
Top

See Also

CodeElementSorter Class
Gallio.Reflection Namespace


SortMembersByDeclaringType Generic Method

CodeElementSorter.SortMembersByDeclaringType Generic Method
[image]

Sorts members such that those declared by supertypes appear before those declared by subtypes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SortMembersByDeclaringType(Of T As IMemberInfo)( _
ByVal members As IEnumerable(Of T) _
) As IList(Of T)
C#
public static IList<T> SortMembersByDeclaringType<T>(
IEnumerable<T> members
) where T : IMemberInfo
C++
public:
static IList<T> SortMembersByDeclaringType<T>(
IEnumerable<T> members
)
J#
public static IList<T> SortMembersByDeclaringType<T>(
IEnumerable<T> members
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of member

Parameters

members
The members to sort

Return Value

The sorted members

See Also

CodeElementSorter Class
Gallio.Reflection Namespace
DeclaringTypeComparer


CodeLocation Structure

CodeLocation Structure
See Also Example Members
[image]

Specifies the location of a code element as a position within a file.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlSchemaProviderAttribute("ProvideXmlSchema"), _
XmlRootAttribute("codeLocation", Namespace := "http://www.gallio.org/")>
Public Structure CodeLocation
Implements IEquatable(Of CodeLocation), IXmlSerializable, ISerializable
C#
[SerializableAttribute]
[XmlSchemaProviderAttribute("ProvideXmlSchema")]
[XmlRootAttribute("codeLocation", Namespace = "http://www.gallio.org/")]
public struct CodeLocation : IEquatable<CodeLocation>, IXmlSerializable, ISerializable
C++
[SerializableAttribute]
[XmlSchemaProviderAttribute(L"ProvideXmlSchema")]
[XmlRootAttribute(L"codeLocation", Namespace = L"http://www.gallio.org/")]
value class CodeLocation : IEquatable<CodeLocation>, IXmlSerializable, ISerializable
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlSchemaProviderAttribute("ProvideXmlSchema") */
/** @attribute XmlRootAttribute("codeLocation", Namespace = "http://www.gallio.org/") */
public final class CodeLocation extends ValueType implements IEquatable<CodeLocation>, IXmlSerializable, ISerializable
JScript
JScript suports the use of structures, but not the declaration of new ones.

Remarks

Lines and columns are numbered starting from 1.

Inheritance Hierarchy

System.Object
Gallio.Reflection.CodeLocation

See Also

CodeLocation Members
Gallio.Reflection Namespace


CodeLocation Members

CodeLocation Members
See Also Example Constructors Fields Properties Methods
[image]

Specifies the location of a code element as a position within a file.

The following tables list the members exposed by CodeLocation.

Public Constructors

 | Name | Description
Public method | CodeLocation | Creates a code location.
Top

Public Fields

Name | Description
Unknown | Gets an empty code location with a null path and no line or column number information. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | Column | Gets the column number, or 0 if unknown.
Public property | Line | Gets the line number, or 0 if unknown.
Public property | Path | Gets the path or Uri of a resource that contains the code element, such as a source file or assembly, or null if unknown.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetObjectData | Allows the code location structure to control its own serialization and deserialization.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two code locations for equality.
 | op_Inequality | Compares two code locations for inequality.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Overridden. Converts the location to a string of the form "path(line,column)", "path(line)" or "path" depending on which components are available.
Top

See Also

CodeLocation Structure
Gallio.Reflection Namespace


CodeLocation Constructor

CodeLocation Constructor
[image]

Creates a code location.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal path As String, _
ByVal line As Integer, _
ByVal column As Integer _
)
C#
public CodeLocation(
string path,
int line,
int column
)
C++
public:
CodeLocation(
String path,
int line,
int column
) sealed
J#
public CodeLocation(
string path,
int line,
int column
)
JScript
public function CodeLocation(
path : String,
line : int,
column : int
)

Parameters

path
The path or Uri of a resource that contains the code element, such as a source file or assembly, or null if unknown
line
The line number, or 0 if unknown
column
The column number, or 0 if unknown

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if line or column is less than 0
ArgumentException | Thrown if path is null and line is non-zero, or if line is 0 and column is non-zero

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Fields

CodeLocation Fields
[image]

Public Fields

Name | Description
Unknown | Gets an empty code location with a null path and no line or column number information. This field is read-only.
Top

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Unknown Field

CodeLocation.Unknown Field
[image]

Gets an empty code location with a null path and no line or column number information. This field is read-only.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Unknown As CodeLocation
C#
public static readonly CodeLocation Unknown;
C++
public:
static const CodeLocation Unknown;
J#
public static final CodeLocation Unknown
JScript
public static const var Unknown : CodeLocation;

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Properties

CodeLocation Properties
[image]

Public Properties

 | Name | Description
Public property | Column | Gets the column number, or 0 if unknown.
Public property | Line | Gets the line number, or 0 if unknown.
Public property | Path | Gets the path or Uri of a resource that contains the code element, such as a source file or assembly, or null if unknown.
Top

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Column Property

CodeLocation.Column Property
[image]

Gets the column number, or 0 if unknown.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As Integer
C#
public int Column { get; }
C++
public property int Column sealed {
int get();
}
J#
/** property */
public int get_Column();
JScript
public function get Column() : int

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Line Property

CodeLocation.Line Property
[image]

Gets the line number, or 0 if unknown.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Line As Integer
C#
public int Line { get; }
C++
public property int Line sealed {
int get();
}
J#
/** property */
public int get_Line();
JScript
public function get Line() : int

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Path Property

CodeLocation.Path Property
[image]

Gets the path or Uri of a resource that contains the code element, such as a source file or assembly, or null if unknown.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Path As String
C#
public string Path { get; }
C++
public property string Path sealed {
String get();
}
J#
/** property */
public string get_Path();
JScript
public function get Path() : String

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Methods

CodeLocation Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetObjectData | Allows the code location structure to control its own serialization and deserialization.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two code locations for equality.
 | op_Inequality | Compares two code locations for inequality.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Overridden. Converts the location to a string of the form "path(line,column)", "path(line)" or "path" depending on which components are available.
Top

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Equals Method

CodeLocation.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (CodeLocation) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

CodeLocation Structure
Gallio.Reflection Namespace


Equals Method (CodeLocation)

CodeLocation.Equals Method (CodeLocation)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As CodeLocation _
) As Boolean _
Implements IEquatable<CodeLocation>.Equals
C#
public bool Equals(
CodeLocation other
)
C++
public:
bool Equals(
CodeLocation other
) sealed
J#
public bool Equals(
CodeLocation other
)
JScript
public function Equals(
other : CodeLocation
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<CodeLocation>.Equals

See Also

CodeLocation Structure
Gallio.Reflection Namespace
CodeLocation.Equals Overload List


Equals Method (Object)

CodeLocation.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

CodeLocation Structure
Gallio.Reflection Namespace
CodeLocation.Equals Overload List


GetHashCode Method

CodeLocation.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

CodeLocation Structure
Gallio.Reflection Namespace


GetObjectData Method

CodeLocation.GetObjectData Method
[image]

Allows the code location structure to control its own serialization and deserialization.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
C#
public void GetObjectData(
SerializationInfo info,
StreamingContext context
)
C++
public:
void GetObjectData(
SerializationInfo info,
StreamingContext context
) sealed
J#
public void GetObjectData(
SerializationInfo info,
StreamingContext context
)
JScript
public function GetObjectData(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info to populate with data.
context
The destination for this serialization.

Implements

ISerializable.GetObjectData

See Also

CodeLocation Structure
Gallio.Reflection Namespace


op_Equality Operator

CodeLocation.op_Equality Operator
[image]

Compares two code locations for equality.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As CodeLocation, _
ByVal b As CodeLocation _
) As Boolean
C#
public static bool operator ==(
CodeLocation a,
CodeLocation b
)
C++
public:
static bool operator ==(
CodeLocation a,
CodeLocation b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first code location
b
The second code location

Return Value

True if the code locations are equal

See Also

CodeLocation Structure
Gallio.Reflection Namespace


op_Inequality Operator

CodeLocation.op_Inequality Operator
[image]

Compares two code locations for inequality.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As CodeLocation, _
ByVal b As CodeLocation _
) As Boolean
C#
public static bool operator !=(
CodeLocation a,
CodeLocation b
)
C++
public:
static bool operator !=(
CodeLocation a,
CodeLocation b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first code location
b
The second code location

Return Value

True if the code references are not equal

See Also

CodeLocation Structure
Gallio.Reflection Namespace


ProvideXmlSchema Method

CodeLocation.ProvideXmlSchema Method
[image]

Provides the Xml schema for this element.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ProvideXmlSchema( _
ByVal schemas As XmlSchemaSet _
) As XmlQualifiedName
C#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
C++
public:
static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
J#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
JScript
public static function ProvideXmlSchema(
schemas : XmlSchemaSet
) : XmlQualifiedName

Parameters

schemas
The schema set

Return Value

The schema type of the element

See Also

CodeLocation Structure
Gallio.Reflection Namespace


ToString Method

CodeLocation.ToString Method
[image]

Converts the location to a string of the form "path(line,column)", "path(line)" or "path" depending on which components are available.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The code location as a string or "(unknown)" if unknown

See Also

CodeLocation Structure
Gallio.Reflection Namespace


CodeReference Structure

CodeReference Structure
See Also Example Members
[image]

A code reference is a pointer into the structure of a .Net program for use in describing the location of a certain code construct to the user. It is typically used to identify the point of definition of a test component.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("codeReference", Namespace := "http://www.gallio.org/"), _
XmlSchemaProviderAttribute("ProvideXmlSchema")>
Public Structure CodeReference
Implements IEquatable(Of CodeReference), IXmlSerializable
C#
[SerializableAttribute]
[XmlRootAttribute("codeReference", Namespace = "http://www.gallio.org/")]
[XmlSchemaProviderAttribute("ProvideXmlSchema")]
public struct CodeReference : IEquatable<CodeReference>, IXmlSerializable
C++
[SerializableAttribute]
[XmlRootAttribute(L"codeReference", Namespace = L"http://www.gallio.org/")]
[XmlSchemaProviderAttribute(L"ProvideXmlSchema")]
value class CodeReference : IEquatable<CodeReference>, IXmlSerializable
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("codeReference", Namespace = "http://www.gallio.org/") */
/** @attribute XmlSchemaProviderAttribute("ProvideXmlSchema") */
public final class CodeReference extends ValueType implements IEquatable<CodeReference>, IXmlSerializable
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Reflection.CodeReference

See Also

CodeReference Members
Gallio.Reflection Namespace


CodeReference Members

CodeReference Members
See Also Example Constructors Fields Properties Methods
[image]

A code reference is a pointer into the structure of a .Net program for use in describing the location of a certain code construct to the user. It is typically used to identify the point of definition of a test component.

The following tables list the members exposed by CodeReference.

Public Constructors

 | Name | Description
Public method | CodeReference | Creates a code reference from strings.
Top

Public Fields

Name | Description
Unknown | Gets an empty code reference used to indicate that the actual reference is unknown. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | AssemblyName | Gets the assembly name, or null if none.
Public property | Kind | Gets the kind of code element specified by the code reference.
Public property | MemberName | Gets the member name, or null if none.
Public property | NamespaceName | Gets the namespace name, or null if none.
Public property | ParameterName | Gets the parameter name, or null if none.
Public property | TypeName | Gets the fully-qualified type name, or null if none.
Top

Public Methods

 | Name | Description
 | CreateFromAssembly | Creates a code reference from an assembly.
 | CreateFromMember | Creates a code reference from a member.
 | CreateFromNamespace | Creates a code reference from an namespace name.
 | CreateFromParameter | Creates a code reference from a method parameter.
 | CreateFromType | Creates a code reference from a type.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two code references for equality.
 | op_Inequality | Compares two code references for inequality.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Overridden. Produces a human-readable description of the code reference.
Top

See Also

CodeReference Structure
Gallio.Reflection Namespace


CodeReference Constructor

CodeReference Constructor
[image]

Creates a code reference from strings.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyName As String, _
ByVal namespaceName As String, _
ByVal typeName As String, _
ByVal memberName As String, _
ByVal parameterName As String _
)
C#
public CodeReference(
string assemblyName,
string namespaceName,
string typeName,
string memberName,
string parameterName
)
C++
public:
CodeReference(
String assemblyName,
String namespaceName,
String typeName,
String memberName,
String parameterName
) sealed
J#
public CodeReference(
string assemblyName,
string namespaceName,
string typeName,
string memberName,
string parameterName
)
JScript
public function CodeReference(
assemblyName : String,
namespaceName : String,
typeName : String,
memberName : String,
parameterName : String
)

Parameters

assemblyName
The assembly name, or null if none
namespaceName
The namespace name, or null if none
typeName
The fully-qualified type name, or null if none
memberName
The member name, or null if none
parameterName
The parameter name, or null if none

See Also

CodeReference Structure
Gallio.Reflection Namespace


Fields

CodeReference Fields
[image]

Public Fields

Name | Description
Unknown | Gets an empty code reference used to indicate that the actual reference is unknown. This field is read-only.
Top

See Also

CodeReference Structure
Gallio.Reflection Namespace


Unknown Field

CodeReference.Unknown Field
[image]

Gets an empty code reference used to indicate that the actual reference is unknown. This field is read-only.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Unknown As CodeReference
C#
public static readonly CodeReference Unknown;
C++
public:
static const CodeReference Unknown;
J#
public static final CodeReference Unknown
JScript
public static const var Unknown : CodeReference;

See Also

CodeReference Structure
Gallio.Reflection Namespace


Properties

CodeReference Properties
[image]

Public Properties

 | Name | Description
Public property | AssemblyName | Gets the assembly name, or null if none.
Public property | Kind | Gets the kind of code element specified by the code reference.
Public property | MemberName | Gets the member name, or null if none.
Public property | NamespaceName | Gets the namespace name, or null if none.
Public property | ParameterName | Gets the parameter name, or null if none.
Public property | TypeName | Gets the fully-qualified type name, or null if none.
Top

See Also

CodeReference Structure
Gallio.Reflection Namespace


AssemblyName Property

CodeReference.AssemblyName Property
[image]

Gets the assembly name, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyName As String
C#
public string AssemblyName { get; }
C++
public property string AssemblyName sealed {
String get();
}
J#
/** property */
public string get_AssemblyName();
JScript
public function get AssemblyName() : String

See Also

CodeReference Structure
Gallio.Reflection Namespace


Kind Property

CodeReference.Kind Property
[image]

Gets the kind of code element specified by the code reference.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property Kind As CodeReferenceKind
C#
[XmlIgnoreAttribute]
public CodeReferenceKind Kind { get; }
C++
[XmlIgnoreAttribute]
public property CodeReferenceKind Kind sealed {
CodeReferenceKind get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public CodeReferenceKind get_Kind();
JScript
public function get Kind() : CodeReferenceKind

See Also

CodeReference Structure
Gallio.Reflection Namespace


MemberName Property

CodeReference.MemberName Property
[image]

Gets the member name, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MemberName As String
C#
public string MemberName { get; }
C++
public property string MemberName sealed {
String get();
}
J#
/** property */
public string get_MemberName();
JScript
public function get MemberName() : String

See Also

CodeReference Structure
Gallio.Reflection Namespace


NamespaceName Property

CodeReference.NamespaceName Property
[image]

Gets the namespace name, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NamespaceName As String
C#
public string NamespaceName { get; }
C++
public property string NamespaceName sealed {
String get();
}
J#
/** property */
public string get_NamespaceName();
JScript
public function get NamespaceName() : String

See Also

CodeReference Structure
Gallio.Reflection Namespace


ParameterName Property

CodeReference.ParameterName Property
[image]

Gets the parameter name, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParameterName As String
C#
public string ParameterName { get; }
C++
public property string ParameterName sealed {
String get();
}
J#
/** property */
public string get_ParameterName();
JScript
public function get ParameterName() : String

See Also

CodeReference Structure
Gallio.Reflection Namespace


TypeName Property

CodeReference.TypeName Property
[image]

Gets the fully-qualified type name, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
C++
public property string TypeName sealed {
String get();
}
J#
/** property */
public string get_TypeName();
JScript
public function get TypeName() : String

See Also

CodeReference Structure
Gallio.Reflection Namespace


Methods

CodeReference Methods
[image]

Public Methods

 | Name | Description
 | CreateFromAssembly | Creates a code reference from an assembly.
 | CreateFromMember | Creates a code reference from a member.
 | CreateFromNamespace | Creates a code reference from an namespace name.
 | CreateFromParameter | Creates a code reference from a method parameter.
 | CreateFromType | Creates a code reference from a type.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two code references for equality.
 | op_Inequality | Compares two code references for inequality.
 | ProvideXmlSchema | Provides the Xml schema for this element.
Public method | ToString | Overridden. Produces a human-readable description of the code reference.
Top

See Also

CodeReference Structure
Gallio.Reflection Namespace


CreateFromAssembly Method

CodeReference.CreateFromAssembly Method
[image]

Creates a code reference from an assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromAssembly( _
ByVal assembly As Assembly _
) As CodeReference
C#
public static CodeReference CreateFromAssembly(
Assembly assembly
)
C++
public:
static CodeReference CreateFromAssembly(
Assembly assembly
)
J#
public static CodeReference CreateFromAssembly(
Assembly assembly
)
JScript
public static function CreateFromAssembly(
assembly : Assembly
) : CodeReference

Parameters

assembly
The assembly

Return Value

The code reference

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

CodeReference Structure
Gallio.Reflection Namespace


CreateFromMember Method

CodeReference.CreateFromMember Method
[image]

Creates a code reference from a member.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromMember( _
ByVal member As MemberInfo _
) As CodeReference
C#
public static CodeReference CreateFromMember(
MemberInfo member
)
C++
public:
static CodeReference CreateFromMember(
MemberInfo member
)
J#
public static CodeReference CreateFromMember(
MemberInfo member
)
JScript
public static function CreateFromMember(
member : MemberInfo
) : CodeReference

Parameters

member
The member

Return Value

The code reference

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if member is null

See Also

CodeReference Structure
Gallio.Reflection Namespace


CreateFromNamespace Method

CodeReference.CreateFromNamespace Method
[image]

Creates a code reference from an namespace name.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromNamespace( _
ByVal namespaceName As String _
) As CodeReference
C#
public static CodeReference CreateFromNamespace(
string namespaceName
)
C++
public:
static CodeReference CreateFromNamespace(
String namespaceName
)
J#
public static CodeReference CreateFromNamespace(
string namespaceName
)
JScript
public static function CreateFromNamespace(
namespaceName : String
) : CodeReference

Parameters

namespaceName
The namespace name

Return Value

The code reference

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if namespaceName is null

See Also

CodeReference Structure
Gallio.Reflection Namespace


CreateFromParameter Method

CodeReference.CreateFromParameter Method
[image]

Creates a code reference from a method parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromParameter( _
ByVal parameter As ParameterInfo _
) As CodeReference
C#
public static CodeReference CreateFromParameter(
ParameterInfo parameter
)
C++
public:
static CodeReference CreateFromParameter(
ParameterInfo parameter
)
J#
public static CodeReference CreateFromParameter(
ParameterInfo parameter
)
JScript
public static function CreateFromParameter(
parameter : ParameterInfo
) : CodeReference

Parameters

parameter
The parameter

Return Value

The code reference

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if parameter is null

See Also

CodeReference Structure
Gallio.Reflection Namespace


CreateFromType Method

CodeReference.CreateFromType Method
[image]

Creates a code reference from a type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromType( _
ByVal type As Type _
) As CodeReference
C#
public static CodeReference CreateFromType(
Type type
)
C++
public:
static CodeReference CreateFromType(
Type type
)
J#
public static CodeReference CreateFromType(
Type type
)
JScript
public static function CreateFromType(
type : Type
) : CodeReference

Parameters

type
The type

Return Value

The code reference

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

CodeReference Structure
Gallio.Reflection Namespace


Equals Method

CodeReference.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (CodeReference) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

CodeReference Structure
Gallio.Reflection Namespace


Equals Method (CodeReference)

CodeReference.Equals Method (CodeReference)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As CodeReference _
) As Boolean _
Implements IEquatable<CodeReference>.Equals
C#
public bool Equals(
CodeReference other
)
C++
public:
bool Equals(
CodeReference other
) sealed
J#
public bool Equals(
CodeReference other
)
JScript
public function Equals(
other : CodeReference
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<CodeReference>.Equals

See Also

CodeReference Structure
Gallio.Reflection Namespace
CodeReference.Equals Overload List


Equals Method (Object)

CodeReference.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

CodeReference Structure
Gallio.Reflection Namespace
CodeReference.Equals Overload List


GetHashCode Method

CodeReference.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

CodeReference Structure
Gallio.Reflection Namespace


op_Equality Operator

CodeReference.op_Equality Operator
[image]

Compares two code references for equality.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As CodeReference, _
ByVal b As CodeReference _
) As Boolean
C#
public static bool operator ==(
CodeReference a,
CodeReference b
)
C++
public:
static bool operator ==(
CodeReference a,
CodeReference b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first code reference
b
The second code reference

Return Value

True if the code references are equal

See Also

CodeReference Structure
Gallio.Reflection Namespace


op_Inequality Operator

CodeReference.op_Inequality Operator
[image]

Compares two code references for inequality.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As CodeReference, _
ByVal b As CodeReference _
) As Boolean
C#
public static bool operator !=(
CodeReference a,
CodeReference b
)
C++
public:
static bool operator !=(
CodeReference a,
CodeReference b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first code reference
b
The second code reference

Return Value

True if the code references are not equal

See Also

CodeReference Structure
Gallio.Reflection Namespace


ProvideXmlSchema Method

CodeReference.ProvideXmlSchema Method
[image]

Provides the Xml schema for this element.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ProvideXmlSchema( _
ByVal schemas As XmlSchemaSet _
) As XmlQualifiedName
C#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
C++
public:
static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
J#
public static XmlQualifiedName ProvideXmlSchema(
XmlSchemaSet schemas
)
JScript
public static function ProvideXmlSchema(
schemas : XmlSchemaSet
) : XmlQualifiedName

Parameters

schemas
The schema set

Return Value

The schema type of the element

See Also

CodeReference Structure
Gallio.Reflection Namespace


ToString Method

CodeReference.ToString Method
[image]

Produces a human-readable description of the code reference.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A description of the code reference

See Also

CodeReference Structure
Gallio.Reflection Namespace


CodeReferenceKind Enumeration

CodeReferenceKind Enumeration
[image]

Describes the kind of code element specified by a CodeReference.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum CodeReferenceKind
C#
public enum CodeReferenceKind
C++
public enum class CodeReferenceKind
J#
public enum CodeReferenceKind
JScript
public enum CodeReferenceKind

Members

Member Name | Description
Unknown | The code reference is unknown.
Assembly | The code reference specifies an assembly.
Namespace | The code reference specifies a namespace.
Type | The code reference specifies a type.
Member | The code reference specifies a constructor, method, property, field or event.
Parameter | The code reference specifies a parameter of a constructor or method.

See Also

Gallio.Reflection Namespace


ConstantValue Structure

ConstantValue Structure
See Also Example Members
[image]

Specifies a typed constant value.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure ConstantValue
C#
public struct ConstantValue
C++
value class ConstantValue
J#
public final class ConstantValue extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Reflection.ConstantValue

See Also

ConstantValue Members
Gallio.Reflection Namespace


ConstantValue Members

ConstantValue Members
See Also Example Constructors Properties Methods
[image]

Specifies a typed constant value.

The following tables list the members exposed by ConstantValue.

Public Constructors

 | Name | Description
Public method | ConstantValue | Creates a constant value.
Top

Public Properties

Name | Description
Public property | IsArray | Returns true if the value is an array.
Public property | IsEnum | Returns true if the value is an enum.
Public property | IsNative | Returns true if the contents of Value can be interpreted as a native value or false if Resolve must be used to resolve the constant to a native value.
Public property | IsType | Returns true if the value is a type.
Public property Type

Gets the type of the constant.

The type may be an array type, an enum type, a primitive type, or the Type type.

Public property Value

Gets the value of the constant.

If IsNative is true, then this property contains the native value. Otherwise it is represented differently depending upon its type.

  • If the constant is a primitive value, then the value will be a primitive value such as an integer, string, float or null.
  • If the constant is an enum, then the value will be a primitive value of the underlying type of the enum.
  • If the constant is an array, then the value will be an array of ConstantValue objects representing the elements of the array.
  • If the constant is a type, then the value will be a ITypeInfo.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
 | FromNative | Creates a constant value that wraps an existing native value.
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Resolve | Resolves the constant to a native value by replacing type references with actual Type values, arrays of constants with Array values of the appropriate type, and enums with Enum values.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

ConstantValue Structure
Gallio.Reflection Namespace


ConstantValue Constructor

ConstantValue Constructor
[image]

Creates a constant value.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As ITypeInfo, _
ByVal value As Object _
)
C#
public ConstantValue(
ITypeInfo type,
object value
)
C++
public:
ConstantValue(
ITypeInfo type,
Object value
) sealed
J#
public ConstantValue(
ITypeInfo type,
object value
)
JScript
public function ConstantValue(
type : ITypeInfo,
value : Object
)

Parameters

type
The constant value type
value
The constant value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

ConstantValue Structure
Gallio.Reflection Namespace


Properties

ConstantValue Properties
[image]

Public Properties

Name | Description
Public property | IsArray | Returns true if the value is an array.
Public property | IsEnum | Returns true if the value is an enum.
Public property | IsNative | Returns true if the contents of Value can be interpreted as a native value or false if Resolve must be used to resolve the constant to a native value.
Public property | IsType | Returns true if the value is a type.
Public property Type

Gets the type of the constant.

The type may be an array type, an enum type, a primitive type, or the Type type.

Public property Value

Gets the value of the constant.

If IsNative is true, then this property contains the native value. Otherwise it is represented differently depending upon its type.

  • If the constant is a primitive value, then the value will be a primitive value such as an integer, string, float or null.
  • If the constant is an enum, then the value will be a primitive value of the underlying type of the enum.
  • If the constant is an array, then the value will be an array of ConstantValue objects representing the elements of the array.
  • If the constant is a type, then the value will be a ITypeInfo.
Top

See Also

ConstantValue Structure
Gallio.Reflection Namespace


IsArray Property

ConstantValue.IsArray Property
[image]

Returns true if the value is an array.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsArray As Boolean
C#
public bool IsArray { get; }
C++
public property bool IsArray sealed {
bool get();
}
J#
/** property */
public bool get_IsArray();
JScript
public function get IsArray() : bool

See Also

ConstantValue Structure
Gallio.Reflection Namespace


IsEnum Property

ConstantValue.IsEnum Property
[image]

Returns true if the value is an enum.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEnum As Boolean
C#
public bool IsEnum { get; }
C++
public property bool IsEnum sealed {
bool get();
}
J#
/** property */
public bool get_IsEnum();
JScript
public function get IsEnum() : bool

See Also

ConstantValue Structure
Gallio.Reflection Namespace


IsNative Property

ConstantValue.IsNative Property
[image]

Returns true if the contents of Value can be interpreted as a native value or false if Resolve must be used to resolve the constant to a native value.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNative As Boolean
C#
public bool IsNative { get; }
C++
public property bool IsNative sealed {
bool get();
}
J#
/** property */
public bool get_IsNative();
JScript
public function get IsNative() : bool

See Also

ConstantValue Structure
Gallio.Reflection Namespace


IsType Property

ConstantValue.IsType Property
[image]

Returns true if the value is a type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsType As Boolean
C#
public bool IsType { get; }
C++
public property bool IsType sealed {
bool get();
}
J#
/** property */
public bool get_IsType();
JScript
public function get IsType() : bool

See Also

ConstantValue Structure
Gallio.Reflection Namespace


Type Property

ConstantValue.Type Property
[image]

Gets the type of the constant.

The type may be an array type, an enum type, a primitive type, or the Type type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ITypeInfo
C#
public ITypeInfo Type { get; }
C++
public property ITypeInfo Type sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_Type();
JScript
public function get Type() : ITypeInfo

See Also

ConstantValue Structure
Gallio.Reflection Namespace


Value Property

ConstantValue.Value Property
[image]

Gets the value of the constant.

If IsNative is true, then this property contains the native value. Otherwise it is represented differently depending upon its type.

  • If the constant is a primitive value, then the value will be a primitive value such as an integer, string, float or null.
  • If the constant is an enum, then the value will be a primitive value of the underlying type of the enum.
  • If the constant is an array, then the value will be an array of ConstantValue objects representing the elements of the array.
  • If the constant is a type, then the value will be a ITypeInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value { get; }
C++
public property object Value sealed {
Object get();
}
J#
/** property */
public object get_Value();
JScript
public function get Value() : Object

See Also

ConstantValue Structure
Gallio.Reflection Namespace


Methods

ConstantValue Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
 | FromNative | Creates a constant value that wraps an existing native value.
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Resolve | Resolves the constant to a native value by replacing type references with actual Type values, arrays of constants with Array values of the appropriate type, and enums with Enum values.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

ConstantValue Structure
Gallio.Reflection Namespace


FromNative Method

ConstantValue.FromNative Method
[image]

Creates a constant value that wraps an existing native value.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FromNative( _
ByVal value As Object _
) As ConstantValue
C#
public static ConstantValue FromNative(
object value
)
C++
public:
static ConstantValue FromNative(
Object value
)
J#
public static ConstantValue FromNative(
object value
)
JScript
public static function FromNative(
value : Object
) : ConstantValue

Parameters

value
The native value

Return Value

The constant

See Also

ConstantValue Structure
Gallio.Reflection Namespace


Resolve Method

ConstantValue.Resolve Method
[image]

Resolves the constant to a native value by replacing type references with actual Type values, arrays of constants with Array values of the appropriate type, and enums with Enum values.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As Object
C#
public object Resolve(
bool throwOnError
)
C++
public:
Object Resolve(
bool throwOnError
) sealed
J#
public object Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : Object

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise the result may include unresolved types, enums or arrays

Return Value

The native constant value

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

ConstantValue Structure
Gallio.Reflection Namespace


DeclaringTypeComparer Generic Class

DeclaringTypeComparer Generic Class
See Also Example Members
[image]

Sorts an members that all belong to the same type such that the members declared by supertypes appear before those declared by subtypes. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DeclaringTypeComparer(Of T As IMemberInfo)
Implements IComparer(Of T)
C#
public sealed class DeclaringTypeComparer<T> : IComparer<T> where T : IMemberInfo
C++
ref class DeclaringTypeComparer<T> sealed : IComparer<T> where T : IMemberInfo
J#
public final class DeclaringTypeComparer<T> implements IComparer<T>
JScript
JScript does not support generic types and methods.

Example

If type A derives from types B and if type C derives from B then given methods A.Foo, A.Bar, B.Foo, C.Quux one possible sorted order will be: B.Foo, C.Quux, A.Bar, A.Foo. The members are not sorted by name or by any other criterion except by relative specificity of the declaring types.

Inheritance Hierarchy

System.Object
Gallio.Reflection.DeclaringTypeComparer<T>

See Also

DeclaringTypeComparer<T> Members
Gallio.Reflection Namespace


DeclaringTypeComparer<T> Members

DeclaringTypeComparer Members
See Also Example Fields Methods
[image]

Sorts an members that all belong to the same type such that the members declared by supertypes appear before those declared by subtypes. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by DeclaringTypeComparer<T>.

Public Fields

Name | Description
Instance | Gets the singleton instance of the comparer. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DeclaringTypeComparer<T> Class
Gallio.Reflection Namespace


Fields

DeclaringTypeComparer Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the comparer. This field is read-only.
Top

See Also

DeclaringTypeComparer<T> Class
Gallio.Reflection Namespace


Instance Field

DeclaringTypeComparer.Instance Field
[image]

Gets the singleton instance of the comparer. This field is read-only.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As DeclaringTypeComparer(Of T)
C#
public static readonly DeclaringTypeComparer<T> Instance;
C++
public:
static const DeclaringTypeComparer<T> Instance;
J#
public static final DeclaringTypeComparer<T> Instance
JScript
JScript does not support generic types and methods.

See Also

DeclaringTypeComparer<T> Class
Gallio.Reflection Namespace


Methods

DeclaringTypeComparer Methods
[image]

Public Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DeclaringTypeComparer<T> Class
Gallio.Reflection Namespace


Compare Method

DeclaringTypeComparer.Compare Method
[image]

Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Compare( _
ByVal x As T, _
ByVal y As T _
) As Integer _
Implements IComparer<T>.Compare
C#
public int Compare(
T x,
T y
)
C++
public:
int Compare(
T x,
T y
) sealed
J#
public int Compare(
T x,
T y
)
JScript
JScript does not support generic types and methods.

Parameters

x
The first object to compare.
y
The second object to compare.

Return Value

Value Condition Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.

Implements

IComparer<T>.Compare

See Also

DeclaringTypeComparer<T> Class
Gallio.Reflection Namespace


IAssemblyInfo Interface

IAssemblyInfo Interface
See Also Example Members
[image]

A Assembly reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAssemblyInfo
Implements ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IAssemblyInfo)
C#
public interface IAssemblyInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IAssemblyInfo>
C++
interface class IAssemblyInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IAssemblyInfo>
J#
public interface IAssemblyInfo implements ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IAssemblyInfo>
JScript
public interface IAssemblyInfo extends ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IAssemblyInfo>

Types that implement IAssemblyInfo

Type | Description
Gallio.Reflection.Impl.StaticAssemblyWrapper | A StaticReflectionPolicy assembly wrapper. This class cannot be inherited.

See Also

IAssemblyInfo Members
Gallio.Reflection Namespace


IAssemblyInfo Members

IAssemblyInfo Members
See Also Example Properties Methods
[image]

A Assembly reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IAssemblyInfo.

Public Properties

 | Name | Description
Public property | FullName | Gets the full name of the assembly.
Public property | Path | Gets the codebase of the assembly as a local path if possible or as a Uri otherwise.
Top

Public Methods

 | Name | Description
Public method | GetExportedTypes | Gets the public types exported by the assembly.
Public method | GetName | Gets the AssemblyName of the assembly.
Public method | GetReferencedAssemblies | Gets the names of the assemblies referenced by this assembly.
Public method | GetType | Gets a public type by name, or null if not found.
Public method | GetTypes | Gets all of the types in an assembly.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


Properties

IAssemblyInfo Properties
[image]

Public Properties

 | Name | Description
Public property | FullName | Gets the full name of the assembly.
Public property | Path | Gets the codebase of the assembly as a local path if possible or as a Uri otherwise.
Top

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


FullName Property

IAssemblyInfo.FullName Property
[image]

Gets the full name of the assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullName As String
C#
string FullName { get; }
C++
property string FullName abstract {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


Path Property

IAssemblyInfo.Path Property
[image]

Gets the codebase of the assembly as a local path if possible or as a Uri otherwise.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Path As String
C#
string Path { get; }
C++
property string Path abstract {
String get();
}
J#
/** property */
public string get_Path();
JScript
public function get Path() : String

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


Methods

IAssemblyInfo Methods
[image]

Public Methods

 | Name | Description
Public method | GetExportedTypes | Gets the public types exported by the assembly.
Public method | GetName | Gets the AssemblyName of the assembly.
Public method | GetReferencedAssemblies | Gets the names of the assemblies referenced by this assembly.
Public method | GetType | Gets a public type by name, or null if not found.
Public method | GetTypes | Gets all of the types in an assembly.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


GetExportedTypes Method

IAssemblyInfo.GetExportedTypes Method
[image]

Gets the public types exported by the assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetExportedTypes() As IList(Of ITypeInfo)
C#
IList<ITypeInfo> GetExportedTypes()
C++
IList<ITypeInfo> GetExportedTypes() abstract
J#
IList<ITypeInfo> GetExportedTypes()
JScript
function GetExportedTypes() : IList<ITypeInfo>

Return Value

The exported types

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


GetName Method

IAssemblyInfo.GetName Method
[image]

Gets the AssemblyName of the assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetName() As AssemblyName
C#
AssemblyName GetName()
C++
AssemblyName GetName() abstract
J#
AssemblyName GetName()
JScript
function GetName() : AssemblyName

Return Value

The assembly name

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


GetReferencedAssemblies Method

IAssemblyInfo.GetReferencedAssemblies Method
[image]

Gets the names of the assemblies referenced by this assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetReferencedAssemblies() As IList(Of AssemblyName)
C#
IList<AssemblyName> GetReferencedAssemblies()
C++
IList<AssemblyName> GetReferencedAssemblies() abstract
J#
IList<AssemblyName> GetReferencedAssemblies()
JScript
function GetReferencedAssemblies() : IList<AssemblyName>

Return Value

The names of the references assemblies

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


GetType Method

IAssemblyInfo.GetType Method
[image]

Gets a public type by name, or null if not found.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetType( _
ByVal typeName As String _
) As ITypeInfo
C#
ITypeInfo GetType(
string typeName
)
C++
ITypeInfo GetType(
String typeName
) abstract
J#
ITypeInfo GetType(
string typeName
)
JScript
function GetType(
typeName : String
) : ITypeInfo

Parameters

typeName
The type name

Return Value

The type

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


GetTypes Method

IAssemblyInfo.GetTypes Method
[image]

Gets all of the types in an assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetTypes() As IList(Of ITypeInfo)
C#
IList<ITypeInfo> GetTypes()
C++
IList<ITypeInfo> GetTypes() abstract
J#
IList<ITypeInfo> GetTypes()
JScript
function GetTypes() : IList<ITypeInfo>

Return Value

The types

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


Resolve Method

IAssemblyInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As Assembly
C#
Assembly Resolve(
bool throwOnError
)
C++
Assembly Resolve(
bool throwOnError
) abstract
J#
Assembly Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : Assembly

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns null

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IAssemblyInfo Interface
Gallio.Reflection Namespace


IAttributeInfo Interface

IAttributeInfo Interface
See Also Example Members
[image]

Provides information about the contents of a custom attribute.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAttributeInfo
C#
public interface IAttributeInfo
C++
interface class IAttributeInfo
J#
public interface IAttributeInfo
JScript
public interface IAttributeInfo

Types that implement IAttributeInfo

Type | Description
Gallio.Reflection.Impl.StaticAttributeWrapper | A StaticReflectionPolicy attribute wrapper. This class cannot be inherited.

See Also

IAttributeInfo Members
Gallio.Reflection Namespace


IAttributeInfo Members

IAttributeInfo Members
See Also Example Properties Methods
[image]

Provides information about the contents of a custom attribute.

The following tables list the members exposed by IAttributeInfo.

Public Properties

 | Name | Description
Public property | Constructor | Gets the constructor used to create the attribute.
Public property | InitializedArgumentValues | Gets the initialized attribute constructor argument values.
Public property | InitializedFieldValues | Gets the initialized attribute field values.
Public property | InitializedPropertyValues | Gets the initialized attribute property values.
Public property | Type | Gets the attribute type.
Top

Public Methods

 | Name | Description
Public method | GetFieldValue | Gets an attribute field value.
Public method | GetPropertyValue | Gets an attribute property value.
Public method | Resolve | Gets the attribute as an object.
Top

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


Properties

IAttributeInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Constructor | Gets the constructor used to create the attribute.
Public property | InitializedArgumentValues | Gets the initialized attribute constructor argument values.
Public property | InitializedFieldValues | Gets the initialized attribute field values.
Public property | InitializedPropertyValues | Gets the initialized attribute property values.
Public property | Type | Gets the attribute type.
Top

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


Constructor Property

IAttributeInfo.Constructor Property
[image]

Gets the constructor used to create the attribute.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Constructor As IConstructorInfo
C#
IConstructorInfo Constructor { get; }
C++
property IConstructorInfo Constructor abstract {
IConstructorInfo get();
}
J#
/** property */
public IConstructorInfo get_Constructor();
JScript
public function get Constructor() : IConstructorInfo

Exceptions

Exception Type | Condition
NotSupportedException | Thrown if not supported

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


InitializedArgumentValues Property

IAttributeInfo.InitializedArgumentValues Property
[image]

Gets the initialized attribute constructor argument values.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InitializedArgumentValues As ConstantValue()
C#
ConstantValue[] InitializedArgumentValues { get; }
C++
property ConstantValue[] InitializedArgumentValues abstract {
array<ConstantValue>^ get();
}
J#
/** property */
public ConstantValue[] get_InitializedArgumentValues();
JScript
public function get InitializedArgumentValues() : ConstantValue[]

Exceptions

Exception Type | Condition
NotSupportedException | Thrown if not supported

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


InitializedFieldValues Property

IAttributeInfo.InitializedFieldValues Property
[image]

Gets the initialized attribute field values.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InitializedFieldValues As IEnumerable(Of KeyValuePair(Of IFieldInfo, ConstantValue))
C#
IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> InitializedFieldValues { get; }
C++
property IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> InitializedFieldValues abstract {
IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> get_InitializedFieldValues();
JScript
public function get InitializedFieldValues() : IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>>

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


InitializedPropertyValues Property

IAttributeInfo.InitializedPropertyValues Property
[image]

Gets the initialized attribute property values.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property InitializedPropertyValues As IEnumerable(Of KeyValuePair(Of IPropertyInfo, ConstantValue))
C#
IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> InitializedPropertyValues { get; }
C++
property IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> InitializedPropertyValues abstract {
IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> get_InitializedPropertyValues();
JScript
public function get InitializedPropertyValues() : IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>>

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


Type Property

IAttributeInfo.Type Property
[image]

Gets the attribute type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As ITypeInfo
C#
ITypeInfo Type { get; }
C++
property ITypeInfo Type abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_Type();
JScript
public function get Type() : ITypeInfo

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


Methods

IAttributeInfo Methods
[image]

Public Methods

 | Name | Description
Public method | GetFieldValue | Gets an attribute field value.
Public method | GetPropertyValue | Gets an attribute property value.
Public method | Resolve | Gets the attribute as an object.
Top

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


GetFieldValue Method

IAttributeInfo.GetFieldValue Method
[image]

Gets an attribute field value.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetFieldValue( _
ByVal name As String _
) As ConstantValue
C#
ConstantValue GetFieldValue(
string name
)
C++
ConstantValue GetFieldValue(
String name
) abstract
J#
ConstantValue GetFieldValue(
string name
)
JScript
function GetFieldValue(
name : String
) : ConstantValue

Parameters

name
The field name

Return Value

The value, or a default value of the field's type if the field with the specified name was not initialized by the attribute declaration

Exceptions

Exception Type | Condition
ArgumentException | Thrown if there is no writable instance field with the specified name

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


GetPropertyValue Method

IAttributeInfo.GetPropertyValue Method
[image]

Gets an attribute property value.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetPropertyValue( _
ByVal name As String _
) As ConstantValue
C#
ConstantValue GetPropertyValue(
string name
)
C++
ConstantValue GetPropertyValue(
String name
) abstract
J#
ConstantValue GetPropertyValue(
string name
)
JScript
function GetPropertyValue(
name : String
) : ConstantValue

Parameters

name
The property name

Return Value

The value, or a default value of the propery's type if the property with the specified name was not initialized by the attribute declaration

Exceptions

Exception Type | Condition
ArgumentException | Thrown if there is no writable instance property with the specified name

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


Resolve Method

IAttributeInfo.Resolve Method
[image]

Gets the attribute as an object.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As Object
C#
object Resolve(
bool throwOnError
)
C++
Object Resolve(
bool throwOnError
) abstract
J#
object Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : Object

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise the result may include unresolved types, enums or arrays though it still may throw an exception if the attribute class cannot be instantiated

Return Value

The attribute

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the attribute could not be resolved

See Also

IAttributeInfo Interface
Gallio.Reflection Namespace


ICodeElementInfo Interface

ICodeElementInfo Interface
See Also Example Members
[image]

Represents a structural element of some code base.

This interface is the base of a hierarchy of abstract reflection objects. Different implementations of these objects may be used to perform reflection over different sources.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICodeElementInfo
Implements IEquatable(Of ICodeElementInfo)
C#
public interface ICodeElementInfo : IEquatable<ICodeElementInfo>
C++
interface class ICodeElementInfo : IEquatable<ICodeElementInfo>
J#
public interface ICodeElementInfo implements IEquatable<ICodeElementInfo>
JScript
public interface ICodeElementInfo extends IEquatable<ICodeElementInfo>

Types that implement ICodeElementInfo

Type | Description
Gallio.Reflection.Impl.StaticCodeElementWrapper | A StaticReflectionPolicy code element wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ICodeElementInfo Members
Gallio.Reflection Namespace
Reflector


ICodeElementInfo Members

ICodeElementInfo Members
See Also Example Properties Methods
[image]

Represents a structural element of some code base.

This interface is the base of a hierarchy of abstract reflection objects. Different implementations of these objects may be used to perform reflection over different sources.

The following tables list the members exposed by ICodeElementInfo.

Public Properties

 | Name | Description
Public property | CodeReference | Gets a CodeReference for this code element.
Public property | Kind | Gets the kind of code element represented by this instance.
Public property | Name | Gets the name of the code element.
Top

Public Methods

 | Name | Description
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type.
Public method | GetAttributes | Gets the code element's custom attributes of the specified type.
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element.
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type.
Top

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace
Reflector


Properties

ICodeElementInfo Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference | Gets a CodeReference for this code element.
Public property | Kind | Gets the kind of code element represented by this instance.
Public property | Name | Gets the name of the code element.
Top

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace
Reflector


CodeReference Property

ICodeElementInfo.CodeReference Property
[image]

Gets a CodeReference for this code element.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CodeReference As CodeReference
C#
CodeReference CodeReference { get; }
C++
property CodeReference CodeReference abstract {
CodeReference get();
}
J#
/** property */
public CodeReference get_CodeReference();
JScript
public function get CodeReference() : CodeReference

Property Value

The code reference

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


Kind Property

ICodeElementInfo.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Kind As CodeElementKind
C#
CodeElementKind Kind { get; }
C++
property CodeElementKind Kind abstract {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


Name Property

ICodeElementInfo.Name Property
[image]

Gets the name of the code element.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
C++
property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


Methods

ICodeElementInfo Methods
[image]

Public Methods

 | Name | Description
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type.
Public method | GetAttributes | Gets the code element's custom attributes of the specified type.
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element.
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type.
Top

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace
Reflector


GetAttributeInfos Method

ICodeElementInfo.GetAttributeInfos Method
[image]

Gets information about the code element's custom attributes of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetAttributeInfos( _
ByVal attributeType As ITypeInfo, _
ByVal inherit As Boolean _
) As IEnumerable(Of IAttributeInfo)
C#
IEnumerable<IAttributeInfo> GetAttributeInfos(
ITypeInfo attributeType,
bool inherit
)
C++
IEnumerable<IAttributeInfo> GetAttributeInfos(
ITypeInfo attributeType,
bool inherit
) abstract
J#
IEnumerable<IAttributeInfo> GetAttributeInfos(
ITypeInfo attributeType,
bool inherit
)
JScript
function GetAttributeInfos(
attributeType : ITypeInfo,
inherit : bool
) : IEnumerable<IAttributeInfo>

Parameters

attributeType
The attribute type, or null to return attributes of all types
inherit
If true, includes inherited attributes from base types (but not from interfaces, just like ICustomAttributeProvider does)

Return Value

The code element's attributes

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


GetAttributes Method

ICodeElementInfo.GetAttributes Method
[image]

Gets the code element's custom attributes of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetAttributes( _
ByVal attributeType As ITypeInfo, _
ByVal inherit As Boolean _
) As IEnumerable(Of Object)
C#
IEnumerable<object> GetAttributes(
ITypeInfo attributeType,
bool inherit
)
C++
IEnumerable<object> GetAttributes(
ITypeInfo attributeType,
bool inherit
) abstract
J#
IEnumerable<object> GetAttributes(
ITypeInfo attributeType,
bool inherit
)
JScript
function GetAttributes(
attributeType : ITypeInfo,
inherit : bool
) : IEnumerable<object>

Parameters

attributeType
The attribute type
inherit
If true, includes inherited attributes from base types (but not from interfaces, just like ICustomAttributeProvider does)

Return Value

The attributes

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


GetCodeLocation Method

ICodeElementInfo.GetCodeLocation Method
[image]

Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetCodeLocation() As CodeLocation
C#
CodeLocation GetCodeLocation()
C++
CodeLocation GetCodeLocation() abstract
J#
CodeLocation GetCodeLocation()
JScript
function GetCodeLocation() : CodeLocation

Return Value

The code location

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


GetXmlDocumentation Method

ICodeElementInfo.GetXmlDocumentation Method
[image]

Gets the XML documentation associated with the code element.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetXmlDocumentation() As String
C#
string GetXmlDocumentation()
C++
String GetXmlDocumentation() abstract
J#
string GetXmlDocumentation()
JScript
function GetXmlDocumentation() : String

Return Value

The XML documentation or null if none available

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


HasAttribute Method

ICodeElementInfo.HasAttribute Method
[image]

Returns true if the code element has a custom attribute of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function HasAttribute( _
ByVal attributeType As ITypeInfo, _
ByVal inherit As Boolean _
) As Boolean
C#
bool HasAttribute(
ITypeInfo attributeType,
bool inherit
)
C++
bool HasAttribute(
ITypeInfo attributeType,
bool inherit
) abstract
J#
bool HasAttribute(
ITypeInfo attributeType,
bool inherit
)
JScript
function HasAttribute(
attributeType : ITypeInfo,
inherit : bool
) : bool

Parameters

attributeType
The attribute type, or null to search for attributes of all types
inherit
If true, includes inherited attributes from base types (but not from interfaces, just like ICustomAttributeProvider does)

Return Value

True if the code element has at least one attribute of the specified type

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace


IConstructorInfo Interface

IConstructorInfo Interface
See Also Example Members
[image]

A ConstructorInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IConstructorInfo
Implements IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of IFunctionInfo), IEquatable(Of IConstructorInfo)
C#
public interface IConstructorInfo : IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>, IEquatable<IConstructorInfo>
C++
interface class IConstructorInfo : IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>, IEquatable<IConstructorInfo>
J#
public interface IConstructorInfo implements IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>, IEquatable<IConstructorInfo>
JScript
public interface IConstructorInfo extends IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>, IEquatable<IConstructorInfo>

Types that implement IConstructorInfo

Type | Description
Gallio.Reflection.Impl.StaticConstructorWrapper | A StaticReflectionPolicy constructor wrapper. This class cannot be inherited.

See Also

IConstructorInfo Members
Gallio.Reflection Namespace


IConstructorInfo Members

IConstructorInfo Members
See Also Example Methods
[image]

A ConstructorInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IConstructorInfo.

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IConstructorInfo Interface
Gallio.Reflection Namespace


Methods

IConstructorInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IConstructorInfo Interface
Gallio.Reflection Namespace


Resolve Method

IConstructorInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As ConstructorInfo
C#
ConstructorInfo Resolve(
bool throwOnError
)
C++
ConstructorInfo Resolve(
bool throwOnError
) abstract
J#
ConstructorInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : ConstructorInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IConstructorInfo Interface
Gallio.Reflection Namespace


IEventInfo Interface

IEventInfo Interface
See Also Example Members
[image]

A EventInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IEventInfo
Implements IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of IEventInfo)
C#
public interface IEventInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IEventInfo>
C++
interface class IEventInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IEventInfo>
J#
public interface IEventInfo implements IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IEventInfo>
JScript
public interface IEventInfo extends IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IEventInfo>

Types that implement IEventInfo

Type | Description
Gallio.Reflection.Impl.StaticEventWrapper | A StaticReflectionPolicy event wrapper. This class cannot be inherited.

See Also

IEventInfo Members
Gallio.Reflection Namespace


IEventInfo Members

IEventInfo Members
See Also Example Properties Methods
[image]

A EventInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IEventInfo.

Public Properties

 | Name | Description
Public property | AddMethod | Gets the add method of the event, or null if none.
Public property | EventAttributes | Gets the event attributes.
Public property | EventHandlerType | Gets the event handler type.
Public property | RaiseMethod | Gets the raise method of the event, or null if none.
Public property | RemoveMethod | Gets the remove method of the event, or null if none.
Top

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IEventInfo Interface
Gallio.Reflection Namespace


Properties

IEventInfo Properties
[image]

Public Properties

 | Name | Description
Public property | AddMethod | Gets the add method of the event, or null if none.
Public property | EventAttributes | Gets the event attributes.
Public property | EventHandlerType | Gets the event handler type.
Public property | RaiseMethod | Gets the raise method of the event, or null if none.
Public property | RemoveMethod | Gets the remove method of the event, or null if none.
Top

See Also

IEventInfo Interface
Gallio.Reflection Namespace


AddMethod Property

IEventInfo.AddMethod Property
[image]

Gets the add method of the event, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AddMethod As IMethodInfo
C#
IMethodInfo AddMethod { get; }
C++
property IMethodInfo AddMethod abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_AddMethod();
JScript
public function get AddMethod() : IMethodInfo

Property Value

The add method, or null if none

See Also

IEventInfo Interface
Gallio.Reflection Namespace


EventAttributes Property

IEventInfo.EventAttributes Property
[image]

Gets the event attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EventAttributes As EventAttributes
C#
EventAttributes EventAttributes { get; }
C++
property EventAttributes EventAttributes abstract {
EventAttributes get();
}
J#
/** property */
public EventAttributes get_EventAttributes();
JScript
public function get EventAttributes() : EventAttributes

See Also

IEventInfo Interface
Gallio.Reflection Namespace


EventHandlerType Property

IEventInfo.EventHandlerType Property
[image]

Gets the event handler type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property EventHandlerType As ITypeInfo
C#
ITypeInfo EventHandlerType { get; }
C++
property ITypeInfo EventHandlerType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_EventHandlerType();
JScript
public function get EventHandlerType() : ITypeInfo

See Also

IEventInfo Interface
Gallio.Reflection Namespace


RaiseMethod Property

IEventInfo.RaiseMethod Property
[image]

Gets the raise method of the event, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RaiseMethod As IMethodInfo
C#
IMethodInfo RaiseMethod { get; }
C++
property IMethodInfo RaiseMethod abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_RaiseMethod();
JScript
public function get RaiseMethod() : IMethodInfo

Property Value

The raise method, or null if none

See Also

IEventInfo Interface
Gallio.Reflection Namespace


RemoveMethod Property

IEventInfo.RemoveMethod Property
[image]

Gets the remove method of the event, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RemoveMethod As IMethodInfo
C#
IMethodInfo RemoveMethod { get; }
C++
property IMethodInfo RemoveMethod abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_RemoveMethod();
JScript
public function get RemoveMethod() : IMethodInfo

Property Value

The remove method, or null if none

See Also

IEventInfo Interface
Gallio.Reflection Namespace


Methods

IEventInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IEventInfo Interface
Gallio.Reflection Namespace


Resolve Method

IEventInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As EventInfo
C#
EventInfo Resolve(
bool throwOnError
)
C++
EventInfo Resolve(
bool throwOnError
) abstract
J#
EventInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : EventInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IEventInfo Interface
Gallio.Reflection Namespace


IFieldInfo Interface

IFieldInfo Interface
See Also Example Members
[image]

A FieldInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFieldInfo
Implements IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), ISlotInfo, IEquatable(Of ISlotInfo), IEquatable(Of IFieldInfo)
C#
public interface IFieldInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IFieldInfo>
C++
interface class IFieldInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IFieldInfo>
J#
public interface IFieldInfo implements IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IFieldInfo>
JScript
public interface IFieldInfo extends IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IFieldInfo>

Types that implement IFieldInfo

Type | Description
Gallio.Reflection.Impl.StaticFieldWrapper | A StaticReflectionPolicy field wrapper. This class cannot be inherited.

See Also

IFieldInfo Members
Gallio.Reflection Namespace


IFieldInfo Members

IFieldInfo Members
See Also Example Properties Methods
[image]

A FieldInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IFieldInfo.

Public Properties

 | Name | Description
Public property | FieldAttributes | Gets the field attributes.
Public property | IsAssembly | Gets a value indicating whether this field has Assembly level visibility.
Public property | IsFamily | Gets a value indicating whether this field has Family level visibility.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this field has FamilyAndAssembly level visibility.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this field has FamilyOrAssembly level visibility.
Public property | IsInitOnly | Returns true if the field is read-only and can only be set from the constructor.
Public property | IsLiteral | Returns true if the field is a literal set at compile time.
Public property | IsPrivate | Gets a value indicating whether the field is private.
Public property | IsPublic | Gets a value indicating whether the field is public.
Public property | IsStatic | Returns true if the field is static.
Top

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


Properties

IFieldInfo Properties
[image]

Public Properties

 | Name | Description
Public property | FieldAttributes | Gets the field attributes.
Public property | IsAssembly | Gets a value indicating whether this field has Assembly level visibility.
Public property | IsFamily | Gets a value indicating whether this field has Family level visibility.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this field has FamilyAndAssembly level visibility.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this field has FamilyOrAssembly level visibility.
Public property | IsInitOnly | Returns true if the field is read-only and can only be set from the constructor.
Public property | IsLiteral | Returns true if the field is a literal set at compile time.
Public property | IsPrivate | Gets a value indicating whether the field is private.
Public property | IsPublic | Gets a value indicating whether the field is public.
Public property | IsStatic | Returns true if the field is static.
Top

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


FieldAttributes Property

IFieldInfo.FieldAttributes Property
[image]

Gets the field attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FieldAttributes As FieldAttributes
C#
FieldAttributes FieldAttributes { get; }
C++
property FieldAttributes FieldAttributes abstract {
FieldAttributes get();
}
J#
/** property */
public FieldAttributes get_FieldAttributes();
JScript
public function get FieldAttributes() : FieldAttributes

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsAssembly Property

IFieldInfo.IsAssembly Property
[image]

Gets a value indicating whether this field has Assembly level visibility.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAssembly As Boolean
C#
bool IsAssembly { get; }
C++
property bool IsAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsAssembly();
JScript
public function get IsAssembly() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsFamily Property

IFieldInfo.IsFamily Property
[image]

Gets a value indicating whether this field has Family level visibility.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFamily As Boolean
C#
bool IsFamily { get; }
C++
property bool IsFamily abstract {
bool get();
}
J#
/** property */
public bool get_IsFamily();
JScript
public function get IsFamily() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsFamilyAndAssembly Property

IFieldInfo.IsFamilyAndAssembly Property
[image]

Gets a value indicating whether this field has FamilyAndAssembly level visibility.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFamilyAndAssembly As Boolean
C#
bool IsFamilyAndAssembly { get; }
C++
property bool IsFamilyAndAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsFamilyAndAssembly();
JScript
public function get IsFamilyAndAssembly() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsFamilyOrAssembly Property

IFieldInfo.IsFamilyOrAssembly Property
[image]

Gets a value indicating whether this field has FamilyOrAssembly level visibility.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFamilyOrAssembly As Boolean
C#
bool IsFamilyOrAssembly { get; }
C++
property bool IsFamilyOrAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsFamilyOrAssembly();
JScript
public function get IsFamilyOrAssembly() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsInitOnly Property

IFieldInfo.IsInitOnly Property
[image]

Returns true if the field is read-only and can only be set from the constructor.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsInitOnly As Boolean
C#
bool IsInitOnly { get; }
C++
property bool IsInitOnly abstract {
bool get();
}
J#
/** property */
public bool get_IsInitOnly();
JScript
public function get IsInitOnly() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsLiteral Property

IFieldInfo.IsLiteral Property
[image]

Returns true if the field is a literal set at compile time.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLiteral As Boolean
C#
bool IsLiteral { get; }
C++
property bool IsLiteral abstract {
bool get();
}
J#
/** property */
public bool get_IsLiteral();
JScript
public function get IsLiteral() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsPrivate Property

IFieldInfo.IsPrivate Property
[image]

Gets a value indicating whether the field is private.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPrivate As Boolean
C#
bool IsPrivate { get; }
C++
property bool IsPrivate abstract {
bool get();
}
J#
/** property */
public bool get_IsPrivate();
JScript
public function get IsPrivate() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsPublic Property

IFieldInfo.IsPublic Property
[image]

Gets a value indicating whether the field is public.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPublic As Boolean
C#
bool IsPublic { get; }
C++
property bool IsPublic abstract {
bool get();
}
J#
/** property */
public bool get_IsPublic();
JScript
public function get IsPublic() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IsStatic Property

IFieldInfo.IsStatic Property
[image]

Returns true if the field is static.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic { get; }
C++
property bool IsStatic abstract {
bool get();
}
J#
/** property */
public bool get_IsStatic();
JScript
public function get IsStatic() : bool

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


Methods

IFieldInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


Resolve Method

IFieldInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As FieldInfo
C#
FieldInfo Resolve(
bool throwOnError
)
C++
FieldInfo Resolve(
bool throwOnError
) abstract
J#
FieldInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : FieldInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IFieldInfo Interface
Gallio.Reflection Namespace


IFunctionInfo Interface

IFunctionInfo Interface
See Also Example Members
[image]

A MethodBase reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFunctionInfo
Implements IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of IFunctionInfo)
C#
public interface IFunctionInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>
C++
interface class IFunctionInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>
J#
public interface IFunctionInfo implements IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>
JScript
public interface IFunctionInfo extends IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>

Types that implement IFunctionInfo

Type | Description
Gallio.Reflection.Impl.StaticFunctionWrapper | A StaticReflectionPolicy function wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IFunctionInfo Members
Gallio.Reflection Namespace


IFunctionInfo Members

IFunctionInfo Members
See Also Example Properties Methods
[image]

A MethodBase reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IFunctionInfo.

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method.
Public property | IsAbstract | Returns true if the method is abstract.
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly.
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly.
Public property | IsFinal | Returns true if the method is final.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class.
Public property | IsPrivate | Gets a value indicating whether this member is private.
Public property | IsPublic | Gets a value indicating whether this is a public method.
Public property | IsStatic | Returns true if the method is static.
Public property | IsVirtual | Gets a value indicating whether the method is virtual.
Public property | MethodAttributes | Gets the method attributes.
Public property | Parameters | Gets the parameters of the function.
Top

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


Properties

IFunctionInfo Properties
[image]

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method.
Public property | IsAbstract | Returns true if the method is abstract.
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly.
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly.
Public property | IsFinal | Returns true if the method is final.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class.
Public property | IsPrivate | Gets a value indicating whether this member is private.
Public property | IsPublic | Gets a value indicating whether this is a public method.
Public property | IsStatic | Returns true if the method is static.
Public property | IsVirtual | Gets a value indicating whether the method is virtual.
Public property | MethodAttributes | Gets the method attributes.
Public property | Parameters | Gets the parameters of the function.
Top

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


CallingConvention Property

IFunctionInfo.CallingConvention Property
[image]

Gets the calling conventions for this method.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CallingConvention As CallingConventions
C#
CallingConventions CallingConvention { get; }
C++
property CallingConventions CallingConvention abstract {
CallingConventions get();
}
J#
/** property */
public CallingConventions get_CallingConvention();
JScript
public function get CallingConvention() : CallingConventions

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsAbstract Property

IFunctionInfo.IsAbstract Property
[image]

Returns true if the method is abstract.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAbstract As Boolean
C#
bool IsAbstract { get; }
C++
property bool IsAbstract abstract {
bool get();
}
J#
/** property */
public bool get_IsAbstract();
JScript
public function get IsAbstract() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsAssembly Property

IFunctionInfo.IsAssembly Property
[image]

Gets a value indicating whether this method can be called by other classes in the same assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAssembly As Boolean
C#
bool IsAssembly { get; }
C++
property bool IsAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsAssembly();
JScript
public function get IsAssembly() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsFamily Property

IFunctionInfo.IsFamily Property
[image]

Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFamily As Boolean
C#
bool IsFamily { get; }
C++
property bool IsFamily abstract {
bool get();
}
J#
/** property */
public bool get_IsFamily();
JScript
public function get IsFamily() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsFamilyAndAssembly Property

IFunctionInfo.IsFamilyAndAssembly Property
[image]

Gets a value indicating whether this method can be called by derived classes if they are in the same assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFamilyAndAssembly As Boolean
C#
bool IsFamilyAndAssembly { get; }
C++
property bool IsFamilyAndAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsFamilyAndAssembly();
JScript
public function get IsFamilyAndAssembly() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsFamilyOrAssembly Property

IFunctionInfo.IsFamilyOrAssembly Property
[image]

Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFamilyOrAssembly As Boolean
C#
bool IsFamilyOrAssembly { get; }
C++
property bool IsFamilyOrAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsFamilyOrAssembly();
JScript
public function get IsFamilyOrAssembly() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsFinal Property

IFunctionInfo.IsFinal Property
[image]

Returns true if the method is final.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsFinal As Boolean
C#
bool IsFinal { get; }
C++
property bool IsFinal abstract {
bool get();
}
J#
/** property */
public bool get_IsFinal();
JScript
public function get IsFinal() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsHideBySig Property

IFunctionInfo.IsHideBySig Property
[image]

Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsHideBySig As Boolean
C#
bool IsHideBySig { get; }
C++
property bool IsHideBySig abstract {
bool get();
}
J#
/** property */
public bool get_IsHideBySig();
JScript
public function get IsHideBySig() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsPrivate Property

IFunctionInfo.IsPrivate Property
[image]

Gets a value indicating whether this member is private.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPrivate As Boolean
C#
bool IsPrivate { get; }
C++
property bool IsPrivate abstract {
bool get();
}
J#
/** property */
public bool get_IsPrivate();
JScript
public function get IsPrivate() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsPublic Property

IFunctionInfo.IsPublic Property
[image]

Gets a value indicating whether this is a public method.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPublic As Boolean
C#
bool IsPublic { get; }
C++
property bool IsPublic abstract {
bool get();
}
J#
/** property */
public bool get_IsPublic();
JScript
public function get IsPublic() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsStatic Property

IFunctionInfo.IsStatic Property
[image]

Returns true if the method is static.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsStatic As Boolean
C#
bool IsStatic { get; }
C++
property bool IsStatic abstract {
bool get();
}
J#
/** property */
public bool get_IsStatic();
JScript
public function get IsStatic() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IsVirtual Property

IFunctionInfo.IsVirtual Property
[image]

Gets a value indicating whether the method is virtual.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsVirtual As Boolean
C#
bool IsVirtual { get; }
C++
property bool IsVirtual abstract {
bool get();
}
J#
/** property */
public bool get_IsVirtual();
JScript
public function get IsVirtual() : bool

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


MethodAttributes Property

IFunctionInfo.MethodAttributes Property
[image]

Gets the method attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MethodAttributes As MethodAttributes
C#
MethodAttributes MethodAttributes { get; }
C++
property MethodAttributes MethodAttributes abstract {
MethodAttributes get();
}
J#
/** property */
public MethodAttributes get_MethodAttributes();
JScript
public function get MethodAttributes() : MethodAttributes

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


Parameters Property

IFunctionInfo.Parameters Property
[image]

Gets the parameters of the function.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Parameters As IList(Of IParameterInfo)
C#
IList<IParameterInfo> Parameters { get; }
C++
property IList<IParameterInfo> Parameters abstract {
IList<IParameterInfo> get();
}
J#
/** property */
public IList<IParameterInfo> get_Parameters();
JScript
public function get Parameters() : IList<IParameterInfo>

Property Value

The parameters

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


Methods

IFunctionInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


Resolve Method

IFunctionInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As MethodBase
C#
MethodBase Resolve(
bool throwOnError
)
C++
MethodBase Resolve(
bool throwOnError
) abstract
J#
MethodBase Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : MethodBase

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IFunctionInfo Interface
Gallio.Reflection Namespace


IGenericParameterInfo Interface

IGenericParameterInfo Interface
See Also Example Members
[image]

A Type reflection wrapper for generic parameters. The parameter is presented as if it were a slot the accepted a value of type Type.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IGenericParameterInfo
Implements ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of ITypeInfo), ISlotInfo, IEquatable(Of ISlotInfo), IEquatable(Of IGenericParameterInfo)
C#
public interface IGenericParameterInfo : ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IGenericParameterInfo>
C++
interface class IGenericParameterInfo : ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IGenericParameterInfo>
J#
public interface IGenericParameterInfo implements ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IGenericParameterInfo>
JScript
public interface IGenericParameterInfo extends ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IGenericParameterInfo>

Types that implement IGenericParameterInfo

Type | Description
Gallio.Reflection.Impl.StaticGenericParameterWrapper | A StaticReflectionPolicy generic parameter wrapper. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

See Also

IGenericParameterInfo Members
Gallio.Reflection Namespace


IGenericParameterInfo Members

IGenericParameterInfo Members
See Also Example Properties
[image]

A Type reflection wrapper for generic parameters. The parameter is presented as if it were a slot the accepted a value of type Type.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IGenericParameterInfo.

Public Properties

 | Name | Description
Public property | Constraints | Gets the constraints of the generic parameter.
Public property | DeclaringMethod | Gets the declaring generic method of a generic method parameter or null for a generic type parameter.
Public property | GenericParameterAttributes | Gets the generic parameter attributes.
Top

See Also

IGenericParameterInfo Interface
Gallio.Reflection Namespace


Properties

IGenericParameterInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Constraints | Gets the constraints of the generic parameter.
Public property | DeclaringMethod | Gets the declaring generic method of a generic method parameter or null for a generic type parameter.
Public property | GenericParameterAttributes | Gets the generic parameter attributes.
Top

See Also

IGenericParameterInfo Interface
Gallio.Reflection Namespace


Constraints Property

IGenericParameterInfo.Constraints Property
[image]

Gets the constraints of the generic parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Constraints As IList(Of ITypeInfo)
C#
IList<ITypeInfo> Constraints { get; }
C++
property IList<ITypeInfo> Constraints abstract {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_Constraints();
JScript
public function get Constraints() : IList<ITypeInfo>

See Also

IGenericParameterInfo Interface
Gallio.Reflection Namespace


DeclaringMethod Property

IGenericParameterInfo.DeclaringMethod Property
[image]

Gets the declaring generic method of a generic method parameter or null for a generic type parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DeclaringMethod As IMethodInfo
C#
IMethodInfo DeclaringMethod { get; }
C++
property IMethodInfo DeclaringMethod abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_DeclaringMethod();
JScript
public function get DeclaringMethod() : IMethodInfo

See Also

IGenericParameterInfo Interface
Gallio.Reflection Namespace
DeclaringType


GenericParameterAttributes Property

IGenericParameterInfo.GenericParameterAttributes Property
[image]

Gets the generic parameter attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GenericParameterAttributes As GenericParameterAttributes
C#
GenericParameterAttributes GenericParameterAttributes { get; }
C++
property GenericParameterAttributes GenericParameterAttributes abstract {
GenericParameterAttributes get();
}
J#
/** property */
public GenericParameterAttributes get_GenericParameterAttributes();
JScript
public function get GenericParameterAttributes() : GenericParameterAttributes

See Also

IGenericParameterInfo Interface
Gallio.Reflection Namespace


IMemberInfo Interface

IMemberInfo Interface
See Also Example Members
[image]

A MemberInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMemberInfo
Implements ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo)
C#
public interface IMemberInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>
C++
interface class IMemberInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>
J#
public interface IMemberInfo implements ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>
JScript
public interface IMemberInfo extends ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>

Types that implement IMemberInfo

Type | Description
Gallio.Reflection.Impl.StaticMemberWrapper | A StaticReflectionPolicy member wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IMemberInfo Members
Gallio.Reflection Namespace


IMemberInfo Members

IMemberInfo Members
See Also Example Properties Methods
[image]

A MemberInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IMemberInfo.

Public Properties

Name Description
Public property DeclaringType

Gets the declaring type of the member.

If the member not a type or is a nested type, returns its containing type. If it is a generic parameter, returns the type to which it (or its declaring method) belongs. Otherwise returns null.

Public property ReflectedType

Gets the reflected type of the member. The reflected type is the type that was used to locate the member. If the member was inherited from a base class, its declaring type will be the base class but its reflected type will be the inherited class from which the member was accessed.

If the member not a type or is a nested type, returns its reflected containing type. If it is a generic parameter, returns the declaring type to which it (or its declaring method) belongs. Otherwise returns null.

Top

Public Methods

 | Name | Description
Public method | Resolve | Gets the member to its underlying native reflection type.
Top

See Also

IMemberInfo Interface
Gallio.Reflection Namespace


Properties

IMemberInfo Properties
[image]

Public Properties

Name Description
Public property DeclaringType

Gets the declaring type of the member.

If the member not a type or is a nested type, returns its containing type. If it is a generic parameter, returns the type to which it (or its declaring method) belongs. Otherwise returns null.

Public property ReflectedType

Gets the reflected type of the member. The reflected type is the type that was used to locate the member. If the member was inherited from a base class, its declaring type will be the base class but its reflected type will be the inherited class from which the member was accessed.

If the member not a type or is a nested type, returns its reflected containing type. If it is a generic parameter, returns the declaring type to which it (or its declaring method) belongs. Otherwise returns null.

Top

See Also

IMemberInfo Interface
Gallio.Reflection Namespace


DeclaringType Property

IMemberInfo.DeclaringType Property
[image]

Gets the declaring type of the member.

If the member not a type or is a nested type, returns its containing type. If it is a generic parameter, returns the type to which it (or its declaring method) belongs. Otherwise returns null.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DeclaringType As ITypeInfo
C#
ITypeInfo DeclaringType { get; }
C++
property ITypeInfo DeclaringType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_DeclaringType();
JScript
public function get DeclaringType() : ITypeInfo

See Also

IMemberInfo Interface
Gallio.Reflection Namespace
DeclaringMethod
ReflectedType


ReflectedType Property

IMemberInfo.ReflectedType Property
[image]

Gets the reflected type of the member. The reflected type is the type that was used to locate the member. If the member was inherited from a base class, its declaring type will be the base class but its reflected type will be the inherited class from which the member was accessed.

If the member not a type or is a nested type, returns its reflected containing type. If it is a generic parameter, returns the declaring type to which it (or its declaring method) belongs. Otherwise returns null.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReflectedType As ITypeInfo
C#
ITypeInfo ReflectedType { get; }
C++
property ITypeInfo ReflectedType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ReflectedType();
JScript
public function get ReflectedType() : ITypeInfo

See Also

IMemberInfo Interface
Gallio.Reflection Namespace
DeclaringType


Methods

IMemberInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Gets the member to its underlying native reflection type.
Top

See Also

IMemberInfo Interface
Gallio.Reflection Namespace


Resolve Method

IMemberInfo.Resolve Method
[image]

Gets the member to its underlying native reflection type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As MemberInfo
C#
MemberInfo Resolve(
bool throwOnError
)
C++
MemberInfo Resolve(
bool throwOnError
) abstract
J#
MemberInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : MemberInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The underlying native reflection type

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IMemberInfo Interface
Gallio.Reflection Namespace


IMethodInfo Interface

IMethodInfo Interface
See Also Example Members
[image]

A MethodInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IMethodInfo
Implements IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of IFunctionInfo)
C#
public interface IMethodInfo : IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>
C++
interface class IMethodInfo : IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>
J#
public interface IMethodInfo implements IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>
JScript
public interface IMethodInfo extends IFunctionInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<IFunctionInfo>

Types that implement IMethodInfo

Type | Description
Gallio.Reflection.Impl.StaticMethodWrapper | A StaticReflectionPolicy method wrapper. This class cannot be inherited.

See Also

IMethodInfo Members
Gallio.Reflection Namespace


IMethodInfo Members

IMethodInfo Members
See Also Example Properties Methods
[image]

A MethodInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IMethodInfo.

Public Properties

 | Name | Description
Public property | ContainsGenericParameters | Returns true if the method contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | GenericArguments | Gets the generic arguments of the method. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericMethodDefinition | Gets the generic method definition of this method, or null if the method is not generic.
Public property | IsGenericMethod | Returns true if the method is a generic method. If so, the GenericArguments list will be non-empty.
Public property | IsGenericMethodDefinition | Returns true if the method is a generic method definition.
Public property | ReturnParameter | Gets the method return parameter object that contains information about the return value and its attributes.
Public property | ReturnType | Gets the method return type.
Top

Public Methods

 | Name | Description
Public method | MakeGenericMethod | Makes a generic method instantiation.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


Properties

IMethodInfo Properties
[image]

Public Properties

 | Name | Description
Public property | ContainsGenericParameters | Returns true if the method contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | GenericArguments | Gets the generic arguments of the method. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericMethodDefinition | Gets the generic method definition of this method, or null if the method is not generic.
Public property | IsGenericMethod | Returns true if the method is a generic method. If so, the GenericArguments list will be non-empty.
Public property | IsGenericMethodDefinition | Returns true if the method is a generic method definition.
Public property | ReturnParameter | Gets the method return parameter object that contains information about the return value and its attributes.
Public property | ReturnType | Gets the method return type.
Top

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


ContainsGenericParameters Property

IMethodInfo.ContainsGenericParameters Property
[image]

Returns true if the method contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ContainsGenericParameters As Boolean
C#
bool ContainsGenericParameters { get; }
C++
property bool ContainsGenericParameters abstract {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


GenericArguments Property

IMethodInfo.GenericArguments Property
[image]

Gets the generic arguments of the method. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GenericArguments As IList(Of ITypeInfo)
C#
IList<ITypeInfo> GenericArguments { get; }
C++
property IList<ITypeInfo> GenericArguments abstract {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_GenericArguments();
JScript
public function get GenericArguments() : IList<ITypeInfo>

Property Value

The generic arguments

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


GenericMethodDefinition Property

IMethodInfo.GenericMethodDefinition Property
[image]

Gets the generic method definition of this method, or null if the method is not generic.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GenericMethodDefinition As IMethodInfo
C#
IMethodInfo GenericMethodDefinition { get; }
C++
property IMethodInfo GenericMethodDefinition abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_GenericMethodDefinition();
JScript
public function get GenericMethodDefinition() : IMethodInfo

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


IsGenericMethod Property

IMethodInfo.IsGenericMethod Property
[image]

Returns true if the method is a generic method. If so, the GenericArguments list will be non-empty.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsGenericMethod As Boolean
C#
bool IsGenericMethod { get; }
C++
property bool IsGenericMethod abstract {
bool get();
}
J#
/** property */
public bool get_IsGenericMethod();
JScript
public function get IsGenericMethod() : bool

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


IsGenericMethodDefinition Property

IMethodInfo.IsGenericMethodDefinition Property
[image]

Returns true if the method is a generic method definition.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsGenericMethodDefinition As Boolean
C#
bool IsGenericMethodDefinition { get; }
C++
property bool IsGenericMethodDefinition abstract {
bool get();
}
J#
/** property */
public bool get_IsGenericMethodDefinition();
JScript
public function get IsGenericMethodDefinition() : bool

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


ReturnParameter Property

IMethodInfo.ReturnParameter Property
[image]

Gets the method return parameter object that contains information about the return value and its attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReturnParameter As IParameterInfo
C#
IParameterInfo ReturnParameter { get; }
C++
property IParameterInfo ReturnParameter abstract {
IParameterInfo get();
}
J#
/** property */
public IParameterInfo get_ReturnParameter();
JScript
public function get ReturnParameter() : IParameterInfo

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


ReturnType Property

IMethodInfo.ReturnType Property
[image]

Gets the method return type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReturnType As ITypeInfo
C#
ITypeInfo ReturnType { get; }
C++
property ITypeInfo ReturnType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ReturnType();
JScript
public function get ReturnType() : ITypeInfo

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


Methods

IMethodInfo Methods
[image]

Public Methods

 | Name | Description
Public method | MakeGenericMethod | Makes a generic method instantiation.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


MakeGenericMethod Method

IMethodInfo.MakeGenericMethod Method
[image]

Makes a generic method instantiation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function MakeGenericMethod( _
ByVal genericArguments As IList(Of ITypeInfo) _
) As IMethodInfo
C#
IMethodInfo MakeGenericMethod(
IList<ITypeInfo> genericArguments
)
C++
IMethodInfo MakeGenericMethod(
IList<ITypeInfo> genericArguments
) abstract
J#
IMethodInfo MakeGenericMethod(
IList<ITypeInfo> genericArguments
)
JScript
function MakeGenericMethod(
genericArguments : IList<ITypeInfo>
) : IMethodInfo

Parameters

genericArguments
The generic arguments

Return Value

The generic method instantiation

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


Resolve Method

IMethodInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As MethodInfo
C#
MethodInfo Resolve(
bool throwOnError
)
C++
MethodInfo Resolve(
bool throwOnError
) abstract
J#
MethodInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : MethodInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
NotSupportedException | Thrown if the target cannot be resolved

See Also

IMethodInfo Interface
Gallio.Reflection Namespace


INamespaceInfo Interface

INamespaceInfo Interface
[image]

A namespace reflection wrapper identified by its name.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface INamespaceInfo
Implements ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of INamespaceInfo)
C#
public interface INamespaceInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<INamespaceInfo>
C++
interface class INamespaceInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<INamespaceInfo>
J#
public interface INamespaceInfo implements ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<INamespaceInfo>
JScript
public interface INamespaceInfo extends ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<INamespaceInfo>

See Also

INamespaceInfo Members
Gallio.Reflection Namespace


IParameterInfo Interface

IParameterInfo Interface
See Also Example Members
[image]

A ParameterInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IParameterInfo
Implements ISlotInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of ISlotInfo), IEquatable(Of IParameterInfo)
C#
public interface IParameterInfo : ISlotInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>, IEquatable<IParameterInfo>
C++
interface class IParameterInfo : ISlotInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>, IEquatable<IParameterInfo>
J#
public interface IParameterInfo implements ISlotInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>, IEquatable<IParameterInfo>
JScript
public interface IParameterInfo extends ISlotInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>, IEquatable<IParameterInfo>

Types that implement IParameterInfo

Type | Description
Gallio.Reflection.Impl.StaticParameterWrapper | A StaticReflectionPolicy parameter wrapper. This class cannot be inherited.

See Also

IParameterInfo Members
Gallio.Reflection Namespace


IParameterInfo Members

IParameterInfo Members
See Also Example Properties Methods
[image]

A ParameterInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IParameterInfo.

Public Properties

 | Name | Description
Public property | IsIn | Gets a value indicating whether this is an input parameter.
Public property | IsOptional | Gets a value indicating whether this parameter is optional.
Public property | IsOut | Gets a value indicating whether this is an output parameter.
Public property | Member | Gets the member to which the parameter belongs.
Public property | ParameterAttributes | Gets the parameter attributes.
Top

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


Properties

IParameterInfo Properties
[image]

Public Properties

 | Name | Description
Public property | IsIn | Gets a value indicating whether this is an input parameter.
Public property | IsOptional | Gets a value indicating whether this parameter is optional.
Public property | IsOut | Gets a value indicating whether this is an output parameter.
Public property | Member | Gets the member to which the parameter belongs.
Public property | ParameterAttributes | Gets the parameter attributes.
Top

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


IsIn Property

IParameterInfo.IsIn Property
[image]

Gets a value indicating whether this is an input parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsIn As Boolean
C#
bool IsIn { get; }
C++
property bool IsIn abstract {
bool get();
}
J#
/** property */
public bool get_IsIn();
JScript
public function get IsIn() : bool

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


IsOptional Property

IParameterInfo.IsOptional Property
[image]

Gets a value indicating whether this parameter is optional.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsOptional As Boolean
C#
bool IsOptional { get; }
C++
property bool IsOptional abstract {
bool get();
}
J#
/** property */
public bool get_IsOptional();
JScript
public function get IsOptional() : bool

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


IsOut Property

IParameterInfo.IsOut Property
[image]

Gets a value indicating whether this is an output parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsOut As Boolean
C#
bool IsOut { get; }
C++
property bool IsOut abstract {
bool get();
}
J#
/** property */
public bool get_IsOut();
JScript
public function get IsOut() : bool

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


Member Property

IParameterInfo.Member Property
[image]

Gets the member to which the parameter belongs.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Member As IMemberInfo
C#
IMemberInfo Member { get; }
C++
property IMemberInfo Member abstract {
IMemberInfo get();
}
J#
/** property */
public IMemberInfo get_Member();
JScript
public function get Member() : IMemberInfo

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


ParameterAttributes Property

IParameterInfo.ParameterAttributes Property
[image]

Gets the parameter attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ParameterAttributes As ParameterAttributes
C#
ParameterAttributes ParameterAttributes { get; }
C++
property ParameterAttributes ParameterAttributes abstract {
ParameterAttributes get();
}
J#
/** property */
public ParameterAttributes get_ParameterAttributes();
JScript
public function get ParameterAttributes() : ParameterAttributes

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


Methods

IParameterInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


Resolve Method

IParameterInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As ParameterInfo
C#
ParameterInfo Resolve(
bool throwOnError
)
C++
ParameterInfo Resolve(
bool throwOnError
) abstract
J#
ParameterInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : ParameterInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IParameterInfo Interface
Gallio.Reflection Namespace


IPropertyInfo Interface

IPropertyInfo Interface
See Also Example Members
[image]

A PropertyInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPropertyInfo
Implements IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), ISlotInfo, IEquatable(Of ISlotInfo), IEquatable(Of IPropertyInfo)
C#
public interface IPropertyInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IPropertyInfo>
C++
interface class IPropertyInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IPropertyInfo>
J#
public interface IPropertyInfo implements IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IPropertyInfo>
JScript
public interface IPropertyInfo extends IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, ISlotInfo, IEquatable<ISlotInfo>, IEquatable<IPropertyInfo>

Types that implement IPropertyInfo

Type | Description
Gallio.Reflection.Impl.StaticPropertyWrapper | A StaticReflectionPolicy property wrapper. This class cannot be inherited.

See Also

IPropertyInfo Members
Gallio.Reflection Namespace


IPropertyInfo Members

IPropertyInfo Members
See Also Example Properties Methods
[image]

A PropertyInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by IPropertyInfo.

Public Properties

 | Name | Description
Public property | CanRead | Returns true if the property can be read.
Public property | CanWrite | Returns true if the property can be written.
Public property | GetMethod | Gets the get method of the property, or null if none.
Public property | IndexParameters | Gets the list of index parameters for an indexer property, or an empty array if none.
Public property | PropertyAttributes | Gets the property attributes.
Public property | SetMethod | Gets the set method of the property, or null if none.
Top

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


Properties

IPropertyInfo Properties
[image]

Public Properties

 | Name | Description
Public property | CanRead | Returns true if the property can be read.
Public property | CanWrite | Returns true if the property can be written.
Public property | GetMethod | Gets the get method of the property, or null if none.
Public property | IndexParameters | Gets the list of index parameters for an indexer property, or an empty array if none.
Public property | PropertyAttributes | Gets the property attributes.
Public property | SetMethod | Gets the set method of the property, or null if none.
Top

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


CanRead Property

IPropertyInfo.CanRead Property
[image]

Returns true if the property can be read.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanRead As Boolean
C#
bool CanRead { get; }
C++
property bool CanRead abstract {
bool get();
}
J#
/** property */
public bool get_CanRead();
JScript
public function get CanRead() : bool

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


CanWrite Property

IPropertyInfo.CanWrite Property
[image]

Returns true if the property can be written.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CanWrite As Boolean
C#
bool CanWrite { get; }
C++
property bool CanWrite abstract {
bool get();
}
J#
/** property */
public bool get_CanWrite();
JScript
public function get CanWrite() : bool

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


GetMethod Property

IPropertyInfo.GetMethod Property
[image]

Gets the get method of the property, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GetMethod As IMethodInfo
C#
IMethodInfo GetMethod { get; }
C++
property IMethodInfo GetMethod abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_GetMethod();
JScript
public function get GetMethod() : IMethodInfo

Property Value

The get method, or null if none

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


IndexParameters Property

IPropertyInfo.IndexParameters Property
[image]

Gets the list of index parameters for an indexer property, or an empty array if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IndexParameters As IList(Of IParameterInfo)
C#
IList<IParameterInfo> IndexParameters { get; }
C++
property IList<IParameterInfo> IndexParameters abstract {
IList<IParameterInfo> get();
}
J#
/** property */
public IList<IParameterInfo> get_IndexParameters();
JScript
public function get IndexParameters() : IList<IParameterInfo>

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


PropertyAttributes Property

IPropertyInfo.PropertyAttributes Property
[image]

Gets the property attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property PropertyAttributes As PropertyAttributes
C#
PropertyAttributes PropertyAttributes { get; }
C++
property PropertyAttributes PropertyAttributes abstract {
PropertyAttributes get();
}
J#
/** property */
public PropertyAttributes get_PropertyAttributes();
JScript
public function get PropertyAttributes() : PropertyAttributes

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


SetMethod Property

IPropertyInfo.SetMethod Property
[image]

Gets the set method of the property, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SetMethod As IMethodInfo
C#
IMethodInfo SetMethod { get; }
C++
property IMethodInfo SetMethod abstract {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_SetMethod();
JScript
public function get SetMethod() : IMethodInfo

Property Value

The set method, or null if none

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


Methods

IPropertyInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


Resolve Method

IPropertyInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As PropertyInfo
C#
PropertyInfo Resolve(
bool throwOnError
)
C++
PropertyInfo Resolve(
bool throwOnError
) abstract
J#
PropertyInfo Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : PropertyInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IPropertyInfo Interface
Gallio.Reflection Namespace


IReflectionPolicy Interface

IReflectionPolicy Interface
See Also Example Members
[image]

A reflection policy provides access to top-level reflection resources such as assemblies.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReflectionPolicy
C#
public interface IReflectionPolicy
C++
interface class IReflectionPolicy
J#
public interface IReflectionPolicy
JScript
public interface IReflectionPolicy

Types that implement IReflectionPolicy

Type | Description
Gallio.Reflection.Impl.BaseReflectionPolicy | A base reflection policy implementation that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IReflectionPolicy Members
Gallio.Reflection Namespace


IReflectionPolicy Members

IReflectionPolicy Members
See Also Example Methods
[image]

A reflection policy provides access to top-level reflection resources such as assemblies.

The following tables list the members exposed by IReflectionPolicy.

Public Methods

 | Name | Description
Public method | LoadAssembly | Loads an assembly by name.
Public method | LoadAssemblyFrom | Loads an assembly from a file.
Top

See Also

IReflectionPolicy Interface
Gallio.Reflection Namespace


Methods

IReflectionPolicy Methods
[image]

Public Methods

 | Name | Description
Public method | LoadAssembly | Loads an assembly by name.
Public method | LoadAssemblyFrom | Loads an assembly from a file.
Top

See Also

IReflectionPolicy Interface
Gallio.Reflection Namespace


LoadAssembly Method

IReflectionPolicy.LoadAssembly Method
[image]

Loads an assembly by name.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function LoadAssembly( _
ByVal assemblyName As AssemblyName _
) As IAssemblyInfo
C#
IAssemblyInfo LoadAssembly(
AssemblyName assemblyName
)
C++
IAssemblyInfo LoadAssembly(
AssemblyName assemblyName
) abstract
J#
IAssemblyInfo LoadAssembly(
AssemblyName assemblyName
)
JScript
function LoadAssembly(
assemblyName : AssemblyName
) : IAssemblyInfo

Parameters

assemblyName
The full or partial assembly name of the assembly to load

Return Value

The loaded assembly

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyName is null
Exception | Thrown if the assembly could not be loaded for any reason

See Also

IReflectionPolicy Interface
Gallio.Reflection Namespace


LoadAssemblyFrom Method

IReflectionPolicy.LoadAssemblyFrom Method
[image]

Loads an assembly from a file.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function LoadAssemblyFrom( _
ByVal assemblyFile As String _
) As IAssemblyInfo
C#
IAssemblyInfo LoadAssemblyFrom(
string assemblyFile
)
C++
IAssemblyInfo LoadAssemblyFrom(
String assemblyFile
) abstract
J#
IAssemblyInfo LoadAssemblyFrom(
string assemblyFile
)
JScript
function LoadAssemblyFrom(
assemblyFile : String
) : IAssemblyInfo

Parameters

assemblyFile
The assembly file path

Return Value

The loaded assembly

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyFile is null
Exception | Thrown if the assembly could not be loaded for any reason

See Also

IReflectionPolicy Interface
Gallio.Reflection Namespace


ISlotInfo Interface

ISlotInfo Interface
See Also Example Members
[image]

A slot represents a field, property or parameter. It is used to simplify the handling of data binding since all three of these types are similar in that they can hold values of some type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISlotInfo
Implements ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of ISlotInfo)
C#
public interface ISlotInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>
C++
interface class ISlotInfo : ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>
J#
public interface ISlotInfo implements ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>
JScript
public interface ISlotInfo extends ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<ISlotInfo>

Types that implement ISlotInfo

Type | Description
Gallio.Reflection.Impl.StaticFieldWrapper | A StaticReflectionPolicy field wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.StaticGenericParameterWrapper | A StaticReflectionPolicy generic parameter wrapper. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Gallio.Reflection.Impl.StaticParameterWrapper | A StaticReflectionPolicy parameter wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.StaticPropertyWrapper | A StaticReflectionPolicy property wrapper. This class cannot be inherited.

See Also

ISlotInfo Members
Gallio.Reflection Namespace


ISlotInfo Members

ISlotInfo Members
See Also Example Properties
[image]

A slot represents a field, property or parameter. It is used to simplify the handling of data binding since all three of these types are similar in that they can hold values of some type.

The following tables list the members exposed by ISlotInfo.

Public Properties

 | Name | Description
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ValueType | Gets the type of value held in the slot.
Top

See Also

ISlotInfo Interface
Gallio.Reflection Namespace


Properties

ISlotInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ValueType | Gets the type of value held in the slot.
Top

See Also

ISlotInfo Interface
Gallio.Reflection Namespace


Position Property

ISlotInfo.Position Property
[image]

Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
C#
int Position { get; }
C++
property int Position abstract {
int get();
}
J#
/** property */
public int get_Position();
JScript
public function get Position() : int

See Also

ISlotInfo Interface
Gallio.Reflection Namespace


ValueType Property

ISlotInfo.ValueType Property
[image]

Gets the type of value held in the slot.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ValueType As ITypeInfo
C#
ITypeInfo ValueType { get; }
C++
property ITypeInfo ValueType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ValueType();
JScript
public function get ValueType() : ITypeInfo

See Also

ISlotInfo Interface
Gallio.Reflection Namespace


ITypeInfo Interface

ITypeInfo Interface
See Also Example Members
[image]

A Type reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITypeInfo
Implements IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of ITypeInfo)
C#
public interface ITypeInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>
C++
interface class ITypeInfo : IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>
J#
public interface ITypeInfo implements IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>
JScript
public interface ITypeInfo extends IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>

Types that implement ITypeInfo

Type | Description
Gallio.Reflection.Impl.StaticTypeWrapper | A StaticReflectionPolicy type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITypeInfo Members
Gallio.Reflection Namespace


ITypeInfo Members

ITypeInfo Members
See Also Example Properties Methods
[image]

A Type reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

The following tables list the members exposed by ITypeInfo.

Public Properties

 | Name | Description
Public property | ArrayRank | Gets the rank of the array type.
Public property | Assembly | Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter.
Public property | BaseType | Gets the base type of the type, or null if none.
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | ElementType | Gets the element type of an array, pointer or byref type, or null if none.
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericTypeDefinition | Gets the generic type definition of this type, or null if the type is not generic.
Public property | Interfaces | Gets all of the type's interfaces.
Public property | IsAbstract | Returns true if the type is abstract and must be overridden.
Public property | IsArray | Returns true if the type represents an array.
Public property | IsByRef | Returns true if the type represents a type that is passed by reference.
Public property | IsClass | Returns true if the type is a class.
Public property | IsEnum | Returns true if the type represents an enumeration.
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter.
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition.
Public property | IsInterface | Returns true if the type is an interface.
Public property | IsNested | Returns true if the type is nested.
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly.
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family.
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly.
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly.
Public property | IsNestedPrivate | Returns true if the type is nested and declared private.
Public property | IsNestedPublic | Returns true if the type is nested and declared public.
Public property | IsNotPublic | Returns true if the type is not declared public.
Public property | IsPointer | Returns true if the type represents a pointer.
Public property | IsPublic | Returns true if the type is declared public.
Public property | IsSealed | Returns true if the type is sealed.
Public property | IsValueType | Returns true if the type is a value type.
Public property | Namespace | Gets the namespace in which the type is declared.
Public property | NamespaceName | Gets the name of the namespace in which the type is declared.
Public property | TypeAttributes | Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode.
Top

Public Methods

 | Name | Description
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Gets a event by name, or null if not found.
Public method | GetEvents | Gets all events of the type that satisfy the binding flags.
Public method | GetField | Gets a field by name, or null if not found.
Public method | GetFields | Gets all fields of the type that satisfy the binding flags.
Public method | GetMethod | Gets a method by name, or null if not found.
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags.
Public method | GetNestedType | Gets a nested type by name, or null if not found.
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags.
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags.
Public method | GetProperty | Gets a property by name, or null if not found.
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type.
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type.
Public method | MakeArrayType | Makes an array type of the specified rank.
Public method | MakeByRefType | Makes a reference type.
Public method | MakeGenericType | Makes a generic type instantiation.
Public method | MakePointerType | Makes a pointer type.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


Properties

ITypeInfo Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | Gets the rank of the array type.
Public property | Assembly | Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter.
Public property | BaseType | Gets the base type of the type, or null if none.
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | ElementType | Gets the element type of an array, pointer or byref type, or null if none.
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericTypeDefinition | Gets the generic type definition of this type, or null if the type is not generic.
Public property | Interfaces | Gets all of the type's interfaces.
Public property | IsAbstract | Returns true if the type is abstract and must be overridden.
Public property | IsArray | Returns true if the type represents an array.
Public property | IsByRef | Returns true if the type represents a type that is passed by reference.
Public property | IsClass | Returns true if the type is a class.
Public property | IsEnum | Returns true if the type represents an enumeration.
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter.
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition.
Public property | IsInterface | Returns true if the type is an interface.
Public property | IsNested | Returns true if the type is nested.
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly.
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family.
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly.
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly.
Public property | IsNestedPrivate | Returns true if the type is nested and declared private.
Public property | IsNestedPublic | Returns true if the type is nested and declared public.
Public property | IsNotPublic | Returns true if the type is not declared public.
Public property | IsPointer | Returns true if the type represents a pointer.
Public property | IsPublic | Returns true if the type is declared public.
Public property | IsSealed | Returns true if the type is sealed.
Public property | IsValueType | Returns true if the type is a value type.
Public property | Namespace | Gets the namespace in which the type is declared.
Public property | NamespaceName | Gets the name of the namespace in which the type is declared.
Public property | TypeAttributes | Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode.
Top

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


ArrayRank Property

ITypeInfo.ArrayRank Property
[image]

Gets the rank of the array type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ArrayRank As Integer
C#
int ArrayRank { get; }
C++
property int ArrayRank abstract {
int get();
}
J#
/** property */
public int get_ArrayRank();
JScript
public function get ArrayRank() : int

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the type is not an array type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


Assembly Property

ITypeInfo.Assembly Property
[image]

Gets the assembly in which the type is declared.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Assembly As IAssemblyInfo
C#
IAssemblyInfo Assembly { get; }
C++
property IAssemblyInfo Assembly abstract {
IAssemblyInfo get();
}
J#
/** property */
public IAssemblyInfo get_Assembly();
JScript
public function get Assembly() : IAssemblyInfo

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


AssemblyQualifiedName Property

ITypeInfo.AssemblyQualifiedName Property
[image]

Gets the assembly-qualified name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AssemblyQualifiedName As String
C#
string AssemblyQualifiedName { get; }
C++
property string AssemblyQualifiedName abstract {
String get();
}
J#
/** property */
public string get_AssemblyQualifiedName();
JScript
public function get AssemblyQualifiedName() : String

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


BaseType Property

ITypeInfo.BaseType Property
[image]

Gets the base type of the type, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property BaseType As ITypeInfo
C#
ITypeInfo BaseType { get; }
C++
property ITypeInfo BaseType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_BaseType();
JScript
public function get BaseType() : ITypeInfo

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


ContainsGenericParameters Property

ITypeInfo.ContainsGenericParameters Property
[image]

Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ContainsGenericParameters As Boolean
C#
bool ContainsGenericParameters { get; }
C++
property bool ContainsGenericParameters abstract {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


ElementType Property

ITypeInfo.ElementType Property
[image]

Gets the element type of an array, pointer or byref type, or null if none.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ElementType As ITypeInfo
C#
ITypeInfo ElementType { get; }
C++
property ITypeInfo ElementType abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ElementType();
JScript
public function get ElementType() : ITypeInfo

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


FullName Property

ITypeInfo.FullName Property
[image]

Gets the full name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FullName As String
C#
string FullName { get; }
C++
property string FullName abstract {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GenericArguments Property

ITypeInfo.GenericArguments Property
[image]

Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GenericArguments As IList(Of ITypeInfo)
C#
IList<ITypeInfo> GenericArguments { get; }
C++
property IList<ITypeInfo> GenericArguments abstract {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_GenericArguments();
JScript
public function get GenericArguments() : IList<ITypeInfo>

Property Value

The generic arguments, or an empty list if there are none

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GenericTypeDefinition Property

ITypeInfo.GenericTypeDefinition Property
[image]

Gets the generic type definition of this type, or null if the type is not generic.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property GenericTypeDefinition As ITypeInfo
C#
ITypeInfo GenericTypeDefinition { get; }
C++
property ITypeInfo GenericTypeDefinition abstract {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_GenericTypeDefinition();
JScript
public function get GenericTypeDefinition() : ITypeInfo

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


Interfaces Property

ITypeInfo.Interfaces Property
[image]

Gets all of the type's interfaces.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Interfaces As IList(Of ITypeInfo)
C#
IList<ITypeInfo> Interfaces { get; }
C++
property IList<ITypeInfo> Interfaces abstract {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_Interfaces();
JScript
public function get Interfaces() : IList<ITypeInfo>

Property Value

The type's interfaces

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsAbstract Property

ITypeInfo.IsAbstract Property
[image]

Returns true if the type is abstract and must be overridden.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsAbstract As Boolean
C#
bool IsAbstract { get; }
C++
property bool IsAbstract abstract {
bool get();
}
J#
/** property */
public bool get_IsAbstract();
JScript
public function get IsAbstract() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsArray Property

ITypeInfo.IsArray Property
[image]

Returns true if the type represents an array.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsArray As Boolean
C#
bool IsArray { get; }
C++
property bool IsArray abstract {
bool get();
}
J#
/** property */
public bool get_IsArray();
JScript
public function get IsArray() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsByRef Property

ITypeInfo.IsByRef Property
[image]

Returns true if the type represents a type that is passed by reference.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsByRef As Boolean
C#
bool IsByRef { get; }
C++
property bool IsByRef abstract {
bool get();
}
J#
/** property */
public bool get_IsByRef();
JScript
public function get IsByRef() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsClass Property

ITypeInfo.IsClass Property
[image]

Returns true if the type is a class.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsClass As Boolean
C#
bool IsClass { get; }
C++
property bool IsClass abstract {
bool get();
}
J#
/** property */
public bool get_IsClass();
JScript
public function get IsClass() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsEnum Property

ITypeInfo.IsEnum Property
[image]

Returns true if the type represents an enumeration.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsEnum As Boolean
C#
bool IsEnum { get; }
C++
property bool IsEnum abstract {
bool get();
}
J#
/** property */
public bool get_IsEnum();
JScript
public function get IsEnum() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsGenericParameter Property

ITypeInfo.IsGenericParameter Property
[image]

Returns true if the type represents a generic type parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsGenericParameter As Boolean
C#
bool IsGenericParameter { get; }
C++
property bool IsGenericParameter abstract {
bool get();
}
J#
/** property */
public bool get_IsGenericParameter();
JScript
public function get IsGenericParameter() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace
IGenericParameterInfo


IsGenericType Property

ITypeInfo.IsGenericType Property
[image]

Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsGenericType As Boolean
C#
bool IsGenericType { get; }
C++
property bool IsGenericType abstract {
bool get();
}
J#
/** property */
public bool get_IsGenericType();
JScript
public function get IsGenericType() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsGenericTypeDefinition Property

ITypeInfo.IsGenericTypeDefinition Property
[image]

Returns true if the type is a generic type definition.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsGenericTypeDefinition As Boolean
C#
bool IsGenericTypeDefinition { get; }
C++
property bool IsGenericTypeDefinition abstract {
bool get();
}
J#
/** property */
public bool get_IsGenericTypeDefinition();
JScript
public function get IsGenericTypeDefinition() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsInterface Property

ITypeInfo.IsInterface Property
[image]

Returns true if the type is an interface.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsInterface As Boolean
C#
bool IsInterface { get; }
C++
property bool IsInterface abstract {
bool get();
}
J#
/** property */
public bool get_IsInterface();
JScript
public function get IsInterface() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNested Property

ITypeInfo.IsNested Property
[image]

Returns true if the type is nested.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNested As Boolean
C#
bool IsNested { get; }
C++
property bool IsNested abstract {
bool get();
}
J#
/** property */
public bool get_IsNested();
JScript
public function get IsNested() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNestedAssembly Property

ITypeInfo.IsNestedAssembly Property
[image]

Returns true if the type is nested and is visible only within its own assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNestedAssembly As Boolean
C#
bool IsNestedAssembly { get; }
C++
property bool IsNestedAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsNestedAssembly();
JScript
public function get IsNestedAssembly() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNestedFamily Property

ITypeInfo.IsNestedFamily Property
[image]

Returns true if the type is nested and visible only within its own family.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNestedFamily As Boolean
C#
bool IsNestedFamily { get; }
C++
property bool IsNestedFamily abstract {
bool get();
}
J#
/** property */
public bool get_IsNestedFamily();
JScript
public function get IsNestedFamily() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNestedFamilyAndAssembly Property

ITypeInfo.IsNestedFamilyAndAssembly Property
[image]

Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNestedFamilyAndAssembly As Boolean
C#
bool IsNestedFamilyAndAssembly { get; }
C++
property bool IsNestedFamilyAndAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsNestedFamilyAndAssembly();
JScript
public function get IsNestedFamilyAndAssembly() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNestedFamilyOrAssembly Property

ITypeInfo.IsNestedFamilyOrAssembly Property
[image]

Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNestedFamilyOrAssembly As Boolean
C#
bool IsNestedFamilyOrAssembly { get; }
C++
property bool IsNestedFamilyOrAssembly abstract {
bool get();
}
J#
/** property */
public bool get_IsNestedFamilyOrAssembly();
JScript
public function get IsNestedFamilyOrAssembly() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNestedPrivate Property

ITypeInfo.IsNestedPrivate Property
[image]

Returns true if the type is nested and declared private.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNestedPrivate As Boolean
C#
bool IsNestedPrivate { get; }
C++
property bool IsNestedPrivate abstract {
bool get();
}
J#
/** property */
public bool get_IsNestedPrivate();
JScript
public function get IsNestedPrivate() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNestedPublic Property

ITypeInfo.IsNestedPublic Property
[image]

Returns true if the type is nested and declared public.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNestedPublic As Boolean
C#
bool IsNestedPublic { get; }
C++
property bool IsNestedPublic abstract {
bool get();
}
J#
/** property */
public bool get_IsNestedPublic();
JScript
public function get IsNestedPublic() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsNotPublic Property

ITypeInfo.IsNotPublic Property
[image]

Returns true if the type is not declared public.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNotPublic As Boolean
C#
bool IsNotPublic { get; }
C++
property bool IsNotPublic abstract {
bool get();
}
J#
/** property */
public bool get_IsNotPublic();
JScript
public function get IsNotPublic() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsPointer Property

ITypeInfo.IsPointer Property
[image]

Returns true if the type represents a pointer.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPointer As Boolean
C#
bool IsPointer { get; }
C++
property bool IsPointer abstract {
bool get();
}
J#
/** property */
public bool get_IsPointer();
JScript
public function get IsPointer() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsPublic Property

ITypeInfo.IsPublic Property
[image]

Returns true if the type is declared public.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPublic As Boolean
C#
bool IsPublic { get; }
C++
property bool IsPublic abstract {
bool get();
}
J#
/** property */
public bool get_IsPublic();
JScript
public function get IsPublic() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsSealed Property

ITypeInfo.IsSealed Property
[image]

Returns true if the type is sealed.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsSealed As Boolean
C#
bool IsSealed { get; }
C++
property bool IsSealed abstract {
bool get();
}
J#
/** property */
public bool get_IsSealed();
JScript
public function get IsSealed() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsValueType Property

ITypeInfo.IsValueType Property
[image]

Returns true if the type is a value type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsValueType As Boolean
C#
bool IsValueType { get; }
C++
property bool IsValueType abstract {
bool get();
}
J#
/** property */
public bool get_IsValueType();
JScript
public function get IsValueType() : bool

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


Namespace Property

ITypeInfo.Namespace Property
[image]

Gets the namespace in which the type is declared.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Namespace As INamespaceInfo
C#
INamespaceInfo Namespace { get; }
C++
property INamespaceInfo Namespace abstract {
INamespaceInfo get();
}
J#
/** property */
public INamespaceInfo get_Namespace();
JScript
public function get Namespace() : INamespaceInfo

Remarks

If the type does not have a namespace, returns an object whose name is an empty string. This is different from the behavior of Namespace which would ordinarily return null.

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


NamespaceName Property

ITypeInfo.NamespaceName Property
[image]

Gets the name of the namespace in which the type is declared.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property NamespaceName As String
C#
string NamespaceName { get; }
C++
property string NamespaceName abstract {
String get();
}
J#
/** property */
public string get_NamespaceName();
JScript
public function get NamespaceName() : String

Remarks

If the type does not have a namespace, returns an empty string. This is different from the behavior of Namespace which would ordinarily return null.

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


TypeAttributes Property

ITypeInfo.TypeAttributes Property
[image]

Gets the type attributes.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TypeAttributes As TypeAttributes
C#
TypeAttributes TypeAttributes { get; }
C++
property TypeAttributes TypeAttributes abstract {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


TypeCode Property

ITypeInfo.TypeCode Property
[image]

Gets the type's TypeCode.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TypeCode As TypeCode
C#
TypeCode TypeCode { get; }
C++
property TypeCode TypeCode abstract {
TypeCode get();
}
J#
/** property */
public TypeCode get_TypeCode();
JScript
public function get TypeCode() : TypeCode

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


Methods

ITypeInfo Methods
[image]

Public Methods

 | Name | Description
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Gets a event by name, or null if not found.
Public method | GetEvents | Gets all events of the type that satisfy the binding flags.
Public method | GetField | Gets a field by name, or null if not found.
Public method | GetFields | Gets all fields of the type that satisfy the binding flags.
Public method | GetMethod | Gets a method by name, or null if not found.
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags.
Public method | GetNestedType | Gets a nested type by name, or null if not found.
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags.
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags.
Public method | GetProperty | Gets a property by name, or null if not found.
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type.
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type.
Public method | MakeArrayType | Makes an array type of the specified rank.
Public method | MakeByRefType | Makes a reference type.
Public method | MakeGenericType | Makes a generic type instantiation.
Public method | MakePointerType | Makes a pointer type.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Top

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetConstructors Method

ITypeInfo.GetConstructors Method
[image]

Gets all constructors of the type that satisfy the binding flags.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetConstructors( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IConstructorInfo)
C#
IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
C++
IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
) abstract
J#
IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
JScript
function GetConstructors(
bindingFlags : BindingFlags
) : IList<IConstructorInfo>

Parameters

bindingFlags
The binding flags

Return Value

The constructors

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetEvent Method

ITypeInfo.GetEvent Method
[image]

Gets a event by name, or null if not found.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetEvent( _
ByVal eventName As String, _
ByVal bindingFlags As BindingFlags _
) As IEventInfo
C#
IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
C++
IEventInfo GetEvent(
String eventName,
BindingFlags bindingFlags
) abstract
J#
IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
JScript
function GetEvent(
eventName : String,
bindingFlags : BindingFlags
) : IEventInfo

Parameters

eventName
The event name
bindingFlags
The binding flags

Return Value

The event

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetEvents Method

ITypeInfo.GetEvents Method
[image]

Gets all events of the type that satisfy the binding flags.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetEvents( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IEventInfo)
C#
IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
C++
IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
) abstract
J#
IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
JScript
function GetEvents(
bindingFlags : BindingFlags
) : IList<IEventInfo>

Parameters

bindingFlags
The binding flags

Return Value

The events

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetField Method

ITypeInfo.GetField Method
[image]

Gets a field by name, or null if not found.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetField( _
ByVal fieldName As String, _
ByVal bindingFlags As BindingFlags _
) As IFieldInfo
C#
IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
C++
IFieldInfo GetField(
String fieldName,
BindingFlags bindingFlags
) abstract
J#
IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
JScript
function GetField(
fieldName : String,
bindingFlags : BindingFlags
) : IFieldInfo

Parameters

fieldName
The field name
bindingFlags
The binding flags

Return Value

The property

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetFields Method

ITypeInfo.GetFields Method
[image]

Gets all fields of the type that satisfy the binding flags.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetFields( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IFieldInfo)
C#
IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
C++
IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
) abstract
J#
IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
JScript
function GetFields(
bindingFlags : BindingFlags
) : IList<IFieldInfo>

Parameters

bindingFlags
The binding flags

Return Value

The fields

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetMethod Method

ITypeInfo.GetMethod Method
[image]

Gets a method by name, or null if not found.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetMethod( _
ByVal methodName As String, _
ByVal bindingFlags As BindingFlags _
) As IMethodInfo
C#
IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
C++
IMethodInfo GetMethod(
String methodName,
BindingFlags bindingFlags
) abstract
J#
IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
JScript
function GetMethod(
methodName : String,
bindingFlags : BindingFlags
) : IMethodInfo

Parameters

methodName
The method name
bindingFlags
The binding flags

Return Value

The method

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetMethods Method

ITypeInfo.GetMethods Method
[image]

Gets all methods of the type that satisfy the binding flags.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetMethods( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IMethodInfo)
C#
IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
C++
IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
) abstract
J#
IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
JScript
function GetMethods(
bindingFlags : BindingFlags
) : IList<IMethodInfo>

Parameters

bindingFlags
The binding flags

Return Value

The methods

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetNestedType Method

ITypeInfo.GetNestedType Method
[image]

Gets a nested type by name, or null if not found.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetNestedType( _
ByVal nestedTypeName As String, _
ByVal bindingFlags As BindingFlags _
) As ITypeInfo
C#
ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
C++
ITypeInfo GetNestedType(
String nestedTypeName,
BindingFlags bindingFlags
) abstract
J#
ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
JScript
function GetNestedType(
nestedTypeName : String,
bindingFlags : BindingFlags
) : ITypeInfo

Parameters

nestedTypeName
The nested type name
bindingFlags
The binding flags

Return Value

The nested type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetNestedTypes Method

ITypeInfo.GetNestedTypes Method
[image]

Gets all nested types of the type that satisfy the binding flags.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetNestedTypes( _
ByVal bindingFlags As BindingFlags _
) As IList(Of ITypeInfo)
C#
IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
C++
IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
) abstract
J#
IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
JScript
function GetNestedTypes(
bindingFlags : BindingFlags
) : IList<ITypeInfo>

Parameters

bindingFlags
The binding flags

Return Value

The nested types

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetProperties Method

ITypeInfo.GetProperties Method
[image]

Gets all properties of the type that satisfy the binding flags.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetProperties( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IPropertyInfo)
C#
IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
C++
IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
) abstract
J#
IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
JScript
function GetProperties(
bindingFlags : BindingFlags
) : IList<IPropertyInfo>

Parameters

bindingFlags
The binding flags

Return Value

The properties

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


GetProperty Method

ITypeInfo.GetProperty Method
[image]

Gets a property by name, or null if not found.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetProperty( _
ByVal propertyName As String, _
ByVal bindingFlags As BindingFlags _
) As IPropertyInfo
C#
IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
C++
IPropertyInfo GetProperty(
String propertyName,
BindingFlags bindingFlags
) abstract
J#
IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
JScript
function GetProperty(
propertyName : String,
bindingFlags : BindingFlags
) : IPropertyInfo

Parameters

propertyName
The property name
bindingFlags
The binding flags

Return Value

The property

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsAssignableFrom Method

ITypeInfo.IsAssignableFrom Method
[image]

Returns true if variables of this type can be assigned with values of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsAssignableFrom( _
ByVal type As ITypeInfo _
) As Boolean
C#
bool IsAssignableFrom(
ITypeInfo type
)
C++
bool IsAssignableFrom(
ITypeInfo type
) abstract
J#
bool IsAssignableFrom(
ITypeInfo type
)
JScript
function IsAssignableFrom(
type : ITypeInfo
) : bool

Parameters

type
The other type, or null if none

Return Value

True if the other type is not null and this type is assignable from the other type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


IsSubclassOf Method

ITypeInfo.IsSubclassOf Method
[image]

Returns true if this type is a subclass of the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsSubclassOf( _
ByVal type As ITypeInfo _
) As Boolean
C#
bool IsSubclassOf(
ITypeInfo type
)
C++
bool IsSubclassOf(
ITypeInfo type
) abstract
J#
bool IsSubclassOf(
ITypeInfo type
)
JScript
function IsSubclassOf(
type : ITypeInfo
) : bool

Parameters

type
The other type, or null if none

Return Value

True if the other type is not null, this type is a subclass of the other type, and this type not the same as the other type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


MakeArrayType Method

ITypeInfo.MakeArrayType Method
[image]

Makes an array type of the specified rank.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function MakeArrayType( _
ByVal arrayRank As Integer _
) As ITypeInfo
C#
ITypeInfo MakeArrayType(
int arrayRank
)
C++
ITypeInfo MakeArrayType(
int arrayRank
) abstract
J#
ITypeInfo MakeArrayType(
int arrayRank
)
JScript
function MakeArrayType(
arrayRank : int
) : ITypeInfo

Parameters

arrayRank
The array rank

Return Value

The array type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


MakeByRefType Method

ITypeInfo.MakeByRefType Method
[image]

Makes a reference type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function MakeByRefType() As ITypeInfo
C#
ITypeInfo MakeByRefType()
C++
ITypeInfo MakeByRefType() abstract
J#
ITypeInfo MakeByRefType()
JScript
function MakeByRefType() : ITypeInfo

Return Value

The reference type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


MakeGenericType Method

ITypeInfo.MakeGenericType Method
[image]

Makes a generic type instantiation.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function MakeGenericType( _
ByVal genericArguments As IList(Of ITypeInfo) _
) As ITypeInfo
C#
ITypeInfo MakeGenericType(
IList<ITypeInfo> genericArguments
)
C++
ITypeInfo MakeGenericType(
IList<ITypeInfo> genericArguments
) abstract
J#
ITypeInfo MakeGenericType(
IList<ITypeInfo> genericArguments
)
JScript
function MakeGenericType(
genericArguments : IList<ITypeInfo>
) : ITypeInfo

Parameters

genericArguments
The generic arguments

Return Value

The generic type instantiation

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


MakePointerType Method

ITypeInfo.MakePointerType Method
[image]

Makes a pointer type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function MakePointerType() As ITypeInfo
C#
ITypeInfo MakePointerType()
C++
ITypeInfo MakePointerType() abstract
J#
ITypeInfo MakePointerType()
JScript
function MakePointerType() : ITypeInfo

Return Value

The pointer type

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


Resolve Method

ITypeInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal throwOnError As Boolean _
) As Type
C#
Type Resolve(
bool throwOnError
)
C++
Type Resolve(
bool throwOnError
) abstract
J#
Type Resolve(
bool throwOnError
)
JScript
function Resolve(
throwOnError : bool
) : Type

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

ITypeInfo Interface
Gallio.Reflection Namespace


ReflectionOnlyAssemblyLoader Class

ReflectionOnlyAssemblyLoader Class
See Also Example Members
[image]

This assembly loader loads assemblies externally for reflection only.

This implementation ensures that the assembly files do not remain locked on disk and are not cached in memory outside of the scope of the loader. Consequently the Garbage Collector will automatically reclaim the loader and its contents when they become unreferenced.

In contrast, that of the standard .Net reflection-only load context () does not allow assemblies to be reclaimed until the AppDomain is unloaded.

The loader considers all assemblies in the specified search path as well as any that can be located using the current AppDomain's assembly resolvers.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ReflectionOnlyAssemblyLoader
C#
public class ReflectionOnlyAssemblyLoader
C++
ref class ReflectionOnlyAssemblyLoader
J#
public class ReflectionOnlyAssemblyLoader
JScript
public class ReflectionOnlyAssemblyLoader

Inheritance Hierarchy

System.Object
Gallio.Reflection.ReflectionOnlyAssemblyLoader

See Also

ReflectionOnlyAssemblyLoader Members
Gallio.Reflection Namespace
ReflectionOnlyLoad


ReflectionOnlyAssemblyLoader Members

ReflectionOnlyAssemblyLoader Members
See Also Example Constructors Properties Methods
[image]

This assembly loader loads assemblies externally for reflection only.

This implementation ensures that the assembly files do not remain locked on disk and are not cached in memory outside of the scope of the loader. Consequently the Garbage Collector will automatically reclaim the loader and its contents when they become unreferenced.

In contrast, that of the standard .Net reflection-only load context () does not allow assemblies to be reclaimed until the AppDomain is unloaded.

The loader considers all assemblies in the specified search path as well as any that can be located using the current AppDomain's assembly resolvers.

The following tables list the members exposed by ReflectionOnlyAssemblyLoader.

Public Constructors

 | Name | Description
Public method | ReflectionOnlyAssemblyLoader | Creates an assembly loader.
Top

Public Properties

 | Name | Description
Public property | ReflectionPolicy | Gets the reflection policy used to load and access the assemblies.
Top

Public Methods

 | Name | Description
Public method | AddHintDirectory | Adds a hint directory to search for loading assemblies.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectionOnlyAssemblyLoader Class
Gallio.Reflection Namespace
ReflectionOnlyLoad


ReflectionOnlyAssemblyLoader Constructor

ReflectionOnlyAssemblyLoader Constructor
[image]

Creates an assembly loader.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ReflectionOnlyAssemblyLoader()
C++
public:
ReflectionOnlyAssemblyLoader() sealed
J#
public ReflectionOnlyAssemblyLoader()
JScript
public function ReflectionOnlyAssemblyLoader()

See Also

ReflectionOnlyAssemblyLoader Class
Gallio.Reflection Namespace


Properties

ReflectionOnlyAssemblyLoader Properties
[image]

Public Properties

 | Name | Description
Public property | ReflectionPolicy | Gets the reflection policy used to load and access the assemblies.
Top

See Also

ReflectionOnlyAssemblyLoader Class
Gallio.Reflection Namespace
ReflectionOnlyLoad


ReflectionPolicy Property

ReflectionOnlyAssemblyLoader.ReflectionPolicy Property
[image]

Gets the reflection policy used to load and access the assemblies.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReflectionPolicy As IReflectionPolicy
C#
public IReflectionPolicy ReflectionPolicy { get; }
C++
public property IReflectionPolicy ReflectionPolicy sealed {
IReflectionPolicy get();
}
J#
/** property */
public IReflectionPolicy get_ReflectionPolicy();
JScript
public function get ReflectionPolicy() : IReflectionPolicy

See Also

ReflectionOnlyAssemblyLoader Class
Gallio.Reflection Namespace


Methods

ReflectionOnlyAssemblyLoader Methods
[image]

Public Methods

 | Name | Description
Public method | AddHintDirectory | Adds a hint directory to search for loading assemblies.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectionOnlyAssemblyLoader Class
Gallio.Reflection Namespace
ReflectionOnlyLoad


AddHintDirectory Method

ReflectionOnlyAssemblyLoader.AddHintDirectory Method
[image]

Adds a hint directory to search for loading assemblies.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddHintDirectory( _
ByVal path As String _
)
C#
public void AddHintDirectory(
string path
)
C++
public:
void AddHintDirectory(
String path
) sealed
J#
public void AddHintDirectory(
string path
)
JScript
public function AddHintDirectory(
path : String
)

Parameters

path
The search directory to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null

See Also

ReflectionOnlyAssemblyLoader Class
Gallio.Reflection Namespace


ReflectionUtils Class

ReflectionUtils Class
See Also Example Members
[image]

Provides functions for working with reflection. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ReflectionUtils
C#
public static class ReflectionUtils
C++
ref class ReflectionUtils abstract sealed
J#
public final class ReflectionUtils
JScript
public class ReflectionUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.ReflectionUtils

See Also

ReflectionUtils Members
Gallio.Reflection Namespace


ReflectionUtils Members

ReflectionUtils Members
See Also Example Methods
[image]

Provides functions for working with reflection. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ReflectionUtils.

Public Methods

Name | Description
CanGetAndSetNonStatic | Determines if the property has public, non-static and non-abstract getter and setter functions.
CanInstantiate | Determines if the type can be instantiated using a public constructor.
CanInvokeNonStatic | Determines if the method is public, non-static and is non-abstract so it can be invoked.
FindAssemblyReference | Finds the assembly name of the directly referenced assembly with the specified display name.
GetAssembly | Gets the assembly that declares the code element, or the code element itself if it is an IAssemblyInfo.
GetDefaultValue | Overloaded. Gets the default value for a type.
GetMember | Gets the non-type member that declares the code element, or the code element itself if it is an IMemberInfo other than a ITypeInfo.
GetNamespace | Gets the namespace that declares the code element, or the code element itself if it is an INamespaceInfo.
GetParameter | Gets the parameter that declares the code element, or the code element itself if it is an IParameterInfo.
GetType | Gets the type that declares the code element, or the code element itself if it is an ITypeInfo.
IsAssignableFrom | Returns true if the named type is assignable from the specified type.
IsDerivedFrom | Returns true if a type is derived from another type with the specified qualified name.
Top

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


Methods

ReflectionUtils Methods
[image]

Public Methods

Name | Description
CanGetAndSetNonStatic | Determines if the property has public, non-static and non-abstract getter and setter functions.
CanInstantiate | Determines if the type can be instantiated using a public constructor.
CanInvokeNonStatic | Determines if the method is public, non-static and is non-abstract so it can be invoked.
FindAssemblyReference | Finds the assembly name of the directly referenced assembly with the specified display name.
GetAssembly | Gets the assembly that declares the code element, or the code element itself if it is an IAssemblyInfo.
GetDefaultValue | Overloaded. Gets the default value for a type.
GetMember | Gets the non-type member that declares the code element, or the code element itself if it is an IMemberInfo other than a ITypeInfo.
GetNamespace | Gets the namespace that declares the code element, or the code element itself if it is an INamespaceInfo.
GetParameter | Gets the parameter that declares the code element, or the code element itself if it is an IParameterInfo.
GetType | Gets the type that declares the code element, or the code element itself if it is an ITypeInfo.
IsAssignableFrom | Returns true if the named type is assignable from the specified type.
IsDerivedFrom | Returns true if a type is derived from another type with the specified qualified name.
Top

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


CanGetAndSetNonStatic Method

ReflectionUtils.CanGetAndSetNonStatic Method
[image]

Determines if the property has public, non-static and non-abstract getter and setter functions.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanGetAndSetNonStatic( _
ByVal property As IPropertyInfo _
) As Boolean
C#
public static bool CanGetAndSetNonStatic(
IPropertyInfo property
)
C++
public:
static bool CanGetAndSetNonStatic(
IPropertyInfo property
)
J#
public static bool CanGetAndSetNonStatic(
IPropertyInfo property
)
JScript
public static function CanGetAndSetNonStatic(
property : IPropertyInfo
) : bool

Parameters

property
The property

Return Value

True if the property can be get and set

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


CanInstantiate Method

ReflectionUtils.CanInstantiate Method
[image]

Determines if the type can be instantiated using a public constructor.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanInstantiate( _
ByVal type As ITypeInfo _
) As Boolean
C#
public static bool CanInstantiate(
ITypeInfo type
)
C++
public:
static bool CanInstantiate(
ITypeInfo type
)
J#
public static bool CanInstantiate(
ITypeInfo type
)
JScript
public static function CanInstantiate(
type : ITypeInfo
) : bool

Parameters

type
The type

Return Value

True if the type can be instantiated

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


CanInvokeNonStatic Method

ReflectionUtils.CanInvokeNonStatic Method
[image]

Determines if the method is public, non-static and is non-abstract so it can be invoked.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanInvokeNonStatic( _
ByVal method As IMethodInfo _
) As Boolean
C#
public static bool CanInvokeNonStatic(
IMethodInfo method
)
C++
public:
static bool CanInvokeNonStatic(
IMethodInfo method
)
J#
public static bool CanInvokeNonStatic(
IMethodInfo method
)
JScript
public static function CanInvokeNonStatic(
method : IMethodInfo
) : bool

Parameters

method
The method

Return Value

True if the method can be invoked

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


FindAssemblyReference Method

ReflectionUtils.FindAssemblyReference Method
[image]

Finds the assembly name of the directly referenced assembly with the specified display name.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FindAssemblyReference( _
ByVal assembly As IAssemblyInfo, _
ByVal displayName As String _
) As AssemblyName
C#
public static AssemblyName FindAssemblyReference(
IAssemblyInfo assembly,
string displayName
)
C++
public:
static AssemblyName FindAssemblyReference(
IAssemblyInfo assembly,
String displayName
)
J#
public static AssemblyName FindAssemblyReference(
IAssemblyInfo assembly,
string displayName
)
JScript
public static function FindAssemblyReference(
assembly : IAssemblyInfo,
displayName : String
) : AssemblyName

Parameters

assembly
The assembly to search
displayName
The display name of the referenced assembly to find

Return Value

The referenced assembly name or null if none

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


GetAssembly Method

ReflectionUtils.GetAssembly Method
[image]

Gets the assembly that declares the code element, or the code element itself if it is an IAssemblyInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAssembly( _
ByVal codeElement As ICodeElementInfo _
) As IAssemblyInfo
C#
public static IAssemblyInfo GetAssembly(
ICodeElementInfo codeElement
)
C++
public:
static IAssemblyInfo GetAssembly(
ICodeElementInfo codeElement
)
J#
public static IAssemblyInfo GetAssembly(
ICodeElementInfo codeElement
)
JScript
public static function GetAssembly(
codeElement : ICodeElementInfo
) : IAssemblyInfo

Parameters

codeElement
The code element, possibly null

Return Value

The assembly, or null if not found

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


GetDefaultValue Method

ReflectionUtils.GetDefaultValue Method

Gets the default value for a type.

Overload List

Name | Description
GetDefaultValue (Type) | Gets the default value for a type.
GetDefaultValue (TypeCode) | Gets the default value of a type with a given type code.

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


GetDefaultValue Method (Type)

ReflectionUtils.GetDefaultValue Method (Type)
See Also Example
[image]

Gets the default value for a type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultValue( _
ByVal type As Type _
) As Object
C#
public static object GetDefaultValue(
Type type
)
C++
public:
static Object GetDefaultValue(
Type type
)
J#
public static object GetDefaultValue(
Type type
)
JScript
public static function GetDefaultValue(
type : Type
) : Object

Parameters

type
The type

Return Value

The default value for the type, such as 0 if the type represents an integer, or null if the type is a reference type or if type was null

See Also

ReflectionUtils Class
Gallio.Reflection Namespace
ReflectionUtils.GetDefaultValue Overload List


GetDefaultValue Method (TypeCode)

ReflectionUtils.GetDefaultValue Method (TypeCode)
See Also Example
[image]

Gets the default value of a type with a given type code.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultValue( _
ByVal typeCode As TypeCode _
) As Object
C#
public static object GetDefaultValue(
TypeCode typeCode
)
C++
public:
static Object GetDefaultValue(
TypeCode typeCode
)
J#
public static object GetDefaultValue(
TypeCode typeCode
)
JScript
public static function GetDefaultValue(
typeCode : TypeCode
) : Object

Parameters

typeCode
The type code

Return Value

The default value of the type associated with the specified type code

See Also

ReflectionUtils Class
Gallio.Reflection Namespace
ReflectionUtils.GetDefaultValue Overload List


GetMember Method

ReflectionUtils.GetMember Method
[image]

Gets the non-type member that declares the code element, or the code element itself if it is an IMemberInfo other than a ITypeInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetMember( _
ByVal codeElement As ICodeElementInfo _
) As IMemberInfo
C#
public static IMemberInfo GetMember(
ICodeElementInfo codeElement
)
C++
public:
static IMemberInfo GetMember(
ICodeElementInfo codeElement
)
J#
public static IMemberInfo GetMember(
ICodeElementInfo codeElement
)
JScript
public static function GetMember(
codeElement : ICodeElementInfo
) : IMemberInfo

Parameters

codeElement
The code element, possibly null

Return Value

The member, or null if not found

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


GetNamespace Method

ReflectionUtils.GetNamespace Method
[image]

Gets the namespace that declares the code element, or the code element itself if it is an INamespaceInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNamespace( _
ByVal codeElement As ICodeElementInfo _
) As INamespaceInfo
C#
public static INamespaceInfo GetNamespace(
ICodeElementInfo codeElement
)
C++
public:
static INamespaceInfo GetNamespace(
ICodeElementInfo codeElement
)
J#
public static INamespaceInfo GetNamespace(
ICodeElementInfo codeElement
)
JScript
public static function GetNamespace(
codeElement : ICodeElementInfo
) : INamespaceInfo

Parameters

codeElement
The code element, possibly null

Return Value

The namespace, or null if not found

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


GetParameter Method

ReflectionUtils.GetParameter Method
[image]

Gets the parameter that declares the code element, or the code element itself if it is an IParameterInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetParameter( _
ByVal codeElement As ICodeElementInfo _
) As IParameterInfo
C#
public static IParameterInfo GetParameter(
ICodeElementInfo codeElement
)
C++
public:
static IParameterInfo GetParameter(
ICodeElementInfo codeElement
)
J#
public static IParameterInfo GetParameter(
ICodeElementInfo codeElement
)
JScript
public static function GetParameter(
codeElement : ICodeElementInfo
) : IParameterInfo

Parameters

codeElement
The code element, possibly null

Return Value

The parameter, or null if not found

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


GetType Method

ReflectionUtils.GetType Method
[image]

Gets the type that declares the code element, or the code element itself if it is an ITypeInfo.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetType( _
ByVal codeElement As ICodeElementInfo _
) As ITypeInfo
C#
public static ITypeInfo GetType(
ICodeElementInfo codeElement
)
C++
public:
static ITypeInfo GetType(
ICodeElementInfo codeElement
)
J#
public static ITypeInfo GetType(
ICodeElementInfo codeElement
)
JScript
public static function GetType(
codeElement : ICodeElementInfo
) : ITypeInfo

Parameters

codeElement
The code element, possibly null

Return Value

The type, or null if not found

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


IsAssignableFrom Method

ReflectionUtils.IsAssignableFrom Method
[image]

Returns true if the named type is assignable from the specified type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsAssignableFrom( _
ByVal searchTypeName As String, _
ByVal candidateType As Type _
) As Boolean
C#
public static bool IsAssignableFrom(
string searchTypeName,
Type candidateType
)
C++
public:
static bool IsAssignableFrom(
String searchTypeName,
Type candidateType
)
J#
public static bool IsAssignableFrom(
string searchTypeName,
Type candidateType
)
JScript
public static function IsAssignableFrom(
searchTypeName : String,
candidateType : Type
) : bool

Parameters

searchTypeName
The search type
candidateType
The candidate type

Return Value

True if the search type is assignable from the candidate type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if searchTypeName or candidateType is null

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


IsDerivedFrom Method

ReflectionUtils.IsDerivedFrom Method
[image]

Returns true if a type is derived from another type with the specified qualified name.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsDerivedFrom( _
ByVal type As ITypeInfo, _
ByVal qualifiedTypeName As String _
) As Boolean
C#
public static bool IsDerivedFrom(
ITypeInfo type,
string qualifiedTypeName
)
C++
public:
static bool IsDerivedFrom(
ITypeInfo type,
String qualifiedTypeName
)
J#
public static bool IsDerivedFrom(
ITypeInfo type,
string qualifiedTypeName
)
JScript
public static function IsDerivedFrom(
type : ITypeInfo,
qualifiedTypeName : String
) : bool

Parameters

type
The type to check
qualifiedTypeName
The qualified type name

Return Value

True if type is derived from qualifiedTypeName

See Also

ReflectionUtils Class
Gallio.Reflection Namespace


ReflectionWrapperResolveException Class

ReflectionWrapperResolveException Class
See Also Example Members
[image]

The type of exception thrown when a reflection wrapper could not be resolved to a native reflection target.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class ReflectionWrapperResolveException
Inherits Exception
C#
[SerializableAttribute]
public class ReflectionWrapperResolveException : Exception
C++
[SerializableAttribute]
ref class ReflectionWrapperResolveException : Exception
J#
/** @attribute SerializableAttribute() */
public class ReflectionWrapperResolveException extends Exception
JScript
public
SerializableAttribute
class ReflectionWrapperResolveException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Reflection.ReflectionWrapperResolveException

See Also

ReflectionWrapperResolveException Members
Gallio.Reflection Namespace


ReflectionWrapperResolveException Members

ReflectionWrapperResolveException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when a reflection wrapper could not be resolved to a native reflection target.

The following tables list the members exposed by ReflectionWrapperResolveException.

Public Constructors

Name | Description
ReflectionWrapperResolveException | Overloaded.
Top

Protected Constructors

Name | Description
ReflectionWrapperResolveException | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ReflectionWrapperResolveException | Overloaded.
Top

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace


ReflectionWrapperResolveException Constructor

ReflectionWrapperResolveException Constructor

Overload List

 | Name | Description
Public method | ReflectionWrapperResolveException (IAttributeInfo) | Creates an exception for an attribute that could not be resolved.
Public method | ReflectionWrapperResolveException (IAttributeInfo, Exception) | Creates an exception for an attribute that could not be resolved.
Public method | ReflectionWrapperResolveException (ICodeElementInfo) | Creates an exception for a code element that could not be resolved.
Public method | ReflectionWrapperResolveException (ICodeElementInfo, Exception) | Creates an exception for a code element that could not be resolved.
Family method | ReflectionWrapperResolveException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace


ReflectionWrapperResolveException Constructor (IAttributeInfo)

ReflectionWrapperResolveException Constructor (IAttributeInfo)
See Also Example
[image]

Creates an exception for an attribute that could not be resolved.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal attribute As IAttributeInfo _
)
C#
public ReflectionWrapperResolveException(
IAttributeInfo attribute
)
C++
public:
ReflectionWrapperResolveException(
IAttributeInfo attribute
) sealed
J#
public ReflectionWrapperResolveException(
IAttributeInfo attribute
)
JScript
public function ReflectionWrapperResolveException(
attribute : IAttributeInfo
)

Parameters

attribute
The attribute that could not be resolved

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attribute is nul

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace
ReflectionWrapperResolveException Constructor Overload List


ReflectionWrapperResolveException Constructor (IAttributeInfo, Exception)

ReflectionWrapperResolveException Constructor (IAttributeInfo, Exception)
See Also Example
[image]

Creates an exception for an attribute that could not be resolved.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal attribute As IAttributeInfo, _
ByVal innerException As Exception _
)
C#
public ReflectionWrapperResolveException(
IAttributeInfo attribute,
Exception innerException
)
C++
public:
ReflectionWrapperResolveException(
IAttributeInfo attribute,
Exception innerException
) sealed
J#
public ReflectionWrapperResolveException(
IAttributeInfo attribute,
Exception innerException
)
JScript
public function ReflectionWrapperResolveException(
attribute : IAttributeInfo,
innerException : Exception
)

Parameters

attribute
The attribute that could not be resolved
innerException
The inner exception, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if attribute is nul

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace
ReflectionWrapperResolveException Constructor Overload List


ReflectionWrapperResolveException Constructor (ICodeElementInfo)

ReflectionWrapperResolveException Constructor (ICodeElementInfo)
See Also Example
[image]

Creates an exception for a code element that could not be resolved.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal codeElement As ICodeElementInfo _
)
C#
public ReflectionWrapperResolveException(
ICodeElementInfo codeElement
)
C++
public:
ReflectionWrapperResolveException(
ICodeElementInfo codeElement
) sealed
J#
public ReflectionWrapperResolveException(
ICodeElementInfo codeElement
)
JScript
public function ReflectionWrapperResolveException(
codeElement : ICodeElementInfo
)

Parameters

codeElement
The code element that could not be resolved

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is nul

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace
ReflectionWrapperResolveException Constructor Overload List


ReflectionWrapperResolveException Constructor (ICodeElementInfo, Exception)

ReflectionWrapperResolveException Constructor (ICodeElementInfo, Exception)
See Also Example
[image]

Creates an exception for a code element that could not be resolved.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal codeElement As ICodeElementInfo, _
ByVal innerException As Exception _
)
C#
public ReflectionWrapperResolveException(
ICodeElementInfo codeElement,
Exception innerException
)
C++
public:
ReflectionWrapperResolveException(
ICodeElementInfo codeElement,
Exception innerException
) sealed
J#
public ReflectionWrapperResolveException(
ICodeElementInfo codeElement,
Exception innerException
)
JScript
public function ReflectionWrapperResolveException(
codeElement : ICodeElementInfo,
innerException : Exception
)

Parameters

codeElement
The code element that could not be resolved
innerException
The inner exception, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is nul

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace
ReflectionWrapperResolveException Constructor Overload List


ReflectionWrapperResolveException Constructor (SerializationInfo, StreamingContext)

ReflectionWrapperResolveException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected ReflectionWrapperResolveException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
ReflectionWrapperResolveException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected ReflectionWrapperResolveException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function ReflectionWrapperResolveException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

ReflectionWrapperResolveException Class
Gallio.Reflection Namespace
ReflectionWrapperResolveException Constructor Overload List


Reflector Class

Reflector Class
See Also Example Members
[image]

Wraps reflection types using the reflection adapter interfaces. Also resolves code references. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module Reflector
C#
public static class Reflector
C++
ref class Reflector abstract sealed
J#
public final class Reflector
JScript
public class Reflector

Inheritance Hierarchy

System.Object
Gallio.Reflection.Reflector

See Also

Reflector Members
Gallio.Reflection Namespace


Reflector Members

Reflector Members
See Also Example Properties Methods
[image]

Wraps reflection types using the reflection adapter interfaces. Also resolves code references. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Reflector.

Public Properties

Name | Description
NativeReflectionPolicy | Gets the singleton instance of the native IReflectionPolicy based on .Net reflection.
Top

Public Methods

Name | Description
GetCallingFunction | Creates a code element from the caller of the executing function.
GetExecutingFunction | Creates a code element from the executing function.
GetFunctionFromStackFrame | Creates a code element representing a function from a particular frame on the current stack.
IsUnresolved | Overloaded. Returns true if the target represents an unresolved member with limited support for reflection.
Resolve | Resolves the specified CodeReference.
Wrap | Overloaded. Obtains a reflection wrapper for an attribute instance.
WrapNamespace | Obtains a reflection wrapper for a namespace.
Top

See Also

Reflector Class
Gallio.Reflection Namespace


Properties

Reflector Properties
[image]

Public Properties

Name | Description
NativeReflectionPolicy | Gets the singleton instance of the native IReflectionPolicy based on .Net reflection.
Top

See Also

Reflector Class
Gallio.Reflection Namespace


NativeReflectionPolicy Property

Reflector.NativeReflectionPolicy Property
[image]

Gets the singleton instance of the native IReflectionPolicy based on .Net reflection.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property NativeReflectionPolicy As IReflectionPolicy
C#
public static IReflectionPolicy NativeReflectionPolicy { get; }
C++
public static property IReflectionPolicy NativeReflectionPolicy {
IReflectionPolicy get();
}
J#
/** property */
public IReflectionPolicy get_NativeReflectionPolicy();
JScript
public function get NativeReflectionPolicy() : IReflectionPolicy

See Also

Reflector Class
Gallio.Reflection Namespace


Methods

Reflector Methods
[image]

Public Methods

Name | Description
GetCallingFunction | Creates a code element from the caller of the executing function.
GetExecutingFunction | Creates a code element from the executing function.
GetFunctionFromStackFrame | Creates a code element representing a function from a particular frame on the current stack.
IsUnresolved | Overloaded. Returns true if the target represents an unresolved member with limited support for reflection.
Resolve | Resolves the specified CodeReference.
Wrap | Overloaded. Obtains a reflection wrapper for an attribute instance.
WrapNamespace | Obtains a reflection wrapper for a namespace.
Top

See Also

Reflector Class
Gallio.Reflection Namespace


GetCallingFunction Method

Reflector.GetCallingFunction Method
[image]

Creates a code element from the caller of the executing function.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCallingFunction() As IFunctionInfo
C#
public static IFunctionInfo GetCallingFunction()
C++
public:
static IFunctionInfo GetCallingFunction()
J#
public static IFunctionInfo GetCallingFunction()
JScript
public static function GetCallingFunction() : IFunctionInfo

Return Value

The code reference

Remarks

This information may be unreliable if the compiler has inlined the executing or calling method into its caller because the stack frame information will be incomplete. This can can occur when compiler optimizations are turned on and the method body is simple.

The inlining problem can be circumvented like this:

Copy Code
            [NonInlined(SecurityAction.Demand)]
            public void Foo()
            {
                IMethodInfo r = NativeReflector.GetCallingFunction();
                // ...
            }

See Also

Reflector Class
Gallio.Reflection Namespace


GetExecutingFunction Method

Reflector.GetExecutingFunction Method
[image]

Creates a code element from the executing function.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExecutingFunction() As IFunctionInfo
C#
public static IFunctionInfo GetExecutingFunction()
C++
public:
static IFunctionInfo GetExecutingFunction()
J#
public static IFunctionInfo GetExecutingFunction()
JScript
public static function GetExecutingFunction() : IFunctionInfo

Return Value

The code reference

Remarks

This information may be unreliable if the compiler has inlined the executing method into its caller because the stack frame information will be incomplete. This can can occur when compiler optimizations are turned on and the method body is simple.

The inlining problem can be circumvented like this:

Copy Code
            [NonInlined(SecurityAction.Demand)]
            public void Foo()
            {
                IMethodInfo r = NativeReflector.GetExecutingFunction();
                // ...
            }

See Also

Reflector Class
Gallio.Reflection Namespace


GetFunctionFromStackFrame Method

Reflector.GetFunctionFromStackFrame Method
[image]

Creates a code element representing a function from a particular frame on the current stack.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFunctionFromStackFrame( _
ByVal framesToSkip As Integer _
) As IFunctionInfo
C#
public static IFunctionInfo GetFunctionFromStackFrame(
int framesToSkip
)
C++
public:
static IFunctionInfo GetFunctionFromStackFrame(
int framesToSkip
)
J#
public static IFunctionInfo GetFunctionFromStackFrame(
int framesToSkip
)
JScript
public static function GetFunctionFromStackFrame(
framesToSkip : int
) : IFunctionInfo

Parameters

framesToSkip
The number of frames to skip. If this number is 0, the code reference will refer to the direct caller of this method; if it is 1, it will refer to the caller's caller, and so on.

Return Value

The code reference

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if framesToSkip is less than zero

See Also

Reflector Class
Gallio.Reflection Namespace


IsUnresolved Method

Reflector.IsUnresolved Method

Returns true if the target represents an unresolved member with limited support for reflection.

Overload List

Name | Description
IsUnresolved (MemberInfo) | Returns true if the target represents an unresolved member with limited support for reflection.
IsUnresolved (ParameterInfo) | Returns true if the target represents an unresolved parameter with limited support for reflection.

See Also

Reflector Class
Gallio.Reflection Namespace


IsUnresolved Method (MemberInfo)

Reflector.IsUnresolved Method (MemberInfo)
See Also Example
[image]

Returns true if the target represents an unresolved member with limited support for reflection.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsUnresolved( _
ByVal target As MemberInfo _
) As Boolean
C#
public static bool IsUnresolved(
MemberInfo target
)
C++
public:
static bool IsUnresolved(
MemberInfo target
)
J#
public static bool IsUnresolved(
MemberInfo target
)
JScript
public static function IsUnresolved(
target : MemberInfo
) : bool

Parameters

target
The member, or null if none

Return Value

True if the target is unresolved

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.IsUnresolved Overload List
IUnresolvedCodeElement


IsUnresolved Method (ParameterInfo)

Reflector.IsUnresolved Method (ParameterInfo)
See Also Example
[image]

Returns true if the target represents an unresolved parameter with limited support for reflection.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsUnresolved( _
ByVal target As ParameterInfo _
) As Boolean
C#
public static bool IsUnresolved(
ParameterInfo target
)
C++
public:
static bool IsUnresolved(
ParameterInfo target
)
J#
public static bool IsUnresolved(
ParameterInfo target
)
JScript
public static function IsUnresolved(
target : ParameterInfo
) : bool

Parameters

target
The parameter, or null if none

Return Value

True if the target is unresolved

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.IsUnresolved Overload List
IUnresolvedCodeElement


Resolve Method

Reflector.Resolve Method
[image]

Resolves the specified CodeReference.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Resolve( _
ByVal reference As CodeReference, _
ByVal throwOnError As Boolean _
) As ICodeElementInfo
C#
public static ICodeElementInfo Resolve(
CodeReference reference,
bool throwOnError
)
C++
public:
static ICodeElementInfo Resolve(
CodeReference reference,
bool throwOnError
)
J#
public static ICodeElementInfo Resolve(
CodeReference reference,
bool throwOnError
)
JScript
public static function Resolve(
reference : CodeReference,
throwOnError : bool
) : ICodeElementInfo

Parameters

reference
The code reference
throwOnError
If true, throws an exception on error

Return Value

The associated code element, or null if the code reference is of kind Unknown

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if throwOnError is true and reference cannot be resolved

See Also

Reflector Class
Gallio.Reflection Namespace


Wrap Method

Reflector.Wrap Method

Obtains a reflection wrapper for an attribute instance.

Overload List

Name | Description
Wrap (Attribute) | Obtains a reflection wrapper for an attribute instance.
Wrap (Assembly) | Obtains a reflection wrapper for an assembly.
Wrap (ConstructorInfo) | Obtains a reflection wrapper for a constructor.
Wrap (EventInfo) | Obtains a reflection wrapper for an event.
Wrap (FieldInfo) | Obtains a reflection wrapper for a field.
Wrap (MemberInfo) | Obtains a reflection wrapper for a member.
Wrap (MethodBase) | Obtains a reflection wrapper for a function.
Wrap (MethodInfo) | Obtains a reflection wrapper for a method.
Wrap (ParameterInfo) | Obtains a reflection wrapper for a parameter.
Wrap (PropertyInfo) | Obtains a reflection wrapper for a property.
Wrap (Type) | Obtains a reflection wrapper for a type.

See Also

Reflector Class
Gallio.Reflection Namespace


Wrap Method (Attribute)

Reflector.Wrap Method (Attribute)
See Also Example
[image]

Obtains a reflection wrapper for an attribute instance.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As Attribute _
) As IAttributeInfo
C#
public static IAttributeInfo Wrap(
Attribute target
)
C++
public:
static IAttributeInfo Wrap(
Attribute target
)
J#
public static IAttributeInfo Wrap(
Attribute target
)
JScript
public static function Wrap(
target : Attribute
) : IAttributeInfo

Parameters

target
The attribute, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (Assembly)

Reflector.Wrap Method (Assembly)
See Also Example
[image]

Obtains a reflection wrapper for an assembly.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As Assembly _
) As IAssemblyInfo
C#
public static IAssemblyInfo Wrap(
Assembly target
)
C++
public:
static IAssemblyInfo Wrap(
Assembly target
)
J#
public static IAssemblyInfo Wrap(
Assembly target
)
JScript
public static function Wrap(
target : Assembly
) : IAssemblyInfo

Parameters

target
The assembly, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (ConstructorInfo)

Reflector.Wrap Method (ConstructorInfo)
See Also Example
[image]

Obtains a reflection wrapper for a constructor.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As ConstructorInfo _
) As IConstructorInfo
C#
public static IConstructorInfo Wrap(
ConstructorInfo target
)
C++
public:
static IConstructorInfo Wrap(
ConstructorInfo target
)
J#
public static IConstructorInfo Wrap(
ConstructorInfo target
)
JScript
public static function Wrap(
target : ConstructorInfo
) : IConstructorInfo

Parameters

target
The constructor, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (EventInfo)

Reflector.Wrap Method (EventInfo)
See Also Example
[image]

Obtains a reflection wrapper for an event.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As EventInfo _
) As IEventInfo
C#
public static IEventInfo Wrap(
EventInfo target
)
C++
public:
static IEventInfo Wrap(
EventInfo target
)
J#
public static IEventInfo Wrap(
EventInfo target
)
JScript
public static function Wrap(
target : EventInfo
) : IEventInfo

Parameters

target
The event, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (FieldInfo)

Reflector.Wrap Method (FieldInfo)
See Also Example
[image]

Obtains a reflection wrapper for a field.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As FieldInfo _
) As IFieldInfo
C#
public static IFieldInfo Wrap(
FieldInfo target
)
C++
public:
static IFieldInfo Wrap(
FieldInfo target
)
J#
public static IFieldInfo Wrap(
FieldInfo target
)
JScript
public static function Wrap(
target : FieldInfo
) : IFieldInfo

Parameters

target
The field, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (MemberInfo)

Reflector.Wrap Method (MemberInfo)
See Also Example
[image]

Obtains a reflection wrapper for a member.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As MemberInfo _
) As IMemberInfo
C#
public static IMemberInfo Wrap(
MemberInfo target
)
C++
public:
static IMemberInfo Wrap(
MemberInfo target
)
J#
public static IMemberInfo Wrap(
MemberInfo target
)
JScript
public static function Wrap(
target : MemberInfo
) : IMemberInfo

Parameters

target
The member, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (MethodBase)

Reflector.Wrap Method (MethodBase)
See Also Example
[image]

Obtains a reflection wrapper for a function.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As MethodBase _
) As IFunctionInfo
C#
public static IFunctionInfo Wrap(
MethodBase target
)
C++
public:
static IFunctionInfo Wrap(
MethodBase target
)
J#
public static IFunctionInfo Wrap(
MethodBase target
)
JScript
public static function Wrap(
target : MethodBase
) : IFunctionInfo

Parameters

target
The function, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (MethodInfo)

Reflector.Wrap Method (MethodInfo)
See Also Example
[image]

Obtains a reflection wrapper for a method.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As MethodInfo _
) As IMethodInfo
C#
public static IMethodInfo Wrap(
MethodInfo target
)
C++
public:
static IMethodInfo Wrap(
MethodInfo target
)
J#
public static IMethodInfo Wrap(
MethodInfo target
)
JScript
public static function Wrap(
target : MethodInfo
) : IMethodInfo

Parameters

target
The method, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (ParameterInfo)

Reflector.Wrap Method (ParameterInfo)
See Also Example
[image]

Obtains a reflection wrapper for a parameter.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As ParameterInfo _
) As IParameterInfo
C#
public static IParameterInfo Wrap(
ParameterInfo target
)
C++
public:
static IParameterInfo Wrap(
ParameterInfo target
)
J#
public static IParameterInfo Wrap(
ParameterInfo target
)
JScript
public static function Wrap(
target : ParameterInfo
) : IParameterInfo

Parameters

target
The parameter, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (PropertyInfo)

Reflector.Wrap Method (PropertyInfo)
See Also Example
[image]

Obtains a reflection wrapper for a property.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As PropertyInfo _
) As IPropertyInfo
C#
public static IPropertyInfo Wrap(
PropertyInfo target
)
C++
public:
static IPropertyInfo Wrap(
PropertyInfo target
)
J#
public static IPropertyInfo Wrap(
PropertyInfo target
)
JScript
public static function Wrap(
target : PropertyInfo
) : IPropertyInfo

Parameters

target
The property, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


Wrap Method (Type)

Reflector.Wrap Method (Type)
See Also Example
[image]

Obtains a reflection wrapper for a type.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Wrap( _
ByVal target As Type _
) As ITypeInfo
C#
public static ITypeInfo Wrap(
Type target
)
C++
public:
static ITypeInfo Wrap(
Type target
)
J#
public static ITypeInfo Wrap(
Type target
)
JScript
public static function Wrap(
target : Type
) : ITypeInfo

Parameters

target
The type, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace
Reflector.Wrap Overload List


WrapNamespace Method

Reflector.WrapNamespace Method
[image]

Obtains a reflection wrapper for a namespace.

Namespace: Gallio.Reflection
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function WrapNamespace( _
ByVal name As String _
) As INamespaceInfo
C#
public static INamespaceInfo WrapNamespace(
string name
)
C++
public:
static INamespaceInfo WrapNamespace(
String name
)
J#
public static INamespaceInfo WrapNamespace(
string name
)
JScript
public static function WrapNamespace(
name : String
) : INamespaceInfo

Parameters

name
The namespace name, or null if none

Return Value

The reflection wrapper, or null if none

See Also

Reflector Class
Gallio.Reflection Namespace


Gallio.Reflection.Impl

Gallio.Reflection.Impl Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | BaseReflectionPolicy | A base reflection policy implementation that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | ComDebugSymbolResolver | Resolves debug symbols via the CorMetaDataDispenser COM class.
Public class | DebugSymbolUtils | Helpers for working with IDebugSymbolResolver. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | DefaultXmlDocumentationResolver | The default XML documentation resolver reads XML documentation files on demand when available and caches them in memory for subsequent accesses. It takes care of mapping member names to XML documentation conventions when asked to resolve the documentation for a member.
Public class | MonoDebugSymbolResolver | Implementation of a debug symbol resolver for Mono.
Public class ReflectorAttributeUtils

Provides helpers for enumerating attributes taking into account the attribute inheritance structure.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class ReflectorFlagsUtils

Provides helpers for manipulating reflection flags enumerations.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

Public class ReflectorResolveUtils

Provides helpers for resolving abstract reflection objects to obtain native ones based on the structural properties of the reflected code elements.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

Public class ReflectorTypeUtils

Provides helpers for working with types and type codes.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

Public class | StaticArrayTypeWrapper | A StaticReflectionPolicy array type wrapper. This class cannot be inherited.
Public class | StaticAssemblyWrapper | A StaticReflectionPolicy assembly wrapper. This class cannot be inherited.
Public class | StaticAttributeWrapper | A StaticReflectionPolicy attribute wrapper. This class cannot be inherited.
Public class | StaticByRefTypeWrapper | A StaticReflectionPolicy by-ref type wrapper. This class cannot be inherited.
Public class | StaticCodeElementWrapper | A StaticReflectionPolicy code element wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | StaticConstructedTypeWrapper | A StaticReflectionPolicy constructed type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | StaticConstructorWrapper | A StaticReflectionPolicy constructor wrapper. This class cannot be inherited.
Public class | StaticDeclaredTypeWrapper | A StaticReflectionPolicy declared type wrapper such as a class, struct, enum or interface definition. This class cannot be inherited.
Public class | StaticEventWrapper | A StaticReflectionPolicy event wrapper. This class cannot be inherited.
Public class | StaticFieldWrapper | A StaticReflectionPolicy field wrapper. This class cannot be inherited.
Public class | StaticFunctionWrapper | A StaticReflectionPolicy function wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | StaticGenericParameterWrapper | A StaticReflectionPolicy generic parameter wrapper. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | StaticMemberWrapper | A StaticReflectionPolicy member wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | StaticMethodWrapper | A StaticReflectionPolicy method wrapper. This class cannot be inherited.
Public class | StaticParameterWrapper | A StaticReflectionPolicy parameter wrapper. This class cannot be inherited.
Public class | StaticPointerTypeWrapper | A StaticReflectionPolicy pointer type wrapper. This class cannot be inherited.
Public class | StaticPropertyWrapper | A StaticReflectionPolicy property wrapper. This class cannot be inherited.
Public class | StaticReflectedMemberWrapper | A StaticReflectionPolicy member wrapper for members that are not types, generic parameters or nested types. These members must be declared by types, so they all share the constraint that the declaring type and reflected type must not be null. In particular, the reflected type may be a subtype of the declaring type in the case of inherited members. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class StaticReflectionPolicy

The static reflection policy base class is intended to assist with the implementation of custom reflection policies defined over static metadata.

It flattens out the code element hierarchy to ease implementation of new policies. It provides a mechanism for handling generic type substitutions to ensure a consistent and correct implementation of generic type and generic method instantiations.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | StaticSpecialTypeWrapper | A StaticReflectionPolicy type wrapper that represents a special type that is either constructed from other types or derived from them as with a generic parameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | StaticTypeWrapper | A StaticReflectionPolicy type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class StaticWrapper

A StaticReflectionPolicy wrapper.

A wrapper holds an underlying reflection object. Its behavior is derived from by primitive operations on the Handle defined by the particular Policy implementation that is in use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | UnresolvedConstructorInfo | Represents a ConstructorInfo whose native definition could not be resolved so we fall back on the IConstructorInfo wrapper. This class cannot be inherited.
Public class | UnresolvedEventInfo | Represents a EventInfo whose native definition could not be resolved so we fall back on the IEventInfo wrapper. This class cannot be inherited.
Public class | UnresolvedFieldInfo | Represents a FieldInfo whose native definition could not be resolved so we fall back on the IFieldInfo wrapper. This class cannot be inherited.
Public class | UnresolvedMethodInfo | Represents a MethodInfo whose native definition could not be resolved so we fall back on the IMethodInfo wrapper. This class cannot be inherited.
Public class | UnresolvedParameterInfo | Represents a ParameterInfo whose native definition could not be resolved so we fall back on the IParameterInfo wrapper. This class cannot be inherited.
Public class | UnresolvedPropertyInfo | Represents a PropertyInfo whose native definition could not be resolved so we fall back on the IPropertyInfo wrapper. This class cannot be inherited.
Public class | UnresolvedType | Represents a Type whose native definition could not be resolved so we fall back on the ITypeInfo wrapper. This class cannot be inherited.
Public class | XmlDocumentationUtils | Helpers for working with IXmlDocumentationResolver. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

 | Interface | Description
Public interface | IDebugSymbolResolver | Resolves debug symbols associated with members.
Public interface | IResolvableTypeInfo | This extension of ITypeInfo is provided to enable the resolution of a type with ResolveType.
Public interface | IUnresolvedCodeElement | An interface implemented by special reflection types that represent code elements whose native definition could not be resolved so we fall back on the ICodeElementInfo wrapper instead.
Public interface | IXmlDocumentationResolver | Resolves members to XML documentation contents.

Structures

 | Structure | Description
Public structure | StaticTypeSubstitution | A type substitution specifies how generic parameters are replaced by other types. It is used by implementors of StaticReflectionPolicy when returning types that may be represented as generic parameters.


BaseReflectionPolicy Class

BaseReflectionPolicy Class
See Also Example Members
[image]

A base reflection policy implementation that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseReflectionPolicy
Implements IReflectionPolicy
C#
public abstract class BaseReflectionPolicy : IReflectionPolicy
C++
ref class BaseReflectionPolicy abstract : IReflectionPolicy
J#
public class BaseReflectionPolicy implements IReflectionPolicy
JScript
public class BaseReflectionPolicy extends IReflectionPolicy

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.BaseReflectionPolicy
Gallio.Reflection.Impl.StaticReflectionPolicy

See Also

BaseReflectionPolicy Members
Gallio.Reflection.Impl Namespace


BaseReflectionPolicy Members

BaseReflectionPolicy Members
See Also Example Constructors Methods
[image]

A base reflection policy implementation that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseReflectionPolicy.

Protected Constructors

 | Name | Description
Family method | BaseReflectionPolicy | Initializes a new instance of the BaseReflectionPolicy class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadAssembly | Loads an assembly by name.
Public method | LoadAssemblyFrom | Loads an assembly from a file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LoadAssemblyFromImpl | Loads an assembly from a file.
Family method | LoadAssemblyImpl | Loads an assembly.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


BaseReflectionPolicy Constructor

BaseReflectionPolicy Constructor
[image]

Initializes a new instance of the BaseReflectionPolicy class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseReflectionPolicy()
C++
protected:
BaseReflectionPolicy() sealed
J#
protected BaseReflectionPolicy()
JScript
protected function BaseReflectionPolicy()

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


Methods

BaseReflectionPolicy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadAssembly | Loads an assembly by name.
Public method | LoadAssemblyFrom | Loads an assembly from a file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LoadAssemblyFromImpl | Loads an assembly from a file.
Family method | LoadAssemblyImpl | Loads an assembly.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


LoadAssembly Method

BaseReflectionPolicy.LoadAssembly Method
[image]

Loads an assembly by name.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadAssembly( _
ByVal assemblyName As AssemblyName _
) As IAssemblyInfo _
Implements IReflectionPolicy.LoadAssembly
C#
public IAssemblyInfo LoadAssembly(
AssemblyName assemblyName
)
C++
public:
IAssemblyInfo LoadAssembly(
AssemblyName assemblyName
) sealed
J#
public IAssemblyInfo LoadAssembly(
AssemblyName assemblyName
)
JScript
public function LoadAssembly(
assemblyName : AssemblyName
) : IAssemblyInfo

Parameters

assemblyName
The full or partial assembly name of the assembly to load

Return Value

The loaded assembly

Implements

IReflectionPolicy.LoadAssembly

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


LoadAssemblyFrom Method

BaseReflectionPolicy.LoadAssemblyFrom Method
[image]

Loads an assembly from a file.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadAssemblyFrom( _
ByVal assemblyFile As String _
) As IAssemblyInfo _
Implements IReflectionPolicy.LoadAssemblyFrom
C#
public IAssemblyInfo LoadAssemblyFrom(
string assemblyFile
)
C++
public:
IAssemblyInfo LoadAssemblyFrom(
String assemblyFile
) sealed
J#
public IAssemblyInfo LoadAssemblyFrom(
string assemblyFile
)
JScript
public function LoadAssemblyFrom(
assemblyFile : String
) : IAssemblyInfo

Parameters

assemblyFile
The assembly file path

Return Value

The loaded assembly

Implements

IReflectionPolicy.LoadAssemblyFrom

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


LoadAssemblyFromImpl Method

BaseReflectionPolicy.LoadAssemblyFromImpl Method
[image]

Loads an assembly from a file.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function LoadAssemblyFromImpl( _
ByVal assemblyFile As String _
) As IAssemblyInfo
C#
protected abstract IAssemblyInfo LoadAssemblyFromImpl(
string assemblyFile
)
C++
protected:
IAssemblyInfo LoadAssemblyFromImpl(
String assemblyFile
) abstract
J#
protected abstract IAssemblyInfo LoadAssemblyFromImpl(
string assemblyFile
)
JScript
protected abstract function LoadAssemblyFromImpl(
assemblyFile : String
) : IAssemblyInfo

Parameters

assemblyFile
The assembly file path, not null

Return Value

The loaded assembly wrapper

Exceptions

Exception Type | Condition
Exception | Any exception may be thrown if the loading fails

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


LoadAssemblyImpl Method

BaseReflectionPolicy.LoadAssemblyImpl Method
[image]

Loads an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function LoadAssemblyImpl( _
ByVal assemblyName As AssemblyName _
) As IAssemblyInfo
C#
protected abstract IAssemblyInfo LoadAssemblyImpl(
AssemblyName assemblyName
)
C++
protected:
IAssemblyInfo LoadAssemblyImpl(
AssemblyName assemblyName
) abstract
J#
protected abstract IAssemblyInfo LoadAssemblyImpl(
AssemblyName assemblyName
)
JScript
protected abstract function LoadAssemblyImpl(
assemblyName : AssemblyName
) : IAssemblyInfo

Parameters

assemblyName
The assembly name, not null

Return Value

The loaded assembly wrapper

Exceptions

Exception Type | Condition
Exception | Any exception may be thrown if the loading fails

See Also

BaseReflectionPolicy Class
Gallio.Reflection.Impl Namespace


ComDebugSymbolResolver Class

ComDebugSymbolResolver Class
See Also Example Members
[image]

Resolves debug symbols via the CorMetaDataDispenser COM class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ComDebugSymbolResolver
Implements IDebugSymbolResolver, IDisposable
C#
public class ComDebugSymbolResolver : IDebugSymbolResolver, IDisposable
C++
ref class ComDebugSymbolResolver : IDebugSymbolResolver, IDisposable
J#
public class ComDebugSymbolResolver implements IDebugSymbolResolver, IDisposable
JScript
public class ComDebugSymbolResolver extends IDebugSymbolResolver, IDisposable

Remarks

This code has been adapted from the CLR Managed Debugger sample from http://www.microsoft.com/downloads/details.aspx?FamilyID=38449a42-6b7a-4e28-80ce-c55645ab1310 and from Mike Stall's PDB2Xml program sample available on his blog at: http://blogs.msdn.com/jmstall/archive/2005/08/25/pdb2xml.aspx. Many thanks to you!

We do not use the ISymWrapper implementation of the symbol store interfaces because they throw COMExceptions whenever method metadata is not available. This causes confusion for users because the Visual Studio Debugger Exception Assistant window may pop up dozens of times while loading symbol information.

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.ComDebugSymbolResolver

See Also

ComDebugSymbolResolver Members
Gallio.Reflection.Impl Namespace


ComDebugSymbolResolver Members

ComDebugSymbolResolver Members
See Also Example Constructors Methods
[image]

Resolves debug symbols via the CorMetaDataDispenser COM class.

The following tables list the members exposed by ComDebugSymbolResolver.

Public Constructors

 | Name | Description
Public method | ComDebugSymbolResolver | Creates a COM debug symbol resolver.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetSourceLocationForMethod | Gets the location of a source file that contains the declaration of a method, or null if not available.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ComDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


ComDebugSymbolResolver Constructor

ComDebugSymbolResolver Constructor
[image]

Creates a COM debug symbol resolver.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal avoidLocks As Boolean _
)
C#
public ComDebugSymbolResolver(
bool avoidLocks
)
C++
public:
ComDebugSymbolResolver(
bool avoidLocks
) sealed
J#
public ComDebugSymbolResolver(
bool avoidLocks
)
JScript
public function ComDebugSymbolResolver(
avoidLocks : bool
)

Parameters

avoidLocks
If true, avoids taking a lock on the PDB files but may use more memory or storage

See Also

ComDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


Methods

ComDebugSymbolResolver Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetSourceLocationForMethod | Gets the location of a source file that contains the declaration of a method, or null if not available.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ComDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


Dispose Method

ComDebugSymbolResolver.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

ComDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


GetSourceLocationForMethod Method

ComDebugSymbolResolver.GetSourceLocationForMethod Method
[image]

Gets the location of a source file that contains the declaration of a method, or null if not available.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSourceLocationForMethod( _
ByVal assemblyPath As String, _
ByVal methodToken As Integer _
) As CodeLocation _
Implements IDebugSymbolResolver.GetSourceLocationForMethod
C#
public CodeLocation GetSourceLocationForMethod(
string assemblyPath,
int methodToken
)
C++
public:
CodeLocation GetSourceLocationForMethod(
String assemblyPath,
int methodToken
) sealed
J#
public CodeLocation GetSourceLocationForMethod(
string assemblyPath,
int methodToken
)
JScript
public function GetSourceLocationForMethod(
assemblyPath : String,
methodToken : int
) : CodeLocation

Parameters

assemblyPath
The path of the assembly that contains the method
methodToken
The method token

Return Value

The source code location, or null if unknown

Implements

IDebugSymbolResolver.GetSourceLocationForMethod

See Also

ComDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


DebugSymbolUtils Class

DebugSymbolUtils Class
See Also Example Members
[image]

Helpers for working with IDebugSymbolResolver. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module DebugSymbolUtils
C#
public static class DebugSymbolUtils
C++
ref class DebugSymbolUtils abstract sealed
J#
public final class DebugSymbolUtils
JScript
public class DebugSymbolUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.DebugSymbolUtils

See Also

DebugSymbolUtils Members
Gallio.Reflection.Impl Namespace


DebugSymbolUtils Members

DebugSymbolUtils Members
See Also Example Properties Methods
[image]

Helpers for working with IDebugSymbolResolver. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by DebugSymbolUtils.

Public Properties

Name | Description
Resolver | Gets the singleton debug symbol resolver used by these utilities.
Top

Public Methods

Name | Description
CreateResolver | Creates a new debug symbol resolver appropriate for this platform.
GetSourceLocation | Overloaded. Gets the location of a source file that contains the declaration of a method, or unknown if not available.
Top

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace


Properties

DebugSymbolUtils Properties
[image]

Public Properties

Name | Description
Resolver | Gets the singleton debug symbol resolver used by these utilities.
Top

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace


Resolver Property

DebugSymbolUtils.Resolver Property
[image]

Gets the singleton debug symbol resolver used by these utilities.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Resolver As IDebugSymbolResolver
C#
public static IDebugSymbolResolver Resolver { get; }
C++
public static property IDebugSymbolResolver Resolver {
IDebugSymbolResolver get();
}
J#
/** property */
public IDebugSymbolResolver get_Resolver();
JScript
public function get Resolver() : IDebugSymbolResolver

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace


Methods

DebugSymbolUtils Methods
[image]

Public Methods

Name | Description
CreateResolver | Creates a new debug symbol resolver appropriate for this platform.
GetSourceLocation | Overloaded. Gets the location of a source file that contains the declaration of a method, or unknown if not available.
Top

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace


CreateResolver Method

DebugSymbolUtils.CreateResolver Method
[image]

Creates a new debug symbol resolver appropriate for this platform.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateResolver( _
ByVal avoidLocks As Boolean _
) As IDebugSymbolResolver
C#
public static IDebugSymbolResolver CreateResolver(
bool avoidLocks
)
C++
public:
static IDebugSymbolResolver CreateResolver(
bool avoidLocks
)
J#
public static IDebugSymbolResolver CreateResolver(
bool avoidLocks
)
JScript
public static function CreateResolver(
avoidLocks : bool
) : IDebugSymbolResolver

Parameters

avoidLocks
If true, avoids taking a lock on the PDB files but may use more memory or storage

Return Value

The debug symbol resolver

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace


GetSourceLocation Method

DebugSymbolUtils.GetSourceLocation Method

Gets the location of a source file that contains the declaration of a method, or unknown if not available.

Overload List

Name | Description
GetSourceLocation (MethodBase) | Gets the location of a source file that contains the declaration of a method, or unknown if not available.
GetSourceLocation (Type) | Gets the location of a source file that contains the declaration of a type, or unknown if not available.

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace


GetSourceLocation Method (MethodBase)

DebugSymbolUtils.GetSourceLocation Method (MethodBase)
See Also Example
[image]

Gets the location of a source file that contains the declaration of a method, or unknown if not available.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSourceLocation( _
ByVal method As MethodBase _
) As CodeLocation
C#
public static CodeLocation GetSourceLocation(
MethodBase method
)
C++
public:
static CodeLocation GetSourceLocation(
MethodBase method
)
J#
public static CodeLocation GetSourceLocation(
MethodBase method
)
JScript
public static function GetSourceLocation(
method : MethodBase
) : CodeLocation

Parameters

method
The method

Return Value

The source location, or Unknown if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if method is null

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace
DebugSymbolUtils.GetSourceLocation Overload List


GetSourceLocation Method (Type)

DebugSymbolUtils.GetSourceLocation Method (Type)
See Also Example
[image]

Gets the location of a source file that contains the declaration of a type, or unknown if not available.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSourceLocation( _
ByVal type As Type _
) As CodeLocation
C#
public static CodeLocation GetSourceLocation(
Type type
)
C++
public:
static CodeLocation GetSourceLocation(
Type type
)
J#
public static CodeLocation GetSourceLocation(
Type type
)
JScript
public static function GetSourceLocation(
type : Type
) : CodeLocation

Parameters

type
The type

Return Value

The code location, or Unknown if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

DebugSymbolUtils Class
Gallio.Reflection.Impl Namespace
DebugSymbolUtils.GetSourceLocation Overload List


DefaultXmlDocumentationResolver Class

DefaultXmlDocumentationResolver Class
See Also Example Members
[image]

The default XML documentation resolver reads XML documentation files on demand when available and caches them in memory for subsequent accesses. It takes care of mapping member names to XML documentation conventions when asked to resolve the documentation for a member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultXmlDocumentationResolver
Implements IXmlDocumentationResolver
C#
public class DefaultXmlDocumentationResolver : IXmlDocumentationResolver
C++
ref class DefaultXmlDocumentationResolver : IXmlDocumentationResolver
J#
public class DefaultXmlDocumentationResolver implements IXmlDocumentationResolver
JScript
public class DefaultXmlDocumentationResolver extends IXmlDocumentationResolver

Remarks

All operations are thread-safe.

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.DefaultXmlDocumentationResolver

See Also

DefaultXmlDocumentationResolver Members
Gallio.Reflection.Impl Namespace


DefaultXmlDocumentationResolver Members

DefaultXmlDocumentationResolver Members
See Also Example Constructors Methods
[image]

The default XML documentation resolver reads XML documentation files on demand when available and caches them in memory for subsequent accesses. It takes care of mapping member names to XML documentation conventions when asked to resolve the documentation for a member.

The following tables list the members exposed by DefaultXmlDocumentationResolver.

Public Constructors

 | Name | Description
Public method | DefaultXmlDocumentationResolver | Creates an XML documentation loader.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation for a member in an assembly.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultXmlDocumentationResolver Class
Gallio.Reflection.Impl Namespace


DefaultXmlDocumentationResolver Constructor

DefaultXmlDocumentationResolver Constructor
[image]

Creates an XML documentation loader.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DefaultXmlDocumentationResolver()
C++
public:
DefaultXmlDocumentationResolver() sealed
J#
public DefaultXmlDocumentationResolver()
JScript
public function DefaultXmlDocumentationResolver()

See Also

DefaultXmlDocumentationResolver Class
Gallio.Reflection.Impl Namespace


Methods

DefaultXmlDocumentationResolver Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation for a member in an assembly.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultXmlDocumentationResolver Class
Gallio.Reflection.Impl Namespace


GetXmlDocumentation Method

DefaultXmlDocumentationResolver.GetXmlDocumentation Method
[image]

Gets the XML documentation for a member in an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetXmlDocumentation( _
ByVal assemblyPath As String, _
ByVal memberId As String _
) As String _
Implements IXmlDocumentationResolver.GetXmlDocumentation
C#
public string GetXmlDocumentation(
string assemblyPath,
string memberId
)
C++
public:
String GetXmlDocumentation(
String assemblyPath,
String memberId
) sealed
J#
public string GetXmlDocumentation(
string assemblyPath,
string memberId
)
JScript
public function GetXmlDocumentation(
assemblyPath : String,
memberId : String
) : String

Parameters

assemblyPath
The assembly path
memberId
The XML documentation id of the member

Return Value

The XML documentation for the member, or null if none available

Implements

IXmlDocumentationResolver.GetXmlDocumentation

See Also

DefaultXmlDocumentationResolver Class
Gallio.Reflection.Impl Namespace


IDebugSymbolResolver Interface

IDebugSymbolResolver Interface
See Also Example Members
[image]

Resolves debug symbols associated with members.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDebugSymbolResolver
Implements IDisposable
C#
public interface IDebugSymbolResolver : IDisposable
C++
interface class IDebugSymbolResolver : IDisposable
J#
public interface IDebugSymbolResolver implements IDisposable
JScript
public interface IDebugSymbolResolver extends IDisposable

Types that implement IDebugSymbolResolver

Type | Description
Gallio.Reflection.Impl.ComDebugSymbolResolver | Resolves debug symbols via the CorMetaDataDispenser COM class.
Gallio.Reflection.Impl.MonoDebugSymbolResolver | Implementation of a debug symbol resolver for Mono.

See Also

IDebugSymbolResolver Members
Gallio.Reflection.Impl Namespace


IDebugSymbolResolver Members

IDebugSymbolResolver Members
See Also Example Methods
[image]

Resolves debug symbols associated with members.

The following tables list the members exposed by IDebugSymbolResolver.

Public Methods

 | Name | Description
Public method | GetSourceLocationForMethod | Gets the location of a source file that contains the declaration of a method, or null if not available.
Top

See Also

IDebugSymbolResolver Interface
Gallio.Reflection.Impl Namespace


Methods

IDebugSymbolResolver Methods
[image]

Public Methods

 | Name | Description
Public method | GetSourceLocationForMethod | Gets the location of a source file that contains the declaration of a method, or null if not available.
Top

See Also

IDebugSymbolResolver Interface
Gallio.Reflection.Impl Namespace


GetSourceLocationForMethod Method

IDebugSymbolResolver.GetSourceLocationForMethod Method
[image]

Gets the location of a source file that contains the declaration of a method, or null if not available.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetSourceLocationForMethod( _
ByVal assemblyPath As String, _
ByVal methodToken As Integer _
) As CodeLocation
C#
CodeLocation GetSourceLocationForMethod(
string assemblyPath,
int methodToken
)
C++
CodeLocation GetSourceLocationForMethod(
String assemblyPath,
int methodToken
) abstract
J#
CodeLocation GetSourceLocationForMethod(
string assemblyPath,
int methodToken
)
JScript
function GetSourceLocationForMethod(
assemblyPath : String,
methodToken : int
) : CodeLocation

Parameters

assemblyPath
The path of the assembly that contains the method
methodToken
The method token

Return Value

The source code location, or null if unknown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyPath is null

See Also

IDebugSymbolResolver Interface
Gallio.Reflection.Impl Namespace


IResolvableTypeInfo Interface

IResolvableTypeInfo Interface
See Also Example Members
[image]

This extension of ITypeInfo is provided to enable the resolution of a type with ResolveType.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IResolvableTypeInfo
Implements ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable(Of ICodeElementInfo), IEquatable(Of IMemberInfo), IEquatable(Of ITypeInfo)
C#
public interface IResolvableTypeInfo : ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>
C++
interface class IResolvableTypeInfo : ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>
J#
public interface IResolvableTypeInfo implements ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>
JScript
public interface IResolvableTypeInfo extends ITypeInfo, IMemberInfo, ICodeElementInfo, IEquatable<ICodeElementInfo>, IEquatable<IMemberInfo>, IEquatable<ITypeInfo>

Types that implement IResolvableTypeInfo

Type | Description
Gallio.Reflection.Impl.StaticTypeWrapper | A StaticReflectionPolicy type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IResolvableTypeInfo Members
Gallio.Reflection.Impl Namespace


IResolvableTypeInfo Members

IResolvableTypeInfo Members
See Also Example Methods
[image]

This extension of ITypeInfo is provided to enable the resolution of a type with ResolveType.

The following tables list the members exposed by IResolvableTypeInfo.

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target within the scope of the specified method.
Top

See Also

IResolvableTypeInfo Interface
Gallio.Reflection.Impl Namespace


Methods

IResolvableTypeInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the wrapper to its native reflection target within the scope of the specified method.
Top

See Also

IResolvableTypeInfo Interface
Gallio.Reflection.Impl Namespace


Resolve Method

IResolvableTypeInfo.Resolve Method
[image]

Resolves the wrapper to its native reflection target within the scope of the specified method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal methodContext As MethodInfo, _
ByVal throwOnError As Boolean _
) As Type
C#
Type Resolve(
MethodInfo methodContext,
bool throwOnError
)
C++
Type Resolve(
MethodInfo methodContext,
bool throwOnError
) abstract
J#
Type Resolve(
MethodInfo methodContext,
bool throwOnError
)
JScript
function Resolve(
methodContext : MethodInfo,
throwOnError : bool
) : Type

Parameters

methodContext
The method that is currently in scope, or null if none. This parameter is used when resolving types that are part of the signature of a generic method so that generic method arguments can be handled correctly.
throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the target cannot be resolved

See Also

IResolvableTypeInfo Interface
Gallio.Reflection.Impl Namespace


IUnresolvedCodeElement Interface

IUnresolvedCodeElement Interface
See Also Example Members
[image]

An interface implemented by special reflection types that represent code elements whose native definition could not be resolved so we fall back on the ICodeElementInfo wrapper instead.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IUnresolvedCodeElement
C#
public interface IUnresolvedCodeElement
C++
interface class IUnresolvedCodeElement
J#
public interface IUnresolvedCodeElement
JScript
public interface IUnresolvedCodeElement

Types that implement IUnresolvedCodeElement

Type | Description
Gallio.Reflection.Impl.UnresolvedConstructorInfo | Represents a ConstructorInfo whose native definition could not be resolved so we fall back on the IConstructorInfo wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.UnresolvedEventInfo | Represents a EventInfo whose native definition could not be resolved so we fall back on the IEventInfo wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.UnresolvedFieldInfo | Represents a FieldInfo whose native definition could not be resolved so we fall back on the IFieldInfo wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.UnresolvedMethodInfo | Represents a MethodInfo whose native definition could not be resolved so we fall back on the IMethodInfo wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.UnresolvedParameterInfo | Represents a ParameterInfo whose native definition could not be resolved so we fall back on the IParameterInfo wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.UnresolvedPropertyInfo | Represents a PropertyInfo whose native definition could not be resolved so we fall back on the IPropertyInfo wrapper. This class cannot be inherited.
Gallio.Reflection.Impl.UnresolvedType | Represents a Type whose native definition could not be resolved so we fall back on the ITypeInfo wrapper. This class cannot be inherited.

See Also

IUnresolvedCodeElement Members
Gallio.Reflection.Impl Namespace


IUnresolvedCodeElement Members

IUnresolvedCodeElement Members
See Also Example Properties
[image]

An interface implemented by special reflection types that represent code elements whose native definition could not be resolved so we fall back on the ICodeElementInfo wrapper instead.

The following tables list the members exposed by IUnresolvedCodeElement.

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Top

See Also

IUnresolvedCodeElement Interface
Gallio.Reflection.Impl Namespace


Properties

IUnresolvedCodeElement Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Top

See Also

IUnresolvedCodeElement Interface
Gallio.Reflection.Impl Namespace


Adapter Property

IUnresolvedCodeElement.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Adapter As ICodeElementInfo
C#
ICodeElementInfo Adapter { get; }
C++
property ICodeElementInfo Adapter abstract {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_Adapter();
JScript
public function get Adapter() : ICodeElementInfo

See Also

IUnresolvedCodeElement Interface
Gallio.Reflection.Impl Namespace


IXmlDocumentationResolver Interface

IXmlDocumentationResolver Interface
See Also Example Members
[image]

Resolves members to XML documentation contents.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IXmlDocumentationResolver
C#
public interface IXmlDocumentationResolver
C++
interface class IXmlDocumentationResolver
J#
public interface IXmlDocumentationResolver
JScript
public interface IXmlDocumentationResolver

Types that implement IXmlDocumentationResolver

Type | Description
Gallio.Reflection.Impl.DefaultXmlDocumentationResolver | The default XML documentation resolver reads XML documentation files on demand when available and caches them in memory for subsequent accesses. It takes care of mapping member names to XML documentation conventions when asked to resolve the documentation for a member.

See Also

IXmlDocumentationResolver Members
Gallio.Reflection.Impl Namespace


IXmlDocumentationResolver Members

IXmlDocumentationResolver Members
See Also Example Methods
[image]

Resolves members to XML documentation contents.

The following tables list the members exposed by IXmlDocumentationResolver.

Public Methods

 | Name | Description
Public method | GetXmlDocumentation | Gets the XML documentation for a member in an assembly.
Top

See Also

IXmlDocumentationResolver Interface
Gallio.Reflection.Impl Namespace


Methods

IXmlDocumentationResolver Methods
[image]

Public Methods

 | Name | Description
Public method | GetXmlDocumentation | Gets the XML documentation for a member in an assembly.
Top

See Also

IXmlDocumentationResolver Interface
Gallio.Reflection.Impl Namespace


GetXmlDocumentation Method

IXmlDocumentationResolver.GetXmlDocumentation Method
[image]

Gets the XML documentation for a member in an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetXmlDocumentation( _
ByVal assemblyPath As String, _
ByVal memberId As String _
) As String
C#
string GetXmlDocumentation(
string assemblyPath,
string memberId
)
C++
String GetXmlDocumentation(
String assemblyPath,
String memberId
) abstract
J#
string GetXmlDocumentation(
string assemblyPath,
string memberId
)
JScript
function GetXmlDocumentation(
assemblyPath : String,
memberId : String
) : String

Parameters

assemblyPath
The assembly path
memberId
The XML documentation id of the member

Return Value

The XML documentation for the member, or null if none available

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyPath or memberId is null

See Also

IXmlDocumentationResolver Interface
Gallio.Reflection.Impl Namespace


MonoDebugSymbolResolver Class

MonoDebugSymbolResolver Class
See Also Example Members
[image]

Implementation of a debug symbol resolver for Mono.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class MonoDebugSymbolResolver
Implements IDebugSymbolResolver, IDisposable
C#
public class MonoDebugSymbolResolver : IDebugSymbolResolver, IDisposable
C++
ref class MonoDebugSymbolResolver : IDebugSymbolResolver, IDisposable
J#
public class MonoDebugSymbolResolver implements IDebugSymbolResolver, IDisposable
JScript
public class MonoDebugSymbolResolver extends IDebugSymbolResolver, IDisposable

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.MonoDebugSymbolResolver

See Also

MonoDebugSymbolResolver Members
Gallio.Reflection.Impl Namespace


MonoDebugSymbolResolver Members

MonoDebugSymbolResolver Members
See Also Example Constructors Methods
[image]

Implementation of a debug symbol resolver for Mono.

The following tables list the members exposed by MonoDebugSymbolResolver.

Public Constructors

 | Name | Description
Public method | MonoDebugSymbolResolver | Creates a Mono debug symbol resolver.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetSourceLocationForMethod | Gets the location of a source file that contains the declaration of a method, or null if not available.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MonoDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


MonoDebugSymbolResolver Constructor

MonoDebugSymbolResolver Constructor
[image]

Creates a Mono debug symbol resolver.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal avoidLocks As Boolean _
)
C#
public MonoDebugSymbolResolver(
bool avoidLocks
)
C++
public:
MonoDebugSymbolResolver(
bool avoidLocks
) sealed
J#
public MonoDebugSymbolResolver(
bool avoidLocks
)
JScript
public function MonoDebugSymbolResolver(
avoidLocks : bool
)

Parameters

avoidLocks
If true, avoids taking a lock on the PDB files but may use more memory or storage

See Also

MonoDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


Methods

MonoDebugSymbolResolver Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetSourceLocationForMethod | Gets the location of a source file that contains the declaration of a method, or null if not available.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MonoDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


Dispose Method

MonoDebugSymbolResolver.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

MonoDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


GetSourceLocationForMethod Method

MonoDebugSymbolResolver.GetSourceLocationForMethod Method
[image]

Gets the location of a source file that contains the declaration of a method, or null if not available.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSourceLocationForMethod( _
ByVal assemblyPath As String, _
ByVal methodToken As Integer _
) As CodeLocation _
Implements IDebugSymbolResolver.GetSourceLocationForMethod
C#
public CodeLocation GetSourceLocationForMethod(
string assemblyPath,
int methodToken
)
C++
public:
CodeLocation GetSourceLocationForMethod(
String assemblyPath,
int methodToken
) sealed
J#
public CodeLocation GetSourceLocationForMethod(
string assemblyPath,
int methodToken
)
JScript
public function GetSourceLocationForMethod(
assemblyPath : String,
methodToken : int
) : CodeLocation

Parameters

assemblyPath
The path of the assembly that contains the method
methodToken
The method token

Return Value

The source code location, or null if unknown

Implements

IDebugSymbolResolver.GetSourceLocationForMethod

See Also

MonoDebugSymbolResolver Class
Gallio.Reflection.Impl Namespace


ReflectorAttributeUtils Class

ReflectorAttributeUtils Class
See Also Example Members
[image]

Provides helpers for enumerating attributes taking into account the attribute inheritance structure.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ReflectorAttributeUtils
C#
public static class ReflectorAttributeUtils
C++
ref class ReflectorAttributeUtils abstract sealed
J#
public final class ReflectorAttributeUtils
JScript
public class ReflectorAttributeUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.ReflectorAttributeUtils

See Also

ReflectorAttributeUtils Members
Gallio.Reflection.Impl Namespace


ReflectorAttributeUtils Members

ReflectorAttributeUtils Members
See Also Example Methods
[image]

Provides helpers for enumerating attributes taking into account the attribute inheritance structure.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ReflectorAttributeUtils.

Public Methods

Name | Description
CreateAttribute | Creates an attribute instance from an IAttributeInfo.
IsAttributeField | Returns true if the field is assignable as a named attribute parameter.
IsAttributeProperty | Returns true if the property is assignable as a named attribute parameter.
Top

See Also

ReflectorAttributeUtils Class
Gallio.Reflection.Impl Namespace


Methods

ReflectorAttributeUtils Methods
[image]

Public Methods

Name | Description
CreateAttribute | Creates an attribute instance from an IAttributeInfo.
IsAttributeField | Returns true if the field is assignable as a named attribute parameter.
IsAttributeProperty | Returns true if the property is assignable as a named attribute parameter.
Top

See Also

ReflectorAttributeUtils Class
Gallio.Reflection.Impl Namespace


CreateAttribute Method

ReflectorAttributeUtils.CreateAttribute Method
[image]

Creates an attribute instance from an IAttributeInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateAttribute( _
ByVal attribute As IAttributeInfo, _
ByVal throwOnError As Boolean _
) As Object
C#
public static object CreateAttribute(
IAttributeInfo attribute,
bool throwOnError
)
C++
public:
static Object CreateAttribute(
IAttributeInfo attribute,
bool throwOnError
)
J#
public static object CreateAttribute(
IAttributeInfo attribute,
bool throwOnError
)
JScript
public static function CreateAttribute(
attribute : IAttributeInfo,
throwOnError : bool
) : Object

Parameters

attribute
The attribute description
throwOnError
If true, throws an exception if the target could not be resolved, otherwise the result may include unresolved types, enums or arrays

Return Value

The attribute instance

Exceptions

Exception Type | Condition
ReflectionWrapperResolveException | Thrown if the attribute could not be resolved

Remarks

This method may be used by Resolve to construct an attribute instance from its raw description. Client code should call Resolve instead of using this method directly.

See Also

ReflectorAttributeUtils Class
Gallio.Reflection.Impl Namespace


IsAttributeField Method

ReflectorAttributeUtils.IsAttributeField Method
[image]

Returns true if the field is assignable as a named attribute parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsAttributeField( _
ByVal field As IFieldInfo _
) As Boolean
C#
public static bool IsAttributeField(
IFieldInfo field
)
C++
public:
static bool IsAttributeField(
IFieldInfo field
)
J#
public static bool IsAttributeField(
IFieldInfo field
)
JScript
public static function IsAttributeField(
field : IFieldInfo
) : bool

Parameters

field
The field

Return Value

True if the field is assignable

See Also

ReflectorAttributeUtils Class
Gallio.Reflection.Impl Namespace


IsAttributeProperty Method

ReflectorAttributeUtils.IsAttributeProperty Method
[image]

Returns true if the property is assignable as a named attribute parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsAttributeProperty( _
ByVal property As IPropertyInfo _
) As Boolean
C#
public static bool IsAttributeProperty(
IPropertyInfo property
)
C++
public:
static bool IsAttributeProperty(
IPropertyInfo property
)
J#
public static bool IsAttributeProperty(
IPropertyInfo property
)
JScript
public static function IsAttributeProperty(
property : IPropertyInfo
) : bool

Parameters

property
The property

Return Value

True if the property is assignable

See Also

ReflectorAttributeUtils Class
Gallio.Reflection.Impl Namespace


ReflectorFlagsUtils Class

ReflectorFlagsUtils Class
See Also Example Members
[image]

Provides helpers for manipulating reflection flags enumerations.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ReflectorFlagsUtils
C#
public class ReflectorFlagsUtils
C++
ref class ReflectorFlagsUtils
J#
public class ReflectorFlagsUtils
JScript
public class ReflectorFlagsUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.ReflectorFlagsUtils

See Also

ReflectorFlagsUtils Members
Gallio.Reflection.Impl Namespace


ReflectorFlagsUtils Members

ReflectorFlagsUtils Members
See Also Example Constructors Methods
[image]

Provides helpers for manipulating reflection flags enumerations.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

The following tables list the members exposed by ReflectorFlagsUtils.

Public Constructors

 | Name | Description
Public method | ReflectorFlagsUtils | Initializes a new instance of the ReflectorFlagsUtils class.
Top

Public Methods

 | Name | Description
 | AddFlagIfTrue | Overloaded. Adds flagToAdd to the flags enumeration if condition is true.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace


ReflectorFlagsUtils Constructor

ReflectorFlagsUtils Constructor
[image]

Initializes a new instance of the ReflectorFlagsUtils class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ReflectorFlagsUtils()
C++
public:
ReflectorFlagsUtils() sealed
J#
public ReflectorFlagsUtils()
JScript
public function ReflectorFlagsUtils()

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace


Methods

ReflectorFlagsUtils Methods
[image]

Public Methods

 | Name | Description
 | AddFlagIfTrue | Overloaded. Adds flagToAdd to the flags enumeration if condition is true.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace


AddFlagIfTrue Method

ReflectorFlagsUtils.AddFlagIfTrue Method

Adds flagToAdd to the flags enumeration if condition is true.

Overload List

Name | Description
AddFlagIfTrue (CallingConventions, CallingConventions, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.
AddFlagIfTrue (FieldAttributes, FieldAttributes, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.
AddFlagIfTrue (GenericParameterAttributes, GenericParameterAttributes, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.
AddFlagIfTrue (MethodAttributes, MethodAttributes, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.
AddFlagIfTrue (ParameterAttributes, ParameterAttributes, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.
AddFlagIfTrue (PropertyAttributes, PropertyAttributes, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.
AddFlagIfTrue (TypeAttributes, TypeAttributes, Boolean) | Adds flagToAdd to the flags enumeration if condition is true.

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace


AddFlagIfTrue Method (CallingConventions, CallingConventions, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (CallingConventions, CallingConventions, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As CallingConventions, _
ByVal flagToAdd As CallingConventions, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref CallingConventions flags,
CallingConventions flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
CallingConventions% flags,
CallingConventions flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
CallingConventions flags,
CallingConventions flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : CallingConventions,
flagToAdd : CallingConventions,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


AddFlagIfTrue Method (FieldAttributes, FieldAttributes, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (FieldAttributes, FieldAttributes, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As FieldAttributes, _
ByVal flagToAdd As FieldAttributes, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref FieldAttributes flags,
FieldAttributes flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
FieldAttributes% flags,
FieldAttributes flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
FieldAttributes flags,
FieldAttributes flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : FieldAttributes,
flagToAdd : FieldAttributes,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


AddFlagIfTrue Method (GenericParameterAttributes, GenericParameterAttributes, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (GenericParameterAttributes, GenericParameterAttributes, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As GenericParameterAttributes, _
ByVal flagToAdd As GenericParameterAttributes, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref GenericParameterAttributes flags,
GenericParameterAttributes flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
GenericParameterAttributes% flags,
GenericParameterAttributes flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
GenericParameterAttributes flags,
GenericParameterAttributes flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : GenericParameterAttributes,
flagToAdd : GenericParameterAttributes,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


AddFlagIfTrue Method (MethodAttributes, MethodAttributes, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (MethodAttributes, MethodAttributes, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As MethodAttributes, _
ByVal flagToAdd As MethodAttributes, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref MethodAttributes flags,
MethodAttributes flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
MethodAttributes% flags,
MethodAttributes flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
MethodAttributes flags,
MethodAttributes flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : MethodAttributes,
flagToAdd : MethodAttributes,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


AddFlagIfTrue Method (ParameterAttributes, ParameterAttributes, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (ParameterAttributes, ParameterAttributes, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As ParameterAttributes, _
ByVal flagToAdd As ParameterAttributes, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref ParameterAttributes flags,
ParameterAttributes flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
ParameterAttributes% flags,
ParameterAttributes flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
ParameterAttributes flags,
ParameterAttributes flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : ParameterAttributes,
flagToAdd : ParameterAttributes,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


AddFlagIfTrue Method (PropertyAttributes, PropertyAttributes, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (PropertyAttributes, PropertyAttributes, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As PropertyAttributes, _
ByVal flagToAdd As PropertyAttributes, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref PropertyAttributes flags,
PropertyAttributes flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
PropertyAttributes% flags,
PropertyAttributes flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
PropertyAttributes flags,
PropertyAttributes flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : PropertyAttributes,
flagToAdd : PropertyAttributes,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


AddFlagIfTrue Method (TypeAttributes, TypeAttributes, Boolean)

ReflectorFlagsUtils.AddFlagIfTrue Method (TypeAttributes, TypeAttributes, Boolean)
See Also Example
[image]

Adds flagToAdd to the flags enumeration if condition is true.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AddFlagIfTrue( _
ByRef flags As TypeAttributes, _
ByVal flagToAdd As TypeAttributes, _
ByVal condition As Boolean _
)
C#
public static void AddFlagIfTrue(
ref TypeAttributes flags,
TypeAttributes flagToAdd,
bool condition
)
C++
public:
static void AddFlagIfTrue(
TypeAttributes% flags,
TypeAttributes flagToAdd,
bool condition
)
J#
public static void AddFlagIfTrue(
TypeAttributes flags,
TypeAttributes flagToAdd,
bool condition
)
JScript
public static function AddFlagIfTrue(
flags : TypeAttributes,
flagToAdd : TypeAttributes,
condition : bool
)

Parameters

flags
The flags enumeration to update
flagToAdd
The flag to add if condition is true
condition
The condition to check

See Also

ReflectorFlagsUtils Class
Gallio.Reflection.Impl Namespace
ReflectorFlagsUtils.AddFlagIfTrue Overload List


ReflectorResolveUtils Class

ReflectorResolveUtils Class
See Also Example Members
[image]

Provides helpers for resolving abstract reflection objects to obtain native ones based on the structural properties of the reflected code elements.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ReflectorResolveUtils
C#
public class ReflectorResolveUtils
C++
ref class ReflectorResolveUtils
J#
public class ReflectorResolveUtils
JScript
public class ReflectorResolveUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.ReflectorResolveUtils

See Also

ReflectorResolveUtils Members
Gallio.Reflection.Impl Namespace


ReflectorResolveUtils Members

ReflectorResolveUtils Members
See Also Example Constructors Methods
[image]

Provides helpers for resolving abstract reflection objects to obtain native ones based on the structural properties of the reflected code elements.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

The following tables list the members exposed by ReflectorResolveUtils.

Public Constructors

 | Name | Description
Public method | ReflectorResolveUtils | Initializes a new instance of the ReflectorResolveUtils class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | ResolveAssembly | Resolves a reflected assembly to its native Assembly object.
 | ResolveConstructor | Resolves a reflected constructor to its native ConstructorInfo object.
 | ResolveEvent | Resolves a reflected event to its native EventInfo object.
 | ResolveField | Resolves a reflected field to its native FieldInfo object.
 | ResolveMethod | Resolves a reflected method to its native MethodInfo object.
 | ResolveParameter | Resolves a reflected parameter to its native ParameterInfo object.
 | ResolveProperty | Resolves a reflected property to its native PropertyInfo object.
 | ResolveType | Resolves a reflected type to its native Type object.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ReflectorResolveUtils Constructor

ReflectorResolveUtils Constructor
[image]

Initializes a new instance of the ReflectorResolveUtils class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ReflectorResolveUtils()
C++
public:
ReflectorResolveUtils() sealed
J#
public ReflectorResolveUtils()
JScript
public function ReflectorResolveUtils()

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


Methods

ReflectorResolveUtils Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | ResolveAssembly | Resolves a reflected assembly to its native Assembly object.
 | ResolveConstructor | Resolves a reflected constructor to its native ConstructorInfo object.
 | ResolveEvent | Resolves a reflected event to its native EventInfo object.
 | ResolveField | Resolves a reflected field to its native FieldInfo object.
 | ResolveMethod | Resolves a reflected method to its native MethodInfo object.
 | ResolveParameter | Resolves a reflected parameter to its native ParameterInfo object.
 | ResolveProperty | Resolves a reflected property to its native PropertyInfo object.
 | ResolveType | Resolves a reflected type to its native Type object.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveAssembly Method

ReflectorResolveUtils.ResolveAssembly Method
[image]

Resolves a reflected assembly to its native Assembly object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveAssembly( _
ByVal assembly As IAssemblyInfo, _
ByVal fallbackOnPartialName As Boolean, _
ByVal throwOnError As Boolean _
) As Assembly
C#
public static Assembly ResolveAssembly(
IAssemblyInfo assembly,
bool fallbackOnPartialName,
bool throwOnError
)
C++
public:
static Assembly ResolveAssembly(
IAssemblyInfo assembly,
bool fallbackOnPartialName,
bool throwOnError
)
J#
public static Assembly ResolveAssembly(
IAssemblyInfo assembly,
bool fallbackOnPartialName,
bool throwOnError
)
JScript
public static function ResolveAssembly(
assembly : IAssemblyInfo,
fallbackOnPartialName : bool,
throwOnError : bool
) : Assembly

Parameters

assembly
The reflected assembly
fallbackOnPartialName
If true, allows the assembly to be resolved by partial name if no match could be found by fullname
throwOnError
If true, throws an exception if resolution fails, otherwise returns null

Return Value

The resolved Assembly.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null
ReflectionWrapperResolveException | Thrown if assembly could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveConstructor Method

ReflectorResolveUtils.ResolveConstructor Method
[image]

Resolves a reflected constructor to its native ConstructorInfo object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveConstructor( _
ByVal constructor As IConstructorInfo, _
ByVal throwOnError As Boolean _
) As ConstructorInfo
C#
public static ConstructorInfo ResolveConstructor(
IConstructorInfo constructor,
bool throwOnError
)
C++
public:
static ConstructorInfo ResolveConstructor(
IConstructorInfo constructor,
bool throwOnError
)
J#
public static ConstructorInfo ResolveConstructor(
IConstructorInfo constructor,
bool throwOnError
)
JScript
public static function ResolveConstructor(
constructor : IConstructorInfo,
throwOnError : bool
) : ConstructorInfo

Parameters

constructor
The reflected constructor
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedConstructorInfo

Return Value

The resolved ConstructorInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if constructor is null
ReflectionWrapperResolveException | Thrown if constructor could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveEvent Method

ReflectorResolveUtils.ResolveEvent Method
[image]

Resolves a reflected event to its native EventInfo object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveEvent( _
ByVal event As IEventInfo, _
ByVal throwOnError As Boolean _
) As EventInfo
C#
public static EventInfo ResolveEvent(
IEventInfo event,
bool throwOnError
)
C++
public:
static EventInfo ResolveEvent(
IEventInfo event,
bool throwOnError
)
J#
public static EventInfo ResolveEvent(
IEventInfo event,
bool throwOnError
)
JScript
public static function ResolveEvent(
event : IEventInfo,
throwOnError : bool
) : EventInfo

Parameters

event
The reflected event
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedEventInfo

Return Value

The resolved EventInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if event is null
ReflectionWrapperResolveException | Thrown if event could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveField Method

ReflectorResolveUtils.ResolveField Method
[image]

Resolves a reflected field to its native FieldInfo object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveField( _
ByVal field As IFieldInfo, _
ByVal throwOnError As Boolean _
) As FieldInfo
C#
public static FieldInfo ResolveField(
IFieldInfo field,
bool throwOnError
)
C++
public:
static FieldInfo ResolveField(
IFieldInfo field,
bool throwOnError
)
J#
public static FieldInfo ResolveField(
IFieldInfo field,
bool throwOnError
)
JScript
public static function ResolveField(
field : IFieldInfo,
throwOnError : bool
) : FieldInfo

Parameters

field
The reflected type
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedFieldInfo

Return Value

The resolved FieldInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if field is null
ReflectionWrapperResolveException | Thrown if field could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveMethod Method

ReflectorResolveUtils.ResolveMethod Method
[image]

Resolves a reflected method to its native MethodInfo object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveMethod( _
ByVal method As IMethodInfo, _
ByVal throwOnError As Boolean _
) As MethodInfo
C#
public static MethodInfo ResolveMethod(
IMethodInfo method,
bool throwOnError
)
C++
public:
static MethodInfo ResolveMethod(
IMethodInfo method,
bool throwOnError
)
J#
public static MethodInfo ResolveMethod(
IMethodInfo method,
bool throwOnError
)
JScript
public static function ResolveMethod(
method : IMethodInfo,
throwOnError : bool
) : MethodInfo

Parameters

method
The reflected method
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedMethodInfo

Return Value

The resolved MethodInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if method is null
ReflectionWrapperResolveException | Thrown if method could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveParameter Method

ReflectorResolveUtils.ResolveParameter Method
[image]

Resolves a reflected parameter to its native ParameterInfo object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveParameter( _
ByVal parameter As IParameterInfo, _
ByVal throwOnError As Boolean _
) As ParameterInfo
C#
public static ParameterInfo ResolveParameter(
IParameterInfo parameter,
bool throwOnError
)
C++
public:
static ParameterInfo ResolveParameter(
IParameterInfo parameter,
bool throwOnError
)
J#
public static ParameterInfo ResolveParameter(
IParameterInfo parameter,
bool throwOnError
)
JScript
public static function ResolveParameter(
parameter : IParameterInfo,
throwOnError : bool
) : ParameterInfo

Parameters

parameter
The reflected parameter
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedParameterInfo

Return Value

The resolved ParameterInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if parameter is null
ReflectionWrapperResolveException | Thrown if parameter could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveProperty Method

ReflectorResolveUtils.ResolveProperty Method
[image]

Resolves a reflected property to its native PropertyInfo object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveProperty( _
ByVal property As IPropertyInfo, _
ByVal throwOnError As Boolean _
) As PropertyInfo
C#
public static PropertyInfo ResolveProperty(
IPropertyInfo property,
bool throwOnError
)
C++
public:
static PropertyInfo ResolveProperty(
IPropertyInfo property,
bool throwOnError
)
J#
public static PropertyInfo ResolveProperty(
IPropertyInfo property,
bool throwOnError
)
JScript
public static function ResolveProperty(
property : IPropertyInfo,
throwOnError : bool
) : PropertyInfo

Parameters

property
The reflected property
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedPropertyInfo

Return Value

The resolved PropertyInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if property is null
ReflectionWrapperResolveException | Thrown if property could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ResolveType Method

ReflectorResolveUtils.ResolveType Method
[image]

Resolves a reflected type to its native Type object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ResolveType( _
ByVal type As IResolvableTypeInfo, _
ByVal methodContext As MethodInfo, _
ByVal throwOnError As Boolean _
) As Type
C#
public static Type ResolveType(
IResolvableTypeInfo type,
MethodInfo methodContext,
bool throwOnError
)
C++
public:
static Type ResolveType(
IResolvableTypeInfo type,
MethodInfo methodContext,
bool throwOnError
)
J#
public static Type ResolveType(
IResolvableTypeInfo type,
MethodInfo methodContext,
bool throwOnError
)
JScript
public static function ResolveType(
type : IResolvableTypeInfo,
methodContext : MethodInfo,
throwOnError : bool
) : Type

Parameters

type
The reflected type
methodContext
The method that is currently in scope, or null if none. This parameter is used when resolving types that are part of the signature of a generic method so that generic method arguments can be handled correctly.
throwOnError
If true, throws an exception if resolution fails, otherwise returns an UnresolvedType

Return Value

The resolved Type.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null
ReflectionWrapperResolveException | Thrown if type could not be resolved

See Also

ReflectorResolveUtils Class
Gallio.Reflection.Impl Namespace


ReflectorTypeUtils Class

ReflectorTypeUtils Class
See Also Example Members
[image]

Provides helpers for working with types and type codes.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ReflectorTypeUtils
C#
public class ReflectorTypeUtils
C++
ref class ReflectorTypeUtils
J#
public class ReflectorTypeUtils
JScript
public class ReflectorTypeUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.ReflectorTypeUtils

See Also

ReflectorTypeUtils Members
Gallio.Reflection.Impl Namespace


ReflectorTypeUtils Members

ReflectorTypeUtils Members
See Also Example Constructors Methods
[image]

Provides helpers for working with types and type codes.

This class is intended to assist with the implementation of new reflection policies. It should not be used directly by clients of the reflection API.

The following tables list the members exposed by ReflectorTypeUtils.

Public Constructors

 | Name | Description
Public method | ReflectorTypeUtils | Initializes a new instance of the ReflectorTypeUtils class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetDefaultValue | Gets the default value for a reflected type.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | GetTypeCode | Determines the type code of a reflected type based on the type's name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectorTypeUtils Class
Gallio.Reflection.Impl Namespace


ReflectorTypeUtils Constructor

ReflectorTypeUtils Constructor
[image]

Initializes a new instance of the ReflectorTypeUtils class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ReflectorTypeUtils()
C++
public:
ReflectorTypeUtils() sealed
J#
public ReflectorTypeUtils()
JScript
public function ReflectorTypeUtils()

See Also

ReflectorTypeUtils Class
Gallio.Reflection.Impl Namespace


Methods

ReflectorTypeUtils Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetDefaultValue | Gets the default value for a reflected type.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | GetTypeCode | Determines the type code of a reflected type based on the type's name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ReflectorTypeUtils Class
Gallio.Reflection.Impl Namespace


GetDefaultValue Method

ReflectorTypeUtils.GetDefaultValue Method
[image]

Gets the default value for a reflected type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultValue( _
ByVal type As ITypeInfo _
) As Object
C#
public static object GetDefaultValue(
ITypeInfo type
)
C++
public:
static Object GetDefaultValue(
ITypeInfo type
)
J#
public static object GetDefaultValue(
ITypeInfo type
)
JScript
public static function GetDefaultValue(
type : ITypeInfo
) : Object

Parameters

type
The reflected type

Return Value

The default value for the type, such as 0 if the type represents an integer, or null if the type is a reference type or if type was null

See Also

ReflectorTypeUtils Class
Gallio.Reflection.Impl Namespace


GetTypeCode Method

ReflectorTypeUtils.GetTypeCode Method
[image]

Determines the type code of a reflected type based on the type's name.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTypeCode( _
ByVal type As ITypeInfo _
) As TypeCode
C#
public static TypeCode GetTypeCode(
ITypeInfo type
)
C++
public:
static TypeCode GetTypeCode(
ITypeInfo type
)
J#
public static TypeCode GetTypeCode(
ITypeInfo type
)
JScript
public static function GetTypeCode(
type : ITypeInfo
) : TypeCode

Parameters

type
The reflected type, or null if none

Return Value

The type code of the type, or Empty if type was null

See Also

ReflectorTypeUtils Class
Gallio.Reflection.Impl Namespace


StaticArrayTypeWrapper Class

StaticArrayTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy array type wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticArrayTypeWrapper
Inherits StaticConstructedTypeWrapper
C#
public sealed class StaticArrayTypeWrapper : StaticConstructedTypeWrapper
C++
ref class StaticArrayTypeWrapper sealed : StaticConstructedTypeWrapper
J#
public final class StaticArrayTypeWrapper extends StaticConstructedTypeWrapper
JScript
public final class StaticArrayTypeWrapper extends StaticConstructedTypeWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticConstructedTypeWrapper
Gallio.Reflection.Impl.StaticArrayTypeWrapper

See Also

StaticArrayTypeWrapper Members
Gallio.Reflection.Impl Namespace


StaticArrayTypeWrapper Members

StaticArrayTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy array type wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticArrayTypeWrapper.

Public Constructors

 | Name | Description
Public method | StaticArrayTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank | Overridden. Gets the rank of the array type.
Public property | Assembly | Gets the assembly in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects. (inherited from StaticConstructedTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticConstructedTypeWrapper)
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter. (inherited from StaticConstructedTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | Overridden. Returns true if the type represents an array.
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Gets the name of the code element. (inherited from StaticConstructedTypeWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Gets the name of the namespace in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly. (inherited from StaticConstructedTypeWrapper)
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | Overridden.
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticConstructedTypeWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticArrayTypeWrapper Constructor

StaticArrayTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal elementType As StaticTypeWrapper, _
ByVal arrayRank As Integer _
)
C#
public StaticArrayTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType,
int arrayRank
)
C++
public:
StaticArrayTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType,
int arrayRank
) sealed
J#
public StaticArrayTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType,
int arrayRank
)
JScript
public function StaticArrayTypeWrapper(
policy : StaticReflectionPolicy,
elementType : StaticTypeWrapper,
arrayRank : int
)

Parameters

policy
The reflection policy
elementType
The element type
arrayRank
The array rank

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or elementType is null
ArgumentOutOfRangeException | Thrown if arrayRank is less than 1

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticArrayTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | Overridden. Gets the rank of the array type.
Public property | Assembly | Gets the assembly in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects. (inherited from StaticConstructedTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticConstructedTypeWrapper)
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter. (inherited from StaticConstructedTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | Overridden. Returns true if the type represents an array.
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Gets the name of the code element. (inherited from StaticConstructedTypeWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Gets the name of the namespace in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


ArrayRank Property

StaticArrayTypeWrapper.ArrayRank Property
[image]

Gets the rank of the array type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ArrayRank As Integer _
Implements ITypeInfo.ArrayRank
C#
public override int ArrayRank { get; }
C++
public override property int ArrayRank override {
int get();
}
J#
/** property */
public int get_ArrayRank();
JScript
public function get ArrayRank() : int

Implements

ITypeInfo.ArrayRank

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsArray Property

StaticArrayTypeWrapper.IsArray Property
[image]

Returns true if the type represents an array.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsArray As Boolean _
Implements ITypeInfo.IsArray
C#
public override bool IsArray { get; }
C++
public override property bool IsArray override {
bool get();
}
J#
/** property */
public bool get_IsArray();
JScript
public function get IsArray() : bool

Implements

ITypeInfo.IsArray

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


TypeAttributes Property

StaticArrayTypeWrapper.TypeAttributes Property
[image]

Gets the type attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TypeAttributes As TypeAttributes _
Implements ITypeInfo.TypeAttributes
C#
public override TypeAttributes TypeAttributes { get; }
C++
public override property TypeAttributes TypeAttributes override {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

Implements

ITypeInfo.TypeAttributes

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticArrayTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly. (inherited from StaticConstructedTypeWrapper)
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | Overridden.
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticConstructedTypeWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


ApplySubstitution Method

StaticArrayTypeWrapper.ApplySubstitution Method
[image]

Applies a type substitution and returns the resulting type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ApplySubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As ITypeInfo
C#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
C++
protected:
virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
) override
J#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
JScript
protected override function ApplySubstitution(
substitution : StaticTypeSubstitution
) : ITypeInfo

Parameters

substitution
The substitution

Return Value

The type after substitution has been performed

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticArrayTypeWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (Object) | Overridden.
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (ITypeInfo) | (inherited from StaticTypeWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (Object)

StaticArrayTypeWrapper.Equals Method (Object)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticArrayTypeWrapper.Equals Overload List


GetHashCode Method

StaticArrayTypeWrapper.GetHashCode Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

StaticArrayTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticAssemblyWrapper Class

StaticAssemblyWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy assembly wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticAssemblyWrapper
Inherits StaticCodeElementWrapper
Implements IAssemblyInfo
C#
public sealed class StaticAssemblyWrapper : StaticCodeElementWrapper, IAssemblyInfo
C++
ref class StaticAssemblyWrapper sealed : StaticCodeElementWrapper, IAssemblyInfo
J#
public final class StaticAssemblyWrapper extends StaticCodeElementWrapper implements IAssemblyInfo
JScript
public final class StaticAssemblyWrapper extends StaticCodeElementWrapper, IAssemblyInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticAssemblyWrapper

See Also

StaticAssemblyWrapper Members
Gallio.Reflection.Impl Namespace


StaticAssemblyWrapper Members

StaticAssemblyWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy assembly wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticAssemblyWrapper.

Public Constructors

 | Name | Description
Public method | StaticAssemblyWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CodeReference | Overridden. Gets a CodeReference for this code element.
Public property | FullName | Gets the full name of the assembly.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | Overridden. Gets the name of the code element.
Public property | Path | Gets the codebase of the assembly as a local path if possible or as a Uri otherwise.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Overridden. Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.
Public method | GetExportedTypes | Gets the public types exported by the assembly.
Public method | GetHashCode | (inherited from StaticWrapper)
Public method | GetName | Gets the AssemblyName of the assembly.
Public method | GetReferencedAssemblies | Gets the names of the assemblies referenced by this assembly.
Public method | GetType | Overloaded. Gets the Type of the current instance.
Public method | GetTypes | Gets all of the types in an assembly.
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssemblyVisibleTo | Returns true if the internal members of this assembly are visible to the specified assembly.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


StaticAssemblyWrapper Constructor

StaticAssemblyWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object _
)
C#
public StaticAssemblyWrapper(
StaticReflectionPolicy policy,
object handle
)
C++
public:
StaticAssemblyWrapper(
StaticReflectionPolicy policy,
Object handle
) sealed
J#
public StaticAssemblyWrapper(
StaticReflectionPolicy policy,
object handle
)
JScript
public function StaticAssemblyWrapper(
policy : StaticReflectionPolicy,
handle : Object
)

Parameters

policy
The reflection policy
handle
The underlying reflection object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticAssemblyWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference | Overridden. Gets a CodeReference for this code element.
Public property | FullName | Gets the full name of the assembly.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | Overridden. Gets the name of the code element.
Public property | Path | Gets the codebase of the assembly as a local path if possible or as a Uri otherwise.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Top

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


CodeReference Property

StaticAssemblyWrapper.CodeReference Property
[image]

Gets a CodeReference for this code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CodeReference As CodeReference _
Implements ICodeElementInfo.CodeReference
C#
public override CodeReference CodeReference { get; }
C++
public override property CodeReference CodeReference override {
CodeReference get();
}
J#
/** property */
public CodeReference get_CodeReference();
JScript
public function get CodeReference() : CodeReference

Property Value

The code reference

Implements

ICodeElementInfo.CodeReference

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


FullName Property

StaticAssemblyWrapper.FullName Property
[image]

Gets the full name of the assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String _
Implements IAssemblyInfo.FullName
C#
public string FullName { get; }
C++
public property string FullName sealed {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

IAssemblyInfo.FullName

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticAssemblyWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Name Property

StaticAssemblyWrapper.Name Property
[image]

Gets the name of the code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String _
Implements ICodeElementInfo.Name
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ICodeElementInfo.Name

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Path Property

StaticAssemblyWrapper.Path Property
[image]

Gets the codebase of the assembly as a local path if possible or as a Uri otherwise.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Path As String _
Implements IAssemblyInfo.Path
C#
public string Path { get; }
C++
public property string Path sealed {
String get();
}
J#
/** property */
public string get_Path();
JScript
public function get Path() : String

Implements

IAssemblyInfo.Path

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticAssemblyWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Overridden. Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.
Public method | GetExportedTypes | Gets the public types exported by the assembly.
Public method | GetHashCode | (inherited from StaticWrapper)
Public method | GetName | Gets the AssemblyName of the assembly.
Public method | GetReferencedAssemblies | Gets the names of the assemblies referenced by this assembly.
Public method | GetType | Overloaded. Gets the Type of the current instance.
Public method | GetTypes | Gets all of the types in an assembly.
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssemblyVisibleTo | Returns true if the internal members of this assembly are visible to the specified assembly.
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticAssemblyWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (IAssemblyInfo) |
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticWrapper)

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IAssemblyInfo)

StaticAssemblyWrapper.Equals Method (IAssemblyInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IAssemblyInfo _
) As Boolean _
Implements IEquatable<IAssemblyInfo>.Equals
C#
public bool Equals(
IAssemblyInfo other
)
C++
public:
bool Equals(
IAssemblyInfo other
) sealed
J#
public bool Equals(
IAssemblyInfo other
)
JScript
public function Equals(
other : IAssemblyInfo
) : bool

Implements

IEquatable<IAssemblyInfo>.Equals

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace
StaticAssemblyWrapper.Equals Overload List


GetCodeLocation Method

StaticAssemblyWrapper.GetCodeLocation Method
[image]

Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCodeLocation() As CodeLocation _
Implements ICodeElementInfo.GetCodeLocation
C#
public override CodeLocation GetCodeLocation()
C++
public:
virtual CodeLocation GetCodeLocation() override
J#
public override CodeLocation GetCodeLocation()
JScript
public override function GetCodeLocation() : CodeLocation

Return Value

The code location

Implements

ICodeElementInfo.GetCodeLocation

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


GetExportedTypes Method

StaticAssemblyWrapper.GetExportedTypes Method
[image]

Gets the public types exported by the assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExportedTypes() As IList(Of ITypeInfo) _
Implements IAssemblyInfo.GetExportedTypes
C#
public IList<ITypeInfo> GetExportedTypes()
C++
public:
IList<ITypeInfo> GetExportedTypes() sealed
J#
public IList<ITypeInfo> GetExportedTypes()
JScript
public function GetExportedTypes() : IList<ITypeInfo>

Return Value

The exported types

Implements

IAssemblyInfo.GetExportedTypes

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


GetName Method

StaticAssemblyWrapper.GetName Method
[image]

Gets the AssemblyName of the assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetName() As AssemblyName _
Implements IAssemblyInfo.GetName
C#
public AssemblyName GetName()
C++
public:
AssemblyName GetName() sealed
J#
public AssemblyName GetName()
JScript
public function GetName() : AssemblyName

Return Value

The assembly name

Implements

IAssemblyInfo.GetName

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


GetReferencedAssemblies Method

StaticAssemblyWrapper.GetReferencedAssemblies Method
[image]

Gets the names of the assemblies referenced by this assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReferencedAssemblies() As IList(Of AssemblyName) _
Implements IAssemblyInfo.GetReferencedAssemblies
C#
public IList<AssemblyName> GetReferencedAssemblies()
C++
public:
IList<AssemblyName> GetReferencedAssemblies() sealed
J#
public IList<AssemblyName> GetReferencedAssemblies()
JScript
public function GetReferencedAssemblies() : IList<AssemblyName>

Return Value

The names of the references assemblies

Implements

IAssemblyInfo.GetReferencedAssemblies

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


GetType Method

StaticAssemblyWrapper.GetType Method

Gets the Type of the current instance.

Overload List

 | Name | Description
Public method | GetType (String) | Gets a public type by name, or null if not found.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


GetType Method (String)

StaticAssemblyWrapper.GetType Method (String)
See Also Example
[image]

Gets a public type by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetType( _
ByVal typeName As String _
) As ITypeInfo _
Implements IAssemblyInfo.GetType
C#
public ITypeInfo GetType(
string typeName
)
C++
public:
ITypeInfo GetType(
String typeName
) sealed
J#
public ITypeInfo GetType(
string typeName
)
JScript
public function GetType(
typeName : String
) : ITypeInfo

Parameters

typeName
The type name

Return Value

The type

Implements

IAssemblyInfo.GetType

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace
StaticAssemblyWrapper.GetType Overload List


GetTypes Method

StaticAssemblyWrapper.GetTypes Method
[image]

Gets all of the types in an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTypes() As IList(Of ITypeInfo) _
Implements IAssemblyInfo.GetTypes
C#
public IList<ITypeInfo> GetTypes()
C++
public:
IList<ITypeInfo> GetTypes() sealed
J#
public IList<ITypeInfo> GetTypes()
JScript
public function GetTypes() : IList<ITypeInfo>

Return Value

The types

Implements

IAssemblyInfo.GetTypes

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


IsAssemblyVisibleTo Method

StaticAssemblyWrapper.IsAssemblyVisibleTo Method
[image]

Returns true if the internal members of this assembly are visible to the specified assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsAssemblyVisibleTo( _
ByVal other As StaticAssemblyWrapper _
) As Boolean
C#
public bool IsAssemblyVisibleTo(
StaticAssemblyWrapper other
)
C++
public:
bool IsAssemblyVisibleTo(
StaticAssemblyWrapper other
) sealed
J#
public bool IsAssemblyVisibleTo(
StaticAssemblyWrapper other
)
JScript
public function IsAssemblyVisibleTo(
other : StaticAssemblyWrapper
) : bool

Parameters

other
The other assembly

Return Value

True if the other assembly can see internal members of this assembly

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticAssemblyWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As Assembly _
Implements IAssemblyInfo.Resolve
C#
public Assembly Resolve(
bool throwOnError
)
C++
public:
Assembly Resolve(
bool throwOnError
) sealed
J#
public Assembly Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : Assembly

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns null

Return Value

The native reflection target

Implements

IAssemblyInfo.Resolve

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticAssemblyWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticAssemblyWrapper Class
Gallio.Reflection.Impl Namespace


StaticAttributeWrapper Class

StaticAttributeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy attribute wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticAttributeWrapper
Inherits StaticWrapper
Implements IAttributeInfo
C#
public sealed class StaticAttributeWrapper : StaticWrapper, IAttributeInfo
C++
ref class StaticAttributeWrapper sealed : StaticWrapper, IAttributeInfo
J#
public final class StaticAttributeWrapper extends StaticWrapper implements IAttributeInfo
JScript
public final class StaticAttributeWrapper extends StaticWrapper, IAttributeInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticAttributeWrapper

See Also

StaticAttributeWrapper Members
Gallio.Reflection.Impl Namespace


StaticAttributeWrapper Members

StaticAttributeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy attribute wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticAttributeWrapper.

Public Constructors

 | Name | Description
Public method | StaticAttributeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | Constructor | Gets the constructor used to create the attribute.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | InitializedArgumentValues | Gets the initialized attribute constructor argument values.
Public property | InitializedFieldValues | Gets the initialized attribute field values.
Public property | InitializedPropertyValues | Gets the initialized attribute property values.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Type | Gets the attribute type.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticWrapper)
Public method | GetFieldValue | Gets an attribute field value.
Public method | GetHashCode | (inherited from StaticWrapper)
Public method | GetPropertyValue | Gets an attribute property value.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Resolve | Gets the attribute as an object.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


StaticAttributeWrapper Constructor

StaticAttributeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object _
)
C#
public StaticAttributeWrapper(
StaticReflectionPolicy policy,
object handle
)
C++
public:
StaticAttributeWrapper(
StaticReflectionPolicy policy,
Object handle
) sealed
J#
public StaticAttributeWrapper(
StaticReflectionPolicy policy,
object handle
)
JScript
public function StaticAttributeWrapper(
policy : StaticReflectionPolicy,
handle : Object
)

Parameters

policy
The reflection policy
handle
The underlying reflection object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticAttributeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | Constructor | Gets the constructor used to create the attribute.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | InitializedArgumentValues | Gets the initialized attribute constructor argument values.
Public property | InitializedFieldValues | Gets the initialized attribute field values.
Public property | InitializedPropertyValues | Gets the initialized attribute property values.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Type | Gets the attribute type.
Top

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


Constructor Property

StaticAttributeWrapper.Constructor Property
[image]

Gets the constructor used to create the attribute.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Constructor As IConstructorInfo _
Implements IAttributeInfo.Constructor
C#
public IConstructorInfo Constructor { get; }
C++
public property IConstructorInfo Constructor sealed {
IConstructorInfo get();
}
J#
/** property */
public IConstructorInfo get_Constructor();
JScript
public function get Constructor() : IConstructorInfo

Implements

IAttributeInfo.Constructor

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


InitializedArgumentValues Property

StaticAttributeWrapper.InitializedArgumentValues Property
[image]

Gets the initialized attribute constructor argument values.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InitializedArgumentValues As ConstantValue() _
Implements IAttributeInfo.InitializedArgumentValues
C#
public ConstantValue[] InitializedArgumentValues { get; }
C++
public property ConstantValue[] InitializedArgumentValues sealed {
array<ConstantValue>^ get();
}
J#
/** property */
public ConstantValue[] get_InitializedArgumentValues();
JScript
public function get InitializedArgumentValues() : ConstantValue[]

Implements

IAttributeInfo.InitializedArgumentValues

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


InitializedFieldValues Property

StaticAttributeWrapper.InitializedFieldValues Property
[image]

Gets the initialized attribute field values.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InitializedFieldValues As IEnumerable(Of KeyValuePair(Of IFieldInfo, ConstantValue)) _
Implements IAttributeInfo.InitializedFieldValues
C#
public IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> InitializedFieldValues { get; }
C++
public property IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> InitializedFieldValues sealed {
IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>> get_InitializedFieldValues();
JScript
public function get InitializedFieldValues() : IEnumerable<KeyValuePair<IFieldInfo, ConstantValue>>

Implements

IAttributeInfo.InitializedFieldValues

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


InitializedPropertyValues Property

StaticAttributeWrapper.InitializedPropertyValues Property
[image]

Gets the initialized attribute property values.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InitializedPropertyValues As IEnumerable(Of KeyValuePair(Of IPropertyInfo, ConstantValue)) _
Implements IAttributeInfo.InitializedPropertyValues
C#
public IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> InitializedPropertyValues { get; }
C++
public property IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> InitializedPropertyValues sealed {
IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> get();
}
J#
/** property */
public IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>> get_InitializedPropertyValues();
JScript
public function get InitializedPropertyValues() : IEnumerable<KeyValuePair<IPropertyInfo, ConstantValue>>

Implements

IAttributeInfo.InitializedPropertyValues

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


Type Property

StaticAttributeWrapper.Type Property
[image]

Gets the attribute type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As ITypeInfo _
Implements IAttributeInfo.Type
C#
public ITypeInfo Type { get; }
C++
public property ITypeInfo Type sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_Type();
JScript
public function get Type() : ITypeInfo

Implements

IAttributeInfo.Type

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticAttributeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticWrapper)
Public method | GetFieldValue | Gets an attribute field value.
Public method | GetHashCode | (inherited from StaticWrapper)
Public method | GetPropertyValue | Gets an attribute property value.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Resolve | Gets the attribute as an object.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


GetFieldValue Method

StaticAttributeWrapper.GetFieldValue Method
[image]

Gets an attribute field value.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFieldValue( _
ByVal name As String _
) As ConstantValue _
Implements IAttributeInfo.GetFieldValue
C#
public ConstantValue GetFieldValue(
string name
)
C++
public:
ConstantValue GetFieldValue(
String name
) sealed
J#
public ConstantValue GetFieldValue(
string name
)
JScript
public function GetFieldValue(
name : String
) : ConstantValue

Parameters

name
The field name

Return Value

The value, or a default value of the field's type if the field with the specified name was not initialized by the attribute declaration

Implements

IAttributeInfo.GetFieldValue

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


GetPropertyValue Method

StaticAttributeWrapper.GetPropertyValue Method
[image]

Gets an attribute property value.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
ByVal name As String _
) As ConstantValue _
Implements IAttributeInfo.GetPropertyValue
C#
public ConstantValue GetPropertyValue(
string name
)
C++
public:
ConstantValue GetPropertyValue(
String name
) sealed
J#
public ConstantValue GetPropertyValue(
string name
)
JScript
public function GetPropertyValue(
name : String
) : ConstantValue

Parameters

name
The property name

Return Value

The value, or a default value of the propery's type if the property with the specified name was not initialized by the attribute declaration

Implements

IAttributeInfo.GetPropertyValue

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticAttributeWrapper.Resolve Method
[image]

Gets the attribute as an object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As Object _
Implements IAttributeInfo.Resolve
C#
public object Resolve(
bool throwOnError
)
C++
public:
Object Resolve(
bool throwOnError
) sealed
J#
public object Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : Object

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise the result may include unresolved types, enums or arrays though it still may throw an exception if the attribute class cannot be instantiated

Return Value

The attribute

Implements

IAttributeInfo.Resolve

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticAttributeWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticAttributeWrapper Class
Gallio.Reflection.Impl Namespace


StaticByRefTypeWrapper Class

StaticByRefTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy by-ref type wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticByRefTypeWrapper
Inherits StaticConstructedTypeWrapper
C#
public sealed class StaticByRefTypeWrapper : StaticConstructedTypeWrapper
C++
ref class StaticByRefTypeWrapper sealed : StaticConstructedTypeWrapper
J#
public final class StaticByRefTypeWrapper extends StaticConstructedTypeWrapper
JScript
public final class StaticByRefTypeWrapper extends StaticConstructedTypeWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticConstructedTypeWrapper
Gallio.Reflection.Impl.StaticByRefTypeWrapper

See Also

StaticByRefTypeWrapper Members
Gallio.Reflection.Impl Namespace


StaticByRefTypeWrapper Members

StaticByRefTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy by-ref type wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticByRefTypeWrapper.

Public Constructors

 | Name | Description
Public method | StaticByRefTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Gets the assembly in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects. (inherited from StaticConstructedTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticConstructedTypeWrapper)
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter. (inherited from StaticConstructedTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Overridden. Returns true if the type represents a type that is passed by reference.
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Gets the name of the code element. (inherited from StaticConstructedTypeWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Gets the name of the namespace in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly. (inherited from StaticConstructedTypeWrapper)
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | Overridden.
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticConstructedTypeWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticByRefTypeWrapper Constructor

StaticByRefTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal elementType As StaticTypeWrapper _
)
C#
public StaticByRefTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
)
C++
public:
StaticByRefTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
) sealed
J#
public StaticByRefTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
)
JScript
public function StaticByRefTypeWrapper(
policy : StaticReflectionPolicy,
elementType : StaticTypeWrapper
)

Parameters

policy
The reflection policy
elementType
The element type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or elementType is null

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticByRefTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Gets the assembly in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects. (inherited from StaticConstructedTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticConstructedTypeWrapper)
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter. (inherited from StaticConstructedTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Overridden. Returns true if the type represents a type that is passed by reference.
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Gets the name of the code element. (inherited from StaticConstructedTypeWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Gets the name of the namespace in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsByRef Property

StaticByRefTypeWrapper.IsByRef Property
[image]

Returns true if the type represents a type that is passed by reference.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsByRef As Boolean _
Implements ITypeInfo.IsByRef
C#
public override bool IsByRef { get; }
C++
public override property bool IsByRef override {
bool get();
}
J#
/** property */
public bool get_IsByRef();
JScript
public function get IsByRef() : bool

Implements

ITypeInfo.IsByRef

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


TypeAttributes Property

StaticByRefTypeWrapper.TypeAttributes Property
[image]

Gets the type attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TypeAttributes As TypeAttributes _
Implements ITypeInfo.TypeAttributes
C#
public override TypeAttributes TypeAttributes { get; }
C++
public override property TypeAttributes TypeAttributes override {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

Implements

ITypeInfo.TypeAttributes

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticByRefTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly. (inherited from StaticConstructedTypeWrapper)
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | Overridden.
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticConstructedTypeWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


ApplySubstitution Method

StaticByRefTypeWrapper.ApplySubstitution Method
[image]

Applies a type substitution and returns the resulting type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ApplySubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As ITypeInfo
C#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
C++
protected:
virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
) override
J#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
JScript
protected override function ApplySubstitution(
substitution : StaticTypeSubstitution
) : ITypeInfo

Parameters

substitution
The substitution

Return Value

The type after substitution has been performed

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticByRefTypeWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (Object) | Overridden.
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (ITypeInfo) | (inherited from StaticTypeWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (Object)

StaticByRefTypeWrapper.Equals Method (Object)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticByRefTypeWrapper.Equals Overload List


GetHashCode Method

StaticByRefTypeWrapper.GetHashCode Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

StaticByRefTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticCodeElementWrapper Class

StaticCodeElementWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy code element wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticCodeElementWrapper
Inherits StaticWrapper
Implements ICodeElementInfo
C#
public abstract class StaticCodeElementWrapper : StaticWrapper, ICodeElementInfo
C++
ref class StaticCodeElementWrapper abstract : StaticWrapper, ICodeElementInfo
J#
public class StaticCodeElementWrapper extends StaticWrapper implements ICodeElementInfo
JScript
public class StaticCodeElementWrapper extends StaticWrapper, ICodeElementInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticAssemblyWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticParameterWrapper

See Also

StaticCodeElementWrapper Members
Gallio.Reflection.Impl Namespace


StaticCodeElementWrapper Members

StaticCodeElementWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy code element wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticCodeElementWrapper.

Public Constructors

 | Name | Description
Public method | StaticCodeElementWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CodeReference |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind |
Public property | Name |
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type.
Public method | GetAttributes | Gets the code element's custom attributes of the specified type.
Public method | GetCodeLocation |
Public method | GetHashCode | (inherited from StaticWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element.
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes.
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits.
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


StaticCodeElementWrapper Constructor

StaticCodeElementWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object _
)
C#
public StaticCodeElementWrapper(
StaticReflectionPolicy policy,
object handle
)
C++
public:
StaticCodeElementWrapper(
StaticReflectionPolicy policy,
Object handle
) sealed
J#
public StaticCodeElementWrapper(
StaticReflectionPolicy policy,
object handle
)
JScript
public function StaticCodeElementWrapper(
policy : StaticReflectionPolicy,
handle : Object
)

Parameters

policy
The reflection policy
handle
The underlying reflection object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticCodeElementWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind |
Public property | Name |
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Top

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


CodeReference Property

StaticCodeElementWrapper.CodeReference Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property CodeReference As CodeReference _
Implements ICodeElementInfo.CodeReference
C#
public abstract CodeReference CodeReference { get; }
C++
public abstract property CodeReference CodeReference abstract {
CodeReference get();
}
J#
/** property */
public CodeReference get_CodeReference();
JScript
public function get CodeReference() : CodeReference

Implements

ICodeElementInfo.CodeReference

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticCodeElementWrapper.Kind Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public abstract CodeElementKind Kind { get; }
C++
public abstract property CodeElementKind Kind abstract {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


Name Property

StaticCodeElementWrapper.Name Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String _
Implements ICodeElementInfo.Name
C#
public abstract string Name { get; }
C++
public abstract property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ICodeElementInfo.Name

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticCodeElementWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type.
Public method | GetAttributes | Gets the code element's custom attributes of the specified type.
Public method | GetCodeLocation |
Public method | GetHashCode | (inherited from StaticWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element.
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes.
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits.
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticCodeElementWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) |
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticWrapper)

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (ICodeElementInfo)

StaticCodeElementWrapper.Equals Method (ICodeElementInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ICodeElementInfo _
) As Boolean _
Implements IEquatable<ICodeElementInfo>.Equals
C#
public bool Equals(
ICodeElementInfo other
)
C++
public:
bool Equals(
ICodeElementInfo other
) sealed
J#
public bool Equals(
ICodeElementInfo other
)
JScript
public function Equals(
other : ICodeElementInfo
) : bool

Implements

IEquatable<ICodeElementInfo>.Equals

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace
StaticCodeElementWrapper.Equals Overload List


GetAttributeInfos Method

StaticCodeElementWrapper.GetAttributeInfos Method
[image]

Gets information about the code element's custom attributes of the specified type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAttributeInfos( _
ByVal attributeType As ITypeInfo, _
ByVal inherit As Boolean _
) As IEnumerable(Of IAttributeInfo) _
Implements ICodeElementInfo.GetAttributeInfos
C#
public IEnumerable<IAttributeInfo> GetAttributeInfos(
ITypeInfo attributeType,
bool inherit
)
C++
public:
IEnumerable<IAttributeInfo> GetAttributeInfos(
ITypeInfo attributeType,
bool inherit
) sealed
J#
public IEnumerable<IAttributeInfo> GetAttributeInfos(
ITypeInfo attributeType,
bool inherit
)
JScript
public function GetAttributeInfos(
attributeType : ITypeInfo,
inherit : bool
) : IEnumerable<IAttributeInfo>

Parameters

attributeType
The attribute type, or null to return attributes of all types
inherit
If true, includes inherited attributes from base types (but not from interfaces, just like ICustomAttributeProvider does)

Return Value

The code element's attributes

Implements

ICodeElementInfo.GetAttributeInfos

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


GetAttributes Method

StaticCodeElementWrapper.GetAttributes Method
[image]

Gets the code element's custom attributes of the specified type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAttributes( _
ByVal attributeType As ITypeInfo, _
ByVal inherit As Boolean _
) As IEnumerable(Of Object) _
Implements ICodeElementInfo.GetAttributes
C#
public IEnumerable<object> GetAttributes(
ITypeInfo attributeType,
bool inherit
)
C++
public:
IEnumerable<object> GetAttributes(
ITypeInfo attributeType,
bool inherit
) sealed
J#
public IEnumerable<object> GetAttributes(
ITypeInfo attributeType,
bool inherit
)
JScript
public function GetAttributes(
attributeType : ITypeInfo,
inherit : bool
) : IEnumerable<object>

Parameters

attributeType
The attribute type
inherit
If true, includes inherited attributes from base types (but not from interfaces, just like ICustomAttributeProvider does)

Return Value

The attributes

Implements

ICodeElementInfo.GetAttributes

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


GetCodeLocation Method

StaticCodeElementWrapper.GetCodeLocation Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCodeLocation() As CodeLocation _
Implements ICodeElementInfo.GetCodeLocation
C#
public virtual CodeLocation GetCodeLocation()
C++
public:
virtual CodeLocation GetCodeLocation()
J#
public virtual CodeLocation GetCodeLocation()
JScript
public virtual function GetCodeLocation() : CodeLocation

Implements

ICodeElementInfo.GetCodeLocation

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

StaticCodeElementWrapper.GetCustomAttributes Method
[image]

Gets all attributes that appear on this code element, excluding inherited attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetCustomAttributes() As IEnumerable(Of StaticAttributeWrapper)
C#
protected abstract IEnumerable<StaticAttributeWrapper> GetCustomAttributes()
C++
protected:
IEnumerable<StaticAttributeWrapper> GetCustomAttributes() abstract
J#
protected abstract IEnumerable<StaticAttributeWrapper> GetCustomAttributes()
JScript
protected abstract function GetCustomAttributes() : IEnumerable<StaticAttributeWrapper>

Return Value

The attribute wrappers

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


GetInheritedElements Method

StaticCodeElementWrapper.GetInheritedElements Method
[image]

Gets an enumeration of elements from which this code element inherits.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetInheritedElements() As IEnumerable(Of ICodeElementInfo)
C#
protected virtual IEnumerable<ICodeElementInfo> GetInheritedElements()
C++
protected:
virtual IEnumerable<ICodeElementInfo> GetInheritedElements()
J#
protected virtual IEnumerable<ICodeElementInfo> GetInheritedElements()
JScript
protected virtual function GetInheritedElements() : IEnumerable<ICodeElementInfo>

Return Value

The inherited code elements

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


GetPseudoCustomAttributes Method

StaticCodeElementWrapper.GetPseudoCustomAttributes Method
[image]

Gets all pseudo custom attributes associated with a member.

These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPseudoCustomAttributes() As IEnumerable(Of Attribute)
C#
protected abstract IEnumerable<Attribute> GetPseudoCustomAttributes()
C++
protected:
IEnumerable<Attribute> GetPseudoCustomAttributes() abstract
J#
protected abstract IEnumerable<Attribute> GetPseudoCustomAttributes()
JScript
protected abstract function GetPseudoCustomAttributes() : IEnumerable<Attribute>

Return Value

The pseudo custom attributes

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


GetXmlDocumentation Method

StaticCodeElementWrapper.GetXmlDocumentation Method
[image]

Gets the XML documentation associated with the code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetXmlDocumentation() As String _
Implements ICodeElementInfo.GetXmlDocumentation
C#
public virtual string GetXmlDocumentation()
C++
public:
virtual String GetXmlDocumentation()
J#
public virtual string GetXmlDocumentation()
JScript
public virtual function GetXmlDocumentation() : String

Return Value

The XML documentation or null if none available

Implements

ICodeElementInfo.GetXmlDocumentation

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


HasAttribute Method

StaticCodeElementWrapper.HasAttribute Method
[image]

Returns true if the code element has a custom attribute of the specified type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function HasAttribute( _
ByVal attributeType As ITypeInfo, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICodeElementInfo.HasAttribute
C#
public bool HasAttribute(
ITypeInfo attributeType,
bool inherit
)
C++
public:
bool HasAttribute(
ITypeInfo attributeType,
bool inherit
) sealed
J#
public bool HasAttribute(
ITypeInfo attributeType,
bool inherit
)
JScript
public function HasAttribute(
attributeType : ITypeInfo,
inherit : bool
) : bool

Parameters

attributeType
The attribute type, or null to search for attributes of all types
inherit
If true, includes inherited attributes from base types (but not from interfaces, just like ICustomAttributeProvider does)

Return Value

True if the code element has at least one attribute of the specified type

Implements

ICodeElementInfo.HasAttribute

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticCodeElementWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticCodeElementWrapper Class
Gallio.Reflection.Impl Namespace


StaticConstructedTypeWrapper Class

StaticConstructedTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy constructed type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticConstructedTypeWrapper
Inherits StaticSpecialTypeWrapper
C#
public abstract class StaticConstructedTypeWrapper : StaticSpecialTypeWrapper
C++
ref class StaticConstructedTypeWrapper abstract : StaticSpecialTypeWrapper
J#
public class StaticConstructedTypeWrapper extends StaticSpecialTypeWrapper
JScript
public class StaticConstructedTypeWrapper extends StaticSpecialTypeWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticConstructedTypeWrapper
Gallio.Reflection.Impl.StaticArrayTypeWrapper
Gallio.Reflection.Impl.StaticByRefTypeWrapper
Gallio.Reflection.Impl.StaticPointerTypeWrapper

See Also

StaticConstructedTypeWrapper Members
Gallio.Reflection.Impl Namespace
StaticArrayTypeWrapper
StaticByRefTypeWrapper
StaticPointerTypeWrapper


StaticConstructedTypeWrapper Members

StaticConstructedTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy constructed type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticConstructedTypeWrapper.

Protected Constructors

 | Name | Description
Family method | StaticConstructedTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Overridden. Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Overridden. Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Overridden. Gets the element type, or null if none.
Public property | FullName | Overridden. Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Overridden. Gets the name of the code element.
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Overridden. Gets the name of the namespace in which the type is declared.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | (inherited from StaticTypeWrapper)
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Protected Properties

 | Name | Description
Family property | BaseTypeInternal | Internal implementation of BaseType. (inherited from StaticSpecialTypeWrapper)
Family property | NameSuffix | Gets the suffix to append to the name of the constructed type.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticTypeWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Overridden. Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Applies a type substitution and returns the resulting type. (inherited from StaticTypeWrapper)
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Overridden. Gets all attributes that appear on this code element, excluding inherited attributes.
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticTypeWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticSpecialTypeWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve (inherited from StaticTypeWrapper)
Top

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticArrayTypeWrapper
StaticByRefTypeWrapper
StaticPointerTypeWrapper


StaticConstructedTypeWrapper Constructor

StaticConstructedTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal elementType As StaticTypeWrapper _
)
C#
protected StaticConstructedTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
)
C++
protected:
StaticConstructedTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
) sealed
J#
protected StaticConstructedTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
)
JScript
protected function StaticConstructedTypeWrapper(
policy : StaticReflectionPolicy,
elementType : StaticTypeWrapper
)

Parameters

policy
The reflection policy
elementType
The element type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or elementType is null

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticConstructedTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Overridden. Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Overridden. Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Overridden. Gets the element type, or null if none.
Public property | FullName | Overridden. Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Overridden. Gets the name of the code element.
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Overridden. Gets the name of the namespace in which the type is declared.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | (inherited from StaticTypeWrapper)
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Protected Properties

 | Name | Description
Family property | BaseTypeInternal | Internal implementation of BaseType. (inherited from StaticSpecialTypeWrapper)
Family property | NameSuffix | Gets the suffix to append to the name of the constructed type.
Top

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticArrayTypeWrapper
StaticByRefTypeWrapper
StaticPointerTypeWrapper


Assembly Property

StaticConstructedTypeWrapper.Assembly Property
[image]

Gets the assembly in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Assembly As IAssemblyInfo _
Implements ITypeInfo.Assembly
C#
public override IAssemblyInfo Assembly { get; }
C++
public override property IAssemblyInfo Assembly override {
IAssemblyInfo get();
}
J#
/** property */
public IAssemblyInfo get_Assembly();
JScript
public function get Assembly() : IAssemblyInfo

Implements

ITypeInfo.Assembly

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

StaticConstructedTypeWrapper.ContainsGenericParameters Property
See Also Example
[image]

Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContainsGenericParameters As Boolean _
Implements ITypeInfo.ContainsGenericParameters
C#
public override bool ContainsGenericParameters { get; }
C++
public override property bool ContainsGenericParameters override {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Implements

ITypeInfo.ContainsGenericParameters

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


ElementType Property

StaticConstructedTypeWrapper.ElementType Property
[image]

Gets the element type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ElementType As StaticTypeWrapper
C#
public override StaticTypeWrapper ElementType { get; }
C++
public override property StaticTypeWrapper ElementType override {
StaticTypeWrapper get();
}
J#
/** property */
public StaticTypeWrapper get_ElementType();
JScript
public function get ElementType() : StaticTypeWrapper

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


FullName Property

StaticConstructedTypeWrapper.FullName Property
[image]

Gets the full name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String _
Implements ITypeInfo.FullName
C#
public override string FullName { get; }
C++
public override property string FullName override {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITypeInfo.FullName

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


Name Property

StaticConstructedTypeWrapper.Name Property
[image]

Gets the name of the code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String _
Implements ICodeElementInfo.Name
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ICodeElementInfo.Name

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


NamespaceName Property

StaticConstructedTypeWrapper.NamespaceName Property
[image]

Gets the name of the namespace in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NamespaceName As String _
Implements ITypeInfo.NamespaceName
C#
public override string NamespaceName { get; }
C++
public override property string NamespaceName override {
String get();
}
J#
/** property */
public string get_NamespaceName();
JScript
public function get NamespaceName() : String

Implements

ITypeInfo.NamespaceName

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


NameSuffix Property

StaticConstructedTypeWrapper.NameSuffix Property
[image]

Gets the suffix to append to the name of the constructed type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride ReadOnly Property NameSuffix As String
C#
protected abstract string NameSuffix { get; }
C++
protected abstract property string NameSuffix abstract {
String get();
}
J#
/** property */
protected string get_NameSuffix();
JScript
protected function get NameSuffix() : String

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticConstructedTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticTypeWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Overridden. Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Applies a type substitution and returns the resulting type. (inherited from StaticTypeWrapper)
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Overridden. Gets all attributes that appear on this code element, excluding inherited attributes.
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticTypeWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticSpecialTypeWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve (inherited from StaticTypeWrapper)
Top

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticArrayTypeWrapper
StaticByRefTypeWrapper
StaticPointerTypeWrapper


GetCodeLocation Method

StaticConstructedTypeWrapper.GetCodeLocation Method
[image]

Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCodeLocation() As CodeLocation _
Implements ICodeElementInfo.GetCodeLocation
C#
public override CodeLocation GetCodeLocation()
C++
public:
virtual CodeLocation GetCodeLocation() override
J#
public override CodeLocation GetCodeLocation()
JScript
public override function GetCodeLocation() : CodeLocation

Return Value

The code location

Implements

ICodeElementInfo.GetCodeLocation

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

StaticConstructedTypeWrapper.GetCustomAttributes Method
[image]

Gets all attributes that appear on this code element, excluding inherited attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCustomAttributes() As IEnumerable(Of StaticAttributeWrapper)
C#
protected override IEnumerable<StaticAttributeWrapper> GetCustomAttributes()
C++
protected:
virtual IEnumerable<StaticAttributeWrapper> GetCustomAttributes() override
J#
protected override IEnumerable<StaticAttributeWrapper> GetCustomAttributes()
JScript
protected override function GetCustomAttributes() : IEnumerable<StaticAttributeWrapper>

Return Value

The attribute wrappers

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticConstructedTypeWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticConstructedTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticConstructorWrapper Class

StaticConstructorWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy constructor wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticConstructorWrapper
Inherits StaticFunctionWrapper
Implements IConstructorInfo
C#
public sealed class StaticConstructorWrapper : StaticFunctionWrapper, IConstructorInfo
C++
ref class StaticConstructorWrapper sealed : StaticFunctionWrapper, IConstructorInfo
J#
public final class StaticConstructorWrapper extends StaticFunctionWrapper implements IConstructorInfo
JScript
public final class StaticConstructorWrapper extends StaticFunctionWrapper, IConstructorInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticFunctionWrapper
Gallio.Reflection.Impl.StaticConstructorWrapper

See Also

StaticConstructorWrapper Members
Gallio.Reflection.Impl Namespace


StaticConstructorWrapper Members

StaticConstructorWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy constructor wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticConstructorWrapper.

Public Constructors

 | Name | Description
Public method | StaticConstructorWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method. (inherited from StaticFunctionWrapper)
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAbstract | Returns true if the method is abstract. (inherited from StaticFunctionWrapper)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from StaticFunctionWrapper)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFinal | Returns true if the method is final. (inherited from StaticFunctionWrapper)
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from StaticFunctionWrapper)
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from StaticFunctionWrapper)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from StaticFunctionWrapper)
Public property | IsStatic | Returns true if the method is static. (inherited from StaticFunctionWrapper)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from StaticFunctionWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | MethodAttributes | Gets the method attributes. (inherited from StaticFunctionWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Parameters | (inherited from StaticFunctionWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


StaticConstructorWrapper Constructor

StaticConstructorWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper _
)
C#
public StaticConstructorWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
C++
public:
StaticConstructorWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType
) sealed
J#
public StaticConstructorWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
JScript
public function StaticConstructorWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, or declaringType is null

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticConstructorWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method. (inherited from StaticFunctionWrapper)
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAbstract | Returns true if the method is abstract. (inherited from StaticFunctionWrapper)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from StaticFunctionWrapper)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFinal | Returns true if the method is final. (inherited from StaticFunctionWrapper)
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from StaticFunctionWrapper)
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from StaticFunctionWrapper)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from StaticFunctionWrapper)
Public property | IsStatic | Returns true if the method is static. (inherited from StaticFunctionWrapper)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from StaticFunctionWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | MethodAttributes | Gets the method attributes. (inherited from StaticFunctionWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Parameters | (inherited from StaticFunctionWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticConstructorWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticConstructorWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticConstructorWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IConstructorInfo) |
Public method | Equals (IFunctionInfo) | (inherited from StaticFunctionWrapper)
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IConstructorInfo)

StaticConstructorWrapper.Equals Method (IConstructorInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IConstructorInfo _
) As Boolean _
Implements IEquatable<IConstructorInfo>.Equals
C#
public bool Equals(
IConstructorInfo other
)
C++
public:
bool Equals(
IConstructorInfo other
) sealed
J#
public bool Equals(
IConstructorInfo other
)
JScript
public function Equals(
other : IConstructorInfo
) : bool

Implements

IEquatable<IConstructorInfo>.Equals

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace
StaticConstructorWrapper.Equals Overload List


Resolve Method

StaticConstructorWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As ConstructorInfo _
Implements IConstructorInfo.Resolve
C#
public ConstructorInfo Resolve(
bool throwOnError
)
C++
public:
ConstructorInfo Resolve(
bool throwOnError
) sealed
J#
public ConstructorInfo Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : ConstructorInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IConstructorInfo.Resolve

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticConstructorWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticConstructorWrapper Class
Gallio.Reflection.Impl Namespace


StaticDeclaredTypeWrapper Class

StaticDeclaredTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy declared type wrapper such as a class, struct, enum or interface definition. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticDeclaredTypeWrapper
Inherits StaticTypeWrapper
C#
public sealed class StaticDeclaredTypeWrapper : StaticTypeWrapper
C++
ref class StaticDeclaredTypeWrapper sealed : StaticTypeWrapper
J#
public final class StaticDeclaredTypeWrapper extends StaticTypeWrapper
JScript
public final class StaticDeclaredTypeWrapper extends StaticTypeWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticDeclaredTypeWrapper

See Also

StaticDeclaredTypeWrapper Members
Gallio.Reflection.Impl Namespace


StaticDeclaredTypeWrapper Members

StaticDeclaredTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy declared type wrapper such as a class, struct, enum or interface definition. This class cannot be inherited.

The following tables list the members exposed by StaticDeclaredTypeWrapper.

Public Constructors

 | Name | Description
Public method | StaticDeclaredTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Overridden. Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type, or null if none.
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Overridden. Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticTypeWrapper)
Public property | FullName | Overridden. Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Overridden. Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericTypeDefinition | Overridden.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Overridden. Gets all of the type's interfaces.
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Overridden. Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.
Public property | IsGenericTypeDefinition | Overridden. Returns true if the type is a generic type definition.
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Overridden. Gets the name of the code element.
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Overridden. Gets the name of the namespace in which the type is declared.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Overridden. Gets the type substitution for generic parameters.
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Public Methods

 | Name | Description
Public method | ComposeSubstitution | Composes the substitution of the type with the specified substitution and returns a new wrapper.
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticTypeWrapper)
Public method | GetAllBaseTypes | Gets an enumeration of all base types.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors | Overridden. Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Overridden. Gets a event by name, or null if not found.
Public method | GetEvents | Overridden. Gets all events of the type that satisfy the binding flags.
Public method | GetField | Overridden. Gets a field by name, or null if not found.
Public method | GetFields | Overridden. Gets all fields of the type that satisfy the binding flags.
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Overridden. Gets a method by name, or null if not found.
Public method | GetMethods | Overridden. Gets all methods of the type that satisfy the binding flags.
Public method | GetNestedType | Overridden. Gets a nested type by name, or null if not found.
Public method | GetNestedTypes | Overridden. Gets all nested types of the type that satisfy the binding flags.
Public method | GetProperties | Overridden. Gets all properties of the type that satisfy the binding flags.
Public method | GetProperty | Overridden. Gets a property by name, or null if not found.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | Overridden.
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticDeclaredTypeWrapper Constructor

StaticDeclaredTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal substitution As StaticTypeSubstitution _
)
C#
public StaticDeclaredTypeWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticTypeSubstitution substitution
)
C++
public:
StaticDeclaredTypeWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticTypeSubstitution substitution
) sealed
J#
public StaticDeclaredTypeWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticTypeSubstitution substitution
)
JScript
public function StaticDeclaredTypeWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
substitution : StaticTypeSubstitution
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type, or null if none
substitution
The type substitution for generic parameters

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticDeclaredTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Overridden. Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type, or null if none.
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Overridden. Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticTypeWrapper)
Public property | FullName | Overridden. Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Overridden. Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericTypeDefinition | Overridden.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Overridden. Gets all of the type's interfaces.
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Overridden. Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.
Public property | IsGenericTypeDefinition | Overridden. Returns true if the type is a generic type definition.
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Overridden. Gets the name of the code element.
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Overridden. Gets the name of the namespace in which the type is declared.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Overridden. Gets the type substitution for generic parameters.
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


Assembly Property

StaticDeclaredTypeWrapper.Assembly Property
[image]

Gets the assembly in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Assembly As IAssemblyInfo _
Implements ITypeInfo.Assembly
C#
public override IAssemblyInfo Assembly { get; }
C++
public override property IAssemblyInfo Assembly override {
IAssemblyInfo get();
}
J#
/** property */
public IAssemblyInfo get_Assembly();
JScript
public function get Assembly() : IAssemblyInfo

Implements

ITypeInfo.Assembly

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


BaseType Property

StaticDeclaredTypeWrapper.BaseType Property
[image]

Gets the base type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property BaseType As StaticDeclaredTypeWrapper
C#
public new StaticDeclaredTypeWrapper BaseType { get; }
C++
public new property StaticDeclaredTypeWrapper BaseType sealed {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_BaseType();
JScript
public function get BaseType() : StaticDeclaredTypeWrapper

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

StaticDeclaredTypeWrapper.ContainsGenericParameters Property
[image]

Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContainsGenericParameters As Boolean _
Implements ITypeInfo.ContainsGenericParameters
C#
public override bool ContainsGenericParameters { get; }
C++
public override property bool ContainsGenericParameters override {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Implements

ITypeInfo.ContainsGenericParameters

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


FullName Property

StaticDeclaredTypeWrapper.FullName Property
[image]

Gets the full name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String _
Implements ITypeInfo.FullName
C#
public override string FullName { get; }
C++
public override property string FullName override {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITypeInfo.FullName

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GenericArguments Property

StaticDeclaredTypeWrapper.GenericArguments Property
[image]

Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property GenericArguments As IList(Of ITypeInfo) _
Implements ITypeInfo.GenericArguments
C#
public override IList<ITypeInfo> GenericArguments { get; }
C++
public override property IList<ITypeInfo> GenericArguments override {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_GenericArguments();
JScript
public function get GenericArguments() : IList<ITypeInfo>

Property Value

The generic arguments, or an empty list if there are none

Implements

ITypeInfo.GenericArguments

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GenericTypeDefinition Property

StaticDeclaredTypeWrapper.GenericTypeDefinition Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property GenericTypeDefinition As StaticDeclaredTypeWrapper
C#
public override StaticDeclaredTypeWrapper GenericTypeDefinition { get; }
C++
public override property StaticDeclaredTypeWrapper GenericTypeDefinition override {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_GenericTypeDefinition();
JScript
public function get GenericTypeDefinition() : StaticDeclaredTypeWrapper

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


Interfaces Property

StaticDeclaredTypeWrapper.Interfaces Property
[image]

Gets all of the type's interfaces.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Interfaces As IList(Of ITypeInfo) _
Implements ITypeInfo.Interfaces
C#
public override IList<ITypeInfo> Interfaces { get; }
C++
public override property IList<ITypeInfo> Interfaces override {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_Interfaces();
JScript
public function get Interfaces() : IList<ITypeInfo>

Property Value

The type's interfaces

Implements

ITypeInfo.Interfaces

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericType Property

StaticDeclaredTypeWrapper.IsGenericType Property
[image]

Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericType As Boolean _
Implements ITypeInfo.IsGenericType
C#
public override bool IsGenericType { get; }
C++
public override property bool IsGenericType override {
bool get();
}
J#
/** property */
public bool get_IsGenericType();
JScript
public function get IsGenericType() : bool

Implements

ITypeInfo.IsGenericType

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericTypeDefinition Property

StaticDeclaredTypeWrapper.IsGenericTypeDefinition Property
[image]

Returns true if the type is a generic type definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericTypeDefinition As Boolean _
Implements ITypeInfo.IsGenericTypeDefinition
C#
public override bool IsGenericTypeDefinition { get; }
C++
public override property bool IsGenericTypeDefinition override {
bool get();
}
J#
/** property */
public bool get_IsGenericTypeDefinition();
JScript
public function get IsGenericTypeDefinition() : bool

Implements

ITypeInfo.IsGenericTypeDefinition

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


Name Property

StaticDeclaredTypeWrapper.Name Property
[image]

Gets the name of the code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String _
Implements ICodeElementInfo.Name
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ICodeElementInfo.Name

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


NamespaceName Property

StaticDeclaredTypeWrapper.NamespaceName Property
[image]

Gets the name of the namespace in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NamespaceName As String _
Implements ITypeInfo.NamespaceName
C#
public override string NamespaceName { get; }
C++
public override property string NamespaceName override {
String get();
}
J#
/** property */
public string get_NamespaceName();
JScript
public function get NamespaceName() : String

Implements

ITypeInfo.NamespaceName

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


Substitution Property

StaticDeclaredTypeWrapper.Substitution Property
[image]

Gets the type substitution for generic parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Substitution As StaticTypeSubstitution
C#
public override StaticTypeSubstitution Substitution { get; }
C++
public override property StaticTypeSubstitution Substitution override {
StaticTypeSubstitution get();
}
J#
/** property */
public StaticTypeSubstitution get_Substitution();
JScript
public function get Substitution() : StaticTypeSubstitution

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


TypeAttributes Property

StaticDeclaredTypeWrapper.TypeAttributes Property
[image]

Gets the type attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TypeAttributes As TypeAttributes _
Implements ITypeInfo.TypeAttributes
C#
public override TypeAttributes TypeAttributes { get; }
C++
public override property TypeAttributes TypeAttributes override {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

Implements

ITypeInfo.TypeAttributes

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticDeclaredTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | ComposeSubstitution | Composes the substitution of the type with the specified substitution and returns a new wrapper.
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticTypeWrapper)
Public method | GetAllBaseTypes | Gets an enumeration of all base types.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors | Overridden. Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Overridden. Gets a event by name, or null if not found.
Public method | GetEvents | Overridden. Gets all events of the type that satisfy the binding flags.
Public method | GetField | Overridden. Gets a field by name, or null if not found.
Public method | GetFields | Overridden. Gets all fields of the type that satisfy the binding flags.
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Overridden. Gets a method by name, or null if not found.
Public method | GetMethods | Overridden. Gets all methods of the type that satisfy the binding flags.
Public method | GetNestedType | Overridden. Gets a nested type by name, or null if not found.
Public method | GetNestedTypes | Overridden. Gets all nested types of the type that satisfy the binding flags.
Public method | GetProperties | Overridden. Gets all properties of the type that satisfy the binding flags.
Public method | GetProperty | Overridden. Gets a property by name, or null if not found.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | Overridden.
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


ApplySubstitution Method

StaticDeclaredTypeWrapper.ApplySubstitution Method
[image]

Applies a type substitution and returns the resulting type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ApplySubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As ITypeInfo
C#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
C++
protected:
virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
) override
J#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
JScript
protected override function ApplySubstitution(
substitution : StaticTypeSubstitution
) : ITypeInfo

Parameters

substitution
The substitution

Return Value

The type after substitution has been performed

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


ComposeSubstitution Method

StaticDeclaredTypeWrapper.ComposeSubstitution Method
[image]

Composes the substitution of the type with the specified substitution and returns a new wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ComposeSubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As StaticDeclaredTypeWrapper
C#
public StaticDeclaredTypeWrapper ComposeSubstitution(
StaticTypeSubstitution substitution
)
C++
public:
StaticDeclaredTypeWrapper ComposeSubstitution(
StaticTypeSubstitution substitution
) sealed
J#
public StaticDeclaredTypeWrapper ComposeSubstitution(
StaticTypeSubstitution substitution
)
JScript
public function ComposeSubstitution(
substitution : StaticTypeSubstitution
) : StaticDeclaredTypeWrapper

Parameters

substitution
The substitution

Return Value

The new wrapper with the composed substitution

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetAllBaseTypes Method

StaticDeclaredTypeWrapper.GetAllBaseTypes Method
[image]

Gets an enumeration of all base types.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllBaseTypes() As IEnumerable(Of StaticDeclaredTypeWrapper)
C#
public IEnumerable<StaticDeclaredTypeWrapper> GetAllBaseTypes()
C++
public:
IEnumerable<StaticDeclaredTypeWrapper> GetAllBaseTypes() sealed
J#
public IEnumerable<StaticDeclaredTypeWrapper> GetAllBaseTypes()
JScript
public function GetAllBaseTypes() : IEnumerable<StaticDeclaredTypeWrapper>

Return Value

The enumeration of base types

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetConstructors Method

StaticDeclaredTypeWrapper.GetConstructors Method
[image]

Gets all constructors of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetConstructors( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IConstructorInfo) _
Implements ITypeInfo.GetConstructors
C#
public override IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
) override
J#
public override IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
JScript
public override function GetConstructors(
bindingFlags : BindingFlags
) : IList<IConstructorInfo>

Parameters

bindingFlags
The binding flags

Return Value

The constructors

Implements

ITypeInfo.GetConstructors

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetEvent Method

StaticDeclaredTypeWrapper.GetEvent Method
[image]

Gets a event by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEvent( _
ByVal eventName As String, _
ByVal bindingFlags As BindingFlags _
) As IEventInfo _
Implements ITypeInfo.GetEvent
C#
public override IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
C++
public:
virtual IEventInfo GetEvent(
String eventName,
BindingFlags bindingFlags
) override
J#
public override IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
JScript
public override function GetEvent(
eventName : String,
bindingFlags : BindingFlags
) : IEventInfo

Parameters

eventName
The event name
bindingFlags
The binding flags

Return Value

The event

Implements

ITypeInfo.GetEvent

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetEvents Method

StaticDeclaredTypeWrapper.GetEvents Method
[image]

Gets all events of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEvents( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IEventInfo) _
Implements ITypeInfo.GetEvents
C#
public override IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
) override
J#
public override IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
JScript
public override function GetEvents(
bindingFlags : BindingFlags
) : IList<IEventInfo>

Parameters

bindingFlags
The binding flags

Return Value

The events

Implements

ITypeInfo.GetEvents

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetField Method

StaticDeclaredTypeWrapper.GetField Method
[image]

Gets a field by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetField( _
ByVal fieldName As String, _
ByVal bindingFlags As BindingFlags _
) As IFieldInfo _
Implements ITypeInfo.GetField
C#
public override IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
C++
public:
virtual IFieldInfo GetField(
String fieldName,
BindingFlags bindingFlags
) override
J#
public override IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
JScript
public override function GetField(
fieldName : String,
bindingFlags : BindingFlags
) : IFieldInfo

Parameters

fieldName
The field name
bindingFlags
The binding flags

Return Value

The property

Implements

ITypeInfo.GetField

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetFields Method

StaticDeclaredTypeWrapper.GetFields Method
[image]

Gets all fields of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFields( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IFieldInfo) _
Implements ITypeInfo.GetFields
C#
public override IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
) override
J#
public override IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
JScript
public override function GetFields(
bindingFlags : BindingFlags
) : IList<IFieldInfo>

Parameters

bindingFlags
The binding flags

Return Value

The fields

Implements

ITypeInfo.GetFields

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetMethod Method

StaticDeclaredTypeWrapper.GetMethod Method
[image]

Gets a method by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethod( _
ByVal methodName As String, _
ByVal bindingFlags As BindingFlags _
) As IMethodInfo _
Implements ITypeInfo.GetMethod
C#
public override IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
C++
public:
virtual IMethodInfo GetMethod(
String methodName,
BindingFlags bindingFlags
) override
J#
public override IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
JScript
public override function GetMethod(
methodName : String,
bindingFlags : BindingFlags
) : IMethodInfo

Parameters

methodName
The method name
bindingFlags
The binding flags

Return Value

The method

Implements

ITypeInfo.GetMethod

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetMethods Method

StaticDeclaredTypeWrapper.GetMethods Method
[image]

Gets all methods of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethods( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IMethodInfo) _
Implements ITypeInfo.GetMethods
C#
public override IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
) override
J#
public override IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
JScript
public override function GetMethods(
bindingFlags : BindingFlags
) : IList<IMethodInfo>

Parameters

bindingFlags
The binding flags

Return Value

The methods

Implements

ITypeInfo.GetMethods

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetNestedType Method

StaticDeclaredTypeWrapper.GetNestedType Method
[image]

Gets a nested type by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetNestedType( _
ByVal nestedTypeName As String, _
ByVal bindingFlags As BindingFlags _
) As ITypeInfo _
Implements ITypeInfo.GetNestedType
C#
public override ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
C++
public:
virtual ITypeInfo GetNestedType(
String nestedTypeName,
BindingFlags bindingFlags
) override
J#
public override ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
JScript
public override function GetNestedType(
nestedTypeName : String,
bindingFlags : BindingFlags
) : ITypeInfo

Parameters

nestedTypeName
The nested type name
bindingFlags
The binding flags

Return Value

The nested type

Implements

ITypeInfo.GetNestedType

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetNestedTypes Method

StaticDeclaredTypeWrapper.GetNestedTypes Method
[image]

Gets all nested types of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetNestedTypes( _
ByVal bindingFlags As BindingFlags _
) As IList(Of ITypeInfo) _
Implements ITypeInfo.GetNestedTypes
C#
public override IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
C++
public:
virtual IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
) override
J#
public override IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
JScript
public override function GetNestedTypes(
bindingFlags : BindingFlags
) : IList<ITypeInfo>

Parameters

bindingFlags
The binding flags

Return Value

The nested types

Implements

ITypeInfo.GetNestedTypes

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetProperties Method

StaticDeclaredTypeWrapper.GetProperties Method
[image]

Gets all properties of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperties( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IPropertyInfo) _
Implements ITypeInfo.GetProperties
C#
public override IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
) override
J#
public override IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
JScript
public override function GetProperties(
bindingFlags : BindingFlags
) : IList<IPropertyInfo>

Parameters

bindingFlags
The binding flags

Return Value

The properties

Implements

ITypeInfo.GetProperties

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetProperty Method

StaticDeclaredTypeWrapper.GetProperty Method
[image]

Gets a property by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty( _
ByVal propertyName As String, _
ByVal bindingFlags As BindingFlags _
) As IPropertyInfo _
Implements ITypeInfo.GetProperty
C#
public override IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
C++
public:
virtual IPropertyInfo GetProperty(
String propertyName,
BindingFlags bindingFlags
) override
J#
public override IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
JScript
public override function GetProperty(
propertyName : String,
bindingFlags : BindingFlags
) : IPropertyInfo

Parameters

propertyName
The property name
bindingFlags
The binding flags

Return Value

The property

Implements

ITypeInfo.GetProperty

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


MakeGenericType Method

StaticDeclaredTypeWrapper.MakeGenericType Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakeGenericType( _
ByVal genericArguments As IList(Of ITypeInfo) _
) As StaticDeclaredTypeWrapper
C#
public override StaticDeclaredTypeWrapper MakeGenericType(
IList<ITypeInfo> genericArguments
)
C++
public:
virtual StaticDeclaredTypeWrapper MakeGenericType(
IList<ITypeInfo> genericArguments
) override
J#
public override StaticDeclaredTypeWrapper MakeGenericType(
IList<ITypeInfo> genericArguments
)
JScript
public override function MakeGenericType(
genericArguments : IList<ITypeInfo>
) : StaticDeclaredTypeWrapper

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticDeclaredTypeWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticDeclaredTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticEventWrapper Class

StaticEventWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy event wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticEventWrapper
Inherits StaticReflectedMemberWrapper
Implements IEventInfo
C#
public sealed class StaticEventWrapper : StaticReflectedMemberWrapper, IEventInfo
C++
ref class StaticEventWrapper sealed : StaticReflectedMemberWrapper, IEventInfo
J#
public final class StaticEventWrapper extends StaticReflectedMemberWrapper implements IEventInfo
JScript
public final class StaticEventWrapper extends StaticReflectedMemberWrapper, IEventInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticEventWrapper

See Also

StaticEventWrapper Members
Gallio.Reflection.Impl Namespace


StaticEventWrapper Members

StaticEventWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy event wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticEventWrapper.

Public Constructors

 | Name | Description
Public method | StaticEventWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | AddMethod |
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | EventAttributes | Gets the event attributes.
Public property | EventHandlerType | Gets the event handler type.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | RaiseMethod |
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | RemoveMethod |
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetOverridenOrHiddenEvents | Gets the events that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


StaticEventWrapper Constructor

StaticEventWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
)
C#
public StaticEventWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
C++
public:
StaticEventWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
) sealed
J#
public StaticEventWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
JScript
public function StaticEventWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type
reflectedType
The reflected type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, declaringType, or reflectedType is null

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticEventWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | AddMethod |
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | EventAttributes | Gets the event attributes.
Public property | EventHandlerType | Gets the event handler type.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | RaiseMethod |
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | RemoveMethod |
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


AddMethod Property

StaticEventWrapper.AddMethod Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AddMethod As StaticMethodWrapper
C#
public StaticMethodWrapper AddMethod { get; }
C++
public property StaticMethodWrapper AddMethod sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_AddMethod();
JScript
public function get AddMethod() : StaticMethodWrapper

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


EventAttributes Property

StaticEventWrapper.EventAttributes Property
[image]

Gets the event attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventAttributes As EventAttributes _
Implements IEventInfo.EventAttributes
C#
public EventAttributes EventAttributes { get; }
C++
public property EventAttributes EventAttributes sealed {
EventAttributes get();
}
J#
/** property */
public EventAttributes get_EventAttributes();
JScript
public function get EventAttributes() : EventAttributes

Implements

IEventInfo.EventAttributes

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


EventHandlerType Property

StaticEventWrapper.EventHandlerType Property
[image]

Gets the event handler type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventHandlerType As ITypeInfo _
Implements IEventInfo.EventHandlerType
C#
public ITypeInfo EventHandlerType { get; }
C++
public property ITypeInfo EventHandlerType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_EventHandlerType();
JScript
public function get EventHandlerType() : ITypeInfo

Implements

IEventInfo.EventHandlerType

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticEventWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


RaiseMethod Property

StaticEventWrapper.RaiseMethod Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RaiseMethod As StaticMethodWrapper
C#
public StaticMethodWrapper RaiseMethod { get; }
C++
public property StaticMethodWrapper RaiseMethod sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_RaiseMethod();
JScript
public function get RaiseMethod() : StaticMethodWrapper

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


RemoveMethod Property

StaticEventWrapper.RemoveMethod Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemoveMethod As StaticMethodWrapper
C#
public StaticMethodWrapper RemoveMethod { get; }
C++
public property StaticMethodWrapper RemoveMethod sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_RemoveMethod();
JScript
public function get RemoveMethod() : StaticMethodWrapper

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticEventWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetOverridenOrHiddenEvents | Gets the events that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticEventWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IEventInfo) |
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IEventInfo)

StaticEventWrapper.Equals Method (IEventInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IEventInfo _
) As Boolean _
Implements IEquatable<IEventInfo>.Equals
C#
public bool Equals(
IEventInfo other
)
C++
public:
bool Equals(
IEventInfo other
) sealed
J#
public bool Equals(
IEventInfo other
)
JScript
public function Equals(
other : IEventInfo
) : bool

Implements

IEquatable<IEventInfo>.Equals

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace
StaticEventWrapper.Equals Overload List


GetOverridenOrHiddenEvents Method

StaticEventWrapper.GetOverridenOrHiddenEvents Method
[image]

Gets the events that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOverridenOrHiddenEvents( _
ByVal overridesOnly As Boolean _
) As IEnumerable(Of StaticEventWrapper)
C#
public IEnumerable<StaticEventWrapper> GetOverridenOrHiddenEvents(
bool overridesOnly
)
C++
public:
IEnumerable<StaticEventWrapper> GetOverridenOrHiddenEvents(
bool overridesOnly
) sealed
J#
public IEnumerable<StaticEventWrapper> GetOverridenOrHiddenEvents(
bool overridesOnly
)
JScript
public function GetOverridenOrHiddenEvents(
overridesOnly : bool
) : IEnumerable<StaticEventWrapper>

Parameters

overridesOnly
If true, only returns overrides

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticEventWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As EventInfo _
Implements IEventInfo.Resolve
C#
public EventInfo Resolve(
bool throwOnError
)
C++
public:
EventInfo Resolve(
bool throwOnError
) sealed
J#
public EventInfo Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : EventInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IEventInfo.Resolve

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticEventWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticEventWrapper Class
Gallio.Reflection.Impl Namespace


StaticFieldWrapper Class

StaticFieldWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy field wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticFieldWrapper
Inherits StaticReflectedMemberWrapper
Implements IFieldInfo, ISlotInfo
C#
public sealed class StaticFieldWrapper : StaticReflectedMemberWrapper, IFieldInfo, ISlotInfo
C++
ref class StaticFieldWrapper sealed : StaticReflectedMemberWrapper, IFieldInfo, ISlotInfo
J#
public final class StaticFieldWrapper extends StaticReflectedMemberWrapper implements IFieldInfo, ISlotInfo
JScript
public final class StaticFieldWrapper extends StaticReflectedMemberWrapper, IFieldInfo, ISlotInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticFieldWrapper

See Also

StaticFieldWrapper Members
Gallio.Reflection.Impl Namespace


StaticFieldWrapper Members

StaticFieldWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy field wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticFieldWrapper.

Public Constructors

 | Name | Description
Public method | StaticFieldWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | FieldAttributes | Gets the field attributes.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAssembly | Gets a value indicating whether this field has Assembly level visibility.
Public property | IsFamily | Gets a value indicating whether this field has Family level visibility.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this field has FamilyAndAssembly level visibility.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this field has FamilyOrAssembly level visibility.
Public property | IsInitOnly | Returns true if the field is read-only and can only be set from the constructor.
Public property | IsLiteral | Returns true if the field is a literal set at compile time.
Public property | IsPrivate | Gets a value indicating whether the field is private.
Public property | IsPublic | Gets a value indicating whether the field is public.
Public property | IsStatic | Returns true if the field is static.
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Public property | ValueType | Gets the type of value held in the slot.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


StaticFieldWrapper Constructor

StaticFieldWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
)
C#
public StaticFieldWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
C++
public:
StaticFieldWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
) sealed
J#
public StaticFieldWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
JScript
public function StaticFieldWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type
reflectedType
The reflected type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, declaringType, or reflectedType is null

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticFieldWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | FieldAttributes | Gets the field attributes.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAssembly | Gets a value indicating whether this field has Assembly level visibility.
Public property | IsFamily | Gets a value indicating whether this field has Family level visibility.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this field has FamilyAndAssembly level visibility.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this field has FamilyOrAssembly level visibility.
Public property | IsInitOnly | Returns true if the field is read-only and can only be set from the constructor.
Public property | IsLiteral | Returns true if the field is a literal set at compile time.
Public property | IsPrivate | Gets a value indicating whether the field is private.
Public property | IsPublic | Gets a value indicating whether the field is public.
Public property | IsStatic | Returns true if the field is static.
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Public property | ValueType | Gets the type of value held in the slot.
Top

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


FieldAttributes Property

StaticFieldWrapper.FieldAttributes Property
[image]

Gets the field attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldAttributes As FieldAttributes _
Implements IFieldInfo.FieldAttributes
C#
public FieldAttributes FieldAttributes { get; }
C++
public property FieldAttributes FieldAttributes sealed {
FieldAttributes get();
}
J#
/** property */
public FieldAttributes get_FieldAttributes();
JScript
public function get FieldAttributes() : FieldAttributes

Implements

IFieldInfo.FieldAttributes

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsAssembly Property

StaticFieldWrapper.IsAssembly Property
[image]

Gets a value indicating whether this field has Assembly level visibility.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAssembly As Boolean _
Implements IFieldInfo.IsAssembly
C#
public bool IsAssembly { get; }
C++
public property bool IsAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsAssembly();
JScript
public function get IsAssembly() : bool

Implements

IFieldInfo.IsAssembly

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsFamily Property

StaticFieldWrapper.IsFamily Property
[image]

Gets a value indicating whether this field has Family level visibility.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFamily As Boolean _
Implements IFieldInfo.IsFamily
C#
public bool IsFamily { get; }
C++
public property bool IsFamily sealed {
bool get();
}
J#
/** property */
public bool get_IsFamily();
JScript
public function get IsFamily() : bool

Implements

IFieldInfo.IsFamily

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsFamilyAndAssembly Property

StaticFieldWrapper.IsFamilyAndAssembly Property
[image]

Gets a value indicating whether this field has FamilyAndAssembly level visibility.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFamilyAndAssembly As Boolean _
Implements IFieldInfo.IsFamilyAndAssembly
C#
public bool IsFamilyAndAssembly { get; }
C++
public property bool IsFamilyAndAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsFamilyAndAssembly();
JScript
public function get IsFamilyAndAssembly() : bool

Implements

IFieldInfo.IsFamilyAndAssembly

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsFamilyOrAssembly Property

StaticFieldWrapper.IsFamilyOrAssembly Property
[image]

Gets a value indicating whether this field has FamilyOrAssembly level visibility.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFamilyOrAssembly As Boolean _
Implements IFieldInfo.IsFamilyOrAssembly
C#
public bool IsFamilyOrAssembly { get; }
C++
public property bool IsFamilyOrAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsFamilyOrAssembly();
JScript
public function get IsFamilyOrAssembly() : bool

Implements

IFieldInfo.IsFamilyOrAssembly

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsInitOnly Property

StaticFieldWrapper.IsInitOnly Property
[image]

Returns true if the field is read-only and can only be set from the constructor.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInitOnly As Boolean _
Implements IFieldInfo.IsInitOnly
C#
public bool IsInitOnly { get; }
C++
public property bool IsInitOnly sealed {
bool get();
}
J#
/** property */
public bool get_IsInitOnly();
JScript
public function get IsInitOnly() : bool

Implements

IFieldInfo.IsInitOnly

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsLiteral Property

StaticFieldWrapper.IsLiteral Property
[image]

Returns true if the field is a literal set at compile time.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLiteral As Boolean _
Implements IFieldInfo.IsLiteral
C#
public bool IsLiteral { get; }
C++
public property bool IsLiteral sealed {
bool get();
}
J#
/** property */
public bool get_IsLiteral();
JScript
public function get IsLiteral() : bool

Implements

IFieldInfo.IsLiteral

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsPrivate Property

StaticFieldWrapper.IsPrivate Property
[image]

Gets a value indicating whether the field is private.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPrivate As Boolean _
Implements IFieldInfo.IsPrivate
C#
public bool IsPrivate { get; }
C++
public property bool IsPrivate sealed {
bool get();
}
J#
/** property */
public bool get_IsPrivate();
JScript
public function get IsPrivate() : bool

Implements

IFieldInfo.IsPrivate

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsPublic Property

StaticFieldWrapper.IsPublic Property
[image]

Gets a value indicating whether the field is public.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPublic As Boolean _
Implements IFieldInfo.IsPublic
C#
public bool IsPublic { get; }
C++
public property bool IsPublic sealed {
bool get();
}
J#
/** property */
public bool get_IsPublic();
JScript
public function get IsPublic() : bool

Implements

IFieldInfo.IsPublic

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


IsStatic Property

StaticFieldWrapper.IsStatic Property
[image]

Returns true if the field is static.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStatic As Boolean _
Implements IFieldInfo.IsStatic
C#
public bool IsStatic { get; }
C++
public property bool IsStatic sealed {
bool get();
}
J#
/** property */
public bool get_IsStatic();
JScript
public function get IsStatic() : bool

Implements

IFieldInfo.IsStatic

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticFieldWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


Position Property

StaticFieldWrapper.Position Property
[image]

Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer _
Implements ISlotInfo.Position
C#
public int Position { get; }
C++
public property int Position sealed {
int get();
}
J#
/** property */
public int get_Position();
JScript
public function get Position() : int

Implements

ISlotInfo.Position

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


ValueType Property

StaticFieldWrapper.ValueType Property
[image]

Gets the type of value held in the slot.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As ITypeInfo _
Implements ISlotInfo.ValueType
C#
public ITypeInfo ValueType { get; }
C++
public property ITypeInfo ValueType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ValueType();
JScript
public function get ValueType() : ITypeInfo

Implements

ISlotInfo.ValueType

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticFieldWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticFieldWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IFieldInfo) |
Public method | Equals (ISlotInfo) |
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IFieldInfo)

StaticFieldWrapper.Equals Method (IFieldInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IFieldInfo _
) As Boolean _
Implements IEquatable<IFieldInfo>.Equals
C#
public bool Equals(
IFieldInfo other
)
C++
public:
bool Equals(
IFieldInfo other
) sealed
J#
public bool Equals(
IFieldInfo other
)
JScript
public function Equals(
other : IFieldInfo
) : bool

Implements

IEquatable<IFieldInfo>.Equals

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace
StaticFieldWrapper.Equals Overload List


Equals Method (ISlotInfo)

StaticFieldWrapper.Equals Method (ISlotInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ISlotInfo _
) As Boolean _
Implements IEquatable<ISlotInfo>.Equals
C#
public bool Equals(
ISlotInfo other
)
C++
public:
bool Equals(
ISlotInfo other
) sealed
J#
public bool Equals(
ISlotInfo other
)
JScript
public function Equals(
other : ISlotInfo
) : bool

Implements

IEquatable<ISlotInfo>.Equals

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace
StaticFieldWrapper.Equals Overload List


Resolve Method

StaticFieldWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As FieldInfo _
Implements IFieldInfo.Resolve
C#
public FieldInfo Resolve(
bool throwOnError
)
C++
public:
FieldInfo Resolve(
bool throwOnError
) sealed
J#
public FieldInfo Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : FieldInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IFieldInfo.Resolve

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticFieldWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticFieldWrapper Class
Gallio.Reflection.Impl Namespace


StaticFunctionWrapper Class

StaticFunctionWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy function wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticFunctionWrapper
Inherits StaticReflectedMemberWrapper
Implements IFunctionInfo
C#
public abstract class StaticFunctionWrapper : StaticReflectedMemberWrapper, IFunctionInfo
C++
ref class StaticFunctionWrapper abstract : StaticReflectedMemberWrapper, IFunctionInfo
J#
public class StaticFunctionWrapper extends StaticReflectedMemberWrapper implements IFunctionInfo
JScript
public class StaticFunctionWrapper extends StaticReflectedMemberWrapper, IFunctionInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticFunctionWrapper
Gallio.Reflection.Impl.StaticConstructorWrapper
Gallio.Reflection.Impl.StaticMethodWrapper

See Also

StaticFunctionWrapper Members
Gallio.Reflection.Impl Namespace


StaticFunctionWrapper Members

StaticFunctionWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy function wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticFunctionWrapper.

Protected Constructors

 | Name | Description
Family method | StaticFunctionWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method.
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAbstract | Returns true if the method is abstract.
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly.
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly.
Public property | IsFinal | Returns true if the method is final.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class.
Public property | IsPrivate | Gets a value indicating whether this member is private.
Public property | IsPublic | Gets a value indicating whether this is a public method.
Public property | IsStatic | Returns true if the method is static.
Public property | IsVirtual | Gets a value indicating whether the method is virtual.
Public property | Kind | (inherited from StaticCodeElementWrapper)
Public property | MethodAttributes | Gets the method attributes.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Parameters |
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticCodeElementWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Overridden. Implementation of Resolve
Family method | ResolveMethodBase | Implementation of Resolve
Top

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


StaticFunctionWrapper Constructor

StaticFunctionWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
)
C#
protected StaticFunctionWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
C++
protected:
StaticFunctionWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
) sealed
J#
protected StaticFunctionWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
JScript
protected function StaticFunctionWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type
reflectedType
The reflected type, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, declaringType, or reflectedType is null

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticFunctionWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method.
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAbstract | Returns true if the method is abstract.
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly.
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes.
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly.
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly.
Public property | IsFinal | Returns true if the method is final.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class.
Public property | IsPrivate | Gets a value indicating whether this member is private.
Public property | IsPublic | Gets a value indicating whether this is a public method.
Public property | IsStatic | Returns true if the method is static.
Public property | IsVirtual | Gets a value indicating whether the method is virtual.
Public property | Kind | (inherited from StaticCodeElementWrapper)
Public property | MethodAttributes | Gets the method attributes.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Parameters |
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


CallingConvention Property

StaticFunctionWrapper.CallingConvention Property
[image]

Gets the calling conventions for this method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CallingConvention As CallingConventions _
Implements IFunctionInfo.CallingConvention
C#
public CallingConventions CallingConvention { get; }
C++
public property CallingConventions CallingConvention sealed {
CallingConventions get();
}
J#
/** property */
public CallingConventions get_CallingConvention();
JScript
public function get CallingConvention() : CallingConventions

Implements

IFunctionInfo.CallingConvention

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsAbstract Property

StaticFunctionWrapper.IsAbstract Property
[image]

Returns true if the method is abstract.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAbstract As Boolean _
Implements IFunctionInfo.IsAbstract
C#
public bool IsAbstract { get; }
C++
public property bool IsAbstract sealed {
bool get();
}
J#
/** property */
public bool get_IsAbstract();
JScript
public function get IsAbstract() : bool

Implements

IFunctionInfo.IsAbstract

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsAssembly Property

StaticFunctionWrapper.IsAssembly Property
[image]

Gets a value indicating whether this method can be called by other classes in the same assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAssembly As Boolean _
Implements IFunctionInfo.IsAssembly
C#
public bool IsAssembly { get; }
C++
public property bool IsAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsAssembly();
JScript
public function get IsAssembly() : bool

Implements

IFunctionInfo.IsAssembly

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsFamily Property

StaticFunctionWrapper.IsFamily Property
[image]

Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFamily As Boolean _
Implements IFunctionInfo.IsFamily
C#
public bool IsFamily { get; }
C++
public property bool IsFamily sealed {
bool get();
}
J#
/** property */
public bool get_IsFamily();
JScript
public function get IsFamily() : bool

Implements

IFunctionInfo.IsFamily

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsFamilyAndAssembly Property

StaticFunctionWrapper.IsFamilyAndAssembly Property
[image]

Gets a value indicating whether this method can be called by derived classes if they are in the same assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFamilyAndAssembly As Boolean _
Implements IFunctionInfo.IsFamilyAndAssembly
C#
public bool IsFamilyAndAssembly { get; }
C++
public property bool IsFamilyAndAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsFamilyAndAssembly();
JScript
public function get IsFamilyAndAssembly() : bool

Implements

IFunctionInfo.IsFamilyAndAssembly

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsFamilyOrAssembly Property

StaticFunctionWrapper.IsFamilyOrAssembly Property
[image]

Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFamilyOrAssembly As Boolean _
Implements IFunctionInfo.IsFamilyOrAssembly
C#
public bool IsFamilyOrAssembly { get; }
C++
public property bool IsFamilyOrAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsFamilyOrAssembly();
JScript
public function get IsFamilyOrAssembly() : bool

Implements

IFunctionInfo.IsFamilyOrAssembly

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsFinal Property

StaticFunctionWrapper.IsFinal Property
[image]

Returns true if the method is final.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFinal As Boolean _
Implements IFunctionInfo.IsFinal
C#
public bool IsFinal { get; }
C++
public property bool IsFinal sealed {
bool get();
}
J#
/** property */
public bool get_IsFinal();
JScript
public function get IsFinal() : bool

Implements

IFunctionInfo.IsFinal

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsHideBySig Property

StaticFunctionWrapper.IsHideBySig Property
[image]

Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsHideBySig As Boolean _
Implements IFunctionInfo.IsHideBySig
C#
public bool IsHideBySig { get; }
C++
public property bool IsHideBySig sealed {
bool get();
}
J#
/** property */
public bool get_IsHideBySig();
JScript
public function get IsHideBySig() : bool

Implements

IFunctionInfo.IsHideBySig

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsPrivate Property

StaticFunctionWrapper.IsPrivate Property
[image]

Gets a value indicating whether this member is private.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPrivate As Boolean _
Implements IFunctionInfo.IsPrivate
C#
public bool IsPrivate { get; }
C++
public property bool IsPrivate sealed {
bool get();
}
J#
/** property */
public bool get_IsPrivate();
JScript
public function get IsPrivate() : bool

Implements

IFunctionInfo.IsPrivate

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsPublic Property

StaticFunctionWrapper.IsPublic Property
[image]

Gets a value indicating whether this is a public method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPublic As Boolean _
Implements IFunctionInfo.IsPublic
C#
public bool IsPublic { get; }
C++
public property bool IsPublic sealed {
bool get();
}
J#
/** property */
public bool get_IsPublic();
JScript
public function get IsPublic() : bool

Implements

IFunctionInfo.IsPublic

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsStatic Property

StaticFunctionWrapper.IsStatic Property
[image]

Returns true if the method is static.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsStatic As Boolean _
Implements IFunctionInfo.IsStatic
C#
public bool IsStatic { get; }
C++
public property bool IsStatic sealed {
bool get();
}
J#
/** property */
public bool get_IsStatic();
JScript
public function get IsStatic() : bool

Implements

IFunctionInfo.IsStatic

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


IsVirtual Property

StaticFunctionWrapper.IsVirtual Property
[image]

Gets a value indicating whether the method is virtual.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsVirtual As Boolean _
Implements IFunctionInfo.IsVirtual
C#
public bool IsVirtual { get; }
C++
public property bool IsVirtual sealed {
bool get();
}
J#
/** property */
public bool get_IsVirtual();
JScript
public function get IsVirtual() : bool

Implements

IFunctionInfo.IsVirtual

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


MethodAttributes Property

StaticFunctionWrapper.MethodAttributes Property
[image]

Gets the method attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MethodAttributes As MethodAttributes _
Implements IFunctionInfo.MethodAttributes
C#
public MethodAttributes MethodAttributes { get; }
C++
public property MethodAttributes MethodAttributes sealed {
MethodAttributes get();
}
J#
/** property */
public MethodAttributes get_MethodAttributes();
JScript
public function get MethodAttributes() : MethodAttributes

Implements

IFunctionInfo.MethodAttributes

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


Parameters Property

StaticFunctionWrapper.Parameters Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As IList(Of StaticParameterWrapper)
C#
public IList<StaticParameterWrapper> Parameters { get; }
C++
public property IList<StaticParameterWrapper> Parameters sealed {
IList<StaticParameterWrapper> get();
}
J#
/** property */
public IList<StaticParameterWrapper> get_Parameters();
JScript
public function get Parameters() : IList<StaticParameterWrapper>

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticFunctionWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticCodeElementWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Overridden. Implementation of Resolve
Family method | ResolveMethodBase | Implementation of Resolve
Top

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticFunctionWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IFunctionInfo) |
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IFunctionInfo)

StaticFunctionWrapper.Equals Method (IFunctionInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IFunctionInfo _
) As Boolean _
Implements IEquatable<IFunctionInfo>.Equals
C#
public bool Equals(
IFunctionInfo other
)
C++
public:
bool Equals(
IFunctionInfo other
) sealed
J#
public bool Equals(
IFunctionInfo other
)
JScript
public function Equals(
other : IFunctionInfo
) : bool

Implements

IEquatable<IFunctionInfo>.Equals

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace
StaticFunctionWrapper.Equals Overload List


ResolveMemberInfo Method

StaticFunctionWrapper.ResolveMemberInfo Method
[image]

Implementation of Resolve

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ResolveMemberInfo( _
ByVal throwOnError As Boolean _
) As MemberInfo
C#
protected override MemberInfo ResolveMemberInfo(
bool throwOnError
)
C++
protected:
virtual MemberInfo ResolveMemberInfo(
bool throwOnError
) override
J#
protected override MemberInfo ResolveMemberInfo(
bool throwOnError
)
JScript
protected override function ResolveMemberInfo(
throwOnError : bool
) : MemberInfo

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


ResolveMethodBase Method

StaticFunctionWrapper.ResolveMethodBase Method
[image]

Implementation of Resolve

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function ResolveMethodBase( _
ByVal throwOnError As Boolean _
) As MethodBase
C#
protected abstract MethodBase ResolveMethodBase(
bool throwOnError
)
C++
protected:
MethodBase ResolveMethodBase(
bool throwOnError
) abstract
J#
protected abstract MethodBase ResolveMethodBase(
bool throwOnError
)
JScript
protected abstract function ResolveMethodBase(
throwOnError : bool
) : MethodBase

See Also

StaticFunctionWrapper Class
Gallio.Reflection.Impl Namespace


StaticGenericParameterWrapper Class

StaticGenericParameterWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy generic parameter wrapper. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticGenericParameterWrapper
Inherits StaticSpecialTypeWrapper
Implements IGenericParameterInfo, ISlotInfo
C#
public sealed class StaticGenericParameterWrapper : StaticSpecialTypeWrapper, IGenericParameterInfo, ISlotInfo
C++
ref class StaticGenericParameterWrapper sealed : StaticSpecialTypeWrapper, IGenericParameterInfo, ISlotInfo
J#
public final class StaticGenericParameterWrapper extends StaticSpecialTypeWrapper implements IGenericParameterInfo, ISlotInfo
JScript
public final class StaticGenericParameterWrapper extends StaticSpecialTypeWrapper, IGenericParameterInfo, ISlotInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticGenericParameterWrapper

See Also

StaticGenericParameterWrapper Members
Gallio.Reflection.Impl Namespace


StaticGenericParameterWrapper Members

StaticGenericParameterWrapper Members
See Also Example Properties Methods
[image]

A StaticReflectionPolicy generic parameter wrapper. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by StaticGenericParameterWrapper.

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Overridden. Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Overridden. Gets the assembly-qualified name of the type, or null if the type is a generic parameter.
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | Constraints | Gets the constraints of the generic parameter.
Public property | ContainsGenericParameters | Overridden. Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringMethod | Gets the declaring method, or null if the generic parameter belongs to a type.
Public property | DeclaringType | Overridden. Gets the declaring type, or null if none.
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticTypeWrapper)
Public property | FullName | Overridden. Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericParameterAttributes | Gets the generic parameter attributes.
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Overridden. Returns true if the type represents a generic type parameter.
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Overridden. Gets the name of the namespace in which the type is declared.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Public property | ValueType | Gets the type of value held in the slot.
Top

Public Methods

 | Name | Description
 | CreateGenericMethodParameter | Creates a wrapper for a generic method parameter.
 | CreateGenericTypeParameter | Creates a wrapper for a generic type parameter.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors | Overridden. Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticGenericParameterWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Overridden. Gets the assembly in which the type is declared.
Public property | AssemblyQualifiedName | Overridden. Gets the assembly-qualified name of the type, or null if the type is a generic parameter.
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | Constraints | Gets the constraints of the generic parameter.
Public property | ContainsGenericParameters | Overridden. Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringMethod | Gets the declaring method, or null if the generic parameter belongs to a type.
Public property | DeclaringType | Overridden. Gets the declaring type, or null if none.
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticTypeWrapper)
Public property | FullName | Overridden. Gets the full name of the type, or null if the type is a generic parameter.
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericParameterAttributes | Gets the generic parameter attributes.
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Overridden. Returns true if the type represents a generic type parameter.
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Overridden. Gets the name of the namespace in which the type is declared.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Public property | ValueType | Gets the type of value held in the slot.
Top

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Assembly Property

StaticGenericParameterWrapper.Assembly Property
[image]

Gets the assembly in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Assembly As IAssemblyInfo _
Implements ITypeInfo.Assembly
C#
public override IAssemblyInfo Assembly { get; }
C++
public override property IAssemblyInfo Assembly override {
IAssemblyInfo get();
}
J#
/** property */
public IAssemblyInfo get_Assembly();
JScript
public function get Assembly() : IAssemblyInfo

Implements

ITypeInfo.Assembly

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


AssemblyQualifiedName Property

StaticGenericParameterWrapper.AssemblyQualifiedName Property
[image]

Gets the assembly-qualified name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AssemblyQualifiedName As String _
Implements ITypeInfo.AssemblyQualifiedName
C#
public override string AssemblyQualifiedName { get; }
C++
public override property string AssemblyQualifiedName override {
String get();
}
J#
/** property */
public string get_AssemblyQualifiedName();
JScript
public function get AssemblyQualifiedName() : String

Implements

ITypeInfo.AssemblyQualifiedName

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Constraints Property

StaticGenericParameterWrapper.Constraints Property
[image]

Gets the constraints of the generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Constraints As IList(Of ITypeInfo) _
Implements IGenericParameterInfo.Constraints
C#
public IList<ITypeInfo> Constraints { get; }
C++
public property IList<ITypeInfo> Constraints sealed {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_Constraints();
JScript
public function get Constraints() : IList<ITypeInfo>

Implements

IGenericParameterInfo.Constraints

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

StaticGenericParameterWrapper.ContainsGenericParameters Property
See Also Example
[image]

Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContainsGenericParameters As Boolean _
Implements ITypeInfo.ContainsGenericParameters
C#
public override bool ContainsGenericParameters { get; }
C++
public override property bool ContainsGenericParameters override {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Implements

ITypeInfo.ContainsGenericParameters

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


DeclaringMethod Property

StaticGenericParameterWrapper.DeclaringMethod Property
[image]

Gets the declaring method, or null if the generic parameter belongs to a type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeclaringMethod As StaticMethodWrapper
C#
public StaticMethodWrapper DeclaringMethod { get; }
C++
public property StaticMethodWrapper DeclaringMethod sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_DeclaringMethod();
JScript
public function get DeclaringMethod() : StaticMethodWrapper

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

StaticGenericParameterWrapper.DeclaringType Property
[image]

Gets the declaring type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As StaticDeclaredTypeWrapper
C#
public override StaticDeclaredTypeWrapper DeclaringType { get; }
C++
public override property StaticDeclaredTypeWrapper DeclaringType override {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_DeclaringType();
JScript
public function get DeclaringType() : StaticDeclaredTypeWrapper

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


FullName Property

StaticGenericParameterWrapper.FullName Property
[image]

Gets the full name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String _
Implements ITypeInfo.FullName
C#
public override string FullName { get; }
C++
public override property string FullName override {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITypeInfo.FullName

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


GenericParameterAttributes Property

StaticGenericParameterWrapper.GenericParameterAttributes Property
See Also Example
[image]

Gets the generic parameter attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GenericParameterAttributes As GenericParameterAttributes _
Implements IGenericParameterInfo.GenericParameterAttributes
C#
public GenericParameterAttributes GenericParameterAttributes { get; }
C++
public property GenericParameterAttributes GenericParameterAttributes sealed {
GenericParameterAttributes get();
}
J#
/** property */
public GenericParameterAttributes get_GenericParameterAttributes();
JScript
public function get GenericParameterAttributes() : GenericParameterAttributes

Implements

IGenericParameterInfo.GenericParameterAttributes

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericParameter Property

StaticGenericParameterWrapper.IsGenericParameter Property
[image]

Returns true if the type represents a generic type parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericParameter As Boolean _
Implements ITypeInfo.IsGenericParameter
C#
public override bool IsGenericParameter { get; }
C++
public override property bool IsGenericParameter override {
bool get();
}
J#
/** property */
public bool get_IsGenericParameter();
JScript
public function get IsGenericParameter() : bool

Implements

ITypeInfo.IsGenericParameter

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticGenericParameterWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


NamespaceName Property

StaticGenericParameterWrapper.NamespaceName Property
[image]

Gets the name of the namespace in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NamespaceName As String _
Implements ITypeInfo.NamespaceName
C#
public override string NamespaceName { get; }
C++
public override property string NamespaceName override {
String get();
}
J#
/** property */
public string get_NamespaceName();
JScript
public function get NamespaceName() : String

Implements

ITypeInfo.NamespaceName

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Position Property

StaticGenericParameterWrapper.Position Property
[image]

Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer _
Implements ISlotInfo.Position
C#
public int Position { get; }
C++
public property int Position sealed {
int get();
}
J#
/** property */
public int get_Position();
JScript
public function get Position() : int

Implements

ISlotInfo.Position

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


TypeAttributes Property

StaticGenericParameterWrapper.TypeAttributes Property
[image]

Gets the type attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TypeAttributes As TypeAttributes _
Implements ITypeInfo.TypeAttributes
C#
public override TypeAttributes TypeAttributes { get; }
C++
public override property TypeAttributes TypeAttributes override {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

Implements

ITypeInfo.TypeAttributes

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


ValueType Property

StaticGenericParameterWrapper.ValueType Property
[image]

Gets the type of value held in the slot.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As ITypeInfo _
Implements ISlotInfo.ValueType
C#
public ITypeInfo ValueType { get; }
C++
public property ITypeInfo ValueType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ValueType();
JScript
public function get ValueType() : ITypeInfo

Implements

ISlotInfo.ValueType

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticGenericParameterWrapper Methods
[image]

Public Methods

 | Name | Description
 | CreateGenericMethodParameter | Creates a wrapper for a generic method parameter.
 | CreateGenericTypeParameter | Creates a wrapper for a generic type parameter.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors | Overridden. Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


ApplySubstitution Method

StaticGenericParameterWrapper.ApplySubstitution Method
[image]

Applies a type substitution and returns the resulting type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ApplySubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As ITypeInfo
C#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
C++
protected:
virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
) override
J#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
JScript
protected override function ApplySubstitution(
substitution : StaticTypeSubstitution
) : ITypeInfo

Parameters

substitution
The substitution

Return Value

The type after substitution has been performed

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


CreateGenericMethodParameter Method

StaticGenericParameterWrapper.CreateGenericMethodParameter Method
See Also Example
[image]

Creates a wrapper for a generic method parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateGenericMethodParameter( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringMethod As StaticMethodWrapper _
) As StaticGenericParameterWrapper
C#
public static StaticGenericParameterWrapper CreateGenericMethodParameter(
StaticReflectionPolicy policy,
object handle,
StaticMethodWrapper declaringMethod
)
C++
public:
static StaticGenericParameterWrapper CreateGenericMethodParameter(
StaticReflectionPolicy policy,
Object handle,
StaticMethodWrapper declaringMethod
)
J#
public static StaticGenericParameterWrapper CreateGenericMethodParameter(
StaticReflectionPolicy policy,
object handle,
StaticMethodWrapper declaringMethod
)
JScript
public static function CreateGenericMethodParameter(
policy : StaticReflectionPolicy,
handle : Object,
declaringMethod : StaticMethodWrapper
) : StaticGenericParameterWrapper

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringMethod
The declaring method, which must be a generic method definition

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle or declaringMethod is null

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


CreateGenericTypeParameter Method

StaticGenericParameterWrapper.CreateGenericTypeParameter Method
See Also Example
[image]

Creates a wrapper for a generic type parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateGenericTypeParameter( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper _
) As StaticGenericParameterWrapper
C#
public static StaticGenericParameterWrapper CreateGenericTypeParameter(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
C++
public:
static StaticGenericParameterWrapper CreateGenericTypeParameter(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType
)
J#
public static StaticGenericParameterWrapper CreateGenericTypeParameter(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
JScript
public static function CreateGenericTypeParameter(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper
) : StaticGenericParameterWrapper

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type, which must be a generic type definition

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle or declaringType is null

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticGenericParameterWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IGenericParameterInfo) |
Public method | Equals (ISlotInfo) |
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (ITypeInfo) | (inherited from StaticTypeWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IGenericParameterInfo)

StaticGenericParameterWrapper.Equals Method (IGenericParameterInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IGenericParameterInfo _
) As Boolean _
Implements IEquatable<IGenericParameterInfo>.Equals
C#
public bool Equals(
IGenericParameterInfo other
)
C++
public:
bool Equals(
IGenericParameterInfo other
) sealed
J#
public bool Equals(
IGenericParameterInfo other
)
JScript
public function Equals(
other : IGenericParameterInfo
) : bool

Implements

IEquatable<IGenericParameterInfo>.Equals

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace
StaticGenericParameterWrapper.Equals Overload List


Equals Method (ISlotInfo)

StaticGenericParameterWrapper.Equals Method (ISlotInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ISlotInfo _
) As Boolean _
Implements IEquatable<ISlotInfo>.Equals
C#
public bool Equals(
ISlotInfo other
)
C++
public:
bool Equals(
ISlotInfo other
) sealed
J#
public bool Equals(
ISlotInfo other
)
JScript
public function Equals(
other : ISlotInfo
) : bool

Implements

IEquatable<ISlotInfo>.Equals

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace
StaticGenericParameterWrapper.Equals Overload List


GetConstructors Method

StaticGenericParameterWrapper.GetConstructors Method
[image]

Gets all constructors of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetConstructors( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IConstructorInfo) _
Implements ITypeInfo.GetConstructors
C#
public override IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
) override
J#
public override IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
JScript
public override function GetConstructors(
bindingFlags : BindingFlags
) : IList<IConstructorInfo>

Parameters

bindingFlags
The binding flags

Return Value

The constructors

Implements

ITypeInfo.GetConstructors

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticGenericParameterWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticGenericParameterWrapper Class
Gallio.Reflection.Impl Namespace


StaticMemberWrapper Class

StaticMemberWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy member wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticMemberWrapper
Inherits StaticCodeElementWrapper
Implements IMemberInfo
C#
public abstract class StaticMemberWrapper : StaticCodeElementWrapper, IMemberInfo
C++
ref class StaticMemberWrapper abstract : StaticCodeElementWrapper, IMemberInfo
J#
public class StaticMemberWrapper extends StaticCodeElementWrapper implements IMemberInfo
JScript
public class StaticMemberWrapper extends StaticCodeElementWrapper, IMemberInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper

See Also

StaticMemberWrapper Members
Gallio.Reflection.Impl Namespace


StaticMemberWrapper Members

StaticMemberWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy member wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticMemberWrapper.

Protected Constructors

 | Name | Description
Family method | StaticMemberWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CodeReference | Overridden.
Public property | DeclaringType | Gets the declaring type, or null if none.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | (inherited from StaticCodeElementWrapper)
Public property | Name | Overridden.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none.
Public property | Substitution | Gets the type substitution for generic parameters.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Overridden.
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Overridden. Gets all attributes that appear on this code element, excluding inherited attributes.
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticCodeElementWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve
Top

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


StaticMemberWrapper Constructor

StaticMemberWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper _
)
C#
protected StaticMemberWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
C++
protected:
StaticMemberWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType
) sealed
J#
protected StaticMemberWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
JScript
protected function StaticMemberWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticMemberWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference | Overridden.
Public property | DeclaringType | Gets the declaring type, or null if none.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | (inherited from StaticCodeElementWrapper)
Public property | Name | Overridden.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none.
Public property | Substitution | Gets the type substitution for generic parameters.
Top

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


CodeReference Property

StaticMemberWrapper.CodeReference Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CodeReference As CodeReference _
Implements ICodeElementInfo.CodeReference
C#
public override CodeReference CodeReference { get; }
C++
public override property CodeReference CodeReference override {
CodeReference get();
}
J#
/** property */
public CodeReference get_CodeReference();
JScript
public function get CodeReference() : CodeReference

Implements

ICodeElementInfo.CodeReference

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

StaticMemberWrapper.DeclaringType Property
[image]

Gets the declaring type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DeclaringType As StaticDeclaredTypeWrapper
C#
public virtual StaticDeclaredTypeWrapper DeclaringType { get; }
C++
public virtual property StaticDeclaredTypeWrapper DeclaringType {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_DeclaringType();
JScript
public function get DeclaringType() : StaticDeclaredTypeWrapper

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


Name Property

StaticMemberWrapper.Name Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String _
Implements ICodeElementInfo.Name
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ICodeElementInfo.Name

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

StaticMemberWrapper.ReflectedType Property
[image]

Gets the reflected type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ReflectedType As StaticDeclaredTypeWrapper
C#
public virtual StaticDeclaredTypeWrapper ReflectedType { get; }
C++
public virtual property StaticDeclaredTypeWrapper ReflectedType {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_ReflectedType();
JScript
public function get ReflectedType() : StaticDeclaredTypeWrapper

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


Substitution Property

StaticMemberWrapper.Substitution Property
[image]

Gets the type substitution for generic parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Substitution As StaticTypeSubstitution
C#
public virtual StaticTypeSubstitution Substitution { get; }
C++
public virtual property StaticTypeSubstitution Substitution {
StaticTypeSubstitution get();
}
J#
/** property */
public StaticTypeSubstitution get_Substitution();
JScript
public function get Substitution() : StaticTypeSubstitution

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticMemberWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Overridden.
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Overridden. Gets all attributes that appear on this code element, excluding inherited attributes.
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticCodeElementWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve
Top

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticMemberWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IMemberInfo) |
Public method | Equals (Object) | Overridden.
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IMemberInfo)

StaticMemberWrapper.Equals Method (IMemberInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IMemberInfo _
) As Boolean _
Implements IEquatable<IMemberInfo>.Equals
C#
public bool Equals(
IMemberInfo other
)
C++
public:
bool Equals(
IMemberInfo other
) sealed
J#
public bool Equals(
IMemberInfo other
)
JScript
public function Equals(
other : IMemberInfo
) : bool

Implements

IEquatable<IMemberInfo>.Equals

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace
StaticMemberWrapper.Equals Overload List


Equals Method (Object)

StaticMemberWrapper.Equals Method (Object)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace
StaticMemberWrapper.Equals Overload List


GetCodeLocation Method

StaticMemberWrapper.GetCodeLocation Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCodeLocation() As CodeLocation _
Implements ICodeElementInfo.GetCodeLocation
C#
public override CodeLocation GetCodeLocation()
C++
public:
virtual CodeLocation GetCodeLocation() override
J#
public override CodeLocation GetCodeLocation()
JScript
public override function GetCodeLocation() : CodeLocation

Implements

ICodeElementInfo.GetCodeLocation

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

StaticMemberWrapper.GetCustomAttributes Method
[image]

Gets all attributes that appear on this code element, excluding inherited attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCustomAttributes() As IEnumerable(Of StaticAttributeWrapper)
C#
protected override IEnumerable<StaticAttributeWrapper> GetCustomAttributes()
C++
protected:
virtual IEnumerable<StaticAttributeWrapper> GetCustomAttributes() override
J#
protected override IEnumerable<StaticAttributeWrapper> GetCustomAttributes()
JScript
protected override function GetCustomAttributes() : IEnumerable<StaticAttributeWrapper>

Return Value

The attribute wrappers

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


GetHashCode Method

StaticMemberWrapper.GetHashCode Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


ResolveMemberInfo Method

StaticMemberWrapper.ResolveMemberInfo Method
[image]

Implementation of Resolve

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function ResolveMemberInfo( _
ByVal throwOnError As Boolean _
) As MemberInfo
C#
protected abstract MemberInfo ResolveMemberInfo(
bool throwOnError
)
C++
protected:
MemberInfo ResolveMemberInfo(
bool throwOnError
) abstract
J#
protected abstract MemberInfo ResolveMemberInfo(
bool throwOnError
)
JScript
protected abstract function ResolveMemberInfo(
throwOnError : bool
) : MemberInfo

See Also

StaticMemberWrapper Class
Gallio.Reflection.Impl Namespace


StaticMethodWrapper Class

StaticMethodWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy method wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticMethodWrapper
Inherits StaticFunctionWrapper
Implements IMethodInfo
C#
public sealed class StaticMethodWrapper : StaticFunctionWrapper, IMethodInfo
C++
ref class StaticMethodWrapper sealed : StaticFunctionWrapper, IMethodInfo
J#
public final class StaticMethodWrapper extends StaticFunctionWrapper implements IMethodInfo
JScript
public final class StaticMethodWrapper extends StaticFunctionWrapper, IMethodInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticFunctionWrapper
Gallio.Reflection.Impl.StaticMethodWrapper

See Also

StaticMethodWrapper Members
Gallio.Reflection.Impl Namespace


StaticMethodWrapper Members

StaticMethodWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy method wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticMethodWrapper.

Public Constructors

 | Name | Description
Public method | StaticMethodWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method. (inherited from StaticFunctionWrapper)
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | ContainsGenericParameters | Returns true if the method contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | GenericArguments | Gets the generic arguments of the method. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericMethodDefinition |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAbstract | Returns true if the method is abstract. (inherited from StaticFunctionWrapper)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from StaticFunctionWrapper)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFinal | Returns true if the method is final. (inherited from StaticFunctionWrapper)
Public property | IsGenericMethod | Returns true if the method is a generic method. If so, the GenericArguments list will be non-empty.
Public property | IsGenericMethodDefinition | Returns true if the method is a generic method definition.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from StaticFunctionWrapper)
Public property | IsOverride | Returns true if this method overrides another.
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from StaticFunctionWrapper)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from StaticFunctionWrapper)
Public property | IsStatic | Returns true if the method is static. (inherited from StaticFunctionWrapper)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from StaticFunctionWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | MethodAttributes | Gets the method attributes. (inherited from StaticFunctionWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Parameters | (inherited from StaticFunctionWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | ReturnParameter | Gets the method return parameter object that contains information about the return value and its attributes.
Public property | ReturnType | Gets the method return type.
Public property | Substitution | Overridden. Gets the type substitution for generic parameters.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticFunctionWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetOverridenOrHiddenMethods | Gets the methods that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | HidesMethod | Returns true if this method hides the specified method.
Public method | MakeGenericMethod |
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


StaticMethodWrapper Constructor

StaticMethodWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper, _
ByVal substitution As StaticTypeSubstitution _
)
C#
public StaticMethodWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType,
StaticTypeSubstitution substitution
)
C++
public:
StaticMethodWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType,
StaticTypeSubstitution substitution
) sealed
J#
public StaticMethodWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType,
StaticTypeSubstitution substitution
)
JScript
public function StaticMethodWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper,
substitution : StaticTypeSubstitution
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type
reflectedType
The reflected type
substitution
The type substitution for generic parameters

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, or declaringType or reflectedType is null

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticMethodWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CallingConvention | Gets the calling conventions for this method. (inherited from StaticFunctionWrapper)
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | ContainsGenericParameters | Returns true if the method contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | GenericArguments | Gets the generic arguments of the method. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericMethodDefinition |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsAbstract | Returns true if the method is abstract. (inherited from StaticFunctionWrapper)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from StaticFunctionWrapper)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from StaticFunctionWrapper)
Public property | IsFinal | Returns true if the method is final. (inherited from StaticFunctionWrapper)
Public property | IsGenericMethod | Returns true if the method is a generic method. If so, the GenericArguments list will be non-empty.
Public property | IsGenericMethodDefinition | Returns true if the method is a generic method definition.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from StaticFunctionWrapper)
Public property | IsOverride | Returns true if this method overrides another.
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from StaticFunctionWrapper)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from StaticFunctionWrapper)
Public property | IsStatic | Returns true if the method is static. (inherited from StaticFunctionWrapper)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from StaticFunctionWrapper)
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | MethodAttributes | Gets the method attributes. (inherited from StaticFunctionWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Parameters | (inherited from StaticFunctionWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | ReturnParameter | Gets the method return parameter object that contains information about the return value and its attributes.
Public property | ReturnType | Gets the method return type.
Public property | Substitution | Overridden. Gets the type substitution for generic parameters.
Top

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

StaticMethodWrapper.ContainsGenericParameters Property
[image]

Returns true if the method contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainsGenericParameters As Boolean _
Implements IMethodInfo.ContainsGenericParameters
C#
public bool ContainsGenericParameters { get; }
C++
public property bool ContainsGenericParameters sealed {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Implements

IMethodInfo.ContainsGenericParameters

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


GenericArguments Property

StaticMethodWrapper.GenericArguments Property
[image]

Gets the generic arguments of the method. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GenericArguments As IList(Of ITypeInfo) _
Implements IMethodInfo.GenericArguments
C#
public IList<ITypeInfo> GenericArguments { get; }
C++
public property IList<ITypeInfo> GenericArguments sealed {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_GenericArguments();
JScript
public function get GenericArguments() : IList<ITypeInfo>

Property Value

The generic arguments

Implements

IMethodInfo.GenericArguments

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


GenericMethodDefinition Property

StaticMethodWrapper.GenericMethodDefinition Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GenericMethodDefinition As StaticMethodWrapper
C#
public StaticMethodWrapper GenericMethodDefinition { get; }
C++
public property StaticMethodWrapper GenericMethodDefinition sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_GenericMethodDefinition();
JScript
public function get GenericMethodDefinition() : StaticMethodWrapper

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericMethod Property

StaticMethodWrapper.IsGenericMethod Property
[image]

Returns true if the method is a generic method. If so, the GenericArguments list will be non-empty.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGenericMethod As Boolean _
Implements IMethodInfo.IsGenericMethod
C#
public bool IsGenericMethod { get; }
C++
public property bool IsGenericMethod sealed {
bool get();
}
J#
/** property */
public bool get_IsGenericMethod();
JScript
public function get IsGenericMethod() : bool

Implements

IMethodInfo.IsGenericMethod

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericMethodDefinition Property

StaticMethodWrapper.IsGenericMethodDefinition Property
[image]

Returns true if the method is a generic method definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsGenericMethodDefinition As Boolean _
Implements IMethodInfo.IsGenericMethodDefinition
C#
public bool IsGenericMethodDefinition { get; }
C++
public property bool IsGenericMethodDefinition sealed {
bool get();
}
J#
/** property */
public bool get_IsGenericMethodDefinition();
JScript
public function get IsGenericMethodDefinition() : bool

Implements

IMethodInfo.IsGenericMethodDefinition

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


IsOverride Property

StaticMethodWrapper.IsOverride Property
[image]

Returns true if this method overrides another.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOverride As Boolean
C#
public bool IsOverride { get; }
C++
public property bool IsOverride sealed {
bool get();
}
J#
/** property */
public bool get_IsOverride();
JScript
public function get IsOverride() : bool

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticMethodWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


ReturnParameter Property

StaticMethodWrapper.ReturnParameter Property
[image]

Gets the method return parameter object that contains information about the return value and its attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReturnParameter As IParameterInfo _
Implements IMethodInfo.ReturnParameter
C#
public IParameterInfo ReturnParameter { get; }
C++
public property IParameterInfo ReturnParameter sealed {
IParameterInfo get();
}
J#
/** property */
public IParameterInfo get_ReturnParameter();
JScript
public function get ReturnParameter() : IParameterInfo

Implements

IMethodInfo.ReturnParameter

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


ReturnType Property

StaticMethodWrapper.ReturnType Property
[image]

Gets the method return type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReturnType As ITypeInfo _
Implements IMethodInfo.ReturnType
C#
public ITypeInfo ReturnType { get; }
C++
public property ITypeInfo ReturnType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ReturnType();
JScript
public function get ReturnType() : ITypeInfo

Implements

IMethodInfo.ReturnType

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


Substitution Property

StaticMethodWrapper.Substitution Property
[image]

Gets the type substitution for generic parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Substitution As StaticTypeSubstitution
C#
public override StaticTypeSubstitution Substitution { get; }
C++
public override property StaticTypeSubstitution Substitution override {
StaticTypeSubstitution get();
}
J#
/** property */
public StaticTypeSubstitution get_Substitution();
JScript
public function get Substitution() : StaticTypeSubstitution

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticMethodWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticFunctionWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetOverridenOrHiddenMethods | Gets the methods that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | HidesMethod | Returns true if this method hides the specified method.
Public method | MakeGenericMethod |
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


GetOverridenOrHiddenMethods Method

StaticMethodWrapper.GetOverridenOrHiddenMethods Method
[image]

Gets the methods that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOverridenOrHiddenMethods( _
ByVal overridesOnly As Boolean _
) As IEnumerable(Of StaticMethodWrapper)
C#
public IEnumerable<StaticMethodWrapper> GetOverridenOrHiddenMethods(
bool overridesOnly
)
C++
public:
IEnumerable<StaticMethodWrapper> GetOverridenOrHiddenMethods(
bool overridesOnly
) sealed
J#
public IEnumerable<StaticMethodWrapper> GetOverridenOrHiddenMethods(
bool overridesOnly
)
JScript
public function GetOverridenOrHiddenMethods(
overridesOnly : bool
) : IEnumerable<StaticMethodWrapper>

Parameters

overridesOnly
If true, only returns overrides

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


HidesMethod Method

StaticMethodWrapper.HidesMethod Method
[image]

Returns true if this method hides the specified method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function HidesMethod( _
ByVal other As StaticMethodWrapper _
) As Boolean
C#
public bool HidesMethod(
StaticMethodWrapper other
)
C++
public:
bool HidesMethod(
StaticMethodWrapper other
) sealed
J#
public bool HidesMethod(
StaticMethodWrapper other
)
JScript
public function HidesMethod(
other : StaticMethodWrapper
) : bool

Parameters

other
The other method

Return Value

True if this method hides the other method

Remarks

This method assumes that other is defined by a base type of this method's declaring type. It determines whether method hiding has taken place based on the method's name and its signature (when IsHideBySig is true).

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


MakeGenericMethod Method

StaticMethodWrapper.MakeGenericMethod Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function MakeGenericMethod( _
ByVal genericArguments As IList(Of ITypeInfo) _
) As StaticMethodWrapper
C#
public StaticMethodWrapper MakeGenericMethod(
IList<ITypeInfo> genericArguments
)
C++
public:
StaticMethodWrapper MakeGenericMethod(
IList<ITypeInfo> genericArguments
) sealed
J#
public StaticMethodWrapper MakeGenericMethod(
IList<ITypeInfo> genericArguments
)
JScript
public function MakeGenericMethod(
genericArguments : IList<ITypeInfo>
) : StaticMethodWrapper

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticMethodWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As MethodInfo _
Implements IMethodInfo.Resolve
C#
public MethodInfo Resolve(
bool throwOnError
)
C++
public:
MethodInfo Resolve(
bool throwOnError
) sealed
J#
public MethodInfo Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : MethodInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IMethodInfo.Resolve

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticMethodWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticMethodWrapper Class
Gallio.Reflection.Impl Namespace


StaticParameterWrapper Class

StaticParameterWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy parameter wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticParameterWrapper
Inherits StaticCodeElementWrapper
Implements IParameterInfo, ISlotInfo
C#
public sealed class StaticParameterWrapper : StaticCodeElementWrapper, IParameterInfo, ISlotInfo
C++
ref class StaticParameterWrapper sealed : StaticCodeElementWrapper, IParameterInfo, ISlotInfo
J#
public final class StaticParameterWrapper extends StaticCodeElementWrapper implements IParameterInfo, ISlotInfo
JScript
public final class StaticParameterWrapper extends StaticCodeElementWrapper, IParameterInfo, ISlotInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticParameterWrapper

See Also

StaticParameterWrapper Members
Gallio.Reflection.Impl Namespace


StaticParameterWrapper Members

StaticParameterWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy parameter wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticParameterWrapper.

Public Constructors

 | Name | Description
Public method | StaticParameterWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CodeReference | Overridden. Gets a CodeReference for this code element.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsIn | Gets a value indicating whether this is an input parameter.
Public property | IsOptional | Gets a value indicating whether this parameter is optional.
Public property | IsOut | Gets a value indicating whether this is an output parameter.
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Member | Gets the member to which the parameter belongs.
Public property | Name | Overridden. Gets the name of the code element.
Public property | ParameterAttributes | Gets the parameter attributes.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ValueType | Gets the type of value held in the slot.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticCodeElementWrapper)
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


StaticParameterWrapper Constructor

StaticParameterWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal member As StaticMemberWrapper _
)
C#
public StaticParameterWrapper(
StaticReflectionPolicy policy,
object handle,
StaticMemberWrapper member
)
C++
public:
StaticParameterWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticMemberWrapper member
) sealed
J#
public StaticParameterWrapper(
StaticReflectionPolicy policy,
object handle,
StaticMemberWrapper member
)
JScript
public function StaticParameterWrapper(
policy : StaticReflectionPolicy,
handle : Object,
member : StaticMemberWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
member
The member to which the parameter belongs

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle or member is null

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticParameterWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference | Overridden. Gets a CodeReference for this code element.
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IsIn | Gets a value indicating whether this is an input parameter.
Public property | IsOptional | Gets a value indicating whether this parameter is optional.
Public property | IsOut | Gets a value indicating whether this is an output parameter.
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Member | Gets the member to which the parameter belongs.
Public property | Name | Overridden. Gets the name of the code element.
Public property | ParameterAttributes | Gets the parameter attributes.
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | ValueType | Gets the type of value held in the slot.
Top

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


CodeReference Property

StaticParameterWrapper.CodeReference Property
[image]

Gets a CodeReference for this code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CodeReference As CodeReference _
Implements ICodeElementInfo.CodeReference
C#
public override CodeReference CodeReference { get; }
C++
public override property CodeReference CodeReference override {
CodeReference get();
}
J#
/** property */
public CodeReference get_CodeReference();
JScript
public function get CodeReference() : CodeReference

Property Value

The code reference

Implements

ICodeElementInfo.CodeReference

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


IsIn Property

StaticParameterWrapper.IsIn Property
[image]

Gets a value indicating whether this is an input parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsIn As Boolean _
Implements IParameterInfo.IsIn
C#
public bool IsIn { get; }
C++
public property bool IsIn sealed {
bool get();
}
J#
/** property */
public bool get_IsIn();
JScript
public function get IsIn() : bool

Implements

IParameterInfo.IsIn

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


IsOptional Property

StaticParameterWrapper.IsOptional Property
[image]

Gets a value indicating whether this parameter is optional.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOptional As Boolean _
Implements IParameterInfo.IsOptional
C#
public bool IsOptional { get; }
C++
public property bool IsOptional sealed {
bool get();
}
J#
/** property */
public bool get_IsOptional();
JScript
public function get IsOptional() : bool

Implements

IParameterInfo.IsOptional

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


IsOut Property

StaticParameterWrapper.IsOut Property
[image]

Gets a value indicating whether this is an output parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOut As Boolean _
Implements IParameterInfo.IsOut
C#
public bool IsOut { get; }
C++
public property bool IsOut sealed {
bool get();
}
J#
/** property */
public bool get_IsOut();
JScript
public function get IsOut() : bool

Implements

IParameterInfo.IsOut

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticParameterWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Member Property

StaticParameterWrapper.Member Property
[image]

Gets the member to which the parameter belongs.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Member As StaticMemberWrapper
C#
public StaticMemberWrapper Member { get; }
C++
public property StaticMemberWrapper Member sealed {
StaticMemberWrapper get();
}
J#
/** property */
public StaticMemberWrapper get_Member();
JScript
public function get Member() : StaticMemberWrapper

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Name Property

StaticParameterWrapper.Name Property
[image]

Gets the name of the code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String _
Implements ICodeElementInfo.Name
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

ICodeElementInfo.Name

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


ParameterAttributes Property

StaticParameterWrapper.ParameterAttributes Property
[image]

Gets the parameter attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParameterAttributes As ParameterAttributes _
Implements IParameterInfo.ParameterAttributes
C#
public ParameterAttributes ParameterAttributes { get; }
C++
public property ParameterAttributes ParameterAttributes sealed {
ParameterAttributes get();
}
J#
/** property */
public ParameterAttributes get_ParameterAttributes();
JScript
public function get ParameterAttributes() : ParameterAttributes

Implements

IParameterInfo.ParameterAttributes

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Position Property

StaticParameterWrapper.Position Property
[image]

Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer _
Implements ISlotInfo.Position
C#
public int Position { get; }
C++
public property int Position sealed {
int get();
}
J#
/** property */
public int get_Position();
JScript
public function get Position() : int

Implements

ISlotInfo.Position

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


ValueType Property

StaticParameterWrapper.ValueType Property
[image]

Gets the type of value held in the slot.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As ITypeInfo _
Implements ISlotInfo.ValueType
C#
public ITypeInfo ValueType { get; }
C++
public property ITypeInfo ValueType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ValueType();
JScript
public function get ValueType() : ITypeInfo

Implements

ISlotInfo.ValueType

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticParameterWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticCodeElementWrapper)
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticParameterWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IParameterInfo) |
Public method | Equals (ISlotInfo) |
Public method | Equals (Object) | Overridden.
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IParameterInfo)

StaticParameterWrapper.Equals Method (IParameterInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IParameterInfo _
) As Boolean _
Implements IEquatable<IParameterInfo>.Equals
C#
public bool Equals(
IParameterInfo other
)
C++
public:
bool Equals(
IParameterInfo other
) sealed
J#
public bool Equals(
IParameterInfo other
)
JScript
public function Equals(
other : IParameterInfo
) : bool

Implements

IEquatable<IParameterInfo>.Equals

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace
StaticParameterWrapper.Equals Overload List


Equals Method (ISlotInfo)

StaticParameterWrapper.Equals Method (ISlotInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ISlotInfo _
) As Boolean _
Implements IEquatable<ISlotInfo>.Equals
C#
public bool Equals(
ISlotInfo other
)
C++
public:
bool Equals(
ISlotInfo other
) sealed
J#
public bool Equals(
ISlotInfo other
)
JScript
public function Equals(
other : ISlotInfo
) : bool

Implements

IEquatable<ISlotInfo>.Equals

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace
StaticParameterWrapper.Equals Overload List


Equals Method (Object)

StaticParameterWrapper.Equals Method (Object)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace
StaticParameterWrapper.Equals Overload List


GetHashCode Method

StaticParameterWrapper.GetHashCode Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticParameterWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As ParameterInfo _
Implements IParameterInfo.Resolve
C#
public ParameterInfo Resolve(
bool throwOnError
)
C++
public:
ParameterInfo Resolve(
bool throwOnError
) sealed
J#
public ParameterInfo Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : ParameterInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IParameterInfo.Resolve

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticParameterWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticParameterWrapper Class
Gallio.Reflection.Impl Namespace


StaticPointerTypeWrapper Class

StaticPointerTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy pointer type wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticPointerTypeWrapper
Inherits StaticConstructedTypeWrapper
C#
public sealed class StaticPointerTypeWrapper : StaticConstructedTypeWrapper
C++
ref class StaticPointerTypeWrapper sealed : StaticConstructedTypeWrapper
J#
public final class StaticPointerTypeWrapper extends StaticConstructedTypeWrapper
JScript
public final class StaticPointerTypeWrapper extends StaticConstructedTypeWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticConstructedTypeWrapper
Gallio.Reflection.Impl.StaticPointerTypeWrapper

See Also

StaticPointerTypeWrapper Members
Gallio.Reflection.Impl Namespace


StaticPointerTypeWrapper Members

StaticPointerTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy pointer type wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticPointerTypeWrapper.

Public Constructors

 | Name | Description
Public method | StaticPointerTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Gets the assembly in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects. (inherited from StaticConstructedTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticConstructedTypeWrapper)
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter. (inherited from StaticConstructedTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Overridden. Returns true if the type represents a pointer.
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Gets the name of the code element. (inherited from StaticConstructedTypeWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Gets the name of the namespace in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly. (inherited from StaticConstructedTypeWrapper)
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | Overridden.
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticConstructedTypeWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticPointerTypeWrapper Constructor

StaticPointerTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal elementType As StaticTypeWrapper _
)
C#
public StaticPointerTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
)
C++
public:
StaticPointerTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
) sealed
J#
public StaticPointerTypeWrapper(
StaticReflectionPolicy policy,
StaticTypeWrapper elementType
)
JScript
public function StaticPointerTypeWrapper(
policy : StaticReflectionPolicy,
elementType : StaticTypeWrapper
)

Parameters

policy
The reflection policy
elementType
The element type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or elementType is null

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticPointerTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | Gets the assembly in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | Returns true if the type contains unbound generic parameters. If so, the GenericArguments list will contain one or more IGenericParameterInfo objects. (inherited from StaticConstructedTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticConstructedTypeWrapper)
Public property | FullName | Gets the full name of the type, or null if the type is a generic parameter. (inherited from StaticConstructedTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Gets all of the type's interfaces. (inherited from StaticSpecialTypeWrapper)
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Overridden. Returns true if the type represents a pointer.
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | Gets the name of the code element. (inherited from StaticConstructedTypeWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | Gets the name of the namespace in which the type is declared. (inherited from StaticConstructedTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticSpecialTypeWrapper)
Public property | TypeAttributes | Overridden. Gets the type attributes.
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsPointer Property

StaticPointerTypeWrapper.IsPointer Property
[image]

Returns true if the type represents a pointer.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPointer As Boolean _
Implements ITypeInfo.IsPointer
C#
public override bool IsPointer { get; }
C++
public override property bool IsPointer override {
bool get();
}
J#
/** property */
public bool get_IsPointer();
JScript
public function get IsPointer() : bool

Implements

ITypeInfo.IsPointer

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


TypeAttributes Property

StaticPointerTypeWrapper.TypeAttributes Property
[image]

Gets the type attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TypeAttributes As TypeAttributes _
Implements ITypeInfo.TypeAttributes
C#
public override TypeAttributes TypeAttributes { get; }
C++
public override property TypeAttributes TypeAttributes override {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

Implements

ITypeInfo.TypeAttributes

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticPointerTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | Gets the location of a resource that contains the declaration of this code element, or Unknown if not available. The location may refer to the code element's source code or to the location of its compiled assembly. (inherited from StaticConstructedTypeWrapper)
Public method | GetConstructors | Gets all constructors of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvent | Gets a event by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetEvents | Gets all events of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetField | Gets a field by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetFields | Gets all fields of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetHashCode | Overridden.
Public method | GetMethod | Gets a method by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetMethods | Gets all methods of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedType | Gets a nested type by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetNestedTypes | Gets all nested types of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperties | Gets all properties of the type that satisfy the binding flags. (inherited from StaticSpecialTypeWrapper)
Public method | GetProperty | Gets a property by name, or null if not found. (inherited from StaticSpecialTypeWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticConstructedTypeWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Overridden. Applies a type substitution and returns the resulting type.
Top

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


ApplySubstitution Method

StaticPointerTypeWrapper.ApplySubstitution Method
[image]

Applies a type substitution and returns the resulting type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ApplySubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As ITypeInfo
C#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
C++
protected:
virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
) override
J#
protected override ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
JScript
protected override function ApplySubstitution(
substitution : StaticTypeSubstitution
) : ITypeInfo

Parameters

substitution
The substitution

Return Value

The type after substitution has been performed

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticPointerTypeWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden.
Public method | Equals (ITypeInfo) | (inherited from StaticTypeWrapper)
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (Object)

StaticPointerTypeWrapper.Equals Method (Object)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticPointerTypeWrapper.Equals Overload List


GetHashCode Method

StaticPointerTypeWrapper.GetHashCode Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

StaticPointerTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticPropertyWrapper Class

StaticPropertyWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy property wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StaticPropertyWrapper
Inherits StaticReflectedMemberWrapper
Implements IPropertyInfo, ISlotInfo
C#
public sealed class StaticPropertyWrapper : StaticReflectedMemberWrapper, IPropertyInfo, ISlotInfo
C++
ref class StaticPropertyWrapper sealed : StaticReflectedMemberWrapper, IPropertyInfo, ISlotInfo
J#
public final class StaticPropertyWrapper extends StaticReflectedMemberWrapper implements IPropertyInfo, ISlotInfo
JScript
public final class StaticPropertyWrapper extends StaticReflectedMemberWrapper, IPropertyInfo, ISlotInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticPropertyWrapper

See Also

StaticPropertyWrapper Members
Gallio.Reflection.Impl Namespace


StaticPropertyWrapper Members

StaticPropertyWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy property wrapper. This class cannot be inherited.

The following tables list the members exposed by StaticPropertyWrapper.

Public Constructors

 | Name | Description
Public method | StaticPropertyWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CanRead | Returns true if the property can be read.
Public property | CanWrite | Returns true if the property can be written.
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | GetMethod |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IndexParameters |
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | PropertyAttributes | Gets the property attributes.
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | SetMethod |
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Public property | ValueType | Gets the type of value held in the slot.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetOverridenOrHiddenProperties | Gets the properties that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


StaticPropertyWrapper Constructor

StaticPropertyWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
)
C#
public StaticPropertyWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
C++
public:
StaticPropertyWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
) sealed
J#
public StaticPropertyWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
JScript
public function StaticPropertyWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type
reflectedType
The reflected type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, declaringType, or reflectedType is null

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticPropertyWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CanRead | Returns true if the property can be read.
Public property | CanWrite | Returns true if the property can be written.
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | GetMethod |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | IndexParameters |
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | Position | Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.
Public property | PropertyAttributes | Gets the property attributes.
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticReflectedMemberWrapper)
Public property | SetMethod |
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Public property | ValueType | Gets the type of value held in the slot.
Top

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


CanRead Property

StaticPropertyWrapper.CanRead Property
[image]

Returns true if the property can be read.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanRead As Boolean _
Implements IPropertyInfo.CanRead
C#
public bool CanRead { get; }
C++
public property bool CanRead sealed {
bool get();
}
J#
/** property */
public bool get_CanRead();
JScript
public function get CanRead() : bool

Implements

IPropertyInfo.CanRead

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


CanWrite Property

StaticPropertyWrapper.CanWrite Property
[image]

Returns true if the property can be written.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanWrite As Boolean _
Implements IPropertyInfo.CanWrite
C#
public bool CanWrite { get; }
C++
public property bool CanWrite sealed {
bool get();
}
J#
/** property */
public bool get_CanWrite();
JScript
public function get CanWrite() : bool

Implements

IPropertyInfo.CanWrite

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


GetMethod Property

StaticPropertyWrapper.GetMethod Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GetMethod As StaticMethodWrapper
C#
public StaticMethodWrapper GetMethod { get; }
C++
public property StaticMethodWrapper GetMethod sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_GetMethod();
JScript
public function get GetMethod() : StaticMethodWrapper

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


IndexParameters Property

StaticPropertyWrapper.IndexParameters Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IndexParameters As IList(Of StaticParameterWrapper)
C#
public IList<StaticParameterWrapper> IndexParameters { get; }
C++
public property IList<StaticParameterWrapper> IndexParameters sealed {
IList<StaticParameterWrapper> get();
}
J#
/** property */
public IList<StaticParameterWrapper> get_IndexParameters();
JScript
public function get IndexParameters() : IList<StaticParameterWrapper>

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticPropertyWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Position Property

StaticPropertyWrapper.Position Property
[image]

Gets the positional index of a method parameter slot, -1 if the slot is a method return parameter, or 0 if the slot is of some other kind.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer _
Implements ISlotInfo.Position
C#
public int Position { get; }
C++
public property int Position sealed {
int get();
}
J#
/** property */
public int get_Position();
JScript
public function get Position() : int

Implements

ISlotInfo.Position

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


PropertyAttributes Property

StaticPropertyWrapper.PropertyAttributes Property
[image]

Gets the property attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PropertyAttributes As PropertyAttributes _
Implements IPropertyInfo.PropertyAttributes
C#
public PropertyAttributes PropertyAttributes { get; }
C++
public property PropertyAttributes PropertyAttributes sealed {
PropertyAttributes get();
}
J#
/** property */
public PropertyAttributes get_PropertyAttributes();
JScript
public function get PropertyAttributes() : PropertyAttributes

Implements

IPropertyInfo.PropertyAttributes

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


SetMethod Property

StaticPropertyWrapper.SetMethod Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SetMethod As StaticMethodWrapper
C#
public StaticMethodWrapper SetMethod { get; }
C++
public property StaticMethodWrapper SetMethod sealed {
StaticMethodWrapper get();
}
J#
/** property */
public StaticMethodWrapper get_SetMethod();
JScript
public function get SetMethod() : StaticMethodWrapper

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


ValueType Property

StaticPropertyWrapper.ValueType Property
[image]

Gets the type of value held in the slot.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As ITypeInfo _
Implements ISlotInfo.ValueType
C#
public ITypeInfo ValueType { get; }
C++
public property ITypeInfo ValueType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_ValueType();
JScript
public function get ValueType() : ITypeInfo

Implements

ISlotInfo.ValueType

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticPropertyWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetOverridenOrHiddenProperties | Gets the properties that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | Resolve | Resolves the wrapper to its native reflection target.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticPropertyWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (IPropertyInfo) |
Public method | Equals (ISlotInfo) |
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (IPropertyInfo)

StaticPropertyWrapper.Equals Method (IPropertyInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As IPropertyInfo _
) As Boolean _
Implements IEquatable<IPropertyInfo>.Equals
C#
public bool Equals(
IPropertyInfo other
)
C++
public:
bool Equals(
IPropertyInfo other
) sealed
J#
public bool Equals(
IPropertyInfo other
)
JScript
public function Equals(
other : IPropertyInfo
) : bool

Implements

IEquatable<IPropertyInfo>.Equals

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace
StaticPropertyWrapper.Equals Overload List


Equals Method (ISlotInfo)

StaticPropertyWrapper.Equals Method (ISlotInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ISlotInfo _
) As Boolean _
Implements IEquatable<ISlotInfo>.Equals
C#
public bool Equals(
ISlotInfo other
)
C++
public:
bool Equals(
ISlotInfo other
) sealed
J#
public bool Equals(
ISlotInfo other
)
JScript
public function Equals(
other : ISlotInfo
) : bool

Implements

IEquatable<ISlotInfo>.Equals

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace
StaticPropertyWrapper.Equals Overload List


GetOverridenOrHiddenProperties Method

StaticPropertyWrapper.GetOverridenOrHiddenProperties Method
[image]

Gets the properties that this one overrides or hides. Only includes overrides that appear on class types, not interfaces.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOverridenOrHiddenProperties( _
ByVal overridesOnly As Boolean _
) As IEnumerable(Of StaticPropertyWrapper)
C#
public IEnumerable<StaticPropertyWrapper> GetOverridenOrHiddenProperties(
bool overridesOnly
)
C++
public:
IEnumerable<StaticPropertyWrapper> GetOverridenOrHiddenProperties(
bool overridesOnly
) sealed
J#
public IEnumerable<StaticPropertyWrapper> GetOverridenOrHiddenProperties(
bool overridesOnly
)
JScript
public function GetOverridenOrHiddenProperties(
overridesOnly : bool
) : IEnumerable<StaticPropertyWrapper>

Parameters

overridesOnly
If true, only returns overrides

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticPropertyWrapper.Resolve Method
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As PropertyInfo _
Implements IPropertyInfo.Resolve
C#
public PropertyInfo Resolve(
bool throwOnError
)
C++
public:
PropertyInfo Resolve(
bool throwOnError
) sealed
J#
public PropertyInfo Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : PropertyInfo

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IPropertyInfo.Resolve

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


ToString Method

StaticPropertyWrapper.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

StaticPropertyWrapper Class
Gallio.Reflection.Impl Namespace


StaticReflectedMemberWrapper Class

StaticReflectedMemberWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy member wrapper for members that are not types, generic parameters or nested types. These members must be declared by types, so they all share the constraint that the declaring type and reflected type must not be null. In particular, the reflected type may be a subtype of the declaring type in the case of inherited members. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticReflectedMemberWrapper
Inherits StaticMemberWrapper
C#
public abstract class StaticReflectedMemberWrapper : StaticMemberWrapper
C++
ref class StaticReflectedMemberWrapper abstract : StaticMemberWrapper
J#
public class StaticReflectedMemberWrapper extends StaticMemberWrapper
JScript
public class StaticReflectedMemberWrapper extends StaticMemberWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticEventWrapper
Gallio.Reflection.Impl.StaticFieldWrapper
Gallio.Reflection.Impl.StaticFunctionWrapper
Gallio.Reflection.Impl.StaticPropertyWrapper

See Also

StaticReflectedMemberWrapper Members
Gallio.Reflection.Impl Namespace


StaticReflectedMemberWrapper Members

StaticReflectedMemberWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy member wrapper for members that are not types, generic parameters or nested types. These members must be declared by types, so they all share the constraint that the declaring type and reflected type must not be null. In particular, the reflected type may be a subtype of the declaring type in the case of inherited members. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticReflectedMemberWrapper.

Protected Constructors

 | Name | Description
Family method | StaticReflectedMemberWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | (inherited from StaticCodeElementWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Overridden. Gets the reflected type, or null if none.
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticMemberWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticCodeElementWrapper)
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve (inherited from StaticMemberWrapper)
Top

See Also

StaticReflectedMemberWrapper Class
Gallio.Reflection.Impl Namespace


StaticReflectedMemberWrapper Constructor

StaticReflectedMemberWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
)
C#
protected StaticReflectedMemberWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
C++
protected:
StaticReflectedMemberWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
) sealed
J#
protected StaticReflectedMemberWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType,
StaticDeclaredTypeWrapper reflectedType
)
JScript
protected function StaticReflectedMemberWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type
reflectedType
The reflected type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy, handle, declaringType, or reflectedType is null

See Also

StaticReflectedMemberWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticReflectedMemberWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | CodeReference | (inherited from StaticMemberWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Kind | (inherited from StaticCodeElementWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Overridden. Gets the reflected type, or null if none.
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Top

See Also

StaticReflectedMemberWrapper Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

StaticReflectedMemberWrapper.ReflectedType Property
[image]

Gets the reflected type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As StaticDeclaredTypeWrapper
C#
public override StaticDeclaredTypeWrapper ReflectedType { get; }
C++
public override property StaticDeclaredTypeWrapper ReflectedType override {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_ReflectedType();
JScript
public function get ReflectedType() : StaticDeclaredTypeWrapper

See Also

StaticReflectedMemberWrapper Class
Gallio.Reflection.Impl Namespace


StaticReflectionPolicy Class

StaticReflectionPolicy Class
See Also Example Members
[image]

The static reflection policy base class is intended to assist with the implementation of custom reflection policies defined over static metadata.

It flattens out the code element hierarchy to ease implementation of new policies. It provides a mechanism for handling generic type substitutions to ensure a consistent and correct implementation of generic type and generic method instantiations.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticReflectionPolicy
Inherits BaseReflectionPolicy
C#
public abstract class StaticReflectionPolicy : BaseReflectionPolicy
C++
ref class StaticReflectionPolicy abstract : BaseReflectionPolicy
J#
public class StaticReflectionPolicy extends BaseReflectionPolicy
JScript
public class StaticReflectionPolicy extends BaseReflectionPolicy

Remarks

Reflection policy subclasses should not perform generic type substitutions themselves. The rest of the infrastructure will take care of these details automatically. However StaticDeclaredTypeWrapper and StaticMethodWrapper objects should be created with the type substitutions of the declaring type extended with generic type arguments.

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.BaseReflectionPolicy
Gallio.Reflection.Impl.StaticReflectionPolicy

See Also

StaticReflectionPolicy Members
Gallio.Reflection.Impl Namespace


StaticReflectionPolicy Members

StaticReflectionPolicy Members
See Also Example Constructors Methods
[image]

The static reflection policy base class is intended to assist with the implementation of custom reflection policies defined over static metadata.

It flattens out the code element hierarchy to ease implementation of new policies. It provides a mechanism for handling generic type substitutions to ensure a consistent and correct implementation of generic type and generic method instantiations.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticReflectionPolicy.

Protected Constructors

 | Name | Description
Family method | StaticReflectionPolicy | Initializes a new instance of the StaticReflectionPolicy class.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadAssembly | Loads an assembly by name. (inherited from BaseReflectionPolicy)
Public method | LoadAssemblyFrom | Loads an assembly from a file. (inherited from BaseReflectionPolicy)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Equals | Overloaded. Determines whether two Object instances are equal.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAssemblyCustomAttributes | Gets the custom attributes of an assembly.
Family method | GetAssemblyExportedTypes | Gets the public types exported by an assembly.
Family method | GetAssemblyName | Gets the name of an assembly.
Family method | GetAssemblyPath | Gets the path of an assembly.
Family method | GetAssemblyReferences | Gets the references of an assembly.
Family method | GetAssemblyType | Gets the specified named type within an assembly.
Family method | GetAssemblyTypes | Gets all types contained in an assembly.
Family method | GetAttributeConstructor | Gets the constructor of an attribute.
Family method | GetAttributeConstructorArguments | Gets the constructor arguments of an attribute.
Family method | GetAttributeFieldArguments | Gets the field arguments of an attribute.
Family method | GetAttributePropertyArguments | Gets the property arguments of an attribute.
Family method | GetEventAddMethod | Gets the add method of an event, or null if none.
Family method | GetEventAttributes | Gets the attributes of an event.
Family method | GetEventHandlerType | Gets the event handler type of an event.
Family method | GetEventRaiseMethod | Gets the raise method of an event, or null if none.
Family method | GetEventRemoveMethod | Gets the remove method of an event, or null if none.
Family method | GetFieldAttributes | Gets the attributes of a field.
Family method | GetFieldType | Gets the field type.
Family method | GetFunctionAttributes | Gets the attributes of a function.
Family method | GetFunctionCallingConvention | Gets the calling conventions of a function.
Family method | GetFunctionParameters | Gets the parameters of a function.
Family method | GetGenericParameterAttributes | Gets the attributes of a generic parameter.
Family method | GetGenericParameterConstraints | Gets the generic parameter constraints.
Family method | GetGenericParameterPosition | Gets the generic parameter position.
Family method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Family method | GetMemberCustomAttributes | Gets the custom attributes of a member.
Family method | GetMemberName | Gets the short name of a member. In the case of a generic type, should exclude the generic parameter count part of the name. eg. "`1"
Family method | GetMemberSourceLocation | Gets the source code location of a member.
Family method | GetMethodGenericParameters | Gets the generic parameters of a method.
Family method | GetMethodReturnParameter | Gets the return parameter of a method.
Family method | GetParameterAttributes | Gets the attributes of a parameter.
Family method | GetParameterCustomAttributes | Gets the custom attributes of a parameter.
Family method | GetParameterName | Gets the name of a parameter.
Family method | GetParameterPosition | Gets the parameter's position, or -1 if the parameter is a return value.
Family method | GetParameterType | Gets the parameter type.
Family method | GetPropertyAttributes | Gets the attributes of a property.
Family method | GetPropertyGetMethod | Gets the get method of a property, or null if none.
Family method | GetPropertySetMethod | Gets the set method of a property, or null if none.
Family method | GetPropertyType | Gets the property type.
Family method | GetTypeAssembly | Gets the assembly that contains a type.
Family method | GetTypeAttributes | Gets the attributes of a type.
Family method | GetTypeBaseType | Gets the base type of atype.
Family method | GetTypeConstructors | Gets the constructors of a type. Only includes declared methods, not inherited ones.
Family method | GetTypeEvents | Gets the events of a type. Only includes declared methods, not inherited ones.
Family method | GetTypeFields | Gets the fields of a type. Only includes declared methods, not inherited ones.
Family method | GetTypeGenericParameters | Gets the generic parameters of a type, including all generic parameters of its declaring types if it is nested enumerated from outside in.
Family method | GetTypeInterfaces | Gets the interfaces directly implemented by a type.
Family method | GetTypeMethods | Gets the methods of a type including accessor methods for properties and events. Only includes declared methods, not inherited ones.
Family method | GetTypeNamespace | Gets the namespace that contains a type.
Family method | GetTypeNestedTypes | Gets the nested types of a type. Only includes declared nested types, not inherited ones.
Family method | GetTypeProperties | Gets the properties of a type. Only includes declared methods, not inherited ones.
Family method | LoadAssemblyFromImpl | Loads an assembly from a file. (inherited from BaseReflectionPolicy)
Family method | LoadAssemblyImpl | Loads an assembly. (inherited from BaseReflectionPolicy)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


StaticReflectionPolicy Constructor

StaticReflectionPolicy Constructor
[image]

Initializes a new instance of the StaticReflectionPolicy class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected StaticReflectionPolicy()
C++
protected:
StaticReflectionPolicy() sealed
J#
protected StaticReflectionPolicy()
JScript
protected function StaticReflectionPolicy()

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


Methods

StaticReflectionPolicy Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadAssembly | Loads an assembly by name. (inherited from BaseReflectionPolicy)
Public method | LoadAssemblyFrom | Loads an assembly from a file. (inherited from BaseReflectionPolicy)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Equals | Overloaded. Determines whether two Object instances are equal.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAssemblyCustomAttributes | Gets the custom attributes of an assembly.
Family method | GetAssemblyExportedTypes | Gets the public types exported by an assembly.
Family method | GetAssemblyName | Gets the name of an assembly.
Family method | GetAssemblyPath | Gets the path of an assembly.
Family method | GetAssemblyReferences | Gets the references of an assembly.
Family method | GetAssemblyType | Gets the specified named type within an assembly.
Family method | GetAssemblyTypes | Gets all types contained in an assembly.
Family method | GetAttributeConstructor | Gets the constructor of an attribute.
Family method | GetAttributeConstructorArguments | Gets the constructor arguments of an attribute.
Family method | GetAttributeFieldArguments | Gets the field arguments of an attribute.
Family method | GetAttributePropertyArguments | Gets the property arguments of an attribute.
Family method | GetEventAddMethod | Gets the add method of an event, or null if none.
Family method | GetEventAttributes | Gets the attributes of an event.
Family method | GetEventHandlerType | Gets the event handler type of an event.
Family method | GetEventRaiseMethod | Gets the raise method of an event, or null if none.
Family method | GetEventRemoveMethod | Gets the remove method of an event, or null if none.
Family method | GetFieldAttributes | Gets the attributes of a field.
Family method | GetFieldType | Gets the field type.
Family method | GetFunctionAttributes | Gets the attributes of a function.
Family method | GetFunctionCallingConvention | Gets the calling conventions of a function.
Family method | GetFunctionParameters | Gets the parameters of a function.
Family method | GetGenericParameterAttributes | Gets the attributes of a generic parameter.
Family method | GetGenericParameterConstraints | Gets the generic parameter constraints.
Family method | GetGenericParameterPosition | Gets the generic parameter position.
Family method | GetHashCode | Overloaded. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Family method | GetMemberCustomAttributes | Gets the custom attributes of a member.
Family method | GetMemberName | Gets the short name of a member. In the case of a generic type, should exclude the generic parameter count part of the name. eg. "`1"
Family method | GetMemberSourceLocation | Gets the source code location of a member.
Family method | GetMethodGenericParameters | Gets the generic parameters of a method.
Family method | GetMethodReturnParameter | Gets the return parameter of a method.
Family method | GetParameterAttributes | Gets the attributes of a parameter.
Family method | GetParameterCustomAttributes | Gets the custom attributes of a parameter.
Family method | GetParameterName | Gets the name of a parameter.
Family method | GetParameterPosition | Gets the parameter's position, or -1 if the parameter is a return value.
Family method | GetParameterType | Gets the parameter type.
Family method | GetPropertyAttributes | Gets the attributes of a property.
Family method | GetPropertyGetMethod | Gets the get method of a property, or null if none.
Family method | GetPropertySetMethod | Gets the set method of a property, or null if none.
Family method | GetPropertyType | Gets the property type.
Family method | GetTypeAssembly | Gets the assembly that contains a type.
Family method | GetTypeAttributes | Gets the attributes of a type.
Family method | GetTypeBaseType | Gets the base type of atype.
Family method | GetTypeConstructors | Gets the constructors of a type. Only includes declared methods, not inherited ones.
Family method | GetTypeEvents | Gets the events of a type. Only includes declared methods, not inherited ones.
Family method | GetTypeFields | Gets the fields of a type. Only includes declared methods, not inherited ones.
Family method | GetTypeGenericParameters | Gets the generic parameters of a type, including all generic parameters of its declaring types if it is nested enumerated from outside in.
Family method | GetTypeInterfaces | Gets the interfaces directly implemented by a type.
Family method | GetTypeMethods | Gets the methods of a type including accessor methods for properties and events. Only includes declared methods, not inherited ones.
Family method | GetTypeNamespace | Gets the namespace that contains a type.
Family method | GetTypeNestedTypes | Gets the nested types of a type. Only includes declared nested types, not inherited ones.
Family method | GetTypeProperties | Gets the properties of a type. Only includes declared methods, not inherited ones.
Family method | LoadAssemblyFromImpl | Loads an assembly from a file. (inherited from BaseReflectionPolicy)
Family method | LoadAssemblyImpl | Loads an assembly. (inherited from BaseReflectionPolicy)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticReflectionPolicy.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Family method | Equals (StaticWrapper, StaticWrapper) | Determines if two wrappers represent the same object.
Public method | Equals (Object) | Determines whether the specified Object is equal to the current Object. (inherited from Object)

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


Equals Method (StaticWrapper, StaticWrapper)

StaticReflectionPolicy.Equals Method (StaticWrapper, StaticWrapper)
See Also Example
[image]

Determines if two wrappers represent the same object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function Equals( _
ByVal a As StaticWrapper, _
ByVal b As StaticWrapper _
) As Boolean
C#
protected virtual bool Equals(
StaticWrapper a,
StaticWrapper b
)
C++
protected:
virtual bool Equals(
StaticWrapper a,
StaticWrapper b
)
J#
protected virtual bool Equals(
StaticWrapper a,
StaticWrapper b
)
JScript
protected virtual function Equals(
a : StaticWrapper,
b : StaticWrapper
) : bool

Parameters

a
The first wrapper, not null
b
The second wrapper, not null

Return Value

True if both wrapper represent the same object

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace
StaticReflectionPolicy.Equals Overload List


GetAssemblyCustomAttributes Method

StaticReflectionPolicy.GetAssemblyCustomAttributes Method
[image]

Gets the custom attributes of an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyCustomAttributes( _
ByVal assembly As StaticAssemblyWrapper _
) As IEnumerable(Of StaticAttributeWrapper)
C#
protected abstract IEnumerable<StaticAttributeWrapper> GetAssemblyCustomAttributes(
StaticAssemblyWrapper assembly
)
C++
protected:
IEnumerable<StaticAttributeWrapper> GetAssemblyCustomAttributes(
StaticAssemblyWrapper assembly
) abstract
J#
protected abstract IEnumerable<StaticAttributeWrapper> GetAssemblyCustomAttributes(
StaticAssemblyWrapper assembly
)
JScript
protected abstract function GetAssemblyCustomAttributes(
assembly : StaticAssemblyWrapper
) : IEnumerable<StaticAttributeWrapper>

Parameters

assembly
The assembly, not null

Return Value

The attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAssemblyExportedTypes Method

StaticReflectionPolicy.GetAssemblyExportedTypes Method
[image]

Gets the public types exported by an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyExportedTypes( _
ByVal assembly As StaticAssemblyWrapper _
) As IList(Of StaticDeclaredTypeWrapper)
C#
protected abstract IList<StaticDeclaredTypeWrapper> GetAssemblyExportedTypes(
StaticAssemblyWrapper assembly
)
C++
protected:
IList<StaticDeclaredTypeWrapper> GetAssemblyExportedTypes(
StaticAssemblyWrapper assembly
) abstract
J#
protected abstract IList<StaticDeclaredTypeWrapper> GetAssemblyExportedTypes(
StaticAssemblyWrapper assembly
)
JScript
protected abstract function GetAssemblyExportedTypes(
assembly : StaticAssemblyWrapper
) : IList<StaticDeclaredTypeWrapper>

Parameters

assembly
The assembly wrapper, not null

Return Value

The types

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAssemblyName Method

StaticReflectionPolicy.GetAssemblyName Method
[image]

Gets the name of an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyName( _
ByVal assembly As StaticAssemblyWrapper _
) As AssemblyName
C#
protected abstract AssemblyName GetAssemblyName(
StaticAssemblyWrapper assembly
)
C++
protected:
AssemblyName GetAssemblyName(
StaticAssemblyWrapper assembly
) abstract
J#
protected abstract AssemblyName GetAssemblyName(
StaticAssemblyWrapper assembly
)
JScript
protected abstract function GetAssemblyName(
assembly : StaticAssemblyWrapper
) : AssemblyName

Parameters

assembly
The assembly wrapper, not null

Return Value

The assembly name

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAssemblyPath Method

StaticReflectionPolicy.GetAssemblyPath Method
[image]

Gets the path of an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyPath( _
ByVal assembly As StaticAssemblyWrapper _
) As String
C#
protected abstract string GetAssemblyPath(
StaticAssemblyWrapper assembly
)
C++
protected:
String GetAssemblyPath(
StaticAssemblyWrapper assembly
) abstract
J#
protected abstract string GetAssemblyPath(
StaticAssemblyWrapper assembly
)
JScript
protected abstract function GetAssemblyPath(
assembly : StaticAssemblyWrapper
) : String

Parameters

assembly
The assembly wrapper, not null

Return Value

The assembly path

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAssemblyReferences Method

StaticReflectionPolicy.GetAssemblyReferences Method
[image]

Gets the references of an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyReferences( _
ByVal assembly As StaticAssemblyWrapper _
) As IList(Of AssemblyName)
C#
protected abstract IList<AssemblyName> GetAssemblyReferences(
StaticAssemblyWrapper assembly
)
C++
protected:
IList<AssemblyName> GetAssemblyReferences(
StaticAssemblyWrapper assembly
) abstract
J#
protected abstract IList<AssemblyName> GetAssemblyReferences(
StaticAssemblyWrapper assembly
)
JScript
protected abstract function GetAssemblyReferences(
assembly : StaticAssemblyWrapper
) : IList<AssemblyName>

Parameters

assembly
The assembly wrapper, not null

Return Value

The assembly references

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAssemblyType Method

StaticReflectionPolicy.GetAssemblyType Method
[image]

Gets the specified named type within an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyType( _
ByVal assembly As StaticAssemblyWrapper, _
ByVal typeName As String _
) As StaticDeclaredTypeWrapper
C#
protected abstract StaticDeclaredTypeWrapper GetAssemblyType(
StaticAssemblyWrapper assembly,
string typeName
)
C++
protected:
StaticDeclaredTypeWrapper GetAssemblyType(
StaticAssemblyWrapper assembly,
String typeName
) abstract
J#
protected abstract StaticDeclaredTypeWrapper GetAssemblyType(
StaticAssemblyWrapper assembly,
string typeName
)
JScript
protected abstract function GetAssemblyType(
assembly : StaticAssemblyWrapper,
typeName : String
) : StaticDeclaredTypeWrapper

Parameters

assembly
The assembly wrapper, not null
typeName
The type name, not null

Return Value

The type, or null if none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAssemblyTypes Method

StaticReflectionPolicy.GetAssemblyTypes Method
[image]

Gets all types contained in an assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAssemblyTypes( _
ByVal assembly As StaticAssemblyWrapper _
) As IList(Of StaticDeclaredTypeWrapper)
C#
protected abstract IList<StaticDeclaredTypeWrapper> GetAssemblyTypes(
StaticAssemblyWrapper assembly
)
C++
protected:
IList<StaticDeclaredTypeWrapper> GetAssemblyTypes(
StaticAssemblyWrapper assembly
) abstract
J#
protected abstract IList<StaticDeclaredTypeWrapper> GetAssemblyTypes(
StaticAssemblyWrapper assembly
)
JScript
protected abstract function GetAssemblyTypes(
assembly : StaticAssemblyWrapper
) : IList<StaticDeclaredTypeWrapper>

Parameters

assembly
The assembly wrapper, not null

Return Value

The types

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAttributeConstructor Method

StaticReflectionPolicy.GetAttributeConstructor Method
[image]

Gets the constructor of an attribute.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAttributeConstructor( _
ByVal attribute As StaticAttributeWrapper _
) As StaticConstructorWrapper
C#
protected abstract StaticConstructorWrapper GetAttributeConstructor(
StaticAttributeWrapper attribute
)
C++
protected:
StaticConstructorWrapper GetAttributeConstructor(
StaticAttributeWrapper attribute
) abstract
J#
protected abstract StaticConstructorWrapper GetAttributeConstructor(
StaticAttributeWrapper attribute
)
JScript
protected abstract function GetAttributeConstructor(
attribute : StaticAttributeWrapper
) : StaticConstructorWrapper

Parameters

attribute
The attribute, not null

Return Value

The constructor

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAttributeConstructorArguments Method

StaticReflectionPolicy.GetAttributeConstructorArguments Method
See Also Example
[image]

Gets the constructor arguments of an attribute.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAttributeConstructorArguments( _
ByVal attribute As StaticAttributeWrapper _
) As ConstantValue()
C#
protected abstract ConstantValue[] GetAttributeConstructorArguments(
StaticAttributeWrapper attribute
)
C++
protected:
array<ConstantValue>^ GetAttributeConstructorArguments(
StaticAttributeWrapper attribute
) abstract
J#
protected abstract ConstantValue[] GetAttributeConstructorArguments(
StaticAttributeWrapper attribute
)
JScript
protected abstract function GetAttributeConstructorArguments(
attribute : StaticAttributeWrapper
) : ConstantValue[]

Parameters

attribute
The attribute, not null

Return Value

The constructor argument values

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAttributeFieldArguments Method

StaticReflectionPolicy.GetAttributeFieldArguments Method
[image]

Gets the field arguments of an attribute.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAttributeFieldArguments( _
ByVal attribute As StaticAttributeWrapper _
) As IEnumerable(Of KeyValuePair(Of StaticFieldWrapper, ConstantValue))
C#
protected abstract IEnumerable<KeyValuePair<StaticFieldWrapper, ConstantValue>> GetAttributeFieldArguments(
StaticAttributeWrapper attribute
)
C++
protected:
IEnumerable<KeyValuePair<StaticFieldWrapper, ConstantValue>> GetAttributeFieldArguments(
StaticAttributeWrapper attribute
) abstract
J#
protected abstract IEnumerable<KeyValuePair<StaticFieldWrapper, ConstantValue>> GetAttributeFieldArguments(
StaticAttributeWrapper attribute
)
JScript
protected abstract function GetAttributeFieldArguments(
attribute : StaticAttributeWrapper
) : IEnumerable<KeyValuePair<StaticFieldWrapper, ConstantValue>>

Parameters

attribute
The attribute, not null

Return Value

The field argument values

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetAttributePropertyArguments Method

StaticReflectionPolicy.GetAttributePropertyArguments Method
[image]

Gets the property arguments of an attribute.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetAttributePropertyArguments( _
ByVal attribute As StaticAttributeWrapper _
) As IEnumerable(Of KeyValuePair(Of StaticPropertyWrapper, ConstantValue))
C#
protected abstract IEnumerable<KeyValuePair<StaticPropertyWrapper, ConstantValue>> GetAttributePropertyArguments(
StaticAttributeWrapper attribute
)
C++
protected:
IEnumerable<KeyValuePair<StaticPropertyWrapper, ConstantValue>> GetAttributePropertyArguments(
StaticAttributeWrapper attribute
) abstract
J#
protected abstract IEnumerable<KeyValuePair<StaticPropertyWrapper, ConstantValue>> GetAttributePropertyArguments(
StaticAttributeWrapper attribute
)
JScript
protected abstract function GetAttributePropertyArguments(
attribute : StaticAttributeWrapper
) : IEnumerable<KeyValuePair<StaticPropertyWrapper, ConstantValue>>

Parameters

attribute
The attribute, not null

Return Value

The property argument values

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetEventAddMethod Method

StaticReflectionPolicy.GetEventAddMethod Method
[image]

Gets the add method of an event, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetEventAddMethod( _
ByVal event As StaticEventWrapper _
) As StaticMethodWrapper
C#
protected abstract StaticMethodWrapper GetEventAddMethod(
StaticEventWrapper event
)
C++
protected:
StaticMethodWrapper GetEventAddMethod(
StaticEventWrapper event
) abstract
J#
protected abstract StaticMethodWrapper GetEventAddMethod(
StaticEventWrapper event
)
JScript
protected abstract function GetEventAddMethod(
event : StaticEventWrapper
) : StaticMethodWrapper

Parameters

event
The event, not null

Return Value

The add method, or null if none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetEventAttributes Method

StaticReflectionPolicy.GetEventAttributes Method
[image]

Gets the attributes of an event.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetEventAttributes( _
ByVal event As StaticEventWrapper _
) As EventAttributes
C#
protected abstract EventAttributes GetEventAttributes(
StaticEventWrapper event
)
C++
protected:
EventAttributes GetEventAttributes(
StaticEventWrapper event
) abstract
J#
protected abstract EventAttributes GetEventAttributes(
StaticEventWrapper event
)
JScript
protected abstract function GetEventAttributes(
event : StaticEventWrapper
) : EventAttributes

Parameters

event
The event, not null

Return Value

The event attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetEventHandlerType Method

StaticReflectionPolicy.GetEventHandlerType Method
[image]

Gets the event handler type of an event.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetEventHandlerType( _
ByVal event As StaticEventWrapper _
) As StaticTypeWrapper
C#
protected abstract StaticTypeWrapper GetEventHandlerType(
StaticEventWrapper event
)
C++
protected:
StaticTypeWrapper GetEventHandlerType(
StaticEventWrapper event
) abstract
J#
protected abstract StaticTypeWrapper GetEventHandlerType(
StaticEventWrapper event
)
JScript
protected abstract function GetEventHandlerType(
event : StaticEventWrapper
) : StaticTypeWrapper

Parameters

event
The event, not null

Return Value

The event handler type

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetEventRaiseMethod Method

StaticReflectionPolicy.GetEventRaiseMethod Method
[image]

Gets the raise method of an event, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetEventRaiseMethod( _
ByVal event As StaticEventWrapper _
) As StaticMethodWrapper
C#
protected abstract StaticMethodWrapper GetEventRaiseMethod(
StaticEventWrapper event
)
C++
protected:
StaticMethodWrapper GetEventRaiseMethod(
StaticEventWrapper event
) abstract
J#
protected abstract StaticMethodWrapper GetEventRaiseMethod(
StaticEventWrapper event
)
JScript
protected abstract function GetEventRaiseMethod(
event : StaticEventWrapper
) : StaticMethodWrapper

Parameters

event
The event, not null

Return Value

The raise method, or null if none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetEventRemoveMethod Method

StaticReflectionPolicy.GetEventRemoveMethod Method
[image]

Gets the remove method of an event, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetEventRemoveMethod( _
ByVal event As StaticEventWrapper _
) As StaticMethodWrapper
C#
protected abstract StaticMethodWrapper GetEventRemoveMethod(
StaticEventWrapper event
)
C++
protected:
StaticMethodWrapper GetEventRemoveMethod(
StaticEventWrapper event
) abstract
J#
protected abstract StaticMethodWrapper GetEventRemoveMethod(
StaticEventWrapper event
)
JScript
protected abstract function GetEventRemoveMethod(
event : StaticEventWrapper
) : StaticMethodWrapper

Parameters

event
The event, not null

Return Value

The remove method, or null if none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetFieldAttributes Method

StaticReflectionPolicy.GetFieldAttributes Method
[image]

Gets the attributes of a field.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetFieldAttributes( _
ByVal field As StaticFieldWrapper _
) As FieldAttributes
C#
protected abstract FieldAttributes GetFieldAttributes(
StaticFieldWrapper field
)
C++
protected:
FieldAttributes GetFieldAttributes(
StaticFieldWrapper field
) abstract
J#
protected abstract FieldAttributes GetFieldAttributes(
StaticFieldWrapper field
)
JScript
protected abstract function GetFieldAttributes(
field : StaticFieldWrapper
) : FieldAttributes

Parameters

field
The field, not null

Return Value

The field attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetFieldType Method

StaticReflectionPolicy.GetFieldType Method
[image]

Gets the field type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetFieldType( _
ByVal field As StaticFieldWrapper _
) As StaticTypeWrapper
C#
protected abstract StaticTypeWrapper GetFieldType(
StaticFieldWrapper field
)
C++
protected:
StaticTypeWrapper GetFieldType(
StaticFieldWrapper field
) abstract
J#
protected abstract StaticTypeWrapper GetFieldType(
StaticFieldWrapper field
)
JScript
protected abstract function GetFieldType(
field : StaticFieldWrapper
) : StaticTypeWrapper

Parameters

field
The field, not null

Return Value

The field type

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetFunctionAttributes Method

StaticReflectionPolicy.GetFunctionAttributes Method
[image]

Gets the attributes of a function.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetFunctionAttributes( _
ByVal function As StaticFunctionWrapper _
) As MethodAttributes
C#
protected abstract MethodAttributes GetFunctionAttributes(
StaticFunctionWrapper function
)
C++
protected:
MethodAttributes GetFunctionAttributes(
StaticFunctionWrapper function
) abstract
J#
protected abstract MethodAttributes GetFunctionAttributes(
StaticFunctionWrapper function
)
JScript
protected abstract function GetFunctionAttributes(
function : StaticFunctionWrapper
) : MethodAttributes

Parameters

function
The function, not null

Return Value

The function attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetFunctionCallingConvention Method

StaticReflectionPolicy.GetFunctionCallingConvention Method
[image]

Gets the calling conventions of a function.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetFunctionCallingConvention( _
ByVal function As StaticFunctionWrapper _
) As CallingConventions
C#
protected abstract CallingConventions GetFunctionCallingConvention(
StaticFunctionWrapper function
)
C++
protected:
CallingConventions GetFunctionCallingConvention(
StaticFunctionWrapper function
) abstract
J#
protected abstract CallingConventions GetFunctionCallingConvention(
StaticFunctionWrapper function
)
JScript
protected abstract function GetFunctionCallingConvention(
function : StaticFunctionWrapper
) : CallingConventions

Parameters

function
The function, not null

Return Value

The function calling conventions

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetFunctionParameters Method

StaticReflectionPolicy.GetFunctionParameters Method
[image]

Gets the parameters of a function.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetFunctionParameters( _
ByVal function As StaticFunctionWrapper _
) As IList(Of StaticParameterWrapper)
C#
protected abstract IList<StaticParameterWrapper> GetFunctionParameters(
StaticFunctionWrapper function
)
C++
protected:
IList<StaticParameterWrapper> GetFunctionParameters(
StaticFunctionWrapper function
) abstract
J#
protected abstract IList<StaticParameterWrapper> GetFunctionParameters(
StaticFunctionWrapper function
)
JScript
protected abstract function GetFunctionParameters(
function : StaticFunctionWrapper
) : IList<StaticParameterWrapper>

Parameters

function
The function, not null

Return Value

The parameters

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetGenericParameterAttributes Method

StaticReflectionPolicy.GetGenericParameterAttributes Method
[image]

Gets the attributes of a generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetGenericParameterAttributes( _
ByVal genericParameter As StaticGenericParameterWrapper _
) As GenericParameterAttributes
C#
protected abstract GenericParameterAttributes GetGenericParameterAttributes(
StaticGenericParameterWrapper genericParameter
)
C++
protected:
GenericParameterAttributes GetGenericParameterAttributes(
StaticGenericParameterWrapper genericParameter
) abstract
J#
protected abstract GenericParameterAttributes GetGenericParameterAttributes(
StaticGenericParameterWrapper genericParameter
)
JScript
protected abstract function GetGenericParameterAttributes(
genericParameter : StaticGenericParameterWrapper
) : GenericParameterAttributes

Parameters

genericParameter
The generic parameter, not null

Return Value

The generic parameter attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetGenericParameterConstraints Method

StaticReflectionPolicy.GetGenericParameterConstraints Method
[image]

Gets the generic parameter constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetGenericParameterConstraints( _
ByVal genericParameter As StaticGenericParameterWrapper _
) As IList(Of StaticTypeWrapper)
C#
protected abstract IList<StaticTypeWrapper> GetGenericParameterConstraints(
StaticGenericParameterWrapper genericParameter
)
C++
protected:
IList<StaticTypeWrapper> GetGenericParameterConstraints(
StaticGenericParameterWrapper genericParameter
) abstract
J#
protected abstract IList<StaticTypeWrapper> GetGenericParameterConstraints(
StaticGenericParameterWrapper genericParameter
)
JScript
protected abstract function GetGenericParameterConstraints(
genericParameter : StaticGenericParameterWrapper
) : IList<StaticTypeWrapper>

Parameters

genericParameter
The generic parameter, not null

Return Value

The generic parameter constraints

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetGenericParameterPosition Method

StaticReflectionPolicy.GetGenericParameterPosition Method
[image]

Gets the generic parameter position.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetGenericParameterPosition( _
ByVal genericParameter As StaticGenericParameterWrapper _
) As Integer
C#
protected abstract int GetGenericParameterPosition(
StaticGenericParameterWrapper genericParameter
)
C++
protected:
int GetGenericParameterPosition(
StaticGenericParameterWrapper genericParameter
) abstract
J#
protected abstract int GetGenericParameterPosition(
StaticGenericParameterWrapper genericParameter
)
JScript
protected abstract function GetGenericParameterPosition(
genericParameter : StaticGenericParameterWrapper
) : int

Parameters

genericParameter
The generic parameter, not null

Return Value

The generic parameter position

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetHashCode Method

StaticReflectionPolicy.GetHashCode Method

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Overload List

 | Name | Description
Family method | GetHashCode (StaticWrapper) | Gets a hashcode for a wrapper.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetHashCode Method (StaticWrapper)

StaticReflectionPolicy.GetHashCode Method (StaticWrapper)
See Also Example
[image]

Gets a hashcode for a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetHashCode( _
ByVal wrapper As StaticWrapper _
) As Integer
C#
protected virtual int GetHashCode(
StaticWrapper wrapper
)
C++
protected:
virtual int GetHashCode(
StaticWrapper wrapper
)
J#
protected virtual int GetHashCode(
StaticWrapper wrapper
)
JScript
protected virtual function GetHashCode(
wrapper : StaticWrapper
) : int

Parameters

wrapper
The wrapper, not null

Return Value

The wrapper's hash code

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace
StaticReflectionPolicy.GetHashCode Overload List


GetMemberCustomAttributes Method

StaticReflectionPolicy.GetMemberCustomAttributes Method
[image]

Gets the custom attributes of a member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetMemberCustomAttributes( _
ByVal member As StaticMemberWrapper _
) As IEnumerable(Of StaticAttributeWrapper)
C#
protected abstract IEnumerable<StaticAttributeWrapper> GetMemberCustomAttributes(
StaticMemberWrapper member
)
C++
protected:
IEnumerable<StaticAttributeWrapper> GetMemberCustomAttributes(
StaticMemberWrapper member
) abstract
J#
protected abstract IEnumerable<StaticAttributeWrapper> GetMemberCustomAttributes(
StaticMemberWrapper member
)
JScript
protected abstract function GetMemberCustomAttributes(
member : StaticMemberWrapper
) : IEnumerable<StaticAttributeWrapper>

Parameters

member
The member, not null

Return Value

The custom attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetMemberName Method

StaticReflectionPolicy.GetMemberName Method
[image]

Gets the short name of a member. In the case of a generic type, should exclude the generic parameter count part of the name. eg. "`1"

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetMemberName( _
ByVal member As StaticMemberWrapper _
) As String
C#
protected abstract string GetMemberName(
StaticMemberWrapper member
)
C++
protected:
String GetMemberName(
StaticMemberWrapper member
) abstract
J#
protected abstract string GetMemberName(
StaticMemberWrapper member
)
JScript
protected abstract function GetMemberName(
member : StaticMemberWrapper
) : String

Parameters

member
The member, not null

Return Value

The member's name

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetMemberSourceLocation Method

StaticReflectionPolicy.GetMemberSourceLocation Method
[image]

Gets the source code location of a member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetMemberSourceLocation( _
ByVal member As StaticMemberWrapper _
) As CodeLocation
C#
protected abstract CodeLocation GetMemberSourceLocation(
StaticMemberWrapper member
)
C++
protected:
CodeLocation GetMemberSourceLocation(
StaticMemberWrapper member
) abstract
J#
protected abstract CodeLocation GetMemberSourceLocation(
StaticMemberWrapper member
)
JScript
protected abstract function GetMemberSourceLocation(
member : StaticMemberWrapper
) : CodeLocation

Parameters

member
The member, not null

Return Value

The source code location, or Unknown if not available

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetMethodGenericParameters Method

StaticReflectionPolicy.GetMethodGenericParameters Method
[image]

Gets the generic parameters of a method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetMethodGenericParameters( _
ByVal method As StaticMethodWrapper _
) As IList(Of StaticGenericParameterWrapper)
C#
protected abstract IList<StaticGenericParameterWrapper> GetMethodGenericParameters(
StaticMethodWrapper method
)
C++
protected:
IList<StaticGenericParameterWrapper> GetMethodGenericParameters(
StaticMethodWrapper method
) abstract
J#
protected abstract IList<StaticGenericParameterWrapper> GetMethodGenericParameters(
StaticMethodWrapper method
)
JScript
protected abstract function GetMethodGenericParameters(
method : StaticMethodWrapper
) : IList<StaticGenericParameterWrapper>

Parameters

method
The method, not null

Return Value

The generic parameters

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetMethodReturnParameter Method

StaticReflectionPolicy.GetMethodReturnParameter Method
[image]

Gets the return parameter of a method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetMethodReturnParameter( _
ByVal method As StaticMethodWrapper _
) As StaticParameterWrapper
C#
protected abstract StaticParameterWrapper GetMethodReturnParameter(
StaticMethodWrapper method
)
C++
protected:
StaticParameterWrapper GetMethodReturnParameter(
StaticMethodWrapper method
) abstract
J#
protected abstract StaticParameterWrapper GetMethodReturnParameter(
StaticMethodWrapper method
)
JScript
protected abstract function GetMethodReturnParameter(
method : StaticMethodWrapper
) : StaticParameterWrapper

Parameters

method
The method, not null

Return Value

The return parameter

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetParameterAttributes Method

StaticReflectionPolicy.GetParameterAttributes Method
[image]

Gets the attributes of a parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetParameterAttributes( _
ByVal parameter As StaticParameterWrapper _
) As ParameterAttributes
C#
protected abstract ParameterAttributes GetParameterAttributes(
StaticParameterWrapper parameter
)
C++
protected:
ParameterAttributes GetParameterAttributes(
StaticParameterWrapper parameter
) abstract
J#
protected abstract ParameterAttributes GetParameterAttributes(
StaticParameterWrapper parameter
)
JScript
protected abstract function GetParameterAttributes(
parameter : StaticParameterWrapper
) : ParameterAttributes

Parameters

parameter
The parameter, not null

Return Value

The parameter attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetParameterCustomAttributes Method

StaticReflectionPolicy.GetParameterCustomAttributes Method
[image]

Gets the custom attributes of a parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetParameterCustomAttributes( _
ByVal parameter As StaticParameterWrapper _
) As IEnumerable(Of StaticAttributeWrapper)
C#
protected abstract IEnumerable<StaticAttributeWrapper> GetParameterCustomAttributes(
StaticParameterWrapper parameter
)
C++
protected:
IEnumerable<StaticAttributeWrapper> GetParameterCustomAttributes(
StaticParameterWrapper parameter
) abstract
J#
protected abstract IEnumerable<StaticAttributeWrapper> GetParameterCustomAttributes(
StaticParameterWrapper parameter
)
JScript
protected abstract function GetParameterCustomAttributes(
parameter : StaticParameterWrapper
) : IEnumerable<StaticAttributeWrapper>

Parameters

parameter
The parameter, not null

Return Value

The custom attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetParameterName Method

StaticReflectionPolicy.GetParameterName Method
[image]

Gets the name of a parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetParameterName( _
ByVal parameter As StaticParameterWrapper _
) As String
C#
protected abstract string GetParameterName(
StaticParameterWrapper parameter
)
C++
protected:
String GetParameterName(
StaticParameterWrapper parameter
) abstract
J#
protected abstract string GetParameterName(
StaticParameterWrapper parameter
)
JScript
protected abstract function GetParameterName(
parameter : StaticParameterWrapper
) : String

Parameters

parameter
The parameter, not null

Return Value

The parameter's name

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetParameterPosition Method

StaticReflectionPolicy.GetParameterPosition Method
[image]

Gets the parameter's position, or -1 if the parameter is a return value.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetParameterPosition( _
ByVal parameter As StaticParameterWrapper _
) As Integer
C#
protected abstract int GetParameterPosition(
StaticParameterWrapper parameter
)
C++
protected:
int GetParameterPosition(
StaticParameterWrapper parameter
) abstract
J#
protected abstract int GetParameterPosition(
StaticParameterWrapper parameter
)
JScript
protected abstract function GetParameterPosition(
parameter : StaticParameterWrapper
) : int

Parameters

parameter
The parameter, not null

Return Value

The parameter's position

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetParameterType Method

StaticReflectionPolicy.GetParameterType Method
[image]

Gets the parameter type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetParameterType( _
ByVal parameter As StaticParameterWrapper _
) As StaticTypeWrapper
C#
protected abstract StaticTypeWrapper GetParameterType(
StaticParameterWrapper parameter
)
C++
protected:
StaticTypeWrapper GetParameterType(
StaticParameterWrapper parameter
) abstract
J#
protected abstract StaticTypeWrapper GetParameterType(
StaticParameterWrapper parameter
)
JScript
protected abstract function GetParameterType(
parameter : StaticParameterWrapper
) : StaticTypeWrapper

Parameters

parameter
The parameter, not null

Return Value

The parameter type

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetPropertyAttributes Method

StaticReflectionPolicy.GetPropertyAttributes Method
[image]

Gets the attributes of a property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPropertyAttributes( _
ByVal property As StaticPropertyWrapper _
) As PropertyAttributes
C#
protected abstract PropertyAttributes GetPropertyAttributes(
StaticPropertyWrapper property
)
C++
protected:
PropertyAttributes GetPropertyAttributes(
StaticPropertyWrapper property
) abstract
J#
protected abstract PropertyAttributes GetPropertyAttributes(
StaticPropertyWrapper property
)
JScript
protected abstract function GetPropertyAttributes(
property : StaticPropertyWrapper
) : PropertyAttributes

Parameters

property
The property, not null

Return Value

The property attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetPropertyGetMethod Method

StaticReflectionPolicy.GetPropertyGetMethod Method
[image]

Gets the get method of a property, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPropertyGetMethod( _
ByVal property As StaticPropertyWrapper _
) As StaticMethodWrapper
C#
protected abstract StaticMethodWrapper GetPropertyGetMethod(
StaticPropertyWrapper property
)
C++
protected:
StaticMethodWrapper GetPropertyGetMethod(
StaticPropertyWrapper property
) abstract
J#
protected abstract StaticMethodWrapper GetPropertyGetMethod(
StaticPropertyWrapper property
)
JScript
protected abstract function GetPropertyGetMethod(
property : StaticPropertyWrapper
) : StaticMethodWrapper

Parameters

property
The property, not null

Return Value

The get method, or null if none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetPropertySetMethod Method

StaticReflectionPolicy.GetPropertySetMethod Method
[image]

Gets the set method of a property, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPropertySetMethod( _
ByVal property As StaticPropertyWrapper _
) As StaticMethodWrapper
C#
protected abstract StaticMethodWrapper GetPropertySetMethod(
StaticPropertyWrapper property
)
C++
protected:
StaticMethodWrapper GetPropertySetMethod(
StaticPropertyWrapper property
) abstract
J#
protected abstract StaticMethodWrapper GetPropertySetMethod(
StaticPropertyWrapper property
)
JScript
protected abstract function GetPropertySetMethod(
property : StaticPropertyWrapper
) : StaticMethodWrapper

Parameters

property
The property, not null

Return Value

The set method, or null if none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetPropertyType Method

StaticReflectionPolicy.GetPropertyType Method
[image]

Gets the property type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPropertyType( _
ByVal property As StaticPropertyWrapper _
) As StaticTypeWrapper
C#
protected abstract StaticTypeWrapper GetPropertyType(
StaticPropertyWrapper property
)
C++
protected:
StaticTypeWrapper GetPropertyType(
StaticPropertyWrapper property
) abstract
J#
protected abstract StaticTypeWrapper GetPropertyType(
StaticPropertyWrapper property
)
JScript
protected abstract function GetPropertyType(
property : StaticPropertyWrapper
) : StaticTypeWrapper

Parameters

property
The property, not null

Return Value

The property type

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeAssembly Method

StaticReflectionPolicy.GetTypeAssembly Method
[image]

Gets the assembly that contains a type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeAssembly( _
ByVal type As StaticDeclaredTypeWrapper _
) As StaticAssemblyWrapper
C#
protected abstract StaticAssemblyWrapper GetTypeAssembly(
StaticDeclaredTypeWrapper type
)
C++
protected:
StaticAssemblyWrapper GetTypeAssembly(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract StaticAssemblyWrapper GetTypeAssembly(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeAssembly(
type : StaticDeclaredTypeWrapper
) : StaticAssemblyWrapper

Parameters

type
The type, not null

Return Value

The type's assembly

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeAttributes Method

StaticReflectionPolicy.GetTypeAttributes Method
[image]

Gets the attributes of a type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeAttributes( _
ByVal type As StaticDeclaredTypeWrapper _
) As TypeAttributes
C#
protected abstract TypeAttributes GetTypeAttributes(
StaticDeclaredTypeWrapper type
)
C++
protected:
TypeAttributes GetTypeAttributes(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract TypeAttributes GetTypeAttributes(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeAttributes(
type : StaticDeclaredTypeWrapper
) : TypeAttributes

Parameters

type
The type, not null

Return Value

The type attributes

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeBaseType Method

StaticReflectionPolicy.GetTypeBaseType Method
[image]

Gets the base type of atype.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeBaseType( _
ByVal type As StaticDeclaredTypeWrapper _
) As StaticDeclaredTypeWrapper
C#
protected abstract StaticDeclaredTypeWrapper GetTypeBaseType(
StaticDeclaredTypeWrapper type
)
C++
protected:
StaticDeclaredTypeWrapper GetTypeBaseType(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract StaticDeclaredTypeWrapper GetTypeBaseType(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeBaseType(
type : StaticDeclaredTypeWrapper
) : StaticDeclaredTypeWrapper

Parameters

type
The type, not null

Return Value

The base type

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeConstructors Method

StaticReflectionPolicy.GetTypeConstructors Method
[image]

Gets the constructors of a type. Only includes declared methods, not inherited ones.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeConstructors( _
ByVal type As StaticDeclaredTypeWrapper _
) As IEnumerable(Of StaticConstructorWrapper)
C#
protected abstract IEnumerable<StaticConstructorWrapper> GetTypeConstructors(
StaticDeclaredTypeWrapper type
)
C++
protected:
IEnumerable<StaticConstructorWrapper> GetTypeConstructors(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract IEnumerable<StaticConstructorWrapper> GetTypeConstructors(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeConstructors(
type : StaticDeclaredTypeWrapper
) : IEnumerable<StaticConstructorWrapper>

Parameters

type
The type, not null

Return Value

The type's constructors

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeEvents Method

StaticReflectionPolicy.GetTypeEvents Method
[image]

Gets the events of a type. Only includes declared methods, not inherited ones.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeEvents( _
ByVal type As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
) As IEnumerable(Of StaticEventWrapper)
C#
protected abstract IEnumerable<StaticEventWrapper> GetTypeEvents(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
C++
protected:
IEnumerable<StaticEventWrapper> GetTypeEvents(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
) abstract
J#
protected abstract IEnumerable<StaticEventWrapper> GetTypeEvents(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
JScript
protected abstract function GetTypeEvents(
type : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
) : IEnumerable<StaticEventWrapper>

Parameters

type
The type, not null
reflectedType
The reflected type, not null

Return Value

The type's events

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeFields Method

StaticReflectionPolicy.GetTypeFields Method
[image]

Gets the fields of a type. Only includes declared methods, not inherited ones.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeFields( _
ByVal type As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
) As IEnumerable(Of StaticFieldWrapper)
C#
protected abstract IEnumerable<StaticFieldWrapper> GetTypeFields(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
C++
protected:
IEnumerable<StaticFieldWrapper> GetTypeFields(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
) abstract
J#
protected abstract IEnumerable<StaticFieldWrapper> GetTypeFields(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
JScript
protected abstract function GetTypeFields(
type : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
) : IEnumerable<StaticFieldWrapper>

Parameters

type
The type, not null
reflectedType
The reflected type, not null

Return Value

The type's fields

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeGenericParameters Method

StaticReflectionPolicy.GetTypeGenericParameters Method
[image]

Gets the generic parameters of a type, including all generic parameters of its declaring types if it is nested enumerated from outside in.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeGenericParameters( _
ByVal type As StaticDeclaredTypeWrapper _
) As IList(Of StaticGenericParameterWrapper)
C#
protected abstract IList<StaticGenericParameterWrapper> GetTypeGenericParameters(
StaticDeclaredTypeWrapper type
)
C++
protected:
IList<StaticGenericParameterWrapper> GetTypeGenericParameters(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract IList<StaticGenericParameterWrapper> GetTypeGenericParameters(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeGenericParameters(
type : StaticDeclaredTypeWrapper
) : IList<StaticGenericParameterWrapper>

Parameters

type
The type, not null

Return Value

The type's generic parameters

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeInterfaces Method

StaticReflectionPolicy.GetTypeInterfaces Method
[image]

Gets the interfaces directly implemented by a type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeInterfaces( _
ByVal type As StaticDeclaredTypeWrapper _
) As IList(Of StaticDeclaredTypeWrapper)
C#
protected abstract IList<StaticDeclaredTypeWrapper> GetTypeInterfaces(
StaticDeclaredTypeWrapper type
)
C++
protected:
IList<StaticDeclaredTypeWrapper> GetTypeInterfaces(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract IList<StaticDeclaredTypeWrapper> GetTypeInterfaces(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeInterfaces(
type : StaticDeclaredTypeWrapper
) : IList<StaticDeclaredTypeWrapper>

Parameters

type
The type, not null

Return Value

The type's interfaces

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeMethods Method

StaticReflectionPolicy.GetTypeMethods Method
[image]

Gets the methods of a type including accessor methods for properties and events. Only includes declared methods, not inherited ones.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeMethods( _
ByVal type As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
) As IEnumerable(Of StaticMethodWrapper)
C#
protected abstract IEnumerable<StaticMethodWrapper> GetTypeMethods(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
C++
protected:
IEnumerable<StaticMethodWrapper> GetTypeMethods(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
) abstract
J#
protected abstract IEnumerable<StaticMethodWrapper> GetTypeMethods(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
JScript
protected abstract function GetTypeMethods(
type : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
) : IEnumerable<StaticMethodWrapper>

Parameters

type
The type, not null
reflectedType
The reflected type, not null

Return Value

The type's methods

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeNamespace Method

StaticReflectionPolicy.GetTypeNamespace Method
[image]

Gets the namespace that contains a type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeNamespace( _
ByVal type As StaticDeclaredTypeWrapper _
) As String
C#
protected abstract string GetTypeNamespace(
StaticDeclaredTypeWrapper type
)
C++
protected:
String GetTypeNamespace(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract string GetTypeNamespace(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeNamespace(
type : StaticDeclaredTypeWrapper
) : String

Parameters

type
The type, not null

Return Value

The type's namespace, or an empty string if it has none

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeNestedTypes Method

StaticReflectionPolicy.GetTypeNestedTypes Method
[image]

Gets the nested types of a type. Only includes declared nested types, not inherited ones.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeNestedTypes( _
ByVal type As StaticDeclaredTypeWrapper _
) As IEnumerable(Of StaticTypeWrapper)
C#
protected abstract IEnumerable<StaticTypeWrapper> GetTypeNestedTypes(
StaticDeclaredTypeWrapper type
)
C++
protected:
IEnumerable<StaticTypeWrapper> GetTypeNestedTypes(
StaticDeclaredTypeWrapper type
) abstract
J#
protected abstract IEnumerable<StaticTypeWrapper> GetTypeNestedTypes(
StaticDeclaredTypeWrapper type
)
JScript
protected abstract function GetTypeNestedTypes(
type : StaticDeclaredTypeWrapper
) : IEnumerable<StaticTypeWrapper>

Parameters

type
The type, not null

Return Value

The type's nested types

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


GetTypeProperties Method

StaticReflectionPolicy.GetTypeProperties Method
[image]

Gets the properties of a type. Only includes declared methods, not inherited ones.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetTypeProperties( _
ByVal type As StaticDeclaredTypeWrapper, _
ByVal reflectedType As StaticDeclaredTypeWrapper _
) As IEnumerable(Of StaticPropertyWrapper)
C#
protected abstract IEnumerable<StaticPropertyWrapper> GetTypeProperties(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
C++
protected:
IEnumerable<StaticPropertyWrapper> GetTypeProperties(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
) abstract
J#
protected abstract IEnumerable<StaticPropertyWrapper> GetTypeProperties(
StaticDeclaredTypeWrapper type,
StaticDeclaredTypeWrapper reflectedType
)
JScript
protected abstract function GetTypeProperties(
type : StaticDeclaredTypeWrapper,
reflectedType : StaticDeclaredTypeWrapper
) : IEnumerable<StaticPropertyWrapper>

Parameters

type
The type, not null
reflectedType
The reflected type, not null

Return Value

The type's properties

See Also

StaticReflectionPolicy Class
Gallio.Reflection.Impl Namespace


StaticSpecialTypeWrapper Class

StaticSpecialTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy type wrapper that represents a special type that is either constructed from other types or derived from them as with a generic parameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticSpecialTypeWrapper
Inherits StaticTypeWrapper
C#
public abstract class StaticSpecialTypeWrapper : StaticTypeWrapper
C++
ref class StaticSpecialTypeWrapper abstract : StaticTypeWrapper
J#
public class StaticSpecialTypeWrapper extends StaticTypeWrapper
JScript
public class StaticSpecialTypeWrapper extends StaticTypeWrapper

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticConstructedTypeWrapper
Gallio.Reflection.Impl.StaticGenericParameterWrapper

See Also

StaticSpecialTypeWrapper Members
Gallio.Reflection.Impl Namespace
StaticConstructedTypeWrapper
StaticGenericParameterWrapper


StaticSpecialTypeWrapper Members

StaticSpecialTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy type wrapper that represents a special type that is either constructed from other types or derived from them as with a generic parameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticSpecialTypeWrapper.

Protected Constructors

 | Name | Description
Family method | StaticSpecialTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | (inherited from StaticTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | (inherited from StaticTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticTypeWrapper)
Public property | FullName | (inherited from StaticTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Overridden. Gets all of the type's interfaces.
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | (inherited from StaticTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Overridden. Gets the type substitution for generic parameters.
Public property | TypeAttributes | (inherited from StaticTypeWrapper)
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Protected Properties

 | Name | Description
Family property | BaseTypeInternal | Overridden. Internal implementation of BaseType.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticTypeWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors | Overridden. Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Overridden. Gets a event by name, or null if not found.
Public method | GetEvents | Overridden. Gets all events of the type that satisfy the binding flags.
Public method | GetField | Overridden. Gets a field by name, or null if not found.
Public method | GetFields | Overridden. Gets all fields of the type that satisfy the binding flags.
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Overridden. Gets a method by name, or null if not found.
Public method | GetMethods | Overridden. Gets all methods of the type that satisfy the binding flags.
Public method | GetNestedType | Overridden. Gets a nested type by name, or null if not found.
Public method | GetNestedTypes | Overridden. Gets all nested types of the type that satisfy the binding flags.
Public method | GetProperties | Overridden. Gets all properties of the type that satisfy the binding flags.
Public method | GetProperty | Overridden. Gets a property by name, or null if not found.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Applies a type substitution and returns the resulting type. (inherited from StaticTypeWrapper)
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticTypeWrapper)
Family method | GetPseudoCustomAttributes | Overridden. Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve (inherited from StaticTypeWrapper)
Top

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticConstructedTypeWrapper
StaticGenericParameterWrapper


StaticSpecialTypeWrapper Constructor

StaticSpecialTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper _
)
C#
protected StaticSpecialTypeWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
C++
protected:
StaticSpecialTypeWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType
) sealed
J#
protected StaticSpecialTypeWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
JScript
protected function StaticSpecialTypeWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticSpecialTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank | (inherited from StaticTypeWrapper)
Public property | Assembly | (inherited from StaticTypeWrapper)
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter. (inherited from StaticTypeWrapper)
Public property | BaseType | Gets the base type of the type, or null if none. (inherited from StaticTypeWrapper)
Public property | CodeReference | Gets a CodeReference for this code element. (inherited from StaticTypeWrapper)
Public property | ContainsGenericParameters | (inherited from StaticTypeWrapper)
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none. (inherited from StaticTypeWrapper)
Public property | FullName | (inherited from StaticTypeWrapper)
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots. (inherited from StaticTypeWrapper)
Public property | GenericTypeDefinition | (inherited from StaticTypeWrapper)
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces | Overridden. Gets all of the type's interfaces.
Public property | IsAbstract | Returns true if the type is abstract and must be overridden. (inherited from StaticTypeWrapper)
Public property | IsArray | (inherited from StaticTypeWrapper)
Public property | IsByRef | Returns true if the type represents a type that is passed by reference. (inherited from StaticTypeWrapper)
Public property | IsClass | Returns true if the type is a class. (inherited from StaticTypeWrapper)
Public property | IsEnum | Returns true if the type represents an enumeration. (inherited from StaticTypeWrapper)
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter. (inherited from StaticTypeWrapper)
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty. (inherited from StaticTypeWrapper)
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition. (inherited from StaticTypeWrapper)
Public property | IsInterface | Returns true if the type is an interface. (inherited from StaticTypeWrapper)
Public property | IsNested | Returns true if the type is nested. (inherited from StaticTypeWrapper)
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from StaticTypeWrapper)
Public property | IsNestedPrivate | Returns true if the type is nested and declared private. (inherited from StaticTypeWrapper)
Public property | IsNestedPublic | Returns true if the type is nested and declared public. (inherited from StaticTypeWrapper)
Public property | IsNotPublic | Returns true if the type is not declared public. (inherited from StaticTypeWrapper)
Public property | IsPointer | Returns true if the type represents a pointer. (inherited from StaticTypeWrapper)
Public property | IsPublic | Returns true if the type is declared public. (inherited from StaticTypeWrapper)
Public property | IsSealed | Returns true if the type is sealed. (inherited from StaticTypeWrapper)
Public property | IsValueType | Returns true if the type is a value type. (inherited from StaticTypeWrapper)
Public property | Kind | Gets the kind of code element represented by this instance. (inherited from StaticTypeWrapper)
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Namespace | Gets the namespace in which the type is declared. (inherited from StaticTypeWrapper)
Public property | NamespaceName | (inherited from StaticTypeWrapper)
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Overridden. Gets the type substitution for generic parameters.
Public property | TypeAttributes | (inherited from StaticTypeWrapper)
Public property | TypeCode | Gets the type's TypeCode. (inherited from StaticTypeWrapper)
Top

Protected Properties

 | Name | Description
Family property | BaseTypeInternal | Overridden. Internal implementation of BaseType.
Top

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticConstructedTypeWrapper
StaticGenericParameterWrapper


BaseTypeInternal Property

StaticSpecialTypeWrapper.BaseTypeInternal Property
[image]

Internal implementation of BaseType.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property BaseTypeInternal As ITypeInfo
C#
protected override ITypeInfo BaseTypeInternal { get; }
C++
protected override property ITypeInfo BaseTypeInternal override {
ITypeInfo get();
}
J#
/** property */
protected ITypeInfo get_BaseTypeInternal();
JScript
protected function get BaseTypeInternal() : ITypeInfo

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


Interfaces Property

StaticSpecialTypeWrapper.Interfaces Property
[image]

Gets all of the type's interfaces.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Interfaces As IList(Of ITypeInfo) _
Implements ITypeInfo.Interfaces
C#
public override IList<ITypeInfo> Interfaces { get; }
C++
public override property IList<ITypeInfo> Interfaces override {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_Interfaces();
JScript
public function get Interfaces() : IList<ITypeInfo>

Property Value

The type's interfaces

Implements

ITypeInfo.Interfaces

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


Substitution Property

StaticSpecialTypeWrapper.Substitution Property
[image]

Gets the type substitution for generic parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Substitution As StaticTypeSubstitution
C#
public override StaticTypeSubstitution Substitution { get; }
C++
public override property StaticTypeSubstitution Substitution override {
StaticTypeSubstitution get();
}
J#
/** property */
public StaticTypeSubstitution get_Substitution();
JScript
public function get Substitution() : StaticTypeSubstitution

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticSpecialTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from StaticTypeWrapper)
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors | Overridden. Gets all constructors of the type that satisfy the binding flags.
Public method | GetEvent | Overridden. Gets a event by name, or null if not found.
Public method | GetEvents | Overridden. Gets all events of the type that satisfy the binding flags.
Public method | GetField | Overridden. Gets a field by name, or null if not found.
Public method | GetFields | Overridden. Gets all fields of the type that satisfy the binding flags.
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod | Overridden. Gets a method by name, or null if not found.
Public method | GetMethods | Overridden. Gets all methods of the type that satisfy the binding flags.
Public method | GetNestedType | Overridden. Gets a nested type by name, or null if not found.
Public method | GetNestedTypes | Overridden. Gets all nested types of the type that satisfy the binding flags.
Public method | GetProperties | Overridden. Gets all properties of the type that satisfy the binding flags.
Public method | GetProperty | Overridden. Gets a property by name, or null if not found.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type. (inherited from StaticTypeWrapper)
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type. (inherited from StaticTypeWrapper)
Public method | MakeArrayType | (inherited from StaticTypeWrapper)
Public method | MakeByRefType | (inherited from StaticTypeWrapper)
Public method | MakeGenericType | (inherited from StaticTypeWrapper)
Public method | MakePointerType | (inherited from StaticTypeWrapper)
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target. (inherited from StaticTypeWrapper)
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Applies a type substitution and returns the resulting type. (inherited from StaticTypeWrapper)
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Gets an enumeration of elements from which this code element inherits. (inherited from StaticTypeWrapper)
Family method | GetPseudoCustomAttributes | Overridden. Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Implementation of Resolve (inherited from StaticTypeWrapper)
Top

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticConstructedTypeWrapper
StaticGenericParameterWrapper


GetConstructors Method

StaticSpecialTypeWrapper.GetConstructors Method
[image]

Gets all constructors of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetConstructors( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IConstructorInfo) _
Implements ITypeInfo.GetConstructors
C#
public override IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
) override
J#
public override IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
JScript
public override function GetConstructors(
bindingFlags : BindingFlags
) : IList<IConstructorInfo>

Parameters

bindingFlags
The binding flags

Return Value

The constructors

Implements

ITypeInfo.GetConstructors

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetEvent Method

StaticSpecialTypeWrapper.GetEvent Method
[image]

Gets a event by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEvent( _
ByVal eventName As String, _
ByVal bindingFlags As BindingFlags _
) As IEventInfo _
Implements ITypeInfo.GetEvent
C#
public override IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
C++
public:
virtual IEventInfo GetEvent(
String eventName,
BindingFlags bindingFlags
) override
J#
public override IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
JScript
public override function GetEvent(
eventName : String,
bindingFlags : BindingFlags
) : IEventInfo

Parameters

eventName
The event name
bindingFlags
The binding flags

Return Value

The event

Implements

ITypeInfo.GetEvent

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetEvents Method

StaticSpecialTypeWrapper.GetEvents Method
[image]

Gets all events of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEvents( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IEventInfo) _
Implements ITypeInfo.GetEvents
C#
public override IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
) override
J#
public override IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
JScript
public override function GetEvents(
bindingFlags : BindingFlags
) : IList<IEventInfo>

Parameters

bindingFlags
The binding flags

Return Value

The events

Implements

ITypeInfo.GetEvents

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetField Method

StaticSpecialTypeWrapper.GetField Method
[image]

Gets a field by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetField( _
ByVal fieldName As String, _
ByVal bindingFlags As BindingFlags _
) As IFieldInfo _
Implements ITypeInfo.GetField
C#
public override IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
C++
public:
virtual IFieldInfo GetField(
String fieldName,
BindingFlags bindingFlags
) override
J#
public override IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
JScript
public override function GetField(
fieldName : String,
bindingFlags : BindingFlags
) : IFieldInfo

Parameters

fieldName
The field name
bindingFlags
The binding flags

Return Value

The property

Implements

ITypeInfo.GetField

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetFields Method

StaticSpecialTypeWrapper.GetFields Method
[image]

Gets all fields of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFields( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IFieldInfo) _
Implements ITypeInfo.GetFields
C#
public override IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
) override
J#
public override IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
JScript
public override function GetFields(
bindingFlags : BindingFlags
) : IList<IFieldInfo>

Parameters

bindingFlags
The binding flags

Return Value

The fields

Implements

ITypeInfo.GetFields

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetMethod Method

StaticSpecialTypeWrapper.GetMethod Method
[image]

Gets a method by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethod( _
ByVal methodName As String, _
ByVal bindingFlags As BindingFlags _
) As IMethodInfo _
Implements ITypeInfo.GetMethod
C#
public override IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
C++
public:
virtual IMethodInfo GetMethod(
String methodName,
BindingFlags bindingFlags
) override
J#
public override IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
JScript
public override function GetMethod(
methodName : String,
bindingFlags : BindingFlags
) : IMethodInfo

Parameters

methodName
The method name
bindingFlags
The binding flags

Return Value

The method

Implements

ITypeInfo.GetMethod

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetMethods Method

StaticSpecialTypeWrapper.GetMethods Method
[image]

Gets all methods of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethods( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IMethodInfo) _
Implements ITypeInfo.GetMethods
C#
public override IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
) override
J#
public override IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
JScript
public override function GetMethods(
bindingFlags : BindingFlags
) : IList<IMethodInfo>

Parameters

bindingFlags
The binding flags

Return Value

The methods

Implements

ITypeInfo.GetMethods

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetNestedType Method

StaticSpecialTypeWrapper.GetNestedType Method
[image]

Gets a nested type by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetNestedType( _
ByVal nestedTypeName As String, _
ByVal bindingFlags As BindingFlags _
) As ITypeInfo _
Implements ITypeInfo.GetNestedType
C#
public override ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
C++
public:
virtual ITypeInfo GetNestedType(
String nestedTypeName,
BindingFlags bindingFlags
) override
J#
public override ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
JScript
public override function GetNestedType(
nestedTypeName : String,
bindingFlags : BindingFlags
) : ITypeInfo

Parameters

nestedTypeName
The nested type name
bindingFlags
The binding flags

Return Value

The nested type

Implements

ITypeInfo.GetNestedType

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetNestedTypes Method

StaticSpecialTypeWrapper.GetNestedTypes Method
[image]

Gets all nested types of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetNestedTypes( _
ByVal bindingFlags As BindingFlags _
) As IList(Of ITypeInfo) _
Implements ITypeInfo.GetNestedTypes
C#
public override IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
C++
public:
virtual IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
) override
J#
public override IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
JScript
public override function GetNestedTypes(
bindingFlags : BindingFlags
) : IList<ITypeInfo>

Parameters

bindingFlags
The binding flags

Return Value

The nested types

Implements

ITypeInfo.GetNestedTypes

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetProperties Method

StaticSpecialTypeWrapper.GetProperties Method
[image]

Gets all properties of the type that satisfy the binding flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperties( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IPropertyInfo) _
Implements ITypeInfo.GetProperties
C#
public override IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
C++
public:
virtual IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
) override
J#
public override IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
JScript
public override function GetProperties(
bindingFlags : BindingFlags
) : IList<IPropertyInfo>

Parameters

bindingFlags
The binding flags

Return Value

The properties

Implements

ITypeInfo.GetProperties

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetProperty Method

StaticSpecialTypeWrapper.GetProperty Method
[image]

Gets a property by name, or null if not found.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty( _
ByVal propertyName As String, _
ByVal bindingFlags As BindingFlags _
) As IPropertyInfo _
Implements ITypeInfo.GetProperty
C#
public override IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
C++
public:
virtual IPropertyInfo GetProperty(
String propertyName,
BindingFlags bindingFlags
) override
J#
public override IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
JScript
public override function GetProperty(
propertyName : String,
bindingFlags : BindingFlags
) : IPropertyInfo

Parameters

propertyName
The property name
bindingFlags
The binding flags

Return Value

The property

Implements

ITypeInfo.GetProperty

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetPseudoCustomAttributes Method

StaticSpecialTypeWrapper.GetPseudoCustomAttributes Method
[image]

Gets all pseudo custom attributes associated with a member.

These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetPseudoCustomAttributes() As IEnumerable(Of Attribute)
C#
protected override IEnumerable<Attribute> GetPseudoCustomAttributes()
C++
protected:
virtual IEnumerable<Attribute> GetPseudoCustomAttributes() override
J#
protected override IEnumerable<Attribute> GetPseudoCustomAttributes()
JScript
protected override function GetPseudoCustomAttributes() : IEnumerable<Attribute>

Return Value

The pseudo custom attributes

See Also

StaticSpecialTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticTypeSubstitution Structure

StaticTypeSubstitution Structure
See Also Example Members
[image]

A type substitution specifies how generic parameters are replaced by other types. It is used by implementors of StaticReflectionPolicy when returning types that may be represented as generic parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure StaticTypeSubstitution
Implements IEquatable(Of StaticTypeSubstitution)
C#
public struct StaticTypeSubstitution : IEquatable<StaticTypeSubstitution>
C++
value class StaticTypeSubstitution : IEquatable<StaticTypeSubstitution>
J#
public final class StaticTypeSubstitution extends ValueType implements IEquatable<StaticTypeSubstitution>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticTypeSubstitution

See Also

StaticTypeSubstitution Members
Gallio.Reflection.Impl Namespace


StaticTypeSubstitution Members

StaticTypeSubstitution Members
See Also Example Fields Properties Methods
[image]

A type substitution specifies how generic parameters are replaced by other types. It is used by implementors of StaticReflectionPolicy when returning types that may be represented as generic parameters.

The following tables list the members exposed by StaticTypeSubstitution.

Public Fields

Name | Description
Empty | Gets the empty type substitution. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | IsEmpty | Returns true if the type substitution does not contain any replacements.
Top

Public Methods

 | Name | Description
Public method | Apply | Overloaded. Applies a type substitution to the specified generic parameter.
Public method | ApplyAll | Applies a type substitution to the specified list of types.
Public method | Compose | Returns a new substitution formed by composing this substitution with the specified one. That is to say, each replacement type in this substitution is replaced as described in the specified substitution.
Public method | DoesNotContainAny | Returns true if this substitution does not contain any of the specified generic parameters.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | Extend | Returns a new substitution with the specified generic parameters replaced by their respective generic arguments.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two static type substitutions for equality.
 | op_Inequality | Compares two static type substitutions for inequality.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Fields

StaticTypeSubstitution Fields
[image]

Public Fields

Name | Description
Empty | Gets the empty type substitution. This field is read-only.
Top

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Empty Field

StaticTypeSubstitution.Empty Field
[image]

Gets the empty type substitution. This field is read-only.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As StaticTypeSubstitution
C#
public static readonly StaticTypeSubstitution Empty;
C++
public:
static const StaticTypeSubstitution Empty;
J#
public static final StaticTypeSubstitution Empty
JScript
public static const var Empty : StaticTypeSubstitution;

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Properties

StaticTypeSubstitution Properties
[image]

Public Properties

 | Name | Description
Public property | IsEmpty | Returns true if the type substitution does not contain any replacements.
Top

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


IsEmpty Property

StaticTypeSubstitution.IsEmpty Property
[image]

Returns true if the type substitution does not contain any replacements.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty { get; }
C++
public property bool IsEmpty sealed {
bool get();
}
J#
/** property */
public bool get_IsEmpty();
JScript
public function get IsEmpty() : bool

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Methods

StaticTypeSubstitution Methods
[image]

Public Methods

 | Name | Description
Public method | Apply | Overloaded. Applies a type substitution to the specified generic parameter.
Public method | ApplyAll | Applies a type substitution to the specified list of types.
Public method | Compose | Returns a new substitution formed by composing this substitution with the specified one. That is to say, each replacement type in this substitution is replaced as described in the specified substitution.
Public method | DoesNotContainAny | Returns true if this substitution does not contain any of the specified generic parameters.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | Extend | Returns a new substitution with the specified generic parameters replaced by their respective generic arguments.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | op_Equality | Compares two static type substitutions for equality.
 | op_Inequality | Compares two static type substitutions for inequality.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Apply Method

StaticTypeSubstitution.Apply Method

Applies a type substitution to the specified generic parameter.

Overload List

 | Name | Description
Public method | Apply (StaticGenericParameterWrapper) | Applies a type substitution to the specified generic parameter.
Public method | Apply (StaticTypeWrapper) | Applies a type substitution to the specified type.

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Apply Method (StaticGenericParameterWrapper)

StaticTypeSubstitution.Apply Method (StaticGenericParameterWrapper)
See Also Example
[image]

Applies a type substitution to the specified generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Apply( _
ByVal type As StaticGenericParameterWrapper _
) As ITypeInfo
C#
public ITypeInfo Apply(
StaticGenericParameterWrapper type
)
C++
public:
ITypeInfo Apply(
StaticGenericParameterWrapper type
) sealed
J#
public ITypeInfo Apply(
StaticGenericParameterWrapper type
)
JScript
public function Apply(
type : StaticGenericParameterWrapper
) : ITypeInfo

Parameters

type
The generic parameter to substitute

Return Value

The substituted type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace
StaticTypeSubstitution.Apply Overload List


Apply Method (StaticTypeWrapper)

StaticTypeSubstitution.Apply Method (StaticTypeWrapper)
See Also Example
[image]

Applies a type substitution to the specified type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Apply( _
ByVal type As StaticTypeWrapper _
) As ITypeInfo
C#
public ITypeInfo Apply(
StaticTypeWrapper type
)
C++
public:
ITypeInfo Apply(
StaticTypeWrapper type
) sealed
J#
public ITypeInfo Apply(
StaticTypeWrapper type
)
JScript
public function Apply(
type : StaticTypeWrapper
) : ITypeInfo

Parameters

type
The type to substitute

Return Value

The substituted type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace
StaticTypeSubstitution.Apply Overload List


ApplyAll Generic Method

StaticTypeSubstitution.ApplyAll Generic Method
[image]

Applies a type substitution to the specified list of types.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ApplyAll(Of T As StaticTypeWrapper)( _
ByVal types As IList(Of T) _
) As IList(Of ITypeInfo)
C#
public IList<ITypeInfo> ApplyAll<T>(
IList<T> types
) where T : StaticTypeWrapper
C++
public:
IList<ITypeInfo> ApplyAll<T>(
IList<T> types
) sealed
J#
public IList<ITypeInfo> ApplyAll<T>(
IList<T> types
)
JScript
JScript does not support generic types and methods.

Parameters

types
The types to substitute

Return Value

The substituted types

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if types is null

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Compose Method

StaticTypeSubstitution.Compose Method
[image]

Returns a new substitution formed by composing this substitution with the specified one. That is to say, each replacement type in this substitution is replaced as described in the specified substitution.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Compose( _
ByVal substitution As StaticTypeSubstitution _
) As StaticTypeSubstitution
C#
public StaticTypeSubstitution Compose(
StaticTypeSubstitution substitution
)
C++
public:
StaticTypeSubstitution Compose(
StaticTypeSubstitution substitution
) sealed
J#
public StaticTypeSubstitution Compose(
StaticTypeSubstitution substitution
)
JScript
public function Compose(
substitution : StaticTypeSubstitution
) : StaticTypeSubstitution

Parameters

substitution
The substitution to compose

Return Value

The new substitution

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


DoesNotContainAny Method

StaticTypeSubstitution.DoesNotContainAny Method
[image]

Returns true if this substitution does not contain any of the specified generic parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function DoesNotContainAny( _
ByVal genericParameters As IList(Of StaticGenericParameterWrapper) _
) As Boolean
C#
public bool DoesNotContainAny(
IList<StaticGenericParameterWrapper> genericParameters
)
C++
public:
bool DoesNotContainAny(
IList<StaticGenericParameterWrapper> genericParameters
) sealed
J#
public bool DoesNotContainAny(
IList<StaticGenericParameterWrapper> genericParameters
)
JScript
public function DoesNotContainAny(
genericParameters : IList<StaticGenericParameterWrapper>
) : bool

Parameters

genericParameters
The generic parameters

Return Value

True if none of the generic parameters are in the substitution

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if genericParameters is null

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Equals Method

StaticTypeSubstitution.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (StaticTypeSubstitution) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


Equals Method (StaticTypeSubstitution)

StaticTypeSubstitution.Equals Method (StaticTypeSubstitution)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As StaticTypeSubstitution _
) As Boolean _
Implements IEquatable<StaticTypeSubstitution>.Equals
C#
public bool Equals(
StaticTypeSubstitution other
)
C++
public:
bool Equals(
StaticTypeSubstitution other
) sealed
J#
public bool Equals(
StaticTypeSubstitution other
)
JScript
public function Equals(
other : StaticTypeSubstitution
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<StaticTypeSubstitution>.Equals

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace
StaticTypeSubstitution.Equals Overload List


Equals Method (Object)

StaticTypeSubstitution.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace
StaticTypeSubstitution.Equals Overload List


Extend Method

StaticTypeSubstitution.Extend Method
[image]

Returns a new substitution with the specified generic parameters replaced by their respective generic arguments.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Extend( _
ByVal genericParameters As IList(Of StaticGenericParameterWrapper), _
ByVal genericArguments As IList(Of ITypeInfo) _
) As StaticTypeSubstitution
C#
public StaticTypeSubstitution Extend(
IList<StaticGenericParameterWrapper> genericParameters,
IList<ITypeInfo> genericArguments
)
C++
public:
StaticTypeSubstitution Extend(
IList<StaticGenericParameterWrapper> genericParameters,
IList<ITypeInfo> genericArguments
) sealed
J#
public StaticTypeSubstitution Extend(
IList<StaticGenericParameterWrapper> genericParameters,
IList<ITypeInfo> genericArguments
)
JScript
public function Extend(
genericParameters : IList<StaticGenericParameterWrapper>,
genericArguments : IList<ITypeInfo>
) : StaticTypeSubstitution

Parameters

genericParameters
The generic parameters
genericArguments
The generic arguments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if genericParameters or genericArguments is null or contain nulls
ArgumentException | Thrown if genericArguments does not have the same number of elements as genericParameters

Remarks

The extended type substitution is normalized so that generic parameters that are idempotently replaced with themselves are excluded from the substitution altogether.

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


GetHashCode Method

StaticTypeSubstitution.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


op_Equality Operator

StaticTypeSubstitution.op_Equality Operator
[image]

Compares two static type substitutions for equality.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator =( _
ByVal a As StaticTypeSubstitution, _
ByVal b As StaticTypeSubstitution _
) As Boolean
C#
public static bool operator ==(
StaticTypeSubstitution a,
StaticTypeSubstitution b
)
C++
public:
static bool operator ==(
StaticTypeSubstitution a,
StaticTypeSubstitution b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first substitution
b
The second substitution

Return Value

True if the substitutions are equal

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


op_Inequality Operator

StaticTypeSubstitution.op_Inequality Operator
[image]

Compares two static type substitutions for inequality.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <>( _
ByVal a As StaticTypeSubstitution, _
ByVal b As StaticTypeSubstitution _
) As Boolean
C#
public static bool operator !=(
StaticTypeSubstitution a,
StaticTypeSubstitution b
)
C++
public:
static bool operator !=(
StaticTypeSubstitution a,
StaticTypeSubstitution b
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

a
The first substitution
b
The second substitution

Return Value

True if the substitutions are equal

See Also

StaticTypeSubstitution Structure
Gallio.Reflection.Impl Namespace


StaticTypeWrapper Class

StaticTypeWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticTypeWrapper
Inherits StaticMemberWrapper
Implements IResolvableTypeInfo, ITypeInfo
C#
public abstract class StaticTypeWrapper : StaticMemberWrapper, IResolvableTypeInfo, ITypeInfo
C++
ref class StaticTypeWrapper abstract : StaticMemberWrapper, IResolvableTypeInfo, ITypeInfo
J#
public class StaticTypeWrapper extends StaticMemberWrapper implements IResolvableTypeInfo, ITypeInfo
JScript
public class StaticTypeWrapper extends StaticMemberWrapper, IResolvableTypeInfo, ITypeInfo

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper
Gallio.Reflection.Impl.StaticMemberWrapper
Gallio.Reflection.Impl.StaticTypeWrapper
Gallio.Reflection.Impl.StaticDeclaredTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper

See Also

StaticTypeWrapper Members
Gallio.Reflection.Impl Namespace


StaticTypeWrapper Members

StaticTypeWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy type wrapper. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticTypeWrapper.

Protected Constructors

 | Name | Description
Family method | StaticTypeWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | ArrayRank |
Public property | Assembly |
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter.
Public property | BaseType | Gets the base type of the type, or null if none.
Public property | CodeReference | Overridden. Gets a CodeReference for this code element.
Public property | ContainsGenericParameters |
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none.
Public property | FullName |
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericTypeDefinition |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces |
Public property | IsAbstract | Returns true if the type is abstract and must be overridden.
Public property | IsArray |
Public property | IsByRef | Returns true if the type represents a type that is passed by reference.
Public property | IsClass | Returns true if the type is a class.
Public property | IsEnum | Returns true if the type represents an enumeration.
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter.
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition.
Public property | IsInterface | Returns true if the type is an interface.
Public property | IsNested | Returns true if the type is nested.
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly.
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family.
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly.
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly.
Public property | IsNestedPrivate | Returns true if the type is nested and declared private.
Public property | IsNestedPublic | Returns true if the type is nested and declared public.
Public property | IsNotPublic | Returns true if the type is not declared public.
Public property | IsPointer | Returns true if the type represents a pointer.
Public property | IsPublic | Returns true if the type is declared public.
Public property | IsSealed | Returns true if the type is sealed.
Public property | IsValueType | Returns true if the type is a value type.
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Namespace | Gets the namespace in which the type is declared.
Public property | NamespaceName |
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Public property | TypeAttributes |
Public property | TypeCode | Gets the type's TypeCode.
Top

Protected Properties

 | Name | Description
Family property | BaseTypeInternal | Internal implementation of BaseType.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors |
Public method | GetEvent |
Public method | GetEvents |
Public method | GetField |
Public method | GetFields |
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod |
Public method | GetMethods |
Public method | GetNestedType |
Public method | GetNestedTypes |
Public method | GetProperties |
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type.
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type.
Public method | MakeArrayType |
Public method | MakeByRefType |
Public method | MakeGenericType |
Public method | MakePointerType |
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target.
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Applies a type substitution and returns the resulting type.
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Overridden. Gets an enumeration of elements from which this code element inherits.
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Overridden. Implementation of Resolve
Top

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticTypeWrapper Constructor

StaticTypeWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object, _
ByVal declaringType As StaticDeclaredTypeWrapper _
)
C#
protected StaticTypeWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
C++
protected:
StaticTypeWrapper(
StaticReflectionPolicy policy,
Object handle,
StaticDeclaredTypeWrapper declaringType
) sealed
J#
protected StaticTypeWrapper(
StaticReflectionPolicy policy,
object handle,
StaticDeclaredTypeWrapper declaringType
)
JScript
protected function StaticTypeWrapper(
policy : StaticReflectionPolicy,
handle : Object,
declaringType : StaticDeclaredTypeWrapper
)

Parameters

policy
The reflection policy
handle
The underlying reflection object
declaringType
The declaring type, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticTypeWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | ArrayRank |
Public property | Assembly |
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the type, or null if the type is a generic parameter.
Public property | BaseType | Gets the base type of the type, or null if none.
Public property | CodeReference | Overridden. Gets a CodeReference for this code element.
Public property | ContainsGenericParameters |
Public property | DeclaringType | Gets the declaring type, or null if none. (inherited from StaticMemberWrapper)
Public property | ElementType | Gets the element type, or null if none.
Public property | FullName |
Public property | GenericArguments | Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.
Public property | GenericTypeDefinition |
Public property | Handle | Gets the underlying reflection object. (inherited from StaticWrapper)
Public property | Interfaces |
Public property | IsAbstract | Returns true if the type is abstract and must be overridden.
Public property | IsArray |
Public property | IsByRef | Returns true if the type represents a type that is passed by reference.
Public property | IsClass | Returns true if the type is a class.
Public property | IsEnum | Returns true if the type represents an enumeration.
Public property | IsGenericParameter | Returns true if the type represents a generic type parameter.
Public property | IsGenericType | Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.
Public property | IsGenericTypeDefinition | Returns true if the type is a generic type definition.
Public property | IsInterface | Returns true if the type is an interface.
Public property | IsNested | Returns true if the type is nested.
Public property | IsNestedAssembly | Returns true if the type is nested and is visible only within its own assembly.
Public property | IsNestedFamily | Returns true if the type is nested and visible only within its own family.
Public property | IsNestedFamilyAndAssembly | Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly.
Public property | IsNestedFamilyOrAssembly | Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly.
Public property | IsNestedPrivate | Returns true if the type is nested and declared private.
Public property | IsNestedPublic | Returns true if the type is nested and declared public.
Public property | IsNotPublic | Returns true if the type is not declared public.
Public property | IsPointer | Returns true if the type represents a pointer.
Public property | IsPublic | Returns true if the type is declared public.
Public property | IsSealed | Returns true if the type is sealed.
Public property | IsValueType | Returns true if the type is a value type.
Public property | Kind | Overridden. Gets the kind of code element represented by this instance.
Public property | Name | (inherited from StaticMemberWrapper)
Public property | Namespace | Gets the namespace in which the type is declared.
Public property | NamespaceName |
Public property | Policy | Gets the reflection policy. (inherited from StaticWrapper)
Public property | ReflectedType | Gets the reflected type, or null if none. (inherited from StaticMemberWrapper)
Public property | Substitution | Gets the type substitution for generic parameters. (inherited from StaticMemberWrapper)
Public property | TypeAttributes |
Public property | TypeCode | Gets the type's TypeCode.
Top

Protected Properties

 | Name | Description
Family property | BaseTypeInternal | Internal implementation of BaseType.
Top

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


ArrayRank Property

StaticTypeWrapper.ArrayRank Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ArrayRank As Integer _
Implements ITypeInfo.ArrayRank
C#
public virtual int ArrayRank { get; }
C++
public virtual property int ArrayRank {
int get();
}
J#
/** property */
public int get_ArrayRank();
JScript
public function get ArrayRank() : int

Implements

ITypeInfo.ArrayRank

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Assembly Property

StaticTypeWrapper.Assembly Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Assembly As IAssemblyInfo _
Implements ITypeInfo.Assembly
C#
public abstract IAssemblyInfo Assembly { get; }
C++
public abstract property IAssemblyInfo Assembly abstract {
IAssemblyInfo get();
}
J#
/** property */
public IAssemblyInfo get_Assembly();
JScript
public function get Assembly() : IAssemblyInfo

Implements

ITypeInfo.Assembly

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


AssemblyQualifiedName Property

StaticTypeWrapper.AssemblyQualifiedName Property
[image]

Gets the assembly-qualified name of the type, or null if the type is a generic parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AssemblyQualifiedName As String _
Implements ITypeInfo.AssemblyQualifiedName
C#
public virtual string AssemblyQualifiedName { get; }
C++
public virtual property string AssemblyQualifiedName {
String get();
}
J#
/** property */
public string get_AssemblyQualifiedName();
JScript
public function get AssemblyQualifiedName() : String

Implements

ITypeInfo.AssemblyQualifiedName

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


BaseType Property

StaticTypeWrapper.BaseType Property
[image]

Gets the base type of the type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseType As ITypeInfo _
Implements ITypeInfo.BaseType
C#
public ITypeInfo BaseType { get; }
C++
public property ITypeInfo BaseType sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_BaseType();
JScript
public function get BaseType() : ITypeInfo

Implements

ITypeInfo.BaseType

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


BaseTypeInternal Property

StaticTypeWrapper.BaseTypeInternal Property
[image]

Internal implementation of BaseType.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride ReadOnly Property BaseTypeInternal As ITypeInfo
C#
protected abstract ITypeInfo BaseTypeInternal { get; }
C++
protected abstract property ITypeInfo BaseTypeInternal abstract {
ITypeInfo get();
}
J#
/** property */
protected ITypeInfo get_BaseTypeInternal();
JScript
protected function get BaseTypeInternal() : ITypeInfo

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


CodeReference Property

StaticTypeWrapper.CodeReference Property
[image]

Gets a CodeReference for this code element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CodeReference As CodeReference _
Implements ICodeElementInfo.CodeReference
C#
public override CodeReference CodeReference { get; }
C++
public override property CodeReference CodeReference override {
CodeReference get();
}
J#
/** property */
public CodeReference get_CodeReference();
JScript
public function get CodeReference() : CodeReference

Property Value

The code reference

Implements

ICodeElementInfo.CodeReference

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

StaticTypeWrapper.ContainsGenericParameters Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ContainsGenericParameters As Boolean _
Implements ITypeInfo.ContainsGenericParameters
C#
public virtual bool ContainsGenericParameters { get; }
C++
public virtual property bool ContainsGenericParameters {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Implements

ITypeInfo.ContainsGenericParameters

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


ElementType Property

StaticTypeWrapper.ElementType Property
[image]

Gets the element type, or null if none.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ElementType As StaticTypeWrapper
C#
public virtual StaticTypeWrapper ElementType { get; }
C++
public virtual property StaticTypeWrapper ElementType {
StaticTypeWrapper get();
}
J#
/** property */
public StaticTypeWrapper get_ElementType();
JScript
public function get ElementType() : StaticTypeWrapper

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


FullName Property

StaticTypeWrapper.FullName Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property FullName As String _
Implements ITypeInfo.FullName
C#
public abstract string FullName { get; }
C++
public abstract property string FullName abstract {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Implements

ITypeInfo.FullName

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GenericArguments Property

StaticTypeWrapper.GenericArguments Property
[image]

Gets the generic arguments of the type. The list may contain IGenericParameterInfo objects when no type has yet been bound to a certain generic parameter slots.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property GenericArguments As IList(Of ITypeInfo) _
Implements ITypeInfo.GenericArguments
C#
public virtual IList<ITypeInfo> GenericArguments { get; }
C++
public virtual property IList<ITypeInfo> GenericArguments {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_GenericArguments();
JScript
public function get GenericArguments() : IList<ITypeInfo>

Property Value

The generic arguments, or an empty list if there are none

Implements

ITypeInfo.GenericArguments

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GenericTypeDefinition Property

StaticTypeWrapper.GenericTypeDefinition Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property GenericTypeDefinition As StaticDeclaredTypeWrapper
C#
public virtual StaticDeclaredTypeWrapper GenericTypeDefinition { get; }
C++
public virtual property StaticDeclaredTypeWrapper GenericTypeDefinition {
StaticDeclaredTypeWrapper get();
}
J#
/** property */
public StaticDeclaredTypeWrapper get_GenericTypeDefinition();
JScript
public function get GenericTypeDefinition() : StaticDeclaredTypeWrapper

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Interfaces Property

StaticTypeWrapper.Interfaces Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Interfaces As IList(Of ITypeInfo) _
Implements ITypeInfo.Interfaces
C#
public abstract IList<ITypeInfo> Interfaces { get; }
C++
public abstract property IList<ITypeInfo> Interfaces abstract {
IList<ITypeInfo> get();
}
J#
/** property */
public IList<ITypeInfo> get_Interfaces();
JScript
public function get Interfaces() : IList<ITypeInfo>

Implements

ITypeInfo.Interfaces

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsAbstract Property

StaticTypeWrapper.IsAbstract Property
[image]

Returns true if the type is abstract and must be overridden.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsAbstract As Boolean _
Implements ITypeInfo.IsAbstract
C#
public bool IsAbstract { get; }
C++
public property bool IsAbstract sealed {
bool get();
}
J#
/** property */
public bool get_IsAbstract();
JScript
public function get IsAbstract() : bool

Implements

ITypeInfo.IsAbstract

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsArray Property

StaticTypeWrapper.IsArray Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsArray As Boolean _
Implements ITypeInfo.IsArray
C#
public virtual bool IsArray { get; }
C++
public virtual property bool IsArray {
bool get();
}
J#
/** property */
public bool get_IsArray();
JScript
public function get IsArray() : bool

Implements

ITypeInfo.IsArray

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsByRef Property

StaticTypeWrapper.IsByRef Property
[image]

Returns true if the type represents a type that is passed by reference.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsByRef As Boolean _
Implements ITypeInfo.IsByRef
C#
public virtual bool IsByRef { get; }
C++
public virtual property bool IsByRef {
bool get();
}
J#
/** property */
public bool get_IsByRef();
JScript
public function get IsByRef() : bool

Implements

ITypeInfo.IsByRef

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsClass Property

StaticTypeWrapper.IsClass Property
[image]

Returns true if the type is a class.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClass As Boolean _
Implements ITypeInfo.IsClass
C#
public bool IsClass { get; }
C++
public property bool IsClass sealed {
bool get();
}
J#
/** property */
public bool get_IsClass();
JScript
public function get IsClass() : bool

Implements

ITypeInfo.IsClass

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsEnum Property

StaticTypeWrapper.IsEnum Property
[image]

Returns true if the type represents an enumeration.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEnum As Boolean _
Implements ITypeInfo.IsEnum
C#
public bool IsEnum { get; }
C++
public property bool IsEnum sealed {
bool get();
}
J#
/** property */
public bool get_IsEnum();
JScript
public function get IsEnum() : bool

Implements

ITypeInfo.IsEnum

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericParameter Property

StaticTypeWrapper.IsGenericParameter Property
[image]

Returns true if the type represents a generic type parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGenericParameter As Boolean _
Implements ITypeInfo.IsGenericParameter
C#
public virtual bool IsGenericParameter { get; }
C++
public virtual property bool IsGenericParameter {
bool get();
}
J#
/** property */
public bool get_IsGenericParameter();
JScript
public function get IsGenericParameter() : bool

Implements

ITypeInfo.IsGenericParameter

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericType Property

StaticTypeWrapper.IsGenericType Property
[image]

Returns true if the type is a generic type. If so, the GenericArguments list will be non-empty.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGenericType As Boolean _
Implements ITypeInfo.IsGenericType
C#
public virtual bool IsGenericType { get; }
C++
public virtual property bool IsGenericType {
bool get();
}
J#
/** property */
public bool get_IsGenericType();
JScript
public function get IsGenericType() : bool

Implements

ITypeInfo.IsGenericType

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsGenericTypeDefinition Property

StaticTypeWrapper.IsGenericTypeDefinition Property
[image]

Returns true if the type is a generic type definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGenericTypeDefinition As Boolean _
Implements ITypeInfo.IsGenericTypeDefinition
C#
public virtual bool IsGenericTypeDefinition { get; }
C++
public virtual property bool IsGenericTypeDefinition {
bool get();
}
J#
/** property */
public bool get_IsGenericTypeDefinition();
JScript
public function get IsGenericTypeDefinition() : bool

Implements

ITypeInfo.IsGenericTypeDefinition

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsInterface Property

StaticTypeWrapper.IsInterface Property
[image]

Returns true if the type is an interface.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInterface As Boolean _
Implements ITypeInfo.IsInterface
C#
public bool IsInterface { get; }
C++
public property bool IsInterface sealed {
bool get();
}
J#
/** property */
public bool get_IsInterface();
JScript
public function get IsInterface() : bool

Implements

ITypeInfo.IsInterface

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNested Property

StaticTypeWrapper.IsNested Property
[image]

Returns true if the type is nested.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNested As Boolean _
Implements ITypeInfo.IsNested
C#
public bool IsNested { get; }
C++
public property bool IsNested sealed {
bool get();
}
J#
/** property */
public bool get_IsNested();
JScript
public function get IsNested() : bool

Implements

ITypeInfo.IsNested

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNestedAssembly Property

StaticTypeWrapper.IsNestedAssembly Property
[image]

Returns true if the type is nested and is visible only within its own assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedAssembly As Boolean _
Implements ITypeInfo.IsNestedAssembly
C#
public bool IsNestedAssembly { get; }
C++
public property bool IsNestedAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsNestedAssembly();
JScript
public function get IsNestedAssembly() : bool

Implements

ITypeInfo.IsNestedAssembly

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNestedFamily Property

StaticTypeWrapper.IsNestedFamily Property
[image]

Returns true if the type is nested and visible only within its own family.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedFamily As Boolean _
Implements ITypeInfo.IsNestedFamily
C#
public bool IsNestedFamily { get; }
C++
public property bool IsNestedFamily sealed {
bool get();
}
J#
/** property */
public bool get_IsNestedFamily();
JScript
public function get IsNestedFamily() : bool

Implements

ITypeInfo.IsNestedFamily

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNestedFamilyAndAssembly Property

StaticTypeWrapper.IsNestedFamilyAndAssembly Property
[image]

Returns true if the type is nested and visible only to classes that belong to both its own family and its own assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedFamilyAndAssembly As Boolean _
Implements ITypeInfo.IsNestedFamilyAndAssembly
C#
public bool IsNestedFamilyAndAssembly { get; }
C++
public property bool IsNestedFamilyAndAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsNestedFamilyAndAssembly();
JScript
public function get IsNestedFamilyAndAssembly() : bool

Implements

ITypeInfo.IsNestedFamilyAndAssembly

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNestedFamilyOrAssembly Property

StaticTypeWrapper.IsNestedFamilyOrAssembly Property
[image]

Returns true if the type is nested and visible only to classes that belong to either its own family or to its own assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedFamilyOrAssembly As Boolean _
Implements ITypeInfo.IsNestedFamilyOrAssembly
C#
public bool IsNestedFamilyOrAssembly { get; }
C++
public property bool IsNestedFamilyOrAssembly sealed {
bool get();
}
J#
/** property */
public bool get_IsNestedFamilyOrAssembly();
JScript
public function get IsNestedFamilyOrAssembly() : bool

Implements

ITypeInfo.IsNestedFamilyOrAssembly

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNestedPrivate Property

StaticTypeWrapper.IsNestedPrivate Property
[image]

Returns true if the type is nested and declared private.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedPrivate As Boolean _
Implements ITypeInfo.IsNestedPrivate
C#
public bool IsNestedPrivate { get; }
C++
public property bool IsNestedPrivate sealed {
bool get();
}
J#
/** property */
public bool get_IsNestedPrivate();
JScript
public function get IsNestedPrivate() : bool

Implements

ITypeInfo.IsNestedPrivate

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNestedPublic Property

StaticTypeWrapper.IsNestedPublic Property
[image]

Returns true if the type is nested and declared public.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNestedPublic As Boolean _
Implements ITypeInfo.IsNestedPublic
C#
public bool IsNestedPublic { get; }
C++
public property bool IsNestedPublic sealed {
bool get();
}
J#
/** property */
public bool get_IsNestedPublic();
JScript
public function get IsNestedPublic() : bool

Implements

ITypeInfo.IsNestedPublic

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsNotPublic Property

StaticTypeWrapper.IsNotPublic Property
[image]

Returns true if the type is not declared public.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNotPublic As Boolean _
Implements ITypeInfo.IsNotPublic
C#
public bool IsNotPublic { get; }
C++
public property bool IsNotPublic sealed {
bool get();
}
J#
/** property */
public bool get_IsNotPublic();
JScript
public function get IsNotPublic() : bool

Implements

ITypeInfo.IsNotPublic

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsPointer Property

StaticTypeWrapper.IsPointer Property
[image]

Returns true if the type represents a pointer.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsPointer As Boolean _
Implements ITypeInfo.IsPointer
C#
public virtual bool IsPointer { get; }
C++
public virtual property bool IsPointer {
bool get();
}
J#
/** property */
public bool get_IsPointer();
JScript
public function get IsPointer() : bool

Implements

ITypeInfo.IsPointer

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsPublic Property

StaticTypeWrapper.IsPublic Property
[image]

Returns true if the type is declared public.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPublic As Boolean _
Implements ITypeInfo.IsPublic
C#
public bool IsPublic { get; }
C++
public property bool IsPublic sealed {
bool get();
}
J#
/** property */
public bool get_IsPublic();
JScript
public function get IsPublic() : bool

Implements

ITypeInfo.IsPublic

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsSealed Property

StaticTypeWrapper.IsSealed Property
[image]

Returns true if the type is sealed.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSealed As Boolean _
Implements ITypeInfo.IsSealed
C#
public bool IsSealed { get; }
C++
public property bool IsSealed sealed {
bool get();
}
J#
/** property */
public bool get_IsSealed();
JScript
public function get IsSealed() : bool

Implements

ITypeInfo.IsSealed

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsValueType Property

StaticTypeWrapper.IsValueType Property
[image]

Returns true if the type is a value type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValueType As Boolean _
Implements ITypeInfo.IsValueType
C#
public bool IsValueType { get; }
C++
public property bool IsValueType sealed {
bool get();
}
J#
/** property */
public bool get_IsValueType();
JScript
public function get IsValueType() : bool

Implements

ITypeInfo.IsValueType

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Kind Property

StaticTypeWrapper.Kind Property
[image]

Gets the kind of code element represented by this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Kind As CodeElementKind _
Implements ICodeElementInfo.Kind
C#
public override CodeElementKind Kind { get; }
C++
public override property CodeElementKind Kind override {
CodeElementKind get();
}
J#
/** property */
public CodeElementKind get_Kind();
JScript
public function get Kind() : CodeElementKind

Implements

ICodeElementInfo.Kind

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Namespace Property

StaticTypeWrapper.Namespace Property
[image]

Gets the namespace in which the type is declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Namespace As INamespaceInfo _
Implements ITypeInfo.Namespace
C#
public INamespaceInfo Namespace { get; }
C++
public property INamespaceInfo Namespace sealed {
INamespaceInfo get();
}
J#
/** property */
public INamespaceInfo get_Namespace();
JScript
public function get Namespace() : INamespaceInfo

Implements

ITypeInfo.Namespace

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


NamespaceName Property

StaticTypeWrapper.NamespaceName Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property NamespaceName As String _
Implements ITypeInfo.NamespaceName
C#
public abstract string NamespaceName { get; }
C++
public abstract property string NamespaceName abstract {
String get();
}
J#
/** property */
public string get_NamespaceName();
JScript
public function get NamespaceName() : String

Implements

ITypeInfo.NamespaceName

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


TypeAttributes Property

StaticTypeWrapper.TypeAttributes Property
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property TypeAttributes As TypeAttributes _
Implements ITypeInfo.TypeAttributes
C#
public abstract TypeAttributes TypeAttributes { get; }
C++
public abstract property TypeAttributes TypeAttributes abstract {
TypeAttributes get();
}
J#
/** property */
public TypeAttributes get_TypeAttributes();
JScript
public function get TypeAttributes() : TypeAttributes

Implements

ITypeInfo.TypeAttributes

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


TypeCode Property

StaticTypeWrapper.TypeCode Property
[image]

Gets the type's TypeCode.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeCode As TypeCode _
Implements ITypeInfo.TypeCode
C#
public virtual TypeCode TypeCode { get; }
C++
public virtual property TypeCode TypeCode {
TypeCode get();
}
J#
/** property */
public TypeCode get_TypeCode();
JScript
public function get TypeCode() : TypeCode

Implements

ITypeInfo.TypeCode

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticTypeWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetAttributeInfos | Gets information about the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetAttributes | Gets the code element's custom attributes of the specified type. (inherited from StaticCodeElementWrapper)
Public method | GetCodeLocation | (inherited from StaticMemberWrapper)
Public method | GetConstructors |
Public method | GetEvent |
Public method | GetEvents |
Public method | GetField |
Public method | GetFields |
Public method | GetHashCode | (inherited from StaticMemberWrapper)
Public method | GetMethod |
Public method | GetMethods |
Public method | GetNestedType |
Public method | GetNestedTypes |
Public method | GetProperties |
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetXmlDocumentation | Gets the XML documentation associated with the code element. (inherited from StaticCodeElementWrapper)
Public method | HasAttribute | Returns true if the code element has a custom attribute of the specified type. (inherited from StaticCodeElementWrapper)
Public method | IsAssignableFrom | Returns true if variables of this type can be assigned with values of the specified type.
Public method | IsSubclassOf | Returns true if this type is a subclass of the specified type.
Public method | MakeArrayType |
Public method | MakeByRefType |
Public method | MakeGenericType |
Public method | MakePointerType |
Public method | Resolve | Overloaded. Resolves the wrapper to its native reflection target.
Public method | ToString | Returns a String that represents the current Object. (inherited from StaticCodeElementWrapper)
Top

Protected Methods

 | Name | Description
Family method | ApplySubstitution | Applies a type substitution and returns the resulting type.
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals. (inherited from StaticWrapper)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetCustomAttributes | Gets all attributes that appear on this code element, excluding inherited attributes. (inherited from StaticMemberWrapper)
Family method | GetInheritedElements | Overridden. Gets an enumeration of elements from which this code element inherits.
Family method | GetPseudoCustomAttributes | Gets all pseudo custom attributes associated with a member. These attributes do not really exist as custom attributes in the metadata. Rather, they are realizations of other metadata features in attribute form. For example, SerializableAttribute is represented in the metadata as a TypeAttributes flag. Pseudo custom attributes preserve the illusion of these attributes. (inherited from StaticCodeElementWrapper)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ResolveMemberInfo | Overridden. Implementation of Resolve
Top

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


ApplySubstitution Method

StaticTypeWrapper.ApplySubstitution Method
[image]

Applies a type substitution and returns the resulting type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ApplySubstitution( _
ByVal substitution As StaticTypeSubstitution _
) As ITypeInfo
C#
protected virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
C++
protected:
virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
J#
protected virtual ITypeInfo ApplySubstitution(
StaticTypeSubstitution substitution
)
JScript
protected virtual function ApplySubstitution(
substitution : StaticTypeSubstitution
) : ITypeInfo

Parameters

substitution
The substitution

Return Value

The type after substitution has been performed

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticTypeWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ICodeElementInfo) | (inherited from StaticCodeElementWrapper)
Public method | Equals (IMemberInfo) | (inherited from StaticMemberWrapper)
Public method | Equals (Object) | Overridden. (inherited from StaticMemberWrapper)
Public method | Equals (ITypeInfo) |
Public method | Equals (StaticWrapper) | (inherited from StaticWrapper)

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (ITypeInfo)

StaticTypeWrapper.Equals Method (ITypeInfo)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ITypeInfo _
) As Boolean _
Implements IEquatable<ITypeInfo>.Equals
C#
public bool Equals(
ITypeInfo other
)
C++
public:
bool Equals(
ITypeInfo other
) sealed
J#
public bool Equals(
ITypeInfo other
)
JScript
public function Equals(
other : ITypeInfo
) : bool

Implements

IEquatable<ITypeInfo>.Equals

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticTypeWrapper.Equals Overload List


GetConstructors Method

StaticTypeWrapper.GetConstructors Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetConstructors( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IConstructorInfo) _
Implements ITypeInfo.GetConstructors
C#
public abstract IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
C++
public:
IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
) abstract
J#
public abstract IList<IConstructorInfo> GetConstructors(
BindingFlags bindingFlags
)
JScript
public abstract function GetConstructors(
bindingFlags : BindingFlags
) : IList<IConstructorInfo>

Implements

ITypeInfo.GetConstructors

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetEvent Method

StaticTypeWrapper.GetEvent Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetEvent( _
ByVal eventName As String, _
ByVal bindingFlags As BindingFlags _
) As IEventInfo _
Implements ITypeInfo.GetEvent
C#
public abstract IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
C++
public:
IEventInfo GetEvent(
String eventName,
BindingFlags bindingFlags
) abstract
J#
public abstract IEventInfo GetEvent(
string eventName,
BindingFlags bindingFlags
)
JScript
public abstract function GetEvent(
eventName : String,
bindingFlags : BindingFlags
) : IEventInfo

Implements

ITypeInfo.GetEvent

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetEvents Method

StaticTypeWrapper.GetEvents Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetEvents( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IEventInfo) _
Implements ITypeInfo.GetEvents
C#
public abstract IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
C++
public:
IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
) abstract
J#
public abstract IList<IEventInfo> GetEvents(
BindingFlags bindingFlags
)
JScript
public abstract function GetEvents(
bindingFlags : BindingFlags
) : IList<IEventInfo>

Implements

ITypeInfo.GetEvents

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetField Method

StaticTypeWrapper.GetField Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetField( _
ByVal fieldName As String, _
ByVal bindingFlags As BindingFlags _
) As IFieldInfo _
Implements ITypeInfo.GetField
C#
public abstract IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
C++
public:
IFieldInfo GetField(
String fieldName,
BindingFlags bindingFlags
) abstract
J#
public abstract IFieldInfo GetField(
string fieldName,
BindingFlags bindingFlags
)
JScript
public abstract function GetField(
fieldName : String,
bindingFlags : BindingFlags
) : IFieldInfo

Implements

ITypeInfo.GetField

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetFields Method

StaticTypeWrapper.GetFields Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetFields( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IFieldInfo) _
Implements ITypeInfo.GetFields
C#
public abstract IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
C++
public:
IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
) abstract
J#
public abstract IList<IFieldInfo> GetFields(
BindingFlags bindingFlags
)
JScript
public abstract function GetFields(
bindingFlags : BindingFlags
) : IList<IFieldInfo>

Implements

ITypeInfo.GetFields

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetInheritedElements Method

StaticTypeWrapper.GetInheritedElements Method
[image]

Gets an enumeration of elements from which this code element inherits.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetInheritedElements() As IEnumerable(Of ICodeElementInfo)
C#
protected override IEnumerable<ICodeElementInfo> GetInheritedElements()
C++
protected:
virtual IEnumerable<ICodeElementInfo> GetInheritedElements() override
J#
protected override IEnumerable<ICodeElementInfo> GetInheritedElements()
JScript
protected override function GetInheritedElements() : IEnumerable<ICodeElementInfo>

Return Value

The inherited code elements

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetMethod Method

StaticTypeWrapper.GetMethod Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetMethod( _
ByVal methodName As String, _
ByVal bindingFlags As BindingFlags _
) As IMethodInfo _
Implements ITypeInfo.GetMethod
C#
public abstract IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
C++
public:
IMethodInfo GetMethod(
String methodName,
BindingFlags bindingFlags
) abstract
J#
public abstract IMethodInfo GetMethod(
string methodName,
BindingFlags bindingFlags
)
JScript
public abstract function GetMethod(
methodName : String,
bindingFlags : BindingFlags
) : IMethodInfo

Implements

ITypeInfo.GetMethod

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetMethods Method

StaticTypeWrapper.GetMethods Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetMethods( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IMethodInfo) _
Implements ITypeInfo.GetMethods
C#
public abstract IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
C++
public:
IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
) abstract
J#
public abstract IList<IMethodInfo> GetMethods(
BindingFlags bindingFlags
)
JScript
public abstract function GetMethods(
bindingFlags : BindingFlags
) : IList<IMethodInfo>

Implements

ITypeInfo.GetMethods

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetNestedType Method

StaticTypeWrapper.GetNestedType Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetNestedType( _
ByVal nestedTypeName As String, _
ByVal bindingFlags As BindingFlags _
) As ITypeInfo _
Implements ITypeInfo.GetNestedType
C#
public abstract ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
C++
public:
ITypeInfo GetNestedType(
String nestedTypeName,
BindingFlags bindingFlags
) abstract
J#
public abstract ITypeInfo GetNestedType(
string nestedTypeName,
BindingFlags bindingFlags
)
JScript
public abstract function GetNestedType(
nestedTypeName : String,
bindingFlags : BindingFlags
) : ITypeInfo

Implements

ITypeInfo.GetNestedType

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetNestedTypes Method

StaticTypeWrapper.GetNestedTypes Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetNestedTypes( _
ByVal bindingFlags As BindingFlags _
) As IList(Of ITypeInfo) _
Implements ITypeInfo.GetNestedTypes
C#
public abstract IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
C++
public:
IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
) abstract
J#
public abstract IList<ITypeInfo> GetNestedTypes(
BindingFlags bindingFlags
)
JScript
public abstract function GetNestedTypes(
bindingFlags : BindingFlags
) : IList<ITypeInfo>

Implements

ITypeInfo.GetNestedTypes

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetProperties Method

StaticTypeWrapper.GetProperties Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetProperties( _
ByVal bindingFlags As BindingFlags _
) As IList(Of IPropertyInfo) _
Implements ITypeInfo.GetProperties
C#
public abstract IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
C++
public:
IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
) abstract
J#
public abstract IList<IPropertyInfo> GetProperties(
BindingFlags bindingFlags
)
JScript
public abstract function GetProperties(
bindingFlags : BindingFlags
) : IList<IPropertyInfo>

Implements

ITypeInfo.GetProperties

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


GetProperty Method

StaticTypeWrapper.GetProperty Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetProperty( _
ByVal propertyName As String, _
ByVal bindingFlags As BindingFlags _
) As IPropertyInfo _
Implements ITypeInfo.GetProperty
C#
public abstract IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
C++
public:
IPropertyInfo GetProperty(
String propertyName,
BindingFlags bindingFlags
) abstract
J#
public abstract IPropertyInfo GetProperty(
string propertyName,
BindingFlags bindingFlags
)
JScript
public abstract function GetProperty(
propertyName : String,
bindingFlags : BindingFlags
) : IPropertyInfo

Implements

ITypeInfo.GetProperty

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsAssignableFrom Method

StaticTypeWrapper.IsAssignableFrom Method
[image]

Returns true if variables of this type can be assigned with values of the specified type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsAssignableFrom( _
ByVal type As ITypeInfo _
) As Boolean _
Implements ITypeInfo.IsAssignableFrom
C#
public bool IsAssignableFrom(
ITypeInfo type
)
C++
public:
bool IsAssignableFrom(
ITypeInfo type
) sealed
J#
public bool IsAssignableFrom(
ITypeInfo type
)
JScript
public function IsAssignableFrom(
type : ITypeInfo
) : bool

Parameters

type
The other type, or null if none

Return Value

True if the other type is not null and this type is assignable from the other type

Implements

ITypeInfo.IsAssignableFrom

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


IsSubclassOf Method

StaticTypeWrapper.IsSubclassOf Method
[image]

Returns true if this type is a subclass of the specified type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsSubclassOf( _
ByVal type As ITypeInfo _
) As Boolean _
Implements ITypeInfo.IsSubclassOf
C#
public bool IsSubclassOf(
ITypeInfo type
)
C++
public:
bool IsSubclassOf(
ITypeInfo type
) sealed
J#
public bool IsSubclassOf(
ITypeInfo type
)
JScript
public function IsSubclassOf(
type : ITypeInfo
) : bool

Parameters

type
The other type, or null if none

Return Value

True if the other type is not null, this type is a subclass of the other type, and this type not the same as the other type

Implements

ITypeInfo.IsSubclassOf

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


MakeArrayType Method

StaticTypeWrapper.MakeArrayType Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function MakeArrayType( _
ByVal arrayRank As Integer _
) As StaticArrayTypeWrapper
C#
public StaticArrayTypeWrapper MakeArrayType(
int arrayRank
)
C++
public:
StaticArrayTypeWrapper MakeArrayType(
int arrayRank
) sealed
J#
public StaticArrayTypeWrapper MakeArrayType(
int arrayRank
)
JScript
public function MakeArrayType(
arrayRank : int
) : StaticArrayTypeWrapper

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


MakeByRefType Method

StaticTypeWrapper.MakeByRefType Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function MakeByRefType() As StaticByRefTypeWrapper
C#
public StaticByRefTypeWrapper MakeByRefType()
C++
public:
StaticByRefTypeWrapper MakeByRefType() sealed
J#
public StaticByRefTypeWrapper MakeByRefType()
JScript
public function MakeByRefType() : StaticByRefTypeWrapper

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


MakeGenericType Method

StaticTypeWrapper.MakeGenericType Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function MakeGenericType( _
ByVal genericArguments As IList(Of ITypeInfo) _
) As StaticDeclaredTypeWrapper
C#
public virtual StaticDeclaredTypeWrapper MakeGenericType(
IList<ITypeInfo> genericArguments
)
C++
public:
virtual StaticDeclaredTypeWrapper MakeGenericType(
IList<ITypeInfo> genericArguments
)
J#
public virtual StaticDeclaredTypeWrapper MakeGenericType(
IList<ITypeInfo> genericArguments
)
JScript
public virtual function MakeGenericType(
genericArguments : IList<ITypeInfo>
) : StaticDeclaredTypeWrapper

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


MakePointerType Method

StaticTypeWrapper.MakePointerType Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function MakePointerType() As StaticPointerTypeWrapper
C#
public StaticPointerTypeWrapper MakePointerType()
C++
public:
StaticPointerTypeWrapper MakePointerType() sealed
J#
public StaticPointerTypeWrapper MakePointerType()
JScript
public function MakePointerType() : StaticPointerTypeWrapper

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method

StaticTypeWrapper.Resolve Method

Resolves the wrapper to its native reflection target.

Overload List

 | Name | Description
Public method | Resolve (Boolean) | Resolves the wrapper to its native reflection target.
Public method | Resolve (MethodInfo, Boolean) | Resolves the wrapper to its native reflection target within the scope of the specified method.

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


Resolve Method (Boolean)

StaticTypeWrapper.Resolve Method (Boolean)
See Also Example
[image]

Resolves the wrapper to its native reflection target.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal throwOnError As Boolean _
) As Type _
Implements ITypeInfo.Resolve
C#
public Type Resolve(
bool throwOnError
)
C++
public:
Type Resolve(
bool throwOnError
) sealed
J#
public Type Resolve(
bool throwOnError
)
JScript
public function Resolve(
throwOnError : bool
) : Type

Parameters

throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

ITypeInfo.Resolve

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticTypeWrapper.Resolve Overload List


Resolve Method (MethodInfo, Boolean)

StaticTypeWrapper.Resolve Method (MethodInfo, Boolean)
See Also Example
[image]

Resolves the wrapper to its native reflection target within the scope of the specified method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal methodContext As MethodInfo, _
ByVal throwOnError As Boolean _
) As Type _
Implements IResolvableTypeInfo.Resolve
C#
public Type Resolve(
MethodInfo methodContext,
bool throwOnError
)
C++
public:
Type Resolve(
MethodInfo methodContext,
bool throwOnError
) sealed
J#
public Type Resolve(
MethodInfo methodContext,
bool throwOnError
)
JScript
public function Resolve(
methodContext : MethodInfo,
throwOnError : bool
) : Type

Parameters

methodContext
The method that is currently in scope, or null if none. This parameter is used when resolving types that are part of the signature of a generic method so that generic method arguments can be handled correctly.
throwOnError
If true, throws an exception if the target could not be resolved, otherwise returns a reflection object that represents an unresolved member which may only support a subset of the usual operations

Return Value

The native reflection target

Implements

IResolvableTypeInfo.Resolve

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace
StaticTypeWrapper.Resolve Overload List


ResolveMemberInfo Method

StaticTypeWrapper.ResolveMemberInfo Method
[image]

Implementation of Resolve

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ResolveMemberInfo( _
ByVal throwOnError As Boolean _
) As MemberInfo
C#
protected override MemberInfo ResolveMemberInfo(
bool throwOnError
)
C++
protected:
virtual MemberInfo ResolveMemberInfo(
bool throwOnError
) override
J#
protected override MemberInfo ResolveMemberInfo(
bool throwOnError
)
JScript
protected override function ResolveMemberInfo(
throwOnError : bool
) : MemberInfo

See Also

StaticTypeWrapper Class
Gallio.Reflection.Impl Namespace


StaticWrapper Class

StaticWrapper Class
See Also Example Members
[image]

A StaticReflectionPolicy wrapper.

A wrapper holds an underlying reflection object. Its behavior is derived from by primitive operations on the Handle defined by the particular Policy implementation that is in use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class StaticWrapper
Implements IEquatable(Of StaticWrapper)
C#
public abstract class StaticWrapper : IEquatable<StaticWrapper>
C++
ref class StaticWrapper abstract : IEquatable<StaticWrapper>
J#
public class StaticWrapper implements IEquatable<StaticWrapper>
JScript
public class StaticWrapper extends IEquatable<StaticWrapper>

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.StaticWrapper
Gallio.Reflection.Impl.StaticAttributeWrapper
Gallio.Reflection.Impl.StaticCodeElementWrapper

See Also

StaticWrapper Members
Gallio.Reflection.Impl Namespace


StaticWrapper Members

StaticWrapper Members
See Also Example Constructors Properties Methods
[image]

A StaticReflectionPolicy wrapper.

A wrapper holds an underlying reflection object. Its behavior is derived from by primitive operations on the Handle defined by the particular Policy implementation that is in use.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by StaticWrapper.

Public Constructors

 | Name | Description
Public method | StaticWrapper | Creates a wrapper.
Top

Public Properties

 | Name | Description
Public property | Handle | Gets the underlying reflection object.
Public property | Policy | Gets the reflection policy.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


StaticWrapper Constructor

StaticWrapper Constructor
[image]

Creates a wrapper.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal policy As StaticReflectionPolicy, _
ByVal handle As Object _
)
C#
public StaticWrapper(
StaticReflectionPolicy policy,
object handle
)
C++
public:
StaticWrapper(
StaticReflectionPolicy policy,
Object handle
) sealed
J#
public StaticWrapper(
StaticReflectionPolicy policy,
object handle
)
JScript
public function StaticWrapper(
policy : StaticReflectionPolicy,
handle : Object
)

Parameters

policy
The reflection policy
handle
The underlying reflection object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if policy or handle is null

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


Properties

StaticWrapper Properties
[image]

Public Properties

 | Name | Description
Public property | Handle | Gets the underlying reflection object.
Public property | Policy | Gets the reflection policy.
Top

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


Handle Property

StaticWrapper.Handle Property
[image]

Gets the underlying reflection object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handle As Object
C#
public object Handle { get; }
C++
public property object Handle sealed {
Object get();
}
J#
/** property */
public object get_Handle();
JScript
public function get Handle() : Object

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


Policy Property

StaticWrapper.Policy Property
[image]

Gets the reflection policy.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Policy As StaticReflectionPolicy
C#
public StaticReflectionPolicy Policy { get; }
C++
public property StaticReflectionPolicy Policy sealed {
StaticReflectionPolicy get();
}
J#
/** property */
public StaticReflectionPolicy get_Policy();
JScript
public function get Policy() : StaticReflectionPolicy

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


Methods

StaticWrapper Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | EqualsByHandle | Compares the policy and handle of this wrapper with those of another using Equals.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method

StaticWrapper.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (StaticWrapper) |
Public method | Equals (Object) | Overridden.

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


Equals Method (StaticWrapper)

StaticWrapper.Equals Method (StaticWrapper)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As StaticWrapper _
) As Boolean _
Implements IEquatable<StaticWrapper>.Equals
C#
public bool Equals(
StaticWrapper other
)
C++
public:
bool Equals(
StaticWrapper other
) sealed
J#
public bool Equals(
StaticWrapper other
)
JScript
public function Equals(
other : StaticWrapper
) : bool

Implements

IEquatable<StaticWrapper>.Equals

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace
StaticWrapper.Equals Overload List


Equals Method (Object)

StaticWrapper.Equals Method (Object)
See Also Example
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace
StaticWrapper.Equals Overload List


EqualsByHandle Method

StaticWrapper.EqualsByHandle Method
[image]

Compares the policy and handle of this wrapper with those of another using Equals.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function EqualsByHandle( _
ByVal other As StaticWrapper _
) As Boolean
C#
protected bool EqualsByHandle(
StaticWrapper other
)
C++
protected:
bool EqualsByHandle(
StaticWrapper other
) sealed
J#
protected bool EqualsByHandle(
StaticWrapper other
)
JScript
protected function EqualsByHandle(
other : StaticWrapper
) : bool

Parameters

other
The other wrapper

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


GetHashCode Method

StaticWrapper.GetHashCode Method
[image]

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

StaticWrapper Class
Gallio.Reflection.Impl Namespace


UnresolvedConstructorInfo Class

UnresolvedConstructorInfo Class
See Also Example Members
[image]

Represents a ConstructorInfo whose native definition could not be resolved so we fall back on the IConstructorInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedConstructorInfo
Inherits ConstructorInfo
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedConstructorInfo : ConstructorInfo, IUnresolvedCodeElement
C++
ref class UnresolvedConstructorInfo sealed : ConstructorInfo, IUnresolvedCodeElement
J#
public final class UnresolvedConstructorInfo extends ConstructorInfo implements IUnresolvedCodeElement
JScript
public final class UnresolvedConstructorInfo extends ConstructorInfo, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.MemberInfo
System.Reflection.MethodBase
System.Reflection.ConstructorInfo
Gallio.Reflection.Impl.UnresolvedConstructorInfo

See Also

UnresolvedConstructorInfo Members
Gallio.Reflection.Impl Namespace


UnresolvedConstructorInfo Members

UnresolvedConstructorInfo Members
See Also Example Constructors Properties Methods
[image]

Represents a ConstructorInfo whose native definition could not be resolved so we fall back on the IConstructorInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedConstructorInfo.

Public Constructors

 | Name | Description
Public method | UnresolvedConstructorInfo | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes associated with this method.
Public property | CallingConvention | Overridden. Gets a value indicating the calling conventions for this method.
Public property | ContainsGenericParameters | Overridden. Gets a value indicating whether the generic method contains unassigned generic type parameters.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | IsAbstract | Gets a value indicating whether the method is abstract. (inherited from MethodBase)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from MethodBase)
Public property | IsConstructor | Gets a value indicating whether the method is a constructor. (inherited from MethodBase)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from MethodBase)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from MethodBase)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from MethodBase)
Public property | IsFinal | Gets a value indicating whether this method is final. (inherited from MethodBase)
Public property | IsGenericMethod | Overridden. Gets a value indicating whether the method is generic.
Public property | IsGenericMethodDefinition | Overridden. Gets a value indicating whether the method is a generic method definition.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from MethodBase)
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from MethodBase)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from MethodBase)
Public property | IsSpecialName | Gets a value indicating whether this method has a special name. (inherited from MethodBase)
Public property | IsStatic | Gets a value indicating whether the method is static. (inherited from MethodBase)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from MethodBase)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a constructor.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | MethodHandle | Overridden. Gets a handle to the internal metadata representation of a method.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetGenericArguments | Overridden. Returns an array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetMethodBody | Overridden. When overridden in a derived class, gets a MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.
Public method | GetMethodImplementationFlags | Overridden. When overridden in a derived class, returns the MethodImplAttributes flags.
Public method | GetParameters | Overridden. When overridden in a derived class, gets the parameters of the specified method or constructor.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Invoke | Overloaded. Invokes the constructor reflected by this instance.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedConstructorInfo Constructor

UnresolvedConstructorInfo Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As IConstructorInfo _
)
C#
public UnresolvedConstructorInfo(
IConstructorInfo adapter
)
C++
public:
UnresolvedConstructorInfo(
IConstructorInfo adapter
) sealed
J#
public UnresolvedConstructorInfo(
IConstructorInfo adapter
)
JScript
public function UnresolvedConstructorInfo(
adapter : IConstructorInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedConstructorInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes associated with this method.
Public property | CallingConvention | Overridden. Gets a value indicating the calling conventions for this method.
Public property | ContainsGenericParameters | Overridden. Gets a value indicating whether the generic method contains unassigned generic type parameters.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | IsAbstract | Gets a value indicating whether the method is abstract. (inherited from MethodBase)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from MethodBase)
Public property | IsConstructor | Gets a value indicating whether the method is a constructor. (inherited from MethodBase)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from MethodBase)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from MethodBase)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from MethodBase)
Public property | IsFinal | Gets a value indicating whether this method is final. (inherited from MethodBase)
Public property | IsGenericMethod | Overridden. Gets a value indicating whether the method is generic.
Public property | IsGenericMethodDefinition | Overridden. Gets a value indicating whether the method is a generic method definition.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from MethodBase)
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from MethodBase)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from MethodBase)
Public property | IsSpecialName | Gets a value indicating whether this method has a special name. (inherited from MethodBase)
Public property | IsStatic | Gets a value indicating whether the method is static. (inherited from MethodBase)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from MethodBase)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a constructor.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | MethodHandle | Overridden. Gets a handle to the internal metadata representation of a method.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedConstructorInfo.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As IConstructorInfo
C#
public IConstructorInfo Adapter { get; }
C++
public property IConstructorInfo Adapter sealed {
IConstructorInfo get();
}
J#
/** property */
public IConstructorInfo get_Adapter();
JScript
public function get Adapter() : IConstructorInfo

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Attributes Property

UnresolvedConstructorInfo.Attributes Property
[image]

Gets the attributes associated with this method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As MethodAttributes
C#
public override MethodAttributes Attributes { get; }
C++
public override property MethodAttributes Attributes override {
MethodAttributes get();
}
J#
/** property */
public MethodAttributes get_Attributes();
JScript
public function get Attributes() : MethodAttributes

Property Value

One of the MethodAttributes values.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


CallingConvention Property

UnresolvedConstructorInfo.CallingConvention Property
[image]

Gets a value indicating the calling conventions for this method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CallingConvention As CallingConventions
C#
public override CallingConventions CallingConvention { get; }
C++
public override property CallingConventions CallingConvention override {
CallingConventions get();
}
J#
/** property */
public CallingConventions get_CallingConvention();
JScript
public function get CallingConvention() : CallingConventions

Property Value

The CallingConventions for this method.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

UnresolvedConstructorInfo.ContainsGenericParameters Property
[image]

Gets a value indicating whether the generic method contains unassigned generic type parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContainsGenericParameters As Boolean
C#
public override bool ContainsGenericParameters { get; }
C++
public override property bool ContainsGenericParameters override {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Property Value

true if the current MethodBase object represents a generic method that contains unassigned generic type parameters; otherwise, false.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

UnresolvedConstructorInfo.DeclaringType Property
[image]

Gets the class that declares this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As Type
C#
public override Type DeclaringType { get; }
C++
public override property Type DeclaringType override {
Type get();
}
J#
/** property */
public Type get_DeclaringType();
JScript
public function get DeclaringType() : Type

Property Value

The Type object for the class that declares this member.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


IsGenericMethod Property

UnresolvedConstructorInfo.IsGenericMethod Property
[image]

Gets a value indicating whether the method is generic.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericMethod As Boolean
C#
public override bool IsGenericMethod { get; }
C++
public override property bool IsGenericMethod override {
bool get();
}
J#
/** property */
public bool get_IsGenericMethod();
JScript
public function get IsGenericMethod() : bool

Property Value

true if the current MethodBase represents a generic method; otherwise, false.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


IsGenericMethodDefinition Property

UnresolvedConstructorInfo.IsGenericMethodDefinition Property
[image]

Gets a value indicating whether the method is a generic method definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericMethodDefinition As Boolean
C#
public override bool IsGenericMethodDefinition { get; }
C++
public override property bool IsGenericMethodDefinition override {
bool get();
}
J#
/** property */
public bool get_IsGenericMethodDefinition();
JScript
public function get IsGenericMethodDefinition() : bool

Property Value

true if the current MethodBase object represents the definition of a generic method; otherwise, false.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


MemberType Property

UnresolvedConstructorInfo.MemberType Property
[image]

Gets a MemberTypes value indicating that this member is a constructor.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberType As MemberTypes
C#
public override MemberTypes MemberType { get; }
C++
public override property MemberTypes MemberType override {
MemberTypes get();
}
J#
/** property */
public MemberTypes get_MemberType();
JScript
public function get MemberType() : MemberTypes

Property Value

A MemberTypes value indicating that this member is a constructor.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


MetadataToken Property

UnresolvedConstructorInfo.MetadataToken Property
[image]

Gets a value that identifies a metadata element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MetadataToken As Integer
C#
public override int MetadataToken { get; }
C++
public override property int MetadataToken override {
int get();
}
J#
/** property */
public int get_MetadataToken();
JScript
public function get MetadataToken() : int

Property Value

A value which, in combination with Module, uniquely identifies a metadata element.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


MethodHandle Property

UnresolvedConstructorInfo.MethodHandle Property
[image]

Gets a handle to the internal metadata representation of a method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MethodHandle As RuntimeMethodHandle
C#
public override RuntimeMethodHandle MethodHandle { get; }
C++
public override property RuntimeMethodHandle MethodHandle override {
RuntimeMethodHandle get();
}
J#
/** property */
public RuntimeMethodHandle get_MethodHandle();
JScript
public function get MethodHandle() : RuntimeMethodHandle

Property Value

A RuntimeMethodHandle object.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Module Property

UnresolvedConstructorInfo.Module Property
[image]

Gets the module in which the type that declares the member represented by the current MemberInfo is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Module As Module
C#
public override Module Module { get; }
C++
public override property Module Module override {
Module get();
}
J#
/** property */
public Module get_Module();
JScript
public function get Module() : Module

Property Value

The Module in which the type that declares the member represented by the current MemberInfo is defined.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedConstructorInfo.Name Property
[image]

Gets the name of the current member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the name of this member.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

UnresolvedConstructorInfo.ReflectedType Property
[image]

Gets the class object that was used to obtain this instance of MemberInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As Type
C#
public override Type ReflectedType { get; }
C++
public override property Type ReflectedType override {
Type get();
}
J#
/** property */
public Type get_ReflectedType();
JScript
public function get ReflectedType() : Type

Property Value

The Type object through which this MemberInfo object was obtained.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedConstructorInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetGenericArguments | Overridden. Returns an array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetMethodBody | Overridden. When overridden in a derived class, gets a MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.
Public method | GetMethodImplementationFlags | Overridden. When overridden in a derived class, returns the MethodImplAttributes flags.
Public method | GetParameters | Overridden. When overridden in a derived class, gets the parameters of the specified method or constructor.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Invoke | Overloaded. Invokes the constructor reflected by this instance.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedConstructorInfo.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

UnresolvedConstructorInfo.GetCustomAttributes Method

When overridden in a derived class, returns all attributes applied to this member.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. When overridden in a derived class, returns an array containing all the custom attributes.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. When overridden in a derived class, returns an array of custom attributes identified by Type.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedConstructorInfo.GetCustomAttributes Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array containing all the custom attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array that contains all the custom attributes, or an array with zero elements if no attributes are defined.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedConstructorInfo.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedConstructorInfo.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array of custom attributes identified by Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The type of attribute to search for. Only attributes that are assignable to this type are returned.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array of custom attributes applied to this member, or an array with zero (0) elements if no attributes have been applied.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedConstructorInfo.GetCustomAttributes Overload List


GetGenericArguments Method

UnresolvedConstructorInfo.GetGenericArguments Method
[image]

Returns an array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGenericArguments() As Type()
C#
public override Type[] GetGenericArguments()
C++
public:
virtual array<Type>^ GetGenericArguments() override
J#
public override Type[] GetGenericArguments()
JScript
public override function GetGenericArguments() : Type[]

Return Value

An array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition. Returns an empty array if the current method is not a generic method.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


GetHashCode Method

UnresolvedConstructorInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


GetMethodBody Method

UnresolvedConstructorInfo.GetMethodBody Method
[image]

When overridden in a derived class, gets a MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethodBody() As MethodBody
C#
public override MethodBody GetMethodBody()
C++
public:
virtual MethodBody GetMethodBody() override
J#
public override MethodBody GetMethodBody()
JScript
public override function GetMethodBody() : MethodBody

Return Value

A MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


GetMethodImplementationFlags Method

UnresolvedConstructorInfo.GetMethodImplementationFlags Method
See Also Example
[image]

When overridden in a derived class, returns the MethodImplAttributes flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethodImplementationFlags() As MethodImplAttributes
C#
public override MethodImplAttributes GetMethodImplementationFlags()
C++
public:
virtual MethodImplAttributes GetMethodImplementationFlags() override
J#
public override MethodImplAttributes GetMethodImplementationFlags()
JScript
public override function GetMethodImplementationFlags() : MethodImplAttributes

Return Value

The MethodImplAttributes flags.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


GetParameters Method

UnresolvedConstructorInfo.GetParameters Method
[image]

When overridden in a derived class, gets the parameters of the specified method or constructor.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetParameters() As ParameterInfo()
C#
public override ParameterInfo[] GetParameters()
C++
public:
virtual array<ParameterInfo>^ GetParameters() override
J#
public override ParameterInfo[] GetParameters()
JScript
public override function GetParameters() : ParameterInfo[]

Return Value

An array of type ParameterInfo containing information that matches the signature of the method (or constructor) reflected by this MethodBase instance.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Invoke Method

UnresolvedConstructorInfo.Invoke Method

Invokes the constructor reflected by this instance.

Overload List

 | Name | Description
Public method | Invoke (Object, BindingFlags, Binder, Object, CultureInfo) | Overridden. When overridden in a derived class, invokes the reflected method or constructor with the given parameters.
Public method | Invoke (BindingFlags, Binder, Object, CultureInfo) | Overridden. When implemented in a derived class, invokes the constructor reflected by this ConstructorInfo with the specified arguments, under the constraints of the specified Binder.
Public method | Invoke (Object) | Invokes the constructor reflected by the instance that has the specified parameters, providing default values for the parameters not commonly used. (inherited from ConstructorInfo)
Public method | Invoke (Object, Object) | Invokes the method or constructor represented by the current instance, using the specified parameters. (inherited from MethodBase)

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


Invoke Method (Object, BindingFlags, Binder, Object[], CultureInfo)

UnresolvedConstructorInfo.Invoke Method (Object, BindingFlags, Binder, Object[], CultureInfo)
See Also Example
[image]

When overridden in a derived class, invokes the reflected method or constructor with the given parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Invoke( _
ByVal obj As Object, _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal parameters As Object(), _
ByVal culture As CultureInfo _
) As Object
C#
public override object Invoke(
object obj,
BindingFlags invokeAttr,
Binder binder,
object[] parameters,
CultureInfo culture
)
C++
public:
virtual Object Invoke(
Object obj,
BindingFlags invokeAttr,
Binder binder,
array<Object>^ parameters,
CultureInfo culture
) override
J#
public override object Invoke(
object obj,
BindingFlags invokeAttr,
Binder binder,
object[] parameters,
CultureInfo culture
)
JScript
public override function Invoke(
obj : Object,
invokeAttr : BindingFlags,
binder : Binder,
parameters : Object[],
culture : CultureInfo
) : Object

Parameters

obj
The object on which to invoke the method or constructor. If a method is static, this argument is ignored. If a constructor is static, this argument must be null or an instance of the class that defines the constructor.
invokeAttr
A bitmask that is a combination of 0 or more bit flags from BindingFlags. If binder is null, this parameter is assigned the value Default; thus, whatever you pass in is ignored.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used.
parameters
An argument list for the invoked method or constructor. This is an array of objects with the same number, order, and type as the parameters of the method or constructor to be invoked. If there are no parameters, this should be null.If the method or constructor represented by this instance takes a ByRef parameter, there is no special attribute required for that parameter in order to invoke the method or constructor using this function. Any object in this array that is not explicitly initialized with a value will contain the default value for that object type. For reference-type elements, this value is null. For value-type elements, this value is 0, 0.0, or false, depending on the specific element type.
culture
An instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread is used. (This is necessary to convert a String that represents 1000 to a Double value, for example, since 1000 is represented differently by different cultures.)

Return Value

An Object containing the return value of the invoked method, or null in the case of a constructor, or null if the method's return type is void. Before calling the method or constructor, Invoke checks to see if the user has access permission and verify that the parameters are valid.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedConstructorInfo.Invoke Overload List


Invoke Method (BindingFlags, Binder, Object[], CultureInfo)

UnresolvedConstructorInfo.Invoke Method (BindingFlags, Binder, Object[], CultureInfo)
See Also Example
[image]

When implemented in a derived class, invokes the constructor reflected by this ConstructorInfo with the specified arguments, under the constraints of the specified Binder.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Invoke( _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal parameters As Object(), _
ByVal culture As CultureInfo _
) As Object
C#
public override object Invoke(
BindingFlags invokeAttr,
Binder binder,
object[] parameters,
CultureInfo culture
)
C++
public:
virtual Object Invoke(
BindingFlags invokeAttr,
Binder binder,
array<Object>^ parameters,
CultureInfo culture
) override
J#
public override object Invoke(
BindingFlags invokeAttr,
Binder binder,
object[] parameters,
CultureInfo culture
)
JScript
public override function Invoke(
invokeAttr : BindingFlags,
binder : Binder,
parameters : Object[],
culture : CultureInfo
) : Object

Parameters

invokeAttr
One of the BindingFlags values that specifies the type of binding.
binder
A Binder that defines a set of properties and enables the binding, coercion of argument types, and invocation of members using reflection. If binder is null, then Binder.DefaultBinding is used.
parameters
An array of type Object used to match the number, order and type of the parameters for this constructor, under the constraints of binder. If this constructor does not require parameters, pass an array with zero elements, as in Object[] parameters = new Object[0]. Any object in this array that is not explicitly initialized with a value will contain the default value for that object type. For reference-type elements, this value is null. For value-type elements, this value is 0, 0.0, or false, depending on the specific element type.
culture
A CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread is used.

Return Value

An instance of the class associated with the constructor.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedConstructorInfo.Invoke Overload List


IsDefined Method

UnresolvedConstructorInfo.IsDefined Method
[image]

When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to which the custom attributes are applied.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

true if one or more instance of attributeType is applied to this member; otherwise false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


ToString Method

UnresolvedConstructorInfo.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

UnresolvedConstructorInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedEventInfo Class

UnresolvedEventInfo Class
See Also Example Members
[image]

Represents a EventInfo whose native definition could not be resolved so we fall back on the IEventInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedEventInfo
Inherits EventInfo
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedEventInfo : EventInfo, IUnresolvedCodeElement
C++
ref class UnresolvedEventInfo sealed : EventInfo, IUnresolvedCodeElement
J#
public final class UnresolvedEventInfo extends EventInfo implements IUnresolvedCodeElement
JScript
public final class UnresolvedEventInfo extends EventInfo, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.MemberInfo
System.Reflection.EventInfo
Gallio.Reflection.Impl.UnresolvedEventInfo

See Also

UnresolvedEventInfo Members
Gallio.Reflection.Impl Namespace


UnresolvedEventInfo Members

UnresolvedEventInfo Members
See Also Example Constructors Properties Methods
[image]

Represents a EventInfo whose native definition could not be resolved so we fall back on the IEventInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedEventInfo.

Public Constructors

 | Name | Description
Public method | UnresolvedEventInfo | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes for this event.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | EventHandlerType | Gets the Type object of the underlying event-handler delegate associated with this event. (inherited from EventInfo)
Public property | IsMulticast | Gets a value indicating whether the event is multicast. (inherited from EventInfo)
Public property | IsSpecialName | Gets a value indicating whether the EventInfo has a name with a special meaning. (inherited from EventInfo)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is an event.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

Public Methods

 | Name | Description
Public method | AddEventHandler | Adds an event handler to an event source. (inherited from EventInfo)
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetAddMethod | Overloaded. Returns the method used to add an event handler delegate to the event source.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetOtherMethods | Overloaded. Returns the methods that were associated with an event in MSIL using the .other directive.
Public method | GetRaiseMethod | Overloaded. Returns the method that is called when the event is raised.
Public method | GetRemoveMethod | Overloaded. Returns the method used to remove an event handler delegate from the event source.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | RemoveEventHandler | Removes an event handler from an event source. (inherited from EventInfo)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedEventInfo Constructor

UnresolvedEventInfo Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As IEventInfo _
)
C#
public UnresolvedEventInfo(
IEventInfo adapter
)
C++
public:
UnresolvedEventInfo(
IEventInfo adapter
) sealed
J#
public UnresolvedEventInfo(
IEventInfo adapter
)
JScript
public function UnresolvedEventInfo(
adapter : IEventInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedEventInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes for this event.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | EventHandlerType | Gets the Type object of the underlying event-handler delegate associated with this event. (inherited from EventInfo)
Public property | IsMulticast | Gets a value indicating whether the event is multicast. (inherited from EventInfo)
Public property | IsSpecialName | Gets a value indicating whether the EventInfo has a name with a special meaning. (inherited from EventInfo)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is an event.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedEventInfo.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As IEventInfo
C#
public IEventInfo Adapter { get; }
C++
public property IEventInfo Adapter sealed {
IEventInfo get();
}
J#
/** property */
public IEventInfo get_Adapter();
JScript
public function get Adapter() : IEventInfo

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Attributes Property

UnresolvedEventInfo.Attributes Property
[image]

Gets the attributes for this event.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As EventAttributes
C#
public override EventAttributes Attributes { get; }
C++
public override property EventAttributes Attributes override {
EventAttributes get();
}
J#
/** property */
public EventAttributes get_Attributes();
JScript
public function get Attributes() : EventAttributes

Property Value

The read-only attributes for this event.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

UnresolvedEventInfo.DeclaringType Property
[image]

Gets the class that declares this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As Type
C#
public override Type DeclaringType { get; }
C++
public override property Type DeclaringType override {
Type get();
}
J#
/** property */
public Type get_DeclaringType();
JScript
public function get DeclaringType() : Type

Property Value

The Type object for the class that declares this member.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


MemberType Property

UnresolvedEventInfo.MemberType Property
[image]

Gets a MemberTypes value indicating that this member is an event.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberType As MemberTypes
C#
public override MemberTypes MemberType { get; }
C++
public override property MemberTypes MemberType override {
MemberTypes get();
}
J#
/** property */
public MemberTypes get_MemberType();
JScript
public function get MemberType() : MemberTypes

Property Value

A MemberTypes value indicating that this member is an event.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


MetadataToken Property

UnresolvedEventInfo.MetadataToken Property
[image]

Gets a value that identifies a metadata element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MetadataToken As Integer
C#
public override int MetadataToken { get; }
C++
public override property int MetadataToken override {
int get();
}
J#
/** property */
public int get_MetadataToken();
JScript
public function get MetadataToken() : int

Property Value

A value which, in combination with Module, uniquely identifies a metadata element.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Module Property

UnresolvedEventInfo.Module Property
[image]

Gets the module in which the type that declares the member represented by the current MemberInfo is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Module As Module
C#
public override Module Module { get; }
C++
public override property Module Module override {
Module get();
}
J#
/** property */
public Module get_Module();
JScript
public function get Module() : Module

Property Value

The Module in which the type that declares the member represented by the current MemberInfo is defined.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedEventInfo.Name Property
[image]

Gets the name of the current member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the name of this member.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

UnresolvedEventInfo.ReflectedType Property
[image]

Gets the class object that was used to obtain this instance of MemberInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As Type
C#
public override Type ReflectedType { get; }
C++
public override property Type ReflectedType override {
Type get();
}
J#
/** property */
public Type get_ReflectedType();
JScript
public function get ReflectedType() : Type

Property Value

The Type object through which this MemberInfo object was obtained.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedEventInfo Methods
[image]

Public Methods

 | Name | Description
Public method | AddEventHandler | Adds an event handler to an event source. (inherited from EventInfo)
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetAddMethod | Overloaded. Returns the method used to add an event handler delegate to the event source.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetOtherMethods | Overloaded. Returns the methods that were associated with an event in MSIL using the .other directive.
Public method | GetRaiseMethod | Overloaded. Returns the method that is called when the event is raised.
Public method | GetRemoveMethod | Overloaded. Returns the method used to remove an event handler delegate from the event source.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | RemoveEventHandler | Removes an event handler from an event source. (inherited from EventInfo)
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedEventInfo.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetAddMethod Method

UnresolvedEventInfo.GetAddMethod Method

Returns the method used to add an event handler delegate to the event source.

Overload List

 | Name | Description
Public method | GetAddMethod (Boolean) | Overridden. When overridden in a derived class, retrieves the MethodInfo object for the AddEventHandler method of the event, specifying whether to return non-public methods.
Public method | GetAddMethod | Returns the method used to add an event handler delegate to the event source. (inherited from EventInfo)

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetAddMethod Method (Boolean)

UnresolvedEventInfo.GetAddMethod Method (Boolean)
See Also Example
[image]

When overridden in a derived class, retrieves the MethodInfo object for the AddEventHandler method of the event, specifying whether to return non-public methods.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetAddMethod( _
ByVal nonPublic As Boolean _
) As MethodInfo
C#
public override MethodInfo GetAddMethod(
bool nonPublic
)
C++
public:
virtual MethodInfo GetAddMethod(
bool nonPublic
) override
J#
public override MethodInfo GetAddMethod(
bool nonPublic
)
JScript
public override function GetAddMethod(
nonPublic : bool
) : MethodInfo

Parameters

nonPublic
true if non-public methods can be returned; otherwise, false.

Return Value

A MethodInfo object representing the method used to add an event handler delegate to the event source.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedEventInfo.GetAddMethod Overload List


GetCustomAttributes Method

UnresolvedEventInfo.GetCustomAttributes Method

When overridden in a derived class, returns all attributes applied to this member.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. When overridden in a derived class, returns an array containing all the custom attributes.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. When overridden in a derived class, returns an array of custom attributes identified by Type.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedEventInfo.GetCustomAttributes Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array containing all the custom attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array that contains all the custom attributes, or an array with zero elements if no attributes are defined.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedEventInfo.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedEventInfo.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array of custom attributes identified by Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The type of attribute to search for. Only attributes that are assignable to this type are returned.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array of custom attributes applied to this member, or an array with zero (0) elements if no attributes have been applied.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedEventInfo.GetCustomAttributes Overload List


GetHashCode Method

UnresolvedEventInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetOtherMethods Method

UnresolvedEventInfo.GetOtherMethods Method

Returns the methods that were associated with an event in MSIL using the .other directive.

Overload List

 | Name | Description
Public method | GetOtherMethods (Boolean) | Overridden. Returns the methods that have been associated with the event in metadata using the .other directive, specifying whether to include non-public methods.
Public method | GetOtherMethods | Returns the public methods that have been associated with an event in metadata using the .other directive. (inherited from EventInfo)

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetOtherMethods Method (Boolean)

UnresolvedEventInfo.GetOtherMethods Method (Boolean)
See Also Example
[image]

Returns the methods that have been associated with the event in metadata using the .other directive, specifying whether to include non-public methods.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetOtherMethods( _
ByVal nonPublic As Boolean _
) As MethodInfo()
C#
public override MethodInfo[] GetOtherMethods(
bool nonPublic
)
C++
public:
virtual array<MethodInfo>^ GetOtherMethods(
bool nonPublic
) override
J#
public override MethodInfo[] GetOtherMethods(
bool nonPublic
)
JScript
public override function GetOtherMethods(
nonPublic : bool
) : MethodInfo[]

Parameters

nonPublic
true to include non-public methods; otherwise, false.

Return Value

An array of EventInfo objects representing methods that have been associated with an event in metadata by using the .other directive. If there are no methods matching the specification, an empty array is returned.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedEventInfo.GetOtherMethods Overload List


GetRaiseMethod Method

UnresolvedEventInfo.GetRaiseMethod Method

Returns the method that is called when the event is raised.

Overload List

 | Name | Description
Public method | GetRaiseMethod (Boolean) | Overridden. When overridden in a derived class, returns the method that is called when the event is raised, specifying whether to return non-public methods.
Public method | GetRaiseMethod | Returns the method that is called when the event is raised. (inherited from EventInfo)

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetRaiseMethod Method (Boolean)

UnresolvedEventInfo.GetRaiseMethod Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns the method that is called when the event is raised, specifying whether to return non-public methods.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRaiseMethod( _
ByVal nonPublic As Boolean _
) As MethodInfo
C#
public override MethodInfo GetRaiseMethod(
bool nonPublic
)
C++
public:
virtual MethodInfo GetRaiseMethod(
bool nonPublic
) override
J#
public override MethodInfo GetRaiseMethod(
bool nonPublic
)
JScript
public override function GetRaiseMethod(
nonPublic : bool
) : MethodInfo

Parameters

nonPublic
true if non-public methods can be returned; otherwise, false.

Return Value

A MethodInfo object that was called when the event was raised.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedEventInfo.GetRaiseMethod Overload List


GetRemoveMethod Method

UnresolvedEventInfo.GetRemoveMethod Method

Returns the method used to remove an event handler delegate from the event source.

Overload List

 | Name | Description
Public method | GetRemoveMethod (Boolean) | Overridden. When overridden in a derived class, retrieves the MethodInfo object for removing a method of the event, specifying whether to return non-public methods.
Public method | GetRemoveMethod | Returns the method used to remove an event handler delegate from the event source. (inherited from EventInfo)

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


GetRemoveMethod Method (Boolean)

UnresolvedEventInfo.GetRemoveMethod Method (Boolean)
See Also Example
[image]

When overridden in a derived class, retrieves the MethodInfo object for removing a method of the event, specifying whether to return non-public methods.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRemoveMethod( _
ByVal nonPublic As Boolean _
) As MethodInfo
C#
public override MethodInfo GetRemoveMethod(
bool nonPublic
)
C++
public:
virtual MethodInfo GetRemoveMethod(
bool nonPublic
) override
J#
public override MethodInfo GetRemoveMethod(
bool nonPublic
)
JScript
public override function GetRemoveMethod(
nonPublic : bool
) : MethodInfo

Parameters

nonPublic
true if non-public methods can be returned; otherwise, false.

Return Value

A MethodInfo object representing the method used to remove an event handler delegate from the event source.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedEventInfo.GetRemoveMethod Overload List


IsDefined Method

UnresolvedEventInfo.IsDefined Method
[image]

When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to which the custom attributes are applied.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

true if one or more instance of attributeType is applied to this member; otherwise false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


ToString Method

UnresolvedEventInfo.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

UnresolvedEventInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedFieldInfo Class

UnresolvedFieldInfo Class
See Also Example Members
[image]

Represents a FieldInfo whose native definition could not be resolved so we fall back on the IFieldInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedFieldInfo
Inherits FieldInfo
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedFieldInfo : FieldInfo, IUnresolvedCodeElement
C++
ref class UnresolvedFieldInfo sealed : FieldInfo, IUnresolvedCodeElement
J#
public final class UnresolvedFieldInfo extends FieldInfo implements IUnresolvedCodeElement
JScript
public final class UnresolvedFieldInfo extends FieldInfo, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.MemberInfo
System.Reflection.FieldInfo
Gallio.Reflection.Impl.UnresolvedFieldInfo

See Also

UnresolvedFieldInfo Members
Gallio.Reflection.Impl Namespace


UnresolvedFieldInfo Members

UnresolvedFieldInfo Members
See Also Example Constructors Properties Methods
[image]

Represents a FieldInfo whose native definition could not be resolved so we fall back on the IFieldInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedFieldInfo.

Public Constructors

 | Name | Description
Public method | UnresolvedFieldInfo | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes associated with this field.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | FieldHandle | Overridden. Gets a RuntimeFieldHandle, which is a handle to the internal metadata representation of a field.
Public property | FieldType | Overridden. Gets the type of this field object.
Public property | IsAssembly | Gets a value indicating whether this field has Assembly level visibility. (inherited from FieldInfo)
Public property | IsFamily | Gets a value indicating whether this field has Family level visibility. (inherited from FieldInfo)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this field has FamilyAndAssembly level visibility. (inherited from FieldInfo)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this field has FamilyOrAssembly level visibility. (inherited from FieldInfo)
Public property | IsInitOnly | Gets a value indicating whether the field can only be set in the body of the constructor. (inherited from FieldInfo)
Public property | IsLiteral | Gets a value indicating whether the value is written at compile time and cannot be changed. (inherited from FieldInfo)
Public property | IsNotSerialized | Gets a value indicating whether this field has the NotSerialized attribute. (inherited from FieldInfo)
Public property | IsPinvokeImpl | Gets a value indicating whether the corresponding PinvokeImpl attribute is set in FieldAttributes. (inherited from FieldInfo)
Public property | IsPrivate | Gets a value indicating whether the field is private. (inherited from FieldInfo)
Public property | IsPublic | Gets a value indicating whether the field is public. (inherited from FieldInfo)
Public property | IsSpecialName | Gets a value indicating whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator. (inherited from FieldInfo)
Public property | IsStatic | Gets a value indicating whether the field is static. (inherited from FieldInfo)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a field.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetOptionalCustomModifiers | Overridden. Gets an array of types that identify the optional custom modifiers of the field.
Public method | GetRawConstantValue | Overridden. Returns a literal value associated with the field by a compiler.
Public method | GetRequiredCustomModifiers | Overridden. Gets an array of types that identify the required custom modifiers of the property.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Overridden. When overridden in a derived class, returns the value of a field supported by a given object.
Public method | GetValueDirect | Overridden. Returns the value of a field supported by a given object.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | SetValue | Overloaded. Sets the value of the field for the given object to the given value.
Public method | SetValueDirect | Overridden. Sets the value of the field supported by the given object.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedFieldInfo Constructor

UnresolvedFieldInfo Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As IFieldInfo _
)
C#
public UnresolvedFieldInfo(
IFieldInfo adapter
)
C++
public:
UnresolvedFieldInfo(
IFieldInfo adapter
) sealed
J#
public UnresolvedFieldInfo(
IFieldInfo adapter
)
JScript
public function UnresolvedFieldInfo(
adapter : IFieldInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedFieldInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes associated with this field.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | FieldHandle | Overridden. Gets a RuntimeFieldHandle, which is a handle to the internal metadata representation of a field.
Public property | FieldType | Overridden. Gets the type of this field object.
Public property | IsAssembly | Gets a value indicating whether this field has Assembly level visibility. (inherited from FieldInfo)
Public property | IsFamily | Gets a value indicating whether this field has Family level visibility. (inherited from FieldInfo)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this field has FamilyAndAssembly level visibility. (inherited from FieldInfo)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this field has FamilyOrAssembly level visibility. (inherited from FieldInfo)
Public property | IsInitOnly | Gets a value indicating whether the field can only be set in the body of the constructor. (inherited from FieldInfo)
Public property | IsLiteral | Gets a value indicating whether the value is written at compile time and cannot be changed. (inherited from FieldInfo)
Public property | IsNotSerialized | Gets a value indicating whether this field has the NotSerialized attribute. (inherited from FieldInfo)
Public property | IsPinvokeImpl | Gets a value indicating whether the corresponding PinvokeImpl attribute is set in FieldAttributes. (inherited from FieldInfo)
Public property | IsPrivate | Gets a value indicating whether the field is private. (inherited from FieldInfo)
Public property | IsPublic | Gets a value indicating whether the field is public. (inherited from FieldInfo)
Public property | IsSpecialName | Gets a value indicating whether the corresponding SpecialName attribute is set in the FieldAttributes enumerator. (inherited from FieldInfo)
Public property | IsStatic | Gets a value indicating whether the field is static. (inherited from FieldInfo)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a field.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedFieldInfo.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As IFieldInfo
C#
public IFieldInfo Adapter { get; }
C++
public property IFieldInfo Adapter sealed {
IFieldInfo get();
}
J#
/** property */
public IFieldInfo get_Adapter();
JScript
public function get Adapter() : IFieldInfo

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Attributes Property

UnresolvedFieldInfo.Attributes Property
[image]

Gets the attributes associated with this field.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As FieldAttributes
C#
public override FieldAttributes Attributes { get; }
C++
public override property FieldAttributes Attributes override {
FieldAttributes get();
}
J#
/** property */
public FieldAttributes get_Attributes();
JScript
public function get Attributes() : FieldAttributes

Property Value

The FieldAttributes for this field.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

UnresolvedFieldInfo.DeclaringType Property
[image]

Gets the class that declares this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As Type
C#
public override Type DeclaringType { get; }
C++
public override property Type DeclaringType override {
Type get();
}
J#
/** property */
public Type get_DeclaringType();
JScript
public function get DeclaringType() : Type

Property Value

The Type object for the class that declares this member.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


FieldHandle Property

UnresolvedFieldInfo.FieldHandle Property
[image]

Gets a RuntimeFieldHandle, which is a handle to the internal metadata representation of a field.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FieldHandle As RuntimeFieldHandle
C#
public override RuntimeFieldHandle FieldHandle { get; }
C++
public override property RuntimeFieldHandle FieldHandle override {
RuntimeFieldHandle get();
}
J#
/** property */
public RuntimeFieldHandle get_FieldHandle();
JScript
public function get FieldHandle() : RuntimeFieldHandle

Property Value

A handle to the internal metadata representation of a field.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


FieldType Property

UnresolvedFieldInfo.FieldType Property
[image]

Gets the type of this field object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FieldType As Type
C#
public override Type FieldType { get; }
C++
public override property Type FieldType override {
Type get();
}
J#
/** property */
public Type get_FieldType();
JScript
public function get FieldType() : Type

Property Value

The type of this field object.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


MemberType Property

UnresolvedFieldInfo.MemberType Property
[image]

Gets a MemberTypes value indicating that this member is a field.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberType As MemberTypes
C#
public override MemberTypes MemberType { get; }
C++
public override property MemberTypes MemberType override {
MemberTypes get();
}
J#
/** property */
public MemberTypes get_MemberType();
JScript
public function get MemberType() : MemberTypes

Property Value

A MemberTypes value indicating that this member is a field.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


MetadataToken Property

UnresolvedFieldInfo.MetadataToken Property
[image]

Gets a value that identifies a metadata element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MetadataToken As Integer
C#
public override int MetadataToken { get; }
C++
public override property int MetadataToken override {
int get();
}
J#
/** property */
public int get_MetadataToken();
JScript
public function get MetadataToken() : int

Property Value

A value which, in combination with Module, uniquely identifies a metadata element.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Module Property

UnresolvedFieldInfo.Module Property
[image]

Gets the module in which the type that declares the member represented by the current MemberInfo is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Module As Module
C#
public override Module Module { get; }
C++
public override property Module Module override {
Module get();
}
J#
/** property */
public Module get_Module();
JScript
public function get Module() : Module

Property Value

The Module in which the type that declares the member represented by the current MemberInfo is defined.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedFieldInfo.Name Property
[image]

Gets the name of the current member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the name of this member.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

UnresolvedFieldInfo.ReflectedType Property
[image]

Gets the class object that was used to obtain this instance of MemberInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As Type
C#
public override Type ReflectedType { get; }
C++
public override property Type ReflectedType override {
Type get();
}
J#
/** property */
public Type get_ReflectedType();
JScript
public function get ReflectedType() : Type

Property Value

The Type object through which this MemberInfo object was obtained.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedFieldInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetOptionalCustomModifiers | Overridden. Gets an array of types that identify the optional custom modifiers of the field.
Public method | GetRawConstantValue | Overridden. Returns a literal value associated with the field by a compiler.
Public method | GetRequiredCustomModifiers | Overridden. Gets an array of types that identify the required custom modifiers of the property.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Overridden. When overridden in a derived class, returns the value of a field supported by a given object.
Public method | GetValueDirect | Overridden. Returns the value of a field supported by a given object.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | SetValue | Overloaded. Sets the value of the field for the given object to the given value.
Public method | SetValueDirect | Overridden. Sets the value of the field supported by the given object.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedFieldInfo.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

UnresolvedFieldInfo.GetCustomAttributes Method

When overridden in a derived class, returns all attributes applied to this member.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. When overridden in a derived class, returns an array containing all the custom attributes.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. When overridden in a derived class, returns an array of custom attributes identified by Type.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedFieldInfo.GetCustomAttributes Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array containing all the custom attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array that contains all the custom attributes, or an array with zero elements if no attributes are defined.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedFieldInfo.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedFieldInfo.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array of custom attributes identified by Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The type of attribute to search for. Only attributes that are assignable to this type are returned.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array of custom attributes applied to this member, or an array with zero (0) elements if no attributes have been applied.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedFieldInfo.GetCustomAttributes Overload List


GetHashCode Method

UnresolvedFieldInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetOptionalCustomModifiers Method

UnresolvedFieldInfo.GetOptionalCustomModifiers Method
[image]

Gets an array of types that identify the optional custom modifiers of the field.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetOptionalCustomModifiers() As Type()
C#
public override Type[] GetOptionalCustomModifiers()
C++
public:
virtual array<Type>^ GetOptionalCustomModifiers() override
J#
public override Type[] GetOptionalCustomModifiers()
JScript
public override function GetOptionalCustomModifiers() : Type[]

Return Value

An array of Type objects that identify the optional custom modifiers of the current field, such as IsConst or IsImplicitlyDeferenced.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetRawConstantValue Method

UnresolvedFieldInfo.GetRawConstantValue Method
[image]

Returns a literal value associated with the field by a compiler.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRawConstantValue() As Object
C#
public override object GetRawConstantValue()
C++
public:
virtual Object GetRawConstantValue() override
J#
public override object GetRawConstantValue()
JScript
public override function GetRawConstantValue() : Object

Return Value

An Object that contains the literal value associated with the field. If the literal value is a class type with an element value of zero, the return value is null.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetRequiredCustomModifiers Method

UnresolvedFieldInfo.GetRequiredCustomModifiers Method
[image]

Gets an array of types that identify the required custom modifiers of the property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRequiredCustomModifiers() As Type()
C#
public override Type[] GetRequiredCustomModifiers()
C++
public:
virtual array<Type>^ GetRequiredCustomModifiers() override
J#
public override Type[] GetRequiredCustomModifiers()
JScript
public override function GetRequiredCustomModifiers() : Type[]

Return Value

An array of Type objects that identify the required custom modifiers of the current property, such as IsConst or IsImplicitlyDeferenced.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetValue Method

UnresolvedFieldInfo.GetValue Method
[image]

When overridden in a derived class, returns the value of a field supported by a given object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetValue( _
ByVal obj As Object _
) As Object
C#
public override object GetValue(
object obj
)
C++
public:
virtual Object GetValue(
Object obj
) override
J#
public override object GetValue(
object obj
)
JScript
public override function GetValue(
obj : Object
) : Object

Parameters

obj
The object whose field value will be returned.

Return Value

An object containing the value of the field reflected by this instance.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


GetValueDirect Method

UnresolvedFieldInfo.GetValueDirect Method
[image]

Returns the value of a field supported by a given object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)>
Public Overrides Function GetValueDirect( _
ByVal obj As TypedReference _
) As Object
C#
[CLSCompliantAttribute(False)]
public override object GetValueDirect(
TypedReference obj
)
C++
[CLSCompliantAttribute(False)]
public:
virtual Object GetValueDirect(
TypedReference obj
) override
J#
/** @attribute CLSCompliantAttribute(False) */
public override object GetValueDirect(
TypedReference obj
)
JScript
public override

CLSCompliantAttribute(False)
function GetValueDirect(
obj : TypedReference
) : Object

Parameters

obj
A TypedReference structure that encapsulates a managed pointer to a location and a runtime representation of the type that might be stored at that location.

Return Value

An Object containing a field value.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


IsDefined Method

UnresolvedFieldInfo.IsDefined Method
[image]

When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to which the custom attributes are applied.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

true if one or more instance of attributeType is applied to this member; otherwise false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


SetValue Method

UnresolvedFieldInfo.SetValue Method

Sets the value of the field for the given object to the given value.

Overload List

 | Name | Description
Public method | SetValue (Object, Object, BindingFlags, Binder, CultureInfo) | Overridden. When overridden in a derived class, sets the value of the field supported by the given object.
Public method | SetValue (Object, Object) | Sets the value of the field supported by the given object. (inherited from FieldInfo)

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


SetValue Method (Object, Object, BindingFlags, Binder, CultureInfo)

UnresolvedFieldInfo.SetValue Method (Object, Object, BindingFlags, Binder, CultureInfo)
See Also Example
[image]

When overridden in a derived class, sets the value of the field supported by the given object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetValue( _
ByVal obj As Object, _
ByVal value As Object, _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal culture As CultureInfo _
)
C#
public override void SetValue(
object obj,
object value,
BindingFlags invokeAttr,
Binder binder,
CultureInfo culture
)
C++
public:
virtual void SetValue(
Object obj,
Object value,
BindingFlags invokeAttr,
Binder binder,
CultureInfo culture
) override
J#
public override void SetValue(
object obj,
object value,
BindingFlags invokeAttr,
Binder binder,
CultureInfo culture
)
JScript
public override function SetValue(
obj : Object,
value : Object,
invokeAttr : BindingFlags,
binder : Binder,
culture : CultureInfo
)

Parameters

obj
The object whose field value will be set.
value
The value to assign to the field.
invokeAttr
A field of Binder that specifies the type of binding that is desired (for example, Binder.CreateInstance or Binder.ExactBinding).
binder
A set of properties that enables the binding, coercion of argument types, and invocation of members through reflection. If binder is null, then Binder.DefaultBinding is used.
culture
The software preferences of a particular culture.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedFieldInfo.SetValue Overload List


SetValueDirect Method

UnresolvedFieldInfo.SetValueDirect Method
[image]

Sets the value of the field supported by the given object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)>
Public Overrides Sub SetValueDirect( _
ByVal obj As TypedReference, _
ByVal value As Object _
)
C#
[CLSCompliantAttribute(False)]
public override void SetValueDirect(
TypedReference obj,
object value
)
C++
[CLSCompliantAttribute(False)]
public:
virtual void SetValueDirect(
TypedReference obj,
Object value
) override
J#
/** @attribute CLSCompliantAttribute(False) */
public override void SetValueDirect(
TypedReference obj,
object value
)
JScript
public override

CLSCompliantAttribute(False)
function SetValueDirect(
obj : TypedReference,
value : Object
)

Parameters

obj
A TypedReference structure that encapsulates a managed pointer to a location and a runtime representation of the type that can be stored at that location.
value
The value to assign to the field.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


ToString Method

UnresolvedFieldInfo.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

UnresolvedFieldInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedMethodInfo Class

UnresolvedMethodInfo Class
See Also Example Members
[image]

Represents a MethodInfo whose native definition could not be resolved so we fall back on the IMethodInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedMethodInfo
Inherits MethodInfo
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedMethodInfo : MethodInfo, IUnresolvedCodeElement
C++
ref class UnresolvedMethodInfo sealed : MethodInfo, IUnresolvedCodeElement
J#
public final class UnresolvedMethodInfo extends MethodInfo implements IUnresolvedCodeElement
JScript
public final class UnresolvedMethodInfo extends MethodInfo, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.MemberInfo
System.Reflection.MethodBase
System.Reflection.MethodInfo
Gallio.Reflection.Impl.UnresolvedMethodInfo

See Also

UnresolvedMethodInfo Members
Gallio.Reflection.Impl Namespace


UnresolvedMethodInfo Members

UnresolvedMethodInfo Members
See Also Example Constructors Properties Methods
[image]

Represents a MethodInfo whose native definition could not be resolved so we fall back on the IMethodInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedMethodInfo.

Public Constructors

 | Name | Description
Public method | UnresolvedMethodInfo | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes associated with this method.
Public property | CallingConvention | Overridden. Gets a value indicating the calling conventions for this method.
Public property | ContainsGenericParameters | Overridden. Gets a value indicating whether a generic method contains unassigned generic type parameters.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | IsAbstract | Gets a value indicating whether the method is abstract. (inherited from MethodBase)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from MethodBase)
Public property | IsConstructor | Gets a value indicating whether the method is a constructor. (inherited from MethodBase)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from MethodBase)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from MethodBase)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from MethodBase)
Public property | IsFinal | Gets a value indicating whether this method is final. (inherited from MethodBase)
Public property | IsGenericMethod | Overridden. Gets a value indicating whether the current method is a generic method.
Public property | IsGenericMethodDefinition | Overridden. Gets a value indicating whether the current MethodInfo represents the definition of a generic method.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from MethodBase)
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from MethodBase)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from MethodBase)
Public property | IsSpecialName | Gets a value indicating whether this method has a special name. (inherited from MethodBase)
Public property | IsStatic | Gets a value indicating whether the method is static. (inherited from MethodBase)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from MethodBase)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a method.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | MethodHandle | Overridden. Gets a handle to the internal metadata representation of a method.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Public property | ReturnParameter | Overridden. Gets a ParameterInfo object that contains information about the return type of the method, such as whether the return type has custom modifiers.
Public property | ReturnType | Overridden. Gets the return type of this method.
Public property | ReturnTypeCustomAttributes | Overridden. Gets the custom attributes for the return type.
Top

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetBaseDefinition | Overridden. When overridden in a derived class, returns the MethodInfo object for the method on the direct or indirect base class in which the method represented by this instance was first declared.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetGenericArguments | Overridden. Returns an array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition.
Public method | GetGenericMethodDefinition | Overridden. Returns a MethodInfo object that represents a generic method definition from which the current method can be constructed.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetMethodBody | Overridden. When overridden in a derived class, gets a MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.
Public method | GetMethodImplementationFlags | Overridden. When overridden in a derived class, returns the MethodImplAttributes flags.
Public method | GetParameters | Overridden. When overridden in a derived class, gets the parameters of the specified method or constructor.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Invoke | Overloaded. Invokes the method or constructor reflected by this MethodInfo instance.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | MakeGenericMethod | Overridden. Substitutes the elements of an array of types for the type parameters of the current generic method definition, and returns a MethodInfo object representing the resulting constructed method.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedMethodInfo Constructor

UnresolvedMethodInfo Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As IMethodInfo _
)
C#
public UnresolvedMethodInfo(
IMethodInfo adapter
)
C++
public:
UnresolvedMethodInfo(
IMethodInfo adapter
) sealed
J#
public UnresolvedMethodInfo(
IMethodInfo adapter
)
JScript
public function UnresolvedMethodInfo(
adapter : IMethodInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedMethodInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes associated with this method.
Public property | CallingConvention | Overridden. Gets a value indicating the calling conventions for this method.
Public property | ContainsGenericParameters | Overridden. Gets a value indicating whether a generic method contains unassigned generic type parameters.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | IsAbstract | Gets a value indicating whether the method is abstract. (inherited from MethodBase)
Public property | IsAssembly | Gets a value indicating whether this method can be called by other classes in the same assembly. (inherited from MethodBase)
Public property | IsConstructor | Gets a value indicating whether the method is a constructor. (inherited from MethodBase)
Public property | IsFamily | Gets a value indicating whether access to this method is restricted to members of the class and members of its derived classes. (inherited from MethodBase)
Public property | IsFamilyAndAssembly | Gets a value indicating whether this method can be called by derived classes if they are in the same assembly. (inherited from MethodBase)
Public property | IsFamilyOrAssembly | Gets a value indicating whether this method can be called by derived classes, wherever they are, and by all classes in the same assembly. (inherited from MethodBase)
Public property | IsFinal | Gets a value indicating whether this method is final. (inherited from MethodBase)
Public property | IsGenericMethod | Overridden. Gets a value indicating whether the current method is a generic method.
Public property | IsGenericMethodDefinition | Overridden. Gets a value indicating whether the current MethodInfo represents the definition of a generic method.
Public property | IsHideBySig | Gets a value indicating whether only a member of the same kind with exactly the same signature is hidden in the derived class. (inherited from MethodBase)
Public property | IsPrivate | Gets a value indicating whether this member is private. (inherited from MethodBase)
Public property | IsPublic | Gets a value indicating whether this is a public method. (inherited from MethodBase)
Public property | IsSpecialName | Gets a value indicating whether this method has a special name. (inherited from MethodBase)
Public property | IsStatic | Gets a value indicating whether the method is static. (inherited from MethodBase)
Public property | IsVirtual | Gets a value indicating whether the method is virtual. (inherited from MethodBase)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a method.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | MethodHandle | Overridden. Gets a handle to the internal metadata representation of a method.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Public property | ReturnParameter | Overridden. Gets a ParameterInfo object that contains information about the return type of the method, such as whether the return type has custom modifiers.
Public property | ReturnType | Overridden. Gets the return type of this method.
Public property | ReturnTypeCustomAttributes | Overridden. Gets the custom attributes for the return type.
Top

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedMethodInfo.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As IMethodInfo
C#
public IMethodInfo Adapter { get; }
C++
public property IMethodInfo Adapter sealed {
IMethodInfo get();
}
J#
/** property */
public IMethodInfo get_Adapter();
JScript
public function get Adapter() : IMethodInfo

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Attributes Property

UnresolvedMethodInfo.Attributes Property
[image]

Gets the attributes associated with this method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As MethodAttributes
C#
public override MethodAttributes Attributes { get; }
C++
public override property MethodAttributes Attributes override {
MethodAttributes get();
}
J#
/** property */
public MethodAttributes get_Attributes();
JScript
public function get Attributes() : MethodAttributes

Property Value

One of the MethodAttributes values.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


CallingConvention Property

UnresolvedMethodInfo.CallingConvention Property
[image]

Gets a value indicating the calling conventions for this method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CallingConvention As CallingConventions
C#
public override CallingConventions CallingConvention { get; }
C++
public override property CallingConventions CallingConvention override {
CallingConventions get();
}
J#
/** property */
public CallingConventions get_CallingConvention();
JScript
public function get CallingConvention() : CallingConventions

Property Value

The CallingConventions for this method.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

UnresolvedMethodInfo.ContainsGenericParameters Property
[image]

Gets a value indicating whether a generic method contains unassigned generic type parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContainsGenericParameters As Boolean
C#
public override bool ContainsGenericParameters { get; }
C++
public override property bool ContainsGenericParameters override {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Property Value

true if the current MethodInfo contains unassigned generic type parameters; otherwise, false.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

UnresolvedMethodInfo.DeclaringType Property
[image]

Gets the class that declares this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As Type
C#
public override Type DeclaringType { get; }
C++
public override property Type DeclaringType override {
Type get();
}
J#
/** property */
public Type get_DeclaringType();
JScript
public function get DeclaringType() : Type

Property Value

The Type object for the class that declares this member.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


IsGenericMethod Property

UnresolvedMethodInfo.IsGenericMethod Property
[image]

Gets a value indicating whether the current method is a generic method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericMethod As Boolean
C#
public override bool IsGenericMethod { get; }
C++
public override property bool IsGenericMethod override {
bool get();
}
J#
/** property */
public bool get_IsGenericMethod();
JScript
public function get IsGenericMethod() : bool

Property Value

true if the current method is a generic method; otherwise, false.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


IsGenericMethodDefinition Property

UnresolvedMethodInfo.IsGenericMethodDefinition Property
[image]

Gets a value indicating whether the current MethodInfo represents the definition of a generic method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericMethodDefinition As Boolean
C#
public override bool IsGenericMethodDefinition { get; }
C++
public override property bool IsGenericMethodDefinition override {
bool get();
}
J#
/** property */
public bool get_IsGenericMethodDefinition();
JScript
public function get IsGenericMethodDefinition() : bool

Property Value

true if the MethodInfo object represents the definition of a generic method; otherwise, false.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


MemberType Property

UnresolvedMethodInfo.MemberType Property
[image]

Gets a MemberTypes value indicating that this member is a method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberType As MemberTypes
C#
public override MemberTypes MemberType { get; }
C++
public override property MemberTypes MemberType override {
MemberTypes get();
}
J#
/** property */
public MemberTypes get_MemberType();
JScript
public function get MemberType() : MemberTypes

Property Value

A MemberTypes value indicating that this member is a method.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


MetadataToken Property

UnresolvedMethodInfo.MetadataToken Property
[image]

Gets a value that identifies a metadata element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MetadataToken As Integer
C#
public override int MetadataToken { get; }
C++
public override property int MetadataToken override {
int get();
}
J#
/** property */
public int get_MetadataToken();
JScript
public function get MetadataToken() : int

Property Value

A value which, in combination with Module, uniquely identifies a metadata element.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


MethodHandle Property

UnresolvedMethodInfo.MethodHandle Property
[image]

Gets a handle to the internal metadata representation of a method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MethodHandle As RuntimeMethodHandle
C#
public override RuntimeMethodHandle MethodHandle { get; }
C++
public override property RuntimeMethodHandle MethodHandle override {
RuntimeMethodHandle get();
}
J#
/** property */
public RuntimeMethodHandle get_MethodHandle();
JScript
public function get MethodHandle() : RuntimeMethodHandle

Property Value

A RuntimeMethodHandle object.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Module Property

UnresolvedMethodInfo.Module Property
[image]

Gets the module in which the type that declares the member represented by the current MemberInfo is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Module As Module
C#
public override Module Module { get; }
C++
public override property Module Module override {
Module get();
}
J#
/** property */
public Module get_Module();
JScript
public function get Module() : Module

Property Value

The Module in which the type that declares the member represented by the current MemberInfo is defined.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedMethodInfo.Name Property
[image]

Gets the name of the current member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the name of this member.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

UnresolvedMethodInfo.ReflectedType Property
[image]

Gets the class object that was used to obtain this instance of MemberInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As Type
C#
public override Type ReflectedType { get; }
C++
public override property Type ReflectedType override {
Type get();
}
J#
/** property */
public Type get_ReflectedType();
JScript
public function get ReflectedType() : Type

Property Value

The Type object through which this MemberInfo object was obtained.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


ReturnParameter Property

UnresolvedMethodInfo.ReturnParameter Property
[image]

Gets a ParameterInfo object that contains information about the return type of the method, such as whether the return type has custom modifiers.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReturnParameter As ParameterInfo
C#
public override ParameterInfo ReturnParameter { get; }
C++
public override property ParameterInfo ReturnParameter override {
ParameterInfo get();
}
J#
/** property */
public ParameterInfo get_ReturnParameter();
JScript
public function get ReturnParameter() : ParameterInfo

Property Value

A ParameterInfo object that contains information about the return type.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


ReturnType Property

UnresolvedMethodInfo.ReturnType Property
[image]

Gets the return type of this method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReturnType As Type
C#
public override Type ReturnType { get; }
C++
public override property Type ReturnType override {
Type get();
}
J#
/** property */
public Type get_ReturnType();
JScript
public function get ReturnType() : Type

Property Value

The return type of this method.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


ReturnTypeCustomAttributes Property

UnresolvedMethodInfo.ReturnTypeCustomAttributes Property
[image]

Gets the custom attributes for the return type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReturnTypeCustomAttributes As ICustomAttributeProvider
C#
public override ICustomAttributeProvider ReturnTypeCustomAttributes { get; }
C++
public override property ICustomAttributeProvider ReturnTypeCustomAttributes override {
ICustomAttributeProvider get();
}
J#
/** property */
public ICustomAttributeProvider get_ReturnTypeCustomAttributes();
JScript
public function get ReturnTypeCustomAttributes() : ICustomAttributeProvider

Property Value

An ICustomAttributeProvider object representing the custom attributes for the return type.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedMethodInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetBaseDefinition | Overridden. When overridden in a derived class, returns the MethodInfo object for the method on the direct or indirect base class in which the method represented by this instance was first declared.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetGenericArguments | Overridden. Returns an array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition.
Public method | GetGenericMethodDefinition | Overridden. Returns a MethodInfo object that represents a generic method definition from which the current method can be constructed.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetMethodBody | Overridden. When overridden in a derived class, gets a MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.
Public method | GetMethodImplementationFlags | Overridden. When overridden in a derived class, returns the MethodImplAttributes flags.
Public method | GetParameters | Overridden. When overridden in a derived class, gets the parameters of the specified method or constructor.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Invoke | Overloaded. Invokes the method or constructor reflected by this MethodInfo instance.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | MakeGenericMethod | Overridden. Substitutes the elements of an array of types for the type parameters of the current generic method definition, and returns a MethodInfo object representing the resulting constructed method.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedMethodInfo.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetBaseDefinition Method

UnresolvedMethodInfo.GetBaseDefinition Method
[image]

When overridden in a derived class, returns the MethodInfo object for the method on the direct or indirect base class in which the method represented by this instance was first declared.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetBaseDefinition() As MethodInfo
C#
public override MethodInfo GetBaseDefinition()
C++
public:
virtual MethodInfo GetBaseDefinition() override
J#
public override MethodInfo GetBaseDefinition()
JScript
public override function GetBaseDefinition() : MethodInfo

Return Value

A MethodInfo object for the first implementation of this method.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

UnresolvedMethodInfo.GetCustomAttributes Method

When overridden in a derived class, returns all attributes applied to this member.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. When overridden in a derived class, returns an array containing all the custom attributes.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. When overridden in a derived class, returns an array of custom attributes identified by Type.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedMethodInfo.GetCustomAttributes Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array containing all the custom attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array that contains all the custom attributes, or an array with zero elements if no attributes are defined.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedMethodInfo.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedMethodInfo.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array of custom attributes identified by Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The type of attribute to search for. Only attributes that are assignable to this type are returned.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array of custom attributes applied to this member, or an array with zero (0) elements if no attributes have been applied.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedMethodInfo.GetCustomAttributes Overload List


GetGenericArguments Method

UnresolvedMethodInfo.GetGenericArguments Method
[image]

Returns an array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGenericArguments() As Type()
C#
public override Type[] GetGenericArguments()
C++
public:
virtual array<Type>^ GetGenericArguments() override
J#
public override Type[] GetGenericArguments()
JScript
public override function GetGenericArguments() : Type[]

Return Value

An array of Type objects that represent the type arguments of a generic method or the type parameters of a generic method definition. Returns an empty array if the current method is not a generic method.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetGenericMethodDefinition Method

UnresolvedMethodInfo.GetGenericMethodDefinition Method
[image]

Returns a MethodInfo object that represents a generic method definition from which the current method can be constructed.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGenericMethodDefinition() As MethodInfo
C#
public override MethodInfo GetGenericMethodDefinition()
C++
public:
virtual MethodInfo GetGenericMethodDefinition() override
J#
public override MethodInfo GetGenericMethodDefinition()
JScript
public override function GetGenericMethodDefinition() : MethodInfo

Return Value

A MethodInfo object representing a generic method definition from which the current method can be constructed.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetHashCode Method

UnresolvedMethodInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetMethodBody Method

UnresolvedMethodInfo.GetMethodBody Method
[image]

When overridden in a derived class, gets a MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethodBody() As MethodBody
C#
public override MethodBody GetMethodBody()
C++
public:
virtual MethodBody GetMethodBody() override
J#
public override MethodBody GetMethodBody()
JScript
public override function GetMethodBody() : MethodBody

Return Value

A MethodBody object that provides access to the MSIL stream, local variables, and exceptions for the current method.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetMethodImplementationFlags Method

UnresolvedMethodInfo.GetMethodImplementationFlags Method
[image]

When overridden in a derived class, returns the MethodImplAttributes flags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethodImplementationFlags() As MethodImplAttributes
C#
public override MethodImplAttributes GetMethodImplementationFlags()
C++
public:
virtual MethodImplAttributes GetMethodImplementationFlags() override
J#
public override MethodImplAttributes GetMethodImplementationFlags()
JScript
public override function GetMethodImplementationFlags() : MethodImplAttributes

Return Value

The MethodImplAttributes flags.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


GetParameters Method

UnresolvedMethodInfo.GetParameters Method
[image]

When overridden in a derived class, gets the parameters of the specified method or constructor.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetParameters() As ParameterInfo()
C#
public override ParameterInfo[] GetParameters()
C++
public:
virtual array<ParameterInfo>^ GetParameters() override
J#
public override ParameterInfo[] GetParameters()
JScript
public override function GetParameters() : ParameterInfo[]

Return Value

An array of type ParameterInfo containing information that matches the signature of the method (or constructor) reflected by this MethodBase instance.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Invoke Method

UnresolvedMethodInfo.Invoke Method

Invokes the method or constructor reflected by this MethodInfo instance.

Overload List

 | Name | Description
Public method | Invoke (Object, BindingFlags, Binder, Object, CultureInfo) | Overridden. When overridden in a derived class, invokes the reflected method or constructor with the given parameters.
Public method | Invoke (Object, Object) | Invokes the method or constructor represented by the current instance, using the specified parameters. (inherited from MethodBase)

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


Invoke Method (Object, BindingFlags, Binder, Object[], CultureInfo)

UnresolvedMethodInfo.Invoke Method (Object, BindingFlags, Binder, Object[], CultureInfo)
See Also Example
[image]

When overridden in a derived class, invokes the reflected method or constructor with the given parameters.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Invoke( _
ByVal obj As Object, _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal parameters As Object(), _
ByVal culture As CultureInfo _
) As Object
C#
public override object Invoke(
object obj,
BindingFlags invokeAttr,
Binder binder,
object[] parameters,
CultureInfo culture
)
C++
public:
virtual Object Invoke(
Object obj,
BindingFlags invokeAttr,
Binder binder,
array<Object>^ parameters,
CultureInfo culture
) override
J#
public override object Invoke(
object obj,
BindingFlags invokeAttr,
Binder binder,
object[] parameters,
CultureInfo culture
)
JScript
public override function Invoke(
obj : Object,
invokeAttr : BindingFlags,
binder : Binder,
parameters : Object[],
culture : CultureInfo
) : Object

Parameters

obj
The object on which to invoke the method or constructor. If a method is static, this argument is ignored. If a constructor is static, this argument must be null or an instance of the class that defines the constructor.
invokeAttr
A bitmask that is a combination of 0 or more bit flags from BindingFlags. If binder is null, this parameter is assigned the value Default; thus, whatever you pass in is ignored.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used.
parameters
An argument list for the invoked method or constructor. This is an array of objects with the same number, order, and type as the parameters of the method or constructor to be invoked. If there are no parameters, this should be null.If the method or constructor represented by this instance takes a ByRef parameter, there is no special attribute required for that parameter in order to invoke the method or constructor using this function. Any object in this array that is not explicitly initialized with a value will contain the default value for that object type. For reference-type elements, this value is null. For value-type elements, this value is 0, 0.0, or false, depending on the specific element type.
culture
An instance of CultureInfo used to govern the coercion of types. If this is null, the CultureInfo for the current thread is used. (This is necessary to convert a String that represents 1000 to a Double value, for example, since 1000 is represented differently by different cultures.)

Return Value

An Object containing the return value of the invoked method, or null in the case of a constructor, or null if the method's return type is void. Before calling the method or constructor, Invoke checks to see if the user has access permission and verify that the parameters are valid.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedMethodInfo.Invoke Overload List


IsDefined Method

UnresolvedMethodInfo.IsDefined Method
[image]

When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to which the custom attributes are applied.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

true if one or more instance of attributeType is applied to this member; otherwise false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


MakeGenericMethod Method

UnresolvedMethodInfo.MakeGenericMethod Method
[image]

Substitutes the elements of an array of types for the type parameters of the current generic method definition, and returns a MethodInfo object representing the resulting constructed method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakeGenericMethod( _
ByVal ParamArray typeArguments As Type() _
) As MethodInfo
C#
public override MethodInfo MakeGenericMethod(
params Type[] typeArguments
)
C++
public:
virtual MethodInfo MakeGenericMethod(
... array<Type>^ typeArguments
) override
J#
public override MethodInfo MakeGenericMethod(
Type[] typeArguments
)
JScript
public override function MakeGenericMethod(
ParamArrayAttribute typeArguments : Type[]
) : MethodInfo

Parameters

typeArguments
An array of types to be substituted for the type parameters of the current generic method definition.

Return Value

A MethodInfo object that represents the constructed method formed by substituting the elements of typeArguments for the type parameters of the current generic method definition.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


ToString Method

UnresolvedMethodInfo.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

UnresolvedMethodInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedParameterInfo Class

UnresolvedParameterInfo Class
See Also Example Members
[image]

Represents a ParameterInfo whose native definition could not be resolved so we fall back on the IParameterInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedParameterInfo
Inherits ParameterInfo
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedParameterInfo : ParameterInfo, IUnresolvedCodeElement
C++
ref class UnresolvedParameterInfo sealed : ParameterInfo, IUnresolvedCodeElement
J#
public final class UnresolvedParameterInfo extends ParameterInfo implements IUnresolvedCodeElement
JScript
public final class UnresolvedParameterInfo extends ParameterInfo, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.ParameterInfo
Gallio.Reflection.Impl.UnresolvedParameterInfo

See Also

UnresolvedParameterInfo Members
Gallio.Reflection.Impl Namespace


UnresolvedParameterInfo Members

UnresolvedParameterInfo Members
See Also Example Constructors Properties Methods
[image]

Represents a ParameterInfo whose native definition could not be resolved so we fall back on the IParameterInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedParameterInfo.

Public Constructors

 | Name | Description
Public method | UnresolvedParameterInfo | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes for this parameter.
Public property | DefaultValue | Overridden. Gets a value indicating the default value if the parameter has a default value.
Public property | IsIn | Gets a value indicating whether this is an input parameter. (inherited from ParameterInfo)
Public property | IsLcid | Gets a value indicating whether this parameter is a locale identifier (lcid). (inherited from ParameterInfo)
Public property | IsOptional | Gets a value indicating whether this parameter is optional. (inherited from ParameterInfo)
Public property | IsOut | Gets a value indicating whether this is an output parameter. (inherited from ParameterInfo)
Public property | IsRetval | Gets a value indicating whether this is a Retval parameter. (inherited from ParameterInfo)
Public property | Member | Overridden. Gets a value indicating the member in which the parameter is implemented.
Public property | MetadataToken | Gets a value that identifies this parameter in metadata. (inherited from ParameterInfo)
Public property | Name | Overridden. Gets the name of the parameter.
Public property | ParameterType | Overridden. Gets the Type of this parameter.
Public property | Position | Overridden. Gets the signature position for the parameter.
Public property | RawDefaultValue | Overridden. Gets a value indicating the default value if the parameter has a default value.
Top

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetCustomAttributes | Overloaded. Gets custom attributes defined on this parameter.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetOptionalCustomModifiers | Overridden. Gets the optional custom modifiers of the parameter.
Public method | GetRequiredCustomModifiers | Overridden. Gets the required custom modifiers of the parameter.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefined | Overridden. Determines if the custom attribute of the specified type is defined on this member.
Public method | ToString | Overridden. Gets the parameter type and name represented as a string.
Top

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedParameterInfo Constructor

UnresolvedParameterInfo Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As IParameterInfo _
)
C#
public UnresolvedParameterInfo(
IParameterInfo adapter
)
C++
public:
UnresolvedParameterInfo(
IParameterInfo adapter
) sealed
J#
public UnresolvedParameterInfo(
IParameterInfo adapter
)
JScript
public function UnresolvedParameterInfo(
adapter : IParameterInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedParameterInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes for this parameter.
Public property | DefaultValue | Overridden. Gets a value indicating the default value if the parameter has a default value.
Public property | IsIn | Gets a value indicating whether this is an input parameter. (inherited from ParameterInfo)
Public property | IsLcid | Gets a value indicating whether this parameter is a locale identifier (lcid). (inherited from ParameterInfo)
Public property | IsOptional | Gets a value indicating whether this parameter is optional. (inherited from ParameterInfo)
Public property | IsOut | Gets a value indicating whether this is an output parameter. (inherited from ParameterInfo)
Public property | IsRetval | Gets a value indicating whether this is a Retval parameter. (inherited from ParameterInfo)
Public property | Member | Overridden. Gets a value indicating the member in which the parameter is implemented.
Public property | MetadataToken | Gets a value that identifies this parameter in metadata. (inherited from ParameterInfo)
Public property | Name | Overridden. Gets the name of the parameter.
Public property | ParameterType | Overridden. Gets the Type of this parameter.
Public property | Position | Overridden. Gets the signature position for the parameter.
Public property | RawDefaultValue | Overridden. Gets a value indicating the default value if the parameter has a default value.
Top

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedParameterInfo.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As IParameterInfo
C#
public IParameterInfo Adapter { get; }
C++
public property IParameterInfo Adapter sealed {
IParameterInfo get();
}
J#
/** property */
public IParameterInfo get_Adapter();
JScript
public function get Adapter() : IParameterInfo

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Attributes Property

UnresolvedParameterInfo.Attributes Property
[image]

Gets the attributes for this parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As ParameterAttributes
C#
public override ParameterAttributes Attributes { get; }
C++
public override property ParameterAttributes Attributes override {
ParameterAttributes get();
}
J#
/** property */
public ParameterAttributes get_Attributes();
JScript
public function get Attributes() : ParameterAttributes

Property Value

A ParameterAttributes object representing the attributes for this parameter.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


DefaultValue Property

UnresolvedParameterInfo.DefaultValue Property
[image]

Gets a value indicating the default value if the parameter has a default value.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultValue As Object
C#
public override object DefaultValue { get; }
C++
public override property object DefaultValue override {
Object get();
}
J#
/** property */
public object get_DefaultValue();
JScript
public function get DefaultValue() : Object

Property Value

The default value of the parameter, or Value if the parameter has no default value.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Member Property

UnresolvedParameterInfo.Member Property
[image]

Gets a value indicating the member in which the parameter is implemented.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Member As MemberInfo
C#
public override MemberInfo Member { get; }
C++
public override property MemberInfo Member override {
MemberInfo get();
}
J#
/** property */
public MemberInfo get_Member();
JScript
public function get Member() : MemberInfo

Property Value

A MemberInfo object.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedParameterInfo.Name Property
[image]

Gets the name of the parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the simple name of this parameter.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


ParameterType Property

UnresolvedParameterInfo.ParameterType Property
[image]

Gets the Type of this parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ParameterType As Type
C#
public override Type ParameterType { get; }
C++
public override property Type ParameterType override {
Type get();
}
J#
/** property */
public Type get_ParameterType();
JScript
public function get ParameterType() : Type

Property Value

The Type object that represents the Type of this parameter.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Position Property

UnresolvedParameterInfo.Position Property
[image]

Gets the signature position for the parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Position As Integer
C#
public override int Position { get; }
C++
public override property int Position override {
int get();
}
J#
/** property */
public int get_Position();
JScript
public function get Position() : int

Property Value

An integer representing the position this parameter occupies in the parameter list.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


RawDefaultValue Property

UnresolvedParameterInfo.RawDefaultValue Property
[image]

Gets a value indicating the default value if the parameter has a default value.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property RawDefaultValue As Object
C#
public override object RawDefaultValue { get; }
C++
public override property object RawDefaultValue override {
Object get();
}
J#
/** property */
public object get_RawDefaultValue();
JScript
public function get RawDefaultValue() : Object

Property Value

The default value of the parameter, or Value if the parameter has no default value.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedParameterInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetCustomAttributes | Overloaded. Gets custom attributes defined on this parameter.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetOptionalCustomModifiers | Overridden. Gets the optional custom modifiers of the parameter.
Public method | GetRequiredCustomModifiers | Overridden. Gets the required custom modifiers of the parameter.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefined | Overridden. Determines if the custom attribute of the specified type is defined on this member.
Public method | ToString | Overridden. Gets the parameter type and name represented as a string.
Top

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedParameterInfo.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

UnresolvedParameterInfo.GetCustomAttributes Method

Gets custom attributes defined on this parameter.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. Gets all the custom attributes defined on this parameter.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. Gets the custom attributes of the specified type defined on this parameter.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedParameterInfo.GetCustomAttributes Method (Boolean)
See Also Example
[image]

Gets all the custom attributes defined on this parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
This argument is ignored for objects of this type.

Return Value

An array of type Object containing all the custom attributes defined on this parameter.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedParameterInfo.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedParameterInfo.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

Gets the custom attributes of the specified type defined on this parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The custom attributes identified by type.
inherit
This argument is ignored for objects of this type.

Return Value

An array of type Object containing the custom attributes of the specified type.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedParameterInfo.GetCustomAttributes Overload List


GetHashCode Method

UnresolvedParameterInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


GetOptionalCustomModifiers Method

UnresolvedParameterInfo.GetOptionalCustomModifiers Method
[image]

Gets the optional custom modifiers of the parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetOptionalCustomModifiers() As Type()
C#
public override Type[] GetOptionalCustomModifiers()
C++
public:
virtual array<Type>^ GetOptionalCustomModifiers() override
J#
public override Type[] GetOptionalCustomModifiers()
JScript
public override function GetOptionalCustomModifiers() : Type[]

Return Value

An array of Type objects that identify the optional custom modifiers of the current parameter, such as IsConst or IsImplicitlyDeferenced.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


GetRequiredCustomModifiers Method

UnresolvedParameterInfo.GetRequiredCustomModifiers Method
[image]

Gets the required custom modifiers of the parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRequiredCustomModifiers() As Type()
C#
public override Type[] GetRequiredCustomModifiers()
C++
public:
virtual array<Type>^ GetRequiredCustomModifiers() override
J#
public override Type[] GetRequiredCustomModifiers()
JScript
public override function GetRequiredCustomModifiers() : Type[]

Return Value

An array of Type objects that identify the required custom modifiers of the current parameter, such as IsConst or IsImplicitlyDeferenced.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


IsDefined Method

UnresolvedParameterInfo.IsDefined Method
[image]

Determines if the custom attribute of the specified type is defined on this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to search for.
inherit
This argument is ignored for objects of this type.

Return Value

true if one or more instance of attributeType is defined on this member; otherwise, false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


ToString Method

UnresolvedParameterInfo.ToString Method
[image]

Gets the parameter type and name represented as a string.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A string containing the type and the name of the parameter.

See Also

UnresolvedParameterInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedPropertyInfo Class

UnresolvedPropertyInfo Class
See Also Example Members
[image]

Represents a PropertyInfo whose native definition could not be resolved so we fall back on the IPropertyInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedPropertyInfo
Inherits PropertyInfo
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedPropertyInfo : PropertyInfo, IUnresolvedCodeElement
C++
ref class UnresolvedPropertyInfo sealed : PropertyInfo, IUnresolvedCodeElement
J#
public final class UnresolvedPropertyInfo extends PropertyInfo implements IUnresolvedCodeElement
JScript
public final class UnresolvedPropertyInfo extends PropertyInfo, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.MemberInfo
System.Reflection.PropertyInfo
Gallio.Reflection.Impl.UnresolvedPropertyInfo

See Also

UnresolvedPropertyInfo Members
Gallio.Reflection.Impl Namespace


UnresolvedPropertyInfo Members

UnresolvedPropertyInfo Members
See Also Example Constructors Properties Methods
[image]

Represents a PropertyInfo whose native definition could not be resolved so we fall back on the IPropertyInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedPropertyInfo.

Public Constructors

 | Name | Description
Public method | UnresolvedPropertyInfo | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes for this property.
Public property | CanRead | Overridden. Gets a value indicating whether the property can be read.
Public property | CanWrite | Overridden. Gets a value indicating whether the property can be written to.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | IsSpecialName | Gets a value indicating whether the property is the special name. (inherited from PropertyInfo)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a property.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | PropertyType | Overridden. Gets the type of this property.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetAccessors | Overloaded. Returns an array of the get and set accessors on this property.
Public method | GetConstantValue | Overridden. Returns a literal value associated with the property by a compiler.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetGetMethod | Overloaded. Returns a MethodInfo representing the get accessor for this property.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetIndexParameters | Overridden. When overridden in a derived class, returns an array of all the index parameters for the property.
Public method | GetOptionalCustomModifiers | Overridden. Returns an array of types representing the optional custom modifiers of the property.
Public method | GetRawConstantValue | Overridden. Returns a literal value associated with the property by a compiler.
Public method | GetRequiredCustomModifiers | Overridden. Returns an array of types representing the required custom modifiers of the property.
Public method | GetSetMethod | Overloaded. Returns a MethodInfo representing the set accessor for this property.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Overloaded. Returns the value of the property.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | SetValue | Overloaded. Sets the property value for the given object to the given value.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedPropertyInfo Constructor

UnresolvedPropertyInfo Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As IPropertyInfo _
)
C#
public UnresolvedPropertyInfo(
IPropertyInfo adapter
)
C++
public:
UnresolvedPropertyInfo(
IPropertyInfo adapter
) sealed
J#
public UnresolvedPropertyInfo(
IPropertyInfo adapter
)
JScript
public function UnresolvedPropertyInfo(
adapter : IPropertyInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedPropertyInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Attributes | Overridden. Gets the attributes for this property.
Public property | CanRead | Overridden. Gets a value indicating whether the property can be read.
Public property | CanWrite | Overridden. Gets a value indicating whether the property can be written to.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | IsSpecialName | Gets a value indicating whether the property is the special name. (inherited from PropertyInfo)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a property.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module in which the type that declares the member represented by the current MemberInfo is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | PropertyType | Overridden. Gets the type of this property.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this instance of MemberInfo.
Top

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedPropertyInfo.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As IPropertyInfo
C#
public IPropertyInfo Adapter { get; }
C++
public property IPropertyInfo Adapter sealed {
IPropertyInfo get();
}
J#
/** property */
public IPropertyInfo get_Adapter();
JScript
public function get Adapter() : IPropertyInfo

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Attributes Property

UnresolvedPropertyInfo.Attributes Property
[image]

Gets the attributes for this property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As PropertyAttributes
C#
public override PropertyAttributes Attributes { get; }
C++
public override property PropertyAttributes Attributes override {
PropertyAttributes get();
}
J#
/** property */
public PropertyAttributes get_Attributes();
JScript
public function get Attributes() : PropertyAttributes

Property Value

Attributes of this property.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


CanRead Property

UnresolvedPropertyInfo.CanRead Property
[image]

Gets a value indicating whether the property can be read.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
C#
public override bool CanRead { get; }
C++
public override property bool CanRead override {
bool get();
}
J#
/** property */
public bool get_CanRead();
JScript
public function get CanRead() : bool

Property Value

true if this property can be read; otherwise, false.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


CanWrite Property

UnresolvedPropertyInfo.CanWrite Property
[image]

Gets a value indicating whether the property can be written to.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
C#
public override bool CanWrite { get; }
C++
public override property bool CanWrite override {
bool get();
}
J#
/** property */
public bool get_CanWrite();
JScript
public function get CanWrite() : bool

Property Value

true if this property can be written to; otherwise, false.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

UnresolvedPropertyInfo.DeclaringType Property
[image]

Gets the class that declares this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As Type
C#
public override Type DeclaringType { get; }
C++
public override property Type DeclaringType override {
Type get();
}
J#
/** property */
public Type get_DeclaringType();
JScript
public function get DeclaringType() : Type

Property Value

The Type object for the class that declares this member.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


MemberType Property

UnresolvedPropertyInfo.MemberType Property
[image]

Gets a MemberTypes value indicating that this member is a property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberType As MemberTypes
C#
public override MemberTypes MemberType { get; }
C++
public override property MemberTypes MemberType override {
MemberTypes get();
}
J#
/** property */
public MemberTypes get_MemberType();
JScript
public function get MemberType() : MemberTypes

Property Value

A MemberTypes value indicating that this member is a property.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


MetadataToken Property

UnresolvedPropertyInfo.MetadataToken Property
[image]

Gets a value that identifies a metadata element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MetadataToken As Integer
C#
public override int MetadataToken { get; }
C++
public override property int MetadataToken override {
int get();
}
J#
/** property */
public int get_MetadataToken();
JScript
public function get MetadataToken() : int

Property Value

A value which, in combination with Module, uniquely identifies a metadata element.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Module Property

UnresolvedPropertyInfo.Module Property
[image]

Gets the module in which the type that declares the member represented by the current MemberInfo is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Module As Module
C#
public override Module Module { get; }
C++
public override property Module Module override {
Module get();
}
J#
/** property */
public Module get_Module();
JScript
public function get Module() : Module

Property Value

The Module in which the type that declares the member represented by the current MemberInfo is defined.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedPropertyInfo.Name Property
[image]

Gets the name of the current member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the name of this member.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


PropertyType Property

UnresolvedPropertyInfo.PropertyType Property
[image]

Gets the type of this property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PropertyType As Type
C#
public override Type PropertyType { get; }
C++
public override property Type PropertyType override {
Type get();
}
J#
/** property */
public Type get_PropertyType();
JScript
public function get PropertyType() : Type

Property Value

The type of this property.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

UnresolvedPropertyInfo.ReflectedType Property
[image]

Gets the class object that was used to obtain this instance of MemberInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As Type
C#
public override Type ReflectedType { get; }
C++
public override property Type ReflectedType override {
Type get();
}
J#
/** property */
public Type get_ReflectedType();
JScript
public function get ReflectedType() : Type

Property Value

The Type object through which this MemberInfo object was obtained.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedPropertyInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overridden. Determines whether the specified Object is equal to the current Object.
Public method | GetAccessors | Overloaded. Returns an array of the get and set accessors on this property.
Public method | GetConstantValue | Overridden. Returns a literal value associated with the property by a compiler.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetGetMethod | Overloaded. Returns a MethodInfo representing the get accessor for this property.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetIndexParameters | Overridden. When overridden in a derived class, returns an array of all the index parameters for the property.
Public method | GetOptionalCustomModifiers | Overridden. Returns an array of types representing the optional custom modifiers of the property.
Public method | GetRawConstantValue | Overridden. Returns a literal value associated with the property by a compiler.
Public method | GetRequiredCustomModifiers | Overridden. Returns an array of types representing the required custom modifiers of the property.
Public method | GetSetMethod | Overloaded. Returns a MethodInfo representing the set accessor for this property.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetValue | Overloaded. Returns the value of the property.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | SetValue | Overloaded. Sets the property value for the given object to the given value.
Public method | ToString | Overridden. Returns a String that represents the current Object.
Top

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedPropertyInfo.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetAccessors Method

UnresolvedPropertyInfo.GetAccessors Method

Returns an array of the get and set accessors on this property.

Overload List

 | Name | Description
Public method | GetAccessors (Boolean) | Overridden. Returns an array whose elements reflect the public and, if specified, non-public get, set, and other accessors of the property reflected by the current instance.
Public method | GetAccessors | Returns an array whose elements reflect the public get, set, and other accessors of the property reflected by the current instance. (inherited from PropertyInfo)

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetAccessors Method (Boolean)

UnresolvedPropertyInfo.GetAccessors Method (Boolean)
See Also Example
[image]

Returns an array whose elements reflect the public and, if specified, non-public get, set, and other accessors of the property reflected by the current instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetAccessors( _
ByVal nonPublic As Boolean _
) As MethodInfo()
C#
public override MethodInfo[] GetAccessors(
bool nonPublic
)
C++
public:
virtual array<MethodInfo>^ GetAccessors(
bool nonPublic
) override
J#
public override MethodInfo[] GetAccessors(
bool nonPublic
)
JScript
public override function GetAccessors(
nonPublic : bool
) : MethodInfo[]

Parameters

nonPublic
Indicates whether non-public methods should be returned in the MethodInfo array. true if non-public methods are to be included; otherwise, false.

Return Value

An array of MethodInfo objects whose elements reflect the get, set, and other accessors of the property reflected by the current instance. If nonPublic is true, this array contains public and non-public get, set, and other accessors. If nonPublic is false, this array contains only public get, set, and other accessors. If no accessors with the specified visibility are found, this method returns an array with zero (0) elements.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetAccessors Overload List


GetConstantValue Method

UnresolvedPropertyInfo.GetConstantValue Method
[image]

Returns a literal value associated with the property by a compiler.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetConstantValue() As Object
C#
public override object GetConstantValue()
C++
public:
virtual Object GetConstantValue() override
J#
public override object GetConstantValue()
JScript
public override function GetConstantValue() : Object

Return Value

An Object that contains the literal value associated with the property. If the literal value is a class type with an element value of zero, the return value is null.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method

UnresolvedPropertyInfo.GetCustomAttributes Method

When overridden in a derived class, returns all attributes applied to this member.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. When overridden in a derived class, returns an array containing all the custom attributes.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. When overridden in a derived class, returns an array of custom attributes identified by Type.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedPropertyInfo.GetCustomAttributes Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array containing all the custom attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array that contains all the custom attributes, or an array with zero elements if no attributes are defined.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedPropertyInfo.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array of custom attributes identified by Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The type of attribute to search for. Only attributes that are assignable to this type are returned.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array of custom attributes applied to this member, or an array with zero (0) elements if no attributes have been applied.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetCustomAttributes Overload List


GetGetMethod Method

UnresolvedPropertyInfo.GetGetMethod Method

Returns a MethodInfo representing the get accessor for this property.

Overload List

 | Name | Description
Public method | GetGetMethod (Boolean) | Overridden. When overridden in a derived class, returns the public or non-public get accessor for this property.
Public method | GetGetMethod | Returns the public get accessor for this property. (inherited from PropertyInfo)

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetGetMethod Method (Boolean)

UnresolvedPropertyInfo.GetGetMethod Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns the public or non-public get accessor for this property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGetMethod( _
ByVal nonPublic As Boolean _
) As MethodInfo
C#
public override MethodInfo GetGetMethod(
bool nonPublic
)
C++
public:
virtual MethodInfo GetGetMethod(
bool nonPublic
) override
J#
public override MethodInfo GetGetMethod(
bool nonPublic
)
JScript
public override function GetGetMethod(
nonPublic : bool
) : MethodInfo

Parameters

nonPublic
Indicates whether a non-public get accessor should be returned. true if a non-public accessor is to be returned; otherwise, false.

Return Value

A MethodInfo object representing the get accessor for this property, if nonPublic is true. Returns null if nonPublic is false and the get accessor is non-public, or if nonPublic is true but no get accessors exist.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetGetMethod Overload List


GetHashCode Method

UnresolvedPropertyInfo.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetIndexParameters Method

UnresolvedPropertyInfo.GetIndexParameters Method
[image]

When overridden in a derived class, returns an array of all the index parameters for the property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetIndexParameters() As ParameterInfo()
C#
public override ParameterInfo[] GetIndexParameters()
C++
public:
virtual array<ParameterInfo>^ GetIndexParameters() override
J#
public override ParameterInfo[] GetIndexParameters()
JScript
public override function GetIndexParameters() : ParameterInfo[]

Return Value

An array of type ParameterInfo containing the parameters for the indexes.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetOptionalCustomModifiers Method

UnresolvedPropertyInfo.GetOptionalCustomModifiers Method
[image]

Returns an array of types representing the optional custom modifiers of the property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetOptionalCustomModifiers() As Type()
C#
public override Type[] GetOptionalCustomModifiers()
C++
public:
virtual array<Type>^ GetOptionalCustomModifiers() override
J#
public override Type[] GetOptionalCustomModifiers()
JScript
public override function GetOptionalCustomModifiers() : Type[]

Return Value

An array of Type objects that identify the optional custom modifiers of the current property, such as IsConst or IsImplicitlyDeferenced.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetRawConstantValue Method

UnresolvedPropertyInfo.GetRawConstantValue Method
[image]

Returns a literal value associated with the property by a compiler.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRawConstantValue() As Object
C#
public override object GetRawConstantValue()
C++
public:
virtual Object GetRawConstantValue() override
J#
public override object GetRawConstantValue()
JScript
public override function GetRawConstantValue() : Object

Return Value

An Object that contains the literal value associated with the property. If the literal value is a class type with an element value of zero, the return value is null.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetRequiredCustomModifiers Method

UnresolvedPropertyInfo.GetRequiredCustomModifiers Method
[image]

Returns an array of types representing the required custom modifiers of the property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRequiredCustomModifiers() As Type()
C#
public override Type[] GetRequiredCustomModifiers()
C++
public:
virtual array<Type>^ GetRequiredCustomModifiers() override
J#
public override Type[] GetRequiredCustomModifiers()
JScript
public override function GetRequiredCustomModifiers() : Type[]

Return Value

An array of Type objects that identify the required custom modifiers of the current property, such as IsConst or IsImplicitlyDeferenced.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetSetMethod Method

UnresolvedPropertyInfo.GetSetMethod Method

Returns a MethodInfo representing the set accessor for this property.

Overload List

 | Name | Description
Public method | GetSetMethod (Boolean) | Overridden. When overridden in a derived class, returns the set accessor for this property.
Public method | GetSetMethod | Returns the public set accessor for this property. (inherited from PropertyInfo)

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetSetMethod Method (Boolean)

UnresolvedPropertyInfo.GetSetMethod Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns the set accessor for this property.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSetMethod( _
ByVal nonPublic As Boolean _
) As MethodInfo
C#
public override MethodInfo GetSetMethod(
bool nonPublic
)
C++
public:
virtual MethodInfo GetSetMethod(
bool nonPublic
) override
J#
public override MethodInfo GetSetMethod(
bool nonPublic
)
JScript
public override function GetSetMethod(
nonPublic : bool
) : MethodInfo

Parameters

nonPublic
Indicates whether the accessor should be returned if it is non-public. true if a non-public accessor is to be returned; otherwise, false.

Return Value

Value Condition A MethodInfo object representing the Set method for this property. The set accessor is public.-or- nonPublic is true and the set accessor is non-public. nullnonPublic is true, but the property is read-only.-or- nonPublic is false and the set accessor is non-public.-or- There is no set accessor.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetSetMethod Overload List


GetValue Method

UnresolvedPropertyInfo.GetValue Method

Returns the value of the property.

Overload List

 | Name | Description
Public method | GetValue (Object, Object) | Overridden. Returns the value of the property with optional index values for indexed properties.
Public method | GetValue (Object, BindingFlags, Binder, Object, CultureInfo) | Overridden. When overridden in a derived class, returns the value of a property having the specified binding, index, and CultureInfo.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


GetValue Method (Object, Object[])

UnresolvedPropertyInfo.GetValue Method (Object, Object[])
See Also Example
[image]

Returns the value of the property with optional index values for indexed properties.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetValue( _
ByVal obj As Object, _
ByVal index As Object() _
) As Object
C#
public override object GetValue(
object obj,
object[] index
)
C++
public:
virtual Object GetValue(
Object obj,
array<Object>^ index
) override
J#
public override object GetValue(
object obj,
object[] index
)
JScript
public override function GetValue(
obj : Object,
index : Object[]
) : Object

Parameters

obj
The object whose property value will be returned.
index
Optional index values for indexed properties. This value should be null for non-indexed properties.

Return Value

The property value for the obj parameter.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetValue Overload List


GetValue Method (Object, BindingFlags, Binder, Object[], CultureInfo)

UnresolvedPropertyInfo.GetValue Method (Object, BindingFlags, Binder, Object[], CultureInfo)
See Also Example
[image]

When overridden in a derived class, returns the value of a property having the specified binding, index, and CultureInfo.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetValue( _
ByVal obj As Object, _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal index As Object(), _
ByVal culture As CultureInfo _
) As Object
C#
public override object GetValue(
object obj,
BindingFlags invokeAttr,
Binder binder,
object[] index,
CultureInfo culture
)
C++
public:
virtual Object GetValue(
Object obj,
BindingFlags invokeAttr,
Binder binder,
array<Object>^ index,
CultureInfo culture
) override
J#
public override object GetValue(
object obj,
BindingFlags invokeAttr,
Binder binder,
object[] index,
CultureInfo culture
)
JScript
public override function GetValue(
obj : Object,
invokeAttr : BindingFlags,
binder : Binder,
index : Object[],
culture : CultureInfo
) : Object

Parameters

obj
The object whose property value will be returned.
invokeAttr
The invocation attribute. This must be a bit flag from BindingFlags : InvokeMethod, CreateInstance, Static, GetField, SetField, GetProperty, or SetProperty. A suitable invocation attribute must be specified. If a static member is to be invoked, the Static flag of BindingFlags must be set.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects via reflection. If binder is null, the default binder is used.
index
Optional index values for indexed properties. This value should be null for non-indexed properties.
culture
The CultureInfo object that represents the culture for which the resource is to be localized. Note that if the resource is not localized for this culture, the CultureInfo.Parent method will be called successively in search of a match. If this value is null, the CultureInfo is obtained from the CultureInfo.CurrentUICulture property.

Return Value

The property value for obj.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.GetValue Overload List


IsDefined Method

UnresolvedPropertyInfo.IsDefined Method
[image]

When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to which the custom attributes are applied.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

true if one or more instance of attributeType is applied to this member; otherwise false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


SetValue Method

UnresolvedPropertyInfo.SetValue Method

Sets the property value for the given object to the given value.

Overload List

 | Name | Description
Public method | SetValue (Object, Object, Object) | Overridden. Sets the value of the property with optional index values for index properties.
Public method | SetValue (Object, Object, BindingFlags, Binder, Object, CultureInfo) | Overridden. When overridden in a derived class, sets the property value for the given object to the given value.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


SetValue Method (Object, Object, Object[])

UnresolvedPropertyInfo.SetValue Method (Object, Object, Object[])
See Also Example
[image]

Sets the value of the property with optional index values for index properties.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetValue( _
ByVal obj As Object, _
ByVal value As Object, _
ByVal index As Object() _
)
C#
public override void SetValue(
object obj,
object value,
object[] index
)
C++
public:
virtual void SetValue(
Object obj,
Object value,
array<Object>^ index
) override
J#
public override void SetValue(
object obj,
object value,
object[] index
)
JScript
public override function SetValue(
obj : Object,
value : Object,
index : Object[]
)

Parameters

obj
The object whose property value will be set.
value
The new value for this property.
index
Optional index values for indexed properties. This value should be null for non-indexed properties.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.SetValue Overload List


SetValue Method (Object, Object, BindingFlags, Binder, Object[], CultureInfo)

UnresolvedPropertyInfo.SetValue Method (Object, Object, BindingFlags, Binder, Object[], CultureInfo)
See Also Example
[image]

When overridden in a derived class, sets the property value for the given object to the given value.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetValue( _
ByVal obj As Object, _
ByVal value As Object, _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal index As Object(), _
ByVal culture As CultureInfo _
)
C#
public override void SetValue(
object obj,
object value,
BindingFlags invokeAttr,
Binder binder,
object[] index,
CultureInfo culture
)
C++
public:
virtual void SetValue(
Object obj,
Object value,
BindingFlags invokeAttr,
Binder binder,
array<Object>^ index,
CultureInfo culture
) override
J#
public override void SetValue(
object obj,
object value,
BindingFlags invokeAttr,
Binder binder,
object[] index,
CultureInfo culture
)
JScript
public override function SetValue(
obj : Object,
value : Object,
invokeAttr : BindingFlags,
binder : Binder,
index : Object[],
culture : CultureInfo
)

Parameters

obj
The object whose property value will be returned.
value
The new value for this property.
invokeAttr
The invocation attribute. This must be a bit flag from BindingFlags : InvokeMethod, CreateInstance, Static, GetField, SetField, GetProperty, or SetProperty. A suitable invocation attribute must be specified. If a static member is to be invoked, the Static flag of BindingFlags must be set.
binder
An object that enables the binding, coercion of argument types, invocation of members, and retrieval of MemberInfo objects through reflection. If binder is null, the default binder is used.
index
Optional index values for indexed properties. This value should be null for non-indexed properties.
culture
The CultureInfo object that represents the culture for which the resource is to be localized. Note that if the resource is not localized for this culture, the CultureInfo.Parent method will be called successively in search of a match. If this value is null, the CultureInfo is obtained from the CultureInfo.CurrentUICulture property.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace
UnresolvedPropertyInfo.SetValue Overload List


ToString Method

UnresolvedPropertyInfo.ToString Method
[image]

Returns a String that represents the current Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String that represents the current Object.

See Also

UnresolvedPropertyInfo Class
Gallio.Reflection.Impl Namespace


UnresolvedType Class

UnresolvedType Class
See Also Example Members
[image]

Represents a Type whose native definition could not be resolved so we fall back on the ITypeInfo wrapper. This class cannot be inherited.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class UnresolvedType
Inherits Type
Implements IUnresolvedCodeElement
C#
public sealed class UnresolvedType : Type, IUnresolvedCodeElement
C++
ref class UnresolvedType sealed : Type, IUnresolvedCodeElement
J#
public final class UnresolvedType extends Type implements IUnresolvedCodeElement
JScript
public final class UnresolvedType extends Type, IUnresolvedCodeElement

Inheritance Hierarchy

System.Object
System.Reflection.MemberInfo
System.Type
Gallio.Reflection.Impl.UnresolvedType

See Also

UnresolvedType Members
Gallio.Reflection.Impl Namespace


UnresolvedType Members

UnresolvedType Members
See Also Example Constructors Properties Methods
[image]

Represents a Type whose native definition could not be resolved so we fall back on the ITypeInfo wrapper. This class cannot be inherited.

The following tables list the members exposed by UnresolvedType.

Public Constructors

 | Name | Description
Public method | UnresolvedType | Creates a reflection object backed by the specified adapter.
Top

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Assembly | Overridden. Gets the Assembly in which the type is declared. For generic types, gets the Assembly in which the generic type is defined.
Public property | AssemblyQualifiedName | Overridden. Gets the assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.
Public property | Attributes | Gets the attributes associated with the Type. (inherited from Type)
Public property | BaseType | Overridden. Gets the type from which the current Type directly inherits.
Public property | ContainsGenericParameters | Overridden. Gets a value indicating whether the current Type object has type parameters that have not been replaced by specific types.
Public property | DeclaringMethod | Overridden. Gets a MethodBase that represents the declaring method, if the current Type represents a type parameter of a generic method.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | FullName | Overridden. Gets the fully qualified name of the Type, including the namespace of the Type but not the assembly.
Public property | GenericParameterAttributes | Overridden. Gets a combination of GenericParameterAttributes flags that describe the covariance and special constraints of the current generic type parameter.
Public property | GenericParameterPosition | Overridden. Gets the position of the type parameter in the type parameter list of the generic type or method that declared the parameter, when the Type object represents a type parameter of a generic type or a generic method.
Public property | GUID | Overridden. Gets the GUID associated with the Type.
Public property | HasElementType | Gets a value indicating whether the current Type encompasses or refers to another type; that is, whether the current Type is an array, a pointer, or is passed by reference. (inherited from Type)
Public property | IsAbstract | Gets a value indicating whether the Type is abstract and must be overridden. (inherited from Type)
Public property | IsAnsiClass | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type. (inherited from Type)
Public property | IsArray | Gets a value indicating whether the Type is an array. (inherited from Type)
Public property | IsAutoClass | Gets a value indicating whether the string format attribute AutoClass is selected for the Type. (inherited from Type)
Public property | IsAutoLayout | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type. (inherited from Type)
Public property | IsByRef | Gets a value indicating whether the Type is passed by reference. (inherited from Type)
Public property | IsClass | Gets a value indicating whether the Type is a class; that is, not a value type or interface. (inherited from Type)
Public property | IsCOMObject | Gets a value indicating whether the Type is a COM object. (inherited from Type)
Public property | IsContextful | Gets a value indicating whether the Type can be hosted in a context. (inherited from Type)
Public property | IsEnum | Gets a value indicating whether the current Type represents an enumeration. (inherited from Type)
Public property | IsExplicitLayout | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type. (inherited from Type)
Public property | IsGenericParameter | Overridden. Gets a value indicating whether the current Type represents a type parameter in the definition of a generic type or method.
Public property | IsGenericType | Overridden. Gets a value indicating whether the current type is a generic type.
Public property | IsGenericTypeDefinition | Overridden. Gets a value indicating whether the current Type represents a generic type definition, from which other generic types can be constructed.
Public property | IsImport | Gets a value indicating whether the Type has a ComImportAttribute attribute applied, indicating that it was imported from a COM type library. (inherited from Type)
Public property | IsInterface | Gets a value indicating whether the Type is an interface; that is, not a class or a value type. (inherited from Type)
Public property | IsLayoutSequential | Gets a value indicating whether the class layout attribute SequentialLayout is selected for the Type. (inherited from Type)
Public property | IsMarshalByRef | Gets a value indicating whether the Type is marshaled by reference. (inherited from Type)
Public property | IsNested | Gets a value indicating whether the current Type object represents a type whose definition is nested inside the definition of another type. (inherited from Type)
Public property | IsNestedAssembly | Gets a value indicating whether the Type is nested and visible only within its own assembly. (inherited from Type)
Public property | IsNestedFamANDAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from Type)
Public property | IsNestedFamily | Gets a value indicating whether the Type is nested and visible only within its own family. (inherited from Type)
Public property | IsNestedFamORAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from Type)
Public property | IsNestedPrivate | Gets a value indicating whether the Type is nested and declared private. (inherited from Type)
Public property | IsNestedPublic | Gets a value indicating whether a class is nested and declared public. (inherited from Type)
Public property | IsNotPublic | Gets a value indicating whether the Type is not declared public. (inherited from Type)
Public property | IsPointer | Gets a value indicating whether the Type is a pointer. (inherited from Type)
Public property | IsPrimitive | Gets a value indicating whether the Type is one of the primitive types. (inherited from Type)
Public property | IsPublic | Gets a value indicating whether the Type is declared public. (inherited from Type)
Public property | IsSealed | Gets a value indicating whether the Type is declared sealed. (inherited from Type)
Public property | IsSerializable | Gets a value indicating whether the Type is serializable. (inherited from Type)
Public property | IsSpecialName | Gets a value indicating whether the Type has a name that requires special handling. (inherited from Type)
Public property | IsUnicodeClass | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type. (inherited from Type)
Public property | IsValueType | Gets a value indicating whether the Type is a value type. (inherited from Type)
Public property | IsVisible | Gets a value indicating whether the Type can be accessed by code outside the assembly. (inherited from Type)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a type or a nested type.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module (the DLL) in which the current Type is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | Namespace | Overridden. Gets the namespace of the Type.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this member.
Public property | StructLayoutAttribute | Overridden. Gets a StructLayoutAttribute that describes the layout of the current type.
Public property | TypeHandle | Overridden. Gets the handle for the current Type.
Public property | TypeInitializer | Gets the initializer for the Type. (inherited from Type)
Public property | UnderlyingSystemType | Overridden. Indicates the type provided by the common language runtime that represents this type.
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
Public method | FindInterfaces | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type. (inherited from Type)
Public method | FindMembers | Returns a filtered array of MemberInfo objects of the specified member type. (inherited from Type)
Public method | GetArrayRank | Overridden. Gets the number of dimensions in an Array.
Public method | GetConstructor | Overloaded. Gets a specific constructor of the current Type. (inherited from Type)
Public method | GetConstructors | Overloaded. Gets the constructors of the current Type.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetDefaultMembers | Overridden. Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
Public method | GetElementType | Overridden. When overridden in a derived class, returns the Type of the object encompassed or referred to by the current array, pointer or reference type.
Public method | GetEvent | Overloaded. Gets a specific event declared or inherited by the current Type.
Public method | GetEvents | Overloaded. Gets the events that are declared or inherited by the current Type.
Public method | GetField | Overloaded. Gets a specific field of the current Type.
Public method | GetFields | Overloaded. Gets the fields of the current Type.
Public method | GetGenericArguments | Overridden. Returns an array of Type objects that represent the type arguments of a generic type or the type parameters of a generic type definition.
Public method | GetGenericParameterConstraints | Overridden. Returns an array of Type objects that represent the constraints on the current generic type parameter.
Public method | GetGenericTypeDefinition | Overridden. Returns a Type object that represents a generic type definition from which the current generic type can be constructed.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetInterface | Overloaded. Gets a specific interface implemented or inherited by the current Type.
Public method | GetInterfaceMap | Overridden. Returns an interface mapping for the specified interface type.
Public method | GetInterfaces | Overridden. When overridden in a derived class, gets all the interfaces implemented or inherited by the current Type.
Public method | GetMember | Overloaded. Gets the specified members of the current Type.
Public method | GetMembers | Overloaded. Gets the members (properties, methods, fields, events, and so on) of the current Type.
Public method | GetMethod | Overloaded. Gets a specific method of the current Type. (inherited from Type)
Public method | GetMethods | Overloaded. Gets the methods of the current Type.
Public method | GetNestedType | Overloaded. Gets a specific type nested within the current Type.
Public method | GetNestedTypes | Overloaded. Gets the types nested within the current Type.
Public method | GetProperties | Overloaded. Gets the properties of the current Type.
Public method | GetProperty | Overloaded. Gets a specific property of the current Type. (inherited from Type)
Public method | GetType | Gets the current Type. (inherited from Type)
Public method | InvokeMember | Overloaded. Invokes a specific member of the current Type.
Public method | IsAssignableFrom | Overridden. Determines whether an instance of the current Type can be assigned from an instance of the specified Type.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | IsInstanceOfType | Overridden. Determines whether the specified object is an instance of the current Type.
Public method | IsSubclassOf | Overridden. Determines whether the class represented by the current Type derives from the class represented by the specified Type.
Public method | MakeArrayType | Overloaded. Returns a Type object that represents an array of the current type.
Public method | MakeByRefType | Overridden. Returns a Type object that represents the current type when passed as a ref parameter (ByRef parameter in Visual Basic).
Public method | MakeGenericType | Overridden. Substitutes the elements of an array of types for the type parameters of the current generic type definition and returns a Type object representing the resulting constructed type.
Public method | MakePointerType | Overridden. Returns a Type object that represents a pointer to the current type.
Public method | ToString | Overridden. Returns a String representing the name of the current Type.
Top

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


UnresolvedType Constructor

UnresolvedType Constructor
[image]

Creates a reflection object backed by the specified adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal adapter As ITypeInfo _
)
C#
public UnresolvedType(
ITypeInfo adapter
)
C++
public:
UnresolvedType(
ITypeInfo adapter
) sealed
J#
public UnresolvedType(
ITypeInfo adapter
)
JScript
public function UnresolvedType(
adapter : ITypeInfo
)

Parameters

adapter
The adapter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if adapter is null

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Properties

UnresolvedType Properties
[image]

Public Properties

 | Name | Description
Public property | Adapter | Gets the underlying reflection adapter.
Public property | Assembly | Overridden. Gets the Assembly in which the type is declared. For generic types, gets the Assembly in which the generic type is defined.
Public property | AssemblyQualifiedName | Overridden. Gets the assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.
Public property | Attributes | Gets the attributes associated with the Type. (inherited from Type)
Public property | BaseType | Overridden. Gets the type from which the current Type directly inherits.
Public property | ContainsGenericParameters | Overridden. Gets a value indicating whether the current Type object has type parameters that have not been replaced by specific types.
Public property | DeclaringMethod | Overridden. Gets a MethodBase that represents the declaring method, if the current Type represents a type parameter of a generic method.
Public property | DeclaringType | Overridden. Gets the class that declares this member.
Public property | FullName | Overridden. Gets the fully qualified name of the Type, including the namespace of the Type but not the assembly.
Public property | GenericParameterAttributes | Overridden. Gets a combination of GenericParameterAttributes flags that describe the covariance and special constraints of the current generic type parameter.
Public property | GenericParameterPosition | Overridden. Gets the position of the type parameter in the type parameter list of the generic type or method that declared the parameter, when the Type object represents a type parameter of a generic type or a generic method.
Public property | GUID | Overridden. Gets the GUID associated with the Type.
Public property | HasElementType | Gets a value indicating whether the current Type encompasses or refers to another type; that is, whether the current Type is an array, a pointer, or is passed by reference. (inherited from Type)
Public property | IsAbstract | Gets a value indicating whether the Type is abstract and must be overridden. (inherited from Type)
Public property | IsAnsiClass | Gets a value indicating whether the string format attribute AnsiClass is selected for the Type. (inherited from Type)
Public property | IsArray | Gets a value indicating whether the Type is an array. (inherited from Type)
Public property | IsAutoClass | Gets a value indicating whether the string format attribute AutoClass is selected for the Type. (inherited from Type)
Public property | IsAutoLayout | Gets a value indicating whether the class layout attribute AutoLayout is selected for the Type. (inherited from Type)
Public property | IsByRef | Gets a value indicating whether the Type is passed by reference. (inherited from Type)
Public property | IsClass | Gets a value indicating whether the Type is a class; that is, not a value type or interface. (inherited from Type)
Public property | IsCOMObject | Gets a value indicating whether the Type is a COM object. (inherited from Type)
Public property | IsContextful | Gets a value indicating whether the Type can be hosted in a context. (inherited from Type)
Public property | IsEnum | Gets a value indicating whether the current Type represents an enumeration. (inherited from Type)
Public property | IsExplicitLayout | Gets a value indicating whether the class layout attribute ExplicitLayout is selected for the Type. (inherited from Type)
Public property | IsGenericParameter | Overridden. Gets a value indicating whether the current Type represents a type parameter in the definition of a generic type or method.
Public property | IsGenericType | Overridden. Gets a value indicating whether the current type is a generic type.
Public property | IsGenericTypeDefinition | Overridden. Gets a value indicating whether the current Type represents a generic type definition, from which other generic types can be constructed.
Public property | IsImport | Gets a value indicating whether the Type has a ComImportAttribute attribute applied, indicating that it was imported from a COM type library. (inherited from Type)
Public property | IsInterface | Gets a value indicating whether the Type is an interface; that is, not a class or a value type. (inherited from Type)
Public property | IsLayoutSequential | Gets a value indicating whether the class layout attribute SequentialLayout is selected for the Type. (inherited from Type)
Public property | IsMarshalByRef | Gets a value indicating whether the Type is marshaled by reference. (inherited from Type)
Public property | IsNested | Gets a value indicating whether the current Type object represents a type whose definition is nested inside the definition of another type. (inherited from Type)
Public property | IsNestedAssembly | Gets a value indicating whether the Type is nested and visible only within its own assembly. (inherited from Type)
Public property | IsNestedFamANDAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to both its own family and its own assembly. (inherited from Type)
Public property | IsNestedFamily | Gets a value indicating whether the Type is nested and visible only within its own family. (inherited from Type)
Public property | IsNestedFamORAssem | Gets a value indicating whether the Type is nested and visible only to classes that belong to either its own family or to its own assembly. (inherited from Type)
Public property | IsNestedPrivate | Gets a value indicating whether the Type is nested and declared private. (inherited from Type)
Public property | IsNestedPublic | Gets a value indicating whether a class is nested and declared public. (inherited from Type)
Public property | IsNotPublic | Gets a value indicating whether the Type is not declared public. (inherited from Type)
Public property | IsPointer | Gets a value indicating whether the Type is a pointer. (inherited from Type)
Public property | IsPrimitive | Gets a value indicating whether the Type is one of the primitive types. (inherited from Type)
Public property | IsPublic | Gets a value indicating whether the Type is declared public. (inherited from Type)
Public property | IsSealed | Gets a value indicating whether the Type is declared sealed. (inherited from Type)
Public property | IsSerializable | Gets a value indicating whether the Type is serializable. (inherited from Type)
Public property | IsSpecialName | Gets a value indicating whether the Type has a name that requires special handling. (inherited from Type)
Public property | IsUnicodeClass | Gets a value indicating whether the string format attribute UnicodeClass is selected for the Type. (inherited from Type)
Public property | IsValueType | Gets a value indicating whether the Type is a value type. (inherited from Type)
Public property | IsVisible | Gets a value indicating whether the Type can be accessed by code outside the assembly. (inherited from Type)
Public property | MemberType | Overridden. Gets a MemberTypes value indicating that this member is a type or a nested type.
Public property | MetadataToken | Overridden. Gets a value that identifies a metadata element.
Public property | Module | Overridden. Gets the module (the DLL) in which the current Type is defined.
Public property | Name | Overridden. Gets the name of the current member.
Public property | Namespace | Overridden. Gets the namespace of the Type.
Public property | ReflectedType | Overridden. Gets the class object that was used to obtain this member.
Public property | StructLayoutAttribute | Overridden. Gets a StructLayoutAttribute that describes the layout of the current type.
Public property | TypeHandle | Overridden. Gets the handle for the current Type.
Public property | TypeInitializer | Gets the initializer for the Type. (inherited from Type)
Public property | UnderlyingSystemType | Overridden. Indicates the type provided by the common language runtime that represents this type.
Top

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Adapter Property

UnresolvedType.Adapter Property
[image]

Gets the underlying reflection adapter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adapter As ITypeInfo
C#
public ITypeInfo Adapter { get; }
C++
public property ITypeInfo Adapter sealed {
ITypeInfo get();
}
J#
/** property */
public ITypeInfo get_Adapter();
JScript
public function get Adapter() : ITypeInfo

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Assembly Property

UnresolvedType.Assembly Property
[image]

Gets the Assembly in which the type is declared. For generic types, gets the Assembly in which the generic type is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Assembly As Assembly
C#
public override Assembly Assembly { get; }
C++
public override property Assembly Assembly override {
Assembly get();
}
J#
/** property */
public Assembly get_Assembly();
JScript
public function get Assembly() : Assembly

Property Value

An Assembly instance that describes the assembly containing the current type. For generic types, the instance describes the assembly that contains the generic type definition, not the assembly that creates and uses a particular constructed type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


AssemblyQualifiedName Property

UnresolvedType.AssemblyQualifiedName Property
[image]

Gets the assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AssemblyQualifiedName As String
C#
public override string AssemblyQualifiedName { get; }
C++
public override property string AssemblyQualifiedName override {
String get();
}
J#
/** property */
public string get_AssemblyQualifiedName();
JScript
public function get AssemblyQualifiedName() : String

Property Value

The assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded, or null if the current instance represents a generic type parameter.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


BaseType Property

UnresolvedType.BaseType Property
[image]

Gets the type from which the current Type directly inherits.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BaseType As Type
C#
public override Type BaseType { get; }
C++
public override property Type BaseType override {
Type get();
}
J#
/** property */
public Type get_BaseType();
JScript
public function get BaseType() : Type

Property Value

The Type from which the current Type directly inherits, or null if the current Type represents the Object class.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


ContainsGenericParameters Property

UnresolvedType.ContainsGenericParameters Property
[image]

Gets a value indicating whether the current Type object has type parameters that have not been replaced by specific types.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContainsGenericParameters As Boolean
C#
public override bool ContainsGenericParameters { get; }
C++
public override property bool ContainsGenericParameters override {
bool get();
}
J#
/** property */
public bool get_ContainsGenericParameters();
JScript
public function get ContainsGenericParameters() : bool

Property Value

true if the Type object has type parameters for which specific types have not been supplied; otherwise, false.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


DeclaringMethod Property

UnresolvedType.DeclaringMethod Property
[image]

Gets a MethodBase that represents the declaring method, if the current Type represents a type parameter of a generic method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringMethod As MethodBase
C#
public override MethodBase DeclaringMethod { get; }
C++
public override property MethodBase DeclaringMethod override {
MethodBase get();
}
J#
/** property */
public MethodBase get_DeclaringMethod();
JScript
public function get DeclaringMethod() : MethodBase

Property Value

If the current Type represents a type parameter of a generic method, a MethodBase that represents declaring method; otherwise, null.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


DeclaringType Property

UnresolvedType.DeclaringType Property
[image]

Gets the class that declares this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DeclaringType As Type
C#
public override Type DeclaringType { get; }
C++
public override property Type DeclaringType override {
Type get();
}
J#
/** property */
public Type get_DeclaringType();
JScript
public function get DeclaringType() : Type

Property Value

The Type object for the class that declares this member. If the type is a nested type, this property returns the enclosing type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


FullName Property

UnresolvedType.FullName Property
[image]

Gets the fully qualified name of the Type, including the namespace of the Type but not the assembly.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FullName As String
C#
public override string FullName { get; }
C++
public override property string FullName override {
String get();
}
J#
/** property */
public string get_FullName();
JScript
public function get FullName() : String

Property Value

A string containing the fully qualified name of the Type, including the namespace of the Type but not the assembly, or null if the current instance represents a generic type parameter.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GenericParameterAttributes Property

UnresolvedType.GenericParameterAttributes Property
[image]

Gets a combination of GenericParameterAttributes flags that describe the covariance and special constraints of the current generic type parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property GenericParameterAttributes As GenericParameterAttributes
C#
public override GenericParameterAttributes GenericParameterAttributes { get; }
C++
public override property GenericParameterAttributes GenericParameterAttributes override {
GenericParameterAttributes get();
}
J#
/** property */
public GenericParameterAttributes get_GenericParameterAttributes();
JScript
public function get GenericParameterAttributes() : GenericParameterAttributes

Property Value

A bitwise combination of GenericParameterAttributes values that describes the covariance and special constraints of the current generic type parameter.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GenericParameterPosition Property

UnresolvedType.GenericParameterPosition Property
[image]

Gets the position of the type parameter in the type parameter list of the generic type or method that declared the parameter, when the Type object represents a type parameter of a generic type or a generic method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property GenericParameterPosition As Integer
C#
public override int GenericParameterPosition { get; }
C++
public override property int GenericParameterPosition override {
int get();
}
J#
/** property */
public int get_GenericParameterPosition();
JScript
public function get GenericParameterPosition() : int

Property Value

The position of a type parameter in the type parameter list of the generic type or method that defines the parameter. Position numbers begin at 0.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GUID Property

UnresolvedType.GUID Property
[image]

Gets the GUID associated with the Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property GUID As Guid
C#
public override Guid GUID { get; }
C++
public override property Guid GUID override {
Guid get();
}
J#
/** property */
public Guid get_GUID();
JScript
public function get GUID() : Guid

Property Value

The GUID associated with the Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


IsGenericParameter Property

UnresolvedType.IsGenericParameter Property
[image]

Gets a value indicating whether the current Type represents a type parameter in the definition of a generic type or method.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericParameter As Boolean
C#
public override bool IsGenericParameter { get; }
C++
public override property bool IsGenericParameter override {
bool get();
}
J#
/** property */
public bool get_IsGenericParameter();
JScript
public function get IsGenericParameter() : bool

Property Value

true if the Type object represents a type parameter of a generic type definition or generic method definition; otherwise, false.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


IsGenericType Property

UnresolvedType.IsGenericType Property
[image]

Gets a value indicating whether the current type is a generic type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericType As Boolean
C#
public override bool IsGenericType { get; }
C++
public override property bool IsGenericType override {
bool get();
}
J#
/** property */
public bool get_IsGenericType();
JScript
public function get IsGenericType() : bool

Property Value

true if the current type is a generic type; otherwise, false.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


IsGenericTypeDefinition Property

UnresolvedType.IsGenericTypeDefinition Property
[image]

Gets a value indicating whether the current Type represents a generic type definition, from which other generic types can be constructed.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsGenericTypeDefinition As Boolean
C#
public override bool IsGenericTypeDefinition { get; }
C++
public override property bool IsGenericTypeDefinition override {
bool get();
}
J#
/** property */
public bool get_IsGenericTypeDefinition();
JScript
public function get IsGenericTypeDefinition() : bool

Property Value

true if the Type object represents a generic type definition; otherwise, false.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


MemberType Property

UnresolvedType.MemberType Property
[image]

Gets a MemberTypes value indicating that this member is a type or a nested type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberType As MemberTypes
C#
public override MemberTypes MemberType { get; }
C++
public override property MemberTypes MemberType override {
MemberTypes get();
}
J#
/** property */
public MemberTypes get_MemberType();
JScript
public function get MemberType() : MemberTypes

Property Value

A MemberTypes value indicating that this member is a type or a nested type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


MetadataToken Property

UnresolvedType.MetadataToken Property
[image]

Gets a value that identifies a metadata element.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property MetadataToken As Integer
C#
public override int MetadataToken { get; }
C++
public override property int MetadataToken override {
int get();
}
J#
/** property */
public int get_MetadataToken();
JScript
public function get MetadataToken() : int

Property Value

A value which, in combination with Module, uniquely identifies a metadata element.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Module Property

UnresolvedType.Module Property
[image]

Gets the module (the DLL) in which the current Type is defined.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Module As Module
C#
public override Module Module { get; }
C++
public override property Module Module override {
Module get();
}
J#
/** property */
public Module get_Module();
JScript
public function get Module() : Module

Property Value

The name of the module in which the current Type is defined.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Name Property

UnresolvedType.Name Property
[image]

Gets the name of the current member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

A String containing the name of this member.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Namespace Property

UnresolvedType.Namespace Property
[image]

Gets the namespace of the Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Namespace As String
C#
public override string Namespace { get; }
C++
public override property string Namespace override {
String get();
}
J#
/** property */
public string get_Namespace();
JScript
public function get Namespace() : String

Property Value

The namespace of the Type, or null if the current instance represents a generic parameter.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


ReflectedType Property

UnresolvedType.ReflectedType Property
[image]

Gets the class object that was used to obtain this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReflectedType As Type
C#
public override Type ReflectedType { get; }
C++
public override property Type ReflectedType override {
Type get();
}
J#
/** property */
public Type get_ReflectedType();
JScript
public function get ReflectedType() : Type

Property Value

The Type object through which this MemberInfo object was obtained.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


StructLayoutAttribute Property

UnresolvedType.StructLayoutAttribute Property
[image]

Gets a StructLayoutAttribute that describes the layout of the current type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property StructLayoutAttribute As StructLayoutAttribute
C#
public override StructLayoutAttribute StructLayoutAttribute { get; }
C++
public override property StructLayoutAttribute StructLayoutAttribute override {
StructLayoutAttribute get();
}
J#
/** property */
public StructLayoutAttribute get_StructLayoutAttribute();
JScript
public function get StructLayoutAttribute() : StructLayoutAttribute

Property Value

Gets a StructLayoutAttribute that describes the gross layout features of the current type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


TypeHandle Property

UnresolvedType.TypeHandle Property
[image]

Gets the handle for the current Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TypeHandle As RuntimeTypeHandle
C#
public override RuntimeTypeHandle TypeHandle { get; }
C++
public override property RuntimeTypeHandle TypeHandle override {
RuntimeTypeHandle get();
}
J#
/** property */
public RuntimeTypeHandle get_TypeHandle();
JScript
public function get TypeHandle() : RuntimeTypeHandle

Property Value

The handle for the current Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


UnderlyingSystemType Property

UnresolvedType.UnderlyingSystemType Property
[image]

Indicates the type provided by the common language runtime that represents this type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property UnderlyingSystemType As Type _
Implements IReflect.UnderlyingSystemType
C#
public override Type UnderlyingSystemType { get; }
C++
public override property Type UnderlyingSystemType override {
Type get();
}
J#
/** property */
public Type get_UnderlyingSystemType();
JScript
public function get UnderlyingSystemType() : Type

Property Value

The underlying system type for the Type.

Implements

IReflect.UnderlyingSystemType

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Methods

UnresolvedType Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.
Public method | FindInterfaces | Returns an array of Type objects representing a filtered list of interfaces implemented or inherited by the current Type. (inherited from Type)
Public method | FindMembers | Returns a filtered array of MemberInfo objects of the specified member type. (inherited from Type)
Public method | GetArrayRank | Overridden. Gets the number of dimensions in an Array.
Public method | GetConstructor | Overloaded. Gets a specific constructor of the current Type. (inherited from Type)
Public method | GetConstructors | Overloaded. Gets the constructors of the current Type.
Public method | GetCustomAttributes | Overloaded. When overridden in a derived class, returns all attributes applied to this member.
Public method | GetDefaultMembers | Overridden. Searches for the members defined for the current Type whose DefaultMemberAttribute is set.
Public method | GetElementType | Overridden. When overridden in a derived class, returns the Type of the object encompassed or referred to by the current array, pointer or reference type.
Public method | GetEvent | Overloaded. Gets a specific event declared or inherited by the current Type.
Public method | GetEvents | Overloaded. Gets the events that are declared or inherited by the current Type.
Public method | GetField | Overloaded. Gets a specific field of the current Type.
Public method | GetFields | Overloaded. Gets the fields of the current Type.
Public method | GetGenericArguments | Overridden. Returns an array of Type objects that represent the type arguments of a generic type or the type parameters of a generic type definition.
Public method | GetGenericParameterConstraints | Overridden. Returns an array of Type objects that represent the constraints on the current generic type parameter.
Public method | GetGenericTypeDefinition | Overridden. Returns a Type object that represents a generic type definition from which the current generic type can be constructed.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetInterface | Overloaded. Gets a specific interface implemented or inherited by the current Type.
Public method | GetInterfaceMap | Overridden. Returns an interface mapping for the specified interface type.
Public method | GetInterfaces | Overridden. When overridden in a derived class, gets all the interfaces implemented or inherited by the current Type.
Public method | GetMember | Overloaded. Gets the specified members of the current Type.
Public method | GetMembers | Overloaded. Gets the members (properties, methods, fields, events, and so on) of the current Type.
Public method | GetMethod | Overloaded. Gets a specific method of the current Type. (inherited from Type)
Public method | GetMethods | Overloaded. Gets the methods of the current Type.
Public method | GetNestedType | Overloaded. Gets a specific type nested within the current Type.
Public method | GetNestedTypes | Overloaded. Gets the types nested within the current Type.
Public method | GetProperties | Overloaded. Gets the properties of the current Type.
Public method | GetProperty | Overloaded. Gets a specific property of the current Type. (inherited from Type)
Public method | GetType | Gets the current Type. (inherited from Type)
Public method | InvokeMember | Overloaded. Invokes a specific member of the current Type.
Public method | IsAssignableFrom | Overridden. Determines whether an instance of the current Type can be assigned from an instance of the specified Type.
Public method | IsDefined | Overridden. When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.
Public method | IsInstanceOfType | Overridden. Determines whether the specified object is an instance of the current Type.
Public method | IsSubclassOf | Overridden. Determines whether the class represented by the current Type derives from the class represented by the specified Type.
Public method | MakeArrayType | Overloaded. Returns a Type object that represents an array of the current type.
Public method | MakeByRefType | Overridden. Returns a Type object that represents the current type when passed as a ref parameter (ByRef parameter in Visual Basic).
Public method | MakeGenericType | Overridden. Substitutes the elements of an array of types for the type parameters of the current generic type definition and returns a Type object representing the resulting constructed type.
Public method | MakePointerType | Overridden. Returns a Type object that represents a pointer to the current type.
Public method | ToString | Overridden. Returns a String representing the name of the current Type.
Top

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Equals Method

UnresolvedType.Equals Method

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object or Type.

Overload List

 | Name | Description
Public method | Equals (Object) | Overridden. Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object.
Public method | Equals (Type) | Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


Equals Method (Object)

UnresolvedType.Equals Method (Object)
See Also Example
[image]

Determines if the underlying system type of the current Type is the same as the underlying system type of the specified Object.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal o As Object _
) As Boolean
C#
public override bool Equals(
object o
)
C++
public:
virtual bool Equals(
Object o
) override
J#
public override bool Equals(
object o
)
JScript
public override function Equals(
o : Object
) : bool

Parameters

o
The Object whose underlying system type is to be compared with the underlying system type of the current Type.

Return Value

true if the underlying system type of o is the same as the underlying system type of the current Type; otherwise, false. This method also returns false if the object specified by the o parameter is not a Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.Equals Overload List


GetArrayRank Method

UnresolvedType.GetArrayRank Method
[image]

Gets the number of dimensions in an Array.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetArrayRank() As Integer
C#
public override int GetArrayRank()
C++
public:
virtual int GetArrayRank() override
J#
public override int GetArrayRank()
JScript
public override function GetArrayRank() : int

Return Value

An Int32 containing the number of dimensions in the current Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetConstructors Method

UnresolvedType.GetConstructors Method

Gets the constructors of the current Type.

Overload List

 | Name | Description
Public method | GetConstructors (BindingFlags) | Overridden. When overridden in a derived class, searches for the constructors defined for the current Type, using the specified BindingFlags.
Public method | GetConstructors | Returns all the public constructors defined for the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetConstructors Method (BindingFlags)

UnresolvedType.GetConstructors Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the constructors defined for the current Type, using the specified BindingFlags.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetConstructors( _
ByVal bindingAttr As BindingFlags _
) As ConstructorInfo()
C#
public override ConstructorInfo[] GetConstructors(
BindingFlags bindingAttr
)
C++
public:
virtual array<ConstructorInfo>^ GetConstructors(
BindingFlags bindingAttr
) override
J#
public override ConstructorInfo[] GetConstructors(
BindingFlags bindingAttr
)
JScript
public override function GetConstructors(
bindingAttr : BindingFlags
) : ConstructorInfo[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of ConstructorInfo objects representing all constructors defined for the current Type that match the specified binding constraints, including the type initializer if it is defined. Returns an empty array of type ConstructorInfo if no constructors are defined for the current Type, if none of the defined constructors match the binding constraints, or if the current Type represents a type parameter in the definition of a generic type or generic method.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetConstructors Overload List


GetCustomAttributes Method

UnresolvedType.GetCustomAttributes Method

When overridden in a derived class, returns all attributes applied to this member.

Overload List

 | Name | Description
Public method | GetCustomAttributes (Boolean) | Overridden. When overridden in a derived class, returns an array containing all the custom attributes.
Public method | GetCustomAttributes (Type, Boolean) | Overridden. When overridden in a derived class, returns an array of custom attributes identified by Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetCustomAttributes Method (Boolean)

UnresolvedType.GetCustomAttributes Method (Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array containing all the custom attributes.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
bool inherit
) override
J#
public override object[] GetCustomAttributes(
bool inherit
)
JScript
public override function GetCustomAttributes(
inherit : bool
) : Object[]

Parameters

inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array that contains all the custom attributes, or an array with zero elements if no attributes are defined.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetCustomAttributes Overload List


GetCustomAttributes Method (Type, Boolean)

UnresolvedType.GetCustomAttributes Method (Type, Boolean)
See Also Example
[image]

When overridden in a derived class, returns an array of custom attributes identified by Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCustomAttributes( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Object() _
Implements ICustomAttributeProvider.GetCustomAttributes
C#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
C++
public:
virtual array<Object>^ GetCustomAttributes(
Type attributeType,
bool inherit
) override
J#
public override object[] GetCustomAttributes(
Type attributeType,
bool inherit
)
JScript
public override function GetCustomAttributes(
attributeType : Type,
inherit : bool
) : Object[]

Parameters

attributeType
The type of attribute to search for. Only attributes that are assignable to this type are returned.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

An array of custom attributes applied to this member, or an array with zero (0) elements if no attributes have been applied.

Implements

ICustomAttributeProvider.GetCustomAttributes

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetCustomAttributes Overload List


GetDefaultMembers Method

UnresolvedType.GetDefaultMembers Method
[image]

Searches for the members defined for the current Type whose DefaultMemberAttribute is set.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetDefaultMembers() As MemberInfo()
C#
public override MemberInfo[] GetDefaultMembers()
C++
public:
virtual array<MemberInfo>^ GetDefaultMembers() override
J#
public override MemberInfo[] GetDefaultMembers()
JScript
public override function GetDefaultMembers() : MemberInfo[]

Return Value

An array of MemberInfo objects representing all default members of the current Type.-or- An empty array of type MemberInfo, if the current Type does not have default members.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetElementType Method

UnresolvedType.GetElementType Method
[image]

When overridden in a derived class, returns the Type of the object encompassed or referred to by the current array, pointer or reference type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetElementType() As Type
C#
public override Type GetElementType()
C++
public:
virtual Type GetElementType() override
J#
public override Type GetElementType()
JScript
public override function GetElementType() : Type

Return Value

The Type of the object encompassed or referred to by the current array, pointer, or reference type, or null if the current Type is not an array or a pointer, or is not passed by reference, or represents a generic type or a type parameter in the definition of a generic type or generic method.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetEvent Method

UnresolvedType.GetEvent Method

Gets a specific event declared or inherited by the current Type.

Overload List

 | Name | Description
Public method | GetEvent (String, BindingFlags) | Overridden. When overridden in a derived class, returns the EventInfo object representing the specified event, using the specified binding constraints.
Public method | GetEvent (String) | Returns the EventInfo object representing the specified public event. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetEvent Method (String, BindingFlags)

UnresolvedType.GetEvent Method (String, BindingFlags)
See Also Example
[image]

When overridden in a derived class, returns the EventInfo object representing the specified event, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEvent( _
ByVal name As String, _
ByVal bindingAttr As BindingFlags _
) As EventInfo
C#
public override EventInfo GetEvent(
string name,
BindingFlags bindingAttr
)
C++
public:
virtual EventInfo GetEvent(
String name,
BindingFlags bindingAttr
) override
J#
public override EventInfo GetEvent(
string name,
BindingFlags bindingAttr
)
JScript
public override function GetEvent(
name : String,
bindingAttr : BindingFlags
) : EventInfo

Parameters

name
The String containing the name of an event which is declared or inherited by the current Type.
bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

The EventInfo object representing the specified event which is declared or inherited by the current Type, if found; otherwise, null.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetEvent Overload List


GetEvents Method

UnresolvedType.GetEvents Method

Gets the events that are declared or inherited by the current Type.

Overload List

 | Name | Description
Public method | GetEvents (BindingFlags) | Overridden. When overridden in a derived class, searches for events that are declared or inherited by the current Type, using the specified binding constraints.
Public method | GetEvents | Returns all the public events that are declared or inherited by the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetEvents Method (BindingFlags)

UnresolvedType.GetEvents Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for events that are declared or inherited by the current Type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEvents( _
ByVal bindingAttr As BindingFlags _
) As EventInfo()
C#
public override EventInfo[] GetEvents(
BindingFlags bindingAttr
)
C++
public:
virtual array<EventInfo>^ GetEvents(
BindingFlags bindingAttr
) override
J#
public override EventInfo[] GetEvents(
BindingFlags bindingAttr
)
JScript
public override function GetEvents(
bindingAttr : BindingFlags
) : EventInfo[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of EventInfo objects representing all events which are declared or inherited by the current Type that match the specified binding constraints.-or- An empty array of type EventInfo, if the current Type does not have events, or if none of the events match the binding constraints.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetEvents Overload List


GetField Method

UnresolvedType.GetField Method

Gets a specific field of the current Type.

Overload List

 | Name | Description
Public method | GetField (String, BindingFlags) | Overridden. Searches for the specified field, using the specified binding constraints.
Public method | GetField (String) | Searches for the public field with the specified name. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetField Method (String, BindingFlags)

UnresolvedType.GetField Method (String, BindingFlags)
See Also Example
[image]

Searches for the specified field, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetField( _
ByVal name As String, _
ByVal bindingAttr As BindingFlags _
) As FieldInfo _
Implements IReflect.GetField
C#
public override FieldInfo GetField(
string name,
BindingFlags bindingAttr
)
C++
public:
virtual FieldInfo GetField(
String name,
BindingFlags bindingAttr
) override
J#
public override FieldInfo GetField(
string name,
BindingFlags bindingAttr
)
JScript
public override function GetField(
name : String,
bindingAttr : BindingFlags
) : FieldInfo

Parameters

name
The String containing the name of the data field to get.
bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

A FieldInfo object representing the field that matches the specified requirements, if found; otherwise, null.

Implements

IReflect.GetField

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetField Overload List


GetFields Method

UnresolvedType.GetFields Method

Gets the fields of the current Type.

Overload List

 | Name | Description
Public method | GetFields (BindingFlags) | Overridden. When overridden in a derived class, searches for the fields defined for the current Type, using the specified binding constraints.
Public method | GetFields | Returns all the public fields of the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetFields Method (BindingFlags)

UnresolvedType.GetFields Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the fields defined for the current Type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFields( _
ByVal bindingAttr As BindingFlags _
) As FieldInfo() _
Implements IReflect.GetFields
C#
public override FieldInfo[] GetFields(
BindingFlags bindingAttr
)
C++
public:
virtual array<FieldInfo>^ GetFields(
BindingFlags bindingAttr
) override
J#
public override FieldInfo[] GetFields(
BindingFlags bindingAttr
)
JScript
public override function GetFields(
bindingAttr : BindingFlags
) : FieldInfo[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of FieldInfo objects representing all fields defined for the current Type that match the specified binding constraints.-or- An empty array of type FieldInfo, if no fields are defined for the current Type, or if none of the defined fields match the binding constraints.

Implements

IReflect.GetFields

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetFields Overload List


GetGenericArguments Method

UnresolvedType.GetGenericArguments Method
[image]

Returns an array of Type objects that represent the type arguments of a generic type or the type parameters of a generic type definition.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGenericArguments() As Type()
C#
public override Type[] GetGenericArguments()
C++
public:
virtual array<Type>^ GetGenericArguments() override
J#
public override Type[] GetGenericArguments()
JScript
public override function GetGenericArguments() : Type[]

Return Value

An array of Type objects that represent the type arguments of a generic type. Returns an empty array if the current type is not a generic type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetGenericParameterConstraints Method

UnresolvedType.GetGenericParameterConstraints Method
[image]

Returns an array of Type objects that represent the constraints on the current generic type parameter.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGenericParameterConstraints() As Type()
C#
public override Type[] GetGenericParameterConstraints()
C++
public:
virtual array<Type>^ GetGenericParameterConstraints() override
J#
public override Type[] GetGenericParameterConstraints()
JScript
public override function GetGenericParameterConstraints() : Type[]

Return Value

An array of Type objects that represent the constraints on the current generic type parameter.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetGenericTypeDefinition Method

UnresolvedType.GetGenericTypeDefinition Method
[image]

Returns a Type object that represents a generic type definition from which the current generic type can be constructed.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetGenericTypeDefinition() As Type
C#
public override Type GetGenericTypeDefinition()
C++
public:
virtual Type GetGenericTypeDefinition() override
J#
public override Type GetGenericTypeDefinition()
JScript
public override function GetGenericTypeDefinition() : Type

Return Value

A Type object representing a generic type from which the current type can be constructed.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetHashCode Method

UnresolvedType.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

An Int32 containing the hash code for this instance.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetInterface Method

UnresolvedType.GetInterface Method

Gets a specific interface implemented or inherited by the current Type.

Overload List

 | Name | Description
Public method | GetInterface (String, Boolean) | Overridden. When overridden in a derived class, searches for the specified interface, specifying whether to do a case-sensitive search.
Public method | GetInterface (String) | Searches for the interface with the specified name. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetInterface Method (String, Boolean)

UnresolvedType.GetInterface Method (String, Boolean)
See Also Example
[image]

When overridden in a derived class, searches for the specified interface, specifying whether to do a case-sensitive search.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetInterface( _
ByVal name As String, _
ByVal ignoreCase As Boolean _
) As Type
C#
public override Type GetInterface(
string name,
bool ignoreCase
)
C++
public:
virtual Type GetInterface(
String name,
bool ignoreCase
) override
J#
public override Type GetInterface(
string name,
bool ignoreCase
)
JScript
public override function GetInterface(
name : String,
ignoreCase : bool
) : Type

Parameters

name
The String containing the name of the interface to get. For generic interfaces, this is the mangled name.
ignoreCase
true to perform a case-insensitive search for name.-or- false to perform a case-sensitive search for name.

Return Value

A Type object representing the interface with the specified name, implemented or inherited by the current Type, if found; otherwise, null.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetInterface Overload List


GetInterfaceMap Method

UnresolvedType.GetInterfaceMap Method
[image]

Returns an interface mapping for the specified interface type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetInterfaceMap( _
ByVal interfaceType As Type _
) As InterfaceMapping
C#
public override InterfaceMapping GetInterfaceMap(
Type interfaceType
)
C++
public:
virtual InterfaceMapping GetInterfaceMap(
Type interfaceType
) override
J#
public override InterfaceMapping GetInterfaceMap(
Type interfaceType
)
JScript
public override function GetInterfaceMap(
interfaceType : Type
) : InterfaceMapping

Parameters

interfaceType
The Type of the interface of which to retrieve a mapping.

Return Value

An InterfaceMapping object representing the interface mapping for interfaceType.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetInterfaces Method

UnresolvedType.GetInterfaces Method
[image]

When overridden in a derived class, gets all the interfaces implemented or inherited by the current Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetInterfaces() As Type()
C#
public override Type[] GetInterfaces()
C++
public:
virtual array<Type>^ GetInterfaces() override
J#
public override Type[] GetInterfaces()
JScript
public override function GetInterfaces() : Type[]

Return Value

An array of Type objects representing all the interfaces implemented or inherited by the current Type.-or- An empty array of type Type, if no interfaces are implemented or inherited by the current Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetMember Method

UnresolvedType.GetMember Method

Gets the specified members of the current Type.

Overload List

 | Name | Description
Public method | GetMember (String, MemberTypes, BindingFlags) | Overridden. Searches for the specified members of the specified member type, using the specified binding constraints.
Public method | GetMember (String) | Searches for the public members with the specified name. (inherited from Type)
Public method | GetMember (String, BindingFlags) | Searches for the specified members, using the specified binding constraints. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetMember Method (String, MemberTypes, BindingFlags)

UnresolvedType.GetMember Method (String, MemberTypes, BindingFlags)
See Also Example
[image]

Searches for the specified members of the specified member type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMember( _
ByVal name As String, _
ByVal type As MemberTypes, _
ByVal bindingAttr As BindingFlags _
) As MemberInfo()
C#
public override MemberInfo[] GetMember(
string name,
MemberTypes type,
BindingFlags bindingAttr
)
C++
public:
virtual array<MemberInfo>^ GetMember(
String name,
MemberTypes type,
BindingFlags bindingAttr
) override
J#
public override MemberInfo[] GetMember(
string name,
MemberTypes type,
BindingFlags bindingAttr
)
JScript
public override function GetMember(
name : String,
type : MemberTypes,
bindingAttr : BindingFlags
) : MemberInfo[]

Parameters

name
The String containing the name of the members to get.
type
The MemberTypes value to search for.
bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return an empty array.

Return Value

An array of MemberInfo objects representing the public members with the specified name, if found; otherwise, an empty array.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetMember Overload List


GetMembers Method

UnresolvedType.GetMembers Method

Gets the members (properties, methods, fields, events, and so on) of the current Type.

Overload List

 | Name | Description
Public method | GetMembers (BindingFlags) | Overridden. When overridden in a derived class, searches for the members defined for the current Type, using the specified binding constraints.
Public method | GetMembers | Returns all the public members of the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetMembers Method (BindingFlags)

UnresolvedType.GetMembers Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the members defined for the current Type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMembers( _
ByVal bindingAttr As BindingFlags _
) As MemberInfo() _
Implements IReflect.GetMembers
C#
public override MemberInfo[] GetMembers(
BindingFlags bindingAttr
)
C++
public:
virtual array<MemberInfo>^ GetMembers(
BindingFlags bindingAttr
) override
J#
public override MemberInfo[] GetMembers(
BindingFlags bindingAttr
)
JScript
public override function GetMembers(
bindingAttr : BindingFlags
) : MemberInfo[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of MemberInfo objects representing all members defined for the current Type that match the specified binding constraints.-or- An empty array of type MemberInfo, if no members are defined for the current Type, or if none of the defined members match the binding constraints.

Implements

IReflect.GetMembers

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetMembers Overload List


GetMethods Method

UnresolvedType.GetMethods Method

Gets the methods of the current Type.

Overload List

 | Name | Description
Public method | GetMethods (BindingFlags) | Overridden. When overridden in a derived class, searches for the methods defined for the current Type, using the specified binding constraints.
Public method | GetMethods | Returns all the public methods of the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetMethods Method (BindingFlags)

UnresolvedType.GetMethods Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the methods defined for the current Type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetMethods( _
ByVal bindingAttr As BindingFlags _
) As MethodInfo() _
Implements IReflect.GetMethods
C#
public override MethodInfo[] GetMethods(
BindingFlags bindingAttr
)
C++
public:
virtual array<MethodInfo>^ GetMethods(
BindingFlags bindingAttr
) override
J#
public override MethodInfo[] GetMethods(
BindingFlags bindingAttr
)
JScript
public override function GetMethods(
bindingAttr : BindingFlags
) : MethodInfo[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of MethodInfo objects representing all methods defined for the current Type that match the specified binding constraints.-or- An empty array of type MethodInfo, if no methods are defined for the current Type, or if none of the defined methods match the binding constraints.

Implements

IReflect.GetMethods

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetMethods Overload List


GetNestedType Method

UnresolvedType.GetNestedType Method

Gets a specific type nested within the current Type.

Overload List

 | Name | Description
Public method | GetNestedType (String, BindingFlags) | Overridden. When overridden in a derived class, searches for the specified nested type, using the specified binding constraints.
Public method | GetNestedType (String) | Searches for the public nested type with the specified name. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetNestedType Method (String, BindingFlags)

UnresolvedType.GetNestedType Method (String, BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the specified nested type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetNestedType( _
ByVal name As String, _
ByVal bindingAttr As BindingFlags _
) As Type
C#
public override Type GetNestedType(
string name,
BindingFlags bindingAttr
)
C++
public:
virtual Type GetNestedType(
String name,
BindingFlags bindingAttr
) override
J#
public override Type GetNestedType(
string name,
BindingFlags bindingAttr
)
JScript
public override function GetNestedType(
name : String,
bindingAttr : BindingFlags
) : Type

Parameters

name
The string containing the name of the nested type to get.
bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

A Type object representing the nested type that matches the specified requirements, if found; otherwise, null.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetNestedType Overload List


GetNestedTypes Method

UnresolvedType.GetNestedTypes Method

Gets the types nested within the current Type.

Overload List

 | Name | Description
Public method | GetNestedTypes (BindingFlags) | Overridden. When overridden in a derived class, searches for the types nested within the current Type, using the specified binding constraints.
Public method | GetNestedTypes | Returns all the public types nested within the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetNestedTypes Method (BindingFlags)

UnresolvedType.GetNestedTypes Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the types nested within the current Type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetNestedTypes( _
ByVal bindingAttr As BindingFlags _
) As Type()
C#
public override Type[] GetNestedTypes(
BindingFlags bindingAttr
)
C++
public:
virtual array<Type>^ GetNestedTypes(
BindingFlags bindingAttr
) override
J#
public override Type[] GetNestedTypes(
BindingFlags bindingAttr
)
JScript
public override function GetNestedTypes(
bindingAttr : BindingFlags
) : Type[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of Type objects representing all the types nested within the current Type that match the specified binding constraints.-or- An empty array of type Type, if no types are nested within the current Type, or if none of the nested types match the binding constraints.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetNestedTypes Overload List


GetProperties Method

UnresolvedType.GetProperties Method

Gets the properties of the current Type.

Overload List

 | Name | Description
Public method | GetProperties (BindingFlags) | Overridden. When overridden in a derived class, searches for the properties of the current Type, using the specified binding constraints.
Public method | GetProperties | Returns all the public properties of the current Type. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


GetProperties Method (BindingFlags)

UnresolvedType.GetProperties Method (BindingFlags)
See Also Example
[image]

When overridden in a derived class, searches for the properties of the current Type, using the specified binding constraints.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperties( _
ByVal bindingAttr As BindingFlags _
) As PropertyInfo() _
Implements IReflect.GetProperties
C#
public override PropertyInfo[] GetProperties(
BindingFlags bindingAttr
)
C++
public:
virtual array<PropertyInfo>^ GetProperties(
BindingFlags bindingAttr
) override
J#
public override PropertyInfo[] GetProperties(
BindingFlags bindingAttr
)
JScript
public override function GetProperties(
bindingAttr : BindingFlags
) : PropertyInfo[]

Parameters

bindingAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted.-or- Zero, to return null.

Return Value

An array of PropertyInfo objects representing all properties of the current Type that match the specified binding constraints.-or- An empty array of type PropertyInfo, if the current Type does not have properties, or if none of the properties match the binding constraints.

Implements

IReflect.GetProperties

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.GetProperties Overload List


InvokeMember Method

UnresolvedType.InvokeMember Method

Invokes a specific member of the current Type.

Overload List

 | Name | Description
Public method | InvokeMember (String, BindingFlags, Binder, Object, Object, ParameterModifier, CultureInfo, String) | Overridden. When overridden in a derived class, invokes the specified member, using the specified binding constraints and matching the specified argument list, modifiers and culture.
Public method | InvokeMember (String, BindingFlags, Binder, Object, Object) | Invokes the specified member, using the specified binding constraints and matching the specified argument list. (inherited from Type)
Public method | InvokeMember (String, BindingFlags, Binder, Object, Object, CultureInfo) | Invokes the specified member, using the specified binding constraints and matching the specified argument list and culture. (inherited from Type)

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


InvokeMember Method (String, BindingFlags, Binder, Object, Object[], ParameterModifier[], CultureInfo, String[])

UnresolvedType.InvokeMember Method (String, BindingFlags, Binder, Object, Object[], ParameterModifier[], CultureInfo, String[])
See Also Example
[image]

When overridden in a derived class, invokes the specified member, using the specified binding constraints and matching the specified argument list, modifiers and culture.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function InvokeMember( _
ByVal name As String, _
ByVal invokeAttr As BindingFlags, _
ByVal binder As Binder, _
ByVal target As Object, _
ByVal args As Object(), _
ByVal modifiers As ParameterModifier(), _
ByVal culture As CultureInfo, _
ByVal namedParameters As String() _
) As Object _
Implements IReflect.InvokeMember
C#
public override object InvokeMember(
string name,
BindingFlags invokeAttr,
Binder binder,
object target,
object[] args,
ParameterModifier[] modifiers,
CultureInfo culture,
string[] namedParameters
)
C++
public:
virtual Object InvokeMember(
String name,
BindingFlags invokeAttr,
Binder binder,
Object target,
array<Object>^ args,
array<ParameterModifier>^ modifiers,
CultureInfo culture,
array<String>^ namedParameters
) override
J#
public override object InvokeMember(
string name,
BindingFlags invokeAttr,
Binder binder,
object target,
object[] args,
ParameterModifier[] modifiers,
CultureInfo culture,
string[] namedParameters
)
JScript
public override function InvokeMember(
name : String,
invokeAttr : BindingFlags,
binder : Binder,
target : Object,
args : Object[],
modifiers : ParameterModifier[],
culture : CultureInfo,
namedParameters : String[]
) : Object

Parameters

name
The String containing the name of the constructor, method, property, or field member to invoke.-or- An empty string ("") to invoke the default member. -or-For IDispatch members, a string representing the DispID, for example "[DispID=3]".
invokeAttr
A bitmask comprised of one or more BindingFlags that specify how the search is conducted. The access can be one of the BindingFlags such as Public, NonPublic, Private, InvokeMethod, GetField, and so on. The type of lookup need not be specified. If the type of lookup is omitted, BindingFlags.Public | BindingFlags.Instance will apply.
binder
A Binder object that defines a set of properties and enables binding, which can involve selection of an overloaded method, coercion of argument types, and invocation of a member through reflection.-or- null, to use the DefaultBinder.
target
The Object on which to invoke the specified member.
args
An array containing the arguments to pass to the member to invoke.
modifiers
An array of ParameterModifier objects representing the attributes associated with the corresponding element in the args array. A parameter's associated attributes are stored in the member's signature. The default binder does not process this parameter.
culture
The CultureInfo object representing the globalization locale to use, which may be necessary for locale-specific conversions, such as converting a numeric String to a Double.-or- null to use the current thread's CultureInfo.
namedParameters
An array containing the names of the parameters to which the values in the args array are passed.

Return Value

An Object representing the return value of the invoked member.

Implements

IReflect.InvokeMember

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.InvokeMember Overload List


IsAssignableFrom Method

UnresolvedType.IsAssignableFrom Method
[image]

Determines whether an instance of the current Type can be assigned from an instance of the specified Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsAssignableFrom( _
ByVal c As Type _
) As Boolean
C#
public override bool IsAssignableFrom(
Type c
)
C++
public:
virtual bool IsAssignableFrom(
Type c
) override
J#
public override bool IsAssignableFrom(
Type c
)
JScript
public override function IsAssignableFrom(
c : Type
) : bool

Parameters

c
The Type to compare with the current Type.

Return Value

true if c and the current Type represent the same type, or if the current Type is in the inheritance hierarchy of c, or if the current Type is an interface that c implements, or if c is a generic type parameter and the current Type represents one of the constraints of c. false if none of these conditions are true, or if c is null.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


IsDefined Method

UnresolvedType.IsDefined Method
[image]

When overridden in a derived class, indicates whether one or more instance of attributeType is applied to this member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsDefined( _
ByVal attributeType As Type, _
ByVal inherit As Boolean _
) As Boolean _
Implements ICustomAttributeProvider.IsDefined
C#
public override bool IsDefined(
Type attributeType,
bool inherit
)
C++
public:
virtual bool IsDefined(
Type attributeType,
bool inherit
) override
J#
public override bool IsDefined(
Type attributeType,
bool inherit
)
JScript
public override function IsDefined(
attributeType : Type,
inherit : bool
) : bool

Parameters

attributeType
The Type object to which the custom attributes are applied.
inherit
Specifies whether to search this member's inheritance chain to find the attributes.

Return Value

true if one or more instance of attributeType is applied to this member; otherwise false.

Implements

ICustomAttributeProvider.IsDefined

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


IsInstanceOfType Method

UnresolvedType.IsInstanceOfType Method
[image]

Determines whether the specified object is an instance of the current Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsInstanceOfType( _
ByVal o As Object _
) As Boolean
C#
public override bool IsInstanceOfType(
object o
)
C++
public:
virtual bool IsInstanceOfType(
Object o
) override
J#
public override bool IsInstanceOfType(
object o
)
JScript
public override function IsInstanceOfType(
o : Object
) : bool

Parameters

o
The object to compare with the current Type.

Return Value

true if the current Type is in the inheritance hierarchy of the object represented by o, or if the current Type is an interface that o supports. false if neither of these conditions is the case, or if o is null, or if the current Type is an open generic type (that is, ContainsGenericParameters returns true).

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


IsSubclassOf Method

UnresolvedType.IsSubclassOf Method
[image]

Determines whether the class represented by the current Type derives from the class represented by the specified Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsSubclassOf( _
ByVal c As Type _
) As Boolean
C#
public override bool IsSubclassOf(
Type c
)
C++
public:
virtual bool IsSubclassOf(
Type c
) override
J#
public override bool IsSubclassOf(
Type c
)
JScript
public override function IsSubclassOf(
c : Type
) : bool

Parameters

c
The Type to compare with the current Type.

Return Value

true if the Type represented by the c parameter and the current Type represent classes, and the class represented by the current Type derives from the class represented by c; otherwise, false. This method also returns false if c and the current Type represent the same class.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


MakeArrayType Method

UnresolvedType.MakeArrayType Method

Returns a Type object that represents an array of the current type.

Overload List

 | Name | Description
Public method | MakeArrayType | Overridden. Returns a Type object representing a one-dimensional array of the current type, with a lower bound of zero.
Public method | MakeArrayType (Int32) | Overridden. Returns a Type object representing an array of the current type, with the specified number of dimensions.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


MakeArrayType Method ()

UnresolvedType.MakeArrayType Method ()
See Also Example
[image]

Returns a Type object representing a one-dimensional array of the current type, with a lower bound of zero.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakeArrayType() As Type
C#
public override Type MakeArrayType()
C++
public:
virtual Type MakeArrayType() override
J#
public override Type MakeArrayType()
JScript
public override function MakeArrayType() : Type

Return Value

A Type object representing a one-dimensional array of the current type, with a lower bound of zero.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.MakeArrayType Overload List


MakeArrayType Method (Int32)

UnresolvedType.MakeArrayType Method (Int32)
See Also Example
[image]

Returns a Type object representing an array of the current type, with the specified number of dimensions.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakeArrayType( _
ByVal rank As Integer _
) As Type
C#
public override Type MakeArrayType(
int rank
)
C++
public:
virtual Type MakeArrayType(
int rank
) override
J#
public override Type MakeArrayType(
int rank
)
JScript
public override function MakeArrayType(
rank : int
) : Type

Parameters

rank
The number of dimensions for the array.

Return Value

A Type object representing an array of the current type, with the specified number of dimensions.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace
UnresolvedType.MakeArrayType Overload List


MakeByRefType Method

UnresolvedType.MakeByRefType Method
[image]

Returns a Type object that represents the current type when passed as a ref parameter (ByRef parameter in Visual Basic).

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakeByRefType() As Type
C#
public override Type MakeByRefType()
C++
public:
virtual Type MakeByRefType() override
J#
public override Type MakeByRefType()
JScript
public override function MakeByRefType() : Type

Return Value

A Type object that represents the current type when passed as a ref parameter (ByRef parameter in Visual Basic).

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


MakeGenericType Method

UnresolvedType.MakeGenericType Method
[image]

Substitutes the elements of an array of types for the type parameters of the current generic type definition and returns a Type object representing the resulting constructed type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakeGenericType( _
ByVal ParamArray typeArguments As Type() _
) As Type
C#
public override Type MakeGenericType(
params Type[] typeArguments
)
C++
public:
virtual Type MakeGenericType(
... array<Type>^ typeArguments
) override
J#
public override Type MakeGenericType(
Type[] typeArguments
)
JScript
public override function MakeGenericType(
ParamArrayAttribute typeArguments : Type[]
) : Type

Parameters

typeArguments
An array of types to be substituted for the type parameters of the current generic type.

Return Value

A Type representing the constructed type formed by substituting the elements of typeArguments for the type parameters of the current generic type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


MakePointerType Method

UnresolvedType.MakePointerType Method
[image]

Returns a Type object that represents a pointer to the current type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function MakePointerType() As Type
C#
public override Type MakePointerType()
C++
public:
virtual Type MakePointerType() override
J#
public override Type MakePointerType()
JScript
public override function MakePointerType() : Type

Return Value

A Type object that represents a pointer to the current type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


ToString Method

UnresolvedType.ToString Method
[image]

Returns a String representing the name of the current Type.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String representing the name of the current Type.

See Also

UnresolvedType Class
Gallio.Reflection.Impl Namespace


XmlDocumentationUtils Class

XmlDocumentationUtils Class
See Also Example Members
[image]

Helpers for working with IXmlDocumentationResolver. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module XmlDocumentationUtils
C#
public static class XmlDocumentationUtils
C++
ref class XmlDocumentationUtils abstract sealed
J#
public final class XmlDocumentationUtils
JScript
public class XmlDocumentationUtils

Inheritance Hierarchy

System.Object
Gallio.Reflection.Impl.XmlDocumentationUtils

See Also

XmlDocumentationUtils Members
Gallio.Reflection.Impl Namespace


XmlDocumentationUtils Members

XmlDocumentationUtils Members
See Also Example Properties Methods
[image]

Helpers for working with IXmlDocumentationResolver. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by XmlDocumentationUtils.

Public Properties

Name | Description
Resolver | Gets the XML documentation resolver.
Top

Public Methods

Name | Description
FormatId | Gets the XML documentation id of a member.
GetXmlDocumentation | Gets the XML documentation for a member.
Top

See Also

XmlDocumentationUtils Class
Gallio.Reflection.Impl Namespace


Properties

XmlDocumentationUtils Properties
[image]

Public Properties

Name | Description
Resolver | Gets the XML documentation resolver.
Top

See Also

XmlDocumentationUtils Class
Gallio.Reflection.Impl Namespace


Resolver Property

XmlDocumentationUtils.Resolver Property
[image]

Gets the XML documentation resolver.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Resolver As IXmlDocumentationResolver
C#
public static IXmlDocumentationResolver Resolver { get; }
C++
public static property IXmlDocumentationResolver Resolver {
IXmlDocumentationResolver get();
}
J#
/** property */
public IXmlDocumentationResolver get_Resolver();
JScript
public function get Resolver() : IXmlDocumentationResolver

See Also

XmlDocumentationUtils Class
Gallio.Reflection.Impl Namespace


Methods

XmlDocumentationUtils Methods
[image]

Public Methods

Name | Description
FormatId | Gets the XML documentation id of a member.
GetXmlDocumentation | Gets the XML documentation for a member.
Top

See Also

XmlDocumentationUtils Class
Gallio.Reflection.Impl Namespace


FormatId Method

XmlDocumentationUtils.FormatId Method
[image]

Gets the XML documentation id of a member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FormatId( _
ByVal member As MemberInfo _
) As String
C#
public static string FormatId(
MemberInfo member
)
C++
public:
static String FormatId(
MemberInfo member
)
J#
public static string FormatId(
MemberInfo member
)
JScript
public static function FormatId(
member : MemberInfo
) : String

Parameters

member
The member

Return Value

The XML documentation id of the member

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if member is null

See Also

XmlDocumentationUtils Class
Gallio.Reflection.Impl Namespace


GetXmlDocumentation Method

XmlDocumentationUtils.GetXmlDocumentation Method
[image]

Gets the XML documentation for a member.

Namespace: Gallio.Reflection.Impl
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetXmlDocumentation( _
ByVal member As MemberInfo _
) As String
C#
public static string GetXmlDocumentation(
MemberInfo member
)
C++
public:
static String GetXmlDocumentation(
MemberInfo member
)
J#
public static string GetXmlDocumentation(
MemberInfo member
)
JScript
public static function GetXmlDocumentation(
member : MemberInfo
) : String

Parameters

member
The member

Return Value

The XML documentation for the member, or null if none available

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if member is null

See Also

XmlDocumentationUtils Class
Gallio.Reflection.Impl Namespace


Gallio.Reports

Gallio.Reports Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | BaseReportFormatter | Abstract base class for report formatters. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class MHtmlReportFormatter

Formats MIME HTML archive reports similar to the web archives generated by Internet Explorer. The report can then be sent to recipients as a single file.

Unfortunately the format is non-standard and cannot be read by most other browsers.

Public class XmlReportFormatter

Formats reports as Xml.

Recognizes the following options:

  • AttachmentContentDisposition - Overrides the default attachment content disposition for the format. The content disposition may be "Absent" to exclude attachments, "Link" to include attachments by reference to external files, or "Inline" to include attachments as inline content within the formatted document. Different formats use different default content dispositions.
Public class XsltReportFormatter

Generic XSLT report formatter.

Recognizes the following options:

  • AttachmentContentDisposition - Overrides the default attachment content disposition for the format. The content disposition may be "Absent" to exclude attachments, "Link" to include attachments by reference to external files, or "Inline" to include attachments as inline content within the formatted document. Different formats use different default content dispositions.


BaseReportFormatter Class

BaseReportFormatter Class
See Also Example Members
[image]

Abstract base class for report formatters. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseReportFormatter
Implements IReportFormatter, IRegisteredComponent
C#
public abstract class BaseReportFormatter : IReportFormatter, IRegisteredComponent
C++
ref class BaseReportFormatter abstract : IReportFormatter, IRegisteredComponent
J#
public class BaseReportFormatter implements IReportFormatter, IRegisteredComponent
JScript
public class BaseReportFormatter extends IReportFormatter, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gallio.Reports.BaseReportFormatter
Gallio.Reports.MHtmlReportFormatter
Gallio.Reports.XmlReportFormatter
Gallio.Reports.XsltReportFormatter

See Also

BaseReportFormatter Members
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


BaseReportFormatter Members

BaseReportFormatter Members
See Also Example Constructors Fields Properties Methods
[image]

Abstract base class for report formatters. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseReportFormatter.

Protected Constructors

 | Name | Description
Family method | BaseReportFormatter | Creates a report formatter.
Top

Public Fields

Name | Description
AttachmentContentDispositionOption | Gets the name of the option that how attachments are saved. This field is constant and read-only.
Top

Public Properties

 | Name | Description
Public property | DefaultAttachmentContentDisposition | Gets or sets the default attachment content disposition. Defaults to Absent.
Public property | Description | Gets the human-readable description of the component.
Public property | Name | Gets the unique name of the component.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


BaseReportFormatter Constructor

BaseReportFormatter Constructor
[image]

Creates a report formatter.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal name As String, _
ByVal description As String _
)
C#
protected BaseReportFormatter(
string name,
string description
)
C++
protected:
BaseReportFormatter(
String name,
String description
) sealed
J#
protected BaseReportFormatter(
string name,
string description
)
JScript
protected function BaseReportFormatter(
name : String,
description : String
)

Parameters

name
The formatter name
description
The formatter description

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or description is null

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Fields

BaseReportFormatter Fields
[image]

Public Fields

Name | Description
AttachmentContentDispositionOption | Gets the name of the option that how attachments are saved. This field is constant and read-only.
Top

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


AttachmentContentDispositionOption Field

BaseReportFormatter.AttachmentContentDispositionOption Field
[image]

Gets the name of the option that how attachments are saved. This field is constant and read-only.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public const AttachmentContentDispositionOption As String = "AttachmentContentDisposition"
C#
public const string AttachmentContentDispositionOption = "AttachmentContentDisposition";
C++
public:
const String AttachmentContentDispositionOption = L"AttachmentContentDisposition";
J#
public const string AttachmentContentDispositionOption = "AttachmentContentDisposition"
JScript
public const AttachmentContentDispositionOption : String = "AttachmentContentDisposition";

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Properties

BaseReportFormatter Properties
[image]

Public Properties

 | Name | Description
Public property | DefaultAttachmentContentDisposition | Gets or sets the default attachment content disposition. Defaults to Absent.
Public property | Description | Gets the human-readable description of the component.
Public property | Name | Gets the unique name of the component.
Top

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


DefaultAttachmentContentDisposition Property

BaseReportFormatter.DefaultAttachmentContentDisposition Property
See Also Example
[image]

Gets or sets the default attachment content disposition. Defaults to Absent.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultAttachmentContentDisposition As AttachmentContentDisposition
C#
public AttachmentContentDisposition DefaultAttachmentContentDisposition { get; set; }
C++
public property AttachmentContentDisposition DefaultAttachmentContentDisposition sealed {
AttachmentContentDisposition get();
void set(AttachmentContentDisposition value);
}
J#
/** property */
public AttachmentContentDisposition get_DefaultAttachmentContentDisposition();

/** property */
public void set_DefaultAttachmentContentDisposition(AttachmentContentDisposition value);
JScript
public function get DefaultAttachmentContentDisposition() : AttachmentContentDisposition

public function set DefaultAttachmentContentDisposition(value : AttachmentContentDisposition);

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Description Property

BaseReportFormatter.Description Property
[image]

Gets the human-readable description of the component.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String _
Implements IRegisteredComponent.Description
C#
public string Description { get; }
C++
public property string Description sealed {
String get();
}
J#
/** property */
public string get_Description();
JScript
public function get Description() : String

Implements

IRegisteredComponent.Description

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Name Property

BaseReportFormatter.Name Property
[image]

Gets the unique name of the component.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String _
Implements IRegisteredComponent.Name
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

IRegisteredComponent.Name

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Methods

BaseReportFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Format Method

BaseReportFormatter.Format Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal formatterOptions As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportFormatter.Format
C#
public abstract void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
C++
public:
void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
) abstract
J#
public abstract void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
JScript
public abstract function Format(
reportWriter : IReportWriter,
formatterOptions : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Return Value

A hash code for the current Object.

Implements

IReportFormatter.Format

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


GetAttachmentContentDisposition Method

BaseReportFormatter.GetAttachmentContentDisposition Method
[image]

Gets the attachment content disposition.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetAttachmentContentDisposition( _
ByVal options As ReportFormatterOptions _
) As AttachmentContentDisposition
C#
protected AttachmentContentDisposition GetAttachmentContentDisposition(
ReportFormatterOptions options
)
C++
protected:
AttachmentContentDisposition GetAttachmentContentDisposition(
ReportFormatterOptions options
) sealed
J#
protected AttachmentContentDisposition GetAttachmentContentDisposition(
ReportFormatterOptions options
)
JScript
protected function GetAttachmentContentDisposition(
options : ReportFormatterOptions
) : AttachmentContentDisposition

Parameters

options
The formatter options

Return Value

The attachment content disposition

See Also

BaseReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


MHtmlReportFormatter Class

MHtmlReportFormatter Class
See Also Example Members
[image]

Formats MIME HTML archive reports similar to the web archives generated by Internet Explorer. The report can then be sent to recipients as a single file.

Unfortunately the format is non-standard and cannot be read by most other browsers.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Class MHtmlReportFormatter
Inherits BaseReportFormatter
C#
public class MHtmlReportFormatter : BaseReportFormatter
C++
ref class MHtmlReportFormatter : BaseReportFormatter
J#
public class MHtmlReportFormatter extends BaseReportFormatter
JScript
public class MHtmlReportFormatter extends BaseReportFormatter

Inheritance Hierarchy

System.Object
Gallio.Reports.BaseReportFormatter
Gallio.Reports.MHtmlReportFormatter

See Also

MHtmlReportFormatter Members
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


MHtmlReportFormatter Members

MHtmlReportFormatter Members
See Also Example Constructors Properties Methods
[image]

Formats MIME HTML archive reports similar to the web archives generated by Internet Explorer. The report can then be sent to recipients as a single file.

Unfortunately the format is non-standard and cannot be read by most other browsers.

The following tables list the members exposed by MHtmlReportFormatter.

Public Constructors

 | Name | Description
Public method | MHtmlReportFormatter | Creates a report formatter.
Top

Public Properties

 | Name | Description
Public property | DefaultAttachmentContentDisposition | Gets or sets the default attachment content disposition. Defaults to Absent. (inherited from BaseReportFormatter)
Public property | Description | Gets the human-readable description of the component. (inherited from BaseReportFormatter)
Public property | Name | Gets the unique name of the component. (inherited from BaseReportFormatter)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition. (inherited from BaseReportFormatter)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MHtmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


MHtmlReportFormatter Constructor

MHtmlReportFormatter Constructor
[image]

Creates a report formatter.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal description As String, _
ByVal htmlReportFormatter As IReportFormatter _
)
C#
public MHtmlReportFormatter(
string name,
string description,
IReportFormatter htmlReportFormatter
)
C++
public:
MHtmlReportFormatter(
String name,
String description,
IReportFormatter htmlReportFormatter
) sealed
J#
public MHtmlReportFormatter(
string name,
string description,
IReportFormatter htmlReportFormatter
)
JScript
public function MHtmlReportFormatter(
name : String,
description : String,
htmlReportFormatter : IReportFormatter
)

Parameters

name
The formatter name
description
The formatter description
htmlReportFormatter
The HTML report formatter

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name, description or htmlReportFormatter is null

See Also

MHtmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Methods

MHtmlReportFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition. (inherited from BaseReportFormatter)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MHtmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Format Method

MHtmlReportFormatter.Format Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal formatterOptions As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportFormatter.Format
C#
public override void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
C++
public:
virtual void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
) override
J#
public override void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
JScript
public override function Format(
reportWriter : IReportWriter,
formatterOptions : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Return Value

A hash code for the current Object.

Implements

IReportFormatter.Format

See Also

MHtmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


XmlReportFormatter Class

XmlReportFormatter Class
See Also Example Members
[image]

Formats reports as Xml.

Recognizes the following options:

  • AttachmentContentDisposition - Overrides the default attachment content disposition for the format. The content disposition may be "Absent" to exclude attachments, "Link" to include attachments by reference to external files, or "Inline" to include attachments as inline content within the formatted document. Different formats use different default content dispositions.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlReportFormatter
Inherits BaseReportFormatter
C#
public class XmlReportFormatter : BaseReportFormatter
C++
ref class XmlReportFormatter : BaseReportFormatter
J#
public class XmlReportFormatter extends BaseReportFormatter
JScript
public class XmlReportFormatter extends BaseReportFormatter

Inheritance Hierarchy

System.Object
Gallio.Reports.BaseReportFormatter
Gallio.Reports.XmlReportFormatter

See Also

XmlReportFormatter Members
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


XmlReportFormatter Members

XmlReportFormatter Members
See Also Example Constructors Properties Methods
[image]

Formats reports as Xml.

Recognizes the following options:

  • AttachmentContentDisposition - Overrides the default attachment content disposition for the format. The content disposition may be "Absent" to exclude attachments, "Link" to include attachments by reference to external files, or "Inline" to include attachments as inline content within the formatted document. Different formats use different default content dispositions.

The following tables list the members exposed by XmlReportFormatter.

Public Constructors

 | Name | Description
Public method | XmlReportFormatter | Creates an Xml report formatter.
Top

Public Properties

 | Name | Description
Public property | DefaultAttachmentContentDisposition | Gets or sets the default attachment content disposition. Defaults to Absent. (inherited from BaseReportFormatter)
Public property | Description | Gets the human-readable description of the component. (inherited from BaseReportFormatter)
Public property | Name | Gets the unique name of the component. (inherited from BaseReportFormatter)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition. (inherited from BaseReportFormatter)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


XmlReportFormatter Constructor

XmlReportFormatter Constructor
[image]

Creates an Xml report formatter.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal description As String _
)
C#
public XmlReportFormatter(
string name,
string description
)
C++
public:
XmlReportFormatter(
String name,
String description
) sealed
J#
public XmlReportFormatter(
string name,
string description
)
JScript
public function XmlReportFormatter(
name : String,
description : String
)

Parameters

name
The formatter name
description
The formatter description

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or description is null

See Also

XmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Methods

XmlReportFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition. (inherited from BaseReportFormatter)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Format Method

XmlReportFormatter.Format Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal options As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportFormatter.Format
C#
public override void Format(
IReportWriter reportWriter,
ReportFormatterOptions options,
IProgressMonitor progressMonitor
)
C++
public:
virtual void Format(
IReportWriter reportWriter,
ReportFormatterOptions options,
IProgressMonitor progressMonitor
) override
J#
public override void Format(
IReportWriter reportWriter,
ReportFormatterOptions options,
IProgressMonitor progressMonitor
)
JScript
public override function Format(
reportWriter : IReportWriter,
options : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Return Value

A hash code for the current Object.

Implements

IReportFormatter.Format

See Also

XmlReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


XsltReportFormatter Class

XsltReportFormatter Class
See Also Example Members
[image]

Generic XSLT report formatter.

Recognizes the following options:

  • AttachmentContentDisposition - Overrides the default attachment content disposition for the format. The content disposition may be "Absent" to exclude attachments, "Link" to include attachments by reference to external files, or "Inline" to include attachments as inline content within the formatted document. Different formats use different default content dispositions.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Class XsltReportFormatter
Inherits BaseReportFormatter
C#
public class XsltReportFormatter : BaseReportFormatter
C++
ref class XsltReportFormatter : BaseReportFormatter
J#
public class XsltReportFormatter extends BaseReportFormatter
JScript
public class XsltReportFormatter extends BaseReportFormatter

Inheritance Hierarchy

System.Object
Gallio.Reports.BaseReportFormatter
Gallio.Reports.XsltReportFormatter

See Also

XsltReportFormatter Members
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


XsltReportFormatter Members

XsltReportFormatter Members
See Also Example Constructors Properties Methods
[image]

Generic XSLT report formatter.

Recognizes the following options:

  • AttachmentContentDisposition - Overrides the default attachment content disposition for the format. The content disposition may be "Absent" to exclude attachments, "Link" to include attachments by reference to external files, or "Inline" to include attachments as inline content within the formatted document. Different formats use different default content dispositions.

The following tables list the members exposed by XsltReportFormatter.

Public Constructors

 | Name | Description
Public method | XsltReportFormatter | Creates an XSLT report formatter.
Top

Public Properties

 | Name | Description
Public property | DefaultAttachmentContentDisposition | Gets or sets the default attachment content disposition. Defaults to Absent. (inherited from BaseReportFormatter)
Public property | Description | Gets the human-readable description of the component. (inherited from BaseReportFormatter)
Public property | Name | Gets the unique name of the component. (inherited from BaseReportFormatter)
Top

Protected Properties

 | Name | Description
Family property | Transform | Gets the XSL transform.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ApplyTransform | Applies the transform to produce a report.
Family method | CopyResources | Copies additional resources to the content path within the report.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition. (inherited from BaseReportFormatter)
Family method | LoadTransform | Loads the XSL transform.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateArguments | Populates the arguments for the XSL template processing.
Top

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


XsltReportFormatter Constructor

XsltReportFormatter Constructor
[image]

Creates an XSLT report formatter.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal runtime As IRuntime, _
ByVal name As String, _
ByVal description As String, _
ByVal extension As String, _
ByVal contentType As String, _
ByVal contentUri As String, _
ByVal xsltPath As String, _
ByVal resourcePaths As String() _
)
C#
public XsltReportFormatter(
IRuntime runtime,
string name,
string description,
string extension,
string contentType,
string contentUri,
string xsltPath,
string[] resourcePaths
)
C++
public:
XsltReportFormatter(
IRuntime runtime,
String name,
String description,
String extension,
String contentType,
String contentUri,
String xsltPath,
array<String>^ resourcePaths
) sealed
J#
public XsltReportFormatter(
IRuntime runtime,
string name,
string description,
string extension,
string contentType,
string contentUri,
string xsltPath,
string[] resourcePaths
)
JScript
public function XsltReportFormatter(
runtime : IRuntime,
name : String,
description : String,
extension : String,
contentType : String,
contentUri : String,
xsltPath : String,
resourcePaths : String[]
)

Parameters

runtime
The runtime
name
The formatter name
description
The formatter description
extension
The preferred extension without a '.'
contentType
The content type of the main report document
contentUri
The Uri of the content directory
xsltPath
The path of the XSLT relative to the content directory
resourcePaths
The paths of the resources (such as images or CSS) to copy to the report directory relative to the content directory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if any arguments are null

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Properties

XsltReportFormatter Properties
[image]

Public Properties

 | Name | Description
Public property | DefaultAttachmentContentDisposition | Gets or sets the default attachment content disposition. Defaults to Absent. (inherited from BaseReportFormatter)
Public property | Description | Gets the human-readable description of the component. (inherited from BaseReportFormatter)
Public property | Name | Gets the unique name of the component. (inherited from BaseReportFormatter)
Top

Protected Properties

 | Name | Description
Family property | Transform | Gets the XSL transform.
Top

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Transform Property

XsltReportFormatter.Transform Property
[image]

Gets the XSL transform.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Transform As XslCompiledTransform
C#
protected XslCompiledTransform Transform { get; }
C++
protected property XslCompiledTransform Transform sealed {
XslCompiledTransform get();
}
J#
/** property */
protected XslCompiledTransform get_Transform();
JScript
protected function get Transform() : XslCompiledTransform

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Methods

XsltReportFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ApplyTransform | Applies the transform to produce a report.
Family method | CopyResources | Copies additional resources to the content path within the report.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetAttachmentContentDisposition | Gets the attachment content disposition. (inherited from BaseReportFormatter)
Family method | LoadTransform | Loads the XSL transform.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateArguments | Populates the arguments for the XSL template processing.
Top

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


ApplyTransform Method

XsltReportFormatter.ApplyTransform Method
[image]

Applies the transform to produce a report.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ApplyTransform( _
ByVal reportWriter As IReportWriter, _
ByVal attachmentContentDisposition As AttachmentContentDisposition, _
ByVal options As ReportFormatterOptions _
)
C#
protected virtual void ApplyTransform(
IReportWriter reportWriter,
AttachmentContentDisposition attachmentContentDisposition,
ReportFormatterOptions options
)
C++
protected:
virtual void ApplyTransform(
IReportWriter reportWriter,
AttachmentContentDisposition attachmentContentDisposition,
ReportFormatterOptions options
)
J#
protected virtual void ApplyTransform(
IReportWriter reportWriter,
AttachmentContentDisposition attachmentContentDisposition,
ReportFormatterOptions options
)
JScript
protected virtual function ApplyTransform(
reportWriter : IReportWriter,
attachmentContentDisposition : AttachmentContentDisposition,
options : ReportFormatterOptions
)

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


CopyResources Method

XsltReportFormatter.CopyResources Method
[image]

Copies additional resources to the content path within the report.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CopyResources( _
ByVal reportWriter As IReportWriter _
)
C#
protected virtual void CopyResources(
IReportWriter reportWriter
)
C++
protected:
virtual void CopyResources(
IReportWriter reportWriter
)
J#
protected virtual void CopyResources(
IReportWriter reportWriter
)
JScript
protected virtual function CopyResources(
reportWriter : IReportWriter
)

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Format Method

XsltReportFormatter.Format Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal options As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportFormatter.Format
C#
public override void Format(
IReportWriter reportWriter,
ReportFormatterOptions options,
IProgressMonitor progressMonitor
)
C++
public:
virtual void Format(
IReportWriter reportWriter,
ReportFormatterOptions options,
IProgressMonitor progressMonitor
) override
J#
public override void Format(
IReportWriter reportWriter,
ReportFormatterOptions options,
IProgressMonitor progressMonitor
)
JScript
public override function Format(
reportWriter : IReportWriter,
options : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Return Value

A hash code for the current Object.

Implements

IReportFormatter.Format

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


LoadTransform Method

XsltReportFormatter.LoadTransform Method
[image]

Loads the XSL transform.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function LoadTransform( _
ByVal resolvedXsltPath As String _
) As XslCompiledTransform
C#
protected virtual XslCompiledTransform LoadTransform(
string resolvedXsltPath
)
C++
protected:
virtual XslCompiledTransform LoadTransform(
String resolvedXsltPath
)
J#
protected virtual XslCompiledTransform LoadTransform(
string resolvedXsltPath
)
JScript
protected virtual function LoadTransform(
resolvedXsltPath : String
) : XslCompiledTransform

Parameters

resolvedXsltPath
The full path of the XSLT

Return Value

The transform

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


PopulateArguments Method

XsltReportFormatter.PopulateArguments Method
[image]

Populates the arguments for the XSL template processing.

Namespace: Gallio.Reports
Assembly: Gallio.Reports (in Gallio.Reports.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PopulateArguments( _
ByVal arguments As XsltArgumentList, _
ByVal options As ReportFormatterOptions, _
ByVal reportName As String _
)
C#
protected virtual void PopulateArguments(
XsltArgumentList arguments,
ReportFormatterOptions options,
string reportName
)
C++
protected:
virtual void PopulateArguments(
XsltArgumentList arguments,
ReportFormatterOptions options,
String reportName
)
J#
protected virtual void PopulateArguments(
XsltArgumentList arguments,
ReportFormatterOptions options,
string reportName
)
JScript
protected virtual function PopulateArguments(
arguments : XsltArgumentList,
options : ReportFormatterOptions,
reportName : String
)

See Also

XsltReportFormatter Class
Gallio.Reports Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.Reports [3.0.6.0]


Gallio.Runner

Gallio.Runner Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | DefaultTestRunner | An implementation of ITestRunner that runs tests using a ITestDriver. The driver is created when the first package is loaded and is disposed when the runner is disposed. Consequently the test driver may be reused for multiple test runs.
Public class | DefaultTestRunnerFactory | A ITestRunnerFactory for DefaultTestRunner using different implementations of ITestDriver.
Public class | DefaultTestRunnerManager | The default implementation of ITestRunnerManager.
Public class | OperationFinishedEventArgs | Base arguments for events raised to indicate the completion of an operation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | OperationStartedEventArgs | Base arguments for events raised to indicate the beginning of an operation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | ResultCode | Describes the result codes used by the application. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | RunnerException | The type of exception thrown when the test runner or one of its supportive components like a test domain fails in an unrecoverable manner. It can happen that the test results will be lost or incomplete.
Public class | StandardTestRunnerFactoryNames | Provides constant names for the standard test runner factories. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class TestLauncher

The test launcher encapsulated the entire test execution lifecycle from start to finish and provides a simplified pattern for running tests.

The basic usage pattern is as follows: Create the launcher.Set properties to specify the inputs and outputs of the test run.Run the tests all in one go.Optionally do something with the contents of the final report.

By default, the launcher assumes that a runtime environment has already been established and is accessible via the RuntimeAccessor. If there is no runtime yet, then you can cause one to be configured automatically for the duration of the test run by setting the RuntimeSetup property accordingly.

You can override the default ITestRunner that is created by setting the TestRunnerFactoryName property.

Public class | TestLauncherResult | Contains the result of a complete test run.
Public class | TestRunnerOptions | Provides options that control the operation of the test runner. This class cannot be inherited.
Public class | TestRunnerUtils | Provides helper functions for test runner tools. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

 | Interface | Description
Public interface | ITestRunner | A test runner provides the basic functionality for loading, exploring and running tests. It abstracts away most concerns having to do with the execution of tests in isolated (possibly remote) domains.
Public interface | ITestRunnerFactory | A test tunner factory is a service that creates an ITestRunner given a set of options. Each factory has a name which is used by ITestRunnerManager to select the particular factory to use for a given test run.
Public interface | ITestRunnerManager | A test runner manager enumerates the names of the ITestRunnerFactory services that are available and provides a mechanism for creating ITestRunner instances.


DefaultTestRunner Class

DefaultTestRunner Class
See Also Example Members
[image]

An implementation of ITestRunner that runs tests using a ITestDriver. The driver is created when the first package is loaded and is disposed when the runner is disposed. Consequently the test driver may be reused for multiple test runs.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestRunner
Implements ITestRunner
C#
public class DefaultTestRunner : ITestRunner
C++
ref class DefaultTestRunner : ITestRunner
J#
public class DefaultTestRunner implements ITestRunner
JScript
public class DefaultTestRunner extends ITestRunner

Inheritance Hierarchy

System.Object
Gallio.Runner.DefaultTestRunner

See Also

DefaultTestRunner Members
Gallio.Runner Namespace


DefaultTestRunner Members

DefaultTestRunner Members
See Also Example Constructors Properties Methods
[image]

An implementation of ITestRunner that runs tests using a ITestDriver. The driver is created when the first package is loaded and is disposed when the runner is disposed. Consequently the test driver may be reused for multiple test runs.

The following tables list the members exposed by DefaultTestRunner.

Public Constructors

 | Name | Description
Public method | DefaultTestRunner | Creates a test runner.
Top

Public Properties

 | Name | Description
Public property | Events | Gets the event dispatcher for the test runner.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or null if the test runner has not been initialized.
Family property | TestRunnerOptions | Gets the test runner options, or null if the test runner has not been initialized.
Top

Public Methods

 | Name | Description
Public method | Dispose | Disposes the test runner. Does nothing if already disposed or if not initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test runner.
Public method | RegisterExtension | Registers a test runner extension.
Public method | Run | Explores and runs tests in a test package.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


DefaultTestRunner Constructor

DefaultTestRunner Constructor
[image]

Creates a test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testDriverFactory As ITestDriverFactory _
)
C#
public DefaultTestRunner(
ITestDriverFactory testDriverFactory
)
C++
public:
DefaultTestRunner(
ITestDriverFactory testDriverFactory
) sealed
J#
public DefaultTestRunner(
ITestDriverFactory testDriverFactory
)
JScript
public function DefaultTestRunner(
testDriverFactory : ITestDriverFactory
)

Parameters

testDriverFactory
The test driver factory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testDriverFactory is null

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Properties

DefaultTestRunner Properties
[image]

Public Properties

 | Name | Description
Public property | Events | Gets the event dispatcher for the test runner.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or null if the test runner has not been initialized.
Family property | TestRunnerOptions | Gets the test runner options, or null if the test runner has not been initialized.
Top

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Events Property

DefaultTestRunner.Events Property
[image]

Gets the event dispatcher for the test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Events As ITestRunnerEvents _
Implements ITestRunner.Events
C#
public ITestRunnerEvents Events { get; }
C++
public property ITestRunnerEvents Events sealed {
ITestRunnerEvents get();
}
J#
/** property */
public ITestRunnerEvents get_Events();
JScript
public function get Events() : ITestRunnerEvents

Implements

ITestRunner.Events

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Logger Property

DefaultTestRunner.Logger Property
[image]

Gets the logger, or null if the test runner has not been initialized.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Logger As ILogger
C#
protected ILogger Logger { get; }
C++
protected property ILogger Logger sealed {
ILogger get();
}
J#
/** property */
protected ILogger get_Logger();
JScript
protected function get Logger() : ILogger

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


TestRunnerOptions Property

DefaultTestRunner.TestRunnerOptions Property
[image]

Gets the test runner options, or null if the test runner has not been initialized.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property TestRunnerOptions As TestRunnerOptions
C#
protected TestRunnerOptions TestRunnerOptions { get; }
C++
protected property TestRunnerOptions TestRunnerOptions sealed {
TestRunnerOptions get();
}
J#
/** property */
protected TestRunnerOptions get_TestRunnerOptions();
JScript
protected function get TestRunnerOptions() : TestRunnerOptions

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Methods

DefaultTestRunner Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Disposes the test runner. Does nothing if already disposed or if not initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test runner.
Public method | RegisterExtension | Registers a test runner extension.
Public method | Run | Explores and runs tests in a test package.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Dispose Method

DefaultTestRunner.Dispose Method
[image]

Disposes the test runner. Does nothing if already disposed or if not initialized.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose( _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestRunner.Dispose
C#
public void Dispose(
IProgressMonitor progressMonitor
)
C++
public:
void Dispose(
IProgressMonitor progressMonitor
) sealed
J#
public void Dispose(
IProgressMonitor progressMonitor
)
JScript
public function Dispose(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Implements

ITestRunner.Dispose

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Explore Method

DefaultTestRunner.Explore Method
[image]

Explores tests in a test package.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Explore( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal progressMonitor As IProgressMonitor _
) As Report _
Implements ITestRunner.Explore
C#
public Report Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
IProgressMonitor progressMonitor
)
C++
public:
Report Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
IProgressMonitor progressMonitor
) sealed
J#
public Report Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
IProgressMonitor progressMonitor
)
JScript
public function Explore(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
progressMonitor : IProgressMonitor
) : Report

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
progressMonitor
The progress monitor

Return Value

The test report

Implements

ITestRunner.Explore

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Initialize Method

DefaultTestRunner.Initialize Method
[image]

Initializes the test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize( _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestRunner.Initialize
C#
public void Initialize(
TestRunnerOptions testRunnerOptions,
ILogger logger,
IProgressMonitor progressMonitor
)
C++
public:
void Initialize(
TestRunnerOptions testRunnerOptions,
ILogger logger,
IProgressMonitor progressMonitor
) sealed
J#
public void Initialize(
TestRunnerOptions testRunnerOptions,
ILogger logger,
IProgressMonitor progressMonitor
)
JScript
public function Initialize(
testRunnerOptions : TestRunnerOptions,
logger : ILogger,
progressMonitor : IProgressMonitor
)

Parameters

testRunnerOptions
The test runner options
logger
The logger
progressMonitor
The progress monitor

Implements

ITestRunner.Initialize

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


RegisterExtension Method

DefaultTestRunner.RegisterExtension Method
[image]

Registers a test runner extension.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterExtension( _
ByVal extension As ITestRunnerExtension _
) _
Implements ITestRunner.RegisterExtension
C#
public void RegisterExtension(
ITestRunnerExtension extension
)
C++
public:
void RegisterExtension(
ITestRunnerExtension extension
) sealed
J#
public void RegisterExtension(
ITestRunnerExtension extension
)
JScript
public function RegisterExtension(
extension : ITestRunnerExtension
)

Parameters

extension
The test runner extension to register

Implements

ITestRunner.RegisterExtension

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


Run Method

DefaultTestRunner.Run Method
[image]

Explores and runs tests in a test package.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Run( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As Report _
Implements ITestRunner.Run
C#
public Report Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
IProgressMonitor progressMonitor
)
C++
public:
Report Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
IProgressMonitor progressMonitor
) sealed
J#
public Report Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
IProgressMonitor progressMonitor
)
JScript
public function Run(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExecutionOptions : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : Report

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExecutionOptions
The test execution options
progressMonitor
The progress monitor

Return Value

The test report

Implements

ITestRunner.Run

See Also

DefaultTestRunner Class
Gallio.Runner Namespace


DefaultTestRunnerFactory Class

DefaultTestRunnerFactory Class
See Also Example Members
[image]

A ITestRunnerFactory for DefaultTestRunner using different implementations of ITestDriver.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestRunnerFactory
Implements ITestRunnerFactory, IRegisteredComponent
C#
public class DefaultTestRunnerFactory : ITestRunnerFactory, IRegisteredComponent
C++
ref class DefaultTestRunnerFactory : ITestRunnerFactory, IRegisteredComponent
J#
public class DefaultTestRunnerFactory implements ITestRunnerFactory, IRegisteredComponent
JScript
public class DefaultTestRunnerFactory extends ITestRunnerFactory, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gallio.Runner.DefaultTestRunnerFactory

See Also

DefaultTestRunnerFactory Members
Gallio.Runner Namespace


DefaultTestRunnerFactory Members

DefaultTestRunnerFactory Members
See Also Example Constructors Properties Methods
[image]

A ITestRunnerFactory for DefaultTestRunner using different implementations of ITestDriver.

The following tables list the members exposed by DefaultTestRunnerFactory.

Public Constructors

 | Name | Description
Public method | DefaultTestRunnerFactory | Creates a test runner factory.
Top

Public Properties

 | Name | Description
Public property | Description | Gets the human-readable description of the component.
Public property | Name | Gets the unique name of the component.
Top

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


DefaultTestRunnerFactory Constructor

DefaultTestRunnerFactory Constructor
[image]

Creates a test runner factory.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testDriverFactory As ITestDriverFactory, _
ByVal name As String, _
ByVal description As String _
)
C#
public DefaultTestRunnerFactory(
ITestDriverFactory testDriverFactory,
string name,
string description
)
C++
public:
DefaultTestRunnerFactory(
ITestDriverFactory testDriverFactory,
String name,
String description
) sealed
J#
public DefaultTestRunnerFactory(
ITestDriverFactory testDriverFactory,
string name,
string description
)
JScript
public function DefaultTestRunnerFactory(
testDriverFactory : ITestDriverFactory,
name : String,
description : String
)

Parameters

testDriverFactory
The test driver factory
name
The test runner factory name
description
The test runner factory description

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testDriverFactory, name or description is null

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


Properties

DefaultTestRunnerFactory Properties
[image]

Public Properties

 | Name | Description
Public property | Description | Gets the human-readable description of the component.
Public property | Name | Gets the unique name of the component.
Top

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


Description Property

DefaultTestRunnerFactory.Description Property
[image]

Gets the human-readable description of the component.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String _
Implements IRegisteredComponent.Description
C#
public string Description { get; }
C++
public property string Description sealed {
String get();
}
J#
/** property */
public string get_Description();
JScript
public function get Description() : String

Implements

IRegisteredComponent.Description

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


Name Property

DefaultTestRunnerFactory.Name Property
[image]

Gets the unique name of the component.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String _
Implements IRegisteredComponent.Name
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Implements

IRegisteredComponent.Name

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


Methods

DefaultTestRunnerFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


CreateTestRunner Method

DefaultTestRunnerFactory.CreateTestRunner Method
[image]

Creates a test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTestRunner() As ITestRunner _
Implements ITestRunnerFactory.CreateTestRunner
C#
public ITestRunner CreateTestRunner()
C++
public:
ITestRunner CreateTestRunner() sealed
J#
public ITestRunner CreateTestRunner()
JScript
public function CreateTestRunner() : ITestRunner

Return Value

The test runner

Implements

ITestRunnerFactory.CreateTestRunner

See Also

DefaultTestRunnerFactory Class
Gallio.Runner Namespace


DefaultTestRunnerManager Class

DefaultTestRunnerManager Class
See Also Example Members
[image]

The default implementation of ITestRunnerManager.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestRunnerManager
Implements ITestRunnerManager
C#
public class DefaultTestRunnerManager : ITestRunnerManager
C++
ref class DefaultTestRunnerManager : ITestRunnerManager
J#
public class DefaultTestRunnerManager implements ITestRunnerManager
JScript
public class DefaultTestRunnerManager extends ITestRunnerManager

Inheritance Hierarchy

System.Object
Gallio.Runner.DefaultTestRunnerManager

See Also

DefaultTestRunnerManager Members
Gallio.Runner Namespace


DefaultTestRunnerManager Members

DefaultTestRunnerManager Members
See Also Example Constructors Properties Methods
[image]

The default implementation of ITestRunnerManager.

The following tables list the members exposed by DefaultTestRunnerManager.

Public Constructors

 | Name | Description
Public method | DefaultTestRunnerManager | Creates a test runner manager.
Top

Public Properties

 | Name | Description
Public property | FactoryResolver | Gets a resolver for resolving registered ITestRunnerFactory components by name.
Top

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFactory | Gets the factory by name, or null if none.
Public method | GetFactoryNames | Gets the names of all supported test runner factories.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


DefaultTestRunnerManager Constructor

DefaultTestRunnerManager Constructor
[image]

Creates a test runner manager.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal factoryResolver As IRegisteredComponentResolver(Of ITestRunnerFactory) _
)
C#
public DefaultTestRunnerManager(
IRegisteredComponentResolver<ITestRunnerFactory> factoryResolver
)
C++
public:
DefaultTestRunnerManager(
IRegisteredComponentResolver<ITestRunnerFactory> factoryResolver
) sealed
J#
public DefaultTestRunnerManager(
IRegisteredComponentResolver<ITestRunnerFactory> factoryResolver
)
JScript
public function DefaultTestRunnerManager(
factoryResolver : IRegisteredComponentResolver<ITestRunnerFactory>
)

Parameters

factoryResolver
The formatter resolver

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if factoryResolver is null

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


Properties

DefaultTestRunnerManager Properties
[image]

Public Properties

 | Name | Description
Public property | FactoryResolver | Gets a resolver for resolving registered ITestRunnerFactory components by name.
Top

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


FactoryResolver Property

DefaultTestRunnerManager.FactoryResolver Property
[image]

Gets a resolver for resolving registered ITestRunnerFactory components by name.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FactoryResolver As IRegisteredComponentResolver(Of ITestRunnerFactory) _
Implements ITestRunnerManager.FactoryResolver
C#
public IRegisteredComponentResolver<ITestRunnerFactory> FactoryResolver { get; }
C++
public property IRegisteredComponentResolver<ITestRunnerFactory> FactoryResolver sealed {
IRegisteredComponentResolver<ITestRunnerFactory> get();
}
J#
/** property */
public IRegisteredComponentResolver<ITestRunnerFactory> get_FactoryResolver();
JScript
public function get FactoryResolver() : IRegisteredComponentResolver<ITestRunnerFactory>

Implements

ITestRunnerManager.FactoryResolver

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


Methods

DefaultTestRunnerManager Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFactory | Gets the factory by name, or null if none.
Public method | GetFactoryNames | Gets the names of all supported test runner factories.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


CreateTestRunner Method

DefaultTestRunnerManager.CreateTestRunner Method
[image]

Creates a test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTestRunner( _
ByVal factoryName As String _
) As ITestRunner _
Implements ITestRunnerManager.CreateTestRunner
C#
public ITestRunner CreateTestRunner(
string factoryName
)
C++
public:
ITestRunner CreateTestRunner(
String factoryName
) sealed
J#
public ITestRunner CreateTestRunner(
string factoryName
)
JScript
public function CreateTestRunner(
factoryName : String
) : ITestRunner

Parameters

factoryName
The name of the test runner factory, matched case-insensitively

Return Value

The test runner

Implements

ITestRunnerManager.CreateTestRunner

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


GetFactory Method

DefaultTestRunnerManager.GetFactory Method
[image]

Gets the factory by name, or null if none.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFactory( _
ByVal factoryName As String _
) As ITestRunnerFactory _
Implements ITestRunnerManager.GetFactory
C#
public ITestRunnerFactory GetFactory(
string factoryName
)
C++
public:
ITestRunnerFactory GetFactory(
String factoryName
) sealed
J#
public ITestRunnerFactory GetFactory(
string factoryName
)
JScript
public function GetFactory(
factoryName : String
) : ITestRunnerFactory

Parameters

factoryName
The name of the test runner factory, matched case-insensitively

Return Value

The test runner

Implements

ITestRunnerManager.GetFactory

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


GetFactoryNames Method

DefaultTestRunnerManager.GetFactoryNames Method
[image]

Gets the names of all supported test runner factories.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFactoryNames() As IList(Of String) _
Implements ITestRunnerManager.GetFactoryNames
C#
public IList<string> GetFactoryNames()
C++
public:
IList<string> GetFactoryNames() sealed
J#
public IList<string> GetFactoryNames()
JScript
public function GetFactoryNames() : IList<string>

Return Value

The names of all runner factories

Implements

ITestRunnerManager.GetFactoryNames

See Also

DefaultTestRunnerManager Class
Gallio.Runner Namespace


ITestRunner Interface

ITestRunner Interface
See Also Example Members
[image]

A test runner provides the basic functionality for loading, exploring and running tests. It abstracts away most concerns having to do with the execution of tests in isolated (possibly remote) domains.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestRunner
C#
public interface ITestRunner
C++
interface class ITestRunner
J#
public interface ITestRunner
JScript
public interface ITestRunner

Types that implement ITestRunner

Type | Description
Gallio.Runner.DefaultTestRunner | An implementation of ITestRunner that runs tests using a ITestDriver. The driver is created when the first package is loaded and is disposed when the runner is disposed. Consequently the test driver may be reused for multiple test runs.

Remarks

The basic usage pattern of a test runner is as follows:

  • As a precondition, ensure that the runtime environment has been initialized.
  • Create the test runner.
  • Add event handlers and register extensions. ,
  • Initialize the runner.
  • Explore and/or Run the tests. and
  • Dispose the test runner.
  • Save or format the report contents as required using the reporting APIs.

Multiple test runs may be performed between initialization and disposal of the test runner.

See Also

ITestRunner Members
Gallio.Runner Namespace
Events
RegisterExtension
Initialize
Explore
Run
Dispose


ITestRunner Members

ITestRunner Members
See Also Example Properties Methods
[image]

A test runner provides the basic functionality for loading, exploring and running tests. It abstracts away most concerns having to do with the execution of tests in isolated (possibly remote) domains.

The following tables list the members exposed by ITestRunner.

Public Properties

 | Name | Description
Public property | Events | Gets the event dispatcher for the test runner.
Top

Public Methods

 | Name | Description
Public method | Dispose | Disposes the test runner. Does nothing if already disposed or if not initialized.
Public method | Explore | Explores tests in a test package.
Public method | Initialize | Initializes the test runner.
Public method | RegisterExtension | Registers a test runner extension.
Public method | Run | Explores and runs tests in a test package.
Top

See Also

ITestRunner Interface
Gallio.Runner Namespace
Events
RegisterExtension
Initialize
Explore
Run
Dispose


Properties

ITestRunner Properties
[image]

Public Properties

 | Name | Description
Public property | Events | Gets the event dispatcher for the test runner.
Top

See Also

ITestRunner Interface
Gallio.Runner Namespace
Events
RegisterExtension
Initialize
Explore
Run
Dispose


Events Property

ITestRunner.Events Property
[image]

Gets the event dispatcher for the test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Events As ITestRunnerEvents
C#
ITestRunnerEvents Events { get; }
C++
property ITestRunnerEvents Events abstract {
ITestRunnerEvents get();
}
J#
/** property */
public ITestRunnerEvents get_Events();
JScript
public function get Events() : ITestRunnerEvents

See Also

ITestRunner Interface
Gallio.Runner Namespace


Methods

ITestRunner Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Disposes the test runner. Does nothing if already disposed or if not initialized.
Public method | Explore | Explores tests in a test package.
Public method | Initialize | Initializes the test runner.
Public method | RegisterExtension | Registers a test runner extension.
Public method | Run | Explores and runs tests in a test package.
Top

See Also

ITestRunner Interface
Gallio.Runner Namespace
Events
RegisterExtension
Initialize
Explore
Run
Dispose


Dispose Method

ITestRunner.Dispose Method
[image]

Disposes the test runner. Does nothing if already disposed or if not initialized.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Dispose( _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Dispose(
IProgressMonitor progressMonitor
)
C++
void Dispose(
IProgressMonitor progressMonitor
) abstract
J#
void Dispose(
IProgressMonitor progressMonitor
)
JScript
function Dispose(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null

See Also

ITestRunner Interface
Gallio.Runner Namespace


Explore Method

ITestRunner.Explore Method
[image]

Explores tests in a test package.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Explore( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal progressMonitor As IProgressMonitor _
) As Report
C#
Report Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
IProgressMonitor progressMonitor
)
C++
Report Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
IProgressMonitor progressMonitor
) abstract
J#
Report Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
IProgressMonitor progressMonitor
)
JScript
function Explore(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
progressMonitor : IProgressMonitor
) : Report

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
progressMonitor
The progress monitor

Return Value

The test report

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackageConfig, testExplorationOptions, or progressMonitor is null
RunnerException | Thrown if the operation failed
ObjectDisposedException | Thrown if the runner has been disposed

Remarks

Returns a report that contains test package and test model information only.

See Also

ITestRunner Interface
Gallio.Runner Namespace


Initialize Method

ITestRunner.Initialize Method
[image]

Initializes the test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize( _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Initialize(
TestRunnerOptions testRunnerOptions,
ILogger logger,
IProgressMonitor progressMonitor
)
C++
void Initialize(
TestRunnerOptions testRunnerOptions,
ILogger logger,
IProgressMonitor progressMonitor
) abstract
J#
void Initialize(
TestRunnerOptions testRunnerOptions,
ILogger logger,
IProgressMonitor progressMonitor
)
JScript
function Initialize(
testRunnerOptions : TestRunnerOptions,
logger : ILogger,
progressMonitor : IProgressMonitor
)

Parameters

testRunnerOptions
The test runner options
logger
The logger
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testRunnerOptions, logger or progressMonitor is null
InvalidOperationException | Thrown if the runner is already initialized
ObjectDisposedException | Thrown if the runner has been disposed

See Also

ITestRunner Interface
Gallio.Runner Namespace


RegisterExtension Method

ITestRunner.RegisterExtension Method
[image]

Registers a test runner extension.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterExtension( _
ByVal extension As ITestRunnerExtension _
)
C#
void RegisterExtension(
ITestRunnerExtension extension
)
C++
void RegisterExtension(
ITestRunnerExtension extension
) abstract
J#
void RegisterExtension(
ITestRunnerExtension extension
)
JScript
function RegisterExtension(
extension : ITestRunnerExtension
)

Parameters

extension
The test runner extension to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if extension is null
InvalidOperationException | Thrown if the test runner has already been initialized

Remarks

The extension should already have been configured before this method is called. Its Install method will be called to register the extension with the test runner as part of the initialization of the test runner.

See Also

ITestRunner Interface
Gallio.Runner Namespace


Run Method

ITestRunner.Run Method
[image]

Explores and runs tests in a test package.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Run( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal progressMonitor As IProgressMonitor _
) As Report
C#
Report Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
IProgressMonitor progressMonitor
)
C++
Report Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
IProgressMonitor progressMonitor
) abstract
J#
Report Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
IProgressMonitor progressMonitor
)
JScript
function Run(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExecutionOptions : TestExecutionOptions,
progressMonitor : IProgressMonitor
) : Report

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExecutionOptions
The test execution options
progressMonitor
The progress monitor

Return Value

The test report

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackageConfig, testExplorationOptions, testExecutionOptions, or progressMonitor is null
RunnerException | Thrown if the operation failed
ObjectDisposedException | Thrown if the runner has been disposed

Remarks

Returns a report that contains test package, test model and test run data.

See Also

ITestRunner Interface
Gallio.Runner Namespace


ITestRunnerFactory Interface

ITestRunnerFactory Interface
See Also Example Members
[image]

A test tunner factory is a service that creates an ITestRunner given a set of options. Each factory has a name which is used by ITestRunnerManager to select the particular factory to use for a given test run.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestRunnerFactory
Implements IRegisteredComponent
C#
public interface ITestRunnerFactory : IRegisteredComponent
C++
interface class ITestRunnerFactory : IRegisteredComponent
J#
public interface ITestRunnerFactory implements IRegisteredComponent
JScript
public interface ITestRunnerFactory extends IRegisteredComponent

Types that implement ITestRunnerFactory

Type | Description
Gallio.Runner.DefaultTestRunnerFactory | A ITestRunnerFactory for DefaultTestRunner using different implementations of ITestDriver.

See Also

ITestRunnerFactory Members
Gallio.Runner Namespace


ITestRunnerFactory Members

ITestRunnerFactory Members
See Also Example Methods
[image]

A test tunner factory is a service that creates an ITestRunner given a set of options. Each factory has a name which is used by ITestRunnerManager to select the particular factory to use for a given test run.

The following tables list the members exposed by ITestRunnerFactory.

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Top

See Also

ITestRunnerFactory Interface
Gallio.Runner Namespace


Methods

ITestRunnerFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Top

See Also

ITestRunnerFactory Interface
Gallio.Runner Namespace


CreateTestRunner Method

ITestRunnerFactory.CreateTestRunner Method
[image]

Creates a test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTestRunner() As ITestRunner
C#
ITestRunner CreateTestRunner()
C++
ITestRunner CreateTestRunner() abstract
J#
ITestRunner CreateTestRunner()
JScript
function CreateTestRunner() : ITestRunner

Return Value

The test runner

See Also

ITestRunnerFactory Interface
Gallio.Runner Namespace


ITestRunnerManager Interface

ITestRunnerManager Interface
See Also Example Members
[image]

A test runner manager enumerates the names of the ITestRunnerFactory services that are available and provides a mechanism for creating ITestRunner instances.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestRunnerManager
C#
public interface ITestRunnerManager
C++
interface class ITestRunnerManager
J#
public interface ITestRunnerManager
JScript
public interface ITestRunnerManager

Types that implement ITestRunnerManager

Type | Description
Gallio.Runner.DefaultTestRunnerManager | The default implementation of ITestRunnerManager.

See Also

ITestRunnerManager Members
Gallio.Runner Namespace


ITestRunnerManager Members

ITestRunnerManager Members
See Also Example Properties Methods
[image]

A test runner manager enumerates the names of the ITestRunnerFactory services that are available and provides a mechanism for creating ITestRunner instances.

The following tables list the members exposed by ITestRunnerManager.

Public Properties

 | Name | Description
Public property | FactoryResolver | Gets a resolver for resolving registered ITestRunnerFactory components by name.
Top

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Public method | GetFactory | Gets the factory by name, or null if none.
Public method | GetFactoryNames | Gets the names of all supported test runner factories.
Top

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


Properties

ITestRunnerManager Properties
[image]

Public Properties

 | Name | Description
Public property | FactoryResolver | Gets a resolver for resolving registered ITestRunnerFactory components by name.
Top

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


FactoryResolver Property

ITestRunnerManager.FactoryResolver Property
[image]

Gets a resolver for resolving registered ITestRunnerFactory components by name.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FactoryResolver As IRegisteredComponentResolver(Of ITestRunnerFactory)
C#
IRegisteredComponentResolver<ITestRunnerFactory> FactoryResolver { get; }
C++
property IRegisteredComponentResolver<ITestRunnerFactory> FactoryResolver abstract {
IRegisteredComponentResolver<ITestRunnerFactory> get();
}
J#
/** property */
public IRegisteredComponentResolver<ITestRunnerFactory> get_FactoryResolver();
JScript
public function get FactoryResolver() : IRegisteredComponentResolver<ITestRunnerFactory>

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


Methods

ITestRunnerManager Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestRunner | Creates a test runner.
Public method | GetFactory | Gets the factory by name, or null if none.
Public method | GetFactoryNames | Gets the names of all supported test runner factories.
Top

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


CreateTestRunner Method

ITestRunnerManager.CreateTestRunner Method
[image]

Creates a test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTestRunner( _
ByVal factoryName As String _
) As ITestRunner
C#
ITestRunner CreateTestRunner(
string factoryName
)
C++
ITestRunner CreateTestRunner(
String factoryName
) abstract
J#
ITestRunner CreateTestRunner(
string factoryName
)
JScript
function CreateTestRunner(
factoryName : String
) : ITestRunner

Parameters

factoryName
The name of the test runner factory, matched case-insensitively

Return Value

The test runner

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if factoryName is null

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


GetFactory Method

ITestRunnerManager.GetFactory Method
[image]

Gets the factory by name, or null if none.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetFactory( _
ByVal factoryName As String _
) As ITestRunnerFactory
C#
ITestRunnerFactory GetFactory(
string factoryName
)
C++
ITestRunnerFactory GetFactory(
String factoryName
) abstract
J#
ITestRunnerFactory GetFactory(
string factoryName
)
JScript
function GetFactory(
factoryName : String
) : ITestRunnerFactory

Parameters

factoryName
The name of the test runner factory, matched case-insensitively

Return Value

The test runner

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if factoryName is null

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


GetFactoryNames Method

ITestRunnerManager.GetFactoryNames Method
[image]

Gets the names of all supported test runner factories.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetFactoryNames() As IList(Of String)
C#
IList<string> GetFactoryNames()
C++
IList<string> GetFactoryNames() abstract
J#
IList<string> GetFactoryNames()
JScript
function GetFactoryNames() : IList<string>

Return Value

The names of all runner factories

See Also

ITestRunnerManager Interface
Gallio.Runner Namespace


OperationFinishedEventArgs Class

OperationFinishedEventArgs Class
See Also Example Members
[image]

Base arguments for events raised to indicate the completion of an operation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class OperationFinishedEventArgs
Inherits EventArgs
C#
public abstract class OperationFinishedEventArgs : EventArgs
C++
ref class OperationFinishedEventArgs abstract : EventArgs
J#
public class OperationFinishedEventArgs extends EventArgs
JScript
public class OperationFinishedEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.Events.DisposeFinishedEventArgs
Gallio.Runner.Events.ExploreFinishedEventArgs
Gallio.Runner.Events.InitializeFinishedEventArgs
Gallio.Runner.Events.RunFinishedEventArgs

See Also

OperationFinishedEventArgs Members
Gallio.Runner Namespace


OperationFinishedEventArgs Members

OperationFinishedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Base arguments for events raised to indicate the completion of an operation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by OperationFinishedEventArgs.

Protected Constructors

 | Name | Description
Family method | OperationFinishedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Success | Returns true if the operation completed successfully.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

OperationFinishedEventArgs Class
Gallio.Runner Namespace


OperationFinishedEventArgs Constructor

OperationFinishedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal success As Boolean _
)
C#
protected OperationFinishedEventArgs(
bool success
)
C++
protected:
OperationFinishedEventArgs(
bool success
) sealed
J#
protected OperationFinishedEventArgs(
bool success
)
JScript
protected function OperationFinishedEventArgs(
success : bool
)

Parameters

success
True if the operation completed successfully

See Also

OperationFinishedEventArgs Class
Gallio.Runner Namespace


Properties

OperationFinishedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Success | Returns true if the operation completed successfully.
Top

See Also

OperationFinishedEventArgs Class
Gallio.Runner Namespace


Success Property

OperationFinishedEventArgs.Success Property
[image]

Returns true if the operation completed successfully.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Success As Boolean
C#
public bool Success { get; }
C++
public property bool Success sealed {
bool get();
}
J#
/** property */
public bool get_Success();
JScript
public function get Success() : bool

See Also

OperationFinishedEventArgs Class
Gallio.Runner Namespace


OperationStartedEventArgs Class

OperationStartedEventArgs Class
See Also Example Members
[image]

Base arguments for events raised to indicate the beginning of an operation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class OperationStartedEventArgs
Inherits EventArgs
C#
public abstract class OperationStartedEventArgs : EventArgs
C++
ref class OperationStartedEventArgs abstract : EventArgs
J#
public class OperationStartedEventArgs extends EventArgs
JScript
public class OperationStartedEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationStartedEventArgs
Gallio.Runner.Events.DisposeStartedEventArgs
Gallio.Runner.Events.ExploreStartedEventArgs
Gallio.Runner.Events.InitializeStartedEventArgs
Gallio.Runner.Events.RunStartedEventArgs

See Also

OperationStartedEventArgs Members
Gallio.Runner Namespace


OperationStartedEventArgs Members

OperationStartedEventArgs Members
See Also Example Constructors Methods
[image]

Base arguments for events raised to indicate the beginning of an operation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by OperationStartedEventArgs.

Protected Constructors

 | Name | Description
Family method | OperationStartedEventArgs | Initializes the event arguments.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

OperationStartedEventArgs Class
Gallio.Runner Namespace


OperationStartedEventArgs Constructor

OperationStartedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected OperationStartedEventArgs()
C++
protected:
OperationStartedEventArgs() sealed
J#
protected OperationStartedEventArgs()
JScript
protected function OperationStartedEventArgs()

See Also

OperationStartedEventArgs Class
Gallio.Runner Namespace


ResultCode Class

ResultCode Class
See Also Example Members
[image]

Describes the result codes used by the application. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ResultCode
C#
public static class ResultCode
C++
ref class ResultCode abstract sealed
J#
public final class ResultCode
JScript
public class ResultCode

Inheritance Hierarchy

System.Object
Gallio.Runner.ResultCode

See Also

ResultCode Members
Gallio.Runner Namespace


ResultCode Members

ResultCode Members
See Also Example Fields
[image]

Describes the result codes used by the application. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ResultCode.

Public Fields

Name | Description
Canceled | The tests were canceled. This field is constant and read-only.
Failure | Some tests failed. This field is constant and read-only.
FatalException | A fatal runtime exception occurred. This field is constant and read-only.
InvalidArguments | Invalid arguments were supplied on the command-line. This field is constant and read-only.
NoTests | No tests were found. This field is constant and read-only.
Success | The tests ran successfully or there were no tests to run. This field is constant and read-only.
Top

See Also

ResultCode Class
Gallio.Runner Namespace


Fields

ResultCode Fields
[image]

Public Fields

Name | Description
Canceled | The tests were canceled. This field is constant and read-only.
Failure | Some tests failed. This field is constant and read-only.
FatalException | A fatal runtime exception occurred. This field is constant and read-only.
InvalidArguments | Invalid arguments were supplied on the command-line. This field is constant and read-only.
NoTests | No tests were found. This field is constant and read-only.
Success | The tests ran successfully or there were no tests to run. This field is constant and read-only.
Top

See Also

ResultCode Class
Gallio.Runner Namespace


Canceled Field

ResultCode.Canceled Field
[image]

The tests were canceled. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Canceled As Integer = 2
C#
public const int Canceled = 2;
C++
public:
const int Canceled = 2;
J#
public const int Canceled = 2
JScript
public const Canceled : int = 2;

See Also

ResultCode Class
Gallio.Runner Namespace


Failure Field

ResultCode.Failure Field
[image]

Some tests failed. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Failure As Integer = 1
C#
public const int Failure = 1;
C++
public:
const int Failure = 1;
J#
public const int Failure = 1
JScript
public const Failure : int = 1;

See Also

ResultCode Class
Gallio.Runner Namespace


FatalException Field

ResultCode.FatalException Field
[image]

A fatal runtime exception occurred. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const FatalException As Integer = 3
C#
public const int FatalException = 3;
C++
public:
const int FatalException = 3;
J#
public const int FatalException = 3
JScript
public const FatalException : int = 3;

See Also

ResultCode Class
Gallio.Runner Namespace


InvalidArguments Field

ResultCode.InvalidArguments Field
[image]

Invalid arguments were supplied on the command-line. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const InvalidArguments As Integer = 10
C#
public const int InvalidArguments = 10;
C++
public:
const int InvalidArguments = 10;
J#
public const int InvalidArguments = 10
JScript
public const InvalidArguments : int = 10;

See Also

ResultCode Class
Gallio.Runner Namespace


NoTests Field

ResultCode.NoTests Field
[image]

No tests were found. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const NoTests As Integer = 16
C#
public const int NoTests = 16;
C++
public:
const int NoTests = 16;
J#
public const int NoTests = 16
JScript
public const NoTests : int = 16;

See Also

ResultCode Class
Gallio.Runner Namespace


Success Field

ResultCode.Success Field
[image]

The tests ran successfully or there were no tests to run. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Success As Integer = 0
C#
public const int Success = 0;
C++
public:
const int Success = 0;
J#
public const int Success = 0
JScript
public const Success : int = 0;

See Also

ResultCode Class
Gallio.Runner Namespace


RunnerException Class

RunnerException Class
See Also Example Members
[image]

The type of exception thrown when the test runner or one of its supportive components like a test domain fails in an unrecoverable manner. It can happen that the test results will be lost or incomplete.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class RunnerException
Inherits Exception
C#
[SerializableAttribute]
public class RunnerException : Exception
C++
[SerializableAttribute]
ref class RunnerException : Exception
J#
/** @attribute SerializableAttribute() */
public class RunnerException extends Exception
JScript
public
SerializableAttribute
class RunnerException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Runner.RunnerException

See Also

RunnerException Members
Gallio.Runner Namespace


RunnerException Members

RunnerException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when the test runner or one of its supportive components like a test domain fails in an unrecoverable manner. It can happen that the test results will be lost or incomplete.

The following tables list the members exposed by RunnerException.

Public Constructors

Name | Description
RunnerException | Overloaded. Initializes a new instance of the RunnerException class.
Top

Protected Constructors

Name | Description
RunnerException | Overloaded. Initializes a new instance of the RunnerException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
RunnerException | Overloaded. Initializes a new instance of the RunnerException class.
Top

See Also

RunnerException Class
Gallio.Runner Namespace


RunnerException Constructor

RunnerException Constructor

Initializes a new instance of the RunnerException class.

Overload List

 | Name | Description
Public method | RunnerException | Creates an exception.
Family method | RunnerException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | RunnerException (String) | Creates an exception.
Public method | RunnerException (String, Exception) | Creates an exception.

See Also

RunnerException Class
Gallio.Runner Namespace


RunnerException Constructor ()

RunnerException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RunnerException()
C++
public:
RunnerException() sealed
J#
public RunnerException()
JScript
public function RunnerException()

See Also

RunnerException Class
Gallio.Runner Namespace
RunnerException Constructor Overload List


RunnerException Constructor (SerializationInfo, StreamingContext)

RunnerException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected RunnerException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
RunnerException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected RunnerException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function RunnerException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

RunnerException Class
Gallio.Runner Namespace
RunnerException Constructor Overload List


RunnerException Constructor (String)

RunnerException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public RunnerException(
string message
)
C++
public:
RunnerException(
String message
) sealed
J#
public RunnerException(
string message
)
JScript
public function RunnerException(
message : String
)

Parameters

message
The message

See Also

RunnerException Class
Gallio.Runner Namespace
RunnerException Constructor Overload List


RunnerException Constructor (String, Exception)

RunnerException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public RunnerException(
string message,
Exception innerException
)
C++
public:
RunnerException(
String message,
Exception innerException
) sealed
J#
public RunnerException(
string message,
Exception innerException
)
JScript
public function RunnerException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

RunnerException Class
Gallio.Runner Namespace
RunnerException Constructor Overload List


StandardTestRunnerFactoryNames Class

StandardTestRunnerFactoryNames Class
See Also Example Members
[image]

Provides constant names for the standard test runner factories. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module StandardTestRunnerFactoryNames
C#
public static class StandardTestRunnerFactoryNames
C++
ref class StandardTestRunnerFactoryNames abstract sealed
J#
public final class StandardTestRunnerFactoryNames
JScript
public class StandardTestRunnerFactoryNames

Inheritance Hierarchy

System.Object
Gallio.Runner.StandardTestRunnerFactoryNames

See Also

StandardTestRunnerFactoryNames Members
Gallio.Runner Namespace


StandardTestRunnerFactoryNames Members

StandardTestRunnerFactoryNames Members
See Also Example Fields
[image]

Provides constant names for the standard test runner factories. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by StandardTestRunnerFactoryNames.

Public Fields

Name | Description
IsolatedAppDomain | Runs the test runner in an isolated AppDomain of the current process. This field is constant and read-only.
IsolatedProcess | Runs the test runner in an isolated process. This field is constant and read-only.
Local | Runs the test runner in the local AppDomain. This field is constant and read-only.
Top

See Also

StandardTestRunnerFactoryNames Class
Gallio.Runner Namespace


Fields

StandardTestRunnerFactoryNames Fields
[image]

Public Fields

Name | Description
IsolatedAppDomain | Runs the test runner in an isolated AppDomain of the current process. This field is constant and read-only.
IsolatedProcess | Runs the test runner in an isolated process. This field is constant and read-only.
Local | Runs the test runner in the local AppDomain. This field is constant and read-only.
Top

See Also

StandardTestRunnerFactoryNames Class
Gallio.Runner Namespace


IsolatedAppDomain Field

StandardTestRunnerFactoryNames.IsolatedAppDomain Field
[image]

Runs the test runner in an isolated AppDomain of the current process. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const IsolatedAppDomain As String = "IsolatedAppDomain"
C#
public const string IsolatedAppDomain = "IsolatedAppDomain";
C++
public:
const String IsolatedAppDomain = L"IsolatedAppDomain";
J#
public const string IsolatedAppDomain = "IsolatedAppDomain"
JScript
public const IsolatedAppDomain : String = "IsolatedAppDomain";

See Also

StandardTestRunnerFactoryNames Class
Gallio.Runner Namespace


IsolatedProcess Field

StandardTestRunnerFactoryNames.IsolatedProcess Field
[image]

Runs the test runner in an isolated process. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const IsolatedProcess As String = "IsolatedProcess"
C#
public const string IsolatedProcess = "IsolatedProcess";
C++
public:
const String IsolatedProcess = L"IsolatedProcess";
J#
public const string IsolatedProcess = "IsolatedProcess"
JScript
public const IsolatedProcess : String = "IsolatedProcess";

See Also

StandardTestRunnerFactoryNames Class
Gallio.Runner Namespace


Local Field

StandardTestRunnerFactoryNames.Local Field
[image]

Runs the test runner in the local AppDomain. This field is constant and read-only.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const Local As String = "Local"
C#
public const string Local = "Local";
C++
public:
const String Local = L"Local";
J#
public const string Local = "Local"
JScript
public const Local : String = "Local";

Remarks

This is is usually the default mode because tests typically run inside of isolated AppDomains of their own nested within the test runner.

See Also

StandardTestRunnerFactoryNames Class
Gallio.Runner Namespace


TestLauncher Class

TestLauncher Class
See Also Example Members
[image]

The test launcher encapsulated the entire test execution lifecycle from start to finish and provides a simplified pattern for running tests.

The basic usage pattern is as follows: Create the launcher.Set properties to specify the inputs and outputs of the test run.Run the tests all in one go.Optionally do something with the contents of the final report.

By default, the launcher assumes that a runtime environment has already been established and is accessible via the RuntimeAccessor. If there is no runtime yet, then you can cause one to be configured automatically for the duration of the test run by setting the RuntimeSetup property accordingly.

You can override the default ITestRunner that is created by setting the TestRunnerFactoryName property.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TestLauncher
C#
public class TestLauncher
C++
ref class TestLauncher
J#
public class TestLauncher
JScript
public class TestLauncher

Inheritance Hierarchy

System.Object
Gallio.Runner.TestLauncher

See Also

TestLauncher Members
Gallio.Runner Namespace


TestLauncher Members

TestLauncher Members
See Also Example Constructors Properties Methods
[image]

The test launcher encapsulated the entire test execution lifecycle from start to finish and provides a simplified pattern for running tests.

The basic usage pattern is as follows: Create the launcher.Set properties to specify the inputs and outputs of the test run.Run the tests all in one go.Optionally do something with the contents of the final report.

By default, the launcher assumes that a runtime environment has already been established and is accessible via the RuntimeAccessor. If there is no runtime yet, then you can cause one to be configured automatically for the duration of the test run by setting the RuntimeSetup property accordingly.

You can override the default ITestRunner that is created by setting the TestRunnerFactoryName property.

The following tables list the members exposed by TestLauncher.

Public Constructors

 | Name | Description
Public method | TestLauncher | Creates a launcher with default options and no test assemblies specified.
Top

Public Properties

 | Name | Description
Public property | DoNotRun | Gets or sets whether to skip test execution. This option may be used to produce a report that contains test metadata for consumption by other tools. The default value is false.
Public property | EchoResults | Controls whether the test runner will echo result to the Logger as each test finishes. The default value is false.
Public property | IgnoreAnnotations | Gets or sets whether to ignore annotations when determining the result code. If false, then error annotations, usually indicative of broken tests, will cause a failure result to be generated. The default value is false.
Public property | Logger | Gets or sets the logger to use. The default logger is Instance.
Public property | ProgressMonitorProvider | Gets or sets the progress monitor provider to use. The default provider is Instance.
Public property | ReportDirectory | Gets or sets the path of the directory to which reports will be written. The default value is "" which causes reports to be written to the current directory.
Public property | ReportFormats | Gets the mutable list of report formats to generate.
Public property | ReportFormatterOptions | Gets or sets the report formatter options.
Public property | ReportNameFormat | Gets or sets a format string used to construct the name of report files (without the extension). Within the format string, {0} is replaced by the date and {1} by the time. The default value is "test-report-{0}-{1}".
Public property | RunTimeLimit | Gets or sets the maximum amount of time the tests can run before they are canceled. The default value is null, meaning an infinite time.
Public property | RuntimeSetup | Gets or sets the RuntimeSetup to use for automatically initializing the runtime during test execution or null if the runtime is already initialized.
Public property | ShowReports | Gets or sets whether to show the reports after the test run finishes. The default value is false.
Public property | TestExecutionOptions | Gets or sets the test execution options.
Public property | TestExplorationOptions | Gets or sets the test exploration options.
Public property | TestPackageConfig | Gets or sets the test package.
Public property | TestRunnerExtensions | Gets a mutable list of test runner extensions to register with the test runner during test execution.
Public property | TestRunnerExtensionSpecifications | Gets a mutable list of test runner extension specifications to instantiate and register with the test runner during test execution.
Public property | TestRunnerFactoryName | Specifies the name of a ITestRunnerFactory to use for constructing the ITestRunner at test execution time. The default value is IsolatedProcess.
Public property | TestRunnerOptions | Gets or sets the test runner options.
Top

Public Methods

 | Name | Description
Public method | Cancel | Cancels the test run and prevents a new one from starting.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs the test package as configured.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestLauncher Class
Gallio.Runner Namespace


TestLauncher Constructor

TestLauncher Constructor
[image]

Creates a launcher with default options and no test assemblies specified.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestLauncher()
C++
public:
TestLauncher() sealed
J#
public TestLauncher()
JScript
public function TestLauncher()

See Also

TestLauncher Class
Gallio.Runner Namespace


Properties

TestLauncher Properties
[image]

Public Properties

 | Name | Description
Public property | DoNotRun | Gets or sets whether to skip test execution. This option may be used to produce a report that contains test metadata for consumption by other tools. The default value is false.
Public property | EchoResults | Controls whether the test runner will echo result to the Logger as each test finishes. The default value is false.
Public property | IgnoreAnnotations | Gets or sets whether to ignore annotations when determining the result code. If false, then error annotations, usually indicative of broken tests, will cause a failure result to be generated. The default value is false.
Public property | Logger | Gets or sets the logger to use. The default logger is Instance.
Public property | ProgressMonitorProvider | Gets or sets the progress monitor provider to use. The default provider is Instance.
Public property | ReportDirectory | Gets or sets the path of the directory to which reports will be written. The default value is "" which causes reports to be written to the current directory.
Public property | ReportFormats | Gets the mutable list of report formats to generate.
Public property | ReportFormatterOptions | Gets or sets the report formatter options.
Public property | ReportNameFormat | Gets or sets a format string used to construct the name of report files (without the extension). Within the format string, {0} is replaced by the date and {1} by the time. The default value is "test-report-{0}-{1}".
Public property | RunTimeLimit | Gets or sets the maximum amount of time the tests can run before they are canceled. The default value is null, meaning an infinite time.
Public property | RuntimeSetup | Gets or sets the RuntimeSetup to use for automatically initializing the runtime during test execution or null if the runtime is already initialized.
Public property | ShowReports | Gets or sets whether to show the reports after the test run finishes. The default value is false.
Public property | TestExecutionOptions | Gets or sets the test execution options.
Public property | TestExplorationOptions | Gets or sets the test exploration options.
Public property | TestPackageConfig | Gets or sets the test package.
Public property | TestRunnerExtensions | Gets a mutable list of test runner extensions to register with the test runner during test execution.
Public property | TestRunnerExtensionSpecifications | Gets a mutable list of test runner extension specifications to instantiate and register with the test runner during test execution.
Public property | TestRunnerFactoryName | Specifies the name of a ITestRunnerFactory to use for constructing the ITestRunner at test execution time. The default value is IsolatedProcess.
Public property | TestRunnerOptions | Gets or sets the test runner options.
Top

See Also

TestLauncher Class
Gallio.Runner Namespace


DoNotRun Property

TestLauncher.DoNotRun Property
[image]

Gets or sets whether to skip test execution. This option may be used to produce a report that contains test metadata for consumption by other tools.

The default value is false.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property DoNotRun As Boolean
C#
public bool DoNotRun { get; set; }
C++
public property bool DoNotRun sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DoNotRun();

/** property */
public void set_DoNotRun(bool value);
JScript
public function get DoNotRun() : bool

public function set DoNotRun(value : bool);

See Also

TestLauncher Class
Gallio.Runner Namespace


EchoResults Property

TestLauncher.EchoResults Property
[image]

Controls whether the test runner will echo result to the Logger as each test finishes.

The default value is false.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property EchoResults As Boolean
C#
public bool EchoResults { get; set; }
C++
public property bool EchoResults sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EchoResults();

/** property */
public void set_EchoResults(bool value);
JScript
public function get EchoResults() : bool

public function set EchoResults(value : bool);

See Also

TestLauncher Class
Gallio.Runner Namespace


IgnoreAnnotations Property

TestLauncher.IgnoreAnnotations Property
[image]

Gets or sets whether to ignore annotations when determining the result code. If false, then error annotations, usually indicative of broken tests, will cause a failure result to be generated.

The default value is false.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreAnnotations As Boolean
C#
public bool IgnoreAnnotations { get; set; }
C++
public property bool IgnoreAnnotations sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IgnoreAnnotations();

/** property */
public void set_IgnoreAnnotations(bool value);
JScript
public function get IgnoreAnnotations() : bool

public function set IgnoreAnnotations(value : bool);

See Also

TestLauncher Class
Gallio.Runner Namespace


Logger Property

TestLauncher.Logger Property
[image]

Gets or sets the logger to use.

The default logger is Instance.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Logger As ILogger
C#
public ILogger Logger { get; set; }
C++
public property ILogger Logger sealed {
ILogger get();
void set(ILogger value);
}
J#
/** property */
public ILogger get_Logger();

/** property */
public void set_Logger(ILogger value);
JScript
public function get Logger() : ILogger

public function set Logger(value : ILogger);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


ProgressMonitorProvider Property

TestLauncher.ProgressMonitorProvider Property
[image]

Gets or sets the progress monitor provider to use.

The default provider is Instance.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ProgressMonitorProvider As IProgressMonitorProvider
C#
public IProgressMonitorProvider ProgressMonitorProvider { get; set; }
C++
public property IProgressMonitorProvider ProgressMonitorProvider sealed {
IProgressMonitorProvider get();
void set(IProgressMonitorProvider value);
}
J#
/** property */
public IProgressMonitorProvider get_ProgressMonitorProvider();

/** property */
public void set_ProgressMonitorProvider(IProgressMonitorProvider value);
JScript
public function get ProgressMonitorProvider() : IProgressMonitorProvider

public function set ProgressMonitorProvider(value : IProgressMonitorProvider);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


ReportDirectory Property

TestLauncher.ReportDirectory Property
[image]

Gets or sets the path of the directory to which reports will be written.

The default value is "" which causes reports to be written to the current directory.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportDirectory As String
C#
public string ReportDirectory { get; set; }
C++
public property string ReportDirectory sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ReportDirectory();

/** property */
public void set_ReportDirectory(string value);
JScript
public function get ReportDirectory() : String

public function set ReportDirectory(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


ReportFormats Property

TestLauncher.ReportFormats Property
[image]

Gets the mutable list of report formats to generate.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportFormats As IList(Of String)
C#
public IList<string> ReportFormats { get; }
C++
public property IList<string> ReportFormats sealed {
IList<string> get();
}
J#
/** property */
public IList<string> get_ReportFormats();
JScript
public function get ReportFormats() : IList<string>

See Also

TestLauncher Class
Gallio.Runner Namespace


ReportFormatterOptions Property

TestLauncher.ReportFormatterOptions Property
[image]

Gets or sets the report formatter options.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportFormatterOptions As ReportFormatterOptions
C#
public ReportFormatterOptions ReportFormatterOptions { get; set; }
C++
public property ReportFormatterOptions ReportFormatterOptions sealed {
ReportFormatterOptions get();
void set(ReportFormatterOptions value);
}
J#
/** property */
public ReportFormatterOptions get_ReportFormatterOptions();

/** property */
public void set_ReportFormatterOptions(ReportFormatterOptions value);
JScript
public function get ReportFormatterOptions() : ReportFormatterOptions

public function set ReportFormatterOptions(value : ReportFormatterOptions);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


ReportNameFormat Property

TestLauncher.ReportNameFormat Property
[image]

Gets or sets a format string used to construct the name of report files (without the extension). Within the format string, {0} is replaced by the date and {1} by the time.

The default value is "test-report-{0}-{1}".

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ReportNameFormat As String
C#
public string ReportNameFormat { get; set; }
C++
public property string ReportNameFormat sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ReportNameFormat();

/** property */
public void set_ReportNameFormat(string value);
JScript
public function get ReportNameFormat() : String

public function set ReportNameFormat(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


RunTimeLimit Property

TestLauncher.RunTimeLimit Property
[image]

Gets or sets the maximum amount of time the tests can run before they are canceled.

The default value is null, meaning an infinite time.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property RunTimeLimit As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> RunTimeLimit { get; set; }
C++
public property Nullable<TimeSpan> RunTimeLimit sealed {
Nullable<TimeSpan> get();
void set(Nullable<TimeSpan> value);
}
J#
/** property */
public Nullable<TimeSpan> get_RunTimeLimit();

/** property */
public void set_RunTimeLimit(Nullable<TimeSpan> value);
JScript
public function get RunTimeLimit() : Nullable<TimeSpan>

public function set RunTimeLimit(value : Nullable<TimeSpan>);

See Also

TestLauncher Class
Gallio.Runner Namespace


RuntimeSetup Property

TestLauncher.RuntimeSetup Property
[image]

Gets or sets the RuntimeSetup to use for automatically initializing the runtime during test execution or null if the runtime is already initialized.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property RuntimeSetup As RuntimeSetup
C#
public RuntimeSetup RuntimeSetup { get; set; }
C++
public property RuntimeSetup RuntimeSetup sealed {
RuntimeSetup get();
void set(RuntimeSetup value);
}
J#
/** property */
public RuntimeSetup get_RuntimeSetup();

/** property */
public void set_RuntimeSetup(RuntimeSetup value);
JScript
public function get RuntimeSetup() : RuntimeSetup

public function set RuntimeSetup(value : RuntimeSetup);

Remarks

If this value if not null then the launcher will initialize the runtime using this RuntimeSetup (unless already initialized) just prior to test execution and will automatically shut down the runtime just afterwards.

The default value is null which assumes that the runtime is already initialized.

See Also

TestLauncher Class
Gallio.Runner Namespace


ShowReports Property

TestLauncher.ShowReports Property
[image]

Gets or sets whether to show the reports after the test run finishes.

The default value is false.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowReports As Boolean
C#
public bool ShowReports { get; set; }
C++
public property bool ShowReports sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowReports();

/** property */
public void set_ShowReports(bool value);
JScript
public function get ShowReports() : bool

public function set ShowReports(value : bool);

See Also

TestLauncher Class
Gallio.Runner Namespace


TestExecutionOptions Property

TestLauncher.TestExecutionOptions Property
[image]

Gets or sets the test execution options.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestExecutionOptions As TestExecutionOptions
C#
public TestExecutionOptions TestExecutionOptions { get; set; }
C++
public property TestExecutionOptions TestExecutionOptions sealed {
TestExecutionOptions get();
void set(TestExecutionOptions value);
}
J#
/** property */
public TestExecutionOptions get_TestExecutionOptions();

/** property */
public void set_TestExecutionOptions(TestExecutionOptions value);
JScript
public function get TestExecutionOptions() : TestExecutionOptions

public function set TestExecutionOptions(value : TestExecutionOptions);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


TestExplorationOptions Property

TestLauncher.TestExplorationOptions Property
[image]

Gets or sets the test exploration options.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestExplorationOptions As TestExplorationOptions
C#
public TestExplorationOptions TestExplorationOptions { get; set; }
C++
public property TestExplorationOptions TestExplorationOptions sealed {
TestExplorationOptions get();
void set(TestExplorationOptions value);
}
J#
/** property */
public TestExplorationOptions get_TestExplorationOptions();

/** property */
public void set_TestExplorationOptions(TestExplorationOptions value);
JScript
public function get TestExplorationOptions() : TestExplorationOptions

public function set TestExplorationOptions(value : TestExplorationOptions);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


TestPackageConfig Property

TestLauncher.TestPackageConfig Property
[image]

Gets or sets the test package.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestPackageConfig As TestPackageConfig
C#
public TestPackageConfig TestPackageConfig { get; set; }
C++
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
void set(TestPackageConfig value);
}
J#
/** property */
public TestPackageConfig get_TestPackageConfig();

/** property */
public void set_TestPackageConfig(TestPackageConfig value);
JScript
public function get TestPackageConfig() : TestPackageConfig

public function set TestPackageConfig(value : TestPackageConfig);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


TestRunnerExtensions Property

TestLauncher.TestRunnerExtensions Property
[image]

Gets a mutable list of test runner extensions to register with the test runner during test execution.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestRunnerExtensions As IList(Of ITestRunnerExtension)
C#
public IList<ITestRunnerExtension> TestRunnerExtensions { get; }
C++
public property IList<ITestRunnerExtension> TestRunnerExtensions sealed {
IList<ITestRunnerExtension> get();
}
J#
/** property */
public IList<ITestRunnerExtension> get_TestRunnerExtensions();
JScript
public function get TestRunnerExtensions() : IList<ITestRunnerExtension>

See Also

TestLauncher Class
Gallio.Runner Namespace


TestRunnerExtensionSpecifications Property

TestLauncher.TestRunnerExtensionSpecifications Property
[image]

Gets a mutable list of test runner extension specifications to instantiate and register with the test runner during test execution.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestRunnerExtensionSpecifications As IList(Of String)
C#
public IList<string> TestRunnerExtensionSpecifications { get; }
C++
public property IList<string> TestRunnerExtensionSpecifications sealed {
IList<string> get();
}
J#
/** property */
public IList<string> get_TestRunnerExtensionSpecifications();
JScript
public function get TestRunnerExtensionSpecifications() : IList<string>

See Also

TestLauncher Class
Gallio.Runner Namespace
CreateExtensionFromSpecification


TestRunnerFactoryName Property

TestLauncher.TestRunnerFactoryName Property
[image]

Specifies the name of a ITestRunnerFactory to use for constructing the ITestRunner at test execution time.

The default value is IsolatedProcess.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestRunnerFactoryName As String
C#
public string TestRunnerFactoryName { get; set; }
C++
public property string TestRunnerFactoryName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TestRunnerFactoryName();

/** property */
public void set_TestRunnerFactoryName(string value);
JScript
public function get TestRunnerFactoryName() : String

public function set TestRunnerFactoryName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


TestRunnerOptions Property

TestLauncher.TestRunnerOptions Property
[image]

Gets or sets the test runner options.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property TestRunnerOptions As TestRunnerOptions
C#
public TestRunnerOptions TestRunnerOptions { get; set; }
C++
public property TestRunnerOptions TestRunnerOptions sealed {
TestRunnerOptions get();
void set(TestRunnerOptions value);
}
J#
/** property */
public TestRunnerOptions get_TestRunnerOptions();

/** property */
public void set_TestRunnerOptions(TestRunnerOptions value);
JScript
public function get TestRunnerOptions() : TestRunnerOptions

public function set TestRunnerOptions(value : TestRunnerOptions);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestLauncher Class
Gallio.Runner Namespace


Methods

TestLauncher Methods
[image]

Public Methods

 | Name | Description
Public method | Cancel | Cancels the test run and prevents a new one from starting.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs the test package as configured.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestLauncher Class
Gallio.Runner Namespace


Cancel Method

TestLauncher.Cancel Method
[image]

Cancels the test run and prevents a new one from starting.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Cancel()
C#
public void Cancel()
C++
public:
void Cancel() sealed
J#
public void Cancel()
JScript
public function Cancel()

See Also

TestLauncher Class
Gallio.Runner Namespace


Run Method

TestLauncher.Run Method
[image]

Runs the test package as configured.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Run() As TestLauncherResult
C#
public TestLauncherResult Run()
C++
public:
TestLauncherResult Run() sealed
J#
public TestLauncherResult Run()
JScript
public function Run() : TestLauncherResult

Return Value

A result object

Remarks

If RuntimeSetup is non-null, initializes the runtime for the duration of this method then shuts it down automatically before returning. Otherwise assumes the runtime has already been initialized and accesses it using RuntimeAccessor.

Runtimes cannot be nested. So if the launcher is asked to initialize the runtime and it has already been initialized, then it will not be initialized again.

See Also

TestLauncher Class
Gallio.Runner Namespace


TestLauncherResult Class

TestLauncherResult Class
See Also Example Members
[image]

Contains the result of a complete test run.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class TestLauncherResult
C#
[SerializableAttribute]
public class TestLauncherResult
C++
[SerializableAttribute]
ref class TestLauncherResult
J#
/** @attribute SerializableAttribute() */
public class TestLauncherResult
JScript
public
SerializableAttribute
class TestLauncherResult

Inheritance Hierarchy

System.Object
Gallio.Runner.TestLauncherResult

See Also

TestLauncherResult Members
Gallio.Runner Namespace


TestLauncherResult Members

TestLauncherResult Members
See Also Example Constructors Properties Methods
[image]

Contains the result of a complete test run.

The following tables list the members exposed by TestLauncherResult.

Public Constructors

 | Name | Description
Public method | TestLauncherResult | Creates a launcher result object.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the test report.
Public property | ReportDocumentPaths | Gets the full paths of the formatted report documents.
Public property | ResultCode | Gets the result code.
Public property | ResultSummary | Gets a short summary with the number of test that passed, failed and so on.
Public property | Statistics | Gets the statistics of the execution from the report or an empty statistics object if none.
Top

Public Methods

 | Name | Description
Public method | AddReportDocumentPath | Adds a new report document path.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GenerateReports | Generates reports of the desired forms. This method adds the paths of the generated report documents to ReportDocumentPaths.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetResultCode | Sets the result code of the result.
Public method | ShowReportDocuments | Shows the report documents enumerated in the launcher result.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestLauncherResult Class
Gallio.Runner Namespace


TestLauncherResult Constructor

TestLauncherResult Constructor
[image]

Creates a launcher result object.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report _
)
C#
public TestLauncherResult(
Report report
)
C++
public:
TestLauncherResult(
Report report
) sealed
J#
public TestLauncherResult(
Report report
)
JScript
public function TestLauncherResult(
report : Report
)

Parameters

report
The test report

See Also

TestLauncherResult Class
Gallio.Runner Namespace


Properties

TestLauncherResult Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the test report.
Public property | ReportDocumentPaths | Gets the full paths of the formatted report documents.
Public property | ResultCode | Gets the result code.
Public property | ResultSummary | Gets a short summary with the number of test that passed, failed and so on.
Public property | Statistics | Gets the statistics of the execution from the report or an empty statistics object if none.
Top

See Also

TestLauncherResult Class
Gallio.Runner Namespace


Report Property

TestLauncherResult.Report Property
[image]

Gets the test report.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

Remarks

The report might be incomplete in varying degrees depending on how much of the test execution was successfully performed.

See Also

TestLauncherResult Class
Gallio.Runner Namespace


ReportDocumentPaths Property

TestLauncherResult.ReportDocumentPaths Property
[image]

Gets the full paths of the formatted report documents.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportDocumentPaths As IList(Of String)
C#
public IList<string> ReportDocumentPaths { get; }
C++
public property IList<string> ReportDocumentPaths sealed {
IList<string> get();
}
J#
/** property */
public IList<string> get_ReportDocumentPaths();
JScript
public function get ReportDocumentPaths() : IList<string>

Property Value

The full paths of the formatted report documents

See Also

TestLauncherResult Class
Gallio.Runner Namespace


ResultCode Property

TestLauncherResult.ResultCode Property
[image]

Gets the result code.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultCode As Integer
C#
public int ResultCode { get; }
C++
public property int ResultCode sealed {
int get();
}
J#
/** property */
public int get_ResultCode();
JScript
public function get ResultCode() : int

See Also

TestLauncherResult Class
Gallio.Runner Namespace


ResultSummary Property

TestLauncherResult.ResultSummary Property
[image]

Gets a short summary with the number of test that passed, failed and so on.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResultSummary As String
C#
public string ResultSummary { get; }
C++
public property string ResultSummary sealed {
String get();
}
J#
/** property */
public string get_ResultSummary();
JScript
public function get ResultSummary() : String

See Also

TestLauncherResult Class
Gallio.Runner Namespace


Statistics Property

TestLauncherResult.Statistics Property
[image]

Gets the statistics of the execution from the report or an empty statistics object if none.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Statistics As Statistics
C#
public Statistics Statistics { get; }
C++
public property Statistics Statistics sealed {
Statistics get();
}
J#
/** property */
public Statistics get_Statistics();
JScript
public function get Statistics() : Statistics

See Also

TestLauncherResult Class
Gallio.Runner Namespace


Methods

TestLauncherResult Methods
[image]

Public Methods

 | Name | Description
Public method | AddReportDocumentPath | Adds a new report document path.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GenerateReports | Generates reports of the desired forms. This method adds the paths of the generated report documents to ReportDocumentPaths.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetResultCode | Sets the result code of the result.
Public method | ShowReportDocuments | Shows the report documents enumerated in the launcher result.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestLauncherResult Class
Gallio.Runner Namespace


AddReportDocumentPath Method

TestLauncherResult.AddReportDocumentPath Method
[image]

Adds a new report document path.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddReportDocumentPath( _
ByVal reportDocumentPath As String _
)
C#
public void AddReportDocumentPath(
string reportDocumentPath
)
C++
public:
void AddReportDocumentPath(
String reportDocumentPath
) sealed
J#
public void AddReportDocumentPath(
string reportDocumentPath
)
JScript
public function AddReportDocumentPath(
reportDocumentPath : String
)

Parameters

reportDocumentPath
The report document path

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportDocumentPath is null

See Also

TestLauncherResult Class
Gallio.Runner Namespace


GenerateReports Method

TestLauncherResult.GenerateReports Method
[image]

Generates reports of the desired forms.

This method adds the paths of the generated report documents to ReportDocumentPaths.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub GenerateReports( _
ByVal reportDirectory As String, _
ByVal reportName As String, _
ByVal reportFormats As IList(Of String), _
ByVal reportFormatOptions As ReportFormatterOptions, _
ByVal reportManager As IReportManager, _
ByVal progressMonitor As IProgressMonitor _
)
C#
public void GenerateReports(
string reportDirectory,
string reportName,
IList<string> reportFormats,
ReportFormatterOptions reportFormatOptions,
IReportManager reportManager,
IProgressMonitor progressMonitor
)
C++
public:
void GenerateReports(
String reportDirectory,
String reportName,
IList<string> reportFormats,
ReportFormatterOptions reportFormatOptions,
IReportManager reportManager,
IProgressMonitor progressMonitor
) sealed
J#
public void GenerateReports(
string reportDirectory,
string reportName,
IList<string> reportFormats,
ReportFormatterOptions reportFormatOptions,
IReportManager reportManager,
IProgressMonitor progressMonitor
)
JScript
public function GenerateReports(
reportDirectory : String,
reportName : String,
reportFormats : IList<string>,
reportFormatOptions : ReportFormatterOptions,
reportManager : IReportManager,
progressMonitor : IProgressMonitor
)

Parameters

reportDirectory
The report directory
reportName
The report name
reportFormats
The report formats to generate
reportFormatOptions
The report formatter options
reportManager
The report manager
progressMonitor
A progress monitor for the operation

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportDirectory, reportName, reportFormats, reportFormatOptions, reportManager, or progressMonitor is null.

See Also

TestLauncherResult Class
Gallio.Runner Namespace


SetResultCode Method

TestLauncherResult.SetResultCode Method
[image]

Sets the result code of the result.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetResultCode( _
ByVal value As Integer _
)
C#
public void SetResultCode(
int value
)
C++
public:
void SetResultCode(
int value
) sealed
J#
public void SetResultCode(
int value
)
JScript
public function SetResultCode(
value : int
)

Parameters

value
The new result code

See Also

TestLauncherResult Class
Gallio.Runner Namespace


ShowReportDocuments Method

TestLauncherResult.ShowReportDocuments Method
[image]

Shows the report documents enumerated in the launcher result.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ShowReportDocuments() As Boolean
C#
public bool ShowReportDocuments()
C++
public:
bool ShowReportDocuments() sealed
J#
public bool ShowReportDocuments()
JScript
public function ShowReportDocuments() : bool

Return Value

True if the report documents were successfully opened

See Also

TestLauncherResult Class
Gallio.Runner Namespace


TestRunnerOptions Class

TestRunnerOptions Class
See Also Example Members
[image]

Provides options that control the operation of the test runner. This class cannot be inherited.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class TestRunnerOptions
C#
[SerializableAttribute]
public sealed class TestRunnerOptions
C++
[SerializableAttribute]
ref class TestRunnerOptions sealed
J#
/** @attribute SerializableAttribute() */
public final class TestRunnerOptions
JScript
public
SerializableAttribute
final class TestRunnerOptions

Inheritance Hierarchy

System.Object
Gallio.Runner.TestRunnerOptions

See Also

TestRunnerOptions Members
Gallio.Runner Namespace


TestRunnerOptions Members

TestRunnerOptions Members
See Also Example Constructors Properties Methods
[image]

Provides options that control the operation of the test runner. This class cannot be inherited.

The following tables list the members exposed by TestRunnerOptions.

Public Constructors

 | Name | Description
Public method | TestRunnerOptions | Creates a default set of options.
Top

Public Properties

 | Name | Description
Public property | Properties | Gets a mutable collection of key/value pairs that specify configuration properties for the test runner.
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestRunnerOptions Class
Gallio.Runner Namespace


TestRunnerOptions Constructor

TestRunnerOptions Constructor
[image]

Creates a default set of options.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestRunnerOptions()
C++
public:
TestRunnerOptions() sealed
J#
public TestRunnerOptions()
JScript
public function TestRunnerOptions()

See Also

TestRunnerOptions Class
Gallio.Runner Namespace


Properties

TestRunnerOptions Properties
[image]

Public Properties

 | Name | Description
Public property | Properties | Gets a mutable collection of key/value pairs that specify configuration properties for the test runner.
Top

See Also

TestRunnerOptions Class
Gallio.Runner Namespace


Properties Property

TestRunnerOptions.Properties Property
[image]

Gets a mutable collection of key/value pairs that specify configuration properties for the test runner.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As PropertySet
C#
public PropertySet Properties { get; }
C++
public property PropertySet Properties sealed {
PropertySet get();
}
J#
/** property */
public PropertySet get_Properties();
JScript
public function get Properties() : PropertySet

See Also

TestRunnerOptions Class
Gallio.Runner Namespace


Methods

TestRunnerOptions Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestRunnerOptions Class
Gallio.Runner Namespace


Copy Method

TestRunnerOptions.Copy Method
[image]

Creates a copy of the options.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As TestRunnerOptions
C#
public TestRunnerOptions Copy()
C++
public:
TestRunnerOptions Copy() sealed
J#
public TestRunnerOptions Copy()
JScript
public function Copy() : TestRunnerOptions

Return Value

The copy

See Also

TestRunnerOptions Class
Gallio.Runner Namespace


TestRunnerUtils Class

TestRunnerUtils Class
See Also Example Members
[image]

Provides helper functions for test runner tools. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestRunnerUtils
C#
public static class TestRunnerUtils
C++
ref class TestRunnerUtils abstract sealed
J#
public final class TestRunnerUtils
JScript
public class TestRunnerUtils

Inheritance Hierarchy

System.Object
Gallio.Runner.TestRunnerUtils

See Also

TestRunnerUtils Members
Gallio.Runner Namespace


TestRunnerUtils Members

TestRunnerUtils Members
See Also Example Methods
[image]

Provides helper functions for test runner tools. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestRunnerUtils.

Public Methods

Name | Description
CreateTestRunnerByName | Creates a test runner given its factory name.
ShowReportDocument | Presents a generated report to the user using the default viewing application for the report's document type.
Top

See Also

TestRunnerUtils Class
Gallio.Runner Namespace


Methods

TestRunnerUtils Methods
[image]

Public Methods

Name | Description
CreateTestRunnerByName | Creates a test runner given its factory name.
ShowReportDocument | Presents a generated report to the user using the default viewing application for the report's document type.
Top

See Also

TestRunnerUtils Class
Gallio.Runner Namespace


CreateTestRunnerByName Method

TestRunnerUtils.CreateTestRunnerByName Method
[image]

Creates a test runner given its factory name.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateTestRunnerByName( _
ByVal factoryName As String _
) As ITestRunner
C#
public static ITestRunner CreateTestRunnerByName(
string factoryName
)
C++
public:
static ITestRunner CreateTestRunnerByName(
String factoryName
)
J#
public static ITestRunner CreateTestRunnerByName(
string factoryName
)
JScript
public static function CreateTestRunnerByName(
factoryName : String
) : ITestRunner

Parameters

factoryName
The test runner factory name

Return Value

The test runner

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if factoryName is null

See Also

TestRunnerUtils Class
Gallio.Runner Namespace


ShowReportDocument Method

TestRunnerUtils.ShowReportDocument Method
[image]

Presents a generated report to the user using the default viewing application for the report's document type.

Namespace: Gallio.Runner
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ShowReportDocument( _
ByVal reportDocumentPath As String _
) As Boolean
C#
public static bool ShowReportDocument(
string reportDocumentPath
)
C++
public:
static bool ShowReportDocument(
String reportDocumentPath
)
J#
public static bool ShowReportDocument(
string reportDocumentPath
)
JScript
public static function ShowReportDocument(
reportDocumentPath : String
) : bool

Parameters

reportDocumentPath
The path of the report

Return Value

True if the report document was successfully opened

See Also

TestRunnerUtils Class
Gallio.Runner Namespace


Gallio.Runner.Caching

Gallio.Runner.Caching Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | DiskCacheException | The type of exception thrown when an error occurs while manipulating the disk cache.
Public class | SimpleDiskCache | A simple disk cache that stores its contents in a particular directory using hashes of the key values to ensure uniqueness.
NestedFamily class | SimpleDiskCache.Group | Represents a disk cache group.
Public class | TemporaryDiskCache | A disk cache that stores its contents in the user's temporary directory.

Interfaces

 | Interface | Description
Public interface | IDiskCache | A disk cache manages temporary files and directories stored on disk and arranged into groups associated with arbitrary string keys. The files and directories within each group are assumed to have the same lifetime.
Public interface | IDiskCacheGroup | A disk cache group represents an indexed partition of the disk cache. It is physically manifested as a directory on disk and may contain any number of related files or directories with the same lifetime.
Public interface | IDiskCacheGroupCollection | Represents a collection of groups in a disk cache indexed by an aritrary key string.


DiskCacheException Class

DiskCacheException Class
See Also Example Members
[image]

The type of exception thrown when an error occurs while manipulating the disk cache.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class DiskCacheException
Inherits Exception
C#
[SerializableAttribute]
public class DiskCacheException : Exception
C++
[SerializableAttribute]
ref class DiskCacheException : Exception
J#
/** @attribute SerializableAttribute() */
public class DiskCacheException extends Exception
JScript
public
SerializableAttribute
class DiskCacheException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Runner.Caching.DiskCacheException

See Also

DiskCacheException Members
Gallio.Runner.Caching Namespace


DiskCacheException Members

DiskCacheException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when an error occurs while manipulating the disk cache.

The following tables list the members exposed by DiskCacheException.

Public Constructors

Name | Description
DiskCacheException | Overloaded. Initializes a new instance of the DiskCacheException class.
Top

Protected Constructors

Name | Description
DiskCacheException | Overloaded. Initializes a new instance of the DiskCacheException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DiskCacheException | Overloaded. Initializes a new instance of the DiskCacheException class.
Top

See Also

DiskCacheException Class
Gallio.Runner.Caching Namespace


DiskCacheException Constructor

DiskCacheException Constructor

Initializes a new instance of the DiskCacheException class.

Overload List

 | Name | Description
Public method | DiskCacheException | Creates an exception.
Family method | DiskCacheException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | DiskCacheException (String) | Creates an exception.
Public method | DiskCacheException (String, Exception) | Creates an exception.

See Also

DiskCacheException Class
Gallio.Runner.Caching Namespace


DiskCacheException Constructor ()

DiskCacheException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DiskCacheException()
C++
public:
DiskCacheException() sealed
J#
public DiskCacheException()
JScript
public function DiskCacheException()

See Also

DiskCacheException Class
Gallio.Runner.Caching Namespace
DiskCacheException Constructor Overload List


DiskCacheException Constructor (SerializationInfo, StreamingContext)

DiskCacheException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected DiskCacheException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
DiskCacheException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected DiskCacheException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function DiskCacheException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

DiskCacheException Class
Gallio.Runner.Caching Namespace
DiskCacheException Constructor Overload List


DiskCacheException Constructor (String)

DiskCacheException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public DiskCacheException(
string message
)
C++
public:
DiskCacheException(
String message
) sealed
J#
public DiskCacheException(
string message
)
JScript
public function DiskCacheException(
message : String
)

Parameters

message
The message

See Also

DiskCacheException Class
Gallio.Runner.Caching Namespace
DiskCacheException Constructor Overload List


DiskCacheException Constructor (String, Exception)

DiskCacheException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public DiskCacheException(
string message,
Exception innerException
)
C++
public:
DiskCacheException(
String message,
Exception innerException
) sealed
J#
public DiskCacheException(
string message,
Exception innerException
)
JScript
public function DiskCacheException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

DiskCacheException Class
Gallio.Runner.Caching Namespace
DiskCacheException Constructor Overload List


IDiskCache Interface

IDiskCache Interface
See Also Example Members
[image]

A disk cache manages temporary files and directories stored on disk and arranged into groups associated with arbitrary string keys. The files and directories within each group are assumed to have the same lifetime.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDiskCache
C#
public interface IDiskCache
C++
interface class IDiskCache
J#
public interface IDiskCache
JScript
public interface IDiskCache

Types that implement IDiskCache

Type | Description
Gallio.Runner.Caching.SimpleDiskCache | A simple disk cache that stores its contents in a particular directory using hashes of the key values to ensure uniqueness.

Example

Write a file to the cache:

Copy Code
            IDiskCache cache = ... get the cache ..;
            using (StreamWriter writer = new StreamWriter(cache.Groups["SomeKey"].OpenFile("Foo",
                FileMode.OpenOrCreate, FileAccess.Write, FileShare.Exclusive)))
            {
                writer.WriteLine("Contents...");
            }

See Also

IDiskCache Members
Gallio.Runner.Caching Namespace


IDiskCache Members

IDiskCache Members
See Also Example Properties Methods
[image]

A disk cache manages temporary files and directories stored on disk and arranged into groups associated with arbitrary string keys. The files and directories within each group are assumed to have the same lifetime.

The following tables list the members exposed by IDiskCache.

Public Properties

 | Name | Description
Public property | Groups | Gets the collection of disk cache groups.
Top

Public Methods

 | Name | Description
Public method | Purge | Deletes all items in the cache.
Top

See Also

IDiskCache Interface
Gallio.Runner.Caching Namespace


Properties

IDiskCache Properties
[image]

Public Properties

 | Name | Description
Public property | Groups | Gets the collection of disk cache groups.
Top

See Also

IDiskCache Interface
Gallio.Runner.Caching Namespace


Groups Property

IDiskCache.Groups Property
[image]

Gets the collection of disk cache groups.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Groups As IDiskCacheGroupCollection
C#
IDiskCacheGroupCollection Groups { get; }
C++
property IDiskCacheGroupCollection Groups abstract {
IDiskCacheGroupCollection get();
}
J#
/** property */
public IDiskCacheGroupCollection get_Groups();
JScript
public function get Groups() : IDiskCacheGroupCollection

See Also

IDiskCache Interface
Gallio.Runner.Caching Namespace


Methods

IDiskCache Methods
[image]

Public Methods

 | Name | Description
Public method | Purge | Deletes all items in the cache.
Top

See Also

IDiskCache Interface
Gallio.Runner.Caching Namespace


Purge Method

IDiskCache.Purge Method
[image]

Deletes all items in the cache.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Purge()
C#
void Purge()
C++
void Purge() abstract
J#
void Purge()
JScript
function Purge()

Exceptions

Exception Type | Condition
DiskCacheException | Thrown if an error occurs.

See Also

IDiskCache Interface
Gallio.Runner.Caching Namespace


IDiskCacheGroup Interface

IDiskCacheGroup Interface
See Also Example Members
[image]

A disk cache group represents an indexed partition of the disk cache. It is physically manifested as a directory on disk and may contain any number of related files or directories with the same lifetime.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDiskCacheGroup
C#
public interface IDiskCacheGroup
C++
interface class IDiskCacheGroup
J#
public interface IDiskCacheGroup
JScript
public interface IDiskCacheGroup

Types that implement IDiskCacheGroup

Type | Description
Gallio.Runner.Caching.SimpleDiskCache.Group | Represents a disk cache group.

See Also

IDiskCacheGroup Members
Gallio.Runner.Caching Namespace


IDiskCacheGroup Members

IDiskCacheGroup Members
See Also Example Properties Methods
[image]

A disk cache group represents an indexed partition of the disk cache. It is physically manifested as a directory on disk and may contain any number of related files or directories with the same lifetime.

The following tables list the members exposed by IDiskCacheGroup.

Public Properties

 | Name | Description
Public property | Cache | Gets the disk cache that contains the group.
Public property | Exists | Returns true if the group exists on disk.
Public property | Key | Gets the key of the group.
Public property | Location | Gets the DirectoryInfo that represents the physical storage location of the disk cache group in the filesystem.
Top

Public Methods

 | Name | Description
Public method | Create | Creates the group if it does not exist.
Public method | CreateSubdirectory | Creates a directory within the group.
Public method | Delete | Deletes the group and all of its contents if any.
Public method | GetFileInfo | Gets information about a file within the group.
Public method | GetSubdirectoryInfo | Gets information about a directory within the group.
Public method | OpenFile | Opens a file within the group. If a new file is being created, automatically create the group and the containing directory for the file.
Top

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Properties

IDiskCacheGroup Properties
[image]

Public Properties

 | Name | Description
Public property | Cache | Gets the disk cache that contains the group.
Public property | Exists | Returns true if the group exists on disk.
Public property | Key | Gets the key of the group.
Public property | Location | Gets the DirectoryInfo that represents the physical storage location of the disk cache group in the filesystem.
Top

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Cache Property

IDiskCacheGroup.Cache Property
[image]

Gets the disk cache that contains the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Cache As IDiskCache
C#
IDiskCache Cache { get; }
C++
property IDiskCache Cache abstract {
IDiskCache get();
}
J#
/** property */
public IDiskCache get_Cache();
JScript
public function get Cache() : IDiskCache

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Exists Property

IDiskCacheGroup.Exists Property
[image]

Returns true if the group exists on disk.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Exists As Boolean
C#
bool Exists { get; }
C++
property bool Exists abstract {
bool get();
}
J#
/** property */
public bool get_Exists();
JScript
public function get Exists() : bool

Exceptions

Exception Type | Condition
DiskCacheException | Thrown if an error occurs.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Key Property

IDiskCacheGroup.Key Property
[image]

Gets the key of the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Key As String
C#
string Key { get; }
C++
property string Key abstract {
String get();
}
J#
/** property */
public string get_Key();
JScript
public function get Key() : String

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Location Property

IDiskCacheGroup.Location Property
[image]

Gets the DirectoryInfo that represents the physical storage location of the disk cache group in the filesystem.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Location As DirectoryInfo
C#
DirectoryInfo Location { get; }
C++
property DirectoryInfo Location abstract {
DirectoryInfo get();
}
J#
/** property */
public DirectoryInfo get_Location();
JScript
public function get Location() : DirectoryInfo

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Methods

IDiskCacheGroup Methods
[image]

Public Methods

 | Name | Description
Public method | Create | Creates the group if it does not exist.
Public method | CreateSubdirectory | Creates a directory within the group.
Public method | Delete | Deletes the group and all of its contents if any.
Public method | GetFileInfo | Gets information about a file within the group.
Public method | GetSubdirectoryInfo | Gets information about a directory within the group.
Public method | OpenFile | Opens a file within the group. If a new file is being created, automatically create the group and the containing directory for the file.
Top

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Create Method

IDiskCacheGroup.Create Method
[image]

Creates the group if it does not exist.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Create()
C#
void Create()
C++
void Create() abstract
J#
void Create()
JScript
function Create()

Exceptions

Exception Type | Condition
DiskCacheException | Thrown if an error occurs.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


CreateSubdirectory Method

IDiskCacheGroup.CreateSubdirectory Method
[image]

Creates a directory within the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateSubdirectory( _
ByVal relativeDirectoryPath As String _
) As DirectoryInfo
C#
DirectoryInfo CreateSubdirectory(
string relativeDirectoryPath
)
C++
DirectoryInfo CreateSubdirectory(
String relativeDirectoryPath
) abstract
J#
DirectoryInfo CreateSubdirectory(
string relativeDirectoryPath
)
JScript
function CreateSubdirectory(
relativeDirectoryPath : String
) : DirectoryInfo

Parameters

relativeDirectoryPath
The relative path of the directory to create within the group

Return Value

Directory information for the directory that was created

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if relativeDirectoryPath is null
DiskCacheException | Thrown if an error occurs.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


Delete Method

IDiskCacheGroup.Delete Method
[image]

Deletes the group and all of its contents if any.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Delete()
C#
void Delete()
C++
void Delete() abstract
J#
void Delete()
JScript
function Delete()

Exceptions

Exception Type | Condition
DiskCacheException | Thrown if an error occurs.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


GetFileInfo Method

IDiskCacheGroup.GetFileInfo Method
[image]

Gets information about a file within the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetFileInfo( _
ByVal relativeFilePath As String _
) As FileInfo
C#
FileInfo GetFileInfo(
string relativeFilePath
)
C++
FileInfo GetFileInfo(
String relativeFilePath
) abstract
J#
FileInfo GetFileInfo(
string relativeFilePath
)
JScript
function GetFileInfo(
relativeFilePath : String
) : FileInfo

Parameters

relativeFilePath
The relative path of the file within the group

Return Value

The file info

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if relativeFilePath is null
DiskCacheException | Thrown if an error occurs.

Remarks

This method will succeed even if the file or the group does not exist.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


GetSubdirectoryInfo Method

IDiskCacheGroup.GetSubdirectoryInfo Method
[image]

Gets information about a directory within the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetSubdirectoryInfo( _
ByVal relativeDirectoryPath As String _
) As DirectoryInfo
C#
DirectoryInfo GetSubdirectoryInfo(
string relativeDirectoryPath
)
C++
DirectoryInfo GetSubdirectoryInfo(
String relativeDirectoryPath
) abstract
J#
DirectoryInfo GetSubdirectoryInfo(
string relativeDirectoryPath
)
JScript
function GetSubdirectoryInfo(
relativeDirectoryPath : String
) : DirectoryInfo

Parameters

relativeDirectoryPath
The relative path of the directory within the group

Return Value

The directory info

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if relativeDirectoryPath is null
DiskCacheException | Thrown if an error occurs.

Remarks

This method will succeed even if the directory or the group does not exist.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


OpenFile Method

IDiskCacheGroup.OpenFile Method
[image]

Opens a file within the group.

If a new file is being created, automatically create the group and the containing directory for the file.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function OpenFile( _
ByVal relativeFilePath As String, _
ByVal mode As FileMode, _
ByVal access As FileAccess, _
ByVal share As FileShare _
) As Stream
C#
Stream OpenFile(
string relativeFilePath,
FileMode mode,
FileAccess access,
FileShare share
)
C++
Stream OpenFile(
String relativeFilePath,
FileMode mode,
FileAccess access,
FileShare share
) abstract
J#
Stream OpenFile(
string relativeFilePath,
FileMode mode,
FileAccess access,
FileShare share
)
JScript
function OpenFile(
relativeFilePath : String,
mode : FileMode,
access : FileAccess,
share : FileShare
) : Stream

Parameters

relativeFilePath
The relative path of the file to open within the group
mode
The file open mode
access
The file access mode
share
The file sharing mode

Return Value

The file stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if relativeFilePath is null
DiskCacheException | Thrown if an error occurs.

See Also

IDiskCacheGroup Interface
Gallio.Runner.Caching Namespace


IDiskCacheGroupCollection Interface

IDiskCacheGroupCollection Interface
See Also Example Members
[image]

Represents a collection of groups in a disk cache indexed by an aritrary key string.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface IDiskCacheGroupCollection
C#
[DefaultMemberAttribute("Item")]
public interface IDiskCacheGroupCollection
C++
[DefaultMemberAttribute(L"Item")]
interface class IDiskCacheGroupCollection
J#
/** @attribute DefaultMemberAttribute("Item") */
public interface IDiskCacheGroupCollection
JScript
public
DefaultMemberAttribute("Item")
interface IDiskCacheGroupCollection

Types that implement IDiskCacheGroupCollection

Type | Description
Gallio.Runner.Caching.SimpleDiskCache | A simple disk cache that stores its contents in a particular directory using hashes of the key values to ensure uniqueness.

See Also

IDiskCacheGroupCollection Members
Gallio.Runner.Caching Namespace


IDiskCacheGroupCollection Members

IDiskCacheGroupCollection Members
See Also Example Properties
[image]

Represents a collection of groups in a disk cache indexed by an aritrary key string.

The following tables list the members exposed by IDiskCacheGroupCollection.

Public Properties

 | Name | Description
Public property | Item | Gets the group with the specified key.
Top

See Also

IDiskCacheGroupCollection Interface
Gallio.Runner.Caching Namespace


Properties

IDiskCacheGroupCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Item | Gets the group with the specified key.
Top

See Also

IDiskCacheGroupCollection Interface
Gallio.Runner.Caching Namespace


Item Property

IDiskCacheGroupCollection.Item Property
[image]

Gets the group with the specified key.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Default ReadOnly Property Item( _
ByVal key As String _
) As IDiskCacheGroup
C#
IDiskCacheGroup this[
string key
] { get; }
C++
property IDiskCacheGroup default[String key] abstract {
IDiskCacheGroup get(String key);
}
J#
/** property */
public IDiskCacheGroup get_Item(string key);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

Parameters

key
The key

Property Value

The group

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if key is null

See Also

IDiskCacheGroupCollection Interface
Gallio.Runner.Caching Namespace


SimpleDiskCache Class

SimpleDiskCache Class
See Also Example Members
[image]

A simple disk cache that stores its contents in a particular directory using hashes of the key values to ensure uniqueness.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class SimpleDiskCache
Implements IDiskCache, IDiskCacheGroupCollection
C#
public class SimpleDiskCache : IDiskCache, IDiskCacheGroupCollection
C++
ref class SimpleDiskCache : IDiskCache, IDiskCacheGroupCollection
J#
public class SimpleDiskCache implements IDiskCache, IDiskCacheGroupCollection
JScript
public class SimpleDiskCache extends IDiskCache, IDiskCacheGroupCollection

Inheritance Hierarchy

System.Object
Gallio.Runner.Caching.SimpleDiskCache
Gallio.Runner.Caching.TemporaryDiskCache

See Also

SimpleDiskCache Members
Gallio.Runner.Caching Namespace


SimpleDiskCache Members

SimpleDiskCache Members
See Also Example Constructors Properties Methods
[image]

A simple disk cache that stores its contents in a particular directory using hashes of the key values to ensure uniqueness.

The following tables list the members exposed by SimpleDiskCache.

Public Constructors

 | Name | Description
Public method | SimpleDiskCache | Creates a simple disk cache.
Top

Public Properties

 | Name | Description
Public property | CacheDirectoryPath | Gets the path of the cache directory.
Public property | Groups | Gets the collection of disk cache groups.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Purge | Deletes all items in the cache.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetGroup | Gets the group with the given key.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


SimpleDiskCache Constructor

SimpleDiskCache Constructor
[image]

Creates a simple disk cache.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal cacheDirectoryPath As String _
)
C#
public SimpleDiskCache(
string cacheDirectoryPath
)
C++
public:
SimpleDiskCache(
String cacheDirectoryPath
) sealed
J#
public SimpleDiskCache(
string cacheDirectoryPath
)
JScript
public function SimpleDiskCache(
cacheDirectoryPath : String
)

Parameters

cacheDirectoryPath
The path of the cache directory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if cacheDirectoryPath is null

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


Properties

SimpleDiskCache Properties
[image]

Public Properties

 | Name | Description
Public property | CacheDirectoryPath | Gets the path of the cache directory.
Public property | Groups | Gets the collection of disk cache groups.
Top

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


CacheDirectoryPath Property

SimpleDiskCache.CacheDirectoryPath Property
[image]

Gets the path of the cache directory.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CacheDirectoryPath As String
C#
public string CacheDirectoryPath { get; }
C++
public property string CacheDirectoryPath sealed {
String get();
}
J#
/** property */
public string get_CacheDirectoryPath();
JScript
public function get CacheDirectoryPath() : String

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


Groups Property

SimpleDiskCache.Groups Property
[image]

Gets the collection of disk cache groups.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Groups As IDiskCacheGroupCollection _
Implements IDiskCache.Groups
C#
public IDiskCacheGroupCollection Groups { get; }
C++
public property IDiskCacheGroupCollection Groups sealed {
IDiskCacheGroupCollection get();
}
J#
/** property */
public IDiskCacheGroupCollection get_Groups();
JScript
public function get Groups() : IDiskCacheGroupCollection

Implements

IDiskCache.Groups

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


Methods

SimpleDiskCache Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Purge | Deletes all items in the cache.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetGroup | Gets the group with the given key.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


GetGroup Method

SimpleDiskCache.GetGroup Method
[image]

Gets the group with the given key.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetGroup( _
ByVal key As String _
) As IDiskCacheGroup
C#
protected virtual IDiskCacheGroup GetGroup(
string key
)
C++
protected:
virtual IDiskCacheGroup GetGroup(
String key
)
J#
protected virtual IDiskCacheGroup GetGroup(
string key
)
JScript
protected virtual function GetGroup(
key : String
) : IDiskCacheGroup

Parameters

key
The key, nor null

Return Value

The cache group

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


Purge Method

SimpleDiskCache.Purge Method
[image]

Deletes all items in the cache.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Purge() _
Implements IDiskCache.Purge
C#
public void Purge()
C++
public:
void Purge() sealed
J#
public void Purge()
JScript
public function Purge()

Implements

IDiskCache.Purge

See Also

SimpleDiskCache Class
Gallio.Runner.Caching Namespace


SimpleDiskCache.Group Class

SimpleDiskCache.Group Class
See Also Example Members
[image]

Represents a disk cache group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Class SimpleDiskCache.Group
Implements IDiskCacheGroup
C#
protected class SimpleDiskCache.Group : IDiskCacheGroup
C++
ref class SimpleDiskCache.Group : IDiskCacheGroup
J#
protected class SimpleDiskCache.Group implements IDiskCacheGroup
JScript
protected class SimpleDiskCache.Group extends IDiskCacheGroup

Inheritance Hierarchy

System.Object
Gallio.Runner.Caching.SimpleDiskCache.Group

See Also

SimpleDiskCache.Group Members
Gallio.Runner.Caching Namespace


SimpleDiskCache.Group Members

SimpleDiskCache.Group Members
See Also Example Constructors Properties Methods
[image]

Represents a disk cache group.

The following tables list the members exposed by SimpleDiskCache.Group.

Public Constructors

 | Name | Description
Public method | SimpleDiskCache.Group | Creates a group.
Top

Public Properties

 | Name | Description
Public property | Cache | Gets the disk cache that contains the group.
Public property | Exists | Returns true if the group exists on disk.
Public property | Key | Gets the key of the group.
Public property | Location | Gets the DirectoryInfo that represents the physical storage location of the disk cache group in the filesystem.
Top

Public Methods

 | Name | Description
Public method | Create | Creates the group if it does not exist.
Public method | CreateSubdirectory | Creates a directory within the group.
Public method | Delete | Deletes the group and all of its contents if any.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFileInfo | Gets information about a file within the group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetSubdirectoryInfo | Gets information about a directory within the group.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | OpenFile | Opens a file within the group. If a new file is being created, automatically create the group and the containing directory for the file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


SimpleDiskCache.Group Constructor

SimpleDiskCache.Group Constructor
[image]

Creates a group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal cache As IDiskCache, _
ByVal key As String, _
ByVal location As DirectoryInfo _
)
C#
public SimpleDiskCache.Group(
IDiskCache cache,
string key,
DirectoryInfo location
)
C++
public:
SimpleDiskCache.Group(
IDiskCache cache,
String key,
DirectoryInfo location
) sealed
J#
public SimpleDiskCache.Group(
IDiskCache cache,
string key,
DirectoryInfo location
)
JScript
public function SimpleDiskCache.Group(
cache : IDiskCache,
key : String,
location : DirectoryInfo
)

Parameters

cache
The cache
key
The cache group key
location
The location of the cache group

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if cache, key or location is null

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Properties

SimpleDiskCache.Group Properties
[image]

Public Properties

 | Name | Description
Public property | Cache | Gets the disk cache that contains the group.
Public property | Exists | Returns true if the group exists on disk.
Public property | Key | Gets the key of the group.
Public property | Location | Gets the DirectoryInfo that represents the physical storage location of the disk cache group in the filesystem.
Top

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Cache Property

SimpleDiskCache.Group.Cache Property
[image]

Gets the disk cache that contains the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cache As IDiskCache _
Implements IDiskCacheGroup.Cache
C#
public IDiskCache Cache { get; }
C++
public property IDiskCache Cache sealed {
IDiskCache get();
}
J#
/** property */
public IDiskCache get_Cache();
JScript
public function get Cache() : IDiskCache

Implements

IDiskCacheGroup.Cache

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Exists Property

SimpleDiskCache.Group.Exists Property
[image]

Returns true if the group exists on disk.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exists As Boolean _
Implements IDiskCacheGroup.Exists
C#
public bool Exists { get; }
C++
public property bool Exists sealed {
bool get();
}
J#
/** property */
public bool get_Exists();
JScript
public function get Exists() : bool

Implements

IDiskCacheGroup.Exists

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Key Property

SimpleDiskCache.Group.Key Property
[image]

Gets the key of the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Key As String _
Implements IDiskCacheGroup.Key
C#
public string Key { get; }
C++
public property string Key sealed {
String get();
}
J#
/** property */
public string get_Key();
JScript
public function get Key() : String

Implements

IDiskCacheGroup.Key

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Location Property

SimpleDiskCache.Group.Location Property
[image]

Gets the DirectoryInfo that represents the physical storage location of the disk cache group in the filesystem.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As DirectoryInfo _
Implements IDiskCacheGroup.Location
C#
public DirectoryInfo Location { get; }
C++
public property DirectoryInfo Location sealed {
DirectoryInfo get();
}
J#
/** property */
public DirectoryInfo get_Location();
JScript
public function get Location() : DirectoryInfo

Implements

IDiskCacheGroup.Location

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Methods

SimpleDiskCache.Group Methods
[image]

Public Methods

 | Name | Description
Public method | Create | Creates the group if it does not exist.
Public method | CreateSubdirectory | Creates a directory within the group.
Public method | Delete | Deletes the group and all of its contents if any.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFileInfo | Gets information about a file within the group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetSubdirectoryInfo | Gets information about a directory within the group.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | OpenFile | Opens a file within the group. If a new file is being created, automatically create the group and the containing directory for the file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Create Method

SimpleDiskCache.Group.Create Method
[image]

Creates the group if it does not exist.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Create() _
Implements IDiskCacheGroup.Create
C#
public void Create()
C++
public:
void Create() sealed
J#
public void Create()
JScript
public function Create()

Implements

IDiskCacheGroup.Create

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


CreateSubdirectory Method

SimpleDiskCache.Group.CreateSubdirectory Method
[image]

Creates a directory within the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSubdirectory( _
ByVal relativeDirectoryPath As String _
) As DirectoryInfo _
Implements IDiskCacheGroup.CreateSubdirectory
C#
public DirectoryInfo CreateSubdirectory(
string relativeDirectoryPath
)
C++
public:
DirectoryInfo CreateSubdirectory(
String relativeDirectoryPath
) sealed
J#
public DirectoryInfo CreateSubdirectory(
string relativeDirectoryPath
)
JScript
public function CreateSubdirectory(
relativeDirectoryPath : String
) : DirectoryInfo

Parameters

relativeDirectoryPath
The relative path of the directory to create within the group

Return Value

Directory information for the directory that was created

Implements

IDiskCacheGroup.CreateSubdirectory

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


Delete Method

SimpleDiskCache.Group.Delete Method
[image]

Deletes the group and all of its contents if any.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Delete() _
Implements IDiskCacheGroup.Delete
C#
public void Delete()
C++
public:
void Delete() sealed
J#
public void Delete()
JScript
public function Delete()

Implements

IDiskCacheGroup.Delete

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


GetFileInfo Method

SimpleDiskCache.Group.GetFileInfo Method
[image]

Gets information about a file within the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFileInfo( _
ByVal relativeFilePath As String _
) As FileInfo _
Implements IDiskCacheGroup.GetFileInfo
C#
public FileInfo GetFileInfo(
string relativeFilePath
)
C++
public:
FileInfo GetFileInfo(
String relativeFilePath
) sealed
J#
public FileInfo GetFileInfo(
string relativeFilePath
)
JScript
public function GetFileInfo(
relativeFilePath : String
) : FileInfo

Parameters

relativeFilePath
The relative path of the file within the group

Return Value

The file info

Implements

IDiskCacheGroup.GetFileInfo

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


GetSubdirectoryInfo Method

SimpleDiskCache.Group.GetSubdirectoryInfo Method
[image]

Gets information about a directory within the group.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSubdirectoryInfo( _
ByVal relativeDirectoryPath As String _
) As DirectoryInfo _
Implements IDiskCacheGroup.GetSubdirectoryInfo
C#
public DirectoryInfo GetSubdirectoryInfo(
string relativeDirectoryPath
)
C++
public:
DirectoryInfo GetSubdirectoryInfo(
String relativeDirectoryPath
) sealed
J#
public DirectoryInfo GetSubdirectoryInfo(
string relativeDirectoryPath
)
JScript
public function GetSubdirectoryInfo(
relativeDirectoryPath : String
) : DirectoryInfo

Parameters

relativeDirectoryPath
The relative path of the directory within the group

Return Value

The directory info

Implements

IDiskCacheGroup.GetSubdirectoryInfo

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


OpenFile Method

SimpleDiskCache.Group.OpenFile Method
[image]

Opens a file within the group.

If a new file is being created, automatically create the group and the containing directory for the file.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenFile( _
ByVal relativeFilePath As String, _
ByVal mode As FileMode, _
ByVal access As FileAccess, _
ByVal share As FileShare _
) As Stream _
Implements IDiskCacheGroup.OpenFile
C#
public Stream OpenFile(
string relativeFilePath,
FileMode mode,
FileAccess access,
FileShare share
)
C++
public:
Stream OpenFile(
String relativeFilePath,
FileMode mode,
FileAccess access,
FileShare share
) sealed
J#
public Stream OpenFile(
string relativeFilePath,
FileMode mode,
FileAccess access,
FileShare share
)
JScript
public function OpenFile(
relativeFilePath : String,
mode : FileMode,
access : FileAccess,
share : FileShare
) : Stream

Parameters

relativeFilePath
The relative path of the file to open within the group
mode
The file open mode
access
The file access mode
share
The file sharing mode

Return Value

The file stream

Implements

IDiskCacheGroup.OpenFile

See Also

SimpleDiskCache.Group Class
Gallio.Runner.Caching Namespace


TemporaryDiskCache Class

TemporaryDiskCache Class
See Also Example Members
[image]

A disk cache that stores its contents in the user's temporary directory.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TemporaryDiskCache
Inherits SimpleDiskCache
C#
public class TemporaryDiskCache : SimpleDiskCache
C++
ref class TemporaryDiskCache : SimpleDiskCache
J#
public class TemporaryDiskCache extends SimpleDiskCache
JScript
public class TemporaryDiskCache extends SimpleDiskCache

Inheritance Hierarchy

System.Object
Gallio.Runner.Caching.SimpleDiskCache
Gallio.Runner.Caching.TemporaryDiskCache

See Also

TemporaryDiskCache Members
Gallio.Runner.Caching Namespace
GetTempPath


TemporaryDiskCache Members

TemporaryDiskCache Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

A disk cache that stores its contents in the user's temporary directory.

The following tables list the members exposed by TemporaryDiskCache.

Public Constructors

Name | Description
TemporaryDiskCache | Overloaded.
Top

Public Fields

Name | Description
DefaultCacheDirectoryName | The default cache directory name. This field is read-only.
Top

Public Properties

 | Name | Description
Public property | CacheDirectoryPath | Gets the path of the cache directory. (inherited from SimpleDiskCache)
Public property | Groups | Gets the collection of disk cache groups. (inherited from SimpleDiskCache)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Purge | Deletes all items in the cache. (inherited from SimpleDiskCache)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetGroup | Gets the group with the given key. (inherited from SimpleDiskCache)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TemporaryDiskCache | Overloaded.
Top

See Also

TemporaryDiskCache Class
Gallio.Runner.Caching Namespace
GetTempPath


TemporaryDiskCache Constructor

TemporaryDiskCache Constructor

Overload List

 | Name | Description
Public method | TemporaryDiskCache | Creates a temporary disk cache within the DefaultCacheDirectoryName subdirectory of the user's temporary directory.
Public method | TemporaryDiskCache (String) | Creates a temporary disk cache within the specified subdirectory of the user's temporary directory.

See Also

TemporaryDiskCache Class
Gallio.Runner.Caching Namespace


TemporaryDiskCache Constructor ()

TemporaryDiskCache Constructor ()
See Also Example
[image]

Creates a temporary disk cache within the DefaultCacheDirectoryName subdirectory of the user's temporary directory.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TemporaryDiskCache()
C++
public:
TemporaryDiskCache() sealed
J#
public TemporaryDiskCache()
JScript
public function TemporaryDiskCache()

See Also

TemporaryDiskCache Class
Gallio.Runner.Caching Namespace
TemporaryDiskCache Constructor Overload List


TemporaryDiskCache Constructor (String)

TemporaryDiskCache Constructor (String)
See Also Example
[image]

Creates a temporary disk cache within the specified subdirectory of the user's temporary directory.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal cacheDirectoryName As String _
)
C#
public TemporaryDiskCache(
string cacheDirectoryName
)
C++
public:
TemporaryDiskCache(
String cacheDirectoryName
) sealed
J#
public TemporaryDiskCache(
string cacheDirectoryName
)
JScript
public function TemporaryDiskCache(
cacheDirectoryName : String
)

Parameters

cacheDirectoryName
The name of the cache subdirectory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if cacheDirectoryName is null

See Also

TemporaryDiskCache Class
Gallio.Runner.Caching Namespace
TemporaryDiskCache Constructor Overload List


Fields

TemporaryDiskCache Fields
[image]

Public Fields

Name | Description
DefaultCacheDirectoryName | The default cache directory name. This field is read-only.
Top

See Also

TemporaryDiskCache Class
Gallio.Runner.Caching Namespace
GetTempPath


DefaultCacheDirectoryName Field

TemporaryDiskCache.DefaultCacheDirectoryName Field
[image]

The default cache directory name. This field is read-only.

Namespace: Gallio.Runner.Caching
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultCacheDirectoryName As String
C#
public static readonly string DefaultCacheDirectoryName;
C++
public:
static const String DefaultCacheDirectoryName;
J#
public static final string DefaultCacheDirectoryName
JScript
public static const var DefaultCacheDirectoryName : String;

See Also

TemporaryDiskCache Class
Gallio.Runner.Caching Namespace


Gallio.Runner.Drivers

Gallio.Runner.Drivers Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AggregateTestDriver | An aggregate test driver partitions the work of running tests among multiple test drivers. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseTestDriver | Base implementation of a test driver. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | HostedTestDriver | A test driver that runs tests remotely within a remote host. The driver further partitions assemblies into test domains based on their configuration requirements.
Public class | HostedTestDriverFactory | Creates hosted test driver instances.
Public class | LocalTestDriver | A simple test driver implementation that runs tests locally within the current domain without any additional consultation of the test frameworks.
Public class | RemoteTestDriver | A proxy for a remote test driver. Wraps a test driver and forwards all messages to it.

Interfaces

 | Interface | Description
Public interface | ITestDriver | A test driver controls how tests are loaded, explored, and run.
Public interface | ITestDriverFactory | Creates test drivers.

Structures

 | Structure | Description
NestedFamily structure | AggregateTestDriver.Partition | Provides information about a partition of the aggregate test driver. Each partition specifies a test driver and a test package configuration that covers a portion of the total test package.


AggregateTestDriver Class

AggregateTestDriver Class
See Also Example Members
[image]

An aggregate test driver partitions the work of running tests among multiple test drivers. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class AggregateTestDriver
Inherits BaseTestDriver
C#
public abstract class AggregateTestDriver : BaseTestDriver
C++
ref class AggregateTestDriver abstract : BaseTestDriver
J#
public class AggregateTestDriver extends BaseTestDriver
JScript
public class AggregateTestDriver extends BaseTestDriver

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runner.Drivers.BaseTestDriver
Gallio.Runner.Drivers.AggregateTestDriver
Gallio.Runner.Drivers.HostedTestDriver

See Also

AggregateTestDriver Members
Gallio.Runner.Drivers Namespace


AggregateTestDriver Members

AggregateTestDriver Members
See Also Example Constructors Properties Methods
[image]

An aggregate test driver partitions the work of running tests among multiple test drivers. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AggregateTestDriver.

Protected Constructors

 | Name | Description
Family method | AggregateTestDriver | Initializes an aggregate test driver.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or a null logger instance if not initialized. (inherited from BaseTestDriver)
Family property | RuntimeSetup | Gets the runtime setup, or null if not initialized. (inherited from BaseTestDriver)
Family property | TestRunnerOptions | Gets the test runner options, or null if not initialized. (inherited from BaseTestDriver)
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Family method | DoWithPartitions | Runs a block of code with partitions of the test package.
Family method | ExploreImpl | Overridden. Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Internal implementation of Initialize. Called after argument validation takes place. (inherited from BaseTestDriver)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Overridden. Internal implementation of Run. Called after argument validation takes place.
Top

See Also

AggregateTestDriver Class
Gallio.Runner.Drivers Namespace


AggregateTestDriver Constructor

AggregateTestDriver Constructor
[image]

Initializes an aggregate test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected AggregateTestDriver()
C++
protected:
AggregateTestDriver() sealed
J#
protected AggregateTestDriver()
JScript
protected function AggregateTestDriver()

See Also

AggregateTestDriver Class
Gallio.Runner.Drivers Namespace


Methods

AggregateTestDriver Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Family method | DoWithPartitions | Runs a block of code with partitions of the test package.
Family method | ExploreImpl | Overridden. Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Internal implementation of Initialize. Called after argument validation takes place. (inherited from BaseTestDriver)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Overridden. Internal implementation of Run. Called after argument validation takes place.
Top

See Also

AggregateTestDriver Class
Gallio.Runner.Drivers Namespace


DoWithPartitions Method

AggregateTestDriver.DoWithPartitions Method
[image]

Runs a block of code with partitions of the test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub DoWithPartitions( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal action As Action(Of IList(Of Partition)), _
ByVal setStatus As Action(Of String) _
)
C#
protected abstract void DoWithPartitions(
TestPackageConfig testPackageConfig,
Action<IList<Partition>> action,
Action<string> setStatus
)
C++
protected:
void DoWithPartitions(
TestPackageConfig testPackageConfig,
Action<IList<Partition>> action,
Action<string> setStatus
) abstract
J#
protected abstract void DoWithPartitions(
TestPackageConfig testPackageConfig,
Action<IList<Partition>> action,
Action<string> setStatus
)
JScript
protected abstract function DoWithPartitions(
testPackageConfig : TestPackageConfig,
action : Action<IList<Partition>>,
setStatus : Action<string>
)

Parameters

testPackageConfig
The test package configuration, not null
action
The action to perform given a list of partitions, not null
setStatus
An action that can be used to report progress, not null

Remarks

The subclass should perform any setup / teardown around the callback.

See Also

AggregateTestDriver Class
Gallio.Runner.Drivers Namespace


ExploreImpl Method

AggregateTestDriver.ExploreImpl Method
[image]

Internal implementation of Explore. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ExploreImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected override void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
protected:
virtual void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) override
J#
protected override void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
protected override function ExploreImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

See Also

AggregateTestDriver Class
Gallio.Runner.Drivers Namespace


RunImpl Method

AggregateTestDriver.RunImpl Method
[image]

Internal implementation of Run. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RunImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected override void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
protected:
virtual void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) override
J#
protected override void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
protected override function RunImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

See Also

AggregateTestDriver Class
Gallio.Runner.Drivers Namespace


AggregateTestDriver.Partition Structure

AggregateTestDriver.Partition Structure
See Also Example Members
[image]

Provides information about a partition of the aggregate test driver. Each partition specifies a test driver and a test package configuration that covers a portion of the total test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Structure AggregateTestDriver.Partition
C#
protected struct AggregateTestDriver.Partition
C++
value class AggregateTestDriver.Partition
J#
protected final class AggregateTestDriver.Partition extends ValueType
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Runner.Drivers.AggregateTestDriver.Partition

See Also

AggregateTestDriver.Partition Members
Gallio.Runner.Drivers Namespace


AggregateTestDriver.Partition Members

AggregateTestDriver.Partition Members
See Also Example Constructors Properties Methods
[image]

Provides information about a partition of the aggregate test driver. Each partition specifies a test driver and a test package configuration that covers a portion of the total test package.

The following tables list the members exposed by AggregateTestDriver.Partition.

Public Constructors

 | Name | Description
Public method | AggregateTestDriver.Partition | Creates a partition information structure.
Top

Public Properties

 | Name | Description
Public property | TestDriverFactory | Gets the test driver factory.
Public property | TestPackageConfig | Gets the test package configuration for the driver.
Top

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

AggregateTestDriver.Partition Structure
Gallio.Runner.Drivers Namespace


AggregateTestDriver.Partition Constructor

AggregateTestDriver.Partition Constructor
[image]

Creates a partition information structure.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testDriverFactory As ITestDriverFactory, _
ByVal testPackageConfig As TestPackageConfig _
)
C#
public AggregateTestDriver.Partition(
ITestDriverFactory testDriverFactory,
TestPackageConfig testPackageConfig
)
C++
public:
AggregateTestDriver.Partition(
ITestDriverFactory testDriverFactory,
TestPackageConfig testPackageConfig
) sealed
J#
public AggregateTestDriver.Partition(
ITestDriverFactory testDriverFactory,
TestPackageConfig testPackageConfig
)
JScript
public function AggregateTestDriver.Partition(
testDriverFactory : ITestDriverFactory,
testPackageConfig : TestPackageConfig
)

Parameters

testDriverFactory
The test driver factory
testPackageConfig
The test package configuration for the driver

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testDriverFactory or testPackageConfig is null

See Also

AggregateTestDriver.Partition Structure
Gallio.Runner.Drivers Namespace


Properties

AggregateTestDriver.Partition Properties
[image]

Public Properties

 | Name | Description
Public property | TestDriverFactory | Gets the test driver factory.
Public property | TestPackageConfig | Gets the test package configuration for the driver.
Top

See Also

AggregateTestDriver.Partition Structure
Gallio.Runner.Drivers Namespace


TestDriverFactory Property

AggregateTestDriver.Partition.TestDriverFactory Property
[image]

Gets the test driver factory.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestDriverFactory As ITestDriverFactory
C#
public ITestDriverFactory TestDriverFactory { get; }
C++
public property ITestDriverFactory TestDriverFactory sealed {
ITestDriverFactory get();
}
J#
/** property */
public ITestDriverFactory get_TestDriverFactory();
JScript
public function get TestDriverFactory() : ITestDriverFactory

See Also

AggregateTestDriver.Partition Structure
Gallio.Runner.Drivers Namespace


TestPackageConfig Property

AggregateTestDriver.Partition.TestPackageConfig Property
[image]

Gets the test package configuration for the driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestPackageConfig As TestPackageConfig
C#
public TestPackageConfig TestPackageConfig { get; }
C++
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
}
J#
/** property */
public TestPackageConfig get_TestPackageConfig();
JScript
public function get TestPackageConfig() : TestPackageConfig

See Also

AggregateTestDriver.Partition Structure
Gallio.Runner.Drivers Namespace


BaseTestDriver Class

BaseTestDriver Class
See Also Example Members
[image]

Base implementation of a test driver. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseTestDriver
Inherits LongLivedMarshalByRefObject
Implements ITestDriver, IDisposable
C#
public abstract class BaseTestDriver : LongLivedMarshalByRefObject, ITestDriver, IDisposable
C++
ref class BaseTestDriver abstract : LongLivedMarshalByRefObject, ITestDriver, IDisposable
J#
public class BaseTestDriver extends LongLivedMarshalByRefObject implements ITestDriver, IDisposable
JScript
public class BaseTestDriver extends LongLivedMarshalByRefObject, ITestDriver, IDisposable

Remarks

The base implementation inherits from LongLivedMarshalByRefObject so that test driver's services can be accessed remotely if needed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runner.Drivers.BaseTestDriver
Gallio.Runner.Drivers.AggregateTestDriver
Gallio.Runner.Drivers.LocalTestDriver
Gallio.Runner.Drivers.RemoteTestDriver

See Also

BaseTestDriver Members
Gallio.Runner.Drivers Namespace


BaseTestDriver Members

BaseTestDriver Members
See Also Example Constructors Properties Methods
[image]

Base implementation of a test driver. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseTestDriver.

Protected Constructors

 | Name | Description
Family method | BaseTestDriver | Initializes a new instance of the BaseTestDriver class.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or a null logger instance if not initialized.
Family property | RuntimeSetup | Gets the runtime setup, or null if not initialized.
Family property | TestRunnerOptions | Gets the test runner options, or null if not initialized.
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | ExploreImpl | Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Internal implementation of Initialize. Called after argument validation takes place.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Internal implementation of Run. Called after argument validation takes place.
Top

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


BaseTestDriver Constructor

BaseTestDriver Constructor
[image]

Initializes a new instance of the BaseTestDriver class.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseTestDriver()
C++
protected:
BaseTestDriver() sealed
J#
protected BaseTestDriver()
JScript
protected function BaseTestDriver()

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Properties

BaseTestDriver Properties
[image]

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or a null logger instance if not initialized.
Family property | RuntimeSetup | Gets the runtime setup, or null if not initialized.
Family property | TestRunnerOptions | Gets the test runner options, or null if not initialized.
Top

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Logger Property

BaseTestDriver.Logger Property
[image]

Gets the logger, or a null logger instance if not initialized.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Logger As ILogger
C#
protected ILogger Logger { get; }
C++
protected property ILogger Logger sealed {
ILogger get();
}
J#
/** property */
protected ILogger get_Logger();
JScript
protected function get Logger() : ILogger

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


RuntimeSetup Property

BaseTestDriver.RuntimeSetup Property
[image]

Gets the runtime setup, or null if not initialized.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RuntimeSetup As RuntimeSetup
C#
protected RuntimeSetup RuntimeSetup { get; }
C++
protected property RuntimeSetup RuntimeSetup sealed {
RuntimeSetup get();
}
J#
/** property */
protected RuntimeSetup get_RuntimeSetup();
JScript
protected function get RuntimeSetup() : RuntimeSetup

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


TestRunnerOptions Property

BaseTestDriver.TestRunnerOptions Property
[image]

Gets the test runner options, or null if not initialized.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property TestRunnerOptions As TestRunnerOptions
C#
protected TestRunnerOptions TestRunnerOptions { get; }
C++
protected property TestRunnerOptions TestRunnerOptions sealed {
TestRunnerOptions get();
}
J#
/** property */
protected TestRunnerOptions get_TestRunnerOptions();
JScript
protected function get TestRunnerOptions() : TestRunnerOptions

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Methods

BaseTestDriver Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | ExploreImpl | Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Internal implementation of Initialize. Called after argument validation takes place.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Internal implementation of Run. Called after argument validation takes place.
Top

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Dispose Method

BaseTestDriver.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Dispose (Boolean) | Disposes the test driver.

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Dispose Method ()

BaseTestDriver.Dispose Method ()
See Also Example
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace
BaseTestDriver.Dispose Overload List


Dispose Method (Boolean)

BaseTestDriver.Dispose Method (Boolean)
See Also Example
[image]

Disposes the test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

Parameters

disposing
True if Dispose was called

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace
BaseTestDriver.Dispose Overload List


Explore Method

BaseTestDriver.Explore Method
[image]

Explores tests in a test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Explore( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestDriver.Explore
C#
public void Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
public:
void Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) sealed
J#
public void Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
public function Explore(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExplorationListener
The test exploration listener
progressMonitor
The progress monitor

Return Value

The test report

Implements

ITestDriver.Explore

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


ExploreImpl Method

BaseTestDriver.ExploreImpl Method
[image]

Internal implementation of Explore. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub ExploreImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected abstract void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
protected:
void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) abstract
J#
protected abstract void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
protected abstract function ExploreImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Initialize Method

BaseTestDriver.Initialize Method
[image]

Initializes the test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize( _
ByVal runtimeSetup As RuntimeSetup, _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger _
) _
Implements ITestDriver.Initialize
C#
public void Initialize(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
C++
public:
void Initialize(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
) sealed
J#
public void Initialize(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
JScript
public function Initialize(
runtimeSetup : RuntimeSetup,
testRunnerOptions : TestRunnerOptions,
logger : ILogger
)

Parameters

runtimeSetup
The runtime setup
testRunnerOptions
The test runner options
logger
The logger

Implements

ITestDriver.Initialize

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


InitializeImpl Method

BaseTestDriver.InitializeImpl Method
[image]

Internal implementation of Initialize. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeImpl( _
ByVal runtimeSetup As RuntimeSetup, _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger _
)
C#
protected virtual void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
C++
protected:
virtual void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
J#
protected virtual void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
JScript
protected virtual function InitializeImpl(
runtimeSetup : RuntimeSetup,
testRunnerOptions : TestRunnerOptions,
logger : ILogger
)

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


Run Method

BaseTestDriver.Run Method
[image]

Explores and runs tests in a test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Run( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestDriver.Run
C#
public void Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
public:
void Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) sealed
J#
public void Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
public function Run(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExplorationListener
The test exploration listener
testExecutionOptions
The test execution options
testExecutionListener
The test execution listener
progressMonitor
The progress monitor

Return Value

The test report

Implements

ITestDriver.Run

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


RunImpl Method

BaseTestDriver.RunImpl Method
[image]

Internal implementation of Run. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub RunImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected abstract void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
protected:
void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) abstract
J#
protected abstract void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
protected abstract function RunImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

See Also

BaseTestDriver Class
Gallio.Runner.Drivers Namespace


HostedTestDriver Class

HostedTestDriver Class
See Also Example Members
[image]

A test driver that runs tests remotely within a remote host. The driver further partitions assemblies into test domains based on their configuration requirements.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class HostedTestDriver
Inherits AggregateTestDriver
C#
public class HostedTestDriver : AggregateTestDriver
C++
ref class HostedTestDriver : AggregateTestDriver
J#
public class HostedTestDriver extends AggregateTestDriver
JScript
public class HostedTestDriver extends AggregateTestDriver

Remarks

Copies down the test runner options to the containing host.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runner.Drivers.BaseTestDriver
Gallio.Runner.Drivers.AggregateTestDriver
Gallio.Runner.Drivers.HostedTestDriver

See Also

HostedTestDriver Members
Gallio.Runner.Drivers Namespace


HostedTestDriver Members

HostedTestDriver Members
See Also Example Constructors Properties Methods
[image]

A test driver that runs tests remotely within a remote host. The driver further partitions assemblies into test domains based on their configuration requirements.

The following tables list the members exposed by HostedTestDriver.

Public Constructors

 | Name | Description
Public method | HostedTestDriver | Creates a hosted test driver.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or a null logger instance if not initialized. (inherited from BaseTestDriver)
Family property | RuntimeSetup | Gets the runtime setup, or null if not initialized. (inherited from BaseTestDriver)
Family property | TestRunnerOptions | Gets the test runner options, or null if not initialized. (inherited from BaseTestDriver)
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConfigureHost | Provides an opportunity for subclasses to configure the host.
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Family method | DisposeHost | Provides an opportunity for subclasses to clean up the host as part of its disposal.
Family method | DoWithPartitions | Overridden. Runs a block of code with partitions of the test package.
Family method | ExploreImpl | Internal implementation of Explore. Called after argument validation takes place. (inherited from AggregateTestDriver)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeHost | Provides an opportunity for subclasses to initialize the host once created.
Family method | InitializeImpl | Internal implementation of Initialize. Called after argument validation takes place. (inherited from BaseTestDriver)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Internal implementation of Run. Called after argument validation takes place. (inherited from AggregateTestDriver)
Top

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


HostedTestDriver Constructor

HostedTestDriver Constructor
[image]

Creates a hosted test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostFactory As IHostFactory, _
ByVal frameworks As ITestFramework(), _
ByVal runtime As IRuntime, _
ByVal shareAppDomain As Boolean _
)
C#
public HostedTestDriver(
IHostFactory hostFactory,
ITestFramework[] frameworks,
IRuntime runtime,
bool shareAppDomain
)
C++
public:
HostedTestDriver(
IHostFactory hostFactory,
array<ITestFramework>^ frameworks,
IRuntime runtime,
bool shareAppDomain
) sealed
J#
public HostedTestDriver(
IHostFactory hostFactory,
ITestFramework[] frameworks,
IRuntime runtime,
bool shareAppDomain
)
JScript
public function HostedTestDriver(
hostFactory : IHostFactory,
frameworks : ITestFramework[],
runtime : IRuntime,
shareAppDomain : bool
)

Parameters

hostFactory
The host factory
frameworks
The test frameworks that should participate in test domain configuration
runtime
The Gallio runtime
shareAppDomain
If true, uses a shared app-domain for all test domains

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostFactory, frameworks, or runtime is null

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


Methods

HostedTestDriver Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConfigureHost | Provides an opportunity for subclasses to configure the host.
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Family method | DisposeHost | Provides an opportunity for subclasses to clean up the host as part of its disposal.
Family method | DoWithPartitions | Overridden. Runs a block of code with partitions of the test package.
Family method | ExploreImpl | Internal implementation of Explore. Called after argument validation takes place. (inherited from AggregateTestDriver)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeHost | Provides an opportunity for subclasses to initialize the host once created.
Family method | InitializeImpl | Internal implementation of Initialize. Called after argument validation takes place. (inherited from BaseTestDriver)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Internal implementation of Run. Called after argument validation takes place. (inherited from AggregateTestDriver)
Top

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


ConfigureHost Method

HostedTestDriver.ConfigureHost Method
[image]

Provides an opportunity for subclasses to configure the host.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ConfigureHost( _
ByVal hostSetup As HostSetup _
)
C#
protected virtual void ConfigureHost(
HostSetup hostSetup
)
C++
protected:
virtual void ConfigureHost(
HostSetup hostSetup
)
J#
protected virtual void ConfigureHost(
HostSetup hostSetup
)
JScript
protected virtual function ConfigureHost(
hostSetup : HostSetup
)

Parameters

hostSetup
The host setup, not null

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


DisposeHost Method

HostedTestDriver.DisposeHost Method
[image]

Provides an opportunity for subclasses to clean up the host as part of its disposal.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DisposeHost( _
ByVal host As IHost _
)
C#
protected virtual void DisposeHost(
IHost host
)
C++
protected:
virtual void DisposeHost(
IHost host
)
J#
protected virtual void DisposeHost(
IHost host
)
JScript
protected virtual function DisposeHost(
host : IHost
)

Parameters

host
The host, not null

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


DoWithPartitions Method

HostedTestDriver.DoWithPartitions Method
[image]

Runs a block of code with partitions of the test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DoWithPartitions( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal action As Action(Of IList(Of Partition)), _
ByVal setStatus As Action(Of String) _
)
C#
protected override void DoWithPartitions(
TestPackageConfig testPackageConfig,
Action<IList<Partition>> action,
Action<string> setStatus
)
C++
protected:
virtual void DoWithPartitions(
TestPackageConfig testPackageConfig,
Action<IList<Partition>> action,
Action<string> setStatus
) override
J#
protected override void DoWithPartitions(
TestPackageConfig testPackageConfig,
Action<IList<Partition>> action,
Action<string> setStatus
)
JScript
protected override function DoWithPartitions(
testPackageConfig : TestPackageConfig,
action : Action<IList<Partition>>,
setStatus : Action<string>
)

Parameters

testPackageConfig
The test package configuration, not null
action
The action to perform given a list of partitions, not null
setStatus
An action that can be used to report progress, not null

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


InitializeHost Method

HostedTestDriver.InitializeHost Method
[image]

Provides an opportunity for subclasses to initialize the host once created.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeHost( _
ByVal host As IHost _
)
C#
protected virtual void InitializeHost(
IHost host
)
C++
protected:
virtual void InitializeHost(
IHost host
)
J#
protected virtual void InitializeHost(
IHost host
)
JScript
protected virtual function InitializeHost(
host : IHost
)

Parameters

host
The host, not null

See Also

HostedTestDriver Class
Gallio.Runner.Drivers Namespace


HostedTestDriverFactory Class

HostedTestDriverFactory Class
See Also Example Members
[image]

Creates hosted test driver instances.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class HostedTestDriverFactory
Implements ITestDriverFactory
C#
public class HostedTestDriverFactory : ITestDriverFactory
C++
ref class HostedTestDriverFactory : ITestDriverFactory
J#
public class HostedTestDriverFactory implements ITestDriverFactory
JScript
public class HostedTestDriverFactory extends ITestDriverFactory

Inheritance Hierarchy

System.Object
Gallio.Runner.Drivers.HostedTestDriverFactory

See Also

HostedTestDriverFactory Members
Gallio.Runner.Drivers Namespace


HostedTestDriverFactory Members

HostedTestDriverFactory Members
See Also Example Constructors Properties Methods
[image]

Creates hosted test driver instances.

The following tables list the members exposed by HostedTestDriverFactory.

Public Constructors

 | Name | Description
Public method | HostedTestDriverFactory | Creates a hosted test driver factory.
Top

Public Properties

 | Name | Description
Public property | ShareAppDomain | Specifies whether to share the app-domain among all test domains.
Top

Public Methods

 | Name | Description
Public method | CreateTestDriver | Creates a test driver.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

HostedTestDriverFactory Class
Gallio.Runner.Drivers Namespace


HostedTestDriverFactory Constructor

HostedTestDriverFactory Constructor
[image]

Creates a hosted test driver factory.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostFactory As IHostFactory, _
ByVal frameworks As ITestFramework(), _
ByVal runtime As IRuntime _
)
C#
public HostedTestDriverFactory(
IHostFactory hostFactory,
ITestFramework[] frameworks,
IRuntime runtime
)
C++
public:
HostedTestDriverFactory(
IHostFactory hostFactory,
array<ITestFramework>^ frameworks,
IRuntime runtime
) sealed
J#
public HostedTestDriverFactory(
IHostFactory hostFactory,
ITestFramework[] frameworks,
IRuntime runtime
)
JScript
public function HostedTestDriverFactory(
hostFactory : IHostFactory,
frameworks : ITestFramework[],
runtime : IRuntime
)

Parameters

hostFactory
The host factory
frameworks
The test frameworks that should participate in test domain configuration
runtime
The Gallio runtime

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostFactory, frameworks, or runtime is null

See Also

HostedTestDriverFactory Class
Gallio.Runner.Drivers Namespace


Properties

HostedTestDriverFactory Properties
[image]

Public Properties

 | Name | Description
Public property | ShareAppDomain | Specifies whether to share the app-domain among all test domains.
Top

See Also

HostedTestDriverFactory Class
Gallio.Runner.Drivers Namespace


ShareAppDomain Property

HostedTestDriverFactory.ShareAppDomain Property
[image]

Specifies whether to share the app-domain among all test domains.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ShareAppDomain As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool ShareAppDomain { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool ShareAppDomain sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShareAppDomain();

/** property */
public void set_ShareAppDomain(bool value);
JScript
public CompilerGeneratedAttribute function get ShareAppDomain() : bool

public CompilerGeneratedAttribute function set ShareAppDomain(value : bool);

Remarks

If false, creates a separate app-domain for each test domain. Otherwise shares the host's own app-domain across all test domains.

When this mode is enabled, any features that depend on test assembly configuration will not work.

See Also

HostedTestDriverFactory Class
Gallio.Runner.Drivers Namespace


Methods

HostedTestDriverFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestDriver | Creates a test driver.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

HostedTestDriverFactory Class
Gallio.Runner.Drivers Namespace


CreateTestDriver Method

HostedTestDriverFactory.CreateTestDriver Method
[image]

Creates a test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTestDriver() As ITestDriver _
Implements ITestDriverFactory.CreateTestDriver
C#
public ITestDriver CreateTestDriver()
C++
public:
ITestDriver CreateTestDriver() sealed
J#
public ITestDriver CreateTestDriver()
JScript
public function CreateTestDriver() : ITestDriver

Return Value

The new test driver

Implements

ITestDriverFactory.CreateTestDriver

See Also

HostedTestDriverFactory Class
Gallio.Runner.Drivers Namespace


ITestDriver Interface

ITestDriver Interface
See Also Example Members
[image]

A test driver controls how tests are loaded, explored, and run.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestDriver
Implements IDisposable
C#
public interface ITestDriver : IDisposable
C++
interface class ITestDriver : IDisposable
J#
public interface ITestDriver implements IDisposable
JScript
public interface ITestDriver extends IDisposable

Types that implement ITestDriver

Type | Description
Gallio.Runner.Drivers.BaseTestDriver | Base implementation of a test driver. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ITestDriver Members
Gallio.Runner.Drivers Namespace


ITestDriver Members

ITestDriver Members
See Also Example Methods
[image]

A test driver controls how tests are loaded, explored, and run.

The following tables list the members exposed by ITestDriver.

Public Methods

 | Name | Description
Public method | Explore | Explores tests in a test package.
Public method | Initialize | Initializes the test driver.
Public method | Run | Explores and runs tests in a test package.
Top

See Also

ITestDriver Interface
Gallio.Runner.Drivers Namespace


Methods

ITestDriver Methods
[image]

Public Methods

 | Name | Description
Public method | Explore | Explores tests in a test package.
Public method | Initialize | Initializes the test driver.
Public method | Run | Explores and runs tests in a test package.
Top

See Also

ITestDriver Interface
Gallio.Runner.Drivers Namespace


Explore Method

ITestDriver.Explore Method
[image]

Explores tests in a test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Explore( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
void Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) abstract
J#
void Explore(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
function Explore(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExplorationListener
The test exploration listener
progressMonitor
The progress monitor

Return Value

The test report

See Also

ITestDriver Interface
Gallio.Runner.Drivers Namespace


Initialize Method

ITestDriver.Initialize Method
[image]

Initializes the test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize( _
ByVal runtimeSetup As RuntimeSetup, _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger _
)
C#
void Initialize(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
C++
void Initialize(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
) abstract
J#
void Initialize(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
JScript
function Initialize(
runtimeSetup : RuntimeSetup,
testRunnerOptions : TestRunnerOptions,
logger : ILogger
)

Parameters

runtimeSetup
The runtime setup
testRunnerOptions
The test runner options
logger
The logger

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if runtimeSetup, testRunnerOptions, or logger is null

See Also

ITestDriver Interface
Gallio.Runner.Drivers Namespace


Run Method

ITestDriver.Run Method
[image]

Explores and runs tests in a test package.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Run( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
void Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) abstract
J#
void Run(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
function Run(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExplorationListener
The test exploration listener
testExecutionOptions
The test execution options
testExecutionListener
The test execution listener
progressMonitor
The progress monitor

Return Value

The test report

See Also

ITestDriver Interface
Gallio.Runner.Drivers Namespace


ITestDriverFactory Interface

ITestDriverFactory Interface
See Also Example Members
[image]

Creates test drivers.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestDriverFactory
C#
public interface ITestDriverFactory
C++
interface class ITestDriverFactory
J#
public interface ITestDriverFactory
JScript
public interface ITestDriverFactory

Types that implement ITestDriverFactory

Type | Description
Gallio.Runner.Drivers.HostedTestDriverFactory | Creates hosted test driver instances.

See Also

ITestDriverFactory Members
Gallio.Runner.Drivers Namespace


ITestDriverFactory Members

ITestDriverFactory Members
See Also Example Methods
[image]

Creates test drivers.

The following tables list the members exposed by ITestDriverFactory.

Public Methods

 | Name | Description
Public method | CreateTestDriver | Creates a test driver.
Top

See Also

ITestDriverFactory Interface
Gallio.Runner.Drivers Namespace


Methods

ITestDriverFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateTestDriver | Creates a test driver.
Top

See Also

ITestDriverFactory Interface
Gallio.Runner.Drivers Namespace


CreateTestDriver Method

ITestDriverFactory.CreateTestDriver Method
[image]

Creates a test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateTestDriver() As ITestDriver
C#
ITestDriver CreateTestDriver()
C++
ITestDriver CreateTestDriver() abstract
J#
ITestDriver CreateTestDriver()
JScript
function CreateTestDriver() : ITestDriver

Return Value

The new test driver

See Also

ITestDriverFactory Interface
Gallio.Runner.Drivers Namespace


LocalTestDriver Class

LocalTestDriver Class
See Also Example Members
[image]

A simple test driver implementation that runs tests locally within the current domain without any additional consultation of the test frameworks.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LocalTestDriver
Inherits BaseTestDriver
C#
public class LocalTestDriver : BaseTestDriver
C++
ref class LocalTestDriver : BaseTestDriver
J#
public class LocalTestDriver extends BaseTestDriver
JScript
public class LocalTestDriver extends BaseTestDriver

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runner.Drivers.BaseTestDriver
Gallio.Runner.Drivers.LocalTestDriver

See Also

LocalTestDriver Members
Gallio.Runner.Drivers Namespace


LocalTestDriver Members

LocalTestDriver Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A simple test driver implementation that runs tests locally within the current domain without any additional consultation of the test frameworks.

The following tables list the members exposed by LocalTestDriver.

Public Constructors

Name | Description
LocalTestDriver | Overloaded. Initializes a new instance of the LocalTestDriver class.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or a null logger instance if not initialized. (inherited from BaseTestDriver)
Family property | RuntimeSetup | Gets the runtime setup, or null if not initialized. (inherited from BaseTestDriver)
Family property | TestRunnerOptions | Gets the test runner options, or null if not initialized. (inherited from BaseTestDriver)
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | ExploreImpl | Overridden. Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Overridden. Internal implementation of Initialize. Called after argument validation takes place.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Overridden. Internal implementation of Run. Called after argument validation takes place.
Top

Explicit Interface Implementations

Name | Description
LocalTestDriver | Overloaded. Initializes a new instance of the LocalTestDriver class.
Top

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


LocalTestDriver Constructor

LocalTestDriver Constructor

Initializes a new instance of the LocalTestDriver class.

Overload List

 | Name | Description
Public method | LocalTestDriver | Creates a test driver.
Public method | LocalTestDriver (IDebuggerManager) | Creates a test driver.

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


LocalTestDriver Constructor ()

LocalTestDriver Constructor ()
See Also Example
[image]

Creates a test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LocalTestDriver()
C++
public:
LocalTestDriver() sealed
J#
public LocalTestDriver()
JScript
public function LocalTestDriver()

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace
LocalTestDriver Constructor Overload List


LocalTestDriver Constructor (IDebuggerManager)

LocalTestDriver Constructor (IDebuggerManager)
See Also Example
[image]

Creates a test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal debuggerManager As IDebuggerManager _
)
C#
public LocalTestDriver(
IDebuggerManager debuggerManager
)
C++
public:
LocalTestDriver(
IDebuggerManager debuggerManager
) sealed
J#
public LocalTestDriver(
IDebuggerManager debuggerManager
)
JScript
public function LocalTestDriver(
debuggerManager : IDebuggerManager
)

Parameters

debuggerManager
A reference to the debugger manager

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if debuggerManager is null

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace
LocalTestDriver Constructor Overload List


Methods

LocalTestDriver Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | ExploreImpl | Overridden. Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Overridden. Internal implementation of Initialize. Called after argument validation takes place.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Overridden. Internal implementation of Run. Called after argument validation takes place.
Top

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


Dispose Method

LocalTestDriver.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Family method | Dispose (Boolean) | Overridden. Disposes the test driver.

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


Dispose Method (Boolean)

LocalTestDriver.Dispose Method (Boolean)
See Also Example
[image]

Disposes the test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if Dispose was called

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace
LocalTestDriver.Dispose Overload List


ExploreImpl Method

LocalTestDriver.ExploreImpl Method
[image]

Internal implementation of Explore. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ExploreImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected override void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
protected:
virtual void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) override
J#
protected override void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
protected override function ExploreImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


InitializeImpl Method

LocalTestDriver.InitializeImpl Method
[image]

Internal implementation of Initialize. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeImpl( _
ByVal runtimeSetup As RuntimeSetup, _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger _
)
C#
protected override void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
C++
protected:
virtual void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
) override
J#
protected override void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
JScript
protected override function InitializeImpl(
runtimeSetup : RuntimeSetup,
testRunnerOptions : TestRunnerOptions,
logger : ILogger
)

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


RunImpl Method

LocalTestDriver.RunImpl Method
[image]

Internal implementation of Run. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RunImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected override void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
protected:
virtual void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) override
J#
protected override void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
protected override function RunImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

See Also

LocalTestDriver Class
Gallio.Runner.Drivers Namespace


RemoteTestDriver Class

RemoteTestDriver Class
See Also Example Members
[image]

A proxy for a remote test driver. Wraps a test driver and forwards all messages to it.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RemoteTestDriver
Inherits BaseTestDriver
C#
public class RemoteTestDriver : BaseTestDriver
C++
ref class RemoteTestDriver : BaseTestDriver
J#
public class RemoteTestDriver extends BaseTestDriver
JScript
public class RemoteTestDriver extends BaseTestDriver

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runner.Drivers.BaseTestDriver
Gallio.Runner.Drivers.RemoteTestDriver

See Also

RemoteTestDriver Members
Gallio.Runner.Drivers Namespace


RemoteTestDriver Members

RemoteTestDriver Members
See Also Example Constructors Properties Methods Events
[image]

A proxy for a remote test driver. Wraps a test driver and forwards all messages to it.

The following tables list the members exposed by RemoteTestDriver.

Public Constructors

 | Name | Description
Public method | RemoteTestDriver | Creates a proxy for a test driver.
Top

Protected Properties

 | Name | Description
Family property | Logger | Gets the logger, or a null logger instance if not initialized. (inherited from BaseTestDriver)
Family property | RuntimeSetup | Gets the runtime setup, or null if not initialized. (inherited from BaseTestDriver)
Family property | TestRunnerOptions | Gets the test runner options, or null if not initialized. (inherited from BaseTestDriver)
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | ExploreImpl | Overridden. Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Overridden. Internal implementation of Initialize. Called after argument validation takes place.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Overridden. Internal implementation of Run. Called after argument validation takes place.
Top

Public Events

 | Name | Description
Public event | Disposed | An event that is fired when the test driver is disposed.
Top

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


RemoteTestDriver Constructor

RemoteTestDriver Constructor
[image]

Creates a proxy for a test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testDriver As ITestDriver _
)
C#
public RemoteTestDriver(
ITestDriver testDriver
)
C++
public:
RemoteTestDriver(
ITestDriver testDriver
) sealed
J#
public RemoteTestDriver(
ITestDriver testDriver
)
JScript
public function RemoteTestDriver(
testDriver : ITestDriver
)

Parameters

testDriver
The test driver to which messages should be forwarded

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testDriver is null

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


Methods

RemoteTestDriver Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Explores tests in a test package. (inherited from BaseTestDriver)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the test driver. (inherited from BaseTestDriver)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Run | Explores and runs tests in a test package. (inherited from BaseTestDriver)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | ExploreImpl | Overridden. Internal implementation of Explore. Called after argument validation takes place.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeImpl | Overridden. Internal implementation of Initialize. Called after argument validation takes place.
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | RunImpl | Overridden. Internal implementation of Run. Called after argument validation takes place.
Top

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


Dispose Method

RemoteTestDriver.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseTestDriver)
Family method | Dispose (Boolean) | Overridden. Disposes the test driver.

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


Dispose Method (Boolean)

RemoteTestDriver.Dispose Method (Boolean)
See Also Example
[image]

Disposes the test driver.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if Dispose was called

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace
RemoteTestDriver.Dispose Overload List


ExploreImpl Method

RemoteTestDriver.ExploreImpl Method
[image]

Internal implementation of Explore. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ExploreImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected override void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
protected:
virtual void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) override
J#
protected override void ExploreImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
protected override function ExploreImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


InitializeImpl Method

RemoteTestDriver.InitializeImpl Method
[image]

Internal implementation of Initialize. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeImpl( _
ByVal runtimeSetup As RuntimeSetup, _
ByVal testRunnerOptions As TestRunnerOptions, _
ByVal logger As ILogger _
)
C#
protected override void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
C++
protected:
virtual void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
) override
J#
protected override void InitializeImpl(
RuntimeSetup runtimeSetup,
TestRunnerOptions testRunnerOptions,
ILogger logger
)
JScript
protected override function InitializeImpl(
runtimeSetup : RuntimeSetup,
testRunnerOptions : TestRunnerOptions,
logger : ILogger
)

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


RunImpl Method

RemoteTestDriver.RunImpl Method
[image]

Internal implementation of Run. Called after argument validation takes place.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RunImpl( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
protected override void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
protected:
virtual void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) override
J#
protected override void RunImpl(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
protected override function RunImpl(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


Events

RemoteTestDriver Events
[image]

Public Events

 | Name | Description
Public event | Disposed | An event that is fired when the test driver is disposed.
Top

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


Disposed Event

RemoteTestDriver.Disposed Event
[image]

An event that is fired when the test driver is disposed.

Namespace: Gallio.Runner.Drivers
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Disposed As EventHandler
C#
public event EventHandler Disposed
C++
public:
virtual event EventHandler Disposed {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Disposed(EventHandler value);

/** event */
public final void remove_Disposed(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

RemoteTestDriver Class
Gallio.Runner.Drivers Namespace


Gallio.Runner.Events

Gallio.Runner.Events Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | DisposeFinishedEventArgs | Arguments for an event raised to indicate that the test runner disposal has finished. This class cannot be inherited.
Public class | DisposeStartedEventArgs | Arguments for an event raised to indicate that the test runner disposal has started. This class cannot be inherited.
Public class | ExploreFinishedEventArgs | Arguments for an event raised to indicate that test exploration has finished. This class cannot be inherited.
Public class | ExploreStartedEventArgs | Arguments for an event raised to indicate that test exploration has started. This class cannot be inherited.
Public class | InitializeFinishedEventArgs | Arguments for an event raised to indicate that the test runner initialization has finished. This class cannot be inherited.
Public class | InitializeStartedEventArgs | Arguments for an event raised to indicate that the test runner initialization has started. This class cannot be inherited.
Public class | RunFinishedEventArgs | Arguments for an event raised to indicate that test execution has finished. This class cannot be inherited.
Public class | RunStartedEventArgs | Arguments for an event raised to indicate that test execution has started. This class cannot be inherited.
Public class | TestModelAnnotationAddedEventArgs | Arguments for an event raised to signal that an annotation has been added to the test model. This class cannot be inherited.
Public class | TestModelSubtreeMergedEventArgs | Arguments for an event raised to signal that a subtree of tests has been merged into the test model. This class cannot be inherited.
Public class | TestRunnerEventDispatcher | Dispatches test runner events to listeners. Each notification function ensures that the event is safely dispatched via SafeInvoke. This class cannot be inherited.
Public class | TestStepEventArgs | Base arguments for an event raised to provide information about a test step. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestStepFinishedEventArgs | Arguments for an event raised to indicate that a test step has finished execution. This class cannot be inherited.
Public class | TestStepLifecyclePhaseChangedEventArgs | Arguments for an event raised to indicate that a test step has entered a new lifecycle phase. This class cannot be inherited.
Public class | TestStepLogAttachEventArgs | Arguments for an event raised to indicate that an attachment has been added to a test step log. This class cannot be inherited.
Public class | TestStepLogStreamBeginMarkerEventArgs | Arguments for an event raised to indicate that a marker region has been started within a test step log stream. This class cannot be inherited.
Public class | TestStepLogStreamBeginSectionEventArgs | Arguments for an event raised to indicate that a section has been started within a test step log stream. This class cannot be inherited.
Public class | TestStepLogStreamEmbedEventArgs | Arguments for an event raised to indicate that an attachment has been embedded into a test step log stream. This class cannot be inherited.
Public class | TestStepLogStreamEndEventArgs | Arguments for an event raised to indicate that a section has been finished within a test step log stream. This class cannot be inherited.
Public class | TestStepLogStreamEventArgs | Base arguments for an event raised to indicate that a test step log stream has been modified in some way. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestStepLogStreamWriteEventArgs | Arguments for an event raised to indicate that text has been written to a test step log stream. This class cannot be inherited.
Public class | TestStepMetadataAddedEventArgs | Arguments for an event raised to indicate that a test step dynamically added metadata to itself. This class cannot be inherited.
Public class | TestStepStartedEventArgs | Arguments for an event raised to indicate that a test step has started execution. This class cannot be inherited.

Interfaces

 | Interface | Description
Public interface | ITestRunnerEvents | Declares all of the events that may be raised by a ITestRunner.


DisposeFinishedEventArgs Class

DisposeFinishedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that the test runner disposal has finished. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DisposeFinishedEventArgs
Inherits OperationFinishedEventArgs
C#
public sealed class DisposeFinishedEventArgs : OperationFinishedEventArgs
C++
ref class DisposeFinishedEventArgs sealed : OperationFinishedEventArgs
J#
public final class DisposeFinishedEventArgs extends OperationFinishedEventArgs
JScript
public final class DisposeFinishedEventArgs extends OperationFinishedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.Events.DisposeFinishedEventArgs

See Also

DisposeFinishedEventArgs Members
Gallio.Runner.Events Namespace


DisposeFinishedEventArgs Members

DisposeFinishedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that the test runner disposal has finished. This class cannot be inherited.

The following tables list the members exposed by DisposeFinishedEventArgs.

Public Constructors

 | Name | Description
Public method | DisposeFinishedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Success | Returns true if the operation completed successfully. (inherited from OperationFinishedEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DisposeFinishedEventArgs Class
Gallio.Runner.Events Namespace


DisposeFinishedEventArgs Constructor

DisposeFinishedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal success As Boolean _
)
C#
public DisposeFinishedEventArgs(
bool success
)
C++
public:
DisposeFinishedEventArgs(
bool success
) sealed
J#
public DisposeFinishedEventArgs(
bool success
)
JScript
public function DisposeFinishedEventArgs(
success : bool
)

Parameters

success
True if the disposal was completed successfully

See Also

DisposeFinishedEventArgs Class
Gallio.Runner.Events Namespace


DisposeStartedEventArgs Class

DisposeStartedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that the test runner disposal has started. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DisposeStartedEventArgs
Inherits OperationStartedEventArgs
C#
public sealed class DisposeStartedEventArgs : OperationStartedEventArgs
C++
ref class DisposeStartedEventArgs sealed : OperationStartedEventArgs
J#
public final class DisposeStartedEventArgs extends OperationStartedEventArgs
JScript
public final class DisposeStartedEventArgs extends OperationStartedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationStartedEventArgs
Gallio.Runner.Events.DisposeStartedEventArgs

See Also

DisposeStartedEventArgs Members
Gallio.Runner.Events Namespace


DisposeStartedEventArgs Members

DisposeStartedEventArgs Members
See Also Example Constructors Methods
[image]

Arguments for an event raised to indicate that the test runner disposal has started. This class cannot be inherited.

The following tables list the members exposed by DisposeStartedEventArgs.

Public Constructors

 | Name | Description
Public method | DisposeStartedEventArgs | Initializes the event arguments.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DisposeStartedEventArgs Class
Gallio.Runner.Events Namespace


DisposeStartedEventArgs Constructor

DisposeStartedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DisposeStartedEventArgs()
C++
public:
DisposeStartedEventArgs() sealed
J#
public DisposeStartedEventArgs()
JScript
public function DisposeStartedEventArgs()

See Also

DisposeStartedEventArgs Class
Gallio.Runner.Events Namespace


ExploreFinishedEventArgs Class

ExploreFinishedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that test exploration has finished. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExploreFinishedEventArgs
Inherits OperationFinishedEventArgs
C#
public sealed class ExploreFinishedEventArgs : OperationFinishedEventArgs
C++
ref class ExploreFinishedEventArgs sealed : OperationFinishedEventArgs
J#
public final class ExploreFinishedEventArgs extends OperationFinishedEventArgs
JScript
public final class ExploreFinishedEventArgs extends OperationFinishedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.Events.ExploreFinishedEventArgs

See Also

ExploreFinishedEventArgs Members
Gallio.Runner.Events Namespace


ExploreFinishedEventArgs Members

ExploreFinishedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that test exploration has finished. This class cannot be inherited.

The following tables list the members exposed by ExploreFinishedEventArgs.

Public Constructors

 | Name | Description
Public method | ExploreFinishedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report, including test model data on success.
Public property | Success | Returns true if the operation completed successfully. (inherited from OperationFinishedEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExploreFinishedEventArgs Class
Gallio.Runner.Events Namespace


ExploreFinishedEventArgs Constructor

ExploreFinishedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal success As Boolean, _
ByVal report As Report _
)
C#
public ExploreFinishedEventArgs(
bool success,
Report report
)
C++
public:
ExploreFinishedEventArgs(
bool success,
Report report
) sealed
J#
public ExploreFinishedEventArgs(
bool success,
Report report
)
JScript
public function ExploreFinishedEventArgs(
success : bool,
report : Report
)

Parameters

success
True if test exploration was successful
report
The report, including test model data on success

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report is null

See Also

ExploreFinishedEventArgs Class
Gallio.Runner.Events Namespace


Properties

ExploreFinishedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the report, including test model data on success.
Public property | Success | Returns true if the operation completed successfully. (inherited from OperationFinishedEventArgs)
Top

See Also

ExploreFinishedEventArgs Class
Gallio.Runner.Events Namespace


Report Property

ExploreFinishedEventArgs.Report Property
[image]

Gets the report, including test model data on success.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

ExploreFinishedEventArgs Class
Gallio.Runner.Events Namespace


ExploreStartedEventArgs Class

ExploreStartedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that test exploration has started. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExploreStartedEventArgs
Inherits OperationStartedEventArgs
C#
public sealed class ExploreStartedEventArgs : OperationStartedEventArgs
C++
ref class ExploreStartedEventArgs sealed : OperationStartedEventArgs
J#
public final class ExploreStartedEventArgs extends OperationStartedEventArgs
JScript
public final class ExploreStartedEventArgs extends OperationStartedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationStartedEventArgs
Gallio.Runner.Events.ExploreStartedEventArgs

See Also

ExploreStartedEventArgs Members
Gallio.Runner.Events Namespace


ExploreStartedEventArgs Members

ExploreStartedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that test exploration has started. This class cannot be inherited.

The following tables list the members exposed by ExploreStartedEventArgs.

Public Constructors

 | Name | Description
Public method | ExploreStartedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
Public property | TestExplorationOptions | Gets the test exploration options.
Public property | TestPackageConfig | Gets the test package configuration.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExploreStartedEventArgs Class
Gallio.Runner.Events Namespace


ExploreStartedEventArgs Constructor

ExploreStartedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal reportLockBox As LockBox(Of Report) _
)
C#
public ExploreStartedEventArgs(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
LockBox<Report> reportLockBox
)
C++
public:
ExploreStartedEventArgs(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
LockBox<Report> reportLockBox
) sealed
J#
public ExploreStartedEventArgs(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
LockBox<Report> reportLockBox
)
JScript
public function ExploreStartedEventArgs(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
reportLockBox : LockBox<Report>
)

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
reportLockBox
The report lock-box which may be used to access the report asynchronously during execution

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackageConfig or testExplorationOptions is null

See Also

ExploreStartedEventArgs Class
Gallio.Runner.Events Namespace


Properties

ExploreStartedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
Public property | TestExplorationOptions | Gets the test exploration options.
Public property | TestPackageConfig | Gets the test package configuration.
Top

See Also

ExploreStartedEventArgs Class
Gallio.Runner.Events Namespace


ReportLockBox Property

ExploreStartedEventArgs.ReportLockBox Property
[image]

Gets the report lock-box which may be used to access the report asynchronously during execution.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportLockBox As LockBox(Of Report)
C#
public LockBox<Report> ReportLockBox { get; }
C++
public property LockBox<Report> ReportLockBox sealed {
LockBox<Report> get();
}
J#
/** property */
public LockBox<Report> get_ReportLockBox();
JScript
public function get ReportLockBox() : LockBox<Report>

See Also

ExploreStartedEventArgs Class
Gallio.Runner.Events Namespace


TestExplorationOptions Property

ExploreStartedEventArgs.TestExplorationOptions Property
[image]

Gets the test exploration options.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestExplorationOptions As TestExplorationOptions
C#
public TestExplorationOptions TestExplorationOptions { get; }
C++
public property TestExplorationOptions TestExplorationOptions sealed {
TestExplorationOptions get();
}
J#
/** property */
public TestExplorationOptions get_TestExplorationOptions();
JScript
public function get TestExplorationOptions() : TestExplorationOptions

See Also

ExploreStartedEventArgs Class
Gallio.Runner.Events Namespace


TestPackageConfig Property

ExploreStartedEventArgs.TestPackageConfig Property
[image]

Gets the test package configuration.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestPackageConfig As TestPackageConfig
C#
public TestPackageConfig TestPackageConfig { get; }
C++
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
}
J#
/** property */
public TestPackageConfig get_TestPackageConfig();
JScript
public function get TestPackageConfig() : TestPackageConfig

See Also

ExploreStartedEventArgs Class
Gallio.Runner.Events Namespace


InitializeFinishedEventArgs Class

InitializeFinishedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that the test runner initialization has finished. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InitializeFinishedEventArgs
Inherits OperationFinishedEventArgs
C#
public sealed class InitializeFinishedEventArgs : OperationFinishedEventArgs
C++
ref class InitializeFinishedEventArgs sealed : OperationFinishedEventArgs
J#
public final class InitializeFinishedEventArgs extends OperationFinishedEventArgs
JScript
public final class InitializeFinishedEventArgs extends OperationFinishedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.Events.InitializeFinishedEventArgs

See Also

InitializeFinishedEventArgs Members
Gallio.Runner.Events Namespace


InitializeFinishedEventArgs Members

InitializeFinishedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that the test runner initialization has finished. This class cannot be inherited.

The following tables list the members exposed by InitializeFinishedEventArgs.

Public Constructors

 | Name | Description
Public method | InitializeFinishedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Success | Returns true if the operation completed successfully. (inherited from OperationFinishedEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

InitializeFinishedEventArgs Class
Gallio.Runner.Events Namespace


InitializeFinishedEventArgs Constructor

InitializeFinishedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal success As Boolean _
)
C#
public InitializeFinishedEventArgs(
bool success
)
C++
public:
InitializeFinishedEventArgs(
bool success
) sealed
J#
public InitializeFinishedEventArgs(
bool success
)
JScript
public function InitializeFinishedEventArgs(
success : bool
)

Parameters

success
True if the test runner was successfully initialized

See Also

InitializeFinishedEventArgs Class
Gallio.Runner.Events Namespace


InitializeStartedEventArgs Class

InitializeStartedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that the test runner initialization has started. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class InitializeStartedEventArgs
Inherits OperationStartedEventArgs
C#
public sealed class InitializeStartedEventArgs : OperationStartedEventArgs
C++
ref class InitializeStartedEventArgs sealed : OperationStartedEventArgs
J#
public final class InitializeStartedEventArgs extends OperationStartedEventArgs
JScript
public final class InitializeStartedEventArgs extends OperationStartedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationStartedEventArgs
Gallio.Runner.Events.InitializeStartedEventArgs

See Also

InitializeStartedEventArgs Members
Gallio.Runner.Events Namespace


InitializeStartedEventArgs Members

InitializeStartedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that the test runner initialization has started. This class cannot be inherited.

The following tables list the members exposed by InitializeStartedEventArgs.

Public Constructors

 | Name | Description
Public method | InitializeStartedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Options | Gets the test runner options.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

InitializeStartedEventArgs Class
Gallio.Runner.Events Namespace


InitializeStartedEventArgs Constructor

InitializeStartedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal options As TestRunnerOptions _
)
C#
public InitializeStartedEventArgs(
TestRunnerOptions options
)
C++
public:
InitializeStartedEventArgs(
TestRunnerOptions options
) sealed
J#
public InitializeStartedEventArgs(
TestRunnerOptions options
)
JScript
public function InitializeStartedEventArgs(
options : TestRunnerOptions
)

Parameters

options
The test runner options

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if options is null

See Also

InitializeStartedEventArgs Class
Gallio.Runner.Events Namespace


Properties

InitializeStartedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Options | Gets the test runner options.
Top

See Also

InitializeStartedEventArgs Class
Gallio.Runner.Events Namespace


Options Property

InitializeStartedEventArgs.Options Property
[image]

Gets the test runner options.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Options As TestRunnerOptions
C#
public TestRunnerOptions Options { get; }
C++
public property TestRunnerOptions Options sealed {
TestRunnerOptions get();
}
J#
/** property */
public TestRunnerOptions get_Options();
JScript
public function get Options() : TestRunnerOptions

See Also

InitializeStartedEventArgs Class
Gallio.Runner.Events Namespace


ITestRunnerEvents Interface

ITestRunnerEvents Interface
See Also Example Members
[image]

Declares all of the events that may be raised by a ITestRunner.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestRunnerEvents
C#
public interface ITestRunnerEvents
C++
interface class ITestRunnerEvents
J#
public interface ITestRunnerEvents
JScript
public interface ITestRunnerEvents

Types that implement ITestRunnerEvents

Type | Description
Gallio.Runner.Events.TestRunnerEventDispatcher | Dispatches test runner events to listeners. Each notification function ensures that the event is safely dispatched via SafeInvoke. This class cannot be inherited.

See Also

ITestRunnerEvents Members
Gallio.Runner.Events Namespace


ITestRunnerEvents Members

ITestRunnerEvents Members
See Also Example Events
[image]

Declares all of the events that may be raised by a ITestRunner.

The following tables list the members exposed by ITestRunnerEvents.

Public Events

 | Name | Description
Public event | DisposeFinished | The event raised to indicate that the test runner disposal has finished.
Public event | DisposeStarted | The event raised to indicate that the test runner disposal has started.
Public event | ExploreFinished | The event raised to indicate that test exploration has finished.
Public event | ExploreStarted | The event raised to indicate that test exploration has started.
Public event | InitializeFinished | The event raised to indicate that the test runner initialization has finished.
Public event | InitializeStarted | The event raised to indicate that the test runner initialization has started.
Public event | LogMessage | The event raised to indicate that a log message was written by the test runner.
Public event | RunFinished | The event raised to indicate that test execution has finished.
Public event | RunStarted | The event raised to indicate that test execution has started.
Public event | TestModelAnnotationAdded | The event raised to indicate that an annotation was added to the test model.
Public event | TestModelSubtreeMerged | The event raised to indicate that a subtree of tests was merged into the test model.
Public event | TestStepFinished | The event raised to indicate that a test step has finished execution.
Public event | TestStepLifecyclePhaseChanged | The event raised to indicate that a test step has entered a new lifecycle phase.
Public event | TestStepLogAttach | The event raised to indicate that an attachment has been added to a test step log.
Public event | TestStepLogStreamBeginMarker | The event raised to indicate that a marker has been started within a test step log stream.
Public event | TestStepLogStreamBeginSection | The event raised to indicate that a section has been started within a test step log stream.
Public event | TestStepLogStreamEmbed | The event raised to indicate that an attachment has been embedded into a test step log stream.
Public event | TestStepLogStreamEnd | The event raised to indicate that a section has finished within a test step log stream.
Public event | TestStepLogStreamWrite | The event raised to indicate that text has been written to a test step log stream.
Public event | TestStepMetadataAdded | The event raised to indicate that a test step dynamically added metadata to itself.
Public event | TestStepStarted | The event raised to indicate that a test step has started execution.
Top

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


Events

ITestRunnerEvents Events
[image]

Public Events

 | Name | Description
Public event | DisposeFinished | The event raised to indicate that the test runner disposal has finished.
Public event | DisposeStarted | The event raised to indicate that the test runner disposal has started.
Public event | ExploreFinished | The event raised to indicate that test exploration has finished.
Public event | ExploreStarted | The event raised to indicate that test exploration has started.
Public event | InitializeFinished | The event raised to indicate that the test runner initialization has finished.
Public event | InitializeStarted | The event raised to indicate that the test runner initialization has started.
Public event | LogMessage | The event raised to indicate that a log message was written by the test runner.
Public event | RunFinished | The event raised to indicate that test execution has finished.
Public event | RunStarted | The event raised to indicate that test execution has started.
Public event | TestModelAnnotationAdded | The event raised to indicate that an annotation was added to the test model.
Public event | TestModelSubtreeMerged | The event raised to indicate that a subtree of tests was merged into the test model.
Public event | TestStepFinished | The event raised to indicate that a test step has finished execution.
Public event | TestStepLifecyclePhaseChanged | The event raised to indicate that a test step has entered a new lifecycle phase.
Public event | TestStepLogAttach | The event raised to indicate that an attachment has been added to a test step log.
Public event | TestStepLogStreamBeginMarker | The event raised to indicate that a marker has been started within a test step log stream.
Public event | TestStepLogStreamBeginSection | The event raised to indicate that a section has been started within a test step log stream.
Public event | TestStepLogStreamEmbed | The event raised to indicate that an attachment has been embedded into a test step log stream.
Public event | TestStepLogStreamEnd | The event raised to indicate that a section has finished within a test step log stream.
Public event | TestStepLogStreamWrite | The event raised to indicate that text has been written to a test step log stream.
Public event | TestStepMetadataAdded | The event raised to indicate that a test step dynamically added metadata to itself.
Public event | TestStepStarted | The event raised to indicate that a test step has started execution.
Top

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


DisposeFinished Event

ITestRunnerEvents.DisposeFinished Event
[image]

The event raised to indicate that the test runner disposal has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event DisposeFinished As EventHandler(Of DisposeFinishedEventArgs)
C#
abstract event EventHandler<DisposeFinishedEventArgs> DisposeFinished
C++
event EventHandler<DisposeFinishedEventArgs> DisposeFinished {
void add(EventHandler<DisposeFinishedEventArgs> value) abstract ;
void remove(EventHandler<DisposeFinishedEventArgs> value) abstract ;
}
J#
/** event */
void add_DisposeFinished(EventHandler<DisposeFinishedEventArgs> value);

/** event */
abstract void remove_DisposeFinished(EventHandler<DisposeFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type DisposeFinishedEventArgs containing data related to this event. The following DisposeFinishedEventArgs property provides information specific to this event.

Property | Description
Success | Returns true if the operation completed successfully.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


DisposeStarted Event

ITestRunnerEvents.DisposeStarted Event
[image]

The event raised to indicate that the test runner disposal has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event DisposeStarted As EventHandler(Of DisposeStartedEventArgs)
C#
abstract event EventHandler<DisposeStartedEventArgs> DisposeStarted
C++
event EventHandler<DisposeStartedEventArgs> DisposeStarted {
void add(EventHandler<DisposeStartedEventArgs> value) abstract ;
void remove(EventHandler<DisposeStartedEventArgs> value) abstract ;
}
J#
/** event */
void add_DisposeStarted(EventHandler<DisposeStartedEventArgs> value);

/** event */
abstract void remove_DisposeStarted(EventHandler<DisposeStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


ExploreFinished Event

ITestRunnerEvents.ExploreFinished Event
[image]

The event raised to indicate that test exploration has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event ExploreFinished As EventHandler(Of ExploreFinishedEventArgs)
C#
abstract event EventHandler<ExploreFinishedEventArgs> ExploreFinished
C++
event EventHandler<ExploreFinishedEventArgs> ExploreFinished {
void add(EventHandler<ExploreFinishedEventArgs> value) abstract ;
void remove(EventHandler<ExploreFinishedEventArgs> value) abstract ;
}
J#
/** event */
void add_ExploreFinished(EventHandler<ExploreFinishedEventArgs> value);

/** event */
abstract void remove_ExploreFinished(EventHandler<ExploreFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type ExploreFinishedEventArgs containing data related to this event. The following ExploreFinishedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report, including test model data on success.
Success | Returns true if the operation completed successfully.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


ExploreStarted Event

ITestRunnerEvents.ExploreStarted Event
[image]

The event raised to indicate that test exploration has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event ExploreStarted As EventHandler(Of ExploreStartedEventArgs)
C#
abstract event EventHandler<ExploreStartedEventArgs> ExploreStarted
C++
event EventHandler<ExploreStartedEventArgs> ExploreStarted {
void add(EventHandler<ExploreStartedEventArgs> value) abstract ;
void remove(EventHandler<ExploreStartedEventArgs> value) abstract ;
}
J#
/** event */
void add_ExploreStarted(EventHandler<ExploreStartedEventArgs> value);

/** event */
abstract void remove_ExploreStarted(EventHandler<ExploreStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type ExploreStartedEventArgs containing data related to this event. The following ExploreStartedEventArgs properties provide information specific to this event.

Property | Description
ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
TestExplorationOptions | Gets the test exploration options.
TestPackageConfig | Gets the test package configuration.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


InitializeFinished Event

ITestRunnerEvents.InitializeFinished Event
[image]

The event raised to indicate that the test runner initialization has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event InitializeFinished As EventHandler(Of InitializeFinishedEventArgs)
C#
abstract event EventHandler<InitializeFinishedEventArgs> InitializeFinished
C++
event EventHandler<InitializeFinishedEventArgs> InitializeFinished {
void add(EventHandler<InitializeFinishedEventArgs> value) abstract ;
void remove(EventHandler<InitializeFinishedEventArgs> value) abstract ;
}
J#
/** event */
void add_InitializeFinished(EventHandler<InitializeFinishedEventArgs> value);

/** event */
abstract void remove_InitializeFinished(EventHandler<InitializeFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type InitializeFinishedEventArgs containing data related to this event. The following InitializeFinishedEventArgs property provides information specific to this event.

Property | Description
Success | Returns true if the operation completed successfully.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


InitializeStarted Event

ITestRunnerEvents.InitializeStarted Event
[image]

The event raised to indicate that the test runner initialization has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event InitializeStarted As EventHandler(Of InitializeStartedEventArgs)
C#
abstract event EventHandler<InitializeStartedEventArgs> InitializeStarted
C++
event EventHandler<InitializeStartedEventArgs> InitializeStarted {
void add(EventHandler<InitializeStartedEventArgs> value) abstract ;
void remove(EventHandler<InitializeStartedEventArgs> value) abstract ;
}
J#
/** event */
void add_InitializeStarted(EventHandler<InitializeStartedEventArgs> value);

/** event */
abstract void remove_InitializeStarted(EventHandler<InitializeStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type InitializeStartedEventArgs containing data related to this event. The following InitializeStartedEventArgs property provides information specific to this event.

Property | Description
Options | Gets the test runner options.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


LogMessage Event

ITestRunnerEvents.LogMessage Event
[image]

The event raised to indicate that a log message was written by the test runner.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event LogMessage As EventHandler(Of LogMessageEventArgs)
C#
abstract event EventHandler<LogMessageEventArgs> LogMessage
C++
event EventHandler<LogMessageEventArgs> LogMessage {
void add(EventHandler<LogMessageEventArgs> value) abstract ;
void remove(EventHandler<LogMessageEventArgs> value) abstract ;
}
J#
/** event */
void add_LogMessage(EventHandler<LogMessageEventArgs> value);

/** event */
abstract void remove_LogMessage(EventHandler<LogMessageEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

The runner automatically writes out these log messages to the logger with which it is initialized. These events are raised to allow other subscribers to receive log messages as well.

Event Data

The event handler receives an argument of type LogMessageEventArgs containing data related to this event. The following LogMessageEventArgs properties provide information specific to this event.

Property | Description
ExceptionData | Gets the exception, or null if none.
Message | Gets the log message.
Severity | Gets the log severity.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


RunFinished Event

ITestRunnerEvents.RunFinished Event
[image]

The event raised to indicate that test execution has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event RunFinished As EventHandler(Of RunFinishedEventArgs)
C#
abstract event EventHandler<RunFinishedEventArgs> RunFinished
C++
event EventHandler<RunFinishedEventArgs> RunFinished {
void add(EventHandler<RunFinishedEventArgs> value) abstract ;
void remove(EventHandler<RunFinishedEventArgs> value) abstract ;
}
J#
/** event */
void add_RunFinished(EventHandler<RunFinishedEventArgs> value);

/** event */
abstract void remove_RunFinished(EventHandler<RunFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type RunFinishedEventArgs containing data related to this event. The following RunFinishedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report, including test package run data on success.
Success | Returns true if the operation completed successfully.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


RunStarted Event

ITestRunnerEvents.RunStarted Event
[image]

The event raised to indicate that test execution has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event RunStarted As EventHandler(Of RunStartedEventArgs)
C#
abstract event EventHandler<RunStartedEventArgs> RunStarted
C++
event EventHandler<RunStartedEventArgs> RunStarted {
void add(EventHandler<RunStartedEventArgs> value) abstract ;
void remove(EventHandler<RunStartedEventArgs> value) abstract ;
}
J#
/** event */
void add_RunStarted(EventHandler<RunStartedEventArgs> value);

/** event */
abstract void remove_RunStarted(EventHandler<RunStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type RunStartedEventArgs containing data related to this event. The following RunStartedEventArgs properties provide information specific to this event.

Property | Description
ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
TestExecutionOptions | Gets the test execution options.
TestExplorationOptions | Gets the test exploration options.
TestPackageConfig | Gets the test package configuration.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestModelAnnotationAdded Event

ITestRunnerEvents.TestModelAnnotationAdded Event
[image]

The event raised to indicate that an annotation was added to the test model.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestModelAnnotationAdded As EventHandler(Of TestModelAnnotationAddedEventArgs)
C#
abstract event EventHandler<TestModelAnnotationAddedEventArgs> TestModelAnnotationAdded
C++
event EventHandler<TestModelAnnotationAddedEventArgs> TestModelAnnotationAdded {
void add(EventHandler<TestModelAnnotationAddedEventArgs> value) abstract ;
void remove(EventHandler<TestModelAnnotationAddedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestModelAnnotationAdded(EventHandler<TestModelAnnotationAddedEventArgs> value);

/** event */
abstract void remove_TestModelAnnotationAdded(EventHandler<TestModelAnnotationAddedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestModelAnnotationAddedEventArgs containing data related to this event. The following TestModelAnnotationAddedEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that was added.
Report | Gets the report.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestModelSubtreeMerged Event

ITestRunnerEvents.TestModelSubtreeMerged Event
[image]

The event raised to indicate that a subtree of tests was merged into the test model.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestModelSubtreeMerged As EventHandler(Of TestModelSubtreeMergedEventArgs)
C#
abstract event EventHandler<TestModelSubtreeMergedEventArgs> TestModelSubtreeMerged
C++
event EventHandler<TestModelSubtreeMergedEventArgs> TestModelSubtreeMerged {
void add(EventHandler<TestModelSubtreeMergedEventArgs> value) abstract ;
void remove(EventHandler<TestModelSubtreeMergedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestModelSubtreeMerged(EventHandler<TestModelSubtreeMergedEventArgs> value);

/** event */
abstract void remove_TestModelSubtreeMerged(EventHandler<TestModelSubtreeMergedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestModelSubtreeMergedEventArgs containing data related to this event. The following TestModelSubtreeMergedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report.
Test | Gets the test at the top of the subtree that was merged.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepFinished Event

ITestRunnerEvents.TestStepFinished Event
[image]

The event raised to indicate that a test step has finished execution.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepFinished As EventHandler(Of TestStepFinishedEventArgs)
C#
abstract event EventHandler<TestStepFinishedEventArgs> TestStepFinished
C++
event EventHandler<TestStepFinishedEventArgs> TestStepFinished {
void add(EventHandler<TestStepFinishedEventArgs> value) abstract ;
void remove(EventHandler<TestStepFinishedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepFinished(EventHandler<TestStepFinishedEventArgs> value);

/** event */
abstract void remove_TestStepFinished(EventHandler<TestStepFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepFinishedEventArgs containing data related to this event. The following TestStepFinishedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLifecyclePhaseChanged Event

ITestRunnerEvents.TestStepLifecyclePhaseChanged Event
[image]

The event raised to indicate that a test step has entered a new lifecycle phase.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLifecyclePhaseChanged As EventHandler(Of TestStepLifecyclePhaseChangedEventArgs)
C#
abstract event EventHandler<TestStepLifecyclePhaseChangedEventArgs> TestStepLifecyclePhaseChanged
C++
event EventHandler<TestStepLifecyclePhaseChangedEventArgs> TestStepLifecyclePhaseChanged {
void add(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value) abstract ;
void remove(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLifecyclePhaseChanged(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value);

/** event */
abstract void remove_TestStepLifecyclePhaseChanged(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLifecyclePhaseChangedEventArgs containing data related to this event. The following TestStepLifecyclePhaseChangedEventArgs properties provide information specific to this event.

Property | Description
LifecyclePhase | Gets the lifecycle phase name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLogAttach Event

ITestRunnerEvents.TestStepLogAttach Event
[image]

The event raised to indicate that an attachment has been added to a test step log.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLogAttach As EventHandler(Of TestStepLogAttachEventArgs)
C#
abstract event EventHandler<TestStepLogAttachEventArgs> TestStepLogAttach
C++
event EventHandler<TestStepLogAttachEventArgs> TestStepLogAttach {
void add(EventHandler<TestStepLogAttachEventArgs> value) abstract ;
void remove(EventHandler<TestStepLogAttachEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLogAttach(EventHandler<TestStepLogAttachEventArgs> value);

/** event */
abstract void remove_TestStepLogAttach(EventHandler<TestStepLogAttachEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLogAttachEventArgs containing data related to this event. The following TestStepLogAttachEventArgs properties provide information specific to this event.

Property | Description
Attachment | Gets the attachment.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLogStreamBeginMarker Event

ITestRunnerEvents.TestStepLogStreamBeginMarker Event
[image]

The event raised to indicate that a marker has been started within a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLogStreamBeginMarker As EventHandler(Of TestStepLogStreamBeginMarkerEventArgs)
C#
abstract event EventHandler<TestStepLogStreamBeginMarkerEventArgs> TestStepLogStreamBeginMarker
C++
event EventHandler<TestStepLogStreamBeginMarkerEventArgs> TestStepLogStreamBeginMarker {
void add(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value) abstract ;
void remove(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLogStreamBeginMarker(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value);

/** event */
abstract void remove_TestStepLogStreamBeginMarker(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLogStreamBeginMarkerEventArgs containing data related to this event. The following TestStepLogStreamBeginMarkerEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Marker | Gets the marker.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLogStreamBeginSection Event

ITestRunnerEvents.TestStepLogStreamBeginSection Event
[image]

The event raised to indicate that a section has been started within a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLogStreamBeginSection As EventHandler(Of TestStepLogStreamBeginSectionEventArgs)
C#
abstract event EventHandler<TestStepLogStreamBeginSectionEventArgs> TestStepLogStreamBeginSection
C++
event EventHandler<TestStepLogStreamBeginSectionEventArgs> TestStepLogStreamBeginSection {
void add(EventHandler<TestStepLogStreamBeginSectionEventArgs> value) abstract ;
void remove(EventHandler<TestStepLogStreamBeginSectionEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLogStreamBeginSection(EventHandler<TestStepLogStreamBeginSectionEventArgs> value);

/** event */
abstract void remove_TestStepLogStreamBeginSection(EventHandler<TestStepLogStreamBeginSectionEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLogStreamBeginSectionEventArgs containing data related to this event. The following TestStepLogStreamBeginSectionEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Report | Gets the report.
SectionName | Gets the name of the section that was started.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLogStreamEmbed Event

ITestRunnerEvents.TestStepLogStreamEmbed Event
[image]

The event raised to indicate that an attachment has been embedded into a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLogStreamEmbed As EventHandler(Of TestStepLogStreamEmbedEventArgs)
C#
abstract event EventHandler<TestStepLogStreamEmbedEventArgs> TestStepLogStreamEmbed
C++
event EventHandler<TestStepLogStreamEmbedEventArgs> TestStepLogStreamEmbed {
void add(EventHandler<TestStepLogStreamEmbedEventArgs> value) abstract ;
void remove(EventHandler<TestStepLogStreamEmbedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLogStreamEmbed(EventHandler<TestStepLogStreamEmbedEventArgs> value);

/** event */
abstract void remove_TestStepLogStreamEmbed(EventHandler<TestStepLogStreamEmbedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLogStreamEmbedEventArgs containing data related to this event. The following TestStepLogStreamEmbedEventArgs properties provide information specific to this event.

Property | Description
AttachmentName | Gets the name of the attachment that was embedded.
LogStreamName | Gets the log stream name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLogStreamEnd Event

ITestRunnerEvents.TestStepLogStreamEnd Event
[image]

The event raised to indicate that a section has finished within a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLogStreamEnd As EventHandler(Of TestStepLogStreamEndEventArgs)
C#
abstract event EventHandler<TestStepLogStreamEndEventArgs> TestStepLogStreamEnd
C++
event EventHandler<TestStepLogStreamEndEventArgs> TestStepLogStreamEnd {
void add(EventHandler<TestStepLogStreamEndEventArgs> value) abstract ;
void remove(EventHandler<TestStepLogStreamEndEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLogStreamEnd(EventHandler<TestStepLogStreamEndEventArgs> value);

/** event */
abstract void remove_TestStepLogStreamEnd(EventHandler<TestStepLogStreamEndEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLogStreamEndEventArgs containing data related to this event. The following TestStepLogStreamEndEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepLogStreamWrite Event

ITestRunnerEvents.TestStepLogStreamWrite Event
[image]

The event raised to indicate that text has been written to a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepLogStreamWrite As EventHandler(Of TestStepLogStreamWriteEventArgs)
C#
abstract event EventHandler<TestStepLogStreamWriteEventArgs> TestStepLogStreamWrite
C++
event EventHandler<TestStepLogStreamWriteEventArgs> TestStepLogStreamWrite {
void add(EventHandler<TestStepLogStreamWriteEventArgs> value) abstract ;
void remove(EventHandler<TestStepLogStreamWriteEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepLogStreamWrite(EventHandler<TestStepLogStreamWriteEventArgs> value);

/** event */
abstract void remove_TestStepLogStreamWrite(EventHandler<TestStepLogStreamWriteEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepLogStreamWriteEventArgs containing data related to this event. The following TestStepLogStreamWriteEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.
Text | Gets the text that was written.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepMetadataAdded Event

ITestRunnerEvents.TestStepMetadataAdded Event
[image]

The event raised to indicate that a test step dynamically added metadata to itself.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepMetadataAdded As EventHandler(Of TestStepMetadataAddedEventArgs)
C#
abstract event EventHandler<TestStepMetadataAddedEventArgs> TestStepMetadataAdded
C++
event EventHandler<TestStepMetadataAddedEventArgs> TestStepMetadataAdded {
void add(EventHandler<TestStepMetadataAddedEventArgs> value) abstract ;
void remove(EventHandler<TestStepMetadataAddedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepMetadataAdded(EventHandler<TestStepMetadataAddedEventArgs> value);

/** event */
abstract void remove_TestStepMetadataAdded(EventHandler<TestStepMetadataAddedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepMetadataAddedEventArgs containing data related to this event. The following TestStepMetadataAddedEventArgs properties provide information specific to this event.

Property | Description
MetadataKey | Gets the metadata key.
MetadataValue | Gets the metadata value.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


TestStepStarted Event

ITestRunnerEvents.TestStepStarted Event
[image]

The event raised to indicate that a test step has started execution.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event TestStepStarted As EventHandler(Of TestStepStartedEventArgs)
C#
abstract event EventHandler<TestStepStartedEventArgs> TestStepStarted
C++
event EventHandler<TestStepStartedEventArgs> TestStepStarted {
void add(EventHandler<TestStepStartedEventArgs> value) abstract ;
void remove(EventHandler<TestStepStartedEventArgs> value) abstract ;
}
J#
/** event */
void add_TestStepStarted(EventHandler<TestStepStartedEventArgs> value);

/** event */
abstract void remove_TestStepStarted(EventHandler<TestStepStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type TestStepStartedEventArgs containing data related to this event. The following TestStepStartedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

ITestRunnerEvents Interface
Gallio.Runner.Events Namespace


RunFinishedEventArgs Class

RunFinishedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that test execution has finished. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RunFinishedEventArgs
Inherits OperationFinishedEventArgs
C#
public sealed class RunFinishedEventArgs : OperationFinishedEventArgs
C++
ref class RunFinishedEventArgs sealed : OperationFinishedEventArgs
J#
public final class RunFinishedEventArgs extends OperationFinishedEventArgs
JScript
public final class RunFinishedEventArgs extends OperationFinishedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.Events.RunFinishedEventArgs

See Also

RunFinishedEventArgs Members
Gallio.Runner.Events Namespace


RunFinishedEventArgs Members

RunFinishedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that test execution has finished. This class cannot be inherited.

The following tables list the members exposed by RunFinishedEventArgs.

Public Constructors

 | Name | Description
Public method | RunFinishedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report, including test package run data on success.
Public property | Success | Returns true if the operation completed successfully. (inherited from OperationFinishedEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RunFinishedEventArgs Class
Gallio.Runner.Events Namespace


RunFinishedEventArgs Constructor

RunFinishedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal success As Boolean, _
ByVal report As Report _
)
C#
public RunFinishedEventArgs(
bool success,
Report report
)
C++
public:
RunFinishedEventArgs(
bool success,
Report report
) sealed
J#
public RunFinishedEventArgs(
bool success,
Report report
)
JScript
public function RunFinishedEventArgs(
success : bool,
report : Report
)

Parameters

success
True if test execution was successful
report
The report, including test package run data on success

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report is null

See Also

RunFinishedEventArgs Class
Gallio.Runner.Events Namespace


Properties

RunFinishedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the report, including test package run data on success.
Public property | Success | Returns true if the operation completed successfully. (inherited from OperationFinishedEventArgs)
Top

See Also

RunFinishedEventArgs Class
Gallio.Runner.Events Namespace


Report Property

RunFinishedEventArgs.Report Property
[image]

Gets the report, including test package run data on success.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

RunFinishedEventArgs Class
Gallio.Runner.Events Namespace


RunStartedEventArgs Class

RunStartedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that test execution has started. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class RunStartedEventArgs
Inherits OperationStartedEventArgs
C#
public sealed class RunStartedEventArgs : OperationStartedEventArgs
C++
ref class RunStartedEventArgs sealed : OperationStartedEventArgs
J#
public final class RunStartedEventArgs extends OperationStartedEventArgs
JScript
public final class RunStartedEventArgs extends OperationStartedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.OperationStartedEventArgs
Gallio.Runner.Events.RunStartedEventArgs

See Also

RunStartedEventArgs Members
Gallio.Runner.Events Namespace


RunStartedEventArgs Members

RunStartedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that test execution has started. This class cannot be inherited.

The following tables list the members exposed by RunStartedEventArgs.

Public Constructors

 | Name | Description
Public method | RunStartedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
Public property | TestExecutionOptions | Gets the test execution options.
Public property | TestExplorationOptions | Gets the test exploration options.
Public property | TestPackageConfig | Gets the test package configuration.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


RunStartedEventArgs Constructor

RunStartedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testPackageConfig As TestPackageConfig, _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal reportLockBox As LockBox(Of Report) _
)
C#
public RunStartedEventArgs(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
LockBox<Report> reportLockBox
)
C++
public:
RunStartedEventArgs(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
LockBox<Report> reportLockBox
) sealed
J#
public RunStartedEventArgs(
TestPackageConfig testPackageConfig,
TestExplorationOptions testExplorationOptions,
TestExecutionOptions testExecutionOptions,
LockBox<Report> reportLockBox
)
JScript
public function RunStartedEventArgs(
testPackageConfig : TestPackageConfig,
testExplorationOptions : TestExplorationOptions,
testExecutionOptions : TestExecutionOptions,
reportLockBox : LockBox<Report>
)

Parameters

testPackageConfig
The test package configuration
testExplorationOptions
The test exploration options
testExecutionOptions
The test execution options
reportLockBox
The report lock-box which may be used to access the report asynchronously during execution

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testPackageConfig, testExplorationOptions or testExecutionOptions is null

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


Properties

RunStartedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
Public property | TestExecutionOptions | Gets the test execution options.
Public property | TestExplorationOptions | Gets the test exploration options.
Public property | TestPackageConfig | Gets the test package configuration.
Top

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


ReportLockBox Property

RunStartedEventArgs.ReportLockBox Property
[image]

Gets the report lock-box which may be used to access the report asynchronously during execution.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportLockBox As LockBox(Of Report)
C#
public LockBox<Report> ReportLockBox { get; }
C++
public property LockBox<Report> ReportLockBox sealed {
LockBox<Report> get();
}
J#
/** property */
public LockBox<Report> get_ReportLockBox();
JScript
public function get ReportLockBox() : LockBox<Report>

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


TestExecutionOptions Property

RunStartedEventArgs.TestExecutionOptions Property
[image]

Gets the test execution options.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestExecutionOptions As TestExecutionOptions
C#
public TestExecutionOptions TestExecutionOptions { get; }
C++
public property TestExecutionOptions TestExecutionOptions sealed {
TestExecutionOptions get();
}
J#
/** property */
public TestExecutionOptions get_TestExecutionOptions();
JScript
public function get TestExecutionOptions() : TestExecutionOptions

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


TestExplorationOptions Property

RunStartedEventArgs.TestExplorationOptions Property
[image]

Gets the test exploration options.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestExplorationOptions As TestExplorationOptions
C#
public TestExplorationOptions TestExplorationOptions { get; }
C++
public property TestExplorationOptions TestExplorationOptions sealed {
TestExplorationOptions get();
}
J#
/** property */
public TestExplorationOptions get_TestExplorationOptions();
JScript
public function get TestExplorationOptions() : TestExplorationOptions

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


TestPackageConfig Property

RunStartedEventArgs.TestPackageConfig Property
[image]

Gets the test package configuration.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestPackageConfig As TestPackageConfig
C#
public TestPackageConfig TestPackageConfig { get; }
C++
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
}
J#
/** property */
public TestPackageConfig get_TestPackageConfig();
JScript
public function get TestPackageConfig() : TestPackageConfig

See Also

RunStartedEventArgs Class
Gallio.Runner.Events Namespace


TestModelAnnotationAddedEventArgs Class

TestModelAnnotationAddedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to signal that an annotation has been added to the test model. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestModelAnnotationAddedEventArgs
Inherits EventArgs
C#
public sealed class TestModelAnnotationAddedEventArgs : EventArgs
C++
ref class TestModelAnnotationAddedEventArgs sealed : EventArgs
J#
public final class TestModelAnnotationAddedEventArgs extends EventArgs
JScript
public final class TestModelAnnotationAddedEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestModelAnnotationAddedEventArgs

See Also

TestModelAnnotationAddedEventArgs Members
Gallio.Runner.Events Namespace


TestModelAnnotationAddedEventArgs Members

TestModelAnnotationAddedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to signal that an annotation has been added to the test model. This class cannot be inherited.

The following tables list the members exposed by TestModelAnnotationAddedEventArgs.

Public Constructors

 | Name | Description
Public method | TestModelAnnotationAddedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Annotation | Gets the annotation that was added.
Public property | Report | Gets the report.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestModelAnnotationAddedEventArgs Class
Gallio.Runner.Events Namespace


TestModelAnnotationAddedEventArgs Constructor

TestModelAnnotationAddedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal annotation As AnnotationData _
)
C#
public TestModelAnnotationAddedEventArgs(
Report report,
AnnotationData annotation
)
C++
public:
TestModelAnnotationAddedEventArgs(
Report report,
AnnotationData annotation
) sealed
J#
public TestModelAnnotationAddedEventArgs(
Report report,
AnnotationData annotation
)
JScript
public function TestModelAnnotationAddedEventArgs(
report : Report,
annotation : AnnotationData
)

Parameters

report
The report
annotation
The annotation that was added

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report is null

See Also

TestModelAnnotationAddedEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestModelAnnotationAddedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Annotation | Gets the annotation that was added.
Public property | Report | Gets the report.
Top

See Also

TestModelAnnotationAddedEventArgs Class
Gallio.Runner.Events Namespace


Annotation Property

TestModelAnnotationAddedEventArgs.Annotation Property
[image]

Gets the annotation that was added.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Annotation As AnnotationData
C#
public AnnotationData Annotation { get; }
C++
public property AnnotationData Annotation sealed {
AnnotationData get();
}
J#
/** property */
public AnnotationData get_Annotation();
JScript
public function get Annotation() : AnnotationData

See Also

TestModelAnnotationAddedEventArgs Class
Gallio.Runner.Events Namespace


Report Property

TestModelAnnotationAddedEventArgs.Report Property
[image]

Gets the report.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

TestModelAnnotationAddedEventArgs Class
Gallio.Runner.Events Namespace


TestModelSubtreeMergedEventArgs Class

TestModelSubtreeMergedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to signal that a subtree of tests has been merged into the test model. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestModelSubtreeMergedEventArgs
Inherits EventArgs
C#
public sealed class TestModelSubtreeMergedEventArgs : EventArgs
C++
ref class TestModelSubtreeMergedEventArgs sealed : EventArgs
J#
public final class TestModelSubtreeMergedEventArgs extends EventArgs
JScript
public final class TestModelSubtreeMergedEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestModelSubtreeMergedEventArgs

See Also

TestModelSubtreeMergedEventArgs Members
Gallio.Runner.Events Namespace


TestModelSubtreeMergedEventArgs Members

TestModelSubtreeMergedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to signal that a subtree of tests has been merged into the test model. This class cannot be inherited.

The following tables list the members exposed by TestModelSubtreeMergedEventArgs.

Public Constructors

 | Name | Description
Public method | TestModelSubtreeMergedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report.
Public property | Test | Gets the test at the top of the subtree that was merged.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestModelSubtreeMergedEventArgs Class
Gallio.Runner.Events Namespace


TestModelSubtreeMergedEventArgs Constructor

TestModelSubtreeMergedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData _
)
C#
public TestModelSubtreeMergedEventArgs(
Report report,
TestData test
)
C++
public:
TestModelSubtreeMergedEventArgs(
Report report,
TestData test
) sealed
J#
public TestModelSubtreeMergedEventArgs(
Report report,
TestData test
)
JScript
public function TestModelSubtreeMergedEventArgs(
report : Report,
test : TestData
)

Parameters

report
The report
test
The test at the top of the subtree that was added

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report is null

See Also

TestModelSubtreeMergedEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestModelSubtreeMergedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the report.
Public property | Test | Gets the test at the top of the subtree that was merged.
Top

See Also

TestModelSubtreeMergedEventArgs Class
Gallio.Runner.Events Namespace


Report Property

TestModelSubtreeMergedEventArgs.Report Property
[image]

Gets the report.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

TestModelSubtreeMergedEventArgs Class
Gallio.Runner.Events Namespace


Test Property

TestModelSubtreeMergedEventArgs.Test Property
[image]

Gets the test at the top of the subtree that was merged.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As TestData
C#
public TestData Test { get; }
C++
public property TestData Test sealed {
TestData get();
}
J#
/** property */
public TestData get_Test();
JScript
public function get Test() : TestData

See Also

TestModelSubtreeMergedEventArgs Class
Gallio.Runner.Events Namespace


TestRunnerEventDispatcher Class

TestRunnerEventDispatcher Class
See Also Example Members
[image]

Dispatches test runner events to listeners. Each notification function ensures that the event is safely dispatched via SafeInvoke. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestRunnerEventDispatcher
Implements ITestRunnerEvents
C#
public sealed class TestRunnerEventDispatcher : ITestRunnerEvents
C++
ref class TestRunnerEventDispatcher sealed : ITestRunnerEvents
J#
public final class TestRunnerEventDispatcher implements ITestRunnerEvents
JScript
public final class TestRunnerEventDispatcher extends ITestRunnerEvents

Inheritance Hierarchy

System.Object
Gallio.Runner.Events.TestRunnerEventDispatcher

See Also

TestRunnerEventDispatcher Members
Gallio.Runner.Events Namespace


TestRunnerEventDispatcher Members

TestRunnerEventDispatcher Members
See Also Example Constructors Methods Events
[image]

Dispatches test runner events to listeners. Each notification function ensures that the event is safely dispatched via SafeInvoke. This class cannot be inherited.

The following tables list the members exposed by TestRunnerEventDispatcher.

Public Constructors

 | Name | Description
Public method | TestRunnerEventDispatcher | Initializes a new instance of the TestRunnerEventDispatcher class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | NotifyDisposeFinished | Dispatches the DisposeFinished event.
Public method | NotifyDisposeStarted | Dispatches the DisposeStarted event.
Public method | NotifyExploreFinished | Dispatches the ExploreFinished event.
Public method | NotifyExploreStarted | Dispatches the ExploreStarted event.
Public method | NotifyInitializeFinished | Dispatches the InitializeFinished event.
Public method | NotifyInitializeStarted | Dispatches the InitializeStarted event.
Public method | NotifyLogMessage | Dispatches the LogMessage event.
Public method | NotifyRunFinished | Dispatches the RunFinished event.
Public method | NotifyRunStarted | Dispatches the RunStarted event.
Public method | NotifyTestModelAnnotationAdded | Dispatches the TestModelAnnotationAdded event.
Public method | NotifyTestModelSubtreeMerged | Dispatches the TestModelSubtreeMerged event.
Public method | NotifyTestStepFinished | Dispatches the TestStepFinished event.
Public method | NotifyTestStepLifecyclePhaseChanged | Dispatches the TestStepLifecyclePhaseChanged event.
Public method | NotifyTestStepLogAttach | Dispatches the TestStepLogAttach event.
Public method | NotifyTestStepLogStreamBeginMarker | Dispatches the TestStepLogStreamBeginMarker event.
Public method | NotifyTestStepLogStreamBeginSection | Dispatches the TestStepLogStreamBeginSection event.
Public method | NotifyTestStepLogStreamEmbed | Dispatches the TestStepLogStreamEmbed event.
Public method | NotifyTestStepLogStreamEnd | Dispatches the TestStepLogStreamEnd event.
Public method | NotifyTestStepLogStreamWrite | Dispatches the TestStepLogStreamWrite event.
Public method | NotifyTestStepMetadataAdded | Dispatches the TestStepMetadataAdded event.
Public method | NotifyTestStepStarted | Dispatches the TestStepStarted event.
Public method | SubscribeTo | Subscribes to another event object such that the events will be forwarded to the handlers registered on this dispatcher.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | DisposeFinished | The event raised to indicate that the test runner disposal has finished.
Public event | DisposeStarted | The event raised to indicate that the test runner disposal has started.
Public event | ExploreFinished | The event raised to indicate that test exploration has finished.
Public event | ExploreStarted | The event raised to indicate that test exploration has started.
Public event | InitializeFinished | The event raised to indicate that the test runner initialization has finished.
Public event | InitializeStarted | The event raised to indicate that the test runner initialization has started.
Public event | LogMessage | The event raised to indicate that a log message was written by the test runner.
Public event | RunFinished | The event raised to indicate that test execution has finished.
Public event | RunStarted | The event raised to indicate that test execution has started.
Public event | TestModelAnnotationAdded | The event raised to indicate that an annotation was added to the test model.
Public event | TestModelSubtreeMerged | The event raised to indicate that a subtree of tests was merged into the test model.
Public event | TestStepFinished | The event raised to indicate that a test step has finished execution.
Public event | TestStepLifecyclePhaseChanged | The event raised to indicate that a test step has entered a new lifecycle phase.
Public event | TestStepLogAttach | The event raised to indicate that an attachment has been added to a test step log.
Public event | TestStepLogStreamBeginMarker | The event raised to indicate that a marker has been started within a test step log stream.
Public event | TestStepLogStreamBeginSection | The event raised to indicate that a section has been started within a test step log stream.
Public event | TestStepLogStreamEmbed | The event raised to indicate that an attachment has been embedded into a test step log stream.
Public event | TestStepLogStreamEnd | The event raised to indicate that a section has finished within a test step log stream.
Public event | TestStepLogStreamWrite | The event raised to indicate that text has been written to a test step log stream.
Public event | TestStepMetadataAdded | The event raised to indicate that a test step dynamically added metadata to itself.
Public event | TestStepStarted | The event raised to indicate that a test step has started execution.
Top

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestRunnerEventDispatcher Constructor

TestRunnerEventDispatcher Constructor
[image]

Initializes a new instance of the TestRunnerEventDispatcher class.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestRunnerEventDispatcher()
C++
public:
TestRunnerEventDispatcher() sealed
J#
public TestRunnerEventDispatcher()
JScript
public function TestRunnerEventDispatcher()

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


Methods

TestRunnerEventDispatcher Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | NotifyDisposeFinished | Dispatches the DisposeFinished event.
Public method | NotifyDisposeStarted | Dispatches the DisposeStarted event.
Public method | NotifyExploreFinished | Dispatches the ExploreFinished event.
Public method | NotifyExploreStarted | Dispatches the ExploreStarted event.
Public method | NotifyInitializeFinished | Dispatches the InitializeFinished event.
Public method | NotifyInitializeStarted | Dispatches the InitializeStarted event.
Public method | NotifyLogMessage | Dispatches the LogMessage event.
Public method | NotifyRunFinished | Dispatches the RunFinished event.
Public method | NotifyRunStarted | Dispatches the RunStarted event.
Public method | NotifyTestModelAnnotationAdded | Dispatches the TestModelAnnotationAdded event.
Public method | NotifyTestModelSubtreeMerged | Dispatches the TestModelSubtreeMerged event.
Public method | NotifyTestStepFinished | Dispatches the TestStepFinished event.
Public method | NotifyTestStepLifecyclePhaseChanged | Dispatches the TestStepLifecyclePhaseChanged event.
Public method | NotifyTestStepLogAttach | Dispatches the TestStepLogAttach event.
Public method | NotifyTestStepLogStreamBeginMarker | Dispatches the TestStepLogStreamBeginMarker event.
Public method | NotifyTestStepLogStreamBeginSection | Dispatches the TestStepLogStreamBeginSection event.
Public method | NotifyTestStepLogStreamEmbed | Dispatches the TestStepLogStreamEmbed event.
Public method | NotifyTestStepLogStreamEnd | Dispatches the TestStepLogStreamEnd event.
Public method | NotifyTestStepLogStreamWrite | Dispatches the TestStepLogStreamWrite event.
Public method | NotifyTestStepMetadataAdded | Dispatches the TestStepMetadataAdded event.
Public method | NotifyTestStepStarted | Dispatches the TestStepStarted event.
Public method | SubscribeTo | Subscribes to another event object such that the events will be forwarded to the handlers registered on this dispatcher.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyDisposeFinished Method

TestRunnerEventDispatcher.NotifyDisposeFinished Method
[image]

Dispatches the DisposeFinished event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyDisposeFinished( _
ByVal e As DisposeFinishedEventArgs _
)
C#
public void NotifyDisposeFinished(
DisposeFinishedEventArgs e
)
C++
public:
void NotifyDisposeFinished(
DisposeFinishedEventArgs e
) sealed
J#
public void NotifyDisposeFinished(
DisposeFinishedEventArgs e
)
JScript
public function NotifyDisposeFinished(
e : DisposeFinishedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyDisposeStarted Method

TestRunnerEventDispatcher.NotifyDisposeStarted Method
[image]

Dispatches the DisposeStarted event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyDisposeStarted( _
ByVal e As DisposeStartedEventArgs _
)
C#
public void NotifyDisposeStarted(
DisposeStartedEventArgs e
)
C++
public:
void NotifyDisposeStarted(
DisposeStartedEventArgs e
) sealed
J#
public void NotifyDisposeStarted(
DisposeStartedEventArgs e
)
JScript
public function NotifyDisposeStarted(
e : DisposeStartedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyExploreFinished Method

TestRunnerEventDispatcher.NotifyExploreFinished Method
[image]

Dispatches the ExploreFinished event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyExploreFinished( _
ByVal e As ExploreFinishedEventArgs _
)
C#
public void NotifyExploreFinished(
ExploreFinishedEventArgs e
)
C++
public:
void NotifyExploreFinished(
ExploreFinishedEventArgs e
) sealed
J#
public void NotifyExploreFinished(
ExploreFinishedEventArgs e
)
JScript
public function NotifyExploreFinished(
e : ExploreFinishedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyExploreStarted Method

TestRunnerEventDispatcher.NotifyExploreStarted Method
[image]

Dispatches the ExploreStarted event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyExploreStarted( _
ByVal e As ExploreStartedEventArgs _
)
C#
public void NotifyExploreStarted(
ExploreStartedEventArgs e
)
C++
public:
void NotifyExploreStarted(
ExploreStartedEventArgs e
) sealed
J#
public void NotifyExploreStarted(
ExploreStartedEventArgs e
)
JScript
public function NotifyExploreStarted(
e : ExploreStartedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyInitializeFinished Method

TestRunnerEventDispatcher.NotifyInitializeFinished Method
[image]

Dispatches the InitializeFinished event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyInitializeFinished( _
ByVal e As InitializeFinishedEventArgs _
)
C#
public void NotifyInitializeFinished(
InitializeFinishedEventArgs e
)
C++
public:
void NotifyInitializeFinished(
InitializeFinishedEventArgs e
) sealed
J#
public void NotifyInitializeFinished(
InitializeFinishedEventArgs e
)
JScript
public function NotifyInitializeFinished(
e : InitializeFinishedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyInitializeStarted Method

TestRunnerEventDispatcher.NotifyInitializeStarted Method
[image]

Dispatches the InitializeStarted event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyInitializeStarted( _
ByVal e As InitializeStartedEventArgs _
)
C#
public void NotifyInitializeStarted(
InitializeStartedEventArgs e
)
C++
public:
void NotifyInitializeStarted(
InitializeStartedEventArgs e
) sealed
J#
public void NotifyInitializeStarted(
InitializeStartedEventArgs e
)
JScript
public function NotifyInitializeStarted(
e : InitializeStartedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyLogMessage Method

TestRunnerEventDispatcher.NotifyLogMessage Method
[image]

Dispatches the LogMessage event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyLogMessage( _
ByVal e As LogMessageEventArgs _
)
C#
public void NotifyLogMessage(
LogMessageEventArgs e
)
C++
public:
void NotifyLogMessage(
LogMessageEventArgs e
) sealed
J#
public void NotifyLogMessage(
LogMessageEventArgs e
)
JScript
public function NotifyLogMessage(
e : LogMessageEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyRunFinished Method

TestRunnerEventDispatcher.NotifyRunFinished Method
[image]

Dispatches the RunFinished event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyRunFinished( _
ByVal e As RunFinishedEventArgs _
)
C#
public void NotifyRunFinished(
RunFinishedEventArgs e
)
C++
public:
void NotifyRunFinished(
RunFinishedEventArgs e
) sealed
J#
public void NotifyRunFinished(
RunFinishedEventArgs e
)
JScript
public function NotifyRunFinished(
e : RunFinishedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyRunStarted Method

TestRunnerEventDispatcher.NotifyRunStarted Method
[image]

Dispatches the RunStarted event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyRunStarted( _
ByVal e As RunStartedEventArgs _
)
C#
public void NotifyRunStarted(
RunStartedEventArgs e
)
C++
public:
void NotifyRunStarted(
RunStartedEventArgs e
) sealed
J#
public void NotifyRunStarted(
RunStartedEventArgs e
)
JScript
public function NotifyRunStarted(
e : RunStartedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestModelAnnotationAdded Method

TestRunnerEventDispatcher.NotifyTestModelAnnotationAdded Method
See Also Example
[image]

Dispatches the TestModelAnnotationAdded event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestModelAnnotationAdded( _
ByVal e As TestModelAnnotationAddedEventArgs _
)
C#
public void NotifyTestModelAnnotationAdded(
TestModelAnnotationAddedEventArgs e
)
C++
public:
void NotifyTestModelAnnotationAdded(
TestModelAnnotationAddedEventArgs e
) sealed
J#
public void NotifyTestModelAnnotationAdded(
TestModelAnnotationAddedEventArgs e
)
JScript
public function NotifyTestModelAnnotationAdded(
e : TestModelAnnotationAddedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestModelSubtreeMerged Method

TestRunnerEventDispatcher.NotifyTestModelSubtreeMerged Method
See Also Example
[image]

Dispatches the TestModelSubtreeMerged event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestModelSubtreeMerged( _
ByVal e As TestModelSubtreeMergedEventArgs _
)
C#
public void NotifyTestModelSubtreeMerged(
TestModelSubtreeMergedEventArgs e
)
C++
public:
void NotifyTestModelSubtreeMerged(
TestModelSubtreeMergedEventArgs e
) sealed
J#
public void NotifyTestModelSubtreeMerged(
TestModelSubtreeMergedEventArgs e
)
JScript
public function NotifyTestModelSubtreeMerged(
e : TestModelSubtreeMergedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepFinished Method

TestRunnerEventDispatcher.NotifyTestStepFinished Method
[image]

Dispatches the TestStepFinished event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepFinished( _
ByVal e As TestStepFinishedEventArgs _
)
C#
public void NotifyTestStepFinished(
TestStepFinishedEventArgs e
)
C++
public:
void NotifyTestStepFinished(
TestStepFinishedEventArgs e
) sealed
J#
public void NotifyTestStepFinished(
TestStepFinishedEventArgs e
)
JScript
public function NotifyTestStepFinished(
e : TestStepFinishedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLifecyclePhaseChanged Method

TestRunnerEventDispatcher.NotifyTestStepLifecyclePhaseChanged Method
See Also Example
[image]

Dispatches the TestStepLifecyclePhaseChanged event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLifecyclePhaseChanged( _
ByVal e As TestStepLifecyclePhaseChangedEventArgs _
)
C#
public void NotifyTestStepLifecyclePhaseChanged(
TestStepLifecyclePhaseChangedEventArgs e
)
C++
public:
void NotifyTestStepLifecyclePhaseChanged(
TestStepLifecyclePhaseChangedEventArgs e
) sealed
J#
public void NotifyTestStepLifecyclePhaseChanged(
TestStepLifecyclePhaseChangedEventArgs e
)
JScript
public function NotifyTestStepLifecyclePhaseChanged(
e : TestStepLifecyclePhaseChangedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLogAttach Method

TestRunnerEventDispatcher.NotifyTestStepLogAttach Method
[image]

Dispatches the TestStepLogAttach event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogAttach( _
ByVal e As TestStepLogAttachEventArgs _
)
C#
public void NotifyTestStepLogAttach(
TestStepLogAttachEventArgs e
)
C++
public:
void NotifyTestStepLogAttach(
TestStepLogAttachEventArgs e
) sealed
J#
public void NotifyTestStepLogAttach(
TestStepLogAttachEventArgs e
)
JScript
public function NotifyTestStepLogAttach(
e : TestStepLogAttachEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLogStreamBeginMarker Method

TestRunnerEventDispatcher.NotifyTestStepLogStreamBeginMarker Method
See Also Example
[image]

Dispatches the TestStepLogStreamBeginMarker event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamBeginMarker( _
ByVal e As TestStepLogStreamBeginMarkerEventArgs _
)
C#
public void NotifyTestStepLogStreamBeginMarker(
TestStepLogStreamBeginMarkerEventArgs e
)
C++
public:
void NotifyTestStepLogStreamBeginMarker(
TestStepLogStreamBeginMarkerEventArgs e
) sealed
J#
public void NotifyTestStepLogStreamBeginMarker(
TestStepLogStreamBeginMarkerEventArgs e
)
JScript
public function NotifyTestStepLogStreamBeginMarker(
e : TestStepLogStreamBeginMarkerEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLogStreamBeginSection Method

TestRunnerEventDispatcher.NotifyTestStepLogStreamBeginSection Method
See Also Example
[image]

Dispatches the TestStepLogStreamBeginSection event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamBeginSection( _
ByVal e As TestStepLogStreamBeginSectionEventArgs _
)
C#
public void NotifyTestStepLogStreamBeginSection(
TestStepLogStreamBeginSectionEventArgs e
)
C++
public:
void NotifyTestStepLogStreamBeginSection(
TestStepLogStreamBeginSectionEventArgs e
) sealed
J#
public void NotifyTestStepLogStreamBeginSection(
TestStepLogStreamBeginSectionEventArgs e
)
JScript
public function NotifyTestStepLogStreamBeginSection(
e : TestStepLogStreamBeginSectionEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLogStreamEmbed Method

TestRunnerEventDispatcher.NotifyTestStepLogStreamEmbed Method
See Also Example
[image]

Dispatches the TestStepLogStreamEmbed event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamEmbed( _
ByVal e As TestStepLogStreamEmbedEventArgs _
)
C#
public void NotifyTestStepLogStreamEmbed(
TestStepLogStreamEmbedEventArgs e
)
C++
public:
void NotifyTestStepLogStreamEmbed(
TestStepLogStreamEmbedEventArgs e
) sealed
J#
public void NotifyTestStepLogStreamEmbed(
TestStepLogStreamEmbedEventArgs e
)
JScript
public function NotifyTestStepLogStreamEmbed(
e : TestStepLogStreamEmbedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLogStreamEnd Method

TestRunnerEventDispatcher.NotifyTestStepLogStreamEnd Method
[image]

Dispatches the TestStepLogStreamEnd event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamEnd( _
ByVal e As TestStepLogStreamEndEventArgs _
)
C#
public void NotifyTestStepLogStreamEnd(
TestStepLogStreamEndEventArgs e
)
C++
public:
void NotifyTestStepLogStreamEnd(
TestStepLogStreamEndEventArgs e
) sealed
J#
public void NotifyTestStepLogStreamEnd(
TestStepLogStreamEndEventArgs e
)
JScript
public function NotifyTestStepLogStreamEnd(
e : TestStepLogStreamEndEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepLogStreamWrite Method

TestRunnerEventDispatcher.NotifyTestStepLogStreamWrite Method
See Also Example
[image]

Dispatches the TestStepLogStreamWrite event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepLogStreamWrite( _
ByVal e As TestStepLogStreamWriteEventArgs _
)
C#
public void NotifyTestStepLogStreamWrite(
TestStepLogStreamWriteEventArgs e
)
C++
public:
void NotifyTestStepLogStreamWrite(
TestStepLogStreamWriteEventArgs e
) sealed
J#
public void NotifyTestStepLogStreamWrite(
TestStepLogStreamWriteEventArgs e
)
JScript
public function NotifyTestStepLogStreamWrite(
e : TestStepLogStreamWriteEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepMetadataAdded Method

TestRunnerEventDispatcher.NotifyTestStepMetadataAdded Method
[image]

Dispatches the TestStepMetadataAdded event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepMetadataAdded( _
ByVal e As TestStepMetadataAddedEventArgs _
)
C#
public void NotifyTestStepMetadataAdded(
TestStepMetadataAddedEventArgs e
)
C++
public:
void NotifyTestStepMetadataAdded(
TestStepMetadataAddedEventArgs e
) sealed
J#
public void NotifyTestStepMetadataAdded(
TestStepMetadataAddedEventArgs e
)
JScript
public function NotifyTestStepMetadataAdded(
e : TestStepMetadataAddedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


NotifyTestStepStarted Method

TestRunnerEventDispatcher.NotifyTestStepStarted Method
[image]

Dispatches the TestStepStarted event.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NotifyTestStepStarted( _
ByVal e As TestStepStartedEventArgs _
)
C#
public void NotifyTestStepStarted(
TestStepStartedEventArgs e
)
C++
public:
void NotifyTestStepStarted(
TestStepStartedEventArgs e
) sealed
J#
public void NotifyTestStepStarted(
TestStepStartedEventArgs e
)
JScript
public function NotifyTestStepStarted(
e : TestStepStartedEventArgs
)

Parameters

e
The event arguments

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


SubscribeTo Method

TestRunnerEventDispatcher.SubscribeTo Method
[image]

Subscribes to another event object such that the events will be forwarded to the handlers registered on this dispatcher.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubscribeTo( _
ByVal events As ITestRunnerEvents _
)
C#
public void SubscribeTo(
ITestRunnerEvents events
)
C++
public:
void SubscribeTo(
ITestRunnerEvents events
) sealed
J#
public void SubscribeTo(
ITestRunnerEvents events
)
JScript
public function SubscribeTo(
events : ITestRunnerEvents
)

Parameters

events
The other events object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if events is null

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


Events

TestRunnerEventDispatcher Events
[image]

Public Events

 | Name | Description
Public event | DisposeFinished | The event raised to indicate that the test runner disposal has finished.
Public event | DisposeStarted | The event raised to indicate that the test runner disposal has started.
Public event | ExploreFinished | The event raised to indicate that test exploration has finished.
Public event | ExploreStarted | The event raised to indicate that test exploration has started.
Public event | InitializeFinished | The event raised to indicate that the test runner initialization has finished.
Public event | InitializeStarted | The event raised to indicate that the test runner initialization has started.
Public event | LogMessage | The event raised to indicate that a log message was written by the test runner.
Public event | RunFinished | The event raised to indicate that test execution has finished.
Public event | RunStarted | The event raised to indicate that test execution has started.
Public event | TestModelAnnotationAdded | The event raised to indicate that an annotation was added to the test model.
Public event | TestModelSubtreeMerged | The event raised to indicate that a subtree of tests was merged into the test model.
Public event | TestStepFinished | The event raised to indicate that a test step has finished execution.
Public event | TestStepLifecyclePhaseChanged | The event raised to indicate that a test step has entered a new lifecycle phase.
Public event | TestStepLogAttach | The event raised to indicate that an attachment has been added to a test step log.
Public event | TestStepLogStreamBeginMarker | The event raised to indicate that a marker has been started within a test step log stream.
Public event | TestStepLogStreamBeginSection | The event raised to indicate that a section has been started within a test step log stream.
Public event | TestStepLogStreamEmbed | The event raised to indicate that an attachment has been embedded into a test step log stream.
Public event | TestStepLogStreamEnd | The event raised to indicate that a section has finished within a test step log stream.
Public event | TestStepLogStreamWrite | The event raised to indicate that text has been written to a test step log stream.
Public event | TestStepMetadataAdded | The event raised to indicate that a test step dynamically added metadata to itself.
Public event | TestStepStarted | The event raised to indicate that a test step has started execution.
Top

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


DisposeFinished Event

TestRunnerEventDispatcher.DisposeFinished Event
[image]

The event raised to indicate that the test runner disposal has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event DisposeFinished As EventHandler(Of DisposeFinishedEventArgs)
C#
public event EventHandler<DisposeFinishedEventArgs> DisposeFinished
C++
public:
virtual event EventHandler<DisposeFinishedEventArgs> DisposeFinished {
void add(EventHandler<DisposeFinishedEventArgs> value) sealed ;
void remove(EventHandler<DisposeFinishedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_DisposeFinished(EventHandler<DisposeFinishedEventArgs> value);

/** event */
public final void remove_DisposeFinished(EventHandler<DisposeFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.DisposeFinished

Event Data

The event handler receives an argument of type DisposeFinishedEventArgs containing data related to this event. The following DisposeFinishedEventArgs property provides information specific to this event.

Property | Description
Success | Returns true if the operation completed successfully.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


DisposeStarted Event

TestRunnerEventDispatcher.DisposeStarted Event
[image]

The event raised to indicate that the test runner disposal has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event DisposeStarted As EventHandler(Of DisposeStartedEventArgs)
C#
public event EventHandler<DisposeStartedEventArgs> DisposeStarted
C++
public:
virtual event EventHandler<DisposeStartedEventArgs> DisposeStarted {
void add(EventHandler<DisposeStartedEventArgs> value) sealed ;
void remove(EventHandler<DisposeStartedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_DisposeStarted(EventHandler<DisposeStartedEventArgs> value);

/** event */
public final void remove_DisposeStarted(EventHandler<DisposeStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.DisposeStarted

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


ExploreFinished Event

TestRunnerEventDispatcher.ExploreFinished Event
[image]

The event raised to indicate that test exploration has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event ExploreFinished As EventHandler(Of ExploreFinishedEventArgs)
C#
public event EventHandler<ExploreFinishedEventArgs> ExploreFinished
C++
public:
virtual event EventHandler<ExploreFinishedEventArgs> ExploreFinished {
void add(EventHandler<ExploreFinishedEventArgs> value) sealed ;
void remove(EventHandler<ExploreFinishedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ExploreFinished(EventHandler<ExploreFinishedEventArgs> value);

/** event */
public final void remove_ExploreFinished(EventHandler<ExploreFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.ExploreFinished

Event Data

The event handler receives an argument of type ExploreFinishedEventArgs containing data related to this event. The following ExploreFinishedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report, including test model data on success.
Success | Returns true if the operation completed successfully.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


ExploreStarted Event

TestRunnerEventDispatcher.ExploreStarted Event
[image]

The event raised to indicate that test exploration has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event ExploreStarted As EventHandler(Of ExploreStartedEventArgs)
C#
public event EventHandler<ExploreStartedEventArgs> ExploreStarted
C++
public:
virtual event EventHandler<ExploreStartedEventArgs> ExploreStarted {
void add(EventHandler<ExploreStartedEventArgs> value) sealed ;
void remove(EventHandler<ExploreStartedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ExploreStarted(EventHandler<ExploreStartedEventArgs> value);

/** event */
public final void remove_ExploreStarted(EventHandler<ExploreStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.ExploreStarted

Event Data

The event handler receives an argument of type ExploreStartedEventArgs containing data related to this event. The following ExploreStartedEventArgs properties provide information specific to this event.

Property | Description
ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
TestExplorationOptions | Gets the test exploration options.
TestPackageConfig | Gets the test package configuration.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


InitializeFinished Event

TestRunnerEventDispatcher.InitializeFinished Event
[image]

The event raised to indicate that the test runner initialization has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event InitializeFinished As EventHandler(Of InitializeFinishedEventArgs)
C#
public event EventHandler<InitializeFinishedEventArgs> InitializeFinished
C++
public:
virtual event EventHandler<InitializeFinishedEventArgs> InitializeFinished {
void add(EventHandler<InitializeFinishedEventArgs> value) sealed ;
void remove(EventHandler<InitializeFinishedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_InitializeFinished(EventHandler<InitializeFinishedEventArgs> value);

/** event */
public final void remove_InitializeFinished(EventHandler<InitializeFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.InitializeFinished

Event Data

The event handler receives an argument of type InitializeFinishedEventArgs containing data related to this event. The following InitializeFinishedEventArgs property provides information specific to this event.

Property | Description
Success | Returns true if the operation completed successfully.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


InitializeStarted Event

TestRunnerEventDispatcher.InitializeStarted Event
[image]

The event raised to indicate that the test runner initialization has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event InitializeStarted As EventHandler(Of InitializeStartedEventArgs)
C#
public event EventHandler<InitializeStartedEventArgs> InitializeStarted
C++
public:
virtual event EventHandler<InitializeStartedEventArgs> InitializeStarted {
void add(EventHandler<InitializeStartedEventArgs> value) sealed ;
void remove(EventHandler<InitializeStartedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_InitializeStarted(EventHandler<InitializeStartedEventArgs> value);

/** event */
public final void remove_InitializeStarted(EventHandler<InitializeStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.InitializeStarted

Event Data

The event handler receives an argument of type InitializeStartedEventArgs containing data related to this event. The following InitializeStartedEventArgs property provides information specific to this event.

Property | Description
Options | Gets the test runner options.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


LogMessage Event

TestRunnerEventDispatcher.LogMessage Event
[image]

The event raised to indicate that a log message was written by the test runner.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event LogMessage As EventHandler(Of LogMessageEventArgs)
C#
public event EventHandler<LogMessageEventArgs> LogMessage
C++
public:
virtual event EventHandler<LogMessageEventArgs> LogMessage {
void add(EventHandler<LogMessageEventArgs> value) sealed ;
void remove(EventHandler<LogMessageEventArgs> value) sealed ;
}
J#
/** event */
public final void add_LogMessage(EventHandler<LogMessageEventArgs> value);

/** event */
public final void remove_LogMessage(EventHandler<LogMessageEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.LogMessage

Event Data

The event handler receives an argument of type LogMessageEventArgs containing data related to this event. The following LogMessageEventArgs properties provide information specific to this event.

Property | Description
ExceptionData | Gets the exception, or null if none.
Message | Gets the log message.
Severity | Gets the log severity.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


RunFinished Event

TestRunnerEventDispatcher.RunFinished Event
[image]

The event raised to indicate that test execution has finished.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event RunFinished As EventHandler(Of RunFinishedEventArgs)
C#
public event EventHandler<RunFinishedEventArgs> RunFinished
C++
public:
virtual event EventHandler<RunFinishedEventArgs> RunFinished {
void add(EventHandler<RunFinishedEventArgs> value) sealed ;
void remove(EventHandler<RunFinishedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_RunFinished(EventHandler<RunFinishedEventArgs> value);

/** event */
public final void remove_RunFinished(EventHandler<RunFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.RunFinished

Event Data

The event handler receives an argument of type RunFinishedEventArgs containing data related to this event. The following RunFinishedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report, including test package run data on success.
Success | Returns true if the operation completed successfully.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


RunStarted Event

TestRunnerEventDispatcher.RunStarted Event
[image]

The event raised to indicate that test execution has started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event RunStarted As EventHandler(Of RunStartedEventArgs)
C#
public event EventHandler<RunStartedEventArgs> RunStarted
C++
public:
virtual event EventHandler<RunStartedEventArgs> RunStarted {
void add(EventHandler<RunStartedEventArgs> value) sealed ;
void remove(EventHandler<RunStartedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_RunStarted(EventHandler<RunStartedEventArgs> value);

/** event */
public final void remove_RunStarted(EventHandler<RunStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.RunStarted

Event Data

The event handler receives an argument of type RunStartedEventArgs containing data related to this event. The following RunStartedEventArgs properties provide information specific to this event.

Property | Description
ReportLockBox | Gets the report lock-box which may be used to access the report asynchronously during execution.
TestExecutionOptions | Gets the test execution options.
TestExplorationOptions | Gets the test exploration options.
TestPackageConfig | Gets the test package configuration.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestModelAnnotationAdded Event

TestRunnerEventDispatcher.TestModelAnnotationAdded Event
[image]

The event raised to indicate that an annotation was added to the test model.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestModelAnnotationAdded As EventHandler(Of TestModelAnnotationAddedEventArgs)
C#
public event EventHandler<TestModelAnnotationAddedEventArgs> TestModelAnnotationAdded
C++
public:
virtual event EventHandler<TestModelAnnotationAddedEventArgs> TestModelAnnotationAdded {
void add(EventHandler<TestModelAnnotationAddedEventArgs> value) sealed ;
void remove(EventHandler<TestModelAnnotationAddedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestModelAnnotationAdded(EventHandler<TestModelAnnotationAddedEventArgs> value);

/** event */
public final void remove_TestModelAnnotationAdded(EventHandler<TestModelAnnotationAddedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestModelAnnotationAdded

Event Data

The event handler receives an argument of type TestModelAnnotationAddedEventArgs containing data related to this event. The following TestModelAnnotationAddedEventArgs properties provide information specific to this event.

Property | Description
Annotation | Gets the annotation that was added.
Report | Gets the report.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestModelSubtreeMerged Event

TestRunnerEventDispatcher.TestModelSubtreeMerged Event
[image]

The event raised to indicate that a subtree of tests was merged into the test model.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestModelSubtreeMerged As EventHandler(Of TestModelSubtreeMergedEventArgs)
C#
public event EventHandler<TestModelSubtreeMergedEventArgs> TestModelSubtreeMerged
C++
public:
virtual event EventHandler<TestModelSubtreeMergedEventArgs> TestModelSubtreeMerged {
void add(EventHandler<TestModelSubtreeMergedEventArgs> value) sealed ;
void remove(EventHandler<TestModelSubtreeMergedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestModelSubtreeMerged(EventHandler<TestModelSubtreeMergedEventArgs> value);

/** event */
public final void remove_TestModelSubtreeMerged(EventHandler<TestModelSubtreeMergedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestModelSubtreeMerged

Event Data

The event handler receives an argument of type TestModelSubtreeMergedEventArgs containing data related to this event. The following TestModelSubtreeMergedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report.
Test | Gets the test at the top of the subtree that was merged.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepFinished Event

TestRunnerEventDispatcher.TestStepFinished Event
[image]

The event raised to indicate that a test step has finished execution.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepFinished As EventHandler(Of TestStepFinishedEventArgs)
C#
public event EventHandler<TestStepFinishedEventArgs> TestStepFinished
C++
public:
virtual event EventHandler<TestStepFinishedEventArgs> TestStepFinished {
void add(EventHandler<TestStepFinishedEventArgs> value) sealed ;
void remove(EventHandler<TestStepFinishedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepFinished(EventHandler<TestStepFinishedEventArgs> value);

/** event */
public final void remove_TestStepFinished(EventHandler<TestStepFinishedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepFinished

Event Data

The event handler receives an argument of type TestStepFinishedEventArgs containing data related to this event. The following TestStepFinishedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLifecyclePhaseChanged Event

TestRunnerEventDispatcher.TestStepLifecyclePhaseChanged Event
See Also Example
[image]

The event raised to indicate that a test step has entered a new lifecycle phase.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLifecyclePhaseChanged As EventHandler(Of TestStepLifecyclePhaseChangedEventArgs)
C#
public event EventHandler<TestStepLifecyclePhaseChangedEventArgs> TestStepLifecyclePhaseChanged
C++
public:
virtual event EventHandler<TestStepLifecyclePhaseChangedEventArgs> TestStepLifecyclePhaseChanged {
void add(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value) sealed ;
void remove(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLifecyclePhaseChanged(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value);

/** event */
public final void remove_TestStepLifecyclePhaseChanged(EventHandler<TestStepLifecyclePhaseChangedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLifecyclePhaseChanged

Event Data

The event handler receives an argument of type TestStepLifecyclePhaseChangedEventArgs containing data related to this event. The following TestStepLifecyclePhaseChangedEventArgs properties provide information specific to this event.

Property | Description
LifecyclePhase | Gets the lifecycle phase name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLogAttach Event

TestRunnerEventDispatcher.TestStepLogAttach Event
[image]

The event raised to indicate that an attachment has been added to a test step log.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLogAttach As EventHandler(Of TestStepLogAttachEventArgs)
C#
public event EventHandler<TestStepLogAttachEventArgs> TestStepLogAttach
C++
public:
virtual event EventHandler<TestStepLogAttachEventArgs> TestStepLogAttach {
void add(EventHandler<TestStepLogAttachEventArgs> value) sealed ;
void remove(EventHandler<TestStepLogAttachEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLogAttach(EventHandler<TestStepLogAttachEventArgs> value);

/** event */
public final void remove_TestStepLogAttach(EventHandler<TestStepLogAttachEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLogAttach

Event Data

The event handler receives an argument of type TestStepLogAttachEventArgs containing data related to this event. The following TestStepLogAttachEventArgs properties provide information specific to this event.

Property | Description
Attachment | Gets the attachment.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLogStreamBeginMarker Event

TestRunnerEventDispatcher.TestStepLogStreamBeginMarker Event
[image]

The event raised to indicate that a marker has been started within a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLogStreamBeginMarker As EventHandler(Of TestStepLogStreamBeginMarkerEventArgs)
C#
public event EventHandler<TestStepLogStreamBeginMarkerEventArgs> TestStepLogStreamBeginMarker
C++
public:
virtual event EventHandler<TestStepLogStreamBeginMarkerEventArgs> TestStepLogStreamBeginMarker {
void add(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value) sealed ;
void remove(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLogStreamBeginMarker(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value);

/** event */
public final void remove_TestStepLogStreamBeginMarker(EventHandler<TestStepLogStreamBeginMarkerEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLogStreamBeginMarker

Event Data

The event handler receives an argument of type TestStepLogStreamBeginMarkerEventArgs containing data related to this event. The following TestStepLogStreamBeginMarkerEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Marker | Gets the marker.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLogStreamBeginSection Event

TestRunnerEventDispatcher.TestStepLogStreamBeginSection Event
See Also Example
[image]

The event raised to indicate that a section has been started within a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLogStreamBeginSection As EventHandler(Of TestStepLogStreamBeginSectionEventArgs)
C#
public event EventHandler<TestStepLogStreamBeginSectionEventArgs> TestStepLogStreamBeginSection
C++
public:
virtual event EventHandler<TestStepLogStreamBeginSectionEventArgs> TestStepLogStreamBeginSection {
void add(EventHandler<TestStepLogStreamBeginSectionEventArgs> value) sealed ;
void remove(EventHandler<TestStepLogStreamBeginSectionEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLogStreamBeginSection(EventHandler<TestStepLogStreamBeginSectionEventArgs> value);

/** event */
public final void remove_TestStepLogStreamBeginSection(EventHandler<TestStepLogStreamBeginSectionEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLogStreamBeginSection

Event Data

The event handler receives an argument of type TestStepLogStreamBeginSectionEventArgs containing data related to this event. The following TestStepLogStreamBeginSectionEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Report | Gets the report.
SectionName | Gets the name of the section that was started.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLogStreamEmbed Event

TestRunnerEventDispatcher.TestStepLogStreamEmbed Event
[image]

The event raised to indicate that an attachment has been embedded into a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLogStreamEmbed As EventHandler(Of TestStepLogStreamEmbedEventArgs)
C#
public event EventHandler<TestStepLogStreamEmbedEventArgs> TestStepLogStreamEmbed
C++
public:
virtual event EventHandler<TestStepLogStreamEmbedEventArgs> TestStepLogStreamEmbed {
void add(EventHandler<TestStepLogStreamEmbedEventArgs> value) sealed ;
void remove(EventHandler<TestStepLogStreamEmbedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLogStreamEmbed(EventHandler<TestStepLogStreamEmbedEventArgs> value);

/** event */
public final void remove_TestStepLogStreamEmbed(EventHandler<TestStepLogStreamEmbedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLogStreamEmbed

Event Data

The event handler receives an argument of type TestStepLogStreamEmbedEventArgs containing data related to this event. The following TestStepLogStreamEmbedEventArgs properties provide information specific to this event.

Property | Description
AttachmentName | Gets the name of the attachment that was embedded.
LogStreamName | Gets the log stream name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLogStreamEnd Event

TestRunnerEventDispatcher.TestStepLogStreamEnd Event
[image]

The event raised to indicate that a section has finished within a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLogStreamEnd As EventHandler(Of TestStepLogStreamEndEventArgs)
C#
public event EventHandler<TestStepLogStreamEndEventArgs> TestStepLogStreamEnd
C++
public:
virtual event EventHandler<TestStepLogStreamEndEventArgs> TestStepLogStreamEnd {
void add(EventHandler<TestStepLogStreamEndEventArgs> value) sealed ;
void remove(EventHandler<TestStepLogStreamEndEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLogStreamEnd(EventHandler<TestStepLogStreamEndEventArgs> value);

/** event */
public final void remove_TestStepLogStreamEnd(EventHandler<TestStepLogStreamEndEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLogStreamEnd

Event Data

The event handler receives an argument of type TestStepLogStreamEndEventArgs containing data related to this event. The following TestStepLogStreamEndEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepLogStreamWrite Event

TestRunnerEventDispatcher.TestStepLogStreamWrite Event
[image]

The event raised to indicate that text has been written to a test step log stream.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepLogStreamWrite As EventHandler(Of TestStepLogStreamWriteEventArgs)
C#
public event EventHandler<TestStepLogStreamWriteEventArgs> TestStepLogStreamWrite
C++
public:
virtual event EventHandler<TestStepLogStreamWriteEventArgs> TestStepLogStreamWrite {
void add(EventHandler<TestStepLogStreamWriteEventArgs> value) sealed ;
void remove(EventHandler<TestStepLogStreamWriteEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepLogStreamWrite(EventHandler<TestStepLogStreamWriteEventArgs> value);

/** event */
public final void remove_TestStepLogStreamWrite(EventHandler<TestStepLogStreamWriteEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepLogStreamWrite

Event Data

The event handler receives an argument of type TestStepLogStreamWriteEventArgs containing data related to this event. The following TestStepLogStreamWriteEventArgs properties provide information specific to this event.

Property | Description
LogStreamName | Gets the log stream name.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.
Text | Gets the text that was written.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepMetadataAdded Event

TestRunnerEventDispatcher.TestStepMetadataAdded Event
[image]

The event raised to indicate that a test step dynamically added metadata to itself.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepMetadataAdded As EventHandler(Of TestStepMetadataAddedEventArgs)
C#
public event EventHandler<TestStepMetadataAddedEventArgs> TestStepMetadataAdded
C++
public:
virtual event EventHandler<TestStepMetadataAddedEventArgs> TestStepMetadataAdded {
void add(EventHandler<TestStepMetadataAddedEventArgs> value) sealed ;
void remove(EventHandler<TestStepMetadataAddedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepMetadataAdded(EventHandler<TestStepMetadataAddedEventArgs> value);

/** event */
public final void remove_TestStepMetadataAdded(EventHandler<TestStepMetadataAddedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepMetadataAdded

Event Data

The event handler receives an argument of type TestStepMetadataAddedEventArgs containing data related to this event. The following TestStepMetadataAddedEventArgs properties provide information specific to this event.

Property | Description
MetadataKey | Gets the metadata key.
MetadataValue | Gets the metadata value.
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepStarted Event

TestRunnerEventDispatcher.TestStepStarted Event
[image]

The event raised to indicate that a test step has started execution.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TestStepStarted As EventHandler(Of TestStepStartedEventArgs)
C#
public event EventHandler<TestStepStartedEventArgs> TestStepStarted
C++
public:
virtual event EventHandler<TestStepStartedEventArgs> TestStepStarted {
void add(EventHandler<TestStepStartedEventArgs> value) sealed ;
void remove(EventHandler<TestStepStartedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_TestStepStarted(EventHandler<TestStepStartedEventArgs> value);

/** event */
public final void remove_TestStepStarted(EventHandler<TestStepStartedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

ITestRunnerEvents.TestStepStarted

Event Data

The event handler receives an argument of type TestStepStartedEventArgs containing data related to this event. The following TestStepStartedEventArgs properties provide information specific to this event.

Property | Description
Report | Gets the report.
Test | Gets the test data of the test that contains the test step.
TestStepRun | Gets the test step run.

See Also

TestRunnerEventDispatcher Class
Gallio.Runner.Events Namespace


TestStepEventArgs Class

TestStepEventArgs Class
See Also Example Members
[image]

Base arguments for an event raised to provide information about a test step. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TestStepEventArgs
Inherits EventArgs
C#
public abstract class TestStepEventArgs : EventArgs
C++
ref class TestStepEventArgs abstract : EventArgs
J#
public class TestStepEventArgs extends EventArgs
JScript
public class TestStepEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Derived types

See Also

TestStepEventArgs Members
Gallio.Runner.Events Namespace


TestStepEventArgs Members

TestStepEventArgs Members
See Also Example Constructors Properties Methods
[image]

Base arguments for an event raised to provide information about a test step. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestStepEventArgs.

Protected Constructors

 | Name | Description
Family method | TestStepEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report.
Public property | Test | Gets the test data of the test that contains the test step.
Public property | TestStepRun | Gets the test step run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


TestStepEventArgs Constructor

TestStepEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun _
)
C#
protected TestStepEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
)
C++
protected:
TestStepEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
) sealed
J#
protected TestStepEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
)
JScript
protected function TestStepEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun
)

Parameters

report
The report
test
The test data
testStepRun
The test step run

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, test or testStepRun is null

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the report.
Public property | Test | Gets the test data of the test that contains the test step.
Public property | TestStepRun | Gets the test step run.
Top

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


Report Property

TestStepEventArgs.Report Property
[image]

Gets the report.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


Test Property

TestStepEventArgs.Test Property
[image]

Gets the test data of the test that contains the test step.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Test As TestData
C#
public TestData Test { get; }
C++
public property TestData Test sealed {
TestData get();
}
J#
/** property */
public TestData get_Test();
JScript
public function get Test() : TestData

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


TestStepRun Property

TestStepEventArgs.TestStepRun Property
[image]

Gets the test step run.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestStepRun As TestStepRun
C#
public TestStepRun TestStepRun { get; }
C++
public property TestStepRun TestStepRun sealed {
TestStepRun get();
}
J#
/** property */
public TestStepRun get_TestStepRun();
JScript
public function get TestStepRun() : TestStepRun

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


Methods

TestStepEventArgs Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


GetStepKind Method

TestStepEventArgs.GetStepKind Method
[image]

Gets the kind of step described using the TestKind metadata key.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStepKind() As String
C#
public string GetStepKind()
C++
public:
String GetStepKind() sealed
J#
public string GetStepKind()
JScript
public function GetStepKind() : String

Return Value

The step kind

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


TestStepFinishedEventArgs Class

TestStepFinishedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a test step has finished execution. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepFinishedEventArgs
Inherits TestStepEventArgs
C#
public sealed class TestStepFinishedEventArgs : TestStepEventArgs
C++
ref class TestStepFinishedEventArgs sealed : TestStepEventArgs
J#
public final class TestStepFinishedEventArgs extends TestStepEventArgs
JScript
public final class TestStepFinishedEventArgs extends TestStepEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepFinishedEventArgs

See Also

TestStepFinishedEventArgs Members
Gallio.Runner.Events Namespace


TestStepFinishedEventArgs Members

TestStepFinishedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a test step has finished execution. This class cannot be inherited.

The following tables list the members exposed by TestStepFinishedEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepFinishedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepFinishedEventArgs Class
Gallio.Runner.Events Namespace


TestStepFinishedEventArgs Constructor

TestStepFinishedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun _
)
C#
public TestStepFinishedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
)
C++
public:
TestStepFinishedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
) sealed
J#
public TestStepFinishedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
)
JScript
public function TestStepFinishedEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun
)

Parameters

report
The report
test
The test data
testStepRun
The test step run

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, test or testStepRun is null

See Also

TestStepFinishedEventArgs Class
Gallio.Runner.Events Namespace


TestStepLifecyclePhaseChangedEventArgs Class

TestStepLifecyclePhaseChangedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a test step has entered a new lifecycle phase. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLifecyclePhaseChangedEventArgs
Inherits TestStepEventArgs
C#
public sealed class TestStepLifecyclePhaseChangedEventArgs : TestStepEventArgs
C++
ref class TestStepLifecyclePhaseChangedEventArgs sealed : TestStepEventArgs
J#
public final class TestStepLifecyclePhaseChangedEventArgs extends TestStepEventArgs
JScript
public final class TestStepLifecyclePhaseChangedEventArgs extends TestStepEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLifecyclePhaseChangedEventArgs

See Also

TestStepLifecyclePhaseChangedEventArgs Members
Gallio.Runner.Events Namespace


TestStepLifecyclePhaseChangedEventArgs Members

TestStepLifecyclePhaseChangedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a test step has entered a new lifecycle phase. This class cannot be inherited.

The following tables list the members exposed by TestStepLifecyclePhaseChangedEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLifecyclePhaseChangedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | LifecyclePhase | Gets the lifecycle phase name.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLifecyclePhaseChangedEventArgs Class
Gallio.Runner.Events Namespace


TestStepLifecyclePhaseChangedEventArgs Constructor

TestStepLifecyclePhaseChangedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal lifecyclePhase As String _
)
C#
public TestStepLifecyclePhaseChangedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string lifecyclePhase
)
C++
public:
TestStepLifecyclePhaseChangedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String lifecyclePhase
) sealed
J#
public TestStepLifecyclePhaseChangedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string lifecyclePhase
)
JScript
public function TestStepLifecyclePhaseChangedEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
lifecyclePhase : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
lifecyclePhase
The lifecycle phase name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun, or lifecyclePhase is null

See Also

TestStepLifecyclePhaseChangedEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLifecyclePhaseChangedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | LifecyclePhase | Gets the lifecycle phase name.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepLifecyclePhaseChangedEventArgs Class
Gallio.Runner.Events Namespace


LifecyclePhase Property

TestStepLifecyclePhaseChangedEventArgs.LifecyclePhase Property
See Also Example
[image]

Gets the lifecycle phase name.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LifecyclePhase As String
C#
public string LifecyclePhase { get; }
C++
public property string LifecyclePhase sealed {
String get();
}
J#
/** property */
public string get_LifecyclePhase();
JScript
public function get LifecyclePhase() : String

See Also

TestStepLifecyclePhaseChangedEventArgs Class
Gallio.Runner.Events Namespace
LifecyclePhases


TestStepLogAttachEventArgs Class

TestStepLogAttachEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that an attachment has been added to a test step log. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLogAttachEventArgs
Inherits TestStepEventArgs
C#
public sealed class TestStepLogAttachEventArgs : TestStepEventArgs
C++
ref class TestStepLogAttachEventArgs sealed : TestStepEventArgs
J#
public final class TestStepLogAttachEventArgs extends TestStepEventArgs
JScript
public final class TestStepLogAttachEventArgs extends TestStepEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogAttachEventArgs

See Also

TestStepLogAttachEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogAttachEventArgs Members

TestStepLogAttachEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that an attachment has been added to a test step log. This class cannot be inherited.

The following tables list the members exposed by TestStepLogAttachEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLogAttachEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Attachment | Gets the attachment.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLogAttachEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogAttachEventArgs Constructor

TestStepLogAttachEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal attachment As Attachment _
)
C#
public TestStepLogAttachEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
Attachment attachment
)
C++
public:
TestStepLogAttachEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
Attachment attachment
) sealed
J#
public TestStepLogAttachEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
Attachment attachment
)
JScript
public function TestStepLogAttachEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
attachment : Attachment
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
attachment
The attachment

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun or attachment is null

See Also

TestStepLogAttachEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLogAttachEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Attachment | Gets the attachment.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepLogAttachEventArgs Class
Gallio.Runner.Events Namespace


Attachment Property

TestStepLogAttachEventArgs.Attachment Property
[image]

Gets the attachment.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attachment As Attachment
C#
public Attachment Attachment { get; }
C++
public property Attachment Attachment sealed {
Attachment get();
}
J#
/** property */
public Attachment get_Attachment();
JScript
public function get Attachment() : Attachment

See Also

TestStepLogAttachEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamBeginMarkerEventArgs Class

TestStepLogStreamBeginMarkerEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a marker region has been started within a test step log stream. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLogStreamBeginMarkerEventArgs
Inherits TestStepLogStreamEventArgs
C#
public sealed class TestStepLogStreamBeginMarkerEventArgs : TestStepLogStreamEventArgs
C++
ref class TestStepLogStreamBeginMarkerEventArgs sealed : TestStepLogStreamEventArgs
J#
public final class TestStepLogStreamBeginMarkerEventArgs extends TestStepLogStreamEventArgs
JScript
public final class TestStepLogStreamBeginMarkerEventArgs extends TestStepLogStreamEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamBeginMarkerEventArgs

See Also

TestStepLogStreamBeginMarkerEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogStreamBeginMarkerEventArgs Members

TestStepLogStreamBeginMarkerEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a marker region has been started within a test step log stream. This class cannot be inherited.

The following tables list the members exposed by TestStepLogStreamBeginMarkerEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLogStreamBeginMarkerEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Marker | Gets the marker.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLogStreamBeginMarkerEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamBeginMarkerEventArgs Constructor

TestStepLogStreamBeginMarkerEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal logStreamName As String, _
ByVal marker As Marker _
)
C#
public TestStepLogStreamBeginMarkerEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
Marker marker
)
C++
public:
TestStepLogStreamBeginMarkerEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String logStreamName,
Marker marker
) sealed
J#
public TestStepLogStreamBeginMarkerEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
Marker marker
)
JScript
public function TestStepLogStreamBeginMarkerEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
logStreamName : String,
marker : Marker
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
logStreamName
The log stream name
marker
The marker

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun or logStreamName is null

See Also

TestStepLogStreamBeginMarkerEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLogStreamBeginMarkerEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Marker | Gets the marker.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepLogStreamBeginMarkerEventArgs Class
Gallio.Runner.Events Namespace


Marker Property

TestStepLogStreamBeginMarkerEventArgs.Marker Property
[image]

Gets the marker.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Marker As Marker
C#
public Marker Marker { get; }
C++
public property Marker Marker sealed {
Marker get();
}
J#
/** property */
public Marker get_Marker();
JScript
public function get Marker() : Marker

See Also

TestStepLogStreamBeginMarkerEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamBeginSectionEventArgs Class

TestStepLogStreamBeginSectionEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a section has been started within a test step log stream. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLogStreamBeginSectionEventArgs
Inherits TestStepLogStreamEventArgs
C#
public sealed class TestStepLogStreamBeginSectionEventArgs : TestStepLogStreamEventArgs
C++
ref class TestStepLogStreamBeginSectionEventArgs sealed : TestStepLogStreamEventArgs
J#
public final class TestStepLogStreamBeginSectionEventArgs extends TestStepLogStreamEventArgs
JScript
public final class TestStepLogStreamBeginSectionEventArgs extends TestStepLogStreamEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamBeginSectionEventArgs

See Also

TestStepLogStreamBeginSectionEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogStreamBeginSectionEventArgs Members

TestStepLogStreamBeginSectionEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a section has been started within a test step log stream. This class cannot be inherited.

The following tables list the members exposed by TestStepLogStreamBeginSectionEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLogStreamBeginSectionEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | SectionName | Gets the name of the section that was started.
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLogStreamBeginSectionEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamBeginSectionEventArgs Constructor

TestStepLogStreamBeginSectionEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal logStreamName As String, _
ByVal sectionName As String _
)
C#
public TestStepLogStreamBeginSectionEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
string sectionName
)
C++
public:
TestStepLogStreamBeginSectionEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String logStreamName,
String sectionName
) sealed
J#
public TestStepLogStreamBeginSectionEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
string sectionName
)
JScript
public function TestStepLogStreamBeginSectionEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
logStreamName : String,
sectionName : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
logStreamName
The log stream name
sectionName
The name of the section that was started

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun, logStreamName, or sectionName is null

See Also

TestStepLogStreamBeginSectionEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLogStreamBeginSectionEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | SectionName | Gets the name of the section that was started.
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepLogStreamBeginSectionEventArgs Class
Gallio.Runner.Events Namespace


SectionName Property

TestStepLogStreamBeginSectionEventArgs.SectionName Property
[image]

Gets the name of the section that was started.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SectionName As String
C#
public string SectionName { get; }
C++
public property string SectionName sealed {
String get();
}
J#
/** property */
public string get_SectionName();
JScript
public function get SectionName() : String

See Also

TestStepLogStreamBeginSectionEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamEmbedEventArgs Class

TestStepLogStreamEmbedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that an attachment has been embedded into a test step log stream. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLogStreamEmbedEventArgs
Inherits TestStepLogStreamEventArgs
C#
public sealed class TestStepLogStreamEmbedEventArgs : TestStepLogStreamEventArgs
C++
ref class TestStepLogStreamEmbedEventArgs sealed : TestStepLogStreamEventArgs
J#
public final class TestStepLogStreamEmbedEventArgs extends TestStepLogStreamEventArgs
JScript
public final class TestStepLogStreamEmbedEventArgs extends TestStepLogStreamEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamEmbedEventArgs

See Also

TestStepLogStreamEmbedEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogStreamEmbedEventArgs Members

TestStepLogStreamEmbedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that an attachment has been embedded into a test step log stream. This class cannot be inherited.

The following tables list the members exposed by TestStepLogStreamEmbedEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLogStreamEmbedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | AttachmentName | Gets the name of the attachment that was embedded.
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLogStreamEmbedEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamEmbedEventArgs Constructor

TestStepLogStreamEmbedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal logStreamName As String, _
ByVal attachmentName As String _
)
C#
public TestStepLogStreamEmbedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
string attachmentName
)
C++
public:
TestStepLogStreamEmbedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String logStreamName,
String attachmentName
) sealed
J#
public TestStepLogStreamEmbedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
string attachmentName
)
JScript
public function TestStepLogStreamEmbedEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
logStreamName : String,
attachmentName : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
logStreamName
The log stream name
attachmentName
The name of the attachment that was embedded

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun, logStreamName, or attachmentName is null

See Also

TestStepLogStreamEmbedEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLogStreamEmbedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | AttachmentName | Gets the name of the attachment that was embedded.
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepLogStreamEmbedEventArgs Class
Gallio.Runner.Events Namespace


AttachmentName Property

TestStepLogStreamEmbedEventArgs.AttachmentName Property
[image]

Gets the name of the attachment that was embedded.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AttachmentName As String
C#
public string AttachmentName { get; }
C++
public property string AttachmentName sealed {
String get();
}
J#
/** property */
public string get_AttachmentName();
JScript
public function get AttachmentName() : String

See Also

TestStepLogStreamEmbedEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamEndEventArgs Class

TestStepLogStreamEndEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a section has been finished within a test step log stream. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLogStreamEndEventArgs
Inherits TestStepLogStreamEventArgs
C#
public sealed class TestStepLogStreamEndEventArgs : TestStepLogStreamEventArgs
C++
ref class TestStepLogStreamEndEventArgs sealed : TestStepLogStreamEventArgs
J#
public final class TestStepLogStreamEndEventArgs extends TestStepLogStreamEventArgs
JScript
public final class TestStepLogStreamEndEventArgs extends TestStepLogStreamEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamEndEventArgs

See Also

TestStepLogStreamEndEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogStreamEndEventArgs Members

TestStepLogStreamEndEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a section has been finished within a test step log stream. This class cannot be inherited.

The following tables list the members exposed by TestStepLogStreamEndEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLogStreamEndEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLogStreamEndEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamEndEventArgs Constructor

TestStepLogStreamEndEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal logStreamName As String _
)
C#
public TestStepLogStreamEndEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName
)
C++
public:
TestStepLogStreamEndEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String logStreamName
) sealed
J#
public TestStepLogStreamEndEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName
)
JScript
public function TestStepLogStreamEndEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
logStreamName : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
logStreamName
The log stream name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun or logStreamName is null

See Also

TestStepLogStreamEndEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamEventArgs Class

TestStepLogStreamEventArgs Class
See Also Example Members
[image]

Base arguments for an event raised to indicate that a test step log stream has been modified in some way. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TestStepLogStreamEventArgs
Inherits TestStepEventArgs
C#
public abstract class TestStepLogStreamEventArgs : TestStepEventArgs
C++
ref class TestStepLogStreamEventArgs abstract : TestStepEventArgs
J#
public class TestStepLogStreamEventArgs extends TestStepEventArgs
JScript
public class TestStepLogStreamEventArgs extends TestStepEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamBeginMarkerEventArgs
Gallio.Runner.Events.TestStepLogStreamBeginSectionEventArgs
Gallio.Runner.Events.TestStepLogStreamEmbedEventArgs
Gallio.Runner.Events.TestStepLogStreamEndEventArgs
Gallio.Runner.Events.TestStepLogStreamWriteEventArgs

See Also

TestStepLogStreamEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogStreamEventArgs Members

TestStepLogStreamEventArgs Members
See Also Example Constructors Properties Methods
[image]

Base arguments for an event raised to indicate that a test step log stream has been modified in some way. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestStepLogStreamEventArgs.

Protected Constructors

 | Name | Description
Family method | TestStepLogStreamEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestStepLogStreamEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamEventArgs Constructor

TestStepLogStreamEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal logStreamName As String _
)
C#
protected TestStepLogStreamEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName
)
C++
protected:
TestStepLogStreamEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String logStreamName
) sealed
J#
protected TestStepLogStreamEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName
)
JScript
protected function TestStepLogStreamEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
logStreamName : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
logStreamName
The log stream name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun, logStreamName or text is null

See Also

TestStepLogStreamEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLogStreamEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepLogStreamEventArgs Class
Gallio.Runner.Events Namespace


LogStreamName Property

TestStepLogStreamEventArgs.LogStreamName Property
[image]

Gets the log stream name.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LogStreamName As String
C#
public string LogStreamName { get; }
C++
public property string LogStreamName sealed {
String get();
}
J#
/** property */
public string get_LogStreamName();
JScript
public function get LogStreamName() : String

See Also

TestStepLogStreamEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamWriteEventArgs Class

TestStepLogStreamWriteEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that text has been written to a test step log stream. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepLogStreamWriteEventArgs
Inherits TestStepLogStreamEventArgs
C#
public sealed class TestStepLogStreamWriteEventArgs : TestStepLogStreamEventArgs
C++
ref class TestStepLogStreamWriteEventArgs sealed : TestStepLogStreamEventArgs
J#
public final class TestStepLogStreamWriteEventArgs extends TestStepLogStreamEventArgs
JScript
public final class TestStepLogStreamWriteEventArgs extends TestStepLogStreamEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamWriteEventArgs

See Also

TestStepLogStreamWriteEventArgs Members
Gallio.Runner.Events Namespace


TestStepLogStreamWriteEventArgs Members

TestStepLogStreamWriteEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that text has been written to a test step log stream. This class cannot be inherited.

The following tables list the members exposed by TestStepLogStreamWriteEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepLogStreamWriteEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Public property | Text | Gets the text that was written.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepLogStreamWriteEventArgs Class
Gallio.Runner.Events Namespace


TestStepLogStreamWriteEventArgs Constructor

TestStepLogStreamWriteEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal logStreamName As String, _
ByVal text As String _
)
C#
public TestStepLogStreamWriteEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
string text
)
C++
public:
TestStepLogStreamWriteEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String logStreamName,
String text
) sealed
J#
public TestStepLogStreamWriteEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string logStreamName,
string text
)
JScript
public function TestStepLogStreamWriteEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
logStreamName : String,
text : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
logStreamName
The log stream name
text
The text that was written

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun or logStreamName is null

See Also

TestStepLogStreamWriteEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepLogStreamWriteEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | LogStreamName | Gets the log stream name. (inherited from TestStepLogStreamEventArgs)
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Public property | Text | Gets the text that was written.
Top

See Also

TestStepLogStreamWriteEventArgs Class
Gallio.Runner.Events Namespace


Text Property

TestStepLogStreamWriteEventArgs.Text Property
[image]

Gets the text that was written.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text { get; }
C++
public property string Text sealed {
String get();
}
J#
/** property */
public string get_Text();
JScript
public function get Text() : String

See Also

TestStepLogStreamWriteEventArgs Class
Gallio.Runner.Events Namespace


TestStepMetadataAddedEventArgs Class

TestStepMetadataAddedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a test step dynamically added metadata to itself. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepMetadataAddedEventArgs
Inherits TestStepEventArgs
C#
public sealed class TestStepMetadataAddedEventArgs : TestStepEventArgs
C++
ref class TestStepMetadataAddedEventArgs sealed : TestStepEventArgs
J#
public final class TestStepMetadataAddedEventArgs extends TestStepEventArgs
JScript
public final class TestStepMetadataAddedEventArgs extends TestStepEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepMetadataAddedEventArgs

See Also

TestStepMetadataAddedEventArgs Members
Gallio.Runner.Events Namespace


TestStepMetadataAddedEventArgs Members

TestStepMetadataAddedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a test step dynamically added metadata to itself. This class cannot be inherited.

The following tables list the members exposed by TestStepMetadataAddedEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepMetadataAddedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | MetadataKey | Gets the metadata key.
Public property | MetadataValue | Gets the metadata value.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepMetadataAddedEventArgs Class
Gallio.Runner.Events Namespace


TestStepMetadataAddedEventArgs Constructor

TestStepMetadataAddedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun, _
ByVal metadataKey As String, _
ByVal metadataValue As String _
)
C#
public TestStepMetadataAddedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string metadataKey,
string metadataValue
)
C++
public:
TestStepMetadataAddedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
String metadataKey,
String metadataValue
) sealed
J#
public TestStepMetadataAddedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun,
string metadataKey,
string metadataValue
)
JScript
public function TestStepMetadataAddedEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun,
metadataKey : String,
metadataValue : String
)

Parameters

report
The report
test
The test data
testStepRun
The test step run
metadataKey
The metadata key
metadataValue
The metadata value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, testtestStepRun, metadataKey or metadataValue is null

See Also

TestStepMetadataAddedEventArgs Class
Gallio.Runner.Events Namespace


Properties

TestStepMetadataAddedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | MetadataKey | Gets the metadata key.
Public property | MetadataValue | Gets the metadata value.
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

See Also

TestStepMetadataAddedEventArgs Class
Gallio.Runner.Events Namespace


MetadataKey Property

TestStepMetadataAddedEventArgs.MetadataKey Property
[image]

Gets the metadata key.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataKey As String
C#
public string MetadataKey { get; }
C++
public property string MetadataKey sealed {
String get();
}
J#
/** property */
public string get_MetadataKey();
JScript
public function get MetadataKey() : String

See Also

TestStepMetadataAddedEventArgs Class
Gallio.Runner.Events Namespace
MetadataKeys


MetadataValue Property

TestStepMetadataAddedEventArgs.MetadataValue Property
[image]

Gets the metadata value.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataValue As String
C#
public string MetadataValue { get; }
C++
public property string MetadataValue sealed {
String get();
}
J#
/** property */
public string get_MetadataValue();
JScript
public function get MetadataValue() : String

See Also

TestStepMetadataAddedEventArgs Class
Gallio.Runner.Events Namespace


TestStepStartedEventArgs Class

TestStepStartedEventArgs Class
See Also Example Members
[image]

Arguments for an event raised to indicate that a test step has started execution. This class cannot be inherited.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TestStepStartedEventArgs
Inherits TestStepEventArgs
C#
public sealed class TestStepStartedEventArgs : TestStepEventArgs
C++
ref class TestStepStartedEventArgs sealed : TestStepEventArgs
J#
public final class TestStepStartedEventArgs extends TestStepEventArgs
JScript
public final class TestStepStartedEventArgs extends TestStepEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepStartedEventArgs

See Also

TestStepStartedEventArgs Members
Gallio.Runner.Events Namespace


TestStepStartedEventArgs Members

TestStepStartedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Arguments for an event raised to indicate that a test step has started execution. This class cannot be inherited.

The following tables list the members exposed by TestStepStartedEventArgs.

Public Constructors

 | Name | Description
Public method | TestStepStartedEventArgs | Initializes the event arguments.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report. (inherited from TestStepEventArgs)
Public property | Test | Gets the test data of the test that contains the test step. (inherited from TestStepEventArgs)
Public property | TestStepRun | Gets the test step run. (inherited from TestStepEventArgs)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStepKind | Gets the kind of step described using the TestKind metadata key. (inherited from TestStepEventArgs)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepStartedEventArgs Class
Gallio.Runner.Events Namespace


TestStepStartedEventArgs Constructor

TestStepStartedEventArgs Constructor
[image]

Initializes the event arguments.

Namespace: Gallio.Runner.Events
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal test As TestData, _
ByVal testStepRun As TestStepRun _
)
C#
public TestStepStartedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
)
C++
public:
TestStepStartedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
) sealed
J#
public TestStepStartedEventArgs(
Report report,
TestData test,
TestStepRun testStepRun
)
JScript
public function TestStepStartedEventArgs(
report : Report,
test : TestData,
testStepRun : TestStepRun
)

Parameters

report
The report
test
The test data
testStepRun
The test step run

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report, test or testStepRun is null

See Also

TestStepStartedEventArgs Class
Gallio.Runner.Events Namespace


Gallio.Runner.Extensions

Gallio.Runner.Extensions Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | DebugExtension | Monitors ITestRunner events and writes debug messages to the runner's logger.
Public class | LogExtension | The log extension writes a summary of test execution progress to the test runner's logger so the user can monitor what's going on. Passing tests are recorded with severity Info, warnings are recorded with severity Warning and failures are recorded with severity Error.
Public class | TestRunnerExtension | Abstract implementation of a test runner extension. for more details. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestRunnerExtensionUtils | Provides utilities for manipulating test runner extensions. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

Interface Description
Public interface ITestRunnerExtension

A test runner extension plugs augments the behavior oa ITestRunner by attaching new behaviors to its event handlers.

Typical extension use-cases:

  • Custom logging by listening for events of interest and writing messages to a file or to another location.
  • Custom configuration of test package loading, test exploration and test execution options by listening for the starting events of the phase and modifying the options in place.


DebugExtension Class

DebugExtension Class
See Also Example Members
[image]

Monitors ITestRunner events and writes debug messages to the runner's logger.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DebugExtension
Inherits TestRunnerExtension
C#
public class DebugExtension : TestRunnerExtension
C++
ref class DebugExtension : TestRunnerExtension
J#
public class DebugExtension extends TestRunnerExtension
JScript
public class DebugExtension extends TestRunnerExtension

Inheritance Hierarchy

System.Object
Gallio.Runner.Extensions.TestRunnerExtension
Gallio.Runner.Extensions.DebugExtension

See Also

DebugExtension Members
Gallio.Runner.Extensions Namespace


DebugExtension Members

DebugExtension Members
See Also Example Constructors Properties Methods
[image]

Monitors ITestRunner events and writes debug messages to the runner's logger.

The following tables list the members exposed by DebugExtension.

Public Constructors

 | Name | Description
Public method | DebugExtension | Initializes a new instance of the DebugExtension class.
Top

Public Properties

 | Name | Description
Public property | Events | Gets the test runner event extension point. (inherited from TestRunnerExtension)
Public property | Logger | Gets the logger. (inherited from TestRunnerExtension)
Public property | Parameters | Gets or sets configuration parameters for the extension. (inherited from TestRunnerExtension)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Install | Installs the extension into a test runner. (inherited from TestRunnerExtension)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the extension as part of extension installation.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DebugExtension Class
Gallio.Runner.Extensions Namespace


DebugExtension Constructor

DebugExtension Constructor
[image]

Initializes a new instance of the DebugExtension class.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DebugExtension()
C++
public:
DebugExtension() sealed
J#
public DebugExtension()
JScript
public function DebugExtension()

See Also

DebugExtension Class
Gallio.Runner.Extensions Namespace


Methods

DebugExtension Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Install | Installs the extension into a test runner. (inherited from TestRunnerExtension)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the extension as part of extension installation.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DebugExtension Class
Gallio.Runner.Extensions Namespace


Initialize Method

DebugExtension.Initialize Method
[image]

Initializes the extension as part of extension installation.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Initialize()
C#
protected override void Initialize()
C++
protected:
virtual void Initialize() override
J#
protected override void Initialize()
JScript
protected override function Initialize()

See Also

DebugExtension Class
Gallio.Runner.Extensions Namespace


ITestRunnerExtension Interface

ITestRunnerExtension Interface
See Also Example Members
[image]

A test runner extension plugs augments the behavior oa ITestRunner by attaching new behaviors to its event handlers.

Typical extension use-cases:

  • Custom logging by listening for events of interest and writing messages to a file or to another location.
  • Custom configuration of test package loading, test exploration and test execution options by listening for the starting events of the phase and modifying the options in place.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestRunnerExtension
C#
public interface ITestRunnerExtension
C++
interface class ITestRunnerExtension
J#
public interface ITestRunnerExtension
JScript
public interface ITestRunnerExtension

Types that implement ITestRunnerExtension

Type | Description
Gallio.Runner.Extensions.TestRunnerExtension | Abstract implementation of a test runner extension. for more details. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Remarks

More complex extensions such as integration of new test frameworks are typically performed by plugins because new runtime services must be registered to support them.

See Also

ITestRunnerExtension Members
Gallio.Runner.Extensions Namespace


ITestRunnerExtension Members

ITestRunnerExtension Members
See Also Example Properties Methods
[image]

A test runner extension plugs augments the behavior oa ITestRunner by attaching new behaviors to its event handlers.

Typical extension use-cases:

  • Custom logging by listening for events of interest and writing messages to a file or to another location.
  • Custom configuration of test package loading, test exploration and test execution options by listening for the starting events of the phase and modifying the options in place.

The following tables list the members exposed by ITestRunnerExtension.

Public Properties

 | Name | Description
Public property | Parameters | Gets or sets configuration parameters for the extension.
Top

Public Methods

 | Name | Description
Public method | Install | Installs the extension into a test runner.
Top

See Also

ITestRunnerExtension Interface
Gallio.Runner.Extensions Namespace


Properties

ITestRunnerExtension Properties
[image]

Public Properties

 | Name | Description
Public property | Parameters | Gets or sets configuration parameters for the extension.
Top

See Also

ITestRunnerExtension Interface
Gallio.Runner.Extensions Namespace


Parameters Property

ITestRunnerExtension.Parameters Property
[image]

Gets or sets configuration parameters for the extension.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Parameters As String
C#
string Parameters { get; set; }
C++
property string Parameters abstract {
String get();
void set(String value);
}
J#
/** property */
public string get_Parameters();

/** property */
public void set_Parameters(string value);
JScript
public function get Parameters() : String

public function set Parameters(value : String);

See Also

ITestRunnerExtension Interface
Gallio.Runner.Extensions Namespace


Methods

ITestRunnerExtension Methods
[image]

Public Methods

 | Name | Description
Public method | Install | Installs the extension into a test runner.
Top

See Also

ITestRunnerExtension Interface
Gallio.Runner.Extensions Namespace


Install Method

ITestRunnerExtension.Install Method
[image]

Installs the extension into a test runner.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Install( _
ByVal events As ITestRunnerEvents, _
ByVal logger As ILogger _
)
C#
void Install(
ITestRunnerEvents events,
ILogger logger
)
C++
void Install(
ITestRunnerEvents events,
ILogger logger
) abstract
J#
void Install(
ITestRunnerEvents events,
ILogger logger
)
JScript
function Install(
events : ITestRunnerEvents,
logger : ILogger
)

Parameters

events
The test runner events, not null
logger
The logger, not null

See Also

ITestRunnerExtension Interface
Gallio.Runner.Extensions Namespace


LogExtension Class

LogExtension Class
See Also Example Members
[image]

The log extension writes a summary of test execution progress to the test runner's logger so the user can monitor what's going on.

Passing tests are recorded with severity Info, warnings are recorded with severity Warning and failures are recorded with severity Error.
Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LogExtension
Inherits TestRunnerExtension
C#
public class LogExtension : TestRunnerExtension
C++
ref class LogExtension : TestRunnerExtension
J#
public class LogExtension extends TestRunnerExtension
JScript
public class LogExtension extends TestRunnerExtension

Inheritance Hierarchy

System.Object
Gallio.Runner.Extensions.TestRunnerExtension
Gallio.Runner.Extensions.LogExtension

See Also

LogExtension Members
Gallio.Runner.Extensions Namespace


LogExtension Members

LogExtension Members
See Also Example Constructors Properties Methods
[image]

The log extension writes a summary of test execution progress to the test runner's logger so the user can monitor what's going on.

Passing tests are recorded with severity Info, warnings are recorded with severity Warning and failures are recorded with severity Error.

The following tables list the members exposed by LogExtension.

Public Constructors

 | Name | Description
Public method | LogExtension | Initializes a new instance of the LogExtension class.
Top

Public Properties

 | Name | Description
Public property | Events | Gets the test runner event extension point. (inherited from TestRunnerExtension)
Public property | Logger | Gets the logger. (inherited from TestRunnerExtension)
Public property | Parameters | Gets or sets configuration parameters for the extension. (inherited from TestRunnerExtension)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Install | Installs the extension into a test runner. (inherited from TestRunnerExtension)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the extension as part of extension installation.
Family method | LogAnnotation | Logs an annotation.
Family method | LogTestCaseFinished | Logs a message about a test case that has finished.
Family method | LogTestCaseStarted | Logs a message about a test case that has started.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


LogExtension Constructor

LogExtension Constructor
[image]

Initializes a new instance of the LogExtension class.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LogExtension()
C++
public:
LogExtension() sealed
J#
public LogExtension()
JScript
public function LogExtension()

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


Methods

LogExtension Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Install | Installs the extension into a test runner. (inherited from TestRunnerExtension)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the extension as part of extension installation.
Family method | LogAnnotation | Logs an annotation.
Family method | LogTestCaseFinished | Logs a message about a test case that has finished.
Family method | LogTestCaseStarted | Logs a message about a test case that has started.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


Initialize Method

LogExtension.Initialize Method
[image]

Initializes the extension as part of extension installation.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Initialize()
C#
protected override void Initialize()
C++
protected:
virtual void Initialize() override
J#
protected override void Initialize()
JScript
protected override function Initialize()

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


LogAnnotation Method

LogExtension.LogAnnotation Method
[image]

Logs an annotation.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LogAnnotation( _
ByVal annotation As AnnotationData _
)
C#
protected virtual void LogAnnotation(
AnnotationData annotation
)
C++
protected:
virtual void LogAnnotation(
AnnotationData annotation
)
J#
protected virtual void LogAnnotation(
AnnotationData annotation
)
JScript
protected virtual function LogAnnotation(
annotation : AnnotationData
)

Parameters

annotation
The annotation to log

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


LogTestCaseFinished Method

LogExtension.LogTestCaseFinished Method
[image]

Logs a message about a test case that has finished.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LogTestCaseFinished( _
ByVal e As TestStepFinishedEventArgs _
)
C#
protected virtual void LogTestCaseFinished(
TestStepFinishedEventArgs e
)
C++
protected:
virtual void LogTestCaseFinished(
TestStepFinishedEventArgs e
)
J#
protected virtual void LogTestCaseFinished(
TestStepFinishedEventArgs e
)
JScript
protected virtual function LogTestCaseFinished(
e : TestStepFinishedEventArgs
)

Parameters

e
The event

Remarks

This method is not called for test steps that have IsTestCase set to false.

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


LogTestCaseStarted Method

LogExtension.LogTestCaseStarted Method
[image]

Logs a message about a test case that has started.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LogTestCaseStarted( _
ByVal e As TestStepStartedEventArgs _
)
C#
protected virtual void LogTestCaseStarted(
TestStepStartedEventArgs e
)
C++
protected:
virtual void LogTestCaseStarted(
TestStepStartedEventArgs e
)
J#
protected virtual void LogTestCaseStarted(
TestStepStartedEventArgs e
)
JScript
protected virtual function LogTestCaseStarted(
e : TestStepStartedEventArgs
)

Parameters

e
The event

Remarks

This method is not called for test steps that have IsTestCase set to false.

See Also

LogExtension Class
Gallio.Runner.Extensions Namespace


TestRunnerExtension Class

TestRunnerExtension Class
See Also Example Members
[image]

Abstract implementation of a test runner extension. for more details. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TestRunnerExtension
Implements ITestRunnerExtension
C#
public abstract class TestRunnerExtension : ITestRunnerExtension
C++
ref class TestRunnerExtension abstract : ITestRunnerExtension
J#
public class TestRunnerExtension implements ITestRunnerExtension
JScript
public class TestRunnerExtension extends ITestRunnerExtension

Inheritance Hierarchy

System.Object
Gallio.Runner.Extensions.TestRunnerExtension
Gallio.Runner.Extensions.DebugExtension
Gallio.Runner.Extensions.LogExtension

See Also

TestRunnerExtension Members
Gallio.Runner.Extensions Namespace
ITestRunnerExtension


TestRunnerExtension Members

TestRunnerExtension Members
See Also Example Constructors Properties Methods
[image]

Abstract implementation of a test runner extension. for more details. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestRunnerExtension.

Protected Constructors

 | Name | Description
Family method | TestRunnerExtension | Initializes a new instance of the TestRunnerExtension class.
Top

Public Properties

 | Name | Description
Public property | Events | Gets the test runner event extension point.
Public property | Logger | Gets the logger.
Public property | Parameters | Gets or sets configuration parameters for the extension.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Install | Installs the extension into a test runner.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Initializes the extension as part of extension installation.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace
ITestRunnerExtension


TestRunnerExtension Constructor

TestRunnerExtension Constructor
[image]

Initializes a new instance of the TestRunnerExtension class.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestRunnerExtension()
C++
protected:
TestRunnerExtension() sealed
J#
protected TestRunnerExtension()
JScript
protected function TestRunnerExtension()

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace


Properties

TestRunnerExtension Properties
[image]

Public Properties

 | Name | Description
Public property | Events | Gets the test runner event extension point.
Public property | Logger | Gets the logger.
Public property | Parameters | Gets or sets configuration parameters for the extension.
Top

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace
ITestRunnerExtension


Events Property

TestRunnerExtension.Events Property
[image]

Gets the test runner event extension point.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Events As ITestRunnerEvents
C#
public ITestRunnerEvents Events { get; }
C++
public property ITestRunnerEvents Events sealed {
ITestRunnerEvents get();
}
J#
/** property */
public ITestRunnerEvents get_Events();
JScript
public function get Events() : ITestRunnerEvents

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace


Logger Property

TestRunnerExtension.Logger Property
[image]

Gets the logger.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Logger As ILogger
C#
public ILogger Logger { get; }
C++
public property ILogger Logger sealed {
ILogger get();
}
J#
/** property */
public ILogger get_Logger();
JScript
public function get Logger() : ILogger

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace


Parameters Property

TestRunnerExtension.Parameters Property
[image]

Gets or sets configuration parameters for the extension.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameters As String _
Implements ITestRunnerExtension.Parameters
C#
public string Parameters { get; set; }
C++
public property string Parameters sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Parameters();

/** property */
public void set_Parameters(string value);
JScript
public function get Parameters() : String

public function set Parameters(value : String);

Implements

ITestRunnerExtension.Parameters

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace


Methods

TestRunnerExtension Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Install | Installs the extension into a test runner.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Initializes the extension as part of extension installation.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace
ITestRunnerExtension


Initialize Method

TestRunnerExtension.Initialize Method
[image]

Initializes the extension as part of extension installation.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub Initialize()
C#
protected abstract void Initialize()
C++
protected:
void Initialize() abstract
J#
protected abstract void Initialize()
JScript
protected abstract function Initialize()

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace


Install Method

TestRunnerExtension.Install Method
[image]

Installs the extension into a test runner.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Install( _
ByVal events As ITestRunnerEvents, _
ByVal logger As ILogger _
) _
Implements ITestRunnerExtension.Install
C#
public void Install(
ITestRunnerEvents events,
ILogger logger
)
C++
public:
void Install(
ITestRunnerEvents events,
ILogger logger
) sealed
J#
public void Install(
ITestRunnerEvents events,
ILogger logger
)
JScript
public function Install(
events : ITestRunnerEvents,
logger : ILogger
)

Parameters

events
The test runner events, not null
logger
The logger, not null

Implements

ITestRunnerExtension.Install

See Also

TestRunnerExtension Class
Gallio.Runner.Extensions Namespace


TestRunnerExtensionUtils Class

TestRunnerExtensionUtils Class
See Also Example Members
[image]

Provides utilities for manipulating test runner extensions. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module TestRunnerExtensionUtils
C#
public static class TestRunnerExtensionUtils
C++
ref class TestRunnerExtensionUtils abstract sealed
J#
public final class TestRunnerExtensionUtils
JScript
public class TestRunnerExtensionUtils

Inheritance Hierarchy

System.Object
Gallio.Runner.Extensions.TestRunnerExtensionUtils

See Also

TestRunnerExtensionUtils Members
Gallio.Runner.Extensions Namespace


TestRunnerExtensionUtils Members

TestRunnerExtensionUtils Members
See Also Example Methods
[image]

Provides utilities for manipulating test runner extensions. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by TestRunnerExtensionUtils.

Public Methods

Name Description
CreateExtensionFromSpecification

Creates an extension from its specification.

An extension specification has the form "[Namespace.]Type,Assembly[;Parameters]". The extension class must implement ITestRunnerExtension. The namespace may be omitted if the assembly contains exactly one class with the specified name. The parameter string is passed to the extension exactly as written.

Examples:

  • "MyExtensions.MyExtension,MyExtensions.dll;Parameter1,Parameter2"
  • "CustomLogger,MyExtensions"
Top

See Also

TestRunnerExtensionUtils Class
Gallio.Runner.Extensions Namespace


Methods

TestRunnerExtensionUtils Methods
[image]

Public Methods

Name Description
CreateExtensionFromSpecification

Creates an extension from its specification.

An extension specification has the form "[Namespace.]Type,Assembly[;Parameters]". The extension class must implement ITestRunnerExtension. The namespace may be omitted if the assembly contains exactly one class with the specified name. The parameter string is passed to the extension exactly as written.

Examples:

  • "MyExtensions.MyExtension,MyExtensions.dll;Parameter1,Parameter2"
  • "CustomLogger,MyExtensions"
Top

See Also

TestRunnerExtensionUtils Class
Gallio.Runner.Extensions Namespace


CreateExtensionFromSpecification Method

TestRunnerExtensionUtils.CreateExtensionFromSpecification Method
See Also Example
[image]

Creates an extension from its specification.

An extension specification has the form "[Namespace.]Type,Assembly[;Parameters]". The extension class must implement ITestRunnerExtension. The namespace may be omitted if the assembly contains exactly one class with the specified name. The parameter string is passed to the extension exactly as written.

Examples:

  • "MyExtensions.MyExtension,MyExtensions.dll;Parameter1,Parameter2"
  • "CustomLogger,MyExtensions"

Namespace: Gallio.Runner.Extensions
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateExtensionFromSpecification( _
ByVal extensionSpecification As String _
) As ITestRunnerExtension
C#
public static ITestRunnerExtension CreateExtensionFromSpecification(
string extensionSpecification
)
C++
public:
static ITestRunnerExtension CreateExtensionFromSpecification(
String extensionSpecification
)
J#
public static ITestRunnerExtension CreateExtensionFromSpecification(
string extensionSpecification
)
JScript
public static function CreateExtensionFromSpecification(
extensionSpecification : String
) : ITestRunnerExtension

Parameters

extensionSpecification
The extension specification

Return Value

The extension

Exceptions

Exception Type | Condition
RunnerException | Thrown if the extension cannot be instantiated and configured
ArgumentNullException | Thrown if extensionSpecification is null

See Also

TestRunnerExtensionUtils Class
Gallio.Runner.Extensions Namespace


Gallio.Runner.Harness

Gallio.Runner.Harness Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ConsoleTestEnvironment | Sets up console I/O streams.
Public class | ContextualLogTextWriter | A contextual log text writer messages to a named log stream in the log associated with the test execution context that is active at the time each message is written. This class cannot be inherited.
Public class | ContextualLogTraceListener | A contextual log trace listener messages to a named log stream in the log associated with the test execution context that is active at the time each message is written. This class cannot be inherited.
Public class | DefaultTestHarness | Default implementation of a test harness.
Public class | DefaultTestHarnessFactory | The default test harness factory creates a DefaultTestHarness.
Public class | TraceTestEnvironment | Sets up trace listeners.
Public class | UnhandledExceptionTestEnvironment | Logs unhandled exceptions instead of killing the AppDomain.

Interfaces

 | Interface | Description
Public interface | ITestEnvironment | The test environment configures global behavior related to preparing the test execution environment for running tests and tearing them down.
Public interface | ITestHarness | The test harness manages the lifecycle of test enumeration and execution. Contributors (such as test framework adapters) may attach event handlers to extend or modify the behavior at distinct points in the lifecycle. A new test harness instance is created when a test project is loaded into memory to serve as the ultimate container for all of its related resources.
Public interface | ITestHarnessFactory | A test harness factory.


ConsoleTestEnvironment Class

ConsoleTestEnvironment Class
See Also Example Members
[image]

Sets up console I/O streams.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ConsoleTestEnvironment
Implements ITestEnvironment
C#
public class ConsoleTestEnvironment : ITestEnvironment
C++
ref class ConsoleTestEnvironment : ITestEnvironment
J#
public class ConsoleTestEnvironment implements ITestEnvironment
JScript
public class ConsoleTestEnvironment extends ITestEnvironment

Inheritance Hierarchy

System.Object
Gallio.Runner.Harness.ConsoleTestEnvironment

See Also

ConsoleTestEnvironment Members
Gallio.Runner.Harness Namespace


ConsoleTestEnvironment Members

ConsoleTestEnvironment Members
See Also Example Constructors Methods
[image]

Sets up console I/O streams.

The following tables list the members exposed by ConsoleTestEnvironment.

Public Constructors

 | Name | Description
Public method | ConsoleTestEnvironment | Initializes a new instance of the ConsoleTestEnvironment class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetUp | Sets up the test environment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ConsoleTestEnvironment Class
Gallio.Runner.Harness Namespace


ConsoleTestEnvironment Constructor

ConsoleTestEnvironment Constructor
[image]

Initializes a new instance of the ConsoleTestEnvironment class.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ConsoleTestEnvironment()
C++
public:
ConsoleTestEnvironment() sealed
J#
public ConsoleTestEnvironment()
JScript
public function ConsoleTestEnvironment()

See Also

ConsoleTestEnvironment Class
Gallio.Runner.Harness Namespace


Methods

ConsoleTestEnvironment Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetUp | Sets up the test environment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ConsoleTestEnvironment Class
Gallio.Runner.Harness Namespace


SetUp Method

ConsoleTestEnvironment.SetUp Method
[image]

Sets up the test environment.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SetUp() As IDisposable _
Implements ITestEnvironment.SetUp
C#
public IDisposable SetUp()
C++
public:
IDisposable SetUp() sealed
J#
public IDisposable SetUp()
JScript
public function SetUp() : IDisposable

Return Value

Returns an object that when disposed causes the test environment to be torn down

Implements

ITestEnvironment.SetUp

See Also

ConsoleTestEnvironment Class
Gallio.Runner.Harness Namespace


ContextualLogTextWriter Class

ContextualLogTextWriter Class
See Also Example Members
[image]

A contextual log text writer messages to a named log stream in the log associated with the test execution context that is active at the time each message is written. This class cannot be inherited.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class ContextualLogTextWriter
Inherits TextWriter
C#
[SerializableAttribute]
public sealed class ContextualLogTextWriter : TextWriter
C++
[SerializableAttribute]
ref class ContextualLogTextWriter sealed : TextWriter
J#
/** @attribute SerializableAttribute() */
public final class ContextualLogTextWriter extends TextWriter
JScript
public
SerializableAttribute
final class ContextualLogTextWriter extends TextWriter

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.TextWriter
Gallio.Runner.Harness.ContextualLogTextWriter

See Also

ContextualLogTextWriter Members
Gallio.Runner.Harness Namespace


ContextualLogTextWriter Members

ContextualLogTextWriter Members
See Also Example Constructors Properties Methods
[image]

A contextual log text writer messages to a named log stream in the log associated with the test execution context that is active at the time each message is written. This class cannot be inherited.

The following tables list the members exposed by ContextualLogTextWriter.

Public Constructors

 | Name | Description
Public method | ContextualLogTextWriter | Creates a text writer that writes to the specified execution log stream.
Top

Public Properties

 | Name | Description
Public property | Encoding | Overridden. When overridden in a derived class, returns the Encoding in which the output is written.
Public property | FormatProvider | Gets an object that controls formatting. (inherited from TextWriter)
Public property | NewLine | Overridden. Gets or sets the line terminator string used by the current TextWriter.
Top

Public Methods

 | Name | Description
Public method | Close | Closes the current writer and releases any system resources associated with the writer. (inherited from TextWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Releases all resources used by the TextWriter object. (inherited from TextWriter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (inherited from TextWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded. Writes the given data type to a text stream.
Public method | WriteLine | Overloaded. Writes some data as specified by the overloaded parameters, followed by a line terminator. (inherited from TextWriter)
Top

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


ContextualLogTextWriter Constructor

ContextualLogTextWriter Constructor
[image]

Creates a text writer that writes to the specified execution log stream.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal streamName As String _
)
C#
public ContextualLogTextWriter(
string streamName
)
C++
public:
ContextualLogTextWriter(
String streamName
) sealed
J#
public ContextualLogTextWriter(
string streamName
)
JScript
public function ContextualLogTextWriter(
streamName : String
)

Parameters

streamName
The execution log stream name

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


Properties

ContextualLogTextWriter Properties
[image]

Public Properties

 | Name | Description
Public property | Encoding | Overridden. When overridden in a derived class, returns the Encoding in which the output is written.
Public property | FormatProvider | Gets an object that controls formatting. (inherited from TextWriter)
Public property | NewLine | Overridden. Gets or sets the line terminator string used by the current TextWriter.
Top

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


Encoding Property

ContextualLogTextWriter.Encoding Property
[image]

When overridden in a derived class, returns the Encoding in which the output is written.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Encoding As Encoding
C#
public override Encoding Encoding { get; }
C++
public override property Encoding Encoding override {
Encoding get();
}
J#
/** property */
public Encoding get_Encoding();
JScript
public function get Encoding() : Encoding

Property Value

The Encoding in which the output is written.

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


NewLine Property

ContextualLogTextWriter.NewLine Property
[image]

Gets or sets the line terminator string used by the current TextWriter.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property NewLine As String
C#
public override string NewLine { get; set; }
C++
public override property string NewLine override {
String get();
void set(String value);
}
J#
/** property */
public string get_NewLine();

/** property */
public void set_NewLine(string value);
JScript
public function get NewLine() : String

public function set NewLine(value : String);

Property Value

The line terminator string for the current TextWriter.

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


Methods

ContextualLogTextWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Close | Closes the current writer and releases any system resources associated with the writer. (inherited from TextWriter)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Releases all resources used by the TextWriter object. (inherited from TextWriter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (inherited from TextWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded. Writes the given data type to a text stream.
Public method | WriteLine | Overloaded. Writes some data as specified by the overloaded parameters, followed by a line terminator. (inherited from TextWriter)
Top

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


Write Method

ContextualLogTextWriter.Write Method

Writes the given data type to a text stream.

Overload List

 | Name | Description
Public method | Write (Char) | Overridden. Writes a character to the text stream.
Public method | Write (Char, Int32, Int32) | Overridden. Writes a subarray of characters to the text stream.
Public method | Write (String) | Overridden. Writes a string to the text stream.
Public method | Write (Boolean) | Writes the text representation of a Boolean value to the text stream. (inherited from TextWriter)
Public method | Write (Char) | Writes a character array to the text stream. (inherited from TextWriter)
Public method | Write (Decimal) | Writes the text representation of a decimal value followed by a line terminator to the text stream. (inherited from TextWriter)
Public method | Write (Double) | Writes the text representation of an 8-byte floating-point value to the text stream. (inherited from TextWriter)
Public method | Write (Int32) | Writes the text representation of a 4-byte signed integer to the text stream. (inherited from TextWriter)
Public method | Write (Int64) | Writes the text representation of an 8-byte signed integer to the text stream. (inherited from TextWriter)
Public method | Write (Object) | Writes the text representation of an object to the text stream by calling ToString on that object. (inherited from TextWriter)
Public method | Write (Single) | Writes the text representation of a 4-byte floating-point value to the text stream. (inherited from TextWriter)
Public method | Write (String, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (String, Object, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (String, Object, Object, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (String, Object) | Writes out a formatted string, using the same semantics as Format. (inherited from TextWriter)
Public method | Write (UInt32) | Writes the text representation of a 4-byte unsigned integer to the text stream. (inherited from TextWriter)
Public method | Write (UInt64) | Writes the text representation of an 8-byte unsigned integer to the text stream. (inherited from TextWriter)

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace


Write Method (Char)

ContextualLogTextWriter.Write Method (Char)
See Also Example
[image]

Writes a character to the text stream.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal value As Char _
)
C#
public override void Write(
char value
)
C++
public:
virtual void Write(
wchar_t value
) override
J#
public override void Write(
char value
)
JScript
public override function Write(
value : char
)

Parameters

value
The character to write to the text stream.

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace
ContextualLogTextWriter.Write Overload List


Write Method (Char[], Int32, Int32)

ContextualLogTextWriter.Write Method (Char[], Int32, Int32)
See Also Example
[image]

Writes a subarray of characters to the text stream.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal buffer As Char(), _
ByVal index As Integer, _
ByVal count As Integer _
)
C#
public override void Write(
char[] buffer,
int index,
int count
)
C++
public:
virtual void Write(
array<wchar_t>^ buffer,
int index,
int count
) override
J#
public override void Write(
char[] buffer,
int index,
int count
)
JScript
public override function Write(
buffer : char[],
index : int,
count : int
)

Parameters

buffer
The character array to write data from.
index
Starting index in the buffer.
count
The number of characters to write.

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace
ContextualLogTextWriter.Write Overload List


Write Method (String)

ContextualLogTextWriter.Write Method (String)
See Also Example
[image]

Writes a string to the text stream.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal value As String _
)
C#
public override void Write(
string value
)
C++
public:
virtual void Write(
String value
) override
J#
public override void Write(
string value
)
JScript
public override function Write(
value : String
)

Parameters

value
The string to write.

See Also

ContextualLogTextWriter Class
Gallio.Runner.Harness Namespace
ContextualLogTextWriter.Write Overload List


ContextualLogTraceListener Class

ContextualLogTraceListener Class
See Also Example Members
[image]

A contextual log trace listener messages to a named log stream in the log associated with the test execution context that is active at the time each message is written. This class cannot be inherited.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ContextualLogTraceListener
Inherits TraceListener
C#
public sealed class ContextualLogTraceListener : TraceListener
C++
ref class ContextualLogTraceListener sealed : TraceListener
J#
public final class ContextualLogTraceListener extends TraceListener
JScript
public final class ContextualLogTraceListener extends TraceListener

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Diagnostics.TraceListener
Gallio.Runner.Harness.ContextualLogTraceListener

See Also

ContextualLogTraceListener Members
Gallio.Runner.Harness Namespace


ContextualLogTraceListener Members

ContextualLogTraceListener Members
See Also Example Constructors Properties Methods
[image]

A contextual log trace listener messages to a named log stream in the log associated with the test execution context that is active at the time each message is written. This class cannot be inherited.

The following tables list the members exposed by ContextualLogTraceListener.

Public Constructors

 | Name | Description
Public method | ContextualLogTraceListener | Creates a trace listener that writes to the specified execution log stream.
Top

Public Properties

 | Name | Description
Public property | Attributes | Gets the custom trace listener attributes defined in the application configuration file. (inherited from TraceListener)
Public property | Filter | Gets and sets the trace filter for the trace listener. (inherited from TraceListener)
Public property | IndentLevel | Gets or sets the indent level. (inherited from TraceListener)
Public property | IndentSize | Gets or sets the number of spaces in an indent. (inherited from TraceListener)
Public property | IsThreadSafe | Overridden. Gets a value indicating whether the trace listener is thread safe.
Public property | Name | Gets or sets a name for this TraceListener. (inherited from TraceListener)
Public property | TraceOutputOptions | Gets or sets the trace output options. (inherited from TraceListener)
Top

Public Methods

 | Name | Description
Public method | Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (inherited from TraceListener)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Releases all resources used by the TraceListener. (inherited from TraceListener)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Fail | Overloaded. Emits error messages to the listener you create when you implement the TraceListener class. (inherited from TraceListener)
Public method | Flush | When overridden in a derived class, flushes the output buffer. (inherited from TraceListener)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TraceData | Overloaded. Writes trace data to the listener specific output. (inherited from TraceListener)
Public method | TraceEvent | Overloaded. Writes trace and event information to the listener specific output. (inherited from TraceListener)
Public method | TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (inherited from TraceListener)
Public method | Write | Overloaded. Writes a message, category name, or the value of an object's ToString method to the listener you create when you implement the TraceListener class.
Public method | WriteLine | Overloaded. Writes a message, category name, or the value of an object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator.
Top

Protected Methods

 | Name | Description
Family method | GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (inherited from TraceListener)
Top

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


ContextualLogTraceListener Constructor

ContextualLogTraceListener Constructor
[image]

Creates a trace listener that writes to the specified execution log stream.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal streamName As String _
)
C#
public ContextualLogTraceListener(
string streamName
)
C++
public:
ContextualLogTraceListener(
String streamName
) sealed
J#
public ContextualLogTraceListener(
string streamName
)
JScript
public function ContextualLogTraceListener(
streamName : String
)

Parameters

streamName
The execution log stream name

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


Properties

ContextualLogTraceListener Properties
[image]

Public Properties

 | Name | Description
Public property | Attributes | Gets the custom trace listener attributes defined in the application configuration file. (inherited from TraceListener)
Public property | Filter | Gets and sets the trace filter for the trace listener. (inherited from TraceListener)
Public property | IndentLevel | Gets or sets the indent level. (inherited from TraceListener)
Public property | IndentSize | Gets or sets the number of spaces in an indent. (inherited from TraceListener)
Public property | IsThreadSafe | Overridden. Gets a value indicating whether the trace listener is thread safe.
Public property | Name | Gets or sets a name for this TraceListener. (inherited from TraceListener)
Public property | TraceOutputOptions | Gets or sets the trace output options. (inherited from TraceListener)
Top

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


IsThreadSafe Property

ContextualLogTraceListener.IsThreadSafe Property
[image]

Gets a value indicating whether the trace listener is thread safe.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsThreadSafe As Boolean
C#
public override bool IsThreadSafe { get; }
C++
public override property bool IsThreadSafe override {
bool get();
}
J#
/** property */
public bool get_IsThreadSafe();
JScript
public function get IsThreadSafe() : bool

Property Value

true if the trace listener is thread safe; otherwise, false. The default is false.

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


Methods

ContextualLogTraceListener Methods
[image]

Public Methods

 | Name | Description
Public method | Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (inherited from TraceListener)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Releases all resources used by the TraceListener. (inherited from TraceListener)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Fail | Overloaded. Emits error messages to the listener you create when you implement the TraceListener class. (inherited from TraceListener)
Public method | Flush | When overridden in a derived class, flushes the output buffer. (inherited from TraceListener)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TraceData | Overloaded. Writes trace data to the listener specific output. (inherited from TraceListener)
Public method | TraceEvent | Overloaded. Writes trace and event information to the listener specific output. (inherited from TraceListener)
Public method | TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (inherited from TraceListener)
Public method | Write | Overloaded. Writes a message, category name, or the value of an object's ToString method to the listener you create when you implement the TraceListener class.
Public method | WriteLine | Overloaded. Writes a message, category name, or the value of an object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator.
Top

Protected Methods

 | Name | Description
Family method | GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (inherited from TraceListener)
Top

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


Write Method

ContextualLogTraceListener.Write Method

Writes a message, category name, or the value of an object's ToString method to the listener you create when you implement the TraceListener class.

Overload List

 | Name | Description
Public method | Write (String) | Overridden. When overridden in a derived class, writes the specified message to the listener you create in the derived class.
Public method | Write (Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (inherited from TraceListener)
Public method | Write (Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (inherited from TraceListener)
Public method | Write (String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (inherited from TraceListener)

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


Write Method (String)

ContextualLogTraceListener.Write Method (String)
See Also Example
[image]

When overridden in a derived class, writes the specified message to the listener you create in the derived class.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal message As String _
)
C#
public override void Write(
string message
)
C++
public:
virtual void Write(
String message
) override
J#
public override void Write(
string message
)
JScript
public override function Write(
message : String
)

Parameters

message
A message to write.

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace
ContextualLogTraceListener.Write Overload List


WriteLine Method

ContextualLogTraceListener.WriteLine Method

Writes a message, category name, or the value of an object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator.

Overload List

 | Name | Description
Public method | WriteLine (String) | Overridden. When overridden in a derived class, writes a message to the listener you create in the derived class, followed by a line terminator.
Public method | WriteLine (Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (inherited from TraceListener)
Public method | WriteLine (Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (inherited from TraceListener)
Public method | WriteLine (String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (inherited from TraceListener)

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace


WriteLine Method (String)

ContextualLogTraceListener.WriteLine Method (String)
See Also Example
[image]

When overridden in a derived class, writes a message to the listener you create in the derived class, followed by a line terminator.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteLine( _
ByVal message As String _
)
C#
public override void WriteLine(
string message
)
C++
public:
virtual void WriteLine(
String message
) override
J#
public override void WriteLine(
string message
)
JScript
public override function WriteLine(
message : String
)

Parameters

message
A message to write.

See Also

ContextualLogTraceListener Class
Gallio.Runner.Harness Namespace
ContextualLogTraceListener.WriteLine Overload List


DefaultTestHarness Class

DefaultTestHarness Class
See Also Example Members
[image]

Default implementation of a test harness.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestHarness
Implements ITestHarness, IDisposable
C#
public class DefaultTestHarness : ITestHarness, IDisposable
C++
ref class DefaultTestHarness : ITestHarness, IDisposable
J#
public class DefaultTestHarness implements ITestHarness, IDisposable
JScript
public class DefaultTestHarness extends ITestHarness, IDisposable

Remarks

The RuntimeAccessor must be initialized prior to using this factory because the tests will run within the current AppDomain and RuntimeAccessor.

Inheritance Hierarchy

System.Object
Gallio.Runner.Harness.DefaultTestHarness

See Also

DefaultTestHarness Members
Gallio.Runner.Harness Namespace


DefaultTestHarness Members

DefaultTestHarness Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a test harness.

The following tables list the members exposed by DefaultTestHarness.

Public Constructors

 | Name | Description
Public method | DefaultTestHarness | Creates a test harness.
Top

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model, or null if the test model has not been built.
Public property | TestPackage | Gets the test package loaded in the test harness, or null if none.
Top

Public Methods

 | Name | Description
Public method | AddTestEnvironment | Adds a test environment.
Public method | AddTestFramework | Adds a test framework.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Populates the test model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Load | Loads a test package into the test harness.
Public method | Run | Runs the tests.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Unload | Unloads the tests.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


DefaultTestHarness Constructor

DefaultTestHarness Constructor
[image]

Creates a test harness.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal contextTracker As ITestContextTracker, _
ByVal loader As ILoader _
)
C#
public DefaultTestHarness(
ITestContextTracker contextTracker,
ILoader loader
)
C++
public:
DefaultTestHarness(
ITestContextTracker contextTracker,
ILoader loader
) sealed
J#
public DefaultTestHarness(
ITestContextTracker contextTracker,
ILoader loader
)
JScript
public function DefaultTestHarness(
contextTracker : ITestContextTracker,
loader : ILoader
)

Parameters

contextTracker
The test context tracker
loader
The loader

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if contextTracker or loader is null

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Properties

DefaultTestHarness Properties
[image]

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model, or null if the test model has not been built.
Public property | TestPackage | Gets the test package loaded in the test harness, or null if none.
Top

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


TestModel Property

DefaultTestHarness.TestModel Property
[image]

Gets the test model, or null if the test model has not been built.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestModel As TestModel _
Implements ITestHarness.TestModel
C#
public TestModel TestModel { get; }
C++
public property TestModel TestModel sealed {
TestModel get();
}
J#
/** property */
public TestModel get_TestModel();
JScript
public function get TestModel() : TestModel

Implements

ITestHarness.TestModel

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


TestPackage Property

DefaultTestHarness.TestPackage Property
[image]

Gets the test package loaded in the test harness, or null if none.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestPackage As TestPackage _
Implements ITestHarness.TestPackage
C#
public TestPackage TestPackage { get; }
C++
public property TestPackage TestPackage sealed {
TestPackage get();
}
J#
/** property */
public TestPackage get_TestPackage();
JScript
public function get TestPackage() : TestPackage

Implements

ITestHarness.TestPackage

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Methods

DefaultTestHarness Methods
[image]

Public Methods

 | Name | Description
Public method | AddTestEnvironment | Adds a test environment.
Public method | AddTestFramework | Adds a test framework.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Explore | Populates the test model.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Load | Loads a test package into the test harness.
Public method | Run | Runs the tests.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Unload | Unloads the tests.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


AddTestEnvironment Method

DefaultTestHarness.AddTestEnvironment Method
[image]

Adds a test environment.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddTestEnvironment( _
ByVal environment As ITestEnvironment _
) _
Implements ITestHarness.AddTestEnvironment
C#
public void AddTestEnvironment(
ITestEnvironment environment
)
C++
public:
void AddTestEnvironment(
ITestEnvironment environment
) sealed
J#
public void AddTestEnvironment(
ITestEnvironment environment
)
JScript
public function AddTestEnvironment(
environment : ITestEnvironment
)

Parameters

environment
The test framework to add

Implements

ITestHarness.AddTestEnvironment

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


AddTestFramework Method

DefaultTestHarness.AddTestFramework Method
[image]

Adds a test framework.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddTestFramework( _
ByVal framework As ITestFramework _
) _
Implements ITestHarness.AddTestFramework
C#
public void AddTestFramework(
ITestFramework framework
)
C++
public:
void AddTestFramework(
ITestFramework framework
) sealed
J#
public void AddTestFramework(
ITestFramework framework
)
JScript
public function AddTestFramework(
framework : ITestFramework
)

Parameters

framework
The test framework to add

Implements

ITestHarness.AddTestFramework

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Dispose Method

DefaultTestHarness.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Explore Method

DefaultTestHarness.Explore Method
[image]

Populates the test model.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Explore( _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestHarness.Explore
C#
public void Explore(
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
public:
void Explore(
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) sealed
J#
public void Explore(
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
public function Explore(
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

Parameters

testExplorationOptions
The test exploration options
testExplorationListener
The test exploration listener
progressMonitor
The progress monitor

Implements

ITestHarness.Explore

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Load Method

DefaultTestHarness.Load Method
[image]

Loads a test package into the test harness.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Load( _
ByVal packageConfig As TestPackageConfig, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestHarness.Load
C#
public void Load(
TestPackageConfig packageConfig,
IProgressMonitor progressMonitor
)
C++
public:
void Load(
TestPackageConfig packageConfig,
IProgressMonitor progressMonitor
) sealed
J#
public void Load(
TestPackageConfig packageConfig,
IProgressMonitor progressMonitor
)
JScript
public function Load(
packageConfig : TestPackageConfig,
progressMonitor : IProgressMonitor
)

Parameters

packageConfig
The test package configuration
progressMonitor
The progress monitor

Implements

ITestHarness.Load

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Run Method

DefaultTestHarness.Run Method
[image]

Runs the tests.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Run( _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestHarness.Run
C#
public void Run(
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
public:
void Run(
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) sealed
J#
public void Run(
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
public function Run(
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

Parameters

testExecutionOptions
The test execution options
testExecutionListener
The test execution listener
progressMonitor
The progress monitor

Implements

ITestHarness.Run

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


Unload Method

DefaultTestHarness.Unload Method
[image]

Unloads the tests.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Unload( _
ByVal progressMonitor As IProgressMonitor _
) _
Implements ITestHarness.Unload
C#
public void Unload(
IProgressMonitor progressMonitor
)
C++
public:
void Unload(
IProgressMonitor progressMonitor
) sealed
J#
public void Unload(
IProgressMonitor progressMonitor
)
JScript
public function Unload(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Implements

ITestHarness.Unload

See Also

DefaultTestHarness Class
Gallio.Runner.Harness Namespace


DefaultTestHarnessFactory Class

DefaultTestHarnessFactory Class
See Also Example Members
[image]

The default test harness factory creates a DefaultTestHarness.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultTestHarnessFactory
Implements ITestHarnessFactory
C#
public class DefaultTestHarnessFactory : ITestHarnessFactory
C++
ref class DefaultTestHarnessFactory : ITestHarnessFactory
J#
public class DefaultTestHarnessFactory implements ITestHarnessFactory
JScript
public class DefaultTestHarnessFactory extends ITestHarnessFactory

Remarks

The RuntimeAccessor must be initialized prior to using this factory because the tests will run within the current AppDomain and RuntimeAccessor.

Inheritance Hierarchy

System.Object
Gallio.Runner.Harness.DefaultTestHarnessFactory

See Also

DefaultTestHarnessFactory Members
Gallio.Runner.Harness Namespace


DefaultTestHarnessFactory Members

DefaultTestHarnessFactory Members
See Also Example Constructors Methods
[image]

The default test harness factory creates a DefaultTestHarness.

The following tables list the members exposed by DefaultTestHarnessFactory.

Public Constructors

 | Name | Description
Public method | DefaultTestHarnessFactory | Creates a default test harness factory with the specified ITestContextTracker, ITestFramework and ITestEnvironment components.
Top

Public Methods

 | Name | Description
Public method | CreateHarness | Creates a test harness and associates it with its test harness contributors, if any.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestHarnessFactory Class
Gallio.Runner.Harness Namespace


DefaultTestHarnessFactory Constructor

DefaultTestHarnessFactory Constructor
[image]

Creates a default test harness factory with the specified ITestContextTracker, ITestFramework and ITestEnvironment components.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal contextTracker As ITestContextTracker, _
ByVal loader As ILoader, _
ByVal frameworks As ITestFramework(), _
ByVal environments As ITestEnvironment() _
)
C#
public DefaultTestHarnessFactory(
ITestContextTracker contextTracker,
ILoader loader,
ITestFramework[] frameworks,
ITestEnvironment[] environments
)
C++
public:
DefaultTestHarnessFactory(
ITestContextTracker contextTracker,
ILoader loader,
array<ITestFramework>^ frameworks,
array<ITestEnvironment>^ environments
) sealed
J#
public DefaultTestHarnessFactory(
ITestContextTracker contextTracker,
ILoader loader,
ITestFramework[] frameworks,
ITestEnvironment[] environments
)
JScript
public function DefaultTestHarnessFactory(
contextTracker : ITestContextTracker,
loader : ILoader,
frameworks : ITestFramework[],
environments : ITestEnvironment[]
)

Parameters

contextTracker
The test context tracker
loader
The loader
frameworks
The collection of test frameworks
environments
The collection of test environments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if contextTracker, loader, frameworks or environments is null

See Also

DefaultTestHarnessFactory Class
Gallio.Runner.Harness Namespace


Methods

DefaultTestHarnessFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHarness | Creates a test harness and associates it with its test harness contributors, if any.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultTestHarnessFactory Class
Gallio.Runner.Harness Namespace


CreateHarness Method

DefaultTestHarnessFactory.CreateHarness Method
[image]

Creates a test harness and associates it with its test harness contributors, if any.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateHarness() As ITestHarness _
Implements ITestHarnessFactory.CreateHarness
C#
public ITestHarness CreateHarness()
C++
public:
ITestHarness CreateHarness() sealed
J#
public ITestHarness CreateHarness()
JScript
public function CreateHarness() : ITestHarness

Return Value

The test harness

Implements

ITestHarnessFactory.CreateHarness

See Also

DefaultTestHarnessFactory Class
Gallio.Runner.Harness Namespace


ITestEnvironment Interface

ITestEnvironment Interface
See Also Example Members
[image]

The test environment configures global behavior related to preparing the test execution environment for running tests and tearing them down.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestEnvironment
C#
public interface ITestEnvironment
C++
interface class ITestEnvironment
J#
public interface ITestEnvironment
JScript
public interface ITestEnvironment

Types that implement ITestEnvironment

Type | Description
Gallio.Runner.Harness.ConsoleTestEnvironment | Sets up console I/O streams.
Gallio.Runner.Harness.TraceTestEnvironment | Sets up trace listeners.
Gallio.Runner.Harness.UnhandledExceptionTestEnvironment | Logs unhandled exceptions instead of killing the AppDomain.

See Also

ITestEnvironment Members
Gallio.Runner.Harness Namespace


ITestEnvironment Members

ITestEnvironment Members
See Also Example Methods
[image]

The test environment configures global behavior related to preparing the test execution environment for running tests and tearing them down.

The following tables list the members exposed by ITestEnvironment.

Public Methods

 | Name | Description
Public method | SetUp | Sets up the test environment.
Top

See Also

ITestEnvironment Interface
Gallio.Runner.Harness Namespace


Methods

ITestEnvironment Methods
[image]

Public Methods

 | Name | Description
Public method | SetUp | Sets up the test environment.
Top

See Also

ITestEnvironment Interface
Gallio.Runner.Harness Namespace


SetUp Method

ITestEnvironment.SetUp Method
[image]

Sets up the test environment.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function SetUp() As IDisposable
C#
IDisposable SetUp()
C++
IDisposable SetUp() abstract
J#
IDisposable SetUp()
JScript
function SetUp() : IDisposable

Return Value

Returns an object that when disposed causes the test environment to be torn down

See Also

ITestEnvironment Interface
Gallio.Runner.Harness Namespace


ITestHarness Interface

ITestHarness Interface
See Also Example Members
[image]

The test harness manages the lifecycle of test enumeration and execution. Contributors (such as test framework adapters) may attach event handlers to extend or modify the behavior at distinct points in the lifecycle. A new test harness instance is created when a test project is loaded into memory to serve as the ultimate container for all of its related resources.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestHarness
Implements IDisposable
C#
public interface ITestHarness : IDisposable
C++
interface class ITestHarness : IDisposable
J#
public interface ITestHarness implements IDisposable
JScript
public interface ITestHarness extends IDisposable

Types that implement ITestHarness

Type | Description
Gallio.Runner.Harness.DefaultTestHarness | Default implementation of a test harness.

See Also

ITestHarness Members
Gallio.Runner.Harness Namespace


ITestHarness Members

ITestHarness Members
See Also Example Properties Methods
[image]

The test harness manages the lifecycle of test enumeration and execution. Contributors (such as test framework adapters) may attach event handlers to extend or modify the behavior at distinct points in the lifecycle. A new test harness instance is created when a test project is loaded into memory to serve as the ultimate container for all of its related resources.

The following tables list the members exposed by ITestHarness.

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model, or null if the test model has not been built.
Public property | TestPackage | Gets the test package loaded in the test harness, or null if none.
Top

Public Methods

 | Name | Description
Public method | AddTestEnvironment | Adds a test environment.
Public method | AddTestFramework | Adds a test framework.
Public method | Explore | Populates the test model.
Public method | Load | Loads a test package into the test harness.
Public method | Run | Runs the tests.
Public method | Unload | Unloads the tests.
Top

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


Properties

ITestHarness Properties
[image]

Public Properties

 | Name | Description
Public property | TestModel | Gets the test model, or null if the test model has not been built.
Public property | TestPackage | Gets the test package loaded in the test harness, or null if none.
Top

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


TestModel Property

ITestHarness.TestModel Property
[image]

Gets the test model, or null if the test model has not been built.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestModel As TestModel
C#
TestModel TestModel { get; }
C++
property TestModel TestModel abstract {
TestModel get();
}
J#
/** property */
public TestModel get_TestModel();
JScript
public function get TestModel() : TestModel

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


TestPackage Property

ITestHarness.TestPackage Property
[image]

Gets the test package loaded in the test harness, or null if none.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property TestPackage As TestPackage
C#
TestPackage TestPackage { get; }
C++
property TestPackage TestPackage abstract {
TestPackage get();
}
J#
/** property */
public TestPackage get_TestPackage();
JScript
public function get TestPackage() : TestPackage

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


Methods

ITestHarness Methods
[image]

Public Methods

 | Name | Description
Public method | AddTestEnvironment | Adds a test environment.
Public method | AddTestFramework | Adds a test framework.
Public method | Explore | Populates the test model.
Public method | Load | Loads a test package into the test harness.
Public method | Run | Runs the tests.
Public method | Unload | Unloads the tests.
Top

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


AddTestEnvironment Method

ITestHarness.AddTestEnvironment Method
[image]

Adds a test environment.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddTestEnvironment( _
ByVal environment As ITestEnvironment _
)
C#
void AddTestEnvironment(
ITestEnvironment environment
)
C++
void AddTestEnvironment(
ITestEnvironment environment
) abstract
J#
void AddTestEnvironment(
ITestEnvironment environment
)
JScript
function AddTestEnvironment(
environment : ITestEnvironment
)

Parameters

environment
The test framework to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if environment is null

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


AddTestFramework Method

ITestHarness.AddTestFramework Method
[image]

Adds a test framework.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddTestFramework( _
ByVal framework As ITestFramework _
)
C#
void AddTestFramework(
ITestFramework framework
)
C++
void AddTestFramework(
ITestFramework framework
) abstract
J#
void AddTestFramework(
ITestFramework framework
)
JScript
function AddTestFramework(
framework : ITestFramework
)

Parameters

framework
The test framework to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if framework is null

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


Explore Method

ITestHarness.Explore Method
[image]

Populates the test model.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Explore( _
ByVal testExplorationOptions As TestExplorationOptions, _
ByVal testExplorationListener As ITestExplorationListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Explore(
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
C++
void Explore(
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
) abstract
J#
void Explore(
TestExplorationOptions testExplorationOptions,
ITestExplorationListener testExplorationListener,
IProgressMonitor progressMonitor
)
JScript
function Explore(
testExplorationOptions : TestExplorationOptions,
testExplorationListener : ITestExplorationListener,
progressMonitor : IProgressMonitor
)

Parameters

testExplorationOptions
The test exploration options
testExplorationListener
The test exploration listener
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor or testExplorationOptions is null
InvalidOperationException | Thrown if Load has not been called yet

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


Load Method

ITestHarness.Load Method
[image]

Loads a test package into the test harness.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Load( _
ByVal packageConfig As TestPackageConfig, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Load(
TestPackageConfig packageConfig,
IProgressMonitor progressMonitor
)
C++
void Load(
TestPackageConfig packageConfig,
IProgressMonitor progressMonitor
) abstract
J#
void Load(
TestPackageConfig packageConfig,
IProgressMonitor progressMonitor
)
JScript
function Load(
packageConfig : TestPackageConfig,
progressMonitor : IProgressMonitor
)

Parameters

packageConfig
The test package configuration
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor or packageConfig is null
InvalidOperationException | Thrown if Load has already been called once because this interface does not support unloading packages except by disposing the harness and recreating it

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


Run Method

ITestHarness.Run Method
[image]

Runs the tests.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Run( _
ByVal testExecutionOptions As TestExecutionOptions, _
ByVal testExecutionListener As ITestExecutionListener, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Run(
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
C++
void Run(
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
) abstract
J#
void Run(
TestExecutionOptions testExecutionOptions,
ITestExecutionListener testExecutionListener,
IProgressMonitor progressMonitor
)
JScript
function Run(
testExecutionOptions : TestExecutionOptions,
testExecutionListener : ITestExecutionListener,
progressMonitor : IProgressMonitor
)

Parameters

testExecutionOptions
The test execution options
testExecutionListener
The test execution listener
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor, testExecutionListener or testExecutionOptions is null
InvalidOperationException | Thrown if Explore has not been called yet

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


Unload Method

ITestHarness.Unload Method
[image]

Unloads the tests.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Unload( _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Unload(
IProgressMonitor progressMonitor
)
C++
void Unload(
IProgressMonitor progressMonitor
) abstract
J#
void Unload(
IProgressMonitor progressMonitor
)
JScript
function Unload(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null

See Also

ITestHarness Interface
Gallio.Runner.Harness Namespace


ITestHarnessFactory Interface

ITestHarnessFactory Interface
See Also Example Members
[image]

A test harness factory.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITestHarnessFactory
C#
public interface ITestHarnessFactory
C++
interface class ITestHarnessFactory
J#
public interface ITestHarnessFactory
JScript
public interface ITestHarnessFactory

Types that implement ITestHarnessFactory

Type | Description
Gallio.Runner.Harness.DefaultTestHarnessFactory | The default test harness factory creates a DefaultTestHarness.

See Also

ITestHarnessFactory Members
Gallio.Runner.Harness Namespace


ITestHarnessFactory Members

ITestHarnessFactory Members
See Also Example Methods
[image]

A test harness factory.

The following tables list the members exposed by ITestHarnessFactory.

Public Methods

 | Name | Description
Public method | CreateHarness | Creates a test harness and associates it with its test harness contributors, if any.
Top

See Also

ITestHarnessFactory Interface
Gallio.Runner.Harness Namespace


Methods

ITestHarnessFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHarness | Creates a test harness and associates it with its test harness contributors, if any.
Top

See Also

ITestHarnessFactory Interface
Gallio.Runner.Harness Namespace


CreateHarness Method

ITestHarnessFactory.CreateHarness Method
[image]

Creates a test harness and associates it with its test harness contributors, if any.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateHarness() As ITestHarness
C#
ITestHarness CreateHarness()
C++
ITestHarness CreateHarness() abstract
J#
ITestHarness CreateHarness()
JScript
function CreateHarness() : ITestHarness

Return Value

The test harness

See Also

ITestHarnessFactory Interface
Gallio.Runner.Harness Namespace


TraceTestEnvironment Class

TraceTestEnvironment Class
See Also Example Members
[image]

Sets up trace listeners.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TraceTestEnvironment
Implements ITestEnvironment
C#
public class TraceTestEnvironment : ITestEnvironment
C++
ref class TraceTestEnvironment : ITestEnvironment
J#
public class TraceTestEnvironment implements ITestEnvironment
JScript
public class TraceTestEnvironment extends ITestEnvironment

Inheritance Hierarchy

System.Object
Gallio.Runner.Harness.TraceTestEnvironment

See Also

TraceTestEnvironment Members
Gallio.Runner.Harness Namespace


TraceTestEnvironment Members

TraceTestEnvironment Members
See Also Example Constructors Methods
[image]

Sets up trace listeners.

The following tables list the members exposed by TraceTestEnvironment.

Public Constructors

 | Name | Description
Public method | TraceTestEnvironment | Initializes a new instance of the TraceTestEnvironment class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetUp | Sets up the test environment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TraceTestEnvironment Class
Gallio.Runner.Harness Namespace


TraceTestEnvironment Constructor

TraceTestEnvironment Constructor
[image]

Initializes a new instance of the TraceTestEnvironment class.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TraceTestEnvironment()
C++
public:
TraceTestEnvironment() sealed
J#
public TraceTestEnvironment()
JScript
public function TraceTestEnvironment()

See Also

TraceTestEnvironment Class
Gallio.Runner.Harness Namespace


Methods

TraceTestEnvironment Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetUp | Sets up the test environment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TraceTestEnvironment Class
Gallio.Runner.Harness Namespace


SetUp Method

TraceTestEnvironment.SetUp Method
[image]

Sets up the test environment.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SetUp() As IDisposable _
Implements ITestEnvironment.SetUp
C#
public IDisposable SetUp()
C++
public:
IDisposable SetUp() sealed
J#
public IDisposable SetUp()
JScript
public function SetUp() : IDisposable

Return Value

Returns an object that when disposed causes the test environment to be torn down

Implements

ITestEnvironment.SetUp

See Also

TraceTestEnvironment Class
Gallio.Runner.Harness Namespace


UnhandledExceptionTestEnvironment Class

UnhandledExceptionTestEnvironment Class
See Also Example Members
[image]

Logs unhandled exceptions instead of killing the AppDomain.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class UnhandledExceptionTestEnvironment
Implements ITestEnvironment
C#
public class UnhandledExceptionTestEnvironment : ITestEnvironment
C++
ref class UnhandledExceptionTestEnvironment : ITestEnvironment
J#
public class UnhandledExceptionTestEnvironment implements ITestEnvironment
JScript
public class UnhandledExceptionTestEnvironment extends ITestEnvironment

Inheritance Hierarchy

System.Object
Gallio.Runner.Harness.UnhandledExceptionTestEnvironment

See Also

UnhandledExceptionTestEnvironment Members
Gallio.Runner.Harness Namespace


UnhandledExceptionTestEnvironment Members

UnhandledExceptionTestEnvironment Members
See Also Example Constructors Methods
[image]

Logs unhandled exceptions instead of killing the AppDomain.

The following tables list the members exposed by UnhandledExceptionTestEnvironment.

Public Constructors

 | Name | Description
Public method | UnhandledExceptionTestEnvironment | Initializes a new instance of the UnhandledExceptionTestEnvironment class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetUp | Sets up the test environment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UnhandledExceptionTestEnvironment Class
Gallio.Runner.Harness Namespace


UnhandledExceptionTestEnvironment Constructor

UnhandledExceptionTestEnvironment Constructor
[image]

Initializes a new instance of the UnhandledExceptionTestEnvironment class.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UnhandledExceptionTestEnvironment()
C++
public:
UnhandledExceptionTestEnvironment() sealed
J#
public UnhandledExceptionTestEnvironment()
JScript
public function UnhandledExceptionTestEnvironment()

See Also

UnhandledExceptionTestEnvironment Class
Gallio.Runner.Harness Namespace


Methods

UnhandledExceptionTestEnvironment Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetUp | Sets up the test environment.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

UnhandledExceptionTestEnvironment Class
Gallio.Runner.Harness Namespace


SetUp Method

UnhandledExceptionTestEnvironment.SetUp Method
[image]

Sets up the test environment.

Namespace: Gallio.Runner.Harness
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function SetUp() As IDisposable _
Implements ITestEnvironment.SetUp
C#
public IDisposable SetUp()
C++
public:
IDisposable SetUp() sealed
J#
public IDisposable SetUp()
JScript
public function SetUp() : IDisposable

Return Value

Returns an object that when disposed causes the test environment to be torn down

Implements

ITestEnvironment.SetUp

See Also

UnhandledExceptionTestEnvironment Class
Gallio.Runner.Harness Namespace


Gallio.Runner.Projects

Gallio.Runner.Projects Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | FilterInfo | Filter record for Gallio project.
Public class | Project | Gallio project container. This class cannot be inherited.
Public class | ProjectUtils | Utilities for working with Gallio projects.


FilterInfo Class

FilterInfo Class
See Also Example Members
[image]

Filter record for Gallio project.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("filterInfo", Namespace := "http://www.gallio.org/")>
Public Class FilterInfo
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("filterInfo", Namespace = "http://www.gallio.org/")]
public class FilterInfo
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"filterInfo", Namespace = L"http://www.gallio.org/")]
ref class FilterInfo
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("filterInfo", Namespace = "http://www.gallio.org/") */
public class FilterInfo
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("filterInfo", Namespace = "http://www.gallio.org/")
class FilterInfo

Inheritance Hierarchy

System.Object
Gallio.Runner.Projects.FilterInfo

See Also

FilterInfo Members
Gallio.Runner.Projects Namespace


FilterInfo Members

FilterInfo Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Filter record for Gallio project.

The following tables list the members exposed by FilterInfo.

Public Constructors

Name | Description
FilterInfo | Overloaded. Initializes a new instance of the FilterInfo class.
Top

Public Properties

 | Name | Description
Public property | Filter | A string representation of the filter.
Public property | FilterName | The name of the filter.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
FilterInfo | Overloaded. Initializes a new instance of the FilterInfo class.
Top

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace


FilterInfo Constructor

FilterInfo Constructor

Initializes a new instance of the FilterInfo class.

Overload List

 | Name | Description
Public method | FilterInfo | Parameterless constructor for serialisation.
Public method | FilterInfo (String, String) | Constructor.

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace


FilterInfo Constructor ()

FilterInfo Constructor ()
See Also Example
[image]

Parameterless constructor for serialisation.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FilterInfo()
C++
public:
FilterInfo() sealed
J#
public FilterInfo()
JScript
public function FilterInfo()

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace
FilterInfo Constructor Overload List


FilterInfo Constructor (String, String)

FilterInfo Constructor (String, String)
See Also Example
[image]

Constructor.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal filterName As String, _
ByVal filter As String _
)
C#
public FilterInfo(
string filterName,
string filter
)
C++
public:
FilterInfo(
String filterName,
String filter
) sealed
J#
public FilterInfo(
string filterName,
string filter
)
JScript
public function FilterInfo(
filterName : String,
filter : String
)

Parameters

filterName
The name of the filter.
filter
The filter itself.

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace
FilterInfo Constructor Overload List


Properties

FilterInfo Properties
[image]

Public Properties

 | Name | Description
Public property | Filter | A string representation of the filter.
Public property | FilterName | The name of the filter.
Top

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace


Filter Property

FilterInfo.Filter Property
[image]

A string representation of the filter.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("filter")>
Public Property Filter As String
C#
[XmlAttributeAttribute("filter")]
public string Filter { get; set; }
C++
[XmlAttributeAttribute(L"filter")]
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("filter") */
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace


FilterName Property

FilterInfo.FilterName Property
[image]

The name of the filter.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("filterName")>
Public Property FilterName As String
C#
[XmlAttributeAttribute("filterName")]
public string FilterName { get; set; }
C++
[XmlAttributeAttribute(L"filterName")]
public property string FilterName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("filterName") */
/** property */
public string get_FilterName();

/** property */
public void set_FilterName(string value);
JScript
public function get FilterName() : String

public function set FilterName(value : String);

See Also

FilterInfo Class
Gallio.Runner.Projects Namespace


Project Class

Project Class
See Also Example Members
[image]

Gallio project container. This class cannot be inherited.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("project", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class Project
C#
[SerializableAttribute]
[XmlRootAttribute("project", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class Project
C++
[SerializableAttribute]
[XmlRootAttribute(L"project", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class Project sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("project", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class Project
JScript
public
SerializableAttribute
XmlRootAttribute("project", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class Project

Inheritance Hierarchy

System.Object
Gallio.Runner.Projects.Project

See Also

Project Members
Gallio.Runner.Projects Namespace


Project Members

Project Members
See Also Example Constructors Properties Methods
[image]

Gallio project container. This class cannot be inherited.

The following tables list the members exposed by Project.

Public Constructors

 | Name | Description
Public method | Project | Creates an empty project.
Top

Public Properties

 | Name | Description
Public property | TestFilters | A list of test filters for the project.
Public property | TestPackageConfig | The test package.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Project Class
Gallio.Runner.Projects Namespace


Project Constructor

Project Constructor
[image]

Creates an empty project.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Project()
C++
public:
Project() sealed
J#
public Project()
JScript
public function Project()

See Also

Project Class
Gallio.Runner.Projects Namespace


Properties

Project Properties
[image]

Public Properties

 | Name | Description
Public property | TestFilters | A list of test filters for the project.
Public property | TestPackageConfig | The test package.
Top

See Also

Project Class
Gallio.Runner.Projects Namespace


TestFilters Property

Project.TestFilters Property
[image]

A list of test filters for the project.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("testFilter", GetType(FilterInfo), IsNullable := False), _
XmlArrayAttribute("testFilters", IsNullable := False)>
Public Property TestFilters As List(Of FilterInfo)
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
[XmlArrayItemAttribute("testFilter", typeof(FilterInfo), IsNullable = False)]
[XmlArrayAttribute("testFilters", IsNullable = False)]
public List<FilterInfo> TestFilters { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
[XmlArrayItemAttribute(L"testFilter", typeof(FilterInfo), IsNullable = False)]
[XmlArrayAttribute(L"testFilters", IsNullable = False)]
public property List<FilterInfo> TestFilters sealed {
List<FilterInfo> get();
void set(List<FilterInfo> value);
}
J#
/** @attribute XmlArrayItemAttribute("testFilter", typeof(FilterInfo), IsNullable = False) */
/** @attribute XmlArrayAttribute("testFilters", IsNullable = False) */
/** property */
public List<FilterInfo> get_TestFilters();

/** property */
public void set_TestFilters(List<FilterInfo> value);
JScript
public CompilerGeneratedAttribute function get TestFilters() : List<FilterInfo>

public CompilerGeneratedAttribute function set TestFilters(value : List<FilterInfo>);

See Also

Project Class
Gallio.Runner.Projects Namespace


TestPackageConfig Property

Project.TestPackageConfig Property
[image]

The test package.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testPackageConfig", IsNullable := False)>
Public Property TestPackageConfig As TestPackageConfig
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
[XmlElementAttribute("testPackageConfig", IsNullable = False)]
public TestPackageConfig TestPackageConfig { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
[XmlElementAttribute(L"testPackageConfig", IsNullable = False)]
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
void set(TestPackageConfig value);
}
J#
/** @attribute XmlElementAttribute("testPackageConfig", IsNullable = False) */
/** property */
public TestPackageConfig get_TestPackageConfig();

/** property */
public void set_TestPackageConfig(TestPackageConfig value);
JScript
public CompilerGeneratedAttribute function get TestPackageConfig() : TestPackageConfig

public CompilerGeneratedAttribute function set TestPackageConfig(value : TestPackageConfig);

See Also

Project Class
Gallio.Runner.Projects Namespace


ProjectUtils Class

ProjectUtils Class
See Also Example Members
[image]

Utilities for working with Gallio projects.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class ProjectUtils
C#
public class ProjectUtils
C++
ref class ProjectUtils
J#
public class ProjectUtils
JScript
public class ProjectUtils

Inheritance Hierarchy

System.Object
Gallio.Runner.Projects.ProjectUtils

See Also

ProjectUtils Members
Gallio.Runner.Projects Namespace


ProjectUtils Members

ProjectUtils Members
See Also Example Constructors Methods
[image]

Utilities for working with Gallio projects.

The following tables list the members exposed by ProjectUtils.

Public Constructors

 | Name | Description
Public method | ProjectUtils | Constructor.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadProject | Load a saved Gallio project file.
Public method | SaveProject | Save a Gallio project to disk.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ProjectUtils Class
Gallio.Runner.Projects Namespace


ProjectUtils Constructor

ProjectUtils Constructor
[image]

Constructor.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal fileSystem As IFileSystem, _
ByVal xmlSerializer As IXmlSerializer _
)
C#
public ProjectUtils(
IFileSystem fileSystem,
IXmlSerializer xmlSerializer
)
C++
public:
ProjectUtils(
IFileSystem fileSystem,
IXmlSerializer xmlSerializer
) sealed
J#
public ProjectUtils(
IFileSystem fileSystem,
IXmlSerializer xmlSerializer
)
JScript
public function ProjectUtils(
fileSystem : IFileSystem,
xmlSerializer : IXmlSerializer
)

Parameters

fileSystem
The file system to use (allows mocking).
xmlSerializer
The xml serializer to use (allows mocking).

See Also

ProjectUtils Class
Gallio.Runner.Projects Namespace


Methods

ProjectUtils Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadProject | Load a saved Gallio project file.
Public method | SaveProject | Save a Gallio project to disk.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ProjectUtils Class
Gallio.Runner.Projects Namespace


LoadProject Method

ProjectUtils.LoadProject Method
[image]

Load a saved Gallio project file.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadProject( _
ByVal projectLocation As String _
) As Project
C#
public Project LoadProject(
string projectLocation
)
C++
public:
Project LoadProject(
String projectLocation
) sealed
J#
public Project LoadProject(
string projectLocation
)
JScript
public function LoadProject(
projectLocation : String
) : Project

Parameters

projectLocation
The location of the project file.

Return Value

A Gallio Project instance.

Exceptions

Exception Type | Condition
ArgumentException | Thrown when the specified project location is invalid.

See Also

ProjectUtils Class
Gallio.Runner.Projects Namespace


SaveProject Method

ProjectUtils.SaveProject Method
[image]

Save a Gallio project to disk.

Namespace: Gallio.Runner.Projects
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveProject( _
ByVal project As Project, _
ByVal projectLocation As String _
)
C#
public void SaveProject(
Project project,
string projectLocation
)
C++
public:
void SaveProject(
Project project,
String projectLocation
) sealed
J#
public void SaveProject(
Project project,
string projectLocation
)
JScript
public function SaveProject(
project : Project,
projectLocation : String
)

Parameters

project
The Project instance to save.
projectLocation
The location to save it to.

See Also

ProjectUtils Class
Gallio.Runner.Projects Namespace


Gallio.Runner.Reports

Gallio.Runner.Reports Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | DefaultReportManager | The default implementation of IReportManager.
Public class | DefaultReportReader | Default implementation of a report reader.
Public class | DefaultReportWriter | Default implementation of a report writer.
Public class | FileSystemReportContainer | A file-system based representation of a report container that uses ordinary files and folders to store report contents.
Public class | LogEntry | Describes a log entry for reporting purposes.
Public class | Report | A report includes a description of the test package, the model objects, the combined results of all test runs and summary statistics. This class cannot be inherited.
Public class | ReportContainerUtils | Utilities for working with IReportContainer. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ReportFormatterOptions | Provides options to report formatters. This class cannot be inherited.
Public class | Statistics | Collects summary statistics about test execution for reporting purposes. This class cannot be inherited.
Public class | TestOutcomeSummary | Describes the number of test cases with a particular TestOutcome. This class cannot be inherited.
Public class | TestPackageRun | Summarizes the execution of a test package for reporting purposes. This class cannot be inherited.
Public class | TestStepRun | Summarizes the execution of a single test step for reporting purposes. This class cannot be inherited.

Interfaces

Interface | Description
Public interface IReportContainer

A report container is used to load or save the contents of a report. A report container consists of zero or more logical report files distinguished by extension and a content folder. The content folder holds attachment contents and format-specific resources.

The definition of a report container is necessarily somewhat abstract. It is intended to allow the files associated with report rendered in multiple formats to coexist side by side unambiguously and without duplication of common attachment contents.

Paths within reports are always specified relative to the root of the container with each path segment delimited by backslashes. The first path segment must be ReportName, optionally with an extra period-delimited extension. For example, if ReportName is "Report" then "Report.xml" and "Report/Contents.txt" are valid paths but "Bar" and "Report-NotAnExtension" are not.

By convention report content such as attachments and images are stored in a folder with the same name as ReportName.

Public interface | IReportFormatter | A report formatter provides a strategy for formatting reports for human consumption.
Public interface | IReportManager | The report manager provides services for manipulating reports.
Public interface | IReportReader | A report writer provides services for loading a previously saved report from a IReportContainer.
Public interface IReportWriter

A report writer provides services for formatting or saving a report to a IReportContainer.

The writer tracks the paths of the report documents paths that are created within the report container. Likewise it remembers whether attachments have been saved so as to avoid redundantly resaving them when the same report is generated in multiple formats.


DefaultReportManager Class

DefaultReportManager Class
See Also Example Members
[image]

The default implementation of IReportManager.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultReportManager
Implements IReportManager
C#
public class DefaultReportManager : IReportManager
C++
ref class DefaultReportManager : IReportManager
J#
public class DefaultReportManager implements IReportManager
JScript
public class DefaultReportManager extends IReportManager

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.DefaultReportManager

See Also

DefaultReportManager Members
Gallio.Runner.Reports Namespace


DefaultReportManager Members

DefaultReportManager Members
See Also Example Constructors Properties Methods
[image]

The default implementation of IReportManager.

The following tables list the members exposed by DefaultReportManager.

Public Constructors

 | Name | Description
Public method | DefaultReportManager | Creates a report manager.
Top

Public Properties

 | Name | Description
Public property | FormatterResolver | Gets a resolver for resolving registered IReportFormatter components by name.
Top

Public Methods

 | Name | Description
Public method | CreateReportReader | Gets a report reader to load a report from the specified container.
Public method | CreateReportWriter | Gets a report writer to save or format a report to the specified container.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the report indicated by the report writer.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


DefaultReportManager Constructor

DefaultReportManager Constructor
[image]

Creates a report manager.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal formatterResolver As IRegisteredComponentResolver(Of IReportFormatter) _
)
C#
public DefaultReportManager(
IRegisteredComponentResolver<IReportFormatter> formatterResolver
)
C++
public:
DefaultReportManager(
IRegisteredComponentResolver<IReportFormatter> formatterResolver
) sealed
J#
public DefaultReportManager(
IRegisteredComponentResolver<IReportFormatter> formatterResolver
)
JScript
public function DefaultReportManager(
formatterResolver : IRegisteredComponentResolver<IReportFormatter>
)

Parameters

formatterResolver
The formatter resolver

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatterResolver is null

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


Properties

DefaultReportManager Properties
[image]

Public Properties

 | Name | Description
Public property | FormatterResolver | Gets a resolver for resolving registered IReportFormatter components by name.
Top

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


FormatterResolver Property

DefaultReportManager.FormatterResolver Property
[image]

Gets a resolver for resolving registered IReportFormatter components by name.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FormatterResolver As IRegisteredComponentResolver(Of IReportFormatter) _
Implements IReportManager.FormatterResolver
C#
public IRegisteredComponentResolver<IReportFormatter> FormatterResolver { get; }
C++
public property IRegisteredComponentResolver<IReportFormatter> FormatterResolver sealed {
IRegisteredComponentResolver<IReportFormatter> get();
}
J#
/** property */
public IRegisteredComponentResolver<IReportFormatter> get_FormatterResolver();
JScript
public function get FormatterResolver() : IRegisteredComponentResolver<IReportFormatter>

Implements

IReportManager.FormatterResolver

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


Methods

DefaultReportManager Methods
[image]

Public Methods

 | Name | Description
Public method | CreateReportReader | Gets a report reader to load a report from the specified container.
Public method | CreateReportWriter | Gets a report writer to save or format a report to the specified container.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Format | Formats the report indicated by the report writer.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


CreateReportReader Method

DefaultReportManager.CreateReportReader Method
[image]

Gets a report reader to load a report from the specified container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateReportReader( _
ByVal reportContainer As IReportContainer _
) As IReportReader _
Implements IReportManager.CreateReportReader
C#
public IReportReader CreateReportReader(
IReportContainer reportContainer
)
C++
public:
IReportReader CreateReportReader(
IReportContainer reportContainer
) sealed
J#
public IReportReader CreateReportReader(
IReportContainer reportContainer
)
JScript
public function CreateReportReader(
reportContainer : IReportContainer
) : IReportReader

Parameters

reportContainer
The report container

Return Value

The report reader

Implements

IReportManager.CreateReportReader

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


CreateReportWriter Method

DefaultReportManager.CreateReportWriter Method
[image]

Gets a report writer to save or format a report to the specified container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateReportWriter( _
ByVal report As Report, _
ByVal reportContainer As IReportContainer _
) As IReportWriter _
Implements IReportManager.CreateReportWriter
C#
public IReportWriter CreateReportWriter(
Report report,
IReportContainer reportContainer
)
C++
public:
IReportWriter CreateReportWriter(
Report report,
IReportContainer reportContainer
) sealed
J#
public IReportWriter CreateReportWriter(
Report report,
IReportContainer reportContainer
)
JScript
public function CreateReportWriter(
report : Report,
reportContainer : IReportContainer
) : IReportWriter

Parameters

report
The report
reportContainer
The report container

Return Value

The report writer

Implements

IReportManager.CreateReportWriter

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


Format Method

DefaultReportManager.Format Method
[image]

Formats the report indicated by the report writer.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal formatterName As String, _
ByVal formatterOptions As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportManager.Format
C#
public void Format(
IReportWriter reportWriter,
string formatterName,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
C++
public:
void Format(
IReportWriter reportWriter,
String formatterName,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
) sealed
J#
public void Format(
IReportWriter reportWriter,
string formatterName,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
JScript
public function Format(
reportWriter : IReportWriter,
formatterName : String,
formatterOptions : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Parameters

reportWriter
The report writer
formatterName
The formatter name
formatterOptions
The report formatter options
progressMonitor
The progress monitor

Implements

IReportManager.Format

See Also

DefaultReportManager Class
Gallio.Runner.Reports Namespace


DefaultReportReader Class

DefaultReportReader Class
See Also Example Members
[image]

Default implementation of a report reader.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultReportReader
Implements IReportReader
C#
public class DefaultReportReader : IReportReader
C++
ref class DefaultReportReader : IReportReader
J#
public class DefaultReportReader implements IReportReader
JScript
public class DefaultReportReader extends IReportReader

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.DefaultReportReader

See Also

DefaultReportReader Members
Gallio.Runner.Reports Namespace


DefaultReportReader Members

DefaultReportReader Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a report reader.

The following tables list the members exposed by DefaultReportReader.

Public Constructors

 | Name | Description
Public method | DefaultReportReader | Creates a report reader.
Top

Public Properties

 | Name | Description
Public property | ReportContainer | Gets the report container.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadReport | Loads the report from an XML file. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | LoadReportAttachments | Loads referenced report attachments from the container. This method has the effect of populating the contents of all AttachmentData nodes in the report that have non-null ContentPath.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


DefaultReportReader Constructor

DefaultReportReader Constructor
[image]

Creates a report reader.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal reportContainer As IReportContainer _
)
C#
public DefaultReportReader(
IReportContainer reportContainer
)
C++
public:
DefaultReportReader(
IReportContainer reportContainer
) sealed
J#
public DefaultReportReader(
IReportContainer reportContainer
)
JScript
public function DefaultReportReader(
reportContainer : IReportContainer
)

Parameters

reportContainer
The report container

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportContainer is null

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


Properties

DefaultReportReader Properties
[image]

Public Properties

 | Name | Description
Public property | ReportContainer | Gets the report container.
Top

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


ReportContainer Property

DefaultReportReader.ReportContainer Property
[image]

Gets the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportContainer As IReportContainer _
Implements IReportReader.ReportContainer
C#
public IReportContainer ReportContainer { get; }
C++
public property IReportContainer ReportContainer sealed {
IReportContainer get();
}
J#
/** property */
public IReportContainer get_ReportContainer();
JScript
public function get ReportContainer() : IReportContainer

Implements

IReportReader.ReportContainer

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


Methods

DefaultReportReader Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadReport | Loads the report from an XML file. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | LoadReportAttachments | Loads referenced report attachments from the container. This method has the effect of populating the contents of all AttachmentData nodes in the report that have non-null ContentPath.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


LoadReport Method

DefaultReportReader.LoadReport Method
[image]

Loads the report from an XML file.

The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadReport( _
ByVal loadAttachmentContents As Boolean, _
ByVal progressMonitor As IProgressMonitor _
) As Report _
Implements IReportReader.LoadReport
C#
public Report LoadReport(
bool loadAttachmentContents,
IProgressMonitor progressMonitor
)
C++
public:
Report LoadReport(
bool loadAttachmentContents,
IProgressMonitor progressMonitor
) sealed
J#
public Report LoadReport(
bool loadAttachmentContents,
IProgressMonitor progressMonitor
)
JScript
public function LoadReport(
loadAttachmentContents : bool,
progressMonitor : IProgressMonitor
) : Report

Parameters

loadAttachmentContents
If true, loads attachment contents in referenced content files if they were not embedded otherwise the attachment contents are not loaded (but may be loaded later using LoadReportAttachments).
progressMonitor
The progress monitor

Return Value

The loaded report

Implements

IReportReader.LoadReport

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


LoadReportAttachments Method

DefaultReportReader.LoadReportAttachments Method
[image]

Loads referenced report attachments from the container.

This method has the effect of populating the contents of all AttachmentData nodes in the report that have non-null ContentPath.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadReportAttachments( _
ByVal report As Report, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportReader.LoadReportAttachments
C#
public void LoadReportAttachments(
Report report,
IProgressMonitor progressMonitor
)
C++
public:
void LoadReportAttachments(
Report report,
IProgressMonitor progressMonitor
) sealed
J#
public void LoadReportAttachments(
Report report,
IProgressMonitor progressMonitor
)
JScript
public function LoadReportAttachments(
report : Report,
progressMonitor : IProgressMonitor
)

Parameters

report
The report whose attachments are to be loaded
progressMonitor
The progress monitor

Implements

IReportReader.LoadReportAttachments

See Also

DefaultReportReader Class
Gallio.Runner.Reports Namespace


DefaultReportWriter Class

DefaultReportWriter Class
See Also Example Members
[image]

Default implementation of a report writer.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultReportWriter
Implements IReportWriter
C#
public class DefaultReportWriter : IReportWriter
C++
ref class DefaultReportWriter : IReportWriter
J#
public class DefaultReportWriter implements IReportWriter
JScript
public class DefaultReportWriter extends IReportWriter

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.DefaultReportWriter

See Also

DefaultReportWriter Members
Gallio.Runner.Reports Namespace


DefaultReportWriter Members

DefaultReportWriter Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a report writer.

The following tables list the members exposed by DefaultReportWriter.

Public Constructors

 | Name | Description
Public method | DefaultReportWriter | Creates a report writer for the specified report.
Top

Public Properties

 | Name | Description
Public property | Report | Gets the report being generated.
Public property | ReportContainer | Gets the report container.
Public property | ReportDocumentPaths | Gets the paths of all report documents that have been generated within the report container. Report documents are the primary files when reports are formatted or saved such as an XML file, a Text file, or the main HTML file that contains the body of the report.
Top

Public Methods

 | Name | Description
Public method | AddReportDocumentPath | Adds the path of a report document that has been created within the report container.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SaveReport | Saves the report as an XML file. The saved report XML file is automatically added to the ReportDocumentPaths list. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | SaveReportAttachments | Saves all report attachments as individual content files to the container. The convention for attachments is to save them in a directory with the same name as the container's ReportName arranged in folders first by test id then by step id then by attachment name. For example: "Report\{testid}\{stepid}\attachment.jpg".
Public method | SerializeReport | Serializes the report to XML.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


DefaultReportWriter Constructor

DefaultReportWriter Constructor
[image]

Creates a report writer for the specified report.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal report As Report, _
ByVal reportContainer As IReportContainer _
)
C#
public DefaultReportWriter(
Report report,
IReportContainer reportContainer
)
C++
public:
DefaultReportWriter(
Report report,
IReportContainer reportContainer
) sealed
J#
public DefaultReportWriter(
Report report,
IReportContainer reportContainer
)
JScript
public function DefaultReportWriter(
report : Report,
reportContainer : IReportContainer
)

Parameters

report
The report
reportContainer
The report container

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report or reportContainer is null

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


Properties

DefaultReportWriter Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the report being generated.
Public property | ReportContainer | Gets the report container.
Public property | ReportDocumentPaths | Gets the paths of all report documents that have been generated within the report container. Report documents are the primary files when reports are formatted or saved such as an XML file, a Text file, or the main HTML file that contains the body of the report.
Top

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


Report Property

DefaultReportWriter.Report Property
[image]

Gets the report being generated.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Report As Report _
Implements IReportWriter.Report
C#
public Report Report { get; }
C++
public property Report Report sealed {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

Implements

IReportWriter.Report

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


ReportContainer Property

DefaultReportWriter.ReportContainer Property
[image]

Gets the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportContainer As IReportContainer _
Implements IReportWriter.ReportContainer
C#
public IReportContainer ReportContainer { get; }
C++
public property IReportContainer ReportContainer sealed {
IReportContainer get();
}
J#
/** property */
public IReportContainer get_ReportContainer();
JScript
public function get ReportContainer() : IReportContainer

Implements

IReportWriter.ReportContainer

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


ReportDocumentPaths Property

DefaultReportWriter.ReportDocumentPaths Property
[image]

Gets the paths of all report documents that have been generated within the report container. Report documents are the primary files when reports are formatted or saved such as an XML file, a Text file, or the main HTML file that contains the body of the report.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportDocumentPaths As IList(Of String) _
Implements IReportWriter.ReportDocumentPaths
C#
public IList<string> ReportDocumentPaths { get; }
C++
public property IList<string> ReportDocumentPaths sealed {
IList<string> get();
}
J#
/** property */
public IList<string> get_ReportDocumentPaths();
JScript
public function get ReportDocumentPaths() : IList<string>

Implements

IReportWriter.ReportDocumentPaths

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


Methods

DefaultReportWriter Methods
[image]

Public Methods

 | Name | Description
Public method | AddReportDocumentPath | Adds the path of a report document that has been created within the report container.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SaveReport | Saves the report as an XML file. The saved report XML file is automatically added to the ReportDocumentPaths list. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | SaveReportAttachments | Saves all report attachments as individual content files to the container. The convention for attachments is to save them in a directory with the same name as the container's ReportName arranged in folders first by test id then by step id then by attachment name. For example: "Report\{testid}\{stepid}\attachment.jpg".
Public method | SerializeReport | Serializes the report to XML.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


AddReportDocumentPath Method

DefaultReportWriter.AddReportDocumentPath Method
[image]

Adds the path of a report document that has been created within the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddReportDocumentPath( _
ByVal path As String _
) _
Implements IReportWriter.AddReportDocumentPath
C#
public void AddReportDocumentPath(
string path
)
C++
public:
void AddReportDocumentPath(
String path
) sealed
J#
public void AddReportDocumentPath(
string path
)
JScript
public function AddReportDocumentPath(
path : String
)

Parameters

path
The document path

Implements

IReportWriter.AddReportDocumentPath

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


SaveReport Method

DefaultReportWriter.SaveReport Method
[image]

Saves the report as an XML file.

The saved report XML file is automatically added to the ReportDocumentPaths list.

The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveReport( _
ByVal attachmentContentDisposition As AttachmentContentDisposition, _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportWriter.SaveReport
C#
public void SaveReport(
AttachmentContentDisposition attachmentContentDisposition,
IProgressMonitor progressMonitor
)
C++
public:
void SaveReport(
AttachmentContentDisposition attachmentContentDisposition,
IProgressMonitor progressMonitor
) sealed
J#
public void SaveReport(
AttachmentContentDisposition attachmentContentDisposition,
IProgressMonitor progressMonitor
)
JScript
public function SaveReport(
attachmentContentDisposition : AttachmentContentDisposition,
progressMonitor : IProgressMonitor
)

Parameters

attachmentContentDisposition
The content disposition to use for all attachments. If the content disposition is Link then this method will automatically call SaveReportAttachments to save the attachments.
progressMonitor
The progress monitor

Implements

IReportWriter.SaveReport

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


SaveReportAttachments Method

DefaultReportWriter.SaveReportAttachments Method
[image]

Saves all report attachments as individual content files to the container.

The convention for attachments is to save them in a directory with the same name as the container's ReportName arranged in folders first by test id then by step id then by attachment name. For example: "Report\{testid}\{stepid}\attachment.jpg".

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveReportAttachments( _
ByVal progressMonitor As IProgressMonitor _
) _
Implements IReportWriter.SaveReportAttachments
C#
public void SaveReportAttachments(
IProgressMonitor progressMonitor
)
C++
public:
void SaveReportAttachments(
IProgressMonitor progressMonitor
) sealed
J#
public void SaveReportAttachments(
IProgressMonitor progressMonitor
)
JScript
public function SaveReportAttachments(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Implements

IReportWriter.SaveReportAttachments

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


SerializeReport Method

DefaultReportWriter.SerializeReport Method
[image]

Serializes the report to XML.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SerializeReport( _
ByVal xmlWriter As XmlWriter, _
ByVal attachmentContentDisposition As AttachmentContentDisposition _
) _
Implements IReportWriter.SerializeReport
C#
public void SerializeReport(
XmlWriter xmlWriter,
AttachmentContentDisposition attachmentContentDisposition
)
C++
public:
void SerializeReport(
XmlWriter xmlWriter,
AttachmentContentDisposition attachmentContentDisposition
) sealed
J#
public void SerializeReport(
XmlWriter xmlWriter,
AttachmentContentDisposition attachmentContentDisposition
)
JScript
public function SerializeReport(
xmlWriter : XmlWriter,
attachmentContentDisposition : AttachmentContentDisposition
)

Parameters

xmlWriter
The XML writer
attachmentContentDisposition
The content disposition to use for all attachments

Implements

IReportWriter.SerializeReport

See Also

DefaultReportWriter Class
Gallio.Runner.Reports Namespace


FileSystemReportContainer Class

FileSystemReportContainer Class
See Also Example Members
[image]

A file-system based representation of a report container that uses ordinary files and folders to store report contents.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FileSystemReportContainer
Implements IReportContainer
C#
public class FileSystemReportContainer : IReportContainer
C++
ref class FileSystemReportContainer : IReportContainer
J#
public class FileSystemReportContainer implements IReportContainer
JScript
public class FileSystemReportContainer extends IReportContainer

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.FileSystemReportContainer

See Also

FileSystemReportContainer Members
Gallio.Runner.Reports Namespace


FileSystemReportContainer Members

FileSystemReportContainer Members
See Also Example Constructors Properties Methods
[image]

A file-system based representation of a report container that uses ordinary files and folders to store report contents.

The following tables list the members exposed by FileSystemReportContainer.

Public Constructors

 | Name | Description
Public method | FileSystemReportContainer | Creates a file-system based representation of a report container.
Top

Public Properties

 | Name | Description
Public property | ReportDirectory | Gets the full-path of the report directory.
Public property | ReportName | Gets the base name of the report. Logical files and folders associated with the report all begin with this name and are disambiguated by extension.
Top

Public Methods

 | Name | Description
Public method | DeleteReport | Deletes the entire contents of the report in all of its formats.
Public method | EncodeFileName | Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | OpenRead | Opens a report file for reading.
Public method | OpenWrite | Opens a report file for writing, overwriting any previous file with the same name. It is not necessary to create "directories" within the container. They are automatically created when new files are opened for writing within them.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


FileSystemReportContainer Constructor

FileSystemReportContainer Constructor
[image]

Creates a file-system based representation of a report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal reportDirectory As String, _
ByVal reportName As String _
)
C#
public FileSystemReportContainer(
string reportDirectory,
string reportName
)
C++
public:
FileSystemReportContainer(
String reportDirectory,
String reportName
) sealed
J#
public FileSystemReportContainer(
string reportDirectory,
string reportName
)
JScript
public function FileSystemReportContainer(
reportDirectory : String,
reportName : String
)

Parameters

reportDirectory
The report directory path
reportName
The report name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportDirectory or reportName is null
ArgumentException | Thrown if reportName is an empty string

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


Properties

FileSystemReportContainer Properties
[image]

Public Properties

 | Name | Description
Public property | ReportDirectory | Gets the full-path of the report directory.
Public property | ReportName | Gets the base name of the report. Logical files and folders associated with the report all begin with this name and are disambiguated by extension.
Top

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


ReportDirectory Property

FileSystemReportContainer.ReportDirectory Property
[image]

Gets the full-path of the report directory.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportDirectory As String
C#
public string ReportDirectory { get; }
C++
public property string ReportDirectory sealed {
String get();
}
J#
/** property */
public string get_ReportDirectory();
JScript
public function get ReportDirectory() : String

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


ReportName Property

FileSystemReportContainer.ReportName Property
[image]

Gets the base name of the report.

Logical files and folders associated with the report all begin with this name and are disambiguated by extension.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReportName As String _
Implements IReportContainer.ReportName
C#
public string ReportName { get; }
C++
public property string ReportName sealed {
String get();
}
J#
/** property */
public string get_ReportName();
JScript
public function get ReportName() : String

Implements

IReportContainer.ReportName

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


Methods

FileSystemReportContainer Methods
[image]

Public Methods

 | Name | Description
Public method | DeleteReport | Deletes the entire contents of the report in all of its formats.
Public method | EncodeFileName | Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | OpenRead | Opens a report file for reading.
Public method | OpenWrite | Opens a report file for writing, overwriting any previous file with the same name. It is not necessary to create "directories" within the container. They are automatically created when new files are opened for writing within them.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


DeleteReport Method

FileSystemReportContainer.DeleteReport Method
[image]

Deletes the entire contents of the report in all of its formats.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteReport() _
Implements IReportContainer.DeleteReport
C#
public void DeleteReport()
C++
public:
void DeleteReport() sealed
J#
public void DeleteReport()
JScript
public function DeleteReport()

Implements

IReportContainer.DeleteReport

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


EncodeFileName Method

FileSystemReportContainer.EncodeFileName Method
[image]

Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function EncodeFileName( _
ByVal fileName As String _
) As String _
Implements IReportContainer.EncodeFileName
C#
public string EncodeFileName(
string fileName
)
C++
public:
String EncodeFileName(
String fileName
) sealed
J#
public string EncodeFileName(
string fileName
)
JScript
public function EncodeFileName(
fileName : String
) : String

Parameters

fileName
The file or directory name

Return Value

The encoded file or directory name

Implements

IReportContainer.EncodeFileName

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


OpenRead Method

FileSystemReportContainer.OpenRead Method
[image]

Opens a report file for reading.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenRead( _
ByVal path As String _
) As Stream _
Implements IReportContainer.OpenRead
C#
public Stream OpenRead(
string path
)
C++
public:
Stream OpenRead(
String path
) sealed
J#
public Stream OpenRead(
string path
)
JScript
public function OpenRead(
path : String
) : Stream

Parameters

path
The relative path of the report file within the container

Return Value

The stream

Implements

IReportContainer.OpenRead

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


OpenWrite Method

FileSystemReportContainer.OpenWrite Method
[image]

Opens a report file for writing, overwriting any previous file with the same name.

It is not necessary to create "directories" within the container. They are automatically created when new files are opened for writing within them.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenWrite( _
ByVal path As String, _
ByVal contentType As String, _
ByVal encoding As Encoding _
) As Stream _
Implements IReportContainer.OpenWrite
C#
public Stream OpenWrite(
string path,
string contentType,
Encoding encoding
)
C++
public:
Stream OpenWrite(
String path,
String contentType,
Encoding encoding
) sealed
J#
public Stream OpenWrite(
string path,
string contentType,
Encoding encoding
)
JScript
public function OpenWrite(
path : String,
contentType : String,
encoding : Encoding
) : Stream

Parameters

path
The path of the report file
contentType
The content type of the file, or null if not specified
encoding
The text encoding of the file, or null if not specified or if the file is binary

Return Value

The stream

Implements

IReportContainer.OpenWrite

See Also

FileSystemReportContainer Class
Gallio.Runner.Reports Namespace


IReportContainer Interface

IReportContainer Interface
See Also Example Members
[image]

A report container is used to load or save the contents of a report. A report container consists of zero or more logical report files distinguished by extension and a content folder. The content folder holds attachment contents and format-specific resources.

The definition of a report container is necessarily somewhat abstract. It is intended to allow the files associated with report rendered in multiple formats to coexist side by side unambiguously and without duplication of common attachment contents.

Paths within reports are always specified relative to the root of the container with each path segment delimited by backslashes. The first path segment must be ReportName, optionally with an extra period-delimited extension. For example, if ReportName is "Report" then "Report.xml" and "Report/Contents.txt" are valid paths but "Bar" and "Report-NotAnExtension" are not.

By convention report content such as attachments and images are stored in a folder with the same name as ReportName.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportContainer
C#
public interface IReportContainer
C++
interface class IReportContainer
J#
public interface IReportContainer
JScript
public interface IReportContainer

Types that implement IReportContainer

Type | Description
Gallio.Runner.Reports.FileSystemReportContainer | A file-system based representation of a report container that uses ordinary files and folders to store report contents.

Example

This example demonstrates the structure of report files with the report name of "MyReport".

  • "MyReport.html": A report file.
  • "MyReport.txt": Another report file in a different format.
  • "MyReport\": The standard report content directory by convention.
  • "MyReport\Step123\AttachedLog.txt": An execution log attachment.
  • "MyReport\img\TestIcon.png": An image used in the report.
  • "MyReport\img\FixtureIcon.png": Another image used in the report.
  • "MyReport\img\Screenshot.jpg": An execution log attachment.

See Also

IReportContainer Members
Gallio.Runner.Reports Namespace


IReportContainer Members

IReportContainer Members
See Also Example Properties Methods
[image]

A report container is used to load or save the contents of a report. A report container consists of zero or more logical report files distinguished by extension and a content folder. The content folder holds attachment contents and format-specific resources.

The definition of a report container is necessarily somewhat abstract. It is intended to allow the files associated with report rendered in multiple formats to coexist side by side unambiguously and without duplication of common attachment contents.

Paths within reports are always specified relative to the root of the container with each path segment delimited by backslashes. The first path segment must be ReportName, optionally with an extra period-delimited extension. For example, if ReportName is "Report" then "Report.xml" and "Report/Contents.txt" are valid paths but "Bar" and "Report-NotAnExtension" are not.

By convention report content such as attachments and images are stored in a folder with the same name as ReportName.

The following tables list the members exposed by IReportContainer.

Public Properties

 | Name | Description
Public property | ReportName | Gets the base name of the report. Logical files and folders associated with the report all begin with this name and are disambiguated by extension.
Top

Public Methods

 | Name | Description
Public method | DeleteReport | Deletes the entire contents of the report in all of its formats.
Public method | EncodeFileName | Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.
Public method | OpenRead | Opens a report file for reading.
Public method | OpenWrite | Opens a report file for writing, overwriting any previous file with the same name. It is not necessary to create "directories" within the container. They are automatically created when new files are opened for writing within them.
Top

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


Properties

IReportContainer Properties
[image]

Public Properties

 | Name | Description
Public property | ReportName | Gets the base name of the report. Logical files and folders associated with the report all begin with this name and are disambiguated by extension.
Top

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


ReportName Property

IReportContainer.ReportName Property
[image]

Gets the base name of the report.

Logical files and folders associated with the report all begin with this name and are disambiguated by extension.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportName As String
C#
string ReportName { get; }
C++
property string ReportName abstract {
String get();
}
J#
/** property */
public string get_ReportName();
JScript
public function get ReportName() : String

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


Methods

IReportContainer Methods
[image]

Public Methods

 | Name | Description
Public method | DeleteReport | Deletes the entire contents of the report in all of its formats.
Public method | EncodeFileName | Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.
Public method | OpenRead | Opens a report file for reading.
Public method | OpenWrite | Opens a report file for writing, overwriting any previous file with the same name. It is not necessary to create "directories" within the container. They are automatically created when new files are opened for writing within them.
Top

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


DeleteReport Method

IReportContainer.DeleteReport Method
[image]

Deletes the entire contents of the report in all of its formats.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteReport()
C#
void DeleteReport()
C++
void DeleteReport() abstract
J#
void DeleteReport()
JScript
function DeleteReport()

Exceptions

Exception Type | Condition
IOException | Thrown if an I/O error occurs

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


EncodeFileName Method

IReportContainer.EncodeFileName Method
[image]

Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function EncodeFileName( _
ByVal fileName As String _
) As String
C#
string EncodeFileName(
string fileName
)
C++
String EncodeFileName(
String fileName
) abstract
J#
string EncodeFileName(
string fileName
)
JScript
function EncodeFileName(
fileName : String
) : String

Parameters

fileName
The file or directory name

Return Value

The encoded file or directory name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if fileName is null

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


OpenRead Method

IReportContainer.OpenRead Method
[image]

Opens a report file for reading.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function OpenRead( _
ByVal path As String _
) As Stream
C#
Stream OpenRead(
string path
)
C++
Stream OpenRead(
String path
) abstract
J#
Stream OpenRead(
string path
)
JScript
function OpenRead(
path : String
) : Stream

Parameters

path
The relative path of the report file within the container

Return Value

The stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null
IOException | Thrown if an I/O error occurs

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


OpenWrite Method

IReportContainer.OpenWrite Method
[image]

Opens a report file for writing, overwriting any previous file with the same name.

It is not necessary to create "directories" within the container. They are automatically created when new files are opened for writing within them.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function OpenWrite( _
ByVal path As String, _
ByVal contentType As String, _
ByVal encoding As Encoding _
) As Stream
C#
Stream OpenWrite(
string path,
string contentType,
Encoding encoding
)
C++
Stream OpenWrite(
String path,
String contentType,
Encoding encoding
) abstract
J#
Stream OpenWrite(
string path,
string contentType,
Encoding encoding
)
JScript
function OpenWrite(
path : String,
contentType : String,
encoding : Encoding
) : Stream

Parameters

path
The path of the report file
contentType
The content type of the file, or null if not specified
encoding
The text encoding of the file, or null if not specified or if the file is binary

Return Value

The stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null
IOException | Thrown if an I/O error occurs

See Also

IReportContainer Interface
Gallio.Runner.Reports Namespace


IReportFormatter Interface

IReportFormatter Interface
See Also Example Members
[image]

A report formatter provides a strategy for formatting reports for human consumption.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportFormatter
Implements IRegisteredComponent
C#
public interface IReportFormatter : IRegisteredComponent
C++
interface class IReportFormatter : IRegisteredComponent
J#
public interface IReportFormatter implements IRegisteredComponent
JScript
public interface IReportFormatter extends IRegisteredComponent

Types that implement IReportFormatter

Type | Description
Gallio.Reports.BaseReportFormatter | Abstract base class for report formatters. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IReportFormatter Members
Gallio.Runner.Reports Namespace


IReportFormatter Members

IReportFormatter Members
See Also Example Methods
[image]

A report formatter provides a strategy for formatting reports for human consumption.

The following tables list the members exposed by IReportFormatter.

Public Methods

 | Name | Description
Public method | Format | Formats the report indicated by the report writer.
Top

See Also

IReportFormatter Interface
Gallio.Runner.Reports Namespace


Methods

IReportFormatter Methods
[image]

Public Methods

 | Name | Description
Public method | Format | Formats the report indicated by the report writer.
Top

See Also

IReportFormatter Interface
Gallio.Runner.Reports Namespace


Format Method

IReportFormatter.Format Method
[image]

Formats the report indicated by the report writer.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal formatterOptions As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
C++
void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
) abstract
J#
void Format(
IReportWriter reportWriter,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
JScript
function Format(
reportWriter : IReportWriter,
formatterOptions : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Parameters

reportWriter
The report writer
formatterOptions
The report formatter options
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportWriter, formatterOptions or progressMonitor is null

See Also

IReportFormatter Interface
Gallio.Runner.Reports Namespace


IReportManager Interface

IReportManager Interface
See Also Example Members
[image]

The report manager provides services for manipulating reports.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportManager
C#
public interface IReportManager
C++
interface class IReportManager
J#
public interface IReportManager
JScript
public interface IReportManager

Types that implement IReportManager

Type | Description
Gallio.Runner.Reports.DefaultReportManager | The default implementation of IReportManager.

See Also

IReportManager Members
Gallio.Runner.Reports Namespace


IReportManager Members

IReportManager Members
See Also Example Properties Methods
[image]

The report manager provides services for manipulating reports.

The following tables list the members exposed by IReportManager.

Public Properties

 | Name | Description
Public property | FormatterResolver | Gets a resolver for resolving registered IReportFormatter components by name.
Top

Public Methods

 | Name | Description
Public method | CreateReportReader | Gets a report reader to load a report from the specified container.
Public method | CreateReportWriter | Gets a report writer to save or format a report to the specified container.
Public method | Format | Formats the report indicated by the report writer.
Top

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


Properties

IReportManager Properties
[image]

Public Properties

 | Name | Description
Public property | FormatterResolver | Gets a resolver for resolving registered IReportFormatter components by name.
Top

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


FormatterResolver Property

IReportManager.FormatterResolver Property
[image]

Gets a resolver for resolving registered IReportFormatter components by name.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FormatterResolver As IRegisteredComponentResolver(Of IReportFormatter)
C#
IRegisteredComponentResolver<IReportFormatter> FormatterResolver { get; }
C++
property IRegisteredComponentResolver<IReportFormatter> FormatterResolver abstract {
IRegisteredComponentResolver<IReportFormatter> get();
}
J#
/** property */
public IRegisteredComponentResolver<IReportFormatter> get_FormatterResolver();
JScript
public function get FormatterResolver() : IRegisteredComponentResolver<IReportFormatter>

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


Methods

IReportManager Methods
[image]

Public Methods

 | Name | Description
Public method | CreateReportReader | Gets a report reader to load a report from the specified container.
Public method | CreateReportWriter | Gets a report writer to save or format a report to the specified container.
Public method | Format | Formats the report indicated by the report writer.
Top

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


CreateReportReader Method

IReportManager.CreateReportReader Method
[image]

Gets a report reader to load a report from the specified container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateReportReader( _
ByVal reportContainer As IReportContainer _
) As IReportReader
C#
IReportReader CreateReportReader(
IReportContainer reportContainer
)
C++
IReportReader CreateReportReader(
IReportContainer reportContainer
) abstract
J#
IReportReader CreateReportReader(
IReportContainer reportContainer
)
JScript
function CreateReportReader(
reportContainer : IReportContainer
) : IReportReader

Parameters

reportContainer
The report container

Return Value

The report reader

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportContainer is null

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


CreateReportWriter Method

IReportManager.CreateReportWriter Method
[image]

Gets a report writer to save or format a report to the specified container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateReportWriter( _
ByVal report As Report, _
ByVal reportContainer As IReportContainer _
) As IReportWriter
C#
IReportWriter CreateReportWriter(
Report report,
IReportContainer reportContainer
)
C++
IReportWriter CreateReportWriter(
Report report,
IReportContainer reportContainer
) abstract
J#
IReportWriter CreateReportWriter(
Report report,
IReportContainer reportContainer
)
JScript
function CreateReportWriter(
report : Report,
reportContainer : IReportContainer
) : IReportWriter

Parameters

report
The report
reportContainer
The report container

Return Value

The report writer

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report or reportContainer is null

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


Format Method

IReportManager.Format Method
[image]

Formats the report indicated by the report writer.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Format( _
ByVal reportWriter As IReportWriter, _
ByVal formatterName As String, _
ByVal formatterOptions As ReportFormatterOptions, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void Format(
IReportWriter reportWriter,
string formatterName,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
C++
void Format(
IReportWriter reportWriter,
String formatterName,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
) abstract
J#
void Format(
IReportWriter reportWriter,
string formatterName,
ReportFormatterOptions formatterOptions,
IProgressMonitor progressMonitor
)
JScript
function Format(
reportWriter : IReportWriter,
formatterName : String,
formatterOptions : ReportFormatterOptions,
progressMonitor : IProgressMonitor
)

Parameters

reportWriter
The report writer
formatterName
The formatter name
formatterOptions
The report formatter options
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reportWriter, formatterName, formatterOptions or progressMonitor is null
InvalidOperationException | Thrown if there is no formatter with the specified name

See Also

IReportManager Interface
Gallio.Runner.Reports Namespace


IReportReader Interface

IReportReader Interface
See Also Example Members
[image]

A report writer provides services for loading a previously saved report from a IReportContainer.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportReader
C#
public interface IReportReader
C++
interface class IReportReader
J#
public interface IReportReader
JScript
public interface IReportReader

Types that implement IReportReader

Type | Description
Gallio.Runner.Reports.DefaultReportReader | Default implementation of a report reader.

See Also

IReportReader Members
Gallio.Runner.Reports Namespace


IReportReader Members

IReportReader Members
See Also Example Properties Methods
[image]

A report writer provides services for loading a previously saved report from a IReportContainer.

The following tables list the members exposed by IReportReader.

Public Properties

 | Name | Description
Public property | ReportContainer | Gets the report container.
Top

Public Methods

 | Name | Description
Public method | LoadReport | Loads the report from an XML file. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | LoadReportAttachments | Loads referenced report attachments from the container. This method has the effect of populating the contents of all AttachmentData nodes in the report that have non-null ContentPath.
Top

See Also

IReportReader Interface
Gallio.Runner.Reports Namespace


Properties

IReportReader Properties
[image]

Public Properties

 | Name | Description
Public property | ReportContainer | Gets the report container.
Top

See Also

IReportReader Interface
Gallio.Runner.Reports Namespace


ReportContainer Property

IReportReader.ReportContainer Property
[image]

Gets the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportContainer As IReportContainer
C#
IReportContainer ReportContainer { get; }
C++
property IReportContainer ReportContainer abstract {
IReportContainer get();
}
J#
/** property */
public IReportContainer get_ReportContainer();
JScript
public function get ReportContainer() : IReportContainer

See Also

IReportReader Interface
Gallio.Runner.Reports Namespace


Methods

IReportReader Methods
[image]

Public Methods

 | Name | Description
Public method | LoadReport | Loads the report from an XML file. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | LoadReportAttachments | Loads referenced report attachments from the container. This method has the effect of populating the contents of all AttachmentData nodes in the report that have non-null ContentPath.
Top

See Also

IReportReader Interface
Gallio.Runner.Reports Namespace


LoadReport Method

IReportReader.LoadReport Method
[image]

Loads the report from an XML file.

The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function LoadReport( _
ByVal loadAttachmentContents As Boolean, _
ByVal progressMonitor As IProgressMonitor _
) As Report
C#
Report LoadReport(
bool loadAttachmentContents,
IProgressMonitor progressMonitor
)
C++
Report LoadReport(
bool loadAttachmentContents,
IProgressMonitor progressMonitor
) abstract
J#
Report LoadReport(
bool loadAttachmentContents,
IProgressMonitor progressMonitor
)
JScript
function LoadReport(
loadAttachmentContents : bool,
progressMonitor : IProgressMonitor
) : Report

Parameters

loadAttachmentContents
If true, loads attachment contents in referenced content files if they were not embedded otherwise the attachment contents are not loaded (but may be loaded later using LoadReportAttachments).
progressMonitor
The progress monitor

Return Value

The loaded report

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null

See Also

IReportReader Interface
Gallio.Runner.Reports Namespace


LoadReportAttachments Method

IReportReader.LoadReportAttachments Method
[image]

Loads referenced report attachments from the container.

This method has the effect of populating the contents of all AttachmentData nodes in the report that have non-null ContentPath.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub LoadReportAttachments( _
ByVal report As Report, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void LoadReportAttachments(
Report report,
IProgressMonitor progressMonitor
)
C++
void LoadReportAttachments(
Report report,
IProgressMonitor progressMonitor
) abstract
J#
void LoadReportAttachments(
Report report,
IProgressMonitor progressMonitor
)
JScript
function LoadReportAttachments(
report : Report,
progressMonitor : IProgressMonitor
)

Parameters

report
The report whose attachments are to be loaded
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if report or progressMonitor is null

See Also

IReportReader Interface
Gallio.Runner.Reports Namespace


IReportWriter Interface

IReportWriter Interface
See Also Example Members
[image]

A report writer provides services for formatting or saving a report to a IReportContainer.

The writer tracks the paths of the report documents paths that are created within the report container. Likewise it remembers whether attachments have been saved so as to avoid redundantly resaving them when the same report is generated in multiple formats.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IReportWriter
C#
public interface IReportWriter
C++
interface class IReportWriter
J#
public interface IReportWriter
JScript
public interface IReportWriter

Types that implement IReportWriter

Type | Description
Gallio.Runner.Reports.DefaultReportWriter | Default implementation of a report writer.

See Also

IReportWriter Members
Gallio.Runner.Reports Namespace


IReportWriter Members

IReportWriter Members
See Also Example Properties Methods
[image]

A report writer provides services for formatting or saving a report to a IReportContainer.

The writer tracks the paths of the report documents paths that are created within the report container. Likewise it remembers whether attachments have been saved so as to avoid redundantly resaving them when the same report is generated in multiple formats.

The following tables list the members exposed by IReportWriter.

Public Properties

 | Name | Description
Public property | Report | Gets the report being generated.
Public property | ReportContainer | Gets the report container.
Public property | ReportDocumentPaths | Gets the paths of all report documents that have been generated within the report container. Report documents are the primary files when reports are formatted or saved such as an XML file, a Text file, or the main HTML file that contains the body of the report.
Top

Public Methods

 | Name | Description
Public method | AddReportDocumentPath | Adds the path of a report document that has been created within the report container.
Public method | SaveReport | Saves the report as an XML file. The saved report XML file is automatically added to the ReportDocumentPaths list. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | SaveReportAttachments | Saves all report attachments as individual content files to the container. The convention for attachments is to save them in a directory with the same name as the container's ReportName arranged in folders first by test id then by step id then by attachment name. For example: "Report\{testid}\{stepid}\attachment.jpg".
Public method | SerializeReport | Serializes the report to XML.
Top

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


Properties

IReportWriter Properties
[image]

Public Properties

 | Name | Description
Public property | Report | Gets the report being generated.
Public property | ReportContainer | Gets the report container.
Public property | ReportDocumentPaths | Gets the paths of all report documents that have been generated within the report container. Report documents are the primary files when reports are formatted or saved such as an XML file, a Text file, or the main HTML file that contains the body of the report.
Top

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


Report Property

IReportWriter.Report Property
[image]

Gets the report being generated.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Report As Report
C#
Report Report { get; }
C++
property Report Report abstract {
Report get();
}
J#
/** property */
public Report get_Report();
JScript
public function get Report() : Report

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


ReportContainer Property

IReportWriter.ReportContainer Property
[image]

Gets the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportContainer As IReportContainer
C#
IReportContainer ReportContainer { get; }
C++
property IReportContainer ReportContainer abstract {
IReportContainer get();
}
J#
/** property */
public IReportContainer get_ReportContainer();
JScript
public function get ReportContainer() : IReportContainer

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


ReportDocumentPaths Property

IReportWriter.ReportDocumentPaths Property
[image]

Gets the paths of all report documents that have been generated within the report container. Report documents are the primary files when reports are formatted or saved such as an XML file, a Text file, or the main HTML file that contains the body of the report.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ReportDocumentPaths As IList(Of String)
C#
IList<string> ReportDocumentPaths { get; }
C++
property IList<string> ReportDocumentPaths abstract {
IList<string> get();
}
J#
/** property */
public IList<string> get_ReportDocumentPaths();
JScript
public function get ReportDocumentPaths() : IList<string>

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


Methods

IReportWriter Methods
[image]

Public Methods

 | Name | Description
Public method | AddReportDocumentPath | Adds the path of a report document that has been created within the report container.
Public method | SaveReport | Saves the report as an XML file. The saved report XML file is automatically added to the ReportDocumentPaths list. The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.
Public method | SaveReportAttachments | Saves all report attachments as individual content files to the container. The convention for attachments is to save them in a directory with the same name as the container's ReportName arranged in folders first by test id then by step id then by attachment name. For example: "Report\{testid}\{stepid}\attachment.jpg".
Public method | SerializeReport | Serializes the report to XML.
Top

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


AddReportDocumentPath Method

IReportWriter.AddReportDocumentPath Method
[image]

Adds the path of a report document that has been created within the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddReportDocumentPath( _
ByVal path As String _
)
C#
void AddReportDocumentPath(
string path
)
C++
void AddReportDocumentPath(
String path
) abstract
J#
void AddReportDocumentPath(
string path
)
JScript
function AddReportDocumentPath(
path : String
)

Parameters

path
The document path

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


SaveReport Method

IReportWriter.SaveReport Method
[image]

Saves the report as an XML file.

The saved report XML file is automatically added to the ReportDocumentPaths list.

The path of the saved report is constructed by appending the extension ".xml" to the container's ReportName.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SaveReport( _
ByVal attachmentContentDisposition As AttachmentContentDisposition, _
ByVal progressMonitor As IProgressMonitor _
)
C#
void SaveReport(
AttachmentContentDisposition attachmentContentDisposition,
IProgressMonitor progressMonitor
)
C++
void SaveReport(
AttachmentContentDisposition attachmentContentDisposition,
IProgressMonitor progressMonitor
) abstract
J#
void SaveReport(
AttachmentContentDisposition attachmentContentDisposition,
IProgressMonitor progressMonitor
)
JScript
function SaveReport(
attachmentContentDisposition : AttachmentContentDisposition,
progressMonitor : IProgressMonitor
)

Parameters

attachmentContentDisposition
The content disposition to use for all attachments. If the content disposition is Link then this method will automatically call SaveReportAttachments to save the attachments.
progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown progressMonitor is null

Remarks

This method may do nothing if the report has already been saved.

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


SaveReportAttachments Method

IReportWriter.SaveReportAttachments Method
[image]

Saves all report attachments as individual content files to the container.

The convention for attachments is to save them in a directory with the same name as the container's ReportName arranged in folders first by test id then by step id then by attachment name. For example: "Report\{testid}\{stepid}\attachment.jpg".

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SaveReportAttachments( _
ByVal progressMonitor As IProgressMonitor _
)
C#
void SaveReportAttachments(
IProgressMonitor progressMonitor
)
C++
void SaveReportAttachments(
IProgressMonitor progressMonitor
) abstract
J#
void SaveReportAttachments(
IProgressMonitor progressMonitor
)
JScript
function SaveReportAttachments(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null

Remarks

This method may do nothing if the attachments have already been saved.

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


SerializeReport Method

IReportWriter.SerializeReport Method
[image]

Serializes the report to XML.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SerializeReport( _
ByVal xmlWriter As XmlWriter, _
ByVal attachmentContentDisposition As AttachmentContentDisposition _
)
C#
void SerializeReport(
XmlWriter xmlWriter,
AttachmentContentDisposition attachmentContentDisposition
)
C++
void SerializeReport(
XmlWriter xmlWriter,
AttachmentContentDisposition attachmentContentDisposition
) abstract
J#
void SerializeReport(
XmlWriter xmlWriter,
AttachmentContentDisposition attachmentContentDisposition
)
JScript
function SerializeReport(
xmlWriter : XmlWriter,
attachmentContentDisposition : AttachmentContentDisposition
)

Parameters

xmlWriter
The XML writer
attachmentContentDisposition
The content disposition to use for all attachments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if xmlWriter is null

See Also

IReportWriter Interface
Gallio.Runner.Reports Namespace


LogEntry Class

LogEntry Class
See Also Example Members
[image]

Describes a log entry for reporting purposes.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public Class LogEntry
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public class LogEntry
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class LogEntry
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public class LogEntry
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
class LogEntry

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.LogEntry

See Also

LogEntry Members
Gallio.Runner.Reports Namespace


LogEntry Members

LogEntry Members
See Also Example Constructors Properties Methods
[image]

Describes a log entry for reporting purposes.

The following tables list the members exposed by LogEntry.

Public Constructors

 | Name | Description
Public method | LogEntry | Initializes a new instance of the LogEntry class.
Top

Public Properties

 | Name | Description
Public property | Details | Gets or sets the log message details, such as an exception.
Public property | Message | Gets or sets the log message.
Public property | Severity | Gets or sets the log message severity.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogEntry Class
Gallio.Runner.Reports Namespace


LogEntry Constructor

LogEntry Constructor
[image]

Initializes a new instance of the LogEntry class.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LogEntry()
C++
public:
LogEntry() sealed
J#
public LogEntry()
JScript
public function LogEntry()

See Also

LogEntry Class
Gallio.Runner.Reports Namespace


Properties

LogEntry Properties
[image]

Public Properties

 | Name | Description
Public property | Details | Gets or sets the log message details, such as an exception.
Public property | Message | Gets or sets the log message.
Public property | Severity | Gets or sets the log message severity.
Top

See Also

LogEntry Class
Gallio.Runner.Reports Namespace


Details Property

LogEntry.Details Property
[image]

Gets or sets the log message details, such as an exception.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("details")>
Public Property Details As String
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
[XmlAttributeAttribute("details")]
public string Details { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
[XmlAttributeAttribute(L"details")]
public property string Details sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("details") */
/** property */
public string get_Details();

/** property */
public void set_Details(string value);
JScript
public CompilerGeneratedAttribute function get Details() : String

public CompilerGeneratedAttribute function set Details(value : String);

See Also

LogEntry Class
Gallio.Runner.Reports Namespace


Message Property

LogEntry.Message Property
[image]

Gets or sets the log message.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("message")>
Public Property Message As String
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
[XmlAttributeAttribute("message")]
public string Message { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
[XmlAttributeAttribute(L"message")]
public property string Message sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("message") */
/** property */
public string get_Message();

/** property */
public void set_Message(string value);
JScript
public CompilerGeneratedAttribute function get Message() : String

public CompilerGeneratedAttribute function set Message(value : String);

See Also

LogEntry Class
Gallio.Runner.Reports Namespace


Severity Property

LogEntry.Severity Property
[image]

Gets or sets the log message severity.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("severity")>
Public Property Severity As LogSeverity
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
[XmlAttributeAttribute("severity")]
public LogSeverity Severity { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
[XmlAttributeAttribute(L"severity")]
public property LogSeverity Severity sealed {
LogSeverity get();
void set(LogSeverity value);
}
J#
/** @attribute XmlAttributeAttribute("severity") */
/** property */
public LogSeverity get_Severity();

/** property */
public void set_Severity(LogSeverity value);
JScript
public CompilerGeneratedAttribute function get Severity() : LogSeverity

public CompilerGeneratedAttribute function set Severity(value : LogSeverity);

See Also

LogEntry Class
Gallio.Runner.Reports Namespace


Report Class

Report Class
See Also Example Members
[image]

A report includes a description of the test package, the model objects, the combined results of all test runs and summary statistics. This class cannot be inherited.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("report", Namespace := "http://www.gallio.org/")>
Public NotInheritable Class Report
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("report", Namespace = "http://www.gallio.org/")]
public sealed class Report
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"report", Namespace = L"http://www.gallio.org/")]
ref class Report sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("report", Namespace = "http://www.gallio.org/") */
public final class Report
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("report", Namespace = "http://www.gallio.org/")
final class Report

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.Report

See Also

Report Members
Gallio.Runner.Reports Namespace


Report Members

Report Members
See Also Example Constructors Properties Methods
[image]

A report includes a description of the test package, the model objects, the combined results of all test runs and summary statistics. This class cannot be inherited.

The following tables list the members exposed by Report.

Public Constructors

 | Name | Description
Public method | Report | Creates an empty report.
Top

Public Properties

 | Name | Description
Public property | LogEntries | Gets a mutable list of log entries.
Public property | TestModel | Gets or sets the test model, or null if none.
Public property | TestPackageConfig | Gets or sets the test package configuration, or null if none.
Public property | TestPackageRun | Gets or sets the test package run results, or null if none.
Top

Public Methods

 | Name | Description
Public method | AddLogEntry | Adds a log entry to the report.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Report Class
Gallio.Runner.Reports Namespace


Report Constructor

Report Constructor
[image]

Creates an empty report.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Report()
C++
public:
Report() sealed
J#
public Report()
JScript
public function Report()

See Also

Report Class
Gallio.Runner.Reports Namespace


Properties

Report Properties
[image]

Public Properties

 | Name | Description
Public property | LogEntries | Gets a mutable list of log entries.
Public property | TestModel | Gets or sets the test model, or null if none.
Public property | TestPackageConfig | Gets or sets the test package configuration, or null if none.
Public property | TestPackageRun | Gets or sets the test package run results, or null if none.
Top

See Also

Report Class
Gallio.Runner.Reports Namespace


LogEntries Property

Report.LogEntries Property
[image]

Gets a mutable list of log entries.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("logEntry", GetType(LogEntry), Namespace := "http://www.gallio.org/", IsNullable := False), _
XmlArrayAttribute("logEntries", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public ReadOnly Property LogEntries As List(Of LogEntry)
C#
[XmlArrayItemAttribute("logEntry", typeof(LogEntry), Namespace = "http://www.gallio.org/", IsNullable = False)]
[XmlArrayAttribute("logEntries", Namespace = "http://www.gallio.org/", IsNullable = False)]
public List<LogEntry> LogEntries { get; }
C++
[XmlArrayItemAttribute(L"logEntry", typeof(LogEntry), Namespace = L"http://www.gallio.org/", IsNullable = False)]
[XmlArrayAttribute(L"logEntries", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property List<LogEntry> LogEntries sealed {
List<LogEntry> get();
}
J#
/** @attribute XmlArrayItemAttribute("logEntry", typeof(LogEntry), Namespace = "http://www.gallio.org/", IsNullable = False) */
/** @attribute XmlArrayAttribute("logEntries", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public List<LogEntry> get_LogEntries();
JScript
public function get LogEntries() : List<LogEntry>

See Also

Report Class
Gallio.Runner.Reports Namespace


TestModel Property

Report.TestModel Property
[image]

Gets or sets the test model, or null if none.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testModel", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property TestModel As TestModelData
C#
[XmlElementAttribute("testModel", Namespace = "http://www.gallio.org/", IsNullable = False)]
public TestModelData TestModel { get; set; }
C++
[XmlElementAttribute(L"testModel", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property TestModelData TestModel sealed {
TestModelData get();
void set(TestModelData value);
}
J#
/** @attribute XmlElementAttribute("testModel", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public TestModelData get_TestModel();

/** property */
public void set_TestModel(TestModelData value);
JScript
public function get TestModel() : TestModelData

public function set TestModel(value : TestModelData);

See Also

Report Class
Gallio.Runner.Reports Namespace


TestPackageConfig Property

Report.TestPackageConfig Property
[image]

Gets or sets the test package configuration, or null if none.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testPackageConfig", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property TestPackageConfig As TestPackageConfig
C#
[XmlElementAttribute("testPackageConfig", Namespace = "http://www.gallio.org/", IsNullable = False)]
public TestPackageConfig TestPackageConfig { get; set; }
C++
[XmlElementAttribute(L"testPackageConfig", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property TestPackageConfig TestPackageConfig sealed {
TestPackageConfig get();
void set(TestPackageConfig value);
}
J#
/** @attribute XmlElementAttribute("testPackageConfig", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public TestPackageConfig get_TestPackageConfig();

/** property */
public void set_TestPackageConfig(TestPackageConfig value);
JScript
public function get TestPackageConfig() : TestPackageConfig

public function set TestPackageConfig(value : TestPackageConfig);

See Also

Report Class
Gallio.Runner.Reports Namespace


TestPackageRun Property

Report.TestPackageRun Property
[image]

Gets or sets the test package run results, or null if none.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testPackageRun", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property TestPackageRun As TestPackageRun
C#
[XmlElementAttribute("testPackageRun", Namespace = "http://www.gallio.org/", IsNullable = False)]
public TestPackageRun TestPackageRun { get; set; }
C++
[XmlElementAttribute(L"testPackageRun", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property TestPackageRun TestPackageRun sealed {
TestPackageRun get();
void set(TestPackageRun value);
}
J#
/** @attribute XmlElementAttribute("testPackageRun", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public TestPackageRun get_TestPackageRun();

/** property */
public void set_TestPackageRun(TestPackageRun value);
JScript
public function get TestPackageRun() : TestPackageRun

public function set TestPackageRun(value : TestPackageRun);

See Also

Report Class
Gallio.Runner.Reports Namespace


Methods

Report Methods
[image]

Public Methods

 | Name | Description
Public method | AddLogEntry | Adds a log entry to the report.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Report Class
Gallio.Runner.Reports Namespace


AddLogEntry Method

Report.AddLogEntry Method
[image]

Adds a log entry to the report.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddLogEntry( _
ByVal logEntry As LogEntry _
)
C#
public void AddLogEntry(
LogEntry logEntry
)
C++
public:
void AddLogEntry(
LogEntry logEntry
) sealed
J#
public void AddLogEntry(
LogEntry logEntry
)
JScript
public function AddLogEntry(
logEntry : LogEntry
)

Parameters

logEntry
The log entry to add

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logEntry is null

See Also

Report Class
Gallio.Runner.Reports Namespace


ReportContainerUtils Class

ReportContainerUtils Class
See Also Example Members
[image]

Utilities for working with IReportContainer. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ReportContainerUtils
C#
public static class ReportContainerUtils
C++
ref class ReportContainerUtils abstract sealed
J#
public final class ReportContainerUtils
JScript
public class ReportContainerUtils

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.ReportContainerUtils

See Also

ReportContainerUtils Members
Gallio.Runner.Reports Namespace


ReportContainerUtils Members

ReportContainerUtils Members
See Also Example Methods
[image]

Utilities for working with IReportContainer. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ReportContainerUtils.

Public Methods

Name | Description
CopyToReport | Recursively copies files and folders from the source path in the native file system to the destination path within the report container.
Top

See Also

ReportContainerUtils Class
Gallio.Runner.Reports Namespace


Methods

ReportContainerUtils Methods
[image]

Public Methods

Name | Description
CopyToReport | Recursively copies files and folders from the source path in the native file system to the destination path within the report container.
Top

See Also

ReportContainerUtils Class
Gallio.Runner.Reports Namespace


CopyToReport Method

ReportContainerUtils.CopyToReport Method
[image]

Recursively copies files and folders from the source path in the native file system to the destination path within the report container.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyToReport( _
ByVal container As IReportContainer, _
ByVal sourcePathInFileSystem As String, _
ByVal destPathInContainer As String _
)
C#
public static void CopyToReport(
IReportContainer container,
string sourcePathInFileSystem,
string destPathInContainer
)
C++
public:
static void CopyToReport(
IReportContainer container,
String sourcePathInFileSystem,
String destPathInContainer
)
J#
public static void CopyToReport(
IReportContainer container,
string sourcePathInFileSystem,
string destPathInContainer
)
JScript
public static function CopyToReport(
container : IReportContainer,
sourcePathInFileSystem : String,
destPathInContainer : String
)

Parameters

container
The container
sourcePathInFileSystem
The source file or directory path in the native file system
destPathInContainer
The destination file or directory path in the report container

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if container, sourcePathInFileSystem or destPathInContainer is null

See Also

ReportContainerUtils Class
Gallio.Runner.Reports Namespace


ReportFormatterOptions Class

ReportFormatterOptions Class
See Also Example Members
[image]

Provides options to report formatters. This class cannot be inherited.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class ReportFormatterOptions
C#
[SerializableAttribute]
public sealed class ReportFormatterOptions
C++
[SerializableAttribute]
ref class ReportFormatterOptions sealed
J#
/** @attribute SerializableAttribute() */
public final class ReportFormatterOptions
JScript
public
SerializableAttribute
final class ReportFormatterOptions

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.ReportFormatterOptions

See Also

ReportFormatterOptions Members
Gallio.Runner.Reports Namespace


ReportFormatterOptions Members

ReportFormatterOptions Members
See Also Example Constructors Properties Methods
[image]

Provides options to report formatters. This class cannot be inherited.

The following tables list the members exposed by ReportFormatterOptions.

Public Constructors

 | Name | Description
Public method | ReportFormatterOptions | Creates a default set of options.
Top

Public Properties

 | Name | Description
Public property | Properties | Gets a mutable collection of key/value pairs that specify configuration properties for the report formatter.
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ReportFormatterOptions Class
Gallio.Runner.Reports Namespace


ReportFormatterOptions Constructor

ReportFormatterOptions Constructor
[image]

Creates a default set of options.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ReportFormatterOptions()
C++
public:
ReportFormatterOptions() sealed
J#
public ReportFormatterOptions()
JScript
public function ReportFormatterOptions()

See Also

ReportFormatterOptions Class
Gallio.Runner.Reports Namespace


Properties

ReportFormatterOptions Properties
[image]

Public Properties

 | Name | Description
Public property | Properties | Gets a mutable collection of key/value pairs that specify configuration properties for the report formatter.
Top

See Also

ReportFormatterOptions Class
Gallio.Runner.Reports Namespace


Properties Property

ReportFormatterOptions.Properties Property
[image]

Gets a mutable collection of key/value pairs that specify configuration properties for the report formatter.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As PropertySet
C#
public PropertySet Properties { get; }
C++
public property PropertySet Properties sealed {
PropertySet get();
}
J#
/** property */
public PropertySet get_Properties();
JScript
public function get Properties() : PropertySet

See Also

ReportFormatterOptions Class
Gallio.Runner.Reports Namespace


Methods

ReportFormatterOptions Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the options.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ReportFormatterOptions Class
Gallio.Runner.Reports Namespace


Copy Method

ReportFormatterOptions.Copy Method
[image]

Creates a copy of the options.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As ReportFormatterOptions
C#
public ReportFormatterOptions Copy()
C++
public:
ReportFormatterOptions Copy() sealed
J#
public ReportFormatterOptions Copy()
JScript
public function Copy() : ReportFormatterOptions

Return Value

The copy

See Also

ReportFormatterOptions Class
Gallio.Runner.Reports Namespace


Statistics Class

Statistics Class
See Also Example Members
[image]

Collects summary statistics about test execution for reporting purposes. This class cannot be inherited.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute(ElementName := "statistics", Namespace := "http://www.gallio.org/")>
Public NotInheritable Class Statistics
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute(ElementName = "statistics", Namespace = "http://www.gallio.org/")]
public sealed class Statistics
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(ElementName = L"statistics", Namespace = L"http://www.gallio.org/")]
ref class Statistics sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute(ElementName = "statistics", Namespace = "http://www.gallio.org/") */
public final class Statistics
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute(ElementName = "statistics", Namespace = "http://www.gallio.org/")
final class Statistics

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.Statistics

See Also

Statistics Members
Gallio.Runner.Reports Namespace


Statistics Members

Statistics Members
See Also Example Constructors Properties Methods
[image]

Collects summary statistics about test execution for reporting purposes. This class cannot be inherited.

The following tables list the members exposed by Statistics.

Public Constructors

 | Name | Description
Public method | Statistics | Creates an empty statistics record.
Top

Public Properties

 | Name | Description
Public property | AssertCount | Gets or sets the number of assertions evaluated.
Public property | Duration | Gets or sets the total duration summarized tests in seconds.
Public property | FailedCount | Gets or sets the number of test cases that ran and failed.
Public property | InconclusiveCount | Gets or sets the number of test cases that ran and were inconclusive.
Public property | OutcomeSummaries | Gets or sets the test outcome summaries.
Public property | PassedCount | Gets or sets the number of test cases that ran and passed.
Public property | RunCount | Gets or sets the number of test cases that were run.
Public property | SkippedCount | Gets or sets the number of test cases that did not run.
Public property | StepCount | Gets or sets the total number of test steps.
Public property | TestCount | Gets or sets the total number of test cases.
Top

Public Methods

 | Name | Description
Public method | AddOutcome | Updates the test outcome statistics counters with an the outcome of a test.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FormatTestCaseResultSummary | Formats a single line of text summarizing test case results.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetOutcomeCount | Gets the number of tests with the specified outcome.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | MergeStepStatistics | Merges statistics from a test step run, incrementing the relevant counters.
Public method | SetOutcomeCount | Ssets the number of tests with the specified outcomee.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Statistics Class
Gallio.Runner.Reports Namespace


Statistics Constructor

Statistics Constructor
[image]

Creates an empty statistics record.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Statistics()
C++
public:
Statistics() sealed
J#
public Statistics()
JScript
public function Statistics()

See Also

Statistics Class
Gallio.Runner.Reports Namespace


Properties

Statistics Properties
[image]

Public Properties

 | Name | Description
Public property | AssertCount | Gets or sets the number of assertions evaluated.
Public property | Duration | Gets or sets the total duration summarized tests in seconds.
Public property | FailedCount | Gets or sets the number of test cases that ran and failed.
Public property | InconclusiveCount | Gets or sets the number of test cases that ran and were inconclusive.
Public property | OutcomeSummaries | Gets or sets the test outcome summaries.
Public property | PassedCount | Gets or sets the number of test cases that ran and passed.
Public property | RunCount | Gets or sets the number of test cases that were run.
Public property | SkippedCount | Gets or sets the number of test cases that did not run.
Public property | StepCount | Gets or sets the total number of test steps.
Public property | TestCount | Gets or sets the total number of test cases.
Top

See Also

Statistics Class
Gallio.Runner.Reports Namespace


AssertCount Property

Statistics.AssertCount Property
[image]

Gets or sets the number of assertions evaluated.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assertCount")>
Public Property AssertCount As Integer
C#
[XmlAttributeAttribute("assertCount")]
public int AssertCount { get; set; }
C++
[XmlAttributeAttribute(L"assertCount")]
public property int AssertCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("assertCount") */
/** property */
public int get_AssertCount();

/** property */
public void set_AssertCount(int value);
JScript
public function get AssertCount() : int

public function set AssertCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


Duration Property

Statistics.Duration Property
[image]

Gets or sets the total duration summarized tests in seconds.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("duration")>
Public Property Duration As Double
C#
[XmlAttributeAttribute("duration")]
public double Duration { get; set; }
C++
[XmlAttributeAttribute(L"duration")]
public property double Duration sealed {
double get();
void set(double value);
}
J#
/** @attribute XmlAttributeAttribute("duration") */
/** property */
public double get_Duration();

/** property */
public void set_Duration(double value);
JScript
public function get Duration() : double

public function set Duration(value : double);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


FailedCount Property

Statistics.FailedCount Property
[image]

Gets or sets the number of test cases that ran and failed.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("failedCount")>
Public Property FailedCount As Integer
C#
[XmlAttributeAttribute("failedCount")]
public int FailedCount { get; set; }
C++
[XmlAttributeAttribute(L"failedCount")]
public property int FailedCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("failedCount") */
/** property */
public int get_FailedCount();

/** property */
public void set_FailedCount(int value);
JScript
public function get FailedCount() : int

public function set FailedCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


InconclusiveCount Property

Statistics.InconclusiveCount Property
[image]

Gets or sets the number of test cases that ran and were inconclusive.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("inconclusiveCount")>
Public Property InconclusiveCount As Integer
C#
[XmlAttributeAttribute("inconclusiveCount")]
public int InconclusiveCount { get; set; }
C++
[XmlAttributeAttribute(L"inconclusiveCount")]
public property int InconclusiveCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("inconclusiveCount") */
/** property */
public int get_InconclusiveCount();

/** property */
public void set_InconclusiveCount(int value);
JScript
public function get InconclusiveCount() : int

public function set InconclusiveCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


OutcomeSummaries Property

Statistics.OutcomeSummaries Property
[image]

Gets or sets the test outcome summaries.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("outcomeSummary", GetType(TestOutcomeSummary), IsNullable := False), _
XmlArrayAttribute("outcomeSummaries", IsNullable := False)>
Public Property OutcomeSummaries As TestOutcomeSummary()
C#
[XmlArrayItemAttribute("outcomeSummary", typeof(TestOutcomeSummary), IsNullable = False)]
[XmlArrayAttribute("outcomeSummaries", IsNullable = False)]
public TestOutcomeSummary[] OutcomeSummaries { get; set; }
C++
[XmlArrayItemAttribute(L"outcomeSummary", typeof(TestOutcomeSummary), IsNullable = False)]
[XmlArrayAttribute(L"outcomeSummaries", IsNullable = False)]
public property TestOutcomeSummary[] OutcomeSummaries sealed {
array<TestOutcomeSummary>^ get();
void set(array<TestOutcomeSummary>^ value);
}
J#
/** @attribute XmlArrayItemAttribute("outcomeSummary", typeof(TestOutcomeSummary), IsNullable = False) */
/** @attribute XmlArrayAttribute("outcomeSummaries", IsNullable = False) */
/** property */
public TestOutcomeSummary[] get_OutcomeSummaries();

/** property */
public void set_OutcomeSummaries(TestOutcomeSummary[] value);
JScript
public function get OutcomeSummaries() : TestOutcomeSummary[]

public function set OutcomeSummaries(value : TestOutcomeSummary[]);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

Statistics Class
Gallio.Runner.Reports Namespace


PassedCount Property

Statistics.PassedCount Property
[image]

Gets or sets the number of test cases that ran and passed.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("passedCount")>
Public Property PassedCount As Integer
C#
[XmlAttributeAttribute("passedCount")]
public int PassedCount { get; set; }
C++
[XmlAttributeAttribute(L"passedCount")]
public property int PassedCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("passedCount") */
/** property */
public int get_PassedCount();

/** property */
public void set_PassedCount(int value);
JScript
public function get PassedCount() : int

public function set PassedCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


RunCount Property

Statistics.RunCount Property
[image]

Gets or sets the number of test cases that were run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("runCount")>
Public Property RunCount As Integer
C#
[XmlAttributeAttribute("runCount")]
public int RunCount { get; set; }
C++
[XmlAttributeAttribute(L"runCount")]
public property int RunCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("runCount") */
/** property */
public int get_RunCount();

/** property */
public void set_RunCount(int value);
JScript
public function get RunCount() : int

public function set RunCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


SkippedCount Property

Statistics.SkippedCount Property
[image]

Gets or sets the number of test cases that did not run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("skippedCount")>
Public Property SkippedCount As Integer
C#
[XmlAttributeAttribute("skippedCount")]
public int SkippedCount { get; set; }
C++
[XmlAttributeAttribute(L"skippedCount")]
public property int SkippedCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("skippedCount") */
/** property */
public int get_SkippedCount();

/** property */
public void set_SkippedCount(int value);
JScript
public function get SkippedCount() : int

public function set SkippedCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


StepCount Property

Statistics.StepCount Property
[image]

Gets or sets the total number of test steps.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("stepCount")>
Public Property StepCount As Integer
C#
[XmlAttributeAttribute("stepCount")]
public int StepCount { get; set; }
C++
[XmlAttributeAttribute(L"stepCount")]
public property int StepCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("stepCount") */
/** property */
public int get_StepCount();

/** property */
public void set_StepCount(int value);
JScript
public function get StepCount() : int

public function set StepCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


TestCount Property

Statistics.TestCount Property
[image]

Gets or sets the total number of test cases.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("testCount")>
Public Property TestCount As Integer
C#
[XmlAttributeAttribute("testCount")]
public int TestCount { get; set; }
C++
[XmlAttributeAttribute(L"testCount")]
public property int TestCount sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("testCount") */
/** property */
public int get_TestCount();

/** property */
public void set_TestCount(int value);
JScript
public function get TestCount() : int

public function set TestCount(value : int);

See Also

Statistics Class
Gallio.Runner.Reports Namespace


Methods

Statistics Methods
[image]

Public Methods

 | Name | Description
Public method | AddOutcome | Updates the test outcome statistics counters with an the outcome of a test.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FormatTestCaseResultSummary | Formats a single line of text summarizing test case results.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetOutcomeCount | Gets the number of tests with the specified outcome.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | MergeStepStatistics | Merges statistics from a test step run, incrementing the relevant counters.
Public method | SetOutcomeCount | Ssets the number of tests with the specified outcomee.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Statistics Class
Gallio.Runner.Reports Namespace


AddOutcome Method

Statistics.AddOutcome Method
[image]

Updates the test outcome statistics counters with an the outcome of a test.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddOutcome( _
ByVal outcome As TestOutcome _
)
C#
public void AddOutcome(
TestOutcome outcome
)
C++
public:
void AddOutcome(
TestOutcome outcome
) sealed
J#
public void AddOutcome(
TestOutcome outcome
)
JScript
public function AddOutcome(
outcome : TestOutcome
)

Parameters

outcome
The test outcome

Remarks

Does not update the test or step count.

See Also

Statistics Class
Gallio.Runner.Reports Namespace


FormatTestCaseResultSummary Method

Statistics.FormatTestCaseResultSummary Method
[image]

Formats a single line of text summarizing test case results.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function FormatTestCaseResultSummary() As String
C#
public string FormatTestCaseResultSummary()
C++
public:
String FormatTestCaseResultSummary() sealed
J#
public string FormatTestCaseResultSummary()
JScript
public function FormatTestCaseResultSummary() : String

See Also

Statistics Class
Gallio.Runner.Reports Namespace


GetOutcomeCount Method

Statistics.GetOutcomeCount Method
[image]

Gets the number of tests with the specified outcome.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOutcomeCount( _
ByVal outcome As TestOutcome _
) As Integer
C#
public int GetOutcomeCount(
TestOutcome outcome
)
C++
public:
int GetOutcomeCount(
TestOutcome outcome
) sealed
J#
public int GetOutcomeCount(
TestOutcome outcome
)
JScript
public function GetOutcomeCount(
outcome : TestOutcome
) : int

Parameters

outcome
The outcome

Return Value

The number of tests with the specified outcome

See Also

Statistics Class
Gallio.Runner.Reports Namespace


MergeStepStatistics Method

Statistics.MergeStepStatistics Method
[image]

Merges statistics from a test step run, incrementing the relevant counters.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub MergeStepStatistics( _
ByVal testStepRun As TestStepRun _
)
C#
public void MergeStepStatistics(
TestStepRun testStepRun
)
C++
public:
void MergeStepStatistics(
TestStepRun testStepRun
) sealed
J#
public void MergeStepStatistics(
TestStepRun testStepRun
)
JScript
public function MergeStepStatistics(
testStepRun : TestStepRun
)

Parameters

testStepRun
The test step run

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testStepRun is null

See Also

Statistics Class
Gallio.Runner.Reports Namespace


SetOutcomeCount Method

Statistics.SetOutcomeCount Method
[image]

Ssets the number of tests with the specified outcomee.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetOutcomeCount( _
ByVal outcome As TestOutcome, _
ByVal count As Integer _
)
C#
public void SetOutcomeCount(
TestOutcome outcome,
int count
)
C++
public:
void SetOutcomeCount(
TestOutcome outcome,
int count
) sealed
J#
public void SetOutcomeCount(
TestOutcome outcome,
int count
)
JScript
public function SetOutcomeCount(
outcome : TestOutcome,
count : int
)

Parameters

outcome
The outcome
count
The count

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if count is less than 0

See Also

Statistics Class
Gallio.Runner.Reports Namespace


TestOutcomeSummary Class

TestOutcomeSummary Class
See Also Example Members
[image]

Describes the number of test cases with a particular TestOutcome. This class cannot be inherited.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestOutcomeSummary
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestOutcomeSummary
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestOutcomeSummary sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestOutcomeSummary
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestOutcomeSummary

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.TestOutcomeSummary

See Also

TestOutcomeSummary Members
Gallio.Runner.Reports Namespace
TestOutcome


TestOutcomeSummary Members

TestOutcomeSummary Members
See Also Example Constructors Properties Methods
[image]

Describes the number of test cases with a particular TestOutcome. This class cannot be inherited.

The following tables list the members exposed by TestOutcomeSummary.

Public Constructors

 | Name | Description
Public method | TestOutcomeSummary | Initializes a new instance of the TestOutcomeSummary class.
Top

Public Properties

 | Name | Description
Public property | Count | Gets or sets the number of test cases with the specified outcome.
Public property | Outcome | Gets or sets the outcome.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestOutcomeSummary Class
Gallio.Runner.Reports Namespace
TestOutcome


TestOutcomeSummary Constructor

TestOutcomeSummary Constructor
[image]

Initializes a new instance of the TestOutcomeSummary class.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestOutcomeSummary()
C++
public:
TestOutcomeSummary() sealed
J#
public TestOutcomeSummary()
JScript
public function TestOutcomeSummary()

See Also

TestOutcomeSummary Class
Gallio.Runner.Reports Namespace


Properties

TestOutcomeSummary Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets or sets the number of test cases with the specified outcome.
Public property | Outcome | Gets or sets the outcome.
Top

See Also

TestOutcomeSummary Class
Gallio.Runner.Reports Namespace
TestOutcome


Count Property

TestOutcomeSummary.Count Property
[image]

Gets or sets the number of test cases with the specified outcome.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("count")>
Public Property Count As Integer
C#
[XmlAttributeAttribute("count")]
public int Count { get; set; }
C++
[XmlAttributeAttribute(L"count")]
public property int Count sealed {
int get();
void set(int value);
}
J#
/** @attribute XmlAttributeAttribute("count") */
/** property */
public int get_Count();

/** property */
public void set_Count(int value);
JScript
public function get Count() : int

public function set Count(value : int);

See Also

TestOutcomeSummary Class
Gallio.Runner.Reports Namespace


Outcome Property

TestOutcomeSummary.Outcome Property
[image]

Gets or sets the outcome.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("outcome", IsNullable := False)>
Public Property Outcome As TestOutcome
C#
[XmlElementAttribute("outcome", IsNullable = False)]
public TestOutcome Outcome { get; set; }
C++
[XmlElementAttribute(L"outcome", IsNullable = False)]
public property TestOutcome Outcome sealed {
TestOutcome get();
void set(TestOutcome value);
}
J#
/** @attribute XmlElementAttribute("outcome", IsNullable = False) */
/** property */
public TestOutcome get_Outcome();

/** property */
public void set_Outcome(TestOutcome value);
JScript
public function get Outcome() : TestOutcome

public function set Outcome(value : TestOutcome);

See Also

TestOutcomeSummary Class
Gallio.Runner.Reports Namespace


TestPackageRun Class

TestPackageRun Class
See Also Example Members
[image]

Summarizes the execution of a test package for reporting purposes. This class cannot be inherited.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestPackageRun
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestPackageRun
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestPackageRun sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestPackageRun
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestPackageRun

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.TestPackageRun

See Also

TestPackageRun Members
Gallio.Runner.Reports Namespace


TestPackageRun Members

TestPackageRun Members
See Also Example Constructors Properties Methods
[image]

Summarizes the execution of a test package for reporting purposes. This class cannot be inherited.

The following tables list the members exposed by TestPackageRun.

Public Constructors

 | Name | Description
Public method | TestPackageRun | Creates an empty package run.
Top

Public Properties

 | Name | Description
Public property | AllTestStepRuns | Recursively enumerates all test step runs including the root test step run.
Public property | EndTime | Gets or sets the time when the package run ended.
Public property | RootTestStepRun | Gets or sets the root test step run, or null if the root test has not run.
Public property | StartTime | Gets or sets the time when the package run started.
Public property | Statistics | Gets or sets the statistics for the package run.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


TestPackageRun Constructor

TestPackageRun Constructor
[image]

Creates an empty package run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestPackageRun()
C++
public:
TestPackageRun() sealed
J#
public TestPackageRun()
JScript
public function TestPackageRun()

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


Properties

TestPackageRun Properties
[image]

Public Properties

 | Name | Description
Public property | AllTestStepRuns | Recursively enumerates all test step runs including the root test step run.
Public property | EndTime | Gets or sets the time when the package run ended.
Public property | RootTestStepRun | Gets or sets the root test step run, or null if the root test has not run.
Public property | StartTime | Gets or sets the time when the package run started.
Public property | Statistics | Gets or sets the statistics for the package run.
Top

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


AllTestStepRuns Property

TestPackageRun.AllTestStepRuns Property
[image]

Recursively enumerates all test step runs including the root test step run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property AllTestStepRuns As IEnumerable(Of TestStepRun)
C#
[XmlIgnoreAttribute]
public IEnumerable<TestStepRun> AllTestStepRuns { get; }
C++
[XmlIgnoreAttribute]
public property IEnumerable<TestStepRun> AllTestStepRuns sealed {
IEnumerable<TestStepRun> get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public IEnumerable<TestStepRun> get_AllTestStepRuns();
JScript
public function get AllTestStepRuns() : IEnumerable<TestStepRun>

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


EndTime Property

TestPackageRun.EndTime Property
[image]

Gets or sets the time when the package run ended.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("endTime")>
Public Property EndTime As Date
C#
[XmlAttributeAttribute("endTime")]
public DateTime EndTime { get; set; }
C++
[XmlAttributeAttribute(L"endTime")]
public property DateTime EndTime sealed {
DateTime get();
void set(DateTime value);
}
J#
/** @attribute XmlAttributeAttribute("endTime") */
/** property */
public DateTime get_EndTime();

/** property */
public void set_EndTime(DateTime value);
JScript
public function get EndTime() : DateTime

public function set EndTime(value : DateTime);

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


RootTestStepRun Property

TestPackageRun.RootTestStepRun Property
[image]

Gets or sets the root test step run, or null if the root test has not run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testStepRun", IsNullable := False)>
Public Property RootTestStepRun As TestStepRun
C#
[XmlElementAttribute("testStepRun", IsNullable = False)]
public TestStepRun RootTestStepRun { get; set; }
C++
[XmlElementAttribute(L"testStepRun", IsNullable = False)]
public property TestStepRun RootTestStepRun sealed {
TestStepRun get();
void set(TestStepRun value);
}
J#
/** @attribute XmlElementAttribute("testStepRun", IsNullable = False) */
/** property */
public TestStepRun get_RootTestStepRun();

/** property */
public void set_RootTestStepRun(TestStepRun value);
JScript
public function get RootTestStepRun() : TestStepRun

public function set RootTestStepRun(value : TestStepRun);

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


StartTime Property

TestPackageRun.StartTime Property
[image]

Gets or sets the time when the package run started.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("startTime")>
Public Property StartTime As Date
C#
[XmlAttributeAttribute("startTime")]
public DateTime StartTime { get; set; }
C++
[XmlAttributeAttribute(L"startTime")]
public property DateTime StartTime sealed {
DateTime get();
void set(DateTime value);
}
J#
/** @attribute XmlAttributeAttribute("startTime") */
/** property */
public DateTime get_StartTime();

/** property */
public void set_StartTime(DateTime value);
JScript
public function get StartTime() : DateTime

public function set StartTime(value : DateTime);

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


Statistics Property

TestPackageRun.Statistics Property
[image]

Gets or sets the statistics for the package run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("statistics", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property Statistics As Statistics
C#
[XmlElementAttribute("statistics", Namespace = "http://www.gallio.org/", IsNullable = False)]
public Statistics Statistics { get; set; }
C++
[XmlElementAttribute(L"statistics", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property Statistics Statistics sealed {
Statistics get();
void set(Statistics value);
}
J#
/** @attribute XmlElementAttribute("statistics", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public Statistics get_Statistics();

/** property */
public void set_Statistics(Statistics value);
JScript
public function get Statistics() : Statistics

public function set Statistics(value : Statistics);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestPackageRun Class
Gallio.Runner.Reports Namespace


TestStepRun Class

TestStepRun Class
See Also Example Members
[image]

Summarizes the execution of a single test step for reporting purposes. This class cannot be inherited.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("testStepRun", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class TestStepRun
C#
[SerializableAttribute]
[XmlRootAttribute("testStepRun", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class TestStepRun
C++
[SerializableAttribute]
[XmlRootAttribute(L"testStepRun", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class TestStepRun sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("testStepRun", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class TestStepRun
JScript
public
SerializableAttribute
XmlRootAttribute("testStepRun", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class TestStepRun

Inheritance Hierarchy

System.Object
Gallio.Runner.Reports.TestStepRun

See Also

TestStepRun Members
Gallio.Runner.Reports Namespace


TestStepRun Members

TestStepRun Members
See Also Example Constructors Properties Methods
[image]

Summarizes the execution of a single test step for reporting purposes. This class cannot be inherited.

The following tables list the members exposed by TestStepRun.

Public Constructors

 | Name | Description
Public method | TestStepRun | Creates a test run step.
Top

Public Properties

 | Name | Description
Public property | AllTestStepRuns | Recursively enumerates all test step runs including this one.
Public property | Children | Gets the list of child step runs.
Public property | EndTime | Gets or sets the time when the test run ended.
Public property | Result | Gets or sets the test result from the run.
Public property | StartTime | Gets or sets the time when the test run started.
Public property | Step | Gets or sets information about the step.
Public property | TestLog | Gets or sets the test log.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


TestStepRun Constructor

TestStepRun Constructor
[image]

Creates a test run step.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal step As TestStepData _
)
C#
public TestStepRun(
TestStepData step
)
C++
public:
TestStepRun(
TestStepData step
) sealed
J#
public TestStepRun(
TestStepData step
)
JScript
public function TestStepRun(
step : TestStepData
)

Parameters

step
Information about the step

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if step is null

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


Properties

TestStepRun Properties
[image]

Public Properties

 | Name | Description
Public property | AllTestStepRuns | Recursively enumerates all test step runs including this one.
Public property | Children | Gets the list of child step runs.
Public property | EndTime | Gets or sets the time when the test run ended.
Public property | Result | Gets or sets the test result from the run.
Public property | StartTime | Gets or sets the time when the test run started.
Public property | Step | Gets or sets information about the step.
Public property | TestLog | Gets or sets the test log.
Top

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


AllTestStepRuns Property

TestStepRun.AllTestStepRuns Property
[image]

Recursively enumerates all test step runs including this one.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property AllTestStepRuns As IEnumerable(Of TestStepRun)
C#
[XmlIgnoreAttribute]
public IEnumerable<TestStepRun> AllTestStepRuns { get; }
C++
[XmlIgnoreAttribute]
public property IEnumerable<TestStepRun> AllTestStepRuns sealed {
IEnumerable<TestStepRun> get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public IEnumerable<TestStepRun> get_AllTestStepRuns();
JScript
public function get AllTestStepRuns() : IEnumerable<TestStepRun>

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


Children Property

TestStepRun.Children Property
[image]

Gets the list of child step runs.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("children", Namespace := "http://www.gallio.org/", IsNullable := False), _
XmlArrayItemAttribute("testStepRun", GetType(TestStepRun), Namespace := "http://www.gallio.org/", IsNullable := False)>
Public ReadOnly Property Children As List(Of TestStepRun)
C#
[XmlArrayAttribute("children", Namespace = "http://www.gallio.org/", IsNullable = False)]
[XmlArrayItemAttribute("testStepRun", typeof(TestStepRun), Namespace = "http://www.gallio.org/", IsNullable = False)]
public List<TestStepRun> Children { get; }
C++
[XmlArrayAttribute(L"children", Namespace = L"http://www.gallio.org/", IsNullable = False)]
[XmlArrayItemAttribute(L"testStepRun", typeof(TestStepRun), Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property List<TestStepRun> Children sealed {
List<TestStepRun> get();
}
J#
/** @attribute XmlArrayAttribute("children", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("testStepRun", typeof(TestStepRun), Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public List<TestStepRun> get_Children();
JScript
public function get Children() : List<TestStepRun>

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


EndTime Property

TestStepRun.EndTime Property
[image]

Gets or sets the time when the test run ended.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("endTime")>
Public Property EndTime As Date
C#
[XmlAttributeAttribute("endTime")]
public DateTime EndTime { get; set; }
C++
[XmlAttributeAttribute(L"endTime")]
public property DateTime EndTime sealed {
DateTime get();
void set(DateTime value);
}
J#
/** @attribute XmlAttributeAttribute("endTime") */
/** property */
public DateTime get_EndTime();

/** property */
public void set_EndTime(DateTime value);
JScript
public function get EndTime() : DateTime

public function set EndTime(value : DateTime);

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


Result Property

TestStepRun.Result Property
[image]

Gets or sets the test result from the run.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("result", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property Result As TestResult
C#
[XmlElementAttribute("result", Namespace = "http://www.gallio.org/", IsNullable = False)]
public TestResult Result { get; set; }
C++
[XmlElementAttribute(L"result", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property TestResult Result sealed {
TestResult get();
void set(TestResult value);
}
J#
/** @attribute XmlElementAttribute("result", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public TestResult get_Result();

/** property */
public void set_Result(TestResult value);
JScript
public function get Result() : TestResult

public function set Result(value : TestResult);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


StartTime Property

TestStepRun.StartTime Property
[image]

Gets or sets the time when the test run started.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("startTime")>
Public Property StartTime As Date
C#
[XmlAttributeAttribute("startTime")]
public DateTime StartTime { get; set; }
C++
[XmlAttributeAttribute(L"startTime")]
public property DateTime StartTime sealed {
DateTime get();
void set(DateTime value);
}
J#
/** @attribute XmlAttributeAttribute("startTime") */
/** property */
public DateTime get_StartTime();

/** property */
public void set_StartTime(DateTime value);
JScript
public function get StartTime() : DateTime

public function set StartTime(value : DateTime);

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


Step Property

TestStepRun.Step Property
[image]

Gets or sets information about the step.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testStep", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property Step As TestStepData
C#
[XmlElementAttribute("testStep", Namespace = "http://www.gallio.org/", IsNullable = False)]
public TestStepData Step { get; set; }
C++
[XmlElementAttribute(L"testStep", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property TestStepData Step sealed {
TestStepData get();
void set(TestStepData value);
}
J#
/** @attribute XmlElementAttribute("testStep", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public TestStepData get_Step();

/** property */
public void set_Step(TestStepData value);
JScript
public function get Step() : TestStepData

public function set Step(value : TestStepData);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


TestLog Property

TestStepRun.TestLog Property
[image]

Gets or sets the test log.

Namespace: Gallio.Runner.Reports
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("testLog", Namespace := "http://www.gallio.org/", IsNullable := False)>
Public Property TestLog As StructuredTestLog
C#
[XmlElementAttribute("testLog", Namespace = "http://www.gallio.org/", IsNullable = False)]
public StructuredTestLog TestLog { get; set; }
C++
[XmlElementAttribute(L"testLog", Namespace = L"http://www.gallio.org/", IsNullable = False)]
public property StructuredTestLog TestLog sealed {
StructuredTestLog get();
void set(StructuredTestLog value);
}
J#
/** @attribute XmlElementAttribute("testLog", Namespace = "http://www.gallio.org/", IsNullable = False) */
/** property */
public StructuredTestLog get_TestLog();

/** property */
public void set_TestLog(StructuredTestLog value);
JScript
public function get TestLog() : StructuredTestLog

public function set TestLog(value : StructuredTestLog);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

TestStepRun Class
Gallio.Runner.Reports Namespace


Gallio.Runtime

Gallio.Runtime Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | CorrelatedExceptionEventArgs | Describes an exception that is to be reported. This class cannot be inherited.
Public class | GallioSectionHandler | A configuration section handler for Gallio used to register Gallio components in applications and in plugins.
Public class | InstallationConfiguration | Describes the configuration of a Gallio installation.
Public class | ProcessTypeDetection | Detects the kind of process that is being used. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | RuntimeAccessor | Provides functions for obtaining runtime services. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | RuntimeBootstrap | Initializes and shuts down the runtime. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | RuntimeDetection | Provides functions for detecting CLR runtime parameters.
Public class | RuntimeException | An exception that expresses a problem performing a runtime service.
Public class | RuntimeRegisteredComponentResolver | A default implementation of IRegisteredComponentResolver based on IRuntime.
Public class | RuntimeSetup | Provides configuration parameters for setting up the RuntimeAccessor. This class cannot be inherited.
Public class UnhandledExceptionPolicy

This class provides a mechanism for reporting unhandled exceptions when the infrastructure is otherwise unable to deal with them locally.

The methods of this class should be considered as the last resort for reporting failures that might otherwise cause the system to crash.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

Interface | Description
Public interface | IRegisteredComponent | A registered component is a component that has a name and description.
Public interface | IRegisteredComponentResolver | A registered service resolver looks up IRegisteredComponent components by name.
Public interface IRuntime

The runtime is instantiated within the test runner to provide a suitable hosting environment for test enumeration and execution.

The runtime provides services to support the Gallio test automation platform. New services are typically registered by adding them to plugin configuration files.

Enumerations

 | Enumeration | Description
Public enumeration | ProcessType | Describes the kind of process that is executing.
Public enumeration | RuntimeVersion | Specifies the version of the runtime.


CorrelatedExceptionEventArgs Class

CorrelatedExceptionEventArgs Class
See Also Example Members
[image]

Describes an exception that is to be reported. This class cannot be inherited.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CorrelatedExceptionEventArgs
Inherits EventArgs
C#
public sealed class CorrelatedExceptionEventArgs : EventArgs
C++
ref class CorrelatedExceptionEventArgs sealed : EventArgs
J#
public final class CorrelatedExceptionEventArgs extends EventArgs
JScript
public final class CorrelatedExceptionEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runtime.CorrelatedExceptionEventArgs

See Also

CorrelatedExceptionEventArgs Members
Gallio.Runtime Namespace


CorrelatedExceptionEventArgs Members

CorrelatedExceptionEventArgs Members
See Also Example Constructors Properties Methods
[image]

Describes an exception that is to be reported. This class cannot be inherited.

The following tables list the members exposed by CorrelatedExceptionEventArgs.

Public Constructors

 | Name | Description
Public method | CorrelatedExceptionEventArgs | Creates event arguments for reporting an exception.
Top

Public Properties

 | Name | Description
Public property | Exception | Gets the exception that occurred.
Public property | IsRecursive | Returns true if a second exception occurred while attempting to report a previous exception on the same thread.
Public property | Message | Gets the message associated with the exception.
Public property | ReporterStackTrace | Gets the stack trace of the code that called to report the exception or null if not available.
Top

Public Methods

 | Name | Description
Public method | AddCorrelationMessage | Adds a message that serves to describe the context in which the exception occurred. The Message will be augmented with these details.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDescription | Formats a description of the exception to a string like: "Message\nException\nReported by: ReporterStackTrace".
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


CorrelatedExceptionEventArgs Constructor

CorrelatedExceptionEventArgs Constructor
[image]

Creates event arguments for reporting an exception.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal exception As Exception, _
ByVal reporterStackTrace As String, _
ByVal isRecursive As Boolean _
)
C#
public CorrelatedExceptionEventArgs(
string message,
Exception exception,
string reporterStackTrace,
bool isRecursive
)
C++
public:
CorrelatedExceptionEventArgs(
String message,
Exception exception,
String reporterStackTrace,
bool isRecursive
) sealed
J#
public CorrelatedExceptionEventArgs(
string message,
Exception exception,
string reporterStackTrace,
bool isRecursive
)
JScript
public function CorrelatedExceptionEventArgs(
message : String,
exception : Exception,
reporterStackTrace : String,
isRecursive : bool
)

Parameters

message
The message associated with the exception
exception
The exception that occurred
reporterStackTrace
The stack trace of the code that called to report the exception, or null if not available
isRecursive
True if a second exception occurred while attempting to report a previous unhandled exception on the same thread

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message or exception is null

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


Properties

CorrelatedExceptionEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Exception | Gets the exception that occurred.
Public property | IsRecursive | Returns true if a second exception occurred while attempting to report a previous exception on the same thread.
Public property | Message | Gets the message associated with the exception.
Public property | ReporterStackTrace | Gets the stack trace of the code that called to report the exception or null if not available.
Top

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


Exception Property

CorrelatedExceptionEventArgs.Exception Property
[image]

Gets the exception that occurred.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception { get; }
C++
public property Exception Exception sealed {
Exception get();
}
J#
/** property */
public Exception get_Exception();
JScript
public function get Exception() : Exception

Remarks

The event handler should use care when processing the exception object as it may have been obtained from an untrusted source.

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


IsRecursive Property

CorrelatedExceptionEventArgs.IsRecursive Property
[image]

Returns true if a second exception occurred while attempting to report a previous exception on the same thread.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRecursive As Boolean
C#
public bool IsRecursive { get; }
C++
public property bool IsRecursive sealed {
bool get();
}
J#
/** property */
public bool get_IsRecursive();
JScript
public function get IsRecursive() : bool

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


Message Property

CorrelatedExceptionEventArgs.Message Property
[image]

Gets the message associated with the exception.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
C++
public property string Message sealed {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


ReporterStackTrace Property

CorrelatedExceptionEventArgs.ReporterStackTrace Property
[image]

Gets the stack trace of the code that called to report the exception or null if not available.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReporterStackTrace As String
C#
public string ReporterStackTrace { get; }
C++
public property string ReporterStackTrace sealed {
String get();
}
J#
/** property */
public string get_ReporterStackTrace();
JScript
public function get ReporterStackTrace() : String

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


Methods

CorrelatedExceptionEventArgs Methods
[image]

Public Methods

 | Name | Description
Public method | AddCorrelationMessage | Adds a message that serves to describe the context in which the exception occurred. The Message will be augmented with these details.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDescription | Formats a description of the exception to a string like: "Message\nException\nReported by: ReporterStackTrace".
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


AddCorrelationMessage Method

CorrelatedExceptionEventArgs.AddCorrelationMessage Method
[image]

Adds a message that serves to describe the context in which the exception occurred. The Message will be augmented with these details.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddCorrelationMessage( _
ByVal correlationMessage As String _
)
C#
public void AddCorrelationMessage(
string correlationMessage
)
C++
public:
void AddCorrelationMessage(
String correlationMessage
) sealed
J#
public void AddCorrelationMessage(
string correlationMessage
)
JScript
public function AddCorrelationMessage(
correlationMessage : String
)

Parameters

correlationMessage
The correlation message to append

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if correlationMessage is null

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace
CorrelateUnhandledException


GetDescription Method

CorrelatedExceptionEventArgs.GetDescription Method
[image]

Formats a description of the exception to a string like: "Message\nException\nReported by: ReporterStackTrace".

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDescription() As String
C#
public string GetDescription()
C++
public:
String GetDescription() sealed
J#
public string GetDescription()
JScript
public function GetDescription() : String

Return Value

The formatted string

See Also

CorrelatedExceptionEventArgs Class
Gallio.Runtime Namespace


GallioSectionHandler Class

GallioSectionHandler Class
See Also Example Members
[image]

A configuration section handler for Gallio used to register Gallio components in applications and in plugins.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class GallioSectionHandler
Implements IConfigurationSectionHandler
C#
public class GallioSectionHandler : IConfigurationSectionHandler
C++
ref class GallioSectionHandler : IConfigurationSectionHandler
J#
public class GallioSectionHandler implements IConfigurationSectionHandler
JScript
public class GallioSectionHandler extends IConfigurationSectionHandler

Inheritance Hierarchy

System.Object
Gallio.Runtime.GallioSectionHandler

See Also

GallioSectionHandler Members
Gallio.Runtime Namespace


GallioSectionHandler Members

GallioSectionHandler Members
See Also Example Constructors Fields Methods
[image]

A configuration section handler for Gallio used to register Gallio components in applications and in plugins.

The following tables list the members exposed by GallioSectionHandler.

Public Constructors

 | Name | Description
Public method | GallioSectionHandler | Initializes a new instance of the GallioSectionHandler class.
Top

Public Fields

Name | Description
SectionName | The name of the Gallio section: "gallio". This field is constant and read-only.
Top

Public Methods

 | Name | Description
Public method | Create | Creates a configuration section handler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GallioSectionHandler Class
Gallio.Runtime Namespace


GallioSectionHandler Constructor

GallioSectionHandler Constructor
[image]

Initializes a new instance of the GallioSectionHandler class.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GallioSectionHandler()
C++
public:
GallioSectionHandler() sealed
J#
public GallioSectionHandler()
JScript
public function GallioSectionHandler()

See Also

GallioSectionHandler Class
Gallio.Runtime Namespace


Fields

GallioSectionHandler Fields
[image]

Public Fields

Name | Description
SectionName | The name of the Gallio section: "gallio". This field is constant and read-only.
Top

See Also

GallioSectionHandler Class
Gallio.Runtime Namespace


SectionName Field

GallioSectionHandler.SectionName Field
[image]

The name of the Gallio section: "gallio". This field is constant and read-only.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const SectionName As String = "gallio"
C#
public const string SectionName = "gallio";
C++
public:
const String SectionName = L"gallio";
J#
public const string SectionName = "gallio"
JScript
public const SectionName : String = "gallio";

See Also

GallioSectionHandler Class
Gallio.Runtime Namespace


Methods

GallioSectionHandler Methods
[image]

Public Methods

 | Name | Description
Public method | Create | Creates a configuration section handler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

GallioSectionHandler Class
Gallio.Runtime Namespace


Create Method

GallioSectionHandler.Create Method
[image]

Creates a configuration section handler.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Create( _
ByVal parent As Object, _
ByVal configContext As Object, _
ByVal section As XmlNode _
) As Object _
Implements IConfigurationSectionHandler.Create
C#
public object Create(
object parent,
object configContext,
XmlNode section
)
C++
public:
Object Create(
Object parent,
Object configContext,
XmlNode section
) sealed
J#
public object Create(
object parent,
object configContext,
XmlNode section
)
JScript
public function Create(
parent : Object,
configContext : Object,
section : XmlNode
) : Object

Parameters

parent
Parent object.
configContext
Configuration context object.
section
Section XML node.

Return Value

The created section handler object.

Implements

IConfigurationSectionHandler.Create

See Also

GallioSectionHandler Class
Gallio.Runtime Namespace


InstallationConfiguration Class

InstallationConfiguration Class
See Also Example Members
[image]

Describes the configuration of a Gallio installation.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class InstallationConfiguration
C#
[SerializableAttribute]
public class InstallationConfiguration
C++
[SerializableAttribute]
ref class InstallationConfiguration
J#
/** @attribute SerializableAttribute() */
public class InstallationConfiguration
JScript
public
SerializableAttribute
class InstallationConfiguration

Inheritance Hierarchy

System.Object
Gallio.Runtime.InstallationConfiguration

See Also

InstallationConfiguration Members
Gallio.Runtime Namespace


InstallationConfiguration Members

InstallationConfiguration Members
See Also Example Constructors Properties Methods
[image]

Describes the configuration of a Gallio installation.

The following tables list the members exposed by InstallationConfiguration.

Public Constructors

 | Name | Description
Public method | InstallationConfiguration | Initializes a new instance of the InstallationConfiguration class.
Top

Public Properties

Name | Description
Public property | AdditionalPluginDirectories | Gets the list of additional plugin directories.
Public property DevelopmentRuntimePath

Gets or sets the runtime path of the development copy of Gallio to use for running tests, or null if not applicable.

To facilitate development of Gallio, it is possible to redirect an out-of-process or isolated app-domain test runner to a different version of Gallio. That way a standard installation of Gallio can be running in the IDE and then delegating to the development version when it actually needs to run tests.

Of course, this mechanism can only hook into certain APIs like the test runner API. Consequently it may still be necessary to reinstall Gallio and/or restart the IDE if the objective is to test changes made to the IDE add-ins themselves.

Public property | InstallationFolder | Get or sets the folder where Gallio was installed, or null if Gallio is not installed.
Public property | InstalledVersion | Get or sets the version that was installed, or null if Gallio is not installed.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDevelopmentRuntimePathValid | Returns true if DevelopmentRuntimePath is set and refers to a directory that exists.
 | LoadFromRegistry | Loads the configuration from the registry.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


InstallationConfiguration Constructor

InstallationConfiguration Constructor
[image]

Initializes a new instance of the InstallationConfiguration class.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public InstallationConfiguration()
C++
public:
InstallationConfiguration() sealed
J#
public InstallationConfiguration()
JScript
public function InstallationConfiguration()

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


Properties

InstallationConfiguration Properties
[image]

Public Properties

Name | Description
Public property | AdditionalPluginDirectories | Gets the list of additional plugin directories.
Public property DevelopmentRuntimePath

Gets or sets the runtime path of the development copy of Gallio to use for running tests, or null if not applicable.

To facilitate development of Gallio, it is possible to redirect an out-of-process or isolated app-domain test runner to a different version of Gallio. That way a standard installation of Gallio can be running in the IDE and then delegating to the development version when it actually needs to run tests.

Of course, this mechanism can only hook into certain APIs like the test runner API. Consequently it may still be necessary to reinstall Gallio and/or restart the IDE if the objective is to test changes made to the IDE add-ins themselves.

Public property | InstallationFolder | Get or sets the folder where Gallio was installed, or null if Gallio is not installed.
Public property | InstalledVersion | Get or sets the version that was installed, or null if Gallio is not installed.
Top

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


AdditionalPluginDirectories Property

InstallationConfiguration.AdditionalPluginDirectories Property
See Also Example
[image]

Gets the list of additional plugin directories.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AdditionalPluginDirectories As IList(Of String)
C#
public IList<string> AdditionalPluginDirectories { get; }
C++
public property IList<string> AdditionalPluginDirectories sealed {
IList<string> get();
}
J#
/** property */
public IList<string> get_AdditionalPluginDirectories();
JScript
public function get AdditionalPluginDirectories() : IList<string>

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


DevelopmentRuntimePath Property

InstallationConfiguration.DevelopmentRuntimePath Property
[image]

Gets or sets the runtime path of the development copy of Gallio to use for running tests, or null if not applicable.

To facilitate development of Gallio, it is possible to redirect an out-of-process or isolated app-domain test runner to a different version of Gallio. That way a standard installation of Gallio can be running in the IDE and then delegating to the development version when it actually needs to run tests.

Of course, this mechanism can only hook into certain APIs like the test runner API. Consequently it may still be necessary to reinstall Gallio and/or restart the IDE if the objective is to test changes made to the IDE add-ins themselves.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property DevelopmentRuntimePath As String
C#
public string DevelopmentRuntimePath { get; set; }
C++
public property string DevelopmentRuntimePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DevelopmentRuntimePath();

/** property */
public void set_DevelopmentRuntimePath(string value);
JScript
public function get DevelopmentRuntimePath() : String

public function set DevelopmentRuntimePath(value : String);

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


InstallationFolder Property

InstallationConfiguration.InstallationFolder Property
[image]

Get or sets the folder where Gallio was installed, or null if Gallio is not installed.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property InstallationFolder As String
C#
public string InstallationFolder { get; set; }
C++
public property string InstallationFolder sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_InstallationFolder();

/** property */
public void set_InstallationFolder(string value);
JScript
public function get InstallationFolder() : String

public function set InstallationFolder(value : String);

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


InstalledVersion Property

InstallationConfiguration.InstalledVersion Property
[image]

Get or sets the version that was installed, or null if Gallio is not installed.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property InstalledVersion As String
C#
public string InstalledVersion { get; set; }
C++
public property string InstalledVersion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_InstalledVersion();

/** property */
public void set_InstalledVersion(string value);
JScript
public function get InstalledVersion() : String

public function set InstalledVersion(value : String);

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


Methods

InstallationConfiguration Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDevelopmentRuntimePathValid | Returns true if DevelopmentRuntimePath is set and refers to a directory that exists.
 | LoadFromRegistry | Loads the configuration from the registry.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


IsDevelopmentRuntimePathValid Method

InstallationConfiguration.IsDevelopmentRuntimePathValid Method
See Also Example
[image]

Returns true if DevelopmentRuntimePath is set and refers to a directory that exists.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsDevelopmentRuntimePathValid() As Boolean
C#
public bool IsDevelopmentRuntimePathValid()
C++
public:
bool IsDevelopmentRuntimePathValid() sealed
J#
public bool IsDevelopmentRuntimePathValid()
JScript
public function IsDevelopmentRuntimePathValid() : bool

Return Value

True if the development runtime path is valid

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


LoadFromRegistry Method

InstallationConfiguration.LoadFromRegistry Method
[image]

Loads the configuration from the registry.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromRegistry() As InstallationConfiguration
C#
public static InstallationConfiguration LoadFromRegistry()
C++
public:
static InstallationConfiguration LoadFromRegistry()
J#
public static InstallationConfiguration LoadFromRegistry()
JScript
public static function LoadFromRegistry() : InstallationConfiguration

Return Value

The installed configuration

See Also

InstallationConfiguration Class
Gallio.Runtime Namespace


IRegisteredComponent Interface

IRegisteredComponent Interface
See Also Example Members
[image]

A registered component is a component that has a name and description.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRegisteredComponent
C#
public interface IRegisteredComponent
C++
interface class IRegisteredComponent
J#
public interface IRegisteredComponent
JScript
public interface IRegisteredComponent

Types that implement IRegisteredComponent

Type | Description
Gallio.Reports.BaseReportFormatter | Abstract base class for report formatters. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Runner.DefaultTestRunnerFactory | A ITestRunnerFactory for DefaultTestRunner using different implementations of ITestDriver.

See Also

IRegisteredComponent Members
Gallio.Runtime Namespace


IRegisteredComponent Members

IRegisteredComponent Members
See Also Example Properties
[image]

A registered component is a component that has a name and description.

The following tables list the members exposed by IRegisteredComponent.

Public Properties

 | Name | Description
Public property | Description | Gets the human-readable description of the component.
Public property | Name | Gets the unique name of the component.
Top

See Also

IRegisteredComponent Interface
Gallio.Runtime Namespace


Properties

IRegisteredComponent Properties
[image]

Public Properties

 | Name | Description
Public property | Description | Gets the human-readable description of the component.
Public property | Name | Gets the unique name of the component.
Top

See Also

IRegisteredComponent Interface
Gallio.Runtime Namespace


Description Property

IRegisteredComponent.Description Property
[image]

Gets the human-readable description of the component.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Description As String
C#
string Description { get; }
C++
property string Description abstract {
String get();
}
J#
/** property */
public string get_Description();
JScript
public function get Description() : String

See Also

IRegisteredComponent Interface
Gallio.Runtime Namespace


Name Property

IRegisteredComponent.Name Property
[image]

Gets the unique name of the component.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
C#
string Name { get; }
C++
property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

IRegisteredComponent Interface
Gallio.Runtime Namespace


IRegisteredComponentResolver Generic Interface

IRegisteredComponentResolver Generic Interface
See Also Example Members
[image]

A registered service resolver looks up IRegisteredComponent components by name.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRegisteredComponentResolver(Of T As {IRegisteredComponent, Class})
C#
public interface IRegisteredComponentResolver<T> where T : IRegisteredComponent, class
C++
interface class IRegisteredComponentResolver<T> where T : IRegisteredComponent, class
J#
public interface IRegisteredComponentResolver<T>
JScript
JScript does not support generic types and methods.

Types that implement IRegisteredComponentResolver<T>

Type | Description
Gallio.Runtime.RuntimeRegisteredComponentResolver<T> | A default implementation of IRegisteredComponentResolver based on IRuntime.

See Also

IRegisteredComponentResolver<T> Members
Gallio.Runtime Namespace


IRegisteredComponentResolver<T> Members

IRegisteredComponentResolver Members
See Also Example Methods
[image]

A registered service resolver looks up IRegisteredComponent components by name.

The following tables list the members exposed by IRegisteredComponentResolver<T>.

Public Methods

 | Name | Description
Public method | GetNames | Gets the names of all registered components.
Public method | Resolve | Resolves a registered component by name.
Top

See Also

IRegisteredComponentResolver<T> Interface
Gallio.Runtime Namespace


Methods

IRegisteredComponentResolver Methods
[image]

Public Methods

 | Name | Description
Public method | GetNames | Gets the names of all registered components.
Public method | Resolve | Resolves a registered component by name.
Top

See Also

IRegisteredComponentResolver<T> Interface
Gallio.Runtime Namespace


GetNames Method

IRegisteredComponentResolver.GetNames Method
[image]

Gets the names of all registered components.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetNames() As IList(Of String)
C#
IList<string> GetNames()
C++
IList<string> GetNames() abstract
J#
IList<string> GetNames()
JScript
JScript does not support generic types and methods.

Return Value

The list of registered component names

See Also

IRegisteredComponentResolver<T> Interface
Gallio.Runtime Namespace


Resolve Method

IRegisteredComponentResolver.Resolve Method
[image]

Resolves a registered component by name.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal name As String _
)
C#
T Resolve(
string name
)
C++
T Resolve(
String name
) abstract
J#
T Resolve(
string name
)
JScript
JScript does not support generic types and methods.

Parameters

name
The name of the registered component, matched case-insensitively

Return Value

The test runner factory, or null if none exist with the specified name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

IRegisteredComponentResolver<T> Interface
Gallio.Runtime Namespace


IRuntime Interface

IRuntime Interface
See Also Example Members
[image]

The runtime is instantiated within the test runner to provide a suitable hosting environment for test enumeration and execution.

The runtime provides services to support the Gallio test automation platform. New services are typically registered by adding them to plugin configuration files.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRuntime
Implements IDisposable
C#
public interface IRuntime : IDisposable
C++
interface class IRuntime : IDisposable
J#
public interface IRuntime implements IDisposable
JScript
public interface IRuntime extends IDisposable

Types that implement IRuntime

Type | Description
Gallio.Runtime.Windsor.WindsorRuntime | Default implementation of IRuntime based on the Castle inversion of control microkernel.

See Also

IRuntime Members
Gallio.Runtime Namespace


IRuntime Members

IRuntime Members
See Also Example Methods
[image]

The runtime is instantiated within the test runner to provide a suitable hosting environment for test enumeration and execution.

The runtime provides services to support the Gallio test automation platform. New services are typically registered by adding them to plugin configuration files.

The following tables list the members exposed by IRuntime.

Public Methods

 | Name | Description
Public method | GetPluginAssemblyPaths | Gets the paths and assembly names of all plugin assemblies.
Public method | GetRuntimeSetup | Gets a deep copy of the runtime setup used to configure this runtime.
Public method | Initialize | Initializes the runtime.
Public method | MapUriToLocalPath | Maps a Uri to a local path.
Public method | Resolve | Overloaded. Resolves a reference to a component with the given id.
Public method | ResolveAll | Resolves references to all components that implement the specified service.
Top

See Also

IRuntime Interface
Gallio.Runtime Namespace


Methods

IRuntime Methods
[image]

Public Methods

 | Name | Description
Public method | GetPluginAssemblyPaths | Gets the paths and assembly names of all plugin assemblies.
Public method | GetRuntimeSetup | Gets a deep copy of the runtime setup used to configure this runtime.
Public method | Initialize | Initializes the runtime.
Public method | MapUriToLocalPath | Maps a Uri to a local path.
Public method | Resolve | Overloaded. Resolves a reference to a component with the given id.
Public method | ResolveAll | Resolves references to all components that implement the specified service.
Top

See Also

IRuntime Interface
Gallio.Runtime Namespace


GetPluginAssemblyPaths Method

IRuntime.GetPluginAssemblyPaths Method
[image]

Gets the paths and assembly names of all plugin assemblies.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetPluginAssemblyPaths() As IDictionary(Of String, AssemblyName)
C#
IDictionary<string, AssemblyName> GetPluginAssemblyPaths()
C++
IDictionary<string, AssemblyName> GetPluginAssemblyPaths() abstract
J#
IDictionary<string, AssemblyName> GetPluginAssemblyPaths()
JScript
function GetPluginAssemblyPaths() : IDictionary<string, AssemblyName>

Return Value

The paths

See Also

IRuntime Interface
Gallio.Runtime Namespace


GetRuntimeSetup Method

IRuntime.GetRuntimeSetup Method
[image]

Gets a deep copy of the runtime setup used to configure this runtime.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetRuntimeSetup() As RuntimeSetup
C#
RuntimeSetup GetRuntimeSetup()
C++
RuntimeSetup GetRuntimeSetup() abstract
J#
RuntimeSetup GetRuntimeSetup()
JScript
function GetRuntimeSetup() : RuntimeSetup

Return Value

The runtime setup

See Also

IRuntime Interface
Gallio.Runtime Namespace


Initialize Method

IRuntime.Initialize Method
[image]

Initializes the runtime.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize( _
ByVal logger As ILogger _
)
C#
void Initialize(
ILogger logger
)
C++
void Initialize(
ILogger logger
) abstract
J#
void Initialize(
ILogger logger
)
JScript
function Initialize(
logger : ILogger
)

Parameters

logger
The runtime logging service

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logger is null
RuntimeException | Thrown if the runtime could not be initialized

See Also

IRuntime Interface
Gallio.Runtime Namespace


MapUriToLocalPath Method

IRuntime.MapUriToLocalPath Method
[image]

Maps a Uri to a local path.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function MapUriToLocalPath( _
ByVal uri As Uri _
) As String
C#
string MapUriToLocalPath(
Uri uri
)
C++
String MapUriToLocalPath(
Uri uri
) abstract
J#
string MapUriToLocalPath(
Uri uri
)
JScript
function MapUriToLocalPath(
uri : Uri
) : String

Parameters

uri
The uri to map

Return Value

The local path

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if uri cannot be mapped to a local path

Remarks

Recognizes plugin-relative paths of the form "plugin://Some.Plugin.Name/foo.txt" and Uri's in the "file" scheme.

See Also

IRuntime Interface
Gallio.Runtime Namespace


Resolve Method

IRuntime.Resolve Method

Resolves a reference to a component with the given id.

Overload List

 | Name | Description
Public method | Resolve (String) | Resolves a reference to a component with the given id.
Public method | Resolve (Type) | Resolves a reference to a component that implements the specified service.
Public method | Resolve | Resolves a reference to a component that implements the specified service.

See Also

IRuntime Interface
Gallio.Runtime Namespace


Resolve Method (String)

IRuntime.Resolve Method (String)
See Also Example
[image]

Resolves a reference to a component with the given id.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Resolve( _
ByVal componentId As String _
) As Object
C#
public abstract object Resolve(
string componentId
)
C++
public:
Object Resolve(
String componentId
) abstract
J#
public abstract object Resolve(
string componentId
)
JScript
public abstract function Resolve(
componentId : String
) : Object

Parameters

componentId
The componentId

Return Value

A component with the specified id

Exceptions

Exception Type | Condition
RuntimeException | Thrown if the component could not be resolved

See Also

IRuntime Interface
Gallio.Runtime Namespace
IRuntime.Resolve Overload List


Resolve Method (Type)

IRuntime.Resolve Method (Type)
See Also Example
[image]

Resolves a reference to a component that implements the specified service.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Resolve( _
ByVal service As Type _
) As Object
C#
public abstract object Resolve(
Type service
)
C++
public:
Object Resolve(
Type service
) abstract
J#
public abstract object Resolve(
Type service
)
JScript
public abstract function Resolve(
service : Type
) : Object

Parameters

service
The service type

Return Value

A component that implements the service

Exceptions

Exception Type | Condition
RuntimeException | Thrown if the service could not be resolved

See Also

IRuntime Interface
Gallio.Runtime Namespace
IRuntime.Resolve Overload List


Resolve Generic Method ()

IRuntime.Resolve Generic Method ()
See Also Example
[image]

Resolves a reference to a component that implements the specified service.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Resolve(Of T)()
C#
public abstract T Resolve<T>()
C++
public:
T Resolve<T>() abstract
J#
public abstract T Resolve<T>()
JScript
JScript does not support generic types and methods.

Type Parameters

T
The service type

Return Value

A component that implements the service

Exceptions

Exception Type | Condition
RuntimeException | Thrown if the service could not be resolved

See Also

IRuntime Interface
Gallio.Runtime Namespace
IRuntime.Resolve Overload List


ResolveAll Generic Method

IRuntime.ResolveAll Generic Method
[image]

Resolves references to all components that implement the specified service.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function ResolveAll(Of T)()
C#
T[] ResolveAll<T>()
C++
array<T>^ ResolveAll<T>() abstract
J#
T[] ResolveAll<T>()
JScript
JScript does not support generic types and methods.

Type Parameters

T
The service type

Return Value

An array of components that implement the service

Exceptions

Exception Type | Condition
RuntimeException | Thrown if the service could not be resolved

See Also

IRuntime Interface
Gallio.Runtime Namespace


ProcessType Enumeration

ProcessType Enumeration
[image]

Describes the kind of process that is executing.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum ProcessType
C#
public enum ProcessType
C++
public enum class ProcessType
J#
public enum ProcessType
JScript
public enum ProcessType

Members

Member Name | Description
Console | The process is running in the console.
Interactive | The process is running interactively.
Service | The process is running as a Windows service.

See Also

Gallio.Runtime Namespace


ProcessTypeDetection Class

ProcessTypeDetection Class
See Also Example Members
[image]

Detects the kind of process that is being used. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ProcessTypeDetection
C#
public static class ProcessTypeDetection
C++
ref class ProcessTypeDetection abstract sealed
J#
public final class ProcessTypeDetection
JScript
public class ProcessTypeDetection

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProcessTypeDetection

See Also

ProcessTypeDetection Members
Gallio.Runtime Namespace


ProcessTypeDetection Members

ProcessTypeDetection Members
See Also Example Properties
[image]

Detects the kind of process that is being used. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ProcessTypeDetection.

Public Properties

Name | Description
ProcessType | Gets the process type of the current process.
Top

See Also

ProcessTypeDetection Class
Gallio.Runtime Namespace


Properties

ProcessTypeDetection Properties
[image]

Public Properties

Name | Description
ProcessType | Gets the process type of the current process.
Top

See Also

ProcessTypeDetection Class
Gallio.Runtime Namespace


ProcessType Property

ProcessTypeDetection.ProcessType Property
[image]

Gets the process type of the current process.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProcessType As ProcessType
C#
public static ProcessType ProcessType { get; }
C++
public static property ProcessType ProcessType {
ProcessType get();
}
J#
/** property */
public ProcessType get_ProcessType();
JScript
public function get ProcessType() : ProcessType

See Also

ProcessTypeDetection Class
Gallio.Runtime Namespace


RuntimeAccessor Class

RuntimeAccessor Class
See Also Example Members
[image]

Provides functions for obtaining runtime services. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module RuntimeAccessor
C#
public static class RuntimeAccessor
C++
ref class RuntimeAccessor abstract sealed
J#
public final class RuntimeAccessor
JScript
public class RuntimeAccessor

Inheritance Hierarchy

System.Object
Gallio.Runtime.RuntimeAccessor

See Also

RuntimeAccessor Members
Gallio.Runtime Namespace


RuntimeAccessor Members

RuntimeAccessor Members
See Also Example Properties Methods Events
[image]

Provides functions for obtaining runtime services. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by RuntimeAccessor.

Public Properties

Name | Description
Instance | Gets the runtime instance.
IsInitialized | Returns true if the runtime has been initialized.
Logger | Gets the runtime's logger, or a NullLogger if the runtime is not initialized.
RuntimePath | Gets the path of the Gallio runtime components.
Top

Public Methods

Name | Description
SetRuntime | Sets the runtime instance. This method should only be used by applications that host Gallio and not generally by client code.
Top

Public Events

Name | Description
InstanceChanged | The event dispatched when the value of the current runtime Instance changes.
Top

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


Properties

RuntimeAccessor Properties
[image]

Public Properties

Name | Description
Instance | Gets the runtime instance.
IsInitialized | Returns true if the runtime has been initialized.
Logger | Gets the runtime's logger, or a NullLogger if the runtime is not initialized.
RuntimePath | Gets the path of the Gallio runtime components.
Top

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


Instance Property

RuntimeAccessor.Instance Property
[image]

Gets the runtime instance.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As IRuntime
C#
public static IRuntime Instance { get; }
C++
public static property IRuntime Instance {
IRuntime get();
}
J#
/** property */
public IRuntime get_Instance();
JScript
public function get Instance() : IRuntime

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the runtime has not been initialized

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


IsInitialized Property

RuntimeAccessor.IsInitialized Property
[image]

Returns true if the runtime has been initialized.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsInitialized As Boolean
C#
public static bool IsInitialized { get; }
C++
public static property bool IsInitialized {
bool get();
}
J#
/** property */
public bool get_IsInitialized();
JScript
public function get IsInitialized() : bool

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


Logger Property

RuntimeAccessor.Logger Property
[image]

Gets the runtime's logger, or a NullLogger if the runtime is not initialized.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Logger As ILogger
C#
public static ILogger Logger { get; }
C++
public static property ILogger Logger {
ILogger get();
}
J#
/** property */
public ILogger get_Logger();
JScript
public function get Logger() : ILogger

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


RuntimePath Property

RuntimeAccessor.RuntimePath Property
[image]

Gets the path of the Gallio runtime components.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RuntimePath As String
C#
public static string RuntimePath { get; }
C++
public static property string RuntimePath {
String get();
}
J#
/** property */
public string get_RuntimePath();
JScript
public function get RuntimePath() : String

Property Value

The runtime path

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


Methods

RuntimeAccessor Methods
[image]

Public Methods

Name | Description
SetRuntime | Sets the runtime instance. This method should only be used by applications that host Gallio and not generally by client code.
Top

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


SetRuntime Method

RuntimeAccessor.SetRuntime Method
[image]

Sets the runtime instance.

This method should only be used by applications that host Gallio and not generally by client code.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetRuntime( _
ByVal runtime As IRuntime _
)
C#
public static void SetRuntime(
IRuntime runtime
)
C++
public:
static void SetRuntime(
IRuntime runtime
)
J#
public static void SetRuntime(
IRuntime runtime
)
JScript
public static function SetRuntime(
runtime : IRuntime
)

Parameters

runtime
The runtime instance, or null if none

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


Events

RuntimeAccessor Events
[image]

Public Events

Name | Description
InstanceChanged | The event dispatched when the value of the current runtime Instance changes.
Top

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


InstanceChanged Event

RuntimeAccessor.InstanceChanged Event
[image]

The event dispatched when the value of the current runtime Instance changes.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Event InstanceChanged As EventHandler
C#
public static event EventHandler InstanceChanged
C++
public:
static event EventHandler InstanceChanged {
void add(EventHandler value);
void remove(EventHandler value);
}
J#
/** event */
public static void add_InstanceChanged(EventHandler value);

/** event */
public static void remove_InstanceChanged(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

RuntimeAccessor Class
Gallio.Runtime Namespace


RuntimeBootstrap Class

RuntimeBootstrap Class
See Also Example Members
[image]

Initializes and shuts down the runtime. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module RuntimeBootstrap
C#
public static class RuntimeBootstrap
C++
ref class RuntimeBootstrap abstract sealed
J#
public final class RuntimeBootstrap
JScript
public class RuntimeBootstrap

Inheritance Hierarchy

System.Object
Gallio.Runtime.RuntimeBootstrap

See Also

RuntimeBootstrap Members
Gallio.Runtime Namespace


RuntimeBootstrap Members

RuntimeBootstrap Members
See Also Example Methods
[image]

Initializes and shuts down the runtime. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by RuntimeBootstrap.

Public Methods

Name | Description
Initialize | Initializes the runtime. Loads plugins and initalizes the runtime component model. The specifics of the system can be configured by editing the appropriate *.plugin files to register new components and facilities as required.
Shutdown | Shuts down the runtime if it is currently initialized. Does nothing if the runtime has not been initialized.
Top

See Also

RuntimeBootstrap Class
Gallio.Runtime Namespace


Methods

RuntimeBootstrap Methods
[image]

Public Methods

Name | Description
Initialize | Initializes the runtime. Loads plugins and initalizes the runtime component model. The specifics of the system can be configured by editing the appropriate *.plugin files to register new components and facilities as required.
Shutdown | Shuts down the runtime if it is currently initialized. Does nothing if the runtime has not been initialized.
Top

See Also

RuntimeBootstrap Class
Gallio.Runtime Namespace


Initialize Method

RuntimeBootstrap.Initialize Method
[image]

Initializes the runtime.

Loads plugins and initalizes the runtime component model. The specifics of the system can be configured by editing the appropriate *.plugin files to register new components and facilities as required.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Initialize( _
ByVal setup As RuntimeSetup, _
ByVal logger As ILogger _
) As IDisposable
C#
public static IDisposable Initialize(
RuntimeSetup setup,
ILogger logger
)
C++
public:
static IDisposable Initialize(
RuntimeSetup setup,
ILogger logger
)
J#
public static IDisposable Initialize(
RuntimeSetup setup,
ILogger logger
)
JScript
public static function Initialize(
setup : RuntimeSetup,
logger : ILogger
) : IDisposable

Parameters

setup
The runtime setup parameters
logger
The runtime logging service

Return Value

An object that when disposed automatically calls Shutdown. This is particularly useful in combination with the C# "using" statement or its equivalent.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if setup or logger is null
InvalidOperationException | Thrown if the runtime has already been initialized

See Also

RuntimeBootstrap Class
Gallio.Runtime Namespace


Shutdown Method

RuntimeBootstrap.Shutdown Method
[image]

Shuts down the runtime if it is currently initialized. Does nothing if the runtime has not been initialized.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Shutdown()
C#
public static void Shutdown()
C++
public:
static void Shutdown()
J#
public static void Shutdown()
JScript
public static function Shutdown()

See Also

RuntimeBootstrap Class
Gallio.Runtime Namespace


RuntimeDetection Class

RuntimeDetection Class
See Also Example Members
[image]

Provides functions for detecting CLR runtime parameters.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RuntimeDetection
C#
public class RuntimeDetection
C++
ref class RuntimeDetection
J#
public class RuntimeDetection
JScript
public class RuntimeDetection

Inheritance Hierarchy

System.Object
Gallio.Runtime.RuntimeDetection

See Also

RuntimeDetection Members
Gallio.Runtime Namespace


RuntimeDetection Members

RuntimeDetection Members
See Also Example Constructors Properties Methods
[image]

Provides functions for detecting CLR runtime parameters.

The following tables list the members exposed by RuntimeDetection.

Public Constructors

 | Name | Description
Public method | RuntimeDetection | Initializes a new instance of the RuntimeDetection class.
Top

Public Properties

Name | Description
IsUsingMono | Returns true if the application is running within the Mono runtime.
Top

Public Methods

 | Name | Description
 | CreateReentrantProcessStartInfo | When using Mono, creates ProcessStartInfo that re-enters the Mono runtime if the executable is .Net otherwise creates a standard process start info.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetRuntimeVersion | Gets the .Net runtime version installed and currently running.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


RuntimeDetection Constructor

RuntimeDetection Constructor
[image]

Initializes a new instance of the RuntimeDetection class.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeDetection()
C++
public:
RuntimeDetection() sealed
J#
public RuntimeDetection()
JScript
public function RuntimeDetection()

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


Properties

RuntimeDetection Properties
[image]

Public Properties

Name | Description
IsUsingMono | Returns true if the application is running within the Mono runtime.
Top

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


IsUsingMono Property

RuntimeDetection.IsUsingMono Property
[image]

Returns true if the application is running within the Mono runtime.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsUsingMono As Boolean
C#
public static bool IsUsingMono { get; }
C++
public static property bool IsUsingMono {
bool get();
}
J#
/** property */
public bool get_IsUsingMono();
JScript
public function get IsUsingMono() : bool

Remarks

It is occasionally necessary to tailor the execution of the test runner depending on whether Mono is running. However, the number of such customizations should be very limited.

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


Methods

RuntimeDetection Methods
[image]

Public Methods

 | Name | Description
 | CreateReentrantProcessStartInfo | When using Mono, creates ProcessStartInfo that re-enters the Mono runtime if the executable is .Net otherwise creates a standard process start info.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetRuntimeVersion | Gets the .Net runtime version installed and currently running.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


CreateReentrantProcessStartInfo Method

RuntimeDetection.CreateReentrantProcessStartInfo Method
[image]

When using Mono, creates ProcessStartInfo that re-enters the Mono runtime if the executable is .Net otherwise creates a standard process start info.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateReentrantProcessStartInfo( _
ByVal executablePath As String, _
ByVal arguments As String _
) As ProcessStartInfo
C#
public static ProcessStartInfo CreateReentrantProcessStartInfo(
string executablePath,
string arguments
)
C++
public:
static ProcessStartInfo CreateReentrantProcessStartInfo(
String executablePath,
String arguments
)
J#
public static ProcessStartInfo CreateReentrantProcessStartInfo(
string executablePath,
string arguments
)
JScript
public static function CreateReentrantProcessStartInfo(
executablePath : String,
arguments : String
) : ProcessStartInfo

Parameters

executablePath
The executable path
arguments
The arguments

Return Value

The process start info

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if executablePath or arguments is null

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


GetRuntimeVersion Method

RuntimeDetection.GetRuntimeVersion Method
[image]

Gets the .Net runtime version installed and currently running.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRuntimeVersion() As RuntimeVersion
C#
public static RuntimeVersion GetRuntimeVersion()
C++
public:
static RuntimeVersion GetRuntimeVersion()
J#
public static RuntimeVersion GetRuntimeVersion()
JScript
public static function GetRuntimeVersion() : RuntimeVersion

Return Value

The runtime version

See Also

RuntimeDetection Class
Gallio.Runtime Namespace


RuntimeException Class

RuntimeException Class
See Also Example Members
[image]

An exception that expresses a problem performing a runtime service.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class RuntimeException
Inherits Exception
C#
[SerializableAttribute]
public class RuntimeException : Exception
C++
[SerializableAttribute]
ref class RuntimeException : Exception
J#
/** @attribute SerializableAttribute() */
public class RuntimeException extends Exception
JScript
public
SerializableAttribute
class RuntimeException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Runtime.RuntimeException

See Also

RuntimeException Members
Gallio.Runtime Namespace


RuntimeException Members

RuntimeException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

An exception that expresses a problem performing a runtime service.

The following tables list the members exposed by RuntimeException.

Public Constructors

Name | Description
RuntimeException | Overloaded. Initializes a new instance of the RuntimeException class.
Top

Protected Constructors

Name | Description
RuntimeException | Overloaded. Initializes a new instance of the RuntimeException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
RuntimeException | Overloaded. Initializes a new instance of the RuntimeException class.
Top

See Also

RuntimeException Class
Gallio.Runtime Namespace


RuntimeException Constructor

RuntimeException Constructor

Initializes a new instance of the RuntimeException class.

Overload List

 | Name | Description
Public method | RuntimeException | Creates an exception.
Family method | RuntimeException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | RuntimeException (String) | Creates an exception.
Public method | RuntimeException (String, Exception) | Creates an exception.

See Also

RuntimeException Class
Gallio.Runtime Namespace


RuntimeException Constructor ()

RuntimeException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeException()
C++
public:
RuntimeException() sealed
J#
public RuntimeException()
JScript
public function RuntimeException()

See Also

RuntimeException Class
Gallio.Runtime Namespace
RuntimeException Constructor Overload List


RuntimeException Constructor (SerializationInfo, StreamingContext)

RuntimeException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected RuntimeException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
RuntimeException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected RuntimeException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function RuntimeException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

RuntimeException Class
Gallio.Runtime Namespace
RuntimeException Constructor Overload List


RuntimeException Constructor (String)

RuntimeException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public RuntimeException(
string message
)
C++
public:
RuntimeException(
String message
) sealed
J#
public RuntimeException(
string message
)
JScript
public function RuntimeException(
message : String
)

Parameters

message
The message

See Also

RuntimeException Class
Gallio.Runtime Namespace
RuntimeException Constructor Overload List


RuntimeException Constructor (String, Exception)

RuntimeException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public RuntimeException(
string message,
Exception innerException
)
C++
public:
RuntimeException(
String message,
Exception innerException
) sealed
J#
public RuntimeException(
string message,
Exception innerException
)
JScript
public function RuntimeException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

RuntimeException Class
Gallio.Runtime Namespace
RuntimeException Constructor Overload List


RuntimeRegisteredComponentResolver Generic Class

RuntimeRegisteredComponentResolver Generic Class
See Also Example Members
[image]

A default implementation of IRegisteredComponentResolver based on IRuntime.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RuntimeRegisteredComponentResolver(Of T As {IRegisteredComponent, Class})
Implements IRegisteredComponentResolver(Of T)
C#
public class RuntimeRegisteredComponentResolver<T> : IRegisteredComponentResolver<T> where T : IRegisteredComponent, class
C++
ref class RuntimeRegisteredComponentResolver<T> : IRegisteredComponentResolver<T> where T : IRegisteredComponent, class
J#
public class RuntimeRegisteredComponentResolver<T> implements IRegisteredComponentResolver<T>
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Runtime.RuntimeRegisteredComponentResolver<T>

See Also

RuntimeRegisteredComponentResolver<T> Members
Gallio.Runtime Namespace


RuntimeRegisteredComponentResolver<T> Members

RuntimeRegisteredComponentResolver Members
See Also Example Constructors Methods
[image]

A default implementation of IRegisteredComponentResolver based on IRuntime.

The following tables list the members exposed by RuntimeRegisteredComponentResolver<T>.

Public Constructors

 | Name | Description
Public method | RuntimeRegisteredComponentResolver | Creates a component resolver.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetNames | Gets the names of all registered components.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Resolve | Resolves a registered component by name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuntimeRegisteredComponentResolver<T> Class
Gallio.Runtime Namespace


RuntimeRegisteredComponentResolver Constructor

RuntimeRegisteredComponentResolver Constructor
[image]

Creates a component resolver.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal runtime As IRuntime _
)
C#
public RuntimeRegisteredComponentResolver(
IRuntime runtime
)
C++
public:
RuntimeRegisteredComponentResolver(
IRuntime runtime
) sealed
J#
public RuntimeRegisteredComponentResolver(
IRuntime runtime
)
JScript
JScript does not support generic types and methods.

Parameters

runtime
The runtime

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if runtime is null

See Also

RuntimeRegisteredComponentResolver<T> Class
Gallio.Runtime Namespace


Methods

RuntimeRegisteredComponentResolver Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetNames | Gets the names of all registered components.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Resolve | Resolves a registered component by name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RuntimeRegisteredComponentResolver<T> Class
Gallio.Runtime Namespace


GetNames Method

RuntimeRegisteredComponentResolver.GetNames Method
[image]

Gets the names of all registered components.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNames() As IList(Of String) _
Implements IRegisteredComponentResolver<T>.GetNames
C#
public IList<string> GetNames()
C++
public:
IList<string> GetNames() sealed
J#
public IList<string> GetNames()
JScript
JScript does not support generic types and methods.

Return Value

The list of registered component names

Implements

IRegisteredComponentResolver<T>.GetNames

See Also

RuntimeRegisteredComponentResolver<T> Class
Gallio.Runtime Namespace


Resolve Method

RuntimeRegisteredComponentResolver.Resolve Method
[image]

Resolves a registered component by name.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal name As String _
) _
Implements IRegisteredComponentResolver<T>.Resolve
C#
public T Resolve(
string name
)
C++
public:
T Resolve(
String name
) sealed
J#
public T Resolve(
string name
)
JScript
JScript does not support generic types and methods.

Parameters

name
The name of the registered component, matched case-insensitively

Return Value

The test runner factory, or null if none exist with the specified name

Implements

IRegisteredComponentResolver<T>.Resolve

See Also

RuntimeRegisteredComponentResolver<T> Class
Gallio.Runtime Namespace


RuntimeSetup Class

RuntimeSetup Class
See Also Example Members
[image]

Provides configuration parameters for setting up the RuntimeAccessor. This class cannot be inherited.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("runtimeSetup", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class RuntimeSetup
C#
[SerializableAttribute]
[XmlRootAttribute("runtimeSetup", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class RuntimeSetup
C++
[SerializableAttribute]
[XmlRootAttribute(L"runtimeSetup", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class RuntimeSetup sealed
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("runtimeSetup", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class RuntimeSetup
JScript
public
SerializableAttribute
XmlRootAttribute("runtimeSetup", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class RuntimeSetup

Inheritance Hierarchy

System.Object
Gallio.Runtime.RuntimeSetup

See Also

RuntimeSetup Members
Gallio.Runtime Namespace


RuntimeSetup Members

RuntimeSetup Members
See Also Example Constructors Properties Methods
[image]

Provides configuration parameters for setting up the RuntimeAccessor. This class cannot be inherited.

The following tables list the members exposed by RuntimeSetup.

Public Constructors

 | Name | Description
Public method | RuntimeSetup | Creates a default runtime setup.
Top

Public Properties

 | Name | Description
Public property | ConfigurationFilePath | Gets or sets the path of the primary configuration file to be loaded by the runtime (if it exists). This is useful when Gallio is launched by a library instead of as a standalone executable.
Public property | InstallationConfiguration | Gets or sets the installation configuration which specifies characteristics about the Gallio installation on the local machine, or null to determine it automatically.
Public property | PluginDirectories | Gets list of relative or absolute paths of directories to be searched for plugin configuration files in addition to the primary Gallio directories.
Public property | RuntimePath | Gets or sets the runtime path, or null to determine it automatically based on the location of the primary runtime assemblies. The runtime path specifies where the standard runtime plugins are located.
Top

Public Methods

 | Name | Description
Public method | Canonicalize | Makes all paths in this instance absolute.
Public method | Copy | Creates a deep copy of the runtime setup parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetConfigurationFilePathFromAssembly | Sets the configuration file path to the *.config file associated with an assembly.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


RuntimeSetup Constructor

RuntimeSetup Constructor
[image]

Creates a default runtime setup.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeSetup()
C++
public:
RuntimeSetup() sealed
J#
public RuntimeSetup()
JScript
public function RuntimeSetup()

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


Properties

RuntimeSetup Properties
[image]

Public Properties

 | Name | Description
Public property | ConfigurationFilePath | Gets or sets the path of the primary configuration file to be loaded by the runtime (if it exists). This is useful when Gallio is launched by a library instead of as a standalone executable.
Public property | InstallationConfiguration | Gets or sets the installation configuration which specifies characteristics about the Gallio installation on the local machine, or null to determine it automatically.
Public property | PluginDirectories | Gets list of relative or absolute paths of directories to be searched for plugin configuration files in addition to the primary Gallio directories.
Public property | RuntimePath | Gets or sets the runtime path, or null to determine it automatically based on the location of the primary runtime assemblies. The runtime path specifies where the standard runtime plugins are located.
Top

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


ConfigurationFilePath Property

RuntimeSetup.ConfigurationFilePath Property
[image]

Gets or sets the path of the primary configuration file to be loaded by the runtime (if it exists). This is useful when Gallio is launched by a library instead of as a standalone executable.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("configurationFilePath")>
Public Property ConfigurationFilePath As String
C#
[XmlAttributeAttribute("configurationFilePath")]
public string ConfigurationFilePath { get; set; }
C++
[XmlAttributeAttribute(L"configurationFilePath")]
public property string ConfigurationFilePath sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("configurationFilePath") */
/** property */
public string get_ConfigurationFilePath();

/** property */
public void set_ConfigurationFilePath(string value);
JScript
public function get ConfigurationFilePath() : String

public function set ConfigurationFilePath(value : String);

Property Value

The primary configuration file path. Default is null to load the configuration from the AppDomain.

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


InstallationConfiguration Property

RuntimeSetup.InstallationConfiguration Property
[image]

Gets or sets the installation configuration which specifies characteristics about the Gallio installation on the local machine, or null to determine it automatically.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("installationConfiguration")>
Public Property InstallationConfiguration As InstallationConfiguration
C#
[XmlElementAttribute("installationConfiguration")]
public InstallationConfiguration InstallationConfiguration { get; set; }
C++
[XmlElementAttribute(L"installationConfiguration")]
public property InstallationConfiguration InstallationConfiguration sealed {
InstallationConfiguration get();
void set(InstallationConfiguration value);
}
J#
/** @attribute XmlElementAttribute("installationConfiguration") */
/** property */
public InstallationConfiguration get_InstallationConfiguration();

/** property */
public void set_InstallationConfiguration(InstallationConfiguration value);
JScript
public function get InstallationConfiguration() : InstallationConfiguration

public function set InstallationConfiguration(value : InstallationConfiguration);

Property Value

The installation configuration. Default is null.

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


PluginDirectories Property

RuntimeSetup.PluginDirectories Property
[image]

Gets list of relative or absolute paths of directories to be searched for plugin configuration files in addition to the primary Gallio directories.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("pluginDirectory", GetType(String), IsNullable := False), _
XmlArrayAttribute("pluginDirectories", IsNullable := False)>
Public ReadOnly Property PluginDirectories As List(Of String)
C#
[XmlArrayItemAttribute("pluginDirectory", typeof(String), IsNullable = False)]
[XmlArrayAttribute("pluginDirectories", IsNullable = False)]
public List<string> PluginDirectories { get; }
C++
[XmlArrayItemAttribute(L"pluginDirectory", typeof(String), IsNullable = False)]
[XmlArrayAttribute(L"pluginDirectories", IsNullable = False)]
public property List<string> PluginDirectories sealed {
List<string> get();
}
J#
/** @attribute XmlArrayItemAttribute("pluginDirectory", typeof(String), IsNullable = False) */
/** @attribute XmlArrayAttribute("pluginDirectories", IsNullable = False) */
/** property */
public List<string> get_PluginDirectories();
JScript
public function get PluginDirectories() : List<string>

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


RuntimePath Property

RuntimeSetup.RuntimePath Property
[image]

Gets or sets the runtime path, or null to determine it automatically based on the location of the primary runtime assemblies. The runtime path specifies where the standard runtime plugins are located.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("runtimePath")>
Public Property RuntimePath As String
C#
[XmlAttributeAttribute("runtimePath")]
public string RuntimePath { get; set; }
C++
[XmlAttributeAttribute(L"runtimePath")]
public property string RuntimePath sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("runtimePath") */
/** property */
public string get_RuntimePath();

/** property */
public void set_RuntimePath(string value);
JScript
public function get RuntimePath() : String

public function set RuntimePath(value : String);

Property Value

The installation path. Default is null.

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


Methods

RuntimeSetup Methods
[image]

Public Methods

 | Name | Description
Public method | Canonicalize | Makes all paths in this instance absolute.
Public method | Copy | Creates a deep copy of the runtime setup parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetConfigurationFilePathFromAssembly | Sets the configuration file path to the *.config file associated with an assembly.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


Canonicalize Method

RuntimeSetup.Canonicalize Method
[image]

Makes all paths in this instance absolute.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Canonicalize( _
ByVal baseDirectory As String _
)
C#
public void Canonicalize(
string baseDirectory
)
C++
public:
void Canonicalize(
String baseDirectory
) sealed
J#
public void Canonicalize(
string baseDirectory
)
JScript
public function Canonicalize(
baseDirectory : String
)

Parameters

baseDirectory
The base directory for resolving relative paths, or null to use the current directory

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


Copy Method

RuntimeSetup.Copy Method
[image]

Creates a deep copy of the runtime setup parameters.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As RuntimeSetup
C#
public RuntimeSetup Copy()
C++
public:
RuntimeSetup Copy() sealed
J#
public RuntimeSetup Copy()
JScript
public function Copy() : RuntimeSetup

Return Value

The copy

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


SetConfigurationFilePathFromAssembly Method

RuntimeSetup.SetConfigurationFilePathFromAssembly Method
[image]

Sets the configuration file path to the *.config file associated with an assembly.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetConfigurationFilePathFromAssembly( _
ByVal assembly As Assembly _
)
C#
public void SetConfigurationFilePathFromAssembly(
Assembly assembly
)
C++
public:
void SetConfigurationFilePathFromAssembly(
Assembly assembly
) sealed
J#
public void SetConfigurationFilePathFromAssembly(
Assembly assembly
)
JScript
public function SetConfigurationFilePathFromAssembly(
assembly : Assembly
)

Parameters

assembly
The assembly

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

RuntimeSetup Class
Gallio.Runtime Namespace


RuntimeVersion Enumeration

RuntimeVersion Enumeration
[image]

Specifies the version of the runtime.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum RuntimeVersion
C#
public enum RuntimeVersion
C++
public enum class RuntimeVersion
J#
public enum RuntimeVersion
JScript
public enum RuntimeVersion

Members

Member Name | Description
DotNet20 | .Net Framework 2.0.
DotNet35 | .Net Framework 3.5.
DotNet40 | .Net Framework 4.0.

See Also

Gallio.Runtime Namespace


UnhandledExceptionPolicy Class

UnhandledExceptionPolicy Class
See Also Example Members
[image]

This class provides a mechanism for reporting unhandled exceptions when the infrastructure is otherwise unable to deal with them locally.

The methods of this class should be considered as the last resort for reporting failures that might otherwise cause the system to crash.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module UnhandledExceptionPolicy
C#
public static class UnhandledExceptionPolicy
C++
ref class UnhandledExceptionPolicy abstract sealed
J#
public final class UnhandledExceptionPolicy
JScript
public class UnhandledExceptionPolicy

Inheritance Hierarchy

System.Object
Gallio.Runtime.UnhandledExceptionPolicy

See Also

UnhandledExceptionPolicy Members
Gallio.Runtime Namespace


UnhandledExceptionPolicy Members

UnhandledExceptionPolicy Members
See Also Example Properties Methods Events
[image]

This class provides a mechanism for reporting unhandled exceptions when the infrastructure is otherwise unable to deal with them locally.

The methods of this class should be considered as the last resort for reporting failures that might otherwise cause the system to crash.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by UnhandledExceptionPolicy.

Public Properties

Name | Description
HasReportUnhandledExceptionHandler | Returns true if there is at least one handler registered for ReportUnhandledException. This property can be used to avoid duplicate exception reporting if some other system component has already registered a handler.
Top

Public Methods

Name | Description
Report | Reports an unhandled exception.
Top

Public Events

Name | Description
CorrelateUnhandledException | Adds or removes an event handler that is notified when unhandled exceptions occur and is given a chance to add additional information the event about the context in which the exception occurred.
ReportUnhandledException | Adds or removes an event handler that is notified when unhandled exceptions occur.
Top

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


Properties

UnhandledExceptionPolicy Properties
[image]

Public Properties

Name | Description
HasReportUnhandledExceptionHandler | Returns true if there is at least one handler registered for ReportUnhandledException. This property can be used to avoid duplicate exception reporting if some other system component has already registered a handler.
Top

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


HasReportUnhandledExceptionHandler Property

UnhandledExceptionPolicy.HasReportUnhandledExceptionHandler Property
See Also Example
[image]

Returns true if there is at least one handler registered for ReportUnhandledException.

This property can be used to avoid duplicate exception reporting if some other system component has already registered a handler.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HasReportUnhandledExceptionHandler As Boolean
C#
public static bool HasReportUnhandledExceptionHandler { get; }
C++
public static property bool HasReportUnhandledExceptionHandler {
bool get();
}
J#
/** property */
public bool get_HasReportUnhandledExceptionHandler();
JScript
public function get HasReportUnhandledExceptionHandler() : bool

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


Methods

UnhandledExceptionPolicy Methods
[image]

Public Methods

Name | Description
Report | Reports an unhandled exception.
Top

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


Report Method

UnhandledExceptionPolicy.Report Method
[image]

Reports an unhandled exception.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Report( _
ByVal message As String, _
ByVal unhandledException As Exception _
)
C#
public static void Report(
string message,
Exception unhandledException
)
C++
public:
static void Report(
String message,
Exception unhandledException
)
J#
public static void Report(
string message,
Exception unhandledException
)
JScript
public static function Report(
message : String,
unhandledException : Exception
)

Parameters

message
A message to explain how the exception was intercepted
unhandledException
The unhandled exception

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message or unhandledException is null

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


Events

UnhandledExceptionPolicy Events
[image]

Public Events

Name | Description
CorrelateUnhandledException | Adds or removes an event handler that is notified when unhandled exceptions occur and is given a chance to add additional information the event about the context in which the exception occurred.
ReportUnhandledException | Adds or removes an event handler that is notified when unhandled exceptions occur.
Top

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


CorrelateUnhandledException Event

UnhandledExceptionPolicy.CorrelateUnhandledException Event
[image]

Adds or removes an event handler that is notified when unhandled exceptions occur and is given a chance to add additional information the event about the context in which the exception occurred.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Event CorrelateUnhandledException As EventHandler(Of CorrelatedExceptionEventArgs)
C#
public static event EventHandler<CorrelatedExceptionEventArgs> CorrelateUnhandledException
C++
public:
static event EventHandler<CorrelatedExceptionEventArgs> CorrelateUnhandledException {
void add(EventHandler<CorrelatedExceptionEventArgs> value);
void remove(EventHandler<CorrelatedExceptionEventArgs> value);
}
J#
/** event */
public static void add_CorrelateUnhandledException(EventHandler<CorrelatedExceptionEventArgs> value);

/** event */
public static void remove_CorrelateUnhandledException(EventHandler<CorrelatedExceptionEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type CorrelatedExceptionEventArgs containing data related to this event. The following CorrelatedExceptionEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the exception that occurred.
IsRecursive | Returns true if a second exception occurred while attempting to report a previous exception on the same thread.
Message | Gets the message associated with the exception.
ReporterStackTrace | Gets the stack trace of the code that called to report the exception or null if not available.

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace
AddCorrelationMessage


ReportUnhandledException Event

UnhandledExceptionPolicy.ReportUnhandledException Event
[image]

Adds or removes an event handler that is notified when unhandled exceptions occur.

Namespace: Gallio.Runtime
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Event ReportUnhandledException As EventHandler(Of CorrelatedExceptionEventArgs)
C#
public static event EventHandler<CorrelatedExceptionEventArgs> ReportUnhandledException
C++
public:
static event EventHandler<CorrelatedExceptionEventArgs> ReportUnhandledException {
void add(EventHandler<CorrelatedExceptionEventArgs> value);
void remove(EventHandler<CorrelatedExceptionEventArgs> value);
}
J#
/** event */
public static void add_ReportUnhandledException(EventHandler<CorrelatedExceptionEventArgs> value);

/** event */
public static void remove_ReportUnhandledException(EventHandler<CorrelatedExceptionEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type CorrelatedExceptionEventArgs containing data related to this event. The following CorrelatedExceptionEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the exception that occurred.
IsRecursive | Returns true if a second exception occurred while attempting to report a previous exception on the same thread.
Message | Gets the message associated with the exception.
ReporterStackTrace | Gets the stack trace of the code that called to report the exception or null if not available.

See Also

UnhandledExceptionPolicy Class
Gallio.Runtime Namespace


Gallio.Runtime.ConsoleSupport

Gallio.Runtime.ConsoleSupport Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | CommandLineArgumentAttribute | Allows control of command line parsing. Attach this attribute to instance fields of types used as the destination of command line argument parsing.
Public class | CommandLineArgumentParser | Parser for command line arguments.
Public class | CommandLineOutput | Responsible for creating output.
Public class | ConsoleProgram | A base class for implementing robust console applications. The subclass should provide a Main method that creates an instance and calls Run. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | DefaultCommandLineArgumentAttribute | Indicates that this argument is the default argument. '/' or '-' prefix only the argument value is specified.
Public class | NativeConsole | An implementation of IRichConsole that targets the native Console. This implementation offers protection against redirection of the Out and Error streams. This object will continue to refer to the standard output and error streams even if they are redirected after its initialization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | RichConsoleLogger | A logger that sends all output to the console and displays messages in color according to their status.

Interfaces

Interface Description
Public interface IRichConsole

A rich console provides a number of services that enable a console to be shared among several cooperating tasks that are independently updating different portions of the display. One task can be writing to the main body of text while another updates a footer.

The rich console also supports intelligent cancelation of tasks. When the user presses control-C, a cancelation flag is set and an event handler is invoked. Tasks can check for the presence of the cancelation flag even if they started execution after the control-C itself occurred. This provides protection against dropped cancelation requests due to race conditions. If the user presses control-C 3 times within a short interval the rich console assumes that the program has become non-responsive and terminates it.

Finally, the rich console interface can be mocked for testing purposes unlike the standard Console API.

Delegates

 | Delegate | Description
Public delegate | CommandLineErrorReporter | A delegate used in error reporting.
Public delegate | ResponseFileReader | Reads the contents of a response file.

Enumerations

 | Enumeration | Description
Public enumeration | CommandLineArgumentFlags | Used to control parsing of command line arguments.


CommandLineArgumentAttribute Class

CommandLineArgumentAttribute Class
See Also Example Members
[image]

Allows control of command line parsing. Attach this attribute to instance fields of types used as the destination of command line argument parsing.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class CommandLineArgumentAttribute
Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class CommandLineArgumentAttribute : Attribute
C++
[AttributeUsageAttribute(AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class CommandLineArgumentAttribute : Attribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class CommandLineArgumentAttribute extends Attribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class CommandLineArgumentAttribute extends Attribute

Remarks

Command line parsing code from Peter Halam, http://www.gotdotnet.com/community/usersamples/details.aspx?sampleguid=62a0f27e-274e-4228-ba7f-bc0118ecc41e

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Runtime.ConsoleSupport.CommandLineArgumentAttribute
Gallio.Runtime.ConsoleSupport.DefaultCommandLineArgumentAttribute

See Also

CommandLineArgumentAttribute Members
Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentAttribute Members

CommandLineArgumentAttribute Members
See Also Example Constructors Properties Methods
[image]

Allows control of command line parsing. Attach this attribute to instance fields of types used as the destination of command line argument parsing.

The following tables list the members exposed by CommandLineArgumentAttribute.

Public Constructors

 | Name | Description
Public method | CommandLineArgumentAttribute | Allows control of command line parsing.
Top

Public Properties

 | Name | Description
Public property | Description | The description of the argument.
Public property | Flags | The error checking to be done on the argument.
Public property | IsDefaultLongName | Returns true if the argument did not have an explicit long name specified.
Public property | IsDefaultShortName | Returns true if the argument did not have an explicit short name specified.
Public property | LongName | The long name of the argument.
Public property | ShortName | The short name of the argument.
Public property | Synonyms | Gets or sets an array of additional synonyms that are silently accepted.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | ValueLabel | The description of the argument value.
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentAttribute Constructor

CommandLineArgumentAttribute Constructor
[image]

Allows control of command line parsing.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal flags As CommandLineArgumentFlags _
)
C#
public CommandLineArgumentAttribute(
CommandLineArgumentFlags flags
)
C++
public:
CommandLineArgumentAttribute(
CommandLineArgumentFlags flags
) sealed
J#
public CommandLineArgumentAttribute(
CommandLineArgumentFlags flags
)
JScript
public function CommandLineArgumentAttribute(
flags : CommandLineArgumentFlags
)

Parameters

flags
Specifies the error checking to be done on the argument.

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


Properties

CommandLineArgumentAttribute Properties
[image]

Public Properties

 | Name | Description
Public property | Description | The description of the argument.
Public property | Flags | The error checking to be done on the argument.
Public property | IsDefaultLongName | Returns true if the argument did not have an explicit long name specified.
Public property | IsDefaultShortName | Returns true if the argument did not have an explicit short name specified.
Public property | LongName | The long name of the argument.
Public property | ShortName | The short name of the argument.
Public property | Synonyms | Gets or sets an array of additional synonyms that are silently accepted.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | ValueLabel | The description of the argument value.
Top

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


Description Property

CommandLineArgumentAttribute.Description Property
[image]

The description of the argument.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


Flags Property

CommandLineArgumentAttribute.Flags Property
[image]

The error checking to be done on the argument.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flags As CommandLineArgumentFlags
C#
public CommandLineArgumentFlags Flags { get; }
C++
public property CommandLineArgumentFlags Flags sealed {
CommandLineArgumentFlags get();
}
J#
/** property */
public CommandLineArgumentFlags get_Flags();
JScript
public function get Flags() : CommandLineArgumentFlags

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


IsDefaultLongName Property

CommandLineArgumentAttribute.IsDefaultLongName Property
[image]

Returns true if the argument did not have an explicit long name specified.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDefaultLongName As Boolean
C#
public bool IsDefaultLongName { get; }
C++
public property bool IsDefaultLongName sealed {
bool get();
}
J#
/** property */
public bool get_IsDefaultLongName();
JScript
public function get IsDefaultLongName() : bool

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


IsDefaultShortName Property

CommandLineArgumentAttribute.IsDefaultShortName Property
[image]

Returns true if the argument did not have an explicit short name specified.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDefaultShortName As Boolean
C#
public bool IsDefaultShortName { get; }
C++
public property bool IsDefaultShortName sealed {
bool get();
}
J#
/** property */
public bool get_IsDefaultShortName();
JScript
public function get IsDefaultShortName() : bool

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


LongName Property

CommandLineArgumentAttribute.LongName Property
[image]

The long name of the argument.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property LongName As String
C#
public string LongName { get; set; }
C++
public property string LongName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LongName();

/** property */
public void set_LongName(string value);
JScript
public function get LongName() : String

public function set LongName(value : String);

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


ShortName Property

CommandLineArgumentAttribute.ShortName Property
[image]

The short name of the argument.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ShortName As String
C#
public string ShortName { get; set; }
C++
public property string ShortName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ShortName();

/** property */
public void set_ShortName(string value);
JScript
public function get ShortName() : String

public function set ShortName(value : String);

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


Synonyms Property

CommandLineArgumentAttribute.Synonyms Property
[image]

Gets or sets an array of additional synonyms that are silently accepted.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Synonyms As String()
C#
public string[] Synonyms { get; set; }
C++
public property string[] Synonyms sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** property */
public string[] get_Synonyms();

/** property */
public void set_Synonyms(string[] value);
JScript
public function get Synonyms() : String[]

public function set Synonyms(value : String[]);

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


ValueLabel Property

CommandLineArgumentAttribute.ValueLabel Property
[image]

The description of the argument value.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueLabel As String
C#
public string ValueLabel { get; set; }
C++
public property string ValueLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ValueLabel();

/** property */
public void set_ValueLabel(string value);
JScript
public function get ValueLabel() : String

public function set ValueLabel(value : String);

See Also

CommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentFlags Enumeration

CommandLineArgumentFlags Enumeration
[image]

Used to control parsing of command line arguments.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute>
Public Enum CommandLineArgumentFlags
C#
[FlagsAttribute]
public enum CommandLineArgumentFlags
C++
[FlagsAttribute]
public enum class CommandLineArgumentFlags
J#
/** @attribute FlagsAttribute() */
public enum CommandLineArgumentFlags
JScript
public enum CommandLineArgumentFlags

Remarks

Command line parsing code from Peter Halam, http://www.gotdotnet.com/community/usersamples/details.aspx?sampleguid=62a0f27e-274e-4228-ba7f-bc0118ecc41e

Members

Member Name | Description | Value
Required | Indicates that this field is required. An error will be displayed if it is not present when parsing arguments. | 1
Unique | Only valid in conjunction with Multiple. Duplicate values will result in an error. | 2
Multiple | Inidicates that the argument may be specified more than once. Only valid if the argument is a collection | 4
AtMostOnce | The default type for non-collection arguments. The argument is not required, but an error will be reported if it is specified more than once. | 0
LastOccurrenceWins | For non-collection arguments, when the argument is specified more than once no error is reported and the value of the argument is the last value which occurs in the argument list. | 4
MultipleUnique | The default type for collection arguments. The argument is permitted to occur multiple times, but duplicate values will cause an error to be reported. | 6

See Also

Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentParser Class

CommandLineArgumentParser Class
See Also Example Members
[image]

Parser for command line arguments.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class CommandLineArgumentParser
C#
public class CommandLineArgumentParser
C++
ref class CommandLineArgumentParser
J#
public class CommandLineArgumentParser
JScript
public class CommandLineArgumentParser

Remarks

The parser specification is infered from the instance fields of the object specified as the destination of the parse. Valid argument types are: int, uint, string, bool, enums Also argument types of Array of the above types are also valid.

Error checking options can be controlled by adding a CommandLineArgumentAttribute to the instance fields of the destination object.

At most one field may be marked with the DefaultCommandLineArgumentAttribute indicating that arguments without a '-' or '/' prefix will be parsed as that argument.

If not specified then the parser will infer default options for parsing each instance field. The default long name of the argument is the field name. The default short name is the first character of the long name. Long names and explicitly specified short names must be unique. Default short names will be used provided that the default short name does not conflict with a long name or an explicitly specified short name.

Arguments which are array types are collection arguments. Collection arguments can be specified multiple times.

Command line parsing code from Peter Halam, http://www.gotdotnet.com/community/usersamples/details.aspx?sampleguid=62a0f27e-274e-4228-ba7f-bc0118ecc41e

Inheritance Hierarchy

System.Object
Gallio.Runtime.ConsoleSupport.CommandLineArgumentParser

See Also

CommandLineArgumentParser Members
Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentParser Members

CommandLineArgumentParser Members
See Also Example Methods Explicit Inteface Implementations
[image]

Parser for command line arguments.

The following tables list the members exposed by CommandLineArgumentParser.

Public Constructors

Name | Description
CommandLineArgumentParser | Overloaded.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Parse | Parses an argument list.
Public method | ShowUsage | Prints a user friendly usage string describing the command line argument syntax.
Public method | ShowUsageInMessageBox | Prints a user friendly usage string describing the command line argument syntax in a message box.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
CommandLineArgumentParser | Overloaded.
Top

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentParser Constructor

CommandLineArgumentParser Constructor

Overload List

 | Name | Description
Public method | CommandLineArgumentParser (Type) | Creates a new command line argument parser.
Public method | CommandLineArgumentParser (Type, ResponseFileReader) | Creates a new command line argument parser.

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineArgumentParser Constructor (Type)

CommandLineArgumentParser Constructor (Type)
See Also Example
[image]

Creates a new command line argument parser.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal argumentSpecification As Type _
)
C#
public CommandLineArgumentParser(
Type argumentSpecification
)
C++
public:
CommandLineArgumentParser(
Type argumentSpecification
) sealed
J#
public CommandLineArgumentParser(
Type argumentSpecification
)
JScript
public function CommandLineArgumentParser(
argumentSpecification : Type
)

Parameters

argumentSpecification
The argument type containing fields decorated with CommandLineArgumentAttribute

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if argumentSpecification is null

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineArgumentParser Constructor Overload List


CommandLineArgumentParser Constructor (Type, ResponseFileReader)

CommandLineArgumentParser Constructor (Type, ResponseFileReader)
See Also Example
[image]

Creates a new command line argument parser.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal argumentSpecification As Type, _
ByVal responseFileReader As ResponseFileReader _
)
C#
public CommandLineArgumentParser(
Type argumentSpecification,
ResponseFileReader responseFileReader
)
C++
public:
CommandLineArgumentParser(
Type argumentSpecification,
ResponseFileReader responseFileReader
) sealed
J#
public CommandLineArgumentParser(
Type argumentSpecification,
ResponseFileReader responseFileReader
)
JScript
public function CommandLineArgumentParser(
argumentSpecification : Type,
responseFileReader : ResponseFileReader
)

Parameters

argumentSpecification
The argument type containing fields decorated with CommandLineArgumentAttribute
responseFileReader
The delegate to use for reading response files instead of the default.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if argumentSpecification or responseFileReader is null

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineArgumentParser Constructor Overload List


Methods

CommandLineArgumentParser Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Parse | Parses an argument list.
Public method | ShowUsage | Prints a user friendly usage string describing the command line argument syntax.
Public method | ShowUsageInMessageBox | Prints a user friendly usage string describing the command line argument syntax in a message box.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace


Parse Method

CommandLineArgumentParser.Parse Method
[image]

Parses an argument list.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Parse( _
ByVal args As String(), _
ByVal destination As Object, _
ByVal reporter As CommandLineErrorReporter _
) As Boolean
C#
public bool Parse(
string[] args,
object destination,
CommandLineErrorReporter reporter
)
C++
public:
bool Parse(
array<String>^ args,
Object destination,
CommandLineErrorReporter reporter
) sealed
J#
public bool Parse(
string[] args,
object destination,
CommandLineErrorReporter reporter
)
JScript
public function Parse(
args : String[],
destination : Object,
reporter : CommandLineErrorReporter
) : bool

Parameters

args
The arguments to parse.
destination
The destination of the parsed arguments.
reporter
The error reporter

Return Value

True if no parse errors were encountered.

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace


ShowUsage Method

CommandLineArgumentParser.ShowUsage Method
[image]

Prints a user friendly usage string describing the command line argument syntax.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ShowUsage( _
ByVal output As CommandLineOutput _
)
C#
public void ShowUsage(
CommandLineOutput output
)
C++
public:
void ShowUsage(
CommandLineOutput output
) sealed
J#
public void ShowUsage(
CommandLineOutput output
)
JScript
public function ShowUsage(
output : CommandLineOutput
)

Parameters

output
The command line output

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace


ShowUsageInMessageBox Method

CommandLineArgumentParser.ShowUsageInMessageBox Method
[image]

Prints a user friendly usage string describing the command line argument syntax in a message box.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ShowUsageInMessageBox( _
ByVal caption As String _
)
C#
public void ShowUsageInMessageBox(
string caption
)
C++
public:
void ShowUsageInMessageBox(
String caption
) sealed
J#
public void ShowUsageInMessageBox(
string caption
)
JScript
public function ShowUsageInMessageBox(
caption : String
)

Parameters

caption
The message box caption

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if caption is null

See Also

CommandLineArgumentParser Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineErrorReporter Delegate

CommandLineErrorReporter Delegate
[image]

A delegate used in error reporting.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub CommandLineErrorReporter( _
ByVal message As String _
)
C#
public delegate void CommandLineErrorReporter(
string message
)
C++
public delegate void CommandLineErrorReporter(
String message
)
J#
/** delegate */
public delegate void CommandLineErrorReporter(
string message
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Remarks

Command line parsing code from Peter Halam, http://www.gotdotnet.com/community/usersamples/details.aspx?sampleguid=62a0f27e-274e-4228-ba7f-bc0118ecc41e

See Also

Gallio.Runtime.ConsoleSupport Namespace


CommandLineOutput Class

CommandLineOutput Class
See Also Example Members
[image]

Responsible for creating output.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class CommandLineOutput
C#
public class CommandLineOutput
C++
ref class CommandLineOutput
J#
public class CommandLineOutput
JScript
public class CommandLineOutput

Inheritance Hierarchy

System.Object
Gallio.Runtime.ConsoleSupport.CommandLineOutput

See Also

CommandLineOutput Members
Gallio.Runtime.ConsoleSupport Namespace


CommandLineOutput Members

CommandLineOutput Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Responsible for creating output.

The following tables list the members exposed by CommandLineOutput.

Public Constructors

Name | Description
CommandLineOutput | Overloaded.
Top

Public Properties

 | Name | Description
Public property | LineLength | Maximum line length allowed before the text will be wraped.
Public property | Output | Output Stream
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | NewLine | Prints out a new line.
Public method | PrintArgumentHelp | Prints help for a specified argument.
Public method | PrintText | Overloaded. Outputs text with specified indentation.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
CommandLineOutput | Overloaded.
Top

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineOutput Constructor

CommandLineOutput Constructor

Overload List

 | Name | Description
Public method | CommandLineOutput (IRichConsole) | Initializes new instance of CommandLineOutput.
Public method | CommandLineOutput (TextWriter) | Initializes new instance of CommandLineOutput that outputs to specified stream.
Public method | CommandLineOutput (TextWriter, Int32) | Initializes new instance of CommandLineOutput that outputs to specified stream.

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineOutput Constructor (IRichConsole)

CommandLineOutput Constructor (IRichConsole)
See Also Example
[image]

Initializes new instance of CommandLineOutput.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal console As IRichConsole _
)
C#
public CommandLineOutput(
IRichConsole console
)
C++
public:
CommandLineOutput(
IRichConsole console
) sealed
J#
public CommandLineOutput(
IRichConsole console
)
JScript
public function CommandLineOutput(
console : IRichConsole
)

Parameters

console
The console

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineOutput Constructor Overload List


CommandLineOutput Constructor (TextWriter)

CommandLineOutput Constructor (TextWriter)
See Also Example
[image]

Initializes new instance of CommandLineOutput that outputs to specified stream.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal output As TextWriter _
)
C#
public CommandLineOutput(
TextWriter output
)
C++
public:
CommandLineOutput(
TextWriter output
) sealed
J#
public CommandLineOutput(
TextWriter output
)
JScript
public function CommandLineOutput(
output : TextWriter
)

Parameters

output
Text writer

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineOutput Constructor Overload List


CommandLineOutput Constructor (TextWriter, Int32)

CommandLineOutput Constructor (TextWriter, Int32)
See Also Example
[image]

Initializes new instance of CommandLineOutput that outputs to specified stream.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal output As TextWriter, _
ByVal width As Integer _
)
C#
public CommandLineOutput(
TextWriter output,
int width
)
C++
public:
CommandLineOutput(
TextWriter output,
int width
) sealed
J#
public CommandLineOutput(
TextWriter output,
int width
)
JScript
public function CommandLineOutput(
output : TextWriter,
width : int
)

Parameters

output
Text writer
width
The output width

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineOutput Constructor Overload List


Properties

CommandLineOutput Properties
[image]

Public Properties

 | Name | Description
Public property | LineLength | Maximum line length allowed before the text will be wraped.
Public property | Output | Output Stream
Top

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


LineLength Property

CommandLineOutput.LineLength Property
[image]

Maximum line length allowed before the text will be wraped.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property LineLength As Integer
C#
public int LineLength { get; set; }
C++
public property int LineLength sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_LineLength();

/** property */
public void set_LineLength(int value);
JScript
public function get LineLength() : int

public function set LineLength(value : int);

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


Output Property

CommandLineOutput.Output Property
[image]

Output Stream

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Output As TextWriter
C#
public TextWriter Output { get; }
C++
public property TextWriter Output sealed {
TextWriter get();
}
J#
/** property */
public TextWriter get_Output();
JScript
public function get Output() : TextWriter

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


Methods

CommandLineOutput Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | NewLine | Prints out a new line.
Public method | PrintArgumentHelp | Prints help for a specified argument.
Public method | PrintText | Overloaded. Outputs text with specified indentation.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


NewLine Method

CommandLineOutput.NewLine Method
[image]

Prints out a new line.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub NewLine()
C#
public void NewLine()
C++
public:
void NewLine() sealed
J#
public void NewLine()
JScript
public function NewLine()

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


PrintArgumentHelp Method

CommandLineOutput.PrintArgumentHelp Method
[image]

Prints help for a specified argument.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub PrintArgumentHelp( _
ByVal prefix As String, _
ByVal longName As String, _
ByVal shortName As String, _
ByVal description As String, _
ByVal valueLabel As String, _
ByVal valueType As Type _
)
C#
public void PrintArgumentHelp(
string prefix,
string longName,
string shortName,
string description,
string valueLabel,
Type valueType
)
C++
public:
void PrintArgumentHelp(
String prefix,
String longName,
String shortName,
String description,
String valueLabel,
Type valueType
) sealed
J#
public void PrintArgumentHelp(
string prefix,
string longName,
string shortName,
string description,
string valueLabel,
Type valueType
)
JScript
public function PrintArgumentHelp(
prefix : String,
longName : String,
shortName : String,
description : String,
valueLabel : String,
valueType : Type
)

Parameters

prefix
The argument prefix, such as "/", or null or empty if none.
longName
The argument's long name, or null or empty if none.
shortName
The argument's short short name, or null or empty if none.
description
The argument's description, or null or empty if none.
valueLabel
The argument's value label such as "path", or null or empty if none.
valueType
The argument's value type, or null if none.

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


PrintText Method

CommandLineOutput.PrintText Method

Outputs text with specified indentation.

Overload List

 | Name | Description
Public method | PrintText (String, Int32) | Outputs text with specified indentation.
Public method | PrintText (String, Int32, Int32) | Outputs text with specified indentation.

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace


PrintText Method (String, Int32)

CommandLineOutput.PrintText Method (String, Int32)
See Also Example
[image]

Outputs text with specified indentation.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub PrintText( _
ByVal text As String, _
ByVal indentation As Integer _
)
C#
public void PrintText(
string text,
int indentation
)
C++
public:
void PrintText(
String text,
int indentation
) sealed
J#
public void PrintText(
string text,
int indentation
)
JScript
public function PrintText(
text : String,
indentation : int
)

Parameters

text
Text to output possibly including newlines.
indentation
Number of blank spaces to indent the first line.

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineOutput.PrintText Overload List


PrintText Method (String, Int32, Int32)

CommandLineOutput.PrintText Method (String, Int32, Int32)
See Also Example
[image]

Outputs text with specified indentation.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub PrintText( _
ByVal text As String, _
ByVal indentation As Integer, _
ByVal firstLineIndent As Integer _
)
C#
public void PrintText(
string text,
int indentation,
int firstLineIndent
)
C++
public:
void PrintText(
String text,
int indentation,
int firstLineIndent
) sealed
J#
public void PrintText(
string text,
int indentation,
int firstLineIndent
)
JScript
public function PrintText(
text : String,
indentation : int,
firstLineIndent : int
)

Parameters

text
Text to output possibly including newlines.
indentation
Number of blank spaces to indent all but the first line.
firstLineIndent
Number of blank spaces to indent the first line.

See Also

CommandLineOutput Class
Gallio.Runtime.ConsoleSupport Namespace
CommandLineOutput.PrintText Overload List


ConsoleProgram Generic Class

ConsoleProgram Generic Class
See Also Example Members
[image]

A base class for implementing robust console applications. The subclass should provide a Main method that creates an instance and calls Run. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ConsoleProgram(Of TArguments As New)
Implements IDisposable
C#
public abstract class ConsoleProgram<TArguments> : IDisposable where TArguments : new()
C++
ref class ConsoleProgram<TArguments> abstract : IDisposable where TArguments : new()
J#
public class ConsoleProgram<TArguments> implements IDisposable
JScript
JScript does not support generic types and methods.

Inheritance Hierarchy

System.Object
Gallio.Runtime.ConsoleSupport.ConsoleProgram<TArguments>

See Also

ConsoleProgram<TArguments> Members
Gallio.Runtime.ConsoleSupport Namespace


ConsoleProgram<TArguments> Members

ConsoleProgram Members
See Also Example Constructors Properties Methods
[image]

A base class for implementing robust console applications. The subclass should provide a Main method that creates an instance and calls Run. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ConsoleProgram<TArguments>.

Protected Constructors

 | Name | Description
Family method | ConsoleProgram | Initializes a new instance of the ConsoleProgram class.
Top

Protected Properties

 | Name | Description
Family property | ApplicationName | Gets or sets the application name.
Family property | ApplicationTitle | Get or sets the application title.
Family property | ApplicationVersion | Gets or sets the application version.
Family property | ArgumentParser | Gets the argument parser.
Family property | Arguments | Gets or sets the parsed command-line arguments. These argument may be modified prior to calling ParseArguments to override the initial argument settings.
Family property | CommandLineOutput | Gets the command-line output formatter, or null if the program is not running.
Family property | Console | Gets the console, or null if the program is not running.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs the program.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | HandleFatalException | Handles a fatal exception that escaped the RunImpl method.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ParseArguments | Parses the arguments.
Family method | RunImpl | Runs the program.
Family method | ShowErrorMessage | Displays an error message to the console.
Family method | ShowHelp | Displays help text to the console.
Top

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ConsoleProgram Constructor

ConsoleProgram Constructor
[image]

Initializes a new instance of the ConsoleProgram class.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected ConsoleProgram()
C++
protected:
ConsoleProgram() sealed
J#
protected ConsoleProgram()
JScript
JScript does not support generic types and methods.

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


Properties

ConsoleProgram Properties
[image]

Protected Properties

 | Name | Description
Family property | ApplicationName | Gets or sets the application name.
Family property | ApplicationTitle | Get or sets the application title.
Family property | ApplicationVersion | Gets or sets the application version.
Family property | ArgumentParser | Gets the argument parser.
Family property | Arguments | Gets or sets the parsed command-line arguments. These argument may be modified prior to calling ParseArguments to override the initial argument settings.
Family property | CommandLineOutput | Gets the command-line output formatter, or null if the program is not running.
Family property | Console | Gets the console, or null if the program is not running.
Top

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ApplicationName Property

ConsoleProgram.ApplicationName Property
[image]

Gets or sets the application name.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Property ApplicationName As String
C#
protected string ApplicationName { get; set; }
C++
protected property string ApplicationName sealed {
String get();
void set(String value);
}
J#
/** property */
protected string get_ApplicationName();

/** property */
protected void set_ApplicationName(string value);
JScript
JScript does not support generic types and methods.

Property Value

The name, by default this is the program assembly's name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ApplicationTitle Property

ConsoleProgram.ApplicationTitle Property
[image]

Get or sets the application title.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Property ApplicationTitle As String
C#
protected string ApplicationTitle { get; set; }
C++
protected property string ApplicationTitle sealed {
String get();
void set(String value);
}
J#
/** property */
protected string get_ApplicationTitle();

/** property */
protected void set_ApplicationTitle(string value);
JScript
JScript does not support generic types and methods.

Property Value

The title, by default this is constructed from the application's name and version

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ApplicationVersion Property

ConsoleProgram.ApplicationVersion Property
[image]

Gets or sets the application version.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Property ApplicationVersion As Version
C#
protected Version ApplicationVersion { get; set; }
C++
protected property Version ApplicationVersion sealed {
Version get();
void set(Version value);
}
J#
/** property */
protected Version get_ApplicationVersion();

/** property */
protected void set_ApplicationVersion(Version value);
JScript
JScript does not support generic types and methods.

Property Value

The version, by default this is the program assembly's version

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ArgumentParser Property

ConsoleProgram.ArgumentParser Property
[image]

Gets the argument parser.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ArgumentParser As CommandLineArgumentParser
C#
protected CommandLineArgumentParser ArgumentParser { get; }
C++
protected property CommandLineArgumentParser ArgumentParser sealed {
CommandLineArgumentParser get();
}
J#
/** property */
protected CommandLineArgumentParser get_ArgumentParser();
JScript
JScript does not support generic types and methods.

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


Arguments Property

ConsoleProgram.Arguments Property
[image]

Gets or sets the parsed command-line arguments. These argument may be modified prior to calling ParseArguments to override the initial argument settings.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Property Arguments
C#
protected TArguments Arguments { get; set; }
C++
protected property TArguments Arguments sealed {
TArguments get();
void set(TArguments value);
}
J#
/** property */
protected TArguments get_Arguments();

/** property */
protected void set_Arguments(TArguments value);
JScript
JScript does not support generic types and methods.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


CommandLineOutput Property

ConsoleProgram.CommandLineOutput Property
[image]

Gets the command-line output formatter, or null if the program is not running.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CommandLineOutput As CommandLineOutput
C#
protected CommandLineOutput CommandLineOutput { get; }
C++
protected property CommandLineOutput CommandLineOutput sealed {
CommandLineOutput get();
}
J#
/** property */
protected CommandLineOutput get_CommandLineOutput();
JScript
JScript does not support generic types and methods.

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


Console Property

ConsoleProgram.Console Property
[image]

Gets the console, or null if the program is not running.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Console As IRichConsole
C#
protected IRichConsole Console { get; }
C++
protected property IRichConsole Console sealed {
IRichConsole get();
}
J#
/** property */
protected IRichConsole get_Console();
JScript
JScript does not support generic types and methods.

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


Methods

ConsoleProgram Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs the program.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | HandleFatalException | Handles a fatal exception that escaped the RunImpl method.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ParseArguments | Parses the arguments.
Family method | RunImpl | Runs the program.
Family method | ShowErrorMessage | Displays an error message to the console.
Family method | ShowHelp | Displays help text to the console.
Top

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


Dispose Method

ConsoleProgram.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose() _
Implements IDisposable.Dispose
C#
public virtual void Dispose()
C++
public:
virtual void Dispose()
J#
public virtual void Dispose()
JScript
JScript does not support generic types and methods.

Implements

IDisposable.Dispose

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


HandleFatalException Method

ConsoleProgram.HandleFatalException Method
[image]

Handles a fatal exception that escaped the RunImpl method.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function HandleFatalException( _
ByVal ex As Exception _
) As Integer
C#
protected virtual int HandleFatalException(
Exception ex
)
C++
protected:
virtual int HandleFatalException(
Exception ex
)
J#
protected virtual int HandleFatalException(
Exception ex
)
JScript
JScript does not support generic types and methods.

Parameters

ex
The exception

Return Value

The exit code to return

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ParseArguments Method

ConsoleProgram.ParseArguments Method
[image]

Parses the arguments.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ParseArguments( _
ByVal args As String() _
) As Boolean
C#
protected virtual bool ParseArguments(
string[] args
)
C++
protected:
virtual bool ParseArguments(
array<String>^ args
)
J#
protected virtual bool ParseArguments(
string[] args
)
JScript
JScript does not support generic types and methods.

Parameters

args
The command-line arguments

Return Value

True if the arguments were parsed successfully

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


Run Method

ConsoleProgram.Run Method
[image]

Runs the program.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Run( _
ByVal console As IRichConsole, _
ByVal args As String() _
) As Integer
C#
public int Run(
IRichConsole console,
string[] args
)
C++
public:
int Run(
IRichConsole console,
array<String>^ args
) sealed
J#
public int Run(
IRichConsole console,
string[] args
)
JScript
JScript does not support generic types and methods.

Parameters

console
The console
args
The command-line arguments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if console or args is null
InvalidOperationException | Thrown if the program has already started running

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


RunImpl Method

ConsoleProgram.RunImpl Method
[image]

Runs the program.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function RunImpl( _
ByVal args As String() _
) As Integer
C#
protected abstract int RunImpl(
string[] args
)
C++
protected:
int RunImpl(
array<String>^ args
) abstract
J#
protected abstract int RunImpl(
string[] args
)
JScript
JScript does not support generic types and methods.

Parameters

args
The command-line arguments

Return Value

The program exit code

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ShowErrorMessage Method

ConsoleProgram.ShowErrorMessage Method
[image]

Displays an error message to the console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ShowErrorMessage( _
ByVal message As String _
)
C#
protected virtual void ShowErrorMessage(
string message
)
C++
protected:
virtual void ShowErrorMessage(
String message
)
J#
protected virtual void ShowErrorMessage(
string message
)
JScript
JScript does not support generic types and methods.

Parameters

message
The error message

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


ShowHelp Method

ConsoleProgram.ShowHelp Method
[image]

Displays help text to the console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ShowHelp()
C#
protected virtual void ShowHelp()
C++
protected:
virtual void ShowHelp()
J#
protected virtual void ShowHelp()
JScript
JScript does not support generic types and methods.

See Also

ConsoleProgram<TArguments> Class
Gallio.Runtime.ConsoleSupport Namespace


DefaultCommandLineArgumentAttribute Class

DefaultCommandLineArgumentAttribute Class
See Also Example Members
[image]

Indicates that this argument is the default argument. '/' or '-' prefix only the argument value is specified.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Field)>
Public Class DefaultCommandLineArgumentAttribute
Inherits CommandLineArgumentAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Field)]
public class DefaultCommandLineArgumentAttribute : CommandLineArgumentAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Field)]
ref class DefaultCommandLineArgumentAttribute : CommandLineArgumentAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Field) */
public class DefaultCommandLineArgumentAttribute extends CommandLineArgumentAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Field)
class DefaultCommandLineArgumentAttribute extends CommandLineArgumentAttribute

Remarks

Command line parsing code from Peter Halam, http://www.gotdotnet.com/community/usersamples/details.aspx?sampleguid=62a0f27e-274e-4228-ba7f-bc0118ecc41e

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Runtime.ConsoleSupport.CommandLineArgumentAttribute
Gallio.Runtime.ConsoleSupport.DefaultCommandLineArgumentAttribute

See Also

DefaultCommandLineArgumentAttribute Members
Gallio.Runtime.ConsoleSupport Namespace


DefaultCommandLineArgumentAttribute Members

DefaultCommandLineArgumentAttribute Members
See Also Example Constructors Properties Methods
[image]

Indicates that this argument is the default argument. '/' or '-' prefix only the argument value is specified.

The following tables list the members exposed by DefaultCommandLineArgumentAttribute.

Public Constructors

 | Name | Description
Public method | DefaultCommandLineArgumentAttribute | Indicates that this argument is the default argument.
Top

Public Properties

 | Name | Description
Public property | Description | The description of the argument. (inherited from CommandLineArgumentAttribute)
Public property | Flags | The error checking to be done on the argument. (inherited from CommandLineArgumentAttribute)
Public property | IsDefaultLongName | Returns true if the argument did not have an explicit long name specified. (inherited from CommandLineArgumentAttribute)
Public property | IsDefaultShortName | Returns true if the argument did not have an explicit short name specified. (inherited from CommandLineArgumentAttribute)
Public property | LongName | The long name of the argument. (inherited from CommandLineArgumentAttribute)
Public property | ShortName | The short name of the argument. (inherited from CommandLineArgumentAttribute)
Public property | Synonyms | Gets or sets an array of additional synonyms that are silently accepted. (inherited from CommandLineArgumentAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | ValueLabel | The description of the argument value. (inherited from CommandLineArgumentAttribute)
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultCommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


DefaultCommandLineArgumentAttribute Constructor

DefaultCommandLineArgumentAttribute Constructor
[image]

Indicates that this argument is the default argument.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal flags As CommandLineArgumentFlags _
)
C#
public DefaultCommandLineArgumentAttribute(
CommandLineArgumentFlags flags
)
C++
public:
DefaultCommandLineArgumentAttribute(
CommandLineArgumentFlags flags
) sealed
J#
public DefaultCommandLineArgumentAttribute(
CommandLineArgumentFlags flags
)
JScript
public function DefaultCommandLineArgumentAttribute(
flags : CommandLineArgumentFlags
)

Parameters

flags
Specifies the error checking to be done on the argument.

See Also

DefaultCommandLineArgumentAttribute Class
Gallio.Runtime.ConsoleSupport Namespace


IRichConsole Interface

IRichConsole Interface
See Also Example Members
[image]

A rich console provides a number of services that enable a console to be shared among several cooperating tasks that are independently updating different portions of the display. One task can be writing to the main body of text while another updates a footer.

The rich console also supports intelligent cancelation of tasks. When the user presses control-C, a cancelation flag is set and an event handler is invoked. Tasks can check for the presence of the cancelation flag even if they started execution after the control-C itself occurred. This provides protection against dropped cancelation requests due to race conditions. If the user presses control-C 3 times within a short interval the rich console assumes that the program has become non-responsive and terminates it.

Finally, the rich console interface can be mocked for testing purposes unlike the standard Console API.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRichConsole
C#
public interface IRichConsole
C++
interface class IRichConsole
J#
public interface IRichConsole
JScript
public interface IRichConsole

Types that implement IRichConsole

Type | Description
Gallio.Runtime.ConsoleSupport.NativeConsole | An implementation of IRichConsole that targets the native Console. This implementation offers protection against redirection of the Out and Error streams. This object will continue to refer to the standard output and error streams even if they are redirected after its initialization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

See Also

IRichConsole Members
Gallio.Runtime.ConsoleSupport Namespace


IRichConsole Members

IRichConsole Members
See Also Example Properties Methods Events
[image]

A rich console provides a number of services that enable a console to be shared among several cooperating tasks that are independently updating different portions of the display. One task can be writing to the main body of text while another updates a footer.

The rich console also supports intelligent cancelation of tasks. When the user presses control-C, a cancelation flag is set and an event handler is invoked. Tasks can check for the presence of the cancelation flag even if they started execution after the control-C itself occurred. This provides protection against dropped cancelation requests due to race conditions. If the user presses control-C 3 times within a short interval the rich console assumes that the program has become non-responsive and terminates it.

Finally, the rich console interface can be mocked for testing purposes unlike the standard Console API.

The following tables list the members exposed by IRichConsole.

Public Properties

 | Name | Description
Public property | CursorLeft | Gets the zero-based column index the cursor is located at.
Public property | CursorTop | Gets the zero-based row index the cursor is located at.
Public property | Error | Gets the error stream writer.
Public property | FooterVisible | Gets or sets whether the footer is visible.
Public property | ForegroundColor | Gets or sets the foreground color of the console.
Public property | IsCancelationEnabled | Gets or sets whether the cancelation function is enabled. If false, cancelation events will not be sent.
Public property | IsCanceled | Gets or sets whether cancelation has occurred. The Cancel event handlers will be called when the value of IsCanceled transitions from false to true. The value will remain true unless it is reset.
Public property | IsRedirected | Returns true if the console is being redirected and therefore the output should be as simple as possible. In particular, it may not be possible to set the cursor position, console color or other properties.
Public property | Out | Gets the output stream writer.
Public property | SyncRoot | Gets a synchronization object that a task can lock to ensure that it is the only thread currently accessing the console.
Public property | Title | Gets or sets the console's title.
Public property | Width | Gets the width of the console. Returns 80 if the console is being redirected.
Top

Public Methods

 | Name | Description
Public method | ResetColor | Resets the console colors.
Public method | SetFooter | Sets a pair of delegates that together display a footer at the bottom of the console. The footer can be hidden so that new text can be written from that point. Removes the previous footer and displays the new one automatically if the footer is visible.
Public method | Write | Overloaded. Writes a character.
Public method | WriteLine | Overloaded. Writes a new line.
Top

Public Events

 | Name | Description
Public event | Cancel | The event raised when console cancelation occurs. If the console cancelation signal is already set when an event handler is added, the event handler will be automatically invoked.
Top

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Properties

IRichConsole Properties
[image]

Public Properties

 | Name | Description
Public property | CursorLeft | Gets the zero-based column index the cursor is located at.
Public property | CursorTop | Gets the zero-based row index the cursor is located at.
Public property | Error | Gets the error stream writer.
Public property | FooterVisible | Gets or sets whether the footer is visible.
Public property | ForegroundColor | Gets or sets the foreground color of the console.
Public property | IsCancelationEnabled | Gets or sets whether the cancelation function is enabled. If false, cancelation events will not be sent.
Public property | IsCanceled | Gets or sets whether cancelation has occurred. The Cancel event handlers will be called when the value of IsCanceled transitions from false to true. The value will remain true unless it is reset.
Public property | IsRedirected | Returns true if the console is being redirected and therefore the output should be as simple as possible. In particular, it may not be possible to set the cursor position, console color or other properties.
Public property | Out | Gets the output stream writer.
Public property | SyncRoot | Gets a synchronization object that a task can lock to ensure that it is the only thread currently accessing the console.
Public property | Title | Gets or sets the console's title.
Public property | Width | Gets the width of the console. Returns 80 if the console is being redirected.
Top

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


CursorLeft Property

IRichConsole.CursorLeft Property
[image]

Gets the zero-based column index the cursor is located at.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property CursorLeft As Integer
C#
int CursorLeft { get; set; }
C++
property int CursorLeft abstract {
int get();
void set(int value);
}
J#
/** property */
public int get_CursorLeft();

/** property */
public void set_CursorLeft(int value);
JScript
public function get CursorLeft() : int

public function set CursorLeft(value : int);

Exceptions

Exception Type | Condition
IOException | Thrown if IsRedirected is true

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


CursorTop Property

IRichConsole.CursorTop Property
[image]

Gets the zero-based row index the cursor is located at.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property CursorTop As Integer
C#
int CursorTop { get; set; }
C++
property int CursorTop abstract {
int get();
void set(int value);
}
J#
/** property */
public int get_CursorTop();

/** property */
public void set_CursorTop(int value);
JScript
public function get CursorTop() : int

public function set CursorTop(value : int);

Exceptions

Exception Type | Condition
IOException | Thrown if IsRedirected is true

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Error Property

IRichConsole.Error Property
[image]

Gets the error stream writer.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Error As TextWriter
C#
TextWriter Error { get; }
C++
property TextWriter Error abstract {
TextWriter get();
}
J#
/** property */
public TextWriter get_Error();
JScript
public function get Error() : TextWriter

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


FooterVisible Property

IRichConsole.FooterVisible Property
[image]

Gets or sets whether the footer is visible.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property FooterVisible As Boolean
C#
bool FooterVisible { get; set; }
C++
property bool FooterVisible abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_FooterVisible();

/** property */
public void set_FooterVisible(bool value);
JScript
public function get FooterVisible() : bool

public function set FooterVisible(value : bool);

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


ForegroundColor Property

IRichConsole.ForegroundColor Property
[image]

Gets or sets the foreground color of the console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property ForegroundColor As ConsoleColor
C#
ConsoleColor ForegroundColor { get; set; }
C++
property ConsoleColor ForegroundColor abstract {
ConsoleColor get();
void set(ConsoleColor value);
}
J#
/** property */
public ConsoleColor get_ForegroundColor();

/** property */
public void set_ForegroundColor(ConsoleColor value);
JScript
public function get ForegroundColor() : ConsoleColor

public function set ForegroundColor(value : ConsoleColor);

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


IsCancelationEnabled Property

IRichConsole.IsCancelationEnabled Property
[image]

Gets or sets whether the cancelation function is enabled. If false, cancelation events will not be sent.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property IsCancelationEnabled As Boolean
C#
bool IsCancelationEnabled { get; set; }
C++
property bool IsCancelationEnabled abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsCancelationEnabled();

/** property */
public void set_IsCancelationEnabled(bool value);
JScript
public function get IsCancelationEnabled() : bool

public function set IsCancelationEnabled(value : bool);

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


IsCanceled Property

IRichConsole.IsCanceled Property
[image]

Gets or sets whether cancelation has occurred.

The Cancel event handlers will be called when the value of IsCanceled transitions from false to true. The value will remain true unless it is reset.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property IsCanceled As Boolean
C#
bool IsCanceled { get; set; }
C++
property bool IsCanceled abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsCanceled();

/** property */
public void set_IsCanceled(bool value);
JScript
public function get IsCanceled() : bool

public function set IsCanceled(value : bool);

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


IsRedirected Property

IRichConsole.IsRedirected Property
[image]

Returns true if the console is being redirected and therefore the output should be as simple as possible. In particular, it may not be possible to set the cursor position, console color or other properties.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsRedirected As Boolean
C#
bool IsRedirected { get; }
C++
property bool IsRedirected abstract {
bool get();
}
J#
/** property */
public bool get_IsRedirected();
JScript
public function get IsRedirected() : bool

Remarks

Trying to set the console color while output is redirected is tolerated by the system and won't cause an error; but it is pointless. On the other hand cursor positioning or attempting to listen to Ctrl-C will fail with an IOException.

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Out Property

IRichConsole.Out Property
[image]

Gets the output stream writer.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Out As TextWriter
C#
TextWriter Out { get; }
C++
property TextWriter Out abstract {
TextWriter get();
}
J#
/** property */
public TextWriter get_Out();
JScript
public function get Out() : TextWriter

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


SyncRoot Property

IRichConsole.SyncRoot Property
[image]

Gets a synchronization object that a task can lock to ensure that it is the only thread currently accessing the console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SyncRoot As Object
C#
object SyncRoot { get; }
C++
property object SyncRoot abstract {
Object get();
}
J#
/** property */
public object get_SyncRoot();
JScript
public function get SyncRoot() : Object

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Title Property

IRichConsole.Title Property
[image]

Gets or sets the console's title.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Property Title As String
C#
string Title { get; set; }
C++
property string Title abstract {
String get();
void set(String value);
}
J#
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

Exceptions

Exception Type | Condition
IOException | Thrown if IsRedirected is true

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Width Property

IRichConsole.Width Property
[image]

Gets the width of the console. Returns 80 if the console is being redirected.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Width As Integer
C#
int Width { get; }
C++
property int Width abstract {
int get();
}
J#
/** property */
public int get_Width();
JScript
public function get Width() : int

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Methods

IRichConsole Methods
[image]

Public Methods

 | Name | Description
Public method | ResetColor | Resets the console colors.
Public method | SetFooter | Sets a pair of delegates that together display a footer at the bottom of the console. The footer can be hidden so that new text can be written from that point. Removes the previous footer and displays the new one automatically if the footer is visible.
Public method | Write | Overloaded. Writes a character.
Public method | WriteLine | Overloaded. Writes a new line.
Top

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


ResetColor Method

IRichConsole.ResetColor Method
[image]

Resets the console colors.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ResetColor()
C#
void ResetColor()
C++
void ResetColor() abstract
J#
void ResetColor()
JScript
function ResetColor()

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


SetFooter Method

IRichConsole.SetFooter Method
[image]

Sets a pair of delegates that together display a footer at the bottom of the console. The footer can be hidden so that new text can be written from that point. Removes the previous footer and displays the new one automatically if the footer is visible.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetFooter( _
ByVal showFooter As Action, _
ByVal hideFooter As Action _
)
C#
void SetFooter(
Action showFooter,
Action hideFooter
)
C++
void SetFooter(
Action showFooter,
Action hideFooter
) abstract
J#
void SetFooter(
Action showFooter,
Action hideFooter
)
JScript
function SetFooter(
showFooter : Action,
hideFooter : Action
)

Parameters

showFooter
A delegate to display the footer
hideFooter
A delegate to hide the footer, leaving the custor at the beginning of the line where the footer used to begin

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Write Method

IRichConsole.Write Method

Writes a character.

Overload List

 | Name | Description
Public method | Write (Char) | Writes a character.
Public method | Write (String) | Writes a string.

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Write Method (Char)

IRichConsole.Write Method (Char)
See Also Example
[image]

Writes a character.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Write( _
ByVal c As Char _
)
C#
public abstract void Write(
char c
)
C++
public:
void Write(
wchar_t c
) abstract
J#
public abstract void Write(
char c
)
JScript
public abstract function Write(
c : char
)

Parameters

c
The character to write

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace
IRichConsole.Write Overload List


Write Method (String)

IRichConsole.Write Method (String)
See Also Example
[image]

Writes a string.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Write( _
ByVal str As String _
)
C#
public abstract void Write(
string str
)
C++
public:
void Write(
String str
) abstract
J#
public abstract void Write(
string str
)
JScript
public abstract function Write(
str : String
)

Parameters

str
The string to write

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace
IRichConsole.Write Overload List


WriteLine Method

IRichConsole.WriteLine Method

Writes a new line.

Overload List

 | Name | Description
Public method | WriteLine | Writes a new line.
Public method | WriteLine (String) | Writes a string followed by a new line.

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


WriteLine Method ()

IRichConsole.WriteLine Method ()
See Also Example
[image]

Writes a new line.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteLine()
C#
public abstract void WriteLine()
C++
public:
void WriteLine() abstract
J#
public abstract void WriteLine()
JScript
public abstract function WriteLine()

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace
IRichConsole.WriteLine Overload List


WriteLine Method (String)

IRichConsole.WriteLine Method (String)
See Also Example
[image]

Writes a string followed by a new line.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteLine( _
ByVal str As String _
)
C#
public abstract void WriteLine(
string str
)
C++
public:
void WriteLine(
String str
) abstract
J#
public abstract void WriteLine(
string str
)
JScript
public abstract function WriteLine(
str : String
)

Parameters

str
The string to write

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace
IRichConsole.WriteLine Overload List


Events

IRichConsole Events
[image]

Public Events

 | Name | Description
Public event | Cancel | The event raised when console cancelation occurs. If the console cancelation signal is already set when an event handler is added, the event handler will be automatically invoked.
Top

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


Cancel Event

IRichConsole.Cancel Event
[image]

The event raised when console cancelation occurs.

If the console cancelation signal is already set when an event handler is added, the event handler will be automatically invoked.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event Cancel As EventHandler
C#
abstract event EventHandler Cancel
C++
event EventHandler Cancel {
void add(EventHandler value) abstract ;
void remove(EventHandler value) abstract ;
}
J#
/** event */
void add_Cancel(EventHandler value);

/** event */
abstract void remove_Cancel(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

IRichConsole Interface
Gallio.Runtime.ConsoleSupport Namespace


NativeConsole Class

NativeConsole Class
See Also Example Members
[image]

An implementation of IRichConsole that targets the native Console.

This implementation offers protection against redirection of the Out and Error streams. This object will continue to refer to the standard output and error streams even if they are redirected after its initialization.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NativeConsole
Implements IRichConsole
C#
public sealed class NativeConsole : IRichConsole
C++
ref class NativeConsole sealed : IRichConsole
J#
public final class NativeConsole implements IRichConsole
JScript
public final class NativeConsole extends IRichConsole

Inheritance Hierarchy

System.Object
Gallio.Runtime.ConsoleSupport.NativeConsole

See Also

NativeConsole Members
Gallio.Runtime.ConsoleSupport Namespace


NativeConsole Members

NativeConsole Members
See Also Example Fields Properties Methods Events
[image]

An implementation of IRichConsole that targets the native Console.

This implementation offers protection against redirection of the Out and Error streams. This object will continue to refer to the standard output and error streams even if they are redirected after its initialization.

This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by NativeConsole.

Public Fields

Name | Description
ForceQuitKeyPressRepetitions | The application will forcibly terminate if the cancel key is pressed ForceQuitKeyPressRepetitions times within no more than ForceQuitKeyPressTimeoutMilliseconds milliseconds. This field is constant and read-only.
ForceQuitKeyPressTimeoutMilliseconds | The application will forcibly terminate if the cancel key is pressed ForceQuitKeyPressRepetitions times within no more than ForceQuitKeyPressTimeoutMilliseconds milliseconds. This field is constant and read-only.
Top

Public Properties

 | Name | Description
Public property | CursorLeft | Gets the zero-based column index the cursor is located at.
Public property | CursorTop | Gets the zero-based row index the cursor is located at.
Public property | Error | Gets the error stream writer.
Public property | FooterVisible | Gets or sets whether the footer is visible.
Public property | ForegroundColor | Gets or sets the foreground color of the console.
 | Instance | Gets the singleton instance of the native console.
Public property | IsCancelationEnabled | Gets or sets whether the cancelation function is enabled. If false, cancelation events will not be sent.
Public property | IsCanceled | Gets or sets whether cancelation has occurred. The Cancel event handlers will be called when the value of IsCanceled transitions from false to true. The value will remain true unless it is reset.
Public property | IsRedirected | Returns true if the console is being redirected and therefore the output should be as simple as possible. In particular, it may not be possible to set the cursor position, console color or other properties.
Public property | Out | Gets the output stream writer.
Public property | SyncRoot | Gets a synchronization object that a task can lock to ensure that it is the only thread currently accessing the console.
Public property | Title | Gets or sets the console's title.
Public property | Width | Gets the width of the console. Returns 80 if the console is being redirected.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ResetColor | Resets the console colors.
Public method | SetFooter | Sets a pair of delegates that together display a footer at the bottom of the console. The footer can be hidden so that new text can be written from that point. Removes the previous footer and displays the new one automatically if the footer is visible.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded. Writes a character.
Public method | WriteLine | Overloaded. Writes a new line.
Top

Public Events

 | Name | Description
Public event | Cancel | The event raised when console cancelation occurs. If the console cancelation signal is already set when an event handler is added, the event handler will be automatically invoked.
Top

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Fields

NativeConsole Fields
[image]

Public Fields

Name | Description
ForceQuitKeyPressRepetitions | The application will forcibly terminate if the cancel key is pressed ForceQuitKeyPressRepetitions times within no more than ForceQuitKeyPressTimeoutMilliseconds milliseconds. This field is constant and read-only.
ForceQuitKeyPressTimeoutMilliseconds | The application will forcibly terminate if the cancel key is pressed ForceQuitKeyPressRepetitions times within no more than ForceQuitKeyPressTimeoutMilliseconds milliseconds. This field is constant and read-only.
Top

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


ForceQuitKeyPressRepetitions Field

NativeConsole.ForceQuitKeyPressRepetitions Field
[image]

The application will forcibly terminate if the cancel key is pressed ForceQuitKeyPressRepetitions times within no more than ForceQuitKeyPressTimeoutMilliseconds milliseconds. This field is constant and read-only.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ForceQuitKeyPressRepetitions As Integer = 3
C#
public const int ForceQuitKeyPressRepetitions = 3;
C++
public:
const int ForceQuitKeyPressRepetitions = 3;
J#
public const int ForceQuitKeyPressRepetitions = 3
JScript
public const ForceQuitKeyPressRepetitions : int = 3;

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


ForceQuitKeyPressTimeoutMilliseconds Field

NativeConsole.ForceQuitKeyPressTimeoutMilliseconds Field
[image]

The application will forcibly terminate if the cancel key is pressed ForceQuitKeyPressRepetitions times within no more than ForceQuitKeyPressTimeoutMilliseconds milliseconds. This field is constant and read-only.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ForceQuitKeyPressTimeoutMilliseconds As Integer = 1000
C#
public const int ForceQuitKeyPressTimeoutMilliseconds = 1000;
C++
public:
const int ForceQuitKeyPressTimeoutMilliseconds = 1000;
J#
public const int ForceQuitKeyPressTimeoutMilliseconds = 1000
JScript
public const ForceQuitKeyPressTimeoutMilliseconds : int = 1000;

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Properties

NativeConsole Properties
[image]

Public Properties

 | Name | Description
Public property | CursorLeft | Gets the zero-based column index the cursor is located at.
Public property | CursorTop | Gets the zero-based row index the cursor is located at.
Public property | Error | Gets the error stream writer.
Public property | FooterVisible | Gets or sets whether the footer is visible.
Public property | ForegroundColor | Gets or sets the foreground color of the console.
 | Instance | Gets the singleton instance of the native console.
Public property | IsCancelationEnabled | Gets or sets whether the cancelation function is enabled. If false, cancelation events will not be sent.
Public property | IsCanceled | Gets or sets whether cancelation has occurred. The Cancel event handlers will be called when the value of IsCanceled transitions from false to true. The value will remain true unless it is reset.
Public property | IsRedirected | Returns true if the console is being redirected and therefore the output should be as simple as possible. In particular, it may not be possible to set the cursor position, console color or other properties.
Public property | Out | Gets the output stream writer.
Public property | SyncRoot | Gets a synchronization object that a task can lock to ensure that it is the only thread currently accessing the console.
Public property | Title | Gets or sets the console's title.
Public property | Width | Gets the width of the console. Returns 80 if the console is being redirected.
Top

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


CursorLeft Property

NativeConsole.CursorLeft Property
[image]

Gets the zero-based column index the cursor is located at.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CursorLeft As Integer _
Implements IRichConsole.CursorLeft
C#
public int CursorLeft { get; set; }
C++
public property int CursorLeft sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_CursorLeft();

/** property */
public void set_CursorLeft(int value);
JScript
public function get CursorLeft() : int

public function set CursorLeft(value : int);

Implements

IRichConsole.CursorLeft

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


CursorTop Property

NativeConsole.CursorTop Property
[image]

Gets the zero-based row index the cursor is located at.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property CursorTop As Integer _
Implements IRichConsole.CursorTop
C#
public int CursorTop { get; set; }
C++
public property int CursorTop sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_CursorTop();

/** property */
public void set_CursorTop(int value);
JScript
public function get CursorTop() : int

public function set CursorTop(value : int);

Implements

IRichConsole.CursorTop

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Error Property

NativeConsole.Error Property
[image]

Gets the error stream writer.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Error As TextWriter _
Implements IRichConsole.Error
C#
public TextWriter Error { get; }
C++
public property TextWriter Error sealed {
TextWriter get();
}
J#
/** property */
public TextWriter get_Error();
JScript
public function get Error() : TextWriter

Implements

IRichConsole.Error

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


FooterVisible Property

NativeConsole.FooterVisible Property
[image]

Gets or sets whether the footer is visible.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property FooterVisible As Boolean _
Implements IRichConsole.FooterVisible
C#
public bool FooterVisible { get; set; }
C++
public property bool FooterVisible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_FooterVisible();

/** property */
public void set_FooterVisible(bool value);
JScript
public function get FooterVisible() : bool

public function set FooterVisible(value : bool);

Implements

IRichConsole.FooterVisible

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


ForegroundColor Property

NativeConsole.ForegroundColor Property
[image]

Gets or sets the foreground color of the console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ForegroundColor As ConsoleColor _
Implements IRichConsole.ForegroundColor
C#
public ConsoleColor ForegroundColor { get; set; }
C++
public property ConsoleColor ForegroundColor sealed {
ConsoleColor get();
void set(ConsoleColor value);
}
J#
/** property */
public ConsoleColor get_ForegroundColor();

/** property */
public void set_ForegroundColor(ConsoleColor value);
JScript
public function get ForegroundColor() : ConsoleColor

public function set ForegroundColor(value : ConsoleColor);

Implements

IRichConsole.ForegroundColor

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Instance Property

NativeConsole.Instance Property
[image]

Gets the singleton instance of the native console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As NativeConsole
C#
public static NativeConsole Instance { get; }
C++
public static property NativeConsole Instance {
NativeConsole get();
}
J#
/** property */
public NativeConsole get_Instance();
JScript
public function get Instance() : NativeConsole

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


IsCancelationEnabled Property

NativeConsole.IsCancelationEnabled Property
[image]

Gets or sets whether the cancelation function is enabled. If false, cancelation events will not be sent.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCancelationEnabled As Boolean _
Implements IRichConsole.IsCancelationEnabled
C#
public bool IsCancelationEnabled { get; set; }
C++
public property bool IsCancelationEnabled sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsCancelationEnabled();

/** property */
public void set_IsCancelationEnabled(bool value);
JScript
public function get IsCancelationEnabled() : bool

public function set IsCancelationEnabled(value : bool);

Implements

IRichConsole.IsCancelationEnabled

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


IsCanceled Property

NativeConsole.IsCanceled Property
[image]

Gets or sets whether cancelation has occurred.

The Cancel event handlers will be called when the value of IsCanceled transitions from false to true. The value will remain true unless it is reset.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCanceled As Boolean _
Implements IRichConsole.IsCanceled
C#
public bool IsCanceled { get; set; }
C++
public property bool IsCanceled sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsCanceled();

/** property */
public void set_IsCanceled(bool value);
JScript
public function get IsCanceled() : bool

public function set IsCanceled(value : bool);

Implements

IRichConsole.IsCanceled

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


IsRedirected Property

NativeConsole.IsRedirected Property
[image]

Returns true if the console is being redirected and therefore the output should be as simple as possible. In particular, it may not be possible to set the cursor position, console color or other properties.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRedirected As Boolean _
Implements IRichConsole.IsRedirected
C#
public bool IsRedirected { get; }
C++
public property bool IsRedirected sealed {
bool get();
}
J#
/** property */
public bool get_IsRedirected();
JScript
public function get IsRedirected() : bool

Implements

IRichConsole.IsRedirected

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Out Property

NativeConsole.Out Property
[image]

Gets the output stream writer.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Out As TextWriter _
Implements IRichConsole.Out
C#
public TextWriter Out { get; }
C++
public property TextWriter Out sealed {
TextWriter get();
}
J#
/** property */
public TextWriter get_Out();
JScript
public function get Out() : TextWriter

Implements

IRichConsole.Out

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


SyncRoot Property

NativeConsole.SyncRoot Property
[image]

Gets a synchronization object that a task can lock to ensure that it is the only thread currently accessing the console.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object _
Implements IRichConsole.SyncRoot
C#
public object SyncRoot { get; }
C++
public property object SyncRoot sealed {
Object get();
}
J#
/** property */
public object get_SyncRoot();
JScript
public function get SyncRoot() : Object

Implements

IRichConsole.SyncRoot

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Title Property

NativeConsole.Title Property
[image]

Gets or sets the console's title.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String _
Implements IRichConsole.Title
C#
public string Title { get; set; }
C++
public property string Title sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

Implements

IRichConsole.Title

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Width Property

NativeConsole.Width Property
[image]

Gets the width of the console. Returns 80 if the console is being redirected.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Integer _
Implements IRichConsole.Width
C#
public int Width { get; }
C++
public property int Width sealed {
int get();
}
J#
/** property */
public int get_Width();
JScript
public function get Width() : int

Implements

IRichConsole.Width

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Methods

NativeConsole Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ResetColor | Resets the console colors.
Public method | SetFooter | Sets a pair of delegates that together display a footer at the bottom of the console. The footer can be hidden so that new text can be written from that point. Removes the previous footer and displays the new one automatically if the footer is visible.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded. Writes a character.
Public method | WriteLine | Overloaded. Writes a new line.
Top

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


ResetColor Method

NativeConsole.ResetColor Method
[image]

Resets the console colors.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ResetColor() _
Implements IRichConsole.ResetColor
C#
public void ResetColor()
C++
public:
void ResetColor() sealed
J#
public void ResetColor()
JScript
public function ResetColor()

Implements

IRichConsole.ResetColor

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


SetFooter Method

NativeConsole.SetFooter Method
[image]

Sets a pair of delegates that together display a footer at the bottom of the console. The footer can be hidden so that new text can be written from that point. Removes the previous footer and displays the new one automatically if the footer is visible.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetFooter( _
ByVal showFooter As Action, _
ByVal hideFooter As Action _
) _
Implements IRichConsole.SetFooter
C#
public void SetFooter(
Action showFooter,
Action hideFooter
)
C++
public:
void SetFooter(
Action showFooter,
Action hideFooter
) sealed
J#
public void SetFooter(
Action showFooter,
Action hideFooter
)
JScript
public function SetFooter(
showFooter : Action,
hideFooter : Action
)

Parameters

showFooter
A delegate to display the footer
hideFooter
A delegate to hide the footer, leaving the custor at the beginning of the line where the footer used to begin

Implements

IRichConsole.SetFooter

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Write Method

NativeConsole.Write Method

Writes a character.

Overload List

 | Name | Description
Public method | Write (Char) | Writes a character.
Public method | Write (String) | Writes a string.

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Write Method (Char)

NativeConsole.Write Method (Char)
See Also Example
[image]

Writes a character.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal c As Char _
) _
Implements IRichConsole.Write
C#
public void Write(
char c
)
C++
public:
void Write(
wchar_t c
) sealed
J#
public void Write(
char c
)
JScript
public function Write(
c : char
)

Parameters

c
The character to write

Implements

IRichConsole.Write

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace
NativeConsole.Write Overload List


Write Method (String)

NativeConsole.Write Method (String)
See Also Example
[image]

Writes a string.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal str As String _
) _
Implements IRichConsole.Write
C#
public void Write(
string str
)
C++
public:
void Write(
String str
) sealed
J#
public void Write(
string str
)
JScript
public function Write(
str : String
)

Parameters

str
The string to write

Implements

IRichConsole.Write

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace
NativeConsole.Write Overload List


WriteLine Method

NativeConsole.WriteLine Method

Writes a new line.

Overload List

 | Name | Description
Public method | WriteLine | Writes a new line.
Public method | WriteLine (String) | Writes a string followed by a new line.

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


WriteLine Method ()

NativeConsole.WriteLine Method ()
See Also Example
[image]

Writes a new line.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteLine() _
Implements IRichConsole.WriteLine
C#
public void WriteLine()
C++
public:
void WriteLine() sealed
J#
public void WriteLine()
JScript
public function WriteLine()

Implements

IRichConsole.WriteLine

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace
NativeConsole.WriteLine Overload List


WriteLine Method (String)

NativeConsole.WriteLine Method (String)
See Also Example
[image]

Writes a string followed by a new line.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteLine( _
ByVal str As String _
) _
Implements IRichConsole.WriteLine
C#
public void WriteLine(
string str
)
C++
public:
void WriteLine(
String str
) sealed
J#
public void WriteLine(
string str
)
JScript
public function WriteLine(
str : String
)

Parameters

str
The string to write

Implements

IRichConsole.WriteLine

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace
NativeConsole.WriteLine Overload List


Events

NativeConsole Events
[image]

Public Events

 | Name | Description
Public event | Cancel | The event raised when console cancelation occurs. If the console cancelation signal is already set when an event handler is added, the event handler will be automatically invoked.
Top

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


Cancel Event

NativeConsole.Cancel Event
[image]

The event raised when console cancelation occurs.

If the console cancelation signal is already set when an event handler is added, the event handler will be automatically invoked.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Cancel As EventHandler
C#
public event EventHandler Cancel
C++
public:
virtual event EventHandler Cancel {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Cancel(EventHandler value);

/** event */
public final void remove_Cancel(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

IRichConsole.Cancel

See Also

NativeConsole Class
Gallio.Runtime.ConsoleSupport Namespace


ResponseFileReader Delegate

ResponseFileReader Delegate
[image]

Reads the contents of a response file.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function ResponseFileReader( _
ByVal responseFileName As String _
) As String
C#
public delegate string ResponseFileReader(
string responseFileName
)
C++
public delegate String ResponseFileReader(
String responseFileName
)
J#
/** delegate */
public delegate string ResponseFileReader(
string responseFileName
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

responseFileName
The response file name, never null

See Also

Gallio.Runtime.ConsoleSupport Namespace


RichConsoleLogger Class

RichConsoleLogger Class
See Also Example Members
[image]

A logger that sends all output to the console and displays messages in color according to their status.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RichConsoleLogger
Inherits BaseLogger
C#
public class RichConsoleLogger : BaseLogger
C++
ref class RichConsoleLogger : BaseLogger
J#
public class RichConsoleLogger extends BaseLogger
JScript
public class RichConsoleLogger extends BaseLogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.ConsoleSupport.RichConsoleLogger

See Also

RichConsoleLogger Members
Gallio.Runtime.ConsoleSupport Namespace


RichConsoleLogger Members

RichConsoleLogger Members
See Also Example Constructors Methods
[image]

A logger that sends all output to the console and displays messages in color according to their status.

The following tables list the members exposed by RichConsoleLogger.

Public Constructors

 | Name | Description
Public method | RichConsoleLogger | Creates a logger.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RichConsoleLogger Class
Gallio.Runtime.ConsoleSupport Namespace


RichConsoleLogger Constructor

RichConsoleLogger Constructor
[image]

Creates a logger.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal console As IRichConsole _
)
C#
public RichConsoleLogger(
IRichConsole console
)
C++
public:
RichConsoleLogger(
IRichConsole console
) sealed
J#
public RichConsoleLogger(
IRichConsole console
)
JScript
public function RichConsoleLogger(
console : IRichConsole
)

Parameters

console
The console

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if console is null

See Also

RichConsoleLogger Class
Gallio.Runtime.ConsoleSupport Namespace


Methods

RichConsoleLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RichConsoleLogger Class
Gallio.Runtime.ConsoleSupport Namespace


LogImpl Method

RichConsoleLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.ConsoleSupport
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
virtual void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) override
J#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected override function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

RichConsoleLogger Class
Gallio.Runtime.ConsoleSupport Namespace


Gallio.Runtime.Debugging

Gallio.Runtime.Debugging Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | DefaultDebuggerManager | Default implementation of a debugger manager.
Public class | NullDebugger | A null implementation of a debugger. All services return do nothing results.

Interfaces

 | Interface | Description
Public interface | IDebugger | Provides control over a debugger.
Public interface | IDebuggerManager | Obtains a reference to a debugger.

Enumerations

 | Enumeration | Description
Public enumeration | AttachDebuggerResult | Describes different possible outcomes from attaching a debugger to a process.
Public enumeration | DetachDebuggerResult | Describes different possible outcomes from detaching a debugger from a process.


AttachDebuggerResult Enumeration

AttachDebuggerResult Enumeration
[image]

Describes different possible outcomes from attaching a debugger to a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum AttachDebuggerResult
C#
public enum AttachDebuggerResult
C++
public enum class AttachDebuggerResult
J#
public enum AttachDebuggerResult
JScript
public enum AttachDebuggerResult

Members

Member Name | Description
CouldNotAttach | The debugger could not attach to the process.
AlreadyAttached | The debugger was already attached to the process.
Attached | The debugger has just been attached to the process.

See Also

Gallio.Runtime.Debugging Namespace


DefaultDebuggerManager Class

DefaultDebuggerManager Class
See Also Example Members
[image]

Default implementation of a debugger manager.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultDebuggerManager
Implements IDebuggerManager
C#
public class DefaultDebuggerManager : IDebuggerManager
C++
ref class DefaultDebuggerManager : IDebuggerManager
J#
public class DefaultDebuggerManager implements IDebuggerManager
JScript
public class DefaultDebuggerManager extends IDebuggerManager

Inheritance Hierarchy

System.Object
Gallio.Runtime.Debugging.DefaultDebuggerManager

See Also

DefaultDebuggerManager Members
Gallio.Runtime.Debugging Namespace


DefaultDebuggerManager Members

DefaultDebuggerManager Members
See Also Example Constructors Methods
[image]

Default implementation of a debugger manager.

The following tables list the members exposed by DefaultDebuggerManager.

Public Constructors

 | Name | Description
Public method | DefaultDebuggerManager | Initializes a new instance of the DefaultDebuggerManager class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDefaultDebugger | Gets the default debugger.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultDebuggerManager Class
Gallio.Runtime.Debugging Namespace


DefaultDebuggerManager Constructor

DefaultDebuggerManager Constructor
[image]

Initializes a new instance of the DefaultDebuggerManager class.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DefaultDebuggerManager()
C++
public:
DefaultDebuggerManager() sealed
J#
public DefaultDebuggerManager()
JScript
public function DefaultDebuggerManager()

See Also

DefaultDebuggerManager Class
Gallio.Runtime.Debugging Namespace


Methods

DefaultDebuggerManager Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDefaultDebugger | Gets the default debugger.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultDebuggerManager Class
Gallio.Runtime.Debugging Namespace


GetDefaultDebugger Method

DefaultDebuggerManager.GetDefaultDebugger Method
[image]

Gets the default debugger.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDefaultDebugger() As IDebugger _
Implements IDebuggerManager.GetDefaultDebugger
C#
public IDebugger GetDefaultDebugger()
C++
public:
IDebugger GetDefaultDebugger() sealed
J#
public IDebugger GetDefaultDebugger()
JScript
public function GetDefaultDebugger() : IDebugger

Return Value

The default debugger

Implements

IDebuggerManager.GetDefaultDebugger

See Also

DefaultDebuggerManager Class
Gallio.Runtime.Debugging Namespace


DetachDebuggerResult Enumeration

DetachDebuggerResult Enumeration
[image]

Describes different possible outcomes from detaching a debugger from a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum DetachDebuggerResult
C#
public enum DetachDebuggerResult
C++
public enum class DetachDebuggerResult
J#
public enum DetachDebuggerResult
JScript
public enum DetachDebuggerResult

Members

Member Name | Description
CouldNotDetach | The debugger could not be detached from the process and remains attached.
AlreadyDetached | The debugger was already detached from the process.
Detached | The debugger has just been detached from the process.

See Also

Gallio.Runtime.Debugging Namespace


IDebugger Interface

IDebugger Interface
See Also Example Members
[image]

Provides control over a debugger.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDebugger
C#
public interface IDebugger
C++
interface class IDebugger
J#
public interface IDebugger
JScript
public interface IDebugger

Types that implement IDebugger

Type | Description
Gallio.Runtime.Debugging.NullDebugger | A null implementation of a debugger. All services return do nothing results.

See Also

IDebugger Members
Gallio.Runtime.Debugging Namespace


IDebugger Members

IDebugger Members
See Also Example Methods
[image]

Provides control over a debugger.

The following tables list the members exposed by IDebugger.

Public Methods

 | Name | Description
Public method | AttachToProcess | Attaches the debugger to a process.
Public method | DetachFromProcess | Detaches the debugger from a process.
Public method | IsAttachedToProcess | Returns true if the debugger is attached to a process.
Top

See Also

IDebugger Interface
Gallio.Runtime.Debugging Namespace


Methods

IDebugger Methods
[image]

Public Methods

 | Name | Description
Public method | AttachToProcess | Attaches the debugger to a process.
Public method | DetachFromProcess | Detaches the debugger from a process.
Public method | IsAttachedToProcess | Returns true if the debugger is attached to a process.
Top

See Also

IDebugger Interface
Gallio.Runtime.Debugging Namespace


AttachToProcess Method

IDebugger.AttachToProcess Method
[image]

Attaches the debugger to a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function AttachToProcess( _
ByVal process As Process _
) As AttachDebuggerResult
C#
AttachDebuggerResult AttachToProcess(
Process process
)
C++
AttachDebuggerResult AttachToProcess(
Process process
) abstract
J#
AttachDebuggerResult AttachToProcess(
Process process
)
JScript
function AttachToProcess(
process : Process
) : AttachDebuggerResult

Parameters

process
The process to which the debugger should be attached

Return Value

A result code to indicate whether the debugger was attached

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if process is null

See Also

IDebugger Interface
Gallio.Runtime.Debugging Namespace


DetachFromProcess Method

IDebugger.DetachFromProcess Method
[image]

Detaches the debugger from a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function DetachFromProcess( _
ByVal process As Process _
) As DetachDebuggerResult
C#
DetachDebuggerResult DetachFromProcess(
Process process
)
C++
DetachDebuggerResult DetachFromProcess(
Process process
) abstract
J#
DetachDebuggerResult DetachFromProcess(
Process process
)
JScript
function DetachFromProcess(
process : Process
) : DetachDebuggerResult

Parameters

process
The process from which the debugger should be detached

Return Value

A result code to indicate whether the debugger was detached

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if process is null

Remarks

Does nothing if the process was not attached.

See Also

IDebugger Interface
Gallio.Runtime.Debugging Namespace


IsAttachedToProcess Method

IDebugger.IsAttachedToProcess Method
[image]

Returns true if the debugger is attached to a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsAttachedToProcess( _
ByVal process As Process _
) As Boolean
C#
bool IsAttachedToProcess(
Process process
)
C++
bool IsAttachedToProcess(
Process process
) abstract
J#
bool IsAttachedToProcess(
Process process
)
JScript
function IsAttachedToProcess(
process : Process
) : bool

Parameters

process
The process to which the debugger should be attached

Return Value

True if the debugger is already attached

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if process is null

See Also

IDebugger Interface
Gallio.Runtime.Debugging Namespace


IDebuggerManager Interface

IDebuggerManager Interface
See Also Example Members
[image]

Obtains a reference to a debugger.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDebuggerManager
C#
public interface IDebuggerManager
C++
interface class IDebuggerManager
J#
public interface IDebuggerManager
JScript
public interface IDebuggerManager

Types that implement IDebuggerManager

Type | Description
Gallio.Runtime.Debugging.DefaultDebuggerManager | Default implementation of a debugger manager.

See Also

IDebuggerManager Members
Gallio.Runtime.Debugging Namespace


IDebuggerManager Members

IDebuggerManager Members
See Also Example Methods
[image]

Obtains a reference to a debugger.

The following tables list the members exposed by IDebuggerManager.

Public Methods

 | Name | Description
Public method | GetDefaultDebugger | Gets the default debugger.
Top

See Also

IDebuggerManager Interface
Gallio.Runtime.Debugging Namespace


Methods

IDebuggerManager Methods
[image]

Public Methods

 | Name | Description
Public method | GetDefaultDebugger | Gets the default debugger.
Top

See Also

IDebuggerManager Interface
Gallio.Runtime.Debugging Namespace


GetDefaultDebugger Method

IDebuggerManager.GetDefaultDebugger Method
[image]

Gets the default debugger.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetDefaultDebugger() As IDebugger
C#
IDebugger GetDefaultDebugger()
C++
IDebugger GetDefaultDebugger() abstract
J#
IDebugger GetDefaultDebugger()
JScript
function GetDefaultDebugger() : IDebugger

Return Value

The default debugger

See Also

IDebuggerManager Interface
Gallio.Runtime.Debugging Namespace


NullDebugger Class

NullDebugger Class
See Also Example Members
[image]

A null implementation of a debugger. All services return do nothing results.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class NullDebugger
Implements IDebugger
C#
public class NullDebugger : IDebugger
C++
ref class NullDebugger : IDebugger
J#
public class NullDebugger implements IDebugger
JScript
public class NullDebugger extends IDebugger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Debugging.NullDebugger

See Also

NullDebugger Members
Gallio.Runtime.Debugging Namespace


NullDebugger Members

NullDebugger Members
See Also Example Constructors Methods
[image]

A null implementation of a debugger. All services return do nothing results.

The following tables list the members exposed by NullDebugger.

Public Constructors

 | Name | Description
Public method | NullDebugger | Initializes a new instance of the NullDebugger class.
Top

Public Methods

 | Name | Description
Public method | AttachToProcess | Attaches the debugger to a process.
Public method | DetachFromProcess | Detaches the debugger from a process.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsAttachedToProcess | Returns true if the debugger is attached to a process.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NullDebugger Class
Gallio.Runtime.Debugging Namespace


NullDebugger Constructor

NullDebugger Constructor
[image]

Initializes a new instance of the NullDebugger class.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NullDebugger()
C++
public:
NullDebugger() sealed
J#
public NullDebugger()
JScript
public function NullDebugger()

See Also

NullDebugger Class
Gallio.Runtime.Debugging Namespace


Methods

NullDebugger Methods
[image]

Public Methods

 | Name | Description
Public method | AttachToProcess | Attaches the debugger to a process.
Public method | DetachFromProcess | Detaches the debugger from a process.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsAttachedToProcess | Returns true if the debugger is attached to a process.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

NullDebugger Class
Gallio.Runtime.Debugging Namespace


AttachToProcess Method

NullDebugger.AttachToProcess Method
[image]

Attaches the debugger to a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AttachToProcess( _
ByVal process As Process _
) As AttachDebuggerResult _
Implements IDebugger.AttachToProcess
C#
public AttachDebuggerResult AttachToProcess(
Process process
)
C++
public:
AttachDebuggerResult AttachToProcess(
Process process
) sealed
J#
public AttachDebuggerResult AttachToProcess(
Process process
)
JScript
public function AttachToProcess(
process : Process
) : AttachDebuggerResult

Parameters

process
The process to which the debugger should be attached

Return Value

A result code to indicate whether the debugger was attached

Implements

IDebugger.AttachToProcess

See Also

NullDebugger Class
Gallio.Runtime.Debugging Namespace


DetachFromProcess Method

NullDebugger.DetachFromProcess Method
[image]

Detaches the debugger from a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function DetachFromProcess( _
ByVal process As Process _
) As DetachDebuggerResult _
Implements IDebugger.DetachFromProcess
C#
public DetachDebuggerResult DetachFromProcess(
Process process
)
C++
public:
DetachDebuggerResult DetachFromProcess(
Process process
) sealed
J#
public DetachDebuggerResult DetachFromProcess(
Process process
)
JScript
public function DetachFromProcess(
process : Process
) : DetachDebuggerResult

Parameters

process
The process from which the debugger should be detached

Return Value

A result code to indicate whether the debugger was detached

Implements

IDebugger.DetachFromProcess

See Also

NullDebugger Class
Gallio.Runtime.Debugging Namespace


IsAttachedToProcess Method

NullDebugger.IsAttachedToProcess Method
[image]

Returns true if the debugger is attached to a process.

Namespace: Gallio.Runtime.Debugging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsAttachedToProcess( _
ByVal process As Process _
) As Boolean _
Implements IDebugger.IsAttachedToProcess
C#
public bool IsAttachedToProcess(
Process process
)
C++
public:
bool IsAttachedToProcess(
Process process
) sealed
J#
public bool IsAttachedToProcess(
Process process
)
JScript
public function IsAttachedToProcess(
process : Process
) : bool

Parameters

process
The process to which the debugger should be attached

Return Value

True if the debugger is already attached

Implements

IDebugger.IsAttachedToProcess

See Also

NullDebugger Class
Gallio.Runtime.Debugging Namespace


Gallio.Runtime.Hosting

Gallio.Runtime.Hosting Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AppDomainUtils | Utilities for working with AppDomains. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | BaseHost | Base implementation of IHost that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseHostFactory | An abstract base class for host factories. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseHostService | Base implementation of IHostService that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | HostAssemblyResolverHook | Attaches to a IHost to provide assembly resolution services. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | HostConfiguration | Describes the runtime configuration of a IHost. This class cannot be inherited.
NestedPublic class | HostConfiguration.AssemblyBindingRedirect | Describes an assembly binding redirection from an old version range to a new version. This class cannot be inherited.
NestedPublic class | HostConfiguration.AssemblyCodeBase | Describes the location of the codebase of a particular assembly version.
NestedPublic class | HostConfiguration.AssemblyDependency | Describes a dependent assembly configuration entry that optionally specifies the codebase, a publisher policy and binding redirects. This class cannot be inherited.
NestedPublic class | HostConfiguration.AssemblyQualification | Describes an assembly name qualification configuration entry that maps an assembly partial name to its full name. This class cannot be inherited.
Public class | HostException | The type of exception thrown when hosting operations fail.
Public class | HostServiceChannelInterop | Provides utilities to interact with a RemoteHostService over a IClientChannel or IServerChannel. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | HostSetup | Specifies a collection of parameters for setting up a IHost. This class cannot be inherited.
Public class | HostUtils | Provides utilities for working with hosts. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | IsolatedAppDomainHost | An isolated app domain host is a IHost the runs code within an isolated AppDomain of this process. Communication with the AppDomain occurs over an inter-AppDomain .Net remoting channel.
Public class | IsolatedAppDomainHostFactory | A factory for initialized IsolatedAppDomainHost hosts.
Public class IsolatedProcessHost

An isolated process host is a IHost that runs code within a new external process. Communication with the external process occurs over an inter-process communication channel.

The host application is copied to a unique temporary folder and configured in place according to the HostSetup. Then it is launched and connected to with inter-process communication. The process is pinged periodically by the BinaryIpcClientChannel. Therefore it can be configured to self-terminate when it looks like the connection has been severed.

Public class | IsolatedProcessHostFactory | A factory for initialized IsolatedProcessHost hosts.
Public class | LocalHost | An implementation of IHost that runs code locally within the current AppDomain.
Public class | LocalHostFactory | A factory for initialized LocalHost hosts.
Public class | RemoteHost
Public class | RemoteHostService | A remotely accessible host service.

Interfaces

 | Interface | Description
Public interface | IHost | A host represents an environment that may be used to perform various services in isolation. For example, a host might provide the ability to run code in an isolated AppDomain of the current process, or it might run code in an isolated process, or connect to an existing remote process.
Public interface | IHostFactory | A host factory encapsulates a policy for creating new IHost instances.
Public interface | IHostService | A host service enables a local client to interact with a remotely executing hosting environment. A host service implementation may choose to implement a keep-alive mechanism to automatically shut itself down when the service is disposed or when it has not received a ping within a set period of time.
Public interface | IRemoteHostService | A specialization of host service designed for hosts that are remotely managed.

Enumerations

 | Enumeration | Description
Public enumeration | ConfigurationFileLocation | Specifies where a IHost should store the temporary configuration file it generates when it is being initialized.


AppDomainUtils Class

AppDomainUtils Class
See Also Example Members
[image]

Utilities for working with AppDomains. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module AppDomainUtils
C#
public static class AppDomainUtils
C++
ref class AppDomainUtils abstract sealed
J#
public final class AppDomainUtils
JScript
public class AppDomainUtils

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.AppDomainUtils

See Also

AppDomainUtils Members
Gallio.Runtime.Hosting Namespace


AppDomainUtils Members

AppDomainUtils Members
See Also Example Methods
[image]

Utilities for working with AppDomains. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AppDomainUtils.

Public Methods

Name | Description
CreateAppDomain | Creates an AppDomain.
CreateRemoteInstance | Creates a remote instance of a type within another AppDomain.
Top

See Also

AppDomainUtils Class
Gallio.Runtime.Hosting Namespace


Methods

AppDomainUtils Methods
[image]

Public Methods

Name | Description
CreateAppDomain | Creates an AppDomain.
CreateRemoteInstance | Creates a remote instance of a type within another AppDomain.
Top

See Also

AppDomainUtils Class
Gallio.Runtime.Hosting Namespace


CreateAppDomain Method

AppDomainUtils.CreateAppDomain Method
[image]

Creates an AppDomain.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateAppDomain( _
ByVal applicationName As String, _
ByVal applicationBaseDirectory As String, _
ByVal configurationFile As String, _
ByVal enableShadowCopy As Boolean _
) As AppDomain
C#
public static AppDomain CreateAppDomain(
string applicationName,
string applicationBaseDirectory,
string configurationFile,
bool enableShadowCopy
)
C++
public:
static AppDomain CreateAppDomain(
String applicationName,
String applicationBaseDirectory,
String configurationFile,
bool enableShadowCopy
)
J#
public static AppDomain CreateAppDomain(
string applicationName,
string applicationBaseDirectory,
string configurationFile,
bool enableShadowCopy
)
JScript
public static function CreateAppDomain(
applicationName : String,
applicationBaseDirectory : String,
configurationFile : String,
enableShadowCopy : bool
) : AppDomain

Parameters

applicationName
The application name for the new AppDomain, or null if none
applicationBaseDirectory
The application base directory for the new AppDomain, or null to use the current one
configurationFile
The configuration file for the new AppDomain, or null to use the current one
enableShadowCopy
If true, enables shadow copying within the AppDomain

Return Value

The new AppDomain

See Also

AppDomainUtils Class
Gallio.Runtime.Hosting Namespace


CreateRemoteInstance Method

AppDomainUtils.CreateRemoteInstance Method
[image]

Creates a remote instance of a type within another AppDomain.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateRemoteInstance( _
ByVal appDomain As AppDomain, _
ByVal type As Type, _
ByVal ParamArray args As Object() _
) As Object
C#
public static object CreateRemoteInstance(
AppDomain appDomain,
Type type,
params object[] args
)
C++
public:
static Object CreateRemoteInstance(
AppDomain appDomain,
Type type,
... array<Object>^ args
)
J#
public static object CreateRemoteInstance(
AppDomain appDomain,
Type type,
object[] args
)
JScript
public static function CreateRemoteInstance(
appDomain : AppDomain,
type : Type,
ParamArrayAttribute args : Object[]
) : Object

Parameters

appDomain
The AppDomain in which to create the instance
type
The type to instantiate
args
The constructor arguments for the type

Return Value

The remote instance

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if appDomain or type is null

Remarks

This method first uses CreateInstanceAndUnwrap to try create an instance of the type. If that fails, it uses CreateInstanceFromAndUnwrap to load the assembly that contains the type into the AppDomain then create an instance of the type.

See Also

AppDomainUtils Class
Gallio.Runtime.Hosting Namespace


BaseHost Class

BaseHost Class
See Also Example Members
[image]

Base implementation of IHost that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseHost
Implements IHost, IDisposable
C#
public abstract class BaseHost : IHost, IDisposable
C++
ref class BaseHost abstract : IHost, IDisposable
J#
public class BaseHost implements IHost, IDisposable
JScript
public class BaseHost extends IHost, IDisposable

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHost
Gallio.Runtime.Hosting.LocalHost
Gallio.Runtime.Hosting.RemoteHost

See Also

BaseHost Members
Gallio.Runtime.Hosting Namespace


BaseHost Members

BaseHost Members
See Also Example Constructors Properties Methods Events
[image]

Base implementation of IHost that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseHost.

Protected Constructors

 | Name | Description
Family method | BaseHost | Creates a host.
Top

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected.
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected.
Family property | HostSetup | Gets the internal host setup information without copying it.
Family property | Logger | Gets the logger.
Top

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service.
Public method | Disconnect | Disconnects the host.
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment.
Public method | GetHostSetup | Gets a deep copy of the host setup information.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it.
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it.
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients.
Family method | ReleaseHostService | Releases the host service.
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed.
Top

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately.
Top

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


BaseHost Constructor

BaseHost Constructor
[image]

Creates a host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
)
C#
protected BaseHost(
HostSetup hostSetup,
ILogger logger
)
C++
protected:
BaseHost(
HostSetup hostSetup,
ILogger logger
) sealed
J#
protected BaseHost(
HostSetup hostSetup,
ILogger logger
)
JScript
protected function BaseHost(
hostSetup : HostSetup,
logger : ILogger
)

Parameters

hostSetup
The host setup
logger
The logger for host message output

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostSetup or logger is null

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Properties

BaseHost Properties
[image]

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected.
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected.
Family property | HostSetup | Gets the internal host setup information without copying it.
Family property | Logger | Gets the logger.
Top

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


HostService Property

BaseHost.HostService Property
[image]

Gets an reference to the host service, or null if not connected.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HostService As IHostService
C#
protected IHostService HostService { get; }
C++
protected property IHostService HostService sealed {
IHostService get();
}
J#
/** property */
protected IHostService get_HostService();
JScript
protected function get HostService() : IHostService

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


HostSetup Property

BaseHost.HostSetup Property
[image]

Gets the internal host setup information without copying it.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HostSetup As HostSetup
C#
protected HostSetup HostSetup { get; }
C++
protected property HostSetup HostSetup sealed {
HostSetup get();
}
J#
/** property */
protected HostSetup get_HostSetup();
JScript
protected function get HostSetup() : HostSetup

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


IsConnected Property

BaseHost.IsConnected Property
[image]

Returns true if the host is connected.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsConnected As Boolean _
Implements IHost.IsConnected
C#
public bool IsConnected { get; }
C++
public property bool IsConnected sealed {
bool get();
}
J#
/** property */
public bool get_IsConnected();
JScript
public function get IsConnected() : bool

Implements

IHost.IsConnected

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


IsLocal Property

BaseHost.IsLocal Property
[image]

Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsLocal As Boolean _
Implements IHost.IsLocal
C#
public abstract bool IsLocal { get; }
C++
public abstract property bool IsLocal abstract {
bool get();
}
J#
/** property */
public bool get_IsLocal();
JScript
public function get IsLocal() : bool

Implements

IHost.IsLocal

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Logger Property

BaseHost.Logger Property
[image]

Gets the logger.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Logger As ILogger
C#
protected ILogger Logger { get; }
C++
protected property ILogger Logger sealed {
ILogger get();
}
J#
/** property */
protected ILogger get_Logger();
JScript
protected function get Logger() : ILogger

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Methods

BaseHost Methods
[image]

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service.
Public method | Disconnect | Disconnects the host.
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment.
Public method | GetHostSetup | Gets a deep copy of the host setup information.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it.
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it.
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients.
Family method | ReleaseHostService | Releases the host service.
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed.
Top

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


AcquireHostService Method

BaseHost.AcquireHostService Method
[image]

Gets the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function AcquireHostService() As IHostService
C#
protected abstract IHostService AcquireHostService()
C++
protected:
IHostService AcquireHostService() abstract
J#
protected abstract IHostService AcquireHostService()
JScript
protected abstract function AcquireHostService() : IHostService

Return Value

The host service, or null if the host service was not available

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


AttachDebuggerIfNeeded Method

BaseHost.AttachDebuggerIfNeeded Method
[image]

Attaches the debugger to a process if the host settings require it.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AttachDebuggerIfNeeded( _
ByVal debuggerManager As IDebuggerManager, _
ByVal debuggedProcess As Process _
)
C#
protected void AttachDebuggerIfNeeded(
IDebuggerManager debuggerManager,
Process debuggedProcess
)
C++
protected:
void AttachDebuggerIfNeeded(
IDebuggerManager debuggerManager,
Process debuggedProcess
) sealed
J#
protected void AttachDebuggerIfNeeded(
IDebuggerManager debuggerManager,
Process debuggedProcess
)
JScript
protected function AttachDebuggerIfNeeded(
debuggerManager : IDebuggerManager,
debuggedProcess : Process
)

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Connect Method

BaseHost.Connect Method
[image]

Initializes the host and connects to the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Connect()
C#
public void Connect()
C++
public:
void Connect() sealed
J#
public void Connect()
JScript
public function Connect()

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the host has already been initialized
ObjectDisposedException | Thrown if the host has been disposed
HostException | Thrown if an exception occurred while connecting to the host

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


DetachDebuggerIfNeeded Method

BaseHost.DetachDebuggerIfNeeded Method
[image]

Detaches the debugger from a process if the host settings require it.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub DetachDebuggerIfNeeded()
C#
protected void DetachDebuggerIfNeeded()
C++
protected:
void DetachDebuggerIfNeeded() sealed
J#
protected void DetachDebuggerIfNeeded()
JScript
protected function DetachDebuggerIfNeeded()

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Disconnect Method

BaseHost.Disconnect Method
[image]

Disconnects the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Disconnect() _
Implements IHost.Disconnect
C#
public void Disconnect()
C++
public:
void Disconnect() sealed
J#
public void Disconnect()
JScript
public function Disconnect()

Implements

IHost.Disconnect

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method

BaseHost.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Dispose (Boolean) | Disposes the host.

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method ()

BaseHost.Dispose Method ()
See Also Example
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace
BaseHost.Dispose Overload List


Dispose Method (Boolean)

BaseHost.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace
BaseHost.Dispose Overload List


GetHostService Method

BaseHost.GetHostService Method
[image]

Gets a host service that can be used to perform operations within the host's environment.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHostService() As IHostService _
Implements IHost.GetHostService
C#
public IHostService GetHostService()
C++
public:
IHostService GetHostService() sealed
J#
public IHostService GetHostService()
JScript
public function GetHostService() : IHostService

Implements

IHost.GetHostService

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


GetHostSetup Method

BaseHost.GetHostSetup Method
[image]

Gets a deep copy of the host setup information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetHostSetup() As HostSetup _
Implements IHost.GetHostSetup
C#
public HostSetup GetHostSetup()
C++
public:
HostSetup GetHostSetup() sealed
J#
public HostSetup GetHostSetup()
JScript
public function GetHostSetup() : HostSetup

Implements

IHost.GetHostSetup

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


NotifyDisconnected Method

BaseHost.NotifyDisconnected Method
[image]

Sets the state of the host to disconnected and notifies clients.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub NotifyDisconnected()
C#
protected void NotifyDisconnected()
C++
protected:
void NotifyDisconnected() sealed
J#
protected void NotifyDisconnected()
JScript
protected function NotifyDisconnected()

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


ReleaseHostService Method

BaseHost.ReleaseHostService Method
[image]

Releases the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ReleaseHostService( _
ByVal hostService As IHostService _
)
C#
protected virtual void ReleaseHostService(
IHostService hostService
)
C++
protected:
virtual void ReleaseHostService(
IHostService hostService
)
J#
protected virtual void ReleaseHostService(
IHostService hostService
)
JScript
protected virtual function ReleaseHostService(
hostService : IHostService
)

Parameters

hostService
The host service that is being released, not null

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


ThrowIfDisposed Method

BaseHost.ThrowIfDisposed Method
[image]

Throws an exception if the host has been disposed.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ThrowIfDisposed()
C#
protected void ThrowIfDisposed()
C++
protected:
void ThrowIfDisposed() sealed
J#
protected void ThrowIfDisposed()
JScript
protected function ThrowIfDisposed()

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Events

BaseHost Events
[image]

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately.
Top

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


Disconnected Event

BaseHost.Disconnected Event
[image]

An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Disconnected As EventHandler
C#
public event EventHandler Disconnected
C++
public:
virtual event EventHandler Disconnected {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Disconnected(EventHandler value);

/** event */
public final void remove_Disconnected(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

IHost.Disconnected

See Also

BaseHost Class
Gallio.Runtime.Hosting Namespace


BaseHostFactory Class

BaseHostFactory Class
See Also Example Members
[image]

An abstract base class for host factories. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseHostFactory
Implements IHostFactory
C#
public abstract class BaseHostFactory : IHostFactory
C++
ref class BaseHostFactory abstract : IHostFactory
J#
public class BaseHostFactory implements IHostFactory
JScript
public class BaseHostFactory extends IHostFactory

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHostFactory
Gallio.Runtime.Hosting.IsolatedAppDomainHostFactory
Gallio.Runtime.Hosting.IsolatedProcessHostFactory
Gallio.Runtime.Hosting.LocalHostFactory

See Also

BaseHostFactory Members
Gallio.Runtime.Hosting Namespace


BaseHostFactory Members

BaseHostFactory Members
See Also Example Constructors Methods
[image]

An abstract base class for host factories. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseHostFactory.

Protected Constructors

 | Name | Description
Family method | BaseHostFactory | Initializes a new instance of the BaseHostFactory class.
Top

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseHostFactory Class
Gallio.Runtime.Hosting Namespace


BaseHostFactory Constructor

BaseHostFactory Constructor
[image]

Initializes a new instance of the BaseHostFactory class.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseHostFactory()
C++
protected:
BaseHostFactory() sealed
J#
protected BaseHostFactory()
JScript
protected function BaseHostFactory()

See Also

BaseHostFactory Class
Gallio.Runtime.Hosting Namespace


Methods

BaseHostFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseHostFactory Class
Gallio.Runtime.Hosting Namespace


CreateHost Method

BaseHostFactory.CreateHost Method
[image]

Creates a host instance.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateHost( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
) As IHost _
Implements IHostFactory.CreateHost
C#
public IHost CreateHost(
HostSetup hostSetup,
ILogger logger
)
C++
public:
IHost CreateHost(
HostSetup hostSetup,
ILogger logger
) sealed
J#
public IHost CreateHost(
HostSetup hostSetup,
ILogger logger
)
JScript
public function CreateHost(
hostSetup : HostSetup,
logger : ILogger
) : IHost

Parameters

hostSetup
The host setup
logger
The logger for host message output

Return Value

The newly created host

Implements

IHostFactory.CreateHost

See Also

BaseHostFactory Class
Gallio.Runtime.Hosting Namespace


CreateHostImpl Method

BaseHostFactory.CreateHostImpl Method
[image]

Creates the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function CreateHostImpl( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
) As IHost
C#
protected abstract IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
C++
protected:
IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
) abstract
J#
protected abstract IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
JScript
protected abstract function CreateHostImpl(
hostSetup : HostSetup,
logger : ILogger
) : IHost

Parameters

hostSetup
The canonicalized host setup, non-null
logger
The logger, non-null

Return Value

The host

See Also

BaseHostFactory Class
Gallio.Runtime.Hosting Namespace


BaseHostService Class

BaseHostService Class
See Also Example Members
[image]

Base implementation of IHostService that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseHostService
Inherits LongLivedMarshalByRefObject
Implements IHostService, IDisposable
C#
public abstract class BaseHostService : LongLivedMarshalByRefObject, IHostService, IDisposable
C++
ref class BaseHostService abstract : LongLivedMarshalByRefObject, IHostService, IDisposable
J#
public class BaseHostService extends LongLivedMarshalByRefObject implements IHostService, IDisposable
JScript
public class BaseHostService extends LongLivedMarshalByRefObject, IHostService, IDisposable

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runtime.Hosting.BaseHostService
Gallio.Runtime.Hosting.RemoteHostService

See Also

BaseHostService Members
Gallio.Runtime.Hosting Namespace


BaseHostService Members

BaseHostService Members
See Also Example Constructors Methods
[image]

Base implementation of IHostService that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseHostService.

Protected Constructors

 | Name | Description
Family method | BaseHostService | Initializes a new instance of the BaseHostService class.
Top

Public Methods

 | Name | Description
Public method | CreateInstance | Creates an instance of a remote object given an assembly name and type name.
Public method | CreateInstanceFrom | Creates an instance of a remote object given an assembly path and type name.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Do | Asks the host to perform the specified action remotely. The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Ping | Pings the host to verify and maintain connectivity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateInstanceFromImpl | Internal implementation of CreateInstanceFrom.
Family method | CreateInstanceImpl | Internal implementation of CreateInstance.
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | DoImpl | Internal implementation of Do.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | PingImpl | Internal implementation of Ping.
Family method | ThrowIfDisposed | Throws an exception if the host service has been disposed.
Top

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


BaseHostService Constructor

BaseHostService Constructor
[image]

Initializes a new instance of the BaseHostService class.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseHostService()
C++
protected:
BaseHostService() sealed
J#
protected BaseHostService()
JScript
protected function BaseHostService()

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


Methods

BaseHostService Methods
[image]

Public Methods

 | Name | Description
Public method | CreateInstance | Creates an instance of a remote object given an assembly name and type name.
Public method | CreateInstanceFrom | Creates an instance of a remote object given an assembly path and type name.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Do | Asks the host to perform the specified action remotely. The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Ping | Pings the host to verify and maintain connectivity.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateInstanceFromImpl | Internal implementation of CreateInstanceFrom.
Family method | CreateInstanceImpl | Internal implementation of CreateInstance.
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | DoImpl | Internal implementation of Do.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | PingImpl | Internal implementation of Ping.
Family method | ThrowIfDisposed | Throws an exception if the host service has been disposed.
Top

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


CreateInstance Method

BaseHostService.CreateInstance Method
[image]

Creates an instance of a remote object given an assembly name and type name.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateInstance( _
ByVal assemblyName As String, _
ByVal typeName As String _
) As ObjectHandle _
Implements IHostService.CreateInstance
C#
public ObjectHandle CreateInstance(
string assemblyName,
string typeName
)
C++
public:
ObjectHandle CreateInstance(
String assemblyName,
String typeName
) sealed
J#
public ObjectHandle CreateInstance(
string assemblyName,
string typeName
)
JScript
public function CreateInstance(
assemblyName : String,
typeName : String
) : ObjectHandle

Parameters

assemblyName
The name of assembly that contains the type
typeName
The full name of the type

Return Value

The object handle of the instance

Implements

IHostService.CreateInstance

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


CreateInstanceFrom Method

BaseHostService.CreateInstanceFrom Method
[image]

Creates an instance of a remote object given an assembly path and type name.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateInstanceFrom( _
ByVal assemblyPath As String, _
ByVal typeName As String _
) As ObjectHandle _
Implements IHostService.CreateInstanceFrom
C#
public ObjectHandle CreateInstanceFrom(
string assemblyPath,
string typeName
)
C++
public:
ObjectHandle CreateInstanceFrom(
String assemblyPath,
String typeName
) sealed
J#
public ObjectHandle CreateInstanceFrom(
string assemblyPath,
string typeName
)
JScript
public function CreateInstanceFrom(
assemblyPath : String,
typeName : String
) : ObjectHandle

Parameters

assemblyPath
The path of assembly that contains the type
typeName
The full name of the type

Return Value

The object handle of the instance

Implements

IHostService.CreateInstanceFrom

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


CreateInstanceFromImpl Method

BaseHostService.CreateInstanceFromImpl Method
[image]

Internal implementation of CreateInstanceFrom.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateInstanceFromImpl( _
ByVal assemblyPath As String, _
ByVal typeName As String _
) As ObjectHandle
C#
protected virtual ObjectHandle CreateInstanceFromImpl(
string assemblyPath,
string typeName
)
C++
protected:
virtual ObjectHandle CreateInstanceFromImpl(
String assemblyPath,
String typeName
)
J#
protected virtual ObjectHandle CreateInstanceFromImpl(
string assemblyPath,
string typeName
)
JScript
protected virtual function CreateInstanceFromImpl(
assemblyPath : String,
typeName : String
) : ObjectHandle

Parameters

assemblyPath
The assembly path, not null
typeName
The type name, not null

Return Value

The created object handle

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


CreateInstanceImpl Method

BaseHostService.CreateInstanceImpl Method
[image]

Internal implementation of CreateInstance.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateInstanceImpl( _
ByVal assemblyName As String, _
ByVal typeName As String _
) As ObjectHandle
C#
protected virtual ObjectHandle CreateInstanceImpl(
string assemblyName,
string typeName
)
C++
protected:
virtual ObjectHandle CreateInstanceImpl(
String assemblyName,
String typeName
)
J#
protected virtual ObjectHandle CreateInstanceImpl(
string assemblyName,
string typeName
)
JScript
protected virtual function CreateInstanceImpl(
assemblyName : String,
typeName : String
) : ObjectHandle

Parameters

assemblyName
The assembly name, not null
typeName
The type name, not null

Return Value

The created object handle

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


Dispose Method

BaseHostService.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Dispose (Boolean) | Disposes the host service.

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


Dispose Method ()

BaseHostService.Dispose Method ()
See Also Example
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace
BaseHostService.Dispose Overload List


Dispose Method (Boolean)

BaseHostService.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace
BaseHostService.Dispose Overload List


Do Generic Method

BaseHostService.Do Generic Method
[image]

Asks the host to perform the specified action remotely.

The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null).

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Do(Of TArg, TResult)( _
ByVal func As Func(Of TArg, TResult), _
ByVal arg As TArg _
) _
Implements IHostService.Do
C#
public TResult Do<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
C++
public:
TResult Do<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
) sealed
J#
public TResult Do<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
JScript
JScript does not support generic types and methods.

Parameters

func
The action to perform
arg
The argument value, if any

Return Value

The result value, if any

Implements

IHostService.Do

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


DoImpl Generic Method

BaseHostService.DoImpl Generic Method
[image]

Internal implementation of Do.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function DoImpl(Of TArg, TResult)( _
ByVal func As Func(Of TArg, TResult), _
ByVal arg As TArg _
)
C#
protected virtual TResult DoImpl<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
C++
protected:
virtual TResult DoImpl<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
J#
protected virtual TResult DoImpl<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
JScript
JScript does not support generic types and methods.

Type Parameters

TArg
The argument type
TResult
The result type

Parameters

func
The action to perform, not null
arg
The argument value, if any

Return Value

The result value, if any

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


Ping Method

BaseHostService.Ping Method
[image]

Pings the host to verify and maintain connectivity.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Ping() _
Implements IHostService.Ping
C#
public void Ping()
C++
public:
void Ping() sealed
J#
public void Ping()
JScript
public function Ping()

Implements

IHostService.Ping

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


PingImpl Method

BaseHostService.PingImpl Method
[image]

Internal implementation of Ping.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PingImpl()
C#
protected virtual void PingImpl()
C++
protected:
virtual void PingImpl()
J#
protected virtual void PingImpl()
JScript
protected virtual function PingImpl()

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


ThrowIfDisposed Method

BaseHostService.ThrowIfDisposed Method
[image]

Throws an exception if the host service has been disposed.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ThrowIfDisposed()
C#
protected void ThrowIfDisposed()
C++
protected:
void ThrowIfDisposed() sealed
J#
protected void ThrowIfDisposed()
JScript
protected function ThrowIfDisposed()

See Also

BaseHostService Class
Gallio.Runtime.Hosting Namespace


ConfigurationFileLocation Enumeration

ConfigurationFileLocation Enumeration
[image]

Specifies where a IHost should store the temporary configuration file it generates when it is being initialized.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum ConfigurationFileLocation
C#
public enum ConfigurationFileLocation
C++
public enum class ConfigurationFileLocation
J#
public enum ConfigurationFileLocation
JScript
public enum ConfigurationFileLocation

Members

Member Name | Description
None | Do not create a configuration file.
Temp | Stores the configuration file in the user's temporary directory.
AppBase | Stores the configuration file in the application base directory of the hosted components.

See Also

Gallio.Runtime.Hosting Namespace


HostAssemblyResolverHook Class

HostAssemblyResolverHook Class
See Also Example Members
[image]

Attaches to a IHost to provide assembly resolution services. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module HostAssemblyResolverHook
C#
public static class HostAssemblyResolverHook
C++
ref class HostAssemblyResolverHook abstract sealed
J#
public final class HostAssemblyResolverHook
JScript
public class HostAssemblyResolverHook

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostAssemblyResolverHook

See Also

HostAssemblyResolverHook Members
Gallio.Runtime.Hosting Namespace


HostAssemblyResolverHook Members

HostAssemblyResolverHook Members
See Also Example Methods
[image]

Attaches to a IHost to provide assembly resolution services. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by HostAssemblyResolverHook.

Public Methods

Name | Description
Bootstrap | Installs an assembly resolver that provides access to the installation path using the AssemblyResolverBootstrap. Does nothing if the host is local.
InstallCallback | Installs an assembly resolver that delegates to the creating AppDomain's assembly resolver to locate assemblies whenever the host is unable to find them. Does nothing if the host is local.
Top

See Also

HostAssemblyResolverHook Class
Gallio.Runtime.Hosting Namespace


Methods

HostAssemblyResolverHook Methods
[image]

Public Methods

Name | Description
Bootstrap | Installs an assembly resolver that provides access to the installation path using the AssemblyResolverBootstrap. Does nothing if the host is local.
InstallCallback | Installs an assembly resolver that delegates to the creating AppDomain's assembly resolver to locate assemblies whenever the host is unable to find them. Does nothing if the host is local.
Top

See Also

HostAssemblyResolverHook Class
Gallio.Runtime.Hosting Namespace


Bootstrap Method

HostAssemblyResolverHook.Bootstrap Method
[image]

Installs an assembly resolver that provides access to the installation path using the AssemblyResolverBootstrap.

Does nothing if the host is local.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Bootstrap( _
ByVal host As IHost, _
ByVal runtimePath As String _
)
C#
public static void Bootstrap(
IHost host,
string runtimePath
)
C++
public:
static void Bootstrap(
IHost host,
String runtimePath
)
J#
public static void Bootstrap(
IHost host,
string runtimePath
)
JScript
public static function Bootstrap(
host : IHost,
runtimePath : String
)

Parameters

host
The host
runtimePath
The Gallio runtime path

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if host or runtimePath is null

Remarks

This hook is recommended for newly created domains.

See Also

HostAssemblyResolverHook Class
Gallio.Runtime.Hosting Namespace


InstallCallback Method

HostAssemblyResolverHook.InstallCallback Method
[image]

Installs an assembly resolver that delegates to the creating AppDomain's assembly resolver to locate assemblies whenever the host is unable to find them.

Does nothing if the host is local.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub InstallCallback( _
ByVal host As IHost _
)
C#
public static void InstallCallback(
IHost host
)
C++
public:
static void InstallCallback(
IHost host
)
J#
public static void InstallCallback(
IHost host
)
JScript
public static function InstallCallback(
host : IHost
)

Parameters

host
The host

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if host is null

Remarks

This hook is useful for testing but should not be used in production code.

See Also

HostAssemblyResolverHook Class
Gallio.Runtime.Hosting Namespace


HostConfiguration Class

HostConfiguration Class
See Also Example Members
[image]

Describes the runtime configuration of a IHost. This class cannot be inherited.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlRootAttribute("hostConfiguration", Namespace := "http://www.gallio.org/"), _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class HostConfiguration
Implements IEquatable(Of HostConfiguration)
C#
[SerializableAttribute]
[XmlRootAttribute("hostConfiguration", Namespace = "http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class HostConfiguration : IEquatable<HostConfiguration>
C++
[SerializableAttribute]
[XmlRootAttribute(L"hostConfiguration", Namespace = L"http://www.gallio.org/")]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class HostConfiguration sealed : IEquatable<HostConfiguration>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlRootAttribute("hostConfiguration", Namespace = "http://www.gallio.org/") */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class HostConfiguration implements IEquatable<HostConfiguration>
JScript
public
SerializableAttribute
XmlRootAttribute("hostConfiguration", Namespace = "http://www.gallio.org/")
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class HostConfiguration extends IEquatable<HostConfiguration>

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostConfiguration

See Also

HostConfiguration Members
Gallio.Runtime.Hosting Namespace


HostConfiguration Members

HostConfiguration Members
See Also Example Constructors Properties Methods
[image]

Describes the runtime configuration of a IHost. This class cannot be inherited.

The following tables list the members exposed by HostConfiguration.

Public Constructors

 | Name | Description
Public method | HostConfiguration | Creates a default host configuration.
Top

Public Properties

 | Name | Description
Public property | AssemblyDependencies | Gets a mutable list of assembly dependencies.
Public property | AssemblyQualifications | Gets a mutable list of assembly qualifications.
Public property | AssertUiEnabled | Gets or sets whether the Assert failure dialog is enabled.
Public property | ConfigurationXml | Gets or sets the primary Xml configuration data, or null if none.
Public property | LegacyUnhandledExceptionPolicyEnabled | Gets or sets whether the legacy unhandled exception policy is enabled.
Public property | RemotingCustomErrorsEnabled | Gets or sets whether remoting exceptions are substituted with custom errors instead of being passed through to the remote client.
Public property | SupportedRuntimeVersions | Gets a mutable list of supported runtime versions in order of preference. When the list is empty, the runtime version used to build the application is used. Otherwise one of the supported runtimes in the list is used.
Top

Public Methods

 | Name | Description
Public method | AddAssemblyBinding | Overloaded. Adds a binding to the configuration for the specified assembly.
Public method | AddAssemblyDependency | Adds an assembly dependency element if a suitable one does not already exist.
Public method | AddAssemblyQualification | Adds an assembly qualification element if a suitable one does not already exist.
Public method | Copy | Creates a copy of the host configuration information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and returns the combined Xml configuration.
Public method | WriteTo | Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and writes the combined Xml configuration to a TextWriter.
Public method | WriteToFile | Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and writes the combined Xml configuration to a file with the given path.
Top

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


HostConfiguration Constructor

HostConfiguration Constructor
[image]

Creates a default host configuration.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HostConfiguration()
C++
public:
HostConfiguration() sealed
J#
public HostConfiguration()
JScript
public function HostConfiguration()

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


Properties

HostConfiguration Properties
[image]

Public Properties

 | Name | Description
Public property | AssemblyDependencies | Gets a mutable list of assembly dependencies.
Public property | AssemblyQualifications | Gets a mutable list of assembly qualifications.
Public property | AssertUiEnabled | Gets or sets whether the Assert failure dialog is enabled.
Public property | ConfigurationXml | Gets or sets the primary Xml configuration data, or null if none.
Public property | LegacyUnhandledExceptionPolicyEnabled | Gets or sets whether the legacy unhandled exception policy is enabled.
Public property | RemotingCustomErrorsEnabled | Gets or sets whether remoting exceptions are substituted with custom errors instead of being passed through to the remote client.
Public property | SupportedRuntimeVersions | Gets a mutable list of supported runtime versions in order of preference. When the list is empty, the runtime version used to build the application is used. Otherwise one of the supported runtimes in the list is used.
Top

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


AssemblyDependencies Property

HostConfiguration.AssemblyDependencies Property
[image]

Gets a mutable list of assembly dependencies.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("assemblyDependency", GetType(HostConfiguration_x002B_AssemblyDependency), IsNullable := False), _
XmlArrayAttribute("assemblyDependencies", IsNullable := False)>
Public ReadOnly Property AssemblyDependencies As List(Of AssemblyDependency)
C#
[XmlArrayItemAttribute("assemblyDependency", typeof(HostConfiguration_x002B_AssemblyDependency), IsNullable = False)]
[XmlArrayAttribute("assemblyDependencies", IsNullable = False)]
public List<AssemblyDependency> AssemblyDependencies { get; }
C++
[XmlArrayItemAttribute(L"assemblyDependency", typeof(HostConfiguration_x002B_AssemblyDependency), IsNullable = False)]
[XmlArrayAttribute(L"assemblyDependencies", IsNullable = False)]
public property List<AssemblyDependency> AssemblyDependencies sealed {
List<AssemblyDependency> get();
}
J#
/** @attribute XmlArrayItemAttribute("assemblyDependency", typeof(HostConfiguration_x002B_AssemblyDependency), IsNullable = False) */
/** @attribute XmlArrayAttribute("assemblyDependencies", IsNullable = False) */
/** property */
public List<AssemblyDependency> get_AssemblyDependencies();
JScript
public function get AssemblyDependencies() : List<AssemblyDependency>

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


AssemblyQualifications Property

HostConfiguration.AssemblyQualifications Property
[image]

Gets a mutable list of assembly qualifications.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("assemblyQualifications", IsNullable := False), _
XmlArrayItemAttribute("assemblyQualification", GetType(HostConfiguration_x002B_AssemblyQualification), IsNullable := False)>
Public ReadOnly Property AssemblyQualifications As List(Of AssemblyQualification)
C#
[XmlArrayAttribute("assemblyQualifications", IsNullable = False)]
[XmlArrayItemAttribute("assemblyQualification", typeof(HostConfiguration_x002B_AssemblyQualification), IsNullable = False)]
public List<AssemblyQualification> AssemblyQualifications { get; }
C++
[XmlArrayAttribute(L"assemblyQualifications", IsNullable = False)]
[XmlArrayItemAttribute(L"assemblyQualification", typeof(HostConfiguration_x002B_AssemblyQualification), IsNullable = False)]
public property List<AssemblyQualification> AssemblyQualifications sealed {
List<AssemblyQualification> get();
}
J#
/** @attribute XmlArrayAttribute("assemblyQualifications", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("assemblyQualification", typeof(HostConfiguration_x002B_AssemblyQualification), IsNullable = False) */
/** property */
public List<AssemblyQualification> get_AssemblyQualifications();
JScript
public function get AssemblyQualifications() : List<AssemblyQualification>

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


AssertUiEnabled Property

HostConfiguration.AssertUiEnabled Property
[image]

Gets or sets whether the Assert failure dialog is enabled.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assertUiEnabled")>
Public Property AssertUiEnabled As Boolean
C#
[XmlAttributeAttribute("assertUiEnabled")]
public bool AssertUiEnabled { get; set; }
C++
[XmlAttributeAttribute(L"assertUiEnabled")]
public property bool AssertUiEnabled sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("assertUiEnabled") */
/** property */
public bool get_AssertUiEnabled();

/** property */
public void set_AssertUiEnabled(bool value);
JScript
public function get AssertUiEnabled() : bool

public function set AssertUiEnabled(value : bool);

Property Value

The default value is false which prevents the assertion dialog from appearing when an assertion fails.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


ConfigurationXml Property

HostConfiguration.ConfigurationXml Property
[image]

Gets or sets the primary Xml configuration data, or null if none.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("configurationXml", IsNullable := False)>
Public Property ConfigurationXml As String
C#
[XmlElementAttribute("configurationXml", IsNullable = False)]
public string ConfigurationXml { get; set; }
C++
[XmlElementAttribute(L"configurationXml", IsNullable = False)]
public property string ConfigurationXml sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("configurationXml", IsNullable = False) */
/** property */
public string get_ConfigurationXml();

/** property */
public void set_ConfigurationXml(string value);
JScript
public function get ConfigurationXml() : String

public function set ConfigurationXml(value : String);

Property Value

The default value is null.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


LegacyUnhandledExceptionPolicyEnabled Property

HostConfiguration.LegacyUnhandledExceptionPolicyEnabled Property
See Also Example
[image]

Gets or sets whether the legacy unhandled exception policy is enabled.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("legacyUnhandledExceptionPolicyEnabled")>
Public Property LegacyUnhandledExceptionPolicyEnabled As Boolean
C#
[XmlAttributeAttribute("legacyUnhandledExceptionPolicyEnabled")]
public bool LegacyUnhandledExceptionPolicyEnabled { get; set; }
C++
[XmlAttributeAttribute(L"legacyUnhandledExceptionPolicyEnabled")]
public property bool LegacyUnhandledExceptionPolicyEnabled sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("legacyUnhandledExceptionPolicyEnabled") */
/** property */
public bool get_LegacyUnhandledExceptionPolicyEnabled();

/** property */
public void set_LegacyUnhandledExceptionPolicyEnabled(bool value);
JScript
public function get LegacyUnhandledExceptionPolicyEnabled() : bool

public function set LegacyUnhandledExceptionPolicyEnabled(value : bool);

Property Value

The default value is true which prevents the application from terminating abruptly when an unhandled exception occurs.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


RemotingCustomErrorsEnabled Property

HostConfiguration.RemotingCustomErrorsEnabled Property
[image]

Gets or sets whether remoting exceptions are substituted with custom errors instead of being passed through to the remote client.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("remotingCustomErrorsEnabled")>
Public Property RemotingCustomErrorsEnabled As Boolean
C#
[XmlAttributeAttribute("remotingCustomErrorsEnabled")]
public bool RemotingCustomErrorsEnabled { get; set; }
C++
[XmlAttributeAttribute(L"remotingCustomErrorsEnabled")]
public property bool RemotingCustomErrorsEnabled sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("remotingCustomErrorsEnabled") */
/** property */
public bool get_RemotingCustomErrorsEnabled();

/** property */
public void set_RemotingCustomErrorsEnabled(bool value);
JScript
public function get RemotingCustomErrorsEnabled() : bool

public function set RemotingCustomErrorsEnabled(value : bool);

Property Value

The default value is false which ensures that the remote client receives all exception details.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


SupportedRuntimeVersions Property

HostConfiguration.SupportedRuntimeVersions Property
[image]

Gets a mutable list of supported runtime versions in order of preference. When the list is empty, the runtime version used to build the application is used. Otherwise one of the supported runtimes in the list is used.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("supportedRuntimeVersions", IsNullable := False), _
XmlArrayItemAttribute("supportedRuntimeVersion", GetType(String), IsNullable := False)>
Public ReadOnly Property SupportedRuntimeVersions As List(Of String)
C#
[XmlArrayAttribute("supportedRuntimeVersions", IsNullable = False)]
[XmlArrayItemAttribute("supportedRuntimeVersion", typeof(String), IsNullable = False)]
public List<string> SupportedRuntimeVersions { get; }
C++
[XmlArrayAttribute(L"supportedRuntimeVersions", IsNullable = False)]
[XmlArrayItemAttribute(L"supportedRuntimeVersion", typeof(String), IsNullable = False)]
public property List<string> SupportedRuntimeVersions sealed {
List<string> get();
}
J#
/** @attribute XmlArrayAttribute("supportedRuntimeVersions", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("supportedRuntimeVersion", typeof(String), IsNullable = False) */
/** property */
public List<string> get_SupportedRuntimeVersions();
JScript
public function get SupportedRuntimeVersions() : List<string>

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


Methods

HostConfiguration Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssemblyBinding | Overloaded. Adds a binding to the configuration for the specified assembly.
Public method | AddAssemblyDependency | Adds an assembly dependency element if a suitable one does not already exist.
Public method | AddAssemblyQualification | Adds an assembly qualification element if a suitable one does not already exist.
Public method | Copy | Creates a copy of the host configuration information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and returns the combined Xml configuration.
Public method | WriteTo | Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and writes the combined Xml configuration to a TextWriter.
Public method | WriteToFile | Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and writes the combined Xml configuration to a file with the given path.
Top

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


AddAssemblyBinding Method

HostConfiguration.AddAssemblyBinding Method

Adds a binding to the configuration for the specified assembly.

Overload List

 | Name | Description
Public method | AddAssemblyBinding (Assembly, Boolean) | Adds a binding to the configuration for the specified assembly.
Public method | AddAssemblyBinding (AssemblyName, String, Boolean) | Adds a binding to the configuration for the specified assembly.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


AddAssemblyBinding Method (Assembly, Boolean)

HostConfiguration.AddAssemblyBinding Method (Assembly, Boolean)
See Also Example
[image]

Adds a binding to the configuration for the specified assembly.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssemblyBinding( _
ByVal assembly As Assembly, _
ByVal bindingRedirect As Boolean _
)
C#
public void AddAssemblyBinding(
Assembly assembly,
bool bindingRedirect
)
C++
public:
void AddAssemblyBinding(
Assembly assembly,
bool bindingRedirect
) sealed
J#
public void AddAssemblyBinding(
Assembly assembly,
bool bindingRedirect
)
JScript
public function AddAssemblyBinding(
assembly : Assembly,
bindingRedirect : bool
)

Parameters

assembly
The assembly
bindingRedirect
True if a catch-all binding redirect should be used to ensure that this exact version of the assembly is loaded no matter which version was originally requested

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assembly is null

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AddAssemblyBinding Overload List


AddAssemblyBinding Method (AssemblyName, String, Boolean)

HostConfiguration.AddAssemblyBinding Method (AssemblyName, String, Boolean)
See Also Example
[image]

Adds a binding to the configuration for the specified assembly.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssemblyBinding( _
ByVal assemblyName As AssemblyName, _
ByVal codeBase As String, _
ByVal bindingRedirect As Boolean _
)
C#
public void AddAssemblyBinding(
AssemblyName assemblyName,
string codeBase,
bool bindingRedirect
)
C++
public:
void AddAssemblyBinding(
AssemblyName assemblyName,
String codeBase,
bool bindingRedirect
) sealed
J#
public void AddAssemblyBinding(
AssemblyName assemblyName,
string codeBase,
bool bindingRedirect
)
JScript
public function AddAssemblyBinding(
assemblyName : AssemblyName,
codeBase : String,
bindingRedirect : bool
)

Parameters

assemblyName
The assembly name
codeBase
The assembly code base Uri
bindingRedirect
True if a catch-all binding redirect should be used to ensure that this exact version of the assembly is loaded no matter which version was originally requested

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyName or codeBase is null

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AddAssemblyBinding Overload List


AddAssemblyDependency Method

HostConfiguration.AddAssemblyDependency Method
[image]

Adds an assembly dependency element if a suitable one does not already exist.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddAssemblyDependency( _
ByVal name As String, _
ByVal publicKeyToken As String, _
ByVal culture As String, _
ByVal architecture As String _
) As HostConfiguration.AssemblyDependency
C#
public HostConfiguration.AssemblyDependency AddAssemblyDependency(
string name,
string publicKeyToken,
string culture,
string architecture
)
C++
public:
HostConfiguration.AssemblyDependency AddAssemblyDependency(
String name,
String publicKeyToken,
String culture,
String architecture
) sealed
J#
public HostConfiguration.AssemblyDependency AddAssemblyDependency(
string name,
string publicKeyToken,
string culture,
string architecture
)
JScript
public function AddAssemblyDependency(
name : String,
publicKeyToken : String,
culture : String,
architecture : String
) : HostConfiguration.AssemblyDependency

Parameters

name
The assembly name
publicKeyToken
The assembly public key token, or null if none
culture
The assembly culture
architecture
The assembly processor architecture, or null if none

Return Value

The assembly dependency element

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


AddAssemblyQualification Method

HostConfiguration.AddAssemblyQualification Method
[image]

Adds an assembly qualification element if a suitable one does not already exist.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddAssemblyQualification( _
ByVal partialName As String, _
ByVal fullName As String _
) As HostConfiguration.AssemblyQualification
C#
public HostConfiguration.AssemblyQualification AddAssemblyQualification(
string partialName,
string fullName
)
C++
public:
HostConfiguration.AssemblyQualification AddAssemblyQualification(
String partialName,
String fullName
) sealed
J#
public HostConfiguration.AssemblyQualification AddAssemblyQualification(
string partialName,
string fullName
)
JScript
public function AddAssemblyQualification(
partialName : String,
fullName : String
) : HostConfiguration.AssemblyQualification

Parameters

partialName
The partial name to quality
fullName
The full name

Return Value

The assembly qualification element

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if an assembly qualification already exists for the same partial name but with a different full name

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


Copy Method

HostConfiguration.Copy Method
[image]

Creates a copy of the host configuration information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As HostConfiguration
C#
public HostConfiguration Copy()
C++
public:
HostConfiguration Copy() sealed
J#
public HostConfiguration Copy()
JScript
public function Copy() : HostConfiguration

Return Value

The copy

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


Equals Method

HostConfiguration.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (HostConfiguration) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


Equals Method (HostConfiguration)

HostConfiguration.Equals Method (HostConfiguration)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As HostConfiguration _
) As Boolean _
Implements IEquatable<HostConfiguration>.Equals
C#
public bool Equals(
HostConfiguration other
)
C++
public:
bool Equals(
HostConfiguration other
) sealed
J#
public bool Equals(
HostConfiguration other
)
JScript
public function Equals(
other : HostConfiguration
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<HostConfiguration>.Equals

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.Equals Overload List


Equals Method (Object)

HostConfiguration.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.Equals Overload List


GetHashCode Method

HostConfiguration.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


ToString Method

HostConfiguration.ToString Method
[image]

Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and returns the combined Xml configuration.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The combined Xml configuration

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


WriteTo Method

HostConfiguration.WriteTo Method
[image]

Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and writes the combined Xml configuration to a TextWriter.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTo( _
ByVal textWriter As TextWriter _
)
C#
public void WriteTo(
TextWriter textWriter
)
C++
public:
void WriteTo(
TextWriter textWriter
) sealed
J#
public void WriteTo(
TextWriter textWriter
)
JScript
public function WriteTo(
textWriter : TextWriter
)

Parameters

textWriter
The TextWriter where the Xml configuration will be written to.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if textWriter is null.
IOException | Thrown if the configuration could not be written

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


WriteToFile Method

HostConfiguration.WriteToFile Method
[image]

Overlays the ConfigurationXml with the additional configuration entries necessary to enable the features described by this instance and writes the combined Xml configuration to a file with the given path.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteToFile( _
ByVal path As String _
)
C#
public void WriteToFile(
string path
)
C++
public:
void WriteToFile(
String path
) sealed
J#
public void WriteToFile(
string path
)
JScript
public function WriteToFile(
path : String
)

Parameters

path
The file path

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null
IOException | Thrown if the configuration could not be written

See Also

HostConfiguration Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyBindingRedirect Class

HostConfiguration.AssemblyBindingRedirect Class
See Also Example Members
[image]

Describes an assembly binding redirection from an old version range to a new version. This class cannot be inherited.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class HostConfiguration.AssemblyBindingRedirect
Implements IEquatable(Of AssemblyBindingRedirect)
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class HostConfiguration.AssemblyBindingRedirect : IEquatable<AssemblyBindingRedirect>
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class HostConfiguration.AssemblyBindingRedirect sealed : IEquatable<AssemblyBindingRedirect>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class HostConfiguration.AssemblyBindingRedirect implements IEquatable<AssemblyBindingRedirect>
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class HostConfiguration.AssemblyBindingRedirect extends IEquatable<AssemblyBindingRedirect>

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostConfiguration.AssemblyBindingRedirect

See Also

HostConfiguration.AssemblyBindingRedirect Members
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyBindingRedirect Members

HostConfiguration.AssemblyBindingRedirect Members
See Also Example Constructors Properties Methods
[image]

Describes an assembly binding redirection from an old version range to a new version. This class cannot be inherited.

The following tables list the members exposed by HostConfiguration.AssemblyBindingRedirect.

Public Constructors

 | Name | Description
Public method | HostConfiguration.AssemblyBindingRedirect | Creates an assembly binding redirect.
Top

Public Properties

 | Name | Description
Public property | NewVersion | Gets or sets the new version to which the binding should be redirected such as "1.2.3.4"
Public property | OldVersionRange | Gets or sets the range of old versions to redirect, specified either as a single version such as "1.2.3.4" or as a range such as "1.2.3.4-10.11.12.13"
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the assembly binding redirect information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyBindingRedirect Constructor

HostConfiguration.AssemblyBindingRedirect Constructor
[image]

Creates an assembly binding redirect.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal oldVersionRange As String, _
ByVal newVersion As String _
)
C#
public HostConfiguration.AssemblyBindingRedirect(
string oldVersionRange,
string newVersion
)
C++
public:
HostConfiguration.AssemblyBindingRedirect(
String oldVersionRange,
String newVersion
) sealed
J#
public HostConfiguration.AssemblyBindingRedirect(
string oldVersionRange,
string newVersion
)
JScript
public function HostConfiguration.AssemblyBindingRedirect(
oldVersionRange : String,
newVersion : String
)

Parameters

oldVersionRange
The range of old versions to redirect, specified either as a single version such as "1.2.3.4" or as a range such as "1.2.3.4-10.11.12.13"
newVersion
The new version to which the binding should be redirected such as "1.2.3.4"

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if oldVersionRange or newVersion is null

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


Properties

HostConfiguration.AssemblyBindingRedirect Properties
[image]

Public Properties

 | Name | Description
Public property | NewVersion | Gets or sets the new version to which the binding should be redirected such as "1.2.3.4"
Public property | OldVersionRange | Gets or sets the range of old versions to redirect, specified either as a single version such as "1.2.3.4" or as a range such as "1.2.3.4-10.11.12.13"
Top

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


NewVersion Property

HostConfiguration.AssemblyBindingRedirect.NewVersion Property
See Also Example
[image]

Gets or sets the new version to which the binding should be redirected such as "1.2.3.4"

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("newVersion")>
Public Property NewVersion As String
C#
[XmlAttributeAttribute("newVersion")]
public string NewVersion { get; set; }
C++
[XmlAttributeAttribute(L"newVersion")]
public property string NewVersion sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("newVersion") */
/** property */
public string get_NewVersion();

/** property */
public void set_NewVersion(string value);
JScript
public function get NewVersion() : String

public function set NewVersion(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


OldVersionRange Property

HostConfiguration.AssemblyBindingRedirect.OldVersionRange Property
See Also Example
[image]

Gets or sets the range of old versions to redirect, specified either as a single version such as "1.2.3.4" or as a range such as "1.2.3.4-10.11.12.13"

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("oldVersionRange")>
Public Property OldVersionRange As String
C#
[XmlAttributeAttribute("oldVersionRange")]
public string OldVersionRange { get; set; }
C++
[XmlAttributeAttribute(L"oldVersionRange")]
public property string OldVersionRange sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("oldVersionRange") */
/** property */
public string get_OldVersionRange();

/** property */
public void set_OldVersionRange(string value);
JScript
public function get OldVersionRange() : String

public function set OldVersionRange(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


Methods

HostConfiguration.AssemblyBindingRedirect Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the assembly binding redirect information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


Copy Method

HostConfiguration.AssemblyBindingRedirect.Copy Method
[image]

Creates a copy of the assembly binding redirect information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As HostConfiguration.AssemblyBindingRedirect
C#
public HostConfiguration.AssemblyBindingRedirect Copy()
C++
public:
HostConfiguration.AssemblyBindingRedirect Copy() sealed
J#
public HostConfiguration.AssemblyBindingRedirect Copy()
JScript
public function Copy() : HostConfiguration.AssemblyBindingRedirect

Return Value

The copy

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


Equals Method

HostConfiguration.AssemblyBindingRedirect.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (HostConfiguration.AssemblyBindingRedirect) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


Equals Method (HostConfiguration.AssemblyBindingRedirect)

HostConfiguration.AssemblyBindingRedirect.Equals Method (HostConfiguration.AssemblyBindingRedirect)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As HostConfiguration.AssemblyBindingRedirect _
) As Boolean _
Implements IEquatable<HostConfiguration.AssemblyBindingRedirect>.Equals
C#
public bool Equals(
HostConfiguration.AssemblyBindingRedirect other
)
C++
public:
bool Equals(
HostConfiguration.AssemblyBindingRedirect other
) sealed
J#
public bool Equals(
HostConfiguration.AssemblyBindingRedirect other
)
JScript
public function Equals(
other : HostConfiguration.AssemblyBindingRedirect
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<HostConfiguration.AssemblyBindingRedirect>.Equals

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyBindingRedirect.Equals Overload List


Equals Method (Object)

HostConfiguration.AssemblyBindingRedirect.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyBindingRedirect.Equals Overload List


GetHashCode Method

HostConfiguration.AssemblyBindingRedirect.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

HostConfiguration.AssemblyBindingRedirect Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyCodeBase Class

HostConfiguration.AssemblyCodeBase Class
See Also Example Members
[image]

Describes the location of the codebase of a particular assembly version.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public Class HostConfiguration.AssemblyCodeBase
Implements IEquatable(Of AssemblyCodeBase)
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public class HostConfiguration.AssemblyCodeBase : IEquatable<AssemblyCodeBase>
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class HostConfiguration.AssemblyCodeBase : IEquatable<AssemblyCodeBase>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public class HostConfiguration.AssemblyCodeBase implements IEquatable<AssemblyCodeBase>
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
class HostConfiguration.AssemblyCodeBase extends IEquatable<AssemblyCodeBase>

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostConfiguration.AssemblyCodeBase

See Also

HostConfiguration.AssemblyCodeBase Members
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyCodeBase Members

HostConfiguration.AssemblyCodeBase Members
See Also Example Constructors Properties Methods
[image]

Describes the location of the codebase of a particular assembly version.

The following tables list the members exposed by HostConfiguration.AssemblyCodeBase.

Public Constructors

 | Name | Description
Public method | HostConfiguration.AssemblyCodeBase | Creates an assembly code base element.
Top

Public Properties

 | Name | Description
Public property | Uri | Gets or sets the Uri that specifies the location of the assembly.
Public property | Version | Gets or sets the assembly version to which this element applies such as "1.2.3.4".
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the assembly binding redirect information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyCodeBase Constructor

HostConfiguration.AssemblyCodeBase Constructor
[image]

Creates an assembly code base element.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal version As String, _
ByVal uri As String _
)
C#
public HostConfiguration.AssemblyCodeBase(
string version,
string uri
)
C++
public:
HostConfiguration.AssemblyCodeBase(
String version,
String uri
) sealed
J#
public HostConfiguration.AssemblyCodeBase(
string version,
string uri
)
JScript
public function HostConfiguration.AssemblyCodeBase(
version : String,
uri : String
)

Parameters

version
The assembly version to which this element applies such as "1.2.3.4"
uri
The Uri that specifies the location of the assembly

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if version or uri is null
ArgumentException | Thrown if uri is not an absolute Uri
UriFormatException | Thrown if uri is not a well-formed Uri

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Properties

HostConfiguration.AssemblyCodeBase Properties
[image]

Public Properties

 | Name | Description
Public property | Uri | Gets or sets the Uri that specifies the location of the assembly.
Public property | Version | Gets or sets the assembly version to which this element applies such as "1.2.3.4".
Top

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Uri Property

HostConfiguration.AssemblyCodeBase.Uri Property
[image]

Gets or sets the Uri that specifies the location of the assembly.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("uri")>
Public Property Uri As String
C#
[XmlAttributeAttribute("uri")]
public string Uri { get; set; }
C++
[XmlAttributeAttribute(L"uri")]
public property string Uri sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("uri") */
/** property */
public string get_Uri();

/** property */
public void set_Uri(string value);
JScript
public function get Uri() : String

public function set Uri(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null
ArgumentException | Thrown if value is not an absolute Uri
UriFormatException | Thrown if value is not a well-formed Uri

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Version Property

HostConfiguration.AssemblyCodeBase.Version Property
[image]

Gets or sets the assembly version to which this element applies such as "1.2.3.4".

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("version")>
Public Property Version As String
C#
[XmlAttributeAttribute("version")]
public string Version { get; set; }
C++
[XmlAttributeAttribute(L"version")]
public property string Version sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("version") */
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Methods

HostConfiguration.AssemblyCodeBase Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the assembly binding redirect information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Copy Method

HostConfiguration.AssemblyCodeBase.Copy Method
[image]

Creates a copy of the assembly binding redirect information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As HostConfiguration.AssemblyCodeBase
C#
public HostConfiguration.AssemblyCodeBase Copy()
C++
public:
HostConfiguration.AssemblyCodeBase Copy() sealed
J#
public HostConfiguration.AssemblyCodeBase Copy()
JScript
public function Copy() : HostConfiguration.AssemblyCodeBase

Return Value

The copy

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Equals Method

HostConfiguration.AssemblyCodeBase.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (HostConfiguration.AssemblyCodeBase) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


Equals Method (HostConfiguration.AssemblyCodeBase)

HostConfiguration.AssemblyCodeBase.Equals Method (HostConfiguration.AssemblyCodeBase)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As HostConfiguration.AssemblyCodeBase _
) As Boolean _
Implements IEquatable<HostConfiguration.AssemblyCodeBase>.Equals
C#
public bool Equals(
HostConfiguration.AssemblyCodeBase other
)
C++
public:
bool Equals(
HostConfiguration.AssemblyCodeBase other
) sealed
J#
public bool Equals(
HostConfiguration.AssemblyCodeBase other
)
JScript
public function Equals(
other : HostConfiguration.AssemblyCodeBase
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<HostConfiguration.AssemblyCodeBase>.Equals

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyCodeBase.Equals Overload List


Equals Method (Object)

HostConfiguration.AssemblyCodeBase.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyCodeBase.Equals Overload List


GetHashCode Method

HostConfiguration.AssemblyCodeBase.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

HostConfiguration.AssemblyCodeBase Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyDependency Class

HostConfiguration.AssemblyDependency Class
See Also Example Members
[image]

Describes a dependent assembly configuration entry that optionally specifies the codebase, a publisher policy and binding redirects. This class cannot be inherited.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class HostConfiguration.AssemblyDependency
Implements IEquatable(Of AssemblyDependency)
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class HostConfiguration.AssemblyDependency : IEquatable<AssemblyDependency>
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class HostConfiguration.AssemblyDependency sealed : IEquatable<AssemblyDependency>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class HostConfiguration.AssemblyDependency implements IEquatable<AssemblyDependency>
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class HostConfiguration.AssemblyDependency extends IEquatable<AssemblyDependency>

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostConfiguration.AssemblyDependency

See Also

HostConfiguration.AssemblyDependency Members
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyDependency Members

HostConfiguration.AssemblyDependency Members
See Also Example Constructors Properties Methods
[image]

Describes a dependent assembly configuration entry that optionally specifies the codebase, a publisher policy and binding redirects. This class cannot be inherited.

The following tables list the members exposed by HostConfiguration.AssemblyDependency.

Public Constructors

 | Name | Description
Public method | HostConfiguration.AssemblyDependency | Creates an assembly dependency.
Top

Public Properties

 | Name | Description
Public property | ApplyPublisherPolicy | Gets or sets whether to apply the publisher policy for this assembly.
Public property | AssemblyCulture | Gets or sets the assembly culture, or null if none.
Public property | AssemblyName | Gets or sets assembly name.
Public property | AssemblyProcessorArchitecture | Gets or sets the assembly processor architecture, or null if none.
Public property | AssemblyPublicKeyToken | Gets or sets the assembly public key token, or null if none.
Public property | BindingRedirects | Gets a mutable list of assembly binding redirect elements.
Public property | CodeBases | Gets a mutable list of assembly code base elements.
Top

Public Methods

 | Name | Description
Public method | AddAssemblyBindingRedirect | Adds an assembly binding redirect element if a suitable one is not already present.
Public method | AddAssemblyCodeBase | Adds an assembly code-base element if a suitable one is not already present.
Public method | Copy | Creates a copy of the assembly dependency information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyDependency Constructor

HostConfiguration.AssemblyDependency Constructor
[image]

Creates an assembly dependency.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyName As String _
)
C#
public HostConfiguration.AssemblyDependency(
string assemblyName
)
C++
public:
HostConfiguration.AssemblyDependency(
String assemblyName
) sealed
J#
public HostConfiguration.AssemblyDependency(
string assemblyName
)
JScript
public function HostConfiguration.AssemblyDependency(
assemblyName : String
)

Parameters

assemblyName
The assembly name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyName is null

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


Properties

HostConfiguration.AssemblyDependency Properties
[image]

Public Properties

 | Name | Description
Public property | ApplyPublisherPolicy | Gets or sets whether to apply the publisher policy for this assembly.
Public property | AssemblyCulture | Gets or sets the assembly culture, or null if none.
Public property | AssemblyName | Gets or sets assembly name.
Public property | AssemblyProcessorArchitecture | Gets or sets the assembly processor architecture, or null if none.
Public property | AssemblyPublicKeyToken | Gets or sets the assembly public key token, or null if none.
Public property | BindingRedirects | Gets a mutable list of assembly binding redirect elements.
Public property | CodeBases | Gets a mutable list of assembly code base elements.
Top

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


ApplyPublisherPolicy Property

HostConfiguration.AssemblyDependency.ApplyPublisherPolicy Property
See Also Example
[image]

Gets or sets whether to apply the publisher policy for this assembly.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Property ApplyPublisherPolicy As Boolean
C#
public bool ApplyPublisherPolicy { get; set; }
C++
public property bool ApplyPublisherPolicy sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ApplyPublisherPolicy();

/** property */
public void set_ApplyPublisherPolicy(bool value);
JScript
public function get ApplyPublisherPolicy() : bool

public function set ApplyPublisherPolicy(value : bool);

Property Value

The default value is true.

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


AssemblyCulture Property

HostConfiguration.AssemblyDependency.AssemblyCulture Property
See Also Example
[image]

Gets or sets the assembly culture, or null if none.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assemblyCulture")>
Public Property AssemblyCulture As String
C#
[XmlAttributeAttribute("assemblyCulture")]
public string AssemblyCulture { get; set; }
C++
[XmlAttributeAttribute(L"assemblyCulture")]
public property string AssemblyCulture sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("assemblyCulture") */
/** property */
public string get_AssemblyCulture();

/** property */
public void set_AssemblyCulture(string value);
JScript
public function get AssemblyCulture() : String

public function set AssemblyCulture(value : String);

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


AssemblyName Property

HostConfiguration.AssemblyDependency.AssemblyName Property
[image]

Gets or sets assembly name.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assemblyName")>
Public Property AssemblyName As String
C#
[XmlAttributeAttribute("assemblyName")]
public string AssemblyName { get; set; }
C++
[XmlAttributeAttribute(L"assemblyName")]
public property string AssemblyName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("assemblyName") */
/** property */
public string get_AssemblyName();

/** property */
public void set_AssemblyName(string value);
JScript
public function get AssemblyName() : String

public function set AssemblyName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


AssemblyProcessorArchitecture Property

HostConfiguration.AssemblyDependency.AssemblyProcessorArchitecture Property
See Also Example
[image]

Gets or sets the assembly processor architecture, or null if none.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assemblyProcessorArchitecture")>
Public Property AssemblyProcessorArchitecture As String
C#
[XmlAttributeAttribute("assemblyProcessorArchitecture")]
public string AssemblyProcessorArchitecture { get; set; }
C++
[XmlAttributeAttribute(L"assemblyProcessorArchitecture")]
public property string AssemblyProcessorArchitecture sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("assemblyProcessorArchitecture") */
/** property */
public string get_AssemblyProcessorArchitecture();

/** property */
public void set_AssemblyProcessorArchitecture(string value);
JScript
public function get AssemblyProcessorArchitecture() : String

public function set AssemblyProcessorArchitecture(value : String);

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


AssemblyPublicKeyToken Property

HostConfiguration.AssemblyDependency.AssemblyPublicKeyToken Property
See Also Example
[image]

Gets or sets the assembly public key token, or null if none.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("assemblyPublicKeyToken")>
Public Property AssemblyPublicKeyToken As String
C#
[XmlAttributeAttribute("assemblyPublicKeyToken")]
public string AssemblyPublicKeyToken { get; set; }
C++
[XmlAttributeAttribute(L"assemblyPublicKeyToken")]
public property string AssemblyPublicKeyToken sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("assemblyPublicKeyToken") */
/** property */
public string get_AssemblyPublicKeyToken();

/** property */
public void set_AssemblyPublicKeyToken(string value);
JScript
public function get AssemblyPublicKeyToken() : String

public function set AssemblyPublicKeyToken(value : String);

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


BindingRedirects Property

HostConfiguration.AssemblyDependency.BindingRedirects Property
See Also Example
[image]

Gets a mutable list of assembly binding redirect elements.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("bindingRedirects", IsNullable := False), _
XmlArrayItemAttribute("bindingRedirect", GetType(HostConfiguration_x002B_AssemblyBindingRedirect), IsNullable := False)>
Public ReadOnly Property BindingRedirects As List(Of AssemblyBindingRedirect)
C#
[XmlArrayAttribute("bindingRedirects", IsNullable = False)]
[XmlArrayItemAttribute("bindingRedirect", typeof(HostConfiguration_x002B_AssemblyBindingRedirect), IsNullable = False)]
public List<AssemblyBindingRedirect> BindingRedirects { get; }
C++
[XmlArrayAttribute(L"bindingRedirects", IsNullable = False)]
[XmlArrayItemAttribute(L"bindingRedirect", typeof(HostConfiguration_x002B_AssemblyBindingRedirect), IsNullable = False)]
public property List<AssemblyBindingRedirect> BindingRedirects sealed {
List<AssemblyBindingRedirect> get();
}
J#
/** @attribute XmlArrayAttribute("bindingRedirects", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("bindingRedirect", typeof(HostConfiguration_x002B_AssemblyBindingRedirect), IsNullable = False) */
/** property */
public List<AssemblyBindingRedirect> get_BindingRedirects();
JScript
public function get BindingRedirects() : List<AssemblyBindingRedirect>

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


CodeBases Property

HostConfiguration.AssemblyDependency.CodeBases Property
[image]

Gets a mutable list of assembly code base elements.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayAttribute("codeBases", IsNullable := False), _
XmlArrayItemAttribute("codeBase", GetType(HostConfiguration_x002B_AssemblyCodeBase), IsNullable := False)>
Public ReadOnly Property CodeBases As List(Of AssemblyCodeBase)
C#
[XmlArrayAttribute("codeBases", IsNullable = False)]
[XmlArrayItemAttribute("codeBase", typeof(HostConfiguration_x002B_AssemblyCodeBase), IsNullable = False)]
public List<AssemblyCodeBase> CodeBases { get; }
C++
[XmlArrayAttribute(L"codeBases", IsNullable = False)]
[XmlArrayItemAttribute(L"codeBase", typeof(HostConfiguration_x002B_AssemblyCodeBase), IsNullable = False)]
public property List<AssemblyCodeBase> CodeBases sealed {
List<AssemblyCodeBase> get();
}
J#
/** @attribute XmlArrayAttribute("codeBases", IsNullable = False) */
/** @attribute XmlArrayItemAttribute("codeBase", typeof(HostConfiguration_x002B_AssemblyCodeBase), IsNullable = False) */
/** property */
public List<AssemblyCodeBase> get_CodeBases();
JScript
public function get CodeBases() : List<AssemblyCodeBase>

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


Methods

HostConfiguration.AssemblyDependency Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssemblyBindingRedirect | Adds an assembly binding redirect element if a suitable one is not already present.
Public method | AddAssemblyCodeBase | Adds an assembly code-base element if a suitable one is not already present.
Public method | Copy | Creates a copy of the assembly dependency information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


AddAssemblyBindingRedirect Method

HostConfiguration.AssemblyDependency.AddAssemblyBindingRedirect Method
See Also Example
[image]

Adds an assembly binding redirect element if a suitable one is not already present.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddAssemblyBindingRedirect( _
ByVal oldVersionRange As String, _
ByVal newVersion As String _
) As HostConfiguration.AssemblyBindingRedirect
C#
public HostConfiguration.AssemblyBindingRedirect AddAssemblyBindingRedirect(
string oldVersionRange,
string newVersion
)
C++
public:
HostConfiguration.AssemblyBindingRedirect AddAssemblyBindingRedirect(
String oldVersionRange,
String newVersion
) sealed
J#
public HostConfiguration.AssemblyBindingRedirect AddAssemblyBindingRedirect(
string oldVersionRange,
string newVersion
)
JScript
public function AddAssemblyBindingRedirect(
oldVersionRange : String,
newVersion : String
) : HostConfiguration.AssemblyBindingRedirect

Parameters

oldVersionRange
Th old version range
newVersion
The new version for redirection

Return Value

The binding redirect element

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


AddAssemblyCodeBase Method

HostConfiguration.AssemblyDependency.AddAssemblyCodeBase Method
See Also Example
[image]

Adds an assembly code-base element if a suitable one is not already present.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function AddAssemblyCodeBase( _
ByVal version As String, _
ByVal uri As String _
) As HostConfiguration.AssemblyCodeBase
C#
public HostConfiguration.AssemblyCodeBase AddAssemblyCodeBase(
string version,
string uri
)
C++
public:
HostConfiguration.AssemblyCodeBase AddAssemblyCodeBase(
String version,
String uri
) sealed
J#
public HostConfiguration.AssemblyCodeBase AddAssemblyCodeBase(
string version,
string uri
)
JScript
public function AddAssemblyCodeBase(
version : String,
uri : String
) : HostConfiguration.AssemblyCodeBase

Parameters

version
The assembly version
uri
The code base uri

Return Value

The code base element

Remarks

If another codebase element exists with the same version but perhaps a different Uri, then we do not add a new codebase since this most likely indicates that the same assembly can be loaded from multiple locations.

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


Copy Method

HostConfiguration.AssemblyDependency.Copy Method
[image]

Creates a copy of the assembly dependency information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As HostConfiguration.AssemblyDependency
C#
public HostConfiguration.AssemblyDependency Copy()
C++
public:
HostConfiguration.AssemblyDependency Copy() sealed
J#
public HostConfiguration.AssemblyDependency Copy()
JScript
public function Copy() : HostConfiguration.AssemblyDependency

Return Value

The copy

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


Equals Method

HostConfiguration.AssemblyDependency.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (HostConfiguration.AssemblyDependency) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


Equals Method (HostConfiguration.AssemblyDependency)

HostConfiguration.AssemblyDependency.Equals Method (HostConfiguration.AssemblyDependency)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As HostConfiguration.AssemblyDependency _
) As Boolean _
Implements IEquatable<HostConfiguration.AssemblyDependency>.Equals
C#
public bool Equals(
HostConfiguration.AssemblyDependency other
)
C++
public:
bool Equals(
HostConfiguration.AssemblyDependency other
) sealed
J#
public bool Equals(
HostConfiguration.AssemblyDependency other
)
JScript
public function Equals(
other : HostConfiguration.AssemblyDependency
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<HostConfiguration.AssemblyDependency>.Equals

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyDependency.Equals Overload List


Equals Method (Object)

HostConfiguration.AssemblyDependency.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyDependency.Equals Overload List


GetHashCode Method

HostConfiguration.AssemblyDependency.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

HostConfiguration.AssemblyDependency Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyQualification Class

HostConfiguration.AssemblyQualification Class
See Also Example Members
[image]

Describes an assembly name qualification configuration entry that maps an assembly partial name to its full name. This class cannot be inherited.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/")>
Public NotInheritable Class HostConfiguration.AssemblyQualification
Implements IEquatable(Of AssemblyQualification)
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
public sealed class HostConfiguration.AssemblyQualification : IEquatable<AssemblyQualification>
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
ref class HostConfiguration.AssemblyQualification sealed : IEquatable<AssemblyQualification>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
public final class HostConfiguration.AssemblyQualification implements IEquatable<AssemblyQualification>
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
final class HostConfiguration.AssemblyQualification extends IEquatable<AssemblyQualification>

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostConfiguration.AssemblyQualification

See Also

HostConfiguration.AssemblyQualification Members
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyQualification Members

HostConfiguration.AssemblyQualification Members
See Also Example Constructors Properties Methods
[image]

Describes an assembly name qualification configuration entry that maps an assembly partial name to its full name. This class cannot be inherited.

The following tables list the members exposed by HostConfiguration.AssemblyQualification.

Public Constructors

 | Name | Description
Public method | HostConfiguration.AssemblyQualification | Creates an assembly name qualification.
Top

Public Properties

 | Name | Description
Public property | FullName | Gets or sets the assembly full name to use.
Public property | PartialName | Gets or sets the assembly partial name to qualify.
Top

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the assembly qualification information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


HostConfiguration.AssemblyQualification Constructor

HostConfiguration.AssemblyQualification Constructor
[image]

Creates an assembly name qualification.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal partialName As String, _
ByVal fullName As String _
)
C#
public HostConfiguration.AssemblyQualification(
string partialName,
string fullName
)
C++
public:
HostConfiguration.AssemblyQualification(
String partialName,
String fullName
) sealed
J#
public HostConfiguration.AssemblyQualification(
string partialName,
string fullName
)
JScript
public function HostConfiguration.AssemblyQualification(
partialName : String,
fullName : String
)

Parameters

partialName
The assembly partial name to qualify
fullName
The assembly full name to use

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if partialName or fullName is null

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


Properties

HostConfiguration.AssemblyQualification Properties
[image]

Public Properties

 | Name | Description
Public property | FullName | Gets or sets the assembly full name to use.
Public property | PartialName | Gets or sets the assembly partial name to qualify.
Top

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


FullName Property

HostConfiguration.AssemblyQualification.FullName Property
[image]

Gets or sets the assembly full name to use.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("fullName")>
Public Property FullName As String
C#
[XmlAttributeAttribute("fullName")]
public string FullName { get; set; }
C++
[XmlAttributeAttribute(L"fullName")]
public property string FullName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("fullName") */
/** property */
public string get_FullName();

/** property */
public void set_FullName(string value);
JScript
public function get FullName() : String

public function set FullName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


PartialName Property

HostConfiguration.AssemblyQualification.PartialName Property
[image]

Gets or sets the assembly partial name to qualify.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("partialName")>
Public Property PartialName As String
C#
[XmlAttributeAttribute("partialName")]
public string PartialName { get; set; }
C++
[XmlAttributeAttribute(L"partialName")]
public property string PartialName sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("partialName") */
/** property */
public string get_PartialName();

/** property */
public void set_PartialName(string value);
JScript
public function get PartialName() : String

public function set PartialName(value : String);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


Methods

HostConfiguration.AssemblyQualification Methods
[image]

Public Methods

 | Name | Description
Public method | Copy | Creates a copy of the assembly qualification information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


Copy Method

HostConfiguration.AssemblyQualification.Copy Method
[image]

Creates a copy of the assembly qualification information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As HostConfiguration.AssemblyQualification
C#
public HostConfiguration.AssemblyQualification Copy()
C++
public:
HostConfiguration.AssemblyQualification Copy() sealed
J#
public HostConfiguration.AssemblyQualification Copy()
JScript
public function Copy() : HostConfiguration.AssemblyQualification

Return Value

The copy

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


Equals Method

HostConfiguration.AssemblyQualification.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (HostConfiguration.AssemblyQualification) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


Equals Method (HostConfiguration.AssemblyQualification)

HostConfiguration.AssemblyQualification.Equals Method (HostConfiguration.AssemblyQualification)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As HostConfiguration.AssemblyQualification _
) As Boolean _
Implements IEquatable<HostConfiguration.AssemblyQualification>.Equals
C#
public bool Equals(
HostConfiguration.AssemblyQualification other
)
C++
public:
bool Equals(
HostConfiguration.AssemblyQualification other
) sealed
J#
public bool Equals(
HostConfiguration.AssemblyQualification other
)
JScript
public function Equals(
other : HostConfiguration.AssemblyQualification
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<HostConfiguration.AssemblyQualification>.Equals

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyQualification.Equals Overload List


Equals Method (Object)

HostConfiguration.AssemblyQualification.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace
HostConfiguration.AssemblyQualification.Equals Overload List


GetHashCode Method

HostConfiguration.AssemblyQualification.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

HostConfiguration.AssemblyQualification Class
Gallio.Runtime.Hosting Namespace


HostException Class

HostException Class
See Also Example Members
[image]

The type of exception thrown when hosting operations fail.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class HostException
Inherits Exception
C#
[SerializableAttribute]
public class HostException : Exception
C++
[SerializableAttribute]
ref class HostException : Exception
J#
/** @attribute SerializableAttribute() */
public class HostException extends Exception
JScript
public
SerializableAttribute
class HostException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Gallio.Runtime.Hosting.HostException

See Also

HostException Members
Gallio.Runtime.Hosting Namespace


HostException Members

HostException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The type of exception thrown when hosting operations fail.

The following tables list the members exposed by HostException.

Public Constructors

Name | Description
HostException | Overloaded. Initializes a new instance of the HostException class.
Top

Protected Constructors

Name | Description
HostException | Overloaded. Initializes a new instance of the HostException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
HostException | Overloaded. Initializes a new instance of the HostException class.
Top

See Also

HostException Class
Gallio.Runtime.Hosting Namespace


HostException Constructor

HostException Constructor

Initializes a new instance of the HostException class.

Overload List

 | Name | Description
Public method | HostException | Creates an exception.
Family method | HostException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | HostException (String) | Creates an exception.
Public method | HostException (String, Exception) | Creates an exception.

See Also

HostException Class
Gallio.Runtime.Hosting Namespace


HostException Constructor ()

HostException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HostException()
C++
public:
HostException() sealed
J#
public HostException()
JScript
public function HostException()

See Also

HostException Class
Gallio.Runtime.Hosting Namespace
HostException Constructor Overload List


HostException Constructor (SerializationInfo, StreamingContext)

HostException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected HostException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
HostException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected HostException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function HostException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

HostException Class
Gallio.Runtime.Hosting Namespace
HostException Constructor Overload List


HostException Constructor (String)

HostException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public HostException(
string message
)
C++
public:
HostException(
String message
) sealed
J#
public HostException(
string message
)
JScript
public function HostException(
message : String
)

Parameters

message
The message

See Also

HostException Class
Gallio.Runtime.Hosting Namespace
HostException Constructor Overload List


HostException Constructor (String, Exception)

HostException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public HostException(
string message,
Exception innerException
)
C++
public:
HostException(
String message,
Exception innerException
) sealed
J#
public HostException(
string message,
Exception innerException
)
JScript
public function HostException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

HostException Class
Gallio.Runtime.Hosting Namespace
HostException Constructor Overload List


HostServiceChannelInterop Class

HostServiceChannelInterop Class
See Also Example Members
[image]

Provides utilities to interact with a RemoteHostService over a IClientChannel or IServerChannel. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module HostServiceChannelInterop
C#
public static class HostServiceChannelInterop
C++
ref class HostServiceChannelInterop abstract sealed
J#
public final class HostServiceChannelInterop
JScript
public class HostServiceChannelInterop

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostServiceChannelInterop

See Also

HostServiceChannelInterop Members
Gallio.Runtime.Hosting Namespace


HostServiceChannelInterop Members

HostServiceChannelInterop Members
See Also Example Fields Methods
[image]

Provides utilities to interact with a RemoteHostService over a IClientChannel or IServerChannel. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by HostServiceChannelInterop.

Public Fields

Name | Description
ServiceName | Gets the name used to register the RemoteHostService. This field is constant and read-only.
Top

Public Methods

Name | Description
GetRemoteHostService | Gets a remote host service using the specified channel.
RegisterWithChannel | Registers the host service with a channel.
Top

See Also

HostServiceChannelInterop Class
Gallio.Runtime.Hosting Namespace


Fields

HostServiceChannelInterop Fields
[image]

Public Fields

Name | Description
ServiceName | Gets the name used to register the RemoteHostService. This field is constant and read-only.
Top

See Also

HostServiceChannelInterop Class
Gallio.Runtime.Hosting Namespace


ServiceName Field

HostServiceChannelInterop.ServiceName Field
[image]

Gets the name used to register the RemoteHostService. This field is constant and read-only.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const ServiceName As String = "HostService"
C#
public const string ServiceName = "HostService";
C++
public:
const String ServiceName = L"HostService";
J#
public const string ServiceName = "HostService"
JScript
public const ServiceName : String = "HostService";

See Also

HostServiceChannelInterop Class
Gallio.Runtime.Hosting Namespace


Methods

HostServiceChannelInterop Methods
[image]

Public Methods

Name | Description
GetRemoteHostService | Gets a remote host service using the specified channel.
RegisterWithChannel | Registers the host service with a channel.
Top

See Also

HostServiceChannelInterop Class
Gallio.Runtime.Hosting Namespace


GetRemoteHostService Method

HostServiceChannelInterop.GetRemoteHostService Method
[image]

Gets a remote host service using the specified channel.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRemoteHostService( _
ByVal channel As IClientChannel _
) As IRemoteHostService
C#
public static IRemoteHostService GetRemoteHostService(
IClientChannel channel
)
C++
public:
static IRemoteHostService GetRemoteHostService(
IClientChannel channel
)
J#
public static IRemoteHostService GetRemoteHostService(
IClientChannel channel
)
JScript
public static function GetRemoteHostService(
channel : IClientChannel
) : IRemoteHostService

Parameters

channel
The channel

Return Value

The remote host service

See Also

HostServiceChannelInterop Class
Gallio.Runtime.Hosting Namespace


RegisterWithChannel Method

HostServiceChannelInterop.RegisterWithChannel Method
[image]

Registers the host service with a channel.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RegisterWithChannel( _
ByVal hostService As RemoteHostService, _
ByVal channel As IServerChannel _
)
C#
public static void RegisterWithChannel(
RemoteHostService hostService,
IServerChannel channel
)
C++
public:
static void RegisterWithChannel(
RemoteHostService hostService,
IServerChannel channel
)
J#
public static void RegisterWithChannel(
RemoteHostService hostService,
IServerChannel channel
)
JScript
public static function RegisterWithChannel(
hostService : RemoteHostService,
channel : IServerChannel
)

Parameters

hostService
The remote host service
channel
The channel

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostService or channel is null

See Also

HostServiceChannelInterop Class
Gallio.Runtime.Hosting Namespace


HostSetup Class

HostSetup Class
See Also Example Members
[image]

Specifies a collection of parameters for setting up a IHost. This class cannot be inherited.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute, _
XmlTypeAttribute(Namespace := "http://www.gallio.org/"), _
XmlRootAttribute("hostSetup", Namespace := "http://www.gallio.org/")>
Public NotInheritable Class HostSetup
Implements IEquatable(Of HostSetup)
C#
[SerializableAttribute]
[XmlTypeAttribute(Namespace = "http://www.gallio.org/")]
[XmlRootAttribute("hostSetup", Namespace = "http://www.gallio.org/")]
public sealed class HostSetup : IEquatable<HostSetup>
C++
[SerializableAttribute]
[XmlTypeAttribute(Namespace = L"http://www.gallio.org/")]
[XmlRootAttribute(L"hostSetup", Namespace = L"http://www.gallio.org/")]
ref class HostSetup sealed : IEquatable<HostSetup>
J#
/** @attribute SerializableAttribute() */
/** @attribute XmlTypeAttribute(Namespace = "http://www.gallio.org/") */
/** @attribute XmlRootAttribute("hostSetup", Namespace = "http://www.gallio.org/") */
public final class HostSetup implements IEquatable<HostSetup>
JScript
public
SerializableAttribute
XmlTypeAttribute(Namespace = "http://www.gallio.org/")
XmlRootAttribute("hostSetup", Namespace = "http://www.gallio.org/")
final class HostSetup extends IEquatable<HostSetup>

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostSetup

See Also

HostSetup Members
Gallio.Runtime.Hosting Namespace


HostSetup Members

HostSetup Members
See Also Example Constructors Properties Methods
[image]

Specifies a collection of parameters for setting up a IHost. This class cannot be inherited.

The following tables list the members exposed by HostSetup.

Public Constructors

 | Name | Description
Public method | HostSetup | Creates a default host setup.
Top

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

Public property | Configuration | Gets or sets the host configuration information.
Public property | ConfigurationFileLocation | Gets or sets where the host should write out the configuration file for the hosted components.
Public property | Debug | Gets or sets whether to attach the debugger to the host.
Public property | ProcessorArchitecture | Gets or sets the processor architecture that the host should target, when supported.
Public property | Properties | Gets a mutable collection of key/value pairs that specify configuration properties for the host.
Public property | ShadowCopy | Gets or sets whether assembly shadow copying is enabled.
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

Top

Public Methods

 | Name | Description
Public method | Canonicalize | Makes all paths in this instance absolute.
Public method | Copy | Creates a copy of the host setup information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteTemporaryConfigurationFile | Writes a temporary configuration file for the application to disk and returns its path based on ConfigurationFileLocation. The file is created with a unique name each time. The file should be deleted by the caller when no longer required.
Top

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


HostSetup Constructor

HostSetup Constructor
[image]

Creates a default host setup.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HostSetup()
C++
public:
HostSetup() sealed
J#
public HostSetup()
JScript
public function HostSetup()

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Properties

HostSetup Properties
[image]

Public Properties

Name | Description
Public property ApplicationBaseDirectory

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

Public property | Configuration | Gets or sets the host configuration information.
Public property | ConfigurationFileLocation | Gets or sets where the host should write out the configuration file for the hosted components.
Public property | Debug | Gets or sets whether to attach the debugger to the host.
Public property | ProcessorArchitecture | Gets or sets the processor architecture that the host should target, when supported.
Public property | Properties | Gets a mutable collection of key/value pairs that specify configuration properties for the host.
Public property | ShadowCopy | Gets or sets whether assembly shadow copying is enabled.
Public property WorkingDirectory

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

Top

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


ApplicationBaseDirectory Property

HostSetup.ApplicationBaseDirectory Property
[image]

Gets or sets the relative or absolute path of the application base directory, or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("applicationBaseDirectory")>
Public Property ApplicationBaseDirectory As String
C#
[XmlAttributeAttribute("applicationBaseDirectory")]
public string ApplicationBaseDirectory { get; set; }
C++
[XmlAttributeAttribute(L"applicationBaseDirectory")]
public property string ApplicationBaseDirectory sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("applicationBaseDirectory") */
/** property */
public string get_ApplicationBaseDirectory();

/** property */
public void set_ApplicationBaseDirectory(string value);
JScript
public function get ApplicationBaseDirectory() : String

public function set ApplicationBaseDirectory(value : String);

Property Value

The application base directory. Default is null.

Remarks

Relative paths should be canonicalized as soon as possible. See Canonicalize.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Configuration Property

HostSetup.Configuration Property
[image]

Gets or sets the host configuration information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("configuration", IsNullable := False)>
Public Property Configuration As HostConfiguration
C#
[XmlElementAttribute("configuration", IsNullable = False)]
public HostConfiguration Configuration { get; set; }
C++
[XmlElementAttribute(L"configuration", IsNullable = False)]
public property HostConfiguration Configuration sealed {
HostConfiguration get();
void set(HostConfiguration value);
}
J#
/** @attribute XmlElementAttribute("configuration", IsNullable = False) */
/** property */
public HostConfiguration get_Configuration();

/** property */
public void set_Configuration(HostConfiguration value);
JScript
public function get Configuration() : HostConfiguration

public function set Configuration(value : HostConfiguration);

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if value is null

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


ConfigurationFileLocation Property

HostSetup.ConfigurationFileLocation Property
[image]

Gets or sets where the host should write out the configuration file for the hosted components.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("configurationFileLocation")>
Public Property ConfigurationFileLocation As ConfigurationFileLocation
C#
[XmlAttributeAttribute("configurationFileLocation")]
public ConfigurationFileLocation ConfigurationFileLocation { get; set; }
C++
[XmlAttributeAttribute(L"configurationFileLocation")]
public property ConfigurationFileLocation ConfigurationFileLocation sealed {
ConfigurationFileLocation get();
void set(ConfigurationFileLocation value);
}
J#
/** @attribute XmlAttributeAttribute("configurationFileLocation") */
/** property */
public ConfigurationFileLocation get_ConfigurationFileLocation();

/** property */
public void set_ConfigurationFileLocation(ConfigurationFileLocation value);
JScript
public function get ConfigurationFileLocation() : ConfigurationFileLocation

public function set ConfigurationFileLocation(value : ConfigurationFileLocation);

Property Value

The configuration file location. Default is Temp.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Debug Property

HostSetup.Debug Property
[image]

Gets or sets whether to attach the debugger to the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("debug")>
Public Property Debug As Boolean
C#
[XmlAttributeAttribute("debug")]
public bool Debug { get; set; }
C++
[XmlAttributeAttribute(L"debug")]
public property bool Debug sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("debug") */
/** property */
public bool get_Debug();

/** property */
public void set_Debug(bool value);
JScript
public function get Debug() : bool

public function set Debug(value : bool);

Property Value

True if a debugger should be attached to the host. Default is false.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


ProcessorArchitecture Property

HostSetup.ProcessorArchitecture Property
[image]

Gets or sets the processor architecture that the host should target, when supported.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("processorArchitecture")>
Public Property ProcessorArchitecture As ProcessorArchitecture
C#
[XmlAttributeAttribute("processorArchitecture")]
public ProcessorArchitecture ProcessorArchitecture { get; set; }
C++
[XmlAttributeAttribute(L"processorArchitecture")]
public property ProcessorArchitecture ProcessorArchitecture sealed {
ProcessorArchitecture get();
void set(ProcessorArchitecture value);
}
J#
/** @attribute XmlAttributeAttribute("processorArchitecture") */
/** property */
public ProcessorArchitecture get_ProcessorArchitecture();

/** property */
public void set_ProcessorArchitecture(ProcessorArchitecture value);
JScript
public function get ProcessorArchitecture() : ProcessorArchitecture

public function set ProcessorArchitecture(value : ProcessorArchitecture);

Property Value

The processor architecture. Default is MSIL

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Properties Property

HostSetup.Properties Property
[image]

Gets a mutable collection of key/value pairs that specify configuration properties for the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Properties As PropertySet
C#
public PropertySet Properties { get; }
C++
public property PropertySet Properties sealed {
PropertySet get();
}
J#
/** property */
public PropertySet get_Properties();
JScript
public function get Properties() : PropertySet

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


ShadowCopy Property

HostSetup.ShadowCopy Property
[image]

Gets or sets whether assembly shadow copying is enabled.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("enableShadowCopy")>
Public Property ShadowCopy As Boolean
C#
[XmlAttributeAttribute("enableShadowCopy")]
public bool ShadowCopy { get; set; }
C++
[XmlAttributeAttribute(L"enableShadowCopy")]
public property bool ShadowCopy sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute("enableShadowCopy") */
/** property */
public bool get_ShadowCopy();

/** property */
public void set_ShadowCopy(bool value);
JScript
public function get ShadowCopy() : bool

public function set ShadowCopy(value : bool);

Property Value

True if shadow copying is enabled. Default is false.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


WorkingDirectory Property

HostSetup.WorkingDirectory Property
[image]

Gets or sets the relative or absolute path of the working directory or null to use a default value selected by the consumer.

If relative, the path is based on the current working directory, so a value of "" causes the current working directory to be used.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("workingDirectory")>
Public Property WorkingDirectory As String
C#
[XmlAttributeAttribute("workingDirectory")]
public string WorkingDirectory { get; set; }
C++
[XmlAttributeAttribute(L"workingDirectory")]
public property string WorkingDirectory sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("workingDirectory") */
/** property */
public string get_WorkingDirectory();

/** property */
public void set_WorkingDirectory(string value);
JScript
public function get WorkingDirectory() : String

public function set WorkingDirectory(value : String);

Property Value

The working directory. Default is null.

Remarks

Relative paths should be canonicalized as soon as possible. See Canonicalize.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Methods

HostSetup Methods
[image]

Public Methods

 | Name | Description
Public method | Canonicalize | Makes all paths in this instance absolute.
Public method | Copy | Creates a copy of the host setup information.
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetHashCode | Overridden. Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteTemporaryConfigurationFile | Writes a temporary configuration file for the application to disk and returns its path based on ConfigurationFileLocation. The file is created with a unique name each time. The file should be deleted by the caller when no longer required.
Top

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Canonicalize Method

HostSetup.Canonicalize Method
[image]

Makes all paths in this instance absolute.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Canonicalize( _
ByVal baseDirectory As String _
)
C#
public void Canonicalize(
string baseDirectory
)
C++
public:
void Canonicalize(
String baseDirectory
) sealed
J#
public void Canonicalize(
string baseDirectory
)
JScript
public function Canonicalize(
baseDirectory : String
)

Parameters

baseDirectory
The base directory for resolving relative paths, or null to use the current directory

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Copy Method

HostSetup.Copy Method
[image]

Creates a copy of the host setup information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Copy() As HostSetup
C#
public HostSetup Copy()
C++
public:
HostSetup Copy() sealed
J#
public HostSetup Copy()
JScript
public function Copy() : HostSetup

Return Value

The copy

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Equals Method

HostSetup.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (HostSetup) | Determines whether the specified Object is equal to the current Object.
Public method | Equals (Object) | Overridden. Determines whether the specified Object is equal to the current Object.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


Equals Method (HostSetup)

HostSetup.Equals Method (HostSetup)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As HostSetup _
) As Boolean _
Implements IEquatable<HostSetup>.Equals
C#
public bool Equals(
HostSetup other
)
C++
public:
bool Equals(
HostSetup other
) sealed
J#
public bool Equals(
HostSetup other
)
JScript
public function Equals(
other : HostSetup
) : bool

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Implements

IEquatable<HostSetup>.Equals

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace
HostSetup.Equals Overload List


Equals Method (Object)

HostSetup.Equals Method (Object)
See Also Example
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace
HostSetup.Equals Overload List


GetHashCode Method

HostSetup.GetHashCode Method
[image]

Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A hash code for the current Object.

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


WriteTemporaryConfigurationFile Method

HostSetup.WriteTemporaryConfigurationFile Method
[image]

Writes a temporary configuration file for the application to disk and returns its path based on ConfigurationFileLocation. The file is created with a unique name each time.

The file should be deleted by the caller when no longer required.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function WriteTemporaryConfigurationFile() As String
C#
public string WriteTemporaryConfigurationFile()
C++
public:
String WriteTemporaryConfigurationFile() sealed
J#
public string WriteTemporaryConfigurationFile()
JScript
public function WriteTemporaryConfigurationFile() : String

Return Value

The full path of the configuration file that was written, or null if no file was written

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if ApplicationBaseDirectory is null but ConfigurationFileLocation is AppBase.
IOException | Thrown if the configuration file could not be written

See Also

HostSetup Class
Gallio.Runtime.Hosting Namespace


HostUtils Class

HostUtils Class
[image]

Provides utilities for working with hosts. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module HostUtils
C#
public static class HostUtils
C++
ref class HostUtils abstract sealed
J#
public final class HostUtils
JScript
public class HostUtils

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.HostUtils

See Also

HostUtils Members
Gallio.Runtime.Hosting Namespace


HostUtils Members

HostUtils Members
[image]

Provides utilities for working with hosts. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by HostUtils.

Public Methods

Name | Description
CreateInstance | Overloaded. Creates an instance of an object within
Top

See Also

HostUtils Class
Gallio.Runtime.Hosting Namespace


Methods

HostUtils Methods
[image]

Public Methods

Name | Description
CreateInstance | Overloaded. Creates an instance of an object within
Top

See Also

HostUtils Class
Gallio.Runtime.Hosting Namespace


CreateInstance Generic Method

HostUtils.CreateInstance Generic Method

Creates an instance of an object within

Overload List

Name | Description
CreateInstance (IHost, Type) | Creates an instance of an object within
CreateInstance (IHost) | Creates an instance of an object within a host.

See Also

HostUtils Class
Gallio.Runtime.Hosting Namespace


CreateInstance Method (IHost, Type)

HostUtils.CreateInstance Method (IHost, Type)
See Also Example
[image]

Creates an instance of an object within

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstance( _
ByVal host As IHost, _
ByVal type As Type _
) As Object
C#
public static object CreateInstance(
IHost host,
Type type
)
C++
public:
static Object CreateInstance(
IHost host,
Type type
)
J#
public static object CreateInstance(
IHost host,
Type type
)
JScript
public static function CreateInstance(
host : IHost,
type : Type
) : Object

Parameters

host
The host in which to create the object
type
The type of object to create

Return Value

The object instance

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if host or type is null

See Also

HostUtils Class
Gallio.Runtime.Hosting Namespace
HostUtils.CreateInstance Overload List


CreateInstance Generic Method (IHost)

HostUtils.CreateInstance Generic Method (IHost)
See Also Example
[image]

Creates an instance of an object within a host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstance(Of T)( _
ByVal host As IHost _
)
C#
public static T CreateInstance<T>(
IHost host
)
C++
public:
static T CreateInstance<T>(
IHost host
)
J#
public static T CreateInstance<T>(
IHost host
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of object to create

Parameters

host
The host in which to create the object

Return Value

The object instance

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if host is null

See Also

HostUtils Class
Gallio.Runtime.Hosting Namespace
HostUtils.CreateInstance Overload List


IHost Interface

IHost Interface
See Also Example Members
[image]

A host represents an environment that may be used to perform various services in isolation.

For example, a host might provide the ability to run code in an isolated AppDomain of the current process, or it might run code in an isolated process, or connect to an existing remote process.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHost
Implements IDisposable
C#
public interface IHost : IDisposable
C++
interface class IHost : IDisposable
J#
public interface IHost implements IDisposable
JScript
public interface IHost extends IDisposable

Types that implement IHost

Type | Description
Gallio.Runtime.Hosting.BaseHost | Base implementation of IHost that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IHost Members
Gallio.Runtime.Hosting Namespace


IHost Members

IHost Members
See Also Example Properties Methods Events
[image]

A host represents an environment that may be used to perform various services in isolation.

For example, a host might provide the ability to run code in an isolated AppDomain of the current process, or it might run code in an isolated process, or connect to an existing remote process.

The following tables list the members exposed by IHost.

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected.
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Public Methods

 | Name | Description
Public method | Disconnect | Disconnects the host.
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment.
Public method | GetHostSetup | Gets a deep copy of the host setup information.
Top

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately.
Top

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


Properties

IHost Properties
[image]

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected.
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


IsConnected Property

IHost.IsConnected Property
[image]

Returns true if the host is connected.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsConnected As Boolean
C#
bool IsConnected { get; }
C++
property bool IsConnected abstract {
bool get();
}
J#
/** property */
public bool get_IsConnected();
JScript
public function get IsConnected() : bool

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the host has been disposed

Remarks

A host may become disconnected non-deterministically due to a failure in the host's communication channel or some other remote eventuality.

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


IsLocal Property

IHost.IsLocal Property
[image]

Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLocal As Boolean
C#
bool IsLocal { get; }
C++
property bool IsLocal abstract {
bool get();
}
J#
/** property */
public bool get_IsLocal();
JScript
public function get IsLocal() : bool

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


Methods

IHost Methods
[image]

Public Methods

 | Name | Description
Public method | Disconnect | Disconnects the host.
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment.
Public method | GetHostSetup | Gets a deep copy of the host setup information.
Top

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


Disconnect Method

IHost.Disconnect Method
[image]

Disconnects the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Disconnect()
C#
void Disconnect()
C++
void Disconnect() abstract
J#
void Disconnect()
JScript
function Disconnect()

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the host has been disposed

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


GetHostService Method

IHost.GetHostService Method
[image]

Gets a host service that can be used to perform operations within the host's environment.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetHostService() As IHostService
C#
IHostService GetHostService()
C++
IHostService GetHostService() abstract
J#
IHostService GetHostService()
JScript
function GetHostService() : IHostService

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the host has been disconnected
ObjectDisposedException | Thrown if the host has been disposed

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


GetHostSetup Method

IHost.GetHostSetup Method
[image]

Gets a deep copy of the host setup information.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetHostSetup() As HostSetup
C#
HostSetup GetHostSetup()
C++
HostSetup GetHostSetup() abstract
J#
HostSetup GetHostSetup()
JScript
function GetHostSetup() : HostSetup

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the host has been disposed

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


Events

IHost Events
[image]

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately.
Top

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace


Disconnected Event

IHost.Disconnected Event
[image]

An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event Disconnected As EventHandler
C#
abstract event EventHandler Disconnected
C++
event EventHandler Disconnected {
void add(EventHandler value) abstract ;
void remove(EventHandler value) abstract ;
}
J#
/** event */
void add_Disconnected(EventHandler value);

/** event */
abstract void remove_Disconnected(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Exceptions

Exception Type | Condition
ObjectDisposedException | Thrown if the host has been disposed

See Also

IHost Interface
Gallio.Runtime.Hosting Namespace
IsConnected


IHostFactory Interface

IHostFactory Interface
See Also Example Members
[image]

A host factory encapsulates a policy for creating new IHost instances.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHostFactory
C#
public interface IHostFactory
C++
interface class IHostFactory
J#
public interface IHostFactory
JScript
public interface IHostFactory

Types that implement IHostFactory

Type | Description
Gallio.Runtime.Hosting.BaseHostFactory | An abstract base class for host factories. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IHostFactory Members
Gallio.Runtime.Hosting Namespace


IHostFactory Members

IHostFactory Members
See Also Example Methods
[image]

A host factory encapsulates a policy for creating new IHost instances.

The following tables list the members exposed by IHostFactory.

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance.
Top

See Also

IHostFactory Interface
Gallio.Runtime.Hosting Namespace


Methods

IHostFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance.
Top

See Also

IHostFactory Interface
Gallio.Runtime.Hosting Namespace


CreateHost Method

IHostFactory.CreateHost Method
[image]

Creates a host instance.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateHost( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
) As IHost
C#
IHost CreateHost(
HostSetup hostSetup,
ILogger logger
)
C++
IHost CreateHost(
HostSetup hostSetup,
ILogger logger
) abstract
J#
IHost CreateHost(
HostSetup hostSetup,
ILogger logger
)
JScript
function CreateHost(
hostSetup : HostSetup,
logger : ILogger
) : IHost

Parameters

hostSetup
The host setup
logger
The logger for host message output

Return Value

The newly created host

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostSetup or logger is null

See Also

IHostFactory Interface
Gallio.Runtime.Hosting Namespace


IHostService Interface

IHostService Interface
See Also Example Members
[image]

A host service enables a local client to interact with a remotely executing hosting environment.

A host service implementation may choose to implement a keep-alive mechanism to automatically shut itself down when the service is disposed or when it has not received a ping within a set period of time.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IHostService
C#
public interface IHostService
C++
interface class IHostService
J#
public interface IHostService
JScript
public interface IHostService

Types that implement IHostService

Type | Description
Gallio.Runtime.Hosting.BaseHostService | Base implementation of IHostService that performs argument validation. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IHostService Members
Gallio.Runtime.Hosting Namespace


IHostService Members

IHostService Members
See Also Example Methods
[image]

A host service enables a local client to interact with a remotely executing hosting environment.

A host service implementation may choose to implement a keep-alive mechanism to automatically shut itself down when the service is disposed or when it has not received a ping within a set period of time.

The following tables list the members exposed by IHostService.

Public Methods

 | Name | Description
Public method | CreateInstance | Creates an instance of a remote object given an assembly name and type name.
Public method | CreateInstanceFrom | Creates an instance of a remote object given an assembly path and type name.
Public method | Do | Asks the host to perform the specified action remotely. The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null).
Public method | Ping | Pings the host to verify and maintain connectivity.
Top

See Also

IHostService Interface
Gallio.Runtime.Hosting Namespace


Methods

IHostService Methods
[image]

Public Methods

 | Name | Description
Public method | CreateInstance | Creates an instance of a remote object given an assembly name and type name.
Public method | CreateInstanceFrom | Creates an instance of a remote object given an assembly path and type name.
Public method | Do | Asks the host to perform the specified action remotely. The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null).
Public method | Ping | Pings the host to verify and maintain connectivity.
Top

See Also

IHostService Interface
Gallio.Runtime.Hosting Namespace


CreateInstance Method

IHostService.CreateInstance Method
[image]

Creates an instance of a remote object given an assembly name and type name.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateInstance( _
ByVal assemblyName As String, _
ByVal typeName As String _
) As ObjectHandle
C#
ObjectHandle CreateInstance(
string assemblyName,
string typeName
)
C++
ObjectHandle CreateInstance(
String assemblyName,
String typeName
) abstract
J#
ObjectHandle CreateInstance(
string assemblyName,
string typeName
)
JScript
function CreateInstance(
assemblyName : String,
typeName : String
) : ObjectHandle

Parameters

assemblyName
The name of assembly that contains the type
typeName
The full name of the type

Return Value

The object handle of the instance

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyName or typeName is null

See Also

IHostService Interface
Gallio.Runtime.Hosting Namespace


CreateInstanceFrom Method

IHostService.CreateInstanceFrom Method
[image]

Creates an instance of a remote object given an assembly path and type name.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateInstanceFrom( _
ByVal assemblyPath As String, _
ByVal typeName As String _
) As ObjectHandle
C#
ObjectHandle CreateInstanceFrom(
string assemblyPath,
string typeName
)
C++
ObjectHandle CreateInstanceFrom(
String assemblyPath,
String typeName
) abstract
J#
ObjectHandle CreateInstanceFrom(
string assemblyPath,
string typeName
)
JScript
function CreateInstanceFrom(
assemblyPath : String,
typeName : String
) : ObjectHandle

Parameters

assemblyPath
The path of assembly that contains the type
typeName
The full name of the type

Return Value

The object handle of the instance

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyPath or typeName is null

See Also

IHostService Interface
Gallio.Runtime.Hosting Namespace


Do Generic Method

IHostService.Do Generic Method
[image]

Asks the host to perform the specified action remotely.

The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null).

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Do(Of TArg, TResult)( _
ByVal func As Func(Of TArg, TResult), _
ByVal arg As TArg _
)
C#
TResult Do<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
C++
TResult Do<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
) abstract
J#
TResult Do<TArg, TResult>(
Func<TArg, TResult> func,
TArg arg
)
JScript
JScript does not support generic types and methods.

Type Parameters

TArg
The argument type
TResult
The result type

Parameters

func
The action to perform
arg
The argument value, if any

Return Value

The result value, if any

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if func is null

See Also

IHostService Interface
Gallio.Runtime.Hosting Namespace


Ping Method

IHostService.Ping Method
[image]

Pings the host to verify and maintain connectivity.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Ping()
C#
void Ping()
C++
void Ping() abstract
J#
void Ping()
JScript
function Ping()

Exceptions

Exception Type | Condition
HostException | Thrown if the remote host is unreachable

See Also

IHostService Interface
Gallio.Runtime.Hosting Namespace


IRemoteHostService Interface

IRemoteHostService Interface
See Also Example Members
[image]

A specialization of host service designed for hosts that are remotely managed.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRemoteHostService
Implements IHostService
C#
public interface IRemoteHostService : IHostService
C++
interface class IRemoteHostService : IHostService
J#
public interface IRemoteHostService implements IHostService
JScript
public interface IRemoteHostService extends IHostService

Types that implement IRemoteHostService

Type | Description
Gallio.Runtime.Hosting.RemoteHostService | A remotely accessible host service.

See Also

IRemoteHostService Members
Gallio.Runtime.Hosting Namespace


IRemoteHostService Members

IRemoteHostService Members
See Also Example Methods
[image]

A specialization of host service designed for hosts that are remotely managed.

The following tables list the members exposed by IRemoteHostService.

Public Methods

 | Name | Description
Public method | Shutdown | Remotely shuts down the host service.
Top

See Also

IRemoteHostService Interface
Gallio.Runtime.Hosting Namespace


Methods

IRemoteHostService Methods
[image]

Public Methods

 | Name | Description
Public method | Shutdown | Remotely shuts down the host service.
Top

See Also

IRemoteHostService Interface
Gallio.Runtime.Hosting Namespace


Shutdown Method

IRemoteHostService.Shutdown Method
[image]

Remotely shuts down the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Shutdown()
C#
void Shutdown()
C++
void Shutdown() abstract
J#
void Shutdown()
JScript
function Shutdown()

See Also

IRemoteHostService Interface
Gallio.Runtime.Hosting Namespace


IsolatedAppDomainHost Class

IsolatedAppDomainHost Class
See Also Example Members
[image]

An isolated app domain host is a IHost the runs code within an isolated AppDomain of this process. Communication with the AppDomain occurs over an inter-AppDomain .Net remoting channel.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class IsolatedAppDomainHost
Inherits RemoteHost
C#
public class IsolatedAppDomainHost : RemoteHost
C++
ref class IsolatedAppDomainHost : RemoteHost
J#
public class IsolatedAppDomainHost extends RemoteHost
JScript
public class IsolatedAppDomainHost extends RemoteHost

Remarks

The IsolatedAppDomainHost does not support the LegacyUnhandledExceptionPolicyEnabled option because it seems to be ignored by the .Net runtime except when set on the default AppDomain of the process.

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHost
Gallio.Runtime.Hosting.RemoteHost
Gallio.Runtime.Hosting.IsolatedAppDomainHost

See Also

IsolatedAppDomainHost Members
Gallio.Runtime.Hosting Namespace


IsolatedAppDomainHost Members

IsolatedAppDomainHost Members
See Also Example Constructors Properties Methods Events
[image]

An isolated app domain host is a IHost the runs code within an isolated AppDomain of this process. Communication with the AppDomain occurs over an inter-AppDomain .Net remoting channel.

The following tables list the members exposed by IsolatedAppDomainHost.

Public Constructors

 | Name | Description
Public method | IsolatedAppDomainHost | Creates an uninitialized host.
Top

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected. (inherited from BaseHost)
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options. (inherited from RemoteHost)
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected. (inherited from BaseHost)
Family property | HostSetup | Gets the internal host setup information without copying it. (inherited from BaseHost)
Family property | Logger | Gets the logger. (inherited from BaseHost)
Top

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service. (inherited from RemoteHost)
Family method | AcquireRemoteHostService | Overridden. Connects to the remote host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | ReleaseHostService | Releases the host service. (inherited from RemoteHost)
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately. (inherited from BaseHost)
Top

See Also

IsolatedAppDomainHost Class
Gallio.Runtime.Hosting Namespace


IsolatedAppDomainHost Constructor

IsolatedAppDomainHost Constructor
[image]

Creates an uninitialized host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger, _
ByVal debuggerManager As IDebuggerManager _
)
C#
public IsolatedAppDomainHost(
HostSetup hostSetup,
ILogger logger,
IDebuggerManager debuggerManager
)
C++
public:
IsolatedAppDomainHost(
HostSetup hostSetup,
ILogger logger,
IDebuggerManager debuggerManager
) sealed
J#
public IsolatedAppDomainHost(
HostSetup hostSetup,
ILogger logger,
IDebuggerManager debuggerManager
)
JScript
public function IsolatedAppDomainHost(
hostSetup : HostSetup,
logger : ILogger,
debuggerManager : IDebuggerManager
)

Parameters

hostSetup
The host setup
logger
The logger for host message output
debuggerManager
The debugger manager

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostSetup, logger or debuggerManager is null

See Also

IsolatedAppDomainHost Class
Gallio.Runtime.Hosting Namespace


Methods

IsolatedAppDomainHost Methods
[image]

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service. (inherited from RemoteHost)
Family method | AcquireRemoteHostService | Overridden. Connects to the remote host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | ReleaseHostService | Releases the host service. (inherited from RemoteHost)
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

See Also

IsolatedAppDomainHost Class
Gallio.Runtime.Hosting Namespace


AcquireRemoteHostService Method

IsolatedAppDomainHost.AcquireRemoteHostService Method
[image]

Connects to the remote host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function AcquireRemoteHostService() As IRemoteHostService
C#
protected override IRemoteHostService AcquireRemoteHostService()
C++
protected:
virtual IRemoteHostService AcquireRemoteHostService() override
J#
protected override IRemoteHostService AcquireRemoteHostService()
JScript
protected override function AcquireRemoteHostService() : IRemoteHostService

Return Value

The remote host service

See Also

IsolatedAppDomainHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method

IsolatedAppDomainHost.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseHost)
Family method | Dispose (Boolean) | Overridden. Disposes the host.

See Also

IsolatedAppDomainHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method (Boolean)

IsolatedAppDomainHost.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

IsolatedAppDomainHost Class
Gallio.Runtime.Hosting Namespace
IsolatedAppDomainHost.Dispose Overload List


IsolatedAppDomainHostFactory Class

IsolatedAppDomainHostFactory Class
See Also Example Members
[image]

A factory for initialized IsolatedAppDomainHost hosts.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class IsolatedAppDomainHostFactory
Inherits BaseHostFactory
C#
public class IsolatedAppDomainHostFactory : BaseHostFactory
C++
ref class IsolatedAppDomainHostFactory : BaseHostFactory
J#
public class IsolatedAppDomainHostFactory extends BaseHostFactory
JScript
public class IsolatedAppDomainHostFactory extends BaseHostFactory

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHostFactory
Gallio.Runtime.Hosting.IsolatedAppDomainHostFactory

See Also

IsolatedAppDomainHostFactory Members
Gallio.Runtime.Hosting Namespace


IsolatedAppDomainHostFactory Members

IsolatedAppDomainHostFactory Members
See Also Example Constructors Fields Methods
[image]

A factory for initialized IsolatedAppDomainHost hosts.

The following tables list the members exposed by IsolatedAppDomainHostFactory.

Public Constructors

 | Name | Description
Public method | IsolatedAppDomainHostFactory | Creates a host factory.
Top

Public Fields

Name | Description
ComponentId | Gets the component Id of this factory. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance. (inherited from BaseHostFactory)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Overridden. Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

IsolatedAppDomainHostFactory Class
Gallio.Runtime.Hosting Namespace


IsolatedAppDomainHostFactory Constructor

IsolatedAppDomainHostFactory Constructor
[image]

Creates a host factory.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal debuggerManager As IDebuggerManager _
)
C#
public IsolatedAppDomainHostFactory(
IDebuggerManager debuggerManager
)
C++
public:
IsolatedAppDomainHostFactory(
IDebuggerManager debuggerManager
) sealed
J#
public IsolatedAppDomainHostFactory(
IDebuggerManager debuggerManager
)
JScript
public function IsolatedAppDomainHostFactory(
debuggerManager : IDebuggerManager
)

Parameters

debuggerManager
A reference to the debugger manager

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if debuggerManager is null

See Also

IsolatedAppDomainHostFactory Class
Gallio.Runtime.Hosting Namespace


Fields

IsolatedAppDomainHostFactory Fields
[image]

Public Fields

Name | Description
ComponentId | Gets the component Id of this factory. This field is read-only.
Top

See Also

IsolatedAppDomainHostFactory Class
Gallio.Runtime.Hosting Namespace


ComponentId Field

IsolatedAppDomainHostFactory.ComponentId Field
[image]

Gets the component Id of this factory. This field is read-only.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ComponentId As String
C#
public static readonly string ComponentId;
C++
public:
static const String ComponentId;
J#
public static final string ComponentId
JScript
public static const var ComponentId : String;

See Also

IsolatedAppDomainHostFactory Class
Gallio.Runtime.Hosting Namespace


Methods

IsolatedAppDomainHostFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance. (inherited from BaseHostFactory)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Overridden. Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

IsolatedAppDomainHostFactory Class
Gallio.Runtime.Hosting Namespace


CreateHostImpl Method

IsolatedAppDomainHostFactory.CreateHostImpl Method
[image]

Creates the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateHostImpl( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
) As IHost
C#
protected override IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
C++
protected:
virtual IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
) override
J#
protected override IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
JScript
protected override function CreateHostImpl(
hostSetup : HostSetup,
logger : ILogger
) : IHost

Parameters

hostSetup
The canonicalized host setup, non-null
logger
The logger, non-null

Return Value

The host

See Also

IsolatedAppDomainHostFactory Class
Gallio.Runtime.Hosting Namespace


IsolatedProcessHost Class

IsolatedProcessHost Class
See Also Example Members
[image]

An isolated process host is a IHost that runs code within a new external process. Communication with the external process occurs over an inter-process communication channel.

The host application is copied to a unique temporary folder and configured in place according to the HostSetup. Then it is launched and connected to with inter-process communication. The process is pinged periodically by the BinaryIpcClientChannel. Therefore it can be configured to self-terminate when it looks like the connection has been severed.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class IsolatedProcessHost
Inherits RemoteHost
C#
public class IsolatedProcessHost : RemoteHost
C++
ref class IsolatedProcessHost : RemoteHost
J#
public class IsolatedProcessHost extends RemoteHost
JScript
public class IsolatedProcessHost extends RemoteHost

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHost
Gallio.Runtime.Hosting.RemoteHost
Gallio.Runtime.Hosting.IsolatedProcessHost

See Also

IsolatedProcessHost Members
Gallio.Runtime.Hosting Namespace


IsolatedProcessHost Members

IsolatedProcessHost Members
See Also Example Constructors Properties Methods Events
[image]

An isolated process host is a IHost that runs code within a new external process. Communication with the external process occurs over an inter-process communication channel.

The host application is copied to a unique temporary folder and configured in place according to the HostSetup. Then it is launched and connected to with inter-process communication. The process is pinged periodically by the BinaryIpcClientChannel. Therefore it can be configured to self-terminate when it looks like the connection has been severed.

The following tables list the members exposed by IsolatedProcessHost.

Public Constructors

 | Name | Description
Public method | IsolatedProcessHost | Creates an uninitialized host.
Top

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected. (inherited from BaseHost)
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options. (inherited from RemoteHost)
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected. (inherited from BaseHost)
Family property | HostSetup | Gets the internal host setup information without copying it. (inherited from BaseHost)
Family property | Logger | Gets the logger. (inherited from BaseHost)
Top

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service. (inherited from RemoteHost)
Family method | AcquireRemoteHostService | Overridden. Connects to the remote host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | CreateProcessTask | Creates the process task to start the process.
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | PrepareConnection | Prepares the parameters for the remote connection.
Family method | ReleaseHostService | Releases the host service. (inherited from RemoteHost)
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately. (inherited from BaseHost)
Top

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


IsolatedProcessHost Constructor

IsolatedProcessHost Constructor
[image]

Creates an uninitialized host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger, _
ByVal runtimePath As String _
)
C#
public IsolatedProcessHost(
HostSetup hostSetup,
ILogger logger,
string runtimePath
)
C++
public:
IsolatedProcessHost(
HostSetup hostSetup,
ILogger logger,
String runtimePath
) sealed
J#
public IsolatedProcessHost(
HostSetup hostSetup,
ILogger logger,
string runtimePath
)
JScript
public function IsolatedProcessHost(
hostSetup : HostSetup,
logger : ILogger,
runtimePath : String
)

Parameters

hostSetup
The host setup
logger
The logger for host message output
runtimePath
The runtime path where the hosting executable will be found

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostSetuplogger, or runtimePath is null

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


Methods

IsolatedProcessHost Methods
[image]

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service. (inherited from RemoteHost)
Family method | AcquireRemoteHostService | Overridden. Connects to the remote host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | CreateProcessTask | Creates the process task to start the process.
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | PrepareConnection | Prepares the parameters for the remote connection.
Family method | ReleaseHostService | Releases the host service. (inherited from RemoteHost)
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


AcquireRemoteHostService Method

IsolatedProcessHost.AcquireRemoteHostService Method
[image]

Connects to the remote host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function AcquireRemoteHostService() As IRemoteHostService
C#
protected override IRemoteHostService AcquireRemoteHostService()
C++
protected:
virtual IRemoteHostService AcquireRemoteHostService() override
J#
protected override IRemoteHostService AcquireRemoteHostService()
JScript
protected override function AcquireRemoteHostService() : IRemoteHostService

Return Value

The remote host service

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


CreateProcessTask Method

IsolatedProcessHost.CreateProcessTask Method
[image]

Creates the process task to start the process.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateProcessTask( _
ByVal executablePath As String, _
ByVal arguments As String, _
ByVal workingDirectory As String _
) As ProcessTask
C#
protected virtual ProcessTask CreateProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
C++
protected:
virtual ProcessTask CreateProcessTask(
String executablePath,
String arguments,
String workingDirectory
)
J#
protected virtual ProcessTask CreateProcessTask(
string executablePath,
string arguments,
string workingDirectory
)
JScript
protected virtual function CreateProcessTask(
executablePath : String,
arguments : String,
workingDirectory : String
) : ProcessTask

Parameters

executablePath
The executable path
arguments
The command-line arguments
workingDirectory
The working directory

Return Value

The process task

Remarks

This method can be overridden to change how the process is started.

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method

IsolatedProcessHost.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseHost)
Family method | Dispose (Boolean) | Overridden. Disposes the host.

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method (Boolean)

IsolatedProcessHost.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace
IsolatedProcessHost.Dispose Overload List


PrepareConnection Method

IsolatedProcessHost.PrepareConnection Method
[image]

Prepares the parameters for the remote connection.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PrepareConnection( _
ByVal uniqueId As String, _
<OutAttribute> ByRef hostConnectionArguments As String, _
<OutAttribute> ByRef clientChannelFactory As Func(Of IClientChannel), _
<OutAttribute> ByRef callbackChannelFactory As Func(Of IServerChannel) _
)
C#
protected virtual void PrepareConnection(
string uniqueId,
out string hostConnectionArguments,
out Func<IClientChannel> clientChannelFactory,
out Func<IServerChannel> callbackChannelFactory
)
C++
protected:
virtual void PrepareConnection(
String uniqueId,
[OutAttribute] String% hostConnectionArguments,
[OutAttribute] Func<IClientChannel>% clientChannelFactory,
[OutAttribute] Func<IServerChannel>% callbackChannelFactory
)
J#
protected virtual void PrepareConnection(
string uniqueId,
/** @attribute OutAttribute() */ /** @ref */ string hostConnectionArguments,
/** @attribute OutAttribute() */ /** @ref */ Func<IClientChannel> clientChannelFactory,
/** @attribute OutAttribute() */ /** @ref */ Func<IServerChannel> callbackChannelFactory
)
JScript
protected virtual function PrepareConnection(
uniqueId : String,
OutAttribute hostConnectionArguments : String,
OutAttribute clientChannelFactory : Func<IClientChannel>,
OutAttribute callbackChannelFactory : Func<IServerChannel>
)

Parameters

uniqueId
The unique id of the host
hostConnectionArguments
Set to the host application arguments used to configure its server channel
clientChannelFactory
Set to a factory used to create the local client channel
callbackChannelFactory
Set to a factory used to create the local server channel to allow the remote host to call back to this one

See Also

IsolatedProcessHost Class
Gallio.Runtime.Hosting Namespace


IsolatedProcessHostFactory Class

IsolatedProcessHostFactory Class
See Also Example Members
[image]

A factory for initialized IsolatedProcessHost hosts.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class IsolatedProcessHostFactory
Inherits BaseHostFactory
C#
public class IsolatedProcessHostFactory : BaseHostFactory
C++
ref class IsolatedProcessHostFactory : BaseHostFactory
J#
public class IsolatedProcessHostFactory extends BaseHostFactory
JScript
public class IsolatedProcessHostFactory extends BaseHostFactory

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHostFactory
Gallio.Runtime.Hosting.IsolatedProcessHostFactory

See Also

IsolatedProcessHostFactory Members
Gallio.Runtime.Hosting Namespace


IsolatedProcessHostFactory Members

IsolatedProcessHostFactory Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

A factory for initialized IsolatedProcessHost hosts.

The following tables list the members exposed by IsolatedProcessHostFactory.

Public Constructors

Name | Description
IsolatedProcessHostFactory | Overloaded.
Top

Public Fields

Name | Description
ComponentId | Gets the component Id of this factory. This field is read-only.
Top

Protected Properties

 | Name | Description
Family property | RuntimePath | Gets the path of the runtime components, in particular the folder where Gallio.Host.exe is located.
Top

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance. (inherited from BaseHostFactory)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Overridden. Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
IsolatedProcessHostFactory | Overloaded.
Top

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


IsolatedProcessHostFactory Constructor

IsolatedProcessHostFactory Constructor

Overload List

 | Name | Description
Public method | IsolatedProcessHostFactory (IRuntime) | Creates a host factory.
Public method | IsolatedProcessHostFactory (String) | Creates a host factory.

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


IsolatedProcessHostFactory Constructor (IRuntime)

IsolatedProcessHostFactory Constructor (IRuntime)
See Also Example
[image]

Creates a host factory.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal runtime As IRuntime _
)
C#
public IsolatedProcessHostFactory(
IRuntime runtime
)
C++
public:
IsolatedProcessHostFactory(
IRuntime runtime
) sealed
J#
public IsolatedProcessHostFactory(
IRuntime runtime
)
JScript
public function IsolatedProcessHostFactory(
runtime : IRuntime
)

Parameters

runtime
The runtime

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if runtime is null

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace
IsolatedProcessHostFactory Constructor Overload List


IsolatedProcessHostFactory Constructor (String)

IsolatedProcessHostFactory Constructor (String)
See Also Example
[image]

Creates a host factory.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal runtimePath As String _
)
C#
public IsolatedProcessHostFactory(
string runtimePath
)
C++
public:
IsolatedProcessHostFactory(
String runtimePath
) sealed
J#
public IsolatedProcessHostFactory(
string runtimePath
)
JScript
public function IsolatedProcessHostFactory(
runtimePath : String
)

Parameters

runtimePath
The path of the runtime components, in particular the folder where Gallio.Host.exe is located

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if runtimePath is null

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace
IsolatedProcessHostFactory Constructor Overload List


Fields

IsolatedProcessHostFactory Fields
[image]

Public Fields

Name | Description
ComponentId | Gets the component Id of this factory. This field is read-only.
Top

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


ComponentId Field

IsolatedProcessHostFactory.ComponentId Field
[image]

Gets the component Id of this factory. This field is read-only.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ComponentId As String
C#
public static readonly string ComponentId;
C++
public:
static const String ComponentId;
J#
public static final string ComponentId
JScript
public static const var ComponentId : String;

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


Properties

IsolatedProcessHostFactory Properties
[image]

Protected Properties

 | Name | Description
Family property | RuntimePath | Gets the path of the runtime components, in particular the folder where Gallio.Host.exe is located.
Top

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


RuntimePath Property

IsolatedProcessHostFactory.RuntimePath Property
[image]

Gets the path of the runtime components, in particular the folder where Gallio.Host.exe is located.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RuntimePath As String
C#
protected string RuntimePath { get; }
C++
protected property string RuntimePath sealed {
String get();
}
J#
/** property */
protected string get_RuntimePath();
JScript
protected function get RuntimePath() : String

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


Methods

IsolatedProcessHostFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance. (inherited from BaseHostFactory)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Overridden. Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


CreateHostImpl Method

IsolatedProcessHostFactory.CreateHostImpl Method
[image]

Creates the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateHostImpl( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
) As IHost
C#
protected override IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
C++
protected:
virtual IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
) override
J#
protected override IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
JScript
protected override function CreateHostImpl(
hostSetup : HostSetup,
logger : ILogger
) : IHost

Parameters

hostSetup
The canonicalized host setup, non-null
logger
The logger, non-null

Return Value

The host

See Also

IsolatedProcessHostFactory Class
Gallio.Runtime.Hosting Namespace


LocalHost Class

LocalHost Class
See Also Example Members
[image]

An implementation of IHost that runs code locally within the current AppDomain.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LocalHost
Inherits BaseHost
C#
public class LocalHost : BaseHost
C++
ref class LocalHost : BaseHost
J#
public class LocalHost extends BaseHost
JScript
public class LocalHost extends BaseHost

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHost
Gallio.Runtime.Hosting.LocalHost

See Also

LocalHost Members
Gallio.Runtime.Hosting Namespace


LocalHost Members

LocalHost Members
See Also Example Constructors Properties Methods Events
[image]

An implementation of IHost that runs code locally within the current AppDomain.

The following tables list the members exposed by LocalHost.

Public Constructors

 | Name | Description
Public method | LocalHost | Creates a local host.
Top

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected. (inherited from BaseHost)
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected. (inherited from BaseHost)
Family property | HostSetup | Gets the internal host setup information without copying it. (inherited from BaseHost)
Family property | Logger | Gets the logger. (inherited from BaseHost)
Top

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | ReleaseHostService | Releases the host service.
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately. (inherited from BaseHost)
Top

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


LocalHost Constructor

LocalHost Constructor
[image]

Creates a local host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger, _
ByVal debuggerManager As IDebuggerManager _
)
C#
public LocalHost(
HostSetup hostSetup,
ILogger logger,
IDebuggerManager debuggerManager
)
C++
public:
LocalHost(
HostSetup hostSetup,
ILogger logger,
IDebuggerManager debuggerManager
) sealed
J#
public LocalHost(
HostSetup hostSetup,
ILogger logger,
IDebuggerManager debuggerManager
)
JScript
public function LocalHost(
hostSetup : HostSetup,
logger : ILogger,
debuggerManager : IDebuggerManager
)

Parameters

hostSetup
The host setup
logger
The logger for host message output
debuggerManager
The debugger manager

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostSetup, logger or debuggerManager is null

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


Properties

LocalHost Properties
[image]

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected. (inherited from BaseHost)
Public property | IsLocal | Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected. (inherited from BaseHost)
Family property | HostSetup | Gets the internal host setup information without copying it. (inherited from BaseHost)
Family property | Logger | Gets the logger. (inherited from BaseHost)
Top

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


IsLocal Property

LocalHost.IsLocal Property
[image]

Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLocal As Boolean _
Implements IHost.IsLocal
C#
public bool IsLocal { get; }
C++
public property bool IsLocal sealed {
bool get();
}
J#
/** property */
public bool get_IsLocal();
JScript
public function get IsLocal() : bool

Implements

IHost.IsLocal

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


Methods

LocalHost Methods
[image]

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | ReleaseHostService | Releases the host service.
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


AcquireHostService Method

LocalHost.AcquireHostService Method
[image]

Gets the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function AcquireHostService() As IHostService
C#
protected IHostService AcquireHostService()
C++
protected:
IHostService AcquireHostService() sealed
J#
protected IHostService AcquireHostService()
JScript
protected function AcquireHostService() : IHostService

Return Value

The host service, or null if the host service was not available

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method

LocalHost.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseHost)
Family method | Dispose (Boolean) | Overridden. Disposes the host.

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method (Boolean)

LocalHost.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace
LocalHost.Dispose Overload List


ReleaseHostService Method

LocalHost.ReleaseHostService Method
[image]

Releases the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ReleaseHostService( _
ByVal hostService As IHostService _
)
C#
protected void ReleaseHostService(
IHostService hostService
)
C++
protected:
void ReleaseHostService(
IHostService hostService
) sealed
J#
protected void ReleaseHostService(
IHostService hostService
)
JScript
protected function ReleaseHostService(
hostService : IHostService
)

Parameters

hostService
The host service that is being released, not null

See Also

LocalHost Class
Gallio.Runtime.Hosting Namespace


LocalHostFactory Class

LocalHostFactory Class
See Also Example Members
[image]

A factory for initialized LocalHost hosts.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LocalHostFactory
Inherits BaseHostFactory
C#
public class LocalHostFactory : BaseHostFactory
C++
ref class LocalHostFactory : BaseHostFactory
J#
public class LocalHostFactory extends BaseHostFactory
JScript
public class LocalHostFactory extends BaseHostFactory

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHostFactory
Gallio.Runtime.Hosting.LocalHostFactory

See Also

LocalHostFactory Members
Gallio.Runtime.Hosting Namespace


LocalHostFactory Members

LocalHostFactory Members
See Also Example Constructors Fields Methods
[image]

A factory for initialized LocalHost hosts.

The following tables list the members exposed by LocalHostFactory.

Public Constructors

 | Name | Description
Public method | LocalHostFactory | Creates a host factory.
Top

Public Fields

Name | Description
ComponentId | Gets the component Id of this factory. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance. (inherited from BaseHostFactory)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Overridden. Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LocalHostFactory Class
Gallio.Runtime.Hosting Namespace


LocalHostFactory Constructor

LocalHostFactory Constructor
[image]

Creates a host factory.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal debuggerManager As IDebuggerManager _
)
C#
public LocalHostFactory(
IDebuggerManager debuggerManager
)
C++
public:
LocalHostFactory(
IDebuggerManager debuggerManager
) sealed
J#
public LocalHostFactory(
IDebuggerManager debuggerManager
)
JScript
public function LocalHostFactory(
debuggerManager : IDebuggerManager
)

Parameters

debuggerManager
A reference to the debugger manager

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if debuggerManager is null

See Also

LocalHostFactory Class
Gallio.Runtime.Hosting Namespace


Fields

LocalHostFactory Fields
[image]

Public Fields

Name | Description
ComponentId | Gets the component Id of this factory. This field is read-only.
Top

See Also

LocalHostFactory Class
Gallio.Runtime.Hosting Namespace


ComponentId Field

LocalHostFactory.ComponentId Field
[image]

Gets the component Id of this factory. This field is read-only.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly ComponentId As String
C#
public static readonly string ComponentId;
C++
public:
static const String ComponentId;
J#
public static final string ComponentId
JScript
public static const var ComponentId : String;

See Also

LocalHostFactory Class
Gallio.Runtime.Hosting Namespace


Methods

LocalHostFactory Methods
[image]

Public Methods

 | Name | Description
Public method | CreateHost | Creates a host instance. (inherited from BaseHostFactory)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | CreateHostImpl | Overridden. Creates the host.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LocalHostFactory Class
Gallio.Runtime.Hosting Namespace


CreateHostImpl Method

LocalHostFactory.CreateHostImpl Method
[image]

Creates the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateHostImpl( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger _
) As IHost
C#
protected override IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
C++
protected:
virtual IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
) override
J#
protected override IHost CreateHostImpl(
HostSetup hostSetup,
ILogger logger
)
JScript
protected override function CreateHostImpl(
hostSetup : HostSetup,
logger : ILogger
) : IHost

Parameters

hostSetup
The canonicalized host setup, non-null
logger
The logger, non-null

Return Value

The host

See Also

LocalHostFactory Class
Gallio.Runtime.Hosting Namespace


RemoteHost Class

RemoteHost Class
See Also Example Members
[image]

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RemoteHost
Inherits BaseHost
C#
public abstract class RemoteHost : BaseHost
C++
ref class RemoteHost abstract : BaseHost
J#
public class RemoteHost extends BaseHost
JScript
public class RemoteHost extends BaseHost

Inheritance Hierarchy

System.Object
Gallio.Runtime.Hosting.BaseHost
Gallio.Runtime.Hosting.RemoteHost
Gallio.Runtime.Hosting.IsolatedAppDomainHost
Gallio.Runtime.Hosting.IsolatedProcessHost

See Also

RemoteHost Members
Gallio.Runtime.Hosting Namespace


RemoteHost Members

RemoteHost Members
See Also Example Constructors Properties Methods Events
[image]

The following tables list the members exposed by RemoteHost.

Protected Constructors

 | Name | Description
Family method | RemoteHost | Creates an uninitialized host.
Top

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected. (inherited from BaseHost)
Public property | IsLocal | Overridden. Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected. (inherited from BaseHost)
Family property | HostSetup | Gets the internal host setup information without copying it. (inherited from BaseHost)
Family property | Logger | Gets the logger. (inherited from BaseHost)
Top

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service.
Family method | AcquireRemoteHostService | Connects to the remote host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | ReleaseHostService | Releases the host service.
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

Public Events

 | Name | Description
Public event | Disconnected | An event that is raised when the host is disconnected. If the host has already been disconnected, the event is fired immediately. (inherited from BaseHost)
Top

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


RemoteHost Constructor

RemoteHost Constructor
[image]

Creates an uninitialized host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal hostSetup As HostSetup, _
ByVal logger As ILogger, _
ByVal pingInterval As Nullable(Of TimeSpan) _
)
C#
protected RemoteHost(
HostSetup hostSetup,
ILogger logger,
Nullable<TimeSpan> pingInterval
)
C++
protected:
RemoteHost(
HostSetup hostSetup,
ILogger logger,
Nullable<TimeSpan> pingInterval
) sealed
J#
protected RemoteHost(
HostSetup hostSetup,
ILogger logger,
Nullable<TimeSpan> pingInterval
)
JScript
protected function RemoteHost(
hostSetup : HostSetup,
logger : ILogger,
pingInterval : Nullable<TimeSpan>
)

Parameters

hostSetup
The host setup
logger
The logger for host message output
pingInterval
The automatic ping interval, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostSetup or logger is null

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


Properties

RemoteHost Properties
[image]

Public Properties

 | Name | Description
Public property | IsConnected | Returns true if the host is connected. (inherited from BaseHost)
Public property | IsLocal | Overridden. Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.
Top

Protected Properties

 | Name | Description
Family property | HostService | Gets an reference to the host service, or null if not connected. (inherited from BaseHost)
Family property | HostSetup | Gets the internal host setup information without copying it. (inherited from BaseHost)
Family property | Logger | Gets the logger. (inherited from BaseHost)
Top

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


IsLocal Property

RemoteHost.IsLocal Property
[image]

Returns true if the host is local to the creating AppDomain, false if it must be accessed across a remote channel. A local host might not support all configuration options.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsLocal As Boolean _
Implements IHost.IsLocal
C#
public override bool IsLocal { get; }
C++
public override property bool IsLocal override {
bool get();
}
J#
/** property */
public bool get_IsLocal();
JScript
public function get IsLocal() : bool

Implements

IHost.IsLocal

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


Methods

RemoteHost Methods
[image]

Public Methods

 | Name | Description
Public method | Connect | Initializes the host and connects to the host service. (inherited from BaseHost)
Public method | Disconnect | Disconnects the host. (inherited from BaseHost)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetHostService | Gets a host service that can be used to perform operations within the host's environment. (inherited from BaseHost)
Public method | GetHostSetup | Gets a deep copy of the host setup information. (inherited from BaseHost)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AcquireHostService | Gets the host service.
Family method | AcquireRemoteHostService | Connects to the remote host service.
Family method | AttachDebuggerIfNeeded | Attaches the debugger to a process if the host settings require it. (inherited from BaseHost)
Family method | DetachDebuggerIfNeeded | Detaches the debugger from a process if the host settings require it. (inherited from BaseHost)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyDisconnected | Sets the state of the host to disconnected and notifies clients. (inherited from BaseHost)
Family method | ReleaseHostService | Releases the host service.
Family method | ThrowIfDisposed | Throws an exception if the host has been disposed. (inherited from BaseHost)
Top

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


AcquireHostService Method

RemoteHost.AcquireHostService Method
[image]

Gets the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function AcquireHostService() As IHostService
C#
protected IHostService AcquireHostService()
C++
protected:
IHostService AcquireHostService() sealed
J#
protected IHostService AcquireHostService()
JScript
protected function AcquireHostService() : IHostService

Return Value

The host service, or null if the host service was not available

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


AcquireRemoteHostService Method

RemoteHost.AcquireRemoteHostService Method
[image]

Connects to the remote host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function AcquireRemoteHostService() As IRemoteHostService
C#
protected abstract IRemoteHostService AcquireRemoteHostService()
C++
protected:
IRemoteHostService AcquireRemoteHostService() abstract
J#
protected abstract IRemoteHostService AcquireRemoteHostService()
JScript
protected abstract function AcquireRemoteHostService() : IRemoteHostService

Return Value

The remote host service

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method

RemoteHost.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseHost)
Family method | Dispose (Boolean) | Overridden. Disposes the host.

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


Dispose Method (Boolean)

RemoteHost.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace
RemoteHost.Dispose Overload List


ReleaseHostService Method

RemoteHost.ReleaseHostService Method
[image]

Releases the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ReleaseHostService( _
ByVal hostService As IHostService _
)
C#
protected void ReleaseHostService(
IHostService hostService
)
C++
protected:
void ReleaseHostService(
IHostService hostService
) sealed
J#
protected void ReleaseHostService(
IHostService hostService
)
JScript
protected function ReleaseHostService(
hostService : IHostService
)

Parameters

hostService
The host service that is being released, not null

See Also

RemoteHost Class
Gallio.Runtime.Hosting Namespace


RemoteHostService Class

RemoteHostService Class
See Also Example Members
[image]

A remotely accessible host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RemoteHostService
Inherits BaseHostService
Implements IRemoteHostService
C#
public class RemoteHostService : BaseHostService, IRemoteHostService
C++
ref class RemoteHostService : BaseHostService, IRemoteHostService
J#
public class RemoteHostService extends BaseHostService implements IRemoteHostService
JScript
public class RemoteHostService extends BaseHostService, IRemoteHostService

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runtime.Hosting.BaseHostService
Gallio.Runtime.Hosting.RemoteHostService

See Also

RemoteHostService Members
Gallio.Runtime.Hosting Namespace


RemoteHostService Members

RemoteHostService Members
See Also Example Constructors Properties Methods
[image]

A remotely accessible host service.

The following tables list the members exposed by RemoteHostService.

Public Constructors

 | Name | Description
Public method | RemoteHostService | Creates a host service.
Top

Public Properties

 | Name | Description
Public property | WatchdogTimerExpired | Returns true if the watchdog timer expired.
Top

Public Methods

 | Name | Description
Public method | CreateInstance | Creates an instance of a remote object given an assembly name and type name. (inherited from BaseHostService)
Public method | CreateInstanceFrom | Creates an instance of a remote object given an assembly path and type name. (inherited from BaseHostService)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Do | Asks the host to perform the specified action remotely. The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null). (inherited from BaseHostService)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Ping | Pings the host to verify and maintain connectivity. (inherited from BaseHostService)
Public method | Shutdown | Remotely shuts down the host service.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WaitUntilShutdown | Waits until the host service is shutdown or a ping timeout occurs.
Top

Protected Methods

 | Name | Description
Family method | CreateInstanceFromImpl | Internal implementation of CreateInstanceFrom. (inherited from BaseHostService)
Family method | CreateInstanceImpl | Internal implementation of CreateInstance. (inherited from BaseHostService)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | DoImpl | Internal implementation of Do. (inherited from BaseHostService)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | PingImpl | Overridden. Internal implementation of Ping.
Family method | ThrowIfDisposed | Throws an exception if the host service has been disposed. (inherited from BaseHostService)
Top

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


RemoteHostService Constructor

RemoteHostService Constructor
[image]

Creates a host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal watchdogTimeout As Nullable(Of TimeSpan) _
)
C#
public RemoteHostService(
Nullable<TimeSpan> watchdogTimeout
)
C++
public:
RemoteHostService(
Nullable<TimeSpan> watchdogTimeout
) sealed
J#
public RemoteHostService(
Nullable<TimeSpan> watchdogTimeout
)
JScript
public function RemoteHostService(
watchdogTimeout : Nullable<TimeSpan>
)

Parameters

watchdogTimeout
The maximum amount of time to wait for a ping before automatically disposing the host service, or null if there should be no timeout

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


Properties

RemoteHostService Properties
[image]

Public Properties

 | Name | Description
Public property | WatchdogTimerExpired | Returns true if the watchdog timer expired.
Top

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


WatchdogTimerExpired Property

RemoteHostService.WatchdogTimerExpired Property
[image]

Returns true if the watchdog timer expired.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WatchdogTimerExpired As Boolean
C#
public bool WatchdogTimerExpired { get; }
C++
public property bool WatchdogTimerExpired sealed {
bool get();
}
J#
/** property */
public bool get_WatchdogTimerExpired();
JScript
public function get WatchdogTimerExpired() : bool

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


Methods

RemoteHostService Methods
[image]

Public Methods

 | Name | Description
Public method | CreateInstance | Creates an instance of a remote object given an assembly name and type name. (inherited from BaseHostService)
Public method | CreateInstanceFrom | Creates an instance of a remote object given an assembly path and type name. (inherited from BaseHostService)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Do | Asks the host to perform the specified action remotely. The action must be a serializable delegate so that it can be sent to the host and executed. Generally speaking, this means it must either be a delegate for a static method or its target object must be serializable. The argument and result values must also be serializable (or null). (inherited from BaseHostService)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from LongLivedMarshalByRefObject)
Public method | Ping | Pings the host to verify and maintain connectivity. (inherited from BaseHostService)
Public method | Shutdown | Remotely shuts down the host service.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WaitUntilShutdown | Waits until the host service is shutdown or a ping timeout occurs.
Top

Protected Methods

 | Name | Description
Family method | CreateInstanceFromImpl | Internal implementation of CreateInstanceFrom. (inherited from BaseHostService)
Family method | CreateInstanceImpl | Internal implementation of CreateInstance. (inherited from BaseHostService)
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | DoImpl | Internal implementation of Do. (inherited from BaseHostService)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | PingImpl | Overridden. Internal implementation of Ping.
Family method | ThrowIfDisposed | Throws an exception if the host service has been disposed. (inherited from BaseHostService)
Top

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


Dispose Method

RemoteHostService.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseHostService)
Family method | Dispose (Boolean) | Overridden. Disposes the host service.

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


Dispose Method (Boolean)

RemoteHostService.Dispose Method (Boolean)
See Also Example
[image]

Disposes the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
True if disposing

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace
RemoteHostService.Dispose Overload List


PingImpl Method

RemoteHostService.PingImpl Method
[image]

Internal implementation of Ping.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PingImpl()
C#
protected override void PingImpl()
C++
protected:
virtual void PingImpl() override
J#
protected override void PingImpl()
JScript
protected override function PingImpl()

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


Shutdown Method

RemoteHostService.Shutdown Method
[image]

Remotely shuts down the host service.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Shutdown() _
Implements IRemoteHostService.Shutdown
C#
public void Shutdown()
C++
public:
void Shutdown() sealed
J#
public void Shutdown()
JScript
public function Shutdown()

Implements

IRemoteHostService.Shutdown

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


WaitUntilShutdown Method

RemoteHostService.WaitUntilShutdown Method
[image]

Waits until the host service is shutdown or a ping timeout occurs.

Namespace: Gallio.Runtime.Hosting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub WaitUntilShutdown()
C#
public void WaitUntilShutdown()
C++
public:
void WaitUntilShutdown() sealed
J#
public void WaitUntilShutdown()
JScript
public function WaitUntilShutdown()

See Also

RemoteHostService Class
Gallio.Runtime.Hosting Namespace


Gallio.Runtime.Loader

Gallio.Runtime.Loader Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AssemblyResolverBootstrap | Bootstraps a globally reachable assembly resolver manager within the Gallio installation path. May be used by clients to ensure that Gallio assemblies can be resolved assuming we were able to load the main assembly and access the bootstrap. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | DefaultAssemblyResolverManager | Resolves assemblies using hint paths and custom resolvers.
Public class | DefaultLoader | Default implementation of a loader.

Interfaces

 | Interface | Description
Public interface | IAssemblyResolver | A custom assembly resolver participates in assembly resolution when standard assembly resolution fails to load the desired assembly but before assembly load paths are considered.
Public interface | IAssemblyResolverManager | Provides support for resolving assemblies using hint paths and custom resolvers.
Public interface | ILoader | Provides services to assist with loading tests and dependent resources.


AssemblyResolverBootstrap Class

AssemblyResolverBootstrap Class
See Also Example Members
[image]

Bootstraps a globally reachable assembly resolver manager within the Gallio installation path. May be used by clients to ensure that Gallio assemblies can be resolved assuming we were able to load the main assembly and access the bootstrap. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module AssemblyResolverBootstrap
C#
public static class AssemblyResolverBootstrap
C++
ref class AssemblyResolverBootstrap abstract sealed
J#
public final class AssemblyResolverBootstrap
JScript
public class AssemblyResolverBootstrap

Inheritance Hierarchy

System.Object
Gallio.Runtime.Loader.AssemblyResolverBootstrap

See Also

AssemblyResolverBootstrap Members
Gallio.Runtime.Loader Namespace


AssemblyResolverBootstrap Members

AssemblyResolverBootstrap Members
See Also Example Properties Methods
[image]

Bootstraps a globally reachable assembly resolver manager within the Gallio installation path. May be used by clients to ensure that Gallio assemblies can be resolved assuming we were able to load the main assembly and access the bootstrap. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AssemblyResolverBootstrap.

Public Properties

Name | Description
AssemblyResolverManager | Gets the bootstrapped assembly resolver manager.
Top

Public Methods

Name | Description
Install | Installs a global assembly resolver given the specified runtime path.
Top

See Also

AssemblyResolverBootstrap Class
Gallio.Runtime.Loader Namespace


Properties

AssemblyResolverBootstrap Properties
[image]

Public Properties

Name | Description
AssemblyResolverManager | Gets the bootstrapped assembly resolver manager.
Top

See Also

AssemblyResolverBootstrap Class
Gallio.Runtime.Loader Namespace


AssemblyResolverManager Property

AssemblyResolverBootstrap.AssemblyResolverManager Property
[image]

Gets the bootstrapped assembly resolver manager.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AssemblyResolverManager As IAssemblyResolverManager
C#
public static IAssemblyResolverManager AssemblyResolverManager { get; }
C++
public static property IAssemblyResolverManager AssemblyResolverManager {
IAssemblyResolverManager get();
}
J#
/** property */
public IAssemblyResolverManager get_AssemblyResolverManager();
JScript
public function get AssemblyResolverManager() : IAssemblyResolverManager

Exceptions

Exception Type | Condition
InvalidOperationException | Thrown if the bootstrap resolver has not been initialized

See Also

AssemblyResolverBootstrap Class
Gallio.Runtime.Loader Namespace


Methods

AssemblyResolverBootstrap Methods
[image]

Public Methods

Name | Description
Install | Installs a global assembly resolver given the specified runtime path.
Top

See Also

AssemblyResolverBootstrap Class
Gallio.Runtime.Loader Namespace


Install Method

AssemblyResolverBootstrap.Install Method
[image]

Installs a global assembly resolver given the specified runtime path.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Install( _
ByVal runtimePath As String _
)
C#
public static void Install(
string runtimePath
)
C++
public:
static void Install(
String runtimePath
)
J#
public static void Install(
string runtimePath
)
JScript
public static function Install(
runtimePath : String
)

Parameters

runtimePath
The Gallio runtime path

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if runtimePath is null

See Also

AssemblyResolverBootstrap Class
Gallio.Runtime.Loader Namespace


DefaultAssemblyResolverManager Class

DefaultAssemblyResolverManager Class
See Also Example Members
[image]

Resolves assemblies using hint paths and custom resolvers.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultAssemblyResolverManager
Implements IAssemblyResolverManager, IDisposable
C#
public class DefaultAssemblyResolverManager : IAssemblyResolverManager, IDisposable
C++
ref class DefaultAssemblyResolverManager : IAssemblyResolverManager, IDisposable
J#
public class DefaultAssemblyResolverManager implements IAssemblyResolverManager, IDisposable
JScript
public class DefaultAssemblyResolverManager extends IAssemblyResolverManager, IDisposable

Inheritance Hierarchy

System.Object
Gallio.Runtime.Loader.DefaultAssemblyResolverManager

See Also

DefaultAssemblyResolverManager Members
Gallio.Runtime.Loader Namespace


DefaultAssemblyResolverManager Members

DefaultAssemblyResolverManager Members
See Also Example Constructors Methods
[image]

Resolves assemblies using hint paths and custom resolvers.

The following tables list the members exposed by DefaultAssemblyResolverManager.

Public Constructors

 | Name | Description
Public method | DefaultAssemblyResolverManager | Initializes the assembly resolver manager.
Top

Public Methods

 | Name | Description
Public method | AddAssemblyResolver | Adds a custom assembly resolver to use when standard assembly resolution fails.
Public method | AddHintDirectory | Adds an assembly load hint directory to search when standard assembly resolution fails.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultAssemblyResolverManager Class
Gallio.Runtime.Loader Namespace


DefaultAssemblyResolverManager Constructor

DefaultAssemblyResolverManager Constructor
[image]

Initializes the assembly resolver manager.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DefaultAssemblyResolverManager()
C++
public:
DefaultAssemblyResolverManager() sealed
J#
public DefaultAssemblyResolverManager()
JScript
public function DefaultAssemblyResolverManager()

See Also

DefaultAssemblyResolverManager Class
Gallio.Runtime.Loader Namespace


Methods

DefaultAssemblyResolverManager Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssemblyResolver | Adds a custom assembly resolver to use when standard assembly resolution fails.
Public method | AddHintDirectory | Adds an assembly load hint directory to search when standard assembly resolution fails.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultAssemblyResolverManager Class
Gallio.Runtime.Loader Namespace


AddAssemblyResolver Method

DefaultAssemblyResolverManager.AddAssemblyResolver Method
[image]

Adds a custom assembly resolver to use when standard assembly resolution fails.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddAssemblyResolver( _
ByVal assemblyResolver As IAssemblyResolver _
) _
Implements IAssemblyResolverManager.AddAssemblyResolver
C#
public void AddAssemblyResolver(
IAssemblyResolver assemblyResolver
)
C++
public:
void AddAssemblyResolver(
IAssemblyResolver assemblyResolver
) sealed
J#
public void AddAssemblyResolver(
IAssemblyResolver assemblyResolver
)
JScript
public function AddAssemblyResolver(
assemblyResolver : IAssemblyResolver
)

Parameters

assemblyResolver
The assembly resolver

Implements

IAssemblyResolverManager.AddAssemblyResolver

See Also

DefaultAssemblyResolverManager Class
Gallio.Runtime.Loader Namespace


AddHintDirectory Method

DefaultAssemblyResolverManager.AddHintDirectory Method
[image]

Adds an assembly load hint directory to search when standard assembly resolution fails.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddHintDirectory( _
ByVal hintDirectory As String _
) _
Implements IAssemblyResolverManager.AddHintDirectory
C#
public void AddHintDirectory(
string hintDirectory
)
C++
public:
void AddHintDirectory(
String hintDirectory
) sealed
J#
public void AddHintDirectory(
string hintDirectory
)
JScript
public function AddHintDirectory(
hintDirectory : String
)

Parameters

hintDirectory
The hint directory

Implements

IAssemblyResolverManager.AddHintDirectory

See Also

DefaultAssemblyResolverManager Class
Gallio.Runtime.Loader Namespace


Dispose Method

DefaultAssemblyResolverManager.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

DefaultAssemblyResolverManager Class
Gallio.Runtime.Loader Namespace


DefaultLoader Class

DefaultLoader Class
See Also Example Members
[image]

Default implementation of a loader.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultLoader
Implements ILoader
C#
public class DefaultLoader : ILoader
C++
ref class DefaultLoader : ILoader
J#
public class DefaultLoader implements ILoader
JScript
public class DefaultLoader extends ILoader

Inheritance Hierarchy

System.Object
Gallio.Runtime.Loader.DefaultLoader

See Also

DefaultLoader Members
Gallio.Runtime.Loader Namespace


DefaultLoader Members

DefaultLoader Members
See Also Example Constructors Properties Methods
[image]

Default implementation of a loader.

The following tables list the members exposed by DefaultLoader.

Public Constructors

 | Name | Description
Public method | DefaultLoader | Creates a loader.
Top

Public Properties

 | Name | Description
Public property | AssemblyResolverManager | Gets the assembly resolver manager used to resolve referenced assemblies.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadAssemblyFrom | Loads an assembly from the specified file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultLoader Class
Gallio.Runtime.Loader Namespace


DefaultLoader Constructor

DefaultLoader Constructor
[image]

Creates a loader.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyResolverManager As IAssemblyResolverManager _
)
C#
public DefaultLoader(
IAssemblyResolverManager assemblyResolverManager
)
C++
public:
DefaultLoader(
IAssemblyResolverManager assemblyResolverManager
) sealed
J#
public DefaultLoader(
IAssemblyResolverManager assemblyResolverManager
)
JScript
public function DefaultLoader(
assemblyResolverManager : IAssemblyResolverManager
)

Parameters

assemblyResolverManager
The assembly resolver manager

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyResolverManager is null

See Also

DefaultLoader Class
Gallio.Runtime.Loader Namespace


Properties

DefaultLoader Properties
[image]

Public Properties

 | Name | Description
Public property | AssemblyResolverManager | Gets the assembly resolver manager used to resolve referenced assemblies.
Top

See Also

DefaultLoader Class
Gallio.Runtime.Loader Namespace


AssemblyResolverManager Property

DefaultLoader.AssemblyResolverManager Property
[image]

Gets the assembly resolver manager used to resolve referenced assemblies.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyResolverManager As IAssemblyResolverManager _
Implements ILoader.AssemblyResolverManager
C#
public IAssemblyResolverManager AssemblyResolverManager { get; }
C++
public property IAssemblyResolverManager AssemblyResolverManager sealed {
IAssemblyResolverManager get();
}
J#
/** property */
public IAssemblyResolverManager get_AssemblyResolverManager();
JScript
public function get AssemblyResolverManager() : IAssemblyResolverManager

Implements

ILoader.AssemblyResolverManager

See Also

DefaultLoader Class
Gallio.Runtime.Loader Namespace


Methods

DefaultLoader Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadAssemblyFrom | Loads an assembly from the specified file.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultLoader Class
Gallio.Runtime.Loader Namespace


LoadAssemblyFrom Method

DefaultLoader.LoadAssemblyFrom Method
[image]

Loads an assembly from the specified file.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadAssemblyFrom( _
ByVal assemblyFile As String _
) As Assembly _
Implements ILoader.LoadAssemblyFrom
C#
public Assembly LoadAssemblyFrom(
string assemblyFile
)
C++
public:
Assembly LoadAssemblyFrom(
String assemblyFile
) sealed
J#
public Assembly LoadAssemblyFrom(
string assemblyFile
)
JScript
public function LoadAssemblyFrom(
assemblyFile : String
) : Assembly

Parameters

assemblyFile
The assembly file

Return Value

The loaded assembly

Implements

ILoader.LoadAssemblyFrom

See Also

DefaultLoader Class
Gallio.Runtime.Loader Namespace


IAssemblyResolver Interface

IAssemblyResolver Interface
See Also Example Members
[image]

A custom assembly resolver participates in assembly resolution when standard assembly resolution fails to load the desired assembly but before assembly load paths are considered.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAssemblyResolver
C#
public interface IAssemblyResolver
C++
interface class IAssemblyResolver
J#
public interface IAssemblyResolver
JScript
public interface IAssemblyResolver

See Also

IAssemblyResolver Members
Gallio.Runtime.Loader Namespace
AssemblyResolve


IAssemblyResolver Members

IAssemblyResolver Members
See Also Example Methods
[image]

A custom assembly resolver participates in assembly resolution when standard assembly resolution fails to load the desired assembly but before assembly load paths are considered.

The following tables list the members exposed by IAssemblyResolver.

Public Methods

 | Name | Description
Public method | Resolve | Resolves the assembly with the specified name.
Top

See Also

IAssemblyResolver Interface
Gallio.Runtime.Loader Namespace
AssemblyResolve


Methods

IAssemblyResolver Methods
[image]

Public Methods

 | Name | Description
Public method | Resolve | Resolves the assembly with the specified name.
Top

See Also

IAssemblyResolver Interface
Gallio.Runtime.Loader Namespace
AssemblyResolve


Resolve Method

IAssemblyResolver.Resolve Method
[image]

Resolves the assembly with the specified name.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function Resolve( _
ByVal assemblyName As String, _
ByVal reflectionOnly As Boolean _
) As Assembly
C#
Assembly Resolve(
string assemblyName,
bool reflectionOnly
)
C++
Assembly Resolve(
String assemblyName,
bool reflectionOnly
) abstract
J#
Assembly Resolve(
string assemblyName,
bool reflectionOnly
)
JScript
function Resolve(
assemblyName : String,
reflectionOnly : bool
) : Assembly

Parameters

assemblyName
The full name of the assembly as was provided to Load
reflectionOnly
True if the assembly is to be resolved in the reflection-only context

Return Value

The assembly, or null if it could not be resolved

See Also

IAssemblyResolver Interface
Gallio.Runtime.Loader Namespace


IAssemblyResolverManager Interface

IAssemblyResolverManager Interface
See Also Example Members
[image]

Provides support for resolving assemblies using hint paths and custom resolvers.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IAssemblyResolverManager
Implements IDisposable
C#
public interface IAssemblyResolverManager : IDisposable
C++
interface class IAssemblyResolverManager : IDisposable
J#
public interface IAssemblyResolverManager implements IDisposable
JScript
public interface IAssemblyResolverManager extends IDisposable

Types that implement IAssemblyResolverManager

Type | Description
Gallio.Runtime.Loader.DefaultAssemblyResolverManager | Resolves assemblies using hint paths and custom resolvers.

See Also

IAssemblyResolverManager Members
Gallio.Runtime.Loader Namespace


IAssemblyResolverManager Members

IAssemblyResolverManager Members
See Also Example Methods
[image]

Provides support for resolving assemblies using hint paths and custom resolvers.

The following tables list the members exposed by IAssemblyResolverManager.

Public Methods

 | Name | Description
Public method | AddAssemblyResolver | Adds a custom assembly resolver to use when standard assembly resolution fails.
Public method | AddHintDirectory | Adds an assembly load hint directory to search when standard assembly resolution fails.
Top

See Also

IAssemblyResolverManager Interface
Gallio.Runtime.Loader Namespace


Methods

IAssemblyResolverManager Methods
[image]

Public Methods

 | Name | Description
Public method | AddAssemblyResolver | Adds a custom assembly resolver to use when standard assembly resolution fails.
Public method | AddHintDirectory | Adds an assembly load hint directory to search when standard assembly resolution fails.
Top

See Also

IAssemblyResolverManager Interface
Gallio.Runtime.Loader Namespace


AddAssemblyResolver Method

IAssemblyResolverManager.AddAssemblyResolver Method
[image]

Adds a custom assembly resolver to use when standard assembly resolution fails.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddAssemblyResolver( _
ByVal assemblyResolver As IAssemblyResolver _
)
C#
void AddAssemblyResolver(
IAssemblyResolver assemblyResolver
)
C++
void AddAssemblyResolver(
IAssemblyResolver assemblyResolver
) abstract
J#
void AddAssemblyResolver(
IAssemblyResolver assemblyResolver
)
JScript
function AddAssemblyResolver(
assemblyResolver : IAssemblyResolver
)

Parameters

assemblyResolver
The assembly resolver

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyResolver is null

See Also

IAssemblyResolverManager Interface
Gallio.Runtime.Loader Namespace


AddHintDirectory Method

IAssemblyResolverManager.AddHintDirectory Method
[image]

Adds an assembly load hint directory to search when standard assembly resolution fails.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub AddHintDirectory( _
ByVal hintDirectory As String _
)
C#
void AddHintDirectory(
string hintDirectory
)
C++
void AddHintDirectory(
String hintDirectory
) abstract
J#
void AddHintDirectory(
string hintDirectory
)
JScript
function AddHintDirectory(
hintDirectory : String
)

Parameters

hintDirectory
The hint directory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hintDirectory is null

See Also

IAssemblyResolverManager Interface
Gallio.Runtime.Loader Namespace


ILoader Interface

ILoader Interface
See Also Example Members
[image]

Provides services to assist with loading tests and dependent resources.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ILoader
C#
public interface ILoader
C++
interface class ILoader
J#
public interface ILoader
JScript
public interface ILoader

Types that implement ILoader

Type | Description
Gallio.Runtime.Loader.DefaultLoader | Default implementation of a loader.

See Also

ILoader Members
Gallio.Runtime.Loader Namespace


ILoader Members

ILoader Members
See Also Example Properties Methods
[image]

Provides services to assist with loading tests and dependent resources.

The following tables list the members exposed by ILoader.

Public Properties

 | Name | Description
Public property | AssemblyResolverManager | Gets the assembly resolver manager used to resolve referenced assemblies.
Top

Public Methods

 | Name | Description
Public method | LoadAssemblyFrom | Loads an assembly from the specified file.
Top

See Also

ILoader Interface
Gallio.Runtime.Loader Namespace


Properties

ILoader Properties
[image]

Public Properties

 | Name | Description
Public property | AssemblyResolverManager | Gets the assembly resolver manager used to resolve referenced assemblies.
Top

See Also

ILoader Interface
Gallio.Runtime.Loader Namespace


AssemblyResolverManager Property

ILoader.AssemblyResolverManager Property
[image]

Gets the assembly resolver manager used to resolve referenced assemblies.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property AssemblyResolverManager As IAssemblyResolverManager
C#
IAssemblyResolverManager AssemblyResolverManager { get; }
C++
property IAssemblyResolverManager AssemblyResolverManager abstract {
IAssemblyResolverManager get();
}
J#
/** property */
public IAssemblyResolverManager get_AssemblyResolverManager();
JScript
public function get AssemblyResolverManager() : IAssemblyResolverManager

See Also

ILoader Interface
Gallio.Runtime.Loader Namespace


Methods

ILoader Methods
[image]

Public Methods

 | Name | Description
Public method | LoadAssemblyFrom | Loads an assembly from the specified file.
Top

See Also

ILoader Interface
Gallio.Runtime.Loader Namespace


LoadAssemblyFrom Method

ILoader.LoadAssemblyFrom Method
[image]

Loads an assembly from the specified file.

Namespace: Gallio.Runtime.Loader
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function LoadAssemblyFrom( _
ByVal assemblyFile As String _
) As Assembly
C#
Assembly LoadAssemblyFrom(
string assemblyFile
)
C++
Assembly LoadAssemblyFrom(
String assemblyFile
) abstract
J#
Assembly LoadAssemblyFrom(
string assemblyFile
)
JScript
function LoadAssemblyFrom(
assemblyFile : String
) : Assembly

Parameters

assemblyFile
The assembly file

Return Value

The loaded assembly

Exceptions

Exception Type | Condition
Exception | Thrown if the assembly could not be loaded

See Also

ILoader Interface
Gallio.Runtime.Loader Namespace


Gallio.Runtime.Logging

Gallio.Runtime.Logging Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | BaseLogger | Base implementation of ILogger that performs argument validation and supports convenience methods. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | EventLogger | A logger that dispatches log messages via events.
Public class | FilteredLogger | Filters another logger to exclude messages below a given level of severity.
Public class | LogMessageEventArgs | Event arguments for the EventLogger
Public class | NullLogger | A null implementation of ILogger that does nothing. This class cannot be inherited.
Public class | RemoteLogger | Wraps a logger so that it can be accessed remotely.
Public class | SeverityPrefixLogger | The severity prefix logger wraps another loggers and encodes the severity of a log entry into the log message itself in a standard form.
Public class | SeverityPrefixParser | Parses severity information from log messages encoded by SeverityPrefixLogger.
Public class | TextLogger | A logger that writes output to a TextWriter.

Interfaces

 | Interface | Description
Public interface | ILogger | Provides support for logging messages from system components.

Enumerations

 | Enumeration | Description
Public enumeration | LogSeverity | Describes the severity of a log message.


BaseLogger Class

BaseLogger Class
See Also Example Members
[image]

Base implementation of ILogger that performs argument validation and supports convenience methods. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class BaseLogger
Implements ILogger
C#
[SerializableAttribute]
public abstract class BaseLogger : ILogger
C++
[SerializableAttribute]
ref class BaseLogger abstract : ILogger
J#
/** @attribute SerializableAttribute() */
public class BaseLogger implements ILogger
JScript
public
SerializableAttribute
class BaseLogger extends ILogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Derived types

See Also

BaseLogger Members
Gallio.Runtime.Logging Namespace


BaseLogger Members

BaseLogger Members
See Also Example Constructors Methods
[image]

Base implementation of ILogger that performs argument validation and supports convenience methods. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseLogger.

Protected Constructors

 | Name | Description
Family method | BaseLogger | Initializes a new instance of the BaseLogger class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace


BaseLogger Constructor

BaseLogger Constructor
[image]

Initializes a new instance of the BaseLogger class.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseLogger()
C++
protected:
BaseLogger() sealed
J#
protected BaseLogger()
JScript
protected function BaseLogger()

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace


Methods

BaseLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace


Log Method

BaseLogger.Log Method

Logs a message.

Overload List

 | Name | Description
Public method | Log (LogSeverity, String) | Logs a message.
Public method | Log (LogSeverity, String, ExceptionData) | Logs a message with an associated exception.
Public method | Log (LogSeverity, String, Exception) | Logs a message with an associated exception.

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace


Log Method (LogSeverity, String)

BaseLogger.Log Method (LogSeverity, String)
See Also Example
[image]

Logs a message.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Log( _
ByVal severity As LogSeverity, _
ByVal message As String _
) _
Implements ILogger.Log
C#
public void Log(
LogSeverity severity,
string message
)
C++
public:
void Log(
LogSeverity severity,
String message
) sealed
J#
public void Log(
LogSeverity severity,
string message
)
JScript
public function Log(
severity : LogSeverity,
message : String
)

Parameters

severity
The log message severity
message
The log message

Implements

ILogger.Log

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace
BaseLogger.Log Overload List


Log Method (LogSeverity, String, ExceptionData)

BaseLogger.Log Method (LogSeverity, String, ExceptionData)
See Also Example
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Log( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
) _
Implements ILogger.Log
C#
public void Log(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
public:
void Log(
LogSeverity severity,
String message,
ExceptionData exceptionData
) sealed
J#
public void Log(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
public function Log(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message
exceptionData
The associated exception data, or null if none

Implements

ILogger.Log

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace
BaseLogger.Log Overload List


Log Method (LogSeverity, String, Exception)

BaseLogger.Log Method (LogSeverity, String, Exception)
See Also Example
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Log( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exception As Exception _
) _
Implements ILogger.Log
C#
public void Log(
LogSeverity severity,
string message,
Exception exception
)
C++
public:
void Log(
LogSeverity severity,
String message,
Exception exception
) sealed
J#
public void Log(
LogSeverity severity,
string message,
Exception exception
)
JScript
public function Log(
severity : LogSeverity,
message : String,
exception : Exception
)

Parameters

severity
The log message severity
message
The log message
exception
The associated exception, or null if none

Implements

ILogger.Log

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace
BaseLogger.Log Overload List


LogImpl Method

BaseLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected abstract void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) abstract
J#
protected abstract void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected abstract function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace


EventLogger Class

EventLogger Class
See Also Example Members
[image]

A logger that dispatches log messages via events.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class EventLogger
Inherits BaseLogger
C#
public class EventLogger : BaseLogger
C++
ref class EventLogger : BaseLogger
J#
public class EventLogger extends BaseLogger
JScript
public class EventLogger extends BaseLogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.Logging.EventLogger

See Also

EventLogger Members
Gallio.Runtime.Logging Namespace


EventLogger Members

EventLogger Members
See Also Example Constructors Methods Events
[image]

A logger that dispatches log messages via events.

The following tables list the members exposed by EventLogger.

Public Constructors

 | Name | Description
Public method | EventLogger | Initializes a new instance of the EventLogger class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | LogMessage | An event that is fired when a log message is received.
Top

See Also

EventLogger Class
Gallio.Runtime.Logging Namespace


EventLogger Constructor

EventLogger Constructor
[image]

Initializes a new instance of the EventLogger class.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EventLogger()
C++
public:
EventLogger() sealed
J#
public EventLogger()
JScript
public function EventLogger()

See Also

EventLogger Class
Gallio.Runtime.Logging Namespace


Methods

EventLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EventLogger Class
Gallio.Runtime.Logging Namespace


LogImpl Method

EventLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
virtual void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) override
J#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected override function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

EventLogger Class
Gallio.Runtime.Logging Namespace


Events

EventLogger Events
[image]

Public Events

 | Name | Description
Public event | LogMessage | An event that is fired when a log message is received.
Top

See Also

EventLogger Class
Gallio.Runtime.Logging Namespace


LogMessage Event

EventLogger.LogMessage Event
[image]

An event that is fired when a log message is received.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event LogMessage As EventHandler(Of LogMessageEventArgs)
C#
public event EventHandler<LogMessageEventArgs> LogMessage
C++
public:
virtual event EventHandler<LogMessageEventArgs> LogMessage {
void add(EventHandler<LogMessageEventArgs> value) sealed ;
void remove(EventHandler<LogMessageEventArgs> value) sealed ;
}
J#
/** event */
public final void add_LogMessage(EventHandler<LogMessageEventArgs> value);

/** event */
public final void remove_LogMessage(EventHandler<LogMessageEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type LogMessageEventArgs containing data related to this event. The following LogMessageEventArgs properties provide information specific to this event.

Property | Description
ExceptionData | Gets the exception, or null if none.
Message | Gets the log message.
Severity | Gets the log severity.

See Also

EventLogger Class
Gallio.Runtime.Logging Namespace


FilteredLogger Class

FilteredLogger Class
See Also Example Members
[image]

Filters another logger to exclude messages below a given level of severity.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FilteredLogger
Inherits BaseLogger
C#
public class FilteredLogger : BaseLogger
C++
ref class FilteredLogger : BaseLogger
J#
public class FilteredLogger extends BaseLogger
JScript
public class FilteredLogger extends BaseLogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.Logging.FilteredLogger

See Also

FilteredLogger Members
Gallio.Runtime.Logging Namespace


FilteredLogger Members

FilteredLogger Members
See Also Example Constructors Methods
[image]

Filters another logger to exclude messages below a given level of severity.

The following tables list the members exposed by FilteredLogger.

Public Constructors

 | Name | Description
Public method | FilteredLogger | Creates a filtered logger.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FilteredLogger Class
Gallio.Runtime.Logging Namespace


FilteredLogger Constructor

FilteredLogger Constructor
[image]

Creates a filtered logger.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal logger As ILogger, _
ByVal minSeverity As LogSeverity _
)
C#
public FilteredLogger(
ILogger logger,
LogSeverity minSeverity
)
C++
public:
FilteredLogger(
ILogger logger,
LogSeverity minSeverity
) sealed
J#
public FilteredLogger(
ILogger logger,
LogSeverity minSeverity
)
JScript
public function FilteredLogger(
logger : ILogger,
minSeverity : LogSeverity
)

Parameters

logger
The logger to which filtered log messages are sent
minSeverity
The lowest severity message type to retain

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logger is null

See Also

FilteredLogger Class
Gallio.Runtime.Logging Namespace


Methods

FilteredLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FilteredLogger Class
Gallio.Runtime.Logging Namespace


LogImpl Method

FilteredLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
virtual void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) override
J#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected override function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

FilteredLogger Class
Gallio.Runtime.Logging Namespace


ILogger Interface

ILogger Interface
[image]

Provides support for logging messages from system components.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface ILogger
C#
public interface ILogger
C++
interface class ILogger
J#
public interface ILogger
JScript
public interface ILogger

Types that implement ILogger

Type | Description
Gallio.Runtime.Logging.BaseLogger | Base implementation of ILogger that performs argument validation and supports convenience methods. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

ILogger Members
Gallio.Runtime.Logging Namespace


ILogger Members

ILogger Members
[image]

Provides support for logging messages from system components.

The following tables list the members exposed by ILogger.

Public Methods

 | Name | Description
Public method | Log | Overloaded. Logs a message.
Top

See Also

ILogger Interface
Gallio.Runtime.Logging Namespace


Methods

ILogger Methods
[image]

Public Methods

 | Name | Description
Public method | Log | Overloaded. Logs a message.
Top

See Also

ILogger Interface
Gallio.Runtime.Logging Namespace


Log Method

ILogger.Log Method

Logs a message.

Overload List

 | Name | Description
Public method | Log (LogSeverity, String) | Logs a message.
Public method | Log (LogSeverity, String, ExceptionData) | Logs a message with an associated exception.
Public method | Log (LogSeverity, String, Exception) | Logs a message with an associated exception.

See Also

ILogger Interface
Gallio.Runtime.Logging Namespace


Log Method (LogSeverity, String)

ILogger.Log Method (LogSeverity, String)
See Also Example
[image]

Logs a message.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Log( _
ByVal severity As LogSeverity, _
ByVal message As String _
)
C#
public abstract void Log(
LogSeverity severity,
string message
)
C++
public:
void Log(
LogSeverity severity,
String message
) abstract
J#
public abstract void Log(
LogSeverity severity,
string message
)
JScript
public abstract function Log(
severity : LogSeverity,
message : String
)

Parameters

severity
The log message severity
message
The log message

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

ILogger Interface
Gallio.Runtime.Logging Namespace
ILogger.Log Overload List


Log Method (LogSeverity, String, ExceptionData)

ILogger.Log Method (LogSeverity, String, ExceptionData)
See Also Example
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Log( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
public abstract void Log(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
public:
void Log(
LogSeverity severity,
String message,
ExceptionData exceptionData
) abstract
J#
public abstract void Log(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
public abstract function Log(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message
exceptionData
The associated exception data, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

ILogger Interface
Gallio.Runtime.Logging Namespace
ILogger.Log Overload List


Log Method (LogSeverity, String, Exception)

ILogger.Log Method (LogSeverity, String, Exception)
See Also Example
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Log( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exception As Exception _
)
C#
public abstract void Log(
LogSeverity severity,
string message,
Exception exception
)
C++
public:
void Log(
LogSeverity severity,
String message,
Exception exception
) abstract
J#
public abstract void Log(
LogSeverity severity,
string message,
Exception exception
)
JScript
public abstract function Log(
severity : LogSeverity,
message : String,
exception : Exception
)

Parameters

severity
The log message severity
message
The log message
exception
The associated exception, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

ILogger Interface
Gallio.Runtime.Logging Namespace
ILogger.Log Overload List


LogMessageEventArgs Class

LogMessageEventArgs Class
See Also Example Members
[image]

Event arguments for the EventLogger

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LogMessageEventArgs
Inherits EventArgs
C#
public class LogMessageEventArgs : EventArgs
C++
ref class LogMessageEventArgs : EventArgs
J#
public class LogMessageEventArgs extends EventArgs
JScript
public class LogMessageEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runtime.Logging.LogMessageEventArgs

See Also

LogMessageEventArgs Members
Gallio.Runtime.Logging Namespace


LogMessageEventArgs Members

LogMessageEventArgs Members
See Also Example Constructors Properties Methods
[image]

Event arguments for the EventLogger

The following tables list the members exposed by LogMessageEventArgs.

Public Constructors

 | Name | Description
Public method | LogMessageEventArgs | Creates a log event.
Top

Public Properties

 | Name | Description
Public property | ExceptionData | Gets the exception, or null if none.
Public property | Message | Gets the log message.
Public property | Severity | Gets the log severity.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogMessageEventArgs Class
Gallio.Runtime.Logging Namespace


LogMessageEventArgs Constructor

LogMessageEventArgs Constructor
[image]

Creates a log event.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
public LogMessageEventArgs(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
public:
LogMessageEventArgs(
LogSeverity severity,
String message,
ExceptionData exceptionData
) sealed
J#
public LogMessageEventArgs(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
public function LogMessageEventArgs(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log severity
message
The log message
exceptionData
The exception data, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

LogMessageEventArgs Class
Gallio.Runtime.Logging Namespace


Properties

LogMessageEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | ExceptionData | Gets the exception, or null if none.
Public property | Message | Gets the log message.
Public property | Severity | Gets the log severity.
Top

See Also

LogMessageEventArgs Class
Gallio.Runtime.Logging Namespace


ExceptionData Property

LogMessageEventArgs.ExceptionData Property
[image]

Gets the exception, or null if none.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExceptionData As ExceptionData
<CompilerGeneratedAttribute> Get
End Property
C#
public ExceptionData ExceptionData { [CompilerGeneratedAttribute] get; }
C++
public property ExceptionData ExceptionData sealed {
ExceptionData get();
}
J#
/** property */
public ExceptionData get_ExceptionData();
JScript
public CompilerGeneratedAttribute function get ExceptionData() : ExceptionData

See Also

LogMessageEventArgs Class
Gallio.Runtime.Logging Namespace


Message Property

LogMessageEventArgs.Message Property
[image]

Gets the log message.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
<CompilerGeneratedAttribute> Get
End Property
C#
public string Message { [CompilerGeneratedAttribute] get; }
C++
public property string Message sealed {
String get();
}
J#
/** property */
public string get_Message();
JScript
public CompilerGeneratedAttribute function get Message() : String

See Also

LogMessageEventArgs Class
Gallio.Runtime.Logging Namespace


Severity Property

LogMessageEventArgs.Severity Property
[image]

Gets the log severity.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Severity As LogSeverity
<CompilerGeneratedAttribute> Get
End Property
C#
public LogSeverity Severity { [CompilerGeneratedAttribute] get; }
C++
public property LogSeverity Severity sealed {
LogSeverity get();
}
J#
/** property */
public LogSeverity get_Severity();
JScript
public CompilerGeneratedAttribute function get Severity() : LogSeverity

See Also

LogMessageEventArgs Class
Gallio.Runtime.Logging Namespace


LogSeverity Enumeration

LogSeverity Enumeration
[image]

Describes the severity of a log message.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Enum LogSeverity
C#
public enum LogSeverity
C++
public enum class LogSeverity
J#
public enum LogSeverity
JScript
public enum LogSeverity

Members

Member Name | Description
Debug | The severity used for debug messages.
Info | The severity used for informational messages.
Important | The severity used for important messages.
Warning | The severity used for warning messages.
Error | The severity used for error messages.

See Also

Gallio.Runtime.Logging Namespace


NullLogger Class

NullLogger Class
See Also Example Members
[image]

A null implementation of ILogger that does nothing. This class cannot be inherited.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullLogger
Inherits BaseLogger
C#
public sealed class NullLogger : BaseLogger
C++
ref class NullLogger sealed : BaseLogger
J#
public final class NullLogger extends BaseLogger
JScript
public final class NullLogger extends BaseLogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.Logging.NullLogger

See Also

NullLogger Members
Gallio.Runtime.Logging Namespace


NullLogger Members

NullLogger Members
See Also Example Constructors Fields Methods
[image]

A null implementation of ILogger that does nothing. This class cannot be inherited.

The following tables list the members exposed by NullLogger.

Public Constructors

 | Name | Description
Public method | NullLogger | Initializes a new instance of the NullLogger class.
Top

Public Fields

Name | Description
Instance | Gets a singleton instance of the null logger. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullLogger Class
Gallio.Runtime.Logging Namespace


NullLogger Constructor

NullLogger Constructor
[image]

Initializes a new instance of the NullLogger class.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NullLogger()
C++
public:
NullLogger() sealed
J#
public NullLogger()
JScript
public function NullLogger()

See Also

NullLogger Class
Gallio.Runtime.Logging Namespace


Fields

NullLogger Fields
[image]

Public Fields

Name | Description
Instance | Gets a singleton instance of the null logger. This field is read-only.
Top

See Also

NullLogger Class
Gallio.Runtime.Logging Namespace


Instance Field

NullLogger.Instance Field
[image]

Gets a singleton instance of the null logger. This field is read-only.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As NullLogger
C#
public static readonly NullLogger Instance;
C++
public:
static const NullLogger Instance;
J#
public static final NullLogger Instance
JScript
public static const var Instance : NullLogger;

See Also

NullLogger Class
Gallio.Runtime.Logging Namespace


RemoteLogger Class

RemoteLogger Class
See Also Example Members
[image]

Wraps a logger so that it can be accessed remotely.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class RemoteLogger
Inherits BaseLogger
C#
[SerializableAttribute]
public class RemoteLogger : BaseLogger
C++
[SerializableAttribute]
ref class RemoteLogger : BaseLogger
J#
/** @attribute SerializableAttribute() */
public class RemoteLogger extends BaseLogger
JScript
public
SerializableAttribute
class RemoteLogger extends BaseLogger

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.Logging.RemoteLogger

See Also

RemoteLogger Members
Gallio.Runtime.Logging Namespace


RemoteLogger Members

RemoteLogger Members
See Also Example Constructors Methods
[image]

Wraps a logger so that it can be accessed remotely.

The following tables list the members exposed by RemoteLogger.

Public Constructors

 | Name | Description
Public method | RemoteLogger | Creates a wrapper for the specified logger.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RemoteLogger Class
Gallio.Runtime.Logging Namespace


RemoteLogger Constructor

RemoteLogger Constructor
[image]

Creates a wrapper for the specified logger.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal logger As ILogger _
)
C#
public RemoteLogger(
ILogger logger
)
C++
public:
RemoteLogger(
ILogger logger
) sealed
J#
public RemoteLogger(
ILogger logger
)
JScript
public function RemoteLogger(
logger : ILogger
)

Parameters

logger
The logger

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logger is null

See Also

RemoteLogger Class
Gallio.Runtime.Logging Namespace


Methods

RemoteLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RemoteLogger Class
Gallio.Runtime.Logging Namespace


LogImpl Method

RemoteLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
virtual void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) override
J#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected override function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

RemoteLogger Class
Gallio.Runtime.Logging Namespace


SeverityPrefixLogger Class

SeverityPrefixLogger Class
See Also Example Members
[image]

The severity prefix logger wraps another loggers and encodes the severity of a log entry into the log message itself in a standard form.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class SeverityPrefixLogger
Inherits BaseLogger
C#
public class SeverityPrefixLogger : BaseLogger
C++
ref class SeverityPrefixLogger : BaseLogger
J#
public class SeverityPrefixLogger extends BaseLogger
JScript
public class SeverityPrefixLogger extends BaseLogger

Remarks

This wrapper is useful when the base logger may not be able to report the severity via other means or when severity information must be reconstructed from plain text.

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.Logging.SeverityPrefixLogger

See Also

SeverityPrefixLogger Members
Gallio.Runtime.Logging Namespace
SeverityPrefixParser


SeverityPrefixLogger Members

SeverityPrefixLogger Members
See Also Example Constructors Methods
[image]

The severity prefix logger wraps another loggers and encodes the severity of a log entry into the log message itself in a standard form.

The following tables list the members exposed by SeverityPrefixLogger.

Public Constructors

 | Name | Description
Public method | SeverityPrefixLogger | Creates a prefix logger.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SeverityPrefixLogger Class
Gallio.Runtime.Logging Namespace
SeverityPrefixParser


SeverityPrefixLogger Constructor

SeverityPrefixLogger Constructor
[image]

Creates a prefix logger.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal inner As ILogger _
)
C#
public SeverityPrefixLogger(
ILogger inner
)
C++
public:
SeverityPrefixLogger(
ILogger inner
) sealed
J#
public SeverityPrefixLogger(
ILogger inner
)
JScript
public function SeverityPrefixLogger(
inner : ILogger
)

Parameters

inner
The inner logger

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if inner is null

See Also

SeverityPrefixLogger Class
Gallio.Runtime.Logging Namespace


Methods

SeverityPrefixLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SeverityPrefixLogger Class
Gallio.Runtime.Logging Namespace
SeverityPrefixParser


LogImpl Method

SeverityPrefixLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
virtual void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) override
J#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected override function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

SeverityPrefixLogger Class
Gallio.Runtime.Logging Namespace


SeverityPrefixParser Class

SeverityPrefixParser Class
See Also Example Members
[image]

Parses severity information from log messages encoded by SeverityPrefixLogger.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class SeverityPrefixParser
C#
public class SeverityPrefixParser
C++
ref class SeverityPrefixParser
J#
public class SeverityPrefixParser
JScript
public class SeverityPrefixParser

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.SeverityPrefixParser

See Also

SeverityPrefixParser Members
Gallio.Runtime.Logging Namespace
SeverityPrefixLogger


SeverityPrefixParser Members

SeverityPrefixParser Members
See Also Example Constructors Methods
[image]

Parses severity information from log messages encoded by SeverityPrefixLogger.

The following tables list the members exposed by SeverityPrefixParser.

Public Constructors

 | Name | Description
Public method | SeverityPrefixParser | Initializes a new instance of the SeverityPrefixParser class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ParseLine | Parses a line of log data.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SeverityPrefixParser Class
Gallio.Runtime.Logging Namespace
SeverityPrefixLogger


SeverityPrefixParser Constructor

SeverityPrefixParser Constructor
[image]

Initializes a new instance of the SeverityPrefixParser class.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SeverityPrefixParser()
C++
public:
SeverityPrefixParser() sealed
J#
public SeverityPrefixParser()
JScript
public function SeverityPrefixParser()

See Also

SeverityPrefixParser Class
Gallio.Runtime.Logging Namespace


Methods

SeverityPrefixParser Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ParseLine | Parses a line of log data.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SeverityPrefixParser Class
Gallio.Runtime.Logging Namespace
SeverityPrefixLogger


ParseLine Method

SeverityPrefixParser.ParseLine Method
[image]

Parses a line of log data.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ParseLine( _
ByVal line As String, _
<OutAttribute> ByRef severity As LogSeverity, _
<OutAttribute> ByRef message As String _
) As Boolean
C#
public bool ParseLine(
string line,
out LogSeverity severity,
out string message
)
C++
public:
bool ParseLine(
String line,
[OutAttribute] LogSeverity% severity,
[OutAttribute] String% message
) sealed
J#
public bool ParseLine(
string line,
/** @attribute OutAttribute() */ /** @ref */ LogSeverity severity,
/** @attribute OutAttribute() */ /** @ref */ string message
)
JScript
public function ParseLine(
line : String,
OutAttribute severity : LogSeverity,
OutAttribute message : String
) : bool

Parameters

line
The line of log data to parse
severity
Set to the severity of the message extracted from the line
message
The message extracted from the line

Return Value

True if the message included a severity, false otherwise

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if line is null

See Also

SeverityPrefixParser Class
Gallio.Runtime.Logging Namespace


TextLogger Class

TextLogger Class
See Also Example Members
[image]

A logger that writes output to a TextWriter.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class TextLogger
Inherits BaseLogger
C#
public class TextLogger : BaseLogger
C++
ref class TextLogger : BaseLogger
J#
public class TextLogger extends BaseLogger
JScript
public class TextLogger extends BaseLogger

Remarks

To include severity information in the output, wrap this logger with a SeverityPrefixLogger.

Inheritance Hierarchy

System.Object
Gallio.Runtime.Logging.BaseLogger
Gallio.Runtime.Logging.TextLogger

See Also

TextLogger Members
Gallio.Runtime.Logging Namespace


TextLogger Members

TextLogger Members
See Also Example Constructors Methods
[image]

A logger that writes output to a TextWriter.

The following tables list the members exposed by TextLogger.

Public Constructors

 | Name | Description
Public method | TextLogger | Creates a text logger.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TextLogger Class
Gallio.Runtime.Logging Namespace


TextLogger Constructor

TextLogger Constructor
[image]

Creates a text logger.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal textWriter As TextWriter _
)
C#
public TextLogger(
TextWriter textWriter
)
C++
public:
TextLogger(
TextWriter textWriter
) sealed
J#
public TextLogger(
TextWriter textWriter
)
JScript
public function TextLogger(
textWriter : TextWriter
)

Parameters

textWriter
The text writer to which the log output should be written

See Also

TextLogger Class
Gallio.Runtime.Logging Namespace


Methods

TextLogger Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Log | Overloaded. Logs a message. (inherited from BaseLogger)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | LogImpl | Overridden. Logs a message with an associated exception.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

TextLogger Class
Gallio.Runtime.Logging Namespace


LogImpl Method

TextLogger.LogImpl Method
[image]

Logs a message with an associated exception.

Namespace: Gallio.Runtime.Logging
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogImpl( _
ByVal severity As LogSeverity, _
ByVal message As String, _
ByVal exceptionData As ExceptionData _
)
C#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
C++
protected:
virtual void LogImpl(
LogSeverity severity,
String message,
ExceptionData exceptionData
) override
J#
protected override void LogImpl(
LogSeverity severity,
string message,
ExceptionData exceptionData
)
JScript
protected override function LogImpl(
severity : LogSeverity,
message : String,
exceptionData : ExceptionData
)

Parameters

severity
The log message severity
message
The log message, not null
exceptionData
The associated exception data, or null if none

See Also

TextLogger Class
Gallio.Runtime.Logging Namespace


Gallio.Runtime.ProgressMonitoring

Gallio.Runtime.ProgressMonitoring Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | BaseProgressMonitorPresenter | Abstract base class for objects whose purpose is to present progress information to the user. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseProgressMonitorProvider | An abstract base class to assist with the implementation of conformant IProgressMonitorProvider classes. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | CancelableProgressMonitor | An abstract base class for progress monitors that implements the cancelation semantics only. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | LogProgressMonitorPresenter | Displays progress by writing a series of messages to an ILogger as the name of the current task changes.
Public class | LogProgressMonitorProvider | Displays progress by writing a series of messages to an ILogger as the name of the current task changes.
Public class | NullProgressMonitor | Creates instances of null progress monitors that do nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | NullProgressMonitorPresenter | A null progress monitor presenter simply does nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | NullProgressMonitorProvider | Runs tasks without reporting any progress. Argument validation and state changes are still noted but they do not have any outward effect. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ObservableProgressMonitor | An observable progress monitor tracks validates arguments and tracks the state of the progress monitor but it does not implement any of its own behavior in response to the notifications received. Instead, it is intended to be observed by a presenter that translates state change events into changes of the view.
NestedFamily class | ObservableProgressMonitor.SubProgressMonitor | A standard sub-progress monitor implementation that notifies its parent as work is performed.
Public class | RemoteProgressMonitor | A remote progress monitor is a serializable wrapper for another progress monitor. The wrapper can be passed to another AppDomain and communication occurs over .Net remoting. This class cannot be inherited.
Public class | RichConsoleProgressMonitorPresenter | A console progress monitor presenter displays a simple tally of the amount of work to be done on the main task as a bar chart. The progress monitor responds to cancelation events at the console.
Public class | RichConsoleProgressMonitorProvider | A console progress monitor displays a simple tally of the amount of work to be done on the main task as a bar chart. The progress monitor responds to cancelation events at the console.
Public class | SubProgressMonitorCreatedEventArgs | Provides a reference to the newly created sub-progress monitor.

Interfaces

 | Interface | Description
Public interface | IProgressMonitor | A progress monitor provides facilities for core functionality to report progress of a long running operation. The interface is typically implemented by a UI component such as a progress dialog.
Public interface | IProgressMonitorPresenter | A progress monitor presenter attaches a progress monitor to a view.
Public interface | IProgressMonitorProvider | A progress monitor provider runs a task with progress monitoring and provides clear notification of cancelation in the form of an OperationCanceledException.

Structures

 | Structure | Description
Public structure | ProgressMonitorTaskCookie | A progress monitor task cookie represents a task in progress. When it is disposed, the corresponding IProgressMonitor's Done method is called.

Delegates

 | Delegate | Description
Public delegate | TaskWithProgress | Represents a task to be executed with a progress monitor.


BaseProgressMonitorPresenter Class

BaseProgressMonitorPresenter Class
See Also Example Members
[image]

Abstract base class for objects whose purpose is to present progress information to the user. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseProgressMonitorPresenter
Implements IProgressMonitorPresenter
C#
public abstract class BaseProgressMonitorPresenter : IProgressMonitorPresenter
C++
ref class BaseProgressMonitorPresenter abstract : IProgressMonitorPresenter
J#
public class BaseProgressMonitorPresenter implements IProgressMonitorPresenter
JScript
public class BaseProgressMonitorPresenter extends IProgressMonitorPresenter

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.LogProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.RichConsoleProgressMonitorPresenter

See Also

BaseProgressMonitorPresenter Members
Gallio.Runtime.ProgressMonitoring Namespace


BaseProgressMonitorPresenter Members

BaseProgressMonitorPresenter Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for objects whose purpose is to present progress information to the user. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseProgressMonitorPresenter.

Protected Constructors

 | Name | Description
Family method | BaseProgressMonitorPresenter | Initializes a new instance of the BaseProgressMonitorPresenter class.
Top

Protected Properties

 | Name | Description
Family property | ProgressMonitor | Gets the attached progress monitor.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Initializes the presenter after a progress monitor has been attached.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


BaseProgressMonitorPresenter Constructor

BaseProgressMonitorPresenter Constructor
[image]

Initializes a new instance of the BaseProgressMonitorPresenter class.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseProgressMonitorPresenter()
C++
protected:
BaseProgressMonitorPresenter() sealed
J#
protected BaseProgressMonitorPresenter()
JScript
protected function BaseProgressMonitorPresenter()

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Properties

BaseProgressMonitorPresenter Properties
[image]

Protected Properties

 | Name | Description
Family property | ProgressMonitor | Gets the attached progress monitor.
Top

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


ProgressMonitor Property

BaseProgressMonitorPresenter.ProgressMonitor Property
[image]

Gets the attached progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ProgressMonitor As ObservableProgressMonitor
C#
protected ObservableProgressMonitor ProgressMonitor { get; }
C++
protected property ObservableProgressMonitor ProgressMonitor sealed {
ObservableProgressMonitor get();
}
J#
/** property */
protected ObservableProgressMonitor get_ProgressMonitor();
JScript
protected function get ProgressMonitor() : ObservableProgressMonitor

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

BaseProgressMonitorPresenter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Initializes the presenter after a progress monitor has been attached.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Initialize Method

BaseProgressMonitorPresenter.Initialize Method
[image]

Initializes the presenter after a progress monitor has been attached.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Initialize()
C#
protected virtual void Initialize()
C++
protected:
virtual void Initialize()
J#
protected virtual void Initialize()
JScript
protected virtual function Initialize()

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Present Method

BaseProgressMonitorPresenter.Present Method
[image]

Presents an observable progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Present( _
ByVal progressMonitor As ObservableProgressMonitor _
) _
Implements IProgressMonitorPresenter.Present
C#
public void Present(
ObservableProgressMonitor progressMonitor
)
C++
public:
void Present(
ObservableProgressMonitor progressMonitor
) sealed
J#
public void Present(
ObservableProgressMonitor progressMonitor
)
JScript
public function Present(
progressMonitor : ObservableProgressMonitor
)

Parameters

progressMonitor
The progress monitor to present

Implements

IProgressMonitorPresenter.Present

See Also

BaseProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


BaseProgressMonitorProvider Class

BaseProgressMonitorProvider Class
See Also Example Members
[image]

An abstract base class to assist with the implementation of conformant IProgressMonitorProvider classes. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseProgressMonitorProvider
Implements IProgressMonitorProvider
C#
public abstract class BaseProgressMonitorProvider : IProgressMonitorProvider
C++
ref class BaseProgressMonitorProvider abstract : IProgressMonitorProvider
J#
public class BaseProgressMonitorProvider implements IProgressMonitorProvider
JScript
public class BaseProgressMonitorProvider extends IProgressMonitorProvider

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.LogProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.NullProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.RichConsoleProgressMonitorProvider

See Also

BaseProgressMonitorProvider Members
Gallio.Runtime.ProgressMonitoring Namespace


BaseProgressMonitorProvider Members

BaseProgressMonitorProvider Members
See Also Example Constructors Methods
[image]

An abstract base class to assist with the implementation of conformant IProgressMonitorProvider classes. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseProgressMonitorProvider.

Protected Constructors

 | Name | Description
Family method | BaseProgressMonitorProvider | Initializes a new instance of the BaseProgressMonitorProvider class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetPresenter | Gets a presenter for the progress monitor.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


BaseProgressMonitorProvider Constructor

BaseProgressMonitorProvider Constructor
[image]

Initializes a new instance of the BaseProgressMonitorProvider class.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected BaseProgressMonitorProvider()
C++
protected:
BaseProgressMonitorProvider() sealed
J#
protected BaseProgressMonitorProvider()
JScript
protected function BaseProgressMonitorProvider()

See Also

BaseProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

BaseProgressMonitorProvider Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetPresenter | Gets a presenter for the progress monitor.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


GetPresenter Method

BaseProgressMonitorProvider.GetPresenter Method
[image]

Gets a presenter for the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetPresenter() As IProgressMonitorPresenter
C#
protected abstract IProgressMonitorPresenter GetPresenter()
C++
protected:
IProgressMonitorPresenter GetPresenter() abstract
J#
protected abstract IProgressMonitorPresenter GetPresenter()
JScript
protected abstract function GetPresenter() : IProgressMonitorPresenter

Return Value

The presenter

See Also

BaseProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


Run Method

BaseProgressMonitorProvider.Run Method
[image]

Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Run( _
ByVal task As TaskWithProgress _
) _
Implements IProgressMonitorProvider.Run
C#
public virtual void Run(
TaskWithProgress task
)
C++
public:
virtual void Run(
TaskWithProgress task
)
J#
public virtual void Run(
TaskWithProgress task
)
JScript
public virtual function Run(
task : TaskWithProgress
)

Parameters

task
The task to run, never null

Implements

IProgressMonitorProvider.Run

See Also

BaseProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


CancelableProgressMonitor Class

CancelableProgressMonitor Class
See Also Example Members
[image]

An abstract base class for progress monitors that implements the cancelation semantics only. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public MustInherit Class CancelableProgressMonitor
Implements IProgressMonitor, IDisposable
C#
[SerializableAttribute]
public abstract class CancelableProgressMonitor : IProgressMonitor, IDisposable
C++
[SerializableAttribute]
ref class CancelableProgressMonitor abstract : IProgressMonitor, IDisposable
J#
/** @attribute SerializableAttribute() */
public class CancelableProgressMonitor implements IProgressMonitor, IDisposable
JScript
public
SerializableAttribute
class CancelableProgressMonitor extends IProgressMonitor, IDisposable

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.CancelableProgressMonitor
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor
Gallio.Runtime.ProgressMonitoring.RemoteProgressMonitor

See Also

CancelableProgressMonitor Members
Gallio.Runtime.ProgressMonitoring Namespace


CancelableProgressMonitor Members

CancelableProgressMonitor Members
See Also Example Constructors Properties Methods Events
[image]

An abstract base class for progress monitors that implements the cancelation semantics only. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by CancelableProgressMonitor.

Protected Constructors

 | Name | Description
Family method | CancelableProgressMonitor | Initializes a new instance of the CancelableProgressMonitor class.
Top

Public Properties

 | Name | Description
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion.
Top

Public Methods

Name | Description
Public method | BeginTask | Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done.
Public method CreateSubProgressMonitor

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.
Public method | Done | Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyCanceled | Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing.
Family method | OnCancel | Called when Cancel performs its updates.
Top

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately.
Top

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


CancelableProgressMonitor Constructor

CancelableProgressMonitor Constructor
[image]

Initializes a new instance of the CancelableProgressMonitor class.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected CancelableProgressMonitor()
C++
protected:
CancelableProgressMonitor() sealed
J#
protected CancelableProgressMonitor()
JScript
protected function CancelableProgressMonitor()

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Properties

CancelableProgressMonitor Properties
[image]

Public Properties

 | Name | Description
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion.
Top

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


IsCanceled Property

CancelableProgressMonitor.IsCanceled Property
[image]

Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsCanceled As Boolean _
Implements IProgressMonitor.IsCanceled
C#
public bool IsCanceled { get; }
C++
public property bool IsCanceled sealed {
bool get();
}
J#
/** property */
public bool get_IsCanceled();
JScript
public function get IsCanceled() : bool

Implements

IProgressMonitor.IsCanceled

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

CancelableProgressMonitor Methods
[image]

Public Methods

Name | Description
Public method | BeginTask | Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done.
Public method CreateSubProgressMonitor

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.
Public method | Done | Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyCanceled | Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing.
Family method | OnCancel | Called when Cancel performs its updates.
Top

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


BeginTask Method

CancelableProgressMonitor.BeginTask Method
[image]

Notifies that the main task is starting. Must be called at most once on the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function BeginTask( _
ByVal taskName As String, _
ByVal totalWorkUnits As Double _
) As ProgressMonitorTaskCookie _
Implements IProgressMonitor.BeginTask
C#
public abstract ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
C++
public:
ProgressMonitorTaskCookie BeginTask(
String taskName,
double totalWorkUnits
) abstract
J#
public abstract ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
JScript
public abstract function BeginTask(
taskName : String,
totalWorkUnits : double
) : ProgressMonitorTaskCookie

Parameters

taskName
The name of the task being monitored
totalWorkUnits
The total number of work units to perform. Must be greater than 0, or NaN if an indeterminate amount of work is to be performed.

Return Value

An object that calls Done when disposed

Implements

IProgressMonitor.BeginTask

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Cancel Method

CancelableProgressMonitor.Cancel Method
[image]

Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Cancel() _
Implements IProgressMonitor.Cancel
C#
public void Cancel()
C++
public:
void Cancel() sealed
J#
public void Cancel()
JScript
public function Cancel()

Implements

IProgressMonitor.Cancel

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


CreateSubProgressMonitor Method

CancelableProgressMonitor.CreateSubProgressMonitor Method
[image]

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function CreateSubProgressMonitor( _
ByVal parentWorkUnits As Double _
) As IProgressMonitor _
Implements IProgressMonitor.CreateSubProgressMonitor
C#
public abstract IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
C++
public:
IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
) abstract
J#
public abstract IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
JScript
public abstract function CreateSubProgressMonitor(
parentWorkUnits : double
) : IProgressMonitor

Parameters

parentWorkUnits
The total number of work units of the parent task that are to be represented by the sub-task. When the sub-task completes, this much work will have been performed on the parent. Must be a finite value greater than or equal to 0.

Implements

IProgressMonitor.CreateSubProgressMonitor

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Dispose Method

CancelableProgressMonitor.Dispose Method

Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.

Overload List

 | Name | Description
Public method | Dispose | Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.
Family method | Dispose (Boolean) | Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Dispose Method ()

CancelableProgressMonitor.Dispose Method ()
See Also Example
[image]

Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
CancelableProgressMonitor.Dispose Overload List


Dispose Method (Boolean)

CancelableProgressMonitor.Dispose Method (Boolean)
See Also Example
[image]

Disposes the progress monitor, including cleaning up an marking as Done the current task, if any.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

Parameters

disposing
True if Dispose was called

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
CancelableProgressMonitor.Dispose Overload List


Done Method

CancelableProgressMonitor.Done Method
[image]

Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Done() _
Implements IProgressMonitor.Done
C#
public abstract void Done()
C++
public:
void Done() abstract
J#
public abstract void Done()
JScript
public abstract function Done()

Implements

IProgressMonitor.Done

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


NotifyCanceled Method

CancelableProgressMonitor.NotifyCanceled Method
[image]

Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Function NotifyCanceled() As Boolean
C#
protected bool NotifyCanceled()
C++
protected:
bool NotifyCanceled() sealed
J#
protected bool NotifyCanceled()
JScript
protected function NotifyCanceled() : bool

Return Value

True if cancelation has just occurred, false if no state change was performed

Remarks

This is the ONLY method of the progress monitor that is allowed to be called concurrently from multiple threads. It needs to be this way so that cancelation can be initiated by either participant in the progress monitoring dialog.

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnCancel Method

CancelableProgressMonitor.OnCancel Method
[image]

Called when Cancel performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCancel()
C#
protected virtual void OnCancel()
C++
protected:
virtual void OnCancel()
J#
protected virtual void OnCancel()
JScript
protected virtual function OnCancel()

Remarks

This method is not called by NotifyCanceled.

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


SetStatus Method

CancelableProgressMonitor.SetStatus Method
[image]

Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetStatus( _
ByVal status As String _
) _
Implements IProgressMonitor.SetStatus
C#
public abstract void SetStatus(
string status
)
C++
public:
void SetStatus(
String status
) abstract
J#
public abstract void SetStatus(
string status
)
JScript
public abstract function SetStatus(
status : String
)

Parameters

status
The name of the current subtask

Implements

IProgressMonitor.SetStatus

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


ThrowIfCanceled Method

CancelableProgressMonitor.ThrowIfCanceled Method
[image]

Throws an OperationCanceledException if the operation has been canceled.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub ThrowIfCanceled() _
Implements IProgressMonitor.ThrowIfCanceled
C#
public void ThrowIfCanceled()
C++
public:
void ThrowIfCanceled() sealed
J#
public void ThrowIfCanceled()
JScript
public function ThrowIfCanceled()

Implements

IProgressMonitor.ThrowIfCanceled

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Worked Method

CancelableProgressMonitor.Worked Method
[image]

Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Worked( _
ByVal workUnits As Double _
) _
Implements IProgressMonitor.Worked
C#
public abstract void Worked(
double workUnits
)
C++
public:
void Worked(
double workUnits
) abstract
J#
public abstract void Worked(
double workUnits
)
JScript
public abstract function Worked(
workUnits : double
)

Parameters

workUnits
The number of work units completed so far. Must be a finite value greater than or equal to 0.

Implements

IProgressMonitor.Worked

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Events

CancelableProgressMonitor Events
[image]

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately.
Top

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Canceled Event

CancelableProgressMonitor.Canceled Event
[image]

Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Canceled As EventHandler
C#
public event EventHandler Canceled
C++
public:
virtual event EventHandler Canceled {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Canceled(EventHandler value);

/** event */
public final void remove_Canceled(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Implements

IProgressMonitor.Canceled

See Also

CancelableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


IProgressMonitor Interface

IProgressMonitor Interface
See Also Example Members
[image]

A progress monitor provides facilities for core functionality to report progress of a long running operation. The interface is typically implemented by a UI component such as a progress dialog.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IProgressMonitor
Implements IDisposable
C#
public interface IProgressMonitor : IDisposable
C++
interface class IProgressMonitor : IDisposable
J#
public interface IProgressMonitor implements IDisposable
JScript
public interface IProgressMonitor extends IDisposable

Types that implement IProgressMonitor

Type | Description
Gallio.Runtime.ProgressMonitoring.CancelableProgressMonitor | An abstract base class for progress monitors that implements the cancelation semantics only. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Example

Copy Code
            // Copy a number of files to another directory, updating the progress
            // monitor before each file is copied to provide status feedback and
            // then after each file is copied to provide progress feedback.
            const int CostOfCopyingFile = 1;
            const int CostOfRunningExpensiveTask = 10;

            IProgressMonitor progressMonitor = progressMonitorDialog.GetProgressMonitor())
            using (progressMonitor.BeginTask("Copy files", files.Length * CostOfCopyingFile + CostOfRunningExpensiveTask))
            {
                foreach (FileInfo file in files)
                {
                    if (progressMonitor.IsCancelled)
                        return;

                    progressMonitor.SetStatus("Copying: " + file.Name);
                    File.Copy(file.FullName, Path.Combine(destinationFolder, file.Name))
                    progressMonitor.Worked(CostOfCopyingFile);
                }
                progressMonitor.SetStatus("");

                DoExpensiveTask(progressMonitor.CreateSubProgressMonitor(CostOfRunningExpensiveTask));
            }

Remarks

This interface is inspired from IProgressMonitor in the Eclipse API and was derived from the Castle.FlexBridge client-side components.

This interface is mostly not safe for use by multiple concurrent threads. Do not share a progress monitor instance across threads! for special rules regarding the handling of the cancelation event.

The BeginTask method returns a ProgressMonitorTaskCookie which implements IDisposable as a convenience for use with the C# "using" statement. Disposing the cookie is precisely equivalent to calling the Done method of the progress monitor.

See Also

IProgressMonitor Members
Gallio.Runtime.ProgressMonitoring Namespace
Canceled


IProgressMonitor Members

IProgressMonitor Members
See Also Example Properties Methods Events
[image]

A progress monitor provides facilities for core functionality to report progress of a long running operation. The interface is typically implemented by a UI component such as a progress dialog.

The following tables list the members exposed by IProgressMonitor.

Public Properties

 | Name | Description
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion.
Top

Public Methods

Name | Description
Public method | BeginTask | Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done.
Public method CreateSubProgressMonitor

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Done | Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | SetStatus | Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled.
Public method | Worked | Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately.
Top

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace
Canceled


Properties

IProgressMonitor Properties
[image]

Public Properties

 | Name | Description
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion.
Top

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace
Canceled


IsCanceled Property

IProgressMonitor.IsCanceled Property
[image]

Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsCanceled As Boolean
C#
bool IsCanceled { get; }
C++
property bool IsCanceled abstract {
bool get();
}
J#
/** property */
public bool get_IsCanceled();
JScript
public function get IsCanceled() : bool

Remarks

Not safe for use by multiple concurrent threads.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


Methods

IProgressMonitor Methods
[image]

Public Methods

Name | Description
Public method | BeginTask | Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done.
Public method CreateSubProgressMonitor

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Done | Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | SetStatus | Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled.
Public method | Worked | Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace
Canceled


BeginTask Method

IProgressMonitor.BeginTask Method
[image]

Notifies that the main task is starting. Must be called at most once on the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function BeginTask( _
ByVal taskName As String, _
ByVal totalWorkUnits As Double _
) As ProgressMonitorTaskCookie
C#
ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
C++
ProgressMonitorTaskCookie BeginTask(
String taskName,
double totalWorkUnits
) abstract
J#
ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
JScript
function BeginTask(
taskName : String,
totalWorkUnits : double
) : ProgressMonitorTaskCookie

Parameters

taskName
The name of the task being monitored
totalWorkUnits
The total number of work units to perform. Must be greater than 0, or NaN if an indeterminate amount of work is to be performed.

Return Value

An object that calls Done when disposed

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if taskName is null
ArgumentOutOfRangeException | Thrown if totalWorkUnits is not valid
InvalidOperationException | Thrown if BeginTask or Done have already been called

Remarks

Not safe for use by multiple concurrent threads.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


Cancel Method

IProgressMonitor.Cancel Method
[image]

Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Cancel()
C#
void Cancel()
C++
void Cancel() abstract
J#
void Cancel()
JScript
function Cancel()

Remarks

It is safe to call this method before BeginTask in which case the task will begin in an already canceled state.

Not safe for use by multiple concurrent threads.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


CreateSubProgressMonitor Method

IProgressMonitor.CreateSubProgressMonitor Method
[image]

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function CreateSubProgressMonitor( _
ByVal parentWorkUnits As Double _
) As IProgressMonitor
C#
IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
C++
IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
) abstract
J#
IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
JScript
function CreateSubProgressMonitor(
parentWorkUnits : double
) : IProgressMonitor

Parameters

parentWorkUnits
The total number of work units of the parent task that are to be represented by the sub-task. When the sub-task completes, this much work will have been performed on the parent. Must be a finite value greater than or equal to 0.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if parentWorkUnits is not valid

Remarks

It it still necessary to call BeginTask on the sub-progress monitor to begin processing the sub-task.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


Done Method

IProgressMonitor.Done Method
[image]

Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Done()
C#
void Done()
C++
void Done() abstract
J#
void Done()
JScript
function Done()

Remarks

This method automatically sets the amount of work remaining to zero. It also sets the amount of work completed to the total unless it was indeterminate or BeginTask was never called.

It is safe to call this method without calling BeginTask first in which case the task is immediately completed without ever having run. However, BeginTask may not subsequently be called.

If there are any currently active subtasks, they are automatically ended by this method exactly as if each subtask's IProgressMonitor had been notified that the work was done. This policy simplifies error recovery in situations where the main task may have been abruptly aborted without proper cleanup of its subtasks such as when severe exceptions occur. It is preferable to tolerate the error rather than to exacerbate it by enforcing stricter rules on subtasks.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


SetStatus Method

IProgressMonitor.SetStatus Method
[image]

Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SetStatus( _
ByVal status As String _
)
C#
void SetStatus(
string status
)
C++
void SetStatus(
String status
) abstract
J#
void SetStatus(
string status
)
JScript
function SetStatus(
status : String
)

Parameters

status
The name of the current subtask

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if status is null
InvalidOperationException | Thrown if the task is not running

Remarks

Not safe for use by multiple concurrent threads.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


ThrowIfCanceled Method

IProgressMonitor.ThrowIfCanceled Method
[image]

Throws an OperationCanceledException if the operation has been canceled.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub ThrowIfCanceled()
C#
void ThrowIfCanceled()
C++
void ThrowIfCanceled() abstract
J#
void ThrowIfCanceled()
JScript
function ThrowIfCanceled()

Exceptions

Exception Type | Condition
OperationCanceledException | Thrown if IsCanceled is true

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


Worked Method

IProgressMonitor.Worked Method
[image]

Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Worked( _
ByVal workUnits As Double _
)
C#
void Worked(
double workUnits
)
C++
void Worked(
double workUnits
) abstract
J#
void Worked(
double workUnits
)
JScript
function Worked(
workUnits : double
)

Parameters

workUnits
The number of work units completed so far. Must be a finite value greater than or equal to 0.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if workUnits is not valid
InvalidOperationException | Thrown if the task is not running

Remarks

Not safe for use by multiple concurrent threads.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


Events

IProgressMonitor Events
[image]

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately.
Top

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace
Canceled


Canceled Event

IProgressMonitor.Canceled Event
[image]

Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
MustOverride Event Canceled As EventHandler
C#
abstract event EventHandler Canceled
C++
event EventHandler Canceled {
void add(EventHandler value) abstract ;
void remove(EventHandler value) abstract ;
}
J#
/** event */
void add_Canceled(EventHandler value);

/** event */
abstract void remove_Canceled(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

Because the event may be delivered on a different thread from the one executing the main task, it is an error for the handler of this event to call any methods of this IProgressMonitor. Instead it should simply notify its main task to quit if possible (possibly by interrupting the main task's thread). Thus when the main task terminates, it will call Done itself to clean up.

The event handler should not block or throw exceptions. If it must perform any possibly long-running tasks of its own (such as synchronizing with processing threads) it should queue up an asynchronous task (possibly using the ThreadPool).

Unlike the other members of this interface, adding and removing event handlers is safe for use by multiple concurrent threads.

See Also

IProgressMonitor Interface
Gallio.Runtime.ProgressMonitoring Namespace


IProgressMonitorPresenter Interface

IProgressMonitorPresenter Interface
See Also Example Members
[image]

A progress monitor presenter attaches a progress monitor to a view.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IProgressMonitorPresenter
C#
public interface IProgressMonitorPresenter
C++
interface class IProgressMonitorPresenter
J#
public interface IProgressMonitorPresenter
JScript
public interface IProgressMonitorPresenter

Types that implement IProgressMonitorPresenter

Type | Description
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorPresenter | Abstract base class for objects whose purpose is to present progress information to the user. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Gallio.Runtime.ProgressMonitoring.NullProgressMonitorPresenter | A null progress monitor presenter simply does nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

See Also

IProgressMonitorPresenter Members
Gallio.Runtime.ProgressMonitoring Namespace


IProgressMonitorPresenter Members

IProgressMonitorPresenter Members
See Also Example Methods
[image]

A progress monitor presenter attaches a progress monitor to a view.

The following tables list the members exposed by IProgressMonitorPresenter.

Public Methods

 | Name | Description
Public method | Present | Presents an observable progress monitor.
Top

See Also

IProgressMonitorPresenter Interface
Gallio.Runtime.ProgressMonitoring Namespace


Methods

IProgressMonitorPresenter Methods
[image]

Public Methods

 | Name | Description
Public method | Present | Presents an observable progress monitor.
Top

See Also

IProgressMonitorPresenter Interface
Gallio.Runtime.ProgressMonitoring Namespace


Present Method

IProgressMonitorPresenter.Present Method
[image]

Presents an observable progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Present( _
ByVal progressMonitor As ObservableProgressMonitor _
)
C#
void Present(
ObservableProgressMonitor progressMonitor
)
C++
void Present(
ObservableProgressMonitor progressMonitor
) abstract
J#
void Present(
ObservableProgressMonitor progressMonitor
)
JScript
function Present(
progressMonitor : ObservableProgressMonitor
)

Parameters

progressMonitor
The progress monitor to present

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null
InvalidOperationException | Thrown if the presenter does not support being reused to present multiple progress monitors

See Also

IProgressMonitorPresenter Interface
Gallio.Runtime.ProgressMonitoring Namespace


IProgressMonitorProvider Interface

IProgressMonitorProvider Interface
See Also Example Members
[image]

A progress monitor provider runs a task with progress monitoring and provides clear notification of cancelation in the form of an OperationCanceledException.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IProgressMonitorProvider
C#
public interface IProgressMonitorProvider
C++
interface class IProgressMonitorProvider
J#
public interface IProgressMonitorProvider
JScript
public interface IProgressMonitorProvider

Types that implement IProgressMonitorProvider

Type | Description
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorProvider | An abstract base class to assist with the implementation of conformant IProgressMonitorProvider classes. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IProgressMonitorProvider Members
Gallio.Runtime.ProgressMonitoring Namespace


IProgressMonitorProvider Members

IProgressMonitorProvider Members
See Also Example Methods
[image]

A progress monitor provider runs a task with progress monitoring and provides clear notification of cancelation in the form of an OperationCanceledException.

The following tables list the members exposed by IProgressMonitorProvider.

Public Methods

 | Name | Description
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled.
Top

See Also

IProgressMonitorProvider Interface
Gallio.Runtime.ProgressMonitoring Namespace


Methods

IProgressMonitorProvider Methods
[image]

Public Methods

 | Name | Description
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled.
Top

See Also

IProgressMonitorProvider Interface
Gallio.Runtime.ProgressMonitoring Namespace


Run Method

IProgressMonitorProvider.Run Method
[image]

Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub Run( _
ByVal task As TaskWithProgress _
)
C#
void Run(
TaskWithProgress task
)
C++
void Run(
TaskWithProgress task
) abstract
J#
void Run(
TaskWithProgress task
)
JScript
function Run(
task : TaskWithProgress
)

Parameters

task
The task to run, never null

Exceptions

Exception Type | Condition
OperationCanceledException | Thrown if the task is canceled

Remarks

The provider should automatically dispose of the progress monitor in case the task forgets to do so. It is also responsible for calling ThrowIfCanceled before and after running the task to ensure that the OperationCanceledException is thrown as required.

The provider can choose to execute the task in a different thread but the method should still complete synchronously.

See Also

IProgressMonitorProvider Interface
Gallio.Runtime.ProgressMonitoring Namespace


LogProgressMonitorPresenter Class

LogProgressMonitorPresenter Class
See Also Example Members
[image]

Displays progress by writing a series of messages to an ILogger as the name of the current task changes.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LogProgressMonitorPresenter
Inherits BaseProgressMonitorPresenter
C#
public class LogProgressMonitorPresenter : BaseProgressMonitorPresenter
C++
ref class LogProgressMonitorPresenter : BaseProgressMonitorPresenter
J#
public class LogProgressMonitorPresenter extends BaseProgressMonitorPresenter
JScript
public class LogProgressMonitorPresenter extends BaseProgressMonitorPresenter

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.LogProgressMonitorPresenter

See Also

LogProgressMonitorPresenter Members
Gallio.Runtime.ProgressMonitoring Namespace


LogProgressMonitorPresenter Members

LogProgressMonitorPresenter Members
See Also Example Constructors Properties Methods
[image]

Displays progress by writing a series of messages to an ILogger as the name of the current task changes.

The following tables list the members exposed by LogProgressMonitorPresenter.

Public Constructors

 | Name | Description
Public method | LogProgressMonitorPresenter | Create a logged progress monitor presenter.
Top

Protected Properties

 | Name | Description
Family property | ProgressMonitor | Gets the attached progress monitor. (inherited from BaseProgressMonitorPresenter)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor. (inherited from BaseProgressMonitorPresenter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the presenter after a progress monitor has been attached.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


LogProgressMonitorPresenter Constructor

LogProgressMonitorPresenter Constructor
[image]

Create a logged progress monitor presenter.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal logger As ILogger _
)
C#
public LogProgressMonitorPresenter(
ILogger logger
)
C++
public:
LogProgressMonitorPresenter(
ILogger logger
) sealed
J#
public LogProgressMonitorPresenter(
ILogger logger
)
JScript
public function LogProgressMonitorPresenter(
logger : ILogger
)

Parameters

logger
A logger instance to which messages will be written

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logger is null

See Also

LogProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

LogProgressMonitorPresenter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor. (inherited from BaseProgressMonitorPresenter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the presenter after a progress monitor has been attached.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Initialize Method

LogProgressMonitorPresenter.Initialize Method
[image]

Initializes the presenter after a progress monitor has been attached.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Initialize()
C#
protected override void Initialize()
C++
protected:
virtual void Initialize() override
J#
protected override void Initialize()
JScript
protected override function Initialize()

See Also

LogProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


LogProgressMonitorProvider Class

LogProgressMonitorProvider Class
See Also Example Members
[image]

Displays progress by writing a series of messages to an ILogger as the name of the current task changes.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class LogProgressMonitorProvider
Inherits BaseProgressMonitorProvider
C#
public class LogProgressMonitorProvider : BaseProgressMonitorProvider
C++
ref class LogProgressMonitorProvider : BaseProgressMonitorProvider
J#
public class LogProgressMonitorProvider extends BaseProgressMonitorProvider
JScript
public class LogProgressMonitorProvider extends BaseProgressMonitorProvider

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.LogProgressMonitorProvider

See Also

LogProgressMonitorProvider Members
Gallio.Runtime.ProgressMonitoring Namespace


LogProgressMonitorProvider Members

LogProgressMonitorProvider Members
See Also Example Constructors Methods
[image]

Displays progress by writing a series of messages to an ILogger as the name of the current task changes.

The following tables list the members exposed by LogProgressMonitorProvider.

Public Constructors

 | Name | Description
Public method | LogProgressMonitorProvider | Creates a log progress monitor provider.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled. (inherited from BaseProgressMonitorProvider)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetPresenter | Overridden. Gets a presenter for the progress monitor.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


LogProgressMonitorProvider Constructor

LogProgressMonitorProvider Constructor
[image]

Creates a log progress monitor provider.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal logger As ILogger _
)
C#
public LogProgressMonitorProvider(
ILogger logger
)
C++
public:
LogProgressMonitorProvider(
ILogger logger
) sealed
J#
public LogProgressMonitorProvider(
ILogger logger
)
JScript
public function LogProgressMonitorProvider(
logger : ILogger
)

Parameters

logger
The logger to which messages should be written

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if logger is null

See Also

LogProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

LogProgressMonitorProvider Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled. (inherited from BaseProgressMonitorProvider)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetPresenter | Overridden. Gets a presenter for the progress monitor.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

LogProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


GetPresenter Method

LogProgressMonitorProvider.GetPresenter Method
[image]

Gets a presenter for the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetPresenter() As IProgressMonitorPresenter
C#
protected override IProgressMonitorPresenter GetPresenter()
C++
protected:
virtual IProgressMonitorPresenter GetPresenter() override
J#
protected override IProgressMonitorPresenter GetPresenter()
JScript
protected override function GetPresenter() : IProgressMonitorPresenter

Return Value

The presenter

See Also

LogProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


NullProgressMonitor Class

NullProgressMonitor Class
See Also Example Members
[image]

Creates instances of null progress monitors that do nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module NullProgressMonitor
C#
public static class NullProgressMonitor
C++
ref class NullProgressMonitor abstract sealed
J#
public final class NullProgressMonitor
JScript
public class NullProgressMonitor

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.NullProgressMonitor

See Also

NullProgressMonitor Members
Gallio.Runtime.ProgressMonitoring Namespace


NullProgressMonitor Members

NullProgressMonitor Members
See Also Example Methods
[image]

Creates instances of null progress monitors that do nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by NullProgressMonitor.

Public Methods

Name | Description
CreateInstance | Creates a null progress monitor.
Top

See Also

NullProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

NullProgressMonitor Methods
[image]

Public Methods

Name | Description
CreateInstance | Creates a null progress monitor.
Top

See Also

NullProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


CreateInstance Method

NullProgressMonitor.CreateInstance Method
[image]

Creates a null progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstance() As IProgressMonitor
C#
public static IProgressMonitor CreateInstance()
C++
public:
static IProgressMonitor CreateInstance()
J#
public static IProgressMonitor CreateInstance()
JScript
public static function CreateInstance() : IProgressMonitor

Return Value

The null progress monitor

See Also

NullProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


NullProgressMonitorPresenter Class

NullProgressMonitorPresenter Class
See Also Example Members
[image]

A null progress monitor presenter simply does nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullProgressMonitorPresenter
Implements IProgressMonitorPresenter
C#
public sealed class NullProgressMonitorPresenter : IProgressMonitorPresenter
C++
ref class NullProgressMonitorPresenter sealed : IProgressMonitorPresenter
J#
public final class NullProgressMonitorPresenter implements IProgressMonitorPresenter
JScript
public final class NullProgressMonitorPresenter extends IProgressMonitorPresenter

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.NullProgressMonitorPresenter

See Also

NullProgressMonitorPresenter Members
Gallio.Runtime.ProgressMonitoring Namespace


NullProgressMonitorPresenter Members

NullProgressMonitorPresenter Members
See Also Example Fields Methods
[image]

A null progress monitor presenter simply does nothing. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by NullProgressMonitorPresenter.

Public Fields

Name | Description
Instance | Gets the singleton instance of the presenter. This field is read-only.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Fields

NullProgressMonitorPresenter Fields
[image]

Public Fields

Name | Description
Instance | Gets the singleton instance of the presenter. This field is read-only.
Top

See Also

NullProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Instance Field

NullProgressMonitorPresenter.Instance Field
[image]

Gets the singleton instance of the presenter. This field is read-only.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Instance As NullProgressMonitorPresenter
C#
public static readonly NullProgressMonitorPresenter Instance;
C++
public:
static const NullProgressMonitorPresenter Instance;
J#
public static final NullProgressMonitorPresenter Instance
JScript
public static const var Instance : NullProgressMonitorPresenter;

See Also

NullProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

NullProgressMonitorPresenter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Present Method

NullProgressMonitorPresenter.Present Method
[image]

Presents an observable progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Present( _
ByVal progressMonitor As ObservableProgressMonitor _
) _
Implements IProgressMonitorPresenter.Present
C#
public void Present(
ObservableProgressMonitor progressMonitor
)
C++
public:
void Present(
ObservableProgressMonitor progressMonitor
) sealed
J#
public void Present(
ObservableProgressMonitor progressMonitor
)
JScript
public function Present(
progressMonitor : ObservableProgressMonitor
)

Parameters

progressMonitor
The progress monitor to present

Implements

IProgressMonitorPresenter.Present

See Also

NullProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


NullProgressMonitorProvider Class

NullProgressMonitorProvider Class
See Also Example Members
[image]

Runs tasks without reporting any progress. Argument validation and state changes are still noted but they do not have any outward effect. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NullProgressMonitorProvider
Inherits BaseProgressMonitorProvider
C#
public sealed class NullProgressMonitorProvider : BaseProgressMonitorProvider
C++
ref class NullProgressMonitorProvider sealed : BaseProgressMonitorProvider
J#
public final class NullProgressMonitorProvider extends BaseProgressMonitorProvider
JScript
public final class NullProgressMonitorProvider extends BaseProgressMonitorProvider

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.NullProgressMonitorProvider

See Also

NullProgressMonitorProvider Members
Gallio.Runtime.ProgressMonitoring Namespace


NullProgressMonitorProvider Members

NullProgressMonitorProvider Members
See Also Example Properties Methods
[image]

Runs tasks without reporting any progress. Argument validation and state changes are still noted but they do not have any outward effect. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by NullProgressMonitorProvider.

Public Properties

Name | Description
Instance | Gets the singleton instance of the provider.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled. (inherited from BaseProgressMonitorProvider)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NullProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


Properties

NullProgressMonitorProvider Properties
[image]

Public Properties

Name | Description
Instance | Gets the singleton instance of the provider.
Top

See Also

NullProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


Instance Property

NullProgressMonitorProvider.Instance Property
[image]

Gets the singleton instance of the provider.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As NullProgressMonitorProvider
C#
public static NullProgressMonitorProvider Instance { get; }
C++
public static property NullProgressMonitorProvider Instance {
NullProgressMonitorProvider get();
}
J#
/** property */
public NullProgressMonitorProvider get_Instance();
JScript
public function get Instance() : NullProgressMonitorProvider

See Also

NullProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


ObservableProgressMonitor Class

ObservableProgressMonitor Class
See Also Example Members
[image]

An observable progress monitor tracks validates arguments and tracks the state of the progress monitor but it does not implement any of its own behavior in response to the notifications received. Instead, it is intended to be observed by a presenter that translates state change events into changes of the view.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class ObservableProgressMonitor
Inherits CancelableProgressMonitor
C#
[SerializableAttribute]
public class ObservableProgressMonitor : CancelableProgressMonitor
C++
[SerializableAttribute]
ref class ObservableProgressMonitor : CancelableProgressMonitor
J#
/** @attribute SerializableAttribute() */
public class ObservableProgressMonitor extends CancelableProgressMonitor
JScript
public
SerializableAttribute
class ObservableProgressMonitor extends CancelableProgressMonitor

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.CancelableProgressMonitor
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor.SubProgressMonitor

See Also

ObservableProgressMonitor Members
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


ObservableProgressMonitor Members

ObservableProgressMonitor Members
See Also Example Constructors Properties Methods Events
[image]

An observable progress monitor tracks validates arguments and tracks the state of the progress monitor but it does not implement any of its own behavior in response to the notifications received. Instead, it is intended to be observed by a presenter that translates state change events into changes of the view.

The following tables list the members exposed by ObservableProgressMonitor.

Public Constructors

 | Name | Description
Public method | ObservableProgressMonitor | Initializes a new instance of the ObservableProgressMonitor class.
Top

Public Properties

 | Name | Description
Public property | Child | Gets the active child sub-progress monitor, or null if none.
Public property | CompletedWorkUnits | Gets the number of work units completed so far. It is the sum of all values passed to the Worked method while the task has been running. This value is never NaN because at each step a finite amount of work must be recorded.
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion. (inherited from CancelableProgressMonitor)
Public property | IsDone | Returns true if Done has been called.
Public property | IsRunning | Returns true if BeginTask has been called and Done has not yet also been called.
Public property | Leaf | Gets the currently active leaf sub-progress monitor, or this one if there are no sub-progress monitors.
Public property | LeafSubTaskName | Gets the name of the most deeply nested sub-task, or an empty string if there are no sub-progress monitors.
Public property | RemainingWorkUnits | Gets the number of remaining work units to perform, or NaN to indicate that an indeterminate amount of work remains to be performed because TotalWorkUnits is NaN and the operation is not done.
Public property | Status | Gets the current status message set by SetStatus or an empty string by default.
Public property | TaskName | Gets the name of the task or an empty string if BeginTask has not been called.
Public property | TotalWorkUnits | Gets the total number of work units to perform, or NaN to indicate that an indeterminate amount of work is to be performed.
Top

Public Methods

Name | Description
Public method | BeginTask | Overridden. Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done. (inherited from CancelableProgressMonitor)
Public method CreateSubProgressMonitor Overridden.

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Public method | Done | Overridden. Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Overridden. Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled. (inherited from CancelableProgressMonitor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Overridden. Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

Protected Methods

 | Name | Description
Family method | BeginSubTask | Begins a sub-task in a sub-progress monitor.
Family method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Family method | EndSubTask | Ends a sub-task in a sub-progress monitor.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyCanceled | Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing. (inherited from CancelableProgressMonitor)
Family method | NotifyRecursiveSubTaskChanged | Called when a subtask changes in any way, including one of its own subtasks changing.
Family method | OnBeginSubTask | Called when the active sub-task BeginSubTask performs its updates.
Family method | OnBeginTask | Called after BeginTask performs its updates.
Family method | OnCancel | Overridden. Called when Cancel performs its updates.
Family method | OnChange | Called when a state change occurs.
Family method | OnDone | Called when Done performs its updates.
Family method | OnEndSubTask | Called when EndSubTask performs its updates.
Family method | OnRecursiveSubTaskChange | Called when NotifyRecursiveSubTaskChanged performs its updates.
Family method | OnSetStatus | Called when SetStatus performs its updates.
Family method | OnSubProgressMonitorCreated | Called when a new progress monitor is created.
Family method | OnWorked | Called when Worked performs its updates.
Top

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately. (inherited from CancelableProgressMonitor)
Public event | Changed | Adds or removes an event handler that is called whenever the state of the progress monitor changes in any way.
Public event | SubProgressMonitorCreated | Adds or removes an event handler that is called whenever a new sub-progress monitor is created so that the observer can attach its event handlers.
Public event | TaskFinished | Adds or removes an event handler that is called when the task is finished.
Public event | TaskStarting | Adds or removes an event handler that is called when the task is starting.
Top

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


ObservableProgressMonitor Constructor

ObservableProgressMonitor Constructor
[image]

Initializes a new instance of the ObservableProgressMonitor class.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ObservableProgressMonitor()
C++
public:
ObservableProgressMonitor() sealed
J#
public ObservableProgressMonitor()
JScript
public function ObservableProgressMonitor()

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Properties

ObservableProgressMonitor Properties
[image]

Public Properties

 | Name | Description
Public property | Child | Gets the active child sub-progress monitor, or null if none.
Public property | CompletedWorkUnits | Gets the number of work units completed so far. It is the sum of all values passed to the Worked method while the task has been running. This value is never NaN because at each step a finite amount of work must be recorded.
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion. (inherited from CancelableProgressMonitor)
Public property | IsDone | Returns true if Done has been called.
Public property | IsRunning | Returns true if BeginTask has been called and Done has not yet also been called.
Public property | Leaf | Gets the currently active leaf sub-progress monitor, or this one if there are no sub-progress monitors.
Public property | LeafSubTaskName | Gets the name of the most deeply nested sub-task, or an empty string if there are no sub-progress monitors.
Public property | RemainingWorkUnits | Gets the number of remaining work units to perform, or NaN to indicate that an indeterminate amount of work remains to be performed because TotalWorkUnits is NaN and the operation is not done.
Public property | Status | Gets the current status message set by SetStatus or an empty string by default.
Public property | TaskName | Gets the name of the task or an empty string if BeginTask has not been called.
Public property | TotalWorkUnits | Gets the total number of work units to perform, or NaN to indicate that an indeterminate amount of work is to be performed.
Top

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


Child Property

ObservableProgressMonitor.Child Property
[image]

Gets the active child sub-progress monitor, or null if none.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Child As ObservableProgressMonitor
C#
public ObservableProgressMonitor Child { get; }
C++
public property ObservableProgressMonitor Child sealed {
ObservableProgressMonitor get();
}
J#
/** property */
public ObservableProgressMonitor get_Child();
JScript
public function get Child() : ObservableProgressMonitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


CompletedWorkUnits Property

ObservableProgressMonitor.CompletedWorkUnits Property
[image]

Gets the number of work units completed so far. It is the sum of all values passed to the Worked method while the task has been running. This value is never NaN because at each step a finite amount of work must be recorded.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CompletedWorkUnits As Double
C#
public double CompletedWorkUnits { get; }
C++
public property double CompletedWorkUnits sealed {
double get();
}
J#
/** property */
public double get_CompletedWorkUnits();
JScript
public function get CompletedWorkUnits() : double

Remarks

Returns 0 if BeginTask and Worked have not been called.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


IsDone Property

ObservableProgressMonitor.IsDone Property
[image]

Returns true if Done has been called.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDone As Boolean
C#
public bool IsDone { get; }
C++
public property bool IsDone sealed {
bool get();
}
J#
/** property */
public bool get_IsDone();
JScript
public function get IsDone() : bool

Remarks

This property is not affected by cancellation.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


IsRunning Property

ObservableProgressMonitor.IsRunning Property
[image]

Returns true if BeginTask has been called and Done has not yet also been called.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRunning As Boolean
C#
public bool IsRunning { get; }
C++
public property bool IsRunning sealed {
bool get();
}
J#
/** property */
public bool get_IsRunning();
JScript
public function get IsRunning() : bool

Remarks

This property is not affected by cancelation.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Leaf Property

ObservableProgressMonitor.Leaf Property
[image]

Gets the currently active leaf sub-progress monitor, or this one if there are no sub-progress monitors.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leaf As ObservableProgressMonitor
C#
public ObservableProgressMonitor Leaf { get; }
C++
public property ObservableProgressMonitor Leaf sealed {
ObservableProgressMonitor get();
}
J#
/** property */
public ObservableProgressMonitor get_Leaf();
JScript
public function get Leaf() : ObservableProgressMonitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


LeafSubTaskName Property

ObservableProgressMonitor.LeafSubTaskName Property
[image]

Gets the name of the most deeply nested sub-task, or an empty string if there are no sub-progress monitors.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LeafSubTaskName As String
C#
public string LeafSubTaskName { get; }
C++
public property string LeafSubTaskName sealed {
String get();
}
J#
/** property */
public string get_LeafSubTaskName();
JScript
public function get LeafSubTaskName() : String

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


RemainingWorkUnits Property

ObservableProgressMonitor.RemainingWorkUnits Property
[image]

Gets the number of remaining work units to perform, or NaN to indicate that an indeterminate amount of work remains to be performed because TotalWorkUnits is NaN and the operation is not done.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemainingWorkUnits As Double
C#
public double RemainingWorkUnits { get; }
C++
public property double RemainingWorkUnits sealed {
double get();
}
J#
/** property */
public double get_RemainingWorkUnits();
JScript
public function get RemainingWorkUnits() : double

Remarks

Returns NaN if BeginTask has not been called.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Status Property

ObservableProgressMonitor.Status Property
[image]

Gets the current status message set by SetStatus or an empty string by default.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As String
C#
public string Status { get; }
C++
public property string Status sealed {
String get();
}
J#
/** property */
public string get_Status();
JScript
public function get Status() : String

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


TaskName Property

ObservableProgressMonitor.TaskName Property
[image]

Gets the name of the task or an empty string if BeginTask has not been called.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TaskName As String
C#
public string TaskName { get; }
C++
public property string TaskName sealed {
String get();
}
J#
/** property */
public string get_TaskName();
JScript
public function get TaskName() : String

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


TotalWorkUnits Property

ObservableProgressMonitor.TotalWorkUnits Property
[image]

Gets the total number of work units to perform, or NaN to indicate that an indeterminate amount of work is to be performed.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalWorkUnits As Double
C#
public double TotalWorkUnits { get; }
C++
public property double TotalWorkUnits sealed {
double get();
}
J#
/** property */
public double get_TotalWorkUnits();
JScript
public function get TotalWorkUnits() : double

Remarks

Returns NaN if BeginTask has not been called.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

ObservableProgressMonitor Methods
[image]

Public Methods

Name | Description
Public method | BeginTask | Overridden. Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done. (inherited from CancelableProgressMonitor)
Public method CreateSubProgressMonitor Overridden.

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Public method | Done | Overridden. Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Overridden. Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled. (inherited from CancelableProgressMonitor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Overridden. Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

Protected Methods

 | Name | Description
Family method | BeginSubTask | Begins a sub-task in a sub-progress monitor.
Family method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Family method | EndSubTask | Ends a sub-task in a sub-progress monitor.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyCanceled | Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing. (inherited from CancelableProgressMonitor)
Family method | NotifyRecursiveSubTaskChanged | Called when a subtask changes in any way, including one of its own subtasks changing.
Family method | OnBeginSubTask | Called when the active sub-task BeginSubTask performs its updates.
Family method | OnBeginTask | Called after BeginTask performs its updates.
Family method | OnCancel | Overridden. Called when Cancel performs its updates.
Family method | OnChange | Called when a state change occurs.
Family method | OnDone | Called when Done performs its updates.
Family method | OnEndSubTask | Called when EndSubTask performs its updates.
Family method | OnRecursiveSubTaskChange | Called when NotifyRecursiveSubTaskChanged performs its updates.
Family method | OnSetStatus | Called when SetStatus performs its updates.
Family method | OnSubProgressMonitorCreated | Called when a new progress monitor is created.
Family method | OnWorked | Called when Worked performs its updates.
Top

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


BeginSubTask Method

ObservableProgressMonitor.BeginSubTask Method
[image]

Begins a sub-task in a sub-progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeginSubTask( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void BeginSubTask(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void BeginSubTask(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void BeginSubTask(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function BeginSubTask(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The sub-progress monitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


BeginTask Method

ObservableProgressMonitor.BeginTask Method
[image]

Notifies that the main task is starting. Must be called at most once on the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BeginTask( _
ByVal taskName As String, _
ByVal totalWorkUnits As Double _
) As ProgressMonitorTaskCookie _
Implements IProgressMonitor.BeginTask
C#
public override ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
C++
public:
virtual ProgressMonitorTaskCookie BeginTask(
String taskName,
double totalWorkUnits
) override
J#
public override ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
JScript
public override function BeginTask(
taskName : String,
totalWorkUnits : double
) : ProgressMonitorTaskCookie

Parameters

taskName
The name of the task being monitored
totalWorkUnits
The total number of work units to perform. Must be greater than 0, or NaN if an indeterminate amount of work is to be performed.

Return Value

An object that calls Done when disposed

Implements

IProgressMonitor.BeginTask

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


CreateSubProgressMonitor Method

ObservableProgressMonitor.CreateSubProgressMonitor Method
[image]

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateSubProgressMonitor( _
ByVal parentWorkUnits As Double _
) As IProgressMonitor _
Implements IProgressMonitor.CreateSubProgressMonitor
C#
public override IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
C++
public:
virtual IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
) override
J#
public override IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
JScript
public override function CreateSubProgressMonitor(
parentWorkUnits : double
) : IProgressMonitor

Parameters

parentWorkUnits
The total number of work units of the parent task that are to be represented by the sub-task. When the sub-task completes, this much work will have been performed on the parent. Must be a finite value greater than or equal to 0.

Implements

IProgressMonitor.CreateSubProgressMonitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Done Method

ObservableProgressMonitor.Done Method
[image]

Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Done() _
Implements IProgressMonitor.Done
C#
public override void Done()
C++
public:
virtual void Done() override
J#
public override void Done()
JScript
public override function Done()

Implements

IProgressMonitor.Done

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


EndSubTask Method

ObservableProgressMonitor.EndSubTask Method
[image]

Ends a sub-task in a sub-progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EndSubTask( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void EndSubTask(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void EndSubTask(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void EndSubTask(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function EndSubTask(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The sub-progress monitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


NotifyRecursiveSubTaskChanged Method

ObservableProgressMonitor.NotifyRecursiveSubTaskChanged Method
See Also Example
[image]

Called when a subtask changes in any way, including one of its own subtasks changing.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub NotifyRecursiveSubTaskChanged( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void NotifyRecursiveSubTaskChanged(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void NotifyRecursiveSubTaskChanged(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void NotifyRecursiveSubTaskChanged(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function NotifyRecursiveSubTaskChanged(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The sub-progress monitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnBeginSubTask Method

ObservableProgressMonitor.OnBeginSubTask Method
[image]

Called when the active sub-task BeginSubTask performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeginSubTask( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void OnBeginSubTask(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void OnBeginSubTask(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void OnBeginSubTask(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function OnBeginSubTask(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The sub-task's progress monitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnBeginTask Method

ObservableProgressMonitor.OnBeginTask Method
[image]

Called after BeginTask performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeginTask( _
ByVal taskName As String, _
ByVal totalWorkUnits As Double _
)
C#
protected virtual void OnBeginTask(
string taskName,
double totalWorkUnits
)
C++
protected:
virtual void OnBeginTask(
String taskName,
double totalWorkUnits
)
J#
protected virtual void OnBeginTask(
string taskName,
double totalWorkUnits
)
JScript
protected virtual function OnBeginTask(
taskName : String,
totalWorkUnits : double
)

Parameters

taskName
The task name
totalWorkUnits
The total number of work units

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnCancel Method

ObservableProgressMonitor.OnCancel Method
[image]

Called when Cancel performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCancel()
C#
protected override void OnCancel()
C++
protected:
virtual void OnCancel() override
J#
protected override void OnCancel()
JScript
protected override function OnCancel()

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnChange Method

ObservableProgressMonitor.OnChange Method
[image]

Called when a state change occurs.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnChange()
C#
protected virtual void OnChange()
C++
protected:
virtual void OnChange()
J#
protected virtual void OnChange()
JScript
protected virtual function OnChange()

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnDone Method

ObservableProgressMonitor.OnDone Method
[image]

Called when Done performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDone()
C#
protected virtual void OnDone()
C++
protected:
virtual void OnDone()
J#
protected virtual void OnDone()
JScript
protected virtual function OnDone()

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnEndSubTask Method

ObservableProgressMonitor.OnEndSubTask Method
[image]

Called when EndSubTask performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEndSubTask( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void OnEndSubTask(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void OnEndSubTask(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void OnEndSubTask(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function OnEndSubTask(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The sub-task's progress monitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnRecursiveSubTaskChange Method

ObservableProgressMonitor.OnRecursiveSubTaskChange Method
[image]

Called when NotifyRecursiveSubTaskChanged performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRecursiveSubTaskChange( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void OnRecursiveSubTaskChange(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void OnRecursiveSubTaskChange(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void OnRecursiveSubTaskChange(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function OnRecursiveSubTaskChange(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The sub-task's progress monitor

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnSetStatus Method

ObservableProgressMonitor.OnSetStatus Method
[image]

Called when SetStatus performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSetStatus( _
ByVal status As String _
)
C#
protected virtual void OnSetStatus(
string status
)
C++
protected:
virtual void OnSetStatus(
String status
)
J#
protected virtual void OnSetStatus(
string status
)
JScript
protected virtual function OnSetStatus(
status : String
)

Parameters

status
The status message

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnSubProgressMonitorCreated Method

ObservableProgressMonitor.OnSubProgressMonitorCreated Method
[image]

Called when a new progress monitor is created.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSubProgressMonitorCreated( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
protected virtual void OnSubProgressMonitorCreated(
ObservableProgressMonitor subProgressMonitor
)
C++
protected:
virtual void OnSubProgressMonitorCreated(
ObservableProgressMonitor subProgressMonitor
)
J#
protected virtual void OnSubProgressMonitorCreated(
ObservableProgressMonitor subProgressMonitor
)
JScript
protected virtual function OnSubProgressMonitorCreated(
subProgressMonitor : ObservableProgressMonitor
)

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnWorked Method

ObservableProgressMonitor.OnWorked Method
[image]

Called when Worked performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnWorked( _
ByVal workUnits As Double _
)
C#
protected virtual void OnWorked(
double workUnits
)
C++
protected:
virtual void OnWorked(
double workUnits
)
J#
protected virtual void OnWorked(
double workUnits
)
JScript
protected virtual function OnWorked(
workUnits : double
)

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


SetStatus Method

ObservableProgressMonitor.SetStatus Method
[image]

Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetStatus( _
ByVal status As String _
) _
Implements IProgressMonitor.SetStatus
C#
public override void SetStatus(
string status
)
C++
public:
virtual void SetStatus(
String status
) override
J#
public override void SetStatus(
string status
)
JScript
public override function SetStatus(
status : String
)

Parameters

status
The name of the current subtask

Implements

IProgressMonitor.SetStatus

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Worked Method

ObservableProgressMonitor.Worked Method
[image]

Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Worked( _
ByVal workUnits As Double _
) _
Implements IProgressMonitor.Worked
C#
public override void Worked(
double workUnits
)
C++
public:
virtual void Worked(
double workUnits
) override
J#
public override void Worked(
double workUnits
)
JScript
public override function Worked(
workUnits : double
)

Parameters

workUnits
The number of work units completed so far. Must be a finite value greater than or equal to 0.

Implements

IProgressMonitor.Worked

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Events

ObservableProgressMonitor Events
[image]

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately. (inherited from CancelableProgressMonitor)
Public event | Changed | Adds or removes an event handler that is called whenever the state of the progress monitor changes in any way.
Public event | SubProgressMonitorCreated | Adds or removes an event handler that is called whenever a new sub-progress monitor is created so that the observer can attach its event handlers.
Public event | TaskFinished | Adds or removes an event handler that is called when the task is finished.
Public event | TaskStarting | Adds or removes an event handler that is called when the task is starting.
Top

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


Changed Event

ObservableProgressMonitor.Changed Event
[image]

Adds or removes an event handler that is called whenever the state of the progress monitor changes in any way.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event Changed As EventHandler
C#
public event EventHandler Changed
C++
public:
virtual event EventHandler Changed {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_Changed(EventHandler value);

/** event */
public final void remove_Changed(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


SubProgressMonitorCreated Event

ObservableProgressMonitor.SubProgressMonitorCreated Event
[image]

Adds or removes an event handler that is called whenever a new sub-progress monitor is created so that the observer can attach its event handlers.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event SubProgressMonitorCreated As EventHandler(Of SubProgressMonitorCreatedEventArgs)
C#
public event EventHandler<SubProgressMonitorCreatedEventArgs> SubProgressMonitorCreated
C++
public:
virtual event EventHandler<SubProgressMonitorCreatedEventArgs> SubProgressMonitorCreated {
void add(EventHandler<SubProgressMonitorCreatedEventArgs> value) sealed ;
void remove(EventHandler<SubProgressMonitorCreatedEventArgs> value) sealed ;
}
J#
/** event */
public final void add_SubProgressMonitorCreated(EventHandler<SubProgressMonitorCreatedEventArgs> value);

/** event */
public final void remove_SubProgressMonitorCreated(EventHandler<SubProgressMonitorCreatedEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Event Data

The event handler receives an argument of type SubProgressMonitorCreatedEventArgs containing data related to this event. The following SubProgressMonitorCreatedEventArgs property provides information specific to this event.

Property | Description
SubProgressMonitor | Gets the newly created sub-progress monitor.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


TaskFinished Event

ObservableProgressMonitor.TaskFinished Event
[image]

Adds or removes an event handler that is called when the task is finished.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TaskFinished As EventHandler
C#
public event EventHandler TaskFinished
C++
public:
virtual event EventHandler TaskFinished {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_TaskFinished(EventHandler value);

/** event */
public final void remove_TaskFinished(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


TaskStarting Event

ObservableProgressMonitor.TaskStarting Event
[image]

Adds or removes an event handler that is called when the task is starting.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Event TaskStarting As EventHandler
C#
public event EventHandler TaskStarting
C++
public:
virtual event EventHandler TaskStarting {
void add(EventHandler value) sealed ;
void remove(EventHandler value) sealed ;
}
J#
/** event */
public final void add_TaskStarting(EventHandler value);

/** event */
public final void remove_TaskStarting(EventHandler value);
JScript
JScript suports the use of events, but not the declaration of new ones.

See Also

ObservableProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


ObservableProgressMonitor.SubProgressMonitor Class

ObservableProgressMonitor.SubProgressMonitor Class
See Also Example Members
[image]

A standard sub-progress monitor implementation that notifies its parent as work is performed.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Class ObservableProgressMonitor.SubProgressMonitor
Inherits ObservableProgressMonitor
C#
protected class ObservableProgressMonitor.SubProgressMonitor : ObservableProgressMonitor
C++
ref class ObservableProgressMonitor.SubProgressMonitor : ObservableProgressMonitor
J#
protected class ObservableProgressMonitor.SubProgressMonitor extends ObservableProgressMonitor
JScript
protected class ObservableProgressMonitor.SubProgressMonitor extends ObservableProgressMonitor

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.CancelableProgressMonitor
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor.SubProgressMonitor

See Also

ObservableProgressMonitor.SubProgressMonitor Members
Gallio.Runtime.ProgressMonitoring Namespace


ObservableProgressMonitor.SubProgressMonitor Members

ObservableProgressMonitor.SubProgressMonitor Members
See Also Example Constructors Properties Methods Events
[image]

A standard sub-progress monitor implementation that notifies its parent as work is performed.

The following tables list the members exposed by ObservableProgressMonitor.SubProgressMonitor.

Public Constructors

 | Name | Description
Public method | ObservableProgressMonitor.SubProgressMonitor | Creates a sub-progress monitor.
Top

Public Properties

 | Name | Description
Public property | Child | Gets the active child sub-progress monitor, or null if none. (inherited from ObservableProgressMonitor)
Public property | CompletedWorkUnits | Gets the number of work units completed so far. It is the sum of all values passed to the Worked method while the task has been running. This value is never NaN because at each step a finite amount of work must be recorded. (inherited from ObservableProgressMonitor)
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion. (inherited from CancelableProgressMonitor)
Public property | IsDone | Returns true if Done has been called. (inherited from ObservableProgressMonitor)
Public property | IsRunning | Returns true if BeginTask has been called and Done has not yet also been called. (inherited from ObservableProgressMonitor)
Public property | Leaf | Gets the currently active leaf sub-progress monitor, or this one if there are no sub-progress monitors. (inherited from ObservableProgressMonitor)
Public property | LeafSubTaskName | Gets the name of the most deeply nested sub-task, or an empty string if there are no sub-progress monitors. (inherited from ObservableProgressMonitor)
Public property | RemainingWorkUnits | Gets the number of remaining work units to perform, or NaN to indicate that an indeterminate amount of work remains to be performed because TotalWorkUnits is NaN and the operation is not done. (inherited from ObservableProgressMonitor)
Public property | Status | Gets the current status message set by SetStatus or an empty string by default. (inherited from ObservableProgressMonitor)
Public property | TaskName | Gets the name of the task or an empty string if BeginTask has not been called. (inherited from ObservableProgressMonitor)
Public property | TotalWorkUnits | Gets the total number of work units to perform, or NaN to indicate that an indeterminate amount of work is to be performed. (inherited from ObservableProgressMonitor)
Top

Public Methods

Name | Description
Public method | BeginTask | Notifies that the main task is starting. Must be called at most once on the progress monitor. (inherited from ObservableProgressMonitor)
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done. (inherited from CancelableProgressMonitor)
Public method CreateSubProgressMonitor

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

(inherited from ObservableProgressMonitor)
Public method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Public method | Done | Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect. (inherited from ObservableProgressMonitor)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files. (inherited from ObservableProgressMonitor)
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled. (inherited from CancelableProgressMonitor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded. (inherited from ObservableProgressMonitor)
Top

Protected Methods

 | Name | Description
Family method | BeginSubTask | Begins a sub-task in a sub-progress monitor. (inherited from ObservableProgressMonitor)
Family method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Family method | EndSubTask | Ends a sub-task in a sub-progress monitor. (inherited from ObservableProgressMonitor)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyCanceled | Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing. (inherited from CancelableProgressMonitor)
Family method | NotifyRecursiveSubTaskChanged | Called when a subtask changes in any way, including one of its own subtasks changing. (inherited from ObservableProgressMonitor)
Family method | OnBeginSubTask | Called when the active sub-task BeginSubTask performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnBeginTask | Overridden. Called after BeginTask performs its updates.
Family method | OnCancel | Overridden. Called when Cancel performs its updates.
Family method | OnChange | Overridden. Called when a state change occurs.
Family method | OnDone | Overridden. Called when Done performs its updates.
Family method | OnEndSubTask | Called when EndSubTask performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnRecursiveSubTaskChange | Called when NotifyRecursiveSubTaskChanged performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnSetStatus | Called when SetStatus performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnSubProgressMonitorCreated | Called when a new progress monitor is created. (inherited from ObservableProgressMonitor)
Family method | OnWorked | Overridden. Called when Worked performs its updates.
Top

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately. (inherited from CancelableProgressMonitor)
Public event | Changed | Adds or removes an event handler that is called whenever the state of the progress monitor changes in any way. (inherited from ObservableProgressMonitor)
Public event | SubProgressMonitorCreated | Adds or removes an event handler that is called whenever a new sub-progress monitor is created so that the observer can attach its event handlers. (inherited from ObservableProgressMonitor)
Public event | TaskFinished | Adds or removes an event handler that is called when the task is finished. (inherited from ObservableProgressMonitor)
Public event | TaskStarting | Adds or removes an event handler that is called when the task is starting. (inherited from ObservableProgressMonitor)
Top

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


ObservableProgressMonitor.SubProgressMonitor Constructor

ObservableProgressMonitor.SubProgressMonitor Constructor
[image]

Creates a sub-progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal parent As ObservableProgressMonitor, _
ByVal parentWorkUnits As Double _
)
C#
public ObservableProgressMonitor.SubProgressMonitor(
ObservableProgressMonitor parent,
double parentWorkUnits
)
C++
public:
ObservableProgressMonitor.SubProgressMonitor(
ObservableProgressMonitor parent,
double parentWorkUnits
) sealed
J#
public ObservableProgressMonitor.SubProgressMonitor(
ObservableProgressMonitor parent,
double parentWorkUnits
)
JScript
public function ObservableProgressMonitor.SubProgressMonitor(
parent : ObservableProgressMonitor,
parentWorkUnits : double
)

Parameters

parent
The parent progress monitor
parentWorkUnits
The total number of work units of the parent task that are to be represented by the sub-task.

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

ObservableProgressMonitor.SubProgressMonitor Methods
[image]

Public Methods

Name | Description
Public method | BeginTask | Notifies that the main task is starting. Must be called at most once on the progress monitor. (inherited from ObservableProgressMonitor)
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done. (inherited from CancelableProgressMonitor)
Public method CreateSubProgressMonitor

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

(inherited from ObservableProgressMonitor)
Public method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Public method | Done | Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect. (inherited from ObservableProgressMonitor)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files. (inherited from ObservableProgressMonitor)
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled. (inherited from CancelableProgressMonitor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded. (inherited from ObservableProgressMonitor)
Top

Protected Methods

 | Name | Description
Family method | BeginSubTask | Begins a sub-task in a sub-progress monitor. (inherited from ObservableProgressMonitor)
Family method | Dispose | Overloaded. Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Family method | EndSubTask | Ends a sub-task in a sub-progress monitor. (inherited from ObservableProgressMonitor)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | NotifyCanceled | Notifies that the task has actually been canceled. If this is the first time NotifyCanceled has been called, sets IsCanceled to true and fires the Canceled event. Otherwise does nothing. (inherited from CancelableProgressMonitor)
Family method | NotifyRecursiveSubTaskChanged | Called when a subtask changes in any way, including one of its own subtasks changing. (inherited from ObservableProgressMonitor)
Family method | OnBeginSubTask | Called when the active sub-task BeginSubTask performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnBeginTask | Overridden. Called after BeginTask performs its updates.
Family method | OnCancel | Overridden. Called when Cancel performs its updates.
Family method | OnChange | Overridden. Called when a state change occurs.
Family method | OnDone | Overridden. Called when Done performs its updates.
Family method | OnEndSubTask | Called when EndSubTask performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnRecursiveSubTaskChange | Called when NotifyRecursiveSubTaskChanged performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnSetStatus | Called when SetStatus performs its updates. (inherited from ObservableProgressMonitor)
Family method | OnSubProgressMonitorCreated | Called when a new progress monitor is created. (inherited from ObservableProgressMonitor)
Family method | OnWorked | Overridden. Called when Worked performs its updates.
Top

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnBeginTask Method

ObservableProgressMonitor.SubProgressMonitor.OnBeginTask Method
See Also Example
[image]

Called after BeginTask performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnBeginTask( _
ByVal taskName As String, _
ByVal totalWorkUnits As Double _
)
C#
protected override void OnBeginTask(
string taskName,
double totalWorkUnits
)
C++
protected:
virtual void OnBeginTask(
String taskName,
double totalWorkUnits
) override
J#
protected override void OnBeginTask(
string taskName,
double totalWorkUnits
)
JScript
protected override function OnBeginTask(
taskName : String,
totalWorkUnits : double
)

Parameters

taskName
The task name
totalWorkUnits
The total number of work units

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnCancel Method

ObservableProgressMonitor.SubProgressMonitor.OnCancel Method
[image]

Called when Cancel performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCancel()
C#
protected override void OnCancel()
C++
protected:
virtual void OnCancel() override
J#
protected override void OnCancel()
JScript
protected override function OnCancel()

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnChange Method

ObservableProgressMonitor.SubProgressMonitor.OnChange Method
[image]

Called when a state change occurs.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnChange()
C#
protected override void OnChange()
C++
protected:
virtual void OnChange() override
J#
protected override void OnChange()
JScript
protected override function OnChange()

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnDone Method

ObservableProgressMonitor.SubProgressMonitor.OnDone Method
[image]

Called when Done performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDone()
C#
protected override void OnDone()
C++
protected:
virtual void OnDone() override
J#
protected override void OnDone()
JScript
protected override function OnDone()

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


OnWorked Method

ObservableProgressMonitor.SubProgressMonitor.OnWorked Method
[image]

Called when Worked performs its updates.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnWorked( _
ByVal workUnits As Double _
)
C#
protected override void OnWorked(
double workUnits
)
C++
protected:
virtual void OnWorked(
double workUnits
) override
J#
protected override void OnWorked(
double workUnits
)
JScript
protected override function OnWorked(
workUnits : double
)

See Also

ObservableProgressMonitor.SubProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


ProgressMonitorTaskCookie Structure

ProgressMonitorTaskCookie Structure
See Also Example Members
[image]

A progress monitor task cookie represents a task in progress. When it is disposed, the corresponding IProgressMonitor's Done method is called.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure ProgressMonitorTaskCookie
Implements IDisposable
C#
public struct ProgressMonitorTaskCookie : IDisposable
C++
value class ProgressMonitorTaskCookie : IDisposable
J#
public final class ProgressMonitorTaskCookie extends ValueType implements IDisposable
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.ProgressMonitorTaskCookie

See Also

ProgressMonitorTaskCookie Members
Gallio.Runtime.ProgressMonitoring Namespace


ProgressMonitorTaskCookie Members

ProgressMonitorTaskCookie Members
See Also Example Constructors Methods
[image]

A progress monitor task cookie represents a task in progress. When it is disposed, the corresponding IProgressMonitor's Done method is called.

The following tables list the members exposed by ProgressMonitorTaskCookie.

Public Constructors

 | Name | Description
Public method | ProgressMonitorTaskCookie | Creates an object representing a task in progress.
Top

Public Methods

 | Name | Description
Public method | Dispose | Marks the task as finished. Equivalent to calling Done on the associated IProgressMonitor. This method is provded as a convenience for use with the C# using statement.
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

ProgressMonitorTaskCookie Structure
Gallio.Runtime.ProgressMonitoring Namespace


ProgressMonitorTaskCookie Constructor

ProgressMonitorTaskCookie Constructor
[image]

Creates an object representing a task in progress.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal progressMonitor As IProgressMonitor _
)
C#
public ProgressMonitorTaskCookie(
IProgressMonitor progressMonitor
)
C++
public:
ProgressMonitorTaskCookie(
IProgressMonitor progressMonitor
) sealed
J#
public ProgressMonitorTaskCookie(
IProgressMonitor progressMonitor
)
JScript
public function ProgressMonitorTaskCookie(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null

See Also

ProgressMonitorTaskCookie Structure
Gallio.Runtime.ProgressMonitoring Namespace


Methods

ProgressMonitorTaskCookie Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Marks the task as finished. Equivalent to calling Done on the associated IProgressMonitor. This method is provded as a convenience for use with the C# using statement.
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

ProgressMonitorTaskCookie Structure
Gallio.Runtime.ProgressMonitoring Namespace


Dispose Method

ProgressMonitorTaskCookie.Dispose Method
[image]

Marks the task as finished.

Equivalent to calling Done on the associated IProgressMonitor. This method is provded as a convenience for use with the C# using statement.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

ProgressMonitorTaskCookie Structure
Gallio.Runtime.ProgressMonitoring Namespace


RemoteProgressMonitor Class

RemoteProgressMonitor Class
See Also Example Members
[image]

A remote progress monitor is a serializable wrapper for another progress monitor. The wrapper can be passed to another AppDomain and communication occurs over .Net remoting. This class cannot be inherited.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class RemoteProgressMonitor
Inherits CancelableProgressMonitor
Implements IDeserializationCallback
C#
[SerializableAttribute]
public sealed class RemoteProgressMonitor : CancelableProgressMonitor, IDeserializationCallback
C++
[SerializableAttribute]
ref class RemoteProgressMonitor sealed : CancelableProgressMonitor, IDeserializationCallback
J#
/** @attribute SerializableAttribute() */
public final class RemoteProgressMonitor extends CancelableProgressMonitor implements IDeserializationCallback
JScript
public
SerializableAttribute
final class RemoteProgressMonitor extends CancelableProgressMonitor, IDeserializationCallback

Remarks

The implementation is defined so as to guard against latency and failures in the remoting channel.

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.CancelableProgressMonitor
Gallio.Runtime.ProgressMonitoring.RemoteProgressMonitor

See Also

RemoteProgressMonitor Members
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


RemoteProgressMonitor Members

RemoteProgressMonitor Members
See Also Example Constructors Properties Methods Events
[image]

A remote progress monitor is a serializable wrapper for another progress monitor. The wrapper can be passed to another AppDomain and communication occurs over .Net remoting. This class cannot be inherited.

The following tables list the members exposed by RemoteProgressMonitor.

Public Constructors

 | Name | Description
Public method | RemoteProgressMonitor | Creates a wrapper for the specified progress monitor.
Top

Public Properties

 | Name | Description
Public property | IsCanceled | Returns true if the operation has been canceled. Clients should poll this value periodically or listen for the Canceled event to ensure the operation is canceled in a timely fashion. (inherited from CancelableProgressMonitor)
Top

Public Methods

Name | Description
Public method | BeginTask | Overridden. Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done. (inherited from CancelableProgressMonitor)
Public method CreateSubProgressMonitor Overridden.

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Dispose | Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Public method | Done | Overridden. Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Overridden. Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled. (inherited from CancelableProgressMonitor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Overridden. Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

Public Events

 | Name | Description
Public event | Canceled | Adds or removes an event handler to be called when the operation is canceled. If the operation has already been canceled, then the event handler will be called immediately. (inherited from CancelableProgressMonitor)
Top

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


RemoteProgressMonitor Constructor

RemoteProgressMonitor Constructor
[image]

Creates a wrapper for the specified progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal progressMonitor As IProgressMonitor _
)
C#
public RemoteProgressMonitor(
IProgressMonitor progressMonitor
)
C++
public:
RemoteProgressMonitor(
IProgressMonitor progressMonitor
) sealed
J#
public RemoteProgressMonitor(
IProgressMonitor progressMonitor
)
JScript
public function RemoteProgressMonitor(
progressMonitor : IProgressMonitor
)

Parameters

progressMonitor
The progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if progressMonitor is null

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

RemoteProgressMonitor Methods
[image]

Public Methods

Name | Description
Public method | BeginTask | Overridden. Notifies that the main task is starting. Must be called at most once on the progress monitor.
Public method | Cancel | Notifies that the operation is to be canceled. The method always causes the IsCanceled flag to be set, even if the operation is already done. (inherited from CancelableProgressMonitor)
Public method CreateSubProgressMonitor Overridden.

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Public method | Dispose | Disposes the progress monitor, including cleaning up an marking as Done the current task, if any. (inherited from CancelableProgressMonitor)
Public method | Done | Overridden. Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SetStatus | Overridden. Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.
Public method | ThrowIfCanceled | Throws an OperationCanceledException if the operation has been canceled. (inherited from CancelableProgressMonitor)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Worked | Overridden. Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.
Top

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace
IProgressMonitor


BeginTask Method

RemoteProgressMonitor.BeginTask Method
[image]

Notifies that the main task is starting. Must be called at most once on the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BeginTask( _
ByVal taskName As String, _
ByVal totalWorkUnits As Double _
) As ProgressMonitorTaskCookie _
Implements IProgressMonitor.BeginTask
C#
public override ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
C++
public:
virtual ProgressMonitorTaskCookie BeginTask(
String taskName,
double totalWorkUnits
) override
J#
public override ProgressMonitorTaskCookie BeginTask(
string taskName,
double totalWorkUnits
)
JScript
public override function BeginTask(
taskName : String,
totalWorkUnits : double
) : ProgressMonitorTaskCookie

Parameters

taskName
The name of the task being monitored
totalWorkUnits
The total number of work units to perform. Must be greater than 0, or NaN if an indeterminate amount of work is to be performed.

Return Value

An object that calls Done when disposed

Implements

IProgressMonitor.BeginTask

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


CreateSubProgressMonitor Method

RemoteProgressMonitor.CreateSubProgressMonitor Method
[image]

Creates a sub-progress monitor that represents a given number of work-units as a sub-task of this progress monitor.

Using sub-tasks allows multiple tasks to be composed into longer sequences that each contribute a predetermined portion of the total work.

As the sub-task performs work its parent task is notified of progress in proportion to the number of work units that it represents. Likewise the parent is notified of cancelation if the child is canceled and vice-versa.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateSubProgressMonitor( _
ByVal parentWorkUnits As Double _
) As IProgressMonitor _
Implements IProgressMonitor.CreateSubProgressMonitor
C#
public override IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
C++
public:
virtual IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
) override
J#
public override IProgressMonitor CreateSubProgressMonitor(
double parentWorkUnits
)
JScript
public override function CreateSubProgressMonitor(
parentWorkUnits : double
) : IProgressMonitor

Parameters

parentWorkUnits
The total number of work units of the parent task that are to be represented by the sub-task. When the sub-task completes, this much work will have been performed on the parent. Must be a finite value greater than or equal to 0.

Implements

IProgressMonitor.CreateSubProgressMonitor

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Done Method

RemoteProgressMonitor.Done Method
[image]

Notifies that the work is done, either the main task is completed was cancelled by the user. If already done, the method has no effect.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Done() _
Implements IProgressMonitor.Done
C#
public override void Done()
C++
public:
virtual void Done() override
J#
public override void Done()
JScript
public override function Done()

Implements

IProgressMonitor.Done

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


SetStatus Method

RemoteProgressMonitor.SetStatus Method
[image]

Sets detailed status information for the current task or subtask. A status message is an optional fine-grained description of the current activity being performed. For instance, a status message might specify the name of a file being copied as part of a task that copies many files.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetStatus( _
ByVal status As String _
) _
Implements IProgressMonitor.SetStatus
C#
public override void SetStatus(
string status
)
C++
public:
virtual void SetStatus(
String status
) override
J#
public override void SetStatus(
string status
)
JScript
public override function SetStatus(
status : String
)

Parameters

status
The name of the current subtask

Implements

IProgressMonitor.SetStatus

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


Worked Method

RemoteProgressMonitor.Worked Method
[image]

Notifies that a given number of work units of the main task have been completed. Note that this amount represents an installment, as opposed to a cumulative amount of work done to date. If the sum of this value and the currently completed work units exceeds the total work units to be performed, the excess portion is discarded.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Worked( _
ByVal workUnits As Double _
) _
Implements IProgressMonitor.Worked
C#
public override void Worked(
double workUnits
)
C++
public:
virtual void Worked(
double workUnits
) override
J#
public override void Worked(
double workUnits
)
JScript
public override function Worked(
workUnits : double
)

Parameters

workUnits
The number of work units completed so far. Must be a finite value greater than or equal to 0.

Implements

IProgressMonitor.Worked

See Also

RemoteProgressMonitor Class
Gallio.Runtime.ProgressMonitoring Namespace


RichConsoleProgressMonitorPresenter Class

RichConsoleProgressMonitorPresenter Class
See Also Example Members
[image]

A console progress monitor presenter displays a simple tally of the amount of work to be done on the main task as a bar chart. The progress monitor responds to cancelation events at the console.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RichConsoleProgressMonitorPresenter
Inherits BaseProgressMonitorPresenter
C#
public class RichConsoleProgressMonitorPresenter : BaseProgressMonitorPresenter
C++
ref class RichConsoleProgressMonitorPresenter : BaseProgressMonitorPresenter
J#
public class RichConsoleProgressMonitorPresenter extends BaseProgressMonitorPresenter
JScript
public class RichConsoleProgressMonitorPresenter extends BaseProgressMonitorPresenter

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.RichConsoleProgressMonitorPresenter

See Also

RichConsoleProgressMonitorPresenter Members
Gallio.Runtime.ProgressMonitoring Namespace


RichConsoleProgressMonitorPresenter Members

RichConsoleProgressMonitorPresenter Members
See Also Example Constructors Properties Methods
[image]

A console progress monitor presenter displays a simple tally of the amount of work to be done on the main task as a bar chart. The progress monitor responds to cancelation events at the console.

The following tables list the members exposed by RichConsoleProgressMonitorPresenter.

Public Constructors

 | Name | Description
Public method | RichConsoleProgressMonitorPresenter | Creates a console presenter for a progress monitor.
Top

Protected Properties

 | Name | Description
Family property | ProgressMonitor | Gets the attached progress monitor. (inherited from BaseProgressMonitorPresenter)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor. (inherited from BaseProgressMonitorPresenter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the presenter after a progress monitor has been attached.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RichConsoleProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


RichConsoleProgressMonitorPresenter Constructor

RichConsoleProgressMonitorPresenter Constructor
[image]

Creates a console presenter for a progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal console As IRichConsole _
)
C#
public RichConsoleProgressMonitorPresenter(
IRichConsole console
)
C++
public:
RichConsoleProgressMonitorPresenter(
IRichConsole console
) sealed
J#
public RichConsoleProgressMonitorPresenter(
IRichConsole console
)
JScript
public function RichConsoleProgressMonitorPresenter(
console : IRichConsole
)

Parameters

console
The console

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if console is null

See Also

RichConsoleProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

RichConsoleProgressMonitorPresenter Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Present | Presents an observable progress monitor. (inherited from BaseProgressMonitorPresenter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Overridden. Initializes the presenter after a progress monitor has been attached.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RichConsoleProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


Initialize Method

RichConsoleProgressMonitorPresenter.Initialize Method
[image]

Initializes the presenter after a progress monitor has been attached.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Initialize()
C#
protected override void Initialize()
C++
protected:
virtual void Initialize() override
J#
protected override void Initialize()
JScript
protected override function Initialize()

See Also

RichConsoleProgressMonitorPresenter Class
Gallio.Runtime.ProgressMonitoring Namespace


RichConsoleProgressMonitorProvider Class

RichConsoleProgressMonitorProvider Class
See Also Example Members
[image]

A console progress monitor displays a simple tally of the amount of work to be done on the main task as a bar chart. The progress monitor responds to cancelation events at the console.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class RichConsoleProgressMonitorProvider
Inherits BaseProgressMonitorProvider
C#
public class RichConsoleProgressMonitorProvider : BaseProgressMonitorProvider
C++
ref class RichConsoleProgressMonitorProvider : BaseProgressMonitorProvider
J#
public class RichConsoleProgressMonitorProvider extends BaseProgressMonitorProvider
JScript
public class RichConsoleProgressMonitorProvider extends BaseProgressMonitorProvider

Inheritance Hierarchy

System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.RichConsoleProgressMonitorProvider

See Also

RichConsoleProgressMonitorProvider Members
Gallio.Runtime.ProgressMonitoring Namespace


RichConsoleProgressMonitorProvider Members

RichConsoleProgressMonitorProvider Members
See Also Example Constructors Methods
[image]

A console progress monitor displays a simple tally of the amount of work to be done on the main task as a bar chart. The progress monitor responds to cancelation events at the console.

The following tables list the members exposed by RichConsoleProgressMonitorProvider.

Public Constructors

 | Name | Description
Public method | RichConsoleProgressMonitorProvider | Creates a rich console progress monitor provider.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled. (inherited from BaseProgressMonitorProvider)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetPresenter | Overridden. Gets a presenter for the progress monitor.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RichConsoleProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


RichConsoleProgressMonitorProvider Constructor

RichConsoleProgressMonitorProvider Constructor
[image]

Creates a rich console progress monitor provider.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal console As IRichConsole _
)
C#
public RichConsoleProgressMonitorProvider(
IRichConsole console
)
C++
public:
RichConsoleProgressMonitorProvider(
IRichConsole console
) sealed
J#
public RichConsoleProgressMonitorProvider(
IRichConsole console
)
JScript
public function RichConsoleProgressMonitorProvider(
console : IRichConsole
)

Parameters

console
The console to which messages should be written

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if console is null

See Also

RichConsoleProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


Methods

RichConsoleProgressMonitorProvider Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Run | Runs a task with a progress monitor. Throws OperationCanceledException if the task is canceled. (inherited from BaseProgressMonitorProvider)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetPresenter | Overridden. Gets a presenter for the progress monitor.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

RichConsoleProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


GetPresenter Method

RichConsoleProgressMonitorProvider.GetPresenter Method
[image]

Gets a presenter for the progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetPresenter() As IProgressMonitorPresenter
C#
protected override IProgressMonitorPresenter GetPresenter()
C++
protected:
virtual IProgressMonitorPresenter GetPresenter() override
J#
protected override IProgressMonitorPresenter GetPresenter()
JScript
protected override function GetPresenter() : IProgressMonitorPresenter

Return Value

The presenter

See Also

RichConsoleProgressMonitorProvider Class
Gallio.Runtime.ProgressMonitoring Namespace


SubProgressMonitorCreatedEventArgs Class

SubProgressMonitorCreatedEventArgs Class
See Also Example Members
[image]

Provides a reference to the newly created sub-progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class SubProgressMonitorCreatedEventArgs
Inherits EventArgs
C#
public class SubProgressMonitorCreatedEventArgs : EventArgs
C++
ref class SubProgressMonitorCreatedEventArgs : EventArgs
J#
public class SubProgressMonitorCreatedEventArgs extends EventArgs
JScript
public class SubProgressMonitorCreatedEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gallio.Runtime.ProgressMonitoring.SubProgressMonitorCreatedEventArgs

See Also

SubProgressMonitorCreatedEventArgs Members
Gallio.Runtime.ProgressMonitoring Namespace


SubProgressMonitorCreatedEventArgs Members

SubProgressMonitorCreatedEventArgs Members
See Also Example Constructors Properties Methods
[image]

Provides a reference to the newly created sub-progress monitor.

The following tables list the members exposed by SubProgressMonitorCreatedEventArgs.

Public Constructors

 | Name | Description
Public method | SubProgressMonitorCreatedEventArgs | Creates an event object.
Top

Public Properties

 | Name | Description
Public property | SubProgressMonitor | Gets the newly created sub-progress monitor.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SubProgressMonitorCreatedEventArgs Class
Gallio.Runtime.ProgressMonitoring Namespace


SubProgressMonitorCreatedEventArgs Constructor

SubProgressMonitorCreatedEventArgs Constructor
[image]

Creates an event object.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal subProgressMonitor As ObservableProgressMonitor _
)
C#
public SubProgressMonitorCreatedEventArgs(
ObservableProgressMonitor subProgressMonitor
)
C++
public:
SubProgressMonitorCreatedEventArgs(
ObservableProgressMonitor subProgressMonitor
) sealed
J#
public SubProgressMonitorCreatedEventArgs(
ObservableProgressMonitor subProgressMonitor
)
JScript
public function SubProgressMonitorCreatedEventArgs(
subProgressMonitor : ObservableProgressMonitor
)

Parameters

subProgressMonitor
The new sub-progress monitor

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if subProgressMonitor is null

See Also

SubProgressMonitorCreatedEventArgs Class
Gallio.Runtime.ProgressMonitoring Namespace


Properties

SubProgressMonitorCreatedEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | SubProgressMonitor | Gets the newly created sub-progress monitor.
Top

See Also

SubProgressMonitorCreatedEventArgs Class
Gallio.Runtime.ProgressMonitoring Namespace


SubProgressMonitor Property

SubProgressMonitorCreatedEventArgs.SubProgressMonitor Property
See Also Example
[image]

Gets the newly created sub-progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubProgressMonitor As ObservableProgressMonitor
C#
public ObservableProgressMonitor SubProgressMonitor { get; }
C++
public property ObservableProgressMonitor SubProgressMonitor sealed {
ObservableProgressMonitor get();
}
J#
/** property */
public ObservableProgressMonitor get_SubProgressMonitor();
JScript
public function get SubProgressMonitor() : ObservableProgressMonitor

See Also

SubProgressMonitorCreatedEventArgs Class
Gallio.Runtime.ProgressMonitoring Namespace


TaskWithProgress Delegate

TaskWithProgress Delegate
[image]

Represents a task to be executed with a progress monitor.

Namespace: Gallio.Runtime.ProgressMonitoring
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub TaskWithProgress( _
ByVal progressMonitor As IProgressMonitor _
)
C#
public delegate void TaskWithProgress(
IProgressMonitor progressMonitor
)
C++
public delegate void TaskWithProgress(
IProgressMonitor progressMonitor
)
J#
/** delegate */
public delegate void TaskWithProgress(
IProgressMonitor progressMonitor
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

progressMonitor
The progress monitor, never null

See Also

Gallio.Runtime.ProgressMonitoring Namespace


Gallio.Runtime.Remoting

Gallio.Runtime.Remoting Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | BaseChannel | Abstract base class for channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseClientChannel | Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BaseServerChannel | Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | BinaryIpcClientChannel | A client channel based on an IpcClientChannel that uses a BinaryClientFormatterSinkProvider.
Public class | BinaryIpcServerChannel | A server channel based on an IpcServerChannel that uses a BinaryServerFormatterSinkProvider.
Public class | BinaryTcpClientChannel | A client channel based on an TcpClientChannel that uses a BinaryClientFormatterSinkProvider.
Public class | BinaryTcpServerChannel | A server channel based on an TcpServerChannel that uses a BinaryServerFormatterSinkProvider.
Public class | LongLivedMarshalByRefObject | Base class for long-lived marshal by ref objects. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Interfaces

 | Interface | Description
Public interface | IClientChannel | A client channel manages the client side of a remoting channel.
Public interface | IServerChannel | A server channel manages the server side of a remoting channel.


BaseChannel Class

BaseChannel Class
See Also Example Members
[image]

Abstract base class for channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseChannel
Implements IDisposable
C#
public abstract class BaseChannel : IDisposable
C++
ref class BaseChannel abstract : IDisposable
J#
public class BaseChannel implements IDisposable
JScript
public class BaseChannel extends IDisposable

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseClientChannel
Gallio.Runtime.Remoting.BaseServerChannel

See Also

BaseChannel Members
Gallio.Runtime.Remoting Namespace


BaseChannel Members

BaseChannel Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseChannel.

Protected Constructors

 | Name | Description
Family method | BaseChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel.
Public property | ChannelUri | Gets the root Uri associated with the channel.
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


BaseChannel Constructor

BaseChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal channel As IChannel, _
ByVal channelUri As Uri _
)
C#
protected BaseChannel(
IChannel channel,
Uri channelUri
)
C++
protected:
BaseChannel(
IChannel channel,
Uri channelUri
) sealed
J#
protected BaseChannel(
IChannel channel,
Uri channelUri
)
JScript
protected function BaseChannel(
channel : IChannel,
channelUri : Uri
)

Parameters

channel
The .Net remoting channel
channelUri
The root Uri associated with the channel

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if channel or channelUri is null

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


Properties

BaseChannel Properties
[image]

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel.
Public property | ChannelUri | Gets the root Uri associated with the channel.
Top

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


Channel Property

BaseChannel.Channel Property
[image]

Gets the associated .Net remoting channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Channel As IChannel
C#
public IChannel Channel { get; }
C++
public property IChannel Channel sealed {
IChannel get();
}
J#
/** property */
public IChannel get_Channel();
JScript
public function get Channel() : IChannel

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


ChannelUri Property

BaseChannel.ChannelUri Property
[image]

Gets the root Uri associated with the channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChannelUri As Uri
C#
public Uri ChannelUri { get; }
C++
public property Uri ChannelUri sealed {
Uri get();
}
J#
/** property */
public Uri get_ChannelUri();
JScript
public function get ChannelUri() : Uri

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


Methods

BaseChannel Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


Dispose Method

BaseChannel.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Dispose (Boolean) |

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


Dispose Method ()

BaseChannel.Dispose Method ()
See Also Example
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace
BaseChannel.Dispose Overload List


Dispose Method (Boolean)

BaseChannel.Dispose Method (Boolean)
See Also Example
[image]

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected virtual void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
)
J#
protected virtual void Dispose(
bool disposing
)
JScript
protected virtual function Dispose(
disposing : bool
)

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace
BaseChannel.Dispose Overload List


GetServiceUri Method

BaseChannel.GetServiceUri Method
[image]

Gets the Uri of a service with the given name that can be accessed using this channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetServiceUri( _
ByVal serviceName As String _
) As String
C#
public string GetServiceUri(
string serviceName
)
C++
public:
String GetServiceUri(
String serviceName
) sealed
J#
public string GetServiceUri(
string serviceName
)
JScript
public function GetServiceUri(
serviceName : String
) : String

Parameters

serviceName
The service name

Return Value

The service uri

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if serviceName is null

See Also

BaseChannel Class
Gallio.Runtime.Remoting Namespace


BaseClientChannel Class

BaseClientChannel Class
See Also Example Members
[image]

Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseClientChannel
Inherits BaseChannel
Implements IClientChannel
C#
public abstract class BaseClientChannel : BaseChannel, IClientChannel
C++
ref class BaseClientChannel abstract : BaseChannel, IClientChannel
J#
public class BaseClientChannel extends BaseChannel implements IClientChannel
JScript
public class BaseClientChannel extends BaseChannel, IClientChannel

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseClientChannel
Gallio.Runtime.Remoting.BinaryIpcClientChannel
Gallio.Runtime.Remoting.BinaryTcpClientChannel

See Also

BaseClientChannel Members
Gallio.Runtime.Remoting Namespace


BaseClientChannel Members

BaseClientChannel Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseClientChannel.

Protected Constructors

 | Name | Description
Family method | BaseClientChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel. (inherited from BaseChannel)
Public property | ChannelUri | Gets the root Uri associated with the channel. (inherited from BaseChannel)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetService | Gets a well-known remote service with the specified name.
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseClientChannel Class
Gallio.Runtime.Remoting Namespace


BaseClientChannel Constructor

BaseClientChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal channel As IChannel, _
ByVal channelUri As Uri _
)
C#
protected BaseClientChannel(
IChannel channel,
Uri channelUri
)
C++
protected:
BaseClientChannel(
IChannel channel,
Uri channelUri
) sealed
J#
protected BaseClientChannel(
IChannel channel,
Uri channelUri
)
JScript
protected function BaseClientChannel(
channel : IChannel,
channelUri : Uri
)

Parameters

channel
The .Net remoting channel
channelUri
The root Uri associated with the channel

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if channel or channelUri is null

See Also

BaseClientChannel Class
Gallio.Runtime.Remoting Namespace


Methods

BaseClientChannel Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetService | Gets a well-known remote service with the specified name.
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseClientChannel Class
Gallio.Runtime.Remoting Namespace


GetService Method

BaseClientChannel.GetService Method
[image]

Gets a well-known remote service with the specified name.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetService( _
ByVal serviceType As Type, _
ByVal serviceName As String _
) As Object _
Implements IClientChannel.GetService
C#
public object GetService(
Type serviceType,
string serviceName
)
C++
public:
Object GetService(
Type serviceType,
String serviceName
) sealed
J#
public object GetService(
Type serviceType,
string serviceName
)
JScript
public function GetService(
serviceType : Type,
serviceName : String
) : Object

Parameters

serviceType
The type of the service
serviceName
The name of the service

Return Value

The component or a proxy that provides the service

Implements

IClientChannel.GetService

See Also

BaseClientChannel Class
Gallio.Runtime.Remoting Namespace


BaseServerChannel Class

BaseServerChannel Class
See Also Example Members
[image]

Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class BaseServerChannel
Inherits BaseChannel
Implements IServerChannel
C#
public abstract class BaseServerChannel : BaseChannel, IServerChannel
C++
ref class BaseServerChannel abstract : BaseChannel, IServerChannel
J#
public class BaseServerChannel extends BaseChannel implements IServerChannel
JScript
public class BaseServerChannel extends BaseChannel, IServerChannel

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseServerChannel
Gallio.Runtime.Remoting.BinaryIpcServerChannel
Gallio.Runtime.Remoting.BinaryTcpServerChannel

See Also

BaseServerChannel Members
Gallio.Runtime.Remoting Namespace


BaseServerChannel Members

BaseServerChannel Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by BaseServerChannel.

Protected Constructors

 | Name | Description
Family method | BaseServerChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel. (inherited from BaseChannel)
Public property | ChannelUri | Gets the root Uri associated with the channel. (inherited from BaseChannel)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RegisterService | Registers a well-known service with the specified name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseServerChannel Class
Gallio.Runtime.Remoting Namespace


BaseServerChannel Constructor

BaseServerChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal channel As IChannel, _
ByVal channelUri As Uri _
)
C#
protected BaseServerChannel(
IChannel channel,
Uri channelUri
)
C++
protected:
BaseServerChannel(
IChannel channel,
Uri channelUri
) sealed
J#
protected BaseServerChannel(
IChannel channel,
Uri channelUri
)
JScript
protected function BaseServerChannel(
channel : IChannel,
channelUri : Uri
)

Parameters

channel
The .Net remoting channel
channelUri
The root Uri associated with the channel

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if channel or channelUri is null

See Also

BaseServerChannel Class
Gallio.Runtime.Remoting Namespace


Methods

BaseServerChannel Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RegisterService | Registers a well-known service with the specified name.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BaseServerChannel Class
Gallio.Runtime.Remoting Namespace


Dispose Method

BaseServerChannel.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Family method | Dispose (Boolean) | Overridden.

See Also

BaseServerChannel Class
Gallio.Runtime.Remoting Namespace


Dispose Method (Boolean)

BaseServerChannel.Dispose Method (Boolean)
See Also Example
[image]

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

See Also

BaseServerChannel Class
Gallio.Runtime.Remoting Namespace
BaseServerChannel.Dispose Overload List


RegisterService Method

BaseServerChannel.RegisterService Method
[image]

Registers a well-known service with the specified name.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterService( _
ByVal serviceName As String, _
ByVal component As MarshalByRefObject _
) _
Implements IServerChannel.RegisterService
C#
public void RegisterService(
string serviceName,
MarshalByRefObject component
)
C++
public:
void RegisterService(
String serviceName,
MarshalByRefObject component
) sealed
J#
public void RegisterService(
string serviceName,
MarshalByRefObject component
)
JScript
public function RegisterService(
serviceName : String,
component : MarshalByRefObject
)

Parameters

serviceName
The name of the service
component
The component that provides the service

Implements

IServerChannel.RegisterService

See Also

BaseServerChannel Class
Gallio.Runtime.Remoting Namespace


BinaryIpcClientChannel Class

BinaryIpcClientChannel Class
See Also Example Members
[image]

A client channel based on an IpcClientChannel that uses a BinaryClientFormatterSinkProvider.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BinaryIpcClientChannel
Inherits BaseClientChannel
C#
public class BinaryIpcClientChannel : BaseClientChannel
C++
ref class BinaryIpcClientChannel : BaseClientChannel
J#
public class BinaryIpcClientChannel extends BaseClientChannel
JScript
public class BinaryIpcClientChannel extends BaseClientChannel

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseClientChannel
Gallio.Runtime.Remoting.BinaryIpcClientChannel

See Also

BinaryIpcClientChannel Members
Gallio.Runtime.Remoting Namespace


BinaryIpcClientChannel Members

BinaryIpcClientChannel Members
See Also Example Constructors Properties Methods
[image]

A client channel based on an IpcClientChannel that uses a BinaryClientFormatterSinkProvider.

The following tables list the members exposed by BinaryIpcClientChannel.

Public Constructors

 | Name | Description
Public method | BinaryIpcClientChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel. (inherited from BaseChannel)
Public property | ChannelUri | Gets the root Uri associated with the channel. (inherited from BaseChannel)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetService | Gets a well-known remote service with the specified name. (inherited from BaseClientChannel)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BinaryIpcClientChannel Class
Gallio.Runtime.Remoting Namespace


BinaryIpcClientChannel Constructor

BinaryIpcClientChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal portName As String _
)
C#
public BinaryIpcClientChannel(
string portName
)
C++
public:
BinaryIpcClientChannel(
String portName
) sealed
J#
public BinaryIpcClientChannel(
string portName
)
JScript
public function BinaryIpcClientChannel(
portName : String
)

Parameters

portName
The ipc port name to connect to

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if portName is null

See Also

BinaryIpcClientChannel Class
Gallio.Runtime.Remoting Namespace


BinaryIpcServerChannel Class

BinaryIpcServerChannel Class
See Also Example Members
[image]

A server channel based on an IpcServerChannel that uses a BinaryServerFormatterSinkProvider.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BinaryIpcServerChannel
Inherits BaseServerChannel
C#
public class BinaryIpcServerChannel : BaseServerChannel
C++
ref class BinaryIpcServerChannel : BaseServerChannel
J#
public class BinaryIpcServerChannel extends BaseServerChannel
JScript
public class BinaryIpcServerChannel extends BaseServerChannel

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseServerChannel
Gallio.Runtime.Remoting.BinaryIpcServerChannel

See Also

BinaryIpcServerChannel Members
Gallio.Runtime.Remoting Namespace


BinaryIpcServerChannel Members

BinaryIpcServerChannel Members
See Also Example Constructors Properties Methods
[image]

A server channel based on an IpcServerChannel that uses a BinaryServerFormatterSinkProvider.

The following tables list the members exposed by BinaryIpcServerChannel.

Public Constructors

 | Name | Description
Public method | BinaryIpcServerChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel. (inherited from BaseChannel)
Public property | ChannelUri | Gets the root Uri associated with the channel. (inherited from BaseChannel)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseServerChannel)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RegisterService | Registers a well-known service with the specified name. (inherited from BaseServerChannel)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseServerChannel)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BinaryIpcServerChannel Class
Gallio.Runtime.Remoting Namespace


BinaryIpcServerChannel Constructor

BinaryIpcServerChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal portName As String _
)
C#
public BinaryIpcServerChannel(
string portName
)
C++
public:
BinaryIpcServerChannel(
String portName
) sealed
J#
public BinaryIpcServerChannel(
string portName
)
JScript
public function BinaryIpcServerChannel(
portName : String
)

Parameters

portName
The ipc port name to register

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if portName is null

See Also

BinaryIpcServerChannel Class
Gallio.Runtime.Remoting Namespace


BinaryTcpClientChannel Class

BinaryTcpClientChannel Class
See Also Example Members
[image]

A client channel based on an TcpClientChannel that uses a BinaryClientFormatterSinkProvider.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BinaryTcpClientChannel
Inherits BaseClientChannel
C#
public class BinaryTcpClientChannel : BaseClientChannel
C++
ref class BinaryTcpClientChannel : BaseClientChannel
J#
public class BinaryTcpClientChannel extends BaseClientChannel
JScript
public class BinaryTcpClientChannel extends BaseClientChannel

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseClientChannel
Gallio.Runtime.Remoting.BinaryTcpClientChannel

See Also

BinaryTcpClientChannel Members
Gallio.Runtime.Remoting Namespace


BinaryTcpClientChannel Members

BinaryTcpClientChannel Members
See Also Example Constructors Properties Methods
[image]

A client channel based on an TcpClientChannel that uses a BinaryClientFormatterSinkProvider.

The following tables list the members exposed by BinaryTcpClientChannel.

Public Constructors

 | Name | Description
Public method | BinaryTcpClientChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel. (inherited from BaseChannel)
Public property | ChannelUri | Gets the root Uri associated with the channel. (inherited from BaseChannel)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetService | Gets a well-known remote service with the specified name. (inherited from BaseClientChannel)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseChannel)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BinaryTcpClientChannel Class
Gallio.Runtime.Remoting Namespace


BinaryTcpClientChannel Constructor

BinaryTcpClientChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostName As String, _
ByVal portNumber As Integer, _
ByVal requestTimeout As Nullable(Of TimeSpan) _
)
C#
public BinaryTcpClientChannel(
string hostName,
int portNumber,
Nullable<TimeSpan> requestTimeout
)
C++
public:
BinaryTcpClientChannel(
String hostName,
int portNumber,
Nullable<TimeSpan> requestTimeout
) sealed
J#
public BinaryTcpClientChannel(
string hostName,
int portNumber,
Nullable<TimeSpan> requestTimeout
)
JScript
public function BinaryTcpClientChannel(
hostName : String,
portNumber : int,
requestTimeout : Nullable<TimeSpan>
)

Parameters

hostName
The host name to connect to
portNumber
The port number to connect to
requestTimeout
The request timeout or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostName is null

See Also

BinaryTcpClientChannel Class
Gallio.Runtime.Remoting Namespace


BinaryTcpServerChannel Class

BinaryTcpServerChannel Class
See Also Example Members
[image]

A server channel based on an TcpServerChannel that uses a BinaryServerFormatterSinkProvider.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class BinaryTcpServerChannel
Inherits BaseServerChannel
C#
public class BinaryTcpServerChannel : BaseServerChannel
C++
ref class BinaryTcpServerChannel : BaseServerChannel
J#
public class BinaryTcpServerChannel extends BaseServerChannel
JScript
public class BinaryTcpServerChannel extends BaseServerChannel

Inheritance Hierarchy

System.Object
Gallio.Runtime.Remoting.BaseChannel
Gallio.Runtime.Remoting.BaseServerChannel
Gallio.Runtime.Remoting.BinaryTcpServerChannel

See Also

BinaryTcpServerChannel Members
Gallio.Runtime.Remoting Namespace


BinaryTcpServerChannel Members

BinaryTcpServerChannel Members
See Also Example Constructors Properties Methods
[image]

A server channel based on an TcpServerChannel that uses a BinaryServerFormatterSinkProvider.

The following tables list the members exposed by BinaryTcpServerChannel.

Public Constructors

 | Name | Description
Public method | BinaryTcpServerChannel | Creates a channel.
Top

Public Properties

 | Name | Description
Public property | Channel | Gets the associated .Net remoting channel. (inherited from BaseChannel)
Public property | ChannelUri | Gets the root Uri associated with the channel. (inherited from BaseChannel)
Top

Public Methods

 | Name | Description
Public method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseServerChannel)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetServiceUri | Gets the Uri of a service with the given name that can be accessed using this channel. (inherited from BaseChannel)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RegisterService | Registers a well-known service with the specified name. (inherited from BaseServerChannel)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (inherited from BaseServerChannel)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BinaryTcpServerChannel Class
Gallio.Runtime.Remoting Namespace


BinaryTcpServerChannel Constructor

BinaryTcpServerChannel Constructor
[image]

Creates a channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hostName As String, _
ByVal portNumber As Integer _
)
C#
public BinaryTcpServerChannel(
string hostName,
int portNumber
)
C++
public:
BinaryTcpServerChannel(
String hostName,
int portNumber
) sealed
J#
public BinaryTcpServerChannel(
string hostName,
int portNumber
)
JScript
public function BinaryTcpServerChannel(
hostName : String,
portNumber : int
)

Parameters

hostName
The remotely accessed hostname
portNumber
The port number

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if hostName is null

See Also

BinaryTcpServerChannel Class
Gallio.Runtime.Remoting Namespace


IClientChannel Interface

IClientChannel Interface
See Also Example Members
[image]

A client channel manages the client side of a remoting channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IClientChannel
Implements IDisposable
C#
public interface IClientChannel : IDisposable
C++
interface class IClientChannel : IDisposable
J#
public interface IClientChannel implements IDisposable
JScript
public interface IClientChannel extends IDisposable

Types that implement IClientChannel

Type | Description
Gallio.Runtime.Remoting.BaseClientChannel | Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IClientChannel Members
Gallio.Runtime.Remoting Namespace
IServerChannel


IClientChannel Members

IClientChannel Members
See Also Example Methods
[image]

A client channel manages the client side of a remoting channel.

The following tables list the members exposed by IClientChannel.

Public Methods

 | Name | Description
Public method | GetService | Gets a well-known remote service with the specified name.
Top

See Also

IClientChannel Interface
Gallio.Runtime.Remoting Namespace
IServerChannel


Methods

IClientChannel Methods
[image]

Public Methods

 | Name | Description
Public method | GetService | Gets a well-known remote service with the specified name.
Top

See Also

IClientChannel Interface
Gallio.Runtime.Remoting Namespace
IServerChannel


GetService Method

IClientChannel.GetService Method
[image]

Gets a well-known remote service with the specified name.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function GetService( _
ByVal serviceType As Type, _
ByVal serviceName As String _
) As Object
C#
object GetService(
Type serviceType,
string serviceName
)
C++
Object GetService(
Type serviceType,
String serviceName
) abstract
J#
object GetService(
Type serviceType,
string serviceName
)
JScript
function GetService(
serviceType : Type,
serviceName : String
) : Object

Parameters

serviceType
The type of the service
serviceName
The name of the service

Return Value

The component or a proxy that provides the service

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if serviceType or serviceName is null

See Also

IClientChannel Interface
Gallio.Runtime.Remoting Namespace


IServerChannel Interface

IServerChannel Interface
See Also Example Members
[image]

A server channel manages the server side of a remoting channel.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IServerChannel
Implements IDisposable
C#
public interface IServerChannel : IDisposable
C++
interface class IServerChannel : IDisposable
J#
public interface IServerChannel implements IDisposable
JScript
public interface IServerChannel extends IDisposable

Types that implement IServerChannel

Type | Description
Gallio.Runtime.Remoting.BaseServerChannel | Abstract base class for client channels implemented using the .Net remoting infrastructure. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

IServerChannel Members
Gallio.Runtime.Remoting Namespace
IClientChannel


IServerChannel Members

IServerChannel Members
See Also Example Methods
[image]

A server channel manages the server side of a remoting channel.

The following tables list the members exposed by IServerChannel.

Public Methods

 | Name | Description
Public method | RegisterService | Registers a well-known service with the specified name.
Top

See Also

IServerChannel Interface
Gallio.Runtime.Remoting Namespace
IClientChannel


Methods

IServerChannel Methods
[image]

Public Methods

 | Name | Description
Public method | RegisterService | Registers a well-known service with the specified name.
Top

See Also

IServerChannel Interface
Gallio.Runtime.Remoting Namespace
IClientChannel


RegisterService Method

IServerChannel.RegisterService Method
[image]

Registers a well-known service with the specified name.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub RegisterService( _
ByVal serviceName As String, _
ByVal component As MarshalByRefObject _
)
C#
void RegisterService(
string serviceName,
MarshalByRefObject component
)
C++
void RegisterService(
String serviceName,
MarshalByRefObject component
) abstract
J#
void RegisterService(
string serviceName,
MarshalByRefObject component
)
JScript
function RegisterService(
serviceName : String,
component : MarshalByRefObject
)

Parameters

serviceName
The name of the service
component
The component that provides the service

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if serviceName or component is null

See Also

IServerChannel Interface
Gallio.Runtime.Remoting Namespace


LongLivedMarshalByRefObject Class

LongLivedMarshalByRefObject Class
See Also Example Members
[image]

Base class for long-lived marshal by ref objects. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class LongLivedMarshalByRefObject
Inherits MarshalByRefObject
C#
public abstract class LongLivedMarshalByRefObject : MarshalByRefObject
C++
ref class LongLivedMarshalByRefObject abstract : MarshalByRefObject
J#
public class LongLivedMarshalByRefObject extends MarshalByRefObject
JScript
public class LongLivedMarshalByRefObject extends MarshalByRefObject

Remarks

A LongLivedMarshalByRefObject represents a remote object whose lifetime is managed explicitly. It ensures that long-lived services are not inadvertently disconnected by the remoting infrastructure and remain accessible until the application discards them.

However, it is important to keep a reference to the marshalled object to ensure it does not get garbage collected prematurely. A marshalled object can also be explicitly disconnected via Disconnect.

This class overrides InitializeLifetimeService to return null which disables the automatic lease-management performed by the default lifetime service.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Model.Messages.RemoteTestExecutionListener
Gallio.Model.Messages.RemoteTestExplorationListener
Gallio.Runner.Drivers.BaseTestDriver
Gallio.Runtime.Hosting.BaseHostService

See Also

LongLivedMarshalByRefObject Members
Gallio.Runtime.Remoting Namespace


LongLivedMarshalByRefObject Members

LongLivedMarshalByRefObject Members
See Also Example Constructors Methods
[image]

Base class for long-lived marshal by ref objects. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by LongLivedMarshalByRefObject.

Protected Constructors

 | Name | Description
Family method | LongLivedMarshalByRefObject | Initializes a new instance of the LongLivedMarshalByRefObject class.
Top

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Overridden. Obtains a lifetime service object to control the lifetime policy for this instance.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

LongLivedMarshalByRefObject Class
Gallio.Runtime.Remoting Namespace


LongLivedMarshalByRefObject Constructor

LongLivedMarshalByRefObject Constructor
[image]

Initializes a new instance of the LongLivedMarshalByRefObject class.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected LongLivedMarshalByRefObject()
C++
protected:
LongLivedMarshalByRefObject() sealed
J#
protected LongLivedMarshalByRefObject()
JScript
protected function LongLivedMarshalByRefObject()

See Also

LongLivedMarshalByRefObject Class
Gallio.Runtime.Remoting Namespace


Methods

LongLivedMarshalByRefObject Methods
[image]

Public Methods

 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Overridden. Obtains a lifetime service object to control the lifetime policy for this instance.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Top

See Also

LongLivedMarshalByRefObject Class
Gallio.Runtime.Remoting Namespace


InitializeLifetimeService Method

LongLivedMarshalByRefObject.InitializeLifetimeService Method
[image]

Obtains a lifetime service object to control the lifetime policy for this instance.

Namespace: Gallio.Runtime.Remoting
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function InitializeLifetimeService() As Object
C#
public override object InitializeLifetimeService()
C++
public:
virtual Object InitializeLifetimeService() override
J#
public override object InitializeLifetimeService()
JScript
public override function InitializeLifetimeService() : Object

Return Value

An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the LeaseManagerPollTime property.

See Also

LongLivedMarshalByRefObject Class
Gallio.Runtime.Remoting Namespace


Gallio.Runtime.Windsor

Gallio.Runtime.Windsor Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | WindsorRuntime | Default implementation of IRuntime based on the Castle inversion of control microkernel.


WindsorRuntime Class

WindsorRuntime Class
See Also Example Members
[image]

Default implementation of IRuntime based on the Castle inversion of control microkernel.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class WindsorRuntime
Implements IRuntime, IDisposable
C#
public class WindsorRuntime : IRuntime, IDisposable
C++
ref class WindsorRuntime : IRuntime, IDisposable
J#
public class WindsorRuntime implements IRuntime, IDisposable
JScript
public class WindsorRuntime extends IRuntime, IDisposable

Remarks

Loads plugins automatically when initialized by searching for configuration files named "*.plugin" in the plugin load directories and installing any Windsor configuration sections into the container.

Inheritance Hierarchy

System.Object
Gallio.Runtime.Windsor.WindsorRuntime

See Also

WindsorRuntime Members
Gallio.Runtime.Windsor Namespace


WindsorRuntime Members

WindsorRuntime Members
See Also Example Constructors Methods
[image]

Default implementation of IRuntime based on the Castle inversion of control microkernel.

The following tables list the members exposed by WindsorRuntime.

Public Constructors

 | Name | Description
Public method | WindsorRuntime | Initializes the runtime.
Top

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPluginAssemblyPaths | Gets the paths and assembly names of all plugin assemblies.
Public method | GetRuntimeSetup | Gets a deep copy of the runtime setup used to configure this runtime.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the runtime.
Public method | MapUriToLocalPath | Maps a Uri to a local path.
Public method | Resolve | Overloaded. Resolves a reference to a component with the given id.
Public method | ResolveAll | Resolves references to all components that implement the specified service.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


WindsorRuntime Constructor

WindsorRuntime Constructor
[image]

Initializes the runtime.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyResolverManager As IAssemblyResolverManager, _
ByVal runtimeSetup As RuntimeSetup _
)
C#
public WindsorRuntime(
IAssemblyResolverManager assemblyResolverManager,
RuntimeSetup runtimeSetup
)
C++
public:
WindsorRuntime(
IAssemblyResolverManager assemblyResolverManager,
RuntimeSetup runtimeSetup
) sealed
J#
public WindsorRuntime(
IAssemblyResolverManager assemblyResolverManager,
RuntimeSetup runtimeSetup
)
JScript
public function WindsorRuntime(
assemblyResolverManager : IAssemblyResolverManager,
runtimeSetup : RuntimeSetup
)

Parameters

assemblyResolverManager
The assembly resolver to use
runtimeSetup
The runtime setup options

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if assemblyResolverManager or runtimeSetup is null

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


Methods

WindsorRuntime Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPluginAssemblyPaths | Gets the paths and assembly names of all plugin assemblies.
Public method | GetRuntimeSetup | Gets a deep copy of the runtime setup used to configure this runtime.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Initializes the runtime.
Public method | MapUriToLocalPath | Maps a Uri to a local path.
Public method | Resolve | Overloaded. Resolves a reference to a component with the given id.
Public method | ResolveAll | Resolves references to all components that implement the specified service.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


Dispose Method

WindsorRuntime.Dispose Method
[image]

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


GetPluginAssemblyPaths Method

WindsorRuntime.GetPluginAssemblyPaths Method
[image]

Gets the paths and assembly names of all plugin assemblies.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPluginAssemblyPaths() As IDictionary(Of String, AssemblyName) _
Implements IRuntime.GetPluginAssemblyPaths
C#
public IDictionary<string, AssemblyName> GetPluginAssemblyPaths()
C++
public:
IDictionary<string, AssemblyName> GetPluginAssemblyPaths() sealed
J#
public IDictionary<string, AssemblyName> GetPluginAssemblyPaths()
JScript
public function GetPluginAssemblyPaths() : IDictionary<string, AssemblyName>

Return Value

The paths

Implements

IRuntime.GetPluginAssemblyPaths

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


GetRuntimeSetup Method

WindsorRuntime.GetRuntimeSetup Method
[image]

Gets a deep copy of the runtime setup used to configure this runtime.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRuntimeSetup() As RuntimeSetup _
Implements IRuntime.GetRuntimeSetup
C#
public RuntimeSetup GetRuntimeSetup()
C++
public:
RuntimeSetup GetRuntimeSetup() sealed
J#
public RuntimeSetup GetRuntimeSetup()
JScript
public function GetRuntimeSetup() : RuntimeSetup

Return Value

The runtime setup

Implements

IRuntime.GetRuntimeSetup

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


Initialize Method

WindsorRuntime.Initialize Method
[image]

Initializes the runtime.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize( _
ByVal logger As ILogger _
) _
Implements IRuntime.Initialize
C#
public void Initialize(
ILogger logger
)
C++
public:
void Initialize(
ILogger logger
) sealed
J#
public void Initialize(
ILogger logger
)
JScript
public function Initialize(
logger : ILogger
)

Parameters

logger
The runtime logging service

Implements

IRuntime.Initialize

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


MapUriToLocalPath Method

WindsorRuntime.MapUriToLocalPath Method
[image]

Maps a Uri to a local path.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function MapUriToLocalPath( _
ByVal uri As Uri _
) As String _
Implements IRuntime.MapUriToLocalPath
C#
public string MapUriToLocalPath(
Uri uri
)
C++
public:
String MapUriToLocalPath(
Uri uri
) sealed
J#
public string MapUriToLocalPath(
Uri uri
)
JScript
public function MapUriToLocalPath(
uri : Uri
) : String

Parameters

uri
The uri to map

Return Value

The local path

Implements

IRuntime.MapUriToLocalPath

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


Resolve Method

WindsorRuntime.Resolve Method

Resolves a reference to a component with the given id.

Overload List

 | Name | Description
Public method | Resolve (String) | Resolves a reference to a component with the given id.
Public method | Resolve (Type) | Resolves a reference to a component that implements the specified service.
Public method | Resolve | Resolves a reference to a component that implements the specified service.

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


Resolve Method (String)

WindsorRuntime.Resolve Method (String)
See Also Example
[image]

Resolves a reference to a component with the given id.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal componentId As String _
) As Object _
Implements IRuntime.Resolve
C#
public object Resolve(
string componentId
)
C++
public:
Object Resolve(
String componentId
) sealed
J#
public object Resolve(
string componentId
)
JScript
public function Resolve(
componentId : String
) : Object

Parameters

componentId
The componentId

Return Value

A component with the specified id

Implements

IRuntime.Resolve

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace
WindsorRuntime.Resolve Overload List


Resolve Method (Type)

WindsorRuntime.Resolve Method (Type)
See Also Example
[image]

Resolves a reference to a component that implements the specified service.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve( _
ByVal service As Type _
) As Object _
Implements IRuntime.Resolve
C#
public object Resolve(
Type service
)
C++
public:
Object Resolve(
Type service
) sealed
J#
public object Resolve(
Type service
)
JScript
public function Resolve(
service : Type
) : Object

Parameters

service
The service type

Return Value

A component that implements the service

Implements

IRuntime.Resolve

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace
WindsorRuntime.Resolve Overload List


Resolve Generic Method ()

WindsorRuntime.Resolve Generic Method ()
See Also Example
[image]

Resolves a reference to a component that implements the specified service.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Resolve(Of T)() _
Implements IRuntime.Resolve
C#
public T Resolve<T>()
C++
public:
T Resolve<T>() sealed
J#
public T Resolve<T>()
JScript
JScript does not support generic types and methods.

Return Value

A component that implements the service

Implements

IRuntime.Resolve

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace
WindsorRuntime.Resolve Overload List


ResolveAll Generic Method

WindsorRuntime.ResolveAll Generic Method
[image]

Resolves references to all components that implement the specified service.

Namespace: Gallio.Runtime.Windsor
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function ResolveAll(Of T)() _
Implements IRuntime.ResolveAll
C#
public T[] ResolveAll<T>()
C++
public:
array<T>^ ResolveAll<T>() sealed
J#
public T[] ResolveAll<T>()
JScript
JScript does not support generic types and methods.

Return Value

An array of components that implement the service

Implements

IRuntime.ResolveAll

See Also

WindsorRuntime Class
Gallio.Runtime.Windsor Namespace


Gallio.UI

Gallio.UI Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | TestStepRunViewer | Displays a summary of a set of test step runs. This control is optimized to display individual test run results to the user on demand more quickly than could be done if we had to show the whole report at once.


TestStepRunViewer Class

TestStepRunViewer Class
See Also Example Members
[image]

Displays a summary of a set of test step runs.

This control is optimized to display individual test run results to the user on demand more quickly than could be done if we had to show the whole report at once.

Namespace: Gallio.UI
Assembly: Gallio.UI (in Gallio.UI.dll)

Syntax

Visual Basic (Declaration)
Public Class TestStepRunViewer
Inherits UserControl
C#
public class TestStepRunViewer : UserControl
C++
ref class TestStepRunViewer : UserControl
J#
public class TestStepRunViewer extends UserControl
JScript
public class TestStepRunViewer extends UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Gallio.UI.TestStepRunViewer

See Also

TestStepRunViewer Members
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


TestStepRunViewer Members

TestStepRunViewer Members
See Also Example Constructors Properties Methods Events
[image]

Displays a summary of a set of test step runs.

This control is optimized to display individual test run results to the user on demand more quickly than could be done if we had to show the whole report at once.

The following tables list the members exposed by TestStepRunViewer.

Public Constructors

 | Name | Description
Public method | TestStepRunViewer | Creates a test step run viewer.
Top

Public Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (inherited from Control)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (inherited from Control)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (inherited from Control)
Public property | AccessibleRole | Gets or sets the accessible role of the control (inherited from Control)
Public property | ActiveControl | Gets or sets the active control on the container control. (inherited from ContainerControl)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (inherited from Control)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (inherited from Control)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (inherited from ContainerControl)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (inherited from ContainerControl)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (inherited from ScrollableControl)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (inherited from ScrollableControl)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (inherited from ScrollableControl)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView. (inherited from Control)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (inherited from ScrollableControl)
Public property | AutoSize | (inherited from UserControl)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (inherited from UserControl)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (inherited from UserControl)
Public property | BackColor | Gets or sets the background color for the control. (inherited from Control)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (inherited from Control)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (inherited from Control)
Public property | BindingContext | (inherited from ContainerControl)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (inherited from UserControl)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (inherited from Control)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (inherited from Control)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (inherited from Control)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (inherited from Control)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (inherited from Control)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (inherited from Control)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (inherited from Control)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (inherited from Control)
Public property | Container | Gets the IContainer that contains the Component. (inherited from Component)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (inherited from Control)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (inherited from Control)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (inherited from Control)
Public property | Controls | Gets the collection of controls contained within the control. (inherited from Control)
Public property | Created | Gets a value indicating whether the control has been created. (inherited from Control)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (inherited from ContainerControl)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (inherited from Control)
Public property | DataBindings | Gets the data bindings for the control. (inherited from Control)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (inherited from ScrollableControl)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (inherited from Control)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (inherited from Control)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (inherited from ScrollableControl)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (inherited from Control)
Public property | Focused | Gets a value indicating whether the control has input focus. (inherited from Control)
Public property | Font | Gets or sets the font of the text displayed by the control. (inherited from Control)
Public property | ForeColor | Gets or sets the foreground color of the control. (inherited from Control)
Public property | Handle | Gets the window handle that the control is bound to. (inherited from Control)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (inherited from Control)
Public property | Height | Gets or sets the height of the control. (inherited from Control)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (inherited from ScrollableControl)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (inherited from Control)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (inherited from Control)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (inherited from Control)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (inherited from Control)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (inherited from Control)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (inherited from Control)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (inherited from Control)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (inherited from Control)
Public property | Margin | Gets or sets the space between controls. (inherited from Control)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize can specify. (inherited from Control)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize can specify. (inherited from Control)
Public property | Name | Gets or sets the name of the control. (inherited from Control)
Public property | Padding | Gets or sets padding within the control. (inherited from Control)
Public property | Parent | Gets or sets the parent container of the control. (inherited from Control)
Public property | ParentForm | Gets the form that the container control is assigned to. (inherited from ContainerControl)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (inherited from Control)
Public property | ProductName | Gets the product name of the assembly containing the control. (inherited from Control)
Public property | ProductVersion | Gets the version of the assembly containing the control. (inherited from Control)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (inherited from Control)
Public property | Region | Gets or sets the window region associated with the control. (inherited from Control)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (inherited from Control)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (inherited from Control)
Public property | Site | Gets or sets the site of the control. (inherited from Control)
Public property | Size | Gets or sets the height and width of the control. (inherited from Control)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (inherited from Control)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (inherited from Control)
Public property | Tag | Gets or sets the object that contains data about the control. (inherited from Control)
Public property | Text | (inherited from UserControl)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (inherited from Control)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (inherited from Control)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (inherited from Control)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (inherited from ScrollableControl)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (inherited from Control)
Public property | Width | Gets or sets the width of the control. (inherited from Control)
Public property | WindowTarget | This property is not relevant for this class. (inherited from Control)
Top

Protected Properties

 | Name | Description
Family property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (inherited from ContainerControl)
Family property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (inherited from ContainerControl)
Family property | CanRaiseEvents | Determines if events can be raised on the control. (inherited from Control)
Family property | CreateParams | (inherited from UserControl)
Family property | DefaultCursor | Gets or sets the default cursor for the control. (inherited from Control)
Family property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (inherited from Control)
Family property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (inherited from Control)
Family property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (inherited from Control)
Family property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (inherited from Control)
Family property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (inherited from Control)
Family property | DefaultSize | (inherited from UserControl)
Family property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (inherited from Component)
Family property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (inherited from Control)
Family property | Events | Gets the list of event handlers that are attached to this Component. (inherited from Component)
Family property | FontHeight | Gets or sets the height of the font of the control. (inherited from Control)
Family property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (inherited from ScrollableControl)
Family property | ImeModeBase | (inherited from Control)
Family property | RenderRightToLeft | This property is now obsolete. (inherited from Control)
Family property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (inherited from Control)
Family property | ScaleChildren | Gets a value that determines the scaling of child controls. (inherited from Control)
Family property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (inherited from Control)
Family property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (inherited from Control)
Family property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Clear | Clears the contents of the report viewer and discards all cached content.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the container.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | ResetBackColor | Resets the BackColor property to its default value. (inherited from Control)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (inherited from Control)
Public method | ResetCursor | Resets the Cursor property to its default value. (inherited from Control)
Public method | ResetFont | Resets the Font property to its default value. (inherited from Control)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (inherited from Control)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (inherited from Control)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the control. (inherited from ContainerControl)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | Show | Overloaded. Displays the control to the user.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (inherited from UserControl)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | AdjustFormScrollbars | (inherited from ContainerControl)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | Creates a new instance of the control collection for the control. (inherited from Control)
Family method | CreateHandle | Creates a handle for the control. (inherited from Control)
Family method | DefWndProc | Sends the specified message to the default window procedure. (inherited from Control)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the container.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (inherited from Control)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Control)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Control)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from UserControl)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | Raises the EnabledChanged event. (inherited from Control)
Family method | OnEnter | Raises the Enter event. (inherited from Control)
Family method | OnFontChanged | Raises the FontChanged event. (inherited from ContainerControl)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | Raises the HandleCreated event. (inherited from Control)
Family method | OnHandleDestroyed | Raises the HandleDestroyed event. (inherited from Control)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Raises the KeyDown event. (inherited from Control)
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from ContainerControl)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from UserControl)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | (inherited from UserControl)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | Raises the PaddingChanged event. (inherited from ScrollableControl)
Family method | OnPaint | Raises the Paint event. (inherited from Control)
Family method | OnPaintBackground | Paints the background of the control. (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from UserControl)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | Raises the StyleChanged event. (inherited from Control)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | Raises the TextChanged event. (inherited from Control)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | (inherited from ScrollableControl)
Family method | ProcessCmdKey | (inherited from ContainerControl)
Family method | ProcessDialogChar | (inherited from ContainerControl)
Family method | ProcessDialogKey | (inherited from ContainerControl)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | Previews a keyboard message. (inherited from Control)
Family method | ProcessMnemonic | (inherited from ContainerControl)
Family method | ProcessTabKey | Selects the next available control and makes it the active control. (inherited from ContainerControl)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from ScrollableControl)
Family method | ScaleCore | (inherited from ScrollableControl)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the control. (inherited from ContainerControl)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (inherited from Control)
Family method | SetClientSizeCore | Sets the size of the client area of the control. (inherited from Control)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets a specified ControlStyles flag to either true or false. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | Sets the control to the specified visible state. (inherited from Control)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (inherited from ContainerControl)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from UserControl)
Top

Public Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (inherited from UserControl)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (inherited from UserControl)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (inherited from Control)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (inherited from Control)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (inherited from Control)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (inherited from Control)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (inherited from Control)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (inherited from Control)
Public event | Click | Occurs when the control is clicked. (inherited from Control)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (inherited from Control)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (inherited from Control)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (inherited from Control)
Public event | ControlAdded | Occurs when a new control is added to the ControlCollection. (inherited from Control)
Public event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (inherited from Control)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (inherited from Control)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (inherited from Component)
Public event | DockChanged | Occurs when the value of the Dock property changes. (inherited from Control)
Public event | DoubleClick | Occurs when the control is double-clicked. (inherited from Control)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (inherited from Control)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (inherited from Control)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (inherited from Control)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (inherited from Control)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (inherited from Control)
Public event | Enter | Occurs when the control is entered. (inherited from Control)
Public event | FontChanged | Occurs when the Font property value changes. (inherited from Control)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (inherited from Control)
Public event | GiveFeedback | Occurs during a drag operation. (inherited from Control)
Public event | GotFocus | Occurs when the control receives focus. (inherited from Control)
Public event | HandleCreated | Occurs when a handle is created for the control. (inherited from Control)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (inherited from Control)
Public event | HelpRequested | Occurs when the user requests help for a control. (inherited from Control)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (inherited from Control)
Public event | Invalidated | Occurs when a control's display requires redrawing. (inherited from Control)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (inherited from Control)
Public event | KeyUp | Occurs when a key is released while the control has focus. (inherited from Control)
Public event | Layout | Occurs when a control should reposition its child controls. (inherited from Control)
Public event | Leave | Occurs when the input focus leaves the control. (inherited from Control)
Public event | Load | Occurs before the control becomes visible for the first time. (inherited from UserControl)
Public event | LocationChanged | Occurs when the Location property value has changed. (inherited from Control)
Public event | LostFocus | Occurs when the control loses focus. (inherited from Control)
Public event | MarginChanged | Occurs when the control's margin changes. (inherited from Control)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (inherited from Control)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (inherited from Control)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (inherited from Control)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (inherited from Control)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (inherited from Control)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (inherited from Control)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (inherited from Control)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (inherited from Control)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (inherited from Control)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (inherited from Control)
Public event | Move | Occurs when the control is moved. (inherited from Control)
Public event | PaddingChanged | Occurs when the control's padding changes. (inherited from Control)
Public event | Paint | Occurs when the control is redrawn. (inherited from Control)
Public event | ParentChanged | Occurs when the Parent property value changes. (inherited from Control)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (inherited from Control)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (inherited from Control)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (inherited from Control)
Public event | RegionChanged | Occurs when the value of the Region property changes. (inherited from Control)
Public event | Resize | Occurs when the control is resized. (inherited from Control)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (inherited from Control)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (inherited from ScrollableControl)
Public event | SizeChanged | Occurs when the Size property value changes. (inherited from Control)
Public event | StyleChanged | Occurs when the control style changes. (inherited from Control)
Public event | SystemColorsChanged | Occurs when the system colors change. (inherited from Control)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (inherited from Control)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (inherited from Control)
Public event | TextChanged | (inherited from UserControl)
Public event | Validated | Occurs when the control is finished validating. (inherited from Control)
Public event | Validating | Occurs when the control is validating. (inherited from Control)
Public event | VisibleChanged | Occurs when the Visible property value changes. (inherited from Control)
Top

See Also

TestStepRunViewer Class
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


TestStepRunViewer Constructor

TestStepRunViewer Constructor
[image]

Creates a test step run viewer.

Namespace: Gallio.UI
Assembly: Gallio.UI (in Gallio.UI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestStepRunViewer()
C++
public:
TestStepRunViewer() sealed
J#
public TestStepRunViewer()
JScript
public function TestStepRunViewer()

See Also

TestStepRunViewer Class
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Methods

TestStepRunViewer Methods
[image]

Public Methods

 | Name | Description
Public method | BeginInvoke | Overloaded. Executes a delegate asynchronously on the thread that the control's underlying handle was created on. (inherited from Control)
Public method | BringToFront | Brings the control to the front of the z-order. (inherited from Control)
Public method | Clear | Clears the contents of the report viewer and discards all cached content.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (inherited from Control)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (inherited from Control)
Public method | CreateGraphics | Creates the Graphics for the control. (inherited from Control)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose | Overloaded. Releases the resources used by the container.
Public method | DoDragDrop | Begins a drag-and-drop operation. (inherited from Control)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (inherited from Control)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (inherited from Control)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindForm | Retrieves the form that the control is on. (inherited from Control)
Public method | Focus | Sets input focus to the control. (inherited from Control)
Public method | GetChildAtPoint | Overloaded. Retrieves the child control at a specified location. (inherited from Control)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (inherited from Control)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (inherited from Control)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (inherited from Control)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Hide | Conceals the control from the user. (inherited from Control)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Invalidate | Overloaded. Invalidates a specific region of the control and causes a paint message to be sent to the control. (inherited from Control)
Public method | Invoke | Overloaded. Executes a delegate on the thread that owns the control's underlying window handle. (inherited from Control)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (inherited from ContainerControl)
Public method | PerformLayout | Overloaded. Forces the control to apply layout logic to child controls. (inherited from Control)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (inherited from Control)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (inherited from Control)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (inherited from Control)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (inherited from Control)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (inherited from Control)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (inherited from Control)
Public method | ResetBackColor | Resets the BackColor property to its default value. (inherited from Control)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (inherited from Control)
Public method | ResetCursor | Resets the Cursor property to its default value. (inherited from Control)
Public method | ResetFont | Resets the Font property to its default value. (inherited from Control)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (inherited from Control)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (inherited from Control)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (inherited from Control)
Public method | ResetText | Resets the Text property to its default value. (inherited from Control)
Public method | ResumeLayout | Overloaded. Resumes the usual layout logic. (inherited from Control)
Public method | Scale | Overloaded. Scales the control and any child controls. (inherited from Control)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (inherited from ScrollableControl)
Public method | Select | Overloaded. Activates the control. (inherited from ContainerControl)
Public method | SelectNextControl | Activates the next control. (inherited from Control)
Public method | SendToBack | Sends the control to the back of the z-order. (inherited from Control)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (inherited from ScrollableControl)
Public method | SetBounds | Overloaded. Sets the bounds of the control. (inherited from Control)
Public method | Show | Overloaded. Displays the control to the user.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (inherited from Control)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (inherited from Component)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (inherited from Control)
Public method | Validate | Overloaded. Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (inherited from ContainerControl)
Public method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (inherited from UserControl)
Top

Protected Methods

 | Name | Description
Family method | AccessibilityNotifyClients | Overloaded. Notifies the accessibility client applications of AccessibleEvents. (inherited from Control)
Family method | AdjustFormScrollbars | (inherited from ContainerControl)
Family method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (inherited from Control)
Family method | CreateControlsInstance | Creates a new instance of the control collection for the control. (inherited from Control)
Family method | CreateHandle | Creates a handle for the control. (inherited from Control)
Family method | DefWndProc | Sends the specified message to the default window procedure. (inherited from Control)
Family method | DestroyHandle | Destroys the handle associated with the control. (inherited from Control)
Family method | Dispose | Overloaded. Releases the resources used by the container.
Family method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (inherited from Component)
Family method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (inherited from Control)
Family method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (inherited from Control)
Family method | GetScrollState | Determines whether the specified flag has been set. (inherited from ScrollableControl)
Family method | GetService | Returns an object that represents a service provided by the Component or by its Container. (inherited from Component)
Family method | GetStyle | Retrieves the value of the specified control style bit for the control. (inherited from Control)
Family method | GetTopLevel | Determines if the control is a top-level control. (inherited from Control)
Family method | InitLayout | Called after the control has been added to another container. (inherited from Control)
Family method | InvokeGotFocus | Raises the GotFocus event for the specified control. (inherited from Control)
Family method | InvokeLostFocus | Raises the LostFocus event for the specified control. (inherited from Control)
Family method | InvokeOnClick | Raises the Click event for the specified control. (inherited from Control)
Family method | InvokePaint | Raises the Paint event for the specified control. (inherited from Control)
Family method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (inherited from Control)
Family method | IsInputChar | Determines if a character is an input character that the control recognizes. (inherited from Control)
Family method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (inherited from Control)
Family method | MemberwiseClone | Overloaded. Creates a shallow copy of the current Object. (inherited from MarshalByRefObject)
Family method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (inherited from Control)
Family method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (inherited from Control)
Family method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (inherited from ContainerControl)
Family method | OnBackColorChanged | Raises the BackColorChanged event. (inherited from Control)
Family method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (inherited from Control)
Family method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (inherited from Control)
Family method | OnBindingContextChanged | Raises the BindingContextChanged event. (inherited from Control)
Family method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (inherited from Control)
Family method | OnChangeUICues | Raises the ChangeUICues event. (inherited from Control)
Family method | OnClick | Raises the Click event. (inherited from Control)
Family method | OnClientSizeChanged | Raises the ClientSizeChanged event. (inherited from Control)
Family method | OnContextMenuChanged | Raises the ContextMenuChanged event. (inherited from Control)
Family method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (inherited from Control)
Family method | OnControlAdded | Raises the ControlAdded event. (inherited from Control)
Family method | OnControlRemoved | Raises the ControlRemoved event. (inherited from Control)
Family method | OnCreateControl | Raises the CreateControl event. (inherited from UserControl)
Family method | OnCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnDockChanged | Raises the DockChanged event. (inherited from Control)
Family method | OnDoubleClick | Raises the DoubleClick event. (inherited from Control)
Family method | OnDragDrop | Raises the DragDrop event. (inherited from Control)
Family method | OnDragEnter | Raises the DragEnter event. (inherited from Control)
Family method | OnDragLeave | Raises the DragLeave event. (inherited from Control)
Family method | OnDragOver | Raises the DragOver event. (inherited from Control)
Family method | OnEnabledChanged | Raises the EnabledChanged event. (inherited from Control)
Family method | OnEnter | Raises the Enter event. (inherited from Control)
Family method | OnFontChanged | Raises the FontChanged event. (inherited from ContainerControl)
Family method | OnForeColorChanged | Raises the ForeColorChanged event. (inherited from Control)
Family method | OnGiveFeedback | Raises the GiveFeedback event. (inherited from Control)
Family method | OnGotFocus | Raises the GotFocus event. (inherited from Control)
Family method | OnHandleCreated | Raises the HandleCreated event. (inherited from Control)
Family method | OnHandleDestroyed | Raises the HandleDestroyed event. (inherited from Control)
Family method | OnHelpRequested | Raises the HelpRequested event. (inherited from Control)
Family method | OnImeModeChanged | Raises the ImeModeChanged event. (inherited from Control)
Family method | OnInvalidated | Raises the Invalidated event. (inherited from Control)
Family method | OnKeyDown | Raises the KeyDown event. (inherited from Control)
Family method | OnKeyPress | Raises the KeyPress event. (inherited from Control)
Family method | OnKeyUp | Raises the KeyUp event. (inherited from Control)
Family method | OnLayout | (inherited from ContainerControl)
Family method | OnLeave | Raises the Leave event. (inherited from Control)
Family method | OnLoad | Raises the Load event. (inherited from UserControl)
Family method | OnLocationChanged | Raises the LocationChanged event. (inherited from Control)
Family method | OnLostFocus | Raises the LostFocus event. (inherited from Control)
Family method | OnMarginChanged | Raises the MarginChanged event. (inherited from Control)
Family method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (inherited from Control)
Family method | OnMouseClick | Raises the MouseClick event. (inherited from Control)
Family method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (inherited from Control)
Family method | OnMouseDown | (inherited from UserControl)
Family method | OnMouseEnter | Raises the MouseEnter event. (inherited from Control)
Family method | OnMouseHover | Raises the MouseHover event. (inherited from Control)
Family method | OnMouseLeave | Raises the MouseLeave event. (inherited from Control)
Family method | OnMouseMove | Raises the MouseMove event. (inherited from Control)
Family method | OnMouseUp | Raises the MouseUp event. (inherited from Control)
Family method | OnMouseWheel | Raises the MouseWheel event. (inherited from ScrollableControl)
Family method | OnMove | Raises the Move event. (inherited from Control)
Family method | OnNotifyMessage | Notifies the control of Windows messages. (inherited from Control)
Family method | OnPaddingChanged | Raises the PaddingChanged event. (inherited from ScrollableControl)
Family method | OnPaint | Raises the Paint event. (inherited from Control)
Family method | OnPaintBackground | Paints the background of the control. (inherited from ScrollableControl)
Family method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (inherited from Control)
Family method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (inherited from Control)
Family method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (inherited from Control)
Family method | OnParentChanged | (inherited from ContainerControl)
Family method | OnParentCursorChanged | Raises the CursorChanged event. (inherited from Control)
Family method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (inherited from Control)
Family method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (inherited from Control)
Family method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (inherited from Control)
Family method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (inherited from Control)
Family method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (inherited from Control)
Family method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (inherited from Control)
Family method | OnPrint | Raises the Paint event. (inherited from Control)
Family method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (inherited from Control)
Family method | OnRegionChanged | Raises the RegionChanged event. (inherited from Control)
Family method | OnResize | (inherited from UserControl)
Family method | OnRightToLeftChanged | (inherited from ScrollableControl)
Family method | OnScroll | Raises the Scroll event. (inherited from ScrollableControl)
Family method | OnSizeChanged | Raises the SizeChanged event. (inherited from Control)
Family method | OnStyleChanged | Raises the StyleChanged event. (inherited from Control)
Family method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (inherited from Control)
Family method | OnTabIndexChanged | Raises the TabIndexChanged event. (inherited from Control)
Family method | OnTabStopChanged | Raises the TabStopChanged event. (inherited from Control)
Family method | OnTextChanged | Raises the TextChanged event. (inherited from Control)
Family method | OnValidated | Raises the Validated event. (inherited from Control)
Family method | OnValidating | Raises the Validating event. (inherited from Control)
Family method | OnVisibleChanged | (inherited from ScrollableControl)
Family method | ProcessCmdKey | (inherited from ContainerControl)
Family method | ProcessDialogChar | (inherited from ContainerControl)
Family method | ProcessDialogKey | (inherited from ContainerControl)
Family method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (inherited from Control)
Family method | ProcessKeyMessage | Processes a keyboard message. (inherited from Control)
Family method | ProcessKeyPreview | Previews a keyboard message. (inherited from Control)
Family method | ProcessMnemonic | (inherited from ContainerControl)
Family method | ProcessTabKey | Selects the next available control and makes it the active control. (inherited from ContainerControl)
Family method | RaiseDragEvent | Raises the appropriate drag event. (inherited from Control)
Family method | RaiseKeyEvent | Raises the appropriate key event. (inherited from Control)
Family method | RaiseMouseEvent | Raises the appropriate mouse event. (inherited from Control)
Family method | RaisePaintEvent | Raises the appropriate paint event. (inherited from Control)
Family method | RecreateHandle | Forces the re-creation of the handle for the control. (inherited from Control)
Family method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (inherited from Control)
Family method | RtlTranslateAlignment | Overloaded. Converts the current alignment to the appropriate alignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (inherited from Control)
Family method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (inherited from Control)
Family method | ScaleControl | (inherited from ScrollableControl)
Family method | ScaleCore | (inherited from ScrollableControl)
Family method | ScrollToControl | Calculates the scroll offset to the specified child control. (inherited from ScrollableControl)
Family method | Select | Overloaded. Activates the control. (inherited from ContainerControl)
Family method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (inherited from Control)
Family method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (inherited from Control)
Family method | SetClientSizeCore | Sets the size of the client area of the control. (inherited from Control)
Family method | SetDisplayRectLocation | Positions the display window to the specified value. (inherited from ScrollableControl)
Family method | SetScrollState | Sets the specified scroll state flag. (inherited from ScrollableControl)
Family method | SetStyle | Sets a specified ControlStyles flag to either true or false. (inherited from Control)
Family method | SetTopLevel | Sets the control as the top-level control. (inherited from Control)
Family method | SetVisibleCore | Sets the control to the specified visible state. (inherited from Control)
Family method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (inherited from Control)
Family method | UpdateBounds | Overloaded. Updates the bounds of the control. (inherited from Control)
Family method | UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (inherited from ContainerControl)
Family method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (inherited from Control)
Family method | UpdateZOrder | Updates the control in its parent's z-order. (inherited from Control)
Family method | WndProc | (inherited from UserControl)
Top

See Also

TestStepRunViewer Class
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Clear Method

TestStepRunViewer.Clear Method
[image]

Clears the contents of the report viewer and discards all cached content.

Namespace: Gallio.UI
Assembly: Gallio.UI (in Gallio.UI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

See Also

TestStepRunViewer Class
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Dispose Method

TestStepRunViewer.Dispose Method

Releases the resources used by the container.

Overload List

 | Name | Description
Family method | Dispose (Boolean) | Overridden. Clean up any resources being used.
Public method | Dispose | Releases all resources used by the Component. (inherited from Component)

See Also

TestStepRunViewer Class
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Dispose Method (Boolean)

TestStepRunViewer.Dispose Method (Boolean)
See Also Example
[image]

Clean up any resources being used.

Namespace: Gallio.UI
Assembly: Gallio.UI (in Gallio.UI.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)
C#
protected override void Dispose(
bool disposing
)
C++
protected:
virtual void Dispose(
bool disposing
) override
J#
protected override void Dispose(
bool disposing
)
JScript
protected override function Dispose(
disposing : bool
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

See Also

TestStepRunViewer Class
Gallio.UI Namespace
TestStepRunViewer.Dispose Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Show Method

TestStepRunViewer.Show Method

Displays the control to the user.

Overload List

 | Name | Description
Public method | Show (ICollection<TestStepRun>) | Displays information about a set of test step run.
Public method | Show (ICollection<TestStepRun>, TestModelData) | Displays information about a set of test step runs, using additional information from the test model when available.
Public method | Show | Displays the control to the user. (inherited from Control)

See Also

TestStepRunViewer Class
Gallio.UI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Show Method (Generic ICollection)

TestStepRunViewer.Show Method (Generic ICollection)
See Also Example
[image]

Displays information about a set of test step run.

Namespace: Gallio.UI
Assembly: Gallio.UI (in Gallio.UI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Show( _
ByVal testStepRuns As ICollection(Of TestStepRun) _
)
C#
public void Show(
ICollection<TestStepRun> testStepRuns
)
C++
public:
void Show(
ICollection<TestStepRun> testStepRuns
) sealed
J#
public void Show(
ICollection<TestStepRun> testStepRuns
)
JScript
public function Show(
testStepRuns : ICollection<TestStepRun>
)

Parameters

testStepRuns
The test step runs

See Also

TestStepRunViewer Class
Gallio.UI Namespace
TestStepRunViewer.Show Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Show Method (Generic ICollection, TestModelData)

TestStepRunViewer.Show Method (Generic ICollection, TestModelData)
See Also Example
[image]

Displays information about a set of test step runs, using additional information from the test model when available.

Namespace: Gallio.UI
Assembly: Gallio.UI (in Gallio.UI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Show( _
ByVal testStepRuns As ICollection(Of TestStepRun), _
ByVal testModelData As TestModelData _
)
C#
public void Show(
ICollection<TestStepRun> testStepRuns,
TestModelData testModelData
)
C++
public:
void Show(
ICollection<TestStepRun> testStepRuns,
TestModelData testModelData
) sealed
J#
public void Show(
ICollection<TestStepRun> testStepRuns,
TestModelData testModelData
)
JScript
public function Show(
testStepRuns : ICollection<TestStepRun>,
testModelData : TestModelData
)

Parameters

testStepRuns
The test step runs
testModelData
The test model data, or null if not available

See Also

TestStepRunViewer Class
Gallio.UI Namespace
TestStepRunViewer.Show Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly Gallio.UI [3.0.6.0]


Gallio.Utilities

Gallio.Utilities Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | CurrentDirectorySwitcher | Sets CurrentDirectory when created, then restores it when disposed.
Public class | DefaultXmlSerializer | Default IXmlSerializer implementation.
Public class | EventHandlerUtils | Provides a few functions for working with EventHandler and EventHandler. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | ExceptionUtils | Provides helper functions for manipulating Exceptions. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | FileSystem | Default implementation of IFileSystem using System.IO classes.
Public class | FileUtils | Utilities for manipulating files. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | StringUtils | Provides utility functions for working with strings. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | Sync | Provides helpers for cross-thread synchronization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | XmlSerializationUtils | Utilities and constants used for serialization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | XmlUtils | Provides utilities for manipulating Xml. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Interfaces

 | Interface | Description
Public interface | IFileSystem | Wrapper for static System.IO.File operations to allow testing.
Public interface | IXmlSerializer | Wrapper for XmlSerializationUtils static methods (allows testing).

Structures

 | Structure | Description
Public structure | Hash64 | A 64bit hash code value type. Provides somewhat more protection against collisions than 32 bit hashes.
Public structure | KeyedMemoizer | A structure that memoizes the result of some computation for later reuse. Maintains an internal dictionary to memoize results by key.
Public structure | Memoizer | A structure that memoizes the result of some computation for later reuse.


CurrentDirectorySwitcher Class

CurrentDirectorySwitcher Class
See Also Example Members
[image]

Sets CurrentDirectory when created, then restores it when disposed.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class CurrentDirectorySwitcher
Implements IDisposable
C#
public class CurrentDirectorySwitcher : IDisposable
C++
ref class CurrentDirectorySwitcher : IDisposable
J#
public class CurrentDirectorySwitcher implements IDisposable
JScript
public class CurrentDirectorySwitcher extends IDisposable

Inheritance Hierarchy

System.Object
Gallio.Utilities.CurrentDirectorySwitcher

See Also

CurrentDirectorySwitcher Members
Gallio.Utilities Namespace


CurrentDirectorySwitcher Members

CurrentDirectorySwitcher Members
See Also Example Constructors Methods
[image]

Sets CurrentDirectory when created, then restores it when disposed.

The following tables list the members exposed by CurrentDirectorySwitcher.

Public Constructors

 | Name | Description
Public method | CurrentDirectorySwitcher | Saves the current directory then changes it to the specified value.
Top

Public Methods

 | Name | Description
Public method | Dispose | Resets the current directory to its original saved value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CurrentDirectorySwitcher Class
Gallio.Utilities Namespace


CurrentDirectorySwitcher Constructor

CurrentDirectorySwitcher Constructor
[image]

Saves the current directory then changes it to the specified value.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal directory As String _
)
C#
public CurrentDirectorySwitcher(
string directory
)
C++
public:
CurrentDirectorySwitcher(
String directory
) sealed
J#
public CurrentDirectorySwitcher(
string directory
)
JScript
public function CurrentDirectorySwitcher(
directory : String
)

Parameters

directory
The new directory

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if directory is null
IOException | Thrown if the current directory could not be set

See Also

CurrentDirectorySwitcher Class
Gallio.Utilities Namespace


Methods

CurrentDirectorySwitcher Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose | Resets the current directory to its original saved value.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CurrentDirectorySwitcher Class
Gallio.Utilities Namespace


Dispose Method

CurrentDirectorySwitcher.Dispose Method
[image]

Resets the current directory to its original saved value.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

Exceptions

Exception Type | Condition
IOException | Thrown if the current directory could not be reset

See Also

CurrentDirectorySwitcher Class
Gallio.Utilities Namespace


DefaultXmlSerializer Class

DefaultXmlSerializer Class
See Also Example Members
[image]

Default IXmlSerializer implementation.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class DefaultXmlSerializer
Implements IXmlSerializer
C#
public class DefaultXmlSerializer : IXmlSerializer
C++
ref class DefaultXmlSerializer : IXmlSerializer
J#
public class DefaultXmlSerializer implements IXmlSerializer
JScript
public class DefaultXmlSerializer extends IXmlSerializer

Inheritance Hierarchy

System.Object
Gallio.Utilities.DefaultXmlSerializer

See Also

DefaultXmlSerializer Members
Gallio.Utilities Namespace


DefaultXmlSerializer Members

DefaultXmlSerializer Members
See Also Example Constructors Methods
[image]

Default IXmlSerializer implementation.

The following tables list the members exposed by DefaultXmlSerializer.

Public Constructors

 | Name | Description
Public method | DefaultXmlSerializer | Initializes a new instance of the DefaultXmlSerializer class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadFromXml | Loads an object graph from an Xml file using XmlSerializer.
Public method | SaveToXml | Saves an object graph to a pretty-printed Xml file using XmlSerializer.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultXmlSerializer Class
Gallio.Utilities Namespace


DefaultXmlSerializer Constructor

DefaultXmlSerializer Constructor
[image]

Initializes a new instance of the DefaultXmlSerializer class.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DefaultXmlSerializer()
C++
public:
DefaultXmlSerializer() sealed
J#
public DefaultXmlSerializer()
JScript
public function DefaultXmlSerializer()

See Also

DefaultXmlSerializer Class
Gallio.Utilities Namespace


Methods

DefaultXmlSerializer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LoadFromXml | Loads an object graph from an Xml file using XmlSerializer.
Public method | SaveToXml | Saves an object graph to a pretty-printed Xml file using XmlSerializer.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DefaultXmlSerializer Class
Gallio.Utilities Namespace


LoadFromXml Generic Method

DefaultXmlSerializer.LoadFromXml Generic Method
[image]

Loads an object graph from an Xml file using XmlSerializer.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadFromXml(Of T)( _
ByVal filename As String _
) _
Implements IXmlSerializer.LoadFromXml
C#
public T LoadFromXml<T>(
string filename
)
C++
public:
T LoadFromXml<T>(
String filename
) sealed
J#
public T LoadFromXml<T>(
string filename
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The root object type

Parameters

filename
The filename

Return Value

The root object

Implements

IXmlSerializer.LoadFromXml

See Also

DefaultXmlSerializer Class
Gallio.Utilities Namespace


SaveToXml Generic Method

DefaultXmlSerializer.SaveToXml Generic Method
[image]

Saves an object graph to a pretty-printed Xml file using XmlSerializer.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveToXml(Of T)( _
ByVal root As T, _
ByVal filename As String _
) _
Implements IXmlSerializer.SaveToXml
C#
public void SaveToXml<T>(
T root,
string filename
)
C++
public:
void SaveToXml<T>(
T root,
String filename
) sealed
J#
public void SaveToXml<T>(
T root,
string filename
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The root object type

Parameters

root
The root object
filename
The filename

Implements

IXmlSerializer.SaveToXml

See Also

DefaultXmlSerializer Class
Gallio.Utilities Namespace


EventHandlerUtils Class

EventHandlerUtils Class
[image]

Provides a few functions for working with EventHandler and EventHandler. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module EventHandlerUtils
C#
public static class EventHandlerUtils
C++
ref class EventHandlerUtils abstract sealed
J#
public final class EventHandlerUtils
JScript
public class EventHandlerUtils

Inheritance Hierarchy

System.Object
Gallio.Utilities.EventHandlerUtils

See Also

EventHandlerUtils Members
Gallio.Utilities Namespace


EventHandlerUtils Members

EventHandlerUtils Members
[image]

Provides a few functions for working with EventHandler and EventHandler. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by EventHandlerUtils.

Public Methods

Name | Description
SafeInvoke | Overloaded. Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.
Top

See Also

EventHandlerUtils Class
Gallio.Utilities Namespace


Methods

EventHandlerUtils Methods
[image]

Public Methods

Name | Description
SafeInvoke | Overloaded. Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.
Top

See Also

EventHandlerUtils Class
Gallio.Utilities Namespace


SafeInvoke Method

EventHandlerUtils.SafeInvoke Method

Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.

Overload List

Name | Description
SafeInvoke (EventHandler, Object, EventArgs) | Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.
SafeInvoke (EventHandler<T>, Object, T) | Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.

See Also

EventHandlerUtils Class
Gallio.Utilities Namespace


SafeInvoke Method (EventHandler, Object, EventArgs)

EventHandlerUtils.SafeInvoke Method (EventHandler, Object, EventArgs)
See Also Example
[image]

Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SafeInvoke( _
ByVal handlerChain As EventHandler, _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C#
public static void SafeInvoke(
EventHandler handlerChain,
object sender,
EventArgs e
)
C++
public:
static void SafeInvoke(
EventHandler handlerChain,
Object sender,
EventArgs e
)
J#
public static void SafeInvoke(
EventHandler handlerChain,
object sender,
EventArgs e
)
JScript
public static function SafeInvoke(
handlerChain : EventHandler,
sender : Object,
e : EventArgs
)

Parameters

handlerChain
The event handler chain
sender
The sender
e
The event arguments

See Also

EventHandlerUtils Class
Gallio.Utilities Namespace
EventHandlerUtils.SafeInvoke Overload List


SafeInvoke Generic Method (Generic EventHandler, Object, T)

EventHandlerUtils.SafeInvoke Generic Method (Generic EventHandler, Object, T)
See Also Example
[image]

Safely invokes each delegate in the invocation list of an event handler. Sends any exceptions thrown by the handler to Report.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SafeInvoke(Of T As EventArgs)( _
ByVal handlerChain As EventHandler(Of T), _
ByVal sender As Object, _
ByVal e As T _
)
C#
public static void SafeInvoke<T>(
EventHandler<T> handlerChain,
object sender,
T e
) where T : EventArgs
C++
public:
static void SafeInvoke<T>(
EventHandler<T> handlerChain,
Object sender,
T e
)
J#
public static void SafeInvoke<T>(
EventHandler<T> handlerChain,
object sender,
T e
)
JScript
JScript does not support generic types and methods.

Parameters

handlerChain
The event handler chain
sender
The sender
e
The event arguments

See Also

EventHandlerUtils Class
Gallio.Utilities Namespace
EventHandlerUtils.SafeInvoke Overload List


ExceptionUtils Class

ExceptionUtils Class
See Also Example Members
[image]

Provides helper functions for manipulating Exceptions. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module ExceptionUtils
C#
public static class ExceptionUtils
C++
ref class ExceptionUtils abstract sealed
J#
public final class ExceptionUtils
JScript
public class ExceptionUtils

Inheritance Hierarchy

System.Object
Gallio.Utilities.ExceptionUtils

See Also

ExceptionUtils Members
Gallio.Utilities Namespace


ExceptionUtils Members

ExceptionUtils Members
See Also Example Methods
[image]

Provides helper functions for manipulating Exceptions. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by ExceptionUtils.

Public Methods

Name | Description
InvokeMethodWithoutTargetInvocationException | Invokes a method without producing a TargetInvocationException
RethrowWithNoStackTraceLoss | Rethrows an exception without discarding its stack trace. This enables the inner exception of TargetInvocationException to be unwrapped.
SafeGetMessage | Safely obtains the Message component of an exception.
SafeGetStackTrace | Safely obtains the StackTrace component of an exception.
SafeToString

Safely converts an exception to a string.

This method protects the caller from unexpected failures that may occur while reporting an exception of untrusted origin. If an error occurs while converting the exception to a string, this method returns a generic description of the exception that can be used instead of the real thing.

It can happen that converting an exception to a string produces a secondary exception because the ToString method has been overridden or because the stack frames associated with the exception are malformed. For example, we observed one case of a TypeLoadException being thrown while printing an exception because one of the stack frames referred to a dynamic method with incorrect metadata.

Top

See Also

ExceptionUtils Class
Gallio.Utilities Namespace


Methods

ExceptionUtils Methods
[image]

Public Methods

Name | Description
InvokeMethodWithoutTargetInvocationException | Invokes a method without producing a TargetInvocationException
RethrowWithNoStackTraceLoss | Rethrows an exception without discarding its stack trace. This enables the inner exception of TargetInvocationException to be unwrapped.
SafeGetMessage | Safely obtains the Message component of an exception.
SafeGetStackTrace | Safely obtains the StackTrace component of an exception.
SafeToString

Safely converts an exception to a string.

This method protects the caller from unexpected failures that may occur while reporting an exception of untrusted origin. If an error occurs while converting the exception to a string, this method returns a generic description of the exception that can be used instead of the real thing.

It can happen that converting an exception to a string produces a secondary exception because the ToString method has been overridden or because the stack frames associated with the exception are malformed. For example, we observed one case of a TypeLoadException being thrown while printing an exception because one of the stack frames referred to a dynamic method with incorrect metadata.

Top

See Also

ExceptionUtils Class
Gallio.Utilities Namespace


InvokeMethodWithoutTargetInvocationException Method

ExceptionUtils.InvokeMethodWithoutTargetInvocationException Method
See Also Example
[image]

Invokes a method without producing a TargetInvocationException

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerStepThroughAttribute, _
DebuggerHiddenAttribute>
Public Shared Function InvokeMethodWithoutTargetInvocationException( _
ByVal method As MethodBase, _
ByVal obj As Object, _
ByVal args As Object() _
) As Object
C#
[DebuggerStepThroughAttribute]
[DebuggerHiddenAttribute]
public static object InvokeMethodWithoutTargetInvocationException(
MethodBase method,
object obj,
object[] args
)
C++
[DebuggerStepThroughAttribute]
[DebuggerHiddenAttribute]
public:
static Object InvokeMethodWithoutTargetInvocationException(
MethodBase method,
Object obj,
array<Object>^ args
)
J#
/** @attribute DebuggerStepThroughAttribute() */
/** @attribute DebuggerHiddenAttribute() */
public static object InvokeMethodWithoutTargetInvocationException(
MethodBase method,
object obj,
object[] args
)
JScript
public static

DebuggerStepThroughAttribute
DebuggerHiddenAttribute
function InvokeMethodWithoutTargetInvocationException(
method : MethodBase,
obj : Object,
args : Object[]
) : Object

Parameters

method
The method to invoke
obj
The instance on which to invoke the method, or null if none
args
The method arguments, or null if none

Return Value

The method return value, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if method is null

See Also

ExceptionUtils Class
Gallio.Utilities Namespace


RethrowWithNoStackTraceLoss Method

ExceptionUtils.RethrowWithNoStackTraceLoss Method
[image]

Rethrows an exception without discarding its stack trace. This enables the inner exception of TargetInvocationException to be unwrapped.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
<DebuggerStepThroughAttribute, _
DebuggerHiddenAttribute>
Public Shared Sub RethrowWithNoStackTraceLoss( _
ByVal ex As Exception _
)
C#
[DebuggerStepThroughAttribute]
[DebuggerHiddenAttribute]
public static void RethrowWithNoStackTraceLoss(
Exception ex
)
C++
[DebuggerStepThroughAttribute]
[DebuggerHiddenAttribute]
public:
static void RethrowWithNoStackTraceLoss(
Exception ex
)
J#
/** @attribute DebuggerStepThroughAttribute() */
/** @attribute DebuggerHiddenAttribute() */
public static void RethrowWithNoStackTraceLoss(
Exception ex
)
JScript
public static

DebuggerStepThroughAttribute
DebuggerHiddenAttribute
function RethrowWithNoStackTraceLoss(
ex : Exception
)

Parameters

ex
The exception to rethrow

Remarks

This implementation is based on code by Brad Wilson.

See Also

ExceptionUtils Class
Gallio.Utilities Namespace


SafeGetMessage Method

ExceptionUtils.SafeGetMessage Method
[image]

Safely obtains the Message component of an exception.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SafeGetMessage( _
ByVal ex As Exception _
) As String
C#
public static string SafeGetMessage(
Exception ex
)
C++
public:
static String SafeGetMessage(
Exception ex
)
J#
public static string SafeGetMessage(
Exception ex
)
JScript
public static function SafeGetMessage(
ex : Exception
) : String

Return Value

The message

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if ex is null

See Also

ExceptionUtils Class
Gallio.Utilities Namespace
SafeToString


SafeGetStackTrace Method

ExceptionUtils.SafeGetStackTrace Method
[image]

Safely obtains the StackTrace component of an exception.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SafeGetStackTrace( _
ByVal ex As Exception _
) As String
C#
public static string SafeGetStackTrace(
Exception ex
)
C++
public:
static String SafeGetStackTrace(
Exception ex
)
J#
public static string SafeGetStackTrace(
Exception ex
)
JScript
public static function SafeGetStackTrace(
ex : Exception
) : String

Return Value

The stack trace

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if ex is null

See Also

ExceptionUtils Class
Gallio.Utilities Namespace
SafeToString


SafeToString Method

ExceptionUtils.SafeToString Method
[image]

Safely converts an exception to a string.

This method protects the caller from unexpected failures that may occur while reporting an exception of untrusted origin. If an error occurs while converting the exception to a string, this method returns a generic description of the exception that can be used instead of the real thing.

It can happen that converting an exception to a string produces a secondary exception because the ToString method has been overridden or because the stack frames associated with the exception are malformed. For example, we observed one case of a TypeLoadException being thrown while printing an exception because one of the stack frames referred to a dynamic method with incorrect metadata.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SafeToString( _
ByVal ex As Exception _
) As String
C#
public static string SafeToString(
Exception ex
)
C++
public:
static String SafeToString(
Exception ex
)
J#
public static string SafeToString(
Exception ex
)
JScript
public static function SafeToString(
ex : Exception
) : String

Parameters

ex
The exception

Return Value

The string contents

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if ex is null

See Also

ExceptionUtils Class
Gallio.Utilities Namespace
ToString


FileSystem Class

FileSystem Class
See Also Example Members
[image]

Default implementation of IFileSystem using System.IO classes.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Class FileSystem
Implements IFileSystem
C#
public class FileSystem : IFileSystem
C++
ref class FileSystem : IFileSystem
J#
public class FileSystem implements IFileSystem
JScript
public class FileSystem extends IFileSystem

Inheritance Hierarchy

System.Object
Gallio.Utilities.FileSystem

See Also

FileSystem Members
Gallio.Utilities Namespace


FileSystem Members

FileSystem Members
See Also Example Constructors Methods
[image]

Default implementation of IFileSystem using System.IO classes.

The following tables list the members exposed by FileSystem.

Public Constructors

 | Name | Description
Public method | FileSystem | Initializes a new instance of the FileSystem class.
Top

Public Methods

 | Name | Description
Public method | CreateDirectory | Attempts to create a directory.
Public method | DeleteFile | Attempts to delete a file.
Public method | DirectoryExists | Checks if a directory exists (Directory.Exists)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FileExists | Checks if a given file exists (File.Exists).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsPathRooted | Checks if a path is relative or absolute (Path.IsPathRooted).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FileSystem Class
Gallio.Utilities Namespace


FileSystem Constructor

FileSystem Constructor
[image]

Initializes a new instance of the FileSystem class.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FileSystem()
C++
public:
FileSystem() sealed
J#
public FileSystem()
JScript
public function FileSystem()

See Also

FileSystem Class
Gallio.Utilities Namespace


Methods

FileSystem Methods
[image]

Public Methods

 | Name | Description
Public method | CreateDirectory | Attempts to create a directory.
Public method | DeleteFile | Attempts to delete a file.
Public method | DirectoryExists | Checks if a directory exists (Directory.Exists)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FileExists | Checks if a given file exists (File.Exists).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsPathRooted | Checks if a path is relative or absolute (Path.IsPathRooted).
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

FileSystem Class
Gallio.Utilities Namespace


CreateDirectory Method

FileSystem.CreateDirectory Method
[image]

Attempts to create a directory.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateDirectory( _
ByVal path As String _
) _
Implements IFileSystem.CreateDirectory
C#
public void CreateDirectory(
string path
)
C++
public:
void CreateDirectory(
String path
) sealed
J#
public void CreateDirectory(
string path
)
JScript
public function CreateDirectory(
path : String
)

Parameters

path
The location of the directory.

Implements

IFileSystem.CreateDirectory

See Also

FileSystem Class
Gallio.Utilities Namespace


DeleteFile Method

FileSystem.DeleteFile Method
[image]

Attempts to delete a file.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteFile( _
ByVal path As String _
) _
Implements IFileSystem.DeleteFile
C#
public void DeleteFile(
string path
)
C++
public:
void DeleteFile(
String path
) sealed
J#
public void DeleteFile(
string path
)
JScript
public function DeleteFile(
path : String
)

Parameters

path
The location of the file.

Implements

IFileSystem.DeleteFile

See Also

FileSystem Class
Gallio.Utilities Namespace


DirectoryExists Method

FileSystem.DirectoryExists Method
[image]

Checks if a directory exists (Directory.Exists)

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function DirectoryExists( _
ByVal path As String _
) As Boolean _
Implements IFileSystem.DirectoryExists
C#
public bool DirectoryExists(
string path
)
C++
public:
bool DirectoryExists(
String path
) sealed
J#
public bool DirectoryExists(
string path
)
JScript
public function DirectoryExists(
path : String
) : bool

Parameters

path
The location of the directory.

Return Value

True if the directory exists, otherwise False.

Implements

IFileSystem.DirectoryExists

See Also

FileSystem Class
Gallio.Utilities Namespace


FileExists Method

FileSystem.FileExists Method
[image]

Checks if a given file exists (File.Exists).

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function FileExists( _
ByVal path As String _
) As Boolean _
Implements IFileSystem.FileExists
C#
public bool FileExists(
string path
)
C++
public:
bool FileExists(
String path
) sealed
J#
public bool FileExists(
string path
)
JScript
public function FileExists(
path : String
) : bool

Parameters

path
The path of the file.

Return Value

True if the file exists, otherwise False.

Implements

IFileSystem.FileExists

See Also

FileSystem Class
Gallio.Utilities Namespace


IsPathRooted Method

FileSystem.IsPathRooted Method
[image]

Checks if a path is relative or absolute (Path.IsPathRooted).

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function IsPathRooted( _
ByVal path As String _
) As Boolean _
Implements IFileSystem.IsPathRooted
C#
public bool IsPathRooted(
string path
)
C++
public:
bool IsPathRooted(
String path
) sealed
J#
public bool IsPathRooted(
string path
)
JScript
public function IsPathRooted(
path : String
) : bool

Parameters

path
The path to check.

Return Value

True if the path is absolute, otherwise False.

Implements

IFileSystem.IsPathRooted

See Also

FileSystem Class
Gallio.Utilities Namespace


FileUtils Class

FileUtils Class
See Also Example Members
[image]

Utilities for manipulating files. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module FileUtils
C#
public static class FileUtils
C++
ref class FileUtils abstract sealed
J#
public final class FileUtils
JScript
public class FileUtils

Inheritance Hierarchy

System.Object
Gallio.Utilities.FileUtils

See Also

FileUtils Members
Gallio.Utilities Namespace


FileUtils Members

FileUtils Members
See Also Example Methods
[image]

Utilities for manipulating files. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by FileUtils.

Public Methods

Name | Description
CanonicalizePath | Makes an absolute path.
CanonicalizePaths | Makes all paths in the list absolute.
CopyAll | Recursively copies files and folders from the source path to the destination.
CopyAllIndirect | Recursively copies files and folders from the source path to the destination using an indirect mechanism to actually create a file or folder.
CopyStreamContents | Copies the contents of a source stream to a destination stream.
DeleteAll | Recursively deletes a file or directory. Does nothing if the file or directory does not exist.
EncodeFileName | Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.
GetFullPathOfParentDirectory | Gets the full path of the containing directory.
StripTrailingBackslash | Strips the trailing backslash off of a directory path, if present.
Top

See Also

FileUtils Class
Gallio.Utilities Namespace


Methods

FileUtils Methods
[image]

Public Methods

Name | Description
CanonicalizePath | Makes an absolute path.
CanonicalizePaths | Makes all paths in the list absolute.
CopyAll | Recursively copies files and folders from the source path to the destination.
CopyAllIndirect | Recursively copies files and folders from the source path to the destination using an indirect mechanism to actually create a file or folder.
CopyStreamContents | Copies the contents of a source stream to a destination stream.
DeleteAll | Recursively deletes a file or directory. Does nothing if the file or directory does not exist.
EncodeFileName | Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.
GetFullPathOfParentDirectory | Gets the full path of the containing directory.
StripTrailingBackslash | Strips the trailing backslash off of a directory path, if present.
Top

See Also

FileUtils Class
Gallio.Utilities Namespace


CanonicalizePath Method

FileUtils.CanonicalizePath Method
[image]

Makes an absolute path.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CanonicalizePath( _
ByVal baseDirectory As String, _
ByVal path As String _
) As String
C#
public static string CanonicalizePath(
string baseDirectory,
string path
)
C++
public:
static String CanonicalizePath(
String baseDirectory,
String path
)
J#
public static string CanonicalizePath(
string baseDirectory,
string path
)
JScript
public static function CanonicalizePath(
baseDirectory : String,
path : String
) : String

Parameters

baseDirectory
The base directory for resolving relative paths, or null to use the current directory
path
The path to canonicalize, or null if none

Return Value

The absolute path, or null if none

See Also

FileUtils Class
Gallio.Utilities Namespace


CanonicalizePaths Method

FileUtils.CanonicalizePaths Method
[image]

Makes all paths in the list absolute.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CanonicalizePaths( _
ByVal baseDirectory As String, _
ByVal paths As IList(Of String) _
)
C#
public static void CanonicalizePaths(
string baseDirectory,
IList<string> paths
)
C++
public:
static void CanonicalizePaths(
String baseDirectory,
IList<string> paths
)
J#
public static void CanonicalizePaths(
string baseDirectory,
IList<string> paths
)
JScript
public static function CanonicalizePaths(
baseDirectory : String,
paths : IList<string>
)

Parameters

baseDirectory
The base directory for resolving relative paths, or null to use the current directory
paths
The list of paths to canonicalize in place

See Also

FileUtils Class
Gallio.Utilities Namespace


CopyAll Method

FileUtils.CopyAll Method
[image]

Recursively copies files and folders from the source path to the destination.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyAll( _
ByVal sourcePath As String, _
ByVal destPath As String, _
ByVal overwrite As Boolean _
)
C#
public static void CopyAll(
string sourcePath,
string destPath,
bool overwrite
)
C++
public:
static void CopyAll(
String sourcePath,
String destPath,
bool overwrite
)
J#
public static void CopyAll(
string sourcePath,
string destPath,
bool overwrite
)
JScript
public static function CopyAll(
sourcePath : String,
destPath : String,
overwrite : bool
)

Parameters

sourcePath
The source file or directory path
destPath
The destination file or directory path
overwrite
If true, overwrites existing files in the destination

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sourcePath or destPath is null

See Also

FileUtils Class
Gallio.Utilities Namespace


CopyAllIndirect Method

FileUtils.CopyAllIndirect Method
[image]

Recursively copies files and folders from the source path to the destination using an indirect mechanism to actually create a file or folder.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyAllIndirect( _
ByVal sourcePath As String, _
ByVal destPath As String, _
ByVal createDirectoryAction As Action(Of String), _
ByVal copyFileAction As Action(Of String, String) _
)
C#
public static void CopyAllIndirect(
string sourcePath,
string destPath,
Action<string> createDirectoryAction,
Action<string, string> copyFileAction
)
C++
public:
static void CopyAllIndirect(
String sourcePath,
String destPath,
Action<string> createDirectoryAction,
Action<string, string> copyFileAction
)
J#
public static void CopyAllIndirect(
string sourcePath,
string destPath,
Action<string> createDirectoryAction,
Action<string, string> copyFileAction
)
JScript
public static function CopyAllIndirect(
sourcePath : String,
destPath : String,
createDirectoryAction : Action<string>,
copyFileAction : Action<string, string>
)

Parameters

sourcePath
The source file or directory path
destPath
The destination file or directory path
createDirectoryAction
A delegate used to create a directory with a given destination directory path, or null to do nothing
copyFileAction
A delegate used to copy a source file to a given destination file path, or null to do nothing

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sourcePath or destPath is null

See Also

FileUtils Class
Gallio.Utilities Namespace


CopyStreamContents Method

FileUtils.CopyStreamContents Method
[image]

Copies the contents of a source stream to a destination stream.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyStreamContents( _
ByVal sourceStream As Stream, _
ByVal destStream As Stream _
)
C#
public static void CopyStreamContents(
Stream sourceStream,
Stream destStream
)
C++
public:
static void CopyStreamContents(
Stream sourceStream,
Stream destStream
)
J#
public static void CopyStreamContents(
Stream sourceStream,
Stream destStream
)
JScript
public static function CopyStreamContents(
sourceStream : Stream,
destStream : Stream
)

Parameters

sourceStream
The source stream
destStream
The destination stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if sourceStream or destStream is null

Remarks

Does not close either stream.

See Also

FileUtils Class
Gallio.Utilities Namespace


DeleteAll Method

FileUtils.DeleteAll Method
[image]

Recursively deletes a file or directory. Does nothing if the file or directory does not exist.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DeleteAll( _
ByVal path As String _
)
C#
public static void DeleteAll(
string path
)
C++
public:
static void DeleteAll(
String path
)
J#
public static void DeleteAll(
string path
)
JScript
public static function DeleteAll(
path : String
)

Parameters

path
The path

See Also

FileUtils Class
Gallio.Utilities Namespace


EncodeFileName Method

FileUtils.EncodeFileName Method
[image]

Replaces invalid characters in a file or directory name with underscores and trims it if it is too long.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function EncodeFileName( _
ByVal fileName As String _
) As String
C#
public static string EncodeFileName(
string fileName
)
C++
public:
static String EncodeFileName(
String fileName
)
J#
public static string EncodeFileName(
string fileName
)
JScript
public static function EncodeFileName(
fileName : String
) : String

Parameters

fileName
The file or directory name

Return Value

The encoded file or directory name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if fileName is null

See Also

FileUtils Class
Gallio.Utilities Namespace


GetFullPathOfParentDirectory Method

FileUtils.GetFullPathOfParentDirectory Method
[image]

Gets the full path of the containing directory.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullPathOfParentDirectory( _
ByVal path As String _
) As String
C#
public static string GetFullPathOfParentDirectory(
string path
)
C++
public:
static String GetFullPathOfParentDirectory(
String path
)
J#
public static string GetFullPathOfParentDirectory(
string path
)
JScript
public static function GetFullPathOfParentDirectory(
path : String
) : String

Parameters

path
The path

Return Value

The full path of the parent directory or null if it is at the root

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null

See Also

FileUtils Class
Gallio.Utilities Namespace


StripTrailingBackslash Method

FileUtils.StripTrailingBackslash Method
[image]

Strips the trailing backslash off of a directory path, if present.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function StripTrailingBackslash( _
ByVal path As String _
) As String
C#
public static string StripTrailingBackslash(
string path
)
C++
public:
static String StripTrailingBackslash(
String path
)
J#
public static string StripTrailingBackslash(
string path
)
JScript
public static function StripTrailingBackslash(
path : String
) : String

Parameters

path
The path to strip, or null if none

Return Value

The stripped path, or null if none

See Also

FileUtils Class
Gallio.Utilities Namespace


Hash64 Structure

Hash64 Structure
See Also Example Members
[image]

A 64bit hash code value type. Provides somewhat more protection against collisions than 32 bit hashes.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure Hash64
Implements IEquatable(Of Hash64)
C#
public struct Hash64 : IEquatable<Hash64>
C++
value class Hash64 : IEquatable<Hash64>
J#
public final class Hash64 extends ValueType implements IEquatable<Hash64>
JScript
JScript suports the use of structures, but not the declaration of new ones.

Inheritance Hierarchy

System.Object
Gallio.Utilities.Hash64

See Also

Hash64 Members
Gallio.Utilities Namespace


Hash64 Members

Hash64 Members
See Also Example Constructors Methods
[image]

A 64bit hash code value type. Provides somewhat more protection against collisions than 32 bit hashes.

The following tables list the members exposed by Hash64.

Public Constructors

 | Name | Description
Public method | Hash64 | Gets a hash code containing the specified 64bit value.
Top

Public Methods

 | Name | Description
Public method | Add | Produces a new hash code by combining information from the specified string with this hash code.
 | CreateUniqueHash | Creates a proabilistically unique 64bit hash code.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Hash64 Structure
Gallio.Utilities Namespace


Hash64 Constructor

Hash64 Constructor
[image]

Gets a hash code containing the specified 64bit value.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal value As Long _
)
C#
public Hash64(
long value
)
C++
public:
Hash64(
__int64 value
) sealed
J#
public Hash64(
long value
)
JScript
public function Hash64(
value : long
)

Parameters

value
The 64bit value

See Also

Hash64 Structure
Gallio.Utilities Namespace


Methods

Hash64 Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Produces a new hash code by combining information from the specified string with this hash code.
 | CreateUniqueHash | Creates a proabilistically unique 64bit hash code.
Public method | Equals | Overloaded. Indicates whether this instance and a specified object are equal.
Public method | GetHashCode | Overridden. Returns the hash code for this instance.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden. Returns the fully qualified type name of this instance.
Top

See Also

Hash64 Structure
Gallio.Utilities Namespace


Add Method

Hash64.Add Method
[image]

Produces a new hash code by combining information from the specified string with this hash code.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal str As String _
) As Hash64
C#
public Hash64 Add(
string str
)
C++
public:
Hash64 Add(
String str
) sealed
J#
public Hash64 Add(
string str
)
JScript
public function Add(
str : String
) : Hash64

Parameters

str
The string, may be null if none

Return Value

The augmented hash code

See Also

Hash64 Structure
Gallio.Utilities Namespace


CreateUniqueHash Method

Hash64.CreateUniqueHash Method
[image]

Creates a proabilistically unique 64bit hash code.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateUniqueHash() As Hash64
C#
public static Hash64 CreateUniqueHash()
C++
public:
static Hash64 CreateUniqueHash()
J#
public static Hash64 CreateUniqueHash()
JScript
public static function CreateUniqueHash() : Hash64

See Also

Hash64 Structure
Gallio.Utilities Namespace


Equals Method

Hash64.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

 | Name | Description
Public method | Equals (Hash64) | Indicates whether this instance and a specified object are equal.
Public method | Equals (Object) | Overridden. Indicates whether this instance and a specified object are equal.

See Also

Hash64 Structure
Gallio.Utilities Namespace


Equals Method (Hash64)

Hash64.Equals Method (Hash64)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As Hash64 _
) As Boolean _
Implements IEquatable<Hash64>.Equals
C#
public bool Equals(
Hash64 other
)
C++
public:
bool Equals(
Hash64 other
) sealed
J#
public bool Equals(
Hash64 other
)
JScript
public function Equals(
other : Hash64
) : bool

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

Implements

IEquatable<Hash64>.Equals

See Also

Hash64 Structure
Gallio.Utilities Namespace
Hash64.Equals Overload List


Equals Method (Object)

Hash64.Equals Method (Object)
See Also Example
[image]

Indicates whether this instance and a specified object are equal.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
object obj
)
C++
public:
virtual bool Equals(
Object obj
) override
J#
public override bool Equals(
object obj
)
JScript
public override function Equals(
obj : Object
) : bool

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Hash64 Structure
Gallio.Utilities Namespace
Hash64.Equals Overload List


GetHashCode Method

Hash64.GetHashCode Method
[image]

Returns the hash code for this instance.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Hash64 Structure
Gallio.Utilities Namespace


ToString Method

Hash64.ToString Method
[image]

Returns the fully qualified type name of this instance.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

A String containing a fully qualified type name.

See Also

Hash64 Structure
Gallio.Utilities Namespace


IFileSystem Interface

IFileSystem Interface
See Also Example Members
[image]

Wrapper for static System.IO.File operations to allow testing.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFileSystem
C#
public interface IFileSystem
C++
interface class IFileSystem
J#
public interface IFileSystem
JScript
public interface IFileSystem

Types that implement IFileSystem

Type | Description
Gallio.Utilities.FileSystem | Default implementation of IFileSystem using System.IO classes.

See Also

IFileSystem Members
Gallio.Utilities Namespace


IFileSystem Members

IFileSystem Members
See Also Example Methods
[image]

Wrapper for static System.IO.File operations to allow testing.

The following tables list the members exposed by IFileSystem.

Public Methods

 | Name | Description
Public method | CreateDirectory | Attempts to create a directory.
Public method | DeleteFile | Attempts to delete a file.
Public method | DirectoryExists | Checks if a directory exists (Directory.Exists)
Public method | FileExists | Checks if a given file exists (File.Exists).
Public method | IsPathRooted | Checks if a path is relative or absolute (Path.IsPathRooted).
Top

See Also

IFileSystem Interface
Gallio.Utilities Namespace


Methods

IFileSystem Methods
[image]

Public Methods

 | Name | Description
Public method | CreateDirectory | Attempts to create a directory.
Public method | DeleteFile | Attempts to delete a file.
Public method | DirectoryExists | Checks if a directory exists (Directory.Exists)
Public method | FileExists | Checks if a given file exists (File.Exists).
Public method | IsPathRooted | Checks if a path is relative or absolute (Path.IsPathRooted).
Top

See Also

IFileSystem Interface
Gallio.Utilities Namespace


CreateDirectory Method

IFileSystem.CreateDirectory Method
[image]

Attempts to create a directory.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub CreateDirectory( _
ByVal path As String _
)
C#
void CreateDirectory(
string path
)
C++
void CreateDirectory(
String path
) abstract
J#
void CreateDirectory(
string path
)
JScript
function CreateDirectory(
path : String
)

Parameters

path
The location of the directory.

See Also

IFileSystem Interface
Gallio.Utilities Namespace


DeleteFile Method

IFileSystem.DeleteFile Method
[image]

Attempts to delete a file.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteFile( _
ByVal path As String _
)
C#
void DeleteFile(
string path
)
C++
void DeleteFile(
String path
) abstract
J#
void DeleteFile(
string path
)
JScript
function DeleteFile(
path : String
)

Parameters

path
The location of the file.

See Also

IFileSystem Interface
Gallio.Utilities Namespace


DirectoryExists Method

IFileSystem.DirectoryExists Method
[image]

Checks if a directory exists (Directory.Exists)

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function DirectoryExists( _
ByVal path As String _
) As Boolean
C#
bool DirectoryExists(
string path
)
C++
bool DirectoryExists(
String path
) abstract
J#
bool DirectoryExists(
string path
)
JScript
function DirectoryExists(
path : String
) : bool

Parameters

path
The location of the directory.

Return Value

True if the directory exists, otherwise False.

See Also

IFileSystem Interface
Gallio.Utilities Namespace


FileExists Method

IFileSystem.FileExists Method
[image]

Checks if a given file exists (File.Exists).

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function FileExists( _
ByVal path As String _
) As Boolean
C#
bool FileExists(
string path
)
C++
bool FileExists(
String path
) abstract
J#
bool FileExists(
string path
)
JScript
function FileExists(
path : String
) : bool

Parameters

path
The path of the file.

Return Value

True if the file exists, otherwise False.

See Also

IFileSystem Interface
Gallio.Utilities Namespace


IsPathRooted Method

IFileSystem.IsPathRooted Method
[image]

Checks if a path is relative or absolute (Path.IsPathRooted).

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function IsPathRooted( _
ByVal path As String _
) As Boolean
C#
bool IsPathRooted(
string path
)
C++
bool IsPathRooted(
String path
) abstract
J#
bool IsPathRooted(
string path
)
JScript
function IsPathRooted(
path : String
) : bool

Parameters

path
The path to check.

Return Value

True if the path is absolute, otherwise False.

See Also

IFileSystem Interface
Gallio.Utilities Namespace


IXmlSerializer Interface

IXmlSerializer Interface
See Also Example Members
[image]

Wrapper for XmlSerializationUtils static methods (allows testing).

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Interface IXmlSerializer
C#
public interface IXmlSerializer
C++
interface class IXmlSerializer
J#
public interface IXmlSerializer
JScript
public interface IXmlSerializer

Types that implement IXmlSerializer

Type | Description
Gallio.Utilities.DefaultXmlSerializer | Default IXmlSerializer implementation.

See Also

IXmlSerializer Members
Gallio.Utilities Namespace


IXmlSerializer Members

IXmlSerializer Members
See Also Example Methods
[image]

Wrapper for XmlSerializationUtils static methods (allows testing).

The following tables list the members exposed by IXmlSerializer.

Public Methods

 | Name | Description
Public method | LoadFromXml | Loads an object graph from an Xml file using XmlSerializer.
Public method | SaveToXml | Saves an object graph to a pretty-printed Xml file using XmlSerializer.
Top

See Also

IXmlSerializer Interface
Gallio.Utilities Namespace


Methods

IXmlSerializer Methods
[image]

Public Methods

 | Name | Description
Public method | LoadFromXml | Loads an object graph from an Xml file using XmlSerializer.
Public method | SaveToXml | Saves an object graph to a pretty-printed Xml file using XmlSerializer.
Top

See Also

IXmlSerializer Interface
Gallio.Utilities Namespace


LoadFromXml Generic Method

IXmlSerializer.LoadFromXml Generic Method
[image]

Loads an object graph from an Xml file using XmlSerializer.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Function LoadFromXml(Of T)( _
ByVal filename As String _
)
C#
T LoadFromXml<T>(
string filename
)
C++
T LoadFromXml<T>(
String filename
) abstract
J#
T LoadFromXml<T>(
string filename
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The root object type

Parameters

filename
The filename

Return Value

The root object

See Also

IXmlSerializer Interface
Gallio.Utilities Namespace


SaveToXml Generic Method

IXmlSerializer.SaveToXml Generic Method
[image]

Saves an object graph to a pretty-printed Xml file using XmlSerializer.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Sub SaveToXml(Of T)( _
ByVal root As T, _
ByVal filename As String _
)
C#
void SaveToXml<T>(
T root,
string filename
)
C++
void SaveToXml<T>(
T root,
String filename
) abstract
J#
void SaveToXml<T>(
T root,
string filename
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The root object type

Parameters

root
The root object
filename
The filename

See Also

IXmlSerializer Interface
Gallio.Utilities Namespace


KeyedMemoizer Generic Structure

KeyedMemoizer Generic Structure
See Also Example Members
[image]

A structure that memoizes the result of some computation for later reuse. Maintains an internal dictionary to memoize results by key.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure KeyedMemoizer(Of TKey, TValue)
C#
public struct KeyedMemoizer<TKey, TValue>
C++
value class KeyedMemoizer<TKey, TValue>
J#
public final class KeyedMemoizer<TKey, TValue> extends ValueType
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The key type
TValue
The value type

Example

Copy Code
            public class MyClass
            {
                // Do NOT put the "readonly" keyword on this field.
                // Otherwise we will not be able to modify the contents of the structure and memoization will not occur.
                private KeyedMemoizer<string, int> valueMemoizer = new KeyedMemoizer<string, int>();

                public int GetValue(string key)
                {
                    return valueMemoizer.Memoize(key, () =>
                    {
                        // Expensive calculation here.
                        return 42;
                    });
                }
            }

Remarks

Not thread safe.

Inheritance Hierarchy

System.Object
Gallio.Utilities.KeyedMemoizer<TKey,TValue>

See Also

KeyedMemoizer<TKey,TValue> Members
Gallio.Utilities Namespace


KeyedMemoizer<TKey,TValue> Members

KeyedMemoizer Members
See Also Example Methods
[image]

A structure that memoizes the result of some computation for later reuse. Maintains an internal dictionary to memoize results by key.

The following tables list the members exposed by KeyedMemoizer<TKey,TValue>.

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Memoize | Gets the memoized value for the given key if available, otherwise populates it using the specified populator function and stores it in association with its keys for later reuse.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

KeyedMemoizer<TKey,TValue> Structure
Gallio.Utilities Namespace


Methods

KeyedMemoizer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Memoize | Gets the memoized value for the given key if available, otherwise populates it using the specified populator function and stores it in association with its keys for later reuse.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

KeyedMemoizer<TKey,TValue> Structure
Gallio.Utilities Namespace


Memoize Method

KeyedMemoizer.Memoize Method
[image]

Gets the memoized value for the given key if available, otherwise populates it using the specified populator function and stores it in association with its keys for later reuse.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Memoize( _
ByVal key As TKey, _
ByVal populator As Func(Of TValue) _
)
C#
public TValue Memoize(
TKey key,
Func<TValue> populator
)
C++
public:
TValue Memoize(
TKey key,
Func<TValue> populator
) sealed
J#
public TValue Memoize(
TKey key,
Func<TValue> populator
)
JScript
JScript does not support generic types and methods.

Parameters

key
The key by which to look up a memoized result
populator
The populator for the value associated with the key

Return Value

The value returned by the populator, possibly memoized

See Also

KeyedMemoizer<TKey,TValue> Structure
Gallio.Utilities Namespace


Memoizer Generic Structure

Memoizer Generic Structure
See Also Example Members
[image]

A structure that memoizes the result of some computation for later reuse.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Structure Memoizer(Of T)
C#
public struct Memoizer<T>
C++
value class Memoizer<T>
J#
public final class Memoizer<T> extends ValueType
JScript
JScript does not support generic types and methods.

Type Parameters

T
The value type

Example

Copy Code
            public class MyClass
            {
                // Do NOT put the "readonly" keyword on this field.
                // Otherwise we will not be able to modify the contents of the structure and memoization will not occur.
                private Memoizer<int> valueMemoizer = new Memoizer<int>();

                public int GetValue()
                {
                    return valueMemoizer.Memoize(() =>
                    {
                        // Expensive calculation here.
                        return 42;
                    });
                }
            }

Remarks

Not thread safe.

Inheritance Hierarchy

System.Object
Gallio.Utilities.Memoizer<T>

See Also

Memoizer<T> Members
Gallio.Utilities Namespace


Memoizer<T> Members

Memoizer Members
See Also Example Methods
[image]

A structure that memoizes the result of some computation for later reuse.

The following tables list the members exposed by Memoizer<T>.

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Memoize | Gets the memoized value if available, otherwise populates it using the specified populator function and stores it for later reuse.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

Memoizer<T> Structure
Gallio.Utilities Namespace


Methods

Memoizer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Memoize | Gets the memoized value if available, otherwise populates it using the specified populator function and stores it for later reuse.
Public method | ToString | Returns the fully qualified type name of this instance. (inherited from ValueType)
Top

See Also

Memoizer<T> Structure
Gallio.Utilities Namespace


Memoize Method

Memoizer.Memoize Method
[image]

Gets the memoized value if available, otherwise populates it using the specified populator function and stores it for later reuse.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Function Memoize( _
ByVal populator As Func(Of T) _
)
C#
public T Memoize(
Func<T> populator
)
C++
public:
T Memoize(
Func<T> populator
) sealed
J#
public T Memoize(
Func<T> populator
)
JScript
JScript does not support generic types and methods.

Parameters

populator
The populator

Return Value

The value returned by the populator, possibly memoized

See Also

Memoizer<T> Structure
Gallio.Utilities Namespace


StringUtils Class

StringUtils Class
See Also Example Members
[image]

Provides utility functions for working with strings. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module StringUtils
C#
public static class StringUtils
C++
ref class StringUtils abstract sealed
J#
public final class StringUtils
JScript
public class StringUtils

Inheritance Hierarchy

System.Object
Gallio.Utilities.StringUtils

See Also

StringUtils Members
Gallio.Utilities Namespace


StringUtils Members

StringUtils Members
See Also Example Methods
[image]

Provides utility functions for working with strings. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by StringUtils.

Public Methods

Name | Description
ParseArguments | Parses a string of whitespace delimited and possibly quoted arguments and returns an array of each one unquoted.
ParseKeyValuePair | Parses a key/value pair from an input string of the form "key=value", with the value optionally quoted and optional surrounding whitespace removed.
ToCharLiteral | Formats a character value as "'x'" or "'\n'" with support for escaped characters as a valid literal value. Encloses the char in single quotes (').
ToHexDigit | Gets a lowercase hexadecimal digit corresponding to the least significant nybble of the specified value.
ToStringLiteral | Formats a string value as ""abc\ndef"" with support for escaped characters as a valid literal value. Encloses the string in quotes (").
ToUnquotedCharLiteral | Escapes a character value as "x" or "\n". Unlike ToCharLiteral, does not enclose the literal in single quotes (').
ToUnquotedStringLiteral | Escapes a string value such as "abc\ndef". Unlike ToStringLiteral, does not enclose the literal in quotes (").
Truncate | Truncates the string to the specified maximum length. Discards characters at the end of the string with indices greater than or equal to maxLength.
TruncateWithEllipsis | If the string is longer than the specified maximum length, truncates it and appends an ellipsis mark ("..."). If the maximum length is less than or equal to 3, omits the ellipsis mark on truncation.
Top

See Also

StringUtils Class
Gallio.Utilities Namespace


Methods

StringUtils Methods
[image]

Public Methods

Name | Description
ParseArguments | Parses a string of whitespace delimited and possibly quoted arguments and returns an array of each one unquoted.
ParseKeyValuePair | Parses a key/value pair from an input string of the form "key=value", with the value optionally quoted and optional surrounding whitespace removed.
ToCharLiteral | Formats a character value as "'x'" or "'\n'" with support for escaped characters as a valid literal value. Encloses the char in single quotes (').
ToHexDigit | Gets a lowercase hexadecimal digit corresponding to the least significant nybble of the specified value.
ToStringLiteral | Formats a string value as ""abc\ndef"" with support for escaped characters as a valid literal value. Encloses the string in quotes (").
ToUnquotedCharLiteral | Escapes a character value as "x" or "\n". Unlike ToCharLiteral, does not enclose the literal in single quotes (').
ToUnquotedStringLiteral | Escapes a string value such as "abc\ndef". Unlike ToStringLiteral, does not enclose the literal in quotes (").
Truncate | Truncates the string to the specified maximum length. Discards characters at the end of the string with indices greater than or equal to maxLength.
TruncateWithEllipsis | If the string is longer than the specified maximum length, truncates it and appends an ellipsis mark ("..."). If the maximum length is less than or equal to 3, omits the ellipsis mark on truncation.
Top

See Also

StringUtils Class
Gallio.Utilities Namespace


ParseArguments Method

StringUtils.ParseArguments Method
[image]

Parses a string of whitespace delimited and possibly quoted arguments and returns an array of each one unquoted.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseArguments( _
ByVal arguments As String _
) As String()
C#
public static string[] ParseArguments(
string arguments
)
C++
public:
static array<String>^ ParseArguments(
String arguments
)
J#
public static string[] ParseArguments(
string arguments
)
JScript
public static function ParseArguments(
arguments : String
) : String[]

Parameters

arguments
The arguments string, eg. "/foo 'quoted arg' /bar

Return Value

The parsed and unquoted arguments

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if arguments is null

See Also

StringUtils Class
Gallio.Utilities Namespace


ParseKeyValuePair Method

StringUtils.ParseKeyValuePair Method
[image]

Parses a key/value pair from an input string of the form "key=value", with the value optionally quoted and optional surrounding whitespace removed.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseKeyValuePair( _
ByVal input As String _
) As KeyValuePair(Of String, String)
C#
public static KeyValuePair<string, string> ParseKeyValuePair(
string input
)
C++
public:
static KeyValuePair<string, string> ParseKeyValuePair(
String input
)
J#
public static KeyValuePair<string, string> ParseKeyValuePair(
string input
)
JScript
public static function ParseKeyValuePair(
input : String
) : KeyValuePair<string, string>

Parameters

input
The input string

Return Value

The key value pair

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if input is null

Remarks

If the value is quoted, the outermost quotes will be removed. If the equals or value is absent then an empty string will be used as the value. Also trims whitespace around the key and value.

See Also

StringUtils Class
Gallio.Utilities Namespace


ToCharLiteral Method

StringUtils.ToCharLiteral Method
[image]

Formats a character value as "'x'" or "'\n'" with support for escaped characters as a valid literal value. Encloses the char in single quotes (').

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToCharLiteral( _
ByVal value As Char _
) As String
C#
public static string ToCharLiteral(
char value
)
C++
public:
static String ToCharLiteral(
wchar_t value
)
J#
public static string ToCharLiteral(
char value
)
JScript
public static function ToCharLiteral(
value : char
) : String

Parameters

value
The character value to format

Return Value

The formatted character

Remarks

Replaces common escaped characters with C# style escape codes. Unprintable characters are represented by a Unicode character escape.

See Also

StringUtils Class
Gallio.Utilities Namespace


ToHexDigit Method

StringUtils.ToHexDigit Method
[image]

Gets a lowercase hexadecimal digit corresponding to the least significant nybble of the specified value.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToHexDigit( _
ByVal value As Integer _
) As Char
C#
public static char ToHexDigit(
int value
)
C++
public:
static wchar_t ToHexDigit(
int value
)
J#
public static char ToHexDigit(
int value
)
JScript
public static function ToHexDigit(
value : int
) : char

Parameters

value
The value, only the last 4 bits of which are used

Return Value

The hexadecimal digit

See Also

StringUtils Class
Gallio.Utilities Namespace


ToStringLiteral Method

StringUtils.ToStringLiteral Method
[image]

Formats a string value as ""abc\ndef"" with support for escaped characters as a valid literal value. Encloses the string in quotes (").

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToStringLiteral( _
ByVal value As String _
) As String
C#
public static string ToStringLiteral(
string value
)
C++
public:
static String ToStringLiteral(
String value
)
J#
public static string ToStringLiteral(
string value
)
JScript
public static function ToStringLiteral(
value : String
) : String

Parameters

value
The string value to format

Return Value

The formatted string

Remarks

Replaces common escaped characters with C# style escape codes. Unprintable characters are represented by a Unicode character escape.

See Also

StringUtils Class
Gallio.Utilities Namespace


ToUnquotedCharLiteral Method

StringUtils.ToUnquotedCharLiteral Method
[image]

Escapes a character value as "x" or "\n". Unlike ToCharLiteral, does not enclose the literal in single quotes (').

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToUnquotedCharLiteral( _
ByVal value As Char _
) As String
C#
public static string ToUnquotedCharLiteral(
char value
)
C++
public:
static String ToUnquotedCharLiteral(
wchar_t value
)
J#
public static string ToUnquotedCharLiteral(
char value
)
JScript
public static function ToUnquotedCharLiteral(
value : char
) : String

Parameters

value
The character value to format

Return Value

The unquoted char literal

Remarks

Replaces common escaped characters with C# style escape codes. Unprintable characters are represented by a Unicode character escape.

See Also

StringUtils Class
Gallio.Utilities Namespace


ToUnquotedStringLiteral Method

StringUtils.ToUnquotedStringLiteral Method
[image]

Escapes a string value such as "abc\ndef". Unlike ToStringLiteral, does not enclose the literal in quotes (").

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToUnquotedStringLiteral( _
ByVal value As String _
) As String
C#
public static string ToUnquotedStringLiteral(
string value
)
C++
public:
static String ToUnquotedStringLiteral(
String value
)
J#
public static string ToUnquotedStringLiteral(
string value
)
JScript
public static function ToUnquotedStringLiteral(
value : String
) : String

Parameters

value
The string value to format

Return Value

The unquoted string literal

Remarks

Replaces common escaped characters with C# style escape codes. Unprintable characters are represented by a Unicode character escape.

See Also

StringUtils Class
Gallio.Utilities Namespace


Truncate Method

StringUtils.Truncate Method
[image]

Truncates the string to the specified maximum length. Discards characters at the end of the string with indices greater than or equal to maxLength.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Truncate( _
ByVal str As String, _
ByVal maxLength As Integer _
) As String
C#
public static string Truncate(
string str,
int maxLength
)
C++
public:
static String Truncate(
String str,
int maxLength
)
J#
public static string Truncate(
string str,
int maxLength
)
JScript
public static function Truncate(
str : String,
maxLength : int
) : String

Parameters

str
The string to truncate
maxLength
The maximum length of the string to retain

Return Value

The truncated string

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if str is null
ArgumentOutOfRangeException | Thrown if maxLength is negative

See Also

StringUtils Class
Gallio.Utilities Namespace


TruncateWithEllipsis Method

StringUtils.TruncateWithEllipsis Method
[image]

If the string is longer than the specified maximum length, truncates it and appends an ellipsis mark ("..."). If the maximum length is less than or equal to 3, omits the ellipsis mark on truncation.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function TruncateWithEllipsis( _
ByVal str As String, _
ByVal maxLength As Integer _
) As String
C#
public static string TruncateWithEllipsis(
string str,
int maxLength
)
C++
public:
static String TruncateWithEllipsis(
String str,
int maxLength
)
J#
public static string TruncateWithEllipsis(
string str,
int maxLength
)
JScript
public static function TruncateWithEllipsis(
str : String,
maxLength : int
) : String

Parameters

str
The string to truncate
maxLength
The maximum length of the string to retain including the ellipsis mark when used

Return Value

The truncated string

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if str is null
ArgumentOutOfRangeException | Thrown if maxLength is negative

See Also

StringUtils Class
Gallio.Utilities Namespace


Sync Class

Sync Class
[image]

Provides helpers for cross-thread synchronization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module Sync
C#
public static class Sync
C++
ref class Sync abstract sealed
J#
public final class Sync
JScript
public class Sync

Inheritance Hierarchy

System.Object
Gallio.Utilities.Sync

See Also

Sync Members
Gallio.Utilities Namespace


Sync Members

Sync Members
[image]

Provides helpers for cross-thread synchronization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Sync.

Public Methods

Name | Description
Invoke | Overloaded. Synchronizes an action.
Top

See Also

Sync Class
Gallio.Utilities Namespace


Methods

Sync Methods
[image]

Public Methods

Name | Description
Invoke | Overloaded. Synchronizes an action.
Top

See Also

Sync Class
Gallio.Utilities Namespace


Invoke Method

Sync.Invoke Method

Synchronizes an action.

Overload List

Name | Description
Invoke (ISynchronizeInvoke, Action) | Synchronizes an action.
Invoke (ISynchronizeInvoke, Func<T>) | Synchronizes a function that returns a value.

See Also

Sync Class
Gallio.Utilities Namespace


Invoke Method (ISynchronizeInvoke, Action)

Sync.Invoke Method (ISynchronizeInvoke, Action)
See Also Example
[image]

Synchronizes an action.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Invoke( _
ByVal invoker As ISynchronizeInvoke, _
ByVal action As Action _
)
C#
public static void Invoke(
ISynchronizeInvoke invoker,
Action action
)
C++
public:
static void Invoke(
ISynchronizeInvoke invoker,
Action action
)
J#
public static void Invoke(
ISynchronizeInvoke invoker,
Action action
)
JScript
public static function Invoke(
invoker : ISynchronizeInvoke,
action : Action
)

Parameters

invoker
The invoker, such as a WinForms control
action
The action

Exceptions

Exception Type | Condition
Exception | The exception thrown by the action

See Also

Sync Class
Gallio.Utilities Namespace
Sync.Invoke Overload List


Invoke Generic Method (ISynchronizeInvoke, Generic Func)

Sync.Invoke Generic Method (ISynchronizeInvoke, Generic Func)
See Also Example
[image]

Synchronizes a function that returns a value.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Invoke(Of T)( _
ByVal invoker As ISynchronizeInvoke, _
ByVal func As Func(Of T) _
)
C#
public static T Invoke<T>(
ISynchronizeInvoke invoker,
Func<T> func
)
C++
public:
static T Invoke<T>(
ISynchronizeInvoke invoker,
Func<T> func
)
J#
public static T Invoke<T>(
ISynchronizeInvoke invoker,
Func<T> func
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The function return type

Parameters

invoker
The invoker, such as a WinForms control
func
The function

Return Value

The value returned by the function

Exceptions

Exception Type | Condition
Exception | The exception thrown by the function

See Also

Sync Class
Gallio.Utilities Namespace
Sync.Invoke Overload List


XmlSerializationUtils Class

XmlSerializationUtils Class
See Also Example Members
[image]

Utilities and constants used for serialization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module XmlSerializationUtils
C#
public static class XmlSerializationUtils
C++
ref class XmlSerializationUtils abstract sealed
J#
public final class XmlSerializationUtils
JScript
public class XmlSerializationUtils

Inheritance Hierarchy

System.Object
Gallio.Utilities.XmlSerializationUtils

See Also

XmlSerializationUtils Members
Gallio.Utilities Namespace


XmlSerializationUtils Members

XmlSerializationUtils Members
See Also Example Fields Methods
[image]

Utilities and constants used for serialization. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by XmlSerializationUtils.

Public Fields

Name | Description
GallioNamespace | The XML namespace for all Gallio XML types. This field is constant and read-only.
Top

Public Methods

Name | Description
LoadFromXml | Loads an object graph from an Xml file using XmlSerializer.
SaveToXml | Saves an object graph to a pretty-printed Xml file using XmlSerializer.
Top

See Also

XmlSerializationUtils Class
Gallio.Utilities Namespace


Fields

XmlSerializationUtils Fields
[image]

Public Fields

Name | Description
GallioNamespace | The XML namespace for all Gallio XML types. This field is constant and read-only.
Top

See Also

XmlSerializationUtils Class
Gallio.Utilities Namespace


GallioNamespace Field

XmlSerializationUtils.GallioNamespace Field
[image]

The XML namespace for all Gallio XML types. This field is constant and read-only.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public const GallioNamespace As String = "http://www.gallio.org/"
C#
public const string GallioNamespace = "http://www.gallio.org/";
C++
public:
const String GallioNamespace = L"http://www.gallio.org/";
J#
public const string GallioNamespace = "http://www.gallio.org/"
JScript
public const GallioNamespace : String = "http://www.gallio.org/";

See Also

XmlSerializationUtils Class
Gallio.Utilities Namespace


Methods

XmlSerializationUtils Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads an object graph from an Xml file using XmlSerializer.
SaveToXml | Saves an object graph to a pretty-printed Xml file using XmlSerializer.
Top

See Also

XmlSerializationUtils Class
Gallio.Utilities Namespace


LoadFromXml Generic Method

XmlSerializationUtils.LoadFromXml Generic Method
[image]

Loads an object graph from an Xml file using XmlSerializer.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function LoadFromXml(Of T)( _
ByVal filename As String _
)
C#
public static T LoadFromXml<T>(
string filename
)
C++
public:
static T LoadFromXml<T>(
String filename
)
J#
public static T LoadFromXml<T>(
string filename
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The root object type

Parameters

filename
The filename

Return Value

The root object

See Also

XmlSerializationUtils Class
Gallio.Utilities Namespace


SaveToXml Generic Method

XmlSerializationUtils.SaveToXml Generic Method
[image]

Saves an object graph to a pretty-printed Xml file using XmlSerializer.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SaveToXml(Of T)( _
ByVal root As T, _
ByVal filename As String _
)
C#
public static void SaveToXml<T>(
T root,
string filename
)
C++
public:
static void SaveToXml<T>(
T root,
String filename
)
J#
public static void SaveToXml<T>(
T root,
string filename
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The root object type

Parameters

root
The root object
filename
The filename

See Also

XmlSerializationUtils Class
Gallio.Utilities Namespace


XmlUtils Class

XmlUtils Class
See Also Example Members
[image]

Provides utilities for manipulating Xml. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Module XmlUtils
C#
public static class XmlUtils
C++
ref class XmlUtils abstract sealed
J#
public final class XmlUtils
JScript
public class XmlUtils

Inheritance Hierarchy

System.Object
Gallio.Utilities.XmlUtils

See Also

XmlUtils Members
Gallio.Utilities Namespace


XmlUtils Members

XmlUtils Members
See Also Example Methods
[image]

Provides utilities for manipulating Xml. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by XmlUtils.

Public Methods

Name | Description
WriteToXPathDocument | Produces an XPathDocument given an action applied to an XmlWriter.
Top

See Also

XmlUtils Class
Gallio.Utilities Namespace


Methods

XmlUtils Methods
[image]

Public Methods

Name | Description
WriteToXPathDocument | Produces an XPathDocument given an action applied to an XmlWriter.
Top

See Also

XmlUtils Class
Gallio.Utilities Namespace


WriteToXPathDocument Method

XmlUtils.WriteToXPathDocument Method
[image]

Produces an XPathDocument given an action applied to an XmlWriter.

Namespace: Gallio.Utilities
Assembly: Gallio (in Gallio.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function WriteToXPathDocument( _
ByVal writeAction As Action(Of XmlWriter) _
) As XPathDocument
C#
public static XPathDocument WriteToXPathDocument(
Action<XmlWriter> writeAction
)
C++
public:
static XPathDocument WriteToXPathDocument(
Action<XmlWriter> writeAction
)
J#
public static XPathDocument WriteToXPathDocument(
Action<XmlWriter> writeAction
)
JScript
public static function WriteToXPathDocument(
writeAction : Action<XmlWriter>
) : XPathDocument

Parameters

writeAction
The action to perform

Return Value

The XPathDocument

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if writeAction is null

See Also

XmlUtils Class
Gallio.Utilities Namespace


MbUnit.Core

MbUnit.Core Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | MbUnitTestFrameworkExtension | A IPatternTestFrameworkExtension that registers MbUnit as a tool when the test assembly contains a reference to the MbUnit assembly.


MbUnitTestFrameworkExtension Class

MbUnitTestFrameworkExtension Class
See Also Example Members
[image]

A IPatternTestFrameworkExtension that registers MbUnit as a tool when the test assembly contains a reference to the MbUnit assembly.

Namespace: MbUnit.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class MbUnitTestFrameworkExtension
Inherits BasePatternTestFrameworkExtension
C#
public class MbUnitTestFrameworkExtension : BasePatternTestFrameworkExtension
C++
ref class MbUnitTestFrameworkExtension : BasePatternTestFrameworkExtension
J#
public class MbUnitTestFrameworkExtension extends BasePatternTestFrameworkExtension
JScript
public class MbUnitTestFrameworkExtension extends BasePatternTestFrameworkExtension

Inheritance Hierarchy

System.Object
Gallio.Framework.Pattern.BasePatternTestFrameworkExtension
MbUnit.Core.MbUnitTestFrameworkExtension

See Also

MbUnitTestFrameworkExtension Members
MbUnit.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnitTestFrameworkExtension Members

MbUnitTestFrameworkExtension Members
See Also Example Constructors Methods
[image]

A IPatternTestFrameworkExtension that registers MbUnit as a tool when the test assembly contains a reference to the MbUnit assembly.

The following tables list the members exposed by MbUnitTestFrameworkExtension.

Public Constructors

 | Name | Description
Public method | MbUnitTestFrameworkExtension | Initializes a new instance of the MbUnitTestFrameworkExtension class.
Top

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method GetReferencedTools Overridden.

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MbUnitTestFrameworkExtension Class
MbUnit.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnitTestFrameworkExtension Constructor

MbUnitTestFrameworkExtension Constructor
[image]

Initializes a new instance of the MbUnitTestFrameworkExtension class.

Namespace: MbUnit.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MbUnitTestFrameworkExtension()
C++
public:
MbUnitTestFrameworkExtension() sealed
J#
public MbUnitTestFrameworkExtension()
JScript
public function MbUnitTestFrameworkExtension()

See Also

MbUnitTestFrameworkExtension Class
MbUnit.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

MbUnitTestFrameworkExtension Methods
[image]

Public Methods

Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method GetReferencedTools Overridden.

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

MbUnitTestFrameworkExtension Class
MbUnit.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetReferencedTools Method

MbUnitTestFrameworkExtension.GetReferencedTools Method
[image]

Gets information about the tools that are used by the specified test assembly. The tool information will be included in the report as part of the framework node that contains the assembly.

This method is used by authors of tools that are derived from the PatternTestFramework to provide brand and version information about the tool so that it will be visible to end users.

If no tools are referenced by the assembly, it will be ignored by the PatternTestExplorer.

Namespace: MbUnit.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetReferencedTools( _
ByVal assembly As IAssemblyInfo _
) As IEnumerable(Of ToolInfo) _
Implements IPatternTestFrameworkExtension.GetReferencedTools
C#
public override IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
C++
public:
virtual IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
) override
J#
public override IEnumerable<ToolInfo> GetReferencedTools(
IAssemblyInfo assembly
)
JScript
public override function GetReferencedTools(
assembly : IAssemblyInfo
) : IEnumerable<ToolInfo>

Parameters

assembly
The test assembly

Return Value

The tool information

Implements

IPatternTestFrameworkExtension.GetReferencedTools

See Also

MbUnitTestFrameworkExtension Class
MbUnit.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnit.Framework

MbUnit.Framework Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AnnotationAttribute | Associates an annotation message of the specified type with the code element.
Public class | ApartmentStateAttribute | Sets the apartment state to be used to run the decorated test and its children unless subsequently overridden.
Public class | AssemblyFixtureAttribute | Declares that a class contains assembly-level setup and teardown methods.
Public class | AssemblyResolverAttribute | Registers a custom assembly resolver. This class cannot be inherited.
Public class | Assert | Defines a set of assertions that enable a test to verify the expected behavior of the subject under test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | AssertEx | Provides extended assertions for .Net 3.5. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | AssertOverSyntax | Defines methods used with the Over syntax for mapping assertions over complex data structures. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | AuthorAttribute | Associates the author's name and email address with a test fixture, test method, test parameter or other test component.
Public class | BindAttribute | The bind attribute overrides the default binding rules for a test parameter by specifying a different data source, a binding path or an index. At most one such attribute may appear on any given test parameter.
Public class | CategoryAttribute | Associates a category name with a test fixture, test method, test parameter or other test component. The category name can be used to classify tests and build test suites of related tests.
Public class | ColumnAttribute | Provides a column of literal values as a data source.
Public class | CombinatorialJoinAttribute | Sets the join strategy of a test to be combinatorial.
Public class | ContentAttribute | An abstract base class for data source attributes that obtain contents from a local file, manifest resource, or inline data. At most one location type may be used. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | CsvDataAttribute | Provides data from Comma Separated Values contents.
Public class | DataAttribute | An abstract base class for MbUnit attributes that contribute values to data sources along with metadata such a description or expected exception type. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | DefaultTestCaseTimeoutAttribute | Specifies the default test case timeout for all tests in the test assembly.
Public class | DegreeOfParallelismAttribute | Specifies the maximum number of concurrent threads to use when tests are run in parallel for all tests in the test assembly.
Public class | DependsOnAttribute | Creates a dependency from this test assembly, test fixture or test method on some other test fixture or test method.
Public class | DescriptionAttribute | Associates a description with a test fixture, test method, test parameter or other test component.
Public class | DynamicTestFactoryAttribute | Specifies a method that is used to generate tests dynamically at runtime.
Public class | ExpectedArgumentExceptionAttribute | Declares that the associated test is expected to throw an ArgumentException.
Public class | ExpectedArgumentNullExceptionAttribute | Declares that the associated test is expected to throw an ArgumentNullException.
Public class | ExpectedArgumentOutOfRangeExceptionAttribute | Declares that the associated test is expected to throw an ArgumentOutOfRangeException.
Public class | ExpectedExceptionAttribute | Declares that the associated test is expected to throw an exception of a particular type.
Public class | ExplicitAttribute | Indicates that a test should only be run explicitly. The test will still appear in the test tree but it will not run and it will not appear in the test results unless it is explicitly selected for execution.
Public class | FactoryAttribute | Specifies a factory member that will provide values for a data-driven test.
Public class | FixtureInitializerAttribute | Specifies a method that is to be invoked after a fixture instance has been created to complete its initialization before test fixture setup runs.
Public class | FixtureSetUpAttribute | Specifies a method that is to be invoked to set up the state of a fixture before any of its tests are executed.
Public class | FixtureTearDownAttribute | Specifies a method that is to be invoked to tear down the state of a fixture after all of its tests have been executed.
Public class | HeaderAttribute | Defines names as aliases for the columns in an indexed data source such as those that have been populated by RowAttribute or ColumnAttribute. The names may subsequently be used in data binding expressions in place of their corresponding column indices.
Public class | IgnoreAttribute | Indicates that a test is to be ignored by the framework and will not be run. The test will still appear in test reports along with the reason that it was ignored, if provided.
Public class | ImportanceAttribute | Associates a Importance with a test fixture, test method, test parameter or other test component.
Public class | JoinAttribute | An abstract class for attributes that specify the join strategy of a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | MetadataAttribute | Associates custom metadata with a test fixture, test method, test parameter or other test component. The metadata can be used for documentation, classification or dynamic customization of tests.
Public class | MultipleAssertsAttribute | Runs the test as if it were surrounded by Multiple so that multiple assertion failures within the test are tolerated.
Public class | NameAttribute | Overrides the name of a test or test parameter.
Public class | OldArrayAssert | Obsolete. Array Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | OldAssert | Obsolete. Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | OldCollectionAssert | Obsolete. Assertion helper for the ICollection class. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | OldFileAssert |
Public class | OldGenericAssert | Obsolete. Assertion class This class cannot be inherited.
Public class | OldReflectionAssert | Obsolete. Reflection Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | OldSecurityAssert | Obsolete. Security Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | OldStringAssert | Obsolete. String Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | OldXmlAssert | Obsolete. Class containing generic assert methods for XML markup This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | PairwiseJoinAttribute | Sets the join strategy of a test to be pairwise.
Public class | ParallelizableAttribute | Specifies that a test can be run in parallel with other parallelizable tests.
Public class | ParameterAttribute | Declares that a property, field, method parameter, constructor parameter, generic type parameter or generic method parameter represents a test parameter.
Public class | PendingAttribute | Indicates that a test has pending prerequisites so it will not be run. The test will still appear in test reports along with an explanation of the reason it it pending, if provided.
Public class | RepeatAttribute | Decorates a test method and causes it to be invoked repeatedly.
Public class | RollbackAttribute | Decorates a test method whose database operation must be executed within a transaction and rolled back when it has finished executing.
Public class | RowAttribute | Provides a row of literal values as a data source.
Public class | RowTestAttribute | Obsolete. Provides compatibility with MbUnit v2 row test feature.
Public class | SequentialJoinAttribute | Sets the join strategy of a test to be sequential.
Public class | SetUpAttribute | Specifies a method that is to be invoked before each test in a fixture executes to set up the state of the test. The method will run once for each test. This class cannot be inherited.
Public class | StaticTestFactoryAttribute | Specifies a method that is used to generate tests statically at test exploration time.
Public class | TearDownAttribute | Specifies a method that is to be invoked after each test in a fixture executes to tear down the state of the test. The method will run once for each test. This class cannot be inherited.
Public class | Test | Describes a test generated either at test exploration time or at test execution time by a test factory. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestAttribute | Specifies that a method represents a single test case within a fixture.
Public class | TestCase | Describes a test case generated either at test exploration time or at test execution time by a test factory.
Public class | TestDecoratorAttribute | An abstract base class for implementing new test decorator behaviors. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestDefinition | Abstract class for custom test definitions such as generated test cases and test suites. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | TestFixtureAttribute | Specifies that a class represents a test fixture. This attribute is optional.
Public class | TestFixtureReference | Describes a reference to another test fixture. This is used to enable test suites to include tests that are defined using attributes.
Public class | TestFixtureSetUpAttribute | Obsolete. Provides compatibility with MbUnit v2 test fixture set up.
Public class | TestFixtureTearDownAttribute | Obsolete. Provides compatibility with MbUnit v2 test fixture tear down.
Public class | TestsOnAttribute | Associates the name of the type under test with a test fixture, test method, test parameter or other test component.
Public class | TestSuite | Describes a test suite generated either at test exploration time or at test execution time by a test factory.
Public class | ThreadedRepeatAttribute | Decorates a test method and causes it to be invoked repeatedly on multiple concurrent threads.
Public class | TimeoutAttribute | Sets the maximum amount of time in seconds that a test or fixture is permitted to run.
Public class | XmlDataAttribute | Provides data from XML contents.

Enumerations

 | Enumeration | Description
Public enumeration | Importance | Specifies the test's relative importance which can be used for classifying tests to be executed.
Public enumeration | TestScope | Specifies the scope to which certain attributes apply.


AnnotationAttribute Class

AnnotationAttribute Class
See Also Example Members
[image]

Associates an annotation message of the specified type with the code element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.All, AllowMultiple := True, Inherited := True)>
Public Class AnnotationAttribute
Inherits AnnotationPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = True, Inherited = True)]
public class AnnotationAttribute : AnnotationPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::All, AllowMultiple = True, Inherited = True)]
ref class AnnotationAttribute : AnnotationPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = True, Inherited = True) */
public class AnnotationAttribute extends AnnotationPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.All, AllowMultiple = True, Inherited = True)
class AnnotationAttribute extends AnnotationPatternAttribute

Remarks

An annotation is a message that is associated with code. This is different from the metadata that may be associated with a test because an annotation can apply to code elements that are not tests.

For example, if an error occurs while parsing the declarative attribute structure that defines a test, then the test itself may not be added to the test tree. Instead, the Pattern Test Framework will associated an error annotation with the point of definition of the test. This annotation is displayed by the test runner as an error. Some test runners, such as the ReSharper test runner, will actually highlight the annotated element in the IDE using an error stripe.

This attribute makes it possible to add annotations to code elements declaratively.

Note: The annotation will only be added if the associated code element is traversed during the normal sequence of test exploration.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.AnnotationPatternAttribute
MbUnit.Framework.AnnotationAttribute

See Also

AnnotationAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AnnotationAttribute Members

AnnotationAttribute Members
See Also Example Constructors Properties Methods
[image]

Associates an annotation message of the specified type with the code element.

The following tables list the members exposed by AnnotationAttribute.

Public Constructors

 | Name | Description
Public method | AnnotationAttribute | Associates an annotation message of the specified type with the code element.
Top

Public Properties

Name | Description
Public property | Details | Gets or sets optional detail text of the annotation, or null if none. (inherited from AnnotationPatternAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets the annotation message. (inherited from AnnotationPatternAttribute)
Public property | Type | Gets the annotation type. (inherited from AnnotationPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from AnnotationPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Top

See Also

AnnotationAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AnnotationAttribute Constructor

AnnotationAttribute Constructor
[image]

Associates an annotation message of the specified type with the code element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As AnnotationType, _
ByVal message As String _
)
C#
public AnnotationAttribute(
AnnotationType type,
string message
)
C++
public:
AnnotationAttribute(
AnnotationType type,
String message
) sealed
J#
public AnnotationAttribute(
AnnotationType type,
string message
)
JScript
public function AnnotationAttribute(
type : AnnotationType,
message : String
)

Parameters

type
The annotation type
message
The annotation message

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if message is null

See Also

AnnotationAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ApartmentStateAttribute Class

ApartmentStateAttribute Class
See Also Example Members
[image]

Sets the apartment state to be used to run the decorated test and its children unless subsequently overridden.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ApartmentStateAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ApartmentStateAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ApartmentStateAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ApartmentStateAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ApartmentStateAttribute extends TestDecoratorPatternAttribute

Remarks

If no apartment state is specified or if it is Unknown the test will inherit the apartment state of its parent test. Consequently if the apartment state is set on the fixture then its tests will use the same apartment state unless overridden.

The default apartment state for a test assembly is STA and may be overridden by setting ApartmentStateAttribute attribute on the assembly.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.ApartmentStateAttribute

See Also

ApartmentStateAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ApartmentStateAttribute Members

ApartmentStateAttribute Members
See Also Example Constructors Properties Methods
[image]

Sets the apartment state to be used to run the decorated test and its children unless subsequently overridden.

The following tables list the members exposed by ApartmentStateAttribute.

Public Constructors

 | Name | Description
Public method | ApartmentStateAttribute | Sets the apartment state to be used to run the decorated test and its children unless subsequently overridden.
Top

Public Properties

Name | Description
Public property | ApartmentState | Gets the apartment state to be used to run the decorated test.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

ApartmentStateAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ApartmentStateAttribute Constructor

ApartmentStateAttribute Constructor
[image]

Sets the apartment state to be used to run the decorated test and its children unless subsequently overridden.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal apartmentState As ApartmentState _
)
C#
public ApartmentStateAttribute(
ApartmentState apartmentState
)
C++
public:
ApartmentStateAttribute(
ApartmentState apartmentState
) sealed
J#
public ApartmentStateAttribute(
ApartmentState apartmentState
)
JScript
public function ApartmentStateAttribute(
apartmentState : ApartmentState
)

Parameters

apartmentState
The apartment state to use

Remarks

If no apartment state is specified or if it is Unknown the test will inherit the apartment state of its parent test. Consequently if the apartment state is set on the fixture then its tests will use the same apartment state unless overridden.

The default apartment state for a test assembly is STA and may be overridden by setting ApartmentStateAttribute attribute on the assembly.

See Also

ApartmentStateAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ApartmentStateAttribute Properties
[image]

Public Properties

Name | Description
Public property | ApartmentState | Gets the apartment state to be used to run the decorated test.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

ApartmentStateAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ApartmentState Property

ApartmentStateAttribute.ApartmentState Property
[image]

Gets the apartment state to be used to run the decorated test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ApartmentState As ApartmentState
C#
public ApartmentState ApartmentState { get; }
C++
public property ApartmentState ApartmentState sealed {
ApartmentState get();
}
J#
/** property */
public ApartmentState get_ApartmentState();
JScript
public function get ApartmentState() : ApartmentState

See Also

ApartmentStateAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ApartmentStateAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

ApartmentStateAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

ApartmentStateAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

ApartmentStateAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyFixtureAttribute Class

AssemblyFixtureAttribute Class
See Also Example Members
[image]

Declares that a class contains assembly-level setup and teardown methods.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := False, Inherited := True)>
Public Class AssemblyFixtureAttribute
Inherits TestTypePatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True)]
public class AssemblyFixtureAttribute : TestTypePatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = False, Inherited = True)]
ref class AssemblyFixtureAttribute : TestTypePatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True) */
public class AssemblyFixtureAttribute extends TestTypePatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True)
class AssemblyFixtureAttribute extends TestTypePatternAttribute

Remarks

The assembly fixture attribute is applied to a class that contains setup and teardown methods that are to be applied at the assembly level. Conceptually, the AssemblyFixtureAttribute adds new behavior to an assembly-level test fixture that contains all of the test fixtures within the assembly.

The following attributes are typically used within an assembly fixture:

  • FixtureSetUpAttribute: Performs setup activities before any test fixtures within the assembly are executed.
  • FixtureTearDownAttribute: Performs teardown activities after all test fixtures within the assembly are executed.
  • SetUpAttribute: Performs setup activities before each test fixture within the assembly is executed.
  • TearDownAttribute: Performs teardown activities after eacj test fixture within the assembly is executed.

It is also possible to use other attributes as with an ordinary TestFixtureAttribute. An assembly fixture also supports data binding. When data binding is used on an assembly fixture, it will cause all test fixtures within the assembly to run once for each combination of data values used.

The class must have a public default constructor. The class may not be static.

There must only be at most one class with an AssemblyFixtureAttribute within any given assembly.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestTypePatternAttribute
MbUnit.Framework.AssemblyFixtureAttribute

See Also

AssemblyFixtureAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyFixtureAttribute Members

AssemblyFixtureAttribute Members
See Also Example Constructors Properties Methods
[image]

Declares that a class contains assembly-level setup and teardown methods.

The following tables list the members exposed by AssemblyFixtureAttribute.

Public Constructors

 | Name | Description
Public method | AssemblyFixtureAttribute | Initializes a new instance of the AssemblyFixtureAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from TestTypePatternAttribute)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from TestTypePatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultConstructorPattern | Gets the default pattern to apply to constructors that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultEventPattern | Gets the default pattern to apply to events that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultFieldPattern | Gets the default pattern to apply to fields that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultMethodPattern | Gets the default pattern to apply to methods that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultNestedTypePattern | Gets the default pattern to apply to nested types that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultPropertyPattern | Gets the default pattern to apply to properties that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestTypePatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConsumeConstructors | Consumes type constructors. (inherited from TestTypePatternAttribute)
Family method | ConsumeMembers | Consumes type members including fields, properties, methods and events. (inherited from TestTypePatternAttribute)
Family method | ConsumeNestedTypes | Consumes nested types. (inherited from TestTypePatternAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMemberBindingFlags | Gets the binding flags that should be used to enumerate non-nested type members of the type for determining their contribution to the test fixture. Instance members are only included if the type is not abstract. (inherited from TestTypePatternAttribute)
Family method | InferTestType | Infers whether the type is a test type based on its structure. Returns true if the type any associated patterns, if it has non-nested type members (subject to GetMemberBindingFlags) with patterns, if it has generic parameters with patterns, or if any of its nested types satisfy the preceding rules. (inherited from TestTypePatternAttribute)
Family method | InitializeTest | Initializes a test for a type after it has been added to the test model. The members of base types are processed before those of subtypes. (inherited from TestTypePatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Overridden. Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

AssemblyFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyFixtureAttribute Constructor

AssemblyFixtureAttribute Constructor
[image]

Initializes a new instance of the AssemblyFixtureAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AssemblyFixtureAttribute()
C++
public:
AssemblyFixtureAttribute() sealed
J#
public AssemblyFixtureAttribute()
JScript
public function AssemblyFixtureAttribute()

See Also

AssemblyFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

AssemblyFixtureAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestTypePatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConsumeConstructors | Consumes type constructors. (inherited from TestTypePatternAttribute)
Family method | ConsumeMembers | Consumes type members including fields, properties, methods and events. (inherited from TestTypePatternAttribute)
Family method | ConsumeNestedTypes | Consumes nested types. (inherited from TestTypePatternAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMemberBindingFlags | Gets the binding flags that should be used to enumerate non-nested type members of the type for determining their contribution to the test fixture. Instance members are only included if the type is not abstract. (inherited from TestTypePatternAttribute)
Family method | InferTestType | Infers whether the type is a test type based on its structure. Returns true if the type any associated patterns, if it has non-nested type members (subject to GetMemberBindingFlags) with patterns, if it has generic parameters with patterns, or if any of its nested types satisfy the preceding rules. (inherited from TestTypePatternAttribute)
Family method | InitializeTest | Initializes a test for a type after it has been added to the test model. The members of base types are processed before those of subtypes. (inherited from TestTypePatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Overridden. Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

AssemblyFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Consume Method

AssemblyFixtureAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

AssemblyFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetTestSemantics Method

AssemblyFixtureAttribute.SetTestSemantics Method
[image]

Applies semantic actions to a test to estalish its runtime behavior.

This method is called after InitializeTest.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub SetTestSemantics( _
ByVal testBuilder As ITestBuilder, _
ByVal type As ITypeInfo _
)
C#
protected override void SetTestSemantics(
ITestBuilder testBuilder,
ITypeInfo type
)
C++
protected:
virtual void SetTestSemantics(
ITestBuilder testBuilder,
ITypeInfo type
) override
J#
protected override void SetTestSemantics(
ITestBuilder testBuilder,
ITypeInfo type
)
JScript
protected override function SetTestSemantics(
testBuilder : ITestBuilder,
type : ITypeInfo
)

Parameters

testBuilder
The test builder
type
The test type

See Also

AssemblyFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

AssemblyFixtureAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal type As ITypeInfo _
)
C#
protected override void Validate(
IPatternScope containingScope,
ITypeInfo type
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
ITypeInfo type
) override
J#
protected override void Validate(
IPatternScope containingScope,
ITypeInfo type
)
JScript
protected override function Validate(
containingScope : IPatternScope,
type : ITypeInfo
)

Parameters

containingScope
The containing scope
type
The type

See Also

AssemblyFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyResolverAttribute Class

AssemblyResolverAttribute Class
See Also Example Members
[image]

Registers a custom assembly resolver. This class cannot be inherited.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := True)>
Public NotInheritable Class AssemblyResolverAttribute
Inherits TestAssemblyInitializationAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True)]
public sealed class AssemblyResolverAttribute : TestAssemblyInitializationAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = True)]
ref class AssemblyResolverAttribute sealed : TestAssemblyInitializationAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True) */
public final class AssemblyResolverAttribute extends TestAssemblyInitializationAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True)
final class AssemblyResolverAttribute extends TestAssemblyInitializationAttribute

Remarks

A custom assembly resolver allows a test assembly to augment the default assembly loading policy with custom rules.

To create a custom assembly resolver, define a resolver class that implement the IAssemblyResolver interface then apply the AssemblyResolverAttribute to the test assembly at the assembly level.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.TestAssemblyInitializationAttribute
MbUnit.Framework.AssemblyResolverAttribute

See Also

AssemblyResolverAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyResolverAttribute Members

AssemblyResolverAttribute Members
See Also Example Constructors Properties Methods
[image]

Registers a custom assembly resolver. This class cannot be inherited.

The following tables list the members exposed by AssemblyResolverAttribute.

Public Constructors

 | Name | Description
Public method | AssemblyResolverAttribute | Registers a custom assembly resolver.
Top

Public Properties

 | Name | Description
Public property | AssemblyResolverType | Gets the assembly resolver type.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Overridden. Performs early initialization for the specified assembly.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AssemblyResolverAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyResolverAttribute Constructor

AssemblyResolverAttribute Constructor
[image]

Registers a custom assembly resolver.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyResolverType As Type _
)
C#
public AssemblyResolverAttribute(
Type assemblyResolverType
)
C++
public:
AssemblyResolverAttribute(
Type assemblyResolverType
) sealed
J#
public AssemblyResolverAttribute(
Type assemblyResolverType
)
JScript
public function AssemblyResolverAttribute(
assemblyResolverType : Type
)

Parameters

assemblyResolverType
The assembly resolver type, must implement IAssemblyResolver

See Also

AssemblyResolverAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

AssemblyResolverAttribute Properties
[image]

Public Properties

 | Name | Description
Public property | AssemblyResolverType | Gets the assembly resolver type.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

AssemblyResolverAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssemblyResolverType Property

AssemblyResolverAttribute.AssemblyResolverType Property
[image]

Gets the assembly resolver type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AssemblyResolverType As Type
C#
public Type AssemblyResolverType { get; }
C++
public property Type AssemblyResolverType sealed {
Type get();
}
J#
/** property */
public Type get_AssemblyResolverType();
JScript
public function get AssemblyResolverType() : Type

See Also

AssemblyResolverAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

AssemblyResolverAttribute Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Initialize | Overridden. Performs early initialization for the specified assembly.
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AssemblyResolverAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Initialize Method

AssemblyResolverAttribute.Initialize Method
[image]

Performs early initialization for the specified assembly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Initialize( _
ByVal frameworkScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
public override void Initialize(
IPatternScope frameworkScope,
IAssemblyInfo assembly
)
C++
public:
virtual void Initialize(
IPatternScope frameworkScope,
IAssemblyInfo assembly
) override
J#
public override void Initialize(
IPatternScope frameworkScope,
IAssemblyInfo assembly
)
JScript
public override function Initialize(
frameworkScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

frameworkScope
The framework-level scope that will eventually contain the assembly-level test
assembly
The assembly to process

See Also

AssemblyResolverAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Assert Class

Assert Class
See Also Example Members
[image]

Defines a set of assertions that enable a test to verify the expected behavior of the subject under test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public MustInherit Class Assert
C#
[TestFrameworkInternalAttribute]
public abstract class Assert
C++
[TestFrameworkInternalAttribute]
ref class Assert abstract
J#
/** @attribute TestFrameworkInternalAttribute() */
public class Assert
JScript
public
TestFrameworkInternalAttribute
class Assert

Remarks

Each assertion is generally provided in at least 4 flavors distinguished by overloads:

  • A simple form that takes only the assertion parameters.
  • A simple form that accepts a custom message format string and arguments in addition to the assertion parameters.
  • A rich form that takes the assertion parameters and a custom comparer object.
  • A rich form that accepts a custom message format string and arguments in addition to the assertion parameters and a custom comparer object.

The value upon which the assertion is being evaluated is usually called the "actual value". Other parameters for the assertion are given names such as the "expected value", "unexpected value", or other terms as appropriate. In some cases where the role of a parameter is ambiguous, we may use designations such as "left" and "right" to distinguish the parameters.

The Assert class does not provide direct support for old-style collection types such as ICollection and IEnumerable. If you are using .Net 3.5 for your test projects, you may find the "Cast" function helpful.

Copy Code
            ICollection myOldCollection = subjectUnderTest.DoSomething();
            Assert.AreElementsEqual(new[] { "a", "b", "c" }, myOldCollection.Cast<string>());

Framework authors may choose to extend this class with additional assertions by creating a subclass. Alternately, new assertions can be defined in other classes.

When formatting values for inclusion in assertion failures, it is recommended to use the formatter provided by the Formatter property instead of directly calling ToString. This enables custom formatting rules to decide how best to present values of particular types and yields a more consistent user experience. In particular the AddRawLabeledValue method and its siblings automatically format values in this manner.

Inheritance Hierarchy

System.Object
MbUnit.Framework.Assert
MbUnit.Framework.AssertEx

See Also

Assert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Assert Members

Assert Members
See Also Example Constructors Properties Methods
[image]

Defines a set of assertions that enable a test to verify the expected behavior of the subject under test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Assert.

Protected Constructors

 | Name | Description
Family method | Assert | Prevents instantiation. Subclasses should likewise define their constructor to be protected.
Top

Public Properties

Name | Description
IsFailurePending | Returns true if there is a pending unreported assertion failure.
Over | Provides methods for composing assertions to map over complex data structures.
Top

Public Methods

 | Name | Description
 | AreApproximatelyEqual | Overloaded. Verifies that an actual value approximately equals some expected value to within a specified delta.
 | AreElementsEqual | Overloaded. Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.
 | AreElementsEqualIgnoringOrder | Overloaded. Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.
 | AreElementsNotEqual | Overloaded. Verifies that unexpected and actual sequences differ in at least one element.
 | AreEqual | Overloaded. Asserts that two strings are equal according to a particular string comparison mode.
 | AreNotApproximatelyEqual | Overloaded. Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.
 | AreNotEqual | Overloaded. Asserts that two strings are not equal according to a particular string comparison mode.
 | AreNotSame | Overloaded. Verifies that an actual value is not referentially identical to some unexpected value.
 | AreSame | Overloaded. Verifies that an actual value is referentially identical to some expected value.
 | Between | Overloaded. Verifies that a test value is between left and right values according to a particular comparer.
 | BinaryDeserialize | Overloaded. Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.
 | BinarySerialize | Overloaded. Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.
 | BinarySerializeThenDeserialize | Overloaded. Verifies that an object can be serialized then deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.
 | Contains | Overloaded. Verifies that a string contains some expected value.
 | ContainsKey | Overloaded. Verifies that expectedKey is in the dictionary dictionary.
 | Deserialize | Overloaded. Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.
 | DoesNotContain | Overloaded. Verifies that a string does not contain some unexpected substring.
 | DoesNotContainKey | Overloaded. Verifies that unexpectedKey is not in the dictionary dictionary.
 | DoesNotThrow | Overloaded. Verifies that a block of code does not throw an exception of any type.
 | EndsWith | Overloaded. Verifies that a string ends with the specified text.
 | Equals | Obsolete. Always throws an InvalidOperationException. Use AreEqual instead.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | Fail | Overloaded. Signals an unconditional assertion failure.
 | FullMatch | Overloaded. Verifies that a string matches regular expression pattern exactly.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | GreaterThan | Overloaded. Verifies that the left value is greater than the right value according to a particular comparer.
 | GreaterThanOrEqualTo | Overloaded. Verifies that the left value is greater than or equal to the right value according to a particular comparer.
 | Inconclusive | Overloaded. Terminates the test and reports an inconclusive test outcome.
 | IsAssignableFrom | Overloaded. Verifies that an object may be assigned to a variable of the specified type.
 | IsEmpty | Overloaded. Verifies that an actual value contains no elements.
 | IsFalse | Overloaded. Verifies that an actual value is false.
 | IsInstanceOfType | Overloaded. Verifies that an actual value is an instance of some expected type.
 | IsNotAssignableFrom | Overloaded. Verifies that an object may not be assigned to a variable of the specified type.
 | IsNotEmpty | Overloaded. Verifies that an actual value contains at least one element.
 | IsNotInstanceOfType | Overloaded. Verifies that an actual value is not an instance of some unexpected type.
 | IsNotNull | Overloaded. Verifies that an actual value is not null.
 | IsNull | Overloaded. Verifies that an actual value is null.
 | IsSerializableType | Overloaded. Verifies that a type supports the runtime serialization protocol.
 | IsTrue | Overloaded. Verifies that an actual value is true.
 | IsXmlSerializableType | Overloaded. Verifies that a type supports the Xml serialization protocol used by XmlSerializer.
 | LessThan | Overloaded. Verifies that the left value is less than the right value according to a particular comparer.
 | LessThanOrEqualTo | Overloaded. Verifies that the left value is less than or equal to the right value according to a particular comparer.
 | Like | Overloaded. Verifies that a string contains a full or partial match of a regular expression pattern.
 | Multiple | Overloaded. Evaluates a block of code that contains multiple related assertions.
 | NotBetween | Overloaded. Verifies that a test value is not between left and right values according to a particular comparer.
 | NotLike | Overloaded. Verifies that a string does not contain a full or partial match of a regular expression pattern.
 | ReferenceEquals | Obsolete. Always throws an InvalidOperationException. Use AreSame instead.
 | Serialize | Overloaded. Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.
 | SerializeThenDeserialize | Overloaded. Verifies that an object can be serialized then deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.
 | StartsWith | Overloaded. Verifies that a string starts with the specified text.
 | Terminate | Overloaded. Terminates the test and reports a specific test outcome.
 | TerminateSilently | Overloaded. Terminates the test silently and reports a specific test outcome.
 | Throws | Overloaded. Verifies that a block of code throws an exception of a particular type.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
 | XmlDeserialize | Overloaded. Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.
 | XmlSerialize | Overloaded. Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.
 | XmlSerializeThenDeserialize | Overloaded. Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Assert Constructor

Assert Constructor
[image]

Prevents instantiation. Subclasses should likewise define their constructor to be protected.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected Assert()
C++
protected:
Assert() sealed
J#
protected Assert()
JScript
protected function Assert()

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

Assert Properties
[image]

Public Properties

Name | Description
IsFailurePending | Returns true if there is a pending unreported assertion failure.
Over | Provides methods for composing assertions to map over complex data structures.
Top

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsFailurePending Property

Assert.IsFailurePending Property
[image]

Returns true if there is a pending unreported assertion failure.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsFailurePending As Boolean
C#
public static bool IsFailurePending { get; }
C++
public static property bool IsFailurePending {
bool get();
}
J#
/** property */
public bool get_IsFailurePending();
JScript
public function get IsFailurePending() : bool

Remarks

This property is used in conjuction with the Multiple feature to determine whether there is a pending assertion failure yet to be reported within a multiple-assertion block.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Over Property

Assert.Over Property
[image]

Provides methods for composing assertions to map over complex data structures.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Over As AssertOverSyntax
C#
public static AssertOverSyntax Over { get; }
C++
public static property AssertOverSyntax Over {
AssertOverSyntax get();
}
J#
/** property */
public AssertOverSyntax get_Over();
JScript
public function get Over() : AssertOverSyntax

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

Assert Methods
[image]

Public Methods

 | Name | Description
 | AreApproximatelyEqual | Overloaded. Verifies that an actual value approximately equals some expected value to within a specified delta.
 | AreElementsEqual | Overloaded. Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.
 | AreElementsEqualIgnoringOrder | Overloaded. Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.
 | AreElementsNotEqual | Overloaded. Verifies that unexpected and actual sequences differ in at least one element.
 | AreEqual | Overloaded. Asserts that two strings are equal according to a particular string comparison mode.
 | AreNotApproximatelyEqual | Overloaded. Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.
 | AreNotEqual | Overloaded. Asserts that two strings are not equal according to a particular string comparison mode.
 | AreNotSame | Overloaded. Verifies that an actual value is not referentially identical to some unexpected value.
 | AreSame | Overloaded. Verifies that an actual value is referentially identical to some expected value.
 | Between | Overloaded. Verifies that a test value is between left and right values according to a particular comparer.
 | BinaryDeserialize | Overloaded. Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.
 | BinarySerialize | Overloaded. Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.
 | BinarySerializeThenDeserialize | Overloaded. Verifies that an object can be serialized then deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.
 | Contains | Overloaded. Verifies that a string contains some expected value.
 | ContainsKey | Overloaded. Verifies that expectedKey is in the dictionary dictionary.
 | Deserialize | Overloaded. Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.
 | DoesNotContain | Overloaded. Verifies that a string does not contain some unexpected substring.
 | DoesNotContainKey | Overloaded. Verifies that unexpectedKey is not in the dictionary dictionary.
 | DoesNotThrow | Overloaded. Verifies that a block of code does not throw an exception of any type.
 | EndsWith | Overloaded. Verifies that a string ends with the specified text.
 | Equals | Obsolete. Always throws an InvalidOperationException. Use AreEqual instead.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | Fail | Overloaded. Signals an unconditional assertion failure.
 | FullMatch | Overloaded. Verifies that a string matches regular expression pattern exactly.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | GreaterThan | Overloaded. Verifies that the left value is greater than the right value according to a particular comparer.
 | GreaterThanOrEqualTo | Overloaded. Verifies that the left value is greater than or equal to the right value according to a particular comparer.
 | Inconclusive | Overloaded. Terminates the test and reports an inconclusive test outcome.
 | IsAssignableFrom | Overloaded. Verifies that an object may be assigned to a variable of the specified type.
 | IsEmpty | Overloaded. Verifies that an actual value contains no elements.
 | IsFalse | Overloaded. Verifies that an actual value is false.
 | IsInstanceOfType | Overloaded. Verifies that an actual value is an instance of some expected type.
 | IsNotAssignableFrom | Overloaded. Verifies that an object may not be assigned to a variable of the specified type.
 | IsNotEmpty | Overloaded. Verifies that an actual value contains at least one element.
 | IsNotInstanceOfType | Overloaded. Verifies that an actual value is not an instance of some unexpected type.
 | IsNotNull | Overloaded. Verifies that an actual value is not null.
 | IsNull | Overloaded. Verifies that an actual value is null.
 | IsSerializableType | Overloaded. Verifies that a type supports the runtime serialization protocol.
 | IsTrue | Overloaded. Verifies that an actual value is true.
 | IsXmlSerializableType | Overloaded. Verifies that a type supports the Xml serialization protocol used by XmlSerializer.
 | LessThan | Overloaded. Verifies that the left value is less than the right value according to a particular comparer.
 | LessThanOrEqualTo | Overloaded. Verifies that the left value is less than or equal to the right value according to a particular comparer.
 | Like | Overloaded. Verifies that a string contains a full or partial match of a regular expression pattern.
 | Multiple | Overloaded. Evaluates a block of code that contains multiple related assertions.
 | NotBetween | Overloaded. Verifies that a test value is not between left and right values according to a particular comparer.
 | NotLike | Overloaded. Verifies that a string does not contain a full or partial match of a regular expression pattern.
 | ReferenceEquals | Obsolete. Always throws an InvalidOperationException. Use AreSame instead.
 | Serialize | Overloaded. Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.
 | SerializeThenDeserialize | Overloaded. Verifies that an object can be serialized then deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.
 | StartsWith | Overloaded. Verifies that a string starts with the specified text.
 | Terminate | Overloaded. Terminates the test and reports a specific test outcome.
 | TerminateSilently | Overloaded. Terminates the test silently and reports a specific test outcome.
 | Throws | Overloaded. Verifies that a block of code throws an exception of a particular type.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
 | XmlDeserialize | Overloaded. Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.
 | XmlSerialize | Overloaded. Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.
 | XmlSerializeThenDeserialize | Overloaded. Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreApproximatelyEqual Generic Method

Assert.AreApproximatelyEqual Generic Method

Verifies that an actual value approximately equals some expected value to within a specified delta.

Overload List

Name | Description
AreApproximatelyEqual (TValue, TValue, TDifference) | Verifies that an actual value approximately equals some expected value to within a specified delta.
AreApproximatelyEqual (TValue, TValue, TDifference, String, Object) | Verifies that an actual value approximately equals some expected value to within a specified delta.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreApproximatelyEqual Generic Method (TValue, TValue, TDifference)

Assert.AreApproximatelyEqual Generic Method (TValue, TValue, TDifference)
See Also Example
[image]

Verifies that an actual value approximately equals some expected value to within a specified delta.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreApproximatelyEqual(Of TValue, TDifference)( _
ByVal expectedValue As TValue, _
ByVal actualValue As TValue, _
ByVal delta As TDifference _
)
C#
public static void AreApproximatelyEqual<TValue, TDifference>(
TValue expectedValue,
TValue actualValue,
TDifference delta
)
C++
public:
static void AreApproximatelyEqual<TValue, TDifference>(
TValue expectedValue,
TValue actualValue,
TDifference delta
)
J#
public static void AreApproximatelyEqual<TValue, TDifference>(
TValue expectedValue,
TValue actualValue,
TDifference delta
)
JScript
JScript does not support generic types and methods.

Type Parameters

TValue
The type of values to be compared
TDifference
The type of the difference produced when the values are subtracted, for numeric types this is the same as TValue but it may differ for other types

Parameters

expectedValue
The expected value
actualValue
The actual value
delta
The inclusive delta between the values

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The values are considered approximately equal if the absolute value of their difference is less than or equal to the delta.

This method works with any comparable type that also supports a subtraction operator including Single, Double, Decimal, Int32, DateTime (using a TimeSpan delta), and many others.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreApproximatelyEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreApproximatelyEqual Generic Method (TValue, TValue, TDifference, String, Object[])

Assert.AreApproximatelyEqual Generic Method (TValue, TValue, TDifference, String, Object[])
See Also Example
[image]

Verifies that an actual value approximately equals some expected value to within a specified delta.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreApproximatelyEqual(Of TValue, TDifference)( _
ByVal expectedValue As TValue, _
ByVal actualValue As TValue, _
ByVal delta As TDifference, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreApproximatelyEqual<TValue, TDifference>(
TValue expectedValue,
TValue actualValue,
TDifference delta,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreApproximatelyEqual<TValue, TDifference>(
TValue expectedValue,
TValue actualValue,
TDifference delta,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreApproximatelyEqual<TValue, TDifference>(
TValue expectedValue,
TValue actualValue,
TDifference delta,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TValue
The type of values to be compared
TDifference
The type of the difference produced when the values are subtracted, for numeric types this is the same as TValue but it may differ for other types

Parameters

expectedValue
The expected value
actualValue
The actual value
delta
The inclusive delta between the values
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The values are considered approximately equal if the absolute value of their difference is less than or equal to the delta.

This method works with any comparable type that also supports a subtraction operator including Single, Double, Decimal, Int32, DateTime (using a TimeSpan delta), and many others.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreApproximatelyEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqual Generic Method

Assert.AreElementsEqual Generic Method

Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.

Overload List

Name | Description
AreElementsEqual (IEnumerable<T>, IEnumerable<T>) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.
AreElementsEqual (IEnumerable<T>, IEnumerable<T>, Func<T, T, bool>) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.
AreElementsEqual (IEnumerable<T>, IEnumerable<T>, Func<T, T, bool>, String, Object) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.
AreElementsEqual (IEnumerable<T>, IEnumerable<T>, String, Object) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable)

Assert.AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable)
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqual(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T) _
)
C#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence
)
C++
public:
static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence
)
J#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func)

Assert.AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func)
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqual(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal comparer As Func(Of T, T, Boolean) _
)
C#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
C++
public:
static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
J#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func, String, Object[])

Assert.AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func, String, Object[])
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqual(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal comparer As Func(Of T, T, Boolean), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable, String, Object[])

Assert.AreElementsEqual Generic Method (Generic IEnumerable, Generic IEnumerable, String, Object[])
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal and in the same order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqual(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreElementsEqual<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqualIgnoringOrder Generic Method

Assert.AreElementsEqualIgnoringOrder Generic Method

Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.

Overload List

Name | Description
AreElementsEqualIgnoringOrder (IEnumerable<T>, IEnumerable<T>) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.
AreElementsEqualIgnoringOrder (IEnumerable<T>, IEnumerable<T>, Func<T, T, bool>) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.
AreElementsEqualIgnoringOrder (IEnumerable<T>, IEnumerable<T>, Func<T, T, bool>, String, Object) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.
AreElementsEqualIgnoringOrder (IEnumerable<T>, IEnumerable<T>, String, Object) | Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable)

Assert.AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable)
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqualIgnoringOrder(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T) _
)
C#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence
)
C++
public:
static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence
)
J#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqualIgnoringOrder Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func)

Assert.AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func)
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqualIgnoringOrder(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal comparer As Func(Of T, T, Boolean) _
)
C#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
C++
public:
static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
J#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqualIgnoringOrder Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func, String, Object[])

Assert.AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func, String, Object[])
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqualIgnoringOrder(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal comparer As Func(Of T, T, Boolean), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqualIgnoringOrder Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable, String, Object[])

Assert.AreElementsEqualIgnoringOrder Generic Method (Generic IEnumerable, Generic IEnumerable, String, Object[])
See Also Example
[image]

Verifies that expected and actual sequences have the same number of elements and that the elements are equal but perhaps in a different order.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqualIgnoringOrder(Of T)( _
ByVal expectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreElementsEqualIgnoringOrder<T>(
IEnumerable<T> expectedSequence,
IEnumerable<T> actualSequence,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedSequence
The expected sequence
actualSequence
The actual sequence
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsEqualIgnoringOrder Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsNotEqual Generic Method

Assert.AreElementsNotEqual Generic Method

Verifies that unexpected and actual sequences differ in at least one element.

Overload List

Name | Description
AreElementsNotEqual (IEnumerable<T>, IEnumerable<T>) | Verifies that unexpected and actual sequences differ in at least one element.
AreElementsNotEqual (IEnumerable<T>, IEnumerable<T>, Func<T, T, bool>) | Verifies that unexpected and actual sequences differ in at least one element.
AreElementsNotEqual (IEnumerable<T>, IEnumerable<T>, Func<T, T, bool>, String, Object) | Verifies that unexpected and actual sequences differ in at least one element.
AreElementsNotEqual (IEnumerable<T>, IEnumerable<T>, String, Object) | Verifies that unexpected and actual sequences differ in at least one element.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable)

Assert.AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable)
See Also Example
[image]

Verifies that unexpected and actual sequences differ in at least one element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsNotEqual(Of T)( _
ByVal unexpectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T) _
)
C#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence
)
C++
public:
static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence
)
J#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedSequence
The unexpected sequence
actualSequence
The actual sequence

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func)

Assert.AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func)
See Also Example
[image]

Verifies that unexpected and actual sequences differ in at least one element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsNotEqual(Of T)( _
ByVal unexpectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal comparer As Func(Of T, T, Boolean) _
)
C#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
C++
public:
static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
J#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedSequence
The unexpected sequence
actualSequence
The actual sequence
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func, String, Object[])

Assert.AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Func, String, Object[])
See Also Example
[image]

Verifies that unexpected and actual sequences differ in at least one element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsNotEqual(Of T)( _
ByVal unexpectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal comparer As Func(Of T, T, Boolean), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
Func<T, T, bool> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedSequence
The unexpected sequence
actualSequence
The actual sequence
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable, String, Object[])

Assert.AreElementsNotEqual Generic Method (Generic IEnumerable, Generic IEnumerable, String, Object[])
See Also Example
[image]

Verifies that unexpected and actual sequences differ in at least one element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsNotEqual(Of T)( _
ByVal unexpectedSequence As IEnumerable(Of T), _
ByVal actualSequence As IEnumerable(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreElementsNotEqual<T>(
IEnumerable<T> unexpectedSequence,
IEnumerable<T> actualSequence,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedSequence
The unexpected sequence
actualSequence
The actual sequence
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreElementsNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method

Assert.AreEqual Generic Method

Asserts that two strings are equal according to a particular string comparison mode.

Overload List

Name | Description
AreEqual (String, String, StringComparison) | Asserts that two strings are equal according to a particular string comparison mode.
AreEqual (String, String, StringComparison, String, Object) | Asserts that two strings are equal according to a particular string comparison mode.
AreEqual (T, T) | Verifies that an actual value equals some expected value.
AreEqual (T, T, Func<T, T, bool>) | Verifies that an actual value equals some expected value according to a particular comparer.
AreEqual (T, T, Func<T, T, bool>, String, Object) | Verifies that an actual value equals some expected value according to a particular comparer.
AreEqual (T, T, IEqualityComparer<T>) | Verifies that an actual value equals some expected value according to a particular comparer.
AreEqual (T, T, IEqualityComparer<T>, String, Object) | Verifies that an actual value equals some expected value according to a particular comparer.
AreEqual (T, T, String, Object) | Verifies that an actual value equals some expected value.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Method (String, String, StringComparison)

Assert.AreEqual Method (String, String, StringComparison)
See Also Example
[image]

Asserts that two strings are equal according to a particular string comparison mode.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expectedValue As String, _
ByVal actualValue As String, _
ByVal comparisonType As StringComparison _
)
C#
public static void AreEqual(
string expectedValue,
string actualValue,
StringComparison comparisonType
)
C++
public:
static void AreEqual(
String expectedValue,
String actualValue,
StringComparison comparisonType
)
J#
public static void AreEqual(
string expectedValue,
string actualValue,
StringComparison comparisonType
)
JScript
public static function AreEqual(
expectedValue : String,
actualValue : String,
comparisonType : StringComparison
)

Parameters

expectedValue
The expected value
actualValue
The actual value
comparisonType
The string comparison type

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Method (String, String, StringComparison, String, Object[])

Assert.AreEqual Method (String, String, StringComparison, String, Object[])
See Also Example
[image]

Asserts that two strings are equal according to a particular string comparison mode.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expectedValue As String, _
ByVal actualValue As String, _
ByVal comparisonType As StringComparison, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreEqual(
string expectedValue,
string actualValue,
StringComparison comparisonType,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreEqual(
String expectedValue,
String actualValue,
StringComparison comparisonType,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreEqual(
string expectedValue,
string actualValue,
StringComparison comparisonType,
string messageFormat,
object[] messageArgs
)
JScript
public static function AreEqual(
expectedValue : String,
actualValue : String,
comparisonType : StringComparison,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

expectedValue
The expected value
actualValue
The actual value
comparisonType
The string comparison type
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method (T, T)

Assert.AreEqual Generic Method (T, T)
See Also Example
[image]

Verifies that an actual value equals some expected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual(Of T)( _
ByVal expectedValue As T, _
ByVal actualValue As T _
)
C#
public static void AreEqual<T>(
T expectedValue,
T actualValue
)
C++
public:
static void AreEqual<T>(
T expectedValue,
T actualValue
)
J#
public static void AreEqual<T>(
T expectedValue,
T actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method (T, T, Generic Func)

Assert.AreEqual Generic Method (T, T, Generic Func)
See Also Example
[image]

Verifies that an actual value equals some expected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual(Of T)( _
ByVal expectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As Func(Of T, T, Boolean) _
)
C#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
Func<T, T, bool> comparer
)
C++
public:
static void AreEqual<T>(
T expectedValue,
T actualValue,
Func<T, T, bool> comparer
)
J#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
Func<T, T, bool> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method (T, T, Generic Func, String, Object[])

Assert.AreEqual Generic Method (T, T, Generic Func, String, Object[])
See Also Example
[image]

Verifies that an actual value equals some expected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual(Of T)( _
ByVal expectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As Func(Of T, T, Boolean), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
Func<T, T, bool> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreEqual<T>(
T expectedValue,
T actualValue,
Func<T, T, bool> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
Func<T, T, bool> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method (T, T, Generic IEqualityComparer)

Assert.AreEqual Generic Method (T, T, Generic IEqualityComparer)
See Also Example
[image]

Verifies that an actual value equals some expected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual(Of T)( _
ByVal expectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As IEqualityComparer(Of T) _
)
C#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
IEqualityComparer<T> comparer
)
C++
public:
static void AreEqual<T>(
T expectedValue,
T actualValue,
IEqualityComparer<T> comparer
)
J#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
IEqualityComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method (T, T, Generic IEqualityComparer, String, Object[])

Assert.AreEqual Generic Method (T, T, Generic IEqualityComparer, String, Object[])
See Also Example
[image]

Verifies that an actual value equals some expected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual(Of T)( _
ByVal expectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As IEqualityComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
IEqualityComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreEqual<T>(
T expectedValue,
T actualValue,
IEqualityComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
IEqualityComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreEqual Generic Method (T, T, String, Object[])

Assert.AreEqual Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that an actual value equals some expected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual(Of T)( _
ByVal expectedValue As T, _
ByVal actualValue As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreEqual<T>(
T expectedValue,
T actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreEqual<T>(
T expectedValue,
T actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotApproximatelyEqual Generic Method

Assert.AreNotApproximatelyEqual Generic Method

Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.

Overload List

Name | Description
AreNotApproximatelyEqual (TValue, TValue, TDifference) | Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.
AreNotApproximatelyEqual (TValue, TValue, TDifference, String, Object) | Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotApproximatelyEqual Generic Method (TValue, TValue, TDifference)

Assert.AreNotApproximatelyEqual Generic Method (TValue, TValue, TDifference)
See Also Example
[image]

Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotApproximatelyEqual(Of TValue, TDifference)( _
ByVal unexpectedValue As TValue, _
ByVal actualValue As TValue, _
ByVal delta As TDifference _
)
C#
public static void AreNotApproximatelyEqual<TValue, TDifference>(
TValue unexpectedValue,
TValue actualValue,
TDifference delta
)
C++
public:
static void AreNotApproximatelyEqual<TValue, TDifference>(
TValue unexpectedValue,
TValue actualValue,
TDifference delta
)
J#
public static void AreNotApproximatelyEqual<TValue, TDifference>(
TValue unexpectedValue,
TValue actualValue,
TDifference delta
)
JScript
JScript does not support generic types and methods.

Type Parameters

TValue
The type of values to be compared
TDifference
The type of the difference produced when the values are subtracted, for numeric types this is the same as TValue but it may differ for other types

Parameters

unexpectedValue
The expected value
actualValue
The actual value
delta
The inclusive delta between the values

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The values are considered approximately equal if the absolute value of their difference is less than or equal to the delta.

This method works with any comparable type that also supports a subtraction operator including Single, Double, Decimal, Int32, DateTime (using a TimeSpan delta), and many others.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotApproximatelyEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotApproximatelyEqual Generic Method (TValue, TValue, TDifference, String, Object[])

Assert.AreNotApproximatelyEqual Generic Method (TValue, TValue, TDifference, String, Object[])
See Also Example
[image]

Verifies that an actual value does not approximately equal some unexpected value to within a specified delta.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotApproximatelyEqual(Of TValue, TDifference)( _
ByVal unexpectedValue As TValue, _
ByVal actualValue As TValue, _
ByVal delta As TDifference, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreNotApproximatelyEqual<TValue, TDifference>(
TValue unexpectedValue,
TValue actualValue,
TDifference delta,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreNotApproximatelyEqual<TValue, TDifference>(
TValue unexpectedValue,
TValue actualValue,
TDifference delta,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreNotApproximatelyEqual<TValue, TDifference>(
TValue unexpectedValue,
TValue actualValue,
TDifference delta,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TValue
The type of values to be compared
TDifference
The type of the difference produced when the values are subtracted, for numeric types this is the same as TValue but it may differ for other types

Parameters

unexpectedValue
The expected value
actualValue
The actual value
delta
The inclusive delta between the values
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The values are considered approximately equal if the absolute value of their difference is less than or equal to the delta.

This method works with any comparable type that also supports a subtraction operator including Single, Double, Decimal, Int32, DateTime (using a TimeSpan delta), and many others.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotApproximatelyEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method

Assert.AreNotEqual Generic Method

Asserts that two strings are not equal according to a particular string comparison mode.

Overload List

Name | Description
AreNotEqual (String, String, StringComparison) | Asserts that two strings are not equal according to a particular string comparison mode.
AreNotEqual (String, String, StringComparison, String, Object) | Asserts that two strings are not equal according to a particular string comparison mode.
AreNotEqual (T, T) | Verifies that an actual value does not equal some unexpected value.
AreNotEqual (T, T, Func<T, T, bool>) | Verifies that an actual value does not equal some unexpected value according to a particular comparer.
AreNotEqual (T, T, Func<T, T, bool>, String, Object) | Verifies that an actual value does not equal some unexpected value according to a particular comparer.
AreNotEqual (T, T, IEqualityComparer<T>) | Verifies that an actual value does not equal some unexpected value according to a particular comparer.
AreNotEqual (T, T, IEqualityComparer<T>, String, Object) | Verifies that an actual value does not equal some unexpected value according to a particular comparer.
AreNotEqual (T, T, String, Object) | Verifies that an actual value does not equal some unexpected value.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Method (String, String, StringComparison)

Assert.AreNotEqual Method (String, String, StringComparison)
See Also Example
[image]

Asserts that two strings are not equal according to a particular string comparison mode.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal unexpectedValue As String, _
ByVal actualValue As String, _
ByVal comparisonType As StringComparison _
)
C#
public static void AreNotEqual(
string unexpectedValue,
string actualValue,
StringComparison comparisonType
)
C++
public:
static void AreNotEqual(
String unexpectedValue,
String actualValue,
StringComparison comparisonType
)
J#
public static void AreNotEqual(
string unexpectedValue,
string actualValue,
StringComparison comparisonType
)
JScript
public static function AreNotEqual(
unexpectedValue : String,
actualValue : String,
comparisonType : StringComparison
)

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
comparisonType
The string comparison type

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Method (String, String, StringComparison, String, Object[])

Assert.AreNotEqual Method (String, String, StringComparison, String, Object[])
See Also Example
[image]

Asserts that two strings are not equal according to a particular string comparison mode.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal unexpectedValue As String, _
ByVal actualValue As String, _
ByVal comparisonType As StringComparison, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreNotEqual(
string unexpectedValue,
string actualValue,
StringComparison comparisonType,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreNotEqual(
String unexpectedValue,
String actualValue,
StringComparison comparisonType,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreNotEqual(
string unexpectedValue,
string actualValue,
StringComparison comparisonType,
string messageFormat,
object[] messageArgs
)
JScript
public static function AreNotEqual(
unexpectedValue : String,
actualValue : String,
comparisonType : StringComparison,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
comparisonType
The string comparison type
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method (T, T)

Assert.AreNotEqual Generic Method (T, T)
See Also Example
[image]

Verifies that an actual value does not equal some unexpected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual(Of T)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T _
)
C#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue
)
C++
public:
static void AreNotEqual<T>(
T unexpectedValue,
T actualValue
)
J#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method (T, T, Generic Func)

Assert.AreNotEqual Generic Method (T, T, Generic Func)
See Also Example
[image]

Verifies that an actual value does not equal some unexpected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual(Of T)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As Func(Of T, T, Boolean) _
)
C#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
Func<T, T, bool> comparer
)
C++
public:
static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
Func<T, T, bool> comparer
)
J#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
Func<T, T, bool> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method (T, T, Generic Func, String, Object[])

Assert.AreNotEqual Generic Method (T, T, Generic Func, String, Object[])
See Also Example
[image]

Verifies that an actual value does not equal some unexpected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual(Of T)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As Func(Of T, T, Boolean), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
Func<T, T, bool> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
Func<T, T, bool> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
Func<T, T, bool> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method (T, T, Generic IEqualityComparer)

Assert.AreNotEqual Generic Method (T, T, Generic IEqualityComparer)
See Also Example
[image]

Verifies that an actual value does not equal some unexpected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual(Of T)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As IEqualityComparer(Of T) _
)
C#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
IEqualityComparer<T> comparer
)
C++
public:
static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
IEqualityComparer<T> comparer
)
J#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
IEqualityComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method (T, T, Generic IEqualityComparer, String, Object[])

Assert.AreNotEqual Generic Method (T, T, Generic IEqualityComparer, String, Object[])
See Also Example
[image]

Verifies that an actual value does not equal some unexpected value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual(Of T)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T, _
ByVal comparer As IEqualityComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
IEqualityComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
IEqualityComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
IEqualityComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotEqual Generic Method (T, T, String, Object[])

Assert.AreNotEqual Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that an actual value does not equal some unexpected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual(Of T)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreNotEqual<T>(
T unexpectedValue,
T actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotSame Generic Method

Assert.AreNotSame Generic Method

Verifies that an actual value is not referentially identical to some unexpected value.

Overload List

Name | Description
AreNotSame (T, T) | Verifies that an actual value is not referentially identical to some unexpected value.
AreNotSame (T, T, String, Object) | Verifies that an actual value is not referentially identical to some unexpected value.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotSame Generic Method (T, T)

Assert.AreNotSame Generic Method (T, T)
See Also Example
[image]

Verifies that an actual value is not referentially identical to some unexpected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotSame(Of T As Class)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T _
)
C#
public static void AreNotSame<T>(
T unexpectedValue,
T actualValue
) where T : class
C++
public:
static void AreNotSame<T>(
T unexpectedValue,
T actualValue
)
J#
public static void AreNotSame<T>(
T unexpectedValue,
T actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreNotSame Generic Method (T, T, String, Object[])

Assert.AreNotSame Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that an actual value is not referentially identical to some unexpected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotSame(Of T As Class)( _
ByVal unexpectedValue As T, _
ByVal actualValue As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreNotSame<T>(
T unexpectedValue,
T actualValue,
string messageFormat,
params object[] messageArgs
) where T : class
C++
public:
static void AreNotSame<T>(
T unexpectedValue,
T actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreNotSame<T>(
T unexpectedValue,
T actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

unexpectedValue
The unexpected value
actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreNotSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreSame Generic Method

Assert.AreSame Generic Method

Verifies that an actual value is referentially identical to some expected value.

Overload List

Name | Description
AreSame (T, T) | Verifies that an actual value is referentially identical to some expected value.
AreSame (T, T, String, Object) | Verifies that an actual value is referentially identical to some expected value.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreSame Generic Method (T, T)

Assert.AreSame Generic Method (T, T)
See Also Example
[image]

Verifies that an actual value is referentially identical to some expected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSame(Of T As Class)( _
ByVal expectedValue As T, _
ByVal actualValue As T _
)
C#
public static void AreSame<T>(
T expectedValue,
T actualValue
) where T : class
C++
public:
static void AreSame<T>(
T expectedValue,
T actualValue
)
J#
public static void AreSame<T>(
T expectedValue,
T actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AreSame Generic Method (T, T, String, Object[])

Assert.AreSame Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that an actual value is referentially identical to some expected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSame(Of T As Class)( _
ByVal expectedValue As T, _
ByVal actualValue As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void AreSame<T>(
T expectedValue,
T actualValue,
string messageFormat,
params object[] messageArgs
) where T : class
C++
public:
static void AreSame<T>(
T expectedValue,
T actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void AreSame<T>(
T expectedValue,
T actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

expectedValue
The expected value
actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.AreSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method

Assert.Between Generic Method

Verifies that a test value is between left and right values according to a particular comparer.

Overload List

Name | Description
Between (T, T, T) | Verifies that a test value is between left and right values according to a particular comparer.
Between (T, T, T, IComparer<T>) | Verifies that a test value is between left and right values according to a particular comparer.
Between (T, T, T, IComparer<T>, String, Object) | Verifies that a test value is between left and right values according to a particular comparer.
Between (T, T, T, Comparison<T>) | Verifies that a test value is between left and right values according to a particular comparer.
Between (T, T, T, Comparison<T>, String, Object) | Verifies that a test value is between left and right values according to a particular comparer.
Between (T, T, T, String, Object) | Verifies that a test value is between left and right values according to a particular comparer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method (T, T, T)

Assert.Between Generic Method (T, T, T)
See Also Example
[image]

Verifies that a test value is between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T _
)
C#
public static void Between<T>(
T actualValue,
T minimum,
T maximum
)
C++
public:
static void Between<T>(
T actualValue,
T minimum,
T maximum
)
J#
public static void Between<T>(
T actualValue,
T minimum,
T maximum
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method (T, T, T, Generic IComparer)

Assert.Between Generic Method (T, T, T, Generic IComparer)
See Also Example
[image]

Verifies that a test value is between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As IComparer(Of T) _
)
C#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer
)
C++
public:
static void Between<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer
)
J#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method (T, T, T, Generic IComparer, String, Object[])

Assert.Between Generic Method (T, T, T, Generic IComparer, String, Object[])
See Also Example
[image]

Verifies that a test value is between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As IComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Between<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method (T, T, T, Generic Comparison)

Assert.Between Generic Method (T, T, T, Generic Comparison)
See Also Example
[image]

Verifies that a test value is between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As Comparison(Of T) _
)
C#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer
)
C++
public:
static void Between<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer
)
J#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method (T, T, T, Generic Comparison, String, Object[])

Assert.Between Generic Method (T, T, T, Generic Comparison, String, Object[])
See Also Example
[image]

Verifies that a test value is between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As Comparison(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Between<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Between Generic Method (T, T, T, String, Object[])

Assert.Between Generic Method (T, T, T, String, Object[])
See Also Example
[image]

Verifies that a test value is between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Between<T>(
T actualValue,
T minimum,
T maximum,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Between<T>(
T actualValue,
T minimum,
T maximum,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinaryDeserialize Generic Method

Assert.BinaryDeserialize Generic Method

Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.

Overload List

Name | Description
BinaryDeserialize (Stream) | Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.
BinaryDeserialize (Stream, String, Object) | Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinaryDeserialize Generic Method (Stream)

Assert.BinaryDeserialize Generic Method (Stream)
See Also Example
[image]

Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BinaryDeserialize(Of T)( _
ByVal stream As Stream _
)
C#
public static T BinaryDeserialize<T>(
Stream stream
)
C++
public:
static T BinaryDeserialize<T>(
Stream stream
)
J#
public static T BinaryDeserialize<T>(
Stream stream
)
JScript
JScript does not support generic types and methods.

Parameters

stream
The stream to deserialize

Return Value

The deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if stream is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.BinaryDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinaryDeserialize Generic Method (Stream, String, Object[])

Assert.BinaryDeserialize Generic Method (Stream, String, Object[])
See Also Example
[image]

Verifies that an object can be deserialized from a stream using a BinaryFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BinaryDeserialize(Of T)( _
ByVal stream As Stream, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static T BinaryDeserialize<T>(
Stream stream,
string messageFormat,
params object[] messageArgs
)
C++
public:
static T BinaryDeserialize<T>(
Stream stream,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static T BinaryDeserialize<T>(
Stream stream,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Parameters

stream
The stream to deserialize
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if stream is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.BinaryDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinarySerialize Method

Assert.BinarySerialize Method

Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.

Overload List

Name | Description
BinarySerialize (Object) | Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.
BinarySerialize (Object, String, Object) | Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinarySerialize Method (Object)

Assert.BinarySerialize Method (Object)
See Also Example
[image]

Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BinarySerialize( _
ByVal value As Object _
) As MemoryStream
C#
public static MemoryStream BinarySerialize(
object value
)
C++
public:
static MemoryStream BinarySerialize(
Object value
)
J#
public static MemoryStream BinarySerialize(
object value
)
JScript
public static function BinarySerialize(
value : Object
) : MemoryStream

Parameters

value
The value

Return Value

The serialized stream

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.BinarySerialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinarySerialize Method (Object, String, Object[])

Assert.BinarySerialize Method (Object, String, Object[])
See Also Example
[image]

Verifies that an object can be serialized to a stream using a BinaryFormatter and returns the resulting stream.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BinarySerialize( _
ByVal value As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
) As MemoryStream
C#
public static MemoryStream BinarySerialize(
object value,
string messageFormat,
params object[] messageArgs
)
C++
public:
static MemoryStream BinarySerialize(
Object value,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static MemoryStream BinarySerialize(
object value,
string messageFormat,
object[] messageArgs
)
JScript
public static function BinarySerialize(
value : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
) : MemoryStream

Parameters

value
The value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The serialized stream

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.BinarySerialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinarySerializeThenDeserialize Generic Method

Assert.BinarySerializeThenDeserialize Generic Method

Verifies that an object can be serialized then deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.

Overload List

Name | Description
BinarySerializeThenDeserialize (T) | Verifies that an object can be serialized then deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.
BinarySerializeThenDeserialize (T, String, Object) | Verifies that an object can be serialized and deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinarySerializeThenDeserialize Generic Method (T)

Assert.BinarySerializeThenDeserialize Generic Method (T)
See Also Example
[image]

Verifies that an object can be serialized then deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BinarySerializeThenDeserialize(Of T)( _
ByVal value As T _
)
C#
public static T BinarySerializeThenDeserialize<T>(
T value
)
C++
public:
static T BinarySerializeThenDeserialize<T>(
T value
)
J#
public static T BinarySerializeThenDeserialize<T>(
T value
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value

Return Value

The serialized then deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.BinarySerializeThenDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BinarySerializeThenDeserialize Generic Method (T, String, Object[])

Assert.BinarySerializeThenDeserialize Generic Method (T, String, Object[])
See Also Example
[image]

Verifies that an object can be serialized and deserialized to and from a stream using a BinaryFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BinarySerializeThenDeserialize(Of T)( _
ByVal value As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static T BinarySerializeThenDeserialize<T>(
T value,
string messageFormat,
params object[] messageArgs
)
C++
public:
static T BinarySerializeThenDeserialize<T>(
T value,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static T BinarySerializeThenDeserialize<T>(
T value,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The serialized then deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.BinarySerializeThenDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Contains Method

Assert.Contains Method

Verifies that a string contains some expected value.

Overload List

Name | Description
Contains (String, String) | Verifies that a string contains some expected value.
Contains (String, String, String, Object) | Verifies that a string contains some expected value.
Contains (IEnumerable<T>, T) | Verifies that expectedValue is in the enumeration enumeration.
Contains (IEnumerable<T>, T, String, Object) | Verifies that expectedValue is in the enumeration enumeration.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Contains Method (String, String)

Assert.Contains Method (String, String)
See Also Example
[image]

Verifies that a string contains some expected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal actualValue As String, _
ByVal expectedSubstring As String _
)
C#
public static void Contains(
string actualValue,
string expectedSubstring
)
C++
public:
static void Contains(
String actualValue,
String expectedSubstring
)
J#
public static void Contains(
string actualValue,
string expectedSubstring
)
JScript
public static function Contains(
actualValue : String,
expectedSubstring : String
)

Parameters

actualValue
The actual value
expectedSubstring
The expected substring

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedSubstring is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Contains Method (String, String, String, Object[])

Assert.Contains Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string contains some expected value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal actualValue As String, _
ByVal expectedSubstring As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Contains(
string actualValue,
string expectedSubstring,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Contains(
String actualValue,
String expectedSubstring,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Contains(
string actualValue,
string expectedSubstring,
string messageFormat,
object[] messageArgs
)
JScript
public static function Contains(
actualValue : String,
expectedSubstring : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
expectedSubstring
The expected substring
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedSubstring is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Contains Generic Method (Generic IEnumerable, T)

Assert.Contains Generic Method (Generic IEnumerable, T)
See Also Example
[image]

Verifies that expectedValue is in the enumeration enumeration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains(Of T)( _
ByVal enumeration As IEnumerable(Of T), _
ByVal expectedValue As T _
)
C#
public static void Contains<T>(
IEnumerable<T> enumeration,
T expectedValue
)
C++
public:
static void Contains<T>(
IEnumerable<T> enumeration,
T expectedValue
)
J#
public static void Contains<T>(
IEnumerable<T> enumeration,
T expectedValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

enumeration
The enumeration of items
expectedValue
The expected value expected to be found in the collection

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Contains Generic Method (Generic IEnumerable, T, String, Object[])

Assert.Contains Generic Method (Generic IEnumerable, T, String, Object[])
See Also Example
[image]

Verifies that expectedValue is in the enumeration enumeration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains(Of T)( _
ByVal enumeration As IEnumerable(Of T), _
ByVal expectedValue As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Contains<T>(
IEnumerable<T> enumeration,
T expectedValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Contains<T>(
IEnumerable<T> enumeration,
T expectedValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Contains<T>(
IEnumerable<T> enumeration,
T expectedValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

enumeration
The enumeration of items
expectedValue
The expected value expected to be found in the collection
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContainsKey Generic Method

Assert.ContainsKey Generic Method

Verifies that expectedKey is in the dictionary dictionary.

Overload List

Name | Description
ContainsKey (IDictionary<TKey, TValue>, TKey) | Verifies that expectedKey is in the dictionary dictionary.
ContainsKey (IDictionary<TKey, TValue>, TKey, String, Object) | Verifies that expectedKey is in the dictionary dictionary.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContainsKey Generic Method (Generic IDictionary, TKey)

Assert.ContainsKey Generic Method (Generic IDictionary, TKey)
See Also Example
[image]

Verifies that expectedKey is in the dictionary dictionary.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ContainsKey(Of TKey, TValue)( _
ByVal dictionary As IDictionary(Of TKey, TValue), _
ByVal expectedKey As TKey _
)
C#
public static void ContainsKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey expectedKey
)
C++
public:
static void ContainsKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey expectedKey
)
J#
public static void ContainsKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey expectedKey
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The type of key
TValue
The type of value

Parameters

dictionary
The dictionary of items
expectedKey
The key expected to be found in the dictionary

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.ContainsKey Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContainsKey Generic Method (Generic IDictionary, TKey, String, Object[])

Assert.ContainsKey Generic Method (Generic IDictionary, TKey, String, Object[])
See Also Example
[image]

Verifies that expectedKey is in the dictionary dictionary.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ContainsKey(Of TKey, TValue)( _
ByVal dictionary As IDictionary(Of TKey, TValue), _
ByVal expectedKey As TKey, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void ContainsKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey expectedKey,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void ContainsKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey expectedKey,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void ContainsKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey expectedKey,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The type of key
TValue
The type of value

Parameters

dictionary
The dictionary of items
expectedKey
The key expected to be found in the dictionary
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.ContainsKey Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Deserialize Generic Method

Assert.Deserialize Generic Method

Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.

Overload List

Name | Description
Deserialize (Stream, IFormatter) | Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.
Deserialize (Stream, IFormatter, String, Object) | Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Deserialize Generic Method (Stream, IFormatter)

Assert.Deserialize Generic Method (Stream, IFormatter)
See Also Example
[image]

Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Deserialize(Of T)( _
ByVal stream As Stream, _
ByVal formatter As IFormatter _
)
C#
public static T Deserialize<T>(
Stream stream,
IFormatter formatter
)
C++
public:
static T Deserialize<T>(
Stream stream,
IFormatter formatter
)
J#
public static T Deserialize<T>(
Stream stream,
IFormatter formatter
)
JScript
JScript does not support generic types and methods.

Parameters

stream
The stream to deserialize
formatter
The object serialization formatter

Return Value

The deserialized object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if stream is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Deserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Deserialize Generic Method (Stream, IFormatter, String, Object[])

Assert.Deserialize Generic Method (Stream, IFormatter, String, Object[])
See Also Example
[image]

Verifies that an object can be deserialized from a stream using the specified IFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Deserialize(Of T)( _
ByVal stream As Stream, _
ByVal formatter As IFormatter, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static T Deserialize<T>(
Stream stream,
IFormatter formatter,
string messageFormat,
params object[] messageArgs
)
C++
public:
static T Deserialize<T>(
Stream stream,
IFormatter formatter,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static T Deserialize<T>(
Stream stream,
IFormatter formatter,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Parameters

stream
The stream to deserialize
formatter
The object serialization formatter
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The deserialized object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if stream is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Deserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContain Method

Assert.DoesNotContain Method

Verifies that a string does not contain some unexpected substring.

Overload List

Name | Description
DoesNotContain (String, String) | Verifies that a string does not contain some unexpected substring.
DoesNotContain (String, String, String, Object) | Verifies that a string does not contain some unexpected substring.
DoesNotContain (IEnumerable<T>, T) | Verifies that unexpectedValue is not in the enumeration enumeration.
DoesNotContain (IEnumerable<T>, T, String, Object) | Verifies that unexpectedValue is not in the enumeration enumeration.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContain Method (String, String)

Assert.DoesNotContain Method (String, String)
See Also Example
[image]

Verifies that a string does not contain some unexpected substring.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain( _
ByVal actualValue As String, _
ByVal unexpectedSubstring As String _
)
C#
public static void DoesNotContain(
string actualValue,
string unexpectedSubstring
)
C++
public:
static void DoesNotContain(
String actualValue,
String unexpectedSubstring
)
J#
public static void DoesNotContain(
string actualValue,
string unexpectedSubstring
)
JScript
public static function DoesNotContain(
actualValue : String,
unexpectedSubstring : String
)

Parameters

actualValue
The actual value
unexpectedSubstring
The unexpected substring

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if unexpectedSubstring is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContain Method (String, String, String, Object[])

Assert.DoesNotContain Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string does not contain some unexpected substring.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain( _
ByVal actualValue As String, _
ByVal unexpectedSubstring As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void DoesNotContain(
string actualValue,
string unexpectedSubstring,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void DoesNotContain(
String actualValue,
String unexpectedSubstring,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void DoesNotContain(
string actualValue,
string unexpectedSubstring,
string messageFormat,
object[] messageArgs
)
JScript
public static function DoesNotContain(
actualValue : String,
unexpectedSubstring : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
unexpectedSubstring
The unexpected substring
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if unexpectedSubstring is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContain Generic Method (Generic IEnumerable, T)

Assert.DoesNotContain Generic Method (Generic IEnumerable, T)
See Also Example
[image]

Verifies that unexpectedValue is not in the enumeration enumeration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain(Of T)( _
ByVal enumeration As IEnumerable(Of T), _
ByVal unexpectedValue As T _
)
C#
public static void DoesNotContain<T>(
IEnumerable<T> enumeration,
T unexpectedValue
)
C++
public:
static void DoesNotContain<T>(
IEnumerable<T> enumeration,
T unexpectedValue
)
J#
public static void DoesNotContain<T>(
IEnumerable<T> enumeration,
T unexpectedValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

enumeration
The enumeration of items
unexpectedValue
The unexpected value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContain Generic Method (Generic IEnumerable, T, String, Object[])

Assert.DoesNotContain Generic Method (Generic IEnumerable, T, String, Object[])
See Also Example
[image]

Verifies that unexpectedValue is not in the enumeration enumeration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain(Of T)( _
ByVal enumeration As IEnumerable(Of T), _
ByVal unexpectedValue As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void DoesNotContain<T>(
IEnumerable<T> enumeration,
T unexpectedValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void DoesNotContain<T>(
IEnumerable<T> enumeration,
T unexpectedValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void DoesNotContain<T>(
IEnumerable<T> enumeration,
T unexpectedValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

enumeration
The enumeration of items
unexpectedValue
The unexpected value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContainKey Generic Method

Assert.DoesNotContainKey Generic Method

Verifies that unexpectedKey is not in the dictionary dictionary.

Overload List

Name | Description
DoesNotContainKey (IDictionary<TKey, TValue>, TKey) | Verifies that unexpectedKey is not in the dictionary dictionary.
DoesNotContainKey (IDictionary<TKey, TValue>, TKey, String, Object) | Verifies that unexpectedKey is not in the dictionary dictionary.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContainKey Generic Method (Generic IDictionary, TKey)

Assert.DoesNotContainKey Generic Method (Generic IDictionary, TKey)
See Also Example
[image]

Verifies that unexpectedKey is not in the dictionary dictionary.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContainKey(Of TKey, TValue)( _
ByVal dictionary As IDictionary(Of TKey, TValue), _
ByVal unexpectedKey As TKey _
)
C#
public static void DoesNotContainKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey unexpectedKey
)
C++
public:
static void DoesNotContainKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey unexpectedKey
)
J#
public static void DoesNotContainKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey unexpectedKey
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The type of key
TValue
The type of value

Parameters

dictionary
The dictionary of items
unexpectedKey
The key that should not be found in the dictionary

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotContainKey Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotContainKey Generic Method (Generic IDictionary, TKey, String, Object[])

Assert.DoesNotContainKey Generic Method (Generic IDictionary, TKey, String, Object[])
See Also Example
[image]

Verifies that unexpectedKey is not in the dictionary dictionary.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContainKey(Of TKey, TValue)( _
ByVal dictionary As IDictionary(Of TKey, TValue), _
ByVal unexpectedKey As TKey, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void DoesNotContainKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey unexpectedKey,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void DoesNotContainKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey unexpectedKey,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void DoesNotContainKey<TKey, TValue>(
IDictionary<TKey, TValue> dictionary,
TKey unexpectedKey,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The type of key
TValue
The type of value

Parameters

dictionary
The dictionary of items
unexpectedKey
The key expected to be found in the dictionary
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotContainKey Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotThrow Method

Assert.DoesNotThrow Method

Verifies that a block of code does not throw an exception of any type.

Overload List

Name | Description
DoesNotThrow (Action) | Verifies that a block of code does not throw an exception of any type.
DoesNotThrow (Action, String, Object) | Verifies that a block of code does not throw an exception of any type.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotThrow Method (Action)

Assert.DoesNotThrow Method (Action)
See Also Example
[image]

Verifies that a block of code does not throw an exception of any type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotThrow( _
ByVal action As Action _
)
C#
public static void DoesNotThrow(
Action action
)
C++
public:
static void DoesNotThrow(
Action action
)
J#
public static void DoesNotThrow(
Action action
)
JScript
public static function DoesNotThrow(
action : Action
)

Parameters

action
The action delegate to evaluate

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The purpose of this assertion is to improve the readability of tests that only verify that an exception was not thrown. Using this assertion makes a positive and explicit statement that not throwing an exception is itself the primary behavior that is being verified.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotThrow Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DoesNotThrow Method (Action, String, Object[])

Assert.DoesNotThrow Method (Action, String, Object[])
See Also Example
[image]

Verifies that a block of code does not throw an exception of any type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotThrow( _
ByVal action As Action, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void DoesNotThrow(
Action action,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void DoesNotThrow(
Action action,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void DoesNotThrow(
Action action,
string messageFormat,
object[] messageArgs
)
JScript
public static function DoesNotThrow(
action : Action,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

action
The action delegate to evaluate
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The purpose of this assertion is to improve the readability of tests that only verify that an exception was not thrown. Using this assertion makes a positive and explicit statement that not throwing an exception is itself the primary behavior that is being verified.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.DoesNotThrow Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EndsWith Method

Assert.EndsWith Method

Verifies that a string ends with the specified text.

Overload List

Name | Description
EndsWith (String, String) | Verifies that a string ends with the specified text.
EndsWith (String, String, String, Object) | Verifies that a string ends with the specified text.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EndsWith Method (String, String)

Assert.EndsWith Method (String, String)
See Also Example
[image]

Verifies that a string ends with the specified text.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EndsWith( _
ByVal actualValue As String, _
ByVal expectedText As String _
)
C#
public static void EndsWith(
string actualValue,
string expectedText
)
C++
public:
static void EndsWith(
String actualValue,
String expectedText
)
J#
public static void EndsWith(
string actualValue,
string expectedText
)
JScript
public static function EndsWith(
actualValue : String,
expectedText : String
)

Parameters

actualValue
The actual value
expectedText
The expected pattern

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedText is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.EndsWith Overload List
EndsWith

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EndsWith Method (String, String, String, Object[])

Assert.EndsWith Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string ends with the specified text.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EndsWith( _
ByVal actualValue As String, _
ByVal expectedText As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void EndsWith(
string actualValue,
string expectedText,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void EndsWith(
String actualValue,
String expectedText,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void EndsWith(
string actualValue,
string expectedText,
string messageFormat,
object[] messageArgs
)
JScript
public static function EndsWith(
actualValue : String,
expectedText : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
expectedText
The expected pattern
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedText is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.EndsWith Overload List
EndsWith

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Equals Method

Assert.Equals Method
[image]

NOTE: This method is now obsolete.

Use Assert.AreEquals instead.

Always throws an InvalidOperationException. Use AreEqual instead.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Shared Sub Equals( _
ByVal a As Object, _
ByVal b As Object _
)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public static void Equals(
object a,
object b
)
C++
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
static void Equals(
Object a,
Object b
)
J#
/** @attribute EditorBrowsableAttribute(EditorBrowsableState.Never) */
public static void Equals(
object a,
object b
)
JScript
public static

EditorBrowsableAttribute(EditorBrowsableState.Never)
function Equals(
a : Object,
b : Object
)

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Fail Method

Assert.Fail Method

Signals an unconditional assertion failure.

Overload List

Name | Description
Fail | Signals an unconditional assertion failure.
Fail (String, Object) | Signals an unconditional assertion failure with a particular message.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Fail Method ()

Assert.Fail Method ()
See Also Example
[image]

Signals an unconditional assertion failure.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Fail()
C#
public static void Fail()
C++
public:
static void Fail()
J#
public static void Fail()
JScript
public static function Fail()

Exceptions

Exception Type | Condition
AssertionException | Thrown unless the current AssertionFailureBehavior indicates otherwise

Remarks

Use Verify and Fail instead when implementing custom assertions.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Fail Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Fail Method (String, Object[])

Assert.Fail Method (String, Object[])
See Also Example
[image]

Signals an unconditional assertion failure with a particular message.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Fail( _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Fail(
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Fail(
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Fail(
string messageFormat,
object[] messageArgs
)
JScript
public static function Fail(
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

messageFormat
The format of the assertion failure message
messageArgs
The arguments for the assertion failure message format string

Exceptions

Exception Type | Condition
AssertionException | Thrown unless the current AssertionFailureBehavior indicates otherwise

Remarks

Use Verify and Fail instead when implementing custom assertions.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Fail Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method

Assert.FullMatch Method

Verifies that a string matches regular expression pattern exactly.

Overload List

Name | Description
FullMatch (String, String) | Verifies that a string matches regular expression pattern exactly.
FullMatch (String, String, String, Object) | Verifies that a string matches regular expression pattern exactly.
FullMatch (String, String, RegexOptions) | Verifies that a string matches regular expression pattern exactly.
FullMatch (String, String, RegexOptions, String, Object) | Verifies that a string matches regular expression pattern exactly.
FullMatch (String, Regex) | Verifies that a string matches regular expression pattern exactly.
FullMatch (String, Regex, String, Object) | Verifies that a string matches regular expression pattern exactly.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method (String, String)

Assert.FullMatch Method (String, String)
See Also Example
[image]

Verifies that a string matches regular expression pattern exactly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal actualValue As String, _
ByVal regexPattern As String _
)
C#
public static void FullMatch(
string actualValue,
string regexPattern
)
C++
public:
static void FullMatch(
String actualValue,
String regexPattern
)
J#
public static void FullMatch(
string actualValue,
string regexPattern
)
JScript
public static function FullMatch(
actualValue : String,
regexPattern : String
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.FullMatch Overload List
Match

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method (String, String, String, Object[])

Assert.FullMatch Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string matches regular expression pattern exactly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void FullMatch(
string actualValue,
string regexPattern,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void FullMatch(
String actualValue,
String regexPattern,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void FullMatch(
string actualValue,
string regexPattern,
string messageFormat,
object[] messageArgs
)
JScript
public static function FullMatch(
actualValue : String,
regexPattern : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.FullMatch Overload List
Match

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method (String, String, RegexOptions)

Assert.FullMatch Method (String, String, RegexOptions)
See Also Example
[image]

Verifies that a string matches regular expression pattern exactly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal regexOptions As RegexOptions _
)
C#
public static void FullMatch(
string actualValue,
string regexPattern,
RegexOptions regexOptions
)
C++
public:
static void FullMatch(
String actualValue,
String regexPattern,
RegexOptions regexOptions
)
J#
public static void FullMatch(
string actualValue,
string regexPattern,
RegexOptions regexOptions
)
JScript
public static function FullMatch(
actualValue : String,
regexPattern : String,
regexOptions : RegexOptions
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
regexOptions
The regular expression options

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.FullMatch Overload List
Match

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method (String, String, RegexOptions, String, Object[])

Assert.FullMatch Method (String, String, RegexOptions, String, Object[])
See Also Example
[image]

Verifies that a string matches regular expression pattern exactly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal regexOptions As RegexOptions, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void FullMatch(
string actualValue,
string regexPattern,
RegexOptions regexOptions,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void FullMatch(
String actualValue,
String regexPattern,
RegexOptions regexOptions,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void FullMatch(
string actualValue,
string regexPattern,
RegexOptions regexOptions,
string messageFormat,
object[] messageArgs
)
JScript
public static function FullMatch(
actualValue : String,
regexPattern : String,
regexOptions : RegexOptions,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
regexOptions
The regular expression options
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.FullMatch Overload List
Match

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method (String, Regex)

Assert.FullMatch Method (String, Regex)
See Also Example
[image]

Verifies that a string matches regular expression pattern exactly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal actualValue As String, _
ByVal regex As Regex _
)
C#
public static void FullMatch(
string actualValue,
Regex regex
)
C++
public:
static void FullMatch(
String actualValue,
Regex regex
)
J#
public static void FullMatch(
string actualValue,
Regex regex
)
JScript
public static function FullMatch(
actualValue : String,
regex : Regex
)

Parameters

actualValue
The actual value
regex
The regular expression

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regex is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.FullMatch Overload List
Match

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FullMatch Method (String, Regex, String, Object[])

Assert.FullMatch Method (String, Regex, String, Object[])
See Also Example
[image]

Verifies that a string matches regular expression pattern exactly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal actualValue As String, _
ByVal regex As Regex, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void FullMatch(
string actualValue,
Regex regex,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void FullMatch(
String actualValue,
Regex regex,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void FullMatch(
string actualValue,
Regex regex,
string messageFormat,
object[] messageArgs
)
JScript
public static function FullMatch(
actualValue : String,
regex : Regex,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regex
The regular expression
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regex is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.FullMatch Overload List
Match

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method

Assert.GreaterThan Generic Method

Verifies that the left value is greater than the right value according to a particular comparer.

Overload List

Name | Description
GreaterThan (T, T) | Verifies that the left value is greater than the right value according to a particular comparer.
GreaterThan (T, T, IComparer<T>) | Verifies that the left value is greater than the right value according to a particular comparer.
GreaterThan (T, T, IComparer<T>, String, Object) | Verifies that the left value is greater than the right value according to a particular comparer.
GreaterThan (T, T, Comparison<T>) | Verifies that the left value is greater than the right value according to a particular comparer.
GreaterThan (T, T, Comparison<T>, String, Object) | Verifies that the left value is greater than the right value according to a particular comparer.
GreaterThan (T, T, String, Object) | Verifies that the left value is greater than the right value according to a particular comparer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method (T, T)

Assert.GreaterThan Generic Method (T, T)
See Also Example
[image]

Verifies that the left value is greater than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan(Of T)( _
ByVal left As T, _
ByVal right As T _
)
C#
public static void GreaterThan<T>(
T left,
T right
)
C++
public:
static void GreaterThan<T>(
T left,
T right
)
J#
public static void GreaterThan<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method (T, T, Generic IComparer)

Assert.GreaterThan Generic Method (T, T, Generic IComparer)
See Also Example
[image]

Verifies that the left value is greater than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T) _
)
C#
public static void GreaterThan<T>(
T left,
T right,
IComparer<T> comparer
)
C++
public:
static void GreaterThan<T>(
T left,
T right,
IComparer<T> comparer
)
J#
public static void GreaterThan<T>(
T left,
T right,
IComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method (T, T, Generic IComparer, String, Object[])

Assert.GreaterThan Generic Method (T, T, Generic IComparer, String, Object[])
See Also Example
[image]

Verifies that the left value is greater than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void GreaterThan<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void GreaterThan<T>(
T left,
T right,
IComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void GreaterThan<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method (T, T, Generic Comparison)

Assert.GreaterThan Generic Method (T, T, Generic Comparison)
See Also Example
[image]

Verifies that the left value is greater than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T) _
)
C#
public static void GreaterThan<T>(
T left,
T right,
Comparison<T> comparer
)
C++
public:
static void GreaterThan<T>(
T left,
T right,
Comparison<T> comparer
)
J#
public static void GreaterThan<T>(
T left,
T right,
Comparison<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method (T, T, Generic Comparison, String, Object[])

Assert.GreaterThan Generic Method (T, T, Generic Comparison, String, Object[])
See Also Example
[image]

Verifies that the left value is greater than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void GreaterThan<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void GreaterThan<T>(
T left,
T right,
Comparison<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void GreaterThan<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThan Generic Method (T, T, String, Object[])

Assert.GreaterThan Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that the left value is greater than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void GreaterThan<T>(
T left,
T right,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void GreaterThan<T>(
T left,
T right,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void GreaterThan<T>(
T left,
T right,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method

Assert.GreaterThanOrEqualTo Generic Method

Verifies that the left value is greater than or equal to the right value according to a particular comparer.

Overload List

Name | Description
GreaterThanOrEqualTo (T, T) | Verifies that the left value is greater than or equal to the right value according to a particular comparer.
GreaterThanOrEqualTo (T, T, IComparer<T>) | Verifies that the left value is greater than or equal to the right value according to a particular comparer.
GreaterThanOrEqualTo (T, T, IComparer<T>, String, Object) | Verifies that the left value is greater than or equal to the right value according to a particular comparer.
GreaterThanOrEqualTo (T, T, Comparison<T>) | Verifies that the left value is greater than or equal to the right value according to a particular comparer.
GreaterThanOrEqualTo (T, T, Comparison<T>, String, Object) | Verifies that the left value is greater or equal than right value according to a particular comparer.
GreaterThanOrEqualTo (T, T, String, Object) | Verifies that the left value is greater than or equal to the right value according to a particular comparer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method (T, T)

Assert.GreaterThanOrEqualTo Generic Method (T, T)
See Also Example
[image]

Verifies that the left value is greater than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T _
)
C#
public static void GreaterThanOrEqualTo<T>(
T left,
T right
)
C++
public:
static void GreaterThanOrEqualTo<T>(
T left,
T right
)
J#
public static void GreaterThanOrEqualTo<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method (T, T, Generic IComparer)

Assert.GreaterThanOrEqualTo Generic Method (T, T, Generic IComparer)
See Also Example
[image]

Verifies that the left value is greater than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T) _
)
C#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer
)
C++
public:
static void GreaterThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer
)
J#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method (T, T, Generic IComparer, String, Object[])

Assert.GreaterThanOrEqualTo Generic Method (T, T, Generic IComparer, String, Object[])
See Also Example
[image]

Verifies that the left value is greater than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void GreaterThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method (T, T, Generic Comparison)

Assert.GreaterThanOrEqualTo Generic Method (T, T, Generic Comparison)
See Also Example
[image]

Verifies that the left value is greater than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T) _
)
C#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer
)
C++
public:
static void GreaterThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer
)
J#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method (T, T, Generic Comparison, String, Object[])

Assert.GreaterThanOrEqualTo Generic Method (T, T, Generic Comparison, String, Object[])
See Also Example
[image]

Verifies that the left value is greater or equal than right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void GreaterThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GreaterThanOrEqualTo Generic Method (T, T, String, Object[])

Assert.GreaterThanOrEqualTo Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that the left value is greater than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void GreaterThanOrEqualTo<T>(
T left,
T right,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void GreaterThanOrEqualTo<T>(
T left,
T right,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.GreaterThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Inconclusive Method

Assert.Inconclusive Method

Terminates the test and reports an inconclusive test outcome.

Overload List

Name | Description
Inconclusive | Terminates the test and reports an inconclusive test outcome.
Inconclusive (String, Object) | Terminates the test and reports an inconclusive test outcome.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Inconclusive Method ()

Assert.Inconclusive Method ()
See Also Example
[image]

Terminates the test and reports an inconclusive test outcome.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Inconclusive()
C#
public static void Inconclusive()
C++
public:
static void Inconclusive()
J#
public static void Inconclusive()
JScript
public static function Inconclusive()

Exceptions

Exception Type | Condition
TestInconclusiveException | Thrown always

Remarks

The test is terminated with an inconclusive test outcome by throwing a TestInconclusiveException. If other code in the test case catches this exception and does not rethrow it then the test might not terminate correctly.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Inconclusive Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Inconclusive Method (String, Object[])

Assert.Inconclusive Method (String, Object[])
See Also Example
[image]

Terminates the test and reports an inconclusive test outcome.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Inconclusive( _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Inconclusive(
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Inconclusive(
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Inconclusive(
string messageFormat,
object[] messageArgs
)
JScript
public static function Inconclusive(
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

messageFormat
The custom message format string, or null if none
messageArgs
The custom message arguments, or null if none

Exceptions

Exception Type | Condition
TestInconclusiveException | Thrown always

Remarks

The test is terminated with an inconclusive test outcome by throwing a TestInconclusiveException. If other code in the test case catches this exception and does not rethrow it then the test might not terminate correctly.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Inconclusive Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsAssignableFrom Method

Assert.IsAssignableFrom Method

Verifies that an object may be assigned to a variable of the specified type.

Overload List

Name | Description
IsAssignableFrom (Type, Object) | Verifies that an object may be assigned to a variable of the specified type.
IsAssignableFrom (Type, Object, String, Object) | Verifies that an object may be assigned to a variable of the specified type.
IsAssignableFrom (Object) | Verifies that an object may be assigned to a variable of the specified type.
IsAssignableFrom (Object, String, Object) | Verifies that an object may be assigned to a variable of the specified type.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsAssignableFrom Method (Type, Object)

Assert.IsAssignableFrom Method (Type, Object)
See Also Example
[image]

Verifies that an object may be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom( _
ByVal expectedType As Type, _
ByVal actualValue As Object _
)
C#
public static void IsAssignableFrom(
Type expectedType,
object actualValue
)
C++
public:
static void IsAssignableFrom(
Type expectedType,
Object actualValue
)
J#
public static void IsAssignableFrom(
Type expectedType,
object actualValue
)
JScript
public static function IsAssignableFrom(
expectedType : Type,
actualValue : Object
)

Parameters

expectedType
The Type to compare with the object's Type
actualValue
The object under examination

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if expectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsAssignableFrom Method (Type, Object, String, Object[])

Assert.IsAssignableFrom Method (Type, Object, String, Object[])
See Also Example
[image]

Verifies that an object may be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom( _
ByVal expectedType As Type, _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsAssignableFrom(
Type expectedType,
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsAssignableFrom(
Type expectedType,
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsAssignableFrom(
Type expectedType,
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsAssignableFrom(
expectedType : Type,
actualValue : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

expectedType
The Type to compare with the object's Type
actualValue
The object under examination
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if expectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsAssignableFrom Generic Method (Object)

Assert.IsAssignableFrom Generic Method (Object)
See Also Example
[image]

Verifies that an object may be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom(Of TExpected)( _
ByVal actualValue As Object _
)
C#
public static void IsAssignableFrom<TExpected>(
object actualValue
)
C++
public:
static void IsAssignableFrom<TExpected>(
Object actualValue
)
J#
public static void IsAssignableFrom<TExpected>(
object actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

TExpected
The Type to compare with the object's Type

Parameters

actualValue
The object under examination

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsAssignableFrom Generic Method (Object, String, Object[])

Assert.IsAssignableFrom Generic Method (Object, String, Object[])
See Also Example
[image]

Verifies that an object may be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom(Of TExpected)( _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsAssignableFrom<TExpected>(
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsAssignableFrom<TExpected>(
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsAssignableFrom<TExpected>(
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TExpected
The Type to compare with the object's Type

Parameters

actualValue
The object under examination
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsEmpty Method

Assert.IsEmpty Method

Verifies that an actual value contains no elements.

Overload List

Name | Description
IsEmpty (IEnumerable) | Verifies that an actual value contains no elements.
IsEmpty (IEnumerable, String, Object) | Verifies that an actual value contains no elements.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsEmpty Method (IEnumerable)

Assert.IsEmpty Method (IEnumerable)
See Also Example
[image]

Verifies that an actual value contains no elements.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal actualValue As IEnumerable _
)
C#
public static void IsEmpty(
IEnumerable actualValue
)
C++
public:
static void IsEmpty(
IEnumerable actualValue
)
J#
public static void IsEmpty(
IEnumerable actualValue
)
JScript
public static function IsEmpty(
actualValue : IEnumerable
)

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsEmpty Method (IEnumerable, String, Object[])

Assert.IsEmpty Method (IEnumerable, String, Object[])
See Also Example
[image]

Verifies that an actual value contains no elements.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal actualValue As IEnumerable, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsEmpty(
IEnumerable actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsEmpty(
IEnumerable actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsEmpty(
IEnumerable actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsEmpty(
actualValue : IEnumerable,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsFalse Method

Assert.IsFalse Method

Verifies that an actual value is false.

Overload List

Name | Description
IsFalse (Boolean) | Verifies that an actual value is false.
IsFalse (Boolean, String, Object) | Verifies that an actual value is false.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsFalse Method (Boolean)

Assert.IsFalse Method (Boolean)
See Also Example
[image]

Verifies that an actual value is false.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsFalse( _
ByVal actualValue As Boolean _
)
C#
public static void IsFalse(
bool actualValue
)
C++
public:
static void IsFalse(
bool actualValue
)
J#
public static void IsFalse(
bool actualValue
)
JScript
public static function IsFalse(
actualValue : bool
)

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsFalse Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsFalse Method (Boolean, String, Object[])

Assert.IsFalse Method (Boolean, String, Object[])
See Also Example
[image]

Verifies that an actual value is false.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsFalse( _
ByVal actualValue As Boolean, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsFalse(
bool actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsFalse(
bool actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsFalse(
bool actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsFalse(
actualValue : bool,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsFalse Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsInstanceOfType Method

Assert.IsInstanceOfType Method

Verifies that an actual value is an instance of some expected type.

Overload List

Name | Description
IsInstanceOfType (Type, Object) | Verifies that an actual value is an instance of some expected type.
IsInstanceOfType (Type, Object, String, Object) | Verifies that an actual value is an instance of some expected type.
IsInstanceOfType (Object) | Verifies that an actual value is an instance of some expected type.
IsInstanceOfType (Object, String, Object) | Verifies that an actual value is an instance of some expected type.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsInstanceOfType Method (Type, Object)

Assert.IsInstanceOfType Method (Type, Object)
See Also Example
[image]

Verifies that an actual value is an instance of some expected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType( _
ByVal expectedType As Type, _
ByVal actualValue As Object _
)
C#
public static void IsInstanceOfType(
Type expectedType,
object actualValue
)
C++
public:
static void IsInstanceOfType(
Type expectedType,
Object actualValue
)
J#
public static void IsInstanceOfType(
Type expectedType,
object actualValue
)
JScript
public static function IsInstanceOfType(
expectedType : Type,
actualValue : Object
)

Parameters

expectedType
The expected type
actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsInstanceOfType Method (Type, Object, String, Object[])

Assert.IsInstanceOfType Method (Type, Object, String, Object[])
See Also Example
[image]

Verifies that an actual value is an instance of some expected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType( _
ByVal expectedType As Type, _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsInstanceOfType(
Type expectedType,
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsInstanceOfType(
Type expectedType,
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsInstanceOfType(
Type expectedType,
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsInstanceOfType(
expectedType : Type,
actualValue : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

expectedType
The expected type
actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsInstanceOfType Generic Method (Object)

Assert.IsInstanceOfType Generic Method (Object)
See Also Example
[image]

Verifies that an actual value is an instance of some expected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType(Of TExpected)( _
ByVal actualValue As Object _
)
C#
public static void IsInstanceOfType<TExpected>(
object actualValue
)
C++
public:
static void IsInstanceOfType<TExpected>(
Object actualValue
)
J#
public static void IsInstanceOfType<TExpected>(
object actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

TExpected
The expected type

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsInstanceOfType Generic Method (Object, String, Object[])

Assert.IsInstanceOfType Generic Method (Object, String, Object[])
See Also Example
[image]

Verifies that an actual value is an instance of some expected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType(Of TExpected)( _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsInstanceOfType<TExpected>(
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsInstanceOfType<TExpected>(
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsInstanceOfType<TExpected>(
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TExpected
The expected type

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotAssignableFrom Method

Assert.IsNotAssignableFrom Method

Verifies that an object may not be assigned to a variable of the specified type.

Overload List

Name | Description
IsNotAssignableFrom (Type, Object) | Verifies that an object may not be assigned to a variable of the specified type.
IsNotAssignableFrom (Type, Object, String, Object) | Verifies that an object may not be assigned to a variable of the specified type.
IsNotAssignableFrom (Object) | Verifies that an object may not be assigned to a variable of the specified type.
IsNotAssignableFrom (Object, String, Object) | Verifies that an object may not be assigned to a variable of the specified type.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotAssignableFrom Method (Type, Object)

Assert.IsNotAssignableFrom Method (Type, Object)
See Also Example
[image]

Verifies that an object may not be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom( _
ByVal unexpectedType As Type, _
ByVal actualValue As Object _
)
C#
public static void IsNotAssignableFrom(
Type unexpectedType,
object actualValue
)
C++
public:
static void IsNotAssignableFrom(
Type unexpectedType,
Object actualValue
)
J#
public static void IsNotAssignableFrom(
Type unexpectedType,
object actualValue
)
JScript
public static function IsNotAssignableFrom(
unexpectedType : Type,
actualValue : Object
)

Parameters

unexpectedType
The Type to compare with the object's Type
actualValue
The object under examination

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if unexpectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotAssignableFrom Method (Type, Object, String, Object[])

Assert.IsNotAssignableFrom Method (Type, Object, String, Object[])
See Also Example
[image]

Verifies that an object may not be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom( _
ByVal unexpectedType As Type, _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNotAssignableFrom(
Type unexpectedType,
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNotAssignableFrom(
Type unexpectedType,
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNotAssignableFrom(
Type unexpectedType,
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsNotAssignableFrom(
unexpectedType : Type,
actualValue : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

unexpectedType
The Type to compare with the object's Type
actualValue
The object under examination
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if unexpectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotAssignableFrom Generic Method (Object)

Assert.IsNotAssignableFrom Generic Method (Object)
See Also Example
[image]

Verifies that an object may not be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom(Of TUnexpected)( _
ByVal actualValue As Object _
)
C#
public static void IsNotAssignableFrom<TUnexpected>(
object actualValue
)
C++
public:
static void IsNotAssignableFrom<TUnexpected>(
Object actualValue
)
J#
public static void IsNotAssignableFrom<TUnexpected>(
object actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

TUnexpected
The Type to compare with the object's Type

Parameters

actualValue
The object under examination

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotAssignableFrom Generic Method (Object, String, Object[])

Assert.IsNotAssignableFrom Generic Method (Object, String, Object[])
See Also Example
[image]

Verifies that an object may not be assigned to a variable of the specified type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom(Of TUnexpected)( _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNotAssignableFrom<TUnexpected>(
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNotAssignableFrom<TUnexpected>(
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNotAssignableFrom<TUnexpected>(
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TUnexpected
The Type to compare with the object's Type

Parameters

actualValue
The object under examination
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotAssignableFrom Overload List
IsAssignableFrom

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotEmpty Method

Assert.IsNotEmpty Method

Verifies that an actual value contains at least one element.

Overload List

Name | Description
IsNotEmpty (IEnumerable) | Verifies that an actual value contains at least one element.
IsNotEmpty (IEnumerable, String, Object) | Verifies that an actual value contains at least one element.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotEmpty Method (IEnumerable)

Assert.IsNotEmpty Method (IEnumerable)
See Also Example
[image]

Verifies that an actual value contains at least one element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal actualValue As IEnumerable _
)
C#
public static void IsNotEmpty(
IEnumerable actualValue
)
C++
public:
static void IsNotEmpty(
IEnumerable actualValue
)
J#
public static void IsNotEmpty(
IEnumerable actualValue
)
JScript
public static function IsNotEmpty(
actualValue : IEnumerable
)

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotEmpty Method (IEnumerable, String, Object[])

Assert.IsNotEmpty Method (IEnumerable, String, Object[])
See Also Example
[image]

Verifies that an actual value contains at least one element.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal actualValue As IEnumerable, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNotEmpty(
IEnumerable actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNotEmpty(
IEnumerable actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNotEmpty(
IEnumerable actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsNotEmpty(
actualValue : IEnumerable,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotInstanceOfType Method

Assert.IsNotInstanceOfType Method

Verifies that an actual value is not an instance of some unexpected type.

Overload List

Name | Description
IsNotInstanceOfType (Type, Object) | Verifies that an actual value is not an instance of some unexpected type.
IsNotInstanceOfType (Type, Object, String, Object) | Verifies that an actual value is not an instance of some unexpected type.
IsNotInstanceOfType (Object) | Verifies that an actual value is not an instance of some unexpected type.
IsNotInstanceOfType (Object, String, Object) | Verifies that an actual value is not an instance of some unexpected type.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotInstanceOfType Method (Type, Object)

Assert.IsNotInstanceOfType Method (Type, Object)
See Also Example
[image]

Verifies that an actual value is not an instance of some unexpected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType( _
ByVal unexpectedType As Type, _
ByVal actualValue As Object _
)
C#
public static void IsNotInstanceOfType(
Type unexpectedType,
object actualValue
)
C++
public:
static void IsNotInstanceOfType(
Type unexpectedType,
Object actualValue
)
J#
public static void IsNotInstanceOfType(
Type unexpectedType,
object actualValue
)
JScript
public static function IsNotInstanceOfType(
unexpectedType : Type,
actualValue : Object
)

Parameters

unexpectedType
The unexpected type
actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if unexpectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotInstanceOfType Method (Type, Object, String, Object[])

Assert.IsNotInstanceOfType Method (Type, Object, String, Object[])
See Also Example
[image]

Verifies that an actual value is not an instance of some unexpected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType( _
ByVal unexpectedType As Type, _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNotInstanceOfType(
Type unexpectedType,
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNotInstanceOfType(
Type unexpectedType,
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNotInstanceOfType(
Type unexpectedType,
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsNotInstanceOfType(
unexpectedType : Type,
actualValue : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

unexpectedType
The unexpected type
actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if unexpectedType is null

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotInstanceOfType Generic Method (Object)

Assert.IsNotInstanceOfType Generic Method (Object)
See Also Example
[image]

Verifies that an actual value is not an instance of some unexpected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType(Of TUnexpected)( _
ByVal actualValue As Object _
)
C#
public static void IsNotInstanceOfType<TUnexpected>(
object actualValue
)
C++
public:
static void IsNotInstanceOfType<TUnexpected>(
Object actualValue
)
J#
public static void IsNotInstanceOfType<TUnexpected>(
object actualValue
)
JScript
JScript does not support generic types and methods.

Type Parameters

TUnexpected
The unexpected type

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotInstanceOfType Generic Method (Object, String, Object[])

Assert.IsNotInstanceOfType Generic Method (Object, String, Object[])
See Also Example
[image]

Verifies that an actual value is not an instance of some unexpected type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType(Of TUnexpected)( _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNotInstanceOfType<TUnexpected>(
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNotInstanceOfType<TUnexpected>(
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNotInstanceOfType<TUnexpected>(
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TUnexpected
The unexpected type

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion will fail if the object is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotNull Method

Assert.IsNotNull Method

Verifies that an actual value is not null.

Overload List

Name | Description
IsNotNull (Object) | Verifies that an actual value is not null.
IsNotNull (Object, String, Object) | Verifies that an actual value is not null.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotNull Method (Object)

Assert.IsNotNull Method (Object)
See Also Example
[image]

Verifies that an actual value is not null.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotNull( _
ByVal actualValue As Object _
)
C#
public static void IsNotNull(
object actualValue
)
C++
public:
static void IsNotNull(
Object actualValue
)
J#
public static void IsNotNull(
object actualValue
)
JScript
public static function IsNotNull(
actualValue : Object
)

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNotNull Method (Object, String, Object[])

Assert.IsNotNull Method (Object, String, Object[])
See Also Example
[image]

Verifies that an actual value is not null.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotNull( _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNotNull(
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNotNull(
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNotNull(
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsNotNull(
actualValue : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNull Method

Assert.IsNull Method

Verifies that an actual value is null.

Overload List

Name | Description
IsNull (Object) | Verifies that an actual value is null.
IsNull (Object, String, Object) | Verifies that an actual value is null.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNull Method (Object)

Assert.IsNull Method (Object)
See Also Example
[image]

Verifies that an actual value is null.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNull( _
ByVal actualValue As Object _
)
C#
public static void IsNull(
object actualValue
)
C++
public:
static void IsNull(
Object actualValue
)
J#
public static void IsNull(
object actualValue
)
JScript
public static function IsNull(
actualValue : Object
)

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsNull Method (Object, String, Object[])

Assert.IsNull Method (Object, String, Object[])
See Also Example
[image]

Verifies that an actual value is null.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNull( _
ByVal actualValue As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsNull(
object actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsNull(
Object actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsNull(
object actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsNull(
actualValue : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsSerializableType Method

Assert.IsSerializableType Method

Verifies that a type supports the runtime serialization protocol.

Overload List

Name | Description
IsSerializableType (Type) | Verifies that a type supports the runtime serialization protocol.
IsSerializableType (Type, String, Object) | Verifies that a type supports the runtime serialization protocol.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsSerializableType Method (Type)

Assert.IsSerializableType Method (Type)
See Also Example
[image]

Verifies that a type supports the runtime serialization protocol.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSerializableType( _
ByVal type As Type _
)
C#
public static void IsSerializableType(
Type type
)
C++
public:
static void IsSerializableType(
Type type
)
J#
public static void IsSerializableType(
Type type
)
JScript
public static function IsSerializableType(
type : Type
)

Parameters

type
The type to verify

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if type is null

Remarks

Ensures that the type has the SerializableAttribute. Also ensures that if it implements ISerializable then it also has a deserialization constructor with signature .ctor(SerializationInfo info, StreamingContext context).

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsSerializableType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsSerializableType Method (Type, String, Object[])

Assert.IsSerializableType Method (Type, String, Object[])
See Also Example
[image]

Verifies that a type supports the runtime serialization protocol.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSerializableType( _
ByVal type As Type, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsSerializableType(
Type type,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsSerializableType(
Type type,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsSerializableType(
Type type,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsSerializableType(
type : Type,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

type
The type to verify
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if type is null

Remarks

Ensures that the type has the SerializableAttribute. Also ensures that if it implements ISerializable then it also has a deserialization constructor with signature .ctor(SerializationInfo, StreamingContext).

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsSerializableType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTrue Method

Assert.IsTrue Method

Verifies that an actual value is true.

Overload List

Name | Description
IsTrue (Boolean) | Verifies that an actual value is true.
IsTrue (Boolean, String, Object) | Verifies that an actual value is true.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTrue Method (Boolean)

Assert.IsTrue Method (Boolean)
See Also Example
[image]

Verifies that an actual value is true.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsTrue( _
ByVal actualValue As Boolean _
)
C#
public static void IsTrue(
bool actualValue
)
C++
public:
static void IsTrue(
bool actualValue
)
J#
public static void IsTrue(
bool actualValue
)
JScript
public static function IsTrue(
actualValue : bool
)

Parameters

actualValue
The actual value

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsTrue Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTrue Method (Boolean, String, Object[])

Assert.IsTrue Method (Boolean, String, Object[])
See Also Example
[image]

Verifies that an actual value is true.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsTrue( _
ByVal actualValue As Boolean, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsTrue(
bool actualValue,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsTrue(
bool actualValue,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsTrue(
bool actualValue,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsTrue(
actualValue : bool,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsTrue Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsXmlSerializableType Method

Assert.IsXmlSerializableType Method

Verifies that a type supports the Xml serialization protocol used by XmlSerializer.

Overload List

Name | Description
IsXmlSerializableType (Type) | Verifies that a type supports the Xml serialization protocol used by XmlSerializer.
IsXmlSerializableType (Type, String, Object) | Verifies that a type supports the Xml serialization protocol used by XmlSerializer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsXmlSerializableType Method (Type)

Assert.IsXmlSerializableType Method (Type)
See Also Example
[image]

Verifies that a type supports the Xml serialization protocol used by XmlSerializer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsXmlSerializableType( _
ByVal type As Type _
)
C#
public static void IsXmlSerializableType(
Type type
)
C++
public:
static void IsXmlSerializableType(
Type type
)
J#
public static void IsXmlSerializableType(
Type type
)
JScript
public static function IsXmlSerializableType(
type : Type
)

Parameters

type
The type to verify

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if type is null

Remarks

Ensures that an XmlSerializer for the type can be constructed without error.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsXmlSerializableType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsXmlSerializableType Method (Type, String, Object[])

Assert.IsXmlSerializableType Method (Type, String, Object[])
See Also Example
[image]

Verifies that a type supports the Xml serialization protocol used by XmlSerializer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsXmlSerializableType( _
ByVal type As Type, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void IsXmlSerializableType(
Type type,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void IsXmlSerializableType(
Type type,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void IsXmlSerializableType(
Type type,
string messageFormat,
object[] messageArgs
)
JScript
public static function IsXmlSerializableType(
type : Type,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

type
The type to verify
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if type is null

Remarks

Ensures that an XmlSerializer for the type can be constructed without error.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.IsXmlSerializableType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method

Assert.LessThan Generic Method

Verifies that the left value is less than the right value according to a particular comparer.

Overload List

Name | Description
LessThan (T, T) | Verifies that the left value is less than the right value according to a particular comparer.
LessThan (T, T, IComparer<T>) | Verifies that the left value is less than the right value according to a particular comparer.
LessThan (T, T, IComparer<T>, String, Object) | Verifies that the left value is less than the right value according to a particular comparer.
LessThan (T, T, Comparison<T>) | Verifies that the left value is less than the right value according to a particular comparer.
LessThan (T, T, Comparison<T>, String, Object) | Verifies that the left value is less than the right value according to a particular comparer.
LessThan (T, T, String, Object) | Verifies that the left value is less than the right value according to a particular comparer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method (T, T)

Assert.LessThan Generic Method (T, T)
See Also Example
[image]

Verifies that the left value is less than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThan(Of T)( _
ByVal left As T, _
ByVal right As T _
)
C#
public static void LessThan<T>(
T left,
T right
)
C++
public:
static void LessThan<T>(
T left,
T right
)
J#
public static void LessThan<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method (T, T, Generic IComparer)

Assert.LessThan Generic Method (T, T, Generic IComparer)
See Also Example
[image]

Verifies that the left value is less than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T) _
)
C#
public static void LessThan<T>(
T left,
T right,
IComparer<T> comparer
)
C++
public:
static void LessThan<T>(
T left,
T right,
IComparer<T> comparer
)
J#
public static void LessThan<T>(
T left,
T right,
IComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method (T, T, Generic IComparer, String, Object[])

Assert.LessThan Generic Method (T, T, Generic IComparer, String, Object[])
See Also Example
[image]

Verifies that the left value is less than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void LessThan<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void LessThan<T>(
T left,
T right,
IComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void LessThan<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method (T, T, Generic Comparison)

Assert.LessThan Generic Method (T, T, Generic Comparison)
See Also Example
[image]

Verifies that the left value is less than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T) _
)
C#
public static void LessThan<T>(
T left,
T right,
Comparison<T> comparer
)
C++
public:
static void LessThan<T>(
T left,
T right,
Comparison<T> comparer
)
J#
public static void LessThan<T>(
T left,
T right,
Comparison<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method (T, T, Generic Comparison, String, Object[])

Assert.LessThan Generic Method (T, T, Generic Comparison, String, Object[])
See Also Example
[image]

Verifies that the left value is less than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void LessThan<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void LessThan<T>(
T left,
T right,
Comparison<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void LessThan<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThan Generic Method (T, T, String, Object[])

Assert.LessThan Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that the left value is less than the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThan(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void LessThan<T>(
T left,
T right,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void LessThan<T>(
T left,
T right,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void LessThan<T>(
T left,
T right,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method

Assert.LessThanOrEqualTo Generic Method

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Overload List

Name | Description
LessThanOrEqualTo (T, T) | Verifies that the left value is less than or equal to the right value according to a particular comparer.
LessThanOrEqualTo (T, T, IComparer<T>) | Verifies that the left value is less than or equal to the right value according to a particular comparer.
LessThanOrEqualTo (T, T, IComparer<T>, String, Object) | Verifies that the left value is less than or equal to the right value according to a particular comparer.
LessThanOrEqualTo (T, T, Comparison<T>) | Verifies that the left value is less than or equal to the right value according to a particular comparer.
LessThanOrEqualTo (T, T, Comparison<T>, String, Object) | Verifies that the left value is less than or equal to the right value according to a particular comparer.
LessThanOrEqualTo (T, T, String, Object) | Verifies that the left value is less than or equal to the right value according to a particular comparer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method (T, T)

Assert.LessThanOrEqualTo Generic Method (T, T)
See Also Example
[image]

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T _
)
C#
public static void LessThanOrEqualTo<T>(
T left,
T right
)
C++
public:
static void LessThanOrEqualTo<T>(
T left,
T right
)
J#
public static void LessThanOrEqualTo<T>(
T left,
T right
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method (T, T, Generic IComparer)

Assert.LessThanOrEqualTo Generic Method (T, T, Generic IComparer)
See Also Example
[image]

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T) _
)
C#
public static void LessThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer
)
C++
public:
static void LessThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer
)
J#
public static void LessThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method (T, T, Generic IComparer, String, Object[])

Assert.LessThanOrEqualTo Generic Method (T, T, Generic IComparer, String, Object[])
See Also Example
[image]

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As IComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void LessThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void LessThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void LessThanOrEqualTo<T>(
T left,
T right,
IComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method (T, T, Generic Comparison)

Assert.LessThanOrEqualTo Generic Method (T, T, Generic Comparison)
See Also Example
[image]

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T) _
)
C#
public static void LessThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer
)
C++
public:
static void LessThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer
)
J#
public static void LessThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method (T, T, Generic Comparison, String, Object[])

Assert.LessThanOrEqualTo Generic Method (T, T, Generic Comparison, String, Object[])
See Also Example
[image]

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal comparer As Comparison(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void LessThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void LessThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void LessThanOrEqualTo<T>(
T left,
T right,
Comparison<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


LessThanOrEqualTo Generic Method (T, T, String, Object[])

Assert.LessThanOrEqualTo Generic Method (T, T, String, Object[])
See Also Example
[image]

Verifies that the left value is less than or equal to the right value according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LessThanOrEqualTo(Of T)( _
ByVal left As T, _
ByVal right As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void LessThanOrEqualTo<T>(
T left,
T right,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void LessThanOrEqualTo<T>(
T left,
T right,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void LessThanOrEqualTo<T>(
T left,
T right,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

left
The expected value
right
The actual value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.LessThanOrEqualTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method

Assert.Like Method

Verifies that a string contains a full or partial match of a regular expression pattern.

Overload List

Name | Description
Like (String, String) | Verifies that a string contains a full or partial match of a regular expression pattern.
Like (String, String, String, Object) | Verifies that a string contains a full or partial match of a regular expression pattern.
Like (String, String, RegexOptions) | Verifies that a string contains a full or partial match of a regular expression pattern.
Like (String, String, RegexOptions, String, Object) | Verifies that a string contains a full or partial match of a regular expression pattern.
Like (String, Regex) | Verifies that a string contains a full or partial match of a regular expression pattern.
Like (String, Regex, String, Object) | Verifies that a string contains a full or partial match of a regular expression pattern.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method (String, String)

Assert.Like Method (String, String)
See Also Example
[image]

Verifies that a string contains a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal actualValue As String, _
ByVal regexPattern As String _
)
C#
public static void Like(
string actualValue,
string regexPattern
)
C++
public:
static void Like(
String actualValue,
String regexPattern
)
J#
public static void Like(
string actualValue,
string regexPattern
)
JScript
public static function Like(
actualValue : String,
regexPattern : String
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Like Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method (String, String, String, Object[])

Assert.Like Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string contains a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Like(
string actualValue,
string regexPattern,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Like(
String actualValue,
String regexPattern,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Like(
string actualValue,
string regexPattern,
string messageFormat,
object[] messageArgs
)
JScript
public static function Like(
actualValue : String,
regexPattern : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Like Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method (String, String, RegexOptions)

Assert.Like Method (String, String, RegexOptions)
See Also Example
[image]

Verifies that a string contains a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal regexOptions As RegexOptions _
)
C#
public static void Like(
string actualValue,
string regexPattern,
RegexOptions regexOptions
)
C++
public:
static void Like(
String actualValue,
String regexPattern,
RegexOptions regexOptions
)
J#
public static void Like(
string actualValue,
string regexPattern,
RegexOptions regexOptions
)
JScript
public static function Like(
actualValue : String,
regexPattern : String,
regexOptions : RegexOptions
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
regexOptions
The regular expression options

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Like Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method (String, String, RegexOptions, String, Object[])

Assert.Like Method (String, String, RegexOptions, String, Object[])
See Also Example
[image]

Verifies that a string contains a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal regexOptions As RegexOptions, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Like(
string actualValue,
string regexPattern,
RegexOptions regexOptions,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Like(
String actualValue,
String regexPattern,
RegexOptions regexOptions,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Like(
string actualValue,
string regexPattern,
RegexOptions regexOptions,
string messageFormat,
object[] messageArgs
)
JScript
public static function Like(
actualValue : String,
regexPattern : String,
regexOptions : RegexOptions,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
regexOptions
The regular expression options
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Like Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method (String, Regex)

Assert.Like Method (String, Regex)
See Also Example
[image]

Verifies that a string contains a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal actualValue As String, _
ByVal regex As Regex _
)
C#
public static void Like(
string actualValue,
Regex regex
)
C++
public:
static void Like(
String actualValue,
Regex regex
)
J#
public static void Like(
string actualValue,
Regex regex
)
JScript
public static function Like(
actualValue : String,
regex : Regex
)

Parameters

actualValue
The actual value
regex
The regular expression

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regex is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Like Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Like Method (String, Regex, String, Object[])

Assert.Like Method (String, Regex, String, Object[])
See Also Example
[image]

Verifies that a string contains a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal actualValue As String, _
ByVal regex As Regex, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Like(
string actualValue,
Regex regex,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Like(
String actualValue,
Regex regex,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Like(
string actualValue,
Regex regex,
string messageFormat,
object[] messageArgs
)
JScript
public static function Like(
actualValue : String,
regex : Regex,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regex
The regular expression
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regex is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Like Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Multiple Method

Assert.Multiple Method

Evaluates a block of code that contains multiple related assertions.

Overload List

Name | Description
Multiple (Action) | Evaluates a block of code that contains multiple related assertions.
Multiple (Action, String, Object) | Evaluates a block of code that contains multiple related assertions.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Multiple Method (Action)

Assert.Multiple Method (Action)
See Also Example
[image]

Evaluates a block of code that contains multiple related assertions.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Multiple( _
ByVal action As Action _
)
C#
public static void Multiple(
Action action
)
C++
public:
static void Multiple(
Action action
)
J#
public static void Multiple(
Action action
)
JScript
public static function Multiple(
action : Action
)

Parameters

action
The action to invoke

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

While the action delegate runs, the behavior of assertions is change such that failures are captured but do not cause a AssertionFailureException to be throw. When the delegate returns, the previous assertion failure behavior is restored and any captured assertion failures are reported. The net effect of this change is that the test can continue to run even after an assertion failure occurs which can help to provide more information about the problem.

A multiple assertion block is useful for verifying the state of a single component with many parts that require several assertions to check. This feature can accelerate debugging because more diagnostic information become available at once.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Multiple Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Multiple Method (Action, String, Object[])

Assert.Multiple Method (Action, String, Object[])
See Also Example
[image]

Evaluates a block of code that contains multiple related assertions.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Multiple( _
ByVal action As Action, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Multiple(
Action action,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Multiple(
Action action,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Multiple(
Action action,
string messageFormat,
object[] messageArgs
)
JScript
public static function Multiple(
action : Action,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

action
The action to invoke
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null

Remarks

While the action delegate runs, the behavior of assertions is change such that failures are captured but do not cause a AssertionFailureException to be throw. When the delegate returns, the previous assertion failure behavior is restored and any captured assertion failures are reported. The net effect of this change is that the test can continue to run even after an assertion failure occurs which can help to provide more information about the problem.

A multiple assertion block is useful for verifying the state of a single component with many parts that require several assertions to check. This feature can accelerate debugging because more diagnostic information become available at once.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Multiple Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method

Assert.NotBetween Generic Method

Verifies that a test value is not between left and right values according to a particular comparer.

Overload List

Name | Description
NotBetween (T, T, T) | Verifies that a test value is not between left and right values according to a particular comparer.
NotBetween (T, T, T, IComparer<T>) | Verifies that a test value is not between left and right values according to a particular comparer.
NotBetween (T, T, T, IComparer<T>, String, Object) | Verifies that a test value is not between left and right values according to a particular comparer.
NotBetween (T, T, T, Comparison<T>) | Verifies that a test value is not between left and right values according to a particular comparer.
NotBetween (T, T, T, Comparison<T>, String, Object) | Verifies that a test value is not between left and right values according to a particular comparer.
NotBetween (T, T, T, String, Object) | Verifies that a test value is not between left and right values according to a particular comparer.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method (T, T, T)

Assert.NotBetween Generic Method (T, T, T)
See Also Example
[image]

Verifies that a test value is not between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T _
)
C#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum
)
C++
public:
static void NotBetween<T>(
T actualValue,
T minimum,
T maximum
)
J#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method (T, T, T, Generic IComparer)

Assert.NotBetween Generic Method (T, T, T, Generic IComparer)
See Also Example
[image]

Verifies that a test value is not between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As IComparer(Of T) _
)
C#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer
)
C++
public:
static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer
)
J#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method (T, T, T, Generic IComparer, String, Object[])

Assert.NotBetween Generic Method (T, T, T, Generic IComparer, String, Object[])
See Also Example
[image]

Verifies that a test value is not between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As IComparer(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
IComparer<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method (T, T, T, Generic Comparison)

Assert.NotBetween Generic Method (T, T, T, Generic Comparison)
See Also Example
[image]

Verifies that a test value is not between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As Comparison(Of T) _
)
C#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer
)
C++
public:
static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer
)
J#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method (T, T, T, Generic Comparison, String, Object[])

Assert.NotBetween Generic Method (T, T, T, Generic Comparison, String, Object[])
See Also Example
[image]

Verifies that a test value is not between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal comparer As Comparison(Of T), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
Comparison<T> comparer,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
comparer
The comparer to use, or null to use the default one
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotBetween Generic Method (T, T, T, String, Object[])

Assert.NotBetween Generic Method (T, T, T, String, Object[])
See Also Example
[image]

Verifies that a test value is not between left and right values according to a particular comparer.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween(Of T)( _
ByVal actualValue As T, _
ByVal minimum As T, _
ByVal maximum As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void NotBetween<T>(
T actualValue,
T minimum,
T maximum,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of value

Parameters

actualValue
The actual value
minimum
Inclusive minimum value
maximum
Inclusive maximum value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method

Assert.NotLike Method

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Overload List

Name | Description
NotLike (String, String) | Verifies that a string does not contain a full or partial match of a regular expression pattern.
NotLike (String, String, String, Object) | Verifies that a string does not contain a full or partial match of a regular expression pattern.
NotLike (String, String, RegexOptions) | Verifies that a string does not contain a full or partial match of a regular expression pattern.
NotLike (String, String, RegexOptions, String, Object) | Verifies that a string does not contain a full or partial match of a regular expression pattern.
NotLike (String, Regex) | Verifies that a string does not contain a full or partial match of a regular expression pattern.
NotLike (String, Regex, String, Object) | Verifies that a string does not contain a full or partial match of a regular expression pattern.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method (String, String)

Assert.NotLike Method (String, String)
See Also Example
[image]

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal actualValue As String, _
ByVal regexPattern As String _
)
C#
public static void NotLike(
string actualValue,
string regexPattern
)
C++
public:
static void NotLike(
String actualValue,
String regexPattern
)
J#
public static void NotLike(
string actualValue,
string regexPattern
)
JScript
public static function NotLike(
actualValue : String,
regexPattern : String
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotLike Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method (String, String, String, Object[])

Assert.NotLike Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void NotLike(
string actualValue,
string regexPattern,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void NotLike(
String actualValue,
String regexPattern,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void NotLike(
string actualValue,
string regexPattern,
string messageFormat,
object[] messageArgs
)
JScript
public static function NotLike(
actualValue : String,
regexPattern : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotLike Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method (String, String, RegexOptions)

Assert.NotLike Method (String, String, RegexOptions)
See Also Example
[image]

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal regexOptions As RegexOptions _
)
C#
public static void NotLike(
string actualValue,
string regexPattern,
RegexOptions regexOptions
)
C++
public:
static void NotLike(
String actualValue,
String regexPattern,
RegexOptions regexOptions
)
J#
public static void NotLike(
string actualValue,
string regexPattern,
RegexOptions regexOptions
)
JScript
public static function NotLike(
actualValue : String,
regexPattern : String,
regexOptions : RegexOptions
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
regexOptions
The regular expression options

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotLike Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method (String, String, RegexOptions, String, Object[])

Assert.NotLike Method (String, String, RegexOptions, String, Object[])
See Also Example
[image]

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal actualValue As String, _
ByVal regexPattern As String, _
ByVal regexOptions As RegexOptions, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void NotLike(
string actualValue,
string regexPattern,
RegexOptions regexOptions,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void NotLike(
String actualValue,
String regexPattern,
RegexOptions regexOptions,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void NotLike(
string actualValue,
string regexPattern,
RegexOptions regexOptions,
string messageFormat,
object[] messageArgs
)
JScript
public static function NotLike(
actualValue : String,
regexPattern : String,
regexOptions : RegexOptions,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regexPattern
The regular expression pattern
regexOptions
The regular expression options
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regexPattern is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotLike Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method (String, Regex)

Assert.NotLike Method (String, Regex)
See Also Example
[image]

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal actualValue As String, _
ByVal regex As Regex _
)
C#
public static void NotLike(
string actualValue,
Regex regex
)
C++
public:
static void NotLike(
String actualValue,
Regex regex
)
J#
public static void NotLike(
string actualValue,
Regex regex
)
JScript
public static function NotLike(
actualValue : String,
regex : Regex
)

Parameters

actualValue
The actual value
regex
The regular expression

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regex is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotLike Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NotLike Method (String, Regex, String, Object[])

Assert.NotLike Method (String, Regex, String, Object[])
See Also Example
[image]

Verifies that a string does not contain a full or partial match of a regular expression pattern.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal actualValue As String, _
ByVal regex As Regex, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void NotLike(
string actualValue,
Regex regex,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void NotLike(
String actualValue,
Regex regex,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void NotLike(
string actualValue,
Regex regex,
string messageFormat,
object[] messageArgs
)
JScript
public static function NotLike(
actualValue : String,
regex : Regex,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
regex
The regular expression
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if regex is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.NotLike Overload List
IsMatch

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReferenceEquals Method

Assert.ReferenceEquals Method
[image]

NOTE: This method is now obsolete.

Use Assert.AreSame instead.

Always throws an InvalidOperationException. Use AreSame instead.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Shared Sub ReferenceEquals( _
ByVal a As Object, _
ByVal b As Object _
)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public static void ReferenceEquals(
object a,
object b
)
C++
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
static void ReferenceEquals(
Object a,
Object b
)
J#
/** @attribute EditorBrowsableAttribute(EditorBrowsableState.Never) */
public static void ReferenceEquals(
object a,
object b
)
JScript
public static

EditorBrowsableAttribute(EditorBrowsableState.Never)
function ReferenceEquals(
a : Object,
b : Object
)

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Serialize Method

Assert.Serialize Method

Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.

Overload List

Name | Description
Serialize (Object, IFormatter) | Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.
Serialize (Object, IFormatter, String, Object) | Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Serialize Method (Object, IFormatter)

Assert.Serialize Method (Object, IFormatter)
See Also Example
[image]

Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Serialize( _
ByVal value As Object, _
ByVal formatter As IFormatter _
) As MemoryStream
C#
public static MemoryStream Serialize(
object value,
IFormatter formatter
)
C++
public:
static MemoryStream Serialize(
Object value,
IFormatter formatter
)
J#
public static MemoryStream Serialize(
object value,
IFormatter formatter
)
JScript
public static function Serialize(
value : Object,
formatter : IFormatter
) : MemoryStream

Parameters

value
The value
formatter
The object serialization formatter

Return Value

The serialized stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Serialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Serialize Method (Object, IFormatter, String, Object[])

Assert.Serialize Method (Object, IFormatter, String, Object[])
See Also Example
[image]

Verifies that an object can be serialized to a stream using the specified IFormatter and returns the resulting stream.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Serialize( _
ByVal value As Object, _
ByVal formatter As IFormatter, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
) As MemoryStream
C#
public static MemoryStream Serialize(
object value,
IFormatter formatter,
string messageFormat,
params object[] messageArgs
)
C++
public:
static MemoryStream Serialize(
Object value,
IFormatter formatter,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static MemoryStream Serialize(
object value,
IFormatter formatter,
string messageFormat,
object[] messageArgs
)
JScript
public static function Serialize(
value : Object,
formatter : IFormatter,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
) : MemoryStream

Parameters

value
The value
formatter
The object serialization formatter
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The serialized stream

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Serialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SerializeThenDeserialize Generic Method

Assert.SerializeThenDeserialize Generic Method

Verifies that an object can be serialized then deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.

Overload List

Name | Description
SerializeThenDeserialize (T, IFormatter) | Verifies that an object can be serialized then deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.
SerializeThenDeserialize (T, IFormatter, String, Object) | Verifies that an object can be serialized and deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SerializeThenDeserialize Generic Method (T, IFormatter)

Assert.SerializeThenDeserialize Generic Method (T, IFormatter)
See Also Example
[image]

Verifies that an object can be serialized then deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SerializeThenDeserialize(Of T)( _
ByVal value As T, _
ByVal formatter As IFormatter _
)
C#
public static T SerializeThenDeserialize<T>(
T value,
IFormatter formatter
)
C++
public:
static T SerializeThenDeserialize<T>(
T value,
IFormatter formatter
)
J#
public static T SerializeThenDeserialize<T>(
T value,
IFormatter formatter
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value
formatter
The object serialization formatter

Return Value

The serialized then deserialized object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.SerializeThenDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SerializeThenDeserialize Generic Method (T, IFormatter, String, Object[])

Assert.SerializeThenDeserialize Generic Method (T, IFormatter, String, Object[])
See Also Example
[image]

Verifies that an object can be serialized and deserialized to and from a stream using the specified IFormatter and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SerializeThenDeserialize(Of T)( _
ByVal value As T, _
ByVal formatter As IFormatter, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static T SerializeThenDeserialize<T>(
T value,
IFormatter formatter,
string messageFormat,
params object[] messageArgs
)
C++
public:
static T SerializeThenDeserialize<T>(
T value,
IFormatter formatter,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static T SerializeThenDeserialize<T>(
T value,
IFormatter formatter,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value
formatter
The object serialization formatter
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The serialized then deserialized object

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if formatter is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.SerializeThenDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


StartsWith Method

Assert.StartsWith Method

Verifies that a string starts with the specified text.

Overload List

Name | Description
StartsWith (String, String) | Verifies that a string starts with the specified text.
StartsWith (String, String, String, Object) | Verifies that a string starts with the specified text.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


StartsWith Method (String, String)

Assert.StartsWith Method (String, String)
See Also Example
[image]

Verifies that a string starts with the specified text.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StartsWith( _
ByVal actualValue As String, _
ByVal expectedText As String _
)
C#
public static void StartsWith(
string actualValue,
string expectedText
)
C++
public:
static void StartsWith(
String actualValue,
String expectedText
)
J#
public static void StartsWith(
string actualValue,
string expectedText
)
JScript
public static function StartsWith(
actualValue : String,
expectedText : String
)

Parameters

actualValue
The actual value
expectedText
The expected pattern

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedText is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.StartsWith Overload List
StartsWith

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


StartsWith Method (String, String, String, Object[])

Assert.StartsWith Method (String, String, String, Object[])
See Also Example
[image]

Verifies that a string starts with the specified text.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StartsWith( _
ByVal actualValue As String, _
ByVal expectedText As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void StartsWith(
string actualValue,
string expectedText,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void StartsWith(
String actualValue,
String expectedText,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void StartsWith(
string actualValue,
string expectedText,
string messageFormat,
object[] messageArgs
)
JScript
public static function StartsWith(
actualValue : String,
expectedText : String,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

actualValue
The actual value
expectedText
The expected pattern
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise
ArgumentNullException | Thrown if expectedText is null

Remarks

This assertion will fail if the string is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.StartsWith Overload List
StartsWith

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Terminate Method

Assert.Terminate Method

Terminates the test and reports a specific test outcome.

Overload List

Name | Description
Terminate (TestOutcome) | Terminates the test and reports a specific test outcome.
Terminate (TestOutcome, String, Object) | Terminates the test and reports a specific test outcome.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Terminate Method (TestOutcome)

Assert.Terminate Method (TestOutcome)
See Also Example
[image]

Terminates the test and reports a specific test outcome.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Terminate( _
ByVal outcome As TestOutcome _
)
C#
public static void Terminate(
TestOutcome outcome
)
C++
public:
static void Terminate(
TestOutcome outcome
)
J#
public static void Terminate(
TestOutcome outcome
)
JScript
public static function Terminate(
outcome : TestOutcome
)

Parameters

outcome
The desired test outcome

Exceptions

Exception Type | Condition
TestTerminatedException | Thrown always

Remarks

The test is terminated with by throwing a TestTerminatedException with the specified outcome. If other code in the test case catches this exception and does not rethrow it then the test might not terminate correctly.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Terminate Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Terminate Method (TestOutcome, String, Object[])

Assert.Terminate Method (TestOutcome, String, Object[])
See Also Example
[image]

Terminates the test and reports a specific test outcome.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Terminate( _
ByVal outcome As TestOutcome, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void Terminate(
TestOutcome outcome,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void Terminate(
TestOutcome outcome,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void Terminate(
TestOutcome outcome,
string messageFormat,
object[] messageArgs
)
JScript
public static function Terminate(
outcome : TestOutcome,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

outcome
The desired test outcome
messageFormat
The custom message format string, or null if none
messageArgs
The custom message arguments, or null if none

Exceptions

Exception Type | Condition
TestTerminatedException | Thrown always

Remarks

The test is terminated with by throwing a TestTerminatedException with the specified outcome. If other code in the test case catches this exception and does not rethrow it then the test might not terminate correctly.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Terminate Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TerminateSilently Method

Assert.TerminateSilently Method

Terminates the test silently and reports a specific test outcome.

Overload List

Name | Description
TerminateSilently (TestOutcome) | Terminates the test silently and reports a specific test outcome.
TerminateSilently (TestOutcome, String, Object) | Terminates the test silently and reports a specific test outcome.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TerminateSilently Method (TestOutcome)

Assert.TerminateSilently Method (TestOutcome)
See Also Example
[image]

Terminates the test silently and reports a specific test outcome.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub TerminateSilently( _
ByVal outcome As TestOutcome _
)
C#
public static void TerminateSilently(
TestOutcome outcome
)
C++
public:
static void TerminateSilently(
TestOutcome outcome
)
J#
public static void TerminateSilently(
TestOutcome outcome
)
JScript
public static function TerminateSilently(
outcome : TestOutcome
)

Parameters

outcome
The desired test outcome

Exceptions

Exception Type | Condition
SilentTestException | Thrown always

Remarks

Unlike Terminate this method does not report the stack trace. It also does not include a termination reason unless one is explicitly specified by the caller.

The test is terminated with by throwing a SilentTestException with the specified outcome. If other code in the test case catches this exception and does not rethrow it then the test might not terminate correctly.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.TerminateSilently Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TerminateSilently Method (TestOutcome, String, Object[])

Assert.TerminateSilently Method (TestOutcome, String, Object[])
See Also Example
[image]

Terminates the test silently and reports a specific test outcome.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub TerminateSilently( _
ByVal outcome As TestOutcome, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void TerminateSilently(
TestOutcome outcome,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void TerminateSilently(
TestOutcome outcome,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void TerminateSilently(
TestOutcome outcome,
string messageFormat,
object[] messageArgs
)
JScript
public static function TerminateSilently(
outcome : TestOutcome,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

outcome
The desired test outcome
messageFormat
The custom message format string, or null if none
messageArgs
The custom message arguments, or null if none

Exceptions

Exception Type | Condition
SilentTestException | Thrown always

Remarks

Unlike Terminate this method does not report the stack trace. It also does not include a termination reason unless one is explicitly specified by the caller.

The test is terminated with by throwing a TestTerminatedException with the specified outcome. If other code in the test case catches this exception and does not rethrow it then the test might not terminate correctly.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.TerminateSilently Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Throws Generic Method

Assert.Throws Generic Method

Verifies that a block of code throws an exception of a particular type.

Overload List

Name | Description
Throws (Type, Action) | Verifies that a block of code throws an exception of a particular type.
Throws (Type, Action, String, Object) | Verifies that a block of code throws an exception of a particular type.
Throws (Action) | Verifies that a block of code throws an exception of a particular type.
Throws (Action, String, Object) | Verifies that a block of code throws an exception of a particular type.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Throws Method (Type, Action)

Assert.Throws Method (Type, Action)
See Also Example
[image]

Verifies that a block of code throws an exception of a particular type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Throws( _
ByVal expectedExceptionType As Type, _
ByVal action As Action _
) As Exception
C#
public static Exception Throws(
Type expectedExceptionType,
Action action
)
C++
public:
static Exception Throws(
Type expectedExceptionType,
Action action
)
J#
public static Exception Throws(
Type expectedExceptionType,
Action action
)
JScript
public static function Throws(
expectedExceptionType : Type,
action : Action
) : Exception

Parameters

expectedExceptionType
The expected exception type
action
The action delegate to evaluate

Return Value

The exception that was thrown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if expectedExceptionType or action is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

If the block of code throws a subtype of the expected exception type then this method will still succeed.

This method returns the exception that was caught. To verify additional properties of the exception, such as the exception message, follow up this assertion with additional ones that verify these properties of the exception object that was returned.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Throws Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Throws Method (Type, Action, String, Object[])

Assert.Throws Method (Type, Action, String, Object[])
See Also Example
[image]

Verifies that a block of code throws an exception of a particular type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Throws( _
ByVal expectedExceptionType As Type, _
ByVal action As Action, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
) As Exception
C#
public static Exception Throws(
Type expectedExceptionType,
Action action,
string messageFormat,
params object[] messageArgs
)
C++
public:
static Exception Throws(
Type expectedExceptionType,
Action action,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static Exception Throws(
Type expectedExceptionType,
Action action,
string messageFormat,
object[] messageArgs
)
JScript
public static function Throws(
expectedExceptionType : Type,
action : Action,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
) : Exception

Parameters

expectedExceptionType
The expected exception type
action
The action delegate to evaluate
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The exception that was thrown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if expectedExceptionType or action is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

If the block of code throws a subtype of the expected exception type then this method will still succeed.

This method returns the exception that was caught. To verify additional properties of the exception, such as the exception message, follow up this assertion with additional ones that verify these properties of the exception object that was returned.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Throws Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Throws Generic Method (Action)

Assert.Throws Generic Method (Action)
See Also Example
[image]

Verifies that a block of code throws an exception of a particular type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Throws(Of TExpectedException As Exception)( _
ByVal action As Action _
)
C#
public static TExpectedException Throws<TExpectedException>(
Action action
) where TExpectedException : Exception
C++
public:
static TExpectedException Throws<TExpectedException>(
Action action
)
J#
public static TExpectedException Throws<TExpectedException>(
Action action
)
JScript
JScript does not support generic types and methods.

Type Parameters

TExpectedException
The expected type of exception

Parameters

action
The action delegate to evaluate

Return Value

The exception that was thrown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

If the block of code throws a subtype of the expected exception type then this method will still succeed.

This method returns the exception that was caught. To verify additional properties of the exception, such as the exception message, follow up this assertion with additional ones that verify these properties of the exception object that was returned.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Throws Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Throws Generic Method (Action, String, Object[])

Assert.Throws Generic Method (Action, String, Object[])
See Also Example
[image]

Verifies that a block of code throws an exception of a particular type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Throws(Of TExpectedException As Exception)( _
ByVal action As Action, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static TExpectedException Throws<TExpectedException>(
Action action,
string messageFormat,
params object[] messageArgs
) where TExpectedException : Exception
C++
public:
static TExpectedException Throws<TExpectedException>(
Action action,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static TExpectedException Throws<TExpectedException>(
Action action,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TExpectedException
The expected type of exception

Parameters

action
The action delegate to evaluate
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The exception that was thrown

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if action is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

If the block of code throws a subtype of the expected exception type then this method will still succeed.

This method returns the exception that was caught. To verify additional properties of the exception, such as the exception message, follow up this assertion with additional ones that verify these properties of the exception object that was returned.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.Throws Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlDeserialize Generic Method

Assert.XmlDeserialize Generic Method

Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.

Overload List

Name | Description
XmlDeserialize (String) | Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.
XmlDeserialize (String, String, Object) | Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlDeserialize Generic Method (String)

Assert.XmlDeserialize Generic Method (String)
See Also Example
[image]

Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlDeserialize(Of T)( _
ByVal xml As String _
)
C#
public static T XmlDeserialize<T>(
string xml
)
C++
public:
static T XmlDeserialize<T>(
String xml
)
J#
public static T XmlDeserialize<T>(
string xml
)
JScript
JScript does not support generic types and methods.

Parameters

xml
The Xml

Return Value

The deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if xml is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.XmlDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlDeserialize Generic Method (String, String, Object[])

Assert.XmlDeserialize Generic Method (String, String, Object[])
See Also Example
[image]

Verifies that an object can be deserialized from Xml using an XmlSerializer and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlDeserialize(Of T)( _
ByVal xml As String, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static T XmlDeserialize<T>(
string xml,
string messageFormat,
params object[] messageArgs
)
C++
public:
static T XmlDeserialize<T>(
String xml,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static T XmlDeserialize<T>(
string xml,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Parameters

xml
The Xml
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if xml is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.XmlDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlSerialize Method

Assert.XmlSerialize Method

Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.

Overload List

Name | Description
XmlSerialize (Object) | Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.
XmlSerialize (Object, String, Object) | Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlSerialize Method (Object)

Assert.XmlSerialize Method (Object)
See Also Example
[image]

Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlSerialize( _
ByVal value As Object _
) As String
C#
public static string XmlSerialize(
object value
)
C++
public:
static String XmlSerialize(
Object value
)
J#
public static string XmlSerialize(
object value
)
JScript
public static function XmlSerialize(
value : Object
) : String

Parameters

value
The value

Return Value

The serialized Xml

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.XmlSerialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlSerialize Method (Object, String, Object[])

Assert.XmlSerialize Method (Object, String, Object[])
See Also Example
[image]

Verifies that an object can be serialized to Xml using an XmlSerializer and returns the resulting Xml as a string.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlSerialize( _
ByVal value As Object, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
) As String
C#
public static string XmlSerialize(
object value,
string messageFormat,
params object[] messageArgs
)
C++
public:
static String XmlSerialize(
Object value,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static string XmlSerialize(
object value,
string messageFormat,
object[] messageArgs
)
JScript
public static function XmlSerialize(
value : Object,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
) : String

Parameters

value
The value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The serialized Xml

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.XmlSerialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlSerializeThenDeserialize Generic Method

Assert.XmlSerializeThenDeserialize Generic Method

Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.

Overload List

Name | Description
XmlSerializeThenDeserialize (T) | Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.
XmlSerializeThenDeserialize (T, String, Object) | Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.

See Also

Assert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlSerializeThenDeserialize Generic Method (T)

Assert.XmlSerializeThenDeserialize Generic Method (T)
See Also Example
[image]

Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlSerializeThenDeserialize(Of T)( _
ByVal value As T _
)
C#
public static T XmlSerializeThenDeserialize<T>(
T value
)
C++
public:
static T XmlSerializeThenDeserialize<T>(
T value
)
J#
public static T XmlSerializeThenDeserialize<T>(
T value
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value

Return Value

The serialized then deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.XmlSerializeThenDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlSerializeThenDeserialize Generic Method (T, String, Object[])

Assert.XmlSerializeThenDeserialize Generic Method (T, String, Object[])
See Also Example
[image]

Verifies that an object can be serialized then deserialized to and from Xml using an XmlSerializer and returns the resulting deserialized object.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlSerializeThenDeserialize(Of T)( _
ByVal value As T, _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static T XmlSerializeThenDeserialize<T>(
T value,
string messageFormat,
params object[] messageArgs
)
C++
public:
static T XmlSerializeThenDeserialize<T>(
T value,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static T XmlSerializeThenDeserialize<T>(
T value,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Parameters

value
The value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Return Value

The serialized then deserialized object

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

The assertion fails if value is null.

See Also

Assert Class
MbUnit.Framework Namespace
Assert.XmlSerializeThenDeserialize Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssertEx Class

AssertEx Class
See Also Example Members
[image]

Provides extended assertions for .Net 3.5. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit35 (in MbUnit35.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class AssertEx
Inherits Assert
C#
public abstract class AssertEx : Assert
C++
ref class AssertEx abstract : Assert
J#
public class AssertEx extends Assert
JScript
public class AssertEx extends Assert

Inheritance Hierarchy

System.Object
MbUnit.Framework.Assert
MbUnit.Framework.AssertEx

See Also

AssertEx Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


AssertEx Members

AssertEx Members
See Also Example Constructors Methods
[image]

Provides extended assertions for .Net 3.5. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AssertEx.

Protected Constructors

 | Name | Description
Family method | AssertEx | Initializes a new instance of the AssertEx class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | That | Overloaded. Verifies that a particular condition holds true. If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssertEx Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


AssertEx Constructor

AssertEx Constructor
[image]

Initializes a new instance of the AssertEx class.

Namespace: MbUnit.Framework
Assembly: MbUnit35 (in MbUnit35.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected AssertEx()
C++
protected:
AssertEx() sealed
J#
protected AssertEx()
JScript
protected function AssertEx()

See Also

AssertEx Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


Methods

AssertEx Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | That | Overloaded. Verifies that a particular condition holds true. If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AssertEx Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


That Method

AssertEx.That Method

Verifies that a particular condition holds true.

If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.

Overload List

Name | Description
That (Expression<Func<bool>>) | Verifies that a particular condition holds true. If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.
That (Expression<Func<bool>>, String, Object) | Verifies that a particular condition holds true. If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.

See Also

AssertEx Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


That Method (Generic Expression)

AssertEx.That Method (Generic Expression)
See Also Example
[image]

Verifies that a particular condition holds true.

If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.

Namespace: MbUnit.Framework
Assembly: MbUnit35 (in MbUnit35.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub That( _
ByVal condition As Expression(Of Func(Of Boolean)) _
)
C#
public static void That(
Expression<Func<bool>> condition
)
C++
public:
static void That(
Expression<Func<bool>> condition
)
J#
public static void That(
Expression<Func<bool>> condition
)
JScript
public static function That(
condition : Expression<Func<bool>>
)

Parameters

condition
The conditional expression to evaluate

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if condition is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

AssertEx Class
MbUnit.Framework Namespace
AssertEx.That Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


That Method (Generic Expression, String, Object[])

AssertEx.That Method (Generic Expression, String, Object[])
See Also Example
[image]

Verifies that a particular condition holds true.

If the condition evaluates to false, the assertion failure message will describe in detail the intermediate value of relevant sub-expressions within the condition. Consequently the assertion failure will include more diagnostic information than if IsTrue were used instead.

Namespace: MbUnit.Framework
Assembly: MbUnit35 (in MbUnit35.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub That( _
ByVal condition As Expression(Of Func(Of Boolean)), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public static void That(
Expression<Func<bool>> condition,
string messageFormat,
params object[] messageArgs
)
C++
public:
static void That(
Expression<Func<bool>> condition,
String messageFormat,
... array<Object>^ messageArgs
)
J#
public static void That(
Expression<Func<bool>> condition,
string messageFormat,
object[] messageArgs
)
JScript
public static function That(
condition : Expression<Func<bool>>,
messageFormat : String,
ParamArrayAttribute messageArgs : Object[]
)

Parameters

condition
The conditional expression to evaluate
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if condition is null
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

See Also

AssertEx Class
MbUnit.Framework Namespace
AssertEx.That Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit35 [3.0.6.0]


AssertOverSyntax Class

AssertOverSyntax Class
See Also Example Members
[image]

Defines methods used with the Over syntax for mapping assertions over complex data structures. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public NotInheritable Class AssertOverSyntax
C#
[TestFrameworkInternalAttribute]
public sealed class AssertOverSyntax
C++
[TestFrameworkInternalAttribute]
ref class AssertOverSyntax sealed
J#
/** @attribute TestFrameworkInternalAttribute() */
public final class AssertOverSyntax
JScript
public
TestFrameworkInternalAttribute
final class AssertOverSyntax

Inheritance Hierarchy

System.Object
MbUnit.Framework.AssertOverSyntax

See Also

AssertOverSyntax Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssertOverSyntax Members

AssertOverSyntax Members
See Also Example Methods
[image]

Defines methods used with the Over syntax for mapping assertions over complex data structures. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by AssertOverSyntax.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | KeyedPairs | Overloaded. Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.
Public method | Pairs | Overloaded. Evaluates an assertion over pairs of values taken from two sequences.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

AssertOverSyntax Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | KeyedPairs | Overloaded. Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.
Public method | Pairs | Overloaded. Evaluates an assertion over pairs of values taken from two sequences.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


KeyedPairs Generic Method

AssertOverSyntax.KeyedPairs Generic Method

Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.

Overload List

 | Name | Description
Public method | KeyedPairs (IDictionary<TKey, TLeftValue>, IDictionary<TKey, TRightValue>, Action<TKey, TLeftValue, TRightValue>) | Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.
Public method | KeyedPairs (IDictionary<TKey, TLeftValue>, IDictionary<TKey, TRightValue>, Action<TKey, TLeftValue, TRightValue>, String, Object) | Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.
Public method | KeyedPairs (IDictionary<TKey, TLeftValue>, IDictionary<TKey, TRightValue>, Action<TLeftValue, TRightValue>) | Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.
Public method | KeyedPairs (IDictionary<TKey, TLeftValue>, IDictionary<TKey, TRightValue>, Action<TLeftValue, TRightValue>, String, Object) | Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action)

AssertOverSyntax.KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action)
See Also Example
[image]

Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub KeyedPairs(Of TKey, TLeftValue, TRightValue)( _
ByVal leftDictionary As IDictionary(Of TKey, TLeftValue), _
ByVal rightDictionary As IDictionary(Of TKey, TRightValue), _
ByVal assertion As Action(Of TKey, TLeftValue, TRightValue) _
)
C#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TKey, TLeftValue, TRightValue> assertion
)
C++
public:
void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TKey, TLeftValue, TRightValue> assertion
) sealed
J#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TKey, TLeftValue, TRightValue> assertion
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The key type
TLeftValue
The expected value type
TRightValue
The expected value type

Parameters

leftDictionary
The left dictionary, or null
rightDictionary
The right dictionary, or null
assertion
The assertion to evaluate over all pairs, with the key as first argument, left value as second, and right value as third

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion fails if the collections have different sizes or if one is null but not the other.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace
AssertOverSyntax.KeyedPairs Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action, String, Object[])

AssertOverSyntax.KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action, String, Object[])
See Also Example
[image]

Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub KeyedPairs(Of TKey, TLeftValue, TRightValue)( _
ByVal leftDictionary As IDictionary(Of TKey, TLeftValue), _
ByVal rightDictionary As IDictionary(Of TKey, TRightValue), _
ByVal assertion As Action(Of TKey, TLeftValue, TRightValue), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TKey, TLeftValue, TRightValue> assertion,
string messageFormat,
params object[] messageArgs
)
C++
public:
void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TKey, TLeftValue, TRightValue> assertion,
String messageFormat,
... array<Object>^ messageArgs
) sealed
J#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TKey, TLeftValue, TRightValue> assertion,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The key type
TLeftValue
The expected value type
TRightValue
The expected value type

Parameters

leftDictionary
The left dictionary, or null
rightDictionary
The right dictionary, or null
assertion
The assertion to evaluate over all pairs, with the key as first argument, left value as second, and right value as third
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion fails if the collections have different sizes or if one is null but not the other.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace
AssertOverSyntax.KeyedPairs Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action)

AssertOverSyntax.KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action)
See Also Example
[image]

Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub KeyedPairs(Of TKey, TLeftValue, TRightValue)( _
ByVal leftDictionary As IDictionary(Of TKey, TLeftValue), _
ByVal rightDictionary As IDictionary(Of TKey, TRightValue), _
ByVal assertion As Action(Of TLeftValue, TRightValue) _
)
C#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TLeftValue, TRightValue> assertion
)
C++
public:
void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TLeftValue, TRightValue> assertion
) sealed
J#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TLeftValue, TRightValue> assertion
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The key type
TLeftValue
The expected value type
TRightValue
The expected value type

Parameters

leftDictionary
The left dictionary, or null
rightDictionary
The right dictionary, or null
assertion
The assertion to evaluate over all pairs, with the left value as first argument, and right value as second

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion fails if the collections have different sizes or if one is null but not the other.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace
AssertOverSyntax.KeyedPairs Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action, String, Object[])

AssertOverSyntax.KeyedPairs Generic Method (Generic IDictionary, Generic IDictionary, Generic Action, String, Object[])
See Also Example
[image]

Evaluates an assertion over key/value pairs with identical keys drawn from two dictionaries.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub KeyedPairs(Of TKey, TLeftValue, TRightValue)( _
ByVal leftDictionary As IDictionary(Of TKey, TLeftValue), _
ByVal rightDictionary As IDictionary(Of TKey, TRightValue), _
ByVal assertion As Action(Of TLeftValue, TRightValue), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TLeftValue, TRightValue> assertion,
string messageFormat,
params object[] messageArgs
)
C++
public:
void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TLeftValue, TRightValue> assertion,
String messageFormat,
... array<Object>^ messageArgs
) sealed
J#
public void KeyedPairs<TKey, TLeftValue, TRightValue>(
IDictionary<TKey, TLeftValue> leftDictionary,
IDictionary<TKey, TRightValue> rightDictionary,
Action<TLeftValue, TRightValue> assertion,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TKey
The key type
TLeftValue
The expected value type
TRightValue
The expected value type

Parameters

leftDictionary
The left dictionary, or null
rightDictionary
The right dictionary, or null
assertion
The assertion to evaluate over all pairs, with the left value as first argument, and right value as second
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Exceptions

Exception Type | Condition
AssertionException | Thrown if the verification failed unless the current AssertionFailureBehavior indicates otherwise

Remarks

This assertion fails if the collections have different sizes or if one is null but not the other.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace
AssertOverSyntax.KeyedPairs Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Pairs Generic Method

AssertOverSyntax.Pairs Generic Method

Evaluates an assertion over pairs of values taken from two sequences.

Overload List

 | Name | Description
Public method | Pairs (IEnumerable<TLeftValue>, IEnumerable<TRightValue>, Action<TLeftValue, TRightValue>) | Evaluates an assertion over pairs of values taken from two sequences.
Public method | Pairs (IEnumerable<TLeftValue>, IEnumerable<TRightValue>, Action<TLeftValue, TRightValue>, String, Object) | Evaluates an assertion over pairs of values taken from two sequence.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Pairs Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Action)

AssertOverSyntax.Pairs Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Action)
See Also Example
[image]

Evaluates an assertion over pairs of values taken from two sequences.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Pairs(Of TLeftValue, TRightValue)( _
ByVal leftSequence As IEnumerable(Of TLeftValue), _
ByVal rightSequence As IEnumerable(Of TRightValue), _
ByVal assertion As Action(Of TLeftValue, TRightValue) _
)
C#
public void Pairs<TLeftValue, TRightValue>(
IEnumerable<TLeftValue> leftSequence,
IEnumerable<TRightValue> rightSequence,
Action<TLeftValue, TRightValue> assertion
)
C++
public:
void Pairs<TLeftValue, TRightValue>(
IEnumerable<TLeftValue> leftSequence,
IEnumerable<TRightValue> rightSequence,
Action<TLeftValue, TRightValue> assertion
) sealed
J#
public void Pairs<TLeftValue, TRightValue>(
IEnumerable<TLeftValue> leftSequence,
IEnumerable<TRightValue> rightSequence,
Action<TLeftValue, TRightValue> assertion
)
JScript
JScript does not support generic types and methods.

Type Parameters

TLeftValue
The left value type
TRightValue
The right value type

Parameters

leftSequence
The left sequence, or null
rightSequence
The right sequence, or null
assertion
The assertion to evaluate given a left value and a right value

Remarks

This assertion fails if the collections have different sizes or if one is null but not the other.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace
AssertOverSyntax.Pairs Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Pairs Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Action, String, Object[])

AssertOverSyntax.Pairs Generic Method (Generic IEnumerable, Generic IEnumerable, Generic Action, String, Object[])
See Also Example
[image]

Evaluates an assertion over pairs of values taken from two sequence.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Pairs(Of TLeftValue, TRightValue)( _
ByVal leftSequence As IEnumerable(Of TLeftValue), _
ByVal rightSequence As IEnumerable(Of TRightValue), _
ByVal assertion As Action(Of TLeftValue, TRightValue), _
ByVal messageFormat As String, _
ByVal ParamArray messageArgs As Object() _
)
C#
public void Pairs<TLeftValue, TRightValue>(
IEnumerable<TLeftValue> leftSequence,
IEnumerable<TRightValue> rightSequence,
Action<TLeftValue, TRightValue> assertion,
string messageFormat,
params object[] messageArgs
)
C++
public:
void Pairs<TLeftValue, TRightValue>(
IEnumerable<TLeftValue> leftSequence,
IEnumerable<TRightValue> rightSequence,
Action<TLeftValue, TRightValue> assertion,
String messageFormat,
... array<Object>^ messageArgs
) sealed
J#
public void Pairs<TLeftValue, TRightValue>(
IEnumerable<TLeftValue> leftSequence,
IEnumerable<TRightValue> rightSequence,
Action<TLeftValue, TRightValue> assertion,
string messageFormat,
object[] messageArgs
)
JScript
JScript does not support generic types and methods.

Type Parameters

TLeftValue
The left value type
TRightValue
The right value type

Parameters

leftSequence
The left sequence, or null
rightSequence
The right sequence, or null
assertion
The assertion to evaluate given a left value and a right value
messageFormat
The custom assertion message format, or null if none
messageArgs
The custom assertion message arguments, or null if none

Remarks

This assertion fails if the collections have different sizes or if one is null but not the other.

See Also

AssertOverSyntax Class
MbUnit.Framework Namespace
AssertOverSyntax.Pairs Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorAttribute Class

AuthorAttribute Class
See Also Example Members
[image]

Associates the author's name and email address with a test fixture, test method, test parameter or other test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class AuthorAttribute
Inherits MetadataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class AuthorAttribute : MetadataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class AuthorAttribute : MetadataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class AuthorAttribute extends MetadataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class AuthorAttribute extends MetadataPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.AuthorAttribute

See Also

AuthorAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorAttribute Members

AuthorAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Associates the author's name and email address with a test fixture, test method, test parameter or other test component.

The following tables list the members exposed by AuthorAttribute.

Public Constructors

Name | Description
AuthorAttribute | Overloaded.
Top

Public Properties

Name | Description
Public property | AuthorEmail | Gets or sets the author's email address or an empty string if none.
Public property | AuthorHomepage | Gets or sets the author's homepage or an empty string if none.
Public property | AuthorName | Gets or sets the author's name.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
AuthorAttribute | Overloaded.
Top

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorAttribute Constructor

AuthorAttribute Constructor

Overload List

 | Name | Description
Public method | AuthorAttribute (String) | Associates the author's name with the test component annotated by this attribute.
Public method | AuthorAttribute (String, String) | Associates the author's name and email address with the test component annotated by this attribute.
Public method | AuthorAttribute (String, String, String) | Associates the author's name, email address and homepage with the test component annotated by this attribute.

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorAttribute Constructor (String)

AuthorAttribute Constructor (String)
See Also Example
[image]

Associates the author's name with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal authorName As String _
)
C#
public AuthorAttribute(
string authorName
)
C++
public:
AuthorAttribute(
String authorName
) sealed
J#
public AuthorAttribute(
string authorName
)
JScript
public function AuthorAttribute(
authorName : String
)

Parameters

authorName
The author's name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if authorName is null

See Also

AuthorAttribute Class
MbUnit.Framework Namespace
AuthorAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorAttribute Constructor (String, String)

AuthorAttribute Constructor (String, String)
See Also Example
[image]

Associates the author's name and email address with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal authorName As String, _
ByVal authorEmail As String _
)
C#
public AuthorAttribute(
string authorName,
string authorEmail
)
C++
public:
AuthorAttribute(
String authorName,
String authorEmail
) sealed
J#
public AuthorAttribute(
string authorName,
string authorEmail
)
JScript
public function AuthorAttribute(
authorName : String,
authorEmail : String
)

Parameters

authorName
The author's name
authorEmail
The author's email address

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if authorName or authorEmail is null

See Also

AuthorAttribute Class
MbUnit.Framework Namespace
AuthorAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorAttribute Constructor (String, String, String)

AuthorAttribute Constructor (String, String, String)
See Also Example
[image]

Associates the author's name, email address and homepage with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal authorName As String, _
ByVal authorEmail As String, _
ByVal authorHomepage As String _
)
C#
public AuthorAttribute(
string authorName,
string authorEmail,
string authorHomepage
)
C++
public:
AuthorAttribute(
String authorName,
String authorEmail,
String authorHomepage
) sealed
J#
public AuthorAttribute(
string authorName,
string authorEmail,
string authorHomepage
)
JScript
public function AuthorAttribute(
authorName : String,
authorEmail : String,
authorHomepage : String
)

Parameters

authorName
The author's name
authorEmail
The author's email address
authorHomepage
The author's home page

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if authorName, authorEmail or authorHomepage is null

See Also

AuthorAttribute Class
MbUnit.Framework Namespace
AuthorAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

AuthorAttribute Properties
[image]

Public Properties

Name | Description
Public property | AuthorEmail | Gets or sets the author's email address or an empty string if none.
Public property | AuthorHomepage | Gets or sets the author's homepage or an empty string if none.
Public property | AuthorName | Gets or sets the author's name.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorEmail Property

AuthorAttribute.AuthorEmail Property
[image]

Gets or sets the author's email address or an empty string if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AuthorEmail As String
C#
public string AuthorEmail { get; }
C++
public property string AuthorEmail sealed {
String get();
}
J#
/** property */
public string get_AuthorEmail();
JScript
public function get AuthorEmail() : String

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorHomepage Property

AuthorAttribute.AuthorHomepage Property
[image]

Gets or sets the author's homepage or an empty string if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AuthorHomepage As String
C#
public string AuthorHomepage { get; }
C++
public property string AuthorHomepage sealed {
String get();
}
J#
/** property */
public string get_AuthorHomepage();
JScript
public function get AuthorHomepage() : String

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AuthorName Property

AuthorAttribute.AuthorName Property
[image]

Gets or sets the author's name.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AuthorName As String
C#
public string AuthorName { get; }
C++
public property string AuthorName sealed {
String get();
}
J#
/** property */
public string get_AuthorName();
JScript
public function get AuthorName() : String

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

AuthorAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

AuthorAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata() override
J#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected override function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

AuthorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BindAttribute Class

BindAttribute Class
See Also Example Members
[image]

The bind attribute overrides the default binding rules for a test parameter by specifying a different data source, a binding path or an index. At most one such attribute may appear on any given test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class BindAttribute
Inherits TestParameterDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class BindAttribute : TestParameterDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class BindAttribute : TestParameterDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class BindAttribute extends TestParameterDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class BindAttribute extends TestParameterDecoratorPatternAttribute

Remarks

The bind attribute supports more complex data binding binding scenarios. For example, in a typical use of CsvDataAttribute, the binding of test parameters to CSV columns is performed by name and by position. This assumes that the CSV file either contains a header with columns that are named the same as the test parameter or that the columns appear in the same order as the test parameters. Should this not be the case, we may apply the BindAttribute to the test parameter to specify an explicit column name (by setting the path) or column position (by setting the index).

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestParameterDecoratorPatternAttribute
MbUnit.Framework.BindAttribute

See Also

BindAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BindAttribute Members

BindAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The bind attribute overrides the default binding rules for a test parameter by specifying a different data source, a binding path or an index. At most one such attribute may appear on any given test parameter.

The following tables list the members exposed by BindAttribute.

Public Constructors

Name | Description
BindAttribute | Overloaded.
Top

Public Properties

Name | Description
Public property | Index | Gets the binding index, or null if none.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Path | Gets the binding path, or null if none.
Public property Source

Gets or sets the name of the data source to bind, or null to bind the default data source for the test parameter.

The default source for a test parameter is the anonymous data source defined within the scope of the test parameter or by its enclosing test.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestParameterDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTestParameter | Overridden. Applies decorations to a PatternTestParameter. A typical use of this method is to augment the test parameter with additional metadata or to add additional behaviors to the test parameter.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestParameterDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
BindAttribute | Overloaded.
Top

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BindAttribute Constructor

BindAttribute Constructor

Overload List

 | Name | Description
Public method | BindAttribute (Int32) | Sets the binding index for the associated test parameter.
Public method | BindAttribute (String) | Sets the binding path for the associated test parameter.

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BindAttribute Constructor (Int32)

BindAttribute Constructor (Int32)
See Also Example
[image]

Sets the binding index for the associated test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal index As Integer _
)
C#
public BindAttribute(
int index
)
C++
public:
BindAttribute(
int index
) sealed
J#
public BindAttribute(
int index
)
JScript
public function BindAttribute(
index : int
)

Parameters

index
The binding index

See Also

BindAttribute Class
MbUnit.Framework Namespace
BindAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BindAttribute Constructor (String)

BindAttribute Constructor (String)
See Also Example
[image]

Sets the binding path for the associated test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal path As String _
)
C#
public BindAttribute(
string path
)
C++
public:
BindAttribute(
String path
) sealed
J#
public BindAttribute(
string path
)
JScript
public function BindAttribute(
path : String
)

Parameters

path
The binding path

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if path is null

See Also

BindAttribute Class
MbUnit.Framework Namespace
BindAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

BindAttribute Properties
[image]

Public Properties

Name | Description
Public property | Index | Gets the binding index, or null if none.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Path | Gets the binding path, or null if none.
Public property Source

Gets or sets the name of the data source to bind, or null to bind the default data source for the test parameter.

The default source for a test parameter is the anonymous data source defined within the scope of the test parameter or by its enclosing test.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Index Property

BindAttribute.Index Property
[image]

Gets the binding index, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Nullable(Of Integer)
C#
public Nullable<int> Index { get; }
C++
public property Nullable<int> Index sealed {
Nullable<int> get();
}
J#
/** property */
public Nullable<int> get_Index();
JScript
public function get Index() : Nullable<int>

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Path Property

BindAttribute.Path Property
[image]

Gets the binding path, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Path As String
C#
public string Path { get; }
C++
public property string Path sealed {
String get();
}
J#
/** property */
public string get_Path();
JScript
public function get Path() : String

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Source Property

BindAttribute.Source Property
[image]

Gets or sets the name of the data source to bind, or null to bind the default data source for the test parameter.

The default source for a test parameter is the anonymous data source defined within the scope of the test parameter or by its enclosing test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Source As String
C#
public string Source { get; set; }
C++
public property string Source sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Source();

/** property */
public void set_Source(string value);
JScript
public function get Source() : String

public function set Source(value : String);

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

BindAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestParameterDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTestParameter | Overridden. Applies decorations to a PatternTestParameter. A typical use of this method is to augment the test parameter with additional metadata or to add additional behaviors to the test parameter.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestParameterDecoratorPatternAttribute)
Top

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTestParameter Method

BindAttribute.DecorateTestParameter Method
[image]

Applies decorations to a PatternTestParameter.

A typical use of this method is to augment the test parameter with additional metadata or to add additional behaviors to the test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTestParameter( _
ByVal slotScope As IPatternScope, _
ByVal slot As ISlotInfo _
)
C#
protected override void DecorateTestParameter(
IPatternScope slotScope,
ISlotInfo slot
)
C++
protected:
virtual void DecorateTestParameter(
IPatternScope slotScope,
ISlotInfo slot
) override
J#
protected override void DecorateTestParameter(
IPatternScope slotScope,
ISlotInfo slot
)
JScript
protected override function DecorateTestParameter(
slotScope : IPatternScope,
slot : ISlotInfo
)

Parameters

slotScope
The slot scope
slot
The slot

See Also

BindAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CategoryAttribute Class

CategoryAttribute Class
See Also Example Members
[image]

Associates a category name with a test fixture, test method, test parameter or other test component. The category name can be used to classify tests and build test suites of related tests.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class CategoryAttribute
Inherits MetadataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class CategoryAttribute : MetadataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class CategoryAttribute : MetadataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class CategoryAttribute extends MetadataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class CategoryAttribute extends MetadataPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.CategoryAttribute

See Also

CategoryAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CategoryAttribute Members

CategoryAttribute Members
See Also Example Constructors Properties Methods
[image]

Associates a category name with a test fixture, test method, test parameter or other test component. The category name can be used to classify tests and build test suites of related tests.

The following tables list the members exposed by CategoryAttribute.

Public Constructors

 | Name | Description
Public method | CategoryAttribute | Associates a category with the test component annotated by this attribute.
Top

Public Properties

Name | Description
Public property | Category | Gets the name of the category.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

CategoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CategoryAttribute Constructor

CategoryAttribute Constructor
[image]

Associates a category with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal category As String _
)
C#
public CategoryAttribute(
string category
)
C++
public:
CategoryAttribute(
String category
) sealed
J#
public CategoryAttribute(
string category
)
JScript
public function CategoryAttribute(
category : String
)

Parameters

category
The name of the category to associate

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if category is null

See Also

CategoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

CategoryAttribute Properties
[image]

Public Properties

Name | Description
Public property | Category | Gets the name of the category.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

CategoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Category Property

CategoryAttribute.Category Property
[image]

Gets the name of the category.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Category As String
C#
public string Category { get; }
C++
public property string Category sealed {
String get();
}
J#
/** property */
public string get_Category();
JScript
public function get Category() : String

See Also

CategoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

CategoryAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

CategoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

CategoryAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata() override
J#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected override function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

CategoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ColumnAttribute Class

ColumnAttribute Class
See Also Example Members
[image]

Provides a column of literal values as a data source.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True), _
CLSCompliantAttribute(False)>
Public Class ColumnAttribute
Inherits DataAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
[CLSCompliantAttribute(False)]
public class ColumnAttribute : DataAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
[CLSCompliantAttribute(False)]
ref class ColumnAttribute : DataAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
/** @attribute CLSCompliantAttribute(False) */
public class ColumnAttribute extends DataAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
CLSCompliantAttribute(False)
class ColumnAttribute extends DataAttribute

Example

[Test] public void ATest([Column(1, 2, 3)] int x, [Column("a", "b")] string y, [Column(0.1, 0.2)] double z) { // This test will run 3 * 2 * 2 = 12 times with all combinations of // the values specified in the column for each parameter. This test // is combinatorial because the values are assigned to each parameter // separately. }

Remarks

This attribute is a compact equivalent to providing a sequence of values using RowAttribute with 1 element in each. It is particularly useful for specifying combinatorial tests.

By default, the column provided by the column data source is unnamed. Use HeaderAttribute to provide an explicit name for the column.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.DataAttribute
MbUnit.Framework.ColumnAttribute

See Also

ColumnAttribute Members
MbUnit.Framework Namespace
RowAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ColumnAttribute Members

ColumnAttribute Members
See Also Example Constructors Properties Methods
[image]

Provides a column of literal values as a data source.

The following tables list the members exposed by ColumnAttribute.

Public Constructors

 | Name | Description
Public method | ColumnAttribute | Adds a column of literal values.
Top

Public Properties

Name | Description
Public property | Description | Gets or sets a description of the values provided by the data source. (inherited from DataAttribute)
Public property | ExpectedException | Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test. (inherited from DataAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | Values | Gets the array of values in the column.
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata for the data source. (inherited from DataAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

ColumnAttribute Class
MbUnit.Framework Namespace
RowAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ColumnAttribute Constructor

ColumnAttribute Constructor
[image]

Adds a column of literal values.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)>
Public Sub New( _
ByVal ParamArray values As Object() _
)
C#
[CLSCompliantAttribute(False)]
public ColumnAttribute(
params object[] values
)
C++
[CLSCompliantAttribute(False)]
public:
ColumnAttribute(
... array<Object>^ values
) sealed
J#
/** @attribute CLSCompliantAttribute(False) */
public ColumnAttribute(
object[] values
)
JScript
public

CLSCompliantAttribute(False)
function ColumnAttribute(
ParamArrayAttribute values : Object[]
)

Parameters

values
The array of values in the column

Remarks

There exist two ambiguities in the use of this attribute that result from how the C# compiler handles functions that accept a variable number of arguments.

Case 1: If there is only 1 argument and its value is null, the compiler will pass a null array reference to the attribute constructor. Since the value array cannot be null, the attribute will assume that you meant to create an array consiting of a single null.

Copy Code
            // Example of case #1.
            // The attribute will assume that you intended to pass in a single null value.
            [Test]
            [Column(null)]
            public void Test(object value)
            {
                Assert.IsNull(value);
            }

Case 2: If there is only 1 argument and its value is an object array, the compiler will pass the array itself as the argument values. Unfortunately, the attribute constructor cannot distinguish this case from the usual case when multiple arguments are present. So you need to disambiguate this case explicitly.

Copy Code
            // Example of case #2.
            // The attribute will treat both of the following declarations equivalently
            // contrary to what we probably intend.
            [Column(new object[] { 1, 2, 3 })]
            [Column(1, 2, 3)]

To fix this case, you must provide explicit disambiguation. (We cannot do it automatically based on the number of method parameters provided because the row attribute can be applied to other elements besides methods and its contents might be consumed in other ways.)

Copy Code
            // Example of case #2, disambiguated to define a column that contains only an array of values.
            [Test]
            [Column(new object[] { new object[] { 1, 2, 3 })]
            public void Test(object[] values)
            {
                ArrayAssert.AreElementsEqual(new object[] { 1, 2, 3 }, values);
            }

See Also

ColumnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ColumnAttribute Properties
[image]

Public Properties

Name | Description
Public property | Description | Gets or sets a description of the values provided by the data source. (inherited from DataAttribute)
Public property | ExpectedException | Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test. (inherited from DataAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | Values | Gets the array of values in the column.
Top

See Also

ColumnAttribute Class
MbUnit.Framework Namespace
RowAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Values Property

ColumnAttribute.Values Property
[image]

Gets the array of values in the column.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As Object()
C#
public object[] Values { get; }
C++
public property object[] Values sealed {
array<Object>^ get();
}
J#
/** property */
public object[] get_Values();
JScript
public function get Values() : Object[]

See Also

ColumnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ColumnAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata for the data source. (inherited from DataAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

ColumnAttribute Class
MbUnit.Framework Namespace
RowAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PopulateDataSource Method

ColumnAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
) override
J#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected override function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

ColumnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CombinatorialJoinAttribute Class

CombinatorialJoinAttribute Class
See Also Example Members
[image]

Sets the join strategy of a test to be combinatorial.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class CombinatorialJoinAttribute
Inherits JoinAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class CombinatorialJoinAttribute : JoinAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class CombinatorialJoinAttribute : JoinAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class CombinatorialJoinAttribute extends JoinAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class CombinatorialJoinAttribute extends JoinAttribute

Remarks

The test will be executed using all possible combinations of values from each data source.

If there are two data sources, A and B with values A1, A2, B1 and B2, then the test will be run four times with inputs: (A1, B1), (A1, B2), (A2, B1) and (A2, B2).

This is the default join strategy for tests. So you do not need to specify this attribute unless you want to be explicit about selecting it.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
MbUnit.Framework.JoinAttribute
MbUnit.Framework.CombinatorialJoinAttribute

See Also

CombinatorialJoinAttribute Members
MbUnit.Framework Namespace
CombinatorialJoinStrategy
SequentialJoinAttribute
PairwiseJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CombinatorialJoinAttribute Members

CombinatorialJoinAttribute Members
See Also Example Constructors Properties Methods
[image]

Sets the join strategy of a test to be combinatorial.

The following tables list the members exposed by CombinatorialJoinAttribute.

Public Constructors

 | Name | Description
Public method | CombinatorialJoinAttribute | Initializes a new instance of the CombinatorialJoinAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from JoinAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Overridden. Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from JoinAttribute)
Top

See Also

CombinatorialJoinAttribute Class
MbUnit.Framework Namespace
CombinatorialJoinStrategy
SequentialJoinAttribute
PairwiseJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CombinatorialJoinAttribute Constructor

CombinatorialJoinAttribute Constructor
[image]

Initializes a new instance of the CombinatorialJoinAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CombinatorialJoinAttribute()
C++
public:
CombinatorialJoinAttribute() sealed
J#
public CombinatorialJoinAttribute()
JScript
public function CombinatorialJoinAttribute()

See Also

CombinatorialJoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

CombinatorialJoinAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from JoinAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Overridden. Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from JoinAttribute)
Top

See Also

CombinatorialJoinAttribute Class
MbUnit.Framework Namespace
CombinatorialJoinStrategy
SequentialJoinAttribute
PairwiseJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetJoinStrategy Method

CombinatorialJoinAttribute.GetJoinStrategy Method
[image]

Gets the join strategy to use.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetJoinStrategy() As IJoinStrategy
C#
protected override IJoinStrategy GetJoinStrategy()
C++
protected:
virtual IJoinStrategy GetJoinStrategy() override
J#
protected override IJoinStrategy GetJoinStrategy()
JScript
protected override function GetJoinStrategy() : IJoinStrategy

Return Value

The join strategy

See Also

CombinatorialJoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContentAttribute Class

ContentAttribute Class
See Also Example Members
[image]

An abstract base class for data source attributes that obtain contents from a local file, manifest resource, or inline data. At most one location type may be used. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public MustInherit Class ContentAttribute
Inherits DataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public abstract class ContentAttribute : DataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class ContentAttribute abstract : DataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class ContentAttribute extends DataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class ContentAttribute extends DataPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.ContentAttribute
MbUnit.Framework.CsvDataAttribute
MbUnit.Framework.XmlDataAttribute

See Also

ContentAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContentAttribute Members

ContentAttribute Members
See Also Example Constructors Properties Methods
[image]

An abstract base class for data source attributes that obtain contents from a local file, manifest resource, or inline data. At most one location type may be used. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ContentAttribute.

Protected Constructors

 | Name | Description
Family method | ContentAttribute | Initializes a new instance of the ContentAttribute class.
Top

Public Properties

Name | Description
Public property | Contents | Gets or sets the inline data contents as a string.
Public property | FilePath | Gets or sets the path of a local file relative to the current working directory from which the file contents should be read.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property ResourcePath

Gets or sets the path of a manifest resource from which the contents should be read. The path will be resolved within the assembly containing the ResourceScope type or the test fixture type if none if provided.

During resolution, a resource name is constructed from the resource path by translating backslashes to periods. If the named resource is found within the scoped assembly manifest, it is used. Otherwise, the name is prepended with the scoped type's namespace and second lookup is attempted. If this final attempt fails, then an error is raised at runtime.

Examples:

  • If the ResourceScope is MyNamespace.MyType within assembly MyAssembly.dll and if ResourcePath is "Resources\Image.gif", then resolution will first check whether Resources.Image.gif in MyAssembly.dll is a valid resource. If not found, it will consider MyNamespace.Resources.Image.gif. If still not found, then a runtime error will be raised.
  • If no ResourceScope is provided, then the containing test fixture type will be used as the resource scope. The above resolution strategy still applies.
Public property ResourceScope

Gets or sets a Type that is used to locate the assembly and namespace within which to resolve a manifest resource in combination with the ResourcePath property.

If no value is specified, the test fixture type is used as the resource scope.

Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | IsDynamic | Returns true if the contents are dynamic, or false if they are static. Static contents can only change if the test assembly is recompiled.
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDataLocationName | Gets the name of the location that is providing the data, or null if none. The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OpenStream | Opens the contents as a stream.
Family method | OpenTextReader | Opens the contents as a text reader.
Family method | PopulateDataSource | Populates the data source with the contributions of this attribute. (inherited from DataPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Family method | ValidateSource | Validates the data source properties of the content attribute.
Top

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContentAttribute Constructor

ContentAttribute Constructor
[image]

Initializes a new instance of the ContentAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected ContentAttribute()
C++
protected:
ContentAttribute() sealed
J#
protected ContentAttribute()
JScript
protected function ContentAttribute()

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ContentAttribute Properties
[image]

Public Properties

Name | Description
Public property | Contents | Gets or sets the inline data contents as a string.
Public property | FilePath | Gets or sets the path of a local file relative to the current working directory from which the file contents should be read.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property ResourcePath

Gets or sets the path of a manifest resource from which the contents should be read. The path will be resolved within the assembly containing the ResourceScope type or the test fixture type if none if provided.

During resolution, a resource name is constructed from the resource path by translating backslashes to periods. If the named resource is found within the scoped assembly manifest, it is used. Otherwise, the name is prepended with the scoped type's namespace and second lookup is attempted. If this final attempt fails, then an error is raised at runtime.

Examples:

  • If the ResourceScope is MyNamespace.MyType within assembly MyAssembly.dll and if ResourcePath is "Resources\Image.gif", then resolution will first check whether Resources.Image.gif in MyAssembly.dll is a valid resource. If not found, it will consider MyNamespace.Resources.Image.gif. If still not found, then a runtime error will be raised.
  • If no ResourceScope is provided, then the containing test fixture type will be used as the resource scope. The above resolution strategy still applies.
Public property ResourceScope

Gets or sets a Type that is used to locate the assembly and namespace within which to resolve a manifest resource in combination with the ResourcePath property.

If no value is specified, the test fixture type is used as the resource scope.

Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | IsDynamic | Returns true if the contents are dynamic, or false if they are static. Static contents can only change if the test assembly is recompiled.
Top

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Contents Property

ContentAttribute.Contents Property
[image]

Gets or sets the inline data contents as a string.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Contents As String
C#
public string Contents { get; set; }
C++
public property string Contents sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Contents();

/** property */
public void set_Contents(string value);
JScript
public function get Contents() : String

public function set Contents(value : String);

Remarks

It is an error to specify more than one content source property.

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FilePath Property

ContentAttribute.FilePath Property
[image]

Gets or sets the path of a local file relative to the current working directory from which the file contents should be read.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property FilePath As String
C#
public string FilePath { get; set; }
C++
public property string FilePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FilePath();

/** property */
public void set_FilePath(string value);
JScript
public function get FilePath() : String

public function set FilePath(value : String);

Remarks

It is an error to specify more than one content source property.

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsDynamic Property

ContentAttribute.IsDynamic Property
[image]

Returns true if the contents are dynamic, or false if they are static. Static contents can only change if the test assembly is recompiled.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsDynamic As Boolean
C#
protected virtual bool IsDynamic { get; }
C++
protected virtual property bool IsDynamic {
bool get();
}
J#
/** property */
protected bool get_IsDynamic();
JScript
protected function get IsDynamic() : bool

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ResourcePath Property

ContentAttribute.ResourcePath Property
[image]

Gets or sets the path of a manifest resource from which the contents should be read. The path will be resolved within the assembly containing the ResourceScope type or the test fixture type if none if provided.

During resolution, a resource name is constructed from the resource path by translating backslashes to periods. If the named resource is found within the scoped assembly manifest, it is used. Otherwise, the name is prepended with the scoped type's namespace and second lookup is attempted. If this final attempt fails, then an error is raised at runtime.

Examples:

  • If the ResourceScope is MyNamespace.MyType within assembly MyAssembly.dll and if ResourcePath is "Resources\Image.gif", then resolution will first check whether Resources.Image.gif in MyAssembly.dll is a valid resource. If not found, it will consider MyNamespace.Resources.Image.gif. If still not found, then a runtime error will be raised.
  • If no ResourceScope is provided, then the containing test fixture type will be used as the resource scope. The above resolution strategy still applies.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourcePath As String
C#
public string ResourcePath { get; set; }
C++
public property string ResourcePath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourcePath();

/** property */
public void set_ResourcePath(string value);
JScript
public function get ResourcePath() : String

public function set ResourcePath(value : String);

Remarks

It is an error to specify more than one content source property.

See Also

ContentAttribute Class
MbUnit.Framework Namespace
ResourceScope

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ResourceScope Property

ContentAttribute.ResourceScope Property
[image]

Gets or sets a Type that is used to locate the assembly and namespace within which to resolve a manifest resource in combination with the ResourcePath property.

If no value is specified, the test fixture type is used as the resource scope.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceScope As Type
C#
public Type ResourceScope { get; set; }
C++
public property Type ResourceScope sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_ResourceScope();

/** property */
public void set_ResourceScope(Type value);
JScript
public function get ResourceScope() : Type

public function set ResourceScope(value : Type);

See Also

ContentAttribute Class
MbUnit.Framework Namespace
ResourcePath

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ContentAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDataLocationName | Gets the name of the location that is providing the data, or null if none. The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OpenStream | Opens the contents as a stream.
Family method | OpenTextReader | Opens the contents as a text reader.
Family method | PopulateDataSource | Populates the data source with the contributions of this attribute. (inherited from DataPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Family method | ValidateSource | Validates the data source properties of the content attribute.
Top

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetDataLocationName Method

ContentAttribute.GetDataLocationName Method
[image]

Gets the name of the location that is providing the data, or null if none.

The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetDataLocationName() As String
C#
protected virtual string GetDataLocationName()
C++
protected:
virtual String GetDataLocationName()
J#
protected virtual string GetDataLocationName()
JScript
protected virtual function GetDataLocationName() : String

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OpenStream Method

ContentAttribute.OpenStream Method
[image]

Opens the contents as a stream.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function OpenStream( _
ByVal codeElement As ICodeElementInfo _
) As Stream
C#
protected virtual Stream OpenStream(
ICodeElementInfo codeElement
)
C++
protected:
virtual Stream OpenStream(
ICodeElementInfo codeElement
)
J#
protected virtual Stream OpenStream(
ICodeElementInfo codeElement
)
JScript
protected virtual function OpenStream(
codeElement : ICodeElementInfo
) : Stream

Parameters

codeElement
The code element to which the attribute was applied

Return Value

The stream

Remarks

If you override this method to return data from a different stream, consider also overriding ValidateSource in case the manner in which the data source location is specified has also changed.

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OpenTextReader Method

ContentAttribute.OpenTextReader Method
[image]

Opens the contents as a text reader.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function OpenTextReader( _
ByVal codeElement As ICodeElementInfo _
) As TextReader
C#
protected virtual TextReader OpenTextReader(
ICodeElementInfo codeElement
)
C++
protected:
virtual TextReader OpenTextReader(
ICodeElementInfo codeElement
)
J#
protected virtual TextReader OpenTextReader(
ICodeElementInfo codeElement
)
JScript
protected virtual function OpenTextReader(
codeElement : ICodeElementInfo
) : TextReader

Parameters

codeElement
The code element to which the attribute was applied

Return Value

The text reader

Remarks

If you override this method to return data from a different stream, consider also overriding ValidateSource in case the manner in which the data source location is specified has also changed.

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

ContentAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ValidateSource Method

ContentAttribute.ValidateSource Method
[image]

Validates the data source properties of the content attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ValidateSource( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void ValidateSource(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void ValidateSource(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void ValidateSource(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function ValidateSource(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The pattern scope
codeElement
The code element to which the attribute was applied

Remarks

Throws a PatternUsageErrorException if none of the source properties, such as Contents, FilePath or ResourcePath have been set.

See Also

ContentAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CsvDataAttribute Class

CsvDataAttribute Class
See Also Example Members
[image]

Provides data from Comma Separated Values contents.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class CsvDataAttribute
Inherits ContentAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class CsvDataAttribute : ContentAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class CsvDataAttribute : ContentAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class CsvDataAttribute extends ContentAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class CsvDataAttribute extends ContentAttribute

Example

This example reads data from an Embedded Resource called Data.csv within the same namespace as the test fixture.

Data files:

Copy Code
            Item, Quantity, UnitPrice, [Category]
            Bananas, 3, 0.85, Produce
            Cookies, 10, 0.10, Snacks
            # Comment: mmmm!
            Shortbread, 1, 2.25, Snacks

A simple test.

Copy Code
            public class AccountingTests
            {
                [Test]
                [CsvData(ResourcePath = "Data.csv")]
                public void ShoppingCartTotalWithSingleItem(string item, decimal unitPrice, decimal quantity)
                {
                    ShoppingCart shoppingCart = new ShoppingCart();
                    shoppingCart.Add(item, unitprice, quantity);
                    Assert.AreEqual(unitPrice * quantity, shoppingCart.TotalCost);
                }
            }

Remarks

If the CSV document has a header, then it is interpreted as the names of the columns. Columns with names in brackets, such as "[ExpectedException]", are interpreted as containing metadata values associated with the named key.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.ContentAttribute
MbUnit.Framework.CsvDataAttribute

See Also

CsvDataAttribute Members
MbUnit.Framework Namespace
CsvDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CsvDataAttribute Members

CsvDataAttribute Members
See Also Example Constructors Properties Methods
[image]

Provides data from Comma Separated Values contents.

The following tables list the members exposed by CsvDataAttribute.

Public Constructors

 | Name | Description
Public method | CsvDataAttribute | Initializes a new instance of the CsvDataAttribute class.
Top

Public Properties

Name | Description
Public property CommentPrefix

Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling.

Comment lines are excluded from the record set.

Public property | Contents | Gets or sets the inline data contents as a string. (inherited from ContentAttribute)
Public property | FieldDelimiter | Gets or sets the field delimiter character.
Public property | FilePath | Gets or sets the path of a local file relative to the current working directory from which the file contents should be read. (inherited from ContentAttribute)
Public property | HasHeader | Gets or sets whether the CSV document has a header that should be used to provide aliases for indexed columns.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property ResourcePath

Gets or sets the path of a manifest resource from which the contents should be read. The path will be resolved within the assembly containing the ResourceScope type or the test fixture type if none if provided.

During resolution, a resource name is constructed from the resource path by translating backslashes to periods. If the named resource is found within the scoped assembly manifest, it is used. Otherwise, the name is prepended with the scoped type's namespace and second lookup is attempted. If this final attempt fails, then an error is raised at runtime.

Examples:

  • If the ResourceScope is MyNamespace.MyType within assembly MyAssembly.dll and if ResourcePath is "Resources\Image.gif", then resolution will first check whether Resources.Image.gif in MyAssembly.dll is a valid resource. If not found, it will consider MyNamespace.Resources.Image.gif. If still not found, then a runtime error will be raised.
  • If no ResourceScope is provided, then the containing test fixture type will be used as the resource scope. The above resolution strategy still applies.

(inherited from ContentAttribute)
Public property ResourceScope

Gets or sets a Type that is used to locate the assembly and namespace within which to resolve a manifest resource in combination with the ResourcePath property.

If no value is specified, the test fixture type is used as the resource scope.

(inherited from ContentAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | IsDynamic | Returns true if the contents are dynamic, or false if they are static. Static contents can only change if the test assembly is recompiled. (inherited from ContentAttribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDataLocationName | Gets the name of the location that is providing the data, or null if none. The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property. (inherited from ContentAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OpenStream | Opens the contents as a stream. (inherited from ContentAttribute)
Family method | OpenTextReader | Opens the contents as a text reader. (inherited from ContentAttribute)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from ContentAttribute)
Family method | ValidateSource | Validates the data source properties of the content attribute. (inherited from ContentAttribute)
Top

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace
CsvDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CsvDataAttribute Constructor

CsvDataAttribute Constructor
[image]

Initializes a new instance of the CsvDataAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CsvDataAttribute()
C++
public:
CsvDataAttribute() sealed
J#
public CsvDataAttribute()
JScript
public function CsvDataAttribute()

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

CsvDataAttribute Properties
[image]

Public Properties

Name | Description
Public property CommentPrefix

Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling.

Comment lines are excluded from the record set.

Public property | Contents | Gets or sets the inline data contents as a string. (inherited from ContentAttribute)
Public property | FieldDelimiter | Gets or sets the field delimiter character.
Public property | FilePath | Gets or sets the path of a local file relative to the current working directory from which the file contents should be read. (inherited from ContentAttribute)
Public property | HasHeader | Gets or sets whether the CSV document has a header that should be used to provide aliases for indexed columns.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property ResourcePath

Gets or sets the path of a manifest resource from which the contents should be read. The path will be resolved within the assembly containing the ResourceScope type or the test fixture type if none if provided.

During resolution, a resource name is constructed from the resource path by translating backslashes to periods. If the named resource is found within the scoped assembly manifest, it is used. Otherwise, the name is prepended with the scoped type's namespace and second lookup is attempted. If this final attempt fails, then an error is raised at runtime.

Examples:

  • If the ResourceScope is MyNamespace.MyType within assembly MyAssembly.dll and if ResourcePath is "Resources\Image.gif", then resolution will first check whether Resources.Image.gif in MyAssembly.dll is a valid resource. If not found, it will consider MyNamespace.Resources.Image.gif. If still not found, then a runtime error will be raised.
  • If no ResourceScope is provided, then the containing test fixture type will be used as the resource scope. The above resolution strategy still applies.

(inherited from ContentAttribute)
Public property ResourceScope

Gets or sets a Type that is used to locate the assembly and namespace within which to resolve a manifest resource in combination with the ResourcePath property.

If no value is specified, the test fixture type is used as the resource scope.

(inherited from ContentAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | IsDynamic | Returns true if the contents are dynamic, or false if they are static. Static contents can only change if the test assembly is recompiled. (inherited from ContentAttribute)
Top

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace
CsvDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CommentPrefix Property

CsvDataAttribute.CommentPrefix Property
[image]

Gets or sets a character that indicates that a line in the source represents a comment. May be set to '\0' (null) to disable comment handling.

Comment lines are excluded from the record set.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property CommentPrefix As Char
C#
public char CommentPrefix { get; set; }
C++
public property char CommentPrefix sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_CommentPrefix();

/** property */
public void set_CommentPrefix(char value);
JScript
public function get CommentPrefix() : char

public function set CommentPrefix(value : char);

Property Value

The default value is '#' (pound).

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FieldDelimiter Property

CsvDataAttribute.FieldDelimiter Property
[image]

Gets or sets the field delimiter character.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property FieldDelimiter As Char
C#
public char FieldDelimiter { get; set; }
C++
public property char FieldDelimiter sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_FieldDelimiter();

/** property */
public void set_FieldDelimiter(char value);
JScript
public function get FieldDelimiter() : char

public function set FieldDelimiter(value : char);

Property Value

The default value is ',' (comma).

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


HasHeader Property

CsvDataAttribute.HasHeader Property
[image]

Gets or sets whether the CSV document has a header that should be used to provide aliases for indexed columns.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property HasHeader As Boolean
C#
public bool HasHeader { get; set; }
C++
public property bool HasHeader sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_HasHeader();

/** property */
public void set_HasHeader(bool value);
JScript
public function get HasHeader() : bool

public function set HasHeader(value : bool);

Property Value

The default value is 'false' which indicates that the file does not have a header.

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

CsvDataAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDataLocationName | Gets the name of the location that is providing the data, or null if none. The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property. (inherited from ContentAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OpenStream | Opens the contents as a stream. (inherited from ContentAttribute)
Family method | OpenTextReader | Opens the contents as a text reader. (inherited from ContentAttribute)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from ContentAttribute)
Family method | ValidateSource | Validates the data source properties of the content attribute. (inherited from ContentAttribute)
Top

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace
CsvDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PopulateDataSource Method

CsvDataAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
) override
J#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected override function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

CsvDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DataAttribute Class

DataAttribute Class
See Also Example Members
[image]

An abstract base class for MbUnit attributes that contribute values to data sources along with metadata such a description or expected exception type. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public MustInherit Class DataAttribute
Inherits DataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public abstract class DataAttribute : DataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class DataAttribute abstract : DataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class DataAttribute extends DataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class DataAttribute extends DataPatternAttribute

Remarks

You may define a new data source by creating a subclass of this attribute and overriding PopulateDataSource.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.DataAttribute
MbUnit.Framework.ColumnAttribute
MbUnit.Framework.RowAttribute

See Also

DataAttribute Members
MbUnit.Framework Namespace
DataPatternAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DataAttribute Members

DataAttribute Members
See Also Example Constructors Properties Methods
[image]

An abstract base class for MbUnit attributes that contribute values to data sources along with metadata such a description or expected exception type. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by DataAttribute.

Protected Constructors

 | Name | Description
Family method | DataAttribute | Initializes a new instance of the DataAttribute class.
Top

Public Properties

Name | Description
Public property | Description | Gets or sets a description of the values provided by the data source.
Public property | ExpectedException | Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata for the data source.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Populates the data source with the contributions of this attribute. (inherited from DataPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

DataAttribute Class
MbUnit.Framework Namespace
DataPatternAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DataAttribute Constructor

DataAttribute Constructor
[image]

Initializes a new instance of the DataAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected DataAttribute()
C++
protected:
DataAttribute() sealed
J#
protected DataAttribute()
JScript
protected function DataAttribute()

See Also

DataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

DataAttribute Properties
[image]

Public Properties

Name | Description
Public property | Description | Gets or sets a description of the values provided by the data source.
Public property | ExpectedException | Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DataAttribute Class
MbUnit.Framework Namespace
DataPatternAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Description Property

DataAttribute.Description Property
[image]

Gets or sets a description of the values provided by the data source.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

DataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedException Property

DataAttribute.ExpectedException Property
[image]

Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpectedException As Type
C#
public Type ExpectedException { get; set; }
C++
public property Type ExpectedException sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_ExpectedException();

/** property */
public void set_ExpectedException(Type value);
JScript
public function get ExpectedException() : Type

public function set ExpectedException(value : Type);

See Also

DataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DataAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata for the data source.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Populates the data source with the contributions of this attribute. (inherited from DataPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

DataAttribute Class
MbUnit.Framework Namespace
DataPatternAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

DataAttribute.GetMetadata Method
[image]

Gets the metadata for the data source.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected virtual IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata()
J#
protected virtual IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected virtual function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata keys and values

See Also

DataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DefaultTestCaseTimeoutAttribute Class

DefaultTestCaseTimeoutAttribute Class
See Also Example Members
[image]

Specifies the default test case timeout for all tests in the test assembly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := True, Inherited := True)>
Public Class DefaultTestCaseTimeoutAttribute
Inherits TestAssemblyDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)]
public class DefaultTestCaseTimeoutAttribute : TestAssemblyDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = True, Inherited = True)]
ref class DefaultTestCaseTimeoutAttribute : TestAssemblyDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True) */
public class DefaultTestCaseTimeoutAttribute extends TestAssemblyDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)
class DefaultTestCaseTimeoutAttribute extends TestAssemblyDecoratorPatternAttribute

Remarks

Defaults to 10 minutes.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestAssemblyDecoratorPatternAttribute
MbUnit.Framework.DefaultTestCaseTimeoutAttribute

See Also

DefaultTestCaseTimeoutAttribute Members
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DefaultTestCaseTimeoutAttribute Members

DefaultTestCaseTimeoutAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies the default test case timeout for all tests in the test assembly.

The following tables list the members exposed by DefaultTestCaseTimeoutAttribute.

Public Constructors

 | Name | Description
Public method | DefaultTestCaseTimeoutAttribute | Sets the default timeout in seconds, or zero if none.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Timeout | Gets the timeout, or null if none.
Public property | TimeoutSeconds | Gets the default timeout in seconds, or zero if none.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestAssemblyDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateAssemblyTest | Overridden. Applies decorations to an assembly-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestAssemblyDecoratorPatternAttribute)
Top

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DefaultTestCaseTimeoutAttribute Constructor

DefaultTestCaseTimeoutAttribute Constructor
[image]

Sets the default timeout in seconds, or zero if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal timeoutSeconds As Integer _
)
C#
public DefaultTestCaseTimeoutAttribute(
int timeoutSeconds
)
C++
public:
DefaultTestCaseTimeoutAttribute(
int timeoutSeconds
) sealed
J#
public DefaultTestCaseTimeoutAttribute(
int timeoutSeconds
)
JScript
public function DefaultTestCaseTimeoutAttribute(
timeoutSeconds : int
)

Parameters

timeoutSeconds
The timeout in seconds, or zero if none

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if timeoutSeconds is less than 0

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

DefaultTestCaseTimeoutAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Timeout | Gets the timeout, or null if none.
Public property | TimeoutSeconds | Gets the default timeout in seconds, or zero if none.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Timeout Property

DefaultTestCaseTimeoutAttribute.Timeout Property
[image]

Gets the timeout, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Timeout As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> Timeout { get; }
C++
public property Nullable<TimeSpan> Timeout sealed {
Nullable<TimeSpan> get();
}
J#
/** property */
public Nullable<TimeSpan> get_Timeout();
JScript
public function get Timeout() : Nullable<TimeSpan>

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TimeoutSeconds Property

DefaultTestCaseTimeoutAttribute.TimeoutSeconds Property
[image]

Gets the default timeout in seconds, or zero if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimeoutSeconds As Integer
C#
public int TimeoutSeconds { get; }
C++
public property int TimeoutSeconds sealed {
int get();
}
J#
/** property */
public int get_TimeoutSeconds();
JScript
public function get TimeoutSeconds() : int

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DefaultTestCaseTimeoutAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestAssemblyDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateAssemblyTest | Overridden. Applies decorations to an assembly-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestAssemblyDecoratorPatternAttribute)
Top

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateAssemblyTest Method

DefaultTestCaseTimeoutAttribute.DecorateAssemblyTest Method
[image]

Applies decorations to an assembly-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateAssemblyTest( _
ByVal assemblyScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected override void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
) override
J#
protected override void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
JScript
protected override function DecorateAssemblyTest(
assemblyScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

assemblyScope
The assembly scope
assembly
The assembly

See Also

DefaultTestCaseTimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DegreeOfParallelismAttribute Class

DegreeOfParallelismAttribute Class
See Also Example Members
[image]

Specifies the maximum number of concurrent threads to use when tests are run in parallel for all tests in the test assembly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := True, Inherited := True)>
Public Class DegreeOfParallelismAttribute
Inherits TestAssemblyDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)]
public class DegreeOfParallelismAttribute : TestAssemblyDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = True, Inherited = True)]
ref class DegreeOfParallelismAttribute : TestAssemblyDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True) */
public class DegreeOfParallelismAttribute extends TestAssemblyDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = True, Inherited = True)
class DegreeOfParallelismAttribute extends TestAssemblyDecoratorPatternAttribute

Remarks

Defaults to ProcessorCount or 2, whichever is greater.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestAssemblyDecoratorPatternAttribute
MbUnit.Framework.DegreeOfParallelismAttribute

See Also

DegreeOfParallelismAttribute Members
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DegreeOfParallelismAttribute Members

DegreeOfParallelismAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies the maximum number of concurrent threads to use when tests are run in parallel for all tests in the test assembly.

The following tables list the members exposed by DegreeOfParallelismAttribute.

Public Constructors

 | Name | Description
Public method | DegreeOfParallelismAttribute | Specifies the maximum number of concurrent threads to use when tests are run in parallel.
Top

Public Properties

Name | Description
Public property | DegreeOfParallelism | Gets the degree of parallelism.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestAssemblyDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateAssemblyTest | Overridden. Applies decorations to an assembly-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestAssemblyDecoratorPatternAttribute)
Top

See Also

DegreeOfParallelismAttribute Class
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DegreeOfParallelismAttribute Constructor

DegreeOfParallelismAttribute Constructor
[image]

Specifies the maximum number of concurrent threads to use when tests are run in parallel.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal degreeOfParallelism As Integer _
)
C#
public DegreeOfParallelismAttribute(
int degreeOfParallelism
)
C++
public:
DegreeOfParallelismAttribute(
int degreeOfParallelism
) sealed
J#
public DegreeOfParallelismAttribute(
int degreeOfParallelism
)
JScript
public function DegreeOfParallelismAttribute(
degreeOfParallelism : int
)

Parameters

degreeOfParallelism
The degree of parallelism

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if degreeOfParallelism is less than 1

See Also

DegreeOfParallelismAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

DegreeOfParallelismAttribute Properties
[image]

Public Properties

Name | Description
Public property | DegreeOfParallelism | Gets the degree of parallelism.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DegreeOfParallelismAttribute Class
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DegreeOfParallelism Property

DegreeOfParallelismAttribute.DegreeOfParallelism Property
[image]

Gets the degree of parallelism.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DegreeOfParallelism As Integer
C#
public int DegreeOfParallelism { get; }
C++
public property int DegreeOfParallelism sealed {
int get();
}
J#
/** property */
public int get_DegreeOfParallelism();
JScript
public function get DegreeOfParallelism() : int

See Also

DegreeOfParallelismAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DegreeOfParallelismAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestAssemblyDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateAssemblyTest | Overridden. Applies decorations to an assembly-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestAssemblyDecoratorPatternAttribute)
Top

See Also

DegreeOfParallelismAttribute Class
MbUnit.Framework Namespace
DegreeOfParallelism

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateAssemblyTest Method

DegreeOfParallelismAttribute.DecorateAssemblyTest Method
[image]

Applies decorations to an assembly-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateAssemblyTest( _
ByVal assemblyScope As IPatternScope, _
ByVal assembly As IAssemblyInfo _
)
C#
protected override void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
C++
protected:
virtual void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
) override
J#
protected override void DecorateAssemblyTest(
IPatternScope assemblyScope,
IAssemblyInfo assembly
)
JScript
protected override function DecorateAssemblyTest(
assemblyScope : IPatternScope,
assembly : IAssemblyInfo
)

Parameters

assemblyScope
The assembly scope
assembly
The assembly

See Also

DegreeOfParallelismAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DependsOnAttribute Class

DependsOnAttribute Class
See Also Example Members
[image]

Creates a dependency from this test assembly, test fixture or test method on some other test fixture or test method.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public Class DependsOnAttribute
Inherits TestDependencyPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public class DependsOnAttribute : TestDependencyPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class DependsOnAttribute : TestDependencyPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class DependsOnAttribute extends TestDependencyPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class DependsOnAttribute extends TestDependencyPatternAttribute

Remarks

If the other test fixture or test method fails then this test will not run. Moreover, the dependency forces this test to run after those it depends upon.

This attribute can be repeated multiple times if there are multiple dependencies.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestDependencyPatternAttribute
MbUnit.Framework.DependsOnAttribute

See Also

DependsOnAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DependsOnAttribute Members

DependsOnAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Creates a dependency from this test assembly, test fixture or test method on some other test fixture or test method.

The following tables list the members exposed by DependsOnAttribute.

Public Constructors

Name | Description
DependsOnAttribute | Overloaded.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TestFixtureType | Gets the dependent test fixture type, or null if the dependency is on another test method of this test fixture.
Public property | TestMethodName | Gets the dependent test method name, or null if the dependency is on the whole test fixture.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDependencyPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDependency | Overridden. Gets the code element that declares the tests on which this test should depend.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDependencyPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
DependsOnAttribute | Overloaded.
Top

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DependsOnAttribute Constructor

DependsOnAttribute Constructor

Overload List

 | Name | Description
Public method | DependsOnAttribute (String) | Creates a dependency from this test on another test method within this test fixture.
Public method | DependsOnAttribute (Type) | Creates a dependency from this test on another test fixture.
Public method | DependsOnAttribute (Type, String) | Creates a dependency from this test on a particular test method within another test fixture.

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DependsOnAttribute Constructor (String)

DependsOnAttribute Constructor (String)
See Also Example
[image]

Creates a dependency from this test on another test method within this test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testMethodName As String _
)
C#
public DependsOnAttribute(
string testMethodName
)
C++
public:
DependsOnAttribute(
String testMethodName
) sealed
J#
public DependsOnAttribute(
string testMethodName
)
JScript
public function DependsOnAttribute(
testMethodName : String
)

Parameters

testMethodName
The dependent test method name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testMethodName is null

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace
DependsOnAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DependsOnAttribute Constructor (Type)

DependsOnAttribute Constructor (Type)
See Also Example
[image]

Creates a dependency from this test on another test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testFixtureType As Type _
)
C#
public DependsOnAttribute(
Type testFixtureType
)
C++
public:
DependsOnAttribute(
Type testFixtureType
) sealed
J#
public DependsOnAttribute(
Type testFixtureType
)
JScript
public function DependsOnAttribute(
testFixtureType : Type
)

Parameters

testFixtureType
The dependent test fixture type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testFixtureType is null

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace
DependsOnAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DependsOnAttribute Constructor (Type, String)

DependsOnAttribute Constructor (Type, String)
See Also Example
[image]

Creates a dependency from this test on a particular test method within another test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testFixtureType As Type, _
ByVal testMethodName As String _
)
C#
public DependsOnAttribute(
Type testFixtureType,
string testMethodName
)
C++
public:
DependsOnAttribute(
Type testFixtureType,
String testMethodName
) sealed
J#
public DependsOnAttribute(
Type testFixtureType,
string testMethodName
)
JScript
public function DependsOnAttribute(
testFixtureType : Type,
testMethodName : String
)

Parameters

testFixtureType
The dependent test fixture type
testMethodName
The dependent test method name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testFixtureType or testMethodName is null

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace
DependsOnAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

DependsOnAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TestFixtureType | Gets the dependent test fixture type, or null if the dependency is on another test method of this test fixture.
Public property | TestMethodName | Gets the dependent test method name, or null if the dependency is on the whole test fixture.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureType Property

DependsOnAttribute.TestFixtureType Property
[image]

Gets the dependent test fixture type, or null if the dependency is on another test method of this test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestFixtureType As Type
C#
public Type TestFixtureType { get; }
C++
public property Type TestFixtureType sealed {
Type get();
}
J#
/** property */
public Type get_TestFixtureType();
JScript
public function get TestFixtureType() : Type

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestMethodName Property

DependsOnAttribute.TestMethodName Property
[image]

Gets the dependent test method name, or null if the dependency is on the whole test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestMethodName As String
C#
public string TestMethodName { get; }
C++
public property string TestMethodName sealed {
String get();
}
J#
/** property */
public string get_TestMethodName();
JScript
public function get TestMethodName() : String

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DependsOnAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDependencyPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDependency | Overridden. Gets the code element that declares the tests on which this test should depend.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDependencyPatternAttribute)
Top

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetDependency Method

DependsOnAttribute.GetDependency Method
[image]

Gets the code element that declares the tests on which this test should depend.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetDependency( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) As ICodeElementInfo
C#
protected override ICodeElementInfo GetDependency(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual ICodeElementInfo GetDependency(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override ICodeElementInfo GetDependency(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function GetDependency(
scope : IPatternScope,
codeElement : ICodeElementInfo
) : ICodeElementInfo

Parameters

scope
The scope
codeElement
The code element

Return Value

The code element representing the dependency

See Also

DependsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DescriptionAttribute Class

DescriptionAttribute Class
See Also Example Members
[image]

Associates a description with a test fixture, test method, test parameter or other test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class DescriptionAttribute
Inherits MetadataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class DescriptionAttribute : MetadataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class DescriptionAttribute : MetadataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class DescriptionAttribute extends MetadataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class DescriptionAttribute extends MetadataPatternAttribute

Remarks

The description provides documentation to users when browsing the tests. However, it is not the only way. If the test has associated XML documentation comments and the compiler is generating an XML documentation file for the test assembly, then MbUnit will automatically import the documentation and make it available to the user as metadata.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.DescriptionAttribute

See Also

DescriptionAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DescriptionAttribute Members

DescriptionAttribute Members
See Also Example Constructors Properties Methods
[image]

Associates a description with a test fixture, test method, test parameter or other test component.

The following tables list the members exposed by DescriptionAttribute.

Public Constructors

 | Name | Description
Public method | DescriptionAttribute | Associates a description with the test component annotated by this attribute.
Top

Public Properties

Name | Description
Public property | Description | Gets or sets the description.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

DescriptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DescriptionAttribute Constructor

DescriptionAttribute Constructor
[image]

Associates a description with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal description As String _
)
C#
public DescriptionAttribute(
string description
)
C++
public:
DescriptionAttribute(
String description
) sealed
J#
public DescriptionAttribute(
string description
)
JScript
public function DescriptionAttribute(
description : String
)

Parameters

description
The description to associate

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if description is null

See Also

DescriptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

DescriptionAttribute Properties
[image]

Public Properties

Name | Description
Public property | Description | Gets or sets the description.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

DescriptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Description Property

DescriptionAttribute.Description Property
[image]

Gets or sets the description.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
C#
public string Description { get; }
C++
public property string Description sealed {
String get();
}
J#
/** property */
public string get_Description();
JScript
public function get Description() : String

See Also

DescriptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DescriptionAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

DescriptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

DescriptionAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata() override
J#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected override function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

DescriptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DynamicTestFactoryAttribute Class

DynamicTestFactoryAttribute Class
See Also Example Members
[image]

Specifies a method that is used to generate tests dynamically at runtime.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class DynamicTestFactoryAttribute
Inherits TestMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class DynamicTestFactoryAttribute : TestMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class DynamicTestFactoryAttribute : TestMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class DynamicTestFactoryAttribute extends TestMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class DynamicTestFactoryAttribute extends TestMethodPatternAttribute

Example

A simple dynamic test factory that reads some data from a file and generates a number of dynamic tests.

Copy Code
            [DynamicTestFactory]
            public IEnumerable<Test> CreateDynamicTests()
            {
                foreach (string searchTerm in File.ReadAllLines("SearchTerms.txt"))
                {
                    yield return new TestCase("Search Term: " + searchTerm, () => {
                        var searchEngine = new SearchEngine();
                        Assert.IsNotEmpty(searchEngine.GetSearchResults(searchTerm));
                    });
                }
            }

A data-driven test factory that reads some data from a file and generates a number of dynamic tests repeatedly in multiple configurations.

Copy Code
            [DynamicTestFactory]
            [Row("Google")]
            [Row("Yahoo")]
            public IEnumerable<Test> CreateDynamicTests(string searchProvider)
            {
                foreach (string searchTerm in File.ReadAllLines("SearchTerms.txt"))
                {
                    yield return new TestCase("Search Term: " + searchTerm, () => {
                        var searchEngine = new SearchEngine(searchProvider);
                        Assert.IsNotEmpty(searchEngine.GetSearchResults(searchTerm));
                    });
                }
            }

Remarks

The tests created by the dynamic test factory are considered to be children of the factory method that generated them. Because the tests are created dynamically, they will not appear in the test tree (so most test runners will not find them) and they are not directly affected by test filters. However, the dynamic test factory is represented as a test so it will be visible in the test tree.

Contrast with DynamicTestFactoryAttribute.

The method to which this attribute is applied must be declared by the fixture class. It may have parameters and be data-driven just like an ordinary test method! The method may be static. It must return an enumeration of values of type Test.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestMethodPatternAttribute
MbUnit.Framework.DynamicTestFactoryAttribute

See Also

DynamicTestFactoryAttribute Members
MbUnit.Framework Namespace
DynamicTestFactoryAttribute
TestCase

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DynamicTestFactoryAttribute Members

DynamicTestFactoryAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is used to generate tests dynamically at runtime.

The following tables list the members exposed by DynamicTestFactoryAttribute.

Public Constructors

 | Name | Description
Public method | DynamicTestFactoryAttribute | Initializes a new instance of the DynamicTestFactoryAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from TestMethodPatternAttribute)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from TestMethodPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none. (inherited from TestMethodPatternAttribute)
Family property | DefaultMethodParameterPattern | Gets the default pattern to apply to method parameters that do not have a primary pattern, or null if none. (inherited from TestMethodPatternAttribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestMethodPatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Overridden. Executes the test method.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model. (inherited from TestMethodPatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest. (inherited from TestMethodPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodPatternAttribute)
Top

See Also

DynamicTestFactoryAttribute Class
MbUnit.Framework Namespace
DynamicTestFactoryAttribute
TestCase

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DynamicTestFactoryAttribute Constructor

DynamicTestFactoryAttribute Constructor
[image]

Initializes a new instance of the DynamicTestFactoryAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DynamicTestFactoryAttribute()
C++
public:
DynamicTestFactoryAttribute() sealed
J#
public DynamicTestFactoryAttribute()
JScript
public function DynamicTestFactoryAttribute()

See Also

DynamicTestFactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DynamicTestFactoryAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestMethodPatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Overridden. Executes the test method.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model. (inherited from TestMethodPatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest. (inherited from TestMethodPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodPatternAttribute)
Top

See Also

DynamicTestFactoryAttribute Class
MbUnit.Framework Namespace
DynamicTestFactoryAttribute
TestCase

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Execute Method

DynamicTestFactoryAttribute.Execute Method
[image]

Executes the test method.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function Execute( _
ByVal state As PatternTestInstanceState _
) As Object
C#
protected override object Execute(
PatternTestInstanceState state
)
C++
protected:
virtual Object Execute(
PatternTestInstanceState state
) override
J#
protected override object Execute(
PatternTestInstanceState state
)
JScript
protected override function Execute(
state : PatternTestInstanceState
) : Object

Parameters

state
The test instance state, not null

Return Value

The test method result

See Also

DynamicTestFactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentExceptionAttribute Class

ExpectedArgumentExceptionAttribute Class
See Also Example Members
[image]

Declares that the associated test is expected to throw an ArgumentException.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ExpectedArgumentExceptionAttribute
Inherits ExpectedExceptionAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ExpectedArgumentExceptionAttribute : ExpectedExceptionAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ExpectedArgumentExceptionAttribute : ExpectedExceptionAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ExpectedArgumentExceptionAttribute extends ExpectedExceptionAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ExpectedArgumentExceptionAttribute extends ExpectedExceptionAttribute

Remarks

The expected contents of the exception message may optionally be specified.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.ExpectedExceptionAttribute
MbUnit.Framework.ExpectedArgumentExceptionAttribute

See Also

ExpectedArgumentExceptionAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentExceptionAttribute Members

ExpectedArgumentExceptionAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Declares that the associated test is expected to throw an ArgumentException.

The following tables list the members exposed by ExpectedArgumentExceptionAttribute.

Public Constructors

Name | Description
ExpectedArgumentExceptionAttribute | Overloaded. Initializes a new instance of the ExpectedArgumentExceptionAttribute class.
Top

Public Properties

Name | Description
Public property | ExceptionType | Gets the expected exception type. (inherited from ExpectedExceptionAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets or sets the expected exception message, or null if none specified. (inherited from ExpectedExceptionAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test. (inherited from ExpectedExceptionAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
ExpectedArgumentExceptionAttribute | Overloaded. Initializes a new instance of the ExpectedArgumentExceptionAttribute class.
Top

See Also

ExpectedArgumentExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentExceptionAttribute Constructor

ExpectedArgumentExceptionAttribute Constructor

Initializes a new instance of the ExpectedArgumentExceptionAttribute class.

Overload List

 | Name | Description
Public method | ExpectedArgumentExceptionAttribute | Declares that the associated test is expected to throw an ArgumentOutOfRangeException.
Public method | ExpectedArgumentExceptionAttribute (String) | Declares that the associated test is expected to throw an ArgumentOutOfRangeException. The expected contents of the exception message may also optionally be specified.

See Also

ExpectedArgumentExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentExceptionAttribute Constructor ()

ExpectedArgumentExceptionAttribute Constructor ()
See Also Example
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExpectedArgumentExceptionAttribute()
C++
public:
ExpectedArgumentExceptionAttribute() sealed
J#
public ExpectedArgumentExceptionAttribute()
JScript
public function ExpectedArgumentExceptionAttribute()

See Also

ExpectedArgumentExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedArgumentExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentExceptionAttribute Constructor (String)

ExpectedArgumentExceptionAttribute Constructor (String)
See Also Example
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException. The expected contents of the exception message may also optionally be specified.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public ExpectedArgumentExceptionAttribute(
string message
)
C++
public:
ExpectedArgumentExceptionAttribute(
String message
) sealed
J#
public ExpectedArgumentExceptionAttribute(
string message
)
JScript
public function ExpectedArgumentExceptionAttribute(
message : String
)

Parameters

message
The expected exception message, or null if not specified

See Also

ExpectedArgumentExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedArgumentExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentNullExceptionAttribute Class

ExpectedArgumentNullExceptionAttribute Class
See Also Example Members
[image]

Declares that the associated test is expected to throw an ArgumentNullException.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ExpectedArgumentNullExceptionAttribute
Inherits ExpectedExceptionAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ExpectedArgumentNullExceptionAttribute : ExpectedExceptionAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ExpectedArgumentNullExceptionAttribute : ExpectedExceptionAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ExpectedArgumentNullExceptionAttribute extends ExpectedExceptionAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ExpectedArgumentNullExceptionAttribute extends ExpectedExceptionAttribute

Remarks

The expected contents of the exception message may optionally be specified.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.ExpectedExceptionAttribute
MbUnit.Framework.ExpectedArgumentNullExceptionAttribute

See Also

ExpectedArgumentNullExceptionAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentNullExceptionAttribute Members

ExpectedArgumentNullExceptionAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Declares that the associated test is expected to throw an ArgumentNullException.

The following tables list the members exposed by ExpectedArgumentNullExceptionAttribute.

Public Constructors

Name | Description
ExpectedArgumentNullExceptionAttribute | Overloaded. Initializes a new instance of the ExpectedArgumentNullExceptionAttribute class.
Top

Public Properties

Name | Description
Public property | ExceptionType | Gets the expected exception type. (inherited from ExpectedExceptionAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets or sets the expected exception message, or null if none specified. (inherited from ExpectedExceptionAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test. (inherited from ExpectedExceptionAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
ExpectedArgumentNullExceptionAttribute | Overloaded. Initializes a new instance of the ExpectedArgumentNullExceptionAttribute class.
Top

See Also

ExpectedArgumentNullExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentNullExceptionAttribute Constructor

ExpectedArgumentNullExceptionAttribute Constructor

Initializes a new instance of the ExpectedArgumentNullExceptionAttribute class.

Overload List

 | Name | Description
Public method | ExpectedArgumentNullExceptionAttribute | Declares that the associated test is expected to throw an ArgumentOutOfRangeException.
Public method | ExpectedArgumentNullExceptionAttribute (String) | Declares that the associated test is expected to throw an ArgumentOutOfRangeException. The expected contents of the exception message may also optionally be specified.

See Also

ExpectedArgumentNullExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentNullExceptionAttribute Constructor ()

ExpectedArgumentNullExceptionAttribute Constructor ()
See Also Example
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExpectedArgumentNullExceptionAttribute()
C++
public:
ExpectedArgumentNullExceptionAttribute() sealed
J#
public ExpectedArgumentNullExceptionAttribute()
JScript
public function ExpectedArgumentNullExceptionAttribute()

See Also

ExpectedArgumentNullExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedArgumentNullExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentNullExceptionAttribute Constructor (String)

ExpectedArgumentNullExceptionAttribute Constructor (String)
See Also Example
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException. The expected contents of the exception message may also optionally be specified.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public ExpectedArgumentNullExceptionAttribute(
string message
)
C++
public:
ExpectedArgumentNullExceptionAttribute(
String message
) sealed
J#
public ExpectedArgumentNullExceptionAttribute(
string message
)
JScript
public function ExpectedArgumentNullExceptionAttribute(
message : String
)

Parameters

message
The expected exception message, or null if not specified

See Also

ExpectedArgumentNullExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedArgumentNullExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentOutOfRangeExceptionAttribute Class

ExpectedArgumentOutOfRangeExceptionAttribute Class
See Also Example Members
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ExpectedArgumentOutOfRangeExceptionAttribute
Inherits ExpectedExceptionAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ExpectedArgumentOutOfRangeExceptionAttribute : ExpectedExceptionAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ExpectedArgumentOutOfRangeExceptionAttribute : ExpectedExceptionAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ExpectedArgumentOutOfRangeExceptionAttribute extends ExpectedExceptionAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ExpectedArgumentOutOfRangeExceptionAttribute extends ExpectedExceptionAttribute

Remarks

The expected contents of the exception message may optionally be specified.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.ExpectedExceptionAttribute
MbUnit.Framework.ExpectedArgumentOutOfRangeExceptionAttribute

See Also

ExpectedArgumentOutOfRangeExceptionAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentOutOfRangeExceptionAttribute Members

ExpectedArgumentOutOfRangeExceptionAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException.

The following tables list the members exposed by ExpectedArgumentOutOfRangeExceptionAttribute.

Public Constructors

Name | Description
ExpectedArgumentOutOfRangeExceptionAttribute | Overloaded. Initializes a new instance of the ExpectedArgumentOutOfRangeExceptionAttribute class.
Top

Public Properties

Name | Description
Public property | ExceptionType | Gets the expected exception type. (inherited from ExpectedExceptionAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets or sets the expected exception message, or null if none specified. (inherited from ExpectedExceptionAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test. (inherited from ExpectedExceptionAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
ExpectedArgumentOutOfRangeExceptionAttribute | Overloaded. Initializes a new instance of the ExpectedArgumentOutOfRangeExceptionAttribute class.
Top

See Also

ExpectedArgumentOutOfRangeExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentOutOfRangeExceptionAttribute Constructor

ExpectedArgumentOutOfRangeExceptionAttribute Constructor

Initializes a new instance of the ExpectedArgumentOutOfRangeExceptionAttribute class.

Overload List

 | Name | Description
Public method | ExpectedArgumentOutOfRangeExceptionAttribute | Declares that the associated test is expected to throw an ArgumentOutOfRangeException.
Public method | ExpectedArgumentOutOfRangeExceptionAttribute (String) | Declares that the associated test is expected to throw an ArgumentOutOfRangeException. The expected contents of the exception message may also optionally be specified.

See Also

ExpectedArgumentOutOfRangeExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentOutOfRangeExceptionAttribute Constructor ()

ExpectedArgumentOutOfRangeExceptionAttribute Constructor ()
See Also Example
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExpectedArgumentOutOfRangeExceptionAttribute()
C++
public:
ExpectedArgumentOutOfRangeExceptionAttribute() sealed
J#
public ExpectedArgumentOutOfRangeExceptionAttribute()
JScript
public function ExpectedArgumentOutOfRangeExceptionAttribute()

See Also

ExpectedArgumentOutOfRangeExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedArgumentOutOfRangeExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedArgumentOutOfRangeExceptionAttribute Constructor (String)

ExpectedArgumentOutOfRangeExceptionAttribute Constructor (String)
See Also Example
[image]

Declares that the associated test is expected to throw an ArgumentOutOfRangeException. The expected contents of the exception message may also optionally be specified.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public ExpectedArgumentOutOfRangeExceptionAttribute(
string message
)
C++
public:
ExpectedArgumentOutOfRangeExceptionAttribute(
String message
) sealed
J#
public ExpectedArgumentOutOfRangeExceptionAttribute(
string message
)
JScript
public function ExpectedArgumentOutOfRangeExceptionAttribute(
message : String
)

Parameters

message
The expected exception message, or null if not specified

See Also

ExpectedArgumentOutOfRangeExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedArgumentOutOfRangeExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedExceptionAttribute Class

ExpectedExceptionAttribute Class
See Also Example Members
[image]

Declares that the associated test is expected to throw an exception of a particular type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ExpectedExceptionAttribute
Inherits TestMethodDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ExpectedExceptionAttribute : TestMethodDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ExpectedExceptionAttribute : TestMethodDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ExpectedExceptionAttribute extends TestMethodDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ExpectedExceptionAttribute extends TestMethodDecoratorPatternAttribute

Remarks

The expected contents of the exception message may optionally be specified.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.ExpectedExceptionAttribute
MbUnit.Framework.ExpectedArgumentExceptionAttribute
MbUnit.Framework.ExpectedArgumentNullExceptionAttribute
MbUnit.Framework.ExpectedArgumentOutOfRangeExceptionAttribute

See Also

ExpectedExceptionAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedExceptionAttribute Members

ExpectedExceptionAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Declares that the associated test is expected to throw an exception of a particular type.

The following tables list the members exposed by ExpectedExceptionAttribute.

Public Constructors

Name | Description
ExpectedExceptionAttribute | Overloaded.
Top

Public Properties

Name | Description
Public property | ExceptionType | Gets the expected exception type.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets or sets the expected exception message, or null if none specified.
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Overridden. Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
ExpectedExceptionAttribute | Overloaded.
Top

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedExceptionAttribute Constructor

ExpectedExceptionAttribute Constructor

Overload List

 | Name | Description
Public method | ExpectedExceptionAttribute (Type) | Declares that the associated test is expected to throw an exception of a particular type.
Public method | ExpectedExceptionAttribute (Type, String) | Declares that the associated test is expected to throw an exception of a particular type. The expected contents of the exception message may also optionally be specified.

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedExceptionAttribute Constructor (Type)

ExpectedExceptionAttribute Constructor (Type)
See Also Example
[image]

Declares that the associated test is expected to throw an exception of a particular type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal exceptionType As Type _
)
C#
public ExpectedExceptionAttribute(
Type exceptionType
)
C++
public:
ExpectedExceptionAttribute(
Type exceptionType
) sealed
J#
public ExpectedExceptionAttribute(
Type exceptionType
)
JScript
public function ExpectedExceptionAttribute(
exceptionType : Type
)

Parameters

exceptionType
The expected exception type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exceptionType is null

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExpectedExceptionAttribute Constructor (Type, String)

ExpectedExceptionAttribute Constructor (Type, String)
See Also Example
[image]

Declares that the associated test is expected to throw an exception of a particular type. The expected contents of the exception message may also optionally be specified.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal exceptionType As Type, _
ByVal message As String _
)
C#
public ExpectedExceptionAttribute(
Type exceptionType,
string message
)
C++
public:
ExpectedExceptionAttribute(
Type exceptionType,
String message
) sealed
J#
public ExpectedExceptionAttribute(
Type exceptionType,
string message
)
JScript
public function ExpectedExceptionAttribute(
exceptionType : Type,
message : String
)

Parameters

exceptionType
The expected exception type
message
The expected exception message, or null if not specified

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if exceptionType is null

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace
ExpectedExceptionAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ExpectedExceptionAttribute Properties
[image]

Public Properties

Name | Description
Public property | ExceptionType | Gets the expected exception type.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Message | Gets or sets the expected exception message, or null if none specified.
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExceptionType Property

ExpectedExceptionAttribute.ExceptionType Property
[image]

Gets the expected exception type.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExceptionType As Type
C#
public Type ExceptionType { get; }
C++
public property Type ExceptionType sealed {
Type get();
}
J#
/** property */
public Type get_ExceptionType();
JScript
public function get ExceptionType() : Type

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Message Property

ExpectedExceptionAttribute.Message Property
[image]

Gets or sets the expected exception message, or null if none specified.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
C++
public property string Message sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Message();

/** property */
public void set_Message(string value);
JScript
public function get Message() : String

public function set Message(value : String);

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ExpectedExceptionAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Overridden. Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateMethodTest Method

ExpectedExceptionAttribute.DecorateMethodTest Method
[image]

Applies decorations to a method-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateMethodTest( _
ByVal methodScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
) override
J#
protected override void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
JScript
protected override function DecorateMethodTest(
methodScope : IPatternScope,
method : IMethodInfo
)

Parameters

methodScope
The method scope
method
The method

See Also

ExpectedExceptionAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExplicitAttribute Class

ExplicitAttribute Class
See Also Example Members
[image]

Indicates that a test should only be run explicitly. The test will still appear in the test tree but it will not run and it will not appear in the test results unless it is explicitly selected for execution.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ExplicitAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ExplicitAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ExplicitAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ExplicitAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ExplicitAttribute extends TestDecoratorPatternAttribute

Remarks

A test is considered to be explicitly selected when the filter used to run the tests matches the test or its descendants but none of its ancestors. For example, if the filter matches a test case but not its containing test fixture then the test case will be deemed to be explicitly selected. Otherwise the test case will be implicitly selected by virtue of the fact that the filter matched one of its ancestors.

This attribute can be used to exclude from normal execution any tests that are particularly expensive or require manual supervision by an operator.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.ExplicitAttribute

See Also

ExplicitAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExplicitAttribute Members

ExplicitAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Indicates that a test should only be run explicitly. The test will still appear in the test tree but it will not run and it will not appear in the test results unless it is explicitly selected for execution.

The following tables list the members exposed by ExplicitAttribute.

Public Constructors

Name | Description
ExplicitAttribute | Overloaded. Initializes a new instance of the ExplicitAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Reason | Gets the reason that the test should only run explicitly.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
ExplicitAttribute | Overloaded. Initializes a new instance of the ExplicitAttribute class.
Top

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExplicitAttribute Constructor

ExplicitAttribute Constructor

Initializes a new instance of the ExplicitAttribute class.

Overload List

 | Name | Description
Public method | ExplicitAttribute | Indicates that this test should only run explicitly without providing a reason.
Public method | ExplicitAttribute (String) | Indicates that this test should only run explicitly and provides a reason.

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExplicitAttribute Constructor ()

ExplicitAttribute Constructor ()
See Also Example
[image]

Indicates that this test should only run explicitly without providing a reason.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExplicitAttribute()
C++
public:
ExplicitAttribute() sealed
J#
public ExplicitAttribute()
JScript
public function ExplicitAttribute()

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace
ExplicitAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExplicitAttribute Constructor (String)

ExplicitAttribute Constructor (String)
See Also Example
[image]

Indicates that this test should only run explicitly and provides a reason.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal reason As String _
)
C#
public ExplicitAttribute(
string reason
)
C++
public:
ExplicitAttribute(
String reason
) sealed
J#
public ExplicitAttribute(
string reason
)
JScript
public function ExplicitAttribute(
reason : String
)

Parameters

reason
The reason for which the test should be run explicitly

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reason is null

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace
ExplicitAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ExplicitAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Reason | Gets the reason that the test should only run explicitly.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reason Property

ExplicitAttribute.Reason Property
[image]

Gets the reason that the test should only run explicitly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reason As String
C#
public string Reason { get; }
C++
public property string Reason sealed {
String get();
}
J#
/** property */
public string get_Reason();
JScript
public function get Reason() : String

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ExplicitAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

ExplicitAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

ExplicitAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FactoryAttribute Class

FactoryAttribute Class
See Also Example Members
[image]

Specifies a factory member that will provide values for a data-driven test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class FactoryAttribute
Inherits DataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class FactoryAttribute : DataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class FactoryAttribute : DataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class FactoryAttribute extends DataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class FactoryAttribute extends DataPatternAttribute

Remarks

The factory may be an instance or static member of the fixture class or a static member of some other class.

Refer to FactoryDataSet and FactoryKind for more information about how the factory data set works and the kinds of factories that are supported.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.FactoryAttribute

See Also

FactoryAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FactoryAttribute Members

FactoryAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Specifies a factory member that will provide values for a data-driven test.

The following tables list the members exposed by FactoryAttribute.

Public Constructors

Name | Description
FactoryAttribute | Overloaded.
Top

Public Properties

Name | Description
Public property | ColumnCount | Gets or sets the number of columns produced by the factory, or 0 if unknown. Defaults to 0.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Kind | Gets or sets the kind of the factory. Defaults to Auto.
Public property | MemberName | Gets the factory member name, never null.
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | Type | Gets the declaring type of the factory, or null if it is assumed to be the fixture class.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
FactoryAttribute | Overloaded.
Top

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FactoryAttribute Constructor

FactoryAttribute Constructor

Overload List

Name Description
Public method FactoryAttribute (String)

Specifies the name of a method, property or field of the fixture class that will provide values for a data-driven test. The factory member must return an enumeration of values ().

The factory member may be non-static if it will be used within the scope of an initialized fixture. Typically this is the case for factory members referenced by non-static test methods.

for more information about factories.
Public method FactoryAttribute (Type, String)

Specifies the declaring type and name of a static method, property or field that will provide values for a data-driven test. The factory member must return an enumeration of values ().

for more information about factories.

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FactoryAttribute Constructor (String)

FactoryAttribute Constructor (String)
See Also Example
[image]

Specifies the name of a method, property or field of the fixture class that will provide values for a data-driven test. The factory member must return an enumeration of values ().

The factory member may be non-static if it will be used within the scope of an initialized fixture. Typically this is the case for factory members referenced by non-static test methods.

for more information about factories.
Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal memberName As String _
)
C#
public FactoryAttribute(
string memberName
)
C++
public:
FactoryAttribute(
String memberName
) sealed
J#
public FactoryAttribute(
string memberName
)
JScript
public function FactoryAttribute(
memberName : String
)

Parameters

memberName
The factory member name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if memberName is null

See Also

FactoryAttribute Class
MbUnit.Framework Namespace
FactoryAttribute Constructor Overload List
FactoryKind
FactoryAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FactoryAttribute Constructor (Type, String)

FactoryAttribute Constructor (Type, String)
See Also Example
[image]

Specifies the declaring type and name of a static method, property or field that will provide values for a data-driven test. The factory member must return an enumeration of values ().

for more information about factories.
Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As Type, _
ByVal memberName As String _
)
C#
public FactoryAttribute(
Type type,
string memberName
)
C++
public:
FactoryAttribute(
Type type,
String memberName
) sealed
J#
public FactoryAttribute(
Type type,
string memberName
)
JScript
public function FactoryAttribute(
type : Type,
memberName : String
)

Parameters

type
The declaring type of the factory
memberName
The factory member name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type or memberName is null

See Also

FactoryAttribute Class
MbUnit.Framework Namespace
FactoryAttribute Constructor Overload List
FactoryKind
FactoryAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

FactoryAttribute Properties
[image]

Public Properties

Name | Description
Public property | ColumnCount | Gets or sets the number of columns produced by the factory, or 0 if unknown. Defaults to 0.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Kind | Gets or sets the kind of the factory. Defaults to Auto.
Public property | MemberName | Gets the factory member name, never null.
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | Type | Gets the declaring type of the factory, or null if it is assumed to be the fixture class.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ColumnCount Property

FactoryAttribute.ColumnCount Property
[image]

Gets or sets the number of columns produced by the factory, or 0 if unknown. Defaults to 0.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ColumnCount As Integer
C#
public int ColumnCount { get; set; }
C++
public property int ColumnCount sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_ColumnCount();

/** property */
public void set_ColumnCount(int value);
JScript
public function get ColumnCount() : int

public function set ColumnCount(value : int);

Property Value

The number of columns

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if value is less than zero

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Kind Property

FactoryAttribute.Kind Property
[image]

Gets or sets the kind of the factory. Defaults to Auto.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Kind As FactoryKind
C#
public FactoryKind Kind { get; set; }
C++
public property FactoryKind Kind sealed {
FactoryKind get();
void set(FactoryKind value);
}
J#
/** property */
public FactoryKind get_Kind();

/** property */
public void set_Kind(FactoryKind value);
JScript
public function get Kind() : FactoryKind

public function set Kind(value : FactoryKind);

Property Value

The kind of the factory.

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MemberName Property

FactoryAttribute.MemberName Property
[image]

Gets the factory member name, never null.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MemberName As String
C#
public string MemberName { get; }
C++
public property string MemberName sealed {
String get();
}
J#
/** property */
public string get_MemberName();
JScript
public function get MemberName() : String

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Type Property

FactoryAttribute.Type Property
[image]

Gets the declaring type of the factory, or null if it is assumed to be the fixture class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Type
C#
public Type Type { get; }
C++
public property Type Type sealed {
Type get();
}
J#
/** property */
public Type get_Type();
JScript
public function get Type() : Type

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

FactoryAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PopulateDataSource Method

FactoryAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
) override
J#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected override function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

FactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureInitializerAttribute Class

FixtureInitializerAttribute Class
See Also Example Members
[image]

Specifies a method that is to be invoked after a fixture instance has been created to complete its initialization before test fixture setup runs.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class FixtureInitializerAttribute
Inherits ContributionMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class FixtureInitializerAttribute : ContributionMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class FixtureInitializerAttribute : ContributionMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class FixtureInitializerAttribute extends ContributionMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class FixtureInitializerAttribute extends ContributionMethodPatternAttribute

Remarks

This attribute provides a mechanism for completing the initialization of a fixture if the work cannot be completed entirely within the constructor. For example, data binding might be used to set fields and property values of the fixture instance. Consequently post-construction initialization may be required.

FixtureInitializerAttribute allows initialization to occur earlier in the test lifecycle than FixtureSetUpAttribute.

The attribute may be applied to multiple methods within a fixture, however the order in which they are processed is undefined.

The method to which this attribute is applied must be declared by the fixture class and must not have any parameters. The method may be static.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.FixtureInitializerAttribute

See Also

FixtureInitializerAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureInitializerAttribute Members

FixtureInitializerAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is to be invoked after a fixture instance has been created to complete its initialization before test fixture setup runs.

The following tables list the members exposed by FixtureInitializerAttribute.

Public Constructors

 | Name | Description
Public method | FixtureInitializerAttribute | Initializes a new instance of the FixtureInitializerAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

FixtureInitializerAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureInitializerAttribute Constructor

FixtureInitializerAttribute Constructor
[image]

Initializes a new instance of the FixtureInitializerAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FixtureInitializerAttribute()
C++
public:
FixtureInitializerAttribute() sealed
J#
public FixtureInitializerAttribute()
JScript
public function FixtureInitializerAttribute()

See Also

FixtureInitializerAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

FixtureInitializerAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

FixtureInitializerAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateContainingScope Method

FixtureInitializerAttribute.DecorateContainingScope Method
[image]

Applies decorations to the containing test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateContainingScope( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function DecorateContainingScope(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method to process

See Also

FixtureInitializerAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

FixtureInitializerAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function Validate(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method

See Also

FixtureInitializerAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureSetUpAttribute Class

FixtureSetUpAttribute Class
See Also Example Members
[image]

Specifies a method that is to be invoked to set up the state of a fixture before any of its tests are executed.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class FixtureSetUpAttribute
Inherits ContributionMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class FixtureSetUpAttribute : ContributionMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class FixtureSetUpAttribute : ContributionMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class FixtureSetUpAttribute extends ContributionMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class FixtureSetUpAttribute extends ContributionMethodPatternAttribute

Remarks

The attribute may be applied to multiple methods within a fixture, however the order in which they are processed is undefined.

The method to which this attribute is applied must be declared by the fixture class and must not have any parameters. The method may be static.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.FixtureSetUpAttribute
MbUnit.Framework.TestFixtureSetUpAttribute

See Also

FixtureSetUpAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureSetUpAttribute Members

FixtureSetUpAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is to be invoked to set up the state of a fixture before any of its tests are executed.

The following tables list the members exposed by FixtureSetUpAttribute.

Public Constructors

 | Name | Description
Public method | FixtureSetUpAttribute | Initializes a new instance of the FixtureSetUpAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

FixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureSetUpAttribute Constructor

FixtureSetUpAttribute Constructor
[image]

Initializes a new instance of the FixtureSetUpAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FixtureSetUpAttribute()
C++
public:
FixtureSetUpAttribute() sealed
J#
public FixtureSetUpAttribute()
JScript
public function FixtureSetUpAttribute()

See Also

FixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

FixtureSetUpAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

FixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateContainingScope Method

FixtureSetUpAttribute.DecorateContainingScope Method
[image]

Applies decorations to the containing test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateContainingScope( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function DecorateContainingScope(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method to process

See Also

FixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

FixtureSetUpAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function Validate(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method

See Also

FixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureTearDownAttribute Class

FixtureTearDownAttribute Class
See Also Example Members
[image]

Specifies a method that is to be invoked to tear down the state of a fixture after all of its tests have been executed.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class FixtureTearDownAttribute
Inherits ContributionMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class FixtureTearDownAttribute : ContributionMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class FixtureTearDownAttribute : ContributionMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class FixtureTearDownAttribute extends ContributionMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class FixtureTearDownAttribute extends ContributionMethodPatternAttribute

Remarks

The attribute may be applied to multiple methods within a fixture, however the order in which they are processed is undefined.

The method to which this attribute is applied must be declared by the fixture class and must not have any parameters. The method may be static.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.FixtureTearDownAttribute
MbUnit.Framework.TestFixtureTearDownAttribute

See Also

FixtureTearDownAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureTearDownAttribute Members

FixtureTearDownAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is to be invoked to tear down the state of a fixture after all of its tests have been executed.

The following tables list the members exposed by FixtureTearDownAttribute.

Public Constructors

 | Name | Description
Public method | FixtureTearDownAttribute | Initializes a new instance of the FixtureTearDownAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

FixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


FixtureTearDownAttribute Constructor

FixtureTearDownAttribute Constructor
[image]

Initializes a new instance of the FixtureTearDownAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FixtureTearDownAttribute()
C++
public:
FixtureTearDownAttribute() sealed
J#
public FixtureTearDownAttribute()
JScript
public function FixtureTearDownAttribute()

See Also

FixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

FixtureTearDownAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

FixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateContainingScope Method

FixtureTearDownAttribute.DecorateContainingScope Method
[image]

Applies decorations to the containing test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateContainingScope( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function DecorateContainingScope(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method to process

See Also

FixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

FixtureTearDownAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function Validate(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method

See Also

FixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


HeaderAttribute Class

HeaderAttribute Class
See Also Example Members
[image]

Defines names as aliases for the columns in an indexed data source such as those that have been populated by RowAttribute or ColumnAttribute. The names may subsequently be used in data binding expressions in place of their corresponding column indices.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False), _
AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class HeaderAttribute
Inherits DataPatternAttribute
C#
[CLSCompliantAttribute(False)]
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class HeaderAttribute : DataPatternAttribute
C++
[CLSCompliantAttribute(False)]
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class HeaderAttribute : DataPatternAttribute
J#
/** @attribute CLSCompliantAttribute(False) */
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class HeaderAttribute extends DataPatternAttribute
JScript
public
CLSCompliantAttribute(False)
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class HeaderAttribute extends DataPatternAttribute

Example

Copy Code
            [Test]
            [Header("username", "password")]
            [Row("jeff", "letmein")]
            [Row("liz", "password")]
            public void Test([BindObject] Credentials credentials)
            {
                // ...
            }

            public class Credentials
            {
                public string UserName;
                public string Password;
            }

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.HeaderAttribute

See Also

HeaderAttribute Members
MbUnit.Framework Namespace
RowAttribute
ColumnAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


HeaderAttribute Members

HeaderAttribute Members
See Also Example Constructors Properties Methods
[image]

Defines names as aliases for the columns in an indexed data source such as those that have been populated by RowAttribute or ColumnAttribute. The names may subsequently be used in data binding expressions in place of their corresponding column indices.

The following tables list the members exposed by HeaderAttribute.

Public Constructors

 | Name | Description
Public method | HeaderAttribute | Defines names as aliases for the columns in an indexed data source.
Top

Public Properties

Name | Description
Public property | ColumnNames | Gets the array of column names.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

HeaderAttribute Class
MbUnit.Framework Namespace
RowAttribute
ColumnAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


HeaderAttribute Constructor

HeaderAttribute Constructor
[image]

Defines names as aliases for the columns in an indexed data source.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)>
Public Sub New( _
ByVal ParamArray columnNames As String() _
)
C#
[CLSCompliantAttribute(False)]
public HeaderAttribute(
params string[] columnNames
)
C++
[CLSCompliantAttribute(False)]
public:
HeaderAttribute(
... array<String>^ columnNames
) sealed
J#
/** @attribute CLSCompliantAttribute(False) */
public HeaderAttribute(
string[] columnNames
)
JScript
public

CLSCompliantAttribute(False)
function HeaderAttribute(
ParamArrayAttribute columnNames : String[]
)

Parameters

columnNames
The names of the columns in the data source in order by index

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if columnNames or if one of the values it contains is null

See Also

HeaderAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

HeaderAttribute Properties
[image]

Public Properties

Name | Description
Public property | ColumnNames | Gets the array of column names.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

HeaderAttribute Class
MbUnit.Framework Namespace
RowAttribute
ColumnAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ColumnNames Property

HeaderAttribute.ColumnNames Property
[image]

Gets the array of column names.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnNames As String()
C#
public string[] ColumnNames { get; }
C++
public property string[] ColumnNames sealed {
array<String>^ get();
}
J#
/** property */
public string[] get_ColumnNames();
JScript
public function get ColumnNames() : String[]

See Also

HeaderAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

HeaderAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

HeaderAttribute Class
MbUnit.Framework Namespace
RowAttribute
ColumnAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PopulateDataSource Method

HeaderAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
) override
J#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected override function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

HeaderAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IgnoreAttribute Class

IgnoreAttribute Class
See Also Example Members
[image]

Indicates that a test is to be ignored by the framework and will not be run. The test will still appear in test reports along with the reason that it was ignored, if provided.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class IgnoreAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class IgnoreAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class IgnoreAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class IgnoreAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class IgnoreAttribute extends TestDecoratorPatternAttribute

Remarks

This attribute can be used to disable tests that are broken or expensive without commenting them out or removing them from the source code.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.IgnoreAttribute

See Also

IgnoreAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IgnoreAttribute Members

IgnoreAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Indicates that a test is to be ignored by the framework and will not be run. The test will still appear in test reports along with the reason that it was ignored, if provided.

The following tables list the members exposed by IgnoreAttribute.

Public Constructors

Name | Description
IgnoreAttribute | Overloaded. Initializes a new instance of the IgnoreAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Reason | Gets the reason that the test has been ignored, or an empty string if none.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
IgnoreAttribute | Overloaded. Initializes a new instance of the IgnoreAttribute class.
Top

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IgnoreAttribute Constructor

IgnoreAttribute Constructor

Initializes a new instance of the IgnoreAttribute class.

Overload List

 | Name | Description
Public method | IgnoreAttribute | Indicates that this test is to be ignored without providing a reason.
Public method | IgnoreAttribute (String) | Indicates that this test is to be ignored and provides a reason.

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IgnoreAttribute Constructor ()

IgnoreAttribute Constructor ()
See Also Example
[image]

Indicates that this test is to be ignored without providing a reason.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public IgnoreAttribute()
C++
public:
IgnoreAttribute() sealed
J#
public IgnoreAttribute()
JScript
public function IgnoreAttribute()

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace
IgnoreAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IgnoreAttribute Constructor (String)

IgnoreAttribute Constructor (String)
See Also Example
[image]

Indicates that this test is to be ignored and provides a reason.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal reason As String _
)
C#
public IgnoreAttribute(
string reason
)
C++
public:
IgnoreAttribute(
String reason
) sealed
J#
public IgnoreAttribute(
string reason
)
JScript
public function IgnoreAttribute(
reason : String
)

Parameters

reason
The reason for which the test is to be ignored

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reason is null

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace
IgnoreAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

IgnoreAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Reason | Gets the reason that the test has been ignored, or an empty string if none.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reason Property

IgnoreAttribute.Reason Property
[image]

Gets the reason that the test has been ignored, or an empty string if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reason As String
C#
public string Reason { get; }
C++
public property string Reason sealed {
String get();
}
J#
/** property */
public string get_Reason();
JScript
public function get Reason() : String

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

IgnoreAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

IgnoreAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

IgnoreAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Importance Enumeration

Importance Enumeration
[image]

Specifies the test's relative importance which can be used for classifying tests to be executed.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Enum Importance
C#
public enum Importance
C++
public enum class Importance
J#
public enum Importance
JScript
public enum Importance

Remarks

In MbUnit v2 this enum had the FlagsAttribute attribute which was pointless because the values were not binary so they could not actually be OR'ed together without loss of information.

In MbUnit v3, to indicate that a test belongs to multiple importance classes, decorate it with multiple occurrences of the ImportanceAttribute.

Members

Member Name | Description
Critical | Critical importance.
Severe | Severe importance. Less important than Critical.
Serious | Serious importance. Less important than Severe.
Default | Default importance.
NoOneReallyCaresAbout | Not important.

See Also

MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImportanceAttribute Class

ImportanceAttribute Class
See Also Example Members
[image]

Associates a Importance with a test fixture, test method, test parameter or other test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class ImportanceAttribute
Inherits MetadataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class ImportanceAttribute : MetadataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class ImportanceAttribute : MetadataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class ImportanceAttribute extends MetadataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class ImportanceAttribute extends MetadataPatternAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.ImportanceAttribute

See Also

ImportanceAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImportanceAttribute Members

ImportanceAttribute Members
See Also Example Constructors Properties Methods
[image]

Associates a Importance with a test fixture, test method, test parameter or other test component.

The following tables list the members exposed by ImportanceAttribute.

Public Constructors

 | Name | Description
Public method | ImportanceAttribute | Associates a Importance with the test component annotated by this attribute.
Top

Public Properties

Name | Description
Public property | Importance | Gets or sets the importance.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

ImportanceAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImportanceAttribute Constructor

ImportanceAttribute Constructor
[image]

Associates a Importance with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal importance As Importance _
)
C#
public ImportanceAttribute(
Importance importance
)
C++
public:
ImportanceAttribute(
Importance importance
) sealed
J#
public ImportanceAttribute(
Importance importance
)
JScript
public function ImportanceAttribute(
importance : Importance
)

Parameters

importance
The importance to associate

See Also

ImportanceAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ImportanceAttribute Properties
[image]

Public Properties

Name | Description
Public property | Importance | Gets or sets the importance.
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

ImportanceAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Importance Property

ImportanceAttribute.Importance Property
[image]

Gets or sets the importance.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Importance As Importance
C#
public Importance Importance { get; }
C++
public property Importance Importance sealed {
Importance get();
}
J#
/** property */
public Importance get_Importance();
JScript
public function get Importance() : Importance

See Also

ImportanceAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ImportanceAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

ImportanceAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

ImportanceAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata() override
J#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected override function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

ImportanceAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


JoinAttribute Class

JoinAttribute Class
See Also Example Members
[image]

An abstract class for attributes that specify the join strategy of a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public MustInherit Class JoinAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public abstract class JoinAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class JoinAttribute abstract : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class JoinAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class JoinAttribute extends PatternAttribute

Remarks

You may define a new join strategy by creating a subclass of this attribute and overriding GetJoinStrategy.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
MbUnit.Framework.JoinAttribute
MbUnit.Framework.CombinatorialJoinAttribute
MbUnit.Framework.PairwiseJoinAttribute
MbUnit.Framework.SequentialJoinAttribute

See Also

JoinAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


JoinAttribute Members

JoinAttribute Members
See Also Example Constructors Properties Methods
[image]

An abstract class for attributes that specify the join strategy of a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by JoinAttribute.

Protected Constructors

 | Name | Description
Family method | JoinAttribute | Initializes a new instance of the JoinAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

JoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


JoinAttribute Constructor

JoinAttribute Constructor
[image]

Initializes a new instance of the JoinAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected JoinAttribute()
C++
protected:
JoinAttribute() sealed
J#
protected JoinAttribute()
JScript
protected function JoinAttribute()

See Also

JoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

JoinAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

JoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetJoinStrategy Method

JoinAttribute.GetJoinStrategy Method
[image]

Gets the join strategy to use.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetJoinStrategy() As IJoinStrategy
C#
protected abstract IJoinStrategy GetJoinStrategy()
C++
protected:
IJoinStrategy GetJoinStrategy() abstract
J#
protected abstract IJoinStrategy GetJoinStrategy()
JScript
protected abstract function GetJoinStrategy() : IJoinStrategy

Return Value

The join strategy

See Also

JoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Process Method

JoinAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

JoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

JoinAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

JoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MetadataAttribute Class

MetadataAttribute Class
See Also Example Members
[image]

Associates custom metadata with a test fixture, test method, test parameter or other test component. The metadata can be used for documentation, classification or dynamic customization of tests.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class MetadataAttribute
Inherits MetadataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class MetadataAttribute : MetadataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class MetadataAttribute : MetadataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class MetadataAttribute extends MetadataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class MetadataAttribute extends MetadataPatternAttribute

Remarks

Metadata appears in the test reports and can be used for filtering. It is also accessible at runtime by inspecting the properties of the current test in the TestContext.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.MetadataAttribute

See Also

MetadataAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MetadataAttribute Members

MetadataAttribute Members
See Also Example Constructors Properties Methods
[image]

Associates custom metadata with a test fixture, test method, test parameter or other test component. The metadata can be used for documentation, classification or dynamic customization of tests.

The following tables list the members exposed by MetadataAttribute.

Public Constructors

 | Name | Description
Public method | MetadataAttribute | Associates custom metadata with a test component.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | MetadataKey | Gets the metadata key.
Public property | MetadataValue | Gets the metadata value.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MetadataAttribute Constructor

MetadataAttribute Constructor
[image]

Associates custom metadata with a test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal metadataKey As String, _
ByVal metadataValue As String _
)
C#
public MetadataAttribute(
string metadataKey,
string metadataValue
)
C++
public:
MetadataAttribute(
String metadataKey,
String metadataValue
) sealed
J#
public MetadataAttribute(
string metadataKey,
string metadataValue
)
JScript
public function MetadataAttribute(
metadataKey : String,
metadataValue : String
)

Parameters

metadataKey
The metadata key
metadataValue
The metadata value

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if metadataKey or metadataValue is null

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

MetadataAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | MetadataKey | Gets the metadata key.
Public property | MetadataValue | Gets the metadata value.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MetadataKey Property

MetadataAttribute.MetadataKey Property
[image]

Gets the metadata key.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataKey As String
C#
public string MetadataKey { get; }
C++
public property string MetadataKey sealed {
String get();
}
J#
/** property */
public string get_MetadataKey();
JScript
public function get MetadataKey() : String

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MetadataValue Property

MetadataAttribute.MetadataValue Property
[image]

Gets the metadata value.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataValue As String
C#
public string MetadataValue { get; }
C++
public property string MetadataValue sealed {
String get();
}
J#
/** property */
public string get_MetadataValue();
JScript
public function get MetadataValue() : String

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

MetadataAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

MetadataAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata() override
J#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected override function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

MetadataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MultipleAssertsAttribute Class

MultipleAssertsAttribute Class
See Also Example Members
[image]

Runs the test as if it were surrounded by Multiple so that multiple assertion failures within the test are tolerated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True), _
TestFrameworkInternalAttribute>
Public Class MultipleAssertsAttribute
Inherits TestMethodDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
[TestFrameworkInternalAttribute]
public class MultipleAssertsAttribute : TestMethodDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
[TestFrameworkInternalAttribute]
ref class MultipleAssertsAttribute : TestMethodDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
/** @attribute TestFrameworkInternalAttribute() */
public class MultipleAssertsAttribute extends TestMethodDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
TestFrameworkInternalAttribute
class MultipleAssertsAttribute extends TestMethodDecoratorPatternAttribute

Remarks

When an assertion failure occurs, it is reported but the test is allowed to proceed until it completes or throws an unhandled exception. When the test finishes, it will still be marked as failed, as usual.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.MultipleAssertsAttribute

See Also

MultipleAssertsAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MultipleAssertsAttribute Members

MultipleAssertsAttribute Members
See Also Example Constructors Properties Methods
[image]

Runs the test as if it were surrounded by Multiple so that multiple assertion failures within the test are tolerated.

The following tables list the members exposed by MultipleAssertsAttribute.

Public Constructors

 | Name | Description
Public method | MultipleAssertsAttribute | Initializes a new instance of the MultipleAssertsAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Overridden. Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

See Also

MultipleAssertsAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MultipleAssertsAttribute Constructor

MultipleAssertsAttribute Constructor
[image]

Initializes a new instance of the MultipleAssertsAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MultipleAssertsAttribute()
C++
public:
MultipleAssertsAttribute() sealed
J#
public MultipleAssertsAttribute()
JScript
public function MultipleAssertsAttribute()

See Also

MultipleAssertsAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

MultipleAssertsAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestMethodDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateMethodTest | Overridden. Applies decorations to a method-level test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodDecoratorPatternAttribute)
Top

See Also

MultipleAssertsAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateMethodTest Method

MultipleAssertsAttribute.DecorateMethodTest Method
[image]

Applies decorations to a method-level test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateMethodTest( _
ByVal methodScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
) override
J#
protected override void DecorateMethodTest(
IPatternScope methodScope,
IMethodInfo method
)
JScript
protected override function DecorateMethodTest(
methodScope : IPatternScope,
method : IMethodInfo
)

Parameters

methodScope
The method scope
method
The method

See Also

MultipleAssertsAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NameAttribute Class

NameAttribute Class
See Also Example Members
[image]

Overrides the name of a test or test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := False, Inherited := True)>
Public Class NameAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True)]
public class NameAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = False, Inherited = True)]
ref class NameAttribute : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True) */
public class NameAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True)
class NameAttribute extends PatternAttribute

Remarks

Use this attribute to specify a more descriptive or readable name than the one chosen by default by MbUnit which is usually derived from the method, class, field, property, or parameters name. The test name specified by this attribute can contain

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
MbUnit.Framework.NameAttribute

See Also

NameAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NameAttribute Members

NameAttribute Members
See Also Example Constructors Properties Methods
[image]

Overrides the name of a test or test parameter.

The following tables list the members exposed by NameAttribute.

Public Constructors

 | Name | Description
Public method | NameAttribute | Overrides the name of a test or test parameter.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Name | Gets the overridden name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


NameAttribute Constructor

NameAttribute Constructor
[image]

Overrides the name of a test or test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public NameAttribute(
string name
)
C++
public:
NameAttribute(
String name
) sealed
J#
public NameAttribute(
string name
)
JScript
public function NameAttribute(
name : String
)

Parameters

name
The overridden name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

NameAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Name | Gets the overridden name.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Name Property

NameAttribute.Name Property
[image]

Gets the overridden name.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

NameAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process Overridden.

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Process Method

NameAttribute.Process Method
[image]

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Process( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
) _
Implements IPattern.Process
C#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
public:
virtual void Process(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
public override void Process(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
public override function Process(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element to process

Implements

IPattern.Process

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

NameAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
J#
protected virtual void Validate(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected virtual function Validate(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

NameAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OldArrayAssert Class

OldArrayAssert Class
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Array Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldArrayAssert
C#
public static class OldArrayAssert
C++
ref class OldArrayAssert abstract sealed
J#
public final class OldArrayAssert
JScript
public class OldArrayAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldArrayAssert

See Also

OldArrayAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldArrayAssert Members

OldArrayAssert Members
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Array Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldArrayAssert.

Public Methods

Name | Description
AreEqual | Overloaded. Verifies that both array have the same dimension and elements.
Top

See Also

OldArrayAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldArrayAssert Methods
[image]

Public Methods

Name | Description
AreEqual | Overloaded. Verifies that both array have the same dimension and elements.
Top

See Also

OldArrayAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method

OldArrayAssert.AreEqual Method

Verifies that both array have the same dimension and elements.

Overload List

Name | Description
AreEqual (Boolean, Boolean) | Verifies that both array have the same dimension and elements.
AreEqual (Byte, Byte) |
AreEqual (Char, Char) |
AreEqual (Double, Double, Double) |
AreEqual (Int32, Int32) |
AreEqual (Int64, Int64) |
AreEqual (Object, Object) |
AreEqual (Single, Single, Single) |

See Also

OldArrayAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Boolean[], Boolean[])

OldArrayAssert.AreEqual Method (Boolean[], Boolean[])
See Also Example
[image]

Verifies that both array have the same dimension and elements.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Boolean(), _
ByVal actual As Boolean() _
)
C#
public static void AreEqual(
bool[] expected,
bool[] actual
)
C++
public:
static void AreEqual(
array<bool>^ expected,
array<bool>^ actual
)
J#
public static void AreEqual(
bool[] expected,
bool[] actual
)
JScript
public static function AreEqual(
expected : bool[],
actual : bool[]
)

Parameters

expected
actual

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Byte[], Byte[])

OldArrayAssert.AreEqual Method (Byte[], Byte[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Byte(), _
ByVal actual As Byte() _
)
C#
public static void AreEqual(
byte[] expected,
byte[] actual
)
C++
public:
static void AreEqual(
array<char>^ expected,
array<char>^ actual
)
J#
public static void AreEqual(
byte[] expected,
byte[] actual
)
JScript
public static function AreEqual(
expected : Byte[],
actual : Byte[]
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Char[], Char[])

OldArrayAssert.AreEqual Method (Char[], Char[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Char(), _
ByVal actual As Char() _
)
C#
public static void AreEqual(
char[] expected,
char[] actual
)
C++
public:
static void AreEqual(
array<wchar_t>^ expected,
array<wchar_t>^ actual
)
J#
public static void AreEqual(
char[] expected,
char[] actual
)
JScript
public static function AreEqual(
expected : char[],
actual : char[]
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Double[], Double[], Double)

OldArrayAssert.AreEqual Method (Double[], Double[], Double)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Double(), _
ByVal actual As Double(), _
ByVal delta As Double _
)
C#
public static void AreEqual(
double[] expected,
double[] actual,
double delta
)
C++
public:
static void AreEqual(
array<double>^ expected,
array<double>^ actual,
double delta
)
J#
public static void AreEqual(
double[] expected,
double[] actual,
double delta
)
JScript
public static function AreEqual(
expected : double[],
actual : double[],
delta : double
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Int32[], Int32[])

OldArrayAssert.AreEqual Method (Int32[], Int32[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Integer(), _
ByVal actual As Integer() _
)
C#
public static void AreEqual(
int[] expected,
int[] actual
)
C++
public:
static void AreEqual(
array<int>^ expected,
array<int>^ actual
)
J#
public static void AreEqual(
int[] expected,
int[] actual
)
JScript
public static function AreEqual(
expected : int[],
actual : int[]
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Int64[], Int64[])

OldArrayAssert.AreEqual Method (Int64[], Int64[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Long(), _
ByVal actual As Long() _
)
C#
public static void AreEqual(
long[] expected,
long[] actual
)
C++
public:
static void AreEqual(
array<__int64>^ expected,
array<__int64>^ actual
)
J#
public static void AreEqual(
long[] expected,
long[] actual
)
JScript
public static function AreEqual(
expected : long[],
actual : long[]
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Object[], Object[])

OldArrayAssert.AreEqual Method (Object[], Object[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Object(), _
ByVal actual As Object() _
)
C#
public static void AreEqual(
object[] expected,
object[] actual
)
C++
public:
static void AreEqual(
array<Object>^ expected,
array<Object>^ actual
)
J#
public static void AreEqual(
object[] expected,
object[] actual
)
JScript
public static function AreEqual(
expected : Object[],
actual : Object[]
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Single[], Single[], Single)

OldArrayAssert.AreEqual Method (Single[], Single[], Single)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Single(), _
ByVal actual As Single(), _
ByVal delta As Single _
)
C#
public static void AreEqual(
float[] expected,
float[] actual,
float delta
)
C++
public:
static void AreEqual(
array<float>^ expected,
array<float>^ actual,
float delta
)
J#
public static void AreEqual(
float[] expected,
float[] actual,
float delta
)
JScript
public static function AreEqual(
expected : float[],
actual : float[],
delta : float
)

See Also

OldArrayAssert Class
MbUnit.Framework Namespace
OldArrayAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldAssert Class

OldAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldAssert
C#
public static class OldAssert
C++
ref class OldAssert abstract sealed
J#
public final class OldAssert
JScript
public class OldAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldAssert

See Also

OldAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldAssert Members

OldAssert Members
See Also Example Methods
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldAssert.

Public Methods

Name | Description
AreEqual | Overloaded. Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.
AreNotEqual | Overloaded. Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.
AreNotSame | Overloaded.
AreSame | Overloaded. Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.
AreValueEqual | Verifies that the value of the property described by pi is the same in both ojects.
Between | Overloaded. Asserts that test is between left and right.
Contains
Equals | The Equals method throws an AssertionException. This is done to make sure there is no mistake by calling this function.
Fail | Overloaded. Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.
Greater | Overloaded. Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
GreaterEqualThan | Overloaded. Verifies that left is greater than right.
GreaterThan | Overloaded. Verifies that left is strictly greater than right.
In | Overloaded. Asserts that test is in the dic dic.
IncrementAssertCount
IsAssignableFrom | Overloaded. Asserts that an object may be assigned a value of a given Type.
IsEmpty | Overloaded. Assert that an array,list or other collection is empty
IsFalse | Overloaded. Asserts that a condition is false. If the condition is true the method throws an AssertionException.
IsInstanceOfType | Overloaded. Asserts that an object is an instance of a given type.
IsNaN Overloaded. Verifies that the double is passed is an
Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.
IsNotAssignableFrom | Overloaded. Asserts that an object may not be assigned a value of a given Type.
IsNotEmpty | Overloaded. Assert that an array,list or other collection is empty
IsNotInstanceOfType | Overloaded. Asserts that an object is not an instance of a given type.
IsNotNull Overloaded. Verifies that the object that is passed in is not equal to
Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.
IsNull Overloaded. Verifies that the object that is passed in is equal to
Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.
IsTrue | Overloaded. Asserts that a condition is true. If the condition is false the method throws an AssertionException.
Less | Overloaded. Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
LowerEqualThan | Overloaded. Verifies that left is strictly lower than right.
LowerThan | Overloaded. Verifies that left is strictly lower than right.
NotBetween | Overloaded. Asserts that test is not between left and right.
NotIn | Overloaded. Asserts that test is not in the dic dic.
ReferenceEquals | override the default ReferenceEquals to throw an AssertionException. This implementation makes sure there is no mistake in calling this function as part of Assert.
Warning | Overloaded.
Top

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldAssert Methods
[image]

Public Methods

Name | Description
AreEqual | Overloaded. Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.
AreNotEqual | Overloaded. Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.
AreNotSame | Overloaded.
AreSame | Overloaded. Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.
AreValueEqual | Verifies that the value of the property described by pi is the same in both ojects.
Between | Overloaded. Asserts that test is between left and right.
Contains
Equals | The Equals method throws an AssertionException. This is done to make sure there is no mistake by calling this function.
Fail | Overloaded. Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.
Greater | Overloaded. Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
GreaterEqualThan | Overloaded. Verifies that left is greater than right.
GreaterThan | Overloaded. Verifies that left is strictly greater than right.
In | Overloaded. Asserts that test is in the dic dic.
IncrementAssertCount
IsAssignableFrom | Overloaded. Asserts that an object may be assigned a value of a given Type.
IsEmpty | Overloaded. Assert that an array,list or other collection is empty
IsFalse | Overloaded. Asserts that a condition is false. If the condition is true the method throws an AssertionException.
IsInstanceOfType | Overloaded. Asserts that an object is an instance of a given type.
IsNaN Overloaded. Verifies that the double is passed is an
Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.
IsNotAssignableFrom | Overloaded. Asserts that an object may not be assigned a value of a given Type.
IsNotEmpty | Overloaded. Assert that an array,list or other collection is empty
IsNotInstanceOfType | Overloaded. Asserts that an object is not an instance of a given type.
IsNotNull Overloaded. Verifies that the object that is passed in is not equal to
Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.
IsNull Overloaded. Verifies that the object that is passed in is equal to
Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.
IsTrue | Overloaded. Asserts that a condition is true. If the condition is false the method throws an AssertionException.
Less | Overloaded. Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
LowerEqualThan | Overloaded. Verifies that left is strictly lower than right.
LowerThan | Overloaded. Verifies that left is strictly lower than right.
NotBetween | Overloaded. Asserts that test is not between left and right.
NotIn | Overloaded. Asserts that test is not in the dic dic.
ReferenceEquals | override the default ReferenceEquals to throw an AssertionException. This implementation makes sure there is no mistake in calling this function as part of Assert.
Warning | Overloaded.
Top

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method

OldAssert.AreEqual Method

Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.

Overload List

Name | Description
AreEqual (Decimal, Decimal) | Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.
AreEqual (Decimal, Decimal, String) | Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.
AreEqual (Decimal, Decimal, String, Object) | Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.
AreEqual (Double, Double, Double) | Verifies that two doubles are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.
AreEqual (Double, Double, Double, String) | Verifies that two doubles are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.
AreEqual (Int32, Int32) | Verifies that two ints are equal. If they are not equals then an AssertionException is thrown.
AreEqual (Int32, Int32, String) | Verifies that two ints are equal. If they are not equals then an AssertionException is thrown.
AreEqual (Int32, Int32, String, Object) | Verifies that two ints are equal. If they are not equals then an AssertionException is thrown.
AreEqual (Object, Object) | Verifies that two objects are equal. Two objects are considered equal if both are null, or if both have the same value. All non-numeric types are compared by using the Equals method. If they are not equal an AssertionException is thrown.
AreEqual (Object, Object, String) | Verifies that two objects are equal. Two objects are considered equal if both are null, or if both have the same value. All non-numeric types are compared by using the Equals method. If they are not equal an AssertionException is thrown.
AreEqual (Object, Object, String, Object) | Verifies that two objects are equal. Two objects are considered equal if both are null, or if both have the same value. All non-numeric types are compared by using the Equals method. If they are not equal an AssertionException is thrown.
AreEqual (Single, Single, Single) | Verifies that two floats are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.
AreEqual (Single, Single, Single, String) | Verifies that two floats are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.
AreEqual (Single, Single, Single, String, Object) |

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Decimal, Decimal)

OldAssert.AreEqual Method (Decimal, Decimal)
See Also Example
[image]

Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Decimal, _
ByVal actual As Decimal _
)
C#
public static void AreEqual(
decimal expected,
decimal actual
)
C++
public:
static void AreEqual(
decimal expected,
decimal actual
)
J#
public static void AreEqual(
decimal expected,
decimal actual
)
JScript
public static function AreEqual(
expected : Decimal,
actual : Decimal
)

Parameters

expected
The expected value
actual
The actual value

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Decimal, Decimal, String)

OldAssert.AreEqual Method (Decimal, Decimal, String)
See Also Example
[image]

Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Decimal, _
ByVal actual As Decimal, _
ByVal message As String _
)
C#
public static void AreEqual(
decimal expected,
decimal actual,
string message
)
C++
public:
static void AreEqual(
decimal expected,
decimal actual,
String message
)
J#
public static void AreEqual(
decimal expected,
decimal actual,
string message
)
JScript
public static function AreEqual(
expected : Decimal,
actual : Decimal,
message : String
)

Parameters

expected
The expected value
actual
The actual value
message
The message printed out upon failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Decimal, Decimal, String, Object[])

OldAssert.AreEqual Method (Decimal, Decimal, String, Object[])
See Also Example
[image]

Verifies that two decimals are equal. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Decimal, _
ByVal actual As Decimal, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreEqual(
decimal expected,
decimal actual,
string format,
params object[] args
)
C++
public:
static void AreEqual(
decimal expected,
decimal actual,
String format,
... array<Object>^ args
)
J#
public static void AreEqual(
decimal expected,
decimal actual,
string format,
object[] args
)
JScript
public static function AreEqual(
expected : Decimal,
actual : Decimal,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected value
actual
The actual value
format
The format of the message to display if the assertion fails, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Double, Double, Double)

OldAssert.AreEqual Method (Double, Double, Double)
See Also Example
[image]

Verifies that two doubles are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Double, _
ByVal actual As Double, _
ByVal delta As Double _
)
C#
public static void AreEqual(
double expected,
double actual,
double delta
)
C++
public:
static void AreEqual(
double expected,
double actual,
double delta
)
J#
public static void AreEqual(
double expected,
double actual,
double delta
)
JScript
public static function AreEqual(
expected : double,
actual : double,
delta : double
)

Parameters

expected
The expected value
actual
The actual value
delta
The maximum acceptable difference between the the expected and the actual

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Double, Double, Double, String)

OldAssert.AreEqual Method (Double, Double, Double, String)
See Also Example
[image]

Verifies that two doubles are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Double, _
ByVal actual As Double, _
ByVal delta As Double, _
ByVal message As String _
)
C#
public static void AreEqual(
double expected,
double actual,
double delta,
string message
)
C++
public:
static void AreEqual(
double expected,
double actual,
double delta,
String message
)
J#
public static void AreEqual(
double expected,
double actual,
double delta,
string message
)
JScript
public static function AreEqual(
expected : double,
actual : double,
delta : double,
message : String
)

Parameters

expected
The expected value
actual
The actual value
delta
The maximum acceptable difference between the the expected and the actual
message
The message printed out upon failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Int32, Int32)

OldAssert.AreEqual Method (Int32, Int32)
See Also Example
[image]

Verifies that two ints are equal. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Integer, _
ByVal actual As Integer _
)
C#
public static void AreEqual(
int expected,
int actual
)
C++
public:
static void AreEqual(
int expected,
int actual
)
J#
public static void AreEqual(
int expected,
int actual
)
JScript
public static function AreEqual(
expected : int,
actual : int
)

Parameters

expected
The expected value
actual
The actual value

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Int32, Int32, String)

OldAssert.AreEqual Method (Int32, Int32, String)
See Also Example
[image]

Verifies that two ints are equal. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Integer, _
ByVal actual As Integer, _
ByVal message As String _
)
C#
public static void AreEqual(
int expected,
int actual,
string message
)
C++
public:
static void AreEqual(
int expected,
int actual,
String message
)
J#
public static void AreEqual(
int expected,
int actual,
string message
)
JScript
public static function AreEqual(
expected : int,
actual : int,
message : String
)

Parameters

expected
The expected value
actual
The actual value
message
The message printed out upon failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Int32, Int32, String, Object[])

OldAssert.AreEqual Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that two ints are equal. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Integer, _
ByVal actual As Integer, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreEqual(
int expected,
int actual,
string format,
params object[] args
)
C++
public:
static void AreEqual(
int expected,
int actual,
String format,
... array<Object>^ args
)
J#
public static void AreEqual(
int expected,
int actual,
string format,
object[] args
)
JScript
public static function AreEqual(
expected : int,
actual : int,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected value
actual
The actual value
format
The format of the message to display if the assertion fails, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Object, Object)

OldAssert.AreEqual Method (Object, Object)
See Also Example
[image]

Verifies that two objects are equal. Two objects are considered equal if both are null, or if both have the same value. All non-numeric types are compared by using the Equals method. If they are not equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Object, _
ByVal actual As Object _
)
C#
public static void AreEqual(
object expected,
object actual
)
C++
public:
static void AreEqual(
Object expected,
Object actual
)
J#
public static void AreEqual(
object expected,
object actual
)
JScript
public static function AreEqual(
expected : Object,
actual : Object
)

Parameters

expected
The value that is expected
actual
The actual value

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Object, Object, String)

OldAssert.AreEqual Method (Object, Object, String)
See Also Example
[image]

Verifies that two objects are equal. Two objects are considered equal if both are null, or if both have the same value. All non-numeric types are compared by using the Equals method. If they are not equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void AreEqual(
object expected,
object actual,
string message
)
C++
public:
static void AreEqual(
Object expected,
Object actual,
String message
)
J#
public static void AreEqual(
object expected,
object actual,
string message
)
JScript
public static function AreEqual(
expected : Object,
actual : Object,
message : String
)

Parameters

expected
The value that is expected
actual
The actual value
message
The message to display if objects are not equal

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Object, Object, String, Object[])

OldAssert.AreEqual Method (Object, Object, String, Object[])
See Also Example
[image]

Verifies that two objects are equal. Two objects are considered equal if both are null, or if both have the same value. All non-numeric types are compared by using the Equals method. If they are not equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreEqual(
object expected,
object actual,
string format,
params object[] args
)
C++
public:
static void AreEqual(
Object expected,
Object actual,
String format,
... array<Object>^ args
)
J#
public static void AreEqual(
object expected,
object actual,
string format,
object[] args
)
JScript
public static function AreEqual(
expected : Object,
actual : Object,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The value that is expected
actual
The actual value
format
The format of the message to display if the assertion fails, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Single, Single, Single)

OldAssert.AreEqual Method (Single, Single, Single)
See Also Example
[image]

Verifies that two floats are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Single, _
ByVal actual As Single, _
ByVal delta As Single _
)
C#
public static void AreEqual(
float expected,
float actual,
float delta
)
C++
public:
static void AreEqual(
float expected,
float actual,
float delta
)
J#
public static void AreEqual(
float expected,
float actual,
float delta
)
JScript
public static function AreEqual(
expected : float,
actual : float,
delta : float
)

Parameters

expected
The expected value
actual
The actual value
delta
The maximum acceptable difference between the the expected and the actual

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Single, Single, Single, String)

OldAssert.AreEqual Method (Single, Single, Single, String)
See Also Example
[image]

Verifies that two floats are equal considering a delta. If the expected value is infinity then the delta value is ignored. If they are not equals then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Single, _
ByVal actual As Single, _
ByVal delta As Single, _
ByVal message As String _
)
C#
public static void AreEqual(
float expected,
float actual,
float delta,
string message
)
C++
public:
static void AreEqual(
float expected,
float actual,
float delta,
String message
)
J#
public static void AreEqual(
float expected,
float actual,
float delta,
string message
)
JScript
public static function AreEqual(
expected : float,
actual : float,
delta : float,
message : String
)

Parameters

expected
The expected value
actual
The actual value
delta
The maximum acceptable difference between the the expected and the actual
message
The message printed out upon failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (Single, Single, Single, String, Object[])

OldAssert.AreEqual Method (Single, Single, Single, String, Object[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As Single, _
ByVal actual As Single, _
ByVal delta As Single, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreEqual(
float expected,
float actual,
float delta,
string format,
params object[] args
)
C++
public:
static void AreEqual(
float expected,
float actual,
float delta,
String format,
... array<Object>^ args
)
J#
public static void AreEqual(
float expected,
float actual,
float delta,
string format,
object[] args
)
JScript
public static function AreEqual(
expected : float,
actual : float,
delta : float,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method

OldAssert.AreNotEqual Method

Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.

Overload List

Name | Description
AreNotEqual (Decimal, Decimal) | Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Decimal, Decimal, String) | Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Decimal, Decimal, String, Object) | Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Double, Double) | Asserts that two doubles are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Double, Double, String) | Asserts that two doubles are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Double, Double, String, Object) | Asserts that two doubles are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Int32, Int32) | Asserts that two ints are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Int32, Int32, String) | Asserts that two ints are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Int32, Int32, String, Object) | Asserts that two ints are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Object, Object) | Asserts that two objects are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Object, Object, String) | Asserts that two objects are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Object, Object, String, Object) | Asserts that two objects are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Single, Single) | Asserts that two floats are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Single, Single, String) | Asserts that two floats are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (Single, Single, String, Object) | Asserts that two floats are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (UInt32, UInt32) | Asserts that two uints are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (UInt32, UInt32, String) | Asserts that two uints are not equal. If they are equal an AssertionException is thrown.
AreNotEqual (UInt32, UInt32, String, Object) | Asserts that two uints are not equal. If they are equal an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Decimal, Decimal)

OldAssert.AreNotEqual Method (Decimal, Decimal)
See Also Example
[image]

Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Decimal, _
ByVal actual As Decimal _
)
C#
public static void AreNotEqual(
decimal expected,
decimal actual
)
C++
public:
static void AreNotEqual(
decimal expected,
decimal actual
)
J#
public static void AreNotEqual(
decimal expected,
decimal actual
)
JScript
public static function AreNotEqual(
expected : Decimal,
actual : Decimal
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Decimal, Decimal, String)

OldAssert.AreNotEqual Method (Decimal, Decimal, String)
See Also Example
[image]

Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Decimal, _
ByVal actual As Decimal, _
ByVal message As String _
)
C#
public static void AreNotEqual(
decimal expected,
decimal actual,
string message
)
C++
public:
static void AreNotEqual(
decimal expected,
decimal actual,
String message
)
J#
public static void AreNotEqual(
decimal expected,
decimal actual,
string message
)
JScript
public static function AreNotEqual(
expected : Decimal,
actual : Decimal,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the objects are the same

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Decimal, Decimal, String, Object[])

OldAssert.AreNotEqual Method (Decimal, Decimal, String, Object[])
See Also Example
[image]

Asserts that two decimals are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Decimal, _
ByVal actual As Decimal, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
decimal expected,
decimal actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
decimal expected,
decimal actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
decimal expected,
decimal actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : Decimal,
actual : Decimal,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the two objects are the same object.
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Double, Double)

OldAssert.AreNotEqual Method (Double, Double)
See Also Example
[image]

Asserts that two doubles are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Double, _
ByVal actual As Double _
)
C#
public static void AreNotEqual(
double expected,
double actual
)
C++
public:
static void AreNotEqual(
double expected,
double actual
)
J#
public static void AreNotEqual(
double expected,
double actual
)
JScript
public static function AreNotEqual(
expected : double,
actual : double
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Double, Double, String)

OldAssert.AreNotEqual Method (Double, Double, String)
See Also Example
[image]

Asserts that two doubles are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Double, _
ByVal actual As Double, _
ByVal message As String _
)
C#
public static void AreNotEqual(
double expected,
double actual,
string message
)
C++
public:
static void AreNotEqual(
double expected,
double actual,
String message
)
J#
public static void AreNotEqual(
double expected,
double actual,
string message
)
JScript
public static function AreNotEqual(
expected : double,
actual : double,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the objects are the same

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Double, Double, String, Object[])

OldAssert.AreNotEqual Method (Double, Double, String, Object[])
See Also Example
[image]

Asserts that two doubles are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Double, _
ByVal actual As Double, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
double expected,
double actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
double expected,
double actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
double expected,
double actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : double,
actual : double,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the two objects are the same object.
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Int32, Int32)

OldAssert.AreNotEqual Method (Int32, Int32)
See Also Example
[image]

Asserts that two ints are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Integer, _
ByVal actual As Integer _
)
C#
public static void AreNotEqual(
int expected,
int actual
)
C++
public:
static void AreNotEqual(
int expected,
int actual
)
J#
public static void AreNotEqual(
int expected,
int actual
)
JScript
public static function AreNotEqual(
expected : int,
actual : int
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Int32, Int32, String)

OldAssert.AreNotEqual Method (Int32, Int32, String)
See Also Example
[image]

Asserts that two ints are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Integer, _
ByVal actual As Integer, _
ByVal message As String _
)
C#
public static void AreNotEqual(
int expected,
int actual,
string message
)
C++
public:
static void AreNotEqual(
int expected,
int actual,
String message
)
J#
public static void AreNotEqual(
int expected,
int actual,
string message
)
JScript
public static function AreNotEqual(
expected : int,
actual : int,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the objects are the same

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Int32, Int32, String, Object[])

OldAssert.AreNotEqual Method (Int32, Int32, String, Object[])
See Also Example
[image]

Asserts that two ints are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Integer, _
ByVal actual As Integer, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
int expected,
int actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
int expected,
int actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
int expected,
int actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : int,
actual : int,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the two objects are the same object.
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Object, Object)

OldAssert.AreNotEqual Method (Object, Object)
See Also Example
[image]

Asserts that two objects are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Object, _
ByVal actual As Object _
)
C#
public static void AreNotEqual(
object expected,
object actual
)
C++
public:
static void AreNotEqual(
Object expected,
Object actual
)
J#
public static void AreNotEqual(
object expected,
object actual
)
JScript
public static function AreNotEqual(
expected : Object,
actual : Object
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Object, Object, String)

OldAssert.AreNotEqual Method (Object, Object, String)
See Also Example
[image]

Asserts that two objects are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void AreNotEqual(
object expected,
object actual,
string message
)
C++
public:
static void AreNotEqual(
Object expected,
Object actual,
String message
)
J#
public static void AreNotEqual(
object expected,
object actual,
string message
)
JScript
public static function AreNotEqual(
expected : Object,
actual : Object,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the objects are the same

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Object, Object, String, Object[])

OldAssert.AreNotEqual Method (Object, Object, String, Object[])
See Also Example
[image]

Asserts that two objects are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
object expected,
object actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
Object expected,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
object expected,
object actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : Object,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the two objects are the same object.
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Single, Single)

OldAssert.AreNotEqual Method (Single, Single)
See Also Example
[image]

Asserts that two floats are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Single, _
ByVal actual As Single _
)
C#
public static void AreNotEqual(
float expected,
float actual
)
C++
public:
static void AreNotEqual(
float expected,
float actual
)
J#
public static void AreNotEqual(
float expected,
float actual
)
JScript
public static function AreNotEqual(
expected : float,
actual : float
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Single, Single, String)

OldAssert.AreNotEqual Method (Single, Single, String)
See Also Example
[image]

Asserts that two floats are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Single, _
ByVal actual As Single, _
ByVal message As String _
)
C#
public static void AreNotEqual(
float expected,
float actual,
string message
)
C++
public:
static void AreNotEqual(
float expected,
float actual,
String message
)
J#
public static void AreNotEqual(
float expected,
float actual,
string message
)
JScript
public static function AreNotEqual(
expected : float,
actual : float,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the objects are the same

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (Single, Single, String, Object[])

OldAssert.AreNotEqual Method (Single, Single, String, Object[])
See Also Example
[image]

Asserts that two floats are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As Single, _
ByVal actual As Single, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
float expected,
float actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
float expected,
float actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
float expected,
float actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : float,
actual : float,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the two objects are the same object.
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (UInt32, UInt32)

OldAssert.AreNotEqual Method (UInt32, UInt32)
See Also Example
[image]

Asserts that two uints are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As UInt32, _
ByVal actual As UInt32 _
)
C#
public static void AreNotEqual(
uint expected,
uint actual
)
C++
public:
static void AreNotEqual(
unsigned int expected,
unsigned int actual
)
J#
public static void AreNotEqual(
uint expected,
uint actual
)
JScript
public static function AreNotEqual(
expected : UInt32,
actual : UInt32
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (UInt32, UInt32, String)

OldAssert.AreNotEqual Method (UInt32, UInt32, String)
See Also Example
[image]

Asserts that two uints are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As UInt32, _
ByVal actual As UInt32, _
ByVal message As String _
)
C#
public static void AreNotEqual(
uint expected,
uint actual,
string message
)
C++
public:
static void AreNotEqual(
unsigned int expected,
unsigned int actual,
String message
)
J#
public static void AreNotEqual(
uint expected,
uint actual,
string message
)
JScript
public static function AreNotEqual(
expected : UInt32,
actual : UInt32,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the objects are the same

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (UInt32, UInt32, String, Object[])

OldAssert.AreNotEqual Method (UInt32, UInt32, String, Object[])
See Also Example
[image]

Asserts that two uints are not equal. If they are equal an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As UInt32, _
ByVal actual As UInt32, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
uint expected,
uint actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
unsigned int expected,
unsigned int actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
uint expected,
uint actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : UInt32,
actual : UInt32,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be displayed when the two objects are the same object.
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotSame Method

OldAssert.AreNotSame Method

Overload List

Name | Description
AreNotSame (Object, Object) |
AreNotSame (Object, Object, String) |
AreNotSame (Object, Object, String, Object) |

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotSame Method (Object, Object)

OldAssert.AreNotSame Method (Object, Object)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotSame( _
ByVal expected As Object, _
ByVal actual As Object _
)
C#
public static void AreNotSame(
object expected,
object actual
)
C++
public:
static void AreNotSame(
Object expected,
Object actual
)
J#
public static void AreNotSame(
object expected,
object actual
)
JScript
public static function AreNotSame(
expected : Object,
actual : Object
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotSame Method (Object, Object, String)

OldAssert.AreNotSame Method (Object, Object, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotSame( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void AreNotSame(
object expected,
object actual,
string message
)
C++
public:
static void AreNotSame(
Object expected,
Object actual,
String message
)
J#
public static void AreNotSame(
object expected,
object actual,
string message
)
JScript
public static function AreNotSame(
expected : Object,
actual : Object,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotSame Method (Object, Object, String, Object[])

OldAssert.AreNotSame Method (Object, Object, String, Object[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotSame( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotSame(
object expected,
object actual,
string format,
params object[] args
)
C++
public:
static void AreNotSame(
Object expected,
Object actual,
String format,
... array<Object>^ args
)
J#
public static void AreNotSame(
object expected,
object actual,
string format,
object[] args
)
JScript
public static function AreNotSame(
expected : Object,
actual : Object,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreNotSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSame Method

OldAssert.AreSame Method

Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.

Overload List

Name | Description
AreSame (Object, Object) | Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.
AreSame (Object, Object, String) | Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.
AreSame (Object, Object, String, Object) | Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSame Method (Object, Object)

OldAssert.AreSame Method (Object, Object)
See Also Example
[image]

Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSame( _
ByVal expected As Object, _
ByVal actual As Object _
)
C#
public static void AreSame(
object expected,
object actual
)
C++
public:
static void AreSame(
Object expected,
Object actual
)
J#
public static void AreSame(
object expected,
object actual
)
JScript
public static function AreSame(
expected : Object,
actual : Object
)

Parameters

expected
The expected object
actual
The actual object

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSame Method (Object, Object, String)

OldAssert.AreSame Method (Object, Object, String)
See Also Example
[image]

Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSame( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void AreSame(
object expected,
object actual,
string message
)
C++
public:
static void AreSame(
Object expected,
Object actual,
String message
)
J#
public static void AreSame(
object expected,
object actual,
string message
)
JScript
public static function AreSame(
expected : Object,
actual : Object,
message : String
)

Parameters

expected
The expected object
actual
The actual object
message
The message to be printed when the two objects are not the same object.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSame Method (Object, Object, String, Object[])

OldAssert.AreSame Method (Object, Object, String, Object[])
See Also Example
[image]

Asserts that two objects refer to the same object. If they are not the same an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSame( _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreSame(
object expected,
object actual,
string format,
params object[] args
)
C++
public:
static void AreSame(
Object expected,
Object actual,
String format,
... array<Object>^ args
)
J#
public static void AreSame(
object expected,
object actual,
string format,
object[] args
)
JScript
public static function AreSame(
expected : Object,
actual : Object,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected object
actual
The actual object
format
The format of the message to display if the assertion fails, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.AreSame Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreValueEqual Method

OldAssert.AreValueEqual Method
[image]

Verifies that the value of the property described by pi is the same in both ojects.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreValueEqual( _
ByVal pi As PropertyInfo, _
ByVal expected As Object, _
ByVal actual As Object, _
ByVal ParamArray indices As Object() _
)
C#
public static void AreValueEqual(
PropertyInfo pi,
object expected,
object actual,
params object[] indices
)
C++
public:
static void AreValueEqual(
PropertyInfo pi,
Object expected,
Object actual,
... array<Object>^ indices
)
J#
public static void AreValueEqual(
PropertyInfo pi,
object expected,
object actual,
object[] indices
)
JScript
public static function AreValueEqual(
pi : PropertyInfo,
expected : Object,
actual : Object,
ParamArrayAttribute indices : Object[]
)

Parameters

pi
Property describing the value to test
expected
Reference object
actual
Actual object
indices
Index of the property.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method

OldAssert.Between Method

Asserts that test is between left and right.

Overload List

Name | Description
Between (Byte, Byte, Byte) | Asserts that test is between left and right.
Between (Byte, Byte, Byte, String) | Asserts that test is between left and right.
Between (Byte, Byte, Byte, String, Object) | Asserts that test is between left and right.
Between (Double, Double, Double) | Asserts that test is between left and right.
Between (Double, Double, Double, String) | Asserts that test is between left and right.
Between (Double, Double, Double, String, Object) | Asserts that test is between left and right.
Between (IComparable, IComparable, IComparable) | Asserts that test is between left and right.
Between (IComparable, IComparable, IComparable, String) | Asserts that test is between left and right.
Between (IComparable, IComparable, IComparable, String, Object) | Asserts that test is between left and right.
Between (Int16, Int16, Int16) | Asserts that test is between left and right.
Between (Int16, Int16, Int16, String) | Asserts that test is between left and right.
Between (Int16, Int16, Int16, String, Object) | Asserts that test is between left and right.
Between (Int32, Int32, Int32) | Asserts that test is between left and right.
Between (Int32, Int32, Int32, String) | Asserts that test is between left and right.
Between (Int32, Int32, Int32, String, Object) | Asserts that test is between left and right.
Between (Int64, Int64, Int64) | Asserts that test is between left and right.
Between (Int64, Int64, Int64, String) | Asserts that test is between left and right.
Between (Int64, Int64, Int64, String, Object) | Asserts that test is between left and right.
Between (Single, Single, Single) | Asserts that test is between left and right.
Between (Single, Single, Single, String) | Asserts that test is between left and right.
Between (Single, Single, Single, String, Object) | Asserts that test is between left and right.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Byte, Byte, Byte)

OldAssert.Between Method (Byte, Byte, Byte)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Byte, _
ByVal left As Byte, _
ByVal right As Byte _
)
C#
public static void Between(
byte test,
byte left,
byte right
)
C++
public:
static void Between(
char test,
char left,
char right
)
J#
public static void Between(
byte test,
byte left,
byte right
)
JScript
public static function Between(
test : Byte,
left : Byte,
right : Byte
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Byte, Byte, Byte, String)

OldAssert.Between Method (Byte, Byte, Byte, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Byte, _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal message As String _
)
C#
public static void Between(
byte test,
byte left,
byte right,
string message
)
C++
public:
static void Between(
char test,
char left,
char right,
String message
)
J#
public static void Between(
byte test,
byte left,
byte right,
string message
)
JScript
public static function Between(
test : Byte,
left : Byte,
right : Byte,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Byte, Byte, Byte, String, Object[])

OldAssert.Between Method (Byte, Byte, Byte, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Byte, _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
byte test,
byte left,
byte right,
string format,
params object[] args
)
C++
public:
static void Between(
char test,
char left,
char right,
String format,
... array<Object>^ args
)
J#
public static void Between(
byte test,
byte left,
byte right,
string format,
object[] args
)
JScript
public static function Between(
test : Byte,
left : Byte,
right : Byte,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Double, Double, Double)

OldAssert.Between Method (Double, Double, Double)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Double, _
ByVal left As Double, _
ByVal right As Double _
)
C#
public static void Between(
double test,
double left,
double right
)
C++
public:
static void Between(
double test,
double left,
double right
)
J#
public static void Between(
double test,
double left,
double right
)
JScript
public static function Between(
test : double,
left : double,
right : double
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Double, Double, Double, String)

OldAssert.Between Method (Double, Double, Double, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Double, _
ByVal left As Double, _
ByVal right As Double, _
ByVal message As String _
)
C#
public static void Between(
double test,
double left,
double right,
string message
)
C++
public:
static void Between(
double test,
double left,
double right,
String message
)
J#
public static void Between(
double test,
double left,
double right,
string message
)
JScript
public static function Between(
test : double,
left : double,
right : double,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Double, Double, Double, String, Object[])

OldAssert.Between Method (Double, Double, Double, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Double, _
ByVal left As Double, _
ByVal right As Double, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
double test,
double left,
double right,
string format,
params object[] args
)
C++
public:
static void Between(
double test,
double left,
double right,
String format,
... array<Object>^ args
)
J#
public static void Between(
double test,
double left,
double right,
string format,
object[] args
)
JScript
public static function Between(
test : double,
left : double,
right : double,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (IComparable, IComparable, IComparable)

OldAssert.Between Method (IComparable, IComparable, IComparable)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As IComparable, _
ByVal left As IComparable, _
ByVal right As IComparable _
)
C#
public static void Between(
IComparable test,
IComparable left,
IComparable right
)
C++
public:
static void Between(
IComparable test,
IComparable left,
IComparable right
)
J#
public static void Between(
IComparable test,
IComparable left,
IComparable right
)
JScript
public static function Between(
test : IComparable,
left : IComparable,
right : IComparable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (IComparable, IComparable, IComparable, String)

OldAssert.Between Method (IComparable, IComparable, IComparable, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As IComparable, _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal message As String _
)
C#
public static void Between(
IComparable test,
IComparable left,
IComparable right,
string message
)
C++
public:
static void Between(
IComparable test,
IComparable left,
IComparable right,
String message
)
J#
public static void Between(
IComparable test,
IComparable left,
IComparable right,
string message
)
JScript
public static function Between(
test : IComparable,
left : IComparable,
right : IComparable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (IComparable, IComparable, IComparable, String, Object[])

OldAssert.Between Method (IComparable, IComparable, IComparable, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As IComparable, _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
IComparable test,
IComparable left,
IComparable right,
string format,
params object[] args
)
C++
public:
static void Between(
IComparable test,
IComparable left,
IComparable right,
String format,
... array<Object>^ args
)
J#
public static void Between(
IComparable test,
IComparable left,
IComparable right,
string format,
object[] args
)
JScript
public static function Between(
test : IComparable,
left : IComparable,
right : IComparable,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int16, Int16, Int16)

OldAssert.Between Method (Int16, Int16, Int16)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Short, _
ByVal left As Short, _
ByVal right As Short _
)
C#
public static void Between(
short test,
short left,
short right
)
C++
public:
static void Between(
short test,
short left,
short right
)
J#
public static void Between(
short test,
short left,
short right
)
JScript
public static function Between(
test : short,
left : short,
right : short
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int16, Int16, Int16, String)

OldAssert.Between Method (Int16, Int16, Int16, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Short, _
ByVal left As Short, _
ByVal right As Short, _
ByVal message As String _
)
C#
public static void Between(
short test,
short left,
short right,
string message
)
C++
public:
static void Between(
short test,
short left,
short right,
String message
)
J#
public static void Between(
short test,
short left,
short right,
string message
)
JScript
public static function Between(
test : short,
left : short,
right : short,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int16, Int16, Int16, String, Object[])

OldAssert.Between Method (Int16, Int16, Int16, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Short, _
ByVal left As Short, _
ByVal right As Short, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
short test,
short left,
short right,
string format,
params object[] args
)
C++
public:
static void Between(
short test,
short left,
short right,
String format,
... array<Object>^ args
)
J#
public static void Between(
short test,
short left,
short right,
string format,
object[] args
)
JScript
public static function Between(
test : short,
left : short,
right : short,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int32, Int32, Int32)

OldAssert.Between Method (Int32, Int32, Int32)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Integer, _
ByVal left As Integer, _
ByVal right As Integer _
)
C#
public static void Between(
int test,
int left,
int right
)
C++
public:
static void Between(
int test,
int left,
int right
)
J#
public static void Between(
int test,
int left,
int right
)
JScript
public static function Between(
test : int,
left : int,
right : int
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int32, Int32, Int32, String)

OldAssert.Between Method (Int32, Int32, Int32, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Integer, _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal message As String _
)
C#
public static void Between(
int test,
int left,
int right,
string message
)
C++
public:
static void Between(
int test,
int left,
int right,
String message
)
J#
public static void Between(
int test,
int left,
int right,
string message
)
JScript
public static function Between(
test : int,
left : int,
right : int,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int32, Int32, Int32, String, Object[])

OldAssert.Between Method (Int32, Int32, Int32, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Integer, _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
int test,
int left,
int right,
string format,
params object[] args
)
C++
public:
static void Between(
int test,
int left,
int right,
String format,
... array<Object>^ args
)
J#
public static void Between(
int test,
int left,
int right,
string format,
object[] args
)
JScript
public static function Between(
test : int,
left : int,
right : int,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int64, Int64, Int64)

OldAssert.Between Method (Int64, Int64, Int64)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Long, _
ByVal left As Long, _
ByVal right As Long _
)
C#
public static void Between(
long test,
long left,
long right
)
C++
public:
static void Between(
__int64 test,
__int64 left,
__int64 right
)
J#
public static void Between(
long test,
long left,
long right
)
JScript
public static function Between(
test : long,
left : long,
right : long
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int64, Int64, Int64, String)

OldAssert.Between Method (Int64, Int64, Int64, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Long, _
ByVal left As Long, _
ByVal right As Long, _
ByVal message As String _
)
C#
public static void Between(
long test,
long left,
long right,
string message
)
C++
public:
static void Between(
__int64 test,
__int64 left,
__int64 right,
String message
)
J#
public static void Between(
long test,
long left,
long right,
string message
)
JScript
public static function Between(
test : long,
left : long,
right : long,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Int64, Int64, Int64, String, Object[])

OldAssert.Between Method (Int64, Int64, Int64, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Long, _
ByVal left As Long, _
ByVal right As Long, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
long test,
long left,
long right,
string format,
params object[] args
)
C++
public:
static void Between(
__int64 test,
__int64 left,
__int64 right,
String format,
... array<Object>^ args
)
J#
public static void Between(
long test,
long left,
long right,
string format,
object[] args
)
JScript
public static function Between(
test : long,
left : long,
right : long,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Single, Single, Single)

OldAssert.Between Method (Single, Single, Single)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Single, _
ByVal left As Single, _
ByVal right As Single _
)
C#
public static void Between(
float test,
float left,
float right
)
C++
public:
static void Between(
float test,
float left,
float right
)
J#
public static void Between(
float test,
float left,
float right
)
JScript
public static function Between(
test : float,
left : float,
right : float
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Single, Single, Single, String)

OldAssert.Between Method (Single, Single, Single, String)
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Single, _
ByVal left As Single, _
ByVal right As Single, _
ByVal message As String _
)
C#
public static void Between(
float test,
float left,
float right,
string message
)
C++
public:
static void Between(
float test,
float left,
float right,
String message
)
J#
public static void Between(
float test,
float left,
float right,
string message
)
JScript
public static function Between(
test : float,
left : float,
right : float,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Between Method (Single, Single, Single, String, Object[])

OldAssert.Between Method (Single, Single, Single, String, Object[])
See Also Example
[image]

Asserts that test is between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Between( _
ByVal test As Single, _
ByVal left As Single, _
ByVal right As Single, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Between(
float test,
float left,
float right,
string format,
params object[] args
)
C++
public:
static void Between(
float test,
float left,
float right,
String format,
... array<Object>^ args
)
J#
public static void Between(
float test,
float left,
float right,
string format,
object[] args
)
JScript
public static function Between(
test : float,
left : float,
right : float,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Between Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Contains Method

OldAssert.Contains Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal s As String, _
ByVal contain As String _
)
C#
public static void Contains(
string s,
string contain
)
C++
public:
static void Contains(
String s,
String contain
)
J#
public static void Contains(
string s,
string contain
)
JScript
public static function Contains(
s : String,
contain : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Equals Method

OldAssert.Equals Method
[image]

The Equals method throws an AssertionException. This is done to make sure there is no mistake by calling this function.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Shared Sub Equals( _
ByVal a As Object, _
ByVal b As Object _
)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public static void Equals(
object a,
object b
)
C++
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public:
static void Equals(
Object a,
Object b
)
J#
/** @attribute EditorBrowsableAttribute(EditorBrowsableState.Never) */
public static void Equals(
object a,
object b
)
JScript
public static

EditorBrowsableAttribute(EditorBrowsableState.Never)
function Equals(
a : Object,
b : Object
)

Parameters

a
b

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Fail Method

OldAssert.Fail Method

Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.

Overload List

Name | Description
Fail | Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.
Fail (String) | Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.
Fail (String, Object) | Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Fail Method ()

OldAssert.Fail Method ()
See Also Example
[image]

Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Fail()
C#
public static void Fail()
C++
public:
static void Fail()
J#
public static void Fail()
JScript
public static function Fail()

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Fail Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Fail Method (String)

OldAssert.Fail Method (String)
See Also Example
[image]

Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Fail( _
ByVal message As String _
)
C#
public static void Fail(
string message
)
C++
public:
static void Fail(
String message
)
J#
public static void Fail(
string message
)
JScript
public static function Fail(
message : String
)

Parameters

message
The message to initialize the AssertionException with.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Fail Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Fail Method (String, Object[])

OldAssert.Fail Method (String, Object[])
See Also Example
[image]

Throws an AssertionException with the message that is passed in. This is used by the other Assert functions.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Fail( _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Fail(
string format,
params object[] args
)
C++
public:
static void Fail(
String format,
... array<Object>^ args
)
J#
public static void Fail(
string format,
object[] args
)
JScript
public static function Fail(
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

format
The format of the message to initialize the AssertionException with.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Fail Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method

OldAssert.Greater Method

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Overload List

Name | Description
Greater (Decimal, Decimal) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Decimal, Decimal, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Decimal, Decimal, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Double, Double) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Double, Double, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Double, Double, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (IComparable, IComparable) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (IComparable, IComparable, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (IComparable, IComparable, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Int32, Int32) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Int32, Int32, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Int32, Int32, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Int64, Int64) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Int64, Int64, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Int64, Int64, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Single, Single) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Single, Single, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (Single, Single, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (UInt32, UInt32) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (UInt32, UInt32, String) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.
Greater (UInt32, UInt32, String, Object) | Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Decimal, Decimal)

OldAssert.Greater Method (Decimal, Decimal)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Decimal, _
ByVal arg2 As Decimal _
)
C#
public static void Greater(
decimal arg1,
decimal arg2
)
C++
public:
static void Greater(
decimal arg1,
decimal arg2
)
J#
public static void Greater(
decimal arg1,
decimal arg2
)
JScript
public static function Greater(
arg1 : Decimal,
arg2 : Decimal
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Decimal, Decimal, String)

OldAssert.Greater Method (Decimal, Decimal, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Decimal, _
ByVal arg2 As Decimal, _
ByVal message As String _
)
C#
public static void Greater(
decimal arg1,
decimal arg2,
string message
)
C++
public:
static void Greater(
decimal arg1,
decimal arg2,
String message
)
J#
public static void Greater(
decimal arg1,
decimal arg2,
string message
)
JScript
public static function Greater(
arg1 : Decimal,
arg2 : Decimal,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Decimal, Decimal, String, Object[])

OldAssert.Greater Method (Decimal, Decimal, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Decimal, _
ByVal arg2 As Decimal, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
decimal arg1,
decimal arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
decimal arg1,
decimal arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
decimal arg1,
decimal arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : Decimal,
arg2 : Decimal,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Double, Double)

OldAssert.Greater Method (Double, Double)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Double, _
ByVal arg2 As Double _
)
C#
public static void Greater(
double arg1,
double arg2
)
C++
public:
static void Greater(
double arg1,
double arg2
)
J#
public static void Greater(
double arg1,
double arg2
)
JScript
public static function Greater(
arg1 : double,
arg2 : double
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Double, Double, String)

OldAssert.Greater Method (Double, Double, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Double, _
ByVal arg2 As Double, _
ByVal message As String _
)
C#
public static void Greater(
double arg1,
double arg2,
string message
)
C++
public:
static void Greater(
double arg1,
double arg2,
String message
)
J#
public static void Greater(
double arg1,
double arg2,
string message
)
JScript
public static function Greater(
arg1 : double,
arg2 : double,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Double, Double, String, Object[])

OldAssert.Greater Method (Double, Double, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Double, _
ByVal arg2 As Double, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
double arg1,
double arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
double arg1,
double arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
double arg1,
double arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : double,
arg2 : double,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (IComparable, IComparable)

OldAssert.Greater Method (IComparable, IComparable)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As IComparable, _
ByVal arg2 As IComparable _
)
C#
public static void Greater(
IComparable arg1,
IComparable arg2
)
C++
public:
static void Greater(
IComparable arg1,
IComparable arg2
)
J#
public static void Greater(
IComparable arg1,
IComparable arg2
)
JScript
public static function Greater(
arg1 : IComparable,
arg2 : IComparable
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (IComparable, IComparable, String)

OldAssert.Greater Method (IComparable, IComparable, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As IComparable, _
ByVal arg2 As IComparable, _
ByVal message As String _
)
C#
public static void Greater(
IComparable arg1,
IComparable arg2,
string message
)
C++
public:
static void Greater(
IComparable arg1,
IComparable arg2,
String message
)
J#
public static void Greater(
IComparable arg1,
IComparable arg2,
string message
)
JScript
public static function Greater(
arg1 : IComparable,
arg2 : IComparable,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (IComparable, IComparable, String, Object[])

OldAssert.Greater Method (IComparable, IComparable, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As IComparable, _
ByVal arg2 As IComparable, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
IComparable arg1,
IComparable arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
IComparable arg1,
IComparable arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
IComparable arg1,
IComparable arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : IComparable,
arg2 : IComparable,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Int32, Int32)

OldAssert.Greater Method (Int32, Int32)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Integer, _
ByVal arg2 As Integer _
)
C#
public static void Greater(
int arg1,
int arg2
)
C++
public:
static void Greater(
int arg1,
int arg2
)
J#
public static void Greater(
int arg1,
int arg2
)
JScript
public static function Greater(
arg1 : int,
arg2 : int
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Int32, Int32, String)

OldAssert.Greater Method (Int32, Int32, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Integer, _
ByVal arg2 As Integer, _
ByVal message As String _
)
C#
public static void Greater(
int arg1,
int arg2,
string message
)
C++
public:
static void Greater(
int arg1,
int arg2,
String message
)
J#
public static void Greater(
int arg1,
int arg2,
string message
)
JScript
public static function Greater(
arg1 : int,
arg2 : int,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Int32, Int32, String, Object[])

OldAssert.Greater Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Integer, _
ByVal arg2 As Integer, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
int arg1,
int arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
int arg1,
int arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
int arg1,
int arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : int,
arg2 : int,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Int64, Int64)

OldAssert.Greater Method (Int64, Int64)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Long, _
ByVal arg2 As Long _
)
C#
public static void Greater(
long arg1,
long arg2
)
C++
public:
static void Greater(
__int64 arg1,
__int64 arg2
)
J#
public static void Greater(
long arg1,
long arg2
)
JScript
public static function Greater(
arg1 : long,
arg2 : long
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Int64, Int64, String)

OldAssert.Greater Method (Int64, Int64, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Long, _
ByVal arg2 As Long, _
ByVal message As String _
)
C#
public static void Greater(
long arg1,
long arg2,
string message
)
C++
public:
static void Greater(
__int64 arg1,
__int64 arg2,
String message
)
J#
public static void Greater(
long arg1,
long arg2,
string message
)
JScript
public static function Greater(
arg1 : long,
arg2 : long,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Int64, Int64, String, Object[])

OldAssert.Greater Method (Int64, Int64, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Long, _
ByVal arg2 As Long, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
long arg1,
long arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
__int64 arg1,
__int64 arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
long arg1,
long arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : long,
arg2 : long,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Single, Single)

OldAssert.Greater Method (Single, Single)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Single, _
ByVal arg2 As Single _
)
C#
public static void Greater(
float arg1,
float arg2
)
C++
public:
static void Greater(
float arg1,
float arg2
)
J#
public static void Greater(
float arg1,
float arg2
)
JScript
public static function Greater(
arg1 : float,
arg2 : float
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Single, Single, String)

OldAssert.Greater Method (Single, Single, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Single, _
ByVal arg2 As Single, _
ByVal message As String _
)
C#
public static void Greater(
float arg1,
float arg2,
string message
)
C++
public:
static void Greater(
float arg1,
float arg2,
String message
)
J#
public static void Greater(
float arg1,
float arg2,
string message
)
JScript
public static function Greater(
arg1 : float,
arg2 : float,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (Single, Single, String, Object[])

OldAssert.Greater Method (Single, Single, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As Single, _
ByVal arg2 As Single, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
float arg1,
float arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
float arg1,
float arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
float arg1,
float arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : float,
arg2 : float,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (UInt32, UInt32)

OldAssert.Greater Method (UInt32, UInt32)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As UInt32, _
ByVal arg2 As UInt32 _
)
C#
public static void Greater(
uint arg1,
uint arg2
)
C++
public:
static void Greater(
unsigned int arg1,
unsigned int arg2
)
J#
public static void Greater(
uint arg1,
uint arg2
)
JScript
public static function Greater(
arg1 : UInt32,
arg2 : UInt32
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (UInt32, UInt32, String)

OldAssert.Greater Method (UInt32, UInt32, String)
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As UInt32, _
ByVal arg2 As UInt32, _
ByVal message As String _
)
C#
public static void Greater(
uint arg1,
uint arg2,
string message
)
C++
public:
static void Greater(
unsigned int arg1,
unsigned int arg2,
String message
)
J#
public static void Greater(
uint arg1,
uint arg2,
string message
)
JScript
public static function Greater(
arg1 : UInt32,
arg2 : UInt32,
message : String
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Greater Method (UInt32, UInt32, String, Object[])

OldAssert.Greater Method (UInt32, UInt32, String, Object[])
See Also Example
[image]

Verifies that the first value is greater than the second value. If they are not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Greater( _
ByVal arg1 As UInt32, _
ByVal arg2 As UInt32, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Greater(
uint arg1,
uint arg2,
string message,
params object[] args
)
C++
public:
static void Greater(
unsigned int arg1,
unsigned int arg2,
String message,
... array<Object>^ args
)
J#
public static void Greater(
uint arg1,
uint arg2,
string message,
object[] args
)
JScript
public static function Greater(
arg1 : UInt32,
arg2 : UInt32,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be greater
arg2
The second value, expected to be less
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Greater Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method

OldAssert.GreaterEqualThan Method

Verifies that left is greater than right.

Overload List

Name | Description
GreaterEqualThan (Byte, Byte) | Verifies that left is greater than right.
GreaterEqualThan (Byte, Byte, String) | Verifies that left is greater than right.
GreaterEqualThan (Byte, Byte, String, Object) | Verifies that left is greater than right.
GreaterEqualThan (Double, Double) | Verifies that left is greater than right.
GreaterEqualThan (Double, Double, String) | Verifies that left is greater than right.
GreaterEqualThan (Double, Double, String, Object) | Verifies that left is greater than right.
GreaterEqualThan (IComparable, IComparable) | Verifies that left is strictly greater than right.
GreaterEqualThan (IComparable, IComparable, String) | Verifies that left is strictly greater than right.
GreaterEqualThan (IComparable, IComparable, String, Object) | Verifies that left is strictly greater than right.
GreaterEqualThan (Int16, Int16) | Verifies that left is greater than right.
GreaterEqualThan (Int16, Int16, String) | Verifies that left is greater than right.
GreaterEqualThan (Int16, Int16, String, Object) | Verifies that left is greater than right.
GreaterEqualThan (Int32, Int32) | Verifies that left is greater than right.
GreaterEqualThan (Int32, Int32, String) | Verifies that left is greater than right.
GreaterEqualThan (Int32, Int32, String, Object) | Verifies that left is greater than right.
GreaterEqualThan (Int64, Int64) | Verifies that left is greater than right.
GreaterEqualThan (Int64, Int64, String) | Verifies that left is greater than right.
GreaterEqualThan (Int64, Int64, String, Object) | Verifies that left is greater than right.
GreaterEqualThan (Single, Single) | Verifies that left is greater than right.
GreaterEqualThan (Single, Single, String) | Verifies that left is greater than right.
GreaterEqualThan (Single, Single, String, Object) | Verifies that left is greater than right.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Byte, Byte)

OldAssert.GreaterEqualThan Method (Byte, Byte)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Byte, _
ByVal right As Byte _
)
C#
public static void GreaterEqualThan(
byte left,
byte right
)
C++
public:
static void GreaterEqualThan(
char left,
char right
)
J#
public static void GreaterEqualThan(
byte left,
byte right
)
JScript
public static function GreaterEqualThan(
left : Byte,
right : Byte
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Byte, Byte, String)

OldAssert.GreaterEqualThan Method (Byte, Byte, String)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
byte left,
byte right,
string message
)
C++
public:
static void GreaterEqualThan(
char left,
char right,
String message
)
J#
public static void GreaterEqualThan(
byte left,
byte right,
string message
)
JScript
public static function GreaterEqualThan(
left : Byte,
right : Byte,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Byte, Byte, String, Object[])

OldAssert.GreaterEqualThan Method (Byte, Byte, String, Object[])
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
byte left,
byte right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
char left,
char right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
byte left,
byte right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : Byte,
right : Byte,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Double, Double)

OldAssert.GreaterEqualThan Method (Double, Double)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Double, _
ByVal right As Double _
)
C#
public static void GreaterEqualThan(
double left,
double right
)
C++
public:
static void GreaterEqualThan(
double left,
double right
)
J#
public static void GreaterEqualThan(
double left,
double right
)
JScript
public static function GreaterEqualThan(
left : double,
right : double
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Double, Double, String)

OldAssert.GreaterEqualThan Method (Double, Double, String)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
double left,
double right,
string message
)
C++
public:
static void GreaterEqualThan(
double left,
double right,
String message
)
J#
public static void GreaterEqualThan(
double left,
double right,
string message
)
JScript
public static function GreaterEqualThan(
left : double,
right : double,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Double, Double, String, Object[])

OldAssert.GreaterEqualThan Method (Double, Double, String, Object[])
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
double left,
double right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
double left,
double right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
double left,
double right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : double,
right : double,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (IComparable, IComparable)

OldAssert.GreaterEqualThan Method (IComparable, IComparable)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As IComparable, _
ByVal right As IComparable _
)
C#
public static void GreaterEqualThan(
IComparable left,
IComparable right
)
C++
public:
static void GreaterEqualThan(
IComparable left,
IComparable right
)
J#
public static void GreaterEqualThan(
IComparable left,
IComparable right
)
JScript
public static function GreaterEqualThan(
left : IComparable,
right : IComparable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (IComparable, IComparable, String)

OldAssert.GreaterEqualThan Method (IComparable, IComparable, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
IComparable left,
IComparable right,
string message
)
C++
public:
static void GreaterEqualThan(
IComparable left,
IComparable right,
String message
)
J#
public static void GreaterEqualThan(
IComparable left,
IComparable right,
string message
)
JScript
public static function GreaterEqualThan(
left : IComparable,
right : IComparable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (IComparable, IComparable, String, Object[])

OldAssert.GreaterEqualThan Method (IComparable, IComparable, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
IComparable left,
IComparable right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
IComparable left,
IComparable right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
IComparable left,
IComparable right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : IComparable,
right : IComparable,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int16, Int16)

OldAssert.GreaterEqualThan Method (Int16, Int16)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Short, _
ByVal right As Short _
)
C#
public static void GreaterEqualThan(
short left,
short right
)
C++
public:
static void GreaterEqualThan(
short left,
short right
)
J#
public static void GreaterEqualThan(
short left,
short right
)
JScript
public static function GreaterEqualThan(
left : short,
right : short
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int16, Int16, String)

OldAssert.GreaterEqualThan Method (Int16, Int16, String)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
short left,
short right,
string message
)
C++
public:
static void GreaterEqualThan(
short left,
short right,
String message
)
J#
public static void GreaterEqualThan(
short left,
short right,
string message
)
JScript
public static function GreaterEqualThan(
left : short,
right : short,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int16, Int16, String, Object[])

OldAssert.GreaterEqualThan Method (Int16, Int16, String, Object[])
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
short left,
short right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
short left,
short right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
short left,
short right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : short,
right : short,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int32, Int32)

OldAssert.GreaterEqualThan Method (Int32, Int32)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Integer, _
ByVal right As Integer _
)
C#
public static void GreaterEqualThan(
int left,
int right
)
C++
public:
static void GreaterEqualThan(
int left,
int right
)
J#
public static void GreaterEqualThan(
int left,
int right
)
JScript
public static function GreaterEqualThan(
left : int,
right : int
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int32, Int32, String)

OldAssert.GreaterEqualThan Method (Int32, Int32, String)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
int left,
int right,
string message
)
C++
public:
static void GreaterEqualThan(
int left,
int right,
String message
)
J#
public static void GreaterEqualThan(
int left,
int right,
string message
)
JScript
public static function GreaterEqualThan(
left : int,
right : int,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int32, Int32, String, Object[])

OldAssert.GreaterEqualThan Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
int left,
int right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
int left,
int right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
int left,
int right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : int,
right : int,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int64, Int64)

OldAssert.GreaterEqualThan Method (Int64, Int64)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Long, _
ByVal right As Long _
)
C#
public static void GreaterEqualThan(
long left,
long right
)
C++
public:
static void GreaterEqualThan(
__int64 left,
__int64 right
)
J#
public static void GreaterEqualThan(
long left,
long right
)
JScript
public static function GreaterEqualThan(
left : long,
right : long
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int64, Int64, String)

OldAssert.GreaterEqualThan Method (Int64, Int64, String)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
long left,
long right,
string message
)
C++
public:
static void GreaterEqualThan(
__int64 left,
__int64 right,
String message
)
J#
public static void GreaterEqualThan(
long left,
long right,
string message
)
JScript
public static function GreaterEqualThan(
left : long,
right : long,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Int64, Int64, String, Object[])

OldAssert.GreaterEqualThan Method (Int64, Int64, String, Object[])
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
long left,
long right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
__int64 left,
__int64 right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
long left,
long right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : long,
right : long,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Single, Single)

OldAssert.GreaterEqualThan Method (Single, Single)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Single, _
ByVal right As Single _
)
C#
public static void GreaterEqualThan(
float left,
float right
)
C++
public:
static void GreaterEqualThan(
float left,
float right
)
J#
public static void GreaterEqualThan(
float left,
float right
)
JScript
public static function GreaterEqualThan(
left : float,
right : float
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Single, Single, String)

OldAssert.GreaterEqualThan Method (Single, Single, String)
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal message As String _
)
C#
public static void GreaterEqualThan(
float left,
float right,
string message
)
C++
public:
static void GreaterEqualThan(
float left,
float right,
String message
)
J#
public static void GreaterEqualThan(
float left,
float right,
string message
)
JScript
public static function GreaterEqualThan(
left : float,
right : float,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterEqualThan Method (Single, Single, String, Object[])

OldAssert.GreaterEqualThan Method (Single, Single, String, Object[])
See Also Example
[image]

Verifies that left is greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterEqualThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterEqualThan(
float left,
float right,
string format,
params object[] args
)
C++
public:
static void GreaterEqualThan(
float left,
float right,
String format,
... array<Object>^ args
)
J#
public static void GreaterEqualThan(
float left,
float right,
string format,
object[] args
)
JScript
public static function GreaterEqualThan(
left : float,
right : float,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method

OldAssert.GreaterThan Method

Verifies that left is strictly greater than right.

Overload List

Name | Description
GreaterThan (Byte, Byte) | Verifies that left is strictly greater than right.
GreaterThan (Byte, Byte, String) | Verifies that left is strictly greater than right.
GreaterThan (Byte, Byte, String, Object) | Verifies that left is strictly greater than right.
GreaterThan (Double, Double) | Verifies that left is strictly greater than right.
GreaterThan (Double, Double, String) | Verifies that left is strictly greater than right.
GreaterThan (Double, Double, String, Object) | Verifies that left is strictly greater than right.
GreaterThan (IComparable, IComparable) | Verifies that left is strictly greater than right.
GreaterThan (IComparable, IComparable, String) | Verifies that left is strictly greater than right.
GreaterThan (IComparable, IComparable, String, Object) | Verifies that left is strictly greater than right.
GreaterThan (Int16, Int16) | Verifies that left is strictly greater than right.
GreaterThan (Int16, Int16, String) | Verifies that left is strictly greater than right.
GreaterThan (Int16, Int16, String, Object) | Verifies that left is strictly greater than right.
GreaterThan (Int32, Int32) | Verifies that left is strictly greater than right.
GreaterThan (Int32, Int32, String) | Verifies that left is strictly greater than right.
GreaterThan (Int32, Int32, String, Object) | Verifies that left is strictly greater than right.
GreaterThan (Int64, Int64) | Verifies that left is strictly greater than right.
GreaterThan (Int64, Int64, String) | Verifies that left is strictly greater than right.
GreaterThan (Int64, Int64, String, Object) | Verifies that left is strictly greater than right.
GreaterThan (Single, Single) | Verifies that left is strictly greater than right.
GreaterThan (Single, Single, String) | Verifies that left is strictly greater than right.
GreaterThan (Single, Single, String, Object) | Verifies that left is strictly greater than right.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Byte, Byte)

OldAssert.GreaterThan Method (Byte, Byte)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Byte, _
ByVal right As Byte _
)
C#
public static void GreaterThan(
byte left,
byte right
)
C++
public:
static void GreaterThan(
char left,
char right
)
J#
public static void GreaterThan(
byte left,
byte right
)
JScript
public static function GreaterThan(
left : Byte,
right : Byte
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Byte, Byte, String)

OldAssert.GreaterThan Method (Byte, Byte, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal message As String _
)
C#
public static void GreaterThan(
byte left,
byte right,
string message
)
C++
public:
static void GreaterThan(
char left,
char right,
String message
)
J#
public static void GreaterThan(
byte left,
byte right,
string message
)
JScript
public static function GreaterThan(
left : Byte,
right : Byte,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Byte, Byte, String, Object[])

OldAssert.GreaterThan Method (Byte, Byte, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
byte left,
byte right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
char left,
char right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
byte left,
byte right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : Byte,
right : Byte,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Double, Double)

OldAssert.GreaterThan Method (Double, Double)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Double, _
ByVal right As Double _
)
C#
public static void GreaterThan(
double left,
double right
)
C++
public:
static void GreaterThan(
double left,
double right
)
J#
public static void GreaterThan(
double left,
double right
)
JScript
public static function GreaterThan(
left : double,
right : double
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Double, Double, String)

OldAssert.GreaterThan Method (Double, Double, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal message As String _
)
C#
public static void GreaterThan(
double left,
double right,
string message
)
C++
public:
static void GreaterThan(
double left,
double right,
String message
)
J#
public static void GreaterThan(
double left,
double right,
string message
)
JScript
public static function GreaterThan(
left : double,
right : double,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Double, Double, String, Object[])

OldAssert.GreaterThan Method (Double, Double, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
double left,
double right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
double left,
double right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
double left,
double right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : double,
right : double,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (IComparable, IComparable)

OldAssert.GreaterThan Method (IComparable, IComparable)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As IComparable, _
ByVal right As IComparable _
)
C#
public static void GreaterThan(
IComparable left,
IComparable right
)
C++
public:
static void GreaterThan(
IComparable left,
IComparable right
)
J#
public static void GreaterThan(
IComparable left,
IComparable right
)
JScript
public static function GreaterThan(
left : IComparable,
right : IComparable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (IComparable, IComparable, String)

OldAssert.GreaterThan Method (IComparable, IComparable, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal message As String _
)
C#
public static void GreaterThan(
IComparable left,
IComparable right,
string message
)
C++
public:
static void GreaterThan(
IComparable left,
IComparable right,
String message
)
J#
public static void GreaterThan(
IComparable left,
IComparable right,
string message
)
JScript
public static function GreaterThan(
left : IComparable,
right : IComparable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (IComparable, IComparable, String, Object[])

OldAssert.GreaterThan Method (IComparable, IComparable, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
IComparable left,
IComparable right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
IComparable left,
IComparable right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
IComparable left,
IComparable right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : IComparable,
right : IComparable,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int16, Int16)

OldAssert.GreaterThan Method (Int16, Int16)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Short, _
ByVal right As Short _
)
C#
public static void GreaterThan(
short left,
short right
)
C++
public:
static void GreaterThan(
short left,
short right
)
J#
public static void GreaterThan(
short left,
short right
)
JScript
public static function GreaterThan(
left : short,
right : short
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int16, Int16, String)

OldAssert.GreaterThan Method (Int16, Int16, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal message As String _
)
C#
public static void GreaterThan(
short left,
short right,
string message
)
C++
public:
static void GreaterThan(
short left,
short right,
String message
)
J#
public static void GreaterThan(
short left,
short right,
string message
)
JScript
public static function GreaterThan(
left : short,
right : short,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int16, Int16, String, Object[])

OldAssert.GreaterThan Method (Int16, Int16, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
short left,
short right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
short left,
short right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
short left,
short right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : short,
right : short,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int32, Int32)

OldAssert.GreaterThan Method (Int32, Int32)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Integer, _
ByVal right As Integer _
)
C#
public static void GreaterThan(
int left,
int right
)
C++
public:
static void GreaterThan(
int left,
int right
)
J#
public static void GreaterThan(
int left,
int right
)
JScript
public static function GreaterThan(
left : int,
right : int
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int32, Int32, String)

OldAssert.GreaterThan Method (Int32, Int32, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal message As String _
)
C#
public static void GreaterThan(
int left,
int right,
string message
)
C++
public:
static void GreaterThan(
int left,
int right,
String message
)
J#
public static void GreaterThan(
int left,
int right,
string message
)
JScript
public static function GreaterThan(
left : int,
right : int,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int32, Int32, String, Object[])

OldAssert.GreaterThan Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
int left,
int right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
int left,
int right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
int left,
int right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : int,
right : int,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int64, Int64)

OldAssert.GreaterThan Method (Int64, Int64)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Long, _
ByVal right As Long _
)
C#
public static void GreaterThan(
long left,
long right
)
C++
public:
static void GreaterThan(
__int64 left,
__int64 right
)
J#
public static void GreaterThan(
long left,
long right
)
JScript
public static function GreaterThan(
left : long,
right : long
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int64, Int64, String)

OldAssert.GreaterThan Method (Int64, Int64, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal message As String _
)
C#
public static void GreaterThan(
long left,
long right,
string message
)
C++
public:
static void GreaterThan(
__int64 left,
__int64 right,
String message
)
J#
public static void GreaterThan(
long left,
long right,
string message
)
JScript
public static function GreaterThan(
left : long,
right : long,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Int64, Int64, String, Object[])

OldAssert.GreaterThan Method (Int64, Int64, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
long left,
long right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
__int64 left,
__int64 right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
long left,
long right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : long,
right : long,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Single, Single)

OldAssert.GreaterThan Method (Single, Single)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Single, _
ByVal right As Single _
)
C#
public static void GreaterThan(
float left,
float right
)
C++
public:
static void GreaterThan(
float left,
float right
)
J#
public static void GreaterThan(
float left,
float right
)
JScript
public static function GreaterThan(
left : float,
right : float
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Single, Single, String)

OldAssert.GreaterThan Method (Single, Single, String)
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal message As String _
)
C#
public static void GreaterThan(
float left,
float right,
string message
)
C++
public:
static void GreaterThan(
float left,
float right,
String message
)
J#
public static void GreaterThan(
float left,
float right,
string message
)
JScript
public static function GreaterThan(
left : float,
right : float,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GreaterThan Method (Single, Single, String, Object[])

OldAssert.GreaterThan Method (Single, Single, String, Object[])
See Also Example
[image]

Verifies that left is strictly greater than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub GreaterThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void GreaterThan(
float left,
float right,
string format,
params object[] args
)
C++
public:
static void GreaterThan(
float left,
float right,
String format,
... array<Object>^ args
)
J#
public static void GreaterThan(
float left,
float right,
string format,
object[] args
)
JScript
public static function GreaterThan(
left : float,
right : float,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.GreaterThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method

OldAssert.In Method

Asserts that test is in the dic dic.

Overload List

Name | Description
In (Object, IDictionary) | Asserts that test is in the dic dic.
In (Object, IDictionary, String) | Asserts that test is in the dic dic.
In (Object, IEnumerable) | Asserts that test is in the enumerable collection enumerable.
In (Object, IEnumerable, String) | Asserts that test is in the enumerable collection enumerable.
In (Object, IList) | Asserts that test is in the list list.
In (Object, IList, String) | Asserts that test is in the list list.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method (Object, IDictionary)

OldAssert.In Method (Object, IDictionary)
See Also Example
[image]

Asserts that test is in the dic dic.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub In( _
ByVal test As Object, _
ByVal dic As IDictionary _
)
C#
public static void In(
object test,
IDictionary dic
)
C++
public:
static void In(
Object test,
IDictionary dic
)
J#
public static void In(
object test,
IDictionary dic
)
JScript
public static function In(
test : Object,
dic : IDictionary
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.In Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method (Object, IDictionary, String)

OldAssert.In Method (Object, IDictionary, String)
See Also Example
[image]

Asserts that test is in the dic dic.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub In( _
ByVal test As Object, _
ByVal dic As IDictionary, _
ByVal message As String _
)
C#
public static void In(
object test,
IDictionary dic,
string message
)
C++
public:
static void In(
Object test,
IDictionary dic,
String message
)
J#
public static void In(
object test,
IDictionary dic,
string message
)
JScript
public static function In(
test : Object,
dic : IDictionary,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.In Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method (Object, IEnumerable)

OldAssert.In Method (Object, IEnumerable)
See Also Example
[image]

Asserts that test is in the enumerable collection enumerable.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub In( _
ByVal test As Object, _
ByVal enumerable As IEnumerable _
)
C#
public static void In(
object test,
IEnumerable enumerable
)
C++
public:
static void In(
Object test,
IEnumerable enumerable
)
J#
public static void In(
object test,
IEnumerable enumerable
)
JScript
public static function In(
test : Object,
enumerable : IEnumerable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.In Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method (Object, IEnumerable, String)

OldAssert.In Method (Object, IEnumerable, String)
See Also Example
[image]

Asserts that test is in the enumerable collection enumerable.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub In( _
ByVal test As Object, _
ByVal enumerable As IEnumerable, _
ByVal message As String _
)
C#
public static void In(
object test,
IEnumerable enumerable,
string message
)
C++
public:
static void In(
Object test,
IEnumerable enumerable,
String message
)
J#
public static void In(
object test,
IEnumerable enumerable,
string message
)
JScript
public static function In(
test : Object,
enumerable : IEnumerable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.In Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method (Object, IList)

OldAssert.In Method (Object, IList)
See Also Example
[image]

Asserts that test is in the list list.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub In( _
ByVal test As Object, _
ByVal list As IList _
)
C#
public static void In(
object test,
IList list
)
C++
public:
static void In(
Object test,
IList list
)
J#
public static void In(
object test,
IList list
)
JScript
public static function In(
test : Object,
list : IList
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.In Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


In Method (Object, IList, String)

OldAssert.In Method (Object, IList, String)
See Also Example
[image]

Asserts that test is in the list list.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub In( _
ByVal test As Object, _
ByVal list As IList, _
ByVal message As String _
)
C#
public static void In(
object test,
IList list,
string message
)
C++
public:
static void In(
Object test,
IList list,
String message
)
J#
public static void In(
object test,
IList list,
string message
)
JScript
public static function In(
test : Object,
list : IList,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.In Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IncrementAssertCount Method

OldAssert.IncrementAssertCount Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IncrementAssertCount()
C#
public static void IncrementAssertCount()
C++
public:
static void IncrementAssertCount()
J#
public static void IncrementAssertCount()
JScript
public static function IncrementAssertCount()

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsAssignableFrom Method

OldAssert.IsAssignableFrom Method

Asserts that an object may be assigned a value of a given Type.

Overload List

Name | Description
IsAssignableFrom (Type, Object) | Asserts that an object may be assigned a value of a given Type.
IsAssignableFrom (Type, Object, String) | Asserts that an object may be assigned a value of a given Type.
IsAssignableFrom (Type, Object, String, Object) | Asserts that an object may be assigned a value of a given Type.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsAssignableFrom Method (Type, Object)

OldAssert.IsAssignableFrom Method (Type, Object)
See Also Example
[image]

Asserts that an object may be assigned a value of a given Type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom( _
ByVal expected As Type, _
ByVal actual As Object _
)
C#
public static void IsAssignableFrom(
Type expected,
object actual
)
C++
public:
static void IsAssignableFrom(
Type expected,
Object actual
)
J#
public static void IsAssignableFrom(
Type expected,
object actual
)
JScript
public static function IsAssignableFrom(
expected : Type,
actual : Object
)

Parameters

expected
The expected Type.
actual
The object under examination

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsAssignableFrom Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsAssignableFrom Method (Type, Object, String)

OldAssert.IsAssignableFrom Method (Type, Object, String)
See Also Example
[image]

Asserts that an object may be assigned a value of a given Type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void IsAssignableFrom(
Type expected,
object actual,
string message
)
C++
public:
static void IsAssignableFrom(
Type expected,
Object actual,
String message
)
J#
public static void IsAssignableFrom(
Type expected,
object actual,
string message
)
JScript
public static function IsAssignableFrom(
expected : Type,
actual : Object,
message : String
)

Parameters

expected
The expected Type.
actual
The object under examination
message
The messge to display in case of failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsAssignableFrom Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsAssignableFrom Method (Type, Object, String, Object[])

OldAssert.IsAssignableFrom Method (Type, Object, String, Object[])
See Also Example
[image]

Asserts that an object may be assigned a value of a given Type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsAssignableFrom(
Type expected,
object actual,
string message,
params object[] args
)
C++
public:
static void IsAssignableFrom(
Type expected,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void IsAssignableFrom(
Type expected,
object actual,
string message,
object[] args
)
JScript
public static function IsAssignableFrom(
expected : Type,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected Type.
actual
The object under examination
message
The message to display in case of failure
args
Array of objects to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsAssignableFrom Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method

OldAssert.IsEmpty Method

Assert that an array,list or other collection is empty

Overload List

Name | Description
IsEmpty (ICollection) | Assert that an array,list or other collection is empty
IsEmpty (ICollection, String) | Assert that an array, list or other collection is empty
IsEmpty (ICollection, String, Object) | Assert that an array, list or other collection is empty
IsEmpty (String) | Assert that a string is empty - that is equal to string.Emtpy
IsEmpty (String, String) | Assert that a string is empty - that is equal to string.Emtpy
IsEmpty (String, String, Object) | Assert that a string is empty - that is equal to string.Empty

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method (ICollection)

OldAssert.IsEmpty Method (ICollection)
See Also Example
[image]

Assert that an array,list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal collection As ICollection _
)
C#
public static void IsEmpty(
ICollection collection
)
C++
public:
static void IsEmpty(
ICollection collection
)
J#
public static void IsEmpty(
ICollection collection
)
JScript
public static function IsEmpty(
collection : ICollection
)

Parameters

collection
An array, list or other collection implementing ICollection

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method (ICollection, String)

OldAssert.IsEmpty Method (ICollection, String)
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal collection As ICollection, _
ByVal message As String _
)
C#
public static void IsEmpty(
ICollection collection,
string message
)
C++
public:
static void IsEmpty(
ICollection collection,
String message
)
J#
public static void IsEmpty(
ICollection collection,
string message
)
JScript
public static function IsEmpty(
collection : ICollection,
message : String
)

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method (ICollection, String, Object[])

OldAssert.IsEmpty Method (ICollection, String, Object[])
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal collection As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsEmpty(
ICollection collection,
string message,
params object[] args
)
C++
public:
static void IsEmpty(
ICollection collection,
String message,
... array<Object>^ args
)
J#
public static void IsEmpty(
ICollection collection,
string message,
object[] args
)
JScript
public static function IsEmpty(
collection : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method (String)

OldAssert.IsEmpty Method (String)
See Also Example
[image]

Assert that a string is empty - that is equal to string.Emtpy

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal aString As String _
)
C#
public static void IsEmpty(
string aString
)
C++
public:
static void IsEmpty(
String aString
)
J#
public static void IsEmpty(
string aString
)
JScript
public static function IsEmpty(
aString : String
)

Parameters

aString
The string to be tested

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method (String, String)

OldAssert.IsEmpty Method (String, String)
See Also Example
[image]

Assert that a string is empty - that is equal to string.Emtpy

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal aString As String, _
ByVal message As String _
)
C#
public static void IsEmpty(
string aString,
string message
)
C++
public:
static void IsEmpty(
String aString,
String message
)
J#
public static void IsEmpty(
string aString,
string message
)
JScript
public static function IsEmpty(
aString : String,
message : String
)

Parameters

aString
The string to be tested
message
The message to be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method (String, String, Object[])

OldAssert.IsEmpty Method (String, String, Object[])
See Also Example
[image]

Assert that a string is empty - that is equal to string.Empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal aString As String, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsEmpty(
string aString,
string message,
params object[] args
)
C++
public:
static void IsEmpty(
String aString,
String message,
... array<Object>^ args
)
J#
public static void IsEmpty(
string aString,
string message,
object[] args
)
JScript
public static function IsEmpty(
aString : String,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

aString
The string to be tested
message
The message to be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsFalse Method

OldAssert.IsFalse Method

Asserts that a condition is false. If the condition is true the method throws an AssertionException.

Overload List

Name | Description
IsFalse (Boolean) | Asserts that a condition is false. If the condition is true the method throws an AssertionException.
IsFalse (Boolean, String) |
IsFalse (Boolean, String, Object) | Asserts that a condition is false. If the condition is true the method throws an AssertionException.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsFalse Method (Boolean)

OldAssert.IsFalse Method (Boolean)
See Also Example
[image]

Asserts that a condition is false. If the condition is true the method throws an AssertionException.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsFalse( _
ByVal condition As Boolean _
)
C#
public static void IsFalse(
bool condition
)
C++
public:
static void IsFalse(
bool condition
)
J#
public static void IsFalse(
bool condition
)
JScript
public static function IsFalse(
condition : bool
)

Parameters

condition
The evaluated condition

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsFalse Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsFalse Method (Boolean, String)

OldAssert.IsFalse Method (Boolean, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsFalse( _
ByVal condition As Boolean, _
ByVal message As String _
)
C#
public static void IsFalse(
bool condition,
string message
)
C++
public:
static void IsFalse(
bool condition,
String message
)
J#
public static void IsFalse(
bool condition,
string message
)
JScript
public static function IsFalse(
condition : bool,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsFalse Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsFalse Method (Boolean, String, Object[])

OldAssert.IsFalse Method (Boolean, String, Object[])
See Also Example
[image]

Asserts that a condition is false. If the condition is true the method throws an AssertionException.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsFalse( _
ByVal condition As Boolean, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsFalse(
bool condition,
string format,
params object[] args
)
C++
public:
static void IsFalse(
bool condition,
String format,
... array<Object>^ args
)
J#
public static void IsFalse(
bool condition,
string format,
object[] args
)
JScript
public static function IsFalse(
condition : bool,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

condition
The evaluated condition
format
The format of the message to display if the condition is false, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsFalse Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsInstanceOfType Method

OldAssert.IsInstanceOfType Method

Asserts that an object is an instance of a given type.

Overload List

Name | Description
IsInstanceOfType (Type, Object) | Asserts that an object is an instance of a given type.
IsInstanceOfType (Type, Object, String) | Asserts that an object is an instance of a given type.
IsInstanceOfType (Type, Object, String, Object) | Asserts that an object is an instance of a given type.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsInstanceOfType Method (Type, Object)

OldAssert.IsInstanceOfType Method (Type, Object)
See Also Example
[image]

Asserts that an object is an instance of a given type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType( _
ByVal expected As Type, _
ByVal actual As Object _
)
C#
public static void IsInstanceOfType(
Type expected,
object actual
)
C++
public:
static void IsInstanceOfType(
Type expected,
Object actual
)
J#
public static void IsInstanceOfType(
Type expected,
object actual
)
JScript
public static function IsInstanceOfType(
expected : Type,
actual : Object
)

Parameters

expected
The expected Type
actual
The object being examined

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsInstanceOfType Method (Type, Object, String)

OldAssert.IsInstanceOfType Method (Type, Object, String)
See Also Example
[image]

Asserts that an object is an instance of a given type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void IsInstanceOfType(
Type expected,
object actual,
string message
)
C++
public:
static void IsInstanceOfType(
Type expected,
Object actual,
String message
)
J#
public static void IsInstanceOfType(
Type expected,
object actual,
string message
)
JScript
public static function IsInstanceOfType(
expected : Type,
actual : Object,
message : String
)

Parameters

expected
The expected Type
actual
The object being examined
message
A message to display in case of failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsInstanceOfType Method (Type, Object, String, Object[])

OldAssert.IsInstanceOfType Method (Type, Object, String, Object[])
See Also Example
[image]

Asserts that an object is an instance of a given type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOfType( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsInstanceOfType(
Type expected,
object actual,
string message,
params object[] args
)
C++
public:
static void IsInstanceOfType(
Type expected,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void IsInstanceOfType(
Type expected,
object actual,
string message,
object[] args
)
JScript
public static function IsInstanceOfType(
expected : Type,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected Type
actual
The object being examined
message
A message to display in case of failure
args
An array of objects to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNaN Method

OldAssert.IsNaN Method

Verifies that the double is passed is an

Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.

Overload List

Name Description
IsNaN (Double) Verifies that the double is passed is an
Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.
IsNaN (Double, String) Verifies that the double is passed is an
Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.
IsNaN (Double, String, Object) Verifies that the double is passed is an
Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNaN Method (Double)

OldAssert.IsNaN Method (Double)
See Also Example
[image]

Verifies that the double is passed is an

Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNaN( _
ByVal aDouble As Double _
)
C#
public static void IsNaN(
double aDouble
)
C++
public:
static void IsNaN(
double aDouble
)
J#
public static void IsNaN(
double aDouble
)
JScript
public static function IsNaN(
aDouble : double
)

Parameters

aDouble
The object that is to be tested

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNaN Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNaN Method (Double, String)

OldAssert.IsNaN Method (Double, String)
See Also Example
[image]

Verifies that the double is passed is an

Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNaN( _
ByVal aDouble As Double, _
ByVal message As String _
)
C#
public static void IsNaN(
double aDouble,
string message
)
C++
public:
static void IsNaN(
double aDouble,
String message
)
J#
public static void IsNaN(
double aDouble,
string message
)
JScript
public static function IsNaN(
aDouble : double,
message : String
)

Parameters

aDouble
The object that is to be tested
message
The message to be displayed when the object is not null

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNaN Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNaN Method (Double, String, Object[])

OldAssert.IsNaN Method (Double, String, Object[])
See Also Example
[image]

Verifies that the double is passed is an

Copy Code
NaN
value. If the object is not
Copy Code
NaN
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNaN( _
ByVal aDouble As Double, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNaN(
double aDouble,
string message,
params object[] args
)
C++
public:
static void IsNaN(
double aDouble,
String message,
... array<Object>^ args
)
J#
public static void IsNaN(
double aDouble,
string message,
object[] args
)
JScript
public static function IsNaN(
aDouble : double,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

aDouble
The value that is to be tested
message
The message to be displayed when the object is not null
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNaN Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotAssignableFrom Method

OldAssert.IsNotAssignableFrom Method

Asserts that an object may not be assigned a value of a given Type.

Overload List

Name | Description
IsNotAssignableFrom (Type, Object) | Asserts that an object may not be assigned a value of a given Type.
IsNotAssignableFrom (Type, Object, String) | Asserts that an object may not be assigned a value of a given Type.
IsNotAssignableFrom (Type, Object, String, Object) | Asserts that an object may not be assigned a value of a given Type.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotAssignableFrom Method (Type, Object)

OldAssert.IsNotAssignableFrom Method (Type, Object)
See Also Example
[image]

Asserts that an object may not be assigned a value of a given Type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom( _
ByVal expected As Type, _
ByVal actual As Object _
)
C#
public static void IsNotAssignableFrom(
Type expected,
object actual
)
C++
public:
static void IsNotAssignableFrom(
Type expected,
Object actual
)
J#
public static void IsNotAssignableFrom(
Type expected,
object actual
)
JScript
public static function IsNotAssignableFrom(
expected : Type,
actual : Object
)

Parameters

expected
The expected Type.
actual
The object under examination

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotAssignableFrom Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotAssignableFrom Method (Type, Object, String)

OldAssert.IsNotAssignableFrom Method (Type, Object, String)
See Also Example
[image]

Asserts that an object may not be assigned a value of a given Type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void IsNotAssignableFrom(
Type expected,
object actual,
string message
)
C++
public:
static void IsNotAssignableFrom(
Type expected,
Object actual,
String message
)
J#
public static void IsNotAssignableFrom(
Type expected,
object actual,
string message
)
JScript
public static function IsNotAssignableFrom(
expected : Type,
actual : Object,
message : String
)

Parameters

expected
The expected Type.
actual
The object under examination
message
The messge to display in case of failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotAssignableFrom Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotAssignableFrom Method (Type, Object, String, Object[])

OldAssert.IsNotAssignableFrom Method (Type, Object, String, Object[])
See Also Example
[image]

Asserts that an object may not be assigned a value of a given Type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAssignableFrom( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotAssignableFrom(
Type expected,
object actual,
string message,
params object[] args
)
C++
public:
static void IsNotAssignableFrom(
Type expected,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void IsNotAssignableFrom(
Type expected,
object actual,
string message,
object[] args
)
JScript
public static function IsNotAssignableFrom(
expected : Type,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected Type.
actual
The object under examination
message
The message to display in case of failure
args
Array of objects to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotAssignableFrom Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method

OldAssert.IsNotEmpty Method

Assert that an array,list or other collection is empty

Overload List

Name | Description
IsNotEmpty (ICollection) | Assert that an array,list or other collection is empty
IsNotEmpty (ICollection, String) | Assert that an array, list or other collection is empty
IsNotEmpty (ICollection, String, Object) | Assert that an array, list or other collection is empty
IsNotEmpty (String) | Assert that a string is empty - that is equal to string.Emtpy
IsNotEmpty (String, String) | Assert that a string is empty - that is equal to string.Emtpy
IsNotEmpty (String, String, Object) | Assert that a string is empty - that is equal to string.Emtpy

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method (ICollection)

OldAssert.IsNotEmpty Method (ICollection)
See Also Example
[image]

Assert that an array,list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal collection As ICollection _
)
C#
public static void IsNotEmpty(
ICollection collection
)
C++
public:
static void IsNotEmpty(
ICollection collection
)
J#
public static void IsNotEmpty(
ICollection collection
)
JScript
public static function IsNotEmpty(
collection : ICollection
)

Parameters

collection
An array, list or other collection implementing ICollection

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method (ICollection, String)

OldAssert.IsNotEmpty Method (ICollection, String)
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal collection As ICollection, _
ByVal message As String _
)
C#
public static void IsNotEmpty(
ICollection collection,
string message
)
C++
public:
static void IsNotEmpty(
ICollection collection,
String message
)
J#
public static void IsNotEmpty(
ICollection collection,
string message
)
JScript
public static function IsNotEmpty(
collection : ICollection,
message : String
)

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method (ICollection, String, Object[])

OldAssert.IsNotEmpty Method (ICollection, String, Object[])
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal collection As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotEmpty(
ICollection collection,
string message,
params object[] args
)
C++
public:
static void IsNotEmpty(
ICollection collection,
String message,
... array<Object>^ args
)
J#
public static void IsNotEmpty(
ICollection collection,
string message,
object[] args
)
JScript
public static function IsNotEmpty(
collection : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method (String)

OldAssert.IsNotEmpty Method (String)
See Also Example
[image]

Assert that a string is empty - that is equal to string.Emtpy

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal aString As String _
)
C#
public static void IsNotEmpty(
string aString
)
C++
public:
static void IsNotEmpty(
String aString
)
J#
public static void IsNotEmpty(
string aString
)
JScript
public static function IsNotEmpty(
aString : String
)

Parameters

aString
The string to be tested

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method (String, String)

OldAssert.IsNotEmpty Method (String, String)
See Also Example
[image]

Assert that a string is empty - that is equal to string.Emtpy

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal aString As String, _
ByVal message As String _
)
C#
public static void IsNotEmpty(
string aString,
string message
)
C++
public:
static void IsNotEmpty(
String aString,
String message
)
J#
public static void IsNotEmpty(
string aString,
string message
)
JScript
public static function IsNotEmpty(
aString : String,
message : String
)

Parameters

aString
The string to be tested
message
The message to be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Method (String, String, Object[])

OldAssert.IsNotEmpty Method (String, String, Object[])
See Also Example
[image]

Assert that a string is empty - that is equal to string.Emtpy

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty( _
ByVal aString As String, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotEmpty(
string aString,
string message,
params object[] args
)
C++
public:
static void IsNotEmpty(
String aString,
String message,
... array<Object>^ args
)
J#
public static void IsNotEmpty(
string aString,
string message,
object[] args
)
JScript
public static function IsNotEmpty(
aString : String,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

aString
The string to be tested
message
The message to be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotInstanceOfType Method

OldAssert.IsNotInstanceOfType Method

Asserts that an object is not an instance of a given type.

Overload List

Name | Description
IsNotInstanceOfType (Type, Object) | Asserts that an object is not an instance of a given type.
IsNotInstanceOfType (Type, Object, String) | Asserts that an object is not an instance of a given type.
IsNotInstanceOfType (Type, Object, String, Object) | Asserts that an object is not an instance of a given type.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotInstanceOfType Method (Type, Object)

OldAssert.IsNotInstanceOfType Method (Type, Object)
See Also Example
[image]

Asserts that an object is not an instance of a given type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType( _
ByVal expected As Type, _
ByVal actual As Object _
)
C#
public static void IsNotInstanceOfType(
Type expected,
object actual
)
C++
public:
static void IsNotInstanceOfType(
Type expected,
Object actual
)
J#
public static void IsNotInstanceOfType(
Type expected,
object actual
)
JScript
public static function IsNotInstanceOfType(
expected : Type,
actual : Object
)

Parameters

expected
The expected Type
actual
The object being examined

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotInstanceOfType Method (Type, Object, String)

OldAssert.IsNotInstanceOfType Method (Type, Object, String)
See Also Example
[image]

Asserts that an object is not an instance of a given type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void IsNotInstanceOfType(
Type expected,
object actual,
string message
)
C++
public:
static void IsNotInstanceOfType(
Type expected,
Object actual,
String message
)
J#
public static void IsNotInstanceOfType(
Type expected,
object actual,
string message
)
JScript
public static function IsNotInstanceOfType(
expected : Type,
actual : Object,
message : String
)

Parameters

expected
The expected Type
actual
The object being examined
message
A message to display in case of failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotInstanceOfType Method (Type, Object, String, Object[])

OldAssert.IsNotInstanceOfType Method (Type, Object, String, Object[])
See Also Example
[image]

Asserts that an object is not an instance of a given type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotInstanceOfType( _
ByVal expected As Type, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotInstanceOfType(
Type expected,
object actual,
string message,
params object[] args
)
C++
public:
static void IsNotInstanceOfType(
Type expected,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void IsNotInstanceOfType(
Type expected,
object actual,
string message,
object[] args
)
JScript
public static function IsNotInstanceOfType(
expected : Type,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The expected Type
actual
The object being examined
message
A message to display in case of failure
args
An array of objects to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotInstanceOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotNull Method

OldAssert.IsNotNull Method

Verifies that the object that is passed in is not equal to

Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.

Overload List

Name Description
IsNotNull (Object) Verifies that the object that is passed in is not equal to
Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.
IsNotNull (Object, String) Verifies that the object that is passed in is not equal to
Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown with the message that is passed in.
IsNotNull (Object, String, Object) Verifies that the object that is passed in is not equal to
Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotNull Method (Object)

OldAssert.IsNotNull Method (Object)
See Also Example
[image]

Verifies that the object that is passed in is not equal to

Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotNull( _
ByVal anObject As Object _
)
C#
public static void IsNotNull(
object anObject
)
C++
public:
static void IsNotNull(
Object anObject
)
J#
public static void IsNotNull(
object anObject
)
JScript
public static function IsNotNull(
anObject : Object
)

Parameters

anObject
The object that is to be tested

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotNull Method (Object, String)

OldAssert.IsNotNull Method (Object, String)
See Also Example
[image]

Verifies that the object that is passed in is not equal to

Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown with the message that is passed in.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotNull( _
ByVal anObject As Object, _
ByVal message As String _
)
C#
public static void IsNotNull(
object anObject,
string message
)
C++
public:
static void IsNotNull(
Object anObject,
String message
)
J#
public static void IsNotNull(
object anObject,
string message
)
JScript
public static function IsNotNull(
anObject : Object,
message : String
)

Parameters

anObject
The object that is to be tested
message
The message to initialize the AssertionException with.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotNull Method (Object, String, Object[])

OldAssert.IsNotNull Method (Object, String, Object[])
See Also Example
[image]

Verifies that the object that is passed in is not equal to

Copy Code
null
If the object is not
Copy Code
null
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotNull( _
ByVal anObject As Object, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotNull(
object anObject,
string format,
params object[] args
)
C++
public:
static void IsNotNull(
Object anObject,
String format,
... array<Object>^ args
)
J#
public static void IsNotNull(
object anObject,
string format,
object[] args
)
JScript
public static function IsNotNull(
anObject : Object,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

anObject
The object that is to be tested
format
The format of the message to display if the assertion fails, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNull Method

OldAssert.IsNull Method

Verifies that the object that is passed in is equal to

Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.

Overload List

Name Description
IsNull (Object) Verifies that the object that is passed in is equal to
Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.
IsNull (Object, String) Verifies that the object that is passed in is equal to
Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown with the message that is passed in.
IsNull (Object, String, Object) Verifies that the object that is passed in is equal to
Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNull Method (Object)

OldAssert.IsNull Method (Object)
See Also Example
[image]

Verifies that the object that is passed in is equal to

Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNull( _
ByVal anObject As Object _
)
C#
public static void IsNull(
object anObject
)
C++
public:
static void IsNull(
Object anObject
)
J#
public static void IsNull(
object anObject
)
JScript
public static function IsNull(
anObject : Object
)

Parameters

anObject
The object that is to be tested

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNull Method (Object, String)

OldAssert.IsNull Method (Object, String)
See Also Example
[image]

Verifies that the object that is passed in is equal to

Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown with the message that is passed in.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNull( _
ByVal anObject As Object, _
ByVal message As String _
)
C#
public static void IsNull(
object anObject,
string message
)
C++
public:
static void IsNull(
Object anObject,
String message
)
J#
public static void IsNull(
object anObject,
string message
)
JScript
public static function IsNull(
anObject : Object,
message : String
)

Parameters

anObject
The object that is to be tested
message
The message to initialize the AssertionException with.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNull Method (Object, String, Object[])

OldAssert.IsNull Method (Object, String, Object[])
See Also Example
[image]

Verifies that the object that is passed in is equal to

Copy Code
null
If the object is
Copy Code
null
then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNull( _
ByVal anObject As Object, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNull(
object anObject,
string format,
params object[] args
)
C++
public:
static void IsNull(
Object anObject,
String format,
... array<Object>^ args
)
J#
public static void IsNull(
object anObject,
string format,
object[] args
)
JScript
public static function IsNull(
anObject : Object,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

anObject
The object that is to be tested
format
The format of the message to display if the assertion fails, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsTrue Method

OldAssert.IsTrue Method

Asserts that a condition is true. If the condition is false the method throws an AssertionException.

Overload List

Name | Description
IsTrue (Boolean) | Asserts that a condition is true. If the condition is false the method throws an AssertionException.
IsTrue (Boolean, String) |
IsTrue (Boolean, String, Object) | Asserts that a condition is true. If the condition is false the method throws an AssertionException.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsTrue Method (Boolean)

OldAssert.IsTrue Method (Boolean)
See Also Example
[image]

Asserts that a condition is true. If the condition is false the method throws an AssertionException.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsTrue( _
ByVal condition As Boolean _
)
C#
public static void IsTrue(
bool condition
)
C++
public:
static void IsTrue(
bool condition
)
J#
public static void IsTrue(
bool condition
)
JScript
public static function IsTrue(
condition : bool
)

Parameters

condition
The evaluated condition

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsTrue Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsTrue Method (Boolean, String)

OldAssert.IsTrue Method (Boolean, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsTrue( _
ByVal condition As Boolean, _
ByVal message As String _
)
C#
public static void IsTrue(
bool condition,
string message
)
C++
public:
static void IsTrue(
bool condition,
String message
)
J#
public static void IsTrue(
bool condition,
string message
)
JScript
public static function IsTrue(
condition : bool,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsTrue Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsTrue Method (Boolean, String, Object[])

OldAssert.IsTrue Method (Boolean, String, Object[])
See Also Example
[image]

Asserts that a condition is true. If the condition is false the method throws an AssertionException.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsTrue( _
ByVal condition As Boolean, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsTrue(
bool condition,
string format,
params object[] args
)
C++
public:
static void IsTrue(
bool condition,
String format,
... array<Object>^ args
)
J#
public static void IsTrue(
bool condition,
string format,
object[] args
)
JScript
public static function IsTrue(
condition : bool,
format : String,
ParamArrayAttribute args : Object[]
)

Parameters

condition
The evaluated condition
format
The format of the message to display if the condition is false, containing zero or more format items.
args
An Object array containing zero or more objects to format.

Remarks

The error message is formatted using Format.

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.IsTrue Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method

OldAssert.Less Method

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Overload List

Name | Description
Less (Decimal, Decimal) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Decimal, Decimal, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Decimal, Decimal, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Double, Double) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Double, Double, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Double, Double, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (IComparable, IComparable) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (IComparable, IComparable, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (IComparable, IComparable, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Int32, Int32) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Int32, Int32, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Int32, Int32, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Int64, Int64) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Int64, Int64, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Int64, Int64, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Single, Single) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Single, Single, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (Single, Single, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (UInt32, UInt32) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (UInt32, UInt32, String) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.
Less (UInt32, UInt32, String, Object) | Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Decimal, Decimal)

OldAssert.Less Method (Decimal, Decimal)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Decimal, _
ByVal arg2 As Decimal _
)
C#
public static void Less(
decimal arg1,
decimal arg2
)
C++
public:
static void Less(
decimal arg1,
decimal arg2
)
J#
public static void Less(
decimal arg1,
decimal arg2
)
JScript
public static function Less(
arg1 : Decimal,
arg2 : Decimal
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Decimal, Decimal, String)

OldAssert.Less Method (Decimal, Decimal, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Decimal, _
ByVal arg2 As Decimal, _
ByVal message As String _
)
C#
public static void Less(
decimal arg1,
decimal arg2,
string message
)
C++
public:
static void Less(
decimal arg1,
decimal arg2,
String message
)
J#
public static void Less(
decimal arg1,
decimal arg2,
string message
)
JScript
public static function Less(
arg1 : Decimal,
arg2 : Decimal,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Decimal, Decimal, String, Object[])

OldAssert.Less Method (Decimal, Decimal, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Decimal, _
ByVal arg2 As Decimal, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
decimal arg1,
decimal arg2,
string message,
params object[] args
)
C++
public:
static void Less(
decimal arg1,
decimal arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
decimal arg1,
decimal arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : Decimal,
arg2 : Decimal,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Double, Double)

OldAssert.Less Method (Double, Double)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Double, _
ByVal arg2 As Double _
)
C#
public static void Less(
double arg1,
double arg2
)
C++
public:
static void Less(
double arg1,
double arg2
)
J#
public static void Less(
double arg1,
double arg2
)
JScript
public static function Less(
arg1 : double,
arg2 : double
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Double, Double, String)

OldAssert.Less Method (Double, Double, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Double, _
ByVal arg2 As Double, _
ByVal message As String _
)
C#
public static void Less(
double arg1,
double arg2,
string message
)
C++
public:
static void Less(
double arg1,
double arg2,
String message
)
J#
public static void Less(
double arg1,
double arg2,
string message
)
JScript
public static function Less(
arg1 : double,
arg2 : double,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Double, Double, String, Object[])

OldAssert.Less Method (Double, Double, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Double, _
ByVal arg2 As Double, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
double arg1,
double arg2,
string message,
params object[] args
)
C++
public:
static void Less(
double arg1,
double arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
double arg1,
double arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : double,
arg2 : double,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (IComparable, IComparable)

OldAssert.Less Method (IComparable, IComparable)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As IComparable, _
ByVal arg2 As IComparable _
)
C#
public static void Less(
IComparable arg1,
IComparable arg2
)
C++
public:
static void Less(
IComparable arg1,
IComparable arg2
)
J#
public static void Less(
IComparable arg1,
IComparable arg2
)
JScript
public static function Less(
arg1 : IComparable,
arg2 : IComparable
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (IComparable, IComparable, String)

OldAssert.Less Method (IComparable, IComparable, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As IComparable, _
ByVal arg2 As IComparable, _
ByVal message As String _
)
C#
public static void Less(
IComparable arg1,
IComparable arg2,
string message
)
C++
public:
static void Less(
IComparable arg1,
IComparable arg2,
String message
)
J#
public static void Less(
IComparable arg1,
IComparable arg2,
string message
)
JScript
public static function Less(
arg1 : IComparable,
arg2 : IComparable,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (IComparable, IComparable, String, Object[])

OldAssert.Less Method (IComparable, IComparable, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As IComparable, _
ByVal arg2 As IComparable, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
IComparable arg1,
IComparable arg2,
string message,
params object[] args
)
C++
public:
static void Less(
IComparable arg1,
IComparable arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
IComparable arg1,
IComparable arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : IComparable,
arg2 : IComparable,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Int32, Int32)

OldAssert.Less Method (Int32, Int32)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Integer, _
ByVal arg2 As Integer _
)
C#
public static void Less(
int arg1,
int arg2
)
C++
public:
static void Less(
int arg1,
int arg2
)
J#
public static void Less(
int arg1,
int arg2
)
JScript
public static function Less(
arg1 : int,
arg2 : int
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Int32, Int32, String)

OldAssert.Less Method (Int32, Int32, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Integer, _
ByVal arg2 As Integer, _
ByVal message As String _
)
C#
public static void Less(
int arg1,
int arg2,
string message
)
C++
public:
static void Less(
int arg1,
int arg2,
String message
)
J#
public static void Less(
int arg1,
int arg2,
string message
)
JScript
public static function Less(
arg1 : int,
arg2 : int,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Int32, Int32, String, Object[])

OldAssert.Less Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Integer, _
ByVal arg2 As Integer, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
int arg1,
int arg2,
string message,
params object[] args
)
C++
public:
static void Less(
int arg1,
int arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
int arg1,
int arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : int,
arg2 : int,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Int64, Int64)

OldAssert.Less Method (Int64, Int64)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Long, _
ByVal arg2 As Long _
)
C#
public static void Less(
long arg1,
long arg2
)
C++
public:
static void Less(
__int64 arg1,
__int64 arg2
)
J#
public static void Less(
long arg1,
long arg2
)
JScript
public static function Less(
arg1 : long,
arg2 : long
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Int64, Int64, String)

OldAssert.Less Method (Int64, Int64, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Long, _
ByVal arg2 As Long, _
ByVal message As String _
)
C#
public static void Less(
long arg1,
long arg2,
string message
)
C++
public:
static void Less(
__int64 arg1,
__int64 arg2,
String message
)
J#
public static void Less(
long arg1,
long arg2,
string message
)
JScript
public static function Less(
arg1 : long,
arg2 : long,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Int64, Int64, String, Object[])

OldAssert.Less Method (Int64, Int64, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Long, _
ByVal arg2 As Long, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
long arg1,
long arg2,
string message,
params object[] args
)
C++
public:
static void Less(
__int64 arg1,
__int64 arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
long arg1,
long arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : long,
arg2 : long,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Single, Single)

OldAssert.Less Method (Single, Single)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Single, _
ByVal arg2 As Single _
)
C#
public static void Less(
float arg1,
float arg2
)
C++
public:
static void Less(
float arg1,
float arg2
)
J#
public static void Less(
float arg1,
float arg2
)
JScript
public static function Less(
arg1 : float,
arg2 : float
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Single, Single, String)

OldAssert.Less Method (Single, Single, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Single, _
ByVal arg2 As Single, _
ByVal message As String _
)
C#
public static void Less(
float arg1,
float arg2,
string message
)
C++
public:
static void Less(
float arg1,
float arg2,
String message
)
J#
public static void Less(
float arg1,
float arg2,
string message
)
JScript
public static function Less(
arg1 : float,
arg2 : float,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (Single, Single, String, Object[])

OldAssert.Less Method (Single, Single, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As Single, _
ByVal arg2 As Single, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
float arg1,
float arg2,
string message,
params object[] args
)
C++
public:
static void Less(
float arg1,
float arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
float arg1,
float arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : float,
arg2 : float,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (UInt32, UInt32)

OldAssert.Less Method (UInt32, UInt32)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As UInt32, _
ByVal arg2 As UInt32 _
)
C#
public static void Less(
uint arg1,
uint arg2
)
C++
public:
static void Less(
unsigned int arg1,
unsigned int arg2
)
J#
public static void Less(
uint arg1,
uint arg2
)
JScript
public static function Less(
arg1 : UInt32,
arg2 : UInt32
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (UInt32, UInt32, String)

OldAssert.Less Method (UInt32, UInt32, String)
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As UInt32, _
ByVal arg2 As UInt32, _
ByVal message As String _
)
C#
public static void Less(
uint arg1,
uint arg2,
string message
)
C++
public:
static void Less(
unsigned int arg1,
unsigned int arg2,
String message
)
J#
public static void Less(
uint arg1,
uint arg2,
string message
)
JScript
public static function Less(
arg1 : UInt32,
arg2 : UInt32,
message : String
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Less Method (UInt32, UInt32, String, Object[])

OldAssert.Less Method (UInt32, UInt32, String, Object[])
See Also Example
[image]

Verifies that the first value is less than the second value. If it is not, then an AssertionException is thrown.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Less( _
ByVal arg1 As UInt32, _
ByVal arg2 As UInt32, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Less(
uint arg1,
uint arg2,
string message,
params object[] args
)
C++
public:
static void Less(
unsigned int arg1,
unsigned int arg2,
String message,
... array<Object>^ args
)
J#
public static void Less(
uint arg1,
uint arg2,
string message,
object[] args
)
JScript
public static function Less(
arg1 : UInt32,
arg2 : UInt32,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

arg1
The first value, expected to be less
arg2
The second value, expected to be greater
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Less Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method

OldAssert.LowerEqualThan Method

Verifies that left is strictly lower than right.

Overload List

Name | Description
LowerEqualThan (Byte, Byte) | Verifies that left is strictly lower than right.
LowerEqualThan (Byte, Byte, String) | Verifies that left is strictly lower than right.
LowerEqualThan (Byte, Byte, String, Object) | Verifies that left is strictly lower than right.
LowerEqualThan (Double, Double) | Verifies that left is strictly lower than right.
LowerEqualThan (Double, Double, String) | Verifies that left is strictly lower than right.
LowerEqualThan (Double, Double, String, Object) | Verifies that left is strictly lower than right.
LowerEqualThan (IComparable, IComparable) | Verifies that left is lower equal than right.
LowerEqualThan (IComparable, IComparable, String) | Verifies that left is lower equal than right.
LowerEqualThan (IComparable, IComparable, String, Object) | Verifies that left is lower equal than right.
LowerEqualThan (Int16, Int16) | Verifies that left is strictly lower than right.
LowerEqualThan (Int16, Int16, String) | Verifies that left is strictly lower than right.
LowerEqualThan (Int16, Int16, String, Object) | Verifies that left is strictly lower than right.
LowerEqualThan (Int32, Int32) | Verifies that left is strictly lower than right.
LowerEqualThan (Int32, Int32, String) | Verifies that left is strictly lower than right.
LowerEqualThan (Int32, Int32, String, Object) | Verifies that left is strictly lower than right.
LowerEqualThan (Int64, Int64) | Verifies that left is strictly lower than right.
LowerEqualThan (Int64, Int64, String) | Verifies that left is strictly lower than right.
LowerEqualThan (Int64, Int64, String, Object) | Verifies that left is strictly lower than right.
LowerEqualThan (Single, Single) | Verifies that left is strictly lower than right.
LowerEqualThan (Single, Single, String) | Verifies that left is strictly lower than right.
LowerEqualThan (Single, Single, String, Object) | Verifies that left is strictly lower than right.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Byte, Byte)

OldAssert.LowerEqualThan Method (Byte, Byte)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Byte, _
ByVal right As Byte _
)
C#
public static void LowerEqualThan(
byte left,
byte right
)
C++
public:
static void LowerEqualThan(
char left,
char right
)
J#
public static void LowerEqualThan(
byte left,
byte right
)
JScript
public static function LowerEqualThan(
left : Byte,
right : Byte
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Byte, Byte, String)

OldAssert.LowerEqualThan Method (Byte, Byte, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
byte left,
byte right,
string message
)
C++
public:
static void LowerEqualThan(
char left,
char right,
String message
)
J#
public static void LowerEqualThan(
byte left,
byte right,
string message
)
JScript
public static function LowerEqualThan(
left : Byte,
right : Byte,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Byte, Byte, String, Object[])

OldAssert.LowerEqualThan Method (Byte, Byte, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
byte left,
byte right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
char left,
char right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
byte left,
byte right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : Byte,
right : Byte,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Double, Double)

OldAssert.LowerEqualThan Method (Double, Double)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Double, _
ByVal right As Double _
)
C#
public static void LowerEqualThan(
double left,
double right
)
C++
public:
static void LowerEqualThan(
double left,
double right
)
J#
public static void LowerEqualThan(
double left,
double right
)
JScript
public static function LowerEqualThan(
left : double,
right : double
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Double, Double, String)

OldAssert.LowerEqualThan Method (Double, Double, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
double left,
double right,
string message
)
C++
public:
static void LowerEqualThan(
double left,
double right,
String message
)
J#
public static void LowerEqualThan(
double left,
double right,
string message
)
JScript
public static function LowerEqualThan(
left : double,
right : double,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Double, Double, String, Object[])

OldAssert.LowerEqualThan Method (Double, Double, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
double left,
double right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
double left,
double right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
double left,
double right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : double,
right : double,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (IComparable, IComparable)

OldAssert.LowerEqualThan Method (IComparable, IComparable)
See Also Example
[image]

Verifies that left is lower equal than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As IComparable, _
ByVal right As IComparable _
)
C#
public static void LowerEqualThan(
IComparable left,
IComparable right
)
C++
public:
static void LowerEqualThan(
IComparable left,
IComparable right
)
J#
public static void LowerEqualThan(
IComparable left,
IComparable right
)
JScript
public static function LowerEqualThan(
left : IComparable,
right : IComparable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (IComparable, IComparable, String)

OldAssert.LowerEqualThan Method (IComparable, IComparable, String)
See Also Example
[image]

Verifies that left is lower equal than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
IComparable left,
IComparable right,
string message
)
C++
public:
static void LowerEqualThan(
IComparable left,
IComparable right,
String message
)
J#
public static void LowerEqualThan(
IComparable left,
IComparable right,
string message
)
JScript
public static function LowerEqualThan(
left : IComparable,
right : IComparable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (IComparable, IComparable, String, Object[])

OldAssert.LowerEqualThan Method (IComparable, IComparable, String, Object[])
See Also Example
[image]

Verifies that left is lower equal than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
IComparable left,
IComparable right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
IComparable left,
IComparable right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
IComparable left,
IComparable right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : IComparable,
right : IComparable,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int16, Int16)

OldAssert.LowerEqualThan Method (Int16, Int16)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Short, _
ByVal right As Short _
)
C#
public static void LowerEqualThan(
short left,
short right
)
C++
public:
static void LowerEqualThan(
short left,
short right
)
J#
public static void LowerEqualThan(
short left,
short right
)
JScript
public static function LowerEqualThan(
left : short,
right : short
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int16, Int16, String)

OldAssert.LowerEqualThan Method (Int16, Int16, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
short left,
short right,
string message
)
C++
public:
static void LowerEqualThan(
short left,
short right,
String message
)
J#
public static void LowerEqualThan(
short left,
short right,
string message
)
JScript
public static function LowerEqualThan(
left : short,
right : short,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int16, Int16, String, Object[])

OldAssert.LowerEqualThan Method (Int16, Int16, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
short left,
short right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
short left,
short right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
short left,
short right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : short,
right : short,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int32, Int32)

OldAssert.LowerEqualThan Method (Int32, Int32)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Integer, _
ByVal right As Integer _
)
C#
public static void LowerEqualThan(
int left,
int right
)
C++
public:
static void LowerEqualThan(
int left,
int right
)
J#
public static void LowerEqualThan(
int left,
int right
)
JScript
public static function LowerEqualThan(
left : int,
right : int
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int32, Int32, String)

OldAssert.LowerEqualThan Method (Int32, Int32, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
int left,
int right,
string message
)
C++
public:
static void LowerEqualThan(
int left,
int right,
String message
)
J#
public static void LowerEqualThan(
int left,
int right,
string message
)
JScript
public static function LowerEqualThan(
left : int,
right : int,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int32, Int32, String, Object[])

OldAssert.LowerEqualThan Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
int left,
int right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
int left,
int right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
int left,
int right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : int,
right : int,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int64, Int64)

OldAssert.LowerEqualThan Method (Int64, Int64)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Long, _
ByVal right As Long _
)
C#
public static void LowerEqualThan(
long left,
long right
)
C++
public:
static void LowerEqualThan(
__int64 left,
__int64 right
)
J#
public static void LowerEqualThan(
long left,
long right
)
JScript
public static function LowerEqualThan(
left : long,
right : long
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int64, Int64, String)

OldAssert.LowerEqualThan Method (Int64, Int64, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
long left,
long right,
string message
)
C++
public:
static void LowerEqualThan(
__int64 left,
__int64 right,
String message
)
J#
public static void LowerEqualThan(
long left,
long right,
string message
)
JScript
public static function LowerEqualThan(
left : long,
right : long,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Int64, Int64, String, Object[])

OldAssert.LowerEqualThan Method (Int64, Int64, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
long left,
long right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
__int64 left,
__int64 right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
long left,
long right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : long,
right : long,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Single, Single)

OldAssert.LowerEqualThan Method (Single, Single)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Single, _
ByVal right As Single _
)
C#
public static void LowerEqualThan(
float left,
float right
)
C++
public:
static void LowerEqualThan(
float left,
float right
)
J#
public static void LowerEqualThan(
float left,
float right
)
JScript
public static function LowerEqualThan(
left : float,
right : float
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Single, Single, String)

OldAssert.LowerEqualThan Method (Single, Single, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal message As String _
)
C#
public static void LowerEqualThan(
float left,
float right,
string message
)
C++
public:
static void LowerEqualThan(
float left,
float right,
String message
)
J#
public static void LowerEqualThan(
float left,
float right,
string message
)
JScript
public static function LowerEqualThan(
left : float,
right : float,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerEqualThan Method (Single, Single, String, Object[])

OldAssert.LowerEqualThan Method (Single, Single, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerEqualThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerEqualThan(
float left,
float right,
string format,
params object[] args
)
C++
public:
static void LowerEqualThan(
float left,
float right,
String format,
... array<Object>^ args
)
J#
public static void LowerEqualThan(
float left,
float right,
string format,
object[] args
)
JScript
public static function LowerEqualThan(
left : float,
right : float,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerEqualThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method

OldAssert.LowerThan Method

Verifies that left is strictly lower than right.

Overload List

Name | Description
LowerThan (Byte, Byte) | Verifies that left is strictly lower than right.
LowerThan (Byte, Byte, String) | Verifies that left is strictly lower than right.
LowerThan (Byte, Byte, String, Object) | Verifies that left is strictly lower than right.
LowerThan (Double, Double) | Verifies that left is strictly lower than right.
LowerThan (Double, Double, String) | Verifies that left is strictly lower than right.
LowerThan (Double, Double, String, Object) | Verifies that left is strictly lower than right.
LowerThan (IComparable, IComparable) | Verifies that left is strictly lower than right.
LowerThan (IComparable, IComparable, String) | Verifies that left is strictly lower than right.
LowerThan (IComparable, IComparable, String, Object) | Verifies that left is strictly lower than right.
LowerThan (Int16, Int16) | Verifies that left is strictly lower than right.
LowerThan (Int16, Int16, String) | Verifies that left is strictly lower than right.
LowerThan (Int16, Int16, String, Object) | Verifies that left is strictly lower than right.
LowerThan (Int32, Int32) | Verifies that left is strictly lower than right.
LowerThan (Int32, Int32, String) | Verifies that left is strictly lower than right.
LowerThan (Int32, Int32, String, Object) | Verifies that left is strictly lower than right.
LowerThan (Int64, Int64) | Verifies that left is strictly lower than right.
LowerThan (Int64, Int64, String) | Verifies that left is strictly lower than right.
LowerThan (Int64, Int64, String, Object) | Verifies that left is strictly lower than right.
LowerThan (Single, Single) | Verifies that left is strictly lower than right.
LowerThan (Single, Single, String) | Verifies that left is strictly lower than right.
LowerThan (Single, Single, String, Object) | Verifies that left is strictly lower than right.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Byte, Byte)

OldAssert.LowerThan Method (Byte, Byte)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Byte, _
ByVal right As Byte _
)
C#
public static void LowerThan(
byte left,
byte right
)
C++
public:
static void LowerThan(
char left,
char right
)
J#
public static void LowerThan(
byte left,
byte right
)
JScript
public static function LowerThan(
left : Byte,
right : Byte
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Byte, Byte, String)

OldAssert.LowerThan Method (Byte, Byte, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal message As String _
)
C#
public static void LowerThan(
byte left,
byte right,
string message
)
C++
public:
static void LowerThan(
char left,
char right,
String message
)
J#
public static void LowerThan(
byte left,
byte right,
string message
)
JScript
public static function LowerThan(
left : Byte,
right : Byte,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Byte, Byte, String, Object[])

OldAssert.LowerThan Method (Byte, Byte, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Byte, _
ByVal right As Byte, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
byte left,
byte right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
char left,
char right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
byte left,
byte right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : Byte,
right : Byte,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Double, Double)

OldAssert.LowerThan Method (Double, Double)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Double, _
ByVal right As Double _
)
C#
public static void LowerThan(
double left,
double right
)
C++
public:
static void LowerThan(
double left,
double right
)
J#
public static void LowerThan(
double left,
double right
)
JScript
public static function LowerThan(
left : double,
right : double
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Double, Double, String)

OldAssert.LowerThan Method (Double, Double, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal message As String _
)
C#
public static void LowerThan(
double left,
double right,
string message
)
C++
public:
static void LowerThan(
double left,
double right,
String message
)
J#
public static void LowerThan(
double left,
double right,
string message
)
JScript
public static function LowerThan(
left : double,
right : double,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Double, Double, String, Object[])

OldAssert.LowerThan Method (Double, Double, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Double, _
ByVal right As Double, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
double left,
double right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
double left,
double right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
double left,
double right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : double,
right : double,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (IComparable, IComparable)

OldAssert.LowerThan Method (IComparable, IComparable)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As IComparable, _
ByVal right As IComparable _
)
C#
public static void LowerThan(
IComparable left,
IComparable right
)
C++
public:
static void LowerThan(
IComparable left,
IComparable right
)
J#
public static void LowerThan(
IComparable left,
IComparable right
)
JScript
public static function LowerThan(
left : IComparable,
right : IComparable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (IComparable, IComparable, String)

OldAssert.LowerThan Method (IComparable, IComparable, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal message As String _
)
C#
public static void LowerThan(
IComparable left,
IComparable right,
string message
)
C++
public:
static void LowerThan(
IComparable left,
IComparable right,
String message
)
J#
public static void LowerThan(
IComparable left,
IComparable right,
string message
)
JScript
public static function LowerThan(
left : IComparable,
right : IComparable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (IComparable, IComparable, String, Object[])

OldAssert.LowerThan Method (IComparable, IComparable, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As IComparable, _
ByVal right As IComparable, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
IComparable left,
IComparable right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
IComparable left,
IComparable right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
IComparable left,
IComparable right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : IComparable,
right : IComparable,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int16, Int16)

OldAssert.LowerThan Method (Int16, Int16)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Short, _
ByVal right As Short _
)
C#
public static void LowerThan(
short left,
short right
)
C++
public:
static void LowerThan(
short left,
short right
)
J#
public static void LowerThan(
short left,
short right
)
JScript
public static function LowerThan(
left : short,
right : short
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int16, Int16, String)

OldAssert.LowerThan Method (Int16, Int16, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal message As String _
)
C#
public static void LowerThan(
short left,
short right,
string message
)
C++
public:
static void LowerThan(
short left,
short right,
String message
)
J#
public static void LowerThan(
short left,
short right,
string message
)
JScript
public static function LowerThan(
left : short,
right : short,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int16, Int16, String, Object[])

OldAssert.LowerThan Method (Int16, Int16, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Short, _
ByVal right As Short, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
short left,
short right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
short left,
short right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
short left,
short right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : short,
right : short,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int32, Int32)

OldAssert.LowerThan Method (Int32, Int32)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Integer, _
ByVal right As Integer _
)
C#
public static void LowerThan(
int left,
int right
)
C++
public:
static void LowerThan(
int left,
int right
)
J#
public static void LowerThan(
int left,
int right
)
JScript
public static function LowerThan(
left : int,
right : int
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int32, Int32, String)

OldAssert.LowerThan Method (Int32, Int32, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal message As String _
)
C#
public static void LowerThan(
int left,
int right,
string message
)
C++
public:
static void LowerThan(
int left,
int right,
String message
)
J#
public static void LowerThan(
int left,
int right,
string message
)
JScript
public static function LowerThan(
left : int,
right : int,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int32, Int32, String, Object[])

OldAssert.LowerThan Method (Int32, Int32, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Integer, _
ByVal right As Integer, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
int left,
int right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
int left,
int right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
int left,
int right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : int,
right : int,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int64, Int64)

OldAssert.LowerThan Method (Int64, Int64)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Long, _
ByVal right As Long _
)
C#
public static void LowerThan(
long left,
long right
)
C++
public:
static void LowerThan(
__int64 left,
__int64 right
)
J#
public static void LowerThan(
long left,
long right
)
JScript
public static function LowerThan(
left : long,
right : long
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int64, Int64, String)

OldAssert.LowerThan Method (Int64, Int64, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal message As String _
)
C#
public static void LowerThan(
long left,
long right,
string message
)
C++
public:
static void LowerThan(
__int64 left,
__int64 right,
String message
)
J#
public static void LowerThan(
long left,
long right,
string message
)
JScript
public static function LowerThan(
left : long,
right : long,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Int64, Int64, String, Object[])

OldAssert.LowerThan Method (Int64, Int64, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Long, _
ByVal right As Long, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
long left,
long right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
__int64 left,
__int64 right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
long left,
long right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : long,
right : long,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Single, Single)

OldAssert.LowerThan Method (Single, Single)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Single, _
ByVal right As Single _
)
C#
public static void LowerThan(
float left,
float right
)
C++
public:
static void LowerThan(
float left,
float right
)
J#
public static void LowerThan(
float left,
float right
)
JScript
public static function LowerThan(
left : float,
right : float
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Single, Single, String)

OldAssert.LowerThan Method (Single, Single, String)
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal message As String _
)
C#
public static void LowerThan(
float left,
float right,
string message
)
C++
public:
static void LowerThan(
float left,
float right,
String message
)
J#
public static void LowerThan(
float left,
float right,
string message
)
JScript
public static function LowerThan(
left : float,
right : float,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


LowerThan Method (Single, Single, String, Object[])

OldAssert.LowerThan Method (Single, Single, String, Object[])
See Also Example
[image]

Verifies that left is strictly lower than right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LowerThan( _
ByVal left As Single, _
ByVal right As Single, _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void LowerThan(
float left,
float right,
string format,
params object[] args
)
C++
public:
static void LowerThan(
float left,
float right,
String format,
... array<Object>^ args
)
J#
public static void LowerThan(
float left,
float right,
string format,
object[] args
)
JScript
public static function LowerThan(
left : float,
right : float,
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.LowerThan Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method

OldAssert.NotBetween Method

Asserts that test is not between left and right.

Overload List

Name | Description
NotBetween (Byte, Byte, Byte) | Asserts that test is not between left and right.
NotBetween (Double, Double, Double) | Asserts that test is not between left and right.
NotBetween (IComparable, IComparable, IComparable) | Asserts that test is not between left and right.
NotBetween (Int16, Int16, Int16) | Asserts that test is not between left and right.
NotBetween (Int32, Int32, Int32) | Asserts that test is not between left and right.
NotBetween (Int64, Int64, Int64) | Asserts that test is not between left and right.
NotBetween (Single, Single, Single) | Asserts that test is not between left and right.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (Byte, Byte, Byte)

OldAssert.NotBetween Method (Byte, Byte, Byte)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As Byte, _
ByVal left As Byte, _
ByVal right As Byte _
)
C#
public static void NotBetween(
byte test,
byte left,
byte right
)
C++
public:
static void NotBetween(
char test,
char left,
char right
)
J#
public static void NotBetween(
byte test,
byte left,
byte right
)
JScript
public static function NotBetween(
test : Byte,
left : Byte,
right : Byte
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (Double, Double, Double)

OldAssert.NotBetween Method (Double, Double, Double)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As Double, _
ByVal left As Double, _
ByVal right As Double _
)
C#
public static void NotBetween(
double test,
double left,
double right
)
C++
public:
static void NotBetween(
double test,
double left,
double right
)
J#
public static void NotBetween(
double test,
double left,
double right
)
JScript
public static function NotBetween(
test : double,
left : double,
right : double
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (IComparable, IComparable, IComparable)

OldAssert.NotBetween Method (IComparable, IComparable, IComparable)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As IComparable, _
ByVal left As IComparable, _
ByVal right As IComparable _
)
C#
public static void NotBetween(
IComparable test,
IComparable left,
IComparable right
)
C++
public:
static void NotBetween(
IComparable test,
IComparable left,
IComparable right
)
J#
public static void NotBetween(
IComparable test,
IComparable left,
IComparable right
)
JScript
public static function NotBetween(
test : IComparable,
left : IComparable,
right : IComparable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (Int16, Int16, Int16)

OldAssert.NotBetween Method (Int16, Int16, Int16)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As Short, _
ByVal left As Short, _
ByVal right As Short _
)
C#
public static void NotBetween(
short test,
short left,
short right
)
C++
public:
static void NotBetween(
short test,
short left,
short right
)
J#
public static void NotBetween(
short test,
short left,
short right
)
JScript
public static function NotBetween(
test : short,
left : short,
right : short
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (Int32, Int32, Int32)

OldAssert.NotBetween Method (Int32, Int32, Int32)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As Integer, _
ByVal left As Integer, _
ByVal right As Integer _
)
C#
public static void NotBetween(
int test,
int left,
int right
)
C++
public:
static void NotBetween(
int test,
int left,
int right
)
J#
public static void NotBetween(
int test,
int left,
int right
)
JScript
public static function NotBetween(
test : int,
left : int,
right : int
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (Int64, Int64, Int64)

OldAssert.NotBetween Method (Int64, Int64, Int64)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As Long, _
ByVal left As Long, _
ByVal right As Long _
)
C#
public static void NotBetween(
long test,
long left,
long right
)
C++
public:
static void NotBetween(
__int64 test,
__int64 left,
__int64 right
)
J#
public static void NotBetween(
long test,
long left,
long right
)
JScript
public static function NotBetween(
test : long,
left : long,
right : long
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotBetween Method (Single, Single, Single)

OldAssert.NotBetween Method (Single, Single, Single)
See Also Example
[image]

Asserts that test is not between left and right.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotBetween( _
ByVal test As Single, _
ByVal left As Single, _
ByVal right As Single _
)
C#
public static void NotBetween(
float test,
float left,
float right
)
C++
public:
static void NotBetween(
float test,
float left,
float right
)
J#
public static void NotBetween(
float test,
float left,
float right
)
JScript
public static function NotBetween(
test : float,
left : float,
right : float
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotBetween Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method

OldAssert.NotIn Method

Asserts that test is not in the dic dic.

Overload List

Name | Description
NotIn (Object, IDictionary) | Asserts that test is not in the dic dic.
NotIn (Object, IDictionary, String) | Asserts that test is not in the dic dic.
NotIn (Object, IEnumerable) | Asserts that test is not in the enumerable collection enumerable.
NotIn (Object, IEnumerable, String) | Asserts that test is not in the enumerable collection enumerable.
NotIn (Object, IList) | Asserts that test is not in the list list.
NotIn (Object, IList, String) | Asserts that test is not in the list list.

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method (Object, IDictionary)

OldAssert.NotIn Method (Object, IDictionary)
See Also Example
[image]

Asserts that test is not in the dic dic.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotIn( _
ByVal test As Object, _
ByVal dic As IDictionary _
)
C#
public static void NotIn(
object test,
IDictionary dic
)
C++
public:
static void NotIn(
Object test,
IDictionary dic
)
J#
public static void NotIn(
object test,
IDictionary dic
)
JScript
public static function NotIn(
test : Object,
dic : IDictionary
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotIn Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method (Object, IDictionary, String)

OldAssert.NotIn Method (Object, IDictionary, String)
See Also Example
[image]

Asserts that test is not in the dic dic.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotIn( _
ByVal test As Object, _
ByVal dic As IDictionary, _
ByVal message As String _
)
C#
public static void NotIn(
object test,
IDictionary dic,
string message
)
C++
public:
static void NotIn(
Object test,
IDictionary dic,
String message
)
J#
public static void NotIn(
object test,
IDictionary dic,
string message
)
JScript
public static function NotIn(
test : Object,
dic : IDictionary,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotIn Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method (Object, IEnumerable)

OldAssert.NotIn Method (Object, IEnumerable)
See Also Example
[image]

Asserts that test is not in the enumerable collection enumerable.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotIn( _
ByVal test As Object, _
ByVal enumerable As IEnumerable _
)
C#
public static void NotIn(
object test,
IEnumerable enumerable
)
C++
public:
static void NotIn(
Object test,
IEnumerable enumerable
)
J#
public static void NotIn(
object test,
IEnumerable enumerable
)
JScript
public static function NotIn(
test : Object,
enumerable : IEnumerable
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotIn Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method (Object, IEnumerable, String)

OldAssert.NotIn Method (Object, IEnumerable, String)
See Also Example
[image]

Asserts that test is not in the enumerable collection enumerable.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotIn( _
ByVal test As Object, _
ByVal enumerable As IEnumerable, _
ByVal message As String _
)
C#
public static void NotIn(
object test,
IEnumerable enumerable,
string message
)
C++
public:
static void NotIn(
Object test,
IEnumerable enumerable,
String message
)
J#
public static void NotIn(
object test,
IEnumerable enumerable,
string message
)
JScript
public static function NotIn(
test : Object,
enumerable : IEnumerable,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotIn Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method (Object, IList)

OldAssert.NotIn Method (Object, IList)
See Also Example
[image]

Asserts that test is not in the list list.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotIn( _
ByVal test As Object, _
ByVal list As IList _
)
C#
public static void NotIn(
object test,
IList list
)
C++
public:
static void NotIn(
Object test,
IList list
)
J#
public static void NotIn(
object test,
IList list
)
JScript
public static function NotIn(
test : Object,
list : IList
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotIn Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotIn Method (Object, IList, String)

OldAssert.NotIn Method (Object, IList, String)
See Also Example
[image]

Asserts that test is not in the list list.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotIn( _
ByVal test As Object, _
ByVal list As IList, _
ByVal message As String _
)
C#
public static void NotIn(
object test,
IList list,
string message
)
C++
public:
static void NotIn(
Object test,
IList list,
String message
)
J#
public static void NotIn(
object test,
IList list,
string message
)
JScript
public static function NotIn(
test : Object,
list : IList,
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.NotIn Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ReferenceEquals Method

OldAssert.ReferenceEquals Method
[image]

override the default ReferenceEquals to throw an AssertionException. This implementation makes sure there is no mistake in calling this function as part of Assert.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ReferenceEquals( _
ByVal a As Object, _
ByVal b As Object _
)
C#
public static void ReferenceEquals(
object a,
object b
)
C++
public:
static void ReferenceEquals(
Object a,
Object b
)
J#
public static void ReferenceEquals(
object a,
object b
)
JScript
public static function ReferenceEquals(
a : Object,
b : Object
)

Parameters

a
b

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Warning Method

OldAssert.Warning Method

Overload List

Name | Description
Warning (String) |
Warning (String, Object) |

See Also

OldAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Warning Method (String)

OldAssert.Warning Method (String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Warning( _
ByVal message As String _
)
C#
public static void Warning(
string message
)
C++
public:
static void Warning(
String message
)
J#
public static void Warning(
string message
)
JScript
public static function Warning(
message : String
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Warning Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Warning Method (String, Object[])

OldAssert.Warning Method (String, Object[])
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Warning( _
ByVal format As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Warning(
string format,
params object[] args
)
C++
public:
static void Warning(
String format,
... array<Object>^ args
)
J#
public static void Warning(
string format,
object[] args
)
JScript
public static function Warning(
format : String,
ParamArrayAttribute args : Object[]
)

See Also

OldAssert Class
MbUnit.Framework Namespace
OldAssert.Warning Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldCollectionAssert Class

OldCollectionAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Assertion helper for the ICollection class. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldCollectionAssert
C#
public static class OldCollectionAssert
C++
ref class OldCollectionAssert abstract sealed
J#
public final class OldCollectionAssert
JScript
public class OldCollectionAssert

Remarks

This class contains static helper methods to verify assertions on the ICollection class.

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldCollectionAssert

See Also

OldCollectionAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldCollectionAssert Members

OldCollectionAssert Members
See Also Example Methods
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Assertion helper for the ICollection class. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldCollectionAssert.

Public Methods

Name | Description
AllItemsAreInstancesOfType | Overloaded. Asserts that all items contained in collection are of the type specified by expectedType.
AllItemsAreNotNull | Overloaded. Asserts that all items contained in collection are not equal to null.
AllItemsAreUnique | Overloaded. Ensures that every object contained in collection exists within the collection once and only once.
AreCountEqual | Overloaded. Verifies that the property value Count of expected and actual are equal.
AreElementsEqual | Verifies that expected and actual are equal collections. Element count and element wize equality is verified.
AreEqual | Verifies that expected and actual are equal collections. Element count and element wize equality is verified.
AreEquivalent | Overloaded. Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.
AreIsSynchronizedEqual | Overloaded. Verifies that the property value IsSynchronized of actual is equal to expected.
AreNotEqual | Overloaded. Asserts that expected and actual are not exactly equal.
AreNotEquivalent | Overloaded. Asserts that expected and actual are not equivalent.
AreSyncRootEqual | Overloaded. Verifies that the property value SyncRoot of expected and actual are equal.
Contains | Overloaded. Asserts that collection contains actual as an item.
DoesNotContain | Overloaded. Asserts that collection does not contain actual as an item.
IsCountCorrect | Verifies that the Count property is synchronized with the number of iterated elements.
IsNotSubsetOf | Overloaded. Asserts that subset is not a subset of superset.
IsNotSynchronized | Verifies that the property value IsSynchronized is false.
IsSubsetOf | Overloaded. Asserts that subset is a subset of superset.
IsSynchronized | Verifies that the property value IsSynchronized is true.
Top

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldCollectionAssert Methods
[image]

Public Methods

Name | Description
AllItemsAreInstancesOfType | Overloaded. Asserts that all items contained in collection are of the type specified by expectedType.
AllItemsAreNotNull | Overloaded. Asserts that all items contained in collection are not equal to null.
AllItemsAreUnique | Overloaded. Ensures that every object contained in collection exists within the collection once and only once.
AreCountEqual | Overloaded. Verifies that the property value Count of expected and actual are equal.
AreElementsEqual | Verifies that expected and actual are equal collections. Element count and element wize equality is verified.
AreEqual | Verifies that expected and actual are equal collections. Element count and element wize equality is verified.
AreEquivalent | Overloaded. Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.
AreIsSynchronizedEqual | Overloaded. Verifies that the property value IsSynchronized of actual is equal to expected.
AreNotEqual | Overloaded. Asserts that expected and actual are not exactly equal.
AreNotEquivalent | Overloaded. Asserts that expected and actual are not equivalent.
AreSyncRootEqual | Overloaded. Verifies that the property value SyncRoot of expected and actual are equal.
Contains | Overloaded. Asserts that collection contains actual as an item.
DoesNotContain | Overloaded. Asserts that collection does not contain actual as an item.
IsCountCorrect | Verifies that the Count property is synchronized with the number of iterated elements.
IsNotSubsetOf | Overloaded. Asserts that subset is not a subset of superset.
IsNotSynchronized | Verifies that the property value IsSynchronized is false.
IsSubsetOf | Overloaded. Asserts that subset is a subset of superset.
IsSynchronized | Verifies that the property value IsSynchronized is true.
Top

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreInstancesOfType Method

OldCollectionAssert.AllItemsAreInstancesOfType Method

Asserts that all items contained in collection are of the type specified by expectedType.

Overload List

Name | Description
AllItemsAreInstancesOfType (ICollection, Type) | Asserts that all items contained in collection are of the type specified by expectedType.
AllItemsAreInstancesOfType (ICollection, Type, String) | Asserts that all items contained in collection are of the type specified by expectedType.
AllItemsAreInstancesOfType (ICollection, Type, String, Object) | Asserts that all items contained in collection are of the type specified by expectedType.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreInstancesOfType Method (ICollection, Type)

OldCollectionAssert.AllItemsAreInstancesOfType Method (ICollection, Type)
See Also Example
[image]

Asserts that all items contained in collection are of the type specified by expectedType.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreInstancesOfType( _
ByVal collection As ICollection, _
ByVal expectedType As Type _
)
C#
public static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType
)
C++
public:
static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType
)
J#
public static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType
)
JScript
public static function AllItemsAreInstancesOfType(
collection : ICollection,
expectedType : Type
)

Parameters

collection
ICollection of objects to be considered
expectedType
System.Type that all objects in collection must be instances of

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreInstancesOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreInstancesOfType Method (ICollection, Type, String)

OldCollectionAssert.AllItemsAreInstancesOfType Method (ICollection, Type, String)
See Also Example
[image]

Asserts that all items contained in collection are of the type specified by expectedType.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreInstancesOfType( _
ByVal collection As ICollection, _
ByVal expectedType As Type, _
ByVal message As String _
)
C#
public static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType,
string message
)
C++
public:
static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType,
String message
)
J#
public static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType,
string message
)
JScript
public static function AllItemsAreInstancesOfType(
collection : ICollection,
expectedType : Type,
message : String
)

Parameters

collection
ICollection of objects to be considered
expectedType
System.Type that all objects in collection must be instances of
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreInstancesOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreInstancesOfType Method (ICollection, Type, String, Object[])

OldCollectionAssert.AllItemsAreInstancesOfType Method (ICollection, Type, String, Object[])
See Also Example
[image]

Asserts that all items contained in collection are of the type specified by expectedType.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreInstancesOfType( _
ByVal collection As ICollection, _
ByVal expectedType As Type, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType,
string message,
params object[] args
)
C++
public:
static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType,
String message,
... array<Object>^ args
)
J#
public static void AllItemsAreInstancesOfType(
ICollection collection,
Type expectedType,
string message,
object[] args
)
JScript
public static function AllItemsAreInstancesOfType(
collection : ICollection,
expectedType : Type,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
ICollection of objects to be considered
expectedType
System.Type that all objects in collection must be instances of
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreInstancesOfType Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreNotNull Method

OldCollectionAssert.AllItemsAreNotNull Method

Asserts that all items contained in collection are not equal to null.

Overload List

Name | Description
AllItemsAreNotNull (ICollection) | Asserts that all items contained in collection are not equal to null.
AllItemsAreNotNull (ICollection, String) | Asserts that all items contained in collection are not equal to null.
AllItemsAreNotNull (ICollection, String, Object) | Asserts that all items contained in collection are not equal to null.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreNotNull Method (ICollection)

OldCollectionAssert.AllItemsAreNotNull Method (ICollection)
See Also Example
[image]

Asserts that all items contained in collection are not equal to null.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreNotNull( _
ByVal collection As ICollection _
)
C#
public static void AllItemsAreNotNull(
ICollection collection
)
C++
public:
static void AllItemsAreNotNull(
ICollection collection
)
J#
public static void AllItemsAreNotNull(
ICollection collection
)
JScript
public static function AllItemsAreNotNull(
collection : ICollection
)

Parameters

collection
ICollection of objects to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreNotNull Method (ICollection, String)

OldCollectionAssert.AllItemsAreNotNull Method (ICollection, String)
See Also Example
[image]

Asserts that all items contained in collection are not equal to null.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreNotNull( _
ByVal collection As ICollection, _
ByVal message As String _
)
C#
public static void AllItemsAreNotNull(
ICollection collection,
string message
)
C++
public:
static void AllItemsAreNotNull(
ICollection collection,
String message
)
J#
public static void AllItemsAreNotNull(
ICollection collection,
string message
)
JScript
public static function AllItemsAreNotNull(
collection : ICollection,
message : String
)

Parameters

collection
ICollection of objects to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreNotNull Method (ICollection, String, Object[])

OldCollectionAssert.AllItemsAreNotNull Method (ICollection, String, Object[])
See Also Example
[image]

Asserts that all items contained in collection are not equal to null.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreNotNull( _
ByVal collection As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AllItemsAreNotNull(
ICollection collection,
string message,
params object[] args
)
C++
public:
static void AllItemsAreNotNull(
ICollection collection,
String message,
... array<Object>^ args
)
J#
public static void AllItemsAreNotNull(
ICollection collection,
string message,
object[] args
)
JScript
public static function AllItemsAreNotNull(
collection : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
ICollection of objects to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreNotNull Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreUnique Method

OldCollectionAssert.AllItemsAreUnique Method

Ensures that every object contained in collection exists within the collection once and only once.

Overload List

Name | Description
AllItemsAreUnique (ICollection) | Ensures that every object contained in collection exists within the collection once and only once.
AllItemsAreUnique (ICollection, String) | Ensures that every object contained in collection exists within the collection once and only once.
AllItemsAreUnique (ICollection, String, Object) | Ensures that every object contained in collection exists within the collection once and only once.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreUnique Method (ICollection)

OldCollectionAssert.AllItemsAreUnique Method (ICollection)
See Also Example
[image]

Ensures that every object contained in collection exists within the collection once and only once.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreUnique( _
ByVal collection As ICollection _
)
C#
public static void AllItemsAreUnique(
ICollection collection
)
C++
public:
static void AllItemsAreUnique(
ICollection collection
)
J#
public static void AllItemsAreUnique(
ICollection collection
)
JScript
public static function AllItemsAreUnique(
collection : ICollection
)

Parameters

collection
ICollection of objects to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreUnique Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreUnique Method (ICollection, String)

OldCollectionAssert.AllItemsAreUnique Method (ICollection, String)
See Also Example
[image]

Ensures that every object contained in collection exists within the collection once and only once.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreUnique( _
ByVal collection As ICollection, _
ByVal message As String _
)
C#
public static void AllItemsAreUnique(
ICollection collection,
string message
)
C++
public:
static void AllItemsAreUnique(
ICollection collection,
String message
)
J#
public static void AllItemsAreUnique(
ICollection collection,
string message
)
JScript
public static function AllItemsAreUnique(
collection : ICollection,
message : String
)

Parameters

collection
ICollection of objects to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreUnique Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AllItemsAreUnique Method (ICollection, String, Object[])

OldCollectionAssert.AllItemsAreUnique Method (ICollection, String, Object[])
See Also Example
[image]

Ensures that every object contained in collection exists within the collection once and only once.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AllItemsAreUnique( _
ByVal collection As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AllItemsAreUnique(
ICollection collection,
string message,
params object[] args
)
C++
public:
static void AllItemsAreUnique(
ICollection collection,
String message,
... array<Object>^ args
)
J#
public static void AllItemsAreUnique(
ICollection collection,
string message,
object[] args
)
JScript
public static function AllItemsAreUnique(
collection : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
ICollection of objects to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AllItemsAreUnique Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreCountEqual Method

OldCollectionAssert.AreCountEqual Method

Verifies that the property value Count of expected and actual are equal.

Overload List

Name | Description
AreCountEqual (ICollection, ICollection) | Verifies that the property value Count of expected and actual are equal.
AreCountEqual (Int32, ICollection) | Verifies that the property value Count of actual is equal to expected.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreCountEqual Method (ICollection, ICollection)

OldCollectionAssert.AreCountEqual Method (ICollection, ICollection)
See Also Example
[image]

Verifies that the property value Count of expected and actual are equal.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreCountEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreCountEqual(
ICollection expected,
ICollection actual
)
C++
public:
static void AreCountEqual(
ICollection expected,
ICollection actual
)
J#
public static void AreCountEqual(
ICollection expected,
ICollection actual
)
JScript
public static function AreCountEqual(
expected : ICollection,
actual : ICollection
)

Parameters

expected
Instance containing the expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreCountEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreCountEqual Method (Int32, ICollection)

OldCollectionAssert.AreCountEqual Method (Int32, ICollection)
See Also Example
[image]

Verifies that the property value Count of actual is equal to expected.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreCountEqual( _
ByVal expected As Integer, _
ByVal actual As ICollection _
)
C#
public static void AreCountEqual(
int expected,
ICollection actual
)
C++
public:
static void AreCountEqual(
int expected,
ICollection actual
)
J#
public static void AreCountEqual(
int expected,
ICollection actual
)
JScript
public static function AreCountEqual(
expected : int,
actual : ICollection
)

Parameters

expected
Expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreCountEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreElementsEqual Method

OldCollectionAssert.AreElementsEqual Method
[image]

Verifies that expected and actual are equal collections. Element count and element wize equality is verified.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreElementsEqual( _
ByVal expected As IEnumerable, _
ByVal actual As IEnumerable _
)
C#
public static void AreElementsEqual(
IEnumerable expected,
IEnumerable actual
)
C++
public:
static void AreElementsEqual(
IEnumerable expected,
IEnumerable actual
)
J#
public static void AreElementsEqual(
IEnumerable expected,
IEnumerable actual
)
JScript
public static function AreElementsEqual(
expected : IEnumerable,
actual : IEnumerable
)

Parameters

expected
Expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method

OldCollectionAssert.AreEqual Method
[image]

Verifies that expected and actual are equal collections. Element count and element wize equality is verified.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreEqual(
ICollection expected,
ICollection actual
)
C++
public:
static void AreEqual(
ICollection expected,
ICollection actual
)
J#
public static void AreEqual(
ICollection expected,
ICollection actual
)
JScript
public static function AreEqual(
expected : ICollection,
actual : ICollection
)

Parameters

expected
Expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEquivalent Method

OldCollectionAssert.AreEquivalent Method

Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.

Overload List

Name | Description
AreEquivalent (ICollection, ICollection) | Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.
AreEquivalent (ICollection, ICollection, String) | Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.
AreEquivalent (ICollection, ICollection, String, Object) | Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEquivalent Method (ICollection, ICollection)

OldCollectionAssert.AreEquivalent Method (ICollection, ICollection)
See Also Example
[image]

Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEquivalent( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreEquivalent(
ICollection expected,
ICollection actual
)
C++
public:
static void AreEquivalent(
ICollection expected,
ICollection actual
)
J#
public static void AreEquivalent(
ICollection expected,
ICollection actual
)
JScript
public static function AreEquivalent(
expected : ICollection,
actual : ICollection
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreEquivalent Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEquivalent Method (ICollection, ICollection, String)

OldCollectionAssert.AreEquivalent Method (ICollection, ICollection, String)
See Also Example
[image]

Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEquivalent( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal message As String _
)
C#
public static void AreEquivalent(
ICollection expected,
ICollection actual,
string message
)
C++
public:
static void AreEquivalent(
ICollection expected,
ICollection actual,
String message
)
J#
public static void AreEquivalent(
ICollection expected,
ICollection actual,
string message
)
JScript
public static function AreEquivalent(
expected : ICollection,
actual : ICollection,
message : String
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreEquivalent Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEquivalent Method (ICollection, ICollection, String, Object[])

OldCollectionAssert.AreEquivalent Method (ICollection, ICollection, String, Object[])
See Also Example
[image]

Asserts that expected and actual are equivalent, containing the same objects but the match may be in any order.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEquivalent( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreEquivalent(
ICollection expected,
ICollection actual,
string message,
params object[] args
)
C++
public:
static void AreEquivalent(
ICollection expected,
ICollection actual,
String message,
... array<Object>^ args
)
J#
public static void AreEquivalent(
ICollection expected,
ICollection actual,
string message,
object[] args
)
JScript
public static function AreEquivalent(
expected : ICollection,
actual : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreEquivalent Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreIsSynchronizedEqual Method

OldCollectionAssert.AreIsSynchronizedEqual Method

Verifies that the property value IsSynchronized of actual is equal to expected.

Overload List

Name | Description
AreIsSynchronizedEqual (Boolean, ICollection) | Verifies that the property value IsSynchronized of actual is equal to expected.
AreIsSynchronizedEqual (ICollection, ICollection) | Verifies that the property value IsSynchronized of expected and actual are equal.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreIsSynchronizedEqual Method (Boolean, ICollection)

OldCollectionAssert.AreIsSynchronizedEqual Method (Boolean, ICollection)
See Also Example
[image]

Verifies that the property value IsSynchronized of actual is equal to expected.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreIsSynchronizedEqual( _
ByVal expected As Boolean, _
ByVal actual As ICollection _
)
C#
public static void AreIsSynchronizedEqual(
bool expected,
ICollection actual
)
C++
public:
static void AreIsSynchronizedEqual(
bool expected,
ICollection actual
)
J#
public static void AreIsSynchronizedEqual(
bool expected,
ICollection actual
)
JScript
public static function AreIsSynchronizedEqual(
expected : bool,
actual : ICollection
)

Parameters

expected
Expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreIsSynchronizedEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreIsSynchronizedEqual Method (ICollection, ICollection)

OldCollectionAssert.AreIsSynchronizedEqual Method (ICollection, ICollection)
See Also Example
[image]

Verifies that the property value IsSynchronized of expected and actual are equal.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreIsSynchronizedEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreIsSynchronizedEqual(
ICollection expected,
ICollection actual
)
C++
public:
static void AreIsSynchronizedEqual(
ICollection expected,
ICollection actual
)
J#
public static void AreIsSynchronizedEqual(
ICollection expected,
ICollection actual
)
JScript
public static function AreIsSynchronizedEqual(
expected : ICollection,
actual : ICollection
)

Parameters

expected
Instance containing the expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreIsSynchronizedEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method

OldCollectionAssert.AreNotEqual Method

Asserts that expected and actual are not exactly equal.

Overload List

Name | Description
AreNotEqual (ICollection, ICollection) | Asserts that expected and actual are not exactly equal.
AreNotEqual (ICollection, ICollection, IComparer) | Asserts that expected and actual are not exactly equal. If comparer is not null then it will be used to compare the objects.
AreNotEqual (ICollection, ICollection, IComparer, String) | Asserts that expected and actual are not exactly equal. If comparer is not null then it will be used to compare the objects.
AreNotEqual (ICollection, ICollection, IComparer, String, Object) | Asserts that expected and actual are not exactly equal. If comparer is not null then it will be used to compare the objects.
AreNotEqual (ICollection, ICollection, String) | Asserts that expected and actual are not exactly equal.
AreNotEqual (ICollection, ICollection, String, Object) | Asserts that expected and actual are not exactly equal.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (ICollection, ICollection)

OldCollectionAssert.AreNotEqual Method (ICollection, ICollection)
See Also Example
[image]

Asserts that expected and actual are not exactly equal.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreNotEqual(
ICollection expected,
ICollection actual
)
C++
public:
static void AreNotEqual(
ICollection expected,
ICollection actual
)
J#
public static void AreNotEqual(
ICollection expected,
ICollection actual
)
JScript
public static function AreNotEqual(
expected : ICollection,
actual : ICollection
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (ICollection, ICollection, IComparer)

OldCollectionAssert.AreNotEqual Method (ICollection, ICollection, IComparer)
See Also Example
[image]

Asserts that expected and actual are not exactly equal. If comparer is not null then it will be used to compare the objects.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal comparer As IComparer _
)
C#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer
)
C++
public:
static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer
)
J#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer
)
JScript
public static function AreNotEqual(
expected : ICollection,
actual : ICollection,
comparer : IComparer
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
comparer
The IComparer to use in comparing objects from each ICollection

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (ICollection, ICollection, IComparer, String)

OldCollectionAssert.AreNotEqual Method (ICollection, ICollection, IComparer, String)
See Also Example
[image]

Asserts that expected and actual are not exactly equal. If comparer is not null then it will be used to compare the objects.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal comparer As IComparer, _
ByVal message As String _
)
C#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer,
string message
)
C++
public:
static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer,
String message
)
J#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer,
string message
)
JScript
public static function AreNotEqual(
expected : ICollection,
actual : ICollection,
comparer : IComparer,
message : String
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
comparer
The IComparer to use in comparing objects from each ICollection
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (ICollection, ICollection, IComparer, String, Object[])

OldCollectionAssert.AreNotEqual Method (ICollection, ICollection, IComparer, String, Object[])
See Also Example
[image]

Asserts that expected and actual are not exactly equal. If comparer is not null then it will be used to compare the objects.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal comparer As IComparer, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
IComparer comparer,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : ICollection,
actual : ICollection,
comparer : IComparer,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
comparer
The IComparer to use in comparing objects from each ICollection
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (ICollection, ICollection, String)

OldCollectionAssert.AreNotEqual Method (ICollection, ICollection, String)
See Also Example
[image]

Asserts that expected and actual are not exactly equal.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal message As String _
)
C#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
string message
)
C++
public:
static void AreNotEqual(
ICollection expected,
ICollection actual,
String message
)
J#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
string message
)
JScript
public static function AreNotEqual(
expected : ICollection,
actual : ICollection,
message : String
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEqual Method (ICollection, ICollection, String, Object[])

OldCollectionAssert.AreNotEqual Method (ICollection, ICollection, String, Object[])
See Also Example
[image]

Asserts that expected and actual are not exactly equal.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
string message,
params object[] args
)
C++
public:
static void AreNotEqual(
ICollection expected,
ICollection actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEqual(
ICollection expected,
ICollection actual,
string message,
object[] args
)
JScript
public static function AreNotEqual(
expected : ICollection,
actual : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEquivalent Method

OldCollectionAssert.AreNotEquivalent Method

Asserts that expected and actual are not equivalent.

Overload List

Name | Description
AreNotEquivalent (ICollection, ICollection) | Asserts that expected and actual are not equivalent.
AreNotEquivalent (ICollection, ICollection, String) | Asserts that expected and actual are not equivalent.
AreNotEquivalent (ICollection, ICollection, String, Object) | Asserts that expected and actual are not equivalent.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEquivalent Method (ICollection, ICollection)

OldCollectionAssert.AreNotEquivalent Method (ICollection, ICollection)
See Also Example
[image]

Asserts that expected and actual are not equivalent.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEquivalent( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreNotEquivalent(
ICollection expected,
ICollection actual
)
C++
public:
static void AreNotEquivalent(
ICollection expected,
ICollection actual
)
J#
public static void AreNotEquivalent(
ICollection expected,
ICollection actual
)
JScript
public static function AreNotEquivalent(
expected : ICollection,
actual : ICollection
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEquivalent Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEquivalent Method (ICollection, ICollection, String)

OldCollectionAssert.AreNotEquivalent Method (ICollection, ICollection, String)
See Also Example
[image]

Asserts that expected and actual are not equivalent.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEquivalent( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal message As String _
)
C#
public static void AreNotEquivalent(
ICollection expected,
ICollection actual,
string message
)
C++
public:
static void AreNotEquivalent(
ICollection expected,
ICollection actual,
String message
)
J#
public static void AreNotEquivalent(
ICollection expected,
ICollection actual,
string message
)
JScript
public static function AreNotEquivalent(
expected : ICollection,
actual : ICollection,
message : String
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEquivalent Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreNotEquivalent Method (ICollection, ICollection, String, Object[])

OldCollectionAssert.AreNotEquivalent Method (ICollection, ICollection, String, Object[])
See Also Example
[image]

Asserts that expected and actual are not equivalent.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreNotEquivalent( _
ByVal expected As ICollection, _
ByVal actual As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void AreNotEquivalent(
ICollection expected,
ICollection actual,
string message,
params object[] args
)
C++
public:
static void AreNotEquivalent(
ICollection expected,
ICollection actual,
String message,
... array<Object>^ args
)
J#
public static void AreNotEquivalent(
ICollection expected,
ICollection actual,
string message,
object[] args
)
JScript
public static function AreNotEquivalent(
expected : ICollection,
actual : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

expected
The first ICollection of objects to be considered
actual
The second ICollection of objects to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreNotEquivalent Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSyncRootEqual Method

OldCollectionAssert.AreSyncRootEqual Method

Verifies that the property value SyncRoot of expected and actual are equal.

Overload List

Name | Description
AreSyncRootEqual (ICollection, ICollection) | Verifies that the property value SyncRoot of expected and actual are equal.
AreSyncRootEqual (Object, ICollection) | Verifies that the property value SyncRoot of actual is equal to expected.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSyncRootEqual Method (ICollection, ICollection)

OldCollectionAssert.AreSyncRootEqual Method (ICollection, ICollection)
See Also Example
[image]

Verifies that the property value SyncRoot of expected and actual are equal.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSyncRootEqual( _
ByVal expected As ICollection, _
ByVal actual As ICollection _
)
C#
public static void AreSyncRootEqual(
ICollection expected,
ICollection actual
)
C++
public:
static void AreSyncRootEqual(
ICollection expected,
ICollection actual
)
J#
public static void AreSyncRootEqual(
ICollection expected,
ICollection actual
)
JScript
public static function AreSyncRootEqual(
expected : ICollection,
actual : ICollection
)

Parameters

expected
Instance containing the expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreSyncRootEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreSyncRootEqual Method (Object, ICollection)

OldCollectionAssert.AreSyncRootEqual Method (Object, ICollection)
See Also Example
[image]

Verifies that the property value SyncRoot of actual is equal to expected.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreSyncRootEqual( _
ByVal expected As Object, _
ByVal actual As ICollection _
)
C#
public static void AreSyncRootEqual(
object expected,
ICollection actual
)
C++
public:
static void AreSyncRootEqual(
Object expected,
ICollection actual
)
J#
public static void AreSyncRootEqual(
object expected,
ICollection actual
)
JScript
public static function AreSyncRootEqual(
expected : Object,
actual : ICollection
)

Parameters

expected
Expected value.
actual
Instance containing the tested value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.AreSyncRootEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Contains Method

OldCollectionAssert.Contains Method

Asserts that collection contains actual as an item.

Overload List

Name | Description
Contains (ICollection, Object) | Asserts that collection contains actual as an item.
Contains (ICollection, Object, String) | Asserts that collection contains actual as an item.
Contains (ICollection, Object, String, Object) | Asserts that collection contains actual as an item.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Contains Method (ICollection, Object)

OldCollectionAssert.Contains Method (ICollection, Object)
See Also Example
[image]

Asserts that collection contains actual as an item.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal collection As ICollection, _
ByVal actual As Object _
)
C#
public static void Contains(
ICollection collection,
object actual
)
C++
public:
static void Contains(
ICollection collection,
Object actual
)
J#
public static void Contains(
ICollection collection,
object actual
)
JScript
public static function Contains(
collection : ICollection,
actual : Object
)

Parameters

collection
ICollection of objects to be considered
actual
Object to be found within collection

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Contains Method (ICollection, Object, String)

OldCollectionAssert.Contains Method (ICollection, Object, String)
See Also Example
[image]

Asserts that collection contains actual as an item.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal collection As ICollection, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void Contains(
ICollection collection,
object actual,
string message
)
C++
public:
static void Contains(
ICollection collection,
Object actual,
String message
)
J#
public static void Contains(
ICollection collection,
object actual,
string message
)
JScript
public static function Contains(
collection : ICollection,
actual : Object,
message : String
)

Parameters

collection
ICollection of objects to be considered
actual
Object to be found within collection
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Contains Method (ICollection, Object, String, Object[])

OldCollectionAssert.Contains Method (ICollection, Object, String, Object[])
See Also Example
[image]

Asserts that collection contains actual as an item.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal collection As ICollection, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void Contains(
ICollection collection,
object actual,
string message,
params object[] args
)
C++
public:
static void Contains(
ICollection collection,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void Contains(
ICollection collection,
object actual,
string message,
object[] args
)
JScript
public static function Contains(
collection : ICollection,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
ICollection of objects to be considered
actual
Object to be found within collection
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.Contains Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DoesNotContain Method

OldCollectionAssert.DoesNotContain Method

Asserts that collection does not contain actual as an item.

Overload List

Name | Description
DoesNotContain (ICollection, Object) | Asserts that collection does not contain actual as an item.
DoesNotContain (ICollection, Object, String) | Asserts that collection does not contain actual as an item.
DoesNotContain (ICollection, Object, String, Object) | Asserts that collection does not contain actual as an item.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DoesNotContain Method (ICollection, Object)

OldCollectionAssert.DoesNotContain Method (ICollection, Object)
See Also Example
[image]

Asserts that collection does not contain actual as an item.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain( _
ByVal collection As ICollection, _
ByVal actual As Object _
)
C#
public static void DoesNotContain(
ICollection collection,
object actual
)
C++
public:
static void DoesNotContain(
ICollection collection,
Object actual
)
J#
public static void DoesNotContain(
ICollection collection,
object actual
)
JScript
public static function DoesNotContain(
collection : ICollection,
actual : Object
)

Parameters

collection
ICollection of objects to be considered
actual
Object that cannot exist within collection

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DoesNotContain Method (ICollection, Object, String)

OldCollectionAssert.DoesNotContain Method (ICollection, Object, String)
See Also Example
[image]

Asserts that collection does not contain actual as an item.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain( _
ByVal collection As ICollection, _
ByVal actual As Object, _
ByVal message As String _
)
C#
public static void DoesNotContain(
ICollection collection,
object actual,
string message
)
C++
public:
static void DoesNotContain(
ICollection collection,
Object actual,
String message
)
J#
public static void DoesNotContain(
ICollection collection,
object actual,
string message
)
JScript
public static function DoesNotContain(
collection : ICollection,
actual : Object,
message : String
)

Parameters

collection
ICollection of objects to be considered
actual
Object that cannot exist within collection
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DoesNotContain Method (ICollection, Object, String, Object[])

OldCollectionAssert.DoesNotContain Method (ICollection, Object, String, Object[])
See Also Example
[image]

Asserts that collection does not contain actual as an item.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain( _
ByVal collection As ICollection, _
ByVal actual As Object, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void DoesNotContain(
ICollection collection,
object actual,
string message,
params object[] args
)
C++
public:
static void DoesNotContain(
ICollection collection,
Object actual,
String message,
... array<Object>^ args
)
J#
public static void DoesNotContain(
ICollection collection,
object actual,
string message,
object[] args
)
JScript
public static function DoesNotContain(
collection : ICollection,
actual : Object,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

collection
ICollection of objects to be considered
actual
Object that cannot exist within collection
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.DoesNotContain Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsCountCorrect Method

OldCollectionAssert.IsCountCorrect Method
[image]

Verifies that the Count property is synchronized with the number of iterated elements.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsCountCorrect( _
ByVal col As ICollection _
)
C#
public static void IsCountCorrect(
ICollection col
)
C++
public:
static void IsCountCorrect(
ICollection col
)
J#
public static void IsCountCorrect(
ICollection col
)
JScript
public static function IsCountCorrect(
col : ICollection
)

Parameters

col
Collection to test

Exceptions

Exception Type | Condition
ArgumentNullException | col is a null reference (Nothing in Visual Basic)

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotSubsetOf Method

OldCollectionAssert.IsNotSubsetOf Method

Asserts that subset is not a subset of superset.

Overload List

Name | Description
IsNotSubsetOf (ICollection, ICollection) | Asserts that subset is not a subset of superset.
IsNotSubsetOf (ICollection, ICollection, String) | Asserts that subset is not a subset of superset.
IsNotSubsetOf (ICollection, ICollection, String, Object) | Asserts that subset is not a subset of superset.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotSubsetOf Method (ICollection, ICollection)

OldCollectionAssert.IsNotSubsetOf Method (ICollection, ICollection)
See Also Example
[image]

Asserts that subset is not a subset of superset.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotSubsetOf( _
ByVal subset As ICollection, _
ByVal superset As ICollection _
)
C#
public static void IsNotSubsetOf(
ICollection subset,
ICollection superset
)
C++
public:
static void IsNotSubsetOf(
ICollection subset,
ICollection superset
)
J#
public static void IsNotSubsetOf(
ICollection subset,
ICollection superset
)
JScript
public static function IsNotSubsetOf(
subset : ICollection,
superset : ICollection
)

Parameters

subset
The ICollection subset to be considered
superset
The ICollection superset to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.IsNotSubsetOf Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotSubsetOf Method (ICollection, ICollection, String)

OldCollectionAssert.IsNotSubsetOf Method (ICollection, ICollection, String)
See Also Example
[image]

Asserts that subset is not a subset of superset.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotSubsetOf( _
ByVal subset As ICollection, _
ByVal superset As ICollection, _
ByVal message As String _
)
C#
public static void IsNotSubsetOf(
ICollection subset,
ICollection superset,
string message
)
C++
public:
static void IsNotSubsetOf(
ICollection subset,
ICollection superset,
String message
)
J#
public static void IsNotSubsetOf(
ICollection subset,
ICollection superset,
string message
)
JScript
public static function IsNotSubsetOf(
subset : ICollection,
superset : ICollection,
message : String
)

Parameters

subset
The ICollection subset to be considered
superset
The ICollection superset to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.IsNotSubsetOf Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotSubsetOf Method (ICollection, ICollection, String, Object[])

OldCollectionAssert.IsNotSubsetOf Method (ICollection, ICollection, String, Object[])
See Also Example
[image]

Asserts that subset is not a subset of superset.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotSubsetOf( _
ByVal subset As ICollection, _
ByVal superset As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotSubsetOf(
ICollection subset,
ICollection superset,
string message,
params object[] args
)
C++
public:
static void IsNotSubsetOf(
ICollection subset,
ICollection superset,
String message,
... array<Object>^ args
)
J#
public static void IsNotSubsetOf(
ICollection subset,
ICollection superset,
string message,
object[] args
)
JScript
public static function IsNotSubsetOf(
subset : ICollection,
superset : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

subset
The ICollection subset to be considered
superset
The ICollection superset to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.IsNotSubsetOf Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotSynchronized Method

OldCollectionAssert.IsNotSynchronized Method
[image]

Verifies that the property value IsSynchronized is false.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotSynchronized( _
ByVal actual As ICollection _
)
C#
public static void IsNotSynchronized(
ICollection actual
)
C++
public:
static void IsNotSynchronized(
ICollection actual
)
J#
public static void IsNotSynchronized(
ICollection actual
)
JScript
public static function IsNotSynchronized(
actual : ICollection
)

Parameters

actual
Instance containing the expected value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsSubsetOf Method

OldCollectionAssert.IsSubsetOf Method

Asserts that subset is a subset of superset.

Overload List

Name | Description
IsSubsetOf (ICollection, ICollection) | Asserts that subset is a subset of superset.
IsSubsetOf (ICollection, ICollection, String) | Asserts that subset is a subset of superset.
IsSubsetOf (ICollection, ICollection, String, Object) | Asserts that subset is a subset of superset.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsSubsetOf Method (ICollection, ICollection)

OldCollectionAssert.IsSubsetOf Method (ICollection, ICollection)
See Also Example
[image]

Asserts that subset is a subset of superset.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSubsetOf( _
ByVal subset As ICollection, _
ByVal superset As ICollection _
)
C#
public static void IsSubsetOf(
ICollection subset,
ICollection superset
)
C++
public:
static void IsSubsetOf(
ICollection subset,
ICollection superset
)
J#
public static void IsSubsetOf(
ICollection subset,
ICollection superset
)
JScript
public static function IsSubsetOf(
subset : ICollection,
superset : ICollection
)

Parameters

subset
The ICollection subset to be considered
superset
The ICollection superset to be considered

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.IsSubsetOf Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsSubsetOf Method (ICollection, ICollection, String)

OldCollectionAssert.IsSubsetOf Method (ICollection, ICollection, String)
See Also Example
[image]

Asserts that subset is a subset of superset.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSubsetOf( _
ByVal subset As ICollection, _
ByVal superset As ICollection, _
ByVal message As String _
)
C#
public static void IsSubsetOf(
ICollection subset,
ICollection superset,
string message
)
C++
public:
static void IsSubsetOf(
ICollection subset,
ICollection superset,
String message
)
J#
public static void IsSubsetOf(
ICollection subset,
ICollection superset,
string message
)
JScript
public static function IsSubsetOf(
subset : ICollection,
superset : ICollection,
message : String
)

Parameters

subset
The ICollection subset to be considered
superset
The ICollection superset to be considered
message
The message that will be displayed on failure

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.IsSubsetOf Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsSubsetOf Method (ICollection, ICollection, String, Object[])

OldCollectionAssert.IsSubsetOf Method (ICollection, ICollection, String, Object[])
See Also Example
[image]

Asserts that subset is a subset of superset.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSubsetOf( _
ByVal subset As ICollection, _
ByVal superset As ICollection, _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsSubsetOf(
ICollection subset,
ICollection superset,
string message,
params object[] args
)
C++
public:
static void IsSubsetOf(
ICollection subset,
ICollection superset,
String message,
... array<Object>^ args
)
J#
public static void IsSubsetOf(
ICollection subset,
ICollection superset,
string message,
object[] args
)
JScript
public static function IsSubsetOf(
subset : ICollection,
superset : ICollection,
message : String,
ParamArrayAttribute args : Object[]
)

Parameters

subset
The ICollection subset to be considered
superset
The ICollection superset to be considered
message
The message that will be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace
OldCollectionAssert.IsSubsetOf Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsSynchronized Method

OldCollectionAssert.IsSynchronized Method
[image]

Verifies that the property value IsSynchronized is true.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSynchronized( _
ByVal actual As ICollection _
)
C#
public static void IsSynchronized(
ICollection actual
)
C++
public:
static void IsSynchronized(
ICollection actual
)
J#
public static void IsSynchronized(
ICollection actual
)
JScript
public static function IsSynchronized(
actual : ICollection
)

Parameters

actual
Instance containing the expected value.

See Also

OldCollectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldFileAssert Class

OldFileAssert Class
See Also Example Members
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldFileAssert
C#
public static class OldFileAssert
C++
ref class OldFileAssert abstract sealed
J#
public final class OldFileAssert
JScript
public class OldFileAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldFileAssert

See Also

OldFileAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldFileAssert Members

OldFileAssert Members
See Also Example Methods
[image]

The following tables list the members exposed by OldFileAssert.

Public Methods

Name | Description
AreEqual | Overloaded.
AreStreamContentEqual |
Exists |
NotExists |
Top

See Also

OldFileAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldFileAssert Methods
[image]

Public Methods

Name | Description
AreEqual | Overloaded.
AreStreamContentEqual |
Exists |
NotExists |
Top

See Also

OldFileAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method

OldFileAssert.AreEqual Method

Overload List

Name | Description
AreEqual (FileInfo, FileInfo) |
AreEqual (FileInfo, String) |
AreEqual (String, String) |

See Also

OldFileAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (FileInfo, FileInfo)

OldFileAssert.AreEqual Method (FileInfo, FileInfo)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As FileInfo, _
ByVal actual As FileInfo _
)
C#
public static void AreEqual(
FileInfo expected,
FileInfo actual
)
C++
public:
static void AreEqual(
FileInfo expected,
FileInfo actual
)
J#
public static void AreEqual(
FileInfo expected,
FileInfo actual
)
JScript
public static function AreEqual(
expected : FileInfo,
actual : FileInfo
)

See Also

OldFileAssert Class
MbUnit.Framework Namespace
OldFileAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (FileInfo, String)

OldFileAssert.AreEqual Method (FileInfo, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expected As FileInfo, _
ByVal filePath As String _
)
C#
public static void AreEqual(
FileInfo expected,
string filePath
)
C++
public:
static void AreEqual(
FileInfo expected,
String filePath
)
J#
public static void AreEqual(
FileInfo expected,
string filePath
)
JScript
public static function AreEqual(
expected : FileInfo,
filePath : String
)

See Also

OldFileAssert Class
MbUnit.Framework Namespace
OldFileAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqual Method (String, String)

OldFileAssert.AreEqual Method (String, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqual( _
ByVal expectedPath As String, _
ByVal actualPath As String _
)
C#
public static void AreEqual(
string expectedPath,
string actualPath
)
C++
public:
static void AreEqual(
String expectedPath,
String actualPath
)
J#
public static void AreEqual(
string expectedPath,
string actualPath
)
JScript
public static function AreEqual(
expectedPath : String,
actualPath : String
)

See Also

OldFileAssert Class
MbUnit.Framework Namespace
OldFileAssert.AreEqual Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreStreamContentEqual Method

OldFileAssert.AreStreamContentEqual Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreStreamContentEqual( _
ByVal expected As Stream, _
ByVal actual As Stream _
)
C#
public static void AreStreamContentEqual(
Stream expected,
Stream actual
)
C++
public:
static void AreStreamContentEqual(
Stream expected,
Stream actual
)
J#
public static void AreStreamContentEqual(
Stream expected,
Stream actual
)
JScript
public static function AreStreamContentEqual(
expected : Stream,
actual : Stream
)

See Also

OldFileAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Exists Method

OldFileAssert.Exists Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Exists( _
ByVal fileName As String _
)
C#
public static void Exists(
string fileName
)
C++
public:
static void Exists(
String fileName
)
J#
public static void Exists(
string fileName
)
JScript
public static function Exists(
fileName : String
)

See Also

OldFileAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotExists Method

OldFileAssert.NotExists Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotExists( _
ByVal fileName As String _
)
C#
public static void NotExists(
string fileName
)
C++
public:
static void NotExists(
String fileName
)
J#
public static void NotExists(
string fileName
)
JScript
public static function NotExists(
fileName : String
)

See Also

OldFileAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldGenericAssert Class

OldGenericAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Assertion class This class cannot be inherited.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OldGenericAssert
C#
public sealed class OldGenericAssert
C++
ref class OldGenericAssert sealed
J#
public final class OldGenericAssert
JScript
public final class OldGenericAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldGenericAssert

See Also

OldGenericAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldGenericAssert Members

OldGenericAssert Members
See Also Example Constructors Methods
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Assertion class This class cannot be inherited.

The following tables list the members exposed by OldGenericAssert.

Public Constructors

 | Name | Description
Public method | OldGenericAssert | Initializes a new instance of the OldGenericAssert class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | IsEmpty | Overloaded. Assert that an array,list or other collection is empty
 | IsNotEmpty | Overloaded. Assert that an array,list or other collection is empty
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

OldGenericAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldGenericAssert Constructor

OldGenericAssert Constructor
[image]

Initializes a new instance of the OldGenericAssert class.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public OldGenericAssert()
C++
public:
OldGenericAssert() sealed
J#
public OldGenericAssert()
JScript
public function OldGenericAssert()

See Also

OldGenericAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldGenericAssert Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | IsEmpty | Overloaded. Assert that an array,list or other collection is empty
 | IsNotEmpty | Overloaded. Assert that an array,list or other collection is empty
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

OldGenericAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Generic Method

OldGenericAssert.IsEmpty Generic Method

Assert that an array,list or other collection is empty

Overload List

Name | Description
IsEmpty (ICollection<T>) | Assert that an array,list or other collection is empty
IsEmpty (ICollection<T>, String) | Assert that an array, list or other collection is empty
IsEmpty (ICollection<T>, String, Object) | Assert that an array, list or other collection is empty

See Also

OldGenericAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Generic Method (Generic ICollection)

OldGenericAssert.IsEmpty Generic Method (Generic ICollection)
See Also Example
[image]

Assert that an array,list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty(Of T)( _
ByVal collection As ICollection(Of T) _
)
C#
public static void IsEmpty<T>(
ICollection<T> collection
)
C++
public:
static void IsEmpty<T>(
ICollection<T> collection
)
J#
public static void IsEmpty<T>(
ICollection<T> collection
)
JScript
JScript does not support generic types and methods.

Parameters

collection
An array, list or other collection implementing ICollection

See Also

OldGenericAssert Class
MbUnit.Framework Namespace
OldGenericAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Generic Method (Generic ICollection, String)

OldGenericAssert.IsEmpty Generic Method (Generic ICollection, String)
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty(Of T)( _
ByVal collection As ICollection(Of T), _
ByVal message As String _
)
C#
public static void IsEmpty<T>(
ICollection<T> collection,
string message
)
C++
public:
static void IsEmpty<T>(
ICollection<T> collection,
String message
)
J#
public static void IsEmpty<T>(
ICollection<T> collection,
string message
)
JScript
JScript does not support generic types and methods.

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure

See Also

OldGenericAssert Class
MbUnit.Framework Namespace
OldGenericAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Generic Method (Generic ICollection, String, Object[])

OldGenericAssert.IsEmpty Generic Method (Generic ICollection, String, Object[])
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty(Of T)( _
ByVal collection As ICollection(Of T), _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsEmpty<T>(
ICollection<T> collection,
string message,
params object[] args
)
C++
public:
static void IsEmpty<T>(
ICollection<T> collection,
String message,
... array<Object>^ args
)
J#
public static void IsEmpty<T>(
ICollection<T> collection,
string message,
object[] args
)
JScript
JScript does not support generic types and methods.

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldGenericAssert Class
MbUnit.Framework Namespace
OldGenericAssert.IsEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Generic Method

OldGenericAssert.IsNotEmpty Generic Method

Assert that an array,list or other collection is empty

Overload List

Name | Description
IsNotEmpty (ICollection<T>) | Assert that an array,list or other collection is empty
IsNotEmpty (ICollection<T>, String) | Assert that an array, list or other collection is empty
IsNotEmpty (ICollection<T>, String, Object) | Assert that an array, list or other collection is empty

See Also

OldGenericAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Generic Method (Generic ICollection)

OldGenericAssert.IsNotEmpty Generic Method (Generic ICollection)
See Also Example
[image]

Assert that an array,list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty(Of T)( _
ByVal collection As ICollection(Of T) _
)
C#
public static void IsNotEmpty<T>(
ICollection<T> collection
)
C++
public:
static void IsNotEmpty<T>(
ICollection<T> collection
)
J#
public static void IsNotEmpty<T>(
ICollection<T> collection
)
JScript
JScript does not support generic types and methods.

Parameters

collection
An array, list or other collection implementing ICollection

See Also

OldGenericAssert Class
MbUnit.Framework Namespace
OldGenericAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Generic Method (Generic ICollection, String)

OldGenericAssert.IsNotEmpty Generic Method (Generic ICollection, String)
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty(Of T)( _
ByVal collection As ICollection(Of T), _
ByVal message As String _
)
C#
public static void IsNotEmpty<T>(
ICollection<T> collection,
string message
)
C++
public:
static void IsNotEmpty<T>(
ICollection<T> collection,
String message
)
J#
public static void IsNotEmpty<T>(
ICollection<T> collection,
string message
)
JScript
JScript does not support generic types and methods.

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure

See Also

OldGenericAssert Class
MbUnit.Framework Namespace
OldGenericAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotEmpty Generic Method (Generic ICollection, String, Object[])

OldGenericAssert.IsNotEmpty Generic Method (Generic ICollection, String, Object[])
See Also Example
[image]

Assert that an array, list or other collection is empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotEmpty(Of T)( _
ByVal collection As ICollection(Of T), _
ByVal message As String, _
ByVal ParamArray args As Object() _
)
C#
public static void IsNotEmpty<T>(
ICollection<T> collection,
string message,
params object[] args
)
C++
public:
static void IsNotEmpty<T>(
ICollection<T> collection,
String message,
... array<Object>^ args
)
J#
public static void IsNotEmpty<T>(
ICollection<T> collection,
string message,
object[] args
)
JScript
JScript does not support generic types and methods.

Parameters

collection
An array, list or other collection implementing ICollection
message
The message to be displayed on failure
args
Arguments to be used in formatting the message

See Also

OldGenericAssert Class
MbUnit.Framework Namespace
OldGenericAssert.IsNotEmpty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldReflectionAssert Class

OldReflectionAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Reflection Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldReflectionAssert
C#
public static class OldReflectionAssert
C++
ref class OldReflectionAssert abstract sealed
J#
public final class OldReflectionAssert
JScript
public class OldReflectionAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldReflectionAssert

See Also

OldReflectionAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldReflectionAssert Members

OldReflectionAssert Members
See Also Example Methods
[image]

NOTE: This class is now obsolete.

Use Assert instead.

Reflection Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldReflectionAssert.

Public Methods

Name | Description
HasConstructor | Overloaded. Asserts that the type has a constructor, with the specified bindind flags, with a signature defined by parameters.
HasDefaultConstructor | Asserts that the type has a default public constructor
HasField | Overloaded. Asserts that the type has a field, with the specified bindind flags, with a signature defined by parameters.
HasMethod | Overloaded. Asserts that the type has a method, with the specified bindind flags, with a signature defined by parameters.
IsAssignableFrom | Asserts whether an instance of the parent can be assigned from an instance of child.
IsInstanceOf | Asserts whether child is an instance of the type.
IsSealed |
NotCreatable |
ReadOnlyProperty | Overloaded.
WriteOnlyProperty | Overloaded.
Top

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldReflectionAssert Methods
[image]

Public Methods

Name | Description
HasConstructor | Overloaded. Asserts that the type has a constructor, with the specified bindind flags, with a signature defined by parameters.
HasDefaultConstructor | Asserts that the type has a default public constructor
HasField | Overloaded. Asserts that the type has a field, with the specified bindind flags, with a signature defined by parameters.
HasMethod | Overloaded. Asserts that the type has a method, with the specified bindind flags, with a signature defined by parameters.
IsAssignableFrom | Asserts whether an instance of the parent can be assigned from an instance of child.
IsInstanceOf | Asserts whether child is an instance of the type.
IsSealed |
NotCreatable |
ReadOnlyProperty | Overloaded.
WriteOnlyProperty | Overloaded.
Top

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasConstructor Method

OldReflectionAssert.HasConstructor Method

Asserts that the type has a constructor, with the specified bindind flags, with a signature defined by parameters.

Overload List

Name | Description
HasConstructor (Type, BindingFlags, Type) | Asserts that the type has a constructor, with the specified bindind flags, with a signature defined by parameters.
HasConstructor (Type, Type) | Asserts that the type has a public instance constructor with a signature defined by parameters.

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasConstructor Method (Type, BindingFlags, Type[])

OldReflectionAssert.HasConstructor Method (Type, BindingFlags, Type[])
See Also Example
[image]

Asserts that the type has a constructor, with the specified bindind flags, with a signature defined by parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasConstructor( _
ByVal type As Type, _
ByVal flags As BindingFlags, _
ByVal ParamArray parameters As Type() _
)
C#
public static void HasConstructor(
Type type,
BindingFlags flags,
params Type[] parameters
)
C++
public:
static void HasConstructor(
Type type,
BindingFlags flags,
... array<Type>^ parameters
)
J#
public static void HasConstructor(
Type type,
BindingFlags flags,
Type[] parameters
)
JScript
public static function HasConstructor(
type : Type,
flags : BindingFlags,
ParamArrayAttribute parameters : Type[]
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.HasConstructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasConstructor Method (Type, Type[])

OldReflectionAssert.HasConstructor Method (Type, Type[])
See Also Example
[image]

Asserts that the type has a public instance constructor with a signature defined by parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasConstructor( _
ByVal type As Type, _
ByVal ParamArray parameters As Type() _
)
C#
public static void HasConstructor(
Type type,
params Type[] parameters
)
C++
public:
static void HasConstructor(
Type type,
... array<Type>^ parameters
)
J#
public static void HasConstructor(
Type type,
Type[] parameters
)
JScript
public static function HasConstructor(
type : Type,
ParamArrayAttribute parameters : Type[]
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.HasConstructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasDefaultConstructor Method

OldReflectionAssert.HasDefaultConstructor Method
[image]

Asserts that the type has a default public constructor

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasDefaultConstructor( _
ByVal type As Type _
)
C#
public static void HasDefaultConstructor(
Type type
)
C++
public:
static void HasDefaultConstructor(
Type type
)
J#
public static void HasDefaultConstructor(
Type type
)
JScript
public static function HasDefaultConstructor(
type : Type
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasField Method

OldReflectionAssert.HasField Method

Asserts that the type has a field, with the specified bindind flags, with a signature defined by parameters.

Overload List

Name | Description
HasField (Type, BindingFlags, String) | Asserts that the type has a field, with the specified bindind flags, with a signature defined by parameters.
HasField (Type, String) | Asserts that the type has a public field method with a signature defined by parameters.

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasField Method (Type, BindingFlags, String)

OldReflectionAssert.HasField Method (Type, BindingFlags, String)
See Also Example
[image]

Asserts that the type has a field, with the specified bindind flags, with a signature defined by parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasField( _
ByVal type As Type, _
ByVal flags As BindingFlags, _
ByVal name As String _
)
C#
public static void HasField(
Type type,
BindingFlags flags,
string name
)
C++
public:
static void HasField(
Type type,
BindingFlags flags,
String name
)
J#
public static void HasField(
Type type,
BindingFlags flags,
string name
)
JScript
public static function HasField(
type : Type,
flags : BindingFlags,
name : String
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.HasField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasField Method (Type, String)

OldReflectionAssert.HasField Method (Type, String)
See Also Example
[image]

Asserts that the type has a public field method with a signature defined by parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasField( _
ByVal type As Type, _
ByVal name As String _
)
C#
public static void HasField(
Type type,
string name
)
C++
public:
static void HasField(
Type type,
String name
)
J#
public static void HasField(
Type type,
string name
)
JScript
public static function HasField(
type : Type,
name : String
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.HasField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasMethod Method

OldReflectionAssert.HasMethod Method

Asserts that the type has a method, with the specified bindind flags, with a signature defined by parameters.

Overload List

Name | Description
HasMethod (Type, BindingFlags, String, Type) | Asserts that the type has a method, with the specified bindind flags, with a signature defined by parameters.
HasMethod (Type, String, Type) | Asserts that the type has a public instance method with a signature defined by parameters.

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasMethod Method (Type, BindingFlags, String, Type[])

OldReflectionAssert.HasMethod Method (Type, BindingFlags, String, Type[])
See Also Example
[image]

Asserts that the type has a method, with the specified bindind flags, with a signature defined by parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasMethod( _
ByVal type As Type, _
ByVal flags As BindingFlags, _
ByVal name As String, _
ByVal ParamArray parameters As Type() _
)
C#
public static void HasMethod(
Type type,
BindingFlags flags,
string name,
params Type[] parameters
)
C++
public:
static void HasMethod(
Type type,
BindingFlags flags,
String name,
... array<Type>^ parameters
)
J#
public static void HasMethod(
Type type,
BindingFlags flags,
string name,
Type[] parameters
)
JScript
public static function HasMethod(
type : Type,
flags : BindingFlags,
name : String,
ParamArrayAttribute parameters : Type[]
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.HasMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


HasMethod Method (Type, String, Type[])

OldReflectionAssert.HasMethod Method (Type, String, Type[])
See Also Example
[image]

Asserts that the type has a public instance method with a signature defined by parameters.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub HasMethod( _
ByVal type As Type, _
ByVal name As String, _
ByVal ParamArray parameters As Type() _
)
C#
public static void HasMethod(
Type type,
string name,
params Type[] parameters
)
C++
public:
static void HasMethod(
Type type,
String name,
... array<Type>^ parameters
)
J#
public static void HasMethod(
Type type,
string name,
Type[] parameters
)
JScript
public static function HasMethod(
type : Type,
name : String,
ParamArrayAttribute parameters : Type[]
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.HasMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsAssignableFrom Method

OldReflectionAssert.IsAssignableFrom Method
[image]

Asserts whether an instance of the parent can be assigned from an instance of child.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAssignableFrom( _
ByVal parent As Type, _
ByVal child As Type _
)
C#
public static void IsAssignableFrom(
Type parent,
Type child
)
C++
public:
static void IsAssignableFrom(
Type parent,
Type child
)
J#
public static void IsAssignableFrom(
Type parent,
Type child
)
JScript
public static function IsAssignableFrom(
parent : Type,
child : Type
)

Parameters

parent
Parent Type instance.
child
Child Type instance.

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsInstanceOf Method

OldReflectionAssert.IsInstanceOf Method
[image]

Asserts whether child is an instance of the type.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsInstanceOf( _
ByVal type As Type, _
ByVal child As Object _
)
C#
public static void IsInstanceOf(
Type type,
object child
)
C++
public:
static void IsInstanceOf(
Type type,
Object child
)
J#
public static void IsInstanceOf(
Type type,
object child
)
JScript
public static function IsInstanceOf(
type : Type,
child : Object
)

Parameters

type
Type instance.
child
Child instance.

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsSealed Method

OldReflectionAssert.IsSealed Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsSealed( _
ByVal t As Type _
)
C#
public static void IsSealed(
Type t
)
C++
public:
static void IsSealed(
Type t
)
J#
public static void IsSealed(
Type t
)
JScript
public static function IsSealed(
t : Type
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotCreatable Method

OldReflectionAssert.NotCreatable Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotCreatable( _
ByVal t As Type _
)
C#
public static void NotCreatable(
Type t
)
C++
public:
static void NotCreatable(
Type t
)
J#
public static void NotCreatable(
Type t
)
JScript
public static function NotCreatable(
t : Type
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ReadOnlyProperty Method

OldReflectionAssert.ReadOnlyProperty Method

Overload List

Name | Description
ReadOnlyProperty (PropertyInfo) |
ReadOnlyProperty (Type, String) |

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ReadOnlyProperty Method (PropertyInfo)

OldReflectionAssert.ReadOnlyProperty Method (PropertyInfo)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ReadOnlyProperty( _
ByVal pi As PropertyInfo _
)
C#
public static void ReadOnlyProperty(
PropertyInfo pi
)
C++
public:
static void ReadOnlyProperty(
PropertyInfo pi
)
J#
public static void ReadOnlyProperty(
PropertyInfo pi
)
JScript
public static function ReadOnlyProperty(
pi : PropertyInfo
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.ReadOnlyProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ReadOnlyProperty Method (Type, String)

OldReflectionAssert.ReadOnlyProperty Method (Type, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ReadOnlyProperty( _
ByVal t As Type, _
ByVal propertyName As String _
)
C#
public static void ReadOnlyProperty(
Type t,
string propertyName
)
C++
public:
static void ReadOnlyProperty(
Type t,
String propertyName
)
J#
public static void ReadOnlyProperty(
Type t,
string propertyName
)
JScript
public static function ReadOnlyProperty(
t : Type,
propertyName : String
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.ReadOnlyProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WriteOnlyProperty Method

OldReflectionAssert.WriteOnlyProperty Method

Overload List

Name | Description
WriteOnlyProperty (PropertyInfo) |
WriteOnlyProperty (Type, String) |

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WriteOnlyProperty Method (PropertyInfo)

OldReflectionAssert.WriteOnlyProperty Method (PropertyInfo)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteOnlyProperty( _
ByVal pi As PropertyInfo _
)
C#
public static void WriteOnlyProperty(
PropertyInfo pi
)
C++
public:
static void WriteOnlyProperty(
PropertyInfo pi
)
J#
public static void WriteOnlyProperty(
PropertyInfo pi
)
JScript
public static function WriteOnlyProperty(
pi : PropertyInfo
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.WriteOnlyProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WriteOnlyProperty Method (Type, String)

OldReflectionAssert.WriteOnlyProperty Method (Type, String)
See Also Example
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteOnlyProperty( _
ByVal t As Type, _
ByVal propertyName As String _
)
C#
public static void WriteOnlyProperty(
Type t,
string propertyName
)
C++
public:
static void WriteOnlyProperty(
Type t,
String propertyName
)
J#
public static void WriteOnlyProperty(
Type t,
string propertyName
)
JScript
public static function WriteOnlyProperty(
t : Type,
propertyName : String
)

See Also

OldReflectionAssert Class
MbUnit.Framework Namespace
OldReflectionAssert.WriteOnlyProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldSecurityAssert Class

OldSecurityAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

No replacement. Please ask for one if you use this feature.

Security Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OldSecurityAssert
C#
public sealed class OldSecurityAssert
C++
ref class OldSecurityAssert sealed
J#
public final class OldSecurityAssert
JScript
public final class OldSecurityAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldSecurityAssert

See Also

OldSecurityAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldSecurityAssert Members

OldSecurityAssert Members
See Also Example Methods
[image]

NOTE: This class is now obsolete.

No replacement. Please ask for one if you use this feature.

Security Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldSecurityAssert.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | IsAuthenticated | Asserts that identity is authenticated.
 | IsNotAuthenticated | Asserts that identity is not authenticated.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
 | WindowIsAuthenticated | Asserts that the current windows identity is authenticated.
 | WindowIsNotAuthenticated | Asserts that the current windows identity is not authenticated.
 | WindowsIsInAdministrator | Asserts that the current windows identity is in Administrator role.
 | WindowsIsInGuest | Asserts that the current windows identity is in Guest role.
 | WindowsIsInPowerUser | Asserts that the current windows identity is in PowerUser role.
 | WindowsIsInRole | Asserts that the current windows identity is in .
 | WindowsIsInUser | Asserts that the current windows identity is in User role.
Top

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldSecurityAssert Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | IsAuthenticated | Asserts that identity is authenticated.
 | IsNotAuthenticated | Asserts that identity is not authenticated.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
 | WindowIsAuthenticated | Asserts that the current windows identity is authenticated.
 | WindowIsNotAuthenticated | Asserts that the current windows identity is not authenticated.
 | WindowsIsInAdministrator | Asserts that the current windows identity is in Administrator role.
 | WindowsIsInGuest | Asserts that the current windows identity is in Guest role.
 | WindowsIsInPowerUser | Asserts that the current windows identity is in PowerUser role.
 | WindowsIsInRole | Asserts that the current windows identity is in .
 | WindowsIsInUser | Asserts that the current windows identity is in User role.
Top

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsAuthenticated Method

OldSecurityAssert.IsAuthenticated Method
[image]

Asserts that identity is authenticated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsAuthenticated( _
ByVal identity As IIdentity _
)
C#
public static void IsAuthenticated(
IIdentity identity
)
C++
public:
static void IsAuthenticated(
IIdentity identity
)
J#
public static void IsAuthenticated(
IIdentity identity
)
JScript
public static function IsAuthenticated(
identity : IIdentity
)

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNotAuthenticated Method

OldSecurityAssert.IsNotAuthenticated Method
[image]

Asserts that identity is not authenticated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNotAuthenticated( _
ByVal identity As IIdentity _
)
C#
public static void IsNotAuthenticated(
IIdentity identity
)
C++
public:
static void IsNotAuthenticated(
IIdentity identity
)
J#
public static void IsNotAuthenticated(
IIdentity identity
)
JScript
public static function IsNotAuthenticated(
identity : IIdentity
)

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowIsAuthenticated Method

OldSecurityAssert.WindowIsAuthenticated Method
[image]

Asserts that the current windows identity is authenticated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowIsAuthenticated()
C#
public static void WindowIsAuthenticated()
C++
public:
static void WindowIsAuthenticated()
J#
public static void WindowIsAuthenticated()
JScript
public static function WindowIsAuthenticated()

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowIsNotAuthenticated Method

OldSecurityAssert.WindowIsNotAuthenticated Method
[image]

Asserts that the current windows identity is not authenticated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowIsNotAuthenticated()
C#
public static void WindowIsNotAuthenticated()
C++
public:
static void WindowIsNotAuthenticated()
J#
public static void WindowIsNotAuthenticated()
JScript
public static function WindowIsNotAuthenticated()

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowsIsInAdministrator Method

OldSecurityAssert.WindowsIsInAdministrator Method
[image]

Asserts that the current windows identity is in Administrator role.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowsIsInAdministrator()
C#
public static void WindowsIsInAdministrator()
C++
public:
static void WindowsIsInAdministrator()
J#
public static void WindowsIsInAdministrator()
JScript
public static function WindowsIsInAdministrator()

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowsIsInGuest Method

OldSecurityAssert.WindowsIsInGuest Method
[image]

Asserts that the current windows identity is in Guest role.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowsIsInGuest()
C#
public static void WindowsIsInGuest()
C++
public:
static void WindowsIsInGuest()
J#
public static void WindowsIsInGuest()
JScript
public static function WindowsIsInGuest()

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowsIsInPowerUser Method

OldSecurityAssert.WindowsIsInPowerUser Method
[image]

Asserts that the current windows identity is in PowerUser role.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowsIsInPowerUser()
C#
public static void WindowsIsInPowerUser()
C++
public:
static void WindowsIsInPowerUser()
J#
public static void WindowsIsInPowerUser()
JScript
public static function WindowsIsInPowerUser()

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowsIsInRole Method

OldSecurityAssert.WindowsIsInRole Method
[image]

Asserts that the current windows identity is in .

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowsIsInRole( _
ByVal role As WindowsBuiltInRole _
)
C#
public static void WindowsIsInRole(
WindowsBuiltInRole role
)
C++
public:
static void WindowsIsInRole(
WindowsBuiltInRole role
)
J#
public static void WindowsIsInRole(
WindowsBuiltInRole role
)
JScript
public static function WindowsIsInRole(
role : WindowsBuiltInRole
)

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WindowsIsInUser Method

OldSecurityAssert.WindowsIsInUser Method
[image]

Asserts that the current windows identity is in User role.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WindowsIsInUser()
C#
public static void WindowsIsInUser()
C++
public:
static void WindowsIsInUser()
J#
public static void WindowsIsInUser()
JScript
public static function WindowsIsInUser()

See Also

OldSecurityAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldStringAssert Class

OldStringAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use Assert instead.

String Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldStringAssert
C#
public static class OldStringAssert
C++
ref class OldStringAssert abstract sealed
J#
public final class OldStringAssert
JScript
public class OldStringAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldStringAssert

See Also

OldStringAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldStringAssert Members

OldStringAssert Members
See Also Example Methods
[image]

NOTE: This class is now obsolete.

Use Assert instead.

String Assertion class This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldStringAssert.

Public Methods

Name | Description
AreEqualIgnoreCase | Asserts that two strings are equal, ignoring the case
Contains |
DoesNotContain | Asserts the string does not contain c
EndsWith |
FullMatch | Overloaded. Asserts the regular expression reg makes a full match on s
IsEmpty | Asserts that the string is non null and empty
IsNonEmpty | Asserts that the string is non null and non empty
Like | Overloaded. Asserts the regular expression reg makes a match on s
NotLike | Overloaded. Asserts the regular expression reg makes a match on s
StartsWith |
Top

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldStringAssert Methods
[image]

Public Methods

Name | Description
AreEqualIgnoreCase | Asserts that two strings are equal, ignoring the case
Contains |
DoesNotContain | Asserts the string does not contain c
EndsWith |
FullMatch | Overloaded. Asserts the regular expression reg makes a full match on s
IsEmpty | Asserts that the string is non null and empty
IsNonEmpty | Asserts that the string is non null and non empty
Like | Overloaded. Asserts the regular expression reg makes a match on s
NotLike | Overloaded. Asserts the regular expression reg makes a match on s
StartsWith |
Top

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AreEqualIgnoreCase Method

OldStringAssert.AreEqualIgnoreCase Method
[image]

Asserts that two strings are equal, ignoring the case

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub AreEqualIgnoreCase( _
ByVal s1 As String, _
ByVal s2 As String _
)
C#
public static void AreEqualIgnoreCase(
string s1,
string s2
)
C++
public:
static void AreEqualIgnoreCase(
String s1,
String s2
)
J#
public static void AreEqualIgnoreCase(
string s1,
string s2
)
JScript
public static function AreEqualIgnoreCase(
s1 : String,
s2 : String
)

Parameters

s1
Expected string
s2
Actual string

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Contains Method

OldStringAssert.Contains Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Contains( _
ByVal s As String, _
ByVal contain As String _
)
C#
public static void Contains(
string s,
string contain
)
C++
public:
static void Contains(
String s,
String contain
)
J#
public static void Contains(
string s,
string contain
)
JScript
public static function Contains(
s : String,
contain : String
)

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DoesNotContain Method

OldStringAssert.DoesNotContain Method
[image]

Asserts the string does not contain c

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DoesNotContain( _
ByVal s As String, _
ByVal ParamArray anyOf As Char() _
)
C#
public static void DoesNotContain(
string s,
params char[] anyOf
)
C++
public:
static void DoesNotContain(
String s,
... array<wchar_t>^ anyOf
)
J#
public static void DoesNotContain(
string s,
char[] anyOf
)
JScript
public static function DoesNotContain(
s : String,
ParamArrayAttribute anyOf : char[]
)

Parameters

s
String to test.
anyOf
Variable list of characeters.

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


EndsWith Method

OldStringAssert.EndsWith Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EndsWith( _
ByVal s As String, _
ByVal pattern As String _
)
C#
public static void EndsWith(
string s,
string pattern
)
C++
public:
static void EndsWith(
String s,
String pattern
)
J#
public static void EndsWith(
string s,
string pattern
)
JScript
public static function EndsWith(
s : String,
pattern : String
)

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


FullMatch Method

OldStringAssert.FullMatch Method

Asserts the regular expression reg makes a full match on s

Overload List

Name | Description
FullMatch (String, String) | Asserts the regular expression reg makes a full match on s
FullMatch (String, Regex) | Asserts the regular expression regex makes a full match on s.

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


FullMatch Method (String, String)

OldStringAssert.FullMatch Method (String, String)
See Also Example
[image]

Asserts the regular expression reg makes a full match on s

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal s As String, _
ByVal reg As String _
)
C#
public static void FullMatch(
string s,
string reg
)
C++
public:
static void FullMatch(
String s,
String reg
)
J#
public static void FullMatch(
string s,
string reg
)
JScript
public static function FullMatch(
s : String,
reg : String
)

Parameters

s
String to test.
reg
Regular expression

See Also

OldStringAssert Class
MbUnit.Framework Namespace
OldStringAssert.FullMatch Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


FullMatch Method (String, Regex)

OldStringAssert.FullMatch Method (String, Regex)
See Also Example
[image]

Asserts the regular expression regex makes a full match on s.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FullMatch( _
ByVal s As String, _
ByVal regex As Regex _
)
C#
public static void FullMatch(
string s,
Regex regex
)
C++
public:
static void FullMatch(
String s,
Regex regex
)
J#
public static void FullMatch(
string s,
Regex regex
)
JScript
public static function FullMatch(
s : String,
regex : Regex
)

Parameters

s
String to test.
regex
Regular expression

See Also

OldStringAssert Class
MbUnit.Framework Namespace
OldStringAssert.FullMatch Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsEmpty Method

OldStringAssert.IsEmpty Method
[image]

Asserts that the string is non null and empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsEmpty( _
ByVal s As String _
)
C#
public static void IsEmpty(
string s
)
C++
public:
static void IsEmpty(
String s
)
J#
public static void IsEmpty(
string s
)
JScript
public static function IsEmpty(
s : String
)

Parameters

s
String to test.

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsNonEmpty Method

OldStringAssert.IsNonEmpty Method
[image]

Asserts that the string is non null and non empty

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub IsNonEmpty( _
ByVal s As String _
)
C#
public static void IsNonEmpty(
string s
)
C++
public:
static void IsNonEmpty(
String s
)
J#
public static void IsNonEmpty(
string s
)
JScript
public static function IsNonEmpty(
s : String
)

Parameters

s
String to test.

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Like Method

OldStringAssert.Like Method

Asserts the regular expression reg makes a match on s

Overload List

Name | Description
Like (String, String) | Asserts the regular expression reg makes a match on s
Like (String, Regex) | Asserts the regular expression regex makes a match on s

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Like Method (String, String)

OldStringAssert.Like Method (String, String)
See Also Example
[image]

Asserts the regular expression reg makes a match on s

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal s As String, _
ByVal reg As String _
)
C#
public static void Like(
string s,
string reg
)
C++
public:
static void Like(
String s,
String reg
)
J#
public static void Like(
string s,
string reg
)
JScript
public static function Like(
s : String,
reg : String
)

Parameters

s
String to test.
reg
Regular expression

See Also

OldStringAssert Class
MbUnit.Framework Namespace
OldStringAssert.Like Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Like Method (String, Regex)

OldStringAssert.Like Method (String, Regex)
See Also Example
[image]

Asserts the regular expression regex makes a match on s

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Like( _
ByVal s As String, _
ByVal regex As Regex _
)
C#
public static void Like(
string s,
Regex regex
)
C++
public:
static void Like(
String s,
Regex regex
)
J#
public static void Like(
string s,
Regex regex
)
JScript
public static function Like(
s : String,
regex : Regex
)

Parameters

s
String to test.
regex
A Regex instance.

See Also

OldStringAssert Class
MbUnit.Framework Namespace
OldStringAssert.Like Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotLike Method

OldStringAssert.NotLike Method

Asserts the regular expression reg makes a match on s

Overload List

Name | Description
NotLike (String, String) | Asserts the regular expression reg makes a match on s
NotLike (String, Regex) | Asserts the regular expression regex makes a match on s

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotLike Method (String, String)

OldStringAssert.NotLike Method (String, String)
See Also Example
[image]

Asserts the regular expression reg makes a match on s

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal s As String, _
ByVal reg As String _
)
C#
public static void NotLike(
string s,
string reg
)
C++
public:
static void NotLike(
String s,
String reg
)
J#
public static void NotLike(
string s,
string reg
)
JScript
public static function NotLike(
s : String,
reg : String
)

Parameters

s
String to test.
reg
Regular expression

See Also

OldStringAssert Class
MbUnit.Framework Namespace
OldStringAssert.NotLike Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


NotLike Method (String, Regex)

OldStringAssert.NotLike Method (String, Regex)
See Also Example
[image]

Asserts the regular expression regex makes a match on s

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub NotLike( _
ByVal s As String, _
ByVal regex As Regex _
)
C#
public static void NotLike(
string s,
Regex regex
)
C++
public:
static void NotLike(
String s,
Regex regex
)
J#
public static void NotLike(
string s,
Regex regex
)
JScript
public static function NotLike(
s : String,
regex : Regex
)

Parameters

s
String to test.
regex
A Regex instance.

See Also

OldStringAssert Class
MbUnit.Framework Namespace
OldStringAssert.NotLike Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


StartsWith Method

OldStringAssert.StartsWith Method
[image]

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub StartsWith( _
ByVal s As String, _
ByVal pattern As String _
)
C#
public static void StartsWith(
string s,
string pattern
)
C++
public:
static void StartsWith(
String s,
String pattern
)
J#
public static void StartsWith(
string s,
string pattern
)
JScript
public static function StartsWith(
s : String,
pattern : String
)

See Also

OldStringAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldXmlAssert Class

OldXmlAssert Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

The OldXmlAsserts are obsolete and will be replaced in a future version.

Class containing generic assert methods for XML markup This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module OldXmlAssert
C#
public static class OldXmlAssert
C++
ref class OldXmlAssert abstract sealed
J#
public final class OldXmlAssert
JScript
public class OldXmlAssert

Inheritance Hierarchy

System.Object
MbUnit.Framework.OldXmlAssert

See Also

OldXmlAssert Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OldXmlAssert Members

OldXmlAssert Members
See Also Example Methods
[image]

NOTE: This class is now obsolete.

The OldXmlAsserts are obsolete and will be replaced in a future version.

Class containing generic assert methods for XML markup This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by OldXmlAssert.

Public Methods

Name | Description
XmlEquals | Overloaded. Asserts that two pieces of XMl are similar given their diff
XmlIdentical | Overloaded. Asserts that two pieces of XML are identical given their diff
XmlNotEquals | Asserts that two pieces of XMl are not similar given their diff
XmlNotIdentical | Asserts that two pieces of XML are not identical given their diff
XmlValid | Overloaded. Asserts that some XML is valid.
XPathEvaluatesTo | Overloaded. Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value
XPathExists | Overloaded. Assert that an XPath expression matches at least one node in someXml
XslTransformResults | Overloaded. Asserts that the results of an XSL transform on some XML are the expected result
Top

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

OldXmlAssert Methods
[image]

Public Methods

Name | Description
XmlEquals | Overloaded. Asserts that two pieces of XMl are similar given their diff
XmlIdentical | Overloaded. Asserts that two pieces of XML are identical given their diff
XmlNotEquals | Asserts that two pieces of XMl are not similar given their diff
XmlNotIdentical | Asserts that two pieces of XML are not identical given their diff
XmlValid | Overloaded. Asserts that some XML is valid.
XPathEvaluatesTo | Overloaded. Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value
XPathExists | Overloaded. Assert that an XPath expression matches at least one node in someXml
XslTransformResults | Overloaded. Asserts that the results of an XSL transform on some XML are the expected result
Top

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlEquals Method

OldXmlAssert.XmlEquals Method

Asserts that two pieces of XMl are similar given their diff

Overload List

Name | Description
XmlEquals (XmlDiff) | Asserts that two pieces of XMl are similar given their diff
XmlEquals (XmlInput, XmlInput) | Asserts that two pieces of XML are similar.
XmlEquals (TextReader, TextReader) | Asserts that two pieces of XML are similar.
XmlEquals (String, String) | Asserts that two pieces of XML are similar.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlEquals Method (XmlDiff)

OldXmlAssert.XmlEquals Method (XmlDiff)
See Also Example
[image]

Asserts that two pieces of XMl are similar given their diff

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlEquals( _
ByVal xmlDiff As XmlDiff _
)
C#
public static void XmlEquals(
XmlDiff xmlDiff
)
C++
public:
static void XmlEquals(
XmlDiff xmlDiff
)
J#
public static void XmlEquals(
XmlDiff xmlDiff
)
JScript
public static function XmlEquals(
xmlDiff : XmlDiff
)

Parameters

xmlDiff
The XML diff.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlEquals Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlEquals Method (XmlInput, XmlInput)

OldXmlAssert.XmlEquals Method (XmlInput, XmlInput)
See Also Example
[image]

Asserts that two pieces of XML are similar.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlEquals( _
ByVal controlInput As XmlInput, _
ByVal testInput As XmlInput _
)
C#
public static void XmlEquals(
XmlInput controlInput,
XmlInput testInput
)
C++
public:
static void XmlEquals(
XmlInput controlInput,
XmlInput testInput
)
J#
public static void XmlEquals(
XmlInput controlInput,
XmlInput testInput
)
JScript
public static function XmlEquals(
controlInput : XmlInput,
testInput : XmlInput
)

Parameters

controlInput
The control input.
testInput
The test input.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlEquals Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlEquals Method (TextReader, TextReader)

OldXmlAssert.XmlEquals Method (TextReader, TextReader)
See Also Example
[image]

Asserts that two pieces of XML are similar.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlEquals( _
ByVal controlTextReader As TextReader, _
ByVal testTextReader As TextReader _
)
C#
public static void XmlEquals(
TextReader controlTextReader,
TextReader testTextReader
)
C++
public:
static void XmlEquals(
TextReader controlTextReader,
TextReader testTextReader
)
J#
public static void XmlEquals(
TextReader controlTextReader,
TextReader testTextReader
)
JScript
public static function XmlEquals(
controlTextReader : TextReader,
testTextReader : TextReader
)

Parameters

controlTextReader
The control text reader.
testTextReader
The test text reader.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlEquals Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlEquals Method (String, String)

OldXmlAssert.XmlEquals Method (String, String)
See Also Example
[image]

Asserts that two pieces of XML are similar.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlEquals( _
ByVal controlText As String, _
ByVal testText As String _
)
C#
public static void XmlEquals(
string controlText,
string testText
)
C++
public:
static void XmlEquals(
String controlText,
String testText
)
J#
public static void XmlEquals(
string controlText,
string testText
)
JScript
public static function XmlEquals(
controlText : String,
testText : String
)

Parameters

controlText
The control text.
testText
The test text.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlEquals Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlIdentical Method

OldXmlAssert.XmlIdentical Method

Asserts that two pieces of XML are identical given their diff

Overload List

Name | Description
XmlIdentical (XmlDiff) | Asserts that two pieces of XML are identical given their diff
XmlIdentical (XmlInput, XmlInput) | Asserts that two pieces of XML are identical.
XmlIdentical (TextReader, TextReader) | Asserts that two pieces of XML are identical.
XmlIdentical (String, String) | Asserts that two pieces of XML are identical.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlIdentical Method (XmlDiff)

OldXmlAssert.XmlIdentical Method (XmlDiff)
See Also Example
[image]

Asserts that two pieces of XML are identical given their diff

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlIdentical( _
ByVal xmlDiff As XmlDiff _
)
C#
public static void XmlIdentical(
XmlDiff xmlDiff
)
C++
public:
static void XmlIdentical(
XmlDiff xmlDiff
)
J#
public static void XmlIdentical(
XmlDiff xmlDiff
)
JScript
public static function XmlIdentical(
xmlDiff : XmlDiff
)

Parameters

xmlDiff
The XML diff.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlIdentical Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlIdentical Method (XmlInput, XmlInput)

OldXmlAssert.XmlIdentical Method (XmlInput, XmlInput)
See Also Example
[image]

Asserts that two pieces of XML are identical.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlIdentical( _
ByVal controlInput As XmlInput, _
ByVal testInput As XmlInput _
)
C#
public static void XmlIdentical(
XmlInput controlInput,
XmlInput testInput
)
C++
public:
static void XmlIdentical(
XmlInput controlInput,
XmlInput testInput
)
J#
public static void XmlIdentical(
XmlInput controlInput,
XmlInput testInput
)
JScript
public static function XmlIdentical(
controlInput : XmlInput,
testInput : XmlInput
)

Parameters

controlInput
The control input.
testInput
The test input.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlIdentical Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlIdentical Method (TextReader, TextReader)

OldXmlAssert.XmlIdentical Method (TextReader, TextReader)
See Also Example
[image]

Asserts that two pieces of XML are identical.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlIdentical( _
ByVal controlTextReader As TextReader, _
ByVal testTextReader As TextReader _
)
C#
public static void XmlIdentical(
TextReader controlTextReader,
TextReader testTextReader
)
C++
public:
static void XmlIdentical(
TextReader controlTextReader,
TextReader testTextReader
)
J#
public static void XmlIdentical(
TextReader controlTextReader,
TextReader testTextReader
)
JScript
public static function XmlIdentical(
controlTextReader : TextReader,
testTextReader : TextReader
)

Parameters

controlTextReader
The control text reader.
testTextReader
The test text reader.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlIdentical Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlIdentical Method (String, String)

OldXmlAssert.XmlIdentical Method (String, String)
See Also Example
[image]

Asserts that two pieces of XML are identical.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlIdentical( _
ByVal controlText As String, _
ByVal testText As String _
)
C#
public static void XmlIdentical(
string controlText,
string testText
)
C++
public:
static void XmlIdentical(
String controlText,
String testText
)
J#
public static void XmlIdentical(
string controlText,
string testText
)
JScript
public static function XmlIdentical(
controlText : String,
testText : String
)

Parameters

controlText
The control text.
testText
The test text.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlIdentical Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlNotEquals Method

OldXmlAssert.XmlNotEquals Method
[image]

Asserts that two pieces of XMl are not similar given their diff

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlNotEquals( _
ByVal xmlDiff As XmlDiff _
)
C#
public static void XmlNotEquals(
XmlDiff xmlDiff
)
C++
public:
static void XmlNotEquals(
XmlDiff xmlDiff
)
J#
public static void XmlNotEquals(
XmlDiff xmlDiff
)
JScript
public static function XmlNotEquals(
xmlDiff : XmlDiff
)

Parameters

xmlDiff
The XML diff.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlNotIdentical Method

OldXmlAssert.XmlNotIdentical Method
[image]

Asserts that two pieces of XML are not identical given their diff

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlNotIdentical( _
ByVal xmlDiff As XmlDiff _
)
C#
public static void XmlNotIdentical(
XmlDiff xmlDiff
)
C++
public:
static void XmlNotIdentical(
XmlDiff xmlDiff
)
J#
public static void XmlNotIdentical(
XmlDiff xmlDiff
)
JScript
public static function XmlNotIdentical(
xmlDiff : XmlDiff
)

Parameters

xmlDiff
The XML diff.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method

OldXmlAssert.XmlValid Method

Asserts that some XML is valid.

Overload List

Name | Description
XmlValid (Validator) | Asserts that some XML is valid.
XmlValid (XmlInput) | Asserts that some XML is valid.
XmlValid (TextReader) | Asserts that some XML is valid.
XmlValid (TextReader, String) | Asserts that some XML is valid given a baseURI
XmlValid (String) | Asserts that someXml is valid XML.
XmlValid (String, String) | Asserts that someXml is valid XML given a baseURI

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method (Validator)

OldXmlAssert.XmlValid Method (Validator)
See Also Example
[image]

Asserts that some XML is valid.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlValid( _
ByVal validator As Validator _
)
C#
public static void XmlValid(
Validator validator
)
C++
public:
static void XmlValid(
Validator validator
)
J#
public static void XmlValid(
Validator validator
)
JScript
public static function XmlValid(
validator : Validator
)

Parameters

validator
A Validator object containing the XML to validate

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlValid Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method (XmlInput)

OldXmlAssert.XmlValid Method (XmlInput)
See Also Example
[image]

Asserts that some XML is valid.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlValid( _
ByVal xmlInput As XmlInput _
)
C#
public static void XmlValid(
XmlInput xmlInput
)
C++
public:
static void XmlValid(
XmlInput xmlInput
)
J#
public static void XmlValid(
XmlInput xmlInput
)
JScript
public static function XmlValid(
xmlInput : XmlInput
)

Parameters

xmlInput
The XML input.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlValid Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method (TextReader)

OldXmlAssert.XmlValid Method (TextReader)
See Also Example
[image]

Asserts that some XML is valid.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlValid( _
ByVal reader As TextReader _
)
C#
public static void XmlValid(
TextReader reader
)
C++
public:
static void XmlValid(
TextReader reader
)
J#
public static void XmlValid(
TextReader reader
)
JScript
public static function XmlValid(
reader : TextReader
)

Parameters

reader
A TextReader pointing to the XML to test.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlValid Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method (TextReader, String)

OldXmlAssert.XmlValid Method (TextReader, String)
See Also Example
[image]

Asserts that some XML is valid given a baseURI

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlValid( _
ByVal reader As TextReader, _
ByVal baseURI As String _
)
C#
public static void XmlValid(
TextReader reader,
string baseURI
)
C++
public:
static void XmlValid(
TextReader reader,
String baseURI
)
J#
public static void XmlValid(
TextReader reader,
string baseURI
)
JScript
public static function XmlValid(
reader : TextReader,
baseURI : String
)

Parameters

reader
A TextReader pointing to the XML to test.
baseURI
The base URI.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlValid Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method (String)

OldXmlAssert.XmlValid Method (String)
See Also Example
[image]

Asserts that someXml is valid XML.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlValid( _
ByVal someXml As String _
)
C#
public static void XmlValid(
string someXml
)
C++
public:
static void XmlValid(
String someXml
)
J#
public static void XmlValid(
string someXml
)
JScript
public static function XmlValid(
someXml : String
)

Parameters

someXml
The XMl to test

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlValid Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlValid Method (String, String)

OldXmlAssert.XmlValid Method (String, String)
See Also Example
[image]

Asserts that someXml is valid XML given a baseURI

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XmlValid( _
ByVal someXml As String, _
ByVal baseURI As String _
)
C#
public static void XmlValid(
string someXml,
string baseURI
)
C++
public:
static void XmlValid(
String someXml,
String baseURI
)
J#
public static void XmlValid(
string someXml,
string baseURI
)
JScript
public static function XmlValid(
someXml : String,
baseURI : String
)

Parameters

someXml
The XML to test.
baseURI
The base URI.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XmlValid Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathEvaluatesTo Method

OldXmlAssert.XPathEvaluatesTo Method

Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value

Overload List

Name | Description
XPathEvaluatesTo (String, XmlInput, String) | Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value
XPathEvaluatesTo (String, TextReader, String) | Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value
XPathEvaluatesTo (String, String, String) | Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathEvaluatesTo Method (String, XmlInput, String)

OldXmlAssert.XPathEvaluatesTo Method (String, XmlInput, String)
See Also Example
[image]

Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XPathEvaluatesTo( _
ByVal anXPathExpression As String, _
ByVal inXml As XmlInput, _
ByVal expectedValue As String _
)
C#
public static void XPathEvaluatesTo(
string anXPathExpression,
XmlInput inXml,
string expectedValue
)
C++
public:
static void XPathEvaluatesTo(
String anXPathExpression,
XmlInput inXml,
String expectedValue
)
J#
public static void XPathEvaluatesTo(
string anXPathExpression,
XmlInput inXml,
string expectedValue
)
JScript
public static function XPathEvaluatesTo(
anXPathExpression : String,
inXml : XmlInput,
expectedValue : String
)

Parameters

anXPathExpression
An X path expression.
inXml
The XML to test.
expectedValue
The expected value.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XPathEvaluatesTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathEvaluatesTo Method (String, TextReader, String)

OldXmlAssert.XPathEvaluatesTo Method (String, TextReader, String)
See Also Example
[image]

Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XPathEvaluatesTo( _
ByVal anXPathExpression As String, _
ByVal inXml As TextReader, _
ByVal expectedValue As String _
)
C#
public static void XPathEvaluatesTo(
string anXPathExpression,
TextReader inXml,
string expectedValue
)
C++
public:
static void XPathEvaluatesTo(
String anXPathExpression,
TextReader inXml,
String expectedValue
)
J#
public static void XPathEvaluatesTo(
string anXPathExpression,
TextReader inXml,
string expectedValue
)
JScript
public static function XPathEvaluatesTo(
anXPathExpression : String,
inXml : TextReader,
expectedValue : String
)

Parameters

anXPathExpression
An X path expression.
inXml
The XML to test.
expectedValue
The expected value.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XPathEvaluatesTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathEvaluatesTo Method (String, String, String)

OldXmlAssert.XPathEvaluatesTo Method (String, String, String)
See Also Example
[image]

Asserts that the flattened String obtained by executing an Xpath on some XML is a particular value

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XPathEvaluatesTo( _
ByVal anXPathExpression As String, _
ByVal inXml As String, _
ByVal expectedValue As String _
)
C#
public static void XPathEvaluatesTo(
string anXPathExpression,
string inXml,
string expectedValue
)
C++
public:
static void XPathEvaluatesTo(
String anXPathExpression,
String inXml,
String expectedValue
)
J#
public static void XPathEvaluatesTo(
string anXPathExpression,
string inXml,
string expectedValue
)
JScript
public static function XPathEvaluatesTo(
anXPathExpression : String,
inXml : String,
expectedValue : String
)

Parameters

anXPathExpression
An X path expression.
inXml
The XML to test.
expectedValue
The expected value.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XPathEvaluatesTo Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method

OldXmlAssert.XPathExists Method

Assert that an XPath expression matches at least one node in someXml

Overload List

Name | Description
XPathExists (String, XmlInput) | Assert that an XPath expression matches at least one node in someXml
XPathExists (String, TextReader) | Assert that an XPath expression matches at least one node in someXml
XPathExists (String, String) | Assert that an XPath expression matches at least one node in someXml

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method (String, XmlInput)

OldXmlAssert.XPathExists Method (String, XmlInput)
See Also Example
[image]

Assert that an XPath expression matches at least one node in someXml

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XPathExists( _
ByVal anXPathExpression As String, _
ByVal inXml As XmlInput _
)
C#
public static void XPathExists(
string anXPathExpression,
XmlInput inXml
)
C++
public:
static void XPathExists(
String anXPathExpression,
XmlInput inXml
)
J#
public static void XPathExists(
string anXPathExpression,
XmlInput inXml
)
JScript
public static function XPathExists(
anXPathExpression : String,
inXml : XmlInput
)

Parameters

anXPathExpression
An X path expression.
inXml
The XML to test.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XPathExists Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method (String, TextReader)

OldXmlAssert.XPathExists Method (String, TextReader)
See Also Example
[image]

Assert that an XPath expression matches at least one node in someXml

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XPathExists( _
ByVal anXPathExpression As String, _
ByVal inXml As TextReader _
)
C#
public static void XPathExists(
string anXPathExpression,
TextReader inXml
)
C++
public:
static void XPathExists(
String anXPathExpression,
TextReader inXml
)
J#
public static void XPathExists(
string anXPathExpression,
TextReader inXml
)
JScript
public static function XPathExists(
anXPathExpression : String,
inXml : TextReader
)

Parameters

anXPathExpression
An X path expression.
inXml
A reader ontot eh XML being tested

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XPathExists Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method (String, String)

OldXmlAssert.XPathExists Method (String, String)
See Also Example
[image]

Assert that an XPath expression matches at least one node in someXml

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XPathExists( _
ByVal anXPathExpression As String, _
ByVal inXml As String _
)
C#
public static void XPathExists(
string anXPathExpression,
string inXml
)
C++
public:
static void XPathExists(
String anXPathExpression,
String inXml
)
J#
public static void XPathExists(
string anXPathExpression,
string inXml
)
JScript
public static function XPathExists(
anXPathExpression : String,
inXml : String
)

Parameters

anXPathExpression
An X path expression.
inXml
The XML being tested.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XPathExists Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XslTransformResults Method

OldXmlAssert.XslTransformResults Method

Asserts that the results of an XSL transform on some XML are the expected result

Overload List

Name | Description
XslTransformResults (XmlInput, XmlInput, XmlInput) | Asserts that the results of an XSL transform on some XML are the expected result
XslTransformResults (String, String, String) | Asserts that the results of an XSL transform on some XML are the expected result

See Also

OldXmlAssert Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XslTransformResults Method (XmlInput, XmlInput, XmlInput)

OldXmlAssert.XslTransformResults Method (XmlInput, XmlInput, XmlInput)
See Also Example
[image]

Asserts that the results of an XSL transform on some XML are the expected result

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XslTransformResults( _
ByVal xslTransform As XmlInput, _
ByVal xmlToTransform As XmlInput, _
ByVal expectedResult As XmlInput _
)
C#
public static void XslTransformResults(
XmlInput xslTransform,
XmlInput xmlToTransform,
XmlInput expectedResult
)
C++
public:
static void XslTransformResults(
XmlInput xslTransform,
XmlInput xmlToTransform,
XmlInput expectedResult
)
J#
public static void XslTransformResults(
XmlInput xslTransform,
XmlInput xmlToTransform,
XmlInput expectedResult
)
JScript
public static function XslTransformResults(
xslTransform : XmlInput,
xmlToTransform : XmlInput,
expectedResult : XmlInput
)

Parameters

xslTransform
The XSL transform.
xmlToTransform
The XML to transform.
expectedResult
The expected result.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XslTransformResults Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XslTransformResults Method (String, String, String)

OldXmlAssert.XslTransformResults Method (String, String, String)
See Also Example
[image]

Asserts that the results of an XSL transform on some XML are the expected result

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub XslTransformResults( _
ByVal xslTransform As String, _
ByVal xmlToTransform As String, _
ByVal expectedResult As String _
)
C#
public static void XslTransformResults(
string xslTransform,
string xmlToTransform,
string expectedResult
)
C++
public:
static void XslTransformResults(
String xslTransform,
String xmlToTransform,
String expectedResult
)
J#
public static void XslTransformResults(
string xslTransform,
string xmlToTransform,
string expectedResult
)
JScript
public static function XslTransformResults(
xslTransform : String,
xmlToTransform : String,
expectedResult : String
)

Parameters

xslTransform
The XSL transform.
xmlToTransform
The XML to transform.
expectedResult
The expected result.

See Also

OldXmlAssert Class
MbUnit.Framework Namespace
OldXmlAssert.XslTransformResults Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


PairwiseJoinAttribute Class

PairwiseJoinAttribute Class
See Also Example Members
[image]

Sets the join strategy of a test to be pairwise.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class PairwiseJoinAttribute
Inherits JoinAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class PairwiseJoinAttribute : JoinAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class PairwiseJoinAttribute : JoinAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class PairwiseJoinAttribute extends JoinAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class PairwiseJoinAttribute extends JoinAttribute

Remarks

The test will be executed using values drawn from each data source and combined so that all possible pairings of values from each data source are produced. This constraint vastly reduces the number of combinations because we only consider all interactions among pairs of variables rather than among all variables at once. This strategy still provides a high degree of variability among combinations and has a high likelihood of finding bugs while incurring much less cost than testing all possible combinations.

If there are three data sources, A, B and C with values A1, A2, B1, B2, C1 and C2 then the test will be run four times with inputs: (A1, B1, C1), (A2, B2, C1), (A1, B2, C2), (A2, B1, C2). Compare this with the eight times that a standard cross-product combinatorial join strategy would have required.

The algorithm used to compute pairwise coverings is approximate and might not find a minimal pairwise covering of values. However, the relative size of a full combinatorial cross product will still be exponentially larger than that of the covering that is produced.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
MbUnit.Framework.JoinAttribute
MbUnit.Framework.PairwiseJoinAttribute

See Also

PairwiseJoinAttribute Members
MbUnit.Framework Namespace
PairwiseJoinStrategy
SequentialJoinAttribute
CombinatorialJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PairwiseJoinAttribute Members

PairwiseJoinAttribute Members
See Also Example Constructors Properties Methods
[image]

Sets the join strategy of a test to be pairwise.

The following tables list the members exposed by PairwiseJoinAttribute.

Public Constructors

 | Name | Description
Public method | PairwiseJoinAttribute | Initializes a new instance of the PairwiseJoinAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from JoinAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Overridden. Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from JoinAttribute)
Top

See Also

PairwiseJoinAttribute Class
MbUnit.Framework Namespace
PairwiseJoinStrategy
SequentialJoinAttribute
CombinatorialJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PairwiseJoinAttribute Constructor

PairwiseJoinAttribute Constructor
[image]

Initializes a new instance of the PairwiseJoinAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PairwiseJoinAttribute()
C++
public:
PairwiseJoinAttribute() sealed
J#
public PairwiseJoinAttribute()
JScript
public function PairwiseJoinAttribute()

See Also

PairwiseJoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

PairwiseJoinAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from JoinAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Overridden. Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from JoinAttribute)
Top

See Also

PairwiseJoinAttribute Class
MbUnit.Framework Namespace
PairwiseJoinStrategy
SequentialJoinAttribute
CombinatorialJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetJoinStrategy Method

PairwiseJoinAttribute.GetJoinStrategy Method
[image]

Gets the join strategy to use.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetJoinStrategy() As IJoinStrategy
C#
protected override IJoinStrategy GetJoinStrategy()
C++
protected:
virtual IJoinStrategy GetJoinStrategy() override
J#
protected override IJoinStrategy GetJoinStrategy()
JScript
protected override function GetJoinStrategy() : IJoinStrategy

Return Value

The join strategy

See Also

PairwiseJoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParallelizableAttribute Class

ParallelizableAttribute Class
See Also Example Members
[image]

Specifies that a test can be run in parallel with other parallelizable tests.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class ParallelizableAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class ParallelizableAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class ParallelizableAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class ParallelizableAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class ParallelizableAttribute extends TestDecoratorPatternAttribute

Example

This C# example shows a fixture with a few tests, two of which are parallelizable.

Copy Code
            public class Fixture
            {
                // may run in parallel with test 2
                [Parallelizable]
                public void Test1() { ... }

                // may run in parallel with test 1
                [Parallelizable]
                public void Test2() { ... }

                // will not run in parallel because it is not parallelizable
                public void Test3() { ... }
            }

This C# example shows a fixture all of whose tests are parallelizable.

Copy Code
            [Parallizable(TestScope.Descendants)]
            public class Fixture
            {
                public void Test1() { ... }

                public void Test2() { ... }

                public void Test3() { ... }
            }

This C# example shows a test assembly all of whose tests are parallelizable.

Copy Code
            [assembly: Parallizable(TestScope.All)]

Remarks

If this attribute is not specified, then the test will be run with Process-level isolation. That is, it will not run concurrently with any other test within the given process (notwithstanding any use of ThreadedRepeatAttribute or similar decorators).

Parallelizable tests are run in batches subject to the hierarchical structure of the tests, any explicit ordering specifications, and test dependencies.

If two tests must be run exclusively of one another but are otherwise parallelizable, then a simple expedient is to assign a different test order to each one. Later editions of the framework may introduce additional controls over test isolation, mutual exclusion, access to shared resources, and degree of paralleism.

To make all tests within a fixture parallelizable, apply this attribute to the fixture class with a scope of Descendants to only make the tests parallelizable or All to also make the fixture itself parallelizable. Likewise to make all tests in a test assembly parallelizable, apply this attribute to the test assembly with the scope set similarly.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.ParallelizableAttribute

See Also

ParallelizableAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParallelizableAttribute Members

ParallelizableAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Specifies that a test can be run in parallel with other parallelizable tests.

The following tables list the members exposed by ParallelizableAttribute.

Public Constructors

Name | Description
ParallelizableAttribute | Overloaded. Initializes a new instance of the ParallelizableAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Scope | Gets the scope to which the parallelizable attribute applies.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
ParallelizableAttribute | Overloaded. Initializes a new instance of the ParallelizableAttribute class.
Top

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParallelizableAttribute Constructor

ParallelizableAttribute Constructor

Initializes a new instance of the ParallelizableAttribute class.

Overload List

 | Name | Description
Public method | ParallelizableAttribute | Specifies that this test is parallelizable.
Public method | ParallelizableAttribute (TestScope) | Specifies that the tests in the specified scope are parallelizable.

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParallelizableAttribute Constructor ()

ParallelizableAttribute Constructor ()
See Also Example
[image]

Specifies that this test is parallelizable.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParallelizableAttribute()
C++
public:
ParallelizableAttribute() sealed
J#
public ParallelizableAttribute()
JScript
public function ParallelizableAttribute()

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace
ParallelizableAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParallelizableAttribute Constructor (TestScope)

ParallelizableAttribute Constructor (TestScope)
See Also Example
[image]

Specifies that the tests in the specified scope are parallelizable.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal scope As TestScope _
)
C#
public ParallelizableAttribute(
TestScope scope
)
C++
public:
ParallelizableAttribute(
TestScope scope
) sealed
J#
public ParallelizableAttribute(
TestScope scope
)
JScript
public function ParallelizableAttribute(
scope : TestScope
)

Parameters

scope
The test scope

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace
ParallelizableAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ParallelizableAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Scope | Gets the scope to which the parallelizable attribute applies.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Scope Property

ParallelizableAttribute.Scope Property
[image]

Gets the scope to which the parallelizable attribute applies.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scope As TestScope
C#
public TestScope Scope { get; }
C++
public property TestScope Scope sealed {
TestScope get();
}
J#
/** property */
public TestScope get_Scope();
JScript
public function get Scope() : TestScope

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ParallelizableAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

ParallelizableAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

ParallelizableAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParameterAttribute Class

ParameterAttribute Class
See Also Example Members
[image]

Declares that a property, field, method parameter, constructor parameter, generic type parameter or generic method parameter represents a test parameter.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := False, Inherited := True)>
Public Class ParameterAttribute
Inherits TestParameterPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True)]
public class ParameterAttribute : TestParameterPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = False, Inherited = True)]
ref class ParameterAttribute : TestParameterPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True) */
public class ParameterAttribute extends TestParameterPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = False, Inherited = True)
class ParameterAttribute extends TestParameterPatternAttribute

Example

[Header("Parameter1", "Parameter2")] [Row(1, "a")] [Row(2, "b")] public class Fixture { [TestParameter] public int Parameter1; [TestParameter] public string Parameter2 { get; set; } }

Remarks

This attribute is optional for a method parameter, constructor parameter, generic type parameter or generic method parameter. For a property or field, this attribute is required unless the property or field has at least one associated data source, in which case the attribute can be omitted.

In other words, this attribute only needs to be specified on a property or field that does not have an associated explicit data binding attribute. This is typically the case when the parameter obtains its values from a data source defined by the test fixture.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestParameterPatternAttribute
MbUnit.Framework.ParameterAttribute

See Also

ParameterAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParameterAttribute Members

ParameterAttribute Members
See Also Example Constructors Properties Methods
[image]

Declares that a property, field, method parameter, constructor parameter, generic type parameter or generic method parameter represents a test parameter.

The following tables list the members exposed by ParameterAttribute.

Public Constructors

 | Name | Description
Public method | ParameterAttribute | Initializes a new instance of the ParameterAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from TestParameterPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestParameterPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from TestParameterPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTestParameter | Initializes a test parameter after it has been added to the containing test. (inherited from TestParameterPatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestParameterPatternAttribute)
Top

See Also

ParameterAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ParameterAttribute Constructor

ParameterAttribute Constructor
[image]

Initializes a new instance of the ParameterAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParameterAttribute()
C++
public:
ParameterAttribute() sealed
J#
public ParameterAttribute()
JScript
public function ParameterAttribute()

See Also

ParameterAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PendingAttribute Class

PendingAttribute Class
See Also Example Members
[image]

Indicates that a test has pending prerequisites so it will not be run. The test will still appear in test reports along with an explanation of the reason it it pending, if provided.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class PendingAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class PendingAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class PendingAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class PendingAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class PendingAttribute extends TestDecoratorPatternAttribute

Remarks

This attribute can be used to disable tests that cannot run because the subject under test is missing certain prerequisite functionality. It may also serve as a placeholder for test that have yet to be implemented.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.PendingAttribute

See Also

PendingAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PendingAttribute Members

PendingAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Indicates that a test has pending prerequisites so it will not be run. The test will still appear in test reports along with an explanation of the reason it it pending, if provided.

The following tables list the members exposed by PendingAttribute.

Public Constructors

Name | Description
PendingAttribute | Overloaded. Initializes a new instance of the PendingAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Reason | Gets the reason that the test is pending.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
PendingAttribute | Overloaded. Initializes a new instance of the PendingAttribute class.
Top

See Also

PendingAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PendingAttribute Constructor

PendingAttribute Constructor

Initializes a new instance of the PendingAttribute class.

Overload List

 | Name | Description
Public method | PendingAttribute | Indicates that this test has pending prerequisites without providing a reason.
Public method | PendingAttribute (String) | Indicates that this test has pending prerequisites and provides a reason.

See Also

PendingAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PendingAttribute Constructor ()

PendingAttribute Constructor ()
See Also Example
[image]

Indicates that this test has pending prerequisites without providing a reason.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PendingAttribute()
C++
public:
PendingAttribute() sealed
J#
public PendingAttribute()
JScript
public function PendingAttribute()

See Also

PendingAttribute Class
MbUnit.Framework Namespace
PendingAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PendingAttribute Constructor (String)

PendingAttribute Constructor (String)
See Also Example
[image]

Indicates that this test has pending prerequisites and provides a reason.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal reason As String _
)
C#
public PendingAttribute(
string reason
)
C++
public:
PendingAttribute(
String reason
) sealed
J#
public PendingAttribute(
string reason
)
JScript
public function PendingAttribute(
reason : String
)

Parameters

reason
The reason for which the test is pending

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if reason is null

See Also

PendingAttribute Class
MbUnit.Framework Namespace
PendingAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

PendingAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Reason | Gets the reason that the test is pending.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

PendingAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reason Property

PendingAttribute.Reason Property
[image]

Gets the reason that the test is pending.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reason As String
C#
public string Reason { get; }
C++
public property string Reason sealed {
String get();
}
J#
/** property */
public string get_Reason();
JScript
public function get Reason() : String

See Also

PendingAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

PendingAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

PendingAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

PendingAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

PendingAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RepeatAttribute Class

RepeatAttribute Class
See Also Example Members
[image]

Decorates a test method and causes it to be invoked repeatedly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public Class RepeatAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public class RepeatAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class RepeatAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class RepeatAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class RepeatAttribute extends TestDecoratorPatternAttribute

Remarks

Each repetition of the test method will occur within its own individually labeled test step so that it can be identified in the test report.

The initialize, setup, teardown and dispose methods will are invoked around each repetition of the test.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.RepeatAttribute

See Also

RepeatAttribute Members
MbUnit.Framework Namespace
ThreadedRepeatAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RepeatAttribute Members

RepeatAttribute Members
See Also Example Constructors Properties Methods
[image]

Decorates a test method and causes it to be invoked repeatedly.

The following tables list the members exposed by RepeatAttribute.

Public Constructors

 | Name | Description
Public method | RepeatAttribute | Executes the test method repeatedly.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

RepeatAttribute Class
MbUnit.Framework Namespace
ThreadedRepeatAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RepeatAttribute Constructor

RepeatAttribute Constructor
[image]

Executes the test method repeatedly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal numRepetitions As Integer _
)
C#
public RepeatAttribute(
int numRepetitions
)
C++
public:
RepeatAttribute(
int numRepetitions
) sealed
J#
public RepeatAttribute(
int numRepetitions
)
JScript
public function RepeatAttribute(
numRepetitions : int
)

Parameters

numRepetitions
The number of times to repeat the test

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if numRepetitions is less than 1

Remarks

Copy Code
            [Test]
            [Repeat(10)]
            public void Test()
            {
                // This test will be executed 10 times.
            }

See Also

RepeatAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

RepeatAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

RepeatAttribute Class
MbUnit.Framework Namespace
ThreadedRepeatAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

RepeatAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

RepeatAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RollbackAttribute Class

RollbackAttribute Class
See Also Example Members
[image]

Decorates a test method whose database operation must be executed within a transaction and rolled back when it has finished executing.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public Class RollbackAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public class RollbackAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class RollbackAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class RollbackAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class RollbackAttribute extends TestDecoratorPatternAttribute

Example

The following example shows the RollbackAttribute in use:

Copy Code
            [TestFixture]
            public class RollbackTest {

                [Test, Rollback]
                public void TestWithRollback()
                {
                    // Any transaction performed within this test will be rolled back
                    // automatically when the test completes.
                }

                [Test, Rollback(IncludeSetupAndTearDown=true)]
                public void TestWithRollback()
                {
                    // Any transaction performed within this test or within its setup and
                    // teardown will be rolled back automatically when the test completes.
                }
            }

Remarks

By default, the attribute does not rollback changes performed during SetUp and TearDown. Set the IncludeSetUpAndTearDown to true to change this.

The attribute uses a TransactionScope to set an ambient transaction that will be rolled back. Assuming the subject under test enlists itself with this transaction then its transactions operations will be rolled back.

Unfortunately there are a few caveats from this approach, the subject under test might use its own transaction manager and ignore the ambient transaction set up here. Likewise, it is possible that the presence of an enclosing transaction scope can interfere with the normal operation of the subject under test.

If this attribute does not work for a particular application, we recommend that you create your own custom rollback decorator attribute with the appropriate application-specific semantics. Just create a new subclass of TestDecoratorAttribute and override the Execute method to wrap test execution as required.

Here are a few troubleshooting tips in case Rollback is not working properly for your application:

  • Ensure that the subject under test enlists its work in the current "ambient" transaction managed by the TransactionManager. Not all databases support these transactions.
  • Ensure that the Distributed Transaction Coordinator service is enabled and running if you are using COM+ transactions.
  • Ensure that the database is configured to enable distributed transactions. This feature is sometimes disabled for performance reasons to prevent long-running distributed transactions from locking database resources.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.RollbackAttribute

See Also

RollbackAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RollbackAttribute Members

RollbackAttribute Members
See Also Example Constructors Properties Methods
[image]

Decorates a test method whose database operation must be executed within a transaction and rolled back when it has finished executing.

The following tables list the members exposed by RollbackAttribute.

Public Constructors

 | Name | Description
Public method | RollbackAttribute | Tags a test method whose database operation must be executed within a transaction and rolled back when it has finished executing.
Top

Public Properties

Name | Description
Public property IncludeSetUpAndTearDown

When set to true, includes setup and teardown in the rollback. Otherwise only transactions performed during the test itself are affected.

The fixture setup and teardown is not included regardless unless this attribute is applied to the fixture class itself instead of the test method.

Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

RollbackAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RollbackAttribute Constructor

RollbackAttribute Constructor
[image]

Tags a test method whose database operation must be executed within a transaction and rolled back when it has finished executing.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RollbackAttribute()
C++
public:
RollbackAttribute() sealed
J#
public RollbackAttribute()
JScript
public function RollbackAttribute()

See Also

RollbackAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

RollbackAttribute Properties
[image]

Public Properties

Name | Description
Public property IncludeSetUpAndTearDown

When set to true, includes setup and teardown in the rollback. Otherwise only transactions performed during the test itself are affected.

The fixture setup and teardown is not included regardless unless this attribute is applied to the fixture class itself instead of the test method.

Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

RollbackAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IncludeSetUpAndTearDown Property

RollbackAttribute.IncludeSetUpAndTearDown Property
[image]

When set to true, includes setup and teardown in the rollback. Otherwise only transactions performed during the test itself are affected.

The fixture setup and teardown is not included regardless unless this attribute is applied to the fixture class itself instead of the test method.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeSetUpAndTearDown As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool IncludeSetUpAndTearDown { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool IncludeSetUpAndTearDown sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IncludeSetUpAndTearDown();

/** property */
public void set_IncludeSetUpAndTearDown(bool value);
JScript
public CompilerGeneratedAttribute function get IncludeSetUpAndTearDown() : bool

public CompilerGeneratedAttribute function set IncludeSetUpAndTearDown(value : bool);

See Also

RollbackAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

RollbackAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

RollbackAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

RollbackAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

RollbackAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RowAttribute Class

RowAttribute Class
See Also Example Members
[image]

Provides a row of literal values as a data source.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False), _
AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class RowAttribute
Inherits DataAttribute
C#
[CLSCompliantAttribute(False)]
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class RowAttribute : DataAttribute
C++
[CLSCompliantAttribute(False)]
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class RowAttribute : DataAttribute
J#
/** @attribute CLSCompliantAttribute(False) */
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class RowAttribute extends DataAttribute
JScript
public
CLSCompliantAttribute(False)
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class RowAttribute extends DataAttribute

Example

[Test] [Row(1, "a", 0.1)] [Row(2, "b", 0.2)] public void ATest(int x, string y, double z) { // This test will run twice. Once with x = 1, y = "a", and z = 0.1 // then again with x = 2, y = "b", and z = 0.2. }

Remarks

The values specified in the row are used for data-driven testing purposes. A row may specify zero or more values that are manipulated as a unit. Typically each row generates a single instance instance of a data-driven test.

By default, the columns provided by the row data source are unnamed. Use HeaderAttribute to provide an explicit name for each column.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.DataAttribute
MbUnit.Framework.RowAttribute

See Also

RowAttribute Members
MbUnit.Framework Namespace
ColumnAttribute
HeaderAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RowAttribute Members

RowAttribute Members
See Also Example Constructors Properties Methods
[image]

Provides a row of literal values as a data source.

The following tables list the members exposed by RowAttribute.

Public Constructors

 | Name | Description
Public method | RowAttribute | Adds a row of literal values.
Top

Public Properties

Name | Description
Public property | Description | Gets or sets a description of the values provided by the data source. (inherited from DataAttribute)
Public property | ExpectedException | Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test. (inherited from DataAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | Values | Gets the array of values in the row.
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata for the data source. (inherited from DataAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

RowAttribute Class
MbUnit.Framework Namespace
ColumnAttribute
HeaderAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RowAttribute Constructor

RowAttribute Constructor
[image]

Adds a row of literal values.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<CLSCompliantAttribute(False)>
Public Sub New( _
ByVal ParamArray values As Object() _
)
C#
[CLSCompliantAttribute(False)]
public RowAttribute(
params object[] values
)
C++
[CLSCompliantAttribute(False)]
public:
RowAttribute(
... array<Object>^ values
) sealed
J#
/** @attribute CLSCompliantAttribute(False) */
public RowAttribute(
object[] values
)
JScript
public

CLSCompliantAttribute(False)
function RowAttribute(
ParamArrayAttribute values : Object[]
)

Parameters

values
The array of values in the row

Remarks

There exist two ambiguities in the use of this attribute that result from how the C# compiler handles functions that accept a variable number of arguments.

Case 1: If there is only 1 argument and its value is null, the compiler will pass a null array reference to the attribute constructor. Since the value array cannot be null, the attribute will assume that you meant to create an array consiting of a single null.

Copy Code
            // Example of case #1.
            // The attribute will assume that you intended to pass in a single null value.
            [Test]
            [Row(null)]
            public void Test(object value)
            {
                Assert.IsNull(value);
            }

Case 2: If there is only 1 argument and its value is an object array, the compiler will pass the array itself as the argument values. Unfortunately, the attribute constructor cannot distinguish this case from the usual case when multiple arguments are present. So you need to disambiguate this case explicitly.

Copy Code
            // Example of case #2.
            // The attribute will treat both of the following declarations equivalently
            // contrary to what we probably intend.
            [Row(new object[] { 1, 2, 3 })]
            [Row(1, 2, 3)]

To fix this case, you must provide explicit disambiguation. (We cannot do it automatically based on the number of method parameters provided because the row attribute can be applied to other elements besides methods and its contents might be consumed in other ways.)

Copy Code
            // Example of case #2, disambiguated to define a row that contains only an array of values.
            [Test]
            [Row(new object[] { new object[] { 1, 2, 3 })]
            public void Test(object[] values)
            {
                ArrayAssert.AreElementsEqual(new object[] { 1, 2, 3 }, values);
            }

See Also

RowAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

RowAttribute Properties
[image]

Public Properties

Name | Description
Public property | Description | Gets or sets a description of the values provided by the data source. (inherited from DataAttribute)
Public property | ExpectedException | Gets or sets the type of exception that should be thrown when the values provided by the data source are consumed by test. (inherited from DataAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | Values | Gets the array of values in the row.
Top

See Also

RowAttribute Class
MbUnit.Framework Namespace
ColumnAttribute
HeaderAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Values Property

RowAttribute.Values Property
[image]

Gets the array of values in the row.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As Object()
C#
public object[] Values { get; }
C++
public property object[] Values sealed {
array<Object>^ get();
}
J#
/** property */
public object[] get_Values();
JScript
public function get Values() : Object[]

See Also

RowAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

RowAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Gets the metadata for the data source. (inherited from DataAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from DataPatternAttribute)
Top

See Also

RowAttribute Class
MbUnit.Framework Namespace
ColumnAttribute
HeaderAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PopulateDataSource Method

RowAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
) override
J#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected override function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

RowAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RowTestAttribute Class

RowTestAttribute Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use the MbUnit v3 [Test] attribute instead. The MbUnit v3 data-driven testing features have been consolidated so the [RowTest] attribute is no longer necessary.

Provides compatibility with MbUnit v2 row test feature.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class RowTestAttribute
Inherits TestAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class RowTestAttribute : TestAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class RowTestAttribute : TestAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class RowTestAttribute extends TestAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class RowTestAttribute extends TestAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestMethodPatternAttribute
MbUnit.Framework.TestAttribute
MbUnit.Framework.RowTestAttribute

See Also

RowTestAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


RowTestAttribute Members

RowTestAttribute Members
See Also Example Constructors Properties Methods
[image]

NOTE: This class is now obsolete.

Use the MbUnit v3 [Test] attribute instead. The MbUnit v3 data-driven testing features have been consolidated so the [RowTest] attribute is no longer necessary.

Provides compatibility with MbUnit v2 row test feature.

The following tables list the members exposed by RowTestAttribute.

Public Constructors

 | Name | Description
Public method | RowTestAttribute | Initializes a new instance of the RowTestAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from TestMethodPatternAttribute)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from TestMethodPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none. (inherited from TestMethodPatternAttribute)
Family property | DefaultMethodParameterPattern | Gets the default pattern to apply to method parameters that do not have a primary pattern, or null if none. (inherited from TestMethodPatternAttribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestMethodPatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Executes the test method. (inherited from TestAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model. (inherited from TestMethodPatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest. (inherited from TestMethodPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodPatternAttribute)
Top

See Also

RowTestAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


RowTestAttribute Constructor

RowTestAttribute Constructor
[image]

Initializes a new instance of the RowTestAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowTestAttribute()
C++
public:
RowTestAttribute() sealed
J#
public RowTestAttribute()
JScript
public function RowTestAttribute()

See Also

RowTestAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


SequentialJoinAttribute Class

SequentialJoinAttribute Class
See Also Example Members
[image]

Sets the join strategy of a test to be sequential.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class SequentialJoinAttribute
Inherits JoinAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class SequentialJoinAttribute : JoinAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class SequentialJoinAttribute : JoinAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class SequentialJoinAttribute extends JoinAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class SequentialJoinAttribute extends JoinAttribute

Remarks

The test will be executed using values drawn from each data source and combined sequentially with elements from each data source chosen in order.

If there are two data sources, A and B with values A1, A2, B1 and B2, then the test will be run twice with inputs: (A1, B1) and (A2, B2).

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
MbUnit.Framework.JoinAttribute
MbUnit.Framework.SequentialJoinAttribute

See Also

SequentialJoinAttribute Members
MbUnit.Framework Namespace
SequentialJoinStrategy
CombinatorialJoinAttribute
PairwiseJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SequentialJoinAttribute Members

SequentialJoinAttribute Members
See Also Example Constructors Properties Methods
[image]

Sets the join strategy of a test to be sequential.

The following tables list the members exposed by SequentialJoinAttribute.

Public Constructors

 | Name | Description
Public method | SequentialJoinAttribute | Initializes a new instance of the SequentialJoinAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from JoinAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Overridden. Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from JoinAttribute)
Top

See Also

SequentialJoinAttribute Class
MbUnit.Framework Namespace
SequentialJoinStrategy
CombinatorialJoinAttribute
PairwiseJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SequentialJoinAttribute Constructor

SequentialJoinAttribute Constructor
[image]

Initializes a new instance of the SequentialJoinAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SequentialJoinAttribute()
C++
public:
SequentialJoinAttribute() sealed
J#
public SequentialJoinAttribute()
JScript
public function SequentialJoinAttribute()

See Also

SequentialJoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

SequentialJoinAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from JoinAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetJoinStrategy | Overridden. Gets the join strategy to use.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from JoinAttribute)
Top

See Also

SequentialJoinAttribute Class
MbUnit.Framework Namespace
SequentialJoinStrategy
CombinatorialJoinAttribute
PairwiseJoinAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetJoinStrategy Method

SequentialJoinAttribute.GetJoinStrategy Method
[image]

Gets the join strategy to use.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetJoinStrategy() As IJoinStrategy
C#
protected override IJoinStrategy GetJoinStrategy()
C++
protected:
virtual IJoinStrategy GetJoinStrategy() override
J#
protected override IJoinStrategy GetJoinStrategy()
JScript
protected override function GetJoinStrategy() : IJoinStrategy

Return Value

The join strategy

See Also

SequentialJoinAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetUpAttribute Class

SetUpAttribute Class
See Also Example Members
[image]

Specifies a method that is to be invoked before each test in a fixture executes to set up the state of the test. The method will run once for each test. This class cannot be inherited.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public NotInheritable Class SetUpAttribute
Inherits ContributionMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public sealed class SetUpAttribute : ContributionMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class SetUpAttribute sealed : ContributionMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public final class SetUpAttribute extends ContributionMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
final class SetUpAttribute extends ContributionMethodPatternAttribute

Remarks

The attribute may be applied to multiple methods within a fixture, however the order in which they are processed is undefined.

The method to which this attribute is applied must be declared by the fixture class and must not have any parameters. The method may be static.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.SetUpAttribute

See Also

SetUpAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetUpAttribute Members

SetUpAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is to be invoked before each test in a fixture executes to set up the state of the test. The method will run once for each test. This class cannot be inherited.

The following tables list the members exposed by SetUpAttribute.

Public Constructors

 | Name | Description
Public method | SetUpAttribute | Initializes a new instance of the SetUpAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetUpAttribute Constructor

SetUpAttribute Constructor
[image]

Initializes a new instance of the SetUpAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SetUpAttribute()
C++
public:
SetUpAttribute() sealed
J#
public SetUpAttribute()
JScript
public function SetUpAttribute()

See Also

SetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


StaticTestFactoryAttribute Class

StaticTestFactoryAttribute Class
See Also Example Members
[image]

Specifies a method that is used to generate tests statically at test exploration time.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class StaticTestFactoryAttribute
Inherits ContributionMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class StaticTestFactoryAttribute : ContributionMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class StaticTestFactoryAttribute : ContributionMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class StaticTestFactoryAttribute extends ContributionMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class StaticTestFactoryAttribute extends ContributionMethodPatternAttribute

Example

A simple static test factory that reads some data from a file and generates a number of static tests. The file is read at test exploration time, so if the file changes, the test package must be reloaded to obtain the new contents.

Copy Code
            [StaticTestFactory]
            public static IEnumerable<Test> CreateStaticTests()
            {
                foreach (string searchTerm in File.ReadAllLines("SearchTerms.txt"))
                {
                    yield return new TestCase("Search Term: " + searchTerm, () => {
                        var searchEngine = new SearchEngine();
                        Assert.IsNotEmpty(searchEngine.GetSearchResults(searchTerm));
                    });
                }
            }

Remarks

The tests created by the static test factory are considered to be children of the fixture that contains the factory method that generated them. Because the tests are created statically, they will appear in the test runner and they can be filtered as usual. However, this means that the tests will be generated only when the fixture is being explored rather than each time the fixture is executed. It also means that the factory method must be static and cannot be parameterized.

Contrast with DynamicTestFactoryAttribute.

The method to which this attribute is applied must be declared by the fixture class. It must be static and must not have any parameters. It must return an enumeration of values of type Test.

Tests built by a StaticTestFactoryAttribute will not be visible in ReSharper and other test runners that rely only on source code and metadata exclusively. This is because the test factory must be executed in order to populate the list of tests but the code might not be available in a compiled form during test exploration. The tests should still run as part of the containing fixture although the results may only be visible in the full test report.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.StaticTestFactoryAttribute

See Also

StaticTestFactoryAttribute Members
MbUnit.Framework Namespace
DynamicTestFactoryAttribute
TestCase

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


StaticTestFactoryAttribute Members

StaticTestFactoryAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is used to generate tests statically at test exploration time.

The following tables list the members exposed by StaticTestFactoryAttribute.

Public Constructors

 | Name | Description
Public method | StaticTestFactoryAttribute | Initializes a new instance of the StaticTestFactoryAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

StaticTestFactoryAttribute Class
MbUnit.Framework Namespace
DynamicTestFactoryAttribute
TestCase

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


StaticTestFactoryAttribute Constructor

StaticTestFactoryAttribute Constructor
[image]

Initializes a new instance of the StaticTestFactoryAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StaticTestFactoryAttribute()
C++
public:
StaticTestFactoryAttribute() sealed
J#
public StaticTestFactoryAttribute()
JScript
public function StaticTestFactoryAttribute()

See Also

StaticTestFactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

StaticTestFactoryAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Overridden. Applies decorations to the containing test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Overridden. Verifies that the attribute is being used correctly.
Top

See Also

StaticTestFactoryAttribute Class
MbUnit.Framework Namespace
DynamicTestFactoryAttribute
TestCase

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateContainingScope Method

StaticTestFactoryAttribute.DecorateContainingScope Method
[image]

Applies decorations to the containing test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateContainingScope( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void DecorateContainingScope(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function DecorateContainingScope(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method to process

See Also

StaticTestFactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

StaticTestFactoryAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal method As IMethodInfo _
)
C#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IMethodInfo method
) override
J#
protected override void Validate(
IPatternScope containingScope,
IMethodInfo method
)
JScript
protected override function Validate(
containingScope : IPatternScope,
method : IMethodInfo
)

Parameters

containingScope
The containing scope
method
The method

See Also

StaticTestFactoryAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TearDownAttribute Class

TearDownAttribute Class
See Also Example Members
[image]

Specifies a method that is to be invoked after each test in a fixture executes to tear down the state of the test. The method will run once for each test. This class cannot be inherited.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public NotInheritable Class TearDownAttribute
Inherits ContributionMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public sealed class TearDownAttribute : ContributionMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TearDownAttribute sealed : ContributionMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public final class TearDownAttribute extends ContributionMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
final class TearDownAttribute extends ContributionMethodPatternAttribute

Remarks

The attribute may be applied to multiple methods within a fixture, however the order in which they are processed is undefined.

The method to which this attribute is applied must be declared by the fixture class and must not have any parameters. The method may be static.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.TearDownAttribute

See Also

TearDownAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TearDownAttribute Members

TearDownAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies a method that is to be invoked after each test in a fixture executes to tear down the state of the test. The method will run once for each test. This class cannot be inherited.

The following tables list the members exposed by TearDownAttribute.

Public Constructors

 | Name | Description
Public method | TearDownAttribute | Initializes a new instance of the TearDownAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TearDownAttribute Constructor

TearDownAttribute Constructor
[image]

Initializes a new instance of the TearDownAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TearDownAttribute()
C++
public:
TearDownAttribute() sealed
J#
public TearDownAttribute()
JScript
public function TearDownAttribute()

See Also

TearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Test Class

Test Class
See Also Example Members
[image]

Describes a test generated either at test exploration time or at test execution time by a test factory. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class Test
C#
public abstract class Test
C++
ref class Test abstract
J#
public class Test
JScript
public class Test

Example

Produces a suite of static tests as part of a containing test fixture. The suite includes some custom set-up and tear-down behavior, metadata, a timeout, an order relative to the other tests in the fixture, and a list of children. There are two test cases defined in line, and one reference to another statically defined test elsewhere.

Copy Code
            [StaticTestFactory]
            public static IEnumerable<Test> TestSuite()
            {
                yield return new TestSuite("My Suite")
                {
                    Description = "An example test suite.",
                    Metadata =
                    {
                        { MetadataKeys.AuthorName, "Me" },
                        { MetadataKeys.AuthorEmail, "me@mycompany.com" }
                    },
                    SuiteSetUp = () => DatabaseUtils.SetUpDatabase(),
                    SuiteTearDown = () => DatabaseUtils.TearDownDatabase(),
                    Timeout = TimeSpan.FromMinutes(2),
                    Children =
                    {
                        new TestCase("Test 1", () => {
                            // first test in suite
                        }),
                        new TestCase("Test 2", () => {
                           // second test in suite
                        }),
                        new TestFixtureReference(typeof(OtherFixtureToIncludeInSuite))
                    }
                };
            }

Remarks

Tests cam be nested to form test suites and other aggregates.

Inheritance Hierarchy

System.Object
MbUnit.Framework.Test
MbUnit.Framework.TestDefinition
MbUnit.Framework.TestFixtureReference

See Also

Test Members
MbUnit.Framework Namespace
StaticTestFactoryAttribute
DynamicTestFactoryAttribute
TestCase
TestSuite
TestFixtureReference

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Test Members

Test Members
See Also Example Constructors Methods
[image]

Describes a test generated either at test exploration time or at test execution time by a test factory. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by Test.

Protected Constructors

 | Name | Description
Family method | Test | Initializes a new instance of the Test class.
Top

Public Methods

 | Name | Description
 | BuildStaticTests | Builds a collection of static tests during test exploration.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | RunDynamicTests | Runs a collection of dynamic tests during test execution.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Builds a static test during test exploration.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunDynamicTest | Runs a dynamic test during test execution.
Top

See Also

Test Class
MbUnit.Framework Namespace
StaticTestFactoryAttribute
DynamicTestFactoryAttribute
TestCase
TestSuite
TestFixtureReference

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Test Constructor

Test Constructor
[image]

Initializes a new instance of the Test class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected Test()
C++
protected:
Test() sealed
J#
protected Test()
JScript
protected function Test()

See Also

Test Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

Test Methods
[image]

Public Methods

 | Name | Description
 | BuildStaticTests | Builds a collection of static tests during test exploration.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | RunDynamicTests | Runs a collection of dynamic tests during test execution.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Builds a static test during test exploration.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunDynamicTest | Runs a dynamic test during test execution.
Top

See Also

Test Class
MbUnit.Framework Namespace
StaticTestFactoryAttribute
DynamicTestFactoryAttribute
TestCase
TestSuite
TestFixtureReference

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BuildStaticTest Method

Test.BuildStaticTest Method
[image]

Builds a static test during test exploration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub BuildStaticTest( _
ByVal containingScope As IPatternScope, _
ByVal declaringCodeElement As ICodeElementInfo _
)
C#
protected abstract void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
C++
protected:
void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
) abstract
J#
protected abstract void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
JScript
protected abstract function BuildStaticTest(
containingScope : IPatternScope,
declaringCodeElement : ICodeElementInfo
)

Parameters

containingScope
The containing pattern evaluation scope
declaringCodeElement
The code element that represents the scope in which the test was defined

Remarks

Subclasses may override this behavior to change how the static test gets added to the test model.

See Also

Test Class
MbUnit.Framework Namespace
StaticTestFactoryAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BuildStaticTests Method

Test.BuildStaticTests Method
[image]

Builds a collection of static tests during test exploration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub BuildStaticTests( _
ByVal tests As IEnumerable(Of Test), _
ByVal containingScope As IPatternScope, _
ByVal declaringCodeElement As ICodeElementInfo _
)
C#
public static void BuildStaticTests(
IEnumerable<Test> tests,
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
C++
public:
static void BuildStaticTests(
IEnumerable<Test> tests,
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
J#
public static void BuildStaticTests(
IEnumerable<Test> tests,
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
JScript
public static function BuildStaticTests(
tests : IEnumerable<Test>,
containingScope : IPatternScope,
declaringCodeElement : ICodeElementInfo
)

Parameters

tests
The enumeration of tests to build as children of the containing scope
containingScope
The containing pattern evaluation scope
declaringCodeElement
The code element that represents the scope in which the test was defined

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if containingScope, declaringCodeElement or tests is null or contains a null

See Also

Test Class
MbUnit.Framework Namespace
StaticTestFactoryAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RunDynamicTest Method

Test.RunDynamicTest Method
[image]

Runs a dynamic test during test execution.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Protected MustOverride Function RunDynamicTest( _
ByVal declaringCodeElement As ICodeElementInfo, _
ByVal setUp As Action, _
ByVal tearDown As Action _
) As TestOutcome
C#
[TestFrameworkInternalAttribute]
protected abstract TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
C++
[TestFrameworkInternalAttribute]
protected:
TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
) abstract
J#
/** @attribute TestFrameworkInternalAttribute() */
protected abstract TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
JScript
protected abstract

TestFrameworkInternalAttribute
function RunDynamicTest(
declaringCodeElement : ICodeElementInfo,
setUp : Action,
tearDown : Action
) : TestOutcome

Parameters

declaringCodeElement
The code element that represents the scope in which the test was defined
setUp
Optional set-up code to run before the test, or null if none
tearDown
Optional tear-down code to run after the test, or null if none

Remarks

Subclasses may override this behavior to change how the dynamic test is executed as a test step.

See Also

Test Class
MbUnit.Framework Namespace
DynamicTestFactoryAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RunDynamicTests Method

Test.RunDynamicTests Method
[image]

Runs a collection of dynamic tests during test execution.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public Shared Function RunDynamicTests( _
ByVal tests As IEnumerable(Of Test), _
ByVal declaringCodeElement As ICodeElementInfo, _
ByVal setUp As Action, _
ByVal tearDown As Action _
) As TestOutcome
C#
[TestFrameworkInternalAttribute]
public static TestOutcome RunDynamicTests(
IEnumerable<Test> tests,
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
C++
[TestFrameworkInternalAttribute]
public:
static TestOutcome RunDynamicTests(
IEnumerable<Test> tests,
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
J#
/** @attribute TestFrameworkInternalAttribute() */
public static TestOutcome RunDynamicTests(
IEnumerable<Test> tests,
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
JScript
public static

TestFrameworkInternalAttribute
function RunDynamicTests(
tests : IEnumerable<Test>,
declaringCodeElement : ICodeElementInfo,
setUp : Action,
tearDown : Action
) : TestOutcome

Parameters

tests
The enumeration of tests to run
declaringCodeElement
The code element that represents the scope in which the test was defined
setUp
Optional set-up code to run before the test, or null if none
tearDown
Optional tear-down code to run after the test, or null if none

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if declaringCodeElement or tests is null or contains a null

See Also

Test Class
MbUnit.Framework Namespace
DynamicTestFactoryAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestAttribute Class

TestAttribute Class
See Also Example Members
[image]

Specifies that a method represents a single test case within a fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class TestAttribute
Inherits TestMethodPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class TestAttribute : TestMethodPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TestAttribute : TestMethodPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class TestAttribute extends TestMethodPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class TestAttribute extends TestMethodPatternAttribute

Remarks

By default, if the method throws an unexpected exception, the test will be deemed to have failed. Otherwise, the test will pass.

The default behavior may be modified by test decorator attributes that may alter the execution environment of the test, catch and reinterpret any exceptions it throws, or impose additional constraints upon its execution.

Output from the test, such as text written to the console, is captured by the framework and will be included in the test report. Additional information can also be logged during test execution using the TestLog class.

A test method has a timeout of 10 minutes by default. This may be changed using the TimeoutAttribute.

The method to which this attribute is applied must be declared by the fixture class. The method may be static. If it has parameters, then the test is considered to be data-driven.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestMethodPatternAttribute
MbUnit.Framework.TestAttribute
MbUnit.Framework.RowTestAttribute

See Also

TestAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestAttribute Members

TestAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies that a method represents a single test case within a fixture.

The following tables list the members exposed by TestAttribute.

Public Constructors

 | Name | Description
Public method | TestAttribute | Initializes a new instance of the TestAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from TestMethodPatternAttribute)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from TestMethodPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none. (inherited from TestMethodPatternAttribute)
Family property | DefaultMethodParameterPattern | Gets the default pattern to apply to method parameters that do not have a primary pattern, or null if none. (inherited from TestMethodPatternAttribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestMethodPatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Overridden. Executes the test method.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model. (inherited from TestMethodPatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest. (inherited from TestMethodPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodPatternAttribute)
Top

See Also

TestAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestAttribute Constructor

TestAttribute Constructor
[image]

Initializes a new instance of the TestAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestAttribute()
C++
public:
TestAttribute() sealed
J#
public TestAttribute()
JScript
public function TestAttribute()

See Also

TestAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestMethodPatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Execute | Overridden. Executes the test method.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a method after it has been added to the test model. (inherited from TestMethodPatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest. (inherited from TestMethodPatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestMethodPatternAttribute)
Top

See Also

TestAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Execute Method

TestAttribute.Execute Method
[image]

Executes the test method.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function Execute( _
ByVal state As PatternTestInstanceState _
) As Object
C#
protected override object Execute(
PatternTestInstanceState state
)
C++
protected:
virtual Object Execute(
PatternTestInstanceState state
) override
J#
protected override object Execute(
PatternTestInstanceState state
)
JScript
protected override function Execute(
state : PatternTestInstanceState
) : Object

Parameters

state
The test instance state, not null

Return Value

The test method result

See Also

TestAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestCase Class

TestCase Class
See Also Example Members
[image]

Describes a test case generated either at test exploration time or at test execution time by a test factory.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class TestCase
Inherits TestDefinition
C#
public class TestCase : TestDefinition
C++
ref class TestCase : TestDefinition
J#
public class TestCase extends TestDefinition
JScript
public class TestCase extends TestDefinition

Remarks

A test case has a timeout of 10 minutes by default. This may be changed setting the Timeout property.

Refer to the examples on the Test class for more information.

Inheritance Hierarchy

System.Object
MbUnit.Framework.Test
MbUnit.Framework.TestDefinition
MbUnit.Framework.TestCase

See Also

TestCase Members
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestCase Members

TestCase Members
See Also Example Constructors Properties Methods
[image]

Describes a test case generated either at test exploration time or at test execution time by a test factory.

The following tables list the members exposed by TestCase.

Public Constructors

 | Name | Description
Public method | TestCase | Creates a test case with a delegate to execute as its main body.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets or sets the code element associated with the test, or null if none. (inherited from TestDefinition)
Public property | Description | Gets or sets the description metadata of the test, or null if none. (inherited from TestDefinition)
Public property | Execute | Gets the delegate to run as the main body of the test case.
Public property | Metadata | Gets a mutable table of metadata entries associated with the test. (inherited from TestDefinition)
Public property | Name | Gets the test name. (inherited from TestDefinition)
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout. (inherited from TestDefinition)
Top

Protected Properties

 | Name | Description
Family property | IsTestCase | Overridden. Returns true if the test represents an individual test case.
Family property | Kind | Overridden. Gets the test kind.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Builds a static test during test exploration. (inherited from TestDefinition)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetChildren | Gets the children of this test. (inherited from TestDefinition)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnExecuteSelf | Overridden. Executes the main body of the test, excluding its children (which will run afterwards).
Family method | OnSetupChild | Runs set-up code before each child. (inherited from TestDefinition)
Family method | OnSetupSelf | Runs set-up code before execute and before all children. (inherited from TestDefinition)
Family method | OnTearDownChild | Runs tear-down code after each child. (inherited from TestDefinition)
Family method | OnTearDownSelf | Runs tear-down code after execute and after all children. (inherited from TestDefinition)
Family method | RunDynamicTest | Runs a dynamic test during test execution. (inherited from TestDefinition)
Top

See Also

TestCase Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestCase Constructor

TestCase Constructor
[image]

Creates a test case with a delegate to execute as its main body.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal execute As Action _
)
C#
public TestCase(
string name,
Action execute
)
C++
public:
TestCase(
String name,
Action execute
) sealed
J#
public TestCase(
string name,
Action execute
)
JScript
public function TestCase(
name : String,
execute : Action
)

Parameters

name
The test case name
execute
The main body of the test case

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name or execute is null

See Also

TestCase Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

TestCase Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets or sets the code element associated with the test, or null if none. (inherited from TestDefinition)
Public property | Description | Gets or sets the description metadata of the test, or null if none. (inherited from TestDefinition)
Public property | Execute | Gets the delegate to run as the main body of the test case.
Public property | Metadata | Gets a mutable table of metadata entries associated with the test. (inherited from TestDefinition)
Public property | Name | Gets the test name. (inherited from TestDefinition)
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout. (inherited from TestDefinition)
Top

Protected Properties

 | Name | Description
Family property | IsTestCase | Overridden. Returns true if the test represents an individual test case.
Family property | Kind | Overridden. Gets the test kind.
Top

See Also

TestCase Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Execute Property

TestCase.Execute Property
[image]

Gets the delegate to run as the main body of the test case.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Execute As Action
<CompilerGeneratedAttribute> Get
End Property
C#
public Action Execute { [CompilerGeneratedAttribute] get; }
C++
public property Action Execute sealed {
Action get();
}
J#
/** property */
public Action get_Execute();
JScript
public CompilerGeneratedAttribute function get Execute() : Action

See Also

TestCase Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTestCase Property

TestCase.IsTestCase Property
[image]

Returns true if the test represents an individual test case.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsTestCase As Boolean
C#
protected override bool IsTestCase { get; }
C++
protected override property bool IsTestCase override {
bool get();
}
J#
/** property */
protected bool get_IsTestCase();
JScript
protected function get IsTestCase() : bool

See Also

TestCase Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Kind Property

TestCase.Kind Property
[image]

Gets the test kind.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Kind As String
C#
protected override string Kind { get; }
C++
protected override property string Kind override {
String get();
}
J#
/** property */
protected string get_Kind();
JScript
protected function get Kind() : String

See Also

TestCase Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestCase Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Builds a static test during test exploration. (inherited from TestDefinition)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetChildren | Gets the children of this test. (inherited from TestDefinition)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnExecuteSelf | Overridden. Executes the main body of the test, excluding its children (which will run afterwards).
Family method | OnSetupChild | Runs set-up code before each child. (inherited from TestDefinition)
Family method | OnSetupSelf | Runs set-up code before execute and before all children. (inherited from TestDefinition)
Family method | OnTearDownChild | Runs tear-down code after each child. (inherited from TestDefinition)
Family method | OnTearDownSelf | Runs tear-down code after execute and after all children. (inherited from TestDefinition)
Family method | RunDynamicTest | Runs a dynamic test during test execution. (inherited from TestDefinition)
Top

See Also

TestCase Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnExecuteSelf Method

TestCase.OnExecuteSelf Method
[image]

Executes the main body of the test, excluding its children (which will run afterwards).

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Protected Overrides Sub OnExecuteSelf()
C#
[TestEntryPointAttribute]
protected override void OnExecuteSelf()
C++
[TestEntryPointAttribute]
protected:
virtual void OnExecuteSelf() override
J#
/** @attribute TestEntryPointAttribute() */
protected override void OnExecuteSelf()
JScript
protected override

TestEntryPointAttribute
function OnExecuteSelf()

See Also

TestCase Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestDecoratorAttribute Class

TestDecoratorAttribute Class
See Also Example Members
[image]

An abstract base class for implementing new test decorator behaviors. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public MustInherit Class TestDecoratorAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public abstract class TestDecoratorAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class TestDecoratorAttribute abstract : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class TestDecoratorAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class TestDecoratorAttribute extends TestDecoratorPatternAttribute

Remarks

A test decorator applies actions to be performed around the initialization, setup, execution, teardown and disposal lifecycle of a test (in that order).

This abstract class provides a convenient way to implement new test decorators of your own. To add new behavior to the decorator, override the appropriate lifecycle methods, such as Execute.

If you need more control over how the test is decorated, you may prefer subclassing TestDecoratorPatternAttribute directly instead.

When multiple test decorators are applied to a test, they are installed in order according to the Order property.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.TestDecoratorAttribute

See Also

TestDecoratorAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestDecoratorAttribute Members

TestDecoratorAttribute Members
See Also Example Constructors Properties Methods
[image]

An abstract base class for implementing new test decorator behaviors. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestDecoratorAttribute.

Protected Constructors

 | Name | Description
Family method | TestDecoratorAttribute | Initializes a new instance of the TestDecoratorAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Dispose | Disposes the test.
Family method | Execute | Executes the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Initializes the test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetUp | Sets up the test.
Family method | TearDown | Tears down the test.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestDecoratorAttribute Constructor

TestDecoratorAttribute Constructor
[image]

Initializes a new instance of the TestDecoratorAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected TestDecoratorAttribute()
C++
protected:
TestDecoratorAttribute() sealed
J#
protected TestDecoratorAttribute()
JScript
protected function TestDecoratorAttribute()

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestDecoratorAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Dispose | Disposes the test.
Family method | Execute | Executes the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | Initialize | Initializes the test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetUp | Sets up the test.
Family method | TearDown | Tears down the test.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

TestDecoratorAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Dispose Method

TestDecoratorAttribute.Dispose Method
[image]

Disposes the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
protected virtual void Dispose(
PatternTestInstanceState testInstanceState
)
C++
protected:
virtual void Dispose(
PatternTestInstanceState testInstanceState
)
J#
protected virtual void Dispose(
PatternTestInstanceState testInstanceState
)
JScript
protected virtual function Dispose(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, not null

Remarks

Override this method to add your own behavior around the default actions.

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace
DisposeTestInstance

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Execute Method

TestDecoratorAttribute.Execute Method
[image]

Executes the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Execute( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
protected virtual void Execute(
PatternTestInstanceState testInstanceState
)
C++
protected:
virtual void Execute(
PatternTestInstanceState testInstanceState
)
J#
protected virtual void Execute(
PatternTestInstanceState testInstanceState
)
JScript
protected virtual function Execute(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, not null

Remarks

Override this method to add your own behavior around the default actions.

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace
ExecuteTestInstance

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Initialize Method

TestDecoratorAttribute.Initialize Method
[image]

Initializes the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Initialize( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
protected virtual void Initialize(
PatternTestInstanceState testInstanceState
)
C++
protected:
virtual void Initialize(
PatternTestInstanceState testInstanceState
)
J#
protected virtual void Initialize(
PatternTestInstanceState testInstanceState
)
JScript
protected virtual function Initialize(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, not null

Remarks

Override this method to add your own behavior around the default actions.

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace
InitializeTestInstance

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetUp Method

TestDecoratorAttribute.SetUp Method
[image]

Sets up the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetUp( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
protected virtual void SetUp(
PatternTestInstanceState testInstanceState
)
C++
protected:
virtual void SetUp(
PatternTestInstanceState testInstanceState
)
J#
protected virtual void SetUp(
PatternTestInstanceState testInstanceState
)
JScript
protected virtual function SetUp(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, not null

Remarks

Override this method to add your own behavior around the default actions.

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace
SetUpTestInstance

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TearDown Method

TestDecoratorAttribute.TearDown Method
[image]

Tears down the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub TearDown( _
ByVal testInstanceState As PatternTestInstanceState _
)
C#
protected virtual void TearDown(
PatternTestInstanceState testInstanceState
)
C++
protected:
virtual void TearDown(
PatternTestInstanceState testInstanceState
)
J#
protected virtual void TearDown(
PatternTestInstanceState testInstanceState
)
JScript
protected virtual function TearDown(
testInstanceState : PatternTestInstanceState
)

Parameters

testInstanceState
The test instance state, not null

Remarks

Override this method to add your own behavior around the default actions.

See Also

TestDecoratorAttribute Class
MbUnit.Framework Namespace
TearDownTestInstance

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestDefinition Class

TestDefinition Class
See Also Example Members
[image]

Abstract class for custom test definitions such as generated test cases and test suites. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TestDefinition
Inherits Test
C#
public abstract class TestDefinition : Test
C++
ref class TestDefinition abstract : Test
J#
public class TestDefinition extends Test
JScript
public class TestDefinition extends Test

Inheritance Hierarchy

System.Object
MbUnit.Framework.Test
MbUnit.Framework.TestDefinition
MbUnit.Framework.TestCase
MbUnit.Framework.TestSuite

See Also

TestDefinition Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestDefinition Members

TestDefinition Members
See Also Example Constructors Properties Methods
[image]

Abstract class for custom test definitions such as generated test cases and test suites. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by TestDefinition.

Protected Constructors

 | Name | Description
Family method | TestDefinition | Creates a test.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets or sets the code element associated with the test, or null if none.
Public property | Description | Gets or sets the description metadata of the test, or null if none.
Public property | Metadata | Gets a mutable table of metadata entries associated with the test.
Public property | Name | Gets the test name.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

Protected Properties

 | Name | Description
Family property | IsTestCase | Returns true if the test represents an individual test case.
Family property | Kind | Gets the test kind.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Overridden. Builds a static test during test exploration.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetChildren | Gets the children of this test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnExecuteSelf | Executes the main body of the test, excluding its children (which will run afterwards).
Family method | OnSetupChild | Runs set-up code before each child.
Family method | OnSetupSelf | Runs set-up code before execute and before all children.
Family method | OnTearDownChild | Runs tear-down code after each child.
Family method | OnTearDownSelf | Runs tear-down code after execute and after all children.
Family method | RunDynamicTest | Overridden. Runs a dynamic test during test execution.
Top

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestDefinition Constructor

TestDefinition Constructor
[image]

Creates a test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal name As String _
)
C#
protected TestDefinition(
string name
)
C++
protected:
TestDefinition(
String name
) sealed
J#
protected TestDefinition(
string name
)
JScript
protected function TestDefinition(
name : String
)

Parameters

name
The test name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

TestDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets or sets the code element associated with the test, or null if none.
Public property | Description | Gets or sets the description metadata of the test, or null if none.
Public property | Metadata | Gets a mutable table of metadata entries associated with the test.
Public property | Name | Gets the test name.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.
Top

Protected Properties

 | Name | Description
Family property | IsTestCase | Returns true if the test represents an individual test case.
Family property | Kind | Gets the test kind.
Top

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CodeElement Property

TestDefinition.CodeElement Property
[image]

Gets or sets the code element associated with the test, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property CodeElement As ICodeElementInfo
C#
public ICodeElementInfo CodeElement { get; set; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
void set(ICodeElementInfo value);
}
J#
/** property */
public ICodeElementInfo get_CodeElement();

/** property */
public void set_CodeElement(ICodeElementInfo value);
JScript
public function get CodeElement() : ICodeElementInfo

public function set CodeElement(value : ICodeElementInfo);

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Description Property

TestDefinition.Description Property
[image]

Gets or sets the description metadata of the test, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

Remarks

This is a convenience method that accesses the Description element of the test case's Metadata.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTestCase Property

TestDefinition.IsTestCase Property
[image]

Returns true if the test represents an individual test case.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride ReadOnly Property IsTestCase As Boolean
C#
protected abstract bool IsTestCase { get; }
C++
protected abstract property bool IsTestCase abstract {
bool get();
}
J#
/** property */
protected bool get_IsTestCase();
JScript
protected function get IsTestCase() : bool

Remarks

A test suite will return true. A test case will return false. Custom tests may return an appropriate result.

Subclasses must override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace
TestKinds

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Kind Property

TestDefinition.Kind Property
[image]

Gets the test kind.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride ReadOnly Property Kind As String
C#
protected abstract string Kind { get; }
C++
protected abstract property string Kind abstract {
String get();
}
J#
/** property */
protected string get_Kind();
JScript
protected function get Kind() : String

Remarks

A test suite will return Suite. A test case will return Test. Custom tests may return other kinds.

Subclasses must override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace
TestKinds

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Metadata Property

TestDefinition.Metadata Property
[image]

Gets a mutable table of metadata entries associated with the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metadata As PropertyBag
C#
public PropertyBag Metadata { get; }
C++
public property PropertyBag Metadata sealed {
PropertyBag get();
}
J#
/** property */
public PropertyBag get_Metadata();
JScript
public function get Metadata() : PropertyBag

Remarks

Add any extra metadata to this map.

See Also

TestDefinition Class
MbUnit.Framework Namespace
MetadataKeys

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Name Property

TestDefinition.Name Property
[image]

Gets the test name.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Timeout Property

TestDefinition.Timeout Property
[image]

Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property Timeout As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> Timeout { get; set; }
C++
public property Nullable<TimeSpan> Timeout sealed {
Nullable<TimeSpan> get();
void set(Nullable<TimeSpan> value);
}
J#
/** property */
public Nullable<TimeSpan> get_Timeout();

/** property */
public void set_Timeout(Nullable<TimeSpan> value);
JScript
public function get Timeout() : Nullable<TimeSpan>

public function set Timeout(value : Nullable<TimeSpan>);

Property Value

The timeout. Default value is null.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if value represents a negative time span

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestDefinition Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Overridden. Builds a static test during test exploration.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetChildren | Gets the children of this test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnExecuteSelf | Executes the main body of the test, excluding its children (which will run afterwards).
Family method | OnSetupChild | Runs set-up code before each child.
Family method | OnSetupSelf | Runs set-up code before execute and before all children.
Family method | OnTearDownChild | Runs tear-down code after each child.
Family method | OnTearDownSelf | Runs tear-down code after execute and after all children.
Family method | RunDynamicTest | Overridden. Runs a dynamic test during test execution.
Top

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BuildStaticTest Method

TestDefinition.BuildStaticTest Method
[image]

Builds a static test during test exploration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub BuildStaticTest( _
ByVal containingScope As IPatternScope, _
ByVal declaringCodeElement As ICodeElementInfo _
)
C#
protected override void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
C++
protected:
virtual void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
) override
J#
protected override void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
JScript
protected override function BuildStaticTest(
containingScope : IPatternScope,
declaringCodeElement : ICodeElementInfo
)

Parameters

containingScope
The containing pattern evaluation scope
declaringCodeElement
The code element that represents the scope in which the test was defined

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetChildren Method

TestDefinition.GetChildren Method
[image]

Gets the children of this test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetChildren() As IEnumerable(Of Test)
C#
protected virtual IEnumerable<Test> GetChildren()
C++
protected:
virtual IEnumerable<Test> GetChildren()
J#
protected virtual IEnumerable<Test> GetChildren()
JScript
protected virtual function GetChildren() : IEnumerable<Test>

Remarks

The default implementation returns an empty array. Subclasses may override this behavior as appropriate.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnExecuteSelf Method

TestDefinition.OnExecuteSelf Method
[image]

Executes the main body of the test, excluding its children (which will run afterwards).

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnExecuteSelf()
C#
protected virtual void OnExecuteSelf()
C++
protected:
virtual void OnExecuteSelf()
J#
protected virtual void OnExecuteSelf()
JScript
protected virtual function OnExecuteSelf()

Remarks

The default implementation does nothing. Subclasses may override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnSetupChild Method

TestDefinition.OnSetupChild Method
[image]

Runs set-up code before each child.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSetupChild()
C#
protected virtual void OnSetupChild()
C++
protected:
virtual void OnSetupChild()
J#
protected virtual void OnSetupChild()
JScript
protected virtual function OnSetupChild()

Remarks

The default implementation does nothing. Subclasses may override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnSetupSelf Method

TestDefinition.OnSetupSelf Method
[image]

Runs set-up code before execute and before all children.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSetupSelf()
C#
protected virtual void OnSetupSelf()
C++
protected:
virtual void OnSetupSelf()
J#
protected virtual void OnSetupSelf()
JScript
protected virtual function OnSetupSelf()

Remarks

The default implementation does nothing. Subclasses may override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnTearDownChild Method

TestDefinition.OnTearDownChild Method
[image]

Runs tear-down code after each child.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTearDownChild()
C#
protected virtual void OnTearDownChild()
C++
protected:
virtual void OnTearDownChild()
J#
protected virtual void OnTearDownChild()
JScript
protected virtual function OnTearDownChild()

Remarks

The default implementation does nothing. Subclasses may override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnTearDownSelf Method

TestDefinition.OnTearDownSelf Method
[image]

Runs tear-down code after execute and after all children.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTearDownSelf()
C#
protected virtual void OnTearDownSelf()
C++
protected:
virtual void OnTearDownSelf()
J#
protected virtual void OnTearDownSelf()
JScript
protected virtual function OnTearDownSelf()

Remarks

The default implementation does nothing. Subclasses may override this behavior.

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RunDynamicTest Method

TestDefinition.RunDynamicTest Method
[image]

Runs a dynamic test during test execution.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Protected Overrides Function RunDynamicTest( _
ByVal declaringCodeElement As ICodeElementInfo, _
ByVal setUp As Action, _
ByVal tearDown As Action _
) As TestOutcome
C#
[TestEntryPointAttribute]
protected override TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
C++
[TestEntryPointAttribute]
protected:
virtual TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
) override
J#
/** @attribute TestEntryPointAttribute() */
protected override TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
JScript
protected override

TestEntryPointAttribute
function RunDynamicTest(
declaringCodeElement : ICodeElementInfo,
setUp : Action,
tearDown : Action
) : TestOutcome

Parameters

declaringCodeElement
The code element that represents the scope in which the test was defined
setUp
Optional set-up code to run before the test, or null if none
tearDown
Optional tear-down code to run after the test, or null if none

See Also

TestDefinition Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureAttribute Class

TestFixtureAttribute Class
See Also Example Members
[image]

Specifies that a class represents a test fixture. This attribute is optional.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := False, Inherited := True)>
Public Class TestFixtureAttribute
Inherits TestTypePatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True)]
public class TestFixtureAttribute : TestTypePatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = False, Inherited = True)]
ref class TestFixtureAttribute : TestTypePatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True) */
public class TestFixtureAttribute extends TestTypePatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = False, Inherited = True)
class TestFixtureAttribute extends TestTypePatternAttribute

Remarks

The test fixture attribute is applied to a class that contains a suite of related test cases. If an error occurs while initializing the fixture or if at least one of the test cases within the fixture fails, then the fixture itself will be deemed to have failed. Otherwise the fixture will pass. Output from the fixture, such as text written to the console, is captured by the framework and will be included in the test report.

A test fixture has no timeout by default. This may be changed using the TimeoutAttribute.

This attribute may be omitted whenever a test fixture class contains at least one test method or test parameter or when other MbUnit attributes are applied to the test fixture class. This is almost always the case unless for some reason you have an empty fixture.

The class must have a public default constructor. The class may not be static.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.TestTypePatternAttribute
MbUnit.Framework.TestFixtureAttribute

See Also

TestFixtureAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureAttribute Members

TestFixtureAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies that a class represents a test fixture. This attribute is optional.

The following tables list the members exposed by TestFixtureAttribute.

Public Constructors

 | Name | Description
Public method | TestFixtureAttribute | Initializes a new instance of the TestFixtureAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from TestTypePatternAttribute)
Public property Order

Gets or sets a number that defines an ordering for the test with respect to its siblings.

Unless compelled otherwise by test dependencies, tests with a lower order number than their siblings will run before those siblings and tests with the same order number as their siblings with run in an arbitrary sequence with respect to those siblings.

(inherited from TestTypePatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | DefaultConstructorPattern | Gets the default pattern to apply to constructors that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultEventPattern | Gets the default pattern to apply to events that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultFieldPattern | Gets the default pattern to apply to fields that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultGenericParameterPattern | Gets the default pattern to apply to generic parameters that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultMethodPattern | Gets the default pattern to apply to methods that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultNestedTypePattern | Gets the default pattern to apply to nested types that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Family property | DefaultPropertyPattern | Gets the default pattern to apply to properties that do not have a primary pattern, or null if none. (inherited from TestTypePatternAttribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from TestTypePatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from TestTypePatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | ConsumeConstructors | Consumes type constructors. (inherited from TestTypePatternAttribute)
Family method | ConsumeMembers | Consumes type members including fields, properties, methods and events. (inherited from TestTypePatternAttribute)
Family method | ConsumeNestedTypes | Consumes nested types. (inherited from TestTypePatternAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMemberBindingFlags | Gets the binding flags that should be used to enumerate non-nested type members of the type for determining their contribution to the test fixture. Instance members are only included if the type is not abstract. (inherited from TestTypePatternAttribute)
Family method | InferTestType | Infers whether the type is a test type based on its structure. Returns true if the type any associated patterns, if it has non-nested type members (subject to GetMemberBindingFlags) with patterns, if it has generic parameters with patterns, or if any of its nested types satisfy the preceding rules. (inherited from TestTypePatternAttribute)
Family method | InitializeTest | Initializes a test for a type after it has been added to the test model. The members of base types are processed before those of subtypes. (inherited from TestTypePatternAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Applies semantic actions to a test to estalish its runtime behavior. This method is called after InitializeTest. (inherited from TestTypePatternAttribute)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestTypePatternAttribute)
Top

See Also

TestFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureAttribute Constructor

TestFixtureAttribute Constructor
[image]

Initializes a new instance of the TestFixtureAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestFixtureAttribute()
C++
public:
TestFixtureAttribute() sealed
J#
public TestFixtureAttribute()
JScript
public function TestFixtureAttribute()

See Also

TestFixtureAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureReference Class

TestFixtureReference Class
See Also Example Members
[image]

Describes a reference to another test fixture. This is used to enable test suites to include tests that are defined using attributes.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class TestFixtureReference
Inherits Test
C#
public class TestFixtureReference : Test
C++
ref class TestFixtureReference : Test
J#
public class TestFixtureReference extends Test
JScript
public class TestFixtureReference extends Test

Remarks

Refer to the examples on the Test class for more information.

Running referenced test fixtures dynamically is not supported at this time. Run it statically instead using StaticTestFactoryAttribute.

Inheritance Hierarchy

System.Object
MbUnit.Framework.Test
MbUnit.Framework.TestFixtureReference

See Also

TestFixtureReference Members
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureReference Members

TestFixtureReference Members
See Also Example Constructors Properties Methods
[image]

Describes a reference to another test fixture. This is used to enable test suites to include tests that are defined using attributes.

The following tables list the members exposed by TestFixtureReference.

Public Constructors

 | Name | Description
Public method | TestFixtureReference | Creates a reference to a test fixture.
Top

Public Properties

 | Name | Description
Public property | TestFixtureType | Gets the referenced test fixture type, or null if the reference is on a test method of the containing test fixture.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Overridden. Builds a static test during test exploration.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunDynamicTest | Overridden. Runs a dynamic test during test execution.
Top

See Also

TestFixtureReference Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureReference Constructor

TestFixtureReference Constructor
[image]

Creates a reference to a test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal testFixtureType As Type _
)
C#
public TestFixtureReference(
Type testFixtureType
)
C++
public:
TestFixtureReference(
Type testFixtureType
) sealed
J#
public TestFixtureReference(
Type testFixtureType
)
JScript
public function TestFixtureReference(
testFixtureType : Type
)

Parameters

testFixtureType
The test fixture type

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if testFixtureType is null

See Also

TestFixtureReference Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

TestFixtureReference Properties
[image]

Public Properties

 | Name | Description
Public property | TestFixtureType | Gets the referenced test fixture type, or null if the reference is on a test method of the containing test fixture.
Top

See Also

TestFixtureReference Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureType Property

TestFixtureReference.TestFixtureType Property
[image]

Gets the referenced test fixture type, or null if the reference is on a test method of the containing test fixture.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestFixtureType As Type
C#
public Type TestFixtureType { get; }
C++
public property Type TestFixtureType sealed {
Type get();
}
J#
/** property */
public Type get_TestFixtureType();
JScript
public function get TestFixtureType() : Type

See Also

TestFixtureReference Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestFixtureReference Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Overridden. Builds a static test during test exploration.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | RunDynamicTest | Overridden. Runs a dynamic test during test execution.
Top

See Also

TestFixtureReference Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


BuildStaticTest Method

TestFixtureReference.BuildStaticTest Method
[image]

Builds a static test during test exploration.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub BuildStaticTest( _
ByVal containingScope As IPatternScope, _
ByVal declaringCodeElement As ICodeElementInfo _
)
C#
protected override void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
C++
protected:
virtual void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
) override
J#
protected override void BuildStaticTest(
IPatternScope containingScope,
ICodeElementInfo declaringCodeElement
)
JScript
protected override function BuildStaticTest(
containingScope : IPatternScope,
declaringCodeElement : ICodeElementInfo
)

Parameters

containingScope
The containing pattern evaluation scope
declaringCodeElement
The code element that represents the scope in which the test was defined

See Also

TestFixtureReference Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RunDynamicTest Method

TestFixtureReference.RunDynamicTest Method
[image]

Runs a dynamic test during test execution.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function RunDynamicTest( _
ByVal declaringCodeElement As ICodeElementInfo, _
ByVal setUp As Action, _
ByVal tearDown As Action _
) As TestOutcome
C#
protected override TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
C++
protected:
virtual TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
) override
J#
protected override TestOutcome RunDynamicTest(
ICodeElementInfo declaringCodeElement,
Action setUp,
Action tearDown
)
JScript
protected override function RunDynamicTest(
declaringCodeElement : ICodeElementInfo,
setUp : Action,
tearDown : Action
) : TestOutcome

Parameters

declaringCodeElement
The code element that represents the scope in which the test was defined
setUp
Optional set-up code to run before the test, or null if none
tearDown
Optional tear-down code to run after the test, or null if none

See Also

TestFixtureReference Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestFixtureSetUpAttribute Class

TestFixtureSetUpAttribute Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use the MbUnit v3 [FixtureSetUp] attribute instead. This attribute has been renamed to be more general purpose.

Provides compatibility with MbUnit v2 test fixture set up.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class TestFixtureSetUpAttribute
Inherits FixtureSetUpAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class TestFixtureSetUpAttribute : FixtureSetUpAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TestFixtureSetUpAttribute : FixtureSetUpAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class TestFixtureSetUpAttribute extends FixtureSetUpAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class TestFixtureSetUpAttribute extends FixtureSetUpAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.FixtureSetUpAttribute
MbUnit.Framework.TestFixtureSetUpAttribute

See Also

TestFixtureSetUpAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestFixtureSetUpAttribute Members

TestFixtureSetUpAttribute Members
See Also Example Constructors Properties Methods
[image]

NOTE: This class is now obsolete.

Use the MbUnit v3 [FixtureSetUp] attribute instead. This attribute has been renamed to be more general purpose.

Provides compatibility with MbUnit v2 test fixture set up.

The following tables list the members exposed by TestFixtureSetUpAttribute.

Public Constructors

 | Name | Description
Public method | TestFixtureSetUpAttribute | Initializes a new instance of the TestFixtureSetUpAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Applies decorations to the containing test. (inherited from FixtureSetUpAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from FixtureSetUpAttribute)
Top

See Also

TestFixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestFixtureSetUpAttribute Constructor

TestFixtureSetUpAttribute Constructor
[image]

Initializes a new instance of the TestFixtureSetUpAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestFixtureSetUpAttribute()
C++
public:
TestFixtureSetUpAttribute() sealed
J#
public TestFixtureSetUpAttribute()
JScript
public function TestFixtureSetUpAttribute()

See Also

TestFixtureSetUpAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestFixtureTearDownAttribute Class

TestFixtureTearDownAttribute Class
See Also Example Members
[image]

NOTE: This class is now obsolete.

Use the MbUnit v3 [FixtureTearDown] attribute instead. This attribute has been renamed to be more general purpose.

Provides compatibility with MbUnit v2 test fixture tear down.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple := False, Inherited := True)>
Public Class TestFixtureTearDownAttribute
Inherits FixtureTearDownAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)]
public class TestFixtureTearDownAttribute : FixtureTearDownAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Method, AllowMultiple = False, Inherited = True)]
ref class TestFixtureTearDownAttribute : FixtureTearDownAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True) */
public class TestFixtureTearDownAttribute extends FixtureTearDownAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method, AllowMultiple = False, Inherited = True)
class TestFixtureTearDownAttribute extends FixtureTearDownAttribute

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.FixtureTearDownAttribute
MbUnit.Framework.TestFixtureTearDownAttribute

See Also

TestFixtureTearDownAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestFixtureTearDownAttribute Members

TestFixtureTearDownAttribute Members
See Also Example Constructors Properties Methods
[image]

NOTE: This class is now obsolete.

Use the MbUnit v3 [FixtureTearDown] attribute instead. This attribute has been renamed to be more general purpose.

Provides compatibility with MbUnit v2 test fixture tear down.

The following tables list the members exposed by TestFixtureTearDownAttribute.

Public Constructors

 | Name | Description
Public method | TestFixtureTearDownAttribute | Initializes a new instance of the TestFixtureTearDownAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from ContributionMethodPatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from ContributionMethodPatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from ContributionMethodPatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateContainingScope | Applies decorations to the containing test. (inherited from FixtureTearDownAttribute)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from FixtureTearDownAttribute)
Top

See Also

TestFixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestFixtureTearDownAttribute Constructor

TestFixtureTearDownAttribute Constructor
[image]

Initializes a new instance of the TestFixtureTearDownAttribute class.

Namespace: MbUnit.Framework
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TestFixtureTearDownAttribute()
C++
public:
TestFixtureTearDownAttribute() sealed
J#
public TestFixtureTearDownAttribute()
JScript
public function TestFixtureTearDownAttribute()

See Also

TestFixtureTearDownAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestScope Enumeration

TestScope Enumeration
[image]

Specifies the scope to which certain attributes apply.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Enum TestScope
C#
public enum TestScope
C++
public enum class TestScope
J#
public enum TestScope
JScript
public enum TestScope

Members

Member Name | Description
Self | Applies to this test only.
Descendants | Applies to the descendants of this test only.
All | Applies to this test and its descendants.

See Also

MbUnit.Framework Namespace
ParallelizableAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestsOnAttribute Class

TestsOnAttribute Class
See Also Example Members
[image]

Associates the name of the type under test with a test fixture, test method, test parameter or other test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class TestsOnAttribute
Inherits MetadataPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class TestsOnAttribute : MetadataPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class TestsOnAttribute : MetadataPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class TestsOnAttribute extends MetadataPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class TestsOnAttribute extends MetadataPatternAttribute

Remarks

Specifying the type under test helps to describe which type is primarily being exercised by the test. This way we can quickly identify which tests to run after making changes to a given type. We can also use the TestsOn metadata as a filter so that we can tell the test runner to only run tests about a particular type.

This attribute can be repeated multiple times if there are multiple types.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.TestsOnAttribute

See Also

TestsOnAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestsOnAttribute Members

TestsOnAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Associates the name of the type under test with a test fixture, test method, test parameter or other test component.

The following tables list the members exposed by TestsOnAttribute.

Public Constructors

Name | Description
TestsOnAttribute | Overloaded.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | TypeName | Gets the full name or assembly qualified name of the type under test.
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

Explicit Interface Implementations

Name | Description
TestsOnAttribute | Overloaded.
Top

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestsOnAttribute Constructor

TestsOnAttribute Constructor

Overload List

 | Name | Description
Public method | TestsOnAttribute (String) | Associates the full name or assembly qualified name of the type under test with the test component annotated by this attribute.
Public method | TestsOnAttribute (Type) | Associates the type under test with the test component annotated by this attribute.

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestsOnAttribute Constructor (String)

TestsOnAttribute Constructor (String)
See Also Example
[image]

Associates the full name or assembly qualified name of the type under test with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal typeName As String _
)
C#
public TestsOnAttribute(
string typeName
)
C++
public:
TestsOnAttribute(
String typeName
) sealed
J#
public TestsOnAttribute(
string typeName
)
JScript
public function TestsOnAttribute(
typeName : String
)

Parameters

typeName
The name of the type under test as obtained by FullName or AssemblyQualifiedName

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if typeName is null

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace
TestsOnAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestsOnAttribute Constructor (Type)

TestsOnAttribute Constructor (Type)
See Also Example
[image]

Associates the type under test with the test component annotated by this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As Type _
)
C#
public TestsOnAttribute(
Type type
)
C++
public:
TestsOnAttribute(
Type type
) sealed
J#
public TestsOnAttribute(
Type type
)
JScript
public function TestsOnAttribute(
type : Type
)

Parameters

type
The type under test

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if type is null

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace
TestsOnAttribute Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

TestsOnAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | TypeName | Gets the full name or assembly qualified name of the type under test.
Top

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TypeName Property

TestsOnAttribute.TypeName Property
[image]

Gets the full name or assembly qualified name of the type under test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
C++
public property string TypeName sealed {
String get();
}
J#
/** property */
public string get_TypeName();
JScript
public function get TypeName() : String

Property Value

The name of the type under test as obtained by FullName or AssemblyQualifiedName.

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestsOnAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from MetadataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetMetadata | Overridden. Gets the metadata key / value pairs to be added to the test component.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from MetadataPatternAttribute)
Top

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetMetadata Method

TestsOnAttribute.GetMetadata Method
[image]

Gets the metadata key / value pairs to be added to the test component.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMetadata() As IEnumerable(Of KeyValuePair(Of String, String))
C#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
C++
protected:
virtual IEnumerable<KeyValuePair<string, string>> GetMetadata() override
J#
protected override IEnumerable<KeyValuePair<string, string>> GetMetadata()
JScript
protected override function GetMetadata() : IEnumerable<KeyValuePair<string, string>>

Return Value

The metadata entries

See Also

TestsOnAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestSuite Class

TestSuite Class
See Also Example Members
[image]

Describes a test suite generated either at test exploration time or at test execution time by a test factory.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class TestSuite
Inherits TestDefinition
C#
public class TestSuite : TestDefinition
C++
ref class TestSuite : TestDefinition
J#
public class TestSuite extends TestDefinition
JScript
public class TestSuite extends TestDefinition

Remarks

A test suite has no timeout by default. This may be changed setting the Timeout property.

Refer to the examples on the Test class for more information.

Inheritance Hierarchy

System.Object
MbUnit.Framework.Test
MbUnit.Framework.TestDefinition
MbUnit.Framework.TestSuite

See Also

TestSuite Members
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestSuite Members

TestSuite Members
See Also Example Constructors Properties Methods
[image]

Describes a test suite generated either at test exploration time or at test execution time by a test factory.

The following tables list the members exposed by TestSuite.

Public Constructors

 | Name | Description
Public method | TestSuite | Creates a test suite.
Top

Public Properties

 | Name | Description
Public property | Children | Gets a mutable list of the children of this test.
Public property | CodeElement | Gets or sets the code element associated with the test, or null if none. (inherited from TestDefinition)
Public property | Description | Gets or sets the description metadata of the test, or null if none. (inherited from TestDefinition)
Public property | Metadata | Gets a mutable table of metadata entries associated with the test. (inherited from TestDefinition)
Public property | Name | Gets the test name. (inherited from TestDefinition)
Public property | SetUp | Gets or sets a delegate to run before each test case in the suite, or null if none.
Public property | SuiteSetUp | Gets or sets a delegate to run before all test cases in the suite, or null if none.
Public property | SuiteTearDown | Gets or sets a delegate to run after all test cases in the suite, or null if none.
Public property | TearDown | Gets or sets a delegate to run after each test case in the suite, or null if none.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout. (inherited from TestDefinition)
Top

Protected Properties

 | Name | Description
Family property | IsTestCase | Overridden. Returns true if the test represents an individual test case.
Family property | Kind | Overridden. Gets the test kind.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Builds a static test during test exploration. (inherited from TestDefinition)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetChildren | Overridden. Gets the children of this test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnExecuteSelf | Executes the main body of the test, excluding its children (which will run afterwards). (inherited from TestDefinition)
Family method | OnSetupChild | Overridden. Runs set-up code before each child.
Family method | OnSetupSelf | Overridden. Runs set-up code before execute and before all children.
Family method | OnTearDownChild | Overridden. Runs tear-down code after each child.
Family method | OnTearDownSelf | Overridden. Runs tear-down code after execute and after all children.
Family method | RunDynamicTest | Runs a dynamic test during test execution. (inherited from TestDefinition)
Top

See Also

TestSuite Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TestSuite Constructor

TestSuite Constructor
[image]

Creates a test suite.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String _
)
C#
public TestSuite(
string name
)
C++
public:
TestSuite(
String name
) sealed
J#
public TestSuite(
string name
)
JScript
public function TestSuite(
name : String
)

Parameters

name
The test suite name

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if name is null

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

TestSuite Properties
[image]

Public Properties

 | Name | Description
Public property | Children | Gets a mutable list of the children of this test.
Public property | CodeElement | Gets or sets the code element associated with the test, or null if none. (inherited from TestDefinition)
Public property | Description | Gets or sets the description metadata of the test, or null if none. (inherited from TestDefinition)
Public property | Metadata | Gets a mutable table of metadata entries associated with the test. (inherited from TestDefinition)
Public property | Name | Gets the test name. (inherited from TestDefinition)
Public property | SetUp | Gets or sets a delegate to run before each test case in the suite, or null if none.
Public property | SuiteSetUp | Gets or sets a delegate to run before all test cases in the suite, or null if none.
Public property | SuiteTearDown | Gets or sets a delegate to run after all test cases in the suite, or null if none.
Public property | TearDown | Gets or sets a delegate to run after each test case in the suite, or null if none.
Public property | Timeout | Gets or sets the maximum amount of time the whole test including its setup, teardown and body should be permitted to run. If the test runs any longer than this, it will be aborted by the framework. The timeout may be null to indicate the absence of a timeout. (inherited from TestDefinition)
Top

Protected Properties

 | Name | Description
Family property | IsTestCase | Overridden. Returns true if the test represents an individual test case.
Family property | Kind | Overridden. Gets the test kind.
Top

See Also

TestSuite Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Children Property

TestSuite.Children Property
[image]

Gets a mutable list of the children of this test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Children As IList(Of Test)
C#
public IList<Test> Children { get; }
C++
public property IList<Test> Children sealed {
IList<Test> get();
}
J#
/** property */
public IList<Test> get_Children();
JScript
public function get Children() : IList<Test>

Remarks

Add test cases to this collection to include them in the test suite.

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTestCase Property

TestSuite.IsTestCase Property
[image]

Returns true if the test represents an individual test case.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsTestCase As Boolean
C#
protected override bool IsTestCase { get; }
C++
protected override property bool IsTestCase override {
bool get();
}
J#
/** property */
protected bool get_IsTestCase();
JScript
protected function get IsTestCase() : bool

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Kind Property

TestSuite.Kind Property
[image]

Gets the test kind.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Kind As String
C#
protected override string Kind { get; }
C++
protected override property string Kind override {
String get();
}
J#
/** property */
protected string get_Kind();
JScript
protected function get Kind() : String

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetUp Property

TestSuite.SetUp Property
[image]

Gets or sets a delegate to run before each test case in the suite, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property SetUp As Action
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public Action SetUp { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property Action SetUp sealed {
Action get();
void set(Action value);
}
J#
/** property */
public Action get_SetUp();

/** property */
public void set_SetUp(Action value);
JScript
public CompilerGeneratedAttribute function get SetUp() : Action

public CompilerGeneratedAttribute function set SetUp(value : Action);

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SuiteSetUp Property

TestSuite.SuiteSetUp Property
[image]

Gets or sets a delegate to run before all test cases in the suite, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property SuiteSetUp As Action
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public Action SuiteSetUp { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property Action SuiteSetUp sealed {
Action get();
void set(Action value);
}
J#
/** property */
public Action get_SuiteSetUp();

/** property */
public void set_SuiteSetUp(Action value);
JScript
public CompilerGeneratedAttribute function get SuiteSetUp() : Action

public CompilerGeneratedAttribute function set SuiteSetUp(value : Action);

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SuiteTearDown Property

TestSuite.SuiteTearDown Property
[image]

Gets or sets a delegate to run after all test cases in the suite, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property SuiteTearDown As Action
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public Action SuiteTearDown { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property Action SuiteTearDown sealed {
Action get();
void set(Action value);
}
J#
/** property */
public Action get_SuiteTearDown();

/** property */
public void set_SuiteTearDown(Action value);
JScript
public CompilerGeneratedAttribute function get SuiteTearDown() : Action

public CompilerGeneratedAttribute function set SuiteTearDown(value : Action);

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TearDown Property

TestSuite.TearDown Property
[image]

Gets or sets a delegate to run after each test case in the suite, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property TearDown As Action
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public Action TearDown { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property Action TearDown sealed {
Action get();
void set(Action value);
}
J#
/** property */
public Action get_TearDown();

/** property */
public void set_TearDown(Action value);
JScript
public CompilerGeneratedAttribute function get TearDown() : Action

public CompilerGeneratedAttribute function set TearDown(value : Action);

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TestSuite Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | BuildStaticTest | Builds a static test during test exploration. (inherited from TestDefinition)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetChildren | Overridden. Gets the children of this test.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OnExecuteSelf | Executes the main body of the test, excluding its children (which will run afterwards). (inherited from TestDefinition)
Family method | OnSetupChild | Overridden. Runs set-up code before each child.
Family method | OnSetupSelf | Overridden. Runs set-up code before execute and before all children.
Family method | OnTearDownChild | Overridden. Runs tear-down code after each child.
Family method | OnTearDownSelf | Overridden. Runs tear-down code after execute and after all children.
Family method | RunDynamicTest | Runs a dynamic test during test execution. (inherited from TestDefinition)
Top

See Also

TestSuite Class
MbUnit.Framework Namespace
Test

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetChildren Method

TestSuite.GetChildren Method
[image]

Gets the children of this test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetChildren() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetChildren()
C++
protected:
virtual IEnumerable<Test> GetChildren() override
J#
protected override IEnumerable<Test> GetChildren()
JScript
protected override function GetChildren() : IEnumerable<Test>

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnSetupChild Method

TestSuite.OnSetupChild Method
[image]

Runs set-up code before each child.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Protected Overrides Sub OnSetupChild()
C#
[TestEntryPointAttribute]
protected override void OnSetupChild()
C++
[TestEntryPointAttribute]
protected:
virtual void OnSetupChild() override
J#
/** @attribute TestEntryPointAttribute() */
protected override void OnSetupChild()
JScript
protected override

TestEntryPointAttribute
function OnSetupChild()

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnSetupSelf Method

TestSuite.OnSetupSelf Method
[image]

Runs set-up code before execute and before all children.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Protected Overrides Sub OnSetupSelf()
C#
[TestEntryPointAttribute]
protected override void OnSetupSelf()
C++
[TestEntryPointAttribute]
protected:
virtual void OnSetupSelf() override
J#
/** @attribute TestEntryPointAttribute() */
protected override void OnSetupSelf()
JScript
protected override

TestEntryPointAttribute
function OnSetupSelf()

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnTearDownChild Method

TestSuite.OnTearDownChild Method
[image]

Runs tear-down code after each child.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Protected Overrides Sub OnTearDownChild()
C#
[TestEntryPointAttribute]
protected override void OnTearDownChild()
C++
[TestEntryPointAttribute]
protected:
virtual void OnTearDownChild() override
J#
/** @attribute TestEntryPointAttribute() */
protected override void OnTearDownChild()
JScript
protected override

TestEntryPointAttribute
function OnTearDownChild()

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


OnTearDownSelf Method

TestSuite.OnTearDownSelf Method
[image]

Runs tear-down code after execute and after all children.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestEntryPointAttribute>
Protected Overrides Sub OnTearDownSelf()
C#
[TestEntryPointAttribute]
protected override void OnTearDownSelf()
C++
[TestEntryPointAttribute]
protected:
virtual void OnTearDownSelf() override
J#
/** @attribute TestEntryPointAttribute() */
protected override void OnTearDownSelf()
JScript
protected override

TestEntryPointAttribute
function OnTearDownSelf()

See Also

TestSuite Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ThreadedRepeatAttribute Class

ThreadedRepeatAttribute Class
See Also Example Members
[image]

Decorates a test method and causes it to be invoked repeatedly on multiple concurrent threads.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := True, Inherited := True)>
Public Class ThreadedRepeatAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)]
public class ThreadedRepeatAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = True, Inherited = True)]
ref class ThreadedRepeatAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True) */
public class ThreadedRepeatAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = True, Inherited = True)
class ThreadedRepeatAttribute extends TestDecoratorPatternAttribute

Remarks

Each repetition of the test method will occur within its own individually labeled test step so that it can be identified in the test report.

The initialize, setup, teardown and dispose methods will are invoked around each repetition of the test. Be aware that this means that these invocations may occur concurrently!

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.ThreadedRepeatAttribute

See Also

ThreadedRepeatAttribute Members
MbUnit.Framework Namespace
RepeatAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ThreadedRepeatAttribute Members

ThreadedRepeatAttribute Members
See Also Example Constructors Properties Methods
[image]

Decorates a test method and causes it to be invoked repeatedly on multiple concurrent threads.

The following tables list the members exposed by ThreadedRepeatAttribute.

Public Constructors

 | Name | Description
Public method | ThreadedRepeatAttribute | Executes the test method on the specified number of concurrent threads.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

ThreadedRepeatAttribute Class
MbUnit.Framework Namespace
RepeatAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ThreadedRepeatAttribute Constructor

ThreadedRepeatAttribute Constructor
[image]

Executes the test method on the specified number of concurrent threads.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal numThreads As Integer _
)
C#
public ThreadedRepeatAttribute(
int numThreads
)
C++
public:
ThreadedRepeatAttribute(
int numThreads
) sealed
J#
public ThreadedRepeatAttribute(
int numThreads
)
JScript
public function ThreadedRepeatAttribute(
numThreads : int
)

Parameters

numThreads
The number of threads to execute the test on

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if numThreads is less than 1

Remarks

Copy Code
            [Test]
            [ThreadedRepeat(10)]
            public void Test()
            {
                // This test will be executed 10 times on 10 concurrent threads.
            }

See Also

ThreadedRepeatAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ThreadedRepeatAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

ThreadedRepeatAttribute Class
MbUnit.Framework Namespace
RepeatAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

ThreadedRepeatAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

ThreadedRepeatAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TimeoutAttribute Class

TimeoutAttribute Class
See Also Example Members
[image]

Sets the maximum amount of time in seconds that a test or fixture is permitted to run.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Method Or AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class TimeoutAttribute
Inherits TestDecoratorPatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class TimeoutAttribute : TestDecoratorPatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Method | AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class TimeoutAttribute : TestDecoratorPatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class TimeoutAttribute extends TestDecoratorPatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class TimeoutAttribute extends TestDecoratorPatternAttribute

Remarks

The default timeout is unlimited for test fixtures and 10 minutes for test methods.

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.TimeoutAttribute

See Also

TimeoutAttribute Members
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TimeoutAttribute Members

TimeoutAttribute Members
See Also Example Constructors Properties Methods
[image]

Sets the maximum amount of time in seconds that a test or fixture is permitted to run.

The following tables list the members exposed by TimeoutAttribute.

Public Constructors

 | Name | Description
Public method | TimeoutAttribute | Sets the test timeout in seconds, or zero if none.
Top

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Timeout | Gets the timeout, or null if none.
Public property | TimeoutSeconds | Gets the test timeout in seconds, or zero if none.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TimeoutAttribute Constructor

TimeoutAttribute Constructor
[image]

Sets the test timeout in seconds, or zero if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal timeoutSeconds As Integer _
)
C#
public TimeoutAttribute(
int timeoutSeconds
)
C++
public:
TimeoutAttribute(
int timeoutSeconds
) sealed
J#
public TimeoutAttribute(
int timeoutSeconds
)
JScript
public function TimeoutAttribute(
timeoutSeconds : int
)

Parameters

timeoutSeconds
The timeout in seconds, or zero if none

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | Thrown if timeoutSeconds is less than 0

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

TimeoutAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property | Timeout | Gets the timeout, or null if none.
Public property | TimeoutSeconds | Gets the test timeout in seconds, or zero if none.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Timeout Property

TimeoutAttribute.Timeout Property
[image]

Gets the timeout, or null if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Timeout As Nullable(Of TimeSpan)
C#
public Nullable<TimeSpan> Timeout { get; }
C++
public property Nullable<TimeSpan> Timeout sealed {
Nullable<TimeSpan> get();
}
J#
/** property */
public Nullable<TimeSpan> get_Timeout();
JScript
public function get Timeout() : Nullable<TimeSpan>

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


TimeoutSeconds Property

TimeoutAttribute.TimeoutSeconds Property
[image]

Gets the test timeout in seconds, or zero if none.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimeoutSeconds As Integer
C#
public int TimeoutSeconds { get; }
C++
public property int TimeoutSeconds sealed {
int get();
}
J#
/** property */
public int get_TimeoutSeconds();
JScript
public function get TimeoutSeconds() : int

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

TimeoutAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from TestDecoratorPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | DecorateTest | Overridden. Applies decorations to a test. A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from TestDecoratorPatternAttribute)
Top

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DecorateTest Method

TimeoutAttribute.DecorateTest Method
[image]

Applies decorations to a test.

A typical use of this method is to augment the test with additional metadata or to add additional behaviors to the test.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub DecorateTest( _
ByVal scope As IPatternScope, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
C++
protected:
virtual void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
) override
J#
protected override void DecorateTest(
IPatternScope scope,
ICodeElementInfo codeElement
)
JScript
protected override function DecorateTest(
scope : IPatternScope,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
codeElement
The code element

See Also

TimeoutAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlDataAttribute Class

XmlDataAttribute Class
See Also Example Members
[image]

Provides data from XML contents.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Assembly Or AttributeTargets.Class Or AttributeTargets.Constructor Or AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field Or AttributeTargets.Parameter Or AttributeTargets.GenericParameter, AllowMultiple := True, Inherited := True)>
Public Class XmlDataAttribute
Inherits ContentAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)]
public class XmlDataAttribute : ContentAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Assembly | AttributeTargets::Class | AttributeTargets::Constructor | AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field | AttributeTargets::Parameter | AttributeTargets::GenericParameter, AllowMultiple = True, Inherited = True)]
ref class XmlDataAttribute : ContentAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True) */
public class XmlDataAttribute extends ContentAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Assembly | AttributeTargets.Class | AttributeTargets.Constructor | AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field | AttributeTargets.Parameter | AttributeTargets.GenericParameter, AllowMultiple = True, Inherited = True)
class XmlDataAttribute extends ContentAttribute

Remarks

An XML data set selects nodes from an XML document using XPath expressions. The selected nodes are returned as XPathNavigator objects.

Two XPath expressions are used.

  • Item Path - An XPath expression that selects a set of nodes that are used to uniquely identify records. For example, the item path might be used to select the containing element of each Book element in an XML document of Books. The item path is specified in the constructor.
  • Binding Path - An XPath expression that selects a node relative to the item path that contains a particular data value of interest. For example, the binding path might be used to select the Author attribute of a Book element in an XML document of Books. The binding path is specified by the DataBinding.

The XML may contain metadata at the row level by adding metadata elements in the http://www.gallio.org/ namespace containing metadata entries. In the following example, the row values would be selected using an Item Path of "//row" and a Binding Path of "@value". Additionally, some rows would have metadata as specified.

Copy Code
            <data>
              <row value="somevalue">
                <metadata xmlns="http://www.gallio.org/">
                  <entry key="Description" value="A row..." />
                  <entry key="Author" value="Me" />
                </metadata>
              </row>
              <row value="anothervalue" />
            </data>

This example reads data from an Embedded Resource called Data.xml within the same namespace as the test fixture. Notice that the binding xpath expressions are specified for each parameter using the BindAttribute attribute.

Data files:

Copy Code
            <shoppingCart>
              <item name="Bananas">
                <unitPrice>0.85</unitPrice>
                <quantity>3</quantity>
              </item>
              <item name="Cookies">
                <unitPrice>0.10</unitPrice>
                <quantity>10</quantity>
              </item>
              <-- Comment: mmm! -->
              <item name="Shortbread">
                <unitPrice>2.25</unitPrice>
                <quantity>1</quantity>
              </item>
            </shoppingCart>

A simple test.

Copy Code
            public class AccountingTests
            {
                [Test]
                [XmlData("//item", ResourcePath = "Data.xml")]
                public void ShoppingCartTotalWithSingleItem([Bind("@name")] string item, [Bind("unitPrice")] decimal unitPrice, [Bind("quantity")] decimal quantity)
                {
                    ShoppingCart shoppingCart = new ShoppingCart();
                    shoppingCart.Add(item, unitprice, quantity);
                    Assert.AreEqual(unitPrice * quantity, shoppingCart.TotalCost);
                }
            }

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.ContentAttribute
MbUnit.Framework.XmlDataAttribute

See Also

XmlDataAttribute Members
MbUnit.Framework Namespace
XmlDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlDataAttribute Members

XmlDataAttribute Members
See Also Example Constructors Properties Methods
[image]

Provides data from XML contents.

The following tables list the members exposed by XmlDataAttribute.

Public Constructors

 | Name | Description
Public method | XmlDataAttribute | Specifies a XML-based data source.
Top

Public Properties

Name | Description
Public property | Contents | Gets or sets the inline data contents as a string. (inherited from ContentAttribute)
Public property | FilePath | Gets or sets the path of a local file relative to the current working directory from which the file contents should be read. (inherited from ContentAttribute)
Public property IsPrimary

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

(inherited from PatternAttribute)
Public property | Order | Gets or sets the order in which the decorator should be applied. Decorators with lower order indices values are applied before decorators with higher ones. In the case of a tie, an arbitrary choice is made among decorators with the same order index to determine the order in which they will be processed. (inherited from DecoratorPatternAttribute)
Public property ResourcePath

Gets or sets the path of a manifest resource from which the contents should be read. The path will be resolved within the assembly containing the ResourceScope type or the test fixture type if none if provided.

During resolution, a resource name is constructed from the resource path by translating backslashes to periods. If the named resource is found within the scoped assembly manifest, it is used. Otherwise, the name is prepended with the scoped type's namespace and second lookup is attempted. If this final attempt fails, then an error is raised at runtime.

Examples:

  • If the ResourceScope is MyNamespace.MyType within assembly MyAssembly.dll and if ResourcePath is "Resources\Image.gif", then resolution will first check whether Resources.Image.gif in MyAssembly.dll is a valid resource. If not found, it will consider MyNamespace.Resources.Image.gif. If still not found, then a runtime error will be raised.
  • If no ResourceScope is provided, then the containing test fixture type will be used as the resource scope. The above resolution strategy still applies.

(inherited from ContentAttribute)
Public property ResourceScope

Gets or sets a Type that is used to locate the assembly and namespace within which to resolve a manifest resource in combination with the ResourcePath property.

If no value is specified, the test fixture type is used as the resource scope.

(inherited from ContentAttribute)
Public property SourceName

Gets or sets the name of the data source to create so that the values produced by this attribute can be referred to elsewhere. Multiple data attributes may use the same data source name to produce a compound data source consisting of all of their values combined.

If no name is given to the data source (or it is an empty string), the data source is considered anonymous. An anonymous data source is only visible within the scope of the code element with which the data source declaration is associated. By default, test parameters are bound to the anonymous data source of their enclosing scope.

(inherited from DataPatternAttribute)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Protected Properties

 | Name | Description
Family property | IsDynamic | Returns true if the contents are dynamic, or false if they are static. Static contents can only change if the test assembly is recompiled. (inherited from ContentAttribute)
Top

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDataLocationName | Gets the name of the location that is providing the data, or null if none. The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property. (inherited from ContentAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OpenStream | Opens the contents as a stream. (inherited from ContentAttribute)
Family method | OpenTextReader | Opens the contents as a text reader. (inherited from ContentAttribute)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from ContentAttribute)
Family method | ValidateSource | Validates the data source properties of the content attribute. (inherited from ContentAttribute)
Top

See Also

XmlDataAttribute Class
MbUnit.Framework Namespace
XmlDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


XmlDataAttribute Constructor

XmlDataAttribute Constructor
[image]

Specifies a XML-based data source.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal itemPath As String _
)
C#
public XmlDataAttribute(
string itemPath
)
C++
public:
XmlDataAttribute(
String itemPath
) sealed
J#
public XmlDataAttribute(
string itemPath
)
JScript
public function XmlDataAttribute(
itemPath : String
)

Parameters

itemPath
The XPath expression used to select items within the document

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if itemPath is null

See Also

XmlDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

XmlDataAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

(inherited from PatternAttribute)
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Returns true if the code element represents a test. (inherited from PatternAttribute)
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method Process

Processes a code element and applies its contributions to the scope of this pattern. The scope will typically have been introduced by the Consume method of a primary pattern applied to this code element.

This method is used by patterns to decorate tests and test parameters that have been declared by primary patterns.

For example, the Process method will typically be called by another pattern that has just created a new test based on the associated code element, such as a test method. The method then has the opportunity to modify the test to add metadata, change its name, add new behaviors, and so on.

(inherited from DataPatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetDataLocationName | Gets the name of the location that is providing the data, or null if none. The name will be the filename or resource path if specified, or a special locale-aware string (such as "<inline>") if the contents were specified inline via the Contents property. (inherited from ContentAttribute)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | OpenStream | Opens the contents as a stream. (inherited from ContentAttribute)
Family method | OpenTextReader | Opens the contents as a text reader. (inherited from ContentAttribute)
Family method | PopulateDataSource | Overridden. Populates the data source with the contributions of this attribute.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly. (inherited from ContentAttribute)
Family method | ValidateSource | Validates the data source properties of the content attribute. (inherited from ContentAttribute)
Top

See Also

XmlDataAttribute Class
MbUnit.Framework Namespace
XmlDataSet

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


PopulateDataSource Method

XmlDataAttribute.PopulateDataSource Method
[image]

Populates the data source with the contributions of this attribute.

Namespace: MbUnit.Framework
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PopulateDataSource( _
ByVal scope As IPatternScope, _
ByVal dataSource As DataSource, _
ByVal codeElement As ICodeElementInfo _
)
C#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
C++
protected:
virtual void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
) override
J#
protected override void PopulateDataSource(
IPatternScope scope,
DataSource dataSource,
ICodeElementInfo codeElement
)
JScript
protected override function PopulateDataSource(
scope : IPatternScope,
dataSource : DataSource,
codeElement : ICodeElementInfo
)

Parameters

scope
The scope
dataSource
The data source
codeElement
The code element

See Also

XmlDataAttribute Class
MbUnit.Framework Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnit.Framework.ContractVerifiers

MbUnit.Framework.ContractVerifiers Namespace
See Also Example Hierarchy

Classes

Class | Description
Public class | AbstractContract | Abstract base class for contracts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class CollectionContract

Contract for verifying the implementation of the generic ICollection.

Built-in verifications:

  • VerifyReadOnlyProperty - The IsReadOnly property returns a value in accordance to the expected result determined in the declaration of the contract verifier, by setting the property IsReadOnly. By default, the collection is expected to be not read-only (items can be added and removed, and the collection to be cleared).
  • AddShouldThrowException - The read-only collection throws an exception when the method Add is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • RemoveShouldThrowException - The read-only collection throws an exception when the method Remove is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • ClearShouldThrowException - The read-only collection throws an exception when the method Clear is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • AddNullArgument - The collection throwns a ArgumentNullException when the method Add is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • RemoveNullArgument - The collection throwns a ArgumentNullException when the method Remove is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • ContainsNullArgument - The collection throwns a ArgumentNullException when the method Contains is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • AddItems - The collection handles correctly with the addition of new items. The method Contains and the property Count are expected to return suited results as well. The case of duplicate items (object equality) is tested too; according to the value of contract property AcceptEqualItems. The test is not run when the contract property IsReadOnly is set to 'true'.
  • RemoveItems The collection handles correctly with the removal of items. The method Contains and the property Count are expected to return suited results as well. The test is not run when the contract property IsReadOnly is set to 'true'.
  • ClearItems - The collection is cleared as expected when the method Clear is called. The test is not run when the contract property IsReadOnly is set to 'true'.
  • CopyTo - Not implemented yet. The test already succeeds.

Public class ComparisonContract

Contract for verifying the implementation of the generic IComparable interface.

Built-in verifications:

  • ComparableCompareTo - The type implements the method CompareTo. The method behaves as expected agains the provided equivalence classes.
  • OperatorGreaterThan - The type has a static "Greater Than" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorGreaterThanOrEqual - The type has a static "Greater Than Or Equal" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorLessThan - The type has a static "Less Than" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorLessThanOrEqual - The type has a static "Less Than Or Equal" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.

The following example shows a simple class implementing the IComparable interface, and a test fixture which uses the comparison contract to test it.
Copy Code
            public class SampleComparable : IComparable<SampleComparable>
            {
                private int value;

                public SampleComparable(int value)
                {
                    this.value = value;
                }

                public int CompareTo(SampleComparable other)
                {
                    return Object.ReferenceEquals(other, null)
                        ? Int32.MaxValue
                        : value.CompareTo(other.value);
                }

                public static bool operator >=(SampleComparable left, SampleComparable right)
                {
                    return (Object.ReferenceEquals(left, null)
                        && Object.ReferenceEquals(right, null))
                        || (!Object.ReferenceEquals(left, null)
                        && (left.CompareTo(right) >= 0));
                }

                public static bool operator <=(SampleComparable left, SampleComparable right)
                {
                    return Object.ReferenceEquals(left, null)
                        || (left.CompareTo(right) <= 0);
                }

                public static bool operator >(SampleComparable left, SampleComparable right)
                {
                    return !Object.ReferenceEquals(left, null)
                        && (left.CompareTo(right) > 0);
                }

                public static bool operator <(SampleComparable left, SampleComparable right)
                {
                    return (!Object.ReferenceEquals(left, null)
                        || !Object.ReferenceEquals(right, null))
                        && (Object.ReferenceEquals(left, null)
                        || (left.CompareTo(right) < 0));
                }

            public class SampleComparableTest
            {
                [VerifyContract]
                public readonly IContract EqualityTests = new ComparisonContract<SampleComparable>
                {
                    ImplementsOperatorOverloads = true, // Optional (default is true)
                    EquivalenceClasses =
                    {
                        { new SampleComparable(1) },
                        { new SampleComparable(2) },
                        { new SampleComparable(3) },
                        { new SampleComparable(4) },
                        { new SampleComparable(5) }
                    }
                };
            }
Public class DistinctInstanceCollection

A collection of distinct object instances. Every element represents a valid instance which is different from all the other elements in the collection (object equality).

Distinct instances are used by some contract verifiers such as CollectionContract to check for the correct implementation of the collection interface.

Use the default constructor followed by a list initializer.

Copy Code
            var collection = new DistinctInstanceCollection<Foo>
            {
                new Foo(1)
                new Foo(2),
                new Foo(3),
            };

Or, use the single-parameter constructor to create a collection from an pre-existing enumeration.

Copy Code
            var collection = new DistinctInstanceCollection<Foo>(Foo.GetThemAll());

Public class EqualityContract

Contract for verifying the implementation of the generic IEquatable interface.

Built-in verifications:

  • ObjectEquals - The Equals method was overriden and behaves correctly against the provided equivalence classes.
  • ObjectGetHashCode - The GetHashCode method was overriden and behaves correctly against the provided equivalence classes.
  • EquatableEquals - The Equals method is implemented and behaves as expected agains the provided equivalence classes.
  • OperatorEquals - The type has a static equality operator (==) overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to
    Copy Code
    false
    .
  • OperatorNotEquals - The type has a static inequality operator (!=) overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to
    Copy Code
    false
    .

The following example shows a simple class implementing the IEquatable interface, and a test fixture which uses the equality contract to test it.
Copy Code
            public class SampleEquatable : IEquatable<SampleEquatable>
            {
                private int value;

                public SampleEquatable(int value)
                {
                    this.value = value;
                }

                public override int GetHashCode()
                {
                    return value.GetHashCode();
                }

                public override bool Equals(object obj)
                {
                    return Equals(obj as SampleEquatable);
                }

                public bool Equals(SampleEquatable other)
                {
                    return !Object.ReferenceEquals(other, null)
                        && (value == other.value);
                }

                public static bool operator ==(SampleEquatable left, SampleEquatable right)
                {
                    return (Object.ReferenceEquals(left, null)
                        && Object.ReferenceEquals(right, null))
                        || (!Object.ReferenceEquals(left, null)
                        && left.Equals(right));
                }

                public static bool operator !=(SampleEquatable left, SampleEquatable right)
                {
                    return !(left == right);
                }
            }

            public class SampleEquatableTest
            {
                [VerifyContract]
                public readonly IContract EqualityTests = new EqualityContract<SampleEquatable>
                {
                    ImplementsOperatorOverloads = true, // Optional (default is true)
                    EquivalenceClasses =
                    {
                        { new SampleEquatable(1) },
                        { new SampleEquatable(2) },
                        { new SampleEquatable(3) },
                        { new SampleEquatable(4) },
                        { new SampleEquatable(5) }
                    }
                };
            }
Public class EquivalenceClass

Contains a collection of equivalent object instances. All the elements of the collection should be equal together, in the sense of the local implementation of an equality contract (IEquatable) or a comparison contract (IComparable).

Equivalent classes are used by some contract verifiers such as EqualityContract to check for the correct implementation of object equality or comparison.

Public class EquivalenceClassCollection

A collection of equivalence classes.

Equivalent classes are used by some contract verifiers such as EqualityContract and ComparisonContract to check for the correct implementation of object equality or comparison.

Use the default constructor followed by a list initializer to create a collection of equivalence classes which contains a variable number of object instances.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>
            {
                { new Foo(1), new Foo("One") },
                { new Foo(2), new Foo("Two") },
                { new Foo(3), new Foo("Three") }
            };

Use the single-parameter constructor to create a collection of equivalence classes which contains one single object instance each.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>(new Foo(1), new Foo(2), new Foo(3));

Public class ExceptionContract

Contract for verifying the implementation of a custom exception type.

Built-in verifications:

  • HasSerializableAttributeThe exception type has the SerializableAttribute attribute. Disable that test by settings the ImplementsSerialization property to false.
  • HasSerializationConstructorThe exception type has a protected serialization constructor similar to Exception. Disable that test by settings the ImplementsSerialization property to false.
  • IsDefaultConstructorWellDefinedThe exception type has a default parameter-less constructor. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.
  • IsMessageConstructorWellDefinedThe exception type has single argument constructor for the message. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.
  • IsMessageAndInnerExceptionConstructorWellDefinedThe exception type has two parameters constructor for the message and an inner exception. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.

The following example shows a simple custom exception class with some basic serialization support, and a test fixture which uses the exception contract to test it.
Copy Code
            [Serializable]
            public class SampleException : Exception, ISerializable
            {
                public SampleException()
                {
                }

                public SampleException(string message)
                    : base(message)
                {
                }

                public SampleException(string message, Exception innerException)
                    : base(message, innerException)
                {
                }

                protected SampleException(SerializationInfo info, StreamingContext context)
                    : base(info, context)
                {
                }

                public override void GetObjectData(SerializationInfo info, StreamingContext context)
                {
                    base.GetObjectData(info, context);
                }
            }

            public class SampleExceptionTest
            {
                [VerifyContract]
                public readonly IContract ExceptionTests = new ExceptionContract<SampleException>()
                {
                    ImplementsSerialization = true, // Optional (default is true)
                    ImplementsStandardConstructors = true // Optional (default is true)
                };
            }
Public class ImmutabilityContract

Contract for verifying the implementation of an immutable type.

Built-in verifications:

  • AreReadOnlyFields - All the public and non-public instance fields are marked as read only. The evaluation is made recursively on the field types too.
  • HasNoPublicPropertySetter - The type does not have any public property setter. The evaluation is made recursively on the property types too.

The following example shows a simple immutable class with all the instance fields marked as read only, and a test fixture which invokes the immutability contract to test the class.
Copy Code
             public class SampleImmutable
             {
                 private readonly int number;
                 private readonly string text;

                 public SampleImmutable(int number, string text)
                 {
                     this.number = number;
                     this.text = text;
                 }
             }

             public class SampleImmutableTest
             {
                 [VerifyContract]
                 public readonly IContract ImmutabilityTests = new ImmutabilityContract<SampleImmutable>();
             }
Public class ListContract

Contract for verifying the implementation of the generic IList interface.

Since the generic IList interface is a descendant of the generic ICollection interface, the contract verifier has the same tests as the CollectionContract contract verifier, plus the following built-in verifications:

  • InsertShouldThrowException - The read-only collection throws an exception when the method Insert is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • RemoveAtShouldThrowException - The read-only collection throws an exception when the method RemoveAt is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • IndexerSetShouldThrowException - The read-only collection throws an exception when the setter of the indexer Item is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • InsertNullArgument - The collection throwns a ArgumentNullException when the method Insert is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • IndexOfNullArgument - The collection throwns a ArgumentNullException when the method IndexOf is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • IndexerSetNullArgument - The collection throwns a ArgumentNullException when the setter of the indexer Item is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • InsertItems - The collection handles correctly with the insertion of new items. The method Contains and the property Count are expected to return suitable results as well. The case of duplicate items (object equality) is tested too; according to the value of contract property AcceptEqualItems, inherited from CollectionContract. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • InsertItemsAtInvalidIndex - The collection handles correctly with the insertion of new items at an invalid index. The method should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • RemoveItemsAt The collection handles correctly with the removal of items at specific indexes. The method Contains and the property Count are expected to return suitable results as well. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • RemoveItemsAtInvalidIndex - The collection handles correctly with the removal of items at an invalid index. The method should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • GetItemsAtInvalidIndex - The collection handles correctly with the retrieval of items at an invalid index. The indexer should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list.
  • GetSetItemsWithIndexer - Setting and getting items by using the indexer property works as expected. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • IndexOfItem - The retrieval of the index of an item in the collection works as expected, and the index can be used effectively to get the item with the getter of the indexer property.

Public class | VerifyContractAttribute | Verifies that a contract has been satisfied. The contract is described by a value assigned to a field of the test fixture.

Interfaces

 | Interface | Description
Public interface | IContract | Describes a contract that can be verified.


AbstractContract Class

AbstractContract Class
See Also Example Members
[image]

Abstract base class for contracts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<TestFrameworkInternalAttribute>
Public MustInherit Class AbstractContract
Implements IContract
C#
[TestFrameworkInternalAttribute]
public abstract class AbstractContract : IContract
C++
[TestFrameworkInternalAttribute]
ref class AbstractContract abstract : IContract
J#
/** @attribute TestFrameworkInternalAttribute() */
public class AbstractContract implements IContract
JScript
public
TestFrameworkInternalAttribute
class AbstractContract extends IContract

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.CollectionContract<TCollection,TItem>
MbUnit.Framework.ContractVerifiers.ComparisonContract<TTarget>
MbUnit.Framework.ContractVerifiers.EqualityContract<TTarget>
MbUnit.Framework.ContractVerifiers.ExceptionContract<TException>
MbUnit.Framework.ContractVerifiers.ImmutabilityContract<TTarget>

See Also

AbstractContract Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AbstractContract Members

AbstractContract Members
See Also Example Constructors Properties Methods
[image]

Abstract base class for contracts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by AbstractContract.

Protected Constructors

 | Name | Description
Family method | AbstractContract | Initializes a new instance of the AbstractContract class.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
 | AssertMethodExists | Verifies that the specified method info object is not null, indicating that the method exists, otherwise raises an assertion failure and describes the expected method signature.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
 | GetInterface | Gets the interface of a particular type if it is implemented by another type, otherwise returns null.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AbstractContract Constructor

AbstractContract Constructor
[image]

Initializes a new instance of the AbstractContract class.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New()
C#
protected AbstractContract()
C++
protected:
AbstractContract() sealed
J#
protected AbstractContract()
JScript
protected function AbstractContract()

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

AbstractContract Properties
[image]

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context.
Top

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Context Property

AbstractContract.Context Property
[image]

Gets the execution context.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Context As ContractVerificationContext
<CompilerGeneratedAttribute> Get
End Property
C#
protected ContractVerificationContext Context { [CompilerGeneratedAttribute] get; }
C++
protected property ContractVerificationContext Context sealed {
ContractVerificationContext get();
}
J#
/** property */
protected ContractVerificationContext get_Context();
JScript
protected CompilerGeneratedAttribute function get Context() : ContractVerificationContext

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

AbstractContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
 | AssertMethodExists | Verifies that the specified method info object is not null, indicating that the method exists, otherwise raises an assertion failure and describes the expected method signature.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
 | GetInterface | Gets the interface of a particular type if it is implemented by another type, otherwise returns null.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssertMethodExists Method

AbstractContract.AssertMethodExists Method
[image]

Verifies that the specified method info object is not null, indicating that the method exists, otherwise raises an assertion failure and describes the expected method signature.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AssertMethodExists( _
ByVal method As MethodInfo, _
ByVal methodSignature As String _
)
C#
protected static void AssertMethodExists(
MethodInfo method,
string methodSignature
)
C++
protected:
static void AssertMethodExists(
MethodInfo method,
String methodSignature
)
J#
protected static void AssertMethodExists(
MethodInfo method,
string methodSignature
)
JScript
protected static function AssertMethodExists(
method : MethodInfo,
methodSignature : String
)

Parameters

method
The method, or null if missing
methodSignature
The expected method signature for diagnostic output

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

AbstractContract.GetContractVerificationTests Method

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Family method | GetContractVerificationTests | Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract.

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

AbstractContract.GetContractVerificationTests Method ()
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected abstract IEnumerable<Test> GetContractVerificationTests()
C++
protected:
IEnumerable<Test> GetContractVerificationTests() abstract
J#
protected abstract IEnumerable<Test> GetContractVerificationTests()
JScript
protected abstract function GetContractVerificationTests() : IEnumerable<Test>

Return Value

An enumeration of tests

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace
AbstractContract.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method (ContractVerificationContext)

AbstractContract.GetContractVerificationTests Method (ContractVerificationContext)
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetContractVerificationTests( _
ByVal context As ContractVerificationContext _
) As IEnumerable(Of Test) _
Implements IContract.GetContractVerificationTests
C#
public IEnumerable<Test> GetContractVerificationTests(
ContractVerificationContext context
)
C++
public:
IEnumerable<Test> GetContractVerificationTests(
ContractVerificationContext context
) sealed
J#
public IEnumerable<Test> GetContractVerificationTests(
ContractVerificationContext context
)
JScript
public function GetContractVerificationTests(
context : ContractVerificationContext
) : IEnumerable<Test>

Parameters

context
The context of execution.

Return Value

An enumeration of tests

Implements

IContract.GetContractVerificationTests

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace
AbstractContract.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetInterface Method

AbstractContract.GetInterface Method
[image]

Gets the interface of a particular type if it is implemented by another type, otherwise returns null.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function GetInterface( _
ByVal implementationType As Type, _
ByVal interfaceType As Type _
) As Type
C#
protected static Type GetInterface(
Type implementationType,
Type interfaceType
)
C++
protected:
static Type GetInterface(
Type implementationType,
Type interfaceType
)
J#
protected static Type GetInterface(
Type implementationType,
Type interfaceType
)
JScript
protected static function GetInterface(
implementationType : Type,
interfaceType : Type
) : Type

Parameters

implementationType
The implementation type
interfaceType
The interface type

Return Value

The interface type or null if it is not implemented by the implementation type

See Also

AbstractContract Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CollectionContract Generic Class

CollectionContract Generic Class
See Also Example Members
[image]

Contract for verifying the implementation of the generic ICollection.

Built-in verifications:

  • VerifyReadOnlyProperty - The IsReadOnly property returns a value in accordance to the expected result determined in the declaration of the contract verifier, by setting the property IsReadOnly. By default, the collection is expected to be not read-only (items can be added and removed, and the collection to be cleared).
  • AddShouldThrowException - The read-only collection throws an exception when the method Add is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • RemoveShouldThrowException - The read-only collection throws an exception when the method Remove is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • ClearShouldThrowException - The read-only collection throws an exception when the method Clear is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • AddNullArgument - The collection throwns a ArgumentNullException when the method Add is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • RemoveNullArgument - The collection throwns a ArgumentNullException when the method Remove is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • ContainsNullArgument - The collection throwns a ArgumentNullException when the method Contains is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • AddItems - The collection handles correctly with the addition of new items. The method Contains and the property Count are expected to return suited results as well. The case of duplicate items (object equality) is tested too; according to the value of contract property AcceptEqualItems. The test is not run when the contract property IsReadOnly is set to 'true'.
  • RemoveItems The collection handles correctly with the removal of items. The method Contains and the property Count are expected to return suited results as well. The test is not run when the contract property IsReadOnly is set to 'true'.
  • ClearItems - The collection is cleared as expected when the method Clear is called. The test is not run when the contract property IsReadOnly is set to 'true'.
  • CopyTo - Not implemented yet. The test already succeeds.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class CollectionContract(Of TCollection As ICollection(Of TItem), TItem)
Inherits AbstractContract
C#
public class CollectionContract<TCollection, TItem> : AbstractContract where TCollection : ICollection<TItem>
C++
ref class CollectionContract<TCollection, TItem> : AbstractContract where TCollection : ICollection<TItem>
J#
public class CollectionContract<TCollection, TItem> extends AbstractContract
JScript
JScript does not support generic types and methods.

Type Parameters

TCollection
The type of the collection implementing ICollection.
TItem
The type of items contained in the collection.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.CollectionContract<TCollection,TItem>
MbUnit.Framework.ContractVerifiers.ListContract<TList,TItem>

See Also

CollectionContract<TCollection,TItem> Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CollectionContract<TCollection,TItem> Members

CollectionContract Members
See Also Example Constructors Properties Methods
[image]

Contract for verifying the implementation of the generic ICollection.

Built-in verifications:

  • VerifyReadOnlyProperty - The IsReadOnly property returns a value in accordance to the expected result determined in the declaration of the contract verifier, by setting the property IsReadOnly. By default, the collection is expected to be not read-only (items can be added and removed, and the collection to be cleared).
  • AddShouldThrowException - The read-only collection throws an exception when the method Add is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • RemoveShouldThrowException - The read-only collection throws an exception when the method Remove is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • ClearShouldThrowException - The read-only collection throws an exception when the method Clear is called. The test is not run when the contract property IsReadOnly is set to 'false'.
  • AddNullArgument - The collection throwns a ArgumentNullException when the method Add is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • RemoveNullArgument - The collection throwns a ArgumentNullException when the method Remove is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • ContainsNullArgument - The collection throwns a ArgumentNullException when the method Contains is called with a null reference item. The test is not run when the contract property AcceptNullReference is set to 'true'.
  • AddItems - The collection handles correctly with the addition of new items. The method Contains and the property Count are expected to return suited results as well. The case of duplicate items (object equality) is tested too; according to the value of contract property AcceptEqualItems. The test is not run when the contract property IsReadOnly is set to 'true'.
  • RemoveItems The collection handles correctly with the removal of items. The method Contains and the property Count are expected to return suited results as well. The test is not run when the contract property IsReadOnly is set to 'true'.
  • ClearItems - The collection is cleared as expected when the method Clear is called. The test is not run when the contract property IsReadOnly is set to 'true'.
  • CopyTo - Not implemented yet. The test already succeeds.

The following tables list the members exposed by CollectionContract<TCollection,TItem>.

Public Constructors

 | Name | Description
Public method | CollectionContract | Default constructor.
Top

Public Properties

Name Description
Public property AcceptEqualItems

Determines whether the collection is expected to accept several identical items (object equality). The default value is true.

The default value is 'true'.
Public property AcceptNullReference

Determines whether the collection is expected to accept null references as valid items.

The default value is 'false'.
Public property DistinctInstances

Gets a collection of distinct object instances that feeds the different tests.

In order to optimize the tests, consider to provide:

  • items which are not in the default collection instance yet.
  • items which are in the default collection instance already (if not empty).

Public property GetDefaultInstance Provides a default instance of the collection to test. By default, the contract verifier attempts to invoke the default constructor to get an valid instance. Overwrite the default provider if the collection has no default constructor, or if you want the contract verifier to use a particular instance.
Copy Code
            [VerifyContract]
            public readonly IContract CollectionTests = new CollectionContract<MyCollection, int>
            {
                GetDefaultInstance = () => new MyCollection(1, 2, 3)
            };
Public property IsReadOnly

Determines whether the tested collection is expected to be read-only.

The default value is 'false'.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AssertDistinctIntancesNotEmpty | Asserts that the collection of distinct instances specified by the user is not empty.
Family method | CreateNotSupportedWriteTest | Creates a test that invokes an action over the collection, which is supposed to not be supported. The test expects that an exception be thrown.
Family method | CreateNullArgumentTest | Creates a test which runs an action over the collection with a null argument. The test expects that an exception be thrown.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CollectionContract Constructor

CollectionContract Constructor
[image]

Default constructor.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CollectionContract()
C++
public:
CollectionContract() sealed
J#
public CollectionContract()
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

CollectionContract Properties
[image]

Public Properties

Name Description
Public property AcceptEqualItems

Determines whether the collection is expected to accept several identical items (object equality). The default value is true.

The default value is 'true'.
Public property AcceptNullReference

Determines whether the collection is expected to accept null references as valid items.

The default value is 'false'.
Public property DistinctInstances

Gets a collection of distinct object instances that feeds the different tests.

In order to optimize the tests, consider to provide:

  • items which are not in the default collection instance yet.
  • items which are in the default collection instance already (if not empty).

Public property GetDefaultInstance Provides a default instance of the collection to test. By default, the contract verifier attempts to invoke the default constructor to get an valid instance. Overwrite the default provider if the collection has no default constructor, or if you want the contract verifier to use a particular instance.
Copy Code
            [VerifyContract]
            public readonly IContract CollectionTests = new CollectionContract<MyCollection, int>
            {
                GetDefaultInstance = () => new MyCollection(1, 2, 3)
            };
Public property IsReadOnly

Determines whether the tested collection is expected to be read-only.

The default value is 'false'.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AcceptEqualItems Property

CollectionContract.AcceptEqualItems Property
[image]

Determines whether the collection is expected to accept several identical items (object equality). The default value is true.

The default value is 'true'.
Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property AcceptEqualItems As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool AcceptEqualItems { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool AcceptEqualItems sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AcceptEqualItems();

/** property */
public void set_AcceptEqualItems(bool value);
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AcceptNullReference Property

CollectionContract.AcceptNullReference Property
[image]

Determines whether the collection is expected to accept null references as valid items.

The default value is 'false'.
Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property AcceptNullReference As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool AcceptNullReference { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool AcceptNullReference sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AcceptNullReference();

/** property */
public void set_AcceptNullReference(bool value);
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DistinctInstances Property

CollectionContract.DistinctInstances Property
[image]

Gets a collection of distinct object instances that feeds the different tests.

In order to optimize the tests, consider to provide:

  • items which are not in the default collection instance yet.
  • items which are in the default collection instance already (if not empty).

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property DistinctInstances As DistinctInstanceCollection(Of TItem)
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public DistinctInstanceCollection<TItem> DistinctInstances { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property DistinctInstanceCollection<TItem> DistinctInstances sealed {
DistinctInstanceCollection<TItem> get();
void set(DistinctInstanceCollection<TItem> value);
}
J#
/** property */
public DistinctInstanceCollection<TItem> get_DistinctInstances();

/** property */
public void set_DistinctInstances(DistinctInstanceCollection<TItem> value);
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetDefaultInstance Property

CollectionContract.GetDefaultInstance Property
[image]

Provides a default instance of the collection to test. By default, the contract verifier attempts to invoke the default constructor to get an valid instance. Overwrite the default provider if the collection has no default constructor, or if you want the contract verifier to use a particular instance.

Copy Code
            [VerifyContract]
            public readonly IContract CollectionTests = new CollectionContract<MyCollection, int>
            {
                GetDefaultInstance = () => new MyCollection(1, 2, 3)
            };

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property GetDefaultInstance As Func(Of TCollection)
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public Func<TCollection> GetDefaultInstance { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property Func<TCollection> GetDefaultInstance sealed {
Func<TCollection> get();
void set(Func<TCollection> value);
}
J#
/** property */
public Func<TCollection> get_GetDefaultInstance();

/** property */
public void set_GetDefaultInstance(Func<TCollection> value);
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsReadOnly Property

CollectionContract.IsReadOnly Property
[image]

Determines whether the tested collection is expected to be read-only.

The default value is 'false'.
Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool IsReadOnly { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool IsReadOnly sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsReadOnly();

/** property */
public void set_IsReadOnly(bool value);
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

CollectionContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AssertDistinctIntancesNotEmpty | Asserts that the collection of distinct instances specified by the user is not empty.
Family method | CreateNotSupportedWriteTest | Creates a test that invokes an action over the collection, which is supposed to not be supported. The test expects that an exception be thrown.
Family method | CreateNullArgumentTest | Creates a test which runs an action over the collection with a null argument. The test expects that an exception be thrown.
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


AssertDistinctIntancesNotEmpty Method

CollectionContract.AssertDistinctIntancesNotEmpty Method
[image]

Asserts that the collection of distinct instances specified by the user is not empty.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AssertDistinctIntancesNotEmpty()
C#
protected void AssertDistinctIntancesNotEmpty()
C++
protected:
void AssertDistinctIntancesNotEmpty() sealed
J#
protected void AssertDistinctIntancesNotEmpty()
JScript
JScript does not support generic types and methods.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CreateNotSupportedWriteTest Method

CollectionContract.CreateNotSupportedWriteTest Method
[image]

Creates a test that invokes an action over the collection, which is supposed to not be supported. The test expects that an exception be thrown.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateNotSupportedWriteTest( _
ByVal methodName As String, _
ByVal invoke As Action(Of TCollection, TItem) _
) As Test
C#
protected Test CreateNotSupportedWriteTest(
string methodName,
Action<TCollection, TItem> invoke
)
C++
protected:
Test CreateNotSupportedWriteTest(
String methodName,
Action<TCollection, TItem> invoke
) sealed
J#
protected Test CreateNotSupportedWriteTest(
string methodName,
Action<TCollection, TItem> invoke
)
JScript
JScript does not support generic types and methods.

Parameters

methodName
invoke

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CreateNullArgumentTest Method

CollectionContract.CreateNullArgumentTest Method
[image]

Creates a test which runs an action over the collection with a null argument. The test expects that an exception be thrown.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateNullArgumentTest( _
ByVal methodName As String, _
ByVal invoke As Action(Of TCollection) _
) As Test
C#
protected Test CreateNullArgumentTest(
string methodName,
Action<TCollection> invoke
)
C++
protected:
Test CreateNullArgumentTest(
String methodName,
Action<TCollection> invoke
) sealed
J#
protected Test CreateNullArgumentTest(
string methodName,
Action<TCollection> invoke
)
JScript
JScript does not support generic types and methods.

Parameters

methodName
invoke

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

CollectionContract<TCollection,TItem>.GetContractVerificationTests Method
See Also Example

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract. (inherited from AbstractContract)
Family method | GetContractVerificationTests | Overridden. Gets an enumeration of test cases whose purpose is to verify the contract.

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

CollectionContract.GetContractVerificationTests Method ()
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetContractVerificationTests()
C++
protected:
virtual IEnumerable<Test> GetContractVerificationTests() override
J#
protected override IEnumerable<Test> GetContractVerificationTests()
JScript
JScript does not support generic types and methods.

Return Value

An enumeration of tests

See Also

CollectionContract<TCollection,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace
CollectionContract<TCollection,TItem>.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ComparisonContract Generic Class

ComparisonContract Generic Class
See Also Example Members
[image]

Contract for verifying the implementation of the generic IComparable interface.

Built-in verifications:

  • ComparableCompareTo - The type implements the method CompareTo. The method behaves as expected agains the provided equivalence classes.
  • OperatorGreaterThan - The type has a static "Greater Than" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorGreaterThanOrEqual - The type has a static "Greater Than Or Equal" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorLessThan - The type has a static "Less Than" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorLessThanOrEqual - The type has a static "Less Than Or Equal" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.

The following example shows a simple class implementing the IComparable interface, and a test fixture which uses the comparison contract to test it.
Copy Code
            public class SampleComparable : IComparable<SampleComparable>
            {
                private int value;

                public SampleComparable(int value)
                {
                    this.value = value;
                }

                public int CompareTo(SampleComparable other)
                {
                    return Object.ReferenceEquals(other, null)
                        ? Int32.MaxValue
                        : value.CompareTo(other.value);
                }

                public static bool operator >=(SampleComparable left, SampleComparable right)
                {
                    return (Object.ReferenceEquals(left, null)
                        && Object.ReferenceEquals(right, null))
                        || (!Object.ReferenceEquals(left, null)
                        && (left.CompareTo(right) >= 0));
                }

                public static bool operator <=(SampleComparable left, SampleComparable right)
                {
                    return Object.ReferenceEquals(left, null)
                        || (left.CompareTo(right) <= 0);
                }

                public static bool operator >(SampleComparable left, SampleComparable right)
                {
                    return !Object.ReferenceEquals(left, null)
                        && (left.CompareTo(right) > 0);
                }

                public static bool operator <(SampleComparable left, SampleComparable right)
                {
                    return (!Object.ReferenceEquals(left, null)
                        || !Object.ReferenceEquals(right, null))
                        && (Object.ReferenceEquals(left, null)
                        || (left.CompareTo(right) < 0));
                }

            public class SampleComparableTest
            {
                [VerifyContract]
                public readonly IContract EqualityTests = new ComparisonContract<SampleComparable>
                {
                    ImplementsOperatorOverloads = true, // Optional (default is true)
                    EquivalenceClasses =
                    {
                        { new SampleComparable(1) },
                        { new SampleComparable(2) },
                        { new SampleComparable(3) },
                        { new SampleComparable(4) },
                        { new SampleComparable(5) }
                    }
                };
            }

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class ComparisonContract(Of TTarget As IComparable(Of TTarget))
Inherits AbstractContract
C#
public class ComparisonContract<TTarget> : AbstractContract where TTarget : IComparable<TTarget>
C++
ref class ComparisonContract<TTarget> : AbstractContract where TTarget : IComparable<TTarget>
J#
public class ComparisonContract<TTarget> extends AbstractContract
JScript
JScript does not support generic types and methods.

Type Parameters

TTarget

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.ComparisonContract<TTarget>

See Also

ComparisonContract<TTarget> Members
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ComparisonContract<TTarget> Members

ComparisonContract Members
See Also Example Constructors Properties Methods
[image]

Contract for verifying the implementation of the generic IComparable interface.

Built-in verifications:

  • ComparableCompareTo - The type implements the method CompareTo. The method behaves as expected agains the provided equivalence classes.
  • OperatorGreaterThan - The type has a static "Greater Than" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorGreaterThanOrEqual - The type has a static "Greater Than Or Equal" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorLessThan - The type has a static "Less Than" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.
  • OperatorLessThanOrEqual - The type has a static "Less Than Or Equal" operator overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to false.

The following example shows a simple class implementing the IComparable interface, and a test fixture which uses the comparison contract to test it.
Copy Code
            public class SampleComparable : IComparable<SampleComparable>
            {
                private int value;

                public SampleComparable(int value)
                {
                    this.value = value;
                }

                public int CompareTo(SampleComparable other)
                {
                    return Object.ReferenceEquals(other, null)
                        ? Int32.MaxValue
                        : value.CompareTo(other.value);
                }

                public static bool operator >=(SampleComparable left, SampleComparable right)
                {
                    return (Object.ReferenceEquals(left, null)
                        && Object.ReferenceEquals(right, null))
                        || (!Object.ReferenceEquals(left, null)
                        && (left.CompareTo(right) >= 0));
                }

                public static bool operator <=(SampleComparable left, SampleComparable right)
                {
                    return Object.ReferenceEquals(left, null)
                        || (left.CompareTo(right) <= 0);
                }

                public static bool operator >(SampleComparable left, SampleComparable right)
                {
                    return !Object.ReferenceEquals(left, null)
                        && (left.CompareTo(right) > 0);
                }

                public static bool operator <(SampleComparable left, SampleComparable right)
                {
                    return (!Object.ReferenceEquals(left, null)
                        || !Object.ReferenceEquals(right, null))
                        && (Object.ReferenceEquals(left, null)
                        || (left.CompareTo(right) < 0));
                }

            public class SampleComparableTest
            {
                [VerifyContract]
                public readonly IContract EqualityTests = new ComparisonContract<SampleComparable>
                {
                    ImplementsOperatorOverloads = true, // Optional (default is true)
                    EquivalenceClasses =
                    {
                        { new SampleComparable(1) },
                        { new SampleComparable(2) },
                        { new SampleComparable(3) },
                        { new SampleComparable(4) },
                        { new SampleComparable(5) }
                    }
                };
            }

The following tables list the members exposed by ComparisonContract<TTarget>.

Public Constructors

 | Name | Description
Public method | ComparisonContract | Default constructor.
Top

Public Properties

 | Name | Description
Public property | EquivalenceClasses | Gets or sets the collection of equivalence classes of instances to feed the contract verifier.
Public property | ImplementsOperatorOverloads | Determines whether the verifier will evaluate the presence and the behavior of the four operator overloads "Greater Than", "Greater Than Or Equal", "Less Than", and "Less Than Or Equal". The default value is 'true'.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ComparisonContract Constructor

ComparisonContract Constructor
[image]

Default constructor.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ComparisonContract()
C++
public:
ComparisonContract() sealed
J#
public ComparisonContract()
JScript
JScript does not support generic types and methods.

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ComparisonContract Properties
[image]

Public Properties

 | Name | Description
Public property | EquivalenceClasses | Gets or sets the collection of equivalence classes of instances to feed the contract verifier.
Public property | ImplementsOperatorOverloads | Determines whether the verifier will evaluate the presence and the behavior of the four operator overloads "Greater Than", "Greater Than Or Equal", "Less Than", and "Less Than Or Equal". The default value is 'true'.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClasses Property

ComparisonContract.EquivalenceClasses Property
[image]

Gets or sets the collection of equivalence classes of instances to feed the contract verifier.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property EquivalenceClasses As EquivalenceClassCollection(Of TTarget)
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public EquivalenceClassCollection<TTarget> EquivalenceClasses { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property EquivalenceClassCollection<TTarget> EquivalenceClasses sealed {
EquivalenceClassCollection<TTarget> get();
void set(EquivalenceClassCollection<TTarget> value);
}
J#
/** property */
public EquivalenceClassCollection<TTarget> get_EquivalenceClasses();

/** property */
public void set_EquivalenceClasses(EquivalenceClassCollection<TTarget> value);
JScript
JScript does not support generic types and methods.

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImplementsOperatorOverloads Property

ComparisonContract.ImplementsOperatorOverloads Property
[image]

Determines whether the verifier will evaluate the presence and the behavior of the four operator overloads "Greater Than", "Greater Than Or Equal", "Less Than", and "Less Than Or Equal". The default value is 'true'.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplementsOperatorOverloads As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool ImplementsOperatorOverloads { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool ImplementsOperatorOverloads sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ImplementsOperatorOverloads();

/** property */
public void set_ImplementsOperatorOverloads(bool value);
JScript
JScript does not support generic types and methods.

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ComparisonContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

ComparisonContract<TTarget>.GetContractVerificationTests Method
See Also Example

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract. (inherited from AbstractContract)
Family method | GetContractVerificationTests | Overridden. Gets an enumeration of test cases whose purpose is to verify the contract.

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

ComparisonContract.GetContractVerificationTests Method ()
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetContractVerificationTests()
C++
protected:
virtual IEnumerable<Test> GetContractVerificationTests() override
J#
protected override IEnumerable<Test> GetContractVerificationTests()
JScript
JScript does not support generic types and methods.

Return Value

An enumeration of tests

See Also

ComparisonContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
ComparisonContract<TTarget>.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DistinctInstanceCollection Generic Class

DistinctInstanceCollection Generic Class
See Also Example Members
[image]

A collection of distinct object instances. Every element represents a valid instance which is different from all the other elements in the collection (object equality).

Distinct instances are used by some contract verifiers such as CollectionContract to check for the correct implementation of the collection interface.

Use the default constructor followed by a list initializer.

Copy Code
            var collection = new DistinctInstanceCollection<Foo>
            {
                new Foo(1)
                new Foo(2),
                new Foo(3),
            };

Or, use the single-parameter constructor to create a collection from an pre-existing enumeration.

Copy Code
            var collection = new DistinctInstanceCollection<Foo>(Foo.GetThemAll());

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class DistinctInstanceCollection(Of T)
Implements IEnumerable(Of T), IEnumerable
C#
public class DistinctInstanceCollection<T> : IEnumerable<T>, IEnumerable
C++
ref class DistinctInstanceCollection<T> : IEnumerable<T>, IEnumerable
J#
public class DistinctInstanceCollection<T> implements IEnumerable<T>, IEnumerable
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of the object instances in the collection.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.DistinctInstanceCollection<T>

See Also

DistinctInstanceCollection<T> Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DistinctInstanceCollection<T> Members

DistinctInstanceCollection Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A collection of distinct object instances. Every element represents a valid instance which is different from all the other elements in the collection (object equality).

Distinct instances are used by some contract verifiers such as CollectionContract to check for the correct implementation of the collection interface.

Use the default constructor followed by a list initializer.

Copy Code
            var collection = new DistinctInstanceCollection<Foo>
            {
                new Foo(1)
                new Foo(2),
                new Foo(3),
            };

Or, use the single-parameter constructor to create a collection from an pre-existing enumeration.

Copy Code
            var collection = new DistinctInstanceCollection<Foo>(Foo.GetThemAll());

The following tables list the members exposed by DistinctInstanceCollection<T>.

Public Constructors

Name | Description
DistinctInstanceCollection | Overloaded. Initializes a new instance of the DistinctInstanceCollection class.
Top

Public Properties

 | Name | Description
Public property | Instances | Gets all the instances.
Top

Public Methods

 | Name | Description
Public method | Add | Adds the specified instance to the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns a strongly-typed enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DistinctInstanceCollection | Overloaded. Initializes a new instance of the DistinctInstanceCollection class.
Top

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DistinctInstanceCollection Constructor

DistinctInstanceCollection Constructor

Initializes a new instance of the DistinctInstanceCollection class.

Overload List

 | Name | Description
Public method | DistinctInstanceCollection | Constructs an empty collection of distinct object instances. All the elements of the collection should be different (object equality).
Public method | DistinctInstanceCollection (IEnumerable<T>) | Constructs acollection of distinct object instances from the specified enumeration of elements.

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DistinctInstanceCollection Constructor ()

DistinctInstanceCollection Constructor ()
See Also Example
[image]

Constructs an empty collection of distinct object instances. All the elements of the collection should be different (object equality).

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DistinctInstanceCollection()
C++
public:
DistinctInstanceCollection() sealed
J#
public DistinctInstanceCollection()
JScript
JScript does not support generic types and methods.

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace
DistinctInstanceCollection<T> Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


DistinctInstanceCollection Constructor (Generic IEnumerable)

DistinctInstanceCollection Constructor (Generic IEnumerable)
See Also Example
[image]

Constructs acollection of distinct object instances from the specified enumeration of elements.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal distinctInstances As IEnumerable(Of T) _
)
C#
public DistinctInstanceCollection(
IEnumerable<T> distinctInstances
)
C++
public:
DistinctInstanceCollection(
IEnumerable<T> distinctInstances
) sealed
J#
public DistinctInstanceCollection(
IEnumerable<T> distinctInstances
)
JScript
JScript does not support generic types and methods.

Parameters

distinctInstances
An enumeration of distinct object instances.

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace
DistinctInstanceCollection<T> Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

DistinctInstanceCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Instances | Gets all the instances.
Top

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Instances Property

DistinctInstanceCollection.Instances Property
[image]

Gets all the instances.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Instances As IList(Of T)
C#
public IList<T> Instances { get; }
C++
public property IList<T> Instances sealed {
IList<T> get();
}
J#
/** property */
public IList<T> get_Instances();
JScript
JScript does not support generic types and methods.

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

DistinctInstanceCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds the specified instance to the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns a strongly-typed enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Add Method

DistinctInstanceCollection.Add Method
[image]

Adds the specified instance to the collection.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal instance As T _
)
C#
public void Add(
T instance
)
C++
public:
void Add(
T instance
) sealed
J#
public void Add(
T instance
)
JScript
JScript does not support generic types and methods.

Parameters

instance
A valid and non-null object instance.

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetEnumerator Method

DistinctInstanceCollection.GetEnumerator Method
[image]

Returns a strongly-typed enumerator that iterates through the collection.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of T) _
Implements IEnumerable<T>.GetEnumerator
C#
public IEnumerator<T> GetEnumerator()
C++
public:
IEnumerator<T> GetEnumerator() sealed
J#
public IEnumerator<T> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A strongly-typed enumerator

Implements

IEnumerable<T>.GetEnumerator

See Also

DistinctInstanceCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EqualityContract Generic Class

EqualityContract Generic Class
See Also Example Members
[image]

Contract for verifying the implementation of the generic IEquatable interface.

Built-in verifications:

  • ObjectEquals - The Equals method was overriden and behaves correctly against the provided equivalence classes.
  • ObjectGetHashCode - The GetHashCode method was overriden and behaves correctly against the provided equivalence classes.
  • EquatableEquals - The Equals method is implemented and behaves as expected agains the provided equivalence classes.
  • OperatorEquals - The type has a static equality operator (==) overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to
    Copy Code
    false
    .
  • OperatorNotEquals - The type has a static inequality operator (!=) overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to
    Copy Code
    false
    .

The following example shows a simple class implementing the IEquatable interface, and a test fixture which uses the equality contract to test it.
Copy Code
            public class SampleEquatable : IEquatable<SampleEquatable>
            {
                private int value;

                public SampleEquatable(int value)
                {
                    this.value = value;
                }

                public override int GetHashCode()
                {
                    return value.GetHashCode();
                }

                public override bool Equals(object obj)
                {
                    return Equals(obj as SampleEquatable);
                }

                public bool Equals(SampleEquatable other)
                {
                    return !Object.ReferenceEquals(other, null)
                        && (value == other.value);
                }

                public static bool operator ==(SampleEquatable left, SampleEquatable right)
                {
                    return (Object.ReferenceEquals(left, null)
                        && Object.ReferenceEquals(right, null))
                        || (!Object.ReferenceEquals(left, null)
                        && left.Equals(right));
                }

                public static bool operator !=(SampleEquatable left, SampleEquatable right)
                {
                    return !(left == right);
                }
            }

            public class SampleEquatableTest
            {
                [VerifyContract]
                public readonly IContract EqualityTests = new EqualityContract<SampleEquatable>
                {
                    ImplementsOperatorOverloads = true, // Optional (default is true)
                    EquivalenceClasses =
                    {
                        { new SampleEquatable(1) },
                        { new SampleEquatable(2) },
                        { new SampleEquatable(3) },
                        { new SampleEquatable(4) },
                        { new SampleEquatable(5) }
                    }
                };
            }

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class EqualityContract(Of TTarget As IEquatable(Of TTarget))
Inherits AbstractContract
C#
public class EqualityContract<TTarget> : AbstractContract where TTarget : IEquatable<TTarget>
C++
ref class EqualityContract<TTarget> : AbstractContract where TTarget : IEquatable<TTarget>
J#
public class EqualityContract<TTarget> extends AbstractContract
JScript
JScript does not support generic types and methods.

Type Parameters

TTarget
The target tested type which implements the generic IEquatable interface.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.EqualityContract<TTarget>

See Also

EqualityContract<TTarget> Members
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EqualityContract<TTarget> Members

EqualityContract Members
See Also Example Constructors Properties Methods
[image]

Contract for verifying the implementation of the generic IEquatable interface.

Built-in verifications:

  • ObjectEquals - The Equals method was overriden and behaves correctly against the provided equivalence classes.
  • ObjectGetHashCode - The GetHashCode method was overriden and behaves correctly against the provided equivalence classes.
  • EquatableEquals - The Equals method is implemented and behaves as expected agains the provided equivalence classes.
  • OperatorEquals - The type has a static equality operator (==) overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to
    Copy Code
    false
    .
  • OperatorNotEquals - The type has a static inequality operator (!=) overload which behaves correctly against the provided equivalence classes. Disable that test by setting the ImplementsOperatorOverloads property to
    Copy Code
    false
    .

The following example shows a simple class implementing the IEquatable interface, and a test fixture which uses the equality contract to test it.
Copy Code
            public class SampleEquatable : IEquatable<SampleEquatable>
            {
                private int value;

                public SampleEquatable(int value)
                {
                    this.value = value;
                }

                public override int GetHashCode()
                {
                    return value.GetHashCode();
                }

                public override bool Equals(object obj)
                {
                    return Equals(obj as SampleEquatable);
                }

                public bool Equals(SampleEquatable other)
                {
                    return !Object.ReferenceEquals(other, null)
                        && (value == other.value);
                }

                public static bool operator ==(SampleEquatable left, SampleEquatable right)
                {
                    return (Object.ReferenceEquals(left, null)
                        && Object.ReferenceEquals(right, null))
                        || (!Object.ReferenceEquals(left, null)
                        && left.Equals(right));
                }

                public static bool operator !=(SampleEquatable left, SampleEquatable right)
                {
                    return !(left == right);
                }
            }

            public class SampleEquatableTest
            {
                [VerifyContract]
                public readonly IContract EqualityTests = new EqualityContract<SampleEquatable>
                {
                    ImplementsOperatorOverloads = true, // Optional (default is true)
                    EquivalenceClasses =
                    {
                        { new SampleEquatable(1) },
                        { new SampleEquatable(2) },
                        { new SampleEquatable(3) },
                        { new SampleEquatable(4) },
                        { new SampleEquatable(5) }
                    }
                };
            }

The following tables list the members exposed by EqualityContract<TTarget>.

Public Constructors

 | Name | Description
Public method | EqualityContract | Default constructor.
Top

Public Properties

Name | Description
Public property | EquivalenceClasses | Gets or sets the collection of equivalence classes of instances to feed the contract verifier.
Public property ImplementsOperatorOverloads

Determines whether the verifier will evaluate the presence and the behavior of the equality and the inequality operator overloads. The default value is

Copy Code
true
.

Built-in verifications:

  • The type has a static equality operator (==) overload which behaves correctly against the provided equivalence classes.
  • The type has a static inequality operator (!=) overload which behaves correctly against the provided equivalence classes.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EqualityContract Constructor

EqualityContract Constructor
[image]

Default constructor.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EqualityContract()
C++
public:
EqualityContract() sealed
J#
public EqualityContract()
JScript
JScript does not support generic types and methods.

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

EqualityContract Properties
[image]

Public Properties

Name | Description
Public property | EquivalenceClasses | Gets or sets the collection of equivalence classes of instances to feed the contract verifier.
Public property ImplementsOperatorOverloads

Determines whether the verifier will evaluate the presence and the behavior of the equality and the inequality operator overloads. The default value is

Copy Code
true
.

Built-in verifications:

  • The type has a static equality operator (==) overload which behaves correctly against the provided equivalence classes.
  • The type has a static inequality operator (!=) overload which behaves correctly against the provided equivalence classes.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClasses Property

EqualityContract.EquivalenceClasses Property
[image]

Gets or sets the collection of equivalence classes of instances to feed the contract verifier.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property EquivalenceClasses As EquivalenceClassCollection(Of TTarget)
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public EquivalenceClassCollection<TTarget> EquivalenceClasses { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property EquivalenceClassCollection<TTarget> EquivalenceClasses sealed {
EquivalenceClassCollection<TTarget> get();
void set(EquivalenceClassCollection<TTarget> value);
}
J#
/** property */
public EquivalenceClassCollection<TTarget> get_EquivalenceClasses();

/** property */
public void set_EquivalenceClasses(EquivalenceClassCollection<TTarget> value);
JScript
JScript does not support generic types and methods.

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImplementsOperatorOverloads Property

EqualityContract.ImplementsOperatorOverloads Property
[image]

Determines whether the verifier will evaluate the presence and the behavior of the equality and the inequality operator overloads. The default value is

Copy Code
true
.

Built-in verifications:

  • The type has a static equality operator (==) overload which behaves correctly against the provided equivalence classes.
  • The type has a static inequality operator (!=) overload which behaves correctly against the provided equivalence classes.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplementsOperatorOverloads As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool ImplementsOperatorOverloads { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool ImplementsOperatorOverloads sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ImplementsOperatorOverloads();

/** property */
public void set_ImplementsOperatorOverloads(bool value);
JScript
JScript does not support generic types and methods.

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

EqualityContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

EqualityContract<TTarget>.GetContractVerificationTests Method
See Also Example

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract. (inherited from AbstractContract)
Family method | GetContractVerificationTests | Overridden. Gets an enumeration of test cases whose purpose is to verify the contract.

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

EqualityContract.GetContractVerificationTests Method ()
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetContractVerificationTests()
C++
protected:
virtual IEnumerable<Test> GetContractVerificationTests() override
J#
protected override IEnumerable<Test> GetContractVerificationTests()
JScript
JScript does not support generic types and methods.

Return Value

An enumeration of tests

See Also

EqualityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
EqualityContract<TTarget>.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClass Generic Class

EquivalenceClass Generic Class
See Also Example Members
[image]

Contains a collection of equivalent object instances. All the elements of the collection should be equal together, in the sense of the local implementation of an equality contract (IEquatable) or a comparison contract (IComparable).

Equivalent classes are used by some contract verifiers such as EqualityContract to check for the correct implementation of object equality or comparison.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class EquivalenceClass(Of T)
Implements IEnumerable(Of T), IEnumerable
C#
public class EquivalenceClass<T> : IEnumerable<T>, IEnumerable
C++
ref class EquivalenceClass<T> : IEnumerable<T>, IEnumerable
J#
public class EquivalenceClass<T> implements IEnumerable<T>, IEnumerable
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of equivalent object instances.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.EquivalenceClass<T>

See Also

EquivalenceClass<T> Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClass<T> Members

EquivalenceClass Members
See Also Example Constructors Properties Methods
[image]

Contains a collection of equivalent object instances. All the elements of the collection should be equal together, in the sense of the local implementation of an equality contract (IEquatable) or a comparison contract (IComparable).

Equivalent classes are used by some contract verifiers such as EqualityContract to check for the correct implementation of object equality or comparison.

The following tables list the members exposed by EquivalenceClass<T>.

Public Constructors

 | Name | Description
Public method | EquivalenceClass | Constructs a class of equivalent instances. All the elements of the collection should be equal together, in the sense of the local implementation of an equality contract (IEquatable) or a comparison contract (IComparable).
Top

Public Properties

 | Name | Description
Public property | EquivalentInstances | Gets the collection of equivalent instances.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns a strongly-typed enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EquivalenceClass<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClass Constructor

EquivalenceClass Constructor
[image]

Constructs a class of equivalent instances.

All the elements of the collection should be equal together, in the sense of the local implementation of an equality contract (IEquatable) or a comparison contract (IComparable).

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal ParamArray equivalentInstances As T() _
)
C#
public EquivalenceClass(
params T[] equivalentInstances
)
C++
public:
EquivalenceClass(
... array<T>^ equivalentInstances
) sealed
J#
public EquivalenceClass(
T[] equivalentInstances
)
JScript
JScript does not support generic types and methods.

Parameters

equivalentInstances
The type of equivalent object instances

See Also

EquivalenceClass<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

EquivalenceClass Properties
[image]

Public Properties

 | Name | Description
Public property | EquivalentInstances | Gets the collection of equivalent instances.
Top

See Also

EquivalenceClass<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalentInstances Property

EquivalenceClass.EquivalentInstances Property
[image]

Gets the collection of equivalent instances.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EquivalentInstances As IList(Of T)
C#
public IList<T> EquivalentInstances { get; }
C++
public property IList<T> EquivalentInstances sealed {
IList<T> get();
}
J#
/** property */
public IList<T> get_EquivalentInstances();
JScript
JScript does not support generic types and methods.

See Also

EquivalenceClass<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

EquivalenceClass Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns a strongly-typed enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EquivalenceClass<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetEnumerator Method

EquivalenceClass.GetEnumerator Method
[image]

Returns a strongly-typed enumerator that iterates through the collection.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of T) _
Implements IEnumerable<T>.GetEnumerator
C#
public IEnumerator<T> GetEnumerator()
C++
public:
IEnumerator<T> GetEnumerator() sealed
J#
public IEnumerator<T> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A strongly-typed enumerator

Implements

IEnumerable<T>.GetEnumerator

See Also

EquivalenceClass<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClassCollection Generic Class

EquivalenceClassCollection Generic Class
See Also Example Members
[image]

A collection of equivalence classes.

Equivalent classes are used by some contract verifiers such as EqualityContract and ComparisonContract to check for the correct implementation of object equality or comparison.

Use the default constructor followed by a list initializer to create a collection of equivalence classes which contains a variable number of object instances.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>
            {
                { new Foo(1), new Foo("One") },
                { new Foo(2), new Foo("Two") },
                { new Foo(3), new Foo("Three") }
            };

Use the single-parameter constructor to create a collection of equivalence classes which contains one single object instance each.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>(new Foo(1), new Foo(2), new Foo(3));

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class EquivalenceClassCollection(Of T)
Implements IEnumerable(Of EquivalenceClass(Of T)), IEnumerable
C#
public class EquivalenceClassCollection<T> : IEnumerable<EquivalenceClass<T>>, IEnumerable
C++
ref class EquivalenceClassCollection<T> : IEnumerable<EquivalenceClass<T>>, IEnumerable
J#
public class EquivalenceClassCollection<T> implements IEnumerable<EquivalenceClass<T>>, IEnumerable
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of equivalent object instances.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.EquivalenceClassCollection<T>

See Also

EquivalenceClassCollection<T> Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClassCollection<T> Members

EquivalenceClassCollection Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A collection of equivalence classes.

Equivalent classes are used by some contract verifiers such as EqualityContract and ComparisonContract to check for the correct implementation of object equality or comparison.

Use the default constructor followed by a list initializer to create a collection of equivalence classes which contains a variable number of object instances.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>
            {
                { new Foo(1), new Foo("One") },
                { new Foo(2), new Foo("Two") },
                { new Foo(3), new Foo("Three") }
            };

Use the single-parameter constructor to create a collection of equivalence classes which contains one single object instance each.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>(new Foo(1), new Foo(2), new Foo(3));

The following tables list the members exposed by EquivalenceClassCollection<T>.

Public Constructors

Name | Description
EquivalenceClassCollection | Overloaded. Initializes a new instance of the EquivalenceClassCollection class.
Top

Public Properties

 | Name | Description
Public property | EquivalenceClasses | Gets the equivalence classes.
Top

Public Methods

 | Name | Description
Public method | Add | Adds to the collection a new equivalence class which contains the specified objects.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns a strongly-typed enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
EquivalenceClassCollection | Overloaded. Initializes a new instance of the EquivalenceClassCollection class.
Top

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClassCollection Constructor

EquivalenceClassCollection Constructor

Initializes a new instance of the EquivalenceClassCollection class.

Overload List

Name | Description
Public method | EquivalenceClassCollection | Constructs an empty collection of equivalence classes.
Public method EquivalenceClassCollection (IEnumerable<T>)

Constructs a collection of equivalence classes from the specified distinct object instances.

The resulting collection contains as many equivalence class as provided instances. Each equivalence class contains one single object. To construct a collection with equivalence classes containing several equivalent instances, use preferably the default constructor followed by a list initializer.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>
            {
                { new Foo(1), new Foo("One") },
                { new Foo(2), new Foo("Two") },
                { new Foo(3), new Foo("Three") }
            };

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClassCollection Constructor ()

EquivalenceClassCollection Constructor ()
See Also Example
[image]

Constructs an empty collection of equivalence classes.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EquivalenceClassCollection()
C++
public:
EquivalenceClassCollection() sealed
J#
public EquivalenceClassCollection()
JScript
JScript does not support generic types and methods.

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace
EquivalenceClassCollection<T> Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClassCollection Constructor (Generic IEnumerable)

EquivalenceClassCollection Constructor (Generic IEnumerable)
See Also Example
[image]

Constructs a collection of equivalence classes from the specified distinct object instances.

The resulting collection contains as many equivalence class as provided instances. Each equivalence class contains one single object. To construct a collection with equivalence classes containing several equivalent instances, use preferably the default constructor followed by a list initializer.

Copy Code
            var collection = new EquivalenceClassCollection<Foo>
            {
                { new Foo(1), new Foo("One") },
                { new Foo(2), new Foo("Two") },
                { new Foo(3), new Foo("Three") }
            };

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal distinctInstances As IEnumerable(Of T) _
)
C#
public EquivalenceClassCollection(
IEnumerable<T> distinctInstances
)
C++
public:
EquivalenceClassCollection(
IEnumerable<T> distinctInstances
) sealed
J#
public EquivalenceClassCollection(
IEnumerable<T> distinctInstances
)
JScript
JScript does not support generic types and methods.

Parameters

distinctInstances
An enumeration of distinct instances.

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace
EquivalenceClassCollection<T> Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

EquivalenceClassCollection Properties
[image]

Public Properties

 | Name | Description
Public property | EquivalenceClasses | Gets the equivalence classes.
Top

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


EquivalenceClasses Property

EquivalenceClassCollection.EquivalenceClasses Property
[image]

Gets the equivalence classes.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EquivalenceClasses As IList(Of EquivalenceClass(Of T))
C#
public IList<EquivalenceClass<T>> EquivalenceClasses { get; }
C++
public property IList<EquivalenceClass<T>> EquivalenceClasses sealed {
IList<EquivalenceClass<T>> get();
}
J#
/** property */
public IList<EquivalenceClass<T>> get_EquivalenceClasses();
JScript
JScript does not support generic types and methods.

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

EquivalenceClassCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds to the collection a new equivalence class which contains the specified objects.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns a strongly-typed enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Add Method

EquivalenceClassCollection.Add Method
[image]

Adds to the collection a new equivalence class which contains the specified objects.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal ParamArray equivalentInstances As T() _
)
C#
public void Add(
params T[] equivalentInstances
)
C++
public:
void Add(
... array<T>^ equivalentInstances
) sealed
J#
public void Add(
T[] equivalentInstances
)
JScript
JScript does not support generic types and methods.

Parameters

equivalentInstances
An array of equivalent instances.

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetEnumerator Method

EquivalenceClassCollection.GetEnumerator Method
[image]

Returns a strongly-typed enumerator that iterates through the collection.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of EquivalenceClass(Of T)) _
Implements IEnumerable<EquivalenceClass`1>.GetEnumerator
C#
public IEnumerator<EquivalenceClass<T>> GetEnumerator()
C++
public:
IEnumerator<EquivalenceClass<T>> GetEnumerator() sealed
J#
public IEnumerator<EquivalenceClass<T>> GetEnumerator()
JScript
JScript does not support generic types and methods.

Return Value

A strongly-typed enumerator

Implements

IEnumerable<EquivalenceClass`1>.GetEnumerator

See Also

EquivalenceClassCollection<T> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExceptionContract Generic Class

ExceptionContract Generic Class
See Also Example Members
[image]

Contract for verifying the implementation of a custom exception type.

Built-in verifications:

  • HasSerializableAttributeThe exception type has the SerializableAttribute attribute. Disable that test by settings the ImplementsSerialization property to false.
  • HasSerializationConstructorThe exception type has a protected serialization constructor similar to Exception. Disable that test by settings the ImplementsSerialization property to false.
  • IsDefaultConstructorWellDefinedThe exception type has a default parameter-less constructor. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.
  • IsMessageConstructorWellDefinedThe exception type has single argument constructor for the message. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.
  • IsMessageAndInnerExceptionConstructorWellDefinedThe exception type has two parameters constructor for the message and an inner exception. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.

The following example shows a simple custom exception class with some basic serialization support, and a test fixture which uses the exception contract to test it.
Copy Code
            [Serializable]
            public class SampleException : Exception, ISerializable
            {
                public SampleException()
                {
                }

                public SampleException(string message)
                    : base(message)
                {
                }

                public SampleException(string message, Exception innerException)
                    : base(message, innerException)
                {
                }

                protected SampleException(SerializationInfo info, StreamingContext context)
                    : base(info, context)
                {
                }

                public override void GetObjectData(SerializationInfo info, StreamingContext context)
                {
                    base.GetObjectData(info, context);
                }
            }

            public class SampleExceptionTest
            {
                [VerifyContract]
                public readonly IContract ExceptionTests = new ExceptionContract<SampleException>()
                {
                    ImplementsSerialization = true, // Optional (default is true)
                    ImplementsStandardConstructors = true // Optional (default is true)
                };
            }

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class ExceptionContract(Of TException As Exception)
Inherits AbstractContract
C#
public class ExceptionContract<TException> : AbstractContract where TException : Exception
C++
ref class ExceptionContract<TException> : AbstractContract where TException : Exception
J#
public class ExceptionContract<TException> extends AbstractContract
JScript
JScript does not support generic types and methods.

Type Parameters

TException
The target custom exception type.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.ExceptionContract<TException>

See Also

ExceptionContract<TException> Members
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExceptionContract<TException> Members

ExceptionContract Members
See Also Example Constructors Properties Methods
[image]

Contract for verifying the implementation of a custom exception type.

Built-in verifications:

  • HasSerializableAttributeThe exception type has the SerializableAttribute attribute. Disable that test by settings the ImplementsSerialization property to false.
  • HasSerializationConstructorThe exception type has a protected serialization constructor similar to Exception. Disable that test by settings the ImplementsSerialization property to false.
  • IsDefaultConstructorWellDefinedThe exception type has a default parameter-less constructor. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.
  • IsMessageConstructorWellDefinedThe exception type has single argument constructor for the message. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.
  • IsMessageAndInnerExceptionConstructorWellDefinedThe exception type has two parameters constructor for the message and an inner exception. When the ImplementsSerialization property is set to true as well, the method verifies that the properties of the exception are preserved during a roundtrip serialization. Disable the test by settings the ImplementsStandardConstructors property to false.

The following example shows a simple custom exception class with some basic serialization support, and a test fixture which uses the exception contract to test it.
Copy Code
            [Serializable]
            public class SampleException : Exception, ISerializable
            {
                public SampleException()
                {
                }

                public SampleException(string message)
                    : base(message)
                {
                }

                public SampleException(string message, Exception innerException)
                    : base(message, innerException)
                {
                }

                protected SampleException(SerializationInfo info, StreamingContext context)
                    : base(info, context)
                {
                }

                public override void GetObjectData(SerializationInfo info, StreamingContext context)
                {
                    base.GetObjectData(info, context);
                }
            }

            public class SampleExceptionTest
            {
                [VerifyContract]
                public readonly IContract ExceptionTests = new ExceptionContract<SampleException>()
                {
                    ImplementsSerialization = true, // Optional (default is true)
                    ImplementsStandardConstructors = true // Optional (default is true)
                };
            }

The following tables list the members exposed by ExceptionContract<TException>.

Public Constructors

 | Name | Description
Public method | ExceptionContract | Default constructor.
Top

Public Properties

Name Description
Public property ImplementsSerialization

Determines whether the verifier will check for the serialization support. The default value is 'true'.

Built-in verifications:

  • The exception implements the ISerializable interface.
  • The exception has the SerializableAttribute attribute.
  • The exception type has a protected serialization constructor similar to Exception.
Public property ImplementsStandardConstructors

Determines whether the verifier will check for the presence of the recommended standard constructors. The default value is 'true'.

Built-in verifications:

  • The exception has a default parameter-less constructor.
  • The exception has a single parameter constructor for the message.
  • The exception two parameters constructor for the message and an inner exception.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
 | RoundTripSerialize | Performs round-trip serialization of the exception and returns the result.
Top

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ExceptionContract Constructor

ExceptionContract Constructor
[image]

Default constructor.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExceptionContract()
C++
public:
ExceptionContract() sealed
J#
public ExceptionContract()
JScript
JScript does not support generic types and methods.

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ExceptionContract Properties
[image]

Public Properties

Name Description
Public property ImplementsSerialization

Determines whether the verifier will check for the serialization support. The default value is 'true'.

Built-in verifications:

  • The exception implements the ISerializable interface.
  • The exception has the SerializableAttribute attribute.
  • The exception type has a protected serialization constructor similar to Exception.
Public property ImplementsStandardConstructors

Determines whether the verifier will check for the presence of the recommended standard constructors. The default value is 'true'.

Built-in verifications:

  • The exception has a default parameter-less constructor.
  • The exception has a single parameter constructor for the message.
  • The exception two parameters constructor for the message and an inner exception.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImplementsSerialization Property

ExceptionContract.ImplementsSerialization Property
[image]

Determines whether the verifier will check for the serialization support. The default value is 'true'.

Built-in verifications:

  • The exception implements the ISerializable interface.
  • The exception has the SerializableAttribute attribute.
  • The exception type has a protected serialization constructor similar to Exception.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplementsSerialization As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool ImplementsSerialization { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool ImplementsSerialization sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ImplementsSerialization();

/** property */
public void set_ImplementsSerialization(bool value);
JScript
JScript does not support generic types and methods.

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImplementsStandardConstructors Property

ExceptionContract.ImplementsStandardConstructors Property
[image]

Determines whether the verifier will check for the presence of the recommended standard constructors. The default value is 'true'.

Built-in verifications:

  • The exception has a default parameter-less constructor.
  • The exception has a single parameter constructor for the message.
  • The exception two parameters constructor for the message and an inner exception.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplementsStandardConstructors As Boolean
<CompilerGeneratedAttribute> Get
<CompilerGeneratedAttribute> Set
End Property
C#
public bool ImplementsStandardConstructors { [CompilerGeneratedAttribute] get; [CompilerGeneratedAttribute] set; }
C++
public property bool ImplementsStandardConstructors sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ImplementsStandardConstructors();

/** property */
public void set_ImplementsStandardConstructors(bool value);
JScript
JScript does not support generic types and methods.

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ExceptionContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
 | RoundTripSerialize | Performs round-trip serialization of the exception and returns the result.
Top

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

ExceptionContract<TException>.GetContractVerificationTests Method
See Also Example

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract. (inherited from AbstractContract)
Family method | GetContractVerificationTests | Overridden. Gets an enumeration of test cases whose purpose is to verify the contract.

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

ExceptionContract.GetContractVerificationTests Method ()
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetContractVerificationTests()
C++
protected:
virtual IEnumerable<Test> GetContractVerificationTests() override
J#
protected override IEnumerable<Test> GetContractVerificationTests()
JScript
JScript does not support generic types and methods.

Return Value

An enumeration of tests

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace
ExceptionContract<TException>.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


RoundTripSerialize Method

ExceptionContract.RoundTripSerialize Method
[image]

Performs round-trip serialization of the exception and returns the result.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Function RoundTripSerialize( _
ByVal instance As Exception _
) As Exception
C#
protected static Exception RoundTripSerialize(
Exception instance
)
C++
protected:
static Exception RoundTripSerialize(
Exception instance
)
J#
protected static Exception RoundTripSerialize(
Exception instance
)
JScript
JScript does not support generic types and methods.

Parameters

instance
The exception instance.

Return Value

The instance produced after serialization and deserialization

See Also

ExceptionContract<TException> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IContract Interface

IContract Interface
See Also Example Members
[image]

Describes a contract that can be verified.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Interface IContract
C#
public interface IContract
C++
interface class IContract
J#
public interface IContract
JScript
public interface IContract

Types that implement IContract

Type | Description
MbUnit.Framework.ContractVerifiers.AbstractContract | Abstract base class for contracts. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Remarks

Contracts can be composed together into more complex forms by combining their lists of verification tests to create test suites. This enables the implementation of one contract to leverage that of another.

See Also

IContract Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IContract Members

IContract Members
See Also Example Methods
[image]

Describes a contract that can be verified.

The following tables list the members exposed by IContract.

Public Methods

 | Name | Description
Public method | GetContractVerificationTests | Gets an enumeration of test cases whose purpose is to verify the contract.
Top

See Also

IContract Interface
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

IContract Methods
[image]

Public Methods

 | Name | Description
Public method | GetContractVerificationTests | Gets an enumeration of test cases whose purpose is to verify the contract.
Top

See Also

IContract Interface
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

IContract.GetContractVerificationTests Method
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Function GetContractVerificationTests( _
ByVal context As ContractVerificationContext _
) As IEnumerable(Of Test)
C#
IEnumerable<Test> GetContractVerificationTests(
ContractVerificationContext context
)
C++
IEnumerable<Test> GetContractVerificationTests(
ContractVerificationContext context
) abstract
J#
IEnumerable<Test> GetContractVerificationTests(
ContractVerificationContext context
)
JScript
function GetContractVerificationTests(
context : ContractVerificationContext
) : IEnumerable<Test>

Parameters

context
The context of execution.

Return Value

An enumeration of tests

See Also

IContract Interface
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImmutabilityContract Generic Class

ImmutabilityContract Generic Class
See Also Example Members
[image]

Contract for verifying the implementation of an immutable type.

Built-in verifications:

  • AreReadOnlyFields - All the public and non-public instance fields are marked as read only. The evaluation is made recursively on the field types too.
  • HasNoPublicPropertySetter - The type does not have any public property setter. The evaluation is made recursively on the property types too.

The following example shows a simple immutable class with all the instance fields marked as read only, and a test fixture which invokes the immutability contract to test the class.
Copy Code
             public class SampleImmutable
             {
                 private readonly int number;
                 private readonly string text;

                 public SampleImmutable(int number, string text)
                 {
                     this.number = number;
                     this.text = text;
                 }
             }

             public class SampleImmutableTest
             {
                 [VerifyContract]
                 public readonly IContract ImmutabilityTests = new ImmutabilityContract<SampleImmutable>();
             }

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class ImmutabilityContract(Of TTarget)
Inherits AbstractContract
C#
public class ImmutabilityContract<TTarget> : AbstractContract
C++
ref class ImmutabilityContract<TTarget> : AbstractContract
J#
public class ImmutabilityContract<TTarget> extends AbstractContract
JScript
JScript does not support generic types and methods.

Type Parameters

TTarget
The target immutable type.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.ImmutabilityContract<TTarget>

See Also

ImmutabilityContract<TTarget> Members
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImmutabilityContract<TTarget> Members

ImmutabilityContract Members
See Also Example Constructors Properties Methods
[image]

Contract for verifying the implementation of an immutable type.

Built-in verifications:

  • AreReadOnlyFields - All the public and non-public instance fields are marked as read only. The evaluation is made recursively on the field types too.
  • HasNoPublicPropertySetter - The type does not have any public property setter. The evaluation is made recursively on the property types too.

The following example shows a simple immutable class with all the instance fields marked as read only, and a test fixture which invokes the immutability contract to test the class.
Copy Code
             public class SampleImmutable
             {
                 private readonly int number;
                 private readonly string text;

                 public SampleImmutable(int number, string text)
                 {
                     this.number = number;
                     this.text = text;
                 }
             }

             public class SampleImmutableTest
             {
                 [VerifyContract]
                 public readonly IContract ImmutabilityTests = new ImmutabilityContract<SampleImmutable>();
             }

The following tables list the members exposed by ImmutabilityContract<TTarget>.

Public Constructors

 | Name | Description
Public method | ImmutabilityContract | Default constructor.
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ImmutabilityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ImmutabilityContract Constructor

ImmutabilityContract Constructor
[image]

Default constructor.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ImmutabilityContract()
C++
public:
ImmutabilityContract() sealed
J#
public ImmutabilityContract()
JScript
JScript does not support generic types and methods.

See Also

ImmutabilityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ImmutabilityContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ImmutabilityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
VerifyContractAttribute

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

ImmutabilityContract<TTarget>.GetContractVerificationTests Method
See Also Example

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract. (inherited from AbstractContract)
Family method | GetContractVerificationTests | Overridden. Gets an enumeration of test cases whose purpose is to verify the contract.

See Also

ImmutabilityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

ImmutabilityContract.GetContractVerificationTests Method ()
See Also Example
[image]

Gets an enumeration of test cases whose purpose is to verify the contract.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetContractVerificationTests()
C++
protected:
virtual IEnumerable<Test> GetContractVerificationTests() override
J#
protected override IEnumerable<Test> GetContractVerificationTests()
JScript
JScript does not support generic types and methods.

Return Value

An enumeration of tests

See Also

ImmutabilityContract<TTarget> Class
MbUnit.Framework.ContractVerifiers Namespace
ImmutabilityContract<TTarget>.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ListContract Generic Class

ListContract Generic Class
See Also Example Members
[image]

Contract for verifying the implementation of the generic IList interface.

Since the generic IList interface is a descendant of the generic ICollection interface, the contract verifier has the same tests as the CollectionContract contract verifier, plus the following built-in verifications:

  • InsertShouldThrowException - The read-only collection throws an exception when the method Insert is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • RemoveAtShouldThrowException - The read-only collection throws an exception when the method RemoveAt is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • IndexerSetShouldThrowException - The read-only collection throws an exception when the setter of the indexer Item is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • InsertNullArgument - The collection throwns a ArgumentNullException when the method Insert is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • IndexOfNullArgument - The collection throwns a ArgumentNullException when the method IndexOf is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • IndexerSetNullArgument - The collection throwns a ArgumentNullException when the setter of the indexer Item is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • InsertItems - The collection handles correctly with the insertion of new items. The method Contains and the property Count are expected to return suitable results as well. The case of duplicate items (object equality) is tested too; according to the value of contract property AcceptEqualItems, inherited from CollectionContract. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • InsertItemsAtInvalidIndex - The collection handles correctly with the insertion of new items at an invalid index. The method should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • RemoveItemsAt The collection handles correctly with the removal of items at specific indexes. The method Contains and the property Count are expected to return suitable results as well. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • RemoveItemsAtInvalidIndex - The collection handles correctly with the removal of items at an invalid index. The method should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • GetItemsAtInvalidIndex - The collection handles correctly with the retrieval of items at an invalid index. The indexer should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list.
  • GetSetItemsWithIndexer - Setting and getting items by using the indexer property works as expected. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • IndexOfItem - The retrieval of the index of an item in the collection works as expected, and the index can be used effectively to get the item with the getter of the indexer property.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class ListContract(Of TList As IList(Of TItem), TItem)
Inherits CollectionContract(Of TList, TItem)
C#
public class ListContract<TList, TItem> : CollectionContract<TList, TItem> where TList : IList<TItem>
C++
ref class ListContract<TList, TItem> : CollectionContract<TList, TItem> where TList : IList<TItem>
J#
public class ListContract<TList, TItem> extends CollectionContract<TList, TItem>
JScript
JScript does not support generic types and methods.

Type Parameters

TList
The type of the collection implementing IList.
TItem
The type of items contained by the list.

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract
MbUnit.Framework.ContractVerifiers.CollectionContract<TCollection,TItem>
MbUnit.Framework.ContractVerifiers.ListContract<TList,TItem>

See Also

ListContract<TList,TItem> Members
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ListContract<TList,TItem> Members

ListContract Members
See Also Example Constructors Properties Methods
[image]

Contract for verifying the implementation of the generic IList interface.

Since the generic IList interface is a descendant of the generic ICollection interface, the contract verifier has the same tests as the CollectionContract contract verifier, plus the following built-in verifications:

  • InsertShouldThrowException - The read-only collection throws an exception when the method Insert is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • RemoveAtShouldThrowException - The read-only collection throws an exception when the method RemoveAt is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • IndexerSetShouldThrowException - The read-only collection throws an exception when the setter of the indexer Item is called. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'false'.
  • InsertNullArgument - The collection throwns a ArgumentNullException when the method Insert is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • IndexOfNullArgument - The collection throwns a ArgumentNullException when the method IndexOf is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • IndexerSetNullArgument - The collection throwns a ArgumentNullException when the setter of the indexer Item is called with a null reference item. The test is not run when the contract property AcceptNullReference inherited from CollectionContract, is set to 'true'.
  • InsertItems - The collection handles correctly with the insertion of new items. The method Contains and the property Count are expected to return suitable results as well. The case of duplicate items (object equality) is tested too; according to the value of contract property AcceptEqualItems, inherited from CollectionContract. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • InsertItemsAtInvalidIndex - The collection handles correctly with the insertion of new items at an invalid index. The method should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • RemoveItemsAt The collection handles correctly with the removal of items at specific indexes. The method Contains and the property Count are expected to return suitable results as well. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • RemoveItemsAtInvalidIndex - The collection handles correctly with the removal of items at an invalid index. The method should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • GetItemsAtInvalidIndex - The collection handles correctly with the retrieval of items at an invalid index. The indexer should throw an ArgumentOutOfRangeException when called with a negative index or with an index greater than the number of items in the list.
  • GetSetItemsWithIndexer - Setting and getting items by using the indexer property works as expected. The test is not run when the contract property IsReadOnly inherited from CollectionContract, is set to 'true'.
  • IndexOfItem - The retrieval of the index of an item in the collection works as expected, and the index can be used effectively to get the item with the getter of the indexer property.

The following tables list the members exposed by ListContract<TList,TItem>.

Public Constructors

 | Name | Description
Public method | ListContract | Initializes a new instance of the ListContract class.
Top

Public Properties

Name Description
Public property AcceptEqualItems

Determines whether the collection is expected to accept several identical items (object equality). The default value is true.

The default value is 'true'. (inherited from CollectionContract)
Public property AcceptNullReference

Determines whether the collection is expected to accept null references as valid items.

The default value is 'false'. (inherited from CollectionContract)
Public property DistinctInstances

Gets a collection of distinct object instances that feeds the different tests.

In order to optimize the tests, consider to provide:

  • items which are not in the default collection instance yet.
  • items which are in the default collection instance already (if not empty).

(inherited from CollectionContract)
Public property GetDefaultInstance Provides a default instance of the collection to test. By default, the contract verifier attempts to invoke the default constructor to get an valid instance. Overwrite the default provider if the collection has no default constructor, or if you want the contract verifier to use a particular instance.
Copy Code
            [VerifyContract]
            public readonly IContract CollectionTests = new CollectionContract<MyCollection, int>
            {
                GetDefaultInstance = () => new MyCollection(1, 2, 3)
            };
(inherited from CollectionContract)
Public property IsReadOnly

Determines whether the tested collection is expected to be read-only.

The default value is 'false'. (inherited from CollectionContract)
Top

Protected Properties

 | Name | Description
Family property | Context | Gets the execution context. (inherited from AbstractContract)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AssertDistinctIntancesNotEmpty | Asserts that the collection of distinct instances specified by the user is not empty. (inherited from CollectionContract)
Family method | CreateNotSupportedWriteTest | Creates a test that invokes an action over the collection, which is supposed to not be supported. The test expects that an exception be thrown. (inherited from CollectionContract)
Family method | CreateNullArgumentTest | Creates a test which runs an action over the collection with a null argument. The test expects that an exception be thrown. (inherited from CollectionContract)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ListContract<TList,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ListContract Constructor

ListContract Constructor
[image]

Initializes a new instance of the ListContract class.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ListContract()
C++
public:
ListContract() sealed
J#
public ListContract()
JScript
JScript does not support generic types and methods.

See Also

ListContract<TList,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ListContract Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | AssertDistinctIntancesNotEmpty | Asserts that the collection of distinct instances specified by the user is not empty. (inherited from CollectionContract)
Family method | CreateNotSupportedWriteTest | Creates a test that invokes an action over the collection, which is supposed to not be supported. The test expects that an exception be thrown. (inherited from CollectionContract)
Family method | CreateNullArgumentTest | Creates a test which runs an action over the collection with a null argument. The test expects that an exception be thrown. (inherited from CollectionContract)
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | GetContractVerificationTests | Overloaded. Gets an enumeration of test cases whose purpose is to verify the contract.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ListContract<TList,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method

ListContract<TList,TItem>.GetContractVerificationTests Method
See Also Example

Gets an enumeration of test cases whose purpose is to verify the contract.

Overload List

 | Name | Description
Public method | GetContractVerificationTests (ContractVerificationContext) | Gets an enumeration of test cases whose purpose is to verify the contract. (inherited from AbstractContract)
Family method | GetContractVerificationTests | Overridden.

See Also

ListContract<TList,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetContractVerificationTests Method ()

ListContract.GetContractVerificationTests Method ()
See Also Example
[image]

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetContractVerificationTests() As IEnumerable(Of Test)
C#
protected override IEnumerable<Test> GetContractVerificationTests()
C++
protected:
virtual IEnumerable<Test> GetContractVerificationTests() override
J#
protected override IEnumerable<Test> GetContractVerificationTests()
JScript
JScript does not support generic types and methods.

See Also

ListContract<TList,TItem> Class
MbUnit.Framework.ContractVerifiers Namespace
ListContract<TList,TItem>.GetContractVerificationTests Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


VerifyContractAttribute Class

VerifyContractAttribute Class
See Also Example Members
[image]

Verifies that a contract has been satisfied. The contract is described by a value assigned to a field of the test fixture.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple := False, Inherited := True)>
Public Class VerifyContractAttribute
Inherits PatternAttribute
C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = False, Inherited = True)]
public class VerifyContractAttribute : PatternAttribute
C++
[AttributeUsageAttribute(AttributeTargets::Field, AllowMultiple = False, Inherited = True)]
ref class VerifyContractAttribute : PatternAttribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = False, Inherited = True) */
public class VerifyContractAttribute extends PatternAttribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = False, Inherited = True)
class VerifyContractAttribute extends PatternAttribute

Example

Copy Code
            [TestFixture]
            public class MyExceptionTests
            {
                [VerifyContract]
                public readonly IContract Contract = new ExceptionContract<MyException>();
            }

Inheritance Hierarchy

System.Object
System.Attribute
Gallio.Framework.Pattern.PatternAttribute
MbUnit.Framework.ContractVerifiers.VerifyContractAttribute

See Also

VerifyContractAttribute Members
MbUnit.Framework.ContractVerifiers Namespace
ComparisonContract
EqualityContract
ExceptionContract
ImmutabilityContract

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


VerifyContractAttribute Members

VerifyContractAttribute Members
See Also Example Constructors Properties Methods
[image]

Verifies that a contract has been satisfied. The contract is described by a value assigned to a field of the test fixture.

The following tables list the members exposed by VerifyContractAttribute.

Public Constructors

 | Name | Description
Public method | VerifyContractAttribute | Initializes a new instance of the VerifyContractAttribute class.
Top

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a contract verifier field after it has been added to the test model.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Establishes the semantics of the contract verifier.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace
ComparisonContract
EqualityContract
ExceptionContract
ImmutabilityContract

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


VerifyContractAttribute Constructor

VerifyContractAttribute Constructor
[image]

Initializes a new instance of the VerifyContractAttribute class.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VerifyContractAttribute()
C++
public:
VerifyContractAttribute() sealed
J#
public VerifyContractAttribute()
JScript
public function VerifyContractAttribute()

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

VerifyContractAttribute Properties
[image]

Public Properties

Name | Description
Public property IsPrimary Overridden.

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace
ComparisonContract
EqualityContract
ExceptionContract
ImmutabilityContract

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsPrimary Property

VerifyContractAttribute.IsPrimary Property
[image]

Returns true if this is a primary pattern.

A primary pattern is a pattern that defines the ultimate purpose of a code element and the nature of the tests or test parameters that are produced from it. Consequently the primary pattern is the only one on which the Consume method will be called.

Each code element may have at most one primary pattern. It is an error for a code element to have more than one associated primary pattern.

If a code element does not have an associated primary pattern, its containing test may choose to apply default processing to it instead. For example, the containing test may give an opportunity to patterns associated with the code element to consume a test method parameter but will revert to default behavior if no primary patterns explicitly claim it.

Non-primary patterns still play a very important part in the construction of the test model. Non-primary patterns may implement the Process method to decorate tests and test parameters declared by the primary pattern.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsPrimary As Boolean _
Implements IPattern.IsPrimary
C#
public override bool IsPrimary { get; }
C++
public override property bool IsPrimary override {
bool get();
}
J#
/** property */
public bool get_IsPrimary();
JScript
public function get IsPrimary() : bool

Implements

IPattern.IsPrimary

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

VerifyContractAttribute Methods
[image]

Public Methods

Name | Description
Public method Consume Overridden.

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | IsTest | Overridden. Returns true if the code element represents a test.
Public method | IsTestPart | Returns true if the code element represents a part of a test such as a test method or a test contribution like a setup or teardown method. (inherited from PatternAttribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | Process | (inherited from PatternAttribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | InitializeTest | Initializes a test for a contract verifier field after it has been added to the test model.
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Family method | SetTestSemantics | Establishes the semantics of the contract verifier.
Family method | ThrowUsageErrorException | Overloaded. Throws a PatternUsageErrorException with the specified message including a short heading that identifies the attribute type. (inherited from PatternAttribute)
Family method | Validate | Verifies that the attribute is being used correctly.
Top

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace
ComparisonContract
EqualityContract
ExceptionContract
ImmutabilityContract

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Consume Method

VerifyContractAttribute.Consume Method
[image]

Consumes a code element and applies its contributions to the scope provided by a containing pattern.

This method is used to declare new tests, test parameters and other components and add them to a containing test that was defined in some other scope.

For example, when enumerating test fixtures, the assembly-level pattern will call the Consume method of the primary patterns associated with each type in an assembly. Some of these patterns will create new test fixture objects and add them as children of the containing assembly-level test. They will then call the Process method of each non-primary pattern associated with the type within the scope of the test fixture. Then they will typically recurse into the fixture to apply contributions defined by patterns associated with methods, fields, properties, events, constructors and generic type parameters.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Consume( _
ByVal containingScope As IPatternScope, _
ByVal codeElement As ICodeElementInfo, _
ByVal skipChildren As Boolean _
) _
Implements IPattern.Consume
C#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
C++
public:
virtual void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
) override
J#
public override void Consume(
IPatternScope containingScope,
ICodeElementInfo codeElement,
bool skipChildren
)
JScript
public override function Consume(
containingScope : IPatternScope,
codeElement : ICodeElementInfo,
skipChildren : bool
)

Parameters

containingScope
The containing scope
codeElement
The code element to process
skipChildren
If true, skips generating child test components. Instead the children may be populated on demand using AddDeferredComponentPopulator. The implementation may safely ignore the value of this flag so long as subsequent attempts to populate children on demand are idempotent (do nothing or have no adverse side-effects).

Implements

IPattern.Consume

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InitializeTest Method

VerifyContractAttribute.InitializeTest Method
[image]

Initializes a test for a contract verifier field after it has been added to the test model.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeTest( _
ByVal fieldScope As IPatternScope, _
ByVal field As IFieldInfo _
)
C#
protected virtual void InitializeTest(
IPatternScope fieldScope,
IFieldInfo field
)
C++
protected:
virtual void InitializeTest(
IPatternScope fieldScope,
IFieldInfo field
)
J#
protected virtual void InitializeTest(
IPatternScope fieldScope,
IFieldInfo field
)
JScript
protected virtual function InitializeTest(
fieldScope : IPatternScope,
field : IFieldInfo
)

Parameters

fieldScope
The field scope
field
The field

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


IsTest Method

VerifyContractAttribute.IsTest Method
[image]

Returns true if the code element represents a test.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsTest( _
ByVal evaluator As IPatternEvaluator, _
ByVal codeElement As ICodeElementInfo _
) As Boolean _
Implements IPattern.IsTest
C#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
C++
public:
virtual bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
) override
J#
public override bool IsTest(
IPatternEvaluator evaluator,
ICodeElementInfo codeElement
)
JScript
public override function IsTest(
evaluator : IPatternEvaluator,
codeElement : ICodeElementInfo
) : bool

Parameters

evaluator
The evaluator
codeElement
The code element

Return Value

True if the code element represents a test

Implements

IPattern.IsTest

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetTestSemantics Method

VerifyContractAttribute.SetTestSemantics Method
[image]

Establishes the semantics of the contract verifier.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTestSemantics( _
ByVal testBuilder As ITestBuilder, _
ByVal field As IFieldInfo _
)
C#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
IFieldInfo field
)
C++
protected:
virtual void SetTestSemantics(
ITestBuilder testBuilder,
IFieldInfo field
)
J#
protected virtual void SetTestSemantics(
ITestBuilder testBuilder,
IFieldInfo field
)
JScript
protected virtual function SetTestSemantics(
testBuilder : ITestBuilder,
field : IFieldInfo
)

Parameters

testBuilder
The test builder
field
The field

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Validate Method

VerifyContractAttribute.Validate Method
[image]

Verifies that the attribute is being used correctly.

Namespace: MbUnit.Framework.ContractVerifiers
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Validate( _
ByVal containingScope As IPatternScope, _
ByVal field As IFieldInfo _
)
C#
protected virtual void Validate(
IPatternScope containingScope,
IFieldInfo field
)
C++
protected:
virtual void Validate(
IPatternScope containingScope,
IFieldInfo field
)
J#
protected virtual void Validate(
IPatternScope containingScope,
IFieldInfo field
)
JScript
protected virtual function Validate(
containingScope : IPatternScope,
field : IFieldInfo
)

Parameters

containingScope
The containing scope
field
The field

Exceptions

Exception Type | Condition
PatternUsageErrorException | Thrown if the attribute is being used incorrectly

See Also

VerifyContractAttribute Class
MbUnit.Framework.ContractVerifiers Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnit.Framework.ContractVerifiers.Core

MbUnit.Framework.ContractVerifiers.Core Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ContractVerificationContext | Execution context of a contract verification test. This class cannot be inherited.


ContractVerificationContext Class

ContractVerificationContext Class
See Also Example Members
[image]

Execution context of a contract verification test. This class cannot be inherited.

Namespace: MbUnit.Framework.ContractVerifiers.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ContractVerificationContext
C#
public sealed class ContractVerificationContext
C++
ref class ContractVerificationContext sealed
J#
public final class ContractVerificationContext
JScript
public final class ContractVerificationContext

Inheritance Hierarchy

System.Object
MbUnit.Framework.ContractVerifiers.Core.ContractVerificationContext

See Also

ContractVerificationContext Members
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContractVerificationContext Members

ContractVerificationContext Members
See Also Example Constructors Properties Methods
[image]

Execution context of a contract verification test. This class cannot be inherited.

The following tables list the members exposed by ContractVerificationContext.

Public Constructors

 | Name | Description
Public method | ContractVerificationContext | Constructs an execution context for the verification tests of a contract verifier.
Top

Public Properties

 | Name | Description
Public property | CodeElement | Gets the code element for the contrat read-only field.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStackTraceData | Gets an artificial stack trace data that points to the contrat read-only field.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ContractVerificationContext Class
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ContractVerificationContext Constructor

ContractVerificationContext Constructor
[image]

Constructs an execution context for the verification tests of a contract verifier.

Namespace: MbUnit.Framework.ContractVerifiers.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal codeElement As ICodeElementInfo _
)
C#
public ContractVerificationContext(
ICodeElementInfo codeElement
)
C++
public:
ContractVerificationContext(
ICodeElementInfo codeElement
) sealed
J#
public ContractVerificationContext(
ICodeElementInfo codeElement
)
JScript
public function ContractVerificationContext(
codeElement : ICodeElementInfo
)

Parameters

codeElement
The code element for the contrat read-only field.

Exceptions

Exception Type | Condition
ArgumentNullException | Thrown if codeElement is null

See Also

ContractVerificationContext Class
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Properties

ContractVerificationContext Properties
[image]

Public Properties

 | Name | Description
Public property | CodeElement | Gets the code element for the contrat read-only field.
Top

See Also

ContractVerificationContext Class
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CodeElement Property

ContractVerificationContext.CodeElement Property
[image]

Gets the code element for the contrat read-only field.

Namespace: MbUnit.Framework.ContractVerifiers.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CodeElement As ICodeElementInfo
C#
public ICodeElementInfo CodeElement { get; }
C++
public property ICodeElementInfo CodeElement sealed {
ICodeElementInfo get();
}
J#
/** property */
public ICodeElementInfo get_CodeElement();
JScript
public function get CodeElement() : ICodeElementInfo

See Also

ContractVerificationContext Class
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

ContractVerificationContext Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetStackTraceData | Gets an artificial stack trace data that points to the contrat read-only field.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ContractVerificationContext Class
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetStackTraceData Method

ContractVerificationContext.GetStackTraceData Method
[image]

Gets an artificial stack trace data that points to the contrat read-only field.

Namespace: MbUnit.Framework.ContractVerifiers.Core
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetStackTraceData() As StackTraceData
C#
public StackTraceData GetStackTraceData()
C++
public:
StackTraceData GetStackTraceData() sealed
J#
public StackTraceData GetStackTraceData()
JScript
public function GetStackTraceData() : StackTraceData

Return Value

An artificial stack trace data that points to the contrat read-only field.

See Also

ContractVerificationContext Class
MbUnit.Framework.ContractVerifiers.Core Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnit.Framework.Reflection

MbUnit.Framework.Reflection Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ReflectionException | Indicates that a reflection operation performed by Reflector failed.
Public class | Reflector | Helps to test non-public classes and class members.

Enumerations

 | Enumeration | Description
Public enumeration | AccessModifier | Access modifier of a class or class member.
Public enumeration | MemberType | Member types of a class.


AccessModifier Enumeration

AccessModifier Enumeration
[image]

Access modifier of a class or class member.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Enum AccessModifier
C#
public enum AccessModifier
C++
public enum class AccessModifier
J#
public enum AccessModifier
JScript
public enum AccessModifier

Members

Member Name | Description
Public | public
NonPublic | protected, internal, private
Static | static
Default | default that includes public, protected, internal, private, and static

See Also

MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MemberType Enumeration

MemberType Enumeration
[image]

Member types of a class.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Enum MemberType
C#
public enum MemberType
C++
public enum class MemberType
J#
public enum MemberType
JScript
public enum MemberType

Members

Member Name | Description
Method | Method
Field | Field or variable
Property | Property

See Also

MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Class

ReflectionException Class
See Also Example Members
[image]

Indicates that a reflection operation performed by Reflector failed.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class ReflectionException
Inherits Exception
C#
[SerializableAttribute]
public class ReflectionException : Exception
C++
[SerializableAttribute]
ref class ReflectionException : Exception
J#
/** @attribute SerializableAttribute() */
public class ReflectionException extends Exception
JScript
public
SerializableAttribute
class ReflectionException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
MbUnit.Framework.Reflection.ReflectionException

See Also

ReflectionException Members
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Members

ReflectionException Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Indicates that a reflection operation performed by Reflector failed.

The following tables list the members exposed by ReflectionException.

Public Constructors

Name | Description
ReflectionException | Overloaded. Initializes a new instance of the ReflectionException class.
Top

Protected Constructors

Name | Description
ReflectionException | Overloaded. Initializes a new instance of the ReflectionException class.
Top

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ReflectionException | Overloaded. Initializes a new instance of the ReflectionException class.
Top

See Also

ReflectionException Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Constructor

ReflectionException Constructor

Initializes a new instance of the ReflectionException class.

Overload List

 | Name | Description
Public method | ReflectionException | Creates an exception.
Family method | ReflectionException (SerializationInfo, StreamingContext) | Creates an exception from serialization info.
Public method | ReflectionException (String) | Creates an exception.
Public method | ReflectionException (String, Exception) | Creates an exception.

See Also

ReflectionException Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Constructor ()

ReflectionException Constructor ()
See Also Example
[image]

Creates an exception.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ReflectionException()
C++
public:
ReflectionException() sealed
J#
public ReflectionException()
JScript
public function ReflectionException()

See Also

ReflectionException Class
MbUnit.Framework.Reflection Namespace
ReflectionException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Constructor (SerializationInfo, StreamingContext)

ReflectionException Constructor (SerializationInfo, StreamingContext)
See Also Example
[image]

Creates an exception from serialization info.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C#
protected ReflectionException(
SerializationInfo info,
StreamingContext context
)
C++
protected:
ReflectionException(
SerializationInfo info,
StreamingContext context
) sealed
J#
protected ReflectionException(
SerializationInfo info,
StreamingContext context
)
JScript
protected function ReflectionException(
info : SerializationInfo,
context : StreamingContext
)

Parameters

info
The serialization info
context
The streaming context

See Also

ReflectionException Class
MbUnit.Framework.Reflection Namespace
ReflectionException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Constructor (String)

ReflectionException Constructor (String)
See Also Example
[image]

Creates an exception.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String _
)
C#
public ReflectionException(
string message
)
C++
public:
ReflectionException(
String message
) sealed
J#
public ReflectionException(
string message
)
JScript
public function ReflectionException(
message : String
)

Parameters

message
The message

See Also

ReflectionException Class
MbUnit.Framework.Reflection Namespace
ReflectionException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


ReflectionException Constructor (String, Exception)

ReflectionException Constructor (String, Exception)
See Also Example
[image]

Creates an exception.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
C#
public ReflectionException(
string message,
Exception innerException
)
C++
public:
ReflectionException(
String message,
Exception innerException
) sealed
J#
public ReflectionException(
string message,
Exception innerException
)
JScript
public function ReflectionException(
message : String,
innerException : Exception
)

Parameters

message
The message
innerException
The inner exception

See Also

ReflectionException Class
MbUnit.Framework.Reflection Namespace
ReflectionException Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reflector Class

Reflector Class
See Also Example Members
[image]

Helps to test non-public classes and class members.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Class Reflector
C#
public class Reflector
C++
ref class Reflector
J#
public class Reflector
JScript
public class Reflector

Inheritance Hierarchy

System.Object
MbUnit.Framework.Reflection.Reflector

See Also

Reflector Members
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reflector Members

Reflector Members
See Also Example Methods Explicit Inteface Implementations
[image]

Helps to test non-public classes and class members.

The following tables list the members exposed by Reflector.

Public Constructors

Name | Description
Reflector | Overloaded.
Top

Public Methods

 | Name | Description
 | CreateInstance | Overloaded. Create Instance
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetField | Overloaded. Get field value.
Public method | GetField | Overloaded. Get public, non-public, or static field value.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetProperty | Overloaded. Get Property Value
Public method | GetProperty | Overloaded. Get Property Value
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | InvokeMethod | Overloaded. Execute a NonPublic method with arguments on a object
Public method | InvokeMethod | Overloaded. Execute a NonPublic method with arguments on a object
 | SetField | Overloaded. Set field value.
Public method | SetField | Overloaded. Set field value.
 | SetProperty | Overloaded. Set Property value.
Public method | SetProperty | Overloaded. Set Property value.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Reflector | Overloaded.
Top

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reflector Constructor

Reflector Constructor

Overload List

 | Name | Description
Public method | Reflector (Object) | Constructor for object
Public method | Reflector (String, String) | Use this constructor if you plan to test default constructor of a non-public class.
Public method | Reflector (String, String, Object) | Use this constructor if you plan to test constructor with arguments of a non-public class.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reflector Constructor (Object)

Reflector Constructor (Object)
See Also Example
[image]

Constructor for object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal obj As Object _
)
C#
public Reflector(
object obj
)
C++
public:
Reflector(
Object obj
) sealed
J#
public Reflector(
object obj
)
JScript
public function Reflector(
obj : Object
)

Parameters

obj
Object to be referred to in methods

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reflector Constructor (String, String)

Reflector Constructor (String, String)
See Also Example
[image]

Use this constructor if you plan to test default constructor of a non-public class.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyName As String, _
ByVal typeName As String _
)
C#
public Reflector(
string assemblyName,
string typeName
)
C++
public:
Reflector(
String assemblyName,
String typeName
) sealed
J#
public Reflector(
string assemblyName,
string typeName
)
JScript
public function Reflector(
assemblyName : String,
typeName : String
)

Parameters

assemblyName
typeName

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Reflector Constructor (String, String, Object[])

Reflector Constructor (String, String, Object[])
See Also Example
[image]

Use this constructor if you plan to test constructor with arguments of a non-public class.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal assemblyName As String, _
ByVal typeName As String, _
ByVal ParamArray args As Object() _
)
C#
public Reflector(
string assemblyName,
string typeName,
params object[] args
)
C++
public:
Reflector(
String assemblyName,
String typeName,
... array<Object>^ args
) sealed
J#
public Reflector(
string assemblyName,
string typeName,
object[] args
)
JScript
public function Reflector(
assemblyName : String,
typeName : String,
ParamArrayAttribute args : Object[]
)

Parameters

assemblyName
Assembly name
typeName
Type name
args
Parameters for a constructor.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


Methods

Reflector Methods
[image]

Public Methods

 | Name | Description
 | CreateInstance | Overloaded. Create Instance
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetField | Overloaded. Get field value.
Public method | GetField | Overloaded. Get public, non-public, or static field value.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetProperty | Overloaded. Get Property Value
Public method | GetProperty | Overloaded. Get Property Value
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | InvokeMethod | Overloaded. Execute a NonPublic method with arguments on a object
Public method | InvokeMethod | Overloaded. Execute a NonPublic method with arguments on a object
 | SetField | Overloaded. Set field value.
Public method | SetField | Overloaded. Set field value.
 | SetProperty | Overloaded. Set Property value.
Public method | SetProperty | Overloaded. Set Property value.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CreateInstance Method

Reflector.CreateInstance Method

Create Instance

Overload List

Name | Description
CreateInstance (String, String) | Create Instance
CreateInstance (String, String, Object) | Create Instance

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CreateInstance Method (String, String)

Reflector.CreateInstance Method (String, String)
See Also Example
[image]

Create Instance

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstance( _
ByVal assemblyName As String, _
ByVal typeName As String _
) As Object
C#
public static object CreateInstance(
string assemblyName,
string typeName
)
C++
public:
static Object CreateInstance(
String assemblyName,
String typeName
)
J#
public static object CreateInstance(
string assemblyName,
string typeName
)
JScript
public static function CreateInstance(
assemblyName : String,
typeName : String
) : Object

Parameters

assemblyName
Full assembly path.
typeName
Type Name such as (System.String)

Return Value

Newly created object.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.CreateInstance Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


CreateInstance Method (String, String, Object[])

Reflector.CreateInstance Method (String, String, Object[])
See Also Example
[image]

Create Instance

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateInstance( _
ByVal assemblyName As String, _
ByVal typeName As String, _
ByVal ParamArray args As Object() _
) As Object
C#
public static object CreateInstance(
string assemblyName,
string typeName,
params object[] args
)
C++
public:
static Object CreateInstance(
String assemblyName,
String typeName,
... array<Object>^ args
)
J#
public static object CreateInstance(
string assemblyName,
string typeName,
object[] args
)
JScript
public static function CreateInstance(
assemblyName : String,
typeName : String,
ParamArrayAttribute args : Object[]
) : Object

Parameters

assemblyName
Full assembly path.
typeName
Type Name such as (System.String)
args
Constructor parameters.

Return Value

Newly created object.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.CreateInstance Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method

Reflector.GetField Method

Get field value.

Overload List

Name | Description
GetField (AccessModifier, Object, String) | Get field value.
GetField (AccessModifier, Object, String, Boolean) | Get field value.
GetField (Object, String) | Get public, non-public, or static field value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method (AccessModifier, Object, String)

Reflector.GetField Method (AccessModifier, Object, String)
See Also Example
[image]

Get field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetField( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal fieldName As String _
) As Object
C#
public static object GetField(
AccessModifier access,
object obj,
string fieldName
)
C++
public:
static Object GetField(
AccessModifier access,
Object obj,
String fieldName
)
J#
public static object GetField(
AccessModifier access,
object obj,
string fieldName
)
JScript
public static function GetField(
access : AccessModifier,
obj : Object,
fieldName : String
) : Object

Parameters

access
Specify field access modifier.
obj
Object where field is defined.
fieldName
Field name.

Return Value

Field value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method (AccessModifier, Object, String, Boolean)

Reflector.GetField Method (AccessModifier, Object, String, Boolean)
See Also Example
[image]

Get field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetField( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal fieldName As String, _
ByVal lookInBase As Boolean _
) As Object
C#
public static object GetField(
AccessModifier access,
object obj,
string fieldName,
bool lookInBase
)
C++
public:
static Object GetField(
AccessModifier access,
Object obj,
String fieldName,
bool lookInBase
)
J#
public static object GetField(
AccessModifier access,
object obj,
string fieldName,
bool lookInBase
)
JScript
public static function GetField(
access : AccessModifier,
obj : Object,
fieldName : String,
lookInBase : bool
) : Object

Parameters

access
Specify field access modifier.
obj
Object where field is defined.
fieldName
Field name.
lookInBase
Specify if need to look in Base classes.

Return Value

Field value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method (Object, String)

Reflector.GetField Method (Object, String)
See Also Example
[image]

Get public, non-public, or static field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetField( _
ByVal obj As Object, _
ByVal fieldName As String _
) As Object
C#
public static object GetField(
object obj,
string fieldName
)
C++
public:
static Object GetField(
Object obj,
String fieldName
)
J#
public static object GetField(
object obj,
string fieldName
)
JScript
public static function GetField(
obj : Object,
fieldName : String
) : Object

Parameters

obj
Object where field is defined.
fieldName
Field name.

Return Value

Field value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method

Reflector.GetField Method

Get public, non-public, or static field value.

Overload List

 | Name | Description
Public method | GetField (String) | Get public, non-public, or static field value.
Public method | GetField (String, AccessModifier) | Get field value.
Public method | GetField (String, AccessModifier, Boolean) | Get field value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method (String)

Reflector.GetField Method (String)
See Also Example
[image]

Get public, non-public, or static field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetField( _
ByVal fieldName As String _
) As Object
C#
public object GetField(
string fieldName
)
C++
public:
Object GetField(
String fieldName
) sealed
J#
public object GetField(
string fieldName
)
JScript
public function GetField(
fieldName : String
) : Object

Parameters

fieldName
Field name.

Return Value

Field value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method (String, AccessModifier)

Reflector.GetField Method (String, AccessModifier)
See Also Example
[image]

Get field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetField( _
ByVal fieldName As String, _
ByVal access As AccessModifier _
) As Object
C#
public object GetField(
string fieldName,
AccessModifier access
)
C++
public:
Object GetField(
String fieldName,
AccessModifier access
) sealed
J#
public object GetField(
string fieldName,
AccessModifier access
)
JScript
public function GetField(
fieldName : String,
access : AccessModifier
) : Object

Parameters

fieldName
Field name.
access
Specify field access modifier.

Return Value

Field value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetField Method (String, AccessModifier, Boolean)

Reflector.GetField Method (String, AccessModifier, Boolean)
See Also Example
[image]

Get field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetField( _
ByVal fieldName As String, _
ByVal access As AccessModifier, _
ByVal lookInBase As Boolean _
) As Object
C#
public object GetField(
string fieldName,
AccessModifier access,
bool lookInBase
)
C++
public:
Object GetField(
String fieldName,
AccessModifier access,
bool lookInBase
) sealed
J#
public object GetField(
string fieldName,
AccessModifier access,
bool lookInBase
)
JScript
public function GetField(
fieldName : String,
access : AccessModifier,
lookInBase : bool
) : Object

Parameters

fieldName
Field name.
access
Specify field access modifier.
lookInBase
Specify if need to look in Base classes.

Return Value

Field value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method

Reflector.GetProperty Method

Get Property Value

Overload List

Name | Description
GetProperty (AccessModifier, Object, String) | Get Property Value
GetProperty (AccessModifier, Object, String, Boolean) | Get Property Value
GetProperty (Object, String) | Get Property Value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method (AccessModifier, Object, String)

Reflector.GetProperty Method (AccessModifier, Object, String)
See Also Example
[image]

Get Property Value

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetProperty( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal propertyName As String _
) As Object
C#
public static object GetProperty(
AccessModifier access,
object obj,
string propertyName
)
C++
public:
static Object GetProperty(
AccessModifier access,
Object obj,
String propertyName
)
J#
public static object GetProperty(
AccessModifier access,
object obj,
string propertyName
)
JScript
public static function GetProperty(
access : AccessModifier,
obj : Object,
propertyName : String
) : Object

Parameters

access
Specify property access modifier.
obj
Object that has the property.
propertyName
Property Name.

Return Value

Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method (AccessModifier, Object, String, Boolean)

Reflector.GetProperty Method (AccessModifier, Object, String, Boolean)
See Also Example
[image]

Get Property Value

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetProperty( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal propertyName As String, _
ByVal lookInBase As Boolean _
) As Object
C#
public static object GetProperty(
AccessModifier access,
object obj,
string propertyName,
bool lookInBase
)
C++
public:
static Object GetProperty(
AccessModifier access,
Object obj,
String propertyName,
bool lookInBase
)
J#
public static object GetProperty(
AccessModifier access,
object obj,
string propertyName,
bool lookInBase
)
JScript
public static function GetProperty(
access : AccessModifier,
obj : Object,
propertyName : String,
lookInBase : bool
) : Object

Parameters

access
Specify property access modifier.
obj
Object that has the property.
propertyName
Property Name.
lookInBase
Set to true if need look for the property in base classes.

Return Value

Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method (Object, String)

Reflector.GetProperty Method (Object, String)
See Also Example
[image]

Get Property Value

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetProperty( _
ByVal obj As Object, _
ByVal propertyName As String _
) As Object
C#
public static object GetProperty(
object obj,
string propertyName
)
C++
public:
static Object GetProperty(
Object obj,
String propertyName
)
J#
public static object GetProperty(
object obj,
string propertyName
)
JScript
public static function GetProperty(
obj : Object,
propertyName : String
) : Object

Parameters

obj
Object where property is defined.
propertyName
Property Name.

Return Value

Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method

Reflector.GetProperty Method

Get Property Value

Overload List

 | Name | Description
Public method | GetProperty (AccessModifier, String) | Get Property Value
Public method | GetProperty (AccessModifier, String, Boolean) | Get Property Value
Public method | GetProperty (String) | Get Property Value

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method (AccessModifier, String)

Reflector.GetProperty Method (AccessModifier, String)
See Also Example
[image]

Get Property Value

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetProperty( _
ByVal access As AccessModifier, _
ByVal propertyName As String _
) As Object
C#
public object GetProperty(
AccessModifier access,
string propertyName
)
C++
public:
Object GetProperty(
AccessModifier access,
String propertyName
) sealed
J#
public object GetProperty(
AccessModifier access,
string propertyName
)
JScript
public function GetProperty(
access : AccessModifier,
propertyName : String
) : Object

Parameters

access
Specify property access modifier.
propertyName
Property Name.

Return Value

Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method (AccessModifier, String, Boolean)

Reflector.GetProperty Method (AccessModifier, String, Boolean)
See Also Example
[image]

Get Property Value

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetProperty( _
ByVal access As AccessModifier, _
ByVal propertyName As String, _
ByVal lookInBase As Boolean _
) As Object
C#
public object GetProperty(
AccessModifier access,
string propertyName,
bool lookInBase
)
C++
public:
Object GetProperty(
AccessModifier access,
String propertyName,
bool lookInBase
) sealed
J#
public object GetProperty(
AccessModifier access,
string propertyName,
bool lookInBase
)
JScript
public function GetProperty(
access : AccessModifier,
propertyName : String,
lookInBase : bool
) : Object

Parameters

access
Specify property access modifier.
propertyName
Property Name.
lookInBase
Specify if need to look in Base classes.

Return Value

Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


GetProperty Method (String)

Reflector.GetProperty Method (String)
See Also Example
[image]

Get Property Value

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function GetProperty( _
ByVal propertyName As String _
) As Object
C#
public object GetProperty(
string propertyName
)
C++
public:
Object GetProperty(
String propertyName
) sealed
J#
public object GetProperty(
string propertyName
)
JScript
public function GetProperty(
propertyName : String
) : Object

Parameters

propertyName
Property Name.

Return Value

Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.GetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method

Reflector.InvokeMethod Method

Execute a NonPublic method with arguments on a object

Overload List

Name | Description
InvokeMethod (AccessModifier, Object, String, Boolean, Object) | Execute a NonPublic method with arguments on a object
InvokeMethod (AccessModifier, Object, String, Object) | Execute a NonPublic method with arguments on a object
InvokeMethod (Object, String) | Execute a NonPublic method with arguments on a object
InvokeMethod (Object, String, Object) | Execute a NonPublic method with arguments on a object

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (AccessModifier, Object, String, Boolean, Object[])

Reflector.InvokeMethod Method (AccessModifier, Object, String, Boolean, Object[])
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function InvokeMethod( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal methodName As String, _
ByVal lookInBase As Boolean, _
ByVal ParamArray methodParams As Object() _
) As Object
C#
public static object InvokeMethod(
AccessModifier access,
object obj,
string methodName,
bool lookInBase,
params object[] methodParams
)
C++
public:
static Object InvokeMethod(
AccessModifier access,
Object obj,
String methodName,
bool lookInBase,
... array<Object>^ methodParams
)
J#
public static object InvokeMethod(
AccessModifier access,
object obj,
string methodName,
bool lookInBase,
object[] methodParams
)
JScript
public static function InvokeMethod(
access : AccessModifier,
obj : Object,
methodName : String,
lookInBase : bool,
ParamArrayAttribute methodParams : Object[]
) : Object

Parameters

access
Specify method access modifier.
obj
Object where method is defined.
methodName
Method to call
lookInBase
Speicifies if to search for the method in the base classes or not.
methodParams
Method's parameters.

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (AccessModifier, Object, String, Object[])

Reflector.InvokeMethod Method (AccessModifier, Object, String, Object[])
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function InvokeMethod( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal methodName As String, _
ByVal ParamArray methodParams As Object() _
) As Object
C#
public static object InvokeMethod(
AccessModifier access,
object obj,
string methodName,
params object[] methodParams
)
C++
public:
static Object InvokeMethod(
AccessModifier access,
Object obj,
String methodName,
... array<Object>^ methodParams
)
J#
public static object InvokeMethod(
AccessModifier access,
object obj,
string methodName,
object[] methodParams
)
JScript
public static function InvokeMethod(
access : AccessModifier,
obj : Object,
methodName : String,
ParamArrayAttribute methodParams : Object[]
) : Object

Parameters

access
Specify method access modifier.
obj
Object where method is defined.
methodName
Method to call
methodParams
Method's parameters.

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (Object, String)

Reflector.InvokeMethod Method (Object, String)
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function InvokeMethod( _
ByVal obj As Object, _
ByVal methodName As String _
) As Object
C#
public static object InvokeMethod(
object obj,
string methodName
)
C++
public:
static Object InvokeMethod(
Object obj,
String methodName
)
J#
public static object InvokeMethod(
object obj,
string methodName
)
JScript
public static function InvokeMethod(
obj : Object,
methodName : String
) : Object

Parameters

obj
Object where method is defined.
methodName
Method to call

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (Object, String, Object[])

Reflector.InvokeMethod Method (Object, String, Object[])
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function InvokeMethod( _
ByVal obj As Object, _
ByVal methodName As String, _
ByVal ParamArray methodParams As Object() _
) As Object
C#
public static object InvokeMethod(
object obj,
string methodName,
params object[] methodParams
)
C++
public:
static Object InvokeMethod(
Object obj,
String methodName,
... array<Object>^ methodParams
)
J#
public static object InvokeMethod(
object obj,
string methodName,
object[] methodParams
)
JScript
public static function InvokeMethod(
obj : Object,
methodName : String,
ParamArrayAttribute methodParams : Object[]
) : Object

Parameters

obj
Object where method is defined.
methodName
Method to call
methodParams
Method's parameters.

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method

Reflector.InvokeMethod Method

Execute a NonPublic method with arguments on a object

Overload List

 | Name | Description
Public method | InvokeMethod (AccessModifier, String, Object) | Execute a NonPublic method with arguments on a object
Public method | InvokeMethod (String) | Execute a NonPublic method with arguments on a object
Public method | InvokeMethod (String, Object) | Execute a NonPublic method with arguments on a object

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (AccessModifier, String, Object[])

Reflector.InvokeMethod Method (AccessModifier, String, Object[])
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function InvokeMethod( _
ByVal access As AccessModifier, _
ByVal methodName As String, _
ByVal ParamArray methodParams As Object() _
) As Object
C#
public object InvokeMethod(
AccessModifier access,
string methodName,
params object[] methodParams
)
C++
public:
Object InvokeMethod(
AccessModifier access,
String methodName,
... array<Object>^ methodParams
) sealed
J#
public object InvokeMethod(
AccessModifier access,
string methodName,
object[] methodParams
)
JScript
public function InvokeMethod(
access : AccessModifier,
methodName : String,
ParamArrayAttribute methodParams : Object[]
) : Object

Parameters

access
Specify method access modifier.
methodName
Method to call
methodParams
Method's parameters.

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (String)

Reflector.InvokeMethod Method (String)
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function InvokeMethod( _
ByVal methodName As String _
) As Object
C#
public object InvokeMethod(
string methodName
)
C++
public:
Object InvokeMethod(
String methodName
) sealed
J#
public object InvokeMethod(
string methodName
)
JScript
public function InvokeMethod(
methodName : String
) : Object

Parameters

methodName
Method to call

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


InvokeMethod Method (String, Object[])

Reflector.InvokeMethod Method (String, Object[])
See Also Example
[image]

Execute a NonPublic method with arguments on a object

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Function InvokeMethod( _
ByVal methodName As String, _
ByVal ParamArray methodParams As Object() _
) As Object
C#
public object InvokeMethod(
string methodName,
params object[] methodParams
)
C++
public:
Object InvokeMethod(
String methodName,
... array<Object>^ methodParams
) sealed
J#
public object InvokeMethod(
string methodName,
object[] methodParams
)
JScript
public function InvokeMethod(
methodName : String,
ParamArrayAttribute methodParams : Object[]
) : Object

Parameters

methodName
Method to call
methodParams
Method's parameters.

Return Value

The object the method should return.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.InvokeMethod Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method

Reflector.SetField Method

Set field value.

Overload List

Name | Description
SetField (AccessModifier, Object, String, Object) | Set field value.
SetField (AccessModifier, Object, String, Object, Boolean) | Set field value.
SetField (Object, String, Object) | Set field value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method (AccessModifier, Object, String, Object)

Reflector.SetField Method (AccessModifier, Object, String, Object)
See Also Example
[image]

Set field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetField( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal fieldName As String, _
ByVal fieldValue As Object _
)
C#
public static void SetField(
AccessModifier access,
object obj,
string fieldName,
object fieldValue
)
C++
public:
static void SetField(
AccessModifier access,
Object obj,
String fieldName,
Object fieldValue
)
J#
public static void SetField(
AccessModifier access,
object obj,
string fieldName,
object fieldValue
)
JScript
public static function SetField(
access : AccessModifier,
obj : Object,
fieldName : String,
fieldValue : Object
)

Parameters

access
Specify field access modifier.
obj
Object where field is defined.
fieldName
Field Name.
fieldValue
Field Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method (AccessModifier, Object, String, Object, Boolean)

Reflector.SetField Method (AccessModifier, Object, String, Object, Boolean)
See Also Example
[image]

Set field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetField( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal fieldName As String, _
ByVal fieldValue As Object, _
ByVal lookInBase As Boolean _
)
C#
public static void SetField(
AccessModifier access,
object obj,
string fieldName,
object fieldValue,
bool lookInBase
)
C++
public:
static void SetField(
AccessModifier access,
Object obj,
String fieldName,
Object fieldValue,
bool lookInBase
)
J#
public static void SetField(
AccessModifier access,
object obj,
string fieldName,
object fieldValue,
bool lookInBase
)
JScript
public static function SetField(
access : AccessModifier,
obj : Object,
fieldName : String,
fieldValue : Object,
lookInBase : bool
)

Parameters

access
Specify field access modifier.
obj
Object where field is defined.
fieldName
Field Name.
fieldValue
Field Value.
lookInBase
Specify if need to look in Base classes.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method (Object, String, Object)

Reflector.SetField Method (Object, String, Object)
See Also Example
[image]

Set field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetField( _
ByVal obj As Object, _
ByVal fieldName As String, _
ByVal fieldValue As Object _
)
C#
public static void SetField(
object obj,
string fieldName,
object fieldValue
)
C++
public:
static void SetField(
Object obj,
String fieldName,
Object fieldValue
)
J#
public static void SetField(
object obj,
string fieldName,
object fieldValue
)
JScript
public static function SetField(
obj : Object,
fieldName : String,
fieldValue : Object
)

Parameters

obj
Object where field is defined.
fieldName
Field Name.
fieldValue
Field Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method

Reflector.SetField Method

Set field value.

Overload List

 | Name | Description
Public method | SetField (AccessModifier, String, Object) | Set field value.
Public method | SetField (String, Object) | Set field value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method (AccessModifier, String, Object)

Reflector.SetField Method (AccessModifier, String, Object)
See Also Example
[image]

Set field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetField( _
ByVal access As AccessModifier, _
ByVal fieldName As String, _
ByVal fieldValue As Object _
)
C#
public void SetField(
AccessModifier access,
string fieldName,
object fieldValue
)
C++
public:
void SetField(
AccessModifier access,
String fieldName,
Object fieldValue
) sealed
J#
public void SetField(
AccessModifier access,
string fieldName,
object fieldValue
)
JScript
public function SetField(
access : AccessModifier,
fieldName : String,
fieldValue : Object
)

Parameters

access
Specify field access modifier.
fieldName
Field Name.
fieldValue
Field Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetField Method (String, Object)

Reflector.SetField Method (String, Object)
See Also Example
[image]

Set field value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetField( _
ByVal fieldName As String, _
ByVal fieldValue As Object _
)
C#
public void SetField(
string fieldName,
object fieldValue
)
C++
public:
void SetField(
String fieldName,
Object fieldValue
) sealed
J#
public void SetField(
string fieldName,
object fieldValue
)
JScript
public function SetField(
fieldName : String,
fieldValue : Object
)

Parameters

fieldName
Field Name.
fieldValue
Field Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetField Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method

Reflector.SetProperty Method

Set Property value.

Overload List

Name | Description
SetProperty (AccessModifier, Object, String, Object) | Set Property value.
SetProperty (AccessModifier, Object, String, Object, Boolean) | Set Property value.
SetProperty (Object, String, Object) | Set Property value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method (AccessModifier, Object, String, Object)

Reflector.SetProperty Method (AccessModifier, Object, String, Object)
See Also Example
[image]

Set Property value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetProperty( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal propertyName As String, _
ByVal propertyValue As Object _
)
C#
public static void SetProperty(
AccessModifier access,
object obj,
string propertyName,
object propertyValue
)
C++
public:
static void SetProperty(
AccessModifier access,
Object obj,
String propertyName,
Object propertyValue
)
J#
public static void SetProperty(
AccessModifier access,
object obj,
string propertyName,
object propertyValue
)
JScript
public static function SetProperty(
access : AccessModifier,
obj : Object,
propertyName : String,
propertyValue : Object
)

Parameters

access
Specify property access modifier.
obj
Object where property is defined.
propertyName
Property Name.
propertyValue
Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method (AccessModifier, Object, String, Object, Boolean)

Reflector.SetProperty Method (AccessModifier, Object, String, Object, Boolean)
See Also Example
[image]

Set Property value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetProperty( _
ByVal access As AccessModifier, _
ByVal obj As Object, _
ByVal propertyName As String, _
ByVal propertyValue As Object, _
ByVal lookInBase As Boolean _
)
C#
public static void SetProperty(
AccessModifier access,
object obj,
string propertyName,
object propertyValue,
bool lookInBase
)
C++
public:
static void SetProperty(
AccessModifier access,
Object obj,
String propertyName,
Object propertyValue,
bool lookInBase
)
J#
public static void SetProperty(
AccessModifier access,
object obj,
string propertyName,
object propertyValue,
bool lookInBase
)
JScript
public static function SetProperty(
access : AccessModifier,
obj : Object,
propertyName : String,
propertyValue : Object,
lookInBase : bool
)

Parameters

access
Specify property access modifier.
obj
Object where property is defined.
propertyName
Property Name.
propertyValue
Property Value.
lookInBase
Set to true if need look for the property in base classes.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method (Object, String, Object)

Reflector.SetProperty Method (Object, String, Object)
See Also Example
[image]

Set Property value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetProperty( _
ByVal obj As Object, _
ByVal propertyName As String, _
ByVal propertyValue As Object _
)
C#
public static void SetProperty(
object obj,
string propertyName,
object propertyValue
)
C++
public:
static void SetProperty(
Object obj,
String propertyName,
Object propertyValue
)
J#
public static void SetProperty(
object obj,
string propertyName,
object propertyValue
)
JScript
public static function SetProperty(
obj : Object,
propertyName : String,
propertyValue : Object
)

Parameters

obj
Object where property is defined.
propertyName
Property Name.
propertyValue
Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method

Reflector.SetProperty Method

Set Property value.

Overload List

 | Name | Description
Public method | SetProperty (AccessModifier, String, Object) | Set Property value.
Public method | SetProperty (String, Object) | Set Property value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method (AccessModifier, String, Object)

Reflector.SetProperty Method (AccessModifier, String, Object)
See Also Example
[image]

Set Property value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetProperty( _
ByVal access As AccessModifier, _
ByVal propertyName As String, _
ByVal propertyValue As Object _
)
C#
public void SetProperty(
AccessModifier access,
string propertyName,
object propertyValue
)
C++
public:
void SetProperty(
AccessModifier access,
String propertyName,
Object propertyValue
) sealed
J#
public void SetProperty(
AccessModifier access,
string propertyName,
object propertyValue
)
JScript
public function SetProperty(
access : AccessModifier,
propertyName : String,
propertyValue : Object
)

Parameters

access
Specify property access modifier.
propertyName
Property Name.
propertyValue
Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


SetProperty Method (String, Object)

Reflector.SetProperty Method (String, Object)
See Also Example
[image]

Set Property value.

Namespace: MbUnit.Framework.Reflection
Assembly: MbUnit (in MbUnit.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetProperty( _
ByVal propertyName As String, _
ByVal propertyValue As Object _
)
C#
public void SetProperty(
string propertyName,
object propertyValue
)
C++
public:
void SetProperty(
String propertyName,
Object propertyValue
) sealed
J#
public void SetProperty(
string propertyName,
object propertyValue
)
JScript
public function SetProperty(
propertyName : String,
propertyValue : Object
)

Parameters

propertyName
Property Name.
propertyValue
Property Value.

See Also

Reflector Class
MbUnit.Framework.Reflection Namespace
Reflector.SetProperty Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit [3.0.6.0]


MbUnit.Framework.Xml

MbUnit.Framework.Xml Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | DiffConfiguration |
Public class | Difference |
Public class | Differences | Utilities for manipulating differences. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.
Public class | DiffResult |
Public class | Validator |
Public class | XmlDiff |
Public class | XmlInput |
Public class | XmlOutput |
Public class | XPath |
Public class | Xslt |

Enumerations

 | Enumeration | Description
Public enumeration | DifferenceType | Describes the type of difference found.


DiffConfiguration Class

DiffConfiguration Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class DiffConfiguration
C#
public class DiffConfiguration
C++
ref class DiffConfiguration
J#
public class DiffConfiguration
JScript
public class DiffConfiguration

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.DiffConfiguration

See Also

DiffConfiguration Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Members

DiffConfiguration Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by DiffConfiguration.

Public Constructors

Name | Description
DiffConfiguration | Overloaded.
Top

Public Fields

Name | Description
DEFAULT_DESCRIPTION |
DEFAULT_USE_VALIDATING_PARSER |
DEFAULT_WHITESPACE_HANDLING |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | UseValidatingParser |
Public property | WhitespaceHandling |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
DiffConfiguration | Overloaded.
Top

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor

DiffConfiguration Constructor

Overload List

 | Name | Description
Public method | DiffConfiguration | Initializes a new instance of the DiffConfiguration class.
Public method | DiffConfiguration (Boolean) |
Public method | DiffConfiguration (String) |
Public method | DiffConfiguration (String, Boolean, WhitespaceHandling) |
Public method | DiffConfiguration (String, WhitespaceHandling) |
Public method | DiffConfiguration (WhitespaceHandling) |

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor ()

DiffConfiguration Constructor ()
See Also Example
[image]

Initializes a new instance of the DiffConfiguration class.

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DiffConfiguration()
C++
public:
DiffConfiguration() sealed
J#
public DiffConfiguration()
JScript
public function DiffConfiguration()

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace
DiffConfiguration Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor (Boolean)

DiffConfiguration Constructor (Boolean)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal useValidatingParser As Boolean _
)
C#
public DiffConfiguration(
bool useValidatingParser
)
C++
public:
DiffConfiguration(
bool useValidatingParser
) sealed
J#
public DiffConfiguration(
bool useValidatingParser
)
JScript
public function DiffConfiguration(
useValidatingParser : bool
)

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace
DiffConfiguration Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor (String)

DiffConfiguration Constructor (String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal description As String _
)
C#
public DiffConfiguration(
string description
)
C++
public:
DiffConfiguration(
String description
) sealed
J#
public DiffConfiguration(
string description
)
JScript
public function DiffConfiguration(
description : String
)

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace
DiffConfiguration Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor (String, Boolean, WhitespaceHandling)

DiffConfiguration Constructor (String, Boolean, WhitespaceHandling)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal description As String, _
ByVal useValidatingParser As Boolean, _
ByVal whitespaceHandling As WhitespaceHandling _
)
C#
public DiffConfiguration(
string description,
bool useValidatingParser,
WhitespaceHandling whitespaceHandling
)
C++
public:
DiffConfiguration(
String description,
bool useValidatingParser,
WhitespaceHandling whitespaceHandling
) sealed
J#
public DiffConfiguration(
string description,
bool useValidatingParser,
WhitespaceHandling whitespaceHandling
)
JScript
public function DiffConfiguration(
description : String,
useValidatingParser : bool,
whitespaceHandling : WhitespaceHandling
)

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace
DiffConfiguration Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor (String, WhitespaceHandling)

DiffConfiguration Constructor (String, WhitespaceHandling)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal description As String, _
ByVal whitespaceHandling As WhitespaceHandling _
)
C#
public DiffConfiguration(
string description,
WhitespaceHandling whitespaceHandling
)
C++
public:
DiffConfiguration(
String description,
WhitespaceHandling whitespaceHandling
) sealed
J#
public DiffConfiguration(
string description,
WhitespaceHandling whitespaceHandling
)
JScript
public function DiffConfiguration(
description : String,
whitespaceHandling : WhitespaceHandling
)

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace
DiffConfiguration Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffConfiguration Constructor (WhitespaceHandling)

DiffConfiguration Constructor (WhitespaceHandling)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal whitespaceHandling As WhitespaceHandling _
)
C#
public DiffConfiguration(
WhitespaceHandling whitespaceHandling
)
C++
public:
DiffConfiguration(
WhitespaceHandling whitespaceHandling
) sealed
J#
public DiffConfiguration(
WhitespaceHandling whitespaceHandling
)
JScript
public function DiffConfiguration(
whitespaceHandling : WhitespaceHandling
)

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace
DiffConfiguration Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Fields

DiffConfiguration Fields
[image]

Public Fields

Name | Description
DEFAULT_DESCRIPTION |
DEFAULT_USE_VALIDATING_PARSER |
DEFAULT_WHITESPACE_HANDLING |
Top

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DEFAULT_DESCRIPTION Field

DiffConfiguration.DEFAULT_DESCRIPTION Field
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_DESCRIPTION As String
C#
public static readonly string DEFAULT_DESCRIPTION;
C++
public:
static const String DEFAULT_DESCRIPTION;
J#
public static final string DEFAULT_DESCRIPTION
JScript
public static const var DEFAULT_DESCRIPTION : String;

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DEFAULT_USE_VALIDATING_PARSER Field

DiffConfiguration.DEFAULT_USE_VALIDATING_PARSER Field
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_USE_VALIDATING_PARSER As Boolean
C#
public static readonly bool DEFAULT_USE_VALIDATING_PARSER;
C++
public:
static const bool DEFAULT_USE_VALIDATING_PARSER;
J#
public static final bool DEFAULT_USE_VALIDATING_PARSER
JScript
public static const var DEFAULT_USE_VALIDATING_PARSER : bool;

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DEFAULT_WHITESPACE_HANDLING Field

DiffConfiguration.DEFAULT_WHITESPACE_HANDLING Field
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DEFAULT_WHITESPACE_HANDLING As WhitespaceHandling
C#
public static readonly WhitespaceHandling DEFAULT_WHITESPACE_HANDLING;
C++
public:
static const WhitespaceHandling DEFAULT_WHITESPACE_HANDLING;
J#
public static final WhitespaceHandling DEFAULT_WHITESPACE_HANDLING
JScript
public static const var DEFAULT_WHITESPACE_HANDLING : WhitespaceHandling;

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Properties

DiffConfiguration Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | UseValidatingParser |
Public property | WhitespaceHandling |
Top

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Description Property

DiffConfiguration.Description Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
C#
public string Description { get; }
C++
public property string Description sealed {
String get();
}
J#
/** property */
public string get_Description();
JScript
public function get Description() : String

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


UseValidatingParser Property

DiffConfiguration.UseValidatingParser Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UseValidatingParser As Boolean
C#
public bool UseValidatingParser { get; }
C++
public property bool UseValidatingParser sealed {
bool get();
}
J#
/** property */
public bool get_UseValidatingParser();
JScript
public function get UseValidatingParser() : bool

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


WhitespaceHandling Property

DiffConfiguration.WhitespaceHandling Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WhitespaceHandling As WhitespaceHandling
C#
public WhitespaceHandling WhitespaceHandling { get; }
C++
public property WhitespaceHandling WhitespaceHandling sealed {
WhitespaceHandling get();
}
J#
/** property */
public WhitespaceHandling get_WhitespaceHandling();
JScript
public function get WhitespaceHandling() : WhitespaceHandling

See Also

DiffConfiguration Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Difference Class

Difference Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class Difference
C#
[SerializableAttribute]
public class Difference
C++
[SerializableAttribute]
ref class Difference
J#
/** @attribute SerializableAttribute() */
public class Difference
JScript
public
SerializableAttribute
class Difference

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.Difference

See Also

Difference Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Difference Members

Difference Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Difference.

Public Constructors

Name | Description
Difference | Overloaded.
Top

Public Properties

 | Name | Description
Public property | ControlNodeType |
Public property | Id |
Public property | MajorDifference |
Public property | TestNodeType |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Difference | Overloaded.
Top

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Difference Constructor

Difference Constructor

Overload List

 | Name | Description
Public method | Difference (DifferenceType) |
Public method | Difference (DifferenceType, XmlNodeType, XmlNodeType) |

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Difference Constructor (DifferenceType)

Difference Constructor (DifferenceType)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As DifferenceType _
)
C#
public Difference(
DifferenceType id
)
C++
public:
Difference(
DifferenceType id
) sealed
J#
public Difference(
DifferenceType id
)
JScript
public function Difference(
id : DifferenceType
)

See Also

Difference Class
MbUnit.Framework.Xml Namespace
Difference Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Difference Constructor (DifferenceType, XmlNodeType, XmlNodeType)

Difference Constructor (DifferenceType, XmlNodeType, XmlNodeType)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As DifferenceType, _
ByVal controlNodeType As XmlNodeType, _
ByVal testNodeType As XmlNodeType _
)
C#
public Difference(
DifferenceType id,
XmlNodeType controlNodeType,
XmlNodeType testNodeType
)
C++
public:
Difference(
DifferenceType id,
XmlNodeType controlNodeType,
XmlNodeType testNodeType
) sealed
J#
public Difference(
DifferenceType id,
XmlNodeType controlNodeType,
XmlNodeType testNodeType
)
JScript
public function Difference(
id : DifferenceType,
controlNodeType : XmlNodeType,
testNodeType : XmlNodeType
)

See Also

Difference Class
MbUnit.Framework.Xml Namespace
Difference Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Properties

Difference Properties
[image]

Public Properties

 | Name | Description
Public property | ControlNodeType |
Public property | Id |
Public property | MajorDifference |
Public property | TestNodeType |
Top

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ControlNodeType Property

Difference.ControlNodeType Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlNodeType As XmlNodeType
C#
public XmlNodeType ControlNodeType { get; }
C++
public property XmlNodeType ControlNodeType sealed {
XmlNodeType get();
}
J#
/** property */
public XmlNodeType get_ControlNodeType();
JScript
public function get ControlNodeType() : XmlNodeType

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Id Property

Difference.Id Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As DifferenceType
C#
public DifferenceType Id { get; }
C++
public property DifferenceType Id sealed {
DifferenceType get();
}
J#
/** property */
public DifferenceType get_Id();
JScript
public function get Id() : DifferenceType

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


MajorDifference Property

Difference.MajorDifference Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MajorDifference As Boolean
C#
public bool MajorDifference { get; }
C++
public property bool MajorDifference sealed {
bool get();
}
J#
/** property */
public bool get_MajorDifference();
JScript
public function get MajorDifference() : bool

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


TestNodeType Property

Difference.TestNodeType Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TestNodeType As XmlNodeType
C#
public XmlNodeType TestNodeType { get; }
C++
public property XmlNodeType TestNodeType sealed {
XmlNodeType get();
}
J#
/** property */
public XmlNodeType get_TestNodeType();
JScript
public function get TestNodeType() : XmlNodeType

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

Difference Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ToString Method

Difference.ToString Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

Difference Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Differences Class

Differences Class
See Also Example Members
[image]

Utilities for manipulating differences. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Module Differences
C#
public static class Differences
C++
ref class Differences abstract sealed
J#
public final class Differences
JScript
public class Differences

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.Differences

See Also

Differences Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Differences Members

Differences Members
See Also Example Methods
[image]

Utilities for manipulating differences. This is a static class (Module in Visual Basic)static classModule and so cannot be inherited or instantiated.

The following tables list the members exposed by Differences.

Public Methods

Name | Description
IsMajorDifference | Returns true is a difference is considered significant.
Top

See Also

Differences Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

Differences Methods
[image]

Public Methods

Name | Description
IsMajorDifference | Returns true is a difference is considered significant.
Top

See Also

Differences Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsMajorDifference Method

Differences.IsMajorDifference Method
[image]

Returns true is a difference is considered significant.

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsMajorDifference( _
ByVal differenceType As DifferenceType _
) As Boolean
C#
public static bool IsMajorDifference(
DifferenceType differenceType
)
C++
public:
static bool IsMajorDifference(
DifferenceType differenceType
)
J#
public static bool IsMajorDifference(
DifferenceType differenceType
)
JScript
public static function IsMajorDifference(
differenceType : DifferenceType
) : bool

See Also

Differences Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DifferenceType Enumeration

DifferenceType Enumeration
[image]

Describes the type of difference found.

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Enum DifferenceType
C#
public enum DifferenceType
C++
public enum class DifferenceType
J#
public enum DifferenceType
JScript
public enum DifferenceType

Members

Member Name | Description
AttributeValueExplicitlySpecified | Comparing an implied attribute value against an explicit value
AttributeNameNotFound | Comparing 2 elements and one has an attribute the other does not
AttributeValue | Comparing 2 attributes with the same name but different values
AttributeSequence | Comparing 2 attribute lists with the same attributes in different sequence
CDATAValue | Comparing 2 CDATA sections with different values
CommentValue | Comparing 2 comments with different values
DOCTYPE_NAME_ID | Comparing 2 document types with different names
DocTypePublicID | Comparing 2 document types with different public identifiers
DocTypeSystemID | Comparing 2 document types with different system identifiers
ElementTagName | Comparing 2 elements with different tag names
ELEMENT_NUM_ATTRIBUTES_ID | Comparing 2 elements with different number of attributes
PROCESSING_INSTRUCTION_TARGET_ID | Comparing 2 processing instructions with different targets
PROCESSING_INSTRUCTION_DATA_ID | Comparing 2 processing instructions with different instructions
TEXT_VALUE_ID | Comparing 2 different text values
NAMESPACE_PREFIX_ID | Comparing 2 nodes with different namespace prefixes
NAMESPACE_URI_ID | Comparing 2 nodes with different namespace URIs
NODE_TYPE_ID | Comparing 2 nodes with different node types
HAS_CHILD_NODES_ID | Comparing 2 nodes but only one has any children
CHILD_NODELIST_LENGTH_ID | Comparing 2 nodes with different numbers of children
CHILD_NODELIST_SEQUENCE_ID | Comparing 2 nodes with children whose nodes are in different sequence
HAS_DOCTYPE_DECLARATION_ID | Comparing 2 Documents only one of which has a doctype
HAS_XML_DECLARATION_PREFIX_ID | Comparing 2 Documents only one of which has an XML Prefix Declaration

See Also

MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffResult Class

DiffResult Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class DiffResult
C#
public class DiffResult
C++
ref class DiffResult
J#
public class DiffResult
JScript
public class DiffResult

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.DiffResult

See Also

DiffResult Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffResult Members

DiffResult Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DiffResult.

Public Constructors

 | Name | Description
Public method | DiffResult | Initializes a new instance of the DiffResult class.
Top

Public Properties

 | Name | Description
Public property | Difference |
Public property | Equal |
Public property | Identical |
Public property | StringValue |
Top

Public Methods

 | Name | Description
Public method | DifferenceFound |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DiffResult Constructor

DiffResult Constructor
[image]

Initializes a new instance of the DiffResult class.

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DiffResult()
C++
public:
DiffResult() sealed
J#
public DiffResult()
JScript
public function DiffResult()

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Properties

DiffResult Properties
[image]

Public Properties

 | Name | Description
Public property | Difference |
Public property | Equal |
Public property | Identical |
Public property | StringValue |
Top

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Difference Property

DiffResult.Difference Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Difference As Difference
C#
public Difference Difference { get; }
C++
public property Difference Difference sealed {
Difference get();
}
J#
/** property */
public Difference get_Difference();
JScript
public function get Difference() : Difference

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Equal Property

DiffResult.Equal Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Equal As Boolean
C#
public bool Equal { get; }
C++
public property bool Equal sealed {
bool get();
}
J#
/** property */
public bool get_Equal();
JScript
public function get Equal() : bool

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Identical Property

DiffResult.Identical Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Identical As Boolean
C#
public bool Identical { get; }
C++
public property bool Identical sealed {
bool get();
}
J#
/** property */
public bool get_Identical();
JScript
public function get Identical() : bool

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


StringValue Property

DiffResult.StringValue Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StringValue As String
C#
public string StringValue { get; }
C++
public property string StringValue sealed {
String get();
}
J#
/** property */
public string get_StringValue();
JScript
public function get StringValue() : String

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

DiffResult Methods
[image]

Public Methods

 | Name | Description
Public method | DifferenceFound |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


DifferenceFound Method

DiffResult.DifferenceFound Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub DifferenceFound( _
ByVal inDiff As XmlDiff, _
ByVal difference As Difference _
)
C#
public void DifferenceFound(
XmlDiff inDiff,
Difference difference
)
C++
public:
void DifferenceFound(
XmlDiff inDiff,
Difference difference
) sealed
J#
public void DifferenceFound(
XmlDiff inDiff,
Difference difference
)
JScript
public function DifferenceFound(
inDiff : XmlDiff,
difference : Difference
)

See Also

DiffResult Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Validator Class

Validator Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class Validator
C#
public class Validator
C++
ref class Validator
J#
public class Validator
JScript
public class Validator

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.Validator

See Also

Validator Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Validator Members

Validator Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Validator.

Public Constructors

 | Name | Description
Public method | Validator |
Top

Public Properties

 | Name | Description
Public property | IsValid |
Public property | ValidationMessage |
Top

Public Methods

 | Name | Description
Public method | AddValidationEventHandler |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ValidationFailed |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Validator Constructor

Validator Constructor
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal input As XmlInput _
)
C#
public Validator(
XmlInput input
)
C++
public:
Validator(
XmlInput input
) sealed
J#
public Validator(
XmlInput input
)
JScript
public function Validator(
input : XmlInput
)

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Properties

Validator Properties
[image]

Public Properties

 | Name | Description
Public property | IsValid |
Public property | ValidationMessage |
Top

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


IsValid Property

Validator.IsValid Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid { get; }
C++
public property bool IsValid sealed {
bool get();
}
J#
/** property */
public bool get_IsValid();
JScript
public function get IsValid() : bool

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ValidationMessage Property

Validator.ValidationMessage Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValidationMessage As String
C#
public string ValidationMessage { get; }
C++
public property string ValidationMessage sealed {
String get();
}
J#
/** property */
public string get_ValidationMessage();
JScript
public function get ValidationMessage() : String

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

Validator Methods
[image]

Public Methods

 | Name | Description
Public method | AddValidationEventHandler |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | ValidationFailed |
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AddValidationEventHandler Method

Validator.AddValidationEventHandler Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddValidationEventHandler( _
ByVal handler As ValidationEventHandler _
)
C#
public void AddValidationEventHandler(
ValidationEventHandler handler
)
C++
public:
void AddValidationEventHandler(
ValidationEventHandler handler
) sealed
J#
public void AddValidationEventHandler(
ValidationEventHandler handler
)
JScript
public function AddValidationEventHandler(
handler : ValidationEventHandler
)

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


ValidationFailed Method

Validator.ValidationFailed Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub ValidationFailed( _
ByVal sender As Object, _
ByVal e As ValidationEventArgs _
)
C#
public void ValidationFailed(
object sender,
ValidationEventArgs e
)
C++
public:
void ValidationFailed(
Object sender,
ValidationEventArgs e
) sealed
J#
public void ValidationFailed(
object sender,
ValidationEventArgs e
)
JScript
public function ValidationFailed(
sender : Object,
e : ValidationEventArgs
)

See Also

Validator Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Class

XmlDiff Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlDiff
C#
public class XmlDiff
C++
ref class XmlDiff
J#
public class XmlDiff
JScript
public class XmlDiff

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.XmlDiff

See Also

XmlDiff Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Members

XmlDiff Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by XmlDiff.

Public Constructors

Name | Description
XmlDiff | Overloaded.
Top

Public Properties

 | Name | Description
Public property | OptionalDescription |
Top

Public Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
XmlDiff | Overloaded.
Top

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Constructor

XmlDiff Constructor

Overload List

 | Name | Description
Public method | XmlDiff (XmlInput, XmlInput) |
Public method | XmlDiff (XmlInput, XmlInput, DiffConfiguration) |
Public method | XmlDiff (TextReader, TextReader) |
Public method | XmlDiff (String, String) |

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Constructor (XmlInput, XmlInput)

XmlDiff Constructor (XmlInput, XmlInput)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal control As XmlInput, _
ByVal test As XmlInput _
)
C#
public XmlDiff(
XmlInput control,
XmlInput test
)
C++
public:
XmlDiff(
XmlInput control,
XmlInput test
) sealed
J#
public XmlDiff(
XmlInput control,
XmlInput test
)
JScript
public function XmlDiff(
control : XmlInput,
test : XmlInput
)

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace
XmlDiff Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Constructor (XmlInput, XmlInput, DiffConfiguration)

XmlDiff Constructor (XmlInput, XmlInput, DiffConfiguration)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal control As XmlInput, _
ByVal test As XmlInput, _
ByVal diffConfiguration As DiffConfiguration _
)
C#
public XmlDiff(
XmlInput control,
XmlInput test,
DiffConfiguration diffConfiguration
)
C++
public:
XmlDiff(
XmlInput control,
XmlInput test,
DiffConfiguration diffConfiguration
) sealed
J#
public XmlDiff(
XmlInput control,
XmlInput test,
DiffConfiguration diffConfiguration
)
JScript
public function XmlDiff(
control : XmlInput,
test : XmlInput,
diffConfiguration : DiffConfiguration
)

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace
XmlDiff Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Constructor (TextReader, TextReader)

XmlDiff Constructor (TextReader, TextReader)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal control As TextReader, _
ByVal test As TextReader _
)
C#
public XmlDiff(
TextReader control,
TextReader test
)
C++
public:
XmlDiff(
TextReader control,
TextReader test
) sealed
J#
public XmlDiff(
TextReader control,
TextReader test
)
JScript
public function XmlDiff(
control : TextReader,
test : TextReader
)

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace
XmlDiff Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlDiff Constructor (String, String)

XmlDiff Constructor (String, String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal control As String, _
ByVal test As String _
)
C#
public XmlDiff(
string control,
string test
)
C++
public:
XmlDiff(
String control,
String test
) sealed
J#
public XmlDiff(
string control,
string test
)
JScript
public function XmlDiff(
control : String,
test : String
)

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace
XmlDiff Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Properties

XmlDiff Properties
[image]

Public Properties

 | Name | Description
Public property | OptionalDescription |
Top

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


OptionalDescription Property

XmlDiff.OptionalDescription Property
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionalDescription As String
C#
public string OptionalDescription { get; }
C++
public property string OptionalDescription sealed {
String get();
}
J#
/** property */
public string get_OptionalDescription();
JScript
public function get OptionalDescription() : String

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

XmlDiff Methods
[image]

Public Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Compare Method

XmlDiff.Compare Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function Compare() As DiffResult
C#
public DiffResult Compare()
C++
public:
DiffResult Compare() sealed
J#
public DiffResult Compare()
JScript
public function Compare() : DiffResult

See Also

XmlDiff Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Class

XmlInput Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlInput
C#
public class XmlInput
C++
ref class XmlInput
J#
public class XmlInput
JScript
public class XmlInput

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.XmlInput

See Also

XmlInput Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Members

XmlInput Members
See Also Example Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by XmlInput.

Public Constructors

Name | Description
XmlInput | Overloaded.
Top

Public Methods

 | Name | Description
Public method | CreateXmlReader |
Public method | Equals | Overridden.
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
XmlInput | Overloaded.
Top

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor

XmlInput Constructor

Overload List

 | Name | Description
Public method | XmlInput (Stream) |
Public method | XmlInput (Stream, String) |
Public method | XmlInput (TextReader) |
Public method | XmlInput (TextReader, String) |
Public method | XmlInput (String) |
Public method | XmlInput (String, String) |
Public method | XmlInput (XmlReader) |

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (Stream)

XmlInput Constructor (Stream)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As Stream _
)
C#
public XmlInput(
Stream someXml
)
C++
public:
XmlInput(
Stream someXml
) sealed
J#
public XmlInput(
Stream someXml
)
JScript
public function XmlInput(
someXml : Stream
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (Stream, String)

XmlInput Constructor (Stream, String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As Stream, _
ByVal baseURI As String _
)
C#
public XmlInput(
Stream someXml,
string baseURI
)
C++
public:
XmlInput(
Stream someXml,
String baseURI
) sealed
J#
public XmlInput(
Stream someXml,
string baseURI
)
JScript
public function XmlInput(
someXml : Stream,
baseURI : String
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (TextReader)

XmlInput Constructor (TextReader)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As TextReader _
)
C#
public XmlInput(
TextReader someXml
)
C++
public:
XmlInput(
TextReader someXml
) sealed
J#
public XmlInput(
TextReader someXml
)
JScript
public function XmlInput(
someXml : TextReader
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (TextReader, String)

XmlInput Constructor (TextReader, String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As TextReader, _
ByVal baseURI As String _
)
C#
public XmlInput(
TextReader someXml,
string baseURI
)
C++
public:
XmlInput(
TextReader someXml,
String baseURI
) sealed
J#
public XmlInput(
TextReader someXml,
string baseURI
)
JScript
public function XmlInput(
someXml : TextReader,
baseURI : String
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (String)

XmlInput Constructor (String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As String _
)
C#
public XmlInput(
string someXml
)
C++
public:
XmlInput(
String someXml
) sealed
J#
public XmlInput(
string someXml
)
JScript
public function XmlInput(
someXml : String
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (String, String)

XmlInput Constructor (String, String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As String, _
ByVal baseURI As String _
)
C#
public XmlInput(
string someXml,
string baseURI
)
C++
public:
XmlInput(
String someXml,
String baseURI
) sealed
J#
public XmlInput(
string someXml,
string baseURI
)
JScript
public function XmlInput(
someXml : String,
baseURI : String
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlInput Constructor (XmlReader)

XmlInput Constructor (XmlReader)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal someXml As XmlReader _
)
C#
public XmlInput(
XmlReader someXml
)
C++
public:
XmlInput(
XmlReader someXml
) sealed
J#
public XmlInput(
XmlReader someXml
)
JScript
public function XmlInput(
someXml : XmlReader
)

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace
XmlInput Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

XmlInput Methods
[image]

Public Methods

 | Name | Description
Public method | CreateXmlReader |
Public method | Equals | Overridden.
Public method | GetHashCode | Overridden.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


CreateXmlReader Method

XmlInput.CreateXmlReader Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateXmlReader() As XmlReader
C#
public XmlReader CreateXmlReader()
C++
public:
XmlReader CreateXmlReader() sealed
J#
public XmlReader CreateXmlReader()
JScript
public function CreateXmlReader() : XmlReader

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Equals Method

XmlInput.Equals Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
ByVal other As Object _
) As Boolean
C#
public override bool Equals(
object other
)
C++
public:
virtual bool Equals(
Object other
) override
J#
public override bool Equals(
object other
)
JScript
public override function Equals(
other : Object
) : bool

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


GetHashCode Method

XmlInput.GetHashCode Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()
C++
public:
virtual int GetHashCode() override
J#
public override int GetHashCode()
JScript
public override function GetHashCode() : int

See Also

XmlInput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlOutput Class

XmlOutput Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlOutput
C#
public class XmlOutput
C++
ref class XmlOutput
J#
public class XmlOutput
JScript
public class XmlOutput

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.XmlOutput

See Also

XmlOutput Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XmlOutput Members

XmlOutput Members
See Also Example Methods
[image]

The following tables list the members exposed by XmlOutput.

Public Methods

 | Name | Description
Public method | AsString |
Public method | AsXml |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

XmlOutput Methods
[image]

Public Methods

 | Name | Description
Public method | AsString |
Public method | AsXml |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AsString Method

XmlOutput.AsString Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function AsString() As String
C#
public string AsString()
C++
public:
String AsString() sealed
J#
public string AsString()
JScript
public function AsString() : String

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


AsXml Method

XmlOutput.AsXml Method
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function AsXml() As XmlInput
C#
public XmlInput AsXml()
C++
public:
XmlInput AsXml() sealed
J#
public XmlInput AsXml()
JScript
public function AsXml() : XmlInput

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Write Method

XmlOutput.Write Method

Overload List

 | Name | Description
Public method | Write (Stream) |
Public method | Write (TextWriter) |
Public method | Write (XmlWriter) |

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Write Method (Stream)

XmlOutput.Write Method (Stream)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal viaStream As Stream _
)
C#
public void Write(
Stream viaStream
)
C++
public:
void Write(
Stream viaStream
) sealed
J#
public void Write(
Stream viaStream
)
JScript
public function Write(
viaStream : Stream
)

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace
XmlOutput.Write Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Write Method (TextWriter)

XmlOutput.Write Method (TextWriter)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal viaTextWriter As TextWriter _
)
C#
public void Write(
TextWriter viaTextWriter
)
C++
public:
void Write(
TextWriter viaTextWriter
) sealed
J#
public void Write(
TextWriter viaTextWriter
)
JScript
public function Write(
viaTextWriter : TextWriter
)

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace
XmlOutput.Write Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Write Method (XmlWriter)

XmlOutput.Write Method (XmlWriter)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal viaXmlWriter As XmlWriter _
)
C#
public void Write(
XmlWriter viaXmlWriter
)
C++
public:
void Write(
XmlWriter viaXmlWriter
) sealed
J#
public void Write(
XmlWriter viaXmlWriter
)
JScript
public function Write(
viaXmlWriter : XmlWriter
)

See Also

XmlOutput Class
MbUnit.Framework.Xml Namespace
XmlOutput.Write Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPath Class

XPath Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class XPath
C#
public class XPath
C++
ref class XPath
J#
public class XPath
JScript
public class XPath

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.XPath

See Also

XPath Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPath Members

XPath Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by XPath.

Public Constructors

 | Name | Description
Public method | XPath |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | EvaluateXPath | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | XPathExists | Overloaded.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XPath Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPath Constructor

XPath Constructor
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal anXPathExpression As String _
)
C#
public XPath(
string anXPathExpression
)
C++
public:
XPath(
String anXPathExpression
) sealed
J#
public XPath(
string anXPathExpression
)
JScript
public function XPath(
anXPathExpression : String
)

See Also

XPath Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

XPath Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | EvaluateXPath | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | XPathExists | Overloaded.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

XPath Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


EvaluateXPath Method

XPath.EvaluateXPath Method

Overload List

 | Name | Description
Public method | EvaluateXPath (XmlInput) |
Public method | EvaluateXPath (String) |

See Also

XPath Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


EvaluateXPath Method (XmlInput)

XPath.EvaluateXPath Method (XmlInput)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function EvaluateXPath( _
ByVal forXmlInput As XmlInput _
) As String
C#
public string EvaluateXPath(
XmlInput forXmlInput
)
C++
public:
String EvaluateXPath(
XmlInput forXmlInput
) sealed
J#
public string EvaluateXPath(
XmlInput forXmlInput
)
JScript
public function EvaluateXPath(
forXmlInput : XmlInput
) : String

See Also

XPath Class
MbUnit.Framework.Xml Namespace
XPath.EvaluateXPath Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


EvaluateXPath Method (String)

XPath.EvaluateXPath Method (String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function EvaluateXPath( _
ByVal forSomeXml As String _
) As String
C#
public string EvaluateXPath(
string forSomeXml
)
C++
public:
String EvaluateXPath(
String forSomeXml
) sealed
J#
public string EvaluateXPath(
string forSomeXml
)
JScript
public function EvaluateXPath(
forSomeXml : String
) : String

See Also

XPath Class
MbUnit.Framework.Xml Namespace
XPath.EvaluateXPath Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method

XPath.XPathExists Method

Overload List

 | Name | Description
Public method | XPathExists (XmlInput) |
Public method | XPathExists (String) |

See Also

XPath Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method (XmlInput)

XPath.XPathExists Method (XmlInput)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function XPathExists( _
ByVal forInput As XmlInput _
) As Boolean
C#
public bool XPathExists(
XmlInput forInput
)
C++
public:
bool XPathExists(
XmlInput forInput
) sealed
J#
public bool XPathExists(
XmlInput forInput
)
JScript
public function XPathExists(
forInput : XmlInput
) : bool

See Also

XPath Class
MbUnit.Framework.Xml Namespace
XPath.XPathExists Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


XPathExists Method (String)

XPath.XPathExists Method (String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function XPathExists( _
ByVal forSomeXml As String _
) As Boolean
C#
public bool XPathExists(
string forSomeXml
)
C++
public:
bool XPathExists(
String forSomeXml
) sealed
J#
public bool XPathExists(
string forSomeXml
)
JScript
public function XPathExists(
forSomeXml : String
) : bool

See Also

XPath Class
MbUnit.Framework.Xml Namespace
XPath.XPathExists Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Class

Xslt Class
See Also Example Members
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Class Xslt
C#
public class Xslt
C++
ref class Xslt
J#
public class Xslt
JScript
public class Xslt

Inheritance Hierarchy

System.Object
MbUnit.Framework.Xml.Xslt

See Also

Xslt Members
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Members

Xslt Members
See Also Example Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Xslt.

Public Constructors

Name | Description
Xslt | Overloaded.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Transform | Overloaded.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Xslt | Overloaded.
Top

See Also

Xslt Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Constructor

Xslt Constructor

Overload List

 | Name | Description
Public method | Xslt (XmlInput) |
Public method | Xslt (XmlInput, XmlResolver, Evidence) |
Public method | Xslt (String) |
Public method | Xslt (String, String) |

See Also

Xslt Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Constructor (XmlInput)

Xslt Constructor (XmlInput)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal xsltInput As XmlInput _
)
C#
public Xslt(
XmlInput xsltInput
)
C++
public:
Xslt(
XmlInput xsltInput
) sealed
J#
public Xslt(
XmlInput xsltInput
)
JScript
public function Xslt(
xsltInput : XmlInput
)

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Constructor (XmlInput, XmlResolver, Evidence)

Xslt Constructor (XmlInput, XmlResolver, Evidence)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal xsltInput As XmlInput, _
ByVal xsltResolver As XmlResolver, _
ByVal evidence As Evidence _
)
C#
public Xslt(
XmlInput xsltInput,
XmlResolver xsltResolver,
Evidence evidence
)
C++
public:
Xslt(
XmlInput xsltInput,
XmlResolver xsltResolver,
Evidence evidence
) sealed
J#
public Xslt(
XmlInput xsltInput,
XmlResolver xsltResolver,
Evidence evidence
)
JScript
public function Xslt(
xsltInput : XmlInput,
xsltResolver : XmlResolver,
evidence : Evidence
)

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Constructor (String)

Xslt Constructor (String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal xslt As String _
)
C#
public Xslt(
string xslt
)
C++
public:
Xslt(
String xslt
) sealed
J#
public Xslt(
string xslt
)
JScript
public function Xslt(
xslt : String
)

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Xslt Constructor (String, String)

Xslt Constructor (String, String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal xslt As String, _
ByVal baseURI As String _
)
C#
public Xslt(
string xslt,
string baseURI
)
C++
public:
Xslt(
String xslt,
String baseURI
) sealed
J#
public Xslt(
string xslt,
string baseURI
)
JScript
public function Xslt(
xslt : String,
baseURI : String
)

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt Constructor Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Methods

Xslt Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Transform | Overloaded.
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

Xslt Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Transform Method

Xslt.Transform Method

Overload List

 | Name | Description
Public method | Transform (XmlInput) |
Public method | Transform (XmlInput, XsltArgumentList) |
Public method | Transform (String) |
Public method | Transform (XmlReader, XmlResolver, XsltArgumentList) |

See Also

Xslt Class
MbUnit.Framework.Xml Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Transform Method (XmlInput)

Xslt.Transform Method (XmlInput)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function Transform( _
ByVal someXml As XmlInput _
) As XmlOutput
C#
public XmlOutput Transform(
XmlInput someXml
)
C++
public:
XmlOutput Transform(
XmlInput someXml
) sealed
J#
public XmlOutput Transform(
XmlInput someXml
)
JScript
public function Transform(
someXml : XmlInput
) : XmlOutput

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt.Transform Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Transform Method (XmlInput, XsltArgumentList)

Xslt.Transform Method (XmlInput, XsltArgumentList)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function Transform( _
ByVal someXml As XmlInput, _
ByVal xsltArgs As XsltArgumentList _
) As XmlOutput
C#
public XmlOutput Transform(
XmlInput someXml,
XsltArgumentList xsltArgs
)
C++
public:
XmlOutput Transform(
XmlInput someXml,
XsltArgumentList xsltArgs
) sealed
J#
public XmlOutput Transform(
XmlInput someXml,
XsltArgumentList xsltArgs
)
JScript
public function Transform(
someXml : XmlInput,
xsltArgs : XsltArgumentList
) : XmlOutput

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt.Transform Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Transform Method (String)

Xslt.Transform Method (String)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function Transform( _
ByVal someXml As String _
) As XmlOutput
C#
public XmlOutput Transform(
string someXml
)
C++
public:
XmlOutput Transform(
String someXml
) sealed
J#
public XmlOutput Transform(
string someXml
)
JScript
public function Transform(
someXml : String
) : XmlOutput

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt.Transform Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Transform Method (XmlReader, XmlResolver, XsltArgumentList)

Xslt.Transform Method (XmlReader, XmlResolver, XsltArgumentList)
See Also Example
[image]

Namespace: MbUnit.Framework.Xml
Assembly: MbUnit.Compatibility (in MbUnit.Compatibility.dll)

Syntax

Visual Basic (Declaration)
Public Function Transform( _
ByVal xmlTransformed As XmlReader, _
ByVal resolverForXmlTransformed As XmlResolver, _
ByVal xsltArgs As XsltArgumentList _
) As XmlOutput
C#
public XmlOutput Transform(
XmlReader xmlTransformed,
XmlResolver resolverForXmlTransformed,
XsltArgumentList xsltArgs
)
C++
public:
XmlOutput Transform(
XmlReader xmlTransformed,
XmlResolver resolverForXmlTransformed,
XsltArgumentList xsltArgs
) sealed
J#
public XmlOutput Transform(
XmlReader xmlTransformed,
XmlResolver resolverForXmlTransformed,
XsltArgumentList xsltArgs
)
JScript
public function Transform(
xmlTransformed : XmlReader,
resolverForXmlTransformed : XmlResolver,
xsltArgs : XsltArgumentList
) : XmlOutput

See Also

Xslt Class
MbUnit.Framework.Xml Namespace
Xslt.Transform Overload List

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

Copyright 2005-2009 Gallio Project - http://www.gallio.org/

Generated from assembly MbUnit.Compatibility [3.0.6.0]


Gallio Hierarchy

Gallio Hierarchy
System.Object
Gallio.ActionChain<T>
Gallio.ActionChain<T1,T2>
Gallio.FuncChain<T,TResult>
Gallio.ICloneable<T> ---- System.ICloneable
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Gallio.Action
Gallio.Action<T1,T2>
Gallio.Action<T1,T2,T3>
Gallio.Action<T1,T2,T3,T4>
Gallio.ActionDecorator<T>
Gallio.ActionDecorator<T1,T2>
Gallio.Func<TResult>
Gallio.Func<T1,TResult>
Gallio.Func<T1,T2,TResult>
Gallio.Func<T1,T2,T3,TResult>
Gallio.Func<T1,T2,T3,T4,TResult>
Gallio.FuncDecorator<T,TResult>
System.ValueType
Gallio.Pair<TFirst,TSecond>
Gallio.Triple<TFirst,TSecond,TThird>

See Also

Gallio Namespace


Gallio.Ambience Hierarchy

Gallio.Ambience Hierarchy
System.Object
Gallio.Ambience.AmbienceClient ---- System.IDisposable
Gallio.Ambience.AmbienceClientConfiguration
Gallio.Ambience.AmbienceSectionHandler ---- System.Configuration.IConfigurationSectionHandler
Gallio.Ambience.AmbienceServer ---- System.IDisposable
Gallio.Ambience.AmbienceServerConfiguration
Gallio.Ambience.Ambient
Gallio.Ambience.AmbientDataContainerExtensions
Gallio.Ambience.AmbientDataQueryExtensions
Gallio.Ambience.IAmbientDataContainer
Gallio.Ambience.IAmbientDataQuery<T> ---- System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
Gallio.Ambience.IAmbientDataSet<T> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IEnumerable<T>, System.Collections.Generic.IList<T>, System.Collections.IEnumerable
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Ambience.AmbienceException

See Also

Gallio.Ambience Namespace


Gallio.Collections Hierarchy

Gallio.Collections Hierarchy
System.Object
Gallio.Collections.ArrayEqualityComparer<T> ---- System.Collections.Generic.IEqualityComparer<T>
Gallio.Collections.CollectionUtils
Gallio.Collections.CovariantList<TInput,TOutput> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IEnumerable<T>, System.Collections.Generic.IList<T>, System.Collections.IEnumerable
Gallio.Collections.EmptyArray<T>
Gallio.Collections.EmptyDictionary<TKey,TValue> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
Gallio.Collections.GenericUtils
Gallio.Collections.HashSet<T> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
Gallio.Collections.IMultiMap<TKey,TValue> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
Gallio.Collections.LazyCache<TKey,TValue>
Gallio.Collections.MultiMap<TKey,TValue> ---- Gallio.Collections.IMultiMap<TKey,TValue>, System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
Gallio.Collections.PropertyBag ---- Gallio.Collections.IMultiMap<TKey,TValue>, System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable, System.IEquatable<T>, System.Xml.Serialization.IXmlSerializable
Gallio.Collections.PropertySet ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable, System.IEquatable<T>, System.Xml.Serialization.IXmlSerializable
Gallio.Collections.ReadOnlyDictionary<TKey,TValue> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
Gallio.Collections.ReferentialEqualityComparer<T> ---- System.Collections.Generic.IEqualityComparer<T>
Gallio.Collections.TreeUtils
Gallio.Collections.UserDataCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Gallio.Collections.TreeUtils.ChildEnumerator<T>
System.ValueType
Gallio.Collections.Key<TValue>

See Also

Gallio.Collections Namespace


Gallio.Concurrency Hierarchy

Gallio.Concurrency Hierarchy
System.Object
Gallio.Concurrency.Task
Gallio.Concurrency.ProcessTask
Gallio.Concurrency.ThreadTask
Gallio.Concurrency.TaskContainer
Gallio.Concurrency.TaskResult
Gallio.Concurrency.ThreadAbortScope
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Gallio.Concurrency.ReadAction<T>
Gallio.Concurrency.WriteAction<T>
System.EventArgs
Gallio.Concurrency.TaskEventArgs
System.ValueType
Gallio.Concurrency.LockBox<T>

See Also

Gallio.Concurrency Namespace


Gallio.Framework Hierarchy

Gallio.Framework Hierarchy
System.Object
Gallio.Framework.ComparisonSemantics
Gallio.Framework.DiagnosticLog
Gallio.Framework.Sandbox ---- System.IDisposable
Gallio.Framework.Tasks
Gallio.Framework.TestContext
Gallio.Framework.TestLog
Gallio.Framework.TestStep
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Framework.TestException
Gallio.Framework.TestFailedException
Gallio.Framework.TestInconclusiveException
Gallio.Framework.TestTerminatedException
Gallio.Framework.SilentTestException
System.ValueType
Gallio.Framework.TestContextCookie ---- System.IDisposable

See Also

Gallio.Framework Namespace


Gallio.Framework.Assertions Hierarchy

Gallio.Framework.Assertions Hierarchy
System.Object
Gallio.Framework.Assertions.AssertionConditionEvaluator
Gallio.Framework.Assertions.AssertionContext
Gallio.Framework.Assertions.AssertionFailure ---- Gallio.Model.Logging.ITestLogStreamWritable
Gallio.Framework.Assertions.AssertionFailureBuilder
Gallio.Framework.Assertions.AssertionHelper
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Framework.TestException
Gallio.Framework.TestFailedException
Gallio.Framework.Assertions.AssertionException
Gallio.Framework.Assertions.AssertionFailureException
System.ValueType
Gallio.Framework.Assertions.AssertionFailure.LabeledValue
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Framework.Assertions.AssertionFailureBehavior

See Also

Gallio.Framework.Assertions Namespace


Gallio.Framework.Conversions Hierarchy

Gallio.Framework.Conversions Hierarchy
System.Object
Gallio.Framework.Conversions.ArrayToArrayConversionRule ---- Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.BaseConverter ---- Gallio.Framework.Conversions.IConverter
Gallio.Framework.Conversions.NullConverter
Gallio.Framework.Conversions.RuleBasedConverter
Gallio.Framework.Conversions.Converter
Gallio.Framework.Conversions.ConvertibleToConvertibleConversionRule ---- Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.IConverter
Gallio.Framework.Conversions.ObjectToStringConversionRule ---- Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.StringToXmlDocumentConversionRule ---- Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.XPathNavigableToXPathNavigatorConversionRule ---- Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.XPathNavigatorToStringConversionRule ---- Gallio.Framework.Conversions.IConversionRule
Gallio.Framework.Conversions.XPathNavigatorToXmlSerializableTypeConversionRule ---- Gallio.Framework.Conversions.IConversionRule
System.ValueType
Gallio.Framework.Conversions.ConversionCost ---- System.IComparable<T>

See Also

Gallio.Framework.Conversions Namespace


Gallio.Framework.Data Hierarchy

Gallio.Framework.Data Hierarchy
System.Object
Gallio.Framework.Data.BaseDataAccessor ---- Gallio.Framework.Data.IDataAccessor
Gallio.Framework.Data.BoundDataAccessor
Gallio.Framework.Data.ConstantDataAccessor
Gallio.Framework.Data.BaseDataBinder ---- Gallio.Framework.Data.IDataBinder
Gallio.Framework.Data.ObjectDataBinder
Gallio.Framework.Data.ScalarDataBinder
Gallio.Framework.Data.BaseDataItem ---- Gallio.Framework.Data.IDataItem
Gallio.Framework.Data.DataRow
Gallio.Framework.Data.NullDataItem
Gallio.Framework.Data.SimpleDataItem
Gallio.Framework.Data.ListDataItem<T>
Gallio.Framework.Data.ScalarDataItem<T>
Gallio.Framework.Data.BaseDataSet ---- Gallio.Framework.Data.IDataProvider, Gallio.Framework.Data.IDataSet
Gallio.Framework.Data.AggregateDataSet
Gallio.Framework.Data.JoinedDataSet
Gallio.Framework.Data.MergedDataSet
Gallio.Framework.Data.DataSource
Gallio.Framework.Data.CsvDataSet
Gallio.Framework.Data.FactoryDataSet
Gallio.Framework.Data.ItemSequenceDataSet
Gallio.Framework.Data.ValueSequenceDataSet
Gallio.Framework.Data.XmlDataSet
Gallio.Framework.Data.CombinatorialJoinStrategy ---- Gallio.Framework.Data.IJoinStrategy
Gallio.Framework.Data.ConcatenationMergeStrategy ---- Gallio.Framework.Data.IMergeStrategy
Gallio.Framework.Data.CsvReader ---- System.IDisposable
Gallio.Framework.Data.DataBinding ---- System.IEquatable<T>
Gallio.Framework.Data.DataBindingContext
Gallio.Framework.Data.DataBindingSpec
Gallio.Framework.Data.MethodInvocationSpec
Gallio.Framework.Data.ObjectCreationSpec
Gallio.Framework.Data.DataItemUtils
Gallio.Framework.Data.DataSourceTable ---- Gallio.Framework.Data.IDataSourceResolver
Gallio.Framework.Data.Generators
Gallio.Framework.Data.IDataAccessor
Gallio.Framework.Data.IDataBinder
Gallio.Framework.Data.IDataItem
Gallio.Framework.Data.IDataProvider
Gallio.Framework.Data.IDataSet ---- Gallio.Framework.Data.IDataProvider
Gallio.Framework.Data.IDataSourceResolver
Gallio.Framework.Data.IJoinStrategy
Gallio.Framework.Data.IMergeStrategy
Gallio.Framework.Data.IntersectionMergeStrategy ---- Gallio.Framework.Data.IMergeStrategy
Gallio.Framework.Data.PairwiseJoinStrategy ---- Gallio.Framework.Data.IJoinStrategy
Gallio.Framework.Data.SequentialJoinStrategy ---- Gallio.Framework.Data.IJoinStrategy
Gallio.Framework.Data.UnionMergeStrategy ---- Gallio.Framework.Data.IMergeStrategy
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Framework.Data.DataBindingException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Framework.Data.FactoryKind

See Also

Gallio.Framework.Data Namespace


Gallio.Framework.Formatting Hierarchy

Gallio.Framework.Formatting Hierarchy
System.Object
Gallio.Framework.Formatting.BooleanFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.ByteFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.CharFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.ConvertToStringFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.DateTimeFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.DBNullFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.DecimalFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.DictionaryEntryFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.DoubleFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.EnumerableFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.ExpressionFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.Formatter
Gallio.Framework.Formatting.FormatterExtensions
Gallio.Framework.Formatting.FormattingRulePriority
Gallio.Framework.Formatting.IFormatter
Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.IntegerFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.KeyValuePairFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.RuleBasedFormatter ---- Gallio.Framework.Formatting.IFormatter
Gallio.Framework.Formatting.StubFormatter
Gallio.Framework.Formatting.SByteFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.SingleFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.StringFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.StructuralFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.TypeFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule
Gallio.Framework.Formatting.XPathNavigableFormattingRule ---- Gallio.Framework.Formatting.IFormattingRule

See Also

Gallio.Framework.Formatting Namespace


Gallio.Framework.Pattern Hierarchy

Gallio.Framework.Pattern Hierarchy
System.Object
Gallio.Framework.Pattern.BaseBuilder ---- Gallio.Framework.Pattern.ISupportDeferredActions
Gallio.Framework.Pattern.BaseTestComponentBuilder ---- Gallio.Framework.Pattern.ITestComponentBuilder
Gallio.Framework.Pattern.DefaultTestBuilder ---- Gallio.Framework.Pattern.ITestBuilder
Gallio.Framework.Pattern.DefaultTestParameterBuilder ---- Gallio.Framework.Pattern.ITestParameterBuilder
Gallio.Framework.Pattern.DefaultTestDataContextBuilder ---- Gallio.Framework.Pattern.ITestDataContextBuilder
Gallio.Framework.Pattern.DefaultTestModelBuilder ---- Gallio.Framework.Pattern.ITestModelBuilder
Gallio.Framework.Pattern.BasePattern ---- Gallio.Framework.Pattern.IPattern
Gallio.Framework.Pattern.BasePatternTestFrameworkExtension ---- Gallio.Framework.Pattern.IPatternTestFrameworkExtension
Gallio.Framework.Pattern.DeclarativePatternResolver ---- Gallio.Framework.Pattern.IPatternResolver
Gallio.Framework.Pattern.DefaultPatternEvaluator ---- Gallio.Framework.Pattern.IPatternEvaluator
Gallio.Framework.Pattern.DefaultPatternScope ---- Gallio.Framework.Pattern.IPatternScope
Gallio.Framework.Pattern.IPattern
Gallio.Framework.Pattern.IPatternEvaluator
Gallio.Framework.Pattern.IPatternResolver
Gallio.Framework.Pattern.IPatternScope
Gallio.Framework.Pattern.IPatternTestComponent ---- Gallio.Model.ITestComponent
Gallio.Framework.Pattern.IPatternTestFrameworkExtension
Gallio.Framework.Pattern.IPatternTestHandler
Gallio.Framework.Pattern.IPatternTestInstanceHandler
Gallio.Framework.Pattern.IPatternTestParameterHandler
Gallio.Framework.Pattern.ISupportDeferredActions
Gallio.Framework.Pattern.ITestBuilder ---- Gallio.Framework.Pattern.ISupportDeferredActions, Gallio.Framework.Pattern.ITestComponentBuilder
Gallio.Framework.Pattern.ITestComponentBuilder ---- Gallio.Framework.Pattern.ISupportDeferredActions
Gallio.Framework.Pattern.ITestDataContextBuilder
Gallio.Framework.Pattern.ITestModelBuilder ---- Gallio.Framework.Pattern.ISupportDeferredActions
Gallio.Framework.Pattern.ITestParameterBuilder ---- Gallio.Framework.Pattern.ISupportDeferredActions, Gallio.Framework.Pattern.ITestComponentBuilder
Gallio.Framework.Pattern.PatternAttributeTargets
Gallio.Framework.Pattern.PatternTestActions ---- Gallio.Framework.Pattern.IPatternTestHandler
Gallio.Framework.Pattern.PatternTestDataContext ---- Gallio.Framework.Data.IDataSourceResolver
Gallio.Framework.Pattern.PatternTestInstanceActions ---- Gallio.Framework.Pattern.IPatternTestInstanceHandler
Gallio.Framework.Pattern.PatternTestInstanceState
Gallio.Framework.Pattern.PatternTestParameterActions ---- Gallio.Framework.Pattern.IPatternTestParameterHandler
Gallio.Framework.Pattern.PatternTestState
Gallio.Framework.Pattern.ProcessIsolation ---- System.IDisposable
Gallio.Framework.Pattern.TestAssemblyExecutionParameters
Gallio.Framework.Pattern.ToolInfo
Gallio.Model.BaseTestComponent ---- Gallio.Model.ITestComponent
Gallio.Model.BaseTest ---- Gallio.Model.ITest
Gallio.Framework.Pattern.PatternTest ---- Gallio.Framework.Pattern.IPatternTestComponent
Gallio.Model.BaseTestParameter ---- Gallio.Model.ITestParameter
Gallio.Framework.Pattern.PatternTestParameter ---- Gallio.Framework.Pattern.IPatternTestComponent
Gallio.Model.BaseTestStep ---- Gallio.Model.ITestStep
Gallio.Framework.Pattern.PatternTestStep
Gallio.Model.BaseTestExplorer ---- Gallio.Model.ITestExplorer
Gallio.Framework.Pattern.PatternTestExplorer
Gallio.Model.BaseTestFramework ---- Gallio.Model.ITestFramework
Gallio.Framework.Pattern.PatternTestFramework
Gallio.Model.Execution.BaseTestController ---- Gallio.Model.Execution.ITestController, System.IDisposable
Gallio.Framework.Pattern.PatternTestController
System.Attribute
Gallio.Framework.Pattern.PatternAttribute ---- Gallio.Framework.Pattern.IPattern
Gallio.Framework.Pattern.AnnotationPatternAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
Gallio.Framework.Pattern.DataPatternAttribute
Gallio.Framework.Pattern.TestAssemblyDecoratorPatternAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
Gallio.Framework.Pattern.TestParameterDecoratorPatternAttribute
Gallio.Framework.Pattern.TestTypeDecoratorPatternAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
Gallio.Framework.Pattern.TestAssemblyPatternAttribute
Gallio.Framework.Pattern.TestConstructorPatternAttribute
Gallio.Framework.Pattern.TestDependencyPatternAttribute
Gallio.Framework.Pattern.TestMethodPatternAttribute
Gallio.Framework.Pattern.TestParameterPatternAttribute
Gallio.Framework.Pattern.TestTypePatternAttribute
Gallio.Framework.Pattern.TestAssemblyInitializationAttribute
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Gallio.Framework.Pattern.DeferredComponentPopulator
Gallio.Framework.Pattern.PatternTestPopulator
Gallio.Framework.Pattern.TestAction
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Framework.Pattern.PatternUsageErrorException

See Also

Gallio.Framework.Pattern Namespace


Gallio.Framework.Text Hierarchy

Gallio.Framework.Text Hierarchy
System.Object
Gallio.Framework.Text.DiffSet ---- Gallio.Model.Logging.ITestLogStreamWritable
System.ValueType
Gallio.Framework.Text.Diff ---- System.IEquatable<T>
Gallio.Framework.Text.Range ---- System.IEquatable<T>
Gallio.Framework.Text.Substring ---- System.IEquatable<T>
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Framework.Text.DiffKind
Gallio.Framework.Text.DiffStyle

See Also

Gallio.Framework.Text Namespace


Gallio.Framework.Utilities Hierarchy

Gallio.Framework.Utilities Hierarchy
System.Object
Gallio.Framework.Utilities.SampleRunner

See Also

Gallio.Framework.Utilities Namespace


Gallio.Linq Hierarchy

Gallio.Linq Hierarchy
System.Object
Gallio.Linq.ActionExtensions
Gallio.Linq.ExpressionExtensions
Gallio.Linq.ExpressionInstrumentor
Gallio.Linq.ExpressionVisitor<T>
System.ValueType
Gallio.Linq.Unit

See Also

Gallio.Linq Namespace


Gallio.Loader Hierarchy

Gallio.Loader Hierarchy
System.Object
Gallio.Loader.IGallioLoader
Gallio.Loader.IGallioRemoteEnvironment ---- System.IDisposable
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Loader.SafeException
System.MarshalByRefObject
Gallio.Loader.GallioLoader ---- Gallio.Loader.IGallioLoader

See Also

Gallio.Loader Namespace


Gallio.Model Hierarchy

Gallio.Model Hierarchy
System.Object
Gallio.Model.Annotation
Gallio.Model.BaseInfo
Gallio.Model.TestComponentInfo ---- Gallio.Model.ITestComponent
Gallio.Model.TestInfo ---- Gallio.Model.ITest
Gallio.Model.TestParameterInfo ---- Gallio.Model.ITestParameter
Gallio.Model.TestStepInfo ---- Gallio.Model.ITestStep
Gallio.Model.BaseInfoList<TModel,TInfo> ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IEnumerable<T>, System.Collections.Generic.IList<T>, System.Collections.IEnumerable
Gallio.Model.TestInfoList
Gallio.Model.TestParameterInfoList
Gallio.Model.BaseTestComponent ---- Gallio.Model.ITestComponent
Gallio.Model.BaseTest ---- Gallio.Model.ITest
Gallio.Model.RootTest
Gallio.Model.BaseTestParameter ---- Gallio.Model.ITestParameter
Gallio.Model.BaseTestStep ---- Gallio.Model.ITestStep
Gallio.Model.BaseTestExplorer ---- Gallio.Model.ITestExplorer
Gallio.Model.AggregateTestExplorer
Gallio.Model.NullTestExplorer
Gallio.Model.BaseTestFramework ---- Gallio.Model.ITestFramework
Gallio.Model.DefaultTestPackageExplorerFactory ---- Gallio.Model.ITestPackageExplorerFactory
Gallio.Model.ITest ---- Gallio.Model.ITestComponent
Gallio.Model.ITestComponent
Gallio.Model.ITestExplorer
Gallio.Model.ITestFramework
Gallio.Model.ITestPackageExplorerFactory
Gallio.Model.ITestParameter ---- Gallio.Model.ITestComponent
Gallio.Model.ITestStep ---- Gallio.Model.ITestComponent
Gallio.Model.LifecyclePhases
Gallio.Model.MetadataKeys
Gallio.Model.ModelUtils
Gallio.Model.TestDomainSetup
Gallio.Model.TestExplorationOptions
Gallio.Model.TestKinds
Gallio.Model.TestModel
Gallio.Model.TestPackage
Gallio.Model.TestPackageConfig
Gallio.Model.TestResult
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Model.ModelException
System.ValueType
Gallio.Model.TestOutcome ---- System.IEquatable<T>, System.Xml.Serialization.IXmlSerializable
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Model.AnnotationType
Gallio.Model.TestStatus

See Also

Gallio.Model Namespace


Gallio.Model.Diagnostics Hierarchy

Gallio.Model.Diagnostics Hierarchy
System.Object
Gallio.Model.Diagnostics.ExceptionData ---- Gallio.Model.Logging.ITestLogStreamWritable
Gallio.Model.Diagnostics.StackTraceData ---- Gallio.Model.Logging.ITestLogStreamWritable
Gallio.Model.Diagnostics.StackTraceFilter
System.Attribute
Gallio.Model.Diagnostics.TestEntryPointAttribute
Gallio.Model.Diagnostics.TestFrameworkInternalAttribute

See Also

Gallio.Model.Diagnostics Namespace


Gallio.Model.Execution Hierarchy

Gallio.Model.Execution Hierarchy
System.Object
Gallio.Model.Execution.BaseTestController ---- Gallio.Model.Execution.ITestController, System.IDisposable
Gallio.Model.Execution.RecursiveTestController
Gallio.Model.Execution.DefaultTestContextTracker ---- Gallio.Model.Execution.ITestContextTracker
Gallio.Model.Execution.StubTestContextTracker
Gallio.Model.Execution.DefaultTestOrderStrategy ---- System.Collections.Generic.IComparer<T>
Gallio.Model.Execution.ITestCommand
Gallio.Model.Execution.ITestContext ---- System.IDisposable
Gallio.Model.Execution.ITestContextManager
Gallio.Model.Execution.ITestContextTracker
Gallio.Model.Execution.ITestController ---- System.IDisposable
Gallio.Model.Execution.ManagedTestCommand ---- Gallio.Model.Execution.ITestCommand
Gallio.Model.Execution.ObservableTestContextManager ---- Gallio.Model.Execution.ITestContextManager
Gallio.Model.Execution.StubTestContext ---- Gallio.Model.Execution.ITestContext, System.IDisposable
Gallio.Model.Execution.TestCommandFactory
Gallio.Model.Execution.TestContextTrackerAccessor
Gallio.Model.Execution.TestExecutionOptions
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Execution.ObservableTestLogWriter

See Also

Gallio.Model.Execution Namespace


Gallio.Model.Filters Hierarchy

Gallio.Model.Filters Hierarchy
System.Object
Gallio.Model.Filters.Filter<T>
Gallio.Model.Filters.AndFilter<T>
Gallio.Model.Filters.AnyFilter<T>
Gallio.Model.Filters.EqualityFilter<T>
Gallio.Model.Filters.NoneFilter<T>
Gallio.Model.Filters.NotFilter<T>
Gallio.Model.Filters.OrFilter<T>
Gallio.Model.Filters.PropertyFilter<T>
Gallio.Model.Filters.AssemblyFilter<T>
Gallio.Model.Filters.IdFilter<T>
Gallio.Model.Filters.MemberFilter<T>
Gallio.Model.Filters.MetadataFilter<T>
Gallio.Model.Filters.NameFilter<T>
Gallio.Model.Filters.NamespaceFilter<T>
Gallio.Model.Filters.TypeFilter<T>
Gallio.Model.Filters.RegexFilter
Gallio.Model.Filters.FilterFormatter ---- Gallio.Model.Filters.IFilterVisitor
Gallio.Model.Filters.FilterParser<T>
Gallio.Model.Filters.FilterRule<T>
Gallio.Model.Filters.FilterSet<T>
Gallio.Model.Filters.FilterUtils
Gallio.Model.Filters.IFilterFactory<T>
Gallio.Model.Filters.IFilterVisitor
Gallio.Model.Filters.ModelComponentFilterFactory<T> ---- Gallio.Model.Filters.IFilterFactory<T>
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Model.Filters.FilterParseException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Model.Filters.FilterRuleType
Gallio.Model.Filters.FilterSetResult

See Also

Gallio.Model.Filters Namespace


Gallio.Model.Logging Hierarchy

Gallio.Model.Logging Hierarchy
System.Object
Gallio.Model.Logging.Attachment
Gallio.Model.Logging.BinaryAttachment ---- System.IEquatable<T>
Gallio.Model.Logging.TextAttachment ---- System.IEquatable<T>
Gallio.Model.Logging.AttachmentData
Gallio.Model.Logging.ITestLogStreamWritable
Gallio.Model.Logging.MimeTypes
Gallio.Model.Logging.StructuredTestLog
Gallio.Model.Logging.StructuredTestLogStream ---- Gallio.Model.Logging.ITestLogStreamWritable
Gallio.Model.Logging.StructuredText ---- Gallio.Model.Logging.ITestLogStreamWritable, System.IEquatable<T>
Gallio.Model.Logging.TestLogStreamNames
Gallio.Runtime.Logging.BaseLogger ---- Gallio.Runtime.Logging.ILogger
Gallio.Model.Logging.TestLogStreamLogger
System.MarshalByRefObject
Gallio.Model.Logging.TestLogWriter
Gallio.Model.Logging.FallbackTestLogWriter
Gallio.Model.Logging.NullTestLogWriter
Gallio.Model.Logging.StructuredTestLogWriter
Gallio.Model.Logging.TextualTestLogWriter
Gallio.Model.Logging.StringTestLogWriter
System.IO.TextWriter ---- System.IDisposable
Gallio.Model.Logging.TestLogStreamWriter
Gallio.Model.Logging.StructuredTextWriter ---- Gallio.Model.Logging.ITestLogStreamWritable
System.ValueType
Gallio.Model.Logging.Marker ---- System.IEquatable<T>
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Model.Logging.AttachmentContentDisposition
Gallio.Model.Logging.AttachmentEncoding

See Also

Gallio.Model.Logging Namespace


Gallio.Model.Logging.Tags Hierarchy

Gallio.Model.Logging.Tags Hierarchy
System.Object
Gallio.Model.Logging.Tags.BaseTagVisitor ---- Gallio.Model.Logging.Tags.ITagVisitor
Gallio.Model.Logging.Tags.ITagVisitor
Gallio.Model.Logging.Tags.MarkerTag.Attribute
Gallio.Model.Logging.Tags.Tag ---- Gallio.ICloneable<T>, Gallio.Model.Logging.ITestLogStreamWritable, System.ICloneable, System.IEquatable<T>
Gallio.Model.Logging.Tags.ContainerTag ---- Gallio.ICloneable<T>, System.IEquatable<T>
Gallio.Model.Logging.Tags.BodyTag ---- Gallio.ICloneable<T>, System.IEquatable<T>
Gallio.Model.Logging.Tags.MarkerTag ---- Gallio.ICloneable<T>, System.IEquatable<T>
Gallio.Model.Logging.Tags.SectionTag ---- Gallio.ICloneable<T>, System.IEquatable<T>
Gallio.Model.Logging.Tags.EmbedTag ---- Gallio.ICloneable<T>, System.IEquatable<T>
Gallio.Model.Logging.Tags.TextTag ---- Gallio.ICloneable<T>, System.IEquatable<T>, System.Xml.Serialization.IXmlSerializable
Gallio.Model.Logging.Tags.TagFormatter ---- Gallio.Model.Logging.Tags.ITagVisitor

See Also

Gallio.Model.Logging.Tags Namespace


Gallio.Model.Messages Hierarchy

Gallio.Model.Messages Hierarchy
System.Object
Gallio.Model.Messages.ITestExecutionListener
Gallio.Model.Messages.ITestExplorationListener
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Model.Messages.RemoteTestExecutionListener ---- Gallio.Model.Messages.ITestExecutionListener
Gallio.Model.Messages.RemoteTestExplorationListener ---- Gallio.Model.Messages.ITestExplorationListener

See Also

Gallio.Model.Messages Namespace


Gallio.Model.Serialization Hierarchy

Gallio.Model.Serialization Hierarchy
System.Object
Gallio.Model.Serialization.AnnotationData
Gallio.Model.Serialization.TestComponentData
Gallio.Model.Serialization.TestData
Gallio.Model.Serialization.TestPackageData
Gallio.Model.Serialization.TestParameterData
Gallio.Model.Serialization.TestStepData
Gallio.Model.Serialization.TestModelData

See Also

Gallio.Model.Serialization Namespace


Gallio.MSBuildTasks Hierarchy

Gallio.MSBuildTasks Hierarchy
System.Object
Microsoft.Build.Utilities.Task ---- Microsoft.Build.Framework.ITask
Gallio.MSBuildTasks.Gallio

See Also

Gallio.MSBuildTasks Namespace


Gallio.NAntTasks Hierarchy

Gallio.NAntTasks Hierarchy
System.Object
NAnt.Core.Element
NAnt.Core.Task
Gallio.NAntTasks.GallioTask

See Also

Gallio.NAntTasks Namespace


Gallio.Reflection Hierarchy

Gallio.Reflection Hierarchy
System.Object
Gallio.Reflection.AssemblyUtils
Gallio.Reflection.AttributeUtils
Gallio.Reflection.CodeElementSorter
Gallio.Reflection.DeclaringTypeComparer<T> ---- System.Collections.Generic.IComparer<T>
Gallio.Reflection.IAssemblyInfo ---- Gallio.Reflection.ICodeElementInfo, System.IEquatable<T>
Gallio.Reflection.IAttributeInfo
Gallio.Reflection.ICodeElementInfo ---- System.IEquatable<T>
Gallio.Reflection.IConstructorInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IFunctionInfo, Gallio.Reflection.IMemberInfo, System.IEquatable<T>
Gallio.Reflection.IEventInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, System.IEquatable<T>
Gallio.Reflection.IFieldInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.IFunctionInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, System.IEquatable<T>
Gallio.Reflection.IGenericParameterInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, Gallio.Reflection.ISlotInfo, Gallio.Reflection.ITypeInfo, System.IEquatable<T>
Gallio.Reflection.IMemberInfo ---- Gallio.Reflection.ICodeElementInfo, System.IEquatable<T>
Gallio.Reflection.IMethodInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IFunctionInfo, Gallio.Reflection.IMemberInfo, System.IEquatable<T>
Gallio.Reflection.INamespaceInfo ---- Gallio.Reflection.ICodeElementInfo, System.IEquatable<T>
Gallio.Reflection.IParameterInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.IPropertyInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.IReflectionPolicy
Gallio.Reflection.ISlotInfo ---- Gallio.Reflection.ICodeElementInfo, System.IEquatable<T>
Gallio.Reflection.ITypeInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, System.IEquatable<T>
Gallio.Reflection.ReflectionOnlyAssemblyLoader
Gallio.Reflection.ReflectionUtils
Gallio.Reflection.Reflector
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Reflection.ReflectionWrapperResolveException
System.ValueType
Gallio.Reflection.CodeLocation ---- System.IEquatable<T>, System.Runtime.Serialization.ISerializable, System.Xml.Serialization.IXmlSerializable
Gallio.Reflection.CodeReference ---- System.IEquatable<T>, System.Xml.Serialization.IXmlSerializable
Gallio.Reflection.ConstantValue
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Reflection.CodeElementKind
Gallio.Reflection.CodeReferenceKind

See Also

Gallio.Reflection Namespace


Gallio.Reflection.Impl Hierarchy

Gallio.Reflection.Impl Hierarchy
System.Object
Gallio.Reflection.Impl.BaseReflectionPolicy ---- Gallio.Reflection.IReflectionPolicy
Gallio.Reflection.Impl.StaticReflectionPolicy
Gallio.Reflection.Impl.ComDebugSymbolResolver ---- Gallio.Reflection.Impl.IDebugSymbolResolver, System.IDisposable
Gallio.Reflection.Impl.DebugSymbolUtils
Gallio.Reflection.Impl.DefaultXmlDocumentationResolver ---- Gallio.Reflection.Impl.IXmlDocumentationResolver
Gallio.Reflection.Impl.IDebugSymbolResolver ---- System.IDisposable
Gallio.Reflection.Impl.IResolvableTypeInfo ---- Gallio.Reflection.ICodeElementInfo, Gallio.Reflection.IMemberInfo, Gallio.Reflection.ITypeInfo, System.IEquatable<T>
Gallio.Reflection.Impl.IUnresolvedCodeElement
Gallio.Reflection.Impl.IXmlDocumentationResolver
Gallio.Reflection.Impl.MonoDebugSymbolResolver ---- Gallio.Reflection.Impl.IDebugSymbolResolver, System.IDisposable
Gallio.Reflection.Impl.ReflectorAttributeUtils
Gallio.Reflection.Impl.ReflectorFlagsUtils
Gallio.Reflection.Impl.ReflectorResolveUtils
Gallio.Reflection.Impl.ReflectorTypeUtils
Gallio.Reflection.Impl.StaticWrapper ---- System.IEquatable<T>
Gallio.Reflection.Impl.StaticAttributeWrapper ---- Gallio.Reflection.IAttributeInfo
Gallio.Reflection.Impl.StaticCodeElementWrapper ---- Gallio.Reflection.ICodeElementInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticAssemblyWrapper ---- Gallio.Reflection.IAssemblyInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticMemberWrapper ---- Gallio.Reflection.IMemberInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticReflectedMemberWrapper
Gallio.Reflection.Impl.StaticEventWrapper ---- Gallio.Reflection.IEventInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticFieldWrapper ---- Gallio.Reflection.IFieldInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticFunctionWrapper ---- Gallio.Reflection.IFunctionInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticConstructorWrapper ---- Gallio.Reflection.IConstructorInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticMethodWrapper ---- Gallio.Reflection.IMethodInfo
Gallio.Reflection.Impl.StaticPropertyWrapper ---- Gallio.Reflection.IPropertyInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticTypeWrapper ---- Gallio.Reflection.Impl.IResolvableTypeInfo, Gallio.Reflection.ITypeInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticDeclaredTypeWrapper
Gallio.Reflection.Impl.StaticSpecialTypeWrapper
Gallio.Reflection.Impl.StaticConstructedTypeWrapper
Gallio.Reflection.Impl.StaticArrayTypeWrapper
Gallio.Reflection.Impl.StaticByRefTypeWrapper
Gallio.Reflection.Impl.StaticPointerTypeWrapper
Gallio.Reflection.Impl.StaticGenericParameterWrapper ---- Gallio.Reflection.IGenericParameterInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.Impl.StaticParameterWrapper ---- Gallio.Reflection.IParameterInfo, Gallio.Reflection.ISlotInfo, System.IEquatable<T>
Gallio.Reflection.Impl.XmlDocumentationUtils
System.Reflection.MemberInfo ---- System.Reflection.ICustomAttributeProvider
System.Reflection.EventInfo
Gallio.Reflection.Impl.UnresolvedEventInfo ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.Reflection.FieldInfo
Gallio.Reflection.Impl.UnresolvedFieldInfo ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.Reflection.MethodBase
System.Reflection.ConstructorInfo
Gallio.Reflection.Impl.UnresolvedConstructorInfo ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.Reflection.MethodInfo
Gallio.Reflection.Impl.UnresolvedMethodInfo ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.Reflection.PropertyInfo
Gallio.Reflection.Impl.UnresolvedPropertyInfo ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.Type ---- System.Reflection.IReflect
Gallio.Reflection.Impl.UnresolvedType ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.Reflection.ParameterInfo ---- System.Reflection.ICustomAttributeProvider
Gallio.Reflection.Impl.UnresolvedParameterInfo ---- Gallio.Reflection.Impl.IUnresolvedCodeElement
System.ValueType
Gallio.Reflection.Impl.StaticTypeSubstitution ---- System.IEquatable<T>

See Also

Gallio.Reflection.Impl Namespace


Gallio.Reports Hierarchy

Gallio.Reports Hierarchy
System.Object
Gallio.Reports.BaseReportFormatter ---- Gallio.Runner.Reports.IReportFormatter, Gallio.Runtime.IRegisteredComponent
Gallio.Reports.MHtmlReportFormatter
Gallio.Reports.XmlReportFormatter
Gallio.Reports.XsltReportFormatter

See Also

Gallio.Reports Namespace


Gallio.Runner Hierarchy

Gallio.Runner Hierarchy
System.Object
Gallio.Runner.DefaultTestRunner ---- Gallio.Runner.ITestRunner
Gallio.Runner.DefaultTestRunnerFactory ---- Gallio.Runner.ITestRunnerFactory, Gallio.Runtime.IRegisteredComponent
Gallio.Runner.DefaultTestRunnerManager ---- Gallio.Runner.ITestRunnerManager
Gallio.Runner.ITestRunner
Gallio.Runner.ITestRunnerFactory ---- Gallio.Runtime.IRegisteredComponent
Gallio.Runner.ITestRunnerManager
Gallio.Runner.ResultCode
Gallio.Runner.StandardTestRunnerFactoryNames
Gallio.Runner.TestLauncher
Gallio.Runner.TestLauncherResult
Gallio.Runner.TestRunnerOptions
Gallio.Runner.TestRunnerUtils
System.EventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.OperationStartedEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Runner.RunnerException

See Also

Gallio.Runner Namespace


Gallio.Runner.Caching Hierarchy

Gallio.Runner.Caching Hierarchy
System.Object
Gallio.Runner.Caching.IDiskCache
Gallio.Runner.Caching.IDiskCacheGroup
Gallio.Runner.Caching.IDiskCacheGroupCollection
Gallio.Runner.Caching.SimpleDiskCache ---- Gallio.Runner.Caching.IDiskCache, Gallio.Runner.Caching.IDiskCacheGroupCollection
Gallio.Runner.Caching.TemporaryDiskCache
Gallio.Runner.Caching.SimpleDiskCache.Group ---- Gallio.Runner.Caching.IDiskCacheGroup
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Runner.Caching.DiskCacheException

See Also

Gallio.Runner.Caching Namespace


Gallio.Runner.Drivers Hierarchy

Gallio.Runner.Drivers Hierarchy
System.Object
Gallio.Runner.Drivers.HostedTestDriverFactory ---- Gallio.Runner.Drivers.ITestDriverFactory
Gallio.Runner.Drivers.ITestDriver ---- System.IDisposable
Gallio.Runner.Drivers.ITestDriverFactory
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runner.Drivers.BaseTestDriver ---- Gallio.Runner.Drivers.ITestDriver, System.IDisposable
Gallio.Runner.Drivers.AggregateTestDriver
Gallio.Runner.Drivers.HostedTestDriver
Gallio.Runner.Drivers.LocalTestDriver
Gallio.Runner.Drivers.RemoteTestDriver
System.ValueType
Gallio.Runner.Drivers.AggregateTestDriver.Partition

See Also

Gallio.Runner.Drivers Namespace


Gallio.Runner.Events Hierarchy

Gallio.Runner.Events Hierarchy
System.Object
Gallio.Runner.Events.ITestRunnerEvents
Gallio.Runner.Events.TestRunnerEventDispatcher ---- Gallio.Runner.Events.ITestRunnerEvents
System.EventArgs
Gallio.Runner.Events.TestModelAnnotationAddedEventArgs
Gallio.Runner.Events.TestModelSubtreeMergedEventArgs
Gallio.Runner.Events.TestStepEventArgs
Gallio.Runner.Events.TestStepFinishedEventArgs
Gallio.Runner.Events.TestStepLifecyclePhaseChangedEventArgs
Gallio.Runner.Events.TestStepLogAttachEventArgs
Gallio.Runner.Events.TestStepLogStreamEventArgs
Gallio.Runner.Events.TestStepLogStreamBeginMarkerEventArgs
Gallio.Runner.Events.TestStepLogStreamBeginSectionEventArgs
Gallio.Runner.Events.TestStepLogStreamEmbedEventArgs
Gallio.Runner.Events.TestStepLogStreamEndEventArgs
Gallio.Runner.Events.TestStepLogStreamWriteEventArgs
Gallio.Runner.Events.TestStepMetadataAddedEventArgs
Gallio.Runner.Events.TestStepStartedEventArgs
Gallio.Runner.OperationFinishedEventArgs
Gallio.Runner.Events.DisposeFinishedEventArgs
Gallio.Runner.Events.ExploreFinishedEventArgs
Gallio.Runner.Events.InitializeFinishedEventArgs
Gallio.Runner.Events.RunFinishedEventArgs
Gallio.Runner.OperationStartedEventArgs
Gallio.Runner.Events.DisposeStartedEventArgs
Gallio.Runner.Events.ExploreStartedEventArgs
Gallio.Runner.Events.InitializeStartedEventArgs
Gallio.Runner.Events.RunStartedEventArgs

See Also

Gallio.Runner.Events Namespace


Gallio.Runner.Extensions Hierarchy

Gallio.Runner.Extensions Hierarchy
System.Object
Gallio.Runner.Extensions.ITestRunnerExtension
Gallio.Runner.Extensions.TestRunnerExtension ---- Gallio.Runner.Extensions.ITestRunnerExtension
Gallio.Runner.Extensions.DebugExtension
Gallio.Runner.Extensions.LogExtension
Gallio.Runner.Extensions.TestRunnerExtensionUtils

See Also

Gallio.Runner.Extensions Namespace


Gallio.Runner.Harness Hierarchy

Gallio.Runner.Harness Hierarchy
System.Object
Gallio.Runner.Harness.ConsoleTestEnvironment ---- Gallio.Runner.Harness.ITestEnvironment
Gallio.Runner.Harness.DefaultTestHarness ---- Gallio.Runner.Harness.ITestHarness, System.IDisposable
Gallio.Runner.Harness.DefaultTestHarnessFactory ---- Gallio.Runner.Harness.ITestHarnessFactory
Gallio.Runner.Harness.ITestEnvironment
Gallio.Runner.Harness.ITestHarness ---- System.IDisposable
Gallio.Runner.Harness.ITestHarnessFactory
Gallio.Runner.Harness.TraceTestEnvironment ---- Gallio.Runner.Harness.ITestEnvironment
Gallio.Runner.Harness.UnhandledExceptionTestEnvironment ---- Gallio.Runner.Harness.ITestEnvironment
System.MarshalByRefObject
System.Diagnostics.TraceListener ---- System.IDisposable
Gallio.Runner.Harness.ContextualLogTraceListener
System.IO.TextWriter ---- System.IDisposable
Gallio.Runner.Harness.ContextualLogTextWriter

See Also

Gallio.Runner.Harness Namespace


Gallio.Runner.Projects Hierarchy

Gallio.Runner.Projects Hierarchy
System.Object
Gallio.Runner.Projects.FilterInfo
Gallio.Runner.Projects.Project
Gallio.Runner.Projects.ProjectUtils

See Also

Gallio.Runner.Projects Namespace


Gallio.Runner.Reports Hierarchy

Gallio.Runner.Reports Hierarchy
System.Object
Gallio.Runner.Reports.DefaultReportManager ---- Gallio.Runner.Reports.IReportManager
Gallio.Runner.Reports.DefaultReportReader ---- Gallio.Runner.Reports.IReportReader
Gallio.Runner.Reports.DefaultReportWriter ---- Gallio.Runner.Reports.IReportWriter
Gallio.Runner.Reports.FileSystemReportContainer ---- Gallio.Runner.Reports.IReportContainer
Gallio.Runner.Reports.IReportContainer
Gallio.Runner.Reports.IReportFormatter ---- Gallio.Runtime.IRegisteredComponent
Gallio.Runner.Reports.IReportManager
Gallio.Runner.Reports.IReportReader
Gallio.Runner.Reports.IReportWriter
Gallio.Runner.Reports.LogEntry
Gallio.Runner.Reports.Report
Gallio.Runner.Reports.ReportContainerUtils
Gallio.Runner.Reports.ReportFormatterOptions
Gallio.Runner.Reports.Statistics
Gallio.Runner.Reports.TestOutcomeSummary
Gallio.Runner.Reports.TestPackageRun
Gallio.Runner.Reports.TestStepRun

See Also

Gallio.Runner.Reports Namespace


Gallio.Runtime Hierarchy

Gallio.Runtime Hierarchy
System.Object
Gallio.Runtime.GallioSectionHandler ---- System.Configuration.IConfigurationSectionHandler
Gallio.Runtime.InstallationConfiguration
Gallio.Runtime.IRegisteredComponent
Gallio.Runtime.IRegisteredComponentResolver<T>
Gallio.Runtime.IRuntime ---- System.IDisposable
Gallio.Runtime.ProcessTypeDetection
Gallio.Runtime.RuntimeAccessor
Gallio.Runtime.RuntimeBootstrap
Gallio.Runtime.RuntimeDetection
Gallio.Runtime.RuntimeRegisteredComponentResolver<T> ---- Gallio.Runtime.IRegisteredComponentResolver<T>
Gallio.Runtime.RuntimeSetup
Gallio.Runtime.UnhandledExceptionPolicy
System.EventArgs
Gallio.Runtime.CorrelatedExceptionEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Runtime.RuntimeException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Runtime.ProcessType
Gallio.Runtime.RuntimeVersion

See Also

Gallio.Runtime Namespace


Gallio.Runtime.ConsoleSupport Hierarchy

Gallio.Runtime.ConsoleSupport Hierarchy
System.Object
Gallio.Runtime.ConsoleSupport.CommandLineArgumentParser
Gallio.Runtime.ConsoleSupport.CommandLineOutput
Gallio.Runtime.ConsoleSupport.ConsoleProgram<TArguments> ---- System.IDisposable
Gallio.Runtime.ConsoleSupport.IRichConsole
Gallio.Runtime.ConsoleSupport.NativeConsole ---- Gallio.Runtime.ConsoleSupport.IRichConsole
Gallio.Runtime.Logging.BaseLogger ---- Gallio.Runtime.Logging.ILogger
Gallio.Runtime.ConsoleSupport.RichConsoleLogger
System.Attribute
Gallio.Runtime.ConsoleSupport.CommandLineArgumentAttribute
Gallio.Runtime.ConsoleSupport.DefaultCommandLineArgumentAttribute
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Gallio.Runtime.ConsoleSupport.CommandLineErrorReporter
Gallio.Runtime.ConsoleSupport.ResponseFileReader
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Runtime.ConsoleSupport.CommandLineArgumentFlags

See Also

Gallio.Runtime.ConsoleSupport Namespace


Gallio.Runtime.Debugging Hierarchy

Gallio.Runtime.Debugging Hierarchy
System.Object
Gallio.Runtime.Debugging.DefaultDebuggerManager ---- Gallio.Runtime.Debugging.IDebuggerManager
Gallio.Runtime.Debugging.IDebugger
Gallio.Runtime.Debugging.IDebuggerManager
Gallio.Runtime.Debugging.NullDebugger ---- Gallio.Runtime.Debugging.IDebugger
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Runtime.Debugging.AttachDebuggerResult
Gallio.Runtime.Debugging.DetachDebuggerResult

See Also

Gallio.Runtime.Debugging Namespace


Gallio.Runtime.Hosting Hierarchy

Gallio.Runtime.Hosting Hierarchy
System.Object
Gallio.Runtime.Hosting.AppDomainUtils
Gallio.Runtime.Hosting.BaseHost ---- Gallio.Runtime.Hosting.IHost, System.IDisposable
Gallio.Runtime.Hosting.LocalHost
Gallio.Runtime.Hosting.RemoteHost
Gallio.Runtime.Hosting.IsolatedAppDomainHost
Gallio.Runtime.Hosting.IsolatedProcessHost
Gallio.Runtime.Hosting.BaseHostFactory ---- Gallio.Runtime.Hosting.IHostFactory
Gallio.Runtime.Hosting.IsolatedAppDomainHostFactory
Gallio.Runtime.Hosting.IsolatedProcessHostFactory
Gallio.Runtime.Hosting.LocalHostFactory
Gallio.Runtime.Hosting.HostAssemblyResolverHook
Gallio.Runtime.Hosting.HostConfiguration ---- System.IEquatable<T>
Gallio.Runtime.Hosting.HostConfiguration.AssemblyBindingRedirect ---- System.IEquatable<T>
Gallio.Runtime.Hosting.HostConfiguration.AssemblyCodeBase ---- System.IEquatable<T>
Gallio.Runtime.Hosting.HostConfiguration.AssemblyDependency ---- System.IEquatable<T>
Gallio.Runtime.Hosting.HostConfiguration.AssemblyQualification ---- System.IEquatable<T>
Gallio.Runtime.Hosting.HostServiceChannelInterop
Gallio.Runtime.Hosting.HostSetup ---- System.IEquatable<T>
Gallio.Runtime.Hosting.HostUtils
Gallio.Runtime.Hosting.IHost ---- System.IDisposable
Gallio.Runtime.Hosting.IHostFactory
Gallio.Runtime.Hosting.IHostService
Gallio.Runtime.Hosting.IRemoteHostService ---- Gallio.Runtime.Hosting.IHostService
System.Exception ---- System.Runtime.Serialization.ISerializable
Gallio.Runtime.Hosting.HostException
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject
Gallio.Runtime.Hosting.BaseHostService ---- Gallio.Runtime.Hosting.IHostService, System.IDisposable
Gallio.Runtime.Hosting.RemoteHostService ---- Gallio.Runtime.Hosting.IRemoteHostService
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Runtime.Hosting.ConfigurationFileLocation

See Also

Gallio.Runtime.Hosting Namespace


Gallio.Runtime.Loader Hierarchy

Gallio.Runtime.Loader Hierarchy
System.Object
Gallio.Runtime.Loader.AssemblyResolverBootstrap
Gallio.Runtime.Loader.DefaultAssemblyResolverManager ---- Gallio.Runtime.Loader.IAssemblyResolverManager, System.IDisposable
Gallio.Runtime.Loader.DefaultLoader ---- Gallio.Runtime.Loader.ILoader
Gallio.Runtime.Loader.IAssemblyResolver
Gallio.Runtime.Loader.IAssemblyResolverManager ---- System.IDisposable
Gallio.Runtime.Loader.ILoader

See Also

Gallio.Runtime.Loader Namespace


Gallio.Runtime.Logging Hierarchy

Gallio.Runtime.Logging Hierarchy
System.Object
Gallio.Runtime.Logging.BaseLogger ---- Gallio.Runtime.Logging.ILogger
Gallio.Runtime.Logging.EventLogger
Gallio.Runtime.Logging.FilteredLogger
Gallio.Runtime.Logging.NullLogger
Gallio.Runtime.Logging.RemoteLogger
Gallio.Runtime.Logging.SeverityPrefixLogger
Gallio.Runtime.Logging.TextLogger
Gallio.Runtime.Logging.ILogger
Gallio.Runtime.Logging.SeverityPrefixParser
System.EventArgs
Gallio.Runtime.Logging.LogMessageEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Gallio.Runtime.Logging.LogSeverity

See Also

Gallio.Runtime.Logging Namespace


Gallio.Runtime.ProgressMonitoring Hierarchy

Gallio.Runtime.ProgressMonitoring Hierarchy
System.Object
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorPresenter ---- Gallio.Runtime.ProgressMonitoring.IProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.LogProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.RichConsoleProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.BaseProgressMonitorProvider ---- Gallio.Runtime.ProgressMonitoring.IProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.LogProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.NullProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.RichConsoleProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.CancelableProgressMonitor ---- Gallio.Runtime.ProgressMonitoring.IProgressMonitor, System.IDisposable
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor
Gallio.Runtime.ProgressMonitoring.ObservableProgressMonitor.SubProgressMonitor
Gallio.Runtime.ProgressMonitoring.RemoteProgressMonitor ---- System.Runtime.Serialization.IDeserializationCallback
Gallio.Runtime.ProgressMonitoring.IProgressMonitor ---- System.IDisposable
Gallio.Runtime.ProgressMonitoring.IProgressMonitorPresenter
Gallio.Runtime.ProgressMonitoring.IProgressMonitorProvider
Gallio.Runtime.ProgressMonitoring.NullProgressMonitor
Gallio.Runtime.ProgressMonitoring.NullProgressMonitorPresenter ---- Gallio.Runtime.ProgressMonitoring.IProgressMonitorPresenter
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Gallio.Runtime.ProgressMonitoring.TaskWithProgress
System.EventArgs
Gallio.Runtime.ProgressMonitoring.SubProgressMonitorCreatedEventArgs
System.ValueType
Gallio.Runtime.ProgressMonitoring.ProgressMonitorTaskCookie ---- System.IDisposable

See Also

Gallio.Runtime.ProgressMonitoring Namespace


Gallio.Runtime.Remoting Hierarchy

Gallio.Runtime.Remoting Hierarchy
System.Object
Gallio.Runtime.Remoting.BaseChannel ---- System.IDisposable
Gallio.Runtime.Remoting.BaseClientChannel ---- Gallio.Runtime.Remoting.IClientChannel
Gallio.Runtime.Remoting.BinaryIpcClientChannel
Gallio.Runtime.Remoting.BinaryTcpClientChannel
Gallio.Runtime.Remoting.BaseServerChannel ---- Gallio.Runtime.Remoting.IServerChannel
Gallio.Runtime.Remoting.BinaryIpcServerChannel
Gallio.Runtime.Remoting.BinaryTcpServerChannel
Gallio.Runtime.Remoting.IClientChannel ---- System.IDisposable
Gallio.Runtime.Remoting.IServerChannel ---- System.IDisposable
System.MarshalByRefObject
Gallio.Runtime.Remoting.LongLivedMarshalByRefObject

See Also

Gallio.Runtime.Remoting Namespace


Gallio.Runtime.Windsor Hierarchy

Gallio.Runtime.Windsor Hierarchy
System.Object
Gallio.Runtime.Windsor.WindsorRuntime ---- Gallio.Runtime.IRuntime, System.IDisposable

See Also

Gallio.Runtime.Windsor Namespace


Gallio.UI Hierarchy

Gallio.UI Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl ---- System.Windows.Forms.IContainerControl
System.Windows.Forms.UserControl
Gallio.UI.TestStepRunViewer

See Also

Gallio.UI Namespace


Gallio.Utilities Hierarchy

Gallio.Utilities Hierarchy
System.Object
Gallio.Utilities.CurrentDirectorySwitcher ---- System.IDisposable
Gallio.Utilities.DefaultXmlSerializer ---- Gallio.Utilities.IXmlSerializer
Gallio.Utilities.EventHandlerUtils
Gallio.Utilities.ExceptionUtils
Gallio.Utilities.FileSystem ---- Gallio.Utilities.IFileSystem
Gallio.Utilities.FileUtils
Gallio.Utilities.IFileSystem
Gallio.Utilities.IXmlSerializer
Gallio.Utilities.StringUtils
Gallio.Utilities.Sync
Gallio.Utilities.XmlSerializationUtils
Gallio.Utilities.XmlUtils
System.ValueType
Gallio.Utilities.Hash64 ---- System.IEquatable<T>
Gallio.Utilities.KeyedMemoizer<TKey,TValue>
Gallio.Utilities.Memoizer<T>

See Also

Gallio.Utilities Namespace


MbUnit.Core Hierarchy

MbUnit.Core Hierarchy
System.Object
Gallio.Framework.Pattern.BasePatternTestFrameworkExtension ---- Gallio.Framework.Pattern.IPatternTestFrameworkExtension
MbUnit.Core.MbUnitTestFrameworkExtension

See Also

MbUnit.Core Namespace


MbUnit.Framework Hierarchy

MbUnit.Framework Hierarchy
System.Object
MbUnit.Framework.Assert
MbUnit.Framework.AssertEx
MbUnit.Framework.AssertOverSyntax
MbUnit.Framework.OldArrayAssert
MbUnit.Framework.OldAssert
MbUnit.Framework.OldCollectionAssert
MbUnit.Framework.OldFileAssert
MbUnit.Framework.OldGenericAssert
MbUnit.Framework.OldReflectionAssert
MbUnit.Framework.OldSecurityAssert
MbUnit.Framework.OldStringAssert
MbUnit.Framework.OldXmlAssert
MbUnit.Framework.Test
MbUnit.Framework.TestDefinition
MbUnit.Framework.TestCase
MbUnit.Framework.TestSuite
MbUnit.Framework.TestFixtureReference
System.Attribute
Gallio.Framework.Pattern.PatternAttribute ---- Gallio.Framework.Pattern.IPattern
Gallio.Framework.Pattern.AnnotationPatternAttribute
MbUnit.Framework.AnnotationAttribute
Gallio.Framework.Pattern.DecoratorPatternAttribute
Gallio.Framework.Pattern.ContributionMethodPatternAttribute
MbUnit.Framework.FixtureInitializerAttribute
MbUnit.Framework.FixtureSetUpAttribute
MbUnit.Framework.TestFixtureSetUpAttribute
MbUnit.Framework.FixtureTearDownAttribute
MbUnit.Framework.TestFixtureTearDownAttribute
MbUnit.Framework.SetUpAttribute
MbUnit.Framework.StaticTestFactoryAttribute
MbUnit.Framework.TearDownAttribute
Gallio.Framework.Pattern.DataPatternAttribute
MbUnit.Framework.ContentAttribute
MbUnit.Framework.CsvDataAttribute
MbUnit.Framework.XmlDataAttribute
MbUnit.Framework.DataAttribute
MbUnit.Framework.ColumnAttribute
MbUnit.Framework.RowAttribute
MbUnit.Framework.FactoryAttribute
MbUnit.Framework.HeaderAttribute
Gallio.Framework.Pattern.TestAssemblyDecoratorPatternAttribute
MbUnit.Framework.DefaultTestCaseTimeoutAttribute
MbUnit.Framework.DegreeOfParallelismAttribute
Gallio.Framework.Pattern.TestDecoratorPatternAttribute
MbUnit.Framework.ApartmentStateAttribute
MbUnit.Framework.ExplicitAttribute
MbUnit.Framework.IgnoreAttribute
MbUnit.Framework.ParallelizableAttribute
MbUnit.Framework.PendingAttribute
MbUnit.Framework.RepeatAttribute
MbUnit.Framework.RollbackAttribute
MbUnit.Framework.TestDecoratorAttribute
MbUnit.Framework.ThreadedRepeatAttribute
MbUnit.Framework.TimeoutAttribute
Gallio.Framework.Pattern.TestMethodDecoratorPatternAttribute
MbUnit.Framework.ExpectedExceptionAttribute
MbUnit.Framework.ExpectedArgumentExceptionAttribute
MbUnit.Framework.ExpectedArgumentNullExceptionAttribute
MbUnit.Framework.ExpectedArgumentOutOfRangeExceptionAttribute
MbUnit.Framework.MultipleAssertsAttribute
Gallio.Framework.Pattern.TestParameterDecoratorPatternAttribute
MbUnit.Framework.BindAttribute
Gallio.Framework.Pattern.MetadataPatternAttribute
MbUnit.Framework.AuthorAttribute
MbUnit.Framework.CategoryAttribute
MbUnit.Framework.DescriptionAttribute
MbUnit.Framework.ImportanceAttribute
MbUnit.Framework.MetadataAttribute
MbUnit.Framework.TestsOnAttribute
Gallio.Framework.Pattern.TestDependencyPatternAttribute
MbUnit.Framework.DependsOnAttribute
Gallio.Framework.Pattern.TestMethodPatternAttribute
MbUnit.Framework.DynamicTestFactoryAttribute
MbUnit.Framework.TestAttribute
MbUnit.Framework.RowTestAttribute
Gallio.Framework.Pattern.TestParameterPatternAttribute
MbUnit.Framework.ParameterAttribute
Gallio.Framework.Pattern.TestTypePatternAttribute
MbUnit.Framework.AssemblyFixtureAttribute
MbUnit.Framework.TestFixtureAttribute
MbUnit.Framework.JoinAttribute
MbUnit.Framework.CombinatorialJoinAttribute
MbUnit.Framework.PairwiseJoinAttribute
MbUnit.Framework.SequentialJoinAttribute
MbUnit.Framework.NameAttribute
Gallio.Framework.Pattern.TestAssemblyInitializationAttribute
MbUnit.Framework.AssemblyResolverAttribute
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MbUnit.Framework.Importance
MbUnit.Framework.TestScope

See Also

MbUnit.Framework Namespace


MbUnit.Framework.ContractVerifiers Hierarchy

MbUnit.Framework.ContractVerifiers Hierarchy
System.Object
MbUnit.Framework.ContractVerifiers.AbstractContract ---- MbUnit.Framework.ContractVerifiers.IContract
MbUnit.Framework.ContractVerifiers.CollectionContract<TCollection,TItem>
MbUnit.Framework.ContractVerifiers.ListContract<TList,TItem>
MbUnit.Framework.ContractVerifiers.ComparisonContract<TTarget>
MbUnit.Framework.ContractVerifiers.EqualityContract<TTarget>
MbUnit.Framework.ContractVerifiers.ExceptionContract<TException>
MbUnit.Framework.ContractVerifiers.ImmutabilityContract<TTarget>
MbUnit.Framework.ContractVerifiers.DistinctInstanceCollection<T> ---- System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
MbUnit.Framework.ContractVerifiers.EquivalenceClass<T> ---- System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
MbUnit.Framework.ContractVerifiers.EquivalenceClassCollection<T> ---- System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
MbUnit.Framework.ContractVerifiers.IContract
System.Attribute
Gallio.Framework.Pattern.PatternAttribute ---- Gallio.Framework.Pattern.IPattern
MbUnit.Framework.ContractVerifiers.VerifyContractAttribute

See Also

MbUnit.Framework.ContractVerifiers Namespace


MbUnit.Framework.ContractVerifiers.Core Hierarchy

MbUnit.Framework.ContractVerifiers.Core Hierarchy
System.Object
MbUnit.Framework.ContractVerifiers.Core.ContractVerificationContext

See Also

MbUnit.Framework.ContractVerifiers.Core Namespace


MbUnit.Framework.Reflection Hierarchy

MbUnit.Framework.Reflection Hierarchy
System.Object
MbUnit.Framework.Reflection.Reflector
System.Exception ---- System.Runtime.Serialization.ISerializable
MbUnit.Framework.Reflection.ReflectionException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MbUnit.Framework.Reflection.AccessModifier
MbUnit.Framework.Reflection.MemberType

See Also

MbUnit.Framework.Reflection Namespace


MbUnit.Framework.Xml Hierarchy

MbUnit.Framework.Xml Hierarchy
System.Object
MbUnit.Framework.Xml.DiffConfiguration
MbUnit.Framework.Xml.Difference
MbUnit.Framework.Xml.Differences
MbUnit.Framework.Xml.DiffResult
MbUnit.Framework.Xml.Validator
MbUnit.Framework.Xml.XmlDiff
MbUnit.Framework.Xml.XmlInput
MbUnit.Framework.Xml.XmlOutput
MbUnit.Framework.Xml.XPath
MbUnit.Framework.Xml.Xslt
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
MbUnit.Framework.Xml.DifferenceType

See Also

MbUnit.Framework.Xml Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace


BaseDataSet Class Hierarchy

BaseDataSet Hierarchy

The following table lists the types derived from BaseDataSet .

Derived Types

Type | Description
AggregateDataSet | Abstract base class for an aggregate data set that combines a list of data sets according to some algorithm. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
CsvDataSet

A CSV data set retrieves fields from a CSV document as strings.

If the CSV document has a header, then it is interpreted as the names of the columns. Columns with names in brackets, such as "[ExpectedException]", are interpreted as containing metadata values associated with the named key.

FactoryDataSet

A factory data set generates data items by invoking a factory delegate and interpreting its output in accordance with the factory kind.

Multiple different interpretations are supported. Refer to the documentation of the FactoryKind enumeration for more details about each kind.

ItemSequenceDataSet | A data set constructed from a sequence of data items. This class cannot be inherited.
ValueSequenceDataSet | A data set constructed from an enumerated sequence of values. This class cannot be inherited.
XmlDataSet | An XML data set selects nodes from an XML document using XPath expressions. The selected nodes are returned as XPathNavigator objects.

See Also

BaseDataSet Class
Gallio.Framework.Data Namespace


ContributionMethodPatternAttribute Class Hierarchy

ContributionMethodPatternAttribute Hierarchy

The following table lists the types derived from ContributionMethodPatternAttribute .

Derived Types

Type | Description
FixtureInitializerAttribute | Specifies a method that is to be invoked after a fixture instance has been created to complete its initialization before test fixture setup runs.
FixtureSetUpAttribute | Specifies a method that is to be invoked to set up the state of a fixture before any of its tests are executed.
FixtureTearDownAttribute | Specifies a method that is to be invoked to tear down the state of a fixture after all of its tests have been executed.
SetUpAttribute | Specifies a method that is to be invoked before each test in a fixture executes to set up the state of the test. The method will run once for each test. This class cannot be inherited.
StaticTestFactoryAttribute | Specifies a method that is used to generate tests statically at test exploration time.
TearDownAttribute | Specifies a method that is to be invoked after each test in a fixture executes to tear down the state of the test. The method will run once for each test. This class cannot be inherited.

See Also

ContributionMethodPatternAttribute Class
Gallio.Framework.Pattern Namespace


DecoratorPatternAttribute Class Hierarchy

DecoratorPatternAttribute Hierarchy

The following table lists the types derived from DecoratorPatternAttribute .

Derived Types

Type | Description
ContributionMethodPatternAttribute | A contribution method pattern attribute applies decorations to a containing scope such as by introducing a new setup or teardown action to a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
DataPatternAttribute

The data pattern attribute applies a data source to a fixture or test parameter declaratively. It can be attached to a fixture class, a public property or field of a fixture, a test method or a test method parameter. When attached to a property or field of a fixture, implies that the property or field is a fixture parameter (so the TestParameterPatternAttribute may be omitted).

The order in which items contributed by a data pattern attribute are use can be controlled via the Order property. The contents of data sets with lower order indices are processed before those with higher indices.

Copy Code
            // Ensures that the rows are processed in exactly the order they appear.
            [Test]
            [Row(1, "a"), Order=1)]
            [Row(2, "b"), Order=2)]
            [Row(3, "c"), Order=3)]
            public void Test(int x, string y) { ... }
This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestAssemblyDecoratorPatternAttribute | A test assembly decorator pattern attribute applies decorations to an existing test declared at the assembly-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestDecoratorPatternAttribute | A test decorator pattern attribute applies decorations to a test defined by an assembly, type, or method. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestMethodDecoratorPatternAttribute | A test decorator pattern attribute applies decorations to an existing test declared at the method-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestParameterDecoratorPatternAttribute | A test parameter decorator pattern attribute applies decorations to an existing PatternTestParameter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestTypeDecoratorPatternAttribute | A test type decorator pattern attribute applies decorations to an existing test declared at the type-level. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

See Also

DecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace


MetadataPatternAttribute Class Hierarchy

MetadataPatternAttribute Hierarchy

The following table lists the types derived from MetadataPatternAttribute .

Derived Types

Type | Description
AuthorAttribute | Associates the author's name and email address with a test fixture, test method, test parameter or other test component.
CategoryAttribute | Associates a category name with a test fixture, test method, test parameter or other test component. The category name can be used to classify tests and build test suites of related tests.
DescriptionAttribute | Associates a description with a test fixture, test method, test parameter or other test component.
ImportanceAttribute | Associates a Importance with a test fixture, test method, test parameter or other test component.
MetadataAttribute | Associates custom metadata with a test fixture, test method, test parameter or other test component. The metadata can be used for documentation, classification or dynamic customization of tests.
TestsOnAttribute | Associates the name of the type under test with a test fixture, test method, test parameter or other test component.

See Also

MetadataPatternAttribute Class
Gallio.Framework.Pattern Namespace


PatternAttribute Class Hierarchy

PatternAttribute Hierarchy

The following table lists the types derived from PatternAttribute .

Derived Types

Type | Description
AnnotationPatternAttribute

Associates an annotation message with a code element. When the code element is processed as part of building some other test, the annotation message will be emitted. This may be used to signal error, warning, and informational messages associated with the code element in question.

Many annotations are automatically generated by the framework. For example, improperly used attributes generally cause error annotations to be emitted. This attribute provides an easy way for test authors to leverage the annotation mechanism for other discretionary purposes where it is desirable to draw attention to a particular code element.

Note that the annotation will only be emitted if it is encountered during the process of building a test. If for some reason the annotated code element is not processed, then the attribute will have no effect.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
DecoratorPatternAttribute

A decorator attribute applies contributions to a test component in scope such as a test or test parameter generated by some other pattern attribute.

Occasionally the order in which decorators are applied is significant so this type provides a Order property to specify an explicit ordering when required. All decorators that apply to a given test component declaration are applied in increasing Order.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
MetadataPatternAttribute

Applies declarative metadata to a test component.

A metadata attribute is similar to a decorator but more restrictive. Metadata does not modify the structure of a test directly. Instead it introduces additional metadata key / value pairs for classification, filtering, reporting, documentation or other purposes.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestAssemblyPatternAttribute

Declares that an assembly generates an assembly-level test. Subclasses of this attribute can customize how test enumeration takes place within the assembly.

At most one attribute of this type may appear on any given assembly.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestConstructorPatternAttribute

Declares that a constructor is used to provide test fixture parameters. Subclasses of this attribute can control what happens with the constructor.

At most one attribute of this type may appear on any given constructor.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestDependencyPatternAttribute | A dependency pattern attribute creates a dependency on the tests defined by some other code element. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestMethodPatternAttribute | Declares that a method represents a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestParameterPatternAttribute

Declares that a field, property, method parameter or generic parameter represents a PatternTestParameter. Subclasses of this attribute can control what happens with the parameter.

At most one attribute of this type may appear on any given property, field or parameter declaration.

This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestTypePatternAttribute | Declares that a type represents an test.
VerifyContractAttribute | Verifies that a contract has been satisfied. The contract is described by a value assigned to a field of the test fixture.
JoinAttribute | An abstract class for attributes that specify the join strategy of a test. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
NameAttribute | Overrides the name of a test or test parameter.

See Also

PatternAttribute Class
Gallio.Framework.Pattern Namespace
IPattern
PatternTestFramework


TestDecoratorPatternAttribute Class Hierarchy

TestDecoratorPatternAttribute Hierarchy

The following table lists the types derived from TestDecoratorPatternAttribute .

Derived Types

Type | Description
ApartmentStateAttribute | Sets the apartment state to be used to run the decorated test and its children unless subsequently overridden.
ExplicitAttribute | Indicates that a test should only be run explicitly. The test will still appear in the test tree but it will not run and it will not appear in the test results unless it is explicitly selected for execution.
IgnoreAttribute | Indicates that a test is to be ignored by the framework and will not be run. The test will still appear in test reports along with the reason that it was ignored, if provided.
ParallelizableAttribute | Specifies that a test can be run in parallel with other parallelizable tests.
PendingAttribute | Indicates that a test has pending prerequisites so it will not be run. The test will still appear in test reports along with an explanation of the reason it it pending, if provided.
RepeatAttribute | Decorates a test method and causes it to be invoked repeatedly.
RollbackAttribute | Decorates a test method whose database operation must be executed within a transaction and rolled back when it has finished executing.
TestDecoratorAttribute | An abstract base class for implementing new test decorator behaviors. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
ThreadedRepeatAttribute | Decorates a test method and causes it to be invoked repeatedly on multiple concurrent threads.
TimeoutAttribute | Sets the maximum amount of time in seconds that a test or fixture is permitted to run.

See Also

TestDecoratorPatternAttribute Class
Gallio.Framework.Pattern Namespace
TestTypePatternAttribute


Filter Generic Class Hierarchy

Filter<T> Hierarchy

The following table lists the types derived from Filter .

Derived Types

Type | Description
AndFilter | A filter combinator that matches a value when all of its constituent filters match the value.
AnyFilter | A filter that matches anything and always returns true.
EqualityFilter | An equality filter compares values for strict equality. This class cannot be inherited.
NoneFilter | A filter that matches nothing and always returns false.
NotFilter | A filter combinator that is the negation of another filter.
OrFilter | A filter combinator that matches a value when at least one of its constituent filters matches the value.
PropertyFilter | Abstract base class for filters that encapsulate a rule for selecting some property of an object to be compared against a string value filter. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
RegexFilter | A regex filter matches strings against a given Regex. Null string values are converted to empty strings for regex evaluation purposes. This class cannot be inherited.

See Also

Filter<T> Class
Gallio.Model.Filters Namespace


PropertyFilter Generic Class Hierarchy

PropertyFilter<T> Hierarchy

The following table lists the types derived from PropertyFilter .

Derived Types

Type | Description
AssemblyFilter | A filter that matches objects whose CodeElement matches the specified assembly name filter.
IdFilter | A filter that matches objects whose Id matches the specified id filter.
MemberFilter | A filter that matches objects whose CodeElement matches the specified member name filter. This filter should normally be used together with a TypeFilter to ensure the accuracy of the member match.
MetadataFilter | A filter that matches objects whose Metadata has a key with a value that matches the value filter.
NameFilter | A filter that matches objects whose Name matches the specified name filter.
NamespaceFilter | A filter that matches objects whose CodeElement matches the specified namespace name.
TypeFilter | A filter that matches objects whose CodeElement matches the specified type name.

See Also

PropertyFilter<T> Class
Gallio.Model.Filters Namespace


ICodeElementInfo Interface Hierarchy

ICodeElementInfo Hierarchy

The following table lists the types derived from ICodeElementInfo .

Derived Types

Type | Description
IAssemblyInfo

A Assembly reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IConstructorInfo

A ConstructorInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IEventInfo

A EventInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IFieldInfo

A FieldInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IFunctionInfo

A MethodBase reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IGenericParameterInfo

A Type reflection wrapper for generic parameters. The parameter is presented as if it were a slot the accepted a value of type Type.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IMemberInfo

A MemberInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IMethodInfo

A MethodInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IResolvableTypeInfo | This extension of ITypeInfo is provided to enable the resolution of a type with ResolveType.
INamespaceInfo

A namespace reflection wrapper identified by its name.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IParameterInfo

A ParameterInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IPropertyInfo

A PropertyInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

ISlotInfo | A slot represents a field, property or parameter. It is used to simplify the handling of data binding since all three of these types are similar in that they can hold values of some type.
ITypeInfo

A Type reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

See Also

ICodeElementInfo Interface
Gallio.Reflection Namespace
Reflector


IMemberInfo Interface Hierarchy

IMemberInfo Hierarchy

The following table lists the types derived from IMemberInfo .

Derived Types

Type | Description
IConstructorInfo

A ConstructorInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IEventInfo

A EventInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IFieldInfo

A FieldInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IFunctionInfo

A MethodBase reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IGenericParameterInfo

A Type reflection wrapper for generic parameters. The parameter is presented as if it were a slot the accepted a value of type Type.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IMethodInfo

A MethodInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

IResolvableTypeInfo | This extension of ITypeInfo is provided to enable the resolution of a type with ResolveType.
IPropertyInfo

A PropertyInfo reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

ITypeInfo

A Type reflection wrapper.

This wrapper enables reflection-based algorithms to be used against code that may or may not be loaded into the current AppDomain. For example, the target of the wrapper could be an in-memory code model representation.

See Also

IMemberInfo Interface
Gallio.Reflection Namespace


TestStepEventArgs Class Hierarchy

TestStepEventArgs Hierarchy

The following table lists the types derived from TestStepEventArgs .

Derived Types

Type | Description
TestStepFinishedEventArgs | Arguments for an event raised to indicate that a test step has finished execution. This class cannot be inherited.
TestStepLifecyclePhaseChangedEventArgs | Arguments for an event raised to indicate that a test step has entered a new lifecycle phase. This class cannot be inherited.
TestStepLogAttachEventArgs | Arguments for an event raised to indicate that an attachment has been added to a test step log. This class cannot be inherited.
TestStepLogStreamEventArgs | Base arguments for an event raised to indicate that a test step log stream has been modified in some way. This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
TestStepMetadataAddedEventArgs | Arguments for an event raised to indicate that a test step dynamically added metadata to itself. This class cannot be inherited.
TestStepStartedEventArgs | Arguments for an event raised to indicate that a test step has started execution. This class cannot be inherited.

See Also

TestStepEventArgs Class
Gallio.Runner.Events Namespace


BaseLogger Class Hierarchy

BaseLogger Hierarchy

The following table lists the types derived from BaseLogger .

Derived Types

Type | Description
TestLogStreamLogger | A ILogger implementation that logs messages to the specified TestLogStreamWriter. This can be used to write log messages to the test execution log. This class cannot be inherited.
RichConsoleLogger | A logger that sends all output to the console and displays messages in color according to their status.
EventLogger | A logger that dispatches log messages via events.
FilteredLogger | Filters another logger to exclude messages below a given level of severity.
NullLogger | A null implementation of ILogger that does nothing. This class cannot be inherited.
RemoteLogger | Wraps a logger so that it can be accessed remotely.
SeverityPrefixLogger | The severity prefix logger wraps another loggers and encodes the severity of a log entry into the log message itself in a standard form.
TextLogger | A logger that writes output to a TextWriter.

See Also

BaseLogger Class
Gallio.Runtime.Logging Namespace